%%ItemTitle%%

PDF4NET

PDF enable Your .NET application
Create, edit, fill, merge, split and encrypt PDF files from your .Net application.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Getting Started
This section of the documentation helps you get started with PDF4NET application development.

In this section

Overview

Covers the features of PDF4NET class library.

System Requirements

Provides information about the PDF4NET's system requirements.

Installation

Provides information regarding the installation of PDF4NET product.

Licensing

Provides information regarding the licensing modes of PDF4NET product.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Overview
PDF4NET is a .NET library for generating PDF documents on the fly from any .NET application. The library does not rely on any Adobe products for creating pdf files. It hides the complex structure of PDF files behind a simple object model that allows creation of complex pdf files with a few lines of code. The PDF4NET library follows the GDI+ model, thus reducing the learning time and increasing productivity. It uses a grid based layout approach allowing precise positioning of content on document's pages. The library also creates and fills PDF e-forms and merges or splits PDF documents.
The final PDF file is compressed, making the library appropriate for web applications. The library can be used both from WinForms and WebForms (ASP.NET) applications without any restrictions. Also, the same package includes a Compact .NET Framework edition of the library. The library is written entirely in C#, being 100% managed.
The PDF4NET library is licensed per developer and can be distributed ROYALTY FREE, reducing project costs.

Here is the classic “Hello world” example:

…
PDFDocument doc = new PDFDocument( );
PDFPage page = doc.AddPage( );
page.Canvas.DrawText( “Hello world”, new PDFFont( PDFFontFace.Helvetica, 12 ),
     new PDFPen( PDFRgbColor( 255, 0, 0 ), 1 ),
     new PDFBrush( new PDFRgbColor( 0, 0, 255 ) ), 10, 20 );
doc.Save( “helloworld.pdf” );
// or
// Response.ContentType = "application/pdf";
// doc.Save( Response.OutputStream ); // for ASP.NET apps
…

The example above creates a PDF file with on page, and draws the string “Hello World” on the page. The used font is Helvetica, and its size is 12. The drawn string is stroked with red color and filled with blue. The text is positioned at 10 points from left margin and at 20 points from top margin of the page (see the Hello World sample).

Features

The main features of PDF4NET library are outlined below:

 | Standard .NET Framework Edition | Compact .NET Framework Edition
PDF Document Features
Partial document load |  |
Digitally sign the document |  |
Document information |  |
XMP Metadata |  |
Custom document properties |  |
Compressed document content |  |
Save to file/stream |  |
Save document page by page, or page fragment by page fragment |  |
PDF/A - Save document using PDF/A-1b, PDF/A-2b/u or PDF/A-3b/u formats |  |
Incremental updates |  |
Automatic page numbering |  |
Import of damaged PDF files (some of them) |  |
PDF portfolios |  |
XDP packages |  |
Add/Edit/Remove document attachments |  |
Add/Edit/Remove document level JavaScript |  |
Extract text from PDF files |  |
Extract images from PDF files |  |
Extract content as a sequence of graphic operators |  |
PDF Editing Features
Add new content/pages to existing pdf files |  |
Merge multiple pdf files to disk or to stream |  |
Split pdf files to single pages |  |
Apply security to existing pdf files |  |
Extract pages from pdf files and include them in new documents |  |
Place multiple pages on a single page (page imposition) |  |
Support for encrypted PDF files |  |
PDF Forms
Create and modify PDF forms (Acroforms only) |  |
Fill PDF forms (Acroforms) |  |
Read values from PDF form fields (Acroforms) |  |
Support for pushbuttons, single and multi lines text fields, checkboxes, radio buttons, comboboxes and listboxes (Acroforms) |  |
Fill static XFA forms (Adobe Designer 7 static forms) |  |
Read values from XFA forms (Adobe Designer 7 static forms) |  |
Support for pushbuttons, single and multi lines text fields, numeric fields, datetime fields, checkboxes, radio buttons, choice fields, image fields and barcode fields (XFA forms) |  |
Support for encrypted forms |  |
Form fields flattening, all fields or field by field |  |
Import/Export of form data in FDF, XFDF and XML |  |
Page features
Standard and custom page sizes |  |
Portrait/Landscape orientations |  |
User defined measure units |  |
User defined coordinate system |  |
Absolute positioning (grid based layout) |  |
Document layout
Headers |  |
Footers |  |
Page templates |  |
Layers and sub-layers |  |
Graphics
DeviceRGB, DeviceCMYK, DeviceGray, Indexed, CalGray, CalRGB, Lab, ICC, Separation and DeviceN colorspaces |  |
PANTONE colors |  |
Lines, polylines, arcs, pies, bezier, ellipses, rectangles |  |
Polygons, polypolygons, chords, rounded rectangles, paths |  |
Pen styles and solid brushes |  |
Hatched and gradient brushes |  |
Transparency and blend modes |  |
Images |  |
Clipping regions |  |
Form XObjects |  |
Function-based, axial and radial shadings |  |
Images
JPEG, GIF, BMP, EMF, PNG |  | *
Images from file/stream/System.Drawing.Bitmap |  | **
Rotated images |  |
Transparent images |  |
Color key masking |  |
Image masking |  |
DEFLATE image compression |  |
TIFF to PDF conversion |  |
CCITT G4 compression for B/W images |  |
Alpha channel transparency |  |
Native EMF support |  |
Text features
Single line text |  |
Multiline text |  |
Rotated text |  |
HTML formatted text |  |
Underline, strikethrough, overline |  |
Hyperlinks |  |
Left, center, right horizontal alignment |  |
Top, middle, bottom vertical alignment |  |
Justified text |  |
Fonts
Base 14 Postscript fonts |  |
CJK fonts |  |
Type1 fonts |  |
Type3 fonts |  |
TrueType fonts with subsetting |  |
Unicode TrueType fonts |  |
TrueType fonts from System.Drawing.Font |  |
PDF Security
AES & RC4 encryption |  |
40/128/256*** bit encryption |  |
Unicode passwords |  |
User and owner password |  |
Restricted document operations |  |
Hyperlinks
Bookmarks |  |
Internal cross-references |  |
External cross-references |  |
PDF Actions
Actions support at document and page level |  |
Actions support at bookmark level |  |
GoTo actions |  |
Remote GoTo actions |  |
Javascript actions |  |
Launch actions |  |
Named actions |  |
URI actions |  |
SubmitForm and ResetForm actions |  |
Annotations
3D annotations |  |
Text annotations |  |
Free text annotations |  |
Rubber stamp annotations |  |
File attachment annotations |  |
Movie annotations |  |
Line/Circle/Square annotations |  |
Link annotations |  |
Flash annotations |  |
Extract annotations from existing PDF files |  |
Custom appearance for annotations |  |
Flatten annotations |  |
Barcodes
1D Barcodes (Codabar, Code 11, Code 128 A/B/C, Code 25, Code 25 Interleaved, Code 39, Code 93, COOP 25, EAN-13, EAN-8, IATA 25, ISBN, ISMN, ISSN, JAN-13, Matrix 25, MSI/Plessey, Planet, Postnet, RM4SCC, SCC-14, SSCC-18, UPC-A, UPC-E, Singapore Post, Royal Dutch TPG Post, PZN, Deutsche Post Identcode, Deutsche Post Leitcode, USPS FIM, UCC/EAN128, USPS Horizontal Bars, USPS Package Identification Code, FedEx Ground 96, Pharmacode, Code 32) |  |
2D Barcodes (QR, Codablock F, Code 16K, DataMatrix, MicroPDF417, PDF417) |  |
Miscellaneous
Royalty free distribution |  |
* - JPEG & BMP only; ** - file only; *** 256bit encryption not available on .NETCF

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


What's new

PDF4NET 5.0.0 - March 1, 2017

PDF4NET 5.0.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ PDF/A-2B/U support
+ PDF/A-3B/U support
+ Added support to use subset TrueType fonts across multiple pages in partial save mode
+ Added '\n' after '%%EOF' at the end of file
+ Added PdfBasicCanvas.DrawDirect method to write a byte buffer to page content stream
+ PDFLayer.ID property is now public
— Some PDF forms cannot be saved as PDF/A - fixed
— PDF file cannot be loaded if file ID contains >> - fixed
— Page objects cannot be extracted from some files - fixed
— When copying fields from one document to another the form level fonts are not copied - fixed
— % characters are not escaped correctly - fixed
— In some situations the PDF version is not read correctly - fixed
— ToUnicode cmap is not handled correctly in some situations - fixed
— Multiline textfields with autosized font are not flattened correctly if the text does not fit the field at default font size - fixed

PDF4NET 4.7.6 - December 21, 2016

PDF4NET 4.7.6 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— PDF files with very large float numbers, but written as int, cannot be open with Acrobat - fixed
— Some images cannot be extracted - fixed
— Color mask is not set correctly for non-RGB images - fixed
— Some rotated annotations are not flattened correctly - fixed

PDF4NET 4.7.5 - August 31, 2016

PDF4NET 4.7.5 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— PDFMetadata.XMPMetadata property is not saved using UTF8 encoding - fixed
— Text is not extracted correctly in some situations - fixed
— 4bb indexed images with ICC colorspace are not extracted correctly - fixed

PDF4NET 4.7.4 - May 4, 2016

PDF4NET 4.7.4 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Added support for AES Enhanced encryption - fixed
— Pages with embedded images are not extracted correctly when removeUnusedResources option is used - fixed
— Form data is not exported correctly as XML in some scenarios - fixed
— Text is not extracted correctly from some files - fixed
— Items in a listbox/dropdown field cannot be cleared - fixed

PDF4NET 4.7.3 - February 3, 2016

PDF4NET 4.7.3 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— Text cannot be extracted for Type3 fonts with custom encoding - fixed
— Page objects cannot be extracted when an image cannot be decoded - fixed
— Some text cannot be extracted - fixed
— Field values in FDF files that contain escaped characters cannot be imported - fixed
— When a document contains flattened form fields and layers the field values are displayed upside down - fixed
— Text cannot be extracted when the page contains TJ operators with no string operands - fixed
— Position and size is not extracted correctly for text that uses Type3 fonts - fixed
— Text cannot be drawn using Type1 font - fixed
— Non-embedded TrueType fonts that are marked as bold/italic are displayed as regular - fixed

PDF4NET 4.7.2 - September 4, 2015

PDF4NET 4.7.2 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— Text position is not extracted correctly when a character code cannot be converted to a character - fixed

PDF4NET 4.7.1 - July 24, 2015

PDF4NET 4.7.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— Document level resources are not merged correctly with page level resources - fixed
— Form fields with invalid appearances (no Bbox) cannot be flattened - fixed
— In some situations 3D annotations are not extracted correctly - fixed
— Interleaved PNG images are not handled correctly - fixed
— Text is not extracted correctly from some PDF files - fixed
— Some Code128 barcodes are not rendered correctly - fixed

PDF4NET 4.7.0 - February 06, 2015

PDF4NET 4.7.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Create and draw text using Type3 fonts
— 1bpp images with ICC based Indexed colorspace are not extracted correctly - fixed
— Textrun and glyph size are not correct when font metrics are invalid - fixed
— PDFAlphaChannelMask takes a long time to be created - fixed
— Destination numeric (left, top, right, bottom, zoom) properties cannot be read if they are set internally to null - fixed
— Some ligatures are not extracted corectly - fixed
— '(' character appears at the end of indirect string objects - fixed

PDF4NET 4.6.2 - June 30, 2014

PDF4NET 4.6.2 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— OTF fonts with CFF outlines are not embedded correctly - fixed
— Field alignment is not preserved in some situations when extracting pages from one file and inserting them in another document - fixed
— Some rotated text in EMF files does not appear in converted PDF - fixed
— Some images cannot be extracted - fixed
— In some situations the position of extracted text is not correct - fixed
— Some images in EMF files are not displayed in PDF - fixed
— Text is not wrapped correctly in some multi-line fields and the last characters on some lines are cut-off - fixed
— Superscript and subscript in HTML text is not placed correctly - fixed
— <a> links in HTML text are not created in the PDF file - fixed
— Bitmaps with 32bppRgb format are not displayed - fixed
— Destination in /Dest key in link annotation is not visible through public API - fixed
— Differences array with strings instead of names is not processed correctly - fixed
— Some PS operators in Type4 functions are not executed correctly - fixed

PDF4NET 4.6.1 - February 4, 2014

PDF4NET 4.6.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— A new extended graphic state cannot be set if another one with the same id exists in the PDF file - fixed
— When text is rotated the position of text runs in search results is not correct - fixed
— Some PDF forms with an invalid field tree cannot be loaded - fixed
— Button links between pages are not preserved when merging PDF files - fixed
— In some scenarios the Adobe Reader Extensions are disabled when the PDF form is saved - fixed
— Read-only files cannot be loaded in a PDFDocument - fixed
— When merging PDF forms, some fields loose their alignment - fixed
— When creating a PDF document with attachments, in some situations some of the attachments cannot be extracted from the PDF file - fixed
— When merging PDF forms with calculated fields, the calculated fields no longer work in the final form - fixed
— Some metafiles are not converted correctly to PDF - fixed
— Text is not extracted correctly from some PDF files - fixed
— Some TrueType fonts are not embedded correctly in the PDF file - fixed
— Some diacritic characters are not printed correctly in the PDF file - fixed

PDF4NET 4.6.0 - August 20, 2013

PDF4NET 4.6.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Extract page content as a collection of high level objects, paths, text and images
— Pages with rotation greater than 360 cannot be loaded - fixed
— Position of extracted text runs is not correct in some situations - fixed

PDF4NET 4.5.1 - June 4, 2013

PDF4NET 4.5.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Added PDFTextRun.FontEncoding property
— DataMatrix barcodes are not drawn correctly in some situations - fixed
— Width is not computed correctly for glyphs that use Identity-H encoded font - fixed
— Unrotated fields on rotated pages change their rotation when the page is extracted and inserted in another document - fixed
— Page numbering ranges are not loaded from some documents - fixed
— None value cannot be set for numbering range number style - fixed
— Numbering ranges cannot be updated in some documents - fixed
— Orientation is not set for text runs in search results - fixed

PDF4NET 4.5.0 - March 27, 2013

PDF4NET 4.5.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Content extraction as a sequence of graphic operators
+ Improved text extraction
+ Reduced memory consumption in some situations when loading PDF files in PDFDocument objects
— Some metafiles are not displayed correctly - fixed
— Some JBIG2 encoded images cannot be extracted - fixed
— Text is not extracted correctly when the font has an empty ToUnicode cmap - fixed
— Text is not extracted correctly when the font's ToUnicode cmap uses character arrays - fixed
— FirstLineIndent does not work correctly - fixed
— Indexed images with base RGB colorspace are not extracted correctly - fixed
— Underline, strikethrough and overline options are not considered in DrawHTMLText/DrawHTMLTextBox methods - fixed
— Some PDF files are not merged correctly - fixed

PDF4NET 4.4.1 - October 15, 2012

PDF4NET 4.4.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Added support for saving layers in partial mode
+ Added ColorSpace property to PDF image
— Document information dictionary is not saved correctly when incremental updates are used - fixed
— Encrypted PDF files that use a key size between 40 and 128 cannot be loaded - fixed
— PDFFile.MergeFiles method does not merge the bookmarks - fixed
— In some situations an exception is thrown when setting the caption of a pushbutton widget - fixed
— Some files with incorrect xref section cannot be loaded - fixed
— Strings that contain ( ) are not justified correctly - fixed
— Resources at form level are discarded when the form is saved - fixed
— Radiobutton items are not drawn correctly when the BorderWidth is not set explicitly - fixed
— Vertical bars are not drawn in comb fields when border width > 0 - fixed
— Bookmark action is not read when it is stored in the /Dest key (incorrect) - fixed
— Graphic content and annotations are not drawn correctly on pages with reversed media box (llx > urx, lly < ury) - fixed

PDF4NET 4.4.0 - April 3, 2012

PDF4NET 4.4.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ QR barcodes
+ Added PDFAnnotation.ID property
— Page content cannot be extracted if the page contains zero length content streams - fixed
— Some documents are not saved correctly in partial mode - fixed
— Some encrypted PDF files cannot be open - fixed
— Hidden annotations become visible when they are flattened - fixed
— In some situations the FileName is not loaded for a Launch action - fixed
— When an XFA ImageField is set, the appearance for its AcroForm counterpart is not updated - fixed
— The PDF file is not saved correctly when the document info dictionary contains indirect references to other objects - fixed
— An exception is thrown when merging files that contain hierarchical fields but the field hierarchies match only partially - fixed
— Next actions are not loaded when they are not an array - fixed
— Indexed images with CalRGB base color space are not extracted correctly - fixed
— Layers are created by default in Always print mode - fixed

PDF4NET 4.3.4 - January 9, 2012

PDF4NET 4.3.4 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— Annotations are not loaded when ExtractPage is called and the /Annots array is an indirect reference - fixed
— Image caching by filename is preserved across PDF files - fixed
— Attachments array is not sorted in the PDF file - fixed
— Fields with multiple widgets are not exported correctly to XFDF and XML - fixed
— TrueType fonts are embedded multiple times when using HTML text - fixed
— Images cannot be extracted from some PDF files - fixed
— ToUnicode Cmap is not generated when the font is not embedded - fixed
— Some encrypted PDF files cannot be open - fixed
— FDF import does not work - fixed

PDF4NET 4.3.3 - September 27, 2011

PDF4NET 4.3.3 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Added support for text extraction for Type3 fonts
— The Hidden visibility status is not read correctly from a field widget - fixed
— When the AcroForm and the page share the resources dictionary, the page content is no longer displayed correctly after filling the form fields - fixed
— The ToUnicode Cmap is not created correctly - fixed
— The PDFFlashAnnotation constructor that accepts a poster as parameter throws an exception - fixed
— TrueType fonts with spaces in their names are not embedded correctly - fixed
— Some invalid PDF forms cannot be saved - fixed
— Using Unicode character in form fields that use non-embedded fonts cause an exception - fixed
— DrawTextBox method throws an exception with PostScript fonts - fixed
— Annotations are not flattened correctly in some situations - fixed

PDF4NET 4.3.2 - July 8, 2011

PDF4NET 4.3.2 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— Saving files in partial mode generates invalid PDF files in some situations - fixed
— Shading colors support only device colors - fixed
— XFA forms with empty DateTime fields cannot be loaded - fixed
— Images with CCITT encoded softmasks cannot be extracted - fixed
— PDF files without version number in the header cannot be loaded - fixed
— Form fields rotated with -90 degrees are not flattened correctly - fixed
— PDF files using encryption with version = 2 and revision = 2 cannot be opened - fixed
— Some PostScript fonts are not embedded correctly - fixed
— PDF forms with 'null' objects in /Fields array cannot be loaded - fixed
— Images with Separation colorspace that use a Type0 function are not decoded correctly - fixed
— Character widths are not read correctly from some TTF files - fixed
— Text is not extracted correctly from PDF files with ASCII85 encoded inline images - fixed

PDF4NET 4.3.1 - May 12, 2011

PDF4NET 4.3.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Added support for setting the name of JavaScript fragments
+ Added Dictionary property to PDFFormXObject class
+ Added CalculatedFields property to PDFForm class
+ Added xml:lang attribute to title and description items in XMP metadata
— Images are not extracted from form XObjects - fixed
— When a PDF file is loaded in a PDFDocument the OutputIntents collection is not populated with the output intents in the PDF file - fixed
— When a PDF file with many bookmarks on the same level is saved, stack overflow might appear - fixed
— Checkbox fields created with PDF4NET are not displayed correctly when Highlight form fields option is enbled in Adobe Reader - fixed
— Page resources are not extracted correctly in some situations - fixed
— Some JPEG2000 images are not decoded correctly - fixed
— Right aligned comb fields loose their alignment when the form is flattened - fixed

PDF4NET 4.3.0 - February 23, 2011

PDF4NET 4.3.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Support for reading/writing PDF files in XDP packages.
+ Support for import/export form data in XDP packages.
— Incremental update does not work correctly when the updated file contains imported objects - fixed
— Checkboxes that use the /Opt array for export values are not filled correctly - fixed
— New annotations are not placed correctly on rotated pages - fixed
— Tamil text is not extracted correctly in some situations - fixed
— Field actions are not loaded when a PDF form is loaded - fixed
— The xref offset is written incorrectly when the file size is larger than 2GB - fixed
— Bookmarks cannot be linked to pages that have already been saved in partial mode - fixed

PDF4NET 4.2.1 - January 14, 2011

PDF4NET 4.2.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Changed behaviour of PDFTextBoxField.Text property to behave like displayed text and to allow a different value than Value property.
+ Added TabOrder property in PDFFieldWidget class.
— Form Xobjects are not compressed - fixed.
— Incorrect link annotation appearance is built in some situations - fixed.
— Annotations with appearance size different than annotation size are not flattened correctly - fixed.
— In some situations images cannot be extracted from a PDF file - fixed.
— Overprint mode does not work - fixed.
— Text cannot be extracted from a PDF page when the font's Unicode cmap does not include the codespacerange entry - fixed.
— SetTransparency method fails when used on the canvas on a page extracted from a PDF file - fixed.
— Unicode text cannot be used in free text annotations - fixed.
— Field appearance is damaged when a page is extracted from a PDF form an inserted into another document - fixed.
— Form fields without appearance are not flattened correctly - fixed.
— TrueTypeFont.Name property is empty for fonts created from objects inside a PDF file - fixed.
— Push button appearance is not created correctly - fixed.
— When PDFDocument.EndSave is called, the TrueType fonts used on the unsaved pages are not subset - fixed.
— When a PDF file is loaded and saved, some annotation attributes are changed - fixed

PDF4NET 4.2 - November 18, 2010

PDF4NET 4.2 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ AES-256 encryption and Unicode passwords
+ PDF portfolios
+ Function based, axial and radial shadings
+ Added support for creating ToUnicode cmaps for Unicode TrueType fonts.
+ Added ImageQuality property to JPEG images.
— When the same page is extracted twice from a PDF form and inserted in the same destination document, the output form is invalid - fixed
— PDF files with page objects that have incorrect /Type key cannot be loaded - fixed
— Font subsetting fails when the PDF file contains form Xobject with cyclic resource references - fixed
— Page content extraction does not work correctly for some PDF files - fixed.
— Background color is not set correctly for form fields - fixed.
— Image mask objects are not created correctly - fixed.
— Field attributes are changed when importing FDF data - fixed.
— Imported content is not displayed correctly in some situations - fixed.
— EAN128 barcodes are not created correctly - fixed.
— ForceRendering property on XFAform has no effect - fixed.
— Changing the page rotation when the page has no canvas causes an exception to be thrown - fixed.
— When a GoTo action targets a rotated page, the coordinates are not computed correctly - fixed.
— PDF3DLightingScheme constructor throws an exception when creating a light scheme object - fixed.
— When a document uses OTF fonts with CFF outlines, if the document is created and saved multiple times, without recreating the font objects, after a few saves (4-6) an exception is thrown - fixed.

PDF4NET 4.1.3 - October 6, 2010

PDF4NET 4.1.3 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
— Optimized extraction of images with Indexed colorspace based on CalRGB colorspace.
— Dispose method throws an exception in NETCF edition in some situations - fixed
— Imported PDF files that contain indirect references in document information dictionary are not saved correctly - fixed
— When content is extracted from a PDF file that uses shared reosurces are pages level, only the resources for first extracted content are extracted correctly, the other are not - fixed
— PDF/A files are not created correctly when the time separator is not the ':' - fixed
— String objects less than 16 bytes in AES encrypted files are not decrypted correctly - fixed
— Text is too large in textbox fields with autosize fonts - fixed
— Textbox fields with Helvetica font without Encoding entry are not filled correctly with extended ascii chars - fixed
— When a PDFDocument is created from a stream, the stream is disposed when the document is disposed - fixed
— When extracting pages from a file, the field widget's additional actions are not preserved - fixed
— Size of autosized font in textbox is not computed correctly when the font is replaced for display with another font - fixed
— PDF files that use /Pages instead of /Page for leaf page objects cannot be loaded - fixed
— Textbox fields that use TrueType fonts cannot be filled with Unicode text - fixed
— When different pages share the same /Resources dictionary, if page content is extracted with removeUnusedResources option set to true, then the first extraction modifies the shared dictionary and the subsequent extractions do not get the valid resources - fixed
— PDF files with invalid name objects as dictionary keys cannot be loaded because they enter an infinite loop - fixed
— Appearance is not created for free text annotations - fixed
— When flattening form fields, hidden fields are made visible - fixed
— When pages with field widgets are extracted, the shared resources are duplicated with each widget - fixed
— TrueType font subsetting does not work when some required tables are missing - fixed
— The Page property is not set for field widgets that are not listed in page's Annotations collection - fixed
— Document with pages rotated with -180 degrees cannot be loaded - fixed
— When a PDF file uses gray and RGB colorspaces, it cannot be saved in PDF/A format because the library incorrectly determines that CMYK profile is missing - fixed
— Annotations with zero length appearance cannot be flattened - fixed
— In some situations middle text box alignment with ClipWords option does not display any text although a line of text should be visible - fixed
— Documents cannot be saved in PDF/A format if they contain annotations with appearances without /Resources dictionary - fixed
— An incorrect PDF file is generated if it includes an imported page that contains text annotations with popup windows - fixed
— Invalid forms are created when setting the checkbox/radiobutton ExportValue contains special PDF characters (/, <,>,(,)) - fixed
— 4bit indexed images cannot be drawn on a PDF page - fixed
— When flattening forms that include buttons with icons using the same internal form Xobject ID, the final PDF page is incorrect, all flattened buttons will display the same icon - fixed
— Imported content cannot be extract from pages with empty /Contents entry - fixed
— ExtractPageContent fails with StackOverflow when the page contains link annotations with /Dest entry that points to the same page - fixed
— Form fields that use symbolic names for fonts that do not exist in the fonts dictionaries cannot be filled - fixed

PDF4NET 4.1.2 - July 15, 2010

PDF4NET 4.1.2 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Added support to keep shared resources when extracting multiple pages at once.
+ Added support for loading destinations by name
+ Added support for Arial and Verdana fonts in PDFFontFace enumeration in .NETCF edition
+ Added support for Flash annotations
+ Added support for TrueType collections (.ttc) in TrueTypeFont constructors
— FileData is always set when the FileName property is set on a document attachment - fixed
— In partial save mode, imported pages are not saved correctly if they are saved by PDFDocument.EndSave instead of PDFDocument.SavePage - fixed
— PDF files that contain page with links that target the host page cannot be merged with other files - fixed
— Black is set explicitly as stroke/fill color for imported content because many pages assume default color is black and they draw without setting explicitly the drawing color - fixed
— Rectangles are not placed correctly when the Y axis orientation is bottom to top - fixed
— Middle vertical alignment is not correct when Y axis is BottomToTop - fixed
— When loading a document with resources at all levels (page and document), the page level resources are discarded - fixed
— Pages with checkbox fields that have only the checked appearance cannot be extracted - fixed
— Layers are not built correctly in some situations - fixed
— Imported PDF files that include output intents are not saved correctly - fixed
— Encrypted PDF files with cross reference streams cannot be loaded - fixed
— Method PDFCanvas.DrawPie(pen, brush, rect, startAngle, sweepAngle) causes a stack overflow - fixed
— Field rotation is not preserved when the field is added to the page - fixed
— Field widget appearance is not created correctly when the field widget is rotated - fixed
— Some JBIG2 images are not decoded correctly - fixed
— OTF fonts with CFF outlines cannot be used to draw text - fixed
— Canvas.GetTextboxHeight method in .NETCF edition throws an exception when the textformatOptions parameter is null - fixed
— Some Code128 barcodes are not generated correctly because the symbols are overwritten - fixed
— TrueType fonts are always embedded, no matter the Embed flag in TrueTypeFont constructor was set to false - fixed
— In some situations the remote file name is not read correctly for Remote Go To actions associated with link annotations - fixed
— Form Xobjects keep the pen settings from page canvas if the default solid pen is used - fixed
— Text cannot be extracted when the font dictionary is incomplete for a TrueType font - fixed
— PDF files that include dictionaries in the trailer cannot be loaded - fixed
— PDF files with fields that use Type1 fonts that match the base PDF fonts but also include a font descriptor but do not include a /Widths array cannot be loaded - fixed
— Pages cannot be extracted from PDF files that do not contain an AcroForm dictionary and the extracted page includes various annotations - fixed

PDF4NET 4.1.1 - April 26, 2010

PDF4NET 4.1.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Added support for bar width reduction in unidimensional barcodes
+ Added support for creating PDFMetafile objects from Metafile objects
+ All device colors are now supported for gradient brushes
+ Added support for handling better large PDF files with document level resources
+ Added support to specify whether to parse the page content in order to remove unused resources from page's resources dictionary and not to extract them
— Saving a form in incremental mode causes the entire form to be saved, even if the fields have not been modified - fixed
— Saving a document in incremental mode causes the entire bookmark tree to be saved, even if the bookmarks have not been modified - fixed
— Root bookmarks do not have the /Parent key pointing to /Outlines object - fixed
— Some form fields with additional actions on parent fields cannot be loaded - fixed
— Adding a background to a page causes the page content to be displayed upside down - fixed
— TrueType fonts are not embedded correctly when they are used in a form XObject and not directly on the page - fixed
— Movie annotations are not imported correctly from a PDF file - fixed
— Underline, strikethrough and overline font attributes are not respected in DrawText method - fixed
— PDF version is not saved correctly in the PDF file - fixed
— In some situations invalid documents are generated if the save operations occur veriy fast one after another and the documents include imported pages - fixed
— When a page is extract from a XFA form and inserted in a new document, the vertical bars are no longer drawn for a comb field - fixed
— Encrypted documents with no DocumentID cannot be loaded - fixed
— Some ASCII85 streams are not loaded and decoded correctly - fixed
— Line width is not explicitly set at the beginning of content stream if its value is 1 - fixed
— Middle text alignment is not correct for HTML textboxes - fixed
— When Y axis direction is bottom to top, the form XObjects and text lines are displayed mirrored against X axis - fixed
— PDF file remains locked if it is opened using PDFFile.FromFile and an invalid password exception is thrown - fixed
— Some Code128 barcodes are not generated correctly because the symbols are overwritten - fixed
— Strings are not decrypted correctly if they belong to objects stored in object streams - fixed
— XFA image fields are not flattened correctly - fixed

PDF4NET 4.1.0 - March 15, 2010

PDF4NET 4.1.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ PDF/A support - added support for creating PDF/A-1b compliant PDF files
+ Added support to load fonts from local machine in HTML text
— In some situations the field names are not renamed correctly and the resulting file is invalid - fixed
— Destination page is not loaded for goto actions in link annotations - fixed
— Bookmarks are not displayed when the document is encrypted - fixed
— Adding a document information object to a document saved in partial mode causes the final PDF file to be damaged - fixed
— In some scenarios movie annotations cannot be played - fixed
— An exception is thrown when trying to draw characters that do not exist in the font - fixed
— Custom property names are returned with a slash prefix - fixed
— An invalid content stream is generated when flattening form fields that have content stream appearances that do not end with a white space - fixed
— Multiline textbox fields cannot be filled if the text cannot be wrapped to fit the field width - fixed
— Text using fonts with MacRomanEncoding is not displayed correctly when character codes differ from WinAnsiEncoding - fixed
— Textboxes that use a font that is not defined in the PDF file cannot display the field value - fixed
— The signature cannot be validated when creating an empty appearance for it - fixed
— Document information is not saved correctly in incremental mode - fixed
— Underline, squiggly and strikeout annotations cannot be created - fixed
— PDFDocument.BeginSave method fails when a security manager is attached to the document - fixed
— Middle aligned text is not aligned correctly on vertical - fixed
— Saving a PDFDocument to Response.OutputStream throws an exception - fixed
— Metadata schema is not stored in document information when PDFMetadataSchema.StoreSchemaInDocInfo property was true - fixed
— Layers are not created correctly when the PDFDocument is created from a source PDF file - fixed
— Some DrawTextBox overloads still use PDFFont parameter type instead of PDFFontBase - fixed
— Pages with annotations cannot be loaded when document is loaded in partial mode - fixed

PDF4NET 4.0.1 - February 15, 2010

PDF4NET 4.0.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
+ Added ClipRectangle property and ExtractColorSpaces method to PDFImportedContent class
+ Added support for loading the PDFDocument.SecurityManager property when loading an encrypted PDF file
— DeviceN colorspaces without extended attributes cannot be imported - fixed
— Pages with resources at an upper level are not extracted correctly - fixed
— Custom annotation appearance is not rotated when the annotation is rotated - fixed
— Comb attribute on text fields is ignored - fixed
— PDF version is not read from the source file - fixed
— Calling Dispose twice on the PDF document causes an exception - fixed
— Font resource is not labeled correctly when filling form fields that have a default appearance - fixed
— Font name is not read correctly when creating a TrueTypeFont from a system.Drawing.Font - fixed
— Acro fields are not synchronized with their XFA counter part fields when filling a XFA form through the AcroForm API - fixed
— Horizontal and vertical line annotations are not displayed - fixed
— CCITT images are not extracted correctly on Win7 and XP, they are correct on one but reversed on the other - fixed
— Multiline text in form fields display the \r characters as blocks - fixed
— Digital signatures are invalidated when saving a signed PDF file - fixed
— Path objects are not drawn correctly in some situations - fixed
— Extracted text runs from a rotated page have incorrect PDF and display bounds - fixed
— StemV and ItalicAngle keys are not set for TrueType fonts - fixed
— Size and position of extracted glyphs is not correct when the font does not specify the ascent or capHeight - fixed
— InteriorColor for rectangle and ellipse annotations is not stored correctly - fixed
— Vertical bars are not drawn in comb fields created with Adobe Designer - fixed
— Field name is duplicated when a page is extracted from a form - fixed
— When subsetting a TrueType font created from a System.Drawing.Font, the subset data is not complete - fixed

PDF4NET 4.0.0 - January 15, 2010

The following new features have been added in PDF4NET 4.0:
+ Partial document load
+ Partial document save, save document page by page, or page fragment by page fragment
+ Incremental updates
+ Text extraction
+ Text search
+ Custom appearance for annotations
+ Flatten annotations
+ Enhanced AcroForms object model
+ JPEG 2000 and JBIG2 support in image extraction
+ Public API for access to low level COS objects

Breaking changes
PDF4NET 4.0 introduces several breaking changes relative to PDF4NET 3.3. Why did we choose this solution?
After 6 years of development on this product, and other PDF related products, we gained deep knowledge on PDF and the existing architecture of PDF4NET could no longer face the challenges. We had to redesign the internal architecture, to make it more extensible, to easily support new features. We kept the public API the same like in previous versions in most scenarios but in several situations we had to change it, to make it easier to understand. Although several classes and enums have been removed because, based on our experience they were not used by customers, the corresponding functionality is still available in PDF4NET. For example the classes in O2S.Components.PDF4NET.Graphics.Shapes namespace have been removed because it is more natural to draw a line using page.Canvas.DrawLine() method then to create a PDFLine object and add it to the canvas.
PDF4NET 3.3 also did not support PDF files with custom information. Loading and saving such a PDF file with PDF4NET 3.3 caused all the custom information to be discarded. The generic PDF engine in PDF4NET 4.0 no longer does this and it also supports adding custom information to PDF objects.
If you upgrade your PDF4NET 3.3 code to PDF4NET 4.0 and you encounter any problems, send us an e-mail and we'll assist you. Also support for PDF4NET 3.3 (bug fixes but no new features) will be available till 31 December 2010.
The breaking changes in PDF4NET 4.0 are listed below:
Removed classes/enums
- O2S.Components.PDF4NET.Annotations.MarkupStyle
- O2S.Components.PDF4NET.Annotations.Movie
- O2S.Components.PDF4NET.Forms.FieldRemoveOptions
- O2S.Components.PDF4NET.Forms.FieldRenameOptions
- O2S.Components.PDF4NET.Forms.IconLayoutMode
- O2S.Components.PDF4NET.Forms.PDFCheckBoxAppearance
- O2S.Components.PDF4NET.Forms.PDFFieldActions
- O2S.Components.PDF4NET.Forms.PDFFieldAppearance
- O2S.Components.PDF4NET.Forms.PDFFieldBorder
- O2S.Components.PDF4NET.Forms.PDFFieldInfo
- O2S.Components.PDF4NET.Forms.PDFPushbuttonAppearance
- O2S.Components.PDF4NET.Forms.PDFRadioButtonAppearance
- O2S.Components.PDF4NET.Forms.PDFRadioButtonItemCollection
- O2S.Components.PDF4NET.Forms.PDFSignatureAppearance
- O2S.Components.PDF4NET.Forms.PDFWidgetActions
- O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
- O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFImportedSeparationColorSpace
- O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpaceCollection
- O2S.Components.PDF4NET.Graphics.PDFBaseColor
- O2S.Components.PDF4NET.Graphics.PDFCustomBrush
- O2S.Components.PDF4NET.Graphics.PDFGradientBrush
- O2S.Components.PDF4NET.Graphics.PDFGraphic
- O2S.Components.PDF4NET.Graphics.Shapes.PDFArc
- O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaDocLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaFileLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaRemoteDocLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaWebLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFBezier
- O2S.Components.PDF4NET.Graphics.Shapes.PDFChord
- O2S.Components.PDF4NET.Graphics.Shapes.PDFClippingRegion
- O2S.Components.PDF4NET.Graphics.Shapes.PDFEllipse
- O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLText
- O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLTextBox
- O2S.Components.PDF4NET.Graphics.Shapes.PDFLine
- O2S.Components.PDF4NET.Graphics.Shapes.PDFLines
- O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFPie
- O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyBezier
- O2S.Components.PDF4NET.Graphics.Shapes.PDFPolygon
- O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyPolygon
- O2S.Components.PDF4NET.Graphics.Shapes.PDFRect
- O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
- O2S.Components.PDF4NET.Graphics.Shapes.PDFRoundRectangle
- O2S.Components.PDF4NET.Graphics.Shapes.PDFText
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextBox
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextDocLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFileLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextRemoteDocLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextWebLink
- O2S.Components.PDF4NET.PageTransitionEffect
- O2S.Components.PDF4NET.PDFBaseObject
- O2S.Components.PDF4NET.PDFFile.PDFImportedObject
- O2S.Components.PDF4NET.PDFFile.Resources.PDFImportedColorSpacesCollection
- O2S.Components.PDF4NET.PDFFile.Resources.PDFResourceManager
- O2S.Components.PDF4NET.PDFPageTemplate
- O2S.Components.PDF4NET.PDFPageTransition
- O2S.Components.PDF4NET.PDFParserException
- O2S.Components.PDF4NET.SaveProgressEventArgs
- O2S.Components.PDF4NET.TransitionAngleDirection
- O2S.Components.PDF4NET.TransitionDimension
- O2S.Components.PDF4NET.TransitionMotionDirection

Renamed classes/enums
- AnnotationFlags has been renamed to PDFAnnotationFlags.
- BlendMode has been renamed to PDFBlendMode and has been moved from namespace O2S.Components.PDF4NET.Graphics.Shapes to namespace O2S.Components.PDF4NET.Graphics.
- BorderStyle has been renamed to PDFBorderStyle.
- ClipText has been renamed to PDFClipText.
- ColorSpace has been renamed to PDFColorSpace and has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.ColorSpaces.
- ContentMirroring has been renamed to PDFContentMirroring and has been moved from namespace O2S.Components.PDF4NET.PDFFile to namespace O2S.Components.PDF4NET.Graphics.
- DashStyle has been renamed to PDFDashStyle.
- DataFormat has been renamed to PDFFormDataFormat.
- DisplayMode has been renamed to PDFDisplayMode.
- ExportDataOptions has been renamed to PDFExportDataOptions.
- FieldBorderStyle has been renamed to PDFBorderStyle.
- FieldVisibilityStatus has been renamed to PDFFieldWidgetVisibilityStatus.
- FileAttachmentAnnotationIcon has been renamed to PDFFileAttachmentAnnotationIcon.
- FillMode has been renamed to PDFFillMode and has been moved from namespace O2S.Components.PDF4NET.Graphics.Shapes to namespace O2S.Components.PDF4NET.Graphics.
- FontFace has been renamed to PDFFontFace and has been moved from namespace O2S.Components.PDF4NET.Graphics to namespace O2S.Components.PDF4NET.Graphics.Fonts.
- HatchType has been renamed to PDFHatchType.
- HighlightMode has been renamed to PDFPushButtonHighlightMode.
- ImageCompression has been renamed to PDFImageCompression.
- KeepAspectRatio has been renamed to PDFKeepAspectRatio.
- LineCap has been renamed to PDFLineCap.
- LineEndingStyle has been renamed to PDFLineEndingStyle.
- LineJoin has been renamed to PDFLineJoin.
- LinkHighlightMode has been renamed to PDFLinkHighlightMode.
- MagnificationMode has been renamed to PDFMagnificationMode and has been moved from namespace O2S.Components.PDF4NET.Actions to namespace O2S.Components.PDF4NET.
- NumberingStyle has been renamed to PDFNumberingStyle.
- OutlineDisplay has been renamed to PDFBookmarkDisplayStyle.
- PageLayout has been renamed to PDFPageLayout.
- PageNumber has been renamed to PDFPageNumber.
- PageNumberingRange has been renamed to PDFPageNumberingRange.
- PageNumberingRangeCollection has been renamed to PDFPageNumberingRangeCollection.
- PageOrientation has been renamed to PDFPageOrientation.
- PageSize has been renamed to PDFPageSize.
- PDFAnnotations has been renamed to PDFAnnotationCollection.
- PDFCircleAnnotation has been renamed to PDFEllipseAnnotation.
- PDFFields has been renamed to PDFFieldCollection.
- PDFFunctions has been renamed to PDFFunctionCollection.
- PDFJavaScriptBlock has been renamed to PDFJavaScript.
- PDFJPXImage has been renamed to PDFJpeg2000Image.
- PDFLayers has been renamed to PDFLayerCollection.
- PDFMarkupAnnotation has been renamed to PDFTextMarkupAnnotation.
- PDFMetadataSchemas has been renamed to PDFMetadataSchemaCollection.
- PDFOutline has been renamed to PDFBookmark.
- PDFOutlines has been renamed to PDFBookmarkCollection.
- PDFPages has been renamed to PDFPageCollection.
- PDFPushbuttonField has been renamed to PDFPushButtonField
- PDFSquareAnnotation has been renamed to PDFRectangleAnnotation.
- PDFWidgetAnnotation has been renamed to PDFFieldWidget.
- PrintScaling has been renamed to PDFPrintScaling.
- RubberStampAnnotationIcon has been renamed to PDFRubberStampAnnotationIcon.
- SymbolStyle has been renamed to PDFCheckSymbolStyle.
- TextAlign has been renamed to PDFTextAlign and has been moved from namespace O2S.Components.PDF4NET.Graphics.Shapes to namespace O2S.Components.PDF4NET.Graphics.
- TextAnnotationIcon has been renamed to PDFTextAnnotationIcon.
- XAxisDirection has been renamed to PDFXAxisDirection and has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- YAxisDirection has been renamed to PDFYAxisDirection and has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.

Moved classes/enums
- PDFBasicCanvas has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFCalGrayColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFCalRgbColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFCanvas has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFCMLogicalUnit has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFCmykColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFDeviceNColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFFont has been moved from namespace O2S.Components.PDF4NET.Graphics to namespace O2S.Components.PDF4NET.Graphics.Fonts.
- PDFGrayColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFICCColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFInchLogicalUnit has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFIndexedColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFLabColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFLogicalUnitBase has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFMMLogicalUnit has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFObject has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Cos.
- PDFPoint has been moved from namespace O2S.Components.PDF4NET.Graphics to namespace O2S.Components.PDF4NET.
- PDFPointLogicalUnit has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFRectangle has been moved from namespace O2S.Components.PDF4NET.Graphics.Shapes to namespace O2S.Components.PDF4NET.
- PDFRgbColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFSeparationColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


System requirements
The PDF4NET library requires .NET Framework 2.0 or later to be installed on the target computer for standard .NET framework edition of PDF4NET. Compact .NET Framework edition of PDF4NET library requires a Windows CE.NET powered mobile device with Compact .NET Framework 1.0 or later installed. The .NET Framework redistributable is not included in the installation kit. It can be obtained from the Microsoft website.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Getting Started
In order to minimize the download time, the PDF4NET library is provided as a single msi package.

How to install

After downloading the archive, run the installation package and follow the installation instructions.

After the installation, the following files will be present on computer's disk:

bin\
o2s.components.pdf4net.dll - the PDF4NET class library compiled for .NET Framework 2.0.
o2s.components.pdf4net.compact.dll - the PDF4NET class library for .NET Compact Framework.
help\
pdf4net.chm - the PDF4NET online help file.

samples\ - over 40 samples (C# and VB.NET) showing how to use the PDF4NET library.

supportfiles\
*.pdf, *.jpg, *.emf, *.ttf, *.u3d - helper files for PDF4NET samples.
samplesign.pfx - sample X.509 certificate.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Licensing
Key points of the license agreement.
- The PDF4NET library is licensed per developer. One license can be used on multiple computers as long as it is used by the same developer, and it can not be used concurently or shared by other developers.
- When using the PDF4NET library for desktop development (native Windows applications), the library is licensed royalty free. You pay to use during the development time to create your final product. You do not need to pay any other fees when you distribute the PDF4NET library with your final product.
- When using the PDF4NET library for mobile development (compact .NET framework applications), the library is licensed royalty free. You pay to use during the development time to create your final product. You do not need to pay any other fees when you distribute the PDF4NET library with your final product.
- When using the PDF4NET library for server-side development (ASP.NET web applications), the library is licensed deployment free. You pay to used during the development time to create your final product. You do not need to pay any other fees when you deploy the PDF4NET library along with your final product on other servers.
- This license does NOT ALLOW you to distribute the PDF4NET library for use in development. This requires an OEM distribution license. If you want to do so, please contact us.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


License Agreement
VERY IMPORTANT - READ CAREFULLY: This O2 Solutions Software License Agreement (hereinafter, this "LICENSE") is a legal agreement between you (either an individual or a single entity) and O2 Solutions, SRL. ("O2 Solutions"), for the software containing this LICENSE which has been obtained through O2 Solutions or its authorized distributor.

1. OWNERSHIP; LICENSE GRANT.

This is a license agreement and NOT an agreement for sale. O2 Solutions continues to own the copy of the SOFTWARE contained on the disk and all other copies that you are authorized by this LICENSE to make. Your rights to the SOFTWARE are specified in this LICENSE, and O2 Solutions retains all rights not expressly granted to you in this LICENSE. O2 Solutions hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.

2. PERMITTED USES.

This LICENSE grants you the following rights:
A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer.
B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy for each developer for which the Software has been licensed as described in Section 2.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.
C. You may use the evaluation versions of the SOFTWARE for the limited purposes of demonstrations, trials and design time evaluations.

3. PROHIBITED USES.

You may not, without the prior written permission of O2 Solutions:
A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.
B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.
C. Transfer, rent, lease, or sublicense the SOFTWARE.

4. REDISTRIBUTABLE COMPONENTS.

A. The files o2s.components.pdf4net.dll and o2s.components.pdf4net.compact.dll are considered as REDISTRIBUTABLE DLLs.
B. In addition to the license and rights granted in Sections I and II, O2 Solutions grants you a nonexclusive, royalty-free right to reproduce and distribute the object code version of the SOFTWARE designated in the SOFTWARE as (i) those portions of the SOFTWARE which are identified in the documentation as REDISTRIBUTABLE DLLs ("DLLs"); provided: you distribute the REDISTRIBUTABLES in object code form only in conjunction with and as part of your software application product which adds significant and primary functionality; you do not use O2 Solutions' name, logo or trademarks to market your software application product; you include a valid copyright notice on your SOFTWARE; and
C. In addition to the other requirements set forth in this Section 4, you hereby agree to indemnify, hold harmless, and defend O2 Solutions from and against any and all liabilities, damages, losses, costs and expenses (including attorneys' fees) arising from or related to any claim, action, proceeding or allegation that arise or result from the use and distribution of any of your software application product(s) or components.

5. COPYRIGHT.

All title and copyrights in and to the SOFTWARE are owned by O2 Solutions. The SOFTWARE is protected by United States copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of O2 Solutions.

6. TERMINATION.

This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from O2 Solutions if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to O2 Solution

7. LIMITED WARRANTY

A. O2 Solutions does not warranty that the SOFTWARE will be error-free. Except with respect to REDISTRIBUTABLES, which are provided "AS IS," without warranty of any kind, O2 Solutions warrants that the SOFTWARE will perform substantially in accordance with the accompanying electronic documentation for a period of thirty (30) days from the date of receipt.
B. O2 Solutions' entire liability, in contract tort or otherwise, and your exclusive remedy under the performance warranty set forth in Section 7.A, shall be, at O2 Solutions' option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.
C. EXCEPT AS EXPRESSLY SET FORTH IN THIS SECTION 7, O2 SOLUTIONS DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, WHETHER ARISING BY STATUTE OR OTHERWISE IN LAW OR FROM A COURSE OF DEALING OR USAGE OR TRADE, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF ACCURACY, COMPLETENESS, PERFORMANCE, CURRENCY, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE WITH REGARD TO THE SOFTWARE.

8. LIMITATION OF LIABILITIES.

O2 Solutions' liability, whether in contract, or otherwise, arising out of Licensee's use of, or in connection with, the SOFTWARE, or otherwise under this Agreement, shall not exceed the amount of the license fee paid by you to O2 Solutions. IN NO EVENT SHALL O2 SOLUTIONS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE, EVEN IF O2 SOLUTIONS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


License Activation

After you purchase the PDF4NET toolkit, you will receive a serial number for unlocking the evaluation version.

Unlocking the PDFFile class

The PDFFile class has a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from the imported pages.

Unlocking the PDFDocument class

The PDFDocument class has a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from documents saved with this class.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Developer's Guide
This section of the documentation helps you get a more specific view of PDF4NET features.

In this section

First PDF file

Covers the creation of a simple pdf file.

The Object Model

Provides information about the PDF4NET's object model.

Creating content

Covers the creation of the pdf file specific content.

TrueType / Type1 fonts support

Covers the external fonts support in PDF4NET library.

PDF editing

Covers the pdf editing (merge, split, encrypt, extract) capabilities of PDF4NET library.

Automatic page numbering

Covers the page numbering features of PDF4NET library.

Creating document's bookmarks tree

Provides information about the creation of bookmarks tree that is displayed in the Bookmarks navigation pane of Adobe's pdf viewers.

Linking to other content

Provides information about creating links in a pdf file.

PDF support for presentations

Covers the presentation features found in pdf files.

Document metadata

Covers the document metadata information and viewer preferences when opening the pdf file.

PDF security and encryption

Provides information about the pdf security and encryption support available in PDF4NET library.

PDF actions

Shows how to work with PDF actions in PDF4NET library.

Annotations

Presents the support for PDF annotations available in PDF4NET library.

Working with forms

Presents the PDF forms support available in PDF4NET library.

Barcodes

Presents the barcodes support available in PDF4NET library.

PDF/A

Shows how to create PDF/A-1b compliant PDF files with PDF4NET.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


First PDF file
Creating pdf files with PDF4NET library is an easy task. Although it is a general purpose library, its simple and easy to use object model allows you to create pdf files with no effort.

The following steps will show how easy is and how few coding lines are needed to create a pdf file (the sample below uses C#. There is no difference using Visual Basic.NET).

Set up references

First, you need to set up the references to PDF4NET library. Using Visual Studio.NET, add a reference to your project to O2S.Components.PDF4NET.dll assembly. Then, add the following lines at the beginning of your source file.
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

Create the document

The first thing to do in your code is to create the document, which is an instance of PDFDocument class.
PDFDocument doc = new PDFDocument();

Create the first page of the document

The next thing to do is to create at least one page in the document. This is accomplished using the AddPage( ) member of document object. A page in the document is an instance of PDFPage class.
PDFPage page = doc.AddPage( );

Create the content of the page

After creating the page, we need to fill it with content. The content of a page is created using the Canvas property of the page object. The canvas encapsulates the drawing surface of the page, like a device context for the screen. Using the Canvas property, you can draw figures on a page or you can write text. In this sample, we'll write a simple text on the page.
page.Canvas.DrawText(“Hello world”, new PDFFont(FontFace.Helvetica, 12),
     new PDFPen(new PDFRgbColor(255, 0, 0), 1),
     new PDFBrush(new PDFRgbColor(0, 0, 255)), 10, 20);
When drawing text, we need a font, a pen and a brush. The pen is used to color the border of the text, and the brush is used to fill the interior of the text. The text is written at 10 points from the left margin and 20 point from the top margin of the page.

Saving the document

Once we created the content, we can save the document. The document can be saved to a file on disk
doc.Save("HelloWorld.pdf");
or it can be saved to a stream, like the response stream of an ASP.NET application
Response.ContentType = "application/pdf";
doc.Save(Response.OutputStream);

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Compact .NET Framework support
PDF4NET library supports Compact .NET Framework through a separate assembly, included in the same installation kit and covered by the same license. Please refer to Overview page for details about the features supported by PDF4NET Compact .NET Edition.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


The Object Model
The PDF4NET library exposes a simple but powerfull object model that gives a developer access to most of pdf features.
The object model is displayed in the diagram below:

The root of the object model is the document object. It has a collection of pages and a collection of outlines. It also has a default page number, template and transition. The outlines collection is composed of individual outline items. The pages collection consists of individual page objects. A page has a canvas and specific page number, template and transition. The canvas holds the list of graphic objects that drawn on the page.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Creating Content
A pdf document consists of several pages. Creating document content implies creating the content for each page.

Page content

The content of a page is created using the Canvas property of the page object. The Canvas encapsulates the drawing surface of the page. Using its properties and methods, the developer can add new content to a page. The content of the page mainly consists of text, images and graphic shapes. A page can also include links to other content.

The Canvas object exposes a rich set of functions to help the developer to create rich content. Using the canvas, the following graphic shapes can be drawn on a page:
- lines (a single line or a sequence of lines).
- bezier splines.
- rectangles.
- circles.
- ellipses.
- arcs.
- pies.
- polygons.
- images.
Also, a rich set of functions is available for drawing text on the page. The canvas allows to draw single line text or multi line text. For multiline text, it is automatically wrapped to fit the required width. All types of text can be aligned in different ways. Also, the text can be displayed rotated around a specified point.

When drawing on the page, the canvas uses several painting objects to create the graphics. The pen object are used to draw the lines and the contour of graphic shapes and text, the brush is used to fill the interior of closed shapes and text, and the font object is used to set the visual appearance of the text.

The default origin of the coordinate system (0, 0) is located at the top left corner of the page. The X axis grows from left to right, the Y axis grows from top to bottom. All the dimensions and positions are given in logical units. The default logical unit used by the library is the point (1/72 inches).

Repetitive content

An important feature of the PDF4NET library is the ability to setup templates to be applied on several pages. The content of a template is created in the same way the content of a page is created. The template has a canvas that is drawing surface. After creating the content of the template, it is applied automatically to each designated page. The developer can setup multiple templates for a document, each set of pages having its own template. The content of the template is applied on a page before the actual content of the page, so the template content is under the page content when the final pdf file is created. The template feature is implemented through the PDFPageTemplate class.

Page sizes

The PDF4NET library lets the user to create documents having pages of different sizes. Each page can have its own size (controlled by Width and Height properties) and orientation (landscape or portrait). The library supports 14 standard page formats, but other sizes can be used by setting the corresponding properties.
The following standard sizes are predefined by the library:

Page format | Width (points) | Height (points)
A3 | 842 | 1190
A4 | 595 | 842
A5 | 420 | 595
B4 | 729 | 1032
B5 | 516 | 729
Letter | 612 | 792
Legal | 612 | 1008
Tabloid | 792 | 1224
Ledger | 1224 | 792
Statement | 396 | 612
Executive | 540 | 720
Folio | 612 | 936
Quarto | 610 | 780
10x14 | 720 | 1008

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Logical units
The concept of logical unit has been introduced in order to facilitate the positioning of content within a page. All drawing functions now use logical units to position the content on the page. A logical unit defines the transformation between the transformation between user's measure unit and the default measure unit used within the pdf files which is the point. Now, you can specify the position of page content using inches, millimeters, centimeters, or any other unit that fits you best. The default logical unit used by the library is the point, so compatibility with previous versions is kept.

Defining a new logical unit

All the logical units used with PDF4NET library must inherit from PDFLogicalUnitBase class, which is the base class representing an abstract logical unit.

When inheriting from PDFLogicalUnitBase, 2 methods must be implemented: ToPDFUnitX( float unit ) and ToPDFUnitY( float unit ).

Method ToPDFUnitX( float unit ) defines the transformation between the user's measure unit and the pdf unit (the point) for the X axis. It says how many pdf units correspond to the number of units given as parameter when representing the logical unit on the X axis.

Method ToPDFUnitY( float unit ) defines the transformation between the user's measure unit and the pdf unit (the point) for the Y axis. It says how many pdf units correspond to the number of units given as parameter when representing the logical unit on the Y axis.

Defining different mappings for X and Y axes, allows a developer to have different physical lengths for a unit on X and Y axes. Thus, a unit on X axis might represent 10 points, while a unit on Y axis might represent 100 points.

The example below shows how to define a new logical unit that maps to 10 points on X axis and to 100 points on Y axis.

class Unit : PDFLogicalUnitBase
{
    float ToPDFUnitX( float unit )
    {
        return unit * 10;
    }

    float ToPDFUnitY( float unit )
    {
        return unit * 100;
    }
}

Using logical units

The PDFDocument class allows to define a global logical unit used across the document. When a new page is added to the document, it inherits the logical unit to be used from the document, but the library allows to set a different logical unit for each page to fit best the drawing needs. Also, in order to provide more flexibility during the drawing process, the developer can change the logical unit while drawing on the page. You can accomplish this using the SetLogicalUnit( ) method of the Canvas object.

The following sample shows how to do it:

...
// create a new logical unit that represents the centimeter.
PDFCMLogicalUnit cm = PDFCMLogicalUnit( );
page.Canvas.SetLogicalUnit( cm );
// the following drawing operations use the centimeter to draw the content
//
// Draw a horizontal line, 10 cm in length, at 1 cm from the top and
// starting at 1 cm from the left of the page and ending at 11 cm from the
// left of the page.
page.Canvas.DrawLine( pen, 1, 1, 11, 1 );
// continue drawing here
...
...
// create a new logical unit that represents the inch
PDFInchLogicalUnit in = PDFInchLogicalUnit( );
page.Canvas.SetLogicalUnit( in );
// the following drawing operations use the inch to draw the content

// Draw a horizontal line, 3 inches in length, at 1 inch from the top and
// starting at 1 inch from the left of the page and ending at 4 inches
// from the left of the page.
page.Canvas.DrawLine( pen, 1, 1, 4, 1 );
// continue drawing here
...

Predefined units

The library defines classes that represent the following units:
- point - PDFPointLogicalUnit
- millimeter - PDFMMLogicalUnit
- centimeter - PDFCMLogicalUnit
- inch - PDFInchLogicalUnit

When a document is created, the default logical unit is the point. Also, when a page is created the default logical unit is the point. At this time, the page size, width and height, is given in points. When a new logical unit is assigned to the page, through LogicalUnit property, these values are recomputed automatically to represent the new units. In this case, changing the page size needs to be done after changing the logical unit for the page, and not before.

The following sample shows how to do it:

PDFDocument doc = new PDFDocument( );
PDFPage page = doc.AddPage( );
// at this time the logical unit of the page is the point
// the Width is set to 612 points and the Height is set to
// 792 points (standard letter values).
...
// Create a new logical unit
PDFInchLogicalUnit in = PDFInchLogicalUnit( );
page.LogicalUnit = in;
// now, the Width is 8.5 in, and Height is 11 in.
page.Width = 10;
page.Height = 10;
// now, the Width is 10 in, and Height is 10 in.
...

In the sample above, if the assignment

page.Width = 10;
page.Height = 10;

would have been done before setting the logical unit for the page, then the page size would have been considered to be 10 points x 10 points and setting the logical unit to inch would have converted the page size to 0.14 x 0.14 inches.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Coordinate systems
The PDF4NET library introduces a new feature that allows a developer to customize the coordinate system in order to fit the drawing requirements. The default coordinate system has its origin in the top left corner of the page, the X axis grows from left to right, and the Y axis grows from top to bottom. The new features allows the developer to set the origin of the coordinate system anywhere on the page, and set arbitrary directions for each axis. When changing the origin of the coordinate system, the new position is always given in the coordinates of the current system.

The following sample moves the origin of the coordinate system to bottom left corner of the page and changes the direction of the Y axis to bottom to top (this is the default pdf coordinate system).

...
// the initial coordinate system has the origin in top left corner
...
// move the origin to bottom left corner
page.Canvas.SetOrigin( 0, page.Height );
// change Y axis direction to grow from bottom to top
page.Canvas.SetAxesDirections( XAxisDirection.LeftToRight, YAxisDirection.BottomToTop ); ...

Left, Top positioned objects

For graphic objects that are positioned on the page using Left, Top, Right, Bottom coordinates the Left coordinate is always on the left of the page and the Right coordinate is always on the right of the page, no matter the direction of the X axis is, left to right, or right to left. When the direction of X axis is LeftToRight, the following relation is always true: Right >= Left. When the direction of X axis is RightToLeft, the following relation is always true: Left >= Right. For Y axis the situation is similar, Top is always at the top of the page and Bottom is at the bottom of the page, no matter the direction of the Y axis is, top to bottom, or bottom to top. When the direction of Y axis is TopToBottom, the following relation is always true: Bottom >= Top. When the direction of Y axis is BottomToTop, the following relation is always true: Top >= Bottom.

The width of these graphic objects is always from Left to Right, and the Height is always from Top to Bottom.

The above situation is detailed in the images below:

Default coordinate system Reversed coordinate system

The relative position of Left, Right, Top, Bottom coordinate is always the same, no matter the axes direction.

Text lines

When drawing text lines, the text alignment is always relative to the printing coordinate, no matter the directions of the axes.

The following images show how TopLeft text alignment is handled for different directions of the axes:

TopLeft text aligment for different axes directions.

Text boxes

When drawing text boxes, the alignment of the text is relative to the interior of the box, no matter the directions of the axes and the text box follows the rules for the graphic objects shown above.

The images below show how the drawing of text boxes is handled for different directions of axes.

Textbox alignment for different axes directions.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


HTML formatting
The PDF4NET library provides HTML formatting features for displayed text, enhancing existing text display capabilities.

Support classes and methods

A series of methods have been added to PDFCanvas class to support the drawing of HTML text. The following methods provide support for HTML formatted text:
DrawHTMLText( ) - works the same way like its counterparts DrawText( ) methods but parses its text in order to display the correct formatting.
DrawHTMLTextBox( ) - works the same way like its counterparts DrawTextBox( ) methods but parses its text in order to display the correct formatting.

Supported HTML tags

The HTML must be well formed, all tags must be closed. The text must be a valid XML document. Also, the tags are case sensitive and lower case must be used.
All the attributes must be quoted, otherwise an exception will be raised. E.g: <font color="#000000">test</font> is valid while <font color=#000000>test</font> will raise an exception.
Overlapping of tags is not allowed, e.g.: <b><i>test</b></i> will not work, while <b><i>test</i></b> is correct.
The following HTML tags are supported:

<b> - marks a block of text as bold.

<i> - marks a block of text as italic.

<u> - marks a block of text as underline.

<st> - marks a block of text as strikethrough.

<o> - marks a block of text as overline.

<br/> - forces a new line in the text box.

<font> - sets the display font for a block of text. The following attributes are supported:
- color - sets the color of the text. Supports both named colors and hex coded colors.
- fillcolor - sets the color of the text interior. Supports both named colors and hex coded colors. This attribute is identical to "color" attribute.
- strokecolor - sets the color of the text border. Supportsbothnamed colors and hex coded colors.
- face - sets the name of the font used to display the text. The following values are accepted for this attribute: Helvetica, Courier, TimesRoman, Symbol, ZapfDingbats.
- size - sets the size, in points, of the font used to display the text. This attribute accepts as value any float value.

The <st> and <o> tags, and "fillcolor" and "strokecolor" attributes are PDF4NET extensions to HTML specification.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Fonts metrics
Version 2.1 of PDF4NET library gives access to the metrics of the fonts used to display text. Any font object exposes a property named Metrics of type PDFFontMetrics that returns read only values of font metrics. Ascent, descent, leading, stemV, stemH, cap height, x height, average width and max width metrics are available. All these values are given in unscaled glyph units.
Also, two new methods are available in any font object:
fontobj.MeasureString(string text) - returns the width of the text in points, based on the fontobj metrics
fontobj.GetCharWidth(char charCode) - returns the width of the given character in unscaled glyph units.
To convert from unscaled glyph units to points, divide the value by 1000 then multiply it by font size.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Clipping regions
PDF4NET library includes support for clipping regions. When a clipping region is active, only the graphics inside the region are visible. Any graphic or part of a graphic that falls outside of the region is clipped at region boundary. The PDFCanvas class makes public two methods to work with clipping regions:
SetClipRegion(PDFPath clipGraphic) sets the given graphic object as a clipping region
ResetClipRegion() clears the active clipping region.
The following sample shows how to use a clipping region:
Clip region
Copy Code
            // create a rectangular clip region, with top left at 10, 10, width 200, height 100
            PDFPath clipPath = new PDFPath();
            clipPath.Rectangle(10, 10, 200, 100);
            page.Canvas.SetClipRegion(clipPath);

            // continue to add content here
            // when the pdf file is viewed, only the graphics inside the rectangle will be visible

            // The clip region is cleared
            page.Canvas.ResetClipRegion( );
            // all the graphics drawn from this point on the page will be visible when the pdf file is viewed

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Layers
Layers in a PDF file allows to define optional content that can selectively shown or hidden by the user. Layers are especially useful in graphics applications for grouping related content.
PDF4NET library allows to create unlimited levels of layers and sub-layers in a parent-child relationship. The page's Canvas has a Layers property that allows to add new layers to a page. Each layer has its own independent Canvas for creating its content. The z-order of the layers on a page is determined by the order they have been added to the layers collection of the page.
Regular page content (created through page's Canvas) is separate from layers' content and its visibility (show/hide) can not be controlled by the user that views the PDF file. For imported PDF documents, layers can be created also under existing page content.
The following sample shows how to create 2 top level layers and 4 sub-layers for the first layer:

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET.Layers
{
   class Layers
   {
      [STAThread]
      static void Main(string[] args)
      {
         // Create the pdf document
         PDFDocument doc = new PDFDocument( );

         // Create one page
         PDFPage page = doc.AddPage( );

         PDFPen redPen = new PDFPen( new PDFColor( 192, 0, 0 ), 1 );
         PDFBrush blueBrush = new PDFBrush( new PDFColor( 0, 0, 255 ) );
         PDFBrush darkBlueBrush = new PDFBrush( new PDFColor( 0, 0, 128 ) );

         // Draw "Hello world" in the center of the page
         // this text is always visible.
         page.Canvas.DrawText( "Hello world !",
            new PDFFont( FontFace.Helvetica, 100 ), redPen, blueBrush, page.Width/2, page.Height/2,
            0, TextAlign.MiddleCenter );

         // Create a parent layer
         PDFLayer squareLayer = page.Canvas.Layers.Add( "Empty square" );
         // Create a poly polygon and draw it on the layer
         PDFPoint[][] polygons = new PDFPoint[2][];
         polygons[0] = new PDFPoint[]{ new PDFPoint( 50, 100 ), new PDFPoint( 550, 100 ),
                                 new PDFPoint( 550, 600 ), new PDFPoint( 50, 600 ) };
         polygons[1] = new PDFPoint[]{ new PDFPoint( 100, 150 ), new PDFPoint( 500, 150 ),
                                 new PDFPoint( 500, 550 ), new PDFPoint( 100, 550 ) };
         PDFPolyPolygon pp = new PDFPolyPolygon( redPen, darkBlueBrush, polygons );
         pp.FillMode = FillMode.EvenOdd;
         squareLayer.Canvas.Add( pp );

         // create 4 sublayers
         // 1. Hatched layer
         PDFLayer hatchedLayer = squareLayer.Canvas.Layers.Add( "Hatched square" );
         // Create a hatch brush
         PDFHatchBrush hb = new PDFHatchBrush( HatchType.DiagonalCross ); hb.HatchColor = new PDFColor( Color.Aquamarine );
         hb.Color = new PDFColor( Color.Azure );
         hatchedLayer.Canvas.DrawRectangle2( redPen, hb, 100, 150, 200, 200 );

         // 2. Vertical gradient layer
         PDFLayer verticalGradientLayer = squareLayer.Canvas.Layers.Add( "Vertical gradient square" );
         // Create a vertical gradien brush
         PDFVerticalGradientBrush vgb = new PDFVerticalGradientBrush( );
         vgb.StartColor = new PDFColor( Color.Aquamarine );
         vgb.EndColor = new PDFColor( Color.Purple );
         verticalGradientLayer.Canvas.DrawRectangle2( redPen, vgb, 300, 150, 200, 200 );

         // 4. Horizontal gradient layer
         PDFLayer horizontalGradientLayer = squareLayer.Canvas.Layers.Add( "Horizontal gradient square" );
         // Create a horizontal gradient brush
         PDFHorizontalGradientBrush hgb = new PDFHorizontalGradientBrush( );
         hgb.StartColor = new PDFColor( Color.YellowGreen );
         hgb.EndColor = new PDFColor( Color.Violet );
         horizontalGradientLayer.Canvas.DrawRectangle2( redPen, hgb, 100, 350, 200, 200 );

         // 4. Solid layer
         PDFLayer solidLayer = squareLayer.Canvas.Layers.Add( "Solid square" );
         // Create a solid brush
         PDFBrush solidBrush = new PDFBrush( new PDFColor( Color.CornflowerBlue ) );
         solidLayer.Canvas.DrawRectangle2( redPen, solidBrush, 300, 350, 200, 200 );

         // create another layer on top of existing ones
         PDFLayer xLayer = page.Canvas.Layers.Add( "Green X" );
         PDFPen greenPen = new PDFPen( new PDFColor( Color.GreenYellow ), 32 );
         greenPen.LineCap = LineCap.Round;
         xLayer.Canvas.DrawLine( greenPen, 50, 100, 550, 600 );
         xLayer.Canvas.DrawLine( greenPen, 550, 100, 50, 600 );

         // Save the document to disk
         doc.SaveToFile( "layers.pdf" );
      }
   }
}

The results of the code above are displayed below:

All layers visible | Top level X layer and 2 child layers invisible | All layers invisible

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Form XObjects
A form XObject is a self contained graphic block. Its content is created like usual page content, using its own Canvas, and it can be painted multiple times on several pages in the same document or on several locations on the same page. The size of a form XObject is defined by its Width and Height properties, anything that falls outside the form XObject's rectangle is not visible. The coordinate system used by a form XObject has its origin in the top left corner. The form XObject has a Canvas property that allows to create its content, much like creating page content.
When a form XObject is drawn onto a page, its content is scaled and/or rotated to fit the given drawing rectangle.
The following sample shows how to create a simple form XObject and draw it multiple times on a page.
using System;
using System.IO;
using System.Drawing;
using System.Drawing.Imaging;
using System.Text;
using System.Net;
using System.Collections;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace Test
{

   class Test
   {

      [STAThread]
      static void Main(string[] args)
      {
         // Create the pdf document
         PDFDocument doc = new PDFDocument( );

         // Create one page
         PDFPage page = doc.AddPage( );

         PDFPen redPen = new PDFPen( new PDFColor( 255, 0, 0 ), 1 );
         PDFBrush darkBlueBrush = new PDFBrush( new PDFColor( 0, 0, 128 ) );

         // create a form XObject
         PDFFont font = new PDFFont( FontFace.Helvetica, 16 );
         string pdf4net = "PDF4NET";
         // the size of form xobject matches the text size
         PDFFormXObject form = new PDFFormXObject( );
         form.Width = font.MeasureString( pdf4net );
         form.Height = 16;
         // draw the text on the form xobject
         form.Canvas.DrawText( pdf4net, font, null, darkBlueBrush, 0, 0 );

         // draw the form XObject on the page.
         // strectch it to cover the whole page header and on the left margin
         page.Canvas.DrawFormXObject( form, 0, 0, page.Width, 24 );
         page.Canvas.DrawFormXObject( form, 32, 0, page.Height, 32, -90 );
         // draw the form XObject in its original size
         page.Canvas.DrawFormXObject( form, 50, 50, form.Width, form.Height );

         doc.SaveToFile( "formxobject.pdf" );
      }
   }
}

The result is displayed below:

The content of a form XObject is stored only once in the PDF file, no matter how many times it is drawn. This allows to reduce PDF file size when there are graphic patterns that repeat themselves on the same page or on several pages.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Custom brushes
The PDF4NET library provides support for custom brushes for filling closed paths. Both hatched brushes and gradient brushes are supported.

Hatched brushes

Hatched brushes allow filling closed paths with predefined patterns. The following patterns are available:

HatchType.BackwardDiagonal | HatchType.ForwardDiagonal | HatchType.Cross | HatchType.DiagonalCross | HatchType.Horizontal | HatchType.Vertical

Hatched brushes can be drawn either transparent (default) or opaque. To draw an opaque hatched pattern, set the Color property of the PDFHatchBrush object. Also, the color of the hatch pattern can be specified.
The following sample shows how to create a red hatched pattern with yellow background:
...
PDFHatchBrush hb = new PDFHatchBrush( HatchType.DiagonalCross );
hb.Color = new PDFColor( 255, 255, 0 ); // yellow background
hb.HatchColor = new PDFColor( 255, 0, 0 ); // red hatch
...
The result is displayed below:

The library allows to customize the distance between pattern's lines, both on vertical and on horizontal.
...
PDFHatchBrush hb = new PDFHatchBrush( HatchType.BackwardDiagonal );
hb.Color = new PDFColor( 255, 255, 0 ); // yellow background
hb.HatchColor = new PDFColor( 255, 0, 0 ); // red hatch
hb.HatchVerticalSize = 5;
hb.HatchHorizontalSize = 10;
...
The result is displayed below:

Gradient brushes

Gradient brushes can be used with any fillable path. They use linear gradients with 2 colors for filling the paths. Both horizontal and vertical gradients can be used with gradient brushes.
The following sample shows how to create a horizontal gradient:
...
PDFHorizontalGradientBrush hgb = new PDFHorizontalGradientBrush( );
hgb.StartColor = new PDFColor( Color.Red );
hgb.EndColor = new PDFColor( Color.Blue );
...
The result is displayed below:

The following sample shows how to create a vertical gradient:
...
PDFVerticalGradientBrush vgb = new PDFVerticalGradientBrush( );
vgb.StartColor = new PDFColor( Color.Green );
vgb.EndColor = new PDFColor( Color.Blue );
...
The result is displayed below:

Gradient brushes work only when using the default coordinate system (the point is the measure unit and the origin of the coordinate system is in the top left corner of the page).

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Transparency
PDF4NET library allows to define unlimited levels of transparency in a PDF file. Once a transparency level has been set in place, all subsequent drawing operations will use it. Only one transparency level can be active at a moment. The transparency levels vary from 0% (opaque) to 100% (full transparency).
The following sample shows how to draw lines of text, each one with its transparency level:
using System;
using System.IO;
using System.Drawing;
using System.Text;
using System.Collections;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace Test
{
   class Test
   {
      [STAThread]
      static void Main(string[] args)
      {
         // Create the pdf document
         PDFDocument doc = new PDFDocument();

         // Create the graphic objects
         PDFBrush blackBrush = new PDFBrush(new PDFColor());
         PDFFont font = new PDFFont(FontFace.Helvetica, 20);
         font.Bold = true;
         PDFPage page = doc.AddPage( );

         // generate random background
         Random rnd = new Random( );
         for( int i = 0; i < 50; i++ )
         {
            // Create random colors for drawing the spline
            PDFRgbColor penColor = new PDFRgbColor(
               (byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256));

            // Create the pen to draw the border
            PDFPen randomPen = new PDFPen( penColor, 1 );

            // Generate random control points
            float x1 = rnd.Next( ( int )page.Width );
            float y1 = rnd.Next( ( int )page.Height );
            float x2 = rnd.Next( ( int )page.Width );
            float y2 = rnd.Next( ( int )page.Height );
            float x3 = rnd.Next( ( int )page.Width );
            float y3 = rnd.Next( ( int )page.Height );
            float x4 = rnd.Next( ( int )page.Width );
            float y4 = rnd.Next( ( int )page.Height );

            // Draw the Bezier spline
            page.Canvas.DrawBezier( randomPen, x1, y1, x2, y2, x3, y3, x4, y4 );
         }

         float y = 100;
         // draw several strings, each one with its level of transparency
         for( int i = 0; i <=  10 0; i = i + 5)
         {
            page.Canvas.SetTransparency( i );
            page.Canvas.DrawText( "PDF4NET transparency sample", font, null, blackBrush, 120, y );
            y = y + 24;
         }

         doc.SaveToFile( "transparency.pdf" );
      }
   }
}

The result is displayed below:

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


TrueType / Type1 fonts / CJK Fonts
The PDF4NET library can use both TrueType/OpenType fonts and Type1 PostScript fonts.

TrueType/OpenType fonts

The TrueType/OpenType fonts can be used with PDF4NET library through TrueTypeFont class. These fonts are used in the same way the built in fonts are used. When a TrueTypeFont object is created, the path to the font file on disk must be provided. The font can be embedded or not in the pdf file.

When the TrueType font is embedded in the pdf file, the best results are obtained when the pdf file is viewed or printed, because the font data is available within the file.

When the TrueType font is not embedded in the pdf file, the pdf viewer will load the font, if available, from the local machine. If the font is not available on the local machine, the pdf viewer with substitute it with a font that matches the best the original font metrics.

At development time, the font must be present on the local machine, no matter the font will be embedded or not in the final pdf file, because the necessary metrics information must be extracted from the file. Because the library parses the font data in order to load the necessary metrics information, the font does not need to be installed on the local machine.

The following code snippet shows how to use a TrueType font:

...
TrueTypeFont ttf = new TrueTypeFont( "verdana.ttf", 12, true );
page.Canvas.DrawText( "This text uses Verdana font, size 12 and the font is embedded", ttf, pen, brush, 10, 10 );
...

The library allows to create a TrueTypeFont object based on an existing TrueTypeFont object. In this way, the second font object does not reparse the TrueType font file, and the font data is shared by both font objects. Because the Bold and Italic attributes are read from the font file, they are shared, so changing the Bold property for one font object causes the other font object to update its Bold property. These 2 properties are the only ones that are shared, all the other properties can be used without side effects.

When the font is embedded in the pdf file, the values of Bold and Italic properties are ignored, because the pdf viewer synthesize the correct font appearance based on the embedded font data. When the font is not embedded, these 2 properties are used to give the pdf viewer a hint about the font appearance.

The following code snippet shows how to create a TrueTypeFont object based on an existing one:

...
TrueTypeFont ttf2 = new TrueTypeFont( ttf, 16 );
page.Canvas.DrawText( "This text uses Verdana font, size 16", ttf2, pen, brush, 10, 50 );
...

The PDF4NET library provides support for Unicode characters, when using TrueType fonts. A Unicode TrueType font is created like in the sample below:

...
TrueTypeFont ttf = new TrueTypeFont( "verdana.ttf", 12, true, true );
page.Canvas.DrawText( "This text uses Unicode Verdana font, size 12 and the font is embedded", ttf, pen, brush, 10, 10 );
...

The 4th parameter of the constructor instructs the library to use Unicode features of the TrueType font.

A TrueType font can also be created from a System.Drawing.Font object. The following sample shows how to do it:

...
System.Drawing.Font fnt = new System.Drawing.Font( "verdana", 12 );
TrueTypeFont ttf = new TrueTypeFont( fnt, true, true );
page.Canvas.DrawText( "This text uses Unicode Verdana font, based on a System.Drawing.Font object, and the font is embedded", ttf, pen, brush, 10, 10 );
...

Type1 PostScript fonts

The Type1 PostScript fonts are used the same way (all that has been said above about TrueType fonts applies to Type1 fonts) like TrueType fonts, with one exception: when creating a PostScriptFont object, there are 2 files that define the font on disk. The PDF4NET library uses a .afm file (Adobe Font Metrics) or a .pfm file (Printer Font Metrics) to read font metrics, and a .pfb file (Printer Font Binary) to read font data.

The following code snippet shows how to use a Type1 font:

...
PostScriptFont psf = new PostScriptFont( "times-roman.afm", "times-roman.pfb", 12, true );
page.Canvas.DrawText( "This text uses Times-Roman postscript font, size 12 and the font is embedded", psf, pen, brush, 10, 10 );
...

CJK fonts

The PDF4NET library provides supports for CJK fonts based on Adobe Asian Language Pack. The following fonts are supported:
- Heisei Kaku Gothic W5 japanese font face (UniJIS-UCS2-H encoding).
- Heisei Mincho W3 japanese font face (UniJIS-UCS2-H encoding).
- Hanyang Systems Gothic Medium korean font face (UniKS-UCS2-H encoding).
- Hanyang Systems Shin MyeongJo Medium korean font face (UniKS-UCS2-H encoding).
- Monotype Hei Medium chinese traditional font face (UniCNS-UCS2-H encoding).
- Monotype Sung Light chinese traditional font face (UniCNS-UCS2-H encoding).
- SinoType Song Light chinese simplified font face (UniGB-UCS2-H encoding).

The following code snippet shows how to use a CJK font:

...
CJKFont cjk = new CJKFont( CJKFontFace.HeiseiKakuGothicW5, 12 );
page.Canvas.DrawText( "PDF4NET はあらゆるNET のアプリケーションからPDF 文書をオンザフラ", psf, pen, brush, 10, 10 );
...

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Update existing pdf files
With PDF4NET library, existing pdf files can be updated to include new content. The library can add new pages to an existing document, at any location, in front of existing pages, in the middle or at the end of the imported document. Adding new content to an existing page is the same like adding content to a new page. The new content is drawn on top of existing content. The existing content of a page can not me changed.

To import a pdf document in PDF4NET library, the following constructor should be used: PDFDocument( string pdfFile ); where the pdfFile parameter is the full path to a pdf file on disk. After the constructor is executed, the Pages collection of PDFDocument object contains a PDFPage object for each page in the source pdf file. The pages of the imported document can be accessed using the index based PDFDocument.Pages collection. Pages[0] is the first page of the document, while Pages[Pages.Count-1] is the last page of the document. New pages can be added anywhere in the document.

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.Save( "new.pdf" );
...

The next sample code shows how to create a new page at the beginning of the imported file, then it draws a line of text on it.
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
// create a new page at the beginning of the document (insert it at index 0)
PDFPage page = doc.InsertPage( 0 );
page.Canvas.DrawText( "This is a new page", font, null, brush, 10, 10 );
doc.Save( "new.pdf" );
...

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF Editing
PDF4NET library allows to perfom a wide range of operations on existing pdf files. The library allows to merge multiple pdf files or to split a pdf file to individual pages, it allows to apply security to existing pdf files. It also allows to extract full pages or their content from a pdf file. All the methods dealing with pdf editing capabilities are located in the O2S.Components.PDF4NET.PDFFile namespace and PDFFile class implements all these operations.

Merging pdf files

Multiple pdf files can be merged at once with a single line of code. The resulted pdf file can be automatically saved to disk, or it can be used further in the application to add new content.
The following 2 methods are available for merging pdf files:
public static void MergeFiles( string destFileName, string[] srcFileNames );
This method allows to merge multiple pdf files into a single one that is automatically saved to disk. The source pdf files are provided in a string array. They are merged in the order they appear in the array. The resulted pdf file is saved to the file specified by destFileName parameter.
public static PDFDocument MergeFiles( string[] srcFileNames );
This method allows to merge multiple pdf files into a single one and returns the corresponding PDFDocument object to be further used in the application. The source pdf files are provided in a string array. They are merged in the order they appear in the array. The resulted pdf file is returned as a PDFDocument object.
Sample
The following sample shows how to append 2 pdf files:
PDFFile.MergeFiles( "append.pdf", new string[]{ "unicode.pdf", "multicolumntextandimages.pdf" } );

or

PDFDocument doc = PDFFile.MergeFiles( new string[]{ "unicode.pdf", "multicolumntextandimages.pdf" } );
doc.Save( stream );

Splitting pdf files

A pdf file can be splitted to individual pages and each pdf file corresponding to a page saved to disk.
The following method is available for splitting pdf files:
public static void SplitFile( string srcFileName, string destFileName );
This method allows to merge split a pdf file into a single pages that are automatically saved to disk. The source pdf file is specified by srcFileName parameter. The destFileName parameter is used to construct the name of each page. At the end of the name a suffix representing the page number is appended.
Sample
The following sample shows how to split a pdf file to single pages:
...
PDFFile.SplitFile( "unicode.pdf", "unicode-page.pdf" );
...

Applying security to existing pdf files

Existing pdf files can be secured at once with a single line of code. The resulted pdf file can be automatically saved to disk, or it can be used further in the application to add new content.
The following 2 methods are available for applying security to an existing pdf file:
public static void EncryptFile( PDFSEcurityManager securityManager, string srcFileName, string destFileName );
This method allows to encrypt a pdf file that is automatically saved to disk. The source pdf file specified by srcFileName parameter. The resulted pdf file that is encrypted is saved to the file specified by destFileName parameter. The security settings are specified by the securityManager parameter.
public static PDFDocument EncryptFile( PDFSEcurityManager securityManager, string srcFileName );
This method allows to encrypt a pdf file and returns the corresponding PDFDocument object to be further used in the application. The source pdf file specified by srcFileName parameter. The resulted pdf file is returned as a PDFDocument object. The security settings are specified by the securityManager parameter.

Sample
The following sample shows how to encrypt a pdf file:
PDFSecurityManager securityManager = new PDFSecurityManager( );
securityManager = securityManager;
securityManager.KeySize = EncryptionKeySize.Use128BitKey;
securityManager.UserPassword = Encoding.ASCII.GetBytes( "userpass" );
securityManager.OwnerPassword = Encoding.ASCII.GetBytes( "ownerpass" );
securityManager.AllowPrint = false;
securityManager.FullQualityPrint = true;
securityManager.AllowModifyDocument = false;
securityManager.AllowExtractContent = false;
securityManager.AllowInteractiveEdit = false;
securityManager.AllowFormsFill = true;
securityManager.AllowAccessibilityExtractContent = true;
securityManager.AllowAssembleDocument = false;

PDFFile.EncryptFile( securityManager, "unicode.pdf", "unicode_secure.pdf" );

// or

PDFDocument doc = PDFFile.EncryptFile( securityManager, "unicode.pdf" );
doc.Save( stream );

Page and content extraction

PDF4NET library allows to extract both full pages and page content only from existing pdf files. The difference between these 2 features is that a full page can be inserted as it is in a new document and includes annotations, links and form fields, while the page content can be drawn on any new page, rotated and scaled. Multiple extracted page contents can be placed on a single new page (page imposition). Page content is extracted as a binary block, not as single items (images, text, drawing primitives)
The following methods are available for extracting pages from an existing pdf file:
public PDFImportedPage ExtractPage( int pageNumber );
This method extracts a single page from a pdf document and returns the corresponding PDFImportedPage object. pageNumber is zero based index.
public PDFImportedPage[] ExtractPages( string pageNumbers );
This method extracts a set of pages from a pdf document and returns an array of PDFImportedPage objects.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.
An imported page can be added to a new pdf document using the AddPage( PDFPage page ) method of PDFDocument class.
The PDF4NET library can extract pages and content from encrypted PDF file. The overloaded FromFile method of PDFFile class accepts a password (user or owner password) as its second parameter.
Sample
The following sample shows how to mix 2 pdf files:
PDFFile unicodeFile = PDFFile.FromFile( "unicode.pdf" );
PDFFile mctiFile = PDFFile.FromFile( "multicolumntextandimages.pdf" );
PDFImportedPage ip = null;

PDFDocument doc = new PDFDocument( );
for( int i = 0; i < 4; i++ )
{
    // extract the page
    ip = unicodeFile.ExtractPage( i );

    // add the page to new document
    doc.AddPage( ip );

    // extract the page
    ip = mctiFile.ExtractPage( i );

    // add the page to new document
    doc.AddPage( ip );
}

// save the mixed document
doc.Save( "mix.pdf" );

unicodeFile.Close( );
mctiFile.Close( );

The following methods are available for extracting page content from an existing pdf file:
public PDFImportedContent ExtractPageContent( int pageNumber );
This method extracts a single page content from a pdf document and returns the corresponding PDFImportedContent object. pageNumber is zero based index.
public PDFImportedContent[] ExtractPagesContent( string pageNumbers );
This method extracts a set of pages content from a pdf document and returns an array of PDFImportedContent objects.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.
Imported content is drawn on a new page using the DrawImportedContent method of PDFCanvas class.

Sample
The following sample shows how to place the content of 4 pages on a single new page:
PDFFile mctiFile = PDFFile.FromFile( "multicolumntextandimages.pdf" );
// extract the content of first 4 pages
PDFImportedContent[] ic = mctiFile.ExtractPagesContent( "0-3" );

// create the new document
PDFDocument doc = new PDFDocument( );
// add a page to it
PDFPage page = doc.AddPage( );

// draw the imported content (4 pages) on the new page
page.Canvas.DrawImportedContent( ic[0], 0, 0, page.Width/2, page.Height/2 );
page.Canvas.DrawImportedContent( ic[1], page.Width/2, 0, page.Width/2, page.Height/2 );
page.Canvas.DrawImportedContent( ic[2], 0, page.Height/2, page.Width/2, page.Height/2 );
page.Canvas.DrawImportedContent( ic[3], page.Width/2, page.Height/2, page.Width/2, page.Height/2 );

// save the mixed document
doc.Save( "imposition.pdf" );

mctiFile.Close( );

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Automatic page numbering
The PDF4NET library offers the possibility of numbering document's pages in an automated way. The developer can customize the way the page number is displayed on document's pages. The visual aspect of page number can be customized for each page, if desired. Also, the developer can set up numbering schemes (also known as numbering ranges), associating a numbering range with a set of consecutive pages in the document. The pages covered by a numbering range share the same numbering system. A numbering range starts from a page in the document and ends where the next numbering range starts, or at the end of the document. The start of a numbering range is defined by the index of first page in range. This index a document global index and represents the position of the page in document's Pages collection. This index is 0 based. The first page of the document has 0 index, the second page has 1 index, the third page has 2 index, and so on. This index is not the same with the page number. While for some documents they may coincide, generally they do not match. The page index always starts at 0 for the first page and runs consecutively through the document, while the page numbers can start with any value that is appropriate for the document's logical structure. For example, a document may have an introduction of 10 pages numbered in roman numerals, while the rest of the document is numbered using arabic numerals. The first page in the document has index 0 and page number i, the tenth page in the document has index 9 and page number x, and the eleventh page has index 10 and page number 1. The previous example assumes that 2 numbering ranges have been defined for the document, one starting at index 0 with roman numbering system, and another starting at index 10 with arabic numbering system.

Implementation

The automatic page numbering features of PDF4NET library are implemented by 2 classes:.

- PDFPageNumberingRange - defines a numbering range.

- PDFPageNumber - defines the visual aspect of the page number as it is printed on the page.

PDFPageNumberingRange
A numbering range defines a common numbering system for a set of consecutive pages. A numbering range is characterized by the following properties:
- start page index - the index of the page where the numbering range starts
- start page number - the value of the page number for the first page in range. For the rest of the pages in range, this value is incremented accordingly with page's position in range. For example, the page number for the first page in a range in 10, then for the second page it is 11, for the third page it is 12, and so on.
- numbering style - defines the numbering system for the range. It can be roman numbering system or arabic numbering system. For roman numbering system, uppercase or lowercase letters can be used.
- page prefix - a string the will be displayed in front of the page number when it is printed on the page. For example, for a range the string "Chapter 1 - " is defined as prefix and the page number starts at 1. When the page numbers are drawn on the page, they will look like this: Chapter 1 - 1 for the first page, Chapter 1 - 2 for the second page, and so on.
The following sample source code numbers the document in the following way: introduction on first 10 page with roman numbering system, and the rest of the pages with arabic numbering system
...
PDFPageNumberingRange pnr1 = new PDFPageNumberingRange();
pnr1.StartPageIndex = 0;
pnr1.StartPageNumber = 1;
pnr1.NumberingStyle = NumberingStyle.LowerCaseRoman;
PDFPageNumberingRange pnr2 = new PDFPageNumberingRange();
pnr2.StartPageIndex = 10;
pnr2.StartPageNumber = 1;
pnr2.NumberingStyle = NumberingStyle.Arabic;
doc.PageNumberingRanges.Add(pnr1);
doc.PageNumberingRanges.Add(pnr2);
...

PDFPageNumber
This class defines the visual aspect of the printed page number. A page number is characterized by the following properties:
- font - the font used to draw the page number.
- pen - the pen used to draw the border of the text representing the page number.
- brush - the brush used to fill the interior of the text representing the page number.
- align - the alignment of the page number when it is drawn on the page.
- vertical offset and horizontal offset - these 2 values are dependent on the type of alignment of the page number. When the page number is left aligned on horizontal, the horizontal offset represents the distance between the left margin of the page and the left margin of the text. When the page number is right aligned on horizontal, the horizontal offset represents the distance between the right margin of the page and the right margin of the text. When the page number is center aligned on horizontal, the horizontal offset is not used, the page number is positioned in the center of the page, on horizontal. When the page number is top aligned on vertical, the vertical offset represents the distance between the top margin of the page and the top margin of the text. When the page number is bottom aligned on vertical, the vertical offset represents the distance between the bottom margin of the page and the bottom margin of the text. When the page number is middle aligned on vertical, the vertical offset is not used, the page number is positioned in the middle of the page, on vertical.
The page number appearance can be customized separately for each page of the document.

Note: The page number is printed on a page only if the page belongs to a numbering range and it has defined a page number (the Number property of the page is not null).

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Creating document's bookmarks tree
To ease navigation in large documents, pdf files may display a document outline in the viewer, allowing the user to navigate from one page to another. The document outline consists of a tree like hierarchy of bookmark items. This tree hierarchy serves as a visual table of content that display the structure of the document to the user. Each node in the outline can be open or closed with the mouse. When a node is open, its immediate children are displayed. Each child can be open or closed, revealing further the parts of the hierarchy. When an item is clicked, the viewer displays the destination page associated with the item. In fact, a bookmark item acts like an internal link, the difference is that the document bookmarks are displayed in a separate navigation page, and both the document and its bookmarks can be visible at the same time.

The document bookmarks are displayed using a viewer selected font, but the document can specify whether a bookmark item should be displayed bold and/or italic. Also, the document can choose a different color for each bookmark item.

In the PDF4NET object model an outline item is represented by PDFBookmark class. Each bookmark has a Bookmarks collection which represents its immediate children. The document object also holds a Bookmarks collection. The bookmark items in this collection represent the top level items in the hierarchy.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Linking to other content
PDF files may include hyperlinks to various content. This content can be internal or external to the document. A hyperlink is defined by a rectangular area on the page.

Depending on the type of the referred content, the hyperlinks can be divided in 4 categories:

1. Internal document links - these links point to pages in the same document. These links can be created using PDFAreaDocLink / PDFTextDocLink classes. When creating an internal link, the destination page and a vertical offset must be specified. The vertical offset is used to position the destination page when it is open in the viewer as a result of using the link. If the vertical offset is 0, then the page is displayed at top, and if it is page.Height/2 then the page is displayed starting from middle. This positioning is dependent on the screen resolution, if the screen resolution allows the display of a full page, then the value of the vertical offset does not matter because the destination page will be always displayed in full. If the screen resolution does not allow the display of a full page and you have to scroll up and down to view the page, then the vertical offset works. The vertical offset is set using the TopDestination property of the document link classes.
When an internal link is clicked, the destination page is displayed in the viewer and it is positioned as specified by the vertical offset.

2. External document links - these links point to other pdf files. These links can be created using PDFAreaRemoteDocLink / PDFTextRemoteDocLink classes. When creating an external document link, the path to the destination pdf document must be specified. If the path is a relative one, then it is considered relative to the location of the current document.
When an external document link is clicked, the destination pdf file is loaded in the viewer.

3. External file links - these links point to other types of files. These links can be created using PDFAreaFileLink / PDFTextFileLink classes. When creating an external file link, the path to the destination file must be specified. If the path is a relative one, then it is considered relative to the location of the current document.
When an external file link is clicked, the destination file is launched or it is opened by its associated application.

4. Web links - these links point to web locations. These links can be created using PDFAreaWebLink / PDFTextwebLink classes. When creating a web link, the URL of the web location file must be specified.
When a web link is clicked, the URL is opened in the browser.

The PDF4NET library allows the creation of all 4 types of links. Each type of link comes in 2 flavours: a rectangular link and a text link.

- rectangular links are defined by a rectangular area on the page. When the user clicks inside the rectangle, he is taken to the corresponding destination.

- text links are a specialized version of the rectangular links. In fact, they are rectangular links, but the library calculates the rectangular area automatically, as the bounding rectangle of the text.

Neither types of links can be displayed rotated.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Document metadata
PDF files can store general information about the document itself. They also can control the way they are displayed when they are open in the viewer.

Document information

A PDF file may store information about the document, such as document's title, subject, etc. This information can be searched by external applications for different purposes.

You can access this information using the DocumentInformation property of the document class. The value of this property is an instance of PDFDocumentInformation class. All the information fields can be accessed using the properties of DocumentInformation object. The following items can be used:

- Title (read/write)

- Author (read/write)

- Subject (read/write)

- Keywords (read/write)

- Creator (read/write) - the application that is creating the pdf file.

- Producer (read only) - this property always evaluates to "PDF4NET (http://www.pdf4net.com/)".

This information is displayed in Document Info window in Adobe's viewers.

Viewer preferences

A PDF file can control the way the document is presented on the screen when it is open in the viewer. The following customizations of the viewer can be performed when a document is open:

- hide toolbar - when the document is open, the toolbar can be made invisible.

- hide menu bar - when the document is open, the menu bar can be made invisible.

- hide viewer user interface - when the document is open, the whole viewer user interface can be made invisible.

- fit window - when the document is open, the document's window can be resized to fit the size of first displayed page.

- center window - when the document is open, the document's window can be placed in the center of the screen.

- display document title - when the document is open, the document's title is displayed in the titlebar of the viewer, instead of file's name.

These properties can be accessed using the ViewerPreferences property of the document class. The value of this property is an instance of PDFViewerPreferences class.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF Security and encryption
PDF4NET library allows to create secure pdf documents, with support for user and owner passwords, document encryption and document access rights.

The following options are available when creating a secure document:

Encryption - pdf documents can be encrypted using 40 bit or 128 bit keys. PDF4NET library supports both key types.

User and owner password - pdf documents can be protected using 2 passwords: a user password and an owner password. The user password allows a user to view the document and the access to document is restricted based on the access rights that have been set. The owner password allows a user to get full control over the pdf document. When both password are identical, the user is considered to log in as owner.

Access rights - the following access rights can be set on a pdf document:
Allow Print - this flag, together with FullQualityPrint flag and encryption key size, controls the printing of the document. If this flag is not set, then the user is not allowed to print the document. If this property is true, then the user is allowed to print the document, depending on the value of FullQualityPrint flag and encryption key size. If encryption key size is 40 bit then FullQualityPrint flag property is ignored. If encryption key size is 128 bit then if FullQualityPrint flag is set, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.
Full Quality Print - This property has effect only when AllowPrint flag is set and encryption key size is 128 bit. If this flag is set, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.
Allow Modify Document - This flag, if set, allows a user to modify the content of pdf document by operations other than those controlled by the following flags: Allow Interactive Edit, Allow Forms Fill, Allow Assemble Document.
Allow Interactive Edit - This flag, if set, allows a user to add or modify text annotations, fill in interactive forms fields, and, if AllowModifyDocument flag is set, create or modify interactive form fields (including signature fields).
Allow Forms Fill - This flag has effect only when using 128 bit encryption. This flag, if set, allows a user to fill in existing interactive form fields (including signature fields), even the Allow Interactive Edit flag is not set.
Allow Assemble Document - This flag has effect only when using 128 bit encryption This flag, if set, allows a user to assemble the document (insert, rotate, or delete pages and create bookmarks or thumbnail images), even the Allow Modify Document flag is not set.
Allow Extract Content - When using 128 bit encryption this flag, if set, allows a user to copy or otherwise extract text and graphics from the document by operations other than those controlled by AllowAccessibilityExtractContent flag. When using 40 bit encryption, then this flag also controls extraction of text and graphics in support of accessibility to disabled users or other purposes.
Allow Accessibility Extract Content - This property has effect only when using 128 bit encryption This flag, if set, allows a user to copy or otherwise extract text and graphics from the document in support of accessibility to disabled users or for other.

The PDF security and encryption are implemented by PDFSecurityManager class. It exposes properties for setting the encryption key size, the user and owner passwords and the above access rights. A pdf document is encrypted automatically when the SecurityManager property of a PDFDocument object is set to a valid instance of PDFSEcurityManager class.

The following sample shows how to set the security over a pdf file:
...
// Create the pdf document
PDFDocument doc = new PDFDocument( );

// set the security options
doc.SecurityManager = new PDFSecurityManager( );
// use 128 bit encryption
doc.SecurityManager.KeySize = EncryptionKeySize.Use128BitKey;
// set user password to "userpass"
doc.SecurityManager.UserPassword = Encoding.ASCII.GetBytes( "userpass" );
// set owner password to "ownerpass"
doc.SecurityManager.OwnerPassword = Encoding.ASCII.GetBytes( "ownerpass" );
// allow to print the pdf document
doc.SecurityManager.AllowPrint = true;
// do not allow high quality print
doc.SecurityManager.FullQualityPrint = false;
// do not alow to modify the document
doc.SecurityManager.AllowModifyDocument = false;
// do not allow to extract content (text and images) from the document
doc.SecurityManager.AllowExtractContent = false;
// do not allow to fill forms or to create annotations
doc.SecurityManager.AllowInteractiveEdit = false;
// do not allow forms fill
doc.SecurityManager.AllowFormsFill = false;
// allow to extract content in support for accessibility
doc.SecurityManager.AllowAccessibilityExtractContent = true;
// do not allow to assemble document
doc.SecurityManager.AllowAssembleDocument = false;
...
...
doc.SaveToFile( "encrypted.pdf" );

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF Actions
In a PDF file, the target of a bookmark can be an action to be performed when the bookmark is selected. Also, actions can be executed automatically when a document is opened or when a page is displayed.
The following actions are supported by PDF4NET library:

GoTo actions

A GoTo action (PDFGoToAction class) displays a specified page in the current document. A position and a magnification factor can be specified for the destination page.

The sample below shows a GoTo action that displays the second page of the document at the top using a magnification factor of 800%:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create two pages
     doc.AddPage( );
     doc.AddPage( );

     /// OpenDocument action
     // Create an action to be executed when the document is opened
     // The action will open the document at the
     // second page of the document using a 800% zoom
     PDFGoToAction goToAction = new PDFGoToAction( );
     goToAction.Page = doc.Pages[1];
     goToAction.MagnificationMode = PDFMagnificationMode.XYZ;
     goToAction.Left = 0;
     goToAction.Top = 0;
     goToAction.Zoom = 800;

     // set the action on the document
     doc.OpenAction = goToAction;
     /// OpenDocument action

     // Save the document to disk
     doc.Save( "actions.pdf" );
}

Remote GoTo actions

A Remote GoTo action (PDFRemoteGoToAction class) displays a specified page in an external pdf document. A position and a magnification factor can be specified for the destination page.

The sample below shows a Remote GoTo action that displays the second page of the "second.pdf" document at the top using a magnification factor of 800%:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a remote GoTo action
     PDFRemoteGoToAction remoteGoToAction = new PDFRemoteGoToAction( );
     // the page number is zero based
     remoteGoToAction.PageNumber = 1;
     remoteGoToAction.RemoteFile = "second.pdf";

     // create a bookmark to point to the "second.pdf"
     PDFBookmark bk = new PDFBookmark("External pdf document", new PDFColor( ), false, OutlineDisplay.Regular, remoteGoToAction);

     // add the bookmark to the document
     doc.Bookmarks.Add(bk);

     // Save the document to disk
     doc.Save( "actions.pdf" );
}

JavaScript actions

A JavaScript action (PDFJavaScriptAction class) allows execution of javascript code embedded in the pdf document.

The sample below shows a JavaScript action that prints the document:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a javascript action to print the document
     PDFJavaScriptAction jsAction = new PDFJavaScriptAction( );
     jsAction.Script = "this.print(true);\n";

     // create a bookmark to execute the action
     PDFOutline js = new PDFOutline( "Print me from JavaScript", new PDFColor( ), false, OutlineDisplay.Regular, jsAction );

     // add the bookmark to the document
     doc.Outlines.Add( js );

     // Save the document to disk
     doc.Save( "actions.pdf" );
}

Launch actions

A Launch action (PDFLaunchAction class) allows execution of an external application or file.

The sample below shows a Launch action that launches Microsoft Word:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a Launch action to start the MS Word application
     PDFLaunchAction launchAction = new PDFLaunchAction( );
     launchAction.File = "msword.exe";

     // create a bookmark to execute the action
     PDFBookmark bk = new PDFBookmark( "Start me", new PDFColor( ), false, OutlineDisplay.Regular, launchAction );

     // add the bookmark to the document
     doc.Outlines.Add(bk);

     // Save the document to disk
     doc.Save( "actions.pdf" );
}

Named actions

A Named action (PDFNamedAction class) allows execution of predefined PDF actions. The following predefined PDF actions are available: go to next page, go to prev page, go to first page, go to last page.

The sample below shows a Named action that displays the last page of the document:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a Named action to display the last page of the document
     PDFNamedAction namedAction = new PDFNamedAction( );
     namedAction.NamedAction = NamedAction.LastPage;

     // create a bookmark to execute the action
     PDFOutline ol = new PDFOutline( "Go to last page", new PDFColor( ), false, OutlineDisplay.Regular, namedAction );

     // add the bookmark to the document
     doc.Outlines.Add( ol );

     // Save the document to disk
     doc.SaveToFile( "actions.pdf" );
}

URI actions

A URI action (PDFURIAction class) allows to display a hypertext link in a web browser.

The sample below shows an URI action that displays the O2 Solutions homepage in the browser:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a URI action to display the O2 Solutions homepage
     PDFURIAction uriAction = new PDFURIAction( );
     uriAction.URI = "http://www.o2sol.com/";

     // create a bookmark to execute the action
     PDFBookmark bk = new PDFBookmark( "www.o2sol.com", new PDFColor( ), false, OutlineDisplay.Regular, uriAction );

     // add the bookmark to the document
     doc.Bookmarks.Add(bk);

     // Save the document to disk
     doc.Save( "actions.pdf" );
}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Annotations
PDF4NET library provides support for adding annotations both to existing and newly created PDF files. The following annotation types are supported: circle annotation, file attachment annotation (for embedding files into a PDF file), line annotation, markup annotation, movie annotation, rubber stamp annotation, square annotation and text annotation. Each annotation allows to control its opacity. The annotation's opacity can vary from 0 (fully transparent) to 100 (opaque).

The following sample shows how to create several types of annotations:

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Annotations;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET.Annotations
{
   /// <summary>
   /// This sample shows all annotations that can be created with PDF4NET.
   /// </summary>
   class Annotations
   {
      /// <summary>
      /// The main entry point for the application.
      /// </summary>
      [STAThread]
      static void Main(string[] args)
      {
         // Create the pdf document
         PDFDocument doc = new PDFDocument( );

         // Create one page
         PDFPage page = doc.AddPage( );

         PDFBrush blackBrush = new PDFBrush( new PDFColor( 0, 0, 0 ) );
         PDFFont fontSection = new PDFFont( FontFace.Helvetica, 10 );
         fontSection.Bold = true;
         PDFFont fontText = new PDFFont( FontFace.Helvetica, 8 );

         page.Canvas.DrawText( "Text annotations", fontSection, null, blackBrush, 20, 45, 0, TextAlign.BottomLeft );
         // Create all available text annotations
         PDFTextAnnotation ta = new PDFTextAnnotation( "Comment", "Comment annotation" );
         ta.Icon = TextAnnotationIcon.Comment;
         ta.Rectangle = new RectangleF( 20, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Comment", fontText, null, blackBrush, 20, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Help", "Help annotation" );
         ta.Icon = TextAnnotationIcon.Help;
         ta.Rectangle = new RectangleF( 100, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Help", fontText, null, blackBrush, 100, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Insert", "Insert annotation" );
         ta.Icon = TextAnnotationIcon.Insert;
         ta.Rectangle = new RectangleF( 180, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Insert", fontText, null, blackBrush, 180, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Key", "Key annotation" );
         ta.Icon = TextAnnotationIcon.Key;
         ta.Rectangle = new RectangleF( 260, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Key", fontText, null, blackBrush, 260, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "New paragraph", "New paragraph annotation" );
         ta.Icon = TextAnnotationIcon.NewParagraph;
         ta.Rectangle = new RectangleF( 340, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "New paragraph", fontText, null, blackBrush, 340, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Note", "Note annotation" );
         ta.Icon = TextAnnotationIcon.Note;
         ta.Rectangle = new RectangleF( 420, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Note", fontText, null, blackBrush, 420, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Paragraph", "Paragraph annotation" );
         ta.Icon = TextAnnotationIcon.Paragraph;
         ta.Rectangle = new RectangleF( 500, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Paragraph", fontText, null, blackBrush, 500, 80, 0, TextAlign.TopLeft );

         // Rubber stamp annotations

         page.Canvas.DrawText( "Rubber stamp annotations", fontSection, null, blackBrush, 20, 120, 0, TextAlign.TopLeft );
         // Create all available rubber stamp annotations
         PDFRubberStampAnnotation rsa = new PDFRubberStampAnnotation( "Approved", "Approved annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Approved;
         rsa.Rectangle = new RectangleF( 20, 140, 100, 30 );
         rsa.Opacity = 50;
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Approved", fontText, null, blackBrush, 20, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "As Is", "As Is annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Asis;
         rsa.Rectangle = new RectangleF( 120, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "As Is", fontText, null, blackBrush, 120, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Confidential", "Confidential annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Confidential;
         rsa.Rectangle = new RectangleF( 220, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Confidential", fontText, null, blackBrush, 220, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Departmental", "Departmental annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Departmental;
         rsa.Rectangle = new RectangleF( 320, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Departmental", fontText, null, blackBrush, 320, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Draft", "Draft annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Draft;
         rsa.Rectangle = new RectangleF( 420, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Draft", fontText, null, blackBrush, 420, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Experimental", "Experimental annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Experimental;
         rsa.Rectangle = new RectangleF( 520, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Experimental", fontText, null, blackBrush, 520, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Expired", "Expired annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Expired;
         rsa.Rectangle = new RectangleF( 20, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Expired", fontText, null, blackBrush, 20, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Final", "Final annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Final;
         rsa.Rectangle = new RectangleF( 120, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Final", fontText, null, blackBrush, 120, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "ForComment", "ForComment annotation" );
         rsa.Icon = RubberStampAnnotationIcon.ForComment;
         rsa.Rectangle = new RectangleF( 220, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "ForComment", fontText, null, blackBrush, 220, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "ForPublicRelease", "ForPublicRelease annotation" );
         rsa.Icon = RubberStampAnnotationIcon.ForPublicRelease;
         rsa.Rectangle = new RectangleF( 320, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "ForPublicRelease", fontText, null, blackBrush, 320, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "NotApproved", "NotApproved annotation" );
         rsa.Icon = RubberStampAnnotationIcon.NotApproved;
         rsa.Rectangle = new RectangleF( 420, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "NotApproved", fontText, null, blackBrush, 420, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "NotForPublicRelease", "NotForPublicRelease annotation" );
         rsa.Icon = RubberStampAnnotationIcon.NotForPublicRelease;
         rsa.Rectangle = new RectangleF( 520, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "NotForPublicRelease", fontText, null, blackBrush, 520, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Sold", "Sold annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Sold;
         rsa.Rectangle = new RectangleF( 20, 260, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Sold", fontText, null, blackBrush, 20, 300, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "TopSecret", "TopSecret annotation" );
         rsa.Icon = RubberStampAnnotationIcon.TopSecret;
         rsa.Rectangle = new RectangleF( 120, 260, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "TopSecret", fontText, null, blackBrush, 120, 300, 0, TextAlign.TopLeft );

         // Line annotations

         page.Canvas.DrawText( "Line annotations", fontSection, null, blackBrush, 20, 350, 0, TextAlign.TopLeft );
         PDFLineAnnotation la = new PDFLineAnnotation( "Line", "Line annotation" );
         la.BeginLineStyle = LineEndingStyle.Circle;
         la.EndLineStyle = LineEndingStyle.OpenArrow;
         la.Rectangle = new RectangleF( 20, 370, 150, 30 );
         la.Border = new PDFAnnotationBorder( 1, BorderStyle.Solid );
         la.BorderColor = new PDFColor( Color.Red );
         la.InteriorColor = new PDFColor( Color.CornflowerBlue );
         page.Annotations.Add( la );
         page.Canvas.DrawText( "Line annotation with a circle and open arrow", fontText, null, blackBrush,
            20, 420, 0, TextAlign.TopLeft );

         // File attachment annotations

         page.Canvas.DrawText( "File attachment annotations", fontSection, null, blackBrush, 20, 480, 0, TextAlign.TopLeft );
         // Create all available file attachment annotations
         PDFFileAttachmentAnnotation faa = new PDFFileAttachmentAnnotation( "Graph", "Graph icon" );
         faa.Icon =FileAttachmentAnnotationIcon.Graph;
         faa.Rectangle = new RectangleF( 20, 500, 100, 30 );
         faa.Compress = true;
         faa.File = "sample.pdf";
         page.Annotations.Add( faa );
         page.Canvas.DrawText( "Graph", fontText, null, blackBrush, 20, 530, 0, TextAlign.TopLeft );

         faa = new PDFFileAttachmentAnnotation( "Paperclip", "Paperclip icon" );
         faa.Icon =FileAttachmentAnnotationIcon.Paperclip;
         faa.Rectangle = new RectangleF( 100, 500, 100, 30 );
         faa.Compress = true;
         faa.File = "sample.pdf";
         page.Annotations.Add( faa );
         page.Canvas.DrawText( "Paperclip", fontText, null, blackBrush, 100, 530, 0, TextAlign.TopLeft );

         faa = new PDFFileAttachmentAnnotation( "PushPin", "PushPin icon" );
         faa.Icon =FileAttachmentAnnotationIcon.PushPin;
         faa.Rectangle = new RectangleF( 180, 500, 100, 30 );
         faa.Compress = true;
         faa.File = "sample.pdf";
         page.Annotations.Add( faa );
         page.Canvas.DrawText( "PushPin", fontText, null, blackBrush, 180, 530, 0, TextAlign.TopLeft );

         faa = new PDFFileAttachmentAnnotation( "Tag", "Tag icon" );
         faa.Icon =FileAttachmentAnnotationIcon.Tag;
         faa.Rectangle = new RectangleF( 260, 500, 100, 30 );
         faa.Compress = true;
         faa.File = "sample.pdf";
         page.Annotations.Add( faa );
         page.Canvas.DrawText( "Graph", fontText, null, blackBrush, 260, 530, 0, TextAlign.TopLeft );

         // Save the document to disk
         doc.Save( "annotations.pdf" );
      }
   }
}

The result is displayed below:

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF Forms
This section shows how to use PDF4NET library when working with PDF forms.
Interactive forms allows to collect input from user. The PDF specification, starting with PDF 1.5, supports 2 types of interactive forms: AcroForms and XFA Forms.

AcroForms

AcroForms are available starting with PDF 1.2. They evolved as the PDF specification evolved, and now complex business scenarios can be developed using AcroForms.
The following form field types are supported in AcroForms:
• textboxes - single and multi line
• pushbuttons
• checboxes
• radiobuttons
• dropdown lists
• listboxes
Form fields can be enhanced with JavaScript actions for data formatting and validation, or for interoperability with external data sources, such as SOAP webservices.
PDF4NET library supports both creating new AcroForms and reading and filling existing AcroForms.

XFA Forms

XFA Forms are available starting with PDF 1.5, but they become widely used starting with PDF 1.6. They are the new generation of PDF forms that follow the Adobe's XML Forms Architecture. They are more complex that AcroForms and they have features that are not available in AcroForms.
The following form field types are supported in XFA Forms:
• text fields - single and multi line
• password fields
• numeric fields
• date and time fields
• pushbutton fields
• checkbutton fields
• radiobutton lists
• choice fields - both drop down and list
• image fields
• barcode fields
Form fields can be enhanced with JavaScript or FormCalc scripts for data formatting, validation and complex calculations, or for interoperability with external data sources, such as databases and SOAP web services.
PDF4NET library supports reading and filling existing XFA Forms, all the above field types being supported.

Working with interactive forms

The PDF4NET library allows to accomplish a variety of form related tasks when working PDF forms.
• Create AcroForms - shows how to create AcroFroms using the object model available in PDF4NET library.
• Read and fill AcroForms - shows how to read values from AcroForms and how to fill fields in AcroForms.
• Read and fill XFA Forms - shows how to read values from XFA Forms and how to fill fields in XFA Forms.
• Data import/export - shows how to import and export data from PDF forms.
• Advanced topics - less known things about PDF forms.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF Forms: Create AcroForms
PDF4NET library can create fully working PDF forms that can be filled from code or from any interactive PDF viewer application.
All AcroForm fields can be created with PDF4NET library. Throughout the sample code fragments below, the doc variable is a PDFDocument object and page variable is a PDFPage object.
All form related classes are located in O2S.Components.PDF4NET.Forms namespace.

How to create a text box

A text box field is represented in PDF4NET library by PDFTextBoxField class.
A simple text box field can be created with only 3 lines of code:
            PDFTextBoxField tbx = new PDFTextBoxField("TextBox2");
            tbx.Widgets[0].Rectangle = new RectangleF(50, 100, 200, 20);
            page.Fields.Add(tbx);

The following sample creates a text field with an enhanced visual appearance:
            PDFTextBoxField tbx = new PDFTextBoxField("TextBox3");
            tbx.Widgets[0].Rectangle = new RectangleF(300, 50, 200, 40);
            tbx.Widgets[0].BorderWidth = 1;
            tbx.Widgets[0].BorderStyle = PDFBorderStyle.Solid;
            tbx.Widgets[0].BorderColor = new PDFRgbColor(255, 0, 0);
            tbx.Text = "Sample field value";
            page.Fields.Add(tbx);

The Text and Value properties allow to create an interesting effect: when the field does not have focus, the Text is displayed, but when the user clicks the field, the Text disappears and the field is empty and ready for text input. This helps to create user friendly forms. For this feature to work, the Value must be an empty string. If either Text or Value are null (Nothing in VB.NET), when the form is created the one that has a value is used both for Text and for Value.

How to create a pushbutton

A pushbutton field is represented in PDF4NET library by PDFPushButtonField class.
Here it is how to create a pushbutton:
            PDFPushButtonField btn = new PDFPushButtonField("Pushbutton");
            btn.Tooltip = "Button Tooltip";
            (btn.Widgets[0] as PDFPushButtonWidget).Caption = "Push me";
            btn.Widgets[0].Rectangle = new RectangleF(50, 150, 200, 20);
            btn.Widgets[0].Color = new PDFRgbColor(255, 0, 0);
            btn.Widgets[0].BackColor = new PDFRgbColor(0, 255, 0);
            page.Fields.Add(btn);

A pushbutton can have up to 3 appearances: one for normal button state, called NormalAppearance, one for when the mouse is over the button, called RolloverAppearance, and one when the button is pressed, called DownAppearance. Normal appearance exists always, the other 2 appearances are optional.
Pushbuttons are used for executing actions inside a form. The following code fragment shows how to execute a JavaScript action when the button is pressed:
            // Set an OnClick action for the button
            PDFJavaScriptAction js = new PDFJavaScriptAction();
            js.Script = "var f = this.getField(\"TextBox1\");\r\nf.value = \"test\";";
            btn.Widgets[0].MouseUp = js;

Pushbuttons are also used to initiate the submission of form data to a server. The following code fragment shows how to create an action that will submit the form data to a server:
            // Set an OnClick action for the button
            PDFSubmitFormAction submitFormAction = new PDFSubmitFormAction();
            submitFormAction.Url = "http://localhost/fieldsexplorer/fieldsviewer.aspx";
            submitFormAction.DataFormat = SubmitDataFormat.HTML;
            btn.Widgets[0].MouseUp = submitFormAction;

How to create a checkbox

A checkbox field is represented in PDF4NET library by PDFCheckBoxField class.
Here it is how to create a checkbox:
            PDFCheckBoxField checkBox = new PDFCheckBoxField("CheckBox");
            (checkBox.Widgets[0] as PDFCheckBoxWidget).ExportValue = "1";
            checkBox.Checked = true;
            (checkBox.Widgets[0] as PDFCheckBoxWidget).CheckSymbolStyle = PDFCheckSymbolStyle.Check;
            checkBox.Widgets[0].Rectangle = new RectangleF(50, 200, 20, 20);
            checkBox.Widgets[0].Color = new PDFRgbColor(0, 0, 0);
            checkBox.Widgets[0].BackColor = new PDFRgbColor(255, 255, 255);
            page.Fields.Add(checkBox);

A checkbox can have up to 3 appearances for each state, checked and unchecked: one for normal checkbox state, called CheckedNormalAppearance and UncheckedNormalAppearance, one when the mouse is over the button, called CheckedRolloverAppearance and UncheckedRolloverAppearance, and one when the button is pressed, called CheckedDownAppearance and UncheckedDownAppearance. Normal appearance exists always, the other 2 appearances are optional.

How to create a radiobutton list

A radiobutton list field is represented in PDF4NET library by PDFRadioButtonListField class.
A radiobutton list field consists of several exclusive radiobutton items. Here it is how to create a radiobutton list field with 2 radiobutton items:
            // Create a radiobutton list
            PDFRadioButtonListField rbl = new PDFRadioButtonListField("RadioButtonList");
            PDFRadioButtonItem rbi = new PDFRadioButtonItem();
            rbi.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond;
            rbi.ExportValue = "1";
            rbi.Rectangle = new RectangleF(50, 250, 20, 20);
            rbi.Color = new PDFRgbColor(255, 255, 255);
            rbi.BackColor = new PDFRgbColor(0, 0, 0);
            rbl.Widgets.Add(rbi);
            PDFRadioButtonItem rbi2 = new PDFRadioButtonItem();
            rbi2.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond;
            rbi2.ExportValue = "2";
            rbi2.Rectangle = new RectangleF(50, 300, 20, 20);
            rbi2.Color = new PDFRgbColor(255, 255, 255);
            rbi2.BackColor = new PDFRgbColor(0, 0, 0);
            rbl.Widgets.Add(rbi2);
            PDFRadioButtonItem rbi3 = new PDFRadioButtonItem();
            rbi3.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond;
            rbi3.ExportValue = "3";
            rbi3.Rectangle = new RectangleF(50, 350, 20, 20);
            rbi3.Color = new PDFRgbColor(255, 255, 255);
            rbi3.BackColor = new PDFRgbColor(0, 0, 0);
            rbl.Widgets.Add(rbi3);
            rbl.SelectedValue = "3";
            page.Fields.Add(rbl);

A radiobutton item, like a checkbox, can have up to 3 appearances for each state, checked and unchecked: one for normal checkbox state, called CheckedNormalAppearance and UncheckedNormalAppearance, one when the mouse is over the button, called CheckedRolloverAppearance and UncheckedRolloverAppearance, and one when the button is pressed, called CheckedDownAppearance and UncheckedDownAppearance. Normal appearance exists always, the other 2 appearances are optional.

How to create a drop down list

A drop down list field is represented in PDF4NET library by PDFDropDownListField class.
Here it is how to create a drop down list:
            // Create a drop down list
            PDFDropDownListField ddl = new PDFDropDownListField("DropDownList");
            PDFListItem li = new PDFListItem("Item 1", "1");
            ddl.Items.Add(li);
            PDFListItem li2 = new PDFListItem("Item 2", "2");
            ddl.Items.Add(li2);
            PDFListItem li3 = new PDFListItem("Item 3", "3");
            ddl.Items.Add(li3);
            ddl.Widgets[0].Rectangle = new RectangleF(50, 400, 200, 20);
            ddl.Widgets[0].Font = new PDFFont(PDFFontFace.Courier, 10);
            ddl.Widgets[0].BorderWidth = 1;
            ddl.Widgets[0].BorderStyle = PDFBorderStyle.Solid;
            ddl.Widgets[0].BorderColor = new PDFRgbColor(0, 0, 255);
            ddl.SelectedIndex = 1;
            page.Fields.Add(ddl);

How to create a list box

A list box field is represented in PDF4NET library by PDFListBoxField class.
Here it is how to create a list box field:
            // Create a list box
            PDFListBoxField lbx = new PDFListBoxField("ListBox");
            PDFListItem lxi = new PDFListItem("Item 1", "1");
            PDFListItem lxi2 = new PDFListItem("Item 2", "2");
            PDFListItem lxi3 = new PDFListItem("Item 3", "3");
            lbx.Items.Add(lxi);
            lbx.Items.Add(lxi2);
            lbx.Items.Add(lxi3);
            lbx.Widgets[0].Rectangle = new RectangleF(50, 450, 200, 80);
            lbx.Widgets[0].BorderWidth = 1;
            lbx.Widgets[0].BorderStyle = PDFBorderStyle.Solid;
            lbx.Widgets[0].BorderColor = new PDFRgbColor(0, 0, 255);
            lbx.SelectedIndex = 2;
            page.Fields.Add(lbx);

Other considerations

A field can be added only to the Fields collection of a PDFPage object. If a field is added to the Fields collection of the PDFDocument object, an exception is thrown. The line below throws an exception:
...
doc.Fields.Add( field ); // this line throws an exception.
...

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF Forms: Reading and filling AcroForms
PDF4NET can read and fill field values in existing PDF forms that have been created with other form design tools.
When a PDF form is loaded with PDF4NET, each field in the form is transformed into a corresponding field object. These fields are available through the Fields collections of PDFDocument object and corresponding PDFPage objects. For each field in the form, a library field object is created:
• text fields - they are available as PDFTextBoxField objects
• pushbutton fields - they are available as PDFPushButtonField objects
• checkbox fields - they are available as PDFCheckBoxField objects
• radiobutton list fields - they are available as PDFRadioButtonListField objects
• drop down list fields - they are available as PDFDropDownListField objects
• list box fields - they are available as PDFListBoxField objects
The Fields collections can be indexed either by field name or by its position. The position of a field in the Fields collection is not related to the position of the field on the page.

The sample below shows how to fill the fields from a PDF document:

...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Fill the fields
doc.Form.Fields["companyName"].Value = "O2 Solutions";
doc.Form.Fields["url"].Value = "http://www.o2sol.com/";
doc.Form.Fields["taxed"].Value = "3";
doc.Form.Fields["country"].Value = "20";
doc.Form.Fields["area"].Value = "2";
// Save the document to disk
doc.Save( "formfill.pdf" );
...

If the PDF form already contains values in its fields, these values can be read into application's variables. The following code fragment shows how to read field values into local variables:
...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Read the fields
string companyName = doc.Form.Fields["companyName"].Value;
string website = doc.Form.Fields["url"].Value;
string countryCode = doc.Form.Fields["country"].Value;
...

In the samples above the fields are used through the generic PDFField class (all field classes inherit this class). If the specialized properties of a field need to be used, the field object needs to be converted to its native type.
The following sample shows how to inspect the items in a drop down list field:

...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Get the countries drop down list
PDFDropDownListField countriesList = doc.Form.Fields["ddlCountry"] as PDFDropDownListField;
// Loop through the list items. for( int i = 0; i < countriesList.Items.Count; i++ )
{
    // Display the item content.
    Console.WriteLine( "Country id-name: {0}-{1)", countriesList.Items[i].Value, countriesList.Items[i].Name );
}
...

Field references can be retrieved both from the Fields collection of the PDFDocument object and the corresponding PDFPage objects. When the Fields collections are accessed by numeric index, a field object is always returned. If the Fields collections are accessed by field name, the collection returns null (Nothing in VB.NET) if the field does not exist in the collection.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF Forms: Reading and filling XFA Forms
PDF4NET can read and fill field values in existing XFA forms (embedded in PDF documents) that have been created with other form design tools.
XFA forms have a hierarchical structure which is reflected in the object model available in PDF4NET. A XFA form can include several subforms and fields. Each subform can include also other subforms and fields and this leads to a tree like structure. The tree structure in the XFA form is mapped 1-to-1 to objects in PDF4NET library. The XFA form embedded in a PDF file is available through the XFAForm property of the PDFDocument object. When a XFA form is loaded with PDF4NET, the library creates an object for each support XFA form element:
• subform - XFASubform class
• area - XFAArea class
• pageSet - XFAPageSet class
• pageArea - XFAPageArea class
• field - XFAField class

Form fields are available for read/write operations through the Fields collections of XFASubform, XFAArea and XFAPageArea objects. For each field in the form, a library field object is created:
• text edit fields - they are available as XFATextEditField objects
• password edit fields - they are available as XFAPasswordEditField objects
• numeric edit fields - they are available as XFANumericEditField objects
• datetime edit fields - they are available as XFADateTimeEditField objects
• pushbutton fields - they are available as XFAButtonField objects
• checkbox fields - they are available as XFACheckButtonField objects
• radiobutton list fields - they are available as XFARadioButtonListField objects
• drop down list fields and list boxes - they are available as XFAChoiceField objects
• image fields - they are available as XFAImageEditField objects
• barcode fields - they are available as XFABarcodeField objects
The Fields collections can be indexed either by field name or by its position. The position of a field in the Fields collection is not related to the position of the field on the page.

The sample below shows how to fill the fields from a XFA form:

...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasampleform.pdf" );
// Get the main subform.
XFASubform mainSubform = doc.XFAForm.Subforms[0].Subforms[0];
// Fill the product name.
mainSubform.Fields["txtName"].Value = "PDF4NET";
// Fill the product SKU.
mainSubform.Fields["txtSKU"].Value = "PDF4NET01090";
// Fill the product URL.
mainSubform.Fields["txtURL"].Value = "http://www.o2sol.com/pdf4net/products.htm";
// Select the product category.
mainSubform.Fields["ddlCategory"].Value = "PDF";
// Also add a new item to Category drop down list.
XFAListItem listItem = new XFAListItem( "Compression", "CMP" );
( mainSubform.Fields["ddlCategory"] as XFAChoiceListField ).Items.Add( listItem );
// Fill the product image.
mainSubform.Fields["imgProduct"].Value = "pdf4net.jpg";
( mainSubform.Fields["imgProduct"] as XFAImageEditField ).ContentType = "image/jpg";
// Fill the product short description.
mainSubform.Fields["txtShortDescription"].Value = "PDF4NET is a .NET library for adding " +
    "PDF capabilities to .NET applications. It supports both desktop and web applications.";
// Fill the product features.
mainSubform.Fields["txtFeature1"].Value = "Create PDF files from scratch.";
mainSubform.Fields["txtFeature2"].Value = "Merge, split and encrypt PDF files.";
mainSubform.Fields["txtFeature3"].Value = "Create, fill and flatten PDF e-forms.";
mainSubform.Fields["txtFeature4"].Value = "Fill XFA forms.";
mainSubform.Fields["txtFeature5"].Value = "Add, edit and remove document attachments.";
mainSubform.Fields["txtFeature6"].Value = "Add, edit and remove text annotations.";
mainSubform.Fields["txtFeature7"].Value = "Support for WinForms and ASP.NET applications.";
// Fill the product long description.
mainSubform.Fields["txtLongDescription"].Value = "PDF4NET is a .NET library for adding " +
    "PDF capabilities to .NET applications. Version 2.7 brings support for PDF e-form " +
    "creation, support for reading and filling static XFA forms and document attachments. " +
    "It supports both desktop and web applications.";
// Save the document to disk
doc.Save( "xfasampleform.fill.pdf" );
...

If the PDF form already contains values in its fields, these values can be read into application's variables. The following code fragment shows how to read field values into local variables:
...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasampleform.pdf" );
// Get the main subform.
XFASubform mainSubform = doc.XFAForm.Subforms[0].Subforms[0];
// Read the fields
string productName = (string)mainSubform.Fields["companyName"].Value;
string sku = (string)mainSubform.Fields["url"].Value;
byte[] productImage = (byte[])mainSubform.Fields["country"].Value;
...

In the samples above the fields are used through the generic XFAField class (all XFA field classes inherit this class). If the specialized properties of a field need to be used, the field object needs to be converted to its native type.
The following sample shows how to inspect the items in a choice list field:

...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasamplesform.pdf" );
// Get the main subform.
XFASubform mainSubform = doc.XFAForm.Subforms[0].Subforms[0];
// Get the countries drop down list
XFAChoiceListField countriesList = mainSubform.Fields["ddlCountry"] as XFAChoiceListField;
// Loop through the list items. for( int i = 0; i < countriesList.Items.Count; i++ )
{
    // Display the item content.
    Console.WriteLine( "Country id-name: {0}-{1)", countriesList.Items[i].Value, countriesList.Items[i].Name );
}
...

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF Forms: Form data import/export

Data export

Data from PDF forms can be exported to files using several formats, such as FDF, XFDF and XML.
AcroForms data can be exported using all 3 formats, while XFA form data can be exported only as XML.

The following sample shows how to export data from an AcroForm in FDF format:

...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Export the form data.
doc.Form.ExportData( "form_data.fdf", DataFormat.FDF, ExportDataOptions.FormData, "form.pdf" );
...

The reason for the last parameter is that FDF and XFDF files require a refernce back to the PDF file they were exported from. Because the PDF file can be loaded from a stream, its name might not be available when exporting the form data.

The next sample shows how to export data from a XFA form in XML format:

...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasampleform.pdf" );
// Export the form data.
doc.Form.ExportData( "xfasampleform_data.xml", XFADataFormat.XML );
...

Data import

PDF forms can be filled automatically using data files. The data files can have several formats, such as FDF, XFDF and XML.
Data can be imported into AcroForm using all 3 formats, while XFA forms can import only XML data files.

The following sample shows how to import FDF data from into an AcroForm:

...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Import the form data. doc.Form.ImportData( "form_data.fdf", DataFormat.FDF );
...

The next sample shows how to import XML data into a XFA form:

...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasampleform.pdf" );
// Import the form data.
doc.Form.ImportData( "xfasampleform_data.xml", XFADataFormat.XML );
...

The data files can be created by exporting form data or using 3rd party tools to create them. While FDF format is more complex and difficult to create, the XML and XFDF (also XML based) formats are easier to create by external tools.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF Forms: Advanced topics

AcroForm advanced topics

This section applies to AcroForms only.

Fields and widgets

An AcroForm field consists of 2 parts: the logical field that stores the field value and the visual part that displays the field value on the form. The visual part of the field is called widget. Any field has always at least a widget, but there are situations when a field can have multiple widgets. A field with multiple widgets appears to the user (in the PDF viewer) as multiple fields but all with the same name. Because the logical field stores the value, all widgets will display always the same value.

When a form is loaded, the Fields collections are filled with the logical fields, and not with the field widgets. Each PDFField object corresponds to a logical field. For example, if an AcroForm contains 7 fields with the same name (they are in fact a single field with 7 widgets), when it is loaded the in PDF4NET, the Fields collection of the PDFDocument object will have only one field. The widgets are loaded into field's Widgets collection.

PDF4NET library can create fields with multiple widgets by creating field objects with the same name.
The following code creates a text box field with 2 widgets:
...
// Create the first text box field.
PDFTextBoxField tbx1 = new PDFTextBoxField( "MultiWidgetTextBox" );
// Set the field's position on page.
tbx1.Appearance.Rectangle = new RectangleF( 50, 50, 200, 20 );
// Attach the field to the page.
page.Fields.Add( tbx1 );
// Create the second text box field.
PDFTextBoxField tbx2 = new PDFTextBoxField( "MultiWidgetTextBox" );// The same field name is used.
// Set the field's position on page.
tbx2.Appearance.Rectangle = new RectangleF( 50, 100, 200, 20 );
// Attach the field to the page.
page.Fields.Add( tbx2 );
...

The code above generates a text box field with 2 widgets. Also, after the above code is executed, the Fields collection of the page object contains only one element (the MultiWidgetTextBox field), not two. A side effect of the above code is that after tbx2 object is added to the page, the library merges its information with the first field (tbx1) and tbx2 is no longer a valid field reference.

How to merge identical AcroForms but with different data.

A common requirement is to merge multiple AcroForms that are identical as structure, but each one containing different data. Because the AcroForms have identical structure, when they are merged, the fields are also merged (fields with the same name appear in each AcroForm) and the final document keeps the data only from the first form used in the merge process, and this data is propagated to all the other forms. In order to avoid this to happen, each form needs to be flattened after it has been inserted in the main document. Fields flattening is the process that transforms all fields into plain PDF content, therefore making the fields no longer editable. Fields flattening is a destructive process, the field definitions are removed from the document and they can no longer be recovered. It is important to mention that this process takes place on the in-memory copy of the form, the actual form is not affected.
The following sample shows how to merge the forms into a single document and also keep the form data intact:
...
// Create a new PDF document that will store the merged forms.
PDFDocument doc = new PDFDocument( );
// Let's assume the GetFormsToMerge method returns the list of forms.
string[] formFiles = GetFormsToMerge();
// Loop through all the forms
for( int i = 0; i < formFiles.Length; i++ ).
{
    // Open the form file.
    PDFFile file = PDFFile.FromFile(formFiles[i]);
    // Let's assume each form is one page length.
    // Extract the page containing the form.
    PDFImportedPage page = file.ExtractPage(0);
    // Insert the page in the new document.
    doc.AddPage(page);
    // Flatten the form fields.
    doc.Form.FlattenFormFields;
}
// Save the final document.
doc.Save("mergedforms.pdf");

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Barcodes
PDF4NET library provides native support for dislaying barcodes in PDF document. The library supports both 1D and 2D barcode symbologies. The library validates the data automatically and computes the check characters as needed. The size of the barcodes is computed automatically based on encoded data and XDimension and YDimension properties.

The following code fragment shows the minimum required code to display a Code39 barcode in a PDF page:
PDFDocument doc = new PDFDocument( );
PDFPage page = new PDFPage( );
// Create and draw the barcode
PDFCode39Barcode c39 = new PDFCode39Barcode( "CODE39" );
page.Canvas.DrawBarcode( c39, 20, 570 );
// Save the PDF file
doc.Save( "Code39.pdf" );

All barcode related classes are included in the following namespace: O2S.Components.PDF4NET.Graphics.Barcodes

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Barcode symbologies
PDF4NET supports both 1D and 2D barcode symbologies. 1D symbologies are also called linear or unidimensional symbologies and 2D symbologies are also called bidimensional symbologies.
The following barcode symbologies are supported by PDF4NET library:
1D Symbologies
Codabar | Codabar
 | Also known as: USD-4 | NW-7 | Code 2 of 7
 | Codabar symbology was developer by Pitney Bowes, Inc in 1972. It is a discrete and self-checking symbology that supports 16 different characters for encoding. Because it is a self-checking symbology, it does not have a checksum character. EnableCheckSum and DisplayCheckSum properties have no effect on this symbology. Codabar symbology uses start and stop characters to mark the beginning and the end of the barcode. The start/stop characters are not returned by barcode reader when the barcode is scanned. Codabar symbology is used by U.S. blood banks, photo labs, and on FedEx airbills.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9 - $ : / . +
 | Required data length: Variable.
Code 11 | Code 11
 | Also known as: USD-8
 | Code 11 is a high density numeric only symbology. The symbology is discrete and is able to encode the numbers 0 through 9, the dash symbol (-) and start/stop characters. Code 11 symbology uses start and stop characters to mark the beginning and the end of the barcode. The start/stop characters are not returned by barcode reader when the barcode is scanned. This symbology is not very secure, printing defects can convert one character into another vald character. Because of this, Code 11 supports one or two check characters, depending on data length. If data length is less than 10, only one check character is used, otherwise two check characters are used. PDF4NET automatically computes the check characters if EnableCheckSum property is true. Code 11 symbology is used primarily in labeling telecommunications equipment.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9 -
 | Required data length: Variable.
Code 128A | Code 128A
 | Code 128A is a high density alphanumeric symbology that uses codeset A of Code 128. The symbology is self-checking and also requires check digit (EnableCheckSum property is true by default and the check character is computed automatically) for greater security. Code 128A symbology is used primarily in applications where large amounts of data must be encoded in a small space.
 | Allowed characters: NUL (0x00) SOH (0x01) STX (0x02) ETX (0x03) EOT (0x04) ENQ (0x05) ACK (0x06) BEL (0x07) BS (0x08) HT (0x09) LF (0x0A) VT (0x0B) FF (0x0C) CR (0x0D) SO (0x0E) SI (0x0F) DLE (0x10) DC1 (0x11) DC2 (0x12) DC3 (0x13) DC4 (0x14) NAK (0x15) SYN (0x16) ETB (0x17) CAN (0x18) EM (0x19) SUB (0x1A) ESC (0x1B) FS (0x1C) GS (0x1D) RS (0x1E) US (0x1F) SPACE (0x20) ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _
 | Required data length: Variable.
Code 128B | Code 128B
 | Code 128B is a high density alphanumeric symbology that uses codeset B of Code 128. The symbology is self-checking and also requires check digit (EnableCheckSum property is true by default and the check character is computed automatically) for greater security. Code 128B symbology is used primarily in applications where large amounts of data must be encoded in a small space.
 | Allowed characters: SPACE (0x20) ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ DEL (\x7F)
 | Required data length: Variable.
Code 128C | Code 128C
 | Code 128C is a high density numberic only symbology that uses codeset C of Code 128. The symbology is self-checking and also requires check digit (EnableCheckSum property is true by default and the check character is computed automatically) for greater security. Code 128C symbology is used primarily in applications where large amounts of numeric data must be encoded in a small space, because each pair of digits is encoded as a single barcode symbol.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Code 2 of 5 | Code 2 of 5
 | Also known as: Standard 2 of 5 | Industrial 2 of 5
 | Code 2 of 5 is a low density numeric only symbology. It has been in use since 1960. This symbology may include an optional check character. PDF4NET automatically computes the check character if EnableCheckSum property is true. A newer version of this symbology is Code 2 of 5 Interleaved which achieves a higher density. Code 2 of 5 is used for sequentially numbering airline tickets, for photofinishing and warehouse sorting industries.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Code 2 of 5 Interleaved | Code 2 of 5 Interleaved
 | Also known as: Interleaved 2 of 5
 | Code 2 of 5 Interleaved is a high density numeric only symbology and it is a newer version of Code 2 of 5. This symbology may include an optional check character. PDF4NET automatically computes the check character if EnableCheckSum property is true. Code 2 of 5 is used in distribution and warehouse industry.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Code 39 | Code 39
 | Also known as: USD-3 | Code 3 of 9 | LOGMARS
 | Code 39 is the first developed barcode symbology. It is self checking and may include an optional check character. PDF4NET automatically computes the check character if EnableCheckSum property is true. Code 39 is used by the United States Department of Defense, by the Health Industry Bar Code Council (HIBCC) and also in non-retail environments.
 | Allowed characters: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
 | Required data length: Variable.
Code 39 Extended | Code 39 Extended
 | Also known as: USD-3 | Code 3 of 9 | LOGMARS
 | Code 39 Extended is based on Code 39 and supports all 128 ASCII characters.
 | Allowed characters: All 128 ASCII characters.
 | Required data length: Variable.
Code 93 | Code 93
 | Also known as: USS-93
 | Code 93 symbology was designed to improve and complement the Code 39 symbology. It supports 47 different characters to encode. Two check characters are required (EnableCheckSum property is true by default) and they are computed automatically.
 | Allowed characters: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
 | Required data length: Variable.
Code 93 Extended | Code 93 Extended
 | Also known as: USS-93
 | Code 93 Extended is based on Code 93 and supports all 128 ASCII characters.
 | Allowed characters: All 128 ASCII characters.
 | Required data length: Variable.
COOP 2 of 5 | COOP 2 of 5
 | Also known as: COOP 25
 | COOP 2 of 5 is a numeric only symbology. It is self checking and it may include an optional check character. PDF4NET automatically computes the check character if EnableCheckSum property is true. COOP 2 of 5 is used for management of physical distribution.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
EAN-13 | EAN-13
 | EAN-13 is a numeric only symbology based on UPC-A standard (it is a super set of UPC-A). It is self checking and it requires a check character. PDF4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. EAN-13 barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. EAN-13 was implemented by the International Article Numbering Association (EAN) in Europe and it uses 2 digits for the number system code.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 12 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
EAN-8 | EAN-8
 | EAN-8 is a numeric only symbology, the "short" version of EAN-13 designed for small packages. It is self checking and it requires a check character. PDF4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. EAN-8 barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 7 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
IATA 2 of 5 | IATA 2 of 5
 | IATA 2 of 5 is a numeric only symbology. It is self checking and a check character is always required. PDF4NET automatically computes the check character if EnableCheckSum property is true (this is default). IATA 2 of 5 is used by IATA (International Air Transport Association) for the management of air cargo.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 16 digits.
ISBN | ISBN
 | ISBN (International Standard Book Numbering) is a EAN-13 symbology that uses the number system 978. ISBN barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. This symbology is used for labeling books.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 9 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
ISMN | ISMN
 | ISMN (International Standard Music Number) is a EAN-13 symbology that uses the number system 979. ISMN barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. This symbology is used for labeling music casettes and CDs.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 9 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
ISSN | ISSN
 | ISSN (International Standard Serial Number for Periodicals) is a EAN-13 symbology that uses the number system 977. ISSN barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. This symbology is used for labeling periodicals and newspapers.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 9 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
JAN-13 | JAN-13
 | JAN-13 is a EAN-13 symbology that uses the number system 49. JAN-13 barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. This symbology is used in Japan in retail applications.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 10 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
Matrix 2 of 5 | Matrix 2 of 5
 | Matrix 2 of 5 is a numeric only symbology. It is self checking and an optional check character may be included. PDF4NET automatically computes the check character if EnableCheckSum property is true.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
MSI/Plessey | MSI/Plessey
 | Also known as: Modified Plessey
 | MSI/Plessey is a numeric only symbology. It was developed by MSI Data Corporation, based on the original Plessey Code. It is not self checking but an optional check character may be included. PDF4NET automatically computes the check character if EnableCheckSum property is true. This symbology is used primarily to mark retail shelves for inventory control.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Planet | Planet
 | Planet is a height modulated numeric only symbology, it is the inverse of PostNet symbology. A check character is required and it is computed automatically regardless of EnableCheckSum property. This symbology is used in combination with PostNet by USPS to track customer's piece of mail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 11 or 13 digits.
Postnet | Postnet
 | Postnet is a height modulated numeric only symbology. It was created by USPS to allow faster sorting and routing of mail. A check character is required and it is computed automatically regardless of EnableCheckSum property. Postnet barcodes can encode 5 digits (ZIP code), 9 digits (ZIP+4) or 11 digits (full delivery point). This symbology is used by USPS to allow faster sorting and routing of mail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 5, 9 or 11 digits.
RM4SCC | RM4SCC
 | RM4SCC (Royal Mail 4-state Customer Code) is a height modulated symbology. A check character is required and it is computed automatically regardless of EnableCheckSum property. This symbology is used by UK Royal Mail to allow faster sorting and routing of mail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
 | Required data length: Variable.
SCC-14 | SCC-14
 | SCC-14 (Shipping Container Code 14) is a numeric only symbology based on Code 128C. It is in fact a Code 128C barcode with a fixed data format. A check character is required and it is computed automatically regardless of EnableCheckSum property. SCC-14 is part of the larger UCC/EAN-128 specification with application identifier 01, and it is a shorter version of SSCC-18 symbology. Shipping Container Code is used to identify individual shipping containers. This is used, generally, to establish a number that is unique worldwide to track a specific container.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 13 digits.
SSCC-18 | SSCC-18
 | SSCC-18 (Serial Shipping Container Code 18) is a numeric only symbology based on Code 128C. It is in fact a Code 128C barcode with a fixed data format. A check character is required and it is computed automatically regardless of EnableCheckSum property. SCC-18 is part of the larger UCC/EAN-128 specification with application identifier 00. Serial Shipping Container Code is used to identify individual shipping containers. This is used, generally, to establish a number that is unique worldwide to track a specific container.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 17 digits.
UPC-A | UPC-A
 | UPC-A is a numeric only symbology. It is self checking and it requires a check character. PDF4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. UPC-A barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. UPC-A is widely used in United States in retail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 11 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
UPC-E | UPC-E
 | UPC-E is a numeric only symbology, a shorter version of UPC-A symbology. It is self checking and it requires a check character. PDF4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. UPC-E barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. UPC-E is widely used in United States in retail and it is used instead of UPC-A for products with very small packaging.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 7 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
2D Symbologies
CODABLOCK F | CODABLOCK F
 | CODABLOCK F is is multirow symbology, a 2D version of Code 128. It was created at ICS Identcode-Systeme, being invented by Heinrich Oehlmann.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 2725 characters.
Code 16K | Code 16K
 | Code 16K is is multirow symbology based on Code 128. It was created by Ted Williams in 1989.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 77 ASCII characters or 154 numeric characters.
DataMatrix | DataMatrix
 | DataMatrix is a 2D matrix symbology made up of square modules arranged within a perimeter finder pattern. A limited set of symbol sizes, both square and rectangular, is available, together with a fixed level of error correction for each symbol size. PDF4NET uses ECC200 version of DataMatrix symbology.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 1556 bytes or 2335 alphanumeric characters or 3116 numeric characters.
MicroPDF417 | MicroPDF417
 | MicroPDF417 is a multi-row symbology, derived from and closely based on PDF417. MicroPDF417 is designed for applications with a need for improved area efficiency but without the requirement for PDF417's maximum data capacity. A limited set of symbol sizes is available, together with a fixed level of error correction for each symbol size.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 150 bytes or 250 alphanumeric characters or 366 numeric characters.
PDF417 | PDF417
 | PDF417 is a multi-row, variable-length symbology that offers high data capacity and error correction capabilities. Up to 2700 characters can be encoded depending on the selected data compaction mode. PDF4NET supports all 3 data compaction modes: Text, Byte and Numeric.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 1108 bytes or 1850 alphanumeric characters or 2710 numeric characters.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF/A

PDF4NET 4.1 brings support for creating PDF files that comply with PDF/A-1b standard. PDF/A files are like regular PDF files but with a few restrictions applied to them. When writing code for generating PDF/A files the following rules must be followed:

  • The document cannot contain attachments (embedded files).
  • The document cannot be encrypted.
  • The document cannot contain imported pages.
  • The document cannot contain optional content, such as page backgrounds and layers.
  • The document cannot contain additional actions, such as before close, before print, after print, before save and after save actions.
  • The document's open action cannot be a launch, sound, movie, reset form, import data or javascript action.
  • The document must include XMP metadata, the document's Metadata property cannot be null.
  • Metadata schemas cannot be used.
  • The NeedAppearances property in document's form must be false.
  • The document must include an output intent and its type must be PDF/A.
  • The graphic content streams (page canvas and form xobject canvas) cannot mix RGB and CMYK colors, either RGB or CMYK should be used.
  • Imported content graphics cannot be used on a canvas.
  • The ICC profile associated with document's output intent must match the device color (RGB or CMYK) used in graphic content streams.
  • Only the following annotations are allowed: text, link, free text, line, square, circle, highlight, underline, squiggly, strikeout, stamp, ink, popup, widget, printer mark, trapnet.
  • Annotation additional actions are not allowed.
  • The action associated with an annotation cannot be a launch, sound, movie, reset form, import data or javascript action.
  • Annotation opacity cannot be less than 100.
  • An annotation cannot be marked as hidden, invisible or not printable.
  • A text annotation must be marked as no zoom and no rotate.
  • Annotation color and interior color should be present only if the document specifies a corresponding output intent.
  • An annotation must have only the normal visual appearance.
  • Form fields cannot have actions associated with them.
  • An image must not have an associated soft mask.
  • The Interpolate property on an image object must be set to false.
  • PDF and CJK fonts cannot be used, all fonts must be embedded in the document.
  • Transparency and blend modes other than "Normal" cannot be used on a canvas.
  • The alternate colorspace in a Separation colorspace, if RGB or CMYK, must match the color profile defined in document's output intent.

In the above rules are broken the Save method of the PDFDocument will throw a PDFInvalidPDFAFormatException. The exception contains details about what rules have been broken.

The sample below shows how to create a PDF/A-1b compliant PDF file:

PDF/A Demo
Copy Code
using System;
using System.IO;
using System.Text;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.ColorSpaces;
using O2S.Components.PDF4NET.Annotations;
namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This demo shows how to create a PDF/A-1b compliant PDF file with PDF4NET.
    /// </summary>
    public class PDFADemo
    {
        static void Main(string[] args)
        {
            PDFDocument doc = new PDFDocument();
            doc.SerialNumber = "serial number here";

            // Read the ICC profile from disk.
            FileStream fs = new FileStream("..\\SupportFiles\\rgb.icc", FileMode.Open, FileAccess.Read);
            byte[] profileData = new byte[fs.Length];
            fs.Read(profileData, 0, profileData.Length);
            fs.Close();

            // Create a RGB output intent and attach it to the document.
            PDFICCColorSpace icc = new PDFICCColorSpace();
            icc.ProfileData = profileData;
            PDFOutputIntent oi = new PDFOutputIntent();
            oi.Type = PDFOutputIntentType.PDFA1;
            oi.Info = "sRGB IEC61966-2.1";
            oi.OutputConditionIdentifier = "Custom";
            oi.DestinationOutputProfile = icc;

            doc.OutputIntents = new PDFOutputIntentCollection();
            doc.OutputIntents.Add(oi);

            // Set the document information and metadata.
            PDFDocumentInformation di = new PDFDocumentInformation();
            di.Author = "O2 Solutions";
            di.Producer = "PDF4NET";
            di.Keywords = "pdf";
            di.Subject = "PDF/A-1b Demo Document created with PDF4NET";
            di.Title = "PDF4NET Demo";
            di.Creator = "PDF4NET Demo";
            doc.DocumentInformation = di;
            doc.Metadata = new PDFXMPMetadata();

            PDFPage page = doc.AddPage();

            // Use an embedded TrueType font to draw the text.
            TrueTypeFont ttf = new TrueTypeFont("..\\SupportFiles\\Verdana.ttf", 96, true, true);
            PDFBrush yellowBrush = new PDFBrush(new PDFRgbColor(255, 255, 0));
            PDFPen greenPen = new PDFPen(new PDFRgbColor(64, 192, 0), 4);
            page.Canvas.DrawText("PDF/A-1b Demo",
                ttf, greenPen, yellowBrush, page.Width / 2, page.Height / 2, 60, PDFTextAlign.MiddleCenter);

            // Save the document in PDF/A-1b format.
            PDFDocumentSaveOptions dso = new PDFDocumentSaveOptions();
            dso.SaveFormat = PDFDocumentSaveFormat.PDFA1b;
            doc.Save("Sample_PDFADemo.pdf", dso);
        }
    }
}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples
The following samples are available. They cover all the features of the PDF4NET library.

Samples

3D

Actions

Annotations

ArcsPies

Attachments

Autonumbering

Barcodes

Bezier

Bookmarks

CharacterMap

ColorSpaces

Digital Signature

DocAndViewer

Edit PDF

Ellipses

Encryption

ExtractImages

Forms

Form XObjects

GroupingGrid

HelloWorld

Images

Layers

Lines

Links

Metafiles

MulticolumnTextAndImages

PageOrientations

PageSizes

Pantone colors

Paths

PDF/A

Polygons

Portfolios

Rectangles

Shadings

SimpleGrid

Sin(x) Graph

SlideShow

Stamp PDF

TextBoxes - with TrueType font support

TextExtract

TextLines

Tiff2PDF

Unicode

Update PDF

Watermarks

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: 3D
This sample shows how to embed 3D artwork (U3D data) in PDF files. It shows how to work with 3D annotations, projections, render modes and lighting schemes.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


3D.cs
using System; using System.IO; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Annotations; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; namespace O2S.Samples.PDF4NET { /// <summary> /// This sample shows how to embed 3D artwork in PDF files. /// </summary> class _3DArtwork { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument doc = new PDFDocument(); // Create a blank page PDFPage page = doc.AddPage(); // Create the annotation that will display the 3D artwork. PDF3DAnnotation annot3d = new PDF3DAnnotation(); annot3d.Rectangle = new RectangleF(50, 50, 400, 400); annot3d.Stream = Create3DStream(); annot3d.Appearance = new PDFFormXObject(); annot3d.Appearance.Canvas.DrawText("Click to activate", new PDFFont(), null, new PDFBrush(new PDFColor()), 200, 200, 0, TextAlign.MiddleCenter); // Create the default view. PDF3DProjection projection1 = new PDF3DProjection(PDF3DProjectionType.Perspective); projection1.FieldOfView = 30; PDF3DLightingScheme lightScheme1 = null;//new PDF3DLightingScheme(PDF3DLightingStyle.Artwork); PDF3DRenderMode renderMode1 = new PDF3DRenderMode(PDF3DRenderStyle.Solid); PDF3DBackground background1 = new PDF3DBackground(new PDFColor(255, 255, 255)); PDF3DView defaultView = CreateView("Default view", new float[]{-0.382684f, 0.92388f, -0.0000000766026f, 0.18024f, 0.0746579f, 0.980785f, 0.906127f, 0.37533f, -0.19509f, -122.669f, -112.432f, 45.6829f}, 131.695f, background1, projection1, renderMode1, lightScheme1); // Create a wireframe view. PDF3DRenderMode renderMode2 = new PDF3DRenderMode(PDF3DRenderStyle.Wireframe); PDF3DView wireframeView = CreateView("Wireframe view", new float[]{-0.382684f, 0.92388f, -0.0000000766026f, 0.18024f, 0.0746579f, 0.980785f, 0.906127f, 0.37533f, -0.19509f, -122.669f, -112.432f, 45.6829f}, 131.695f, background1, projection1, renderMode2, lightScheme1); // Create a wireframe view. PDF3DRenderMode renderMode3 = new PDF3DRenderMode(PDF3DRenderStyle.TransparentWireframe); renderMode3.AuxiliaryColor = new PDFColor(0, 192, 0); PDF3DView transparentWireframeView = CreateView("Transparent wireframe view", new float[]{-0.382684f, 0.92388f, -0.0000000766026f, 0.18024f, 0.0746579f, 0.980785f, 0.906127f, 0.37533f, -0.19509f, -122.669f, -112.432f, 45.6829f}, 131.695f, background1, projection1, renderMode3, lightScheme1); annot3d.Stream.Views.Add(defaultView); annot3d.Stream.Views.Add(wireframeView); annot3d.Stream.Views.Add(transparentWireframeView); annot3d.Stream.DefaultView = 0; // Add the annotation to the page. page.Annotations.Add(annot3d); doc.Save("3d.pdf"); } /// <summary> /// Creates the 3D stream. /// </summary> private static PDF3DStream Create3DStream() { // Read the U3D file. FileStream fs = new FileStream("box.u3d", FileMode.Open, FileAccess.Read); byte[] u3data = new byte[fs.Length]; fs.Read(u3data, 0, u3data.Length); fs.Close(); PDF3DStream stream = new PDF3DStream(); stream.Content = u3data; return stream; } /// <summary> /// Creates a view for the 3D artwork. /// </summary> private static PDF3DView CreateView(string viewName, float[] camera2world, float centerOfOrbit, PDF3DBackground background, PDF3DProjection projection, PDF3DRenderMode renderMode, PDF3DLightingScheme lightingScheme) { PDF3DView view = new PDF3DView(); view.ExternalName = viewName; view.InternalName = Guid.NewGuid().ToString("N"); view.CameraToWorldMatrix = camera2world; view.CenterOfOrbit = centerOfOrbit; view.Background = background; view.Projection = projection; view.RenderMode = renderMode; view.LightingScheme = lightingScheme; view.ResetNodesState = true; return view; } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


3D.vb
Imports System Imports System.IO Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Annotations Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Fonts Imports O2S.Components.PDF4NET.Graphics.Shapes Namespace O2S.Samples.PDF4NET ''' <summary> ''' This sample shows how to embed 3D artwork in PDF files. ''' </summary> Class _3DArtwork ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument() ' Create a blank page Dim page As PDFPage = doc.AddPage() ' Create the annotation that will display the 3D artwork. Dim annot3d As New PDF3DAnnotation() annot3d.Rectangle = New RectangleF(50, 50, 400, 400) annot3d.Stream = Create3DStream() annot3d.Appearance = New PDFAnnotationAppearance() annot3d.Appearance.Canvas.DrawText("Click to activate", New PDFFont(), Nothing, New PDFBrush(New PDFRgbColor()), 200, 200, _ 0, PDFTextAlign.MiddleCenter) ' Create the default view. Dim projection1 As New PDF3DProjection(PDF3DProjectionType.Perspective) projection1.FieldOfView = 30 Dim lightScheme1 As PDF3DLightingScheme = Nothing 'new PDF3DLightingScheme(PDF3DLightingStyle.Artwork); Dim renderMode1 As New PDF3DRenderMode(PDF3DRenderStyle.Solid) Dim background1 As New PDF3DBackground(New PDFRgbColor(255, 255, 255)) Dim defaultView As PDF3DView = CreateView("Default view", New Double() {-0.382684F, 0.92388F, -7.66026E-08F, 0.18024F, 0.0746579F, 0.980785F, _ 0.906127F, 0.37533F, -0.19509F, -122.669F, -112.432F, 45.6829F}, 131.695F, background1, projection1, renderMode1, _ lightScheme1) ' Create a wireframe view. Dim renderMode2 As New PDF3DRenderMode(PDF3DRenderStyle.Wireframe) Dim wireframeView As PDF3DView = CreateView("Wireframe view", New Double() {-0.382684F, 0.92388F, -7.66026E-08F, 0.18024F, 0.0746579F, 0.980785F, _ 0.906127F, 0.37533F, -0.19509F, -122.669F, -112.432F, 45.6829F}, 131.695F, background1, projection1, renderMode2, _ lightScheme1) ' Create a wireframe view. Dim renderMode3 As New PDF3DRenderMode(PDF3DRenderStyle.TransparentWireframe) renderMode3.AuxiliaryColor = New PDFRgbColor(0, 192, 0) Dim transparentWireframeView As PDF3DView = CreateView("Transparent wireframe view", New Double() {-0.382684F, 0.92388F, -7.66026E-08F, 0.18024F, 0.0746579F, 0.980785F, _ 0.906127F, 0.37533F, -0.19509F, -122.669F, -112.432F, 45.6829F}, 131.695F, background1, projection1, renderMode3, _ lightScheme1) annot3d.Stream.Views.Add(defaultView) annot3d.Stream.Views.Add(wireframeView) annot3d.Stream.Views.Add(transparentWireframeView) annot3d.Stream.DefaultView = 0 ' Add the annotation to the page. page.Annotations.Add(annot3d) doc.Save("Sample_3D.pdf") End Sub ''' <summary> ''' Creates the 3D stream. ''' </summary> Private Shared Function Create3DStream() As PDF3DStream ' Read the U3D file. Dim fs As New FileStream("..\SupportFiles\box.u3d", FileMode.Open, FileAccess.Read) Dim u3data As Byte() = New Byte(fs.Length) {} fs.Read(u3data, 0, u3data.Length) fs.Close() Dim stream As New PDF3DStream() stream.Content = u3data Return stream End Function ''' <summary> ''' Creates a view for the 3D artwork. ''' </summary> Private Shared Function CreateView(viewName As String, camera2world As Double(), centerOfOrbit As Single, background As PDF3DBackground, projection As PDF3DProjection, renderMode As PDF3DRenderMode, _ lightingScheme As PDF3DLightingScheme) As PDF3DView Dim view As New PDF3DView() view.ExternalName = viewName view.InternalName = Guid.NewGuid().ToString("N") view.CameraToWorldMatrix = camera2world view.CenterOfOrbit = centerOfOrbit view.Background = background view.Projection = projection view.RenderMode = renderMode view.LightingScheme = lightingScheme view.ResetNodesState = True Return view End Function End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Actions
This sample demonstrates the support for PDF actions implemented in PDF4NET library.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Actions.cs
using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Actions;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;
namespace O2S.Samples.PDF4NET.Actions
{
    /// <summary>
    /// This sample shows how to use the PDF actions.
    /// </summary>
    class Actions
    {
    /// <summary>
    /// The main entry point for the application.
    ///
    </summary> [STAThread] static
    void Main(string[]
    args) { // Create the pdf document PDFDocument
    doc = new PDFDocument(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); // Create 3 pages PDFPage page = doc.AddPage();
    page.Canvas.DrawText("Page 1", fontText, null,
    blackBrush, 20, 30); page = doc.AddPage(); page.Canvas.DrawText("Page 2", fontText,
    null, blackBrush, 20, 30); page =
    doc.AddPage(); page.Canvas.DrawText("Page
    3", fontText, null, blackBrush, 20, 30); /// URI Action
    // create a web action PDFURIAction uriAction
    = new PDFURIAction(); uriAction.URI
    = "http://www.o2sol.com/"; // create a bookmark to
    point to the url above PDFBookmark url = new PDFBookmark(); url.Title = "www.o2sol.com";
    url.Color = new PDFRgbColor();
    url.Action = uriAction; // add the bookmark to the document doc.Bookmarks.Add(url); /// URI Action /// Javascript
    Action // create a javascript action to print the document PDFJavaScriptAction jsAction = new PDFJavaScriptAction(); jsAction.Script = "this.print(true);\n"; // create a bookmark to point to execute the action PDFBookmark
    js = new PDFBookmark(); js.Title
    = "Print me from JavaScript"; js.Color = new
    PDFRgbColor(); js.Action = jsAction;
    // add the bookmark to the document doc.Bookmarks.Add(js); /// Javascript Action /// OpenDocument action // Create an action to be executed when the document is opened // The
    action will open the document at the // second page of the document using a 800%
    zoom PDFPageDestination pageDestination = new PDFPageDestination(); pageDestination.Page =
    doc.Pages[1]; pageDestination.MagnificationMode
    = PDFMagnificationMode.XYZ; pageDestination.Left = 0; pageDestination.Top = 0; pageDestination.Zoom = 800; PDFGoToAction goToAction = new PDFGoToAction(); goToAction.Destination = pageDestination; // set the
    action on the document doc.OpenAction = goToAction; /// OpenDocument action // Save the document to disk doc.Save("Sample_Actions.pdf"); } }
    }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Actions.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Actions Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Actions ''' <summary> ''' This sample shows how to use the PDF actions. ''' </summary> Class Actions ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) ' Create 3 pages Dim page As PDFPage = doc.AddPage() page.Canvas.DrawText("Page 1", fontText, Nothing, blackBrush, 20, 30) page = doc.AddPage() page.Canvas.DrawText("Page 2", fontText, Nothing, blackBrush, 20, 30) page = doc.AddPage() page.Canvas.DrawText("Page 3", fontText, Nothing, blackBrush, 20, 30) ' create a web action Dim uriAction As New PDFURIAction() uriAction.URI = "http://www.o2sol.com/" ' create a bookmark to point to the url above Dim url As New PDFBookmark() url.Title = "www.o2sol.com" url.Color = New PDFRgbColor() url.Action = uriAction ' add the bookmark to the document doc.Bookmarks.Add(url) ' create a javascript action to print the document Dim jsAction As New PDFJavaScriptAction() jsAction.Script = "this.print(true);" & vbLf ' create a bookmark to point to execute the action Dim js As New PDFBookmark() js.Title = "Print me from JavaScript" js.Color = New PDFRgbColor() js.Action = jsAction ' add the bookmark to the document doc.Bookmarks.Add(js) ' Create an action to be executed when the document is opened ' The action will open the document at the ' second page of the document using a 800% zoom Dim pageDestination As New PDFPageDestination() pageDestination.Page = doc.Pages(1) pageDestination.MagnificationMode = PDFMagnificationMode.XYZ pageDestination.Left = 0 pageDestination.Top = 0 pageDestination.Zoom = 800 Dim goToAction As New PDFGoToAction() goToAction.Destination = pageDestination ' set the action on the document doc.OpenAction = goToAction ' Save the document to disk doc.Save("Sample_Actions.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Annotations
This sample demonstrates the support for PDF annotations implemented in PDF4NET library.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Annotations.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Annotations; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Fonts; using O2S.Components.PDF4NET.Graphics.Shapes; namespace O2S.Samples.PDF4NET.Annotations { /// <summary> /// This sample shows all annotations that can be created with PDF4NET. /// </summary> class Annotations { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument doc = new PDFDocument(); // Create one page PDFPage page = doc.AddPage(); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor(0, 0, 0)); PDFFont fontSection = new PDFFont(PDFFontFace.Helvetica, 10); fontSection.Bold = true; PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 8); page.Canvas.DrawText("Text annotations", fontSection, null, blackBrush, 20, 45, 0, PDFTextAlign.BottomLeft); // Create all available text annotations PDFTextAnnotation ta = new PDFTextAnnotation("Comment", "Comment annotation"); ta.Icon = PDFTextAnnotationIcon.Comment; ta.Rectangle = new RectangleF(20, 60, 20, 20); page.Annotations.Add(ta); page.Canvas.DrawText("Comment", fontText, null, blackBrush, 20, 80, 0, PDFTextAlign.TopLeft); ta = new PDFTextAnnotation("Help", "Help annotation"); ta.Icon = PDFTextAnnotationIcon.Help; ta.Rectangle = new RectangleF(100, 60, 20, 20); page.Annotations.Add(ta); page.Canvas.DrawText("Help", fontText, null, blackBrush, 100, 80, 0, PDFTextAlign.TopLeft); ta = new PDFTextAnnotation("Insert", "Insert annotation"); ta.Icon = PDFTextAnnotationIcon.Insert; ta.Rectangle = new RectangleF(180, 60, 20, 20); page.Annotations.Add(ta); page.Canvas.DrawText("Insert", fontText, null, blackBrush, 180, 80, 0, PDFTextAlign.TopLeft); ta = new PDFTextAnnotation("Key", "Key annotation"); ta.Icon = PDFTextAnnotationIcon.Key; ta.Rectangle = new RectangleF(260, 60, 20, 20); page.Annotations.Add(ta); page.Canvas.DrawText("Key", fontText, null, blackBrush, 260, 80, 0, PDFTextAlign.TopLeft); ta = new PDFTextAnnotation("New paragraph", "New paragraph annotation"); ta.Icon = PDFTextAnnotationIcon.NewParagraph; ta.Rectangle = new RectangleF(340, 60, 20, 20); page.Annotations.Add(ta); page.Canvas.DrawText("New paragraph", fontText, null, blackBrush, 340, 80, 0, PDFTextAlign.TopLeft); ta = new PDFTextAnnotation("Note", "Note annotation"); ta.Icon = PDFTextAnnotationIcon.Note; ta.Rectangle = new RectangleF(420, 60, 20, 20); page.Annotations.Add(ta); page.Canvas.DrawText("Note", fontText, null, blackBrush, 420, 80, 0, PDFTextAlign.TopLeft); ta = new PDFTextAnnotation("Paragraph", "Paragraph annotation"); ta.Icon = PDFTextAnnotationIcon.Paragraph; ta.Rectangle = new RectangleF(500, 60, 20, 20); page.Annotations.Add(ta); page.Canvas.DrawText("Paragraph", fontText, null, blackBrush, 500, 80, 0, PDFTextAlign.TopLeft); // Rubber stamp annotations page.Canvas.DrawText("Rubber stamp annotations", fontSection, null, blackBrush, 20, 120, 0, PDFTextAlign.TopLeft); // Create all available rubber stamp annotations PDFRubberStampAnnotation rsa = new PDFRubberStampAnnotation("Approved", "Approved annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.Approved; rsa.Rectangle = new RectangleF(20, 140, 100, 30); rsa.Opacity = 50; page.Annotations.Add(rsa); page.Canvas.DrawText("Approved", fontText, null, blackBrush, 20, 180, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("As Is", "As Is annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.AsIs; rsa.Rectangle = new RectangleF(120, 140, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("As Is", fontText, null, blackBrush, 120, 180, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("Confidential", "Confidential annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.Confidential; rsa.Rectangle = new RectangleF(220, 140, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("Confidential", fontText, null, blackBrush, 220, 180, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("Departmental", "Departmental annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.Departmental; rsa.Rectangle = new RectangleF(320, 140, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("Departmental", fontText, null, blackBrush, 320, 180, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("Draft", "Draft annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.Draft; rsa.Rectangle = new RectangleF(420, 140, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("Draft", fontText, null, blackBrush, 420, 180, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("Experimental", "Experimental annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.Experimental; rsa.Rectangle = new RectangleF(520, 140, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("Experimental", fontText, null, blackBrush, 520, 180, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("Expired", "Expired annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.Expired; rsa.Rectangle = new RectangleF(20, 200, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("Expired", fontText, null, blackBrush, 20, 240, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("Final", "Final annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.Final; rsa.Rectangle = new RectangleF(120, 200, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("Final", fontText, null, blackBrush, 120, 240, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("ForComment", "ForComment annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.ForComment; rsa.Rectangle = new RectangleF(220, 200, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("ForComment", fontText, null, blackBrush, 220, 240, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("ForPublicRelease", "ForPublicRelease annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.ForPublicRelease; rsa.Rectangle = new RectangleF(320, 200, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("ForPublicRelease", fontText, null, blackBrush, 320, 240, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("NotApproved", "NotApproved annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.NotApproved; rsa.Rectangle = new RectangleF(420, 200, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("NotApproved", fontText, null, blackBrush, 420, 240, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("NotForPublicRelease", "NotForPublicRelease annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.NotForPublicRelease; rsa.Rectangle = new RectangleF(520, 200, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("NotForPublicRelease", fontText, null, blackBrush, 520, 240, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("Sold", "Sold annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.Sold; rsa.Rectangle = new RectangleF(20, 260, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("Sold", fontText, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft); rsa = new PDFRubberStampAnnotation("TopSecret", "TopSecret annotation"); rsa.Icon = PDFRubberStampAnnotationIcon.TopSecret; rsa.Rectangle = new RectangleF(120, 260, 100, 30); page.Annotations.Add(rsa); page.Canvas.DrawText("TopSecret", fontText, null, blackBrush, 120, 300, 0, PDFTextAlign.TopLeft); // Line annotations page.Canvas.DrawText("Line annotations", fontSection, null, blackBrush, 20, 350, 0, PDFTextAlign.TopLeft); PDFLineAnnotation la = new PDFLineAnnotation("Line", "Line annotation"); la.BeginLineStyle = PDFLineEndingStyle.Circle; la.EndLineStyle = PDFLineEndingStyle.OpenArrow; la.LineDirection = PDFLineDirection.TopLeftToBottomRight; la.Rectangle = new RectangleF(20, 370, 150, 30); la.Border = new PDFAnnotationBorder(1, PDFBorderStyle.Solid); la.Color = new PDFRgbColor(Color.Red); la.InteriorColor = new PDFRgbColor(Color.CornflowerBlue); page.Annotations.Add(la); page.Canvas.DrawText("Line annotation with a circle and open arrow", fontText, null, blackBrush, 20, 420, 0, PDFTextAlign.TopLeft); // File attachment annotations page.Canvas.DrawText("File attachment annotations", fontSection, null, blackBrush, 20, 450, 0, PDFTextAlign.TopLeft); // Create all available file attachment annotations PDFFileAttachmentAnnotation faa = new PDFFileAttachmentAnnotation("Graph", "Graph icon"); faa.Icon = PDFFileAttachmentAnnotationIcon.Graph; faa.Rectangle = new RectangleF(20, 470, 20, 20); faa.FileName = "sample.pdf"; page.Annotations.Add(faa); page.Canvas.DrawText("Graph", fontText, null, blackBrush, 20, 500, 0, PDFTextAlign.TopLeft); faa = new PDFFileAttachmentAnnotation("Paperclip", "Paperclip icon"); faa.Icon = PDFFileAttachmentAnnotationIcon.Paperclip; faa.Rectangle = new RectangleF(100, 470, 20, 20); faa.FileName = "sample.pdf"; page.Annotations.Add(faa); page.Canvas.DrawText("Paperclip", fontText, null, blackBrush, 100, 500, 0, PDFTextAlign.TopLeft); faa = new PDFFileAttachmentAnnotation("PushPin", "PushPin icon"); faa.Icon = PDFFileAttachmentAnnotationIcon.PushPin; faa.Rectangle = new RectangleF(180, 470, 20, 20); faa.FileName = "sample.pdf"; page.Annotations.Add(faa); page.Canvas.DrawText("PushPin", fontText, null, blackBrush, 180, 500, 0, PDFTextAlign.TopLeft); faa = new PDFFileAttachmentAnnotation("Tag", "Tag icon"); faa.Icon = PDFFileAttachmentAnnotationIcon.Tag; faa.Rectangle = new RectangleF(260, 470, 20, 20); faa.FileName = "sample.pdf"; page.Annotations.Add(faa); page.Canvas.DrawText("Graph", fontText, null, blackBrush, 260, 500, 0, PDFTextAlign.TopLeft); // Highlight annotation page.Canvas.DrawText("Markup annotation - this text will be highlighted", fontSection, null, blackBrush, 20, 610); PDFHighlightAnnotation ha = new PDFHighlightAnnotation("Markup annotation", "Markup annotation with highlight style"); ha.Rectangle = new RectangleF(100, 610, 100, 10); ha.Color = new PDFRgbColor(255, 255, 0); page.Annotations.Add(ha); // Square and circle annotations page.Canvas.DrawText("Square and circle annotations", fontSection, null, blackBrush, 20, 650); PDFEllipseAnnotation ea = new PDFEllipseAnnotation("Ellipse annotation", "An ellipse annotation"); ea.Rectangle = new RectangleF(20, 670, 150, 75); ea.Color = new PDFRgbColor(255, 255, 0); ea.InteriorColor = new PDFRgbColor(0, 255, 0); page.Annotations.Add(ea); PDFRectangleAnnotation ra = new PDFRectangleAnnotation("Rectangle annotation", "A rectangle annotation"); ra.Rectangle = new RectangleF(200, 670, 150, 75); ra.Color = new PDFRgbColor(255, 64, 0); ra.InteriorColor = new PDFRgbColor(64, 0, 255); page.Annotations.Add(ra); // Create 2nd page page = doc.AddPage(); page.Canvas.DrawText("Annotations with custom appearance", fontSection, null, blackBrush, 20, 45, 0, PDFTextAlign.BottomLeft); page.Canvas.DrawText("a. Annotations with image appearance", fontSection, null, blackBrush, 20, 60, 0, PDFTextAlign.BottomLeft); PDFRubberStampAnnotation isa = new PDFRubberStampAnnotation("ImageAppearance", "Annotation with image appearance."); Bitmap img = new Bitmap("..\\SupportFiles\\auto1.jpg"); isa.Appearance = new PDFImageAppearance(img); img.Dispose(); isa.Rectangle = new RectangleF(20, 70, 200, 100); page.Annotations.Add(isa); page.Canvas.DrawText("Image appearance", fontText, null, blackBrush, 20, 175, 0, PDFTextAlign.TopLeft); page.Canvas.DrawText("b. Annotations with owner draw appearance", fontSection, null, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft); PDFRubberStampAnnotation odsa = new PDFRubberStampAnnotation("OwnerDrawAppearance", "Annotation with owner draw appearance."); odsa.Rectangle = new RectangleF(20, 220, 200, 100); odsa.Appearance = new PDFAnnotationAppearance(); odsa.Appearance.Width = odsa.Rectangle.Width; odsa.Appearance.Height = odsa.Rectangle.Height; PDFBrush redBrush = new PDFBrush(new PDFRgbColor(192, 0, 0)); odsa.Appearance.Canvas.DrawRoundRectangle(redBrush, 0, 0, odsa.Rectangle.Width, odsa.Rectangle.Height, 40, 40); PDFBrush blueBrush = new PDFBrush(new PDFRgbColor(0, 0, 128)); odsa.Appearance.Canvas.DrawEllipse(blueBrush, (odsa.Rectangle.Width - odsa.Rectangle.Height) / 2, 0, odsa.Rectangle.Height, odsa.Rectangle.Height); page.Annotations.Add(odsa); page.Canvas.DrawText("Owner draw appearance", fontText, null, blackBrush, 20, 325, 0, PDFTextAlign.TopLeft); // Save the document to disk doc.Save("Sample_Annotations.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Annotations.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Annotations Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Fonts Imports O2S.Components.PDF4NET.Graphics.Shapes Namespace O2S.Samples.PDF4NET.Annotations ''' <summary> ''' This sample shows all annotations that can be created with PDF4NET. ''' </summary> Class Annotations ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument() ' Create one page Dim page As PDFPage = doc.AddPage() Dim blackBrush As New PDFBrush(New PDFRgbColor(0, 0, 0)) Dim fontSection As New PDFFont(PDFFontFace.Helvetica, 10) fontSection.Bold = True Dim fontText As New PDFFont(PDFFontFace.Helvetica, 8) page.Canvas.DrawText("Text annotations", fontSection, Nothing, blackBrush, 20, 45, _ 0, PDFTextAlign.BottomLeft) ' Create all available text annotations Dim ta As New PDFTextAnnotation("Comment", "Comment annotation") ta.Icon = PDFTextAnnotationIcon.Comment ta.Rectangle = New RectangleF(20, 60, 20, 20) page.Annotations.Add(ta) page.Canvas.DrawText("Comment", fontText, Nothing, blackBrush, 20, 80, _ 0, PDFTextAlign.TopLeft) ta = New PDFTextAnnotation("Help", "Help annotation") ta.Icon = PDFTextAnnotationIcon.Help ta.Rectangle = New RectangleF(100, 60, 20, 20) page.Annotations.Add(ta) page.Canvas.DrawText("Help", fontText, Nothing, blackBrush, 100, 80, _ 0, PDFTextAlign.TopLeft) ta = New PDFTextAnnotation("Insert", "Insert annotation") ta.Icon = PDFTextAnnotationIcon.Insert ta.Rectangle = New RectangleF(180, 60, 20, 20) page.Annotations.Add(ta) page.Canvas.DrawText("Insert", fontText, Nothing, blackBrush, 180, 80, _ 0, PDFTextAlign.TopLeft) ta = New PDFTextAnnotation("Key", "Key annotation") ta.Icon = PDFTextAnnotationIcon.Key ta.Rectangle = New RectangleF(260, 60, 20, 20) page.Annotations.Add(ta) page.Canvas.DrawText("Key", fontText, Nothing, blackBrush, 260, 80, _ 0, PDFTextAlign.TopLeft) ta = New PDFTextAnnotation("New paragraph", "New paragraph annotation") ta.Icon = PDFTextAnnotationIcon.NewParagraph ta.Rectangle = New RectangleF(340, 60, 20, 20) page.Annotations.Add(ta) page.Canvas.DrawText("New paragraph", fontText, Nothing, blackBrush, 340, 80, _ 0, PDFTextAlign.TopLeft) ta = New PDFTextAnnotation("Note", "Note annotation") ta.Icon = PDFTextAnnotationIcon.Note ta.Rectangle = New RectangleF(420, 60, 20, 20) page.Annotations.Add(ta) page.Canvas.DrawText("Note", fontText, Nothing, blackBrush, 420, 80, _ 0, PDFTextAlign.TopLeft) ta = New PDFTextAnnotation("Paragraph", "Paragraph annotation") ta.Icon = PDFTextAnnotationIcon.Paragraph ta.Rectangle = New RectangleF(500, 60, 20, 20) page.Annotations.Add(ta) page.Canvas.DrawText("Paragraph", fontText, Nothing, blackBrush, 500, 80, _ 0, PDFTextAlign.TopLeft) ' Rubber stamp annotations page.Canvas.DrawText("Rubber stamp annotations", fontSection, Nothing, blackBrush, 20, 120, _ 0, PDFTextAlign.TopLeft) ' Create all available rubber stamp annotations Dim rsa As New PDFRubberStampAnnotation("Approved", "Approved annotation") rsa.Icon = PDFRubberStampAnnotationIcon.Approved rsa.Rectangle = New RectangleF(20, 140, 100, 30) rsa.Opacity = 50 page.Annotations.Add(rsa) page.Canvas.DrawText("Approved", fontText, Nothing, blackBrush, 20, 180, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("As Is", "As Is annotation") rsa.Icon = PDFRubberStampAnnotationIcon.AsIs rsa.Rectangle = New RectangleF(120, 140, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("As Is", fontText, Nothing, blackBrush, 120, 180, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("Confidential", "Confidential annotation") rsa.Icon = PDFRubberStampAnnotationIcon.Confidential rsa.Rectangle = New RectangleF(220, 140, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("Confidential", fontText, Nothing, blackBrush, 220, 180, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("Departmental", "Departmental annotation") rsa.Icon = PDFRubberStampAnnotationIcon.Departmental rsa.Rectangle = New RectangleF(320, 140, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("Departmental", fontText, Nothing, blackBrush, 320, 180, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("Draft", "Draft annotation") rsa.Icon = PDFRubberStampAnnotationIcon.Draft rsa.Rectangle = New RectangleF(420, 140, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("Draft", fontText, Nothing, blackBrush, 420, 180, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("Experimental", "Experimental annotation") rsa.Icon = PDFRubberStampAnnotationIcon.Experimental rsa.Rectangle = New RectangleF(520, 140, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("Experimental", fontText, Nothing, blackBrush, 520, 180, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("Expired", "Expired annotation") rsa.Icon = PDFRubberStampAnnotationIcon.Expired rsa.Rectangle = New RectangleF(20, 200, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("Expired", fontText, Nothing, blackBrush, 20, 240, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("Final", "Final annotation") rsa.Icon = PDFRubberStampAnnotationIcon.Final rsa.Rectangle = New RectangleF(120, 200, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("Final", fontText, Nothing, blackBrush, 120, 240, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("ForComment", "ForComment annotation") rsa.Icon = PDFRubberStampAnnotationIcon.ForComment rsa.Rectangle = New RectangleF(220, 200, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("ForComment", fontText, Nothing, blackBrush, 220, 240, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("ForPublicRelease", "ForPublicRelease annotation") rsa.Icon = PDFRubberStampAnnotationIcon.ForPublicRelease rsa.Rectangle = New RectangleF(320, 200, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("ForPublicRelease", fontText, Nothing, blackBrush, 320, 240, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("NotApproved", "NotApproved annotation") rsa.Icon = PDFRubberStampAnnotationIcon.NotApproved rsa.Rectangle = New RectangleF(420, 200, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("NotApproved", fontText, Nothing, blackBrush, 420, 240, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("NotForPublicRelease", "NotForPublicRelease annotation") rsa.Icon = PDFRubberStampAnnotationIcon.NotForPublicRelease rsa.Rectangle = New RectangleF(520, 200, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("NotForPublicRelease", fontText, Nothing, blackBrush, 520, 240, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("Sold", "Sold annotation") rsa.Icon = PDFRubberStampAnnotationIcon.Sold rsa.Rectangle = New RectangleF(20, 260, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("Sold", fontText, Nothing, blackBrush, 20, 300, _ 0, PDFTextAlign.TopLeft) rsa = New PDFRubberStampAnnotation("TopSecret", "TopSecret annotation") rsa.Icon = PDFRubberStampAnnotationIcon.TopSecret rsa.Rectangle = New RectangleF(120, 260, 100, 30) page.Annotations.Add(rsa) page.Canvas.DrawText("TopSecret", fontText, Nothing, blackBrush, 120, 300, _ 0, PDFTextAlign.TopLeft) ' Line annotations page.Canvas.DrawText("Line annotations", fontSection, Nothing, blackBrush, 20, 350, _ 0, PDFTextAlign.TopLeft) Dim la As New PDFLineAnnotation("Line", "Line annotation") la.BeginLineStyle = PDFLineEndingStyle.Circle la.EndLineStyle = PDFLineEndingStyle.OpenArrow la.LineDirection = PDFLineDirection.TopLeftToBottomRight la.Rectangle = New RectangleF(20, 370, 150, 30) la.Border = New PDFAnnotationBorder(1, PDFBorderStyle.Solid) la.Color = New PDFRgbColor(Color.Red) la.InteriorColor = New PDFRgbColor(Color.CornflowerBlue) page.Annotations.Add(la) page.Canvas.DrawText("Line annotation with a circle and open arrow", fontText, Nothing, blackBrush, 20, 420, _ 0, PDFTextAlign.TopLeft) ' File attachment annotations page.Canvas.DrawText("File attachment annotations", fontSection, Nothing, blackBrush, 20, 450, _ 0, PDFTextAlign.TopLeft) ' Create all available file attachment annotations Dim faa As New PDFFileAttachmentAnnotation("Graph", "Graph icon") faa.Icon = PDFFileAttachmentAnnotationIcon.Graph faa.Rectangle = New RectangleF(20, 470, 20, 20) faa.FileName = "sample.pdf" page.Annotations.Add(faa) page.Canvas.DrawText("Graph", fontText, Nothing, blackBrush, 20, 500, _ 0, PDFTextAlign.TopLeft) faa = New PDFFileAttachmentAnnotation("Paperclip", "Paperclip icon") faa.Icon = PDFFileAttachmentAnnotationIcon.Paperclip faa.Rectangle = New RectangleF(100, 470, 20, 20) faa.FileName = "sample.pdf" page.Annotations.Add(faa) page.Canvas.DrawText("Paperclip", fontText, Nothing, blackBrush, 100, 500, _ 0, PDFTextAlign.TopLeft) faa = New PDFFileAttachmentAnnotation("PushPin", "PushPin icon") faa.Icon = PDFFileAttachmentAnnotationIcon.PushPin faa.Rectangle = New RectangleF(180, 470, 20, 20) faa.FileName = "sample.pdf" page.Annotations.Add(faa) page.Canvas.DrawText("PushPin", fontText, Nothing, blackBrush, 180, 500, _ 0, PDFTextAlign.TopLeft) faa = New PDFFileAttachmentAnnotation("Tag", "Tag icon") faa.Icon = PDFFileAttachmentAnnotationIcon.Tag faa.Rectangle = New RectangleF(260, 470, 20, 20) faa.FileName = "sample.pdf" page.Annotations.Add(faa) page.Canvas.DrawText("Graph", fontText, Nothing, blackBrush, 260, 500, _ 0, PDFTextAlign.TopLeft) ' Highlight annotation page.Canvas.DrawText("Markup annotation - this text will be highlighted", fontSection, Nothing, blackBrush, 20, 610) Dim ha As New PDFHighlightAnnotation("Markup annotation", "Markup annotation with highlight style") ha.Rectangle = New RectangleF(100, 610, 100, 10) ha.Color = New PDFRgbColor(255, 255, 0) page.Annotations.Add(ha) ' Square and circle annotations page.Canvas.DrawText("Square and circle annotations", fontSection, Nothing, blackBrush, 20, 650) Dim ea As New PDFEllipseAnnotation("Ellipse annotation", "An ellipse annotation") ea.Rectangle = New RectangleF(20, 670, 150, 75) ea.Color = New PDFRgbColor(255, 255, 0) ea.InteriorColor = New PDFRgbColor(0, 255, 0) page.Annotations.Add(ea) Dim ra As New PDFRectangleAnnotation("Rectangle annotation", "A rectangle annotation") ra.Rectangle = New RectangleF(200, 670, 150, 75) ra.Color = New PDFRgbColor(255, 64, 0) ra.InteriorColor = New PDFRgbColor(64, 0, 255) page.Annotations.Add(ra) ' Create 2nd page page = doc.AddPage() page.Canvas.DrawText("Annotations with custom appearance", fontSection, Nothing, blackBrush, 20, 45, 0, PDFTextAlign.BottomLeft) page.Canvas.DrawText("a. Annotations with image appearance", fontSection, Nothing, blackBrush, 20, 60, 0, PDFTextAlign.BottomLeft) Dim isa As New PDFRubberStampAnnotation("ImageAppearance", "Annotation with image appearance.") Dim img As New Bitmap("..\SupportFiles\auto1.jpg") isa.Appearance = New PDFImageAppearance(img) img.Dispose() isa.Rectangle = New RectangleF(20, 70, 200, 100) page.Annotations.Add(isa) page.Canvas.DrawText("Image appearance", fontText, Nothing, blackBrush, 20, 175, 0, PDFTextAlign.TopLeft) page.Canvas.DrawText("b. Annotations with owner draw appearance", fontSection, Nothing, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft) Dim odsa As New PDFRubberStampAnnotation("OwnerDrawAppearance", "Annotation with owner draw appearance.") odsa.Rectangle = New RectangleF(20, 220, 200, 100) odsa.Appearance = New PDFAnnotationAppearance() odsa.Appearance.Width = odsa.Rectangle.Width odsa.Appearance.Height = odsa.Rectangle.Height Dim redBrush As New PDFBrush(New PDFRgbColor(192, 0, 0)) odsa.Appearance.Canvas.DrawRoundRectangle(redBrush, 0, 0, odsa.Rectangle.Width, odsa.Rectangle.Height, 40, 40) Dim blueBrush As New PDFBrush(New PDFRgbColor(0, 0, 128)) odsa.Appearance.Canvas.DrawEllipse(blueBrush, (odsa.Rectangle.Width - odsa.Rectangle.Height) / 2, 0, odsa.Rectangle.Height, odsa.Rectangle.Height) page.Annotations.Add(odsa) page.Canvas.DrawText("Owner draw appearance", fontText, Nothing, blackBrush, 20, 325, 0, PDFTextAlign.TopLeft) ' Save the document to disk doc.Save("Sample_Annotations.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: ArcsPies
This samples demonstrates the arcs and pies drawing capabilities of the PDF4NET library. It creates a 2 pages document. On the first page, it draws 50 arcs positioned at random locations, with random angles. On the second page, it draws 50 pies positioned at random locations, with random angles. The colors of the arcs and pies are generated randomly.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


ArcsPies.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Fonts; using O2S.Components.PDF4NET.Graphics.Shapes; namespace O2S.Samples.PDF4NET.ArcsPies { /// <summary> /// This sample will show how to draw arcs and pies /// on the page. /// </summary> class ArcsPies { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor(Color.Black)); PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(Color.Green)); PDFPen pen = new PDFPen(new PDFRgbColor(Color.Orange), 1); Random rnd = new Random(); // Create first page PDFPage pdfPage1 = pdfDoc.AddPage(); // Draw 50 arcs for (int i = 0; i < 50; i++) { // Create random colors for the border and the interior Color penColor = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256)); // Create the pen to draw the border PDFPen randomPen = new PDFPen(new PDFRgbColor(penColor), 1); // Generate random positions float left = rnd.Next((int)pdfPage1.Width); float top = rnd.Next((int)pdfPage1.Height); // Generate random sizes float width = rnd.Next((int)(pdfPage1.Width - left)); // try to keep the arc within the page float height = rnd.Next((int)(pdfPage1.Height - top)); // try to keep the arc within the page float startAngle = rnd.Next(360); float sweepAngle = rnd.Next(360); // Draw the ellipse pdfPage1.Canvas.DrawArc(randomPen, top, left, width, height, startAngle, sweepAngle); } // Draw a label pdfPage1.Canvas.DrawText("Random arcs", fontText, null, blackBrush, 20, 20); // Create the second page PDFPage pdfPage2 = pdfDoc.AddPage(); // Draw 50 pies for (int i = 0; i < 50; i++) { // Create random colors for the border and the interior Color brushColor = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256)); Color penColor = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256)); // Create the brush to fill the interior PDFBrush randomBrush = new PDFBrush(new PDFRgbColor(brushColor)); // Create the pen to draw the border PDFPen randomPen = new PDFPen(new PDFRgbColor(penColor), 1); // Generate random positions float left = rnd.Next((int)pdfPage2.Width); float top = rnd.Next((int)pdfPage2.Height); // Generate random sizes float width = rnd.Next((int)(pdfPage2.Width - left)); // try to keep the pie within the page float height = rnd.Next((int)(pdfPage2.Height - top)); // try to keep the pie within the page float startAngle = rnd.Next(360); float sweepAngle = rnd.Next(360); // Draw the ellipse pdfPage2.Canvas.DrawPie(randomPen, randomBrush, top, left, width, height, startAngle, sweepAngle); } // Draw a label pdfPage2.Canvas.DrawText("Random pies", fontText, null, blackBrush, 20, 20); // Save the document to disk pdfDoc.Save("Sample_ArcsPies.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


ArcsPies.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Fonts Imports O2S.Components.PDF4NET.Graphics.Shapes Namespace O2S.Samples.PDF4NET.ArcsPies ''' <summary> ''' This sample will show how to draw arcs and pies ''' on the page. ''' </summary> Class ArcsPies ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor(Color.Black)) Dim greenBrush As New PDFBrush(New PDFRgbColor(Color.Green)) Dim pen As New PDFPen(New PDFRgbColor(Color.Orange), 1) Dim rnd As New Random() ' Create first page Dim pdfPage1 As PDFPage = pdfDoc.AddPage() ' Draw 50 arcs Dim i As Integer = 0 While i < 50 ' Create random colors for the border and the interior Dim penColor As Color = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256)) ' Create the pen to draw the border Dim randomPen As New PDFPen(New PDFRgbColor(penColor), 1) ' Generate random positions Dim left As Single = rnd.NextDouble() * pdfPage1.Width Dim top As Single = rnd.NextDouble() * pdfPage1.Height ' Generate random sizes Dim width As Single = rnd.NextDouble() * (pdfPage1.Width - left) ' try to keep the arc within the page Dim height As Single = rnd.NextDouble() * (pdfPage1.Height - top) ' try to keep the arc within the page Dim startAngle As Single = rnd.Next(360) Dim sweepAngle As Single = rnd.Next(360) ' Draw the ellipse pdfPage1.Canvas.DrawArc(randomPen, top, left, width, height, startAngle, _ sweepAngle) i = i + 1 End While ' Draw a label pdfPage1.Canvas.DrawText("Random arcs", fontText, Nothing, blackBrush, 20, 20) ' Create the second page Dim pdfPage2 As PDFPage = pdfDoc.AddPage() ' Draw 50 pies i = 0 While i < 50 ' Create random colors for the border and the interior Dim brushColor As Color = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256)) Dim penColor As Color = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256)) ' Create the brush to fill the interior Dim randomBrush As New PDFBrush(New PDFRgbColor(brushColor)) ' Create the pen to draw the border Dim randomPen As New PDFPen(New PDFRgbColor(penColor), 1) ' Generate random positions Dim left As Single = rnd.NextDouble() * pdfPage2.Width Dim top As Single = rnd.NextDouble() * pdfPage2.Height ' Generate random sizes Dim width As Single = rnd.NextDouble() * (pdfPage2.Width - left) ' try to keep the pie within the page Dim height As Single = rnd.NextDouble() * (pdfPage2.Height - top) ' try to keep the pie within the page Dim startAngle As Single = rnd.Next(360) Dim sweepAngle As Single = rnd.Next(360) ' Draw the ellipse pdfPage2.Canvas.DrawPie(randomPen, randomBrush, top, left, width, height, _ startAngle, sweepAngle) i = i + 1 End While ' Draw a label pdfPage2.Canvas.DrawText("Random pies", fontText, Nothing, blackBrush, 20, 20) ' Save the document to disk pdfDoc.Save("Sample_ArcsPies.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Attachments
This sample shows how to work with document attachments using PDF4NET library.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Attachments.cs
using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to work with document attachments using PDF4NET library.
    /// </summary>
    class Attachments
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create a document with 2 file attachments.
            CreateAttachments();

            // Display attachments in a PDF file.
            DisplayAttachments();
        }

        /// <summary>
        /// Creates a PDF file that contains 2 file attachments.
        /// </summary>
        private static void CreateAttachments()
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create a blank page
            PDFPage page = doc.AddPage();
            // Print instructions about how to view the attachments in the PDF file.
            PDFBrush brush = new PDFBrush(new PDFRgbColor(0, 0, 0));
            PDFFont font = new PDFFont();
            page.Canvas.DrawText("This document contains 2 file attachments.",
                font, null, brush, 50, 50);
            page.Canvas.DrawText("In the Acrobat/Reader menu click on View > " +
                "Navigation tabs > Attachments to view them.", font, null, brush, 50, 60);

            // Create an attachment for 'xfasampleform.pdf' file
            PDFDocumentAttachment attachment = new PDFDocumentAttachment();
            attachment.FileName = "..\\SupportFiles\\xfasampleform.pdf";
            attachment.MimeType = "application/pdf";
            attachment.Description = "XFA sample form";
            // Add the attachment to document.
            doc.Attachments.Add(attachment);

            // Create an attachment for 'auto1.pdf' file
            attachment = new PDFDocumentAttachment();
            attachment.FileName = "..\\SupportFiles\\auto1.jpg";
            attachment.MimeType = "image/jpg";
            attachment.Description = "Lexus - Minority Report";
            // Add the attachment to document.
            doc.Attachments.Add(attachment);

            // Save the document to disk
            doc.Save("Sample_Attachments.pdf");
        }

        private static void DisplayAttachments()
        {
            // Load the PDF file that contains the attachments
            // (use the document created by previous function)
            PDFDocument doc = new PDFDocument("Sample_Attachments.pdf");
            // Display the attachments in the document
            for (int i = 0; i < doc.Attachments.Count; i++)
            {
                Console.WriteLine("Attachment: {0}; Description: {1}; Creation Date: {2}",
                    doc.Attachments[i].FileName, doc.Attachments[i].Description,
                    doc.Attachments[i].CreationDate);
                // doc.Attachments[i].FileData contains the attachment content.
                // It can be saved to disk if needed.
            }
        }
    }
}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Attachments.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Fonts Imports O2S.Components.PDF4NET.Graphics.Shapes Namespace O2S.Samples.PDF4NET ''' <summary> ''' This sample shows how to work with document attachments using PDF4NET library. ''' </summary> Class Attachments ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create a document with 2 file attachments. CreateAttachments() ' Display attachments in a PDF file. DisplayAttachments() End Sub ''' <summary> ''' Creates a PDF file that contains 2 file attachments. ''' </summary> Private Shared Sub CreateAttachments() ' Create the pdf document Dim doc As New PDFDocument() ' Create a blank page Dim page As PDFPage = doc.AddPage() ' Print instructions about how to view the attachments in the PDF file. Dim brush As New PDFBrush(New PDFRgbColor(0, 0, 0)) Dim font As New PDFFont() page.Canvas.DrawText("This document contains 2 file attachments.", font, Nothing, brush, 50, 50) page.Canvas.DrawText("In the Acrobat/Reader menu click on View > " + "Navigation tabs > Attachments to view them.", font, Nothing, brush, 50, 60) ' Create an attachment for 'xfasampleform.pdf' file Dim attachment As New PDFDocumentAttachment() attachment.FileName = "..\SupportFiles\xfasampleform.pdf" attachment.MimeType = "application/pdf" attachment.Description = "XFA sample form" ' Add the attachment to document. doc.Attachments.Add(attachment) ' Create an attachment for 'auto1.pdf' file attachment = New PDFDocumentAttachment() attachment.FileName = "..\SupportFiles\auto1.jpg" attachment.MimeType = "image/jpg" attachment.Description = "Lexus - Minority Report" ' Add the attachment to document. doc.Attachments.Add(attachment) ' Save the document to disk doc.Save("Sample_Attachments.pdf") End Sub Private Shared Sub DisplayAttachments() ' Load the PDF file that contains the attachments ' (use the document created by previous function) Dim doc As New PDFDocument("Sample_Attachments.pdf") ' Display the attachments in the document Dim i As Integer = 0 While i < doc.Attachments.Count ' doc.Attachments[i].FileData contains the attachment content. ' It can be saved to disk if needed. Console.WriteLine("Attachment: {0}; Description: {1}; Creation Date: {2}", doc.Attachments(i).FileName, doc.Attachments(i).Description, doc.Attachments(i).CreationDate) i = i + 1 End While End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Autonumbering
This samples demonstrates the autonumbering capabilities of the PDF4NET library. It creates a 100 pages document. Then, it creates 10 numbering ranges, one range for each 10 pages. Each numbering range is considered to be a chapter, the first range is considered to be the introduction. The first numbering range uses roman numbering system, while the others use arabic numbering system. The numbering of the chapters use the chapter number as the prefix for page number.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


AutoNumbering.cs
using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.AutoNumbering
{
    /// <summary>
    /// This sample will show how to use the automatic page numbering feature
    /// available with the PDF4NET library.
    /// The document will have 100 pages, first 10 pages will be the introduction
    /// and they will use roman numerals, then each 10 pages will be grouped as
    /// a chapter. The numbering will be chapter based, meaning the pages will be
    /// numbered within the chapter. Ex: chapte 1: 1-1, 1-2, 1-3, etc, chapter 2:
    /// 2-1, 2-2, 2-3, etc.
    /// </summary>
    class AutoNumbering
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 96);
            PDFFont fontNumber = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            int i;
            // Create 10 numbering ranges, each range will correspond to a chapter
            // The first range is for the introduction.
            for (i = 0; i < 10; i++)
            {
                PDFPageNumberingRange pnr = new PDFPageNumberingRange();
                if (i == 0)
                { // pages in the introduction use roman numerals
                    pnr.NumberingStyle = PDFNumberingStyle.LowerCaseRoman;
                }
                else
                { // pages in the rest of the chapters use arabic numerals
                    pnr.NumberingStyle = PDFNumberingStyle.Arabic;
                }
                // Each numbering range covers 10 pages
                pnr.StartPageIndex = i * 10;

                // Within each chapter, the page numbers will start from 1
                pnr.StartPageNumber = 1;

                // Set the page number prefix for each numbering range
                // to be the number of the chapter. For the introduction
                // we do not set a page number.
                if (i > 0)
                {
                    pnr.PageNumberPrefix = i.ToString() + " - ";
                }

                // Add the numbering range to document
                pdfDoc.PageNumberingRanges.Add(pnr);
            }

            // Create the visual aspect of the page number
            PDFPageNumber pn = new PDFPageNumber();
            pn.Font = fontNumber;
            pn.Brush = blackBrush;
            // Print the page number centered at the bottom of the page
            pn.Align = PDFTextAlign.BottomCenter;
            // The page number will be printed 10 points above the bottom margin.
            pn.VerticalOffset = 10;

            // Set the page number visual aspect for all the pages in the document
            // by attaching it to the document.
            pdfDoc.PageNumber = pn;

            // Create the pages of the document, 100 pages
            for (i = 0; i < 100; i++)
            {
                // Create the page
                PDFPage pdfPage = pdfDoc.AddPage();
                // Draw a label on it
                if (i / 10 == 0)
                {
                    pdfPage.Canvas.DrawText("Introduction",
                        fontText, null, blackBrush, pdfPage.Width / 2, pdfPage.Height / 2,
                        0, PDFTextAlign.MiddleCenter);
                }
                else
                {
                    pdfPage.Canvas.DrawText("Chapter " + (i / 10).ToString(),
                        fontText, null, blackBrush, pdfPage.Width / 2, pdfPage.Height / 2,
                        0, PDFTextAlign.MiddleCenter);
                }
            }

            // Save the document to disk
            pdfDoc.Save("Sample_AutoNumbering.pdf");
        }
    }
}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


AutoNumbering.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.AutoNumbering ''' <summary> ''' This sample will show how to use the automatic page numbering feature ''' available with the PDF4NET library. ''' The document will have 100 pages, first 10 pages will be the introduction ''' and they will use roman numerals, then each 10 pages will be grouped as ''' a chapter. The numbering will be chapter based, meaning the pages will be ''' numbered within the chapter. Ex: chapter 1: 1-1, 1-2, 1-3, etc, chapter 2: ''' 2-1, 2-2, 2-3, etc. ''' </summary> Class AutoNumbering ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 96) Dim fontNumber As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) ' Create the pdf document Dim pdfDoc As New PDFDocument() Dim i As Integer ' Create 10 numbering ranges, each range will correspond to a chapter ' The first range is for the introduction. i = 0 While i < 10 Dim pnr As New PDFPageNumberingRange() If i = 0 Then ' pages in the introduction use roman numerals pnr.NumberingStyle = PDFNumberingStyle.LowerCaseRoman Else ' pages in the rest of the chapters use arabic numerals pnr.NumberingStyle = PDFNumberingStyle.Arabic End If ' Each numbering range covers 10 pages pnr.StartPageIndex = i * 10 ' Within each chapter, the page numbers will start from 1 pnr.StartPageNumber = 1 ' Set the page number prefix for each numbering range ' to be the number of the chapter. For the introduction ' we do not set a page number. If i > 0 Then pnr.PageNumberPrefix = i.ToString() + " - " End If ' Add the numbering range to document pdfDoc.PageNumberingRanges.Add(pnr) i = i + 1 End While ' Create the visual aspect of the page number Dim pn As New PDFPageNumber() pn.Font = fontNumber pn.Brush = blackBrush ' Print the page number centered at the bottom of the page pn.Align = PDFTextAlign.BottomCenter ' The page number will be printed 10 points above the bottom margin. pn.VerticalOffset = 10 ' Set the page number visual aspect for all the pages in the document ' by attaching it to the document. pdfDoc.PageNumber = pn ' Create the pages of the document, 100 pages i = 0 While i < 100 ' Create the page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Draw a label on it If i / 10 = 0 Then pdfPage.Canvas.DrawText("Introduction", fontText, Nothing, blackBrush, pdfPage.Width / 2, pdfPage.Height / 2, _ 0, PDFTextAlign.MiddleCenter) Else pdfPage.Canvas.DrawText("Chapter " + (i / 10).ToString(), fontText, Nothing, blackBrush, pdfPage.Width / 2, pdfPage.Height / 2, _ 0, PDFTextAlign.MiddleCenter) End If i = i + 1 End While ' Save the document to disk pdfDoc.Save("Sample_AutoNumbering.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Barcodes
This sample demonstrates the native support for barcodes implemented in PDF4NET library. Both 1D and 2D barcodes are shown in this sample.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Barcodes.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Barcodes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Barcodes { /// <summary> /// This sample shows how to display barcodes in a PDF document. /// </summary> class Barcodes { [STAThread] static void Main(string[] args) { // Create the PDF document PDFDocument doc = new PDFDocument(); // Create the helper graphic objects. PDFFont titleFont = new PDFFont(PDFFontFace.Helvetica, 10); titleFont.Bold = true; PDFFont textFont = new PDFFont(PDFFontFace.Helvetica, 8); PDFBrush brush = new PDFBrush(new PDFRgbColor(Color.Black)); // First page for linear barcodes. PDFPage page = doc.AddPage(); page.Canvas.DrawText("1D/Linear barcodes", titleFont, null, brush, 20, 50); page.Canvas.DrawText("1. Codabar", textFont, null, brush, 20, 70); PDFCodabarBarcode cb = new PDFCodabarBarcode("0123456789"); page.Canvas.DrawBarcode(cb, 20, 80); page.Canvas.DrawText("2. Code 11", textFont, null, brush, 20, 140); PDFCode11Barcode c11 = new PDFCode11Barcode("0123456789"); page.Canvas.DrawBarcode(c11, 20, 150); page.Canvas.DrawText("3. Code 128A", textFont, null, brush, 20, 210); PDFCode128ABarcode c128a = new PDFCode128ABarcode("CODE128A"); page.Canvas.DrawBarcode(c128a, 20, 220); page.Canvas.DrawText("4. Code 128B", textFont, null, brush, 20, 280); PDFCode128BBarcode c128b = new PDFCode128BBarcode("CODE128B"); page.Canvas.DrawBarcode(c128b, 20, 290); page.Canvas.DrawText("5. Code 128C", textFont, null, brush, 20, 350); PDFCode128CBarcode c128c = new PDFCode128CBarcode("0123456789"); page.Canvas.DrawBarcode(c128c, 20, 360); page.Canvas.DrawText("6. Code 25", textFont, null, brush, 20, 420); PDFCode25Barcode c25 = new PDFCode25Barcode("0123456789"); page.Canvas.DrawBarcode(c25, 20, 430); page.Canvas.DrawText("7. Code 25 Interleaved", textFont, null, brush, 20, 490); PDFCode25InterleavedBarcode c25i = new PDFCode25InterleavedBarcode("0123456789"); page.Canvas.DrawBarcode(c25i, 20, 500); page.Canvas.DrawText("8. Code 39", textFont, null, brush, 20, 560); PDFCode39Barcode c39 = new PDFCode39Barcode("CODE39"); page.Canvas.DrawBarcode(c39, 20, 570); page.Canvas.DrawText("9. Code 39 Extended", textFont, null, brush, 20, 630); PDFCode39ExtendedBarcode c39x = new PDFCode39ExtendedBarcode("C39Ext"); page.Canvas.DrawBarcode(c39x, 20, 640); page.Canvas.DrawText("10. Code 93", textFont, null, brush, 20, 700); PDFCode93Barcode c93 = new PDFCode93Barcode("CODE93"); page.Canvas.DrawBarcode(c93, 20, 710); page.Canvas.DrawText("11. Code 93 Extended", textFont, null, brush, 200, 70); PDFCode93ExtendedBarcode c93x = new PDFCode93ExtendedBarcode("C93Ext"); page.Canvas.DrawBarcode(c93x, 200, 80); page.Canvas.DrawText("12. COOP 25", textFont, null, brush, 200, 140); PDFCOOP25Barcode coop25 = new PDFCOOP25Barcode("0123456789"); page.Canvas.DrawBarcode(coop25, 200, 150); page.Canvas.DrawText("13. EAN-13", textFont, null, brush, 200, 210); PDFEAN13Barcode ean13 = new PDFEAN13Barcode("012345678901"); page.Canvas.DrawBarcode(ean13, 200, 220); page.Canvas.DrawText("14. EAN-8", textFont, null, brush, 200, 280); PDFEAN8Barcode ean8 = new PDFEAN8Barcode("0123456"); page.Canvas.DrawBarcode(ean8, 200, 290); page.Canvas.DrawText("15. IATA 25", textFont, null, brush, 200, 350); PDFIATA25Barcode i25 = new PDFIATA25Barcode("0123456789"); page.Canvas.DrawBarcode(i25, 200, 360); page.Canvas.DrawText("16. ISBN", textFont, null, brush, 200, 420); PDFISBNBarcode isbn = new PDFISBNBarcode("123456789"); page.Canvas.DrawBarcode(isbn, 200, 430); page.Canvas.DrawText("17. ISMN", textFont, null, brush, 200, 490); PDFISMNBarcode ismn = new PDFISMNBarcode("123456789"); page.Canvas.DrawBarcode(ismn, 200, 500); page.Canvas.DrawText("18. ISSN", textFont, null, brush, 200, 560); PDFISSNBarcode issn = new PDFISSNBarcode("123456789"); page.Canvas.DrawBarcode(issn, 200, 570); page.Canvas.DrawText("19. JAN-13", textFont, null, brush, 200, 630); PDFJAN13Barcode jan13 = new PDFJAN13Barcode("1234567890"); page.Canvas.DrawBarcode(jan13, 200, 640); page.Canvas.DrawText("20. Matrix 25", textFont, null, brush, 200, 700); PDFMatrix25Barcode m25 = new PDFMatrix25Barcode("0123456789"); page.Canvas.DrawBarcode(m25, 200, 710); page.Canvas.DrawText("21. Msi/Plessey", textFont, null, brush, 350, 70); PDFMSIPlesseyBarcode msi = new PDFMSIPlesseyBarcode("0123456789"); page.Canvas.DrawBarcode(msi, 350, 80); page.Canvas.DrawText("22. Planet", textFont, null, brush, 350, 140); PDFPlanetBarcode planet = new PDFPlanetBarcode("012345678901"); page.Canvas.DrawBarcode(planet, 350, 150); page.Canvas.DrawText("23. Postnet", textFont, null, brush, 350, 210); PDFPostNetBarcode postnet = new PDFPostNetBarcode("012345678"); page.Canvas.DrawBarcode(postnet, 350, 220); page.Canvas.DrawText("24. RM4SCC", textFont, null, brush, 350, 280); PDFRM4SCCBarcode rm4scc = new PDFRM4SCCBarcode("RM4SCC"); page.Canvas.DrawBarcode(rm4scc, 350, 290); page.Canvas.DrawText("25. SCC-14", textFont, null, brush, 350, 350); PDFSCC14Barcode scc14 = new PDFSCC14Barcode("0123456789012"); page.Canvas.DrawBarcode(scc14, 350, 360); page.Canvas.DrawText("26. SSCC-18", textFont, null, brush, 350, 420); PDFSSCC18Barcode sscc18 = new PDFSSCC18Barcode("00000012331234567"); page.Canvas.DrawBarcode(sscc18, 350, 430); page.Canvas.DrawText("27. UPC-A", textFont, null, brush, 350, 490); PDFUPCABarcode upca = new PDFUPCABarcode("87567816412"); upca.Supplement = "59999"; upca.SupplementYDimension = 20; upca.SupplementDisplayLocation = BarcodeTextLocation.Above; page.Canvas.DrawBarcode(upca, 350, 500); page.Canvas.DrawText("28. UPC-E", textFont, null, brush, 350, 560); PDFUPCEBarcode upce = new PDFUPCEBarcode("0425261"); page.Canvas.DrawBarcode(upce, 350, 570); // Second page for linear barcodes. page = doc.AddPage(); page.Canvas.DrawText("1D/Linear barcodes (continued)", titleFont, null, brush, 20, 50); page.Canvas.DrawText("29. Singapore Post", textFont, null, brush, 20, 70); PDFSingaporePostBarcode singPost = new PDFSingaporePostBarcode("0123456789"); page.Canvas.DrawBarcode(singPost, 20, 80); page.Canvas.DrawText("30. Royal Dutch TPG Post", textFont, null, brush, 20, 140); PDFKixBarcode kix = new PDFKixBarcode("0123456789"); page.Canvas.DrawBarcode(kix, 20, 150); page.Canvas.DrawText("31. PZN", textFont, null, brush, 20, 210); PDFPZNBarcode pzn = new PDFPZNBarcode("123456"); page.Canvas.DrawBarcode(pzn, 20, 220); page.Canvas.DrawText("32. Deutsche Post Identcode", textFont, null, brush, 20, 280); PDFIdentcodeBarcode identcode = new PDFIdentcodeBarcode("01234567890"); page.Canvas.DrawBarcode(identcode, 20, 290); page.Canvas.DrawText("33. Deutsche Post Leitcode", textFont, null, brush, 20, 350); PDFLeitcodeBarcode leitcode = new PDFLeitcodeBarcode("0123456789012"); page.Canvas.DrawBarcode(leitcode, 20, 360); page.Canvas.DrawText("34. USPS Facing Identification Mark", textFont, null, brush, 20, 420); PDFUSPSFIMBarcode fim = new PDFUSPSFIMBarcode("A"); page.Canvas.DrawBarcode(fim, 20, 430); page.Canvas.DrawText("35. USPS Horizontal Bars", textFont, null, brush, 20, 490); PDFUSPSHorizontalBarcode hb = new PDFUSPSHorizontalBarcode("111"); page.Canvas.DrawBarcode(hb, 20, 500); page.Canvas.DrawText("36. USPS Package Identification Code", textFont, null, brush, 20, 560); PDFUSPSPICBarcode pic = new PDFUSPSPICBarcode("910123456789012345678"); page.Canvas.DrawBarcode(pic, 20, 570); page.Canvas.DrawText("37. FedEx Ground 96", textFont, null, brush, 20, 630); PDFFedExGround96Barcode fg96 = new PDFFedExGround96Barcode("960123456789012345678"); page.Canvas.DrawBarcode(fg96, 20, 640); page.Canvas.DrawText("38. Pharmacode", textFont, null, brush, 20, 700); PDFPharmacodeBarcode pharma = new PDFPharmacodeBarcode("12345"); page.Canvas.DrawBarcode(pharma, 20, 710); page.Canvas.DrawText("39. Code 32 - Italian Pharmacode", textFont, null, brush, 200, 70); PDFCode32Barcode c32 = new PDFCode32Barcode("12345678"); page.Canvas.DrawBarcode(c32, 200, 80); page.Canvas.DrawText("40. UCC/EAN 128", textFont, null, brush, 200, 140); PDFEAN128Barcode ean128 = new PDFEAN128Barcode("0123456789"); ean128.ApplicationIdentifier = "101"; page.Canvas.DrawBarcode(ean128, 200, 150); // Create the 3rd page to display 2D barcodes. page = doc.AddPage(); page.Canvas.DrawText("2D/Bidimensional barcodes", titleFont, null, brush, 20, 50); page.Canvas.DrawText("1. Codablock F", textFont, null, brush, 20, 70); PDFCodablockFBarcode cf = new PDFCodablockFBarcode(); cf.Rows = 5; cf.Columns = 7; cf.Data = "1234567890"; page.Canvas.DrawBarcode(cf, 20, 80); page.Canvas.DrawText("2. Code 16K", textFont, null, brush, 20, 140); PDFCode16KBarcode c16k = new PDFCode16KBarcode(); c16k.Rows = 0; c16k.Data = "Abcd-1234567890-wxyZ"; page.Canvas.DrawBarcode(c16k, 20, 150); page.Canvas.DrawText("3. DataMatrix", textFont, null, brush, 20, 210); PDFDataMatrixBarcode dm = new PDFDataMatrixBarcode(); dm.Encoding = DataMatrixEncoding.ASCII; dm.SymbolSize = DataMatrixSymbolSize.Auto; dm.Data = "ABCDabcd"; dm.XDimension = 3; page.Canvas.DrawBarcode(dm, 20, 220); page.Canvas.DrawText("4. MicroPDF417", textFont, null, brush, 20, 280); PDFMicroPDF417Barcode mpdf417 = new PDFMicroPDF417Barcode(); mpdf417.CompactionMode = PDF417DataCompactionMode.Text; mpdf417.Data = "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZ" + "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZAB"; mpdf417.XDimension = 1; mpdf417.YDimension = 2.5f; mpdf417.SymbolSize = MicroPDF417SymbolSize.Size20x4; page.Canvas.DrawBarcode(mpdf417, 20, 290); page.Canvas.DrawText("5. PDF417", textFont, null, brush, 20, 370); PDF417Barcode pdf417 = new PDF417Barcode(); pdf417.CompactionMode = PDF417DataCompactionMode.Text; pdf417.Data = "ABCDEF"; pdf417.Rows = 5; pdf417.Columns = 5; pdf417.XDimension = 1; pdf417.YDimension = 10; pdf417.ErrorCorrectionLevel = PDF417ErrorCorrectionLevel.Level2; page.Canvas.DrawBarcode(pdf417, 20, 380); doc.Save("Sample_Barcodes.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Barcodes.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Barcodes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Barcodes ''' <summary> ''' This sample shows how to display barcodes in a PDF document. ''' </summary> Class Barcodes <STAThread> _ Shared Sub Main(args As String()) ' Create the PDF document Dim doc As New PDFDocument() ' Create the helper graphic objects. Dim titleFont As New PDFFont(PDFFontFace.Helvetica, 10) titleFont.Bold = True Dim textFont As New PDFFont(PDFFontFace.Helvetica, 8) Dim brush As New PDFBrush(New PDFRgbColor(Color.Black)) ' First page for linear barcodes. Dim page As PDFPage = doc.AddPage() page.Canvas.DrawText("1D/Linear barcodes", titleFont, Nothing, brush, 20, 50) page.Canvas.DrawText("1. Codabar", textFont, Nothing, brush, 20, 70) Dim cb As New PDFCodabarBarcode("0123456789") page.Canvas.DrawBarcode(cb, 20, 80) page.Canvas.DrawText("2. Code 11", textFont, Nothing, brush, 20, 140) Dim c11 As New PDFCode11Barcode("0123456789") page.Canvas.DrawBarcode(c11, 20, 150) page.Canvas.DrawText("3. Code 128A", textFont, Nothing, brush, 20, 210) Dim c128a As New PDFCode128ABarcode("CODE128A") page.Canvas.DrawBarcode(c128a, 20, 220) page.Canvas.DrawText("4. Code 128B", textFont, Nothing, brush, 20, 280) Dim c128b As New PDFCode128BBarcode("CODE128B") page.Canvas.DrawBarcode(c128b, 20, 290) page.Canvas.DrawText("5. Code 128C", textFont, Nothing, brush, 20, 350) Dim c128c As New PDFCode128CBarcode("0123456789") page.Canvas.DrawBarcode(c128c, 20, 360) page.Canvas.DrawText("6. Code 25", textFont, Nothing, brush, 20, 420) Dim c25 As New PDFCode25Barcode("0123456789") page.Canvas.DrawBarcode(c25, 20, 430) page.Canvas.DrawText("7. Code 25 Interleaved", textFont, Nothing, brush, 20, 490) Dim c25i As New PDFCode25InterleavedBarcode("0123456789") page.Canvas.DrawBarcode(c25i, 20, 500) page.Canvas.DrawText("8. Code 39", textFont, Nothing, brush, 20, 560) Dim c39 As New PDFCode39Barcode("CODE39") page.Canvas.DrawBarcode(c39, 20, 570) page.Canvas.DrawText("9. Code 39 Extended", textFont, Nothing, brush, 20, 630) Dim c39x As New PDFCode39ExtendedBarcode("C39Ext") page.Canvas.DrawBarcode(c39x, 20, 640) page.Canvas.DrawText("10. Code 93", textFont, Nothing, brush, 20, 700) Dim c93 As New PDFCode93Barcode("CODE93") page.Canvas.DrawBarcode(c93, 20, 710) page.Canvas.DrawText("11. Code 93 Extended", textFont, Nothing, brush, 200, 70) Dim c93x As New PDFCode93ExtendedBarcode("C93Ext") page.Canvas.DrawBarcode(c93x, 200, 80) page.Canvas.DrawText("12. COOP 25", textFont, Nothing, brush, 200, 140) Dim coop25 As New PDFCOOP25Barcode("0123456789") page.Canvas.DrawBarcode(coop25, 200, 150) page.Canvas.DrawText("13. EAN-13", textFont, Nothing, brush, 200, 210) Dim ean13 As New PDFEAN13Barcode("012345678901") page.Canvas.DrawBarcode(ean13, 200, 220) page.Canvas.DrawText("14. EAN-8", textFont, Nothing, brush, 200, 280) Dim ean8 As New PDFEAN8Barcode("0123456") page.Canvas.DrawBarcode(ean8, 200, 290) page.Canvas.DrawText("15. IATA 25", textFont, Nothing, brush, 200, 350) Dim i25 As New PDFIATA25Barcode("0123456789") page.Canvas.DrawBarcode(i25, 200, 360) page.Canvas.DrawText("16. ISBN", textFont, Nothing, brush, 200, 420) Dim isbn As New PDFISBNBarcode("123456789") page.Canvas.DrawBarcode(isbn, 200, 430) page.Canvas.DrawText("17. ISMN", textFont, Nothing, brush, 200, 490) Dim ismn As New PDFISMNBarcode("123456789") page.Canvas.DrawBarcode(ismn, 200, 500) page.Canvas.DrawText("18. ISSN", textFont, Nothing, brush, 200, 560) Dim issn As New PDFISSNBarcode("123456789") page.Canvas.DrawBarcode(issn, 200, 570) page.Canvas.DrawText("19. JAN-13", textFont, Nothing, brush, 200, 630) Dim jan13 As New PDFJAN13Barcode("1234567890") page.Canvas.DrawBarcode(jan13, 200, 640) page.Canvas.DrawText("20. Matrix 25", textFont, Nothing, brush, 200, 700) Dim m25 As New PDFMatrix25Barcode("0123456789") page.Canvas.DrawBarcode(m25, 200, 710) page.Canvas.DrawText("21. Msi/Plessey", textFont, Nothing, brush, 350, 70) Dim msi As New PDFMSIPlesseyBarcode("0123456789") page.Canvas.DrawBarcode(msi, 350, 80) page.Canvas.DrawText("22. Planet", textFont, Nothing, brush, 350, 140) Dim planet As New PDFPlanetBarcode("012345678901") page.Canvas.DrawBarcode(planet, 350, 150) page.Canvas.DrawText("23. Postnet", textFont, Nothing, brush, 350, 210) Dim postnet As New PDFPostNetBarcode("012345678") page.Canvas.DrawBarcode(postnet, 350, 220) page.Canvas.DrawText("24. RM4SCC", textFont, Nothing, brush, 350, 280) Dim rm4scc As New PDFRM4SCCBarcode("RM4SCC") page.Canvas.DrawBarcode(rm4scc, 350, 290) page.Canvas.DrawText("25. SCC-14", textFont, Nothing, brush, 350, 350) Dim scc14 As New PDFSCC14Barcode("0123456789012") page.Canvas.DrawBarcode(scc14, 350, 360) page.Canvas.DrawText("26. SSCC-18", textFont, Nothing, brush, 350, 420) Dim sscc18 As New PDFSSCC18Barcode("00000012331234567") page.Canvas.DrawBarcode(sscc18, 350, 430) page.Canvas.DrawText("27. UPC-A", textFont, Nothing, brush, 350, 490) Dim upca As New PDFUPCABarcode("87567816412") upca.Supplement = "59999" upca.SupplementYDimension = 20 upca.SupplementDisplayLocation = BarcodeTextLocation.Above page.Canvas.DrawBarcode(upca, 350, 500) page.Canvas.DrawText("28. UPC-E", textFont, Nothing, brush, 350, 560) Dim upce As New PDFUPCEBarcode("0425261") page.Canvas.DrawBarcode(upce, 350, 570) ' Second page for linear barcodes. page = doc.AddPage() page.Canvas.DrawText("1D/Linear barcodes (continued)", titleFont, Nothing, brush, 20, 50) page.Canvas.DrawText("29. Singapore Post", textFont, Nothing, brush, 20, 70) Dim singPost As New PDFSingaporePostBarcode("0123456789") page.Canvas.DrawBarcode(singPost, 20, 80) page.Canvas.DrawText("30. Royal Dutch TPG Post", textFont, Nothing, brush, 20, 140) Dim kix As New PDFKixBarcode("0123456789") page.Canvas.DrawBarcode(kix, 20, 150) page.Canvas.DrawText("31. PZN", textFont, Nothing, brush, 20, 210) Dim pzn As New PDFPZNBarcode("123456") page.Canvas.DrawBarcode(pzn, 20, 220) page.Canvas.DrawText("32. Deutsche Post Identcode", textFont, Nothing, brush, 20, 280) Dim identcode As New PDFIdentcodeBarcode("01234567890") page.Canvas.DrawBarcode(identcode, 20, 290) page.Canvas.DrawText("33. Deutsche Post Leitcode", textFont, Nothing, brush, 20, 350) Dim leitcode As New PDFLeitcodeBarcode("0123456789012") page.Canvas.DrawBarcode(leitcode, 20, 360) page.Canvas.DrawText("34. USPS Facing Identification Mark", textFont, Nothing, brush, 20, 420) Dim fim As New PDFUSPSFIMBarcode("A") page.Canvas.DrawBarcode(fim, 20, 430) page.Canvas.DrawText("35. USPS Horizontal Bars", textFont, Nothing, brush, 20, 490) Dim hb As New PDFUSPSHorizontalBarcode("111") page.Canvas.DrawBarcode(hb, 20, 500) page.Canvas.DrawText("36. USPS Package Identification Code", textFont, Nothing, brush, 20, 560) Dim pic As New PDFUSPSPICBarcode("910123456789012345678") page.Canvas.DrawBarcode(pic, 20, 570) page.Canvas.DrawText("37. FedEx Ground 96", textFont, Nothing, brush, 20, 630) Dim fg96 As New PDFFedExGround96Barcode("960123456789012345678") page.Canvas.DrawBarcode(fg96, 20, 640) page.Canvas.DrawText("38. Pharmacode", textFont, Nothing, brush, 20, 700) Dim pharma As New PDFPharmacodeBarcode("12345") page.Canvas.DrawBarcode(pharma, 20, 710) page.Canvas.DrawText("39. Code 32 - Italian Pharmacode", textFont, Nothing, brush, 200, 70) Dim c32 As New PDFCode32Barcode("12345678") page.Canvas.DrawBarcode(c32, 200, 80) page.Canvas.DrawText("40. UCC/EAN 128", textFont, Nothing, brush, 200, 140) Dim ean128 As New PDFEAN128Barcode("0123456789") ean128.ApplicationIdentifier = "101" page.Canvas.DrawBarcode(ean128, 200, 150) ' Create the 3rd page to display 2D barcodes. page = doc.AddPage() page.Canvas.DrawText("2D/Bidimensional barcodes", titleFont, Nothing, brush, 20, 50) page.Canvas.DrawText("1. Codablock F", textFont, Nothing, brush, 20, 70) Dim cf As New PDFCodablockFBarcode() cf.Rows = 5 cf.Columns = 7 cf.Data = "1234567890" page.Canvas.DrawBarcode(cf, 20, 80) page.Canvas.DrawText("2. Code 16K", textFont, Nothing, brush, 20, 140) Dim c16k As New PDFCode16KBarcode() c16k.Rows = 0 c16k.Data = "Abcd-1234567890-wxyZ" page.Canvas.DrawBarcode(c16k, 20, 150) page.Canvas.DrawText("3. DataMatrix", textFont, Nothing, brush, 20, 210) Dim dm As New PDFDataMatrixBarcode() dm.Encoding = DataMatrixEncoding.ASCII dm.SymbolSize = DataMatrixSymbolSize.Auto dm.Data = "ABCDabcd" dm.XDimension = 3 page.Canvas.DrawBarcode(dm, 20, 220) page.Canvas.DrawText("4. MicroPDF417", textFont, Nothing, brush, 20, 280) Dim mpdf417 As New PDFMicroPDF417Barcode() mpdf417.CompactionMode = PDF417DataCompactionMode.Text mpdf417.Data = "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZ" + "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZAB" mpdf417.XDimension = 1 mpdf417.YDimension = 2.5F mpdf417.SymbolSize = MicroPDF417SymbolSize.Size20x4 page.Canvas.DrawBarcode(mpdf417, 20, 290) page.Canvas.DrawText("5. PDF417", textFont, Nothing, brush, 20, 370) Dim pdf417 As New PDF417Barcode() pdf417.CompactionMode = PDF417DataCompactionMode.Text pdf417.Data = "ABCDEF" pdf417.Rows = 5 pdf417.Columns = 5 pdf417.XDimension = 1 pdf417.YDimension = 10 pdf417.ErrorCorrectionLevel = PDF417ErrorCorrectionLevel.Level2 page.Canvas.DrawBarcode(pdf417, 20, 380) doc.Save("Sample_Barcodes.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Bezier
This samples demonstrates the bezier splines drawing capabilities of the PDF4NET library. It creates a 1 page document. On the first page, it draws 50 bezier splines positioned at random locations. The colors of the bezier splines are generated randomly.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Bezier.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Bezier { /// <summary> /// This sample will show how to draw Bezier splines /// on the page. /// </summary> class Bezier { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create first page PDFPage pdfPage1 = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); Random rnd = new Random(); for (int i = 0; i < 50; i++) { // Create random colors for drawing the spline PDFColor penColor = new PDFRgbColor((byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256)); // Create the pen to draw the border PDFPen randomPen = new PDFPen(penColor, 1); // Generate random control points float x1 = rnd.Next((int)pdfPage1.Width); float y1 = rnd.Next((int)pdfPage1.Height); float x2 = rnd.Next((int)pdfPage1.Width); float y2 = rnd.Next((int)pdfPage1.Height); float x3 = rnd.Next((int)pdfPage1.Width); float y3 = rnd.Next((int)pdfPage1.Height); float x4 = rnd.Next((int)pdfPage1.Width); float y4 = rnd.Next((int)pdfPage1.Height); // Draw the Bezier spline pdfPage1.Canvas.DrawBezier(randomPen, x1, y1, x2, y2, x3, y3, x4, y4); } // Draw a label pdfPage1.Canvas.DrawText("Random Bezier splines", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); // Save the document to disk pdfDoc.Save("Sample_Bezier.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Bezier.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Bezier ''' <summary> ''' This sample will show how to draw Bezier splines ''' on the page. ''' </summary> Class Bezier ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create first page Dim pdfPage1 As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim rnd As New Random() Dim i As Integer = 0 While i < 50 ' Create random colors for drawing the spline Dim penColor As PDFColor = New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256)) ' Create the pen to draw the border Dim randomPen As New PDFPen(penColor, 1) ' Generate random control points Dim x1 As Double = rnd.NextDouble() * pdfPage1.Width Dim y1 As Double = rnd.NextDouble() * pdfPage1.Height Dim x2 As Double = rnd.NextDouble() * pdfPage1.Width Dim y2 As Double = rnd.NextDouble() * pdfPage1.Height Dim x3 As Double = rnd.NextDouble() * pdfPage1.Width Dim y3 As Double = rnd.NextDouble() * pdfPage1.Height Dim x4 As Double = rnd.NextDouble() * pdfPage1.Width Dim y4 As Double = rnd.NextDouble() * pdfPage1.Height ' Draw the Bezier spline pdfPage1.Canvas.DrawBezier(randomPen, x1, y1, x2, y2, x3, y3, x4, y4) i = i + 1 End While ' Draw a label pdfPage1.Canvas.DrawText("Random Bezier splines", _ fontText, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft) ' Save the document to disk pdfDoc.Save("Sample_Bezier.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Bookmarks
This samples demonstrates the bookmarks capabilities of the PDF4NET library. It creates a 10 pages document. Each page is considered to be a chapter. Each chapter has 2 sections, and each section has 3 paragraphs. Then, the sample builds the corresponding outlines tree, allowing to quickly navigate to each chapter / section / paragraph.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Bookmarks.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; using O2S.Components.PDF4NET.Actions; namespace O2S.Samples.PDF4NET.Bookmarks { /// <summary> /// This sample will show how to create a bookmarks/outlines tree /// for a document /// </summary> class Bookmarks { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the graphic objects PDFFont fontChapter = new PDFFont(PDFFontFace.Helvetica, 20); fontChapter.Bold = true; PDFFont fontSection = new PDFFont(PDFFontFace.Helvetica, 16); fontSection.Italic = true; PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Display the outlines when opening the document pdfDoc.DisplayMode = PDFDisplayMode.UseOutlines; // Create 10 pages for (int i = 0; i < 10; i++) { PDFPage pdfPage = pdfDoc.AddPage(); pdfPage.Canvas.DrawText("Chapter " + (i + 1).ToString(), fontChapter, null, blackBrush, 10, 10, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Section " + (i + 1).ToString() + ".1", fontSection, null, blackBrush, 20, 32, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.1", fontText, null, blackBrush, 30, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.2", fontText, null, blackBrush, 30, 200, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.3", fontText, null, blackBrush, 30, 300, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Section " + (i + 1).ToString() + ".2", fontSection, null, blackBrush, 20, 400, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.1", fontText, null, blackBrush, 30, 420, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.2", fontText, null, blackBrush, 30, 570, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.3", fontText, null, blackBrush, 30, 650, 0, PDFTextAlign.TopLeft); } // Create the bookmarks tree // Create a root outline PDFBookmark root = CreateBookmark("Bookmarks", new PDFRgbColor(Color.Black), PDFBookmarkDisplayStyle.Bold, pdfDoc.Pages[0]); pdfDoc.Bookmarks.Add(root); // Create document bookmarks for (int i = 0; i < pdfDoc.Pages.Count; i++) { // Create chapter bookmark PDFBookmark chapter = CreateBookmark("Chapter " + (i + 1).ToString(), new PDFRgbColor(Color.Blue), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages[i]); root.Bookmarks.Add(chapter); // Create section 1 bookmark PDFBookmark section1 = CreateBookmark("Section " + (i + 1).ToString() + ".1", new PDFRgbColor(Color.Green), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages[i]); chapter.Bookmarks.Add(section1); // Create paragraph bookmarks PDFBookmark paragraph11 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.1", new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]); section1.Bookmarks.Add(paragraph11); PDFBookmark paragraph12 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.2", new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]); section1.Bookmarks.Add(paragraph12); PDFBookmark paragraph13 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.3", new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]); section1.Bookmarks.Add(paragraph13); section1.Expanded = true; // Create section 2 bookmark PDFBookmark section2 = CreateBookmark("Section " + (i + 1).ToString() + ".2", new PDFRgbColor(Color.Green), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages[i]); chapter.Bookmarks.Add(section2); // Create paragraph bookmarks PDFBookmark paragraph21 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.1", new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]); section2.Bookmarks.Add(paragraph21); PDFBookmark paragraph22 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.2", new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]); section2.Bookmarks.Add(paragraph22); PDFBookmark paragraph23 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.3", new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]); section2.Bookmarks.Add(paragraph23); section2.Expanded = true; chapter.Expanded = true; } root.Expanded = true; // Save the document to disk pdfDoc.Save("Sample_Bookmarks.pdf"); } /// <summary> /// Creates a new bookmark and adds it at the end of the collection. /// </summary> /// <param name="title">the title of the bookmark</param> /// <param name="bookmarkColor">a <see cref="PDFRgbColor"/> object specifying /// the color used to draw the bookmark in the bookmark tree.</param> /// <param name="displayStyle">a combination of <see cref="PDFBookmarkDisplayStyle"/> /// enumeration members, specifying the font style used to draw /// the bookmark title.</param> /// <param name="destinationPage">a <see cref="PDFPage"/> object /// representing the destination of the bookmark.</param> /// <returns>a <see cref="PDFBookmark"/> object representing the /// newly created bookmark.</returns> public static PDFBookmark CreateBookmark(string title, PDFRgbColor bookmarkColor, PDFBookmarkDisplayStyle displayStyle, PDFPage destinationPage) { PDFBookmark bookmark = new PDFBookmark(); bookmark.Title = title; bookmark.Color = bookmarkColor; bookmark.DisplayStyle = displayStyle; PDFGoToAction gotoAction = new PDFGoToAction(); gotoAction.Destination = new PDFPageDestination(); gotoAction.Destination.Page = destinationPage; bookmark.Action = gotoAction; return bookmark; } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Bookmarks.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Imports O2S.Components.PDF4NET.Actions Namespace O2S.Samples.PDF4NET.Bookmarks ''' <summary> ''' This sample will show how to create a bookmarks/outlines tree ''' for a document ''' </summary> Class Bookmarks ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the graphic objects Dim fontChapter As New PDFFont(PDFFontFace.Helvetica, 20) fontChapter.Bold = True Dim fontSection As New PDFFont(PDFFontFace.Helvetica, 16) fontSection.Italic = True Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Display the outlines when opening the document pdfDoc.DisplayMode = PDFDisplayMode.UseOutlines ' Create 10 pages Dim i As Integer = 0 While i < 10 Dim pdfPage As PDFPage = pdfDoc.AddPage() pdfPage.Canvas.DrawText("Chapter " + (i + 1).ToString(), fontChapter, Nothing, blackBrush, 10, 10, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Section " + (i + 1).ToString() + ".1", fontSection, Nothing, blackBrush, 20, 32, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.1", fontText, Nothing, blackBrush, 30, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.2", fontText, Nothing, blackBrush, 30, 200, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.3", fontText, Nothing, blackBrush, 30, 300, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Section " + (i + 1).ToString() + ".2", fontSection, Nothing, blackBrush, 20, 400, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.1", fontText, Nothing, blackBrush, 30, 420, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.2", fontText, Nothing, blackBrush, 30, 570, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.3", fontText, Nothing, blackBrush, 30, 650, _ 0, PDFTextAlign.TopLeft) i = i + 1 End While ' Create the bookmarks tree ' Create a root outline Dim root As PDFBookmark = CreateBookmark("Bookmarks", New PDFRgbColor(Color.Black), PDFBookmarkDisplayStyle.Bold, pdfDoc.Pages(0)) pdfDoc.Bookmarks.Add(root) ' Create document bookmarks i = 0 While i < pdfDoc.Pages.Count ' Create chapter bookmark Dim chapter As PDFBookmark = CreateBookmark("Chapter " + (i + 1).ToString(), New PDFRgbColor(Color.Blue), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages(i)) root.Bookmarks.Add(chapter) ' Create section 1 bookmark Dim section1 As PDFBookmark = CreateBookmark("Section " + (i + 1).ToString() + ".1", New PDFRgbColor(Color.Green), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages(i)) chapter.Bookmarks.Add(section1) ' Create paragraph bookmarks Dim paragraph11 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.1", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i)) section1.Bookmarks.Add(paragraph11) Dim paragraph12 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.2", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i)) section1.Bookmarks.Add(paragraph12) Dim paragraph13 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.3", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i)) section1.Bookmarks.Add(paragraph13) section1.Expanded = True ' Create section 2 bookmark Dim section2 As PDFBookmark = CreateBookmark("Section " + (i + 1).ToString() + ".2", New PDFRgbColor(Color.Green), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages(i)) chapter.Bookmarks.Add(section2) ' Create paragraph bookmarks Dim paragraph21 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.1", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i)) section2.Bookmarks.Add(paragraph21) Dim paragraph22 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.2", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i)) section2.Bookmarks.Add(paragraph22) Dim paragraph23 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.3", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i)) section2.Bookmarks.Add(paragraph23) section2.Expanded = True chapter.Expanded = True i = i + 1 End While root.Expanded = True ' Save the document to disk pdfDoc.Save("Sample_Bookmarks.pdf") End Sub ''' <summary> ''' Creates a new bookmark and adds it at the end of the collection. ''' </summary> ''' <param name="title">the title of the bookmark</param> ''' <param name="bookmarkColor">a <see cref="PDFRgbColor"/> object specifying ''' the color used to draw the bookmark in the bookmark tree.</param> ''' <param name="displayStyle">a combination of <see cref="PDFBookmarkDisplayStyle"/> ''' enumeration members, specifying the font style used to draw ''' the bookmark title.</param> ''' <param name="destinationPage">a <see cref="PDFPage"/> object ''' representing the destination of the bookmark.</param> ''' <returns>a <see cref="PDFBookmark"/> object representing the ''' newly created bookmark.</returns> Public Shared Function CreateBookmark(title As String, bookmarkColor As PDFRgbColor, displayStyle As PDFBookmarkDisplayStyle, destinationPage As PDFPage) As PDFBookmark Dim bookmark As New PDFBookmark() bookmark.Title = title bookmark.Color = bookmarkColor bookmark.DisplayStyle = displayStyle Dim gotoAction As New PDFGoToAction() gotoAction.Destination = New PDFPageDestination() gotoAction.Destination.Page = destinationPage bookmark.Action = gotoAction Return bookmark End Function End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: CharacterMap
This samples prints all the font glyphs in a standard latin font, as they are represented by the pdf. For each glyph, its decimal and hex code are printed. On the second page, it prints all the glyphs in Symbol font, together with their decimal and hex codes. The third page is similar to second page, but it uses the ZapfDingbats font.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


CharacterMap.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.CharacterMap { /// <summary> /// This sample prints all available characters in WinAnsiEncoding, plus /// those available in ZapfDingbats and Symbol fonts. /// </summary> class CharacterMap { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); DrawFirstPage(pdfDoc); DrawSecondPage(pdfDoc); DrawThirdPage(pdfDoc); // Save the document to disk pdfDoc.Save("Sample_CharacterMap.pdf"); } private static void DrawFirstPage(PDFDocument pdfDoc) { PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFFont fontCode = new PDFFont(PDFFontFace.Helvetica, 11); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); pdfPage.Canvas.DrawText("Latin font - WinAnsiEncoding", fontText, null, blackBrush, 10, 30, 0, PDFTextAlign.TopLeft); // Draw the header for the first column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 10, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 70, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 100, 50, 0, PDFTextAlign.TopLeft); // Draw the header for the second column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 170, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 230, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 260, 50, 0, PDFTextAlign.TopLeft); // Draw the header for the third column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 330, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 390, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 420, 50, 0, PDFTextAlign.TopLeft); // Draw the header for the fourth column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 490, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 550, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 580, 50, 0, PDFTextAlign.TopLeft); // Draw the codes and characters float xDec = 10; float xHex = 70; float xChar = 100; float xDelta = 160; float y = 65; byte i = 31; while (i <= 255) { i++; if (((i - 32) % 60 == 0) && i != 32) { xDec = xDec + xDelta; xHex = xHex + xDelta; xChar = xChar + xDelta; y = 65; } char c = (char)i; pdfPage.Canvas.DrawText(i.ToString(), fontCode, null, blackBrush, xDec, y, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("\\x" + i.ToString("X"), fontCode, null, blackBrush, xHex, y, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText(c.ToString(), fontCode, null, blackBrush, xChar, y, 0, PDFTextAlign.TopLeft); y = y + 12; if (i == 255) { break; } } } private static void DrawSecondPage(PDFDocument pdfDoc) { // Create second page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontChar = new PDFFont(PDFFontFace.Symbol, 11); PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFFont fontCode = new PDFFont(PDFFontFace.Helvetica, 11); pdfPage.Canvas.DrawText("Symbol font", fontText, null, blackBrush, 10, 30, 0, PDFTextAlign.TopLeft); // Draw the header for the first column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 10, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 70, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 100, 50, 0, PDFTextAlign.TopLeft); // Draw the header for the second column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 170, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 230, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 260, 50, 0, PDFTextAlign.TopLeft); // Draw the header for the third column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 330, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 390, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 420, 50, 0, PDFTextAlign.TopLeft); // Draw the header for the fourth column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 490, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 550, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 580, 50, 0, PDFTextAlign.TopLeft); // Draw the codes and characters float xDec = 10; float xHex = 70; float xChar = 100; float xDelta = 160; float y = 65; byte i = 31; while (i <= 255) { i++; if (((i - 32) % 60 == 0) && i != 32) { xDec = xDec + xDelta; xHex = xHex + xDelta; xChar = xChar + xDelta; y = 65; } char c = (char)i; pdfPage.Canvas.DrawText(i.ToString(), fontCode, null, blackBrush, xDec, y, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("\\x" + i.ToString("X"), fontCode, null, blackBrush, xHex, y, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText(c.ToString(), fontChar, null, blackBrush, xChar, y, 0, PDFTextAlign.TopLeft); y = y + 12; if (i == 255) { break; } } } private static void DrawThirdPage(PDFDocument pdfDoc) { // Create first page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontChar = new PDFFont(PDFFontFace.ZapfDingbats, 11); PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFFont fontCode = new PDFFont(PDFFontFace.Helvetica, 11); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); pdfPage.Canvas.DrawText("ZapfDingbats font", fontText, null, blackBrush, 10, 30, 0, PDFTextAlign.TopLeft); // Draw the header for the first column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 10, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 70, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 100, 50, 0, PDFTextAlign.TopLeft); // Draw the header for the second column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 170, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 230, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 260, 50, 0, PDFTextAlign.TopLeft); // Draw the header for the third column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 330, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 390, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 420, 50, 0, PDFTextAlign.TopLeft); // Draw the header for the fourth column pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 490, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 550, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 580, 50, 0, PDFTextAlign.TopLeft); // Draw the codes and characters float xDec = 10; float xHex = 70; float xChar = 100; float xDelta = 160; float y = 65; byte i = 31; while (i <= 255) { i++; if (((i - 32) % 60 == 0) && i != 32) { xDec = xDec + xDelta; xHex = xHex + xDelta; xChar = xChar + xDelta; y = 65; } char c = (char)i; pdfPage.Canvas.DrawText(i.ToString(), fontCode, null, blackBrush, xDec, y, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("\\x" + i.ToString("X"), fontCode, null, blackBrush, xHex, y, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText(c.ToString(), fontChar, null, blackBrush, xChar, y, 0, PDFTextAlign.TopLeft); y = y + 12; if (i == 255) { break; } } } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


CharacterMap.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.CharacterMap ''' <summary> ''' This sample prints all available characters in WinAnsiEncoding, plus ''' those available in ZapfDingbats and Symbol fonts. ''' </summary> Class CharacterMap ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() DrawFirstPage(pdfDoc) DrawSecondPage(pdfDoc) DrawThirdPage(pdfDoc) ' Save the document to disk pdfDoc.Save("Sample_CharacterMap.pdf") End Sub Private Shared Sub DrawFirstPage(pdfDoc As PDFDocument) Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim fontCode As New PDFFont(PDFFontFace.Helvetica, 11) Dim blackBrush As New PDFBrush(New PDFRgbColor()) pdfPage.Canvas.DrawText("Latin font - WinAnsiEncoding", fontText, Nothing, blackBrush, 10, 30, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the first column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 10, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 70, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 100, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the second column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 170, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 230, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 260, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the third column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 330, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 390, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 420, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the fourth column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 490, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 550, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 580, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the codes and characters Dim xDec As Single = 10 Dim xHex As Single = 70 Dim xChar As Single = 100 Dim xDelta As Single = 160 Dim y As Single = 65 Dim i As Byte = 31 While i <= 255 i = i + 1 If ((i - 32) Mod 60 = 0) AndAlso i <> 32 Then xDec = xDec + xDelta xHex = xHex + xDelta xChar = xChar + xDelta y = 65 End If Dim c As Char = Microsoft.VisualBasic.ChrW(i) pdfPage.Canvas.DrawText(i.ToString(), fontCode, Nothing, blackBrush, xDec, y, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("\x" + i.ToString("X"), fontCode, Nothing, blackBrush, xHex, y, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText(c.ToString(), fontCode, Nothing, blackBrush, xChar, y, _ 0, PDFTextAlign.TopLeft) y = y + 12 If i = 255 Then Exit While End If End While End Sub Private Shared Sub DrawSecondPage(pdfDoc As PDFDocument) ' Create second page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontChar As New PDFFont(PDFFontFace.Symbol, 11) Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim fontCode As New PDFFont(PDFFontFace.Helvetica, 11) pdfPage.Canvas.DrawText("Symbol font", fontText, Nothing, blackBrush, 10, 30, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the first column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 10, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 70, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 100, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the second column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 170, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 230, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 260, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the third column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 330, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 390, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 420, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the fourth column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 490, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 550, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 580, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the codes and characters Dim xDec As Single = 10 Dim xHex As Single = 70 Dim xChar As Single = 100 Dim xDelta As Single = 160 Dim y As Single = 65 Dim i As Byte = 31 While i <= 255 i = i + 1 If ((i - 32) Mod 60 = 0) AndAlso i <> 32 Then xDec = xDec + xDelta xHex = xHex + xDelta xChar = xChar + xDelta y = 65 End If Dim c As Char = Microsoft.VisualBasic.ChrW(i) pdfPage.Canvas.DrawText(i.ToString(), fontCode, Nothing, blackBrush, xDec, y, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("\x" + i.ToString("X"), fontCode, Nothing, blackBrush, xHex, y, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText(c.ToString(), fontChar, Nothing, blackBrush, xChar, y, _ 0, PDFTextAlign.TopLeft) y = y + 12 If i = 255 Then Exit While End If End While End Sub Private Shared Sub DrawThirdPage(pdfDoc As PDFDocument) ' Create first page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontChar As New PDFFont(PDFFontFace.ZapfDingbats, 11) Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim fontCode As New PDFFont(PDFFontFace.Helvetica, 11) Dim blackBrush As New PDFBrush(New PDFRgbColor()) pdfPage.Canvas.DrawText("ZapfDingbats font", fontText, Nothing, blackBrush, 10, 30, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the first column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 10, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 70, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 100, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the second column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 170, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 230, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 260, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the third column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 330, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 390, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 420, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the header for the fourth column pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 490, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 550, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 580, 50, _ 0, PDFTextAlign.TopLeft) ' Draw the codes and characters Dim xDec As Single = 10 Dim xHex As Single = 70 Dim xChar As Single = 100 Dim xDelta As Single = 160 Dim y As Single = 65 Dim i As Byte = 31 While i <= 255 i = i + 1 If ((i - 32) Mod 60 = 0) AndAlso i <> 32 Then xDec = xDec + xDelta xHex = xHex + xDelta xChar = xChar + xDelta y = 65 End If Dim c As Char = Microsoft.VisualBasic.ChrW(i) pdfPage.Canvas.DrawText(i.ToString(), fontCode, Nothing, blackBrush, xDec, y, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("\x" + i.ToString("X"), fontCode, Nothing, blackBrush, xHex, y, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText(c.ToString(), fontChar, Nothing, blackBrush, xChar, y, _ 0, PDFTextAlign.TopLeft) y = y + 12 If i = 255 Then Exit While End If End While End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: ColorSpaces
This sample shows how to work with various PDF colorspaces. New color classes have been introduced to allow creation of colors based on specific colorspaces. The new colors can be used instead of existing PDFColor objects.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


ColorSpaces.cs
using System; using System.IO; using System.Text; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Functions; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.ColorSpaces; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET { /// <summary> /// This sample shows how to work with various PDF colorspaces when creating a PDF document. /// </summary> class ColorSpaces { [STAThread] static void Main(string[] args) { PDFDocument doc = new PDFDocument(); PDFPage page = doc.AddPage(); DrawDeviceColorSpace(page); page = doc.AddPage(); DrawIndexedColorSpace(page); page = doc.AddPage(); DrawCalGrayColorSpace(page); page = doc.AddPage(); DrawCalRgbColorSpace(page); page = doc.AddPage(); DrawLabColorSpace(page); page = doc.AddPage(); DrawICCColorSpace(page); page = doc.AddPage(); DrawSeparationColorSpace(page); doc.Save("Sample_ColorSpaces.pdf"); } /// <summary> /// Draws content on a page using colors created from a device colorspace. /// </summary> /// <param name="page">The page to draw to.</param> /// <remarks>RGB, CMYK and Gray are device colorspaces. /// The PDFRgbColor, PDFCmykColor and PDFGrayColor classes create automatically the /// required colorspaces.</remarks> private static void DrawDeviceColorSpace(PDFPage page) { PDFRgbColor black = new PDFRgbColor(0, 0, 0); PDFBrush blackBrush = new PDFBrush(black); PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16); page.Canvas.DrawText("Device colorspaces: RGB, CMYK and Gray", font, null, blackBrush, 50, 50); // Draw RGB content. page.Canvas.DrawText("RGB", font, null, blackBrush, 50, 80); PDFRgbColor red = new PDFRgbColor(255, 0, 0); PDFRgbColor blue = new PDFRgbColor(0, 0, 255); PDFBrush redBrush = new PDFBrush(red); PDFPen bluePen = new PDFPen(blue, 5); page.Canvas.DrawRoundRectangle(bluePen, redBrush, 50, 100, 400, 150, 20, 20); // Draw CMYK content. page.Canvas.DrawText("CMYK", font, null, blackBrush, 50, 280); PDFCmykColor cyan = new PDFCmykColor(1, 0, 0, 0); PDFCmykColor magenta = new PDFCmykColor(0, 1, 0, 0); PDFBrush cyanBrush = new PDFBrush(cyan); PDFPen magentaPen = new PDFPen(magenta, 5); page.Canvas.DrawRoundRectangle(magentaPen, cyanBrush, 50, 300, 400, 150, 20, 20); // Draw Gray content. page.Canvas.DrawText("Gray", font, null, blackBrush, 50, 480); PDFGrayColor lightGray = new PDFGrayColor(0.85); PDFGrayColor darkGray = new PDFGrayColor(0.1); PDFBrush lgBrush = new PDFBrush(lightGray); PDFPen dgPen = new PDFPen(darkGray, 5); page.Canvas.DrawRoundRectangle(dgPen, lgBrush, 50, 500, 400, 150, 20, 20); } /// <summary> /// Draws content on a page using colors created from an indexed colorspace. /// </summary> /// <param name="page">The page to draw to.</param> private static void DrawIndexedColorSpace(PDFPage page) { PDFRgbColor black = new PDFRgbColor(0, 0, 0); PDFBrush blackBrush = new PDFBrush(black); PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16); page.Canvas.DrawText("Indexed colorspace with 2 colors", font, null, blackBrush, 50, 50); // Create an indexed colorspace with 2 RGB colors, 24bits (3*8bytes) per color. PDFIndexedColorSpace ixCS = new PDFIndexedColorSpace(); ixCS.MaxIndex = 1; ixCS.ColorTable = new byte[] { 255, 0, 0, 192, 0, 255 }; PDFIndexedColor red = new PDFIndexedColor(ixCS); red.ColorIndex = 0; PDFIndexedColor violet = new PDFIndexedColor(ixCS); violet.ColorIndex = 1; PDFBrush redBrush = new PDFBrush(red); PDFPen violetPen = new PDFPen(violet, 5); page.Canvas.DrawRoundRectangle(violetPen, redBrush, 50, 100, 400, 150, 20, 20); } /// <summary> /// Draws content on a page using colors created from a calibrated gray colorspace. /// </summary> /// <param name="page">The page to draw to.</param> private static void DrawCalGrayColorSpace(PDFPage page) { PDFRgbColor black = new PDFRgbColor(0, 0, 0); PDFBrush blackBrush = new PDFBrush(black); PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16); page.Canvas.DrawText("CalGray colorspace", font, null, blackBrush, 50, 50); PDFCalGrayColorSpace calGrayCS = new PDFCalGrayColorSpace(); PDFCalGrayColor dkGray = new PDFCalGrayColor(calGrayCS); dkGray.Gray = 0.1; PDFCalGrayColor ltGray = new PDFCalGrayColor(calGrayCS); ltGray.Gray = 0.8; PDFBrush dkBrush = new PDFBrush(dkGray); PDFPen ltPen = new PDFPen(ltGray, 5); page.Canvas.DrawRoundRectangle(ltPen, dkBrush, 50, 100, 400, 150, 20, 20); } /// <summary> /// Draws content on a page using colors created from a calibrated RGB colorspace. /// </summary> /// <param name="page">The page to draw to.</param> private static void DrawCalRgbColorSpace(PDFPage page) { PDFRgbColor black = new PDFRgbColor(0, 0, 0); PDFBrush blackBrush = new PDFBrush(black); PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16); page.Canvas.DrawText("CalRGB colorspace", font, null, blackBrush, 50, 50); PDFCalRgbColorSpace calRgbCS = new PDFCalRgbColorSpace(); PDFCalRgbColor red = new PDFCalRgbColor(calRgbCS); red.Red = 1; red.Green = 0; red.Blue = 0; PDFCalRgbColor blue = new PDFCalRgbColor(calRgbCS); blue.Red = 0; blue.Green = 0; blue.Blue = 1; PDFBrush blueBrush = new PDFBrush(blue); PDFPen redPen = new PDFPen(red, 5); page.Canvas.DrawRoundRectangle(redPen, blueBrush, 50, 100, 400, 150, 20, 20); } /// <summary> /// Draws content on a page using colors created from a calibrated Lab colorspace. /// </summary> /// <param name="page">The page to draw to.</param> private static void DrawLabColorSpace(PDFPage page) { PDFRgbColor black = new PDFRgbColor(0, 0, 0); PDFBrush blackBrush = new PDFBrush(black); PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16); page.Canvas.DrawText("L*a*b* colorspace", font, null, blackBrush, 50, 50); PDFLabColorSpace labCS = new PDFLabColorSpace(); PDFLabColor labClr1 = new PDFLabColor(labCS); labClr1.L = 90; labClr1.A = 20; labClr1.B = -10; PDFLabColor labClr2 = new PDFLabColor(labCS); labClr2.L = 10; labClr2.A = 70; labClr2.B = -50; PDFBrush brush = new PDFBrush(labClr1); PDFPen pen = new PDFPen(labClr2, 5); page.Canvas.DrawRoundRectangle(pen, brush, 50, 100, 400, 150, 20, 20); } /// <summary> /// Draws content on a page using colors created from a calibrated ICC colorspace. /// </summary> /// <param name="page">The page to draw to.</param> private static void DrawICCColorSpace(PDFPage page) { PDFRgbColor black = new PDFRgbColor(0, 0, 0); PDFBrush blackBrush = new PDFBrush(black); PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16); page.Canvas.DrawText("ICC colorspace", font, null, blackBrush, 50, 50); // Read the ICC profile from disk. FileStream fs = new FileStream("..\\SupportFiles\\rgb.icc", FileMode.Open, FileAccess.Read); byte[] profileData = new byte[fs.Length]; fs.Read(profileData, 0, profileData.Length); fs.Close(); PDFICCColorSpace iccCS = new PDFICCColorSpace(); iccCS.ProfileData = profileData; PDFICCColor red = new PDFICCColor(iccCS); red.ColorComponents = new double[] { 192, 0, 0 }; PDFICCColor blue = new PDFICCColor(iccCS); blue.ColorComponents = new double[] { 0, 0, 192 }; PDFBrush blueBrush = new PDFBrush(blue); PDFPen redPen = new PDFPen(red, 5); page.Canvas.DrawRoundRectangle(redPen, blueBrush, 50, 100, 400, 150, 20, 20); } /// <summary> /// Draws content on a page using colors created from a separation colorspace. /// </summary> /// <param name="page">The page to draw to.</param> private static void DrawSeparationColorSpace(PDFPage page) { PDFRgbColor black = new PDFRgbColor(0, 0, 0); PDFBrush blackBrush = new PDFBrush(black); PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16); page.Canvas.DrawText("Separation colorspace", font, null, blackBrush, 50, 50); PDFType2Function tintTransform = new PDFType2Function(); tintTransform.C0 = new double[] { 0, 0, 0, 0 }; tintTransform.C1 = new double[] { 0, 0.53f, 1, 0 }; tintTransform.Exponent = 1; tintTransform.Domain = new double[] { 0, 1 }; tintTransform.Range = new double[] { 0, 1, 0, 1, 0, 1, 0, 1 }; PDFSeparationColorSpace separationCS = new PDFSeparationColorSpace(); separationCS.Colorant = "PANTONE Orange 021 C"; separationCS.TintTransform = tintTransform; PDFSeparationColor orange = new PDFSeparationColor(separationCS); orange.Tint = 0.9; tintTransform = new PDFType2Function(); tintTransform.C0 = new double[] { 0, 0, 0, 0 }; tintTransform.C1 = new double[] { 0, 0.75f, 0.9f, 0 }; tintTransform.Exponent = 1; tintTransform.Domain = new double[] { 0, 1 }; tintTransform.Range = new double[] { 0, 1, 0, 1, 0, 1, 0, 1 }; separationCS = new PDFSeparationColorSpace(); separationCS.Colorant = "PANTONE Warm Red C"; separationCS.TintTransform = tintTransform; PDFSeparationColor warmRed = new PDFSeparationColor(separationCS); warmRed.Tint = 0.4; PDFBrush orangeBrush = new PDFBrush(orange); PDFPen warmRedPen = new PDFPen(warmRed, 5); page.Canvas.DrawRoundRectangle(warmRedPen, orangeBrush, 50, 100, 400, 150, 20, 20); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


ColorSpaces.vb
Imports System Imports System.IO Imports System.Text Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Functions Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.ColorSpaces Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET ''' <summary> ''' This sample shows how to work with various PDF colorspaces when creating a PDF document. ''' </summary> Class ColorSpaces <STAThread> _ Shared Sub Main(args As String()) Dim doc As New PDFDocument() Dim page As PDFPage = doc.AddPage() DrawDeviceColorSpace(page) page = doc.AddPage() DrawIndexedColorSpace(page) page = doc.AddPage() DrawCalGrayColorSpace(page) page = doc.AddPage() DrawCalRgbColorSpace(page) page = doc.AddPage() DrawLabColorSpace(page) page = doc.AddPage() DrawICCColorSpace(page) page = doc.AddPage() DrawSeparationColorSpace(page) doc.Save("Sample_ColorSpaces.pdf") End Sub ''' <summary> ''' Draws content on a page using colors created from a device colorspace. ''' </summary> ''' <param name="page">The page to draw to.</param> ''' <remarks>RGB, CMYK and Gray are device colorspaces. ''' The PDFRgbColor, PDFCmykColor and PDFGrayColor classes create automatically the ''' required colorspaces.</remarks> Private Shared Sub DrawDeviceColorSpace(page As PDFPage) Dim black As New PDFRgbColor(0, 0, 0) Dim blackBrush As New PDFBrush(black) Dim font As New PDFFont(PDFFontFace.Helvetica, 16) page.Canvas.DrawText("Device colorspaces: RGB, CMYK and Gray", font, Nothing, blackBrush, 50, 50) ' Draw RGB content. page.Canvas.DrawText("RGB", font, Nothing, blackBrush, 50, 80) Dim red As New PDFRgbColor(255, 0, 0) Dim blue As New PDFRgbColor(0, 0, 255) Dim redBrush As New PDFBrush(red) Dim bluePen As New PDFPen(blue, 5) page.Canvas.DrawRoundRectangle(bluePen, redBrush, 50, 100, 400, 150, _ 20, 20) ' Draw CMYK content. page.Canvas.DrawText("CMYK", font, Nothing, blackBrush, 50, 280) Dim cyan As New PDFCmykColor(1, 0, 0, 0) Dim magenta As New PDFCmykColor(0, 1, 0, 0) Dim cyanBrush As New PDFBrush(cyan) Dim magentaPen As New PDFPen(magenta, 5) page.Canvas.DrawRoundRectangle(magentaPen, cyanBrush, 50, 300, 400, 150, _ 20, 20) ' Draw Gray content. page.Canvas.DrawText("Gray", font, Nothing, blackBrush, 50, 480) Dim lightGray As New PDFGrayColor(0.85) Dim darkGray As New PDFGrayColor(0.1) Dim lgBrush As New PDFBrush(lightGray) Dim dgPen As New PDFPen(darkGray, 5) page.Canvas.DrawRoundRectangle(dgPen, lgBrush, 50, 500, 400, 150, _ 20, 20) End Sub ''' <summary> ''' Draws content on a page using colors created from an indexed colorspace. ''' </summary> ''' <param name="page">The page to draw to.</param> Private Shared Sub DrawIndexedColorSpace(page As PDFPage) Dim black As New PDFRgbColor(0, 0, 0) Dim blackBrush As New PDFBrush(black) Dim font As New PDFFont(PDFFontFace.Helvetica, 16) page.Canvas.DrawText("Indexed colorspace with 2 colors", font, Nothing, blackBrush, 50, 50) ' Create an indexed colorspace with 2 RGB colors, 24bits (3*8bytes) per color. Dim ixCS As New PDFIndexedColorSpace() ixCS.MaxIndex = 1 ixCS.ColorTable = New Byte() {255, 0, 0, 192, 0, 255} Dim red As New PDFIndexedColor(ixCS) red.ColorIndex = 0 Dim violet As New PDFIndexedColor(ixCS) violet.ColorIndex = 1 Dim redBrush As New PDFBrush(red) Dim violetPen As New PDFPen(violet, 5) page.Canvas.DrawRoundRectangle(violetPen, redBrush, 50, 100, 400, 150, _ 20, 20) End Sub ''' <summary> ''' Draws content on a page using colors created from a calibrated gray colorspace. ''' </summary> ''' <param name="page">The page to draw to.</param> Private Shared Sub DrawCalGrayColorSpace(page As PDFPage) Dim black As New PDFRgbColor(0, 0, 0) Dim blackBrush As New PDFBrush(black) Dim font As New PDFFont(PDFFontFace.Helvetica, 16) page.Canvas.DrawText("CalGray colorspace", font, Nothing, blackBrush, 50, 50) Dim calGrayCS As New PDFCalGrayColorSpace() Dim dkGray As New PDFCalGrayColor(calGrayCS) dkGray.Gray = 0.1 Dim ltGray As New PDFCalGrayColor(calGrayCS) ltGray.Gray = 0.8 Dim dkBrush As New PDFBrush(dkGray) Dim ltPen As New PDFPen(ltGray, 5) page.Canvas.DrawRoundRectangle(ltPen, dkBrush, 50, 100, 400, 150, _ 20, 20) End Sub ''' <summary> ''' Draws content on a page using colors created from a calibrated RGB colorspace. ''' </summary> ''' <param name="page">The page to draw to.</param> Private Shared Sub DrawCalRgbColorSpace(page As PDFPage) Dim black As New PDFRgbColor(0, 0, 0) Dim blackBrush As New PDFBrush(black) Dim font As New PDFFont(PDFFontFace.Helvetica, 16) page.Canvas.DrawText("CalRGB colorspace", font, Nothing, blackBrush, 50, 50) Dim calRgbCS As New PDFCalRgbColorSpace() Dim red As New PDFCalRgbColor(calRgbCS) red.Red = 1 red.Green = 0 red.Blue = 0 Dim blue As New PDFCalRgbColor(calRgbCS) blue.Red = 0 blue.Green = 0 blue.Blue = 1 Dim blueBrush As New PDFBrush(blue) Dim redPen As New PDFPen(red, 5) page.Canvas.DrawRoundRectangle(redPen, blueBrush, 50, 100, 400, 150, _ 20, 20) End Sub ''' <summary> ''' Draws content on a page using colors created from a calibrated Lab colorspace. ''' </summary> ''' <param name="page">The page to draw to.</param> Private Shared Sub DrawLabColorSpace(page As PDFPage) Dim black As New PDFRgbColor(0, 0, 0) Dim blackBrush As New PDFBrush(black) Dim font As New PDFFont(PDFFontFace.Helvetica, 16) page.Canvas.DrawText("L*a*b* colorspace", font, Nothing, blackBrush, 50, 50) Dim labCS As New PDFLabColorSpace() Dim labClr1 As New PDFLabColor(labCS) labClr1.L = 90 labClr1.A = 20 labClr1.B = -10 Dim labClr2 As New PDFLabColor(labCS) labClr2.L = 10 labClr2.A = 70 labClr2.B = -50 Dim brush As New PDFBrush(labClr1) Dim pen As New PDFPen(labClr2, 5) page.Canvas.DrawRoundRectangle(pen, brush, 50, 100, 400, 150, _ 20, 20) End Sub ''' <summary> ''' Draws content on a page using colors created from a calibrated ICC colorspace. ''' </summary> ''' <param name="page">The page to draw to.</param> Private Shared Sub DrawICCColorSpace(page As PDFPage) Dim black As New PDFRgbColor(0, 0, 0) Dim blackBrush As New PDFBrush(black) Dim font As New PDFFont(PDFFontFace.Helvetica, 16) page.Canvas.DrawText("ICC colorspace", font, Nothing, blackBrush, 50, 50) ' Read the ICC profile from disk. Dim fs As New FileStream("..\SupportFiles\rgb.icc", FileMode.Open, FileAccess.Read) Dim profileData As Byte() = New Byte(fs.Length) {} fs.Read(profileData, 0, profileData.Length) fs.Close() Dim iccCS As New PDFICCColorSpace() iccCS.ProfileData = profileData Dim red As New PDFICCColor(iccCS) red.ColorComponents = New Double() {192, 0, 0} Dim blue As New PDFICCColor(iccCS) blue.ColorComponents = New Double() {0, 0, 192} Dim blueBrush As New PDFBrush(blue) Dim redPen As New PDFPen(red, 5) page.Canvas.DrawRoundRectangle(redPen, blueBrush, 50, 100, 400, 150, _ 20, 20) End Sub ''' <summary> ''' Draws content on a page using colors created from a separation colorspace. ''' </summary> ''' <param name="page">The page to draw to.</param> Private Shared Sub DrawSeparationColorSpace(page As PDFPage) Dim black As New PDFRgbColor(0, 0, 0) Dim blackBrush As New PDFBrush(black) Dim font As New PDFFont(PDFFontFace.Helvetica, 16) page.Canvas.DrawText("Separation colorspace", font, Nothing, blackBrush, 50, 50) Dim tintTransform As New PDFType2Function() tintTransform.C0 = New Double() {0, 0, 0, 0} tintTransform.C1 = New Double() {0, 0.53F, 1, 0} tintTransform.Exponent = 1 tintTransform.Domain = New Double() {0, 1} tintTransform.Range = New Double() {0, 1, 0, 1, 0, 1, _ 0, 1} Dim separationCS As New PDFSeparationColorSpace() separationCS.Colorant = "PANTONE Orange 021 C" separationCS.TintTransform = tintTransform Dim orange As New PDFSeparationColor(separationCS) orange.Tint = 0.9 tintTransform = New PDFType2Function() tintTransform.C0 = New Double() {0, 0, 0, 0} tintTransform.C1 = New Double() {0, 0.75F, 0.9F, 0} tintTransform.Exponent = 1 tintTransform.Domain = New Double() {0, 1} tintTransform.Range = New Double() {0, 1, 0, 1, 0, 1, _ 0, 1} separationCS = New PDFSeparationColorSpace() separationCS.Colorant = "PANTONE Warm Red C" separationCS.TintTransform = tintTransform Dim warmRed As New PDFSeparationColor(separationCS) warmRed.Tint = 0.4 Dim orangeBrush As New PDFBrush(orange) Dim warmRedPen As New PDFPen(warmRed, 5) page.Canvas.DrawRoundRectangle(warmRedPen, orangeBrush, 50, 100, 400, 150, _ 20, 20) End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Digital Signature
This sample shows how to add digital signatures, based on X.509 certificates, to PDF files.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


DigitalSignature.cs
using System; using System.IO; using System.Drawing; using System.Security.Cryptography.X509Certificates; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Forms; using O2S.Components.PDF4NET.Security; namespace O2S.Samples.PDF4NET { /// <summary> /// This sample shows how to sign a PDF file using X.509 certificates. /// </summary> class DigitalSignature { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument doc = new PDFDocument(); // Create a blank page PDFPage page = doc.AddPage(); // Create the signature field. PDFSignatureField sign = new PDFSignatureField("Signature"); sign.Widgets[0].DisplayRectangle = new DisplayRectangle(50, 100, 200, 40); // Create the digital signature. sign.Signature = new PDFDigitalSignature(); // The certificate is loaded from disk, but it also can be loaded from a certificate store. sign.Signature.Certificate = new X509Certificate2("..\\SupportFiles\\samplesign.pfx", "password"); sign.Signature.Location = "Romania"; sign.Signature.Reason = "For demo"; sign.Signature.ContactInfo = "techsupport@o2sol.com"; page.Fields.Add(sign); doc.Save("Sample_DigitalSign.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


DigitalSignature.vb
Imports System Imports System.IO Imports System.Drawing Imports System.Security.Cryptography.X509Certificates Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Forms Imports O2S.Components.PDF4NET.Security Namespace O2S.Samples.PDF4NET ''' <summary> ''' This sample shows how to sign a PDF file using X.509 certificates. ''' </summary> Class DigitalSignature ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument() ' Create a blank page Dim page As PDFPage = doc.AddPage() ' Create the signature field. Dim sign As New PDFSignatureField("Signature") sign.Widgets(0).DisplayRectangle = New DisplayRectangle(50, 100, 200, 40) ' Create the digital signature. sign.Signature = New PDFDigitalSignature() ' The certificate is loaded from disk, but it also can be loaded from a certificate store. sign.Signature.Certificate = New X509Certificate2("..\SupportFiles\samplesign.pfx", "password") sign.Signature.Location = "Romania" sign.Signature.Reason = "For demo" sign.Signature.ContactInfo = "techsupport@o2sol.com" page.Fields.Add(sign) doc.Save("Sample_DigitalSign.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: DocAndViewer
This samples shows how to set the metadata information for a pdf document. Also, it demonstrates how to set the way the pdf document is open in the viewer. In this sample, when the pdf document is open in the viewer, the whole user interface of the viewer is hidden. This sample has been enhanced to show how to add custom properties to a document. To view the custom properties, in Adobe Acrobat (Reader) go to File > Document Properties > Document Metadata.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


DocAndViewer.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.DocAndViewer { /// <summary> /// This sample will show how to set the document information /// and the way the viewer will behave when will open the document. /// It also shows how to create custom properties for the document. /// </summary> class DocAndViewer { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Set the document information pdfDoc.DocumentInformation = new PDFDocumentInformation(); pdfDoc.DocumentInformation.Author = "O2 Solutions (http://www.o2sol.com)"; pdfDoc.DocumentInformation.Title = "Sample document"; pdfDoc.DocumentInformation.Subject = "The abilities of the PDF4NET library"; pdfDoc.DocumentInformation.Keywords = "pdf4net, pdf, .net, sample"; pdfDoc.DocumentInformation.Creator = "DocAndViewer"; // Set viewer preferences // Change HideMenubar to false in order to // access the Preferences menu item. pdfDoc.ViewerPreferences = new PDFViewerPreferences(); pdfDoc.ViewerPreferences.HideMenubar = false; pdfDoc.ViewerPreferences.HideToolbar = true; pdfDoc.ViewerPreferences.HideWindowUI = true; pdfDoc.ViewerPreferences.DisplayDocTitle = true; // Set up custom properties PDFMetadataSchema ms = new PDFMetadataSchema(); ms["Company"] = "O2 Solutions"; ms["Website"] = "http://www.o2sol.com/"; ms["Product"] = "PDF4NET Library"; // Add schema to document pdfDoc.Metadata.MetadataSchemas.Add(ms); // Create one page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFFont fontTitle = new PDFFont(PDFFontFace.Helvetica, 12); fontTitle.Bold = true; PDFBrush brush = new PDFBrush(new PDFRgbColor()); // Write on the page the current settings pdfPage.Canvas.DrawText("Document information", fontTitle, null, brush, 20, 20, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Author: " + pdfDoc.DocumentInformation.Author, fontText, null, brush, 20, 35, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Title: " + pdfDoc.DocumentInformation.Title, fontText, null, brush, 20, 50, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Subject: " + pdfDoc.DocumentInformation.Subject, fontText, null, brush, 20, 65, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Keywords: " + pdfDoc.DocumentInformation.Keywords, fontText, null, brush, 20, 80, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Creator: " + pdfDoc.DocumentInformation.Creator, fontText, null, brush, 20, 95, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Viewer preferences", fontTitle, null, brush, 20, 120, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("HideMenubar: " + pdfDoc.ViewerPreferences.HideMenubar.ToString(), fontText, null, brush, 20, 135, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("HideToolbar: " + pdfDoc.ViewerPreferences.HideToolbar.ToString(), fontText, null, brush, 20, 150, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("HideWindowUI: " + pdfDoc.ViewerPreferences.HideWindowUI.ToString(), fontText, null, brush, 20, 165, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("DisplayDocTitle: " + pdfDoc.ViewerPreferences.DisplayDocTitle.ToString(), fontText, null, brush, 20, 180, 0, PDFTextAlign.TopLeft); // Save the document to disk pdfDoc.Save("Sample_DocAndViewer.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


DocAndViewer.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.DocAndViewer ''' <summary> ''' This sample will show how to set the document information ''' and the way the viewer will behave when will open the document. ''' It also shows how to create custom properties for the document. ''' </summary> Class DocAndViewer ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Set the document information pdfDoc.DocumentInformation = New PDFDocumentInformation() pdfDoc.DocumentInformation.Author = "O2 Solutions (http://www.o2sol.com)" pdfDoc.DocumentInformation.Title = "Sample document" pdfDoc.DocumentInformation.Subject = "The abilities of the PDF4NET library" pdfDoc.DocumentInformation.Keywords = "pdf4net, pdf, .net, sample" pdfDoc.DocumentInformation.Creator = "DocAndViewer" ' Set viewer preferences ' Change HideMenubar to false in order to ' access the Preferences menu item. pdfDoc.ViewerPreferences = New PDFViewerPreferences() pdfDoc.ViewerPreferences.HideMenubar = False pdfDoc.ViewerPreferences.HideToolbar = True pdfDoc.ViewerPreferences.HideWindowUI = True pdfDoc.ViewerPreferences.DisplayDocTitle = True ' Set up custom properties Dim ms As New PDFMetadataSchema() ms("Company") = "O2 Solutions" ms("Website") = "http://www.o2sol.com/" ms("Product") = "PDF4NET Library" ' Add schema to document pdfDoc.Metadata.MetadataSchemas.Add(ms) ' Create one page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim fontTitle As New PDFFont(PDFFontFace.Helvetica, 12) fontTitle.Bold = True Dim brush As New PDFBrush(New PDFRgbColor()) ' Write on the page the current settings pdfPage.Canvas.DrawText("Document information", fontTitle, Nothing, brush, 20, 20, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Author: " + pdfDoc.DocumentInformation.Author, fontText, Nothing, brush, 20, 35, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Title: " + pdfDoc.DocumentInformation.Title, fontText, Nothing, brush, 20, 50, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Subject: " + pdfDoc.DocumentInformation.Subject, fontText, Nothing, brush, 20, 65, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Keywords: " + pdfDoc.DocumentInformation.Keywords, fontText, Nothing, brush, 20, 80, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Creator: " + pdfDoc.DocumentInformation.Creator, fontText, Nothing, brush, 20, 95, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Viewer preferences", fontTitle, Nothing, brush, 20, 120, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("HideMenubar: " + pdfDoc.ViewerPreferences.HideMenubar.ToString(), fontText, Nothing, brush, 20, 135, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("HideToolbar: " + pdfDoc.ViewerPreferences.HideToolbar.ToString(), fontText, Nothing, brush, 20, 150, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("HideWindowUI: " + pdfDoc.ViewerPreferences.HideWindowUI.ToString(), fontText, Nothing, brush, 20, 165, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("DisplayDocTitle: " + pdfDoc.ViewerPreferences.DisplayDocTitle.ToString(), fontText, Nothing, brush, 20, 180, _ 0, PDFTextAlign.TopLeft) ' Save the document to disk pdfDoc.Save("Sample_DocAndViewer.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Edit PDF
This sample shows the pdf editing capabilities of PDF4NET library. The following features are shown: mixing 2 different documents, merge files, apply security to existing files, page imposition and pdf file splitting.

C# Source code | VB.NET Source code

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


EditPDF.cs
using System; using System.Drawing; using System.Text; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Security; using O2S.Components.PDF4NET.PDFFile; namespace O2S.Samples.PDF4NET.EditPDF { /// <summary> /// This sample shows the pdf editing capabilities of /// PDF4NET library. The following features are shown: /// Mixing 2 different documents, merge files, /// encryption of existing files, /// page imposition and pdf file splitting. /// </summary> class EditPDF { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Documents mix MixFiles(); // Apppend files AppendFiles(); // Encrypt file EncryptFile(); // Split file SplitFile(); // Page imposition MultiPage(); } // For this sample to work, the following files // need to exist: unicode.pdf and multicolumntextandimages.pdf. // Compile the corresponding samples to get these files public static void MixFiles() { PDFFile unicodeFile = PDFFile.FromFile("Sample_Unicode.pdf"); PDFFile mctiFile = PDFFile.FromFile("Sample_MultiColumnTextAndImages.pdf"); PDFImportedPage ip = null; PDFDocument doc = new PDFDocument(); for (int i = 0; i < 4; i++) { // extract the page ip = unicodeFile.ExtractPage(i); // add the page to new document doc.Pages.Add(ip); // extract the page ip = mctiFile.ExtractPage(i); // add the page to new document doc.Pages.Add(ip); } // save the mixed document doc.Save("Sample_Mix.pdf"); unicodeFile.Close(); mctiFile.Close(); } // For this sample to work, the following files // need to exist: unicode.pdf and multicolumntextandimages.pdf. // Compile the corresponding samples to get these files public static void AppendFiles() { PDFFile.MergeFiles("Sample_Append.pdf", new string[] { "Sample_Unicode.pdf", "Sample_MultiColumnTextAndImages.pdf" }); // or //PDFDocument doc = // PDFFile.MergeFiles( new string[]{ "unicode.pdf", "multicolumntextandimages.pdf" } ); //doc.SaveToStream( stream ); } // For this sample to work, the following file // need to exist: multicolumntextandimages.pdf. // Compile the corresponding sample to get this file public static void EncryptFile() { PDFSecurityManager securityManager = new PDFSecurityManager(); securityManager.KeySize = EncryptionKeySize.Use128BitKey; securityManager.UserPassword = Encoding.ASCII.GetBytes("userpass"); securityManager.OwnerPassword = Encoding.ASCII.GetBytes("ownerpass"); securityManager.AllowPrint = false; securityManager.FullQualityPrint = true; securityManager.AllowModifyDocument = false; securityManager.AllowExtractContent = false; securityManager.AllowInteractiveEdit = false; securityManager.AllowFormsFill = true; securityManager.AllowAccessibilityExtractContent = true; securityManager.AllowAssembleDocument = false; PDFFile.EncryptFile(securityManager, "Sample_MultiColumnTextAndImages.pdf", "Sample_MultiColumnTextAndImages-Secure.pdf"); // or //PDFDocument doc = // PDFFile.EncryptFile( securityManager, "multicolumntextandimages-secure.pdf" ); //doc.SaveToStream( stream ); } // For this sample to work, the following file // need to exist: unicode.pdf. // Compile the corresponding sample to get this file public static void SplitFile() { PDFFile.SplitFile("Sample_Unicode.pdf", "Sample_Unicode-page.pdf"); } // For this sample to work, the following file // needs to exist: multicolumntextandimages.pdf. // Compile the corresponding sample to get this file public static void MultiPage() { PDFFile mctiFile = PDFFile.FromFile("Sample_MultiColumnTextAndImages-Secure.pdf", Encoding.ASCII.GetBytes("userpass")); // extract the content of first 4 pages PDFImportedContent[] ic = mctiFile.ExtractPagesContent("0-3"); // create the new document PDFDocument doc = new PDFDocument(); // add a page to it PDFPage page = doc.AddPage(); // draw the imported content (4 pages) on the new page page.Canvas.DrawImportedContent(ic[0], 0, 0, page.Width / 2, page.Height / 2); page.Canvas.DrawImportedContent(ic[1], page.Width / 2, 0, page.Width / 2, page.Height / 2); page.Canvas.DrawImportedContent(ic[2], 0, page.Height / 2, page.Width / 2, page.Height / 2); page.Canvas.DrawImportedContent(ic[3], page.Width / 2, page.Height / 2, page.Width / 2, page.Height / 2); // save the mixed document doc.Save("Sample_Imposition.pdf"); mctiFile.Close(); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


EditPDF.vb
Imports System Imports System.Drawing Imports System.Text Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Security Imports O2S.Components.PDF4NET.PDFFile Namespace O2S.Samples.PDF4NET.EditPDF ''' <summary> ''' This sample shows the pdf editing capabilities of ''' PDF4NET library. The following features are shown: ''' Mixing 2 different documents, merge files, ''' encryption of existing files, ''' page imposition and pdf file splitting. ''' </summary> Class EditPDF ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Documents mix MixFiles() ' Apppend files AppendFiles() ' Encrypt file EncryptFile() ' Split file SplitFile() ' Page imposition MultiPage() End Sub ' For this sample to work, the following files ' need to exist: unicode.pdf and multicolumntextandimages.pdf. ' Compile the corresponding samples to get these files Public Shared Sub MixFiles() Dim unicodeFile As PDFFile = PDFFile.FromFile("Sample_Unicode.pdf") Dim mctiFile As PDFFile = PDFFile.FromFile("Sample_MultiColumnTextAndImages.pdf") Dim ip As PDFImportedPage = Nothing Dim doc As New PDFDocument() Dim i As Integer = 0 While i < 4 ' extract the page ip = unicodeFile.ExtractPage(i) ' add the page to new document doc.Pages.Add(ip) ' extract the page ip = mctiFile.ExtractPage(i) ' add the page to new document doc.Pages.Add(ip) i = i + 1 End While ' save the mixed document doc.Save("Sample_Mix.pdf") unicodeFile.Close() mctiFile.Close() End Sub ' For this sample to work, the following files ' need to exist: unicode.pdf and multicolumntextandimages.pdf. ' Compile the corresponding samples to get these files Public Shared Sub AppendFiles() PDFFile.MergeFiles("Sample_Append.pdf", New String() {"Sample_Unicode.pdf", "Sample_MultiColumnTextAndImages.pdf"}) ' or 'PDFDocument doc = ' PDFFile.MergeFiles( new string[]{ "unicode.pdf", "multicolumntextandimages.pdf" } ); 'doc.SaveToStream( stream ); End Sub ' For this sample to work, the following file ' need to exist: multicolumntextandimages.pdf. ' Compile the corresponding sample to get this file Public Shared Sub EncryptFile() Dim securityManager As New PDFSecurityManager() securityManager.KeySize = EncryptionKeySize.Use128BitKey securityManager.UserPassword = Encoding.ASCII.GetBytes("userpass") securityManager.OwnerPassword = Encoding.ASCII.GetBytes("ownerpass") securityManager.AllowPrint = False securityManager.FullQualityPrint = True securityManager.AllowModifyDocument = False securityManager.AllowExtractContent = False securityManager.AllowInteractiveEdit = False securityManager.AllowFormsFill = True securityManager.AllowAccessibilityExtractContent = True securityManager.AllowAssembleDocument = False PDFFile.EncryptFile(securityManager, "Sample_MultiColumnTextAndImages.pdf", "Sample_MultiColumnTextAndImages-Secure.pdf") ' or 'PDFDocument doc = ' PDFFile.EncryptFile( securityManager, "multicolumntextandimages-secure.pdf" ); 'doc.SaveToStream( stream ); End Sub ' For this sample to work, the following file ' need to exist: unicode.pdf. ' Compile the corresponding sample to get this file Public Shared Sub SplitFile() PDFFile.SplitFile("Sample_Unicode.pdf", "Sample_Unicode-page.pdf") End Sub ' For this sample to work, the following file ' needs to exist: multicolumntextandimages.pdf. ' Compile the corresponding sample to get this file Public Shared Sub MultiPage() Dim mctiFile As PDFFile = PDFFile.FromFile("Sample_MultiColumnTextAndImages-Secure.pdf", Encoding.ASCII.GetBytes("userpass")) ' extract the content of first 4 pages Dim ic As PDFImportedContent() = mctiFile.ExtractPagesContent("0-3") ' create the new document Dim doc As New PDFDocument() ' add a page to it Dim page As PDFPage = doc.AddPage() ' draw the imported content (4 pages) on the new page page.Canvas.DrawImportedContent(ic(0), 0, 0, page.Width / 2, page.Height / 2) page.Canvas.DrawImportedContent(ic(1), page.Width / 2, 0, page.Width / 2, page.Height / 2) page.Canvas.DrawImportedContent(ic(2), 0, page.Height / 2, page.Width / 2, page.Height / 2) page.Canvas.DrawImportedContent(ic(3), page.Width / 2, page.Height / 2, page.Width / 2, page.Height / 2) ' save the mixed document doc.Save("Sample_Imposition.pdf") mctiFile.Close() End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Ellipses
This samples shows the ellipse drawing capabilities of the PDF4NET library. On the first page, it draws an ellipse by painting its border, an ellipse by filling its interior, and an ellipse by painting its border and filling its interior. It also show how to draw a circle. On the second page it draws 50 ellipses at random locations on the page. The color of the ellipses is generated randomly.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Ellipses.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Ellipses { /// <summary> /// This sample will show how to draw various ellipses /// on the page. /// </summary> class Ellipses { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create first page PDFPage pdfPage1 = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(0, 255, 0)); PDFPen pen = new PDFPen(new PDFRgbColor(Color.Orange), 1); // Draw an ellipse that has a border pdfPage1.Canvas.DrawText("This ellipse is drawn by drawing its border", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawEllipse(pen, null, 20, 35, 200, 100); // Draw an ellipse that has no border and its interior is filled pdfPage1.Canvas.DrawText("This ellipse is drawn by filling its interior", fontText, null, blackBrush, 300, 20, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawEllipse(null, greenBrush, 300, 35, 300, 150); // Draw an ellipse that has a border and its interior is filled pdfPage1.Canvas.DrawText("This ellipse has a border and a filled interior", fontText, null, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawEllipse(pen, greenBrush, 20, 215, 200, 150); // Draw a circle pdfPage1.Canvas.DrawText("This is a circle", fontText, null, blackBrush, 300, 200, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawEllipse(pen, greenBrush, 300, 215, 200, 200); // Create the second page PDFPage pdfPage2 = pdfDoc.AddPage(); Random rnd = new Random(); for (int i = 0; i < 50; i++) { // Create random colors for the border and the interior PDFRgbColor brushColor = new PDFRgbColor((byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256)); PDFRgbColor penColor = new PDFRgbColor((byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256)); // Create the brush to fill the interior PDFBrush randomBrush = new PDFBrush(brushColor); // Create the pen to draw the border PDFPen randomPen = new PDFPen(penColor, 1); // Generate random positions float left = rnd.Next((int)pdfPage2.Width); float top = rnd.Next((int)pdfPage2.Height); // Generate random sizes float width = rnd.Next((int)(pdfPage2.Width - left)); // try to keep the rectangle float height = rnd.Next((int)(pdfPage2.Height - top)); // within the page // Draw the ellipse pdfPage2.Canvas.DrawEllipse(randomPen, randomBrush, left, top, width, height); } // Draw a label pdfPage2.Canvas.DrawText("Random ellipses", fontText, null, blackBrush, 20, 350, 0, PDFTextAlign.TopLeft); // Save the document to disk pdfDoc.Save("Sample_Ellipses.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Ellipses.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Ellipses ''' <summary> ''' This sample will show how to draw various ellipses ''' on the page. ''' </summary> Class Ellipses ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create first page Dim pdfPage1 As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim greenBrush As New PDFBrush(New PDFRgbColor(0, 255, 0)) Dim pen As New PDFPen(New PDFRgbColor(Color.Orange), 1) ' Draw an ellipse that has a border pdfPage1.Canvas.DrawText("This ellipse is drawn by drawing its border", fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawEllipse(pen, 20, 35, 200, 100) ' Draw an ellipse that has no border and its interior is filled pdfPage1.Canvas.DrawText("This ellipse is drawn by filling its interior", fontText, Nothing, blackBrush, 300, 20, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawEllipse(greenBrush, 300, 35, 300, 150) ' Draw an ellipse that has a border and its interior is filled pdfPage1.Canvas.DrawText("This ellipse has a border and a filled interior", fontText, Nothing, blackBrush, 20, 200, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawEllipse(pen, greenBrush, 20, 215, 200, 150) ' Draw a circle pdfPage1.Canvas.DrawText("This is a circle", fontText, Nothing, blackBrush, 300, 200, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawEllipse(pen, greenBrush, 300, 215, 200, 200) ' Create the second page Dim pdfPage2 As PDFPage = pdfDoc.AddPage() Dim rnd As New Random() Dim i As Integer = 0 While i < 50 ' Create random colors for the border and the interior Dim brushColor As New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256)) Dim penColor As New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256)) ' Create the brush to fill the interior Dim randomBrush As New PDFBrush(brushColor) ' Create the pen to draw the border Dim randomPen As New PDFPen(penColor, 1) ' Generate random positions Dim left As Double = rnd.NextDouble() * pdfPage2.Width Dim top As Double = rnd.NextDouble() * pdfPage2.Height ' Generate random sizes Dim width As Double = rnd.NextDouble() * (pdfPage2.Width - left) ' try to keep the rectangle Dim height As Double = rnd.NextDouble() * (pdfPage2.Height - top) ' within the page ' Draw the ellipse pdfPage2.Canvas.DrawEllipse(randomPen, randomBrush, left, top, width, height) i = i + 1 End While ' Draw a label pdfPage2.Canvas.DrawText("Random ellipses", fontText, Nothing, blackBrush, 20, 350, _ 0, PDFTextAlign.TopLeft) ' Save the document to disk pdfDoc.Save("Sample_Ellipses.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Encryption
This samples shows the pdf security features of PDF4NET library. It shows user and owner passwords, encryption strength and document access rights. The user user password for the attached document is 'userpass', and the owner password is 'ownerpass'.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Encryption.cs
using System; using System.Text; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Security; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Encryption { /// <summary> /// This sample shows how to use the pdf /// security features of PDF4NET library /// </summary> class Encryption { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // set the security options pdfDoc.SecurityManager = new PDFSecurityManager(); // use 128 bit encryption pdfDoc.SecurityManager.KeySize = EncryptionKeySize.Use128BitKey; // set user password to "userpass" pdfDoc.SecurityManager.UserPassword = Encoding.ASCII.GetBytes("userpass"); // set owner password to "ownerpass" pdfDoc.SecurityManager.OwnerPassword = Encoding.ASCII.GetBytes("ownerpass"); // allow to print the pdf document pdfDoc.SecurityManager.AllowPrint = true; // do not allow high quality print pdfDoc.SecurityManager.FullQualityPrint = false; // do not alow to modify the document pdfDoc.SecurityManager.AllowModifyDocument = false; // do not allow to extract content (text and images) from the document pdfDoc.SecurityManager.AllowExtractContent = false; // do not allow to fill forms or to create annotations pdfDoc.SecurityManager.AllowInteractiveEdit = false; // do not allow forms fill pdfDoc.SecurityManager.AllowFormsFill = false; // allow to extract content in support for accessibility pdfDoc.SecurityManager.AllowAccessibilityExtractContent = true; // do not allow to assemble document pdfDoc.SecurityManager.AllowAssembleDocument = false; // Create one page PDFPage pdfPage = pdfDoc.AddPage(); // Draw "Encrypted Hello world" in the center of the page pdfPage.Canvas.DrawText("Encrypted", new PDFFont(PDFFontFace.Helvetica, 100), new PDFPen(new PDFRgbColor(255, 0, 0), 1), new PDFBrush(new PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2 - 3, 0, PDFTextAlign.BottomCenter); pdfPage.Canvas.DrawText("Hello world !", new PDFFont(PDFFontFace.Helvetica, 100), new PDFPen(new PDFRgbColor(255, 0, 0), 1), new PDFBrush(new PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2 + 3, 0, PDFTextAlign.TopCenter); // Save the document to disk pdfDoc.Save("Sample_Encryption.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Encryption.vb
Imports System Imports System.Text Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Security Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Encryption ''' <summary> ''' This sample shows how to use the pdf ''' security features of PDF4NET library ''' </summary> Class Encryption ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' set the security options pdfDoc.SecurityManager = New PDFSecurityManager() ' use 128 bit encryption pdfDoc.SecurityManager.KeySize = EncryptionKeySize.Use128BitKey ' set user password to "userpass" pdfDoc.SecurityManager.UserPassword = Encoding.ASCII.GetBytes("userpass") ' set owner password to "ownerpass" pdfDoc.SecurityManager.OwnerPassword = Encoding.ASCII.GetBytes("ownerpass") ' allow to print the pdf document pdfDoc.SecurityManager.AllowPrint = True ' do not allow high quality print pdfDoc.SecurityManager.FullQualityPrint = False ' do not alow to modify the document pdfDoc.SecurityManager.AllowModifyDocument = False ' do not allow to extract content (text and images) from the document pdfDoc.SecurityManager.AllowExtractContent = False ' do not allow to fill forms or to create annotations pdfDoc.SecurityManager.AllowInteractiveEdit = False ' do not allow forms fill pdfDoc.SecurityManager.AllowFormsFill = False ' allow to extract content in support for accessibility pdfDoc.SecurityManager.AllowAccessibilityExtractContent = True ' do not allow to assemble document pdfDoc.SecurityManager.AllowAssembleDocument = False ' Create one page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Draw "Encrypted Hello world" in the center of the page pdfPage.Canvas.DrawText("Encrypted", New PDFFont(PDFFontFace.Helvetica, 100), New PDFPen(New PDFRgbColor(255, 0, 0), 1), New PDFBrush(New PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2 - 3, _ 0, PDFTextAlign.BottomCenter) pdfPage.Canvas.DrawText("Hello world !", New PDFFont(PDFFontFace.Helvetica, 100), New PDFPen(New PDFRgbColor(255, 0, 0), 1), New PDFBrush(New PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2 + 3, _ 0, PDFTextAlign.TopCenter) ' Save the document to disk pdfDoc.Save("Sample_Encryption.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: ExtractImages
This samples shows how to extract the images stored in a PDF file.

C# Source code | VB.NET Source code

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


ExtractImages.cs
using System; using System.IO; using System.Text; using System.Drawing; using System.Drawing.Imaging; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.PDFFile; namespace O2S.Samples.PDF4NET { class ExtractImages { static void Main(string[] args) { // Load the PDF file. PDFDocument doc = new PDFDocument("..\\SupportFiles\\Images.pdf"); for (int i = 0; i < doc.Pages.Count; i++) { // Convert the pages to PDFImportedPage to get access to ExtractImages method. PDFImportedPage ip = doc.Pages[i] as PDFImportedPage; Bitmap[] images = ip.ExtractImages(); // Save the page images to disk, if there are any. for (int j = 0; j < images.Length; j++) { images[j].Save("image" + i.ToString() + j.ToString() + ".png", ImageFormat.Png); } } } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


ExtractImages.vb
Imports System Imports System.IO Imports System.Text Imports System.Drawing Imports System.Drawing.Imaging Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.PDFFile Namespace O2S.Samples.PDF4NET Class ExtractImages Shared Sub Main(args As String()) ' Load the PDF file. Dim doc As New PDFDocument("..\SupportFiles\Images.pdf") Dim i As Integer = 0 While i < doc.Pages.Count ' Convert the pages to PDFImportedPage to get access to ExtractImages method. Dim ip As PDFImportedPage = TryCast(doc.Pages(i), PDFImportedPage) Dim images As Bitmap() = ip.ExtractImages() ' Save the page images to disk, if there are any. Dim j As Integer = 0 While j < images.Length images(j).Save("image" + i.ToString() + j.ToString() + ".png", ImageFormat.Png) j = j + 1 End While i = i + 1 End While End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Forms
This section includes several samples related to PDF forms.

FormCreate - shows how to create a PDF form using PDF4NET library.

FormFieldsEnumerator - shows how to enumerate all the fields in a PDF form using PDF4NET library.

FormFill - shows how to fill a PDF form using PDF4NET library.

FormFillXFA - shows how to fill a XFA form using PDF4NET library.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: FormCreate
This samples shows how to create a PDF e-form using PDF4NET library. The sample creates all types of available fields. It also shows how to attach actions to button clicks and how to create a submit form button.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormCreate.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Actions; using O2S.Components.PDF4NET.Forms; using O2S.Components.PDF4NET.Graphics.Fonts; using O2S.Components.PDF4NET.Annotations; namespace O2S.Samples.PDF4NET { /// <summary> /// This samples shows how to create a PDF e-form using PDF4NET library. The /// sample creates all types of available fields. It also shows how to attach /// actions to button clicks and how to create a submit form button. /// </summary> class FormCreate { [STAThread] static void Main(string[] args) { PDFDocument doc = new PDFDocument(); PDFPage page = doc.AddPage(); PDFRgbColor blackColor = new PDFRgbColor(0, 0, 0); // Create 4 textboxes. PDFTextBoxField tbx = new PDFTextBoxField("TextBox1"); tbx.Widgets[0].Rectangle = new RectangleF(50, 50, 200, 20); tbx.Widgets[0].BorderWidth = 1; tbx.Widgets[0].BorderStyle = PDFBorderStyle.Solid; tbx.Widgets[0].BorderColor = blackColor; page.Fields.Add(tbx); tbx = new PDFTextBoxField("TextBox3"); tbx.Widgets[0].Rectangle = new RectangleF(300, 50, 200, 40); tbx.Widgets[0].BorderWidth = 1; tbx.Widgets[0].BorderStyle = PDFBorderStyle.Solid; tbx.Widgets[0].BorderColor = blackColor; tbx.Text = "Sample field value"; page.Fields.Add(tbx); // These 2 textboxes have no border. tbx = new PDFTextBoxField("TextBox2"); tbx.Widgets[0].Rectangle = new RectangleF(50, 100, 200, 20); tbx.Text = "<Click here to fill your name>"; tbx.Value = ""; page.Fields.Add(tbx); tbx = new PDFTextBoxField("TextBox4"); tbx.Widgets[0].Rectangle = new RectangleF(300, 100, 200, 40); page.Fields.Add(tbx); // Create a push button PDFPushButtonField btn = new PDFPushButtonField("Pushbutton"); btn.Tooltip = "Button Tooltip"; (btn.Widgets[0] as PDFPushButtonWidget).Caption = "Push me"; btn.Widgets[0].Rectangle = new RectangleF(50, 150, 200, 20); btn.Widgets[0].Color = new PDFRgbColor(255, 0, 0); btn.Widgets[0].BackColor = new PDFRgbColor(0, 255, 0); page.Fields.Add(btn); // Set an OnClick action for the button PDFJavaScriptAction js = new PDFJavaScriptAction(); js.Script = "var f = this.getField(\"TextBox1\");\r\nf.value = \"test\";"; btn.Widgets[0].MouseUp = js; // Create a submit form push button btn = new PDFPushButtonField("SubmitForm"); btn.Tooltip = "Submits the form fields"; (btn.Widgets[0] as PDFPushButtonWidget).Caption = "Submit form"; btn.Widgets[0].Rectangle = new RectangleF(300, 150, 200, 20); btn.Widgets[0].Color = new PDFRgbColor(255, 0, 0); btn.Widgets[0].BackColor = new PDFRgbColor(0, 255, 0); page.Fields.Add(btn); // Set an OnClick action for the button PDFSubmitFormAction submitFormAction = new PDFSubmitFormAction(); submitFormAction.Url = "http://localhost/fieldsexplorer/fieldsviewer.aspx"; submitFormAction.DataFormat = SubmitDataFormat.HTML; btn.Widgets[0].MouseUp = submitFormAction; // Create a checkbox PDFCheckBoxField checkBox = new PDFCheckBoxField("CheckBox"); (checkBox.Widgets[0] as PDFCheckBoxWidget).ExportValue = "1"; checkBox.Checked = true; (checkBox.Widgets[0] as PDFCheckBoxWidget).CheckSymbolStyle = PDFCheckSymbolStyle.Check; checkBox.Widgets[0].Rectangle = new RectangleF(50, 200, 20, 20); checkBox.Widgets[0].Color = new PDFRgbColor(0, 0, 0); checkBox.Widgets[0].BackColor = new PDFRgbColor(255, 255, 255); page.Fields.Add(checkBox); // Create a radiobutton list PDFRadioButtonListField rbl = new PDFRadioButtonListField("RadioButtonList"); PDFRadioButtonItem rbi = new PDFRadioButtonItem(); rbi.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond; rbi.ExportValue = "1"; rbi.Rectangle = new RectangleF(50, 250, 20, 20); rbi.Color = new PDFRgbColor(255, 255, 255); rbi.BackColor = new PDFRgbColor(0, 0, 0); rbl.Widgets.Add(rbi); PDFRadioButtonItem rbi2 = new PDFRadioButtonItem(); rbi2.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond; rbi2.ExportValue = "2"; rbi2.Rectangle = new RectangleF(50, 300, 20, 20); rbi2.Color = new PDFRgbColor(255, 255, 255); rbi2.BackColor = new PDFRgbColor(0, 0, 0); rbl.Widgets.Add(rbi2); PDFRadioButtonItem rbi3 = new PDFRadioButtonItem(); rbi3.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond; rbi3.ExportValue = "3"; rbi3.Rectangle = new RectangleF(50, 350, 20, 20); rbi3.Color = new PDFRgbColor(255, 255, 255); rbi3.BackColor = new PDFRgbColor(0, 0, 0); rbl.Widgets.Add(rbi3); rbl.SelectedValue = "3"; page.Fields.Add(rbl); // Create a drop down list PDFDropDownListField ddl = new PDFDropDownListField("DropDownList"); PDFListItem li = new PDFListItem("Item 1", "1"); ddl.Items.Add(li); PDFListItem li2 = new PDFListItem("Item 2", "2"); ddl.Items.Add(li2); PDFListItem li3 = new PDFListItem("Item 3", "3"); ddl.Items.Add(li3); ddl.Widgets[0].Rectangle = new RectangleF(50, 400, 200, 20); ddl.Widgets[0].Font = new PDFFont(PDFFontFace.Courier, 10); ddl.Widgets[0].BorderWidth = 1; ddl.Widgets[0].BorderStyle = PDFBorderStyle.Solid; ddl.Widgets[0].BorderColor = new PDFRgbColor(0, 0, 255); ddl.SelectedIndex = 1; page.Fields.Add(ddl); // Create a list box PDFListBoxField lbx = new PDFListBoxField("ListBox"); PDFListItem lxi = new PDFListItem("Item 1", "1"); PDFListItem lxi2 = new PDFListItem("Item 2", "2"); PDFListItem lxi3 = new PDFListItem("Item 3", "3"); lbx.Items.Add(lxi); lbx.Items.Add(lxi2); lbx.Items.Add(lxi3); lbx.Widgets[0].Rectangle = new RectangleF(50, 450, 200, 80); lbx.Widgets[0].BorderWidth = 1; lbx.Widgets[0].BorderStyle = PDFBorderStyle.Solid; lbx.Widgets[0].BorderColor = new PDFRgbColor(0, 0, 255); lbx.SelectedIndex = 2; page.Fields.Add(lbx); doc.Save("Sample_FormNew.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormCreate.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Actions Imports O2S.Components.PDF4NET.Forms Imports O2S.Components.PDF4NET.Graphics.Fonts Imports O2S.Components.PDF4NET.Annotations Namespace O2S.Samples.PDF4NET ''' <summary> ''' This samples shows how to create a PDF e-form using PDF4NET library. The ''' sample creates all types of available fields. It also shows how to attach ''' actions to button clicks and how to create a submit form button. ''' </summary> Class FormCreate <STAThread> _ Shared Sub Main(args As String()) Dim doc As New PDFDocument() Dim page As PDFPage = doc.AddPage() Dim blackColor As New PDFRgbColor(0, 0, 0) ' Create 4 textboxes. Dim tbx As New PDFTextBoxField("TextBox1") tbx.Widgets(0).Rectangle = New RectangleF(50, 50, 200, 20) tbx.Widgets(0).BorderWidth = 1 tbx.Widgets(0).BorderStyle = PDFBorderStyle.Solid tbx.Widgets(0).BorderColor = blackColor page.Fields.Add(tbx) tbx = New PDFTextBoxField("TextBox3") tbx.Widgets(0).Rectangle = New RectangleF(300, 50, 200, 40) tbx.Widgets(0).BorderWidth = 1 tbx.Widgets(0).BorderStyle = PDFBorderStyle.Solid tbx.Widgets(0).BorderColor = blackColor tbx.Text = "Sample field value" page.Fields.Add(tbx) ' These 2 textboxes have no border. tbx = New PDFTextBoxField("TextBox2") tbx.Widgets(0).Rectangle = New RectangleF(50, 100, 200, 20) tbx.Text = "<Click here to fill your name>" tbx.Value = "" page.Fields.Add(tbx) tbx = New PDFTextBoxField("TextBox4") tbx.Widgets(0).Rectangle = New RectangleF(300, 100, 200, 40) page.Fields.Add(tbx) ' Create a push button Dim btn As New PDFPushButtonField("Pushbutton") btn.Tooltip = "Button Tooltip" Dim pushButtonWidget As PDFPushButtonWidget = btn.Widgets(0) pushButtonWidget.Caption = "Push me" btn.Widgets(0).Rectangle = New RectangleF(50, 150, 200, 20) btn.Widgets(0).Color = New PDFRgbColor(255, 0, 0) btn.Widgets(0).BackColor = New PDFRgbColor(0, 255, 0) page.Fields.Add(btn) ' Set an OnClick action for the button Dim js As New PDFJavaScriptAction() js.Script = "var f = this.getField(""TextBox1"");" & vbCr & vbLf & "f.value = ""test"";" btn.Widgets(0).MouseUp = js ' Create a submit form push button btn = New PDFPushButtonField("SubmitForm") btn.Tooltip = "Submits the form fields" pushButtonWidget = btn.Widgets(0) pushButtonWidget.Caption = "Submit form" btn.Widgets(0).Rectangle = New RectangleF(300, 150, 200, 20) btn.Widgets(0).Color = New PDFRgbColor(255, 0, 0) btn.Widgets(0).BackColor = New PDFRgbColor(0, 255, 0) page.Fields.Add(btn) ' Set an OnClick action for the button Dim submitFormAction As New PDFSubmitFormAction() submitFormAction.Url = "http://localhost/fieldsexplorer/fieldsviewer.aspx" submitFormAction.DataFormat = SubmitDataFormat.HTML btn.Widgets(0).MouseUp = submitFormAction ' Create a checkbox Dim checkBox As New PDFCheckBoxField("CheckBox") Dim checkBoxWidget As PDFCheckBoxWidget = checkBox.Widgets(0) checkBoxWidget.ExportValue = "1" checkBoxWidget.CheckSymbolStyle = PDFCheckSymbolStyle.Check checkBox.Widgets(0).Rectangle = New RectangleF(50, 200, 20, 20) checkBox.Widgets(0).Color = New PDFRgbColor(0, 0, 0) checkBox.Widgets(0).BackColor = New PDFRgbColor(255, 255, 255) checkBox.Checked = True page.Fields.Add(checkBox) ' Create a radiobutton list Dim rbl As New PDFRadioButtonListField("RadioButtonList") Dim rbi As New PDFRadioButtonItem() rbi.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond rbi.ExportValue = "1" rbi.Rectangle = New RectangleF(50, 250, 20, 20) rbi.Color = New PDFRgbColor(255, 255, 255) rbi.BackColor = New PDFRgbColor(0, 0, 0) rbl.Widgets.Add(rbi) Dim rbi2 As New PDFRadioButtonItem() rbi2.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond rbi2.ExportValue = "2" rbi2.Rectangle = New RectangleF(50, 300, 20, 20) rbi2.Color = New PDFRgbColor(255, 255, 255) rbi2.BackColor = New PDFRgbColor(0, 0, 0) rbl.Widgets.Add(rbi2) Dim rbi3 As New PDFRadioButtonItem() rbi3.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond rbi3.ExportValue = "3" rbi3.Rectangle = New RectangleF(50, 350, 20, 20) rbi3.Color = New PDFRgbColor(255, 255, 255) rbi3.BackColor = New PDFRgbColor(0, 0, 0) rbl.Widgets.Add(rbi3) rbl.SelectedValue = "3" page.Fields.Add(rbl) ' Create a drop down list Dim ddl As New PDFDropDownListField("DropDownList") Dim li As New PDFListItem("Item 1", "1") ddl.Items.Add(li) Dim li2 As New PDFListItem("Item 2", "2") ddl.Items.Add(li2) Dim li3 As New PDFListItem("Item 3", "3") ddl.Items.Add(li3) ddl.Widgets(0).Rectangle = New RectangleF(50, 400, 200, 20) ddl.Widgets(0).Font = New PDFFont(PDFFontFace.Courier, 10) ddl.Widgets(0).BorderWidth = 1 ddl.Widgets(0).BorderStyle = PDFBorderStyle.Solid ddl.Widgets(0).BorderColor = New PDFRgbColor(0, 0, 255) ddl.SelectedIndex = 1 page.Fields.Add(ddl) ' Create a list box Dim lbx As New PDFListBoxField("ListBox") Dim lxi As New PDFListItem("Item 1", "1") Dim lxi2 As New PDFListItem("Item 2", "2") Dim lxi3 As New PDFListItem("Item 3", "3") lbx.Items.Add(lxi) lbx.Items.Add(lxi2) lbx.Items.Add(lxi3) lbx.Widgets(0).Rectangle = New RectangleF(50, 450, 200, 80) lbx.Widgets(0).BorderWidth = 1 lbx.Widgets(0).BorderStyle = PDFBorderStyle.Solid lbx.Widgets(0).BorderColor = New PDFRgbColor(0, 0, 255) lbx.SelectedIndex = 2 page.Fields.Add(lbx) doc.Save("Sample_FormNew.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: FormFieldsEnumerator
This sample shows how to enumerate the fields in a PDF document. Because PDF specification allows the same field to appear multiple times (both on the same page, and in the document), a difference is made between fields and their widgets (their visual representations). For example, if the same field appears 3 times in a PDF file, the Fields collection of the document will contain only one element, 1 field. The field tells the user how many widgets it has.
The radiobutton list is a special case: each item can have only one widget, but the list can spread over multiple pages (for example 3 items on a page, 3 items on another page, like in the PDF file used in this sample).

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormFieldsEnumerator.cs
using System; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Forms; namespace O2S.Samples.PDF4NET { /// <summary> /// This sample shows how to enumerate the fields in a PDF document. Because PDF specification /// allows the same field to appear multiple times (both on the same page, and in the document), /// a difference is made between fields and their widgets (their visual representations). /// For example, if the same field appears 3 times in a PDF file, the Fields collection of the /// document will contain only one element, 1 field. The field tells the user how many /// widgets it has. /// The radiobutton list is a special case: each item can have only one widget, but the list /// can spread over multiple pages (for example 3 items on a page, 3 items on another page, like /// in the PDF file used in this sample). /// </summary> class FormFieldsEnumerator { [STAThread] static void Main(string[] args) { // Load the PDF document PDFDocument doc = new PDFDocument( "..\\SupportFiles\\FormFieldsEnumerator.pdf" ); // Display total number of fields in the document // 6 fields: 1 text box (3 widgets), 1 checkbox (3 widgets), 1 combobox (1 widget) // 1 listbox (1 widget), 1 radiobuttonlist (6 items), 1 pushbutton (1 widget) Console.WriteLine( "Total number of fields in the document: {0}", doc.Form.Fields.Count ); // Display number of fields located on page 1 // 6 fields: 1 text box (2 widgets), 1 checkbox (3 widgets), 1 combobox (1 widget) // 1 listbox (1 widget), 1 radiobuttonlist (3 items on this page), 1 pushbutton Console.WriteLine( "Number of fields on page 1: {0}", doc.Pages[0].Fields.Count ); // Display number of fields located on page 2 // 2 fields: 1 text box (1 widgets), 1 radiobuttonlist (3 items on this page) Console.WriteLine( "Number of fields on page 2: {0}", doc.Pages[1].Fields.Count ); // Sum of fields on both pages is different from the number of fields // in the document because there are fields that appear on both pages (TextBox and RadioButton) Console.WriteLine( "Sum of fields on both pages is different from the number of fields " + "in the document because there are fields that appear on both pages (TextBox and RadioButton)" ); Console.WriteLine( " " ); // Enumerate the widgets of all fields in the document Console.WriteLine( "Field widgets at document level" ); for( int i = 0; i < doc.Form.Fields.Count; i++ ) { // Display the field name Console.WriteLine( "Field name: {0}", doc.Form.Fields[i].Name ); switch (doc.Form.Fields[i].Type) { case PDFFieldType.TextBox: PDFTextBoxField textBox = (PDFTextBoxField)doc.Form.Fields[i]; for (int wx = 0; wx < textBox.Widgets.Count; wx++) { DisplayRectangle rc = textBox.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); } break; case PDFFieldType.PushButton: PDFPushButtonField pushButton = (PDFPushButtonField)doc.Form.Fields[i]; for (int wx = 0; wx < pushButton.Widgets.Count; wx++) { DisplayRectangle rc = pushButton.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); } break; case PDFFieldType.CheckBox: PDFCheckBoxField checkBox = (PDFCheckBoxField)doc.Form.Fields[i]; for (int wx = 0; wx < checkBox.Widgets.Count; wx++) { DisplayRectangle rc = checkBox.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); Console.WriteLine(" Export value for widget {0}: {1}", wx + 1, (checkBox.Widgets[wx] as PDFCheckBoxWidget).ExportValue); Console.WriteLine(" Widget {0} is checked: {1}", wx + 1, (checkBox.Widgets[wx] as PDFCheckBoxWidget).Checked); } break; case PDFFieldType.DropDownList: PDFDropDownListField dropDownList = (PDFDropDownListField)doc.Form.Fields[i]; for (int wx = 0; wx < dropDownList.Widgets.Count; wx++) { DisplayRectangle rc = dropDownList.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); } break; case PDFFieldType.ListBox: PDFListBoxField listBox = (PDFListBoxField)doc.Form.Fields[i]; for (int wx = 0; wx < listBox.Widgets.Count; wx++) { DisplayRectangle rc = listBox.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); } break; case PDFFieldType.RadioButton: PDFRadioButtonListField radioButtonList = (PDFRadioButtonListField)doc.Form.Fields[i]; Console.WriteLine(" Field \"{0}\" has {1} item(s)", radioButtonList.Name, radioButtonList.Widgets.Count); break; } Console.WriteLine(" Field \"{0}\" has {1} widget(s)", doc.Form.Fields[i].Name, doc.Form.Fields[i].Widgets.Count); } Console.WriteLine( " " ); // Enumerate the widgets of all fields at page level Console.WriteLine( "Field widgets at page level" ); for( int j = 0; j < doc.Pages.Count; j++ ) { Console.WriteLine( "*** Field widgets on page {0}", j + 1 ); for (int i = 0; i < doc.Pages[j].Fields.Count; i++) { // Display the field name Console.WriteLine("Field name: {0}", doc.Pages[j].Fields[i].Name); switch (doc.Pages[j].Fields[i].Type) { case PDFFieldType.TextBox: PDFTextBoxField textBox = (PDFTextBoxField)doc.Pages[j].Fields[i]; for (int wx = 0; wx < textBox.Widgets.Count; wx++) { // Consider only the widgets on current page. if (textBox.Widgets[wx].Page == doc.Pages[j]) { DisplayRectangle rc = textBox.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); } } break; case PDFFieldType.PushButton: PDFPushButtonField pushButton = (PDFPushButtonField)doc.Pages[j].Fields[i]; for (int wx = 0; wx < pushButton.Widgets.Count; wx++) { // Consider only the widgets on current page. if (pushButton.Widgets[wx].Page == doc.Pages[j]) { DisplayRectangle rc = pushButton.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); } } break; case PDFFieldType.CheckBox: PDFCheckBoxField checkBox = (PDFCheckBoxField)doc.Pages[j].Fields[i]; for (int wx = 0; wx < checkBox.Widgets.Count; wx++) { // Consider only the widgets on current page. if (checkBox.Widgets[wx].Page == doc.Pages[j]) { DisplayRectangle rc = checkBox.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); Console.WriteLine(" Export value for widget {0}: {1}", wx + 1, (checkBox.Widgets[wx] as PDFCheckBoxWidget).ExportValue); Console.WriteLine(" Widget {0} is checked: {1}", wx + 1, (checkBox.Widgets[wx] as PDFCheckBoxWidget).Checked); } } break; case PDFFieldType.DropDownList: PDFDropDownListField dropDownList = (PDFDropDownListField)doc.Pages[j].Fields[i]; for (int wx = 0; wx < dropDownList.Widgets.Count; wx++) { // Consider only the widgets on current page. if (dropDownList.Widgets[wx].Page == doc.Pages[j]) { DisplayRectangle rc = dropDownList.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); } } break; case PDFFieldType.ListBox: PDFListBoxField listBox = (PDFListBoxField)doc.Pages[j].Fields[i]; for (int wx = 0; wx < listBox.Widgets.Count; wx++) { // Consider only the widgets on current page. if (listBox.Widgets[wx].Page == doc.Pages[j]) { DisplayRectangle rc = listBox.Widgets[wx].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height); } } break; case PDFFieldType.RadioButton: PDFRadioButtonListField radioButtonList = (PDFRadioButtonListField)doc.Pages[j].Fields[i]; // Number of radiobutton items located on this page int itemsCount = 0; for (int k = 0; k < radioButtonList.Widgets.Count; k++) { if (radioButtonList.Widgets[k].Page == doc.Pages[j]) { itemsCount++; DisplayRectangle rc = radioButtonList.Widgets[k].DisplayRectangle; // Display widget position on the page Console.WriteLine(" Position for item {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", itemsCount, rc.Left, rc.Top, rc.Width, rc.Height); } } Console.WriteLine(" Field \"{0}\" has {1} item(s) on this page", radioButtonList.Name, itemsCount); break; } } } } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormFieldsEnumerator.vb
Imports System Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Forms Namespace O2S.Samples.PDF4NET ''' <summary> ''' This sample shows how to enumerate the fields in a PDF document. Because PDF specification ''' allows the same field to appear multiple times (both on the same page, and in the document), ''' a difference is made between fields and their widgets (their visual representations). ''' For example, if the same field appears 3 times in a PDF file, the Fields collection of the ''' document will contain only one element, 1 field. The field tells the user how many ''' widgets it has. ''' The radiobutton list is a special case: each item can have only one widget, but the list ''' can spread over multiple pages (for example 3 items on a page, 3 items on another page, like ''' in the PDF file used in this sample). ''' </summary> Class FormFieldsEnumerator <STAThread> _ Shared Sub Main(args As String()) ' Load the PDF document Dim doc As New PDFDocument("..\SupportFiles\FormFieldsEnumerator.pdf") ' Display total number of fields in the document ' 6 fields: 1 text box (3 widgets), 1 checkbox (3 widgets), 1 combobox (1 widget) ' 1 listbox (1 widget), 1 radiobuttonlist (6 items), 1 pushbutton (1 widget) Console.WriteLine("Total number of fields in the document: {0}", doc.Form.Fields.Count) ' Display number of fields located on page 1 ' 6 fields: 1 text box (2 widgets), 1 checkbox (3 widgets), 1 combobox (1 widget) ' 1 listbox (1 widget), 1 radiobuttonlist (3 items on this page), 1 pushbutton Console.WriteLine("Number of fields on page 1: {0}", doc.Pages(0).Fields.Count) ' Display number of fields located on page 2 ' 2 fields: 1 text box (1 widgets), 1 radiobuttonlist (3 items on this page) Console.WriteLine("Number of fields on page 2: {0}", doc.Pages(1).Fields.Count) ' Sum of fields on both pages is different from the number of fields ' in the document because there are fields that appear on both pages (TextBox and RadioButton) Console.WriteLine("Sum of fields on both pages is different from the number of fields " + "in the document because there are fields that appear on both pages (TextBox and RadioButton)") Console.WriteLine(" ") ' Enumerate the widgets of all fields in the document Console.WriteLine("Field widgets at document level") Dim i As Integer = 0 While i < doc.Form.Fields.Count ' Display the field name Console.WriteLine("Field name: {0}", doc.Form.Fields(i).Name) Select Case doc.Form.Fields(i).Type Case PDFFieldType.TextBox Dim textBox As PDFTextBoxField = DirectCast(doc.Form.Fields(i), PDFTextBoxField) Dim wx As Integer = 0 While wx < textBox.Widgets.Count Dim rc As DisplayRectangle = textBox.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) wx = wx + 1 End While Exit Select Case PDFFieldType.PushButton Dim pushButton As PDFPushButtonField = DirectCast(doc.Form.Fields(i), PDFPushButtonField) Dim wx As Integer = 0 While wx < pushButton.Widgets.Count Dim rc As DisplayRectangle = pushButton.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) wx = wx + 1 End While Exit Select Case PDFFieldType.CheckBox Dim checkBox As PDFCheckBoxField = DirectCast(doc.Form.Fields(i), PDFCheckBoxField) Dim wx As Integer = 0 While wx < checkBox.Widgets.Count Dim rc As DisplayRectangle = checkBox.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) Console.WriteLine(" Export value for widget {0}: {1}", wx + 1, (TryCast(checkBox.Widgets(wx), PDFCheckBoxWidget)).ExportValue) Console.WriteLine(" Widget {0} is checked: {1}", wx + 1, (TryCast(checkBox.Widgets(wx), PDFCheckBoxWidget)).Checked) wx = wx + 1 End While Exit Select Case PDFFieldType.DropDownList Dim dropDownList As PDFDropDownListField = DirectCast(doc.Form.Fields(i), PDFDropDownListField) Dim wx As Integer = 0 While wx < dropDownList.Widgets.Count Dim rc As DisplayRectangle = dropDownList.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) wx = wx + 1 End While Exit Select Case PDFFieldType.ListBox Dim listBox As PDFListBoxField = DirectCast(doc.Form.Fields(i), PDFListBoxField) Dim wx As Integer = 0 While wx < listBox.Widgets.Count Dim rc As DisplayRectangle = listBox.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) wx = wx + 1 End While Exit Select Case PDFFieldType.RadioButton Dim radioButtonList As PDFRadioButtonListField = DirectCast(doc.Form.Fields(i), PDFRadioButtonListField) Console.WriteLine(" Field ""{0}"" has {1} item(s)", radioButtonList.Name, radioButtonList.Widgets.Count) Exit Select End Select Console.WriteLine(" Field ""{0}"" has {1} widget(s)", doc.Form.Fields(i).Name, doc.Form.Fields(i).Widgets.Count) i = i + 1 End While Console.WriteLine(" ") ' Enumerate the widgets of all fields at page level Console.WriteLine("Field widgets at page level") Dim j As Integer = 0 While j < doc.Pages.Count Console.WriteLine("*** Field widgets on page {0}", j + 1) i = 0 While i < doc.Pages(j).Fields.Count ' Display the field name Console.WriteLine("Field name: {0}", doc.Pages(j).Fields(i).Name) Select Case doc.Pages(j).Fields(i).Type Case PDFFieldType.TextBox Dim textBox As PDFTextBoxField = DirectCast(doc.Pages(j).Fields(i), PDFTextBoxField) Dim wx As Integer = 0 While wx < textBox.Widgets.Count ' Consider only the widgets on current page. If Object.Equals(textBox.Widgets(wx).Page, doc.Pages(j)) Then Dim rc As DisplayRectangle = textBox.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) End If wx = wx + 1 End While Exit Select Case PDFFieldType.PushButton Dim pushButton As PDFPushButtonField = DirectCast(doc.Pages(j).Fields(i), PDFPushButtonField) Dim wx As Integer = 0 While wx < pushButton.Widgets.Count ' Consider only the widgets on current page. If Object.Equals(pushButton.Widgets(wx).Page, doc.Pages(j)) Then Dim rc As DisplayRectangle = pushButton.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) End If wx = wx + 1 End While Exit Select Case PDFFieldType.CheckBox Dim checkBox As PDFCheckBoxField = DirectCast(doc.Pages(j).Fields(i), PDFCheckBoxField) Dim wx As Integer = 0 While wx < checkBox.Widgets.Count ' Consider only the widgets on current page. If Object.Equals(checkBox.Widgets(wx).Page, doc.Pages(j)) Then Dim rc As DisplayRectangle = checkBox.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) Console.WriteLine(" Export value for widget {0}: {1}", wx + 1, (TryCast(checkBox.Widgets(wx), PDFCheckBoxWidget)).ExportValue) Console.WriteLine(" Widget {0} is checked: {1}", wx + 1, (TryCast(checkBox.Widgets(wx), PDFCheckBoxWidget)).Checked) End If wx = wx + 1 End While Exit Select Case PDFFieldType.DropDownList Dim dropDownList As PDFDropDownListField = DirectCast(doc.Pages(j).Fields(i), PDFDropDownListField) Dim wx As Integer = 0 While wx < dropDownList.Widgets.Count ' Consider only the widgets on current page. If Object.Equals(dropDownList.Widgets(wx).Page, doc.Pages(j)) Then Dim rc As DisplayRectangle = dropDownList.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) End If wx = wx + 1 End While Exit Select Case PDFFieldType.ListBox Dim listBox As PDFListBoxField = DirectCast(doc.Pages(j).Fields(i), PDFListBoxField) Dim wx As Integer = 0 While wx < listBox.Widgets.Count ' Consider only the widgets on current page. If Object.Equals(listBox.Widgets(wx).Page, doc.Pages(j)) Then Dim rc As DisplayRectangle = listBox.Widgets(wx).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height) End If wx = wx + 1 End While Exit Select Case PDFFieldType.RadioButton Dim radioButtonList As PDFRadioButtonListField = DirectCast(doc.Pages(j).Fields(i), PDFRadioButtonListField) ' Number of radiobutton items located on this page Dim itemsCount As Integer = 0 Dim k As Integer = 0 While k < radioButtonList.Widgets.Count If Object.Equals(radioButtonList.Widgets(k).Page, doc.Pages(j)) Then itemsCount = itemsCount + 1 Dim rc As DisplayRectangle = radioButtonList.Widgets(k).DisplayRectangle ' Display widget position on the page Console.WriteLine(" Position for item {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", itemsCount, rc.Left, rc.Top, rc.Width, rc.Height) End If k = k + 1 End While Console.WriteLine(" Field ""{0}"" has {1} item(s) on this page", radioButtonList.Name, itemsCount) Exit Select End Select i = i + 1 End While j = j + 1 End While End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Formfill
This sample demonstrates how to fill a PDF form using PDF4NET.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormFill.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Forms; namespace O2S.Samples.PDF4NET { /// <summary> /// This sample shows how to fill a PDF form using PDF4NET library. /// </summary> class FormFill { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument doc = new PDFDocument("..\\SupportFiles\\fw4.pdf"); // fill the fields from the first page (doc.Form.Fields["f1-1"] as PDFTextBoxField).Text = "1"; (doc.Form.Fields["f1-2"] as PDFTextBoxField).Text = "1"; (doc.Form.Fields["f1-3"] as PDFTextBoxField).Text = "1"; (doc.Form.Fields["f1-4"] as PDFTextBoxField).Text = "3"; (doc.Form.Fields["f1-5"] as PDFTextBoxField).Text = "1"; (doc.Form.Fields["f1-6"] as PDFTextBoxField).Text = "1"; (doc.Form.Fields["f1-7"] as PDFTextBoxField).Text = "22"; (doc.Form.Fields["f1-8"] as PDFTextBoxField).Text = "30"; (doc.Form.Fields["f1-9"] as PDFTextBoxField).Text = "John"; (doc.Form.Fields["f1-10"] as PDFTextBoxField).Text = "Doe"; (doc.Form.Fields["f1-11"] as PDFTextBoxField).Text = "11 Voltaire str."; (doc.Form.Fields["f1-12"] as PDFTextBoxField).Text = "Cluj-Napoca, CJ 400000"; (doc.Form.Fields["f1-13"] as PDFTextBoxField).Text = "332"; (doc.Form.Fields["f1-14"] as PDFTextBoxField).Text = "43"; (doc.Form.Fields["f1-15"] as PDFTextBoxField).Text = "4556"; (doc.Form.Fields["f1-16"] as PDFTextBoxField).Text = "3"; (doc.Form.Fields["f1-17"] as PDFTextBoxField).Text = "2000"; (doc.Form.Fields["f1-18"] as PDFTextBoxField).Text = "Exempt"; (doc.Form.Fields["f1-19"] as PDFTextBoxField).Text = "PDF4NET SRL, 11 Voltaire str., Cluj-Napoca, CJ 400000"; (doc.Form.Fields["f1-20"] as PDFTextBoxField).Text = "200"; (doc.Form.Fields["f1-21"] as PDFTextBoxField).Text = "22"; (doc.Form.Fields["f1-22"] as PDFTextBoxField).Text = "56654"; (doc.Form.Fields["c1-1"] as PDFCheckBoxField).Value = "Yes"; (doc.Form.Fields["c1-2"] as PDFCheckBoxField).Checked = true; // fill the fields from the second page (doc.Form.Fields["f2-1"] as PDFTextBoxField).Text = "3200"; (doc.Form.Fields["f2-2"] as PDFTextBoxField).Text = "4850"; (doc.Form.Fields["f2-3"] as PDFTextBoxField).Text = "0"; (doc.Form.Fields["f2-4"] as PDFTextBoxField).Text = "500"; (doc.Form.Fields["f2-5"] as PDFTextBoxField).Text = "500"; (doc.Form.Fields["f2-6"] as PDFTextBoxField).Text = "800"; (doc.Form.Fields["f2-7"] as PDFTextBoxField).Text = "0"; (doc.Form.Fields["f2-8"] as PDFTextBoxField).Text = "0"; (doc.Form.Fields["f2-9"] as PDFTextBoxField).Text = "3"; (doc.Form.Fields["f2-10"] as PDFTextBoxField).Text = "3"; (doc.Form.Fields["f2-11"] as PDFTextBoxField).Text = "3"; (doc.Form.Fields["f2-12"] as PDFTextBoxField).Text = "2"; (doc.Form.Fields["f2-13"] as PDFTextBoxField).Text = "3"; (doc.Form.Fields["f2-14"] as PDFTextBoxField).Text = "3"; (doc.Form.Fields["f2-15"] as PDFTextBoxField).Text = "2"; (doc.Form.Fields["f2-16"] as PDFTextBoxField).Text = "1"; (doc.Form.Fields["f2-17"] as PDFTextBoxField).Text = "200"; (doc.Form.Fields["f2-18"] as PDFTextBoxField).Text = "600"; (doc.Form.Fields["f2-19"] as PDFTextBoxField).Text = "250"; // the fields below do not exist in the sample pdf file // the code is provided to show how to work with other field types // select a checkbox //( doc.Form.Fields["c1-1"] as PDFCheckBoxField ).Checked = true; // select the second radio button in the list //( doc.Form.Fields["r1-1"] as PDFRadioButtonListField ).SelectedIndex = 1; // select the first item in the drop down list //( doc.Form.Fields["ddl1-1"] as PDFDropDownListField ).SelectedIndex = 0; // select the 4th item in the list box //( doc.Form.Fields["lb1-1"] as PDFTextBoxField ).SelectedIndex = 3; // Save the document to disk doc.Save("Sample_Fw4fill.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormFill.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Forms Namespace O2S.Samples.PDF4NET ''' <summary> ''' This sample shows how to fill a PDF form using PDF4NET library. ''' </summary> Class FormFill ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument("..\SupportFiles\fw4.pdf") ' fill the fields from the first page CType(doc.Form.Fields("f1-1"), PDFTextBoxField).Text = "1" CType(doc.Form.Fields("f1-2"), PDFTextBoxField).Text = "1" CType(doc.Form.Fields("f1-3"), PDFTextBoxField).Text = "1" CType(doc.Form.Fields("f1-4"), PDFTextBoxField).Text = "3" CType(doc.Form.Fields("f1-5"), PDFTextBoxField).Text = "1" CType(doc.Form.Fields("f1-6"), PDFTextBoxField).Text = "1" CType(doc.Form.Fields("f1-7"), PDFTextBoxField).Text = "22" CType(doc.Form.Fields("f1-8"), PDFTextBoxField).Text = "30" CType(doc.Form.Fields("f1-9"), PDFTextBoxField).Text = "John" CType(doc.Form.Fields("f1-10"), PDFTextBoxField).Text = "Doe" CType(doc.Form.Fields("f1-11"), PDFTextBoxField).Text = "11 Voltaire str." CType(doc.Form.Fields("f1-12"), PDFTextBoxField).Text = "Cluj-Napoca, CJ 400000" CType(doc.Form.Fields("f1-13"), PDFTextBoxField).Text = "332" CType(doc.Form.Fields("f1-14"), PDFTextBoxField).Text = "43" CType(doc.Form.Fields("f1-15"), PDFTextBoxField).Text = "4556" CType(doc.Form.Fields("f1-16"), PDFTextBoxField).Text = "3" CType(doc.Form.Fields("f1-17"), PDFTextBoxField).Text = "2000" CType(doc.Form.Fields("f1-18"), PDFTextBoxField).Text = "Exempt" CType(doc.Form.Fields("f1-19"), PDFTextBoxField).Text = "PDF4NET SRL, 11 Voltaire str., Cluj-Napoca, CJ 400000" CType(doc.Form.Fields("f1-20"), PDFTextBoxField).Text = "200" CType(doc.Form.Fields("f1-21"), PDFTextBoxField).Text = "22" CType(doc.Form.Fields("f1-22"), PDFTextBoxField).Text = "56654" CType(doc.Form.Fields("c1-1"), PDFCheckBoxField).Value = "Yes" CType(doc.Form.Fields("c1-2"), PDFCheckBoxField).Checked = True ' fill the fields from the second page CType(doc.Form.Fields("f2-1"), PDFTextBoxField).Text = "3200" CType(doc.Form.Fields("f2-2"), PDFTextBoxField).Text = "4850" CType(doc.Form.Fields("f2-3"), PDFTextBoxField).Text = "0" CType(doc.Form.Fields("f2-4"), PDFTextBoxField).Text = "500" CType(doc.Form.Fields("f2-5"), PDFTextBoxField).Text = "500" CType(doc.Form.Fields("f2-6"), PDFTextBoxField).Text = "800" CType(doc.Form.Fields("f2-7"), PDFTextBoxField).Text = "0" CType(doc.Form.Fields("f2-8"), PDFTextBoxField).Text = "0" CType(doc.Form.Fields("f2-9"), PDFTextBoxField).Text = "3" CType(doc.Form.Fields("f2-10"), PDFTextBoxField).Text = "3" CType(doc.Form.Fields("f2-11"), PDFTextBoxField).Text = "3" CType(doc.Form.Fields("f2-12"), PDFTextBoxField).Text = "2" CType(doc.Form.Fields("f2-13"), PDFTextBoxField).Text = "3" CType(doc.Form.Fields("f2-14"), PDFTextBoxField).Text = "3" CType(doc.Form.Fields("f2-15"), PDFTextBoxField).Text = "2" CType(doc.Form.Fields("f2-16"), PDFTextBoxField).Text = "1" CType(doc.Form.Fields("f2-17"), PDFTextBoxField).Text = "200" CType(doc.Form.Fields("f2-18"), PDFTextBoxField).Text = "600" CType(doc.Form.Fields("f2-19"), PDFTextBoxField).Text = "250" ' the fields below do not exist in the sample pdf file ' the code is provided to show how to work with other field types ' select a checkbox '( doc.Form.Fields["c1-1"] as PDFCheckBoxField ).Checked = true ' select the second radio button in the list '( doc.Form.Fields["r1-1"] as PDFRadioButtonListField ).SelectedIndex = 1 ' select the first item in the drop down list '( doc.Form.Fields["ddl1-1"] as PDFDropDownListField ).SelectedIndex = 0 ' select the 4th item in the list box '( doc.Form.Fields["lb1-1"] as PDFTextBoxField ).SelectedIndex = 3 ' Save the document to disk doc.Save("Sample_Fw4fill.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: FormFillXFA
This sample demonstrates how to fill a XFA form using PDF4NET.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormFillXFA.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Forms; using O2S.Components.PDF4NET.Forms.XFA; namespace O2S.Samples.PDF4NET { /// <summary> /// This sample shows how to fill a XFA form using PDF4NET library. /// XFA forms are created with Adobe Designer 7. /// </summary> class FormFillXFA { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument doc = new PDFDocument( "..\\SupportFiles\\xfasampleform.pdf" ); // Get the main subform. XFASubform mainSubform = doc.XFAForm.Subforms[0].Subforms[0]; // Fill the product name. mainSubform.Fields["txtName"].Value = "PDF4NET"; // Fill the product SKU. mainSubform.Fields["txtSKU"].Value = "PDF4NET01090"; // Fill the product URL. mainSubform.Fields["txtURL"].Value = "http://www.o2sol.com/pdf4net/products.htm"; // Select the product category. mainSubform.Fields["ddlCategory"].Value = "PDF"; // Also add a new item to Category drop down list. XFAListItem listItem = new XFAListItem( "Compression", "CMP" ); ( mainSubform.Fields["ddlCategory"] as XFAChoiceListField ).Items.Add( listItem ); // Fill the product image. mainSubform.Fields["imgProduct"].Value = "..\\SupportFiles\\pdf4net.jpg"; ( mainSubform.Fields["imgProduct"] as XFAImageEditField ).ContentType = "image/jpg"; // Fill the product short description. mainSubform.Fields["txtShortDescription"].Value = "PDF4NET is a .NET library for adding " + "PDF capabilities to .NET applications. It supports both desktop and web applications."; // Fill the product features. mainSubform.Fields["txtFeature1"].Value = "Create PDF files from scratch."; mainSubform.Fields["txtFeature2"].Value = "Merge, split and encrypt PDF files."; mainSubform.Fields["txtFeature3"].Value = "Create, fill and flatten PDF e-forms."; mainSubform.Fields["txtFeature4"].Value = "Fill XFA forms."; mainSubform.Fields["txtFeature5"].Value = "Add, edit and remove document attachments."; mainSubform.Fields["txtFeature6"].Value = "Add, edit and remove text annotations."; mainSubform.Fields["txtFeature7"].Value = "Support for WinForms and ASP.NET applications."; // Fill the product long description. mainSubform.Fields["txtLongDescription"].Value = "PDF4NET is a .NET library for adding " + "PDF capabilities to .NET applications. Version 2.7 brings support for PDF e-form " + "creation, support for reading and filling static XFA forms and document attachments. " + "It supports both desktop and web applications."; // Save the document to disk doc.Save( "Sample_XfaSampleForm_Fill.pdf" ); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormFillXFA.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Forms Imports O2S.Components.PDF4NET.Forms.XFA Namespace O2S.Samples.PDF4NET ''' <summary> ''' This sample shows how to fill a XFA form using PDF4NET library. ''' XFA forms are created with Adobe Designer 7. ''' </summary> Class FormFillXFA ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument("..\SupportFiles\xfasampleform.pdf") ' Get the main subform. Dim mainSubform As XFASubform = doc.XFAForm.Subforms(0).Subforms(0) ' Fill the product name. mainSubform.Fields("txtName").Value = "PDF4NET" ' Fill the product SKU. mainSubform.Fields("txtSKU").Value = "PDF4NET01090" ' Fill the product URL. mainSubform.Fields("txtURL").Value = "http://www.o2sol.com/pdf4net/products.htm" ' Select the product category. mainSubform.Fields("ddlCategory").Value = "PDF" ' Also add a new item to Category drop down list. Dim listItem As New XFAListItem("Compression", "CMP") CType(mainSubform.Fields("ddlCategory"), XFAChoiceListField).Items.Add(listItem) ' Fill the product image. mainSubform.Fields("imgProduct").Value = "..\SupportFiles\pdf4net.jpg" CType(mainSubform.Fields("imgProduct"), XFAImageEditField).ContentType = "image/jpg" ' Fill the product short description. mainSubform.Fields("txtShortDescription").Value = "PDF4NET is a .NET library for adding " + "PDF capabilities to .NET applications. It supports both desktop and web applications." ' Fill the product features. mainSubform.Fields("txtFeature1").Value = "Create PDF files from scratch." mainSubform.Fields("txtFeature2").Value = "Merge, split and encrypt PDF files." mainSubform.Fields("txtFeature3").Value = "Create, fill and flatten PDF e-forms." mainSubform.Fields("txtFeature4").Value = "Fill XFA forms." mainSubform.Fields("txtFeature5").Value = "Add, edit and remove document attachments." mainSubform.Fields("txtFeature6").Value = "Add, edit and remove text annotations." mainSubform.Fields("txtFeature7").Value = "Support for WinForms and ASP.NET applications." ' Fill the product long description. mainSubform.Fields("txtLongDescription").Value = "PDF4NET is a .NET library for adding " + "PDF capabilities to .NET applications. Version 2.7 brings support for PDF e-form " + "creation, support for reading and filling static XFA forms and document attachments. " + "It supports both desktop and web applications." ' Save the document to disk doc.Save("Sample_XfaSampleForm_Fill.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Form XObjects
This sample demonstrates the support for PDF form XObjects implemented in PDF4NET library. Form XObjects are graphic blocks that can be drawn multiple times in a PDF document and their content is stored only once in the PDF file.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormXObject.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Actions; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.FormXObject { /// <summary> /// This sample shows how to use form XObjects with PDF4NET. /// </summary> class FormXObject { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument doc = new PDFDocument(); // Create one page PDFPage page = doc.AddPage(); PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1); PDFBrush darkBlueBrush = new PDFBrush(new PDFRgbColor(0, 0, 128)); // create a form XObject for stretched text PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16); string pdf4net = "PDF4NET"; // the size of form xobject matches the text PDFFormXObject form = new PDFFormXObject(); form.Width = font.MeasureString(pdf4net); form.Height = 16; // draw the text on the form xobject form.Canvas.DrawText(pdf4net, font, null, darkBlueBrush, 0, 0); // draw the form xobject on the page. // strectch it to cover the whole page header and on the left margin page.Canvas.DrawFormXObject(form, 0, 0, page.Width, 24); page.Canvas.DrawFormXObject(form, 32, 0, page.Height, 32, -90); // create another for xobject that is more complex PDFFormXObject form2 = new PDFFormXObject(); form2.Width = 100; form2.Height = 100; // create the form content // draw an image form2.Canvas.DrawImage("..\\SupportFiles\\target.gif", 0, 0, 50, 50); // draw a round rectangle filled with a hatched brush PDFHatchBrush hb = new PDFHatchBrush(PDFHatchType.DiagonalCross); hb.HatchForeColor = new PDFRgbColor(Color.CornflowerBlue); form2.Canvas.DrawRoundRectangle(redPen, hb, 50, 0, 50, 50, 20, 20); // draw a square with vertical gradient filling PDFVerticalGradientBrush vgb = new PDFVerticalGradientBrush(); vgb.StartColor = new PDFRgbColor(Color.Crimson); vgb.EndColor = new PDFRgbColor(Color.GreenYellow); form2.Canvas.DrawRectangle(redPen, vgb, 0, 50, 50, 50); // draw a square with horizontal gradient filling PDFHorizontalGradientBrush hgb = new PDFHorizontalGradientBrush(); hgb.StartColor = new PDFRgbColor(Color.CornflowerBlue); hgb.EndColor = new PDFRgbColor(Color.Chartreuse); form2.Canvas.DrawRectangle(redPen, hgb, 50, 50, 50, 50); // draw text PDFFont font2 = new PDFFont(PDFFontFace.Helvetica, 20); font2.Bold = true; form2.Canvas.DrawText(pdf4net, font2, null, darkBlueBrush, 50, 50, 0, PDFTextAlign.MiddleCenter); // draw the form xobject on the page. // no stretch page.Canvas.DrawFormXObject(form2, 100, 50, form2.Width, form2.Height); // stretch 200% page.Canvas.DrawFormXObject(form2, 100, 50 + form2.Height, 2 * form2.Width, 2 * form2.Height); // stretch 400% page.Canvas.DrawFormXObject(form2, 100, 50 + form2.Height + 2 * form2.Height, 4 * form2.Width, 4 * form2.Height); // Save the document to disk doc.Save("Sample_FormXObject.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


FormXObject.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Actions Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.FormXObject ''' <summary> ''' This sample shows how to use form XObjects with PDF4NET. ''' </summary> Class FormXObject ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument() ' Create one page Dim page As PDFPage = doc.AddPage() Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1) Dim darkBlueBrush As New PDFBrush(New PDFRgbColor(0, 0, 128)) ' create a form XObject for stretched text Dim font As New PDFFont(PDFFontFace.Helvetica, 16) Dim pdf4net As String = "PDF4NET" ' the size of form xobject matches the text Dim form As New PDFFormXObject() form.Width = font.MeasureString(pdf4net) form.Height = 16 ' draw the text on the form xobject form.Canvas.DrawText(pdf4net, font, Nothing, darkBlueBrush, 0, 0) ' draw the form xobject on the page. ' strectch it to cover the whole page header and on the left margin page.Canvas.DrawFormXObject(form, 0, 0, page.Width, 24) page.Canvas.DrawFormXObject(form, 32, 0, page.Height, 32, -90) ' create another for xobject that is more complex Dim form2 As New PDFFormXObject() form2.Width = 100 form2.Height = 100 ' create the form content ' draw an image form2.Canvas.DrawImage("..\SupportFiles\target.gif", 0, 0, 50, 50) ' draw a round rectangle filled with a hatched brush Dim hb As New PDFHatchBrush(PDFHatchType.DiagonalCross) hb.HatchForeColor = New PDFRgbColor(Color.CornflowerBlue) form2.Canvas.DrawRoundRectangle(redPen, hb, 50, 0, 50, 50, 20, 20) ' draw a square with vertical gradient filling Dim vgb As New PDFVerticalGradientBrush() vgb.StartColor = New PDFRgbColor(Color.Crimson) vgb.EndColor = New PDFRgbColor(Color.GreenYellow) form2.Canvas.DrawRectangle(redPen, vgb, 0, 50, 50, 50) ' draw a square with horizontal gradient filling Dim hgb As New PDFHorizontalGradientBrush() hgb.StartColor = New PDFRgbColor(Color.CornflowerBlue) hgb.EndColor = New PDFRgbColor(Color.Chartreuse) form2.Canvas.DrawRectangle(redPen, hgb, 50, 50, 50, 50) ' draw text Dim font2 As New PDFFont(PDFFontFace.Helvetica, 20) font2.Bold = True form2.Canvas.DrawText(pdf4net, font2, Nothing, darkBlueBrush, 50, 50, _ 0, PDFTextAlign.MiddleCenter) ' draw the form xobject on the page. ' no stretch page.Canvas.DrawFormXObject(form2, 100, 50, form2.Width, form2.Height) ' stretch 200% page.Canvas.DrawFormXObject(form2, 100, 50 + form2.Height, 2 * form2.Width, 2 * form2.Height) ' stretch 400% page.Canvas.DrawFormXObject(form2, 100, 50 + form2.Height + 2 * form2.Height, 4 * form2.Width, 4 * form2.Height) ' Save the document to disk doc.Save("Sample_FormXObject.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: GroupingGrid
This sample shows how to draw a complex report with grouping capabilites. It loads the data from an XML file, then draws the lines of the report. The lines of the report are grouped by client id. Each time a new group starts, a group header is drawn, and each time a group ends a group footer is drawn. This sample uses customerorders.xml file found in \bin folder.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


GroupingGrid.cs
using System; using System.Drawing; using System.Data; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.GroupingGrid { /// <summary> /// This sample will show how to draw a complex report /// with groping using content from a database/xml file. /// </summary> class GroupingGrid { private static float leftMargin = 15; private static float rightMargin = 15; private static float topMargin = 20; private static float minBottomMargin = 20; private static float rowHeight = 20; private static float groupHeaderHeight = 20; private static float groupFooterHeight = 20; private static float headerHeight = 30; private static float firstPageTopOffset = 50; private static float[] columnsWidth = { 50, 80, 80, 170, 222, 100, 60 }; private static string[] columnsHeader = { "Order ID", "Order date", "Shipped date", "Ship to", "Address", "City", "Country" }; /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the graphic objects PDFFont fontTitle = new PDFFont(PDFFontFace.Helvetica, 20); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Set the document to be Landscape oriented pdfDoc.PageOrientation = PDFPageOrientation.Landscape; // Create first page of the report PDFPage page = pdfDoc.AddPage(); // Draw the title of the report page.Canvas.DrawText("Orders for customers", fontTitle, null, blackBrush, page.Width / 2, 15, 0, PDFTextAlign.TopCenter); // Draw report header DrawReportHeader(page, firstPageTopOffset); // Create the dataset DataSet ds = new DataSet(); // Load the dataset ds.ReadXml("..\\SupportFiles\\customerorders.xml", XmlReadMode.ReadSchema); // Get the table from the dataset DataTable co = ds.Tables[0]; // rowOffset - specifies the vertical position where a row // should begin to be printed float rowOffset = firstPageTopOffset + headerHeight; // initial customer code string customerID = ""; int ordersCount = 0; // draw the rows in the dataset for (int i = 0; i < co.Rows.Count; i++) { // new customer, we need to draw the group header if (customerID != co.Rows[i][0].ToString()) { if (customerID != "") { // draw the footer for the previous group if (rowOffset + groupFooterHeight > page.Height - minBottomMargin) { // not enough space to draw the footer // create a new page page = pdfDoc.AddPage(); // draw the report header DrawReportHeader(page, topMargin); // adjust the position for next prints rowOffset = topMargin + headerHeight; } // draw the group header DrawGroupFooter(page, rowOffset, customerID, ordersCount); // Adjust the position of the next row rowOffset = rowOffset + groupFooterHeight; } // do we has enough space to draw the group header and at least one row? if (rowOffset + groupHeaderHeight + rowHeight > page.Height - minBottomMargin) { // not enough // create a new page page = pdfDoc.AddPage(); // draw the report header DrawReportHeader(page, topMargin); // adjust the position of next rows rowOffset = topMargin + headerHeight; } // draw the group header DrawGroupHeader(page, rowOffset, co.Rows[i]); // Adjust the position of the next row rowOffset = rowOffset + groupHeaderHeight; customerID = co.Rows[i][0].ToString(); // reset customer's orders count ordersCount = 0; } if (rowOffset + rowHeight > page.Height - minBottomMargin) { // not enough space to draw a new row, then create a new page, // draw the header, then draw the rows. page = pdfDoc.AddPage(); DrawReportHeader(page, topMargin); rowOffset = topMargin + headerHeight; } DrawReportRow(page, rowOffset, co.Rows[i]); rowOffset = rowOffset + rowHeight; ordersCount++; } // Save the document to disk pdfDoc.Save("Sample_GroupingGrid.pdf"); } private static void DrawReportHeader(PDFPage pdfPage, float topOffset) { // Create the graphic objects PDFFont fontHeader = new PDFFont(PDFFontFace.Helvetica, 12); fontHeader.Bold = true; PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1); PDFBrush textColor = new PDFBrush(new PDFRgbColor()); PDFBrush headerFill = new PDFBrush(new PDFRgbColor(192, 192, 192)); // Draw the header pdfPage.Canvas.DrawRectangle(borderColor, headerFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, headerHeight); int i; float xOffset = leftMargin; // Draw the columns separators for (i = 0; i < columnsWidth.Length - 1; i++) { xOffset = xOffset + columnsWidth[i]; pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + headerHeight); } xOffset = leftMargin; // Draw the columns header for (i = 0; i < columnsWidth.Length; i++) { pdfPage.Canvas.DrawText(columnsHeader[i], fontHeader, null, textColor, xOffset + columnsWidth[i] / 2, topOffset + headerHeight / 2, 0, PDFTextAlign.MiddleCenter); xOffset = xOffset + columnsWidth[i]; } } private static void DrawReportRow(PDFPage pdfPage, float topOffset, DataRow row) { // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 10); PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1); PDFBrush textColor = new PDFBrush(new PDFRgbColor()); PDFBrush headerFill = new PDFBrush(new PDFRgbColor(192, 192, 192)); // Draw rows borders PointF[] points = { new PointF( leftMargin, topOffset ), new PointF( leftMargin, topOffset + rowHeight), new PointF( (float)pdfPage.Width - rightMargin, topOffset + rowHeight ), new PointF( (float)pdfPage.Width - rightMargin, topOffset )}; pdfPage.Canvas.DrawLines(borderColor, points); int i; float xOffset = leftMargin; // Draw the columns separators for (i = 0; i < columnsWidth.Length - 1; i++) { xOffset = xOffset + columnsWidth[i]; pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + rowHeight); } xOffset = leftMargin; // Draw the columns values // Order id pdfPage.Canvas.DrawText(row[2].ToString(), fontText, null, textColor, xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft); xOffset = xOffset + columnsWidth[0]; // Order date DateTime date; if (row[3] != System.DBNull.Value) { date = (DateTime)row[3]; pdfPage.Canvas.DrawText(date.ToString("MM/dd/yyyy"), fontText, null, textColor, xOffset + columnsWidth[1] / 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleCenter); } xOffset = xOffset + columnsWidth[1]; // Shipped date if (row[4] != System.DBNull.Value) { date = (DateTime)row[4]; pdfPage.Canvas.DrawText(date.ToString("MM/dd/yyyy"), fontText, null, textColor, xOffset + columnsWidth[2] / 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleCenter); } xOffset = xOffset + columnsWidth[2]; // Ship to pdfPage.Canvas.DrawText(row[5].ToString(), fontText, null, textColor, xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft); xOffset = xOffset + columnsWidth[3]; // Address pdfPage.Canvas.DrawText(row[6].ToString(), fontText, null, textColor, xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft); xOffset = xOffset + columnsWidth[4]; // City pdfPage.Canvas.DrawText(row[7].ToString(), fontText, null, textColor, xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft); xOffset = xOffset + columnsWidth[5]; // Country pdfPage.Canvas.DrawText(row[8].ToString(), fontText, null, textColor, xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft); xOffset = xOffset + columnsWidth[6]; } private static void DrawGroupHeader(PDFPage pdfPage, float topOffset, DataRow row) { // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1); PDFBrush textColor = new PDFBrush(new PDFRgbColor()); PDFBrush groupFill = new PDFBrush(new PDFRgbColor(192, 192, 192)); // Draw group header pdfPage.Canvas.DrawRectangle(borderColor, groupFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, groupHeaderHeight); // Draw the content of the header pdfPage.Canvas.DrawText("Customer ID: " + row[0].ToString() + " / Company name: " + row[1].ToString(), fontText, null, textColor, leftMargin + 2, topOffset + groupHeaderHeight / 2, 0, PDFTextAlign.MiddleLeft); } private static void DrawGroupFooter(PDFPage pdfPage, float topOffset, string customerID, int totalOrders) { // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1); PDFBrush textColor = new PDFBrush(new PDFRgbColor()); PDFBrush groupFill = new PDFBrush(new PDFRgbColor(192, 192, 192)); // Draw group header pdfPage.Canvas.DrawRectangle(borderColor, groupFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, groupFooterHeight); // Draw the content of the header pdfPage.Canvas.DrawText("Total number of orders for customer " + customerID + " is " + totalOrders.ToString(), fontText, null, textColor, leftMargin + 2, topOffset + groupFooterHeight / 2, 0, PDFTextAlign.MiddleLeft); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


GroupingGrid.vb
Imports System Imports System.Drawing Imports System.Data Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.GroupingGrid ''' <summary> ''' This sample will show how to draw a complex report ''' with groping using content from a database/xml file. ''' </summary> Class GroupingGrid Private Shared leftMargin As Single = 15 Private Shared rightMargin As Single = 15 Private Shared topMargin As Single = 20 Private Shared minBottomMargin As Single = 20 Private Shared rowHeight As Single = 20 Private Shared groupHeaderHeight As Single = 20 Private Shared groupFooterHeight As Single = 20 Private Shared headerHeight As Single = 30 Private Shared firstPageTopOffset As Single = 50 Private Shared columnsWidth As Single() = {50, 80, 80, 170, 222, 100, _ 60} Private Shared columnsHeader As String() = {"Order ID", "Order date", "Shipped date", "Ship to", "Address", "City", _ "Country"} ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the graphic objects Dim fontTitle As New PDFFont(PDFFontFace.Helvetica, 20) Dim blackBrush As New PDFBrush(New PDFRgbColor()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Set the document to be Landscape oriented pdfDoc.PageOrientation = PDFPageOrientation.Landscape ' Create first page of the report Dim page As PDFPage = pdfDoc.AddPage() ' Draw the title of the report page.Canvas.DrawText("Orders for customers", fontTitle, Nothing, blackBrush, page.Width / 2, 15, _ 0, PDFTextAlign.TopCenter) ' Draw report header DrawReportHeader(page, firstPageTopOffset) ' Create the dataset Dim ds As New DataSet() ' Load the dataset ds.ReadXml("..\SupportFiles\customerorders.xml", XmlReadMode.ReadSchema) ' Get the table from the dataset Dim co As DataTable = ds.Tables(0) ' rowOffset - specifies the vertical position where a row ' should begin to be printed Dim rowOffset As Single = firstPageTopOffset + headerHeight ' initial customer code Dim customerID As String = "" Dim ordersCount As Integer = 0 ' draw the rows in the dataset Dim i As Integer = 0 While i < co.Rows.Count ' new customer, we need to draw the group header If customerID <> co.Rows(i)(0).ToString() Then If customerID <> "" Then ' draw the footer for the previous group If rowOffset + groupFooterHeight > page.Height - minBottomMargin Then ' not enough space to draw the footer ' create a new page page = pdfDoc.AddPage() ' draw the report header DrawReportHeader(page, topMargin) ' adjust the position for next prints rowOffset = topMargin + headerHeight End If ' draw the group header DrawGroupFooter(page, rowOffset, customerID, ordersCount) ' Adjust the position of the next row rowOffset = rowOffset + groupFooterHeight End If ' do we has enough space to draw the group header and at least one row? If rowOffset + groupHeaderHeight + rowHeight > page.Height - minBottomMargin Then ' not enough ' create a new page page = pdfDoc.AddPage() ' draw the report header DrawReportHeader(page, topMargin) ' adjust the position of next rows rowOffset = topMargin + headerHeight End If ' draw the group header DrawGroupHeader(page, rowOffset, co.Rows(i)) ' Adjust the position of the next row rowOffset = rowOffset + groupHeaderHeight customerID = co.Rows(i)(0).ToString() ' reset customer's orders count ordersCount = 0 End If If rowOffset + rowHeight > page.Height - minBottomMargin Then ' not enough space to draw a new row, then create a new page, ' draw the header, then draw the rows. page = pdfDoc.AddPage() DrawReportHeader(page, topMargin) rowOffset = topMargin + headerHeight End If DrawReportRow(page, rowOffset, co.Rows(i)) rowOffset = rowOffset + rowHeight ordersCount = ordersCount + 1 i = i + 1 End While ' Save the document to disk pdfDoc.Save("Sample_GroupingGrid.pdf") End Sub Private Shared Sub DrawReportHeader(pdfPage As PDFPage, topOffset As Single) ' Create the graphic objects Dim fontHeader As New PDFFont(PDFFontFace.Helvetica, 12) fontHeader.Bold = True Dim borderColor As New PDFPen(New PDFRgbColor(), 1) Dim textColor As New PDFBrush(New PDFRgbColor()) Dim headerFill As New PDFBrush(New PDFRgbColor(192, 192, 192)) ' Draw the header pdfPage.Canvas.DrawRectangle(borderColor, headerFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, headerHeight) Dim i As Integer Dim xOffset As Single = leftMargin ' Draw the columns separators i = 0 While i < columnsWidth.Length - 1 xOffset = xOffset + columnsWidth(i) pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + headerHeight) i = i + 1 End While xOffset = leftMargin ' Draw the columns header i = 0 While i < columnsWidth.Length pdfPage.Canvas.DrawText(columnsHeader(i), fontHeader, Nothing, textColor, xOffset + columnsWidth(i) / 2, topOffset + headerHeight / 2, _ 0, PDFTextAlign.MiddleCenter) xOffset = xOffset + columnsWidth(i) i = i + 1 End While End Sub Private Shared Sub DrawReportRow(pdfPage As PDFPage, topOffset As Single, row As DataRow) ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 10) Dim borderColor As New PDFPen(New PDFRgbColor(), 1) Dim textColor As New PDFBrush(New PDFRgbColor()) Dim headerFill As New PDFBrush(New PDFRgbColor(192, 192, 192)) ' Draw rows borders Dim points As PointF() = {New PointF(leftMargin, topOffset), _ New PointF(leftMargin, topOffset + rowHeight), _ New PointF(pdfPage.Width - rightMargin, topOffset + rowHeight), _ New PointF(pdfPage.Width - rightMargin, topOffset)} pdfPage.Canvas.DrawLines(borderColor, points) Dim i As Integer Dim xOffset As Single = leftMargin ' Draw the columns separators i = 0 While i < columnsWidth.Length - 1 xOffset = xOffset + columnsWidth(i) pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + rowHeight) i = i + 1 End While xOffset = leftMargin ' Draw the columns values ' Order id pdfPage.Canvas.DrawText(row(2).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _ 0, PDFTextAlign.MiddleLeft) xOffset = xOffset + columnsWidth(0) ' Order date Dim [date] As DateTime If Not (row(3) Is System.DBNull.Value) Then [date] = DirectCast(row(3), DateTime) pdfPage.Canvas.DrawText([date].ToString("MM/dd/yyyy"), fontText, Nothing, textColor, xOffset + columnsWidth(1) / 2, topOffset + rowHeight / 2, _ 0, PDFTextAlign.MiddleCenter) End If xOffset = xOffset + columnsWidth(1) ' Shipped date If Not (row(4) Is System.DBNull.Value) Then [date] = DirectCast(row(4), DateTime) pdfPage.Canvas.DrawText([date].ToString("MM/dd/yyyy"), fontText, Nothing, textColor, xOffset + columnsWidth(2) / 2, topOffset + rowHeight / 2, _ 0, PDFTextAlign.MiddleCenter) End If xOffset = xOffset + columnsWidth(2) ' Ship to pdfPage.Canvas.DrawText(row(5).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _ 0, PDFTextAlign.MiddleLeft) xOffset = xOffset + columnsWidth(3) ' Address pdfPage.Canvas.DrawText(row(6).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _ 0, PDFTextAlign.MiddleLeft) xOffset = xOffset + columnsWidth(4) ' City pdfPage.Canvas.DrawText(row(7).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _ 0, PDFTextAlign.MiddleLeft) xOffset = xOffset + columnsWidth(5) ' Country pdfPage.Canvas.DrawText(row(8).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _ 0, PDFTextAlign.MiddleLeft) xOffset = xOffset + columnsWidth(6) End Sub Private Shared Sub DrawGroupHeader(pdfPage As PDFPage, topOffset As Single, row As DataRow) ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim borderColor As New PDFPen(New PDFRgbColor(), 1) Dim textColor As New PDFBrush(New PDFRgbColor()) Dim groupFill As New PDFBrush(New PDFRgbColor(192, 192, 192)) ' Draw group header pdfPage.Canvas.DrawRectangle(borderColor, groupFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, groupHeaderHeight) ' Draw the content of the header pdfPage.Canvas.DrawText("Customer ID: " + row(0).ToString() + " / Company name: " + row(1).ToString(), fontText, Nothing, textColor, leftMargin + 2, topOffset + groupHeaderHeight / 2, _ 0, PDFTextAlign.MiddleLeft) End Sub Private Shared Sub DrawGroupFooter(pdfPage As PDFPage, topOffset As Single, customerID As String, totalOrders As Integer) ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim borderColor As New PDFPen(New PDFRgbColor(), 1) Dim textColor As New PDFBrush(New PDFRgbColor()) Dim groupFill As New PDFBrush(New PDFRgbColor(192, 192, 192)) ' Draw group header pdfPage.Canvas.DrawRectangle(borderColor, groupFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, groupFooterHeight) ' Draw the content of the header pdfPage.Canvas.DrawText("Total number of orders for customer " + customerID + " is " + totalOrders.ToString(), _ fontText, Nothing, textColor, leftMargin + 2, topOffset + groupFooterHeight / 2, _ 0, PDFTextAlign.MiddleLeft) End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: HelloWorld
This sample is the simplest pdf file. It draws the string "Hello PDF World" in the center of the page. The text has a red border and it is filled with blue.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


HelloWorld.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET { /// <summary> /// The classic Hello world sample. /// </summary> class HelloPDFWorld { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create one page PDFPage pdfPage = pdfDoc.AddPage(); // Draw "Hello world" in the center of the page pdfPage.Canvas.DrawText("Hello PDF world!", new PDFFont(PDFFontFace.Helvetica, 100), new PDFPen(new PDFRgbColor(255, 0, 0), 1), new PDFBrush(new PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2, -60, PDFTextAlign.MiddleCenter); // Save the document to disk pdfDoc.Save("Sample_HelloPDFWorld.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


HelloWorld.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET ''' <summary> ''' The classic Hello world sample. ''' </summary> Class HelloPDFWorld ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create one page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Draw "Hello world" in the center of the page pdfPage.Canvas.DrawText("Hello PDF world!", _ New PDFFont(PDFFontFace.Helvetica, 100), _ New PDFPen(New PDFRgbColor(255, 0, 0), 1), _ New PDFBrush(New PDFRgbColor(0, 0, 255)), _ pdfPage.Width / 2, pdfPage.Height / 2, _ -60, PDFTextAlign.MiddleCenter) ' Save the document to disk pdfDoc.Save("Sample_HelloPDFWorld.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Images
This sample shows how to draw images on a page. It draws a normal image, then it draws another image that is rotated with 30 degrees around the top left corner.
The sample also demonstrates the image transparency capabilities in PDF4NET library. Color keys masking, image masks and alpha channel transparency are shown. This sample uses pdf4net.jpg, pdf4net.png and o2solutions.jpg images found in \bin folder.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Images.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Shapes.Transparency; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Images { /// <summary> /// This sample will show how to draw jpeg images on a page. /// </summary> class Images { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create first page PDFPage page = pdfDoc.AddPage(); // Draw a label page.Canvas.DrawText("Normal image", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); // Draw the image page.Canvas.DrawImage("..\\SupportFiles\\pdf4net.jpg", 20, 35, 467, 200, 0, PDFKeepAspectRatio.KeepWidth); // Draw the image page.Canvas.DrawImage("..\\SupportFiles\\pdf4net.jpg", 20, 250, 467, 200, 0, PDFKeepAspectRatio.KeepWidth); // Draw a label page.Canvas.DrawText("30 degrees rotated image", fontText, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft); // Draw the image page.Canvas.DrawImage("..\\SupportFiles\\o2solutions.jpg", 20, 435, 444, 126.85F, 30, PDFKeepAspectRatio.KeepWidth); // Create second page page = pdfDoc.AddPage(); // Draw a label page.Canvas.DrawText("Image with a transparent color", fontText, null, blackBrush, 20, 30, 0, PDFTextAlign.TopLeft); // create an image object PDFImage img = new PDFImage("..\\SupportFiles\\pdf4net.jpg"); // set the transparent color // even opaque images can be made transparent // the color image mask allows to set a range of colors as tranparent, not only one color img.Mask = new PDFColorImageMask(new PDFRgbColor(220, 220, 220), new PDFRgbColor(220, 220, 220)); // Draw the image page.Canvas.DrawImage(img, 20, 40, 467, 200, 0, PDFKeepAspectRatio.KeepBoth); // Draw a label page.Canvas.DrawText("Image with a mask, black color is transparent, white is opaque", fontText, null, blackBrush, 20, 250, 0, PDFTextAlign.TopLeft); // create another image object img = new PDFImage("..\\SupportFiles\\pdf4net.jpg"); // set an image mask for this image img.Mask = new PDFImageMask("..\\SupportFiles\\mask.bmp"); // Draw the image page.Canvas.DrawImage(img, 20, 260, 467, 200, 0, PDFKeepAspectRatio.KeepBoth); // Create third page page = pdfDoc.AddPage(); // Draw a label page.Canvas.DrawText("Image with alpha channel transparency (take a look at the rounded corners)", fontText, null, blackBrush, 20, 30, 0, PDFTextAlign.TopLeft); PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(Color.GreenYellow)); // Draw a green rectangle under the image to emphasize the alpha channel transparency page.Canvas.DrawRectangle(greenBrush, 45, 45, 510, 325); // create an image object PDFImage cc = new PDFImage("..\\SupportFiles\\pdf4net.png"); // Draw the image on green background page.Canvas.DrawImage(cc, 50, 50, 500, 200); PDFBrush redBrush = new PDFBrush(new PDFRgbColor(Color.RosyBrown)); // Draw a rosy rectangle under the image to emphasize the alpha channel transparency page.Canvas.DrawRectangle(redBrush, 45, 395, 510, 325); // Draw the image on rosy background page.Canvas.DrawImage(cc, 50, 400, 500, 200, 0, PDFKeepAspectRatio.KeepWidth); // Save the document to disk pdfDoc.Save("Sample_Images.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Images.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Shapes.Transparency Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Images ''' <summary> ''' This sample will show how to draw jpeg images on a page. ''' </summary> Class Images ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create first page Dim page As PDFPage = pdfDoc.AddPage() ' Draw a label page.Canvas.DrawText("Normal image", fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) ' Draw the image page.Canvas.DrawImage("..\SupportFiles\pdf4net.jpg", 20, 35, 467, 200, 0, _ PDFKeepAspectRatio.KeepWidth) ' Draw the image page.Canvas.DrawImage("..\SupportFiles\pdf4net.jpg", 20, 250, 467, 200, 0, _ PDFKeepAspectRatio.KeepWidth) ' Draw a label page.Canvas.DrawText("30 degrees rotated image", fontText, Nothing, blackBrush, 20, 300, _ 0, PDFTextAlign.TopLeft) ' Draw the image page.Canvas.DrawImage("..\SupportFiles\o2solutions.jpg", 20, 435, 444, 126.85F, 30, _ PDFKeepAspectRatio.KeepWidth) ' Create second page page = pdfDoc.AddPage() ' Draw a label page.Canvas.DrawText("Image with a transparent color", fontText, Nothing, blackBrush, 20, 30, _ 0, PDFTextAlign.TopLeft) ' create an image object Dim img As New PDFImage("..\SupportFiles\pdf4net.jpg") ' set the transparent color ' even opaque images can be made transparent ' the color image mask allows to set a range of colors as tranparent, not only one color img.Mask = New PDFColorImageMask(New PDFRgbColor(220, 220, 220), New PDFRgbColor(220, 220, 220)) ' Draw the image page.Canvas.DrawImage(img, 20, 40, 467, 200, 0, _ PDFKeepAspectRatio.KeepBoth) ' Draw a label page.Canvas.DrawText("Image with a mask, black color is transparent, white is opaque", fontText, Nothing, blackBrush, 20, 250, _ 0, PDFTextAlign.TopLeft) ' create another image object img = New PDFImage("..\SupportFiles\pdf4net.jpg") ' set an image mask for this image img.Mask = New PDFImageMask("..\SupportFiles\mask.bmp") ' Draw the image page.Canvas.DrawImage(img, 20, 260, 467, 200, 0, _ PDFKeepAspectRatio.KeepBoth) ' Create third page page = pdfDoc.AddPage() ' Draw a label page.Canvas.DrawText("Image with alpha channel transparency (take a look at the rounded corners)", fontText, Nothing, blackBrush, 20, 30, _ 0, PDFTextAlign.TopLeft) Dim greenBrush As New PDFBrush(New PDFRgbColor(Color.GreenYellow)) ' Draw a green rectangle under the image to emphasize the alpha channel transparency page.Canvas.DrawRectangle(greenBrush, 45, 45, 510, 325) ' create an image object Dim cc As New PDFImage("..\SupportFiles\pdf4net.png") ' Draw the image on green background page.Canvas.DrawImage(cc, 50, 50, 500, 200) Dim redBrush As New PDFBrush(New PDFRgbColor(Color.RosyBrown)) ' Draw a rosy rectangle under the image to emphasize the alpha channel transparency page.Canvas.DrawRectangle(redBrush, 45, 395, 510, 325) ' Draw the image on rosy background page.Canvas.DrawImage(cc, 50, 400, 500, 200, 0, _ PDFKeepAspectRatio.KeepWidth) ' Save the document to disk pdfDoc.Save("Sample_Images.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Layers
This sample demonstrates the support for layers in a PDF file implemented in PDF4NET library. Unlimited levels of layers and sublayers can be created. The layers are stacked on top of each other in the order they were created.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Layers.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Layers { /// <summary> /// The sample shows how to use layers in a PDF file. /// The PDF4NET library supports unlimited levels of nested layers. /// Each layers can be hidden or shown independently. Hidding a parent layer /// will hide all its child layers. Layers' content is always drawn on top of page content /// and they are drawn on top of each other in the order they have been added to the Layers collection. /// Page main content can not be hidden, it is always visible. /// </summary> class Layers { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument doc = new PDFDocument(); // Create one page PDFPage page = doc.AddPage(); PDFPen redPen = new PDFPen(new PDFRgbColor(192, 0, 0), 1); PDFBrush blueBrush = new PDFBrush(new PDFRgbColor(0, 0, 255)); PDFBrush darkBlueBrush = new PDFBrush(new PDFRgbColor(0, 0, 128)); // Draw "Hello world" in the center of the page // this text is always visible. page.Canvas.DrawText("Hello world !", new PDFFont(PDFFontFace.Helvetica, 100), redPen, blueBrush, page.Width / 2, page.Height / 2, 0, PDFTextAlign.MiddleCenter); // Create a parent layer PDFLayer squareLayer = page.Canvas.Layers.Add("Empty square"); // Create a poly polygon and draw it on the layer PDFPoint[][] polygons = new PDFPoint[2][]; polygons[0] = new PDFPoint[]{ new PDFPoint( 50, 100 ), new PDFPoint( 550, 100 ), new PDFPoint( 550, 600 ), new PDFPoint( 50, 600 ) }; polygons[1] = new PDFPoint[]{ new PDFPoint( 100, 150 ), new PDFPoint( 500, 150 ), new PDFPoint( 500, 550 ), new PDFPoint( 100, 550 ) }; squareLayer.Canvas.DrawPolyPolygon(redPen, darkBlueBrush, polygons, PDFFillMode.EvenOdd); // create 4 sublayers // 1. Hatched layer PDFLayer hatchedLayer = squareLayer.Canvas.Layers.Add("Hatched square"); // Create a hatch brush PDFHatchBrush hb = new PDFHatchBrush(PDFHatchType.DiagonalCross); hb.HatchForeColor = new PDFRgbColor(Color.Aquamarine); hb.HatchBackColor = new PDFRgbColor(Color.Azure); hatchedLayer.Canvas.DrawRectangle(redPen, hb, 100, 150, 200, 200); // 2. Vertical gradient layer PDFLayer verticalGradientLayer = squareLayer.Canvas.Layers.Add("Vertical gradient square"); // Create a vertical gradien brush PDFVerticalGradientBrush vgb = new PDFVerticalGradientBrush(); vgb.StartColor = new PDFRgbColor(Color.Aquamarine); vgb.EndColor = new PDFRgbColor(Color.Purple); verticalGradientLayer.Canvas.DrawRectangle(redPen, vgb, 300, 150, 200, 200); // 3. Horizontal gradient layer PDFLayer horizontalGradientLayer = squareLayer.Canvas.Layers.Add("Horizontal gradient square"); // Create a horizontal gradient brush PDFHorizontalGradientBrush hgb = new PDFHorizontalGradientBrush(); hgb.StartColor = new PDFRgbColor(Color.YellowGreen); hgb.EndColor = new PDFRgbColor(Color.Violet); horizontalGradientLayer.Canvas.DrawRectangle(redPen, hgb, 100, 350, 200, 200); // 4. Solid layer PDFLayer solidLayer = squareLayer.Canvas.Layers.Add("Solid square"); // Create a solid brush PDFBrush solidBrush = new PDFBrush(new PDFRgbColor(Color.CornflowerBlue)); solidLayer.Canvas.DrawRectangle(redPen, solidBrush, 300, 350, 200, 200); // create another layer on top of existing ones PDFLayer xLayer = page.Canvas.Layers.Add("Green X"); PDFPen greenPen = new PDFPen(new PDFRgbColor(Color.GreenYellow), 32); greenPen.LineCap = PDFLineCap.Round; xLayer.Canvas.DrawLine(greenPen, 50, 100, 550, 600); xLayer.Canvas.DrawLine(greenPen, 550, 100, 50, 600); // Save the document to disk doc.Save("Sample_Layers.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Layers.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Layers ''' <summary> ''' The sample shows how to use layers in a PDF file. ''' The PDF4NET library supports unlimited levels of nested layers. ''' Each layers can be hidden or shown independently. Hidding a parent layer ''' will hide all its child layers. Layers' content is always drawn on top of page content ''' and they are drawn on top of each other in the order they have been added to the Layers collection. ''' Page main content can not be hidden, it is always visible. ''' </summary> Class Layers ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument() ' Create one page Dim page As PDFPage = doc.AddPage() Dim redPen As New PDFPen(New PDFRgbColor(192, 0, 0), 1) Dim blueBrush As New PDFBrush(New PDFRgbColor(0, 0, 255)) Dim darkBlueBrush As New PDFBrush(New PDFRgbColor(0, 0, 128)) ' Draw "Hello world" in the center of the page ' this text is always visible. page.Canvas.DrawText("Hello world !", New PDFFont(PDFFontFace.Helvetica, 100), redPen, blueBrush, page.Width / 2, page.Height / 2, _ 0, PDFTextAlign.MiddleCenter) ' Create a parent layer Dim squareLayer As PDFLayer = page.Canvas.Layers.Add("Empty square") ' Create a poly polygon and draw it on the layer Dim polygons As PDFPoint()() = New PDFPoint(1)() {} polygons(0) = New PDFPoint() {New PDFPoint(50, 100), New PDFPoint(550, 100), New PDFPoint(550, 600), New PDFPoint(50, 600)} polygons(1) = New PDFPoint() {New PDFPoint(100, 150), New PDFPoint(500, 150), New PDFPoint(500, 550), New PDFPoint(100, 550)} squareLayer.Canvas.DrawPolyPolygon(redPen, darkBlueBrush, polygons, PDFFillMode.EvenOdd) ' create 4 sublayers ' 1. Hatched layer Dim hatchedLayer As PDFLayer = squareLayer.Canvas.Layers.Add("Hatched square") ' Create a hatch brush Dim hb As New PDFHatchBrush(PDFHatchType.DiagonalCross) hb.HatchForeColor = New PDFRgbColor(Color.Aquamarine) hb.HatchBackColor = New PDFRgbColor(Color.Azure) hatchedLayer.Canvas.DrawRectangle(redPen, hb, 100, 150, 200, 200) ' 2. Vertical gradient layer Dim verticalGradientLayer As PDFLayer = squareLayer.Canvas.Layers.Add("Vertical gradient square") ' Create a vertical gradien brush Dim vgb As New PDFVerticalGradientBrush() vgb.StartColor = New PDFRgbColor(Color.Aquamarine) vgb.EndColor = New PDFRgbColor(Color.Purple) verticalGradientLayer.Canvas.DrawRectangle(redPen, vgb, 300, 150, 200, 200) ' 3. Horizontal gradient layer Dim horizontalGradientLayer As PDFLayer = squareLayer.Canvas.Layers.Add("Horizontal gradient square") ' Create a horizontal gradient brush Dim hgb As New PDFHorizontalGradientBrush() hgb.StartColor = New PDFRgbColor(Color.YellowGreen) hgb.EndColor = New PDFRgbColor(Color.Violet) horizontalGradientLayer.Canvas.DrawRectangle(redPen, hgb, 100, 350, 200, 200) ' 4. Solid layer Dim solidLayer As PDFLayer = squareLayer.Canvas.Layers.Add("Solid square") ' Create a solid brush Dim solidBrush As New PDFBrush(New PDFRgbColor(Color.CornflowerBlue)) solidLayer.Canvas.DrawRectangle(redPen, solidBrush, 300, 350, 200, 200) ' create another layer on top of existing ones Dim xLayer As PDFLayer = page.Canvas.Layers.Add("Green X") Dim greenPen As New PDFPen(New PDFRgbColor(Color.GreenYellow), 32) greenPen.LineCap = PDFLineCap.Round xLayer.Canvas.DrawLine(greenPen, 50, 100, 550, 600) xLayer.Canvas.DrawLine(greenPen, 550, 100, 50, 600) ' Save the document to disk doc.Save("Sample_Layers.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Lines
This sample shows the lines drawing capabilities. On the first page it draws random positioned lines, the second page demonstrates the LineCap and LineJoin properties, and on the third page it draws a spiral using an array of consecutive line segments.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Lines.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Lines { /// <summary> /// This sample will show various types of lines. /// </summary> class Lines { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); DrawFirstPage(pdfDoc); DrawSecondPage(pdfDoc); DrawThirdPage(pdfDoc); // Save the document to disk pdfDoc.Save("Sample_Lines.pdf"); } private static void DrawFirstPage(PDFDocument pdfDoc) { // Create first page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); Random rnd = new Random(); for (int i = 0; i < 50; i++) { // Create random colors for drawing the spline PDFRgbColor penColor = new PDFRgbColor((byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256)); // Create the pen to draw the border PDFPen randomPen = new PDFPen(penColor, 1); // Generate random control points double x1 = rnd.Next((int)pdfPage.Width); double y1 = rnd.Next((int)pdfPage.Height); double x2 = rnd.Next((int)pdfPage.Width); double y2 = rnd.Next((int)pdfPage.Height); // Draw the line pdfPage.Canvas.DrawLine(randomPen, x1, y1, x2, y2); } // Draw a label pdfPage.Canvas.DrawText("Random lines", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); } private static void DrawSecondPage(PDFDocument pdfDoc) { // Create first page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 16); fontText.Bold = true; PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFPen thinPen = new PDFPen(new PDFRgbColor(), 1); // Draw the line caps // Flat line cap PDFPen thickFlatPen = new PDFPen(new PDFRgbColor(Color.Orange), 15); thickFlatPen.LineCap = PDFLineCap.Flat; pdfPage.Canvas.DrawText("Line cap: Flat", fontText, null, blackBrush, 20, 25, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLine(thickFlatPen, 200, 30, 400, 30); pdfPage.Canvas.DrawLine(thinPen, 200, 30, 400, 30); // Round line cap PDFPen thickRoundPen = new PDFPen(new PDFRgbColor(Color.Orange), 15); thickRoundPen.LineCap = PDFLineCap.Round; pdfPage.Canvas.DrawText("Line cap: Round", fontText, null, blackBrush, 20, 55, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLine(thickRoundPen, 200, 60, 400, 60); pdfPage.Canvas.DrawLine(thinPen, 200, 60, 400, 60); // Square line cap PDFPen thickSquarePen = new PDFPen(new PDFRgbColor(Color.Orange), 15); thickSquarePen.LineCap = PDFLineCap.Square; pdfPage.Canvas.DrawText("Line cap: Square", fontText, null, blackBrush, 20, 85, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLine(thickSquarePen, 200, 90, 400, 90); pdfPage.Canvas.DrawLine(thinPen, 200, 90, 400, 90); // Draw the line joins // Miter join PDFPoint[] pointsMiter = { new PDFPoint(200, 250), new PDFPoint(300, 150), new PDFPoint(400, 250) }; thickRoundPen.LineJoin = PDFLineJoin.Miter; pdfPage.Canvas.DrawText("Line join: Miter", fontText, null, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLines(thickRoundPen, pointsMiter); // Bevel join PDFPoint[] pointsBevel = { new PDFPoint(200, 350), new PDFPoint(300, 250), new PDFPoint(400, 350) }; PDFPen thickRoundBevelPen = new PDFPen(new PDFRgbColor(Color.Orange), 15); thickRoundBevelPen.LineCap = PDFLineCap.Round; thickRoundBevelPen.LineJoin = PDFLineJoin.Bevel; pdfPage.Canvas.DrawText("Line join: Bevel", fontText, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLines(thickRoundBevelPen, pointsBevel); // Round join PDFPoint[] pointsRound = { new PDFPoint(200, 450), new PDFPoint(300, 350), new PDFPoint(400, 450) }; PDFPen thickFlatRoundPen = new PDFPen(new PDFRgbColor(Color.Orange), 15); thickFlatRoundPen.LineCap = PDFLineCap.Round; thickFlatRoundPen.LineJoin = PDFLineJoin.Round; pdfPage.Canvas.DrawText("Line join: Round", fontText, null, blackBrush, 20, 400, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLines(thickFlatRoundPen, pointsRound); // Draw dash styles // Dash line style PDFPen dashPen = new PDFPen(new PDFRgbColor(Color.Orange), 1); dashPen.DashStyle = PDFDashStyle.Dash; pdfPage.Canvas.DrawText("Dash style: Dash", fontText, null, blackBrush, 20, 500, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLine(dashPen, 200, 505, 400, 505); // Dash dot line style PDFPen dashDotPen = new PDFPen(new PDFRgbColor(Color.Orange), 1); dashDotPen.DashStyle = PDFDashStyle.DashDot; pdfPage.Canvas.DrawText("Dash style: DashDot", fontText, null, blackBrush, 20, 530, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLine(dashDotPen, 200, 535, 400, 535); // Dash dot dot line style PDFPen dashDotDotPen = new PDFPen(new PDFRgbColor(Color.Orange), 1); dashDotDotPen.DashStyle = PDFDashStyle.DashDotDot; pdfPage.Canvas.DrawText("Dash style: DashDotDot", fontText, null, blackBrush, 20, 560, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLine(dashDotDotPen, 200, 565, 400, 565); // Dot line style PDFPen dotPen = new PDFPen(new PDFRgbColor(Color.Orange), 1); dotPen.DashStyle = PDFDashStyle.Dot; pdfPage.Canvas.DrawText("Dash style: Dot", fontText, null, blackBrush, 20, 590, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLine(dotPen, 200, 595, 400, 595); // Custom line style double[] dashPattern = { 20, 5, 10, 5, 5, 5 }; PDFPen customPen = new PDFPen(new PDFRgbColor(Color.Orange), 1); customPen.DashStyle = PDFDashStyle.Custom; customPen.DashPattern = dashPattern; pdfPage.Canvas.DrawText("Dash style: Custom", fontText, null, blackBrush, 20, 620, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawLine(customPen, 200, 625, 400, 625); } private static void DrawThirdPage(PDFDocument pdfDoc) { // Create first page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); // Draw a label pdfPage.Canvas.DrawText("Spiral lines", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); PDFPoint[] spiral = { new PDFPoint( 30, 30 ), new PDFPoint( 600, 30 ), new PDFPoint( 600, 700 ), new PDFPoint( 30, 700 ), new PDFPoint( 30, 60 ), new PDFPoint( 570, 60 ), new PDFPoint( 570, 670 ), new PDFPoint( 60, 670 ), new PDFPoint( 60, 90 ), new PDFPoint( 540, 90 ), new PDFPoint( 540, 640 ), new PDFPoint( 90, 640 ), new PDFPoint( 90, 120 ), new PDFPoint( 510, 120 ), new PDFPoint( 510, 610 ), new PDFPoint( 120, 610 ), new PDFPoint( 120, 150 ), new PDFPoint( 480, 150 ), new PDFPoint( 480, 580 ), new PDFPoint( 150, 580 ), new PDFPoint( 150, 180 ), new PDFPoint( 450, 180 ), new PDFPoint( 450, 550 ), new PDFPoint( 180, 550 ), new PDFPoint( 180, 210 ), new PDFPoint( 420, 210 ), new PDFPoint( 420, 520 ), new PDFPoint( 210, 520 ), new PDFPoint( 210, 240 ), new PDFPoint( 390, 240 ), new PDFPoint( 390, 490 ), new PDFPoint( 240, 490 ), new PDFPoint( 240, 270 ), new PDFPoint( 360, 270 ), new PDFPoint( 360, 460 ), new PDFPoint( 270, 460 ), new PDFPoint( 270, 300 ), new PDFPoint( 330, 300 ), new PDFPoint( 330, 430 ), new PDFPoint( 300, 430 ), new PDFPoint( 300, 330 ) }; Random rnd = new Random(); // Create random color for drawing the line PDFRgbColor penColor2 = new PDFRgbColor((byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256)); // Create the pen to draw the line PDFPen randomPen2 = new PDFPen(penColor2, 1); pdfPage.Canvas.DrawLines(randomPen2, spiral); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Lines.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Lines ''' <summary> ''' This sample will show various types of lines. ''' </summary> Class Lines ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() DrawFirstPage(pdfDoc) DrawSecondPage(pdfDoc) DrawThirdPage(pdfDoc) ' Save the document to disk pdfDoc.Save("Sample_Lines.pdf") End Sub Private Shared Sub DrawFirstPage(pdfDoc As PDFDocument) ' Create first page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim rnd As New Random() Dim i As Integer = 0 While i < 50 ' Create random colors for drawing the spline Dim penColor As New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256)) ' Create the pen to draw the border Dim randomPen As New PDFPen(penColor, 1) ' Generate random control points Dim x1 As Double = rnd.NextDouble() * pdfPage.Width Dim y1 As Double = rnd.NextDouble() * pdfPage.Height Dim x2 As Double = rnd.NextDouble() * pdfPage.Width Dim y2 As Double = rnd.NextDouble() * pdfPage.Height ' Draw the line pdfPage.Canvas.DrawLine(randomPen, x1, y1, x2, y2) i = i + 1 End While ' Draw a label pdfPage.Canvas.DrawText("Random lines", fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) End Sub Private Shared Sub DrawSecondPage(pdfDoc As PDFDocument) ' Create first page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 16) fontText.Bold = True Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim thinPen As New PDFPen(New PDFRgbColor(), 1) ' Draw the line caps ' Flat line cap Dim thickFlatPen As New PDFPen(New PDFRgbColor(Color.Orange), 15) thickFlatPen.LineCap = PDFLineCap.Flat pdfPage.Canvas.DrawText("Line cap: Flat", fontText, Nothing, blackBrush, 20, 25, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLine(thickFlatPen, 200, 30, 400, 30) pdfPage.Canvas.DrawLine(thinPen, 200, 30, 400, 30) ' Round line cap Dim thickRoundPen As New PDFPen(New PDFRgbColor(Color.Orange), 15) thickRoundPen.LineCap = PDFLineCap.Round pdfPage.Canvas.DrawText("Line cap: Round", fontText, Nothing, blackBrush, 20, 55, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLine(thickRoundPen, 200, 60, 400, 60) pdfPage.Canvas.DrawLine(thinPen, 200, 60, 400, 60) ' Square line cap Dim thickSquarePen As New PDFPen(New PDFRgbColor(Color.Orange), 15) thickSquarePen.LineCap = PDFLineCap.Square pdfPage.Canvas.DrawText("Line cap: Square", fontText, Nothing, blackBrush, 20, 85, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLine(thickSquarePen, 200, 90, 400, 90) pdfPage.Canvas.DrawLine(thinPen, 200, 90, 400, 90) ' Draw the line joins ' Miter join Dim pointsMiter As PDFPoint() = {New PDFPoint(200, 250), New PDFPoint(300, 150), New PDFPoint(400, 250)} thickRoundPen.LineJoin = PDFLineJoin.Miter pdfPage.Canvas.DrawText("Line join: Miter", fontText, Nothing, blackBrush, 20, 200, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLines(thickRoundPen, pointsMiter) ' Bevel join Dim pointsBevel As PDFPoint() = {New PDFPoint(200, 350), New PDFPoint(300, 250), New PDFPoint(400, 350)} Dim thickRoundBevelPen As New PDFPen(New PDFRgbColor(Color.Orange), 15) thickRoundBevelPen.LineCap = PDFLineCap.Round thickRoundBevelPen.LineJoin = PDFLineJoin.Bevel pdfPage.Canvas.DrawText("Line join: Bevel", fontText, Nothing, blackBrush, 20, 300, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLines(thickRoundBevelPen, pointsBevel) ' Round join Dim pointsRound As PDFPoint() = {New PDFPoint(200, 450), New PDFPoint(300, 350), New PDFPoint(400, 450)} Dim thickFlatRoundPen As New PDFPen(New PDFRgbColor(Color.Orange), 15) thickFlatRoundPen.LineCap = PDFLineCap.Round thickFlatRoundPen.LineJoin = PDFLineJoin.Round pdfPage.Canvas.DrawText("Line join: Round", fontText, Nothing, blackBrush, 20, 400, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLines(thickFlatRoundPen, pointsRound) ' Draw dash styles ' Dash line style Dim dashPen As New PDFPen(New PDFRgbColor(Color.Orange), 1) dashPen.DashStyle = PDFDashStyle.Dash pdfPage.Canvas.DrawText("Dash style: Dash", fontText, Nothing, blackBrush, 20, 500, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLine(dashPen, 200, 505, 400, 505) ' Dash dot line style Dim dashDotPen As New PDFPen(New PDFRgbColor(Color.Orange), 1) dashDotPen.DashStyle = PDFDashStyle.DashDot pdfPage.Canvas.DrawText("Dash style: DashDot", fontText, Nothing, blackBrush, 20, 530, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLine(dashDotPen, 200, 535, 400, 535) ' Dash dot dot line style Dim dashDotDotPen As New PDFPen(New PDFRgbColor(Color.Orange), 1) dashDotDotPen.DashStyle = PDFDashStyle.DashDotDot pdfPage.Canvas.DrawText("Dash style: DashDot", fontText, Nothing, blackBrush, 20, 560, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLine(dashDotDotPen, 200, 565, 400, 565) ' Dot line style Dim dotPen As New PDFPen(New PDFRgbColor(Color.Orange), 1) dotPen.DashStyle = PDFDashStyle.Dot pdfPage.Canvas.DrawText("Dash style: Dot", fontText, Nothing, blackBrush, 20, 590, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLine(dotPen, 200, 595, 400, 595) ' Custom line style Dim dashPattern As Double() = {20, 5, 10, 5, 5, 5} Dim customPen As New PDFPen(New PDFRgbColor(Color.Orange), 1) customPen.DashStyle = PDFDashStyle.[Custom] customPen.DashPattern = dashPattern pdfPage.Canvas.DrawText("Dash style: Custom", fontText, Nothing, blackBrush, 20, 620, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawLine(customPen, 200, 625, 400, 625) End Sub Private Shared Sub DrawThirdPage(pdfDoc As PDFDocument) ' Create first page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) ' Draw a label pdfPage.Canvas.DrawText("Spiral lines", fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) Dim spiral As PDFPoint() = {New PDFPoint(30, 30), New PDFPoint(600, 30), New PDFPoint(600, 700), New PDFPoint(30, 700), New PDFPoint(30, 60), New PDFPoint(570, 60), _ New PDFPoint(570, 670), New PDFPoint(60, 670), New PDFPoint(60, 90), New PDFPoint(540, 90), New PDFPoint(540, 640), New PDFPoint(90, 640), _ New PDFPoint(90, 120), New PDFPoint(510, 120), New PDFPoint(510, 610), New PDFPoint(120, 610), New PDFPoint(120, 150), New PDFPoint(480, 150), _ New PDFPoint(480, 580), New PDFPoint(150, 580), New PDFPoint(150, 180), New PDFPoint(450, 180), New PDFPoint(450, 550), New PDFPoint(180, 550), _ New PDFPoint(180, 210), New PDFPoint(420, 210), New PDFPoint(420, 520), New PDFPoint(210, 520), New PDFPoint(210, 240), New PDFPoint(390, 240), _ New PDFPoint(390, 490), New PDFPoint(240, 490), New PDFPoint(240, 270), New PDFPoint(360, 270), New PDFPoint(360, 460), New PDFPoint(270, 460), _ New PDFPoint(270, 300), New PDFPoint(330, 300), New PDFPoint(330, 430), New PDFPoint(300, 430), New PDFPoint(300, 330)} Dim rnd As New Random() ' Create random color for drawing the line Dim penColor2 As New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256)) ' Create the pen to draw the line Dim randomPen2 As New PDFPen(penColor2, 1) pdfPage.Canvas.DrawLines(randomPen2, spiral) End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Links
This sample shows how to create links in a page that point to other content. It shows all 4 types of links: internal links, external document links, file links and web links. For each type of link, an area link and a text link are created.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Links.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Actions; using O2S.Components.PDF4NET.Annotations; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Links { /// <summary> /// This sample will show how to create links to internal /// and external elements. /// </summary> class Links { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // The default page size is letter const int width = 612; const int height = 792; // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFFont fontTitle = new PDFFont(PDFFontFace.Helvetica, 72); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFPen blackPen = new PDFPen(new PDFRgbColor(), 1); // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Add 2 pages to the document PDFPage pdfPage1 = pdfDoc.AddPage(); PDFPage pdfPage2 = pdfDoc.AddPage(); // Create content for page1 pdfPage1.Canvas.DrawText("Rectangular area links", fontText, null, blackBrush, width / 4, 20, 0, PDFTextAlign.TopCenter); pdfPage1.Canvas.DrawText("Text links", fontText, null, blackBrush, 3 * width / 4, 20, 0, PDFTextAlign.TopCenter); pdfPage1.Canvas.DrawLine(blackPen, width / 2, 20, width / 2, height - 20); // Draw the rectangular links // Web link DrawAreaWebLink(pdfPage1, "http://www.o2sol.com/", 10, 30, width / 2 - 30, 150, new PDFRgbColor(0, 0, 255), 1); pdfPage1.Canvas.DrawText("web link", fontText, null, blackBrush, 15, 35, 0, PDFTextAlign.TopLeft); // File link DrawAreaFileLink(pdfPage1, "links.exe", 10, 200, width / 2 - 30, 150, new PDFRgbColor(255, 0, 0), 1); pdfPage1.Canvas.DrawText("file link", fontText, null, blackBrush, 15, 205, 0, PDFTextAlign.TopLeft); // External pdf document link DrawAreaRemoteDocLink(pdfPage1, "Sample_HelloPDFWorld.pdf", 10, 400, width / 2 - 30, 150, new PDFRgbColor(0, 255, 0), 1); pdfPage1.Canvas.DrawText("external pdf file link", fontText, null, blackBrush, 15, 405, 0, PDFTextAlign.TopLeft); // In document link DrawAreaDocLink(pdfPage1, pdfPage2, 10, 600, width / 2 - 30, 150, new PDFRgbColor(), 1); pdfPage1.Canvas.DrawText("in document link (click to go to next page)", fontText, null, blackBrush, 15, 605, 0, PDFTextAlign.TopLeft); // Draw the text links // Web link DrawTextWebLink(pdfPage1, "http://www.o2sol.com/", "Text web link", fontText, blackBrush, width / 2 + 30, 35, new PDFRgbColor(), 0); // File link DrawTextFileLink(pdfPage1, "links.exe", "Text file link", fontText, blackBrush, width / 2 + 30, 205, new PDFRgbColor(), 0); // External pdf document link DrawTextRemoteDocLink(pdfPage1, "Sample_HelloPDFWorld.pdf", "Text external pdf document link", fontText, blackBrush, width / 2 + 30, 405, new PDFRgbColor(), 0); // In document link DrawTextDocLink(pdfPage1, pdfPage2, "Text in document link (click to go to next page)", fontText, blackBrush, width / 2 + 30, 605, new PDFRgbColor(), 0); pdfPage2.Canvas.DrawText("This is page 2.", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); // Save the document to disk pdfDoc.Save("Sample_Links.pdf"); } private static PDFLinkAnnotation CreateLinkAnnotation(PDFPage page, double left, double top, double width, double height, PDFDeviceColor borderColor, double borderWidth) { PDFLinkAnnotation linkAnnotation = new PDFLinkAnnotation(); linkAnnotation.DisplayRectangle = new DisplayRectangle(left, top, width, height); linkAnnotation.Border = new PDFAnnotationBorder(borderWidth, PDFBorderStyle.Solid); linkAnnotation.Color = borderColor; page.Annotations.Add(linkAnnotation); return linkAnnotation; } private static void DrawAreaWebLink(PDFPage page, string url, double left, double top, double width, double height, PDFDeviceColor borderColor, double borderWidth) { PDFURIAction uriAction = new PDFURIAction(); uriAction.URI = url; PDFLinkAnnotation linkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, borderWidth); linkAnnotation.Action = uriAction; } private static void DrawAreaFileLink(PDFPage page, string fileName, double left, double top, double width, double height, PDFDeviceColor borderColor, double borderWidth) { PDFLaunchAction launchAction = new PDFLaunchAction(); launchAction.FileName = fileName; PDFLinkAnnotation linkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, borderWidth); linkAnnotation.Action = launchAction; } private static void DrawAreaRemoteDocLink(PDFPage page, string pdfFileName, double left, double top, double width, double height, PDFDeviceColor borderColor, double borderWidth) { PDFRemotePageDestination rpd = new PDFRemotePageDestination(); rpd.PageNumber = 0; PDFRemoteGoToAction remoteGoToAction = new PDFRemoteGoToAction(); remoteGoToAction.FileName = pdfFileName; remoteGoToAction.Destination = rpd; PDFLinkAnnotation linkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, borderWidth); linkAnnotation.Action = remoteGoToAction; } private static void DrawAreaDocLink(PDFPage page, PDFPage destinationPage, double left, double top, double width, double height, PDFDeviceColor borderColor, double borderWidth) { PDFPageDestination pd = new PDFPageDestination(); pd.Page = destinationPage; pd.MagnificationMode = PDFMagnificationMode.Fit; PDFGoToAction goToAction = new PDFGoToAction(); goToAction.Destination = pd; PDFLinkAnnotation linkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, borderWidth); linkAnnotation.Action = goToAction; } private static void DrawTextWebLink(PDFPage page, string url, string linkText, PDFFontBase font, PDFBrush brush, double left, double top, PDFDeviceColor borderColor, double borderWidth) { double width = font.MeasureString(linkText); double height = font.Size; page.Canvas.DrawText(linkText, font, brush, left, top); DrawAreaWebLink(page, url, left, top, width, height, borderColor, borderWidth); } private static void DrawTextFileLink(PDFPage page, string fileName, string linkText, PDFFontBase font, PDFBrush brush, double left, double top, PDFDeviceColor borderColor, double borderWidth) { double width = font.MeasureString(linkText); double height = font.Size; page.Canvas.DrawText(linkText, font, brush, left, top); DrawAreaFileLink(page, fileName, left, top, width, height, borderColor, borderWidth); } private static void DrawTextRemoteDocLink( PDFPage page, string pdfFileName, string linkText, PDFFontBase font, PDFBrush brush, double left, double top, PDFDeviceColor borderColor, double borderWidth) { double width = font.MeasureString(linkText); double height = font.Size; page.Canvas.DrawText(linkText, font, brush, left, top); DrawAreaRemoteDocLink(page, pdfFileName, left, top, width, height, borderColor, borderWidth); } private static void DrawTextDocLink( PDFPage page, PDFPage destinationPage, string linkText, PDFFontBase font, PDFBrush brush, double left, double top, PDFDeviceColor borderColor, double borderWidth) { double width = font.MeasureString(linkText); double height = font.Size; page.Canvas.DrawText(linkText, font, brush, left, top); DrawAreaDocLink(page, destinationPage, left, top, width, height, borderColor, borderWidth); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Links.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Actions Imports O2S.Components.PDF4NET.Annotations Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Links ''' <summary> ''' This sample will show how to create links to internal ''' and external elements. ''' </summary> Class Links ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' The default page size is letter Const width As Integer = 612 Const height As Integer = 792 ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim fontTitle As New PDFFont(PDFFontFace.Helvetica, 72) Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim blackPen As New PDFPen(New PDFRgbColor(), 1) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Add 2 pages to the document Dim pdfPage1 As PDFPage = pdfDoc.AddPage() Dim pdfPage2 As PDFPage = pdfDoc.AddPage() ' Create content for page1 pdfPage1.Canvas.DrawText("Rectangular area links", fontText, Nothing, blackBrush, width / 4, 20, _ 0, PDFTextAlign.TopCenter) pdfPage1.Canvas.DrawText("Text links", fontText, Nothing, blackBrush, 3 * width / 4, 20, _ 0, PDFTextAlign.TopCenter) pdfPage1.Canvas.DrawLine(blackPen, width / 2, 20, width / 2, height - 20) ' Draw the rectangular links ' Web link DrawAreaWebLink(pdfPage1, "http://www.o2sol.com/", 10, 30, width / 2 - 30, 150, _ New PDFRgbColor(0, 0, 255), 1) pdfPage1.Canvas.DrawText("web link", fontText, Nothing, blackBrush, 15, 35, _ 0, PDFTextAlign.TopLeft) ' File link DrawAreaFileLink(pdfPage1, "links.exe", 10, 200, width / 2 - 30, 150, _ New PDFRgbColor(255, 0, 0), 1) pdfPage1.Canvas.DrawText("file link", fontText, Nothing, blackBrush, 15, 205, _ 0, PDFTextAlign.TopLeft) ' External pdf document link DrawAreaRemoteDocLink(pdfPage1, "Sample_HelloPDFWorld.pdf", 10, 400, width / 2 - 30, 150, _ New PDFRgbColor(0, 255, 0), 1) pdfPage1.Canvas.DrawText("external pdf file link", fontText, Nothing, blackBrush, 15, 405, _ 0, PDFTextAlign.TopLeft) ' In document link DrawAreaDocLink(pdfPage1, pdfPage2, 10, 600, width / 2 - 30, 150, _ New PDFRgbColor(), 1) pdfPage1.Canvas.DrawText("in document link (click to go to next page)", fontText, Nothing, blackBrush, 15, 605, _ 0, PDFTextAlign.TopLeft) ' Draw the text links ' Web link DrawTextWebLink(pdfPage1, "http://www.o2sol.com/", "Text web link", fontText, blackBrush, width / 2 + 30, _ 35, New PDFRgbColor(), 0) ' File link DrawTextFileLink(pdfPage1, "links.exe", "Text file link", fontText, blackBrush, width / 2 + 30, _ 205, New PDFRgbColor(), 0) ' External pdf document link DrawTextRemoteDocLink(pdfPage1, "Sample_HelloPDFWorld.pdf", "Text external pdf document link", fontText, blackBrush, width / 2 + 30, _ 405, New PDFRgbColor(), 0) ' In document link DrawTextDocLink(pdfPage1, pdfPage2, "Text in document link (click to go to next page)", fontText, blackBrush, width / 2 + 30, _ 605, New PDFRgbColor(), 0) pdfPage2.Canvas.DrawText("This is page 2.", fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) ' Save the document to disk pdfDoc.Save("Sample_Links.pdf") End Sub Private Shared Function CreateLinkAnnotation(page As PDFPage, left As Double, top As Double, width As Double, height As Double, borderColor As PDFDeviceColor, _ borderWidth As Double) As PDFLinkAnnotation Dim linkAnnotation As New PDFLinkAnnotation() linkAnnotation.DisplayRectangle = New DisplayRectangle(left, top, width, height) linkAnnotation.Border = New PDFAnnotationBorder(borderWidth, PDFBorderStyle.Solid) linkAnnotation.Color = borderColor page.Annotations.Add(linkAnnotation) Return linkAnnotation End Function Private Shared Sub DrawAreaWebLink(page As PDFPage, url As String, left As Double, top As Double, width As Double, height As Double, _ borderColor As PDFDeviceColor, borderWidth As Double) Dim uriAction As New PDFURIAction() uriAction.URI = url Dim linkAnnotation As PDFLinkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, _ borderWidth) linkAnnotation.Action = uriAction End Sub Private Shared Sub DrawAreaFileLink(page As PDFPage, fileName As String, left As Double, top As Double, width As Double, height As Double, _ borderColor As PDFDeviceColor, borderWidth As Double) Dim launchAction As New PDFLaunchAction() launchAction.FileName = fileName Dim linkAnnotation As PDFLinkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, _ borderWidth) linkAnnotation.Action = launchAction End Sub Private Shared Sub DrawAreaRemoteDocLink(page As PDFPage, pdfFileName As String, left As Double, top As Double, width As Double, height As Double, _ borderColor As PDFDeviceColor, borderWidth As Double) Dim rpd As New PDFRemotePageDestination() rpd.PageNumber = 0 Dim remoteGoToAction As New PDFRemoteGoToAction() remoteGoToAction.FileName = pdfFileName remoteGoToAction.Destination = rpd Dim linkAnnotation As PDFLinkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, _ borderWidth) linkAnnotation.Action = remoteGoToAction End Sub Private Shared Sub DrawAreaDocLink(page As PDFPage, destinationPage As PDFPage, left As Double, top As Double, width As Double, height As Double, _ borderColor As PDFDeviceColor, borderWidth As Double) Dim pd As New PDFPageDestination() pd.Page = destinationPage pd.MagnificationMode = PDFMagnificationMode.Fit Dim goToAction As New PDFGoToAction() goToAction.Destination = pd Dim linkAnnotation As PDFLinkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, _ borderWidth) linkAnnotation.Action = goToAction End Sub Private Shared Sub DrawTextWebLink(page As PDFPage, url As String, linkText As String, font As PDFFontBase, brush As PDFBrush, left As Double, _ top As Double, borderColor As PDFDeviceColor, borderWidth As Double) Dim width As Double = font.MeasureString(linkText) Dim height As Double = font.Size page.Canvas.DrawText(linkText, font, brush, left, top) DrawAreaWebLink(page, url, left, top, width, height, _ borderColor, borderWidth) End Sub Private Shared Sub DrawTextFileLink(page As PDFPage, fileName As String, linkText As String, font As PDFFontBase, brush As PDFBrush, left As Double, _ top As Double, borderColor As PDFDeviceColor, borderWidth As Double) Dim width As Double = font.MeasureString(linkText) Dim height As Double = font.Size page.Canvas.DrawText(linkText, font, brush, left, top) DrawAreaFileLink(page, fileName, left, top, width, height, _ borderColor, borderWidth) End Sub Private Shared Sub DrawTextRemoteDocLink(page As PDFPage, pdfFileName As String, linkText As String, font As PDFFontBase, brush As PDFBrush, left As Double, _ top As Double, borderColor As PDFDeviceColor, borderWidth As Double) Dim width As Double = font.MeasureString(linkText) Dim height As Double = font.Size page.Canvas.DrawText(linkText, font, brush, left, top) DrawAreaRemoteDocLink(page, pdfFileName, left, top, width, height, _ borderColor, borderWidth) End Sub Private Shared Sub DrawTextDocLink(page As PDFPage, destinationPage As PDFPage, linkText As String, font As PDFFontBase, brush As PDFBrush, left As Double, _ top As Double, borderColor As PDFDeviceColor, borderWidth As Double) Dim width As Double = font.MeasureString(linkText) Dim height As Double = font.Size page.Canvas.DrawText(linkText, font, brush, left, top) DrawAreaDocLink(page, destinationPage, left, top, width, height, _ borderColor, borderWidth) End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Metafiles
This sample demonstrates the metafiles support implemented in PDF4NET library. Enhanced Windows Metafiles are converted to native PDF vector data when using PDFMetafile class. Metafiles can be scaled or rotated without losing their graphic quality.
Metafiles are stored as form XObjects to reduce the file size, and allowing the viewer to cache their graphic representation when the metafile is displayed multiple times in the same file.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Metafiles.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; namespace O2S.Samples.PDF4NET.Metafiles { /// <summary> /// This sample shows how to use metafiles in a PDF file. /// When using metafiles in this way, they are converted to PDF vector data /// thus keeping the graphic details, no matter the drawing size. If metafiles /// are used with DrawImage methods, they are converted to raster data thus resulting /// the stairs effect when zooming the PDF file.<br> /// The metafile data is stored only once in the PDF file /// and can be drawn multiple times. /// </summary> class Metafiles { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument doc = new PDFDocument(); // Create first page PDFPage page = doc.AddPage(); // Create a metafile object PDFMetafile mf = new PDFMetafile("..\\SupportFiles\\sample.emf"); page.Orientation = PDFPageOrientation.Landscape; page.Canvas.DrawFormXObject(mf, 10, 10, page.Width - 20, page.Height - 20); // Create second page page = doc.AddPage(); page.Orientation = PDFPageOrientation.Landscape; page.Canvas.DrawFormXObject(mf, 10, 10, page.Width / 2 - 20, page.Height / 2 - 20); page.Canvas.DrawFormXObject(mf, page.Width / 2 + 10, 10, page.Width / 2 - 20, page.Height / 2 - 20); page.Canvas.DrawFormXObject(mf, 10, page.Height / 2 + 10, page.Width / 2 - 20, page.Height / 2 - 20); page.Canvas.DrawFormXObject(mf, page.Width / 2 + 10, page.Height / 2 + 10, page.Width / 2 - 20, page.Height / 2 - 20); // Save the document to disk doc.Save("Sample_Metafiles.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Metafiles.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Namespace O2S.Samples.PDF4NET.Metafiles ''' <summary> ''' This sample shows how to use metafiles in a PDF file. ''' When using metafiles in this way, they are converted to PDF vector data ''' thus keeping the graphic details, no matter the drawing size. If metafiles ''' are used with DrawImage methods, they are converted to raster data thus resulting ''' the stairs effect when zooming the PDF file.<br> ''' The metafile data is stored only once in the PDF file ''' and can be drawn multiple times. ''' </summary> Class Metafiles ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument() ' Create first page Dim page As PDFPage = doc.AddPage() ' Create a metafile object Dim mf As New PDFMetafile("..\SupportFiles\sample.emf") page.Orientation = PDFPageOrientation.Landscape page.Canvas.DrawFormXObject(mf, 10, 10, page.Width - 20, page.Height - 20) ' Create second page page = doc.AddPage() page.Orientation = PDFPageOrientation.Landscape page.Canvas.DrawFormXObject(mf, 10, 10, page.Width / 2 - 20, page.Height / 2 - 20) page.Canvas.DrawFormXObject(mf, page.Width / 2 + 10, 10, page.Width / 2 - 20, page.Height / 2 - 20) page.Canvas.DrawFormXObject(mf, 10, page.Height / 2 + 10, page.Width / 2 - 20, page.Height / 2 - 20) page.Canvas.DrawFormXObject(mf, page.Width / 2 + 10, page.Height / 2 + 10, page.Width / 2 - 20, page.Height / 2 - 20) ' Save the document to disk doc.Save("Sample_Metafiles.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Multicolumn Text and Images
This sample shows how to draw columnar text that flows over multiple pages. It also demonstrates HTML formatting capabilities of PDF4NET library.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


MultiColumnTextAndImages.cs
using System; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.MultiColumnTextAndImages { /// <summary> /// Summary description for Class1. /// </summary> class MultiColumnTextAndImages { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { double leftMargin = 30; double topMargin = 30; double rightMargin = 30; double bottomMargin = 30; double columnSpace = 30; double columnCount = 2; double columnWidth = (612 - leftMargin - rightMargin - columnSpace) / 2;//612 - width of Letter size in points double columnHeight = 792 - topMargin - bottomMargin;//792 - height of Letter size in points PDFBrush blackBrush = new PDFBrush(new PDFRgbColor(0, 0, 0)); PDFFont font = new PDFFont(PDFFontFace.Helvetica, 12); string longText = "<font color='#0000F8'><b>PDF4NET</b></font> is a <u><i>.NET</i></u> " + "library for embedding pdf " + "documents creation in any <u><i>.NET</i></u> application. " + "The pdf files structure is " + "hidden behind a simple object model that allows the creation of " + "<u>complex pdf documents with a few lines of code</u>. The library uses " + "a grid-based approach for placing content on document's pages. " + "It allows random access to each page of the document, allowing " + "the developer to set the size and the orientation for each page. " + "The object model provides support for basic drawing primitives, " + "like lines, circles, rectangles, images, etc. " + "It also provides extensive support for drawing text, giving the " + "developer a large freedom in formatting and placing text on page. " + "<font face='TimesRoman'>The library also offers more advanced features, like: automatic page " + "numbering; page templates; creation of bookmarks tree; " + "creation of hyperlinks; transition effects between pages; support " + "for viewer preferences; support for document metadata, like author, " + "title, etc, allowing the document to be searched and indexed; custom " + "document properties; enhanced color support (RGB, CMYK, Grayscale); " + "Adobe XMP metadata storage; user defined logical units; user defined " + "coordinate system.</font><br/>" + "The resulting pdf documents can be saved to disk or HTTP streams. " + "The library compresses document's content, thus resulting smaller pdf files. " + "The <font color='#0000F8'><b>PDF4NET</b></font> library can be used both from windows and <i>ASP.NET</i> applications. " + "The library is 100% managed, being written in C#. " + "The <font color='#0000F8'><b>PDF4NET</b></font> library is <u>licensed " + "per developer</u> and can be " + "distributed <font color='#F80000'>royalty free</font>.<br/><br/>"; longText = longText + longText + longText + longText + longText + longText + longText + longText + longText + longText + longText + longText; // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); PDFTextFormatOptions tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.TopJustified; tfo.ClipText = PDFClipText.ClipWords; // length of text that fits in the column int columnTextLength; bool endOfText = false; int startIndex = 0; // start drawing text while (!endOfText) { // where to start to print the column double leftOffset = leftMargin; // Create a new page in the document PDFPage page = pdfDoc.AddPage(); int i = 0; // draw each column // each column will contain one random positioned image Random rnd = new Random(); while (i < columnCount) { #region Random Image Placement // index of the image to be displayed int imageIndex = 1 + rnd.Next(5); // set columnHeight for height, because we'll set KeepAspectRatio to // KeepWidth and the height will be automatically computed. PDFImage img = new PDFImage("..\\SupportFiles\\auto" + imageIndex.ToString() + ".jpg"); double imageHeight = img.Height * columnWidth / img.Width; // compute a random top position for the image so it fits full // in the column double imageTop = 30 + (columnHeight - topMargin - bottomMargin - imageHeight) * rnd.NextDouble(); // draw the image page.Canvas.DrawImage(img, leftOffset, imageTop, columnWidth, imageHeight); #endregion Random Image Placement #region Above Image Text // see how much text fits above the image // imageTop - topMargin = the height available above the image columnTextLength = page.Canvas.FitHtmlText(longText, startIndex, font, columnWidth, imageTop - topMargin); // draw text above image page.Canvas.DrawHTMLTextBox(longText, font, null, blackBrush, leftOffset, topMargin, columnWidth, imageTop - topMargin, tfo, startIndex); // move the index to the next fragment startIndex = startIndex + columnTextLength; if (startIndex >= longText.Length) { endOfText = true; break; } #endregion Above Image Text #region Below Image Text // see how much text fits below the image // columnHeight - ( topText - topMargin ) = available space below image double topText = Math.Ceiling((imageTop + imageHeight) / font.Size) * font.Size; columnTextLength = page.Canvas.FitHtmlText(longText, startIndex, font, columnWidth, columnHeight - (topText - topMargin)); // draw text below image page.Canvas.DrawHTMLTextBox(longText, font, null, blackBrush, leftOffset, topText, columnWidth, columnHeight - (topText - topMargin), tfo, startIndex); // move the index to the next fragment startIndex = startIndex + columnTextLength; if (startIndex >= longText.Length) { endOfText = true; break; } #endregion Below Image Text // compute the offset of the next column leftOffset = leftOffset + columnWidth + columnSpace; i++; } } // Save the document to disk pdfDoc.Save("Sample_MultiColumnTextAndImages.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


MultiColumnTextAndImages.vb
Imports System Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.MultiColumnTextAndImages ''' <summary> ''' Summary description for Class1. ''' </summary> Class MultiColumnTextAndImages ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) Dim leftMargin As Double = 30 Dim topMargin As Double = 30 Dim rightMargin As Double = 30 Dim bottomMargin As Double = 30 Dim columnSpace As Double = 30 Dim columnCount As Double = 2 Dim columnWidth As Double = (612 - leftMargin - rightMargin - columnSpace) / 2 '612 - width of Letter size in points Dim columnHeight As Double = 792 - topMargin - bottomMargin '792 - height of Letter size in points Dim blackBrush As New PDFBrush(New PDFRgbColor(0, 0, 0)) Dim font As New PDFFont(PDFFontFace.Helvetica, 12) Dim longText As String = "<font color='#0000F8'><b>PDF4NET</b></font> is a <u><i>.NET</i></u> " + _ "library for embedding pdf documents creation in any <u><i>.NET</i></u> application. " + _ "The pdf files structure is " + "hidden behind a simple object model that allows the creation of " + _ "<u>complex pdf documents with a few lines of code</u>. The library uses " + _ "a grid-based approach for placing content on document's pages. " + _ "It allows random access to each page of the document, allowing " + _ "the developer to set the size and the orientation for each page. " + _ "The object model provides support for basic drawing primitives, " + _ "like lines, circles, rectangles, images, etc. " + _ "It also provides extensive support for drawing text, giving the " + _ "developer a large freedom in formatting and placing text on page. " + _ "<font face='TimesRoman'>The library also offers more advanced features, like: automatic page " + _ "numbering; page templates; creation of bookmarks tree; " + _ "creation of hyperlinks; transition effects between pages; support " + _ "for viewer preferences; support for document metadata, like author, " + _ "title, etc, allowing the document to be searched and indexed; custom " + _ "document properties; enhanced color support (RGB, CMYK, Grayscale); " + _ "Adobe XMP metadata storage; user defined logical units; user defined " + _ "coordinate system.</font><br/>" + _ "The resulting pdf documents can be saved to disk or HTTP streams. " + _ "The library compresses document's content, thus resulting smaller pdf files. " + _ "The <font color='#0000F8'><b>PDF4NET</b></font> library can be used both from windows and <i>ASP.NET</i> applications. " + _ "The library is 100% managed, being written in C#. " + _ "The <font color='#0000F8'><b>PDF4NET</b></font> library is <u>licensed " + + "per developer</u> and can be " + "distributed <font color='#F80000'>royalty free</font>.<br/><br/>" longText = longText + longText + longText + longText + longText + longText + longText + longText + longText + longText + longText + longText ' Create the pdf document Dim pdfDoc As New PDFDocument() Dim tfo As New PDFTextFormatOptions() tfo.Align = PDFTextAlign.TopJustified tfo.ClipText = PDFClipText.ClipWords ' length of text that fits in the column Dim columnTextLength As Integer Dim endOfText As Boolean = False Dim startIndex As Integer = 0 ' start drawing text While Not endOfText ' where to start to print the column Dim leftOffset As Double = leftMargin ' Create a new page in the document Dim page As PDFPage = pdfDoc.AddPage() Dim i As Integer = 0 ' draw each column ' each column will contain one random positioned image Dim rnd As New Random() While i < columnCount ' index of the image to be displayed Dim imageIndex As Integer = 1 + rnd.[Next](5) ' set columnHeight for height, because we'll set KeepAspectRatio to ' KeepWidth and the height will be automatically computed. Dim img As New PDFImage("..\SupportFiles\auto" + imageIndex.ToString() + ".jpg") Dim imageHeight As Double = img.Height * columnWidth / img.Width ' compute a random top position for the image so it fits full ' in the column Dim imageTop As Double = 30 + (columnHeight - topMargin - bottomMargin - imageHeight) * rnd.NextDouble() ' draw the image page.Canvas.DrawImage(img, leftOffset, imageTop, columnWidth, imageHeight) ' see how much text fits above the image ' imageTop - topMargin = the height available above the image columnTextLength = page.Canvas.FitHtmlText(longText, startIndex, font, columnWidth, imageTop - topMargin) ' draw text above image page.Canvas.DrawHTMLTextBox(longText, font, Nothing, blackBrush, leftOffset, topMargin, _ columnWidth, imageTop - topMargin, tfo, startIndex) ' move the index to the next fragment startIndex = startIndex + columnTextLength If startIndex >= longText.Length Then endOfText = True Exit While End If ' see how much text fits below the image ' columnHeight - ( topText - topMargin ) = available space below image Dim topText As Double = Math.Ceiling((imageTop + imageHeight) / font.Size) * font.Size columnTextLength = page.Canvas.FitHtmlText(longText, startIndex, font, columnWidth, columnHeight - (topText - topMargin)) ' draw text below image page.Canvas.DrawHTMLTextBox(longText, font, Nothing, blackBrush, leftOffset, topText, _ columnWidth, columnHeight - (topText - topMargin), tfo, startIndex) ' move the index to the next fragment startIndex = startIndex + columnTextLength If startIndex >= longText.Length Then endOfText = True Exit While End If ' compute the offset of the next column leftOffset = leftOffset + columnWidth + columnSpace i = i + 1 End While End While ' Save the document to disk pdfDoc.Save("Sample_MultiColumnTextAndImages.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: PageOrientations
This sample shows how the PDF4NET library allows to create documents with different orientations of their pages. It creates a document with 2 pages. The first page has Portrait orientation, while the second one has Landscape orientation.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PageOrientations.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.PageOrientations { /// <summary> /// This sample will show how to create a document with /// different pages orientations /// </summary> class PageOrientations { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 20); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create first page PDFPage pdfPage1 = pdfDoc.AddPage(); // No need to do this because Portrait is the default orientation pdfPage1.Orientation = PDFPageOrientation.Portrait; // Draw a label on first page pdfPage1.Canvas.DrawText("This page uses Portrait orientation.", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); // Create second page PDFPage pdfPage2 = pdfDoc.AddPage(); // Set page's orientation to Landscape pdfPage2.Orientation = PDFPageOrientation.Landscape; // Draw a label on first page pdfPage2.Canvas.DrawText("This page uses Landscape orientation.", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); // Save the document to disk pdfDoc.Save("Sample_PageOrientations.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PageOrientations.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.PageOrientations ''' <summary> ''' This sample will show how to create a document with ''' different pages orientations ''' </summary> Class PageOrientations ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 20) Dim blackBrush As New PDFBrush(New PDFRgbColor()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create first page Dim pdfPage1 As PDFPage = pdfDoc.AddPage() ' No need to do this because Portrait is the default orientation pdfPage1.Orientation = PDFPageOrientation.Portrait ' Draw a label on first page pdfPage1.Canvas.DrawText("This page uses Portrait orientation.", fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) ' Create second page Dim pdfPage2 As PDFPage = pdfDoc.AddPage() ' Set page's orientation to Landscape pdfPage2.Orientation = PDFPageOrientation.Landscape ' Draw a label on first page pdfPage2.Canvas.DrawText("This page uses Landscape orientation.", fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) ' Save the document to disk pdfDoc.Save("Sample_PageOrientations.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: PageSizes
This sample shows how the PDF4NET library allows to create documents with pages of different sizes. It creates a document with 14 pages, each page has a different size.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PageSizes.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.PageSizes { /// <summary> /// This sample will show how to create a document with different page sizes /// </summary> class PageSizes { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { PDFPageSize[] pageSizes = { PDFPageSize.A3, PDFPageSize.A4, PDFPageSize.A5, PDFPageSize.B4, PDFPageSize.B5, PDFPageSize.Executive, PDFPageSize.Folio, PDFPageSize.Ledger, PDFPageSize.Legal, PDFPageSize.Letter, PDFPageSize.Quarto, PDFPageSize.Size10x14, PDFPageSize.Statement, PDFPageSize.Tabloid }; // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 20); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create the pages of the document, each one having a different size for (int i = 0; i < pageSizes.Length; i++) { // Create the page PDFPage pdfPage = pdfDoc.AddPage(); // Set its size pdfPage.Size = pageSizes[i]; // Draw a label on it pdfPage.Canvas.DrawText("This page has the following size: " + pageSizes[i].ToString(), fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); } // Save the document to disk pdfDoc.Save("Sample_PageSizes.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PageSizes.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.PageSizes ''' <summary> ''' This sample will show how to create a document with different page sizes ''' </summary> Class PageSizes ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) Dim pageSizes As PDFPageSize() = {PDFPageSize.A3, PDFPageSize.A4, PDFPageSize.A5, PDFPageSize.B4, PDFPageSize.B5, PDFPageSize.Executive, _ PDFPageSize.Folio, PDFPageSize.Ledger, PDFPageSize.Legal, PDFPageSize.Letter, PDFPageSize.Quarto, PDFPageSize.Size10x14, _ PDFPageSize.Statement, PDFPageSize.Tabloid} ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 20) Dim blackBrush As New PDFBrush(New PDFRgbColor()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create the pages of the document, each one having a different size Dim i As Integer = 0 While i < pageSizes.Length ' Create the page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Set its size pdfPage.Size = pageSizes(i) ' Draw a label on it pdfPage.Canvas.DrawText("This page has the following size: " + pageSizes(i).ToString(), fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) i = i + 1 End While ' Save the document to disk pdfDoc.Save("Sample_PageSizes.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Pantone colors
This sample shows how to work with Pantone colors. These colors are specific instances of separation colors.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PantoneColors.cs
using System; using System.IO; using System.Text; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Functions; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.ColorSpaces; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET { /// <summary> /// This sample shows how to work with various PANTONE colors when creating a PDF document. /// </summary> class PantoneColors { [STAThread] static void Main(string[] args) { PDFDocument doc = new PDFDocument(); PDFPage page = doc.AddPage(); DrawPantoneColors(page); doc.Save("Sample_PantoneColors.pdf"); doc.Dispose(); } /// <summary> /// Draws content on a page using PANTONE colors. /// </summary> /// <param name="page">The page to draw to.</param> private static void DrawPantoneColors(PDFPage page) { PDFRgbColor black = new PDFRgbColor(0, 0, 0); PDFBrush blackBrush = new PDFBrush(black); PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16); page.Canvas.DrawText("Pantone colors", font, null, blackBrush, 50, 50); PDFPantoneColor orange = PDFPantoneColor.Orange021; orange.Tint = 0.9; PDFPantoneColor warmRed = PDFPantoneColor.WarmRed; warmRed.Tint = 0.4; PDFBrush orangeBrush = new PDFBrush(orange); PDFPen warmRedPen = new PDFPen(warmRed, 5); page.Canvas.DrawRoundRectangle(warmRedPen, orangeBrush, 50, 100, 400, 150, 20, 20); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PantoneColors.vb
Imports System Imports System.IO Imports System.Text Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Functions Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.ColorSpaces Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET ''' <summary> ''' This sample shows how to work with various PANTONE colors when creating a PDF document. ''' </summary> Class PantoneColors <STAThread> _ Shared Sub Main(args As String()) Dim doc As New PDFDocument() Dim page As PDFPage = doc.AddPage() DrawPantoneColors(page) doc.Save("Sample_PantoneColors.pdf") doc.Dispose() End Sub ''' <summary> ''' Draws content on a page using PANTONE colors. ''' </summary> ''' <param name="page">The page to draw to.</param> Private Shared Sub DrawPantoneColors(page As PDFPage) Dim black As New PDFRgbColor(0, 0, 0) Dim blackBrush As New PDFBrush(black) Dim font As New PDFFont(PDFFontFace.Helvetica, 16) page.Canvas.DrawText("Pantone colors", font, Nothing, blackBrush, 50, 50) Dim orange As PDFPantoneColor = PDFPantoneColor.Orange021 orange.Tint = 0.9 Dim warmRed As PDFPantoneColor = PDFPantoneColor.WarmRed warmRed.Tint = 0.4 Dim orangeBrush As New PDFBrush(orange) Dim warmRedPen As New PDFPen(warmRed, 5) page.Canvas.DrawRoundRectangle(warmRedPen, orangeBrush, 50, 100, 400, 150, _ 20, 20) End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Paths
This sample demonstrates the support for free form paths implemented in PDF4NET library. A path can be constructed from several drawing primitives and it can be stroked and/or filled.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Paths.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; namespace O2S.Samples.PDF4NET.Paths { /// <summary> /// This sample shows how to use free form graphics paths with PDF4NET. /// </summary> class Paths { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument doc = new PDFDocument(); // Create one page PDFPage page = doc.AddPage(); PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1); PDFBrush darkBlueBrush = new PDFBrush(new PDFRgbColor(0, 0, 128)); // a star PDFPoint[] points = new PDFPoint[]{ new PDFPoint( 50, 200 ), new PDFPoint( 500, 200 ), new PDFPoint( 200, 400 ), new PDFPoint( 275, 50 ), new PDFPoint( 350, 400 ) }; // create a graphic path PDFPath path = new PDFPath(); path.MoveTo(50, 200); path.Polygon(points); path.MoveTo(50, 450); path.LineTo(600, 450); path.BezierTo(600, 500, 500, 500, 500, 600); path.BezierTo(400, 600, 300, 550, 600, 500); path.CloseSubpath(); // draw the path on the page page.Canvas.DrawPath(redPen, darkBlueBrush, path, PDFFillMode.EvenOdd); // Save the document to disk doc.Save("Sample_Paths.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Paths.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Namespace O2S.Samples.PDF4NET.Paths ''' <summary> ''' This sample shows how to use free form graphics paths with PDF4NET. ''' </summary> Class Paths ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim doc As New PDFDocument() ' Create one page Dim page As PDFPage = doc.AddPage() Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1) Dim darkBlueBrush As New PDFBrush(New PDFRgbColor(0, 0, 128)) ' a star Dim points As PDFPoint() = New PDFPoint() {New PDFPoint(50, 200), New PDFPoint(500, 200), New PDFPoint(200, 400), New PDFPoint(275, 50), New PDFPoint(350, 400)} ' create a graphic path Dim path As New PDFPath() path.MoveTo(50, 200) path.Polygon(points) path.MoveTo(50, 450) path.LineTo(600, 450) path.BezierTo(600, 500, 500, 500, 500, 600) path.BezierTo(400, 600, 300, 550, 600, 500) path.CloseSubpath() ' draw the path on the page page.Canvas.DrawPath(redPen, darkBlueBrush, path, PDFFillMode.EvenOdd) ' Save the document to disk doc.Save("Sample_Paths.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Sample: PDF/A

This sample shows how to create a PDF/A-1b compliant PDF file with PDF4NET. For more details about creating PDF/A-1b files with PDF4NET click PDF/A.

PDFA.cs | PDFA.vb | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDFA.cs
PDF/A Demo
Copy Code
using System;
using System.IO;
using System.Text;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.ColorSpaces;
using O2S.Components.PDF4NET.Annotations;
namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This demo shows how to create a PDF/A-1b compliant PDF file with PDF4NET.
    /// </summary>
    public class PDFADemo
    {
        static void Main(string[] args)
        {
            PDFDocument doc = new PDFDocument();
            doc.SerialNumber = "serial number here";

            // Read the ICC profile from disk.
            FileStream fs = new FileStream("..\\SupportFiles\\rgb.icc", FileMode.Open, FileAccess.Read);
            byte[] profileData = new byte[fs.Length];
            fs.Read(profileData, 0, profileData.Length);
            fs.Close();

            // Create a RGB output intent and attach it to the document.
            PDFICCColorSpace icc = new PDFICCColorSpace();
            icc.ProfileData = profileData;
            PDFOutputIntent oi = new PDFOutputIntent();
            oi.Type = PDFOutputIntentType.PDFA1;
            oi.Info = "sRGB IEC61966-2.1";
            oi.OutputConditionIdentifier = "Custom";
            oi.DestinationOutputProfile = icc;

            doc.OutputIntents = new PDFOutputIntentCollection();
            doc.OutputIntents.Add(oi);

            // Set the document information and metadata.
            PDFDocumentInformation di = new PDFDocumentInformation();
            di.Author = "O2 Solutions";
            di.Producer = "PDF4NET";
            di.Keywords = "pdf";
            di.Subject = "PDF/A-1b Demo Document created with PDF4NET";
            di.Title = "PDF4NET Demo";
            di.Creator = "PDF4NET Demo";
            doc.DocumentInformation = di;
            doc.Metadata = new PDFXMPMetadata();

            PDFPage page = doc.AddPage();

            // Use an embedded TrueType font to draw the text.
            TrueTypeFont ttf = new TrueTypeFont("..\\SupportFiles\\Verdana.ttf", 96, true, true);
            PDFBrush yellowBrush = new PDFBrush(new PDFRgbColor(255, 255, 0));
            PDFPen greenPen = new PDFPen(new PDFRgbColor(64, 192, 0), 4);
            page.Canvas.DrawText("PDF/A-1b Demo",
                ttf, greenPen, yellowBrush, page.Width / 2, page.Height / 2, 60, PDFTextAlign.MiddleCenter);

            // Save the document in PDF/A-1b format.
            PDFDocumentSaveOptions dso = new PDFDocumentSaveOptions();
            dso.SaveFormat = PDFDocumentSaveFormat.PDFA1b;
            doc.Save("Sample_PDFADemo.pdf", dso);
        }
    }
}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDFA.vb
PDF/A Demo
Copy Code
Imports System
Imports System.IO
Imports System.Text
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Fonts
Imports O2S.Components.PDF4NET.Graphics.ColorSpaces
Imports O2S.Components.PDF4NET.Annotations
Namespace O2S.Samples.PDF4NET
 ''' <summary>
 ''' This demo shows how to create a PDF/A-1b compliant PDF file with PDF4NET.
 ''' </summary>
 Public Class PDFADemo
  Shared Sub Main(args As String())
   Dim doc As New PDFDocument()
   doc.SerialNumber = "serial number here"
   ' Read the ICC profile from disk.
   Dim fs As New FileStream("..\SupportFiles\rgb.icc", FileMode.Open, FileAccess.Read)
   Dim profileData As Byte() = New Byte(fs.Length) {}
   fs.Read(profileData, 0, profileData.Length)
   fs.Close()
   ' Create a RGB output intent and attach it to the document.
   Dim icc As New PDFICCColorSpace()
   icc.ProfileData = profileData
   Dim oi As New PDFOutputIntent()
   oi.Type = PDFOutputIntentType.PDFA1
   oi.Info = "sRGB IEC61966-2.1"
   oi.OutputConditionIdentifier = "Custom"
   oi.DestinationOutputProfile = icc
   doc.OutputIntents = New PDFOutputIntentCollection()
   doc.OutputIntents.Add(oi)
   ' Set the document information and metadata.
   Dim di As New PDFDocumentInformation()
   di.Author = "O2 Solutions"
   di.Producer = "PDF4NET"
   di.Keywords = "pdf"
   di.Subject = "PDF/A-1b Demo Document created with PDF4NET"
   di.Title = "PDF4NET Demo"
   di.Creator = "PDF4NET Demo"
   doc.DocumentInformation = di
   doc.Metadata = New PDFXMPMetadata()
   Dim page As PDFPage = doc.AddPage()
   ' Use an embedded TrueType font to draw the text.
   Dim ttf As New TrueTypeFont("..\SupportFiles\Verdana.ttf", 96, True, True)
   Dim yellowBrush As New PDFBrush(New PDFRgbColor(255, 255, 0))
   Dim greenPen As New PDFPen(New PDFRgbColor(64, 192, 0), 4)
   page.Canvas.DrawText("PDF/A-1b Demo", ttf, greenPen, yellowBrush, page.Width / 2, page.Height / 2, _
    60, PDFTextAlign.MiddleCenter)
   ' Save the document in PDF/A-1b format.
   Dim dso As New PDFDocumentSaveOptions()
   dso.SaveFormat = PDFDocumentSaveFormat.PDFA1b
   doc.Save("Sample_PDFADemo.pdf", dso)
  End Sub
 End Class
End Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Polygons
This sample shows the polygons drawing capabilities. On the first page it draws a few geometric figures. Second page demonstrates poly-polygon drawing capabilities. For poly-polygons the filling mode can be set.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Polygons.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Polygons { /// <summary> /// This sample will show how to draw various polygons and polypolygons on the page. /// </summary> class Polygons { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create first page PDFPage pdfPage1 = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFBrush orangeBrush = new PDFBrush(new PDFRgbColor(Color.Orange)); PDFPen pen = new PDFPen(new PDFRgbColor(Color.GreenYellow), 1); // Draw a pentagon PDFPoint[] pentagon = { new PDFPoint( 150, 35 ), new PDFPoint( 250, 125 ), new PDFPoint( 200, 215 ), new PDFPoint( 100, 215 ), new PDFPoint( 50, 125 ) }; pdfPage1.Canvas.DrawText("This is a pentagon", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawPolygon(pen, orangeBrush, pentagon); // Draw a hexagon PDFPoint[] hexagon = { new PDFPoint( 450, 35 ), new PDFPoint( 550, 135 ), new PDFPoint( 550, 235 ), new PDFPoint( 450, 335 ), new PDFPoint( 350, 235 ), new PDFPoint( 350, 135 ) }; pdfPage1.Canvas.DrawText("This is a hexagon", fontText, null, blackBrush, 300, 20, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawPolygon(pen, orangeBrush, hexagon); // Draw an arrow PDFPoint[] arrow = { new PDFPoint( 20, 350 ), new PDFPoint( 220, 350 ), new PDFPoint( 220, 300 ), new PDFPoint( 320, 400 ), new PDFPoint( 220, 500 ), new PDFPoint( 220, 450 ), new PDFPoint( 20, 450 ) }; pdfPage1.Canvas.DrawText("This is an arrow", fontText, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawPolygon(pen, null, arrow); // Draw a rectangular callout PDFPoint[] callout = { new PDFPoint( 350, 350 ), new PDFPoint( 550, 350 ), new PDFPoint( 550, 450 ), new PDFPoint( 480, 450 ), new PDFPoint( 350, 550 ), new PDFPoint( 420, 450 ), new PDFPoint( 350, 450 ) }; pdfPage1.Canvas.DrawText("This is a rectangular callout", fontText, null, blackBrush, 370, 400, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawPolygon(pen, null, callout); // Create second page PDFPage pdfPage2 = pdfDoc.AddPage(); // a star PDFPoint[] points = new PDFPoint[]{ new PDFPoint( 50, 200 ), new PDFPoint( 500, 200 ), new PDFPoint( 150, 500 ), new PDFPoint( 275, 50 ), new PDFPoint( 400, 500 ) }; pdfPage2.Canvas.DrawPolygon(pen, orangeBrush, points, PDFFillMode.EvenOdd); // Create third page PDFPage pdfPage3 = pdfDoc.AddPage(); // a polypolygon PDFPoint[][] polygons = new PDFPoint[4][]; polygons[0] = new PDFPoint[]{ new PDFPoint( 50, 100 ), new PDFPoint( 550, 100 ), new PDFPoint( 550, 600 ), new PDFPoint( 50, 600 ) }; polygons[1] = new PDFPoint[]{ new PDFPoint( 100, 150 ), new PDFPoint( 500, 150 ), new PDFPoint( 500, 550 ), new PDFPoint( 100, 550 ) }; polygons[2] = new PDFPoint[]{ new PDFPoint( 150, 200 ), new PDFPoint( 450, 200 ), new PDFPoint( 450, 500 ), new PDFPoint( 150, 500 ) }; polygons[3] = new PDFPoint[]{ new PDFPoint( 200, 250 ), new PDFPoint( 400, 250 ), new PDFPoint( 400, 450 ), new PDFPoint( 200, 450 ) }; pdfPage3.Canvas.DrawPolyPolygon(pen, orangeBrush, polygons, PDFFillMode.EvenOdd); // Save the document to disk pdfDoc.Save("Sample_Polygons.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Polygons.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Polygons ''' <summary> ''' This sample will show how to draw various polygons and polypolygons on the page. ''' </summary> Class Polygons ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create first page Dim pdfPage1 As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim orangeBrush As New PDFBrush(New PDFRgbColor(Color.Orange)) Dim pen As New PDFPen(New PDFRgbColor(Color.GreenYellow), 1) ' Draw a pentagon Dim pentagon As PDFPoint() = {New PDFPoint(150, 35), New PDFPoint(250, 125), New PDFPoint(200, 215), New PDFPoint(100, 215), New PDFPoint(50, 125)} pdfPage1.Canvas.DrawText("This is a pentagon", fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawPolygon(pen, orangeBrush, pentagon) ' Draw a hexagon Dim hexagon As PDFPoint() = {New PDFPoint(450, 35), New PDFPoint(550, 135), New PDFPoint(550, 235), New PDFPoint(450, 335), New PDFPoint(350, 235), New PDFPoint(350, 135)} pdfPage1.Canvas.DrawText("This is a hexagon", fontText, Nothing, blackBrush, 300, 20, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawPolygon(pen, orangeBrush, hexagon) ' Draw an arrow Dim arrow As PDFPoint() = {New PDFPoint(20, 350), New PDFPoint(220, 350), New PDFPoint(220, 300), New PDFPoint(320, 400), New PDFPoint(220, 500), New PDFPoint(220, 450), _ New PDFPoint(20, 450)} pdfPage1.Canvas.DrawText("This is an arrow", fontText, Nothing, blackBrush, 20, 300, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawPolygon(pen, Nothing, arrow) ' Draw a rectangular callout Dim callout As PDFPoint() = {New PDFPoint(350, 350), New PDFPoint(550, 350), New PDFPoint(550, 450), New PDFPoint(480, 450), New PDFPoint(350, 550), New PDFPoint(420, 450), _ New PDFPoint(350, 450)} pdfPage1.Canvas.DrawText("This is a rectangular callout", fontText, Nothing, blackBrush, 370, 400, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawPolygon(pen, Nothing, callout) ' Create second page Dim pdfPage2 As PDFPage = pdfDoc.AddPage() ' a star Dim points As PDFPoint() = New PDFPoint() {New PDFPoint(50, 200), New PDFPoint(500, 200), New PDFPoint(150, 500), New PDFPoint(275, 50), New PDFPoint(400, 500)} pdfPage2.Canvas.DrawPolygon(pen, orangeBrush, points, PDFFillMode.EvenOdd) ' Create third page Dim pdfPage3 As PDFPage = pdfDoc.AddPage() ' a polypolygon Dim polygons As PDFPoint()() = New PDFPoint(3)() {} polygons(0) = New PDFPoint() {New PDFPoint(50, 100), New PDFPoint(550, 100), New PDFPoint(550, 600), New PDFPoint(50, 600)} polygons(1) = New PDFPoint() {New PDFPoint(100, 150), New PDFPoint(500, 150), New PDFPoint(500, 550), New PDFPoint(100, 550)} polygons(2) = New PDFPoint() {New PDFPoint(150, 200), New PDFPoint(450, 200), New PDFPoint(450, 500), New PDFPoint(150, 500)} polygons(3) = New PDFPoint() {New PDFPoint(200, 250), New PDFPoint(400, 250), New PDFPoint(400, 450), New PDFPoint(200, 450)} pdfPage3.Canvas.DrawPolyPolygon(pen, orangeBrush, polygons, PDFFillMode.EvenOdd) ' Save the document to disk pdfDoc.Save("Sample_Polygons.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Sample: Portfolios
This samples shows the portfolio capabilites available in PDF4NET. It creates a portfolio with 2 PDF files, associates a schema with the portfolio and then adds the custom information matching the schema to each file in the portfolio.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Portfolios.cs
Portfolios.cs
Copy Code
using System;
using System.Collections.Generic;
using System.Text;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Portfolios;
using O2S.Components.PDF4NET.Cos;
namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to create a PDF portfolio.
    /// </summary>
    public class Portfolios
    {
        static void Mainx(string[] args)
        {
            PDFDocument portfolioDoc = new PDFDocument();
            portfolioDoc.DisplayMode = PDFDisplayMode.UseAttachments;
            portfolioDoc.VersionExtension = new PDFVersionExtension();
            portfolioDoc.VersionExtension.Level = 3;
            portfolioDoc.VersionExtension.PDFVersion = PDFVersion.Version17;
            // This empty page will be displayed initially when the portfolio is loaded
            // if a startup display document is not specified.
            portfolioDoc.AddPage();
            portfolioDoc.PortfolioInformation = new PDFPortfolioInformation();
            portfolioDoc.PortfolioInformation.ViewMode = PDFPortfolioViewMode.Tile;
            // Create the portfolio schema
            PDFPortfolioSchema schema = new PDFPortfolioSchema();
            PDFPortfolioSchemaField fromField = new PDFPortfolioSchemaField();
            fromField.Name = "From";
            fromField.Type = PDFPortfolioSchemaFieldType.String;
            fromField.Order = 1;
            fromField.Visible = true;
            fromField.Editable = false;
            schema["from"] = fromField;
            PDFPortfolioSchemaField toField = new PDFPortfolioSchemaField();
            toField.Name = "To";
            toField.Type = PDFPortfolioSchemaFieldType.String;
            toField.Order = 2;
            toField.Visible = true;
            toField.Editable = false;
            schema["to"] = toField;
            PDFPortfolioSchemaField dateField = new PDFPortfolioSchemaField();
            dateField.Name = "Date received";
            dateField.Type = PDFPortfolioSchemaFieldType.Date;
            dateField.Order = 3;
            dateField.Visible = true;
            dateField.Editable = false;
            schema["date"] = dateField;
            PDFPortfolioSchemaField subjectField = new PDFPortfolioSchemaField();
            subjectField.Name = "Subject";
            subjectField.Type = PDFPortfolioSchemaFieldType.String;
            subjectField.Order = 4;
            subjectField.Visible = true;
            subjectField.Editable = false;
            schema["subject"] = subjectField;
            PDFPortfolioSchemaField sizeField = new PDFPortfolioSchemaField();
            sizeField.Name = "Size";
            sizeField.Type = PDFPortfolioSchemaFieldType.Size;
            sizeField.Order = 5;
            sizeField.Visible = true;
            sizeField.Editable = false;
            schema["size"] = sizeField;
            portfolioDoc.PortfolioInformation.Schema = schema;
            // Setup the sort order for the files in the portfolio.
            PDFPortfolioSortInformation sortInfo = new PDFPortfolioSortInformation();
            sortInfo.SortFields = new string[] { "date" };
            sortInfo.Ascending = new bool[] { false };
            portfolioDoc.PortfolioInformation.SortInformation = sortInfo;
            // Create the document attachments that are part of the portfolio and
            // fill the portfolio attributes for each attachment.
            PDFDocumentAttachment file1 = new PDFDocumentAttachment();
            file1.FileName = "..\\SupportFiles\\hellopdfworld.pdf";
            file1.PortfolioAttributes = new PDFPortfolioAttributes();
            file1.PortfolioAttributes["from"] = new PDFString("John Doe");
            file1.PortfolioAttributes["to"] = new PDFString("Mary Jane");
            file1.PortfolioAttributes["date"] = new PDFDateTime(DateTime.Now.Subtract(new TimeSpan(24, 0, 0)));
            file1.PortfolioAttributes["subject"] = new PDFString("Hello PDF World");
            portfolioDoc.Attachments.Add(file1);
            PDFDocumentAttachment file2 = new PDFDocumentAttachment();
            file2.FileName = "..\\SupportFiles\\sample.pdf";
            file2.PortfolioAttributes = new PDFPortfolioAttributes();
            file2.PortfolioAttributes["from"] = new PDFString("Mary Jane");
            file2.PortfolioAttributes["to"] = new PDFString("John Doe");
            file2.PortfolioAttributes["date"] = new PDFDateTime(DateTime.Now);
            file2.PortfolioAttributes["subject"] = new PDFString("Sample");
            portfolioDoc.Attachments.Add(file2);
            portfolioDoc.PortfolioInformation.StartupDocument = file2;
            portfolioDoc.Save("Sample_Portfolios.pdf");
        }
    }
}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Portfolios.vb
Portfolios.vb
Copy Code
Imports System
Imports System.Collections.Generic
Imports System.Text
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Portfolios
Imports O2S.Components.PDF4NET.Cos
Namespace O2S.Samples.PDF4NET
 ''' <summary>
 ''' This sample shows how to create a PDF portfolio.
 ''' </summary>
 Public Class Portfolios
  Private Shared Sub Mainx(args As String())
   Dim portfolioDoc As New PDFDocument()
   portfolioDoc.DisplayMode = PDFDisplayMode.UseAttachments
   portfolioDoc.VersionExtension = New PDFVersionExtension()
   portfolioDoc.VersionExtension.Level = 3
   portfolioDoc.VersionExtension.PDFVersion = PDFVersion.Version17
   ' This empty page will be displayed initially when the portfolio is loaded
   ' if a startup display document is not specified.
   portfolioDoc.AddPage()
   portfolioDoc.PortfolioInformation = New PDFPortfolioInformation()
   portfolioDoc.PortfolioInformation.ViewMode = PDFPortfolioViewMode.Tile
   ' Create the portfolio schema
   Dim schema As New PDFPortfolioSchema()
   Dim fromField As New PDFPortfolioSchemaField()
   fromField.Name = "From"
   fromField.Type = PDFPortfolioSchemaFieldType.[String]
   fromField.Order = 1
   fromField.Visible = True
   fromField.Editable = False
   schema("from") = fromField
   Dim toField As New PDFPortfolioSchemaField()
   toField.Name = "To"
   toField.Type = PDFPortfolioSchemaFieldType.[String]
   toField.Order = 2
   toField.Visible = True
   toField.Editable = False
   schema("to") = toField
   Dim dateField As New PDFPortfolioSchemaField()
   dateField.Name = "Date received"
   dateField.Type = PDFPortfolioSchemaFieldType.[Date]
   dateField.Order = 3
   dateField.Visible = True
   dateField.Editable = False
   schema("date") = dateField
   Dim subjectField As New PDFPortfolioSchemaField()
   subjectField.Name = "Subject"
   subjectField.Type = PDFPortfolioSchemaFieldType.[String]
   subjectField.Order = 4
   subjectField.Visible = True
   subjectField.Editable = False
   schema("subject") = subjectField
   Dim sizeField As New PDFPortfolioSchemaField()
   sizeField.Name = "Size"
   sizeField.Type = PDFPortfolioSchemaFieldType.Size
   sizeField.Order = 5
   sizeField.Visible = True
   sizeField.Editable = False
   schema("size") = sizeField
   portfolioDoc.PortfolioInformation.Schema = schema
   ' Setup the sort order for the files in the portfolio.
   Dim sortInfo As New PDFPortfolioSortInformation()
   sortInfo.SortFields = New String() {"date"}
   sortInfo.Ascending = New Boolean() {False}
   portfolioDoc.PortfolioInformation.SortInformation = sortInfo
   ' Create the document attachments that are part of the portfolio and
   ' fill the portfolio attributes for each attachment.
   Dim file1 As New PDFDocumentAttachment()
   file1.FileName = "..\SupportFiles\hellopdfworld.pdf"
   file1.PortfolioAttributes = New PDFPortfolioAttributes()
   file1.PortfolioAttributes("from") = New PDFString("John Doe")
   file1.PortfolioAttributes("to") = New PDFString("Mary Jane")
   file1.PortfolioAttributes("date") = New PDFDateTime(DateTime.Now.Subtract(New TimeSpan(24, 0, 0)))
   file1.PortfolioAttributes("subject") = New PDFString("Hello PDF World")
   portfolioDoc.Attachments.Add(file1)
   Dim file2 As New PDFDocumentAttachment()
   file2.FileName = "..\SupportFiles\sample.pdf"
   file2.PortfolioAttributes = New PDFPortfolioAttributes()
   file2.PortfolioAttributes("from") = New PDFString("Mary Jane")
   file2.PortfolioAttributes("to") = New PDFString("John Doe")
   file2.PortfolioAttributes("date") = New PDFDateTime(DateTime.Now)
   file2.PortfolioAttributes("subject") = New PDFString("Sample")
   portfolioDoc.Attachments.Add(file2)
   portfolioDoc.PortfolioInformation.StartupDocument = file2
   portfolioDoc.Save("Sample_Portfolios.pdf")
  End Sub
 End Class
End Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Rectangles
This samples shows the rectangles drawing capabilities of the PDF4NET library. On the first page, it draws a rectangle by painting its border, a rectangle by filling its interior, and a rectangle by painting its border and filling its interior. It also show how to draw a rotated rectangle. On the second page it draws 50 rectangles at random locations on the page. The color of the rectangles is generated randomly.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Rectangles.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Rectangles { /// <summary> /// This sample will show how to draw various rectangles /// on the page. /// </summary> class Rectangles { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create first page PDFPage pdfPage1 = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFBrush redBrush = new PDFBrush(new PDFRgbColor(255, 0, 0)); PDFPen pen = new PDFPen(new PDFRgbColor(0, 0, 255), 1); // Draw a rectangle that has a border pdfPage1.Canvas.DrawText("This rectangle is drawn by drawing its border", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawRectangle(pen, null, 20, 35, 200, 100, 0); // Draw a rectangle that has no border and its interior is filled pdfPage1.Canvas.DrawText("This rectangle is drawn by filling its interior", fontText, null, blackBrush, 300, 20, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawRectangle(null, redBrush, 300, 35, 300, 150, 0); // Draw a rectangle that has a border and its interior is filled pdfPage1.Canvas.DrawText("This rectangle has a border and a filled interior", fontText, null, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 215, 200, 150, 0); // Draw a rotated rectangle pdfPage1.Canvas.DrawText("This rectangle is rotated with 30 degrees around the top left corner", fontText, null, blackBrush, 20, 400, 0, PDFTextAlign.TopLeft); pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 550, 200, 150, 30); pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 550, 200, 150, 0); // Create the second page PDFPage pdfPage2 = pdfDoc.AddPage(); Random rnd = new Random(); for (int i = 0; i < 50; i++) { // Create random colors for the border and the interior PDFColor brushColor = new PDFRgbColor((byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256)); PDFColor penColor = new PDFRgbColor((byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256)); // Create the brush to fill the interior PDFBrush randomBrush = new PDFBrush(brushColor); // Create the pen to draw the border PDFPen randomPen = new PDFPen(penColor, 1); // Generate random positions float left = rnd.Next((int)pdfPage2.Width); float top = rnd.Next((int)pdfPage2.Height); // Generate random sizes float width = rnd.Next((int)(pdfPage2.Width - left)); // try to keep the rectangle float height = rnd.Next((int)(pdfPage2.Height - top)); // within the page // Generate random orientation float orientation = rnd.Next(360); // Draw the rectangle pdfPage2.Canvas.DrawRectangle(randomPen, randomBrush, left, top, width, height, orientation); } // Draw a label pdfPage2.Canvas.DrawText("Random rectangles", fontText, null, blackBrush, 20, 350, 0, PDFTextAlign.TopLeft); // Save the document to disk pdfDoc.Save("Sample_Rectangles.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Rectangles.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Rectangles ''' <summary> ''' This sample will show how to draw various rectangles ''' on the page. ''' </summary> Class Rectangles ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create first page Dim pdfPage1 As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim redBrush As New PDFBrush(New PDFRgbColor(255, 0, 0)) Dim pen As New PDFPen(New PDFRgbColor(0, 0, 255), 1) ' Draw a rectangle that has a border pdfPage1.Canvas.DrawText("This rectangle is drawn by drawing its border", fontText, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawRectangle(pen, Nothing, 20, 35, 200, 100, _ 0) ' Draw a rectangle that has no border and its interior is filled pdfPage1.Canvas.DrawText("This rectangle is drawn by filling its interior", fontText, Nothing, blackBrush, 300, 20, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawRectangle(Nothing, redBrush, 300, 35, 300, 150, _ 0) ' Draw a rectangle that has a border and its interior is filled pdfPage1.Canvas.DrawText("This rectangle has a border and a filled interior", fontText, Nothing, blackBrush, 20, 200, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 215, 200, 150, _ 0) ' Draw a rotated rectangle pdfPage1.Canvas.DrawText("This rectangle is rotated with 30 degrees around the top left corner", fontText, Nothing, blackBrush, 20, 400, _ 0, PDFTextAlign.TopLeft) pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 550, 200, 150, _ 30) pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 550, 200, 150, _ 0) ' Create the second page Dim pdfPage2 As PDFPage = pdfDoc.AddPage() Dim rnd As New Random() Dim i As Integer = 0 While i < 50 ' Create random colors for the border and the interior Dim brushColor As PDFColor = New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256)) Dim penColor As PDFColor = New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256)) ' Create the brush to fill the interior Dim randomBrush As New PDFBrush(brushColor) ' Create the pen to draw the border Dim randomPen As New PDFPen(penColor, 1) ' Generate random positions Dim left As Double = rnd.NextDouble() * pdfPage2.Width Dim top As Double = rnd.NextDouble() * pdfPage2.Height ' Generate random sizes Dim width As Double = rnd.NextDouble() * (pdfPage2.Width - left) ' try to keep the rectangle Dim height As Double = rnd.NextDouble() * (pdfPage2.Height - top) ' within the page ' Generate random orientation Dim orientation As Double = rnd.Next(360) ' Draw the rectangle pdfPage2.Canvas.DrawRectangle(randomPen, randomBrush, left, top, width, height, _ orientation) i = i + 1 End While ' Draw a label pdfPage2.Canvas.DrawText("Random rectangles", fontText, Nothing, blackBrush, 20, 350, _ 0, PDFTextAlign.TopLeft) ' Save the document to disk pdfDoc.Save("Sample_Rectangles.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Shadings
This samples demonstrates the shading draw capabilites in PDF4NET. On first 2 pages is draws 2 axis shadings, a free one and a clipped one to a circle, and on the 3rd page it draws several radial shadings.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Shadings.cs
Shadings.cs
Copy Code
using System;
using System.Collections.Generic;
using System.Text;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics.Shadings;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to create and display PDF shadings.
    /// </summary>
    public class Shadings
    {
        static void Main(string[] args)
        {
            PDFDocument doc = new PDFDocument();
            // Create an axial shading that covers the entire page.
            PDFPage page1 = doc.AddPage();
            PDFAxialShading pageAxialShading = new PDFAxialShading();
            pageAxialShading.StartPoint = new PDFPoint(0, 0);
            pageAxialShading.EndPoint = new PDFPoint(page1.Width, page1.Height);
            pageAxialShading.StartColor = new PDFRgbColor(255, 0, 0);
            pageAxialShading.EndColor = new PDFRgbColor(0, 255, 0);
            page1.Canvas.DrawShading(pageAxialShading);
            // Fill a circle with an axial shading.
            PDFPage page2 = doc.AddPage();
            PDFPath path = new PDFPath();
            path.Ellipse(page2.Width / 2 - 200, page2.Height / 2 - 200, 400, 400);
            page2.Canvas.SetClipRegion(path);
            PDFAxialShading circleAxialShading = new PDFAxialShading();
            circleAxialShading.StartPoint = new PDFPoint(page2.Width / 2 - 170, page2.Height / 2 - 170);
            circleAxialShading.EndPoint = new PDFPoint(page2.Width / 2 + 170, page2.Height / 2 + 170);
            circleAxialShading.StartColor = new PDFRgbColor(255, 0, 0);
            circleAxialShading.EndColor = new PDFRgbColor(0, 0, 255);
            page2.Canvas.DrawShading(circleAxialShading);
            page2.Canvas.ResetClipRegion();
            PDFPen greenPen = new PDFPen(new PDFRgbColor(0, 255, 0), 5);
            page2.Canvas.DrawPath(greenPen, path);
            // Draw a radial shading between 2 circles.
            PDFPage page3 = doc.AddPage();
            PDFRadialShading radialShading1 = new PDFRadialShading();
            radialShading1.StartCircleCenter = new PDFPoint(150, 150);
            radialShading1.StartCircleRadius = 100;
            radialShading1.EndCircleCenter = new PDFPoint(230, 150);
            radialShading1.EndCircleRadius = 10;
            radialShading1.StartColor = new PDFRgbColor(255, 0, 0);
            radialShading1.EndColor = new PDFRgbColor(0, 0, 255);
            radialShading1.ExtendEnd = true;
            page3.Canvas.DrawShading(radialShading1);
            PDFRadialShading radialShading2 = new PDFRadialShading();
            radialShading2.StartCircleCenter = new PDFPoint(450, 150);
            radialShading2.StartCircleRadius = 100;
            radialShading2.EndCircleCenter = new PDFPoint(520, 110);
            radialShading2.EndCircleRadius = 1;
            radialShading2.StartColor = new PDFRgbColor(255, 255, 0);
            radialShading2.EndColor = new PDFRgbColor(255, 0, 255);
            radialShading2.ExtendEnd = true;
            page3.Canvas.DrawShading(radialShading2);
            PDFRadialShading radialShading3 = new PDFRadialShading();
            radialShading3.StartCircleCenter = new PDFPoint(150, 450);
            radialShading3.StartCircleRadius = 100;
            radialShading3.EndCircleCenter = new PDFPoint(250, 450);
            radialShading3.EndCircleRadius = 10;
            radialShading3.StartColor = new PDFRgbColor(255, 0, 255);
            radialShading3.EndColor = new PDFRgbColor(128, 64, 255);
            radialShading3.ExtendEnd = false;
            page3.Canvas.DrawShading(radialShading3);
            doc.Save("Sample_Shadings.pdf");
        }
    }
}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Shadings.vb
Shadings.vb
Copy Code
Imports System
Imports System.Collections.Generic
Imports System.Text
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics.Shadings
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Namespace O2S.Samples.PDF4NET
 ''' <summary>
 ''' This sample shows how to create and display PDF shadings.
 ''' </summary>
 Public Class Shadings
  Private Shared Sub Main(args As String())
   Dim doc As New PDFDocument()
   ' Create an axial shading that covers the entire page.
   Dim page1 As PDFPage = doc.AddPage()
   Dim pageAxialShading As New PDFAxialShading()
   pageAxialShading.StartPoint = New PDFPoint(0, 0)
   pageAxialShading.EndPoint = New PDFPoint(page1.Width, page1.Height)
   pageAxialShading.StartColor = New PDFRgbColor(255, 0, 0)
   pageAxialShading.EndColor = New PDFRgbColor(0, 255, 0)
   page1.Canvas.DrawShading(pageAxialShading)
   ' Fill a circle with an axial shading.
   Dim page2 As PDFPage = doc.AddPage()
   Dim path As New PDFPath()
   path.Ellipse(page2.Width / 2 - 200, page2.Height / 2 - 200, 400, 400)
   page2.Canvas.SetClipRegion(path)
   Dim circleAxialShading As New PDFAxialShading()
   circleAxialShading.StartPoint = New PDFPoint(page2.Width / 2 - 170, page2.Height / 2 - 170)
   circleAxialShading.EndPoint = New PDFPoint(page2.Width / 2 + 170, page2.Height / 2 + 170)
   circleAxialShading.StartColor = New PDFRgbColor(255, 0, 0)
   circleAxialShading.EndColor = New PDFRgbColor(0, 0, 255)
   page2.Canvas.DrawShading(circleAxialShading)
   page2.Canvas.ResetClipRegion()
   Dim greenPen As New PDFPen(New PDFRgbColor(0, 255, 0), 5)
   page2.Canvas.DrawPath(greenPen, path)
   ' Draw a radial shading between 2 circles.
   Dim page3 As PDFPage = doc.AddPage()
   Dim radialShading1 As New PDFRadialShading()
   radialShading1.StartCircleCenter = New PDFPoint(150, 150)
   radialShading1.StartCircleRadius = 100
   radialShading1.EndCircleCenter = New PDFPoint(230, 150)
   radialShading1.EndCircleRadius = 10
   radialShading1.StartColor = New PDFRgbColor(255, 0, 0)
   radialShading1.EndColor = New PDFRgbColor(0, 0, 255)
   radialShading1.ExtendEnd = True
   page3.Canvas.DrawShading(radialShading1)
   Dim radialShading2 As New PDFRadialShading()
   radialShading2.StartCircleCenter = New PDFPoint(450, 150)
   radialShading2.StartCircleRadius = 100
   radialShading2.EndCircleCenter = New PDFPoint(520, 110)
   radialShading2.EndCircleRadius = 1
   radialShading2.StartColor = New PDFRgbColor(255, 255, 0)
   radialShading2.EndColor = New PDFRgbColor(255, 0, 255)
   radialShading2.ExtendEnd = True
   page3.Canvas.DrawShading(radialShading2)
   Dim radialShading3 As New PDFRadialShading()
   radialShading3.StartCircleCenter = New PDFPoint(150, 450)
   radialShading3.StartCircleRadius = 100
   radialShading3.EndCircleCenter = New PDFPoint(250, 450)
   radialShading3.EndCircleRadius = 10
   radialShading3.StartColor = New PDFRgbColor(255, 0, 255)
   radialShading3.EndColor = New PDFRgbColor(128, 64, 255)
   radialShading3.ExtendEnd = False
   page3.Canvas.DrawShading(radialShading3)
   doc.Save("Sample_Shadings.pdf")
  End Sub
 End Class
End Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: SimpleGrid
This samples shows how to draw a simple report. The content of the report is loaded from an XML file.
This sample uses authors.xml file found in \supportfiles folder.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


SimpleGrid.cs
using System; using System.Drawing; using System.Data; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.SimpleGrid { /// <summary> /// This sample will show how to draw a simple report /// using content from a database/xml file. /// </summary> class SimpleGrid { private static float leftMargin = 15; private static float rightMargin = 15; private static float topMargin = 20; private static float minBottomMargin = 20; private static float rowHeight = 30; private static float headerHeight = 30; private static float firstPageTopOffset = 50; private static float[] columnsWidth = { 80, 100, 100, 90, 212, 90, 40, 50 }; private static string[] columnsHeader = { "Author ID", "First name", "Last name", "Phone", "Address", "City", "State", "ZIP" }; /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the graphic objects PDFFont fontTitle = new PDFFont(PDFFontFace.Helvetica, 20); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Set the document to be Landscape oriented pdfDoc.PageOrientation = PDFPageOrientation.Landscape; // Create first page of the report PDFPage page = pdfDoc.AddPage(); // Draw the title of the report page.Canvas.DrawText("Authors", fontTitle, null, blackBrush, page.Width / 2, 15, 0, PDFTextAlign.TopCenter); // Draw report header DrawReportHeader(page, firstPageTopOffset); // Create the dataset DataSet ds = new DataSet(); // Load the dataset ds.ReadXml("..\\SupportFiles\\authors.xml", XmlReadMode.ReadSchema); // Get the table from the dataset DataTable authors = ds.Tables[0]; // rowOffset - specifies the vertical position where a row // should begin to be printed float rowOffset = firstPageTopOffset + headerHeight; for (int i = 0; i < authors.Rows.Count; i++) { if (rowOffset + rowHeight > page.Height - minBottomMargin) { // not enough space to draw a new row, then create a new page, // draw the header, then draw the rows. page = pdfDoc.AddPage(); DrawReportHeader(page, topMargin); rowOffset = topMargin + headerHeight; } DrawReportRow(page, rowOffset, authors.Rows[i]); rowOffset = rowOffset + rowHeight; } // Save the document to disk pdfDoc.Save("Sample_SimpleGrid.pdf"); } private static void DrawReportHeader(PDFPage pdfPage, float topOffset) { // Create the graphic objects PDFFont fontHeader = new PDFFont(PDFFontFace.Helvetica, 12); fontHeader.Bold = true; PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1); PDFBrush textColor = new PDFBrush(new PDFRgbColor()); PDFBrush headerFill = new PDFBrush(new PDFRgbColor(192, 192, 192)); // Draw the header pdfPage.Canvas.DrawRectangle(borderColor, headerFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, headerHeight); int i; float xOffset = leftMargin; // Draw the columns separators for (i = 0; i < columnsWidth.Length - 1; i++) { xOffset = xOffset + columnsWidth[i]; pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + headerHeight); } xOffset = leftMargin; // Draw the columns header for (i = 0; i < columnsWidth.Length; i++) { pdfPage.Canvas.DrawText(columnsHeader[i], fontHeader, null, textColor, xOffset + columnsWidth[i] / 2, topOffset + headerHeight / 2, 0, PDFTextAlign.MiddleCenter); xOffset = xOffset + columnsWidth[i]; } } private static void DrawReportRow(PDFPage pdfPage, float topOffset, DataRow row) { // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1); PDFBrush textColor = new PDFBrush(new PDFRgbColor()); PDFBrush headerFill = new PDFBrush(new PDFRgbColor(192, 192, 192)); // Draw rows borders PDFPoint[] points = { new PDFPoint( leftMargin, topOffset ), new PDFPoint( leftMargin, topOffset + rowHeight), new PDFPoint( pdfPage.Width - rightMargin, topOffset + rowHeight ), new PDFPoint( pdfPage.Width - rightMargin, topOffset )}; pdfPage.Canvas.DrawLines(borderColor, points); int i; float xOffset = leftMargin; // Draw the columns separators for (i = 0; i < columnsWidth.Length - 1; i++) { xOffset = xOffset + columnsWidth[i]; pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + rowHeight); } xOffset = leftMargin; // Draw the columns header for (i = 0; i < columnsWidth.Length; i++) { pdfPage.Canvas.DrawText((string)row[i], fontText, null, textColor, xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft); xOffset = xOffset + columnsWidth[i]; } } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


SimpleGrid.vb
Imports System Imports System.Drawing Imports System.Data Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.SimpleGrid ''' <summary> ''' This sample will show how to draw a simple report ''' using content from a database/xml file. ''' </summary> Class SimpleGrid Private Shared leftMargin As Single = 15 Private Shared rightMargin As Single = 15 Private Shared topMargin As Single = 20 Private Shared minBottomMargin As Single = 20 Private Shared rowHeight As Single = 30 Private Shared headerHeight As Single = 30 Private Shared firstPageTopOffset As Single = 50 Private Shared columnsWidth As Single() = {80, 100, 100, 90, 212, 90, _ 40, 50} Private Shared columnsHeader As String() = {"Author ID", "First name", "Last name", "Phone", "Address", "City", _ "State", "ZIP"} ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the graphic objects Dim fontTitle As New PDFFont(PDFFontFace.Helvetica, 20) Dim blackBrush As New PDFBrush(New PDFRgbColor()) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Set the document to be Landscape oriented pdfDoc.PageOrientation = PDFPageOrientation.Landscape ' Create first page of the report Dim page As PDFPage = pdfDoc.AddPage() ' Draw the title of the report page.Canvas.DrawText("Authors", fontTitle, Nothing, blackBrush, page.Width / 2, 15, _ 0, PDFTextAlign.TopCenter) ' Draw report header DrawReportHeader(page, firstPageTopOffset) ' Create the dataset Dim ds As New DataSet() ' Load the dataset ds.ReadXml("..\SupportFiles\authors.xml", XmlReadMode.ReadSchema) ' Get the table from the dataset Dim authors As DataTable = ds.Tables(0) ' rowOffset - specifies the vertical position where a row ' should begin to be printed Dim rowOffset As Single = firstPageTopOffset + headerHeight Dim i As Integer = 0 While i < authors.Rows.Count If rowOffset + rowHeight > page.Height - minBottomMargin Then ' not enough space to draw a new row, then create a new page, ' draw the header, then draw the rows. page = pdfDoc.AddPage() DrawReportHeader(page, topMargin) rowOffset = topMargin + headerHeight End If DrawReportRow(page, rowOffset, authors.Rows(i)) rowOffset = rowOffset + rowHeight i = i + 1 End While ' Save the document to disk pdfDoc.Save("Sample_SimpleGrid.pdf") End Sub Private Shared Sub DrawReportHeader(pdfPage As PDFPage, topOffset As Single) ' Create the graphic objects Dim fontHeader As New PDFFont(PDFFontFace.Helvetica, 12) fontHeader.Bold = True Dim borderColor As New PDFPen(New PDFRgbColor(), 1) Dim textColor As New PDFBrush(New PDFRgbColor()) Dim headerFill As New PDFBrush(New PDFRgbColor(192, 192, 192)) ' Draw the header pdfPage.Canvas.DrawRectangle(borderColor, headerFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, headerHeight) Dim i As Integer Dim xOffset As Single = leftMargin ' Draw the columns separators i = 0 While i < columnsWidth.Length - 1 xOffset = xOffset + columnsWidth(i) pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + headerHeight) i = i + 1 End While xOffset = leftMargin ' Draw the columns header i = 0 While i < columnsWidth.Length pdfPage.Canvas.DrawText(columnsHeader(i), fontHeader, Nothing, textColor, xOffset + columnsWidth(i) / 2, topOffset + headerHeight / 2, _ 0, PDFTextAlign.MiddleCenter) xOffset = xOffset + columnsWidth(i) i = i + 1 End While End Sub Private Shared Sub DrawReportRow(pdfPage As PDFPage, topOffset As Single, row As DataRow) ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim borderColor As New PDFPen(New PDFRgbColor(), 1) Dim textColor As New PDFBrush(New PDFRgbColor()) Dim headerFill As New PDFBrush(New PDFRgbColor(192, 192, 192)) ' Draw rows borders Dim points As PDFPoint() = {New PDFPoint(leftMargin, topOffset), New PDFPoint(leftMargin, topOffset + rowHeight), New PDFPoint(pdfPage.Width - rightMargin, topOffset + rowHeight), New PDFPoint(pdfPage.Width - rightMargin, topOffset)} pdfPage.Canvas.DrawLines(borderColor, points) Dim i As Integer Dim xOffset As Single = leftMargin ' Draw the columns separators i = 0 While i < columnsWidth.Length - 1 xOffset = xOffset + columnsWidth(i) pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + rowHeight) i = i + 1 End While xOffset = leftMargin ' Draw the columns header i = 0 While i < columnsWidth.Length pdfPage.Canvas.DrawText(DirectCast(row(i), String), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _ 0, PDFTextAlign.MiddleLeft) xOffset = xOffset + columnsWidth(i) i = i + 1 End While End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Sin(x) Graph
This sample shows how to use user defined logical units, define them and change the current logical unit during the drawing process. It will also show how to move the coordinate system in order to better fit the drawing needs. The sample will draw the graph of Sin(x) function, using 3 different user defined logical units. These 3 units will be equal on X axis, but they will be different on Y axis.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Sinus.cs
using System; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Sinus { /// <summary> /// This sample shows how to use user defined logical units, /// define them and change the current logical unit /// during the drawing process. It will also show how to move /// the coordinate system in order to better fit the drawing needs. /// The sample will draw the graph of Sin(x) function, using 3 /// different user defined logical units. These 3 units will be /// equal on X axis, but they will be different on Y axis. /// </summary> class Sinus { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1); PDFPen bluePen = new PDFPen(new PDFRgbColor(0, 0, 192), 1); PDFPen greenPen = new PDFPen(new PDFRgbColor(0, 192, 0), 1); // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); // Create first page of the document PDFPage page = pdfDoc.AddPage(); // Setup Graph (draw axes, draw labels) SetupGraph(page); // Create a new logical unit CustomUnit1 un1 = new CustomUnit1(); DrawGraph(page, un1, redPen); // Create a new logical unit CustomUnit2 un2 = new CustomUnit2(); DrawGraph(page, un2, bluePen); // Create an inch logical unit PDFInchLogicalUnit inch = new PDFInchLogicalUnit(); DrawGraph(page, inch, greenPen); // Save the document to disk pdfDoc.Save("Sample_Sinus.pdf"); } public static void SetupGraph(PDFPage page) { // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 10); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFPen blackPen = new PDFPen(new PDFRgbColor(), 1); page.Canvas.DrawText("Sin(x) graph", fontText, null, blackBrush, 50, 50); PDFTextFormatOptions tfo = new PDFTextFormatOptions(); tfo.LineSpacing = 2; tfo.ClipText = PDFClipText.ClipNone; page.Canvas.DrawTextBox("All 3 graphs are drawn at the same logical " + "position on the page. The difference between them is the logical " + "unit that has been used for drawing each graph. Each logical unit " + "performed a different mapping between the logical position and the " + "physical position on the page.", fontText, null, blackBrush, 50, 70, 250, 0, tfo); // Move the origin of the coordinate system to the // center of the page page.Canvas.SetOrigin(page.Width / 2, page.Height / 2); // Draw the axes of the coordinate system // Draw the Y axis. Adjust 50 pixels to have // some space between the end of the axis and // the page margin. page.Canvas.DrawLine(blackPen, 0, -(page.Height / 2 - 50), 0, page.Height / 2 - 50); // Draw the X axis. page.Canvas.DrawLine(blackPen, -(page.Width / 2 - 50), 0, page.Width / 2 - 50, 0); page.Canvas.DrawText("0", fontText, null, blackBrush, 1, 1); page.Canvas.DrawText("x", fontText, null, blackBrush, page.Width / 2 - 55, 1); page.Canvas.DrawText("y", fontText, null, blackBrush, 1, -page.Height / 2 + 50); // Set the direction of Y axis to BottomToTop // and leave the X axis unchanged page.Canvas.SetAxesDirection(PDFXAxisDirection.LeftToRight, PDFYAxisDirection.BottomToTop); } /// <summary> /// Draws the Sin(x) graph on the given page using the specified logical unit. /// </summary> /// <param name="page">The page to draw to.</param> /// <param name="lu">The logical unit used to position the graph.</param> /// <param name="pen">The pen used to draw the graph.</param> public static void DrawGraph(PDFPage page, PDFLogicalUnitBase lu, PDFPen pen) { double x, y; // Set the unit for the page page.Canvas.SetLogicalUnit(lu); pen.Width = pen.Width / lu.ToPDFUnitY(1); // i goes from -180 degrees to 180 degrees (=Math.PI) PDFPoint[] points = new PDFPoint[361]; for (int i = -180; i <= 180; i++) { x = (float)(i * Math.PI / 180); y = (float)Math.Sin(x); points[i + 180] = new PDFPoint(x, y); } page.Canvas.DrawLines(pen, points); } } /// <summary> /// Defines a custom unit that specifies different mappings for X /// and Y axis. The unit on Y axis equals to 3 inch (3*72 points), /// and the unit on X axis equals 1 inch. /// </summary> class CustomUnit1 : PDFLogicalUnitBase { public CustomUnit1() { } public override double ToPDFUnitX(double unit) { return unit * 72; } public override double ToPDFUnitY(double unit) { return unit * 72 * 3; } } /// <summary> /// Defines a custom unit that specifies different mappings for X /// and Y axis. The unit on Y axis equals to 2 inch (2*72 points), /// and the unit on X axis equals 1 inch. /// </summary> class CustomUnit2 : PDFLogicalUnitBase { public CustomUnit2() { } public override double ToPDFUnitX(double unit) { return unit * 72; } public override double ToPDFUnitY(double unit) { return unit * 72 * 2; } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Sinus.vb
Imports System Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Sinus ''' <summary> ''' This sample shows how to use user defined logical units, ''' define them and change the current logical unit ''' during the drawing process. It will also show how to move ''' the coordinate system in order to better fit the drawing needs. ''' The sample will draw the graph of Sin(x) function, using 3 ''' different user defined logical units. These 3 units will be ''' equal on X axis, but they will be different on Y axis. ''' </summary> Class Sinus ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1) Dim bluePen As New PDFPen(New PDFRgbColor(0, 0, 192), 1) Dim greenPen As New PDFPen(New PDFRgbColor(0, 192, 0), 1) ' Create the pdf document Dim pdfDoc As New PDFDocument() ' Create first page of the document Dim page As PDFPage = pdfDoc.AddPage() ' Setup Graph (draw axes, draw labels) SetupGraph(page) ' Create a new logical unit Dim un1 As New CustomUnit1() DrawGraph(page, un1, redPen) ' Create a new logical unit Dim un2 As New CustomUnit2() DrawGraph(page, un2, bluePen) ' Create an inch logical unit Dim inch As New PDFInchLogicalUnit() DrawGraph(page, inch, greenPen) ' Save the document to disk pdfDoc.Save("Sample_Sinus.pdf") End Sub Public Shared Sub SetupGraph(page As PDFPage) ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 10) Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim blackPen As New PDFPen(New PDFRgbColor(), 1) page.Canvas.DrawText("Sin(x) graph", fontText, Nothing, blackBrush, 50, 50) Dim tfo As New PDFTextFormatOptions() tfo.LineSpacing = 2 tfo.ClipText = PDFClipText.ClipNone page.Canvas.DrawTextBox("All 3 graphs are drawn at the same logical " + "position on the page. The difference between them is the logical " + "unit that has been used for drawing each graph. Each logical unit " + "performed a different mapping between the logical position and the " + "physical position on the page.", fontText, Nothing, blackBrush, 50, 70, _ 250, 0, tfo) ' Move the origin of the coordinate system to the ' center of the page page.Canvas.SetOrigin(page.Width / 2, page.Height / 2) ' Draw the axes of the coordinate system ' Draw the Y axis. Adjust 50 pixels to have ' some space between the end of the axis and ' the page margin. page.Canvas.DrawLine(blackPen, 0, -(page.Height / 2 - 50), 0, page.Height / 2 - 50) ' Draw the X axis. page.Canvas.DrawLine(blackPen, -(page.Width / 2 - 50), 0, page.Width / 2 - 50, 0) page.Canvas.DrawText("0", fontText, Nothing, blackBrush, 1, 1) page.Canvas.DrawText("x", fontText, Nothing, blackBrush, page.Width / 2 - 55, 1) page.Canvas.DrawText("y", fontText, Nothing, blackBrush, 1, -page.Height / 2 + 50) ' Set the direction of Y axis to BottomToTop ' and leave the X axis unchanged page.Canvas.SetAxesDirection(PDFXAxisDirection.LeftToRight, PDFYAxisDirection.BottomToTop) End Sub ''' <summary> ''' Draws the Sin(x) graph on the given page using the specified logical unit. ''' </summary> ''' <param name="page">The page to draw to.</param> ''' <param name="lu">The logical unit used to position the graph.</param> ''' <param name="pen">The pen used to draw the graph.</param> Public Shared Sub DrawGraph(page As PDFPage, lu As PDFLogicalUnitBase, pen As PDFPen) Dim x As Double, y As Double ' Set the unit for the page page.Canvas.SetLogicalUnit(lu) pen.Width = pen.Width / lu.ToPDFUnitY(1) ' i goes from -180 degrees to 180 degrees (=Math.PI) Dim points As PDFPoint() = New PDFPoint(360) {} Dim i As Integer = -180 While i <= 180 x = i * Math.PI / 180 y = Math.Sin(x) points(i + 180) = New PDFPoint(x, y) i = i + 1 End While page.Canvas.DrawLines(pen, points) End Sub End Class ''' <summary> ''' Defines a custom unit that specifies different mappings for X ''' and Y axis. The unit on Y axis equals to 3 inch (3*72 points), ''' and the unit on X axis equals 1 inch. ''' </summary> Class CustomUnit1 Inherits PDFLogicalUnitBase Public Sub New() End Sub Public Overloads Overrides Function ToPDFUnitX(unit As Double) As Double Return unit * 72 End Function Public Overloads Overrides Function ToPDFUnitY(unit As Double) As Double Return unit * 72 * 3 End Function End Class ''' <summary> ''' Defines a custom unit that specifies different mappings for X ''' and Y axis. The unit on Y axis equals to 2 inch (2*72 points), ''' and the unit on X axis equals 1 inch. ''' </summary> Class CustomUnit2 Inherits PDFLogicalUnitBase Public Sub New() End Sub Public Overloads Overrides Function ToPDFUnitX(unit As Double) As Double Return unit * 72 End Function Public Overloads Overrides Function ToPDFUnitY(unit As Double) As Double Return unit * 72 * 2 End Function End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Stamp PDF
This sample shows how to stamp a PDF file. A PDF file can be stamped with any combination of text, graphics, images and annotations. The stamps can be opaque or transparent. First page in the sample is stamped with a rubber stamp annotation, second page is stamped with regular text and third page is stamped with a transparent image.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


StampPDF.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Annotations; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.StampPDF { /// <summary> /// This sample shows how to stamp existing PDF files with stamp annotations, text or images. /// </summary> class StampPDF { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Import the pdf document PDFDocument doc = new PDFDocument("..\\SupportFiles\\sample.pdf"); // stamp first page with a rubber stamp annotation. PDFRubberStampAnnotation rsa = new PDFRubberStampAnnotation("Approved", "This document has been approved."); rsa.Icon = PDFRubberStampAnnotationIcon.Approved; rsa.DisplayRectangle = new DisplayRectangle(50, 50, 500, 100); // make the stamp transparent, so the text behind it is visible rsa.Opacity = 50; doc.Pages[0].Annotations.Add(rsa); // stamp second page with regular text. PDFFont font = new PDFFont(PDFFontFace.Helvetica, 96); font.Bold = true; PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(Color.Green)); // make the stamp transparent doc.Pages[1].Canvas.SetTransparency(50); doc.Pages[1].Canvas.DrawText("Approved", font, null, greenBrush, doc.Pages[1].Width / 2, 120, 20, PDFTextAlign.MiddleCenter); doc.Pages[1].Canvas.SetTransparency(0); // stamp third page with an image. // make the stamp transparent doc.Pages[2].Canvas.SetTransparency(50); doc.Pages[2].Canvas.DrawImage("..\\SupportFiles\\auto1.jpg", 200, 500, 300, 1, 20, PDFKeepAspectRatio.KeepWidth); doc.Pages[2].Canvas.SetTransparency(0); // Save the document to disk doc.Save("Sample_StampPDF.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


StampPDF.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Annotations Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.StampPDF ''' <summary> ''' This sample shows how to stamp existing PDF files with stamp annotations, text or images. ''' </summary> Class StampPDF ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Import the pdf document Dim doc As New PDFDocument("..\SupportFiles\sample.pdf") ' stamp first page with a rubber stamp annotation. Dim rsa As New PDFRubberStampAnnotation("Approved", "This document has been approved.") rsa.Icon = PDFRubberStampAnnotationIcon.Approved rsa.DisplayRectangle = New DisplayRectangle(50, 50, 500, 100) ' make the stamp transparent, so the text behind it is visible rsa.Opacity = 50 doc.Pages(0).Annotations.Add(rsa) ' stamp second page with regular text. Dim font As New PDFFont(PDFFontFace.Helvetica, 96) font.Bold = True Dim greenBrush As New PDFBrush(New PDFRgbColor(Color.Green)) ' make the stamp transparent doc.Pages(1).Canvas.SetTransparency(50) doc.Pages(1).Canvas.DrawText("Approved", font, Nothing, greenBrush, doc.Pages(1).Width / 2, 120, _ 20, PDFTextAlign.MiddleCenter) doc.Pages(1).Canvas.SetTransparency(0) ' stamp third page with an image. ' make the stamp transparent doc.Pages(2).Canvas.SetTransparency(50) doc.Pages(2).Canvas.DrawImage("..\SupportFiles\auto1.jpg", 200, 500, 300, 1, 20, _ PDFKeepAspectRatio.KeepWidth) doc.Pages(2).Canvas.SetTransparency(0) ' Save the document to disk doc.Save("Sample_StampPDF.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: TextBoxes
This samples shows the columnar text drawing capabilities of the PDF4NET library. On the first page, it shows all the possible alignments of the text inside a box. On the second page is shows how to draw rotated text boxes or how the constrain the text to stay inside the box. It also shows how the text can be let to flow out of the box if it does not fit inside it. The text uses Verdana font for display.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


TextBoxes.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.TextBoxes { /// <summary> /// This sample will show the available possibilities /// for columnar text formatting. /// </summary> class TextBoxes { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); TrueTypeFont ttf = new TrueTypeFont("..\\SupportFiles\\verdana.ttf", 12, true); DrawFirstPage(pdfDoc, ttf); DrawSecondPage(pdfDoc, ttf); // Save the document to disk pdfDoc.Save("Sample_TextBoxes.pdf"); } //private static void DrawFirstPage( PDFDocument pdfDoc, TrueTypeFont fnt ) private static void DrawFirstPage(PDFDocument pdfDoc, PDFFontBase fnt) { // Create first page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1); // Draw the bounding boxes pdfPage.Canvas.DrawRectangle(redPen, null, 20, 20, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 190, 20, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 360, 20, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 20, 190, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 190, 190, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 360, 190, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 20, 360, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 190, 360, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 360, 360, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 20, 530, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 190, 530, 150, 150, 0); pdfPage.Canvas.DrawRectangle(redPen, null, 360, 530, 150, 150, 0); // Draw the text // Top align PDFTextFormatOptions tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.TopLeft; tfo.ClipText = PDFClipText.ClipNone; pdfPage.Canvas.DrawTextBox("These lines of text are top left aligned. These lines of text are top left aligned.", fnt, null, blackBrush, 20, 20, 150, 150, tfo); tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.TopCenter; pdfPage.Canvas.DrawTextBox("These lines of text are top center aligned. These lines of text are top center aligned.", fnt, null, blackBrush, 190, 20, 150, 150, tfo); tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.TopRight; pdfPage.Canvas.DrawTextBox("These lines of text are top right aligned. These lines of text are top right aligned.", fnt, null, blackBrush, 360, 20, 150, 150, tfo); // Middle align tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.MiddleLeft; pdfPage.Canvas.DrawTextBox("These lines of text are middle left aligned. These lines of text are middle left aligned.", fnt, null, blackBrush, 20, 190, 150, 150, tfo); tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.MiddleCenter; pdfPage.Canvas.DrawTextBox("These lines of text are middle center aligned. These lines of text are middle center aligned.", fnt, null, blackBrush, 190, 190, 150, 150, tfo); tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.MiddleRight; pdfPage.Canvas.DrawTextBox("These lines of text are middle right aligned. These lines of text are middle right aligned.", fnt, null, blackBrush, 360, 190, 150, 150, tfo); // Bottom align tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.BottomLeft; pdfPage.Canvas.DrawTextBox("These lines of text are bottom left aligned. These lines of text are bottom left aligned.", fnt, null, blackBrush, 20, 360, 150, 150, tfo); tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.BottomCenter; pdfPage.Canvas.DrawTextBox("These lines of text are bottom center aligned. These lines of text are bottom center aligned.", fnt, null, blackBrush, 190, 360, 150, 150, tfo); tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.BottomRight; pdfPage.Canvas.DrawTextBox("These lines of text are bottom right aligned. These lines of text are bottom right aligned.", fnt, null, blackBrush, 360, 360, 150, 150, tfo); // Justification tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.TopJustified; pdfPage.Canvas.DrawTextBox("These lines of text are top justify aligned. These lines of text are top justify aligned.", fnt, null, blackBrush, 20, 530, 150, 150, tfo); tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.MiddleJustified; pdfPage.Canvas.DrawTextBox("These lines of text are middle justify aligned. These lines of text are middle justify aligned.", fnt, null, blackBrush, 190, 530, 150, 150, tfo); tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.BottomJustified; pdfPage.Canvas.DrawTextBox("These lines of text are bottom justify aligned. These lines of text are bottom justify justify aligned.", fnt, null, blackBrush, 360, 530, 150, 150, tfo); } //private static void DrawSecondPage( PDFDocument pdfDoc, TrueTypeFont fnt ) private static void DrawSecondPage(PDFDocument pdfDoc, PDFFontBase fnt) { // Create first page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1); // Draw a label pdfPage.Canvas.DrawText("Rotated text box", fnt, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); // Draw the bounding boxes pdfPage.Canvas.DrawRectangle(redPen, null, 190, 100, 150, 150, 30); // Draw the text PDFTextFormatOptions tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.TopLeft; tfo.Orientation = 30; pdfPage.Canvas.DrawTextBox("This text box is rotated with 30 degrees around " + "the top left corner. The red border does not belong to the text box. It has " + "been drawn using DrawRectangle( ) method.", fnt, null, blackBrush, 190, 100, 150, 150, tfo); // Draw a label pdfPage.Canvas.DrawText("Clipped text", fnt, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft); // Draw the bounding boxes pdfPage.Canvas.DrawRectangle(redPen, null, 20, 315, 150, 53, 0); // Draw the text tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.TopLeft; pdfPage.Canvas.DrawTextBox("This text is not allowed to get out of the box. " + "This is the default behavior of the text box. The last line will be clipped.", fnt, null, blackBrush, 20, 315, 150, 53, tfo); // Draw a label pdfPage.Canvas.DrawText("Flow out text", fnt, null, blackBrush, 300, 300, 0, PDFTextAlign.TopLeft); // Draw the bounding boxes pdfPage.Canvas.DrawRectangle(redPen, null, 300, 315, 150, 53, 0); // Draw the text tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.TopLeft; tfo.ClipText = PDFClipText.ClipNone; tfo.LineSpacing = 5; pdfPage.Canvas.DrawTextBox("This text is allowed to get out of the box. " + "This behavior can be enforced by setting the clipText parameter to true." + "As it can be seen, the text can flow out of the box. " + "Also, for this sample, the line spacing has been increased with 5 points.", fnt, null, blackBrush, 300, 315, 150, 53, tfo); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


TextBoxes.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.TextBoxes ''' <summary> ''' This sample will show the available possibilities ''' for columnar text formatting. ''' </summary> Class TextBoxes ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() Dim ttf As New TrueTypeFont("..\SupportFiles\verdana.ttf", 12, True) DrawFirstPage(pdfDoc, ttf) DrawSecondPage(pdfDoc, ttf) ' Save the document to disk pdfDoc.Save("Sample_TextBoxes.pdf") End Sub 'private static void DrawFirstPage( PDFDocument pdfDoc, TrueTypeFont fnt ) Private Shared Sub DrawFirstPage(pdfDoc As PDFDocument, fnt As PDFFontBase) ' Create first page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1) ' Draw the bounding boxes pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 20, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 20, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 360, 20, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 190, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 190, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 360, 190, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 360, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 360, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 360, 360, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 530, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 530, 150, 150, _ 0) pdfPage.Canvas.DrawRectangle(redPen, Nothing, 360, 530, 150, 150, _ 0) ' Draw the text ' Top align Dim tfo As New PDFTextFormatOptions() tfo.Align = PDFTextAlign.TopLeft tfo.ClipText = PDFClipText.ClipNone pdfPage.Canvas.DrawTextBox("These lines of text are top left aligned. These lines of text are top left aligned.", fnt, Nothing, blackBrush, 20, 20, _ 150, 150, tfo) tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.TopCenter pdfPage.Canvas.DrawTextBox("These lines of text are top center aligned. These lines of text are top center aligned.", fnt, Nothing, blackBrush, 190, 20, _ 150, 150, tfo) tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.TopRight pdfPage.Canvas.DrawTextBox("These lines of text are top right aligned. These lines of text are top right aligned.", fnt, Nothing, blackBrush, 360, 20, _ 150, 150, tfo) ' Middle align tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.MiddleLeft pdfPage.Canvas.DrawTextBox("These lines of text are middle left aligned. These lines of text are middle left aligned.", fnt, Nothing, blackBrush, 20, 190, _ 150, 150, tfo) tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.MiddleCenter pdfPage.Canvas.DrawTextBox("These lines of text are middle center aligned. These lines of text are middle center aligned.", fnt, Nothing, blackBrush, 190, 190, _ 150, 150, tfo) tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.MiddleRight pdfPage.Canvas.DrawTextBox("These lines of text are middle right aligned. These lines of text are middle right aligned.", fnt, Nothing, blackBrush, 360, 190, _ 150, 150, tfo) ' Bottom align tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.BottomLeft pdfPage.Canvas.DrawTextBox("These lines of text are bottom left aligned. These lines of text are bottom left aligned.", fnt, Nothing, blackBrush, 20, 360, _ 150, 150, tfo) tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.BottomCenter pdfPage.Canvas.DrawTextBox("These lines of text are bottom center aligned. These lines of text are bottom center aligned.", fnt, Nothing, blackBrush, 190, 360, _ 150, 150, tfo) tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.BottomRight pdfPage.Canvas.DrawTextBox("These lines of text are bottom right aligned. These lines of text are bottom right aligned.", fnt, Nothing, blackBrush, 360, 360, _ 150, 150, tfo) ' Justification tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.TopJustified pdfPage.Canvas.DrawTextBox("These lines of text are top justify aligned. These lines of text are top justify aligned.", fnt, Nothing, blackBrush, 20, 530, _ 150, 150, tfo) tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.MiddleJustified pdfPage.Canvas.DrawTextBox("These lines of text are middle justify aligned. These lines of text are middle justify aligned.", fnt, Nothing, blackBrush, 190, 530, _ 150, 150, tfo) tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.BottomJustified pdfPage.Canvas.DrawTextBox("These lines of text are bottom justify aligned. These lines of text are bottom justify justify aligned.", fnt, Nothing, blackBrush, 360, 530, _ 150, 150, tfo) End Sub 'private static void DrawSecondPage( PDFDocument pdfDoc, TrueTypeFont fnt ) Private Shared Sub DrawSecondPage(pdfDoc As PDFDocument, fnt As PDFFontBase) ' Create first page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1) ' Draw a label pdfPage.Canvas.DrawText("Rotated text box", fnt, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) ' Draw the bounding boxes pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 100, 150, 150, _ 30) ' Draw the text Dim tfo As New PDFTextFormatOptions() tfo.Align = PDFTextAlign.TopLeft tfo.Orientation = 30 pdfPage.Canvas.DrawTextBox("This text box is rotated with 30 degrees around " + "the top left corner. The red border does not belong to the text box. It has " + "been drawn using DrawRectangle( ) method.", fnt, Nothing, blackBrush, 190, 100, _ 150, 150, tfo) ' Draw a label pdfPage.Canvas.DrawText("Clipped text", fnt, Nothing, blackBrush, 20, 300, _ 0, PDFTextAlign.TopLeft) ' Draw the bounding boxes pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 315, 150, 53, _ 0) ' Draw the text tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.TopLeft pdfPage.Canvas.DrawTextBox("This text is not allowed to get out of the box. " + "This is the default behavior of the text box. The last line will be clipped.", fnt, Nothing, blackBrush, 20, 315, _ 150, 53, tfo) ' Draw a label pdfPage.Canvas.DrawText("Flow out text", fnt, Nothing, blackBrush, 300, 300, _ 0, PDFTextAlign.TopLeft) ' Draw the bounding boxes pdfPage.Canvas.DrawRectangle(redPen, Nothing, 300, 315, 150, 53, _ 0) ' Draw the text tfo = New PDFTextFormatOptions() tfo.Align = PDFTextAlign.TopLeft tfo.ClipText = PDFClipText.ClipNone tfo.LineSpacing = 5 pdfPage.Canvas.DrawTextBox("This text is allowed to get out of the box. " + "This behavior can be enforced by setting the clipText parameter to true." + "As it can be seen, the text can flow out of the box. " + "Also, for this sample, the line spacing has been increased with 5 points.", fnt, Nothing, blackBrush, 300, 315, _ 150, 53, tfo) End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: TextExtract

This sample shows how to extract the text from a PDF page.

C# Source code | VB.NET Source code

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


TextExtract.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.PDFFile; namespace O2S.Samples.PDF4NET.TextExtract { /// <summary> /// This sample shows how to extract text from an existing pdf file. /// </summary> class TextExtract { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument("..\\SupportFiles\\Sample.pdf"); for (int i = 0; i < pdfDoc.Pages.Count; i++) { PDFImportedPage ip = pdfDoc.Pages[i] as PDFImportedPage; Console.WriteLine("Page {0}:", i + 1); string text = ip.ExtractText(); Console.WriteLine(text); } pdfDoc.Dispose(); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


TextExtract.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.PDFFile Namespace O2S.Samples.PDF4NET.TextExtract ''' <summary> ''' This sample shows how to extract text from an existing pdf file. ''' </summary> Class TextExtract ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread()> _ Shared Sub Main(ByVal args As String()) ' Load the pdf document Dim pdfDoc As New PDFDocument("..\SupportFiles\Sample.pdf") Dim i As Integer = 0 While i < pdfDoc.Pages.Count Dim ip As PDFImportedPage = pdfDoc.Pages(i) Console.WriteLine("Page {0}:", i + 1) Dim text As String = ip.ExtractText() Console.WriteLine(text) i = i + 1 End While pdfDoc.Dispose() End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: TextLines
This samples shows the single line text drawing capabilities of the PDF4NET library. On the first page, it shows all the supported fonts. On the second page, it shows how to draw rotated text at random positions and of random size. On the third page it shows all the possible alignments for text lines.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


TextLines.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.TextLines { struct PrintFont { public PrintFont(PDFFontFace fontFace, bool bold, bool italic) { PDFFontFace = fontFace; Bold = bold; Italic = italic; } public override string ToString() { string s = PDFFontFace.ToString(); if (Bold) { s = s + "Bold"; } if (Italic) { s = s + "Italic"; } return s; } public PDFFontFace PDFFontFace; public bool Bold; public bool Italic; } /// <summary> /// This sample will show various possibilities to draw text on page /// </summary> class TextLines { static PrintFont[] fonts = { new PrintFont( PDFFontFace.Helvetica, false, false ), new PrintFont( PDFFontFace.Helvetica, true, false ), new PrintFont( PDFFontFace.Helvetica, false, true ), new PrintFont( PDFFontFace.Helvetica, true, true ), new PrintFont( PDFFontFace.Courier, false, false ), new PrintFont( PDFFontFace.Courier, true, false ), new PrintFont( PDFFontFace.Courier, false, true ), new PrintFont( PDFFontFace.Courier, true, true ), new PrintFont( PDFFontFace.TimesRoman, false, false ), new PrintFont( PDFFontFace.TimesRoman, true, false ), new PrintFont( PDFFontFace.TimesRoman, false, true ), new PrintFont( PDFFontFace.TimesRoman, true, true ) }; /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument(); DrawFirstPage(pdfDoc); DrawSecondPage(pdfDoc); DrawThirdPage(pdfDoc); // Save the document to disk pdfDoc.Save("Sample_TextLines.pdf"); } private static void DrawFirstPage(PDFDocument pdfDoc) { // Create first page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12); PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); for (int i = 0; i < fonts.Length; i++) { PDFFont font = new PDFFont(fonts[i].PDFFontFace, 12); font.Bold = fonts[i].Bold; font.Italic = fonts[i].Italic; pdfPage.Canvas.DrawText("This font is " + fonts[i].ToString() + " size 12", font, null, blackBrush, 20, (i + 1) * 20, 0, PDFTextAlign.TopLeft); } for (int i = 0; i < fonts.Length; i++) { PDFFont font = new PDFFont(fonts[i].PDFFontFace, 16); font.Bold = fonts[i].Bold; font.Italic = fonts[i].Italic; pdfPage.Canvas.DrawText("This font is " + fonts[i].ToString() + " size 16", font, null, blackBrush, 20, 300 + (i + 1) * 20, 0, PDFTextAlign.TopLeft); } } private static void DrawSecondPage(PDFDocument pdfDoc) { // Create first page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); Random rnd = new Random(); for (int i = 0; i < 50; i++) { // Random position int x = rnd.Next((int)pdfPage.Width); int y = rnd.Next((int)pdfPage.Height); // Random text size int fontSize = rnd.Next(16); // Random orientation int orientation = rnd.Next(360); // Random font face int fontFaceIndex = rnd.Next(fonts.Length); // Create random colors for drawing the text PDFColor brushColor = new PDFRgbColor((byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256)); // Create the brush to draw the text PDFBrush brush = new PDFBrush(brushColor); PDFFont font = new PDFFont(fonts[fontFaceIndex].PDFFontFace, fontSize); font.Italic = fonts[fontFaceIndex].Italic; font.Bold = fonts[fontFaceIndex].Bold; pdfPage.Canvas.DrawText("Font: " + fonts[fontFaceIndex].ToString() + ", size: " + fontSize.ToString() + ", orientation: " + orientation.ToString() + " degrees.", font, null, brush, x, y, orientation, PDFTextAlign.TopLeft); } } private static void DrawThirdPage(PDFDocument pdfDoc) { // Create first page PDFPage pdfPage = pdfDoc.AddPage(); // Create the graphic objects PDFBrush orangeBrush = new PDFBrush(new PDFRgbColor(Color.Orange)); PDFPen pen = new PDFPen(new PDFRgbColor(), 1); PDFFont font2 = new PDFFont(PDFFontFace.Helvetica, 18); // Draw the drid pdfPage.Canvas.DrawLine(pen, 10, 100, 600, 100); pdfPage.Canvas.DrawLine(pen, 10, 300, 600, 300); pdfPage.Canvas.DrawLine(pen, 10, 500, 600, 500); pdfPage.Canvas.DrawLine(pen, 10, 100, 10, 500); pdfPage.Canvas.DrawLine(pen, 300, 100, 300, 500); pdfPage.Canvas.DrawLine(pen, 600, 100, 600, 500); // Draw the labels // Top Align pdfPage.Canvas.DrawText("Top left align", font2, null, orangeBrush, 10, 100, 0, PDFTextAlign.TopLeft); pdfPage.Canvas.DrawText("Top center align", font2, null, orangeBrush, 300, 100, 0, PDFTextAlign.TopCenter); pdfPage.Canvas.DrawText("Top right align", font2, null, orangeBrush, 600, 100, 0, PDFTextAlign.TopRight); // Middle align pdfPage.Canvas.DrawText("Middle left align", font2, null, orangeBrush, 10, 300, 0, PDFTextAlign.MiddleLeft); pdfPage.Canvas.DrawText("Middle center align", font2, null, orangeBrush, 300, 300, 0, PDFTextAlign.MiddleCenter); pdfPage.Canvas.DrawText("Middle right align", font2, null, orangeBrush, 600, 300, 0, PDFTextAlign.MiddleRight); // Right align pdfPage.Canvas.DrawText("Bottom left align", font2, null, orangeBrush, 10, 500, 0, PDFTextAlign.BottomLeft); pdfPage.Canvas.DrawText("Bottom center align", font2, null, orangeBrush, 300, 500, 0, PDFTextAlign.BottomCenter); pdfPage.Canvas.DrawText("Bottom right align", font2, null, orangeBrush, 600, 500, 0, PDFTextAlign.BottomRight); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


TextLines.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.TextLines Structure PrintFont Public Sub New(fontFace As PDFFontFace, bold As Boolean, italic As Boolean) PDFFontFace = fontFace Bold = bold Italic = italic End Sub Public Overloads Overrides Function ToString() As String Dim s As String = PDFFontFace.ToString() If Bold Then s = s + "Bold" End If If Italic Then s = s + "Italic" End If Return s End Function Public PDFFontFace As PDFFontFace Public Bold As Boolean Public Italic As Boolean End Structure ''' <summary> ''' This sample will show various possibilities to draw text on page ''' </summary> Class TextLines Shared fonts As PrintFont() = {New PrintFont(PDFFontFace.Helvetica, False, False), New PrintFont(PDFFontFace.Helvetica, True, False), New PrintFont(PDFFontFace.Helvetica, False, True), New PrintFont(PDFFontFace.Helvetica, True, True), New PrintFont(PDFFontFace.Courier, False, False), New PrintFont(PDFFontFace.Courier, True, False), _ New PrintFont(PDFFontFace.Courier, False, True), New PrintFont(PDFFontFace.Courier, True, True), New PrintFont(PDFFontFace.TimesRoman, False, False), New PrintFont(PDFFontFace.TimesRoman, True, False), New PrintFont(PDFFontFace.TimesRoman, False, True), New PrintFont(PDFFontFace.TimesRoman, True, True)} ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument() DrawFirstPage(pdfDoc) DrawSecondPage(pdfDoc) DrawThirdPage(pdfDoc) ' Save the document to disk pdfDoc.Save("Sample_TextLines.pdf") End Sub Private Shared Sub DrawFirstPage(pdfDoc As PDFDocument) ' Create first page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12) Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim i As Integer = 0 While i < fonts.Length Dim font As New PDFFont(fonts(i).PDFFontFace, 12) font.Bold = fonts(i).Bold font.Italic = fonts(i).Italic pdfPage.Canvas.DrawText("This font is " + fonts(i).ToString() + " size 12", font, Nothing, blackBrush, 20, (i + 1) * 20, _ 0, PDFTextAlign.TopLeft) i = i + 1 End While i = 0 While i < fonts.Length Dim font As New PDFFont(fonts(i).PDFFontFace, 16) font.Bold = fonts(i).Bold font.Italic = fonts(i).Italic pdfPage.Canvas.DrawText("This font is " + fonts(i).ToString() + " size 16", font, Nothing, blackBrush, 20, 300 + (i + 1) * 20, _ 0, PDFTextAlign.TopLeft) i = i + 1 End While End Sub Private Shared Sub DrawSecondPage(pdfDoc As PDFDocument) ' Create first page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim rnd As New Random() Dim i As Integer = 0 While i < 50 ' Random position Dim x As Double = rnd.NextDouble() * pdfPage.Width Dim y As Double = rnd.NextDouble() * pdfPage.Height ' Random text size Dim fontSize As Integer = rnd.Next(16) ' Random orientation Dim orientation As Integer = rnd.Next(360) ' Random font face Dim fontFaceIndex As Integer = rnd.Next(fonts.Length) ' Create random colors for drawing the text Dim brushColor As PDFColor = New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256)) ' Create the brush to draw the text Dim brush As New PDFBrush(brushColor) Dim font As New PDFFont(fonts(fontFaceIndex).PDFFontFace, fontSize) font.Italic = fonts(fontFaceIndex).Italic font.Bold = fonts(fontFaceIndex).Bold pdfPage.Canvas.DrawText("Font: " + fonts(fontFaceIndex).ToString() + ", size: " + fontSize.ToString() + ", orientation: " + orientation.ToString() + " degrees.", font, Nothing, brush, x, y, _ orientation, PDFTextAlign.TopLeft) i = i + 1 End While End Sub Private Shared Sub DrawThirdPage(pdfDoc As PDFDocument) ' Create first page Dim pdfPage As PDFPage = pdfDoc.AddPage() ' Create the graphic objects Dim orangeBrush As New PDFBrush(New PDFRgbColor(Color.Orange)) Dim pen As New PDFPen(New PDFRgbColor(), 1) Dim font2 As New PDFFont(PDFFontFace.Helvetica, 18) ' Draw the drid pdfPage.Canvas.DrawLine(pen, 10, 100, 600, 100) pdfPage.Canvas.DrawLine(pen, 10, 300, 600, 300) pdfPage.Canvas.DrawLine(pen, 10, 500, 600, 500) pdfPage.Canvas.DrawLine(pen, 10, 100, 10, 500) pdfPage.Canvas.DrawLine(pen, 300, 100, 300, 500) pdfPage.Canvas.DrawLine(pen, 600, 100, 600, 500) ' Draw the labels ' Top Align pdfPage.Canvas.DrawText("Top left align", font2, Nothing, orangeBrush, 10, 100, _ 0, PDFTextAlign.TopLeft) pdfPage.Canvas.DrawText("Top center align", font2, Nothing, orangeBrush, 300, 100, _ 0, PDFTextAlign.TopCenter) pdfPage.Canvas.DrawText("Top right align", font2, Nothing, orangeBrush, 600, 100, _ 0, PDFTextAlign.TopRight) ' Middle align pdfPage.Canvas.DrawText("Middle left align", font2, Nothing, orangeBrush, 10, 300, _ 0, PDFTextAlign.MiddleLeft) pdfPage.Canvas.DrawText("Middle center align", font2, Nothing, orangeBrush, 300, 300, _ 0, PDFTextAlign.MiddleCenter) pdfPage.Canvas.DrawText("Middle right align", font2, Nothing, orangeBrush, 600, 300, _ 0, PDFTextAlign.MiddleRight) ' Right align pdfPage.Canvas.DrawText("Bottom left align", font2, Nothing, orangeBrush, 10, 500, _ 0, PDFTextAlign.BottomLeft) pdfPage.Canvas.DrawText("Bottom center align", font2, Nothing, orangeBrush, 300, 500, _ 0, PDFTextAlign.BottomCenter) pdfPage.Canvas.DrawText("Bottom right align", font2, Nothing, orangeBrush, 600, 500, _ 0, PDFTextAlign.BottomRight) End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Tiff2PDF
This sample demonstrates how to convert a multipage tiff file to PDF.

C# Source code | VB.NET Source code

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Tiff2PDF.cs
using System; using System.Drawing; using System.Drawing.Imaging; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Converters; namespace O2S.Samples.PDF4NET.Tiff2PDF { /// <summary> /// This sample shows how to convert a multi page tiff file to pdf /// </summary> class Tiff2PDF { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { PageByPageConversion(); BulkConversion(); } private static void BulkConversion() { PDFConverter.ConvertTiffToPDF("..\\SupportFiles\\Sample.tif", "Sample_Tiff2PDF_Bulk.pdf"); } private static void PageByPageConversion() { // Create the pdf document PDFDocument doc = new PDFDocument(); // Load TIFF file Bitmap bitmap = new Bitmap("..\\SupportFiles\\sample.tif"); // Calculate number of pages/images used in TIFF file FrameDimension frameDimension = new FrameDimension(bitmap.FrameDimensionsList[0]); int framesCount = bitmap.GetFrameCount(frameDimension); for (int i = 0; i < framesCount; i++) { // Create a new page PDFPage page = doc.AddPage(); // draw the current tiff frame on the page PDFImage image = new PDFImage(bitmap, i); page.Canvas.DrawImage(image, 0, 0, page.Width, page.Height, 0, PDFKeepAspectRatio.KeepNone); } doc.Save("Sample_Tiff2PDF_PageByPage.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Tiff2PDF.vb
Imports System Imports System.Drawing Imports System.Drawing.Imaging Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Converters Namespace O2S.Samples.PDF4NET.Tiff2PDF ''' <summary> ''' This sample shows how to convert a multi page tiff file to pdf ''' </summary> Class Tiff2PDF ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread()> _ Shared Sub Main(ByVal args As String()) PageByPageConversion() BulkConversion() End Sub Private Shared Sub BulkConversion() PDFConverter.ConvertTiffToPDF("..\SupportFiles\Sample.tif", "Sample_Tiff2PDF_Bulk.pdf") End Sub Private Shared Sub PageByPageConversion() ' Create the pdf document Dim doc As New PDFDocument() ' Load TIFF file Dim bitmap As New Bitmap("..\SupportFiles\sample.tif") ' Calculate number of pages/images used in TIFF file Dim frameDimension As New FrameDimension(bitmap.FrameDimensionsList(0)) Dim framesCount As Integer = bitmap.GetFrameCount(frameDimension) Dim i As Integer = 0 While i < framesCount ' Create a new page Dim page As PDFPage = doc.AddPage() ' draw the current tiff frame on the page Dim image As New PDFImage(bitmap, i) page.Canvas.DrawImage(image, 0, 0, page.Width, page.Height, 0, PDFKeepAspectRatio.KeepNone) i = i + 1 End While doc.Save("Sample_Tiff2PDF_PageByPage.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Unicode
This samples shows the Unicode capabilities of PDF4NET library. The same text is printed on several pages but translated in various languages. Some of the translations were done automatically, we apologize for any mistakes.

C# Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Unicode.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; using O2S.Components.PDF4NET.Actions; namespace O2S.Samples.PDF4NET.Unicode { public class PageData { public PageData(PDFFontBase font, string language, string text) { Font = font; Language = language; Text = text; } public PDFFontBase Font; public string Language; public string Text; } /// <summary> /// This sample will show the Unicode display capabilities of PDF4NET library. /// </summary> class Unicode { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the fonts to write the text TrueTypeFont ttf = new TrueTypeFont("..\\SupportFiles\\tahoma.ttf", 12, true, true); TrueTypeFont titleFont = new TrueTypeFont(ttf, 16); CJKFont csFont = new CJKFont(CJKFontFace.SinoTypeSongLight, 12); CJKFont ctFont = new CJKFont(CJKFontFace.MonotypeHeiMedium, 12); CJKFont krFont = new CJKFont(CJKFontFace.HanyangSystemsGothicMedium, 12); CJKFont jpFont = new CJKFont(CJKFontFace.HeiseiKakuGothicW5, 12); PageData[] pagesInfo = { new PageData( ttf, "English", "PDF4NET is a .NET library for generating pdf documents " + "on the fly from any .NET application. The library does not rely on any Adobe " + "products for creating pdf files. It hides the complex structure of pdf files " + "behind a simple object model that allows creation of complex pdf files with a few " + "lines of code. The PDF4NET library follows the GDI+ model, thus reducing the " + "learning time and increasing productivity.\n" + "It uses a grid based layout approach allowing precise positioning of content on " + "document's pages. The final pdf file is compressed, making the library apropriate " + "for web applications. The library can be used both from WinForms and WebForms " + "(ASP.NET) applications without any restrictions. The library is written entirely " + "in C#, being 100% managed. The PDF4NET library is licensed per developer and can " + "be distributed ROYALTY FREE, reducing project costs.\n" ), new PageData( csFont, "Chinese Simplified", "PDF4NET 是一个NET 图书馆为正在进行中生成" + "pdf 文件从任一个NET 申请。 图书馆不依靠任何Adobe 产品为创建pdf 文件。 它隐藏pdf " + "文件复杂结构在允许复杂pdf 文件创建以几个代码行的一个简单对象模型之后。 PDF4NET " + "图书馆跟随GDI+ 设计, 如此减少学习时间和增加生产力。它使用网格基于的格式途径允许精" + "确安置目录在文件的页。 最终pdf 文件是压缩的, 使图书馆适当为万维网申请。 图书馆可能" + "被使用从WinForms 和WebForms (ASP.NET) 申请没有任何限制。 图书馆整个地被写在C#, " + "是100% 管理。 PDF4NET 图书馆被准许每开发员, 可能任意是被分配的皇族, 减少项目费用。" ), new PageData( ctFont, "Chinese Traditional", "PDF4NET 是一個NET 圖書館為正在進行中生成" + "pdf 文件從任一個NET 申請。 圖書館不依靠任何Adobe 產品為創建pdf 文件。 它隱藏pdf 文" + "件複雜結構在承認複雜pdf 文件創建以幾個代碼行的一個簡單對象模型之後。 PDF4NET 圖書館" + "跟隨GDI+ 設計, 如此減少學習時間和增加生產力。它使用網格基於的格式途徑允許精確安置目" + "錄在文件的頁。 最終pdf 文件是壓縮的, 使圖書館適當為萬維網申請。 圖書館可能被使用從" + "WinForms 和WebForms (ASP.NET) 申請沒有任何限制。 圖書館整個地被寫在C#, 是100% " + "管理。 PDF4NET 圖書館被准許每開發員, 可能任意是被分配的皇族, 減少項目費用。" ), new PageData( ttf, "Dutch", "PDF4NET is a. NETTO bibliotheek voor het produceren van " + "pdf documenten op de vlieg van om het even welke. NETTO toepassing. De bibliotheek " + "zich baseert niet op enige producten van de Adobe voor het creëren van pdf dossiers. " + "Het verbergt de complexe structuur van pdfdossiers achter een eenvoudig objecten " + "model dat verwezenlijking van complexe pdfdossiers met een paar lijnen van code " + "toestaat. De bibliotheek PDF4NET volgt GDI + model, waarbij de het leren tijd wordt " + "verminderd en het verhogen van productiviteit. Het gebruikt een net gebaseerde " + "lay-outbenadering die het nauwkeurige plaatsen van inhoud op de pagina's van het " + "document toestaat. Het definitieve pdfdossier wordt samengeperst, makend de " + "bibliotheek voor Webtoepassingen aangewezen. De bibliotheek kan zowel van " + "(NETTO ASP.) toepassingen WinForms als WebForms zonder enige beperkingen worden " + "gebruikt. De bibliotheek wordt geschreven volledig in C#, zijnd geleide 100%. " + "De bibliotheek PDF4NET is vergunning gegeven per ontwikkelaar en kan verdeelde " + "VRIJ ROYALTY zijn die, projectkosten drukt.\n" ), new PageData( ttf, "French", "PDF4NET est une bibliothèque de NET pour produire des " + "documents de pdf en marche de n'importe quelle application de NET. La bibliothèque " + "ne se fonde sur aucun produit d'adobe pour créer des fichiers de pdf. Elle cache " + "la structure complexe des fichiers de pdf derrière un modèle simple d'objet qui " + "permet la création des fichiers complexes de pdf avec quelques lignes de code. " + "La bibliothèque de PDF4NET suit le modèle de GDI+, de ce fait réduisant le temps " + "d'étude et augmentant la productivité. Elle utilise une approche de disposition " + "basée par grille permettant le positionnement précis du contenu sur les pages du " + "document. Le fichier final de pdf est comprimé, rendant la bibliothèque appropriée " + "pour des applications de Web. La bibliothèque peut être utilisée des applications " + "de WinForms et de WebForms (ASP.NET) sans aucune restriction. La bibliothèque est " + "écrite entièrement dans C#, étant 100% contrôlé. La bibliothèque de PDF4NET est " + "autorisée par réalisateur et peut être REDEVANCE distribuée LIBREMENT, réduisant " + "des coûts de projet.\n" ), new PageData( ttf, "German", "PDF4NET ist eine NET Bibliothek für pdf Dokumente schnell " + "festlegen von jeder möglicher NET Anwendung. Die Bibliothek beruht nicht auf " + "irgendwelchen Ziegelsteinprodukten für das Herstellen der pdf Dateien. Sie versteckt " + "die komplizierte Struktur der pdf Dateien hinter einem einfachen Nachricht Modell, " + "das Kreation der komplizierten pdf Dateien mit einigen Zeilen des Codes erlaubt. " + "Die PDF4NET Bibliothek folgt dem GDI+ Modell, so verringert die erlernenzeit und " + "erhöht Produktivität. Sie verwendet eine Rasterfeld gegründete Planannäherung, " + "die exakte Positionierung des Inhalts auf Seiten des Dokumentes erlaubend. Die " + "abschließende pdf Datei wird komprimiert und bildet die Bibliothek passend für " + "Web-Anwendungen. Die Bibliothek kann WinForms und WebForms (ASP.NET) von den " + "Anwendungen ohne irgendwelche Beschränkungen benutzt werden. Die Bibliothek wird " + "völlig in C# geschrieben und ist gehandhabtes 100%. Die PDF4NET Bibliothek wird pro " + "Entwickler genehmigt und kann verteilte ABGABE FREI sein und verringert Projektkosten.\n" ), new PageData( ttf, "Greek", "PDF4NET είναι βιβλιοθήκη δικτύου α. για την παραγωγή pdf των " + "εγγράφων σχετικά με τη μύγα από οποιαδήποτε. εφαρμογή δικτύου. Η βιβλιοθήκη δεν " + "στηρίζεται σε οποιαδήποτε προϊόντα πλίθας για τη δημιουργία pdf των αρχείων. Κρύβει " + "τη σύνθετη δομή των αρχείων pdf πίσω από ένα απλό μοντέλο αντικειμένου που επιτρέπει " + "τη δημιουργία των σύνθετων αρχείων pdf με μερικές γραμμές κώδικα. Η βιβλιοθήκη " + "PDF4NET ακολουθεί GDI + το μοντέλο, μειώνοντας κατά συνέπεια το χρόνο εκμάθησης και " + "αύξηση της παραγωγικότητας. Χρησιμοποιεί μια βασισμένη στο πλέγμα προσέγγιση " + "σχεδιαγράμματος που επιτρέπει τον ακριβή προσδιορισμό θέσης του περιεχομένου στις " + "σελίδες του εγγράφου. Το τελικό αρχείο pdf συμπιέζεται, καθιστώντας τη βιβλιοθήκη " + "αρμόδια για τις εφαρμογές Ιστού. Η βιβλιοθήκη μπορεί να χρησιμοποιηθεί και από " + "(ASP. δίκτυο) τις εφαρμογές WinForms και WebForms χωρίς οποιουσδήποτε περιορισμούς. " + "Η βιβλιοθήκη γράφεται εξ ολοκλήρου C#, όντας 100% διοικούμενο. Η βιβλιοθήκη " + "PDF4NET είναι χορηγημένη άδεια ανά υπεύθυνο για την ανάπτυξη και μπορεί να είναι " + "διανεμημένο ΔΙΚΑΊΩΜΑ ΕΛΕΎΘΕΡΟ, που μειώνει τις δαπάνες προγράμματος.\n" ), new PageData( ttf, "Italian", "PDF4NET proviene una libreria del NET per la generazione " + "dei documenti del pdf in moto da tutta l'applicazione del NET. La libreria non " + "conta su alcuni prodotti dell'adobe per la creazione degli archivi del pdf. " + "Nasconde la struttura complessa degli archivi del pdf dietro un modello semplice " + "dell'oggetto che permette la creazione degli archivi complessi del pdf con alcune " + "righe del codice. La libreria di PDF4NET segue il modello di GDI+, così riducendo " + "il tempo imparante ed aumentando il rendimento. Usa un metodo della disposizione " + "basato griglia permettendo posizionare preciso del soddisfare alle pagine del " + "documento. L'archivio finale del pdf è compresso, rendente la libreria adatta per " + "le applicazioni di Web. La libreria può essere usata sia dalle applicazioni di " + "WebForms che di WinForms (ASP.NET) senza alcune limitazioni. La libreria è " + "scritta interamente in C#, essendo 100% gestito. La libreria di PDF4NET è " + "autorizzata per sviluppatore e può essere la SOVRANITÀ distribuita LIBERAMENTE, " + "riducendo i costi di progetto.\n" ), new PageData( jpFont, "Japanese", "PDF4NET はあらゆるNET のアプリケーションからPDF " + "文書をオンザフライ式で生成する為のNET ライブラリである。 ライブラリはPDF ファイ" + "ルを作成する為のAdobe あらゆるプロダクトに頼らない。 それは少数のコード行が付い" + "ている複雑なPDF ファイルの作成を可能にする簡単なオブジェクトモデルの後ろのPDF フ" + "ァイルの複雑な構造を隠す。 従ってPDF4NET ライブラリはGDI+ モデルに続き、学習時間" + "を減らし、生産性を高める。それは格子によって基づかせているレイアウトのアプローチ" + "を使用し文書のページの内容の精密な位置を許可する。 最終的なPDF ファイルは圧縮され" + "て、ライブラリを網アプリケーションのために適切にさせる。 ライブラリは制限のない" + "WinForms 及びWebForms (ASP.NET) アプリケーションから両方使用することができる。 " + "ライブラリはでC# 完全に書かれ、管理される100% である。 PDF4NET ライブラリは1 開" + "発者につき認可され、分散特許権使用料自由にである場合もありプロジェクトのコストを" + "削減する。" ), new PageData( krFont, "Korean", "PDF4NET은 어떤NET응용에서pdf문서를 몰래 생성하기를 " + "위해NET도서관 이다. 도서관은pdf파일을 만들기를 위해Adobe어떤 제품에 의지하지 않는" + "다. 그것은 약간 코드 행에 복잡한pdf파일의 창조를 허용하는 간단한 객체 모형뒤에pdf" + "파일의 복잡한 구조를 숨긴다. PDF4NET도서관은 GDI+모형을 따라, 따라서 학습 시간을 " + "감소하고 생산력을 증가한. 그것은 격자에 의하여 기초를 두는 배치 접근을 사용해 문" + "서 페이지에 내용의 정확한 두기 허용한. 마지막pdf파일은 압축 이어, 도서관을 웹 응" + "용을 위해 적당한 시킨. 도서관은 어떤 금지없이 WinForms과 WebForms(22#ASP.NET) 응" + "용에서 모두 이용할 수 있는다. 도서관은 전체로안에C#써, 처리되는 100% 이. PDF4NET" + "도서관은 개발자당 허용하 배부된 특허권 사용료 자유롭게 이을 수 있어, 계획사업 비" + "용을 감소한." ), new PageData( ttf, "Portuguese", "PDF4NET é uma biblioteca do NET para gerar originais " + "do pdf na mosca de toda a aplicação do NET. A biblioteca não confia em nenhuns " + "produtos do adôbe para criar limas do pdf. Esconde a estrutura complexa de limas " + "do pdf atrás de um modelo simples do objeto que permita a criação de limas " + "complexas do pdf com algumas linhas do código. A biblioteca de PDF4NET segue o " + "modelo de GDI+, assim reduzindo o tempo de aprendizagem e aumentando a produtividade. " + "Usa uma aproximação baseada grade da disposição permitindo posicionar preciso do " + "índice em páginas do original. A lima final do pdf é comprimida, fazendo a " + "biblioteca apropriada para aplicações do Web. A biblioteca pode ser usada das " + "aplicações de WinForms e de WebForms (ASP.NET) sem nenhumas limitações. A " + "biblioteca é escrita inteiramente em C#, sendo 100% controlado. A biblioteca de " + "PDF4NET é licenciada por o colaborador e pode ser ROYALTY distribuído LIVRE, " + "reduzindo custos do projeto.\n" ), new PageData( ttf, "Romanian", "PDF4NET este o librărie .NET destinată generării de " + "documente pdf din orice aplicaţie .NET. Librăria nu se bazează pe nici un product " + "Adobe pentru generarea fişierelor pdf. Ea ascunde structura complexă a fişierelor " + "pdf în spatele unui model obiect simplu ce permite crearea de fişiere pdf complexe " + "cu doar câteva linii de cod. Librăria PDF4NET urmează modelul GDI+, reducând astfel " + "timpul de învăţare şi crescând productivitatea.\n" + "Librăria utilizeaza o abordare de poziţionare a conţinutului bazată pe grid, " + "permiţând poziţionarea precisă a continuţului în paginile documentului. Fisierul " + "pdf final este comprimat, făcând librăria potrivită pentru aplicaţiile web. " + "Librăria poate fi utilizată atât din aplicaţii desktop WinForms cât şi din " + "aplicaţii web WebForms (ASP.NET) fără nici o restricţie. Librăria a fost dezvoltată " + "în întregime în C#, fiind 100% managed. Librăria PDF4NET este licenţiată per " + "programator şi poate fi distribuită fără taxe suplimentare, reducând astfel " + "costurile proiectului în care este folosită.\n" ), new PageData( ttf, "Russian", "PDF4NET будет архивом NET для производить документы pdf " + "на мухе от любого применения NET. Архив не полагается на всех продуктах самана для " + "создавать архивы pdf. Он прячет сложную структуру архивов pdf за просто моделью " + "предмета позволяет творение сложных архивов pdf с немного линий Кодего. Архив " + "PDF4NET следует за моделью GDI+, таким образом уменьшающ учя время и увеличивающ " + "урожайность. Он использует основанный решеткой подход к плана позволяющ точный " + "располагать содержания на страницы документа. Обжат окончательный архив pdf, делая " + "архив соотвествующим для применений стержня. Архив можно использовать и от " + "применений WinForms и WebForms (ASP.NET) без всех ограничений. Архив написан вс в C#, " + "был управляемым 100%. Архив PDF4NET лицензирован в проявитель и может быть " + "распределенной КОРОЛЕВСКОЙ ВЛАСТЬЮ СВОБОДНО, уменьшающ цены проекта.\n" ), new PageData( ttf, "Spanish", "PDF4NET es una biblioteca del NET para generar documentos " + "del pdf en marcha de cualquier aplicación del NET. La biblioteca no confía en " + "ninguna productos del adobe para crear ficheros del pdf. Oculta la estructura " + "compleja de los ficheros del pdf detrás de un modelo simple del objeto que permita " + "la creación de los ficheros complejos del pdf con algunas líneas del código. " + "La biblioteca de PDF4NET sigue el modelo de GDI+, así reduciendo el tiempo que " + "aprende y aumentando productividad. Utiliza un acercamiento basado rejilla de la " + "disposición permitiendo la colocación exacta del contenido en las paginaciones del " + "documento. El fichero final del pdf se comprime, haciendo la biblioteca apropiada " + "para las aplicaciones del Web. La biblioteca se puede utilizar de las aplicaciones " + "de WinForms y de WebForms (ASP.NET) sin ningunas restricciones. La biblioteca se " + "escribe enteramente en C#, siendo el 100% manejado. La biblioteca de PDF4NET se " + "licencia por el revelador y puede ser DERECHOS distribuidos LIBREMENTE, reduciendo " + "costes del proyecto.\n" ), new PageData( ttf, "Swedish", "PDF4NET är ett .NET-bibliotek för att generera " + "pdf-dokument i farten i en .NET-applikation. Biblioteket är inte beroende av någon " + "produkt från Adobe för att skapa pdf-filer. Det döljer pdf-filernas komplexa " + "struktur bakom en enkel objektsmodell, som tillåter skapandet av komplexa " + "pdf-filer med några få rader kod. PDF4NET-biblioteket följer modellen GDI+, och " + "förkortar därigenom inlärningstiden och ökar produktiviteten.\n" + "Det använder en layoutmetod, baserad på rutnät, vilket möjliggör absolut " + "positionering av innehållet i dokumentet. Den slutgiltiga pdf-filen är komprimerad, " + "vilket gör biblioteket lämpligt för webapplikationer. Biblioteket kan användas både " + "från WinForms- och WebForms- (ASP.NET) applikationer utan några begränsningar. " + "Biblioteket är helt och hållet skrivet i C#, och är till 100% s.k. \"Managed Code\". " + "PDF4NET-biblioteket licensieras per utvecklare och kan distribueras royaltyfritt, " + "vilket minskar projektkostnader.\n" ) }; // Create the pdf document PDFDocument doc = new PDFDocument(); doc.DisplayMode = PDFDisplayMode.UseOutlines; // Create the graphic objects PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); // Create the root bookmark PDFBookmark root = new PDFBookmark(); root.DisplayStyle = PDFBookmarkDisplayStyle.Bold; root.Title = "Unicode"; doc.Bookmarks.Add(root); PDFTextFormatOptions tfo = new PDFTextFormatOptions(); tfo.Align = PDFTextAlign.TopJustified; for (int i = 0; i < pagesInfo.Length; i++) { PDFPage page = doc.AddPage(); // draw the page title page.Canvas.DrawText(pagesInfo[i].Language, titleFont, null, blackBrush, 20, 40); // draw the page content page.Canvas.DrawTextBox(pagesInfo[i].Text, pagesInfo[i].Font, null, blackBrush, 20, 60, page.Width - 40, page.Height - 80, tfo); // add a bookmark to point to this page PDFPageDestination pageDestination = new PDFPageDestination(); pageDestination.Page = page; pageDestination.MagnificationMode = PDFMagnificationMode.XYZ; pageDestination.Zoom = 100; pageDestination.Top = page.Height; PDFGoToAction gta = new PDFGoToAction(); gta.Destination = pageDestination; PDFBookmark pageBookmark = new PDFBookmark(); pageBookmark.Title = pagesInfo[i].Language; pageBookmark.Action = gta; root.Bookmarks.Add(pageBookmark); } // Save the document to disk doc.Save("Sample_Unicode.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Update PDF
This samples shows the import and update capabilities of PDF4NET library. It loads an external pdf file, draws content on the first page of the document, then it creates a new page at the beginning of the document.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


UpdatePDF.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.UpdatePDF { /// <summary> /// This sample shows how to add content to an existing pdf file. /// </summary> class UpdatePDF { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Create the pdf document PDFDocument pdfDoc = new PDFDocument("..\\SupportFiles\\HelloPDFWorld.pdf"); // Create the graphic objects PDFBrush blackBrush = new PDFBrush(new PDFRgbColor()); PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(0, 128, 0)); PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 2); PDFFont fnt = new PDFFont(PDFFontFace.Helvetica, 12); // Draw on the first page of the imported document pdfDoc.Pages[0].Canvas.DrawRectangle(redPen, greenBrush, 15, 15, 500, 200, 0); pdfDoc.Pages[0].Canvas.DrawText("This is new content added to an imported page.", fnt, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); // Create a page and insert it at the beginning // of the document PDFPage firstPage = new PDFPage(); pdfDoc.Pages.Insert(0, firstPage); firstPage.Canvas.DrawText("This is a new page added to the old document", fnt, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft); // Save the document to disk pdfDoc.Save("Sample_UpdatePDF.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


UpdatePDF.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.UpdatePDF ''' <summary> ''' This sample shows how to add content to an existing pdf file. ''' </summary> Class UpdatePDF ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Create the pdf document Dim pdfDoc As New PDFDocument("..\SupportFiles\HelloPDFWorld.pdf") ' Create the graphic objects Dim blackBrush As New PDFBrush(New PDFRgbColor()) Dim greenBrush As New PDFBrush(New PDFRgbColor(0, 128, 0)) Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 2) Dim fnt As New PDFFont(PDFFontFace.Helvetica, 12) ' Draw on the first page of the imported document pdfDoc.Pages(0).Canvas.DrawRectangle(redPen, greenBrush, 15, 15, 500, 200, _ 0) pdfDoc.Pages(0).Canvas.DrawText("This is new content added to an imported page.", fnt, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) ' Create a page and insert it at the beginning ' of the document Dim firstPage As New PDFPage() pdfDoc.Pages.Insert(0, firstPage) firstPage.Canvas.DrawText("This is a new page added to the old document", fnt, Nothing, blackBrush, 20, 20, _ 0, PDFTextAlign.TopLeft) ' Save the document to disk pdfDoc.Save("Sample_UpdatePDF.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Watermarks
This sample demonstrates how to a watermark to a PDF file. The sample draws a simple text watermark on each page of a PDF document. Any type of text, graphics and image can be used as watermarks.

C# Source code | VB.NET Source code | PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Watermarks.cs
using System; using System.Drawing; using O2S.Components.PDF4NET; using O2S.Components.PDF4NET.PDFFile; using O2S.Components.PDF4NET.Annotations; using O2S.Components.PDF4NET.Graphics; using O2S.Components.PDF4NET.Graphics.Shapes; using O2S.Components.PDF4NET.Graphics.Fonts; namespace O2S.Samples.PDF4NET.Watermarks { /// <summary> /// This sample shows how to draw a text watermark on existing PDF files behind actual page content. /// </summary> class Watermarks { /// <summary> /// The main entry point for the application. /// </summary> [STAThread] static void Main(string[] args) { // Import the pdf document PDFDocument doc = new PDFDocument("..\\SupportFiles\\sample.pdf"); // stamp second page with regular text. PDFFont font = new PDFFont(PDFFontFace.Helvetica, 96); font.Bold = true; PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(Color.Green)); for (int i = 0; i < doc.Pages.Count; i++) { PDFImportedPage ip = (PDFImportedPage)doc.Pages[i]; // Use the UnderCanvas property to draw under existing page content ip.UnderCanvas.DrawText("Approved", font, null, greenBrush, ip.Width / 2, ip.Height / 2, 20, PDFTextAlign.MiddleCenter); } // Save the document to disk doc.Save("Sample_Watermarks.pdf"); } } }

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Watermarks.vb
Imports System Imports System.Drawing Imports O2S.Components.PDF4NET Imports O2S.Components.PDF4NET.PDFFile Imports O2S.Components.PDF4NET.Annotations Imports O2S.Components.PDF4NET.Graphics Imports O2S.Components.PDF4NET.Graphics.Shapes Imports O2S.Components.PDF4NET.Graphics.Fonts Namespace O2S.Samples.PDF4NET.Watermarks ''' <summary> ''' This sample shows how to draw a text watermark on existing PDF files behind actual page content. ''' </summary> Class Watermarks ''' <summary> ''' The main entry point for the application. ''' </summary> <STAThread> _ Shared Sub Main(args As String()) ' Import the pdf document Dim doc As New PDFDocument("..\SupportFiles\sample.pdf") ' stamp second page with regular text. Dim font As New PDFFont(PDFFontFace.Helvetica, 96) font.Bold = True Dim greenBrush As New PDFBrush(New PDFRgbColor(Color.Green)) Dim i As Integer = 0 While i < doc.Pages.Count Dim ip As PDFImportedPage = DirectCast(doc.Pages(i), PDFImportedPage) ' Use the UnderCanvas property to draw under existing page content ip.UnderCanvas.DrawText("Approved", font, Nothing, greenBrush, ip.Width / 2, ip.Height / 2, _ 20, PDFTextAlign.MiddleCenter) i = i + 1 End While ' Save the document to disk doc.Save("Sample_Watermarks.pdf") End Sub End ClassEnd Namespace

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


O2S.Components.PDF4NET Assembly
Namespaces
Namespace | Description
(Global) |
O2S.Components.PDF4NET |
O2S.Components.PDF4NET.Actions |
O2S.Components.PDF4NET.Annotations |
O2S.Components.PDF4NET.Annotations.RichMedia |
O2S.Components.PDF4NET.Converters |
O2S.Components.PDF4NET.Cos |
O2S.Components.PDF4NET.Forms |
O2S.Components.PDF4NET.Forms.XFA |
O2S.Components.PDF4NET.Functions |
O2S.Components.PDF4NET.Geo |
O2S.Components.PDF4NET.Graphics |
O2S.Components.PDF4NET.Graphics.Barcodes |
O2S.Components.PDF4NET.Graphics.ColorSpaces |
O2S.Components.PDF4NET.Graphics.Fonts |
O2S.Components.PDF4NET.Graphics.Shadings |
O2S.Components.PDF4NET.Graphics.Shapes |
O2S.Components.PDF4NET.Graphics.Shapes.Transparency |
O2S.Components.PDF4NET.Measures |
O2S.Components.PDF4NET.PageObjects |
O2S.Components.PDF4NET.PDFA |
O2S.Components.PDF4NET.PDFFile |
O2S.Components.PDF4NET.Portfolios |
O2S.Components.PDF4NET.Security |
O2S.Components.PDF4NET.Text |
Send Feedback


(Global) Namespace
Inheritance Hierarchy
See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | DisplayRectangle | Defines a rectangle in display coordinates, relative to top left corner of the page.
Class | PDFBookmark | Defines a bookmark in a PDF file.
Class | PDFBookmarkCollection | Defines a collection of bookmarks.
Class | PDFCollection<T,K> | Defines a collection that fires notifications when it changes or when an item in the collection changes its properties.
Class | PDFCustomProperties | Defines the custom properties that can be added to document.
Class | PDFDestination | Defines the base class for PDF destinations.
Class | PDFDirectDestination | Defines the base class direct PDF destinations.
Class | PDFDocument | Represents a PDF document.
Class | PDFDocumentAttachment | Defines a file embedded in a PDF document.
Class | PDFDocumentAttachmentCollection | Defines a collection of annotations.
Class | PDFDocumentInformation | Provides access to document metadata.
Class | PDFDocumentLoadOptions | Provides several options for loading a PDF file.
Class | PDFDocumentSaveOptions | Provides several options for saving a PDF file.
Class | PDFException | Defines a generic PDF exception.
Class | PDFGraphicsContainer | Defines an abstract object that can store graphic content.
Class | PDFInvalidPasswordException | The exception that is thrown when the password supplied for opening the file is invalid or when the password contains unsupported characters.
Class | PDFInvalidPDFAFormatException | Thrown when the saved document does not meet the PDF-A/1b requirements.
Class | PDFJavaScript | Defines a fragment of JavaScript code.
Class | PDFJavaScriptCollection | Defines a collection of annotations.
Class | PDFMetadataSchema | Defines a schema within the document's metadata
Class | PDFMetadataSchemaCollection | Defines a collection of bookmarks.
Class | PDFOutputIntent | Defines an output intent for a PDF document.
Class | PDFOutputIntentCollection | Defines a collection of output intents.
Class | PDFPage | Defines a page within the pdf document.
Class | PDFPageBackground | Defines a background for a PDF page.
Class | PDFPageCollection | Defines a collection of PDF pages.
Class | PDFPageDestination | Defines a destination to a page within the current document.
Class | PDFPageNumber | Defines the visual aspect of the page number when it is drawn on the page
Class | PDFPageNumberingRange | Defines a series of consecutive pages within the PDF document using the same numbering system
Class | PDFPageNumberingRangeCollection | Defines a collection of bookmarks.
Class | PDFParserException | Defines the exceptions thrown by the pdf parser.
Class | PDFPoint | Represents a pair of floating point x- and y-coordinates that defines a point in a two-dimensional plane.
Class | PDFRectangle | Defines a rectangle in PDF default coordinates, where the origin of the coordinate system is located in the bottom left corner of the page.
Class | PDFRemotePageDestination | Defines a destination to a page in another PDF document.
Class | PDFSeparationInfo | Defines the separation information for a PDF page.
Class | PDFVersionExtension | Defines an extension to an existing PDF version.
Class | PDFViewerPreferences | Defines the way the PDF document is displayed on the screen.
Class | PDFXMPMetadata | Defines the XMP metadata for a PDF document.
Class | XDPPackage | Defines a XDP package.
Enumerations
 | Enumeration | Description
Enumeration | PDFBookmarkDisplayStyle | Specifies the available modes for displaying a bookmark in a viewer application.
Enumeration | PDFDisplayMode | Specifies the possible modes to be display the document when it is opened.
Enumeration | PDFDocumentAttachmentRelationship | Relationships between a file attachment and its owner.
Enumeration | PDFDocumentSaveFormat | Specifies the available save formats for a PDF document.
Enumeration | PDFMagnificationMode | Specifies the available zoom modes that can be applied when the PDF page specified in the destination is displayed.
Enumeration | PDFNumberingStyle | Specifies the available styles when setting up a page numbering range.
Enumeration | PDFOutputIntentType | Specifies the available output intent types.
Enumeration | PDFPageLayout | Specifies the possible page layouts to be used when the document is opened.
Enumeration | PDFPageOrientation | Specifies the possible orientations for a page.
Enumeration | PDFPageSize | Specifies the predefined page sizes.
Enumeration | PDFPrintScaling | Specifies the available print scaling options.
Enumeration | PDFRotationMode | Specifies the available rotation modes for a PDF object.
Enumeration | PDFVersion | Specifies the available PDF versions to save a PDF document.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

DisplayRectangle Class
Members

O2S.Components.PDF4NET Namespace : DisplayRectangle Class
Defines a rectangle in display coordinates, relative to top left corner of the page.
Object Model
DisplayRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DisplayRectangle
'Usage

Dim instance As DisplayRectangle
public class DisplayRectangle
public __gc class DisplayRectangle
public ref class DisplayRectangle
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.DisplayRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

DisplayRectangle Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : DisplayRectangle Class

The following tables list the members exposed by DisplayRectangle.

Public Constructors
 | Name | Description
Public Constructor | DisplayRectangle Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | Left | Gets or sets X coordinate of the top left corner.
Public Property | Top | Gets or sets Y coordinate of the top left corner.
Public Property | Width | Gets or sets the rectangle's width.
Top
Public Methods
 | Name | Description
Public Method | Intersects | Verifies if the given rectangle intersects this rectangle.
Public Method | ToString | Converts the rectangle to string representation.
Top
See Also

Reference

DisplayRectangle Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

DisplayRectangle Constructor

O2S.Components.PDF4NET Namespace > DisplayRectangle Class : DisplayRectangle Constructor
Overload List
Overload | Description
DisplayRectangle Constructor() | Initializes a new DisplayRectangle object.
DisplayRectangle Constructor(Double,Double,Double,Double) | Initializes a new PDFRectangle object.
DisplayRectangle Constructor(RectangleF) | Initializes a new PDFRectangle object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%PageItemTitle%%

DisplayRectangle Constructor()

O2S.Components.PDF4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor()
Initializes a new DisplayRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DisplayRectangle()
public DisplayRectangle()
public: DisplayRectangle();
public:
DisplayRectangle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


%%PageItemTitle%%

DisplayRectangle Constructor(Double,Double,Double,Double)

O2S.Components.PDF4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor(Double,Double,Double,Double)
The x coordinate of the top left corner of the rectangle.
The y coordinate of the top left corner of the rectangle.
The width of the rectangle.
The height of the rectangle.
Initializes a new PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

Dim instance As New DisplayRectangle(left, top, width, height)
public DisplayRectangle(
   double left,
   double top,
   double width,
   double height
)
public: DisplayRectangle(
   double left,
   double top,
   double width,
   double height
)
public:
DisplayRectangle(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


%%PageItemTitle%%

DisplayRectangle Constructor(RectangleF)

O2S.Components.PDF4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor(RectangleF)
Source rectangle.
Initializes a new PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rectangle As RectangleF _
)
'Usage

Dim rectangle As RectangleF

Dim instance As New DisplayRectangle(rectangle)
public DisplayRectangle(
   RectangleF rectangle
)
public: DisplayRectangle(
   RectangleF rectangle
)
public:
DisplayRectangle(
   RectangleF rectangle
)

Parameters

rectangle
Source rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

DisplayRectangle Class Methods

O2S.Components.PDF4NET Namespace : DisplayRectangle Class

For a list of all members of this type, see DisplayRectangle members.

Public Methods
 | Name | Description
Public Method | Intersects | Verifies if the given rectangle intersects this rectangle.
Public Method | ToString | Converts the rectangle to string representation.
Top
See Also

Reference

DisplayRectangle Class
O2S.Components.PDF4NET Namespace


Intersects Method

O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Intersects Method
The rectangle to intersect.
Verifies if the given rectangle intersects this rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Intersects( _
   ByVal displayRect As DisplayRectangle _
) As Boolean
'Usage

Dim instance As DisplayRectangle
Dim displayRect As DisplayRectangle
Dim value As Boolean

value = instance.Intersects(displayRect)
public bool Intersects(
   DisplayRectangle displayRect
)
public: bool Intersects(
   DisplayRectangle* displayRect
)
public:
bool Intersects(
   DisplayRectangle^ displayRect
)

Parameters

displayRect
The rectangle to intersect.

Return Value

True if the rectangles intersect, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


ToString Method (DisplayRectangle)

O2S.Components.PDF4NET Namespace > DisplayRectangle Class : ToString Method
Converts the rectangle to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As DisplayRectangle
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%PageItemTitle%% $$Properties$$

DisplayRectangle Class Properties

O2S.Components.PDF4NET Namespace : DisplayRectangle Class

For a list of all members of this type, see DisplayRectangle members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | Left | Gets or sets X coordinate of the top left corner.
Public Property | Top | Gets or sets Y coordinate of the top left corner.
Public Property | Width | Gets or sets the rectangle's width.
Top
See Also

Reference

DisplayRectangle Class
O2S.Components.PDF4NET Namespace


Height Property (DisplayRectangle)

O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Height Property
Gets or sets the rectangle's height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As DisplayRectangle
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public: __property double get_Height();
public: __property void set_Height(
   double value
);
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The height of the rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


Left Property (DisplayRectangle)

O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Left Property
Gets or sets X coordinate of the top left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As DisplayRectangle
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public: __property double get_Left();
public: __property void set_Left(
   double value
);
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the top left corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


Top Property (DisplayRectangle)

O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Top Property
Gets or sets Y coordinate of the top left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Top As Double
'Usage

Dim instance As DisplayRectangle
Dim value As Double

instance.Top = value

value = instance.Top
public double Top {get; set;}
public: __property double get_Top();
public: __property void set_Top(
   double value
);
public:
property double Top {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the top left corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


Width Property (DisplayRectangle)

O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Width Property
Gets or sets the rectangle's width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As DisplayRectangle
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%PageItemTitle%%

PDFBookmark Class
Members

O2S.Components.PDF4NET Namespace : PDFBookmark Class
Defines a bookmark in a PDF file.
Object Model
PDFBookmark ClassPDFAction ClassPDFBookmarkCollection ClassPDFBookmark ClassPDFRgbColor ClassPDFDictionary ClassPDFBookmark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFBookmark
'Usage

Dim instance As PDFBookmark
public class PDFBookmark
public __gc class PDFBookmark
public ref class PDFBookmark
Remarks
The bookmarks have a tree structure that allows an easier navigation into the document. The bookmarks tree serves as a table of contents for the document.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBookmark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFBookmark Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFBookmark Class

The following tables list the members exposed by PDFBookmark.

Public Constructors
 | Name | Description
Public Constructor | PDFBookmark Constructor | Initializes a new PDFBookmark object.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the bookmark is clicked.
Public Property | Bookmarks | Gets the collection of child bookmarks.
Public Property | Color | Gets or sets the bookmark color.
Public Property | Dictionary | Gets the bookmark dictionary.
Public Property | DisplayStyle | Gets or sets the display style of this bookmark.
Public Property | Expanded | Gets or sets a value indicating whether the bookmark should be displayed in collapsed or expanded state.
Public Property | Parent | Gets the parent of this PDFBookmark object.
Public Property | Title | Gets or sets the title of this bookmark.
Top
See Also

Reference

PDFBookmark Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFBookmark Constructor

O2S.Components.PDF4NET Namespace > PDFBookmark Class : PDFBookmark Constructor
Initializes a new PDFBookmark object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFBookmark()
public PDFBookmark()
public: PDFBookmark();
public:
PDFBookmark();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%PageItemTitle%% $$Properties$$

PDFBookmark Class Properties

O2S.Components.PDF4NET Namespace : PDFBookmark Class

For a list of all members of this type, see PDFBookmark members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the bookmark is clicked.
Public Property | Bookmarks | Gets the collection of child bookmarks.
Public Property | Color | Gets or sets the bookmark color.
Public Property | Dictionary | Gets the bookmark dictionary.
Public Property | DisplayStyle | Gets or sets the display style of this bookmark.
Public Property | Expanded | Gets or sets a value indicating whether the bookmark should be displayed in collapsed or expanded state.
Public Property | Parent | Gets the parent of this PDFBookmark object.
Public Property | Title | Gets or sets the title of this bookmark.
Top
See Also

Reference

PDFBookmark Class
O2S.Components.PDF4NET Namespace


Action Property (PDFBookmark)

O2S.Components.PDF4NET Namespace > PDFBookmark Class : Action Property
Gets or sets the action to be executed when the bookmark is clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Action As PDFAction
'Usage

Dim instance As PDFBookmark
Dim value As PDFAction

instance.Action = value

value = instance.Action
public PDFAction Action {get; set;}
public: __property PDFAction* get_Action();
public: __property void set_Action(
   PDFAction* value
);
public:
property PDFAction^ Action {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to execute when the bookmark is selected by the user.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Bookmarks Property (PDFBookmark)

O2S.Components.PDF4NET Namespace > PDFBookmark Class : Bookmarks Property
Gets the collection of child bookmarks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bookmarks As PDFBookmarkCollection
'Usage

Dim instance As PDFBookmark
Dim value As PDFBookmarkCollection

value = instance.Bookmarks
public PDFBookmarkCollection Bookmarks {get;}
public: __property PDFBookmarkCollection* get_Bookmarks();
public:
property PDFBookmarkCollection^ Bookmarks {
   PDFBookmarkCollection^ get();
}

Property Value

A PDFBookmarkCollection object with the list of child bookmarks.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Color Property (PDFBookmark)

O2S.Components.PDF4NET Namespace > PDFBookmark Class : Color Property
Gets or sets the bookmark color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As PDFRgbColor
'Usage

Dim instance As PDFBookmark
Dim value As PDFRgbColor

instance.Color = value

value = instance.Color
public PDFRgbColor Color {get; set;}
public: __property PDFRgbColor* get_Color();
public: __property void set_Color(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ Color {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The color of the bookmark.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Dictionary Property (PDFBookmark)

O2S.Components.PDF4NET Namespace > PDFBookmark Class : Dictionary Property
Gets the bookmark dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFBookmark
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw bookmark dictionary.
Remarks
This property gives you direct access to bookmark dictionary and its associated resources. Note: Modifying directly the bookmark dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


DisplayStyle Property

O2S.Components.PDF4NET Namespace > PDFBookmark Class : DisplayStyle Property
Gets or sets the display style of this bookmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayStyle As PDFBookmarkDisplayStyle
'Usage

Dim instance As PDFBookmark
Dim value As PDFBookmarkDisplayStyle

instance.DisplayStyle = value

value = instance.DisplayStyle
public PDFBookmarkDisplayStyle DisplayStyle {get; set;}
public: __property PDFBookmarkDisplayStyle get_DisplayStyle();
public: __property void set_DisplayStyle(
   PDFBookmarkDisplayStyle value
);
public:
property PDFBookmarkDisplayStyle DisplayStyle {
   PDFBookmarkDisplayStyle get();
   void set (    PDFBookmarkDisplayStyle value);
}

Property Value

The bookmark's display style.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Expanded Property

O2S.Components.PDF4NET Namespace > PDFBookmark Class : Expanded Property
Gets or sets a value indicating whether the bookmark should be displayed in collapsed or expanded state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Expanded As Boolean
'Usage

Dim instance As PDFBookmark
Dim value As Boolean

instance.Expanded = value

value = instance.Expanded
public bool Expanded {get; set;}
public: __property bool get_Expanded();
public: __property void set_Expanded(
   bool value
);
public:
property bool Expanded {
   bool get();
   void set (    bool value);
}

Property Value

True if the bookmark should be displayed in expanded state, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Parent Property (PDFBookmark)

O2S.Components.PDF4NET Namespace > PDFBookmark Class : Parent Property
Gets the parent of this PDFBookmark object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As PDFBookmark
'Usage

Dim instance As PDFBookmark
Dim value As PDFBookmark

value = instance.Parent
public PDFBookmark Parent {get;}
public: __property PDFBookmark* get_Parent();
public:
property PDFBookmark^ Parent {
   PDFBookmark^ get();
}

Property Value

The parent bookmark.
Remarks
If the parent bookmark is null, the bookmark is a top level bookmark.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Title Property (PDFBookmark)

O2S.Components.PDF4NET Namespace > PDFBookmark Class : Title Property
Gets or sets the title of this bookmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As PDFBookmark
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

The bookmark title.
Remarks
The title is displayed by the viewer application in the bookmarks tree.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%PageItemTitle%%

PDFBookmarkCollection Class
Members

O2S.Components.PDF4NET Namespace : PDFBookmarkCollection Class
Defines a collection of bookmarks.
Object Model
PDFBookmarkCollection ClassPDFBookmark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFBookmarkCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFBookmark,PDFBookmark)
'Usage

Dim instance As PDFBookmarkCollection
public class PDFBookmarkCollection : O2S.Components.PDF4NET.PDFCollection<PDFBookmark,PDFBookmark>
public __gc class PDFBookmarkCollection : public O2S.Components.PDF4NET.PDFCollection<PDFBookmark,PDFBookmark>
public ref class PDFBookmarkCollection : public O2S.Components.PDF4NET.PDFCollection<PDFBookmark,PDFBookmark>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.PDFBookmarkCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarkCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFBookmarkCollection Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFBookmarkCollection Class

The following tables list the members exposed by PDFBookmarkCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates a new bookmark and adds it at the end of the collection.
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top
See Also

Reference

PDFBookmarkCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFBookmarkCollection Class Methods

O2S.Components.PDF4NET Namespace : PDFBookmarkCollection Class

For a list of all members of this type, see PDFBookmarkCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates a new bookmark and adds it at the end of the collection.
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top
See Also

Reference

PDFBookmarkCollection Class
O2S.Components.PDF4NET Namespace


Add Method (PDFBookmarkCollection)

O2S.Components.PDF4NET Namespace > PDFBookmarkCollection Class : Add Method
Creates a new bookmark and adds it at the end of the collection.
Overload List
Overload | Description
Add(String,PDFRgbColor,Boolean,PDFBookmarkDisplayStyle,PDFPage,Double) | Creates a new bookmark and adds it at the end of the collection.
Add(PDFBookmark) | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarkCollection Class
PDFBookmarkCollection Members


Add(String,PDFRgbColor,Boolean,PDFBookmarkDisplayStyle,PDFPage,Double) Method

O2S.Components.PDF4NET Namespace > PDFBookmarkCollection Class > Add Method : Add(String,PDFRgbColor,Boolean,PDFBookmarkDisplayStyle,PDFPage,Double) Method
the title of the bookmark
a O2S.Components.PDF4NET.Graphics.PDFRgbColor object specifying the color used to draw the bookmark in the bookmark tree.
specifies whether the bookmark should be displayed expanded or collapsed the tree when the document is open.
a combination of PDFBookmarkDisplayStyle enumeration members, specifying the font style used to draw the bookmark title.
a PDFPage object representing the destination of the bookmark.
the vertical position of the destination page when it is displayed as the result of using the bookmark.
Creates a new bookmark and adds it at the end of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Add( _
   ByVal title As String, _
   ByVal bookmarkColor As PDFRgbColor, _
   ByVal expanded As Boolean, _
   ByVal displayStyle As PDFBookmarkDisplayStyle, _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Double _
) As PDFBookmark
'Usage

Dim instance As PDFBookmarkCollection
Dim title As String
Dim bookmarkColor As PDFRgbColor
Dim expanded As Boolean
Dim displayStyle As PDFBookmarkDisplayStyle
Dim destinationPage As PDFPage
Dim topDestination As Double
Dim value As PDFBookmark

value = instance.Add(title, bookmarkColor, expanded, displayStyle, destinationPage, topDestination)
public PDFBookmark Add(
   string title,
   PDFRgbColor bookmarkColor,
   bool expanded,
   PDFBookmarkDisplayStyle displayStyle,
   PDFPage destinationPage,
   double topDestination
)
public: PDFBookmark* Add(
   string* title,
   PDFRgbColor* bookmarkColor,
   bool expanded,
   PDFBookmarkDisplayStyle displayStyle,
   PDFPage* destinationPage,
   double topDestination
)
public:
PDFBookmark^ Add(
   String^ title,
   PDFRgbColor^ bookmarkColor,
   bool expanded,
   PDFBookmarkDisplayStyle displayStyle,
   PDFPage^ destinationPage,
   double topDestination
)

Parameters

title
the title of the bookmark
bookmarkColor
a O2S.Components.PDF4NET.Graphics.PDFRgbColor object specifying the color used to draw the bookmark in the bookmark tree.
expanded
specifies whether the bookmark should be displayed expanded or collapsed the tree when the document is open.
displayStyle
a combination of PDFBookmarkDisplayStyle enumeration members, specifying the font style used to draw the bookmark title.
destinationPage
a PDFPage object representing the destination of the bookmark.
topDestination
the vertical position of the destination page when it is displayed as the result of using the bookmark.

Return Value

a PDFBookmark object representing the newly created bookmark.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarkCollection Class
PDFBookmarkCollection Members
Overload List


%%PageItemTitle%%

PDFCollection<T,K> Class
Members

O2S.Components.PDF4NET Namespace : PDFCollection<T,K> Class
The type of the collection items.
The type of the collection parent.
Defines a collection that fires notifications when it changes or when an item in the collection changes its properties.
Object Model
PDFCollection<T,K> Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCollection
    (Of T,K)
   Inherits System.Collections.ObjectModel.Collection(Of T)
'Usage

Dim instance As PDFCollection(Of T,K)
public class PDFCollection<T,K> : System.Collections.ObjectModel.Collection<T>
public __gc class PDFCollection<T,K> : public System.Collections.ObjectModel.Collection<T>
generic<typename T>
generic<typename K>
public ref class PDFCollection : public System.Collections.ObjectModel.Collection<T>
Type Parameters
T
The type of the collection items.
K
The type of the collection parent.
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Annotations.PDFAnnotationCollection
O2S.Components.PDF4NET.Annotations.PDFPointsCollection
O2S.Components.PDF4NET.Forms.FDFFieldCollection
O2S.Components.PDF4NET.Forms.PDFCalculatedFieldCollection
O2S.Components.PDF4NET.Forms.PDFFieldCollection
O2S.Components.PDF4NET.Forms.PDFFieldWidgetCollection
O2S.Components.PDF4NET.Forms.PDFListItemCollection
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection
O2S.Components.PDF4NET.Forms.XFDFFieldCollection
O2S.Components.PDF4NET.Graphics.PDFLayerCollection
O2S.Components.PDF4NET.PDFBookmarkCollection
O2S.Components.PDF4NET.PDFDocumentAttachmentCollection
O2S.Components.PDF4NET.PDFJavaScriptCollection
O2S.Components.PDF4NET.PDFMetadataSchemaCollection
O2S.Components.PDF4NET.PDFOutputIntentCollection
O2S.Components.PDF4NET.PDFPageCollection
O2S.Components.PDF4NET.PDFPageNumberingRangeCollection
O2S.Components.PDF4NET.Portfolios.PDFPortfolioFolderCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollection<T,K> Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFCollection<T,K> Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFCollection<T,K> Class

The following tables list the members exposed by PDFCollection<T,K>.

Public Constructors
 | Name | Description
Public Constructor | PDFCollection<T,K> Constructor | Initializes a new PDFCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

PDFCollection<T,K> Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFCollection<T,K> Constructor

O2S.Components.PDF4NET Namespace > PDFCollection<T,K> Class : PDFCollection<T,K> Constructor
The object that owns the collection.
Initializes a new PDFCollection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal parent As K _
)
'Usage

Dim parent As K

Dim instance As New PDFCollection(Of T,K)(parent)
public PDFCollection<T,K>(
   K parent
)
public: PDFCollection<T,K>(
   K* parent
)
public:
PDFCollection<T,K>(
   K^ parent
)

Parameters

parent
The object that owns the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollection<T,K> Class
PDFCollection<T,K> Members


%%PageItemTitle%%

PDFCustomProperties Class
Members

O2S.Components.PDF4NET Namespace : PDFCustomProperties Class
Defines the custom properties that can be added to document.
Object Model
PDFCustomProperties Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PDFCustomProperties
'Usage

Dim instance As PDFCustomProperties
[DefaultMember("Item")]
public class PDFCustomProperties
[DefaultMember("Item")]
public __gc class PDFCustomProperties
[DefaultMember("Item")]
public ref class PDFCustomProperties
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFCustomProperties

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCustomProperties Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFCustomProperties Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFCustomProperties Class

The following tables list the members exposed by PDFCustomProperties.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of custom properties.
Public Property | Item |
Public Property | Properties | Gets the list of custom properties.
Top
See Also

Reference

PDFCustomProperties Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFCustomProperties Class Properties

O2S.Components.PDF4NET Namespace : PDFCustomProperties Class

For a list of all members of this type, see PDFCustomProperties members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of custom properties.
Public Property | Item |
Public Property | Properties | Gets the list of custom properties.
Top
See Also

Reference

PDFCustomProperties Class
O2S.Components.PDF4NET Namespace


Count Property (PDFCustomProperties)

O2S.Components.PDF4NET Namespace > PDFCustomProperties Class : Count Property
Gets the number of custom properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As PDFCustomProperties
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}

Property Value

The number of the custom properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCustomProperties Class
PDFCustomProperties Members


Item Property (PDFCustomProperties)

O2S.Components.PDF4NET Namespace > PDFCustomProperties Class : Item Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal propertyName As String _
) As String
'Usage

Dim instance As PDFCustomProperties
Dim propertyName As String
Dim value As String

instance.Item(propertyName) = value

value = instance.Item(propertyName)
public string this[
   string propertyName
]; {get; set;}
public: __property string* get_Item   string* propertyName
;
public: __property void set_Item   string* propertyName,
   string* value
;
public:
property String^ default [String^] {
   String^ get(String^ propertyName);
   void set (String^ propertyName, String^ value);
}

Parameters

propertyName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCustomProperties Class
PDFCustomProperties Members


Properties Property (PDFCustomProperties)

O2S.Components.PDF4NET Namespace > PDFCustomProperties Class : Properties Property
Gets the list of custom properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Properties As String()
'Usage

Dim instance As PDFCustomProperties
Dim value() As String

value = instance.Properties
public string[] Properties {get;}
public: __property string*[]* get_Properties();
public:
property array<String^>^ Properties {
   array<String^>^ get();
}

Property Value

An array of strings representing the names of the custom properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCustomProperties Class
PDFCustomProperties Members


%%PageItemTitle%%

PDFDestination Class
Members

O2S.Components.PDF4NET Namespace : PDFDestination Class
Defines the base class for PDF destinations.
Object Model
PDFDestination ClassPDFArray Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFDestination
'Usage

Dim instance As PDFDestination
public abstract class PDFDestination
public __gc abstract class PDFDestination
public ref class PDFDestination abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDestination Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDestination Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFDestination Class

The following tables list the members exposed by PDFDestination.

Public Properties
 | Name | Description
Public Property | Destination | Gets the COS destination object.
Top
See Also

Reference

PDFDestination Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFDestination Class Properties

O2S.Components.PDF4NET Namespace : PDFDestination Class

For a list of all members of this type, see PDFDestination members.

Public Properties
 | Name | Description
Public Property | Destination | Gets the COS destination object.
Top
See Also

Reference

PDFDestination Class
O2S.Components.PDF4NET Namespace


Destination Property (PDFDestination)

O2S.Components.PDF4NET Namespace > PDFDestination Class : Destination Property
Gets the COS destination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Destination As PDFArray
'Usage

Dim instance As PDFDestination
Dim value As PDFArray

value = instance.Destination
public PDFArray Destination {get;}
public: __property PDFArray* get_Destination();
public:
property PDFArray^ Destination {
   PDFArray^ get();
}

Property Value

The underlying destination array object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDestination Class
PDFDestination Members


%%PageItemTitle%%

PDFDirectDestination Class
Members

O2S.Components.PDF4NET Namespace : PDFDirectDestination Class
Defines the base class direct PDF destinations.
Object Model
PDFDirectDestination ClassPDFArray Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFDirectDestination
   Inherits PDFDestination
'Usage

Dim instance As PDFDirectDestination
public abstract class PDFDirectDestination : PDFDestination
public __gc abstract class PDFDirectDestination : public PDFDestination
public ref class PDFDirectDestination abstract : public PDFDestination
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination
O2S.Components.PDF4NET.PDFPageDestination
O2S.Components.PDF4NET.PDFRemotePageDestination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDirectDestination Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFDirectDestination Class

The following tables list the members exposed by PDFDirectDestination.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page.
Public Property | Destination | Gets the COS destination object. (Inherited from O2S.Components.PDF4NET.PDFDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page.
Public Property | MagnificationMode | Gets or sets the magnification mode.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page.
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed.
Top
See Also

Reference

PDFDirectDestination Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFDirectDestination Class Properties

O2S.Components.PDF4NET Namespace : PDFDirectDestination Class

For a list of all members of this type, see PDFDirectDestination members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page.
Public Property | Destination | Gets the COS destination object. (Inherited from O2S.Components.PDF4NET.PDFDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page.
Public Property | MagnificationMode | Gets or sets the magnification mode.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page.
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed.
Top
See Also

Reference

PDFDirectDestination Class
O2S.Components.PDF4NET Namespace


Bottom Property

O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Bottom Property
Gets or sets the bottom coordinate in the page where the viewer should display the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Bottom As Double
'Usage

Dim instance As PDFDirectDestination
Dim value As Double

instance.Bottom = value

value = instance.Bottom
public double Bottom {get; set;}
public: __property double get_Bottom();
public: __property void set_Bottom(
   double value
);
public:
property double Bottom {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the bottom coordinate in the page where the viewer should display the page.
Remarks
When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate. It is relative to the top of the page.
This value is used by the following magnification modes: O2S.Components.PDF4NET.MagnificationMode.FitR
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


Left Property (PDFDirectDestination)

O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Left Property
Gets or sets the left coordinate in the page where the viewer should display the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As PDFDirectDestination
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public: __property double get_Left();
public: __property void set_Left(
   double value
);
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the left coordinate in the page where the viewer should display the page.
Remarks
When the destination page is displayed, the viewer will try to display the page at the given coordinate. This value is relative to the left margin of the page, 0 value meaning that the page will be displayed starting from its left margin.
A -1 value for this property means that the current left coordinate used by the viewer will not be changed when dispaying the page.
This value is used by the following magnification modes: O2S.Components.PDF4NET.MagnificationMode.XYZ, O2S.Components.PDF4NET.MagnificationMode.FitV, O2S.Components.PDF4NET.MagnificationMode.FitR, O2S.Components.PDF4NET.MagnificationMode.FitBV
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


MagnificationMode Property

O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : MagnificationMode Property
Gets or sets the magnification mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MagnificationMode As PDFMagnificationMode
'Usage

Dim instance As PDFDirectDestination
Dim value As PDFMagnificationMode

instance.MagnificationMode = value

value = instance.MagnificationMode
public PDFMagnificationMode MagnificationMode {get; set;}
public: __property PDFMagnificationMode get_MagnificationMode();
public: __property void set_MagnificationMode(
   PDFMagnificationMode value
);
public:
property PDFMagnificationMode MagnificationMode {
   PDFMagnificationMode get();
   void set (    PDFMagnificationMode value);
}

Property Value

The zoom mode to be applied when the destination is displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


Right Property

O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Right Property
Gets or sets the right coordinate in the page where the viewer should display the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Right As Double
'Usage

Dim instance As PDFDirectDestination
Dim value As Double

instance.Right = value

value = instance.Right
public double Right {get; set;}
public: __property double get_Right();
public: __property void set_Right(
   double value
);
public:
property double Right {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the right coordinate in the page where the viewer should display the page.
Remarks
When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate.
This value is used by the following magnification modes: O2S.Components.PDF4NET.MagnificationMode.FitR
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


Top Property (PDFDirectDestination)

O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Top Property
Gets or sets the top coordinate in the page where the viewer should display the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Top As Double
'Usage

Dim instance As PDFDirectDestination
Dim value As Double

instance.Top = value

value = instance.Top
public virtual double Top {get; set;}
public: __property virtual double get_Top();
public: __property virtual void set_Top(
   double value
);
public:
virtual property double Top {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the top coordinate in the page where the viewer should display the page.
Remarks
When the destination page is displayed, the viewer will try to display the page at the given coordinate. This value is relative to the top of the page, 0 value meaning that the top of the page will be displayed.
A -1 value for this property means that the current top coordinate used by the viewer will not be changed when dispaying the page.
This value is used by the following magnification modes: PDFMagnificationMode.XYZ, PDFMagnificationMode.FitH, PDFMagnificationMode.FitR, PDFMagnificationMode.FitBH
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


Zoom Property

O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Zoom Property
Gets or sets the zoom factor to be used when the page is displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Zoom As Double
'Usage

Dim instance As PDFDirectDestination
Dim value As Double

instance.Zoom = value

value = instance.Zoom
public double Zoom {get; set;}
public: __property double get_Zoom();
public: __property void set_Zoom(
   double value
);
public:
property double Zoom {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the zoom factor to be used when the page is displayed.
Remarks
When the destination page is displayed, it will be magnified using the zoom factor specified by this property. This value is used only in conjunction with PDFMagnificationMode.XYZ magnification mode ( see PDFMagnificationMode enumeration) and it is given as percents (100 means 100% zoom).
A 0 value for this property means that the current zoom factor used by the viewer will not be changed when displaying the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


%%PageItemTitle%%

PDFDocument Class
Members

O2S.Components.PDF4NET Namespace : PDFDocument Class
Represents a PDF document.
Object Model
PDFDocument ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFDocumentAttachmentCollection ClassPDFDocumentAttachment ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFBookmarkCollection ClassPDFBookmark ClassPDFDictionary ClassPDFDocumentInformation ClassPDFForm ClassPDFJavaScriptCollection ClassPDFJavaScript ClassPDFXMPMetadata ClassPDFAction ClassPDFOutputIntentCollection ClassPDFOutputIntent ClassPDFPageBackground ClassPDFPageNumber ClassPDFPageNumberingRangeCollection ClassPDFPageNumberingRange ClassPDFPageCollection ClassPDFPage ClassPDFPortfolioInformation ClassPDFSecurityManager ClassPDFVersionExtension ClassPDFViewerPreferences ClassXFAForm Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDocument
'Usage

Dim instance As PDFDocument
public class PDFDocument
public __gc class PDFDocument
public ref class PDFDocument
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocument Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFDocument Class

The following tables list the members exposed by PDFDocument.

Public Constructors
 | Name | Description
Public Constructor | PDFDocument Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | Attachments | Gets the list of file attachments embedded in this document.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | Bookmarks | Gets the list of bookmarks in the PDF document.
Public Property | Dictionary | Gets the document catalog dictionary.
Public Property | DisplayMode | Gets or sets how the document should be displayed when opened in the viewer.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | Form | Gets the PDF form included in the document.
Public Property | ID | Gets the document ID.
Public Property | JavaScripts | Gets the list of global JavaScript actions associated with this document.
Public Property | Metadata | Gets the XMP metadata for this PDFDocument object.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | OutputIntents | Gets or sets the collection of output intents.
Public Property | PageBackground | Gets or sets the default page background.
Public Property | PageHeight | Gets or sets the default page height.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | PageNumber | Gets or sets the default page number visual aspect for this PDFDocument object.
Public Property | PageNumberingRanges | Gets the list of page numbering ranges in the PDF document.
Public Property | PageOrientation | Gets or sets the default page orientation.
Public Property | Pages | Gets the document's collection of pages.
Public Property | PageSize | Gets or sets the default page size.
Public Property | PageWidth | Gets or sets the default page width.
Public Property | PDFVersion | Gets or sets the PDF version of this PDFDocument object.
Public Property | PortfolioInformation | Gets or sets the portfolio information associated with this document.
Public Property | SecurityManager | Gets or sets the security manager for this pdf document.
Public Property | SerialNumber | Sets the serial number and unlocks the component.
Public Property | VersionExtension | Gets or sets the version extension.
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Public Property | XFAForm | Gets the XFA form associated with this document.
Top
Public Methods
 | Name | Description
Public Method | AddPage | Creates a new page and adds it as the last page of the document
Public Method | BeginSave | Overloaded. Begins to save the document.
Public Method | Dispose | Disposes the internal resources.
Public Method | EndSave | Finishes a partial save operation.
Public Method | GetNamedDestination | Gets the destination with the specified name from the document.
Public Method | GetPDFAsByteArray | Gets the pdf file as a byte array.
Public Method | Save | Overloaded. Saves the PDF document to a file.
Public Method | SavePage | Saves the specified page.
Public Method | SavePageContent | Saves the content of the specified page.
Top
See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocument Constructor

O2S.Components.PDF4NET Namespace > PDFDocument Class : PDFDocument Constructor
Overload List
Overload | Description
PDFDocument Constructor() | Initializes a new PDFDocument object.
PDFDocument Constructor(String) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(String,Byte[]) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(String,PDFDocumentLoadOptions) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(Stream) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(Stream,Byte[]) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(Stream,PDFDocumentLoadOptions) | Initializes a new PDFDocument object based on an existing pdf document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PDFDocument Constructor()

O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor()
Initializes a new PDFDocument object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDocument()
public PDFDocument()
public: PDFDocument();
public:
PDFDocument();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(String)
Example

O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(String)
path to pdf file used as source for creating this PDFDocument object.
Initializes a new PDFDocument object based on an existing pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pdfFile As String _
)
'Usage

Dim pdfFile As String

Dim instance As New PDFDocument(pdfFile)
public PDFDocument(
   string pdfFile
)
public: PDFDocument(
   string* pdfFile
)
public:
PDFDocument(
   String^ pdfFile
)

Parameters

pdfFile
path to pdf file used as source for creating this PDFDocument object.
Exceptions
Exception | Description
PDFParserException | thrown when the input file can not be parsed for import.
Remarks
This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.
Example
The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
  • C#
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(String,Byte[])
Example

O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(String,Byte[])
path to pdf file used as source for creating this PDFDocument object.
the user or owner password used to decrypt the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pdfFile As String, _
   ByVal password() As Byte _
)
'Usage

Dim pdfFile As String
Dim password() As Byte

Dim instance As New PDFDocument(pdfFile, password)
public PDFDocument(
   string pdfFile,
   byte[] password
)
public: PDFDocument(
   string* pdfFile,
   byte[]* password
)
public:
PDFDocument(
   String^ pdfFile,
   array<byte>^ password
)

Parameters

pdfFile
path to pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.
Exceptions
Exception | Description
PDFParserException | thrown when the input file can not be parsed for import or the given password is invalid.
Remarks
This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.
Example
The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
  • C#
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(String,PDFDocumentLoadOptions)

O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(String,PDFDocumentLoadOptions)
path to pdf file used as source for creating this PDFDocument object.
options for loading the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pdfFile As String, _
   ByVal loadOptions As PDFDocumentLoadOptions _
)
'Usage

Dim pdfFile As String
Dim loadOptions As PDFDocumentLoadOptions

Dim instance As New PDFDocument(pdfFile, loadOptions)
public PDFDocument(
   string pdfFile,
   PDFDocumentLoadOptions loadOptions
)
public: PDFDocument(
   string* pdfFile,
   PDFDocumentLoadOptions* loadOptions
)
public:
PDFDocument(
   String^ pdfFile,
   PDFDocumentLoadOptions^ loadOptions
)

Parameters

pdfFile
path to pdf file used as source for creating this PDFDocument object.
loadOptions
options for loading the PDF file.
Exceptions
Exception | Description
PDFParserException | thrown when the input file can not be parsed for import or the given password is invalid.
Remarks
This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(Stream)
Example

O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(Stream)
a System.IO.Stream descendant storing the pdf file used as source for creating this PDFDocument object.
Initializes a new PDFDocument object based on an existing pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PDFDocument(stream)
public PDFDocument(
   Stream stream
)
public: PDFDocument(
   Stream* stream
)
public:
PDFDocument(
   Stream^ stream
)

Parameters

stream
a System.IO.Stream descendant storing the pdf file used as source for creating this PDFDocument object.
Exceptions
Exception | Description
PDFParserException | thrown when the input pdf document can not be parsed for import.
Remarks
This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.
Example
The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
  • C#
MemoryStream pdfStream = new MemoryStream( );
// load the pdf file into the stream
...
PDFDocument doc = new PDFDocument( pdfStream );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(Stream,Byte[])
Example

O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(Stream,Byte[])
a System.IO.Stream descendant storing the pdf file used as source for creating this PDFDocument object.
the user or owner password used to decrypt the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal password() As Byte _
)
'Usage

Dim stream As Stream
Dim password() As Byte

Dim instance As New PDFDocument(stream, password)
public PDFDocument(
   Stream stream,
   byte[] password
)
public: PDFDocument(
   Stream* stream,
   byte[]* password
)
public:
PDFDocument(
   Stream^ stream,
   array<byte>^ password
)

Parameters

stream
a System.IO.Stream descendant storing the pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.
Exceptions
Exception | Description
PDFParserException | thrown when the input pdf document can not be parsed for import or the given password is invalid.
Remarks
This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.
Example
The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
  • C#
MemoryStream pdfStream = new MemoryStream( );
// load the pdf file into the stream
...
PDFDocument doc = new PDFDocument( pdfStream );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(Stream,PDFDocumentLoadOptions)
Example

O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(Stream,PDFDocumentLoadOptions)
a System.IO.Stream descendant storing the pdf file used as source for creating this PDFDocument object.
options for loading the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal loadOptions As PDFDocumentLoadOptions _
)
'Usage

Dim stream As Stream
Dim loadOptions As PDFDocumentLoadOptions

Dim instance As New PDFDocument(stream, loadOptions)
public PDFDocument(
   Stream stream,
   PDFDocumentLoadOptions loadOptions
)
public: PDFDocument(
   Stream* stream,
   PDFDocumentLoadOptions* loadOptions
)
public:
PDFDocument(
   Stream^ stream,
   PDFDocumentLoadOptions^ loadOptions
)

Parameters

stream
a System.IO.Stream descendant storing the pdf file used as source for creating this PDFDocument object.
loadOptions
options for loading the PDF file.
Exceptions
Exception | Description
PDFParserException | thrown when the input pdf document can not be parsed for import or the given password is invalid.
Remarks
This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.
Example
The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
  • C#
MemoryStream pdfStream = new MemoryStream( );
// load the pdf file into the stream
...
PDFDocument doc = new PDFDocument( pdfStream );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFDocument Class Methods

O2S.Components.PDF4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Methods
 | Name | Description
Public Method | AddPage | Creates a new page and adds it as the last page of the document
Public Method | BeginSave | Overloaded. Begins to save the document.
Public Method | Dispose | Disposes the internal resources.
Public Method | EndSave | Finishes a partial save operation.
Public Method | GetNamedDestination | Gets the destination with the specified name from the document.
Public Method | GetPDFAsByteArray | Gets the pdf file as a byte array.
Public Method | Save | Overloaded. Saves the PDF document to a file.
Public Method | SavePage | Saves the specified page.
Public Method | SavePageContent | Saves the content of the specified page.
Top
See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


AddPage Method

O2S.Components.PDF4NET Namespace > PDFDocument Class : AddPage Method
Creates a new page and adds it as the last page of the document
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AddPage() As PDFPage
'Usage

Dim instance As PDFDocument
Dim value As PDFPage

value = instance.AddPage()
public PDFPage AddPage()
public: PDFPage* AddPage();
public:
PDFPage^ AddPage();

Return Value

a PDFPage object representing the newly added page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


BeginSave Method

O2S.Components.PDF4NET Namespace > PDFDocument Class : BeginSave Method
Begins to save the document.
Overload List
Overload | Description
BeginSave(Stream) | Begins to save the document.
BeginSave(Stream,PDFDocumentSaveFormat) | Begins to save the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


BeginSave(Stream) Method

O2S.Components.PDF4NET Namespace > PDFDocument Class > BeginSave Method : BeginSave(Stream) Method
Destination stream for saving the document.
Begins to save the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub BeginSave( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PDFDocument
Dim stream As Stream

instance.BeginSave(stream)
public void BeginSave(
   Stream stream
)
public: void BeginSave(
   Stream* stream
)
public:
void BeginSave(
   Stream^ stream
)

Parameters

stream
Destination stream for saving the document.
Remarks
This method, together with SavePage and EndSave, allows to save a PDF document page by page thus reducing the memory consumption. Once a page has been saved, it can no longer be used, its properties and invalid.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


BeginSave(Stream,PDFDocumentSaveFormat) Method

O2S.Components.PDF4NET Namespace > PDFDocument Class > BeginSave Method : BeginSave(Stream,PDFDocumentSaveFormat) Method
Destination stream for saving the document.
Begins to save the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub BeginSave( _
   ByVal stream As Stream, _
   ByVal saveFormat As PDFDocumentSaveFormat _
)
'Usage

Dim instance As PDFDocument
Dim stream As Stream
Dim saveFormat As PDFDocumentSaveFormat

instance.BeginSave(stream, saveFormat)
public void BeginSave(
   Stream stream,
   PDFDocumentSaveFormat saveFormat
)
public: void BeginSave(
   Stream* stream,
   PDFDocumentSaveFormat saveFormat
)
public:
void BeginSave(
   Stream^ stream,
   PDFDocumentSaveFormat saveFormat
)

Parameters

stream
Destination stream for saving the document.
saveFormat
Remarks
This method, together with SavePage and EndSave, allows to save a PDF document page by page thus reducing the memory consumption. Once a page has been saved, it can no longer be used, its properties and invalid.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Dispose Method (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : Dispose Method
Disposes the internal resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PDFDocument

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


EndSave Method

O2S.Components.PDF4NET Namespace > PDFDocument Class : EndSave Method
Finishes a partial save operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndSave()
'Usage

Dim instance As PDFDocument

instance.EndSave()
public void EndSave()
public: void EndSave();
public:
void EndSave();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


GetNamedDestination(String) Method

O2S.Components.PDF4NET Namespace > PDFDocument Class : GetNamedDestination(String) Method
The name of the destination.
Gets the destination with the specified name from the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetNamedDestination( _
   ByVal destinationName As String _
) As PDFDestination
'Usage

Dim instance As PDFDocument
Dim destinationName As String
Dim value As PDFDestination

value = instance.GetNamedDestination(destinationName)
public PDFDestination GetNamedDestination(
   string destinationName
)
public: PDFDestination* GetNamedDestination(
   string* destinationName
)
public:
PDFDestination^ GetNamedDestination(
   String^ destinationName
)

Parameters

destinationName
The name of the destination.

Return Value

The destination if it exists.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


GetPDFAsByteArray Method

O2S.Components.PDF4NET Namespace > PDFDocument Class : GetPDFAsByteArray Method
Gets the pdf file as a byte array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPDFAsByteArray() As Byte()
'Usage

Dim instance As PDFDocument
Dim value() As Byte

value = instance.GetPDFAsByteArray()
public byte[] GetPDFAsByteArray()
public: byte[]* GetPDFAsByteArray();
public:
array<byte>^ GetPDFAsByteArray();

Return Value

a byte array storing the pdf file.
Remarks
This method retrives the pdf file as an array of bytes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


Save Method (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : Save Method
Saves the PDF document to a file.
Overload List
Overload | Description
Save(String) | Saves the PDF document to a file.
Save(String,Boolean) | Saves the PDF document to a file.
Save(String,PDFDocumentSaveOptions) | Saves the PDF document to a file.
Save(Stream) | Saves the PDF document to a stream.
Save(Stream,Boolean) | Saves the PDF document to a stream.
Save(Stream,PDFDocumentSaveOptions) | Saves the PDF document to a stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


Save(String) Method

O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(String) Method
The path to the file where the PDF document will be saved.
Saves the PDF document to a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As String _
)
'Usage

Dim instance As PDFDocument
Dim fileName As String

instance.Save(fileName)
public void Save(
   string fileName
)
public: void Save(
   string* fileName
)
public:
void Save(
   String^ fileName
)

Parameters

fileName
The path to the file where the PDF document will be saved.
Remarks
If the file already exists, it will be overwritten.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(String,Boolean) Method

O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(String,Boolean) Method
The path to the file where the PDF document will be saved.
True if the file should be saved in fast web view format (linearized).
Saves the PDF document to a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As String, _
   ByVal saveForFastWebView As Boolean _
)
'Usage

Dim instance As PDFDocument
Dim fileName As String
Dim saveForFastWebView As Boolean

instance.Save(fileName, saveForFastWebView)
public void Save(
   string fileName,
   bool saveForFastWebView
)
public: void Save(
   string* fileName,
   bool saveForFastWebView
)
public:
void Save(
   String^ fileName,
   bool saveForFastWebView
)

Parameters

fileName
The path to the file where the PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).
Remarks
If the file already exists, it will be overwritten.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(String,PDFDocumentSaveOptions) Method

O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(String,PDFDocumentSaveOptions) Method
The path to the file where the PDF document will be saved.
Options for saving the PDF document.
Saves the PDF document to a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As String, _
   ByVal saveOptions As PDFDocumentSaveOptions _
)
'Usage

Dim instance As PDFDocument
Dim fileName As String
Dim saveOptions As PDFDocumentSaveOptions

instance.Save(fileName, saveOptions)
public void Save(
   string fileName,
   PDFDocumentSaveOptions saveOptions
)
public: void Save(
   string* fileName,
   PDFDocumentSaveOptions* saveOptions
)
public:
void Save(
   String^ fileName,
   PDFDocumentSaveOptions^ saveOptions
)

Parameters

fileName
The path to the file where the PDF document will be saved.
saveOptions
Options for saving the PDF document.
Remarks
If the file already exists, it will be overwritten.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(Stream) Method

O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(Stream) Method
The stream object where PDF document will be saved.
Saves the PDF document to a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PDFDocument
Dim stream As Stream

instance.Save(stream)
public void Save(
   Stream stream
)
public: void Save(
   Stream* stream
)
public:
void Save(
   Stream^ stream
)

Parameters

stream
The stream object where PDF document will be saved.
Remarks
The stream needs to be created prior saving the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(Stream,Boolean) Method

O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(Stream,Boolean) Method
The stream object where PDF document will be saved.
True if the file should be saved in fast web view format (linearized).
Saves the PDF document to a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal stream As Stream, _
   ByVal saveForFastWebView As Boolean _
)
'Usage

Dim instance As PDFDocument
Dim stream As Stream
Dim saveForFastWebView As Boolean

instance.Save(stream, saveForFastWebView)
public void Save(
   Stream stream,
   bool saveForFastWebView
)
public: void Save(
   Stream* stream,
   bool saveForFastWebView
)
public:
void Save(
   Stream^ stream,
   bool saveForFastWebView
)

Parameters

stream
The stream object where PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).
Remarks
The stream needs to be created prior saving the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(Stream,PDFDocumentSaveOptions) Method

O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(Stream,PDFDocumentSaveOptions) Method
The stream object where PDF document will be saved.
Options for saving the PDF file.
Saves the PDF document to a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal stream As Stream, _
   ByVal saveOptions As PDFDocumentSaveOptions _
)
'Usage

Dim instance As PDFDocument
Dim stream As Stream
Dim saveOptions As PDFDocumentSaveOptions

instance.Save(stream, saveOptions)
public void Save(
   Stream stream,
   PDFDocumentSaveOptions saveOptions
)
public: void Save(
   Stream* stream,
   PDFDocumentSaveOptions* saveOptions
)
public:
void Save(
   Stream^ stream,
   PDFDocumentSaveOptions^ saveOptions
)

Parameters

stream
The stream object where PDF document will be saved.
saveOptions
Options for saving the PDF file.
Remarks
The stream needs to be created prior saving the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


SavePage Method

O2S.Components.PDF4NET Namespace > PDFDocument Class : SavePage Method
The number of the page to save.
Saves the specified page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SavePage( _
   ByVal pageNumber As Integer _
)
'Usage

Dim instance As PDFDocument
Dim pageNumber As Integer

instance.SavePage(pageNumber)
public void SavePage(
   int pageNumber
)
public: void SavePage(
   int pageNumber
)
public:
void SavePage(
   int pageNumber
)

Parameters

pageNumber
The number of the page to save.
Remarks
This method, together with BeginSave(Stream) and EndSave, allows to save a PDF document page by page thus reducing the memory consumption. Once a page has been saved, it can no longer be used, its properties and invalid.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


SavePageContent Method

O2S.Components.PDF4NET Namespace > PDFDocument Class : SavePageContent Method
The number of the page to save.
Saves the content of the specified page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SavePageContent( _
   ByVal pageNumber As Integer _
)
'Usage

Dim instance As PDFDocument
Dim pageNumber As Integer

instance.SavePageContent(pageNumber)
public void SavePageContent(
   int pageNumber
)
public: void SavePageContent(
   int pageNumber
)
public:
void SavePageContent(
   int pageNumber
)

Parameters

pageNumber
The number of the page to save.
Remarks
This method, together with BeginSave(Stream), SavePage and EndSave, allows to save a PDF document page by page and page content by page content thus reducing the memory consumption. This method lets you save pieces of the page content while making possible to add new content to the page after the save. In this way, if the page content is very large, if can be saved piece by piece by calling this method multiple times. After the page is completed a call to SavePage is required.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%% $$Properties$$

PDFDocument Class Properties

O2S.Components.PDF4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Properties
 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | Attachments | Gets the list of file attachments embedded in this document.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | Bookmarks | Gets the list of bookmarks in the PDF document.
Public Property | Dictionary | Gets the document catalog dictionary.
Public Property | DisplayMode | Gets or sets how the document should be displayed when opened in the viewer.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | Form | Gets the PDF form included in the document.
Public Property | ID | Gets the document ID.
Public Property | JavaScripts | Gets the list of global JavaScript actions associated with this document.
Public Property | Metadata | Gets the XMP metadata for this PDFDocument object.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | OutputIntents | Gets or sets the collection of output intents.
Public Property | PageBackground | Gets or sets the default page background.
Public Property | PageHeight | Gets or sets the default page height.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | PageNumber | Gets or sets the default page number visual aspect for this PDFDocument object.
Public Property | PageNumberingRanges | Gets the list of page numbering ranges in the PDF document.
Public Property | PageOrientation | Gets or sets the default page orientation.
Public Property | Pages | Gets the document's collection of pages.
Public Property | PageSize | Gets or sets the default page size.
Public Property | PageWidth | Gets or sets the default page width.
Public Property | PDFVersion | Gets or sets the PDF version of this PDFDocument object.
Public Property | PortfolioInformation | Gets or sets the portfolio information associated with this document.
Public Property | SecurityManager | Gets or sets the security manager for this pdf document.
Public Property | SerialNumber | Sets the serial number and unlocks the component.
Public Property | VersionExtension | Gets or sets the version extension.
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Public Property | XFAForm | Gets the XFA form associated with this document.
Top
See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


AfterPrintAction Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : AfterPrintAction Property
Gets or sets the javascript action to execute after the document is printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AfterPrintAction As PDFJavaScriptAction
'Usage

Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.AfterPrintAction = value

value = instance.AfterPrintAction
public PDFJavaScriptAction AfterPrintAction {get; set;}
public: __property PDFJavaScriptAction* get_AfterPrintAction();
public: __property void set_AfterPrintAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ AfterPrintAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFJavaScriptAction object specifying the action to be executed after the document is printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


AfterSaveAction Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : AfterSaveAction Property
Gets or sets the javascript action to execute after the document is saved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AfterSaveAction As PDFJavaScriptAction
'Usage

Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.AfterSaveAction = value

value = instance.AfterSaveAction
public PDFJavaScriptAction AfterSaveAction {get; set;}
public: __property PDFJavaScriptAction* get_AfterSaveAction();
public: __property void set_AfterSaveAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ AfterSaveAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFJavaScriptAction object specifying the action to be executed after the document is saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


Attachments Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : Attachments Property
Gets the list of file attachments embedded in this document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Attachments As PDFDocumentAttachmentCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFDocumentAttachmentCollection

value = instance.Attachments
public PDFDocumentAttachmentCollection Attachments {get;}
public: __property PDFDocumentAttachmentCollection* get_Attachments();
public:
property PDFDocumentAttachmentCollection^ Attachments {
   PDFDocumentAttachmentCollection^ get();
}

Property Value

PDFDocumentAttachmentCollection object specifying the list of document attachments.
Remarks
When a PDF file is imported into a PDFDocument object, this collection is populated automatically with the attachments in the file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


BeforeCloseAction Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : BeforeCloseAction Property
Gets or sets the javascript action to execute before the document is closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BeforeCloseAction As PDFJavaScriptAction
'Usage

Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.BeforeCloseAction = value

value = instance.BeforeCloseAction
public PDFJavaScriptAction BeforeCloseAction {get; set;}
public: __property PDFJavaScriptAction* get_BeforeCloseAction();
public: __property void set_BeforeCloseAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ BeforeCloseAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFJavaScriptAction object specifying the action to be executed before the document is closed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


BeforePrintAction Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : BeforePrintAction Property
Gets or sets the javascript action to execute before the document is printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BeforePrintAction As PDFJavaScriptAction
'Usage

Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.BeforePrintAction = value

value = instance.BeforePrintAction
public PDFJavaScriptAction BeforePrintAction {get; set;}
public: __property PDFJavaScriptAction* get_BeforePrintAction();
public: __property void set_BeforePrintAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ BeforePrintAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFJavaScriptAction object specifying the action to be executed before the document is printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


BeforeSaveAction Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : BeforeSaveAction Property
Gets or sets the javascript action to execute before the document is saved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BeforeSaveAction As PDFJavaScriptAction
'Usage

Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.BeforeSaveAction = value

value = instance.BeforeSaveAction
public PDFJavaScriptAction BeforeSaveAction {get; set;}
public: __property PDFJavaScriptAction* get_BeforeSaveAction();
public: __property void set_BeforeSaveAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ BeforeSaveAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFJavaScriptAction object specifying the action to be executed before the document is saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


Bookmarks Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : Bookmarks Property
Gets the list of bookmarks in the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bookmarks As PDFBookmarkCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFBookmarkCollection

value = instance.Bookmarks
public PDFBookmarkCollection Bookmarks {get;}
public: __property PDFBookmarkCollection* get_Bookmarks();
public:
property PDFBookmarkCollection^ Bookmarks {
   PDFBookmarkCollection^ get();
}

Property Value

The list of top level bookmarks in the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


Dictionary Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : Dictionary Property
Gets the document catalog dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFDocument
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw document catalog dictionary.
Remarks
This property gives you direct access to document catalog dictionary and the entire PDF tree. Starting with the document catalog dictionary every bit of information stored in the PDF file can be accessed using the low level COS objects even if it is not avialable through PDF4NET public API.
Note: Modifying directly the document catalog dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


DisplayMode Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : DisplayMode Property
Gets or sets how the document should be displayed when opened in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayMode As PDFDisplayMode
'Usage

Dim instance As PDFDocument
Dim value As PDFDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
public PDFDisplayMode DisplayMode {get; set;}
public: __property PDFDisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   PDFDisplayMode value
);
public:
property PDFDisplayMode DisplayMode {
   PDFDisplayMode get();
   void set (    PDFDisplayMode value);
}

Property Value

A PDFDisplayMode enumeration member specifying how the viewer should display the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


DocumentInformation Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : DocumentInformation Property
Gets or sets the document information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DocumentInformation As PDFDocumentInformation
'Usage

Dim instance As PDFDocument
Dim value As PDFDocumentInformation

instance.DocumentInformation = value

value = instance.DocumentInformation
public PDFDocumentInformation DocumentInformation {get; set;}
public: __property PDFDocumentInformation* get_DocumentInformation();
public: __property void set_DocumentInformation(
   PDFDocumentInformation* value
);
public:
property PDFDocumentInformation^ DocumentInformation {
   PDFDocumentInformation^ get();
   void set (    PDFDocumentInformation^ value);
}

Property Value

The document's metadata.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


Form Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : Form Property
Gets the PDF form included in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Form As PDFForm
'Usage

Dim instance As PDFDocument
Dim value As PDFForm

value = instance.Form
public PDFForm Form {get;}
public: __property PDFForm* get_Form();
public:
property PDFForm^ Form {
   PDFForm^ get();
}

Property Value

A O2S.Components.PDF4NET.Forms.PDFForm object representing the PDF form included in the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


ID Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : ID Property
Gets the document ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ID As String
'Usage

Dim instance As PDFDocument
Dim value As String

value = instance.ID
public string ID {get;}
public: __property string* get_ID();
public:
property String^ ID {
   String^ get();
}

Property Value

The PDF identifier of this document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


JavaScripts Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : JavaScripts Property
Gets the list of global JavaScript actions associated with this document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property JavaScripts As PDFJavaScriptCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFJavaScriptCollection

value = instance.JavaScripts
public PDFJavaScriptCollection JavaScripts {get;}
public: __property PDFJavaScriptCollection* get_JavaScripts();
public:
property PDFJavaScriptCollection^ JavaScripts {
   PDFJavaScriptCollection^ get();
}

Property Value

PDFJavaScriptCollection object specifying the list of global JavaScript actions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


Metadata Property
Example

O2S.Components.PDF4NET Namespace > PDFDocument Class : Metadata Property
Gets the XMP metadata for this PDFDocument object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Metadata As PDFXMPMetadata
'Usage

Dim instance As PDFDocument
Dim value As PDFXMPMetadata

instance.Metadata = value

value = instance.Metadata
public PDFXMPMetadata Metadata {get; set;}
public: __property PDFXMPMetadata* get_Metadata();
public: __property void set_Metadata(
   PDFXMPMetadata* value
);
public:
property PDFXMPMetadata^ Metadata {
   PDFXMPMetadata^ get();
   void set (    PDFXMPMetadata^ value);
}

Property Value

A PDFXMPMetadata object specifying the collection of metadata schemas.
Remarks
Metadata schemas are used to define custom properties for a document. Related properties can be grouped into a schema and several schemas can be attached to a document.
Example
The following example shows how to set several custom properties for a document:
  • C#
...
PDFDocument doc = new PDFDocument();

PDFMetadataSchema schema = new PDFMetadataSchema();
schema.Name = "http://ns.o2sol.com/schema/pdf/1.4/";
schema.NamespacePrefix = "o2sol";

// set Company attribute
schema["Company"] = "O2 Solutions";
// set Website attribute
schema["Website"] = "http://www.o2sol.com/";

// Add schema to the document
doc.Metadata.MetadataSchemas.Add(schema);
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


OpenAction Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : OpenAction Property
Gets or sets the action to execute when the document is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OpenAction As PDFAction
'Usage

Dim instance As PDFDocument
Dim value As PDFAction

instance.OpenAction = value

value = instance.OpenAction
public PDFAction OpenAction {get; set;}
public: __property PDFAction* get_OpenAction();
public: __property void set_OpenAction(
   PDFAction* value
);
public:
property PDFAction^ OpenAction {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFAction object specifying the action to be executed when documents opens in the viewer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


OutputIntents Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : OutputIntents Property
Gets or sets the collection of output intents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OutputIntents As PDFOutputIntentCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFOutputIntentCollection

instance.OutputIntents = value

value = instance.OutputIntents
public PDFOutputIntentCollection OutputIntents {get; set;}
public: __property PDFOutputIntentCollection* get_OutputIntents();
public: __property void set_OutputIntents(
   PDFOutputIntentCollection* value
);
public:
property PDFOutputIntentCollection^ OutputIntents {
   PDFOutputIntentCollection^ get();
   void set (    PDFOutputIntentCollection^ value);
}

Property Value

A collection of PDFOutputIntent objects describing the color characteristics of output devices on which the document might be rendered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PageBackground Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : PageBackground Property
Gets or sets the default page background.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageBackground As PDFPageBackground
'Usage

Dim instance As PDFDocument
Dim value As PDFPageBackground

instance.PageBackground = value

value = instance.PageBackground
public PDFPageBackground PageBackground {get; set;}
public: __property PDFPageBackground* get_PageBackground();
public: __property void set_PageBackground(
   PDFPageBackground* value
);
public:
property PDFPageBackground^ PageBackground {
   PDFPageBackground^ get();
   void set (    PDFPageBackground^ value);
}

Property Value

A PDFPageBackground object specifying the default background for pages creates with AddPage method.
Remarks
This value is used by the AddPage method when adding a new page to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PageHeight Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : PageHeight Property
Gets or sets the default page height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageHeight As Double
'Usage

Dim instance As PDFDocument
Dim value As Double

instance.PageHeight = value

value = instance.PageHeight
public double PageHeight {get; set;}
public: __property double get_PageHeight();
public: __property void set_PageHeight(
   double value
);
public:
property double PageHeight {
   double get();
   void set (    double value);
}

Property Value

Default height for newly created document pages.
Remarks
This value is used by the AddPage method when adding a new page to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PageLayout Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : PageLayout Property
Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageLayout As PDFPageLayout
'Usage

Dim instance As PDFDocument
Dim value As PDFPageLayout

instance.PageLayout = value

value = instance.PageLayout
public PDFPageLayout PageLayout {get; set;}
public: __property PDFPageLayout get_PageLayout();
public: __property void set_PageLayout(
   PDFPageLayout value
);
public:
property PDFPageLayout PageLayout {
   PDFPageLayout get();
   void set (    PDFPageLayout value);
}

Property Value

The document's page layout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PageNumber Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : PageNumber Property
Gets or sets the default page number visual aspect for this PDFDocument object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As PDFPageNumber
'Usage

Dim instance As PDFDocument
Dim value As PDFPageNumber

instance.PageNumber = value

value = instance.PageNumber
public PDFPageNumber PageNumber {get; set;}
public: __property PDFPageNumber* get_PageNumber();
public: __property void set_PageNumber(
   PDFPageNumber* value
);
public:
property PDFPageNumber^ PageNumber {
   PDFPageNumber^ get();
   void set (    PDFPageNumber^ value);
}

Property Value

A PDFPageNumber object specifying the default visual appearance of the printed page numbers.
Remarks
This value is used by the AddPage method when adding a new page to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PageNumberingRanges Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : PageNumberingRanges Property
Gets the list of page numbering ranges in the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumberingRanges As PDFPageNumberingRangeCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFPageNumberingRangeCollection

value = instance.PageNumberingRanges
public PDFPageNumberingRangeCollection PageNumberingRanges {get;}
public: __property PDFPageNumberingRangeCollection* get_PageNumberingRanges();
public:
property PDFPageNumberingRangeCollection^ PageNumberingRanges {
   PDFPageNumberingRangeCollection^ get();
}

Property Value

The list of page numbering ranges in the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PageOrientation Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : PageOrientation Property
Gets or sets the default page orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageOrientation As PDFPageOrientation
'Usage

Dim instance As PDFDocument
Dim value As PDFPageOrientation

instance.PageOrientation = value

value = instance.PageOrientation
public PDFPageOrientation PageOrientation {get; set;}
public: __property PDFPageOrientation get_PageOrientation();
public: __property void set_PageOrientation(
   PDFPageOrientation value
);
public:
property PDFPageOrientation PageOrientation {
   PDFPageOrientation get();
   void set (    PDFPageOrientation value);
}

Property Value

A PageOrientation enumeration member specifying the default orientation for newly created document pages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


Pages Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : Pages Property
Gets the document's collection of pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pages As PDFPageCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFPageCollection

value = instance.Pages
public PDFPageCollection Pages {get;}
public: __property PDFPageCollection* get_Pages();
public:
property PDFPageCollection^ Pages {
   PDFPageCollection^ get();
}

Property Value

A PDFPageCollection object containing the list of document's pages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PageSize Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : PageSize Property
Gets or sets the default page size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageSize As PDFPageSize
'Usage

Dim instance As PDFDocument
Dim value As PDFPageSize

instance.PageSize = value

value = instance.PageSize
public PDFPageSize PageSize {get; set;}
public: __property PDFPageSize get_PageSize();
public: __property void set_PageSize(
   PDFPageSize value
);
public:
property PDFPageSize PageSize {
   PDFPageSize get();
   void set (    PDFPageSize value);
}

Property Value

A PDFPageSize enumeration member specifying the default size for newly created document pages.
Remarks
This value is used by the AddPage method when adding a new page to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PageWidth Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : PageWidth Property
Gets or sets the default page width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageWidth As Double
'Usage

Dim instance As PDFDocument
Dim value As Double

instance.PageWidth = value

value = instance.PageWidth
public double PageWidth {get; set;}
public: __property double get_PageWidth();
public: __property void set_PageWidth(
   double value
);
public:
property double PageWidth {
   double get();
   void set (    double value);
}

Property Value

Default width for newly created document pages.
Remarks
This value is used by the AddPage method when adding a new page to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PDFVersion Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : PDFVersion Property
Gets or sets the PDF version of this PDFDocument object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PDFVersion As PDFVersion
'Usage

Dim instance As PDFDocument
Dim value As PDFVersion

instance.PDFVersion = value

value = instance.PDFVersion
public PDFVersion PDFVersion {get; set;}
public: __property PDFVersion get_PDFVersion();
public: __property void set_PDFVersion(
   PDFVersion value
);
public:
property PDFVersion PDFVersion {
   PDFVersion get();
   void set (    PDFVersion value);
}

Property Value

A PDFVersion enumeration member specifying the PDF version of this PDFDocument object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


PortfolioInformation Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : PortfolioInformation Property
Gets or sets the portfolio information associated with this document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PortfolioInformation As PDFPortfolioInformation
'Usage

Dim instance As PDFDocument
Dim value As PDFPortfolioInformation

instance.PortfolioInformation = value

value = instance.PortfolioInformation
public PDFPortfolioInformation PortfolioInformation {get; set;}
public: __property PDFPortfolioInformation* get_PortfolioInformation();
public: __property void set_PortfolioInformation(
   PDFPortfolioInformation* value
);
public:
property PDFPortfolioInformation^ PortfolioInformation {
   PDFPortfolioInformation^ get();
   void set (    PDFPortfolioInformation^ value);
}

Property Value

Portfolio information stored in this document.
Remarks
Set this property to a valid O2S.Components.PDF4NET.Portfolios.PDFPortfolioInformation object and the document is transformed into a PDF portfolio.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


SecurityManager Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : SecurityManager Property
Gets or sets the security manager for this pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SecurityManager As PDFSecurityManager
'Usage

Dim instance As PDFDocument
Dim value As PDFSecurityManager

instance.SecurityManager = value

value = instance.SecurityManager
public PDFSecurityManager SecurityManager {get; set;}
public: __property PDFSecurityManager* get_SecurityManager();
public: __property void set_SecurityManager(
   PDFSecurityManager* value
);
public:
property PDFSecurityManager^ SecurityManager {
   PDFSecurityManager^ get();
   void set (    PDFSecurityManager^ value);
}

Property Value

A O2S.Components.PDF4NET.Security.PDFSecurityManager object specifying the security manager for this pdf document.
Remarks
Set this property to a valid security manager object to enforce security settings (document encryption, passwords, access rights), on the pdf document. When this property is null, no security is applied on the resulted pdf document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


SerialNumber Property (PDFDocument)

O2S.Components.PDF4NET Namespace > PDFDocument Class : SerialNumber Property
Sets the serial number and unlocks the component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public WriteOnly Property SerialNumber As String
'Usage

Dim instance As PDFDocument

instance.SerialNumber = value
public string SerialNumber {set;}
public: __property void set_SerialNumber(
   string* value
);
public:
property String^ SerialNumber {
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


VersionExtension Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : VersionExtension Property
Gets or sets the version extension.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VersionExtension As PDFVersionExtension
'Usage

Dim instance As PDFDocument
Dim value As PDFVersionExtension

instance.VersionExtension = value

value = instance.VersionExtension
public PDFVersionExtension VersionExtension {get; set;}
public: __property PDFVersionExtension* get_VersionExtension();
public: __property void set_VersionExtension(
   PDFVersionExtension* value
);
public:
property PDFVersionExtension^ VersionExtension {
   PDFVersionExtension^ get();
   void set (    PDFVersionExtension^ value);
}

Property Value

The extended PDF version this document implements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


ViewerPreferences Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : ViewerPreferences Property
Gets or sets the document's viewer preferences.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ViewerPreferences As PDFViewerPreferences
'Usage

Dim instance As PDFDocument
Dim value As PDFViewerPreferences

instance.ViewerPreferences = value

value = instance.ViewerPreferences
public PDFViewerPreferences ViewerPreferences {get; set;}
public: __property PDFViewerPreferences* get_ViewerPreferences();
public: __property void set_ViewerPreferences(
   PDFViewerPreferences* value
);
public:
property PDFViewerPreferences^ ViewerPreferences {
   PDFViewerPreferences^ get();
   void set (    PDFViewerPreferences^ value);
}

Property Value

The viewer preferences for displaying the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


XFAForm Property

O2S.Components.PDF4NET Namespace > PDFDocument Class : XFAForm Property
Gets the XFA form associated with this document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property XFAForm As XFAForm
'Usage

Dim instance As PDFDocument
Dim value As XFAForm

value = instance.XFAForm
public XFAForm XFAForm {get;}
public: __property XFAForm* get_XFAForm();
public:
property XFAForm^ XFAForm {
   XFAForm^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PDFDocumentAttachment Class
Members

O2S.Components.PDF4NET Namespace : PDFDocumentAttachment Class
Defines a file embedded in a PDF document.
Object Model
PDFDocumentAttachment ClassPDFDictionary ClassPDFPortfolioFolder ClassPDFPortfolioAttributes Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDocumentAttachment
'Usage

Dim instance As PDFDocumentAttachment
public class PDFDocumentAttachment
public __gc class PDFDocumentAttachment
public ref class PDFDocumentAttachment
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocumentAttachment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocumentAttachment Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFDocumentAttachment Class

The following tables list the members exposed by PDFDocumentAttachment.

Public Constructors
 | Name | Description
Public Constructor | PDFDocumentAttachment Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Compress | Gets or sets a value indicating whether the attachment content should be compressed or not.
Public Property | CreationDate | Gets or sets the creation date and time of the attachment.
Public Property | Description | Gets or sets the attachment description.
Public Property | Dictionary | Gets the attachment dictionary.
Public Property | FileData | Gets or sets the file data for this embedded file.
Public Property | FileName | Gets or sets the name of file to embed.
Public Property | Folder | Gets or sets the portfolio folder that includes this attachment.
Public Property | MimeType | Gets or sets the MIME type of the file to embed.
Public Property | ModifyDate | Gets or sets the modify date and time of the attachment.
Public Property | PortfolioAttributes | Gets or sets the portfolio attributes for this attachment.
Public Property | RelationshipWithDocument | Gets or sets the relationship between the attachment and the document.
Top
See Also

Reference

PDFDocumentAttachment Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocumentAttachment Constructor

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : PDFDocumentAttachment Constructor
Overload List
Overload | Description
PDFDocumentAttachment Constructor() | Initializes a new PDFDocumentAttachment object.
PDFDocumentAttachment Constructor(String) | Initializes a new PDFDocumentAttachment object with the given file.
PDFDocumentAttachment Constructor(Byte[]) | Initializes a new PDFDocumentAttachment object with the given content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


%%PageItemTitle%%

PDFDocumentAttachment Constructor()

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class > PDFDocumentAttachment Constructor : PDFDocumentAttachment Constructor()
Initializes a new PDFDocumentAttachment object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDocumentAttachment()
public PDFDocumentAttachment()
public: PDFDocumentAttachment();
public:
PDFDocumentAttachment();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members
Overload List


%%PageItemTitle%%

PDFDocumentAttachment Constructor(String)

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class > PDFDocumentAttachment Constructor : PDFDocumentAttachment Constructor(String)
The name of the file to embed.
Initializes a new PDFDocumentAttachment object with the given file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String _
)
'Usage

Dim fileName As String

Dim instance As New PDFDocumentAttachment(fileName)
public PDFDocumentAttachment(
   string fileName
)
public: PDFDocumentAttachment(
   string* fileName
)
public:
PDFDocumentAttachment(
   String^ fileName
)

Parameters

fileName
The name of the file to embed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members
Overload List


%%PageItemTitle%%

PDFDocumentAttachment Constructor(Byte[])

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class > PDFDocumentAttachment Constructor : PDFDocumentAttachment Constructor(Byte[])
The binary content to embed in the PDF file.
Initializes a new PDFDocumentAttachment object with the given content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileData() As Byte _
)
'Usage

Dim fileData() As Byte

Dim instance As New PDFDocumentAttachment(fileData)
public PDFDocumentAttachment(
   byte[] fileData
)
public: PDFDocumentAttachment(
   byte[]* fileData
)
public:
PDFDocumentAttachment(
   array<byte>^ fileData
)

Parameters

fileData
The binary content to embed in the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFDocumentAttachment Class Properties

O2S.Components.PDF4NET Namespace : PDFDocumentAttachment Class

For a list of all members of this type, see PDFDocumentAttachment members.

Public Properties
 | Name | Description
Public Property | Compress | Gets or sets a value indicating whether the attachment content should be compressed or not.
Public Property | CreationDate | Gets or sets the creation date and time of the attachment.
Public Property | Description | Gets or sets the attachment description.
Public Property | Dictionary | Gets the attachment dictionary.
Public Property | FileData | Gets or sets the file data for this embedded file.
Public Property | FileName | Gets or sets the name of file to embed.
Public Property | Folder | Gets or sets the portfolio folder that includes this attachment.
Public Property | MimeType | Gets or sets the MIME type of the file to embed.
Public Property | ModifyDate | Gets or sets the modify date and time of the attachment.
Public Property | PortfolioAttributes | Gets or sets the portfolio attributes for this attachment.
Public Property | RelationshipWithDocument | Gets or sets the relationship between the attachment and the document.
Top
See Also

Reference

PDFDocumentAttachment Class
O2S.Components.PDF4NET Namespace


Compress Property

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : Compress Property
Gets or sets a value indicating whether the attachment content should be compressed or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compress As Boolean
'Usage

Dim instance As PDFDocumentAttachment
Dim value As Boolean

instance.Compress = value

value = instance.Compress
public bool Compress {get; set;}
public: __property bool get_Compress();
public: __property void set_Compress(
   bool value
);
public:
property bool Compress {
   bool get();
   void set (    bool value);
}

Property Value

True if the content should be compressed (default), false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


CreationDate Property (PDFDocumentAttachment)

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : CreationDate Property
Gets or sets the creation date and time of the attachment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PDFDocumentAttachment
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

A DateTime value specifying the date and time when the attachment was created.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


Description Property (PDFDocumentAttachment)

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : Description Property
Gets or sets the attachment description.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As PDFDocumentAttachment
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying an optional description associated with this attachment.
Remarks
The description is used to provide the user with more information about the embedded attachment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


Dictionary Property (PDFDocumentAttachment)

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : Dictionary Property
Gets the attachment dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFDocumentAttachment
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw attachment dictionary.
Remarks
This property gives you direct access to attachment dictionary and its associated resources. Note: Modifying directly the attachment dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


FileData Property

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : FileData Property
Gets or sets the file data for this embedded file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileData As Byte()
'Usage

Dim instance As PDFDocumentAttachment
Dim value() As Byte

instance.FileData = value

value = instance.FileData
public byte[] FileData {get; set;}
public: __property byte[]* get_FileData();
public: __property void set_FileData(
   byte[]* value
);
public:
property array<byte>^ FileData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array specifying the content to embed.
Remarks
If both FileName and FileData are set, FileData will be used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


FileName Property (PDFDocumentAttachment)

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : FileName Property
Gets or sets the name of file to embed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PDFDocumentAttachment
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string specifying the file to embed.
Remarks
If both FileName and FileData are set, FileData will be used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


Folder Property (PDFDocumentAttachment)

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : Folder Property
Gets or sets the portfolio folder that includes this attachment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Folder As PDFPortfolioFolder
'Usage

Dim instance As PDFDocumentAttachment
Dim value As PDFPortfolioFolder

instance.Folder = value

value = instance.Folder
public PDFPortfolioFolder Folder {get; set;}
public: __property PDFPortfolioFolder* get_Folder();
public: __property void set_Folder(
   PDFPortfolioFolder* value
);
public:
property PDFPortfolioFolder^ Folder {
   PDFPortfolioFolder^ get();
   void set (    PDFPortfolioFolder^ value);
}

Property Value

The portfolio folder that includes this attachment.
Remarks
Folders are used to group attachments into logical groups and they are displayed in the tree like sturcture. An attachment without a folder is displayed directly under portfolio root.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


MimeType Property

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : MimeType Property
Gets or sets the MIME type of the file to embed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MimeType As String
'Usage

Dim instance As PDFDocumentAttachment
Dim value As String

instance.MimeType = value

value = instance.MimeType
public string MimeType {get; set;}
public: __property string* get_MimeType();
public: __property void set_MimeType(
   string* value
);
public:
property String^ MimeType {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the MIME type of the file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


ModifyDate Property (PDFDocumentAttachment)

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : ModifyDate Property
Gets or sets the modify date and time of the attachment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModifyDate As Date
'Usage

Dim instance As PDFDocumentAttachment
Dim value As Date

instance.ModifyDate = value

value = instance.ModifyDate
public DateTime ModifyDate {get; set;}
public: __property DateTime get_ModifyDate();
public: __property void set_ModifyDate(
   DateTime value
);
public:
property DateTime ModifyDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

A DateTime value specifying the date and time when the attachment was modified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


PortfolioAttributes Property (PDFDocumentAttachment)

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : PortfolioAttributes Property
Gets or sets the portfolio attributes for this attachment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PortfolioAttributes As PDFPortfolioAttributes
'Usage

Dim instance As PDFDocumentAttachment
Dim value As PDFPortfolioAttributes

instance.PortfolioAttributes = value

value = instance.PortfolioAttributes
public PDFPortfolioAttributes PortfolioAttributes {get; set;}
public: __property PDFPortfolioAttributes* get_PortfolioAttributes();
public: __property void set_PortfolioAttributes(
   PDFPortfolioAttributes* value
);
public:
property PDFPortfolioAttributes^ PortfolioAttributes {
   PDFPortfolioAttributes^ get();
   void set (    PDFPortfolioAttributes^ value);
}

Property Value

A collection of attributes associated with this attachment.
Remarks
These attributes are displayed in the user interface of the PDF viewer application when this document attachment is part of a PDF portfolio.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


RelationshipWithDocument Property

O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : RelationshipWithDocument Property
Gets or sets the relationship between the attachment and the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RelationshipWithDocument As PDFDocumentAttachmentRelationship
'Usage

Dim instance As PDFDocumentAttachment
Dim value As PDFDocumentAttachmentRelationship

instance.RelationshipWithDocument = value

value = instance.RelationshipWithDocument
public PDFDocumentAttachmentRelationship RelationshipWithDocument {get; set;}
public: __property PDFDocumentAttachmentRelationship get_RelationshipWithDocument();
public: __property void set_RelationshipWithDocument(
   PDFDocumentAttachmentRelationship value
);
public:
property PDFDocumentAttachmentRelationship RelationshipWithDocument {
   PDFDocumentAttachmentRelationship get();
   void set (    PDFDocumentAttachmentRelationship value);
}

Property Value

A PDFDocumentAttachmentRelationship enumeration member specifying the relationship between the attachment and the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


%%PageItemTitle%%

PDFDocumentAttachmentCollection Class
Members

O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class
Defines a collection of annotations.
Object Model
PDFDocumentAttachmentCollection ClassPDFDocumentAttachment Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDocumentAttachmentCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFDocumentAttachment,PDFDocument)
'Usage

Dim instance As PDFDocumentAttachmentCollection
public class PDFDocumentAttachmentCollection : O2S.Components.PDF4NET.PDFCollection<PDFDocumentAttachment,PDFDocument>
public __gc class PDFDocumentAttachmentCollection : public O2S.Components.PDF4NET.PDFCollection<PDFDocumentAttachment,PDFDocument>
public ref class PDFDocumentAttachmentCollection : public O2S.Components.PDF4NET.PDFCollection<PDFDocumentAttachment,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.PDFDocumentAttachmentCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentAttachmentCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocumentAttachmentCollection Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

The following tables list the members exposed by PDFDocumentAttachmentCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Top
See Also

Reference

PDFDocumentAttachmentCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocumentInformation Class
Members

O2S.Components.PDF4NET Namespace : PDFDocumentInformation Class
Provides access to document metadata.
Object Model
PDFDocumentInformation ClassPDFCustomProperties ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDocumentInformation
'Usage

Dim instance As PDFDocumentInformation
public class PDFDocumentInformation
public __gc class PDFDocumentInformation
public ref class PDFDocumentInformation
Remarks
This class stores document general information, such as document's title, author and other information.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocumentInformation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocumentInformation Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFDocumentInformation Class

The following tables list the members exposed by PDFDocumentInformation.

Public Constructors
 | Name | Description
Public Constructor | PDFDocumentInformation Constructor | Initializes a new PDFDocumentInformation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the author of the document.
Public Property | CreationDate | Gets or sets the date when the document was created.
Public Property | Creator | Gets or sets the application that created the document.
Public Property | CustomProperties | Gets the collection of custom properties of the document.
Public Property | Dictionary | Gets the document information dictionary.
Public Property | Keywords | Gets or sets the keywords of the document.
Public Property | ModDate | Gets or sets the date when the document was modified.
Public Property | Producer | Gets or sets the PDF engine that produced the document.
Public Property | Subject | Gets or sets the subject of the document.
Public Property | Title | Gets or sets the title of the document.
Top
See Also

Reference

PDFDocumentInformation Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocumentInformation Constructor

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : PDFDocumentInformation Constructor
Initializes a new PDFDocumentInformation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDocumentInformation()
public PDFDocumentInformation()
public: PDFDocumentInformation();
public:
PDFDocumentInformation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%% $$Properties$$

PDFDocumentInformation Class Properties

O2S.Components.PDF4NET Namespace : PDFDocumentInformation Class

For a list of all members of this type, see PDFDocumentInformation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the author of the document.
Public Property | CreationDate | Gets or sets the date when the document was created.
Public Property | Creator | Gets or sets the application that created the document.
Public Property | CustomProperties | Gets the collection of custom properties of the document.
Public Property | Dictionary | Gets the document information dictionary.
Public Property | Keywords | Gets or sets the keywords of the document.
Public Property | ModDate | Gets or sets the date when the document was modified.
Public Property | Producer | Gets or sets the PDF engine that produced the document.
Public Property | Subject | Gets or sets the subject of the document.
Public Property | Title | Gets or sets the title of the document.
Top
See Also

Reference

PDFDocumentInformation Class
O2S.Components.PDF4NET Namespace


Author Property (PDFDocumentInformation)

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Author Property
Gets or sets the author of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The document author.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


CreationDate Property (PDFDocumentInformation)

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : CreationDate Property
Gets or sets the date when the document was created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PDFDocumentInformation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The document creation date.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Creator Property

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Creator Property
Gets or sets the application that created the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Creator As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Creator = value

value = instance.Creator
public string Creator {get; set;}
public: __property string* get_Creator();
public: __property void set_Creator(
   string* value
);
public:
property String^ Creator {
   String^ get();
   void set (    String^ value);
}

Property Value

The document creator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


CustomProperties Property

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : CustomProperties Property
Gets the collection of custom properties of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CustomProperties As PDFCustomProperties
'Usage

Dim instance As PDFDocumentInformation
Dim value As PDFCustomProperties

value = instance.CustomProperties
public PDFCustomProperties CustomProperties {get;}
public: __property PDFCustomProperties* get_CustomProperties();
public:
property PDFCustomProperties^ CustomProperties {
   PDFCustomProperties^ get();
}

Property Value

a PDFCustomProperties object storing the document's custom properties.
Remarks
The properties in this collection are stored in the DocumentInformation dictionary as custom keys.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Dictionary Property (PDFDocumentInformation)

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Dictionary Property
Gets the document information dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFDocumentInformation
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw document information dictionary.
Remarks
This property gives you direct access to document information dictionary and its associated resources. Note: Modifying directly the document information dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Keywords Property

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Keywords Property
Gets or sets the keywords of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Keywords As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Keywords = value

value = instance.Keywords
public string Keywords {get; set;}
public: __property string* get_Keywords();
public: __property void set_Keywords(
   string* value
);
public:
property String^ Keywords {
   String^ get();
   void set (    String^ value);
}

Property Value

The document keywords.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


ModDate Property

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : ModDate Property
Gets or sets the date when the document was modified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModDate As Date
'Usage

Dim instance As PDFDocumentInformation
Dim value As Date

instance.ModDate = value

value = instance.ModDate
public DateTime ModDate {get; set;}
public: __property DateTime get_ModDate();
public: __property void set_ModDate(
   DateTime value
);
public:
property DateTime ModDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The document modifiy date.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Producer Property

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Producer Property
Gets or sets the PDF engine that produced the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Producer As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Producer = value

value = instance.Producer
public string Producer {get; set;}
public: __property string* get_Producer();
public: __property void set_Producer(
   string* value
);
public:
property String^ Producer {
   String^ get();
   void set (    String^ value);
}

Property Value

The document producer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Subject Property (PDFDocumentInformation)

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Subject Property
Gets or sets the subject of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Subject As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Subject = value

value = instance.Subject
public string Subject {get; set;}
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
public:
property String^ Subject {
   String^ get();
   void set (    String^ value);
}

Property Value

The document subject.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Title Property (PDFDocumentInformation)

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Title Property
Gets or sets the title of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

The document title.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

PDFDocumentLoadOptions Class
Members

O2S.Components.PDF4NET Namespace : PDFDocumentLoadOptions Class
Provides several options for loading a PDF file.
Object Model
PDFDocumentLoadOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDocumentLoadOptions
'Usage

Dim instance As PDFDocumentLoadOptions
public class PDFDocumentLoadOptions
public __gc class PDFDocumentLoadOptions
public ref class PDFDocumentLoadOptions
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocumentLoadOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocumentLoadOptions Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFDocumentLoadOptions Class

The following tables list the members exposed by PDFDocumentLoadOptions.

Public Constructors
 | Name | Description
Public Constructor | PDFDocumentLoadOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CheckCyclicBookmarks | Gets or sets a value indicating whether the bookmarks hierarchy should be checked for cyclic bookmarks.
Public Property | CreatePageCanvas | Gets or sets a value indicating whether the page canvas should be created or not.
Public Property | LoadBookmarks | Gets or sets a value indicating whether the document bookmarks should be loaded or not.
Public Property | LoadDestinations | Gets or sets a value indicating whether the document destinations should be loaded or not.
Public Property | LoadDocumentAttachments | Gets or sets a value indicating whether the document attachments should be loaded or not.
Public Property | LoadFormFields | Gets or sets a flag indicating whether form fields should be loaded or not.
Public Property | LoadJavaScript | Gets or sets a value indicating whether the document level JavaScript should be loaded or not.
Public Property | LoadPageContent | Gets or sets a value indicating whether complete page content should be loaded or not.
Public Property | LoadStructureTree | Gets or sets a value indicating whether the document structure tree should be loaded or not.
Public Property | LoadThreads | Gets or sets a value indicating whether the document threads should be loaded or not.
Public Property | Password | Gets or sets the password for opening the PDF file.
Public Property | TryRepairDamagedFiles | Gets or sets a value indicating whether damaged files should be repaired or not.
Public Property | UnicodePassword | Gets or sets the Unicode password for opening the PDF file.
Top
See Also

Reference

PDFDocumentLoadOptions Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocumentLoadOptions Constructor

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : PDFDocumentLoadOptions Constructor
Overload List
Overload | Description
PDFDocumentLoadOptions Constructor() | Initializes a new PDFDocumentLoadOptions
PDFDocumentLoadOptions Constructor(Boolean) | Initializes a new PDFDocumentLoadOptions
PDFDocumentLoadOptions Constructor(Byte[]) | Initializes a new PDFDocumentLoadOptions
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


%%PageItemTitle%%

PDFDocumentLoadOptions Constructor()

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class > PDFDocumentLoadOptions Constructor : PDFDocumentLoadOptions Constructor()
Initializes a new PDFDocumentLoadOptions
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDocumentLoadOptions()
public PDFDocumentLoadOptions()
public: PDFDocumentLoadOptions();
public:
PDFDocumentLoadOptions();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members
Overload List


%%PageItemTitle%%

PDFDocumentLoadOptions Constructor(Boolean)

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class > PDFDocumentLoadOptions Constructor : PDFDocumentLoadOptions Constructor(Boolean)
True if all the load options, except CreatePageCanvas and CheckCyclicBookmarks, should be set to true, false otherwise.
Initializes a new PDFDocumentLoadOptions
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal load As Boolean _
)
'Usage

Dim load As Boolean

Dim instance As New PDFDocumentLoadOptions(load)
public PDFDocumentLoadOptions(
   bool load
)
public: PDFDocumentLoadOptions(
   bool load
)
public:
PDFDocumentLoadOptions(
   bool load
)

Parameters

load
True if all the load options, except CreatePageCanvas and CheckCyclicBookmarks, should be set to true, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members
Overload List


%%PageItemTitle%%

PDFDocumentLoadOptions Constructor(Byte[])

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class > PDFDocumentLoadOptions Constructor : PDFDocumentLoadOptions Constructor(Byte[])
The password for opening the PDF file.
Initializes a new PDFDocumentLoadOptions
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal password() As Byte _
)
'Usage

Dim password() As Byte

Dim instance As New PDFDocumentLoadOptions(password)
public PDFDocumentLoadOptions(
   byte[] password
)
public: PDFDocumentLoadOptions(
   byte[]* password
)
public:
PDFDocumentLoadOptions(
   array<byte>^ password
)

Parameters

password
The password for opening the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFDocumentLoadOptions Class Properties

O2S.Components.PDF4NET Namespace : PDFDocumentLoadOptions Class

For a list of all members of this type, see PDFDocumentLoadOptions members.

Public Properties
 | Name | Description
Public Property | CheckCyclicBookmarks | Gets or sets a value indicating whether the bookmarks hierarchy should be checked for cyclic bookmarks.
Public Property | CreatePageCanvas | Gets or sets a value indicating whether the page canvas should be created or not.
Public Property | LoadBookmarks | Gets or sets a value indicating whether the document bookmarks should be loaded or not.
Public Property | LoadDestinations | Gets or sets a value indicating whether the document destinations should be loaded or not.
Public Property | LoadDocumentAttachments | Gets or sets a value indicating whether the document attachments should be loaded or not.
Public Property | LoadFormFields | Gets or sets a flag indicating whether form fields should be loaded or not.
Public Property | LoadJavaScript | Gets or sets a value indicating whether the document level JavaScript should be loaded or not.
Public Property | LoadPageContent | Gets or sets a value indicating whether complete page content should be loaded or not.
Public Property | LoadStructureTree | Gets or sets a value indicating whether the document structure tree should be loaded or not.
Public Property | LoadThreads | Gets or sets a value indicating whether the document threads should be loaded or not.
Public Property | Password | Gets or sets the password for opening the PDF file.
Public Property | TryRepairDamagedFiles | Gets or sets a value indicating whether damaged files should be repaired or not.
Public Property | UnicodePassword | Gets or sets the Unicode password for opening the PDF file.
Top
See Also

Reference

PDFDocumentLoadOptions Class
O2S.Components.PDF4NET Namespace


CheckCyclicBookmarks Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : CheckCyclicBookmarks Property
Gets or sets a value indicating whether the bookmarks hierarchy should be checked for cyclic bookmarks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckCyclicBookmarks As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.CheckCyclicBookmarks = value

value = instance.CheckCyclicBookmarks
public bool CheckCyclicBookmarks {get; set;}
public: __property bool get_CheckCyclicBookmarks();
public: __property void set_CheckCyclicBookmarks(
   bool value
);
public:
property bool CheckCyclicBookmarks {
   bool get();
   void set (    bool value);
}

Property Value

True if the check should be performed, false otherwise. Default is false.
Remarks
In default mode cyclic bookmarks (an invalid PDF structure) cause an infinite loop when loading the file. Set this property to true to detect cyclic bookmarks and load the file, but depending on the size of the bookmarks tree this check can add a significant overhead.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


CreatePageCanvas Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : CreatePageCanvas Property
Gets or sets a value indicating whether the page canvas should be created or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatePageCanvas As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.CreatePageCanvas = value

value = instance.CreatePageCanvas
public bool CreatePageCanvas {get; set;}
public: __property bool get_CreatePageCanvas();
public: __property void set_CreatePageCanvas(
   bool value
);
public:
property bool CreatePageCanvas {
   bool get();
   void set (    bool value);
}

Property Value

True if the page canvas should be created, false otherwise. Default is true.
Remarks
This property should be set to false only when signing a PDF file that already contains a valid signature. Creating page canvases in such scenario causes the initial signature to be invalidated because the pages has been modified when the canvases have been created.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadBookmarks Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadBookmarks Property
Gets or sets a value indicating whether the document bookmarks should be loaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadBookmarks As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadBookmarks = value

value = instance.LoadBookmarks
public bool LoadBookmarks {get; set;}
public: __property bool get_LoadBookmarks();
public: __property void set_LoadBookmarks(
   bool value
);
public:
property bool LoadBookmarks {
   bool get();
   void set (    bool value);
}

Property Value

True if the bookmarks should be loaded, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadDestinations Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadDestinations Property
Gets or sets a value indicating whether the document destinations should be loaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadDestinations As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadDestinations = value

value = instance.LoadDestinations
public bool LoadDestinations {get; set;}
public: __property bool get_LoadDestinations();
public: __property void set_LoadDestinations(
   bool value
);
public:
property bool LoadDestinations {
   bool get();
   void set (    bool value);
}

Property Value

True if the destinations should be loaded, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadDocumentAttachments Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadDocumentAttachments Property
Gets or sets a value indicating whether the document attachments should be loaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadDocumentAttachments As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadDocumentAttachments = value

value = instance.LoadDocumentAttachments
public bool LoadDocumentAttachments {get; set;}
public: __property bool get_LoadDocumentAttachments();
public: __property void set_LoadDocumentAttachments(
   bool value
);
public:
property bool LoadDocumentAttachments {
   bool get();
   void set (    bool value);
}

Property Value

True if the document attachments should be loaded, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadFormFields Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadFormFields Property
Gets or sets a flag indicating whether form fields should be loaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadFormFields As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadFormFields = value

value = instance.LoadFormFields
public bool LoadFormFields {get; set;}
public: __property bool get_LoadFormFields();
public: __property void set_LoadFormFields(
   bool value
);
public:
property bool LoadFormFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the form fields should be loaded.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadJavaScript Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadJavaScript Property
Gets or sets a value indicating whether the document level JavaScript should be loaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadJavaScript As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadJavaScript = value

value = instance.LoadJavaScript
public bool LoadJavaScript {get; set;}
public: __property bool get_LoadJavaScript();
public: __property void set_LoadJavaScript(
   bool value
);
public:
property bool LoadJavaScript {
   bool get();
   void set (    bool value);
}

Property Value

True if the document level JavaScript should be loaded, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadPageContent Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadPageContent Property
Gets or sets a value indicating whether complete page content should be loaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadPageContent As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadPageContent = value

value = instance.LoadPageContent
public bool LoadPageContent {get; set;}
public: __property bool get_LoadPageContent();
public: __property void set_LoadPageContent(
   bool value
);
public:
property bool LoadPageContent {
   bool get();
   void set (    bool value);
}

Property Value

True if complete page content needs to be loaded, false otherwise. Default is true.
Remarks
Setting this property to true causes the complete page content to load, otherwise only the page header is loaded.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadStructureTree Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadStructureTree Property
Gets or sets a value indicating whether the document structure tree should be loaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadStructureTree As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadStructureTree = value

value = instance.LoadStructureTree
public bool LoadStructureTree {get; set;}
public: __property bool get_LoadStructureTree();
public: __property void set_LoadStructureTree(
   bool value
);
public:
property bool LoadStructureTree {
   bool get();
   void set (    bool value);
}

Property Value

True if the document structure tree should be loaded, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadThreads Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadThreads Property
Gets or sets a value indicating whether the document threads should be loaded or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadThreads As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadThreads = value

value = instance.LoadThreads
public bool LoadThreads {get; set;}
public: __property bool get_LoadThreads();
public: __property void set_LoadThreads(
   bool value
);
public:
property bool LoadThreads {
   bool get();
   void set (    bool value);
}

Property Value

True if the threads should be loaded, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


Password Property (PDFDocumentLoadOptions)

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : Password Property
Gets or sets the password for opening the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Password As Byte()
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value() As Byte

instance.Password = value

value = instance.Password
public byte[] Password {get; set;}
public: __property byte[]* get_Password();
public: __property void set_Password(
   byte[]* value
);
public:
property array<byte>^ Password {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The user or owner password required for opening the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


TryRepairDamagedFiles Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : TryRepairDamagedFiles Property
Gets or sets a value indicating whether damaged files should be repaired or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TryRepairDamagedFiles As Boolean
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.TryRepairDamagedFiles = value

value = instance.TryRepairDamagedFiles
public bool TryRepairDamagedFiles {get; set;}
public: __property bool get_TryRepairDamagedFiles();
public: __property void set_TryRepairDamagedFiles(
   bool value
);
public:
property bool TryRepairDamagedFiles {
   bool get();
   void set (    bool value);
}

Property Value

True if the damaged file should be repaired, if possible.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


UnicodePassword Property

O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : UnicodePassword Property
Gets or sets the Unicode password for opening the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnicodePassword As String
'Usage

Dim instance As PDFDocumentLoadOptions
Dim value As String

instance.UnicodePassword = value

value = instance.UnicodePassword
public string UnicodePassword {get; set;}
public: __property string* get_UnicodePassword();
public: __property void set_UnicodePassword(
   string* value
);
public:
property String^ UnicodePassword {
   String^ get();
   void set (    String^ value);
}

Property Value

The user or owner password required for opening the PDF file.
Remarks
This property must be set when opening an AES256 encrpyted PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


%%PageItemTitle%%

PDFDocumentSaveOptions Class
Members

O2S.Components.PDF4NET Namespace : PDFDocumentSaveOptions Class
Provides several options for saving a PDF file.
Object Model
PDFDocumentSaveOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDocumentSaveOptions
'Usage

Dim instance As PDFDocumentSaveOptions
public class PDFDocumentSaveOptions
public __gc class PDFDocumentSaveOptions
public ref class PDFDocumentSaveOptions
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocumentSaveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentSaveOptions Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocumentSaveOptions Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFDocumentSaveOptions Class

The following tables list the members exposed by PDFDocumentSaveOptions.

Public Constructors
 | Name | Description
Public Constructor | PDFDocumentSaveOptions Constructor | Initializes a new PDFDocumentSaveOptions
Top
Public Properties
 | Name | Description
Public Property | AllowInteractiveSignatures | Gets or sets a flag indicating whether an user interface can be displayed when signing a PDF file.
Public Property | FastWebView | Gets or sets a value indicating whether the document should be saved in fast web view mode or not.
Public Property | IncrementalUpdate | Gets or sets a value indicating whether incremental update should be used of document save or not.
Public Property | SaveFormat | Gets or sets the document save format.
Top
See Also

Reference

PDFDocumentSaveOptions Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocumentSaveOptions Constructor

O2S.Components.PDF4NET Namespace > PDFDocumentSaveOptions Class : PDFDocumentSaveOptions Constructor
Initializes a new PDFDocumentSaveOptions
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDocumentSaveOptions()
public PDFDocumentSaveOptions()
public: PDFDocumentSaveOptions();
public:
PDFDocumentSaveOptions();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentSaveOptions Class
PDFDocumentSaveOptions Members


%%PageItemTitle%% $$Properties$$

PDFDocumentSaveOptions Class Properties

O2S.Components.PDF4NET Namespace : PDFDocumentSaveOptions Class

For a list of all members of this type, see PDFDocumentSaveOptions members.

Public Properties
 | Name | Description
Public Property | AllowInteractiveSignatures | Gets or sets a flag indicating whether an user interface can be displayed when signing a PDF file.
Public Property | FastWebView | Gets or sets a value indicating whether the document should be saved in fast web view mode or not.
Public Property | IncrementalUpdate | Gets or sets a value indicating whether incremental update should be used of document save or not.
Public Property | SaveFormat | Gets or sets the document save format.
Top
See Also

Reference

PDFDocumentSaveOptions Class
O2S.Components.PDF4NET Namespace


AllowInteractiveSignatures Property

O2S.Components.PDF4NET Namespace > PDFDocumentSaveOptions Class : AllowInteractiveSignatures Property
Gets or sets a flag indicating whether an user interface can be displayed when signing a PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowInteractiveSignatures As Boolean
'Usage

Dim instance As PDFDocumentSaveOptions
Dim value As Boolean

instance.AllowInteractiveSignatures = value

value = instance.AllowInteractiveSignatures
public bool AllowInteractiveSignatures {get; set;}
public: __property bool get_AllowInteractiveSignatures();
public: __property void set_AllowInteractiveSignatures(
   bool value
);
public:
property bool AllowInteractiveSignatures {
   bool get();
   void set (    bool value);
}

Property Value

True if the user interface can be displayed. Default false.
Remarks
Many cryptographic providers display a custom UI when the private key of a certificate is retrieved. If the UI is not allowed to be displayed, the access to private key is denied and the sign process fail. Set this property to true to allow the user to enter a PIN/password when requested by the cryptographic provider on in a Windows Forms application.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentSaveOptions Class
PDFDocumentSaveOptions Members


FastWebView Property

O2S.Components.PDF4NET Namespace > PDFDocumentSaveOptions Class : FastWebView Property
Gets or sets a value indicating whether the document should be saved in fast web view mode or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FastWebView As Boolean
'Usage

Dim instance As PDFDocumentSaveOptions
Dim value As Boolean

instance.FastWebView = value

value = instance.FastWebView
public bool FastWebView {get; set;}
public: __property bool get_FastWebView();
public: __property void set_FastWebView(
   bool value
);
public:
property bool FastWebView {
   bool get();
   void set (    bool value);
}

Property Value

True if the document should be saved in fast web view mode, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentSaveOptions Class
PDFDocumentSaveOptions Members


IncrementalUpdate Property

O2S.Components.PDF4NET Namespace > PDFDocumentSaveOptions Class : IncrementalUpdate Property
Gets or sets a value indicating whether incremental update should be used of document save or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncrementalUpdate As Boolean
'Usage

Dim instance As PDFDocumentSaveOptions
Dim value As Boolean

instance.IncrementalUpdate = value

value = instance.IncrementalUpdate
public bool IncrementalUpdate {get; set;}
public: __property bool get_IncrementalUpdate();
public: __property void set_IncrementalUpdate(
   bool value
);
public:
property bool IncrementalUpdate {
   bool get();
   void set (    bool value);
}

Property Value

True if incremental update should be used, false otherwise. Default is false.
Remarks
Incremental update should be used when the document has been partially loaded (any of the properties of the PDFDocumentLoadOptions object have been set to false). Incremental updates allow faster saves of the PDF document because only the modified objects are appended at the end of the source file. Incremental updates work only when the source document is loaded from disk and not from a stream.
If the document has been partially loaded but this property is false, the remaining parts of the document will be loaded in memory before saving the file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentSaveOptions Class
PDFDocumentSaveOptions Members


SaveFormat Property

O2S.Components.PDF4NET Namespace > PDFDocumentSaveOptions Class : SaveFormat Property
Gets or sets the document save format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SaveFormat As PDFDocumentSaveFormat
'Usage

Dim instance As PDFDocumentSaveOptions
Dim value As PDFDocumentSaveFormat

instance.SaveFormat = value

value = instance.SaveFormat
public PDFDocumentSaveFormat SaveFormat {get; set;}
public: __property PDFDocumentSaveFormat get_SaveFormat();
public: __property void set_SaveFormat(
   PDFDocumentSaveFormat value
);
public:
property PDFDocumentSaveFormat SaveFormat {
   PDFDocumentSaveFormat get();
   void set (    PDFDocumentSaveFormat value);
}

Property Value

A format for saving the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentSaveOptions Class
PDFDocumentSaveOptions Members


%%PageItemTitle%%

PDFException Class
Members

O2S.Components.PDF4NET Namespace : PDFException Class
Defines a generic PDF exception.
Object Model
PDFException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFException
   Inherits System.ApplicationException
'Usage

Dim instance As PDFException
public class PDFException : System.ApplicationException
public __gc class PDFException : public System.ApplicationException
public ref class PDFException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.Cos.IncompatiblePDFObjectException
O2S.Components.PDF4NET.Cos.InvalidPDFValueException
O2S.Components.PDF4NET.PDFInvalidPasswordException
O2S.Components.PDF4NET.PDFInvalidPDFAFormatException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFException Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFException Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFException Class

The following tables list the members exposed by PDFException.

Public Constructors
 | Name | Description
Public Constructor | PDFException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFException Constructor

O2S.Components.PDF4NET Namespace > PDFException Class : PDFException Constructor
Overload List
Overload | Description
PDFException Constructor(String) | Initializes a new PDFException object.
PDFException Constructor(String,Exception) | Initializes a new PDFException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFException Class
PDFException Members


%%PageItemTitle%%

PDFException Constructor(String)

O2S.Components.PDF4NET Namespace > PDFException Class > PDFException Constructor : PDFException Constructor(String)
The message that describes the exception.
Initializes a new PDFException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PDFException(message)
public PDFException(
   string message
)
public: PDFException(
   string* message
)
public:
PDFException(
   String^ message
)

Parameters

message
The message that describes the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFException Class
PDFException Members
Overload List


%%PageItemTitle%%

PDFException Constructor(String,Exception)

O2S.Components.PDF4NET Namespace > PDFException Class > PDFException Constructor : PDFException Constructor(String,Exception)
the message that describes the exception.
The exception that is the cause of the current exception.
Initializes a new PDFException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PDFException(message, innerException)
public PDFException(
   string message,
   Exception innerException
)
public: PDFException(
   string* message,
   Exception* innerException
)
public:
PDFException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFException Class
PDFException Members
Overload List


%%PageItemTitle%%

PDFGraphicsContainer Class
Members

O2S.Components.PDF4NET Namespace : PDFGraphicsContainer Class
Defines an abstract object that can store graphic content.
Object Model
PDFGraphicsContainer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFGraphicsContainer
'Usage

Dim instance As PDFGraphicsContainer
public abstract class PDFGraphicsContainer
public __gc abstract class PDFGraphicsContainer
public ref class PDFGraphicsContainer abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Fonts.Type3VisualChar
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.PDFFile.PDFImportedContent
O2S.Components.PDF4NET.PDFPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGraphicsContainer Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFGraphicsContainer Class Members

O2S.Components.PDF4NET Namespace : PDFGraphicsContainer Class

The following tables list the members exposed by PDFGraphicsContainer.

See Also

Reference

PDFGraphicsContainer Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFInvalidPasswordException Class
Members

O2S.Components.PDF4NET Namespace : PDFInvalidPasswordException Class
The exception that is thrown when the password supplied for opening the file is invalid or when the password contains unsupported characters.
Object Model
PDFInvalidPasswordException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFInvalidPasswordException
   Inherits PDFException
'Usage

Dim instance As PDFInvalidPasswordException
public class PDFInvalidPasswordException : PDFException
public __gc class PDFInvalidPasswordException : public PDFException
public ref class PDFInvalidPasswordException : public PDFException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.PDFInvalidPasswordException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInvalidPasswordException Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFInvalidPasswordException Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFInvalidPasswordException Class

The following tables list the members exposed by PDFInvalidPasswordException.

Public Constructors
 | Name | Description
Public Constructor | PDFInvalidPasswordException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFInvalidPasswordException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFInvalidPasswordException Constructor

O2S.Components.PDF4NET Namespace > PDFInvalidPasswordException Class : PDFInvalidPasswordException Constructor
Overload List
Overload | Description
PDFInvalidPasswordException Constructor(String) | Initializes a new InvalidPasswordException object.
PDFInvalidPasswordException Constructor(String,Exception) | Initializes a new InvalidPasswordException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInvalidPasswordException Class
PDFInvalidPasswordException Members


%%PageItemTitle%%

PDFInvalidPasswordException Constructor(String)

O2S.Components.PDF4NET Namespace > PDFInvalidPasswordException Class > PDFInvalidPasswordException Constructor : PDFInvalidPasswordException Constructor(String)
The message that describes the exception.
Initializes a new InvalidPasswordException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PDFInvalidPasswordException(message)
public PDFInvalidPasswordException(
   string message
)
public: PDFInvalidPasswordException(
   string* message
)
public:
PDFInvalidPasswordException(
   String^ message
)

Parameters

message
The message that describes the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInvalidPasswordException Class
PDFInvalidPasswordException Members
Overload List


%%PageItemTitle%%

PDFInvalidPasswordException Constructor(String,Exception)

O2S.Components.PDF4NET Namespace > PDFInvalidPasswordException Class > PDFInvalidPasswordException Constructor : PDFInvalidPasswordException Constructor(String,Exception)
the message that describes the exception.
The exception that is the cause of the current exception.
Initializes a new InvalidPasswordException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PDFInvalidPasswordException(message, innerException)
public PDFInvalidPasswordException(
   string message,
   Exception innerException
)
public: PDFInvalidPasswordException(
   string* message,
   Exception* innerException
)
public:
PDFInvalidPasswordException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInvalidPasswordException Class
PDFInvalidPasswordException Members
Overload List


%%PageItemTitle%%

PDFInvalidPDFAFormatException Class
Members

O2S.Components.PDF4NET Namespace : PDFInvalidPDFAFormatException Class
Thrown when the saved document does not meet the PDF-A/1b requirements.
Object Model
PDFInvalidPDFAFormatException ClassPDFAValidationErrorCollection ClassPDFAValidationError Enumeration
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFInvalidPDFAFormatException
   Inherits PDFException
'Usage

Dim instance As PDFInvalidPDFAFormatException
public class PDFInvalidPDFAFormatException : PDFException
public __gc class PDFInvalidPDFAFormatException : public PDFException
public ref class PDFInvalidPDFAFormatException : public PDFException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.PDFInvalidPDFAFormatException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInvalidPDFAFormatException Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFInvalidPDFAFormatException Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFInvalidPDFAFormatException Class

The following tables list the members exposed by PDFInvalidPDFAFormatException.

Public Constructors
 | Name | Description
Public Constructor | PDFInvalidPDFAFormatException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Public Property | ValidationErrors | Gets the list of errors encountered during PDF-A validation.
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFInvalidPDFAFormatException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFInvalidPDFAFormatException Constructor

O2S.Components.PDF4NET Namespace > PDFInvalidPDFAFormatException Class : PDFInvalidPDFAFormatException Constructor
Overload List
Overload | Description
PDFInvalidPDFAFormatException Constructor(String) | Initializes a new PDFInvalidPDFAFormatException object.
PDFInvalidPDFAFormatException Constructor(String,Exception) | Initializes a new PDFInvalidPDFAFormatException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInvalidPDFAFormatException Class
PDFInvalidPDFAFormatException Members


%%PageItemTitle%%

PDFInvalidPDFAFormatException Constructor(String)

O2S.Components.PDF4NET Namespace > PDFInvalidPDFAFormatException Class > PDFInvalidPDFAFormatException Constructor : PDFInvalidPDFAFormatException Constructor(String)
The message that describes the exception.
Initializes a new PDFInvalidPDFAFormatException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PDFInvalidPDFAFormatException(message)
public PDFInvalidPDFAFormatException(
   string message
)
public: PDFInvalidPDFAFormatException(
   string* message
)
public:
PDFInvalidPDFAFormatException(
   String^ message
)

Parameters

message
The message that describes the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInvalidPDFAFormatException Class
PDFInvalidPDFAFormatException Members
Overload List


%%PageItemTitle%%

PDFInvalidPDFAFormatException Constructor(String,Exception)

O2S.Components.PDF4NET Namespace > PDFInvalidPDFAFormatException Class > PDFInvalidPDFAFormatException Constructor : PDFInvalidPDFAFormatException Constructor(String,Exception)
the message that describes the exception.
The exception that is the cause of the current exception.
Initializes a new PDFInvalidPDFAFormatException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PDFInvalidPDFAFormatException(message, innerException)
public PDFInvalidPDFAFormatException(
   string message,
   Exception innerException
)
public: PDFInvalidPDFAFormatException(
   string* message,
   Exception* innerException
)
public:
PDFInvalidPDFAFormatException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInvalidPDFAFormatException Class
PDFInvalidPDFAFormatException Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFInvalidPDFAFormatException Class Properties

O2S.Components.PDF4NET Namespace : PDFInvalidPDFAFormatException Class

For a list of all members of this type, see PDFInvalidPDFAFormatException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Public Property | ValidationErrors | Gets the list of errors encountered during PDF-A validation.
Top
See Also

Reference

PDFInvalidPDFAFormatException Class
O2S.Components.PDF4NET Namespace


ValidationErrors Property

O2S.Components.PDF4NET Namespace > PDFInvalidPDFAFormatException Class : ValidationErrors Property
Gets the list of errors encountered during PDF-A validation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ValidationErrors As PDFAValidationErrorCollection
'Usage

Dim instance As PDFInvalidPDFAFormatException
Dim value As PDFAValidationErrorCollection

value = instance.ValidationErrors
public PDFAValidationErrorCollection ValidationErrors {get;}
public: __property PDFAValidationErrorCollection* get_ValidationErrors();
public:
property PDFAValidationErrorCollection^ ValidationErrors {
   PDFAValidationErrorCollection^ get();
}

Property Value

All errors encountered during the PDF-A validation of the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInvalidPDFAFormatException Class
PDFInvalidPDFAFormatException Members


%%PageItemTitle%%

PDFJavaScript Class
Members

O2S.Components.PDF4NET Namespace : PDFJavaScript Class
Defines a fragment of JavaScript code.
Object Model
PDFJavaScript Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFJavaScript
'Usage

Dim instance As PDFJavaScript
public class PDFJavaScript
public __gc class PDFJavaScript
public ref class PDFJavaScript
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFJavaScript

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScript Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFJavaScript Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFJavaScript Class

The following tables list the members exposed by PDFJavaScript.

Public Constructors
 | Name | Description
Public Constructor | PDFJavaScript Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of this JavaScript fragment.
Public Property | Script | Gets or sets the javascript code to be included in the block.
Top
See Also

Reference

PDFJavaScript Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFJavaScript Constructor

O2S.Components.PDF4NET Namespace > PDFJavaScript Class : PDFJavaScript Constructor
Overload List
Overload | Description
PDFJavaScript Constructor() | Initializes a new PDFJavaScript object.
PDFJavaScript Constructor(String) | Initializes a new PDFJavaScript object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScript Class
PDFJavaScript Members


%%PageItemTitle%%

PDFJavaScript Constructor()

O2S.Components.PDF4NET Namespace > PDFJavaScript Class > PDFJavaScript Constructor : PDFJavaScript Constructor()
Initializes a new PDFJavaScript object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFJavaScript()
public PDFJavaScript()
public: PDFJavaScript();
public:
PDFJavaScript();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScript Class
PDFJavaScript Members
Overload List


%%PageItemTitle%%

PDFJavaScript Constructor(String)

O2S.Components.PDF4NET Namespace > PDFJavaScript Class > PDFJavaScript Constructor : PDFJavaScript Constructor(String)
The JavaScript code to be included in the fragment.
Initializes a new PDFJavaScript object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal javaScript As String _
)
'Usage

Dim javaScript As String

Dim instance As New PDFJavaScript(javaScript)
public PDFJavaScript(
   string javaScript
)
public: PDFJavaScript(
   string* javaScript
)
public:
PDFJavaScript(
   String^ javaScript
)

Parameters

javaScript
The JavaScript code to be included in the fragment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScript Class
PDFJavaScript Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFJavaScript Class Properties

O2S.Components.PDF4NET Namespace : PDFJavaScript Class

For a list of all members of this type, see PDFJavaScript members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of this JavaScript fragment.
Public Property | Script | Gets or sets the javascript code to be included in the block.
Top
See Also

Reference

PDFJavaScript Class
O2S.Components.PDF4NET Namespace


Name Property (PDFJavaScript)

O2S.Components.PDF4NET Namespace > PDFJavaScript Class : Name Property
Gets or sets the name of this JavaScript fragment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFJavaScript
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the JavaScript fragment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScript Class
PDFJavaScript Members


Script Property (PDFJavaScript)

O2S.Components.PDF4NET Namespace > PDFJavaScript Class : Script Property
Gets or sets the javascript code to be included in the block.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Script As String
'Usage

Dim instance As PDFJavaScript
Dim value As String

instance.Script = value

value = instance.Script
public string Script {get; set;}
public: __property string* get_Script();
public: __property void set_Script(
   string* value
);
public:
property String^ Script {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing valid javascript code.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScript Class
PDFJavaScript Members


%%PageItemTitle%%

PDFJavaScriptCollection Class
Members

O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class
Defines a collection of annotations.
Object Model
PDFJavaScriptCollection ClassPDFJavaScript Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFJavaScriptCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFJavaScript,PDFDocument)
'Usage

Dim instance As PDFJavaScriptCollection
public class PDFJavaScriptCollection : O2S.Components.PDF4NET.PDFCollection<PDFJavaScript,PDFDocument>
public __gc class PDFJavaScriptCollection : public O2S.Components.PDF4NET.PDFCollection<PDFJavaScript,PDFDocument>
public ref class PDFJavaScriptCollection : public O2S.Components.PDF4NET.PDFCollection<PDFJavaScript,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.PDFJavaScriptCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFJavaScriptCollection Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

The following tables list the members exposed by PDFJavaScriptCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new JavaScript action to the collection.
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Top
See Also

Reference

PDFJavaScriptCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFJavaScriptCollection Class Methods

O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

For a list of all members of this type, see PDFJavaScriptCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new JavaScript action to the collection.
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Top
See Also

Reference

PDFJavaScriptCollection Class
O2S.Components.PDF4NET Namespace


Add Method (PDFJavaScriptCollection)

O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : Add Method
Adds a new JavaScript action to the collection.
Overload List
Overload | Description
Add(String) | Adds a new JavaScript action to the collection.
Add(PDFJavaScript) | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


Add(String) Method

O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class > Add Method : Add(String) Method
The JavaScript code.
Adds a new JavaScript action to the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal javaScript As String _
)
'Usage

Dim instance As PDFJavaScriptCollection
Dim javaScript As String

instance.Add(javaScript)
public void Add(
   string javaScript
)
public: void Add(
   string* javaScript
)
public:
void Add(
   String^ javaScript
)

Parameters

javaScript
The JavaScript code.
Remarks
This method adds a JavaScript code fragment in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members
Overload List


%%PageItemTitle%%

PDFMetadataSchema Class
Members

O2S.Components.PDF4NET Namespace : PDFMetadataSchema Class
Defines a schema within the document's metadata
Object Model
PDFMetadataSchema Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PDFMetadataSchema
'Usage

Dim instance As PDFMetadataSchema
[DefaultMember("Item")]
public class PDFMetadataSchema
[DefaultMember("Item")]
public __gc class PDFMetadataSchema
[DefaultMember("Item")]
public ref class PDFMetadataSchema
Remarks
A document's metadata consists of several schemas. A schema groups several properties. Each schema has a name and a namespace prefix.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFMetadataSchema

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetadataSchema Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFMetadataSchema Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFMetadataSchema Class

The following tables list the members exposed by PDFMetadataSchema.

Public Constructors
 | Name | Description
Public Constructor | PDFMetadataSchema Constructor | Initializes a new PDFMetadataSchema object.
Top
Public Properties
 | Name | Description
Public Property | IncludeNamespacePrefixInDocInfo | Gets or sets a value indicating whether the metadata properties are written in the document information with the namespace prefix.
Public Property | Item | Gets or sets the value of a property.
Public Property | Name | Gets or sets schema's name.
Public Property | NamespacePrefix | Gets or sets schema's namespace prefix.
Public Property | Properties | Gets the hashtable storing the properties in this schema.
Public Property | StoreSchemaInDocInfo | Gets or sets whether the properties in this schema are stored also in Document Information dictionary or not.
Top
See Also

Reference

PDFMetadataSchema Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFMetadataSchema Constructor

O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : PDFMetadataSchema Constructor
Initializes a new PDFMetadataSchema object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMetadataSchema()
public PDFMetadataSchema()
public: PDFMetadataSchema();
public:
PDFMetadataSchema();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


%%PageItemTitle%% $$Properties$$

PDFMetadataSchema Class Properties

O2S.Components.PDF4NET Namespace : PDFMetadataSchema Class

For a list of all members of this type, see PDFMetadataSchema members.

Public Properties
 | Name | Description
Public Property | IncludeNamespacePrefixInDocInfo | Gets or sets a value indicating whether the metadata properties are written in the document information with the namespace prefix.
Public Property | Item | Gets or sets the value of a property.
Public Property | Name | Gets or sets schema's name.
Public Property | NamespacePrefix | Gets or sets schema's namespace prefix.
Public Property | Properties | Gets the hashtable storing the properties in this schema.
Public Property | StoreSchemaInDocInfo | Gets or sets whether the properties in this schema are stored also in Document Information dictionary or not.
Top
See Also

Reference

PDFMetadataSchema Class
O2S.Components.PDF4NET Namespace


IncludeNamespacePrefixInDocInfo Property

O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : IncludeNamespacePrefixInDocInfo Property
Gets or sets a value indicating whether the metadata properties are written in the document information with the namespace prefix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncludeNamespacePrefixInDocInfo As Boolean
'Usage

Dim instance As PDFMetadataSchema
Dim value As Boolean

instance.IncludeNamespacePrefixInDocInfo = value

value = instance.IncludeNamespacePrefixInDocInfo
public bool IncludeNamespacePrefixInDocInfo {get; set;}
public: __property bool get_IncludeNamespacePrefixInDocInfo();
public: __property void set_IncludeNamespacePrefixInDocInfo(
   bool value
);
public:
property bool IncludeNamespacePrefixInDocInfo {
   bool get();
   void set (    bool value);
}

Property Value

True if the namespace prefix is included in property name.
Remarks
This property has effect when StoreSchemaInDocInfo is true. When the metadata properties are added to document information dictionary, they can be overwritten if the same property name appears in different metadata schemas. Setting this property to true avoids this problem.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


Item Property (PDFMetadataSchema)
Example

O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : Item Property
Gets or sets the value of a property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal propertyName As String _
) As String
'Usage

Dim instance As PDFMetadataSchema
Dim propertyName As String
Dim value As String

instance.Item(propertyName) = value

value = instance.Item(propertyName)
public string this[
   string propertyName
]; {get; set;}
public: __property string* get_Item   string* propertyName
;
public: __property void set_Item   string* propertyName,
   string* value
;
public:
property String^ default [String^] {
   String^ get(String^ propertyName);
   void set (String^ propertyName, String^ value);
}

Parameters

propertyName

Property Value

A string value representing the value of the property. The name of the property is used to set or get its value.
Example
The following example set the "Company" property to the value "O2 Solutions" (in the sample below, schema is considered to be an instance of PDFMetadataSchema class):
  • C#
...
schema["Company"] = "O2 Solutions";
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


Name Property (PDFMetadataSchema)

O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : Name Property
Gets or sets schema's name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFMetadataSchema
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

A unique string value representing the name of the schema. Usually, this name looks like an URL, but it is a simple identifier. It serves to uniquely identify the schema.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


NamespacePrefix Property

O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : NamespacePrefix Property
Gets or sets schema's namespace prefix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NamespacePrefix As String
'Usage

Dim instance As PDFMetadataSchema
Dim value As String

instance.NamespacePrefix = value

value = instance.NamespacePrefix
public string NamespacePrefix {get; set;}
public: __property string* get_NamespacePrefix();
public: __property void set_NamespacePrefix(
   string* value
);
public:
property String^ NamespacePrefix {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the namespace prefix for this PDFMetadataSchema object. It is a short abbreviation for the full schema name. It follows the rules of XML namespaces. This namespace prefix has the local scope of the xmlns attribute that declares it (in the XML representation of the schema).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


Properties Property (PDFMetadataSchema)

O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : Properties Property
Gets the hashtable storing the properties in this schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Properties As Dictionary(Of String,String)
'Usage

Dim instance As PDFMetadataSchema
Dim value As Dictionary(Of String,String)

value = instance.Properties
public Dictionary<string,string> Properties {get;}
public: __property Dictionary<string*,string*>* get_Properties();
public:
property Dictionary<String^,String^>^ Properties {
   Dictionary<String^,String^>^ get();
}

Property Value

A System.Collections.Hashtable object storing the schema's properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


StoreSchemaInDocInfo Property

O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : StoreSchemaInDocInfo Property
Gets or sets whether the properties in this schema are stored also in Document Information dictionary or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StoreSchemaInDocInfo As Boolean
'Usage

Dim instance As PDFMetadataSchema
Dim value As Boolean

instance.StoreSchemaInDocInfo = value

value = instance.StoreSchemaInDocInfo
public bool StoreSchemaInDocInfo {get; set;}
public: __property bool get_StoreSchemaInDocInfo();
public: __property void set_StoreSchemaInDocInfo(
   bool value
);
public:
property bool StoreSchemaInDocInfo {
   bool get();
   void set (    bool value);
}

Property Value

If true, the properties in this schema are stored also in Document Information dictionary. Default: false
Remarks
When schema's properties are stored in the Document Information dictionary, the property name is the key and its value is stored as a string value in the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


%%PageItemTitle%%

PDFMetadataSchemaCollection Class
Members

O2S.Components.PDF4NET Namespace : PDFMetadataSchemaCollection Class
Defines a collection of bookmarks.
Object Model
PDFMetadataSchemaCollection ClassPDFMetadataSchema Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMetadataSchemaCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFMetadataSchema,PDFDocument)
'Usage

Dim instance As PDFMetadataSchemaCollection
public class PDFMetadataSchemaCollection : O2S.Components.PDF4NET.PDFCollection<PDFMetadataSchema,PDFDocument>
public __gc class PDFMetadataSchemaCollection : public O2S.Components.PDF4NET.PDFCollection<PDFMetadataSchema,PDFDocument>
public ref class PDFMetadataSchemaCollection : public O2S.Components.PDF4NET.PDFCollection<PDFMetadataSchema,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.PDFMetadataSchemaCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetadataSchemaCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFMetadataSchemaCollection Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFMetadataSchemaCollection Class

The following tables list the members exposed by PDFMetadataSchemaCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Top
See Also

Reference

PDFMetadataSchemaCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFOutputIntent Class
Members

O2S.Components.PDF4NET Namespace : PDFOutputIntent Class
Defines an output intent for a PDF document.
Object Model
PDFOutputIntent ClassPDFICCColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFOutputIntent
'Usage

Dim instance As PDFOutputIntent
public class PDFOutputIntent
public __gc class PDFOutputIntent
public ref class PDFOutputIntent
Remarks
Output intents provide a means for matching the color characteristics of a PDF document with those of a target output device or production environment in which the document will be printed.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFOutputIntent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntent Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFOutputIntent Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFOutputIntent Class

The following tables list the members exposed by PDFOutputIntent.

Public Constructors
 | Name | Description
Public Constructor | PDFOutputIntent Constructor | Initializes a new PDFOutputIntent object.
Top
Public Properties
 | Name | Description
Public Property | DestinationOutputProfile | Gets or sets the destination output profile.
Public Property | Info | Gets or sets the output intent info.
Public Property | OutputCondition | Gets or sets the output condition.
Public Property | OutputConditionIdentifier | Gets or sets the output condition identifier.
Public Property | RegistryName | Gets or sets the registry name.
Public Property | Type | Gets of sets the type of this output intent.
Top
See Also

Reference

PDFOutputIntent Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFOutputIntent Constructor

O2S.Components.PDF4NET Namespace > PDFOutputIntent Class : PDFOutputIntent Constructor
Initializes a new PDFOutputIntent object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFOutputIntent()
public PDFOutputIntent()
public: PDFOutputIntent();
public:
PDFOutputIntent();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntent Class
PDFOutputIntent Members


%%PageItemTitle%% $$Properties$$

PDFOutputIntent Class Properties

O2S.Components.PDF4NET Namespace : PDFOutputIntent Class

For a list of all members of this type, see PDFOutputIntent members.

Public Properties
 | Name | Description
Public Property | DestinationOutputProfile | Gets or sets the destination output profile.
Public Property | Info | Gets or sets the output intent info.
Public Property | OutputCondition | Gets or sets the output condition.
Public Property | OutputConditionIdentifier | Gets or sets the output condition identifier.
Public Property | RegistryName | Gets or sets the registry name.
Public Property | Type | Gets of sets the type of this output intent.
Top
See Also

Reference

PDFOutputIntent Class
O2S.Components.PDF4NET Namespace


DestinationOutputProfile Property

O2S.Components.PDF4NET Namespace > PDFOutputIntent Class : DestinationOutputProfile Property
Gets or sets the destination output profile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DestinationOutputProfile As PDFICCColorSpace
'Usage

Dim instance As PDFOutputIntent
Dim value As PDFICCColorSpace

instance.DestinationOutputProfile = value

value = instance.DestinationOutputProfile
public PDFICCColorSpace DestinationOutputProfile {get; set;}
public: __property PDFICCColorSpace* get_DestinationOutputProfile();
public: __property void set_DestinationOutputProfile(
   PDFICCColorSpace* value
);
public:
property PDFICCColorSpace^ DestinationOutputProfile {
   PDFICCColorSpace^ get();
   void set (    PDFICCColorSpace^ value);
}

Property Value

An ICC profile stream defining the transformation from the PDF document's source colors to output device colorants.
Remarks
Required if OutputConditionIdentifier does not specify a standard production condition; optional otherwise
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntent Class
PDFOutputIntent Members


Info Property

O2S.Components.PDF4NET Namespace > PDFOutputIntent Class : Info Property
Gets or sets the output intent info.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Info As String
'Usage

Dim instance As PDFOutputIntent
Dim value As String

instance.Info = value

value = instance.Info
public string Info {get; set;}
public: __property string* get_Info();
public: __property void set_Info(
   string* value
);
public:
property String^ Info {
   String^ get();
   void set (    String^ value);
}

Property Value

A human-readable text string containing additional information or comments about the intended target device or production condition.
Remarks
This property is required if OutputConditionIdentifier does not specify a standard production condition; optional otherwise
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntent Class
PDFOutputIntent Members


OutputCondition Property

O2S.Components.PDF4NET Namespace > PDFOutputIntent Class : OutputCondition Property
Gets or sets the output condition.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OutputCondition As String
'Usage

Dim instance As PDFOutputIntent
Dim value As String

instance.OutputCondition = value

value = instance.OutputCondition
public string OutputCondition {get; set;}
public: __property string* get_OutputCondition();
public: __property void set_OutputCondition(
   string* value
);
public:
property String^ OutputCondition {
   String^ get();
   void set (    String^ value);
}

Property Value

A text string concisely identifying the intended output device or production condition in human-readable form.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntent Class
PDFOutputIntent Members


OutputConditionIdentifier Property

O2S.Components.PDF4NET Namespace > PDFOutputIntent Class : OutputConditionIdentifier Property
Gets or sets the output condition identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OutputConditionIdentifier As String
'Usage

Dim instance As PDFOutputIntent
Dim value As String

instance.OutputConditionIdentifier = value

value = instance.OutputConditionIdentifier
public string OutputConditionIdentifier {get; set;}
public: __property string* get_OutputConditionIdentifier();
public: __property void set_OutputConditionIdentifier(
   string* value
);
public:
property String^ OutputConditionIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

A string identifying the intended output device or production condition in human- or machine-readable form.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when this property is set to a null or empty value.
Remarks
If human-readable, this string may be used in lieu of an OutputCondition string for presentation to the user.
A typical value for this entry would be the name of a production condition maintained in an industry-standard registry such as the ICC Characterization Data Registry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntent Class
PDFOutputIntent Members


RegistryName Property

O2S.Components.PDF4NET Namespace > PDFOutputIntent Class : RegistryName Property
Gets or sets the registry name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RegistryName As String
'Usage

Dim instance As PDFOutputIntent
Dim value As String

instance.RegistryName = value

value = instance.RegistryName
public string RegistryName {get; set;}
public: __property string* get_RegistryName();
public: __property void set_RegistryName(
   string* value
);
public:
property String^ RegistryName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string (conventionally a uniform resource identifier, or URI) identifying the registry in which the condition designated by OutputConditionIdentifier is defined.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntent Class
PDFOutputIntent Members


Type Property (PDFOutputIntent)

O2S.Components.PDF4NET Namespace > PDFOutputIntent Class : Type Property
Gets of sets the type of this output intent.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As PDFOutputIntentType
'Usage

Dim instance As PDFOutputIntent
Dim value As PDFOutputIntentType

instance.Type = value

value = instance.Type
public PDFOutputIntentType Type {get; set;}
public: __property PDFOutputIntentType get_Type();
public: __property void set_Type(
   PDFOutputIntentType value
);
public:
property PDFOutputIntentType Type {
   PDFOutputIntentType get();
   void set (    PDFOutputIntentType value);
}

Property Value

The type of the output intent.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to PDFOutputIntentType.Unknown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntent Class
PDFOutputIntent Members


%%PageItemTitle%%

PDFOutputIntentCollection Class
Members

O2S.Components.PDF4NET Namespace : PDFOutputIntentCollection Class
Defines a collection of output intents.
Object Model
PDFOutputIntentCollection ClassPDFOutputIntent Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFOutputIntentCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFOutputIntent,PDFDocument)
'Usage

Dim instance As PDFOutputIntentCollection
public class PDFOutputIntentCollection : O2S.Components.PDF4NET.PDFCollection<PDFOutputIntent,PDFDocument>
public __gc class PDFOutputIntentCollection : public O2S.Components.PDF4NET.PDFCollection<PDFOutputIntent,PDFDocument>
public ref class PDFOutputIntentCollection : public O2S.Components.PDF4NET.PDFCollection<PDFOutputIntent,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.PDFOutputIntentCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntentCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFOutputIntentCollection Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFOutputIntentCollection Class

The following tables list the members exposed by PDFOutputIntentCollection.

Public Constructors
 | Name | Description
Public Constructor | PDFOutputIntentCollection Constructor | Initializes a new PDFOutputIntentCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Top
See Also

Reference

PDFOutputIntentCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFOutputIntentCollection Constructor

O2S.Components.PDF4NET Namespace > PDFOutputIntentCollection Class : PDFOutputIntentCollection Constructor
Initializes a new PDFOutputIntentCollection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFOutputIntentCollection()
public PDFOutputIntentCollection()
public: PDFOutputIntentCollection();
public:
PDFOutputIntentCollection();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntentCollection Class
PDFOutputIntentCollection Members


%%PageItemTitle%%

PDFPage Class
Members

O2S.Components.PDF4NET Namespace : PDFPage Class
Defines a page within the pdf document.
Object Model
PDFPage ClassPDFAnnotationCollection ClassPDFAnnotation ClassPDFRectangle ClassPDFPageBackground ClassPDFRectangle ClassPDFCanvas ClassPDFAction ClassPDFRectangle ClassPDFDictionary ClassPDFDocument ClassPDFFieldCollection ClassPDFField ClassPDFRectangle ClassPDFPageNumber ClassPDFAction ClassPDFSeparationInfo ClassPDFRectangle ClassPDFViewportCollection ClassPDFViewport Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPage
   Inherits PDFGraphicsContainer
'Usage

Dim instance As PDFPage
public class PDFPage : PDFGraphicsContainer
public __gc class PDFPage : public PDFGraphicsContainer
public ref class PDFPage : public PDFGraphicsContainer
Remarks
This class is used to create new pages in a pdf document. The pages can be created in any order. The position of the page in the PDFDocument.Pages collection gives the position of the page within the final pdf file. The content of the page is mainly created using the Canvas property of the page.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPage Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFPage Class

The following tables list the members exposed by PDFPage.

Public Constructors
 | Name | Description
Public Constructor | PDFPage Constructor | Initializes a new PDFPage object.
Top
Public Properties
 | Name | Description
Public Property | Annotations | Gets the list of page annotations.
Public Property | ArtBox | Gets or sets the page art box.
Public Property | Background | Gets or sets the background of the page.
Public Property | BleedBox | Gets or sets the page bleed box.
Public Property | ByteCount | Gets the approximate size in bytes of the imported page.
Public Property | Canvas | Gets the page canvas.
Public Property | CloseAction | Gets or sets the action to be performed when the page is closed.
Public Property | CropBox | Gets or sets the page crop box.
Public Property | Dictionary | Gets the page dictionary.
Public Property | Document | Gets the document this page belongs to.
Public Property | Fields | Gets the list of fields defined on this page.
Public Property | Height | Gets or sets the page height.
Public Property | MediaBox | Gets or sets the page media box.
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object.
Public Property | OpenAction | Gets or sets the action to be performed when the page is opened.
Public Property | Orientation | Gets or sets the page orientation.
Public Property | Rotation | Gets or sets the page rotation angle.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Size | Gets or sets the page size.
Public Property | TrimBox | Gets or sets the page trim box.
Public Property | Viewports | Gets or sets the page viewports.
Public Property | Width | Gets or sets the page width.
Top
See Also

Reference

PDFPage Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPage Constructor

O2S.Components.PDF4NET Namespace > PDFPage Class : PDFPage Constructor
Initializes a new PDFPage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPage()
public PDFPage()
public: PDFPage();
public:
PDFPage();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%% $$Properties$$

PDFPage Class Properties

O2S.Components.PDF4NET Namespace : PDFPage Class

For a list of all members of this type, see PDFPage members.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the list of page annotations.
Public Property | ArtBox | Gets or sets the page art box.
Public Property | Background | Gets or sets the background of the page.
Public Property | BleedBox | Gets or sets the page bleed box.
Public Property | ByteCount | Gets the approximate size in bytes of the imported page.
Public Property | Canvas | Gets the page canvas.
Public Property | CloseAction | Gets or sets the action to be performed when the page is closed.
Public Property | CropBox | Gets or sets the page crop box.
Public Property | Dictionary | Gets the page dictionary.
Public Property | Document | Gets the document this page belongs to.
Public Property | Fields | Gets the list of fields defined on this page.
Public Property | Height | Gets or sets the page height.
Public Property | MediaBox | Gets or sets the page media box.
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object.
Public Property | OpenAction | Gets or sets the action to be performed when the page is opened.
Public Property | Orientation | Gets or sets the page orientation.
Public Property | Rotation | Gets or sets the page rotation angle.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Size | Gets or sets the page size.
Public Property | TrimBox | Gets or sets the page trim box.
Public Property | Viewports | Gets or sets the page viewports.
Public Property | Width | Gets or sets the page width.
Top
See Also

Reference

PDFPage Class
O2S.Components.PDF4NET Namespace


Annotations Property

O2S.Components.PDF4NET Namespace > PDFPage Class : Annotations Property
Gets the list of page annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotations As PDFAnnotationCollection
'Usage

Dim instance As PDFPage
Dim value As PDFAnnotationCollection

value = instance.Annotations
public PDFAnnotationCollection Annotations {get;}
public: __property PDFAnnotationCollection* get_Annotations();
public:
property PDFAnnotationCollection^ Annotations {
   PDFAnnotationCollection^ get();
}

Property Value

The list of all annotations included on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


ArtBox Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : ArtBox Property
Gets or sets the page art box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ArtBox As PDFRectangle
'Usage

Dim instance As PDFPage
Dim value As PDFRectangle

instance.ArtBox = value

value = instance.ArtBox
public PDFRectangle ArtBox {get; set;}
public: __property PDFRectangle* get_ArtBox();
public: __property void set_ArtBox(
   PDFRectangle* value
);
public:
property PDFRectangle^ ArtBox {
   PDFRectangle^ get();
   void set (    PDFRectangle^ value);
}

Property Value

A rectangle that defines the page art box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Background Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Background Property
Gets or sets the background of the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Background As PDFPageBackground
'Usage

Dim instance As PDFPage
Dim value As PDFPageBackground

instance.Background = value

value = instance.Background
public PDFPageBackground Background {get; set;}
public: __property PDFPageBackground* get_Background();
public: __property void set_Background(
   PDFPageBackground* value
);
public:
property PDFPageBackground^ Background {
   PDFPageBackground^ get();
   void set (    PDFPageBackground^ value);
}

Property Value

A PDFPageBackground object specifying the background of the page.
Remarks
The background is drawn always first on the page and the rest of page content appears on top of it.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


BleedBox Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : BleedBox Property
Gets or sets the page bleed box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BleedBox As PDFRectangle
'Usage

Dim instance As PDFPage
Dim value As PDFRectangle

instance.BleedBox = value

value = instance.BleedBox
public PDFRectangle BleedBox {get; set;}
public: __property PDFRectangle* get_BleedBox();
public: __property void set_BleedBox(
   PDFRectangle* value
);
public:
property PDFRectangle^ BleedBox {
   PDFRectangle^ get();
   void set (    PDFRectangle^ value);
}

Property Value

A rectangle that defines the page bleed box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


ByteCount Property

O2S.Components.PDF4NET Namespace > PDFPage Class : ByteCount Property
Gets the approximate size in bytes of the imported page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ByteCount As Long
'Usage

Dim instance As PDFPage
Dim value As Long

value = instance.ByteCount
public long ByteCount {get;}
public: __property long get_ByteCount();
public:
property int64 ByteCount {
   int64 get();
}

Property Value

an integer value specifying the approximate size, in bytes, of the imported page.
Remarks
This property returns an approximate value representing the size on disk of the imported page. This size includes only the binary streams associated with the page (images, embedded fonts, page content).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Canvas Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Canvas Property
Gets the page canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Canvas As PDFCanvas
'Usage

Dim instance As PDFPage
Dim value As PDFCanvas

value = instance.Canvas
public PDFCanvas Canvas {get;}
public: __property PDFCanvas* get_Canvas();
public:
property PDFCanvas^ Canvas {
   PDFCanvas^ get();
}

Property Value

The drawing surface of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


CloseAction Property

O2S.Components.PDF4NET Namespace > PDFPage Class : CloseAction Property
Gets or sets the action to be performed when the page is closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CloseAction As PDFAction
'Usage

Dim instance As PDFPage
Dim value As PDFAction

instance.CloseAction = value

value = instance.CloseAction
public PDFAction CloseAction {get; set;}
public: __property PDFAction* get_CloseAction();
public: __property void set_CloseAction(
   PDFAction* value
);
public:
property PDFAction^ CloseAction {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page is closed.
Remarks
This action applies to the page being closed and is executed before any other page is opened.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


CropBox Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : CropBox Property
Gets or sets the page crop box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropBox As PDFRectangle
'Usage

Dim instance As PDFPage
Dim value As PDFRectangle

instance.CropBox = value

value = instance.CropBox
public PDFRectangle CropBox {get; set;}
public: __property PDFRectangle* get_CropBox();
public: __property void set_CropBox(
   PDFRectangle* value
);
public:
property PDFRectangle^ CropBox {
   PDFRectangle^ get();
   void set (    PDFRectangle^ value);
}

Property Value

A rectangle that defines the page crop box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Dictionary Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Dictionary Property
Gets the page dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFPage
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw page dictionary.
Remarks
This property gives you direct access to page dictionary and its associated resources. Note: Modifying directly the page dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Document Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Document Property
Gets the document this page belongs to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Document As PDFDocument
'Usage

Dim instance As PDFPage
Dim value As PDFDocument

value = instance.Document
public PDFDocument Document {get;}
public: __property PDFDocument* get_Document();
public:
property PDFDocument^ Document {
   PDFDocument^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Fields Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Fields Property
Gets the list of fields defined on this page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As PDFFieldCollection
'Usage

Dim instance As PDFPage
Dim value As PDFFieldCollection

value = instance.Fields
public PDFFieldCollection Fields {get;}
public: __property PDFFieldCollection* get_Fields();
public:
property PDFFieldCollection^ Fields {
   PDFFieldCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Height Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Height Property
Gets or sets the page height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PDFPage
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public: __property double get_Height();
public: __property void set_Height(
   double value
);
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The height of the page. The default value of this property is inherited from the document.
Remarks
In a pdf document, each page can have its own height by setting this property to the desired value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


MediaBox Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : MediaBox Property
Gets or sets the page media box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MediaBox As PDFRectangle
'Usage

Dim instance As PDFPage
Dim value As PDFRectangle

instance.MediaBox = value

value = instance.MediaBox
public PDFRectangle MediaBox {get; set;}
public: __property PDFRectangle* get_MediaBox();
public: __property void set_MediaBox(
   PDFRectangle* value
);
public:
property PDFRectangle^ MediaBox {
   PDFRectangle^ get();
   void set (    PDFRectangle^ value);
}

Property Value

A rectangle that defines the page media box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Number Property

O2S.Components.PDF4NET Namespace > PDFPage Class : Number Property
Gets or sets the page number visual aspect for this PDFPage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Number As PDFPageNumber
'Usage

Dim instance As PDFPage
Dim value As PDFPageNumber

instance.Number = value

value = instance.Number
public PDFPageNumber Number {get; set;}
public: __property PDFPageNumber* get_Number();
public: __property void set_Number(
   PDFPageNumber* value
);
public:
property PDFPageNumber^ Number {
   PDFPageNumber^ get();
   void set (    PDFPageNumber^ value);
}
Remarks
Each page can specify its own appearance for the page number by setting this property to the desired page number object. The default value for this property is the one defined for the whole document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


OpenAction Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : OpenAction Property
Gets or sets the action to be performed when the page is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OpenAction As PDFAction
'Usage

Dim instance As PDFPage
Dim value As PDFAction

instance.OpenAction = value

value = instance.OpenAction
public PDFAction OpenAction {get; set;}
public: __property PDFAction* get_OpenAction();
public: __property void set_OpenAction(
   PDFAction* value
);
public:
property PDFAction^ OpenAction {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page is opened.
Remarks
This action is executed after the document's Open action has been executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Orientation Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Orientation Property
Gets or sets the page orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As PDFPageOrientation
'Usage

Dim instance As PDFPage
Dim value As PDFPageOrientation

instance.Orientation = value

value = instance.Orientation
public PDFPageOrientation Orientation {get; set;}
public: __property PDFPageOrientation get_Orientation();
public: __property void set_Orientation(
   PDFPageOrientation value
);
public:
property PDFPageOrientation Orientation {
   PDFPageOrientation get();
   void set (    PDFPageOrientation value);
}

Property Value

A PDFPageOrientation enumeration member specifying the orientation of the page, portrait or landscape.
Remarks
In a pdf document each page can have its own orientation, by setting this property to the desired value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Rotation Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Rotation Property
Gets or sets the page rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFPage
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation();
public: __property void set_Rotation(
   PDFRotationMode value
);
public:
property PDFRotationMode Rotation {
   PDFRotationMode get();
   void set (    PDFRotationMode value);
}

Property Value

The rotation angle of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


SeparationInfo Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : SeparationInfo Property
Gets the separation information associated with the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SeparationInfo As PDFSeparationInfo
'Usage

Dim instance As PDFPage
Dim value As PDFSeparationInfo

instance.SeparationInfo = value

value = instance.SeparationInfo
public PDFSeparationInfo SeparationInfo {get; set;}
public: __property PDFSeparationInfo* get_SeparationInfo();
public: __property void set_SeparationInfo(
   PDFSeparationInfo* value
);
public:
property PDFSeparationInfo^ SeparationInfo {
   PDFSeparationInfo^ get();
   void set (    PDFSeparationInfo^ value);
}

Property Value

A PDFSeparationInfo object specifying the separation information for the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Size Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Size Property
Gets or sets the page size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Size As PDFPageSize
'Usage

Dim instance As PDFPage
Dim value As PDFPageSize

instance.Size = value

value = instance.Size
public PDFPageSize Size {get; set;}
public: __property PDFPageSize get_Size();
public: __property void set_Size(
   PDFPageSize value
);
public:
property PDFPageSize Size {
   PDFPageSize get();
   void set (    PDFPageSize value);
}

Property Value

A PageSize enumeration member specifying the page dimensions.
Remarks
Setting this property, the Width and Height properties are automatically set to the right value. But, setting the Width or the Height does not set this property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


TrimBox Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : TrimBox Property
Gets or sets the page trim box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TrimBox As PDFRectangle
'Usage

Dim instance As PDFPage
Dim value As PDFRectangle

instance.TrimBox = value

value = instance.TrimBox
public PDFRectangle TrimBox {get; set;}
public: __property PDFRectangle* get_TrimBox();
public: __property void set_TrimBox(
   PDFRectangle* value
);
public:
property PDFRectangle^ TrimBox {
   PDFRectangle^ get();
   void set (    PDFRectangle^ value);
}

Property Value

A rectangle that defines the page trim box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Viewports Property

O2S.Components.PDF4NET Namespace > PDFPage Class : Viewports Property
Gets or sets the page viewports.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Viewports As PDFViewportCollection
'Usage

Dim instance As PDFPage
Dim value As PDFViewportCollection

instance.Viewports = value

value = instance.Viewports
public PDFViewportCollection Viewports {get; set;}
public: __property PDFViewportCollection* get_Viewports();
public: __property void set_Viewports(
   PDFViewportCollection* value
);
public:
property PDFViewportCollection^ Viewports {
   PDFViewportCollection^ get();
   void set (    PDFViewportCollection^ value);
}

Property Value

A collection of viewports defined on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


Width Property (PDFPage)

O2S.Components.PDF4NET Namespace > PDFPage Class : Width Property
Gets or sets the page width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFPage
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the page. The default value of this property is inherited from the document.
Remarks
In a pdf document, each page can have its own width by setting this property to the desired value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

PDFPageBackground Class
Members

O2S.Components.PDF4NET Namespace : PDFPageBackground Class
Defines a background for a PDF page.
Object Model
PDFPageBackground ClassPDFBasicCanvas ClassPDFDictionary ClassDisplayRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageBackground
   Inherits O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
'Usage

Dim instance As PDFPageBackground
public class PDFPageBackground : O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
public __gc class PDFPageBackground : public O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
public ref class PDFPageBackground : public O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
Remarks
The page background is displayed under actual page content.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.PDFPageBackground

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageBackground Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageBackground Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFPageBackground Class

The following tables list the members exposed by PDFPageBackground.

Public Constructors
 | Name | Description
Public Constructor | PDFPageBackground Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Dictionary | Gets the form XObject dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Display | Gets or sets a value indicating whether the page background is displayed on the screen.
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Location | Gets or sets the location on the page where the background is drawn.
Public Property | Opacity | Gets or sets the opacity of the page background.
Public Property | Orientation | Gets or sets the rotation angle of the page background.
Public Property | Print | Gets or sets a value indicating whether the page background is printed when the document is printed.
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top
See Also

Reference

PDFPageBackground Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageBackground Constructor

O2S.Components.PDF4NET Namespace > PDFPageBackground Class : PDFPageBackground Constructor
Overload List
Overload | Description
PDFPageBackground Constructor() | Initializes a new PDFPageBackground object.
PDFPageBackground Constructor(PDFImportedContent) | Initializes a new PDFPageBackground object with the content of an existing PDF page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

PDFPageBackground Constructor()

O2S.Components.PDF4NET Namespace > PDFPageBackground Class > PDFPageBackground Constructor : PDFPageBackground Constructor()
Initializes a new PDFPageBackground object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPageBackground()
public PDFPageBackground()
public: PDFPageBackground();
public:
PDFPageBackground();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members
Overload List


%%PageItemTitle%%

PDFPageBackground Constructor(PDFImportedContent)

O2S.Components.PDF4NET Namespace > PDFPageBackground Class > PDFPageBackground Constructor : PDFPageBackground Constructor(PDFImportedContent)
The content of an existing PDF page
Initializes a new PDFPageBackground object with the content of an existing PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal importedContent As PDFImportedContent _
)
'Usage

Dim importedContent As PDFImportedContent

Dim instance As New PDFPageBackground(importedContent)
public PDFPageBackground(
   PDFImportedContent importedContent
)
public: PDFPageBackground(
   PDFImportedContent* importedContent
)
public:
PDFPageBackground(
   PDFImportedContent^ importedContent
)

Parameters

importedContent
The content of an existing PDF page
Remarks
This constructor initializes the page background with the content of another PDF page. All the new content that is added to the background is drawn on top of imported content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPageBackground Class Properties

O2S.Components.PDF4NET Namespace : PDFPageBackground Class

For a list of all members of this type, see PDFPageBackground members.

Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Dictionary | Gets the form XObject dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Display | Gets or sets a value indicating whether the page background is displayed on the screen.
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Location | Gets or sets the location on the page where the background is drawn.
Public Property | Opacity | Gets or sets the opacity of the page background.
Public Property | Orientation | Gets or sets the rotation angle of the page background.
Public Property | Print | Gets or sets a value indicating whether the page background is printed when the document is printed.
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top
See Also

Reference

PDFPageBackground Class
O2S.Components.PDF4NET Namespace


Display Property (PDFPageBackground)

O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Display Property
Gets or sets a value indicating whether the page background is displayed on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Display As Boolean
'Usage

Dim instance As PDFPageBackground
Dim value As Boolean

instance.Display = value

value = instance.Display
public bool Display {get; set;}
public: __property bool get_Display();
public: __property void set_Display(
   bool value
);
public:
property bool Display {
   bool get();
   void set (    bool value);
}

Property Value

True if the page background is displayed on the screen, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


Location Property (PDFPageBackground)

O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Location Property
Gets or sets the location on the page where the background is drawn.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Location As DisplayRectangle
'Usage

Dim instance As PDFPageBackground
Dim value As DisplayRectangle

instance.Location = value

value = instance.Location
public DisplayRectangle Location {get; set;}
public: __property DisplayRectangle* get_Location();
public: __property void set_Location(
   DisplayRectangle* value
);
public:
property DisplayRectangle^ Location {
   DisplayRectangle^ get();
   void set (    DisplayRectangle^ value);
}

Property Value

A DisplayRectangle object specifying the location on the page where the background is drawn.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


Opacity Property (PDFPageBackground)

O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Opacity Property
Gets or sets the opacity of the page background.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Double
'Usage

Dim instance As PDFPageBackground
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public double Opacity {get; set;}
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
public:
property double Opacity {
   double get();
   void set (    double value);
}

Property Value

The opacity of the page background.
Remarks
This property controls the transparency level of the page background. 0 means full transparency, 100 means full opacity.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


Orientation Property (PDFPageBackground)

O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Orientation Property
Gets or sets the rotation angle of the page background.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As Double
'Usage

Dim instance As PDFPageBackground
Dim value As Double

instance.Orientation = value

value = instance.Orientation
public double Orientation {get; set;}
public: __property double get_Orientation();
public: __property void set_Orientation(
   double value
);
public:
property double Orientation {
   double get();
   void set (    double value);
}

Property Value

A float value specifying the rotation angle of the page background.
Remarks
The page background is rotated around the top left corner of the Location rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


Print Property (PDFPageBackground)

O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Print Property
Gets or sets a value indicating whether the page background is printed when the document is printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Print As Boolean
'Usage

Dim instance As PDFPageBackground
Dim value As Boolean

instance.Print = value

value = instance.Print
public bool Print {get; set;}
public: __property bool get_Print();
public: __property void set_Print(
   bool value
);
public:
property bool Print {
   bool get();
   void set (    bool value);
}

Property Value

True if the page background is printed when the document is printed, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


%%PageItemTitle%%

PDFPageCollection Class
Members

O2S.Components.PDF4NET Namespace : PDFPageCollection Class
Defines a collection of PDF pages.
Object Model
PDFPageCollection ClassPDFPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFPage,PDFDocument)
'Usage

Dim instance As PDFPageCollection
public class PDFPageCollection : O2S.Components.PDF4NET.PDFCollection<PDFPage,PDFDocument>
public __gc class PDFPageCollection : public O2S.Components.PDF4NET.PDFCollection<PDFPage,PDFDocument>
public ref class PDFPageCollection : public O2S.Components.PDF4NET.PDFCollection<PDFPage,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.PDFPageCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageCollection Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFPageCollection Class

The following tables list the members exposed by PDFPageCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top
See Also

Reference

PDFPageCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageDestination Class
Members

O2S.Components.PDF4NET Namespace : PDFPageDestination Class
Defines a destination to a page within the current document.
Object Model
PDFPageDestination ClassPDFArray ClassPDFPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageDestination
   Inherits PDFDirectDestination
'Usage

Dim instance As PDFPageDestination
public class PDFPageDestination : PDFDirectDestination
public __gc class PDFPageDestination : public PDFDirectDestination
public ref class PDFPageDestination : public PDFDirectDestination
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination
O2S.Components.PDF4NET.PDFPageDestination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageDestination Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFPageDestination Class

The following tables list the members exposed by PDFPageDestination.

Public Constructors
 | Name | Description
Public Constructor | PDFPageDestination Constructor | Initializes a new PDFPageDestination object.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Destination | Gets the COS destination object. (Inherited from O2S.Components.PDF4NET.PDFDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | MagnificationMode | Gets or sets the magnification mode. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Page | Gets or sets the destination page.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Top | Overridden. Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Top
See Also

Reference

PDFPageDestination Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageDestination Constructor

O2S.Components.PDF4NET Namespace > PDFPageDestination Class : PDFPageDestination Constructor
Initializes a new PDFPageDestination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPageDestination()
public PDFPageDestination()
public: PDFPageDestination();
public:
PDFPageDestination();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


%%PageItemTitle%% $$Properties$$

PDFPageDestination Class Properties

O2S.Components.PDF4NET Namespace : PDFPageDestination Class

For a list of all members of this type, see PDFPageDestination members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Destination | Gets the COS destination object. (Inherited from O2S.Components.PDF4NET.PDFDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | MagnificationMode | Gets or sets the magnification mode. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Page | Gets or sets the destination page.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Top | Overridden. Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Top
See Also

Reference

PDFPageDestination Class
O2S.Components.PDF4NET Namespace


Page Property (PDFPageDestination)

O2S.Components.PDF4NET Namespace > PDFPageDestination Class : Page Property
Gets or sets the destination page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As PDFPage
'Usage

Dim instance As PDFPageDestination
Dim value As PDFPage

instance.Page = value

value = instance.Page
public PDFPage Page {get; set;}
public: __property PDFPage* get_Page();
public: __property void set_Page(
   PDFPage* value
);
public:
property PDFPage^ Page {
   PDFPage^ get();
   void set (    PDFPage^ value);
}

Property Value

The target page of the destination.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


Top Property (PDFPageDestination)

O2S.Components.PDF4NET Namespace > PDFPageDestination Class : Top Property
Gets or sets the top coordinate in the page where the viewer should display the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Top As Double
'Usage

Dim instance As PDFPageDestination
Dim value As Double

instance.Top = value

value = instance.Top
public override double Top {get; set;}
public: __property double get_Top() override;
public: __property void set_Top(
   double value
) override;
public:
property double Top {
   double get() override;
   void set (    double value) override;
}

Property Value

A double value specifying the top coordinate in the page where the viewer should display the page.
Remarks
When the destination page is displayed, the viewer will try to display the page at the given coordinate. This value is relative to the top of the page, 0 value meaning that the top of the page will be displayed.
A -1 value for this property means that the current top coordinate used by the viewer will not be changed when dispaying the page.
This value is used by the following magnification modes: PDFMagnificationMode.XYZ, PDFMagnificationMode.FitH, PDFMagnificationMode.FitR, PDFMagnificationMode.FitBH
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


%%PageItemTitle%%

PDFPageNumber Class
Members

O2S.Components.PDF4NET Namespace : PDFPageNumber Class
Defines the visual aspect of the page number when it is drawn on the page
Object Model
PDFPageNumber ClassPDFBrush ClassPDFFontBase ClassPDFPen Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageNumber
'Usage

Dim instance As PDFPageNumber
public class PDFPageNumber
public __gc class PDFPageNumber
public ref class PDFPageNumber
Remarks
This class works in conjunction with PDFPageNumberingRange class. In order to have the page number automatically drawn on the page, at least one numberig range must be defined for the document and the page must be included in the interval defined by the numbering range.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFPageNumber

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumber Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageNumber Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFPageNumber Class

The following tables list the members exposed by PDFPageNumber.

Public Constructors
 | Name | Description
Public Constructor | PDFPageNumber Constructor | Initializes a new PageNumber object. Supported by Compact .NET Edition.
Top
Public Properties
 | Name | Description
Public Property | Align | Gets or sets the alignment of text used to draw the page number.
Public Property | Brush | Gets or sets the brush used to draw the page number.
Public Property | Font | Gets or sets the font used to draw the page number.
Public Property | HorizontalOffset | Gets or sets the horizontal offset used to position the page number.
Public Property | Pen | Gets or sets the pen used to draw the page number.
Public Property | VerticalOffset | Gets or sets the vertical offset used to position the page number.
Top
See Also

Reference

PDFPageNumber Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageNumber Constructor

O2S.Components.PDF4NET Namespace > PDFPageNumber Class : PDFPageNumber Constructor
Initializes a new PageNumber object.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPageNumber()
public PDFPageNumber()
public: PDFPageNumber();
public:
PDFPageNumber();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


%%PageItemTitle%% $$Properties$$

PDFPageNumber Class Properties

O2S.Components.PDF4NET Namespace : PDFPageNumber Class

For a list of all members of this type, see PDFPageNumber members.

Public Properties
 | Name | Description
Public Property | Align | Gets or sets the alignment of text used to draw the page number.
Public Property | Brush | Gets or sets the brush used to draw the page number.
Public Property | Font | Gets or sets the font used to draw the page number.
Public Property | HorizontalOffset | Gets or sets the horizontal offset used to position the page number.
Public Property | Pen | Gets or sets the pen used to draw the page number.
Public Property | VerticalOffset | Gets or sets the vertical offset used to position the page number.
Top
See Also

Reference

PDFPageNumber Class
O2S.Components.PDF4NET Namespace


Align Property (PDFPageNumber)

O2S.Components.PDF4NET Namespace > PDFPageNumber Class : Align Property
Gets or sets the alignment of text used to draw the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Align As PDFTextAlign
'Usage

Dim instance As PDFPageNumber
Dim value As PDFTextAlign

instance.Align = value

value = instance.Align
public PDFTextAlign Align {get; set;}
public: __property PDFTextAlign get_Align();
public: __property void set_Align(
   PDFTextAlign value
);
public:
property PDFTextAlign Align {
   PDFTextAlign get();
   void set (    PDFTextAlign value);
}

Property Value

A TextAlign enumeration member used to position the page number within the page.
Remarks
This property is used to position the page number within the page. Top and bottom alignments use VerticalOffset property to position the page number. Left and right alignments use HorizontalOffset property to position the page number. Middle and center alignments center the page number on vertical, respectivelly on horizontal.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


Brush Property

O2S.Components.PDF4NET Namespace > PDFPageNumber Class : Brush Property
Gets or sets the brush used to draw the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Brush As PDFBrush
'Usage

Dim instance As PDFPageNumber
Dim value As PDFBrush

instance.Brush = value

value = instance.Brush
public PDFBrush Brush {get; set;}
public: __property PDFBrush* get_Brush();
public: __property void set_Brush(
   PDFBrush* value
);
public:
property PDFBrush^ Brush {
   PDFBrush^ get();
   void set (    PDFBrush^ value);
}

Property Value

a O2S.Components.PDF4NET.Graphics.PDFBrush object used to draw the page number.
Remarks
This O2S.Components.PDF4NET.Graphics.PDFBrush object is used to fill the interior of the text representing the page number. If this is null, then the text will be drawn unfilled. The default value of this property is a brush of black color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


Font Property (PDFPageNumber)

O2S.Components.PDF4NET Namespace > PDFPageNumber Class : Font Property
Gets or sets the font used to draw the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Font As PDFFontBase
'Usage

Dim instance As PDFPageNumber
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
public PDFFontBase Font {get; set;}
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (    PDFFontBase^ value);
}

Property Value

a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase object used to draw the page number
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


HorizontalOffset Property

O2S.Components.PDF4NET Namespace > PDFPageNumber Class : HorizontalOffset Property
Gets or sets the horizontal offset used to position the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HorizontalOffset As Double
'Usage

Dim instance As PDFPageNumber
Dim value As Double

instance.HorizontalOffset = value

value = instance.HorizontalOffset
public double HorizontalOffset {get; set;}
public: __property double get_HorizontalOffset();
public: __property void set_HorizontalOffset(
   double value
);
public:
property double HorizontalOffset {
   double get();
   void set (    double value);
}

Property Value

a double value specifying the horizontal offset
Remarks
The horizontal offset is used when the page number is left or right aligned.

When the page number is left aligned, the horizontal offset represents the distance between the left margin of the page and the left corner of the rectangle bounding the page number.

When the page number is right aligned, the horizontal offset represents the distance between the right margin of the page and the right corner of the rectangle bounding the page number.

When the page number is center aligned on the horizontal, the horizontal offset is not used. The horizontal center of the bounding rectangle is positioned at half of page width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


Pen Property

O2S.Components.PDF4NET Namespace > PDFPageNumber Class : Pen Property
Gets or sets the pen used to draw the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Pen As PDFPen
'Usage

Dim instance As PDFPageNumber
Dim value As PDFPen

instance.Pen = value

value = instance.Pen
public PDFPen Pen {get; set;}
public: __property PDFPen* get_Pen();
public: __property void set_Pen(
   PDFPen* value
);
public:
property PDFPen^ Pen {
   PDFPen^ get();
   void set (    PDFPen^ value);
}

Property Value

a O2S.Components.PDF4NET.Graphics.PDFPen object used to draw the page number.
Remarks
This O2S.Components.PDF4NET.Graphics.PDFPen object is used to draw the border of the text representing the page number. If this is null, then the text will be drawn without border. The default value of this property is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


VerticalOffset Property

O2S.Components.PDF4NET Namespace > PDFPageNumber Class : VerticalOffset Property
Gets or sets the vertical offset used to position the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VerticalOffset As Double
'Usage

Dim instance As PDFPageNumber
Dim value As Double

instance.VerticalOffset = value

value = instance.VerticalOffset
public double VerticalOffset {get; set;}
public: __property double get_VerticalOffset();
public: __property void set_VerticalOffset(
   double value
);
public:
property double VerticalOffset {
   double get();
   void set (    double value);
}

Property Value

a double value specifying the vertical offset
Remarks
The vertical offset is used when the page number is top or bottom aligned.

When the page number is top aligned, the vertical offset represents the distance between the top margin of the page and the top corner of the rectangle bounding the page number.

When the page number is bottom aligned, the vertical offset represents the distance between the bottom margin of the page and the bottom corner of the rectangle bounding the page number.

When the page number is middle aligned on the vertical, the vertical offset is not used. The vertical middle of the bounding rectangle is positioned at half of page height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


%%PageItemTitle%%

PDFPageNumberingRange Class
Members

O2S.Components.PDF4NET Namespace : PDFPageNumberingRange Class
Defines a series of consecutive pages within the PDF document using the same numbering system
Object Model
PDFPageNumberingRange Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class PDFPageNumberingRange
'Usage

Dim instance As PDFPageNumberingRange
public sealed class PDFPageNumberingRange
public __gc __sealed class PDFPageNumberingRange
public ref class PDFPageNumberingRange sealed
Remarks
A numbering range defines a set of consecutive pages that use the same numbering system. The range is considered to start from the page specified by StartPageIndex property and ends at the last page of the document. If multiple numbering ranges are defined, then a numbering range ends where the next numbering range starts. The numbering ranges of a document are ordered ascending by StartPageIndex property.

For example, a document has an introduction on first 3 pages, then it starts first chapter from the 4th page. A numbering range starting at index zero can be defined for the introduction using roman numerals, then a new numbering range can be defined starting at index 3 using arabic numerals. For this new range, the start page number can be set to 1, this being the first logical page, although it is the 4th physical page in the document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFPageNumberingRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumberingRange Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageNumberingRange Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFPageNumberingRange Class

The following tables list the members exposed by PDFPageNumberingRange.

Public Constructors
 | Name | Description
Public Constructor | PDFPageNumberingRange Constructor | Initializes a new PDFPageNumberingRange object.
Top
Public Properties
 | Name | Description
Public Property | NumberingStyle | Gets or sets the visual style of the page numbers for this PageNumberingRange object.
Public Property | PageNumberPrefix | Gets or sets the prefix that will be appended in front of the page number.
Public Property | PageNumberSuffix | Gets or sets the suffix that will be appended at the end of the page number.
Public Property | StartPageIndex | Gets or sets the start page where the numbering range starts.
Public Property | StartPageNumber | Gets or sets the page number the numbering of the pages starts for this range.
Top
See Also

Reference

PDFPageNumberingRange Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageNumberingRange Constructor

O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : PDFPageNumberingRange Constructor
Initializes a new PDFPageNumberingRange object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPageNumberingRange()
public PDFPageNumberingRange()
public: PDFPageNumberingRange();
public:
PDFPageNumberingRange();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


%%PageItemTitle%% $$Properties$$

PDFPageNumberingRange Class Properties

O2S.Components.PDF4NET Namespace : PDFPageNumberingRange Class

For a list of all members of this type, see PDFPageNumberingRange members.

Public Properties
 | Name | Description
Public Property | NumberingStyle | Gets or sets the visual style of the page numbers for this PageNumberingRange object.
Public Property | PageNumberPrefix | Gets or sets the prefix that will be appended in front of the page number.
Public Property | PageNumberSuffix | Gets or sets the suffix that will be appended at the end of the page number.
Public Property | StartPageIndex | Gets or sets the start page where the numbering range starts.
Public Property | StartPageNumber | Gets or sets the page number the numbering of the pages starts for this range.
Top
See Also

Reference

PDFPageNumberingRange Class
O2S.Components.PDF4NET Namespace


NumberingStyle Property

O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : NumberingStyle Property
Gets or sets the visual style of the page numbers for this PageNumberingRange object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NumberingStyle As PDFNumberingStyle
'Usage

Dim instance As PDFPageNumberingRange
Dim value As PDFNumberingStyle

instance.NumberingStyle = value

value = instance.NumberingStyle
public PDFNumberingStyle NumberingStyle {get; set;}
public: __property PDFNumberingStyle get_NumberingStyle();
public: __property void set_NumberingStyle(
   PDFNumberingStyle value
);
public:
property PDFNumberingStyle NumberingStyle {
   PDFNumberingStyle get();
   void set (    PDFNumberingStyle value);
}

Property Value

a NumberingStyle enumeration member specifying the numbering style for this PageNumberingRange object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


PageNumberPrefix Property

O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : PageNumberPrefix Property
Gets or sets the prefix that will be appended in front of the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumberPrefix As String
'Usage

Dim instance As PDFPageNumberingRange
Dim value As String

instance.PageNumberPrefix = value

value = instance.PageNumberPrefix
public string PageNumberPrefix {get; set;}
public: __property string* get_PageNumberPrefix();
public: __property void set_PageNumberPrefix(
   string* value
);
public:
property String^ PageNumberPrefix {
   String^ get();
   void set (    String^ value);
}

Property Value

a System.String value representing a prefix that is appended to all the page numbers in this range.
Remarks
This prefix is printed on the pages in the range before the page number. All pages in a range share the same prefix. This prefix is also visible in the Print dialog box of the PDF viewer, when specifing a range of pages to print.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


PageNumberSuffix Property

O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : PageNumberSuffix Property
Gets or sets the suffix that will be appended at the end of the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumberSuffix As String
'Usage

Dim instance As PDFPageNumberingRange
Dim value As String

instance.PageNumberSuffix = value

value = instance.PageNumberSuffix
public string PageNumberSuffix {get; set;}
public: __property string* get_PageNumberSuffix();
public: __property void set_PageNumberSuffix(
   string* value
);
public:
property String^ PageNumberSuffix {
   String^ get();
   void set (    String^ value);
}

Property Value

a System.String value representing a suffix that is appended to all the page numbers in this range.
Remarks
This prefix is printed on the pages in the range after the page number. All pages in a range share the same suffix.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


StartPageIndex Property

O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : StartPageIndex Property
Gets or sets the start page where the numbering range starts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartPageIndex As Integer
'Usage

Dim instance As PDFPageNumberingRange
Dim value As Integer

instance.StartPageIndex = value

value = instance.StartPageIndex
public int StartPageIndex {get; set;}
public: __property int get_StartPageIndex();
public: __property void set_StartPageIndex(
   int value
);
public:
property int StartPageIndex {
   int get();
   void set (    int value);
}

Property Value

an integer value specifying the zero based index of the page where the numbering range starts. The index is considered within the pages collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


StartPageNumber Property

O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : StartPageNumber Property
Gets or sets the page number the numbering of the pages starts for this range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartPageNumber As Integer
'Usage

Dim instance As PDFPageNumberingRange
Dim value As Integer

instance.StartPageNumber = value

value = instance.StartPageNumber
public int StartPageNumber {get; set;}
public: __property int get_StartPageNumber();
public: __property void set_StartPageNumber(
   int value
);
public:
property int StartPageNumber {
   int get();
   void set (    int value);
}

Property Value

an integer value specifying the start page number for this PageNumberingRange object.
Remarks
This property specifies the page number that will be printed on the first page in this range. The other pages will be numbered consecutively, starting from this value. It represents a logical page number and it is related to the specific content of the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


%%PageItemTitle%%

PDFPageNumberingRangeCollection Class
Members

O2S.Components.PDF4NET Namespace : PDFPageNumberingRangeCollection Class
Defines a collection of bookmarks.
Object Model
PDFPageNumberingRangeCollection ClassPDFPageNumberingRange Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageNumberingRangeCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFPageNumberingRange,PDFDocument)
'Usage

Dim instance As PDFPageNumberingRangeCollection
public class PDFPageNumberingRangeCollection : O2S.Components.PDF4NET.PDFCollection<PDFPageNumberingRange,PDFDocument>
public __gc class PDFPageNumberingRangeCollection : public O2S.Components.PDF4NET.PDFCollection<PDFPageNumberingRange,PDFDocument>
public ref class PDFPageNumberingRangeCollection : public O2S.Components.PDF4NET.PDFCollection<PDFPageNumberingRange,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.PDFPageNumberingRangeCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumberingRangeCollection Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageNumberingRangeCollection Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFPageNumberingRangeCollection Class

The following tables list the members exposed by PDFPageNumberingRangeCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Top
See Also

Reference

PDFPageNumberingRangeCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFParserException Class
Members

O2S.Components.PDF4NET Namespace : PDFParserException Class
Defines the exceptions thrown by the pdf parser.
Object Model
PDFParserException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFParserException
   Inherits System.ApplicationException
'Usage

Dim instance As PDFParserException
public class PDFParserException : System.ApplicationException
public __gc class PDFParserException : public System.ApplicationException
public ref class PDFParserException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFParserException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFParserException Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFParserException Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFParserException Class

The following tables list the members exposed by PDFParserException.

Public Constructors
 | Name | Description
Public Constructor | PDFParserException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFParserException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFParserException Constructor

O2S.Components.PDF4NET Namespace > PDFParserException Class : PDFParserException Constructor
Overload List
Overload | Description
PDFParserException Constructor(String) | Initializes a new PDFParserException object.
PDFParserException Constructor(String,Exception) | Initializes a new PDFParserException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFParserException Class
PDFParserException Members


%%PageItemTitle%%

PDFParserException Constructor(String)

O2S.Components.PDF4NET Namespace > PDFParserException Class > PDFParserException Constructor : PDFParserException Constructor(String)
The message that describes the exception.
Initializes a new PDFParserException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PDFParserException(message)
public PDFParserException(
   string message
)
public: PDFParserException(
   string* message
)
public:
PDFParserException(
   String^ message
)

Parameters

message
The message that describes the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFParserException Class
PDFParserException Members
Overload List


%%PageItemTitle%%

PDFParserException Constructor(String,Exception)

O2S.Components.PDF4NET Namespace > PDFParserException Class > PDFParserException Constructor : PDFParserException Constructor(String,Exception)
the message that describes the exception.
The exception that is the cause of the current exception.
Initializes a new PDFParserException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PDFParserException(message, innerException)
public PDFParserException(
   string message,
   Exception innerException
)
public: PDFParserException(
   string* message,
   Exception* innerException
)
public:
PDFParserException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFParserException Class
PDFParserException Members
Overload List


%%PageItemTitle%%

PDFPoint Class
Members

O2S.Components.PDF4NET Namespace : PDFPoint Class
Represents a pair of floating point x- and y-coordinates that defines a point in a two-dimensional plane.
Object Model
PDFPoint Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPoint
'Usage

Dim instance As PDFPoint
public class PDFPoint
public __gc class PDFPoint
public ref class PDFPoint
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPoint Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPoint Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFPoint Class

The following tables list the members exposed by PDFPoint.

Public Constructors
 | Name | Description
Public Constructor | PDFPoint Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | X | Gets or set the x coordinate of this point.
Public Property | Y | Gets or set the y coordinate of this point.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the point to string.
Top
See Also

Reference

PDFPoint Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPoint Constructor

O2S.Components.PDF4NET Namespace > PDFPoint Class : PDFPoint Constructor
Overload List
Overload | Description
PDFPoint Constructor() | Initializes a new PDFPoint object.
PDFPoint Constructor(PointF) | Initializes a new PDFPoint object based on a System.Drawing.PointF structure.
PDFPoint Constructor(Point) | Initializes a new PDFPoint object based on a System.Drawing.Point structure.
PDFPoint Constructor(Double,Double) | Initializes a new PDFPoint object based on the given coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPoint Class
PDFPoint Members


%%PageItemTitle%%

PDFPoint Constructor()

O2S.Components.PDF4NET Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor()
Initializes a new PDFPoint object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPoint()
public PDFPoint()
public: PDFPoint();
public:
PDFPoint();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


%%PageItemTitle%%

PDFPoint Constructor(PointF)

O2S.Components.PDF4NET Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor(PointF)
a System.Drawing.PointF structure to initialize this PDFPoint object.
Initializes a new PDFPoint object based on a System.Drawing.PointF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal point As PointF _
)
'Usage

Dim point As PointF

Dim instance As New PDFPoint(point)
public PDFPoint(
   PointF point
)
public: PDFPoint(
   PointF point
)
public:
PDFPoint(
   PointF point
)

Parameters

point
a System.Drawing.PointF structure to initialize this PDFPoint object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


%%PageItemTitle%%

PDFPoint Constructor(Point)

O2S.Components.PDF4NET Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor(Point)
a System.Drawing.Point structure to initialize this PDFPoint object.
Initializes a new PDFPoint object based on a System.Drawing.Point structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal point As Point _
)
'Usage

Dim point As Point

Dim instance As New PDFPoint(point)
public PDFPoint(
   Point point
)
public: PDFPoint(
   Point point
)
public:
PDFPoint(
   Point point
)

Parameters

point
a System.Drawing.Point structure to initialize this PDFPoint object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


%%PageItemTitle%%

PDFPoint Constructor(Double,Double)

O2S.Components.PDF4NET Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor(Double,Double)
the x coordinate of the point
the y coordinate of the point
Initializes a new PDFPoint object based on the given coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim x As Double
Dim y As Double

Dim instance As New PDFPoint(x, y)
public PDFPoint(
   double x,
   double y
)
public: PDFPoint(
   double x,
   double y
)
public:
PDFPoint(
   double x,
   double y
)

Parameters

x
the x coordinate of the point
y
the y coordinate of the point
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFPoint Class Methods

O2S.Components.PDF4NET Namespace : PDFPoint Class

For a list of all members of this type, see PDFPoint members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the point to string.
Top
See Also

Reference

PDFPoint Class
O2S.Components.PDF4NET Namespace


ToString Method (PDFPoint)

O2S.Components.PDF4NET Namespace > PDFPoint Class : ToString Method
Converts the point to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFPoint
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The point as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPoint Class
PDFPoint Members


%%PageItemTitle%% $$Properties$$

PDFPoint Class Properties

O2S.Components.PDF4NET Namespace : PDFPoint Class

For a list of all members of this type, see PDFPoint members.

Public Properties
 | Name | Description
Public Property | X | Gets or set the x coordinate of this point.
Public Property | Y | Gets or set the y coordinate of this point.
Top
See Also

Reference

PDFPoint Class
O2S.Components.PDF4NET Namespace


X Property (PDFPoint)

O2S.Components.PDF4NET Namespace > PDFPoint Class : X Property
Gets or set the x coordinate of this point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As Double
'Usage

Dim instance As PDFPoint
Dim value As Double

instance.X = value

value = instance.X
public double X {get; set;}
public: __property double get_X();
public: __property void set_X(
   double value
);
public:
property double X {
   double get();
   void set (    double value);
}

Property Value

A float value representing the x coordinate of this point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPoint Class
PDFPoint Members


Y Property (PDFPoint)

O2S.Components.PDF4NET Namespace > PDFPoint Class : Y Property
Gets or set the y coordinate of this point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PDFPoint
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public: __property double get_Y();
public: __property void set_Y(
   double value
);
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

A float value representing the y coordinate of this point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPoint Class
PDFPoint Members


%%PageItemTitle%%

PDFRectangle Class
Members

O2S.Components.PDF4NET Namespace : PDFRectangle Class
Defines a rectangle in PDF default coordinates, where the origin of the coordinate system is located in the bottom left corner of the page.
Object Model
PDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRectangle
'Usage

Dim instance As PDFRectangle
public class PDFRectangle
public __gc class PDFRectangle
public ref class PDFRectangle
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFRectangle Class Members
Properties Methods

O2S.Components.PDF4NET Namespace : PDFRectangle Class

The following tables list the members exposed by PDFRectangle.

Public Constructors
 | Name | Description
Public Constructor | PDFRectangle Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | LLX | Gets or sets X coordinate of the lower left corner.
Public Property | LLY | Gets or sets Y coordinate of the lower left corner.
Public Property | URX | Gets or sets X coordinate of the upper right corner.
Public Property | URY | Gets or sets Y coordinate of the upper right corner.
Public Property | Width | Gets or sets the rectangle's width.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the rectangle to string representation.
Top
See Also

Reference

PDFRectangle Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFRectangle Constructor

O2S.Components.PDF4NET Namespace > PDFRectangle Class : PDFRectangle Constructor
Overload List
Overload | Description
PDFRectangle Constructor() | Initializes a new PDFRectangle object.
PDFRectangle Constructor(Double,Double,Double,Double) | Initializes a new PDFRectangle object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%PageItemTitle%%

PDFRectangle Constructor()

O2S.Components.PDF4NET Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor()
Initializes a new PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRectangle()
public PDFRectangle()
public: PDFRectangle();
public:
PDFRectangle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%%

PDFRectangle Constructor(Double,Double,Double,Double)

O2S.Components.PDF4NET Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor(Double,Double,Double,Double)
The x coordinate of the lower left corner of the rectangle.
The y coordinate of the lower left corner of the rectangle.
The x coordinate of the upper right corner of the rectangle.
The y coordinate of the upper right corner of the rectangle.
Initializes a new PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal llx As Double, _
   ByVal lly As Double, _
   ByVal urx As Double, _
   ByVal ury As Double _
)
'Usage

Dim llx As Double
Dim lly As Double
Dim urx As Double
Dim ury As Double

Dim instance As New PDFRectangle(llx, lly, urx, ury)
public PDFRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)
public: PDFRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)
public:
PDFRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)

Parameters

llx
The x coordinate of the lower left corner of the rectangle.
lly
The y coordinate of the lower left corner of the rectangle.
urx
The x coordinate of the upper right corner of the rectangle.
ury
The y coordinate of the upper right corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFRectangle Class Methods

O2S.Components.PDF4NET Namespace : PDFRectangle Class

For a list of all members of this type, see PDFRectangle members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the rectangle to string representation.
Top
See Also

Reference

PDFRectangle Class
O2S.Components.PDF4NET Namespace


ToString Method (PDFRectangle)

O2S.Components.PDF4NET Namespace > PDFRectangle Class : ToString Method
Converts the rectangle to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFRectangle
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%PageItemTitle%% $$Properties$$

PDFRectangle Class Properties

O2S.Components.PDF4NET Namespace : PDFRectangle Class

For a list of all members of this type, see PDFRectangle members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | LLX | Gets or sets X coordinate of the lower left corner.
Public Property | LLY | Gets or sets Y coordinate of the lower left corner.
Public Property | URX | Gets or sets X coordinate of the upper right corner.
Public Property | URY | Gets or sets Y coordinate of the upper right corner.
Public Property | Width | Gets or sets the rectangle's width.
Top
See Also

Reference

PDFRectangle Class
O2S.Components.PDF4NET Namespace


Height Property (PDFRectangle)

O2S.Components.PDF4NET Namespace > PDFRectangle Class : Height Property
Gets or sets the rectangle's height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public: __property double get_Height();
public: __property void set_Height(
   double value
);
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The height of the rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


LLX Property

O2S.Components.PDF4NET Namespace > PDFRectangle Class : LLX Property
Gets or sets X coordinate of the lower left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LLX As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.LLX = value

value = instance.LLX
public double LLX {get; set;}
public: __property double get_LLX();
public: __property void set_LLX(
   double value
);
public:
property double LLX {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the lower left corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


LLY Property

O2S.Components.PDF4NET Namespace > PDFRectangle Class : LLY Property
Gets or sets Y coordinate of the lower left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LLY As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.LLY = value

value = instance.LLY
public double LLY {get; set;}
public: __property double get_LLY();
public: __property void set_LLY(
   double value
);
public:
property double LLY {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the lower left corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


URX Property

O2S.Components.PDF4NET Namespace > PDFRectangle Class : URX Property
Gets or sets X coordinate of the upper right corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property URX As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.URX = value

value = instance.URX
public double URX {get; set;}
public: __property double get_URX();
public: __property void set_URX(
   double value
);
public:
property double URX {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the upper right corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


URY Property

O2S.Components.PDF4NET Namespace > PDFRectangle Class : URY Property
Gets or sets Y coordinate of the upper right corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property URY As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.URY = value

value = instance.URY
public double URY {get; set;}
public: __property double get_URY();
public: __property void set_URY(
   double value
);
public:
property double URY {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the upper right corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


Width Property (PDFRectangle)

O2S.Components.PDF4NET Namespace > PDFRectangle Class : Width Property
Gets or sets the rectangle's width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%PageItemTitle%%

PDFRemotePageDestination Class
Members

O2S.Components.PDF4NET Namespace : PDFRemotePageDestination Class
Defines a destination to a page in another PDF document.
Object Model
PDFRemotePageDestination ClassPDFArray Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRemotePageDestination
   Inherits PDFDirectDestination
'Usage

Dim instance As PDFRemotePageDestination
public class PDFRemotePageDestination : PDFDirectDestination
public __gc class PDFRemotePageDestination : public PDFDirectDestination
public ref class PDFRemotePageDestination : public PDFDirectDestination
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination
O2S.Components.PDF4NET.PDFRemotePageDestination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemotePageDestination Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFRemotePageDestination Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFRemotePageDestination Class

The following tables list the members exposed by PDFRemotePageDestination.

Public Constructors
 | Name | Description
Public Constructor | PDFRemotePageDestination Constructor | Initializes a new PDFRemotePageDestination object.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Destination | Gets the COS destination object. (Inherited from O2S.Components.PDF4NET.PDFDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | MagnificationMode | Gets or sets the magnification mode. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | PageNumber | Gets or sets the destination page number.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Top
See Also

Reference

PDFRemotePageDestination Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFRemotePageDestination Constructor

O2S.Components.PDF4NET Namespace > PDFRemotePageDestination Class : PDFRemotePageDestination Constructor
Initializes a new PDFRemotePageDestination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRemotePageDestination()
public PDFRemotePageDestination()
public: PDFRemotePageDestination();
public:
PDFRemotePageDestination();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemotePageDestination Class
PDFRemotePageDestination Members


%%PageItemTitle%% $$Properties$$

PDFRemotePageDestination Class Properties

O2S.Components.PDF4NET Namespace : PDFRemotePageDestination Class

For a list of all members of this type, see PDFRemotePageDestination members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Destination | Gets the COS destination object. (Inherited from O2S.Components.PDF4NET.PDFDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | MagnificationMode | Gets or sets the magnification mode. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | PageNumber | Gets or sets the destination page number.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed. (Inherited from O2S.Components.PDF4NET.PDFDirectDestination)
Top
See Also

Reference

PDFRemotePageDestination Class
O2S.Components.PDF4NET Namespace


PageNumber Property (PDFRemotePageDestination)

O2S.Components.PDF4NET Namespace > PDFRemotePageDestination Class : PageNumber Property
Gets or sets the destination page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As PDFRemotePageDestination
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

The number of the page in the remote PDF document.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 0.
Remarks
The page number if 0 based.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemotePageDestination Class
PDFRemotePageDestination Members


%%PageItemTitle%%

PDFSeparationInfo Class
Members

O2S.Components.PDF4NET Namespace : PDFSeparationInfo Class
Defines the separation information for a PDF page.
Object Model
PDFSeparationInfo ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSeparationInfo
'Usage

Dim instance As PDFSeparationInfo
public class PDFSeparationInfo
public __gc class PDFSeparationInfo
public ref class PDFSeparationInfo
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFSeparationInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationInfo Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFSeparationInfo Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFSeparationInfo Class

The following tables list the members exposed by PDFSeparationInfo.

Public Constructors
 | Name | Description
Public Constructor | PDFSeparationInfo Constructor | Initializes a new PDFSeparationInfo object.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the base colorspace for this separation object.
Public Property | DeviceColorant | Gets the name of the device colorant used in rendering this separation.
Public Property | Pages | Gets or sets the list of pages included in the same separation group.
Top
See Also

Reference

PDFSeparationInfo Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFSeparationInfo Constructor

O2S.Components.PDF4NET Namespace > PDFSeparationInfo Class : PDFSeparationInfo Constructor
Initializes a new PDFSeparationInfo object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSeparationInfo()
public PDFSeparationInfo()
public: PDFSeparationInfo();
public:
PDFSeparationInfo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


%%PageItemTitle%% $$Properties$$

PDFSeparationInfo Class Properties

O2S.Components.PDF4NET Namespace : PDFSeparationInfo Class

For a list of all members of this type, see PDFSeparationInfo members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the base colorspace for this separation object.
Public Property | DeviceColorant | Gets the name of the device colorant used in rendering this separation.
Public Property | Pages | Gets or sets the list of pages included in the same separation group.
Top
See Also

Reference

PDFSeparationInfo Class
O2S.Components.PDF4NET Namespace


ColorSpace Property (PDFSeparationInfo)

O2S.Components.PDF4NET Namespace > PDFSeparationInfo Class : ColorSpace Property
Gets or sets the base colorspace for this separation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorSpace As PDFColorSpace
'Usage

Dim instance As PDFSeparationInfo
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public PDFColorSpace ColorSpace {get; set;}
public: __property PDFColorSpace* get_ColorSpace();
public: __property void set_ColorSpace(
   PDFColorSpace* value
);
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace object specifying the colorspace used by this separation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


DeviceColorant Property

O2S.Components.PDF4NET Namespace > PDFSeparationInfo Class : DeviceColorant Property
Gets the name of the device colorant used in rendering this separation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeviceColorant As String
'Usage

Dim instance As PDFSeparationInfo
Dim value As String

instance.DeviceColorant = value

value = instance.DeviceColorant
public string DeviceColorant {get; set;}
public: __property string* get_DeviceColorant();
public: __property void set_DeviceColorant(
   string* value
);
public:
property String^ DeviceColorant {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the name of the device colorant used in rendering this separation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


Pages Property (PDFSeparationInfo)

O2S.Components.PDF4NET Namespace > PDFSeparationInfo Class : Pages Property
Gets or sets the list of pages included in the same separation group.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Pages As Integer()
'Usage

Dim instance As PDFSeparationInfo
Dim value() As Integer

instance.Pages = value

value = instance.Pages
public int[] Pages {get; set;}
public: __property int[]* get_Pages();
public: __property void set_Pages(
   int[]* value
);
public:
property array<int>^ Pages {
   array<int>^ get();
   void set (    array<int>^ value);
}

Property Value

An array of integer values representing the numbers of the pages included in the separation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


%%PageItemTitle%%

PDFVersionExtension Class
Members

O2S.Components.PDF4NET Namespace : PDFVersionExtension Class
Defines an extension to an existing PDF version.
Object Model
PDFVersionExtension Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFVersionExtension
'Usage

Dim instance As PDFVersionExtension
public class PDFVersionExtension
public __gc class PDFVersionExtension
public ref class PDFVersionExtension
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFVersionExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFVersionExtension Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFVersionExtension Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFVersionExtension Class

The following tables list the members exposed by PDFVersionExtension.

Public Constructors
 | Name | Description
Public Constructor | PDFVersionExtension Constructor | Initializes a new PDFVersionExtension object.
Top
Public Properties
 | Name | Description
Public Property | Level | Gets or sets the extension level.
Public Property | PDFVersion | Gets or sets the PDF version that is being extended.
Top
See Also

Reference

PDFVersionExtension Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFVersionExtension Constructor

O2S.Components.PDF4NET Namespace > PDFVersionExtension Class : PDFVersionExtension Constructor
Initializes a new PDFVersionExtension object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFVersionExtension()
public PDFVersionExtension()
public: PDFVersionExtension();
public:
PDFVersionExtension();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFVersionExtension Class
PDFVersionExtension Members


%%PageItemTitle%% $$Properties$$

PDFVersionExtension Class Properties

O2S.Components.PDF4NET Namespace : PDFVersionExtension Class

For a list of all members of this type, see PDFVersionExtension members.

Public Properties
 | Name | Description
Public Property | Level | Gets or sets the extension level.
Public Property | PDFVersion | Gets or sets the PDF version that is being extended.
Top
See Also

Reference

PDFVersionExtension Class
O2S.Components.PDF4NET Namespace


Level Property

O2S.Components.PDF4NET Namespace > PDFVersionExtension Class : Level Property
Gets or sets the extension level.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Level As Integer
'Usage

Dim instance As PDFVersionExtension
Dim value As Integer

instance.Level = value

value = instance.Level
public int Level {get; set;}
public: __property int get_Level();
public: __property void set_Level(
   int value
);
public:
property int Level {
   int get();
   void set (    int value);
}

Property Value

The extension level over an existing PDF specification.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFVersionExtension Class
PDFVersionExtension Members


PDFVersion Property (PDFVersionExtension)

O2S.Components.PDF4NET Namespace > PDFVersionExtension Class : PDFVersion Property
Gets or sets the PDF version that is being extended.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PDFVersion As PDFVersion
'Usage

Dim instance As PDFVersionExtension
Dim value As PDFVersion

instance.PDFVersion = value

value = instance.PDFVersion
public PDFVersion PDFVersion {get; set;}
public: __property PDFVersion get_PDFVersion();
public: __property void set_PDFVersion(
   PDFVersion value
);
public:
property PDFVersion PDFVersion {
   PDFVersion get();
   void set (    PDFVersion value);
}

Property Value

A PDFVersion enumeration member specifying the PDF version being extended.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFVersionExtension Class
PDFVersionExtension Members


%%PageItemTitle%%

PDFViewerPreferences Class
Members

O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class
Defines the way the PDF document is displayed on the screen.
Object Model
PDFViewerPreferences ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFViewerPreferences
'Usage

Dim instance As PDFViewerPreferences
public class PDFViewerPreferences
public __gc class PDFViewerPreferences
public ref class PDFViewerPreferences
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFViewerPreferences

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFViewerPreferences Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class

The following tables list the members exposed by PDFViewerPreferences.

Public Constructors
 | Name | Description
Public Constructor | PDFViewerPreferences Constructor | Initializes a new PDFViewerPreferences object.
Top
Public Properties
 | Name | Description
Public Property | CenterWindow | Gets or sets a value indicating whether the document's window should be centered on the screen.
Public Property | Dictionary | Gets the viewer preferences dictionary dictionary.
Public Property | DisplayDocTitle | Gets or sets a value indicating whether the window's title bar should display the document's title loaded from document information metadata.
Public Property | FitWindow | Gets or sets a value indicating whether the document's window should be resized to match the size of the first displayed page.
Public Property | HideMenubar | Gets or sets a value indicating whether the viewer's menubar should be hidden when the document is active.
Public Property | HideToolbar | Gets or sets a value indicating whether the viewer's toolbar should be hidden when the document is active.
Public Property | HideWindowUI | Gets or sets a value indicating whether the viewer's UI should be hidden when the document is active.
Public Property | NonFullScreenPageMode | Gets or sets the document's page mode specifying how to display the document on exiting the full-screen mode.
Public Property | PrintScaling | Gets or sets how the print scaling for this document.
Top
See Also

Reference

PDFViewerPreferences Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFViewerPreferences Constructor

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : PDFViewerPreferences Constructor
Initializes a new PDFViewerPreferences object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFViewerPreferences()
public PDFViewerPreferences()
public: PDFViewerPreferences();
public:
PDFViewerPreferences();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%% $$Properties$$

PDFViewerPreferences Class Properties

O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class

For a list of all members of this type, see PDFViewerPreferences members.

Public Properties
 | Name | Description
Public Property | CenterWindow | Gets or sets a value indicating whether the document's window should be centered on the screen.
Public Property | Dictionary | Gets the viewer preferences dictionary dictionary.
Public Property | DisplayDocTitle | Gets or sets a value indicating whether the window's title bar should display the document's title loaded from document information metadata.
Public Property | FitWindow | Gets or sets a value indicating whether the document's window should be resized to match the size of the first displayed page.
Public Property | HideMenubar | Gets or sets a value indicating whether the viewer's menubar should be hidden when the document is active.
Public Property | HideToolbar | Gets or sets a value indicating whether the viewer's toolbar should be hidden when the document is active.
Public Property | HideWindowUI | Gets or sets a value indicating whether the viewer's UI should be hidden when the document is active.
Public Property | NonFullScreenPageMode | Gets or sets the document's page mode specifying how to display the document on exiting the full-screen mode.
Public Property | PrintScaling | Gets or sets how the print scaling for this document.
Top
See Also

Reference

PDFViewerPreferences Class
O2S.Components.PDF4NET Namespace


CenterWindow Property

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : CenterWindow Property
Gets or sets a value indicating whether the document's window should be centered on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterWindow As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.CenterWindow = value

value = instance.CenterWindow
public bool CenterWindow {get; set;}
public: __property bool get_CenterWindow();
public: __property void set_CenterWindow(
   bool value
);
public:
property bool CenterWindow {
   bool get();
   void set (    bool value);
}

Property Value

True if the document's window should be centered on the screen. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


Dictionary Property (PDFViewerPreferences)

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : Dictionary Property
Gets the viewer preferences dictionary dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFViewerPreferences
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw viewer preferences dictionary.
Remarks
This property gives you direct access to viewer preferences dictionary and its associated resources. Note: Modifying directly the viewer preferences dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


DisplayDocTitle Property

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : DisplayDocTitle Property
Gets or sets a value indicating whether the window's title bar should display the document's title loaded from document information metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayDocTitle As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.DisplayDocTitle = value

value = instance.DisplayDocTitle
public bool DisplayDocTitle {get; set;}
public: __property bool get_DisplayDocTitle();
public: __property void set_DisplayDocTitle(
   bool value
);
public:
property bool DisplayDocTitle {
   bool get();
   void set (    bool value);
}

Property Value

True if the window's title bar should display the document's title. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


FitWindow Property

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : FitWindow Property
Gets or sets a value indicating whether the document's window should be resized to match the size of the first displayed page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FitWindow As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.FitWindow = value

value = instance.FitWindow
public bool FitWindow {get; set;}
public: __property bool get_FitWindow();
public: __property void set_FitWindow(
   bool value
);
public:
property bool FitWindow {
   bool get();
   void set (    bool value);
}

Property Value

True if the document's window should be resized. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


HideMenubar Property

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : HideMenubar Property
Gets or sets a value indicating whether the viewer's menubar should be hidden when the document is active.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HideMenubar As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideMenubar = value

value = instance.HideMenubar
public bool HideMenubar {get; set;}
public: __property bool get_HideMenubar();
public: __property void set_HideMenubar(
   bool value
);
public:
property bool HideMenubar {
   bool get();
   void set (    bool value);
}

Property Value

True if the menubar should be hidden. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


HideToolbar Property

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : HideToolbar Property
Gets or sets a value indicating whether the viewer's toolbar should be hidden when the document is active.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HideToolbar As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideToolbar = value

value = instance.HideToolbar
public bool HideToolbar {get; set;}
public: __property bool get_HideToolbar();
public: __property void set_HideToolbar(
   bool value
);
public:
property bool HideToolbar {
   bool get();
   void set (    bool value);
}

Property Value

True if the toolbar should be hidden. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


HideWindowUI Property

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : HideWindowUI Property
Gets or sets a value indicating whether the viewer's UI should be hidden when the document is active.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HideWindowUI As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideWindowUI = value

value = instance.HideWindowUI
public bool HideWindowUI {get; set;}
public: __property bool get_HideWindowUI();
public: __property void set_HideWindowUI(
   bool value
);
public:
property bool HideWindowUI {
   bool get();
   void set (    bool value);
}

Property Value

True if the UI should be hidden. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


NonFullScreenPageMode Property

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : NonFullScreenPageMode Property
Gets or sets the document's page mode specifying how to display the document on exiting the full-screen mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NonFullScreenPageMode As PDFDisplayMode
'Usage

Dim instance As PDFViewerPreferences
Dim value As PDFDisplayMode

instance.NonFullScreenPageMode = value

value = instance.NonFullScreenPageMode
public PDFDisplayMode NonFullScreenPageMode {get; set;}
public: __property PDFDisplayMode get_NonFullScreenPageMode();
public: __property void set_NonFullScreenPageMode(
   PDFDisplayMode value
);
public:
property PDFDisplayMode NonFullScreenPageMode {
   PDFDisplayMode get();
   void set (    PDFDisplayMode value);
}

Property Value

The document's page mode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown if the value to be set is not one of the supported values.
Remarks
Only the following page modes are supported: PDFDisplayMode.UseNone, PDFDisplayMode.UseOutlines, PDFDisplayMode.UseThumbs and PDFDisplayMode.UseOC.
This property is meaningful only if the PDFDocument.DisplayMode property is PDFDisplayMode.FullScreen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


PrintScaling Property

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : PrintScaling Property
Gets or sets how the print scaling for this document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PrintScaling As PDFPrintScaling
'Usage

Dim instance As PDFViewerPreferences
Dim value As PDFPrintScaling

instance.PrintScaling = value

value = instance.PrintScaling
public PDFPrintScaling PrintScaling {get; set;}
public: __property PDFPrintScaling get_PrintScaling();
public: __property void set_PrintScaling(
   PDFPrintScaling value
);
public:
property PDFPrintScaling PrintScaling {
   PDFPrintScaling get();
   void set (    PDFPrintScaling value);
}

Property Value

The page scaling option to be selected when a print dialog is displayed for this document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

PDFXMPMetadata Class
Members

O2S.Components.PDF4NET Namespace : PDFXMPMetadata Class
Defines the XMP metadata for a PDF document.
Object Model
PDFXMPMetadata ClassPDFMetadataSchemaCollection ClassPDFMetadataSchema Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFXMPMetadata
'Usage

Dim instance As PDFXMPMetadata
public class PDFXMPMetadata
public __gc class PDFXMPMetadata
public ref class PDFXMPMetadata
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFXMPMetadata

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFXMPMetadata Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

PDFXMPMetadata Class Members
Properties

O2S.Components.PDF4NET Namespace : PDFXMPMetadata Class

The following tables list the members exposed by PDFXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | PDFXMPMetadata Constructor | Initializes a new PDFXMPMetadata object.
Top
Public Properties
 | Name | Description
Public Property | MetadataSchemas | Gets the metadata schema collection.
Public Property | XMPMetadata | Gets the raw XMP metadata as an XML string.
Top
See Also

Reference

PDFXMPMetadata Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFXMPMetadata Constructor

O2S.Components.PDF4NET Namespace > PDFXMPMetadata Class : PDFXMPMetadata Constructor
Initializes a new PDFXMPMetadata object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFXMPMetadata()
public PDFXMPMetadata()
public: PDFXMPMetadata();
public:
PDFXMPMetadata();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


%%PageItemTitle%% $$Properties$$

PDFXMPMetadata Class Properties

O2S.Components.PDF4NET Namespace : PDFXMPMetadata Class

For a list of all members of this type, see PDFXMPMetadata members.

Public Properties
 | Name | Description
Public Property | MetadataSchemas | Gets the metadata schema collection.
Public Property | XMPMetadata | Gets the raw XMP metadata as an XML string.
Top
See Also

Reference

PDFXMPMetadata Class
O2S.Components.PDF4NET Namespace


MetadataSchemas Property

O2S.Components.PDF4NET Namespace > PDFXMPMetadata Class : MetadataSchemas Property
Gets the metadata schema collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MetadataSchemas As PDFMetadataSchemaCollection
'Usage

Dim instance As PDFXMPMetadata
Dim value As PDFMetadataSchemaCollection

value = instance.MetadataSchemas
public PDFMetadataSchemaCollection MetadataSchemas {get;}
public: __property PDFMetadataSchemaCollection* get_MetadataSchemas();
public:
property PDFMetadataSchemaCollection^ MetadataSchemas {
   PDFMetadataSchemaCollection^ get();
}

Property Value

A collection of metadata schema objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


XMPMetadata Property

O2S.Components.PDF4NET Namespace > PDFXMPMetadata Class : XMPMetadata Property
Gets the raw XMP metadata as an XML string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XMPMetadata As String
'Usage

Dim instance As PDFXMPMetadata
Dim value As String

instance.XMPMetadata = value

value = instance.XMPMetadata
public string XMPMetadata {get; set;}
public: __property string* get_XMPMetadata();
public: __property void set_XMPMetadata(
   string* value
);
public:
property String^ XMPMetadata {
   String^ get();
   void set (    String^ value);
}

Property Value

The raw XMP metadata stored in the PDF file.
Remarks
If the PDFDocument object has been created from a source PDF file, this property returns the XMP metadata included in the file, otherwise it returns an empty string.
If this property is set from user code, the new value is appended as it is to the XMP metadata generated by PDF4NET.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


%%PageItemTitle%%

XDPPackage Class
Members

O2S.Components.PDF4NET Namespace : XDPPackage Class
Defines a XDP package.
Object Model
XDPPackage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XDPPackage
'Usage

Dim instance As XDPPackage
public class XDPPackage
public __gc class XDPPackage
public ref class XDPPackage
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.XDPPackage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XDPPackage Members
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Members$$

XDPPackage Class Members
Methods

O2S.Components.PDF4NET Namespace : XDPPackage Class

The following tables list the members exposed by XDPPackage.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | LoadDocument | Overloaded. Loads the PDF document that is embedded in the XDP package.
static (Shared in Visual Basic) | SaveDocument | Overloaded. Saves the PDF document as a XDP package.
Top
See Also

Reference

XDPPackage Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

XDPPackage Class Methods

O2S.Components.PDF4NET Namespace : XDPPackage Class

For a list of all members of this type, see XDPPackage members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | LoadDocument | Overloaded. Loads the PDF document that is embedded in the XDP package.
static (Shared in Visual Basic) | SaveDocument | Overloaded. Saves the PDF document as a XDP package.
Top
See Also

Reference

XDPPackage Class
O2S.Components.PDF4NET Namespace


LoadDocument Method

O2S.Components.PDF4NET Namespace > XDPPackage Class : LoadDocument Method
Loads the PDF document that is embedded in the XDP package.
Overload List
Overload | Description
LoadDocument(String) | Loads the PDF document that is embedded in the XDP package.
LoadDocument(Stream) | Loads the PDF document that is embedded in the XDP package.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XDPPackage Class
XDPPackage Members


LoadDocument(String) Method

O2S.Components.PDF4NET Namespace > XDPPackage Class > LoadDocument Method : LoadDocument(String) Method
File containing the XDP package.
Loads the PDF document that is embedded in the XDP package.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadDocument( _
   ByVal fileName As String _
) As PDFDocument
'Usage

Dim fileName As String
Dim value As PDFDocument

value = XDPPackage.LoadDocument(fileName)
public static PDFDocument LoadDocument(
   string fileName
)
public: static PDFDocument* LoadDocument(
   string* fileName
)
public:
static PDFDocument^ LoadDocument(
   String^ fileName
)

Parameters

fileName
File containing the XDP package.

Return Value

The PDFDocument object if the XDP package contains a PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XDPPackage Class
XDPPackage Members
Overload List


LoadDocument(Stream) Method

O2S.Components.PDF4NET Namespace > XDPPackage Class > LoadDocument Method : LoadDocument(Stream) Method
Stream containing the XDP package.
Loads the PDF document that is embedded in the XDP package.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function LoadDocument( _
   ByVal stream As Stream _
) As PDFDocument
'Usage

Dim stream As Stream
Dim value As PDFDocument

value = XDPPackage.LoadDocument(stream)
public static PDFDocument LoadDocument(
   Stream stream
)
public: static PDFDocument* LoadDocument(
   Stream* stream
)
public:
static PDFDocument^ LoadDocument(
   Stream^ stream
)

Parameters

stream
Stream containing the XDP package.

Return Value

The PDFDocument object if the XDP package contains a PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XDPPackage Class
XDPPackage Members
Overload List


SaveDocument Method

O2S.Components.PDF4NET Namespace > XDPPackage Class : SaveDocument Method
Saves the PDF document as a XDP package.
Overload List
Overload | Description
SaveDocument(String,PDFDocument) | Saves the PDF document as a XDP package.
SaveDocument(Stream,PDFDocument) | Saves the PDF document as a XDP package.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XDPPackage Class
XDPPackage Members


SaveDocument(String,PDFDocument) Method

O2S.Components.PDF4NET Namespace > XDPPackage Class > SaveDocument Method : SaveDocument(String,PDFDocument) Method
Document to be saved.
Saves the PDF document as a XDP package.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SaveDocument( _
   ByVal fileName As String, _
   ByVal document As PDFDocument _
)
'Usage

Dim fileName As String
Dim document As PDFDocument

XDPPackage.SaveDocument(fileName, document)
public static void SaveDocument(
   string fileName,
   PDFDocument document
)
public: static void SaveDocument(
   string* fileName,
   PDFDocument* document
)
public:
static void SaveDocument(
   String^ fileName,
   PDFDocument^ document
)

Parameters

fileName
document
Document to be saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XDPPackage Class
XDPPackage Members
Overload List


SaveDocument(Stream,PDFDocument) Method

O2S.Components.PDF4NET Namespace > XDPPackage Class > SaveDocument Method : SaveDocument(Stream,PDFDocument) Method
Stream containing the XDP package.
Document to be saved.
Saves the PDF document as a XDP package.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub SaveDocument( _
   ByVal stream As Stream, _
   ByVal document As PDFDocument _
)
'Usage

Dim stream As Stream
Dim document As PDFDocument

XDPPackage.SaveDocument(stream, document)
public static void SaveDocument(
   Stream stream,
   PDFDocument document
)
public: static void SaveDocument(
   Stream* stream,
   PDFDocument* document
)
public:
static void SaveDocument(
   Stream^ stream,
   PDFDocument^ document
)

Parameters

stream
Stream containing the XDP package.
document
Document to be saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XDPPackage Class
XDPPackage Members
Overload List


%%PageItemTitle%%

PDFBookmarkDisplayStyle Enumeration

O2S.Components.PDF4NET Namespace : PDFBookmarkDisplayStyle Enumeration
Specifies the available modes for displaying a bookmark in a viewer application.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PDFBookmarkDisplayStyle
   Inherits System.Enum
'Usage

Dim instance As PDFBookmarkDisplayStyle
[Flags()]
public enum PDFBookmarkDisplayStyle : System.Enum
[Flags()]
__value public enum PDFBookmarkDisplayStyle : public System.Enum
[Flags()]
public enum class PDFBookmarkDisplayStyle : public System.Enum
Members
Member | Description
Bold | The bookmark is displayed using bold font.
Italic | The bookmark is displayed using italic font.
Regular | The bookmark is displayed using regular font.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFBookmarkDisplayStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDisplayMode Enumeration

O2S.Components.PDF4NET Namespace : PDFDisplayMode Enumeration
Specifies the possible modes to be display the document when it is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFDisplayMode
   Inherits System.Enum
'Usage

Dim instance As PDFDisplayMode
public enum PDFDisplayMode : System.Enum
__value public enum PDFDisplayMode : public System.Enum
public enum class PDFDisplayMode : public System.Enum
Members
Member | Description
FullScreen | Full screen mode, with no menu bar, window controls, or any other window visible.
UseAttachments | Attachments panel visible.
UseNone | Neither document outline nor thumbnail images visible.
UseOC | Optional content panel visible.
UseOutlines | Document outline visible.
UseThumbs | Thumbnail images visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocumentAttachmentRelationship Enumeration

O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentRelationship Enumeration
Relationships between a file attachment and its owner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFDocumentAttachmentRelationship
   Inherits System.Enum
'Usage

Dim instance As PDFDocumentAttachmentRelationship
public enum PDFDocumentAttachmentRelationship : System.Enum
__value public enum PDFDocumentAttachmentRelationship : public System.Enum
public enum class PDFDocumentAttachmentRelationship : public System.Enum
Members
Member | Description
Alternative | The file attachment is an alternative representation of content.
Data | The file attachment represents information used to derive a visual presentation.
Source | The file attachment is the original source material for the associated content.
Supplement | The file attachment represents a supplemental representation of the original source or data that may be more easily consumable.
Unspecified | Relationship is unknown.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFDocumentAttachmentRelationship

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocumentSaveFormat Enumeration

O2S.Components.PDF4NET Namespace : PDFDocumentSaveFormat Enumeration
Specifies the available save formats for a PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFDocumentSaveFormat
   Inherits System.Enum
'Usage

Dim instance As PDFDocumentSaveFormat
public enum PDFDocumentSaveFormat : System.Enum
__value public enum PDFDocumentSaveFormat : public System.Enum
public enum class PDFDocumentSaveFormat : public System.Enum
Members
Member | Description
PDFA1b | File is saved in PDF/A-1B format, format restrictions apply according to standard.
PDFA2b | File is saved in PDF/A-2B format, format restrictions apply according to standard.
PDFA2u | File is saved in PDF/A-2U format, format restrictions apply according to standard.
PDFA3b | File is saved in PDF/A-3B format, format restrictions apply according to standard.
PDFA3u | File is saved in PDF/A-3U format, format restrictions apply according to standard.
Regular | Regular PDF file, no format restrictions apply.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFDocumentSaveFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFMagnificationMode Enumeration

O2S.Components.PDF4NET Namespace : PDFMagnificationMode Enumeration
Specifies the available zoom modes that can be applied when the PDF page specified in the destination is displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFMagnificationMode
   Inherits System.Enum
'Usage

Dim instance As PDFMagnificationMode
public enum PDFMagnificationMode : System.Enum
__value public enum PDFMagnificationMode : public System.Enum
public enum class PDFMagnificationMode : public System.Enum
Members
Member | Description
Fit | Display the destination page, with its contents magnified just enough to fit the entire page within the window both horizontally and vertically.
FitB | Display the destination page, with its contents magnified just enough to fit its bounding box entirely within the window both horizontally and vertically.
FitBH | Display the destination page at the specified top position and the contents of the page magnified just enough to fit the entire width of its bounding box within the window.
FitBV | Display the destination page at the specified left position and the contents of the page magnified just enough to fit the entire height of its bounding box within the window.
FitH | Display the destination page at the specified top position and the contents of the page magnified just enough to fit the entire width of the page within the window.
FitR | Display the destination page, with its contents magnified just enough to fit the rectangle specified by the coordinates left, bottom, right, and top entirely within the window both horizontally and vertically.
FitV | Display the destination page at the specified left position and the contents of the page magnified just enough to fit the entire height of the page within the window.
XYZ | Display the destination page at the specified position and zoom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFMagnificationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFNumberingStyle Enumeration

O2S.Components.PDF4NET Namespace : PDFNumberingStyle Enumeration
Specifies the available styles when setting up a page numbering range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFNumberingStyle
   Inherits System.Enum
'Usage

Dim instance As PDFNumberingStyle
public enum PDFNumberingStyle : System.Enum
__value public enum PDFNumberingStyle : public System.Enum
public enum class PDFNumberingStyle : public System.Enum
Members
Member | Description
Arabic | The numbering style uses arabic numerals
LowerCaseLetter | Lower case letters are used for page numbers.
LowerCaseRoman | The numbering style uses lowercase roman numerals
None | No numbering Style.
UpperCaseLetter | Upper case letters are used for page numbers.
UpperCaseRoman | The numbering style uses uppercase roman numerals
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFNumberingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFOutputIntentType Enumeration

O2S.Components.PDF4NET Namespace : PDFOutputIntentType Enumeration
Specifies the available output intent types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFOutputIntentType
   Inherits System.Enum
'Usage

Dim instance As PDFOutputIntentType
public enum PDFOutputIntentType : System.Enum
__value public enum PDFOutputIntentType : public System.Enum
public enum class PDFOutputIntentType : public System.Enum
Members
Member | Description
PDFA1 | PDF/A-1 output intent.
PDFX | PDF/X output intent.
Unknown | Unknown output intent.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFOutputIntentType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageLayout Enumeration

O2S.Components.PDF4NET Namespace : PDFPageLayout Enumeration
Specifies the possible page layouts to be used when the document is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageLayout
   Inherits System.Enum
'Usage

Dim instance As PDFPageLayout
public enum PDFPageLayout : System.Enum
__value public enum PDFPageLayout : public System.Enum
public enum class PDFPageLayout : public System.Enum
Members
Member | Description
OneColumn | Display the pages in one column.
SinglePage | Display one page at a time.
TwoColumnLeft | Display the pages in two columns, with odd-numbered pages on the left.
TwoColumnRight | Display the pages in two columns, with odd-numbered pages on the right.
TwoPageLeft | Display the pages two at a time, with odd-numbered pages on the left.
TwoPageRight | Display the pages two at a time, with odd-numbered pages on the right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFPageLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageOrientation Enumeration

O2S.Components.PDF4NET Namespace : PDFPageOrientation Enumeration
Specifies the possible orientations for a page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageOrientation
   Inherits System.Enum
'Usage

Dim instance As PDFPageOrientation
public enum PDFPageOrientation : System.Enum
__value public enum PDFPageOrientation : public System.Enum
public enum class PDFPageOrientation : public System.Enum
Members
Member | Description
Landscape | Landscape orientation.
Portrait | Portrait orientation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFPageOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageSize Enumeration

O2S.Components.PDF4NET Namespace : PDFPageSize Enumeration
Specifies the predefined page sizes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageSize
   Inherits System.Enum
'Usage

Dim instance As PDFPageSize
public enum PDFPageSize : System.Enum
__value public enum PDFPageSize : public System.Enum
public enum class PDFPageSize : public System.Enum
Members
Member | Description
A0 | A0 page size (2380 points x 3368 points).
A1 | A1 page size (1684 points x 2380 points).
A2 | A2 page size (1190 points x 1684 points).
A3 | A3 page size (842 points x 1190 points).
A4 | A4 page size (595 points x 842 points).
A5 | A5 page size (420 points x 595 points).
B4 | B4 page size (729 points x 1032 points).
B5 | B4 page size (516 points x 729 points).
Executive | Executive page size (540 points x 720 points).
Folio | Folio page size (612 points x 936 points).
Ledger | Ledger page size (1224 points x 792 points).
Legal | Legal page size (612 points x 1008 points).
Letter | Letter page size (612 points x 792 points).
Quarto | Quarto page size (610 points x 780 points).
Size10x14 | 10x14 page size (720 points x 1008 points).
Statement | Statement page size (396 points x 612 points).
Tabloid | Tabloid page size (792 points x 1024 points).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFPageSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPrintScaling Enumeration

O2S.Components.PDF4NET Namespace : PDFPrintScaling Enumeration
Specifies the available print scaling options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPrintScaling
   Inherits System.Enum
'Usage

Dim instance As PDFPrintScaling
public enum PDFPrintScaling : System.Enum
__value public enum PDFPrintScaling : public System.Enum
public enum class PDFPrintScaling : public System.Enum
Members
Member | Description
AppDefault | Application default page scaling.
None | No print scaling.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFPrintScaling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFRotationMode Enumeration

O2S.Components.PDF4NET Namespace : PDFRotationMode Enumeration
Specifies the available rotation modes for a PDF object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFRotationMode
   Inherits System.Enum
'Usage

Dim instance As PDFRotationMode
public enum PDFRotationMode : System.Enum
__value public enum PDFRotationMode : public System.Enum
public enum class PDFRotationMode : public System.Enum
Members
Member | Description
Rotate0Degrees | 0 degrees rotation.
Rotate180Degrees | 180 degrees rotation.
Rotate270Degrees | 270 degrees rotation.
Rotate90Degrees | 90 degrees rotation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFRotationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFVersion Enumeration

O2S.Components.PDF4NET Namespace : PDFVersion Enumeration
Specifies the available PDF versions to save a PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFVersion
   Inherits System.Enum
'Usage

Dim instance As PDFVersion
public enum PDFVersion : System.Enum
__value public enum PDFVersion : public System.Enum
public enum class PDFVersion : public System.Enum
Members
Member | Description
Unknown | Unknown document version.
Version10 | PDF 1.0 - Adobe Acrobat 1
Version11 | PDF 1.1 - Adobe Acrobat 2
Version12 | PDF 1.2 - Adobe Acrobat 3
Version13 | PDF 1.3 - Adobe Acrobat 4
Version14 | PDF 1.4 - Adobe Acrobat 5
Version15 | PDF 1.5 - Adobe Acrobat 6
Version16 | PDF 1.6 - Adobe Acrobat 7
Version17 | PDF 1.7 - Adobe Acrobat 8
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFVersion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET Namespace


O2S.Components.PDF4NET.Actions Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFAction | This is the base class for all PDF actions
Class | PDFActionCollection | Defines a collection of PDF actions.
Class | PDFGoToAction | This class represents a PDF Go-To action.
Class | PDFHideAction | Defines a PDF hide action.
Class | PDFJavaScriptAction | This class represents a PDF Javascript action.
Class | PDFLaunchAction | This class represents a PDF Launch action.
Class | PDFNamedAction | This class represents a PDF Named action.
Class | PDFRemoteGoToAction | This class represents a PDF Remote Go-To action.
Class | PDFResetFormAction | Defines a SubmitForm action.
Class | PDFSubmitFormAction | Defines a SubmitForm action.
Class | PDFURIAction | This class represents a PDF URI action.
Enumerations
 | Enumeration | Description
Enumeration | NamedAction | Specifies the available named actions supported by the viewer.
Enumeration | SubmitDataFormat | Specifies the available data formats for submitting the form data.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFAction Class
This is the base class for all PDF actions
Object Model
PDFAction ClassPDFActionCollection ClassPDFAction ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFAction
'Usage

Dim instance As PDFAction
public abstract class PDFAction
public __gc abstract class PDFAction
public ref class PDFAction abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFGoToAction
O2S.Components.PDF4NET.Actions.PDFHideAction
O2S.Components.PDF4NET.Actions.PDFJavaScriptAction
O2S.Components.PDF4NET.Actions.PDFLaunchAction
O2S.Components.PDF4NET.Actions.PDFNamedAction
O2S.Components.PDF4NET.Actions.PDFRemoteGoToAction
O2S.Components.PDF4NET.Actions.PDFResetFormAction
O2S.Components.PDF4NET.Actions.PDFSubmitFormAction
O2S.Components.PDF4NET.Actions.PDFURIAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFAction Class

The following tables list the members exposed by PDFAction.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one.
Public Property | Dictionary | Gets the action dictionary.
Top
See Also

Reference

PDFAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Properties$$

PDFAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFAction Class

For a list of all members of this type, see PDFAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one.
Public Property | Dictionary | Gets the action dictionary.
Top
See Also

Reference

PDFAction Class
O2S.Components.PDF4NET.Actions Namespace


Actions Property

O2S.Components.PDF4NET.Actions Namespace > PDFAction Class : Actions Property
Gets the list of actions to be performed after this one.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Actions As PDFActionCollection
'Usage

Dim instance As PDFAction
Dim value As PDFActionCollection

value = instance.Actions
public PDFActionCollection Actions {get;}
public: __property PDFActionCollection* get_Actions();
public:
property PDFActionCollection^ Actions {
   PDFActionCollection^ get();
}

Property Value

An PDFActionCollection object storing the actions to be performed after current action (this one) has been executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAction Class
PDFAction Members


Dictionary Property (PDFAction)

O2S.Components.PDF4NET.Actions Namespace > PDFAction Class : Dictionary Property
Gets the action dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFAction
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw action dictionary.
Remarks
This property gives you direct access to action dictionary and its associated resources. Note: Modifying directly the action dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAction Class
PDFAction Members


%%PageItemTitle%%

PDFActionCollection Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFActionCollection Class
Defines a collection of PDF actions.
Object Model
PDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFActionCollection
   Inherits System.Collections.ObjectModel.Collection(Of PDFAction)
'Usage

Dim instance As PDFActionCollection
public class PDFActionCollection : System.Collections.ObjectModel.Collection<PDFAction>
public __gc class PDFActionCollection : public System.Collections.ObjectModel.Collection<PDFAction>
public ref class PDFActionCollection : public System.Collections.ObjectModel.Collection<PDFAction>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Actions.PDFActionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFActionCollection Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFActionCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Actions Namespace : PDFActionCollection Class

The following tables list the members exposed by PDFActionCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top
See Also

Reference

PDFActionCollection Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFGoToAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFGoToAction Class
This class represents a PDF Go-To action.
Object Model
PDFGoToAction ClassPDFActionCollection ClassPDFAction ClassPDFPageDestination ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGoToAction
   Inherits PDFAction
'Usage

Dim instance As PDFGoToAction
public class PDFGoToAction : PDFAction
public __gc class PDFGoToAction : public PDFAction
public ref class PDFGoToAction : public PDFAction
Remarks
This type of action allows a user to navigate to a specific page in the current document. It allows to specify the page to open when this action is executed, the location in the page where the viewer should display the page and a magnification factor to be used when displaying the destination page.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFGoToAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGoToAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFGoToAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFGoToAction Class

The following tables list the members exposed by PDFGoToAction.

Public Constructors
 | Name | Description
Public Constructor | PDFGoToAction Constructor | Initializes a new PDFGoToAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Destination | Gets or sets the destination of the GoTo action.
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Top
See Also

Reference

PDFGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFGoToAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : PDFGoToAction Constructor
Initializes a new PDFGoToAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFGoToAction()
public PDFGoToAction()
public: PDFGoToAction();
public:
PDFGoToAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%% $$Properties$$

PDFGoToAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFGoToAction Class

For a list of all members of this type, see PDFGoToAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Destination | Gets or sets the destination of the GoTo action.
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Top
See Also

Reference

PDFGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


Destination Property (PDFGoToAction)

O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : Destination Property
Gets or sets the destination of the GoTo action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Destination As PDFPageDestination
'Usage

Dim instance As PDFGoToAction
Dim value As PDFPageDestination

instance.Destination = value

value = instance.Destination
public PDFPageDestination Destination {get; set;}
public: __property PDFPageDestination* get_Destination();
public: __property void set_Destination(
   PDFPageDestination* value
);
public:
property PDFPageDestination^ Destination {
   PDFPageDestination^ get();
   void set (    PDFPageDestination^ value);
}

Property Value

The location in the document that will be displayed as a result of executing this action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

PDFHideAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFHideAction Class
Defines a PDF hide action.
Object Model
PDFHideAction ClassPDFActionCollection ClassPDFAction ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFHideAction
   Inherits PDFAction
'Usage

Dim instance As PDFHideAction
public class PDFHideAction : PDFAction
public __gc class PDFHideAction : public PDFAction
public ref class PDFHideAction : public PDFAction
Remarks
This action allows a user to hide or show a form field.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFHideAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFHideAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFHideAction Class

The following tables list the members exposed by PDFHideAction.

Public Constructors
 | Name | Description
Public Constructor | PDFHideAction Constructor | Initializes a new PDFHideAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether the specified form field should be hidden or shown.
Top
See Also

Reference

PDFHideAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFHideAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : PDFHideAction Constructor
Initializes a new PDFHideAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFHideAction()
public PDFHideAction()
public: PDFHideAction();
public:
PDFHideAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%PageItemTitle%% $$Properties$$

PDFHideAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFHideAction Class

For a list of all members of this type, see PDFHideAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether the specified form field should be hidden or shown.
Top
See Also

Reference

PDFHideAction Class
O2S.Components.PDF4NET.Actions Namespace


FieldName Property

O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : FieldName Property
Gets or sets the name of the field that is affected by this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FieldName As String
'Usage

Dim instance As PDFHideAction
Dim value As String

instance.FieldName = value

value = instance.FieldName
public string FieldName {get; set;}
public: __property string* get_FieldName();
public: __property void set_FieldName(
   string* value
);
public:
property String^ FieldName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the name of the field that is affected by this action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Class
PDFHideAction Members


Hide Property

O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : Hide Property
Gets or sets a value indicating whether the specified form field should be hidden or shown.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Hide As Boolean
'Usage

Dim instance As PDFHideAction
Dim value As Boolean

instance.Hide = value

value = instance.Hide
public bool Hide {get; set;}
public: __property bool get_Hide();
public: __property void set_Hide(
   bool value
);
public:
property bool Hide {
   bool get();
   void set (    bool value);
}

Property Value

True if the form field should be hidden, false if the form field should be shown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%PageItemTitle%%

PDFJavaScriptAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFJavaScriptAction Class
This class represents a PDF Javascript action.
Object Model
PDFJavaScriptAction ClassPDFActionCollection ClassPDFAction ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFJavaScriptAction
   Inherits PDFAction
'Usage

Dim instance As PDFJavaScriptAction
public class PDFJavaScriptAction : PDFAction
public __gc class PDFJavaScriptAction : public PDFAction
public ref class PDFJavaScriptAction : public PDFAction
Remarks
This type of action allows a user to execute Javascript code within the viewer.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFJavaScriptAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFJavaScriptAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFJavaScriptAction Class

The following tables list the members exposed by PDFJavaScriptAction.

Public Constructors
 | Name | Description
Public Constructor | PDFJavaScriptAction Constructor | Initializes a new PDFJavaScriptAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Script | Gets or sets the javascript code to be executed when this action is executed.
Top
See Also

Reference

PDFJavaScriptAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFJavaScriptAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFJavaScriptAction Class : PDFJavaScriptAction Constructor
Initializes a new PDFJavaScriptAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFJavaScriptAction()
public PDFJavaScriptAction()
public: PDFJavaScriptAction();
public:
PDFJavaScriptAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


%%PageItemTitle%% $$Properties$$

PDFJavaScriptAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFJavaScriptAction Class

For a list of all members of this type, see PDFJavaScriptAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Script | Gets or sets the javascript code to be executed when this action is executed.
Top
See Also

Reference

PDFJavaScriptAction Class
O2S.Components.PDF4NET.Actions Namespace


Script Property (PDFJavaScriptAction)

O2S.Components.PDF4NET.Actions Namespace > PDFJavaScriptAction Class : Script Property
Gets or sets the javascript code to be executed when this action is executed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Script As String
'Usage

Dim instance As PDFJavaScriptAction
Dim value As String

instance.Script = value

value = instance.Script
public string Script {get; set;}
public: __property string* get_Script();
public: __property void set_Script(
   string* value
);
public:
property String^ Script {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing valid javascript code to be executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


%%PageItemTitle%%

PDFLaunchAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFLaunchAction Class
This class represents a PDF Launch action.
Object Model
PDFLaunchAction ClassPDFActionCollection ClassPDFAction ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLaunchAction
   Inherits PDFAction
'Usage

Dim instance As PDFLaunchAction
public class PDFLaunchAction : PDFAction
public __gc class PDFLaunchAction : public PDFAction
public ref class PDFLaunchAction : public PDFAction
Remarks
This type of action allows a user to launch an application or to open a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFLaunchAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFLaunchAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFLaunchAction Class

The following tables list the members exposed by PDFLaunchAction.

Public Constructors
 | Name | Description
Public Constructor | PDFLaunchAction Constructor | Initializes a new PDFLaunchAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | FileName | Gets or sets the name of the file to be launched by this action.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the launched application.
Top
See Also

Reference

PDFLaunchAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFLaunchAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : PDFLaunchAction Constructor
Initializes a new PDFLaunchAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLaunchAction()
public PDFLaunchAction()
public: PDFLaunchAction();
public:
PDFLaunchAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%% $$Properties$$

PDFLaunchAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFLaunchAction Class

For a list of all members of this type, see PDFLaunchAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | FileName | Gets or sets the name of the file to be launched by this action.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the launched application.
Top
See Also

Reference

PDFLaunchAction Class
O2S.Components.PDF4NET.Actions Namespace


FileName Property (PDFLaunchAction)

O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : FileName Property
Gets or sets the name of the file to be launched by this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PDFLaunchAction
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

An string value specifying the full path to the file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


NewWindow Property (PDFLaunchAction)

O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : NewWindow Property
Gets or sets whether the remote document opens in current window or in a new window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NewWindow As Boolean
'Usage

Dim instance As PDFLaunchAction
Dim value As Boolean

instance.NewWindow = value

value = instance.NewWindow
public bool NewWindow {get; set;}
public: __property bool get_NewWindow();
public: __property void set_NewWindow(
   bool value
);
public:
property bool NewWindow {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the remote document opens in current window or in a new window. If the remote document opens in the current window, the current pdf file is replaced with the remote document.
Remarks
If the file is not a pdf document, this property is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


Parameters Property (PDFLaunchAction)

O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : Parameters Property
Gets or sets a parameter string to be passed to the launched application.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Parameters As String
'Usage

Dim instance As PDFLaunchAction
Dim value As String

instance.Parameters = value

value = instance.Parameters
public string Parameters {get; set;}
public: __property string* get_Parameters();
public: __property void set_Parameters(
   string* value
);
public:
property String^ Parameters {
   String^ get();
   void set (    String^ value);
}

Property Value

An string value specifying the the list of parameters to be passed to the launched application
Remarks
This property matches the string of parameters as if they were passed to the application in the command line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%%

PDFNamedAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFNamedAction Class
This class represents a PDF Named action.
Object Model
PDFNamedAction ClassPDFActionCollection ClassPDFAction ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFNamedAction
   Inherits PDFAction
'Usage

Dim instance As PDFNamedAction
public class PDFNamedAction : PDFAction
public __gc class PDFNamedAction : public PDFAction
public ref class PDFNamedAction : public PDFAction
Remarks
This type of action allows a user to navigate to specific pages in the document or to print the document.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFNamedAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFNamedAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFNamedAction Class

The following tables list the members exposed by PDFNamedAction.

Public Constructors
 | Name | Description
Public Constructor | PDFNamedAction Constructor | Initializes a new PDFNamedAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | NamedAction | Gets or sets the named action to be executed when this action is executed.
Top
See Also

Reference

PDFNamedAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFNamedAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFNamedAction Class : PDFNamedAction Constructor
Initializes a new PDFNamedAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFNamedAction()
public PDFNamedAction()
public: PDFNamedAction();
public:
PDFNamedAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


%%PageItemTitle%% $$Properties$$

PDFNamedAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFNamedAction Class

For a list of all members of this type, see PDFNamedAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | NamedAction | Gets or sets the named action to be executed when this action is executed.
Top
See Also

Reference

PDFNamedAction Class
O2S.Components.PDF4NET.Actions Namespace


NamedAction Property

O2S.Components.PDF4NET.Actions Namespace > PDFNamedAction Class : NamedAction Property
Gets or sets the named action to be executed when this action is executed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NamedAction As NamedAction
'Usage

Dim instance As PDFNamedAction
Dim value As NamedAction

instance.NamedAction = value

value = instance.NamedAction
public NamedAction NamedAction {get; set;}
public: __property NamedAction get_NamedAction();
public: __property void set_NamedAction(
   NamedAction value
);
public:
property NamedAction NamedAction {
   NamedAction get();
   void set (    NamedAction value);
}

Property Value

An NamedAction enumeration member specifying the action to be executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


%%PageItemTitle%%

PDFRemoteGoToAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFRemoteGoToAction Class
This class represents a PDF Remote Go-To action.
Object Model
PDFRemoteGoToAction ClassPDFActionCollection ClassPDFAction ClassPDFRemotePageDestination ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRemoteGoToAction
   Inherits PDFAction
'Usage

Dim instance As PDFRemoteGoToAction
public class PDFRemoteGoToAction : PDFAction
public __gc class PDFRemoteGoToAction : public PDFAction
public ref class PDFRemoteGoToAction : public PDFAction
Remarks
This type of action allows a user to navigate to a specific page in an external pdf document. It allows to specify the page to open when this action is executed, the location in the page where the viewer should display the page and a magnification factor to be used when displaying the destination page.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFRemoteGoToAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFRemoteGoToAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFRemoteGoToAction Class

The following tables list the members exposed by PDFRemoteGoToAction.

Public Constructors
 | Name | Description
Public Constructor | PDFRemoteGoToAction Constructor | Initializes a new PDFRemoteGoToAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Destination | Gets or sets the destination of this action.
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | FileName | Gets or sets the target file name.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Top
See Also

Reference

PDFRemoteGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFRemoteGoToAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : PDFRemoteGoToAction Constructor
Initializes a new PDFRemoteGoToAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRemoteGoToAction()
public PDFRemoteGoToAction()
public: PDFRemoteGoToAction();
public:
PDFRemoteGoToAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%% $$Properties$$

PDFRemoteGoToAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFRemoteGoToAction Class

For a list of all members of this type, see PDFRemoteGoToAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Destination | Gets or sets the destination of this action.
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | FileName | Gets or sets the target file name.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Top
See Also

Reference

PDFRemoteGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


Destination Property (PDFRemoteGoToAction)

O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : Destination Property
Gets or sets the destination of this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Destination As PDFRemotePageDestination
'Usage

Dim instance As PDFRemoteGoToAction
Dim value As PDFRemotePageDestination

instance.Destination = value

value = instance.Destination
public PDFRemotePageDestination Destination {get; set;}
public: __property PDFRemotePageDestination* get_Destination();
public: __property void set_Destination(
   PDFRemotePageDestination* value
);
public:
property PDFRemotePageDestination^ Destination {
   PDFRemotePageDestination^ get();
   void set (    PDFRemotePageDestination^ value);
}

Property Value

The location in the remote document that will be displayed as a result of executing this action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


FileName Property (PDFRemoteGoToAction)

O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : FileName Property
Gets or sets the target file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PDFRemoteGoToAction
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the file that represents the target of this action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


NewWindow Property (PDFRemoteGoToAction)

O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : NewWindow Property
Gets or sets whether the remote document opens in current window or in a new window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NewWindow As Boolean
'Usage

Dim instance As PDFRemoteGoToAction
Dim value As Boolean

instance.NewWindow = value

value = instance.NewWindow
public bool NewWindow {get; set;}
public: __property bool get_NewWindow();
public: __property void set_NewWindow(
   bool value
);
public:
property bool NewWindow {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the remote document opens in current window or in a new window. If the remote document opens in the current window, the current pdf file is replaced with the remote document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

PDFResetFormAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFResetFormAction Class
Defines a SubmitForm action.
Object Model
PDFResetFormAction ClassPDFActionCollection ClassPDFAction ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFResetFormAction
   Inherits PDFAction
'Usage

Dim instance As PDFResetFormAction
public class PDFResetFormAction : PDFAction
public __gc class PDFResetFormAction : public PDFAction
public ref class PDFResetFormAction : public PDFAction
Remarks
This action allows a user to reset the form fields to their default values.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFResetFormAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFResetFormAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFResetFormAction Class

The following tables list the members exposed by PDFResetFormAction.

Public Constructors
 | Name | Description
Public Constructor | PDFResetFormAction Constructor | Initializes a new PDFResetFormAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | ResetFields | Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Top
See Also

Reference

PDFResetFormAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFResetFormAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : PDFResetFormAction Constructor
Initializes a new PDFResetFormAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFResetFormAction()
public PDFResetFormAction()
public: PDFResetFormAction();
public:
PDFResetFormAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%PageItemTitle%% $$Properties$$

PDFResetFormAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFResetFormAction Class

For a list of all members of this type, see PDFResetFormAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | ResetFields | Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Top
See Also

Reference

PDFResetFormAction Class
O2S.Components.PDF4NET.Actions Namespace


Fields Property (PDFResetFormAction)

O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : Fields Property
Gets or sets the list of fields affected by this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fields As List(Of String)
'Usage

Dim instance As PDFResetFormAction
Dim value As List(Of String)

instance.Fields = value

value = instance.Fields
public List<string> Fields {get; set;}
public: __property List<string*>* get_Fields();
public: __property void set_Fields(
   List<string*>* value
);
public:
property List<String^>^ Fields {
   List<String^>^ get();
   void set (    List<String^>^ value);
}

Property Value

A System.Collections.Specialized.StringCollection object specifying the list of fields affected by this action.
Remarks
The ResetFields property controls how the fields in this collection are reset.
If ResetFields property is true, only the fields in this collection will be reset.
If ResetFields property is false, the fields in this collection are not reset and only the remaining form fields are reset.
If the collection is null or empty, then all the form fields are reset and the ResetFields property is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


ResetFields Property

O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : ResetFields Property
Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResetFields As Boolean
'Usage

Dim instance As PDFResetFormAction
Dim value As Boolean

instance.ResetFields = value

value = instance.ResetFields
public bool ResetFields {get; set;}
public: __property bool get_ResetFields();
public: __property void set_ResetFields(
   bool value
);
public:
property bool ResetFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the fields in Fields collection should be reset, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%PageItemTitle%%

PDFSubmitFormAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFSubmitFormAction Class
Defines a SubmitForm action.
Object Model
PDFSubmitFormAction ClassPDFActionCollection ClassPDFAction ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSubmitFormAction
   Inherits PDFAction
'Usage

Dim instance As PDFSubmitFormAction
public class PDFSubmitFormAction : PDFAction
public __gc class PDFSubmitFormAction : public PDFAction
public ref class PDFSubmitFormAction : public PDFAction
Remarks
This action allows a user to submit the form data to a specified URL.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFSubmitFormAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFSubmitFormAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFSubmitFormAction Class

The following tables list the members exposed by PDFSubmitFormAction.

Public Constructors
 | Name | Description
Public Constructor | PDFSubmitFormAction Constructor | Initializes a new PDFSubmitFormAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | DataFormat | Gets or sets the format of the data being submitted.
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | EmbedForm | Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value should be submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Public Property | Url | Gets or sets the URL for submitting the form data.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Top
See Also

Reference

PDFSubmitFormAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFSubmitFormAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : PDFSubmitFormAction Constructor
Initializes a new PDFSubmitFormAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSubmitFormAction()
public PDFSubmitFormAction()
public: PDFSubmitFormAction();
public:
PDFSubmitFormAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%% $$Properties$$

PDFSubmitFormAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFSubmitFormAction Class

For a list of all members of this type, see PDFSubmitFormAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | DataFormat | Gets or sets the format of the data being submitted.
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | EmbedForm | Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value should be submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Public Property | Url | Gets or sets the URL for submitting the form data.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Top
See Also

Reference

PDFSubmitFormAction Class
O2S.Components.PDF4NET.Actions Namespace


DataFormat Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : DataFormat Property
Gets or sets the format of the data being submitted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DataFormat As SubmitDataFormat
'Usage

Dim instance As PDFSubmitFormAction
Dim value As SubmitDataFormat

instance.DataFormat = value

value = instance.DataFormat
public SubmitDataFormat DataFormat {get; set;}
public: __property SubmitDataFormat get_DataFormat();
public: __property void set_DataFormat(
   SubmitDataFormat value
);
public:
property SubmitDataFormat DataFormat {
   SubmitDataFormat get();
   void set (    SubmitDataFormat value);
}

Property Value

A SubmitDataFormat enumeration member specifying the format of the data being submitted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


EmbedForm Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : EmbedForm Property
Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EmbedForm As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.EmbedForm = value

value = instance.EmbedForm
public bool EmbedForm {get; set;}
public: __property bool get_EmbedForm();
public: __property void set_EmbedForm(
   bool value
);
public:
property bool EmbedForm {
   bool get();
   void set (    bool value);
}

Property Value

True if the PDF document is embedded in the submitted FDF file, false otherwise. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.FDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


ExcludeNonUserAnnotations Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : ExcludeNonUserAnnotations Property
Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExcludeNonUserAnnotations As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.ExcludeNonUserAnnotations = value

value = instance.ExcludeNonUserAnnotations
public bool ExcludeNonUserAnnotations {get; set;}
public: __property bool get_ExcludeNonUserAnnotations();
public: __property void set_ExcludeNonUserAnnotations(
   bool value
);
public:
property bool ExcludeNonUserAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

True if only the annotations whose author is the current user should be submitted, false otherwise. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.FDF and IncludeAnnotations property is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


Fields Property (PDFSubmitFormAction)

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : Fields Property
Gets or sets the list of fields affected by this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fields As List(Of String)
'Usage

Dim instance As PDFSubmitFormAction
Dim value As List(Of String)

instance.Fields = value

value = instance.Fields
public List<string> Fields {get; set;}
public: __property List<string*>* get_Fields();
public: __property void set_Fields(
   List<string*>* value
);
public:
property List<String^>^ Fields {
   List<String^>^ get();
   void set (    List<String^>^ value);
}

Property Value

A System.Collections.Specialized.StringCollection object specifying the list of fields affected by this action.
Remarks
The SubmitFields property controls how the fields in this collection are submitted to the specified URL.
If SubmitFields property is true, only the fields in this collection will be submitted.
If SubmitFields property is false, the fields in this collection will not be submitted and only the remaining form fields will be submitted.
If the collection is null or empty, then all the form fields are submitted and the SubmitFields property is ignored.
In any of the situations above, the fields with PDFField.NoExport property set to true will not be submitted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


IncludeAnnotations Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeAnnotations Property
Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncludeAnnotations As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeAnnotations = value

value = instance.IncludeAnnotations
public bool IncludeAnnotations {get; set;}
public: __property bool get_IncludeAnnotations();
public: __property void set_IncludeAnnotations(
   bool value
);
public:
property bool IncludeAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

True if the incremental updates to the underlying PDF document should be included in the submitted FDF file, false otherwise. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.FDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


IncludeAppendSaves Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeAppendSaves Property
Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncludeAppendSaves As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeAppendSaves = value

value = instance.IncludeAppendSaves
public bool IncludeAppendSaves {get; set;}
public: __property bool get_IncludeAppendSaves();
public: __property void set_IncludeAppendSaves(
   bool value
);
public:
property bool IncludeAppendSaves {
   bool get();
   void set (    bool value);
}

Property Value

True if the incremental updates to the underlying PDF document should be included in the submitted FDF file, false otherwise. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.FDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


IncludeNoValueFields Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeNoValueFields Property
Gets or sets a value indicating whether the fields with no value should be submitted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncludeNoValueFields As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeNoValueFields = value

value = instance.IncludeNoValueFields
public bool IncludeNoValueFields {get; set;}
public: __property bool get_IncludeNoValueFields();
public: __property void set_IncludeNoValueFields(
   bool value
);
public:
property bool IncludeNoValueFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the fields with no value should be submitted, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


SubmitCoordinates Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : SubmitCoordinates Property
Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubmitCoordinates As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.SubmitCoordinates = value

value = instance.SubmitCoordinates
public bool SubmitCoordinates {get; set;}
public: __property bool get_SubmitCoordinates();
public: __property void set_SubmitCoordinates(
   bool value
);
public:
property bool SubmitCoordinates {
   bool get();
   void set (    bool value);
}

Property Value

True if the coordinates of the mouse click that caused the submit form action should be transmitted as part of form data, otherwise false. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.HTML.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


SubmitFields Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : SubmitFields Property
Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubmitFields As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.SubmitFields = value

value = instance.SubmitFields
public bool SubmitFields {get; set;}
public: __property bool get_SubmitFields();
public: __property void set_SubmitFields(
   bool value
);
public:
property bool SubmitFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the fields in Fields collection should be submitted, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


Url Property (PDFSubmitFormAction)

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : Url Property
Gets or sets the URL for submitting the form data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Url As String
'Usage

Dim instance As PDFSubmitFormAction
Dim value As String

instance.Url = value

value = instance.Url
public string Url {get; set;}
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
public:
property String^ Url {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the URL where the form data should be submitted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


UseCanonicalDateTimeFormat Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : UseCanonicalDateTimeFormat Property
Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseCanonicalDateTimeFormat As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.UseCanonicalDateTimeFormat = value

value = instance.UseCanonicalDateTimeFormat
public bool UseCanonicalDateTimeFormat {get; set;}
public: __property bool get_UseCanonicalDateTimeFormat();
public: __property void set_UseCanonicalDateTimeFormat(
   bool value
);
public:
property bool UseCanonicalDateTimeFormat {
   bool get();
   void set (    bool value);
}

Property Value

True if the the field values representing dates should be submitted using PDF date/time format. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


UseHttpGet Property

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : UseHttpGet Property
Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseHttpGet As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.UseHttpGet = value

value = instance.UseHttpGet
public bool UseHttpGet {get; set;}
public: __property bool get_UseHttpGet();
public: __property void set_UseHttpGet(
   bool value
);
public:
property bool UseHttpGet {
   bool get();
   void set (    bool value);
}

Property Value

True if the field names and values should be submitted using HTTP GET method. If false, the field names and values are submitted using HTTP POST method. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.HTML or DataFormat.PDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

PDFURIAction Class
Members

O2S.Components.PDF4NET.Actions Namespace : PDFURIAction Class
This class represents a PDF URI action.
Object Model
PDFURIAction ClassPDFActionCollection ClassPDFAction ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFURIAction
   Inherits PDFAction
'Usage

Dim instance As PDFURIAction
public class PDFURIAction : PDFAction
public __gc class PDFURIAction : public PDFAction
public ref class PDFURIAction : public PDFAction
Remarks
This type of action allows a user to go to a resource on the Internet, tipically a hypertext link.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFURIAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFURIAction Members
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFURIAction Class Members
Properties

O2S.Components.PDF4NET.Actions Namespace : PDFURIAction Class

The following tables list the members exposed by PDFURIAction.

Public Constructors
 | Name | Description
Public Constructor | PDFURIAction Constructor | Initializes a new PDFURIAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | URI | Gets or sets the uri to be resolved when this action is executed.
Top
See Also

Reference

PDFURIAction Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFURIAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFURIAction Class : PDFURIAction Constructor
Initializes a new PDFURIAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFURIAction()
public PDFURIAction()
public: PDFURIAction();
public:
PDFURIAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFURIAction Class
PDFURIAction Members


%%PageItemTitle%% $$Properties$$

PDFURIAction Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFURIAction Class

For a list of all members of this type, see PDFURIAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from O2S.Components.PDF4NET.Actions.PDFAction)
Public Property | URI | Gets or sets the uri to be resolved when this action is executed.
Top
See Also

Reference

PDFURIAction Class
O2S.Components.PDF4NET.Actions Namespace


URI Property

O2S.Components.PDF4NET.Actions Namespace > PDFURIAction Class : URI Property
Gets or sets the uri to be resolved when this action is executed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property URI As String
'Usage

Dim instance As PDFURIAction
Dim value As String

instance.URI = value

value = instance.URI
public string URI {get; set;}
public: __property string* get_URI();
public: __property void set_URI(
   string* value
);
public:
property String^ URI {
   String^ get();
   void set (    String^ value);
}

Property Value

An string value specifying the full URI for the internet resource.
Remarks
The value of this property is usually a HTTP url, like below:
action.URI = "http://www.o2sol.com/";
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFURIAction Class
PDFURIAction Members


%%PageItemTitle%%

NamedAction Enumeration

O2S.Components.PDF4NET.Actions Namespace : NamedAction Enumeration
Specifies the available named actions supported by the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum NamedAction
   Inherits System.Enum
'Usage

Dim instance As NamedAction
public enum NamedAction : System.Enum
__value public enum NamedAction : public System.Enum
public enum class NamedAction : public System.Enum
Members
Member | Description
FirstPage | Go to first page in the document.
LastPage | Go to last page in the document.
NextPage | Go to next page in the document.
PrevPage | Go to previous page in the document.
Print | Print the document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Actions.NamedAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

SubmitDataFormat Enumeration

O2S.Components.PDF4NET.Actions Namespace : SubmitDataFormat Enumeration
Specifies the available data formats for submitting the form data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum SubmitDataFormat
   Inherits System.Enum
'Usage

Dim instance As SubmitDataFormat
public enum SubmitDataFormat : System.Enum
__value public enum SubmitDataFormat : public System.Enum
public enum class SubmitDataFormat : public System.Enum
Members
Member | Description
FDF | The field names and values are submitted in FDF format.
HTML | The field names and values are submitted in HTML Form format.
PDF | The entire PDF file is submitted.
XFDF | The field names and values are submitted in XFDF format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Actions.SubmitDataFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Actions Namespace


O2S.Components.PDF4NET.Annotations Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDF3DActivation | Defines how the annotation is activated and deactivated.
Class | PDF3DAnimation | Defines the lighting to apply to 3D artwork.
Class | PDF3DAnnotation | Defines a 3D annotation.
Class | PDF3DBackground | Defines the background appearance for 3D artwork.
Class | PDF3DCrossSection | Defines how a portion of the 3D artwork is clipped for the purpose of showing artwork cross sections.
Class | PDF3DCrossSectionCollection | Defines a collection of PDF actions.
Class | PDF3DEntity | Defines the base class for all 3D related classes.
Class | PDF3DLightingScheme | Defines the lighting to apply to 3D artwork.
Class | PDF3DNode | Defines particular areas of 3D artwork and the opacity and visibility with which individual nodes are displayed.
Class | PDF3DNodeCollection | Defines a collection of PDF actions.
Class | PDF3DProjection | Defines the mapping of 3D camera coordinates onto the target coordinate system of the annotation.
Class | PDF3DRenderMode | Defines the style in which the 3D artwork is rendered.
Class | PDF3DStream | Defines the stream that contains the 3D artwork.
Class | PDF3DView | Defines the parameters to be applied to the virtual camera associated with a 3D annotation.
Class | PDF3DViewCollection | Defines a collection of PDF actions.
Class | PDFAnnotation | Defines the base class for all annotations available in a PDF file.
Class | PDFAnnotationAppearance | Defines the base class for all annotation appearances.
Class | PDFAnnotationBorder | Defines the border of an annotation.
Class | PDFAnnotationCollection | Defines a collection of annotations.
Class | PDFBaseMarkupAnnotation | Defines the base class for all markup type annotations.
Class | PDFEllipseAnnotation | Defines an ellipse (Circle) annotation.
Class | PDFFileAttachmentAnnotation | Defines a file attachment annotation.
Class | PDFFlashAnnotation | Defines a flash annotation in a PDF file.
Class | PDFFreeTextAnnotation | Defines a free text annotations.
Class | PDFHighlightAnnotation | Defines a highlight annotation.
Class | PDFImageAppearance | Defines an annotation appearance that consists of an image.
Class | PDFInkAnnotation | Defines an ink annotation.
Class | PDFLineAnnotation | Defines a line annotation.
Class | PDFLinkAnnotation | Defines a link annotations.
Class | PDFMovieAnnotation | Defines a movie annotation in a PDF file.
Class | PDFPointsCollection | Defines a collection of array the store points on the page.
Class | PDFRectangleAnnotation | Defines a rectangle (Square) annotation.
Class | PDFRubberStampAnnotation | Defines a rubber stamp annotation.
Class | PDFSCAnnotation | Defines the base class for rectangle (Square) and ellipse (Circle) annotations.
Class | PDFSquigglyAnnotation | Defines a squiggly annotation.
Class | PDFStrikeOutAnnotation | Defines a strike out annotation.
Class | PDFTextAnnotation | Defines a text annotation.
Class | PDFTextMarkupAnnotation | Defines a text markup annotation.
Class | PDFUnderlineAnnotation | Defines an underline annotation.
Enumerations
 | Enumeration | Description
Enumeration | PDF3DActivationMode | Specifies the available modes for activating a 3D annotation.
Enumeration | PDF3DActivationState | Specifies the available states upon activation of the 3D annotation.
Enumeration | PDF3DAnimationType | Specifies the available styles for applying light to 3D artwork.
Enumeration | PDF3DDeactivationMode | Specifies the available modes for activating a 3D annotation.
Enumeration | PDF3DDeactivationState | Specifies the available states upon deactivation of the 3D annotation.
Enumeration | PDF3DLightingStyle | Specifies the available styles for applying light to 3D artwork.
Enumeration | PDF3DProjectionClipStyle | Specifies the available styles for the projection clipping.
Enumeration | PDF3DProjectionOrthoScaleMode | Specifies the available scaling modes for orthographic projections.
Enumeration | PDF3DProjectionType | Specifies the available types for the projection of 3D artwork.
Enumeration | PDF3DRenderStyle | Specifies the available styles for rendering the 3D artwork.
Enumeration | PDFAnnotationFlags | Specifies the available flags for an annotation.
Enumeration | PDFAnnotationType | Specifies the available types of annotations.
Enumeration | PDFBorderStyle | Specifies the available styles for an annotation's border.
Enumeration | PDFFileAttachmentAnnotationIcon | Specifies the available icons for a file attachment annotation.
Enumeration | PDFLineDirection | Specifies the available directions for a line annotation.
Enumeration | PDFLineEndingStyle | Specifies the available line ending styles to be used when drawing a line annotation.
Enumeration | PDFLinkHighlightMode | Specifies the available highlighting modes for a link annotation.
Enumeration | PDFMovieType | Specifies the available movie types to be included in a PDF document.
Enumeration | PDFRubberStampAnnotationIcon | Specifies the available icons for a stmap annotation.
Enumeration | PDFTextAnnotationIcon | Specifies the available icons for a text annotation.
Enumeration | PDFTextAnnotationState | Specifies the available states for a text annotation.
Enumeration | PDFTextMarkupType | Specifies the available markup types for a text markup annotation.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDF3DActivation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivation Class
Defines how the annotation is activated and deactivated.
Object Model
PDF3DActivation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DActivation
   Inherits PDF3DEntity
'Usage

Dim instance As PDF3DActivation
public class PDF3DActivation : PDF3DEntity
public __gc class PDF3DActivation : public PDF3DEntity
public ref class PDF3DActivation : public PDF3DEntity
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DActivation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DActivation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DActivation Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivation Class

The following tables list the members exposed by PDF3DActivation.

Public Constructors
 | Name | Description
Public Constructor | PDF3DActivation Constructor | Initializes a new PDF3DActivation object.
Top
Public Properties
 | Name | Description
Public Property | ActivationMode | Gets or sets the activation mode for the annotation.
Public Property | ActivationState | Gets or sets the activation state for the annotation.
Public Property | DeactivationMode | Gets or sets the deactivation mode for the annotation.
Public Property | DeactivationState | Gets or sets the deactivation state for the annotation.
Public Property | ShowToolbar | Gets or sets a value indicating whether the toolbar should be displayed when the annotation is activated.
Public Property | ShowUI | Gets or sets a value indicating whether the UI for managing the 3D artwork should be displayed when the annotation is activated.
Top
See Also

Reference

PDF3DActivation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DActivation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : PDF3DActivation Constructor
Initializes a new PDF3DActivation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DActivation()
public PDF3DActivation()
public: PDF3DActivation();
public:
PDF3DActivation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%% $$Properties$$

PDF3DActivation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivation Class

For a list of all members of this type, see PDF3DActivation members.

Public Properties
 | Name | Description
Public Property | ActivationMode | Gets or sets the activation mode for the annotation.
Public Property | ActivationState | Gets or sets the activation state for the annotation.
Public Property | DeactivationMode | Gets or sets the deactivation mode for the annotation.
Public Property | DeactivationState | Gets or sets the deactivation state for the annotation.
Public Property | ShowToolbar | Gets or sets a value indicating whether the toolbar should be displayed when the annotation is activated.
Public Property | ShowUI | Gets or sets a value indicating whether the UI for managing the 3D artwork should be displayed when the annotation is activated.
Top
See Also

Reference

PDF3DActivation Class
O2S.Components.PDF4NET.Annotations Namespace


ActivationMode Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ActivationMode Property
Gets or sets the activation mode for the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ActivationMode As PDF3DActivationMode
'Usage

Dim instance As PDF3DActivation
Dim value As PDF3DActivationMode

instance.ActivationMode = value

value = instance.ActivationMode
public PDF3DActivationMode ActivationMode {get; set;}
public: __property PDF3DActivationMode get_ActivationMode();
public: __property void set_ActivationMode(
   PDF3DActivationMode value
);
public:
property PDF3DActivationMode ActivationMode {
   PDF3DActivationMode get();
   void set (    PDF3DActivationMode value);
}

Property Value

A PDF3DActivationMode enumeration member specifying the circumstances under which the annotation should be activated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


ActivationState Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ActivationState Property
Gets or sets the activation state for the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ActivationState As PDF3DActivationState
'Usage

Dim instance As PDF3DActivation
Dim value As PDF3DActivationState

instance.ActivationState = value

value = instance.ActivationState
public PDF3DActivationState ActivationState {get; set;}
public: __property PDF3DActivationState get_ActivationState();
public: __property void set_ActivationState(
   PDF3DActivationState value
);
public:
property PDF3DActivationState ActivationState {
   PDF3DActivationState get();
   void set (    PDF3DActivationState value);
}

Property Value

A PDF3DActivationState enumeration member specifying the state of the artwork instance upon activation of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


DeactivationMode Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : DeactivationMode Property
Gets or sets the deactivation mode for the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeactivationMode As PDF3DDeactivationMode
'Usage

Dim instance As PDF3DActivation
Dim value As PDF3DDeactivationMode

instance.DeactivationMode = value

value = instance.DeactivationMode
public PDF3DDeactivationMode DeactivationMode {get; set;}
public: __property PDF3DDeactivationMode get_DeactivationMode();
public: __property void set_DeactivationMode(
   PDF3DDeactivationMode value
);
public:
property PDF3DDeactivationMode DeactivationMode {
   PDF3DDeactivationMode get();
   void set (    PDF3DDeactivationMode value);
}

Property Value

A PDF3DDeactivationMode enumeration member specifying the circumstances under which the annotation should be deactivated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


DeactivationState Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : DeactivationState Property
Gets or sets the deactivation state for the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeactivationState As PDF3DDeactivationState
'Usage

Dim instance As PDF3DActivation
Dim value As PDF3DDeactivationState

instance.DeactivationState = value

value = instance.DeactivationState
public PDF3DDeactivationState DeactivationState {get; set;}
public: __property PDF3DDeactivationState get_DeactivationState();
public: __property void set_DeactivationState(
   PDF3DDeactivationState value
);
public:
property PDF3DDeactivationState DeactivationState {
   PDF3DDeactivationState get();
   void set (    PDF3DDeactivationState value);
}

Property Value

A PDF3DDeactivationState enumeration member specifying the state of the artwork instance upon deactivation of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


ShowToolbar Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ShowToolbar Property
Gets or sets a value indicating whether the toolbar should be displayed when the annotation is activated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShowToolbar As Boolean
'Usage

Dim instance As PDF3DActivation
Dim value As Boolean

instance.ShowToolbar = value

value = instance.ShowToolbar
public bool ShowToolbar {get; set;}
public: __property bool get_ShowToolbar();
public: __property void set_ShowToolbar(
   bool value
);
public:
property bool ShowToolbar {
   bool get();
   void set (    bool value);
}

Property Value

If true, a toolbar should be displayed by default when the annotation is activated and given focus. If false, a toolbar should not be displayed by default.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


ShowUI Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ShowUI Property
Gets or sets a value indicating whether the UI for managing the 3D artwork should be displayed when the annotation is activated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShowUI As Boolean
'Usage

Dim instance As PDF3DActivation
Dim value As Boolean

instance.ShowUI = value

value = instance.ShowUI
public bool ShowUI {get; set;}
public: __property bool get_ShowUI();
public: __property void set_ShowUI(
   bool value
);
public:
property bool ShowUI {
   bool get();
   void set (    bool value);
}

Property Value

If true, the user interface should be made visible when the annotation is activated. If false, the user interface should not be made visible by default.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%%

PDF3DAnimation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimation Class
Defines the lighting to apply to 3D artwork.
Object Model
PDF3DAnimation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DAnimation
   Inherits PDF3DEntity
'Usage

Dim instance As PDF3DAnimation
public class PDF3DAnimation : PDF3DEntity
public __gc class PDF3DAnimation : public PDF3DEntity
public ref class PDF3DAnimation : public PDF3DEntity
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DAnimation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnimation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DAnimation Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimation Class

The following tables list the members exposed by PDF3DAnimation.

Public Constructors
 | Name | Description
Public Constructor | PDF3DAnimation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | PlayCount | Gets or sets the play count.
Public Property | TimeMultiplier | Gets or sets the time multiplier for the animation.
Public Property | Type | Gets or sets the animation type.
Top
See Also

Reference

PDF3DAnimation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DAnimation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : PDF3DAnimation Constructor
Overload List
Overload | Description
PDF3DAnimation Constructor() | Initializes a new PDF3DAnimation object.
PDF3DAnimation Constructor(PDF3DAnimationType) | Initializes a new PDF3DAnimation object with a new type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


%%PageItemTitle%%

PDF3DAnimation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class > PDF3DAnimation Constructor : PDF3DAnimation Constructor()
Initializes a new PDF3DAnimation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DAnimation()
public PDF3DAnimation()
public: PDF3DAnimation();
public:
PDF3DAnimation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members
Overload List


%%PageItemTitle%%

PDF3DAnimation Constructor(PDF3DAnimationType)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class > PDF3DAnimation Constructor : PDF3DAnimation Constructor(PDF3DAnimationType)
Initializes a new PDF3DAnimation object with a new type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal type As PDF3DAnimationType _
)
'Usage

Dim type As PDF3DAnimationType

Dim instance As New PDF3DAnimation(type)
public PDF3DAnimation(
   PDF3DAnimationType type
)
public: PDF3DAnimation(
   PDF3DAnimationType type
)
public:
PDF3DAnimation(
   PDF3DAnimationType type
)

Parameters

type
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DAnimation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimation Class

For a list of all members of this type, see PDF3DAnimation members.

Public Properties
 | Name | Description
Public Property | PlayCount | Gets or sets the play count.
Public Property | TimeMultiplier | Gets or sets the time multiplier for the animation.
Public Property | Type | Gets or sets the animation type.
Top
See Also

Reference

PDF3DAnimation Class
O2S.Components.PDF4NET.Annotations Namespace


PlayCount Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : PlayCount Property
Gets or sets the play count.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PlayCount As Integer
'Usage

Dim instance As PDF3DAnimation
Dim value As Integer

instance.PlayCount = value

value = instance.PlayCount
public int PlayCount {get; set;}
public: __property int get_PlayCount();
public: __property void set_PlayCount(
   int value
);
public:
property int PlayCount {
   int get();
   void set (    int value);
}

Property Value

An integer specifying the play count for this animation.
Remarks
A non-negative integer represents the number of times the animation is played. A negative integer indicates that the animation is infinitely repeated. This value is ignored for animation types of PDF3DAnimationType.None.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


TimeMultiplier Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : TimeMultiplier Property
Gets or sets the time multiplier for the animation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TimeMultiplier As Double
'Usage

Dim instance As PDF3DAnimation
Dim value As Double

instance.TimeMultiplier = value

value = instance.TimeMultiplier
public double TimeMultiplier {get; set;}
public: __property double get_TimeMultiplier();
public: __property void set_TimeMultiplier(
   double value
);
public:
property double TimeMultiplier {
   double get();
   void set (    double value);
}

Property Value

A positive number specifying the time multiplier to be used when running the animation.
Remarks
A value greater than one shortens the time it takes to play the animation, or effectively speeds up the animation. This value is ignored for animation types of PDF3DAnimationType.None.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


Type Property (PDF3DAnimation)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : Type Property
Gets or sets the animation type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As PDF3DAnimationType
'Usage

Dim instance As PDF3DAnimation
Dim value As PDF3DAnimationType

instance.Type = value

value = instance.Type
public PDF3DAnimationType Type {get; set;}
public: __property PDF3DAnimationType get_Type();
public: __property void set_Type(
   PDF3DAnimationType value
);
public:
property PDF3DAnimationType Type {
   PDF3DAnimationType get();
   void set (    PDF3DAnimationType value);
}

Property Value

A PDF3DAnimationType enumeration member specifying the animation type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


%%PageItemTitle%%

PDF3DAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class
Defines a 3D annotation.
Object Model
PDF3DAnnotation ClassPDF3DActivation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDF3DStream Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DAnnotation
   Inherits PDFAnnotation
'Usage

Dim instance As PDF3DAnnotation
public class PDF3DAnnotation : PDFAnnotation
public __gc class PDF3DAnnotation : public PDFAnnotation
public ref class PDF3DAnnotation : public PDFAnnotation
Remarks
3D annotations allow to include 3D artwork in PDF files.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

The following tables list the members exposed by PDF3DAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDF3DAnnotation Constructor | Initializes a new PDF3DAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Activation | Gets or sets the activation options for the annotation.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Stream | Gets or sets the 3D stream associated with the annotation.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDF3DAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : PDF3DAnnotation Constructor
Initializes a new PDF3DAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DAnnotation()
public PDF3DAnnotation()
public: PDF3DAnnotation();
public:
PDF3DAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


%%PageItemTitle%% $$Properties$$

PDF3DAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

For a list of all members of this type, see PDF3DAnnotation members.

Public Properties
 | Name | Description
Public Property | Activation | Gets or sets the activation options for the annotation.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Stream | Gets or sets the 3D stream associated with the annotation.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDF3DAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Activation Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : Activation Property
Gets or sets the activation options for the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Activation As PDF3DActivation
'Usage

Dim instance As PDF3DAnnotation
Dim value As PDF3DActivation

instance.Activation = value

value = instance.Activation
public PDF3DActivation Activation {get; set;}
public: __property PDF3DActivation* get_Activation();
public: __property void set_Activation(
   PDF3DActivation* value
);
public:
property PDF3DActivation^ Activation {
   PDF3DActivation^ get();
   void set (    PDF3DActivation^ value);
}

Property Value

A PDF3DActivation object specifying the activation options for the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


Appearance Property (PDF3DAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDF3DAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


Stream Property (PDF3DAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : Stream Property
Gets or sets the 3D stream associated with the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Stream As PDF3DStream
'Usage

Dim instance As PDF3DAnnotation
Dim value As PDF3DStream

instance.Stream = value

value = instance.Stream
public PDF3DStream Stream {get; set;}
public: __property PDF3DStream* get_Stream();
public: __property void set_Stream(
   PDF3DStream* value
);
public:
property PDF3DStream^ Stream {
   PDF3DStream^ get();
   void set (    PDF3DStream^ value);
}

Property Value

A PDF3DStream object specifying the stream containing the 3D artwork.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


%%PageItemTitle%%

PDF3DBackground Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DBackground Class
Defines the background appearance for 3D artwork.
Object Model
PDF3DBackground ClassPDFRgbColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DBackground
   Inherits PDF3DEntity
'Usage

Dim instance As PDF3DBackground
public class PDF3DBackground : PDF3DEntity
public __gc class PDF3DBackground : public PDF3DEntity
public ref class PDF3DBackground : public PDF3DEntity
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DBackground

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DBackground Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DBackground Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DBackground Class

The following tables list the members exposed by PDF3DBackground.

Public Constructors
 | Name | Description
Public Constructor | PDF3DBackground Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ApplyToEntireAnnotation | Gets or sets a value indicating how the background is applied.
Public Property | Color | Gets or sets the background color.
Top
See Also

Reference

PDF3DBackground Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DBackground Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class : PDF3DBackground Constructor
Overload List
Overload | Description
PDF3DBackground Constructor() | Initializes a new PDF3DBackground object.
PDF3DBackground Constructor(PDFRgbColor) | Initializes a new PDF3DBackground object with a new color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members


%%PageItemTitle%%

PDF3DBackground Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class > PDF3DBackground Constructor : PDF3DBackground Constructor()
Initializes a new PDF3DBackground object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DBackground()
public PDF3DBackground()
public: PDF3DBackground();
public:
PDF3DBackground();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members
Overload List


%%PageItemTitle%%

PDF3DBackground Constructor(PDFRgbColor)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class > PDF3DBackground Constructor : PDF3DBackground Constructor(PDFRgbColor)
The background color.
Initializes a new PDF3DBackground object with a new color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As PDFRgbColor _
)
'Usage

Dim color As PDFRgbColor

Dim instance As New PDF3DBackground(color)
public PDF3DBackground(
   PDFRgbColor color
)
public: PDF3DBackground(
   PDFRgbColor* color
)
public:
PDF3DBackground(
   PDFRgbColor^ color
)

Parameters

color
The background color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DBackground Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DBackground Class

For a list of all members of this type, see PDF3DBackground members.

Public Properties
 | Name | Description
Public Property | ApplyToEntireAnnotation | Gets or sets a value indicating how the background is applied.
Public Property | Color | Gets or sets the background color.
Top
See Also

Reference

PDF3DBackground Class
O2S.Components.PDF4NET.Annotations Namespace


ApplyToEntireAnnotation Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class : ApplyToEntireAnnotation Property
Gets or sets a value indicating how the background is applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ApplyToEntireAnnotation As Boolean
'Usage

Dim instance As PDF3DBackground
Dim value As Boolean

instance.ApplyToEntireAnnotation = value

value = instance.ApplyToEntireAnnotation
public bool ApplyToEntireAnnotation {get; set;}
public: __property bool get_ApplyToEntireAnnotation();
public: __property void set_ApplyToEntireAnnotation(
   bool value
);
public:
property bool ApplyToEntireAnnotation {
   bool get();
   void set (    bool value);
}

Property Value

True if the background is applied to entire annotation, false if the background is applied to annotation's 3D view box only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members


Color Property (PDF3DBackground)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class : Color Property
Gets or sets the background color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As PDFRgbColor
'Usage

Dim instance As PDF3DBackground
Dim value As PDFRgbColor

instance.Color = value

value = instance.Color
public PDFRgbColor Color {get; set;}
public: __property PDFRgbColor* get_Color();
public: __property void set_Color(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ Color {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the background color for the 3D artwork.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members


%%PageItemTitle%%

PDF3DCrossSection Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSection Class
Defines how a portion of the 3D artwork is clipped for the purpose of showing artwork cross sections.
Object Model
PDF3DCrossSection ClassPDFRgbColor ClassPDFRgbColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DCrossSection
   Inherits PDF3DEntity
'Usage

Dim instance As PDF3DCrossSection
public class PDF3DCrossSection : PDF3DEntity
public __gc class PDF3DCrossSection : public PDF3DEntity
public ref class PDF3DCrossSection : public PDF3DEntity
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DCrossSection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DCrossSection Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSection Class

The following tables list the members exposed by PDF3DCrossSection.

Public Constructors
 | Name | Description
Public Constructor | PDF3DCrossSection Constructor | Initializes a new PDF3DCrossSection object.
Top
Public Properties
 | Name | Description
Public Property | Center | Gets or sets the center of the cutting plane.
Public Property | Color | Gets or sets the cutting plane color.
Public Property | IntersectionColor | Gets or sets the intersection color.
Public Property | IntersectionIsVisible | Gets or sets a value indicating whether the intersection of cutting plane with 3D artwork is visible.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Orientation | Gets or sets the orientation of the cutting plane.
Top
See Also

Reference

PDF3DCrossSection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DCrossSection Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : PDF3DCrossSection Constructor
Initializes a new PDF3DCrossSection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DCrossSection()
public PDF3DCrossSection()
public: PDF3DCrossSection();
public:
PDF3DCrossSection();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%% $$Properties$$

PDF3DCrossSection Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSection Class

For a list of all members of this type, see PDF3DCrossSection members.

Public Properties
 | Name | Description
Public Property | Center | Gets or sets the center of the cutting plane.
Public Property | Color | Gets or sets the cutting plane color.
Public Property | IntersectionColor | Gets or sets the intersection color.
Public Property | IntersectionIsVisible | Gets or sets a value indicating whether the intersection of cutting plane with 3D artwork is visible.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Orientation | Gets or sets the orientation of the cutting plane.
Top
See Also

Reference

PDF3DCrossSection Class
O2S.Components.PDF4NET.Annotations Namespace


Center Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Center Property
Gets or sets the center of the cutting plane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Center As Double()
'Usage

Dim instance As PDF3DCrossSection
Dim value() As Double

instance.Center = value

value = instance.Center
public double[] Center {get; set;}
public: __property double[]* get_Center();
public: __property void set_Center(
   double[]* value
);
public:
property array<double>^ Center {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A three element array specifying the center of rotation on the cutting plane in world space coordinates.
Remarks
If the array has more than 3 elements, only the first 3 will be considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


Color Property (PDF3DCrossSection)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Color Property
Gets or sets the cutting plane color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As PDFRgbColor
'Usage

Dim instance As PDF3DCrossSection
Dim value As PDFRgbColor

instance.Color = value

value = instance.Color
public PDFRgbColor Color {get; set;}
public: __property PDFRgbColor* get_Color();
public: __property void set_Color(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ Color {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the color of the cutting plane.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


IntersectionColor Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : IntersectionColor Property
Gets or sets the intersection color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IntersectionColor As PDFRgbColor
'Usage

Dim instance As PDF3DCrossSection
Dim value As PDFRgbColor

instance.IntersectionColor = value

value = instance.IntersectionColor
public PDFRgbColor IntersectionColor {get; set;}
public: __property PDFRgbColor* get_IntersectionColor();
public: __property void set_IntersectionColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ IntersectionColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the color of the the intersection of cutting plane with 3D artwork.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


IntersectionIsVisible Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : IntersectionIsVisible Property
Gets or sets a value indicating whether the intersection of cutting plane with 3D artwork is visible.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IntersectionIsVisible As Boolean
'Usage

Dim instance As PDF3DCrossSection
Dim value As Boolean

instance.IntersectionIsVisible = value

value = instance.IntersectionIsVisible
public bool IntersectionIsVisible {get; set;}
public: __property bool get_IntersectionIsVisible();
public: __property void set_IntersectionIsVisible(
   bool value
);
public:
property bool IntersectionIsVisible {
   bool get();
   void set (    bool value);
}

Property Value

True if the intersection of cutting plane with 3D artwork is visible.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


Opacity Property (PDF3DCrossSection)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Opacity Property
Gets or sets the cutting plane opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Double
'Usage

Dim instance As PDF3DCrossSection
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public double Opacity {get; set;}
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
public:
property double Opacity {
   double get();
   void set (    double value);
}

Property Value

A number indicating the opacity of the cutting plane using a standard additive blend mode.
Remarks
The opacity is given in percents, 100 is full opacity, 0 is no opacity.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


Orientation Property (PDF3DCrossSection)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Orientation Property
Gets or sets the orientation of the cutting plane.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As Object()
'Usage

Dim instance As PDF3DCrossSection
Dim value() As Object

instance.Orientation = value

value = instance.Orientation
public object[] Orientation {get; set;}
public: __property Object*[]* get_Orientation();
public: __property void set_Orientation(
   Object*[]* value
);
public:
property array<Object^>^ Orientation {
   array<Object^>^ get();
   void set (    array<Object^>^ value);
}

Property Value

A three-element array specifying the orientation of the cutting plane in world space, where each value represents the orientation in relation to the X, Y, and Z axes, respectively.
Remarks
If the array has more than 3 elements, only the first 3 will be considered.
Exactly one of the values must be null, indicating an initial state of the cutting plane that is perpendicular to the corresponding axis and clipping all geometry on the positive side of that axis. The other two values must be numbers indicating the rotation of the plane, in degrees, around their corresponding axes. The order in which these rotations are applied should match the order in which the values appear in the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%%

PDF3DCrossSectionCollection Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class
Defines a collection of PDF actions.
Object Model
PDF3DCrossSectionCollection ClassPDF3DCrossSection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DCrossSectionCollection
   Inherits System.Collections.ObjectModel.Collection(Of PDF3DCrossSection)
'Usage

Dim instance As PDF3DCrossSectionCollection
public class PDF3DCrossSectionCollection : System.Collections.ObjectModel.Collection<PDF3DCrossSection>
public __gc class PDF3DCrossSectionCollection : public System.Collections.ObjectModel.Collection<PDF3DCrossSection>
public ref class PDF3DCrossSectionCollection : public System.Collections.ObjectModel.Collection<PDF3DCrossSection>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Annotations.PDF3DCrossSectionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSectionCollection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DCrossSectionCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

The following tables list the members exposed by PDF3DCrossSectionCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Top
See Also

Reference

PDF3DCrossSectionCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DEntity Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DEntity Class
Defines the base class for all 3D related classes.
Object Model
PDF3DEntity Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDF3DEntity
'Usage

Dim instance As PDF3DEntity
public abstract class PDF3DEntity
public __gc abstract class PDF3DEntity
public ref class PDF3DEntity abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DActivation
O2S.Components.PDF4NET.Annotations.PDF3DAnimation
O2S.Components.PDF4NET.Annotations.PDF3DBackground
O2S.Components.PDF4NET.Annotations.PDF3DCrossSection
O2S.Components.PDF4NET.Annotations.PDF3DNode
O2S.Components.PDF4NET.Annotations.PDF3DProjection
O2S.Components.PDF4NET.Annotations.PDF3DRenderMode
O2S.Components.PDF4NET.Annotations.PDF3DStream
O2S.Components.PDF4NET.Annotations.PDF3DView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DEntity Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DEntity Class Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DEntity Class

The following tables list the members exposed by PDF3DEntity.

See Also

Reference

PDF3DEntity Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DLightingScheme Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingScheme Class
Defines the lighting to apply to 3D artwork.
Object Model
PDF3DLightingScheme Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DLightingScheme
'Usage

Dim instance As PDF3DLightingScheme
public class PDF3DLightingScheme
public __gc class PDF3DLightingScheme
public ref class PDF3DLightingScheme
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DLightingScheme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DLightingScheme Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DLightingScheme Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingScheme Class

The following tables list the members exposed by PDF3DLightingScheme.

Public Constructors
 | Name | Description
Public Constructor | PDF3DLightingScheme Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Style | Gets or sets the style for applying light to 3D artwork.
Top
See Also

Reference

PDF3DLightingScheme Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DLightingScheme Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class : PDF3DLightingScheme Constructor
Overload List
Overload | Description
PDF3DLightingScheme Constructor() | Initializes a new PDF3DLightingScheme object.
PDF3DLightingScheme Constructor(PDF3DLightingStyle) | Initializes a new PDF3DLightingScheme object with a new lighting style.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members


%%PageItemTitle%%

PDF3DLightingScheme Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class > PDF3DLightingScheme Constructor : PDF3DLightingScheme Constructor()
Initializes a new PDF3DLightingScheme object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DLightingScheme()
public PDF3DLightingScheme()
public: PDF3DLightingScheme();
public:
PDF3DLightingScheme();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members
Overload List


%%PageItemTitle%%

PDF3DLightingScheme Constructor(PDF3DLightingStyle)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class > PDF3DLightingScheme Constructor : PDF3DLightingScheme Constructor(PDF3DLightingStyle)
The lighting style.
Initializes a new PDF3DLightingScheme object with a new lighting style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal style As PDF3DLightingStyle _
)
'Usage

Dim style As PDF3DLightingStyle

Dim instance As New PDF3DLightingScheme(style)
public PDF3DLightingScheme(
   PDF3DLightingStyle style
)
public: PDF3DLightingScheme(
   PDF3DLightingStyle style
)
public:
PDF3DLightingScheme(
   PDF3DLightingStyle style
)

Parameters

style
The lighting style.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DLightingScheme Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingScheme Class

For a list of all members of this type, see PDF3DLightingScheme members.

Public Properties
 | Name | Description
Public Property | Style | Gets or sets the style for applying light to 3D artwork.
Top
See Also

Reference

PDF3DLightingScheme Class
O2S.Components.PDF4NET.Annotations Namespace


Style Property (PDF3DLightingScheme)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class : Style Property
Gets or sets the style for applying light to 3D artwork.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Style As PDF3DLightingStyle
'Usage

Dim instance As PDF3DLightingScheme
Dim value As PDF3DLightingStyle

instance.Style = value

value = instance.Style
public PDF3DLightingStyle Style {get; set;}
public: __property PDF3DLightingStyle get_Style();
public: __property void set_Style(
   PDF3DLightingStyle value
);
public:
property PDF3DLightingStyle Style {
   PDF3DLightingStyle get();
   void set (    PDF3DLightingStyle value);
}

Property Value

A PDF3DLightingStyle enumeration member specifying the style for applying light to 3D artwork.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members


%%PageItemTitle%%

PDF3DNode Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DNode Class
Defines particular areas of 3D artwork and the opacity and visibility with which individual nodes are displayed.
Object Model
PDF3DNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DNode
   Inherits PDF3DEntity
'Usage

Dim instance As PDF3DNode
public class PDF3DNode : PDF3DEntity
public __gc class PDF3DNode : public PDF3DEntity
public ref class PDF3DNode : public PDF3DEntity
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DNode Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DNode Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DNode Class

The following tables list the members exposed by PDF3DNode.

Public Constructors
 | Name | Description
Public Constructor | PDF3DNode Constructor | Initializes a new PDF3DNode object.
Top
Public Properties
 | Name | Description
Public Property | Matrix | Gets or sets the 3D transformation matrix.
Public Property | Name | Gets or sets the node name.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Visible | Gets or sets a value indicating whether the node is visible or not.
Top
See Also

Reference

PDF3DNode Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DNode Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : PDF3DNode Constructor
Initializes a new PDF3DNode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DNode()
public PDF3DNode()
public: PDF3DNode();
public:
PDF3DNode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DNode Class
PDF3DNode Members


%%PageItemTitle%% $$Properties$$

PDF3DNode Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DNode Class

For a list of all members of this type, see PDF3DNode members.

Public Properties
 | Name | Description
Public Property | Matrix | Gets or sets the 3D transformation matrix.
Public Property | Name | Gets or sets the node name.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Visible | Gets or sets a value indicating whether the node is visible or not.
Top
See Also

Reference

PDF3DNode Class
O2S.Components.PDF4NET.Annotations Namespace


Matrix Property (PDF3DNode)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Matrix Property
Gets or sets the 3D transformation matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Matrix As Double()
'Usage

Dim instance As PDF3DNode
Dim value() As Double

instance.Matrix = value

value = instance.Matrix
public double[] Matrix {get; set;}
public: __property double[]* get_Matrix();
public: __property void set_Matrix(
   double[]* value
);
public:
property array<double>^ Matrix {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A 12-element 3D transformation matrix that specifies the position and orientation of this node, relative to its parent, in world coordinates.
Remarks
If the array has more than 12 elements, only the first 12 will be considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DNode Class
PDF3DNode Members


Name Property (PDF3DNode)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Name Property
Gets or sets the node name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDF3DNode
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the 3D node (in the 3D content stream) being described by this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DNode Class
PDF3DNode Members


Opacity Property (PDF3DNode)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Opacity Property
Gets or sets the cutting plane opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Double
'Usage

Dim instance As PDF3DNode
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public double Opacity {get; set;}
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
public:
property double Opacity {
   double get();
   void set (    double value);
}

Property Value

A number indicating the opacity of the cutting plane using a standard additive blend mode.
Remarks
The opacity is given in percents, 100 is full opacity, 0 is no opacity.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DNode Class
PDF3DNode Members


Visible Property (PDF3DNode)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Visible Property
Gets or sets a value indicating whether the node is visible or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As PDF3DNode
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

True if the node is visible.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DNode Class
PDF3DNode Members


%%PageItemTitle%%

PDF3DNodeCollection Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class
Defines a collection of PDF actions.
Object Model
PDF3DNodeCollection ClassPDF3DNode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DNodeCollection
   Inherits System.Collections.ObjectModel.Collection(Of PDF3DNode)
'Usage

Dim instance As PDF3DNodeCollection
public class PDF3DNodeCollection : System.Collections.ObjectModel.Collection<PDF3DNode>
public __gc class PDF3DNodeCollection : public System.Collections.ObjectModel.Collection<PDF3DNode>
public ref class PDF3DNodeCollection : public System.Collections.ObjectModel.Collection<PDF3DNode>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Annotations.PDF3DNodeCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DNodeCollection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DNodeCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

The following tables list the members exposed by PDF3DNodeCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Top
See Also

Reference

PDF3DNodeCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DProjection Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjection Class
Defines the mapping of 3D camera coordinates onto the target coordinate system of the annotation.
Object Model
PDF3DProjection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DProjection
   Inherits PDF3DEntity
'Usage

Dim instance As PDF3DProjection
public class PDF3DProjection : PDF3DEntity
public __gc class PDF3DProjection : public PDF3DEntity
public ref class PDF3DProjection : public PDF3DEntity
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DProjection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DProjection Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjection Class

The following tables list the members exposed by PDF3DProjection.

Public Constructors
 | Name | Description
Public Constructor | PDF3DProjection Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ClipStyle | Gets or sets the clipping style for the projection.
Public Property | FarClipDistance | Gets or sets the far clipping distance.
Public Property | FieldOfView | Gets or sets the field of view.
Public Property | NearClipDistance | Gets or sets the near clipping distance.
Public Property | OrthoScaleMode | Gets or sets the scale mode for orthographic projections.
Public Property | Scaling | Gets or sets the projection scaling.
Public Property | Type | Gets or sets the type of the projection.
Top
See Also

Reference

PDF3DProjection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DProjection Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : PDF3DProjection Constructor
Overload List
Overload | Description
PDF3DProjection Constructor() | Initializes a new PDF3DProjection object.
PDF3DProjection Constructor(PDF3DProjectionType) | Initializes a new PDF3DProjection object with the specified projection type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

PDF3DProjection Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class > PDF3DProjection Constructor : PDF3DProjection Constructor()
Initializes a new PDF3DProjection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DProjection()
public PDF3DProjection()
public: PDF3DProjection();
public:
PDF3DProjection();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members
Overload List


%%PageItemTitle%%

PDF3DProjection Constructor(PDF3DProjectionType)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class > PDF3DProjection Constructor : PDF3DProjection Constructor(PDF3DProjectionType)
The projection with
Initializes a new PDF3DProjection object with the specified projection type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal type As PDF3DProjectionType _
)
'Usage

Dim type As PDF3DProjectionType

Dim instance As New PDF3DProjection(type)
public PDF3DProjection(
   PDF3DProjectionType type
)
public: PDF3DProjection(
   PDF3DProjectionType type
)
public:
PDF3DProjection(
   PDF3DProjectionType type
)

Parameters

type
The projection with
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DProjection Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjection Class

For a list of all members of this type, see PDF3DProjection members.

Public Properties
 | Name | Description
Public Property | ClipStyle | Gets or sets the clipping style for the projection.
Public Property | FarClipDistance | Gets or sets the far clipping distance.
Public Property | FieldOfView | Gets or sets the field of view.
Public Property | NearClipDistance | Gets or sets the near clipping distance.
Public Property | OrthoScaleMode | Gets or sets the scale mode for orthographic projections.
Public Property | Scaling | Gets or sets the projection scaling.
Public Property | Type | Gets or sets the type of the projection.
Top
See Also

Reference

PDF3DProjection Class
O2S.Components.PDF4NET.Annotations Namespace


ClipStyle Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : ClipStyle Property
Gets or sets the clipping style for the projection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClipStyle As PDF3DProjectionClipStyle
'Usage

Dim instance As PDF3DProjection
Dim value As PDF3DProjectionClipStyle

instance.ClipStyle = value

value = instance.ClipStyle
public PDF3DProjectionClipStyle ClipStyle {get; set;}
public: __property PDF3DProjectionClipStyle get_ClipStyle();
public: __property void set_ClipStyle(
   PDF3DProjectionClipStyle value
);
public:
property PDF3DProjectionClipStyle ClipStyle {
   PDF3DProjectionClipStyle get();
   void set (    PDF3DProjectionClipStyle value);
}

Property Value

A PDF3DProjectionClipStyle enumeration member specifying the clipping style for the projection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


FarClipDistance Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : FarClipDistance Property
Gets or sets the far clipping distance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FarClipDistance As Double
'Usage

Dim instance As PDF3DProjection
Dim value As Double

instance.FarClipDistance = value

value = instance.FarClipDistance
public double FarClipDistance {get; set;}
public: __property double get_FarClipDistance();
public: __property void set_FarClipDistance(
   double value
);
public:
property double FarClipDistance {
   double get();
   void set (    double value);
}

Property Value

The far clipping distance, expressed in the camera coordinate system.
Remarks
This property has meaning only if ClipStyle property is PDF3DProjectionClipStyle.ExplicitNearFar.
A negative value for this property disables the far clipping.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


FieldOfView Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : FieldOfView Property
Gets or sets the field of view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FieldOfView As Double
'Usage

Dim instance As PDF3DProjection
Dim value As Double

instance.FieldOfView = value

value = instance.FieldOfView
public double FieldOfView {get; set;}
public: __property double get_FieldOfView();
public: __property void set_FieldOfView(
   double value
);
public:
property double FieldOfView {
   double get();
   void set (    double value);
}

Property Value

A number between 0 and 180, inclusive, specifying the field of view of the virtual camera, in degrees.
Remarks
This property has meaning only if Type is PDF3DProjectionType.Perspective.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


NearClipDistance Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : NearClipDistance Property
Gets or sets the near clipping distance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NearClipDistance As Double
'Usage

Dim instance As PDF3DProjection
Dim value As Double

instance.NearClipDistance = value

value = instance.NearClipDistance
public double NearClipDistance {get; set;}
public: __property double get_NearClipDistance();
public: __property void set_NearClipDistance(
   double value
);
public:
property double NearClipDistance {
   double get();
   void set (    double value);
}

Property Value

The near clipping distance, expressed in the camera coordinate system.
Remarks
This property has meaning only if ClipStyle property is PDF3DProjectionClipStyle.ExplicitNearFar or if Type is PDF3DProjectionType.Perspective.
This property must be non-negative for orthographic projections and greater than 0 for perspective projections.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


OrthoScaleMode Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : OrthoScaleMode Property
Gets or sets the scale mode for orthographic projections.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OrthoScaleMode As PDF3DProjectionOrthoScaleMode
'Usage

Dim instance As PDF3DProjection
Dim value As PDF3DProjectionOrthoScaleMode

instance.OrthoScaleMode = value

value = instance.OrthoScaleMode
public PDF3DProjectionOrthoScaleMode OrthoScaleMode {get; set;}
public: __property PDF3DProjectionOrthoScaleMode get_OrthoScaleMode();
public: __property void set_OrthoScaleMode(
   PDF3DProjectionOrthoScaleMode value
);
public:
property PDF3DProjectionOrthoScaleMode OrthoScaleMode {
   PDF3DProjectionOrthoScaleMode get();
   void set (    PDF3DProjectionOrthoScaleMode value);
}

Property Value

A PDF3DProjectionOrthoScaleMode enumeration member specifying a strategy for scaling to fit the near plane’s x and y coordinates onto the annotation’s target coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


Scaling Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : Scaling Property
Gets or sets the projection scaling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Scaling As Double
'Usage

Dim instance As PDF3DProjection
Dim value As Double

instance.Scaling = value

value = instance.Scaling
public double Scaling {get; set;}
public: __property double get_Scaling();
public: __property void set_Scaling(
   double value
);
public:
property double Scaling {
   double get();
   void set (    double value);
}

Property Value

A positive number that specifies the scaling used when projecting the 3D artwork onto the annotation’s target coordinate system.
Remarks
This property has meaning only if Type is PDF3DProjectionType.Perspective.
A negative value for this property specifies default scaling for the projection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


Type Property (PDF3DProjection)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : Type Property
Gets or sets the type of the projection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As PDF3DProjectionType
'Usage

Dim instance As PDF3DProjection
Dim value As PDF3DProjectionType

instance.Type = value

value = instance.Type
public PDF3DProjectionType Type {get; set;}
public: __property PDF3DProjectionType get_Type();
public: __property void set_Type(
   PDF3DProjectionType value
);
public:
property PDF3DProjectionType Type {
   PDF3DProjectionType get();
   void set (    PDF3DProjectionType value);
}

Property Value

A PDF3DProjectionType enumeration member specifying the projection type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


%%PageItemTitle%%

PDF3DRenderMode Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderMode Class
Defines the style in which the 3D artwork is rendered.
Object Model
PDF3DRenderMode ClassPDFRgbColor ClassPDFRgbColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DRenderMode
   Inherits PDF3DEntity
'Usage

Dim instance As PDF3DRenderMode
public class PDF3DRenderMode : PDF3DEntity
public __gc class PDF3DRenderMode : public PDF3DEntity
public ref class PDF3DRenderMode : public PDF3DEntity
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DRenderMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DRenderMode Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DRenderMode Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderMode Class

The following tables list the members exposed by PDF3DRenderMode.

Public Constructors
 | Name | Description
Public Constructor | PDF3DRenderMode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AuxiliaryColor | Gets or sets the auxiliary color.
Public Property | CreaseValue | Gets or sets the crease value.
Public Property | FaceColor | Gets or sets the face color.
Public Property | Opacity | Gets or sets the rendering opacity.
Public Property | Style | Gets or sets the style for rendering the 3D artwork.
Top
See Also

Reference

PDF3DRenderMode Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DRenderMode Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : PDF3DRenderMode Constructor
Overload List
Overload | Description
PDF3DRenderMode Constructor() | Initializes a new PDF3DRenderMode object.
PDF3DRenderMode Constructor(PDF3DRenderStyle) | Initializes a new PDF3DRenderMode object with a new render style.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


%%PageItemTitle%%

PDF3DRenderMode Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class > PDF3DRenderMode Constructor : PDF3DRenderMode Constructor()
Initializes a new PDF3DRenderMode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DRenderMode()
public PDF3DRenderMode()
public: PDF3DRenderMode();
public:
PDF3DRenderMode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members
Overload List


%%PageItemTitle%%

PDF3DRenderMode Constructor(PDF3DRenderStyle)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class > PDF3DRenderMode Constructor : PDF3DRenderMode Constructor(PDF3DRenderStyle)
The rendering style.
Initializes a new PDF3DRenderMode object with a new render style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal style As PDF3DRenderStyle _
)
'Usage

Dim style As PDF3DRenderStyle

Dim instance As New PDF3DRenderMode(style)
public PDF3DRenderMode(
   PDF3DRenderStyle style
)
public: PDF3DRenderMode(
   PDF3DRenderStyle style
)
public:
PDF3DRenderMode(
   PDF3DRenderStyle style
)

Parameters

style
The rendering style.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDF3DRenderMode Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderMode Class

For a list of all members of this type, see PDF3DRenderMode members.

Public Properties
 | Name | Description
Public Property | AuxiliaryColor | Gets or sets the auxiliary color.
Public Property | CreaseValue | Gets or sets the crease value.
Public Property | FaceColor | Gets or sets the face color.
Public Property | Opacity | Gets or sets the rendering opacity.
Public Property | Style | Gets or sets the style for rendering the 3D artwork.
Top
See Also

Reference

PDF3DRenderMode Class
O2S.Components.PDF4NET.Annotations Namespace


AuxiliaryColor Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : AuxiliaryColor Property
Gets or sets the auxiliary color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AuxiliaryColor As PDFRgbColor
'Usage

Dim instance As PDF3DRenderMode
Dim value As PDFRgbColor

instance.AuxiliaryColor = value

value = instance.AuxiliaryColor
public PDFRgbColor AuxiliaryColor {get; set;}
public: __property PDFRgbColor* get_AuxiliaryColor();
public: __property void set_AuxiliaryColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ AuxiliaryColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the auxiliary color to be used when rendering the 3D image.
Remarks
Auxiliary color is used by some of the 3D render styles.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


CreaseValue Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : CreaseValue Property
Gets or sets the crease value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreaseValue As Double
'Usage

Dim instance As PDF3DRenderMode
Dim value As Double

instance.CreaseValue = value

value = instance.CreaseValue
public double CreaseValue {get; set;}
public: __property double get_CreaseValue();
public: __property void set_CreaseValue(
   double value
);
public:
property double CreaseValue {
   double get();
   void set (    double value);
}

Property Value

A number specifying the angle to be used as the crease value to be used when determining silhouette edges.
Remarks
The crease value is specified in degrees, from 0 to 360.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


FaceColor Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : FaceColor Property
Gets or sets the face color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FaceColor As PDFRgbColor
'Usage

Dim instance As PDF3DRenderMode
Dim value As PDFRgbColor

instance.FaceColor = value

value = instance.FaceColor
public PDFRgbColor FaceColor {get; set;}
public: __property PDFRgbColor* get_FaceColor();
public: __property void set_FaceColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ FaceColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the face color to be used when rendering the 3D image.
Remarks
Face color is used only by Illustration render style.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


Opacity Property (PDF3DRenderMode)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : Opacity Property
Gets or sets the rendering opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Opacity As Double
'Usage

Dim instance As PDF3DRenderMode
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public double Opacity {get; set;}
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
public:
property double Opacity {
   double get();
   void set (    double value);
}

Property Value

A number specifying the opacity of the added transparency applied by some render modes.
Remarks
The opacity is given in percents, 100 is full opacity, 0 is no opacity.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


Style Property (PDF3DRenderMode)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : Style Property
Gets or sets the style for rendering the 3D artwork.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Style As PDF3DRenderStyle
'Usage

Dim instance As PDF3DRenderMode
Dim value As PDF3DRenderStyle

instance.Style = value

value = instance.Style
public PDF3DRenderStyle Style {get; set;}
public: __property PDF3DRenderStyle get_Style();
public: __property void set_Style(
   PDF3DRenderStyle value
);
public:
property PDF3DRenderStyle Style {
   PDF3DRenderStyle get();
   void set (    PDF3DRenderStyle value);
}

Property Value

A PDF3DRenderStyle enumeration member specifying the style for rendering the 3D artwork.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


%%PageItemTitle%%

PDF3DStream Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DStream Class
Defines the stream that contains the 3D artwork.
Object Model
PDF3DStream ClassPDF3DAnimation ClassPDFJavaScript ClassPDF3DViewCollection ClassPDF3DView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DStream
   Inherits PDF3DEntity
'Usage

Dim instance As PDF3DStream
public class PDF3DStream : PDF3DEntity
public __gc class PDF3DStream : public PDF3DEntity
public ref class PDF3DStream : public PDF3DEntity
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DStream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DStream Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DStream Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DStream Class

The following tables list the members exposed by PDF3DStream.

Public Constructors
 | Name | Description
Public Constructor | PDF3DStream Constructor | Initializes a new PDF3DStream object.
Top
Public Properties
 | Name | Description
Public Property | Animation | Gets or sets the animation for this 3D artwork.
Public Property | Content | Gets or sets content of this stream.
Public Property | DefaultView | Gets or sets the default view.
Public Property | OnInstantiate | Gets or sets the code to execute when the 3D artwork is instantiated.
Public Property | Views | Gets the list of views for this 3D artwork.
Top
See Also

Reference

PDF3DStream Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DStream Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : PDF3DStream Constructor
Initializes a new PDF3DStream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DStream()
public PDF3DStream()
public: PDF3DStream();
public:
PDF3DStream();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DStream Class
PDF3DStream Members


%%PageItemTitle%% $$Properties$$

PDF3DStream Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DStream Class

For a list of all members of this type, see PDF3DStream members.

Public Properties
 | Name | Description
Public Property | Animation | Gets or sets the animation for this 3D artwork.
Public Property | Content | Gets or sets content of this stream.
Public Property | DefaultView | Gets or sets the default view.
Public Property | OnInstantiate | Gets or sets the code to execute when the 3D artwork is instantiated.
Public Property | Views | Gets the list of views for this 3D artwork.
Top
See Also

Reference

PDF3DStream Class
O2S.Components.PDF4NET.Annotations Namespace


Animation Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : Animation Property
Gets or sets the animation for this 3D artwork.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Animation As PDF3DAnimation
'Usage

Dim instance As PDF3DStream
Dim value As PDF3DAnimation

instance.Animation = value

value = instance.Animation
public PDF3DAnimation Animation {get; set;}
public: __property PDF3DAnimation* get_Animation();
public: __property void set_Animation(
   PDF3DAnimation* value
);
public:
property PDF3DAnimation^ Animation {
   PDF3DAnimation^ get();
   void set (    PDF3DAnimation^ value);
}

Property Value

A PDF3DAnimation object that defines the preferred method that viewer applications should use to drive keyframe animations present in this artwork.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DStream Class
PDF3DStream Members


Content Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : Content Property
Gets or sets content of this stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Content As Byte()
'Usage

Dim instance As PDF3DStream
Dim value() As Byte

instance.Content = value

value = instance.Content
public byte[] Content {get; set;}
public: __property byte[]* get_Content();
public: __property void set_Content(
   byte[]* value
);
public:
property array<byte>^ Content {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array that contains the 3D artwork in U3D format.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DStream Class
PDF3DStream Members


DefaultView Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : DefaultView Property
Gets or sets the default view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultView As Integer
'Usage

Dim instance As PDF3DStream
Dim value As Integer

instance.DefaultView = value

value = instance.DefaultView
public int DefaultView {get; set;}
public: __property int get_DefaultView();
public: __property void set_DefaultView(
   int value
);
public:
property int DefaultView {
   int get();
   void set (    int value);
}

Property Value

Index in Views collection.
Remarks
If there are no views, this value is ignored. If the value is outside of the valid range, the first view is considered to be default.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DStream Class
PDF3DStream Members


OnInstantiate Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : OnInstantiate Property
Gets or sets the code to execute when the 3D artwork is instantiated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OnInstantiate As PDFJavaScript
'Usage

Dim instance As PDF3DStream
Dim value As PDFJavaScript

instance.OnInstantiate = value

value = instance.OnInstantiate
public PDFJavaScript OnInstantiate {get; set;}
public: __property PDFJavaScript* get_OnInstantiate();
public: __property void set_OnInstantiate(
   PDFJavaScript* value
);
public:
property PDFJavaScript^ OnInstantiate {
   PDFJavaScript^ get();
   void set (    PDFJavaScript^ value);
}

Property Value

Javascript code to be executed when the 3D artwork is instantiated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DStream Class
PDF3DStream Members


Views Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : Views Property
Gets the list of views for this 3D artwork.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Views As PDF3DViewCollection
'Usage

Dim instance As PDF3DStream
Dim value As PDF3DViewCollection

value = instance.Views
public PDF3DViewCollection Views {get;}
public: __property PDF3DViewCollection* get_Views();
public:
property PDF3DViewCollection^ Views {
   PDF3DViewCollection^ get();
}

Property Value

A list of PDF3DViews objects available for this 3D artwork.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DStream Class
PDF3DStream Members


%%PageItemTitle%%

PDF3DView Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DView Class
Defines the parameters to be applied to the virtual camera associated with a 3D annotation.
Object Model
PDF3DView ClassPDF3DBackground ClassPDF3DCrossSectionCollection ClassPDF3DCrossSection ClassPDF3DLightingScheme ClassPDF3DNodeCollection ClassPDF3DNode ClassPDF3DProjection ClassPDF3DRenderMode Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DView
   Inherits PDF3DEntity
'Usage

Dim instance As PDF3DView
public class PDF3DView : PDF3DEntity
public __gc class PDF3DView : public PDF3DEntity
public ref class PDF3DView : public PDF3DEntity
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DView Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DView Class

The following tables list the members exposed by PDF3DView.

Public Constructors
 | Name | Description
Public Constructor | PDF3DView Constructor | Initializes a new PDF3DView object.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the background for this view.
Public Property | CameraToWorldMatrix | Gets or sets the 3D transformation matrix.
Public Property | CenterOfOrbit | Gets or sets the center of orbit for 3D artwork.
Public Property | CrossSections | Gets the list of cross sections for this view.
Public Property | ExternalName | Gets or sets the view's external name.
Public Property | InternalName | Gets or sets the view's internal name.
Public Property | LightingScheme | Gets or sets the rendering mode for this view.
Public Property | Nodes | Gets the list of 3D nodes for this view.
Public Property | Projection | Gets or sets the projection for this view.
Public Property | RenderMode | Gets or sets the rendering mode for this view.
Public Property | ResetNodesState | Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node dictionaries.
Public Property | ViewNodeName | Gets or sets the name of the view node.
Top
See Also

Reference

PDF3DView Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DView Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : PDF3DView Constructor
Initializes a new PDF3DView object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF3DView()
public PDF3DView()
public: PDF3DView();
public:
PDF3DView();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%% $$Properties$$

PDF3DView Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DView Class

For a list of all members of this type, see PDF3DView members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the background for this view.
Public Property | CameraToWorldMatrix | Gets or sets the 3D transformation matrix.
Public Property | CenterOfOrbit | Gets or sets the center of orbit for 3D artwork.
Public Property | CrossSections | Gets the list of cross sections for this view.
Public Property | ExternalName | Gets or sets the view's external name.
Public Property | InternalName | Gets or sets the view's internal name.
Public Property | LightingScheme | Gets or sets the rendering mode for this view.
Public Property | Nodes | Gets the list of 3D nodes for this view.
Public Property | Projection | Gets or sets the projection for this view.
Public Property | RenderMode | Gets or sets the rendering mode for this view.
Public Property | ResetNodesState | Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node dictionaries.
Public Property | ViewNodeName | Gets or sets the name of the view node.
Top
See Also

Reference

PDF3DView Class
O2S.Components.PDF4NET.Annotations Namespace


Background Property (PDF3DView)

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : Background Property
Gets or sets the background for this view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Background As PDF3DBackground
'Usage

Dim instance As PDF3DView
Dim value As PDF3DBackground

instance.Background = value

value = instance.Background
public PDF3DBackground Background {get; set;}
public: __property PDF3DBackground* get_Background();
public: __property void set_Background(
   PDF3DBackground* value
);
public:
property PDF3DBackground^ Background {
   PDF3DBackground^ get();
   void set (    PDF3DBackground^ value);
}

Property Value

A PDF3DBackground object that defines the background over which the 3D artwork is to be drawn.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


CameraToWorldMatrix Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : CameraToWorldMatrix Property
Gets or sets the 3D transformation matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CameraToWorldMatrix As Double()
'Usage

Dim instance As PDF3DView
Dim value() As Double

instance.CameraToWorldMatrix = value

value = instance.CameraToWorldMatrix
public double[] CameraToWorldMatrix {get; set;}
public: __property double[]* get_CameraToWorldMatrix();
public: __property void set_CameraToWorldMatrix(
   double[]* value
);
public:
property array<double>^ CameraToWorldMatrix {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A 12-element 3D transformation matrix that specifies a position and orientation of the camera in world coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


CenterOfOrbit Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : CenterOfOrbit Property
Gets or sets the center of orbit for 3D artwork.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterOfOrbit As Double
'Usage

Dim instance As PDF3DView
Dim value As Double

instance.CenterOfOrbit = value

value = instance.CenterOfOrbit
public double CenterOfOrbit {get; set;}
public: __property double get_CenterOfOrbit();
public: __property void set_CenterOfOrbit(
   double value
);
public:
property double CenterOfOrbit {
   double get();
   void set (    double value);
}

Property Value

A non-negative number indicating a distance in the camera coordinate system along the z axis to the center of orbit for this view.
Remarks
If this value is negative, the viewer application must determine the center of orbit.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


CrossSections Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : CrossSections Property
Gets the list of cross sections for this view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CrossSections As PDF3DCrossSectionCollection
'Usage

Dim instance As PDF3DView
Dim value As PDF3DCrossSectionCollection

value = instance.CrossSections
public PDF3DCrossSectionCollection CrossSections {get;}
public: __property PDF3DCrossSectionCollection* get_CrossSections();
public:
property PDF3DCrossSectionCollection^ CrossSections {
   PDF3DCrossSectionCollection^ get();
}

Property Value

A list of PDF3DCrossSection objects available for this view.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


ExternalName Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : ExternalName Property
Gets or sets the view's external name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExternalName As String
'Usage

Dim instance As PDF3DView
Dim value As String

instance.ExternalName = value

value = instance.ExternalName
public string ExternalName {get; set;}
public: __property string* get_ExternalName();
public: __property void set_ExternalName(
   string* value
);
public:
property String^ ExternalName {
   String^ get();
   void set (    String^ value);
}

Property Value

The external name of the view, suitable for presentation in a user interface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


InternalName Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : InternalName Property
Gets or sets the view's internal name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InternalName As String
'Usage

Dim instance As PDF3DView
Dim value As String

instance.InternalName = value

value = instance.InternalName
public string InternalName {get; set;}
public: __property string* get_InternalName();
public: __property void set_InternalName(
   string* value
);
public:
property String^ InternalName {
   String^ get();
   void set (    String^ value);
}

Property Value

The internal name of the view, used to refer to the view from other objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


LightingScheme Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : LightingScheme Property
Gets or sets the rendering mode for this view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LightingScheme As PDF3DLightingScheme
'Usage

Dim instance As PDF3DView
Dim value As PDF3DLightingScheme

instance.LightingScheme = value

value = instance.LightingScheme
public PDF3DLightingScheme LightingScheme {get; set;}
public: __property PDF3DLightingScheme* get_LightingScheme();
public: __property void set_LightingScheme(
   PDF3DLightingScheme* value
);
public:
property PDF3DLightingScheme^ LightingScheme {
   PDF3DLightingScheme^ get();
   void set (    PDF3DLightingScheme^ value);
}

Property Value

A PDF3DLightingScheme object that specifies the lighting scheme to be used when rendering 3D artwork with this view.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


Nodes Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : Nodes Property
Gets the list of 3D nodes for this view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Nodes As PDF3DNodeCollection
'Usage

Dim instance As PDF3DView
Dim value As PDF3DNodeCollection

value = instance.Nodes
public PDF3DNodeCollection Nodes {get;}
public: __property PDF3DNodeCollection* get_Nodes();
public:
property PDF3DNodeCollection^ Nodes {
   PDF3DNodeCollection^ get();
}

Property Value

A list of PDF3DNode objects available for this view.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


Projection Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : Projection Property
Gets or sets the projection for this view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Projection As PDF3DProjection
'Usage

Dim instance As PDF3DView
Dim value As PDF3DProjection

instance.Projection = value

value = instance.Projection
public PDF3DProjection Projection {get; set;}
public: __property PDF3DProjection* get_Projection();
public: __property void set_Projection(
   PDF3DProjection* value
);
public:
property PDF3DProjection^ Projection {
   PDF3DProjection^ get();
   void set (    PDF3DProjection^ value);
}

Property Value

A PDF3DProjection object that defines the projection of coordinates in the 3D artwork (already transformed into camera coordinates) onto the target coordinate system of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


RenderMode Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : RenderMode Property
Gets or sets the rendering mode for this view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RenderMode As PDF3DRenderMode
'Usage

Dim instance As PDF3DView
Dim value As PDF3DRenderMode

instance.RenderMode = value

value = instance.RenderMode
public PDF3DRenderMode RenderMode {get; set;}
public: __property PDF3DRenderMode* get_RenderMode();
public: __property void set_RenderMode(
   PDF3DRenderMode* value
);
public:
property PDF3DRenderMode^ RenderMode {
   PDF3DRenderMode^ get();
   void set (    PDF3DRenderMode^ value);
}

Property Value

A PDF3DRenderMode object that specifies the render mode to use when rendering 3D artwork with this view.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


ResetNodesState Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : ResetNodesState Property
Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node dictionaries.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResetNodesState As Boolean
'Usage

Dim instance As PDF3DView
Dim value As Boolean

instance.ResetNodesState = value

value = instance.ResetNodesState
public bool ResetNodesState {get; set;}
public: __property bool get_ResetNodesState();
public: __property void set_ResetNodesState(
   bool value
);
public:
property bool ResetNodesState {
   bool get();
   void set (    bool value);
}

Property Value

True if the artwork’s 3D node parameters are restored to their original states and then the dictionaries specified by the Nodes collection are applied.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


ViewNodeName Property

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : ViewNodeName Property
Gets or sets the name of the view node.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ViewNodeName As String
'Usage

Dim instance As PDF3DView
Dim value As String

instance.ViewNodeName = value

value = instance.ViewNodeName
public string ViewNodeName {get; set;}
public: __property string* get_ViewNodeName();
public: __property void set_ViewNodeName(
   string* value
);
public:
property String^ ViewNodeName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of a view node in the 3D content stream.
Remarks
The view node in the content stream defines all the properties for viewing the 3D artwork. If both ViewNodeName and CameraToWorldMatrix are specified, then ViewNodeName takes precedence.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%%

PDF3DViewCollection Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class
Defines a collection of PDF actions.
Object Model
PDF3DViewCollection ClassPDF3DView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF3DViewCollection
   Inherits System.Collections.ObjectModel.Collection(Of PDF3DView)
'Usage

Dim instance As PDF3DViewCollection
public class PDF3DViewCollection : System.Collections.ObjectModel.Collection<PDF3DView>
public __gc class PDF3DViewCollection : public System.Collections.ObjectModel.Collection<PDF3DView>
public ref class PDF3DViewCollection : public System.Collections.ObjectModel.Collection<PDF3DView>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Annotations.PDF3DViewCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DViewCollection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDF3DViewCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

The following tables list the members exposed by PDF3DViewCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Top
See Also

Reference

PDF3DViewCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class
Defines the base class for all annotations available in a PDF file.
Object Model
PDFAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAnnotation
'Usage

Dim instance As PDFAnnotation
public class PDFAnnotation
public __gc class PDFAnnotation
public ref class PDFAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFFlashAnnotation
O2S.Components.PDF4NET.Annotations.PDFFreeTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFLinkAnnotation
O2S.Components.PDF4NET.Annotations.PDFMovieAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

The following tables list the members exposed by PDFAnnotation.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color.
Public Property | Contents | Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date.
Public Property | Dictionary | Gets the annotation dictionary.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Flags | Gets or sets the annotation flags.
Public Property | ID | Gets or sets the annotation ID.
Public Property | ModifiedDate | Gets or sets the annotation modified date.
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle.
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle.
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle.
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle.
Public Property | Page | Gets the page that includes this annotation.
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed.
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee.
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened.
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Rotation | Gets or sets the annotation rotation angle.
Public Property | Type | Gets the annotation type.
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation.
Top
See Also

Reference

PDFAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

For a list of all members of this type, see PDFAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation.
Top
See Also

Reference

PDFAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Flatten Method (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Flatten Method
Flattens the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Flatten()
'Usage

Dim instance As PDFAnnotation

instance.Flatten()
public virtual void Flatten()
public: virtual void Flatten();
public:
virtual void Flatten();
Remarks
This operation writes the annotation appearance to the content and destroys the annotation. Its effects are irreversible. After calling this method the PDFAnnotation object is invalid and should no longer be used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

For a list of all members of this type, see PDFAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color.
Public Property | Contents | Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date.
Public Property | Dictionary | Gets the annotation dictionary.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Flags | Gets or sets the annotation flags.
Public Property | ID | Gets or sets the annotation ID.
Public Property | ModifiedDate | Gets or sets the annotation modified date.
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle.
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle.
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle.
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle.
Public Property | Page | Gets the page that includes this annotation.
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed.
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee.
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened.
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Rotation | Gets or sets the annotation rotation angle.
Public Property | Type | Gets the annotation type.
Top
See Also

Reference

PDFAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public virtual PDFAnnotationAppearance Appearance {get; set;}
public: __property virtual PDFAnnotationAppearance* get_Appearance();
public: __property virtual void set_Appearance(
   PDFAnnotationAppearance* value
);
public:
virtual property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The appearance of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Color Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Color Property
Gets or sets the annotation color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As PDFDeviceColor
'Usage

Dim instance As PDFAnnotation
Dim value As PDFDeviceColor

instance.Color = value

value = instance.Color
public PDFDeviceColor Color {get; set;}
public: __property PDFDeviceColor* get_Color();
public: __property void set_Color(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ Color {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The annotation color.
Remarks
The actual usage of this color depends on the annotation type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Contents Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Contents Property
Gets or sets the annotation contents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Contents As String
'Usage

Dim instance As PDFAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
public virtual string Contents {get; set;}
public: __property virtual string* get_Contents();
public: __property virtual void set_Contents(
   string* value
);
public:
virtual property String^ Contents {
   String^ get();
   void set (    String^ value);
}

Property Value

The text to be displayed for the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


CreationDate Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : CreationDate Property
Gets or sets the annotation creation date.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PDFAnnotation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date when the annotation was created.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Dictionary Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Dictionary Property
Gets the annotation dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFAnnotation
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw annotation dictionary.
Remarks
This property gives you direct access to annotation dictionary and its associated resources. Note: Modifying directly the annotation dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


DisplayRectangle Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : DisplayRectangle Property
Gets or sets the display rectangle of this annotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayRectangle As DisplayRectangle
'Usage

Dim instance As PDFAnnotation
Dim value As DisplayRectangle

instance.DisplayRectangle = value

value = instance.DisplayRectangle
public DisplayRectangle DisplayRectangle {get; set;}
public: __property DisplayRectangle* get_DisplayRectangle();
public: __property void set_DisplayRectangle(
   DisplayRectangle* value
);
public:
property DisplayRectangle^ DisplayRectangle {
   DisplayRectangle^ get();
   void set (    DisplayRectangle^ value);
}

Property Value

A System.Drawing.RectangleF object specifying the position and size of the annotation.
Remarks
The display rectangle is relative to the top left corner of the page, as opposed to PDFRectangle which is relative to bottom left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Flags Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Flags Property
Gets or sets the annotation flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flags As PDFAnnotationFlags
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAnnotationFlags

instance.Flags = value

value = instance.Flags
public PDFAnnotationFlags Flags {get; set;}
public: __property PDFAnnotationFlags get_Flags();
public: __property void set_Flags(
   PDFAnnotationFlags value
);
public:
property PDFAnnotationFlags Flags {
   PDFAnnotationFlags get();
   void set (    PDFAnnotationFlags value);
}

Property Value

Flags the control the annotation behavior.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


ID Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : ID Property
Gets or sets the annotation ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ID As String
'Usage

Dim instance As PDFAnnotation
Dim value As String

instance.ID = value

value = instance.ID
public string ID {get; set;}
public: __property string* get_ID();
public: __property void set_ID(
   string* value
);
public:
property String^ ID {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


ModifiedDate Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : ModifiedDate Property
Gets or sets the annotation modified date.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModifiedDate As Date
'Usage

Dim instance As PDFAnnotation
Dim value As Date

instance.ModifiedDate = value

value = instance.ModifiedDate
public DateTime ModifiedDate {get; set;}
public: __property DateTime get_ModifiedDate();
public: __property void set_ModifiedDate(
   DateTime value
);
public:
property DateTime ModifiedDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The most recent date when the annotation was modified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


MouseDown Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : MouseDown Property
Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseDown As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseDown = value

value = instance.MouseDown
public PDFAction MouseDown {get; set;}
public: __property PDFAction* get_MouseDown();
public: __property void set_MouseDown(
   PDFAction* value
);
public:
property PDFAction^ MouseDown {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the mouse is pressed in the annotation rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


MouseEnter Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : MouseEnter Property
Gets or sets the action that is executed when the mouse enters the annotation rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseEnter As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseEnter = value

value = instance.MouseEnter
public PDFAction MouseEnter {get; set;}
public: __property PDFAction* get_MouseEnter();
public: __property void set_MouseEnter(
   PDFAction* value
);
public:
property PDFAction^ MouseEnter {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the mouse enters the annotation rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


MouseLeave Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : MouseLeave Property
Gets or sets the action that is executed when the mouse leaves the annotation rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseLeave As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseLeave = value

value = instance.MouseLeave
public PDFAction MouseLeave {get; set;}
public: __property PDFAction* get_MouseLeave();
public: __property void set_MouseLeave(
   PDFAction* value
);
public:
property PDFAction^ MouseLeave {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the mouse leaves the annotation rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


MouseUp Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : MouseUp Property
Gets or sets the action that is executed when the mouse is released in the annotation rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseUp As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseUp = value

value = instance.MouseUp
public PDFAction MouseUp {get; set;}
public: __property PDFAction* get_MouseUp();
public: __property void set_MouseUp(
   PDFAction* value
);
public:
property PDFAction^ MouseUp {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the mouse is released in the annotation rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Page Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Page Property
Gets the page that includes this annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PDFPage
'Usage

Dim instance As PDFAnnotation
Dim value As PDFPage

value = instance.Page
public PDFPage Page {get;}
public: __property PDFPage* get_Page();
public:
property PDFPage^ Page {
   PDFPage^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PageClose Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PageClose Property
Gets or sets the action to be performed when the page containing the annotation is closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageClose As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageClose = value

value = instance.PageClose
public PDFAction PageClose {get; set;}
public: __property PDFAction* get_PageClose();
public: __property void set_PageClose(
   PDFAction* value
);
public:
property PDFAction^ PageClose {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page containing the annotation is closed.
Remarks
This action is executed before the page's Close action has been executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PageHide Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PageHide Property
Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageHide As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageHide = value

value = instance.PageHide
public PDFAction PageHide {get; set;}
public: __property PDFAction* get_PageHide();
public: __property void set_PageHide(
   PDFAction* value
);
public:
property PDFAction^ PageHide {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PageOpen Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PageOpen Property
Gets or sets the action to be performed when the page containing the annotation is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageOpen As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageOpen = value

value = instance.PageOpen
public PDFAction PageOpen {get; set;}
public: __property PDFAction* get_PageOpen();
public: __property void set_PageOpen(
   PDFAction* value
);
public:
property PDFAction^ PageOpen {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page containing the annotation is opened.
Remarks
This action is executed after the page's Open action has been executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PageShow Property

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PageShow Property
Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageShow As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageShow = value

value = instance.PageShow
public PDFAction PageShow {get; set;}
public: __property PDFAction* get_PageShow();
public: __property void set_PageShow(
   PDFAction* value
);
public:
property PDFAction^ PageShow {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PDFRectangle Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public virtual PDFRectangle PDFRectangle {get; set;}
public: __property virtual PDFRectangle* get_PDFRectangle();
public: __property virtual void set_PDFRectangle(
   PDFRectangle* value
);
public:
virtual property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get();
   void set (    PDFRectangle^ value);
}

Property Value

The annotation rectangle specified in the default PDF coordinate system, as opposed to Rectangle which specifies the annotation rectangle relative to top left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Rectangle Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Rectangle Property
Gets or sets the display rectangle of this annotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rectangle As RectangleF
'Usage

Dim instance As PDFAnnotation
Dim value As RectangleF

instance.Rectangle = value

value = instance.Rectangle
public RectangleF Rectangle {get; set;}
public: __property RectangleF get_Rectangle();
public: __property void set_Rectangle(
   RectangleF value
);
public:
property RectangleF Rectangle {
   RectangleF get();
   void set (    RectangleF value);
}

Property Value

A System.Drawing.RectangleF object specifying the position and size of the annotation.
Remarks
The display rectangle is relative to the top left corner of the page, as opposed to PDFRectangle which is relative to bottom left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Rotation Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public virtual PDFRotationMode Rotation {get; set;}
public: __property virtual PDFRotationMode get_Rotation();
public: __property virtual void set_Rotation(
   PDFRotationMode value
);
public:
virtual property PDFRotationMode Rotation {
   PDFRotationMode get();
   void set (    PDFRotationMode value);
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Type Property (PDFAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Type Property
Gets the annotation type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PDFAnnotationType
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAnnotationType

value = instance.Type
public PDFAnnotationType Type {get;}
public: __property PDFAnnotationType get_Type();
public:
property PDFAnnotationType Type {
   PDFAnnotationType get();
}

Property Value

The annotation type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

PDFAnnotationAppearance Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationAppearance Class
Defines the base class for all annotation appearances.
Object Model
PDFAnnotationAppearance ClassPDFBasicCanvas ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAnnotationAppearance
   Inherits O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
'Usage

Dim instance As PDFAnnotationAppearance
public class PDFAnnotationAppearance : O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
public __gc class PDFAnnotationAppearance : public O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
public ref class PDFAnnotationAppearance : public O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDF4NET.Annotations.PDFImageAppearance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationAppearance Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationAppearance Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationAppearance Class

The following tables list the members exposed by PDFAnnotationAppearance.

Public Constructors
 | Name | Description
Public Constructor | PDFAnnotationAppearance Constructor | Initializes a new PDFAnnotationAppearance object.
Top
Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Dictionary | Gets the form XObject dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top
See Also

Reference

PDFAnnotationAppearance Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFAnnotationAppearance Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationAppearance Class : PDFAnnotationAppearance Constructor
Initializes a new PDFAnnotationAppearance object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFAnnotationAppearance()
public PDFAnnotationAppearance()
public: PDFAnnotationAppearance();
public:
PDFAnnotationAppearance();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationAppearance Class
PDFAnnotationAppearance Members


%%PageItemTitle%%

PDFAnnotationBorder Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationBorder Class
Defines the border of an annotation.
Object Model
PDFAnnotationBorder Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAnnotationBorder
'Usage

Dim instance As PDFAnnotationBorder
public class PDFAnnotationBorder
public __gc class PDFAnnotationBorder
public ref class PDFAnnotationBorder
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotationBorder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationBorder Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationBorder Class

The following tables list the members exposed by PDFAnnotationBorder.

Public Constructors
 | Name | Description
Public Constructor | PDFAnnotationBorder Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BorderStyle | Gets or sets the style of annotation's border.
Public Property | Width | Gets or sets the border width.
Top
See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFAnnotationBorder Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : PDFAnnotationBorder Constructor
Overload List
Overload | Description
PDFAnnotationBorder Constructor() | Initializes a new PDFAnnotationBorder object.
PDFAnnotationBorder Constructor(Double,PDFBorderStyle) | Initializes a new PDFAnnotationBorder object with the given width and style.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%%

PDFAnnotationBorder Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class > PDFAnnotationBorder Constructor : PDFAnnotationBorder Constructor()
Initializes a new PDFAnnotationBorder object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFAnnotationBorder()
public PDFAnnotationBorder()
public: PDFAnnotationBorder();
public:
PDFAnnotationBorder();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members
Overload List


%%PageItemTitle%%

PDFAnnotationBorder Constructor(Double,PDFBorderStyle)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class > PDFAnnotationBorder Constructor : PDFAnnotationBorder Constructor(Double,PDFBorderStyle)
the width of annotation's border.
the style of annotation's border.
Initializes a new PDFAnnotationBorder object with the given width and style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal style As PDFBorderStyle _
)
'Usage

Dim width As Double
Dim style As PDFBorderStyle

Dim instance As New PDFAnnotationBorder(width, style)
public PDFAnnotationBorder(
   double width,
   PDFBorderStyle style
)
public: PDFAnnotationBorder(
   double width,
   PDFBorderStyle style
)
public:
PDFAnnotationBorder(
   double width,
   PDFBorderStyle style
)

Parameters

width
the width of annotation's border.
style
the style of annotation's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFAnnotationBorder Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationBorder Class

For a list of all members of this type, see PDFAnnotationBorder members.

Public Properties
 | Name | Description
Public Property | BorderStyle | Gets or sets the style of annotation's border.
Public Property | Width | Gets or sets the border width.
Top
See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDF4NET.Annotations Namespace


BorderStyle Property (PDFAnnotationBorder)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : BorderStyle Property
Gets or sets the style of annotation's border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderStyle As PDFBorderStyle
'Usage

Dim instance As PDFAnnotationBorder
Dim value As PDFBorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public PDFBorderStyle BorderStyle {get; set;}
public: __property PDFBorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   PDFBorderStyle value
);
public:
property PDFBorderStyle BorderStyle {
   PDFBorderStyle get();
   void set (    PDFBorderStyle value);
}

Property Value

A BorderStyle enumeration member specifying the style of the annotation's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


Width Property (PDFAnnotationBorder)

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : Width Property
Gets or sets the border width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFAnnotationBorder
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the border.
Remarks
0 means no border is displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%%

PDFAnnotationCollection Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationCollection Class
Defines a collection of annotations.
Object Model
PDFAnnotationCollection ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAnnotationCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFAnnotation,PDFPage)
'Usage

Dim instance As PDFAnnotationCollection
public class PDFAnnotationCollection : O2S.Components.PDF4NET.PDFCollection<PDFAnnotation,PDFPage>
public __gc class PDFAnnotationCollection : public O2S.Components.PDF4NET.PDFCollection<PDFAnnotation,PDFPage>
public ref class PDFAnnotationCollection : public O2S.Components.PDF4NET.PDFCollection<PDFAnnotation,PDFPage>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Annotations.PDFAnnotationCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationCollection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationCollection Class

The following tables list the members exposed by PDFAnnotationCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top
See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFAnnotationCollection Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationCollection Class

For a list of all members of this type, see PDFAnnotationCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top
See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDF4NET.Annotations Namespace


MoveItem Method

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationCollection Class : MoveItem Method
Item to move.
Number of positions to move.
Moves the item up or down to the beginning or end of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MoveItem( _
   ByVal item As PDFAnnotation, _
   ByVal step As Integer _
) As Boolean
'Usage

Dim instance As PDFAnnotationCollection
Dim item As PDFAnnotation
Dim step As Integer
Dim value As Boolean

value = instance.MoveItem(item, step)
public bool MoveItem(
   PDFAnnotation item,
   int step
)
public: bool MoveItem(
   PDFAnnotation* item,
   int step
)
public:
bool MoveItem(
   PDFAnnotation^ item,
   int step
)

Parameters

item
Item to move.
step
Number of positions to move.

Return Value

True if the item has been moved.
Remarks
It the new position is outside the collection, the item is not moved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationCollection Class
PDFAnnotationCollection Members


%%PageItemTitle%%

PDFBaseMarkupAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class
Defines the base class for all markup type annotations.
Object Model
PDFBaseMarkupAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFBaseMarkupAnnotation
   Inherits PDFAnnotation
'Usage

Dim instance As PDFBaseMarkupAnnotation
public class PDFBaseMarkupAnnotation : PDFAnnotation
public __gc class PDFBaseMarkupAnnotation : public PDFAnnotation
public ref class PDFBaseMarkupAnnotation : public PDFAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotation
O2S.Components.PDF4NET.Annotations.PDFInkAnnotation
O2S.Components.PDF4NET.Annotations.PDFLineAnnotation
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBaseMarkupAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFBaseMarkupAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

The following tables list the members exposed by PDFBaseMarkupAnnotation.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFBaseMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFBaseMarkupAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

For a list of all members of this type, see PDFBaseMarkupAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFBaseMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Author Property (PDFBaseMarkupAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Author Property
Gets or sets the annotation author.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PDFBaseMarkupAnnotation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the person who created the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


InReplyTo Property

O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : InReplyTo Property
Gets or sets the annotation that this annotation is "in reply to".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InReplyTo As PDFAnnotation
'Usage

Dim instance As PDFBaseMarkupAnnotation
Dim value As PDFAnnotation

instance.InReplyTo = value

value = instance.InReplyTo
public PDFAnnotation InReplyTo {get; set;}
public: __property PDFAnnotation* get_InReplyTo();
public: __property void set_InReplyTo(
   PDFAnnotation* value
);
public:
property PDFAnnotation^ InReplyTo {
   PDFAnnotation^ get();
   void set (    PDFAnnotation^ value);
}

Property Value

The parent annotation that this annotation is "in reply to".
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


Opacity Property (PDFBaseMarkupAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Opacity Property
Gets or sets the annotation opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Opacity As Double
'Usage

Dim instance As PDFBaseMarkupAnnotation
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public virtual double Opacity {get; set;}
public: __property virtual double get_Opacity();
public: __property virtual void set_Opacity(
   double value
);
public:
virtual property double Opacity {
   double get();
   void set (    double value);
}

Property Value

The opacity of the annotation in percents.
Remarks
100 means total opacity, 0 means fully transparent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


Subject Property (PDFBaseMarkupAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Subject Property
Gets or sets the annotation subject.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Subject As String
'Usage

Dim instance As PDFBaseMarkupAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
public string Subject {get; set;}
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
public:
property String^ Subject {
   String^ get();
   void set (    String^ value);
}

Property Value

The subject of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


%%PageItemTitle%%

PDFEllipseAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFEllipseAnnotation Class
Defines an ellipse (Circle) annotation.
Object Model
PDFEllipseAnnotation ClassPDFAnnotationAppearance ClassPDFAnnotationBorder ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFDeviceColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFEllipseAnnotation
   Inherits PDFSCAnnotation
'Usage

Dim instance As PDFEllipseAnnotation
public class PDFEllipseAnnotation : PDFSCAnnotation
public __gc class PDFEllipseAnnotation : public PDFSCAnnotation
public ref class PDFEllipseAnnotation : public PDFSCAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFEllipseAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEllipseAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFEllipseAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFEllipseAnnotation Class

The following tables list the members exposed by PDFEllipseAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFEllipseAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from O2S.Components.PDF4NET.Annotations.PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFEllipseAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFEllipseAnnotation Class : PDFEllipseAnnotation Constructor
Overload List
Overload | Description
PDFEllipseAnnotation Constructor() | Initializes a new PDFEllipseAnnotation object.
PDFEllipseAnnotation Constructor(String,String) | Initializes a new PDFEllipseAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEllipseAnnotation Class
PDFEllipseAnnotation Members


%%PageItemTitle%%

PDFEllipseAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFEllipseAnnotation Class > PDFEllipseAnnotation Constructor : PDFEllipseAnnotation Constructor()
Initializes a new PDFEllipseAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFEllipseAnnotation()
public PDFEllipseAnnotation()
public: PDFEllipseAnnotation();
public:
PDFEllipseAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEllipseAnnotation Class
PDFEllipseAnnotation Members
Overload List


%%PageItemTitle%%

PDFEllipseAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFEllipseAnnotation Class > PDFEllipseAnnotation Constructor : PDFEllipseAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFEllipseAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFEllipseAnnotation(author, contents)
public PDFEllipseAnnotation(
   string author,
   string contents
)
public: PDFEllipseAnnotation(
   string* author,
   string* contents
)
public:
PDFEllipseAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEllipseAnnotation Class
PDFEllipseAnnotation Members
Overload List


%%PageItemTitle%%

PDFFileAttachmentAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class
Defines a file attachment annotation.
Object Model
PDFFileAttachmentAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFileAttachmentAnnotation
   Inherits PDFBaseMarkupAnnotation
'Usage

Dim instance As PDFFileAttachmentAnnotation
public class PDFFileAttachmentAnnotation : PDFBaseMarkupAnnotation
public __gc class PDFFileAttachmentAnnotation : public PDFBaseMarkupAnnotation
public ref class PDFFileAttachmentAnnotation : public PDFBaseMarkupAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFFileAttachmentAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

The following tables list the members exposed by PDFFileAttachmentAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFFileAttachmentAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Data | Gets or sets the data stored in the file attachment annotation.
Public Property | Description | Gets or sets the file description.
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | FileName | Gets or sets the file name.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Size | Gets the file size.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Method | Save | Overloaded. Saves the content of the embedded file to the specified file.
Top
See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFFileAttachmentAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : PDFFileAttachmentAnnotation Constructor
Overload List
Overload | Description
PDFFileAttachmentAnnotation Constructor() | Initializes a new PDFFileAttachmentAnnotation object.
PDFFileAttachmentAnnotation Constructor(String,String) | Initializes a new PDFFileAttachmentAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

PDFFileAttachmentAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > PDFFileAttachmentAnnotation Constructor : PDFFileAttachmentAnnotation Constructor()
Initializes a new PDFFileAttachmentAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFileAttachmentAnnotation()
public PDFFileAttachmentAnnotation()
public: PDFFileAttachmentAnnotation();
public:
PDFFileAttachmentAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


%%PageItemTitle%%

PDFFileAttachmentAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > PDFFileAttachmentAnnotation Constructor : PDFFileAttachmentAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFFileAttachmentAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFFileAttachmentAnnotation(author, contents)
public PDFFileAttachmentAnnotation(
   string author,
   string contents
)
public: PDFFileAttachmentAnnotation(
   string* author,
   string* contents
)
public:
PDFFileAttachmentAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFFileAttachmentAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

For a list of all members of this type, see PDFFileAttachmentAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Method | Save | Overloaded. Saves the content of the embedded file to the specified file.
Top
See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Save Method (PDFFileAttachmentAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Save Method
Saves the content of the embedded file to the specified file.
Overload List
Overload | Description
Save(String) | Saves the content of the embedded file to the specified file.
Save(Stream) | Saves the content of the embedded file to the specified stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Save(String) Method

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > Save Method : Save(String) Method
Physical path where the embedded file should be saved.
Saves the content of the embedded file to the specified file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As String _
)
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim fileName As String

instance.Save(fileName)
public void Save(
   string fileName
)
public: void Save(
   string* fileName
)
public:
void Save(
   String^ fileName
)

Parameters

fileName
Physical path where the embedded file should be saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


Save(Stream) Method

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > Save Method : Save(Stream) Method
Stream where the embedded file should be saved.
Saves the content of the embedded file to the specified stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim stream As Stream

instance.Save(stream)
public void Save(
   Stream stream
)
public: void Save(
   Stream* stream
)
public:
void Save(
   Stream^ stream
)

Parameters

stream
Stream where the embedded file should be saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFileAttachmentAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

For a list of all members of this type, see PDFFileAttachmentAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Data | Gets or sets the data stored in the file attachment annotation.
Public Property | Description | Gets or sets the file description.
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | FileName | Gets or sets the file name.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Size | Gets the file size.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property (PDFFileAttachmentAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the text annotation icon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Data Property (PDFFileAttachmentAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Data Property
Gets or sets the data stored in the file attachment annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Data As Byte()
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value() As Byte

instance.Data = value

value = instance.Data
public byte[] Data {get; set;}
public: __property byte[]* get_Data();
public: __property void set_Data(
   byte[]* value
);
public:
property array<byte>^ Data {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The content of the file attachment annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Description Property (PDFFileAttachmentAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Description Property
Gets or sets the file description.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

The description of the file stored in the attachment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


FileName Property (PDFFileAttachmentAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : FileName Property
Gets or sets the file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the file whose content is stored in Data property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Icon Property (PDFFileAttachmentAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Icon Property
Gets or sets the annotation icon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Icon As PDFFileAttachmentAnnotationIcon
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As PDFFileAttachmentAnnotationIcon

instance.Icon = value

value = instance.Icon
public PDFFileAttachmentAnnotationIcon Icon {get; set;}
public: __property PDFFileAttachmentAnnotationIcon get_Icon();
public: __property void set_Icon(
   PDFFileAttachmentAnnotationIcon value
);
public:
property PDFFileAttachmentAnnotationIcon Icon {
   PDFFileAttachmentAnnotationIcon get();
   void set (    PDFFileAttachmentAnnotationIcon value);
}

Property Value

The icon to be displayed for the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


IconName Property (PDFFileAttachmentAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : IconName Property
Gets or sets the icon name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IconName As String
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
public string IconName {get; set;}
public: __property string* get_IconName();
public: __property void set_IconName(
   string* value
);
public:
property String^ IconName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the file attachment's icon.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
This property lets you set a custom name for your user defined appearances.
If the Icon property to any of the PDFFileAttachmentAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFFileAttachmentAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFFileAttachmentAnnotationIcon.Custom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Size Property (PDFFileAttachmentAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Size Property
Gets the file size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Size As Integer
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As Integer

value = instance.Size
public int Size {get;}
public: __property int get_Size();
public:
property int Size {
   int get();
}

Property Value

The size of the file stored in Data property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

PDFFlashAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFFlashAnnotation Class
Defines a flash annotation in a PDF file.
Object Model
PDFFlashAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFFormXObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFlashAnnotation
   Inherits PDFAnnotation
'Usage

Dim instance As PDFFlashAnnotation
public class PDFFlashAnnotation : PDFAnnotation
public __gc class PDFFlashAnnotation : public PDFAnnotation
public ref class PDFFlashAnnotation : public PDFAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFFlashAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFlashAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFFlashAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFFlashAnnotation Class

The following tables list the members exposed by PDFFlashAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFFlashAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ActivationCondition | Gets or sets the activation condition for the flash annotation.
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DeactivationCondition | Gets or sets the deactivation condition for the rich media annotation.
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | FlashData | Gets or sets the Flash content associated with this annotation.
Public Property | FlashFile | Gets or sets the movie file associated with this annotation.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Poster | Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFlashAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFFlashAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFFlashAnnotation Class : PDFFlashAnnotation Constructor
Overload List
Overload | Description
PDFFlashAnnotation Constructor() | Initializes a new PDFFlashAnnotation object.
PDFFlashAnnotation Constructor(String,PDFFormXObject) | Initializes a new PDFFlashAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFlashAnnotation Class
PDFFlashAnnotation Members


%%PageItemTitle%%

PDFFlashAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFFlashAnnotation Class > PDFFlashAnnotation Constructor : PDFFlashAnnotation Constructor()
Initializes a new PDFFlashAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFlashAnnotation()
public PDFFlashAnnotation()
public: PDFFlashAnnotation();
public:
PDFFlashAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFlashAnnotation Class
PDFFlashAnnotation Members
Overload List


%%PageItemTitle%%

PDFFlashAnnotation Constructor(String,PDFFormXObject)

O2S.Components.PDF4NET.Annotations Namespace > PDFFlashAnnotation Class > PDFFlashAnnotation Constructor : PDFFlashAnnotation Constructor(String,PDFFormXObject)
a static image to represent the annotation when the movie is not playing.
Initializes a new PDFFlashAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal flashFile As String, _
   ByVal poster As PDFFormXObject _
)
'Usage

Dim flashFile As String
Dim poster As PDFFormXObject

Dim instance As New PDFFlashAnnotation(flashFile, poster)
public PDFFlashAnnotation(
   string flashFile,
   PDFFormXObject poster
)
public: PDFFlashAnnotation(
   string* flashFile,
   PDFFormXObject* poster
)
public:
PDFFlashAnnotation(
   String^ flashFile,
   PDFFormXObject^ poster
)

Parameters

flashFile
poster
a static image to represent the annotation when the movie is not playing.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFlashAnnotation Class
PDFFlashAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFlashAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFFlashAnnotation Class

For a list of all members of this type, see PDFFlashAnnotation members.

Public Properties
 | Name | Description
Public Property | ActivationCondition | Gets or sets the activation condition for the flash annotation.
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DeactivationCondition | Gets or sets the deactivation condition for the rich media annotation.
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | FlashData | Gets or sets the Flash content associated with this annotation.
Public Property | FlashFile | Gets or sets the movie file associated with this annotation.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Poster | Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFlashAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


ActivationCondition Property

O2S.Components.PDF4NET.Annotations Namespace > PDFFlashAnnotation Class : ActivationCondition Property
Gets or sets the activation condition for the flash annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ActivationCondition As PDFRichMediaActivationCondition
'Usage

Dim instance As PDFFlashAnnotation
Dim value As PDFRichMediaActivationCondition

instance.ActivationCondition = value

value = instance.ActivationCondition
public PDFRichMediaActivationCondition ActivationCondition {get; set;}
public: __property PDFRichMediaActivationCondition get_ActivationCondition();
public: __property void set_ActivationCondition(
   PDFRichMediaActivationCondition value
);
public:
property PDFRichMediaActivationCondition ActivationCondition {
   PDFRichMediaActivationCondition get();
   void set (    PDFRichMediaActivationCondition value);
}

Property Value

The condition that specifies how the flash annotation is activated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFlashAnnotation Class
PDFFlashAnnotation Members


DeactivationCondition Property

O2S.Components.PDF4NET.Annotations Namespace > PDFFlashAnnotation Class : DeactivationCondition Property
Gets or sets the deactivation condition for the rich media annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeactivationCondition As PDFRichMediaDeactivationCondition
'Usage

Dim instance As PDFFlashAnnotation
Dim value As PDFRichMediaDeactivationCondition

instance.DeactivationCondition = value

value = instance.DeactivationCondition
public PDFRichMediaDeactivationCondition DeactivationCondition {get; set;}
public: __property PDFRichMediaDeactivationCondition get_DeactivationCondition();
public: __property void set_DeactivationCondition(
   PDFRichMediaDeactivationCondition value
);
public:
property PDFRichMediaDeactivationCondition DeactivationCondition {
   PDFRichMediaDeactivationCondition get();
   void set (    PDFRichMediaDeactivationCondition value);
}

Property Value

The condition that specifies how the rich media annotation is deactivated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFlashAnnotation Class
PDFFlashAnnotation Members


FlashData Property

O2S.Components.PDF4NET.Annotations Namespace > PDFFlashAnnotation Class : FlashData Property
Gets or sets the Flash content associated with this annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FlashData As Byte()
'Usage

Dim instance As PDFFlashAnnotation
Dim value() As Byte

instance.FlashData = value

value = instance.FlashData
public byte[] FlashData {get; set;}
public: __property byte[]* get_FlashData();
public: __property void set_FlashData(
   byte[]* value
);
public:
property array<byte>^ FlashData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array value specifying the Flash content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFlashAnnotation Class
PDFFlashAnnotation Members


FlashFile Property

O2S.Components.PDF4NET.Annotations Namespace > PDFFlashAnnotation Class : FlashFile Property
Gets or sets the movie file associated with this annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FlashFile As String
'Usage

Dim instance As PDFFlashAnnotation
Dim value As String

instance.FlashFile = value

value = instance.FlashFile
public string FlashFile {get; set;}
public: __property string* get_FlashFile();
public: __property void set_FlashFile(
   string* value
);
public:
property String^ FlashFile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the full path to the movie file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFlashAnnotation Class
PDFFlashAnnotation Members


Poster Property (PDFFlashAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFlashAnnotation Class : Poster Property
Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Poster As PDFFormXObject
'Usage

Dim instance As PDFFlashAnnotation
Dim value As PDFFormXObject

instance.Poster = value

value = instance.Poster
public PDFFormXObject Poster {get; set;}
public: __property PDFFormXObject* get_Poster();
public: __property void set_Poster(
   PDFFormXObject* value
);
public:
property PDFFormXObject^ Poster {
   PDFFormXObject^ get();
   void set (    PDFFormXObject^ value);
}

Property Value

A string value specifying the movie poster to be displayed on the page when the movie is not playing.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFlashAnnotation Class
PDFFlashAnnotation Members


%%PageItemTitle%%

PDFFreeTextAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class
Defines a free text annotations.
Object Model
PDFFreeTextAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFRgbColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFFreeTextAnnotation
   Inherits PDFAnnotation
'Usage

Dim instance As PDFFreeTextAnnotation
[Serializable()]
public class PDFFreeTextAnnotation : PDFAnnotation
[Serializable()]
public __gc class PDFFreeTextAnnotation : public PDFAnnotation
[Serializable()]
public ref class PDFFreeTextAnnotation : public PDFAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFFreeTextAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFFreeTextAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

The following tables list the members exposed by PDFFreeTextAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFFreeTextAnnotation Constructor | Initializes a new PDFFreeTextAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFFreeTextAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : PDFFreeTextAnnotation Constructor
Initializes a new PDFFreeTextAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFreeTextAnnotation()
public PDFFreeTextAnnotation()
public: PDFFreeTextAnnotation();
public:
PDFFreeTextAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFFreeTextAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

For a list of all members of this type, see PDFFreeTextAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Author Property (PDFFreeTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Author Property
Gets or sets the annotation author.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the person who created the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


BorderColor Property (PDFFreeTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : BorderColor Property
Gets or sets the widget's border color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderColor As PDFDeviceColor
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFDeviceColor

instance.BorderColor = value

value = instance.BorderColor
public PDFDeviceColor BorderColor {get; set;}
public: __property PDFDeviceColor* get_BorderColor();
public: __property void set_BorderColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ BorderColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The color of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


BorderStyle Property (PDFFreeTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : BorderStyle Property
Gets or sets the widget's border style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderStyle As PDFBorderStyle
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFBorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public PDFBorderStyle BorderStyle {get; set;}
public: __property PDFBorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   PDFBorderStyle value
);
public:
property PDFBorderStyle BorderStyle {
   PDFBorderStyle get();
   void set (    PDFBorderStyle value);
}

Property Value

The style of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


BorderWidth Property (PDFFreeTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : BorderWidth Property
Gets or sets the widget's border width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public: __property double get_BorderWidth();
public: __property void set_BorderWidth(
   double value
);
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


Contents Property (PDFFreeTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Contents Property
Gets or sets the annotation contents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Contents As String
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
public override string Contents {get; set;}
public: __property string* get_Contents() override;
public: __property void set_Contents(
   string* value
) override;
public:
property String^ Contents {
   String^ get() override;
   void set (    String^ value) override;
}

Property Value

The text to be displayed for the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


Font Property (PDFFreeTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Font Property
Gets or sets the font used to display the widget text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Font As PDFFontBase
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
public PDFFontBase Font {get; set;}
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (    PDFFontBase^ value);
}

Property Value

The font used for displaying the widget content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


PDFRectangle Property (PDFFreeTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


Subject Property (PDFFreeTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Subject Property
Gets or sets the annotation subject.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Subject As String
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
public string Subject {get; set;}
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
public:
property String^ Subject {
   String^ get();
   void set (    String^ value);
}

Property Value

The subject of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


TextColor Property (PDFFreeTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : TextColor Property
Gets or sets the text color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As PDFRgbColor
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFRgbColor

instance.TextColor = value

value = instance.TextColor
public PDFRgbColor TextColor {get; set;}
public: __property PDFRgbColor* get_TextColor();
public: __property void set_TextColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ TextColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The color of the annotation's text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%%

PDFHighlightAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFHighlightAnnotation Class
Defines a highlight annotation.
Object Model
PDFHighlightAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFHighlightAnnotation
   Inherits PDFTextMarkupAnnotation
'Usage

Dim instance As PDFHighlightAnnotation
public class PDFHighlightAnnotation : PDFTextMarkupAnnotation
public __gc class PDFHighlightAnnotation : public PDFTextMarkupAnnotation
public ref class PDFHighlightAnnotation : public PDFTextMarkupAnnotation
Remarks
This annotation is used to highlight text in a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFHighlightAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHighlightAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFHighlightAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFHighlightAnnotation Class

The following tables list the members exposed by PDFHighlightAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFHighlightAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFHighlightAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFHighlightAnnotation Class : PDFHighlightAnnotation Constructor
Overload List
Overload | Description
PDFHighlightAnnotation Constructor() | Initializes a new PDFHighlightAnnotation object.
PDFHighlightAnnotation Constructor(String,String) | Initializes a new PDFHighlightAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHighlightAnnotation Class
PDFHighlightAnnotation Members


%%PageItemTitle%%

PDFHighlightAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFHighlightAnnotation Class > PDFHighlightAnnotation Constructor : PDFHighlightAnnotation Constructor()
Initializes a new PDFHighlightAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFHighlightAnnotation()
public PDFHighlightAnnotation()
public: PDFHighlightAnnotation();
public:
PDFHighlightAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHighlightAnnotation Class
PDFHighlightAnnotation Members
Overload List


%%PageItemTitle%%

PDFHighlightAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFHighlightAnnotation Class > PDFHighlightAnnotation Constructor : PDFHighlightAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFHighlightAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFHighlightAnnotation(author, contents)
public PDFHighlightAnnotation(
   string author,
   string contents
)
public: PDFHighlightAnnotation(
   string* author,
   string* contents
)
public:
PDFHighlightAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHighlightAnnotation Class
PDFHighlightAnnotation Members
Overload List


%%PageItemTitle%%

PDFImageAppearance Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFImageAppearance Class
Defines an annotation appearance that consists of an image.
Object Model
PDFImageAppearance ClassPDFBasicCanvas ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFImageAppearance
   Inherits PDFAnnotationAppearance
'Usage

Dim instance As PDFImageAppearance
public class PDFImageAppearance : PDFAnnotationAppearance
public __gc class PDFImageAppearance : public PDFAnnotationAppearance
public ref class PDFImageAppearance : public PDFAnnotationAppearance
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDF4NET.Annotations.PDFImageAppearance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageAppearance Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFImageAppearance Class Members
Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFImageAppearance Class

The following tables list the members exposed by PDFImageAppearance.

Public Constructors
 | Name | Description
Public Constructor | PDFImageAppearance Constructor | Initializes a new PDFImageAppearance object.
Top
Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Dictionary | Gets the form XObject dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top
See Also

Reference

PDFImageAppearance Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFImageAppearance Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFImageAppearance Class : PDFImageAppearance Constructor
The image used for creating the appearance.
Initializes a new PDFImageAppearance object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As Bitmap _
)
'Usage

Dim image As Bitmap

Dim instance As New PDFImageAppearance(image)
public PDFImageAppearance(
   Bitmap image
)
public: PDFImageAppearance(
   Bitmap* image
)
public:
PDFImageAppearance(
   Bitmap^ image
)

Parameters

image
The image used for creating the appearance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageAppearance Class
PDFImageAppearance Members


%%PageItemTitle%%

PDFInkAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFInkAnnotation Class
Defines an ink annotation.
Object Model
PDFInkAnnotation ClassPDFAnnotationAppearance ClassPDFAnnotationBorder ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFPointsCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFInkAnnotation
   Inherits PDFBaseMarkupAnnotation
'Usage

Dim instance As PDFInkAnnotation
public class PDFInkAnnotation : PDFBaseMarkupAnnotation
public __gc class PDFInkAnnotation : public PDFBaseMarkupAnnotation
public ref class PDFInkAnnotation : public PDFBaseMarkupAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFInkAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFInkAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFInkAnnotation Class

The following tables list the members exposed by PDFInkAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFInkAnnotation Constructor | Initializes a new PDFInkAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Points | Gets the annotation points.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFInkAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFInkAnnotation Class : PDFInkAnnotation Constructor
Initializes a new PDFInkAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFInkAnnotation()
public PDFInkAnnotation()
public: PDFInkAnnotation();
public:
PDFInkAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFInkAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFInkAnnotation Class

For a list of all members of this type, see PDFInkAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Points | Gets the annotation points.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Border Property (PDFInkAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFInkAnnotation Class : Border Property
Gets or sets the annotation border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As PDFAnnotationBorder
'Usage

Dim instance As PDFInkAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
public PDFAnnotationBorder Border {get; set;}
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (    PDFAnnotationBorder^ value);
}

Property Value

The annotation border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


Points Property

O2S.Components.PDF4NET.Annotations Namespace > PDFInkAnnotation Class : Points Property
Gets the annotation points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Points As PDFPointsCollection
'Usage

Dim instance As PDFInkAnnotation
Dim value As PDFPointsCollection

value = instance.Points
public PDFPointsCollection Points {get;}
public: __property PDFPointsCollection* get_Points();
public:
property PDFPointsCollection^ Points {
   PDFPointsCollection^ get();
}

Property Value

The list of points that create this annotation.
Remarks
The collection consists of at least one points array. Each points array includes 2*n values representing the coordinates of n points in the page coordinate space
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%PageItemTitle%%

PDFLineAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class
Defines a line annotation.
Object Model
PDFLineAnnotation ClassPDFAnnotationAppearance ClassPDFAnnotationBorder ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFDeviceColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLineAnnotation
   Inherits PDFBaseMarkupAnnotation
'Usage

Dim instance As PDFLineAnnotation
public class PDFLineAnnotation : PDFBaseMarkupAnnotation
public __gc class PDFLineAnnotation : public PDFBaseMarkupAnnotation
public ref class PDFLineAnnotation : public PDFBaseMarkupAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFLineAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFLineAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

The following tables list the members exposed by PDFLineAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFLineAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | BeginLineStyle | Gets or sets the style used for the beginning of the line.
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | EndLineStyle | Gets or sets the style used for the end of the line.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | LineDirection | Gets or sets the direction of the line annotation.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFLineAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : PDFLineAnnotation Constructor
Overload List
Overload | Description
PDFLineAnnotation Constructor() | Initializes a new PDFLineAnnotation object.
PDFLineAnnotation Constructor(String,String) | Initializes a new PDFLineAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%%

PDFLineAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class > PDFLineAnnotation Constructor : PDFLineAnnotation Constructor()
Initializes a new PDFLineAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLineAnnotation()
public PDFLineAnnotation()
public: PDFLineAnnotation();
public:
PDFLineAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members
Overload List


%%PageItemTitle%%

PDFLineAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class > PDFLineAnnotation Constructor : PDFLineAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFLineAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFLineAnnotation(author, contents)
public PDFLineAnnotation(
   string author,
   string contents
)
public: PDFLineAnnotation(
   string* author,
   string* contents
)
public:
PDFLineAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFLineAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

For a list of all members of this type, see PDFLineAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | BeginLineStyle | Gets or sets the style used for the beginning of the line.
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | EndLineStyle | Gets or sets the style used for the end of the line.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | LineDirection | Gets or sets the direction of the line annotation.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property (PDFLineAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


BeginLineStyle Property

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : BeginLineStyle Property
Gets or sets the style used for the beginning of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BeginLineStyle As PDFLineEndingStyle
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFLineEndingStyle

instance.BeginLineStyle = value

value = instance.BeginLineStyle
public PDFLineEndingStyle BeginLineStyle {get; set;}
public: __property PDFLineEndingStyle get_BeginLineStyle();
public: __property void set_BeginLineStyle(
   PDFLineEndingStyle value
);
public:
property PDFLineEndingStyle BeginLineStyle {
   PDFLineEndingStyle get();
   void set (    PDFLineEndingStyle value);
}

Property Value

A PDFLineEndingStyle enumeration member specifying the style for the beginning of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


Border Property (PDFLineAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : Border Property
Gets or sets the annotation border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As PDFAnnotationBorder
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
public PDFAnnotationBorder Border {get; set;}
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (    PDFAnnotationBorder^ value);
}

Property Value

The annotation border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


EndLineStyle Property

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : EndLineStyle Property
Gets or sets the style used for the end of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndLineStyle As PDFLineEndingStyle
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFLineEndingStyle

instance.EndLineStyle = value

value = instance.EndLineStyle
public PDFLineEndingStyle EndLineStyle {get; set;}
public: __property PDFLineEndingStyle get_EndLineStyle();
public: __property void set_EndLineStyle(
   PDFLineEndingStyle value
);
public:
property PDFLineEndingStyle EndLineStyle {
   PDFLineEndingStyle get();
   void set (    PDFLineEndingStyle value);
}

Property Value

A PDFLineEndingStyle enumeration member specifying the style for the end of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


InteriorColor Property (PDFLineAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : InteriorColor Property
Gets or sets the annotation's interior color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteriorColor As PDFDeviceColor
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFDeviceColor

instance.InteriorColor = value

value = instance.InteriorColor
public PDFDeviceColor InteriorColor {get; set;}
public: __property PDFDeviceColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ InteriorColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The annotation interior color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


LineDirection Property

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : LineDirection Property
Gets or sets the direction of the line annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineDirection As PDFLineDirection
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFLineDirection

instance.LineDirection = value

value = instance.LineDirection
public PDFLineDirection LineDirection {get; set;}
public: __property PDFLineDirection get_LineDirection();
public: __property void set_LineDirection(
   PDFLineDirection value
);
public:
property PDFLineDirection LineDirection {
   PDFLineDirection get();
   void set (    PDFLineDirection value);
}

Property Value

A PDFLineDirection enumeration member specifying the direction of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


Rotation Property (PDFLineAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%%

PDFLinkAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class
Defines a link annotations.
Object Model
PDFLinkAnnotation ClassPDFAction ClassPDFAnnotationAppearance ClassPDFAnnotationBorder ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLinkAnnotation
   Inherits PDFAnnotation
'Usage

Dim instance As PDFLinkAnnotation
public class PDFLinkAnnotation : PDFAnnotation
public __gc class PDFLinkAnnotation : public PDFAnnotation
public ref class PDFLinkAnnotation : public PDFAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFLinkAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFLinkAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

The following tables list the members exposed by PDFLinkAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFLinkAnnotation Constructor | Initializes a new PDFLinkAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the link is clicked.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author.
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | HighlightMode | Gets or sets the highlighting mode of the link.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFLinkAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : PDFLinkAnnotation Constructor
Initializes a new PDFLinkAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLinkAnnotation()
public PDFLinkAnnotation()
public: PDFLinkAnnotation();
public:
PDFLinkAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFLinkAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

For a list of all members of this type, see PDFLinkAnnotation members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the link is clicked.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author.
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | HighlightMode | Gets or sets the highlighting mode of the link.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Action Property (PDFLinkAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : Action Property
Gets or sets the action to be executed when the link is clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Action As PDFAction
'Usage

Dim instance As PDFLinkAnnotation
Dim value As PDFAction

instance.Action = value

value = instance.Action
public PDFAction Action {get; set;}
public: __property PDFAction* get_Action();
public: __property void set_Action(
   PDFAction* value
);
public:
property PDFAction^ Action {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

Action to execute.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


Appearance Property (PDFLinkAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFLinkAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


Author Property (PDFLinkAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : Author Property
Gets or sets the annotation author.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PDFLinkAnnotation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the person who created the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


Border Property (PDFLinkAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : Border Property
Gets or sets the annotation border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As PDFAnnotationBorder
'Usage

Dim instance As PDFLinkAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
public PDFAnnotationBorder Border {get; set;}
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (    PDFAnnotationBorder^ value);
}

Property Value

The annotation border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


HighlightMode Property (PDFLinkAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : HighlightMode Property
Gets or sets the highlighting mode of the link.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighlightMode As PDFLinkHighlightMode
'Usage

Dim instance As PDFLinkAnnotation
Dim value As PDFLinkHighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
public PDFLinkHighlightMode HighlightMode {get; set;}
public: __property PDFLinkHighlightMode get_HighlightMode();
public: __property void set_HighlightMode(
   PDFLinkHighlightMode value
);
public:
property PDFLinkHighlightMode HighlightMode {
   PDFLinkHighlightMode get();
   void set (    PDFLinkHighlightMode value);
}

Property Value

A PDFLinkHighlightMode enumeration member specifying the highlighting mode for the link.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%%

PDFMovieAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class
Defines a movie annotation in a PDF file.
Object Model
PDFMovieAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFFormXObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMovieAnnotation
   Inherits PDFAnnotation
'Usage

Dim instance As PDFMovieAnnotation
public class PDFMovieAnnotation : PDFAnnotation
public __gc class PDFMovieAnnotation : public PDFAnnotation
public ref class PDFMovieAnnotation : public PDFAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFMovieAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFMovieAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

The following tables list the members exposed by PDFMovieAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFMovieAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Duration | Gets or sets the duration of the movie clip.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MovieData | Gets or sets the movie content associated with this annotation.
Public Property | MovieFile | Gets or sets the movie file associated with this annotation.
Public Property | MovieType | Gets or sets the MIME type of the movie file.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Poster | Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ShowPlayerControls | Gets or sets whether player control interface should be displayed while playing the movie.
Public Property | Title | Gets or sets the annotation title.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFMovieAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFMovieAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : PDFMovieAnnotation Constructor
Overload List
Overload | Description
PDFMovieAnnotation Constructor() | Initializes a new PDFMovieAnnotation object.
PDFMovieAnnotation Constructor(String,PDFMovieType,PDFFormXObject) | Initializes a new PDFMovieAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


%%PageItemTitle%%

PDFMovieAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class > PDFMovieAnnotation Constructor : PDFMovieAnnotation Constructor()
Initializes a new PDFMovieAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMovieAnnotation()
public PDFMovieAnnotation()
public: PDFMovieAnnotation();
public:
PDFMovieAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members
Overload List


%%PageItemTitle%%

PDFMovieAnnotation Constructor(String,PDFMovieType,PDFFormXObject)

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class > PDFMovieAnnotation Constructor : PDFMovieAnnotation Constructor(String,PDFMovieType,PDFFormXObject)
the movie file associated with this annotation object.
the type of the movie file.
a static image to represent the annotation when the movie is not playing.
Initializes a new PDFMovieAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal movieFile As String, _
   ByVal movieType As PDFMovieType, _
   ByVal poster As PDFFormXObject _
)
'Usage

Dim movieFile As String
Dim movieType As PDFMovieType
Dim poster As PDFFormXObject

Dim instance As New PDFMovieAnnotation(movieFile, movieType, poster)
public PDFMovieAnnotation(
   string movieFile,
   PDFMovieType movieType,
   PDFFormXObject poster
)
public: PDFMovieAnnotation(
   string* movieFile,
   PDFMovieType movieType,
   PDFFormXObject* poster
)
public:
PDFMovieAnnotation(
   String^ movieFile,
   PDFMovieType movieType,
   PDFFormXObject^ poster
)

Parameters

movieFile
the movie file associated with this annotation object.
movieType
the type of the movie file.
poster
a static image to represent the annotation when the movie is not playing.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFMovieAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

For a list of all members of this type, see PDFMovieAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Duration | Gets or sets the duration of the movie clip.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MovieData | Gets or sets the movie content associated with this annotation.
Public Property | MovieFile | Gets or sets the movie file associated with this annotation.
Public Property | MovieType | Gets or sets the MIME type of the movie file.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Poster | Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ShowPlayerControls | Gets or sets whether player control interface should be displayed while playing the movie.
Public Property | Title | Gets or sets the annotation title.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFMovieAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Duration Property

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : Duration Property
Gets or sets the duration of the movie clip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Duration As Double
'Usage

Dim instance As PDFMovieAnnotation
Dim value As Double

instance.Duration = value

value = instance.Duration
public double Duration {get; set;}
public: __property double get_Duration();
public: __property void set_Duration(
   double value
);
public:
property double Duration {
   double get();
   void set (    double value);
}

Property Value

A float value specifying the duration of the movie clip.
Remarks
If this property is -1, the actual movie duration is used for playing the movie. If this property is 0, the duration is infinity.
If the duration is greater than actual movie duration, when the movie ends, the player displays the last frame till the specified duration elapses. If the duration is lower than actual movie duration, the movie ends when the duration elapses.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


MovieData Property

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : MovieData Property
Gets or sets the movie content associated with this annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MovieData As Byte()
'Usage

Dim instance As PDFMovieAnnotation
Dim value() As Byte

instance.MovieData = value

value = instance.MovieData
public byte[] MovieData {get; set;}
public: __property byte[]* get_MovieData();
public: __property void set_MovieData(
   byte[]* value
);
public:
property array<byte>^ MovieData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array value specifying the movie content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


MovieFile Property

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : MovieFile Property
Gets or sets the movie file associated with this annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MovieFile As String
'Usage

Dim instance As PDFMovieAnnotation
Dim value As String

instance.MovieFile = value

value = instance.MovieFile
public string MovieFile {get; set;}
public: __property string* get_MovieFile();
public: __property void set_MovieFile(
   string* value
);
public:
property String^ MovieFile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the full path to the movie file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


MovieType Property

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : MovieType Property
Gets or sets the MIME type of the movie file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MovieType As PDFMovieType
'Usage

Dim instance As PDFMovieAnnotation
Dim value As PDFMovieType

instance.MovieType = value

value = instance.MovieType
public PDFMovieType MovieType {get; set;}
public: __property PDFMovieType get_MovieType();
public: __property void set_MovieType(
   PDFMovieType value
);
public:
property PDFMovieType MovieType {
   PDFMovieType get();
   void set (    PDFMovieType value);
}

Property Value

A MovieType enumeration member specifying the MIME type of the movie file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


Poster Property (PDFMovieAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : Poster Property
Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Poster As PDFFormXObject
'Usage

Dim instance As PDFMovieAnnotation
Dim value As PDFFormXObject

instance.Poster = value

value = instance.Poster
public PDFFormXObject Poster {get; set;}
public: __property PDFFormXObject* get_Poster();
public: __property void set_Poster(
   PDFFormXObject* value
);
public:
property PDFFormXObject^ Poster {
   PDFFormXObject^ get();
   void set (    PDFFormXObject^ value);
}

Property Value

A string value specifying the movie poster to be displayed on the page when the movie is not playing.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


ShowPlayerControls Property

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : ShowPlayerControls Property
Gets or sets whether player control interface should be displayed while playing the movie.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShowPlayerControls As Boolean
'Usage

Dim instance As PDFMovieAnnotation
Dim value As Boolean

instance.ShowPlayerControls = value

value = instance.ShowPlayerControls
public bool ShowPlayerControls {get; set;}
public: __property bool get_ShowPlayerControls();
public: __property void set_ShowPlayerControls(
   bool value
);
public:
property bool ShowPlayerControls {
   bool get();
   void set (    bool value);
}

Property Value

True if the player control interface should be displayed, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


Title Property (PDFMovieAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : Title Property
Gets or sets the annotation title.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As PDFMovieAnnotation
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

The title of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


%%PageItemTitle%%

PDFPointsCollection Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class
Defines a collection of array the store points on the page.
Object Model
PDFPointsCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPointsCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of Double(),PDFAnnotation)
'Usage

Dim instance As PDFPointsCollection
public class PDFPointsCollection : O2S.Components.PDF4NET.PDFCollection<double[],PDFAnnotation>
public __gc class PDFPointsCollection : public O2S.Components.PDF4NET.PDFCollection<double[],PDFAnnotation>
public ref class PDFPointsCollection : public O2S.Components.PDF4NET.PDFCollection<array<double>,PDFAnnotation>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Annotations.PDFPointsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointsCollection Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFPointsCollection Class Members
Properties Methods Events

O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class

The following tables list the members exposed by PDFPointsCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Top
Public Events
 | Name | Description
Public Event | CollectionChanged | Occurs when the collection changes.
Top
See Also

Reference

PDFPointsCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Events$$

PDFPointsCollection Class Events

O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class

For a list of all members of this type, see PDFPointsCollection members.

Public Events
 | Name | Description
Public Event | CollectionChanged | Occurs when the collection changes.
Top
See Also

Reference

PDFPointsCollection Class
O2S.Components.PDF4NET.Annotations Namespace


CollectionChanged Event

O2S.Components.PDF4NET.Annotations Namespace > PDFPointsCollection Class : CollectionChanged Event
Occurs when the collection changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event CollectionChanged As EventHandler
'Usage

Dim instance As PDFPointsCollection
Dim handler As EventHandler

AddHandler instance.CollectionChanged, handler
public event EventHandler CollectionChanged
public: __event EventHandler* CollectionChanged
public:
event EventHandler^ CollectionChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointsCollection Class
PDFPointsCollection Members


%%PageItemTitle%%

PDFRectangleAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFRectangleAnnotation Class
Defines a rectangle (Square) annotation.
Object Model
PDFRectangleAnnotation ClassPDFAnnotationAppearance ClassPDFAnnotationBorder ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFDeviceColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRectangleAnnotation
   Inherits PDFSCAnnotation
'Usage

Dim instance As PDFRectangleAnnotation
public class PDFRectangleAnnotation : PDFSCAnnotation
public __gc class PDFRectangleAnnotation : public PDFSCAnnotation
public ref class PDFRectangleAnnotation : public PDFSCAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFRectangleAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangleAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFRectangleAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFRectangleAnnotation Class

The following tables list the members exposed by PDFRectangleAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFRectangleAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from O2S.Components.PDF4NET.Annotations.PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFRectangleAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFRectangleAnnotation Class : PDFRectangleAnnotation Constructor
Overload List
Overload | Description
PDFRectangleAnnotation Constructor() | Initializes a new PDFRectangleAnnotation object.
PDFRectangleAnnotation Constructor(String,String) | Initializes a new PDFRectangleAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangleAnnotation Class
PDFRectangleAnnotation Members


%%PageItemTitle%%

PDFRectangleAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFRectangleAnnotation Class > PDFRectangleAnnotation Constructor : PDFRectangleAnnotation Constructor()
Initializes a new PDFRectangleAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRectangleAnnotation()
public PDFRectangleAnnotation()
public: PDFRectangleAnnotation();
public:
PDFRectangleAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangleAnnotation Class
PDFRectangleAnnotation Members
Overload List


%%PageItemTitle%%

PDFRectangleAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFRectangleAnnotation Class > PDFRectangleAnnotation Constructor : PDFRectangleAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFRectangleAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFRectangleAnnotation(author, contents)
public PDFRectangleAnnotation(
   string author,
   string contents
)
public: PDFRectangleAnnotation(
   string* author,
   string* contents
)
public:
PDFRectangleAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangleAnnotation Class
PDFRectangleAnnotation Members
Overload List


%%PageItemTitle%%

PDFRubberStampAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class
Defines a rubber stamp annotation.
Object Model
PDFRubberStampAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRubberStampAnnotation
   Inherits PDFBaseMarkupAnnotation
'Usage

Dim instance As PDFRubberStampAnnotation
public class PDFRubberStampAnnotation : PDFBaseMarkupAnnotation
public __gc class PDFRubberStampAnnotation : public PDFBaseMarkupAnnotation
public ref class PDFRubberStampAnnotation : public PDFBaseMarkupAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRubberStampAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFRubberStampAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

The following tables list the members exposed by PDFRubberStampAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFRubberStampAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Icon |
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRubberStampAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFRubberStampAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : PDFRubberStampAnnotation Constructor
Overload List
Overload | Description
PDFRubberStampAnnotation Constructor() | Initializes a new PDFRubberStampAnnotation object.
PDFRubberStampAnnotation Constructor(String,String) | Initializes a new PDFRubberStampAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


%%PageItemTitle%%

PDFRubberStampAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class > PDFRubberStampAnnotation Constructor : PDFRubberStampAnnotation Constructor()
Initializes a new PDFRubberStampAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRubberStampAnnotation()
public PDFRubberStampAnnotation()
public: PDFRubberStampAnnotation();
public:
PDFRubberStampAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members
Overload List


%%PageItemTitle%%

PDFRubberStampAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class > PDFRubberStampAnnotation Constructor : PDFRubberStampAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFRubberStampAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFRubberStampAnnotation(author, contents)
public PDFRubberStampAnnotation(
   string author,
   string contents
)
public: PDFRubberStampAnnotation(
   string* author,
   string* contents
)
public:
PDFRubberStampAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFRubberStampAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

For a list of all members of this type, see PDFRubberStampAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Icon |
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRubberStampAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property (PDFRubberStampAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFRubberStampAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the stamp.
Remarks
When this property is set to a valid appearance, the Icon is set to PDFRubberStampAnnotationIcon.Custom and the IconName is set to "Custom". If you want to use your custom icon name, make sure you set the IconName property after this property is set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


Icon Property (PDFRubberStampAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : Icon Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Icon As PDFRubberStampAnnotationIcon
'Usage

Dim instance As PDFRubberStampAnnotation
Dim value As PDFRubberStampAnnotationIcon

instance.Icon = value

value = instance.Icon
public PDFRubberStampAnnotationIcon Icon {get; set;}
public: __property PDFRubberStampAnnotationIcon get_Icon();
public: __property void set_Icon(
   PDFRubberStampAnnotationIcon value
);
public:
property PDFRubberStampAnnotationIcon Icon {
   PDFRubberStampAnnotationIcon get();
   void set (    PDFRubberStampAnnotationIcon value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


IconName Property (PDFRubberStampAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : IconName Property
Gets or sets the icon name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IconName As String
'Usage

Dim instance As PDFRubberStampAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
public string IconName {get; set;}
public: __property string* get_IconName();
public: __property void set_IconName(
   string* value
);
public:
property String^ IconName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the stamp's icon.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
This property lets you set a custom name for your user defined stamp appearances.
If the Icon property to any of the PDFStampAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFRubberStampAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFRubberStampAnnotationIcon.Custom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


%%PageItemTitle%%

PDFSCAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFSCAnnotation Class
Defines the base class for rectangle (Square) and ellipse (Circle) annotations.
Object Model
PDFSCAnnotation ClassPDFAnnotationAppearance ClassPDFAnnotationBorder ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFDeviceColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSCAnnotation
   Inherits PDFBaseMarkupAnnotation
'Usage

Dim instance As PDFSCAnnotation
public class PDFSCAnnotation : PDFBaseMarkupAnnotation
public __gc class PDFSCAnnotation : public PDFBaseMarkupAnnotation
public ref class PDFSCAnnotation : public PDFBaseMarkupAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFEllipseAnnotation
O2S.Components.PDF4NET.Annotations.PDFRectangleAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFSCAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFSCAnnotation Class

The following tables list the members exposed by PDFSCAnnotation.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFSCAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFSCAnnotation Class

For a list of all members of this type, see PDFSCAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Border Property (PDFSCAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFSCAnnotation Class : Border Property
Gets or sets the annotation border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As PDFAnnotationBorder
'Usage

Dim instance As PDFSCAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
public PDFAnnotationBorder Border {get; set;}
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (    PDFAnnotationBorder^ value);
}

Property Value

The annotation border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


InteriorColor Property (PDFSCAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFSCAnnotation Class : InteriorColor Property
Gets or sets the annotation's interior color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteriorColor As PDFDeviceColor
'Usage

Dim instance As PDFSCAnnotation
Dim value As PDFDeviceColor

instance.InteriorColor = value

value = instance.InteriorColor
public PDFDeviceColor InteriorColor {get; set;}
public: __property PDFDeviceColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ InteriorColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The annotation interior color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


%%PageItemTitle%%

PDFSquigglyAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFSquigglyAnnotation Class
Defines a squiggly annotation.
Object Model
PDFSquigglyAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSquigglyAnnotation
   Inherits PDFTextMarkupAnnotation
'Usage

Dim instance As PDFSquigglyAnnotation
public class PDFSquigglyAnnotation : PDFTextMarkupAnnotation
public __gc class PDFSquigglyAnnotation : public PDFTextMarkupAnnotation
public ref class PDFSquigglyAnnotation : public PDFTextMarkupAnnotation
Remarks
This annotation is used to underline text in a document with a jagged line.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFSquigglyAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSquigglyAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFSquigglyAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFSquigglyAnnotation Class

The following tables list the members exposed by PDFSquigglyAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFSquigglyAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFSquigglyAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFSquigglyAnnotation Class : PDFSquigglyAnnotation Constructor
Overload List
Overload | Description
PDFSquigglyAnnotation Constructor() | Initializes a new PDFSquigglyAnnotation object.
PDFSquigglyAnnotation Constructor(String,String) | Initializes a new PDFSquigglyAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSquigglyAnnotation Class
PDFSquigglyAnnotation Members


%%PageItemTitle%%

PDFSquigglyAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFSquigglyAnnotation Class > PDFSquigglyAnnotation Constructor : PDFSquigglyAnnotation Constructor()
Initializes a new PDFSquigglyAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSquigglyAnnotation()
public PDFSquigglyAnnotation()
public: PDFSquigglyAnnotation();
public:
PDFSquigglyAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSquigglyAnnotation Class
PDFSquigglyAnnotation Members
Overload List


%%PageItemTitle%%

PDFSquigglyAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFSquigglyAnnotation Class > PDFSquigglyAnnotation Constructor : PDFSquigglyAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFSquigglyAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFSquigglyAnnotation(author, contents)
public PDFSquigglyAnnotation(
   string author,
   string contents
)
public: PDFSquigglyAnnotation(
   string* author,
   string* contents
)
public:
PDFSquigglyAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSquigglyAnnotation Class
PDFSquigglyAnnotation Members
Overload List


%%PageItemTitle%%

PDFStrikeOutAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFStrikeOutAnnotation Class
Defines a strike out annotation.
Object Model
PDFStrikeOutAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFStrikeOutAnnotation
   Inherits PDFTextMarkupAnnotation
'Usage

Dim instance As PDFStrikeOutAnnotation
public class PDFStrikeOutAnnotation : PDFTextMarkupAnnotation
public __gc class PDFStrikeOutAnnotation : public PDFTextMarkupAnnotation
public ref class PDFStrikeOutAnnotation : public PDFTextMarkupAnnotation
Remarks
This annotation is used to strike out text in a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFStrikeOutAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStrikeOutAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFStrikeOutAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

The following tables list the members exposed by PDFStrikeOutAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFStrikeOutAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFStrikeOutAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFStrikeOutAnnotation Class : PDFStrikeOutAnnotation Constructor
Overload List
Overload | Description
PDFStrikeOutAnnotation Constructor() | Initializes a new PDFStrikeOutAnnotation object.
PDFStrikeOutAnnotation Constructor(String,String) | Initializes a new PDFStrikeOutAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStrikeOutAnnotation Class
PDFStrikeOutAnnotation Members


%%PageItemTitle%%

PDFStrikeOutAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFStrikeOutAnnotation Class > PDFStrikeOutAnnotation Constructor : PDFStrikeOutAnnotation Constructor()
Initializes a new PDFStrikeOutAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFStrikeOutAnnotation()
public PDFStrikeOutAnnotation()
public: PDFStrikeOutAnnotation();
public:
PDFStrikeOutAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStrikeOutAnnotation Class
PDFStrikeOutAnnotation Members
Overload List


%%PageItemTitle%%

PDFStrikeOutAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFStrikeOutAnnotation Class > PDFStrikeOutAnnotation Constructor : PDFStrikeOutAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFStrikeOutAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFStrikeOutAnnotation(author, contents)
public PDFStrikeOutAnnotation(
   string author,
   string contents
)
public: PDFStrikeOutAnnotation(
   string* author,
   string* contents
)
public:
PDFStrikeOutAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStrikeOutAnnotation Class
PDFStrikeOutAnnotation Members
Overload List


%%PageItemTitle%%

PDFTextAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class
Defines a text annotation.
Object Model
PDFTextAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextAnnotation
   Inherits PDFBaseMarkupAnnotation
'Usage

Dim instance As PDFTextAnnotation
public class PDFTextAnnotation : PDFBaseMarkupAnnotation
public __gc class PDFTextAnnotation : public PDFBaseMarkupAnnotation
public ref class PDFTextAnnotation : public PDFBaseMarkupAnnotation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFTextAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

The following tables list the members exposed by PDFTextAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFTextAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Open | Gets or sets whether the annotation should initially be displayed open.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | State | Gets or sets the annotation state.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : PDFTextAnnotation Constructor
Overload List
Overload | Description
PDFTextAnnotation Constructor() | Initializes a new PDFTextAnnotation object.
PDFTextAnnotation Constructor(String,String) | Initializes a new PDFTextAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%PageItemTitle%%

PDFTextAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class > PDFTextAnnotation Constructor : PDFTextAnnotation Constructor()
Initializes a new PDFTextAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFTextAnnotation()
public PDFTextAnnotation()
public: PDFTextAnnotation();
public:
PDFTextAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members
Overload List


%%PageItemTitle%%

PDFTextAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class > PDFTextAnnotation Constructor : PDFTextAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFTextAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFTextAnnotation(author, contents)
public PDFTextAnnotation(
   string author,
   string contents
)
public: PDFTextAnnotation(
   string* author,
   string* contents
)
public:
PDFTextAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFTextAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

For a list of all members of this type, see PDFTextAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Open | Gets or sets whether the annotation should initially be displayed open.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | State | Gets or sets the annotation state.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property (PDFTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFTextAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the text annotation icon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


Icon Property (PDFTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : Icon Property
Gets or sets the annotation icon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Icon As PDFTextAnnotationIcon
'Usage

Dim instance As PDFTextAnnotation
Dim value As PDFTextAnnotationIcon

instance.Icon = value

value = instance.Icon
public PDFTextAnnotationIcon Icon {get; set;}
public: __property PDFTextAnnotationIcon get_Icon();
public: __property void set_Icon(
   PDFTextAnnotationIcon value
);
public:
property PDFTextAnnotationIcon Icon {
   PDFTextAnnotationIcon get();
   void set (    PDFTextAnnotationIcon value);
}

Property Value

The icon to be displayed for the annotation.
Remarks
If the Icon property to any of the PDFTextAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFTextAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFTextAnnotationIcon.Custom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


IconName Property (PDFTextAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : IconName Property
Gets or sets the icon name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IconName As String
'Usage

Dim instance As PDFTextAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
public string IconName {get; set;}
public: __property string* get_IconName();
public: __property void set_IconName(
   string* value
);
public:
property String^ IconName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the stamp's icon.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
This property lets you set a custom name for your user defined stamp appearances.
If the Icon property to any of the PDFTextAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFTextAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFTextAnnotationIcon.Custom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


Open Property

O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : Open Property
Gets or sets whether the annotation should initially be displayed open.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Open As Boolean
'Usage

Dim instance As PDFTextAnnotation
Dim value As Boolean

instance.Open = value

value = instance.Open
public bool Open {get; set;}
public: __property bool get_Open();
public: __property void set_Open(
   bool value
);
public:
property bool Open {
   bool get();
   void set (    bool value);
}

Property Value

True if the annotation should initially be displayed open. Default: false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


State Property

O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : State Property
Gets or sets the annotation state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property State As PDFTextAnnotationState
'Usage

Dim instance As PDFTextAnnotation
Dim value As PDFTextAnnotationState

instance.State = value

value = instance.State
public PDFTextAnnotationState State {get; set;}
public: __property PDFTextAnnotationState get_State();
public: __property void set_State(
   PDFTextAnnotationState value
);
public:
property PDFTextAnnotationState State {
   PDFTextAnnotationState get();
   void set (    PDFTextAnnotationState value);
}

Property Value

The state of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%PageItemTitle%%

PDFTextMarkupAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupAnnotation Class
Defines a text markup annotation.
Object Model
PDFTextMarkupAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextMarkupAnnotation
   Inherits PDFBaseMarkupAnnotation
'Usage

Dim instance As PDFTextMarkupAnnotation
public class PDFTextMarkupAnnotation : PDFBaseMarkupAnnotation
public __gc class PDFTextMarkupAnnotation : public PDFBaseMarkupAnnotation
public ref class PDFTextMarkupAnnotation : public PDFBaseMarkupAnnotation
Remarks
Text markup annotations appear as highlights, underlines, strikeouts or jagged (squiggly) underlines in the text of a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFHighlightAnnotation
O2S.Components.PDF4NET.Annotations.PDFSquigglyAnnotation
O2S.Components.PDF4NET.Annotations.PDFStrikeOutAnnotation
O2S.Components.PDF4NET.Annotations.PDFUnderlineAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFTextMarkupAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

The following tables list the members exposed by PDFTextMarkupAnnotation.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | QuadPoints | Gets or sets the points that define the markup area.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFTextMarkupAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

For a list of all members of this type, see PDFTextMarkupAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | QuadPoints | Gets or sets the points that define the markup area.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


MarkupType Property

O2S.Components.PDF4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : MarkupType Property
Gets or sets the type of the annotation markup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property MarkupType As PDFTextMarkupType
'Usage

Dim instance As PDFTextMarkupAnnotation
Dim value As PDFTextMarkupType

value = instance.MarkupType
public virtual PDFTextMarkupType MarkupType {get;}
public: __property virtual PDFTextMarkupType get_MarkupType();
public:
virtual property PDFTextMarkupType MarkupType {
   PDFTextMarkupType get();
}

Property Value

The type of the text markup.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


PDFRectangle Property (PDFTextMarkupAnnotation)

O2S.Components.PDF4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFTextMarkupAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


QuadPoints Property

O2S.Components.PDF4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : QuadPoints Property
Gets or sets the points that define the markup area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property QuadPoints As Double()
'Usage

Dim instance As PDFTextMarkupAnnotation
Dim value() As Double

instance.QuadPoints = value

value = instance.QuadPoints
public double[] QuadPoints {get; set;}
public: __property double[]* get_QuadPoints();
public: __property void set_QuadPoints(
   double[]* value
);
public:
property array<double>^ QuadPoints {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of points the define the location of the markup within the annotation.
Remarks
The array must include 8*n values representing the coordinates (x, y)of n quadrilaters. The coordinates for each quadrilateral are given in the order x1 y1 x2 y2 x3 y3 x4 y4 specifying the quadrilater's 4 vertices in counterclockwise order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


%%PageItemTitle%%

PDFUnderlineAnnotation Class
Members

O2S.Components.PDF4NET.Annotations Namespace : PDFUnderlineAnnotation Class
Defines an underline annotation.
Object Model
PDFUnderlineAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUnderlineAnnotation
   Inherits PDFTextMarkupAnnotation
'Usage

Dim instance As PDFUnderlineAnnotation
public class PDFUnderlineAnnotation : PDFTextMarkupAnnotation
public __gc class PDFUnderlineAnnotation : public PDFTextMarkupAnnotation
public ref class PDFUnderlineAnnotation : public PDFTextMarkupAnnotation
Remarks
This annotation is used to underline text in a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFUnderlineAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnderlineAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFUnderlineAnnotation Class Members
Properties Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFUnderlineAnnotation Class

The following tables list the members exposed by PDFUnderlineAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFUnderlineAnnotation Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFUnderlineAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFUnderlineAnnotation Class : PDFUnderlineAnnotation Constructor
Overload List
Overload | Description
PDFUnderlineAnnotation Constructor() | Initializes a new PDFUnderlineAnnotation object.
PDFUnderlineAnnotation Constructor(String,String) | Initializes a new PDFUnderlineAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnderlineAnnotation Class
PDFUnderlineAnnotation Members


%%PageItemTitle%%

PDFUnderlineAnnotation Constructor()

O2S.Components.PDF4NET.Annotations Namespace > PDFUnderlineAnnotation Class > PDFUnderlineAnnotation Constructor : PDFUnderlineAnnotation Constructor()
Initializes a new PDFUnderlineAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUnderlineAnnotation()
public PDFUnderlineAnnotation()
public: PDFUnderlineAnnotation();
public:
PDFUnderlineAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnderlineAnnotation Class
PDFUnderlineAnnotation Members
Overload List


%%PageItemTitle%%

PDFUnderlineAnnotation Constructor(String,String)

O2S.Components.PDF4NET.Annotations Namespace > PDFUnderlineAnnotation Class > PDFUnderlineAnnotation Constructor : PDFUnderlineAnnotation Constructor(String,String)
The author of the annotation.
The content of the annotation.
Initializes a new PDFUnderlineAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
'Usage

Dim author As String
Dim contents As String

Dim instance As New PDFUnderlineAnnotation(author, contents)
public PDFUnderlineAnnotation(
   string author,
   string contents
)
public: PDFUnderlineAnnotation(
   string* author,
   string* contents
)
public:
PDFUnderlineAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnderlineAnnotation Class
PDFUnderlineAnnotation Members
Overload List


%%PageItemTitle%%

PDF3DActivationMode Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivationMode Enumeration
Specifies the available modes for activating a 3D annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DActivationMode
   Inherits System.Enum
'Usage

Dim instance As PDF3DActivationMode
public enum PDF3DActivationMode : System.Enum
__value public enum PDF3DActivationMode : public System.Enum
public enum class PDF3DActivationMode : public System.Enum
Members
Member | Description
ExplicitActivation | The annotation should remain inactive until explicitly activated by a script or user action.
PageOpen | The annotation should be activated as soon as the page containing the annotation is opened.
PageVisible | The annotation should be activated as soon as any part of the page containing the annotation becomes visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DActivationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DActivationState Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivationState Enumeration
Specifies the available states upon activation of the 3D annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DActivationState
   Inherits System.Enum
'Usage

Dim instance As PDF3DActivationState
public enum PDF3DActivationState : System.Enum
__value public enum PDF3DActivationState : public System.Enum
public enum class PDF3DActivationState : public System.Enum
Members
Member | Description
Instantiated | The artwork is instantiated, but real-time script-driven animations are disabled.
Live | Real-time script-driven animations are enabled if present; if not, the artwork is instantiated.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DActivationState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DAnimationType Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimationType Enumeration
Specifies the available styles for applying light to 3D artwork.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DAnimationType
   Inherits System.Enum
'Usage

Dim instance As PDF3DAnimationType
public enum PDF3DAnimationType : System.Enum
__value public enum PDF3DAnimationType : public System.Enum
public enum class PDF3DAnimationType : public System.Enum
Members
Member | Description
Linear | Keyframe animations are driven linearly from beginning to end.
None | Animations are driven through alternate means, such as JavaScript.
Oscillating | Keyframe animations should oscillate along their time range.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DAnimationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DDeactivationMode Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DDeactivationMode Enumeration
Specifies the available modes for activating a 3D annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DDeactivationMode
   Inherits System.Enum
'Usage

Dim instance As PDF3DDeactivationMode
public enum PDF3DDeactivationMode : System.Enum
__value public enum PDF3DDeactivationMode : public System.Enum
public enum class PDF3DDeactivationMode : public System.Enum
Members
Member | Description
ExplicitDeactivation | The annotation should remain active until explicitly deactivated by a script or user action.
PageClose | The annotation should be deactivated as soon as the page is closed.
PageInvisible | The annotation should be deactivated as soon as the page containing the annotation becomes invisible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DDeactivationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DDeactivationState Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DDeactivationState Enumeration
Specifies the available states upon deactivation of the 3D annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DDeactivationState
   Inherits System.Enum
'Usage

Dim instance As PDF3DDeactivationState
public enum PDF3DDeactivationState : System.Enum
__value public enum PDF3DDeactivationState : public System.Enum
public enum class PDF3DDeactivationState : public System.Enum
Members
Member | Description
Instantiated | The artwork remains instantiated.
Live | The artwork remains live.
Uninstantiated | The artwork is uninstantiated.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DDeactivationState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DLightingStyle Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingStyle Enumeration
Specifies the available styles for applying light to 3D artwork.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DLightingStyle
   Inherits System.Enum
'Usage

Dim instance As PDF3DLightingStyle
public enum PDF3DLightingStyle : System.Enum
__value public enum PDF3DLightingStyle : public System.Enum
public enum class PDF3DLightingStyle : public System.Enum
Members
Member | Description
Artwork | Lights as specified in the 3D artwork.
Blue | Three blue infinite lights, no ambient term.
CAD | Three grey infinite lights and one light attached to the camera, no ambient term.
Cube | Six grey infinite lights aligned with the major axes, no ambient term.
Day | Three light-grey infinite lights, no ambient term.
Hard | Three grey infinite lights, moderate ambient term.
Headlamp | Single infinite light attached to the camera, low ambient term.
Night | One yellow, one aqua, and one blue infinite light, no ambient term.
None | No lights are used.
Primary | One red, one green, and one blue infinite light, no ambient term.
Red | Three red infinite lights, no ambient term.
White | Three blue-grey infinite lights, no ambient term.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DLightingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DProjectionClipStyle Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjectionClipStyle Enumeration
Specifies the available styles for the projection clipping.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DProjectionClipStyle
   Inherits System.Enum
'Usage

Dim instance As PDF3DProjectionClipStyle
public enum PDF3DProjectionClipStyle : System.Enum
__value public enum PDF3DProjectionClipStyle : public System.Enum
public enum class PDF3DProjectionClipStyle : public System.Enum
Members
Member | Description
AutomaticNearFar | Automatic near/far.
ExplicitNearFar | Explicit near/far.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DProjectionClipStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DProjectionOrthoScaleMode Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjectionOrthoScaleMode Enumeration
Specifies the available scaling modes for orthographic projections.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DProjectionOrthoScaleMode
   Inherits System.Enum
'Usage

Dim instance As PDF3DProjectionOrthoScaleMode
public enum PDF3DProjectionOrthoScaleMode : System.Enum
__value public enum PDF3DProjectionOrthoScaleMode : public System.Enum
public enum class PDF3DProjectionOrthoScaleMode : public System.Enum
Members
Member | Description
Absolute | No scaling.
Height | Fit height.
Max | Fit max between width and height.
Min | Fit min between width and height.
Width | Fit width.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DProjectionOrthoScaleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DProjectionType Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjectionType Enumeration
Specifies the available types for the projection of 3D artwork.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DProjectionType
   Inherits System.Enum
'Usage

Dim instance As PDF3DProjectionType
public enum PDF3DProjectionType : System.Enum
__value public enum PDF3DProjectionType : public System.Enum
public enum class PDF3DProjectionType : public System.Enum
Members
Member | Description
Orthographic | Orthographic projection.
Perspective | Perspective projection.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DProjectionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DRenderStyle Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderStyle Enumeration
Specifies the available styles for rendering the 3D artwork.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF3DRenderStyle
   Inherits System.Enum
'Usage

Dim instance As PDF3DRenderStyle
public enum PDF3DRenderStyle : System.Enum
__value public enum PDF3DRenderStyle : public System.Enum
public enum class PDF3DRenderStyle : public System.Enum
Members
Member | Description
BoundingBox | Displays the bounding box edges of each node. The color of the bounding box edges is determined by the auxiliary color.
HiddenWireframe | Displays edges in a single color, though removes back-facing and obscured edges. The color of these edges is determined by the auxiliary color.
Illustration | Displays silhouette edges with surfaces, removes obscured lines. The color of these edges is determined by the auxiliary color, and the color of the surfaces is determined by the face color.
ShadedIllustration | Displays silhouette edges with lit and textured surfaces and an additional emissive term to remove poorly lit areas of the artwork. The color of these edges is determined by the auxiliary color.
ShadedVertices | Displays only vertices, though uses their vertex color and applies lighting. The auxiliary color is ignored.
ShadedWireframe | Displays only edges and applies lighting. The auxiliary color is ignored.
Solid | Displays textured and lit geometric shapes. The auxiliary color is ignored.
SolidOutline | Displays silhouette edges with lit and textured surfaces, removes obscured lines. The color of these edges is determined by the auxiliary color.
SolidWireframe | Displays textured and lit geometric shapes (triangles) with single color edges on top of them. The color of these edges is determined by the auxiliary color.
Transparent | Displays textured and lit geometric shapes (triangles) with an added level of transparency. The auxiliary color is ignored.
TransparentBoundingBox | Displays bounding boxes faces of each node with an added level of transparency. The color of the bounding box faces is determined by the face color.
TransparentBoundingBoxOutline | Displays bounding boxes edges and faces of each node with an added level of transparency. The color of the bounding box edges is determined by the auxiliary color. The color of the bounding boxes faces is determined by the face color.
TransparentWireframe | Displays textured and lit geometric shapes (triangles) with an added level of transparency, with single color opaque edges on top of it. The color of these edges is determined by the auxiliary color.
Vertices | Displays only vertices in a single color. The color of these points is determined by the auxiliary color.
Wireframe | Displays only edges in a single color. The color of these edges is determined by the auxiliary color.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DRenderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFAnnotationFlags Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationFlags Enumeration
Specifies the available flags for an annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PDFAnnotationFlags
   Inherits System.Enum
'Usage

Dim instance As PDFAnnotationFlags
[Flags()]
public enum PDFAnnotationFlags : System.Enum
[Flags()]
__value public enum PDFAnnotationFlags : public System.Enum
[Flags()]
public enum class PDFAnnotationFlags : public System.Enum
Members
Member | Description
Hidden | If set, do not display or print the annotation or allow it to interact with the user.
Invisible | If set, do not display the annotation if it does not belong to one of the standard annotation types.
Locked | If set, do not allow the annotation to be deleted or its properties (including position and size) to be modified by the user. However, this flag does not restrict changes to the annotation’s contents, such as the value of a form field.
LockedContents | If set, do not allow the contents of the annotation to be modified by the user. This flag does not restrict deletion of the annotation or changes to other annotation properties, such as position and size.
NoRotate | If set, do not rotate the annotation's appearance to match the rotation of the page.
NoView | If set, do not display the annotation on the screen or allow it to interact with the user. The annotation may be printed (depending on the Print flag), but should be considered hidden for the purposes of onscreen display and user interaction.
NoZoom | If set, do not scale the annotation's appearance to match the magnification of the page.
Print | If set, print the annotation when the page is printed. If clear, never print the annotation, regardless of whether it is displayed on the screen.
ReadOnly | If set, do not allow the annotation to interact with the user.
ToggleNoView | If set, invert the interpretation of the NoView flag for certain events.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFAnnotationFlags

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFAnnotationType Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationType Enumeration
Specifies the available types of annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFAnnotationType
   Inherits System.Enum
'Usage

Dim instance As PDFAnnotationType
public enum PDFAnnotationType : System.Enum
__value public enum PDFAnnotationType : public System.Enum
public enum class PDFAnnotationType : public System.Enum
Members
Member | Description
_3D | 3D annotation.
Ellipse | Ellipse (Circle) annotation.
FileAttachment | File attachment annotation.
Flash | Flash annotation.
FreeText | Free text annotation.
Highlight | Highlight annotation.
Ink | Ink annotation.
Line | Line annotation.
Link | Link annotation.
Movie | Movie annotation.
Rectangle | Rectangle (Square) annotation.
Squiggly | Squiggly annotation.
Stamp | Stamp annotation.
StrikeOut | StrikeOut annotation.
Text | Text annotation.
Underline | Underline annotation.
Unknown | Unknown annotation.
Widget | Field widget annotation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFAnnotationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFBorderStyle Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFBorderStyle Enumeration
Specifies the available styles for an annotation's border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFBorderStyle
   Inherits System.Enum
'Usage

Dim instance As PDFBorderStyle
public enum PDFBorderStyle : System.Enum
__value public enum PDFBorderStyle : public System.Enum
public enum class PDFBorderStyle : public System.Enum
Members
Member | Description
Beveled | A simulated embossed rectangle that appears to be raised above the surface of the page.
Dashed | A dashed rectangle surrounding the annotation.
Inset | A simulated engraved rectangle that appears to be recessed below the surface of the page.
Solid | A solid rectangle surrounding the annotation.
Underline | A single line along the bottom of the annotation rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFFileAttachmentAnnotationIcon Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotationIcon Enumeration
Specifies the available icons for a file attachment annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFileAttachmentAnnotationIcon
   Inherits System.Enum
'Usage

Dim instance As PDFFileAttachmentAnnotationIcon
public enum PDFFileAttachmentAnnotationIcon : System.Enum
__value public enum PDFFileAttachmentAnnotationIcon : public System.Enum
public enum class PDFFileAttachmentAnnotationIcon : public System.Enum
Members
Member | Description
Custom | Custom appearance.
Graph | Graph icon.
Paperclip | Paperclip icon.
PushPin | Push pin icon.
Tag | Tag icon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotationIcon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFLineDirection Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFLineDirection Enumeration
Specifies the available directions for a line annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFLineDirection
   Inherits System.Enum
'Usage

Dim instance As PDFLineDirection
public enum PDFLineDirection : System.Enum
__value public enum PDFLineDirection : public System.Enum
public enum class PDFLineDirection : public System.Enum
Members
Member | Description
BottomLeftToTopRight | Line starts at bottom left corner and ends at top right corner.
BottomRightToTopLeft | Line starts at bottom right corner and ends at top left corner.
BottomToTop | Vertical line from bottom to top.
LeftToRight | Horizontal line from left to right.
RightToLeft | Horizontal line from right to left.
TopLeftToBottomRight | Line starts at top left corner and ends at bottom right corner.
TopRightToBottomLeft | Line starts at top right corner and ends at bottom left corner.
TopToBottom | Vertical line from top to bottom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFLineDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFLineEndingStyle Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFLineEndingStyle Enumeration
Specifies the available line ending styles to be used when drawing a line annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFLineEndingStyle
   Inherits System.Enum
'Usage

Dim instance As PDFLineEndingStyle
public enum PDFLineEndingStyle : System.Enum
__value public enum PDFLineEndingStyle : public System.Enum
public enum class PDFLineEndingStyle : public System.Enum
Members
Member | Description
Circle | A circle filled with annotation's interior color, if any.
ClosedArrow | Two short lines meeting in an acute angle as in the OpenArrow style, connected by a third line to form a triangular closed arrowhead filled with annotation's interior color, if any.
Diamond | A diamond filled with annotation's interior color, if any.
None | No line ending.
OpenArrow | Two short lines meeting in an acute angle, forming a open arrow head.
Square | A square filled with annotation's interior color, if any.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFLineEndingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFLinkHighlightMode Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFLinkHighlightMode Enumeration
Specifies the available highlighting modes for a link annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFLinkHighlightMode
   Inherits System.Enum
'Usage

Dim instance As PDFLinkHighlightMode
public enum PDFLinkHighlightMode : System.Enum
__value public enum PDFLinkHighlightMode : public System.Enum
public enum class PDFLinkHighlightMode : public System.Enum
Members
Member | Description
Invert | Inverts the content of link's normal appearance.
None | No highlighting, the link's appearance does not change when the link is activated.
Outline | Inverts the link's border.
Push | Displays the link's down appearance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFLinkHighlightMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFMovieType Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFMovieType Enumeration
Specifies the available movie types to be included in a PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFMovieType
   Inherits System.Enum
'Usage

Dim instance As PDFMovieType
public enum PDFMovieType : System.Enum
__value public enum PDFMovieType : public System.Enum
public enum class PDFMovieType : public System.Enum
Members
Member | Description
Video_Avi | A video file with video/avi MIME type.
Video_Flc | A video file with video/flc MIME type.
Video_Mp4 | A video file with video/mp4 MIME type.
Video_Mpeg | A video file with video/mpeg MIME type.
Video_Mpg | A video file with video/mpg MIME type.
Video_MsVideo | A video file with video/msvideo MIME type.
Video_QuickTime | A video file with video/quicktime MIME type.
Video_X_Dv | A video file with video/x-dv MIME type.
Video_X_Ivf | A video file with video/x-ivf MIME type.
Video_X_Mpeg | A video file with video/x-mpeg MIME type.
Video_X_Mpg | A video file with video/x-mpg MIME type.
Video_X_Ms_Asf | A video file with video/x-ms-asf MIME type.
Video_X_Ms_Asx | A video file with video/x-ms-asx MIME type.
Video_X_Ms_Wm | A video file with video/x-ms-wm MIME type.
Video_X_Ms_Wmp | A video file with video/x-ms-wmp MIME type.
Video_X_Ms_Wmv | A video file with video/x-ms-wmv MIME type.
Video_X_Ms_Wmx | A video file with video/x-ms-wmx MIME type.
Video_X_Ms_Wvx | A video file with video/x-ms-wvx MIME type.
Video_X_MsVideo | A video file with video/x-msvideo MIME type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFMovieType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFRubberStampAnnotationIcon Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotationIcon Enumeration
Specifies the available icons for a stmap annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFRubberStampAnnotationIcon
   Inherits System.Enum
'Usage

Dim instance As PDFRubberStampAnnotationIcon
public enum PDFRubberStampAnnotationIcon : System.Enum
__value public enum PDFRubberStampAnnotationIcon : public System.Enum
public enum class PDFRubberStampAnnotationIcon : public System.Enum
Members
Member | Description
Approved | Approved icon.
AsIs | As Is icon.
Confidential | Confidential icon.
Custom | User defined custom icon.
Departmental | Departmental icon.
Draft | Draft icon.
Experimental | Experimental icon.
Expired | Expired icon.
Final | Final icon.
ForComment | for comment icon.
ForPublicRelease | For public release icon.
NotApproved | Not approved icon.
NotForPublicRelease | Not for public release icon.
Sold | Sold icon.
TopSecret | Top secret icon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotationIcon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextAnnotationIcon Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotationIcon Enumeration
Specifies the available icons for a text annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFTextAnnotationIcon
   Inherits System.Enum
'Usage

Dim instance As PDFTextAnnotationIcon
public enum PDFTextAnnotationIcon : System.Enum
__value public enum PDFTextAnnotationIcon : public System.Enum
public enum class PDFTextAnnotationIcon : public System.Enum
Members
Member | Description
Check | Check mark icon.
Circle | Circle icon.
Comment | Comment icon.
Cross | Cross icon.
Custom | User defined custom icon.
Help | Help icon.
Insert | Insert icon.
Key | Key icon.
NewParagraph | New paragraph icon.
Note | Note icon.
Paragraph | Paragraph icon.
RightArrow | Right arrow icon.
RightPointer | Right pointer icon.
Star | Star arrow icon.
UpArrow | Up arrow icon.
UpLeftArrow | Up left arrow icon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFTextAnnotationIcon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextAnnotationState Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotationState Enumeration
Specifies the available states for a text annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFTextAnnotationState
   Inherits System.Enum
'Usage

Dim instance As PDFTextAnnotationState
public enum PDFTextAnnotationState : System.Enum
__value public enum PDFTextAnnotationState : public System.Enum
public enum class PDFTextAnnotationState : public System.Enum
Members
Member | Description
Accepted | The user agrees with the change.
Cancelled | The change has been cancelled.
Completed | The change has been completed.
Marked | The annotation has been marked by the user.
None | The user has indicated nothing about the change.
NoState | No state has been associated with the annotation.
Rejected | The user disagrees with the change.
Unmarked | The annotation has not been marked by the user.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFTextAnnotationState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextMarkupType Enumeration

O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupType Enumeration
Specifies the available markup types for a text markup annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFTextMarkupType
   Inherits System.Enum
'Usage

Dim instance As PDFTextMarkupType
public enum PDFTextMarkupType : System.Enum
__value public enum PDFTextMarkupType : public System.Enum
public enum class PDFTextMarkupType : public System.Enum
Members
Member | Description
Highlight | Highlight.
Squiggly | Jagged underline.
StrikeOut | Strike out.
Underline | Underline.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFTextMarkupType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


O2S.Components.PDF4NET.Annotations.RichMedia Namespace
Inheritance Hierarchy
Enumerations
 | Enumeration | Description
Enumeration | PDFRichMediaActivationCondition | Specifies the available modes for activating a rich media annotation.
Enumeration | PDFRichMediaDeactivationCondition | Specifies the available modes for deactivating a rich media annotation.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFRichMediaActivationCondition Enumeration

O2S.Components.PDF4NET.Annotations.RichMedia Namespace : PDFRichMediaActivationCondition Enumeration
Specifies the available modes for activating a rich media annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFRichMediaActivationCondition
   Inherits System.Enum
'Usage

Dim instance As PDFRichMediaActivationCondition
public enum PDFRichMediaActivationCondition : System.Enum
__value public enum PDFRichMediaActivationCondition : public System.Enum
public enum class PDFRichMediaActivationCondition : public System.Enum
Members
Member | Description
ExplicitActivation | The user explicitly activates the annotation.
PageOpen | The annotation is activated when the page receives focus as current page.
PageVisible | The annotation is activated when the page becomes visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.RichMedia.PDFRichMediaActivationCondition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations.RichMedia Namespace


%%PageItemTitle%%

PDFRichMediaDeactivationCondition Enumeration

O2S.Components.PDF4NET.Annotations.RichMedia Namespace : PDFRichMediaDeactivationCondition Enumeration
Specifies the available modes for deactivating a rich media annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFRichMediaDeactivationCondition
   Inherits System.Enum
'Usage

Dim instance As PDFRichMediaDeactivationCondition
public enum PDFRichMediaDeactivationCondition : System.Enum
__value public enum PDFRichMediaDeactivationCondition : public System.Enum
public enum class PDFRichMediaDeactivationCondition : public System.Enum
Members
Member | Description
ExplicitDeactivation | The user explicitly deactivates the annotation.
PageClose | The annotation is deactivated when the page loses focus as current page.
PageInvisible | The annotation is deactivated when the page becomes entirely invisible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.RichMedia.PDFRichMediaDeactivationCondition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Annotations.RichMedia Namespace


O2S.Components.PDF4NET.Converters Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFConverter | Provides conversion services from different file formats to PDF.
Class | PDFConvertOptions | Provides several parameters for converting files to PDF.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFConverter Class
Members

O2S.Components.PDF4NET.Converters Namespace : PDFConverter Class
Provides conversion services from different file formats to PDF.
Object Model
PDFConverter Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFConverter
'Usage

Dim instance As PDFConverter
public class PDFConverter
public __gc class PDFConverter
public ref class PDFConverter
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Converters.PDFConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConverter Members
O2S.Components.PDF4NET.Converters Namespace


%%PageItemTitle%% $$Members$$

PDFConverter Class Members
Methods

O2S.Components.PDF4NET.Converters Namespace : PDFConverter Class

The following tables list the members exposed by PDFConverter.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ConvertTiffToPDF | Overloaded. Converts a multipage TIFF image to PDF.
Top
See Also

Reference

PDFConverter Class
O2S.Components.PDF4NET.Converters Namespace


%%PageItemTitle%% $$Methods$$

PDFConverter Class Methods

O2S.Components.PDF4NET.Converters Namespace : PDFConverter Class

For a list of all members of this type, see PDFConverter members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ConvertTiffToPDF | Overloaded. Converts a multipage TIFF image to PDF.
Top
See Also

Reference

PDFConverter Class
O2S.Components.PDF4NET.Converters Namespace


ConvertTiffToPDF Method

O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class : ConvertTiffToPDF Method
Converts a multipage TIFF image to PDF.
Overload List
Overload | Description
ConvertTiffToPDF(String,String) | Converts a multipage TIFF image to PDF.
ConvertTiffToPDF(String,String,PDFConvertOptions) | Converts a multipage TIFF image to PDF.
ConvertTiffToPDF(Stream,Stream) | Converts a multipage TIFF image to PDF.
ConvertTiffToPDF(Stream,Stream,PDFConvertOptions) | Converts a multipage TIFF image to PDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConverter Class
PDFConverter Members


ConvertTiffToPDF(String,String) Method

O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class > ConvertTiffToPDF Method : ConvertTiffToPDF(String,String) Method
Source TIFF image to convert.
Destination PDF file.
Converts a multipage TIFF image to PDF.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertTiffToPDF( _
   ByVal sourceTiffFile As String, _
   ByVal destinationPdfFile As String _
)
'Usage

Dim sourceTiffFile As String
Dim destinationPdfFile As String

PDFConverter.ConvertTiffToPDF(sourceTiffFile, destinationPdfFile)
public static void ConvertTiffToPDF(
   string sourceTiffFile,
   string destinationPdfFile
)
public: static void ConvertTiffToPDF(
   string* sourceTiffFile,
   string* destinationPdfFile
)
public:
static void ConvertTiffToPDF(
   String^ sourceTiffFile,
   String^ destinationPdfFile
)

Parameters

sourceTiffFile
Source TIFF image to convert.
destinationPdfFile
Destination PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConverter Class
PDFConverter Members
Overload List


ConvertTiffToPDF(String,String,PDFConvertOptions) Method

O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class > ConvertTiffToPDF Method : ConvertTiffToPDF(String,String,PDFConvertOptions) Method
Source TIFF image to convert.
Destination PDF file.
Options for converting the TIFF image to PDF.
Converts a multipage TIFF image to PDF.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertTiffToPDF( _
   ByVal sourceTiffFile As String, _
   ByVal destinationPdfFile As String, _
   ByVal options As PDFConvertOptions _
)
'Usage

Dim sourceTiffFile As String
Dim destinationPdfFile As String
Dim options As PDFConvertOptions

PDFConverter.ConvertTiffToPDF(sourceTiffFile, destinationPdfFile, options)
public static void ConvertTiffToPDF(
   string sourceTiffFile,
   string destinationPdfFile,
   PDFConvertOptions options
)
public: static void ConvertTiffToPDF(
   string* sourceTiffFile,
   string* destinationPdfFile,
   PDFConvertOptions* options
)
public:
static void ConvertTiffToPDF(
   String^ sourceTiffFile,
   String^ destinationPdfFile,
   PDFConvertOptions^ options
)

Parameters

sourceTiffFile
Source TIFF image to convert.
destinationPdfFile
Destination PDF file.
options
Options for converting the TIFF image to PDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConverter Class
PDFConverter Members
Overload List


ConvertTiffToPDF(Stream,Stream) Method

O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class > ConvertTiffToPDF Method : ConvertTiffToPDF(Stream,Stream) Method
Source TIFF image to convert.
Destination PDF file.
Converts a multipage TIFF image to PDF.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertTiffToPDF( _
   ByVal sourceTiffStream As Stream, _
   ByVal destinationPdfStream As Stream _
)
'Usage

Dim sourceTiffStream As Stream
Dim destinationPdfStream As Stream

PDFConverter.ConvertTiffToPDF(sourceTiffStream, destinationPdfStream)
public static void ConvertTiffToPDF(
   Stream sourceTiffStream,
   Stream destinationPdfStream
)
public: static void ConvertTiffToPDF(
   Stream* sourceTiffStream,
   Stream* destinationPdfStream
)
public:
static void ConvertTiffToPDF(
   Stream^ sourceTiffStream,
   Stream^ destinationPdfStream
)

Parameters

sourceTiffStream
Source TIFF image to convert.
destinationPdfStream
Destination PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConverter Class
PDFConverter Members
Overload List


ConvertTiffToPDF(Stream,Stream,PDFConvertOptions) Method

O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class > ConvertTiffToPDF Method : ConvertTiffToPDF(Stream,Stream,PDFConvertOptions) Method
Source TIFF image to convert.
Destination PDF file.
Options for converting the TIFF image to PDF.
Converts a multipage TIFF image to PDF.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub ConvertTiffToPDF( _
   ByVal sourceTiffStream As Stream, _
   ByVal destinationPdfStream As Stream, _
   ByVal options As PDFConvertOptions _
)
'Usage

Dim sourceTiffStream As Stream
Dim destinationPdfStream As Stream
Dim options As PDFConvertOptions

PDFConverter.ConvertTiffToPDF(sourceTiffStream, destinationPdfStream, options)
public static void ConvertTiffToPDF(
   Stream sourceTiffStream,
   Stream destinationPdfStream,
   PDFConvertOptions options
)
public: static void ConvertTiffToPDF(
   Stream* sourceTiffStream,
   Stream* destinationPdfStream,
   PDFConvertOptions* options
)
public:
static void ConvertTiffToPDF(
   Stream^ sourceTiffStream,
   Stream^ destinationPdfStream,
   PDFConvertOptions^ options
)

Parameters

sourceTiffStream
Source TIFF image to convert.
destinationPdfStream
Destination PDF file.
options
Options for converting the TIFF image to PDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConverter Class
PDFConverter Members
Overload List


%%PageItemTitle%%

PDFConvertOptions Class
Members

O2S.Components.PDF4NET.Converters Namespace : PDFConvertOptions Class
Provides several parameters for converting files to PDF.
Object Model
PDFConvertOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFConvertOptions
'Usage

Dim instance As PDFConvertOptions
public class PDFConvertOptions
public __gc class PDFConvertOptions
public ref class PDFConvertOptions
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Converters.PDFConvertOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConvertOptions Members
O2S.Components.PDF4NET.Converters Namespace


%%PageItemTitle%% $$Members$$

PDFConvertOptions Class Members
Properties

O2S.Components.PDF4NET.Converters Namespace : PDFConvertOptions Class

The following tables list the members exposed by PDFConvertOptions.

Public Constructors
 | Name | Description
Public Constructor | PDFConvertOptions Constructor | Initializes a new PDFConvertOptions object.
Top
Public Properties
 | Name | Description
Public Property | PageHeight | Gets or sets the height of the page in the destination PDF file.
Public Property | PageWidth | Gets or sets the width of the pages in the destination PDF file.
Top
See Also

Reference

PDFConvertOptions Class
O2S.Components.PDF4NET.Converters Namespace


%%PageItemTitle%%

PDFConvertOptions Constructor

O2S.Components.PDF4NET.Converters Namespace > PDFConvertOptions Class : PDFConvertOptions Constructor
Initializes a new PDFConvertOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFConvertOptions()
public PDFConvertOptions()
public: PDFConvertOptions();
public:
PDFConvertOptions();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConvertOptions Class
PDFConvertOptions Members


%%PageItemTitle%% $$Properties$$

PDFConvertOptions Class Properties

O2S.Components.PDF4NET.Converters Namespace : PDFConvertOptions Class

For a list of all members of this type, see PDFConvertOptions members.

Public Properties
 | Name | Description
Public Property | PageHeight | Gets or sets the height of the page in the destination PDF file.
Public Property | PageWidth | Gets or sets the width of the pages in the destination PDF file.
Top
See Also

Reference

PDFConvertOptions Class
O2S.Components.PDF4NET.Converters Namespace


PageHeight Property (PDFConvertOptions)

O2S.Components.PDF4NET.Converters Namespace > PDFConvertOptions Class : PageHeight Property
Gets or sets the height of the page in the destination PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageHeight As Double
'Usage

Dim instance As PDFConvertOptions
Dim value As Double

instance.PageHeight = value

value = instance.PageHeight
public double PageHeight {get; set;}
public: __property double get_PageHeight();
public: __property void set_PageHeight(
   double value
);
public:
property double PageHeight {
   double get();
   void set (    double value);
}

Property Value

The height of the pages in the destination PDF file
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConvertOptions Class
PDFConvertOptions Members


PageWidth Property (PDFConvertOptions)

O2S.Components.PDF4NET.Converters Namespace > PDFConvertOptions Class : PageWidth Property
Gets or sets the width of the pages in the destination PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageWidth As Double
'Usage

Dim instance As PDFConvertOptions
Dim value As Double

instance.PageWidth = value

value = instance.PageWidth
public double PageWidth {get; set;}
public: __property double get_PageWidth();
public: __property void set_PageWidth(
   double value
);
public:
property double PageWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the pages in the destination PDF file
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFConvertOptions Class
PDFConvertOptions Members


O2S.Components.PDF4NET.Cos Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | IncompatiblePDFObjectException | The exception that is thrown when a PDF object cannot be converted to requested type.
Class | InvalidPDFValueException | The exception that is thrown when the value for a PDF object is invalid.
Class | PDFArray | Defines a PDF object that represents an array.
Class | PDFBoolean | Defines a PDF object that represents a boolean value.
Class | PDFCosObject | Defines a PDF COS object in the PDF file.
Class | PDFDateTime | Defines a PDF object that represents a date.
Class | PDFDictionary | Defines a PDF object that represents a dictionary.
Class | PDFName | Defines a PDF object that represents a name value.
Class | PDFNull | Defines a PDF object that represents the null PDF value.
Class | PDFNumber | Defines a PDF object that represents a number.
Class | PDFObject | Base class for all PDF objects.
Class | PDFString | Defines a PDF object that represents a string.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

IncompatiblePDFObjectException Class
Members

O2S.Components.PDF4NET.Cos Namespace : IncompatiblePDFObjectException Class
The exception that is thrown when a PDF object cannot be converted to requested type.
Object Model
IncompatiblePDFObjectException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class IncompatiblePDFObjectException
   Inherits O2S.Components.PDF4NET.PDFException
'Usage

Dim instance As IncompatiblePDFObjectException
public class IncompatiblePDFObjectException : O2S.Components.PDF4NET.PDFException
public __gc class IncompatiblePDFObjectException : public O2S.Components.PDF4NET.PDFException
public ref class IncompatiblePDFObjectException : public O2S.Components.PDF4NET.PDFException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.Cos.IncompatiblePDFObjectException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IncompatiblePDFObjectException Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

IncompatiblePDFObjectException Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : IncompatiblePDFObjectException Class

The following tables list the members exposed by IncompatiblePDFObjectException.

Public Constructors
 | Name | Description
Public Constructor | IncompatiblePDFObjectException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

IncompatiblePDFObjectException Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

IncompatiblePDFObjectException Constructor

O2S.Components.PDF4NET.Cos Namespace > IncompatiblePDFObjectException Class : IncompatiblePDFObjectException Constructor
Overload List
Overload | Description
IncompatiblePDFObjectException Constructor(String) | Initializes a new IncompatiblePDFObjectException object.
IncompatiblePDFObjectException Constructor(String,Exception) | Initializes a new IncompatiblePDFObjectException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IncompatiblePDFObjectException Class
IncompatiblePDFObjectException Members


%%PageItemTitle%%

IncompatiblePDFObjectException Constructor(String)

O2S.Components.PDF4NET.Cos Namespace > IncompatiblePDFObjectException Class > IncompatiblePDFObjectException Constructor : IncompatiblePDFObjectException Constructor(String)
The message that describes the exception.
Initializes a new IncompatiblePDFObjectException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New IncompatiblePDFObjectException(message)
public IncompatiblePDFObjectException(
   string message
)
public: IncompatiblePDFObjectException(
   string* message
)
public:
IncompatiblePDFObjectException(
   String^ message
)

Parameters

message
The message that describes the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IncompatiblePDFObjectException Class
IncompatiblePDFObjectException Members
Overload List


%%PageItemTitle%%

IncompatiblePDFObjectException Constructor(String,Exception)

O2S.Components.PDF4NET.Cos Namespace > IncompatiblePDFObjectException Class > IncompatiblePDFObjectException Constructor : IncompatiblePDFObjectException Constructor(String,Exception)
the message that describes the exception.
The exception that is the cause of the current exception.
Initializes a new IncompatiblePDFObjectException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New IncompatiblePDFObjectException(message, innerException)
public IncompatiblePDFObjectException(
   string message,
   Exception innerException
)
public: IncompatiblePDFObjectException(
   string* message,
   Exception* innerException
)
public:
IncompatiblePDFObjectException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IncompatiblePDFObjectException Class
IncompatiblePDFObjectException Members
Overload List


%%PageItemTitle%%

InvalidPDFValueException Class
Members

O2S.Components.PDF4NET.Cos Namespace : InvalidPDFValueException Class
The exception that is thrown when the value for a PDF object is invalid.
Object Model
InvalidPDFValueException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class InvalidPDFValueException
   Inherits O2S.Components.PDF4NET.PDFException
'Usage

Dim instance As InvalidPDFValueException
public class InvalidPDFValueException : O2S.Components.PDF4NET.PDFException
public __gc class InvalidPDFValueException : public O2S.Components.PDF4NET.PDFException
public ref class InvalidPDFValueException : public O2S.Components.PDF4NET.PDFException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.Cos.InvalidPDFValueException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPDFValueException Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

InvalidPDFValueException Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : InvalidPDFValueException Class

The following tables list the members exposed by InvalidPDFValueException.

Public Constructors
 | Name | Description
Public Constructor | InvalidPDFValueException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPDFValueException Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

InvalidPDFValueException Constructor

O2S.Components.PDF4NET.Cos Namespace > InvalidPDFValueException Class : InvalidPDFValueException Constructor
Overload List
Overload | Description
InvalidPDFValueException Constructor(String) | Initializes a new InvalidPDFValueException object.
InvalidPDFValueException Constructor(String,Exception) | Initializes a new InvalidPDFValueException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPDFValueException Class
InvalidPDFValueException Members


%%PageItemTitle%%

InvalidPDFValueException Constructor(String)

O2S.Components.PDF4NET.Cos Namespace > InvalidPDFValueException Class > InvalidPDFValueException Constructor : InvalidPDFValueException Constructor(String)
The message that describes the exception.
Initializes a new InvalidPDFValueException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPDFValueException(message)
public InvalidPDFValueException(
   string message
)
public: InvalidPDFValueException(
   string* message
)
public:
InvalidPDFValueException(
   String^ message
)

Parameters

message
The message that describes the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPDFValueException Class
InvalidPDFValueException Members
Overload List


%%PageItemTitle%%

InvalidPDFValueException Constructor(String,Exception)

O2S.Components.PDF4NET.Cos Namespace > InvalidPDFValueException Class > InvalidPDFValueException Constructor : InvalidPDFValueException Constructor(String,Exception)
the message that describes the exception.
The exception that is the cause of the current exception.
Initializes a new InvalidPDFValueException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidPDFValueException(message, innerException)
public InvalidPDFValueException(
   string message,
   Exception innerException
)
public: InvalidPDFValueException(
   string* message,
   Exception* innerException
)
public:
InvalidPDFValueException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPDFValueException Class
InvalidPDFValueException Members
Overload List


%%PageItemTitle%%

PDFArray Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFArray Class
Defines a PDF object that represents an array.
Object Model
PDFArray ClassPDFObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PDFArray
   Inherits PDFObject
'Usage

Dim instance As PDFArray
[DefaultMember("Item")]
public class PDFArray : PDFObject
[DefaultMember("Item")]
public __gc class PDFArray : public PDFObject
[DefaultMember("Item")]
public ref class PDFArray : public PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFArray

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFArray Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : PDFArray Class

The following tables list the members exposed by PDFArray.

Public Constructors
 | Name | Description
Public Constructor | PDFArray Constructor | Initializes a new PDFArray object.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets the item at the specified index.
Public Property | Length | Gets the number of items in the array.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a new element at the end of the array.
Public Method | Clear | Removes all the elements from the array.
Public Method | IndexOf | Searches the array for the specified object and returns its position in the array.
Public Method | Insert | Inserts a new element in the array at the specified position.
Public Method | Remove | Removes the specified PDF object from the array.
Public Method | RemoveAt | Removes the array item at the specified position.
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFArray Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFArray Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : PDFArray Constructor
Initializes a new PDFArray object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFArray()
public PDFArray()
public: PDFArray();
public:
PDFArray();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


%%PageItemTitle%% $$Methods$$

PDFArray Class Methods

O2S.Components.PDF4NET.Cos Namespace : PDFArray Class

For a list of all members of this type, see PDFArray members.

Public Methods
 | Name | Description
Public Method | Add | Adds a new element at the end of the array.
Public Method | Clear | Removes all the elements from the array.
Public Method | IndexOf | Searches the array for the specified object and returns its position in the array.
Public Method | Insert | Inserts a new element in the array at the specified position.
Public Method | Remove | Removes the specified PDF object from the array.
Public Method | RemoveAt | Removes the array item at the specified position.
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFArray Class
O2S.Components.PDF4NET.Cos Namespace


Add Method (PDFArray)

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Add Method
Item to add the end of the array.
Adds a new element at the end of the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Add( _
   ByVal item As PDFObject _
)
'Usage

Dim instance As PDFArray
Dim item As PDFObject

instance.Add(item)
public void Add(
   PDFObject item
)
public: void Add(
   PDFObject* item
)
public:
void Add(
   PDFObject^ item
)

Parameters

item
Item to add the end of the array.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the item is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


Clear Method (PDFArray)

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Clear Method
Removes all the elements from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As PDFArray

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


IndexOf Method

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : IndexOf Method
Object to search.
Searches the array for the specified object and returns its position in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal obj As PDFObject _
) As Integer
'Usage

Dim instance As PDFArray
Dim obj As PDFObject
Dim value As Integer

value = instance.IndexOf(obj)
public int IndexOf(
   PDFObject obj
)
public: int IndexOf(
   PDFObject* obj
)
public:
int IndexOf(
   PDFObject^ obj
)

Parameters

obj
Object to search.

Return Value

Position of object if it exists in the array, -1 otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


Insert Method (PDFArray)

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Insert Method
Position where to insert the new element.
New element to insert in the array.
Inserts a new element in the array at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As PDFObject _
)
'Usage

Dim instance As PDFArray
Dim index As Integer
Dim item As PDFObject

instance.Insert(index, item)
public void Insert(
   int index,
   PDFObject item
)
public: void Insert(
   int index,
   PDFObject* item
)
public:
void Insert(
   int index,
   PDFObject^ item
)

Parameters

index
Position where to insert the new element.
item
New element to insert in the array.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the item is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


Remove Method (PDFArray)

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Remove Method
Object to remove.
Removes the specified PDF object from the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove( _
   ByVal obj As PDFObject _
)
'Usage

Dim instance As PDFArray
Dim obj As PDFObject

instance.Remove(obj)
public void Remove(
   PDFObject obj
)
public: void Remove(
   PDFObject* obj
)
public:
void Remove(
   PDFObject^ obj
)

Parameters

obj
Object to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


RemoveAt Method

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : RemoveAt Method
Position of the item to remove.
Removes the array item at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As PDFArray
Dim index As Integer

instance.RemoveAt(index)
public void RemoveAt(
   int index
)
public: void RemoveAt(
   int index
)
public:
void RemoveAt(
   int index
)

Parameters

index
Position of the item to remove.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of range.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


ToString Method (PDFArray)

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : ToString Method
Converts the object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFArray
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


%%PageItemTitle%% $$Properties$$

PDFArray Class Properties

O2S.Components.PDF4NET.Cos Namespace : PDFArray Class

For a list of all members of this type, see PDFArray members.

Public Properties
 | Name | Description
Public Property | Item | Gets the item at the specified index.
Public Property | Length | Gets the number of items in the array.
Top
See Also

Reference

PDFArray Class
O2S.Components.PDF4NET.Cos Namespace


Item Property (PDFArray)

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Item Property
Index of item to return.
Gets the item at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As PDFObject
'Usage

Dim instance As PDFArray
Dim index As Integer
Dim value As PDFObject

instance.Item(index) = value

value = instance.Item(index)
public PDFObject this[
   int index
]; {get; set;}
public: __property PDFObject* get_Item   int index
;
public: __property void set_Item   int index,
   PDFObject* value
;
public:
property PDFObject^ default [int] {
   PDFObject^ get(int index);
   void set (int index, PDFObject^ value);
}

Parameters

index
Index of item to return.

Property Value

A PDFObject representing the item.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the index value is invalid
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


Length Property

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Length Property
Gets the number of items in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Length As Integer
'Usage

Dim instance As PDFArray
Dim value As Integer

value = instance.Length
public int Length {get;}
public: __property int get_Length();
public:
property int Length {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


%%PageItemTitle%%

PDFBoolean Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFBoolean Class
Defines a PDF object that represents a boolean value.
Object Model
PDFBoolean Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFBoolean
   Inherits PDFObject
'Usage

Dim instance As PDFBoolean
public class PDFBoolean : PDFObject
public __gc class PDFBoolean : public PDFObject
public ref class PDFBoolean : public PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFBoolean

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBoolean Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFBoolean Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : PDFBoolean Class

The following tables list the members exposed by PDFBoolean.

Public Constructors
 | Name | Description
Public Constructor | PDFBoolean Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFBoolean Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFBoolean Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class : PDFBoolean Constructor
Overload List
Overload | Description
PDFBoolean Constructor() | Initializes a new PDFBoolean object.
PDFBoolean Constructor(Boolean) | Initializes a new PDFBoolean object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBoolean Class
PDFBoolean Members


%%PageItemTitle%%

PDFBoolean Constructor()

O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class > PDFBoolean Constructor : PDFBoolean Constructor()
Initializes a new PDFBoolean object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFBoolean()
public PDFBoolean()
public: PDFBoolean();
public:
PDFBoolean();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBoolean Class
PDFBoolean Members
Overload List


%%PageItemTitle%%

PDFBoolean Constructor(Boolean)

O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class > PDFBoolean Constructor : PDFBoolean Constructor(Boolean)
Initial object value.
Initializes a new PDFBoolean object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Boolean _
)
'Usage

Dim value As Boolean

Dim instance As New PDFBoolean(value)
public PDFBoolean(
   bool value
)
public: PDFBoolean(
   bool value
)
public:
PDFBoolean(
   bool value
)

Parameters

value
Initial object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBoolean Class
PDFBoolean Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFBoolean Class Methods

O2S.Components.PDF4NET.Cos Namespace : PDFBoolean Class

For a list of all members of this type, see PDFBoolean members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFBoolean Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method (PDFBoolean)

O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class : ToString Method
Converts the object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFBoolean
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBoolean Class
PDFBoolean Members


%%PageItemTitle%% $$Properties$$

PDFBoolean Class Properties

O2S.Components.PDF4NET.Cos Namespace : PDFBoolean Class

For a list of all members of this type, see PDFBoolean members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PDFBoolean Class
O2S.Components.PDF4NET.Cos Namespace


Value Property (PDFBoolean)

O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Boolean
'Usage

Dim instance As PDFBoolean
Dim value As Boolean

instance.Value = value

value = instance.Value
public bool Value {get; set;}
public: __property bool get_Value();
public: __property void set_Value(
   bool value
);
public:
property bool Value {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBoolean Class
PDFBoolean Members


%%PageItemTitle%%

PDFCosObject Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFCosObject Class
Defines a PDF COS object in the PDF file.
Object Model
PDFCosObject ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCosObject
   Inherits PDFObject
'Usage

Dim instance As PDFCosObject
public class PDFCosObject : PDFObject
public __gc class PDFCosObject : public PDFObject
public ref class PDFCosObject : public PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFCosObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObject Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFCosObject Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : PDFCosObject Class

The following tables list the members exposed by PDFCosObject.

Public Constructors
 | Name | Description
Public Constructor | PDFCosObject Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DecodedStream | Gets the object's decoded stream.
Public Property | Dictionary | Gets or sets the object's dictionary.
Public Property | ObjectID | Gets the object id.
Public Property | Stream | Gets or sets the object' stream.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFCosObject Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFCosObject Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : PDFCosObject Constructor
Overload List
Overload | Description
PDFCosObject Constructor() | Initializes a new PDFCosObject object.
PDFCosObject Constructor(PDFDictionary) | Initializes a new PDFCosObject object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObject Class
PDFCosObject Members


%%PageItemTitle%%

PDFCosObject Constructor()

O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class > PDFCosObject Constructor : PDFCosObject Constructor()
Initializes a new PDFCosObject object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCosObject()
public PDFCosObject()
public: PDFCosObject();
public:
PDFCosObject();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObject Class
PDFCosObject Members
Overload List


%%PageItemTitle%%

PDFCosObject Constructor(PDFDictionary)

O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class > PDFCosObject Constructor : PDFCosObject Constructor(PDFDictionary)
Initial object value.
Initializes a new PDFCosObject object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dictionary As PDFDictionary _
)
'Usage

Dim dictionary As PDFDictionary

Dim instance As New PDFCosObject(dictionary)
public PDFCosObject(
   PDFDictionary dictionary
)
public: PDFCosObject(
   PDFDictionary* dictionary
)
public:
PDFCosObject(
   PDFDictionary^ dictionary
)

Parameters

dictionary
Initial object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObject Class
PDFCosObject Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFCosObject Class Methods

O2S.Components.PDF4NET.Cos Namespace : PDFCosObject Class

For a list of all members of this type, see PDFCosObject members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFCosObject Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method (PDFCosObject)

O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : ToString Method
Converts the object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFCosObject
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObject Class
PDFCosObject Members


%%PageItemTitle%% $$Properties$$

PDFCosObject Class Properties

O2S.Components.PDF4NET.Cos Namespace : PDFCosObject Class

For a list of all members of this type, see PDFCosObject members.

Public Properties
 | Name | Description
Public Property | DecodedStream | Gets the object's decoded stream.
Public Property | Dictionary | Gets or sets the object's dictionary.
Public Property | ObjectID | Gets the object id.
Public Property | Stream | Gets or sets the object' stream.
Top
See Also

Reference

PDFCosObject Class
O2S.Components.PDF4NET.Cos Namespace


DecodedStream Property

O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : DecodedStream Property
Gets the object's decoded stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DecodedStream As Byte()
'Usage

Dim instance As PDFCosObject
Dim value() As Byte

value = instance.DecodedStream
public byte[] DecodedStream {get;}
public: __property byte[]* get_DecodedStream();
public:
property array<byte>^ DecodedStream {
   array<byte>^ get();
}

Property Value

The object' decoded stream.
Remarks
This property returns the object stream after it has been decompressed and unfiltered
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObject Class
PDFCosObject Members


Dictionary Property (PDFCosObject)

O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : Dictionary Property
Gets or sets the object's dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFCosObject
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The inner dictionary of this COS object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObject Class
PDFCosObject Members


ObjectID Property

O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : ObjectID Property
Gets the object id.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObjectID As Long
'Usage

Dim instance As PDFCosObject
Dim value As Long

value = instance.ObjectID
public long ObjectID {get;}
public: __property long get_ObjectID();
public:
property int64 ObjectID {
   int64 get();
}
Remarks
The object ID is used when the object is saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObject Class
PDFCosObject Members


Stream Property (PDFCosObject)

O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : Stream Property
Gets or sets the object' stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Stream As Byte()
'Usage

Dim instance As PDFCosObject
Dim value() As Byte

instance.Stream = value

value = instance.Stream
public byte[] Stream {get; set;}
public: __property byte[]* get_Stream();
public: __property void set_Stream(
   byte[]* value
);
public:
property array<byte>^ Stream {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The object' stream.
Remarks
Object' stream is optional. This property returns the object' stream as it appears in the PDF file, possibly compressed and with other filters applied to it. If you need to plain stream data, use the DecodedStream property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObject Class
PDFCosObject Members


%%PageItemTitle%%

PDFDateTime Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFDateTime Class
Defines a PDF object that represents a date.
Object Model
PDFDateTime Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDateTime
   Inherits PDFObject
'Usage

Dim instance As PDFDateTime
public class PDFDateTime : PDFObject
public __gc class PDFDateTime : public PDFObject
public ref class PDFDateTime : public PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFDateTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDateTime Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFDateTime Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : PDFDateTime Class

The following tables list the members exposed by PDFDateTime.

Public Constructors
 | Name | Description
Public Constructor | PDFDateTime Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFDateTime Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFDateTime Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFDateTime Class : PDFDateTime Constructor
Overload List
Overload | Description
PDFDateTime Constructor() | Initializes a new PDFDateTime object.
PDFDateTime Constructor(DateTime) | Initializes a new PDFDateTime object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDateTime Class
PDFDateTime Members


%%PageItemTitle%%

PDFDateTime Constructor()

O2S.Components.PDF4NET.Cos Namespace > PDFDateTime Class > PDFDateTime Constructor : PDFDateTime Constructor()
Initializes a new PDFDateTime object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDateTime()
public PDFDateTime()
public: PDFDateTime();
public:
PDFDateTime();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDateTime Class
PDFDateTime Members
Overload List


%%PageItemTitle%%

PDFDateTime Constructor(DateTime)

O2S.Components.PDF4NET.Cos Namespace > PDFDateTime Class > PDFDateTime Constructor : PDFDateTime Constructor(DateTime)
Initial object value.
Initializes a new PDFDateTime object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Date _
)
'Usage

Dim value As Date

Dim instance As New PDFDateTime(value)
public PDFDateTime(
   DateTime value
)
public: PDFDateTime(
   DateTime value
)
public:
PDFDateTime(
   DateTime value
)

Parameters

value
Initial object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDateTime Class
PDFDateTime Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFDateTime Class Methods

O2S.Components.PDF4NET.Cos Namespace : PDFDateTime Class

For a list of all members of this type, see PDFDateTime members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFDateTime Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method (PDFDateTime)

O2S.Components.PDF4NET.Cos Namespace > PDFDateTime Class : ToString Method
Converts the object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFDateTime
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDateTime Class
PDFDateTime Members


%%PageItemTitle%% $$Properties$$

PDFDateTime Class Properties

O2S.Components.PDF4NET.Cos Namespace : PDFDateTime Class

For a list of all members of this type, see PDFDateTime members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PDFDateTime Class
O2S.Components.PDF4NET.Cos Namespace


Value Property (PDFDateTime)

O2S.Components.PDF4NET.Cos Namespace > PDFDateTime Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Date
'Usage

Dim instance As PDFDateTime
Dim value As Date

instance.Value = value

value = instance.Value
public DateTime Value {get; set;}
public: __property DateTime get_Value();
public: __property void set_Value(
   DateTime value
);
public:
property DateTime Value {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date/time that represents this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDateTime Class
PDFDateTime Members


%%PageItemTitle%%

PDFDictionary Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFDictionary Class
Defines a PDF object that represents a dictionary.
Object Model
PDFDictionary ClassPDFObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PDFDictionary
   Inherits PDFObject
'Usage

Dim instance As PDFDictionary
[DefaultMember("Item")]
public class PDFDictionary : PDFObject
[DefaultMember("Item")]
public __gc class PDFDictionary : public PDFObject
[DefaultMember("Item")]
public ref class PDFDictionary : public PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFDictionary

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDictionary Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFDictionary Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : PDFDictionary Class

The following tables list the members exposed by PDFDictionary.

Public Constructors
 | Name | Description
Public Constructor | PDFDictionary Constructor | Initializes a new PDFDictionary object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of items in the dictionary.
Public Property | Item | Gets or sets the value associated with the specified key.
Public Property | Keys | Gets the list of keys in the dictionary.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFDictionary Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFDictionary Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : PDFDictionary Constructor
Initializes a new PDFDictionary object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDictionary()
public PDFDictionary()
public: PDFDictionary();
public:
PDFDictionary();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDictionary Class
PDFDictionary Members


%%PageItemTitle%% $$Methods$$

PDFDictionary Class Methods

O2S.Components.PDF4NET.Cos Namespace : PDFDictionary Class

For a list of all members of this type, see PDFDictionary members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFDictionary Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method (PDFDictionary)

O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : ToString Method
Converts the object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFDictionary
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The object as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDictionary Class
PDFDictionary Members


%%PageItemTitle%% $$Properties$$

PDFDictionary Class Properties

O2S.Components.PDF4NET.Cos Namespace : PDFDictionary Class

For a list of all members of this type, see PDFDictionary members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of items in the dictionary.
Public Property | Item | Gets or sets the value associated with the specified key.
Public Property | Keys | Gets the list of keys in the dictionary.
Top
See Also

Reference

PDFDictionary Class
O2S.Components.PDF4NET.Cos Namespace


Count Property (PDFDictionary)

O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : Count Property
Gets the number of items in the dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As PDFDictionary
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDictionary Class
PDFDictionary Members


Item Property (PDFDictionary)

O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : Item Property
The key of the value to get or set.
Gets or sets the value associated with the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal key As String _
) As PDFObject
'Usage

Dim instance As PDFDictionary
Dim key As String
Dim value As PDFObject

instance.Item(key) = value

value = instance.Item(key)
public PDFObject this[
   string key
]; {get; set;}
public: __property PDFObject* get_Item   string* key
;
public: __property void set_Item   string* key,
   PDFObject* value
;
public:
property PDFObject^ default [String^] {
   PDFObject^ get(String^ key);
   void set (String^ key, PDFObject^ value);
}

Parameters

key
The key of the value to get or set.

Property Value

The value if the key exists in the dictionary, otherwise null.
Remarks
If the key already exists in the dictionary, the set operation overwrites it.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDictionary Class
PDFDictionary Members


Keys Property

O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : Keys Property
Gets the list of keys in the dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Keys As String()
'Usage

Dim instance As PDFDictionary
Dim value() As String

value = instance.Keys
public string[] Keys {get;}
public: __property string*[]* get_Keys();
public:
property array<String^>^ Keys {
   array<String^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDictionary Class
PDFDictionary Members


%%PageItemTitle%%

PDFName Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFName Class
Defines a PDF object that represents a name value.
Object Model
PDFName Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFName
   Inherits PDFObject
'Usage

Dim instance As PDFName
public class PDFName : PDFObject
public __gc class PDFName : public PDFObject
public ref class PDFName : public PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFName Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFName Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : PDFName Class

The following tables list the members exposed by PDFName.

Public Constructors
 | Name | Description
Public Constructor | PDFName Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFName Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFName Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFName Class : PDFName Constructor
Overload List
Overload | Description
PDFName Constructor() | Initializes a new PDFName object.
PDFName Constructor(String) | Initializes a new PDFName object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFName Class
PDFName Members


%%PageItemTitle%%

PDFName Constructor()

O2S.Components.PDF4NET.Cos Namespace > PDFName Class > PDFName Constructor : PDFName Constructor()
Initializes a new PDFName object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFName()
public PDFName()
public: PDFName();
public:
PDFName();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFName Class
PDFName Members
Overload List


%%PageItemTitle%%

PDFName Constructor(String)

O2S.Components.PDF4NET.Cos Namespace > PDFName Class > PDFName Constructor : PDFName Constructor(String)
Initial object value.
Initializes a new PDFName object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As String _
)
'Usage

Dim value As String

Dim instance As New PDFName(value)
public PDFName(
   string value
)
public: PDFName(
   string* value
)
public:
PDFName(
   String^ value
)

Parameters

value
Initial object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFName Class
PDFName Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFName Class Methods

O2S.Components.PDF4NET.Cos Namespace : PDFName Class

For a list of all members of this type, see PDFName members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFName Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method (PDFName)

O2S.Components.PDF4NET.Cos Namespace > PDFName Class : ToString Method
Converts the object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFName
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFName Class
PDFName Members


%%PageItemTitle%% $$Properties$$

PDFName Class Properties

O2S.Components.PDF4NET.Cos Namespace : PDFName Class

For a list of all members of this type, see PDFName members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PDFName Class
O2S.Components.PDF4NET.Cos Namespace


Value Property (PDFName)

O2S.Components.PDF4NET.Cos Namespace > PDFName Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As String
'Usage

Dim instance As PDFName
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFName Class
PDFName Members


%%PageItemTitle%%

PDFNull Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFNull Class
Defines a PDF object that represents the null PDF value.
Object Model
PDFNull Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFNull
   Inherits PDFObject
'Usage

Dim instance As PDFNull
public class PDFNull : PDFObject
public __gc class PDFNull : public PDFObject
public ref class PDFNull : public PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFNull

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNull Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFNull Class Members
Methods

O2S.Components.PDF4NET.Cos Namespace : PDFNull Class

The following tables list the members exposed by PDFNull.

Public Constructors
 | Name | Description
Public Constructor | PDFNull Constructor | Initializes a new PDFNull object.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFNull Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFNull Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFNull Class : PDFNull Constructor
Initializes a new PDFNull object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFNull()
public PDFNull()
public: PDFNull();
public:
PDFNull();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNull Class
PDFNull Members


%%PageItemTitle%% $$Methods$$

PDFNull Class Methods

O2S.Components.PDF4NET.Cos Namespace : PDFNull Class

For a list of all members of this type, see PDFNull members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFNull Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method (PDFNull)

O2S.Components.PDF4NET.Cos Namespace > PDFNull Class : ToString Method
Converts the object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFNull
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNull Class
PDFNull Members


%%PageItemTitle%%

PDFNumber Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFNumber Class
Defines a PDF object that represents a number.
Object Model
PDFNumber Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFNumber
   Inherits PDFObject
'Usage

Dim instance As PDFNumber
public class PDFNumber : PDFObject
public __gc class PDFNumber : public PDFObject
public ref class PDFNumber : public PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFNumber

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumber Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFNumber Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : PDFNumber Class

The following tables list the members exposed by PDFNumber.

Public Constructors
 | Name | Description
Public Constructor | PDFNumber Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFNumber Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFNumber Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class : PDFNumber Constructor
Overload List
Overload | Description
PDFNumber Constructor() | Initializes a new PDFNumber object.
PDFNumber Constructor(Double) | Initializes a new PDFNumber object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumber Class
PDFNumber Members


%%PageItemTitle%%

PDFNumber Constructor()

O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class > PDFNumber Constructor : PDFNumber Constructor()
Initializes a new PDFNumber object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFNumber()
public PDFNumber()
public: PDFNumber();
public:
PDFNumber();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumber Class
PDFNumber Members
Overload List


%%PageItemTitle%%

PDFNumber Constructor(Double)

O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class > PDFNumber Constructor : PDFNumber Constructor(Double)
Initial object value.
Initializes a new PDFNumber object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal _value As Double _
)
'Usage

Dim _value As Double

Dim instance As New PDFNumber(_value)
public PDFNumber(
   double _value
)
public: PDFNumber(
   double _value
)
public:
PDFNumber(
   double _value
)

Parameters

_value
Initial object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumber Class
PDFNumber Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFNumber Class Methods

O2S.Components.PDF4NET.Cos Namespace : PDFNumber Class

For a list of all members of this type, see PDFNumber members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFNumber Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method (PDFNumber)

O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class : ToString Method
Converts the object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFNumber
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumber Class
PDFNumber Members


%%PageItemTitle%% $$Properties$$

PDFNumber Class Properties

O2S.Components.PDF4NET.Cos Namespace : PDFNumber Class

For a list of all members of this type, see PDFNumber members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PDFNumber Class
O2S.Components.PDF4NET.Cos Namespace


Value Property (PDFNumber)

O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Double
'Usage

Dim instance As PDFNumber
Dim value As Double

instance.Value = value

value = instance.Value
public double Value {get; set;}
public: __property double get_Value();
public: __property void set_Value(
   double value
);
public:
property double Value {
   double get();
   void set (    double value);
}

Property Value

The number that represents this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumber Class
PDFNumber Members


%%PageItemTitle%%

PDFObject Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFObject Class
Base class for all PDF objects.
Object Model
PDFObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFObject
'Usage

Dim instance As PDFObject
public abstract class PDFObject
public __gc abstract class PDFObject
public ref class PDFObject abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFArray
O2S.Components.PDF4NET.Cos.PDFBoolean
O2S.Components.PDF4NET.Cos.PDFCosObject
O2S.Components.PDF4NET.Cos.PDFDateTime
O2S.Components.PDF4NET.Cos.PDFDictionary
O2S.Components.PDF4NET.Cos.PDFName
O2S.Components.PDF4NET.Cos.PDFNull
O2S.Components.PDF4NET.Cos.PDFNumber
O2S.Components.PDF4NET.Cos.PDFString
O2S.Components.PDF4NET.Security.PDFDigitalSignature

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFObject Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFObject Class Members

O2S.Components.PDF4NET.Cos Namespace : PDFObject Class

The following tables list the members exposed by PDFObject.

See Also

Reference

PDFObject Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFString Class
Members

O2S.Components.PDF4NET.Cos Namespace : PDFString Class
Defines a PDF object that represents a string.
Object Model
PDFString Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFString
   Inherits PDFObject
'Usage

Dim instance As PDFString
public class PDFString : PDFObject
public __gc class PDFString : public PDFObject
public ref class PDFString : public PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFString Members
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Members$$

PDFString Class Members
Properties Methods

O2S.Components.PDF4NET.Cos Namespace : PDFString Class

The following tables list the members exposed by PDFString.

Public Constructors
 | Name | Description
Public Constructor | PDFString Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFString Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFString Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFString Class : PDFString Constructor
Overload List
Overload | Description
PDFString Constructor() | Initializes a new PDFString object.
PDFString Constructor(String) | Initializes a new PDFString object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFString Class
PDFString Members


%%PageItemTitle%%

PDFString Constructor()

O2S.Components.PDF4NET.Cos Namespace > PDFString Class > PDFString Constructor : PDFString Constructor()
Initializes a new PDFString object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFString()
public PDFString()
public: PDFString();
public:
PDFString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFString Class
PDFString Members
Overload List


%%PageItemTitle%%

PDFString Constructor(String)

O2S.Components.PDF4NET.Cos Namespace > PDFString Class > PDFString Constructor : PDFString Constructor(String)
Initial object value.
Initializes a new PDFString object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As String _
)
'Usage

Dim value As String

Dim instance As New PDFString(value)
public PDFString(
   string value
)
public: PDFString(
   string* value
)
public:
PDFString(
   String^ value
)

Parameters

value
Initial object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFString Class
PDFString Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFString Class Methods

O2S.Components.PDF4NET.Cos Namespace : PDFString Class

For a list of all members of this type, see PDFString members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string representation.
Top
See Also

Reference

PDFString Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method (PDFString)

O2S.Components.PDF4NET.Cos Namespace > PDFString Class : ToString Method
Converts the object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFString
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFString Class
PDFString Members


%%PageItemTitle%% $$Properties$$

PDFString Class Properties

O2S.Components.PDF4NET.Cos Namespace : PDFString Class

For a list of all members of this type, see PDFString members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PDFString Class
O2S.Components.PDF4NET.Cos Namespace


Value Property (PDFString)

O2S.Components.PDF4NET.Cos Namespace > PDFString Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As String
'Usage

Dim instance As PDFString
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Property Value

The string that represents this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFString Class
PDFString Members


O2S.Components.PDF4NET.Forms Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | FDFField | Defines a field in a FDF document.
Class | FDFFieldCollection | Defines a collection of fields in a FDF document.
Class | FDFFile | Represents a FDF file on disk.
Class | PDFCalculatedFieldCollection | Defines a collection of calculated form fields.
Class | PDFCheckBoxField | Defines a checkbox in a PDF form.
Class | PDFCheckBoxWidget | Defines the widget for a check box field.
Class | PDFCheckWidget | Defines a widget that can be checked.
Class | PDFDropDownListField | Defines a drop down list field for user input in the PDF file.
Class | PDFDropDownListWidget | Defines the widget for a textbox field.
Class | PDFField | Defines the base class for form fields in a PDF form.
Class | PDFFieldCollection | Defines a collection of form fields.
Class | PDFFieldImportError | Represents an error that happened during the import of a FDF/XFDF/XML file.
Class | PDFFieldWidget | Defines the widget for a form field.
Class | PDFFieldWidgetCollection | Defines a collection of form fields.
Class | PDFForm | Defines a form in a PDF document.
Class | PDFListBoxField | Defines a scrollable list box field for user input in the PDF file.
Class | PDFListBoxWidget | Defines the widget for a listbox field.
Class | PDFListField | Base class for all list type fields.
Class | PDFListItem | Defines an item in a list.
Class | PDFListItemCollection | Defines a collection of list items.
Class | PDFPushButtonField | Defines a pushbutton in a PDF form.
Class | PDFPushButtonWidget | Defines the widget for a pushbutton field.
Class | PDFRadioButtonItem | Defines the widget for a radio button.
Class | PDFRadioButtonListField | Defines a list of radio buttons in a PDF form.
Class | PDFSignatureField | Defines a signature field in a PDF form.
Class | PDFSignatureLockFieldAction | Defines the field lock action to be executed when a signature field is signed.
Class | PDFSignatureWidget | Defines the widget for a signature field.
Class | PDFTextBoxField | Defines a text box in a PDF form.
Class | PDFTextBoxWidget | Defines the widget for a textbox field.
Class | XFDFField | Defines a field in a XFDF document.
Class | XFDFFieldCollection | Defines a collection of fields in a XFDF document.
Class | XFDFFile | Represents a XFDF file on disk.
Enumerations
 | Enumeration | Description
Enumeration | PDFCheckSymbolStyle | Specifies the available style for a check box and radio button items.
Enumeration | PDFExportDataOptions | Specifies the available export options for PDF forms.
Enumeration | PDFFieldTextAlign | Specifies the available alignments for text in a field.
Enumeration | PDFFieldType | Specifies the available field types.
Enumeration | PDFFieldWidgetVisibilityStatus | Specifies the available visibility states for a field widget.
Enumeration | PDFFormDataFormat | Specifies the available formats for data import/export for AcroForms.
Enumeration | PDFPushButtonHighlightMode | Specifies the available highlighting modes for a button.
Enumeration | PDFPushButtonIconLayoutMode | Specifies the available modes for displaying the icon on a pushbutton.
Enumeration | PDFSignatureLockFieldMode | Specifies the available lock modes for form fields when a signature lock is applied.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

FDFField Class
Members

O2S.Components.PDF4NET.Forms Namespace : FDFField Class
Defines a field in a FDF document.
Object Model
FDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class FDFField
'Usage

Dim instance As FDFField
public sealed class FDFField
public __gc __sealed class FDFField
public ref class FDFField sealed
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.FDFField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

FDFField Class Members
Properties

O2S.Components.PDF4NET.Forms Namespace : FDFField Class

The following tables list the members exposed by FDFField.

Public Properties
 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top
See Also

Reference

FDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

FDFField Class Properties

O2S.Components.PDF4NET.Forms Namespace : FDFField Class

For a list of all members of this type, see FDFField members.

Public Properties
 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top
See Also

Reference

FDFField Class
O2S.Components.PDF4NET.Forms Namespace


Name Property (FDFField)

O2S.Components.PDF4NET.Forms Namespace > FDFField Class : Name Property
Gets the field name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As FDFField
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

A string value specifying the name of the FDF field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFField Class
FDFField Members


Value Property (FDFField)

O2S.Components.PDF4NET.Forms Namespace > FDFField Class : Value Property
Gets the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As String
'Usage

Dim instance As FDFField
Dim value As String

value = instance.Value
public string Value {get;}
public: __property string* get_Value();
public:
property String^ Value {
   String^ get();
}

Property Value

A string value specifying the value of the FDF field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFField Class
FDFField Members


%%PageItemTitle%%

FDFFieldCollection Class
Members

O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class
Defines a collection of fields in a FDF document.
Object Model
FDFFieldCollection ClassFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FDFFieldCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of FDFField,FDFFile)
'Usage

Dim instance As FDFFieldCollection
public class FDFFieldCollection : O2S.Components.PDF4NET.PDFCollection<FDFField,FDFFile>
public __gc class FDFFieldCollection : public O2S.Components.PDF4NET.PDFCollection<FDFField,FDFFile>
public ref class FDFFieldCollection : public O2S.Components.PDF4NET.PDFCollection<FDFField,FDFFile>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Forms.FDFFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFieldCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

FDFFieldCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

The following tables list the members exposed by FDFFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top
See Also

Reference

FDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

FDFFile Class
Members

O2S.Components.PDF4NET.Forms Namespace : FDFFile Class
Represents a FDF file on disk.
Object Model
FDFFile ClassFDFFieldCollection ClassFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FDFFile
'Usage

Dim instance As FDFFile
public class FDFFile
public __gc class FDFFile
public ref class FDFFile
Remarks
This class defines an existing FDF file. Its methods allows to import/export data from/to FDF files.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.FDFFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

FDFFile Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

The following tables list the members exposed by FDFFile.

Public Properties
 | Name | Description
Public Property | Fields | Gets the list of fields in the FDF file.
Public Property | PDFFileName | Gets the name of the PDF file the FDF file was exported from.
Top
Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a FDFFile object from the given FDF file.
static (Shared in Visual Basic) | FromStream | Creates a FDFFile object from the given stream object.
Top
See Also

Reference

FDFFile Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

FDFFile Class Methods

O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

For a list of all members of this type, see FDFFile members.

Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a FDFFile object from the given FDF file.
static (Shared in Visual Basic) | FromStream | Creates a FDFFile object from the given stream object.
Top
See Also

Reference

FDFFile Class
O2S.Components.PDF4NET.Forms Namespace


Close Method (FDFFile)

O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : Close Method
Closes the underlying pdf file and frees all resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As FDFFile

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


FromFile Method (FDFFile)

O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : FromFile Method
the full path to a FDF file used as source for this FDFFile object.
Creates a FDFFile object from the given FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromFile( _
   ByVal fileName As String _
) As FDFFile
'Usage

Dim fileName As String
Dim value As FDFFile

value = FDFFile.FromFile(fileName)
public static FDFFile FromFile(
   string fileName
)
public: static FDFFile* FromFile(
   string* fileName
)
public:
static FDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a FDF file used as source for this FDFFile object.

Return Value

A FDFFile object created based on the given FDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


FromStream(Stream) Method

O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : FromStream(Stream) Method
the stream object used as source for this FDFFile object.
Creates a FDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromStream( _
   ByVal stream As Stream _
) As FDFFile
'Usage

Dim stream As Stream
Dim value As FDFFile

value = FDFFile.FromStream(stream)
public static FDFFile FromStream(
   Stream stream
)
public: static FDFFile* FromStream(
   Stream* stream
)
public:
static FDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this FDFFile object.

Return Value

A FDFFile object created based on the given stream object.
Remarks
The stream must contain a valid FDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%% $$Properties$$

FDFFile Class Properties

O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

For a list of all members of this type, see FDFFile members.

Public Properties
 | Name | Description
Public Property | Fields | Gets the list of fields in the FDF file.
Public Property | PDFFileName | Gets the name of the PDF file the FDF file was exported from.
Top
See Also

Reference

FDFFile Class
O2S.Components.PDF4NET.Forms Namespace


Fields Property (FDFFile)

O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : Fields Property
Gets the list of fields in the FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As FDFFieldCollection
'Usage

Dim instance As FDFFile
Dim value As FDFFieldCollection

value = instance.Fields
public FDFFieldCollection Fields {get;}
public: __property FDFFieldCollection* get_Fields();
public:
property FDFFieldCollection^ Fields {
   FDFFieldCollection^ get();
}

Property Value

A FDFFieldCollection object specifying the list of fields in the FDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


PDFFileName Property (FDFFile)

O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : PDFFileName Property
Gets the name of the PDF file the FDF file was exported from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PDFFileName As String
'Usage

Dim instance As FDFFile
Dim value As String

value = instance.PDFFileName
public string PDFFileName {get;}
public: __property string* get_PDFFileName();
public:
property String^ PDFFileName {
   String^ get();
}

Property Value

A string value specifying the the name of the PDF file the FDF file was exported from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%%

PDFCalculatedFieldCollection Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFCalculatedFieldCollection Class
Defines a collection of calculated form fields.
Object Model
PDFCalculatedFieldCollection ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCalculatedFieldCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFField,PDFForm)
'Usage

Dim instance As PDFCalculatedFieldCollection
public class PDFCalculatedFieldCollection : O2S.Components.PDF4NET.PDFCollection<PDFField,PDFForm>
public __gc class PDFCalculatedFieldCollection : public O2S.Components.PDF4NET.PDFCollection<PDFField,PDFForm>
public ref class PDFCalculatedFieldCollection : public O2S.Components.PDF4NET.PDFCollection<PDFField,PDFForm>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Forms.PDFCalculatedFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalculatedFieldCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFCalculatedFieldCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFCalculatedFieldCollection Class

The following tables list the members exposed by PDFCalculatedFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top
See Also

Reference

PDFCalculatedFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxField Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class
Defines a checkbox in a PDF form.
Object Model
PDFCheckBoxField ClassPDFJavaScriptAction ClassPDFDictionary ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCheckBoxField
   Inherits PDFField
'Usage

Dim instance As PDFCheckBoxField
public class PDFCheckBoxField : PDFField
public __gc class PDFCheckBoxField : public PDFField
public ref class PDFCheckBoxField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFCheckBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFCheckBoxField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

The following tables list the members exposed by PDFCheckBoxField.

Public Constructors
 | Name | Description
Public Constructor | PDFCheckBoxField Constructor | Initializes a new PDFCheckBoxField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Checked | Gets or sets a value indicating whether the checkbox is checked or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : PDFCheckBoxField Constructor
The name of the field.
Initializes a new PDFCheckBoxField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFCheckBoxField(name)
public PDFCheckBoxField(
   string name
)
public: PDFCheckBoxField(
   string* name
)
public:
PDFCheckBoxField(
   String^ name
)

Parameters

name
The name of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%% $$Properties$$

PDFCheckBoxField Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

For a list of all members of this type, see PDFCheckBoxField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Checked | Gets or sets a value indicating whether the checkbox is checked or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDF4NET.Forms Namespace


Checked Property (PDFCheckBoxField)

O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : Checked Property
Gets or sets a value indicating whether the checkbox is checked or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Checked As Boolean
'Usage

Dim instance As PDFCheckBoxField
Dim value As Boolean

instance.Checked = value

value = instance.Checked
public bool Checked {get; set;}
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
public:
property bool Checked {
   bool get();
   void set (    bool value);
}

Property Value

True if at least one checkbox widget is checked, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

PDFCheckBoxWidget Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxWidget Class
Defines the widget for a check box field.
Object Model
PDFCheckBoxWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCheckBoxWidget
   Inherits PDFCheckWidget
'Usage

Dim instance As PDFCheckBoxWidget
public class PDFCheckBoxWidget : PDFCheckWidget
public __gc class PDFCheckBoxWidget : public PDFCheckWidget
public ref class PDFCheckBoxWidget : public PDFCheckWidget
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFCheckBoxWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxWidget Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFCheckBoxWidget Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxWidget Class

The following tables list the members exposed by PDFCheckBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFCheckBoxWidget Constructor | Initializes a new PDFCheckBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxWidget Class : PDFCheckBoxWidget Constructor
Initializes a new PDFCheckBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCheckBoxWidget()
public PDFCheckBoxWidget()
public: PDFCheckBoxWidget();
public:
PDFCheckBoxWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxWidget Class
PDFCheckBoxWidget Members


%%PageItemTitle%%

PDFCheckWidget Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFCheckWidget Class
Defines a widget that can be checked.
Object Model
PDFCheckWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCheckWidget
   Inherits PDFFieldWidget
'Usage

Dim instance As PDFCheckWidget
public class PDFCheckWidget : PDFFieldWidget
public __gc class PDFCheckWidget : public PDFFieldWidget
public ref class PDFCheckWidget : public PDFFieldWidget
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFCheckBoxWidget
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFCheckWidget Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFCheckWidget Class

The following tables list the members exposed by PDFCheckWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFCheckWidget Constructor | Initializes a new PDFCheckWidget object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not.
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance.
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget.
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance.
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance.
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance.
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFCheckWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : PDFCheckWidget Constructor
Initializes a new PDFCheckWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCheckWidget()
public PDFCheckWidget()
public: PDFCheckWidget();
public:
PDFCheckWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%PageItemTitle%% $$Properties$$

PDFCheckWidget Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFCheckWidget Class

For a list of all members of this type, see PDFCheckWidget members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not.
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance.
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget.
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance.
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance.
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance.
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFCheckWidget Class
O2S.Components.PDF4NET.Forms Namespace


Appearance Property (PDFCheckWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : Appearance Property
Gets or sets the widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The normal appearance of the field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


Checked Property (PDFCheckWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : Checked Property
Gets or sets a value indicating whether this widget is checked or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Checked As Boolean
'Usage

Dim instance As PDFCheckWidget
Dim value As Boolean

instance.Checked = value

value = instance.Checked
public bool Checked {get; set;}
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
public:
property bool Checked {
   bool get();
   void set (    bool value);
}

Property Value

True if the widget is checked, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


CheckedDownAppearance Property

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : CheckedDownAppearance Property
Gets or sets the checked down widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckedDownAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.CheckedDownAppearance = value

value = instance.CheckedDownAppearance
public PDFAnnotationAppearance CheckedDownAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_CheckedDownAppearance();
public: __property void set_CheckedDownAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ CheckedDownAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The down appearance of the field widget in checked state.
Remarks
This appearance is displayed when the mouse is clicked on the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


CheckedNormalAppearance Property

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : CheckedNormalAppearance Property
Gets or sets the checked rollover widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckedNormalAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.CheckedNormalAppearance = value

value = instance.CheckedNormalAppearance
public PDFAnnotationAppearance CheckedNormalAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_CheckedNormalAppearance();
public: __property void set_CheckedNormalAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ CheckedNormalAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The rollover appearance of the field widget in checked state.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


CheckedRolloverAppearance Property

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : CheckedRolloverAppearance Property
Gets or sets the checked rollover widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckedRolloverAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.CheckedRolloverAppearance = value

value = instance.CheckedRolloverAppearance
public PDFAnnotationAppearance CheckedRolloverAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_CheckedRolloverAppearance();
public: __property void set_CheckedRolloverAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ CheckedRolloverAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The rollover appearance of the field widget in checked state.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


CheckSymbolStyle Property

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : CheckSymbolStyle Property
Gets or sets the symbol used as checkmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckSymbolStyle As PDFCheckSymbolStyle
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFCheckSymbolStyle

instance.CheckSymbolStyle = value

value = instance.CheckSymbolStyle
public PDFCheckSymbolStyle CheckSymbolStyle {get; set;}
public: __property PDFCheckSymbolStyle get_CheckSymbolStyle();
public: __property void set_CheckSymbolStyle(
   PDFCheckSymbolStyle value
);
public:
property PDFCheckSymbolStyle CheckSymbolStyle {
   PDFCheckSymbolStyle get();
   void set (    PDFCheckSymbolStyle value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


ExportValue Property

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : ExportValue Property
Gets or sets the export value for this check box widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExportValue As String
'Usage

Dim instance As PDFCheckWidget
Dim value As String

instance.ExportValue = value

value = instance.ExportValue
public string ExportValue {get; set;}
public: __property string* get_ExportValue();
public: __property void set_ExportValue(
   string* value
);
public:
property String^ ExportValue {
   String^ get();
   void set (    String^ value);
}

Property Value

The value that is exported from the form if the widget is checked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


UncheckedDownAppearance Property

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : UncheckedDownAppearance Property
Gets or sets the unchecked down widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UncheckedDownAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.UncheckedDownAppearance = value

value = instance.UncheckedDownAppearance
public PDFAnnotationAppearance UncheckedDownAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_UncheckedDownAppearance();
public: __property void set_UncheckedDownAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ UncheckedDownAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The down appearance of the field widget in unchecked state.
Remarks
This appearance is displayed when the mouse is clicked on the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


UncheckedNormalAppearance Property

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : UncheckedNormalAppearance Property
Gets or sets the unchecked normal widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UncheckedNormalAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.UncheckedNormalAppearance = value

value = instance.UncheckedNormalAppearance
public PDFAnnotationAppearance UncheckedNormalAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_UncheckedNormalAppearance();
public: __property void set_UncheckedNormalAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ UncheckedNormalAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The normal appearance of the field widget in unchecked state.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


UncheckedRolloverAppearance Property

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : UncheckedRolloverAppearance Property
Gets or sets the unchecked rollover widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UncheckedRolloverAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.UncheckedRolloverAppearance = value

value = instance.UncheckedRolloverAppearance
public PDFAnnotationAppearance UncheckedRolloverAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_UncheckedRolloverAppearance();
public: __property void set_UncheckedRolloverAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ UncheckedRolloverAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The rollover appearance of the field widget in unchecked state.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%PageItemTitle%%

PDFDropDownListField Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class
Defines a drop down list field for user input in the PDF file.
Object Model
PDFDropDownListField ClassPDFJavaScriptAction ClassPDFDictionary ClassPDFForm ClassPDFJavaScriptAction ClassPDFListItemCollection ClassPDFListItem ClassPDFJavaScriptAction ClassPDFListItem ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDropDownListField
   Inherits PDFListField
'Usage

Dim instance As PDFDropDownListField
public class PDFDropDownListField : PDFListField
public __gc class PDFDropDownListField : public PDFListField
public ref class PDFDropDownListField : public PDFListField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFDropDownListField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFDropDownListField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

The following tables list the members exposed by PDFDropDownListField.

Public Constructors
 | Name | Description
Public Constructor | PDFDropDownListField Constructor | Initializes a new PDFDropDownListField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | CheckSpelling | Gets or sets whether the field content should be checked for spelling erorrs.
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Edit | Gets or sets whether the user can enter text in the drop down list or not.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFDropDownListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFDropDownListField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : PDFDropDownListField Constructor
The name of this drop down list field object.
Initializes a new PDFDropDownListField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFDropDownListField(name)
public PDFDropDownListField(
   string name
)
public: PDFDropDownListField(
   string* name
)
public:
PDFDropDownListField(
   String^ name
)

Parameters

name
The name of this drop down list field object.
Remarks
The field name must be unique across the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%% $$Properties$$

PDFDropDownListField Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

For a list of all members of this type, see PDFDropDownListField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | CheckSpelling | Gets or sets whether the field content should be checked for spelling erorrs.
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Edit | Gets or sets whether the user can enter text in the drop down list or not.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFDropDownListField Class
O2S.Components.PDF4NET.Forms Namespace


CheckSpelling Property (PDFDropDownListField)

O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : CheckSpelling Property
Gets or sets whether the field content should be checked for spelling erorrs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckSpelling As Boolean
'Usage

Dim instance As PDFDropDownListField
Dim value As Boolean

instance.CheckSpelling = value

value = instance.CheckSpelling
public bool CheckSpelling {get; set;}
public: __property bool get_CheckSpelling();
public: __property void set_CheckSpelling(
   bool value
);
public:
property bool CheckSpelling {
   bool get();
   void set (    bool value);
}

Property Value

True if the field content should be checked for spelling erorrs, false otherwise. Default is true.
Remarks
The field content is checked for spelling errors only when the PDF file is opened in the viewer (if the PDF viewer support this feature) and it is not spell checked when its value is set from code. This flag has meaning only if Edit is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


Edit Property

O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : Edit Property
Gets or sets whether the user can enter text in the drop down list or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Edit As Boolean
'Usage

Dim instance As PDFDropDownListField
Dim value As Boolean

instance.Edit = value

value = instance.Edit
public bool Edit {get; set;}
public: __property bool get_Edit();
public: __property void set_Edit(
   bool value
);
public:
property bool Edit {
   bool get();
   void set (    bool value);
}

Property Value

True if the drop down list is editable, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%%

PDFDropDownListWidget Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListWidget Class
Defines the widget for a textbox field.
Object Model
PDFDropDownListWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDropDownListWidget
   Inherits PDFFieldWidget
'Usage

Dim instance As PDFDropDownListWidget
public class PDFDropDownListWidget : PDFFieldWidget
public __gc class PDFDropDownListWidget : public PDFFieldWidget
public ref class PDFDropDownListWidget : public PDFFieldWidget
Remarks
The field widget is the field's visual representation on a PDF page. A textbox field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFDropDownListWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListWidget Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFDropDownListWidget Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListWidget Class

The following tables list the members exposed by PDFDropDownListWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFDropDownListWidget Constructor | Initializes a new PDFDropDownListWidget object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFDropDownListWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListWidget Class : PDFDropDownListWidget Constructor
Initializes a new PDFDropDownListWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDropDownListWidget()
public PDFDropDownListWidget()
public: PDFDropDownListWidget();
public:
PDFDropDownListWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListWidget Class
PDFDropDownListWidget Members


%%PageItemTitle%%

PDFField Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFField Class
Defines the base class for form fields in a PDF form.
Object Model
PDFField ClassPDFJavaScriptAction ClassPDFDictionary ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFField
'Usage

Dim instance As PDFField
public class PDFField
public __gc class PDFField
public ref class PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFCheckBoxField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFPushButtonField
O2S.Components.PDF4NET.Forms.PDFRadioButtonListField
O2S.Components.PDF4NET.Forms.PDFSignatureField
O2S.Components.PDF4NET.Forms.PDFTextBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFField Class

The following tables list the members exposed by PDFField.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value.
Public Property | Dictionary | Gets the field dictionary.
Public Property | Form | Gets the form that contains this field.
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke.
Public Property | MappingName | Gets or sets the mapping name of the field.
Public Property | Name | Gets or sets the field name.
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Tooltip | Gets or sets the field tooltip.
Public Property | Type | Gets the field type.
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value.
Public Property | Value | Gets or sets the field value.
Public Property | Widgets | Gets the list of widgets associated with this field.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources.
Top
See Also

Reference

PDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFField Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFField Class

For a list of all members of this type, see PDFField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources.
Top
See Also

Reference

PDFField Class
O2S.Components.PDF4NET.Forms Namespace


Dispose Method (PDFField)

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Dispose Method
Disposes the internal resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PDFField

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%% $$Properties$$

PDFField Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFField Class

For a list of all members of this type, see PDFField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value.
Public Property | Dictionary | Gets the field dictionary.
Public Property | Form | Gets the form that contains this field.
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke.
Public Property | MappingName | Gets or sets the mapping name of the field.
Public Property | Name | Gets or sets the field name.
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Tooltip | Gets or sets the field tooltip.
Public Property | Type | Gets the field type.
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value.
Public Property | Value | Gets or sets the field value.
Public Property | Widgets | Gets the list of widgets associated with this field.
Top
See Also

Reference

PDFField Class
O2S.Components.PDF4NET.Forms Namespace


CalculateAction Property

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : CalculateAction Property
Gets or sets the JavaScript action to be executed for calculating the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CalculateAction As PDFJavaScriptAction
'Usage

Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.CalculateAction = value

value = instance.CalculateAction
public PDFJavaScriptAction CalculateAction {get; set;}
public: __property PDFJavaScriptAction* get_CalculateAction();
public: __property void set_CalculateAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ CalculateAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFJavaScriptAction object specifying the action to be executed for calculating the field value.
Remarks
This property specifies a JavaScript action to be performed to recalculate the value of this field when that of another field changes.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


Dictionary Property (PDFField)

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Dictionary Property
Gets the field dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFField
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw field dictionary.
Remarks
This property gives you direct access to field dictionary and its associated resources. Note: Modifying directly the field dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


Form Property (PDFField)

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Form Property
Gets the form that contains this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Form As PDFForm
'Usage

Dim instance As PDFField
Dim value As PDFForm

value = instance.Form
public PDFForm Form {get;}
public: __property PDFForm* get_Form();
public:
property PDFForm^ Form {
   PDFForm^ get();
}

Property Value

The form that owns the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


FormatAction Property

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : FormatAction Property
Gets or sets the JavaScript action to be executed for formating the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FormatAction As PDFJavaScriptAction
'Usage

Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.FormatAction = value

value = instance.FormatAction
public PDFJavaScriptAction FormatAction {get; set;}
public: __property PDFJavaScriptAction* get_FormatAction();
public: __property void set_FormatAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ FormatAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFJavaScriptAction object specifying the action to be executed for formating the field value.
Remarks
This property specifies a JavaScript action to be performed before the field is formatted to display its current value. This action can modify the field’s value before formatting.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


KeyPressAction Property

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : KeyPressAction Property
Gets or sets the JavaScript action to be executed when the user types a keystroke.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property KeyPressAction As PDFJavaScriptAction
'Usage

Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.KeyPressAction = value

value = instance.KeyPressAction
public PDFJavaScriptAction KeyPressAction {get; set;}
public: __property PDFJavaScriptAction* get_KeyPressAction();
public: __property void set_KeyPressAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ KeyPressAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFJavaScriptAction object specifying the action to be executed when the user types a keystroke.
Remarks
This property specifies a JavaScript action to be performed when the user types a keystroke into a text field or combo box or modifies the selection in a scrollable list box. This action can check the keystroke for validity and reject or modify it.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField and PDFRadioButtonListField fields.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


MappingName Property

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : MappingName Property
Gets or sets the mapping name of the field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MappingName As String
'Usage

Dim instance As PDFField
Dim value As String

instance.MappingName = value

value = instance.MappingName
public string MappingName {get; set;}
public: __property string* get_MappingName();
public: __property void set_MappingName(
   string* value
);
public:
property String^ MappingName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the mapping name of the field.
Remarks
The field's mapping name is used when exporting interactive form field data from the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


Name Property (PDFField)

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Name Property
Gets or sets the field name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFField
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The fully qualified field name.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the name is null or empty or not a valid PDF field name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


NoExport Property

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : NoExport Property
Gets or sets a value indicating whether the field can be exported or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NoExport As Boolean
'Usage

Dim instance As PDFField
Dim value As Boolean

instance.NoExport = value

value = instance.NoExport
public bool NoExport {get; set;}
public: __property bool get_NoExport();
public: __property void set_NoExport(
   bool value
);
public:
property bool NoExport {
   bool get();
   void set (    bool value);
}

Property Value

True if the field can not be exported, false otherwise. Default is false.
Remarks
If true, the field must not be exported by a submit-form action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


ReadOnly Property

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : ReadOnly Property
Gets or sets a value indicating whether the field is read-only.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReadOnly As Boolean
'Usage

Dim instance As PDFField
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
public bool ReadOnly {get; set;}
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
public:
property bool ReadOnly {
   bool get();
   void set (    bool value);
}

Property Value

True if the field is read-only, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


Required Property

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Required Property
Gets or sets a value indicating whether the field is required.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Required As Boolean
'Usage

Dim instance As PDFField
Dim value As Boolean

instance.Required = value

value = instance.Required
public bool Required {get; set;}
public: __property bool get_Required();
public: __property void set_Required(
   bool value
);
public:
property bool Required {
   bool get();
   void set (    bool value);
}

Property Value

True if the field is required, false otherwise. Default is false.
Remarks
If true, the field must have a value when it is exported by a submit-form action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


Tooltip Property (PDFField)

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Tooltip Property
Gets or sets the field tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Tooltip As String
'Usage

Dim instance As PDFField
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
public virtual string Tooltip {get; set;}
public: __property virtual string* get_Tooltip();
public: __property virtual void set_Tooltip(
   string* value
);
public:
virtual property String^ Tooltip {
   String^ get();
   void set (    String^ value);
}

Property Value

The field's tooltip.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


Type Property (PDFField)

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Type Property
Gets the field type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PDFFieldType
'Usage

Dim instance As PDFField
Dim value As PDFFieldType

value = instance.Type
public PDFFieldType Type {get;}
public: __property PDFFieldType get_Type();
public:
property PDFFieldType Type {
   PDFFieldType get();
}

Property Value

The type of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


ValidateAction Property

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : ValidateAction Property
Gets or sets the JavaScript action to be executed for validating the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ValidateAction As PDFJavaScriptAction
'Usage

Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.ValidateAction = value

value = instance.ValidateAction
public PDFJavaScriptAction ValidateAction {get; set;}
public: __property PDFJavaScriptAction* get_ValidateAction();
public: __property void set_ValidateAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ ValidateAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDF4NET.Actions.PDFJavaScriptAction object specifying the action to be executed for validating the field value.
Remarks
This property specifies a JavaScript action to be performed when the field’s value is changed. This action can check the new value for validity.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


Value Property (PDFField)

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Value Property
Gets or sets the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Object
'Usage

Dim instance As PDFField
Dim value As Object

instance.Value = value

value = instance.Value
public object Value {get; set;}
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
public:
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The field value.
Remarks
The value type depends on the actual field. Check box fields accept string and boolean values while other fields work only with strings. If other type is provided, it will be converted to string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


Widgets Property

O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Widgets Property
Gets the list of widgets associated with this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Widgets As PDFFieldWidgetCollection
'Usage

Dim instance As PDFField
Dim value As PDFFieldWidgetCollection

value = instance.Widgets
public PDFFieldWidgetCollection Widgets {get;}
public: __property PDFFieldWidgetCollection* get_Widgets();
public:
property PDFFieldWidgetCollection^ Widgets {
   PDFFieldWidgetCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

PDFFieldCollection Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFFieldCollection Class
Defines a collection of form fields.
Object Model
PDFFieldCollection ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PDFFieldCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFField,PDFForm)
'Usage

Dim instance As PDFFieldCollection
[DefaultMember("Item")]
public class PDFFieldCollection : O2S.Components.PDF4NET.PDFCollection<PDFField,PDFForm>
[DefaultMember("Item")]
public __gc class PDFFieldCollection : public O2S.Components.PDF4NET.PDFCollection<PDFField,PDFForm>
[DefaultMember("Item")]
public ref class PDFFieldCollection : public O2S.Components.PDF4NET.PDFCollection<PDFField,PDFForm>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Forms.PDFFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFFieldCollection Class

The following tables list the members exposed by PDFFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Property | Item | Gets the field with the specified name.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Dispose | Disposes the internal objects and resources.
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Remove | Overloaded. Removes the field with the specified name from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top
See Also

Reference

PDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFFieldCollection Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFFieldCollection Class

For a list of all members of this type, see PDFFieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Dispose | Disposes the internal objects and resources.
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Remove | Overloaded. Removes the field with the specified name from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top
See Also

Reference

PDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


Dispose Method (PDFFieldCollection)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldCollection Class : Dispose Method
Disposes the internal objects and resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PDFFieldCollection

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks
This method also calls Dispose on the objects in the collection. If you want to remove the items from the collection then call the Clear method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members


Remove Method (PDFFieldCollection)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldCollection Class : Remove Method
Removes the field with the specified name from the collection.
Overload List
Overload | Description
Remove(String) | Removes the field with the specified name from the collection.
Remove(PDFField) | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members


Remove(String) Method

O2S.Components.PDF4NET.Forms Namespace > PDFFieldCollection Class > Remove Method : Remove(String) Method
The name of the field to remove.
Removes the field with the specified name from the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal name As String _
)
'Usage

Dim instance As PDFFieldCollection
Dim name As String

instance.Remove(name)
public void Remove(
   string name
)
public: void Remove(
   string* name
)
public:
void Remove(
   String^ name
)

Parameters

name
The name of the field to remove.
Remarks
If the field with the specified name does not exist in the collection nothing happens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFieldCollection Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFFieldCollection Class

For a list of all members of this type, see PDFFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Property | Item | Gets the field with the specified name.
Top
See Also

Reference

PDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


Item Property (PDFFieldCollection)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldCollection Class : Item Property
The name of the field to lookup in the collection.
Gets the field with the specified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal name As String _
) As PDFField
'Usage

Dim instance As PDFFieldCollection
Dim name As String
Dim value As PDFField

value = instance.Item(name)
public new PDFField this[
   string name
]; {get;}
public: __property new PDFField* get_Item   string* name
;
public:
new property PDFField^ default [String^] {
   PDFField^ get(String^ name);
}

Parameters

name
The name of the field to lookup in the collection.

Property Value

The field if exists, otherwise null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members


%%PageItemTitle%%

PDFFieldImportError Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFFieldImportError Class
Represents an error that happened during the import of a FDF/XFDF/XML file.
Object Model
PDFFieldImportError ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFieldImportError
'Usage

Dim instance As PDFFieldImportError
public class PDFFieldImportError
public __gc class PDFFieldImportError
public ref class PDFFieldImportError
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFFieldImportError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldImportError Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldImportError Class Members
Properties

O2S.Components.PDF4NET.Forms Namespace : PDFFieldImportError Class

The following tables list the members exposed by PDFFieldImportError.

Public Properties
 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top
See Also

Reference

PDFFieldImportError Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFFieldImportError Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFFieldImportError Class

For a list of all members of this type, see PDFFieldImportError members.

Public Properties
 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top
See Also

Reference

PDFFieldImportError Class
O2S.Components.PDF4NET.Forms Namespace


Exception Property (PDFFieldImportError)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldImportError Class : Exception Property
Gets the exception thrown by the field during the import.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Exception As Exception
'Usage

Dim instance As PDFFieldImportError
Dim value As Exception

value = instance.Exception
public Exception Exception {get;}
public: __property Exception* get_Exception();
public:
property Exception^ Exception {
   Exception^ get();
}

Property Value

A Exception object with the details about the import error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldImportError Class
PDFFieldImportError Members


Field Property (PDFFieldImportError)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldImportError Class : Field Property
Gets the field that generated the import error.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As PDFFieldImportError
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

A PDFField object representing the field that generated the error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldImportError Class
PDFFieldImportError Members


%%PageItemTitle%%

PDFFieldWidget Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidget Class
Defines the widget for a form field.
Object Model
PDFFieldWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFieldWidget
   Inherits O2S.Components.PDF4NET.Annotations.PDFAnnotation
'Usage

Dim instance As PDFFieldWidget
public class PDFFieldWidget : O2S.Components.PDF4NET.Annotations.PDFAnnotation
public __gc class PDFFieldWidget : public O2S.Components.PDF4NET.Annotations.PDFAnnotation
public ref class PDFFieldWidget : public O2S.Components.PDF4NET.Annotations.PDFAnnotation
Remarks
The field widget is the field's visual representation on a PDF page. A form field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFDropDownListWidget
O2S.Components.PDF4NET.Forms.PDFListBoxWidget
O2S.Components.PDF4NET.Forms.PDFPushButtonWidget
O2S.Components.PDF4NET.Forms.PDFSignatureWidget
O2S.Components.PDF4NET.Forms.PDFTextBoxWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldWidget Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidget Class

The following tables list the members exposed by PDFFieldWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFFieldWidget Constructor | Initializes a new PDFFieldWidget object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color.
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus.
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the widget rotation angle.
Public Property | TabOrder | Gets or sets the widget's tab order.
Public Property | TextColor | Gets or sets the widget's text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget.
Top
Public Methods
 | Name | Description
Public Method | Flatten | Overridden. Flattens the field widget.
Top
See Also

Reference

PDFFieldWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : PDFFieldWidget Constructor
Initializes a new PDFFieldWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFieldWidget()
public PDFFieldWidget()
public: PDFFieldWidget();
public:
PDFFieldWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%PageItemTitle%% $$Methods$$

PDFFieldWidget Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidget Class

For a list of all members of this type, see PDFFieldWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Overridden. Flattens the field widget.
Top
See Also

Reference

PDFFieldWidget Class
O2S.Components.PDF4NET.Forms Namespace


Flatten Method (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Flatten Method
Flattens the field widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flatten()
'Usage

Dim instance As PDFFieldWidget

instance.Flatten()
public override void Flatten()
public: void Flatten(); override
public:
void Flatten(); override
Remarks
This operation writes the field appearance to the page content and destroys the widget. Its effects are irreversible. After calling this method the PDFFieldWidget object is invalid and should no longer be used.
If this is the only widget of the field, the field object will also be removed from the document and destroyed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%PageItemTitle%% $$Properties$$

PDFFieldWidget Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidget Class

For a list of all members of this type, see PDFFieldWidget members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color.
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus.
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the widget rotation angle.
Public Property | TabOrder | Gets or sets the widget's tab order.
Public Property | TextColor | Gets or sets the widget's text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget.
Top
See Also

Reference

PDFFieldWidget Class
O2S.Components.PDF4NET.Forms Namespace


Appearance Property (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Appearance Property
Gets or sets the widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The normal appearance of the field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


BackColor Property (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : BackColor Property
Gets or sets the widget's background color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BackColor As PDFDeviceColor
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFDeviceColor

instance.BackColor = value

value = instance.BackColor
public PDFDeviceColor BackColor {get; set;}
public: __property PDFDeviceColor* get_BackColor();
public: __property void set_BackColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ BackColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The color of widget's background.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Blur Property

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Blur Property
Gets or sets the action that is executed when the field widget loses focus.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Blur As PDFAction
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFAction

instance.Blur = value

value = instance.Blur
public PDFAction Blur {get; set;}
public: __property PDFAction* get_Blur();
public: __property void set_Blur(
   PDFAction* value
);
public:
property PDFAction^ Blur {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the field widget loses focus.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


BorderColor Property (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : BorderColor Property
Gets or sets the widget's border color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderColor As PDFDeviceColor
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFDeviceColor

instance.BorderColor = value

value = instance.BorderColor
public PDFDeviceColor BorderColor {get; set;}
public: __property PDFDeviceColor* get_BorderColor();
public: __property void set_BorderColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ BorderColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The color of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


BorderStyle Property (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : BorderStyle Property
Gets or sets the widget's border style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderStyle As PDFBorderStyle
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFBorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public PDFBorderStyle BorderStyle {get; set;}
public: __property PDFBorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   PDFBorderStyle value
);
public:
property PDFBorderStyle BorderStyle {
   PDFBorderStyle get();
   void set (    PDFBorderStyle value);
}

Property Value

The style of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


BorderWidth Property (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : BorderWidth Property
Gets or sets the widget's border width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PDFFieldWidget
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public: __property double get_BorderWidth();
public: __property void set_BorderWidth(
   double value
);
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Field Property (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Field Property
Gets the form field that owns this widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

The form field that owns this widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Focus Property

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Focus Property
Gets or sets the action that is executed when the field widget receives focus.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Focus As PDFAction
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFAction

instance.Focus = value

value = instance.Focus
public PDFAction Focus {get; set;}
public: __property PDFAction* get_Focus();
public: __property void set_Focus(
   PDFAction* value
);
public:
property PDFAction^ Focus {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the field widget receives focus.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Font Property (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Font Property
Gets or sets the font used to display the widget text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Font As PDFFontBase
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
public PDFFontBase Font {get; set;}
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (    PDFFontBase^ value);
}

Property Value

The font used for displaying the widget content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Rotation Property (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Rotation Property
Gets or sets the widget rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


TabOrder Property

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : TabOrder Property
Gets or sets the widget's tab order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TabOrder As Integer
'Usage

Dim instance As PDFFieldWidget
Dim value As Integer

instance.TabOrder = value

value = instance.TabOrder
public int TabOrder {get; set;}
public: __property int get_TabOrder();
public: __property void set_TabOrder(
   int value
);
public:
property int TabOrder {
   int get();
   void set (    int value);
}

Property Value

The position of the widget that defines the navigation between the fields using TAB key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


TextColor Property (PDFFieldWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : TextColor Property
Gets or sets the widget's text color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As PDFDeviceColor
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFDeviceColor

instance.TextColor = value

value = instance.TextColor
public PDFDeviceColor TextColor {get; set;}
public: __property PDFDeviceColor* get_TextColor();
public: __property void set_TextColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ TextColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The color of widget's text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


VisibilityStatus Property

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : VisibilityStatus Property
Gets or sets the visibility status of the field widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VisibilityStatus As PDFFieldWidgetVisibilityStatus
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFFieldWidgetVisibilityStatus

instance.VisibilityStatus = value

value = instance.VisibilityStatus
public PDFFieldWidgetVisibilityStatus VisibilityStatus {get; set;}
public: __property PDFFieldWidgetVisibilityStatus get_VisibilityStatus();
public: __property void set_VisibilityStatus(
   PDFFieldWidgetVisibilityStatus value
);
public:
property PDFFieldWidgetVisibilityStatus VisibilityStatus {
   PDFFieldWidgetVisibilityStatus get();
   void set (    PDFFieldWidgetVisibilityStatus value);
}

Property Value

A PDFFieldWidgetVisibilityStatus enumeration member specifying the visibility status of the field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%PageItemTitle%%

PDFFieldWidgetCollection Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetCollection Class
Defines a collection of form fields.
Object Model
PDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFieldWidgetCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFFieldWidget,PDFField)
'Usage

Dim instance As PDFFieldWidgetCollection
public class PDFFieldWidgetCollection : O2S.Components.PDF4NET.PDFCollection<PDFFieldWidget,PDFField>
public __gc class PDFFieldWidgetCollection : public O2S.Components.PDF4NET.PDFCollection<PDFFieldWidget,PDFField>
public ref class PDFFieldWidgetCollection : public O2S.Components.PDF4NET.PDFCollection<PDFFieldWidget,PDFField>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Forms.PDFFieldWidgetCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidgetCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldWidgetCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetCollection Class

The following tables list the members exposed by PDFFieldWidgetCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top
See Also

Reference

PDFFieldWidgetCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFForm Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFForm Class
Defines a form in a PDF document.
Object Model
PDFForm ClassPDFCalculatedFieldCollection ClassPDFField ClassPDFDocument ClassPDFFieldCollection ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFForm
'Usage

Dim instance As PDFForm
public class PDFForm
public __gc class PDFForm
public ref class PDFForm
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFForm Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

The following tables list the members exposed by PDFForm.

Public Properties
 | Name | Description
Public Property | CalculatedFields | Gets the list of calculated fields in the form.
Public Property | Document | Gets the document that includes this form.
Public Property | Fields | Gets the list of fields included in the form.
Public Property | NeedAppearances | Gets or sets a value indicating whether the viewer application needs to rebuild the field appearance upon form loading.
Top
Public Methods
 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | FlattenFormField | Flattens the specified form field, making the field uneditable.
Public Method | FlattenFormFields | Flattens all the fields in the PDF form, making the PDF file uneditable.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top
See Also

Reference

PDFForm Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFForm Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

For a list of all members of this type, see PDFForm members.

Public Methods
 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | FlattenFormField | Flattens the specified form field, making the field uneditable.
Public Method | FlattenFormFields | Flattens all the fields in the PDF form, making the PDF file uneditable.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top
See Also

Reference

PDFForm Class
O2S.Components.PDF4NET.Forms Namespace


ExportData Method (PDFForm)

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : ExportData Method
Exports the form data to a file.
Overload List
Overload | Description
ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) | Exports the form data to a file.
ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) | Exports the form data to a stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ExportData Method : ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) Method
The full path to the file where form data will be exported.
The format of exported data.
Options for specifying the type of data to be exported.
The name of the PDF file the data is exported from.
Exports the form data to a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ExportData( _
   ByVal fileName As String, _
   ByVal format As PDFFormDataFormat, _
   ByVal options As PDFExportDataOptions, _
   ByVal pdfFileName As String _
)
'Usage

Dim instance As PDFForm
Dim fileName As String
Dim format As PDFFormDataFormat
Dim options As PDFExportDataOptions
Dim pdfFileName As String

instance.ExportData(fileName, format, options, pdfFileName)
public void ExportData(
   string fileName,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string pdfFileName
)
public: void ExportData(
   string* fileName,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string* pdfFileName
)
public:
void ExportData(
   String^ fileName,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   String^ pdfFileName
)

Parameters

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFileName
The name of the PDF file the data is exported from.
Remarks
The name of the source PDF file is required because the data files (both FDF and XFDF) need a reference to the PDF file from which they were exported. This file name does not need to match the actual file name used for saving the PDF document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ExportData Method : ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) Method
The stream where form data will be exported.
The format of exported data.
Options for specifying the type of data to be exported.
Exports the form data to a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ExportData( _
   ByVal stream As Stream, _
   ByVal format As PDFFormDataFormat, _
   ByVal options As PDFExportDataOptions, _
   ByVal pdfFilename As String _
)
'Usage

Dim instance As PDFForm
Dim stream As Stream
Dim format As PDFFormDataFormat
Dim options As PDFExportDataOptions
Dim pdfFilename As String

instance.ExportData(stream, format, options, pdfFilename)
public void ExportData(
   Stream stream,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string pdfFilename
)
public: void ExportData(
   Stream* stream,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string* pdfFilename
)
public:
void ExportData(
   Stream^ stream,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   String^ pdfFilename
)

Parameters

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFilename
Remarks
The name of the source PDF file is required because the data files (both FDF and XFDF) need a reference to the PDF file from which they were exported. This file name does not need to match the actual file name used for saving the PDF document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


FlattenFormField Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : FlattenFormField Method
Flattens the specified form field, making the field uneditable.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub FlattenFormField( _
   ByVal field As PDFField _
)
'Usage

Dim instance As PDFForm
Dim field As PDFField

instance.FlattenFormField(field)
public void FlattenFormField(
   PDFField field
)
public: void FlattenFormField(
   PDFField* field
)
public:
void FlattenFormField(
   PDFField^ field
)

Parameters

field
Remarks
This action is ireversible. Once the form field has been flattened, it can no longer be edited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


FlattenFormFields Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : FlattenFormFields Method
Flattens all the fields in the PDF form, making the PDF file uneditable.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub FlattenFormFields()
'Usage

Dim instance As PDFForm

instance.FlattenFormFields()
public void FlattenFormFields()
public: void FlattenFormFields();
public:
void FlattenFormFields();
Remarks
This action is ireversible. Once the form fields have been flattened, they can no longer be edited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


ImportData Method (PDFForm)

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : ImportData Method
Imports form data from an external file.
Overload List
Overload | Description
ImportData(String,PDFFormDataFormat) | Imports form data from an external file.
ImportData(String,PDFFormDataFormat,Boolean) | Imports form data from an external file.
ImportData(Stream,PDFFormDataFormat) | Imports form data from an external file.
ImportData(Stream,PDFFormDataFormat,Boolean) | Imports form data from an external file.
ImportData(FDFFile) | Imports form data from a FDF file.
ImportData(FDFFile,Boolean) | Imports form data from a FDF file.
ImportData(XFDFFile) | Imports form data from a XFDF file.
ImportData(XFDFFile,Boolean) | Imports form data from a XFDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


ImportData(String,PDFFormDataFormat) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(String,PDFFormDataFormat) Method
The file from which to import form data.
The format of input file.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As PDFFormDataFormat _
)
'Usage

Dim instance As PDFForm
Dim fileName As String
Dim dataFormat As PDFFormDataFormat

instance.ImportData(fileName, dataFormat)
public void ImportData(
   string fileName,
   PDFFormDataFormat dataFormat
)
public: void ImportData(
   string* fileName,
   PDFFormDataFormat dataFormat
)
public:
void ImportData(
   String^ fileName,
   PDFFormDataFormat dataFormat
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFException | thrown when the input file can not be open or read.
O2S.Components.PDF4NET.PDFParserException | thrown when the input file can not be parsed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(String,PDFFormDataFormat,Boolean) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(String,PDFFormDataFormat,Boolean) Method
The file from which to import form data.
The format of input file.
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As PDFFormDataFormat, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
'Usage

Dim instance As PDFForm
Dim fileName As String
Dim dataFormat As PDFFormDataFormat
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(fileName, dataFormat, continueImportOnError)
public PDFFieldImportError[] ImportData(
   string fileName,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
public: PDFFieldImportError*[]* ImportData(
   string* fileName,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
public:
array<PDFFieldImportError^>^ ImportData(
   String^ fileName,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFException | thrown when the input file can not be open or read.
O2S.Components.PDF4NET.PDFParserException | thrown when the input file can not be parsed.
Remarks
If no errors occured during the import, the returned array is null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(Stream,PDFFormDataFormat) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(Stream,PDFFormDataFormat) Method
The stream from which to import form data.
The format of input stream.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As PDFFormDataFormat _
)
'Usage

Dim instance As PDFForm
Dim stream As Stream
Dim dataFormat As PDFFormDataFormat

instance.ImportData(stream, dataFormat)
public void ImportData(
   Stream stream,
   PDFFormDataFormat dataFormat
)
public: void ImportData(
   Stream* stream,
   PDFFormDataFormat dataFormat
)
public:
void ImportData(
   Stream^ stream,
   PDFFormDataFormat dataFormat
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFException | Thrown when the input stream can not be read.
O2S.Components.PDF4NET.PDFParserException | Thrown when the input stream can not be parsed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(Stream,PDFFormDataFormat,Boolean) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(Stream,PDFFormDataFormat,Boolean) Method
The stream from which to import form data.
The format of input stream.
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As PDFFormDataFormat, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
'Usage

Dim instance As PDFForm
Dim stream As Stream
Dim dataFormat As PDFFormDataFormat
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(stream, dataFormat, continueImportOnError)
public PDFFieldImportError[] ImportData(
   Stream stream,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
public: PDFFieldImportError*[]* ImportData(
   Stream* stream,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
public:
array<PDFFieldImportError^>^ ImportData(
   Stream^ stream,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFException | Thrown when the input stream can not be read.
O2S.Components.PDF4NET.PDFParserException | Thrown when the input stream can not be parsed.
Remarks
If no errors occured during the import, the returned array is null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(FDFFile) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(FDFFile) Method
A FDFFile object that stores the form data.
Imports form data from a FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal fdfFile As FDFFile _
)
'Usage

Dim instance As PDFForm
Dim fdfFile As FDFFile

instance.ImportData(fdfFile)
public void ImportData(
   FDFFile fdfFile
)
public: void ImportData(
   FDFFile* fdfFile
)
public:
void ImportData(
   FDFFile^ fdfFile
)

Parameters

fdfFile
A FDFFile object that stores the form data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(FDFFile,Boolean) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(FDFFile,Boolean) Method
A FDFFile object that stores the form data.
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from a FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ImportData( _
   ByVal fdfFile As FDFFile, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
'Usage

Dim instance As PDFForm
Dim fdfFile As FDFFile
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(fdfFile, continueImportOnError)
public PDFFieldImportError[] ImportData(
   FDFFile fdfFile,
   bool continueImportOnError
)
public: PDFFieldImportError*[]* ImportData(
   FDFFile* fdfFile,
   bool continueImportOnError
)
public:
array<PDFFieldImportError^>^ ImportData(
   FDFFile^ fdfFile,
   bool continueImportOnError
)

Parameters

fdfFile
A FDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.
Remarks
If no errors occured during the import, the returned array is null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(XFDFFile) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(XFDFFile) Method
A XFDFFile object that stores the form data.
Imports form data from a XFDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal xfdfFile As XFDFFile _
)
'Usage

Dim instance As PDFForm
Dim xfdfFile As XFDFFile

instance.ImportData(xfdfFile)
public void ImportData(
   XFDFFile xfdfFile
)
public: void ImportData(
   XFDFFile* xfdfFile
)
public:
void ImportData(
   XFDFFile^ xfdfFile
)

Parameters

xfdfFile
A XFDFFile object that stores the form data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(XFDFFile,Boolean) Method

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(XFDFFile,Boolean) Method
A XFDFFile object that stores the form data.
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from a XFDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ImportData( _
   ByVal xfdfFile As XFDFFile, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
'Usage

Dim instance As PDFForm
Dim xfdfFile As XFDFFile
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(xfdfFile, continueImportOnError)
public PDFFieldImportError[] ImportData(
   XFDFFile xfdfFile,
   bool continueImportOnError
)
public: PDFFieldImportError*[]* ImportData(
   XFDFFile* xfdfFile,
   bool continueImportOnError
)
public:
array<PDFFieldImportError^>^ ImportData(
   XFDFFile^ xfdfFile,
   bool continueImportOnError
)

Parameters

xfdfFile
A XFDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.
Remarks
If no errors occured during the import, the returned array is null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFForm Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

For a list of all members of this type, see PDFForm members.

Public Properties
 | Name | Description
Public Property | CalculatedFields | Gets the list of calculated fields in the form.
Public Property | Document | Gets the document that includes this form.
Public Property | Fields | Gets the list of fields included in the form.
Public Property | NeedAppearances | Gets or sets a value indicating whether the viewer application needs to rebuild the field appearance upon form loading.
Top
See Also

Reference

PDFForm Class
O2S.Components.PDF4NET.Forms Namespace


CalculatedFields Property

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : CalculatedFields Property
Gets the list of calculated fields in the form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CalculatedFields As PDFCalculatedFieldCollection
'Usage

Dim instance As PDFForm
Dim value As PDFCalculatedFieldCollection

value = instance.CalculatedFields
public PDFCalculatedFieldCollection CalculatedFields {get;}
public: __property PDFCalculatedFieldCollection* get_CalculatedFields();
public:
property PDFCalculatedFieldCollection^ CalculatedFields {
   PDFCalculatedFieldCollection^ get();
}
Remarks
The order of the fields in this collection define the calculation order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


Document Property (PDFForm)

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : Document Property
Gets the document that includes this form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Document As PDFDocument
'Usage

Dim instance As PDFForm
Dim value As PDFDocument

value = instance.Document
public PDFDocument Document {get;}
public: __property PDFDocument* get_Document();
public:
property PDFDocument^ Document {
   PDFDocument^ get();
}

Property Value

The document that owns the form.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


Fields Property (PDFForm)

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : Fields Property
Gets the list of fields included in the form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As PDFFieldCollection
'Usage

Dim instance As PDFForm
Dim value As PDFFieldCollection

value = instance.Fields
public PDFFieldCollection Fields {get;}
public: __property PDFFieldCollection* get_Fields();
public:
property PDFFieldCollection^ Fields {
   PDFFieldCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


NeedAppearances Property

O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : NeedAppearances Property
Gets or sets a value indicating whether the viewer application needs to rebuild the field appearance upon form loading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NeedAppearances As Boolean
'Usage

Dim instance As PDFForm
Dim value As Boolean

instance.NeedAppearances = value

value = instance.NeedAppearances
public bool NeedAppearances {get; set;}
public: __property bool get_NeedAppearances();
public: __property void set_NeedAppearances(
   bool value
);
public:
property bool NeedAppearances {
   bool get();
   void set (    bool value);
}

Property Value

True if the field appearance must be rebuilt by the viewer application, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


%%PageItemTitle%%

PDFListBoxField Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class
Defines a scrollable list box field for user input in the PDF file.
Object Model
PDFListBoxField ClassPDFJavaScriptAction ClassPDFDictionary ClassPDFForm ClassPDFJavaScriptAction ClassPDFListItemCollection ClassPDFListItem ClassPDFJavaScriptAction ClassPDFListItem ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFListBoxField
   Inherits PDFListField
'Usage

Dim instance As PDFListBoxField
public class PDFListBoxField : PDFListField
public __gc class PDFListBoxField : public PDFListField
public ref class PDFListBoxField : public PDFListField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFListBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListBoxField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

The following tables list the members exposed by PDFListBoxField.

Public Constructors
 | Name | Description
Public Constructor | PDFListBoxField Constructor | Initializes a new PDFListBoxField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFListBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFListBoxField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFListBoxField Class : PDFListBoxField Constructor
The name of this field object.
Initializes a new PDFListBoxField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFListBoxField(name)
public PDFListBoxField(
   string name
)
public: PDFListBoxField(
   string* name
)
public:
PDFListBoxField(
   String^ name
)

Parameters

name
The name of this field object.
Remarks
The field name must be unique across the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxField Class
PDFListBoxField Members


%%PageItemTitle%%

PDFListBoxWidget Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFListBoxWidget Class
Defines the widget for a listbox field.
Object Model
PDFListBoxWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFListBoxWidget
   Inherits PDFFieldWidget
'Usage

Dim instance As PDFListBoxWidget
public class PDFListBoxWidget : PDFFieldWidget
public __gc class PDFListBoxWidget : public PDFFieldWidget
public ref class PDFListBoxWidget : public PDFFieldWidget
Remarks
The field widget is the field's visual representation on a PDF page. A textbox field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFListBoxWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxWidget Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListBoxWidget Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListBoxWidget Class

The following tables list the members exposed by PDFListBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFListBoxWidget Constructor | Initializes a new PDFListBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFListBoxWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFListBoxWidget Class : PDFListBoxWidget Constructor
Initializes a new PDFListBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFListBoxWidget()
public PDFListBoxWidget()
public: PDFListBoxWidget();
public:
PDFListBoxWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxWidget Class
PDFListBoxWidget Members


%%PageItemTitle%%

PDFListField Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFListField Class
Base class for all list type fields.
Object Model
PDFListField ClassPDFJavaScriptAction ClassPDFDictionary ClassPDFForm ClassPDFJavaScriptAction ClassPDFListItemCollection ClassPDFListItem ClassPDFJavaScriptAction ClassPDFListItem ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFListField
   Inherits PDFField
'Usage

Dim instance As PDFListField
public abstract class PDFListField : PDFField
public __gc abstract class PDFListField : public PDFField
public ref class PDFListField abstract : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFDropDownListField
O2S.Components.PDF4NET.Forms.PDFListBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

The following tables list the members exposed by PDFListField.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFListField Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

For a list of all members of this type, see PDFListField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFListField Class
O2S.Components.PDF4NET.Forms Namespace


CommitOnSelChange Property

O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : CommitOnSelChange Property
Gets or sets whether the selected item is commited as soon as the selection is made.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CommitOnSelChange As Boolean
'Usage

Dim instance As PDFListField
Dim value As Boolean

instance.CommitOnSelChange = value

value = instance.CommitOnSelChange
public bool CommitOnSelChange {get; set;}
public: __property bool get_CommitOnSelChange();
public: __property void set_CommitOnSelChange(
   bool value
);
public:
property bool CommitOnSelChange {
   bool get();
   void set (    bool value);
}

Property Value

True if the selected item is commited as soon as the selection is made, false otherwise. Default is false.
Remarks
If set, the new value is committed as soon as a selection is made with the pointing device. This option enables applications to perform an action once a selection is made, without requiring the user to exit the field. If clear, the new value is not committed until the user exits the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


Items Property (PDFListField)

O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : Items Property
Gets the collection of items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Items As PDFListItemCollection
'Usage

Dim instance As PDFListField
Dim value As PDFListItemCollection

value = instance.Items
public PDFListItemCollection Items {get;}
public: __property PDFListItemCollection* get_Items();
public:
property PDFListItemCollection^ Items {
   PDFListItemCollection^ get();
}

Property Value

A PDFListItemCollection that represents the items within the list.
Remarks
Use this property to get the properties of items in the list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


SelectedIndex Property (PDFListField)

O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : SelectedIndex Property
Gets or sets the lowest ordinal index of the selected items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedIndex As Integer
'Usage

Dim instance As PDFListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
public int SelectedIndex {get; set;}
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
public:
property int SelectedIndex {
   int get();
   void set (    int value);
}

Property Value

The lowest ordinal index of the selected items in the list. The default is -1, which indicates that nothing is selected.
Remarks
Use this property to determine the index of the currently selected item in the list if the list control allows only one selection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


SelectedItem Property (PDFListField)

O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : SelectedItem Property
Gets or sets the first selected item in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedItem As PDFListItem
'Usage

Dim instance As PDFListField
Dim value As PDFListItem

instance.SelectedItem = value

value = instance.SelectedItem
public PDFListItem SelectedItem {get; set;}
public: __property PDFListItem* get_SelectedItem();
public: __property void set_SelectedItem(
   PDFListItem* value
);
public:
property PDFListItem^ SelectedItem {
   PDFListItem^ get();
   void set (    PDFListItem^ value);
}

Property Value

A PDFListItem object specifying the first selected item.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The item does not exist in the list.
Remarks
null (Nothing in VB.NET) means that no item is selected.
If the item does not exist in the list, an exception is thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


SelectedValue Property (PDFListField)

O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : SelectedValue Property
Gets or sets the value of the first selected item in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedValue As String
'Usage

Dim instance As PDFListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
public string SelectedValue {get; set;}
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
public:
property String^ SelectedValue {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the value of the first selected item, null (Nothing in VB.NET) if there is no selected item.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The value does not exist in field's set of values.
Remarks
When setting the selected value, if the value does not exist in the list, an exception is thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


Sort Property

O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : Sort Property
Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sort As Boolean
'Usage

Dim instance As PDFListField
Dim value As Boolean

instance.Sort = value

value = instance.Sort
public bool Sort {get; set;}
public: __property bool get_Sort();
public: __property void set_Sort(
   bool value
);
public:
property bool Sort {
   bool get();
   void set (    bool value);
}

Property Value

True if the items are sorted, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


%%PageItemTitle%%

PDFListItem Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class
Defines an item in a list.
Object Model
PDFListItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFListItem
'Usage

Dim instance As PDFListItem
public class PDFListItem
public __gc class PDFListItem
public ref class PDFListItem
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFListItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListItem Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

The following tables list the members exposed by PDFListItem.

Public Constructors
 | Name | Description
Public Constructor | PDFListItem Constructor | Initialzies a new PDFListItem object.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the item.
Public Property | Value | Gets or sets the value of the item.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new PDFListItem object.
Top
See Also

Reference

PDFListItem Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFListItem Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : PDFListItem Constructor
The item name, it is displayed in the list.
The item value, it is exported when form content is exported.
Initialzies a new PDFListItem object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal value As String _
)
'Usage

Dim name As String
Dim value As String

Dim instance As New PDFListItem(name, value)
public PDFListItem(
   string name,
   string value
)
public: PDFListItem(
   string* name,
   string* value
)
public:
PDFListItem(
   String^ name,
   String^ value
)

Parameters

name
The item name, it is displayed in the list.
value
The item value, it is exported when form content is exported.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the item value is null or empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%% $$Methods$$

PDFListItem Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

For a list of all members of this type, see PDFListItem members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new PDFListItem object.
Top
See Also

Reference

PDFListItem Class
O2S.Components.PDF4NET.Forms Namespace


Create Method

O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : Create Method
The item name, it is displayed in the list.
The item value, it is exported when form content is exported.
Creates a new PDFListItem object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Create( _
   ByVal name As String, _
   ByVal value As String _
) As PDFListItem
'Usage

Dim name As String
Dim value As String
Dim value As PDFListItem

value = PDFListItem.Create(name, value)
public static PDFListItem Create(
   string name,
   string value
)
public: static PDFListItem* Create(
   string* name,
   string* value
)
public:
static PDFListItem^ Create(
   String^ name,
   String^ value
)

Parameters

name
The item name, it is displayed in the list.
value
The item value, it is exported when form content is exported.

Return Value

A PDFListItem object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%% $$Properties$$

PDFListItem Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

For a list of all members of this type, see PDFListItem members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the item.
Public Property | Value | Gets or sets the value of the item.
Top
See Also

Reference

PDFListItem Class
O2S.Components.PDF4NET.Forms Namespace


Name Property (PDFListItem)

O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : Name Property
Gets or sets the name of the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFListItem
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the name of the item.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Class
PDFListItem Members


Value Property (PDFListItem)

O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : Value Property
Gets or sets the value of the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As String
'Usage

Dim instance As PDFListItem
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the value of the item.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%%

PDFListItemCollection Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class
Defines a collection of list items.
Object Model
PDFListItemCollection ClassPDFListItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFListItemCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFListItem,PDFListField)
'Usage

Dim instance As PDFListItemCollection
public class PDFListItemCollection : O2S.Components.PDF4NET.PDFCollection<PDFListItem,PDFListField>
public __gc class PDFListItemCollection : public O2S.Components.PDF4NET.PDFCollection<PDFListItem,PDFListField>
public ref class PDFListItemCollection : public O2S.Components.PDF4NET.PDFCollection<PDFListItem,PDFListField>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Forms.PDFListItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItemCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListItemCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

The following tables list the members exposed by PDFListItemCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top
See Also

Reference

PDFListItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonField Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonField Class
Defines a pushbutton in a PDF form.
Object Model
PDFPushButtonField ClassPDFJavaScriptAction ClassPDFDictionary ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPushButtonField
   Inherits PDFField
'Usage

Dim instance As PDFPushButtonField
public class PDFPushButtonField : PDFField
public __gc class PDFPushButtonField : public PDFField
public ref class PDFPushButtonField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFPushButtonField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFPushButtonField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonField Class

The following tables list the members exposed by PDFPushButtonField.

Public Constructors
 | Name | Description
Public Constructor | PDFPushButtonField Constructor | Initializes a new PDFPushButtonField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Caption | Gets the button caption.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Tooltip | Overridden. Gets or sets the field tooltip.
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFPushButtonField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonField Class : PDFPushButtonField Constructor
The name of the pushbutton field
Initializes a new PDFPushButtonField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFPushButtonField(name)
public PDFPushButtonField(
   string name
)
public: PDFPushButtonField(
   string* name
)
public:
PDFPushButtonField(
   String^ name
)

Parameters

name
The name of the pushbutton field
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


%%PageItemTitle%% $$Properties$$

PDFPushButtonField Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonField Class

For a list of all members of this type, see PDFPushButtonField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Caption | Gets the button caption.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Tooltip | Overridden. Gets or sets the field tooltip.
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFPushButtonField Class
O2S.Components.PDF4NET.Forms Namespace


Caption Property (PDFPushButtonField)

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonField Class : Caption Property
Gets the button caption.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Caption As String
'Usage

Dim instance As PDFPushButtonField
Dim value As String

value = instance.Caption
public string Caption {get;}
public: __property string* get_Caption();
public:
property String^ Caption {
   String^ get();
}

Property Value

The text displayed on the button.
Remarks
If the button has multiple widgets, this property returns the caption defined on the first widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


Tooltip Property (PDFPushButtonField)

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonField Class : Tooltip Property
Gets or sets the field tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Tooltip As String
'Usage

Dim instance As PDFPushButtonField
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
public override string Tooltip {get; set;}
public: __property string* get_Tooltip() override;
public: __property void set_Tooltip(
   string* value
) override;
public:
property String^ Tooltip {
   String^ get() override;
   void set (    String^ value) override;
}

Property Value

The field's tooltip.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


%%PageItemTitle%%

PDFPushButtonWidget Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonWidget Class
Defines the widget for a pushbutton field.
Object Model
PDFPushButtonWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFAnnotationAppearance ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFFormXObject ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFAnnotationAppearance ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPushButtonWidget
   Inherits PDFFieldWidget
'Usage

Dim instance As PDFPushButtonWidget
public class PDFPushButtonWidget : PDFFieldWidget
public __gc class PDFPushButtonWidget : public PDFFieldWidget
public ref class PDFPushButtonWidget : public PDFFieldWidget
Remarks
The field widget is the field's visual representation on a PDF page. A pushbutton field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFPushButtonWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFPushButtonWidget Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonWidget Class

The following tables list the members exposed by PDFPushButtonWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFPushButtonWidget Constructor | Initializes a new PDFPushButtonWidget object.
Top
Public Properties
 | Name | Description
Public Property | Align | Gets or sets the caption alignment on the button.
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Caption | Gets or sets the widget's caption.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DownAppearance | Gets or sets the down widget appearance.
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | HighlightMode | Gets or sets the highlighting mode of the button widget.
Public Property | Icon | Gets or sets the icon of the button.
Public Property | IconLayoutMode | Gets or sets the layout mode of button's icon.
Public Property | IconSize | Gets or sets the size of the displayed icon.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | RolloverAppearance | Gets or sets the rollover widget appearance.
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : PDFPushButtonWidget Constructor
Initializes a new PDFPushButtonWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPushButtonWidget()
public PDFPushButtonWidget()
public: PDFPushButtonWidget();
public:
PDFPushButtonWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%PageItemTitle%% $$Properties$$

PDFPushButtonWidget Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonWidget Class

For a list of all members of this type, see PDFPushButtonWidget members.

Public Properties
 | Name | Description
Public Property | Align | Gets or sets the caption alignment on the button.
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Caption | Gets or sets the widget's caption.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DownAppearance | Gets or sets the down widget appearance.
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | HighlightMode | Gets or sets the highlighting mode of the button widget.
Public Property | Icon | Gets or sets the icon of the button.
Public Property | IconLayoutMode | Gets or sets the layout mode of button's icon.
Public Property | IconSize | Gets or sets the size of the displayed icon.
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | RolloverAppearance | Gets or sets the rollover widget appearance.
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDF4NET.Forms Namespace


Align Property (PDFPushButtonWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : Align Property
Gets or sets the caption alignment on the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Align As PDFFieldTextAlign
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFFieldTextAlign

instance.Align = value

value = instance.Align
public PDFFieldTextAlign Align {get; set;}
public: __property PDFFieldTextAlign get_Align();
public: __property void set_Align(
   PDFFieldTextAlign value
);
public:
property PDFFieldTextAlign Align {
   PDFFieldTextAlign get();
   void set (    PDFFieldTextAlign value);
}

Property Value

A PDFFieldTextAlign enumeration member specifying the caption alignment on the button.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


Caption Property (PDFPushButtonWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : Caption Property
Gets or sets the widget's caption.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Caption As String
'Usage

Dim instance As PDFPushButtonWidget
Dim value As String

instance.Caption = value

value = instance.Caption
public string Caption {get; set;}
public: __property string* get_Caption();
public: __property void set_Caption(
   string* value
);
public:
property String^ Caption {
   String^ get();
   void set (    String^ value);
}

Property Value

The caption of pushbutton's widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


DownAppearance Property

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : DownAppearance Property
Gets or sets the down widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DownAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFAnnotationAppearance

instance.DownAppearance = value

value = instance.DownAppearance
public PDFAnnotationAppearance DownAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_DownAppearance();
public: __property void set_DownAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ DownAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The down appearance of the field widget.
Remarks
This appearance is displayed when the mouse is clicked on the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


HighlightMode Property (PDFPushButtonWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : HighlightMode Property
Gets or sets the highlighting mode of the button widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighlightMode As PDFPushButtonHighlightMode
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFPushButtonHighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
public PDFPushButtonHighlightMode HighlightMode {get; set;}
public: __property PDFPushButtonHighlightMode get_HighlightMode();
public: __property void set_HighlightMode(
   PDFPushButtonHighlightMode value
);
public:
property PDFPushButtonHighlightMode HighlightMode {
   PDFPushButtonHighlightMode get();
   void set (    PDFPushButtonHighlightMode value);
}

Property Value

A PDFPushButtonHighlightMode enumeration member specifying the highlighting mode for the button widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


Icon Property (PDFPushButtonWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : Icon Property
Gets or sets the icon of the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Icon As PDFFormXObject
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFFormXObject

instance.Icon = value

value = instance.Icon
public PDFFormXObject Icon {get; set;}
public: __property PDFFormXObject* get_Icon();
public: __property void set_Icon(
   PDFFormXObject* value
);
public:
property PDFFormXObject^ Icon {
   PDFFormXObject^ get();
   void set (    PDFFormXObject^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject object specifying the caption of the button.
Remarks
When this proeprty is set, the IconSize property is automatically set to icon's original size.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


IconLayoutMode Property

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : IconLayoutMode Property
Gets or sets the layout mode of button's icon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IconLayoutMode As PDFPushButtonIconLayoutMode
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFPushButtonIconLayoutMode

instance.IconLayoutMode = value

value = instance.IconLayoutMode
public PDFPushButtonIconLayoutMode IconLayoutMode {get; set;}
public: __property PDFPushButtonIconLayoutMode get_IconLayoutMode();
public: __property void set_IconLayoutMode(
   PDFPushButtonIconLayoutMode value
);
public:
property PDFPushButtonIconLayoutMode IconLayoutMode {
   PDFPushButtonIconLayoutMode get();
   void set (    PDFPushButtonIconLayoutMode value);
}

Property Value

A PDFPushButtonIconLayoutMode enumeration member specifying the layout mode for button's icon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


IconSize Property

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : IconSize Property
Gets or sets the size of the displayed icon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IconSize As SizeF
'Usage

Dim instance As PDFPushButtonWidget
Dim value As SizeF

instance.IconSize = value

value = instance.IconSize
public SizeF IconSize {get; set;}
public: __property SizeF get_IconSize();
public: __property void set_IconSize(
   SizeF value
);
public:
property SizeF IconSize {
   SizeF get();
   void set (    SizeF value);
}

Property Value

A System.Drawing.SizeF object specifying the size of the displayed icon.
Remarks
The icon is scaled to fit in the given size, it is not cut. If this property is (0,0), then the icon is not displayed.
Set this property always after the Icon property has been set, because when Icon property is set, it resets the values of this property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


RolloverAppearance Property

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : RolloverAppearance Property
Gets or sets the rollover widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RolloverAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFAnnotationAppearance

instance.RolloverAppearance = value

value = instance.RolloverAppearance
public PDFAnnotationAppearance RolloverAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_RolloverAppearance();
public: __property void set_RolloverAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ RolloverAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The rollover appearance of the field widget.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%PageItemTitle%%

PDFRadioButtonItem Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class
Defines the widget for a radio button.
Object Model
PDFRadioButtonItem ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRadioButtonItem
   Inherits PDFCheckWidget
'Usage

Dim instance As PDFRadioButtonItem
public class PDFRadioButtonItem : PDFCheckWidget
public __gc class PDFRadioButtonItem : public PDFCheckWidget
public ref class PDFRadioButtonItem : public PDFCheckWidget
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonItem Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFRadioButtonItem Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

The following tables list the members exposed by PDFRadioButtonItem.

Public Constructors
 | Name | Description
Public Constructor | PDFRadioButtonItem Constructor | Initializes a new PDFRadioButtonItem object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonItem Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : PDFRadioButtonItem Constructor
Initializes a new PDFRadioButtonItem object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRadioButtonItem()
public PDFRadioButtonItem()
public: PDFRadioButtonItem();
public:
PDFRadioButtonItem();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

PDFRadioButtonListField Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class
Defines a list of radio buttons in a PDF form.
Object Model
PDFRadioButtonListField ClassPDFJavaScriptAction ClassPDFDictionary ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRadioButtonListField
   Inherits PDFField
'Usage

Dim instance As PDFRadioButtonListField
public class PDFRadioButtonListField : PDFField
public __gc class PDFRadioButtonListField : public PDFField
public ref class PDFRadioButtonListField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFRadioButtonListField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFRadioButtonListField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

The following tables list the members exposed by PDFRadioButtonListField.

Public Constructors
 | Name | Description
Public Constructor | PDFRadioButtonListField Constructor | Initializes a new PDFRadioButtonListField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Checked | Gets or sets a value indicating whether the radio button list is checked or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radiobutton should be selected all the time.
Public Property | RadiosInUnison | Gets or sets a value indicating whether radio button fields with the same export value in the same group should be all selected.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the selected radio button item.
Public Property | SelectedValue | Gets or sets the value of the selected radio button item .
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonListField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : PDFRadioButtonListField Constructor
The name of the field.
Initializes a new PDFRadioButtonListField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFRadioButtonListField(name)
public PDFRadioButtonListField(
   string name
)
public: PDFRadioButtonListField(
   string* name
)
public:
PDFRadioButtonListField(
   String^ name
)

Parameters

name
The name of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%% $$Properties$$

PDFRadioButtonListField Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

For a list of all members of this type, see PDFRadioButtonListField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Checked | Gets or sets a value indicating whether the radio button list is checked or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radiobutton should be selected all the time.
Public Property | RadiosInUnison | Gets or sets a value indicating whether radio button fields with the same export value in the same group should be all selected.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the selected radio button item.
Public Property | SelectedValue | Gets or sets the value of the selected radio button item .
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDF4NET.Forms Namespace


Checked Property (PDFRadioButtonListField)

O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : Checked Property
Gets or sets a value indicating whether the radio button list is checked or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Checked As Boolean
'Usage

Dim instance As PDFRadioButtonListField
Dim value As Boolean

instance.Checked = value

value = instance.Checked
public bool Checked {get; set;}
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
public:
property bool Checked {
   bool get();
   void set (    bool value);
}

Property Value

True if at least one radio button widget is checked, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


NoToggleToOff Property

O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : NoToggleToOff Property
Gets or sets a value indicating whether a radiobutton should be selected all the time.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NoToggleToOff As Boolean
'Usage

Dim instance As PDFRadioButtonListField
Dim value As Boolean

instance.NoToggleToOff = value

value = instance.NoToggleToOff
public bool NoToggleToOff {get; set;}
public: __property bool get_NoToggleToOff();
public: __property void set_NoToggleToOff(
   bool value
);
public:
property bool NoToggleToOff {
   bool get();
   void set (    bool value);
}

Property Value

True if a radiobutton should be selected all the time, otherwise false. Default is true.
Remarks
If this property is true, clicking on currently selected radiobutton has no effect. If this property is false, clicking on currently selected radiobutton deselects it, leaving no radiobutton selected.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


RadiosInUnison Property

O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : RadiosInUnison Property
Gets or sets a value indicating whether radio button fields with the same export value in the same group should be all selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RadiosInUnison As Boolean
'Usage

Dim instance As PDFRadioButtonListField
Dim value As Boolean

instance.RadiosInUnison = value

value = instance.RadiosInUnison
public bool RadiosInUnison {get; set;}
public: __property bool get_RadiosInUnison();
public: __property void set_RadiosInUnison(
   bool value
);
public:
property bool RadiosInUnison {
   bool get();
   void set (    bool value);
}

Property Value

True if all the buttons with the same export value should be selected.
Remarks
If true, a group of radio buttons within a radio button field that use the same value for the on state will turn on and off in unison; that is if one is checked, they are all checked. If false, the buttons are mutually exclusive.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


SelectedIndex Property (PDFRadioButtonListField)

O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : SelectedIndex Property
Gets or sets the selected radio button item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedIndex As Integer
'Usage

Dim instance As PDFRadioButtonListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
public int SelectedIndex {get; set;}
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
public:
property int SelectedIndex {
   int get();
   void set (    int value);
}

Property Value

The index of the selected radio button item.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


SelectedValue Property (PDFRadioButtonListField)

O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : SelectedValue Property
Gets or sets the value of the selected radio button item .
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedValue As String
'Usage

Dim instance As PDFRadioButtonListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
public string SelectedValue {get; set;}
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
public:
property String^ SelectedValue {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the value of the selected item.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The value does not exist in field's set of values.
Remarks
null (Nothing in VB.NET) or "Off" means that no radio button item is selected.
When setting the selected value, if the value does not exist in the list, an exception is thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%%

PDFSignatureField Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class
Defines a signature field in a PDF form.
Object Model
PDFSignatureField ClassPDFJavaScriptAction ClassPDFDictionary ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFSignatureLockFieldAction ClassPDFDigitalSignature ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSignatureField
   Inherits PDFField
'Usage

Dim instance As PDFSignatureField
public class PDFSignatureField : PDFField
public __gc class PDFSignatureField : public PDFField
public ref class PDFSignatureField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFSignatureField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFSignatureField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

The following tables list the members exposed by PDFSignatureField.

Public Constructors
 | Name | Description
Public Constructor | PDFSignatureField Constructor | Initializes a new PDFSignatureField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | LockFieldAction | Gets or sets the lock field action.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Signature | Gets or sets the digital signature for signing the the field.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFSignatureField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : PDFSignatureField Constructor
The name of the field.
Initializes a new PDFSignatureField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFSignatureField(name)
public PDFSignatureField(
   string name
)
public: PDFSignatureField(
   string* name
)
public:
PDFSignatureField(
   String^ name
)

Parameters

name
The name of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%PageItemTitle%% $$Properties$$

PDFSignatureField Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

For a list of all members of this type, see PDFSignatureField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | LockFieldAction | Gets or sets the lock field action.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Signature | Gets or sets the digital signature for signing the the field.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFSignatureField Class
O2S.Components.PDF4NET.Forms Namespace


LockFieldAction Property

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : LockFieldAction Property
Gets or sets the lock field action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LockFieldAction As PDFSignatureLockFieldAction
'Usage

Dim instance As PDFSignatureField
Dim value As PDFSignatureLockFieldAction

instance.LockFieldAction = value

value = instance.LockFieldAction
public PDFSignatureLockFieldAction LockFieldAction {get; set;}
public: __property PDFSignatureLockFieldAction* get_LockFieldAction();
public: __property void set_LockFieldAction(
   PDFSignatureLockFieldAction* value
);
public:
property PDFSignatureLockFieldAction^ LockFieldAction {
   PDFSignatureLockFieldAction^ get();
   void set (    PDFSignatureLockFieldAction^ value);
}

Property Value

The lock field action to be executed when the signature field is signed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


Signature Property

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : Signature Property
Gets or sets the digital signature for signing the the field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Signature As PDFDigitalSignature
'Usage

Dim instance As PDFSignatureField
Dim value As PDFDigitalSignature

instance.Signature = value

value = instance.Signature
public PDFDigitalSignature Signature {get; set;}
public: __property PDFDigitalSignature* get_Signature();
public: __property void set_Signature(
   PDFDigitalSignature* value
);
public:
property PDFDigitalSignature^ Signature {
   PDFDigitalSignature^ get();
   void set (    PDFDigitalSignature^ value);
}

Property Value

A O2S.Components.PDF4NET.Security.PDFDigitalSignature object specifying the digital signature for signing the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%PageItemTitle%%

PDFSignatureLockFieldAction Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureLockFieldAction Class
Defines the field lock action to be executed when a signature field is signed.
Object Model
PDFSignatureLockFieldAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSignatureLockFieldAction
'Usage

Dim instance As PDFSignatureLockFieldAction
public class PDFSignatureLockFieldAction
public __gc class PDFSignatureLockFieldAction
public ref class PDFSignatureLockFieldAction
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFSignatureLockFieldAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFSignatureLockFieldAction Class Members
Properties

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureLockFieldAction Class

The following tables list the members exposed by PDFSignatureLockFieldAction.

Public Constructors
 | Name | Description
Public Constructor | PDFSignatureLockFieldAction Constructor | Initializes a new PDFSignatureLockFieldAction object.
Top
Public Properties
 | Name | Description
Public Property | Fields | Gets or sets the fields to be locked.
Public Property | SignatureLockFieldMode | Gets or sets the mode for applying the field lock.
Top
See Also

Reference

PDFSignatureLockFieldAction Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureLockFieldAction Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureLockFieldAction Class : PDFSignatureLockFieldAction Constructor
Initializes a new PDFSignatureLockFieldAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSignatureLockFieldAction()
public PDFSignatureLockFieldAction()
public: PDFSignatureLockFieldAction();
public:
PDFSignatureLockFieldAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


%%PageItemTitle%% $$Properties$$

PDFSignatureLockFieldAction Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureLockFieldAction Class

For a list of all members of this type, see PDFSignatureLockFieldAction members.

Public Properties
 | Name | Description
Public Property | Fields | Gets or sets the fields to be locked.
Public Property | SignatureLockFieldMode | Gets or sets the mode for applying the field lock.
Top
See Also

Reference

PDFSignatureLockFieldAction Class
O2S.Components.PDF4NET.Forms Namespace


Fields Property (PDFSignatureLockFieldAction)

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureLockFieldAction Class : Fields Property
Gets or sets the fields to be locked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fields As String()
'Usage

Dim instance As PDFSignatureLockFieldAction
Dim value() As String

instance.Fields = value

value = instance.Fields
public string[] Fields {get; set;}
public: __property string*[]* get_Fields();
public: __property void set_Fields(
   string*[]* value
);
public:
property array<String^>^ Fields {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

The list of fields to be locked when the signature lock is applied.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


SignatureLockFieldMode Property

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureLockFieldAction Class : SignatureLockFieldMode Property
Gets or sets the mode for applying the field lock.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SignatureLockFieldMode As PDFSignatureLockFieldMode
'Usage

Dim instance As PDFSignatureLockFieldAction
Dim value As PDFSignatureLockFieldMode

instance.SignatureLockFieldMode = value

value = instance.SignatureLockFieldMode
public PDFSignatureLockFieldMode SignatureLockFieldMode {get; set;}
public: __property PDFSignatureLockFieldMode get_SignatureLockFieldMode();
public: __property void set_SignatureLockFieldMode(
   PDFSignatureLockFieldMode value
);
public:
property PDFSignatureLockFieldMode SignatureLockFieldMode {
   PDFSignatureLockFieldMode get();
   void set (    PDFSignatureLockFieldMode value);
}

Property Value

A value which, in conjunction with Fields, indicates the set of fields that should be locked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


%%PageItemTitle%%

PDFSignatureWidget Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureWidget Class
Defines the widget for a signature field.
Object Model
PDFSignatureWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSignatureWidget
   Inherits PDFFieldWidget
'Usage

Dim instance As PDFSignatureWidget
public class PDFSignatureWidget : PDFFieldWidget
public __gc class PDFSignatureWidget : public PDFFieldWidget
public ref class PDFSignatureWidget : public PDFFieldWidget
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFSignatureWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureWidget Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFSignatureWidget Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureWidget Class

The following tables list the members exposed by PDFSignatureWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFSignatureWidget Constructor | Initializes a new PDFSignatureWidget object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureWidget Class : PDFSignatureWidget Constructor
Initializes a new PDFSignatureWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSignatureWidget()
public PDFSignatureWidget()
public: PDFSignatureWidget();
public:
PDFSignatureWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureWidget Class
PDFSignatureWidget Members


%%PageItemTitle%%

PDFTextBoxField Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class
Defines a text box in a PDF form.
Object Model
PDFTextBoxField ClassPDFJavaScriptAction ClassPDFDictionary ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextBoxField
   Inherits PDFField
'Usage

Dim instance As PDFTextBoxField
public class PDFTextBoxField : PDFField
public __gc class PDFTextBoxField : public PDFField
public ref class PDFTextBoxField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFTextBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFTextBoxField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

The following tables list the members exposed by PDFTextBoxField.

Public Constructors
 | Name | Description
Public Constructor | PDFTextBoxField Constructor | Initializes a new PDFTextBoxField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | CheckSpelling | Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Public Property | Comb | Gets or sets a value indicating whether the field acts like a comb or not.
Public Property | DefaultValue | Gets or sets the field default value.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FileSelect | Gets or sets a value indicating whether the field can be used for selecting a file from disk.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MaxLength | Gets or sets the max length of the text that can be inserted in the field.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Password | Gets or sets a value indicating whether the field is used for entering passwords.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ScrollLongText | Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Public Property | Text | Gets or sets the field text.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFTextBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFTextBoxField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : PDFTextBoxField Constructor
The name of the field.
Initializes a new PDFTextBoxField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFTextBoxField(name)
public PDFTextBoxField(
   string name
)
public: PDFTextBoxField(
   string* name
)
public:
PDFTextBoxField(
   String^ name
)

Parameters

name
The name of the field.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the name is null or empty or not a valid PDF field name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%% $$Properties$$

PDFTextBoxField Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

For a list of all members of this type, see PDFTextBoxField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | CheckSpelling | Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Public Property | Comb | Gets or sets a value indicating whether the field acts like a comb or not.
Public Property | DefaultValue | Gets or sets the field default value.
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FileSelect | Gets or sets a value indicating whether the field can be used for selecting a file from disk.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MaxLength | Gets or sets the max length of the text that can be inserted in the field.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Password | Gets or sets a value indicating whether the field is used for entering passwords.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ScrollLongText | Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Public Property | Text | Gets or sets the field text.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFTextBoxField Class
O2S.Components.PDF4NET.Forms Namespace


CheckSpelling Property (PDFTextBoxField)

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : CheckSpelling Property
Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckSpelling As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.CheckSpelling = value

value = instance.CheckSpelling
public bool CheckSpelling {get; set;}
public: __property bool get_CheckSpelling();
public: __property void set_CheckSpelling(
   bool value
);
public:
property bool CheckSpelling {
   bool get();
   void set (    bool value);
}

Property Value

True if the field content should be checked for spelling erorrs, false otherwise. Default is true.
Remarks
The field content is checked for spelling errors only when the PDF file is opened in the viewer (if the PDF viewer support this feature) and it is not spell checked when its value is set from code.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


Comb Property

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Comb Property
Gets or sets a value indicating whether the field acts like a comb or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Comb As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Comb = value

value = instance.Comb
public bool Comb {get; set;}
public: __property bool get_Comb();
public: __property void set_Comb(
   bool value
);
public:
property bool Comb {
   bool get();
   void set (    bool value);
}

Property Value

True if the field acts like a comb, otherwise false. Default is false.
Remarks
If this property is true, the field is automatically divided into as many equally spaced positions, or combs, as the value of MaxLen property and the text is laid out into those combs.
When this property is set to true, the Multiline and Password properties are automatically set to false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


DefaultValue Property

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : DefaultValue Property
Gets or sets the field default value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultValue As String
'Usage

Dim instance As PDFTextBoxField
Dim value As String

instance.DefaultValue = value

value = instance.DefaultValue
public string DefaultValue {get; set;}
public: __property string* get_DefaultValue();
public: __property void set_DefaultValue(
   string* value
);
public:
property String^ DefaultValue {
   String^ get();
   void set (    String^ value);
}

Property Value

The field default value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


FileSelect Property

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : FileSelect Property
Gets or sets a value indicating whether the field can be used for selecting a file from disk.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileSelect As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.FileSelect = value

value = instance.FileSelect
public bool FileSelect {get; set;}
public: __property bool get_FileSelect();
public: __property void set_FileSelect(
   bool value
);
public:
property bool FileSelect {
   bool get();
   void set (    bool value);
}

Property Value

True if the text entered in the field represents the pathname of a file whose contents are to be submitted as the value of the field. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


MaxLength Property

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : MaxLength Property
Gets or sets the max length of the text that can be inserted in the field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxLength As Integer
'Usage

Dim instance As PDFTextBoxField
Dim value As Integer

instance.MaxLength = value

value = instance.MaxLength
public int MaxLength {get; set;}
public: __property int get_MaxLength();
public: __property void set_MaxLength(
   int value
);
public:
property int MaxLength {
   int get();
   void set (    int value);
}

Property Value

Maximum amount of text that can be inserted in the text.
Remarks
If this property is 0, then the text length is unlimited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


Multiline Property (PDFTextBoxField)

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Multiline Property
Gets or sets a value indicating whether the field is multiline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Multiline As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Multiline = value

value = instance.Multiline
public bool Multiline {get; set;}
public: __property bool get_Multiline();
public: __property void set_Multiline(
   bool value
);
public:
property bool Multiline {
   bool get();
   void set (    bool value);
}

Property Value

True if the field is multiline, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


Password Property (PDFTextBoxField)

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Password Property
Gets or sets a value indicating whether the field is used for entering passwords.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Password As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Password = value

value = instance.Password
public bool Password {get; set;}
public: __property bool get_Password();
public: __property void set_Password(
   bool value
);
public:
property bool Password {
   bool get();
   void set (    bool value);
}

Property Value

True if the field is a password field, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


ScrollLongText Property

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : ScrollLongText Property
Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScrollLongText As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.ScrollLongText = value

value = instance.ScrollLongText
public bool ScrollLongText {get; set;}
public: __property bool get_ScrollLongText();
public: __property void set_ScrollLongText(
   bool value
);
public:
property bool ScrollLongText {
   bool get();
   void set (    bool value);
}

Property Value

True if the field content can be scrolled, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


Text Property (PDFTextBoxField)

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Text Property
Gets or sets the field text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As PDFTextBoxField
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

The text content of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

PDFTextBoxWidget Class
Members

O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxWidget Class
Defines the widget for a textbox field.
Object Model
PDFTextBoxWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFDeviceColor ClassPDFDictionary ClassDisplayRectangle ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRectangle ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextBoxWidget
   Inherits PDFFieldWidget
'Usage

Dim instance As PDFTextBoxWidget
public class PDFTextBoxWidget : PDFFieldWidget
public __gc class PDFTextBoxWidget : public PDFFieldWidget
public ref class PDFTextBoxWidget : public PDFFieldWidget
Remarks
The field widget is the field's visual representation on a PDF page. A textbox field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFTextBoxWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxWidget Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFTextBoxWidget Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxWidget Class

The following tables list the members exposed by PDFTextBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFTextBoxWidget Constructor | Initializes a new PDFTextBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFTextBoxWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxWidget Class : PDFTextBoxWidget Constructor
Initializes a new PDFTextBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFTextBoxWidget()
public PDFTextBoxWidget()
public: PDFTextBoxWidget();
public:
PDFTextBoxWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxWidget Class
PDFTextBoxWidget Members


%%PageItemTitle%% $$Properties$$

PDFTextBoxWidget Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxWidget Class

For a list of all members of this type, see PDFTextBoxWidget members.

Public Properties
 | Name | Description
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


Align Property (PDFTextBoxWidget)

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxWidget Class : Align Property
Gets or sets the text alignment in a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Align As PDFFieldTextAlign
'Usage

Dim instance As PDFTextBoxWidget
Dim value As PDFFieldTextAlign

instance.Align = value

value = instance.Align
public PDFFieldTextAlign Align {get; set;}
public: __property PDFFieldTextAlign get_Align();
public: __property void set_Align(
   PDFFieldTextAlign value
);
public:
property PDFFieldTextAlign Align {
   PDFFieldTextAlign get();
   void set (    PDFFieldTextAlign value);
}

Property Value

A PDFFieldTextAlign enumeration member specifying the text alignment in a field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxWidget Class
PDFTextBoxWidget Members


%%PageItemTitle%%

XFDFField Class
Members

O2S.Components.PDF4NET.Forms Namespace : XFDFField Class
Defines a field in a XFDF document.
Object Model
XFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class XFDFField
'Usage

Dim instance As XFDFField
public sealed class XFDFField
public __gc __sealed class XFDFField
public ref class XFDFField sealed
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFDFField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFField Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

XFDFField Class Members
Properties

O2S.Components.PDF4NET.Forms Namespace : XFDFField Class

The following tables list the members exposed by XFDFField.

Public Properties
 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top
See Also

Reference

XFDFField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

XFDFField Class Properties

O2S.Components.PDF4NET.Forms Namespace : XFDFField Class

For a list of all members of this type, see XFDFField members.

Public Properties
 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top
See Also

Reference

XFDFField Class
O2S.Components.PDF4NET.Forms Namespace


Name Property (XFDFField)

O2S.Components.PDF4NET.Forms Namespace > XFDFField Class : Name Property
Gets the field name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As XFDFField
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

A string value specifying the name of the XFDF field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFField Class
XFDFField Members


Value Property (XFDFField)

O2S.Components.PDF4NET.Forms Namespace > XFDFField Class : Value Property
Gets the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As String
'Usage

Dim instance As XFDFField
Dim value As String

value = instance.Value
public string Value {get;}
public: __property string* get_Value();
public:
property String^ Value {
   String^ get();
}

Property Value

A string value specifying the value of the XFDF field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFField Class
XFDFField Members


%%PageItemTitle%%

XFDFFieldCollection Class
Members

O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class
Defines a collection of fields in a XFDF document.
Object Model
XFDFFieldCollection ClassXFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class XFDFFieldCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of XFDFField,XFDFFile)
'Usage

Dim instance As XFDFFieldCollection
public sealed class XFDFFieldCollection : O2S.Components.PDF4NET.PDFCollection<XFDFField,XFDFFile>
public __gc __sealed class XFDFFieldCollection : public O2S.Components.PDF4NET.PDFCollection<XFDFField,XFDFFile>
public ref class XFDFFieldCollection sealed : public O2S.Components.PDF4NET.PDFCollection<XFDFField,XFDFFile>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Forms.XFDFFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFieldCollection Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

XFDFFieldCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

The following tables list the members exposed by XFDFFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top
See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

XFDFFile Class
Members

O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class
Represents a XFDF file on disk.
Object Model
XFDFFile ClassXFDFFieldCollection ClassXFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFDFFile
'Usage

Dim instance As XFDFFile
public class XFDFFile
public __gc class XFDFFile
public ref class XFDFFile
Remarks
This class defines an existing XFDF file.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFDFFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Members
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

XFDFFile Class Members
Properties Methods

O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

The following tables list the members exposed by XFDFFile.

Public Properties
 | Name | Description
Public Property | Fields | Gets the list of fields in the XFDF file.
Public Property | PDFFileName | Gets the name of the PDF file the XFDF file was exported from.
Top
Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a XFDFFile object from the given XFDF file.
static (Shared in Visual Basic) | FromStream | Creates a XFDFFile object from the given stream object.
Top
See Also

Reference

XFDFFile Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

XFDFFile Class Methods

O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

For a list of all members of this type, see XFDFFile members.

Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a XFDFFile object from the given XFDF file.
static (Shared in Visual Basic) | FromStream | Creates a XFDFFile object from the given stream object.
Top
See Also

Reference

XFDFFile Class
O2S.Components.PDF4NET.Forms Namespace


Close Method (XFDFFile)

O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : Close Method
Closes the underlying pdf file and frees all resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As XFDFFile

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


FromFile Method (XFDFFile)

O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : FromFile Method
the full path to a XFDF file used as source for this XFDFFile object.
Creates a XFDFFile object from the given XFDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromFile( _
   ByVal fileName As String _
) As XFDFFile
'Usage

Dim fileName As String
Dim value As XFDFFile

value = XFDFFile.FromFile(fileName)
public static XFDFFile FromFile(
   string fileName
)
public: static XFDFFile* FromFile(
   string* fileName
)
public:
static XFDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a XFDF file used as source for this XFDFFile object.

Return Value

A XFDFFile object created based on the given XFDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


FromStream(Stream) Method

O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : FromStream(Stream) Method
the stream object used as source for this XFDFFile object.
Creates a XFDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromStream( _
   ByVal stream As Stream _
) As XFDFFile
'Usage

Dim stream As Stream
Dim value As XFDFFile

value = XFDFFile.FromStream(stream)
public static XFDFFile FromStream(
   Stream stream
)
public: static XFDFFile* FromStream(
   Stream* stream
)
public:
static XFDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this XFDFFile object.

Return Value

A XFDFFile object created based on the given stream object.
Remarks
The stream must contain a valid XFDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


%%PageItemTitle%% $$Properties$$

XFDFFile Class Properties

O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

For a list of all members of this type, see XFDFFile members.

Public Properties
 | Name | Description
Public Property | Fields | Gets the list of fields in the XFDF file.
Public Property | PDFFileName | Gets the name of the PDF file the XFDF file was exported from.
Top
See Also

Reference

XFDFFile Class
O2S.Components.PDF4NET.Forms Namespace


Fields Property (XFDFFile)

O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : Fields Property
Gets the list of fields in the XFDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As XFDFFieldCollection
'Usage

Dim instance As XFDFFile
Dim value As XFDFFieldCollection

value = instance.Fields
public XFDFFieldCollection Fields {get;}
public: __property XFDFFieldCollection* get_Fields();
public:
property XFDFFieldCollection^ Fields {
   XFDFFieldCollection^ get();
}

Property Value

A XFDFFieldCollection object specifying the list of fields in the XFDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


PDFFileName Property (XFDFFile)

O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : PDFFileName Property
Gets the name of the PDF file the XFDF file was exported from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PDFFileName As String
'Usage

Dim instance As XFDFFile
Dim value As String

value = instance.PDFFileName
public string PDFFileName {get;}
public: __property string* get_PDFFileName();
public:
property String^ PDFFileName {
   String^ get();
}

Property Value

A string value specifying the the name of the PDF file the XFDF file was exported from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


%%PageItemTitle%%

PDFCheckSymbolStyle Enumeration

O2S.Components.PDF4NET.Forms Namespace : PDFCheckSymbolStyle Enumeration
Specifies the available style for a check box and radio button items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFCheckSymbolStyle
   Inherits System.Enum
'Usage

Dim instance As PDFCheckSymbolStyle
public enum PDFCheckSymbolStyle : System.Enum
__value public enum PDFCheckSymbolStyle : public System.Enum
public enum class PDFCheckSymbolStyle : public System.Enum
Members
Member | Description
Check | A check mark is used for the checked state.
Circle | A circle is used for the checked state.
Cross | A cross is used for the checked state.
Cross2 | A cross is used for the checked state.
Cross3 | A cross is used for the checked state.
Custom | The appearance of the check box is created from code.
Diamond | A diamond symbol is used for the checked state.
Square | A square is used for the checked state.
Star | A star is used for the checked state.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFCheckSymbolStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFExportDataOptions Enumeration

O2S.Components.PDF4NET.Forms Namespace : PDFExportDataOptions Enumeration
Specifies the available export options for PDF forms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PDFExportDataOptions
   Inherits System.Enum
'Usage

Dim instance As PDFExportDataOptions
[Flags()]
public enum PDFExportDataOptions : System.Enum
[Flags()]
__value public enum PDFExportDataOptions : public System.Enum
[Flags()]
public enum class PDFExportDataOptions : public System.Enum
Members
Member | Description
FormData | Form data is exported from the PDF document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFExportDataOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldTextAlign Enumeration

O2S.Components.PDF4NET.Forms Namespace : PDFFieldTextAlign Enumeration
Specifies the available alignments for text in a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFieldTextAlign
   Inherits System.Enum
'Usage

Dim instance As PDFFieldTextAlign
public enum PDFFieldTextAlign : System.Enum
__value public enum PDFFieldTextAlign : public System.Enum
public enum class PDFFieldTextAlign : public System.Enum
Members
Member | Description
Center | The text is center aligned
Left | The text is left aligned
Right | The text is right aligned
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFFieldTextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldType Enumeration

O2S.Components.PDF4NET.Forms Namespace : PDFFieldType Enumeration
Specifies the available field types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFieldType
   Inherits System.Enum
'Usage

Dim instance As PDFFieldType
public enum PDFFieldType : System.Enum
__value public enum PDFFieldType : public System.Enum
public enum class PDFFieldType : public System.Enum
Members
Member | Description
CheckBox | Check box.
DropDownList | Combobox.
ListBox | List box.
PushButton | Push button.
RadioButton | Radio button list.
Signature | Signature field.
TextBox | Text box.
Unknown | Unknown.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFFieldType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldWidgetVisibilityStatus Enumeration

O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetVisibilityStatus Enumeration
Specifies the available visibility states for a field widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFieldWidgetVisibilityStatus
   Inherits System.Enum
'Usage

Dim instance As PDFFieldWidgetVisibilityStatus
public enum PDFFieldWidgetVisibilityStatus : System.Enum
__value public enum PDFFieldWidgetVisibilityStatus : public System.Enum
public enum class PDFFieldWidgetVisibilityStatus : public System.Enum
Members
Member | Description
Hidden | The field widget is not visible on the page.
HiddenPrintable | The field widget is not visible on the page but it prints.
Visible | The field widget is visible on the page.
VisibleNonPrintable | The field widget is visible on the page but it does not print.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFFieldWidgetVisibilityStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFFormDataFormat Enumeration

O2S.Components.PDF4NET.Forms Namespace : PDFFormDataFormat Enumeration
Specifies the available formats for data import/export for AcroForms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFormDataFormat
   Inherits System.Enum
'Usage

Dim instance As PDFFormDataFormat
public enum PDFFormDataFormat : System.Enum
__value public enum PDFFormDataFormat : public System.Enum
public enum class PDFFormDataFormat : public System.Enum
Members
Member | Description
FDF | Form data is imported or exported in FDF format.
XFDF | Form data is imported or exported in XFDF format.
XML | Form data is imported or exported in XML format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFFormDataFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonHighlightMode Enumeration

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonHighlightMode Enumeration
Specifies the available highlighting modes for a button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPushButtonHighlightMode
   Inherits System.Enum
'Usage

Dim instance As PDFPushButtonHighlightMode
public enum PDFPushButtonHighlightMode : System.Enum
__value public enum PDFPushButtonHighlightMode : public System.Enum
public enum class PDFPushButtonHighlightMode : public System.Enum
Members
Member | Description
Invert | Inverts the content of button's normal appearance. Rollover and down button appearances are ignored.
None | No highlighting, the button's appearance does not change when the button is pressed. Rollover and down button appearances are ignored.
Outline | Inverts the button's border. Rollover and down button appearances are ignored.
Push | Displays the button's down appearance. Rollover appearance has also effect on this mode. When this mode is used, both rollover and down appearances must be constructed from code.
Remarks
The highlight mode defines how the button's down appearance is created when the button is pressed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFPushButtonHighlightMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonIconLayoutMode Enumeration

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonIconLayoutMode Enumeration
Specifies the available modes for displaying the icon on a pushbutton.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPushButtonIconLayoutMode
   Inherits System.Enum
'Usage

Dim instance As PDFPushButtonIconLayoutMode
public enum PDFPushButtonIconLayoutMode : System.Enum
__value public enum PDFPushButtonIconLayoutMode : public System.Enum
public enum class PDFPushButtonIconLayoutMode : public System.Enum
Members
Member | Description
IconBottom | The caption is displayed above the icon.
IconLeft | The icon is displayed to the left of the caption.
IconOnly | Only the icon is displayed, the caption is not displayed.
IconOverlay | The caption is overlaid directly on the icon.
IconRight | The icon is displayed to the right of the caption.
IconTop | The caption is displayed below the icon.
NoIcon | The icon is not displayed, only the caption is displayed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFPushButtonIconLayoutMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureLockFieldMode Enumeration

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureLockFieldMode Enumeration
Specifies the available lock modes for form fields when a signature lock is applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFSignatureLockFieldMode
   Inherits System.Enum
'Usage

Dim instance As PDFSignatureLockFieldMode
public enum PDFSignatureLockFieldMode : System.Enum
__value public enum PDFSignatureLockFieldMode : public System.Enum
public enum class PDFSignatureLockFieldMode : public System.Enum
Members
Member | Description
All | All fields in the form are locked.
Exclude | All the form fields are locked excepting the specified fields.
Include | Only the specified fields are locked.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFSignatureLockFieldMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


O2S.Components.PDF4NET.Forms.XFA Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | XFAArea | Defines a XFA area.
Class | XFAAreaCollection | Defines a collection of XFA areas.
Class | XFABarcodeField | Defines a XFA barcode field.
Class | XFABasicContainer | Defines a basic XFA container.
Class | XFAButtonField | Defines a XFA button field.
Class | XFACheckButtonField | Defines a XFA check button field.
Class | XFAChoiceListField | Defines a XFA choice list field.
Class | XFADateTimeEditField | Defines a XFA date/time edit field.
Class | XFAElement | Defines the base class for all elements in a XFA form.
Class | XFAExtendedContainer | Defines an extended XFA container.
Class | XFAField | Defines a XFA field.
Class | XFAFieldCollection | Defines a collection of XFA fields.
Class | XFAFieldImportError | Represents an error that happened during the import of a XML file.
Class | XFAForm | Defines a document level XFA form.
Class | XFAHttpSubmitButtonField | Defines a XFA button field that submits the form data to a server using HTTP protocol.
Class | XFAImageEditField | Defines a XFA image edit field.
Class | XFAListItem | Defines an item in a choice list.
Class | XFAListItemCollection | Defines a collection of fields in a FDF document.
Class | XFANumericEditField | Defines a XFA numeric edit field.
Class | XFAPageArea | Defines a XFA page area.
Class | XFAPageAreaCollection | Defines a collection of XFA page areas.
Class | XFAPageSet | Defines a XFA page set.
Class | XFAPageSetCollection | Defines a collection of XFA page sets.
Class | XFAPasswordEditField | Defines a XFA password edit field.
Class | XFARadioButtonField | Defines a XFA radio button field.
Class | XFARadioButtonFieldCollection | Defines a collection of exclusive radio buttons.
Class | XFARadioButtonListField | Defines a XFA radio buttons list field.
Class | XFASubform | Defines a XFA subform.
Class | XFASubformCollection | Defines a collection of XFA subforms.
Class | XFATextEditField | Defines a XFA text edit field.
Enumerations
 | Enumeration | Description
Enumeration | XFABarcodeType | Specifies the available barcode types for displaying field content.
Enumeration | XFACheckButtonState | Specifies the available states for a checkbutton and radiobutton.
Enumeration | XFAChoiceListDisplayMode | Specifies the modes for presenting the drop down choice list in interactive applications.
Enumeration | XFAContentAccess | Specifies the access modes to the content of a container.
Enumeration | XFAContentType | Specifies the available types of content accepted by a XFA value.
Enumeration | XFAContentVisibility | Specifies the visibility of the content of a container.
Enumeration | XFADataFormat | Specifies the available formats for data import/export for XFA Forms.
Enumeration | XFAImageAspect | Specifies the available modes for scaling the image when it is displayed in the image edit field.
Enumeration | XFAImageStorageMode | Specifies the available modes for storing image content in an image edit field.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

XFAArea Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAArea Class
Defines a XFA area.
Object Model
XFAArea ClassXFAAreaCollection ClassXFAArea ClassXFAFieldCollection ClassXFAField ClassXFASubformCollection ClassXFASubform Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAArea
   Inherits XFAExtendedContainer
'Usage

Dim instance As XFAArea
public class XFAArea : XFAExtendedContainer
public __gc class XFAArea : public XFAExtendedContainer
public ref class XFAArea : public XFAExtendedContainer
Remarks
A XFA area is a container representing a geographical grouping of other containers.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAArea Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAArea Class Members
Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAArea Class

The following tables list the members exposed by XFAArea.

Public Properties
 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Top
See Also

Reference

XFAArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAAreaCollection Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class
Defines a collection of XFA areas.
Object Model
XFAAreaCollection ClassXFAArea Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class XFAAreaCollection
'Usage

Dim instance As XFAAreaCollection
[DefaultMember("Item")]
public class XFAAreaCollection
[DefaultMember("Item")]
public __gc class XFAAreaCollection
[DefaultMember("Item")]
public ref class XFAAreaCollection
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAAreaCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAAreaCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAAreaCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

The following tables list the members exposed by XFAAreaCollection.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the area at the specified index (zero based index).
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFAAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAAreaCollection Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

For a list of all members of this type, see XFAAreaCollection members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFAAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method (XFAAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : GetEnumerator Method
Returns an enumerator that can iterate through a collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As XFAAreaCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


MoveNext Method (XFAAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : MoveNext Method
Advances the enumerator to the next element of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As XFAAreaCollection
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


Reset Method (XFAAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Reset Method
Sets the enumerator to its initial position, which is before the first element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As XFAAreaCollection

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


%%PageItemTitle%% $$Properties$$

XFAAreaCollection Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

For a list of all members of this type, see XFAAreaCollection members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the area at the specified index (zero based index).
Top
See Also

Reference

XFAAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property (XFAAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Count Property
Returns the number of items in the collection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As XFAAreaCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


Current Property (XFAAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Current Property
Gets the current element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Current As Object
'Usage

Dim instance As XFAAreaCollection
Dim value As Object

value = instance.Current
public object Current {get;}
public: __property Object* get_Current();
public:
property Object^ Current {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


Item Property (XFAAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Item Property
Gets the area at the specified index (zero based index).
Overload List
Overload | Description
Item(Int32) | Gets the area at the specified index (zero based index).
Item(String) | Gets the area with the given name.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


Item(Int32) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class > Item Property : Item(Int32) Property
Gets the area at the specified index (zero based index).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAArea
'Usage

Dim instance As XFAAreaCollection
Dim index As Integer
Dim value As XFAArea

value = instance.Item(index)
public XFAArea Item(
   int index
) {get;}
public: __property XFAArea* get_Item(
   int index
);
public:
property XFAArea^ Item {
   XFAArea^ get(int index);
}

Parameters

index
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members
Overload List


Item(String) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class > Item Property : Item(String) Property
Gets the area with the given name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As XFAArea
'Usage

Dim instance As XFAAreaCollection
Dim name As String
Dim value As XFAArea

value = instance.Item(name)
public XFAArea Item(
   string name
) {get;}
public: __property XFAArea* get_Item(
   string* name
);
public:
property XFAArea^ Item {
   XFAArea^ get(String^ name);
}

Parameters

name
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members
Overload List


%%PageItemTitle%%

XFABarcodeField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class
Defines a XFA barcode field.
Object Model
XFABarcodeField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFABarcodeField
   Inherits XFAField
'Usage

Dim instance As XFABarcodeField
public class XFABarcodeField : XFAField
public __gc class XFABarcodeField : public XFAField
public ref class XFABarcodeField : public XFAField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFABarcodeField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFABarcodeField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class

The following tables list the members exposed by XFABarcodeField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Data | Gets or sets the barcode data.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Type | Gets the type of the barcode used by this field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFABarcodeField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFABarcodeField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class

For a list of all members of this type, see XFABarcodeField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Data | Gets or sets the barcode data.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Type | Gets the type of the barcode used by this field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFABarcodeField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Data Property (XFABarcodeField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFABarcodeField Class : Data Property
Gets or sets the barcode data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Data As String
'Usage

Dim instance As XFABarcodeField
Dim value As String

instance.Data = value

value = instance.Data
public string Data {get; set;}
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
public:
property String^ Data {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the text to be displayed as barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFABarcodeField Class
XFABarcodeField Members


Type Property (XFABarcodeField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFABarcodeField Class : Type Property
Gets the type of the barcode used by this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As XFABarcodeType
'Usage

Dim instance As XFABarcodeField
Dim value As XFABarcodeType

value = instance.Type
public XFABarcodeType Type {get;}
public: __property XFABarcodeType get_Type();
public:
property XFABarcodeType Type {
   XFABarcodeType get();
}

Property Value

A XFABarcodeType enumeration member specifying the type of the barcode used to represent the content of this field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFABarcodeField Class
XFABarcodeField Members


%%PageItemTitle%%

XFABasicContainer Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFABasicContainer Class
Defines a basic XFA container.
Object Model
XFABasicContainer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class XFABasicContainer
   Inherits XFAElement
'Usage

Dim instance As XFABasicContainer
public abstract class XFABasicContainer : XFAElement
public __gc abstract class XFABasicContainer : public XFAElement
public ref class XFABasicContainer abstract : public XFAElement
Remarks
A basic XFA container is an element that can include only other basic containers.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAPageSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFABasicContainer Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFABasicContainer Class Members
Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFABasicContainer Class

The following tables list the members exposed by XFABasicContainer.

Public Properties
 | Name | Description
Public Property | ID | Gets the id of this container.
Public Property | Name | Gets the name of this container.
Top
See Also

Reference

XFABasicContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFABasicContainer Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFABasicContainer Class

For a list of all members of this type, see XFABasicContainer members.

Public Properties
 | Name | Description
Public Property | ID | Gets the id of this container.
Public Property | Name | Gets the name of this container.
Top
See Also

Reference

XFABasicContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


ID Property (XFABasicContainer)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFABasicContainer Class : ID Property
Gets the id of this container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ID As String
'Usage

Dim instance As XFABasicContainer
Dim value As String

value = instance.ID
public string ID {get;}
public: __property string* get_ID();
public:
property String^ ID {
   String^ get();
}

Property Value

A string value specifying the the container identifier.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFABasicContainer Class
XFABasicContainer Members


Name Property (XFABasicContainer)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFABasicContainer Class : Name Property
Gets the name of this container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As XFABasicContainer
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

A string value specifying the the container name.
Remarks
The name is used to locate the container inside the form hierarchy and it is relative to parent container.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFABasicContainer Class
XFABasicContainer Members


%%PageItemTitle%%

XFAButtonField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class
Defines a XFA button field.
Object Model
XFAButtonField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAButtonField
   Inherits XFAField
'Usage

Dim instance As XFAButtonField
public class XFAButtonField : XFAField
public __gc class XFAButtonField : public XFAField
public ref class XFAButtonField : public XFAField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAHttpSubmitButtonField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAButtonField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class

The following tables list the members exposed by XFAButtonField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFACheckButtonField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class
Defines a XFA check button field.
Object Model
XFACheckButtonField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFACheckButtonField
   Inherits XFARadioButtonField
'Usage

Dim instance As XFACheckButtonField
public class XFACheckButtonField : XFARadioButtonField
public __gc class XFACheckButtonField : public XFARadioButtonField
public ref class XFACheckButtonField : public XFARadioButtonField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFACheckButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFACheckButtonField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class

The following tables list the members exposed by XFACheckButtonField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | AllowNeutral | Gets a value indicating whether the check button allows neutral state.
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFACheckButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFACheckButtonField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class

For a list of all members of this type, see XFACheckButtonField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | AllowNeutral | Gets a value indicating whether the check button allows neutral state.
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFACheckButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


AllowNeutral Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFACheckButtonField Class : AllowNeutral Property
Gets a value indicating whether the check button allows neutral state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AllowNeutral As Boolean
'Usage

Dim instance As XFACheckButtonField
Dim value As Boolean

value = instance.AllowNeutral
public bool AllowNeutral {get;}
public: __property bool get_AllowNeutral();
public:
property bool AllowNeutral {
   bool get();
}

Property Value

True if the check button allows neutral state, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFACheckButtonField Class
XFACheckButtonField Members


%%PageItemTitle%%

XFAChoiceListField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class
Defines a XFA choice list field.
Object Model
XFAChoiceListField ClassXFAListItemCollection ClassXFAListItem ClassXFAListItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAChoiceListField
   Inherits XFAField
'Usage

Dim instance As XFAChoiceListField
public class XFAChoiceListField : XFAField
public __gc class XFAChoiceListField : public XFAField
public ref class XFAChoiceListField : public XFAField
Remarks
The field can be either a drop down list or a list box, depending on the DisplayMode property.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAChoiceListField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAChoiceListField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class

The following tables list the members exposed by XFAChoiceListField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | DisplayMode | Gets the display mode of the drop down choice list.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Items | Gets the collection of items in the choice list.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAChoiceListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAChoiceListField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class

For a list of all members of this type, see XFAChoiceListField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | DisplayMode | Gets the display mode of the drop down choice list.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Items | Gets the collection of items in the choice list.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAChoiceListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


DisplayMode Property (XFAChoiceListField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : DisplayMode Property
Gets the display mode of the drop down choice list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayMode As XFAChoiceListDisplayMode
'Usage

Dim instance As XFAChoiceListField
Dim value As XFAChoiceListDisplayMode

value = instance.DisplayMode
public XFAChoiceListDisplayMode DisplayMode {get;}
public: __property XFAChoiceListDisplayMode get_DisplayMode();
public:
property XFAChoiceListDisplayMode DisplayMode {
   XFAChoiceListDisplayMode get();
}

Property Value

A XFAChoiceListDisplayMode enumeration member specifying the display mode of the drop down choice list.
Remarks
If the value of this property is XFAChoiceListDisplayMode.Always or XFAChoiceListDisplayMode.Multiselect, then the choice list is presented as a list box in user interactive applications, otherwise it is presented as a drop down list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


Items Property (XFAChoiceListField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : Items Property
Gets the collection of items in the choice list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Items As XFAListItemCollection
'Usage

Dim instance As XFAChoiceListField
Dim value As XFAListItemCollection

value = instance.Items
public XFAListItemCollection Items {get;}
public: __property XFAListItemCollection* get_Items();
public:
property XFAListItemCollection^ Items {
   XFAListItemCollection^ get();
}

Property Value

A XFAListItemCollection that represents the items in the choice list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


SelectedIndex Property (XFAChoiceListField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : SelectedIndex Property
Gets or sets the lowest ordinal index of the selected items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedIndex As Integer
'Usage

Dim instance As XFAChoiceListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
public int SelectedIndex {get; set;}
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
public:
property int SelectedIndex {
   int get();
   void set (    int value);
}

Property Value

The lowest ordinal index of the selected items in the list. The default is -1, which indicates that nothing is selected.
Remarks
Use this property to determine the index of the currently selected item in the list if the list control allows only one selection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


SelectedItem Property (XFAChoiceListField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : SelectedItem Property
Gets or sets the first selected item in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedItem As XFAListItem
'Usage

Dim instance As XFAChoiceListField
Dim value As XFAListItem

instance.SelectedItem = value

value = instance.SelectedItem
public XFAListItem SelectedItem {get; set;}
public: __property XFAListItem* get_SelectedItem();
public: __property void set_SelectedItem(
   XFAListItem* value
);
public:
property XFAListItem^ SelectedItem {
   XFAListItem^ get();
   void set (    XFAListItem^ value);
}

Property Value

A XFAListItem object specifying the first selected item.
Remarks
If the item to select does not exist in the list, current selection is not changed.
If the item to select is null, then the selection is reset and SelectedIndex property becomes -1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


SelectedValue Property (XFAChoiceListField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : SelectedValue Property
Gets or sets the value of the first selected item in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedValue As String
'Usage

Dim instance As XFAChoiceListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
public string SelectedValue {get; set;}
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
public:
property String^ SelectedValue {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the value of the first selected item, null (Nothing in VB.NET) if there is no selected item.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The value does not exist in field's set of values.
Remarks
When setting the selected value, if the value does not exist in the list, an exception is thrown.
If the value to select is null (Nothing in VB.NET), then the selection is reset and SelectedIndex property becomes -1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


%%PageItemTitle%%

XFADateTimeEditField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class
Defines a XFA date/time edit field.
Object Model
XFADateTimeEditField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFADateTimeEditField
   Inherits XFAField
'Usage

Dim instance As XFADateTimeEditField
public class XFADateTimeEditField : XFAField
public __gc class XFADateTimeEditField : public XFAField
public ref class XFADateTimeEditField : public XFAField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFADateTimeEditField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFADateTimeEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFADateTimeEditField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class

The following tables list the members exposed by XFADateTimeEditField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | DateTimeValue | Gets or sets the date and time.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFADateTimeEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFADateTimeEditField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class

For a list of all members of this type, see XFADateTimeEditField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | DateTimeValue | Gets or sets the date and time.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFADateTimeEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


DateTimeValue Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFADateTimeEditField Class : DateTimeValue Property
Gets or sets the date and time.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeValue As Date
'Usage

Dim instance As XFADateTimeEditField
Dim value As Date

instance.DateTimeValue = value

value = instance.DateTimeValue
public DateTime DateTimeValue {get; set;}
public: __property DateTime get_DateTimeValue();
public: __property void set_DateTimeValue(
   DateTime value
);
public:
property DateTime DateTimeValue {
   DateTime get();
   void set (    DateTime value);
}

Property Value

A System.DateTime value specifying the value of the field.
Remarks
The value of this property is controlled by System.ValueType property.
When System.ValueType property is XFAContentType.Date, only the date part of the System.DateTime value is stored and the time part is set to 12:00:00 AM.
When System.ValueType property is XFAContentType.DateTime, the complete System.DateTime value is stored.
When System.ValueType property is XFAContentType.Time, only the time part of the System.DateTime value is stored and the date part is set to 01 January 0001.
This property returns 01 January 0001 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFADateTimeEditField Class
XFADateTimeEditField Members


%%PageItemTitle%%

XFAElement Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAElement Class
Defines the base class for all elements in a XFA form.
Object Model
XFAElement Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class XFAElement
'Usage

Dim instance As XFAElement
public abstract class XFAElement
public __gc abstract class XFAElement
public ref class XFAElement abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAElement Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAElement Class Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAElement Class

The following tables list the members exposed by XFAElement.

See Also

Reference

XFAElement Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAExtendedContainer Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAExtendedContainer Class
Defines an extended XFA container.
Object Model
XFAExtendedContainer ClassXFAAreaCollection ClassXFAArea ClassXFAFieldCollection ClassXFAField ClassXFASubformCollection ClassXFASubform Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class XFAExtendedContainer
   Inherits XFABasicContainer
'Usage

Dim instance As XFAExtendedContainer
public abstract class XFAExtendedContainer : XFABasicContainer
public __gc abstract class XFAExtendedContainer : public XFABasicContainer
public ref class XFAExtendedContainer abstract : public XFABasicContainer
Remarks
An extended XFA container is an element that can include other containers, both basic and extended, such as subforms, areas and fields.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAArea
O2S.Components.PDF4NET.Forms.XFA.XFAPageArea
O2S.Components.PDF4NET.Forms.XFA.XFASubform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAExtendedContainer Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAExtendedContainer Class Members
Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAExtendedContainer Class

The following tables list the members exposed by XFAExtendedContainer.

Public Properties
 | Name | Description
Public Property | Areas | Gets the list of areas included in this container.
Public Property | Fields | Gets the list of fields included in this container.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container.
Top
See Also

Reference

XFAExtendedContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAExtendedContainer Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAExtendedContainer Class

For a list of all members of this type, see XFAExtendedContainer members.

Public Properties
 | Name | Description
Public Property | Areas | Gets the list of areas included in this container.
Public Property | Fields | Gets the list of fields included in this container.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container.
Top
See Also

Reference

XFAExtendedContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Areas Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAExtendedContainer Class : Areas Property
Gets the list of areas included in this container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Areas As XFAAreaCollection
'Usage

Dim instance As XFAExtendedContainer
Dim value As XFAAreaCollection

value = instance.Areas
public XFAAreaCollection Areas {get;}
public: __property XFAAreaCollection* get_Areas();
public:
property XFAAreaCollection^ Areas {
   XFAAreaCollection^ get();
}

Property Value

A XFAAreaCollection object specifying the list of areas included in this container.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAExtendedContainer Class
XFAExtendedContainer Members


Fields Property (XFAExtendedContainer)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAExtendedContainer Class : Fields Property
Gets the list of fields included in this container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As XFAFieldCollection
'Usage

Dim instance As XFAExtendedContainer
Dim value As XFAFieldCollection

value = instance.Fields
public XFAFieldCollection Fields {get;}
public: __property XFAFieldCollection* get_Fields();
public:
property XFAFieldCollection^ Fields {
   XFAFieldCollection^ get();
}

Property Value

A XFAFieldCollection object specifying the list of fields included in this container.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAExtendedContainer Class
XFAExtendedContainer Members


Subforms Property (XFAExtendedContainer)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAExtendedContainer Class : Subforms Property
Gets the list of subforms included in this container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Subforms As XFASubformCollection
'Usage

Dim instance As XFAExtendedContainer
Dim value As XFASubformCollection

value = instance.Subforms
public XFASubformCollection Subforms {get;}
public: __property XFASubformCollection* get_Subforms();
public:
property XFASubformCollection^ Subforms {
   XFASubformCollection^ get();
}

Property Value

A XFASubformCollection object specifying the list of subforms included in this container.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAExtendedContainer Class
XFAExtendedContainer Members


%%PageItemTitle%%

XFAField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class
Defines a XFA field.
Object Model
XFAField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAField
   Inherits XFABasicContainer
'Usage

Dim instance As XFAField
public class XFAField : XFABasicContainer
public __gc class XFAField : public XFABasicContainer
public ref class XFAField : public XFABasicContainer
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListField
O2S.Components.PDF4NET.Forms.XFA.XFADateTimeEditField
O2S.Components.PDF4NET.Forms.XFA.XFAImageEditField
O2S.Components.PDF4NET.Forms.XFA.XFANumericEditField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonListField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class

The following tables list the members exposed by XFAField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content.
Public Property | BindRef | Gets the explicit data binding string.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field.
Public Property | ValueType | Gets the type of value stored in this field.
Public Property | Visibility | Gets the visibility of the field content.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation.
Top
See Also

Reference

XFAField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class

For a list of all members of this type, see XFAField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation.
Top
See Also

Reference

XFAField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


ToString Method (XFAField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : ToString Method
Converts the field to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As XFAField
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAField Class
XFAField Members


%%PageItemTitle%% $$Properties$$

XFAField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class

For a list of all members of this type, see XFAField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content.
Public Property | BindRef | Gets the explicit data binding string.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field.
Public Property | ValueType | Gets the type of value stored in this field.
Public Property | Visibility | Gets the visibility of the field content.
Top
See Also

Reference

XFAField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Access Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : Access Property
Gets or sets the access mode to field content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Access As XFAContentAccess
'Usage

Dim instance As XFAField
Dim value As XFAContentAccess

instance.Access = value

value = instance.Access
public XFAContentAccess Access {get; set;}
public: __property XFAContentAccess get_Access();
public: __property void set_Access(
   XFAContentAccess value
);
public:
property XFAContentAccess Access {
   XFAContentAccess get();
   void set (    XFAContentAccess value);
}

Property Value

A XFAContentAccess enumeration member specifying the allowed access mode for field content.
Remarks
If this property is XFAContentAccess.Protected or XFAContentAccess.ReadOnly, the field value can not be changed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAField Class
XFAField Members


BindRef Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : BindRef Property
Gets the explicit data binding string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BindRef As String
'Usage

Dim instance As XFAField
Dim value As String

value = instance.BindRef
public string BindRef {get;}
public: __property string* get_BindRef();
public:
property String^ BindRef {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAField Class
XFAField Members


Value Property (XFAField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : Value Property
Gets or sets the value stored in this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Object
'Usage

Dim instance As XFAField
Dim value As Object

instance.Value = value

value = instance.Value
public object Value {get; set;}
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
public:
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}

Property Value

An object that boxes actual value.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the provided value is not supported by the actual field type.
System.ArgumentOutOfRangeException | The value does not exist in field's specific set of values.
Remarks
The values accepted by this property depend on the actual field type. If the actual field does not support the provided value, an exception is raised.
If the field Access is Protected or ReadOnly, the Value can not be changed.
Fields with a fixed range of values (checkboxes, radiobutton lists and choice fields) will throw an exception if the value does not exist in their set of values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAField Class
XFAField Members


ValueType Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : ValueType Property
Gets the type of value stored in this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ValueType As XFAContentType
'Usage

Dim instance As XFAField
Dim value As XFAContentType

value = instance.ValueType
public XFAContentType ValueType {get;}
public: __property XFAContentType get_ValueType();
public:
property XFAContentType ValueType {
   XFAContentType get();
}

Property Value

A XFAContentType enumeration member specifying the type of the value stored in this field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAField Class
XFAField Members


Visibility Property (XFAField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : Visibility Property
Gets the visibility of the field content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Visibility As XFAContentVisibility
'Usage

Dim instance As XFAField
Dim value As XFAContentVisibility

value = instance.Visibility
public XFAContentVisibility Visibility {get;}
public: __property XFAContentVisibility get_Visibility();
public:
property XFAContentVisibility Visibility {
   XFAContentVisibility get();
}

Property Value

A XFAContentVisibility enumeration member specifying the visibility for field content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAField Class
XFAField Members


%%PageItemTitle%%

XFAFieldCollection Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class
Defines a collection of XFA fields.
Object Model
XFAFieldCollection ClassXFAField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class XFAFieldCollection
'Usage

Dim instance As XFAFieldCollection
[DefaultMember("Item")]
public class XFAFieldCollection
[DefaultMember("Item")]
public __gc class XFAFieldCollection
[DefaultMember("Item")]
public ref class XFAFieldCollection
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAFieldCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

The following tables list the members exposed by XFAFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFAFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAFieldCollection Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

For a list of all members of this type, see XFAFieldCollection members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFAFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method (XFAFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : GetEnumerator Method
Returns an enumerator that can iterate through a collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As XFAFieldCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


MoveNext Method (XFAFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : MoveNext Method
Advances the enumerator to the next element of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As XFAFieldCollection
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


Reset Method (XFAFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Reset Method
Sets the enumerator to its initial position, which is before the first element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As XFAFieldCollection

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


%%PageItemTitle%% $$Properties$$

XFAFieldCollection Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

For a list of all members of this type, see XFAFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top
See Also

Reference

XFAFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property (XFAFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Count Property
Returns the number of items in the collection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As XFAFieldCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


Current Property (XFAFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Current Property
Gets the current element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Current As Object
'Usage

Dim instance As XFAFieldCollection
Dim value As Object

value = instance.Current
public object Current {get;}
public: __property Object* get_Current();
public:
property Object^ Current {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


Item Property (XFAFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Item Property
Gets the field at the specified index (zero based index).
Overload List
Overload | Description
Item(Int32) | Gets the field at the specified index (zero based index).
Item(String) | Gets the field with the given name.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


Item(Int32) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class > Item Property : Item(Int32) Property
Gets the field at the specified index (zero based index).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAField
'Usage

Dim instance As XFAFieldCollection
Dim index As Integer
Dim value As XFAField

value = instance.Item(index)
public XFAField Item(
   int index
) {get;}
public: __property XFAField* get_Item(
   int index
);
public:
property XFAField^ Item {
   XFAField^ get(int index);
}

Parameters

index
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members
Overload List


Item(String) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class > Item Property : Item(String) Property
Gets the field with the given name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As XFAField
'Usage

Dim instance As XFAFieldCollection
Dim name As String
Dim value As XFAField

value = instance.Item(name)
public XFAField Item(
   string name
) {get;}
public: __property XFAField* get_Item(
   string* name
);
public:
property XFAField^ Item {
   XFAField^ get(String^ name);
}

Parameters

name
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members
Overload List


%%PageItemTitle%%

XFAFieldImportError Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldImportError Class
Represents an error that happened during the import of a XML file.
Object Model
XFAFieldImportError ClassXFAField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAFieldImportError
'Usage

Dim instance As XFAFieldImportError
public class XFAFieldImportError
public __gc class XFAFieldImportError
public ref class XFAFieldImportError
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAFieldImportError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldImportError Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAFieldImportError Class Members
Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldImportError Class

The following tables list the members exposed by XFAFieldImportError.

Public Properties
 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top
See Also

Reference

XFAFieldImportError Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAFieldImportError Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldImportError Class

For a list of all members of this type, see XFAFieldImportError members.

Public Properties
 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top
See Also

Reference

XFAFieldImportError Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Exception Property (XFAFieldImportError)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldImportError Class : Exception Property
Gets the exception thrown by the field during the import.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Exception As Exception
'Usage

Dim instance As XFAFieldImportError
Dim value As Exception

value = instance.Exception
public Exception Exception {get;}
public: __property Exception* get_Exception();
public:
property Exception^ Exception {
   Exception^ get();
}

Property Value

A Exception object with the details about the import error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldImportError Class
XFAFieldImportError Members


Field Property (XFAFieldImportError)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldImportError Class : Field Property
Gets the field that generated the import error.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As XFAField
'Usage

Dim instance As XFAFieldImportError
Dim value As XFAField

value = instance.Field
public XFAField Field {get;}
public: __property XFAField* get_Field();
public:
property XFAField^ Field {
   XFAField^ get();
}

Property Value

A XFAField object representing the field that generated the error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAFieldImportError Class
XFAFieldImportError Members


%%PageItemTitle%%

XFAForm Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class
Defines a document level XFA form.
Object Model
XFAForm ClassXFASubformCollection ClassXFASubform Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAForm
   Inherits XFAElement
'Usage

Dim instance As XFAForm
public class XFAForm : XFAElement
public __gc class XFAForm : public XFAElement
public ref class XFAForm : public XFAElement
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFAForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAForm Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAForm Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

The following tables list the members exposed by XFAForm.

Public Properties
 | Name | Description
Public Property | ForceRendering | Gets or sets a value indicating whether the XFA form should be regenerated when it is open for the first time.
Public Property | Subforms | Gets the list of subforms included in the form.
Top
Public Methods
 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top
See Also

Reference

XFAForm Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAForm Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

For a list of all members of this type, see XFAForm members.

Public Methods
 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top
See Also

Reference

XFAForm Class
O2S.Components.PDF4NET.Forms.XFA Namespace


ExportData Method (XFAForm)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : ExportData Method
Exports the form data to a file.
Overload List
Overload | Description
ExportData(String,XFADataFormat,PDFExportDataOptions) | Exports the form data to a file.
ExportData(Stream,XFADataFormat,PDFExportDataOptions) | Exports the form data to a stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAForm Class
XFAForm Members


ExportData(String,XFADataFormat,PDFExportDataOptions) Method

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ExportData Method : ExportData(String,XFADataFormat,PDFExportDataOptions) Method
The full path to the file where form data will be exported.
The format of exported data.
Options for specifying the type of data to be exported.
Exports the form data to a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ExportData( _
   ByVal fileName As String, _
   ByVal format As XFADataFormat, _
   ByVal options As PDFExportDataOptions _
)
'Usage

Dim instance As XFAForm
Dim fileName As String
Dim format As XFADataFormat
Dim options As PDFExportDataOptions

instance.ExportData(fileName, format, options)
public void ExportData(
   string fileName,
   XFADataFormat format,
   PDFExportDataOptions options
)
public: void ExportData(
   string* fileName,
   XFADataFormat format,
   PDFExportDataOptions options
)
public:
void ExportData(
   String^ fileName,
   XFADataFormat format,
   PDFExportDataOptions options
)

Parameters

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


ExportData(Stream,XFADataFormat,PDFExportDataOptions) Method

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ExportData Method : ExportData(Stream,XFADataFormat,PDFExportDataOptions) Method
The stream where form data will be exported.
The format of exported data.
Options for specifying the type of data to be exported.
Exports the form data to a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ExportData( _
   ByVal stream As Stream, _
   ByVal format As XFADataFormat, _
   ByVal options As PDFExportDataOptions _
)
'Usage

Dim instance As XFAForm
Dim stream As Stream
Dim format As XFADataFormat
Dim options As PDFExportDataOptions

instance.ExportData(stream, format, options)
public void ExportData(
   Stream stream,
   XFADataFormat format,
   PDFExportDataOptions options
)
public: void ExportData(
   Stream* stream,
   XFADataFormat format,
   PDFExportDataOptions options
)
public:
void ExportData(
   Stream^ stream,
   XFADataFormat format,
   PDFExportDataOptions options
)

Parameters

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


ImportData Method (XFAForm)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : ImportData Method
Imports form data from an external file.
Overload List
Overload | Description
ImportData(String,XFADataFormat) | Imports form data from an external file.
ImportData(Stream,XFADataFormat) | Imports form data from an external file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAForm Class
XFAForm Members


ImportData(String,XFADataFormat) Method

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ImportData Method : ImportData(String,XFADataFormat) Method
The file from which to import form data.
The format of input file.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As XFADataFormat _
)
'Usage

Dim instance As XFAForm
Dim fileName As String
Dim dataFormat As XFADataFormat

instance.ImportData(fileName, dataFormat)
public void ImportData(
   string fileName,
   XFADataFormat dataFormat
)
public: void ImportData(
   string* fileName,
   XFADataFormat dataFormat
)
public:
void ImportData(
   String^ fileName,
   XFADataFormat dataFormat
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFException | thrown when the input file can not be open or read.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


ImportData(Stream,XFADataFormat) Method

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ImportData Method : ImportData(Stream,XFADataFormat) Method
The stream from which to import form data.
The format of input stream.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As XFADataFormat _
)
'Usage

Dim instance As XFAForm
Dim stream As Stream
Dim dataFormat As XFADataFormat

instance.ImportData(stream, dataFormat)
public void ImportData(
   Stream stream,
   XFADataFormat dataFormat
)
public: void ImportData(
   Stream* stream,
   XFADataFormat dataFormat
)
public:
void ImportData(
   Stream^ stream,
   XFADataFormat dataFormat
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFException | Thrown when the input stream can not be read.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


%%PageItemTitle%% $$Properties$$

XFAForm Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

For a list of all members of this type, see XFAForm members.

Public Properties
 | Name | Description
Public Property | ForceRendering | Gets or sets a value indicating whether the XFA form should be regenerated when it is open for the first time.
Public Property | Subforms | Gets the list of subforms included in the form.
Top
See Also

Reference

XFAForm Class
O2S.Components.PDF4NET.Forms.XFA Namespace


ForceRendering Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : ForceRendering Property
Gets or sets a value indicating whether the XFA form should be regenerated when it is open for the first time.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ForceRendering As Boolean
'Usage

Dim instance As XFAForm
Dim value As Boolean

instance.ForceRendering = value

value = instance.ForceRendering
public bool ForceRendering {get; set;}
public: __property bool get_ForceRendering();
public: __property void set_ForceRendering(
   bool value
);
public:
property bool ForceRendering {
   bool get();
   void set (    bool value);
}

Property Value

True if the XFA form should be regenerated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAForm Class
XFAForm Members


Subforms Property (XFAForm)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : Subforms Property
Gets the list of subforms included in the form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Subforms As XFASubformCollection
'Usage

Dim instance As XFAForm
Dim value As XFASubformCollection

value = instance.Subforms
public XFASubformCollection Subforms {get;}
public: __property XFASubformCollection* get_Subforms();
public:
property XFASubformCollection^ Subforms {
   XFASubformCollection^ get();
}

Property Value

A XFASubformCollection object specifying the list of subforms included in this form.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAForm Class
XFAForm Members


%%PageItemTitle%%

XFAHttpSubmitButtonField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class
Defines a XFA button field that submits the form data to a server using HTTP protocol.
Object Model
XFAHttpSubmitButtonField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAHttpSubmitButtonField
   Inherits XFAButtonField
'Usage

Dim instance As XFAHttpSubmitButtonField
public class XFAHttpSubmitButtonField : XFAButtonField
public __gc class XFAHttpSubmitButtonField : public XFAButtonField
public ref class XFAHttpSubmitButtonField : public XFAButtonField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAHttpSubmitButtonField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAHttpSubmitButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAHttpSubmitButtonField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class

The following tables list the members exposed by XFAHttpSubmitButtonField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Url | Gets or sets the Url where the form data is submitted.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAHttpSubmitButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAHttpSubmitButtonField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class

For a list of all members of this type, see XFAHttpSubmitButtonField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Url | Gets or sets the Url where the form data is submitted.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAHttpSubmitButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Url Property (XFAHttpSubmitButtonField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAHttpSubmitButtonField Class : Url Property
Gets or sets the Url where the form data is submitted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Url As String
'Usage

Dim instance As XFAHttpSubmitButtonField
Dim value As String

instance.Url = value

value = instance.Url
public string Url {get; set;}
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
public:
property String^ Url {
   String^ get();
   void set (    String^ value);
}
Remarks
A string value specifying the HTTP Url where the form data is submitted when the button is clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAHttpSubmitButtonField Class
XFAHttpSubmitButtonField Members


%%PageItemTitle%%

XFAImageEditField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class
Defines a XFA image edit field.
Object Model
XFAImageEditField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAImageEditField
   Inherits XFAField
'Usage

Dim instance As XFAImageEditField
public class XFAImageEditField : XFAField
public __gc class XFAImageEditField : public XFAField
public ref class XFAImageEditField : public XFAField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAImageEditField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAImageEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAImageEditField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class

The following tables list the members exposed by XFAImageEditField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ContentType | Gets or sets the image content type.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | ImageAspect | Gets the scaling mode for the image.
Public Property | ImageData | Gets or sets the image data to be loaded in this field.
Public Property | ImagePath | Gets or sets the path to the image to be loaded in this field.
Public Property | ImageStorageMode | Gets the mode the image is stored in this field.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAImageEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAImageEditField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class

For a list of all members of this type, see XFAImageEditField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ContentType | Gets or sets the image content type.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | ImageAspect | Gets the scaling mode for the image.
Public Property | ImageData | Gets or sets the image data to be loaded in this field.
Public Property | ImagePath | Gets or sets the path to the image to be loaded in this field.
Public Property | ImageStorageMode | Gets the mode the image is stored in this field.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAImageEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


ContentType Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ContentType Property
Gets or sets the image content type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContentType As String
'Usage

Dim instance As XFAImageEditField
Dim value As String

instance.ContentType = value

value = instance.ContentType
public string ContentType {get; set;}
public: __property string* get_ContentType();
public: __property void set_ContentType(
   string* value
);
public:
property String^ ContentType {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the image content type.
Remarks
This property is the MIME-type of the image stored in the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


ImageAspect Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImageAspect Property
Gets the scaling mode for the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageAspect As XFAImageAspect
'Usage

Dim instance As XFAImageEditField
Dim value As XFAImageAspect

value = instance.ImageAspect
public XFAImageAspect ImageAspect {get;}
public: __property XFAImageAspect get_ImageAspect();
public:
property XFAImageAspect ImageAspect {
   XFAImageAspect get();
}

Property Value

A XFAImageAspect enumeration member specifying how the image is scaled when it is displayed in the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


ImageData Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImageData Property
Gets or sets the image data to be loaded in this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageData As Byte()
'Usage

Dim instance As XFAImageEditField
Dim value() As Byte

instance.ImageData = value

value = instance.ImageData
public byte[] ImageData {get; set;}
public: __property byte[]* get_ImageData();
public: __property void set_ImageData(
   byte[]* value
);
public:
property array<byte>^ ImageData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array specifying the image data to be loaded in this field.
Remarks
Only one of ImagePath or ImageData properties can be set. If this property is set, then ImagePath property is set to null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


ImagePath Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImagePath Property
Gets or sets the path to the image to be loaded in this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImagePath As String
'Usage

Dim instance As XFAImageEditField
Dim value As String

instance.ImagePath = value

value = instance.ImagePath
public string ImagePath {get; set;}
public: __property string* get_ImagePath();
public: __property void set_ImagePath(
   string* value
);
public:
property String^ ImagePath {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the path to the image to be loaded in this field.
Remarks
Only one of ImagePath or ImageData properties can be set. If this property is set, then ImageData property is set to null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


ImageStorageMode Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImageStorageMode Property
Gets the mode the image is stored in this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageStorageMode As XFAImageStorageMode
'Usage

Dim instance As XFAImageEditField
Dim value As XFAImageStorageMode

value = instance.ImageStorageMode
public XFAImageStorageMode ImageStorageMode {get;}
public: __property XFAImageStorageMode get_ImageStorageMode();
public:
property XFAImageStorageMode ImageStorageMode {
   XFAImageStorageMode get();
}

Property Value

A ImageStorageMode enumeration member specifying the mode the image is stored in this field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


%%PageItemTitle%%

XFAListItem Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItem Class
Defines an item in a choice list.
Object Model
XFAListItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAListItem
'Usage

Dim instance As XFAListItem
public class XFAListItem
public __gc class XFAListItem
public ref class XFAListItem
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAListItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAListItem Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAListItem Class Members
Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItem Class

The following tables list the members exposed by XFAListItem.

Public Constructors
 | Name | Description
Public Constructor | XFAListItem Constructor | Initializes a new XFAListItem object.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the list item.
Public Property | Value | Gets or sets the value of the list item.
Top
See Also

Reference

XFAListItem Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAListItem Constructor

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItem Class : XFAListItem Constructor
The item name, it is displayed in the list.
The item value, it is exported when form content is exported.
Initializes a new XFAListItem object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal itemName As String, _
   ByVal itemValue As String _
)
'Usage

Dim itemName As String
Dim itemValue As String

Dim instance As New XFAListItem(itemName, itemValue)
public XFAListItem(
   string itemName,
   string itemValue
)
public: XFAListItem(
   string* itemName,
   string* itemValue
)
public:
XFAListItem(
   String^ itemName,
   String^ itemValue
)

Parameters

itemName
The item name, it is displayed in the list.
itemValue
The item value, it is exported when form content is exported.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the item value is null or empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAListItem Class
XFAListItem Members


%%PageItemTitle%% $$Properties$$

XFAListItem Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItem Class

For a list of all members of this type, see XFAListItem members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the list item.
Public Property | Value | Gets or sets the value of the list item.
Top
See Also

Reference

XFAListItem Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Name Property (XFAListItem)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItem Class : Name Property
Gets or sets the name of the list item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As XFAListItem
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the name of the list item.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAListItem Class
XFAListItem Members


Value Property (XFAListItem)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItem Class : Value Property
Gets or sets the value of the list item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As String
'Usage

Dim instance As XFAListItem
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the value of the list item.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAListItem Class
XFAListItem Members


%%PageItemTitle%%

XFAListItemCollection Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class
Defines a collection of fields in a FDF document.
Object Model
XFAListItemCollection ClassXFAListItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAListItemCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of XFAListItem,XFAChoiceListField)
'Usage

Dim instance As XFAListItemCollection
public class XFAListItemCollection : O2S.Components.PDF4NET.PDFCollection<XFAListItem,XFAChoiceListField>
public __gc class XFAListItemCollection : public O2S.Components.PDF4NET.PDFCollection<XFAListItem,XFAChoiceListField>
public ref class XFAListItemCollection : public O2S.Components.PDF4NET.PDFCollection<XFAListItem,XFAChoiceListField>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAListItemCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAListItemCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

The following tables list the members exposed by XFAListItemCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Top
See Also

Reference

XFAListItemCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFANumericEditField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class
Defines a XFA numeric edit field.
Object Model
XFANumericEditField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFANumericEditField
   Inherits XFAField
'Usage

Dim instance As XFANumericEditField
public class XFANumericEditField : XFAField
public __gc class XFANumericEditField : public XFAField
public ref class XFANumericEditField : public XFAField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFANumericEditField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFANumericEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFANumericEditField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class

The following tables list the members exposed by XFANumericEditField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | DecimalValue | Gets or sets the decimal number in this numeric edit field.
Public Property | FloatValue | Gets or sets the float number in this numeric edit field.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | IntValue | Gets or sets the integer number in this numeric edit field.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFANumericEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFANumericEditField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class

For a list of all members of this type, see XFANumericEditField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | DecimalValue | Gets or sets the decimal number in this numeric edit field.
Public Property | FloatValue | Gets or sets the float number in this numeric edit field.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | IntValue | Gets or sets the integer number in this numeric edit field.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFANumericEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


DecimalValue Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFANumericEditField Class : DecimalValue Property
Gets or sets the decimal number in this numeric edit field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DecimalValue As Decimal
'Usage

Dim instance As XFANumericEditField
Dim value As Decimal

instance.DecimalValue = value

value = instance.DecimalValue
public decimal DecimalValue {get; set;}
public: __property decimal get_DecimalValue();
public: __property void set_DecimalValue(
   decimal value
);
public:
property decimal DecimalValue {
   decimal get();
   void set (    decimal value);
}

Property Value

A decimal value specifying the number displayed in the numeric edit field.
Remarks
This property returns 0 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFANumericEditField Class
XFANumericEditField Members


FloatValue Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFANumericEditField Class : FloatValue Property
Gets or sets the float number in this numeric edit field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FloatValue As Double
'Usage

Dim instance As XFANumericEditField
Dim value As Double

instance.FloatValue = value

value = instance.FloatValue
public double FloatValue {get; set;}
public: __property double get_FloatValue();
public: __property void set_FloatValue(
   double value
);
public:
property double FloatValue {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the number displayed in the numeric edit field.
Remarks
This property returns 0 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFANumericEditField Class
XFANumericEditField Members


IntValue Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFANumericEditField Class : IntValue Property
Gets or sets the integer number in this numeric edit field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IntValue As Integer
'Usage

Dim instance As XFANumericEditField
Dim value As Integer

instance.IntValue = value

value = instance.IntValue
public int IntValue {get; set;}
public: __property int get_IntValue();
public: __property void set_IntValue(
   int value
);
public:
property int IntValue {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number displayed in the numeric edit field.
Remarks
This property returns 0 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFANumericEditField Class
XFANumericEditField Members


%%PageItemTitle%%

XFAPageArea Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageArea Class
Defines a XFA page area.
Object Model
XFAPageArea ClassXFAAreaCollection ClassXFAArea ClassXFAFieldCollection ClassXFAField ClassXFASubformCollection ClassXFASubform Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAPageArea
   Inherits XFAExtendedContainer
'Usage

Dim instance As XFAPageArea
public class XFAPageArea : XFAExtendedContainer
public __gc class XFAPageArea : public XFAExtendedContainer
public ref class XFAPageArea : public XFAExtendedContainer
Remarks
A XFA page area is an element that describes a rendering surface.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAPageArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageArea Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPageArea Class Members
Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageArea Class

The following tables list the members exposed by XFAPageArea.

Public Properties
 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Top
See Also

Reference

XFAPageArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAPageAreaCollection Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class
Defines a collection of XFA page areas.
Object Model
XFAPageAreaCollection ClassXFAPageArea Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class XFAPageAreaCollection
'Usage

Dim instance As XFAPageAreaCollection
[DefaultMember("Item")]
public class XFAPageAreaCollection
[DefaultMember("Item")]
public __gc class XFAPageAreaCollection
[DefaultMember("Item")]
public ref class XFAPageAreaCollection
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAPageAreaCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageAreaCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPageAreaCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

The following tables list the members exposed by XFAPageAreaCollection.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page area at the specified index (zero based index).
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFAPageAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAPageAreaCollection Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

For a list of all members of this type, see XFAPageAreaCollection members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFAPageAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method (XFAPageAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : GetEnumerator Method
Returns an enumerator that can iterate through a collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As XFAPageAreaCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


MoveNext Method (XFAPageAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : MoveNext Method
Advances the enumerator to the next element of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As XFAPageAreaCollection
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


Reset Method (XFAPageAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Reset Method
Sets the enumerator to its initial position, which is before the first element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As XFAPageAreaCollection

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


%%PageItemTitle%% $$Properties$$

XFAPageAreaCollection Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

For a list of all members of this type, see XFAPageAreaCollection members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page area at the specified index (zero based index).
Top
See Also

Reference

XFAPageAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property (XFAPageAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Count Property
Returns the number of items in the collection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As XFAPageAreaCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


Current Property (XFAPageAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Current Property
Gets the current element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Current As Object
'Usage

Dim instance As XFAPageAreaCollection
Dim value As Object

value = instance.Current
public object Current {get;}
public: __property Object* get_Current();
public:
property Object^ Current {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


Item Property (XFAPageAreaCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Item Property
Gets the page area at the specified index (zero based index).
Overload List
Overload | Description
Item(Int32) | Gets the page area at the specified index (zero based index).
Item(String) | Gets the page area with the given name.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


Item(Int32) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class > Item Property : Item(Int32) Property
Gets the page area at the specified index (zero based index).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAPageArea
'Usage

Dim instance As XFAPageAreaCollection
Dim index As Integer
Dim value As XFAPageArea

value = instance.Item(index)
public XFAPageArea Item(
   int index
) {get;}
public: __property XFAPageArea* get_Item(
   int index
);
public:
property XFAPageArea^ Item {
   XFAPageArea^ get(int index);
}

Parameters

index
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members
Overload List


Item(String) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class > Item Property : Item(String) Property
Gets the page area with the given name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As XFAPageArea
'Usage

Dim instance As XFAPageAreaCollection
Dim name As String
Dim value As XFAPageArea

value = instance.Item(name)
public XFAPageArea Item(
   string name
) {get;}
public: __property XFAPageArea* get_Item(
   string* name
);
public:
property XFAPageArea^ Item {
   XFAPageArea^ get(String^ name);
}

Parameters

name
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members
Overload List


%%PageItemTitle%%

XFAPageSet Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSet Class
Defines a XFA page set.
Object Model
XFAPageSet ClassXFAPageAreaCollection ClassXFAPageArea ClassXFAPageSetCollection ClassXFAPageSet Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAPageSet
   Inherits XFABasicContainer
'Usage

Dim instance As XFAPageSet
public class XFAPageSet : XFABasicContainer
public __gc class XFAPageSet : public XFABasicContainer
public ref class XFAPageSet : public XFABasicContainer
Remarks
A page set describes a set of related page areas.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAPageSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSet Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPageSet Class Members
Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSet Class

The following tables list the members exposed by XFAPageSet.

Public Properties
 | Name | Description
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | PageAreas | Gets the list of page areas included in this page set.
Public Property | PageSets | Gets the list of page sets included in this page set.
Top
See Also

Reference

XFAPageSet Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAPageSet Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSet Class

For a list of all members of this type, see XFAPageSet members.

Public Properties
 | Name | Description
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | PageAreas | Gets the list of page areas included in this page set.
Public Property | PageSets | Gets the list of page sets included in this page set.
Top
See Also

Reference

XFAPageSet Class
O2S.Components.PDF4NET.Forms.XFA Namespace


PageAreas Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSet Class : PageAreas Property
Gets the list of page areas included in this page set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageAreas As XFAPageAreaCollection
'Usage

Dim instance As XFAPageSet
Dim value As XFAPageAreaCollection

value = instance.PageAreas
public XFAPageAreaCollection PageAreas {get;}
public: __property XFAPageAreaCollection* get_PageAreas();
public:
property XFAPageAreaCollection^ PageAreas {
   XFAPageAreaCollection^ get();
}

Property Value

A XFAPageAreaCollection object specifying the list of areas included in this container.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSet Class
XFAPageSet Members


PageSets Property (XFAPageSet)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSet Class : PageSets Property
Gets the list of page sets included in this page set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageSets As XFAPageSetCollection
'Usage

Dim instance As XFAPageSet
Dim value As XFAPageSetCollection

value = instance.PageSets
public XFAPageSetCollection PageSets {get;}
public: __property XFAPageSetCollection* get_PageSets();
public:
property XFAPageSetCollection^ PageSets {
   XFAPageSetCollection^ get();
}

Property Value

A XFAPageSetCollection object specifying the list of page sets included in this page set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSet Class
XFAPageSet Members


%%PageItemTitle%%

XFAPageSetCollection Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class
Defines a collection of XFA page sets.
Object Model
XFAPageSetCollection ClassXFAPageSet Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class XFAPageSetCollection
'Usage

Dim instance As XFAPageSetCollection
[DefaultMember("Item")]
public class XFAPageSetCollection
[DefaultMember("Item")]
public __gc class XFAPageSetCollection
[DefaultMember("Item")]
public ref class XFAPageSetCollection
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAPageSetCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSetCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPageSetCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

The following tables list the members exposed by XFAPageSetCollection.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page set at the specified index (zero based index).
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFAPageSetCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAPageSetCollection Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

For a list of all members of this type, see XFAPageSetCollection members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFAPageSetCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method (XFAPageSetCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : GetEnumerator Method
Returns an enumerator that can iterate through a collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As XFAPageSetCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


MoveNext Method (XFAPageSetCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : MoveNext Method
Advances the enumerator to the next element of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As XFAPageSetCollection
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


Reset Method (XFAPageSetCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Reset Method
Sets the enumerator to its initial position, which is before the first element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As XFAPageSetCollection

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


%%PageItemTitle%% $$Properties$$

XFAPageSetCollection Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

For a list of all members of this type, see XFAPageSetCollection members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page set at the specified index (zero based index).
Top
See Also

Reference

XFAPageSetCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property (XFAPageSetCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Count Property
Returns the number of items in the collection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As XFAPageSetCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


Current Property (XFAPageSetCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Current Property
Gets the current element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Current As Object
'Usage

Dim instance As XFAPageSetCollection
Dim value As Object

value = instance.Current
public object Current {get;}
public: __property Object* get_Current();
public:
property Object^ Current {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


Item Property (XFAPageSetCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Item Property
Gets the page set at the specified index (zero based index).
Overload List
Overload | Description
Item(Int32) | Gets the page set at the specified index (zero based index).
Item(String) | Gets the page set with the given name.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


Item(Int32) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class > Item Property : Item(Int32) Property
Gets the page set at the specified index (zero based index).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAPageSet
'Usage

Dim instance As XFAPageSetCollection
Dim index As Integer
Dim value As XFAPageSet

value = instance.Item(index)
public XFAPageSet Item(
   int index
) {get;}
public: __property XFAPageSet* get_Item(
   int index
);
public:
property XFAPageSet^ Item {
   XFAPageSet^ get(int index);
}

Parameters

index
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members
Overload List


Item(String) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class > Item Property : Item(String) Property
Gets the page set with the given name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As XFAPageSet
'Usage

Dim instance As XFAPageSetCollection
Dim name As String
Dim value As XFAPageSet

value = instance.Item(name)
public XFAPageSet Item(
   string name
) {get;}
public: __property XFAPageSet* get_Item(
   string* name
);
public:
property XFAPageSet^ Item {
   XFAPageSet^ get(String^ name);
}

Parameters

name
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members
Overload List


%%PageItemTitle%%

XFAPasswordEditField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class
Defines a XFA password edit field.
Object Model
XFAPasswordEditField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFAPasswordEditField
   Inherits XFATextEditField
'Usage

Dim instance As XFAPasswordEditField
public class XFAPasswordEditField : XFATextEditField
public __gc class XFAPasswordEditField : public XFATextEditField
public ref class XFAPasswordEditField : public XFATextEditField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPasswordEditField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPasswordEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFAPasswordEditField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class

The following tables list the members exposed by XFAPasswordEditField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFATextEditField)
Public Property | Multiline | Gets a value indicating whether the field is multiline. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFATextEditField)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | PasswordChar | Gets the character used to mask the user input that is entered in the field.
Public Property | Text | Gets or sets the text in this text edit field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFATextEditField)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAPasswordEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAPasswordEditField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class

For a list of all members of this type, see XFAPasswordEditField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFATextEditField)
Public Property | Multiline | Gets a value indicating whether the field is multiline. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFATextEditField)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | PasswordChar | Gets the character used to mask the user input that is entered in the field.
Public Property | Text | Gets or sets the text in this text edit field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFATextEditField)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAPasswordEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


PasswordChar Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPasswordEditField Class : PasswordChar Property
Gets the character used to mask the user input that is entered in the field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PasswordChar As Char
'Usage

Dim instance As XFAPasswordEditField
Dim value As Char

value = instance.PasswordChar
public char PasswordChar {get;}
public: __property char get_PasswordChar();
public:
property char PasswordChar {
   char get();
}

Property Value

A char value specifying the character used to mask the user input that is entered in the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFAPasswordEditField Class
XFAPasswordEditField Members


%%PageItemTitle%%

XFARadioButtonField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class
Defines a XFA radio button field.
Object Model
XFARadioButtonField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFARadioButtonField
   Inherits XFAField
'Usage

Dim instance As XFARadioButtonField
public class XFARadioButtonField : XFAField
public __gc class XFARadioButtonField : public XFAField
public ref class XFARadioButtonField : public XFAField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFARadioButtonField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class

The following tables list the members exposed by XFARadioButtonField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFARadioButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFARadioButtonField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class

For a list of all members of this type, see XFARadioButtonField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field.
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFARadioButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


CheckedState Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonField Class : CheckedState Property
Gets or sets the checked state of the field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckedState As XFACheckButtonState
'Usage

Dim instance As XFARadioButtonField
Dim value As XFACheckButtonState

instance.CheckedState = value

value = instance.CheckedState
public XFACheckButtonState CheckedState {get; set;}
public: __property XFACheckButtonState get_CheckedState();
public: __property void set_CheckedState(
   XFACheckButtonState value
);
public:
property XFACheckButtonState CheckedState {
   XFACheckButtonState get();
   void set (    XFACheckButtonState value);
}

Property Value

A XFACheckButtonState enumeration member specifying the checked state of the field.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when trying to set Neutral state on a radio button or on a check button that does not support it.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonField Class
XFARadioButtonField Members


%%PageItemTitle%%

XFARadioButtonFieldCollection Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class
Defines a collection of exclusive radio buttons.
Object Model
XFARadioButtonFieldCollection ClassXFARadioButtonField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class XFARadioButtonFieldCollection
'Usage

Dim instance As XFARadioButtonFieldCollection
[DefaultMember("Item")]
public class XFARadioButtonFieldCollection
[DefaultMember("Item")]
public __gc class XFARadioButtonFieldCollection
[DefaultMember("Item")]
public ref class XFARadioButtonFieldCollection
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonFieldCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFARadioButtonFieldCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

The following tables list the members exposed by XFARadioButtonFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the radio button at the specified index.
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFARadioButtonFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFARadioButtonFieldCollection Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

For a list of all members of this type, see XFARadioButtonFieldCollection members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFARadioButtonFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method (XFARadioButtonFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : GetEnumerator Method
Returns an enumerator that can iterate through a collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As XFARadioButtonFieldCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


MoveNext Method (XFARadioButtonFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : MoveNext Method
Advances the enumerator to the next element of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As XFARadioButtonFieldCollection
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


Reset Method (XFARadioButtonFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Reset Method
Sets the enumerator to its initial position, which is before the first element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As XFARadioButtonFieldCollection

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


%%PageItemTitle%% $$Properties$$

XFARadioButtonFieldCollection Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

For a list of all members of this type, see XFARadioButtonFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the radio button at the specified index.
Top
See Also

Reference

XFARadioButtonFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property (XFARadioButtonFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Count Property
Returns the number of items in the collection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As XFARadioButtonFieldCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


Current Property (XFARadioButtonFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Current Property
Gets the current element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Current As Object
'Usage

Dim instance As XFARadioButtonFieldCollection
Dim value As Object

value = instance.Current
public object Current {get;}
public: __property Object* get_Current();
public:
property Object^ Current {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


Item Property (XFARadioButtonFieldCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Item Property
Gets the radio button at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As XFARadioButtonField
'Usage

Dim instance As XFARadioButtonFieldCollection
Dim index As Integer
Dim value As XFARadioButtonField

value = instance.Item(index)
public XFARadioButtonField this[
   int index
]; {get;}
public: __property XFARadioButtonField* get_Item   int index
;
public:
property XFARadioButtonField^ default [int] {
   XFARadioButtonField^ get(int index);
}

Parameters

index
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is lower than 0 or greater than or equal to Count.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


%%PageItemTitle%%

XFARadioButtonListField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class
Defines a XFA radio buttons list field.
Object Model
XFARadioButtonListField ClassXFARadioButtonFieldCollection ClassXFARadioButtonField ClassXFARadioButtonField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFARadioButtonListField
   Inherits XFAField
'Usage

Dim instance As XFARadioButtonListField
public class XFARadioButtonListField : XFAField
public __gc class XFARadioButtonListField : public XFAField
public ref class XFARadioButtonListField : public XFAField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonListField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonListField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFARadioButtonListField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class

The following tables list the members exposed by XFARadioButtonListField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Items | Gets the list of radio buttons included in this list.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the index of the checked radio button in the list.
Public Property | SelectedItem | Gets or sets the selected radio button in the list.
Public Property | SelectedValue | Gets or sets the selected radio button based on radio button's value.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFARadioButtonListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFARadioButtonListField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class

For a list of all members of this type, see XFARadioButtonListField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Items | Gets the list of radio buttons included in this list.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the index of the checked radio button in the list.
Public Property | SelectedItem | Gets or sets the selected radio button in the list.
Public Property | SelectedValue | Gets or sets the selected radio button based on radio button's value.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFARadioButtonListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Items Property (XFARadioButtonListField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : Items Property
Gets the list of radio buttons included in this list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Items As XFARadioButtonFieldCollection
'Usage

Dim instance As XFARadioButtonListField
Dim value As XFARadioButtonFieldCollection

value = instance.Items
public XFARadioButtonFieldCollection Items {get;}
public: __property XFARadioButtonFieldCollection* get_Items();
public:
property XFARadioButtonFieldCollection^ Items {
   XFARadioButtonFieldCollection^ get();
}

Property Value

A XFARadioButtonFieldCollection object specifying the list of radio buttons in this list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


SelectedIndex Property (XFARadioButtonListField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : SelectedIndex Property
Gets or sets the index of the checked radio button in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedIndex As Integer
'Usage

Dim instance As XFARadioButtonListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
public int SelectedIndex {get; set;}
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
public:
property int SelectedIndex {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the checked radio button in the list.
Remarks
-1 means that no radio button is checked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


SelectedItem Property (XFARadioButtonListField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : SelectedItem Property
Gets or sets the selected radio button in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedItem As XFARadioButtonField
'Usage

Dim instance As XFARadioButtonListField
Dim value As XFARadioButtonField

instance.SelectedItem = value

value = instance.SelectedItem
public XFARadioButtonField SelectedItem {get; set;}
public: __property XFARadioButtonField* get_SelectedItem();
public: __property void set_SelectedItem(
   XFARadioButtonField* value
);
public:
property XFARadioButtonField^ SelectedItem {
   XFARadioButtonField^ get();
   void set (    XFARadioButtonField^ value);
}

Property Value

A XFARadioButtonField object specifying the selected radio button.
Remarks
null (Nothing in VB.NET) means that no radio button is selected.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


SelectedValue Property (XFARadioButtonListField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : SelectedValue Property
Gets or sets the selected radio button based on radio button's value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedValue As String
'Usage

Dim instance As XFARadioButtonListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
public string SelectedValue {get; set;}
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
public:
property String^ SelectedValue {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the value of the selected item.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The value does not exist in field's set of values.
Remarks
When setting the selected value, if the value does not exist in the list, an exception is thrown.
If the value to select is null (Nothing in VB.NET), then the selection is reset and SelectedIndex property becomes -1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


%%PageItemTitle%%

XFASubform Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubform Class
Defines a XFA subform.
Object Model
XFASubform ClassXFAAreaCollection ClassXFAArea ClassXFAFieldCollection ClassXFAField ClassXFAPageSetCollection ClassXFAPageSet ClassXFASubformCollection ClassXFASubform Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFASubform
   Inherits XFAExtendedContainer
'Usage

Dim instance As XFASubform
public class XFASubform : XFAExtendedContainer
public __gc class XFASubform : public XFAExtendedContainer
public ref class XFASubform : public XFAExtendedContainer
Remarks
A XFA subform is used to group in a logical manner the elements in a XFA form. A XFA subform can be included in another subform and also it ca include other subforms.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFASubform

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubform Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFASubform Class Members
Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubform Class

The following tables list the members exposed by XFASubform.

Public Properties
 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | PageSets | Gets the list of page sets included in this subform.
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | Visibility | Gets the visibility of the subform content.
Top
See Also

Reference

XFASubform Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFASubform Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubform Class

For a list of all members of this type, see XFASubform members.

Public Properties
 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | PageSets | Gets the list of page sets included in this subform.
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | Visibility | Gets the visibility of the subform content.
Top
See Also

Reference

XFASubform Class
O2S.Components.PDF4NET.Forms.XFA Namespace


PageSets Property (XFASubform)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubform Class : PageSets Property
Gets the list of page sets included in this subform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageSets As XFAPageSetCollection
'Usage

Dim instance As XFASubform
Dim value As XFAPageSetCollection

value = instance.PageSets
public XFAPageSetCollection PageSets {get;}
public: __property XFAPageSetCollection* get_PageSets();
public:
property XFAPageSetCollection^ PageSets {
   XFAPageSetCollection^ get();
}

Property Value

A XFAPageSetCollection object specifying the list of page sets included in this subform.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubform Class
XFASubform Members


Visibility Property (XFASubform)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubform Class : Visibility Property
Gets the visibility of the subform content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Visibility As XFAContentVisibility
'Usage

Dim instance As XFASubform
Dim value As XFAContentVisibility

value = instance.Visibility
public XFAContentVisibility Visibility {get;}
public: __property XFAContentVisibility get_Visibility();
public:
property XFAContentVisibility Visibility {
   XFAContentVisibility get();
}

Property Value

A XFAContentVisibility enumeration member specifying the visibility for subform content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubform Class
XFASubform Members


%%PageItemTitle%%

XFASubformCollection Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class
Defines a collection of XFA subforms.
Object Model
XFASubformCollection ClassXFASubform Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class XFASubformCollection
'Usage

Dim instance As XFASubformCollection
[DefaultMember("Item")]
public class XFASubformCollection
[DefaultMember("Item")]
public __gc class XFASubformCollection
[DefaultMember("Item")]
public ref class XFASubformCollection
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFASubformCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubformCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFASubformCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

The following tables list the members exposed by XFASubformCollection.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the subform at the specified index (zero based index).
Top
Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFASubformCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFASubformCollection Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

For a list of all members of this type, see XFASubformCollection members.

Public Methods
 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

XFASubformCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method (XFASubformCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : GetEnumerator Method
Returns an enumerator that can iterate through a collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As XFASubformCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator();
public:
IEnumerator^ GetEnumerator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


MoveNext Method (XFASubformCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : MoveNext Method
Advances the enumerator to the next element of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As XFASubformCollection
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


Reset Method (XFASubformCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Reset Method
Sets the enumerator to its initial position, which is before the first element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As XFASubformCollection

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


%%PageItemTitle%% $$Properties$$

XFASubformCollection Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

For a list of all members of this type, see XFASubformCollection members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the subform at the specified index (zero based index).
Top
See Also

Reference

XFASubformCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property (XFASubformCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Count Property
Returns the number of items in the collection
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As XFASubformCollection
Dim value As Integer

value = instance.Count
public int Count {get;}
public: __property int get_Count();
public:
property int Count {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


Current Property (XFASubformCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Current Property
Gets the current element in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Current As Object
'Usage

Dim instance As XFASubformCollection
Dim value As Object

value = instance.Current
public object Current {get;}
public: __property Object* get_Current();
public:
property Object^ Current {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


Item Property (XFASubformCollection)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Item Property
Gets the subform at the specified index (zero based index).
Overload List
Overload | Description
Item(Int32) | Gets the subform at the specified index (zero based index).
Item(String) | Gets the subform with the given name.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


Item(Int32) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class > Item Property : Item(Int32) Property
Gets the subform at the specified index (zero based index).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As XFASubform
'Usage

Dim instance As XFASubformCollection
Dim index As Integer
Dim value As XFASubform

value = instance.Item(index)
public XFASubform Item(
   int index
) {get;}
public: __property XFASubform* get_Item(
   int index
);
public:
property XFASubform^ Item {
   XFASubform^ get(int index);
}

Parameters

index
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members
Overload List


Item(String) Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class > Item Property : Item(String) Property
Gets the subform with the given name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As XFASubform
'Usage

Dim instance As XFASubformCollection
Dim name As String
Dim value As XFASubform

value = instance.Item(name)
public XFASubform Item(
   string name
) {get;}
public: __property XFASubform* get_Item(
   string* name
);
public:
property XFASubform^ Item {
   XFASubform^ get(String^ name);
}

Parameters

name
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members
Overload List


%%PageItemTitle%%

XFATextEditField Class
Members

O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class
Defines a XFA text edit field.
Object Model
XFATextEditField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFATextEditField
   Inherits XFAField
'Usage

Dim instance As XFATextEditField
public class XFATextEditField : XFAField
public __gc class XFATextEditField : public XFAField
public ref class XFATextEditField : public XFAField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPasswordEditField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFATextEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Members$$

XFATextEditField Class Members
Properties Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class

The following tables list the members exposed by XFATextEditField.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field.
Public Property | Multiline | Gets a value indicating whether the field is multiline.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Text | Gets or sets the text in this text edit field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFATextEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFATextEditField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class

For a list of all members of this type, see XFATextEditField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field.
Public Property | Multiline | Gets a value indicating whether the field is multiline.
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Text | Gets or sets the text in this text edit field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFATextEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


MaxLen Property

O2S.Components.PDF4NET.Forms.XFA Namespace > XFATextEditField Class : MaxLen Property
Gets or sets the maximum number of characters that can be entered in the text edit field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MaxLen As Integer
'Usage

Dim instance As XFATextEditField
Dim value As Integer

value = instance.MaxLen
public int MaxLen {get;}
public: __property int get_MaxLen();
public:
property int MaxLen {
   int get();
}

Property Value

An non-negative integer value specifying the maximum number of characters that can be entered in the text edit field.
Remarks
If the value of this property is 0, then the length of this field is unlimited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFATextEditField Class
XFATextEditField Members


Multiline Property (XFATextEditField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFATextEditField Class : Multiline Property
Gets a value indicating whether the field is multiline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Multiline As Boolean
'Usage

Dim instance As XFATextEditField
Dim value As Boolean

value = instance.Multiline
public bool Multiline {get;}
public: __property bool get_Multiline();
public:
property bool Multiline {
   bool get();
}

Property Value

True if the field is multiline, false otherwise.
Remarks
For password edit fields this property is always false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFATextEditField Class
XFATextEditField Members


Text Property (XFATextEditField)

O2S.Components.PDF4NET.Forms.XFA Namespace > XFATextEditField Class : Text Property
Gets or sets the text in this text edit field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As XFATextEditField
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the text displayed in the text edit field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFATextEditField Class
XFATextEditField Members


%%PageItemTitle%%

XFABarcodeType Enumeration

O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeType Enumeration
Specifies the available barcode types for displaying field content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum XFABarcodeType
   Inherits System.Enum
'Usage

Dim instance As XFABarcodeType
public enum XFABarcodeType : System.Enum
__value public enum XFABarcodeType : public System.Enum
public enum class XFABarcodeType : public System.Enum
Members
Member | Description
Codabar | Codabar, as defined in ANSI/AIM BC3-1995, USS Codabar.
Code11 | Code 11 (USD-8); no official standard.
Code128 | Code 128, as defined in ANSI/AIM BC4-1995.
Code128A | Code 128 A, as defined in ANSI/AIM BC4-1995.
Code128B | Code 128 B, as defined in ANSI/AIM BC4-1995.
Code128C | Code 128 C, as defined in ANSI/AIM BC4-1995.
Code128SSCC | Code 128 serial shipping container code, as defined in ANSI/AIM BC4-1995.
Code2Of5Industrial | Code 2 of 5 Industrial; no official standard.
Code2Of5Interleaved | Code 2 of 5 Interleaved, as defined in ANSI/AIM BC2-1995.
Code2Of5Matrix | Code 2 of 5 Matrix; no official standard.
Code2Of5Standard | Code 2 of 5 Standard; no official standard.
Code3Of9 | Code 39 (also known as code 3 of 9), as defined in ANSI/AIM BC1-1995.
Code3Of9Extended | Code 39 extended; no official standard.
Code49 | Code 49, as defined in ANSI/AIM BC6-1995.
Code93 | Code 93, as defined in ANSI/AIM BC5-1995.
Ean13 | EAN-13, as defined in ISO/EEC 15420.
Ean13Add2 | EAN-13 with 2-digit Addendum, as defined in ISO/EEC 15420.
Ean13Add5 | EAN-13 with 5-digit Addendum, as defined in ISO/EEC 15420.
Ean13Pwcd | EAN-13 with Price/Weight customer data, as defined in ISO/EEC 15420.
Ean8 | EAN-8, as defined in ISO/EEC 15420.
Ean8Add2 | EAN-8 with 2-digit Addendum, as defined in ISO/EEC 15420.
Ean8Add5 | EAN-8 with 5-digit Addendum, as defined in ISO/EEC 15420.
Fim | United States Postal Service FIM (Facing Identification Mark), as described in First-Class Mail.
Logmars | Logmars (Logistics Applications of Automated Marking and Reading Symbols) as defined by U.S. Military Standard MIL-STD-1189B
Maxicode | UPS Maxicode, as defined in ANSI/AIM BC10-ISS Maxicode.
Msi | MSI (modified Plessey).
Pdf417 | PDF417, as defined in USS PDF417.
Pdf417Macro | PDF417, but allowing the data to span multiple PDF417 bar codes.
Plessey | Plessey; no official standard.
PostAUSCust2 | Australian Postal Customer 2, as defined in Customer Barcoding Technical Specifications.
PostAUSCust3 | Australian Postal Customer 3, as defined in Customer Barcoding Technical Specifications.
PostAUSReplyPaid | Australian Postal Reply Paid, as defined in Customer Barcoding Technical Specifications.
PostAUSStandard | Australian Postal Standard, as defined in Customer Barcoding Technical Specifications.
PostUKRM4SCC | United Kingdom RM4SCC (Royal Mail 4-State Customer Code), as defined in the How to Use Mailsort Guide.
PostUSDPBC | United States Postal Service Delivery Point Bar Code, as defined in DMM C840 Barcoding Standards for Letters and Flats.
PostUSStandard | United States Postal Service POSTNET bar code (Zip+4), as defined in DMM C840 Barcoding Standards for Letters and Flats.
PostUSZip | United States Postal Service POSTNET bar code (5 digit Zip), as defined in DMM C840 Barcoding Standards for Letters and Flats.
QR | QR Code, as defined in ISS - QR Code.
Telepen | Telepen, as defined in USS Telepen.
Ucc128 | UCC/EAN 128, as defined in International Symbology Specification - Code 128.
Ucc128Random | UCC/EAN 128 Random Weight, as defined in International Symbology Specification - Code 128.
Ucc128SSCC | UCC/EAN 128 serial shipping container code (SSCC), as defined in International Symbology Specification - Code 128.
Unknown | Unknown barcode type.
UpcA | UPC-A, as defined in ISO/EEC 15420.
UpcAAdd2 | UPC-A with 2-digit Addendum, as defined in ISO/EEC 15420.
UpcAAdd5 | UPC-A with 5-digit Addendum, as defined in ISO/EEC 15420.
UpcAPwcd | UPC-A with Price/Weight customer data, as defined in ISO/EEC 15420.
UpcE | UPC-E, as defined in ISO/EEC 15420.
UpcEAdd2 | UPC-E with 2-digit Addendum, as defined in ISO/EEC 15420.
UpcEAdd5 | UPC-E with 5-digit Addendum, as defined in ISO/EEC 15420.
UpcEan2 | UPC/EAN with 2-digit Addendum, as defined in ISO/EEC 15420.
UpcEan5 | UPC/EAN with 5-digit Addendum, as defined in ISO/EEC 15420.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFACheckButtonState Enumeration

O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonState Enumeration
Specifies the available states for a checkbutton and radiobutton.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum XFACheckButtonState
   Inherits System.Enum
'Usage

Dim instance As XFACheckButtonState
public enum XFACheckButtonState : System.Enum
__value public enum XFACheckButtonState : public System.Enum
public enum class XFACheckButtonState : public System.Enum
Members
Member | Description
Checked | Checked state.
Neutral | Neutral state, not available for radiobuttons.
Unchecked | Unchecked state.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAChoiceListDisplayMode Enumeration

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListDisplayMode Enumeration
Specifies the modes for presenting the drop down choice list in interactive applications.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum XFAChoiceListDisplayMode
   Inherits System.Enum
'Usage

Dim instance As XFAChoiceListDisplayMode
public enum XFAChoiceListDisplayMode : System.Enum
__value public enum XFAChoiceListDisplayMode : public System.Enum
public enum class XFAChoiceListDisplayMode : public System.Enum
Members
Member | Description
Always | The drop down list is always displayed (the field is a list box).
Multiselect | The drop down list is always displayed and allows selection of multiple items (the field is a list box).
OnEntry | The drop down list is displayed when the field gets the focus.
UserControl | The drop down list is displayed when the user clicks on the field or on the arrow button.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAContentAccess Enumeration

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAContentAccess Enumeration
Specifies the access modes to the content of a container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum XFAContentAccess
   Inherits System.Enum
'Usage

Dim instance As XFAContentAccess
public enum XFAContentAccess : System.Enum
__value public enum XFAContentAccess : public System.Enum
public enum class XFAContentAccess : public System.Enum
Members
Member | Description
NonInteractive | Allows the content to be loaded from the data document, but not updated interactively.
Open | Allow update without restriction.
Protected | The processing application must prevent the user from making any direct changes to the container's content. Indirect changes (e.g., via calculations) may occur. A protected container will not generate any events.
ReadOnly | The processing application must not allow the user to make direct changes to the container's content. Indirect changes (e.g., via calculations) may occur. A protected container will not generate a subset of regular events (those that are not related to direct modification of the content).
Remarks
Fields with Protected or ReadOnly access can not be updated from code.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAContentAccess

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAContentType Enumeration

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAContentType Enumeration
Specifies the available types of content accepted by a XFA value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum XFAContentType
   Inherits System.Enum
'Usage

Dim instance As XFAContentType
public enum XFAContentType : System.Enum
__value public enum XFAContentType : public System.Enum
public enum class XFAContentType : public System.Enum
Members
Member | Description
Arc | Arc data type
Boolean | Boolean data type.
Date | Date data type.
DateTime | DateTime data type.
Decimal | Decimal data type.
Float | Float data type.
Image | Image data type.
Integer | Integer data type.
Line | Line data type.
Null | No data.
Rectangle | Rectangle data type.
Text | String data type.
Time | Time data type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAContentType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAContentVisibility Enumeration

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAContentVisibility Enumeration
Specifies the visibility of the content of a container.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum XFAContentVisibility
   Inherits System.Enum
'Usage

Dim instance As XFAContentVisibility
public enum XFAContentVisibility : System.Enum
__value public enum XFAContentVisibility : public System.Enum
public enum class XFAContentVisibility : public System.Enum
Members
Member | Description
Hidden | The container content is not visible and it does not take up space.
Invisible | The container content is not visible, but it still takes up space.
Visible | The container content is visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAContentVisibility

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFADataFormat Enumeration

O2S.Components.PDF4NET.Forms.XFA Namespace : XFADataFormat Enumeration
Specifies the available formats for data import/export for XFA Forms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum XFADataFormat
   Inherits System.Enum
'Usage

Dim instance As XFADataFormat
public enum XFADataFormat : System.Enum
__value public enum XFADataFormat : public System.Enum
public enum class XFADataFormat : public System.Enum
Members
Member | Description
XDP | Form data is imported or exported in XDP format.
XML | Form data is imported or exported in XML format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFADataFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAImageAspect Enumeration

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageAspect Enumeration
Specifies the available modes for scaling the image when it is displayed in the image edit field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum XFAImageAspect
   Inherits System.Enum
'Usage

Dim instance As XFAImageAspect
public enum XFAImageAspect : System.Enum
__value public enum XFAImageAspect : public System.Enum
public enum class XFAImageAspect : public System.Enum
Members
Member | Description
Actual | The image is not scaled, its original size is used.
Fit | The image is scaled to maximum possible size while keeping the original aspect ratio.
Height | The image is scaled proportionally such that its height matches the field height and the original aspect ratio is kept.
None | The image is scaled to occupy the entire field area.
Width | The image is scaled proportionally such that its width matches the field width and the original aspect ratio is kept.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAImageAspect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%%

XFAImageStorageMode Enumeration

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageStorageMode Enumeration
Specifies the available modes for storing image content in an image edit field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum XFAImageStorageMode
   Inherits System.Enum
'Usage

Dim instance As XFAImageStorageMode
public enum XFAImageStorageMode : System.Enum
__value public enum XFAImageStorageMode : public System.Enum
public enum class XFAImageStorageMode : public System.Enum
Members
Member | Description
Embed | The image data is stored in the field.
Link | The path to the image file is stored in the field.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAImageStorageMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


O2S.Components.PDF4NET.Functions Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFFunction | Defines the base class for PDF functions.
Class | PDFFunctionCollection | Defines a collection of PDF actions.
Class | PDFType0Function | Defines a type 0 function.
Class | PDFType2Function | Defines a type 2 function.
Class | PDFType3Function | Defines a type 3 function.
Class | PDFType4Function | Defines a type 4 function.
Enumerations
 | Enumeration | Description
Enumeration | InterpolationMode | Specifies the available interpolation modes for a type 0 function values.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFFunction Class
Members

O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class
Defines the base class for PDF functions.
Object Model
PDFFunction ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFFunction
'Usage

Dim instance As PDFFunction
public abstract class PDFFunction
public __gc abstract class PDFFunction
public ref class PDFFunction abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType0Function
O2S.Components.PDF4NET.Functions.PDFType2Function
O2S.Components.PDF4NET.Functions.PDFType3Function
O2S.Components.PDF4NET.Functions.PDFType4Function

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunction Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFFunction Class Members
Properties

O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class

The following tables list the members exposed by PDFFunction.

Public Properties
 | Name | Description
Public Property | Dictionary | Gets the function dictionary.
Public Property | Domain | Gets or sets the domain function domain.
Public Property | Range | Gets or sets the function range.
Top
See Also

Reference

PDFFunction Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Properties$$

PDFFunction Class Properties

O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class

For a list of all members of this type, see PDFFunction members.

Public Properties
 | Name | Description
Public Property | Dictionary | Gets the function dictionary.
Public Property | Domain | Gets or sets the domain function domain.
Public Property | Range | Gets or sets the function range.
Top
See Also

Reference

PDFFunction Class
O2S.Components.PDF4NET.Functions Namespace


Dictionary Property (PDFFunction)

O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : Dictionary Property
Gets the function dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFFunction
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw function dictionary.
Remarks
This property gives you direct access to function dictionary and its associated resources. Note: Modifying directly the function dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunction Class
PDFFunction Members


Domain Property (PDFFunction)

O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : Domain Property
Gets or sets the domain function domain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Domain As Double()
'Usage

Dim instance As PDFFunction
Dim value() As Double

instance.Domain = value

value = instance.Domain
public double[] Domain {get; set;}
public: __property double[]* get_Domain();
public: __property void set_Domain(
   double[]* value
);
public:
property array<double>^ Domain {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A double array specifying the function domain.
Remarks
The domain is an array of 2 × m numbers, where m is the number of input values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunction Class
PDFFunction Members


Range Property (PDFFunction)

O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : Range Property
Gets or sets the function range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Range As Double()
'Usage

Dim instance As PDFFunction
Dim value() As Double

instance.Range = value

value = instance.Range
public double[] Range {get; set;}
public: __property double[]* get_Range();
public: __property void set_Range(
   double[]* value
);
public:
property array<double>^ Range {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A double array specifying the function range.
Remarks
The rangle is an array of 2 × n numbers, where n is the number of output values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunction Class
PDFFunction Members


%%PageItemTitle%%

PDFFunctionCollection Class
Members

O2S.Components.PDF4NET.Functions Namespace : PDFFunctionCollection Class
Defines a collection of PDF actions.
Object Model
PDFFunctionCollection ClassPDFFunction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFunctionCollection
   Inherits System.Collections.ObjectModel.Collection(Of PDFFunction)
'Usage

Dim instance As PDFFunctionCollection
public class PDFFunctionCollection : System.Collections.ObjectModel.Collection<PDFFunction>
public __gc class PDFFunctionCollection : public System.Collections.ObjectModel.Collection<PDFFunction>
public ref class PDFFunctionCollection : public System.Collections.ObjectModel.Collection<PDFFunction>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Functions.PDFFunctionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunctionCollection Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFFunctionCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Functions Namespace : PDFFunctionCollection Class

The following tables list the members exposed by PDFFunctionCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Top
See Also

Reference

PDFFunctionCollection Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType0Function Class
Members

O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class
Defines a type 0 function.
Object Model
PDFType0Function ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFType0Function
   Inherits PDFFunction
'Usage

Dim instance As PDFType0Function
public class PDFType0Function : PDFFunction
public __gc class PDFType0Function : public PDFFunction
public ref class PDFType0Function : public PDFFunction
Remarks
Type 0 functions use a sequence of sample values (contained in a stream) to provide an approximation for functions whose domains and ranges are bounded. The samples are organized as an m-dimensional table in which each entry has n components.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType0Function

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFType0Function Class Members
Properties

O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class

The following tables list the members exposed by PDFType0Function.

Public Constructors
 | Name | Description
Public Constructor | PDFType0Function Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BitsPerSample | Gets or sets the function's bits per sample.
Public Property | Decode | Gets or sets the function's decoding array.
Public Property | Dictionary | Gets the function dictionary. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | InterpolationMode | Gets or sets the function's interpolation mode.
Public Property | Range | Gets or sets the function range. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Samples | Get or sets the stream that stores the sample values.
Public Property | Size | Gets or sets the number of samples.
Top
See Also

Reference

PDFType0Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType0Function Constructor

O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : PDFType0Function Constructor
Overload List
Overload | Description
PDFType0Function Constructor() | Initilizes a new PDFType0Function object.
PDFType0Function Constructor(Int32[],Int32,InterpolationMode,Double[],Double[],Byte[]) | Initializes new PDFType0Function object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%%

PDFType0Function Constructor()

O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class > PDFType0Function Constructor : PDFType0Function Constructor()
Initilizes a new PDFType0Function object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFType0Function()
public PDFType0Function()
public: PDFType0Function();
public:
PDFType0Function();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Class
PDFType0Function Members
Overload List


%%PageItemTitle%%

PDFType0Function Constructor(Int32[],Int32,InterpolationMode,Double[],Double[],Byte[])

O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class > PDFType0Function Constructor : PDFType0Function Constructor(Int32[],Int32,InterpolationMode,Double[],Double[],Byte[])
An array of m positive integers specifying the number of samples in each input dimension of the sample table.
The number of bits used to represent each sample.
The interpolation mode between samples.
An array of 2*m numbers specifying the linear mapping of input values into the domain of the function's sample table.
An array of 2*n numbers specifying the linear mapping of sample values into the range appropriate for the function's output values.
Sample function data.
Initializes new PDFType0Function object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal size() As Integer, _
   ByVal bitsPerSample As Integer, _
   ByVal interpolationMode As InterpolationMode, _
   ByVal encode() As Double, _
   ByVal decode() As Double, _
   ByVal samples() As Byte _
)
'Usage

Dim size() As Integer
Dim bitsPerSample As Integer
Dim interpolationMode As InterpolationMode
Dim encode() As Double
Dim decode() As Double
Dim samples() As Byte

Dim instance As New PDFType0Function(size, bitsPerSample, interpolationMode, encode, decode, samples)
public PDFType0Function(
   int[] size,
   int bitsPerSample,
   InterpolationMode interpolationMode,
   double[] encode,
   double[] decode,
   byte[] samples
)
public: PDFType0Function(
   int[]* size,
   int bitsPerSample,
   InterpolationMode interpolationMode,
   double[]* encode,
   double[]* decode,
   byte[]* samples
)
public:
PDFType0Function(
   array<int>^ size,
   int bitsPerSample,
   InterpolationMode interpolationMode,
   array<double>^ encode,
   array<double>^ decode,
   array<byte>^ samples
)

Parameters

size
An array of m positive integers specifying the number of samples in each input dimension of the sample table.
bitsPerSample
The number of bits used to represent each sample.
interpolationMode
The interpolation mode between samples.
encode
An array of 2*m numbers specifying the linear mapping of input values into the domain of the function's sample table.
decode
An array of 2*n numbers specifying the linear mapping of sample values into the range appropriate for the function's output values.
samples
Sample function data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Class
PDFType0Function Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFType0Function Class Properties

O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class

For a list of all members of this type, see PDFType0Function members.

Public Properties
 | Name | Description
Public Property | BitsPerSample | Gets or sets the function's bits per sample.
Public Property | Decode | Gets or sets the function's decoding array.
Public Property | Dictionary | Gets the function dictionary. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | InterpolationMode | Gets or sets the function's interpolation mode.
Public Property | Range | Gets or sets the function range. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Samples | Get or sets the stream that stores the sample values.
Public Property | Size | Gets or sets the number of samples.
Top
See Also

Reference

PDFType0Function Class
O2S.Components.PDF4NET.Functions Namespace


BitsPerSample Property

O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : BitsPerSample Property
Gets or sets the function's bits per sample.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitsPerSample As Integer
'Usage

Dim instance As PDFType0Function
Dim value As Integer

instance.BitsPerSample = value

value = instance.BitsPerSample
public int BitsPerSample {get; set;}
public: __property int get_BitsPerSample();
public: __property void set_BitsPerSample(
   int value
);
public:
property int BitsPerSample {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the function's bits per sample.
Remarks
This property is the number of bits used to represent each sample. (If the function has multiple output values, each one occupies BitsPerSample bits.) Valid values are 1, 2, 4, 8, 12, 16, 24, and 32.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Class
PDFType0Function Members


Decode Property

O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Decode Property
Gets or sets the function's decoding array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Decode As Double()
'Usage

Dim instance As PDFType0Function
Dim value() As Double

instance.Decode = value

value = instance.Decode
public double[] Decode {get; set;}
public: __property double[]* get_Decode();
public: __property void set_Decode(
   double[]* value
);
public:
property array<double>^ Decode {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A float array specifying the function's decoding array.
Remarks
The decode is an array of 2*n numbers specifying the linear mapping of sample values into the range appropriate for the function's output values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Class
PDFType0Function Members


Encode Property (PDFType0Function)

O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Encode Property
Gets or sets the function's encoding array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Encode As Double()
'Usage

Dim instance As PDFType0Function
Dim value() As Double

instance.Encode = value

value = instance.Encode
public double[] Encode {get; set;}
public: __property double[]* get_Encode();
public: __property void set_Encode(
   double[]* value
);
public:
property array<double>^ Encode {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A float array specifying the function's encoding array.
Remarks
The encode is an array of 2*m numbers specifying the linear mapping of input values into the domain of the function’s sample table.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Class
PDFType0Function Members


InterpolationMode Property

O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : InterpolationMode Property
Gets or sets the function's interpolation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InterpolationMode As InterpolationMode
'Usage

Dim instance As PDFType0Function
Dim value As InterpolationMode

instance.InterpolationMode = value

value = instance.InterpolationMode
public InterpolationMode InterpolationMode {get; set;}
public: __property InterpolationMode get_InterpolationMode();
public: __property void set_InterpolationMode(
   InterpolationMode value
);
public:
property InterpolationMode InterpolationMode {
   InterpolationMode get();
   void set (    InterpolationMode value);
}

Property Value

A InterpolationMode enumeration member specifying the function's interpolation mode.
Remarks
This property specifies how the sample values are interpolated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Class
PDFType0Function Members


Samples Property

O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Samples Property
Get or sets the stream that stores the sample values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Samples As Byte()
'Usage

Dim instance As PDFType0Function
Dim value() As Byte

instance.Samples = value

value = instance.Samples
public byte[] Samples {get; set;}
public: __property byte[]* get_Samples();
public: __property void set_Samples(
   byte[]* value
);
public:
property array<byte>^ Samples {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array that stores the sample values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Class
PDFType0Function Members


Size Property (PDFType0Function)

O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Size Property
Gets or sets the number of samples.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Size As Integer()
'Usage

Dim instance As PDFType0Function
Dim value() As Integer

instance.Size = value

value = instance.Size
public int[] Size {get; set;}
public: __property int[]* get_Size();
public: __property void set_Size(
   int[]* value
);
public:
property array<int>^ Size {
   array<int>^ get();
   void set (    array<int>^ value);
}

Property Value

An int array specifying the number of samples.
Remarks
An array of m positive integers specifying the number of samples in each input dimension of the sample table.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType0Function Class
PDFType0Function Members


%%PageItemTitle%%

PDFType2Function Class
Members

O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class
Defines a type 2 function.
Object Model
PDFType2Function ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFType2Function
   Inherits PDFFunction
'Usage

Dim instance As PDFType2Function
public class PDFType2Function : PDFFunction
public __gc class PDFType2Function : public PDFFunction
public ref class PDFType2Function : public PDFFunction
Remarks
Type 2 functions define an exponential interpolation of one input value and n output values.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType2Function

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType2Function Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFType2Function Class Members
Properties

O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class

The following tables list the members exposed by PDFType2Function.

Public Constructors
 | Name | Description
Public Constructor | PDFType2Function Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | C0 | Gets or sets the function result when input value is 0.
Public Property | C1 | Gets or sets the function result when input value is 1.
Public Property | Dictionary | Gets the function dictionary. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Exponent | Gets or sets the interpolation exponent.
Public Property | Range | Gets or sets the function range. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Top
See Also

Reference

PDFType2Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType2Function Constructor

O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : PDFType2Function Constructor
Overload List
Overload | Description
PDFType2Function Constructor() | Initilizes a new PDFType2Function object.
PDFType2Function Constructor(Double[],Double[],Int32) | Initializes new PDFType2Function object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType2Function Class
PDFType2Function Members


%%PageItemTitle%%

PDFType2Function Constructor()

O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class > PDFType2Function Constructor : PDFType2Function Constructor()
Initilizes a new PDFType2Function object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFType2Function()
public PDFType2Function()
public: PDFType2Function();
public:
PDFType2Function();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType2Function Class
PDFType2Function Members
Overload List


%%PageItemTitle%%

PDFType2Function Constructor(Double[],Double[],Int32)

O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class > PDFType2Function Constructor : PDFType2Function Constructor(Double[],Double[],Int32)
An array of N numbers defining the function result when x = 0.0.
An array of N numbers defining the function result when x = 1.0.
Initializes new PDFType2Function object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal c0() As Double, _
   ByVal c1() As Double, _
   ByVal exponent As Integer _
)
'Usage

Dim c0() As Double
Dim c1() As Double
Dim exponent As Integer

Dim instance As New PDFType2Function(c0, c1, exponent)
public PDFType2Function(
   double[] c0,
   double[] c1,
   int exponent
)
public: PDFType2Function(
   double[]* c0,
   double[]* c1,
   int exponent
)
public:
PDFType2Function(
   array<double>^ c0,
   array<double>^ c1,
   int exponent
)

Parameters

c0
An array of N numbers defining the function result when x = 0.0.
c1
An array of N numbers defining the function result when x = 1.0.
exponent
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType2Function Class
PDFType2Function Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFType2Function Class Properties

O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class

For a list of all members of this type, see PDFType2Function members.

Public Properties
 | Name | Description
Public Property | C0 | Gets or sets the function result when input value is 0.
Public Property | C1 | Gets or sets the function result when input value is 1.
Public Property | Dictionary | Gets the function dictionary. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Exponent | Gets or sets the interpolation exponent.
Public Property | Range | Gets or sets the function range. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Top
See Also

Reference

PDFType2Function Class
O2S.Components.PDF4NET.Functions Namespace


C0 Property

O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : C0 Property
Gets or sets the function result when input value is 0.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property C0 As Double()
'Usage

Dim instance As PDFType2Function
Dim value() As Double

instance.C0 = value

value = instance.C0
public double[] C0 {get; set;}
public: __property double[]* get_C0();
public: __property void set_C0(
   double[]* value
);
public:
property array<double>^ C0 {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A double array specifying the function result when input value is 0.
Remarks
This property is an array of n numbers defining the function result when the input value is 0.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType2Function Class
PDFType2Function Members


C1 Property

O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : C1 Property
Gets or sets the function result when input value is 1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property C1 As Double()
'Usage

Dim instance As PDFType2Function
Dim value() As Double

instance.C1 = value

value = instance.C1
public double[] C1 {get; set;}
public: __property double[]* get_C1();
public: __property void set_C1(
   double[]* value
);
public:
property array<double>^ C1 {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A double array specifying the function result when input value is 1.
Remarks
This property is an array of n numbers defining the function result when the input value is 1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType2Function Class
PDFType2Function Members


Exponent Property

O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : Exponent Property
Gets or sets the interpolation exponent.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Exponent As Double
'Usage

Dim instance As PDFType2Function
Dim value As Double

instance.Exponent = value

value = instance.Exponent
public double Exponent {get; set;}
public: __property double get_Exponent();
public: __property void set_Exponent(
   double value
);
public:
property double Exponent {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the function's interpolation exponent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType2Function Class
PDFType2Function Members


%%PageItemTitle%%

PDFType3Function Class
Members

O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class
Defines a type 3 function.
Object Model
PDFType3Function ClassPDFDictionary ClassPDFFunctionCollection ClassPDFFunction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFType3Function
   Inherits PDFFunction
'Usage

Dim instance As PDFType3Function
public class PDFType3Function : PDFFunction
public __gc class PDFType3Function : public PDFFunction
public ref class PDFType3Function : public PDFFunction
Remarks
Type 3 functions define a stitching of the subdomains of several 1-input functions to produce a single new 1-input function.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType3Function

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType3Function Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFType3Function Class Members
Properties

O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class

The following tables list the members exposed by PDFType3Function.

Public Constructors
 | Name | Description
Public Constructor | PDFType3Function Constructor | Initilizes a new PDFType3Function object.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the intervals to which the functions apply.
Public Property | Dictionary | Gets the function dictionary. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | Functions | Gets the list of functions that make up this function.
Public Property | Range | Gets or sets the function range. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Top
See Also

Reference

PDFType3Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType3Function Constructor

O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : PDFType3Function Constructor
Initilizes a new PDFType3Function object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFType3Function()
public PDFType3Function()
public: PDFType3Function();
public:
PDFType3Function();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType3Function Class
PDFType3Function Members


%%PageItemTitle%% $$Properties$$

PDFType3Function Class Properties

O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class

For a list of all members of this type, see PDFType3Function members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the intervals to which the functions apply.
Public Property | Dictionary | Gets the function dictionary. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | Functions | Gets the list of functions that make up this function.
Public Property | Range | Gets or sets the function range. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Top
See Also

Reference

PDFType3Function Class
O2S.Components.PDF4NET.Functions Namespace


Bounds Property (PDFType3Function)

O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Bounds Property
Gets or sets the intervals to which the functions apply.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Bounds As Double()
'Usage

Dim instance As PDFType3Function
Dim value() As Double

instance.Bounds = value

value = instance.Bounds
public double[] Bounds {get; set;}
public: __property double[]* get_Bounds();
public: __property void set_Bounds(
   double[]* value
);
public:
property array<double>^ Bounds {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A float array specifying the intervals to which the functions apply.
Remarks
This property is an An array of k - 1 numbers that, in combination with PDFFunction.Domain, define the intervals to which each function from the Functions list applies. Bounds elements must be in order of increasing value, and each value must be within the domain defined by PDFFunction.Domain.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType3Function Class
PDFType3Function Members


Encode Property (PDFType3Function)

O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Encode Property
Gets or sets the function's encoding array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Encode As Double()
'Usage

Dim instance As PDFType3Function
Dim value() As Double

instance.Encode = value

value = instance.Encode
public double[] Encode {get; set;}
public: __property double[]* get_Encode();
public: __property void set_Encode(
   double[]* value
);
public:
property array<double>^ Encode {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A float array specifying the function's encoding array.
Remarks
The encode is an array of 2*k numbers that, taken in pairs, map each subset of the domain defined by PDFFunction.Domain and the Bounds array to the domain of the corresponding function.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType3Function Class
PDFType3Function Members


Functions Property

O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Functions Property
Gets the list of functions that make up this function.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Functions As PDFFunctionCollection
'Usage

Dim instance As PDFType3Function
Dim value As PDFFunctionCollection

value = instance.Functions
public PDFFunctionCollection Functions {get;}
public: __property PDFFunctionCollection* get_Functions();
public:
property PDFFunctionCollection^ Functions {
   PDFFunctionCollection^ get();
}

Property Value

The list of functions that make up this function.
Remarks
An array of k 1-input functions making up the stitching function. The output dimensionality of all functions must be the same, and compatible with the value of PDFFunction.Range if PDFFunction.Range is present.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType3Function Class
PDFType3Function Members


%%PageItemTitle%%

PDFType4Function Class
Members

O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class
Defines a type 4 function.
Object Model
PDFType4Function ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFType4Function
   Inherits PDFFunction
'Usage

Dim instance As PDFType4Function
public class PDFType4Function : PDFFunction
public __gc class PDFType4Function : public PDFFunction
public ref class PDFType4Function : public PDFFunction
Remarks
A type 4 function, also called a PostScript calculator function, is represented as a stream containing code written in a small subset of the PostScript language.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType4Function

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType4Function Members
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Members$$

PDFType4Function Class Members
Properties

O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class

The following tables list the members exposed by PDFType4Function.

Public Constructors
 | Name | Description
Public Constructor | PDFType4Function Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Dictionary | Gets the function dictionary. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Range | Gets or sets the function range. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Stream | Get or sets the stream that represents the function's code.
Top
See Also

Reference

PDFType4Function Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType4Function Constructor

O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class : PDFType4Function Constructor
Overload List
Overload | Description
PDFType4Function Constructor() | Initilizes a new PDFType4Function object.
PDFType4Function Constructor(Byte[]) | Initializes new PDFType4Function object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType4Function Class
PDFType4Function Members


%%PageItemTitle%%

PDFType4Function Constructor()

O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class > PDFType4Function Constructor : PDFType4Function Constructor()
Initilizes a new PDFType4Function object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFType4Function()
public PDFType4Function()
public: PDFType4Function();
public:
PDFType4Function();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType4Function Class
PDFType4Function Members
Overload List


%%PageItemTitle%%

PDFType4Function Constructor(Byte[])

O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class > PDFType4Function Constructor : PDFType4Function Constructor(Byte[])
Postscript code for the function.
Initializes new PDFType4Function object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal code() As Byte _
)
'Usage

Dim code() As Byte

Dim instance As New PDFType4Function(code)
public PDFType4Function(
   byte[] code
)
public: PDFType4Function(
   byte[]* code
)
public:
PDFType4Function(
   array<byte>^ code
)

Parameters

code
Postscript code for the function.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType4Function Class
PDFType4Function Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFType4Function Class Properties

O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class

For a list of all members of this type, see PDFType4Function members.

Public Properties
 | Name | Description
Public Property | Dictionary | Gets the function dictionary. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Range | Gets or sets the function range. (Inherited from O2S.Components.PDF4NET.Functions.PDFFunction)
Public Property | Stream | Get or sets the stream that represents the function's code.
Top
See Also

Reference

PDFType4Function Class
O2S.Components.PDF4NET.Functions Namespace


Stream Property (PDFType4Function)

O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class : Stream Property
Get or sets the stream that represents the function's code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Stream As Byte()
'Usage

Dim instance As PDFType4Function
Dim value() As Byte

instance.Stream = value

value = instance.Stream
public byte[] Stream {get; set;}
public: __property byte[]* get_Stream();
public: __property void set_Stream(
   byte[]* value
);
public:
property array<byte>^ Stream {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array that represents the function's code.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType4Function Class
PDFType4Function Members


%%PageItemTitle%%

InterpolationMode Enumeration

O2S.Components.PDF4NET.Functions Namespace : InterpolationMode Enumeration
Specifies the available interpolation modes for a type 0 function values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum InterpolationMode
   Inherits System.Enum
'Usage

Dim instance As InterpolationMode
public enum InterpolationMode : System.Enum
__value public enum InterpolationMode : public System.Enum
public enum class InterpolationMode : public System.Enum
Members
Member | Description
CubicSpline | Cubic spline interpolation.
Linear | Linear intepolation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Functions.InterpolationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Functions Namespace


O2S.Components.PDF4NET.Geo Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFCoordinateSystem | Defines the base class for coordinate systems.
Class | PDFGeographicCoordinateSystem | Defines a geographic coordinate system.
Class | PDFGeospatialMeasure | Defines a geospatial measure.
Class | PDFPointData | Defines a class that specifies extended data associated with points in the 2D space.
Class | PDFProjectedCoordinateSystem | Defines a projected coordinate system.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFCoordinateSystem Class
Members

O2S.Components.PDF4NET.Geo Namespace : PDFCoordinateSystem Class
Defines the base class for coordinate systems.
Object Model
PDFCoordinateSystem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFCoordinateSystem
'Usage

Dim instance As PDFCoordinateSystem
public abstract class PDFCoordinateSystem
public __gc abstract class PDFCoordinateSystem
public ref class PDFCoordinateSystem abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Geo.PDFCoordinateSystem
O2S.Components.PDF4NET.Geo.PDFGeographicCoordinateSystem
O2S.Components.PDF4NET.Geo.PDFProjectedCoordinateSystem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCoordinateSystem Members
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%% $$Members$$

PDFCoordinateSystem Class Members
Properties

O2S.Components.PDF4NET.Geo Namespace : PDFCoordinateSystem Class

The following tables list the members exposed by PDFCoordinateSystem.

Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code.
Public Property | WKT | Gets or sets the well known text.
Top
See Also

Reference

PDFCoordinateSystem Class
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%% $$Properties$$

PDFCoordinateSystem Class Properties

O2S.Components.PDF4NET.Geo Namespace : PDFCoordinateSystem Class

For a list of all members of this type, see PDFCoordinateSystem members.

Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code.
Public Property | WKT | Gets or sets the well known text.
Top
See Also

Reference

PDFCoordinateSystem Class
O2S.Components.PDF4NET.Geo Namespace


EPSG Property

O2S.Components.PDF4NET.Geo Namespace > PDFCoordinateSystem Class : EPSG Property
Gets or sets the EPSG code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EPSG As Integer
'Usage

Dim instance As PDFCoordinateSystem
Dim value As Integer

instance.EPSG = value

value = instance.EPSG
public int EPSG {get; set;}
public: __property int get_EPSG();
public: __property void set_EPSG(
   int value
);
public:
property int EPSG {
   int get();
   void set (    int value);
}

Property Value

An EPSG reference code specifying the geographic coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCoordinateSystem Class
PDFCoordinateSystem Members


WKT Property

O2S.Components.PDF4NET.Geo Namespace > PDFCoordinateSystem Class : WKT Property
Gets or sets the well known text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WKT As String
'Usage

Dim instance As PDFCoordinateSystem
Dim value As String

instance.WKT = value

value = instance.WKT
public string WKT {get; set;}
public: __property string* get_WKT();
public: __property void set_WKT(
   string* value
);
public:
property String^ WKT {
   String^ get();
   void set (    String^ value);
}

Property Value

A string of Well Known Text describing the geographic coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCoordinateSystem Class
PDFCoordinateSystem Members


%%PageItemTitle%%

PDFGeographicCoordinateSystem Class
Members

O2S.Components.PDF4NET.Geo Namespace : PDFGeographicCoordinateSystem Class
Defines a geographic coordinate system.
Object Model
PDFGeographicCoordinateSystem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGeographicCoordinateSystem
   Inherits PDFCoordinateSystem
'Usage

Dim instance As PDFGeographicCoordinateSystem
public class PDFGeographicCoordinateSystem : PDFCoordinateSystem
public __gc class PDFGeographicCoordinateSystem : public PDFCoordinateSystem
public ref class PDFGeographicCoordinateSystem : public PDFCoordinateSystem
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Geo.PDFCoordinateSystem
O2S.Components.PDF4NET.Geo.PDFGeographicCoordinateSystem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeographicCoordinateSystem Members
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%% $$Members$$

PDFGeographicCoordinateSystem Class Members
Properties

O2S.Components.PDF4NET.Geo Namespace : PDFGeographicCoordinateSystem Class

The following tables list the members exposed by PDFGeographicCoordinateSystem.

Public Constructors
 | Name | Description
Public Constructor | PDFGeographicCoordinateSystem Constructor | Initializes a new PDFGeographicCoordinateSystem object.
Top
Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code. (Inherited from O2S.Components.PDF4NET.Geo.PDFCoordinateSystem)
Public Property | WKT | Gets or sets the well known text. (Inherited from O2S.Components.PDF4NET.Geo.PDFCoordinateSystem)
Top
See Also

Reference

PDFGeographicCoordinateSystem Class
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%%

PDFGeographicCoordinateSystem Constructor

O2S.Components.PDF4NET.Geo Namespace > PDFGeographicCoordinateSystem Class : PDFGeographicCoordinateSystem Constructor
Initializes a new PDFGeographicCoordinateSystem object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFGeographicCoordinateSystem()
public PDFGeographicCoordinateSystem()
public: PDFGeographicCoordinateSystem();
public:
PDFGeographicCoordinateSystem();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeographicCoordinateSystem Class
PDFGeographicCoordinateSystem Members


%%PageItemTitle%%

PDFGeospatialMeasure Class
Members

O2S.Components.PDF4NET.Geo Namespace : PDFGeospatialMeasure Class
Defines a geospatial measure.
Object Model
PDFGeospatialMeasure ClassPDFPoint ClassPDFCoordinateSystem ClassPDFCoordinateSystem ClassPDFPoint ClassPDFPoint Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGeospatialMeasure
   Inherits O2S.Components.PDF4NET.Measures.PDFMeasure
'Usage

Dim instance As PDFGeospatialMeasure
public class PDFGeospatialMeasure : O2S.Components.PDF4NET.Measures.PDFMeasure
public __gc class PDFGeospatialMeasure : public O2S.Components.PDF4NET.Measures.PDFMeasure
public ref class PDFGeospatialMeasure : public O2S.Components.PDF4NET.Measures.PDFMeasure
Remarks
The geospatial measure defines the relationship between points or regions in the two dimensional PDF object space and points or regions with respect to an underlying model of the earth (or, potentially, other ellipsoid objects).
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Measures.PDFMeasure
O2S.Components.PDF4NET.Geo.PDFGeospatialMeasure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Members
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%% $$Members$$

PDFGeospatialMeasure Class Members
Properties

O2S.Components.PDF4NET.Geo Namespace : PDFGeospatialMeasure Class

The following tables list the members exposed by PDFGeospatialMeasure.

Public Constructors
 | Name | Description
Public Constructor | PDFGeospatialMeasure Constructor | Initializes a new PDFGeospatialMeasure object.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the bounds.
Public Property | CoordinateSystem | Gets or sets the coordinate system.
Public Property | DisplayCoordinateSystem | Gets or sets the display coordinate system.
Public Property | GeographicPoints | Gets or sets the geographic points.
Public Property | LocalPoints | Gets or sets the local points.
Public Property | PreferredDisplayUnitForAngles | Gets or sets the preferred display unit for angles.
Public Property | PreferredDisplayUnitForArea | Gets or sets the preferred display unit for area.
Public Property | PreferredDisplayUnitForDistance | Gets or sets the preferred display unit for distance.
Top
See Also

Reference

PDFGeospatialMeasure Class
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%%

PDFGeospatialMeasure Constructor

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : PDFGeospatialMeasure Constructor
Initializes a new PDFGeospatialMeasure object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFGeospatialMeasure()
public PDFGeospatialMeasure()
public: PDFGeospatialMeasure();
public:
PDFGeospatialMeasure();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


%%PageItemTitle%% $$Properties$$

PDFGeospatialMeasure Class Properties

O2S.Components.PDF4NET.Geo Namespace : PDFGeospatialMeasure Class

For a list of all members of this type, see PDFGeospatialMeasure members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the bounds.
Public Property | CoordinateSystem | Gets or sets the coordinate system.
Public Property | DisplayCoordinateSystem | Gets or sets the display coordinate system.
Public Property | GeographicPoints | Gets or sets the geographic points.
Public Property | LocalPoints | Gets or sets the local points.
Public Property | PreferredDisplayUnitForAngles | Gets or sets the preferred display unit for angles.
Public Property | PreferredDisplayUnitForArea | Gets or sets the preferred display unit for area.
Public Property | PreferredDisplayUnitForDistance | Gets or sets the preferred display unit for distance.
Top
See Also

Reference

PDFGeospatialMeasure Class
O2S.Components.PDF4NET.Geo Namespace


Bounds Property (PDFGeospatialMeasure)

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : Bounds Property
Gets or sets the bounds.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Bounds As PDFPoint()
'Usage

Dim instance As PDFGeospatialMeasure
Dim value() As PDFPoint

instance.Bounds = value

value = instance.Bounds
public PDFPoint[] Bounds {get; set;}
public: __property PDFPoint*[]* get_Bounds();
public: __property void set_Bounds(
   PDFPoint*[]* value
);
public:
property array<PDFPoint^>^ Bounds {
   array<PDFPoint^>^ get();
   void set (    array<PDFPoint^>^ value);
}

Property Value

An array of points that describes the bounds of an area for which geospatial transformations are valid.
Remarks
For maps, this bounding polygon is known as a neatline. These points are expressed relative to a unit square that describes the bounds associated with a O2S.Components.PDF4NET.Measures.PDFViewport, O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject or O2S.Components.PDF4NET.Graphics.Shapes.PDFImage.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


CoordinateSystem Property

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : CoordinateSystem Property
Gets or sets the coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CoordinateSystem As PDFCoordinateSystem
'Usage

Dim instance As PDFGeospatialMeasure
Dim value As PDFCoordinateSystem

instance.CoordinateSystem = value

value = instance.CoordinateSystem
public PDFCoordinateSystem CoordinateSystem {get; set;}
public: __property PDFCoordinateSystem* get_CoordinateSystem();
public: __property void set_CoordinateSystem(
   PDFCoordinateSystem* value
);
public:
property PDFCoordinateSystem^ CoordinateSystem {
   PDFCoordinateSystem^ get();
   void set (    PDFCoordinateSystem^ value);
}

Property Value

A projected or geographic coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


DisplayCoordinateSystem Property

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : DisplayCoordinateSystem Property
Gets or sets the display coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayCoordinateSystem As PDFCoordinateSystem
'Usage

Dim instance As PDFGeospatialMeasure
Dim value As PDFCoordinateSystem

instance.DisplayCoordinateSystem = value

value = instance.DisplayCoordinateSystem
public PDFCoordinateSystem DisplayCoordinateSystem {get; set;}
public: __property PDFCoordinateSystem* get_DisplayCoordinateSystem();
public: __property void set_DisplayCoordinateSystem(
   PDFCoordinateSystem* value
);
public:
property PDFCoordinateSystem^ DisplayCoordinateSystem {
   PDFCoordinateSystem^ get();
   void set (    PDFCoordinateSystem^ value);
}

Property Value

A projected or geographic coordinate system that shall be used for the display of position values, such as latitude and longitude.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


GeographicPoints Property

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : GeographicPoints Property
Gets or sets the geographic points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GeographicPoints As PDFPoint()
'Usage

Dim instance As PDFGeospatialMeasure
Dim value() As PDFPoint

instance.GeographicPoints = value

value = instance.GeographicPoints
public PDFPoint[] GeographicPoints {get; set;}
public: __property PDFPoint*[]* get_GeographicPoints();
public: __property void set_GeographicPoints(
   PDFPoint*[]* value
);
public:
property array<PDFPoint^>^ GeographicPoints {
   array<PDFPoint^>^ get();
   void set (    array<PDFPoint^>^ value);
}

Property Value

An array of points in geographic space as degrees of latitude and longitude.
Remarks
These values shall be based on the geographic coordinate system described CoordinateSystem.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


LocalPoints Property

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : LocalPoints Property
Gets or sets the local points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LocalPoints As PDFPoint()
'Usage

Dim instance As PDFGeospatialMeasure
Dim value() As PDFPoint

instance.LocalPoints = value

value = instance.LocalPoints
public PDFPoint[] LocalPoints {get; set;}
public: __property PDFPoint*[]* get_LocalPoints();
public: __property void set_LocalPoints(
   PDFPoint*[]* value
);
public:
property array<PDFPoint^>^ LocalPoints {
   array<PDFPoint^>^ get();
   void set (    array<PDFPoint^>^ value);
}

Property Value

An array of points in a 2D unit square.
Remarks
The unit square is mapped to the rectangular bounds of the O2S.Components.PDF4NET.Measures.PDFViewport, O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject or O2S.Components.PDF4NET.Graphics.Shapes.PDFImage that contains the measure object.
This array shall contain the same number of points as the GeographicPoints array; each point is the unit square object position corresponding to the geospatial position in the GeographicPoints array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


PreferredDisplayUnitForAngles Property

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : PreferredDisplayUnitForAngles Property
Gets or sets the preferred display unit for angles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PreferredDisplayUnitForAngles As String
'Usage

Dim instance As PDFGeospatialMeasure
Dim value As String

instance.PreferredDisplayUnitForAngles = value

value = instance.PreferredDisplayUnitForAngles
public string PreferredDisplayUnitForAngles {get; set;}
public: __property string* get_PreferredDisplayUnitForAngles();
public: __property void set_PreferredDisplayUnitForAngles(
   string* value
);
public:
property String^ PreferredDisplayUnitForAngles {
   String^ get();
   void set (    String^ value);
}

Property Value

The preferred display unit for angles.
Remarks
The following values are supported: DEG - Degree; GRD - Grad.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


PreferredDisplayUnitForArea Property

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : PreferredDisplayUnitForArea Property
Gets or sets the preferred display unit for area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PreferredDisplayUnitForArea As String
'Usage

Dim instance As PDFGeospatialMeasure
Dim value As String

instance.PreferredDisplayUnitForArea = value

value = instance.PreferredDisplayUnitForArea
public string PreferredDisplayUnitForArea {get; set;}
public: __property string* get_PreferredDisplayUnitForArea();
public: __property void set_PreferredDisplayUnitForArea(
   string* value
);
public:
property String^ PreferredDisplayUnitForArea {
   String^ get();
   void set (    String^ value);
}

Property Value

The preferred display unit for area.
Remarks
The following values are supported: SQM - Square Metre; HA - Hectare; SQKM - Square Kilometre; SQFT - Square US Foot; A - Acre; SQMI - Square Mile.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


PreferredDisplayUnitForDistance Property

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : PreferredDisplayUnitForDistance Property
Gets or sets the preferred display unit for distance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PreferredDisplayUnitForDistance As String
'Usage

Dim instance As PDFGeospatialMeasure
Dim value As String

instance.PreferredDisplayUnitForDistance = value

value = instance.PreferredDisplayUnitForDistance
public string PreferredDisplayUnitForDistance {get; set;}
public: __property string* get_PreferredDisplayUnitForDistance();
public: __property void set_PreferredDisplayUnitForDistance(
   string* value
);
public:
property String^ PreferredDisplayUnitForDistance {
   String^ get();
   void set (    String^ value);
}

Property Value

The preferred display unit for distance.
Remarks
The following values are supported: M - Metre; KM - Kilometre; FT - Foot; USFT - US Foot; MI - Mile, NM - Nautical Mile.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


%%PageItemTitle%%

PDFPointData Class
Members

O2S.Components.PDF4NET.Geo Namespace : PDFPointData Class
Defines a class that specifies extended data associated with points in the 2D space.
Object Model
PDFPointData Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPointData
'Usage

Dim instance As PDFPointData
public class PDFPointData
public __gc class PDFPointData
public ref class PDFPointData
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Geo.PDFPointData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointData Members
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%% $$Members$$

PDFPointData Class Members
Properties

O2S.Components.PDF4NET.Geo Namespace : PDFPointData Class

The following tables list the members exposed by PDFPointData.

Public Constructors
 | Name | Description
Public Constructor | PDFPointData Constructor | Initializes a new PDFPointData object.
Top
Public Properties
 | Name | Description
Public Property | ExtendedPoints | Gets or sets the extended points.
Public Property | PointTypes | Gets or sets the point types.
Top
See Also

Reference

PDFPointData Class
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%%

PDFPointData Constructor

O2S.Components.PDF4NET.Geo Namespace > PDFPointData Class : PDFPointData Constructor
Initializes a new PDFPointData object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPointData()
public PDFPointData()
public: PDFPointData();
public:
PDFPointData();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointData Class
PDFPointData Members


%%PageItemTitle%% $$Properties$$

PDFPointData Class Properties

O2S.Components.PDF4NET.Geo Namespace : PDFPointData Class

For a list of all members of this type, see PDFPointData members.

Public Properties
 | Name | Description
Public Property | ExtendedPoints | Gets or sets the extended points.
Public Property | PointTypes | Gets or sets the point types.
Top
See Also

Reference

PDFPointData Class
O2S.Components.PDF4NET.Geo Namespace


ExtendedPoints Property

O2S.Components.PDF4NET.Geo Namespace > PDFPointData Class : ExtendedPoints Property
Gets or sets the extended points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtendedPoints As Double()
'Usage

Dim instance As PDFPointData
Dim value() As Double

instance.ExtendedPoints = value

value = instance.ExtendedPoints
public double[] ExtendedPoints {get; set;}
public: __property double[]* get_ExtendedPoints();
public: __property void set_ExtendedPoints(
   double[]* value
);
public:
property array<double>^ ExtendedPoints {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of arrays of values.
Remarks
The number of elements in each interior array shall correspond to the size of the PointTypes array; each element in the interior arrays is of a type defined by the corresponding name in the PointTypes array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointData Class
PDFPointData Members


PointTypes Property

O2S.Components.PDF4NET.Geo Namespace > PDFPointData Class : PointTypes Property
Gets or sets the point types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PointTypes As String()
'Usage

Dim instance As PDFPointData
Dim value() As String

instance.PointTypes = value

value = instance.PointTypes
public string[] PointTypes {get; set;}
public: __property string*[]* get_PointTypes();
public: __property void set_PointTypes(
   string*[]* value
);
public:
property array<String^>^ PointTypes {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

An array of names that identify the internal data elements of the individual point arrays in the ExtendedPoints array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointData Class
PDFPointData Members


%%PageItemTitle%%

PDFProjectedCoordinateSystem Class
Members

O2S.Components.PDF4NET.Geo Namespace : PDFProjectedCoordinateSystem Class
Defines a projected coordinate system.
Object Model
PDFProjectedCoordinateSystem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFProjectedCoordinateSystem
   Inherits PDFCoordinateSystem
'Usage

Dim instance As PDFProjectedCoordinateSystem
public class PDFProjectedCoordinateSystem : PDFCoordinateSystem
public __gc class PDFProjectedCoordinateSystem : public PDFCoordinateSystem
public ref class PDFProjectedCoordinateSystem : public PDFCoordinateSystem
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Geo.PDFCoordinateSystem
O2S.Components.PDF4NET.Geo.PDFProjectedCoordinateSystem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFProjectedCoordinateSystem Members
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%% $$Members$$

PDFProjectedCoordinateSystem Class Members
Properties

O2S.Components.PDF4NET.Geo Namespace : PDFProjectedCoordinateSystem Class

The following tables list the members exposed by PDFProjectedCoordinateSystem.

Public Constructors
 | Name | Description
Public Constructor | PDFProjectedCoordinateSystem Constructor | Initializes a new PDFProjectedCoordinateSystem object.
Top
Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code. (Inherited from O2S.Components.PDF4NET.Geo.PDFCoordinateSystem)
Public Property | WKT | Gets or sets the well known text. (Inherited from O2S.Components.PDF4NET.Geo.PDFCoordinateSystem)
Top
See Also

Reference

PDFProjectedCoordinateSystem Class
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%%

PDFProjectedCoordinateSystem Constructor

O2S.Components.PDF4NET.Geo Namespace > PDFProjectedCoordinateSystem Class : PDFProjectedCoordinateSystem Constructor
Initializes a new PDFProjectedCoordinateSystem object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFProjectedCoordinateSystem()
public PDFProjectedCoordinateSystem()
public: PDFProjectedCoordinateSystem();
public:
PDFProjectedCoordinateSystem();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFProjectedCoordinateSystem Class
PDFProjectedCoordinateSystem Members


O2S.Components.PDF4NET.Graphics Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFAxialShadingPattern | Defines a PDF shading pattern.
Class | PDFBasicCanvas | Encapsulates a drawing surface.
Class | PDFBrush | Defines an object used to fill a closed shape with a single color.
Class | PDFCalGrayColor | Defines a calibrated gray color, based on a CalGray colorspace.
Class | PDFCalRgbColor | Defines a calibrated RGB color, based on a CalRGB colorspace.
Class | PDFCanvas | Encapsulates a page's drawing surface. Supported by Compact .NET Edition.
Class | PDFCMLogicalUnit | Defines the centimeter as a logical unit.
Class | PDFCmykColor | Defines a CMYK color, a color based on a CMYK device colorspace.
Class | PDFColor | Defines the base class for all PDF colors.
Class | PDFCosObjectParamOperator | Defines a PDF graphic operator that has an array of COS objects as parameters.
Class | PDFDeviceColor | Defines a device based color.
Class | PDFDeviceNColor | Defines a DeviceN color, based on a DeviceN colorspace.
Class | PDFExtendedGraphicState | Defines the current graphic state in a PDF content stream.
Class | PDFGraphicOperator | Defines a PDF operator used in a graphic content stream.
Class | PDFGraphicOperatorCollection | Defines a read only collection of PDFGraphicOperator objects.
Class | PDFGrayColor | Defines a Gray color, a color based on a Gray device colorspace.
Class | PDFHatchBrush | Defines a hatch brush for filling closed shapes.
Class | PDFHatchPattern | Defines a PDF hatch pattern.
Class | PDFHorizontalGradientBrush | Defines a horizontal gradient brush for filling closed shapes.
Class | PDFICCColor | Defines an ICC color, based on an ICC colorspace.
Class | PDFInchLogicalUnit | Defines the inch as a logical unit.
Class | PDFIndexedColor | Defines an indexed color, based on an indexed colorspace.
Class | PDFLabColor | Defines a calibrated Lab color, based on a Lab colorspace.
Class | PDFLayer | Defines a layer on a page's canvas.
Class | PDFLayerCollection | Defines a collection of PDF layers.
Class | PDFLinearGradientBrush | Defines a hatch brush for filling closed shapes.
Class | PDFLinearGradientPattern | Defines a pattern that represents a linear gradient.
Class | PDFLogicalUnitBase | Base class for all the classes that implement custom logical units.
Class | PDFMatrix | Defines a tranformation matrix in the PDF content stream.
Class | PDFMMLogicalUnit | Defines the millimeter as a logical unit.
Class | PDFNumericParamOperator | Defines a PDF graphic operator that has an array of numbers as parameters.
Class | PDFPattern | Defines the base class for all PDF patterns.
Class | PDFPen | Defines an object used to draw lines and curves. This class cannot be inherited. Supported by Compact .NET Edition.
Class | PDFPointLogicalUnit | Defines the point (pdf unit) as a logical unit.
Class | PDFRgbColor | Defines a RGB color, a color based on a RGB device colorspace.
Class | PDFSeparationColor | Defines an separation color, based on a separation colorspace.
Class | PDFShadingPattern | Defines a PDF shading pattern.
Class | PDFShadingPatternColor | Defines a special color based on a shading pattern.
Class | PDFTilingPattern | Defines a PDF tiling pattern.
Class | PDFTilingPatternColor | Defines a special color based on a tiling pattern.
Class | PDFVerticalGradientBrush | Defines a vertical gradient brush for filling closed shapes.
Enumerations
 | Enumeration | Description
Enumeration | PDFBlendMode | Specifies the available blend modes.
Enumeration | PDFContentMirroring | Specifies the available mirroring options when drawing graphic content.
Enumeration | PDFDashStyle | Specifies the style of dashed lines drawn with a PDFPen object.
Enumeration | PDFFillMode | Specifies the available fill modes for a complex shape.
Enumeration | PDFHatchType | Specifies the available types for hatch brushes.
Enumeration | PDFLineCap | Specifies the available cap styles with which a Pen object can begin or end a line.
Enumeration | PDFLineJoin | Specifies how to join consecutive line or curve segments
Enumeration | PDFPaddingGlyph | Specifies the available options for padding glyphs in PDFBasicCanvas.DrawGlyphs method.
Enumeration | PDFTextAlign | Specifies the available alignments for text lines.
Enumeration | PDFXAxisDirection | Specifies the available directions for the X axis of the page canvas.
Enumeration | PDFYAxisDirection | Specifies the available directions for the Y axis of the page canvas.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFAxialShadingPattern Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFAxialShadingPattern Class
Defines a PDF shading pattern.
Object Model
PDFAxialShadingPattern ClassPDFColorSpace ClassPDFFunction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAxialShadingPattern
   Inherits PDFShadingPattern
'Usage

Dim instance As PDFAxialShadingPattern
public class PDFAxialShadingPattern : PDFShadingPattern
public __gc class PDFAxialShadingPattern : public PDFShadingPattern
public ref class PDFAxialShadingPattern : public PDFShadingPattern
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern
O2S.Components.PDF4NET.Graphics.PDFLinearGradientPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShadingPattern Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFAxialShadingPattern Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFAxialShadingPattern Class

The following tables list the members exposed by PDFAxialShadingPattern.

Public Constructors
 | Name | Description
Public Constructor | PDFAxialShadingPattern Constructor | Initializes a new PDFAxialShadingPattern object.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the shading's colorspace.
Public Property | Coordinates | Gets or sets the shading coordinates.
Public Property | Function | Gets or sets the function that defines the axial shading.
Top
See Also

Reference

PDFAxialShadingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFAxialShadingPattern Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFAxialShadingPattern Class : PDFAxialShadingPattern Constructor
Initializes a new PDFAxialShadingPattern object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFAxialShadingPattern()
public PDFAxialShadingPattern()
public: PDFAxialShadingPattern();
public:
PDFAxialShadingPattern();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShadingPattern Class
PDFAxialShadingPattern Members


%%PageItemTitle%% $$Properties$$

PDFAxialShadingPattern Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFAxialShadingPattern Class

For a list of all members of this type, see PDFAxialShadingPattern members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the shading's colorspace.
Public Property | Coordinates | Gets or sets the shading coordinates.
Public Property | Function | Gets or sets the function that defines the axial shading.
Top
See Also

Reference

PDFAxialShadingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


ColorSpace Property (PDFAxialShadingPattern)

O2S.Components.PDF4NET.Graphics Namespace > PDFAxialShadingPattern Class : ColorSpace Property
Gets or sets the shading's colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorSpace As PDFColorSpace
'Usage

Dim instance As PDFAxialShadingPattern
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public PDFColorSpace ColorSpace {get; set;}
public: __property PDFColorSpace* get_ColorSpace();
public: __property void set_ColorSpace(
   PDFColorSpace* value
);
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The color space in which color values are expressed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShadingPattern Class
PDFAxialShadingPattern Members


Coordinates Property

O2S.Components.PDF4NET.Graphics Namespace > PDFAxialShadingPattern Class : Coordinates Property
Gets or sets the shading coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Coordinates As Double()
'Usage

Dim instance As PDFAxialShadingPattern
Dim value() As Double

instance.Coordinates = value

value = instance.Coordinates
public double[] Coordinates {get; set;}
public: __property double[]* get_Coordinates();
public: __property void set_Coordinates(
   double[]* value
);
public:
property array<double>^ Coordinates {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of four numbers [ x0 y0 x1 y1 ] specifying the starting and ending coordinates of the axis, expressed in the shading's target coordinate space.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShadingPattern Class
PDFAxialShadingPattern Members


Function Property (PDFAxialShadingPattern)

O2S.Components.PDF4NET.Graphics Namespace > PDFAxialShadingPattern Class : Function Property
Gets or sets the function that defines the axial shading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Function As PDFFunction
'Usage

Dim instance As PDFAxialShadingPattern
Dim value As PDFFunction

instance.Function = value

value = instance.Function
public PDFFunction Function {get; set;}
public: __property PDFFunction* get_Function();
public: __property void set_Function(
   PDFFunction* value
);
public:
property PDFFunction^ Function {
   PDFFunction^ get();
   void set (    PDFFunction^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShadingPattern Class
PDFAxialShadingPattern Members


%%PageItemTitle%%

PDFBasicCanvas Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFBasicCanvas Class
Encapsulates a drawing surface.
Object Model
PDFBasicCanvas Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFBasicCanvas
'Usage

Dim instance As PDFBasicCanvas
public class PDFBasicCanvas
public __gc class PDFBasicCanvas
public ref class PDFBasicCanvas
Remarks
This class is used to create the content of a standalone drawing.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBasicCanvas
O2S.Components.PDF4NET.Graphics.PDFCanvas

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFBasicCanvas Class Members
Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFBasicCanvas Class

The following tables list the members exposed by PDFBasicCanvas.

Public Methods
 | Name | Description
Public Method | Clear | Clears the canvas content.
Public Method | DrawArc | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas.
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four System.Drawing.PointF structures.
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Public Method | DrawDirect | Overloaded. Writes the buffer to the page content stream.
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height.
Public Method | DrawGlyphs | Draws a series of glyphs.
Public Method | DrawGraphicOperator | Draws the graphic operator on the canvas.
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height.
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition.
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of System.Drawing.PointF structures.
Public Method | DrawPath | Overloaded. Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen.
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of System.Drawing.PointF structures.
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects.
Public Method | DrawPolyPolygon | Overloaded.
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawShading | Draws the shading on the page.
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | FitHtmlText | Overloaded. Calculates how much of the text really fits in the box.
Public Method | FitText | Overloaded. Calculates how much of the given text fits in the given area.
Public Method | GetHtmlTextBoxHeight | Overloaded. Gets the height of the wrapped HTML text.
Public Method | GetHtmlTextBoxLastLineWidth | Overloaded. Gets the width of the last line in the HTML text box.
Public Method | GetTextBoxHeight | Overloaded. Gets the height of the wrapped text.
Public Method | GetTextBoxLastLineWidth | Gets the width of the last line in the text box.
Public Method | MultiplyTransform | Multiplies the current transformation matrix with the one given as parameter.
Public Method | ResetClipRegion | Resets the current clipping region to previous clip region.
Public Method | ResetCoordinateSystem | Resets the coordinate system to the default PDF coordinate system.
Public Method | RestoreGraphicState | Restores the current graphic state in the PDF content stream.
Public Method | RotateTransform | Applies a rotate transformation to current transformation matrix.
Public Method | SaveGraphicState | Saves the current graphic state in the PDF content stream.
Public Method | ScaleTransform | Applies a scale transformation to current transformation matrix.
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system.
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations.
Public Method | SetCharSpace | Sets the character spacing.
Public Method | SetClipRegion | Overloaded. Sets a clipping region on page's canvas.
Public Method | SetExtendedGraphicState | Sets the current graphic state in the content stream.
Public Method | SetHorizontalScaling | Sets the horizontal scaling.
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations.
Public Method | SetOrigin | Sets the new point of origin for the coordinate system.
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations.
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations.
Public Method | SetupCoordinateSystem | Sets the coordinate system to top left corner.
Public Method | SetWordSpace | Sets the word spacing.
Public Method | ToString | Gets the string representation of this object.
Public Method | TranslateTransform | Applies a translate transformation to current transformation matrix.
Top
See Also

Reference

PDFBasicCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PDFBasicCanvas Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFBasicCanvas Class

For a list of all members of this type, see PDFBasicCanvas members.

Public Methods
 | Name | Description
Public Method | Clear | Clears the canvas content.
Public Method | DrawArc | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas.
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four System.Drawing.PointF structures.
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Public Method | DrawDirect | Overloaded. Writes the buffer to the page content stream.
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height.
Public Method | DrawGlyphs | Draws a series of glyphs.
Public Method | DrawGraphicOperator | Draws the graphic operator on the canvas.
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height.
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition.
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of System.Drawing.PointF structures.
Public Method | DrawPath | Overloaded. Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen.
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of System.Drawing.PointF structures.
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects.
Public Method | DrawPolyPolygon | Overloaded.
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawShading | Draws the shading on the page.
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | FitHtmlText | Overloaded. Calculates how much of the text really fits in the box.
Public Method | FitText | Overloaded. Calculates how much of the given text fits in the given area.
Public Method | GetHtmlTextBoxHeight | Overloaded. Gets the height of the wrapped HTML text.
Public Method | GetHtmlTextBoxLastLineWidth | Overloaded. Gets the width of the last line in the HTML text box.
Public Method | GetTextBoxHeight | Overloaded. Gets the height of the wrapped text.
Public Method | GetTextBoxLastLineWidth | Gets the width of the last line in the text box.
Public Method | MultiplyTransform | Multiplies the current transformation matrix with the one given as parameter.
Public Method | ResetClipRegion | Resets the current clipping region to previous clip region.
Public Method | ResetCoordinateSystem | Resets the coordinate system to the default PDF coordinate system.
Public Method | RestoreGraphicState | Restores the current graphic state in the PDF content stream.
Public Method | RotateTransform | Applies a rotate transformation to current transformation matrix.
Public Method | SaveGraphicState | Saves the current graphic state in the PDF content stream.
Public Method | ScaleTransform | Applies a scale transformation to current transformation matrix.
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system.
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations.
Public Method | SetCharSpace | Sets the character spacing.
Public Method | SetClipRegion | Overloaded. Sets a clipping region on page's canvas.
Public Method | SetExtendedGraphicState | Sets the current graphic state in the content stream.
Public Method | SetHorizontalScaling | Sets the horizontal scaling.
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations.
Public Method | SetOrigin | Sets the new point of origin for the coordinate system.
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations.
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations.
Public Method | SetupCoordinateSystem | Sets the coordinate system to top left corner.
Public Method | SetWordSpace | Sets the word spacing.
Public Method | ToString | Gets the string representation of this object.
Public Method | TranslateTransform | Applies a translate transformation to current transformation matrix.
Top
See Also

Reference

PDFBasicCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


Clear Method (PDFBasicCanvas)

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : Clear Method
Clears the canvas content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As PDFBasicCanvas

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawArc Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawArc Method
a PDFPen object used to draw the border of the arc.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DrawArc( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawArc(pen, left, top, width, height, startAngle, sweepAngle)
public void DrawArc(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public: void DrawArc(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawArc(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the arc.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawBarcode Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawBarcode Method
Draws the barcode on the canvas.
Overload List
Overload | Description
DrawBarcode(PDFBarcode) | Draws the barcode on the canvas.
DrawBarcode(PDFBarcode,Double,Double) | Draws the barcode on the canvas at the specified position.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawBarcode(PDFBarcode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBarcode Method : DrawBarcode(PDFBarcode) Method
A O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode descendant object.
Draws the barcode on the canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawBarcode( _
   ByVal barcode As PDFBarcode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim barcode As PDFBarcode

instance.DrawBarcode(barcode)
public void DrawBarcode(
   PDFBarcode barcode
)
public: void DrawBarcode(
   PDFBarcode* barcode
)
public:
void DrawBarcode(
   PDFBarcode^ barcode
)

Parameters

barcode
A O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode descendant object.
Remarks
This method draws the given barcode on the canvas. The position of the barcode is given by the barcode's properties O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode.Left, O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode.Top, O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode.Width and O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode.Height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawBarcode(PDFBarcode,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBarcode Method : DrawBarcode(PDFBarcode,Double,Double) Method
A O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode descendant object.
The X coordinate of the top left corner of barcode's bounding rectangle.
The Y coordinate of the top left corner of barcode's bounding rectangle.
Draws the barcode on the canvas at the specified position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawBarcode( _
   ByVal barcode As PDFBarcode, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim barcode As PDFBarcode
Dim left As Double
Dim top As Double

instance.DrawBarcode(barcode, left, top)
public void DrawBarcode(
   PDFBarcode barcode,
   double left,
   double top
)
public: void DrawBarcode(
   PDFBarcode* barcode,
   double left,
   double top
)
public:
void DrawBarcode(
   PDFBarcode^ barcode,
   double left,
   double top
)

Parameters

barcode
A O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode descendant object.
left
The X coordinate of the top left corner of barcode's bounding rectangle.
top
The Y coordinate of the top left corner of barcode's bounding rectangle.
Remarks
This method draws the given barcode on the canvas. The barcode's properties O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode.Left, O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode.Top, O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode.Width and O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode.Height are ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawBezier Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawBezier Method
Draws a Bezier spline specified by four System.Drawing.PointF structures.
Overload List
Overload | Description
DrawBezier(PDFPen,PointF,PointF,PointF,PointF) | Draws a Bezier spline specified by four System.Drawing.PointF structures.
DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) | Draws a Bezier spline specified by four O2S.Components.PDF4NET.PDFPoint objects.
DrawBezier(PDFPen,Double,Double,Double,Double,Double,Double,Double,Double) | Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawBezier(PDFPen,PointF,PointF,PointF,PointF) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBezier Method : DrawBezier(PDFPen,PointF,PointF,PointF,PointF) Method
a PDFPen object used to draw the Bezier spline.
the first control point
the second control point
the third control point
the fourth control point
Draws a Bezier spline specified by four System.Drawing.PointF structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawBezier( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF, _
   ByVal pt3 As PointF, _
   ByVal pt4 As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PointF
Dim pt2 As PointF
Dim pt3 As PointF
Dim pt4 As PointF

instance.DrawBezier(pen, pt1, pt2, pt3, pt4)
public void DrawBezier(
   PDFPen pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
)
public: void DrawBezier(
   PDFPen* pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
)
public:
void DrawBezier(
   PDFPen^ pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
)

Parameters

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBezier Method : DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) Method
a PDFPen object used to draw the Bezier spline.
the first control point
the second control point
the third control point
the fourth control point
Draws a Bezier spline specified by four O2S.Components.PDF4NET.PDFPoint objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawBezier( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PDFPoint, _
   ByVal pt2 As PDFPoint, _
   ByVal pt3 As PDFPoint, _
   ByVal pt4 As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PDFPoint
Dim pt2 As PDFPoint
Dim pt3 As PDFPoint
Dim pt4 As PDFPoint

instance.DrawBezier(pen, pt1, pt2, pt3, pt4)
public void DrawBezier(
   PDFPen pen,
   PDFPoint pt1,
   PDFPoint pt2,
   PDFPoint pt3,
   PDFPoint pt4
)
public: void DrawBezier(
   PDFPen* pen,
   PDFPoint* pt1,
   PDFPoint* pt2,
   PDFPoint* pt3,
   PDFPoint* pt4
)
public:
void DrawBezier(
   PDFPen^ pen,
   PDFPoint^ pt1,
   PDFPoint^ pt2,
   PDFPoint^ pt3,
   PDFPoint^ pt4
)

Parameters

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawBezier(PDFPen,Double,Double,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBezier Method : DrawBezier(PDFPen,Double,Double,Double,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the Bezier spline.
the x coordinate of the first control point.
the y coordinate of the first control point.
the x coordinate of the second control point.
the y coordinate of the second control point.
the x coordinate of the third control point.
the y coordinate of the third control point.
the x coordinate of the fourth control point.
the y coordinate of the fourth control point.
Draws a Bezier spline specified by four pairs of coordinates.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawBezier( _
   ByVal pen As PDFPen, _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double, _
   ByVal x4 As Double, _
   ByVal y4 As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double
Dim x4 As Double
Dim y4 As Double

instance.DrawBezier(pen, x1, y1, x2, y2, x3, y3, x4, y4)
public void DrawBezier(
   PDFPen pen,
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3,
   double x4,
   double y4
)
public: void DrawBezier(
   PDFPen* pen,
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3,
   double x4,
   double y4
)
public:
void DrawBezier(
   PDFPen^ pen,
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3,
   double x4,
   double y4
)

Parameters

pen
a PDFPen object used to draw the Bezier spline.
x1
the x coordinate of the first control point.
y1
the y coordinate of the first control point.
x2
the x coordinate of the second control point.
y2
the y coordinate of the second control point.
x3
the x coordinate of the third control point.
y3
the y coordinate of the third control point.
x4
the x coordinate of the fourth control point.
y4
the y coordinate of the fourth control point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawChord Method
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Overload List
Overload | Description
DrawChord(PDFPen,Double,Double,Double,Double,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PDFPen,RectangleF,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a System.Drawing.RectangleF structure.
DrawChord(PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PDFBrush,RectangleF,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a System.Drawing.RectangleF structure.
DrawChord(PDFPen,PDFBrush,RectangleF,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a System.Drawing.RectangleF structure.
DrawChord(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawChord(PDFPen,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,Double,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the pie.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, left, top, width, height, startAngle, sweepAngle)
public void DrawChord(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public: void DrawChord(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawChord(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Remarks
The height of the bounding rectangle is always equal to the width of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFPen,RectangleF,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,RectangleF,Double,Double) Method
a PDFPen object used to draw the border of the chord.
a System.Drawing.RectangleF structure specifying the bounding rectangle of the chord.
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, rect, startAngle, sweepAngle)
public void DrawChord(
   PDFPen pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public: void DrawChord(
   PDFPen* pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public:
void DrawChord(
   PDFPen^ pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the chord.
rect
a System.Drawing.RectangleF structure specifying the bounding rectangle of the chord.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFBrush,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFBrush,Double,Double,Double,Double,Double,Double) Method
a PDFBrush object used to fill the interior of the chord.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(brush, left, top, width, height, startAngle, sweepAngle)
public void DrawChord(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public: void DrawChord(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawChord(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the chord.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFBrush,RectangleF,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFBrush,RectangleF,Double,Double) Method
a PDFBrush object used to fill the interior of the chord.
a System.Drawing.RectangleF structure specifying the bounding rectangle of the chord.
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(brush, rect, startAngle, sweepAngle)
public void DrawChord(
   PDFBrush brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public: void DrawChord(
   PDFBrush* brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public:
void DrawChord(
   PDFBrush^ brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the chord.
rect
a System.Drawing.RectangleF structure specifying the bounding rectangle of the chord.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFPen,PDFBrush,RectangleF,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,PDFBrush,RectangleF,Double,Double) Method
a PDFPen object used to draw the border of the chord.
a PDFBrush object used to fill the interior of the chord.
a System.Drawing.RectangleF structure specifying the bounding rectangle of the circle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, brush, rect, startAngle, sweepAngle)
public void DrawChord(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public: void DrawChord(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public:
void DrawChord(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the chord.
brush
a PDFBrush object used to fill the interior of the chord.
rect
a System.Drawing.RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the pie.
a PDFBrush object used to fill the interior of the pie.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, brush, left, top, width, height, startAngle, sweepAngle)
public void DrawChord(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public: void DrawChord(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawChord(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawDirect Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawDirect Method
Writes the buffer to the page content stream.
Overload List
Overload | Description
DrawDirect(Byte[]) | Writes the buffer to the page content stream.
DrawDirect(Byte[],Int32,Int32) | Writes the specifies sequence of bytes to the page content stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawDirect(Byte[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawDirect Method : DrawDirect(Byte[]) Method
Source buffer
Writes the buffer to the page content stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawDirect( _
   ByVal buffer() As Byte _
)
'Usage

Dim instance As PDFBasicCanvas
Dim buffer() As Byte

instance.DrawDirect(buffer)
public void DrawDirect(
   byte[] buffer
)
public: void DrawDirect(
   byte[]* buffer
)
public:
void DrawDirect(
   array<byte>^ buffer
)

Parameters

buffer
Source buffer
Remarks
The method writes the buffer to the page content stream without verifying the validity of the buffer content. If the buffer contains invalid content, the page might not be rendered properly.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawDirect(Byte[],Int32,Int32) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawDirect Method : DrawDirect(Byte[],Int32,Int32) Method
Source buffer
Offset where sequence starts
Number of bytes in the sequence
Writes the specifies sequence of bytes to the page content stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawDirect( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As PDFBasicCanvas
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.DrawDirect(buffer, offset, count)
public void DrawDirect(
   byte[] buffer,
   int offset,
   int count
)
public: void DrawDirect(
   byte[]* buffer,
   int offset,
   int count
)
public:
void DrawDirect(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
Source buffer
offset
Offset where sequence starts
count
Number of bytes in the sequence
Remarks
The method writes the specified sequence of bytes to the page content stream without verifying the validity of the buffer content. If the buffer contains invalid content, the page might not be rendered properly.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawEllipse Method
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Overload List
Overload | Description
DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFPen,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFPen,Double,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFPen,RectangleF) | Draws an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
DrawEllipse(PDFBrush,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFBrush,Double,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFBrush,RectangleF) | Draws an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
DrawEllipse(PDFPen,PDFBrush,RectangleF) | Draws an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the ellipse.
a PDFBrush object used to fill the interior of the ellipse.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawEllipse(pen, brush, left, top, width, height)
public void DrawEllipse(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
public: void DrawEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the ellipse.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawEllipse(pen, left, top, width, height)
public void DrawEllipse(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height
)
public: void DrawEllipse(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawEllipse(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the ellipse.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
rotation angle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawEllipse(pen, left, top, width, height, orientation)
public void DrawEllipse(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawEllipse(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawEllipse(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
rotation angle of the ellipse.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,RectangleF) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,RectangleF) Method
a PDFPen object used to draw the border of the ellipse.
a System.Drawing.RectangleF structure specifying the bounding rectangle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF

instance.DrawEllipse(pen, rect)
public void DrawEllipse(
   PDFPen pen,
   RectangleF rect
)
public: void DrawEllipse(
   PDFPen* pen,
   RectangleF rect
)
public:
void DrawEllipse(
   PDFPen^ pen,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
rect
a System.Drawing.RectangleF structure specifying the bounding rectangle of the ellipse.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFBrush,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFBrush,Double,Double,Double,Double) Method
a PDFBrush object used to fill the interior of the ellipse.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawEllipse(brush, left, top, width, height)
public void DrawEllipse(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
public: void DrawEllipse(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawEllipse(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFBrush,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFBrush,Double,Double,Double,Double,Double) Method
a PDFBrush object used to fill the interior of the ellipse.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
rotation angle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawEllipse(brush, left, top, width, height, orientation)
public void DrawEllipse(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawEllipse(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawEllipse(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
rotation angle of the ellipse.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFBrush,RectangleF) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFBrush,RectangleF) Method
a PDFBrush object used to fill the interior of the ellipse.
a System.Drawing.RectangleF structure specifying the bounding rectangle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawEllipse(brush, rect)
public void DrawEllipse(
   PDFBrush brush,
   RectangleF rect
)
public: void DrawEllipse(
   PDFBrush* brush,
   RectangleF rect
)
public:
void DrawEllipse(
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a System.Drawing.RectangleF structure specifying the bounding rectangle of the ellipse.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,PDFBrush,RectangleF) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,PDFBrush,RectangleF) Method
a PDFPen object used to draw the border of the ellipse.
a PDFBrush object used to fill the interior of the ellipse.
a System.Drawing.RectangleF structure specifying the bounding rectangle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawEllipse(pen, brush, rect)
public void DrawEllipse(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect
)
public: void DrawEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect
)
public:
void DrawEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a System.Drawing.RectangleF structure specifying the bounding rectangle of the ellipse.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the ellipse.
a PDFBrush object used to fill the interior of the ellipse.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle.
rotation angle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawEllipse(pen, brush, left, top, width, height, orientation)
public void DrawEllipse(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
rotation angle of the ellipse.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawFormXObject Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawFormXObject Method
Draws a form XObject specified by a pair of coordinates, a width and a height.
Overload List
Overload | Description
DrawFormXObject(PDFFormXObject,Double,Double,Double,Double) | Draws a form XObject specified by a pair of coordinates, a width and a height.
DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double) | Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.
DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,PDFContentMirroring) | Draws a form XObject specified by a pair of coordinates, a width and a height and a mirroring mode.
DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double,PDFContentMirroring) | Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawFormXObject(PDFFormXObject,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Double,Double,Double,Double) Method
the form XObject.
the x coordinate of the top left corner of the graphic block when it is placed on the page.
the y coordinate of the top left corner of the graphic block when it is placed on the page.
the width of the graphic block when it is placed on the page.
the height of the graphic block when it is placed on the page.
Draws a form XObject specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawFormXObject(formXObject, left, top, width, height)
public void DrawFormXObject(
   PDFFormXObject formXObject,
   double left,
   double top,
   double width,
   double height
)
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   double left,
   double top,
   double width,
   double height
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
Remarks
This function is used to draw a graphic block on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn graphic block are set by the corresponding parameters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double) Method
the form XObject.
the x coordinate of the top left corner of the graphic block when it is placed on the page.
the y coordinate of the top left corner of the graphic block when it is placed on the page.
the width of the graphic block when it is placed on the page.
the height of the graphic block when it is placed on the page.
the orientation of the graphic block when it is placed on the page.
Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawFormXObject(formXObject, left, top, width, height, orientation)
public void DrawFormXObject(
   PDFFormXObject formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.
Remarks
This function is used to draw a graphic block on the canvas. The top left corner of the graphic block is placed at left,top coordinates. The graphic block content is scaled to fit the given width and height. The graphic block is rotated around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,PDFContentMirroring) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,PDFContentMirroring) Method
the form XObject.
the x coordinate of the top left corner of the graphic block when it is placed on the page.
the y coordinate of the top left corner of the graphic block when it is placed on the page.
the width of the graphic block when it is placed on the page.
the height of the graphic block when it is placed on the page.
The mirroring mode of the form XObject content.
Draws a form XObject specified by a pair of coordinates, a width and a height and a mirroring mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal contentMirroring As PDFContentMirroring _
)
'Usage

Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim contentMirroring As PDFContentMirroring

instance.DrawFormXObject(formXObject, left, top, width, height, contentMirroring)
public void DrawFormXObject(
   PDFFormXObject formXObject,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.
Remarks
This function is used to draw a graphic block on the canvas. The top left corner of the graphic block is placed at left,top coordinates. The graphic block content is scaled to fit the given width and height. The content is mirrored according to contentMirroring parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double,PDFContentMirroring) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double,PDFContentMirroring) Method
the form XObject.
the x coordinate of the top left corner of the graphic block when it is placed on the page.
the y coordinate of the top left corner of the graphic block when it is placed on the page.
the width of the graphic block when it is placed on the page.
the height of the graphic block when it is placed on the page.
the orientation of the graphic block when it is placed on the page.
The mirroring mode of the form XObject content.
Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal contentMirroring As PDFContentMirroring _
)
'Usage

Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim contentMirroring As PDFContentMirroring

instance.DrawFormXObject(formXObject, left, top, width, height, orientation, contentMirroring)
public void DrawFormXObject(
   PDFFormXObject formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.
Remarks
This function is used to draw a graphic block on the canvas. The top left corner of the graphic block is placed at left,top coordinates. The graphic block content is scaled to fit the given width and height. The graphic block is rotated around the top left corner with a number of degrees specified by the orientation parameter. The content is mirrored according to contentMirroring parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawGlyphs Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawGlyphs Method
Array of glyphs to display.
Glyphs used for padding the space between displayed glyphs.
Font used to display the glyphs.
Pen for stroking the glyphs outlines.
Brush for filling the glyphs outlines.
Horizontal advancement from glyph to glyph.
Stretch widths for the glyphs.
Offsets for glyphs.
X coordinate where to display the glyphs.
Y coordinate where to display the glyphs.
the orientation of the text.
a TextAlign enumeration member specifying the aligment of the text.
Draws a series of glyphs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DrawGlyphs( _
   ByVal glyphs() As Integer, _
   ByVal paddingGlyphs() As PDFPaddingGlyph, _
   ByVal font As TrueTypeFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal advanceWidths() As Double, _
   ByVal stretchWidths() As Double, _
   ByVal glyphOffsets() As PDFPoint, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
'Usage

Dim instance As PDFBasicCanvas
Dim glyphs() As Integer
Dim paddingGlyphs() As PDFPaddingGlyph
Dim font As TrueTypeFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim advanceWidths() As Double
Dim stretchWidths() As Double
Dim glyphOffsets() As PDFPoint
Dim x As Double
Dim y As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawGlyphs(glyphs, paddingGlyphs, font, pen, brush, advanceWidths, stretchWidths, glyphOffsets, x, y, orientation, align)
public void DrawGlyphs(
   int[] glyphs,
   PDFPaddingGlyph[] paddingGlyphs,
   TrueTypeFont font,
   PDFPen pen,
   PDFBrush brush,
   double[] advanceWidths,
   double[] stretchWidths,
   PDFPoint[] glyphOffsets,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public: void DrawGlyphs(
   int[]* glyphs,
   PDFPaddingGlyph[]* paddingGlyphs,
   TrueTypeFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   double[]* advanceWidths,
   double[]* stretchWidths,
   PDFPoint*[]* glyphOffsets,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public:
void DrawGlyphs(
   array<int>^ glyphs,
   array<PDFPaddingGlyph>^ paddingGlyphs,
   TrueTypeFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   array<double>^ advanceWidths,
   array<double>^ stretchWidths,
   array<PDFPoint^>^ glyphOffsets,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)

Parameters

glyphs
Array of glyphs to display.
paddingGlyphs
Glyphs used for padding the space between displayed glyphs.
font
Font used to display the glyphs.
pen
Pen for stroking the glyphs outlines.
brush
Brush for filling the glyphs outlines.
advanceWidths
Horizontal advancement from glyph to glyph.
stretchWidths
Stretch widths for the glyphs.
glyphOffsets
Offsets for glyphs.
x
X coordinate where to display the glyphs.
y
Y coordinate where to display the glyphs.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawGraphicOperator Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawGraphicOperator Method
Operator to draw.
Draws the graphic operator on the canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DrawGraphicOperator( _
   ByVal op As PDFGraphicOperator _
)
'Usage

Dim instance As PDFBasicCanvas
Dim op As PDFGraphicOperator

instance.DrawGraphicOperator(op)
public void DrawGraphicOperator(
   PDFGraphicOperator op
)
public: void DrawGraphicOperator(
   PDFGraphicOperator* op
)
public:
void DrawGraphicOperator(
   PDFGraphicOperator^ op
)

Parameters

op
Operator to draw.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawHTMLText Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawHTMLText Method
Draws a line of text specified by a string and a pair of coordinates.
Overload List
Overload | Description
DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) | Draws a line of text specified by a string and a pair of coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the printing point.
the y coordinate of the printing point.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double

instance.DrawHTMLText(text, font, brush, x, y)
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y
)
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y
)
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
Remarks
The text may contain HTML tags for formatting.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the printing point.
the y coordinate of the printing point.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double

instance.DrawHTMLText(text, font, pen, brush, x, y)
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y
)
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y
)
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
Remarks
The text may contain HTML tags for formatting.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the printing point.
the y coordinate of the printing point.
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double

instance.DrawHTMLText(text, font, brush, x, y, orientation)
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y,
   double orientation
)
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y,
   double orientation
)
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
Remarks
The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. The text may contain HTML tags for formatting.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the printing point.
the y coordinate of the printing point.
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double

instance.DrawHTMLText(text, font, pen, brush, x, y, orientation)
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y,
   double orientation
)
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y,
   double orientation
)
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
Remarks
The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. The text may contain HTML tags for formatting.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the printing point.
the y coordinate of the printing point.
the orientation of the text.
a PDFTextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawHTMLText(text, font, brush, x, y, orientation, align)
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a PDFTextAlign enumeration member specifying the aligment of the text.
Remarks
The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point. The text may contain HTML tags for formatting.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the printing point.
the y coordinate of the printing point.
the orientation of the text.
a PDFTextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawHTMLText(text, font, pen, brush, x, y, orientation, align)
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a PDFTextAlign enumeration member specifying the aligment of the text.
Remarks
The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point. The text may contain HTML tags for formatting.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawHTMLTextBox Method
Draws a text specified by a string, a pair of coordinates, a width and a height.
Overload List
Overload | Description
DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) | Draws a text specified by a string, a pair of coordinates, a width and a height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawHTMLTextBox(text, font, brush, left, top, width, height)
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
Remarks
The text is automatically wrapped to fit the width of the text box. The text supports HTML formatting tags.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height)
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
Remarks
The text is automatically wrapped to fit the width of the text box. The text supports HTML formatting tags.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawHTMLTextBox(text, font, brush, left, top, width, height, textFormatOptions)
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Remarks
The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions)
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Remarks
The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
An integer value representing the index within the text where the text to be displayed starts.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions, _
   ByVal startDisplayFrom As Integer _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim startDisplayFrom As Integer

instance.DrawHTMLTextBox(text, font, brush, left, top, width, height, textFormatOptions, startDisplayFrom)
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions,
   int startDisplayFrom
)
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions,
   int startDisplayFrom
)
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions,
   int startDisplayFrom
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
Remarks
The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
An integer value representing the index within the text where the text to be displayed starts.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions, _
   ByVal startDisplayFrom As Integer _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim startDisplayFrom As Integer

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions, startDisplayFrom)
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions,
   int startDisplayFrom
)
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions,
   int startDisplayFrom
)
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions,
   int startDisplayFrom
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
Remarks
The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawImage Method
Draws an image specified by a file name, a pair of coordinates, a width and a height.
Overload List
Overload | Description
DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double,Double) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double) | Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double,Double) | Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio) | Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) | Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) | Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
DrawImage(PDFImage,Double,Double,Double,Double) | Draws an image specified by an O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object, a pair of coordinates, a width and a height.
DrawImage(PDFImage,Double,Double,Double,Double,Double) | Draws an image specified by an O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object, a pair of coordinates, a width and a height.
DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio) | Draws an image specified by an O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object, a pair of coordinates, a width and a height.
DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio,PDFContentMirroring) | Draws an image specified by an O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object, a pair of coordinates, a width and a height.
DrawImage(String,Double,Double,Double,Double) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Double,Double,Double,Double,Double) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method
a full path to the image file.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by a file name, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim value As Double

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio)
public double DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
public: double DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
public:
double DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A double value specifying the calculated image dimension, based on the requested aspect ratio.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method
a full path to the image file.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
the index of the frame within the image to be drawn on the page.
Draws an image specified by a file name, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim value As Double

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio, activeFrame)
public double DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
public: double DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
public:
double DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.

Return Value

A double value specifying the calculated image dimension, based on the requested aspect ratio.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method
a full path to the image file.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
the index of the frame within the image to be drawn on the page.
the compression method used to store image data in the PDF file.
Draws an image specified by a file name, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer, _
   ByVal compression As PDFImageCompression _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim compression As PDFImageCompression
Dim value As Double

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio, activeFrame, compression)
public double DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
public: double DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
public:
double DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.

Return Value

A double value specifying the calculated image dimension, based on the requested aspect ratio.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double) Method
a System.IO.Stream object storing image data.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
Draws an image specified by a stream, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImage(imageStream, left, top, width, height)
public void DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height
)
public: void DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height
)

Parameters

imageStream
a System.IO.Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double,Double) Method
a System.IO.Stream object storing image data.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
Draws an image specified by a stream, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImage(imageStream, left, top, width, height, orientation)
public void DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

imageStream
a System.IO.Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method
a System.IO.Stream object storing image data.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by a stream, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim value As Double

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio)
public double DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
public: double DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
public:
double DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)

Parameters

imageStream
a System.IO.Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method
a System.IO.Stream object storing image data.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
the index of the frame within the image to be drawn on the page.
Draws an image specified by a stream, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim value As Double

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio, activeFrame)
public double DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
public: double DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
public:
double DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)

Parameters

imageStream
a System.IO.Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method
a System.IO.Stream object storing image data.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
the index of the frame within the image to be drawn on the page.
the compression method used to store image data in the PDF file.
Draws an image specified by a stream, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer, _
   ByVal compression As PDFImageCompression _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim compression As PDFImageCompression
Dim value As Double

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio, activeFrame, compression)
public double DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
public: double DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
public:
double DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)

Parameters

imageStream
a System.IO.Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double) Method
a System.Drawing.Image object storing the image.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImage(image, left, top, width, height)
public void DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height
)
public: void DrawImage(
   Bitmap* image,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawImage(
   Bitmap^ image,
   double left,
   double top,
   double width,
   double height
)

Parameters

image
a System.Drawing.Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double,Double) Method
a System.Drawing.Image object storing the image.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImage(image, left, top, width, height, orientation)
public void DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawImage(
   Bitmap* image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawImage(
   Bitmap^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

image
a System.Drawing.Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method
a System.Drawing.Image object storing the image.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio)
public double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
public: double DrawImage(
   Bitmap* image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
public:
double DrawImage(
   Bitmap^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)

Parameters

image
a System.Drawing.Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method
a System.Drawing.Image object storing the image.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
the index of the frame within the image to be drawn on the page.
Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio, activeFrame)
public double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
public: double DrawImage(
   Bitmap* image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
public:
double DrawImage(
   Bitmap^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)

Parameters

image
a System.Drawing.Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method
a System.Drawing.Image object storing the image.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
the index of the frame within the image to be drawn on the page.
the compression method used to store image data in the PDF file.
Draws an image specified by a System.Drawing.Bitmap object, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer, _
   ByVal compression As PDFImageCompression _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim compression As PDFImageCompression
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio, activeFrame, compression)
public double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
public: double DrawImage(
   Bitmap* image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
public:
double DrawImage(
   Bitmap^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)

Parameters

image
a System.Drawing.Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a keepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(PDFImage,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(PDFImage,Double,Double,Double,Double) Method
a O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object storing the image.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
Draws an image specified by an O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As PDFImage, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim image As PDFImage
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImage(image, left, top, width, height)
public void DrawImage(
   PDFImage image,
   double left,
   double top,
   double width,
   double height
)
public: void DrawImage(
   PDFImage* image,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawImage(
   PDFImage^ image,
   double left,
   double top,
   double width,
   double height
)

Parameters

image
a O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(PDFImage,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(PDFImage,Double,Double,Double,Double,Double) Method
a O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object storing the image.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the rotation angle of the image.
Draws an image specified by an O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As PDFImage, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim image As PDFImage
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImage(image, left, top, width, height, orientation)
public void DrawImage(
   PDFImage image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawImage(
   PDFImage* image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawImage(
   PDFImage^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

image
a O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the rotation angle of the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method
a O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object storing the image.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the rotation angle of the image.
requested aspect ratio for the image.
Draws an image specified by an O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal image As PDFImage, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim image As PDFImage
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio)
public double DrawImage(
   PDFImage image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
public: double DrawImage(
   PDFImage* image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
public:
double DrawImage(
   PDFImage^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)

Parameters

image
a O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the rotation angle of the image.
keepAspectRatio
requested aspect ratio for the image.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio, or -1 if KeepNone or KeepBoth aspect ratio modes have been specified on the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

Based on the KeepAspectRatio parameter the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio,PDFContentMirroring) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio,PDFContentMirroring) Method
a O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object storing the image.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the rotation angle of the image.
requested aspect ratio for the image.
The mirroring mode of the image.
Draws an image specified by an O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal image As PDFImage, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal contentMirroring As PDFContentMirroring _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim image As PDFImage
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim contentMirroring As PDFContentMirroring
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio, contentMirroring)
public double DrawImage(
   PDFImage image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   PDFContentMirroring contentMirroring
)
public: double DrawImage(
   PDFImage* image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   PDFContentMirroring contentMirroring
)
public:
double DrawImage(
   PDFImage^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   PDFContentMirroring contentMirroring
)

Parameters

image
a O2S.Components.PDF4NET.Graphics.Shapes.PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the rotation angle of the image.
keepAspectRatio
requested aspect ratio for the image.
contentMirroring
The mirroring mode of the image.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio, or -1 if KeepNone or KeepBoth aspect ratio modes have been specified on the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

Based on the KeepAspectRatio parameter the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(String,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double) Method
a full path to the image file.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
Draws an image specified by a file name, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImage(fileName, left, top, width, height)
public void DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height
)
public: void DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(String,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double,Double) Method
a full path to the image file.
the x coordinate of the top left corner of the image.
the y coordinate of the top left corner of the image.
the width of the image.
the height of the image.
the orientation of the image.
Draws an image specified by a file name, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImage(fileName, left, top, width, height, orientation)
public void DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
Remarks
This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImportedContent Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawImportedContent Method
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Overload List
Overload | Description
DrawImportedContent(PDFImportedContent,Double,Double,Double,Double) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,PDFContentMirroring) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double,PDFContentMirroring) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawImportedContent(PDFImportedContent,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Double,Double,Double,Double) Method
the imported content object.
the x coordinate of the top left corner of the imported content when it is placed on the page.
the y coordinate of the top left corner of the imported content when it is placed on the page.
the width of the imported content when it is placed on the page.
the height of the imported content when it is placed on the page.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim importedContent As PDFImportedContent
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImportedContent(importedContent, left, top, width, height)
public void DrawImportedContent(
   PDFImportedContent importedContent,
   double left,
   double top,
   double width,
   double height
)
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   double left,
   double top,
   double width,
   double height
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
Remarks
This function is used to draw the content of an imported page on current canvas. The content is scaled to fit the given width and height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double) Method
the imported content object.
the x coordinate of the top left corner of the imported content when it is placed on the page.
the y coordinate of the top left corner of the imported content when it is placed on the page.
the width of the imported content when it is placed on the page.
the height of the imported content when it is placed on the page.
The orientation angle of the imported content.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim importedContent As PDFImportedContent
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImportedContent(importedContent, left, top, width, height, orientation)
public void DrawImportedContent(
   PDFImportedContent importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
orientation
The orientation angle of the imported content.
Remarks
This function is used to draw the content of an imported page on current canvas. The content is scaled to fit the given width and height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,PDFContentMirroring) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,PDFContentMirroring) Method
the imported content object.
the x coordinate of the top left corner of the imported content when it is placed on the page.
the y coordinate of the top left corner of the imported content when it is placed on the page.
the width of the imported content when it is placed on the page.
the height of the imported content when it is placed on the page.
The mirroring mode of the imported content.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal contentMirroring As PDFContentMirroring _
)
'Usage

Dim instance As PDFBasicCanvas
Dim importedContent As PDFImportedContent
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim contentMirroring As PDFContentMirroring

instance.DrawImportedContent(importedContent, left, top, width, height, contentMirroring)
public void DrawImportedContent(
   PDFImportedContent importedContent,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
contentMirroring
The mirroring mode of the imported content.
Remarks
This function is used to draw the content of an imported page on current canvas. The content is scaled to fit the given width and height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double,PDFContentMirroring) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double,PDFContentMirroring) Method
the imported content object.
the x coordinate of the top left corner of the imported content when it is placed on the page.
the y coordinate of the top left corner of the imported content when it is placed on the page.
the width of the imported content when it is placed on the page.
the height of the imported content when it is placed on the page.
The orientation angle of the imported content.
The mirroring mode of the imported content.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal contentMirroring As PDFContentMirroring _
)
'Usage

Dim instance As PDFBasicCanvas
Dim importedContent As PDFImportedContent
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim contentMirroring As PDFContentMirroring

instance.DrawImportedContent(importedContent, left, top, width, height, orientation, contentMirroring)
public void DrawImportedContent(
   PDFImportedContent importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
orientation
The orientation angle of the imported content.
contentMirroring
The mirroring mode of the imported content.
Remarks
This function is used to draw the content of an imported page on current canvas. The content is scaled to fit the given width and height and it is rotated around the top left corner with a number of degrees specified by the orientation parameter. The content is mirrored according to contentMirroring parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLine Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawLine Method
Draws a line connecting two points specified by coordinate pairs using the specified pen.

Supported by Compact .NET Edition.

Overload List
Overload | Description
DrawLine(PDFPen,Double,Double,Double,Double) | Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition.
DrawLine(PDFPen,PointF,PointF) | Draws a line connecting two points specified by System.Drawing.PointF structures using the specified pen.
DrawLine(PDFPen,PDFPoint,PDFPoint) | Draws a line connecting two points specified by System.Drawing.Point structures using the specified pen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawLine(PDFPen,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLine Method : DrawLine(PDFPen,Double,Double,Double,Double) Method
a PDFPen object used to draw the line.
x coordinate of the beginning of the line.
y coordinate of the beginning of the line.
x coordinate of the end of the line.
y coordinate of the end of the line.
Draws a line connecting two points specified by coordinate pairs using the specified pen.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawLine( _
   ByVal pen As PDFPen, _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double

instance.DrawLine(pen, x1, y1, x2, y2)
public void DrawLine(
   PDFPen pen,
   double x1,
   double y1,
   double x2,
   double y2
)
public: void DrawLine(
   PDFPen* pen,
   double x1,
   double y1,
   double x2,
   double y2
)
public:
void DrawLine(
   PDFPen^ pen,
   double x1,
   double y1,
   double x2,
   double y2
)

Parameters

pen
a PDFPen object used to draw the line.
x1
x coordinate of the beginning of the line.
y1
y coordinate of the beginning of the line.
x2
x coordinate of the end of the line.
y2
y coordinate of the end of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLine(PDFPen,PointF,PointF) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLine Method : DrawLine(PDFPen,PointF,PointF) Method
a PDFPen object used to draw the line.
a System.Drawing.PointF structure specifying the beginning of the line.
a System.Drawing.PointF structure specifying the end of the line.
Draws a line connecting two points specified by System.Drawing.PointF structures using the specified pen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawLine( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PointF
Dim pt2 As PointF

instance.DrawLine(pen, pt1, pt2)
public void DrawLine(
   PDFPen pen,
   PointF pt1,
   PointF pt2
)
public: void DrawLine(
   PDFPen* pen,
   PointF pt1,
   PointF pt2
)
public:
void DrawLine(
   PDFPen^ pen,
   PointF pt1,
   PointF pt2
)

Parameters

pen
a PDFPen object used to draw the line.
pt1
a System.Drawing.PointF structure specifying the beginning of the line.
pt2
a System.Drawing.PointF structure specifying the end of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLine(PDFPen,PDFPoint,PDFPoint) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLine Method : DrawLine(PDFPen,PDFPoint,PDFPoint) Method
a PDFPen object used to draw the line.
a O2S.Components.PDF4NET.PDFPoint structure specifying the beginning of the line.
a O2S.Components.PDF4NET.PDFPoint structure specifying the end of the line.
Draws a line connecting two points specified by System.Drawing.Point structures using the specified pen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawLine( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PDFPoint, _
   ByVal pt2 As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PDFPoint
Dim pt2 As PDFPoint

instance.DrawLine(pen, pt1, pt2)
public void DrawLine(
   PDFPen pen,
   PDFPoint pt1,
   PDFPoint pt2
)
public: void DrawLine(
   PDFPen* pen,
   PDFPoint* pt1,
   PDFPoint* pt2
)
public:
void DrawLine(
   PDFPen^ pen,
   PDFPoint^ pt1,
   PDFPoint^ pt2
)

Parameters

pen
a PDFPen object used to draw the line.
pt1
a O2S.Components.PDF4NET.PDFPoint structure specifying the beginning of the line.
pt2
a O2S.Components.PDF4NET.PDFPoint structure specifying the end of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLines Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawLines Method
Draws a series of line segments that connect an array of System.Drawing.PointF structures.
Overload List
Overload | Description
DrawLines(PDFPen,PointF[]) | Draws a series of line segments that connect an array of System.Drawing.PointF structures.
DrawLines(PDFPen,PointF[],Int32,Int32) | Draws a series of line segments that connect an array of System.Drawing.PointF structures starting at index position in the array.
DrawLines(PDFPen,PDFPoint[]) | Draws a series of line segments that connect an array of O2S.Components.PDF4NET.PDFPoint objects.
DrawLines(PDFPen,PDFPoint[],Int32,Int32) | Draws a series of line segments that connect an array of O2S.Components.PDF4NET.PDFPoint objects starting at index position in the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawLines(PDFPen,PointF[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLines Method : DrawLines(PDFPen,PointF[]) Method
a PDFPen object used to draw the lines.
an array of System.Drawing.PointF structures specifying the coordinates of the lines.
Draws a series of line segments that connect an array of System.Drawing.PointF structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawLines( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawLines(pen, points)
public void DrawLines(
   PDFPen pen,
   PointF[] points
)
public: void DrawLines(
   PDFPen* pen,
   PointF[]* points
)
public:
void DrawLines(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the lines.
points
an array of System.Drawing.PointF structures specifying the coordinates of the lines.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLines(PDFPen,PointF[],Int32,Int32) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLines Method : DrawLines(PDFPen,PointF[],Int32,Int32) Method
a PDFPen object used to draw the lines.
an array of System.Drawing.PointF structures specifying the coordinates of the lines.
Index in the array where to start drawing.
Number of points in the array to draw.
Draws a series of line segments that connect an array of System.Drawing.PointF structures starting at index position in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawLines( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF
Dim index As Integer
Dim count As Integer

instance.DrawLines(pen, points, index, count)
public void DrawLines(
   PDFPen pen,
   PointF[] points,
   int index,
   int count
)
public: void DrawLines(
   PDFPen* pen,
   PointF[]* points,
   int index,
   int count
)
public:
void DrawLines(
   PDFPen^ pen,
   array<PointF>^ points,
   int index,
   int count
)

Parameters

pen
a PDFPen object used to draw the lines.
points
an array of System.Drawing.PointF structures specifying the coordinates of the lines.
index
Index in the array where to start drawing.
count
Number of points in the array to draw.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when index is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLines(PDFPen,PDFPoint[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLines Method : DrawLines(PDFPen,PDFPoint[]) Method
a PDFPen object used to draw the lines.
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of the lines.
Draws a series of line segments that connect an array of O2S.Components.PDF4NET.PDFPoint objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawLines( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawLines(pen, points)
public void DrawLines(
   PDFPen pen,
   PDFPoint[] points
)
public: void DrawLines(
   PDFPen* pen,
   PDFPoint*[]* points
)
public:
void DrawLines(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the lines.
points
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of the lines.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLines(PDFPen,PDFPoint[],Int32,Int32) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLines Method : DrawLines(PDFPen,PDFPoint[],Int32,Int32) Method
a PDFPen object used to draw the lines.
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of the lines.
Index in the array where to start drawing.
Number of points in the array to draw.
Draws a series of line segments that connect an array of O2S.Components.PDF4NET.PDFPoint objects starting at index position in the array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawLines( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint
Dim index As Integer
Dim count As Integer

instance.DrawLines(pen, points, index, count)
public void DrawLines(
   PDFPen pen,
   PDFPoint[] points,
   int index,
   int count
)
public: void DrawLines(
   PDFPen* pen,
   PDFPoint*[]* points,
   int index,
   int count
)
public:
void DrawLines(
   PDFPen^ pen,
   array<PDFPoint^>^ points,
   int index,
   int count
)

Parameters

pen
a PDFPen object used to draw the lines.
points
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of the lines.
index
Index in the array where to start drawing.
count
Number of points in the array to draw.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when index is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPath Method
Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen.
Overload List
Overload | Description
DrawPath(PDFPen,PDFPath) | Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen.
DrawPath(PDFBrush,PDFPath) | Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified brush.
DrawPath(PDFBrush,PDFPath,PDFFillMode) | Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified brush.
DrawPath(PDFPen,PDFBrush,PDFPath) | Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen and brush.
DrawPath(PDFPen,PDFBrush,PDFPath,PDFFillMode) | Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen and brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPath(PDFPen,PDFPath) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFPen,PDFPath) Method
A PDFPen object used to stroke the path.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal pen As PDFPen, _
   ByVal path As PDFPath _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim path As PDFPath

instance.DrawPath(pen, path)
public void DrawPath(
   PDFPen pen,
   PDFPath path
)
public: void DrawPath(
   PDFPen* pen,
   PDFPath* path
)
public:
void DrawPath(
   PDFPen^ pen,
   PDFPath^ path
)

Parameters

pen
A PDFPen object used to stroke the path.
path
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
Remarks
This function strokes a user defined path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath(PDFBrush,PDFPath) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFBrush,PDFPath) Method
A PDFBrush object used to fill the interior of the path.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified brush.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim path As PDFPath

instance.DrawPath(brush, path)
public void DrawPath(
   PDFBrush brush,
   PDFPath path
)
public: void DrawPath(
   PDFBrush* brush,
   PDFPath* path
)
public:
void DrawPath(
   PDFBrush^ brush,
   PDFPath^ path
)

Parameters

brush
A PDFBrush object used to fill the interior of the path.
path
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
Remarks
This function strokes and fill a user defined path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath(PDFBrush,PDFPath,PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFBrush,PDFPath,PDFFillMode) Method
A PDFBrush object used to fill the interior of the path.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
The fill mode of the path.
Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified brush.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim path As PDFPath
Dim fillMode As PDFFillMode

instance.DrawPath(brush, path, fillMode)
public void DrawPath(
   PDFBrush brush,
   PDFPath path,
   PDFFillMode fillMode
)
public: void DrawPath(
   PDFBrush* brush,
   PDFPath* path,
   PDFFillMode fillMode
)
public:
void DrawPath(
   PDFBrush^ brush,
   PDFPath^ path,
   PDFFillMode fillMode
)

Parameters

brush
A PDFBrush object used to fill the interior of the path.
path
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
fillMode
The fill mode of the path.
Remarks
This function strokes and fill a user defined path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath(PDFPen,PDFBrush,PDFPath) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFPen,PDFBrush,PDFPath) Method
A PDFPen object used to stroke the path.
A PDFBrush object used to fill the interior of the path.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen and brush.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim path As PDFPath

instance.DrawPath(pen, brush, path)
public void DrawPath(
   PDFPen pen,
   PDFBrush brush,
   PDFPath path
)
public: void DrawPath(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPath* path
)
public:
void DrawPath(
   PDFPen^ pen,
   PDFBrush^ brush,
   PDFPath^ path
)

Parameters

pen
A PDFPen object used to stroke the path.
brush
A PDFBrush object used to fill the interior of the path.
path
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
Remarks
This function strokes and fill a user defined path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath(PDFPen,PDFBrush,PDFPath,PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFPen,PDFBrush,PDFPath,PDFFillMode) Method
A PDFPen object used to stroke the path.
A PDFBrush object used to fill the interior of the path.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
The fill mode of the path.
Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen and brush.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim path As PDFPath
Dim fillMode As PDFFillMode

instance.DrawPath(pen, brush, path, fillMode)
public void DrawPath(
   PDFPen pen,
   PDFBrush brush,
   PDFPath path,
   PDFFillMode fillMode
)
public: void DrawPath(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPath* path,
   PDFFillMode fillMode
)
public:
void DrawPath(
   PDFPen^ pen,
   PDFBrush^ brush,
   PDFPath^ path,
   PDFFillMode fillMode
)

Parameters

pen
A PDFPen object used to stroke the path.
brush
A PDFBrush object used to fill the interior of the path.
path
A O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object to be drawn on the canvas.
fillMode
The fill mode of the path.
Remarks
This function strokes and fill a user defined path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPie Method
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Overload List
Overload | Description
DrawPie(PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
DrawPie(PDFPen,Double,Double,Double,Double,Double,Double) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
DrawPie(PDFPen,RectangleF,Double,Double) | Draws a pie representing a closed portion of an circle specified by a System.Drawing.RectangleF structure.
DrawPie(PDFBrush,RectangleF,Double,Double) | Draws a pie representing a closed portion of an circle specified by a System.Drawing.RectangleF structure.
DrawPie(PDFPen,PDFBrush,RectangleF,Double,Double) | Draws a pie representing a closed portion of an circle specified by a System.Drawing.RectangleF structure.
DrawPie(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPie(PDFBrush,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFBrush,Double,Double,Double,Double,Double,Double) Method
a PDFBrush object used to fill the interior of the pie.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(brush, left, top, width, height, startAngle, sweepAngle)
public void DrawPie(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public: void DrawPie(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawPie(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Remarks
The height of the bounding rectangle is always equal to the width of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFPen,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,Double,Double,Double,Double,Double,Double) Method
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, left, top, width, height, startAngle, sweepAngle)
public void DrawPie(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public: void DrawPie(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawPie(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Remarks
The height of the bounding rectangle is always equal to the width of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFPen,RectangleF,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,RectangleF,Double,Double) Method
a PDFPen object used to draw the border of the pie.
a System.Drawing.RectangleF structure specifying the bounding rectangle of the circle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, rect, startAngle, sweepAngle)
public void DrawPie(
   PDFPen pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public: void DrawPie(
   PDFPen* pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public:
void DrawPie(
   PDFPen^ pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
rect
a System.Drawing.RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Remarks
The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the System.Drawing.RectangleF structure, internally, these two values are made equal.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFBrush,RectangleF,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFBrush,RectangleF,Double,Double) Method
a PDFBrush object used to fill the interior of the pie.
a System.Drawing.RectangleF structure specifying the bounding rectangle of the circle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(brush, rect, startAngle, sweepAngle)
public void DrawPie(
   PDFBrush brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public: void DrawPie(
   PDFBrush* brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public:
void DrawPie(
   PDFBrush^ brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the pie.
rect
a System.Drawing.RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Remarks
The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the System.Drawing.RectangleF structure, internally, these two values are made equal.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFPen,PDFBrush,RectangleF,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,PDFBrush,RectangleF,Double,Double) Method
a PDFPen object used to draw the border of the pie.
a PDFBrush object used to fill the interior of the pie.
a System.Drawing.RectangleF structure specifying the bounding rectangle of the circle.
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, brush, rect, startAngle, sweepAngle)
public void DrawPie(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public: void DrawPie(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
public:
void DrawPie(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
rect
a System.Drawing.RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Remarks
The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the System.Drawing.RectangleF structure, internally, these two values are made equal.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the pie.
a PDFBrush object used to fill the interior of the pie.
the x coordinate of the top left corner of the bounding rectangle.
the y coordinate of the top left corner of the bounding rectangle.
the width of the rectangle.
the height of the rectangle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, brush, left, top, width, height, startAngle, sweepAngle)
public void DrawPie(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public: void DrawPie(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawPie(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Remarks
The height of the bounding rectangle is always equal to the width of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyBezier Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPolyBezier Method
Draws a series of connected curves defined by an array of System.Drawing.PointF structures.
Overload List
Overload | Description
DrawPolyBezier(PDFPen,PointF[]) | Draws a series of connected curves defined by an array of System.Drawing.PointF structures.
DrawPolyBezier(PDFPen,PDFPoint[]) | Draws a series of connected curves defined by an array of O2S.Components.PDF4NET.PDFPoint objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPolyBezier(PDFPen,PointF[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyBezier Method : DrawPolyBezier(PDFPen,PointF[]) Method
A PDFPen object used to draw the curves.
An array of System.Drawing.PointF structures specifying the coordinates of the control points.
Draws a series of connected curves defined by an array of System.Drawing.PointF structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyBezier( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawPolyBezier(pen, points)
public void DrawPolyBezier(
   PDFPen pen,
   PointF[] points
)
public: void DrawPolyBezier(
   PDFPen* pen,
   PointF[]* points
)
public:
void DrawPolyBezier(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
A PDFPen object used to draw the curves.
points
An array of System.Drawing.PointF structures specifying the coordinates of the control points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyBezier(PDFPen,PDFPoint[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyBezier Method : DrawPolyBezier(PDFPen,PDFPoint[]) Method
A PDFPen object used to draw the curves.
An array of O2S.Components.PDF4NET.PDFPoint structures specifying the coordinates of the control points.
Draws a series of connected curves defined by an array of O2S.Components.PDF4NET.PDFPoint objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyBezier( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawPolyBezier(pen, points)
public void DrawPolyBezier(
   PDFPen pen,
   PDFPoint[] points
)
public: void DrawPolyBezier(
   PDFPen* pen,
   PDFPoint*[]* points
)
public:
void DrawPolyBezier(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
A PDFPen object used to draw the curves.
points
An array of O2S.Components.PDF4NET.PDFPoint structures specifying the coordinates of the control points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPolygon Method
Draws a polygon defined by an array of PDFPoint objects.
Overload List
Overload | Description
DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFPen,PDFPoint[]) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFBrush,PDFPoint[]) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFBrush,PDFPoint[],PDFFillMode) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFPen,PointF[]) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFBrush,PointF[]) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFBrush,PointF[],PDFFillMode) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFPen,PDFBrush,PointF[]) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) | Draws a polygon defined by an array of PDFPoint objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) Method
a PDFPen object used to draw the border of the polygon.
a PDFBrush object used to fill the interior of the polygon.
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PDFPoint objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolygon(pen, brush, points)
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points
)
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points
)
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
Remarks
This function draws a polygon defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PDFPoint[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFPoint[]) Method
a PDFPen object used to draw the border of the polygon.
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PDFPoint objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawPolygon(pen, points)
public void DrawPolygon(
   PDFPen pen,
   PDFPoint[] points
)
public: void DrawPolygon(
   PDFPen* pen,
   PDFPoint*[]* points
)
public:
void DrawPolygon(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
points
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFBrush,PDFPoint[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PDFPoint[]) Method
a PDFBrush object used to fill the interior of the polygon.
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PDFPoint objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolygon(brush, points)
public void DrawPolygon(
   PDFBrush brush,
   PDFPoint[] points
)
public: void DrawPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points
)
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFBrush,PDFPoint[],PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PDFPoint[],PDFFillMode) Method
a PDFBrush object used to fill the interior of the polygon.
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
The fill mode of the polygon.
Draws a polygon defined by an array of PDFPoint objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint
Dim fillMode As PDFFillMode

instance.DrawPolygon(brush, points, fillMode)
public void DrawPolygon(
   PDFBrush brush,
   PDFPoint[] points,
   PDFFillMode fillMode
)
public: void DrawPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points,
   PDFFillMode fillMode
)
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points,
   PDFFillMode fillMode
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
fillMode
The fill mode of the polygon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PointF[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PointF[]) Method
a PDFPen object used to draw the border of the polygon.
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PointF structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawPolygon(pen, points)
public void DrawPolygon(
   PDFPen pen,
   PointF[] points
)
public: void DrawPolygon(
   PDFPen* pen,
   PointF[]* points
)
public:
void DrawPolygon(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
points
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFBrush,PointF[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PointF[]) Method
a PDFBrush object used to fill the interior of the polygon.
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PointF structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolygon(brush, points)
public void DrawPolygon(
   PDFBrush brush,
   PointF[] points
)
public: void DrawPolygon(
   PDFBrush* brush,
   PointF[]* points
)
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFBrush,PointF[],PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PointF[],PDFFillMode) Method
a PDFBrush object used to fill the interior of the polygon.
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
The fill mode of the polygon.
Draws a polygon defined by an array of PointF structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF
Dim fillMode As PDFFillMode

instance.DrawPolygon(brush, points, fillMode)
public void DrawPolygon(
   PDFBrush brush,
   PointF[] points,
   PDFFillMode fillMode
)
public: void DrawPolygon(
   PDFBrush* brush,
   PointF[]* points,
   PDFFillMode fillMode
)
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PointF>^ points,
   PDFFillMode fillMode
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
fillMode
The fill mode of the polygon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PDFBrush,PointF[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PointF[]) Method
a PDFPen object used to draw the border of the polygon.
a PDFBrush object used to fill the interior of the polygon.
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PointF structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolygon(pen, brush, points)
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points
)
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points
)
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
Remarks
This function draws a polygon defined by an array of PointF structures. The border of the polygon is drawn using the pen, and the interior is filled with the brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) Method
a PDFPen object used to draw the border of the polygon.
a PDFBrush object used to fill the interior of the polygon.
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
The fill mode of the polygon.
Draws a polygon defined by an array of PointF structures.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF
Dim fillMode As PDFFillMode

instance.DrawPolygon(pen, brush, points, fillMode)
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points,
   PDFFillMode fillMode
)
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points,
   PDFFillMode fillMode
)
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points,
   PDFFillMode fillMode
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of System.Drawing.PointF structures specifying the coordinates of polygon's corners.
fillMode
The fill mode of the polygon.
Remarks
This function draws a polygon defined by an array of PointF structures. The border of the polygon is drawn using the pen, and the interior is filled with the brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) Method
a PDFPen object used to draw the border of the polygon.
a PDFBrush object used to fill the interior of the polygon.
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
The fill mode for the polygon.
Draws a polygon defined by an array of PDFPoint objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint
Dim fillMode As PDFFillMode

instance.DrawPolygon(pen, brush, points, fillMode)
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points,
   PDFFillMode fillMode
)
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points,
   PDFFillMode fillMode
)
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points,
   PDFFillMode fillMode
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of O2S.Components.PDF4NET.PDFPoint objects specifying the coordinates of polygon's corners.
fillMode
The fill mode for the polygon.
Remarks
This function draws a polygon defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPolyPolygon Method
Overload List
Overload | Description
DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[]) |
DrawPolyPolygon(PDFPen,PDFPoint[]) |
DrawPolyPolygon(PDFBrush,PDFPoint[]) |
DrawPolyPolygon(PDFBrush,PDFPoint[],PDFFillMode) |
DrawPolyPolygon(PDFPen,PointF[]) |
DrawPolyPolygon(PDFBrush,PointF[]) |
DrawPolyPolygon(PDFBrush,PointF[],PDFFillMode) |
DrawPolyPolygon(PDFPen,PDFBrush,PointF[]) |
DrawPolyPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) |
DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[]) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolyPolygon(pen, brush, points)
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points
)
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points
)
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

pen
brush
points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PDFPoint[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFPoint[]) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawPolyPolygon(pen, points)
public void DrawPolyPolygon(
   PDFPen pen,
   PDFPoint[] points
)
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFPoint*[]* points
)
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFBrush,PDFPoint[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PDFPoint[]) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolyPolygon(brush, points)
public void DrawPolyPolygon(
   PDFBrush brush,
   PDFPoint[] points
)
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points
)
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

brush
points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFBrush,PDFPoint[],PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PDFPoint[],PDFFillMode) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint
Dim fillMode As PDFFillMode

instance.DrawPolyPolygon(brush, points, fillMode)
public void DrawPolyPolygon(
   PDFBrush brush,
   PDFPoint[] points,
   PDFFillMode fillMode
)
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points,
   PDFFillMode fillMode
)
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points,
   PDFFillMode fillMode
)

Parameters

brush
points
fillMode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PointF[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PointF[]) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawPolyPolygon(pen, points)
public void DrawPolyPolygon(
   PDFPen pen,
   PointF[] points
)
public: void DrawPolyPolygon(
   PDFPen* pen,
   PointF[]* points
)
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFBrush,PointF[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PointF[]) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolyPolygon(brush, points)
public void DrawPolyPolygon(
   PDFBrush brush,
   PointF[] points
)
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PointF[]* points
)
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

brush
points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFBrush,PointF[],PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PointF[],PDFFillMode) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF
Dim fillMode As PDFFillMode

instance.DrawPolyPolygon(brush, points, fillMode)
public void DrawPolyPolygon(
   PDFBrush brush,
   PointF[] points,
   PDFFillMode fillMode
)
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PointF[]* points,
   PDFFillMode fillMode
)
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PointF>^ points,
   PDFFillMode fillMode
)

Parameters

brush
points
fillMode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PDFBrush,PointF[]) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PointF[]) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolyPolygon(pen, brush, points)
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points
)
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points
)
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

pen
brush
points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF
Dim fillMode As PDFFillMode

instance.DrawPolyPolygon(pen, brush, points, fillMode)
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points,
   PDFFillMode fillMode
)
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points,
   PDFFillMode fillMode
)
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points,
   PDFFillMode fillMode
)

Parameters

pen
brush
points
fillMode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint
Dim fillMode As PDFFillMode

instance.DrawPolyPolygon(pen, brush, points, fillMode)
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points,
   PDFFillMode fillMode
)
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points,
   PDFFillMode fillMode
)
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points,
   PDFFillMode fillMode
)

Parameters

pen
brush
points
fillMode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawRectangle Method
Draws a rectangle specified by a pair of coordinates, a width and a height.
Overload List
Overload | Description
DrawRectangle(PDFPen,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,Double,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,RectangleF) | Draws a rectangle specified by a System.Drawing.RectangleF structure.
DrawRectangle(PDFPen,RectangleF,Double) | Draws a rectangle specified by a System.Drawing.RectangleF structure.
DrawRectangle(PDFBrush,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFBrush,Double,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFBrush,RectangleF) | Draws a rectangle specified by a System.Drawing.RectangleF structure.
DrawRectangle(PDFBrush,RectangleF,Double) | Draws a rectangle specified by a System.Drawing.RectangleF structure.
DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,PDFBrush,RectangleF) | Draws a rectangle specified by a System.Drawing.RectangleF structure.
DrawRectangle(PDFPen,PDFBrush,RectangleF,Double) | Draws a rectangle specified by a System.Drawing.RectangleF structure.
DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawRectangle(PDFPen,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawRectangle(pen, left, top, width, height)
public void DrawRectangle(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height
)
public: void DrawRectangle(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawRectangle(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawRectangle(pen, left, top, width, height, orientation)
public void DrawRectangle(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawRectangle(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawRectangle(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Remarks
This function is used to draw a rectangle specified by a pair of coordinates, a width and a height. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,RectangleF) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,RectangleF) Method
a PDFPen object used to draw the border of the rectangle.
a System.Drawing.RectangleF structure specifying the rectangle.
Draws a rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF

instance.DrawRectangle(pen, rect)
public void DrawRectangle(
   PDFPen pen,
   RectangleF rect
)
public: void DrawRectangle(
   PDFPen* pen,
   RectangleF rect
)
public:
void DrawRectangle(
   PDFPen^ pen,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
rect
a System.Drawing.RectangleF structure specifying the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,RectangleF,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,RectangleF,Double) Method
a PDFPen object used to draw the border of the rectangle.
a System.Drawing.RectangleF structure specifying the rectangle.
the orientation of the rectangle.
Draws a rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim orientation As Double

instance.DrawRectangle(pen, rect, orientation)
public void DrawRectangle(
   PDFPen pen,
   RectangleF rect,
   double orientation
)
public: void DrawRectangle(
   PDFPen* pen,
   RectangleF rect,
   double orientation
)
public:
void DrawRectangle(
   PDFPen^ pen,
   RectangleF rect,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
rect
a System.Drawing.RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.
Remarks
This function is used to draw a rectangle specified by a System.Drawing.RectangleF structure. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFBrush,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,Double,Double,Double,Double) Method
a PDFBrush object used to fill the interior of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawRectangle(brush, left, top, width, height)
public void DrawRectangle(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
public: void DrawRectangle(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawRectangle(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFBrush,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,Double,Double,Double,Double,Double) Method
a PDFBrush object used to fill the interior of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawRectangle(brush, left, top, width, height, orientation)
public void DrawRectangle(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawRectangle(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawRectangle(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Remarks
This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFBrush,RectangleF) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,RectangleF) Method
a PDFBrush object used to fill the interior of the rectangle.
a System.Drawing.RectangleF structure specifying the rectangle.
Draws a rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawRectangle(brush, rect)
public void DrawRectangle(
   PDFBrush brush,
   RectangleF rect
)
public: void DrawRectangle(
   PDFBrush* brush,
   RectangleF rect
)
public:
void DrawRectangle(
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a System.Drawing.RectangleF structure specifying the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFBrush,RectangleF,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,RectangleF,Double) Method
a PDFBrush object used to fill the interior of the rectangle.
a System.Drawing.RectangleF structure specifying the rectangle.
the orientation of the rectangle.
Draws a rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF
Dim orientation As Double

instance.DrawRectangle(brush, rect, orientation)
public void DrawRectangle(
   PDFBrush brush,
   RectangleF rect,
   double orientation
)
public: void DrawRectangle(
   PDFBrush* brush,
   RectangleF rect,
   double orientation
)
public:
void DrawRectangle(
   PDFBrush^ brush,
   RectangleF rect,
   double orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a System.Drawing.RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.
Remarks
This function is used to draw a filled rectangle specified by a System.Drawing.RectangleF structure. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the rectangle.
a PDFBrush object used to fill the interior of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawRectangle(pen, brush, left, top, width, height)
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Remarks
This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,PDFBrush,RectangleF) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,RectangleF) Method
a PDFPen object used to draw the border of the rectangle.
a PDFBrush object used to fill the interior of the rectangle.
a System.Drawing.RectangleF structure specifying the rectangle.
Draws a rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawRectangle(pen, brush, rect)
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect
)
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect
)
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a System.Drawing.RectangleF structure specifying the rectangle.
Remarks
This function is used to draw a filled rectangle specified by a System.Drawing.RectangleF structure. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,PDFBrush,RectangleF,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,RectangleF,Double) Method
a PDFPen object used to draw the border of the rectangle.
a PDFBrush object used to fill the interior of the rectangle.
a System.Drawing.RectangleF structure specifying the rectangle.
the orientation of the rectangle.
Draws a rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim orientation As Double

instance.DrawRectangle(pen, brush, rect, orientation)
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   double orientation
)
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   double orientation
)
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a System.Drawing.RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.
Remarks
This function is used to draw a filled rectangle specified by a System.Drawing.RectangleF structure. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the rectangle.
a PDFBrush object used to fill the interior of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawRectangle(pen, brush, left, top, width, height, orientation)
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Remarks
This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawRoundRectangle Method
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Overload List
Overload | Description
DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the rectangle.
a PDFBrush object used to fill the interior of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
the width of the ellipse used to draw the rounded corners.
the height of the ellipse used to draw the rounded corners.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.DrawRoundRectangle(pen, brush, left, top, width, height, ellipseWidth, ellipseHeight)
public void DrawRoundRectangle(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public: void DrawRoundRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
Remarks
This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
the width of the ellipse used to draw the rounded corners.
the height of the ellipse used to draw the rounded corners.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.DrawRoundRectangle(pen, left, top, width, height, ellipseWidth, ellipseHeight)
public void DrawRoundRectangle(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public: void DrawRoundRectangle(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
Remarks
This function strokes the rectangle with the given PDFPen object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
the width of the ellipse used to draw the rounded corners.
the height of the ellipse used to draw the rounded corners.
the orientation of the rectangle.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double
Dim orientation As Double

instance.DrawRoundRectangle(pen, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
public void DrawRoundRectangle(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
public: void DrawRoundRectangle(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.
Remarks
This function strokes the rectangle with the given PDFPen object.
The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double) Method
a PDFBrush object used to fill the interior of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
the width of the ellipse used to draw the rounded corners.
the height of the ellipse used to draw the rounded corners.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.DrawRoundRectangle(brush, left, top, width, height, ellipseWidth, ellipseHeight)
public void DrawRoundRectangle(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public: void DrawRoundRectangle(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public:
void DrawRoundRectangle(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
Remarks
This function fill the interior of the rectangle with the given PDFBrush object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method
a PDFBrush object used to fill the interior of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
the width of the ellipse used to draw the rounded corners.
the height of the ellipse used to draw the rounded corners.
the orientation of the rectangle.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double
Dim orientation As Double

instance.DrawRoundRectangle(brush, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
public void DrawRoundRectangle(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
public: void DrawRoundRectangle(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
public:
void DrawRoundRectangle(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.
Remarks
This function fill the interior of the rectangle with the given PDFBrush object.
The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method
a PDFPen object used to draw the border of the rectangle.
a PDFBrush object used to fill the interior of the rectangle.
the x coordinate of the top left corner of the rectangle.
the y coordinate of the top left corner of the rectangle.
the width of the rectangle.
the height of the rectangle.
the width of the ellipse used to draw the rounded corners.
the height of the ellipse used to draw the rounded corners.
the orientation of the rectangle.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double
Dim orientation As Double

instance.DrawRoundRectangle(pen, brush, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
public void DrawRoundRectangle(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
public: void DrawRoundRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.
Remarks
This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.
The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawShading Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawShading Method
Draws the shading on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DrawShading( _
   ByVal shading As PDFShading _
)
'Usage

Dim instance As PDFBasicCanvas
Dim shading As PDFShading

instance.DrawShading(shading)
public void DrawShading(
   PDFShading shading
)
public: void DrawShading(
   PDFShading* shading
)
public:
void DrawShading(
   PDFShading^ shading
)

Parameters

shading
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the shading is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawText Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawText Method
Draws a line of text specified by a string and a pair of coordinates.
Overload List
Overload | Description
DrawText(String,PDFFontBase,PDFBrush,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) | Draws a line of text specified by a string and a pair of coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawText(String,PDFFontBase,PDFBrush,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFBrush,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the drawn text.
the y coordinate of the top left corner of the drawn text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double

instance.DrawText(text, font, brush, x, y)
public void DrawText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y
)
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y
)
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the drawn text.
the y coordinate of the top left corner of the drawn text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double

instance.DrawText(text, font, pen, brush, x, y)
public void DrawText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y
)
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y
)
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase descendant object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the drawn text.
the y coordinate of the top left corner of the drawn text.
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double

instance.DrawText(text, font, brush, x, y, orientation)
public void DrawText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y,
   double orientation
)
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y,
   double orientation
)
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase descendant object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
orientation
the orientation of the text.
Remarks
The text is drawn rotated around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase descendant object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the drawn text.
the y coordinate of the top left corner of the drawn text.
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double

instance.DrawText(text, font, pen, brush, x, y, orientation)
public void DrawText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y,
   double orientation
)
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y,
   double orientation
)
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase descendant object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
orientation
the orientation of the text.
Remarks
The text is drawn rotated around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase descendant object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the printing point.
the y coordinate of the printing point.
the orientation of the text.
a TextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawText(text, font, brush, x, y, orientation, align)
public void DrawText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase descendant object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.
Remarks
The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase descendant object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the printing point.
the y coordinate of the printing point.
the orientation of the text.
a TextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawText(text, font, pen, brush, x, y, orientation, align)
public void DrawText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase descendant object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.
Remarks
The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawTextBox Method
Draws a text specified by a string, a pair of coordinates, a width and a height.
Overload List
Overload | Description
DrawTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawTextBox(text, font, brush, left, top, width, height, textFormatOptions)
public void DrawTextBox(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
public: void DrawTextBox(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
public:
void DrawTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Remarks
The text is automatically wrapped to fit the width of the text box. The formatting of the text is controlled by the textFormatOptions parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawTextBox(text, font, pen, brush, left, top, width, height)
public void DrawTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
public: void DrawTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
public:
void DrawTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
Remarks
The text is automatically wrapped to fit the width of the text box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
the orientation of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation)
public void DrawTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public: void DrawTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
public:
void DrawTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
Remarks
The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
the orientation of the text box.
a TextAlign enumeration member specifying how the text is aligned inside the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation, align)
public void DrawTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align
)
public: void DrawTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align
)
public:
void DrawTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
Remarks
The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
the orientation of the text box.
a PDFTextAlign enumeration member specifying how the text is aligned inside the text box.
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign, _
   ByVal clipText As Boolean _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim align As PDFTextAlign
Dim clipText As Boolean

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation, align, clipText)
public void DrawTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText
)
public: void DrawTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText
)
public:
void DrawTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a PDFTextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
Remarks
The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean,Double) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
the orientation of the text box.
a TextAlign enumeration member specifying how the text is aligned inside the text box.
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
a float value specifying additional space between wrapped lines of text.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign, _
   ByVal clipText As Boolean, _
   ByVal lineSpacing As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim align As PDFTextAlign
Dim clipText As Boolean
Dim lineSpacing As Double

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation, align, clipText, lineSpacing)
public void DrawTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText,
   double lineSpacing
)
public: void DrawTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText,
   double lineSpacing
)
public:
void DrawTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText,
   double lineSpacing
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
lineSpacing
a float value specifying additional space between wrapped lines of text.
Remarks
The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter. The space between lines of text is increased with the value specified by the lineSpacing parameter. If this value is negative, then the lines pf text are drawn closer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method
the string to be drawn.
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
a PDFPen object used to draw the border of the string.
a PDFBrush object used to fill the interior of the string.
the x coordinate of the top left corner of the text box.
the y coordinate of the top left corner of the text box.
the width of the text box.
the height of the text box.
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions)
public void DrawTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
public: void DrawTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
public:
void DrawTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Remarks
The text is automatically wrapped to fit the width of the text box. The formatting of the text is controlled by the textFormatOptions parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


FitHtmlText Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : FitHtmlText Method
Calculates how much of the text really fits in the box.
Overload List
Overload | Description
FitHtmlText(String,Int32,PDFFontBase,Double,Double) | Calculates how much of the text really fits in the box.
FitHtmlText(String,Int32,PDFFontBase,Double,Double,PDFTextFormatOptions) | Calculates how much of the text really fits in the box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


FitHtmlText(String,Int32,PDFFontBase,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > FitHtmlText Method : FitHtmlText(String,Int32,PDFFontBase,Double,Double) Method
the text to fit in the given area.
Position within the text where to start calculating.
the font used to display the text.
the width of the area.
the height of the area.
Calculates how much of the text really fits in the box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function FitHtmlText( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal height As Double _
) As Integer
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim height As Double
Dim value As Integer

value = instance.FitHtmlText(text, startDisplayFrom, font, width, height)
public int FitHtmlText(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width,
   double height
)
public: int FitHtmlText(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width,
   double height
)
public:
int FitHtmlText(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width,
   double height
)

Parameters

text
the text to fit in the given area.
startDisplayFrom
Position within the text where to start calculating.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.

Return Value

an integer value representing the length of the text that fits in the area.
Remarks
The width and height of the area are considered always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


FitHtmlText(String,Int32,PDFFontBase,Double,Double,PDFTextFormatOptions) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > FitHtmlText Method : FitHtmlText(String,Int32,PDFFontBase,Double,Double,PDFTextFormatOptions) Method
the text to fit in the given area.
Position within the text where to start calculating.
the font used to display the text.
the width of the area.
the height of the area.
Options for text formatting.
Calculates how much of the text really fits in the box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function FitHtmlText( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Integer
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Integer

value = instance.FitHtmlText(text, startDisplayFrom, font, width, height, textFormatOptions)
public int FitHtmlText(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
public: int FitHtmlText(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
public:
int FitHtmlText(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to fit in the given area.
startDisplayFrom
Position within the text where to start calculating.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.
textFormatOptions
Options for text formatting.

Return Value

an integer value representing the length of the text that fits in the area.
Remarks
The width and height of the area are considered always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


FitText Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : FitText Method
Calculates how much of the given text fits in the given area.
Overload List
Overload | Description
FitText(String,PDFFontBase,Double,Double) | Calculates how much of the given text fits in the given area.
FitText(String,PDFFontBase,Double,Double,PDFTextFormatOptions) | Calculates how much of the given text fits in the given area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


FitText(String,PDFFontBase,Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > FitText Method : FitText(String,PDFFontBase,Double,Double) Method
the text to fit in the given area.
the font used to display the text.
the width of the area.
the height of the area.
Calculates how much of the given text fits in the given area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function FitText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal height As Double _
) As Integer
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim height As Double
Dim value As Integer

value = instance.FitText(text, font, width, height)
public int FitText(
   string text,
   PDFFontBase font,
   double width,
   double height
)
public: int FitText(
   string* text,
   PDFFontBase* font,
   double width,
   double height
)
public:
int FitText(
   String^ text,
   PDFFontBase^ font,
   double width,
   double height
)

Parameters

text
the text to fit in the given area.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.

Return Value

an integer value representing the length of the text that fits in the area.
Remarks
The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


FitText(String,PDFFontBase,Double,Double,PDFTextFormatOptions) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > FitText Method : FitText(String,PDFFontBase,Double,Double,PDFTextFormatOptions) Method
the text to fit in the given area.
the font used to display the text.
the width of the area.
the height of the area.
Options for text formatting.
Calculates how much of the given text fits in the given area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function FitText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Integer
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Integer

value = instance.FitText(text, font, width, height, textFormatOptions)
public int FitText(
   string text,
   PDFFontBase font,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
public: int FitText(
   string* text,
   PDFFontBase* font,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
public:
int FitText(
   String^ text,
   PDFFontBase^ font,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to fit in the given area.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.
textFormatOptions
Options for text formatting.

Return Value

an integer value representing the length of the text that fits in the area.
Remarks
The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetHtmlTextBoxHeight Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : GetHtmlTextBoxHeight Method
Gets the height of the wrapped HTML text.
Overload List
Overload | Description
GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double) | Gets the height of the wrapped HTML text.
GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) | Gets the height of the wrapped HTML text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetHtmlTextBoxHeight Method : GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double) Method
the text to wrap in the given area.
position within the text where to start wrapping.
the font used to display the text.
the width of the area.
Gets the height of the wrapped HTML text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetHtmlTextBoxHeight( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim value As Double

value = instance.GetHtmlTextBoxHeight(text, startDisplayFrom, font, width)
public double GetHtmlTextBoxHeight(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width
)
public: double GetHtmlTextBoxHeight(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width
)
public:
double GetHtmlTextBoxHeight(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width
)

Parameters

text
the text to wrap in the given area.
startDisplayFrom
position within the text where to start wrapping.
font
the font used to display the text.
width
the width of the area.

Return Value

The height of the wrapped text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetHtmlTextBoxHeight Method : GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method
the text to wrap in the given area.
position within the text where to start wrapping.
the font used to display the text.
the width of the area.
Options for text formatting.
Gets the height of the wrapped HTML text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetHtmlTextBoxHeight( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Double

value = instance.GetHtmlTextBoxHeight(text, startDisplayFrom, font, width, textFormatOptions)
public double GetHtmlTextBoxHeight(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width,
   PDFTextFormatOptions textFormatOptions
)
public: double GetHtmlTextBoxHeight(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width,
   PDFTextFormatOptions* textFormatOptions
)
public:
double GetHtmlTextBoxHeight(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to wrap in the given area.
startDisplayFrom
position within the text where to start wrapping.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.

Return Value

The height of the wrapped text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetHtmlTextBoxLastLineWidth Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : GetHtmlTextBoxLastLineWidth Method
Gets the width of the last line in the HTML text box.
Overload List
Overload | Description
GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double) | Gets the width of the last line in the HTML text box.
GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) | Gets the width of the last line in the HTML text box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetHtmlTextBoxLastLineWidth Method : GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double) Method
the text to wrap in the given area.
position in text where to start wrapping.
the font used to display the text.
the width of the area.
Gets the width of the last line in the HTML text box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetHtmlTextBoxLastLineWidth( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim value As Double

value = instance.GetHtmlTextBoxLastLineWidth(text, startDisplayFrom, font, width)
public double GetHtmlTextBoxLastLineWidth(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width
)
public: double GetHtmlTextBoxLastLineWidth(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width
)
public:
double GetHtmlTextBoxLastLineWidth(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width
)

Parameters

text
the text to wrap in the given area.
startDisplayFrom
position in text where to start wrapping.
font
the font used to display the text.
width
the width of the area.

Return Value

The width of the last wrapped line in the textbox.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetHtmlTextBoxLastLineWidth Method : GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method
the text to wrap in the given area.
position in text where to start wrapping.
the font used to display the text.
the width of the area.
Options for text formatting.
Gets the width of the last line in the HTML text box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetHtmlTextBoxLastLineWidth( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Double

value = instance.GetHtmlTextBoxLastLineWidth(text, startDisplayFrom, font, width, textFormatOptions)
public double GetHtmlTextBoxLastLineWidth(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width,
   PDFTextFormatOptions textFormatOptions
)
public: double GetHtmlTextBoxLastLineWidth(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width,
   PDFTextFormatOptions* textFormatOptions
)
public:
double GetHtmlTextBoxLastLineWidth(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to wrap in the given area.
startDisplayFrom
position in text where to start wrapping.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.

Return Value

The width of the last wrapped line in the textbox.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetTextBoxHeight Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : GetTextBoxHeight Method
Gets the height of the wrapped text.
Overload List
Overload | Description
GetTextBoxHeight(String,PDFFontBase,Double) | Gets the height of the wrapped text.
GetTextBoxHeight(String,PDFFontBase,Double,PDFTextFormatOptions) | Gets the height of the wrapped text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


GetTextBoxHeight(String,PDFFontBase,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetTextBoxHeight Method : GetTextBoxHeight(String,PDFFontBase,Double) Method
the text to wrap in the given area.
the font used to display the text.
the width of the area.
Gets the height of the wrapped text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetTextBoxHeight( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim value As Double

value = instance.GetTextBoxHeight(text, font, width)
public double GetTextBoxHeight(
   string text,
   PDFFontBase font,
   double width
)
public: double GetTextBoxHeight(
   string* text,
   PDFFontBase* font,
   double width
)
public:
double GetTextBoxHeight(
   String^ text,
   PDFFontBase^ font,
   double width
)

Parameters

text
the text to wrap in the given area.
font
the font used to display the text.
width
the width of the area.

Return Value

The height of the wrapped text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetTextBoxHeight(String,PDFFontBase,Double,PDFTextFormatOptions) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetTextBoxHeight Method : GetTextBoxHeight(String,PDFFontBase,Double,PDFTextFormatOptions) Method
the text to wrap in the given area.
the font used to display the text.
the width of the area.
Options for text formatting.
Gets the height of the wrapped text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetTextBoxHeight( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Double

value = instance.GetTextBoxHeight(text, font, width, textFormatOptions)
public double GetTextBoxHeight(
   string text,
   PDFFontBase font,
   double width,
   PDFTextFormatOptions textFormatOptions
)
public: double GetTextBoxHeight(
   string* text,
   PDFFontBase* font,
   double width,
   PDFTextFormatOptions* textFormatOptions
)
public:
double GetTextBoxHeight(
   String^ text,
   PDFFontBase^ font,
   double width,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to wrap in the given area.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.

Return Value

The height of the wrapped text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetTextBoxLastLineWidth Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : GetTextBoxLastLineWidth Method
the text to wrap in the given area.
the font used to display the text.
the width of the area.
Options for text formatting.
Gets the width of the last line in the text box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTextBoxLastLineWidth( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Double
'Usage

Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Double

value = instance.GetTextBoxLastLineWidth(text, font, width, textFormatOptions)
public double GetTextBoxLastLineWidth(
   string text,
   PDFFontBase font,
   double width,
   PDFTextFormatOptions textFormatOptions
)
public: double GetTextBoxLastLineWidth(
   string* text,
   PDFFontBase* font,
   double width,
   PDFTextFormatOptions* textFormatOptions
)
public:
double GetTextBoxLastLineWidth(
   String^ text,
   PDFFontBase^ font,
   double width,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to wrap in the given area.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.

Return Value

The width of the last wrapped line in the textbox.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


MultiplyTransform Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : MultiplyTransform Method
The M11 member of the matrix.
The M12 member of the matrix.
The M21 member of the matrix.
The M22 member of the matrix.
The x translation value.
The y translation value.
Multiplies the current transformation matrix with the one given as parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MultiplyTransform( _
   ByVal m11 As Double, _
   ByVal m12 As Double, _
   ByVal m21 As Double, _
   ByVal m22 As Double, _
   ByVal dx As Double, _
   ByVal dy As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim m11 As Double
Dim m12 As Double
Dim m21 As Double
Dim m22 As Double
Dim dx As Double
Dim dy As Double

instance.MultiplyTransform(m11, m12, m21, m22, dx, dy)
public void MultiplyTransform(
   double m11,
   double m12,
   double m21,
   double m22,
   double dx,
   double dy
)
public: void MultiplyTransform(
   double m11,
   double m12,
   double m21,
   double m22,
   double dx,
   double dy
)
public:
void MultiplyTransform(
   double m11,
   double m12,
   double m21,
   double m22,
   double dx,
   double dy
)

Parameters

m11
The M11 member of the matrix.
m12
The M12 member of the matrix.
m21
The M21 member of the matrix.
m22
The M22 member of the matrix.
dx
The x translation value.
dy
The y translation value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


ResetClipRegion Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : ResetClipRegion Method
Resets the current clipping region to previous clip region.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ResetClipRegion()
'Usage

Dim instance As PDFBasicCanvas

instance.ResetClipRegion()
public void ResetClipRegion()
public: void ResetClipRegion();
public:
void ResetClipRegion();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


ResetCoordinateSystem Method (PDFBasicCanvas)

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : ResetCoordinateSystem Method
Resets the coordinate system to the default PDF coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub ResetCoordinateSystem()
'Usage

Dim instance As PDFBasicCanvas

instance.ResetCoordinateSystem()
public virtual void ResetCoordinateSystem()
public: virtual void ResetCoordinateSystem();
public:
virtual void ResetCoordinateSystem();
Remarks
When PDF4NET creates a drawin surface (a canvas) it sets the coordinate system to top left corner. This methods resets this coordinate system to the default PDF coordinate system in bottom left corner. The method assumes that only the transformations created by PDF4NET are in place.
Use this method when you want to draw on the canvas graphic operators extracted from a PDF page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


RestoreGraphicState Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : RestoreGraphicState Method
Restores the current graphic state in the PDF content stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RestoreGraphicState()
'Usage

Dim instance As PDFBasicCanvas

instance.RestoreGraphicState()
public void RestoreGraphicState()
public: void RestoreGraphicState();
public:
void RestoreGraphicState();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


RotateTransform Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : RotateTransform Method
The rotation angle in degrees.
Applies a rotate transformation to current transformation matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RotateTransform( _
   ByVal rotate As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim rotate As Double

instance.RotateTransform(rotate)
public void RotateTransform(
   double rotate
)
public: void RotateTransform(
   double rotate
)
public:
void RotateTransform(
   double rotate
)

Parameters

rotate
The rotation angle in degrees.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SaveGraphicState Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SaveGraphicState Method
Saves the current graphic state in the PDF content stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SaveGraphicState()
'Usage

Dim instance As PDFBasicCanvas

instance.SaveGraphicState()
public void SaveGraphicState()
public: void SaveGraphicState();
public:
void SaveGraphicState();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


ScaleTransform Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : ScaleTransform Method
The x scale factor.
The y scale factor.
Applies a scale transformation to current transformation matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ScaleTransform( _
   ByVal sx As Double, _
   ByVal sy As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim sx As Double
Dim sy As Double

instance.ScaleTransform(sx, sy)
public void ScaleTransform(
   double sx,
   double sy
)
public: void ScaleTransform(
   double sx,
   double sy
)
public:
void ScaleTransform(
   double sx,
   double sy
)

Parameters

sx
The x scale factor.
sy
The y scale factor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetAxesDirection Method
Example

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetAxesDirection Method
A xAxisDirection enumeration member specifying the new direction of the X axis.
A yAxisDirection enumeration member specifying the new direction of the Y axis.
Sets the new directions for the axes of the coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetAxesDirection( _
   ByVal xAxisDirection As PDFXAxisDirection, _
   ByVal yAxisDirection As PDFYAxisDirection _
)
'Usage

Dim instance As PDFBasicCanvas
Dim xAxisDirection As PDFXAxisDirection
Dim yAxisDirection As PDFYAxisDirection

instance.SetAxesDirection(xAxisDirection, yAxisDirection)
public void SetAxesDirection(
   PDFXAxisDirection xAxisDirection,
   PDFYAxisDirection yAxisDirection
)
public: void SetAxesDirection(
   PDFXAxisDirection xAxisDirection,
   PDFYAxisDirection yAxisDirection
)
public:
void SetAxesDirection(
   PDFXAxisDirection xAxisDirection,
   PDFYAxisDirection yAxisDirection
)

Parameters

xAxisDirection
A xAxisDirection enumeration member specifying the new direction of the X axis.
yAxisDirection
A yAxisDirection enumeration member specifying the new direction of the Y axis.
Remarks
This method changes the direction of the axes of the coordinate system. The default directions are: top to bottom for the Y axis and left to right for the X axis.
Example
The following example sets the direction of the Y axis to be from bottom to top. It also sets the origin of the coordinate system to bottom left corner of the page (this is the default coordinate system used by pdf files). The sample assumes the current origin of the coordinate system is at top left corner of the page.
  • C#
...
page.Canvas.SetOrigin( 0, page.Height );
page.Canvas.SetAxesDirection( XAxisDirection.LeftToRight, YAxisDirection.BottomToTop );
// the default pdf coordinate system is now in place
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetBlendMode Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetBlendMode Method
A PDFBlendMode enumeration member specifying how colors are combined.
Sets the blending mode for the subsequent drawing operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetBlendMode( _
   ByVal blendMode As PDFBlendMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim blendMode As PDFBlendMode

instance.SetBlendMode(blendMode)
public void SetBlendMode(
   PDFBlendMode blendMode
)
public: void SetBlendMode(
   PDFBlendMode blendMode
)
public:
void SetBlendMode(
   PDFBlendMode blendMode
)

Parameters

blendMode
A PDFBlendMode enumeration member specifying how colors are combined.
Remarks
A blend mode specifies how backdrop color combine with source color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetCharSpace Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetCharSpace Method
Character spacing in unscaled text units.
Sets the character spacing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetCharSpace( _
   ByVal cs As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim cs As Double

instance.SetCharSpace(cs)
public void SetCharSpace(
   double cs
)
public: void SetCharSpace(
   double cs
)
public:
void SetCharSpace(
   double cs
)

Parameters

cs
Character spacing in unscaled text units.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetClipRegion Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetClipRegion Method
Sets a clipping region on page's canvas.
Overload List
Overload | Description
SetClipRegion(PDFPath) | Sets a clipping region on page's canvas.
SetClipRegion(PDFPath,PDFFillMode) | Sets a clipping region on page's canvas.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetClipRegion(PDFPath) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > SetClipRegion Method : SetClipRegion(PDFPath) Method
The path that defines the clipping region.
Sets a clipping region on page's canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetClipRegion( _
   ByVal clipPath As PDFPath _
)
'Usage

Dim instance As PDFBasicCanvas
Dim clipPath As PDFPath

instance.SetClipRegion(clipPath)
public void SetClipRegion(
   PDFPath clipPath
)
public: void SetClipRegion(
   PDFPath* clipPath
)
public:
void SetClipRegion(
   PDFPath^ clipPath
)

Parameters

clipPath
The path that defines the clipping region.
Remarks
The path that defines the clipping region must be a closed path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


SetClipRegion(PDFPath,PDFFillMode) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > SetClipRegion Method : SetClipRegion(PDFPath,PDFFillMode) Method
The path that defines the clipping region.
The fill mode for the clip path.
Sets a clipping region on page's canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetClipRegion( _
   ByVal clipPath As PDFPath, _
   ByVal fillMode As PDFFillMode _
)
'Usage

Dim instance As PDFBasicCanvas
Dim clipPath As PDFPath
Dim fillMode As PDFFillMode

instance.SetClipRegion(clipPath, fillMode)
public void SetClipRegion(
   PDFPath clipPath,
   PDFFillMode fillMode
)
public: void SetClipRegion(
   PDFPath* clipPath,
   PDFFillMode fillMode
)
public:
void SetClipRegion(
   PDFPath^ clipPath,
   PDFFillMode fillMode
)

Parameters

clipPath
The path that defines the clipping region.
fillMode
The fill mode for the clip path.
Remarks
The path that defines the clipping region must be a closed path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


SetExtendedGraphicState Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetExtendedGraphicState Method
The new graphic state.
Sets the current graphic state in the content stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetExtendedGraphicState( _
   ByVal extendedGraphicState As PDFExtendedGraphicState _
)
'Usage

Dim instance As PDFBasicCanvas
Dim extendedGraphicState As PDFExtendedGraphicState

instance.SetExtendedGraphicState(extendedGraphicState)
public void SetExtendedGraphicState(
   PDFExtendedGraphicState extendedGraphicState
)
public: void SetExtendedGraphicState(
   PDFExtendedGraphicState* extendedGraphicState
)
public:
void SetExtendedGraphicState(
   PDFExtendedGraphicState^ extendedGraphicState
)

Parameters

extendedGraphicState
The new graphic state.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetHorizontalScaling Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetHorizontalScaling Method
Horizontal scaling as a percentage of the normal width.
Sets the horizontal scaling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetHorizontalScaling( _
   ByVal hs As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim hs As Double

instance.SetHorizontalScaling(hs)
public void SetHorizontalScaling(
   double hs
)
public: void SetHorizontalScaling(
   double hs
)
public:
void SetHorizontalScaling(
   double hs
)

Parameters

hs
Horizontal scaling as a percentage of the normal width.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetLogicalUnit Method
Example

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetLogicalUnit Method
The new measure unit for subsequent drawing operations.
Sets the logical unit for the drawing operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetLogicalUnit( _
   ByVal logicalUnit As PDFLogicalUnitBase _
)
'Usage

Dim instance As PDFBasicCanvas
Dim logicalUnit As PDFLogicalUnitBase

instance.SetLogicalUnit(logicalUnit)
public void SetLogicalUnit(
   PDFLogicalUnitBase logicalUnit
)
public: void SetLogicalUnit(
   PDFLogicalUnitBase* logicalUnit
)
public:
void SetLogicalUnit(
   PDFLogicalUnitBase^ logicalUnit
)

Parameters

logicalUnit
The new measure unit for subsequent drawing operations.
Remarks
The default logical unit used to position graphic objects on the page is the PDF point (1/72 inches). During the drawing operations, the logical unit can be changed in order to achieve desired functionality. In this way, some objects can be positioned on the page using one logical unit, while other objects can be positioned using another logical unit.
Example
The following example show how to draw different objects on the page using different logical units to position them.
  • C#
...
PDFPen pen = new PDFPen(new PDFColor(255, 0, 0), 1);
PDFDocument doc = new PDFDocument();
PDFPage page = doc.AddPage();
page.Canvas.SetLogicalUnit(new PDFMMLogicalUnit());
// the following drawing operation uses the millimeter
// as a logical unit to draw the line. The milimeter
// was defined as default logical unit for the page.
page.Canvas.DrawLine(pen, 10, 10, 100, 100);

page.Canvas.SetLogicalUnit(new PDFPointLogicalUnit());
// the following drawing operation uses the point, as requested above,
// to draw the line.
page.Canvas.DrawLine(pen, 20, 10, 110, 100);
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetOrigin Method
Example

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetOrigin Method
The X coordinate of the origin.
The Y coordinate of the origin.
Sets the new point of origin for the coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetOrigin( _
   ByVal newXAxisOrigin As Double, _
   ByVal newYAxisOrigin As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim newXAxisOrigin As Double
Dim newYAxisOrigin As Double

instance.SetOrigin(newXAxisOrigin, newYAxisOrigin)
public void SetOrigin(
   double newXAxisOrigin,
   double newYAxisOrigin
)
public: void SetOrigin(
   double newXAxisOrigin,
   double newYAxisOrigin
)
public:
void SetOrigin(
   double newXAxisOrigin,
   double newYAxisOrigin
)

Parameters

newXAxisOrigin
The X coordinate of the origin.
newYAxisOrigin
The Y coordinate of the origin.
Remarks
This method moves the origin of the coordinate system to the new position. The new position is always given relative to the current origin. The values specifying the new origin are given in logical units.
Example
The following example sets the origin of the coordinate system at 100mm from the left margin of the page and at 100mm from the top margin of the page. The example assumes the current origin is set at the top left corner of the page. The direction of the axes is left untouched, from top to bottom and from left to right.
  • C#
...
page.Canvas.SetLogicalUnit(new PDFMMLogicalUnit());
page.Canvas.SetOrigin(100, 100);
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetOverprint Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetOverprint Method
a value indicating whether overprint is enabled or not for stroke operations.
a value indicating whether overprint is enabled or not for fill operations.
Sets the overprint for the subsequent drawing (stroke and fill) operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetOverprint( _
   ByVal strokeOverprint As Boolean, _
   ByVal fillOverprint As Boolean _
)
'Usage

Dim instance As PDFBasicCanvas
Dim strokeOverprint As Boolean
Dim fillOverprint As Boolean

instance.SetOverprint(strokeOverprint, fillOverprint)
public void SetOverprint(
   bool strokeOverprint,
   bool fillOverprint
)
public: void SetOverprint(
   bool strokeOverprint,
   bool fillOverprint
)
public:
void SetOverprint(
   bool strokeOverprint,
   bool fillOverprint
)

Parameters

strokeOverprint
a value indicating whether overprint is enabled or not for stroke operations.
fillOverprint
a value indicating whether overprint is enabled or not for fill operations.
Remarks
If true, the overprint is enabled for subsequent drawing (stroke and/or fill) operations.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetTransparency Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetTransparency Method
a double value specifying the transparency level.
Sets the transparency level for the subsequent drawing operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTransparency( _
   ByVal transparency As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim transparency As Double

instance.SetTransparency(transparency)
public void SetTransparency(
   double transparency
)
public: void SetTransparency(
   double transparency
)
public:
void SetTransparency(
   double transparency
)

Parameters

transparency
a double value specifying the transparency level.
Remarks
The transparency level can take any value between 0 and 100. 100 means full transparency (100%), 0 means opaque (0% transparency).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetupCoordinateSystem Method (PDFBasicCanvas)

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetupCoordinateSystem Method
Sets the coordinate system to top left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub SetupCoordinateSystem()
'Usage

Dim instance As PDFBasicCanvas

instance.SetupCoordinateSystem()
public virtual void SetupCoordinateSystem()
public: virtual void SetupCoordinateSystem();
public:
virtual void SetupCoordinateSystem();
Remarks
When PDF4NET creates a drawin surface (a canvas) it sets the coordinate system to top left corner. If the coordinate system was reset the ResetCoordinateSystem then this method sets it back to top left corner.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetWordSpace Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetWordSpace Method
Word spacing in unscaled text units.
Sets the word spacing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetWordSpace( _
   ByVal ws As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim ws As Double

instance.SetWordSpace(ws)
public void SetWordSpace(
   double ws
)
public: void SetWordSpace(
   double ws
)
public:
void SetWordSpace(
   double ws
)

Parameters

ws
Word spacing in unscaled text units.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


ToString Method (PDFBasicCanvas)

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : ToString Method
Gets the string representation of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFBasicCanvas
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The canvas content as a string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


TranslateTransform Method

O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : TranslateTransform Method
The x translation value.
The y translation value.
Applies a translate transformation to current transformation matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub TranslateTransform( _
   ByVal dx As Double, _
   ByVal dy As Double _
)
'Usage

Dim instance As PDFBasicCanvas
Dim dx As Double
Dim dy As Double

instance.TranslateTransform(dx, dy)
public void TranslateTransform(
   double dx,
   double dy
)
public: void TranslateTransform(
   double dx,
   double dy
)
public:
void TranslateTransform(
   double dx,
   double dy
)

Parameters

dx
The x translation value.
dy
The y translation value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


%%PageItemTitle%%

PDFBrush Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFBrush Class
Defines an object used to fill a closed shape with a single color.
Object Model
PDFBrush ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFBrush
'Usage

Dim instance As PDFBrush
public class PDFBrush
public __gc class PDFBrush
public ref class PDFBrush
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFHatchBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFBrush Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFBrush Class

The following tables list the members exposed by PDFBrush.

Public Constructors
 | Name | Description
Public Constructor | PDFBrush Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object.
Top
See Also

Reference

PDFBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFBrush Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class : PDFBrush Constructor
Overload List
Overload | Description
PDFBrush Constructor() | Initializes a new PDFBrush object of White color.
PDFBrush Constructor(PDFBrush) | Initializes a new PDFBrush object based on the given brush.
PDFBrush Constructor(PDFColor) | Initializes a new PDFBrush object of the specified color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBrush Class
PDFBrush Members


%%PageItemTitle%%

PDFBrush Constructor()

O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class > PDFBrush Constructor : PDFBrush Constructor()
Initializes a new PDFBrush object of White color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFBrush()
public PDFBrush()
public: PDFBrush();
public:
PDFBrush();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBrush Class
PDFBrush Members
Overload List


%%PageItemTitle%%

PDFBrush Constructor(PDFBrush)

O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class > PDFBrush Constructor : PDFBrush Constructor(PDFBrush)
Initializes a new PDFBrush object based on the given brush.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal brush As PDFBrush _
)
'Usage

Dim brush As PDFBrush

Dim instance As New PDFBrush(brush)
public PDFBrush(
   PDFBrush brush
)
public: PDFBrush(
   PDFBrush* brush
)
public:
PDFBrush(
   PDFBrush^ brush
)

Parameters

brush
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBrush Class
PDFBrush Members
Overload List


%%PageItemTitle%%

PDFBrush Constructor(PDFColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class > PDFBrush Constructor : PDFBrush Constructor(PDFColor)
a PDFColor object that represents the color of this brush
Initializes a new PDFBrush object of the specified color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As PDFColor _
)
'Usage

Dim color As PDFColor

Dim instance As New PDFBrush(color)
public PDFBrush(
   PDFColor color
)
public: PDFBrush(
   PDFColor* color
)
public:
PDFBrush(
   PDFColor^ color
)

Parameters

color
a PDFColor object that represents the color of this brush
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBrush Class
PDFBrush Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFBrush Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFBrush Class

For a list of all members of this type, see PDFBrush members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object.
Top
See Also

Reference

PDFBrush Class
O2S.Components.PDF4NET.Graphics Namespace


Color Property (PDFBrush)

O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class : Color Property
Gets or sets the color of this Brush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Color As PDFColor
'Usage

Dim instance As PDFBrush
Dim value As PDFColor

instance.Color = value

value = instance.Color
public virtual PDFColor Color {get; set;}
public: __property virtual PDFColor* get_Color();
public: __property virtual void set_Color(
   PDFColor* value
);
public:
virtual property PDFColor^ Color {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

The color of this brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBrush Class
PDFBrush Members


%%PageItemTitle%%

PDFCalGrayColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFCalGrayColor Class
Defines a calibrated gray color, based on a CalGray colorspace.
Object Model
PDFCalGrayColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCalGrayColor
   Inherits PDFColor
'Usage

Dim instance As PDFCalGrayColor
public class PDFCalGrayColor : PDFColor
public __gc class PDFCalGrayColor : public PDFColor
public ref class PDFCalGrayColor : public PDFColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFCalGrayColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFCalGrayColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCalGrayColor Class

The following tables list the members exposed by PDFCalGrayColor.

Public Constructors
 | Name | Description
Public Constructor | PDFCalGrayColor Constructor | Initializes a new PDFCalGrayColor object.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Gray | Gets or sets the gray level for this color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFCalGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFCalGrayColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : PDFCalGrayColor Constructor
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace object the color is based on.
Initializes a new PDFCalGrayColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PDFCalGrayColorSpace _
)
'Usage

Dim colorSpace As PDFCalGrayColorSpace

Dim instance As New PDFCalGrayColor(colorSpace)
public PDFCalGrayColor(
   PDFCalGrayColorSpace colorSpace
)
public: PDFCalGrayColor(
   PDFCalGrayColorSpace* colorSpace
)
public:
PDFCalGrayColor(
   PDFCalGrayColorSpace^ colorSpace
)

Parameters

colorSpace
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace object the color is based on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


%%PageItemTitle%% $$Methods$$

PDFCalGrayColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCalGrayColor Class

For a list of all members of this type, see PDFCalGrayColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFCalGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFCalGrayColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFCalGrayColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


Equals Method (PDFCalGrayColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFCalGrayColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


GetHashCode Method (PDFCalGrayColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFCalGrayColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


ToString Method (PDFCalGrayColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFCalGrayColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


%%PageItemTitle%% $$Properties$$

PDFCalGrayColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFCalGrayColor Class

For a list of all members of this type, see PDFCalGrayColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Gray | Gets or sets the gray level for this color.
Top
See Also

Reference

PDFCalGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


Gray Property

O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : Gray Property
Gets or sets the gray level for this color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Gray As Double
'Usage

Dim instance As PDFCalGrayColor
Dim value As Double

instance.Gray = value

value = instance.Gray
public double Gray {get; set;}
public: __property double get_Gray();
public: __property void set_Gray(
   double value
);
public:
property double Gray {
   double get();
   void set (    double value);
}

Property Value

The gray level of this color.
Remarks
The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


%%PageItemTitle%%

PDFCalRgbColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFCalRgbColor Class
Defines a calibrated RGB color, based on a CalRGB colorspace.
Object Model
PDFCalRgbColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCalRgbColor
   Inherits PDFColor
'Usage

Dim instance As PDFCalRgbColor
public class PDFCalRgbColor : PDFColor
public __gc class PDFCalRgbColor : public PDFColor
public ref class PDFCalRgbColor : public PDFColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFCalRgbColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFCalRgbColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCalRgbColor Class

The following tables list the members exposed by PDFCalRgbColor.

Public Constructors
 | Name | Description
Public Constructor | PDFCalRgbColor Constructor | Initializes a new PDFCalRgbColor object.
Top
Public Properties
 | Name | Description
Public Property | Blue | Gets or sets the blue level for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Green | Gets or sets the green level for this color.
Public Property | Red | Gets or sets the red level for this color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFCalRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFCalRgbColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : PDFCalRgbColor Constructor
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace object the color is based on.
Initializes a new PDFCalRgbColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PDFCalRgbColorSpace _
)
'Usage

Dim colorSpace As PDFCalRgbColorSpace

Dim instance As New PDFCalRgbColor(colorSpace)
public PDFCalRgbColor(
   PDFCalRgbColorSpace colorSpace
)
public: PDFCalRgbColor(
   PDFCalRgbColorSpace* colorSpace
)
public:
PDFCalRgbColor(
   PDFCalRgbColorSpace^ colorSpace
)

Parameters

colorSpace
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace object the color is based on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


%%PageItemTitle%% $$Methods$$

PDFCalRgbColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCalRgbColor Class

For a list of all members of this type, see PDFCalRgbColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFCalRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFCalRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFCalRgbColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


Equals Method (PDFCalRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFCalRgbColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


GetHashCode Method (PDFCalRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFCalRgbColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


ToString Method (PDFCalRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFCalRgbColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


%%PageItemTitle%% $$Properties$$

PDFCalRgbColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFCalRgbColor Class

For a list of all members of this type, see PDFCalRgbColor members.

Public Properties
 | Name | Description
Public Property | Blue | Gets or sets the blue level for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Green | Gets or sets the green level for this color.
Public Property | Red | Gets or sets the red level for this color.
Top
See Also

Reference

PDFCalRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


Blue Property

O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Blue Property
Gets or sets the blue level for this color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Blue As Double
'Usage

Dim instance As PDFCalRgbColor
Dim value As Double

instance.Blue = value

value = instance.Blue
public double Blue {get; set;}
public: __property double get_Blue();
public: __property void set_Blue(
   double value
);
public:
property double Blue {
   double get();
   void set (    double value);
}

Property Value

The blue level of this color.
Remarks
The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


Green Property (PDFCalRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Green Property
Gets or sets the green level for this color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Green As Double
'Usage

Dim instance As PDFCalRgbColor
Dim value As Double

instance.Green = value

value = instance.Green
public double Green {get; set;}
public: __property double get_Green();
public: __property void set_Green(
   double value
);
public:
property double Green {
   double get();
   void set (    double value);
}

Property Value

The green level of this color.
Remarks
The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


Red Property

O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Red Property
Gets or sets the red level for this color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Red As Double
'Usage

Dim instance As PDFCalRgbColor
Dim value As Double

instance.Red = value

value = instance.Red
public double Red {get; set;}
public: __property double get_Red();
public: __property void set_Red(
   double value
);
public:
property double Red {
   double get();
   void set (    double value);
}

Property Value

The red level of this color.
Remarks
The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


%%PageItemTitle%%

PDFCanvas Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFCanvas Class
Encapsulates a page's drawing surface.

Supported by Compact .NET Edition.

Object Model
PDFCanvas ClassPDFLayerCollection ClassPDFLayer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class PDFCanvas
   Inherits PDFBasicCanvas
'Usage

Dim instance As PDFCanvas
public sealed class PDFCanvas : PDFBasicCanvas
public __gc __sealed class PDFCanvas : public PDFBasicCanvas
public ref class PDFCanvas sealed : public PDFBasicCanvas
Remarks
This class is mainly used for creating the content of the document. All the drawing functions are exposed by this class. It can not be created directly, it is accessible through the Canvas property of O2S.Components.PDF4NET.PDFPage object.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBasicCanvas
O2S.Components.PDF4NET.Graphics.PDFCanvas

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCanvas Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFCanvas Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCanvas Class

The following tables list the members exposed by PDFCanvas.

Public Properties
 | Name | Description
Public Property | Layers | Gets the collection of layers available for this canvas.
Top
Public Methods
 | Name | Description
Public Method | Clear | Clears the canvas content. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawArc | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four System.Drawing.PointF structures. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawDirect | Overloaded. Writes the buffer to the page content stream. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawGlyphs | Draws a series of glyphs. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawGraphicOperator | Draws the graphic operator on the canvas. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of System.Drawing.PointF structures. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPath | Overloaded. Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of System.Drawing.PointF structures. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPolyPolygon | Overloaded. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawShading | Draws the shading on the page. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | FitHtmlText | Overloaded. Calculates how much of the text really fits in the box. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | FitText | Overloaded. Calculates how much of the given text fits in the given area. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | GetHtmlTextBoxHeight | Overloaded. Gets the height of the wrapped HTML text. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | GetHtmlTextBoxLastLineWidth | Overloaded. Gets the width of the last line in the HTML text box. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | GetTextBoxHeight | Overloaded. Gets the height of the wrapped text. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | GetTextBoxLastLineWidth | Gets the width of the last line in the text box. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | MultiplyTransform | Multiplies the current transformation matrix with the one given as parameter. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | ResetClipRegion | Resets the current clipping region to previous clip region. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | ResetCoordinateSystem | Overridden. Resets the coordinate system to the default PDF coordinate system.
Public Method | RestoreGraphicState | Restores the current graphic state in the PDF content stream. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | RotateTransform | Applies a rotate transformation to current transformation matrix. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SaveGraphicState | Saves the current graphic state in the PDF content stream. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | ScaleTransform | Applies a scale transformation to current transformation matrix. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetCharSpace | Sets the character spacing. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetClipRegion | Overloaded. Sets a clipping region on page's canvas. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetExtendedGraphicState | Sets the current graphic state in the content stream. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetHorizontalScaling | Sets the horizontal scaling. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetOrigin | Sets the new point of origin for the coordinate system. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetupCoordinateSystem | Overridden. Sets the coordinate system to top left corner.
Public Method | SetWordSpace | Sets the word spacing. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | ToString | Gets the string representation of this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | TranslateTransform | Applies a translate transformation to current transformation matrix. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Top
See Also

Reference

PDFCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PDFCanvas Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCanvas Class

For a list of all members of this type, see PDFCanvas members.

Public Methods
 | Name | Description
Public Method | Clear | Clears the canvas content. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawArc | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four System.Drawing.PointF structures. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawDirect | Overloaded. Writes the buffer to the page content stream. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawGlyphs | Draws a series of glyphs. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawGraphicOperator | Draws the graphic operator on the canvas. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of System.Drawing.PointF structures. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPath | Overloaded. Draws a O2S.Components.PDF4NET.Graphics.Shapes.PDFPath object with the specified pen. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of System.Drawing.PointF structures. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawPolyPolygon | Overloaded. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawShading | Draws the shading on the page. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | FitHtmlText | Overloaded. Calculates how much of the text really fits in the box. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | FitText | Overloaded. Calculates how much of the given text fits in the given area. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | GetHtmlTextBoxHeight | Overloaded. Gets the height of the wrapped HTML text. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | GetHtmlTextBoxLastLineWidth | Overloaded. Gets the width of the last line in the HTML text box. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | GetTextBoxHeight | Overloaded. Gets the height of the wrapped text. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | GetTextBoxLastLineWidth | Gets the width of the last line in the text box. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | MultiplyTransform | Multiplies the current transformation matrix with the one given as parameter. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | ResetClipRegion | Resets the current clipping region to previous clip region. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | ResetCoordinateSystem | Overridden. Resets the coordinate system to the default PDF coordinate system.
Public Method | RestoreGraphicState | Restores the current graphic state in the PDF content stream. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | RotateTransform | Applies a rotate transformation to current transformation matrix. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SaveGraphicState | Saves the current graphic state in the PDF content stream. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | ScaleTransform | Applies a scale transformation to current transformation matrix. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetCharSpace | Sets the character spacing. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetClipRegion | Overloaded. Sets a clipping region on page's canvas. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetExtendedGraphicState | Sets the current graphic state in the content stream. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetHorizontalScaling | Sets the horizontal scaling. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetOrigin | Sets the new point of origin for the coordinate system. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | SetupCoordinateSystem | Overridden. Sets the coordinate system to top left corner.
Public Method | SetWordSpace | Sets the word spacing. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | ToString | Gets the string representation of this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Public Method | TranslateTransform | Applies a translate transformation to current transformation matrix. (Inherited from O2S.Components.PDF4NET.Graphics.PDFBasicCanvas)
Top
See Also

Reference

PDFCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


ResetCoordinateSystem Method (PDFCanvas)

O2S.Components.PDF4NET.Graphics Namespace > PDFCanvas Class : ResetCoordinateSystem Method
Resets the coordinate system to the default PDF coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Sub ResetCoordinateSystem()
'Usage

Dim instance As PDFCanvas

instance.ResetCoordinateSystem()
public override void ResetCoordinateSystem()
public: void ResetCoordinateSystem(); override
public:
void ResetCoordinateSystem(); override
Remarks
When PDF4NET creates a drawin surface (a canvas) it sets the coordinate system to top left corner. This methods resets this coordinate system to the default PDF coordinate system in bottom left corner. The method assumes that only the transformations created by PDF4NET are in place.
Use this method when you want to draw on the canvas graphic operators extracted from a PDF page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCanvas Class
PDFCanvas Members


SetupCoordinateSystem Method (PDFCanvas)

O2S.Components.PDF4NET.Graphics Namespace > PDFCanvas Class : SetupCoordinateSystem Method
Sets the coordinate system to top left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Sub SetupCoordinateSystem()
'Usage

Dim instance As PDFCanvas

instance.SetupCoordinateSystem()
public override void SetupCoordinateSystem()
public: void SetupCoordinateSystem(); override
public:
void SetupCoordinateSystem(); override
Remarks
When PDF4NET creates a drawin surface (a canvas) it sets the coordinate system to top left corner. If the coordinate system was reset the ResetCoordinateSystem then this method sets it back to top left corner.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%% $$Properties$$

PDFCanvas Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFCanvas Class

For a list of all members of this type, see PDFCanvas members.

Public Properties
 | Name | Description
Public Property | Layers | Gets the collection of layers available for this canvas.
Top
See Also

Reference

PDFCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


Layers Property

O2S.Components.PDF4NET.Graphics Namespace > PDFCanvas Class : Layers Property
Gets the collection of layers available for this canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Layers As PDFLayerCollection
'Usage

Dim instance As PDFCanvas
Dim value As PDFLayerCollection

value = instance.Layers
public PDFLayerCollection Layers {get;}
public: __property PDFLayerCollection* get_Layers();
public:
property PDFLayerCollection^ Layers {
   PDFLayerCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCanvas Class
PDFCanvas Members


%%PageItemTitle%%

PDFCMLogicalUnit Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFCMLogicalUnit Class
Defines the centimeter as a logical unit.
Object Model
PDFCMLogicalUnit Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCMLogicalUnit
   Inherits PDFLogicalUnitBase
'Usage

Dim instance As PDFCMLogicalUnit
public class PDFCMLogicalUnit : PDFLogicalUnitBase
public __gc class PDFCMLogicalUnit : public PDFLogicalUnitBase
public ref class PDFCMLogicalUnit : public PDFLogicalUnitBase
Remarks
This class defines the centimeter as a logical unit. The mapping between logical unit and pdf unit is 28.34646-to-1, one logical unit equals to 28.34646 pdf units. The mapping functions return the value given as parameter multiplied by 28.34646.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFCMLogicalUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCMLogicalUnit Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFCMLogicalUnit Class Members
Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCMLogicalUnit Class

The following tables list the members exposed by PDFCMLogicalUnit.

Public Constructors
 | Name | Description
Public Constructor | PDFCMLogicalUnit Constructor | Initializes a new PDFCMLogicalUnit object.
Top
Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFCMLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFCMLogicalUnit Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFCMLogicalUnit Class : PDFCMLogicalUnit Constructor
Initializes a new PDFCMLogicalUnit object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCMLogicalUnit()
public PDFCMLogicalUnit()
public: PDFCMLogicalUnit();
public:
PDFCMLogicalUnit();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCMLogicalUnit Class
PDFCMLogicalUnit Members


%%PageItemTitle%% $$Methods$$

PDFCMLogicalUnit Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCMLogicalUnit Class

For a list of all members of this type, see PDFCMLogicalUnit members.

Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFCMLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method (PDFCMLogicalUnit)

O2S.Components.PDF4NET.Graphics Namespace > PDFCMLogicalUnit Class : ToPDFUnitX Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFCMLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
public override double ToPDFUnitX(
   double unit
)
public: double ToPDFUnitX(
   double unit
) override
public:
double ToPDFUnitX(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCMLogicalUnit Class
PDFCMLogicalUnit Members


ToPDFUnitY Method (PDFCMLogicalUnit)

O2S.Components.PDF4NET.Graphics Namespace > PDFCMLogicalUnit Class : ToPDFUnitY Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFCMLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
public override double ToPDFUnitY(
   double unit
)
public: double ToPDFUnitY(
   double unit
) override
public:
double ToPDFUnitY(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCMLogicalUnit Class
PDFCMLogicalUnit Members


%%PageItemTitle%%

PDFCmykColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFCmykColor Class
Defines a CMYK color, a color based on a CMYK device colorspace.
Object Model
PDFCmykColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCmykColor
   Inherits PDFDeviceColor
'Usage

Dim instance As PDFCmykColor
public class PDFCmykColor : PDFDeviceColor
public __gc class PDFCmykColor : public PDFDeviceColor
public ref class PDFCmykColor : public PDFDeviceColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFCmykColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFCmykColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCmykColor Class

The following tables list the members exposed by PDFCmykColor.

Public Constructors
 | Name | Description
Public Constructor | PDFCmykColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | K | Gets or sets the black component of the color.
Public Property | M | Gets or sets the magenta component of the color.
Public Property | Y | Gets or sets the yellow component of the color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFCmykColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFCmykColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : PDFCmykColor Constructor
Overload List
Overload | Description
PDFCmykColor Constructor() | Initializes a new PDFRgbColor object.
PDFCmykColor Constructor(Double,Double,Double,Double) | Initializes a new PDFCmykColor object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

PDFCmykColor Constructor()

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class > PDFCmykColor Constructor : PDFCmykColor Constructor()
Initializes a new PDFRgbColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCmykColor()
public PDFCmykColor()
public: PDFCmykColor();
public:
PDFCmykColor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members
Overload List


%%PageItemTitle%%

PDFCmykColor Constructor(Double,Double,Double,Double)

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class > PDFCmykColor Constructor : PDFCmykColor Constructor(Double,Double,Double,Double)
Cyan component of the color.
Magenta component of the color.
Yellow component of the color.
Black component of the color.
Initializes a new PDFCmykColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal c As Double, _
   ByVal m As Double, _
   ByVal y As Double, _
   ByVal k As Double _
)
'Usage

Dim c As Double
Dim m As Double
Dim y As Double
Dim k As Double

Dim instance As New PDFCmykColor(c, m, y, k)
public PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)
public: PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)
public:
PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)

Parameters

c
Cyan component of the color.
m
Magenta component of the color.
y
Yellow component of the color.
k
Black component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFCmykColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCmykColor Class

For a list of all members of this type, see PDFCmykColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFCmykColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFCmykColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFCmykColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


Equals Method (PDFCmykColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFCmykColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


GetHashCode Method (PDFCmykColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFCmykColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


ToString Method (PDFCmykColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFCmykColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%% $$Properties$$

PDFCmykColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFCmykColor Class

For a list of all members of this type, see PDFCmykColor members.

Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | K | Gets or sets the black component of the color.
Public Property | M | Gets or sets the magenta component of the color.
Public Property | Y | Gets or sets the yellow component of the color.
Top
See Also

Reference

PDFCmykColor Class
O2S.Components.PDF4NET.Graphics Namespace


C Property

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : C Property
Gets or sets the cyan component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property C As Double
'Usage

Dim instance As PDFCmykColor
Dim value As Double

instance.C = value

value = instance.C
public double C {get; set;}
public: __property double get_C();
public: __property void set_C(
   double value
);
public:
property double C {
   double get();
   void set (    double value);
}

Property Value

Cyan component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


K Property

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : K Property
Gets or sets the black component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property K As Double
'Usage

Dim instance As PDFCmykColor
Dim value As Double

instance.K = value

value = instance.K
public double K {get; set;}
public: __property double get_K();
public: __property void set_K(
   double value
);
public:
property double K {
   double get();
   void set (    double value);
}

Property Value

Black component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


M Property

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : M Property
Gets or sets the magenta component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M As Double
'Usage

Dim instance As PDFCmykColor
Dim value As Double

instance.M = value

value = instance.M
public double M {get; set;}
public: __property double get_M();
public: __property void set_M(
   double value
);
public:
property double M {
   double get();
   void set (    double value);
}

Property Value

Magenta component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


Y Property (PDFCmykColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : Y Property
Gets or sets the yellow component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PDFCmykColor
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public: __property double get_Y();
public: __property void set_Y(
   double value
);
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

Yellow component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

PDFColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class
Defines the base class for all PDF colors.
Object Model
PDFColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFColor
'Usage

Dim instance As PDFColor
public abstract class PDFColor
public __gc abstract class PDFColor
public ref class PDFColor abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFCalGrayColor
O2S.Components.PDF4NET.Graphics.PDFCalRgbColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFDeviceNColor
O2S.Components.PDF4NET.Graphics.PDFICCColor
O2S.Components.PDF4NET.Graphics.PDFIndexedColor
O2S.Components.PDF4NET.Graphics.PDFLabColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.PDFShadingPatternColor
O2S.Components.PDF4NET.Graphics.PDFTilingPatternColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

The following tables list the members exposed by PDFColor.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on.
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PDFColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

For a list of all members of this type, see PDFColor members.

Public Methods
 | Name | Description
Public Method | Clone | Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Clone() As Object
'Usage

Dim instance As PDFColor
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public: virtual Object* Clone();
public:
virtual Object^ Clone();

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Class
PDFColor Members


Equals Method (PDFColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Class
PDFColor Members


GetHashCode Method (PDFColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Class
PDFColor Members


ToString Method (PDFColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%% $$Properties$$

PDFColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

For a list of all members of this type, see PDFColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on.
Top
See Also

Reference

PDFColor Class
O2S.Components.PDF4NET.Graphics Namespace


ColorSpace Property (PDFColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : ColorSpace Property
Gets the colorspace this color is based on.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorSpace As PDFColorSpace
'Usage

Dim instance As PDFColor
Dim value As PDFColorSpace

value = instance.ColorSpace
public PDFColorSpace ColorSpace {get;}
public: __property PDFColorSpace* get_ColorSpace();
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
}

Property Value

A colorspace object specifying the colorspace this color was created from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Class
PDFColor Members


%%PageItemTitle%%

PDFCosObjectParamOperator Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFCosObjectParamOperator Class
Defines a PDF graphic operator that has an array of COS objects as parameters.
Object Model
PDFCosObjectParamOperator ClassPDFObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCosObjectParamOperator
   Inherits PDFGraphicOperator
'Usage

Dim instance As PDFCosObjectParamOperator
public class PDFCosObjectParamOperator : PDFGraphicOperator
public __gc class PDFCosObjectParamOperator : public PDFGraphicOperator
public ref class PDFCosObjectParamOperator : public PDFGraphicOperator
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFGraphicOperator
O2S.Components.PDF4NET.Graphics.PDFCosObjectParamOperator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObjectParamOperator Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFCosObjectParamOperator Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCosObjectParamOperator Class

The following tables list the members exposed by PDFCosObjectParamOperator.

Public Constructors
 | Name | Description
Public Constructor | PDFCosObjectParamOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the operator name. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphicOperator)
Public Property | Parameters | Gets or sets the operator parameters.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string.
Top
See Also

Reference

PDFCosObjectParamOperator Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFCosObjectParamOperator Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFCosObjectParamOperator Class : PDFCosObjectParamOperator Constructor
Overload List
Overload | Description
PDFCosObjectParamOperator Constructor() | Initializes a new PDFCosObjectParamOperator object.
PDFCosObjectParamOperator Constructor(String) | Initializes a new PDFCosObjectParamOperator object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObjectParamOperator Class
PDFCosObjectParamOperator Members


%%PageItemTitle%%

PDFCosObjectParamOperator Constructor()

O2S.Components.PDF4NET.Graphics Namespace > PDFCosObjectParamOperator Class > PDFCosObjectParamOperator Constructor : PDFCosObjectParamOperator Constructor()
Initializes a new PDFCosObjectParamOperator object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCosObjectParamOperator()
public PDFCosObjectParamOperator()
public: PDFCosObjectParamOperator();
public:
PDFCosObjectParamOperator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObjectParamOperator Class
PDFCosObjectParamOperator Members
Overload List


%%PageItemTitle%%

PDFCosObjectParamOperator Constructor(String)

O2S.Components.PDF4NET.Graphics Namespace > PDFCosObjectParamOperator Class > PDFCosObjectParamOperator Constructor : PDFCosObjectParamOperator Constructor(String)
The operator name.
Initializes a new PDFCosObjectParamOperator object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFCosObjectParamOperator(name)
public PDFCosObjectParamOperator(
   string name
)
public: PDFCosObjectParamOperator(
   string* name
)
public:
PDFCosObjectParamOperator(
   String^ name
)

Parameters

name
The operator name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObjectParamOperator Class
PDFCosObjectParamOperator Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFCosObjectParamOperator Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFCosObjectParamOperator Class

For a list of all members of this type, see PDFCosObjectParamOperator members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string.
Top
See Also

Reference

PDFCosObjectParamOperator Class
O2S.Components.PDF4NET.Graphics Namespace


ToString Method (PDFCosObjectParamOperator)

O2S.Components.PDF4NET.Graphics Namespace > PDFCosObjectParamOperator Class : ToString Method
Converts the object to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFCosObjectParamOperator
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The object as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObjectParamOperator Class
PDFCosObjectParamOperator Members


%%PageItemTitle%% $$Properties$$

PDFCosObjectParamOperator Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFCosObjectParamOperator Class

For a list of all members of this type, see PDFCosObjectParamOperator members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the operator name. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphicOperator)
Public Property | Parameters | Gets or sets the operator parameters.
Top
See Also

Reference

PDFCosObjectParamOperator Class
O2S.Components.PDF4NET.Graphics Namespace


Parameters Property (PDFCosObjectParamOperator)

O2S.Components.PDF4NET.Graphics Namespace > PDFCosObjectParamOperator Class : Parameters Property
Gets or sets the operator parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Parameters As PDFObject()
'Usage

Dim instance As PDFCosObjectParamOperator
Dim value() As PDFObject

instance.Parameters = value

value = instance.Parameters
public PDFObject[] Parameters {get; set;}
public: __property PDFObject*[]* get_Parameters();
public: __property void set_Parameters(
   PDFObject*[]* value
);
public:
property array<PDFObject^>^ Parameters {
   array<PDFObject^>^ get();
   void set (    array<PDFObject^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCosObjectParamOperator Class
PDFCosObjectParamOperator Members


%%PageItemTitle%%

PDFDeviceColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceColor Class
Defines a device based color.
Object Model
PDFDeviceColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDeviceColor
   Inherits PDFColor
'Usage

Dim instance As PDFDeviceColor
public class PDFDeviceColor : PDFColor
public __gc class PDFDeviceColor : public PDFColor
public ref class PDFDeviceColor : public PDFColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFCmykColor
O2S.Components.PDF4NET.Graphics.PDFGrayColor
O2S.Components.PDF4NET.Graphics.PDFRgbColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceColor Class

The following tables list the members exposed by PDFDeviceColor.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Method | Equals | Verifies if the given object is equal to this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Method | GetHashCode | Gets the hash code of this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Method | ToString | Converts the color object to string representation. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
See Also

Reference

PDFDeviceColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFDeviceNColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceNColor Class
Defines a DeviceN color, based on a DeviceN colorspace.
Object Model
PDFDeviceNColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDeviceNColor
   Inherits PDFColor
'Usage

Dim instance As PDFDeviceNColor
public class PDFDeviceNColor : PDFColor
public __gc class PDFDeviceNColor : public PDFColor
public ref class PDFDeviceNColor : public PDFColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceNColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceNColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceNColor Class

The following tables list the members exposed by PDFDeviceNColor.

Public Constructors
 | Name | Description
Public Constructor | PDFDeviceNColor Constructor | Initializes a new PDFDeviceNColor object.
Top
Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFDeviceNColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFDeviceNColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : PDFDeviceNColor Constructor
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace object the color is based on.
Initializes a new PDFDeviceNColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PDFDeviceNColorSpace _
)
'Usage

Dim colorSpace As PDFDeviceNColorSpace

Dim instance As New PDFDeviceNColor(colorSpace)
public PDFDeviceNColor(
   PDFDeviceNColorSpace colorSpace
)
public: PDFDeviceNColor(
   PDFDeviceNColorSpace* colorSpace
)
public:
PDFDeviceNColor(
   PDFDeviceNColorSpace^ colorSpace
)

Parameters

colorSpace
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace object the color is based on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


%%PageItemTitle%% $$Methods$$

PDFDeviceNColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceNColor Class

For a list of all members of this type, see PDFDeviceNColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFDeviceNColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFDeviceNColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFDeviceNColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


Equals Method (PDFDeviceNColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFDeviceNColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


GetHashCode Method (PDFDeviceNColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFDeviceNColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


ToString Method (PDFDeviceNColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFDeviceNColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


%%PageItemTitle%% $$Properties$$

PDFDeviceNColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceNColor Class

For a list of all members of this type, see PDFDeviceNColor members.

Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
See Also

Reference

PDFDeviceNColor Class
O2S.Components.PDF4NET.Graphics Namespace


ColorComponents Property (PDFDeviceNColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : ColorComponents Property
Gets or sets the color components.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorComponents As Double()
'Usage

Dim instance As PDFDeviceNColor
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
public double[] ColorComponents {get; set;}
public: __property double[]* get_ColorComponents();
public: __property void set_ColorComponents(
   double[]* value
);
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of values that describe the color in the DeviceN colorspace.
Remarks
The length of this array must match the number of O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace.ColorantNames in the underlying DeviceN colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


%%PageItemTitle%%

PDFExtendedGraphicState Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFExtendedGraphicState Class
Defines the current graphic state in a PDF content stream.
Object Model
PDFExtendedGraphicState ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFExtendedGraphicState
'Usage

Dim instance As PDFExtendedGraphicState
public class PDFExtendedGraphicState
public __gc class PDFExtendedGraphicState
public ref class PDFExtendedGraphicState
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFExtendedGraphicState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFExtendedGraphicState Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFExtendedGraphicState Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFExtendedGraphicState Class

The following tables list the members exposed by PDFExtendedGraphicState.

Public Constructors
 | Name | Description
Public Constructor | PDFExtendedGraphicState Constructor | Initializes a new PDFExtendedGraphicState object.
Top
Public Properties
 | Name | Description
Public Property | BlendMode | Gets or sets the blend mode.
Public Property | Dictionary | Gets the extended graphic state dictionary.
Public Property | FillAlpha | Gets or sets the value for the alpha channel for fill operations.
Public Property | FillOverprint | Gets or sets the value for the overprint flag for fill operations.
Public Property | StrokeAlpha | Gets or sets the value for the alpha channel for stroke operations.
Public Property | StrokeOverprint | Gets or sets the value for the overprint flag for stroke operations.
Top
See Also

Reference

PDFExtendedGraphicState Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFExtendedGraphicState Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : PDFExtendedGraphicState Constructor
Initializes a new PDFExtendedGraphicState object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFExtendedGraphicState()
public PDFExtendedGraphicState()
public: PDFExtendedGraphicState();
public:
PDFExtendedGraphicState();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


%%PageItemTitle%% $$Properties$$

PDFExtendedGraphicState Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFExtendedGraphicState Class

For a list of all members of this type, see PDFExtendedGraphicState members.

Public Properties
 | Name | Description
Public Property | BlendMode | Gets or sets the blend mode.
Public Property | Dictionary | Gets the extended graphic state dictionary.
Public Property | FillAlpha | Gets or sets the value for the alpha channel for fill operations.
Public Property | FillOverprint | Gets or sets the value for the overprint flag for fill operations.
Public Property | StrokeAlpha | Gets or sets the value for the alpha channel for stroke operations.
Public Property | StrokeOverprint | Gets or sets the value for the overprint flag for stroke operations.
Top
See Also

Reference

PDFExtendedGraphicState Class
O2S.Components.PDF4NET.Graphics Namespace


BlendMode Property

O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : BlendMode Property
Gets or sets the blend mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlendMode As PDFBlendMode
'Usage

Dim instance As PDFExtendedGraphicState
Dim value As PDFBlendMode

instance.BlendMode = value

value = instance.BlendMode
public PDFBlendMode BlendMode {get; set;}
public: __property PDFBlendMode get_BlendMode();
public: __property void set_BlendMode(
   PDFBlendMode value
);
public:
property PDFBlendMode BlendMode {
   PDFBlendMode get();
   void set (    PDFBlendMode value);
}

Property Value

The blend mode for the drawing operations.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


Dictionary Property (PDFExtendedGraphicState)

O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : Dictionary Property
Gets the extended graphic state dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFExtendedGraphicState
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw extended graphic state dictionary.
Remarks
This property gives you direct access to extended graphic state dictionary and its associated resources. Note: Modifying directly the extended graphic state dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


FillAlpha Property

O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : FillAlpha Property
Gets or sets the value for the alpha channel for fill operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillAlpha As Double
'Usage

Dim instance As PDFExtendedGraphicState
Dim value As Double

instance.FillAlpha = value

value = instance.FillAlpha
public double FillAlpha {get; set;}
public: __property double get_FillAlpha();
public: __property void set_FillAlpha(
   double value
);
public:
property double FillAlpha {
   double get();
   void set (    double value);
}

Property Value

A value between 0 and 100 specifying the value for the alpha channel for fill operations.
Remarks
0 means full transparency, 100 means full opacity.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


FillOverprint Property

O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : FillOverprint Property
Gets or sets the value for the overprint flag for fill operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FillOverprint As Boolean
'Usage

Dim instance As PDFExtendedGraphicState
Dim value As Boolean

instance.FillOverprint = value

value = instance.FillOverprint
public bool FillOverprint {get; set;}
public: __property bool get_FillOverprint();
public: __property void set_FillOverprint(
   bool value
);
public:
property bool FillOverprint {
   bool get();
   void set (    bool value);
}

Property Value

True if overprinting should be enabled for fill operations, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


StrokeAlpha Property

O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : StrokeAlpha Property
Gets or sets the value for the alpha channel for stroke operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StrokeAlpha As Double
'Usage

Dim instance As PDFExtendedGraphicState
Dim value As Double

instance.StrokeAlpha = value

value = instance.StrokeAlpha
public double StrokeAlpha {get; set;}
public: __property double get_StrokeAlpha();
public: __property void set_StrokeAlpha(
   double value
);
public:
property double StrokeAlpha {
   double get();
   void set (    double value);
}

Property Value

A value between 0 and 100 specifying the value for the alpha channel for stroking operations.
Remarks
0 means full transparency, 100 means full opacity.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


StrokeOverprint Property

O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : StrokeOverprint Property
Gets or sets the value for the overprint flag for stroke operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StrokeOverprint As Boolean
'Usage

Dim instance As PDFExtendedGraphicState
Dim value As Boolean

instance.StrokeOverprint = value

value = instance.StrokeOverprint
public bool StrokeOverprint {get; set;}
public: __property bool get_StrokeOverprint();
public: __property void set_StrokeOverprint(
   bool value
);
public:
property bool StrokeOverprint {
   bool get();
   void set (    bool value);
}

Property Value

True if overprinting should be enabled for stroke operations, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


%%PageItemTitle%%

PDFGraphicOperator Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFGraphicOperator Class
Defines a PDF operator used in a graphic content stream.
Object Model
PDFGraphicOperator Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGraphicOperator
'Usage

Dim instance As PDFGraphicOperator
public class PDFGraphicOperator
public __gc class PDFGraphicOperator
public ref class PDFGraphicOperator
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFGraphicOperator
O2S.Components.PDF4NET.Graphics.PDFCosObjectParamOperator
O2S.Components.PDF4NET.Graphics.PDFNumericParamOperator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGraphicOperator Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFGraphicOperator Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFGraphicOperator Class

The following tables list the members exposed by PDFGraphicOperator.

Public Constructors
 | Name | Description
Public Constructor | PDFGraphicOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the operator name.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string.
Top
See Also

Reference

PDFGraphicOperator Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFGraphicOperator Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFGraphicOperator Class : PDFGraphicOperator Constructor
Overload List
Overload | Description
PDFGraphicOperator Constructor() | Initializes a new PDFGraphicOperator object.
PDFGraphicOperator Constructor(String) | Initializes a new PDFGraphicOperator object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGraphicOperator Class
PDFGraphicOperator Members


%%PageItemTitle%%

PDFGraphicOperator Constructor()

O2S.Components.PDF4NET.Graphics Namespace > PDFGraphicOperator Class > PDFGraphicOperator Constructor : PDFGraphicOperator Constructor()
Initializes a new PDFGraphicOperator object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFGraphicOperator()
public PDFGraphicOperator()
public: PDFGraphicOperator();
public:
PDFGraphicOperator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGraphicOperator Class
PDFGraphicOperator Members
Overload List


%%PageItemTitle%%

PDFGraphicOperator Constructor(String)

O2S.Components.PDF4NET.Graphics Namespace > PDFGraphicOperator Class > PDFGraphicOperator Constructor : PDFGraphicOperator Constructor(String)
The operator name.
Initializes a new PDFGraphicOperator object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFGraphicOperator(name)
public PDFGraphicOperator(
   string name
)
public: PDFGraphicOperator(
   string* name
)
public:
PDFGraphicOperator(
   String^ name
)

Parameters

name
The operator name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGraphicOperator Class
PDFGraphicOperator Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFGraphicOperator Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFGraphicOperator Class

For a list of all members of this type, see PDFGraphicOperator members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string.
Top
See Also

Reference

PDFGraphicOperator Class
O2S.Components.PDF4NET.Graphics Namespace


ToString Method (PDFGraphicOperator)

O2S.Components.PDF4NET.Graphics Namespace > PDFGraphicOperator Class : ToString Method
Converts the object to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFGraphicOperator
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The object as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGraphicOperator Class
PDFGraphicOperator Members


%%PageItemTitle%% $$Properties$$

PDFGraphicOperator Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFGraphicOperator Class

For a list of all members of this type, see PDFGraphicOperator members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the operator name.
Top
See Also

Reference

PDFGraphicOperator Class
O2S.Components.PDF4NET.Graphics Namespace


Name Property (PDFGraphicOperator)

O2S.Components.PDF4NET.Graphics Namespace > PDFGraphicOperator Class : Name Property
Gets or sets the operator name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFGraphicOperator
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGraphicOperator Class
PDFGraphicOperator Members


%%PageItemTitle%%

PDFGraphicOperatorCollection Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFGraphicOperatorCollection Class
Defines a read only collection of PDFGraphicOperator objects.
Object Model
PDFGraphicOperatorCollection ClassPDFGraphicOperator Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGraphicOperatorCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFGraphicOperator)
'Usage

Dim instance As PDFGraphicOperatorCollection
public class PDFGraphicOperatorCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>
public __gc class PDFGraphicOperatorCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>
public ref class PDFGraphicOperatorCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.Graphics.PDFGraphicOperatorCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGraphicOperatorCollection Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFGraphicOperatorCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFGraphicOperatorCollection Class

The following tables list the members exposed by PDFGraphicOperatorCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Top
See Also

Reference

PDFGraphicOperatorCollection Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFGrayColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFGrayColor Class
Defines a Gray color, a color based on a Gray device colorspace.
Object Model
PDFGrayColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGrayColor
   Inherits PDFDeviceColor
'Usage

Dim instance As PDFGrayColor
public class PDFGrayColor : PDFDeviceColor
public __gc class PDFGrayColor : public PDFDeviceColor
public ref class PDFGrayColor : public PDFDeviceColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFGrayColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFGrayColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFGrayColor Class

The following tables list the members exposed by PDFGrayColor.

Public Constructors
 | Name | Description
Public Constructor | PDFGrayColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | G | Gets or sets the gray level of the color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFGrayColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : PDFGrayColor Constructor
Overload List
Overload | Description
PDFGrayColor Constructor() | Initializes a new PDFGrayColor object.
PDFGrayColor Constructor(Double) | Initializes a new PDFGrayColor object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%%

PDFGrayColor Constructor()

O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class > PDFGrayColor Constructor : PDFGrayColor Constructor()
Initializes a new PDFGrayColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFGrayColor()
public PDFGrayColor()
public: PDFGrayColor();
public:
PDFGrayColor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members
Overload List


%%PageItemTitle%%

PDFGrayColor Constructor(Double)

O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class > PDFGrayColor Constructor : PDFGrayColor Constructor(Double)
Gray level of the color.
Initializes a new PDFGrayColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal g As Double _
)
'Usage

Dim g As Double

Dim instance As New PDFGrayColor(g)
public PDFGrayColor(
   double g
)
public: PDFGrayColor(
   double g
)
public:
PDFGrayColor(
   double g
)

Parameters

g
Gray level of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFGrayColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFGrayColor Class

For a list of all members of this type, see PDFGrayColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFGrayColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFGrayColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


Equals Method (PDFGrayColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFGrayColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


GetHashCode Method (PDFGrayColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFGrayColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


ToString Method (PDFGrayColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFGrayColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%% $$Properties$$

PDFGrayColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFGrayColor Class

For a list of all members of this type, see PDFGrayColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | G | Gets or sets the gray level of the color.
Top
See Also

Reference

PDFGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


G Property (PDFGrayColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : G Property
Gets or sets the gray level of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property G As Double
'Usage

Dim instance As PDFGrayColor
Dim value As Double

instance.G = value

value = instance.G
public double G {get; set;}
public: __property double get_G();
public: __property void set_G(
   double value
);
public:
property double G {
   double get();
   void set (    double value);
}

Property Value

Gray level of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%%

PDFHatchBrush Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFHatchBrush Class
Defines a hatch brush for filling closed shapes.
Object Model
PDFHatchBrush ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFHatchBrush
   Inherits PDFBrush
'Usage

Dim instance As PDFHatchBrush
public class PDFHatchBrush : PDFBrush
public __gc class PDFHatchBrush : public PDFBrush
public ref class PDFHatchBrush : public PDFBrush
Remarks
The type of the hatch brush is defined by the PDFHatchType enumeration.
A hatch brush uses a hatch cell as its basic drawing unit. The hatch cells are drawn repeatedly from left to right, and top to bottom till the closed shaped is filled.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFHatchBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFHatchBrush Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFHatchBrush Class

The following tables list the members exposed by PDFHatchBrush.

Public Constructors
 | Name | Description
Public Constructor | PDFHatchBrush Constructor | Initializes a new PDFHatchBrush object.
Top
Public Properties
 | Name | Description
Public Property | Color | Overridden. Gets or sets the color of this Brush object.
Public Property | HatchBackColor | Gets or sets the hatch background color.
Public Property | HatchForeColor | Gets or sets the hatch foreground color.
Public Property | HatchHorizontalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchBrush object.
Public Property | HatchVerticalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Top
See Also

Reference

PDFHatchBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFHatchBrush Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : PDFHatchBrush Constructor
Initializes a new PDFHatchBrush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal hatchType As PDFHatchType _
)
'Usage

Dim hatchType As PDFHatchType

Dim instance As New PDFHatchBrush(hatchType)
public PDFHatchBrush(
   PDFHatchType hatchType
)
public: PDFHatchBrush(
   PDFHatchType hatchType
)
public:
PDFHatchBrush(
   PDFHatchType hatchType
)

Parameters

hatchType
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


%%PageItemTitle%% $$Properties$$

PDFHatchBrush Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFHatchBrush Class

For a list of all members of this type, see PDFHatchBrush members.

Public Properties
 | Name | Description
Public Property | Color | Overridden. Gets or sets the color of this Brush object.
Public Property | HatchBackColor | Gets or sets the hatch background color.
Public Property | HatchForeColor | Gets or sets the hatch foreground color.
Public Property | HatchHorizontalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchBrush object.
Public Property | HatchVerticalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Top
See Also

Reference

PDFHatchBrush Class
O2S.Components.PDF4NET.Graphics Namespace


Color Property (PDFHatchBrush)

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : Color Property
Gets or sets the color of this Brush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Color As PDFColor
'Usage

Dim instance As PDFHatchBrush
Dim value As PDFColor

instance.Color = value

value = instance.Color
public override PDFColor Color {get; set;}
public: __property PDFColor* get_Color() override;
public: __property void set_Color(
   PDFColor* value
) override;
public:
property PDFColor^ Color {
   PDFColor^ get() override;
   void set (    PDFColor^ value) override;
}

Property Value

The color of this brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchBackColor Property

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchBackColor Property
Gets or sets the hatch background color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchBackColor As PDFColor
'Usage

Dim instance As PDFHatchBrush
Dim value As PDFColor

instance.HatchBackColor = value

value = instance.HatchBackColor
public PDFColor HatchBackColor {get; set;}
public: __property PDFColor* get_HatchBackColor();
public: __property void set_HatchBackColor(
   PDFColor* value
);
public:
property PDFColor^ HatchBackColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A PDFColor object specifying the background color of the hatch.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchForeColor Property

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchForeColor Property
Gets or sets the hatch foreground color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchForeColor As PDFColor
'Usage

Dim instance As PDFHatchBrush
Dim value As PDFColor

instance.HatchForeColor = value

value = instance.HatchForeColor
public PDFColor HatchForeColor {get; set;}
public: __property PDFColor* get_HatchForeColor();
public: __property void set_HatchForeColor(
   PDFColor* value
);
public:
property PDFColor^ HatchForeColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A PDFColor object specifying the foreground color of the hatch.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchHorizontalSize Property

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchHorizontalSize Property
Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchHorizontalSize As Double
'Usage

Dim instance As PDFHatchBrush
Dim value As Double

instance.HatchHorizontalSize = value

value = instance.HatchHorizontalSize
public double HatchHorizontalSize {get; set;}
public: __property double get_HatchHorizontalSize();
public: __property void set_HatchHorizontalSize(
   double value
);
public:
property double HatchHorizontalSize {
   double get();
   void set (    double value);
}

Property Value

A float value specfying the size of horizontal of the hatch cell for this brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchType Property (PDFHatchBrush)

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchType Property
Gets or sets the hatch type for this PDFHatchBrush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchType As PDFHatchType
'Usage

Dim instance As PDFHatchBrush
Dim value As PDFHatchType

instance.HatchType = value

value = instance.HatchType
public PDFHatchType HatchType {get; set;}
public: __property PDFHatchType get_HatchType();
public: __property void set_HatchType(
   PDFHatchType value
);
public:
property PDFHatchType HatchType {
   PDFHatchType get();
   void set (    PDFHatchType value);
}

Property Value

A HatchType enumeration member specfying the hatch type for this brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchVerticalSize Property

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchVerticalSize Property
Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchVerticalSize As Double
'Usage

Dim instance As PDFHatchBrush
Dim value As Double

instance.HatchVerticalSize = value

value = instance.HatchVerticalSize
public double HatchVerticalSize {get; set;}
public: __property double get_HatchVerticalSize();
public: __property void set_HatchVerticalSize(
   double value
);
public:
property double HatchVerticalSize {
   double get();
   void set (    double value);
}

Property Value

A float value specfying the size of horizontal of the hatch cell for this brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


%%PageItemTitle%%

PDFHatchPattern Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFHatchPattern Class
Defines a PDF hatch pattern.
Object Model
PDFHatchPattern ClassPDFColor ClassPDFBasicCanvas ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFHatchPattern
   Inherits PDFTilingPattern
'Usage

Dim instance As PDFHatchPattern
public class PDFHatchPattern : PDFTilingPattern
public __gc class PDFHatchPattern : public PDFTilingPattern
public ref class PDFHatchPattern : public PDFTilingPattern
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFTilingPattern
O2S.Components.PDF4NET.Graphics.PDFHatchPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchPattern Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFHatchPattern Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFHatchPattern Class

The following tables list the members exposed by PDFHatchPattern.

Public Constructors
 | Name | Description
Public Constructor | PDFHatchPattern Constructor | Initializes a new PDFHatchPattern object.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the hatch.
Public Property | Canvas | Gets the pattern canvas. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Public Property | ForeColor | Gets or sets the foreground color of the hatch.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchPattern object.
Public Property | Height | Gets or sets the height of the pattern cell. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Public Property | Width | Gets or sets the width of the pattern cell. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Public Property | XStep | Gets or sets the horizontal spacing between pattern cells. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Public Property | YStep | Gets or sets the vertical spacing between pattern cells. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Top
See Also

Reference

PDFHatchPattern Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFHatchPattern Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchPattern Class : PDFHatchPattern Constructor
The type of the hatch for the pattern.
Initializes a new PDFHatchPattern object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal hatchType As PDFHatchType _
)
'Usage

Dim hatchType As PDFHatchType

Dim instance As New PDFHatchPattern(hatchType)
public PDFHatchPattern(
   PDFHatchType hatchType
)
public: PDFHatchPattern(
   PDFHatchType hatchType
)
public:
PDFHatchPattern(
   PDFHatchType hatchType
)

Parameters

hatchType
The type of the hatch for the pattern.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchPattern Class
PDFHatchPattern Members


%%PageItemTitle%% $$Properties$$

PDFHatchPattern Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFHatchPattern Class

For a list of all members of this type, see PDFHatchPattern members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the hatch.
Public Property | Canvas | Gets the pattern canvas. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Public Property | ForeColor | Gets or sets the foreground color of the hatch.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchPattern object.
Public Property | Height | Gets or sets the height of the pattern cell. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Public Property | Width | Gets or sets the width of the pattern cell. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Public Property | XStep | Gets or sets the horizontal spacing between pattern cells. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Public Property | YStep | Gets or sets the vertical spacing between pattern cells. (Inherited from O2S.Components.PDF4NET.Graphics.PDFTilingPattern)
Top
See Also

Reference

PDFHatchPattern Class
O2S.Components.PDF4NET.Graphics Namespace


BackColor Property (PDFHatchPattern)

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchPattern Class : BackColor Property
Gets or sets the background color of the hatch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BackColor As PDFColor
'Usage

Dim instance As PDFHatchPattern
Dim value As PDFColor

instance.BackColor = value

value = instance.BackColor
public PDFColor BackColor {get; set;}
public: __property PDFColor* get_BackColor();
public: __property void set_BackColor(
   PDFColor* value
);
public:
property PDFColor^ BackColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A PDFColor object specifying the background color for this pattern object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchPattern Class
PDFHatchPattern Members


ForeColor Property

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchPattern Class : ForeColor Property
Gets or sets the foreground color of the hatch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ForeColor As PDFColor
'Usage

Dim instance As PDFHatchPattern
Dim value As PDFColor

instance.ForeColor = value

value = instance.ForeColor
public PDFColor ForeColor {get; set;}
public: __property PDFColor* get_ForeColor();
public: __property void set_ForeColor(
   PDFColor* value
);
public:
property PDFColor^ ForeColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A PDFColor object specifying the foreground color for this pattern object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchPattern Class
PDFHatchPattern Members


HatchType Property (PDFHatchPattern)

O2S.Components.PDF4NET.Graphics Namespace > PDFHatchPattern Class : HatchType Property
Gets or sets the hatch type for this PDFHatchPattern object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchType As PDFHatchType
'Usage

Dim instance As PDFHatchPattern
Dim value As PDFHatchType

instance.HatchType = value

value = instance.HatchType
public PDFHatchType HatchType {get; set;}
public: __property PDFHatchType get_HatchType();
public: __property void set_HatchType(
   PDFHatchType value
);
public:
property PDFHatchType HatchType {
   PDFHatchType get();
   void set (    PDFHatchType value);
}

Property Value

A PDFHatchType enumeration member specifying the type of hatch for this pattern.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHatchPattern Class
PDFHatchPattern Members


%%PageItemTitle%%

PDFHorizontalGradientBrush Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFHorizontalGradientBrush Class
Defines a horizontal gradient brush for filling closed shapes.
Object Model
PDFHorizontalGradientBrush ClassPDFColor ClassPDFDeviceColor ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFHorizontalGradientBrush
   Inherits PDFLinearGradientBrush
'Usage

Dim instance As PDFHorizontalGradientBrush
public class PDFHorizontalGradientBrush : PDFLinearGradientBrush
public __gc class PDFHorizontalGradientBrush : public PDFLinearGradientBrush
public ref class PDFHorizontalGradientBrush : public PDFLinearGradientBrush
Remarks
A horizontal gradient starts on the left and ends on the right of the filled shape.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHorizontalGradientBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHorizontalGradientBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFHorizontalGradientBrush Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFHorizontalGradientBrush Class

The following tables list the members exposed by PDFHorizontalGradientBrush.

Public Constructors
 | Name | Description
Public Constructor | PDFHorizontalGradientBrush Constructor | Initializes a new PDFHorizontalGradientBrush object.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Public Property | EndColor | (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Top
See Also

Reference

PDFHorizontalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFHorizontalGradientBrush Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFHorizontalGradientBrush Class : PDFHorizontalGradientBrush Constructor
Initializes a new PDFHorizontalGradientBrush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFHorizontalGradientBrush()
public PDFHorizontalGradientBrush()
public: PDFHorizontalGradientBrush();
public:
PDFHorizontalGradientBrush();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHorizontalGradientBrush Class
PDFHorizontalGradientBrush Members


%%PageItemTitle%%

PDFICCColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFICCColor Class
Defines an ICC color, based on an ICC colorspace.
Object Model
PDFICCColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFICCColor
   Inherits PDFColor
'Usage

Dim instance As PDFICCColor
public class PDFICCColor : PDFColor
public __gc class PDFICCColor : public PDFColor
public ref class PDFICCColor : public PDFColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFICCColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFICCColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFICCColor Class

The following tables list the members exposed by PDFICCColor.

Public Constructors
 | Name | Description
Public Constructor | PDFICCColor Constructor | Initializes a new PDFICCColor object.
Top
Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFICCColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFICCColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : PDFICCColor Constructor
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace object the color is based on.
Initializes a new PDFICCColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PDFICCColorSpace _
)
'Usage

Dim colorSpace As PDFICCColorSpace

Dim instance As New PDFICCColor(colorSpace)
public PDFICCColor(
   PDFICCColorSpace colorSpace
)
public: PDFICCColor(
   PDFICCColorSpace* colorSpace
)
public:
PDFICCColor(
   PDFICCColorSpace^ colorSpace
)

Parameters

colorSpace
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace object the color is based on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColor Class
PDFICCColor Members


%%PageItemTitle%% $$Methods$$

PDFICCColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFICCColor Class

For a list of all members of this type, see PDFICCColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFICCColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFICCColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFICCColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColor Class
PDFICCColor Members


Equals Method (PDFICCColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFICCColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColor Class
PDFICCColor Members


GetHashCode Method (PDFICCColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFICCColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColor Class
PDFICCColor Members


ToString Method (PDFICCColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFICCColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColor Class
PDFICCColor Members


%%PageItemTitle%% $$Properties$$

PDFICCColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFICCColor Class

For a list of all members of this type, see PDFICCColor members.

Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
See Also

Reference

PDFICCColor Class
O2S.Components.PDF4NET.Graphics Namespace


ColorComponents Property (PDFICCColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : ColorComponents Property
Gets or sets the color components.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorComponents As Double()
'Usage

Dim instance As PDFICCColor
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
public double[] ColorComponents {get; set;}
public: __property double[]* get_ColorComponents();
public: __property void set_ColorComponents(
   double[]* value
);
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of values that describe the color in the ICC colorspace.
Remarks
The length of this array must match the value of O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace.ColorComponents property on the underlying ICC colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColor Class
PDFICCColor Members


%%PageItemTitle%%

PDFInchLogicalUnit Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFInchLogicalUnit Class
Defines the inch as a logical unit.
Object Model
PDFInchLogicalUnit Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFInchLogicalUnit
   Inherits PDFLogicalUnitBase
'Usage

Dim instance As PDFInchLogicalUnit
public class PDFInchLogicalUnit : PDFLogicalUnitBase
public __gc class PDFInchLogicalUnit : public PDFLogicalUnitBase
public ref class PDFInchLogicalUnit : public PDFLogicalUnitBase
Remarks
This class defines the inch as a logical unit. The mapping between logical unit and pdf unit is 72-to-1, one logical unit equals to 72 pdf units. The mapping functions return the value given as parameter multiplied by 72.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFInchLogicalUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInchLogicalUnit Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFInchLogicalUnit Class Members
Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFInchLogicalUnit Class

The following tables list the members exposed by PDFInchLogicalUnit.

Public Constructors
 | Name | Description
Public Constructor | PDFInchLogicalUnit Constructor | Initializes a new PDFInchLogicalUnit object.
Top
Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFInchLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFInchLogicalUnit Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFInchLogicalUnit Class : PDFInchLogicalUnit Constructor
Initializes a new PDFInchLogicalUnit object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFInchLogicalUnit()
public PDFInchLogicalUnit()
public: PDFInchLogicalUnit();
public:
PDFInchLogicalUnit();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInchLogicalUnit Class
PDFInchLogicalUnit Members


%%PageItemTitle%% $$Methods$$

PDFInchLogicalUnit Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFInchLogicalUnit Class

For a list of all members of this type, see PDFInchLogicalUnit members.

Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFInchLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method (PDFInchLogicalUnit)

O2S.Components.PDF4NET.Graphics Namespace > PDFInchLogicalUnit Class : ToPDFUnitX Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFInchLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
public override double ToPDFUnitX(
   double unit
)
public: double ToPDFUnitX(
   double unit
) override
public:
double ToPDFUnitX(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInchLogicalUnit Class
PDFInchLogicalUnit Members


ToPDFUnitY Method (PDFInchLogicalUnit)

O2S.Components.PDF4NET.Graphics Namespace > PDFInchLogicalUnit Class : ToPDFUnitY Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFInchLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
public override double ToPDFUnitY(
   double unit
)
public: double ToPDFUnitY(
   double unit
) override
public:
double ToPDFUnitY(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInchLogicalUnit Class
PDFInchLogicalUnit Members


%%PageItemTitle%%

PDFIndexedColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFIndexedColor Class
Defines an indexed color, based on an indexed colorspace.
Object Model
PDFIndexedColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFIndexedColor
   Inherits PDFColor
'Usage

Dim instance As PDFIndexedColor
public class PDFIndexedColor : PDFColor
public __gc class PDFIndexedColor : public PDFColor
public ref class PDFIndexedColor : public PDFColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFIndexedColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFIndexedColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFIndexedColor Class

The following tables list the members exposed by PDFIndexedColor.

Public Constructors
 | Name | Description
Public Constructor | PDFIndexedColor Constructor | Initializes a new PDFIndexedColor object.
Top
Public Properties
 | Name | Description
Public Property | ColorIndex | Gets or sets the color index.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFIndexedColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFIndexedColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : PDFIndexedColor Constructor
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace object the color is based on.
Initializes a new PDFIndexedColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PDFIndexedColorSpace _
)
'Usage

Dim colorSpace As PDFIndexedColorSpace

Dim instance As New PDFIndexedColor(colorSpace)
public PDFIndexedColor(
   PDFIndexedColorSpace colorSpace
)
public: PDFIndexedColor(
   PDFIndexedColorSpace* colorSpace
)
public:
PDFIndexedColor(
   PDFIndexedColorSpace^ colorSpace
)

Parameters

colorSpace
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace object the color is based on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


%%PageItemTitle%% $$Methods$$

PDFIndexedColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFIndexedColor Class

For a list of all members of this type, see PDFIndexedColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFIndexedColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFIndexedColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFIndexedColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


Equals Method (PDFIndexedColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFIndexedColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


GetHashCode Method (PDFIndexedColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFIndexedColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


ToString Method (PDFIndexedColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFIndexedColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


%%PageItemTitle%% $$Properties$$

PDFIndexedColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFIndexedColor Class

For a list of all members of this type, see PDFIndexedColor members.

Public Properties
 | Name | Description
Public Property | ColorIndex | Gets or sets the color index.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
See Also

Reference

PDFIndexedColor Class
O2S.Components.PDF4NET.Graphics Namespace


ColorIndex Property

O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : ColorIndex Property
Gets or sets the color index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorIndex As Integer
'Usage

Dim instance As PDFIndexedColor
Dim value As Integer

instance.ColorIndex = value

value = instance.ColorIndex
public int ColorIndex {get; set;}
public: __property int get_ColorIndex();
public: __property void set_ColorIndex(
   int value
);
public:
property int ColorIndex {
   int get();
   void set (    int value);
}

Property Value

The index of this color.
Remarks
The acceptable range for this value is 0 - O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace.MaxIndex.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


%%PageItemTitle%%

PDFLabColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFLabColor Class
Defines a calibrated Lab color, based on a Lab colorspace.
Object Model
PDFLabColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLabColor
   Inherits PDFColor
'Usage

Dim instance As PDFLabColor
public class PDFLabColor : PDFColor
public __gc class PDFLabColor : public PDFColor
public ref class PDFLabColor : public PDFColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFLabColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFLabColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFLabColor Class

The following tables list the members exposed by PDFLabColor.

Public Constructors
 | Name | Description
Public Constructor | PDFLabColor Constructor | Initializes a new PDFLabColor object.
Top
Public Properties
 | Name | Description
Public Property | A | Gets or sets the a* component for this color.
Public Property | B | Gets or sets the b* component for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | L | Gets or sets the l component for this color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFLabColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFLabColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : PDFLabColor Constructor
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace object the color is based on.
Initializes a new PDFLabColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PDFLabColorSpace _
)
'Usage

Dim colorSpace As PDFLabColorSpace

Dim instance As New PDFLabColor(colorSpace)
public PDFLabColor(
   PDFLabColorSpace colorSpace
)
public: PDFLabColor(
   PDFLabColorSpace* colorSpace
)
public:
PDFLabColor(
   PDFLabColorSpace^ colorSpace
)

Parameters

colorSpace
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace object the color is based on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColor Class
PDFLabColor Members


%%PageItemTitle%% $$Methods$$

PDFLabColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFLabColor Class

For a list of all members of this type, see PDFLabColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFLabColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFLabColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFLabColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColor Class
PDFLabColor Members


Equals Method (PDFLabColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFLabColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColor Class
PDFLabColor Members


GetHashCode Method (PDFLabColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFLabColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColor Class
PDFLabColor Members


ToString Method (PDFLabColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFLabColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColor Class
PDFLabColor Members


%%PageItemTitle%% $$Properties$$

PDFLabColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFLabColor Class

For a list of all members of this type, see PDFLabColor members.

Public Properties
 | Name | Description
Public Property | A | Gets or sets the a* component for this color.
Public Property | B | Gets or sets the b* component for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | L | Gets or sets the l component for this color.
Top
See Also

Reference

PDFLabColor Class
O2S.Components.PDF4NET.Graphics Namespace


A Property

O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : A Property
Gets or sets the a* component for this color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property A As Double
'Usage

Dim instance As PDFLabColor
Dim value As Double

instance.A = value

value = instance.A
public double A {get; set;}
public: __property double get_A();
public: __property void set_A(
   double value
);
public:
property double A {
   double get();
   void set (    double value);
}

Property Value

The a* component of this color.
Remarks
The range for this value is defined by the O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace.Range property of the underlying Lab colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColor Class
PDFLabColor Members


B Property (PDFLabColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : B Property
Gets or sets the b* component for this color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property B As Double
'Usage

Dim instance As PDFLabColor
Dim value As Double

instance.B = value

value = instance.B
public double B {get; set;}
public: __property double get_B();
public: __property void set_B(
   double value
);
public:
property double B {
   double get();
   void set (    double value);
}

Property Value

The b* component of this color.
Remarks
The range for this value is defined by the O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace.Range property of the underlying Lab colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColor Class
PDFLabColor Members


L Property

O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : L Property
Gets or sets the l component for this color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property L As Double
'Usage

Dim instance As PDFLabColor
Dim value As Double

instance.L = value

value = instance.L
public double L {get; set;}
public: __property double get_L();
public: __property void set_L(
   double value
);
public:
property double L {
   double get();
   void set (    double value);
}

Property Value

The l component of this color.
Remarks
The acceptable range for this value is [0.0 100.0].
0.0 means the darkest color that can be achieved, and 100.0 means the lightest color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColor Class
PDFLabColor Members


%%PageItemTitle%%

PDFLayer Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFLayer Class
Defines a layer on a page's canvas.
Object Model
PDFLayer ClassPDFCanvas Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLayer
'Usage

Dim instance As PDFLayer
public class PDFLayer
public __gc class PDFLayer
public ref class PDFLayer
Remarks
A layer allows to define sections of a content of a PDF document that can be selectively viewed or hidden by PDF consumers (PDF viewer aplications for example).
Regular page content, created through page's canvas, is not included in any layer and it is always visible.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayer Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFLayer Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFLayer Class

The following tables list the members exposed by PDFLayer.

Public Properties
 | Name | Description
Public Property | Canvas | Gets the canvas of the layer.
Public Property | Display | Gets or sets a value indicating whether the layer is displayed on the screen.
Public Property | ID | Gets the ID of this layer.
Public Property | Locked | Gets or sets whether this layer is locked when the document is opened.
Public Property | Name | Gets or sets the name of this layer.
Public Property | Print | Gets or sets a value indicating whether the layer is printed when the document is printed.
Public Property | Visible | Gets or sets whether this layer is visible when the document is opened.
Top
See Also

Reference

PDFLayer Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PDFLayer Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFLayer Class

For a list of all members of this type, see PDFLayer members.

Public Properties
 | Name | Description
Public Property | Canvas | Gets the canvas of the layer.
Public Property | Display | Gets or sets a value indicating whether the layer is displayed on the screen.
Public Property | ID | Gets the ID of this layer.
Public Property | Locked | Gets or sets whether this layer is locked when the document is opened.
Public Property | Name | Gets or sets the name of this layer.
Public Property | Print | Gets or sets a value indicating whether the layer is printed when the document is printed.
Public Property | Visible | Gets or sets whether this layer is visible when the document is opened.
Top
See Also

Reference

PDFLayer Class
O2S.Components.PDF4NET.Graphics Namespace


Canvas Property (PDFLayer)

O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Canvas Property
Gets the canvas of the layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Canvas As PDFCanvas
'Usage

Dim instance As PDFLayer
Dim value As PDFCanvas

value = instance.Canvas
public PDFCanvas Canvas {get;}
public: __property PDFCanvas* get_Canvas();
public:
property PDFCanvas^ Canvas {
   PDFCanvas^ get();
}

Property Value

A PDFCanvas object specifying the drawing surface of the layer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayer Class
PDFLayer Members


Display Property (PDFLayer)

O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Display Property
Gets or sets a value indicating whether the layer is displayed on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Display As Boolean
'Usage

Dim instance As PDFLayer
Dim value As Boolean

instance.Display = value

value = instance.Display
public bool Display {get; set;}
public: __property bool get_Display();
public: __property void set_Display(
   bool value
);
public:
property bool Display {
   bool get();
   void set (    bool value);
}

Property Value

True if the layer is displayed on the screen, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayer Class
PDFLayer Members


ID Property (PDFLayer)

O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : ID Property
Gets the ID of this layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ID As String
'Usage

Dim instance As PDFLayer
Dim value As String

value = instance.ID
public string ID {get;}
public: __property string* get_ID();
public:
property String^ ID {
   String^ get();
}

Property Value

A string value specifying the ID of this layer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayer Class
PDFLayer Members


Locked Property

O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Locked Property
Gets or sets whether this layer is locked when the document is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Locked As Boolean
'Usage

Dim instance As PDFLayer
Dim value As Boolean

instance.Locked = value

value = instance.Locked
public bool Locked {get; set;}
public: __property bool get_Locked();
public: __property void set_Locked(
   bool value
);
public:
property bool Locked {
   bool get();
   void set (    bool value);
}

Property Value

True if this layer is locked when the document is opened, otherwise false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayer Class
PDFLayer Members


Name Property (PDFLayer)

O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Name Property
Gets or sets the name of this layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFLayer
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the name of this layer.
Remarks
This name is displayed in the user interface of the viewer application, allowing the user to show/hide the layer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayer Class
PDFLayer Members


Print Property (PDFLayer)

O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Print Property
Gets or sets a value indicating whether the layer is printed when the document is printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Print As Boolean
'Usage

Dim instance As PDFLayer
Dim value As Boolean

instance.Print = value

value = instance.Print
public bool Print {get; set;}
public: __property bool get_Print();
public: __property void set_Print(
   bool value
);
public:
property bool Print {
   bool get();
   void set (    bool value);
}

Property Value

True if the layer is printed when the document is printed, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayer Class
PDFLayer Members


Visible Property (PDFLayer)

O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Visible Property
Gets or sets whether this layer is visible when the document is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As PDFLayer
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

True if this layer is visible when the document is opened, otherwise false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayer Class
PDFLayer Members


%%PageItemTitle%%

PDFLayerCollection Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFLayerCollection Class
Defines a collection of PDF layers.
Object Model
PDFLayerCollection ClassPDFLayer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLayerCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFLayer,PDFPage)
'Usage

Dim instance As PDFLayerCollection
public class PDFLayerCollection : O2S.Components.PDF4NET.PDFCollection<PDFLayer,PDFPage>
public __gc class PDFLayerCollection : public O2S.Components.PDF4NET.PDFCollection<PDFLayer,PDFPage>
public ref class PDFLayerCollection : public O2S.Components.PDF4NET.PDFCollection<PDFLayer,PDFPage>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Graphics.PDFLayerCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayerCollection Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFLayerCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFLayerCollection Class

The following tables list the members exposed by PDFLayerCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates a new layer with the given name and adds it at the end of the collection.
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | Insert | Overloaded. Creates a new layer with the given name and inserts it at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Top
See Also

Reference

PDFLayerCollection Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PDFLayerCollection Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFLayerCollection Class

For a list of all members of this type, see PDFLayerCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates a new layer with the given name and adds it at the end of the collection.
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | Insert | Overloaded. Creates a new layer with the given name and inserts it at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Top
See Also

Reference

PDFLayerCollection Class
O2S.Components.PDF4NET.Graphics Namespace


Add Method (PDFLayerCollection)

O2S.Components.PDF4NET.Graphics Namespace > PDFLayerCollection Class : Add Method
Creates a new layer with the given name and adds it at the end of the collection.
Overload List
Overload | Description
Add(String) | Creates a new layer with the given name and adds it at the end of the collection.
Add(PDFLayer) | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayerCollection Class
PDFLayerCollection Members


Add(String) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFLayerCollection Class > Add Method : Add(String) Method
the name of the new layer.
Creates a new layer with the given name and adds it at the end of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Add( _
   ByVal name As String _
) As PDFLayer
'Usage

Dim instance As PDFLayerCollection
Dim name As String
Dim value As PDFLayer

value = instance.Add(name)
public PDFLayer Add(
   string name
)
public: PDFLayer* Add(
   string* name
)
public:
PDFLayer^ Add(
   String^ name
)

Parameters

name
the name of the new layer.

Return Value

a PDFLayer object representing the new layer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayerCollection Class
PDFLayerCollection Members
Overload List


Insert Method (PDFLayerCollection)

O2S.Components.PDF4NET.Graphics Namespace > PDFLayerCollection Class : Insert Method
Creates a new layer with the given name and inserts it at the specified index.
Overload List
Overload | Description
Insert(Int32,String) | Creates a new layer with the given name and inserts it at the specified index.
Insert(Int32,PDFLayer) | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayerCollection Class
PDFLayerCollection Members


Insert(Int32,String) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFLayerCollection Class > Insert Method : Insert(Int32,String) Method
The zero-based index at which the new layer should be inserted.
The name of the new layer.
Creates a new layer with the given name and inserts it at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Insert( _
   ByVal index As Integer, _
   ByVal name As String _
) As PDFLayer
'Usage

Dim instance As PDFLayerCollection
Dim index As Integer
Dim name As String
Dim value As PDFLayer

value = instance.Insert(index, name)
public PDFLayer Insert(
   int index,
   string name
)
public: PDFLayer* Insert(
   int index,
   string* name
)
public:
PDFLayer^ Insert(
   int index,
   String^ name
)

Parameters

index
The zero-based index at which the new layer should be inserted.
name
The name of the new layer.

Return Value

a PDFLayer object representing the new layer.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLayerCollection Class
PDFLayerCollection Members
Overload List


%%PageItemTitle%%

PDFLinearGradientBrush Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientBrush Class
Defines a hatch brush for filling closed shapes.
Object Model
PDFLinearGradientBrush ClassPDFColor ClassPDFDeviceColor ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLinearGradientBrush
   Inherits PDFBrush
'Usage

Dim instance As PDFLinearGradientBrush
public class PDFLinearGradientBrush : PDFBrush
public __gc class PDFLinearGradientBrush : public PDFBrush
public ref class PDFLinearGradientBrush : public PDFBrush
Remarks
The type of the hatch brush is defined by the PDFHatchType enumeration.
A hatch brush uses a hatch cell as its basic drawing unit. The hatch cells are drawn repeatedly from left to right, and top to bottom till the closed shaped is filled.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHorizontalGradientBrush
O2S.Components.PDF4NET.Graphics.PDFVerticalGradientBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinearGradientBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFLinearGradientBrush Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientBrush Class

The following tables list the members exposed by PDFLinearGradientBrush.

Public Constructors
 | Name | Description
Public Constructor | PDFLinearGradientBrush Constructor | Initializes a new PDFHatchBrush object.
Top
Public Properties
 | Name | Description
Public Property | Color | Overridden. Gets or sets the color of this Brush object.
Public Property | EndColor |
Public Property | StartColor | Gets or sets the start color of the gradient.
Top
See Also

Reference

PDFLinearGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFLinearGradientBrush Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientBrush Class : PDFLinearGradientBrush Constructor
Initializes a new PDFHatchBrush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLinearGradientBrush()
public PDFLinearGradientBrush()
public: PDFLinearGradientBrush();
public:
PDFLinearGradientBrush();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinearGradientBrush Class
PDFLinearGradientBrush Members


%%PageItemTitle%% $$Properties$$

PDFLinearGradientBrush Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientBrush Class

For a list of all members of this type, see PDFLinearGradientBrush members.

Public Properties
 | Name | Description
Public Property | Color | Overridden. Gets or sets the color of this Brush object.
Public Property | EndColor |
Public Property | StartColor | Gets or sets the start color of the gradient.
Top
See Also

Reference

PDFLinearGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


Color Property (PDFLinearGradientBrush)

O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientBrush Class : Color Property
Gets or sets the color of this Brush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Color As PDFColor
'Usage

Dim instance As PDFLinearGradientBrush
Dim value As PDFColor

instance.Color = value

value = instance.Color
public override PDFColor Color {get; set;}
public: __property PDFColor* get_Color() override;
public: __property void set_Color(
   PDFColor* value
) override;
public:
property PDFColor^ Color {
   PDFColor^ get() override;
   void set (    PDFColor^ value) override;
}

Property Value

The color of this brush.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinearGradientBrush Class
PDFLinearGradientBrush Members


EndColor Property (PDFLinearGradientBrush)

O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientBrush Class : EndColor Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndColor As PDFDeviceColor
'Usage

Dim instance As PDFLinearGradientBrush
Dim value As PDFDeviceColor

instance.EndColor = value

value = instance.EndColor
public PDFDeviceColor EndColor {get; set;}
public: __property PDFDeviceColor* get_EndColor();
public: __property void set_EndColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ EndColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinearGradientBrush Class
PDFLinearGradientBrush Members


StartColor Property (PDFLinearGradientBrush)

O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientBrush Class : StartColor Property
Gets or sets the start color of the gradient.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartColor As PDFDeviceColor
'Usage

Dim instance As PDFLinearGradientBrush
Dim value As PDFDeviceColor

instance.StartColor = value

value = instance.StartColor
public PDFDeviceColor StartColor {get; set;}
public: __property PDFDeviceColor* get_StartColor();
public: __property void set_StartColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ StartColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

A device color specifying the start color of the gradient.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinearGradientBrush Class
PDFLinearGradientBrush Members


%%PageItemTitle%%

PDFLinearGradientPattern Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientPattern Class
Defines a pattern that represents a linear gradient.
Object Model
PDFLinearGradientPattern ClassPDFColorSpace ClassPDFDeviceColor ClassPDFFunction ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLinearGradientPattern
   Inherits PDFAxialShadingPattern
'Usage

Dim instance As PDFLinearGradientPattern
public class PDFLinearGradientPattern : PDFAxialShadingPattern
public __gc class PDFLinearGradientPattern : public PDFAxialShadingPattern
public ref class PDFLinearGradientPattern : public PDFAxialShadingPattern
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern
O2S.Components.PDF4NET.Graphics.PDFLinearGradientPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinearGradientPattern Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFLinearGradientPattern Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientPattern Class

The following tables list the members exposed by PDFLinearGradientPattern.

Public Constructors
 | Name | Description
Public Constructor | PDFLinearGradientPattern Constructor | Initializes a new PDFLinearGradientPattern object.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern)
Public Property | Coordinates | Gets or sets the shading coordinates. (Inherited from O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern)
Public Property | EndColor | Gets or sets the color at the end of the gradient.
Public Property | Function | Gets or sets the function that defines the axial shading. (Inherited from O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern)
Public Property | StartColor | Gets or sets the color at the start of the gradient.
Top
See Also

Reference

PDFLinearGradientPattern Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFLinearGradientPattern Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientPattern Class : PDFLinearGradientPattern Constructor
Initializes a new PDFLinearGradientPattern object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLinearGradientPattern()
public PDFLinearGradientPattern()
public: PDFLinearGradientPattern();
public:
PDFLinearGradientPattern();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinearGradientPattern Class
PDFLinearGradientPattern Members


%%PageItemTitle%% $$Properties$$

PDFLinearGradientPattern Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientPattern Class

For a list of all members of this type, see PDFLinearGradientPattern members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern)
Public Property | Coordinates | Gets or sets the shading coordinates. (Inherited from O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern)
Public Property | EndColor | Gets or sets the color at the end of the gradient.
Public Property | Function | Gets or sets the function that defines the axial shading. (Inherited from O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern)
Public Property | StartColor | Gets or sets the color at the start of the gradient.
Top
See Also

Reference

PDFLinearGradientPattern Class
O2S.Components.PDF4NET.Graphics Namespace


EndColor Property (PDFLinearGradientPattern)

O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientPattern Class : EndColor Property
Gets or sets the color at the end of the gradient.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndColor As PDFDeviceColor
'Usage

Dim instance As PDFLinearGradientPattern
Dim value As PDFDeviceColor

instance.EndColor = value

value = instance.EndColor
public PDFDeviceColor EndColor {get; set;}
public: __property PDFDeviceColor* get_EndColor();
public: __property void set_EndColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ EndColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

End color of the gradient.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinearGradientPattern Class
PDFLinearGradientPattern Members


StartColor Property (PDFLinearGradientPattern)

O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientPattern Class : StartColor Property
Gets or sets the color at the start of the gradient.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartColor As PDFDeviceColor
'Usage

Dim instance As PDFLinearGradientPattern
Dim value As PDFDeviceColor

instance.StartColor = value

value = instance.StartColor
public PDFDeviceColor StartColor {get; set;}
public: __property PDFDeviceColor* get_StartColor();
public: __property void set_StartColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ StartColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

Start color of the gradient.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinearGradientPattern Class
PDFLinearGradientPattern Members


%%PageItemTitle%%

PDFLogicalUnitBase Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFLogicalUnitBase Class
Base class for all the classes that implement custom logical units.
Object Model
PDFLogicalUnitBase Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFLogicalUnitBase
'Usage

Dim instance As PDFLogicalUnitBase
public abstract class PDFLogicalUnitBase
public __gc abstract class PDFLogicalUnitBase
public ref class PDFLogicalUnitBase abstract
Remarks
This class is the base class for implementing user defined logical units. All classes that represent a custom defined logical unit must implement two methods: ToPDFUnitX( float unit ) and ToPDFUnitY( float unit ). These 2 methods need to define the mapping between the logical unit and measure unit used by pdf files, which is the point (1/72 inches). These 2 methods allow to define custom mappings between logical unit and pdf unit (point) for each axis. The mapping between the logical unit and the pdf unit shows how many pdf units correspond to a logical unit.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFCMLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFInchLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFMMLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFPointLogicalUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLogicalUnitBase Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFLogicalUnitBase Class Members
Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFLogicalUnitBase Class

The following tables list the members exposed by PDFLogicalUnitBase.

Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFLogicalUnitBase Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PDFLogicalUnitBase Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFLogicalUnitBase Class

For a list of all members of this type, see PDFLogicalUnitBase members.

Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFLogicalUnitBase Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method (PDFLogicalUnitBase)

O2S.Components.PDF4NET.Graphics Namespace > PDFLogicalUnitBase Class : ToPDFUnitX Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFLogicalUnitBase
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
public virtual double ToPDFUnitX(
   double unit
)
public: virtual double ToPDFUnitX(
   double unit
)
public:
virtual double ToPDFUnitX(
   double unit
)

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLogicalUnitBase Class
PDFLogicalUnitBase Members


ToPDFUnitY Method (PDFLogicalUnitBase)

O2S.Components.PDF4NET.Graphics Namespace > PDFLogicalUnitBase Class : ToPDFUnitY Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFLogicalUnitBase
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
public virtual double ToPDFUnitY(
   double unit
)
public: virtual double ToPDFUnitY(
   double unit
)
public:
virtual double ToPDFUnitY(
   double unit
)

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLogicalUnitBase Class
PDFLogicalUnitBase Members


%%PageItemTitle%%

PDFMatrix Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFMatrix Class
Defines a tranformation matrix in the PDF content stream.
Object Model
PDFMatrix Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMatrix
'Usage

Dim instance As PDFMatrix
public class PDFMatrix
public __gc class PDFMatrix
public ref class PDFMatrix
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFMatrix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFMatrix Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFMatrix Class

The following tables list the members exposed by PDFMatrix.

Public Constructors
 | Name | Description
Public Constructor | PDFMatrix Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | M11 | Gets or sets the m11 element of the matrix.
Public Property | M12 | Gets or sets the m12 element of the matrix.
Public Property | M21 | Gets or sets the m21 element of the matrix.
Public Property | M22 | Gets or sets the m22 element of the matrix.
Public Property | TX | Gets or sets the tx element of the matrix.
Public Property | TY | Gets or sets the ty element of the matrix.
Top
Public Methods
 | Name | Description
Public Method | Multiply | Multiplies this matrix with another one.
Public Method | Rotate | Rotates the matrix with the specified angle.
Public Method | Scale | Scales the matrix.
Public Method | ToString | Converts the matrix to string representation.
Public Method | TransformPoint | Overloaded. Transforms the point with the affine transformation specifies by this matrix.
Public Method | TransformPoints | Transforms the point with the affine transformation specifies by this matrix.
Public Method | TransformVector | Overloaded. Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Public Method | TransformVectors | Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Public Method | Translate | Translates the matrix.
Top
See Also

Reference

PDFMatrix Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFMatrix Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : PDFMatrix Constructor
Overload List
Overload | Description
PDFMatrix Constructor() | Initializes a new PDFMatrix object.
PDFMatrix Constructor(Double,Double,Double,Double,Double,Double) | Initializes a new PDFMatrix object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%PageItemTitle%%

PDFMatrix Constructor()

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class > PDFMatrix Constructor : PDFMatrix Constructor()
Initializes a new PDFMatrix object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMatrix()
public PDFMatrix()
public: PDFMatrix();
public:
PDFMatrix();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


%%PageItemTitle%%

PDFMatrix Constructor(Double,Double,Double,Double,Double,Double)

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class > PDFMatrix Constructor : PDFMatrix Constructor(Double,Double,Double,Double,Double,Double)
The element located at row 1, column 1 in the matrix.
The element located at row 1, column 2 in the matrix.
The element located at row 2, column 1 in the matrix.
The element located at row 2, column 2 in the matrix.
The X translation offset.
The Y translation offset.
Initializes a new PDFMatrix object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal m11 As Double, _
   ByVal m12 As Double, _
   ByVal m21 As Double, _
   ByVal m22 As Double, _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim m11 As Double
Dim m12 As Double
Dim m21 As Double
Dim m22 As Double
Dim tx As Double
Dim ty As Double

Dim instance As New PDFMatrix(m11, m12, m21, m22, tx, ty)
public PDFMatrix(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)
public: PDFMatrix(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)
public:
PDFMatrix(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)

Parameters

m11
The element located at row 1, column 1 in the matrix.
m12
The element located at row 1, column 2 in the matrix.
m21
The element located at row 2, column 1 in the matrix.
m22
The element located at row 2, column 2 in the matrix.
tx
The X translation offset.
ty
The Y translation offset.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFMatrix Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFMatrix Class

For a list of all members of this type, see PDFMatrix members.

Public Methods
 | Name | Description
Public Method | Multiply | Multiplies this matrix with another one.
Public Method | Rotate | Rotates the matrix with the specified angle.
Public Method | Scale | Scales the matrix.
Public Method | ToString | Converts the matrix to string representation.
Public Method | TransformPoint | Overloaded. Transforms the point with the affine transformation specifies by this matrix.
Public Method | TransformPoints | Transforms the point with the affine transformation specifies by this matrix.
Public Method | TransformVector | Overloaded. Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Public Method | TransformVectors | Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Public Method | Translate | Translates the matrix.
Top
See Also

Reference

PDFMatrix Class
O2S.Components.PDF4NET.Graphics Namespace


Multiply Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : Multiply Method
Matrix to multiply this one to.
Multiplies this matrix with another one.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Multiply( _
   ByVal matrix As PDFMatrix _
)
'Usage

Dim instance As PDFMatrix
Dim matrix As PDFMatrix

instance.Multiply(matrix)
public void Multiply(
   PDFMatrix matrix
)
public: void Multiply(
   PDFMatrix* matrix
)
public:
void Multiply(
   PDFMatrix^ matrix
)

Parameters

matrix
Matrix to multiply this one to.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


Rotate Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : Rotate Method
Angle (degrees) to rotate the matrix.
Rotates the matrix with the specified angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal angle As Double _
)
'Usage

Dim instance As PDFMatrix
Dim angle As Double

instance.Rotate(angle)
public void Rotate(
   double angle
)
public: void Rotate(
   double angle
)
public:
void Rotate(
   double angle
)

Parameters

angle
Angle (degrees) to rotate the matrix.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


Scale Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : Scale Method
X scale factor.
Y scale factor.
Scales the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Scale( _
   ByVal sx As Double, _
   ByVal sy As Double _
)
'Usage

Dim instance As PDFMatrix
Dim sx As Double
Dim sy As Double

instance.Scale(sx, sy)
public void Scale(
   double sx,
   double sy
)
public: void Scale(
   double sx,
   double sy
)
public:
void Scale(
   double sx,
   double sy
)

Parameters

sx
X scale factor.
sy
Y scale factor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


ToString Method (PDFMatrix)

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : ToString Method
Converts the matrix to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFMatrix
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


TransformPoint Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : TransformPoint Method
Transforms the point with the affine transformation specifies by this matrix.
Overload List
Overload | Description
TransformPoint(PDFPoint) | Transforms the point with the affine transformation specifies by this matrix.
TransformPoint(Double,Double) | Transforms the point with the affine transformation specifies by this matrix.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


TransformPoint(PDFPoint) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class > TransformPoint Method : TransformPoint(PDFPoint) Method
Transforms the point with the affine transformation specifies by this matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TransformPoint( _
   ByVal srcPoint As PDFPoint _
) As PDFPoint
'Usage

Dim instance As PDFMatrix
Dim srcPoint As PDFPoint
Dim value As PDFPoint

value = instance.TransformPoint(srcPoint)
public PDFPoint TransformPoint(
   PDFPoint srcPoint
)
public: PDFPoint* TransformPoint(
   PDFPoint* srcPoint
)
public:
PDFPoint^ TransformPoint(
   PDFPoint^ srcPoint
)

Parameters

srcPoint

Return Value

Transformed point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


TransformPoint(Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class > TransformPoint Method : TransformPoint(Double,Double) Method
X coordinate.
Y coordinate.
Transforms the point with the affine transformation specifies by this matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TransformPoint( _
   ByVal x As Double, _
   ByVal y As Double _
) As PDFPoint
'Usage

Dim instance As PDFMatrix
Dim x As Double
Dim y As Double
Dim value As PDFPoint

value = instance.TransformPoint(x, y)
public PDFPoint TransformPoint(
   double x,
   double y
)
public: PDFPoint* TransformPoint(
   double x,
   double y
)
public:
PDFPoint^ TransformPoint(
   double x,
   double y
)

Parameters

x
X coordinate.
y
Y coordinate.

Return Value

Transformed point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


TransformPoints Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : TransformPoints Method
Transforms the point with the affine transformation specifies by this matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub TransformPoints( _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFMatrix
Dim points() As PDFPoint

instance.TransformPoints(points)
public void TransformPoints(
   PDFPoint[] points
)
public: void TransformPoints(
   PDFPoint*[]* points
)
public:
void TransformPoints(
   array<PDFPoint^>^ points
)

Parameters

points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


TransformVector Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : TransformVector Method
Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Overload List
Overload | Description
TransformVector(PDFPoint) | Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
TransformVector(Double,Double) | Transforms the point with the affine transformation specifies by this matrix and ignores the translation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


TransformVector(PDFPoint) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class > TransformVector Method : TransformVector(PDFPoint) Method
Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TransformVector( _
   ByVal srcPoint As PDFPoint _
) As PDFPoint
'Usage

Dim instance As PDFMatrix
Dim srcPoint As PDFPoint
Dim value As PDFPoint

value = instance.TransformVector(srcPoint)
public PDFPoint TransformVector(
   PDFPoint srcPoint
)
public: PDFPoint* TransformVector(
   PDFPoint* srcPoint
)
public:
PDFPoint^ TransformVector(
   PDFPoint^ srcPoint
)

Parameters

srcPoint

Return Value

Transformed point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


TransformVector(Double,Double) Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class > TransformVector Method : TransformVector(Double,Double) Method
X coordinate.
Y coordinate.
Transforms the point with the affine transformation specifies by this matrix and ignores the translation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TransformVector( _
   ByVal x As Double, _
   ByVal y As Double _
) As PDFPoint
'Usage

Dim instance As PDFMatrix
Dim x As Double
Dim y As Double
Dim value As PDFPoint

value = instance.TransformVector(x, y)
public PDFPoint TransformVector(
   double x,
   double y
)
public: PDFPoint* TransformVector(
   double x,
   double y
)
public:
PDFPoint^ TransformVector(
   double x,
   double y
)

Parameters

x
X coordinate.
y
Y coordinate.

Return Value

Transformed point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


TransformVectors Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : TransformVectors Method
Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub TransformVectors( _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFMatrix
Dim points() As PDFPoint

instance.TransformVectors(points)
public void TransformVectors(
   PDFPoint[] points
)
public: void TransformVectors(
   PDFPoint*[]* points
)
public:
void TransformVectors(
   array<PDFPoint^>^ points
)

Parameters

points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


Translate Method

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : Translate Method
x translation offset.
y translation offset.
Translates the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Translate( _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim instance As PDFMatrix
Dim tx As Double
Dim ty As Double

instance.Translate(tx, ty)
public void Translate(
   double tx,
   double ty
)
public: void Translate(
   double tx,
   double ty
)
public:
void Translate(
   double tx,
   double ty
)

Parameters

tx
x translation offset.
ty
y translation offset.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%PageItemTitle%% $$Properties$$

PDFMatrix Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFMatrix Class

For a list of all members of this type, see PDFMatrix members.

Public Properties
 | Name | Description
Public Property | M11 | Gets or sets the m11 element of the matrix.
Public Property | M12 | Gets or sets the m12 element of the matrix.
Public Property | M21 | Gets or sets the m21 element of the matrix.
Public Property | M22 | Gets or sets the m22 element of the matrix.
Public Property | TX | Gets or sets the tx element of the matrix.
Public Property | TY | Gets or sets the ty element of the matrix.
Top
See Also

Reference

PDFMatrix Class
O2S.Components.PDF4NET.Graphics Namespace


M11 Property

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : M11 Property
Gets or sets the m11 element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M11 As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.M11 = value

value = instance.M11
public double M11 {get; set;}
public: __property double get_M11();
public: __property void set_M11(
   double value
);
public:
property double M11 {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


M12 Property

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : M12 Property
Gets or sets the m12 element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M12 As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.M12 = value

value = instance.M12
public double M12 {get; set;}
public: __property double get_M12();
public: __property void set_M12(
   double value
);
public:
property double M12 {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


M21 Property

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : M21 Property
Gets or sets the m21 element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M21 As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.M21 = value

value = instance.M21
public double M21 {get; set;}
public: __property double get_M21();
public: __property void set_M21(
   double value
);
public:
property double M21 {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


M22 Property

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : M22 Property
Gets or sets the m22 element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M22 As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.M22 = value

value = instance.M22
public double M22 {get; set;}
public: __property double get_M22();
public: __property void set_M22(
   double value
);
public:
property double M22 {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


TX Property

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : TX Property
Gets or sets the tx element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TX As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.TX = value

value = instance.TX
public double TX {get; set;}
public: __property double get_TX();
public: __property void set_TX(
   double value
);
public:
property double TX {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


TY Property

O2S.Components.PDF4NET.Graphics Namespace > PDFMatrix Class : TY Property
Gets or sets the ty element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TY As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.TY = value

value = instance.TY
public double TY {get; set;}
public: __property double get_TY();
public: __property void set_TY(
   double value
);
public:
property double TY {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%PageItemTitle%%

PDFMMLogicalUnit Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFMMLogicalUnit Class
Defines the millimeter as a logical unit.
Object Model
PDFMMLogicalUnit Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMMLogicalUnit
   Inherits PDFLogicalUnitBase
'Usage

Dim instance As PDFMMLogicalUnit
public class PDFMMLogicalUnit : PDFLogicalUnitBase
public __gc class PDFMMLogicalUnit : public PDFLogicalUnitBase
public ref class PDFMMLogicalUnit : public PDFLogicalUnitBase
Remarks
This class defines the millimeter as a logical unit. The mapping between logical unit and pdf unit is 2.834646-to-1, one logical unit equals to 2.834646 pdf units. The mapping functions return the value given as parameter multiplied by 2.834646.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFMMLogicalUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMMLogicalUnit Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFMMLogicalUnit Class Members
Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFMMLogicalUnit Class

The following tables list the members exposed by PDFMMLogicalUnit.

Public Constructors
 | Name | Description
Public Constructor | PDFMMLogicalUnit Constructor | Initializes a new PDFMMLogicalUnit object.
Top
Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFMMLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFMMLogicalUnit Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFMMLogicalUnit Class : PDFMMLogicalUnit Constructor
Initializes a new PDFMMLogicalUnit object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMMLogicalUnit()
public PDFMMLogicalUnit()
public: PDFMMLogicalUnit();
public:
PDFMMLogicalUnit();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMMLogicalUnit Class
PDFMMLogicalUnit Members


%%PageItemTitle%% $$Methods$$

PDFMMLogicalUnit Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFMMLogicalUnit Class

For a list of all members of this type, see PDFMMLogicalUnit members.

Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFMMLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method (PDFMMLogicalUnit)

O2S.Components.PDF4NET.Graphics Namespace > PDFMMLogicalUnit Class : ToPDFUnitX Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFMMLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
public override double ToPDFUnitX(
   double unit
)
public: double ToPDFUnitX(
   double unit
) override
public:
double ToPDFUnitX(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMMLogicalUnit Class
PDFMMLogicalUnit Members


ToPDFUnitY Method (PDFMMLogicalUnit)

O2S.Components.PDF4NET.Graphics Namespace > PDFMMLogicalUnit Class : ToPDFUnitY Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFMMLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
public override double ToPDFUnitY(
   double unit
)
public: double ToPDFUnitY(
   double unit
) override
public:
double ToPDFUnitY(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMMLogicalUnit Class
PDFMMLogicalUnit Members


%%PageItemTitle%%

PDFNumericParamOperator Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFNumericParamOperator Class
Defines a PDF graphic operator that has an array of numbers as parameters.
Object Model
PDFNumericParamOperator Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFNumericParamOperator
   Inherits PDFGraphicOperator
'Usage

Dim instance As PDFNumericParamOperator
public class PDFNumericParamOperator : PDFGraphicOperator
public __gc class PDFNumericParamOperator : public PDFGraphicOperator
public ref class PDFNumericParamOperator : public PDFGraphicOperator
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFGraphicOperator
O2S.Components.PDF4NET.Graphics.PDFNumericParamOperator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumericParamOperator Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFNumericParamOperator Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFNumericParamOperator Class

The following tables list the members exposed by PDFNumericParamOperator.

Public Constructors
 | Name | Description
Public Constructor | PDFNumericParamOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the operator name. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphicOperator)
Public Property | Parameters | Gets or sets the operator parameters.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string.
Top
See Also

Reference

PDFNumericParamOperator Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFNumericParamOperator Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFNumericParamOperator Class : PDFNumericParamOperator Constructor
Overload List
Overload | Description
PDFNumericParamOperator Constructor() | Initializes a new PDFNumericParamOperator object.
PDFNumericParamOperator Constructor(String) | Initializes a new PDFNumericParamOperator object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumericParamOperator Class
PDFNumericParamOperator Members


%%PageItemTitle%%

PDFNumericParamOperator Constructor()

O2S.Components.PDF4NET.Graphics Namespace > PDFNumericParamOperator Class > PDFNumericParamOperator Constructor : PDFNumericParamOperator Constructor()
Initializes a new PDFNumericParamOperator object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFNumericParamOperator()
public PDFNumericParamOperator()
public: PDFNumericParamOperator();
public:
PDFNumericParamOperator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumericParamOperator Class
PDFNumericParamOperator Members
Overload List


%%PageItemTitle%%

PDFNumericParamOperator Constructor(String)

O2S.Components.PDF4NET.Graphics Namespace > PDFNumericParamOperator Class > PDFNumericParamOperator Constructor : PDFNumericParamOperator Constructor(String)
The operator name.
Initializes a new PDFNumericParamOperator object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFNumericParamOperator(name)
public PDFNumericParamOperator(
   string name
)
public: PDFNumericParamOperator(
   string* name
)
public:
PDFNumericParamOperator(
   String^ name
)

Parameters

name
The operator name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumericParamOperator Class
PDFNumericParamOperator Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFNumericParamOperator Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFNumericParamOperator Class

For a list of all members of this type, see PDFNumericParamOperator members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to string.
Top
See Also

Reference

PDFNumericParamOperator Class
O2S.Components.PDF4NET.Graphics Namespace


ToString Method (PDFNumericParamOperator)

O2S.Components.PDF4NET.Graphics Namespace > PDFNumericParamOperator Class : ToString Method
Converts the object to string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFNumericParamOperator
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The object as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumericParamOperator Class
PDFNumericParamOperator Members


%%PageItemTitle%% $$Properties$$

PDFNumericParamOperator Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFNumericParamOperator Class

For a list of all members of this type, see PDFNumericParamOperator members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the operator name. (Inherited from O2S.Components.PDF4NET.Graphics.PDFGraphicOperator)
Public Property | Parameters | Gets or sets the operator parameters.
Top
See Also

Reference

PDFNumericParamOperator Class
O2S.Components.PDF4NET.Graphics Namespace


Parameters Property (PDFNumericParamOperator)

O2S.Components.PDF4NET.Graphics Namespace > PDFNumericParamOperator Class : Parameters Property
Gets or sets the operator parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Parameters As Double()
'Usage

Dim instance As PDFNumericParamOperator
Dim value() As Double

instance.Parameters = value

value = instance.Parameters
public double[] Parameters {get; set;}
public: __property double[]* get_Parameters();
public: __property void set_Parameters(
   double[]* value
);
public:
property array<double>^ Parameters {
   array<double>^ get();
   void set (    array<double>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumericParamOperator Class
PDFNumericParamOperator Members


%%PageItemTitle%%

PDFPattern Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFPattern Class
Defines the base class for all PDF patterns.
Object Model
PDFPattern Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFPattern
   Inherits O2S.Components.PDF4NET.PDFGraphicsContainer
'Usage

Dim instance As PDFPattern
public abstract class PDFPattern : O2S.Components.PDF4NET.PDFGraphicsContainer
public __gc abstract class PDFPattern : public O2S.Components.PDF4NET.PDFGraphicsContainer
public ref class PDFPattern abstract : public O2S.Components.PDF4NET.PDFGraphicsContainer
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFTilingPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPattern Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFPattern Class Members

O2S.Components.PDF4NET.Graphics Namespace : PDFPattern Class

The following tables list the members exposed by PDFPattern.

See Also

Reference

PDFPattern Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFPen Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFPen Class
Defines an object used to draw lines and curves. This class cannot be inherited.

Supported by Compact .NET Edition.

Object Model
PDFPen ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class PDFPen
'Usage

Dim instance As PDFPen
public sealed class PDFPen
public __gc __sealed class PDFPen
public ref class PDFPen sealed
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFPen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFPen Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFPen Class

The following tables list the members exposed by PDFPen.

Public Constructors
 | Name | Description
Public Constructor | PDFPen Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this PDFPen object.
Public Property | DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this Pen object.
Public Property | LineCap | Gets or sets the cap style used at the beginning and the end of lines drawn with this Pen object.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.
Public Property | Width | Gets or sets the width of this PDFPen object.
Top
See Also

Reference

PDFPen Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFPen Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : PDFPen Constructor
Overload List
Overload | Description
PDFPen Constructor(PDFColor,Double) | Initializes a new PDFPen object of the specified color and width.
PDFPen Constructor() | Initializes a new PDFPen object.
PDFPen Constructor(PDFPen) | Initializes a new PDFPen object based on the given pen.
PDFPen Constructor(PDFColor) | Initializes a new PDFPen object of the specified color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

PDFPen Constructor(PDFColor,Double)

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor(PDFColor,Double)
the color of the pen.
the width of the pen.
Initializes a new PDFPen object of the specified color and width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As PDFColor, _
   ByVal width As Double _
)
'Usage

Dim color As PDFColor
Dim width As Double

Dim instance As New PDFPen(color, width)
public PDFPen(
   PDFColor color,
   double width
)
public: PDFPen(
   PDFColor* color,
   double width
)
public:
PDFPen(
   PDFColor^ color,
   double width
)

Parameters

color
the color of the pen.
width
the width of the pen.
Remarks
The width of the pen is always set in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


%%PageItemTitle%%

PDFPen Constructor()

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor()
Initializes a new PDFPen object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPen()
public PDFPen()
public: PDFPen();
public:
PDFPen();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


%%PageItemTitle%%

PDFPen Constructor(PDFPen)

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor(PDFPen)
the pen to copy.
Initializes a new PDFPen object based on the given pen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pen As PDFPen _
)
'Usage

Dim pen As PDFPen

Dim instance As New PDFPen(pen)
public PDFPen(
   PDFPen pen
)
public: PDFPen(
   PDFPen* pen
)
public:
PDFPen(
   PDFPen^ pen
)

Parameters

pen
the pen to copy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


%%PageItemTitle%%

PDFPen Constructor(PDFColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor(PDFColor)
the color of the pen.
Initializes a new PDFPen object of the specified color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As PDFColor _
)
'Usage

Dim color As PDFColor

Dim instance As New PDFPen(color)
public PDFPen(
   PDFColor color
)
public: PDFPen(
   PDFColor* color
)
public:
PDFPen(
   PDFColor^ color
)

Parameters

color
the color of the pen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPen Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFPen Class

For a list of all members of this type, see PDFPen members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this PDFPen object.
Public Property | DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this Pen object.
Public Property | LineCap | Gets or sets the cap style used at the beginning and the end of lines drawn with this Pen object.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.
Public Property | Width | Gets or sets the width of this PDFPen object.
Top
See Also

Reference

PDFPen Class
O2S.Components.PDF4NET.Graphics Namespace


Color Property (PDFPen)

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : Color Property
Gets or sets the color of this PDFPen object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As PDFColor
'Usage

Dim instance As PDFPen
Dim value As PDFColor

instance.Color = value

value = instance.Color
public PDFColor Color {get; set;}
public: __property PDFColor* get_Color();
public: __property void set_Color(
   PDFColor* value
);
public:
property PDFColor^ Color {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

The color of the pen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members


DashOffset Property

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : DashOffset Property
Gets or sets the distance from the start of a line to the beginning of a dash pattern.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DashOffset As Double
'Usage

Dim instance As PDFPen
Dim value As Double

instance.DashOffset = value

value = instance.DashOffset
public double DashOffset {get; set;}
public: __property double get_DashOffset();
public: __property void set_DashOffset(
   double value
);
public:
property double DashOffset {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members


DashPattern Property

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : DashPattern Property
Gets or sets an array of custom dashes and spaces.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DashPattern As Double()
'Usage

Dim instance As PDFPen
Dim value() As Double

instance.DashPattern = value

value = instance.DashPattern
public double[] DashPattern {get; set;}
public: __property double[]* get_DashPattern();
public: __property void set_DashPattern(
   double[]* value
);
public:
property array<double>^ DashPattern {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of float values specifying custom dashes and spaces.
Remarks
A custom dashed line is drawn using a dash pattern specified as an array of float values. The odd values represent the length of the dashes in the pattern, and the even values represent the length of the spaces in the pattern. The pattern is repeated until the whole line is drawn.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members


DashStyle Property

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : DashStyle Property
Gets or sets the style used for dashed lines drawn with this Pen object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DashStyle As PDFDashStyle
'Usage

Dim instance As PDFPen
Dim value As PDFDashStyle

instance.DashStyle = value

value = instance.DashStyle
public PDFDashStyle DashStyle {get; set;}
public: __property PDFDashStyle get_DashStyle();
public: __property void set_DashStyle(
   PDFDashStyle value
);
public:
property PDFDashStyle DashStyle {
   PDFDashStyle get();
   void set (    PDFDashStyle value);
}

Property Value

A DashStyle enumeration member specifying how dashed lines are drawn.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members


LineCap Property

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : LineCap Property
Gets or sets the cap style used at the beginning and the end of lines drawn with this Pen object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineCap As PDFLineCap
'Usage

Dim instance As PDFPen
Dim value As PDFLineCap

instance.LineCap = value

value = instance.LineCap
public PDFLineCap LineCap {get; set;}
public: __property PDFLineCap get_LineCap();
public: __property void set_LineCap(
   PDFLineCap value
);
public:
property PDFLineCap LineCap {
   PDFLineCap get();
   void set (    PDFLineCap value);
}

Property Value

a LineCap enumeration member specifying how the lines end.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members


LineJoin Property

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : LineJoin Property
Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineJoin As PDFLineJoin
'Usage

Dim instance As PDFPen
Dim value As PDFLineJoin

instance.LineJoin = value

value = instance.LineJoin
public PDFLineJoin LineJoin {get; set;}
public: __property PDFLineJoin get_LineJoin();
public: __property void set_LineJoin(
   PDFLineJoin value
);
public:
property PDFLineJoin LineJoin {
   PDFLineJoin get();
   void set (    PDFLineJoin value);
}

Property Value

a LineJoin enumeration member specifying the join style for consecutive lines.
Remarks
This join style is used by lines, polygon and rectangle objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members


Width Property (PDFPen)

O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : Width Property
Gets or sets the width of this PDFPen object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFPen
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

a float value specifying the width of this PDFPen object in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPen Class
PDFPen Members


%%PageItemTitle%%

PDFPointLogicalUnit Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFPointLogicalUnit Class
Defines the point (pdf unit) as a logical unit.
Object Model
PDFPointLogicalUnit Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPointLogicalUnit
   Inherits PDFLogicalUnitBase
'Usage

Dim instance As PDFPointLogicalUnit
public class PDFPointLogicalUnit : PDFLogicalUnitBase
public __gc class PDFPointLogicalUnit : public PDFLogicalUnitBase
public ref class PDFPointLogicalUnit : public PDFLogicalUnitBase
Remarks
This class defines the point as a logical unit. The mapping between logical unit and pdf unit is one-to-one, one logical unit equals to one pdf unit. The mapping functions simply return the value given as parameter.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFPointLogicalUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointLogicalUnit Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFPointLogicalUnit Class Members
Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFPointLogicalUnit Class

The following tables list the members exposed by PDFPointLogicalUnit.

Public Constructors
 | Name | Description
Public Constructor | PDFPointLogicalUnit Constructor | Initializes a new PDFPointLogicalUnit object.
Top
Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFPointLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFPointLogicalUnit Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFPointLogicalUnit Class : PDFPointLogicalUnit Constructor
Initializes a new PDFPointLogicalUnit object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPointLogicalUnit()
public PDFPointLogicalUnit()
public: PDFPointLogicalUnit();
public:
PDFPointLogicalUnit();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointLogicalUnit Class
PDFPointLogicalUnit Members


%%PageItemTitle%% $$Methods$$

PDFPointLogicalUnit Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFPointLogicalUnit Class

For a list of all members of this type, see PDFPointLogicalUnit members.

Public Methods
 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top
See Also

Reference

PDFPointLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method (PDFPointLogicalUnit)

O2S.Components.PDF4NET.Graphics Namespace > PDFPointLogicalUnit Class : ToPDFUnitX Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFPointLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
public override double ToPDFUnitX(
   double unit
)
public: double ToPDFUnitX(
   double unit
) override
public:
double ToPDFUnitX(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointLogicalUnit Class
PDFPointLogicalUnit Members


ToPDFUnitY Method (PDFPointLogicalUnit)

O2S.Components.PDF4NET.Graphics Namespace > PDFPointLogicalUnit Class : ToPDFUnitY Method
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
'Usage

Dim instance As PDFPointLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
public override double ToPDFUnitY(
   double unit
)
public: double ToPDFUnitY(
   double unit
) override
public:
double ToPDFUnitY(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.
Remarks
This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointLogicalUnit Class
PDFPointLogicalUnit Members


%%PageItemTitle%%

PDFRgbColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFRgbColor Class
Defines a RGB color, a color based on a RGB device colorspace.
Object Model
PDFRgbColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRgbColor
   Inherits PDFDeviceColor
'Usage

Dim instance As PDFRgbColor
public class PDFRgbColor : PDFDeviceColor
public __gc class PDFRgbColor : public PDFDeviceColor
public ref class PDFRgbColor : public PDFDeviceColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFRgbColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFRgbColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFRgbColor Class

The following tables list the members exposed by PDFRgbColor.

Public Constructors
 | Name | Description
Public Constructor | PDFRgbColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | B | Gets or sets the blue component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | G | Gets or sets the green component of the color.
Public Property | R | Gets or sets the red component of the color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFRgbColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : PDFRgbColor Constructor
Overload List
Overload | Description
PDFRgbColor Constructor() | Initializes a new PDFRgbColor object.
PDFRgbColor Constructor(Byte,Byte,Byte) | Initializes a new PDFRgbColor object.
PDFRgbColor Constructor(Color) | Initializes a new PDFRgbColor object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%%

PDFRgbColor Constructor()

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor()
Initializes a new PDFRgbColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRgbColor()
public PDFRgbColor()
public: PDFRgbColor();
public:
PDFRgbColor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


%%PageItemTitle%%

PDFRgbColor Constructor(Byte,Byte,Byte)

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor(Byte,Byte,Byte)
Red component of the color.
Green component of the color.
Blue component of the color.
Initializes a new PDFRgbColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal r As Byte, _
   ByVal g As Byte, _
   ByVal b As Byte _
)
'Usage

Dim r As Byte
Dim g As Byte
Dim b As Byte

Dim instance As New PDFRgbColor(r, g, b)
public PDFRgbColor(
   byte r,
   byte g,
   byte b
)
public: PDFRgbColor(
   byte r,
   byte g,
   byte b
)
public:
PDFRgbColor(
   byte r,
   byte g,
   byte b
)

Parameters

r
Red component of the color.
g
Green component of the color.
b
Blue component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


%%PageItemTitle%%

PDFRgbColor Constructor(Color)

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor(Color)
Source color.
Initializes a new PDFRgbColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As Color _
)
'Usage

Dim color As Color

Dim instance As New PDFRgbColor(color)
public PDFRgbColor(
   Color color
)
public: PDFRgbColor(
   Color color
)
public:
PDFRgbColor(
   Color color
)

Parameters

color
Source color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFRgbColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFRgbColor Class

For a list of all members of this type, see PDFRgbColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFRgbColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


Equals Method (PDFRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFRgbColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


GetHashCode Method (PDFRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFRgbColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


ToString Method (PDFRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFRgbColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%% $$Properties$$

PDFRgbColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFRgbColor Class

For a list of all members of this type, see PDFRgbColor members.

Public Properties
 | Name | Description
Public Property | B | Gets or sets the blue component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | G | Gets or sets the green component of the color.
Public Property | R | Gets or sets the red component of the color.
Top
See Also

Reference

PDFRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


B Property (PDFRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : B Property
Gets or sets the blue component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property B As Byte
'Usage

Dim instance As PDFRgbColor
Dim value As Byte

instance.B = value

value = instance.B
public byte B {get; set;}
public: __property byte get_B();
public: __property void set_B(
   byte value
);
public:
property byte B {
   byte get();
   void set (    byte value);
}

Property Value

Blue component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


G Property (PDFRgbColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : G Property
Gets or sets the green component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property G As Byte
'Usage

Dim instance As PDFRgbColor
Dim value As Byte

instance.G = value

value = instance.G
public byte G {get; set;}
public: __property byte get_G();
public: __property void set_G(
   byte value
);
public:
property byte G {
   byte get();
   void set (    byte value);
}

Property Value

Green component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


R Property

O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : R Property
Gets or sets the red component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property R As Byte
'Usage

Dim instance As PDFRgbColor
Dim value As Byte

instance.R = value

value = instance.R
public byte R {get; set;}
public: __property byte get_R();
public: __property void set_R(
   byte value
);
public:
property byte R {
   byte get();
   void set (    byte value);
}

Property Value

Red component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%%

PDFSeparationColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFSeparationColor Class
Defines an separation color, based on a separation colorspace.
Object Model
PDFSeparationColor ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSeparationColor
   Inherits PDFColor
'Usage

Dim instance As PDFSeparationColor
public class PDFSeparationColor : PDFColor
public __gc class PDFSeparationColor : public PDFColor
public ref class PDFSeparationColor : public PDFColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFSeparationColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFSeparationColor Class

The following tables list the members exposed by PDFSeparationColor.

Public Constructors
 | Name | Description
Public Constructor | PDFSeparationColor Constructor | Initializes a new PDFSeparationColor object.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Tint | Gets or sets the tint for this color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFSeparationColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFSeparationColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : PDFSeparationColor Constructor
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace object the color is based on.
Initializes a new PDFSeparationColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PDFSeparationColorSpace _
)
'Usage

Dim colorSpace As PDFSeparationColorSpace

Dim instance As New PDFSeparationColor(colorSpace)
public PDFSeparationColor(
   PDFSeparationColorSpace colorSpace
)
public: PDFSeparationColor(
   PDFSeparationColorSpace* colorSpace
)
public:
PDFSeparationColor(
   PDFSeparationColorSpace^ colorSpace
)

Parameters

colorSpace
a O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace object the color is based on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


%%PageItemTitle%% $$Methods$$

PDFSeparationColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFSeparationColor Class

For a list of all members of this type, see PDFSeparationColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFSeparationColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFSeparationColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFSeparationColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


Equals Method (PDFSeparationColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFSeparationColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


GetHashCode Method (PDFSeparationColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFSeparationColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


ToString Method (PDFSeparationColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFSeparationColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


%%PageItemTitle%% $$Properties$$

PDFSeparationColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFSeparationColor Class

For a list of all members of this type, see PDFSeparationColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Tint | Gets or sets the tint for this color.
Top
See Also

Reference

PDFSeparationColor Class
O2S.Components.PDF4NET.Graphics Namespace


Tint Property

O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : Tint Property
Gets or sets the tint for this color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tint As Double
'Usage

Dim instance As PDFSeparationColor
Dim value As Double

instance.Tint = value

value = instance.Tint
public double Tint {get; set;}
public: __property double get_Tint();
public: __property void set_Tint(
   double value
);
public:
property double Tint {
   double get();
   void set (    double value);
}

Property Value

A float value specifying the tint of this color.
Remarks
The acceptable range for this value is [0.0 1.0].
0.0 means the lightest color that can be achieved, and 1.0 means the darkest color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


%%PageItemTitle%%

PDFShadingPattern Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPattern Class
Defines a PDF shading pattern.
Object Model
PDFShadingPattern Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFShadingPattern
   Inherits PDFPattern
'Usage

Dim instance As PDFShadingPattern
public class PDFShadingPattern : PDFPattern
public __gc class PDFShadingPattern : public PDFPattern
public ref class PDFShadingPattern : public PDFPattern
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPattern Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFShadingPattern Class Members

O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPattern Class

The following tables list the members exposed by PDFShadingPattern.

Public Constructors
 | Name | Description
Public Constructor | PDFShadingPattern Constructor | Initializes a new PDFShadingPattern object.
Top
See Also

Reference

PDFShadingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFShadingPattern Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPattern Class : PDFShadingPattern Constructor
Initializes a new PDFShadingPattern object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFShadingPattern()
public PDFShadingPattern()
public: PDFShadingPattern();
public:
PDFShadingPattern();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPattern Class
PDFShadingPattern Members


%%PageItemTitle%%

PDFShadingPatternColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPatternColor Class
Defines a special color based on a shading pattern.
Object Model
PDFShadingPatternColor ClassPDFColorSpace ClassPDFShadingPattern Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFShadingPatternColor
   Inherits PDFColor
'Usage

Dim instance As PDFShadingPatternColor
public class PDFShadingPatternColor : PDFColor
public __gc class PDFShadingPatternColor : public PDFColor
public ref class PDFShadingPatternColor : public PDFColor
Remarks
This is not an actual color, the pattern is used for stroking and filling shapes.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFShadingPatternColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPatternColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFShadingPatternColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPatternColor Class

The following tables list the members exposed by PDFShadingPatternColor.

Public Constructors
 | Name | Description
Public Constructor | PDFShadingPatternColor Constructor | Initializes a new PDFShadingPatternColor object.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Pattern | Gets the pattern that defines the color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFShadingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFShadingPatternColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : PDFShadingPatternColor Constructor
The tiling pattern that represents the color.
Initializes a new PDFShadingPatternColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal shadingPattern As PDFShadingPattern _
)
'Usage

Dim shadingPattern As PDFShadingPattern

Dim instance As New PDFShadingPatternColor(shadingPattern)
public PDFShadingPatternColor(
   PDFShadingPattern shadingPattern
)
public: PDFShadingPatternColor(
   PDFShadingPattern* shadingPattern
)
public:
PDFShadingPatternColor(
   PDFShadingPattern^ shadingPattern
)

Parameters

shadingPattern
The tiling pattern that represents the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


%%PageItemTitle%% $$Methods$$

PDFShadingPatternColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPatternColor Class

For a list of all members of this type, see PDFShadingPatternColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFShadingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFShadingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFShadingPatternColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


Equals Method (PDFShadingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFShadingPatternColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


GetHashCode Method (PDFShadingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFShadingPatternColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


ToString Method (PDFShadingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFShadingPatternColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


%%PageItemTitle%% $$Properties$$

PDFShadingPatternColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPatternColor Class

For a list of all members of this type, see PDFShadingPatternColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Pattern | Gets the pattern that defines the color.
Top
See Also

Reference

PDFShadingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


Pattern Property (PDFShadingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : Pattern Property
Gets the pattern that defines the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pattern As PDFShadingPattern
'Usage

Dim instance As PDFShadingPatternColor
Dim value As PDFShadingPattern

value = instance.Pattern
public PDFShadingPattern Pattern {get;}
public: __property PDFShadingPattern* get_Pattern();
public:
property PDFShadingPattern^ Pattern {
   PDFShadingPattern^ get();
}

Property Value

The pattern used for painting.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


%%PageItemTitle%%

PDFTilingPattern Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPattern Class
Defines a PDF tiling pattern.
Object Model
PDFTilingPattern ClassPDFBasicCanvas Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTilingPattern
   Inherits PDFPattern
'Usage

Dim instance As PDFTilingPattern
public class PDFTilingPattern : PDFPattern
public __gc class PDFTilingPattern : public PDFPattern
public ref class PDFTilingPattern : public PDFPattern
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFTilingPattern
O2S.Components.PDF4NET.Graphics.PDFHatchPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPattern Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFTilingPattern Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPattern Class

The following tables list the members exposed by PDFTilingPattern.

Public Constructors
 | Name | Description
Public Constructor | PDFTilingPattern Constructor | Initializes a new PDFTilingPattern object.
Top
Public Properties
 | Name | Description
Public Property | Canvas | Gets the pattern canvas.
Public Property | Height | Gets or sets the height of the pattern cell.
Public Property | Width | Gets or sets the width of the pattern cell.
Public Property | XStep | Gets or sets the horizontal spacing between pattern cells.
Public Property | YStep | Gets or sets the vertical spacing between pattern cells.
Top
See Also

Reference

PDFTilingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFTilingPattern Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : PDFTilingPattern Constructor
Initializes a new PDFTilingPattern object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFTilingPattern()
public PDFTilingPattern()
public: PDFTilingPattern();
public:
PDFTilingPattern();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


%%PageItemTitle%% $$Properties$$

PDFTilingPattern Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPattern Class

For a list of all members of this type, see PDFTilingPattern members.

Public Properties
 | Name | Description
Public Property | Canvas | Gets the pattern canvas.
Public Property | Height | Gets or sets the height of the pattern cell.
Public Property | Width | Gets or sets the width of the pattern cell.
Public Property | XStep | Gets or sets the horizontal spacing between pattern cells.
Public Property | YStep | Gets or sets the vertical spacing between pattern cells.
Top
See Also

Reference

PDFTilingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


Canvas Property (PDFTilingPattern)

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : Canvas Property
Gets the pattern canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Canvas As PDFBasicCanvas
'Usage

Dim instance As PDFTilingPattern
Dim value As PDFBasicCanvas

value = instance.Canvas
public PDFBasicCanvas Canvas {get;}
public: __property PDFBasicCanvas* get_Canvas();
public:
property PDFBasicCanvas^ Canvas {
   PDFBasicCanvas^ get();
}

Property Value

The drawing surface of the pattern.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


Height Property (PDFTilingPattern)

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : Height Property
Gets or sets the height of the pattern cell.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PDFTilingPattern
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public: __property double get_Height();
public: __property void set_Height(
   double value
);
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The height of the pattern cell.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


Width Property (PDFTilingPattern)

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : Width Property
Gets or sets the width of the pattern cell.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFTilingPattern
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the pattern cell.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


XStep Property

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : XStep Property
Gets or sets the horizontal spacing between pattern cells.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XStep As Double
'Usage

Dim instance As PDFTilingPattern
Dim value As Double

instance.XStep = value

value = instance.XStep
public double XStep {get; set;}
public: __property double get_XStep();
public: __property void set_XStep(
   double value
);
public:
property double XStep {
   double get();
   void set (    double value);
}

Property Value

The horizontal space between pattern cells.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


YStep Property

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : YStep Property
Gets or sets the vertical spacing between pattern cells.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property YStep As Double
'Usage

Dim instance As PDFTilingPattern
Dim value As Double

instance.YStep = value

value = instance.YStep
public double YStep {get; set;}
public: __property double get_YStep();
public: __property void set_YStep(
   double value
);
public:
property double YStep {
   double get();
   void set (    double value);
}

Property Value

The vertical space between pattern cells.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


%%PageItemTitle%%

PDFTilingPatternColor Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPatternColor Class
Defines a special color based on a tiling pattern.
Object Model
PDFTilingPatternColor ClassPDFColorSpace ClassPDFTilingPattern Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTilingPatternColor
   Inherits PDFColor
'Usage

Dim instance As PDFTilingPatternColor
public class PDFTilingPatternColor : PDFColor
public __gc class PDFTilingPatternColor : public PDFColor
public ref class PDFTilingPatternColor : public PDFColor
Remarks
This is not an actual color, the pattern is used for stroking and filling shapes.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFTilingPatternColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPatternColor Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFTilingPatternColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPatternColor Class

The following tables list the members exposed by PDFTilingPatternColor.

Public Constructors
 | Name | Description
Public Constructor | PDFTilingPatternColor Constructor | Initializes a new PDFTilingPatternColor object.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Pattern | Gets the pattern that defines the color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFTilingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFTilingPatternColor Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : PDFTilingPatternColor Constructor
The tiling pattern that represents the color.
Initializes a new PDFTilingPatternColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tillingPattern As PDFTilingPattern _
)
'Usage

Dim tillingPattern As PDFTilingPattern

Dim instance As New PDFTilingPatternColor(tillingPattern)
public PDFTilingPatternColor(
   PDFTilingPattern tillingPattern
)
public: PDFTilingPatternColor(
   PDFTilingPattern* tillingPattern
)
public:
PDFTilingPatternColor(
   PDFTilingPattern^ tillingPattern
)

Parameters

tillingPattern
The tiling pattern that represents the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


%%PageItemTitle%% $$Methods$$

PDFTilingPatternColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPatternColor Class

For a list of all members of this type, see PDFTilingPatternColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFTilingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method (PDFTilingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFTilingPatternColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


Equals Method (PDFTilingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFTilingPatternColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


GetHashCode Method (PDFTilingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFTilingPatternColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


ToString Method (PDFTilingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFTilingPatternColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


%%PageItemTitle%% $$Properties$$

PDFTilingPatternColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPatternColor Class

For a list of all members of this type, see PDFTilingPatternColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Property | Pattern | Gets the pattern that defines the color.
Top
See Also

Reference

PDFTilingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


Pattern Property (PDFTilingPatternColor)

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : Pattern Property
Gets the pattern that defines the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pattern As PDFTilingPattern
'Usage

Dim instance As PDFTilingPatternColor
Dim value As PDFTilingPattern

value = instance.Pattern
public PDFTilingPattern Pattern {get;}
public: __property PDFTilingPattern* get_Pattern();
public:
property PDFTilingPattern^ Pattern {
   PDFTilingPattern^ get();
}

Property Value

The pattern used for painting.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


%%PageItemTitle%%

PDFVerticalGradientBrush Class
Members

O2S.Components.PDF4NET.Graphics Namespace : PDFVerticalGradientBrush Class
Defines a vertical gradient brush for filling closed shapes.
Object Model
PDFVerticalGradientBrush ClassPDFColor ClassPDFDeviceColor ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFVerticalGradientBrush
   Inherits PDFLinearGradientBrush
'Usage

Dim instance As PDFVerticalGradientBrush
public class PDFVerticalGradientBrush : PDFLinearGradientBrush
public __gc class PDFVerticalGradientBrush : public PDFLinearGradientBrush
public ref class PDFVerticalGradientBrush : public PDFLinearGradientBrush
Remarks
A vertical gradient starts at top and ends at the bottom of the filled shape.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush
O2S.Components.PDF4NET.Graphics.PDFVerticalGradientBrush

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFVerticalGradientBrush Members
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFVerticalGradientBrush Class Members
Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFVerticalGradientBrush Class

The following tables list the members exposed by PDFVerticalGradientBrush.

Public Constructors
 | Name | Description
Public Constructor | PDFVerticalGradientBrush Constructor | Initializes a new PDFVerticalGradientBrush object.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Public Property | EndColor | (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Top
See Also

Reference

PDFVerticalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFVerticalGradientBrush Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFVerticalGradientBrush Class : PDFVerticalGradientBrush Constructor
Initializes a new PDFVerticalGradientBrush object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFVerticalGradientBrush()
public PDFVerticalGradientBrush()
public: PDFVerticalGradientBrush();
public:
PDFVerticalGradientBrush();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFVerticalGradientBrush Class
PDFVerticalGradientBrush Members


%%PageItemTitle%%

PDFBlendMode Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFBlendMode Enumeration
Specifies the available blend modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFBlendMode
   Inherits System.Enum
'Usage

Dim instance As PDFBlendMode
public enum PDFBlendMode : System.Enum
__value public enum PDFBlendMode : public System.Enum
public enum class PDFBlendMode : public System.Enum
Members
Member | Description
Color | Creates a color with the saturation and hue of the source color and the luminance of the backdrop color.
ColorBurn | Darkens the backdrop color to reflect the source color.
ColorDodge | Brightens the backdrop color to reflect the source color.
Darken | Selects the darker of the backdrop and source colors.
Difference | Subtracts the darker of the two constituents colors from the lighter.
Exclusion | Same as Difference, but lower in contrast.
HardLight | Multiplies or screens the colors depending on the source color.
Hue | Creates a color with the hue of the source color and the saturation and luminance of the backdrop color.
Lighten | Selects the lighter of the backdrop and source colors.
Luminosity | Creates a color with the luminance of the source color and the saturation and hue of the backdrop color.
Multiply | Multiplies the backdrop and source color.
None | Same as Normal, but for internal library use.
Normal | Selects the source color.
Overlay | Multiplies or screens the colors depending on the backdrop color.
Saturation | Creates a color with the saturation of the source color and the hue and luminance of the backdrop color.
Screen | Multiplies the complements of backdrop and source color values, and then complements the result.
SoftLight | Darkens or lightens the colors depending on the source color.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFBlendMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFContentMirroring Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFContentMirroring Enumeration
Specifies the available mirroring options when drawing graphic content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PDFContentMirroring
   Inherits System.Enum
'Usage

Dim instance As PDFContentMirroring
[Flags()]
public enum PDFContentMirroring : System.Enum
[Flags()]
__value public enum PDFContentMirroring : public System.Enum
[Flags()]
public enum class PDFContentMirroring : public System.Enum
Members
Member | Description
NoMirroring | The content is drawn as it is.
XAxisMirroring | The content is mirrored about X axis.
YAxisMirroring | The content is mirrored about Y axis.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFContentMirroring

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFDashStyle Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFDashStyle Enumeration
Specifies the style of dashed lines drawn with a PDFPen object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFDashStyle
   Inherits System.Enum
'Usage

Dim instance As PDFDashStyle
public enum PDFDashStyle : System.Enum
__value public enum PDFDashStyle : public System.Enum
public enum class PDFDashStyle : public System.Enum
Members
Member | Description
Custom | Specifies a custom dash style. The DashPattern property of the PDFPen object is used to specify the dashes and spaces pattern.
Dash | Specifies a line consisting of dashes.
DashDot | Specifies a line consisting of a repeating pattern of dash-dot.
DashDotDot | Specifies a line consisting of a repeating pattern of dash-dot-dot.
Dot | Specifies a line consisting of dots.
Solid | Specifies a solid line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFDashStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFFillMode Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFFillMode Enumeration
Specifies the available fill modes for a complex shape.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFillMode
   Inherits System.Enum
'Usage

Dim instance As PDFFillMode
public enum PDFFillMode : System.Enum
__value public enum PDFFillMode : public System.Enum
public enum class PDFFillMode : public System.Enum
Members
Member | Description
EvenOdd | Even-odd rule for filling the polygons.
NonZeroWinding | Non zero winding rule for filling the polygons.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFFillMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFHatchType Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFHatchType Enumeration
Specifies the available types for hatch brushes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFHatchType
   Inherits System.Enum
'Usage

Dim instance As PDFHatchType
public enum PDFHatchType : System.Enum
__value public enum PDFHatchType : public System.Enum
public enum class PDFHatchType : public System.Enum
Members
Member | Description
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
Cross | Specifies horizontal and vertical lines that cross.
DiagonalCross | Specifies forward diagonal and backward diagonal lines that cross
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
Horizontal | A pattern of horizontal lines.
Vertical | A pattern of vertical lines.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFHatchType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFLineCap Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFLineCap Enumeration
Specifies the available cap styles with which a Pen object can begin or end a line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFLineCap
   Inherits System.Enum
'Usage

Dim instance As PDFLineCap
public enum PDFLineCap : System.Enum
__value public enum PDFLineCap : public System.Enum
public enum class PDFLineCap : public System.Enum
Members
Member | Description
Flat | Specifies a flat line cap.
Round | Specifies a round line cap.
Square | Specifies a square line cap.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFLineCap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFLineJoin Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFLineJoin Enumeration
Specifies how to join consecutive line or curve segments
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFLineJoin
   Inherits System.Enum
'Usage

Dim instance As PDFLineJoin
public enum PDFLineJoin : System.Enum
__value public enum PDFLineJoin : public System.Enum
public enum class PDFLineJoin : public System.Enum
Members
Member | Description
Bevel | Specifies a beveled join. This produces a diagonal corner.
Miter | Specifies a mitered join. This produces a sharp corner.
Round | Specifies a round join. This produces a smooth, circular arc between the lines.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFLineJoin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFPaddingGlyph Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFPaddingGlyph Enumeration
Specifies the available options for padding glyphs in PDFBasicCanvas.DrawGlyphs method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPaddingGlyph
   Inherits System.Enum
'Usage

Dim instance As PDFPaddingGlyph
public enum PDFPaddingGlyph : System.Enum
__value public enum PDFPaddingGlyph : public System.Enum
public enum class PDFPaddingGlyph : public System.Enum
Members
Member | Description
Kashida | Kashida character is used for padding.
None | No glyph is used for padding.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFPaddingGlyph

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFTextAlign Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFTextAlign Enumeration
Specifies the available alignments for text lines.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFTextAlign
   Inherits System.Enum
'Usage

Dim instance As PDFTextAlign
public enum PDFTextAlign : System.Enum
__value public enum PDFTextAlign : public System.Enum
public enum class PDFTextAlign : public System.Enum
Members
Member | Description
BottomCenter | The text is bottom center aligned
BottomDescentCenter | The text is bottom center aligned at descent level
BottomDescentLeft | The text is bottom left aligned at descent level
BottomDescentRight | The text is bottom right aligned at descent level
BottomJustified | The text is bottom justified aligned. This alignment is used only by text boxes.
BottomLeft | The text is bottom left aligned
BottomRight | The text is bottom right aligned
MiddleCenter | The text is middle center aligned
MiddleDescentCenter | The text is middle center aligned but the font descent is considered for middle alignment.
MiddleDescentLeft | The text is middle left aligned but the font descent is considered for middle alignment.
MiddleDescentRight | The text is middle right aligned but the font descent is considered for middle alignment.
MiddleJustified | The text is middle justified aligned. This alignment is used only by text boxes.
MiddleLeft | The text is middle left aligned
MiddleRight | The text is middle right aligned
TopCenter | The text is top center aligned
TopJustified | The text is top justified aligned. This alignment is used only by text boxes.
TopLeft | The text is top left aligned
TopRight | The text is top right aligned
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFTextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFXAxisDirection Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFXAxisDirection Enumeration
Specifies the available directions for the X axis of the page canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFXAxisDirection
   Inherits System.Enum
'Usage

Dim instance As PDFXAxisDirection
public enum PDFXAxisDirection : System.Enum
__value public enum PDFXAxisDirection : public System.Enum
public enum class PDFXAxisDirection : public System.Enum
Members
Member | Description
LeftToRight | The X axis is oriented from left to right. The values on X axis grow from left to right. This is the default direction used by PDF4NET library.
RightToLeft | The X axis is oriented from right to left. The values on X axis grow from right to left.
Remarks
The X axis directions are used when positioning the graphic objects in the page canvas' coordinate system. The RightToLeft direction has no connection with RightToLeft reading and text writting used by some languages.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFXAxisDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFYAxisDirection Enumeration

O2S.Components.PDF4NET.Graphics Namespace : PDFYAxisDirection Enumeration
Specifies the available directions for the Y axis of the page canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFYAxisDirection
   Inherits System.Enum
'Usage

Dim instance As PDFYAxisDirection
public enum PDFYAxisDirection : System.Enum
__value public enum PDFYAxisDirection : public System.Enum
public enum class PDFYAxisDirection : public System.Enum
Members
Member | Description
BottomToTop | The Y axis is oriented from bottom to top. The values on Y axis grow from bottom to top.
TopToBottom | The Y axis is oriented from top to bottom. The values on Y axis grow from top to bottom. This is the default direction used by PDF4NET library.
Remarks
The Y axis directions are used when positioning the graphic objects in the page canvas' coordinate system.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFYAxisDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


O2S.Components.PDF4NET.Graphics.Barcodes Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | BarcodeEncodingException | Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.
Class | PDF417Barcode | Defines a PDF 417 barcode.
Class | PDFBarcode | Defines the base class for all barcode types.
Class | PDFBasePDF417Barcode | Defines the base class for all PDF 417 barcodes.
Class | PDFBidimensionalBarcode | Defines the base class for all bidimensional barcodes.
Class | PDFCodabarBarcode | Defines a Code 39 barcode.
Class | PDFCodablockFBarcode | Defines a CODABLOCK F barcode.
Class | PDFCode11Barcode | Defines a Code 11 barcode.
Class | PDFCode128ABarcode | Defines a Code 128 barcode.
Class | PDFCode128Barcode | Defines the base class for all Code 128 barcodes.
Class | PDFCode128BBarcode | Defines a Code 128 barcode.
Class | PDFCode128CBarcode | Defines a Code 128 barcode.
Class | PDFCode16KBarcode | Defines a Code 16K barcode.
Class | PDFCode25Barcode | Defines a Code 2 of 5 barcode.
Class | PDFCode25InterleavedBarcode | Defines a Code 2 of 5 barcode.
Class | PDFCode32Barcode | Defines a Code 32 barcode.
Class | PDFCode39Barcode | Defines a Code 39 barcode.
Class | PDFCode39ExtendedBarcode | Defines an extended Code 39 barcode.
Class | PDFCode93Barcode | Defines a Code 93 barcode.
Class | PDFCode93ExtendedBarcode | Defines an extended Code 93 barcode.
Class | PDFCOOP25Barcode | Defines a COOP 2 of 5 barcode.
Class | PDFDataMatrixBarcode | Defines a DataMatrix barcode.
Class | PDFEAN128Barcode | Defines a EAN 128 barcode.
Class | PDFEAN13Barcode | Defines the class for EAN-13 barcodes.
Class | PDFEAN8Barcode | Defines the class for EAN-8 barcodes.
Class | PDFEANBarcode | Defines the base class for EAN based barcodes.
Class | PDFFedExGround96Barcode | Defines a FedEx Ground 96 barcode.
Class | PDFHeightModulatedBarcode | Defines the base class for all height modulated barcodes.
Class | PDFIATA25Barcode | Defines a IATA 2 of 5 barcode.
Class | PDFIdentcodeBarcode | Defines an Identcode barcode.
Class | PDFISBNBarcode | Defines the class for ISBN barcodes.
Class | PDFISMNBarcode | Defines the class for ISMN barcodes.
Class | PDFISSNBarcode | Defines the class for ISSN barcodes.
Class | PDFJAN13Barcode | Defines the class for JAN13 barcodes.
Class | PDFKixBarcode | Defines a Kix barcode.
Class | PDFLeitcodeBarcode | Defines a Leitcode barcode.
Class | PDFMatrix25Barcode | Defines a Matrix 2 of 5 barcode.
Class | PDFMicroPDF417Barcode | Defines a Micro PDF 417 barcode.
Class | PDFMSIPlesseyBarcode | Defines a MSI/Plessey barcode.
Class | PDFPharmacodeBarcode | Defines a Pharmacode barcode.
Class | PDFPlanetBarcode | Defines a Planet barcode.
Class | PDFPostNetBarcode | Defines a PostNet barcode.
Class | PDFPZNBarcode | Defines a PZN barcode.
Class | PDFQRBarcode | Defines a QR barcode.
Class | PDFRM4SCCBarcode | Defines a RM4SCC barcode.
Class | PDFSCC14Barcode | Defines a SCC-14 barcode.
Class | PDFSingaporePostBarcode | Defines a Singapore Post barcode.
Class | PDFSSCC18Barcode | Defines a SSCC-18 barcode.
Class | PDFUnidimensionalBarcode | Defines the base class for 1D barcodes.
Class | PDFUPCABarcode | Defines the class for UPC-A barcodes.
Class | PDFUPCEBarcode | Defines the class for UPC-E barcodes.
Class | PDFUSPSFIMBarcode | Defines a USPS FIM barcode.
Class | PDFUSPSHorizontalBarcode | Defines a horizontal bars barcode.
Class | PDFUSPSPICBarcode | Defines a USPS Package Identification Code barcode.
Enumerations
 | Enumeration | Description
Enumeration | BarcodeTextLocation | Specifies the available locations for displaying text on a linear barcode.
Enumeration | DataMatrixEncoding | Specifies the available encoding modes for a DataMatrix barcode.
Enumeration | DataMatrixSymbolSize | Specifies the available sizes for a DataMatrix symbol.
Enumeration | MicroPDF417SymbolSize | Specifies the available sizes for a Micro PDF417 symbol.
Enumeration | PDF417DataCompactionMode | Specifies the available data compaction modes for a PDF417 barcode.
Enumeration | PDF417ErrorCorrectionLevel | Specifies the available error correction levels for a PDF417 barcode.
Enumeration | QRCharacterSet | Supported character sets.
Enumeration | QRErrorCorrectionLevel | Supported error correction levels for QR barcodes.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

BarcodeEncodingException Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class
Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.
Object Model
BarcodeEncodingException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BarcodeEncodingException
   Inherits System.ApplicationException
'Usage

Dim instance As BarcodeEncodingException
public class BarcodeEncodingException : System.ApplicationException
public __gc class BarcodeEncodingException : public System.ApplicationException
public ref class BarcodeEncodingException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.Graphics.Barcodes.BarcodeEncodingException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarcodeEncodingException Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

BarcodeEncodingException Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

The following tables list the members exposed by BarcodeEncodingException.

Public Constructors
 | Name | Description
Public Constructor | BarcodeEncodingException Constructor | Initializes a new BarcodeEncodingException object with the specified message.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

BarcodeEncodingException Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > BarcodeEncodingException Class : BarcodeEncodingException Constructor
The exception message.
Initializes a new BarcodeEncodingException object with the specified message.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New BarcodeEncodingException(message)
public BarcodeEncodingException(
   string message
)
public: BarcodeEncodingException(
   string* message
)
public:
BarcodeEncodingException(
   String^ message
)

Parameters

message
The exception message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarcodeEncodingException Class
BarcodeEncodingException Members


%%PageItemTitle%%

PDF417Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class
Defines a PDF 417 barcode.
Object Model
PDF417Barcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF417Barcode
   Inherits PDFBasePDF417Barcode
'Usage

Dim instance As PDF417Barcode
public class PDF417Barcode : PDFBasePDF417Barcode
public __gc class PDF417Barcode : public PDFBasePDF417Barcode
public ref class PDF417Barcode : public PDFBasePDF417Barcode
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDF417Barcode Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

The following tables list the members exposed by PDF417Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDF417Barcode Constructor | Initializes a new PDF417Barcode object.
Top
Public Properties
 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Top
See Also

Reference

PDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDF417Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : PDF417Barcode Constructor
Initializes a new PDF417Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF417Barcode()
public PDF417Barcode()
public: PDF417Barcode();
public:
PDF417Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%% $$Properties$$

PDF417Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Properties
 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


ActualColumns Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ActualColumns Property
Returns the actual number of columns used by this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ActualColumns As Integer
'Usage

Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualColumns
public int ActualColumns {get;}
public: __property int get_ActualColumns();
public:
property int ActualColumns {
   int get();
}

Property Value

An integer value specifying the actual number of columns used by this barcode.
Remarks
This value is computed automatically by the library when Columns property is 0. When Columns property is not 0, this property matches the Columns property.
This property returns -1 if a valid number of columns can not be computed for the following combination: barcode data, rows and error correction level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


ActualRows Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ActualRows Property
Returns the actual number of rows used by this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ActualRows As Integer
'Usage

Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualRows
public int ActualRows {get;}
public: __property int get_ActualRows();
public:
property int ActualRows {
   int get();
}

Property Value

An integer value specifying the actual number of rows used by this barcode.
Remarks
This value is computed automatically by the library when Rows property is 0. When Rows property is not 0, this property matches the Rows property.
This property returns -1 if a valid number of rows can not be computed for the following combination: barcode data, columns and error correction level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


Columns Property (PDF417Barcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : Columns Property
Gets or sets the number of columns in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Columns As Integer
'Usage

Dim instance As PDF417Barcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
public int Columns {get; set;}
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
public:
property int Columns {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of columns used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 0 or greater than 30 - OR - Throws when value is 0 and Rows is also 0.
Remarks
The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Rows property must not be 0.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


ErrorCorrectionLevel Property (PDF417Barcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ErrorCorrectionLevel Property
Gets or sets the level of error correction used by this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
'Usage

Dim instance As PDF417Barcode
Dim value As PDF417ErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
public PDF417ErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
public: __property PDF417ErrorCorrectionLevel get_ErrorCorrectionLevel();
public: __property void set_ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
public:
property PDF417ErrorCorrectionLevel ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (    PDF417ErrorCorrectionLevel value);
}

Property Value

An PDF417ErrorCorrectionLevel enumeration member specifying the level of error correction used by this barcode.
Remarks
The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


Rows Property (PDF417Barcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : Rows Property
Gets or sets the number of rows in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As PDF417Barcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of rows used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Columns is also 0.
Remarks
The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Columns property must not be 0.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

PDFBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBarcode Class
Defines the base class for all barcode types.
Object Model
PDFBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFBarcode
'Usage

Dim instance As PDFBarcode
public abstract class PDFBarcode
public __gc abstract class PDFBarcode
public ref class PDFBarcode abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBarcode Class

The following tables list the members exposed by PDFBarcode.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the bars color.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | Height | Gets the height in points of the barcode rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode.
Public Property | Position | Gets or sets the position of this barcode object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object.
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode.
Public Property | Size | Gets or sets the size of this barcode object.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode.
Public Property | Width | Gets the width in points of the barcode rectangle.
Public Property | XDimension | Gets or sets the width in points of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top
See Also

Reference

PDFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBarcode Class

For a list of all members of this type, see PDFBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the bars color.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | Height | Gets the height in points of the barcode rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode.
Public Property | Position | Gets or sets the position of this barcode object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object.
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode.
Public Property | Size | Gets or sets the size of this barcode object.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode.
Public Property | Width | Gets the width in points of the barcode rectangle.
Public Property | XDimension | Gets or sets the width in points of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top
See Also

Reference

PDFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


BackColor Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BackColor Property
Gets or sets the background color of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BackColor As PDFColor
'Usage

Dim instance As PDFBarcode
Dim value As PDFColor

instance.BackColor = value

value = instance.BackColor
public PDFColor BackColor {get; set;}
public: __property PDFColor* get_BackColor();
public: __property void set_BackColor(
   PDFColor* value
);
public:
property PDFColor^ BackColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the background color of barcode.
Remarks
If this property is null (Nothing in VB.NET), then the barcode's background will be transparent. Default barcode background color is white.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


BarColor Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BarColor Property
Gets or sets the bars color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BarColor As PDFColor
'Usage

Dim instance As PDFBarcode
Dim value As PDFColor

instance.BarColor = value

value = instance.BarColor
public PDFColor BarColor {get; set;}
public: __property PDFColor* get_BarColor();
public: __property void set_BarColor(
   PDFColor* value
);
public:
property PDFColor^ BarColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the bars color.
Remarks
If this property is null (Nothing in VB.NET), then no bars are shown. Default bars color is black.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


BottomQuietZone Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BottomQuietZone Property
Gets or sets the height of the bottom quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BottomQuietZone As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.BottomQuietZone = value

value = instance.BottomQuietZone
public double BottomQuietZone {get; set;}
public: __property double get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   double value
);
public:
property double BottomQuietZone {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of the bottom quiet zone.
Remarks
The bottom quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Data Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Data Property
Gets or sets the string to be encoded as barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Data As String
'Usage

Dim instance As PDFBarcode
Dim value As String

instance.Data = value

value = instance.Data
public string Data {get; set;}
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
public:
property String^ Data {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the value to be encoded as barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).
Remarks
The characters allowed to be encoded are defined by each barcode type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Height Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Height Property
Gets the height in points of the barcode rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

value = instance.Height
public double Height {get;}
public: __property double get_Height();
public:
property double Height {
   double get();
}

Property Value

A double value specifying the height of the barcode rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Left Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Left Property
Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public: __property double get_Left();
public: __property void set_Left(
   double value
);
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

a double value representing the X coordinate of the top left corner of the barcode's rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


LeftQuietZone Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : LeftQuietZone Property
Gets or sets the width of the left quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LeftQuietZone As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.LeftQuietZone = value

value = instance.LeftQuietZone
public double LeftQuietZone {get; set;}
public: __property double get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   double value
);
public:
property double LeftQuietZone {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the width of the left quiet zone.
Remarks
The left quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Position Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Position Property
Gets or sets the position of this barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Position As PointF
'Usage

Dim instance As PDFBarcode
Dim value As PointF

instance.Position = value

value = instance.Position
public PointF Position {get; set;}
public: __property PointF get_Position();
public: __property void set_Position(
   PointF value
);
public:
property PointF Position {
   PointF get();
   void set (    PointF value);
}

Property Value

A System.Drawing.PointF object specifying the position of the barcode.
Remarks
This position is relative to the top left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Rectangle Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Rectangle Property
Gets or sets the bounding rectangle of this barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Rectangle As RectangleF
'Usage

Dim instance As PDFBarcode
Dim value As RectangleF

value = instance.Rectangle
public RectangleF Rectangle {get;}
public: __property RectangleF get_Rectangle();
public:
property RectangleF Rectangle {
   RectangleF get();
}

Property Value

A System.Drawing.RectangleF object specifying the position and size of the barcode.
Remarks
The bounding rectangle is relative to the top left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


RightQuietZone Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : RightQuietZone Property
Gets or sets the width of the right quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RightQuietZone As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.RightQuietZone = value

value = instance.RightQuietZone
public double RightQuietZone {get; set;}
public: __property double get_RightQuietZone();
public: __property void set_RightQuietZone(
   double value
);
public:
property double RightQuietZone {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the width of the right quiet zone.
Remarks
The right quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Size Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Size Property
Gets or sets the size of this barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Size As SizeF
'Usage

Dim instance As PDFBarcode
Dim value As SizeF

value = instance.Size
public SizeF Size {get;}
public: __property SizeF get_Size();
public:
property SizeF Size {
   SizeF get();
}

Property Value

A System.Drawing.SizeF object specifying the size of the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


TextColor Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : TextColor Property
Gets or sets the color of the barcode text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As PDFColor
'Usage

Dim instance As PDFBarcode
Dim value As PDFColor

instance.TextColor = value

value = instance.TextColor
public PDFColor TextColor {get; set;}
public: __property PDFColor* get_TextColor();
public: __property void set_TextColor(
   PDFColor* value
);
public:
property PDFColor^ TextColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the text color.
Remarks
If this property is null (Nothing in VB.NET), then no text is shown. Default text color is black.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Top Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Top Property
Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Top As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.Top = value

value = instance.Top
public double Top {get; set;}
public: __property double get_Top();
public: __property void set_Top(
   double value
);
public:
property double Top {
   double get();
   void set (    double value);
}

Property Value

a double value representing the Y coordinate of the top left corner of the barcode's rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


TopQuietZone Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : TopQuietZone Property
Gets or sets the height of the top quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TopQuietZone As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.TopQuietZone = value

value = instance.TopQuietZone
public double TopQuietZone {get; set;}
public: __property double get_TopQuietZone();
public: __property void set_TopQuietZone(
   double value
);
public:
property double TopQuietZone {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of the top quiet zone.
Remarks
The top quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Width Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Width Property
Gets the width in points of the barcode rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

value = instance.Width
public double Width {get;}
public: __property double get_Width();
public:
property double Width {
   double get();
}

Property Value

A double value specifying the width of the barcode rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


XDimension Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : XDimension Property
Gets or sets the width in points of a narrow bar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XDimension As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.XDimension = value

value = instance.XDimension
public double XDimension {get; set;}
public: __property double get_XDimension();
public: __property void set_XDimension(
   double value
);
public:
property double XDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the width of a narrow bar.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.
Remarks
The recommended width of a narrow bar is 0.864 points, which is 12 mils (1 mil = 0.001inches). Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


YDimension Property (PDFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : YDimension Property
Gets or sets the height of a bar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property YDimension As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
public virtual double YDimension {get; set;}
public: __property virtual double get_YDimension();
public: __property virtual void set_YDimension(
   double value
);
public:
virtual property double YDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of a bar.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

PDFBasePDF417Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class
Defines the base class for all PDF 417 barcodes.
Object Model
PDFBasePDF417Barcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFBasePDF417Barcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFBasePDF417Barcode
public abstract class PDFBasePDF417Barcode : PDFBidimensionalBarcode
public __gc abstract class PDFBasePDF417Barcode : public PDFBidimensionalBarcode
public ref class PDFBasePDF417Barcode abstract : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMicroPDF417Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasePDF417Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFBasePDF417Barcode Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

The following tables list the members exposed by PDFBasePDF417Barcode.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top
See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Methods$$

PDFBasePDF417Barcode Class Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

For a list of all members of this type, see PDFBasePDF417Barcode members.

Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top
See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


GetMaxDataLength Method

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : GetMaxDataLength Method
Calculates the length of the maximum data section that can be encoded in the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMaxDataLength() As Integer
'Usage

Dim instance As PDFBasePDF417Barcode
Dim value As Integer

value = instance.GetMaxDataLength()
public int GetMaxDataLength()
public: int GetMaxDataLength();
public:
int GetMaxDataLength();

Return Value

The maximum length of encoded data.
Remarks
This method calculates how much of the barcode data can be actually encoded in the barcode. The encoded data is considered to start at the beginning of barcode data. The maximum length is calculated based on barcode data, error correction level and barcode rows and columns.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


%%PageItemTitle%% $$Properties$$

PDFBasePDF417Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

For a list of all members of this type, see PDFBasePDF417Barcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


CompactionMode Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : CompactionMode Property
Gets or sets the data compaction mode for this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompactionMode As PDF417DataCompactionMode
'Usage

Dim instance As PDFBasePDF417Barcode
Dim value As PDF417DataCompactionMode

instance.CompactionMode = value

value = instance.CompactionMode
public PDF417DataCompactionMode CompactionMode {get; set;}
public: __property PDF417DataCompactionMode get_CompactionMode();
public: __property void set_CompactionMode(
   PDF417DataCompactionMode value
);
public:
property PDF417DataCompactionMode CompactionMode {
   PDF417DataCompactionMode get();
   void set (    PDF417DataCompactionMode value);
}

Property Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this barcode.
Remarks
The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


IsValid Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : IsValid Property
Gets a value indicating whether a valid barcode can be built.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsValid As Boolean
'Usage

Dim instance As PDFBasePDF417Barcode
Dim value As Boolean

value = instance.IsValid
public bool IsValid {get;}
public: __property bool get_IsValid();
public:
property bool IsValid {
   bool get();
}

Property Value

True if the barcode can be built, false otherwise.
Remarks
The following items are considered when building the barcode: barcode data, rows, columns and error correction level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


%%PageItemTitle%%

PDFBidimensionalBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class
Defines the base class for all bidimensional barcodes.
Object Model
PDFBidimensionalBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFBidimensionalBarcode
   Inherits PDFBarcode
'Usage

Dim instance As PDFBidimensionalBarcode
public abstract class PDFBidimensionalBarcode : PDFBarcode
public __gc abstract class PDFBidimensionalBarcode : public PDFBarcode
public ref class PDFBidimensionalBarcode abstract : public PDFBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodablockFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode16KBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFDataMatrixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFQRBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBidimensionalBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFBidimensionalBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

The following tables list the members exposed by PDFBidimensionalBarcode.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFBidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFBidimensionalBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

For a list of all members of this type, see PDFBidimensionalBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFBidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


AlternateData Property
Example

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBidimensionalBarcode Class : AlternateData Property
Gets or sets the alternate data to encode as a barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlternateData As Byte()
'Usage

Dim instance As PDFBidimensionalBarcode
Dim value() As Byte

instance.AlternateData = value

value = instance.AlternateData
public byte[] AlternateData {get; set;}
public: __property byte[]* get_AlternateData();
public: __property void set_AlternateData(
   byte[]* value
);
public:
property array<byte>^ AlternateData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array specifying the data to be encoded as a barcode.
Remarks
Barcodes were designed to work with 8bit characters. Because .NET strings are Unicode, when they are converted to 8bit characters (using Windows 1252 encoding) the Unicode characters are removed. This property allows you to specify directly the byte array to encode.
If both PDFBarcode.Data and AlternateData properties are specified, the AlternateData property is used.
Example
The following line of code shows how to encode a Unicode string:
  • C#
...
barcode.AlternateData = Encoding.Unicode.GetBytes("my unicode string");
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBidimensionalBarcode Class
PDFBidimensionalBarcode Members


%%PageItemTitle%%

PDFCodabarBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class
Defines a Code 39 barcode.
Object Model
PDFCodabarBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCodabarBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCodabarBarcode
public class PDFCodabarBarcode : PDFUnidimensionalBarcode
public __gc class PDFCodabarBarcode : public PDFUnidimensionalBarcode
public ref class PDFCodabarBarcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Codabar barcode: 0 1 2 3 4 5 6 7 8 9 - $ : / . +
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodabarBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCodabarBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

The following tables list the members exposed by PDFCodabarBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCodabarBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCodabarBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCodabarBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class : PDFCodabarBarcode Constructor
Overload List
Overload | Description
PDFCodabarBarcode Constructor() | Initializes a new PDFCodabarBarcode object.
PDFCodabarBarcode Constructor(String,Double,Double) | Initializes a new PDFCodabarBarcode object.
PDFCodabarBarcode Constructor(String) | Initializes a new PDFCodabarBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members


%%PageItemTitle%%

PDFCodabarBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor()
Initializes a new PDFCodabarBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCodabarBarcode()
public PDFCodabarBarcode()
public: PDFCodabarBarcode();
public:
PDFCodabarBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


%%PageItemTitle%%

PDFCodabarBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCodabarBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCodabarBarcode(data, left, top)
public PDFCodabarBarcode(
   string data,
   double left,
   double top
)
public: PDFCodabarBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCodabarBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


%%PageItemTitle%%

PDFCodabarBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCodabarBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCodabarBarcode(data)
public PDFCodabarBarcode(
   string data
)
public: PDFCodabarBarcode(
   string* data
)
public:
PDFCodabarBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


%%PageItemTitle%%

PDFCodablockFBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class
Defines a CODABLOCK F barcode.
Object Model
PDFCodablockFBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCodablockFBarcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFCodablockFBarcode
public class PDFCodablockFBarcode : PDFBidimensionalBarcode
public __gc class PDFCodablockFBarcode : public PDFBidimensionalBarcode
public ref class PDFCodablockFBarcode : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodablockFBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCodablockFBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

The following tables list the members exposed by PDFCodablockFBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCodablockFBarcode Constructor | Initializes a new PDFCodablockFBarcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top
See Also

Reference

PDFCodablockFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCodablockFBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : PDFCodablockFBarcode Constructor
Initializes a new PDFCodablockFBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCodablockFBarcode()
public PDFCodablockFBarcode()
public: PDFCodablockFBarcode();
public:
PDFCodablockFBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%PageItemTitle%% $$Properties$$

PDFCodablockFBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

For a list of all members of this type, see PDFCodablockFBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top
See Also

Reference

PDFCodablockFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


Columns Property (PDFCodablockFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : Columns Property
Gets or sets the number of columns in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Columns As Integer
'Usage

Dim instance As PDFCodablockFBarcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
public int Columns {get; set;}
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
public:
property int Columns {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of columns used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.
Remarks
The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


Rows Property (PDFCodablockFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : Rows Property
Gets or sets the number of rows in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As PDFCodablockFBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of rows used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 2, or greater than 44.
Remarks
The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


YDimension Property (PDFCodablockFBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : YDimension Property
Gets or sets the height of a barcode row.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property YDimension As Double
'Usage

Dim instance As PDFCodablockFBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
public new double YDimension {get; set;}
public: __property new double get_YDimension();
public: __property new void set_YDimension(
   double value
);
public:
new property double YDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of a barcode row.
Remarks
The minimum YDimension should be either 8*XDimension or 0.55*Columns+3, whichever is greater. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%PageItemTitle%%

PDFCode11Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class
Defines a Code 11 barcode.
Object Model
PDFCode11Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode11Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode11Barcode
public class PDFCode11Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode11Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode11Barcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Code 11 barcode: 0 1 2 3 4 5 6 7 8 9 -
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode11Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode11Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

The following tables list the members exposed by PDFCode11Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode11Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode11Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode11Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class : PDFCode11Barcode Constructor
Overload List
Overload | Description
PDFCode11Barcode Constructor() | Initializes a new PDFCode11Barcode object.
PDFCode11Barcode Constructor(String,Double,Double) | Initializes a new PDFCode11Barcode object.
PDFCode11Barcode Constructor(String) | Initializes a new PDFCode11Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members


%%PageItemTitle%%

PDFCode11Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor()
Initializes a new PDFCode11Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode11Barcode()
public PDFCode11Barcode()
public: PDFCode11Barcode();
public:
PDFCode11Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


%%PageItemTitle%%

PDFCode11Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode11Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode11Barcode(data, left, top)
public PDFCode11Barcode(
   string data,
   double left,
   double top
)
public: PDFCode11Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode11Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


%%PageItemTitle%%

PDFCode11Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode11Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode11Barcode(data)
public PDFCode11Barcode(
   string data
)
public: PDFCode11Barcode(
   string* data
)
public:
PDFCode11Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128ABarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class
Defines a Code 128 barcode.
Object Model
PDFCode128ABarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode128ABarcode
   Inherits PDFCode128Barcode
'Usage

Dim instance As PDFCode128ABarcode
public class PDFCode128ABarcode : PDFCode128Barcode
public __gc class PDFCode128ABarcode : public PDFCode128Barcode
public ref class PDFCode128ABarcode : public PDFCode128Barcode
Remarks
This class defines a Code 128 barcode using the A character set. Only the following symbols are allowed in a Code 128 A barcode: NUL (\x00) SOH (\x01) STX (\x02) ETX (\x03) EOT (\x04) ENQ (\x05) ACK (\x06) BEL (\x07) BS (\x08) HT (\x09) LF (\x0A) VT (\x0B) FF (\x0C) CR (\x0D) SO (\x0E) SI (\x0F) DLE (\x10) DC1 (\x11) DC2 (\x12) DC3 (\x13) DC4 (\x14) NAK (\x15) SYN (\x16) ETB (\x17) CAN (\x18) EM (\x19) SUB (\x1A) ESC (\x1B) FS (\x1C) GS (\x1D) RS (\x1E) US (\x1F) SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128ABarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128ABarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

The following tables list the members exposed by PDFCode128ABarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode128ABarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128ABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128ABarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class : PDFCode128ABarcode Constructor
Overload List
Overload | Description
PDFCode128ABarcode Constructor() | Initializes a new PDFCode128ABarcode object.
PDFCode128ABarcode Constructor(String,Double,Double) | Initializes a new PDFCode128ABarcode object.
PDFCode128ABarcode Constructor(String) | Initializes a new PDFCode128ABarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members


%%PageItemTitle%%

PDFCode128ABarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor()
Initializes a new PDFCode128ABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode128ABarcode()
public PDFCode128ABarcode()
public: PDFCode128ABarcode();
public:
PDFCode128ABarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


%%PageItemTitle%%

PDFCode128ABarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128ABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode128ABarcode(data, left, top)
public PDFCode128ABarcode(
   string data,
   double left,
   double top
)
public: PDFCode128ABarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode128ABarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


%%PageItemTitle%%

PDFCode128ABarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode128ABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode128ABarcode(data)
public PDFCode128ABarcode(
   string data
)
public: PDFCode128ABarcode(
   string* data
)
public:
PDFCode128ABarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


%%PageItemTitle%%

PDFCode128Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class
Defines the base class for all Code 128 barcodes.
Object Model
PDFCode128Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode128Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode128Barcode
public class PDFCode128Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode128Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode128Barcode : public PDFUnidimensionalBarcode
Remarks
Code 128 allows to encode 102 symbols, grouped in 3 sets of symbols, A, B and C. Each symbol set is represented by its own barcode class: PDFCode128ABarcode, PDFCode128BBarcode and PDFCode128CBarcode.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128ABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128BBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN128Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

The following tables list the members exposed by PDFCode128Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode128Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class : PDFCode128Barcode Constructor
Overload List
Overload | Description
PDFCode128Barcode Constructor() | Initializes a new PDFCode128Barcode object.
PDFCode128Barcode Constructor(String,Double,Double) | Initializes a new PDFCode128Barcode object.
PDFCode128Barcode Constructor(String) | Initializes a new PDFCode128Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members


%%PageItemTitle%%

PDFCode128Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor()
Initializes a new PDFCode128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode128Barcode()
public PDFCode128Barcode()
public: PDFCode128Barcode();
public:
PDFCode128Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode128Barcode(data, left, top)
public PDFCode128Barcode(
   string data,
   double left,
   double top
)
public: PDFCode128Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode128Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode128Barcode(data)
public PDFCode128Barcode(
   string data
)
public: PDFCode128Barcode(
   string* data
)
public:
PDFCode128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128BBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class
Defines a Code 128 barcode.
Object Model
PDFCode128BBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode128BBarcode
   Inherits PDFCode128Barcode
'Usage

Dim instance As PDFCode128BBarcode
public class PDFCode128BBarcode : PDFCode128Barcode
public __gc class PDFCode128BBarcode : public PDFCode128Barcode
public ref class PDFCode128BBarcode : public PDFCode128Barcode
Remarks
This class defines a Code 128 barcode using the B character set. Only the following symbols are allowed in a Code 128 B barcode: SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ DEL (\x7F) FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128BBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128BBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

The following tables list the members exposed by PDFCode128BBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode128BBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128BBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128BBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class : PDFCode128BBarcode Constructor
Overload List
Overload | Description
PDFCode128BBarcode Constructor() | Initializes a new PDFCode128BBarcode object.
PDFCode128BBarcode Constructor(String,Double,Double) | Initializes a new PDFCode128BBarcode object.
PDFCode128BBarcode Constructor(String) | Initializes a new PDFCode128BBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members


%%PageItemTitle%%

PDFCode128BBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor()
Initializes a new PDFCode128BBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode128BBarcode()
public PDFCode128BBarcode()
public: PDFCode128BBarcode();
public:
PDFCode128BBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128BBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128BBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode128BBarcode(data, left, top)
public PDFCode128BBarcode(
   string data,
   double left,
   double top
)
public: PDFCode128BBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode128BBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128BBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode128BBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode128BBarcode(data)
public PDFCode128BBarcode(
   string data
)
public: PDFCode128BBarcode(
   string* data
)
public:
PDFCode128BBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128CBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class
Defines a Code 128 barcode.
Object Model
PDFCode128CBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode128CBarcode
   Inherits PDFCode128Barcode
'Usage

Dim instance As PDFCode128CBarcode
public class PDFCode128CBarcode : PDFCode128Barcode
public __gc class PDFCode128CBarcode : public PDFCode128Barcode
public ref class PDFCode128CBarcode : public PDFCode128Barcode
Remarks
This class defines a Code 128 barcode using the C character set. Only the following symbols are allowed in a Code 128 C barcode: 0 1 2 3 4 5 6 7 8 9 FNC1 (\xF0).
Code 128 C encodes only numeric symbols at double density, each pair of digits is encoded using a single symbol.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFFedExGround96Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSCC14Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSSCC18Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSPICBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128CBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

The following tables list the members exposed by PDFCode128CBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode128CBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128CBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128CBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class : PDFCode128CBarcode Constructor
Overload List
Overload | Description
PDFCode128CBarcode Constructor() | Initializes a new PDFCode128CBarcode object.
PDFCode128CBarcode Constructor(String,Double,Double) | Initializes a new PDFCode128CBarcode object.
PDFCode128CBarcode Constructor(String) | Initializes a new PDFCode128CBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members


%%PageItemTitle%%

PDFCode128CBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor()
Initializes a new PDFCode128CBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode128CBarcode()
public PDFCode128CBarcode()
public: PDFCode128CBarcode();
public:
PDFCode128CBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128CBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128CBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode128CBarcode(data, left, top)
public PDFCode128CBarcode(
   string data,
   double left,
   double top
)
public: PDFCode128CBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode128CBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128CBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode128CBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode128CBarcode(data)
public PDFCode128CBarcode(
   string data
)
public: PDFCode128CBarcode(
   string* data
)
public:
PDFCode128CBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


%%PageItemTitle%%

PDFCode16KBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class
Defines a Code 16K barcode.
Object Model
PDFCode16KBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode16KBarcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFCode16KBarcode
public class PDFCode16KBarcode : PDFBidimensionalBarcode
public __gc class PDFCode16KBarcode : public PDFBidimensionalBarcode
public ref class PDFCode16KBarcode : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode16KBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode16KBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

The following tables list the members exposed by PDFCode16KBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode16KBarcode Constructor | Initializes a new PDFCode16KBarcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top
See Also

Reference

PDFCode16KBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode16KBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : PDFCode16KBarcode Constructor
Initializes a new PDFCode16KBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode16KBarcode()
public PDFCode16KBarcode()
public: PDFCode16KBarcode();
public:
PDFCode16KBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%PageItemTitle%% $$Properties$$

PDFCode16KBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

For a list of all members of this type, see PDFCode16KBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top
See Also

Reference

PDFCode16KBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


Columns Property (PDFCode16KBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : Columns Property
Gets the number of columns in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Columns As Integer
'Usage

Dim instance As PDFCode16KBarcode
Dim value As Integer

value = instance.Columns
public int Columns {get;}
public: __property int get_Columns();
public:
property int Columns {
   int get();
}

Property Value

An integer value specifying the number of columns used by this barcode.
Remarks
A Code 16K barcode has always 5 columns.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


Rows Property (PDFCode16KBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : Rows Property
Gets or sets the number of rows in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As PDFCode16KBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of rows used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.
Remarks
The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


YDimension Property (PDFCode16KBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : YDimension Property
Gets or sets the height of a barcode row.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property YDimension As Double
'Usage

Dim instance As PDFCode16KBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
public new double YDimension {get; set;}
public: __property new double get_YDimension();
public: __property new void set_YDimension(
   double value
);
public:
new property double YDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of a barcode row.
Remarks
A minimum YDimension of 8*XDimension is recommended for ease of scanning. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%PageItemTitle%%

PDFCode25Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class
Defines a Code 2 of 5 barcode.
Object Model
PDFCode25Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode25Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode25Barcode
public class PDFCode25Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode25Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode25Barcode : public PDFUnidimensionalBarcode
Remarks
Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCOOP25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIATA25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMatrix25Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode25Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

The following tables list the members exposed by PDFCode25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode25Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class : PDFCode25Barcode Constructor
Overload List
Overload | Description
PDFCode25Barcode Constructor() | Initializes a new PDFCode25Barcode object.
PDFCode25Barcode Constructor(String,Double,Double) | Initializes a new PDFCode25Barcode object.
PDFCode25Barcode Constructor(String) | Initializes a new PDFCode25Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members


%%PageItemTitle%%

PDFCode25Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor()
Initializes a new PDFCode25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode25Barcode()
public PDFCode25Barcode()
public: PDFCode25Barcode();
public:
PDFCode25Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


%%PageItemTitle%%

PDFCode25Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode25Barcode(data, left, top)
public PDFCode25Barcode(
   string data,
   double left,
   double top
)
public: PDFCode25Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


%%PageItemTitle%%

PDFCode25Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode25Barcode(data)
public PDFCode25Barcode(
   string data
)
public: PDFCode25Barcode(
   string* data
)
public:
PDFCode25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFCode25Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

For a list of all members of this type, see PDFCode25Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


WideToNarrowRatio Property (PDFCode25Barcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class : WideToNarrowRatio Property
Gets or sets the ratio between wide bars and narrow bars.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WideToNarrowRatio As Double
'Usage

Dim instance As PDFCode25Barcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
public double WideToNarrowRatio {get; set;}
public: __property double get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   double value
);
public:
property double WideToNarrowRatio {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the ratio between wide bars and narrow bars.
Remarks
The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members


%%PageItemTitle%%

PDFCode25InterleavedBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class
Defines a Code 2 of 5 barcode.
Object Model
PDFCode25InterleavedBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode25InterleavedBarcode
   Inherits PDFCode25Barcode
'Usage

Dim instance As PDFCode25InterleavedBarcode
public class PDFCode25InterleavedBarcode : PDFCode25Barcode
public __gc class PDFCode25InterleavedBarcode : public PDFCode25Barcode
public ref class PDFCode25InterleavedBarcode : public PDFCode25Barcode
Remarks
Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIdentcodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFLeitcodeBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode25InterleavedBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

The following tables list the members exposed by PDFCode25InterleavedBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode25InterleavedBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode25InterleavedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class : PDFCode25InterleavedBarcode Constructor
Overload List
Overload | Description
PDFCode25InterleavedBarcode Constructor() | Initializes a new PDFCode25InterleavedBarcode object.
PDFCode25InterleavedBarcode Constructor(String,Double,Double) | Initializes a new PDFCode25InterleavedBarcode object.
PDFCode25InterleavedBarcode Constructor(String) | Initializes a new PDFCode25InterleavedBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor()
Initializes a new PDFCode25InterleavedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode25InterleavedBarcode()
public PDFCode25InterleavedBarcode()
public: PDFCode25InterleavedBarcode();
public:
PDFCode25InterleavedBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode25InterleavedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode25InterleavedBarcode(data, left, top)
public PDFCode25InterleavedBarcode(
   string data,
   double left,
   double top
)
public: PDFCode25InterleavedBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode25InterleavedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode25InterleavedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode25InterleavedBarcode(data)
public PDFCode25InterleavedBarcode(
   string data
)
public: PDFCode25InterleavedBarcode(
   string* data
)
public:
PDFCode25InterleavedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode32Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class
Defines a Code 32 barcode.
Object Model
PDFCode32Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode32Barcode
   Inherits PDFCode39Barcode
'Usage

Dim instance As PDFCode32Barcode
public class PDFCode32Barcode : PDFCode39Barcode
public __gc class PDFCode32Barcode : public PDFCode39Barcode
public ref class PDFCode32Barcode : public PDFCode39Barcode
Remarks
Only the following symbols are allowed in a Code 32 barcode: 1 2 3 4 5 6 7 8 9 0. The barcode length is 9 digits (8 user defined digits + 1 check digit).
Code 32 barcodes are also known as Italian Pharmacode barcodes.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode32Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode32Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

The following tables list the members exposed by PDFCode32Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode32Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode32Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode32Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class : PDFCode32Barcode Constructor
Overload List
Overload | Description
PDFCode32Barcode Constructor() | Initializes a new PDFCode32Barcode object.
PDFCode32Barcode Constructor(String,Double,Double) | Initializes a new PDFCode32Barcode object.
PDFCode32Barcode Constructor(String) | Initializes a new PDFCode32Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members


%%PageItemTitle%%

PDFCode32Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor()
Initializes a new PDFCode32Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode32Barcode()
public PDFCode32Barcode()
public: PDFCode32Barcode();
public:
PDFCode32Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


%%PageItemTitle%%

PDFCode32Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode32Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode32Barcode(data, left, top)
public PDFCode32Barcode(
   string data,
   double left,
   double top
)
public: PDFCode32Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode32Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


%%PageItemTitle%%

PDFCode32Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode32Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode32Barcode(data)
public PDFCode32Barcode(
   string data
)
public: PDFCode32Barcode(
   string* data
)
public:
PDFCode32Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


%%PageItemTitle%%

PDFCode39Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class
Defines a Code 39 barcode.
Object Model
PDFCode39Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode39Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode39Barcode
public class PDFCode39Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode39Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode39Barcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Code 39 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 39 Extended barcode must be used.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode32Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPZNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode39Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

The following tables list the members exposed by PDFCode39Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode39Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode39Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode39Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class : PDFCode39Barcode Constructor
Overload List
Overload | Description
PDFCode39Barcode Constructor() | Initializes a new PDFCode39Barcode object.
PDFCode39Barcode Constructor(String,Double,Double) | Initializes a new PDFCode39Barcode object.
PDFCode39Barcode Constructor(String) | Initializes a new PDFCode39Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members


%%PageItemTitle%%

PDFCode39Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor()
Initializes a new PDFCode39Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode39Barcode()
public PDFCode39Barcode()
public: PDFCode39Barcode();
public:
PDFCode39Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


%%PageItemTitle%%

PDFCode39Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode39Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode39Barcode(data, left, top)
public PDFCode39Barcode(
   string data,
   double left,
   double top
)
public: PDFCode39Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode39Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


%%PageItemTitle%%

PDFCode39Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode39Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode39Barcode(data)
public PDFCode39Barcode(
   string data
)
public: PDFCode39Barcode(
   string* data
)
public:
PDFCode39Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFCode39Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

For a list of all members of this type, see PDFCode39Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode39Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


WideToNarrowRatio Property (PDFCode39Barcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class : WideToNarrowRatio Property
Gets or sets the ratio between wide bars and narrow bars.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WideToNarrowRatio As Double
'Usage

Dim instance As PDFCode39Barcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
public double WideToNarrowRatio {get; set;}
public: __property double get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   double value
);
public:
property double WideToNarrowRatio {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the ratio between wide bars and narrow bars.
Remarks
The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members


%%PageItemTitle%%

PDFCode39ExtendedBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class
Defines an extended Code 39 barcode.
Object Model
PDFCode39ExtendedBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode39ExtendedBarcode
   Inherits PDFCode39Barcode
'Usage

Dim instance As PDFCode39ExtendedBarcode
public class PDFCode39ExtendedBarcode : PDFCode39Barcode
public __gc class PDFCode39ExtendedBarcode : public PDFCode39Barcode
public ref class PDFCode39ExtendedBarcode : public PDFCode39Barcode
Remarks
All 128 ASCII characters can be encoded in an extended Code 39 barcode.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode39ExtendedBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

The following tables list the members exposed by PDFCode39ExtendedBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode39ExtendedBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode39ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class : PDFCode39ExtendedBarcode Constructor
Overload List
Overload | Description
PDFCode39ExtendedBarcode Constructor() | Initializes a new PDFCode39ExtendedBarcode object.
PDFCode39ExtendedBarcode Constructor(String,Double,Double) | Initializes a new PDFCode39ExtendedBarcode object.
PDFCode39ExtendedBarcode Constructor(String) | Initializes a new PDFCode39ExtendedBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor()
Initializes a new PDFCode39ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode39ExtendedBarcode()
public PDFCode39ExtendedBarcode()
public: PDFCode39ExtendedBarcode();
public:
PDFCode39ExtendedBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode39ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode39ExtendedBarcode(data, left, top)
public PDFCode39ExtendedBarcode(
   string data,
   double left,
   double top
)
public: PDFCode39ExtendedBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode39ExtendedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode39ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode39ExtendedBarcode(data)
public PDFCode39ExtendedBarcode(
   string data
)
public: PDFCode39ExtendedBarcode(
   string* data
)
public:
PDFCode39ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode93Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class
Defines a Code 93 barcode.
Object Model
PDFCode93Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode93Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode93Barcode
public class PDFCode93Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode93Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode93Barcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Code 93 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 93 Extended barcode must be used.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode93Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

The following tables list the members exposed by PDFCode93Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode93Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode93Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode93Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class : PDFCode93Barcode Constructor
Overload List
Overload | Description
PDFCode93Barcode Constructor() | Initializes a new PDFCode93Barcode object.
PDFCode93Barcode Constructor(String,Double,Double) | Initializes a new PDFCode93Barcode object.
PDFCode93Barcode Constructor(String) | Initializes a new PDFCode93Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members


%%PageItemTitle%%

PDFCode93Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor()
Initializes a new PDFCode93Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode93Barcode()
public PDFCode93Barcode()
public: PDFCode93Barcode();
public:
PDFCode93Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


%%PageItemTitle%%

PDFCode93Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode93Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode93Barcode(data, left, top)
public PDFCode93Barcode(
   string data,
   double left,
   double top
)
public: PDFCode93Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode93Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


%%PageItemTitle%%

PDFCode93Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode93Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode93Barcode(data)
public PDFCode93Barcode(
   string data
)
public: PDFCode93Barcode(
   string* data
)
public:
PDFCode93Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


%%PageItemTitle%%

PDFCode93ExtendedBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class
Defines an extended Code 93 barcode.
Object Model
PDFCode93ExtendedBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode93ExtendedBarcode
   Inherits PDFCode93Barcode
'Usage

Dim instance As PDFCode93ExtendedBarcode
public class PDFCode93ExtendedBarcode : PDFCode93Barcode
public __gc class PDFCode93ExtendedBarcode : public PDFCode93Barcode
public ref class PDFCode93ExtendedBarcode : public PDFCode93Barcode
Remarks
All 128 ASCII characters can be encoded in an extended Code 93 barcode.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode93ExtendedBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

The following tables list the members exposed by PDFCode93ExtendedBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode93ExtendedBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode93ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class : PDFCode93ExtendedBarcode Constructor
Overload List
Overload | Description
PDFCode93ExtendedBarcode Constructor() | Initializes a new PDFCode93ExtendedBarcode object.
PDFCode93ExtendedBarcode Constructor(String,Double,Double) | Initializes a new PDFCode93ExtendedBarcode object.
PDFCode93ExtendedBarcode Constructor(String) | Initializes a new PDFCode93ExtendedBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor()
Initializes a new PDFCode93ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode93ExtendedBarcode()
public PDFCode93ExtendedBarcode()
public: PDFCode93ExtendedBarcode();
public:
PDFCode93ExtendedBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode93ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode93ExtendedBarcode(data, left, top)
public PDFCode93ExtendedBarcode(
   string data,
   double left,
   double top
)
public: PDFCode93ExtendedBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode93ExtendedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode93ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode93ExtendedBarcode(data)
public PDFCode93ExtendedBarcode(
   string data
)
public: PDFCode93ExtendedBarcode(
   string* data
)
public:
PDFCode93ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCOOP25Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class
Defines a COOP 2 of 5 barcode.
Object Model
PDFCOOP25Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCOOP25Barcode
   Inherits PDFCode25Barcode
'Usage

Dim instance As PDFCOOP25Barcode
public class PDFCOOP25Barcode : PDFCode25Barcode
public __gc class PDFCOOP25Barcode : public PDFCode25Barcode
public ref class PDFCOOP25Barcode : public PDFCode25Barcode
Remarks
COOP 2 of 5 is a numeric symbology. Only the following symbols are allowed in a COOP 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCOOP25Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCOOP25Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

The following tables list the members exposed by PDFCOOP25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCOOP25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCOOP25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCOOP25Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class : PDFCOOP25Barcode Constructor
Overload List
Overload | Description
PDFCOOP25Barcode Constructor() | Initializes a new PDFCOOP25Barcode object.
PDFCOOP25Barcode Constructor(String,Double,Double) | Initializes a new PDFCOOP25Barcode object.
PDFCOOP25Barcode Constructor(String) | Initializes a new PDFCOOP25Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members


%%PageItemTitle%%

PDFCOOP25Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor()
Initializes a new PDFCOOP25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCOOP25Barcode()
public PDFCOOP25Barcode()
public: PDFCOOP25Barcode();
public:
PDFCOOP25Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


%%PageItemTitle%%

PDFCOOP25Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCOOP25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCOOP25Barcode(data, left, top)
public PDFCOOP25Barcode(
   string data,
   double left,
   double top
)
public: PDFCOOP25Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCOOP25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


%%PageItemTitle%%

PDFCOOP25Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCOOP25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCOOP25Barcode(data)
public PDFCOOP25Barcode(
   string data
)
public: PDFCOOP25Barcode(
   string* data
)
public:
PDFCOOP25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


%%PageItemTitle%%

PDFDataMatrixBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class
Defines a DataMatrix barcode.
Object Model
PDFDataMatrixBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDataMatrixBarcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFDataMatrixBarcode
public class PDFDataMatrixBarcode : PDFBidimensionalBarcode
public __gc class PDFDataMatrixBarcode : public PDFBidimensionalBarcode
public ref class PDFDataMatrixBarcode : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFDataMatrixBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFDataMatrixBarcode Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

The following tables list the members exposed by PDFDataMatrixBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFDataMatrixBarcode Constructor | Initializes a new PDFDataMatrixBarcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
Public Methods
 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top
See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFDataMatrixBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : PDFDataMatrixBarcode Constructor
Initializes a new PDFDataMatrixBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDataMatrixBarcode()
public PDFDataMatrixBarcode()
public: PDFDataMatrixBarcode();
public:
PDFDataMatrixBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%% $$Methods$$

PDFDataMatrixBarcode Class Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

For a list of all members of this type, see PDFDataMatrixBarcode members.

Public Methods
 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top
See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


Randomize253State Method

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : Randomize253State Method
The padding codeword, usually 129.
The position of the padding codeword (0 based index).
Applies the 253-state randomizing algorithm on padding values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Randomize253State( _
   ByVal padCodeword As Integer, _
   ByVal position As Integer _
) As Byte
'Usage

Dim instance As PDFDataMatrixBarcode
Dim padCodeword As Integer
Dim position As Integer
Dim value As Byte

value = instance.Randomize253State(padCodeword, position)
public byte Randomize253State(
   int padCodeword,
   int position
)
public: byte Randomize253State(
   int padCodeword,
   int position
)
public:
byte Randomize253State(
   int padCodeword,
   int position
)

Parameters

padCodeword
The padding codeword, usually 129.
position
The position of the padding codeword (0 based index).

Return Value

The randomized value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%% $$Properties$$

PDFDataMatrixBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

For a list of all members of this type, see PDFDataMatrixBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


Encoding Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : Encoding Property
Gets or sets the encoding of this DataMatrix barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Encoding As DataMatrixEncoding
'Usage

Dim instance As PDFDataMatrixBarcode
Dim value As DataMatrixEncoding

instance.Encoding = value

value = instance.Encoding
public DataMatrixEncoding Encoding {get; set;}
public: __property DataMatrixEncoding get_Encoding();
public: __property void set_Encoding(
   DataMatrixEncoding value
);
public:
property DataMatrixEncoding Encoding {
   DataMatrixEncoding get();
   void set (    DataMatrixEncoding value);
}

Property Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.
Remarks
If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then DataMatrixEncoding.Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both DataMatrixEncoding.ASCII and DataMatrixEncoding.Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the DataMatrixEncoding.Base256 encoding is the best option.
If the selected encoding is DataMatrixEncoding.Auto, then the library will select the encoding that will generate the smallest encoded data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


SymbolSize Property (PDFDataMatrixBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : SymbolSize Property
Gets or sets the symbol size of this DataMatrix barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SymbolSize As DataMatrixSymbolSize
'Usage

Dim instance As PDFDataMatrixBarcode
Dim value As DataMatrixSymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
public DataMatrixSymbolSize SymbolSize {get; set;}
public: __property DataMatrixSymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   DataMatrixSymbolSize value
);
public:
property DataMatrixSymbolSize SymbolSize {
   DataMatrixSymbolSize get();
   void set (    DataMatrixSymbolSize value);
}

Property Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.
Remarks
If the SymbolSize is DataMatrixSymbolSize.Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%%

PDFEAN128Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class
Defines a EAN 128 barcode.
Object Model
PDFEAN128Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFEAN128Barcode
   Inherits PDFCode128Barcode
'Usage

Dim instance As PDFEAN128Barcode
public class PDFEAN128Barcode : PDFCode128Barcode
public __gc class PDFEAN128Barcode : public PDFCode128Barcode
public ref class PDFEAN128Barcode : public PDFCode128Barcode
Remarks
An EAN-128 barcode is a Code 128 barcode that has specific rules for interpreting the encoded data, based on an application identifier.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN128Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEAN128Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

The following tables list the members exposed by PDFEAN128Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFEAN128Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEAN128Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class : PDFEAN128Barcode Constructor
Overload List
Overload | Description
PDFEAN128Barcode Constructor() | Initializes a new PDFEAN128Barcode object.
PDFEAN128Barcode Constructor(String,Double,Double) | Initializes a new PDFEAN128Barcode object.
PDFEAN128Barcode Constructor(String) | Initializes a new PDFEAN128Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members


%%PageItemTitle%%

PDFEAN128Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor()
Initializes a new PDFEAN128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFEAN128Barcode()
public PDFEAN128Barcode()
public: PDFEAN128Barcode();
public:
PDFEAN128Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN128Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFEAN128Barcode(data, left, top)
public PDFEAN128Barcode(
   string data,
   double left,
   double top
)
public: PDFEAN128Barcode(
   string* data,
   double left,
   double top
)
public:
PDFEAN128Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN128Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFEAN128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFEAN128Barcode(data)
public PDFEAN128Barcode(
   string data
)
public: PDFEAN128Barcode(
   string* data
)
public:
PDFEAN128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFEAN128Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

For a list of all members of this type, see PDFEAN128Barcode members.

Public Properties
 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


ApplicationIdentifier Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class : ApplicationIdentifier Property
Gets or sets the application identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ApplicationIdentifier As String
'Usage

Dim instance As PDFEAN128Barcode
Dim value As String

instance.ApplicationIdentifier = value

value = instance.ApplicationIdentifier
public string ApplicationIdentifier {get; set;}
public: __property string* get_ApplicationIdentifier();
public: __property void set_ApplicationIdentifier(
   string* value
);
public:
property String^ ApplicationIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the application identifier.
Remarks
The application identifier defines how the barcode data should be interpreted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members


%%PageItemTitle%%

PDFEAN13Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class
Defines the class for EAN-13 barcodes.
Object Model
PDFEAN13Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFEAN13Barcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFEAN13Barcode
public class PDFEAN13Barcode : PDFEANBarcode
public __gc class PDFEAN13Barcode : public PDFEANBarcode
public ref class PDFEAN13Barcode : public PDFEANBarcode
Remarks
EAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always have 12 characters length. The 13th character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN13Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEAN13Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

The following tables list the members exposed by PDFEAN13Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFEAN13Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEAN13Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class : PDFEAN13Barcode Constructor
Overload List
Overload | Description
PDFEAN13Barcode Constructor() | Initializes a new PDFEAN13Barcode object.
PDFEAN13Barcode Constructor(String,Double,Double) | Initializes a new PDFEAN13Barcode object.
PDFEAN13Barcode Constructor(String) | Initializes a new PDFEAN13Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members


%%PageItemTitle%%

PDFEAN13Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor()
Initializes a new PDFEAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFEAN13Barcode()
public PDFEAN13Barcode()
public: PDFEAN13Barcode();
public:
PDFEAN13Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN13Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFEAN13Barcode(data, left, top)
public PDFEAN13Barcode(
   string data,
   double left,
   double top
)
public: PDFEAN13Barcode(
   string* data,
   double left,
   double top
)
public:
PDFEAN13Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN13Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFEAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFEAN13Barcode(data)
public PDFEAN13Barcode(
   string data
)
public: PDFEAN13Barcode(
   string* data
)
public:
PDFEAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN8Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class
Defines the class for EAN-8 barcodes.
Object Model
PDFEAN8Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFEAN8Barcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFEAN8Barcode
public class PDFEAN8Barcode : PDFEANBarcode
public __gc class PDFEAN8Barcode : public PDFEANBarcode
public ref class PDFEAN8Barcode : public PDFEANBarcode
Remarks
EAN-8 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-8 barcode must always have 7 characters length. The 8th character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN8Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEAN8Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

The following tables list the members exposed by PDFEAN8Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFEAN8Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN8Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEAN8Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class : PDFEAN8Barcode Constructor
Overload List
Overload | Description
PDFEAN8Barcode Constructor() | Initializes a new PDFEAN8Barcode object.
PDFEAN8Barcode Constructor(String,Double,Double) | Initializes a new PDFEAN8Barcode object.
PDFEAN8Barcode Constructor(String) | Initializes a new PDFEAN8Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members


%%PageItemTitle%%

PDFEAN8Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor()
Initializes a new PDFEAN8Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFEAN8Barcode()
public PDFEAN8Barcode()
public: PDFEAN8Barcode();
public:
PDFEAN8Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN8Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN8Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFEAN8Barcode(data, left, top)
public PDFEAN8Barcode(
   string data,
   double left,
   double top
)
public: PDFEAN8Barcode(
   string* data,
   double left,
   double top
)
public:
PDFEAN8Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN8Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFEAN8Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFEAN8Barcode(data)
public PDFEAN8Barcode(
   string data
)
public: PDFEAN8Barcode(
   string* data
)
public:
PDFEAN8Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


%%PageItemTitle%%

PDFEANBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class
Defines the base class for EAN based barcodes.
Object Model
PDFEANBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFEANBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFEANBarcode
public abstract class PDFEANBarcode : PDFUnidimensionalBarcode
public __gc abstract class PDFEANBarcode : public PDFUnidimensionalBarcode
public ref class PDFEANBarcode abstract : public PDFUnidimensionalBarcode
Remarks
An EAN based symbology is a numeric symbology. Only the following symbols are allowed in an EAN based barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always has 12 characters length. The 13th character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN8Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISBNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISMNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISSNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFJAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCEBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEANBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

The following tables list the members exposed by PDFEANBarcode.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters.
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEANBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFEANBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

For a list of all members of this type, see PDFEANBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters.
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEANBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


BarReductionFactor Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : BarReductionFactor Property
Gets or sets the factor used for reducing/enlarging bar widths for special characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BarReductionFactor As Double
'Usage

Dim instance As PDFEANBarcode
Dim value As Double

instance.BarReductionFactor = value

value = instance.BarReductionFactor
public double BarReductionFactor {get; set;}
public: __property double get_BarReductionFactor();
public: __property void set_BarReductionFactor(
   double value
);
public:
property double BarReductionFactor {
   double get();
   void set (    double value);
}

Property Value

A factor applied to bar width for reducing/enlarging the bars for special characters 1, 2, 7, and 8.
Remarks
The standard recommends this value to be 1/13 of bar width.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


Supplement Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : Supplement Property
Gets or sets the supplement for barcode data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Supplement As String
'Usage

Dim instance As PDFEANBarcode
Dim value As String

instance.Supplement = value

value = instance.Supplement
public string Supplement {get; set;}
public: __property string* get_Supplement();
public: __property void set_Supplement(
   string* value
);
public:
property String^ Supplement {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying a 2 or 5 digit supplemental barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).
Remarks
This supplement is optional. If it exists, it can be only 2 or 5 digits.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


SupplementDisplayLocation Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : SupplementDisplayLocation Property
Gets or sets the location of the supplement text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SupplementDisplayLocation As BarcodeTextLocation
'Usage

Dim instance As PDFEANBarcode
Dim value As BarcodeTextLocation

instance.SupplementDisplayLocation = value

value = instance.SupplementDisplayLocation
public BarcodeTextLocation SupplementDisplayLocation {get; set;}
public: __property BarcodeTextLocation get_SupplementDisplayLocation();
public: __property void set_SupplementDisplayLocation(
   BarcodeTextLocation value
);
public:
property BarcodeTextLocation SupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (    BarcodeTextLocation value);
}

Property Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.
Remarks
The embedding options are ignored for supplement text. BarcodeTextLocation.AboveEmbedded has the same effect like BarcodeTextLocation.Above, and BarcodeTextLocation.BelowEmbedded has the same effect like BarcodeTextLocation.Below.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


SupplementYDimension Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : SupplementYDimension Property
Gets or sets the height of a bar in the supplement barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SupplementYDimension As Double
'Usage

Dim instance As PDFEANBarcode
Dim value As Double

instance.SupplementYDimension = value

value = instance.SupplementYDimension
public double SupplementYDimension {get; set;}
public: __property double get_SupplementYDimension();
public: __property void set_SupplementYDimension(
   double value
);
public:
property double SupplementYDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of a bar in the supplement barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


%%PageItemTitle%%

PDFFedExGround96Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class
Defines a FedEx Ground 96 barcode.
Object Model
PDFFedExGround96Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFedExGround96Barcode
   Inherits PDFCode128CBarcode
'Usage

Dim instance As PDFFedExGround96Barcode
public class PDFFedExGround96Barcode : PDFCode128CBarcode
public __gc class PDFFedExGround96Barcode : public PDFCode128CBarcode
public ref class PDFFedExGround96Barcode : public PDFCode128CBarcode
Remarks
This class defines a FedEx Ground 96 barcode. Only the following symbols are allowed in the barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 21 digits and the first 2 digits are always 96.
The structure of a FedEx Ground 96 barcode is as follows:
1-2 - Application Identifier (96)
3-4 - Two digit “Serial Container Numeric Code” - “11,12,13” identifies the carrier as “FedEx Ground”.
5-7 - Class of Service - Three-digit number used to identify the FedEx Ground class of service.
8-14 - FedEx Ground Shipper ID - Seven-digit unique shipper identification number.
15-21 - Package Number - Seven-digit package serial number.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFFedExGround96Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFFedExGround96Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

The following tables list the members exposed by PDFFedExGround96Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFFedExGround96Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFFedExGround96Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class : PDFFedExGround96Barcode Constructor
Overload List
Overload | Description
PDFFedExGround96Barcode Constructor() | Initializes a new PDFFedExGround96Barcode object.
PDFFedExGround96Barcode Constructor(String,Double,Double) | Initializes a new PDFFedExGround96Barcode object.
PDFFedExGround96Barcode Constructor(String) | Initializes a new PDFFedExGround96Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor()
Initializes a new PDFFedExGround96Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFedExGround96Barcode()
public PDFFedExGround96Barcode()
public: PDFFedExGround96Barcode();
public:
PDFFedExGround96Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFFedExGround96Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFFedExGround96Barcode(data, left, top)
public PDFFedExGround96Barcode(
   string data,
   double left,
   double top
)
public: PDFFedExGround96Barcode(
   string* data,
   double left,
   double top
)
public:
PDFFedExGround96Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFFedExGround96Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFFedExGround96Barcode(data)
public PDFFedExGround96Barcode(
   string data
)
public: PDFFedExGround96Barcode(
   string* data
)
public:
PDFFedExGround96Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PDFHeightModulatedBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class
Defines the base class for all height modulated barcodes.
Object Model
PDFHeightModulatedBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFHeightModulatedBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFHeightModulatedBarcode
public abstract class PDFHeightModulatedBarcode : PDFUnidimensionalBarcode
public __gc abstract class PDFHeightModulatedBarcode : public PDFUnidimensionalBarcode
public ref class PDFHeightModulatedBarcode abstract : public PDFUnidimensionalBarcode
Remarks
Height modulated barcodes encode the information in the height of the bars, not and in the width of the bars and spaces.
Usually height modulated barcodes are used for encoding postal information, such as ZIP/Postal codes or delivery points.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPlanetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPostNetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHeightModulatedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFHeightModulatedBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

The following tables list the members exposed by PDFHeightModulatedBarcode.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFHeightModulatedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFIATA25Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class
Defines a IATA 2 of 5 barcode.
Object Model
PDFIATA25Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFIATA25Barcode
   Inherits PDFCode25Barcode
'Usage

Dim instance As PDFIATA25Barcode
public class PDFIATA25Barcode : PDFCode25Barcode
public __gc class PDFIATA25Barcode : public PDFCode25Barcode
public ref class PDFIATA25Barcode : public PDFCode25Barcode
Remarks
IATA 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
IATA (International Air Transport Assosiation) uses this for the management of air cargo.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIATA25Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFIATA25Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

The following tables list the members exposed by PDFIATA25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFIATA25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFIATA25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFIATA25Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class : PDFIATA25Barcode Constructor
Overload List
Overload | Description
PDFIATA25Barcode Constructor() | Initializes a new PDFIATA25Barcode object.
PDFIATA25Barcode Constructor(String,Double,Double) | Initializes a new PDFIATA25Barcode object.
PDFIATA25Barcode Constructor(String) | Initializes a new PDFIATA25Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members


%%PageItemTitle%%

PDFIATA25Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor()
Initializes a new PDFIATA25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFIATA25Barcode()
public PDFIATA25Barcode()
public: PDFIATA25Barcode();
public:
PDFIATA25Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


%%PageItemTitle%%

PDFIATA25Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFIATA25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFIATA25Barcode(data, left, top)
public PDFIATA25Barcode(
   string data,
   double left,
   double top
)
public: PDFIATA25Barcode(
   string* data,
   double left,
   double top
)
public:
PDFIATA25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


%%PageItemTitle%%

PDFIATA25Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFIATA25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFIATA25Barcode(data)
public PDFIATA25Barcode(
   string data
)
public: PDFIATA25Barcode(
   string* data
)
public:
PDFIATA25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


%%PageItemTitle%%

PDFIdentcodeBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class
Defines an Identcode barcode.
Object Model
PDFIdentcodeBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFIdentcodeBarcode
   Inherits PDFCode25InterleavedBarcode
'Usage

Dim instance As PDFIdentcodeBarcode
public class PDFIdentcodeBarcode : PDFCode25InterleavedBarcode
public __gc class PDFIdentcodeBarcode : public PDFCode25InterleavedBarcode
public ref class PDFIdentcodeBarcode : public PDFCode25InterleavedBarcode
Remarks
The Identcode is a numeric barcode using the digits from 0 to 9 and is used by the Deutsche Post AG (DHL). It has a fixed length of 12 digits (11 user defined digits + 1 check digit).
The structure of Identcode barcode is:
1..2 - Mail center (outgoing)
3..5 - Customer code
6..11 - Delivery number
12 - Check digit (computed automatically)
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIdentcodeBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFIdentcodeBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

The following tables list the members exposed by PDFIdentcodeBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFIdentcodeBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFIdentcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class : PDFIdentcodeBarcode Constructor
Overload List
Overload | Description
PDFIdentcodeBarcode Constructor() | Initializes a new PDFIdentcodeBarcode object.
PDFIdentcodeBarcode Constructor(String,Double,Double) | Initializes a new PDFIdentcodeBarcode object.
PDFIdentcodeBarcode Constructor(String) | Initializes a new PDFIdentcodeBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor()
Initializes a new PDFIdentcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFIdentcodeBarcode()
public PDFIdentcodeBarcode()
public: PDFIdentcodeBarcode();
public:
PDFIdentcodeBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFIdentcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFIdentcodeBarcode(data, left, top)
public PDFIdentcodeBarcode(
   string data,
   double left,
   double top
)
public: PDFIdentcodeBarcode(
   string* data,
   double left,
   double top
)
public:
PDFIdentcodeBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFIdentcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFIdentcodeBarcode(data)
public PDFIdentcodeBarcode(
   string data
)
public: PDFIdentcodeBarcode(
   string* data
)
public:
PDFIdentcodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFISBNBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class
Defines the class for ISBN barcodes.
Object Model
PDFISBNBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFISBNBarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFISBNBarcode
public class PDFISBNBarcode : PDFEANBarcode
public __gc class PDFISBNBarcode : public PDFEANBarcode
public ref class PDFISBNBarcode : public PDFEANBarcode
Remarks
ISBN symbology is a numeric symbology. Only the following symbols are allowed in an ISBN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISBN barcode (International Standard Book Numbering) is in fact an EAN-13 barcode having the 978 number system. The data for an ISBN barcode must always have 9 characters length. The number system is always 978 and the last character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISBNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFISBNBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

The following tables list the members exposed by PDFISBNBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFISBNBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISBNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFISBNBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class : PDFISBNBarcode Constructor
Overload List
Overload | Description
PDFISBNBarcode Constructor() | Initializes a new PDFISBNBarcode object.
PDFISBNBarcode Constructor(String,Double,Double) | Initializes a new PDFISBNBarcode object.
PDFISBNBarcode Constructor(String) | Initializes a new PDFISBNBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members


%%PageItemTitle%%

PDFISBNBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor()
Initializes a new PDFISBNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFISBNBarcode()
public PDFISBNBarcode()
public: PDFISBNBarcode();
public:
PDFISBNBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


%%PageItemTitle%%

PDFISBNBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISBNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFISBNBarcode(data, left, top)
public PDFISBNBarcode(
   string data,
   double left,
   double top
)
public: PDFISBNBarcode(
   string* data,
   double left,
   double top
)
public:
PDFISBNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


%%PageItemTitle%%

PDFISBNBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFISBNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFISBNBarcode(data)
public PDFISBNBarcode(
   string data
)
public: PDFISBNBarcode(
   string* data
)
public:
PDFISBNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


%%PageItemTitle%%

PDFISMNBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class
Defines the class for ISMN barcodes.
Object Model
PDFISMNBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFISMNBarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFISMNBarcode
public class PDFISMNBarcode : PDFEANBarcode
public __gc class PDFISMNBarcode : public PDFEANBarcode
public ref class PDFISMNBarcode : public PDFEANBarcode
Remarks
ISMN symbology is a numeric symbology. Only the following symbols are allowed in an ISMN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISMN barcode (International Standard Music Number) is in fact an EAN-13 barcode having the 979 number system. The data for an ISMN barcode must always have 9 characters length. The number system is always 979 and the last character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISMNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFISMNBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

The following tables list the members exposed by PDFISMNBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFISMNBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISMNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFISMNBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class : PDFISMNBarcode Constructor
Overload List
Overload | Description
PDFISMNBarcode Constructor() | Initializes a new PDFISMNBarcode object.
PDFISMNBarcode Constructor(String,Double,Double) | Initializes a new PDFISMNBarcode object.
PDFISMNBarcode Constructor(String) | Initializes a new PDFISMNBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members


%%PageItemTitle%%

PDFISMNBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor()
Initializes a new PDFISMNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFISMNBarcode()
public PDFISMNBarcode()
public: PDFISMNBarcode();
public:
PDFISMNBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


%%PageItemTitle%%

PDFISMNBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISMNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFISMNBarcode(data, left, top)
public PDFISMNBarcode(
   string data,
   double left,
   double top
)
public: PDFISMNBarcode(
   string* data,
   double left,
   double top
)
public:
PDFISMNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


%%PageItemTitle%%

PDFISMNBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFISMNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFISMNBarcode(data)
public PDFISMNBarcode(
   string data
)
public: PDFISMNBarcode(
   string* data
)
public:
PDFISMNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


%%PageItemTitle%%

PDFISSNBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class
Defines the class for ISSN barcodes.
Object Model
PDFISSNBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFISSNBarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFISSNBarcode
public class PDFISSNBarcode : PDFEANBarcode
public __gc class PDFISSNBarcode : public PDFEANBarcode
public ref class PDFISSNBarcode : public PDFEANBarcode
Remarks
ISSN symbology is a numeric symbology. Only the following symbols are allowed in an ISSN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISSN barcode (International Standard Serial Number for Periodicals) is in fact an EAN-13 barcode having the 977 number system. The data for an ISSN barcode must always have 9 characters length. The number system is always 977 and the last character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISSNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFISSNBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

The following tables list the members exposed by PDFISSNBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFISSNBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISSNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFISSNBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class : PDFISSNBarcode Constructor
Overload List
Overload | Description
PDFISSNBarcode Constructor() | Initializes a new PDFISSNBarcode object.
PDFISSNBarcode Constructor(String,Double,Double) | Initializes a new PDFISSNBarcode object.
PDFISSNBarcode Constructor(String) | Initializes a new PDFISSNBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members


%%PageItemTitle%%

PDFISSNBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor()
Initializes a new PDFISSNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFISSNBarcode()
public PDFISSNBarcode()
public: PDFISSNBarcode();
public:
PDFISSNBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


%%PageItemTitle%%

PDFISSNBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISSNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFISSNBarcode(data, left, top)
public PDFISSNBarcode(
   string data,
   double left,
   double top
)
public: PDFISSNBarcode(
   string* data,
   double left,
   double top
)
public:
PDFISSNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


%%PageItemTitle%%

PDFISSNBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFISSNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFISSNBarcode(data)
public PDFISSNBarcode(
   string data
)
public: PDFISSNBarcode(
   string* data
)
public:
PDFISSNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


%%PageItemTitle%%

PDFJAN13Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class
Defines the class for JAN13 barcodes.
Object Model
PDFJAN13Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFJAN13Barcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFJAN13Barcode
public class PDFJAN13Barcode : PDFEANBarcode
public __gc class PDFJAN13Barcode : public PDFEANBarcode
public ref class PDFJAN13Barcode : public PDFEANBarcode
Remarks
JAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an JAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. An JAN-13 barcode (Japanese Article Numbering) is in fact an EAN-13 barcode having the 49 number system. The data for an JAN-13 barcode must always have 10 characters length. The number system is always 49 and the last character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFJAN13Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFJAN13Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

The following tables list the members exposed by PDFJAN13Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFJAN13Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFJAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFJAN13Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class : PDFJAN13Barcode Constructor
Overload List
Overload | Description
PDFJAN13Barcode Constructor() | Initializes a new PDFJAN13Barcode object.
PDFJAN13Barcode Constructor(String,Double,Double) | Initializes a new PDFJAN13Barcode object.
PDFJAN13Barcode Constructor(String) | Initializes a new PDFJAN13Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members


%%PageItemTitle%%

PDFJAN13Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor()
Initializes a new PDFJAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFJAN13Barcode()
public PDFJAN13Barcode()
public: PDFJAN13Barcode();
public:
PDFJAN13Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFJAN13Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFJAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFJAN13Barcode(data, left, top)
public PDFJAN13Barcode(
   string data,
   double left,
   double top
)
public: PDFJAN13Barcode(
   string* data,
   double left,
   double top
)
public:
PDFJAN13Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFJAN13Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFJAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFJAN13Barcode(data)
public PDFJAN13Barcode(
   string data
)
public: PDFJAN13Barcode(
   string* data
)
public:
PDFJAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFKixBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class
Defines a Kix barcode.
Object Model
PDFKixBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFKixBarcode
   Inherits PDFRM4SCCBarcode
'Usage

Dim instance As PDFKixBarcode
public class PDFKixBarcode : PDFRM4SCCBarcode
public __gc class PDFKixBarcode : public PDFRM4SCCBarcode
public ref class PDFKixBarcode : public PDFRM4SCCBarcode
Remarks
The Kix barcode, a height-modulated barcode symbology, is used by Royal Dutch Post in automated mail sortation process.
Only the following symbols are allowed in a Kix barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFKixBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFKixBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

The following tables list the members exposed by PDFKixBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFKixBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFKixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFKixBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class : PDFKixBarcode Constructor
Overload List
Overload | Description
PDFKixBarcode Constructor() | Initializes a new PDFKixBarcode object.
PDFKixBarcode Constructor(String,Double,Double) | Initializes a new PDFKixBarcode object.
PDFKixBarcode Constructor(String) | Initializes a new PDFKixBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members


%%PageItemTitle%%

PDFKixBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor()
Initializes a new PDFKixBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFKixBarcode()
public PDFKixBarcode()
public: PDFKixBarcode();
public:
PDFKixBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


%%PageItemTitle%%

PDFKixBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFKixBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFKixBarcode(data, left, top)
public PDFKixBarcode(
   string data,
   double left,
   double top
)
public: PDFKixBarcode(
   string* data,
   double left,
   double top
)
public:
PDFKixBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


%%PageItemTitle%%

PDFKixBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFKixBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFKixBarcode(data)
public PDFKixBarcode(
   string data
)
public: PDFKixBarcode(
   string* data
)
public:
PDFKixBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


%%PageItemTitle%%

PDFLeitcodeBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class
Defines a Leitcode barcode.
Object Model
PDFLeitcodeBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLeitcodeBarcode
   Inherits PDFCode25InterleavedBarcode
'Usage

Dim instance As PDFLeitcodeBarcode
public class PDFLeitcodeBarcode : PDFCode25InterleavedBarcode
public __gc class PDFLeitcodeBarcode : public PDFCode25InterleavedBarcode
public ref class PDFLeitcodeBarcode : public PDFCode25InterleavedBarcode
Remarks
The Leitcode is a numeric barcode using the digits from 0 to 9 and is used by the Deutsche Post AG (DHL). It has a fixed length of 14 digits (13 user defined digits + 1 check digit).
The structure of Leitcode barcode is:
1..5 - ZIP code
6..8 - Street's code number
9..11 - House number
12..13 - Product code
14 - Check Digit
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFLeitcodeBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFLeitcodeBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

The following tables list the members exposed by PDFLeitcodeBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFLeitcodeBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFLeitcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class : PDFLeitcodeBarcode Constructor
Overload List
Overload | Description
PDFLeitcodeBarcode Constructor() | Initializes a new PDFLeitcodeBarcode object.
PDFLeitcodeBarcode Constructor(String,Double,Double) | Initializes a new PDFLeitcodeBarcode object.
PDFLeitcodeBarcode Constructor(String) | Initializes a new PDFLeitcodeBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor()
Initializes a new PDFLeitcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLeitcodeBarcode()
public PDFLeitcodeBarcode()
public: PDFLeitcodeBarcode();
public:
PDFLeitcodeBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFLeitcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFLeitcodeBarcode(data, left, top)
public PDFLeitcodeBarcode(
   string data,
   double left,
   double top
)
public: PDFLeitcodeBarcode(
   string* data,
   double left,
   double top
)
public:
PDFLeitcodeBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFLeitcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFLeitcodeBarcode(data)
public PDFLeitcodeBarcode(
   string data
)
public: PDFLeitcodeBarcode(
   string* data
)
public:
PDFLeitcodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFMatrix25Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class
Defines a Matrix 2 of 5 barcode.
Object Model
PDFMatrix25Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMatrix25Barcode
   Inherits PDFCode25Barcode
'Usage

Dim instance As PDFMatrix25Barcode
public class PDFMatrix25Barcode : PDFCode25Barcode
public __gc class PDFMatrix25Barcode : public PDFCode25Barcode
public ref class PDFMatrix25Barcode : public PDFCode25Barcode
Remarks
Matrix 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMatrix25Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFMatrix25Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

The following tables list the members exposed by PDFMatrix25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFMatrix25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMatrix25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFMatrix25Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class : PDFMatrix25Barcode Constructor
Overload List
Overload | Description
PDFMatrix25Barcode Constructor() | Initializes a new PDFMatrix25Barcode object.
PDFMatrix25Barcode Constructor(String,Double,Double) | Initializes a new PDFMatrix25Barcode object.
PDFMatrix25Barcode Constructor(String) | Initializes a new PDFMatrix25Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members


%%PageItemTitle%%

PDFMatrix25Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor()
Initializes a new PDFMatrix25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMatrix25Barcode()
public PDFMatrix25Barcode()
public: PDFMatrix25Barcode();
public:
PDFMatrix25Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PDFMatrix25Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFMatrix25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFMatrix25Barcode(data, left, top)
public PDFMatrix25Barcode(
   string data,
   double left,
   double top
)
public: PDFMatrix25Barcode(
   string* data,
   double left,
   double top
)
public:
PDFMatrix25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PDFMatrix25Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFMatrix25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFMatrix25Barcode(data)
public PDFMatrix25Barcode(
   string data
)
public: PDFMatrix25Barcode(
   string* data
)
public:
PDFMatrix25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PDFMicroPDF417Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class
Defines a Micro PDF 417 barcode.
Object Model
PDFMicroPDF417Barcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMicroPDF417Barcode
   Inherits PDFBasePDF417Barcode
'Usage

Dim instance As PDFMicroPDF417Barcode
public class PDFMicroPDF417Barcode : PDFBasePDF417Barcode
public __gc class PDFMicroPDF417Barcode : public PDFBasePDF417Barcode
public ref class PDFMicroPDF417Barcode : public PDFBasePDF417Barcode
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMicroPDF417Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMicroPDF417Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFMicroPDF417Barcode Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

The following tables list the members exposed by PDFMicroPDF417Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFMicroPDF417Barcode Constructor | Initializes a new PDFMicroPDF417Barcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Top
See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFMicroPDF417Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMicroPDF417Barcode Class : PDFMicroPDF417Barcode Constructor
Initializes a new PDFMicroPDF417Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMicroPDF417Barcode()
public PDFMicroPDF417Barcode()
public: PDFMicroPDF417Barcode();
public:
PDFMicroPDF417Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMicroPDF417Barcode Class
PDFMicroPDF417Barcode Members


%%PageItemTitle%% $$Properties$$

PDFMicroPDF417Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

For a list of all members of this type, see PDFMicroPDF417Barcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


SymbolSize Property (PDFMicroPDF417Barcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMicroPDF417Barcode Class : SymbolSize Property
Gets or sets the symbol size of this Micro PDF 417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SymbolSize As MicroPDF417SymbolSize
'Usage

Dim instance As PDFMicroPDF417Barcode
Dim value As MicroPDF417SymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
public MicroPDF417SymbolSize SymbolSize {get; set;}
public: __property MicroPDF417SymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   MicroPDF417SymbolSize value
);
public:
property MicroPDF417SymbolSize SymbolSize {
   MicroPDF417SymbolSize get();
   void set (    MicroPDF417SymbolSize value);
}

Property Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.
Remarks
If the SymbolSize is MicroPDF417SymbolSize.Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMicroPDF417Barcode Class
PDFMicroPDF417Barcode Members


%%PageItemTitle%%

PDFMSIPlesseyBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class
Defines a MSI/Plessey barcode.
Object Model
PDFMSIPlesseyBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMSIPlesseyBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFMSIPlesseyBarcode
public class PDFMSIPlesseyBarcode : PDFUnidimensionalBarcode
public __gc class PDFMSIPlesseyBarcode : public PDFUnidimensionalBarcode
public ref class PDFMSIPlesseyBarcode : public PDFUnidimensionalBarcode
Remarks
MSI/Plessey is a numeric symbology. Only the following symbols are allowed in a MSI/Plessey barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFMSIPlesseyBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

The following tables list the members exposed by PDFMSIPlesseyBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFMSIPlesseyBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMSIPlesseyBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class : PDFMSIPlesseyBarcode Constructor
Overload List
Overload | Description
PDFMSIPlesseyBarcode Constructor() | Initializes a new PDFMSIPlesseyBarcode object.
PDFMSIPlesseyBarcode Constructor(String,Double,Double) | Initializes a new PDFMSIPlesseyBarcode object.
PDFMSIPlesseyBarcode Constructor(String) | Initializes a new PDFMSIPlesseyBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor()
Initializes a new PDFMSIPlesseyBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMSIPlesseyBarcode()
public PDFMSIPlesseyBarcode()
public: PDFMSIPlesseyBarcode();
public:
PDFMSIPlesseyBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFMSIPlesseyBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFMSIPlesseyBarcode(data, left, top)
public PDFMSIPlesseyBarcode(
   string data,
   double left,
   double top
)
public: PDFMSIPlesseyBarcode(
   string* data,
   double left,
   double top
)
public:
PDFMSIPlesseyBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFMSIPlesseyBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFMSIPlesseyBarcode(data)
public PDFMSIPlesseyBarcode(
   string data
)
public: PDFMSIPlesseyBarcode(
   string* data
)
public:
PDFMSIPlesseyBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PDFPharmacodeBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class
Defines a Pharmacode barcode.
Object Model
PDFPharmacodeBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPharmacodeBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFPharmacodeBarcode
public class PDFPharmacodeBarcode : PDFUnidimensionalBarcode
public __gc class PDFPharmacodeBarcode : public PDFUnidimensionalBarcode
public ref class PDFPharmacodeBarcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Pharmacode barcode: 1 2 3 4 5 6 7 8 9 0 and the Data property must represent a number between 3 and 131070.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPharmacodeBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPharmacodeBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

The following tables list the members exposed by PDFPharmacodeBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFPharmacodeBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarSpacing | Gets or sets the space between bars.
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPharmacodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : PDFPharmacodeBarcode Constructor
Overload List
Overload | Description
PDFPharmacodeBarcode Constructor() | Initializes a new PDFPharmacodeBarcode object.
PDFPharmacodeBarcode Constructor(String,Double,Double) | Initializes a new PDFPharmacodeBarcode object.
PDFPharmacodeBarcode Constructor(String) | Initializes a new PDFPharmacodeBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor()
Initializes a new PDFPharmacodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPharmacodeBarcode()
public PDFPharmacodeBarcode()
public: PDFPharmacodeBarcode();
public:
PDFPharmacodeBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPharmacodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFPharmacodeBarcode(data, left, top)
public PDFPharmacodeBarcode(
   string data,
   double left,
   double top
)
public: PDFPharmacodeBarcode(
   string* data,
   double left,
   double top
)
public:
PDFPharmacodeBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFPharmacodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFPharmacodeBarcode(data)
public PDFPharmacodeBarcode(
   string data
)
public: PDFPharmacodeBarcode(
   string* data
)
public:
PDFPharmacodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPharmacodeBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

For a list of all members of this type, see PDFPharmacodeBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarSpacing | Gets or sets the space between bars.
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPharmacodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


BarSpacing Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : BarSpacing Property
Gets or sets the space between bars.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BarSpacing As Double
'Usage

Dim instance As PDFPharmacodeBarcode
Dim value As Double

instance.BarSpacing = value

value = instance.BarSpacing
public double BarSpacing {get; set;}
public: __property double get_BarSpacing();
public: __property void set_BarSpacing(
   double value
);
public:
property double BarSpacing {
   double get();
   void set (    double value);
}

Property Value

The distance between the bars.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


WideToNarrowRatio Property (PDFPharmacodeBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : WideToNarrowRatio Property
Gets or sets the ratio between wide bars and narrow bars.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WideToNarrowRatio As Double
'Usage

Dim instance As PDFPharmacodeBarcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
public double WideToNarrowRatio {get; set;}
public: __property double get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   double value
);
public:
property double WideToNarrowRatio {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the ratio between wide bars and narrow bars.
Remarks
The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


%%PageItemTitle%%

PDFPlanetBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class
Defines a Planet barcode.
Object Model
PDFPlanetBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPlanetBarcode
   Inherits PDFHeightModulatedBarcode
'Usage

Dim instance As PDFPlanetBarcode
public class PDFPlanetBarcode : PDFHeightModulatedBarcode
public __gc class PDFPlanetBarcode : public PDFHeightModulatedBarcode
public ref class PDFPlanetBarcode : public PDFHeightModulatedBarcode
Remarks
The Planet barcode was developed by the United States Postal Service (USPS).
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPlanetBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPlanetBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

The following tables list the members exposed by PDFPlanetBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFPlanetBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPlanetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPlanetBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class : PDFPlanetBarcode Constructor
Overload List
Overload | Description
PDFPlanetBarcode Constructor() | Initializes a new PDFPlanetBarcode object.
PDFPlanetBarcode Constructor(String,Double,Double) | Initializes a new PDFPlanetBarcode object.
PDFPlanetBarcode Constructor(String) | Initializes a new PDFPlanetBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members


%%PageItemTitle%%

PDFPlanetBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor()
Initializes a new PDFPlanetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPlanetBarcode()
public PDFPlanetBarcode()
public: PDFPlanetBarcode();
public:
PDFPlanetBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


%%PageItemTitle%%

PDFPlanetBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPlanetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFPlanetBarcode(data, left, top)
public PDFPlanetBarcode(
   string data,
   double left,
   double top
)
public: PDFPlanetBarcode(
   string* data,
   double left,
   double top
)
public:
PDFPlanetBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


%%PageItemTitle%%

PDFPlanetBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFPlanetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFPlanetBarcode(data)
public PDFPlanetBarcode(
   string data
)
public: PDFPlanetBarcode(
   string* data
)
public:
PDFPlanetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


%%PageItemTitle%%

PDFPostNetBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class
Defines a PostNet barcode.
Object Model
PDFPostNetBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPostNetBarcode
   Inherits PDFHeightModulatedBarcode
'Usage

Dim instance As PDFPostNetBarcode
public class PDFPostNetBarcode : PDFHeightModulatedBarcode
public __gc class PDFPostNetBarcode : public PDFHeightModulatedBarcode
public ref class PDFPostNetBarcode : public PDFHeightModulatedBarcode
Remarks
PostNet was developed by the United States Postal Service (USPS) to allow faster sorting and routing of mail.
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPostNetBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPostNetBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

The following tables list the members exposed by PDFPostNetBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFPostNetBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPostNetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPostNetBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class : PDFPostNetBarcode Constructor
Overload List
Overload | Description
PDFPostNetBarcode Constructor() | Initializes a new PDFPostNetBarcode object.
PDFPostNetBarcode Constructor(String,Double,Double) | Initializes a new PDFPostNetBarcode object.
PDFPostNetBarcode Constructor(String) | Initializes a new PDFPostNetBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members


%%PageItemTitle%%

PDFPostNetBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor()
Initializes a new PDFPostNetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPostNetBarcode()
public PDFPostNetBarcode()
public: PDFPostNetBarcode();
public:
PDFPostNetBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


%%PageItemTitle%%

PDFPostNetBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPostNetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFPostNetBarcode(data, left, top)
public PDFPostNetBarcode(
   string data,
   double left,
   double top
)
public: PDFPostNetBarcode(
   string* data,
   double left,
   double top
)
public:
PDFPostNetBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


%%PageItemTitle%%

PDFPostNetBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFPostNetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFPostNetBarcode(data)
public PDFPostNetBarcode(
   string data
)
public: PDFPostNetBarcode(
   string* data
)
public:
PDFPostNetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


%%PageItemTitle%%

PDFPZNBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class
Defines a PZN barcode.
Object Model
PDFPZNBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPZNBarcode
   Inherits PDFCode39Barcode
'Usage

Dim instance As PDFPZNBarcode
public class PDFPZNBarcode : PDFCode39Barcode
public __gc class PDFPZNBarcode : public PDFCode39Barcode
public ref class PDFPZNBarcode : public PDFCode39Barcode
Remarks
The PZN barcode has a fixed length, 6 digits and only the following symbols are allowed: 1 2 3 4 5 6 7 8 9 0.
PZN (Pharma-Zentral-Nummer) barcodes are used in pharmaceutical industry in Germany.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPZNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPZNBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

The following tables list the members exposed by PDFPZNBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFPZNBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPZNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPZNBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class : PDFPZNBarcode Constructor
Overload List
Overload | Description
PDFPZNBarcode Constructor() | Initializes a new PDFPZNBarcode object.
PDFPZNBarcode Constructor(String,Double,Double) | Initializes a new PDFPZNBarcode object.
PDFPZNBarcode Constructor(String) | Initializes a new PDFPZNBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members


%%PageItemTitle%%

PDFPZNBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor()
Initializes a new PDFPZNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPZNBarcode()
public PDFPZNBarcode()
public: PDFPZNBarcode();
public:
PDFPZNBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


%%PageItemTitle%%

PDFPZNBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPZNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFPZNBarcode(data, left, top)
public PDFPZNBarcode(
   string data,
   double left,
   double top
)
public: PDFPZNBarcode(
   string* data,
   double left,
   double top
)
public:
PDFPZNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


%%PageItemTitle%%

PDFPZNBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFPZNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFPZNBarcode(data)
public PDFPZNBarcode(
   string data
)
public: PDFPZNBarcode(
   string* data
)
public:
PDFPZNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


%%PageItemTitle%%

PDFQRBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFQRBarcode Class
Defines a QR barcode.
Object Model
PDFQRBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFQRBarcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFQRBarcode
public class PDFQRBarcode : PDFBidimensionalBarcode
public __gc class PDFQRBarcode : public PDFBidimensionalBarcode
public ref class PDFQRBarcode : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFQRBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFQRBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFQRBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFQRBarcode Class

The following tables list the members exposed by PDFQRBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFQRBarcode Constructor | Iniitalizes a new PDFQRBarcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CharacterSet | Gets or sets the character set.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFQRBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFQRBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFQRBarcode Class : PDFQRBarcode Constructor
Iniitalizes a new PDFQRBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFQRBarcode()
public PDFQRBarcode()
public: PDFQRBarcode();
public:
PDFQRBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFQRBarcode Class
PDFQRBarcode Members


%%PageItemTitle%% $$Properties$$

PDFQRBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFQRBarcode Class

For a list of all members of this type, see PDFQRBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CharacterSet | Gets or sets the character set.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFQRBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


CharacterSet Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFQRBarcode Class : CharacterSet Property
Gets or sets the character set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CharacterSet As QRCharacterSet
'Usage

Dim instance As PDFQRBarcode
Dim value As QRCharacterSet

instance.CharacterSet = value

value = instance.CharacterSet
public QRCharacterSet CharacterSet {get; set;}
public: __property QRCharacterSet get_CharacterSet();
public: __property void set_CharacterSet(
   QRCharacterSet value
);
public:
property QRCharacterSet CharacterSet {
   QRCharacterSet get();
   void set (    QRCharacterSet value);
}

Property Value

The character set used to encode the barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFQRBarcode Class
PDFQRBarcode Members


ErrorCorrectionLevel Property (PDFQRBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFQRBarcode Class : ErrorCorrectionLevel Property
Gets or sets the error correction level.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ErrorCorrectionLevel As QRErrorCorrectionLevel
'Usage

Dim instance As PDFQRBarcode
Dim value As QRErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
public QRErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
public: __property QRErrorCorrectionLevel get_ErrorCorrectionLevel();
public: __property void set_ErrorCorrectionLevel(
   QRErrorCorrectionLevel value
);
public:
property QRErrorCorrectionLevel ErrorCorrectionLevel {
   QRErrorCorrectionLevel get();
   void set (    QRErrorCorrectionLevel value);
}

Property Value

The error correction level for the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFQRBarcode Class
PDFQRBarcode Members


%%PageItemTitle%%

PDFRM4SCCBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class
Defines a RM4SCC barcode.
Object Model
PDFRM4SCCBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRM4SCCBarcode
   Inherits PDFHeightModulatedBarcode
'Usage

Dim instance As PDFRM4SCCBarcode
public class PDFRM4SCCBarcode : PDFHeightModulatedBarcode
public __gc class PDFRM4SCCBarcode : public PDFHeightModulatedBarcode
public ref class PDFRM4SCCBarcode : public PDFHeightModulatedBarcode
Remarks
The Royal Mail 4-state Customer Code (RM4SCC) is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a RM4SCC barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFKixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSingaporePostBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFRM4SCCBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

The following tables list the members exposed by PDFRM4SCCBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFRM4SCCBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFRM4SCCBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class : PDFRM4SCCBarcode Constructor
Overload List
Overload | Description
PDFRM4SCCBarcode Constructor() | Initializes a new PDFRM4SCCBarcode object.
PDFRM4SCCBarcode Constructor(String,Double,Double) | Initializes a new PDFRM4SCCBarcode object.
PDFRM4SCCBarcode Constructor(String) | Initializes a new PDFRM4SCCBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor()
Initializes a new PDFRM4SCCBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRM4SCCBarcode()
public PDFRM4SCCBarcode()
public: PDFRM4SCCBarcode();
public:
PDFRM4SCCBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFRM4SCCBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFRM4SCCBarcode(data, left, top)
public PDFRM4SCCBarcode(
   string data,
   double left,
   double top
)
public: PDFRM4SCCBarcode(
   string* data,
   double left,
   double top
)
public:
PDFRM4SCCBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFRM4SCCBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFRM4SCCBarcode(data)
public PDFRM4SCCBarcode(
   string data
)
public: PDFRM4SCCBarcode(
   string* data
)
public:
PDFRM4SCCBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


%%PageItemTitle%%

PDFSCC14Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class
Defines a SCC-14 barcode.
Object Model
PDFSCC14Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSCC14Barcode
   Inherits PDFCode128CBarcode
'Usage

Dim instance As PDFSCC14Barcode
public class PDFSCC14Barcode : PDFCode128CBarcode
public __gc class PDFSCC14Barcode : public PDFCode128CBarcode
public ref class PDFSCC14Barcode : public PDFCode128CBarcode
Remarks
This class defines a SCC-14 (Shipping Container Code) barcode. Only the following symbols are allowed in a SCC-14 barcode: 0 1 2 3 4 5 6 7 8 9.
A SCC-14 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 14 digits. 13 digits are provided by the user, the 14th digit is the check digit and it is calculated automatically by the library.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSCC14Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFSCC14Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

The following tables list the members exposed by PDFSCC14Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFSCC14Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSCC14Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFSCC14Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class : PDFSCC14Barcode Constructor
Overload List
Overload | Description
PDFSCC14Barcode Constructor() | Initializes a new PDFSCC14Barcode object.
PDFSCC14Barcode Constructor(String,Double,Double) | Initializes a new PDFSCC14Barcode object.
PDFSCC14Barcode Constructor(String) | Initializes a new PDFSCC14Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members


%%PageItemTitle%%

PDFSCC14Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor()
Initializes a new PDFSCC14Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSCC14Barcode()
public PDFSCC14Barcode()
public: PDFSCC14Barcode();
public:
PDFSCC14Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


%%PageItemTitle%%

PDFSCC14Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSCC14Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFSCC14Barcode(data, left, top)
public PDFSCC14Barcode(
   string data,
   double left,
   double top
)
public: PDFSCC14Barcode(
   string* data,
   double left,
   double top
)
public:
PDFSCC14Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


%%PageItemTitle%%

PDFSCC14Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFSCC14Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFSCC14Barcode(data)
public PDFSCC14Barcode(
   string data
)
public: PDFSCC14Barcode(
   string* data
)
public:
PDFSCC14Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


%%PageItemTitle%%

PDFSingaporePostBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class
Defines a Singapore Post barcode.
Object Model
PDFSingaporePostBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSingaporePostBarcode
   Inherits PDFRM4SCCBarcode
'Usage

Dim instance As PDFSingaporePostBarcode
public class PDFSingaporePostBarcode : PDFRM4SCCBarcode
public __gc class PDFSingaporePostBarcode : public PDFRM4SCCBarcode
public ref class PDFSingaporePostBarcode : public PDFRM4SCCBarcode
Remarks
The Singapore Post barcode is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a Singapore Post barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSingaporePostBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFSingaporePostBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

The following tables list the members exposed by PDFSingaporePostBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFSingaporePostBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSingaporePostBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class : PDFSingaporePostBarcode Constructor
Overload List
Overload | Description
PDFSingaporePostBarcode Constructor() | Initializes a new PDFSingaporePostBarcode object.
PDFSingaporePostBarcode Constructor(String,Double,Double) | Initializes a new PDFSingaporePostBarcode object.
PDFSingaporePostBarcode Constructor(String) | Initializes a new PDFSingaporePostBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor()
Initializes a new PDFSingaporePostBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSingaporePostBarcode()
public PDFSingaporePostBarcode()
public: PDFSingaporePostBarcode();
public:
PDFSingaporePostBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSingaporePostBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFSingaporePostBarcode(data, left, top)
public PDFSingaporePostBarcode(
   string data,
   double left,
   double top
)
public: PDFSingaporePostBarcode(
   string* data,
   double left,
   double top
)
public:
PDFSingaporePostBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFSingaporePostBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFSingaporePostBarcode(data)
public PDFSingaporePostBarcode(
   string data
)
public: PDFSingaporePostBarcode(
   string* data
)
public:
PDFSingaporePostBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PDFSSCC18Barcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class
Defines a SSCC-18 barcode.
Object Model
PDFSSCC18Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSSCC18Barcode
   Inherits PDFCode128CBarcode
'Usage

Dim instance As PDFSSCC18Barcode
public class PDFSSCC18Barcode : PDFCode128CBarcode
public __gc class PDFSSCC18Barcode : public PDFCode128CBarcode
public ref class PDFSSCC18Barcode : public PDFCode128CBarcode
Remarks
This class defines a SSCC-18 (Serial Shipping Container Code) barcode. Only the following symbols are allowed in a SSCC-18 barcode: 0 1 2 3 4 5 6 7 8 9.
A SSCC-18 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 18 digits. 17 digits are provided by the user, the 18th digit is the check digit and it is calculated automatically by the library.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSSCC18Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFSSCC18Barcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

The following tables list the members exposed by PDFSSCC18Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFSSCC18Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSSCC18Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFSSCC18Barcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class : PDFSSCC18Barcode Constructor
Overload List
Overload | Description
PDFSSCC18Barcode Constructor() | Initializes a new PDFSSCC18Barcode object.
PDFSSCC18Barcode Constructor(String,Double,Double) | Initializes a new PDFSSCC18Barcode object.
PDFSSCC18Barcode Constructor(String) | Initializes a new PDFSSCC18Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members


%%PageItemTitle%%

PDFSSCC18Barcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor()
Initializes a new PDFSSCC18Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSSCC18Barcode()
public PDFSSCC18Barcode()
public: PDFSSCC18Barcode();
public:
PDFSSCC18Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


%%PageItemTitle%%

PDFSSCC18Barcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSSCC18Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFSSCC18Barcode(data, left, top)
public PDFSSCC18Barcode(
   string data,
   double left,
   double top
)
public: PDFSSCC18Barcode(
   string* data,
   double left,
   double top
)
public:
PDFSSCC18Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


%%PageItemTitle%%

PDFSSCC18Barcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFSSCC18Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFSSCC18Barcode(data)
public PDFSSCC18Barcode(
   string data
)
public: PDFSSCC18Barcode(
   string* data
)
public:
PDFSSCC18Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


%%PageItemTitle%%

PDFUnidimensionalBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class
Defines the base class for 1D barcodes.
Object Model
PDFUnidimensionalBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFUnidimensionalBarcode
   Inherits PDFBarcode
'Usage

Dim instance As PDFUnidimensionalBarcode
public abstract class PDFUnidimensionalBarcode : PDFBarcode
public __gc abstract class PDFUnidimensionalBarcode : public PDFBarcode
public ref class PDFUnidimensionalBarcode abstract : public PDFBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodabarBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode11Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPharmacodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSFIMBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUnidimensionalBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

The following tables list the members exposed by PDFUnidimensionalBarcode.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form.
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUnidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUnidimensionalBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

For a list of all members of this type, see PDFUnidimensionalBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form.
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUnidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


BarWidthReduction Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : BarWidthReduction Property
Gets or sets the bar width reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BarWidthReduction As Double
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As Double

instance.BarWidthReduction = value

value = instance.BarWidthReduction
public double BarWidthReduction {get; set;}
public: __property double get_BarWidthReduction();
public: __property void set_BarWidthReduction(
   double value
);
public:
property double BarWidthReduction {
   double get();
   void set (    double value);
}

Property Value

A value used for reducing the bar width (not the space width) in order to compensate for ink bleeding when printing the barcode on various surfaces.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


DataDisplayLocation Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DataDisplayLocation Property
Gets or sets the location of the barcode data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DataDisplayLocation As BarcodeTextLocation
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
public BarcodeTextLocation DataDisplayLocation {get; set;}
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (    BarcodeTextLocation value);
}

Property Value

A BarcodeTextLocation enumeration member specifying the location where the barcode data is displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


DisplayCheckSum Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DisplayCheckSum Property
Gets or sets whether the check characters should be displayed in human readable form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayCheckSum As Boolean
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
public bool DisplayCheckSum {get; set;}
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
public:
property bool DisplayCheckSum {
   bool get();
   void set (    bool value);
}

Property Value

True if the check characters should be displayed. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


DisplayStartStopSymbols Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DisplayStartStopSymbols Property
Gets or sets a value indicating whether the start/stop symbols should be displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayStartStopSymbols As Boolean
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.DisplayStartStopSymbols = value

value = instance.DisplayStartStopSymbols
public bool DisplayStartStopSymbols {get; set;}
public: __property bool get_DisplayStartStopSymbols();
public: __property void set_DisplayStartStopSymbols(
   bool value
);
public:
property bool DisplayStartStopSymbols {
   bool get();
   void set (    bool value);
}

Property Value

True if the start/stop symbol should be displayed. Default is true.
Remarks
Hiding the start/stop symbols can generate unreadable barcodes in some situations, unless you have specialized barcode readers that are aware of missing start/stop symbols.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


EnableCheckSum Property

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : EnableCheckSum Property
Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnableCheckSum As Boolean
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
public bool EnableCheckSum {get; set;}
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
public:
property bool EnableCheckSum {
   bool get();
   void set (    bool value);
}

Property Value

True if a checksum symbol should be appended automatically to the barcode, false otherwise.
Remarks
Not all barcodes support checksum symbols. This property is ignored for those that do not support them.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


Font Property (PDFUnidimensionalBarcode)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : Font Property
Gets or sets the font used to display the barcode text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Font As PDFFontBase
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
public PDFFontBase Font {get; set;}
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (    PDFFontBase^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.Fonts.PDFFont object used to display the barcode text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%PageItemTitle%%

PDFUPCABarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class
Defines the class for UPC-A barcodes.
Object Model
PDFUPCABarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUPCABarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFUPCABarcode
public class PDFUPCABarcode : PDFEANBarcode
public __gc class PDFUPCABarcode : public PDFEANBarcode
public ref class PDFUPCABarcode : public PDFEANBarcode
Remarks
UPC-A symbology is a numeric symbology. Only the following symbols are allowed in an UPC-A barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-A barcode must always have 11 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCABarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUPCABarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

The following tables list the members exposed by PDFUPCABarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUPCABarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUPCABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUPCABarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class : PDFUPCABarcode Constructor
Overload List
Overload | Description
PDFUPCABarcode Constructor() | Initializes a new PDFUPCABarcode object.
PDFUPCABarcode Constructor(String,Double,Double) | Initializes a new PDFUPCABarcode object.
PDFUPCABarcode Constructor(String) | Initializes a new PDFUPCABarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members


%%PageItemTitle%%

PDFUPCABarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor()
Initializes a new PDFUPCABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUPCABarcode()
public PDFUPCABarcode()
public: PDFUPCABarcode();
public:
PDFUPCABarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


%%PageItemTitle%%

PDFUPCABarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUPCABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUPCABarcode(data, left, top)
public PDFUPCABarcode(
   string data,
   double left,
   double top
)
public: PDFUPCABarcode(
   string* data,
   double left,
   double top
)
public:
PDFUPCABarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


%%PageItemTitle%%

PDFUPCABarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUPCABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUPCABarcode(data)
public PDFUPCABarcode(
   string data
)
public: PDFUPCABarcode(
   string* data
)
public:
PDFUPCABarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


%%PageItemTitle%%

PDFUPCEBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class
Defines the class for UPC-E barcodes.
Object Model
PDFUPCEBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUPCEBarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFUPCEBarcode
public class PDFUPCEBarcode : PDFEANBarcode
public __gc class PDFUPCEBarcode : public PDFEANBarcode
public ref class PDFUPCEBarcode : public PDFEANBarcode
Remarks
UPC-E symbology is a numeric symbology. Only the following symbols are allowed in an UPC-E barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-E barcode must always have 7 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCEBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUPCEBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

The following tables list the members exposed by PDFUPCEBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUPCEBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUPCEBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUPCEBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class : PDFUPCEBarcode Constructor
Overload List
Overload | Description
PDFUPCEBarcode Constructor() | Initializes a new PDFUPCEBarcode object.
PDFUPCEBarcode Constructor(String,Double,Double) | Initializes a new PDFUPCEBarcode object.
PDFUPCEBarcode Constructor(String) | Initializes a new PDFUPCEBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members


%%PageItemTitle%%

PDFUPCEBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor()
Initializes a new PDFUPCEBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUPCEBarcode()
public PDFUPCEBarcode()
public: PDFUPCEBarcode();
public:
PDFUPCEBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


%%PageItemTitle%%

PDFUPCEBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUPCEBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUPCEBarcode(data, left, top)
public PDFUPCEBarcode(
   string data,
   double left,
   double top
)
public: PDFUPCEBarcode(
   string* data,
   double left,
   double top
)
public:
PDFUPCEBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


%%PageItemTitle%%

PDFUPCEBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUPCEBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUPCEBarcode(data)
public PDFUPCEBarcode(
   string data
)
public: PDFUPCEBarcode(
   string* data
)
public:
PDFUPCEBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSFIMBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class
Defines a USPS FIM barcode.
Object Model
PDFUSPSFIMBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUSPSFIMBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFUSPSFIMBarcode
public class PDFUSPSFIMBarcode : PDFUnidimensionalBarcode
public __gc class PDFUSPSFIMBarcode : public PDFUnidimensionalBarcode
public ref class PDFUSPSFIMBarcode : public PDFUnidimensionalBarcode
Remarks
The Facing Identification Mark, or FIM, is a bar code designed by the United States Postal Service to assist in the automated processing of mail. The FIM is a set of vertical bars printed on the envelope or postcard near the upper edge, just to the left of the postage area (the area where the postage stamp or its equivalent is placed). The FIM is intended for use primarily on preprinted envelopes and postcards and is applied by the company printing the envelopes or postcards, not by the USPS.
FIM barcodes support only 4 data strings: "A", "B", "C", and "D", one string for each FIM barcode.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSFIMBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUSPSFIMBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

The following tables list the members exposed by PDFUSPSFIMBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUSPSFIMBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSFIMBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class : PDFUSPSFIMBarcode Constructor
Overload List
Overload | Description
PDFUSPSFIMBarcode Constructor() | Initializes a new PDFUSPSFIMBarcode object.
PDFUSPSFIMBarcode Constructor(String,Double,Double) | Initializes a new PDFUSPSFIMBarcode object.
PDFUSPSFIMBarcode Constructor(String) | Initializes a new PDFUSPSFIMBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor()
Initializes a new PDFUSPSFIMBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUSPSFIMBarcode()
public PDFUSPSFIMBarcode()
public: PDFUSPSFIMBarcode();
public:
PDFUSPSFIMBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSFIMBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUSPSFIMBarcode(data, left, top)
public PDFUSPSFIMBarcode(
   string data,
   double left,
   double top
)
public: PDFUSPSFIMBarcode(
   string* data,
   double left,
   double top
)
public:
PDFUSPSFIMBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUSPSFIMBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUSPSFIMBarcode(data)
public PDFUSPSFIMBarcode(
   string data
)
public: PDFUSPSFIMBarcode(
   string* data
)
public:
PDFUSPSFIMBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class
Defines a horizontal bars barcode.
Object Model
PDFUSPSHorizontalBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUSPSHorizontalBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFUSPSHorizontalBarcode
public class PDFUSPSHorizontalBarcode : PDFUnidimensionalBarcode
public __gc class PDFUSPSHorizontalBarcode : public PDFUnidimensionalBarcode
public ref class PDFUSPSHorizontalBarcode : public PDFUnidimensionalBarcode
Remarks
This type of barcode is used by USPS to identify mailings as business reply mail. The Data property is a string of "1", each digit corresponding to a bar.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUSPSHorizontalBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

The following tables list the members exposed by PDFUSPSHorizontalBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUSPSHorizontalBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSHorizontalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class : PDFUSPSHorizontalBarcode Constructor
Overload List
Overload | Description
PDFUSPSHorizontalBarcode Constructor() | Initializes a new PDFUSPSHorizontalBarcode object.
PDFUSPSHorizontalBarcode Constructor(String) | Initializes a new PDFUSPSHorizontalBarcode object.
PDFUSPSHorizontalBarcode Constructor(String,Double,Double) | Initializes a new PDFUSPSHorizontalBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor()
Initializes a new PDFUSPSHorizontalBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUSPSHorizontalBarcode()
public PDFUSPSHorizontalBarcode()
public: PDFUSPSHorizontalBarcode();
public:
PDFUSPSHorizontalBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUSPSHorizontalBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUSPSHorizontalBarcode(data)
public PDFUSPSHorizontalBarcode(
   string data
)
public: PDFUSPSHorizontalBarcode(
   string* data
)
public:
PDFUSPSHorizontalBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSHorizontalBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUSPSHorizontalBarcode(data, left, top)
public PDFUSPSHorizontalBarcode(
   string data,
   double left,
   double top
)
public: PDFUSPSHorizontalBarcode(
   string* data,
   double left,
   double top
)
public:
PDFUSPSHorizontalBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSPICBarcode Class
Members

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class
Defines a USPS Package Identification Code barcode.
Object Model
PDFUSPSPICBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUSPSPICBarcode
   Inherits PDFCode128CBarcode
'Usage

Dim instance As PDFUSPSPICBarcode
public class PDFUSPSPICBarcode : PDFCode128CBarcode
public __gc class PDFUSPSPICBarcode : public PDFCode128CBarcode
public ref class PDFUSPSPICBarcode : public PDFCode128CBarcode
Remarks
Only the following symbols are allowed in the barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 21 digits for standard barcode (the first 2 digits are always 91) or 29 digits for concatenated barcode (the first 3 digits are always 420).
The structure of a USPS PIC standard barcode is as follows:
1 - 2 - Application Identifier (91)
3 - 4 - Service Type Code (STC)
5 - 13 - Customer ID: DUNS number that uniquely identifies the customer
14 - 21 - Package Sequence Number (PSN)
The structure of a USPS PIC concatenated barcode is as follows:
1 - 3 - Routing Application Identifier (420)
4 - 8 - 5-digit ZIP code
9 - 10 - Application Identifier (91)
11 - 12 - Service Type Code (STC)
13 - 21 - Customer ID: DUNS number that uniquely identifies the customer
22 - 29 - Package Sequence Number (PSN)
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSPICBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUSPSPICBarcode Class Members
Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

The following tables list the members exposed by PDFUSPSPICBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUSPSPICBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSPICBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class : PDFUSPSPICBarcode Constructor
Overload List
Overload | Description
PDFUSPSPICBarcode Constructor() | Initializes a new PDFUSPSPICBarcode object.
PDFUSPSPICBarcode Constructor(String,Double,Double) | Initializes a new PDFUSPSPICBarcode object.
PDFUSPSPICBarcode Constructor(String) | Initializes a new PDFUSPSPICBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor()

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor()
Initializes a new PDFUSPSPICBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUSPSPICBarcode()
public PDFUSPSPICBarcode()
public: PDFUSPSPICBarcode();
public:
PDFUSPSPICBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor(String,Double,Double)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSPICBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUSPSPICBarcode(data, left, top)
public PDFUSPSPICBarcode(
   string data,
   double left,
   double top
)
public: PDFUSPSPICBarcode(
   string* data,
   double left,
   double top
)
public:
PDFUSPSPICBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor(String)

O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUSPSPICBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUSPSPICBarcode(data)
public PDFUSPSPICBarcode(
   string data
)
public: PDFUSPSPICBarcode(
   string* data
)
public:
PDFUSPSPICBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


%%PageItemTitle%%

BarcodeTextLocation Enumeration

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeTextLocation Enumeration
Specifies the available locations for displaying text on a linear barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum BarcodeTextLocation
   Inherits System.Enum
'Usage

Dim instance As BarcodeTextLocation
public enum BarcodeTextLocation : System.Enum
__value public enum BarcodeTextLocation : public System.Enum
public enum class BarcodeTextLocation : public System.Enum
Members
Member | Description
Above | Barcode text is placed above the bar code.
AboveEmbedded | Barcode text is partially embedded at the top of the bar code. The top of the text is aligned with the top of the bars.
Below | Barcode text is placed below the bar code.
BelowEmbedded | Barcode text is partially embedded in the bottom of the bar code. The baseline of the text is aligned with the bottom of the bars.
None | Barcode text is not displayed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.BarcodeTextLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

DataMatrixEncoding Enumeration

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : DataMatrixEncoding Enumeration
Specifies the available encoding modes for a DataMatrix barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DataMatrixEncoding
   Inherits System.Enum
'Usage

Dim instance As DataMatrixEncoding
public enum DataMatrixEncoding : System.Enum
__value public enum DataMatrixEncoding : public System.Enum
public enum class DataMatrixEncoding : public System.Enum
Members
Member | Description
ASCII | The data to encode contains ASCII characters only (0x00 - 0x7F). Extended ASCII characters (0x80 - 0xFF) are also supported.
Auto | The encoding is determined automatically based on the data to encode.
Base256 | The data to encode is a binary stream.
Numeric | The data to encode contains only numbers (ASCII characters 0x30 - 0x39)
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.DataMatrixEncoding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

DataMatrixSymbolSize Enumeration

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : DataMatrixSymbolSize Enumeration
Specifies the available sizes for a DataMatrix symbol.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DataMatrixSymbolSize
   Inherits System.Enum
'Usage

Dim instance As DataMatrixSymbolSize
public enum DataMatrixSymbolSize : System.Enum
__value public enum DataMatrixSymbolSize : public System.Enum
public enum class DataMatrixSymbolSize : public System.Enum
Members
Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size104x104 | Square DataMatrix symbol with 104 rows and 104 columns.
Size10x10 | Square DataMatrix symbol with 10 rows and 10 columns.
Size120x120 | Square DataMatrix symbol with 120 rows and 120 columns.
Size12x12 | Square DataMatrix symbol with 12 rows and 12 columns.
Size12x26 | Rectangular DataMatrix symbol with 12 rows and 26 columns.
Size12x36 | Rectangular DataMatrix symbol with 12 rows and 36 columns.
Size132x132 | Square DataMatrix symbol with 132 rows and 132 columns.
Size144x144 | Square DataMatrix symbol with 144 rows and 144 columns.
Size14x14 | Square DataMatrix symbol with 14 rows and 14 columns.
Size16x16 | Square DataMatrix symbol with 16 rows and 16 columns.
Size16x36 | Rectangular DataMatrix symbol with 16 rows and 36 columns.
Size16x48 | Rectangular DataMatrix symbol with 16 rows and 48 columns.
Size18x18 | Square DataMatrix symbol with 18 rows and 18 columns.
Size20x20 | Square DataMatrix symbol with 20 rows and 20 columns.
Size22x22 | Square DataMatrix symbol with 22 rows and 22 columns.
Size24x24 | Square DataMatrix symbol with 24 rows and 24 columns.
Size26x26 | Square DataMatrix symbol with 26 rows and 26 columns.
Size32x32 | Square DataMatrix symbol with 32 rows and 32 columns.
Size36x36 | Square DataMatrix symbol with 36 rows and 36 columns.
Size40x40 | Square DataMatrix symbol with 40 rows and 40 columns.
Size44x44 | Square DataMatrix symbol with 44 rows and 44 columns.
Size48x48 | Square DataMatrix symbol with 48 rows and 48 columns.
Size52x52 | Square DataMatrix symbol with 52 rows and 52 columns.
Size64x64 | Square DataMatrix symbol with 64 rows and 64 columns.
Size72x72 | Square DataMatrix symbol with 72 rows and 72 columns.
Size80x80 | Square DataMatrix symbol with 80 rows and 80 columns.
Size88x88 | Square DataMatrix symbol with 88 rows and 88 columns.
Size8x18 | Rectangular DataMatrix symbol with 8 rows and 18 columns.
Size8x32 | Rectangular DataMatrix symbol with 8 rows and 32 columns.
Size96x96 | Square DataMatrix symbol with 96 rows and 96 columns.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.DataMatrixSymbolSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

MicroPDF417SymbolSize Enumeration

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : MicroPDF417SymbolSize Enumeration
Specifies the available sizes for a Micro PDF417 symbol.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MicroPDF417SymbolSize
   Inherits System.Enum
'Usage

Dim instance As MicroPDF417SymbolSize
public enum MicroPDF417SymbolSize : System.Enum
__value public enum MicroPDF417SymbolSize : public System.Enum
public enum class MicroPDF417SymbolSize : public System.Enum
Members
Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size10x3 | Micro PDF417 symbol with 10 rows and 3 columns.
Size10x4 | Micro PDF417 symbol with 10 rows and 4 columns.
Size11x1 | Micro PDF417 symbol with 11 rows and 1 column.
Size11x2 | Micro PDF417 symbol with 11 rows and 2 columns.
Size12x3 | Micro PDF417 symbol with 12 rows and 3 columns.
Size12x4 | Micro PDF417 symbol with 12 rows and 4 columns.
Size14x1 | Micro PDF417 symbol with 14 rows and 1 column.
Size14x2 | Micro PDF417 symbol with 14 rows and 2 columns.
Size15x3 | Micro PDF417 symbol with 15 rows and 3 columns.
Size15x4 | Micro PDF417 symbol with 15 rows and 4 columns.
Size17x1 | Micro PDF417 symbol with 17 rows and 1 column.
Size17x2 | Micro PDF417 symbol with 17 rows and 2 columns.
Size20x1 | Micro PDF417 symbol with 20 rows and 1 column.
Size20x2 | Micro PDF417 symbol with 20 rows and 2 columns.
Size20x3 | Micro PDF417 symbol with 20 rows and 3 columns.
Size20x4 | Micro PDF417 symbol with 20 rows and 4 columns.
Size23x2 | Micro PDF417 symbol with 23 rows and 2 columns.
Size24x1 | Micro PDF417 symbol with 24 rows and 1 column.
Size26x2 | Micro PDF417 symbol with 26 rows and 2 columns.
Size26x3 | Micro PDF417 symbol with 26 rows and 3 columns.
Size26x4 | Micro PDF417 symbol with 26 rows and 4 columns.
Size28x1 | Micro PDF417 symbol with 28 rows and 1 column.
Size32x3 | Micro PDF417 symbol with 32 rows and 3 columns.
Size32x4 | Micro PDF417 symbol with 32 rows and 4 columns.
Size38x3 | Micro PDF417 symbol with 38 rows and 3 columns.
Size38x4 | Micro PDF417 symbol with 38 rows and 4 columns.
Size44x3 | Micro PDF417 symbol with 44 rows and 3 columns.
Size44x4 | Micro PDF417 symbol with 44 rows and 4 columns.
Size4x4 | Micro PDF417 symbol with 4 rows and 4 columns.
Size6x3 | Micro PDF417 symbol with 6 rows and 3 columns.
Size6x4 | Micro PDF417 symbol with 6 rows and 4 columns.
Size8x2 | Micro PDF417 symbol with 8 rows and 2 columns.
Size8x3 | Micro PDF417 symbol with 8 rows and 3 columns.
Size8x4 | Micro PDF417 symbol with 8 rows and 4 columns.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.MicroPDF417SymbolSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDF417DataCompactionMode Enumeration

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417DataCompactionMode Enumeration
Specifies the available data compaction modes for a PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF417DataCompactionMode
   Inherits System.Enum
'Usage

Dim instance As PDF417DataCompactionMode
public enum PDF417DataCompactionMode : System.Enum
__value public enum PDF417DataCompactionMode : public System.Enum
public enum class PDF417DataCompactionMode : public System.Enum
Members
Member | Description
Byte | Binary compaction mode.
Numeric | Numeric compaction mode.
Text | Text compaction mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417DataCompactionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDF417ErrorCorrectionLevel Enumeration

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417ErrorCorrectionLevel Enumeration
Specifies the available error correction levels for a PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF417ErrorCorrectionLevel
   Inherits System.Enum
'Usage

Dim instance As PDF417ErrorCorrectionLevel
public enum PDF417ErrorCorrectionLevel : System.Enum
__value public enum PDF417ErrorCorrectionLevel : public System.Enum
public enum class PDF417ErrorCorrectionLevel : public System.Enum
Members
Member | Description
Level0 | Level 0 - 2 error correction codewords.
Level1 | Level 1 - 4 error correction codewords.
Level2 | Level 2 - 8 error correction codewords.
Level3 | Level 3 - 16 error correction codewords.
Level4 | Level 4 - 32 error correction codewords.
Level5 | Level 5 - 64 error correction codewords.
Level6 | Level 6 - 128 error correction codewords.
Level7 | Level 7 - 256 error correction codewords.
Level8 | Level 8 - 512 error correction codewords.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417ErrorCorrectionLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

QRCharacterSet Enumeration

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : QRCharacterSet Enumeration
Supported character sets.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum QRCharacterSet
   Inherits System.Enum
'Usage

Dim instance As QRCharacterSet
public enum QRCharacterSet : System.Enum
__value public enum QRCharacterSet : public System.Enum
public enum class QRCharacterSet : public System.Enum
Members
Member | Description
Cp437 | CP437 character set.
ISO8859_1 | ISO-8859-1 character set.
ISO8859_2 | ISO-8859-2 character set.
ISO8859_3 | ISO-8859-3 character set.
ISO8859_4 | ISO-8859-4 character set.
ISO8859_5 | ISO-8859-5 character set.
ISO8859_6 | ISO-8859-6 character set.
ISO8859_7 | ISO-8859-7 character set.
ISO8859_8 | ISO-8859-8 character set.
ISO8859_9 | ISO-8859-9 character set.
ShiftJIS | Shift JIS character set.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.QRCharacterSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

QRErrorCorrectionLevel Enumeration

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : QRErrorCorrectionLevel Enumeration
Supported error correction levels for QR barcodes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum QRErrorCorrectionLevel
   Inherits System.Enum
'Usage

Dim instance As QRErrorCorrectionLevel
public enum QRErrorCorrectionLevel : System.Enum
__value public enum QRErrorCorrectionLevel : public System.Enum
public enum class QRErrorCorrectionLevel : public System.Enum
Members
Member | Description
H | H error correction level.
L | L error correction level.
M | M error correction level.
Q | Q error correction level.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.QRErrorCorrectionLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFCalGrayColorSpace | Defines a CalGray colorspace.
Class | PDFCalRgbColorSpace | Defines a CalRGB colorspace.
Class | PDFColorSpace | Defines the base class for all colorspaces.
Class | PDFColorSpaceCollection | Defines a collection of colorspaces.
Class | PDFDeviceColorSpace | Defines a device colorspace.
Class | PDFDeviceNAttributes | Defines the attributes for the DeviceN colorspace.
Class | PDFDeviceNColorants |
Class | PDFDeviceNColorNameCollection | Defines a collection of PDF actions.
Class | PDFDeviceNColorSpace | Defines a DeviceN colorspace.
Class | PDFICCColorSpace | Defines an ICC based colorspace.
Class | PDFIndexedColorSpace | Defines an indexed colorspace.
Class | PDFLabColorSpace | Defines a Lab colorspace.
Class | PDFPantoneColor | Defines a PANTONE color.
Class | PDFPatternColorSpace | Defines a pattern colorspace.
Class | PDFSeparationColorSpace | Defines a separation colorspace.
Enumerations
 | Enumeration | Description
Enumeration | PDFColorSpaceType | Defines the available colorspace types.
Enumeration | PDFDeviceColorSpaceType | Defines the available device colorspace types.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFCalGrayColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class
Defines a CalGray colorspace.
Object Model
PDFCalGrayColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCalGrayColorSpace
   Inherits PDFColorSpace
'Usage

Dim instance As PDFCalGrayColorSpace
public class PDFCalGrayColorSpace : PDFColorSpace
public __gc class PDFCalGrayColorSpace : public PDFColorSpace
public ref class PDFCalGrayColorSpace : public PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFCalGrayColorSpace Class Members
Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class

The following tables list the members exposed by PDFCalGrayColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PDFCalGrayColorSpace Constructor | Initializes a new PDFCalGrayColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PDFCalGrayColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFCalGrayColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : PDFCalGrayColorSpace Constructor
Initializes a new PDFCalGrayColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCalGrayColorSpace()
public PDFCalGrayColorSpace()
public: PDFCalGrayColorSpace();
public:
PDFCalGrayColorSpace();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFCalGrayColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class

For a list of all members of this type, see PDFCalGrayColorSpace members.

Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PDFCalGrayColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


BlackPoint Property (PDFCalGrayColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : BlackPoint Property
Gets or sets the black point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlackPoint As Double()
'Usage

Dim instance As PDFCalGrayColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
public double[] BlackPoint {get; set;}
public: __property double[]* get_BlackPoint();
public: __property void set_BlackPoint(
   double[]* value
);
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


Gamma Property (PDFCalGrayColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : Gamma Property
Gets or sets the gamma.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Gamma As Double
'Usage

Dim instance As PDFCalGrayColorSpace
Dim value As Double

instance.Gamma = value

value = instance.Gamma
public double Gamma {get; set;}
public: __property double get_Gamma();
public: __property void set_Gamma(
   double value
);
public:
property double Gamma {
   double get();
   void set (    double value);
}

Property Value

The gamma value for the gray component.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


WhitePoint Property (PDFCalGrayColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : WhitePoint Property
Gets or sets the white point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WhitePoint As Double()
'Usage

Dim instance As PDFCalGrayColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
public double[] WhitePoint {get; set;}
public: __property double[]* get_WhitePoint();
public: __property void set_WhitePoint(
   double[]* value
);
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


%%PageItemTitle%%

PDFCalRgbColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class
Defines a CalRGB colorspace.
Object Model
PDFCalRgbColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCalRgbColorSpace
   Inherits PDFColorSpace
'Usage

Dim instance As PDFCalRgbColorSpace
public class PDFCalRgbColorSpace : PDFColorSpace
public __gc class PDFCalRgbColorSpace : public PDFColorSpace
public ref class PDFCalRgbColorSpace : public PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFCalRgbColorSpace Class Members
Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class

The following tables list the members exposed by PDFCalRgbColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PDFCalRgbColorSpace Constructor | Initializes a new PDFCalRgbColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Matrix | Gets or sets the colorspace transformation matrix.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PDFCalRgbColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFCalRgbColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : PDFCalRgbColorSpace Constructor
Initializes a new PDFCalRgbColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCalRgbColorSpace()
public PDFCalRgbColorSpace()
public: PDFCalRgbColorSpace();
public:
PDFCalRgbColorSpace();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFCalRgbColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class

For a list of all members of this type, see PDFCalRgbColorSpace members.

Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Matrix | Gets or sets the colorspace transformation matrix.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PDFCalRgbColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


BlackPoint Property (PDFCalRgbColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : BlackPoint Property
Gets or sets the black point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlackPoint As Double()
'Usage

Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
public double[] BlackPoint {get; set;}
public: __property double[]* get_BlackPoint();
public: __property void set_BlackPoint(
   double[]* value
);
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


Gamma Property (PDFCalRgbColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : Gamma Property
Gets or sets the gamma.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Gamma As Double()
'Usage

Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.Gamma = value

value = instance.Gamma
public double[] Gamma {get; set;}
public: __property double[]* get_Gamma();
public: __property void set_Gamma(
   double[]* value
);
public:
property array<double>^ Gamma {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [GR GG GB] specifying the gamma for the red, green, and blue components of the color space.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


Matrix Property (PDFCalRgbColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : Matrix Property
Gets or sets the colorspace transformation matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Matrix As Double()
'Usage

Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.Matrix = value

value = instance.Matrix
public double[] Matrix {get; set;}
public: __property double[]* get_Matrix();
public: __property void set_Matrix(
   double[]* value
);
public:
property array<double>^ Matrix {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of nine numbers [XA YA ZA XB YB ZB XC YC ZC] specifying the linear interpretation of the decoded A, B, and C components of the color space with respect to the final XYZ representation..
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


WhitePoint Property (PDFCalRgbColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : WhitePoint Property
Gets or sets the white point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WhitePoint As Double()
'Usage

Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
public double[] WhitePoint {get; set;}
public: __property double[]* get_WhitePoint();
public: __property void set_WhitePoint(
   double[]* value
);
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%%

PDFColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpace Class
Defines the base class for all colorspaces.
Object Model
PDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFColorSpace
'Usage

Dim instance As PDFColorSpace
public class PDFColorSpace
public __gc class PDFColorSpace
public ref class PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPatternColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFColorSpace Class Members
Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpace Class

The following tables list the members exposed by PDFColorSpace.

Public Properties
 | Name | Description
Public Property | Type | Gets the type of this colorspace.
Top
See Also

Reference

PDFColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Properties$$

PDFColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpace Class

For a list of all members of this type, see PDFColorSpace members.

Public Properties
 | Name | Description
Public Property | Type | Gets the type of this colorspace.
Top
See Also

Reference

PDFColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


Type Property (PDFColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFColorSpace Class : Type Property
Gets the type of this colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PDFColorSpaceType
'Usage

Dim instance As PDFColorSpace
Dim value As PDFColorSpaceType

value = instance.Type
public PDFColorSpaceType Type {get;}
public: __property PDFColorSpaceType get_Type();
public:
property PDFColorSpaceType Type {
   PDFColorSpaceType get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColorSpace Class
PDFColorSpace Members


%%PageItemTitle%%

PDFColorSpaceCollection Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceCollection Class
Defines a collection of colorspaces.
Object Model
PDFColorSpaceCollection ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFColorSpaceCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFColorSpace)
'Usage

Dim instance As PDFColorSpaceCollection
public class PDFColorSpaceCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>
public __gc class PDFColorSpaceCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>
public ref class PDFColorSpaceCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpaceCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColorSpaceCollection Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFColorSpaceCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceCollection Class

The following tables list the members exposed by PDFColorSpaceCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Top
See Also

Reference

PDFColorSpaceCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class
Defines a device colorspace.
Object Model
PDFDeviceColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDeviceColorSpace
   Inherits PDFColorSpace
'Usage

Dim instance As PDFDeviceColorSpace
public class PDFDeviceColorSpace : PDFColorSpace
public __gc class PDFDeviceColorSpace : public PDFColorSpace
public ref class PDFDeviceColorSpace : public PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceColorSpace Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

The following tables list the members exposed by PDFDeviceColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PDFDeviceColorSpace Constructor | Initializes a new PDFDeviceColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | DeviceType | Gets the type of this device colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
Public Methods
 | Name | Description
Public Method | Equals | Tests if this colorspace equals another colorspace.
Top
See Also

Reference

PDFDeviceColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : PDFDeviceColorSpace Constructor
The type of the newly created device colorspace.
Initializes a new PDFDeviceColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal deviceType As PDFDeviceColorSpaceType _
)
'Usage

Dim deviceType As PDFDeviceColorSpaceType

Dim instance As New PDFDeviceColorSpace(deviceType)
public PDFDeviceColorSpace(
   PDFDeviceColorSpaceType deviceType
)
public: PDFDeviceColorSpace(
   PDFDeviceColorSpaceType deviceType
)
public:
PDFDeviceColorSpace(
   PDFDeviceColorSpaceType deviceType
)

Parameters

deviceType
The type of the newly created device colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFDeviceColorSpace Class Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

For a list of all members of this type, see PDFDeviceColorSpace members.

Public Methods
 | Name | Description
Public Method | Equals | Tests if this colorspace equals another colorspace.
Top
See Also

Reference

PDFDeviceColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


Equals Method (PDFDeviceColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : Equals Method
Tests if this colorspace equals another colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFDeviceColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFDeviceColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

For a list of all members of this type, see PDFDeviceColorSpace members.

Public Properties
 | Name | Description
Public Property | DeviceType | Gets the type of this device colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFDeviceColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


DeviceType Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : DeviceType Property
Gets the type of this device colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DeviceType As PDFDeviceColorSpaceType
'Usage

Dim instance As PDFDeviceColorSpace
Dim value As PDFDeviceColorSpaceType

value = instance.DeviceType
public PDFDeviceColorSpaceType DeviceType {get;}
public: __property PDFDeviceColorSpaceType get_DeviceType();
public:
property PDFDeviceColorSpaceType DeviceType {
   PDFDeviceColorSpaceType get();
}

Property Value

The type of the device colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


%%PageItemTitle%%

PDFDeviceNAttributes Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNAttributes Class
Defines the attributes for the DeviceN colorspace.
Object Model
PDFDeviceNAttributes Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDeviceNAttributes
'Usage

Dim instance As PDFDeviceNAttributes
public class PDFDeviceNAttributes
public __gc class PDFDeviceNAttributes
public ref class PDFDeviceNAttributes
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNAttributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNAttributes Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceNAttributes Class Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNAttributes Class

The following tables list the members exposed by PDFDeviceNAttributes.

Public Constructors
 | Name | Description
Public Constructor | PDFDeviceNAttributes Constructor | Initilizes a new PDFDeviceNAttributes object.
Top
See Also

Reference

PDFDeviceNAttributes Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceNAttributes Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNAttributes Class : PDFDeviceNAttributes Constructor
Initilizes a new PDFDeviceNAttributes object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDeviceNAttributes()
public PDFDeviceNAttributes()
public: PDFDeviceNAttributes();
public:
PDFDeviceNAttributes();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNAttributes Class
PDFDeviceNAttributes Members


%%PageItemTitle%%

PDFDeviceNColorants Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorants Class
Object Model
PDFDeviceNColorants Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDeviceNColorants
'Usage

Dim instance As PDFDeviceNColorants
public class PDFDeviceNColorants
public __gc class PDFDeviceNColorants
public ref class PDFDeviceNColorants
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorants

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorants Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceNColorants Class Members
Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorants Class

The following tables list the members exposed by PDFDeviceNColorants.

Public Constructors
 | Name | Description
Public Constructor | PDFDeviceNColorants Constructor | Initilizes a new PDFDeviceNColorants object.
Top
Public Methods
 | Name | Description
Public Method | AddColorant | Adds a colorant to the DeviceN colorspace.
Public Method | GetColorant | Gets the colorant with the specified name.
Public Method | GetColorantNames | Gets the names of the colorants included in the DeviceN colorspace.
Public Method | RemoveColorant | Removes the colorant with the specified name from the colorspace.
Top
See Also

Reference

PDFDeviceNColorants Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceNColorants Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : PDFDeviceNColorants Constructor
Initilizes a new PDFDeviceNColorants object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDeviceNColorants()
public PDFDeviceNColorants()
public: PDFDeviceNColorants();
public:
PDFDeviceNColorants();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


%%PageItemTitle%% $$Methods$$

PDFDeviceNColorants Class Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorants Class

For a list of all members of this type, see PDFDeviceNColorants members.

Public Methods
 | Name | Description
Public Method | AddColorant | Adds a colorant to the DeviceN colorspace.
Public Method | GetColorant | Gets the colorant with the specified name.
Public Method | GetColorantNames | Gets the names of the colorants included in the DeviceN colorspace.
Public Method | RemoveColorant | Removes the colorant with the specified name from the colorspace.
Top
See Also

Reference

PDFDeviceNColorants Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


AddColorant Method

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : AddColorant Method
The colorant to be addded to the colorspace.
Adds a colorant to the DeviceN colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddColorant( _
   ByVal colorant As PDFSeparationColorSpace _
)
'Usage

Dim instance As PDFDeviceNColorants
Dim colorant As PDFSeparationColorSpace

instance.AddColorant(colorant)
public void AddColorant(
   PDFSeparationColorSpace colorant
)
public: void AddColorant(
   PDFSeparationColorSpace* colorant
)
public:
void AddColorant(
   PDFSeparationColorSpace^ colorant
)

Parameters

colorant
The colorant to be addded to the colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


GetColorant Method

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : GetColorant Method
The name of the colorant to get.
Gets the colorant with the specified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColorant( _
   ByVal colorantName As String _
) As PDFSeparationColorSpace
'Usage

Dim instance As PDFDeviceNColorants
Dim colorantName As String
Dim value As PDFSeparationColorSpace

value = instance.GetColorant(colorantName)
public PDFSeparationColorSpace GetColorant(
   string colorantName
)
public: PDFSeparationColorSpace* GetColorant(
   string* colorantName
)
public:
PDFSeparationColorSpace^ GetColorant(
   String^ colorantName
)

Parameters

colorantName
The name of the colorant to get.

Return Value

The colorant as a separation colorspace if it exists, null otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


GetColorantNames Method

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : GetColorantNames Method
Gets the names of the colorants included in the DeviceN colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetColorantNames() As String()
'Usage

Dim instance As PDFDeviceNColorants
Dim value() As String

value = instance.GetColorantNames()
public string[] GetColorantNames()
public: string*[]* GetColorantNames();
public:
array<String^>^ GetColorantNames();

Return Value

List of colorant names.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


RemoveColorant Method

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : RemoveColorant Method
The name of the colorant to be removed.
Removes the colorant with the specified name from the colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveColorant( _
   ByVal colorantName As String _
)
'Usage

Dim instance As PDFDeviceNColorants
Dim colorantName As String

instance.RemoveColorant(colorantName)
public void RemoveColorant(
   string colorantName
)
public: void RemoveColorant(
   string* colorantName
)
public:
void RemoveColorant(
   String^ colorantName
)

Parameters

colorantName
The name of the colorant to be removed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


%%PageItemTitle%%

PDFDeviceNColorNameCollection Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorNameCollection Class
Defines a collection of PDF actions.
Object Model
PDFDeviceNColorNameCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDeviceNColorNameCollection
   Inherits System.Collections.ObjectModel.Collection(Of String)
'Usage

Dim instance As PDFDeviceNColorNameCollection
public class PDFDeviceNColorNameCollection : System.Collections.ObjectModel.Collection<string>
public __gc class PDFDeviceNColorNameCollection : public System.Collections.ObjectModel.Collection<string>
public ref class PDFDeviceNColorNameCollection : public System.Collections.ObjectModel.Collection<String>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorNameCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorNameCollection Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceNColorNameCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorNameCollection Class

The following tables list the members exposed by PDFDeviceNColorNameCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<string>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Top
See Also

Reference

PDFDeviceNColorNameCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceNColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class
Defines a DeviceN colorspace.
Object Model
PDFDeviceNColorSpace ClassPDFColorSpace ClassPDFDeviceNAttributes ClassPDFDeviceNColorNameCollection ClassPDFFunction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDeviceNColorSpace
   Inherits PDFColorSpace
'Usage

Dim instance As PDFDeviceNColorSpace
public class PDFDeviceNColorSpace : PDFColorSpace
public __gc class PDFDeviceNColorSpace : public PDFColorSpace
public ref class PDFDeviceNColorSpace : public PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceNColorSpace Class Members
Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class

The following tables list the members exposed by PDFDeviceNColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PDFDeviceNColorSpace Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Attributes | Gets the attributes associated with this colorsspace.
Public Property | ColorantNames | Gets the collection of colorant names included in this DeviceN colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFDeviceNColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceNColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : PDFDeviceNColorSpace Constructor
Overload List
Overload | Description
PDFDeviceNColorSpace Constructor(PDFArray) | Initializes a new PDFDeviceNColorSpace object.
PDFDeviceNColorSpace Constructor() | Initializes a new PDFDeviceNColorSpace object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


%%PageItemTitle%%

PDFDeviceNColorSpace Constructor(PDFArray)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class > PDFDeviceNColorSpace Constructor : PDFDeviceNColorSpace Constructor(PDFArray)
Initializes a new PDFDeviceNColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rawColorSpace As PDFArray _
)
'Usage

Dim rawColorSpace As PDFArray

Dim instance As New PDFDeviceNColorSpace(rawColorSpace)
public PDFDeviceNColorSpace(
   PDFArray rawColorSpace
)
public: PDFDeviceNColorSpace(
   PDFArray* rawColorSpace
)
public:
PDFDeviceNColorSpace(
   PDFArray^ rawColorSpace
)

Parameters

rawColorSpace
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members
Overload List


%%PageItemTitle%%

PDFDeviceNColorSpace Constructor()

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class > PDFDeviceNColorSpace Constructor : PDFDeviceNColorSpace Constructor()
Initializes a new PDFDeviceNColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDeviceNColorSpace()
public PDFDeviceNColorSpace()
public: PDFDeviceNColorSpace();
public:
PDFDeviceNColorSpace();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFDeviceNColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class

For a list of all members of this type, see PDFDeviceNColorSpace members.

Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Attributes | Gets the attributes associated with this colorsspace.
Public Property | ColorantNames | Gets the collection of colorant names included in this DeviceN colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFDeviceNColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


AlternateColorSpace Property (PDFDeviceNColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : AlternateColorSpace Property
Gets or sets the alternate colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlternateColorSpace As PDFColorSpace
'Usage

Dim instance As PDFDeviceNColorSpace
Dim value As PDFColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
public PDFColorSpace AlternateColorSpace {get; set;}
public: __property PDFColorSpace* get_AlternateColorSpace();
public: __property void set_AlternateColorSpace(
   PDFColorSpace* value
);
public:
property PDFColorSpace^ AlternateColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The alternate color space to be used when the destination device does not support DeviceN colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


Attributes Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : Attributes Property
Gets the attributes associated with this colorsspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Attributes As PDFDeviceNAttributes
'Usage

Dim instance As PDFDeviceNColorSpace
Dim value As PDFDeviceNAttributes

instance.Attributes = value

value = instance.Attributes
public PDFDeviceNAttributes Attributes {get; set;}
public: __property PDFDeviceNAttributes* get_Attributes();
public: __property void set_Attributes(
   PDFDeviceNAttributes* value
);
public:
property PDFDeviceNAttributes^ Attributes {
   PDFDeviceNAttributes^ get();
   void set (    PDFDeviceNAttributes^ value);
}

Property Value

The attributes of the colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


ColorantNames Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : ColorantNames Property
Gets the collection of colorant names included in this DeviceN colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorantNames As PDFDeviceNColorNameCollection
'Usage

Dim instance As PDFDeviceNColorSpace
Dim value As PDFDeviceNColorNameCollection

value = instance.ColorantNames
public PDFDeviceNColorNameCollection ColorantNames {get;}
public: __property PDFDeviceNColorNameCollection* get_ColorantNames();
public:
property PDFDeviceNColorNameCollection^ ColorantNames {
   PDFDeviceNColorNameCollection^ get();
}

Property Value

The list of colorant names.
Remarks
If this list is empty, the library will build it automatically from the names of the separation colorspaces included in this colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


TintTransform Property (PDFDeviceNColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : TintTransform Property
Gets or sets the tint transform function for the this colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TintTransform As PDFFunction
'Usage

Dim instance As PDFDeviceNColorSpace
Dim value As PDFFunction

instance.TintTransform = value

value = instance.TintTransform
public PDFFunction TintTransform {get; set;}
public: __property PDFFunction* get_TintTransform();
public: __property void set_TintTransform(
   PDFFunction* value
);
public:
property PDFFunction^ TintTransform {
   PDFFunction^ get();
   void set (    PDFFunction^ value);
}

Property Value

Tint transform function for the colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


%%PageItemTitle%%

PDFICCColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class
Defines an ICC based colorspace.
Object Model
PDFICCColorSpace ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFICCColorSpace
   Inherits PDFColorSpace
'Usage

Dim instance As PDFICCColorSpace
public class PDFICCColorSpace : PDFColorSpace
public __gc class PDFICCColorSpace : public PDFColorSpace
public ref class PDFICCColorSpace : public PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFICCColorSpace Class Members
Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class

The following tables list the members exposed by PDFICCColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PDFICCColorSpace Constructor | Initializes a new PDFICCColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorComponents | Gets or sets the number of color components in the ICC colorspace.
Public Property | ProfileData | Gets or sets the profile data.
Public Property | Range | Gets or sets the range for color components.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFICCColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFICCColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : PDFICCColorSpace Constructor
Initializes a new PDFICCColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFICCColorSpace()
public PDFICCColorSpace()
public: PDFICCColorSpace();
public:
PDFICCColorSpace();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFICCColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class

For a list of all members of this type, see PDFICCColorSpace members.

Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorComponents | Gets or sets the number of color components in the ICC colorspace.
Public Property | ProfileData | Gets or sets the profile data.
Public Property | Range | Gets or sets the range for color components.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFICCColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


AlternateColorSpace Property (PDFICCColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : AlternateColorSpace Property
Gets or sets the alternate colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlternateColorSpace As PDFColorSpace
'Usage

Dim instance As PDFICCColorSpace
Dim value As PDFColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
public PDFColorSpace AlternateColorSpace {get; set;}
public: __property PDFColorSpace* get_AlternateColorSpace();
public: __property void set_AlternateColorSpace(
   PDFColorSpace* value
);
public:
property PDFColorSpace^ AlternateColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The alternate color space to be used in case the one specified in the stream data is not supported
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


ColorComponents Property (PDFICCColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : ColorComponents Property
Gets or sets the number of color components in the ICC colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorComponents As Integer
'Usage

Dim instance As PDFICCColorSpace
Dim value As Integer

instance.ColorComponents = value

value = instance.ColorComponents
public int ColorComponents {get; set;}
public: __property int get_ColorComponents();
public: __property void set_ColorComponents(
   int value
);
public:
property int ColorComponents {
   int get();
   void set (    int value);
}

Property Value

The number of color components in the color space described by the ICC profile data.
Remarks
This number must match the number of components actually in the ICC profile. As of PDF 1.4, this value must be 1, 3 or 4.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


ProfileData Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : ProfileData Property
Gets or sets the profile data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProfileData As Byte()
'Usage

Dim instance As PDFICCColorSpace
Dim value() As Byte

instance.ProfileData = value

value = instance.ProfileData
public byte[] ProfileData {get; set;}
public: __property byte[]* get_ProfileData();
public: __property void set_ProfileData(
   byte[]* value
);
public:
property array<byte>^ ProfileData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The ICC profile data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


Range Property (PDFICCColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : Range Property
Gets or sets the range for color components.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Range As Double()
'Usage

Dim instance As PDFICCColorSpace
Dim value() As Double

instance.Range = value

value = instance.Range
public double[] Range {get; set;}
public: __property double[]* get_Range();
public: __property void set_Range(
   double[]* value
);
public:
property array<double>^ Range {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of 2 * ColorComponents numbers [ min0 max0 min1 max1 ... ] specifying the minimum and maximum valid values of the corresponding color components. These values must match the information in the ICC profile.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%%

PDFIndexedColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class
Defines an indexed colorspace.
Object Model
PDFIndexedColorSpace ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFIndexedColorSpace
   Inherits PDFColorSpace
'Usage

Dim instance As PDFIndexedColorSpace
public class PDFIndexedColorSpace : PDFColorSpace
public __gc class PDFIndexedColorSpace : public PDFColorSpace
public ref class PDFIndexedColorSpace : public PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFIndexedColorSpace Class Members
Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class

The following tables list the members exposed by PDFIndexedColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PDFIndexedColorSpace Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BaseColorSpace | Gets or sets the base colorspace.
Public Property | ColorTable | Gets or sets the color table.
Public Property | MaxIndex | Gets or sets the maximum index for the colors in the color table.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFIndexedColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFIndexedColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : PDFIndexedColorSpace Constructor
Overload List
Overload | Description
PDFIndexedColorSpace Constructor(PDFArray) | Initializes a new PDFIndexedColorSpace object.
PDFIndexedColorSpace Constructor() | Initializes a new PDFIndexedColorSpace object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


%%PageItemTitle%%

PDFIndexedColorSpace Constructor(PDFArray)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class > PDFIndexedColorSpace Constructor : PDFIndexedColorSpace Constructor(PDFArray)
Initializes a new PDFIndexedColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rawColorSpace As PDFArray _
)
'Usage

Dim rawColorSpace As PDFArray

Dim instance As New PDFIndexedColorSpace(rawColorSpace)
public PDFIndexedColorSpace(
   PDFArray rawColorSpace
)
public: PDFIndexedColorSpace(
   PDFArray* rawColorSpace
)
public:
PDFIndexedColorSpace(
   PDFArray^ rawColorSpace
)

Parameters

rawColorSpace
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members
Overload List


%%PageItemTitle%%

PDFIndexedColorSpace Constructor()

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class > PDFIndexedColorSpace Constructor : PDFIndexedColorSpace Constructor()
Initializes a new PDFIndexedColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFIndexedColorSpace()
public PDFIndexedColorSpace()
public: PDFIndexedColorSpace();
public:
PDFIndexedColorSpace();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFIndexedColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class

For a list of all members of this type, see PDFIndexedColorSpace members.

Public Properties
 | Name | Description
Public Property | BaseColorSpace | Gets or sets the base colorspace.
Public Property | ColorTable | Gets or sets the color table.
Public Property | MaxIndex | Gets or sets the maximum index for the colors in the color table.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFIndexedColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


BaseColorSpace Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : BaseColorSpace Property
Gets or sets the base colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BaseColorSpace As PDFColorSpace
'Usage

Dim instance As PDFIndexedColorSpace
Dim value As PDFColorSpace

instance.BaseColorSpace = value

value = instance.BaseColorSpace
public PDFColorSpace BaseColorSpace {get; set;}
public: __property PDFColorSpace* get_BaseColorSpace();
public: __property void set_BaseColorSpace(
   PDFColorSpace* value
);
public:
property PDFColorSpace^ BaseColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The color space in which the values in the color table are to be interpreted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


ColorTable Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : ColorTable Property
Gets or sets the color table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorTable As Byte()
'Usage

Dim instance As PDFIndexedColorSpace
Dim value() As Byte

instance.ColorTable = value

value = instance.ColorTable
public byte[] ColorTable {get; set;}
public: __property byte[]* get_ColorTable();
public: __property void set_ColorTable(
   byte[]* value
);
public:
property array<byte>^ ColorTable {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The table of color components.
Remarks
The color table data must be m * (maxIndex + 1) bytes long, where m is the number of color components in the base color space. Each byte is an unsigned integer in the range 0 to 255 that is scaled to the range of the corresponding color component in the base color space; that is, 0 corresponds to the minimum value in the range for that component, and 255 corresponds to the maximum.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


MaxIndex Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : MaxIndex Property
Gets or sets the maximum index for the colors in the color table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxIndex As Integer
'Usage

Dim instance As PDFIndexedColorSpace
Dim value As Integer

instance.MaxIndex = value

value = instance.MaxIndex
public int MaxIndex {get; set;}
public: __property int get_MaxIndex();
public: __property void set_MaxIndex(
   int value
);
public:
property int MaxIndex {
   int get();
   void set (    int value);
}

Property Value

The maximum index that can be used to access the values in the color table.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


%%PageItemTitle%%

PDFLabColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class
Defines a Lab colorspace.
Object Model
PDFLabColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLabColorSpace
   Inherits PDFColorSpace
'Usage

Dim instance As PDFLabColorSpace
public class PDFLabColorSpace : PDFColorSpace
public __gc class PDFLabColorSpace : public PDFColorSpace
public ref class PDFLabColorSpace : public PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFLabColorSpace Class Members
Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class

The following tables list the members exposed by PDFLabColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PDFLabColorSpace Constructor | Initializes a new PDFLabColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Range | Gets or sets the range.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PDFLabColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFLabColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : PDFLabColorSpace Constructor
Initializes a new PDFLabColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLabColorSpace()
public PDFLabColorSpace()
public: PDFLabColorSpace();
public:
PDFLabColorSpace();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFLabColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class

For a list of all members of this type, see PDFLabColorSpace members.

Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Range | Gets or sets the range.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PDFLabColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


BlackPoint Property (PDFLabColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : BlackPoint Property
Gets or sets the black point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlackPoint As Double()
'Usage

Dim instance As PDFLabColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
public double[] BlackPoint {get; set;}
public: __property double[]* get_BlackPoint();
public: __property void set_BlackPoint(
   double[]* value
);
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


Range Property (PDFLabColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : Range Property
Gets or sets the range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Range As Double()
'Usage

Dim instance As PDFLabColorSpace
Dim value() As Double

instance.Range = value

value = instance.Range
public double[] Range {get; set;}
public: __property double[]* get_Range();
public: __property void set_Range(
   double[]* value
);
public:
property array<double>^ Range {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of four numbers [amin amax bmin bmax] specifying the range of valid values for the a* and b* (B and C) components of the color space.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


WhitePoint Property (PDFLabColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : WhitePoint Property
Gets or sets the white point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WhitePoint As Double()
'Usage

Dim instance As PDFLabColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
public double[] WhitePoint {get; set;}
public: __property double[]* get_WhitePoint();
public: __property void set_WhitePoint(
   double[]* value
);
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


%%PageItemTitle%%

PDFPantoneColor Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class
Defines a PANTONE color.
Object Model
PDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFColorSpace ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor ClassPDFPantoneColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPantoneColor
   Inherits O2S.Components.PDF4NET.Graphics.PDFSeparationColor
'Usage

Dim instance As PDFPantoneColor
public class PDFPantoneColor : O2S.Components.PDF4NET.Graphics.PDFSeparationColor
public __gc class PDFPantoneColor : public O2S.Components.PDF4NET.Graphics.PDFSeparationColor
public ref class PDFPantoneColor : public O2S.Components.PDF4NET.Graphics.PDFSeparationColor
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFPantoneColor Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

The following tables list the members exposed by PDFPantoneColor.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Black | Gets the PANTONE Black color.
static (Shared in Visual Basic) | Black2 | Gets the PANTONE Black 2 color.
static (Shared in Visual Basic) | Black3 | Gets the PANTONE Black 3 color.
static (Shared in Visual Basic) | Black4 | Gets the PANTONE Black 4 color.
static (Shared in Visual Basic) | Black5 | Gets the PANTONE Black 5 color.
static (Shared in Visual Basic) | Black6 | Gets the PANTONE Black 6 color.
static (Shared in Visual Basic) | Black7 | Gets the PANTONE Black 7 color.
static (Shared in Visual Basic) | Blue072 | Gets the PANTONE Blue 072 color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
static (Shared in Visual Basic) | CoolGray1 | Gets the PANTONE Cool Gray 1 color.
static (Shared in Visual Basic) | CoolGray10 | Gets the PANTONE Cool Gray 10 color.
static (Shared in Visual Basic) | CoolGray11 | Gets the PANTONE Cool Gray 11 color.
static (Shared in Visual Basic) | CoolGray2 | Gets the PANTONE Cool Gray 2 color.
static (Shared in Visual Basic) | CoolGray3 | Gets the PANTONE Cool Gray 3 color.
static (Shared in Visual Basic) | CoolGray4 | Gets the PANTONE Cool Gray 4 color.
static (Shared in Visual Basic) | CoolGray5 | Gets the PANTONE Cool Gray 5 color.
static (Shared in Visual Basic) | CoolGray6 | Gets the PANTONE Cool Gray 6 color.
static (Shared in Visual Basic) | CoolGray7 | Gets the PANTONE Cool Gray 7 color.
static (Shared in Visual Basic) | CoolGray8 | Gets the PANTONE Cool Gray 8 color.
static (Shared in Visual Basic) | CoolGray9 | Gets the PANTONE Cool Gray 9 color.
static (Shared in Visual Basic) | Green | Gets the PANTONE Green color.
static (Shared in Visual Basic) | HexachromeBlack | Gets the PANTONE Hexachrome Black color.
static (Shared in Visual Basic) | HexachromeCyan | Gets the PANTONE Hexachrome Cyan color.
static (Shared in Visual Basic) | HexachromeGreen | Gets the PANTONE Hexachrome Green color.
static (Shared in Visual Basic) | HexachromeMagenta | Gets the PANTONE Hexachrome Magenta color.
static (Shared in Visual Basic) | HexachromeOrange | Gets the PANTONE Hexachrome Orange color.
static (Shared in Visual Basic) | HexachromeYellow | Gets the PANTONE Hexachrome Yellow color.
static (Shared in Visual Basic) | Orange021 | Gets the PANTONE Orange 021 color.
static (Shared in Visual Basic) | PANTONE100 | Gets the PANTONE 100 color.
static (Shared in Visual Basic) | PANTONE101 | Gets the PANTONE 101 color.
static (Shared in Visual Basic) | PANTONE102 | Gets the PANTONE 102 color.
static (Shared in Visual Basic) | PANTONE103 | Gets the PANTONE 103 color.
static (Shared in Visual Basic) | PANTONE104 | Gets the PANTONE 104 color.
static (Shared in Visual Basic) | PANTONE105 | Gets the PANTONE 105 color.
static (Shared in Visual Basic) | PANTONE106 | Gets the PANTONE 106 color.
static (Shared in Visual Basic) | PANTONE107 | Gets the PANTONE 107 color.
static (Shared in Visual Basic) | PANTONE108 | Gets the PANTONE 108 color.
static (Shared in Visual Basic) | PANTONE109 | Gets the PANTONE 109 color.
static (Shared in Visual Basic) | PANTONE110 | Gets the PANTONE 110 color.
static (Shared in Visual Basic) | PANTONE111 | Gets the PANTONE 111 color.
static (Shared in Visual Basic) | PANTONE112 | Gets the PANTONE 112 color.
static (Shared in Visual Basic) | PANTONE113 | Gets the PANTONE 113 color.
static (Shared in Visual Basic) | PANTONE114 | Gets the PANTONE 114 color.
static (Shared in Visual Basic) | PANTONE115 | Gets the PANTONE 115 color.
static (Shared in Visual Basic) | PANTONE116 | Gets the PANTONE 116 color.
static (Shared in Visual Basic) | PANTONE117 | Gets the PANTONE 117 color.
static (Shared in Visual Basic) | PANTONE118 | Gets the PANTONE 118 color.
static (Shared in Visual Basic) | PANTONE119 | Gets the PANTONE 119 color.
static (Shared in Visual Basic) | PANTONE120 | Gets the PANTONE 120 color.
static (Shared in Visual Basic) | PANTONE1205 | Gets the PANTONE 1205 color.
static (Shared in Visual Basic) | PANTONE121 | Gets the PANTONE 121 color.
static (Shared in Visual Basic) | PANTONE1215 | Gets the PANTONE 1215 color.
static (Shared in Visual Basic) | PANTONE122 | Gets the PANTONE 122 color.
static (Shared in Visual Basic) | PANTONE1225 | Gets the PANTONE 1225 color.
static (Shared in Visual Basic) | PANTONE123 | Gets the PANTONE 123 color.
static (Shared in Visual Basic) | PANTONE1235 | Gets the PANTONE 1235 color.
static (Shared in Visual Basic) | PANTONE124 | Gets the PANTONE 124 color.
static (Shared in Visual Basic) | PANTONE1245 | Gets the PANTONE 1245 color.
static (Shared in Visual Basic) | PANTONE125 | Gets the PANTONE 125 color.
static (Shared in Visual Basic) | PANTONE1255 | Gets the PANTONE 1255 color.
static (Shared in Visual Basic) | PANTONE126 | Gets the PANTONE 126 color.
static (Shared in Visual Basic) | PANTONE1265 | Gets the PANTONE 1265 color.
static (Shared in Visual Basic) | PANTONE127 | Gets the PANTONE 127 color.
static (Shared in Visual Basic) | PANTONE128 | Gets the PANTONE 128 color.
static (Shared in Visual Basic) | PANTONE129 | Gets the PANTONE 129 color.
static (Shared in Visual Basic) | PANTONE130 | Gets the PANTONE 130 color.
static (Shared in Visual Basic) | PANTONE131 | Gets the PANTONE 131 color.
static (Shared in Visual Basic) | PANTONE132 | Gets the PANTONE 132 color.
static (Shared in Visual Basic) | PANTONE133 | Gets the PANTONE 133 color.
static (Shared in Visual Basic) | PANTONE134 | Gets the PANTONE 134 color.
static (Shared in Visual Basic) | PANTONE1345 | Gets the PANTONE 1345 color.
static (Shared in Visual Basic) | PANTONE135 | Gets the PANTONE 135 color.
static (Shared in Visual Basic) | PANTONE1355 | Gets the PANTONE 1355 color.
static (Shared in Visual Basic) | PANTONE136 | Gets the PANTONE 136 color.
static (Shared in Visual Basic) | PANTONE1365 | Gets the PANTONE 1365 color.
static (Shared in Visual Basic) | PANTONE137 | Gets the PANTONE 137 color.
static (Shared in Visual Basic) | PANTONE1375 | Gets the PANTONE 1375 color.
static (Shared in Visual Basic) | PANTONE138 | Gets the PANTONE 138 color.
static (Shared in Visual Basic) | PANTONE1385 | Gets the PANTONE 1385 color.
static (Shared in Visual Basic) | PANTONE139 | Gets the PANTONE 139 color.
static (Shared in Visual Basic) | PANTONE1395 | Gets the PANTONE 1395 color.
static (Shared in Visual Basic) | PANTONE140 | Gets the PANTONE 140 color.
static (Shared in Visual Basic) | PANTONE1405 | Gets the PANTONE 1405 color.
static (Shared in Visual Basic) | PANTONE141 | Gets the PANTONE 141 color.
static (Shared in Visual Basic) | PANTONE142 | Gets the PANTONE 142 color.
static (Shared in Visual Basic) | PANTONE143 | Gets the PANTONE 143 color.
static (Shared in Visual Basic) | PANTONE144 | Gets the PANTONE 144 color.
static (Shared in Visual Basic) | PANTONE145 | Gets the PANTONE 145 color.
static (Shared in Visual Basic) | PANTONE146 | Gets the PANTONE 146 color.
static (Shared in Visual Basic) | PANTONE147 | Gets the PANTONE 147 color.
static (Shared in Visual Basic) | PANTONE148 | Gets the PANTONE 148 color.
static (Shared in Visual Basic) | PANTONE1485 | Gets the PANTONE 1485 color.
static (Shared in Visual Basic) | PANTONE149 | Gets the PANTONE 149 color.
static (Shared in Visual Basic) | PANTONE1495 | Gets the PANTONE 1495 color.
static (Shared in Visual Basic) | PANTONE150 | Gets the PANTONE 150 color.
static (Shared in Visual Basic) | PANTONE1505 | Gets the PANTONE 1505 color.
static (Shared in Visual Basic) | PANTONE151 | Gets the PANTONE 151 color.
static (Shared in Visual Basic) | PANTONE152 | Gets the PANTONE 152 color.
static (Shared in Visual Basic) | PANTONE1525 | Gets the PANTONE 1525 color.
static (Shared in Visual Basic) | PANTONE153 | Gets the PANTONE 153 color.
static (Shared in Visual Basic) | PANTONE1535 | Gets the PANTONE 1535 color.
static (Shared in Visual Basic) | PANTONE154 | Gets the PANTONE 154 color.
static (Shared in Visual Basic) | PANTONE1545 | Gets the PANTONE 1545 color.
static (Shared in Visual Basic) | PANTONE155 | Gets the PANTONE 155 color.
static (Shared in Visual Basic) | PANTONE1555 | Gets the PANTONE 1555 color.
static (Shared in Visual Basic) | PANTONE156 | Gets the PANTONE 156 color.
static (Shared in Visual Basic) | PANTONE1565 | Gets the PANTONE 1565 color.
static (Shared in Visual Basic) | PANTONE157 | Gets the PANTONE 157 color.
static (Shared in Visual Basic) | PANTONE1575 | Gets the PANTONE 1575 color.
static (Shared in Visual Basic) | PANTONE158 | Gets the PANTONE 158 color.
static (Shared in Visual Basic) | PANTONE1585 | Gets the PANTONE 1585 color.
static (Shared in Visual Basic) | PANTONE159 | Gets the PANTONE 159 color.
static (Shared in Visual Basic) | PANTONE1595 | Gets the PANTONE 1595 color.
static (Shared in Visual Basic) | PANTONE160 | Gets the PANTONE 160 color.
static (Shared in Visual Basic) | PANTONE1605 | Gets the PANTONE 1605 color.
static (Shared in Visual Basic) | PANTONE161 | Gets the PANTONE 161 color.
static (Shared in Visual Basic) | PANTONE1615 | Gets the PANTONE 1615 color.
static (Shared in Visual Basic) | PANTONE162 | Gets the PANTONE 162 color.
static (Shared in Visual Basic) | PANTONE1625 | Gets the PANTONE 1625 color.
static (Shared in Visual Basic) | PANTONE163 | Gets the PANTONE 163 color.
static (Shared in Visual Basic) | PANTONE1635 | Gets the PANTONE 1635 color.
static (Shared in Visual Basic) | PANTONE164 | Gets the PANTONE 164 color.
static (Shared in Visual Basic) | PANTONE1645 | Gets the PANTONE 1645 color.
static (Shared in Visual Basic) | PANTONE165 | Gets the PANTONE 165 color.
static (Shared in Visual Basic) | PANTONE1655 | Gets the PANTONE 1655 color.
static (Shared in Visual Basic) | PANTONE166 | Gets the PANTONE 166 color.
static (Shared in Visual Basic) | PANTONE1665 | Gets the PANTONE 1665 color.
static (Shared in Visual Basic) | PANTONE167 | Gets the PANTONE 167 color.
static (Shared in Visual Basic) | PANTONE1675 | Gets the PANTONE 1675 color.
static (Shared in Visual Basic) | PANTONE168 | Gets the PANTONE 168 color.
static (Shared in Visual Basic) | PANTONE1685 | Gets the PANTONE 1685 color.
static (Shared in Visual Basic) | PANTONE169 | Gets the PANTONE 169 color.
static (Shared in Visual Basic) | PANTONE170 | Gets the PANTONE 170 color.
static (Shared in Visual Basic) | PANTONE171 | Gets the PANTONE 171 color.
static (Shared in Visual Basic) | PANTONE172 | Gets the PANTONE 172 color.
static (Shared in Visual Basic) | PANTONE173 | Gets the PANTONE 173 color.
static (Shared in Visual Basic) | PANTONE174 | Gets the PANTONE 174 color.
static (Shared in Visual Basic) | PANTONE175 | Gets the PANTONE 175 color.
static (Shared in Visual Basic) | PANTONE176 | Gets the PANTONE 176 color.
static (Shared in Visual Basic) | PANTONE1765 | Gets the PANTONE 1765 color.
static (Shared in Visual Basic) | PANTONE1767 | Gets the PANTONE 1767 color.
static (Shared in Visual Basic) | PANTONE177 | Gets the PANTONE 177 color.
static (Shared in Visual Basic) | PANTONE1775 | Gets the PANTONE 1775 color.
static (Shared in Visual Basic) | PANTONE1777 | Gets the PANTONE 1777 color.
static (Shared in Visual Basic) | PANTONE178 | Gets the PANTONE 178 color.
static (Shared in Visual Basic) | PANTONE1785 | Gets the PANTONE 1785 color.
static (Shared in Visual Basic) | PANTONE1787 | Gets the PANTONE 1787 color.
static (Shared in Visual Basic) | PANTONE1788 | Gets the PANTONE 1788 color.
static (Shared in Visual Basic) | PANTONE179 | Gets the PANTONE 179 color.
static (Shared in Visual Basic) | PANTONE1795 | Gets the PANTONE 1795 color.
static (Shared in Visual Basic) | PANTONE1797 | Gets the PANTONE 1797 color.
static (Shared in Visual Basic) | PANTONE180 | Gets the PANTONE 180 color.
static (Shared in Visual Basic) | PANTONE1805 | Gets the PANTONE 1805 color.
static (Shared in Visual Basic) | PANTONE1807 | Gets the PANTONE 1807 color.
static (Shared in Visual Basic) | PANTONE181 | Gets the PANTONE 181 color.
static (Shared in Visual Basic) | PANTONE1815 | Gets the PANTONE 1815 color.
static (Shared in Visual Basic) | PANTONE1817 | Gets the PANTONE 1817 color.
static (Shared in Visual Basic) | PANTONE182 | Gets the PANTONE 182 color.
static (Shared in Visual Basic) | PANTONE183 | Gets the PANTONE 183 color.
static (Shared in Visual Basic) | PANTONE184 | Gets the PANTONE 184 color.
static (Shared in Visual Basic) | PANTONE185 | Gets the PANTONE 185 color.
static (Shared in Visual Basic) | PANTONE186 | Gets the PANTONE 186 color.
static (Shared in Visual Basic) | PANTONE187 | Gets the PANTONE 187 color.
static (Shared in Visual Basic) | PANTONE188 | Gets the PANTONE 188 color.
static (Shared in Visual Basic) | PANTONE189 | Gets the PANTONE 189 color.
static (Shared in Visual Basic) | PANTONE1895 | Gets the PANTONE 1895 color.
static (Shared in Visual Basic) | PANTONE190 | Gets the PANTONE 190 color.
static (Shared in Visual Basic) | PANTONE1905 | Gets the PANTONE 1905 color.
static (Shared in Visual Basic) | PANTONE191 | Gets the PANTONE 191 color.
static (Shared in Visual Basic) | PANTONE1915 | Gets the PANTONE 1915 color.
static (Shared in Visual Basic) | PANTONE192 | Gets the PANTONE 192 color.
static (Shared in Visual Basic) | PANTONE1925 | Gets the PANTONE 1925 color.
static (Shared in Visual Basic) | PANTONE193 | Gets the PANTONE 193 color.
static (Shared in Visual Basic) | PANTONE1935 | Gets the PANTONE 1935 color.
static (Shared in Visual Basic) | PANTONE194 | Gets the PANTONE 194 color.
static (Shared in Visual Basic) | PANTONE1945 | Gets the PANTONE 1945 color.
static (Shared in Visual Basic) | PANTONE195 | Gets the PANTONE 195 color.
static (Shared in Visual Basic) | PANTONE1955 | Gets the PANTONE 1955 color.
static (Shared in Visual Basic) | PANTONE196 | Gets the PANTONE 196 color.
static (Shared in Visual Basic) | PANTONE197 | Gets the PANTONE 197 color.
static (Shared in Visual Basic) | PANTONE198 | Gets the PANTONE 198 color.
static (Shared in Visual Basic) | PANTONE199 | Gets the PANTONE 199 color.
static (Shared in Visual Basic) | PANTONE200 | Gets the PANTONE 200 color.
static (Shared in Visual Basic) | PANTONE201 | Gets the PANTONE 201 color.
static (Shared in Visual Basic) | PANTONE202 | Gets the PANTONE 202 color.
static (Shared in Visual Basic) | PANTONE203 | Gets the PANTONE 203 color.
static (Shared in Visual Basic) | PANTONE204 | Gets the PANTONE 204 color.
static (Shared in Visual Basic) | PANTONE205 | Gets the PANTONE 205 color.
static (Shared in Visual Basic) | PANTONE206 | Gets the PANTONE 206 color.
static (Shared in Visual Basic) | PANTONE207 | Gets the PANTONE 207 color.
static (Shared in Visual Basic) | PANTONE208 | Gets the PANTONE 208 color.
static (Shared in Visual Basic) | PANTONE209 | Gets the PANTONE 209 color.
static (Shared in Visual Basic) | PANTONE210 | Gets the PANTONE 210 color.
static (Shared in Visual Basic) | PANTONE211 | Gets the PANTONE 211 color.
static (Shared in Visual Basic) | PANTONE212 | Gets the PANTONE 212 color.
static (Shared in Visual Basic) | PANTONE213 | Gets the PANTONE 213 color.
static (Shared in Visual Basic) | PANTONE214 | Gets the PANTONE 214 color.
static (Shared in Visual Basic) | PANTONE215 | Gets the PANTONE 215 color.
static (Shared in Visual Basic) | PANTONE216 | Gets the PANTONE 216 color.
static (Shared in Visual Basic) | PANTONE217 | Gets the PANTONE 217 color.
static (Shared in Visual Basic) | PANTONE218 | Gets the PANTONE 218 color.
static (Shared in Visual Basic) | PANTONE219 | Gets the PANTONE 219 color.
static (Shared in Visual Basic) | PANTONE220 | Gets the PANTONE 220 color.
static (Shared in Visual Basic) | PANTONE221 | Gets the PANTONE 221 color.
static (Shared in Visual Basic) | PANTONE222 | Gets the PANTONE 222 color.
static (Shared in Visual Basic) | PANTONE223 | Gets the PANTONE 223 color.
static (Shared in Visual Basic) | PANTONE224 | Gets the PANTONE 224 color.
static (Shared in Visual Basic) | PANTONE225 | Gets the PANTONE 225 color.
static (Shared in Visual Basic) | PANTONE226 | Gets the PANTONE 226 color.
static (Shared in Visual Basic) | PANTONE227 | Gets the PANTONE 227 color.
static (Shared in Visual Basic) | PANTONE228 | Gets the PANTONE 228 color.
static (Shared in Visual Basic) | PANTONE229 | Gets the PANTONE 229 color.
static (Shared in Visual Basic) | PANTONE230 | Gets the PANTONE 230 color.
static (Shared in Visual Basic) | PANTONE231 | Gets the PANTONE 231 color.
static (Shared in Visual Basic) | PANTONE232 | Gets the PANTONE 232 color.
static (Shared in Visual Basic) | PANTONE233 | Gets the PANTONE 233 color.
static (Shared in Visual Basic) | PANTONE234 | Gets the PANTONE 234 color.
static (Shared in Visual Basic) | PANTONE235 | Gets the PANTONE 235 color.
static (Shared in Visual Basic) | PANTONE236 | Gets the PANTONE 236 color.
static (Shared in Visual Basic) | PANTONE2365 | Gets the PANTONE 2365 color.
static (Shared in Visual Basic) | PANTONE237 | Gets the PANTONE 237 color.
static (Shared in Visual Basic) | PANTONE2375 | Gets the PANTONE 2375 color.
static (Shared in Visual Basic) | PANTONE238 | Gets the PANTONE 238 color.
static (Shared in Visual Basic) | PANTONE2385 | Gets the PANTONE 2385 color.
static (Shared in Visual Basic) | PANTONE239 | Gets the PANTONE 239 color.
static (Shared in Visual Basic) | PANTONE2395 | Gets the PANTONE 2395 color.
static (Shared in Visual Basic) | PANTONE240 | Gets the PANTONE 240 color.
static (Shared in Visual Basic) | PANTONE2405 | Gets the PANTONE 2405 color.
static (Shared in Visual Basic) | PANTONE241 | Gets the PANTONE 241 color.
static (Shared in Visual Basic) | PANTONE2415 | Gets the PANTONE 2415 color.
static (Shared in Visual Basic) | PANTONE242 | Gets the PANTONE 242 color.
static (Shared in Visual Basic) | PANTONE2425 | Gets the PANTONE 2425 color.
static (Shared in Visual Basic) | PANTONE243 | Gets the PANTONE 243 color.
static (Shared in Visual Basic) | PANTONE244 | Gets the PANTONE 244 color.
static (Shared in Visual Basic) | PANTONE245 | Gets the PANTONE 245 color.
static (Shared in Visual Basic) | PANTONE246 | Gets the PANTONE 246 color.
static (Shared in Visual Basic) | PANTONE247 | Gets the PANTONE 247 color.
static (Shared in Visual Basic) | PANTONE248 | Gets the PANTONE 248 color.
static (Shared in Visual Basic) | PANTONE249 | Gets the PANTONE 249 color.
static (Shared in Visual Basic) | PANTONE250 | Gets the PANTONE 250 color.
static (Shared in Visual Basic) | PANTONE251 | Gets the PANTONE 251 color.
static (Shared in Visual Basic) | PANTONE252 | Gets the PANTONE 252 color.
static (Shared in Visual Basic) | PANTONE253 | Gets the PANTONE 253 color.
static (Shared in Visual Basic) | PANTONE254 | Gets the PANTONE 254 color.
static (Shared in Visual Basic) | PANTONE255 | Gets the PANTONE 255 color.
static (Shared in Visual Basic) | PANTONE256 | Gets the PANTONE 256 color.
static (Shared in Visual Basic) | PANTONE2562 | Gets the PANTONE 2562 color.
static (Shared in Visual Basic) | PANTONE2563 | Gets the PANTONE 2563 color.
static (Shared in Visual Basic) | PANTONE2567 | Gets the PANTONE 2567 color.
static (Shared in Visual Basic) | PANTONE257 | Gets the PANTONE 257 color.
static (Shared in Visual Basic) | PANTONE2572 | Gets the PANTONE 2572 color.
static (Shared in Visual Basic) | PANTONE2573 | Gets the PANTONE 2573 color.
static (Shared in Visual Basic) | PANTONE2577 | Gets the PANTONE 2577 color.
static (Shared in Visual Basic) | PANTONE258 | Gets the PANTONE 258 color.
static (Shared in Visual Basic) | PANTONE2582 | Gets the PANTONE 2582 color.
static (Shared in Visual Basic) | PANTONE2583 | Gets the PANTONE 2583 color.
static (Shared in Visual Basic) | PANTONE2587 | Gets the PANTONE 2587 color.
static (Shared in Visual Basic) | PANTONE259 | Gets the PANTONE 259 color.
static (Shared in Visual Basic) | PANTONE2592 | Gets the PANTONE 2592 color.
static (Shared in Visual Basic) | PANTONE2593 | Gets the PANTONE 2593 color.
static (Shared in Visual Basic) | PANTONE2597 | Gets the PANTONE 2597 color.
static (Shared in Visual Basic) | PANTONE260 | Gets the PANTONE 260 color.
static (Shared in Visual Basic) | PANTONE2602 | Gets the PANTONE 2602 color.
static (Shared in Visual Basic) | PANTONE2603 | Gets the PANTONE 2603 color.
static (Shared in Visual Basic) | PANTONE2607 | Gets the PANTONE 2607 color.
static (Shared in Visual Basic) | PANTONE261 | Gets the PANTONE 261 color.
static (Shared in Visual Basic) | PANTONE2612 | Gets the PANTONE 2612 color.
static (Shared in Visual Basic) | PANTONE2613 | Gets the PANTONE 2613 color.
static (Shared in Visual Basic) | PANTONE2617 | Gets the PANTONE 2617 color.
static (Shared in Visual Basic) | PANTONE262 | Gets the PANTONE 262 color.
static (Shared in Visual Basic) | PANTONE2622 | Gets the PANTONE 2622 color.
static (Shared in Visual Basic) | PANTONE2623 | Gets the PANTONE 2623 color.
static (Shared in Visual Basic) | PANTONE2627 | Gets the PANTONE 2627 color.
static (Shared in Visual Basic) | PANTONE263 | Gets the PANTONE 263 color.
static (Shared in Visual Basic) | PANTONE2635 | Gets the PANTONE 2635 color.
static (Shared in Visual Basic) | PANTONE264 | Gets the PANTONE 264 color.
static (Shared in Visual Basic) | PANTONE2645 | Gets the PANTONE 2645 color.
static (Shared in Visual Basic) | PANTONE265 | Gets the PANTONE 265 color.
static (Shared in Visual Basic) | PANTONE2655 | Gets the PANTONE 2655 color.
static (Shared in Visual Basic) | PANTONE266 | Gets the PANTONE 266 color.
static (Shared in Visual Basic) | PANTONE2665 | Gets the PANTONE 2665 color.
static (Shared in Visual Basic) | PANTONE267 | Gets the PANTONE 267 color.
static (Shared in Visual Basic) | PANTONE268 | Gets the PANTONE 268 color.
static (Shared in Visual Basic) | PANTONE2685 | Gets the PANTONE 2685 color.
static (Shared in Visual Basic) | PANTONE269 | Gets the PANTONE 269 color.
static (Shared in Visual Basic) | PANTONE2695 | Gets the PANTONE 2695 color.
static (Shared in Visual Basic) | PANTONE270 | Gets the PANTONE 270 color.
static (Shared in Visual Basic) | PANTONE2705 | Gets the PANTONE 2705 color.
static (Shared in Visual Basic) | PANTONE2706 | Gets the PANTONE 2706 color.
static (Shared in Visual Basic) | PANTONE2707 | Gets the PANTONE 2707 color.
static (Shared in Visual Basic) | PANTONE2708 | Gets the PANTONE 2708 color.
static (Shared in Visual Basic) | PANTONE271 | Gets the PANTONE 271 color.
static (Shared in Visual Basic) | PANTONE2715 | Gets the PANTONE 2715 color.
static (Shared in Visual Basic) | PANTONE2716 | Gets the PANTONE 2716 color.
static (Shared in Visual Basic) | PANTONE2717 | Gets the PANTONE 2717 color.
static (Shared in Visual Basic) | PANTONE2718 | Gets the PANTONE 2718 color.
static (Shared in Visual Basic) | PANTONE272 | Gets the PANTONE 272 color.
static (Shared in Visual Basic) | PANTONE2725 | Gets the PANTONE 2725 color.
static (Shared in Visual Basic) | PANTONE2726 | Gets the PANTONE 2726 color.
static (Shared in Visual Basic) | PANTONE2727 | Gets the PANTONE 2727 color.
static (Shared in Visual Basic) | PANTONE2728 | Gets the PANTONE 2728 color.
static (Shared in Visual Basic) | PANTONE273 | Gets the PANTONE 273 color.
static (Shared in Visual Basic) | PANTONE2735 | Gets the PANTONE 2735 color.
static (Shared in Visual Basic) | PANTONE2736 | Gets the PANTONE 2736 color.
static (Shared in Visual Basic) | PANTONE2738 | Gets the PANTONE 2738 color.
static (Shared in Visual Basic) | PANTONE274 | Gets the PANTONE 274 color.
static (Shared in Visual Basic) | PANTONE2745 | Gets the PANTONE 2745 color.
static (Shared in Visual Basic) | PANTONE2746 | Gets the PANTONE 2746 color.
static (Shared in Visual Basic) | PANTONE2747 | Gets the PANTONE 2747 color.
static (Shared in Visual Basic) | PANTONE2748 | Gets the PANTONE 2748 color.
static (Shared in Visual Basic) | PANTONE275 | Gets the PANTONE 275 color.
static (Shared in Visual Basic) | PANTONE2755 | Gets the PANTONE 2755 color.
static (Shared in Visual Basic) | PANTONE2756 | Gets the PANTONE 2756 color.
static (Shared in Visual Basic) | PANTONE2757 | Gets the PANTONE 2757 color.
static (Shared in Visual Basic) | PANTONE2758 | Gets the PANTONE 2758 color.
static (Shared in Visual Basic) | PANTONE276 | Gets the PANTONE 276 color.
static (Shared in Visual Basic) | PANTONE2765 | Gets the PANTONE 2765 color.
static (Shared in Visual Basic) | PANTONE2766 | Gets the PANTONE 2766 color.
static (Shared in Visual Basic) | PANTONE2767 | Gets the PANTONE 2767 color.
static (Shared in Visual Basic) | PANTONE2768 | Gets the PANTONE 2768 color.
static (Shared in Visual Basic) | PANTONE277 | Gets the PANTONE 277 color.
static (Shared in Visual Basic) | PANTONE278 | Gets the PANTONE 278 color.
static (Shared in Visual Basic) | PANTONE279 | Gets the PANTONE 279 color.
static (Shared in Visual Basic) | PANTONE280 | Gets the PANTONE 280 color.
static (Shared in Visual Basic) | PANTONE281 | Gets the PANTONE 281 color.
static (Shared in Visual Basic) | PANTONE282 | Gets the PANTONE 282 color.
static (Shared in Visual Basic) | PANTONE283 | Gets the PANTONE 283 color.
static (Shared in Visual Basic) | PANTONE284 | Gets the PANTONE 284 color.
static (Shared in Visual Basic) | PANTONE285 | Gets the PANTONE 285 color.
static (Shared in Visual Basic) | PANTONE286 | Gets the PANTONE 286 color.
static (Shared in Visual Basic) | PANTONE287 | Gets the PANTONE 287 color.
static (Shared in Visual Basic) | PANTONE288 | Gets the PANTONE 288 color.
static (Shared in Visual Basic) | PANTONE289 | Gets the PANTONE 289 color.
static (Shared in Visual Basic) | PANTONE290 | Gets the PANTONE 290 color.
static (Shared in Visual Basic) | PANTONE2905 | Gets the PANTONE 2905 color.
static (Shared in Visual Basic) | PANTONE291 | Gets the PANTONE 291 color.
static (Shared in Visual Basic) | PANTONE2915 | Gets the PANTONE 2915 color.
static (Shared in Visual Basic) | PANTONE292 | Gets the PANTONE 292 color.
static (Shared in Visual Basic) | PANTONE2925 | Gets the PANTONE 2925 color.
static (Shared in Visual Basic) | PANTONE293 | Gets the PANTONE 293 color.
static (Shared in Visual Basic) | PANTONE2935 | Gets the PANTONE 2935 color.
static (Shared in Visual Basic) | PANTONE294 | Gets the PANTONE 294 color.
static (Shared in Visual Basic) | PANTONE2945 | Gets the PANTONE 2945 color.
static (Shared in Visual Basic) | PANTONE295 | Gets the PANTONE 295 color.
static (Shared in Visual Basic) | PANTONE2955 | Gets the PANTONE 2955 color.
static (Shared in Visual Basic) | PANTONE296 | Gets the PANTONE 296 color.
static (Shared in Visual Basic) | PANTONE2965 | Gets the PANTONE 2965 color.
static (Shared in Visual Basic) | PANTONE297 | Gets the PANTONE 297 color.
static (Shared in Visual Basic) | PANTONE2975 | Gets the PANTONE 2975 color.
static (Shared in Visual Basic) | PANTONE298 | Gets the PANTONE 298 color.
static (Shared in Visual Basic) | PANTONE2985 | Gets the PANTONE 2985 color.
static (Shared in Visual Basic) | PANTONE299 | Gets the PANTONE 299 color.
static (Shared in Visual Basic) | PANTONE2995 | Gets the PANTONE 2995 color.
static (Shared in Visual Basic) | PANTONE300 | Gets the PANTONE 300 color.
static (Shared in Visual Basic) | PANTONE3005 | Gets the PANTONE 3005 color.
static (Shared in Visual Basic) | PANTONE301 | Gets the PANTONE 301 color.
static (Shared in Visual Basic) | PANTONE3015 | Gets the PANTONE 3015 color.
static (Shared in Visual Basic) | PANTONE302 | Gets the PANTONE 302 color.
static (Shared in Visual Basic) | PANTONE3025 | Gets the PANTONE 3025 color.
static (Shared in Visual Basic) | PANTONE303 | Gets the PANTONE 303 color.
static (Shared in Visual Basic) | PANTONE3035 | Gets the PANTONE 3035 color.
static (Shared in Visual Basic) | PANTONE304 | Gets the PANTONE 304 color.
static (Shared in Visual Basic) | PANTONE305 | Gets the PANTONE 305 color.
static (Shared in Visual Basic) | PANTONE306 | Gets the PANTONE 306 color.
static (Shared in Visual Basic) | PANTONE307 | Gets the PANTONE 307 color.
static (Shared in Visual Basic) | PANTONE308 | Gets the PANTONE 308 color.
static (Shared in Visual Basic) | PANTONE309 | Gets the PANTONE 309 color.
static (Shared in Visual Basic) | PANTONE310 | Gets the PANTONE 310 color.
static (Shared in Visual Basic) | PANTONE3105 | Gets the PANTONE 3105 color.
static (Shared in Visual Basic) | PANTONE311 | Gets the PANTONE 311 color.
static (Shared in Visual Basic) | PANTONE3115 | Gets the PANTONE 3115 color.
static (Shared in Visual Basic) | PANTONE312 | Gets the PANTONE 312 color.
static (Shared in Visual Basic) | PANTONE3125 | Gets the PANTONE 3125 color.
static (Shared in Visual Basic) | PANTONE313 | Gets the PANTONE 313 color.
static (Shared in Visual Basic) | PANTONE3135 | Gets the PANTONE 3135 color.
static (Shared in Visual Basic) | PANTONE314 | Gets the PANTONE 314 color.
static (Shared in Visual Basic) | PANTONE3145 | Gets the PANTONE 3145 color.
static (Shared in Visual Basic) | PANTONE315 | Gets the PANTONE 315 color.
static (Shared in Visual Basic) | PANTONE3155 | Gets the PANTONE 3155 color.
static (Shared in Visual Basic) | PANTONE316 | Gets the PANTONE 316 color.
static (Shared in Visual Basic) | PANTONE3165 | Gets the PANTONE 3165 color.
static (Shared in Visual Basic) | PANTONE317 | Gets the PANTONE 317 color.
static (Shared in Visual Basic) | PANTONE318 | Gets the PANTONE 318 color.
static (Shared in Visual Basic) | PANTONE319 | Gets the PANTONE 319 color.
static (Shared in Visual Basic) | PANTONE320 | Gets the PANTONE 320 color.
static (Shared in Visual Basic) | PANTONE321 | Gets the PANTONE 321 color.
static (Shared in Visual Basic) | PANTONE322 | Gets the PANTONE 322 color.
static (Shared in Visual Basic) | PANTONE323 | Gets the PANTONE 323 color.
static (Shared in Visual Basic) | PANTONE324 | Gets the PANTONE 324 color.
static (Shared in Visual Basic) | PANTONE3242 | Gets the PANTONE 3242 color.
static (Shared in Visual Basic) | PANTONE3245 | Gets the PANTONE 3245 color.
static (Shared in Visual Basic) | PANTONE3248 | Gets the PANTONE 3248 color.
static (Shared in Visual Basic) | PANTONE325 | Gets the PANTONE 325 color.
static (Shared in Visual Basic) | PANTONE3252 | Gets the PANTONE 3252 color.
static (Shared in Visual Basic) | PANTONE3255 | Gets the PANTONE 3255 color.
static (Shared in Visual Basic) | PANTONE3258 | Gets the PANTONE 3258 color.
static (Shared in Visual Basic) | PANTONE326 | Gets the PANTONE 326 color.
static (Shared in Visual Basic) | PANTONE3262 | Gets the PANTONE 3262 color.
static (Shared in Visual Basic) | PANTONE3265 | Gets the PANTONE 3265 color.
static (Shared in Visual Basic) | PANTONE3268 | Gets the PANTONE 3268 color.
static (Shared in Visual Basic) | PANTONE327 | Gets the PANTONE 327 color.
static (Shared in Visual Basic) | PANTONE3272 | Gets the PANTONE 3272 color.
static (Shared in Visual Basic) | PANTONE3275 | Gets the PANTONE 3275 color.
static (Shared in Visual Basic) | PANTONE3278 | Gets the PANTONE 3278 color.
static (Shared in Visual Basic) | PANTONE328 | Gets the PANTONE 328 color.
static (Shared in Visual Basic) | PANTONE3282 | Gets the PANTONE 3282 color.
static (Shared in Visual Basic) | PANTONE3285 | Gets the PANTONE 3285 color.
static (Shared in Visual Basic) | PANTONE3288 | Gets the PANTONE 3288 color.
static (Shared in Visual Basic) | PANTONE329 | Gets the PANTONE 329 color.
static (Shared in Visual Basic) | PANTONE3292 | Gets the PANTONE 3292 color.
static (Shared in Visual Basic) | PANTONE3295 | Gets the PANTONE 3295 color.
static (Shared in Visual Basic) | PANTONE3298 | Gets the PANTONE 3298 color.
static (Shared in Visual Basic) | PANTONE330 | Gets the PANTONE 330 color.
static (Shared in Visual Basic) | PANTONE3302 | Gets the PANTONE 3302 color.
static (Shared in Visual Basic) | PANTONE3305 | Gets the PANTONE 3305 color.
static (Shared in Visual Basic) | PANTONE3308 | Gets the PANTONE 3308 color.
static (Shared in Visual Basic) | PANTONE331 | Gets the PANTONE 331 color.
static (Shared in Visual Basic) | PANTONE332 | Gets the PANTONE 332 color.
static (Shared in Visual Basic) | PANTONE333 | Gets the PANTONE 333 color.
static (Shared in Visual Basic) | PANTONE334 | Gets the PANTONE 334 color.
static (Shared in Visual Basic) | PANTONE335 | Gets the PANTONE 335 color.
static (Shared in Visual Basic) | PANTONE336 | Gets the PANTONE 336 color.
static (Shared in Visual Basic) | PANTONE337 | Gets the PANTONE 337 color.
static (Shared in Visual Basic) | PANTONE3375 | Gets the PANTONE 3375 color.
static (Shared in Visual Basic) | PANTONE338 | Gets the PANTONE 338 color.
static (Shared in Visual Basic) | PANTONE3385 | Gets the PANTONE 3385 color.
static (Shared in Visual Basic) | PANTONE339 | Gets the PANTONE 339 color.
static (Shared in Visual Basic) | PANTONE3395 | Gets the PANTONE 3395 color.
static (Shared in Visual Basic) | PANTONE340 | Gets the PANTONE 340 color.
static (Shared in Visual Basic) | PANTONE3405 | Gets the PANTONE 3405 color.
static (Shared in Visual Basic) | PANTONE341 | Gets the PANTONE 341 color.
static (Shared in Visual Basic) | PANTONE3415 | Gets the PANTONE 3415 color.
static (Shared in Visual Basic) | PANTONE342 | Gets the PANTONE 342 color.
static (Shared in Visual Basic) | PANTONE3425 | Gets the PANTONE 3425 color.
static (Shared in Visual Basic) | PANTONE343 | Gets the PANTONE 343 color.
static (Shared in Visual Basic) | PANTONE3435 | Gets the PANTONE 3435 color.
static (Shared in Visual Basic) | PANTONE344 | Gets the PANTONE 344 color.
static (Shared in Visual Basic) | PANTONE345 | Gets the PANTONE 345 color.
static (Shared in Visual Basic) | PANTONE346 | Gets the PANTONE 346 color.
static (Shared in Visual Basic) | PANTONE347 | Gets the PANTONE 347 color.
static (Shared in Visual Basic) | PANTONE348 | Gets the PANTONE 348 color.
static (Shared in Visual Basic) | PANTONE349 | Gets the PANTONE 349 color.
static (Shared in Visual Basic) | PANTONE350 | Gets the PANTONE 350 color.
static (Shared in Visual Basic) | PANTONE351 | Gets the PANTONE 351 color.
static (Shared in Visual Basic) | PANTONE352 | Gets the PANTONE 352 color.
static (Shared in Visual Basic) | PANTONE353 | Gets the PANTONE 353 color.
static (Shared in Visual Basic) | PANTONE354 | Gets the PANTONE 354 color.
static (Shared in Visual Basic) | PANTONE355 | Gets the PANTONE 355 color.
static (Shared in Visual Basic) | PANTONE356 | Gets the PANTONE 356 color.
static (Shared in Visual Basic) | PANTONE357 | Gets the PANTONE 357 color.
static (Shared in Visual Basic) | PANTONE358 | Gets the PANTONE 358 color.
static (Shared in Visual Basic) | PANTONE359 | Gets the PANTONE 359 color.
static (Shared in Visual Basic) | PANTONE360 | Gets the PANTONE 360 color.
static (Shared in Visual Basic) | PANTONE361 | Gets the PANTONE 361 color.
static (Shared in Visual Basic) | PANTONE362 | Gets the PANTONE 362 color.
static (Shared in Visual Basic) | PANTONE363 | Gets the PANTONE 363 color.
static (Shared in Visual Basic) | PANTONE364 | Gets the PANTONE 364 color.
static (Shared in Visual Basic) | PANTONE365 | Gets the PANTONE 365 color.
static (Shared in Visual Basic) | PANTONE366 | Gets the PANTONE 366 color.
static (Shared in Visual Basic) | PANTONE367 | Gets the PANTONE 367 color.
static (Shared in Visual Basic) | PANTONE368 | Gets the PANTONE 368 color.
static (Shared in Visual Basic) | PANTONE369 | Gets the PANTONE 369 color.
static (Shared in Visual Basic) | PANTONE370 | Gets the PANTONE 370 color.
static (Shared in Visual Basic) | PANTONE371 | Gets the PANTONE 371 color.
static (Shared in Visual Basic) | PANTONE372 | Gets the PANTONE 372 color.
static (Shared in Visual Basic) | PANTONE373 | Gets the PANTONE 373 color.
static (Shared in Visual Basic) | PANTONE374 | Gets the PANTONE 374 color.
static (Shared in Visual Basic) | PANTONE375 | Gets the PANTONE 375 color.
static (Shared in Visual Basic) | PANTONE376 | Gets the PANTONE 376 color.
static (Shared in Visual Basic) | PANTONE377 | Gets the PANTONE 377 color.
static (Shared in Visual Basic) | PANTONE378 | Gets the PANTONE 378 color.
static (Shared in Visual Basic) | PANTONE379 | Gets the PANTONE 379 color.
static (Shared in Visual Basic) | PANTONE380 | Gets the PANTONE 380 color.
static (Shared in Visual Basic) | PANTONE381 | Gets the PANTONE 381 color.
static (Shared in Visual Basic) | PANTONE382 | Gets the PANTONE 382 color.
static (Shared in Visual Basic) | PANTONE383 | Gets the PANTONE 383 color.
static (Shared in Visual Basic) | PANTONE384 | Gets the PANTONE 384 color.
static (Shared in Visual Basic) | PANTONE385 | Gets the PANTONE 385 color.
static (Shared in Visual Basic) | PANTONE386 | Gets the PANTONE 386 color.
static (Shared in Visual Basic) | PANTONE387 | Gets the PANTONE 387 color.
static (Shared in Visual Basic) | PANTONE388 | Gets the PANTONE 388 color.
static (Shared in Visual Basic) | PANTONE389 | Gets the PANTONE 389 color.
static (Shared in Visual Basic) | PANTONE390 | Gets the PANTONE 390 color.
static (Shared in Visual Basic) | PANTONE391 | Gets the PANTONE 391 color.
static (Shared in Visual Basic) | PANTONE392 | Gets the PANTONE 392 color.
static (Shared in Visual Basic) | PANTONE393 | Gets the PANTONE 393 color.
static (Shared in Visual Basic) | PANTONE3935 | Gets the PANTONE 3935 color.
static (Shared in Visual Basic) | PANTONE394 | Gets the PANTONE 394 color.
static (Shared in Visual Basic) | PANTONE3945 | Gets the PANTONE 3945 color.
static (Shared in Visual Basic) | PANTONE395 | Gets the PANTONE 395 color.
static (Shared in Visual Basic) | PANTONE3955 | Gets the PANTONE 3955 color.
static (Shared in Visual Basic) | PANTONE396 | Gets the PANTONE 396 color.
static (Shared in Visual Basic) | PANTONE3965 | Gets the PANTONE 3965 color.
static (Shared in Visual Basic) | PANTONE397 | Gets the PANTONE 397 color.
static (Shared in Visual Basic) | PANTONE3975 | Gets the PANTONE 3975 color.
static (Shared in Visual Basic) | PANTONE398 | Gets the PANTONE 398 color.
static (Shared in Visual Basic) | PANTONE3985 | Gets the PANTONE 3985 color.
static (Shared in Visual Basic) | PANTONE399 | Gets the PANTONE 399 color.
static (Shared in Visual Basic) | PANTONE3995 | Gets the PANTONE 3995 color.
static (Shared in Visual Basic) | PANTONE400 | Gets the PANTONE 400 color.
static (Shared in Visual Basic) | PANTONE401 | Gets the PANTONE 401 color.
static (Shared in Visual Basic) | PANTONE402 | Gets the PANTONE 402 color.
static (Shared in Visual Basic) | PANTONE403 | Gets the PANTONE 403 color.
static (Shared in Visual Basic) | PANTONE404 | Gets the PANTONE 404 color.
static (Shared in Visual Basic) | PANTONE405 | Gets the PANTONE 405 color.
static (Shared in Visual Basic) | PANTONE406 | Gets the PANTONE 406 color.
static (Shared in Visual Basic) | PANTONE407 | Gets the PANTONE 407 color.
static (Shared in Visual Basic) | PANTONE408 | Gets the PANTONE 408 color.
static (Shared in Visual Basic) | PANTONE409 | Gets the PANTONE 409 color.
static (Shared in Visual Basic) | PANTONE410 | Gets the PANTONE 410 color.
static (Shared in Visual Basic) | PANTONE411 | Gets the PANTONE 411 color.
static (Shared in Visual Basic) | PANTONE412 | Gets the PANTONE 412 color.
static (Shared in Visual Basic) | PANTONE413 | Gets the PANTONE 413 color.
static (Shared in Visual Basic) | PANTONE414 | Gets the PANTONE 414 color.
static (Shared in Visual Basic) | PANTONE415 | Gets the PANTONE 415 color.
static (Shared in Visual Basic) | PANTONE416 | Gets the PANTONE 416 color.
static (Shared in Visual Basic) | PANTONE417 | Gets the PANTONE 417 color.
static (Shared in Visual Basic) | PANTONE418 | Gets the PANTONE 418 color.
static (Shared in Visual Basic) | PANTONE419 | Gets the PANTONE 419 color.
static (Shared in Visual Basic) | PANTONE420 | Gets the PANTONE 420 color.
static (Shared in Visual Basic) | PANTONE421 | Gets the PANTONE 421 color.
static (Shared in Visual Basic) | PANTONE422 | Gets the PANTONE 422 color.
static (Shared in Visual Basic) | PANTONE423 | Gets the PANTONE 423 color.
static (Shared in Visual Basic) | PANTONE424 | Gets the PANTONE 424 color.
static (Shared in Visual Basic) | PANTONE425 | Gets the PANTONE 425 color.
static (Shared in Visual Basic) | PANTONE426 | Gets the PANTONE 426 color.
static (Shared in Visual Basic) | PANTONE427 | Gets the PANTONE 427 color.
static (Shared in Visual Basic) | PANTONE428 | Gets the PANTONE 428 color.
static (Shared in Visual Basic) | PANTONE429 | Gets the PANTONE 429 color.
static (Shared in Visual Basic) | PANTONE430 | Gets the PANTONE 430 color.
static (Shared in Visual Basic) | PANTONE431 | Gets the PANTONE 431 color.
static (Shared in Visual Basic) | PANTONE432 | Gets the PANTONE 432 color.
static (Shared in Visual Basic) | PANTONE433 | Gets the PANTONE 433 color.
static (Shared in Visual Basic) | PANTONE434 | Gets the PANTONE 434 color.
static (Shared in Visual Basic) | PANTONE435 | Gets the PANTONE 435 color.
static (Shared in Visual Basic) | PANTONE436 | Gets the PANTONE 436 color.
static (Shared in Visual Basic) | PANTONE437 | Gets the PANTONE 437 color.
static (Shared in Visual Basic) | PANTONE438 | Gets the PANTONE 438 color.
static (Shared in Visual Basic) | PANTONE439 | Gets the PANTONE 439 color.
static (Shared in Visual Basic) | PANTONE440 | Gets the PANTONE 440 color.
static (Shared in Visual Basic) | PANTONE441 | Gets the PANTONE 441 color.
static (Shared in Visual Basic) | PANTONE442 | Gets the PANTONE 442 color.
static (Shared in Visual Basic) | PANTONE443 | Gets the PANTONE 443 color.
static (Shared in Visual Basic) | PANTONE444 | Gets the PANTONE 444 color.
static (Shared in Visual Basic) | PANTONE445 | Gets the PANTONE 445 color.
static (Shared in Visual Basic) | PANTONE446 | Gets the PANTONE 446 color.
static (Shared in Visual Basic) | PANTONE447 | Gets the PANTONE 447 color.
static (Shared in Visual Basic) | PANTONE448 | Gets the PANTONE 448 color.
static (Shared in Visual Basic) | PANTONE4485 | Gets the PANTONE 4485 color.
static (Shared in Visual Basic) | PANTONE449 | Gets the PANTONE 449 color.
static (Shared in Visual Basic) | PANTONE4495 | Gets the PANTONE 4495 color.
static (Shared in Visual Basic) | PANTONE450 | Gets the PANTONE 450 color.
static (Shared in Visual Basic) | PANTONE4505 | Gets the PANTONE 4505 color.
static (Shared in Visual Basic) | PANTONE451 | Gets the PANTONE 451 color.
static (Shared in Visual Basic) | PANTONE4515 | Gets the PANTONE 4515 color.
static (Shared in Visual Basic) | PANTONE452 | Gets the PANTONE 452 color.
static (Shared in Visual Basic) | PANTONE4525 | Gets the PANTONE 4525 color.
static (Shared in Visual Basic) | PANTONE453 | Gets the PANTONE 453 color.
static (Shared in Visual Basic) | PANTONE4535 | Gets the PANTONE 4535 color.
static (Shared in Visual Basic) | PANTONE454 | Gets the PANTONE 454 color.
static (Shared in Visual Basic) | PANTONE4545 | Gets the PANTONE 4545 color.
static (Shared in Visual Basic) | PANTONE455 | Gets the PANTONE 455 color.
static (Shared in Visual Basic) | PANTONE456 | Gets the PANTONE 456 color.
static (Shared in Visual Basic) | PANTONE457 | Gets the PANTONE 457 color.
static (Shared in Visual Basic) | PANTONE458 | Gets the PANTONE 458 color.
static (Shared in Visual Basic) | PANTONE459 | Gets the PANTONE 459 color.
static (Shared in Visual Basic) | PANTONE460 | Gets the PANTONE 460 color.
static (Shared in Visual Basic) | PANTONE461 | Gets the PANTONE 461 color.
static (Shared in Visual Basic) | PANTONE462 | Gets the PANTONE 462 color.
static (Shared in Visual Basic) | PANTONE4625 | Gets the PANTONE 4625 color.
static (Shared in Visual Basic) | PANTONE463 | Gets the PANTONE 463 color.
static (Shared in Visual Basic) | PANTONE4635 | Gets the PANTONE 4635 color.
static (Shared in Visual Basic) | PANTONE464 | Gets the PANTONE 464 color.
static (Shared in Visual Basic) | PANTONE4645 | Gets the PANTONE 4645 color.
static (Shared in Visual Basic) | PANTONE465 | Gets the PANTONE 465 color.
static (Shared in Visual Basic) | PANTONE4655 | Gets the PANTONE 4655 color.
static (Shared in Visual Basic) | PANTONE466 | Gets the PANTONE 466 color.
static (Shared in Visual Basic) | PANTONE4665 | Gets the PANTONE 4665 color.
static (Shared in Visual Basic) | PANTONE467 | Gets the PANTONE 467 color.
static (Shared in Visual Basic) | PANTONE4675 | Gets the PANTONE 4675 color.
static (Shared in Visual Basic) | PANTONE468 | Gets the PANTONE 468 color.
static (Shared in Visual Basic) | PANTONE4685 | Gets the PANTONE 4685 color.
static (Shared in Visual Basic) | PANTONE469 | Gets the PANTONE 469 color.
static (Shared in Visual Basic) | PANTONE4695 | Gets the PANTONE 4695 color.
static (Shared in Visual Basic) | PANTONE470 | Gets the PANTONE 470 color.
static (Shared in Visual Basic) | PANTONE4705 | Gets the PANTONE 4705 color.
static (Shared in Visual Basic) | PANTONE471 | Gets the PANTONE 471 color.
static (Shared in Visual Basic) | PANTONE4715 | Gets the PANTONE 4715 color.
static (Shared in Visual Basic) | PANTONE472 | Gets the PANTONE 472 color.
static (Shared in Visual Basic) | PANTONE4725 | Gets the PANTONE 4725 color.
static (Shared in Visual Basic) | PANTONE473 | Gets the PANTONE 473 color.
static (Shared in Visual Basic) | PANTONE4735 | Gets the PANTONE 4735 color.
static (Shared in Visual Basic) | PANTONE474 | Gets the PANTONE 474 color.
static (Shared in Visual Basic) | PANTONE4745 | Gets the PANTONE 4745 color.
static (Shared in Visual Basic) | PANTONE475 | Gets the PANTONE 475 color.
static (Shared in Visual Basic) | PANTONE4755 | Gets the PANTONE 4755 color.
static (Shared in Visual Basic) | PANTONE476 | Gets the PANTONE 476 color.
static (Shared in Visual Basic) | PANTONE477 | Gets the PANTONE 477 color.
static (Shared in Visual Basic) | PANTONE478 | Gets the PANTONE 478 color.
static (Shared in Visual Basic) | PANTONE479 | Gets the PANTONE 479 color.
static (Shared in Visual Basic) | PANTONE480 | Gets the PANTONE 480 color.
static (Shared in Visual Basic) | PANTONE481 | Gets the PANTONE 481 color.
static (Shared in Visual Basic) | PANTONE482 | Gets the PANTONE 482 color.
static (Shared in Visual Basic) | PANTONE483 | Gets the PANTONE 483 color.
static (Shared in Visual Basic) | PANTONE484 | Gets the PANTONE 484 color.
static (Shared in Visual Basic) | PANTONE485 | Gets the PANTONE 485 color.
static (Shared in Visual Basic) | PANTONE486 | Gets the PANTONE 486 color.
static (Shared in Visual Basic) | PANTONE487 | Gets the PANTONE 487 color.
static (Shared in Visual Basic) | PANTONE488 | Gets the PANTONE 488 color.
static (Shared in Visual Basic) | PANTONE489 | Gets the PANTONE 489 color.
static (Shared in Visual Basic) | PANTONE490 | Gets the PANTONE 490 color.
static (Shared in Visual Basic) | PANTONE491 | Gets the PANTONE 491 color.
static (Shared in Visual Basic) | PANTONE492 | Gets the PANTONE 492 color.
static (Shared in Visual Basic) | PANTONE493 | Gets the PANTONE 493 color.
static (Shared in Visual Basic) | PANTONE494 | Gets the PANTONE 494 color.
static (Shared in Visual Basic) | PANTONE495 | Gets the PANTONE 495 color.
static (Shared in Visual Basic) | PANTONE496 | Gets the PANTONE 496 color.
static (Shared in Visual Basic) | PANTONE497 | Gets the PANTONE 497 color.
static (Shared in Visual Basic) | PANTONE4975 | Gets the PANTONE 4975 color.
static (Shared in Visual Basic) | PANTONE498 | Gets the PANTONE 498 color.
static (Shared in Visual Basic) | PANTONE4985 | Gets the PANTONE 4985 color.
static (Shared in Visual Basic) | PANTONE499 | Gets the PANTONE 499 color.
static (Shared in Visual Basic) | PANTONE4995 | Gets the PANTONE 4995 color.
static (Shared in Visual Basic) | PANTONE500 | Gets the PANTONE 500 color.
static (Shared in Visual Basic) | PANTONE5005 | Gets the PANTONE 5005 color.
static (Shared in Visual Basic) | PANTONE501 | Gets the PANTONE 501 color.
static (Shared in Visual Basic) | PANTONE5015 | Gets the PANTONE 5015 color.
static (Shared in Visual Basic) | PANTONE502 | Gets the PANTONE 502 color.
static (Shared in Visual Basic) | PANTONE5025 | Gets the PANTONE 5025 color.
static (Shared in Visual Basic) | PANTONE503 | Gets the PANTONE 503 color.
static (Shared in Visual Basic) | PANTONE5035 | Gets the PANTONE 5035 color.
static (Shared in Visual Basic) | PANTONE504 | Gets the PANTONE 504 color.
static (Shared in Visual Basic) | PANTONE505 | Gets the PANTONE 505 color.
static (Shared in Visual Basic) | PANTONE506 | Gets the PANTONE 506 color.
static (Shared in Visual Basic) | PANTONE507 | Gets the PANTONE 507 color.
static (Shared in Visual Basic) | PANTONE508 | Gets the PANTONE 508 color.
static (Shared in Visual Basic) | PANTONE509 | Gets the PANTONE 509 color.
static (Shared in Visual Basic) | PANTONE510 | Gets the PANTONE 510 color.
static (Shared in Visual Basic) | PANTONE511 | Gets the PANTONE 511 color.
static (Shared in Visual Basic) | PANTONE5115 | Gets the PANTONE 5115 color.
static (Shared in Visual Basic) | PANTONE512 | Gets the PANTONE 512 color.
static (Shared in Visual Basic) | PANTONE5125 | Gets the PANTONE 5125 color.
static (Shared in Visual Basic) | PANTONE513 | Gets the PANTONE 513 color.
static (Shared in Visual Basic) | PANTONE5135 | Gets the PANTONE 5135 color.
static (Shared in Visual Basic) | PANTONE514 | Gets the PANTONE 514 color.
static (Shared in Visual Basic) | PANTONE5145 | Gets the PANTONE 5145 color.
static (Shared in Visual Basic) | PANTONE515 | Gets the PANTONE 515 color.
static (Shared in Visual Basic) | PANTONE5155 | Gets the PANTONE 5155 color.
static (Shared in Visual Basic) | PANTONE516 | Gets the PANTONE 516 color.
static (Shared in Visual Basic) | PANTONE5165 | Gets the PANTONE 5165 color.
static (Shared in Visual Basic) | PANTONE517 | Gets the PANTONE 517 color.
static (Shared in Visual Basic) | PANTONE5175 | Gets the PANTONE 5175 color.
static (Shared in Visual Basic) | PANTONE518 | Gets the PANTONE 518 color.
static (Shared in Visual Basic) | PANTONE5185 | Gets the PANTONE 5185 color.
static (Shared in Visual Basic) | PANTONE519 | Gets the PANTONE 519 color.
static (Shared in Visual Basic) | PANTONE5195 | Gets the PANTONE 5195 color.
static (Shared in Visual Basic) | PANTONE520 | Gets the PANTONE 520 color.
static (Shared in Visual Basic) | PANTONE5205 | Gets the PANTONE 5205 color.
static (Shared in Visual Basic) | PANTONE521 | Gets the PANTONE 521 color.
static (Shared in Visual Basic) | PANTONE5215 | Gets the PANTONE 5215 color.
static (Shared in Visual Basic) | PANTONE522 | Gets the PANTONE 522 color.
static (Shared in Visual Basic) | PANTONE5225 | Gets the PANTONE 5225 color.
static (Shared in Visual Basic) | PANTONE523 | Gets the PANTONE 523 color.
static (Shared in Visual Basic) | PANTONE5235 | Gets the PANTONE 5235 color.
static (Shared in Visual Basic) | PANTONE524 | Gets the PANTONE 524 color.
static (Shared in Visual Basic) | PANTONE5245 | Gets the PANTONE 5245 color.
static (Shared in Visual Basic) | PANTONE525 | Gets the PANTONE 525 color.
static (Shared in Visual Basic) | PANTONE5255 | Gets the PANTONE 5255 color.
static (Shared in Visual Basic) | PANTONE526 | Gets the PANTONE 526 color.
static (Shared in Visual Basic) | PANTONE5265 | Gets the PANTONE 5265 color.
static (Shared in Visual Basic) | PANTONE527 | Gets the PANTONE 527 color.
static (Shared in Visual Basic) | PANTONE5275 | Gets the PANTONE 5275 color.
static (Shared in Visual Basic) | PANTONE528 | Gets the PANTONE 528 color.
static (Shared in Visual Basic) | PANTONE5285 | Gets the PANTONE 5285 color.
static (Shared in Visual Basic) | PANTONE529 | Gets the PANTONE 529 color.
static (Shared in Visual Basic) | PANTONE5295 | Gets the PANTONE 5295 color.
static (Shared in Visual Basic) | PANTONE530 | Gets the PANTONE 530 color.
static (Shared in Visual Basic) | PANTONE5305 | Gets the PANTONE 5305 color.
static (Shared in Visual Basic) | PANTONE531 | Gets the PANTONE 531 color.
static (Shared in Visual Basic) | PANTONE5315 | Gets the PANTONE 5315 color.
static (Shared in Visual Basic) | PANTONE532 | Gets the PANTONE 532 color.
static (Shared in Visual Basic) | PANTONE533 | Gets the PANTONE 533 color.
static (Shared in Visual Basic) | PANTONE534 | Gets the PANTONE 534 color.
static (Shared in Visual Basic) | PANTONE535 | Gets the PANTONE 535 color.
static (Shared in Visual Basic) | PANTONE536 | Gets the PANTONE 536 color.
static (Shared in Visual Basic) | PANTONE537 | Gets the PANTONE 537 color.
static (Shared in Visual Basic) | PANTONE538 | Gets the PANTONE 538 color.
static (Shared in Visual Basic) | PANTONE539 | Gets the PANTONE 539 color.
static (Shared in Visual Basic) | PANTONE5395 | Gets the PANTONE 5395 color.
static (Shared in Visual Basic) | PANTONE540 | Gets the PANTONE 540 color.
static (Shared in Visual Basic) | PANTONE5405 | Gets the PANTONE 5405 color.
static (Shared in Visual Basic) | PANTONE541 | Gets the PANTONE 541 color.
static (Shared in Visual Basic) | PANTONE5415 | Gets the PANTONE 5415 color.
static (Shared in Visual Basic) | PANTONE542 | Gets the PANTONE 542 color.
static (Shared in Visual Basic) | PANTONE5425 | Gets the PANTONE 5425 color.
static (Shared in Visual Basic) | PANTONE543 | Gets the PANTONE 543 color.
static (Shared in Visual Basic) | PANTONE5435 | Gets the PANTONE 5435 color.
static (Shared in Visual Basic) | PANTONE544 | Gets the PANTONE 544 color.
static (Shared in Visual Basic) | PANTONE5445 | Gets the PANTONE 5445 color.
static (Shared in Visual Basic) | PANTONE545 | Gets the PANTONE 545 color.
static (Shared in Visual Basic) | PANTONE5455 | Gets the PANTONE 5455 color.
static (Shared in Visual Basic) | PANTONE546 | Gets the PANTONE 546 color.
static (Shared in Visual Basic) | PANTONE5463 | Gets the PANTONE 5463 color.
static (Shared in Visual Basic) | PANTONE5467 | Gets the PANTONE 5467 color.
static (Shared in Visual Basic) | PANTONE547 | Gets the PANTONE 547 color.
static (Shared in Visual Basic) | PANTONE5473 | Gets the PANTONE 5473 color.
static (Shared in Visual Basic) | PANTONE5477 | Gets the PANTONE 5477 color.
static (Shared in Visual Basic) | PANTONE548 | Gets the PANTONE 548 color.
static (Shared in Visual Basic) | PANTONE5483 | Gets the PANTONE 5483 color.
static (Shared in Visual Basic) | PANTONE5487 | Gets the PANTONE 5487 color.
static (Shared in Visual Basic) | PANTONE549 | Gets the PANTONE 549 color.
static (Shared in Visual Basic) | PANTONE5493 | Gets the PANTONE 5493 color.
static (Shared in Visual Basic) | PANTONE5497 | Gets the PANTONE 5497 color.
static (Shared in Visual Basic) | PANTONE550 | Gets the PANTONE 550 color.
static (Shared in Visual Basic) | PANTONE5503 | Gets the PANTONE 5503 color.
static (Shared in Visual Basic) | PANTONE5507 | Gets the PANTONE 5507 color.
static (Shared in Visual Basic) | PANTONE551 | Gets the PANTONE 551 color.
static (Shared in Visual Basic) | PANTONE5513 | Gets the PANTONE 5513 color.
static (Shared in Visual Basic) | PANTONE5517 | Gets the PANTONE 5517 color.
static (Shared in Visual Basic) | PANTONE552 | Gets the PANTONE 552 color.
static (Shared in Visual Basic) | PANTONE5523 | Gets the PANTONE 5523 color.
static (Shared in Visual Basic) | PANTONE5527 | Gets the PANTONE 5527 color.
static (Shared in Visual Basic) | PANTONE553 | Gets the PANTONE 553 color.
static (Shared in Visual Basic) | PANTONE5535 | Gets the PANTONE 5535 color.
static (Shared in Visual Basic) | PANTONE554 | Gets the PANTONE 554 color.
static (Shared in Visual Basic) | PANTONE5545 | Gets the PANTONE 5545 color.
static (Shared in Visual Basic) | PANTONE555 | Gets the PANTONE 555 color.
static (Shared in Visual Basic) | PANTONE5555 | Gets the PANTONE 5555 color.
static (Shared in Visual Basic) | PANTONE556 | Gets the PANTONE 556 color.
static (Shared in Visual Basic) | PANTONE5565 | Gets the PANTONE 5565 color.
static (Shared in Visual Basic) | PANTONE557 | Gets the PANTONE 557 color.
static (Shared in Visual Basic) | PANTONE5575 | Gets the PANTONE 5575 color.
static (Shared in Visual Basic) | PANTONE558 | Gets the PANTONE 558 color.
static (Shared in Visual Basic) | PANTONE5585 | Gets the PANTONE 5585 color.
static (Shared in Visual Basic) | PANTONE559 | Gets the PANTONE 559 color.
static (Shared in Visual Basic) | PANTONE5595 | Gets the PANTONE 5595 color.
static (Shared in Visual Basic) | PANTONE560 | Gets the PANTONE 560 color.
static (Shared in Visual Basic) | PANTONE5605 | Gets the PANTONE 5605 color.
static (Shared in Visual Basic) | PANTONE561 | Gets the PANTONE 561 color.
static (Shared in Visual Basic) | PANTONE5615 | Gets the PANTONE 5615 color.
static (Shared in Visual Basic) | PANTONE562 | Gets the PANTONE 562 color.
static (Shared in Visual Basic) | PANTONE5625 | Gets the PANTONE 5625 color.
static (Shared in Visual Basic) | PANTONE563 | Gets the PANTONE 563 color.
static (Shared in Visual Basic) | PANTONE5635 | Gets the PANTONE 5635 color.
static (Shared in Visual Basic) | PANTONE564 | Gets the PANTONE 564 color.
static (Shared in Visual Basic) | PANTONE5645 | Gets the PANTONE 5645 color.
static (Shared in Visual Basic) | PANTONE565 | Gets the PANTONE 565 color.
static (Shared in Visual Basic) | PANTONE5655 | Gets the PANTONE 5655 color.
static (Shared in Visual Basic) | PANTONE566 | Gets the PANTONE 566 color.
static (Shared in Visual Basic) | PANTONE5665 | Gets the PANTONE 5665 color.
static (Shared in Visual Basic) | PANTONE567 | Gets the PANTONE 567 color.
static (Shared in Visual Basic) | PANTONE568 | Gets the PANTONE 568 color.
static (Shared in Visual Basic) | PANTONE569 | Gets the PANTONE 569 color.
static (Shared in Visual Basic) | PANTONE570 | Gets the PANTONE 570 color.
static (Shared in Visual Basic) | PANTONE571 | Gets the PANTONE 571 color.
static (Shared in Visual Basic) | PANTONE572 | Gets the PANTONE 572 color.
static (Shared in Visual Basic) | PANTONE573 | Gets the PANTONE 573 color.
static (Shared in Visual Basic) | PANTONE574 | Gets the PANTONE 574 color.
static (Shared in Visual Basic) | PANTONE5743 | Gets the PANTONE 5743 color.
static (Shared in Visual Basic) | PANTONE5747 | Gets the PANTONE 5747 color.
static (Shared in Visual Basic) | PANTONE575 | Gets the PANTONE 575 color.
static (Shared in Visual Basic) | PANTONE5753 | Gets the PANTONE 5753 color.
static (Shared in Visual Basic) | PANTONE5757 | Gets the PANTONE 5757 color.
static (Shared in Visual Basic) | PANTONE576 | Gets the PANTONE 576 color.
static (Shared in Visual Basic) | PANTONE5763 | Gets the PANTONE 5763 color.
static (Shared in Visual Basic) | PANTONE5767 | Gets the PANTONE 5767 color.
static (Shared in Visual Basic) | PANTONE577 | Gets the PANTONE 577 color.
static (Shared in Visual Basic) | PANTONE5773 | Gets the PANTONE 5773 color.
static (Shared in Visual Basic) | PANTONE5777 | Gets the PANTONE 5777 color.
static (Shared in Visual Basic) | PANTONE578 | Gets the PANTONE 578 color.
static (Shared in Visual Basic) | PANTONE5783 | Gets the PANTONE 5783 color.
static (Shared in Visual Basic) | PANTONE5787 | Gets the PANTONE 5787 color.
static (Shared in Visual Basic) | PANTONE579 | Gets the PANTONE 579 color.
static (Shared in Visual Basic) | PANTONE5793 | Gets the PANTONE 5793 color.
static (Shared in Visual Basic) | PANTONE5797 | Gets the PANTONE 5797 color.
static (Shared in Visual Basic) | PANTONE580 | Gets the PANTONE 580 color.
static (Shared in Visual Basic) | PANTONE5803 | Gets the PANTONE 5803 color.
static (Shared in Visual Basic) | PANTONE5807 | Gets the PANTONE 5807 color.
static (Shared in Visual Basic) | PANTONE581 | Gets the PANTONE 581 color.
static (Shared in Visual Basic) | PANTONE5815 | Gets the PANTONE 5815 color.
static (Shared in Visual Basic) | PANTONE582 | Gets the PANTONE 582 color.
static (Shared in Visual Basic) | PANTONE5825 | Gets the PANTONE 5825 color.
static (Shared in Visual Basic) | PANTONE583 | Gets the PANTONE 583 color.
static (Shared in Visual Basic) | PANTONE5835 | Gets the PANTONE 5835 color.
static (Shared in Visual Basic) | PANTONE584 | Gets the PANTONE 584 color.
static (Shared in Visual Basic) | PANTONE5845 | Gets the PANTONE 5845 color.
static (Shared in Visual Basic) | PANTONE585 | Gets the PANTONE 585 color.
static (Shared in Visual Basic) | PANTONE5855 | Gets the PANTONE 5855 color.
static (Shared in Visual Basic) | PANTONE586 | Gets the PANTONE 586 color.
static (Shared in Visual Basic) | PANTONE5865 | Gets the PANTONE 5865 color.
static (Shared in Visual Basic) | PANTONE587 | Gets the PANTONE 587 color.
static (Shared in Visual Basic) | PANTONE5875 | Gets the PANTONE 5875 color.
static (Shared in Visual Basic) | PANTONE600 | Gets the PANTONE 600 color.
static (Shared in Visual Basic) | PANTONE601 | Gets the PANTONE 601 color.
static (Shared in Visual Basic) | PANTONE602 | Gets the PANTONE 602 color.
static (Shared in Visual Basic) | PANTONE603 | Gets the PANTONE 603 color.
static (Shared in Visual Basic) | PANTONE604 | Gets the PANTONE 604 color.
static (Shared in Visual Basic) | PANTONE605 | Gets the PANTONE 605 color.
static (Shared in Visual Basic) | PANTONE606 | Gets the PANTONE 606 color.
static (Shared in Visual Basic) | PANTONE607 | Gets the PANTONE 607 color.
static (Shared in Visual Basic) | PANTONE608 | Gets the PANTONE 608 color.
static (Shared in Visual Basic) | PANTONE609 | Gets the PANTONE 609 color.
static (Shared in Visual Basic) | PANTONE610 | Gets the PANTONE 610 color.
static (Shared in Visual Basic) | PANTONE611 | Gets the PANTONE 611 color.
static (Shared in Visual Basic) | PANTONE612 | Gets the PANTONE 612 color.
static (Shared in Visual Basic) | PANTONE613 | Gets the PANTONE 613 color.
static (Shared in Visual Basic) | PANTONE614 | Gets the PANTONE 614 color.
static (Shared in Visual Basic) | PANTONE615 | Gets the PANTONE 615 color.
static (Shared in Visual Basic) | PANTONE616 | Gets the PANTONE 616 color.
static (Shared in Visual Basic) | PANTONE617 | Gets the PANTONE 617 color.
static (Shared in Visual Basic) | PANTONE618 | Gets the PANTONE 618 color.
static (Shared in Visual Basic) | PANTONE619 | Gets the PANTONE 619 color.
static (Shared in Visual Basic) | PANTONE620 | Gets the PANTONE 620 color.
static (Shared in Visual Basic) | PANTONE621 | Gets the PANTONE 621 color.
static (Shared in Visual Basic) | PANTONE622 | Gets the PANTONE 622 color.
static (Shared in Visual Basic) | PANTONE623 | Gets the PANTONE 623 color.
static (Shared in Visual Basic) | PANTONE624 | Gets the PANTONE 624 color.
static (Shared in Visual Basic) | PANTONE625 | Gets the PANTONE 625 color.
static (Shared in Visual Basic) | PANTONE626 | Gets the PANTONE 626 color.
static (Shared in Visual Basic) | PANTONE627 | Gets the PANTONE 627 color.
static (Shared in Visual Basic) | PANTONE628 | Gets the PANTONE 628 color.
static (Shared in Visual Basic) | PANTONE629 | Gets the PANTONE 629 color.
static (Shared in Visual Basic) | PANTONE630 | Gets the PANTONE 630 color.
static (Shared in Visual Basic) | PANTONE631 | Gets the PANTONE 631 color.
static (Shared in Visual Basic) | PANTONE632 | Gets the PANTONE 632 color.
static (Shared in Visual Basic) | PANTONE633 | Gets the PANTONE 633 color.
static (Shared in Visual Basic) | PANTONE634 | Gets the PANTONE 634 color.
static (Shared in Visual Basic) | PANTONE635 | Gets the PANTONE 635 color.
static (Shared in Visual Basic) | PANTONE636 | Gets the PANTONE 636 color.
static (Shared in Visual Basic) | PANTONE637 | Gets the PANTONE 637 color.
static (Shared in Visual Basic) | PANTONE638 | Gets the PANTONE 638 color.
static (Shared in Visual Basic) | PANTONE639 | Gets the PANTONE 639 color.
static (Shared in Visual Basic) | PANTONE640 | Gets the PANTONE 640 color.
static (Shared in Visual Basic) | PANTONE641 | Gets the PANTONE 641 color.
static (Shared in Visual Basic) | PANTONE642 | Gets the PANTONE 642 color.
static (Shared in Visual Basic) | PANTONE643 | Gets the PANTONE 643 color.
static (Shared in Visual Basic) | PANTONE644 | Gets the PANTONE 644 color.
static (Shared in Visual Basic) | PANTONE645 | Gets the PANTONE 645 color.
static (Shared in Visual Basic) | PANTONE646 | Gets the PANTONE 646 color.
static (Shared in Visual Basic) | PANTONE647 | Gets the PANTONE 647 color.
static (Shared in Visual Basic) | PANTONE648 | Gets the PANTONE 648 color.
static (Shared in Visual Basic) | PANTONE649 | Gets the PANTONE 649 color.
static (Shared in Visual Basic) | PANTONE650 | Gets the PANTONE 650 color.
static (Shared in Visual Basic) | PANTONE651 | Gets the PANTONE 651 color.
static (Shared in Visual Basic) | PANTONE652 | Gets the PANTONE 652 color.
static (Shared in Visual Basic) | PANTONE653 | Gets the PANTONE 653 color.
static (Shared in Visual Basic) | PANTONE654 | Gets the PANTONE 654 color.
static (Shared in Visual Basic) | PANTONE655 | Gets the PANTONE 655 color.
static (Shared in Visual Basic) | PANTONE656 | Gets the PANTONE 656 color.
static (Shared in Visual Basic) | PANTONE657 | Gets the PANTONE 657 color.
static (Shared in Visual Basic) | PANTONE658 | Gets the PANTONE 658 color.
static (Shared in Visual Basic) | PANTONE659 | Gets the PANTONE 659 color.
static (Shared in Visual Basic) | PANTONE660 | Gets the PANTONE 660 color.
static (Shared in Visual Basic) | PANTONE661 | Gets the PANTONE 661 color.
static (Shared in Visual Basic) | PANTONE662 | Gets the PANTONE 662 color.
static (Shared in Visual Basic) | PANTONE663 | Gets the PANTONE 663 color.
static (Shared in Visual Basic) | PANTONE664 | Gets the PANTONE 664 color.
static (Shared in Visual Basic) | PANTONE665 | Gets the PANTONE 665 color.
static (Shared in Visual Basic) | PANTONE666 | Gets the PANTONE 666 color.
static (Shared in Visual Basic) | PANTONE667 | Gets the PANTONE 667 color.
static (Shared in Visual Basic) | PANTONE668 | Gets the PANTONE 668 color.
static (Shared in Visual Basic) | PANTONE669 | Gets the PANTONE 669 color.
static (Shared in Visual Basic) | PANTONE670 | Gets the PANTONE 670 color.
static (Shared in Visual Basic) | PANTONE671 | Gets the PANTONE 671 color.
static (Shared in Visual Basic) | PANTONE672 | Gets the PANTONE 672 color.
static (Shared in Visual Basic) | PANTONE673 | Gets the PANTONE 673 color.
static (Shared in Visual Basic) | PANTONE674 | Gets the PANTONE 674 color.
static (Shared in Visual Basic) | PANTONE675 | Gets the PANTONE 675 color.
static (Shared in Visual Basic) | PANTONE676 | Gets the PANTONE 676 color.
static (Shared in Visual Basic) | PANTONE677 | Gets the PANTONE 677 color.
static (Shared in Visual Basic) | PANTONE678 | Gets the PANTONE 678 color.
static (Shared in Visual Basic) | PANTONE679 | Gets the PANTONE 679 color.
static (Shared in Visual Basic) | PANTONE680 | Gets the PANTONE 680 color.
static (Shared in Visual Basic) | PANTONE681 | Gets the PANTONE 681 color.
static (Shared in Visual Basic) | PANTONE682 | Gets the PANTONE 682 color.
static (Shared in Visual Basic) | PANTONE683 | Gets the PANTONE 683 color.
static (Shared in Visual Basic) | PANTONE684 | Gets the PANTONE 684 color.
static (Shared in Visual Basic) | PANTONE685 | Gets the PANTONE 685 color.
static (Shared in Visual Basic) | PANTONE686 | Gets the PANTONE 686 color.
static (Shared in Visual Basic) | PANTONE687 | Gets the PANTONE 687 color.
static (Shared in Visual Basic) | PANTONE688 | Gets the PANTONE 688 color.
static (Shared in Visual Basic) | PANTONE689 | Gets the PANTONE 689 color.
static (Shared in Visual Basic) | PANTONE690 | Gets the PANTONE 690 color.
static (Shared in Visual Basic) | PANTONE691 | Gets the PANTONE 691 color.
static (Shared in Visual Basic) | PANTONE692 | Gets the PANTONE 692 color.
static (Shared in Visual Basic) | PANTONE693 | Gets the PANTONE 693 color.
static (Shared in Visual Basic) | PANTONE694 | Gets the PANTONE 694 color.
static (Shared in Visual Basic) | PANTONE695 | Gets the PANTONE 695 color.
static (Shared in Visual Basic) | PANTONE696 | Gets the PANTONE 696 color.
static (Shared in Visual Basic) | PANTONE697 | Gets the PANTONE 697 color.
static (Shared in Visual Basic) | PANTONE698 | Gets the PANTONE 698 color.
static (Shared in Visual Basic) | PANTONE699 | Gets the PANTONE 699 color.
static (Shared in Visual Basic) | PANTONE700 | Gets the PANTONE 700 color.
static (Shared in Visual Basic) | PANTONE701 | Gets the PANTONE 701 color.
static (Shared in Visual Basic) | PANTONE702 | Gets the PANTONE 702 color.
static (Shared in Visual Basic) | PANTONE703 | Gets the PANTONE 703 color.
static (Shared in Visual Basic) | PANTONE704 | Gets the PANTONE 704 color.
static (Shared in Visual Basic) | PANTONE705 | Gets the PANTONE 705 color.
static (Shared in Visual Basic) | PANTONE706 | Gets the PANTONE 706 color.
static (Shared in Visual Basic) | PANTONE707 | Gets the PANTONE 707 color.
static (Shared in Visual Basic) | PANTONE708 | Gets the PANTONE 708 color.
static (Shared in Visual Basic) | PANTONE709 | Gets the PANTONE 709 color.
static (Shared in Visual Basic) | PANTONE710 | Gets the PANTONE 710 color.
static (Shared in Visual Basic) | PANTONE711 | Gets the PANTONE 711 color.
static (Shared in Visual Basic) | PANTONE712 | Gets the PANTONE 712 color.
static (Shared in Visual Basic) | PANTONE713 | Gets the PANTONE 713 color.
static (Shared in Visual Basic) | PANTONE714 | Gets the PANTONE 714 color.
static (Shared in Visual Basic) | PANTONE715 | Gets the PANTONE 715 color.
static (Shared in Visual Basic) | PANTONE716 | Gets the PANTONE 716 color.
static (Shared in Visual Basic) | PANTONE717 | Gets the PANTONE 717 color.
static (Shared in Visual Basic) | PANTONE718 | Gets the PANTONE 718 color.
static (Shared in Visual Basic) | PANTONE719 | Gets the PANTONE 719 color.
static (Shared in Visual Basic) | PANTONE720 | Gets the PANTONE 720 color.
static (Shared in Visual Basic) | PANTONE721 | Gets the PANTONE 721 color.
static (Shared in Visual Basic) | PANTONE722 | Gets the PANTONE 722 color.
static (Shared in Visual Basic) | PANTONE723 | Gets the PANTONE 723 color.
static (Shared in Visual Basic) | PANTONE724 | Gets the PANTONE 724 color.
static (Shared in Visual Basic) | PANTONE725 | Gets the PANTONE 725 color.
static (Shared in Visual Basic) | PANTONE726 | Gets the PANTONE 726 color.
static (Shared in Visual Basic) | PANTONE727 | Gets the PANTONE 727 color.
static (Shared in Visual Basic) | PANTONE728 | Gets the PANTONE 728 color.
static (Shared in Visual Basic) | PANTONE729 | Gets the PANTONE 729 color.
static (Shared in Visual Basic) | PANTONE730 | Gets the PANTONE 730 color.
static (Shared in Visual Basic) | PANTONE731 | Gets the PANTONE 731 color.
static (Shared in Visual Basic) | PANTONE732 | Gets the PANTONE 732 color.
static (Shared in Visual Basic) | PANTONE7401 | Gets the PANTONE 7401 color.
static (Shared in Visual Basic) | PANTONE7402 | Gets the PANTONE 7402 color.
static (Shared in Visual Basic) | PANTONE7403 | Gets the PANTONE 7403 color.
static (Shared in Visual Basic) | PANTONE7404 | Gets the PANTONE 7404 color.
static (Shared in Visual Basic) | PANTONE7405 | Gets the PANTONE 7405 color.
static (Shared in Visual Basic) | PANTONE7406 | Gets the PANTONE 7406 color.
static (Shared in Visual Basic) | PANTONE7407 | Gets the PANTONE 7407 color.
static (Shared in Visual Basic) | PANTONE7408 | Gets the PANTONE 7408 color.
static (Shared in Visual Basic) | PANTONE7409 | Gets the PANTONE 7409 color.
static (Shared in Visual Basic) | PANTONE7410 | Gets the PANTONE 7410 color.
static (Shared in Visual Basic) | PANTONE7411 | Gets the PANTONE 7411 color.
static (Shared in Visual Basic) | PANTONE7412 | Gets the PANTONE 7412 color.
static (Shared in Visual Basic) | PANTONE7413 | Gets the PANTONE 7413 color.
static (Shared in Visual Basic) | PANTONE7414 | Gets the PANTONE 7414 color.
static (Shared in Visual Basic) | PANTONE7415 | Gets the PANTONE 7415 color.
static (Shared in Visual Basic) | PANTONE7416 | Gets the PANTONE 7416 color.
static (Shared in Visual Basic) | PANTONE7417 | Gets the PANTONE 7417 color.
static (Shared in Visual Basic) | PANTONE7418 | Gets the PANTONE 7418 color.
static (Shared in Visual Basic) | PANTONE7419 | Gets the PANTONE 7419 color.
static (Shared in Visual Basic) | PANTONE7420 | Gets the PANTONE 7420 color.
static (Shared in Visual Basic) | PANTONE7421 | Gets the PANTONE 7421 color.
static (Shared in Visual Basic) | PANTONE7422 | Gets the PANTONE 7422 color.
static (Shared in Visual Basic) | PANTONE7423 | Gets the PANTONE 7423 color.
static (Shared in Visual Basic) | PANTONE7424 | Gets the PANTONE 7424 color.
static (Shared in Visual Basic) | PANTONE7425 | Gets the PANTONE 7425 color.
static (Shared in Visual Basic) | PANTONE7426 | Gets the PANTONE 7426 color.
static (Shared in Visual Basic) | PANTONE7427 | Gets the PANTONE 7427 color.
static (Shared in Visual Basic) | PANTONE7428 | Gets the PANTONE 7428 color.
static (Shared in Visual Basic) | PANTONE7429 | Gets the PANTONE 7429 color.
static (Shared in Visual Basic) | PANTONE7430 | Gets the PANTONE 7430 color.
static (Shared in Visual Basic) | PANTONE7431 | Gets the PANTONE 7431 color.
static (Shared in Visual Basic) | PANTONE7432 | Gets the PANTONE 7432 color.
static (Shared in Visual Basic) | PANTONE7433 | Gets the PANTONE 7433 color.
static (Shared in Visual Basic) | PANTONE7434 | Gets the PANTONE 7434 color.
static (Shared in Visual Basic) | PANTONE7435 | Gets the PANTONE 7435 color.
static (Shared in Visual Basic) | PANTONE7436 | Gets the PANTONE 7436 color.
static (Shared in Visual Basic) | PANTONE7437 | Gets the PANTONE 7437 color.
static (Shared in Visual Basic) | PANTONE7438 | Gets the PANTONE 7438 color.
static (Shared in Visual Basic) | PANTONE7439 | Gets the PANTONE 7439 color.
static (Shared in Visual Basic) | PANTONE7440 | Gets the PANTONE 7440 color.
static (Shared in Visual Basic) | PANTONE7441 | Gets the PANTONE 7441 color.
static (Shared in Visual Basic) | PANTONE7442 | Gets the PANTONE 7442 color.
static (Shared in Visual Basic) | PANTONE7443 | Gets the PANTONE 7443 color.
static (Shared in Visual Basic) | PANTONE7444 | Gets the PANTONE 7444 color.
static (Shared in Visual Basic) | PANTONE7445 | Gets the PANTONE 7445 color.
static (Shared in Visual Basic) | PANTONE7446 | Gets the PANTONE 7446 color.
static (Shared in Visual Basic) | PANTONE7447 | Gets the PANTONE 7447 color.
static (Shared in Visual Basic) | PANTONE7448 | Gets the PANTONE 7448 color.
static (Shared in Visual Basic) | PANTONE7449 | Gets the PANTONE 7449 color.
static (Shared in Visual Basic) | PANTONE7450 | Gets the PANTONE 7450 color.
static (Shared in Visual Basic) | PANTONE7451 | Gets the PANTONE 7451 color.
static (Shared in Visual Basic) | PANTONE7452 | Gets the PANTONE 7452 color.
static (Shared in Visual Basic) | PANTONE7453 | Gets the PANTONE 7453 color.
static (Shared in Visual Basic) | PANTONE7454 | Gets the PANTONE 7454 color.
static (Shared in Visual Basic) | PANTONE7455 | Gets the PANTONE 7455 color.
static (Shared in Visual Basic) | PANTONE7456 | Gets the PANTONE 7456 color.
static (Shared in Visual Basic) | PANTONE7457 | Gets the PANTONE 7457 color.
static (Shared in Visual Basic) | PANTONE7458 | Gets the PANTONE 7458 color.
static (Shared in Visual Basic) | PANTONE7459 | Gets the PANTONE 7459 color.
static (Shared in Visual Basic) | PANTONE7460 | Gets the PANTONE 7460 color.
static (Shared in Visual Basic) | PANTONE7461 | Gets the PANTONE 7461 color.
static (Shared in Visual Basic) | PANTONE7462 | Gets the PANTONE 7462 color.
static (Shared in Visual Basic) | PANTONE7463 | Gets the PANTONE 7463 color.
static (Shared in Visual Basic) | PANTONE7464 | Gets the PANTONE 7464 color.
static (Shared in Visual Basic) | PANTONE7465 | Gets the PANTONE 7465 color.
static (Shared in Visual Basic) | PANTONE7466 | Gets the PANTONE 7466 color.
static (Shared in Visual Basic) | PANTONE7467 | Gets the PANTONE 7467 color.
static (Shared in Visual Basic) | PANTONE7468 | Gets the PANTONE 7468 color.
static (Shared in Visual Basic) | PANTONE7469 | Gets the PANTONE 7469 color.
static (Shared in Visual Basic) | PANTONE7470 | Gets the PANTONE 7470 color.
static (Shared in Visual Basic) | PANTONE7471 | Gets the PANTONE 7471 color.
static (Shared in Visual Basic) | PANTONE7472 | Gets the PANTONE 7472 color.
static (Shared in Visual Basic) | PANTONE7473 | Gets the PANTONE 7473 color.
static (Shared in Visual Basic) | PANTONE7474 | Gets the PANTONE 7474 color.
static (Shared in Visual Basic) | PANTONE7475 | Gets the PANTONE 7475 color.
static (Shared in Visual Basic) | PANTONE7476 | Gets the PANTONE 7476 color.
static (Shared in Visual Basic) | PANTONE7477 | Gets the PANTONE 7477 color.
static (Shared in Visual Basic) | PANTONE7478 | Gets the PANTONE 7478 color.
static (Shared in Visual Basic) | PANTONE7479 | Gets the PANTONE 7479 color.
static (Shared in Visual Basic) | PANTONE7480 | Gets the PANTONE 7480 color.
static (Shared in Visual Basic) | PANTONE7481 | Gets the PANTONE 7481 color.
static (Shared in Visual Basic) | PANTONE7482 | Gets the PANTONE 7482 color.
static (Shared in Visual Basic) | PANTONE7483 | Gets the PANTONE 7483 color.
static (Shared in Visual Basic) | PANTONE7484 | Gets the PANTONE 7484 color.
static (Shared in Visual Basic) | PANTONE7485 | Gets the PANTONE 7485 color.
static (Shared in Visual Basic) | PANTONE7486 | Gets the PANTONE 7486 color.
static (Shared in Visual Basic) | PANTONE7487 | Gets the PANTONE 7487 color.
static (Shared in Visual Basic) | PANTONE7488 | Gets the PANTONE 7488 color.
static (Shared in Visual Basic) | PANTONE7489 | Gets the PANTONE 7489 color.
static (Shared in Visual Basic) | PANTONE7490 | Gets the PANTONE 7490 color.
static (Shared in Visual Basic) | PANTONE7491 | Gets the PANTONE 7491 color.
static (Shared in Visual Basic) | PANTONE7492 | Gets the PANTONE 7492 color.
static (Shared in Visual Basic) | PANTONE7493 | Gets the PANTONE 7493 color.
static (Shared in Visual Basic) | PANTONE7494 | Gets the PANTONE 7494 color.
static (Shared in Visual Basic) | PANTONE7495 | Gets the PANTONE 7495 color.
static (Shared in Visual Basic) | PANTONE7496 | Gets the PANTONE 7496 color.
static (Shared in Visual Basic) | PANTONE7497 | Gets the PANTONE 7497 color.
static (Shared in Visual Basic) | PANTONE7498 | Gets the PANTONE 7498 color.
static (Shared in Visual Basic) | PANTONE7499 | Gets the PANTONE 7499 color.
static (Shared in Visual Basic) | PANTONE7500 | Gets the PANTONE 7500 color.
static (Shared in Visual Basic) | PANTONE7501 | Gets the PANTONE 7501 color.
static (Shared in Visual Basic) | PANTONE7502 | Gets the PANTONE 7502 color.
static (Shared in Visual Basic) | PANTONE7503 | Gets the PANTONE 7503 color.
static (Shared in Visual Basic) | PANTONE7504 | Gets the PANTONE 7504 color.
static (Shared in Visual Basic) | PANTONE7505 | Gets the PANTONE 7505 color.
static (Shared in Visual Basic) | PANTONE7506 | Gets the PANTONE 7506 color.
static (Shared in Visual Basic) | PANTONE7507 | Gets the PANTONE 7507 color.
static (Shared in Visual Basic) | PANTONE7508 | Gets the PANTONE 7508 color.
static (Shared in Visual Basic) | PANTONE7509 | Gets the PANTONE 7509 color.
static (Shared in Visual Basic) | PANTONE7510 | Gets the PANTONE 7510 color.
static (Shared in Visual Basic) | PANTONE7511 | Gets the PANTONE 7511 color.
static (Shared in Visual Basic) | PANTONE7512 | Gets the PANTONE 7512 color.
static (Shared in Visual Basic) | PANTONE7513 | Gets the PANTONE 7513 color.
static (Shared in Visual Basic) | PANTONE7514 | Gets the PANTONE 7514 color.
static (Shared in Visual Basic) | PANTONE7515 | Gets the PANTONE 7515 color.
static (Shared in Visual Basic) | PANTONE7516 | Gets the PANTONE 7516 color.
static (Shared in Visual Basic) | PANTONE7517 | Gets the PANTONE 7517 color.
static (Shared in Visual Basic) | PANTONE7518 | Gets the PANTONE 7518 color.
static (Shared in Visual Basic) | PANTONE7519 | Gets the PANTONE 7519 color.
static (Shared in Visual Basic) | PANTONE7520 | Gets the PANTONE 7520 color.
static (Shared in Visual Basic) | PANTONE7521 | Gets the PANTONE 7521 color.
static (Shared in Visual Basic) | PANTONE7522 | Gets the PANTONE 7522 color.
static (Shared in Visual Basic) | PANTONE7523 | Gets the PANTONE 7523 color.
static (Shared in Visual Basic) | PANTONE7524 | Gets the PANTONE 7524 color.
static (Shared in Visual Basic) | PANTONE7525 | Gets the PANTONE 7525 color.
static (Shared in Visual Basic) | PANTONE7526 | Gets the PANTONE 7526 color.
static (Shared in Visual Basic) | PANTONE7527 | Gets the PANTONE 7527 color.
static (Shared in Visual Basic) | PANTONE7528 | Gets the PANTONE 7528 color.
static (Shared in Visual Basic) | PANTONE7529 | Gets the PANTONE 7529 color.
static (Shared in Visual Basic) | PANTONE7530 | Gets the PANTONE 7530 color.
static (Shared in Visual Basic) | PANTONE7531 | Gets the PANTONE 7531 color.
static (Shared in Visual Basic) | PANTONE7532 | Gets the PANTONE 7532 color.
static (Shared in Visual Basic) | PANTONE7533 | Gets the PANTONE 7533 color.
static (Shared in Visual Basic) | PANTONE7534 | Gets the PANTONE 7534 color.
static (Shared in Visual Basic) | PANTONE7535 | Gets the PANTONE 7535 color.
static (Shared in Visual Basic) | PANTONE7536 | Gets the PANTONE 7536 color.
static (Shared in Visual Basic) | PANTONE7537 | Gets the PANTONE 7537 color.
static (Shared in Visual Basic) | PANTONE7538 | Gets the PANTONE 7538 color.
static (Shared in Visual Basic) | PANTONE7539 | Gets the PANTONE 7539 color.
static (Shared in Visual Basic) | PANTONE7540 | Gets the PANTONE 7540 color.
static (Shared in Visual Basic) | PANTONE7541 | Gets the PANTONE 7541 color.
static (Shared in Visual Basic) | PANTONE7542 | Gets the PANTONE 7542 color.
static (Shared in Visual Basic) | PANTONE7543 | Gets the PANTONE 7543 color.
static (Shared in Visual Basic) | PANTONE7544 | Gets the PANTONE 7544 color.
static (Shared in Visual Basic) | PANTONE7545 | Gets the PANTONE 7545 color.
static (Shared in Visual Basic) | PANTONE7546 | Gets the PANTONE 7546 color.
static (Shared in Visual Basic) | PANTONE7547 | Gets the PANTONE 7547 color.
static (Shared in Visual Basic) | PANTONE8003 | Gets the PANTONE 8003 color.
static (Shared in Visual Basic) | PANTONE801 | Gets the PANTONE 801 color.
static (Shared in Visual Basic) | PANTONE802 | Gets the PANTONE 802 color.
static (Shared in Visual Basic) | PANTONE8021 | Gets the PANTONE 8021 color.
static (Shared in Visual Basic) | PANTONE803 | Gets the PANTONE 803 color.
static (Shared in Visual Basic) | PANTONE804 | Gets the PANTONE 804 color.
static (Shared in Visual Basic) | PANTONE805 | Gets the PANTONE 805 color.
static (Shared in Visual Basic) | PANTONE806 | Gets the PANTONE 806 color.
static (Shared in Visual Basic) | PANTONE8062 | Gets the PANTONE 8062 color.
static (Shared in Visual Basic) | PANTONE807 | Gets the PANTONE 807 color.
static (Shared in Visual Basic) | PANTONE808 | Gets the PANTONE 808 color.
static (Shared in Visual Basic) | PANTONE809 | Gets the PANTONE 809 color.
static (Shared in Visual Basic) | PANTONE810 | Gets the PANTONE 810 color.
static (Shared in Visual Basic) | PANTONE8100 | Gets the PANTONE 8100 color.
static (Shared in Visual Basic) | PANTONE811 | Gets the PANTONE 811 color.
static (Shared in Visual Basic) | PANTONE812 | Gets the PANTONE 812 color.
static (Shared in Visual Basic) | PANTONE813 | Gets the PANTONE 813 color.
static (Shared in Visual Basic) | PANTONE814 | Gets the PANTONE 814 color.
static (Shared in Visual Basic) | PANTONE8201 | Gets the PANTONE 8201 color.
static (Shared in Visual Basic) | PANTONE8281 | Gets the PANTONE 8281 color.
static (Shared in Visual Basic) | PANTONE8321 | Gets the PANTONE 8321 color.
static (Shared in Visual Basic) | PANTONE871 | Gets the PANTONE 871 color.
static (Shared in Visual Basic) | PANTONE872 | Gets the PANTONE 872 color.
static (Shared in Visual Basic) | PANTONE873 | Gets the PANTONE 873 color.
static (Shared in Visual Basic) | PANTONE874 | Gets the PANTONE 874 color.
static (Shared in Visual Basic) | PANTONE875 | Gets the PANTONE 875 color.
static (Shared in Visual Basic) | PANTONE876 | Gets the PANTONE 876 color.
static (Shared in Visual Basic) | PANTONE877 | Gets the PANTONE 877 color.
static (Shared in Visual Basic) | ProcessBlack | Gets the PANTONE Process Black color.
static (Shared in Visual Basic) | ProcessBlue | Gets the PANTONE Process Blue color.
static (Shared in Visual Basic) | ProcessCyan | Gets the PANTONE Process Cyan color.
static (Shared in Visual Basic) | ProcessMagenta | Gets the PANTONE Process Magenta color.
static (Shared in Visual Basic) | ProcessYellow | Gets the PANTONE Process Yellow color.
static (Shared in Visual Basic) | Purple | Gets the PANTONE Purple color.
static (Shared in Visual Basic) | Red032 | Gets the PANTONE Red 032 color.
static (Shared in Visual Basic) | ReflexBlue | Gets the PANTONE Reflex Blue color.
static (Shared in Visual Basic) | RhodamineRed | Gets the PANTONE Rhodamine Red color.
static (Shared in Visual Basic) | RubineRed | Gets the PANTONE Rubine Red color.
Public Property | Tint | Gets or sets the tint for this color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
static (Shared in Visual Basic) | Violet | Gets the PANTONE Violet color.
static (Shared in Visual Basic) | WarmGray1 | Gets the PANTONE Warm Gray 1 color.
static (Shared in Visual Basic) | WarmGray10 | Gets the PANTONE Warm Gray 10 color.
static (Shared in Visual Basic) | WarmGray11 | Gets the PANTONE Warm Gray 11 color.
static (Shared in Visual Basic) | WarmGray2 | Gets the PANTONE Warm Gray 2 color.
static (Shared in Visual Basic) | WarmGray3 | Gets the PANTONE Warm Gray 3 color.
static (Shared in Visual Basic) | WarmGray4 | Gets the PANTONE Warm Gray 4 color.
static (Shared in Visual Basic) | WarmGray5 | Gets the PANTONE Warm Gray 5 color.
static (Shared in Visual Basic) | WarmGray6 | Gets the PANTONE Warm Gray 6 color.
static (Shared in Visual Basic) | WarmGray7 | Gets the PANTONE Warm Gray 7 color.
static (Shared in Visual Basic) | WarmGray8 | Gets the PANTONE Warm Gray 8 color.
static (Shared in Visual Basic) | WarmGray9 | Gets the PANTONE Warm Gray 9 color.
static (Shared in Visual Basic) | WarmRed | Gets the PANTONE Warm Red color.
static (Shared in Visual Basic) | Yellow | Gets the PANTONE Yellow color.
static (Shared in Visual Basic) | Yellow012 | Gets the PANTONE Yellow 012 color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Public Method | Equals | Verifies if the given object is equal to this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
static (Shared in Visual Basic) | FromName | Creates a Pantone color from a known pantone name.
Public Method | GetHashCode | Gets the hash code of this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Public Method | ToString | Converts the color object to string representation. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Top
See Also

Reference

PDFPantoneColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Methods$$

PDFPantoneColor Class Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

For a list of all members of this type, see PDFPantoneColor members.

Public Methods
 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Public Method | Equals | Verifies if the given object is equal to this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
static (Shared in Visual Basic) | FromName | Creates a Pantone color from a known pantone name.
Public Method | GetHashCode | Gets the hash code of this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Public Method | ToString | Converts the color object to string representation. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Top
See Also

Reference

PDFPantoneColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


FromName Method

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : FromName Method
Name of pantone color.
Creates a Pantone color from a known pantone name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromName( _
   ByVal pantoneName As String _
) As PDFPantoneColor
'Usage

Dim pantoneName As String
Dim value As PDFPantoneColor

value = PDFPantoneColor.FromName(pantoneName)
public static PDFPantoneColor FromName(
   string pantoneName
)
public: static PDFPantoneColor* FromName(
   string* pantoneName
)
public:
static PDFPantoneColor^ FromName(
   String^ pantoneName
)

Parameters

pantoneName
Name of pantone color.

Return Value

The pantone color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%% $$Properties$$

PDFPantoneColor Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

For a list of all members of this type, see PDFPantoneColor members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Black | Gets the PANTONE Black color.
static (Shared in Visual Basic) | Black2 | Gets the PANTONE Black 2 color.
static (Shared in Visual Basic) | Black3 | Gets the PANTONE Black 3 color.
static (Shared in Visual Basic) | Black4 | Gets the PANTONE Black 4 color.
static (Shared in Visual Basic) | Black5 | Gets the PANTONE Black 5 color.
static (Shared in Visual Basic) | Black6 | Gets the PANTONE Black 6 color.
static (Shared in Visual Basic) | Black7 | Gets the PANTONE Black 7 color.
static (Shared in Visual Basic) | Blue072 | Gets the PANTONE Blue 072 color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
static (Shared in Visual Basic) | CoolGray1 | Gets the PANTONE Cool Gray 1 color.
static (Shared in Visual Basic) | CoolGray10 | Gets the PANTONE Cool Gray 10 color.
static (Shared in Visual Basic) | CoolGray11 | Gets the PANTONE Cool Gray 11 color.
static (Shared in Visual Basic) | CoolGray2 | Gets the PANTONE Cool Gray 2 color.
static (Shared in Visual Basic) | CoolGray3 | Gets the PANTONE Cool Gray 3 color.
static (Shared in Visual Basic) | CoolGray4 | Gets the PANTONE Cool Gray 4 color.
static (Shared in Visual Basic) | CoolGray5 | Gets the PANTONE Cool Gray 5 color.
static (Shared in Visual Basic) | CoolGray6 | Gets the PANTONE Cool Gray 6 color.
static (Shared in Visual Basic) | CoolGray7 | Gets the PANTONE Cool Gray 7 color.
static (Shared in Visual Basic) | CoolGray8 | Gets the PANTONE Cool Gray 8 color.
static (Shared in Visual Basic) | CoolGray9 | Gets the PANTONE Cool Gray 9 color.
static (Shared in Visual Basic) | Green | Gets the PANTONE Green color.
static (Shared in Visual Basic) | HexachromeBlack | Gets the PANTONE Hexachrome Black color.
static (Shared in Visual Basic) | HexachromeCyan | Gets the PANTONE Hexachrome Cyan color.
static (Shared in Visual Basic) | HexachromeGreen | Gets the PANTONE Hexachrome Green color.
static (Shared in Visual Basic) | HexachromeMagenta | Gets the PANTONE Hexachrome Magenta color.
static (Shared in Visual Basic) | HexachromeOrange | Gets the PANTONE Hexachrome Orange color.
static (Shared in Visual Basic) | HexachromeYellow | Gets the PANTONE Hexachrome Yellow color.
static (Shared in Visual Basic) | Orange021 | Gets the PANTONE Orange 021 color.
static (Shared in Visual Basic) | PANTONE100 | Gets the PANTONE 100 color.
static (Shared in Visual Basic) | PANTONE101 | Gets the PANTONE 101 color.
static (Shared in Visual Basic) | PANTONE102 | Gets the PANTONE 102 color.
static (Shared in Visual Basic) | PANTONE103 | Gets the PANTONE 103 color.
static (Shared in Visual Basic) | PANTONE104 | Gets the PANTONE 104 color.
static (Shared in Visual Basic) | PANTONE105 | Gets the PANTONE 105 color.
static (Shared in Visual Basic) | PANTONE106 | Gets the PANTONE 106 color.
static (Shared in Visual Basic) | PANTONE107 | Gets the PANTONE 107 color.
static (Shared in Visual Basic) | PANTONE108 | Gets the PANTONE 108 color.
static (Shared in Visual Basic) | PANTONE109 | Gets the PANTONE 109 color.
static (Shared in Visual Basic) | PANTONE110 | Gets the PANTONE 110 color.
static (Shared in Visual Basic) | PANTONE111 | Gets the PANTONE 111 color.
static (Shared in Visual Basic) | PANTONE112 | Gets the PANTONE 112 color.
static (Shared in Visual Basic) | PANTONE113 | Gets the PANTONE 113 color.
static (Shared in Visual Basic) | PANTONE114 | Gets the PANTONE 114 color.
static (Shared in Visual Basic) | PANTONE115 | Gets the PANTONE 115 color.
static (Shared in Visual Basic) | PANTONE116 | Gets the PANTONE 116 color.
static (Shared in Visual Basic) | PANTONE117 | Gets the PANTONE 117 color.
static (Shared in Visual Basic) | PANTONE118 | Gets the PANTONE 118 color.
static (Shared in Visual Basic) | PANTONE119 | Gets the PANTONE 119 color.
static (Shared in Visual Basic) | PANTONE120 | Gets the PANTONE 120 color.
static (Shared in Visual Basic) | PANTONE1205 | Gets the PANTONE 1205 color.
static (Shared in Visual Basic) | PANTONE121 | Gets the PANTONE 121 color.
static (Shared in Visual Basic) | PANTONE1215 | Gets the PANTONE 1215 color.
static (Shared in Visual Basic) | PANTONE122 | Gets the PANTONE 122 color.
static (Shared in Visual Basic) | PANTONE1225 | Gets the PANTONE 1225 color.
static (Shared in Visual Basic) | PANTONE123 | Gets the PANTONE 123 color.
static (Shared in Visual Basic) | PANTONE1235 | Gets the PANTONE 1235 color.
static (Shared in Visual Basic) | PANTONE124 | Gets the PANTONE 124 color.
static (Shared in Visual Basic) | PANTONE1245 | Gets the PANTONE 1245 color.
static (Shared in Visual Basic) | PANTONE125 | Gets the PANTONE 125 color.
static (Shared in Visual Basic) | PANTONE1255 | Gets the PANTONE 1255 color.
static (Shared in Visual Basic) | PANTONE126 | Gets the PANTONE 126 color.
static (Shared in Visual Basic) | PANTONE1265 | Gets the PANTONE 1265 color.
static (Shared in Visual Basic) | PANTONE127 | Gets the PANTONE 127 color.
static (Shared in Visual Basic) | PANTONE128 | Gets the PANTONE 128 color.
static (Shared in Visual Basic) | PANTONE129 | Gets the PANTONE 129 color.
static (Shared in Visual Basic) | PANTONE130 | Gets the PANTONE 130 color.
static (Shared in Visual Basic) | PANTONE131 | Gets the PANTONE 131 color.
static (Shared in Visual Basic) | PANTONE132 | Gets the PANTONE 132 color.
static (Shared in Visual Basic) | PANTONE133 | Gets the PANTONE 133 color.
static (Shared in Visual Basic) | PANTONE134 | Gets the PANTONE 134 color.
static (Shared in Visual Basic) | PANTONE1345 | Gets the PANTONE 1345 color.
static (Shared in Visual Basic) | PANTONE135 | Gets the PANTONE 135 color.
static (Shared in Visual Basic) | PANTONE1355 | Gets the PANTONE 1355 color.
static (Shared in Visual Basic) | PANTONE136 | Gets the PANTONE 136 color.
static (Shared in Visual Basic) | PANTONE1365 | Gets the PANTONE 1365 color.
static (Shared in Visual Basic) | PANTONE137 | Gets the PANTONE 137 color.
static (Shared in Visual Basic) | PANTONE1375 | Gets the PANTONE 1375 color.
static (Shared in Visual Basic) | PANTONE138 | Gets the PANTONE 138 color.
static (Shared in Visual Basic) | PANTONE1385 | Gets the PANTONE 1385 color.
static (Shared in Visual Basic) | PANTONE139 | Gets the PANTONE 139 color.
static (Shared in Visual Basic) | PANTONE1395 | Gets the PANTONE 1395 color.
static (Shared in Visual Basic) | PANTONE140 | Gets the PANTONE 140 color.
static (Shared in Visual Basic) | PANTONE1405 | Gets the PANTONE 1405 color.
static (Shared in Visual Basic) | PANTONE141 | Gets the PANTONE 141 color.
static (Shared in Visual Basic) | PANTONE142 | Gets the PANTONE 142 color.
static (Shared in Visual Basic) | PANTONE143 | Gets the PANTONE 143 color.
static (Shared in Visual Basic) | PANTONE144 | Gets the PANTONE 144 color.
static (Shared in Visual Basic) | PANTONE145 | Gets the PANTONE 145 color.
static (Shared in Visual Basic) | PANTONE146 | Gets the PANTONE 146 color.
static (Shared in Visual Basic) | PANTONE147 | Gets the PANTONE 147 color.
static (Shared in Visual Basic) | PANTONE148 | Gets the PANTONE 148 color.
static (Shared in Visual Basic) | PANTONE1485 | Gets the PANTONE 1485 color.
static (Shared in Visual Basic) | PANTONE149 | Gets the PANTONE 149 color.
static (Shared in Visual Basic) | PANTONE1495 | Gets the PANTONE 1495 color.
static (Shared in Visual Basic) | PANTONE150 | Gets the PANTONE 150 color.
static (Shared in Visual Basic) | PANTONE1505 | Gets the PANTONE 1505 color.
static (Shared in Visual Basic) | PANTONE151 | Gets the PANTONE 151 color.
static (Shared in Visual Basic) | PANTONE152 | Gets the PANTONE 152 color.
static (Shared in Visual Basic) | PANTONE1525 | Gets the PANTONE 1525 color.
static (Shared in Visual Basic) | PANTONE153 | Gets the PANTONE 153 color.
static (Shared in Visual Basic) | PANTONE1535 | Gets the PANTONE 1535 color.
static (Shared in Visual Basic) | PANTONE154 | Gets the PANTONE 154 color.
static (Shared in Visual Basic) | PANTONE1545 | Gets the PANTONE 1545 color.
static (Shared in Visual Basic) | PANTONE155 | Gets the PANTONE 155 color.
static (Shared in Visual Basic) | PANTONE1555 | Gets the PANTONE 1555 color.
static (Shared in Visual Basic) | PANTONE156 | Gets the PANTONE 156 color.
static (Shared in Visual Basic) | PANTONE1565 | Gets the PANTONE 1565 color.
static (Shared in Visual Basic) | PANTONE157 | Gets the PANTONE 157 color.
static (Shared in Visual Basic) | PANTONE1575 | Gets the PANTONE 1575 color.
static (Shared in Visual Basic) | PANTONE158 | Gets the PANTONE 158 color.
static (Shared in Visual Basic) | PANTONE1585 | Gets the PANTONE 1585 color.
static (Shared in Visual Basic) | PANTONE159 | Gets the PANTONE 159 color.
static (Shared in Visual Basic) | PANTONE1595 | Gets the PANTONE 1595 color.
static (Shared in Visual Basic) | PANTONE160 | Gets the PANTONE 160 color.
static (Shared in Visual Basic) | PANTONE1605 | Gets the PANTONE 1605 color.
static (Shared in Visual Basic) | PANTONE161 | Gets the PANTONE 161 color.
static (Shared in Visual Basic) | PANTONE1615 | Gets the PANTONE 1615 color.
static (Shared in Visual Basic) | PANTONE162 | Gets the PANTONE 162 color.
static (Shared in Visual Basic) | PANTONE1625 | Gets the PANTONE 1625 color.
static (Shared in Visual Basic) | PANTONE163 | Gets the PANTONE 163 color.
static (Shared in Visual Basic) | PANTONE1635 | Gets the PANTONE 1635 color.
static (Shared in Visual Basic) | PANTONE164 | Gets the PANTONE 164 color.
static (Shared in Visual Basic) | PANTONE1645 | Gets the PANTONE 1645 color.
static (Shared in Visual Basic) | PANTONE165 | Gets the PANTONE 165 color.
static (Shared in Visual Basic) | PANTONE1655 | Gets the PANTONE 1655 color.
static (Shared in Visual Basic) | PANTONE166 | Gets the PANTONE 166 color.
static (Shared in Visual Basic) | PANTONE1665 | Gets the PANTONE 1665 color.
static (Shared in Visual Basic) | PANTONE167 | Gets the PANTONE 167 color.
static (Shared in Visual Basic) | PANTONE1675 | Gets the PANTONE 1675 color.
static (Shared in Visual Basic) | PANTONE168 | Gets the PANTONE 168 color.
static (Shared in Visual Basic) | PANTONE1685 | Gets the PANTONE 1685 color.
static (Shared in Visual Basic) | PANTONE169 | Gets the PANTONE 169 color.
static (Shared in Visual Basic) | PANTONE170 | Gets the PANTONE 170 color.
static (Shared in Visual Basic) | PANTONE171 | Gets the PANTONE 171 color.
static (Shared in Visual Basic) | PANTONE172 | Gets the PANTONE 172 color.
static (Shared in Visual Basic) | PANTONE173 | Gets the PANTONE 173 color.
static (Shared in Visual Basic) | PANTONE174 | Gets the PANTONE 174 color.
static (Shared in Visual Basic) | PANTONE175 | Gets the PANTONE 175 color.
static (Shared in Visual Basic) | PANTONE176 | Gets the PANTONE 176 color.
static (Shared in Visual Basic) | PANTONE1765 | Gets the PANTONE 1765 color.
static (Shared in Visual Basic) | PANTONE1767 | Gets the PANTONE 1767 color.
static (Shared in Visual Basic) | PANTONE177 | Gets the PANTONE 177 color.
static (Shared in Visual Basic) | PANTONE1775 | Gets the PANTONE 1775 color.
static (Shared in Visual Basic) | PANTONE1777 | Gets the PANTONE 1777 color.
static (Shared in Visual Basic) | PANTONE178 | Gets the PANTONE 178 color.
static (Shared in Visual Basic) | PANTONE1785 | Gets the PANTONE 1785 color.
static (Shared in Visual Basic) | PANTONE1787 | Gets the PANTONE 1787 color.
static (Shared in Visual Basic) | PANTONE1788 | Gets the PANTONE 1788 color.
static (Shared in Visual Basic) | PANTONE179 | Gets the PANTONE 179 color.
static (Shared in Visual Basic) | PANTONE1795 | Gets the PANTONE 1795 color.
static (Shared in Visual Basic) | PANTONE1797 | Gets the PANTONE 1797 color.
static (Shared in Visual Basic) | PANTONE180 | Gets the PANTONE 180 color.
static (Shared in Visual Basic) | PANTONE1805 | Gets the PANTONE 1805 color.
static (Shared in Visual Basic) | PANTONE1807 | Gets the PANTONE 1807 color.
static (Shared in Visual Basic) | PANTONE181 | Gets the PANTONE 181 color.
static (Shared in Visual Basic) | PANTONE1815 | Gets the PANTONE 1815 color.
static (Shared in Visual Basic) | PANTONE1817 | Gets the PANTONE 1817 color.
static (Shared in Visual Basic) | PANTONE182 | Gets the PANTONE 182 color.
static (Shared in Visual Basic) | PANTONE183 | Gets the PANTONE 183 color.
static (Shared in Visual Basic) | PANTONE184 | Gets the PANTONE 184 color.
static (Shared in Visual Basic) | PANTONE185 | Gets the PANTONE 185 color.
static (Shared in Visual Basic) | PANTONE186 | Gets the PANTONE 186 color.
static (Shared in Visual Basic) | PANTONE187 | Gets the PANTONE 187 color.
static (Shared in Visual Basic) | PANTONE188 | Gets the PANTONE 188 color.
static (Shared in Visual Basic) | PANTONE189 | Gets the PANTONE 189 color.
static (Shared in Visual Basic) | PANTONE1895 | Gets the PANTONE 1895 color.
static (Shared in Visual Basic) | PANTONE190 | Gets the PANTONE 190 color.
static (Shared in Visual Basic) | PANTONE1905 | Gets the PANTONE 1905 color.
static (Shared in Visual Basic) | PANTONE191 | Gets the PANTONE 191 color.
static (Shared in Visual Basic) | PANTONE1915 | Gets the PANTONE 1915 color.
static (Shared in Visual Basic) | PANTONE192 | Gets the PANTONE 192 color.
static (Shared in Visual Basic) | PANTONE1925 | Gets the PANTONE 1925 color.
static (Shared in Visual Basic) | PANTONE193 | Gets the PANTONE 193 color.
static (Shared in Visual Basic) | PANTONE1935 | Gets the PANTONE 1935 color.
static (Shared in Visual Basic) | PANTONE194 | Gets the PANTONE 194 color.
static (Shared in Visual Basic) | PANTONE1945 | Gets the PANTONE 1945 color.
static (Shared in Visual Basic) | PANTONE195 | Gets the PANTONE 195 color.
static (Shared in Visual Basic) | PANTONE1955 | Gets the PANTONE 1955 color.
static (Shared in Visual Basic) | PANTONE196 | Gets the PANTONE 196 color.
static (Shared in Visual Basic) | PANTONE197 | Gets the PANTONE 197 color.
static (Shared in Visual Basic) | PANTONE198 | Gets the PANTONE 198 color.
static (Shared in Visual Basic) | PANTONE199 | Gets the PANTONE 199 color.
static (Shared in Visual Basic) | PANTONE200 | Gets the PANTONE 200 color.
static (Shared in Visual Basic) | PANTONE201 | Gets the PANTONE 201 color.
static (Shared in Visual Basic) | PANTONE202 | Gets the PANTONE 202 color.
static (Shared in Visual Basic) | PANTONE203 | Gets the PANTONE 203 color.
static (Shared in Visual Basic) | PANTONE204 | Gets the PANTONE 204 color.
static (Shared in Visual Basic) | PANTONE205 | Gets the PANTONE 205 color.
static (Shared in Visual Basic) | PANTONE206 | Gets the PANTONE 206 color.
static (Shared in Visual Basic) | PANTONE207 | Gets the PANTONE 207 color.
static (Shared in Visual Basic) | PANTONE208 | Gets the PANTONE 208 color.
static (Shared in Visual Basic) | PANTONE209 | Gets the PANTONE 209 color.
static (Shared in Visual Basic) | PANTONE210 | Gets the PANTONE 210 color.
static (Shared in Visual Basic) | PANTONE211 | Gets the PANTONE 211 color.
static (Shared in Visual Basic) | PANTONE212 | Gets the PANTONE 212 color.
static (Shared in Visual Basic) | PANTONE213 | Gets the PANTONE 213 color.
static (Shared in Visual Basic) | PANTONE214 | Gets the PANTONE 214 color.
static (Shared in Visual Basic) | PANTONE215 | Gets the PANTONE 215 color.
static (Shared in Visual Basic) | PANTONE216 | Gets the PANTONE 216 color.
static (Shared in Visual Basic) | PANTONE217 | Gets the PANTONE 217 color.
static (Shared in Visual Basic) | PANTONE218 | Gets the PANTONE 218 color.
static (Shared in Visual Basic) | PANTONE219 | Gets the PANTONE 219 color.
static (Shared in Visual Basic) | PANTONE220 | Gets the PANTONE 220 color.
static (Shared in Visual Basic) | PANTONE221 | Gets the PANTONE 221 color.
static (Shared in Visual Basic) | PANTONE222 | Gets the PANTONE 222 color.
static (Shared in Visual Basic) | PANTONE223 | Gets the PANTONE 223 color.
static (Shared in Visual Basic) | PANTONE224 | Gets the PANTONE 224 color.
static (Shared in Visual Basic) | PANTONE225 | Gets the PANTONE 225 color.
static (Shared in Visual Basic) | PANTONE226 | Gets the PANTONE 226 color.
static (Shared in Visual Basic) | PANTONE227 | Gets the PANTONE 227 color.
static (Shared in Visual Basic) | PANTONE228 | Gets the PANTONE 228 color.
static (Shared in Visual Basic) | PANTONE229 | Gets the PANTONE 229 color.
static (Shared in Visual Basic) | PANTONE230 | Gets the PANTONE 230 color.
static (Shared in Visual Basic) | PANTONE231 | Gets the PANTONE 231 color.
static (Shared in Visual Basic) | PANTONE232 | Gets the PANTONE 232 color.
static (Shared in Visual Basic) | PANTONE233 | Gets the PANTONE 233 color.
static (Shared in Visual Basic) | PANTONE234 | Gets the PANTONE 234 color.
static (Shared in Visual Basic) | PANTONE235 | Gets the PANTONE 235 color.
static (Shared in Visual Basic) | PANTONE236 | Gets the PANTONE 236 color.
static (Shared in Visual Basic) | PANTONE2365 | Gets the PANTONE 2365 color.
static (Shared in Visual Basic) | PANTONE237 | Gets the PANTONE 237 color.
static (Shared in Visual Basic) | PANTONE2375 | Gets the PANTONE 2375 color.
static (Shared in Visual Basic) | PANTONE238 | Gets the PANTONE 238 color.
static (Shared in Visual Basic) | PANTONE2385 | Gets the PANTONE 2385 color.
static (Shared in Visual Basic) | PANTONE239 | Gets the PANTONE 239 color.
static (Shared in Visual Basic) | PANTONE2395 | Gets the PANTONE 2395 color.
static (Shared in Visual Basic) | PANTONE240 | Gets the PANTONE 240 color.
static (Shared in Visual Basic) | PANTONE2405 | Gets the PANTONE 2405 color.
static (Shared in Visual Basic) | PANTONE241 | Gets the PANTONE 241 color.
static (Shared in Visual Basic) | PANTONE2415 | Gets the PANTONE 2415 color.
static (Shared in Visual Basic) | PANTONE242 | Gets the PANTONE 242 color.
static (Shared in Visual Basic) | PANTONE2425 | Gets the PANTONE 2425 color.
static (Shared in Visual Basic) | PANTONE243 | Gets the PANTONE 243 color.
static (Shared in Visual Basic) | PANTONE244 | Gets the PANTONE 244 color.
static (Shared in Visual Basic) | PANTONE245 | Gets the PANTONE 245 color.
static (Shared in Visual Basic) | PANTONE246 | Gets the PANTONE 246 color.
static (Shared in Visual Basic) | PANTONE247 | Gets the PANTONE 247 color.
static (Shared in Visual Basic) | PANTONE248 | Gets the PANTONE 248 color.
static (Shared in Visual Basic) | PANTONE249 | Gets the PANTONE 249 color.
static (Shared in Visual Basic) | PANTONE250 | Gets the PANTONE 250 color.
static (Shared in Visual Basic) | PANTONE251 | Gets the PANTONE 251 color.
static (Shared in Visual Basic) | PANTONE252 | Gets the PANTONE 252 color.
static (Shared in Visual Basic) | PANTONE253 | Gets the PANTONE 253 color.
static (Shared in Visual Basic) | PANTONE254 | Gets the PANTONE 254 color.
static (Shared in Visual Basic) | PANTONE255 | Gets the PANTONE 255 color.
static (Shared in Visual Basic) | PANTONE256 | Gets the PANTONE 256 color.
static (Shared in Visual Basic) | PANTONE2562 | Gets the PANTONE 2562 color.
static (Shared in Visual Basic) | PANTONE2563 | Gets the PANTONE 2563 color.
static (Shared in Visual Basic) | PANTONE2567 | Gets the PANTONE 2567 color.
static (Shared in Visual Basic) | PANTONE257 | Gets the PANTONE 257 color.
static (Shared in Visual Basic) | PANTONE2572 | Gets the PANTONE 2572 color.
static (Shared in Visual Basic) | PANTONE2573 | Gets the PANTONE 2573 color.
static (Shared in Visual Basic) | PANTONE2577 | Gets the PANTONE 2577 color.
static (Shared in Visual Basic) | PANTONE258 | Gets the PANTONE 258 color.
static (Shared in Visual Basic) | PANTONE2582 | Gets the PANTONE 2582 color.
static (Shared in Visual Basic) | PANTONE2583 | Gets the PANTONE 2583 color.
static (Shared in Visual Basic) | PANTONE2587 | Gets the PANTONE 2587 color.
static (Shared in Visual Basic) | PANTONE259 | Gets the PANTONE 259 color.
static (Shared in Visual Basic) | PANTONE2592 | Gets the PANTONE 2592 color.
static (Shared in Visual Basic) | PANTONE2593 | Gets the PANTONE 2593 color.
static (Shared in Visual Basic) | PANTONE2597 | Gets the PANTONE 2597 color.
static (Shared in Visual Basic) | PANTONE260 | Gets the PANTONE 260 color.
static (Shared in Visual Basic) | PANTONE2602 | Gets the PANTONE 2602 color.
static (Shared in Visual Basic) | PANTONE2603 | Gets the PANTONE 2603 color.
static (Shared in Visual Basic) | PANTONE2607 | Gets the PANTONE 2607 color.
static (Shared in Visual Basic) | PANTONE261 | Gets the PANTONE 261 color.
static (Shared in Visual Basic) | PANTONE2612 | Gets the PANTONE 2612 color.
static (Shared in Visual Basic) | PANTONE2613 | Gets the PANTONE 2613 color.
static (Shared in Visual Basic) | PANTONE2617 | Gets the PANTONE 2617 color.
static (Shared in Visual Basic) | PANTONE262 | Gets the PANTONE 262 color.
static (Shared in Visual Basic) | PANTONE2622 | Gets the PANTONE 2622 color.
static (Shared in Visual Basic) | PANTONE2623 | Gets the PANTONE 2623 color.
static (Shared in Visual Basic) | PANTONE2627 | Gets the PANTONE 2627 color.
static (Shared in Visual Basic) | PANTONE263 | Gets the PANTONE 263 color.
static (Shared in Visual Basic) | PANTONE2635 | Gets the PANTONE 2635 color.
static (Shared in Visual Basic) | PANTONE264 | Gets the PANTONE 264 color.
static (Shared in Visual Basic) | PANTONE2645 | Gets the PANTONE 2645 color.
static (Shared in Visual Basic) | PANTONE265 | Gets the PANTONE 265 color.
static (Shared in Visual Basic) | PANTONE2655 | Gets the PANTONE 2655 color.
static (Shared in Visual Basic) | PANTONE266 | Gets the PANTONE 266 color.
static (Shared in Visual Basic) | PANTONE2665 | Gets the PANTONE 2665 color.
static (Shared in Visual Basic) | PANTONE267 | Gets the PANTONE 267 color.
static (Shared in Visual Basic) | PANTONE268 | Gets the PANTONE 268 color.
static (Shared in Visual Basic) | PANTONE2685 | Gets the PANTONE 2685 color.
static (Shared in Visual Basic) | PANTONE269 | Gets the PANTONE 269 color.
static (Shared in Visual Basic) | PANTONE2695 | Gets the PANTONE 2695 color.
static (Shared in Visual Basic) | PANTONE270 | Gets the PANTONE 270 color.
static (Shared in Visual Basic) | PANTONE2705 | Gets the PANTONE 2705 color.
static (Shared in Visual Basic) | PANTONE2706 | Gets the PANTONE 2706 color.
static (Shared in Visual Basic) | PANTONE2707 | Gets the PANTONE 2707 color.
static (Shared in Visual Basic) | PANTONE2708 | Gets the PANTONE 2708 color.
static (Shared in Visual Basic) | PANTONE271 | Gets the PANTONE 271 color.
static (Shared in Visual Basic) | PANTONE2715 | Gets the PANTONE 2715 color.
static (Shared in Visual Basic) | PANTONE2716 | Gets the PANTONE 2716 color.
static (Shared in Visual Basic) | PANTONE2717 | Gets the PANTONE 2717 color.
static (Shared in Visual Basic) | PANTONE2718 | Gets the PANTONE 2718 color.
static (Shared in Visual Basic) | PANTONE272 | Gets the PANTONE 272 color.
static (Shared in Visual Basic) | PANTONE2725 | Gets the PANTONE 2725 color.
static (Shared in Visual Basic) | PANTONE2726 | Gets the PANTONE 2726 color.
static (Shared in Visual Basic) | PANTONE2727 | Gets the PANTONE 2727 color.
static (Shared in Visual Basic) | PANTONE2728 | Gets the PANTONE 2728 color.
static (Shared in Visual Basic) | PANTONE273 | Gets the PANTONE 273 color.
static (Shared in Visual Basic) | PANTONE2735 | Gets the PANTONE 2735 color.
static (Shared in Visual Basic) | PANTONE2736 | Gets the PANTONE 2736 color.
static (Shared in Visual Basic) | PANTONE2738 | Gets the PANTONE 2738 color.
static (Shared in Visual Basic) | PANTONE274 | Gets the PANTONE 274 color.
static (Shared in Visual Basic) | PANTONE2745 | Gets the PANTONE 2745 color.
static (Shared in Visual Basic) | PANTONE2746 | Gets the PANTONE 2746 color.
static (Shared in Visual Basic) | PANTONE2747 | Gets the PANTONE 2747 color.
static (Shared in Visual Basic) | PANTONE2748 | Gets the PANTONE 2748 color.
static (Shared in Visual Basic) | PANTONE275 | Gets the PANTONE 275 color.
static (Shared in Visual Basic) | PANTONE2755 | Gets the PANTONE 2755 color.
static (Shared in Visual Basic) | PANTONE2756 | Gets the PANTONE 2756 color.
static (Shared in Visual Basic) | PANTONE2757 | Gets the PANTONE 2757 color.
static (Shared in Visual Basic) | PANTONE2758 | Gets the PANTONE 2758 color.
static (Shared in Visual Basic) | PANTONE276 | Gets the PANTONE 276 color.
static (Shared in Visual Basic) | PANTONE2765 | Gets the PANTONE 2765 color.
static (Shared in Visual Basic) | PANTONE2766 | Gets the PANTONE 2766 color.
static (Shared in Visual Basic) | PANTONE2767 | Gets the PANTONE 2767 color.
static (Shared in Visual Basic) | PANTONE2768 | Gets the PANTONE 2768 color.
static (Shared in Visual Basic) | PANTONE277 | Gets the PANTONE 277 color.
static (Shared in Visual Basic) | PANTONE278 | Gets the PANTONE 278 color.
static (Shared in Visual Basic) | PANTONE279 | Gets the PANTONE 279 color.
static (Shared in Visual Basic) | PANTONE280 | Gets the PANTONE 280 color.
static (Shared in Visual Basic) | PANTONE281 | Gets the PANTONE 281 color.
static (Shared in Visual Basic) | PANTONE282 | Gets the PANTONE 282 color.
static (Shared in Visual Basic) | PANTONE283 | Gets the PANTONE 283 color.
static (Shared in Visual Basic) | PANTONE284 | Gets the PANTONE 284 color.
static (Shared in Visual Basic) | PANTONE285 | Gets the PANTONE 285 color.
static (Shared in Visual Basic) | PANTONE286 | Gets the PANTONE 286 color.
static (Shared in Visual Basic) | PANTONE287 | Gets the PANTONE 287 color.
static (Shared in Visual Basic) | PANTONE288 | Gets the PANTONE 288 color.
static (Shared in Visual Basic) | PANTONE289 | Gets the PANTONE 289 color.
static (Shared in Visual Basic) | PANTONE290 | Gets the PANTONE 290 color.
static (Shared in Visual Basic) | PANTONE2905 | Gets the PANTONE 2905 color.
static (Shared in Visual Basic) | PANTONE291 | Gets the PANTONE 291 color.
static (Shared in Visual Basic) | PANTONE2915 | Gets the PANTONE 2915 color.
static (Shared in Visual Basic) | PANTONE292 | Gets the PANTONE 292 color.
static (Shared in Visual Basic) | PANTONE2925 | Gets the PANTONE 2925 color.
static (Shared in Visual Basic) | PANTONE293 | Gets the PANTONE 293 color.
static (Shared in Visual Basic) | PANTONE2935 | Gets the PANTONE 2935 color.
static (Shared in Visual Basic) | PANTONE294 | Gets the PANTONE 294 color.
static (Shared in Visual Basic) | PANTONE2945 | Gets the PANTONE 2945 color.
static (Shared in Visual Basic) | PANTONE295 | Gets the PANTONE 295 color.
static (Shared in Visual Basic) | PANTONE2955 | Gets the PANTONE 2955 color.
static (Shared in Visual Basic) | PANTONE296 | Gets the PANTONE 296 color.
static (Shared in Visual Basic) | PANTONE2965 | Gets the PANTONE 2965 color.
static (Shared in Visual Basic) | PANTONE297 | Gets the PANTONE 297 color.
static (Shared in Visual Basic) | PANTONE2975 | Gets the PANTONE 2975 color.
static (Shared in Visual Basic) | PANTONE298 | Gets the PANTONE 298 color.
static (Shared in Visual Basic) | PANTONE2985 | Gets the PANTONE 2985 color.
static (Shared in Visual Basic) | PANTONE299 | Gets the PANTONE 299 color.
static (Shared in Visual Basic) | PANTONE2995 | Gets the PANTONE 2995 color.
static (Shared in Visual Basic) | PANTONE300 | Gets the PANTONE 300 color.
static (Shared in Visual Basic) | PANTONE3005 | Gets the PANTONE 3005 color.
static (Shared in Visual Basic) | PANTONE301 | Gets the PANTONE 301 color.
static (Shared in Visual Basic) | PANTONE3015 | Gets the PANTONE 3015 color.
static (Shared in Visual Basic) | PANTONE302 | Gets the PANTONE 302 color.
static (Shared in Visual Basic) | PANTONE3025 | Gets the PANTONE 3025 color.
static (Shared in Visual Basic) | PANTONE303 | Gets the PANTONE 303 color.
static (Shared in Visual Basic) | PANTONE3035 | Gets the PANTONE 3035 color.
static (Shared in Visual Basic) | PANTONE304 | Gets the PANTONE 304 color.
static (Shared in Visual Basic) | PANTONE305 | Gets the PANTONE 305 color.
static (Shared in Visual Basic) | PANTONE306 | Gets the PANTONE 306 color.
static (Shared in Visual Basic) | PANTONE307 | Gets the PANTONE 307 color.
static (Shared in Visual Basic) | PANTONE308 | Gets the PANTONE 308 color.
static (Shared in Visual Basic) | PANTONE309 | Gets the PANTONE 309 color.
static (Shared in Visual Basic) | PANTONE310 | Gets the PANTONE 310 color.
static (Shared in Visual Basic) | PANTONE3105 | Gets the PANTONE 3105 color.
static (Shared in Visual Basic) | PANTONE311 | Gets the PANTONE 311 color.
static (Shared in Visual Basic) | PANTONE3115 | Gets the PANTONE 3115 color.
static (Shared in Visual Basic) | PANTONE312 | Gets the PANTONE 312 color.
static (Shared in Visual Basic) | PANTONE3125 | Gets the PANTONE 3125 color.
static (Shared in Visual Basic) | PANTONE313 | Gets the PANTONE 313 color.
static (Shared in Visual Basic) | PANTONE3135 | Gets the PANTONE 3135 color.
static (Shared in Visual Basic) | PANTONE314 | Gets the PANTONE 314 color.
static (Shared in Visual Basic) | PANTONE3145 | Gets the PANTONE 3145 color.
static (Shared in Visual Basic) | PANTONE315 | Gets the PANTONE 315 color.
static (Shared in Visual Basic) | PANTONE3155 | Gets the PANTONE 3155 color.
static (Shared in Visual Basic) | PANTONE316 | Gets the PANTONE 316 color.
static (Shared in Visual Basic) | PANTONE3165 | Gets the PANTONE 3165 color.
static (Shared in Visual Basic) | PANTONE317 | Gets the PANTONE 317 color.
static (Shared in Visual Basic) | PANTONE318 | Gets the PANTONE 318 color.
static (Shared in Visual Basic) | PANTONE319 | Gets the PANTONE 319 color.
static (Shared in Visual Basic) | PANTONE320 | Gets the PANTONE 320 color.
static (Shared in Visual Basic) | PANTONE321 | Gets the PANTONE 321 color.
static (Shared in Visual Basic) | PANTONE322 | Gets the PANTONE 322 color.
static (Shared in Visual Basic) | PANTONE323 | Gets the PANTONE 323 color.
static (Shared in Visual Basic) | PANTONE324 | Gets the PANTONE 324 color.
static (Shared in Visual Basic) | PANTONE3242 | Gets the PANTONE 3242 color.
static (Shared in Visual Basic) | PANTONE3245 | Gets the PANTONE 3245 color.
static (Shared in Visual Basic) | PANTONE3248 | Gets the PANTONE 3248 color.
static (Shared in Visual Basic) | PANTONE325 | Gets the PANTONE 325 color.
static (Shared in Visual Basic) | PANTONE3252 | Gets the PANTONE 3252 color.
static (Shared in Visual Basic) | PANTONE3255 | Gets the PANTONE 3255 color.
static (Shared in Visual Basic) | PANTONE3258 | Gets the PANTONE 3258 color.
static (Shared in Visual Basic) | PANTONE326 | Gets the PANTONE 326 color.
static (Shared in Visual Basic) | PANTONE3262 | Gets the PANTONE 3262 color.
static (Shared in Visual Basic) | PANTONE3265 | Gets the PANTONE 3265 color.
static (Shared in Visual Basic) | PANTONE3268 | Gets the PANTONE 3268 color.
static (Shared in Visual Basic) | PANTONE327 | Gets the PANTONE 327 color.
static (Shared in Visual Basic) | PANTONE3272 | Gets the PANTONE 3272 color.
static (Shared in Visual Basic) | PANTONE3275 | Gets the PANTONE 3275 color.
static (Shared in Visual Basic) | PANTONE3278 | Gets the PANTONE 3278 color.
static (Shared in Visual Basic) | PANTONE328 | Gets the PANTONE 328 color.
static (Shared in Visual Basic) | PANTONE3282 | Gets the PANTONE 3282 color.
static (Shared in Visual Basic) | PANTONE3285 | Gets the PANTONE 3285 color.
static (Shared in Visual Basic) | PANTONE3288 | Gets the PANTONE 3288 color.
static (Shared in Visual Basic) | PANTONE329 | Gets the PANTONE 329 color.
static (Shared in Visual Basic) | PANTONE3292 | Gets the PANTONE 3292 color.
static (Shared in Visual Basic) | PANTONE3295 | Gets the PANTONE 3295 color.
static (Shared in Visual Basic) | PANTONE3298 | Gets the PANTONE 3298 color.
static (Shared in Visual Basic) | PANTONE330 | Gets the PANTONE 330 color.
static (Shared in Visual Basic) | PANTONE3302 | Gets the PANTONE 3302 color.
static (Shared in Visual Basic) | PANTONE3305 | Gets the PANTONE 3305 color.
static (Shared in Visual Basic) | PANTONE3308 | Gets the PANTONE 3308 color.
static (Shared in Visual Basic) | PANTONE331 | Gets the PANTONE 331 color.
static (Shared in Visual Basic) | PANTONE332 | Gets the PANTONE 332 color.
static (Shared in Visual Basic) | PANTONE333 | Gets the PANTONE 333 color.
static (Shared in Visual Basic) | PANTONE334 | Gets the PANTONE 334 color.
static (Shared in Visual Basic) | PANTONE335 | Gets the PANTONE 335 color.
static (Shared in Visual Basic) | PANTONE336 | Gets the PANTONE 336 color.
static (Shared in Visual Basic) | PANTONE337 | Gets the PANTONE 337 color.
static (Shared in Visual Basic) | PANTONE3375 | Gets the PANTONE 3375 color.
static (Shared in Visual Basic) | PANTONE338 | Gets the PANTONE 338 color.
static (Shared in Visual Basic) | PANTONE3385 | Gets the PANTONE 3385 color.
static (Shared in Visual Basic) | PANTONE339 | Gets the PANTONE 339 color.
static (Shared in Visual Basic) | PANTONE3395 | Gets the PANTONE 3395 color.
static (Shared in Visual Basic) | PANTONE340 | Gets the PANTONE 340 color.
static (Shared in Visual Basic) | PANTONE3405 | Gets the PANTONE 3405 color.
static (Shared in Visual Basic) | PANTONE341 | Gets the PANTONE 341 color.
static (Shared in Visual Basic) | PANTONE3415 | Gets the PANTONE 3415 color.
static (Shared in Visual Basic) | PANTONE342 | Gets the PANTONE 342 color.
static (Shared in Visual Basic) | PANTONE3425 | Gets the PANTONE 3425 color.
static (Shared in Visual Basic) | PANTONE343 | Gets the PANTONE 343 color.
static (Shared in Visual Basic) | PANTONE3435 | Gets the PANTONE 3435 color.
static (Shared in Visual Basic) | PANTONE344 | Gets the PANTONE 344 color.
static (Shared in Visual Basic) | PANTONE345 | Gets the PANTONE 345 color.
static (Shared in Visual Basic) | PANTONE346 | Gets the PANTONE 346 color.
static (Shared in Visual Basic) | PANTONE347 | Gets the PANTONE 347 color.
static (Shared in Visual Basic) | PANTONE348 | Gets the PANTONE 348 color.
static (Shared in Visual Basic) | PANTONE349 | Gets the PANTONE 349 color.
static (Shared in Visual Basic) | PANTONE350 | Gets the PANTONE 350 color.
static (Shared in Visual Basic) | PANTONE351 | Gets the PANTONE 351 color.
static (Shared in Visual Basic) | PANTONE352 | Gets the PANTONE 352 color.
static (Shared in Visual Basic) | PANTONE353 | Gets the PANTONE 353 color.
static (Shared in Visual Basic) | PANTONE354 | Gets the PANTONE 354 color.
static (Shared in Visual Basic) | PANTONE355 | Gets the PANTONE 355 color.
static (Shared in Visual Basic) | PANTONE356 | Gets the PANTONE 356 color.
static (Shared in Visual Basic) | PANTONE357 | Gets the PANTONE 357 color.
static (Shared in Visual Basic) | PANTONE358 | Gets the PANTONE 358 color.
static (Shared in Visual Basic) | PANTONE359 | Gets the PANTONE 359 color.
static (Shared in Visual Basic) | PANTONE360 | Gets the PANTONE 360 color.
static (Shared in Visual Basic) | PANTONE361 | Gets the PANTONE 361 color.
static (Shared in Visual Basic) | PANTONE362 | Gets the PANTONE 362 color.
static (Shared in Visual Basic) | PANTONE363 | Gets the PANTONE 363 color.
static (Shared in Visual Basic) | PANTONE364 | Gets the PANTONE 364 color.
static (Shared in Visual Basic) | PANTONE365 | Gets the PANTONE 365 color.
static (Shared in Visual Basic) | PANTONE366 | Gets the PANTONE 366 color.
static (Shared in Visual Basic) | PANTONE367 | Gets the PANTONE 367 color.
static (Shared in Visual Basic) | PANTONE368 | Gets the PANTONE 368 color.
static (Shared in Visual Basic) | PANTONE369 | Gets the PANTONE 369 color.
static (Shared in Visual Basic) | PANTONE370 | Gets the PANTONE 370 color.
static (Shared in Visual Basic) | PANTONE371 | Gets the PANTONE 371 color.
static (Shared in Visual Basic) | PANTONE372 | Gets the PANTONE 372 color.
static (Shared in Visual Basic) | PANTONE373 | Gets the PANTONE 373 color.
static (Shared in Visual Basic) | PANTONE374 | Gets the PANTONE 374 color.
static (Shared in Visual Basic) | PANTONE375 | Gets the PANTONE 375 color.
static (Shared in Visual Basic) | PANTONE376 | Gets the PANTONE 376 color.
static (Shared in Visual Basic) | PANTONE377 | Gets the PANTONE 377 color.
static (Shared in Visual Basic) | PANTONE378 | Gets the PANTONE 378 color.
static (Shared in Visual Basic) | PANTONE379 | Gets the PANTONE 379 color.
static (Shared in Visual Basic) | PANTONE380 | Gets the PANTONE 380 color.
static (Shared in Visual Basic) | PANTONE381 | Gets the PANTONE 381 color.
static (Shared in Visual Basic) | PANTONE382 | Gets the PANTONE 382 color.
static (Shared in Visual Basic) | PANTONE383 | Gets the PANTONE 383 color.
static (Shared in Visual Basic) | PANTONE384 | Gets the PANTONE 384 color.
static (Shared in Visual Basic) | PANTONE385 | Gets the PANTONE 385 color.
static (Shared in Visual Basic) | PANTONE386 | Gets the PANTONE 386 color.
static (Shared in Visual Basic) | PANTONE387 | Gets the PANTONE 387 color.
static (Shared in Visual Basic) | PANTONE388 | Gets the PANTONE 388 color.
static (Shared in Visual Basic) | PANTONE389 | Gets the PANTONE 389 color.
static (Shared in Visual Basic) | PANTONE390 | Gets the PANTONE 390 color.
static (Shared in Visual Basic) | PANTONE391 | Gets the PANTONE 391 color.
static (Shared in Visual Basic) | PANTONE392 | Gets the PANTONE 392 color.
static (Shared in Visual Basic) | PANTONE393 | Gets the PANTONE 393 color.
static (Shared in Visual Basic) | PANTONE3935 | Gets the PANTONE 3935 color.
static (Shared in Visual Basic) | PANTONE394 | Gets the PANTONE 394 color.
static (Shared in Visual Basic) | PANTONE3945 | Gets the PANTONE 3945 color.
static (Shared in Visual Basic) | PANTONE395 | Gets the PANTONE 395 color.
static (Shared in Visual Basic) | PANTONE3955 | Gets the PANTONE 3955 color.
static (Shared in Visual Basic) | PANTONE396 | Gets the PANTONE 396 color.
static (Shared in Visual Basic) | PANTONE3965 | Gets the PANTONE 3965 color.
static (Shared in Visual Basic) | PANTONE397 | Gets the PANTONE 397 color.
static (Shared in Visual Basic) | PANTONE3975 | Gets the PANTONE 3975 color.
static (Shared in Visual Basic) | PANTONE398 | Gets the PANTONE 398 color.
static (Shared in Visual Basic) | PANTONE3985 | Gets the PANTONE 3985 color.
static (Shared in Visual Basic) | PANTONE399 | Gets the PANTONE 399 color.
static (Shared in Visual Basic) | PANTONE3995 | Gets the PANTONE 3995 color.
static (Shared in Visual Basic) | PANTONE400 | Gets the PANTONE 400 color.
static (Shared in Visual Basic) | PANTONE401 | Gets the PANTONE 401 color.
static (Shared in Visual Basic) | PANTONE402 | Gets the PANTONE 402 color.
static (Shared in Visual Basic) | PANTONE403 | Gets the PANTONE 403 color.
static (Shared in Visual Basic) | PANTONE404 | Gets the PANTONE 404 color.
static (Shared in Visual Basic) | PANTONE405 | Gets the PANTONE 405 color.
static (Shared in Visual Basic) | PANTONE406 | Gets the PANTONE 406 color.
static (Shared in Visual Basic) | PANTONE407 | Gets the PANTONE 407 color.
static (Shared in Visual Basic) | PANTONE408 | Gets the PANTONE 408 color.
static (Shared in Visual Basic) | PANTONE409 | Gets the PANTONE 409 color.
static (Shared in Visual Basic) | PANTONE410 | Gets the PANTONE 410 color.
static (Shared in Visual Basic) | PANTONE411 | Gets the PANTONE 411 color.
static (Shared in Visual Basic) | PANTONE412 | Gets the PANTONE 412 color.
static (Shared in Visual Basic) | PANTONE413 | Gets the PANTONE 413 color.
static (Shared in Visual Basic) | PANTONE414 | Gets the PANTONE 414 color.
static (Shared in Visual Basic) | PANTONE415 | Gets the PANTONE 415 color.
static (Shared in Visual Basic) | PANTONE416 | Gets the PANTONE 416 color.
static (Shared in Visual Basic) | PANTONE417 | Gets the PANTONE 417 color.
static (Shared in Visual Basic) | PANTONE418 | Gets the PANTONE 418 color.
static (Shared in Visual Basic) | PANTONE419 | Gets the PANTONE 419 color.
static (Shared in Visual Basic) | PANTONE420 | Gets the PANTONE 420 color.
static (Shared in Visual Basic) | PANTONE421 | Gets the PANTONE 421 color.
static (Shared in Visual Basic) | PANTONE422 | Gets the PANTONE 422 color.
static (Shared in Visual Basic) | PANTONE423 | Gets the PANTONE 423 color.
static (Shared in Visual Basic) | PANTONE424 | Gets the PANTONE 424 color.
static (Shared in Visual Basic) | PANTONE425 | Gets the PANTONE 425 color.
static (Shared in Visual Basic) | PANTONE426 | Gets the PANTONE 426 color.
static (Shared in Visual Basic) | PANTONE427 | Gets the PANTONE 427 color.
static (Shared in Visual Basic) | PANTONE428 | Gets the PANTONE 428 color.
static (Shared in Visual Basic) | PANTONE429 | Gets the PANTONE 429 color.
static (Shared in Visual Basic) | PANTONE430 | Gets the PANTONE 430 color.
static (Shared in Visual Basic) | PANTONE431 | Gets the PANTONE 431 color.
static (Shared in Visual Basic) | PANTONE432 | Gets the PANTONE 432 color.
static (Shared in Visual Basic) | PANTONE433 | Gets the PANTONE 433 color.
static (Shared in Visual Basic) | PANTONE434 | Gets the PANTONE 434 color.
static (Shared in Visual Basic) | PANTONE435 | Gets the PANTONE 435 color.
static (Shared in Visual Basic) | PANTONE436 | Gets the PANTONE 436 color.
static (Shared in Visual Basic) | PANTONE437 | Gets the PANTONE 437 color.
static (Shared in Visual Basic) | PANTONE438 | Gets the PANTONE 438 color.
static (Shared in Visual Basic) | PANTONE439 | Gets the PANTONE 439 color.
static (Shared in Visual Basic) | PANTONE440 | Gets the PANTONE 440 color.
static (Shared in Visual Basic) | PANTONE441 | Gets the PANTONE 441 color.
static (Shared in Visual Basic) | PANTONE442 | Gets the PANTONE 442 color.
static (Shared in Visual Basic) | PANTONE443 | Gets the PANTONE 443 color.
static (Shared in Visual Basic) | PANTONE444 | Gets the PANTONE 444 color.
static (Shared in Visual Basic) | PANTONE445 | Gets the PANTONE 445 color.
static (Shared in Visual Basic) | PANTONE446 | Gets the PANTONE 446 color.
static (Shared in Visual Basic) | PANTONE447 | Gets the PANTONE 447 color.
static (Shared in Visual Basic) | PANTONE448 | Gets the PANTONE 448 color.
static (Shared in Visual Basic) | PANTONE4485 | Gets the PANTONE 4485 color.
static (Shared in Visual Basic) | PANTONE449 | Gets the PANTONE 449 color.
static (Shared in Visual Basic) | PANTONE4495 | Gets the PANTONE 4495 color.
static (Shared in Visual Basic) | PANTONE450 | Gets the PANTONE 450 color.
static (Shared in Visual Basic) | PANTONE4505 | Gets the PANTONE 4505 color.
static (Shared in Visual Basic) | PANTONE451 | Gets the PANTONE 451 color.
static (Shared in Visual Basic) | PANTONE4515 | Gets the PANTONE 4515 color.
static (Shared in Visual Basic) | PANTONE452 | Gets the PANTONE 452 color.
static (Shared in Visual Basic) | PANTONE4525 | Gets the PANTONE 4525 color.
static (Shared in Visual Basic) | PANTONE453 | Gets the PANTONE 453 color.
static (Shared in Visual Basic) | PANTONE4535 | Gets the PANTONE 4535 color.
static (Shared in Visual Basic) | PANTONE454 | Gets the PANTONE 454 color.
static (Shared in Visual Basic) | PANTONE4545 | Gets the PANTONE 4545 color.
static (Shared in Visual Basic) | PANTONE455 | Gets the PANTONE 455 color.
static (Shared in Visual Basic) | PANTONE456 | Gets the PANTONE 456 color.
static (Shared in Visual Basic) | PANTONE457 | Gets the PANTONE 457 color.
static (Shared in Visual Basic) | PANTONE458 | Gets the PANTONE 458 color.
static (Shared in Visual Basic) | PANTONE459 | Gets the PANTONE 459 color.
static (Shared in Visual Basic) | PANTONE460 | Gets the PANTONE 460 color.
static (Shared in Visual Basic) | PANTONE461 | Gets the PANTONE 461 color.
static (Shared in Visual Basic) | PANTONE462 | Gets the PANTONE 462 color.
static (Shared in Visual Basic) | PANTONE4625 | Gets the PANTONE 4625 color.
static (Shared in Visual Basic) | PANTONE463 | Gets the PANTONE 463 color.
static (Shared in Visual Basic) | PANTONE4635 | Gets the PANTONE 4635 color.
static (Shared in Visual Basic) | PANTONE464 | Gets the PANTONE 464 color.
static (Shared in Visual Basic) | PANTONE4645 | Gets the PANTONE 4645 color.
static (Shared in Visual Basic) | PANTONE465 | Gets the PANTONE 465 color.
static (Shared in Visual Basic) | PANTONE4655 | Gets the PANTONE 4655 color.
static (Shared in Visual Basic) | PANTONE466 | Gets the PANTONE 466 color.
static (Shared in Visual Basic) | PANTONE4665 | Gets the PANTONE 4665 color.
static (Shared in Visual Basic) | PANTONE467 | Gets the PANTONE 467 color.
static (Shared in Visual Basic) | PANTONE4675 | Gets the PANTONE 4675 color.
static (Shared in Visual Basic) | PANTONE468 | Gets the PANTONE 468 color.
static (Shared in Visual Basic) | PANTONE4685 | Gets the PANTONE 4685 color.
static (Shared in Visual Basic) | PANTONE469 | Gets the PANTONE 469 color.
static (Shared in Visual Basic) | PANTONE4695 | Gets the PANTONE 4695 color.
static (Shared in Visual Basic) | PANTONE470 | Gets the PANTONE 470 color.
static (Shared in Visual Basic) | PANTONE4705 | Gets the PANTONE 4705 color.
static (Shared in Visual Basic) | PANTONE471 | Gets the PANTONE 471 color.
static (Shared in Visual Basic) | PANTONE4715 | Gets the PANTONE 4715 color.
static (Shared in Visual Basic) | PANTONE472 | Gets the PANTONE 472 color.
static (Shared in Visual Basic) | PANTONE4725 | Gets the PANTONE 4725 color.
static (Shared in Visual Basic) | PANTONE473 | Gets the PANTONE 473 color.
static (Shared in Visual Basic) | PANTONE4735 | Gets the PANTONE 4735 color.
static (Shared in Visual Basic) | PANTONE474 | Gets the PANTONE 474 color.
static (Shared in Visual Basic) | PANTONE4745 | Gets the PANTONE 4745 color.
static (Shared in Visual Basic) | PANTONE475 | Gets the PANTONE 475 color.
static (Shared in Visual Basic) | PANTONE4755 | Gets the PANTONE 4755 color.
static (Shared in Visual Basic) | PANTONE476 | Gets the PANTONE 476 color.
static (Shared in Visual Basic) | PANTONE477 | Gets the PANTONE 477 color.
static (Shared in Visual Basic) | PANTONE478 | Gets the PANTONE 478 color.
static (Shared in Visual Basic) | PANTONE479 | Gets the PANTONE 479 color.
static (Shared in Visual Basic) | PANTONE480 | Gets the PANTONE 480 color.
static (Shared in Visual Basic) | PANTONE481 | Gets the PANTONE 481 color.
static (Shared in Visual Basic) | PANTONE482 | Gets the PANTONE 482 color.
static (Shared in Visual Basic) | PANTONE483 | Gets the PANTONE 483 color.
static (Shared in Visual Basic) | PANTONE484 | Gets the PANTONE 484 color.
static (Shared in Visual Basic) | PANTONE485 | Gets the PANTONE 485 color.
static (Shared in Visual Basic) | PANTONE486 | Gets the PANTONE 486 color.
static (Shared in Visual Basic) | PANTONE487 | Gets the PANTONE 487 color.
static (Shared in Visual Basic) | PANTONE488 | Gets the PANTONE 488 color.
static (Shared in Visual Basic) | PANTONE489 | Gets the PANTONE 489 color.
static (Shared in Visual Basic) | PANTONE490 | Gets the PANTONE 490 color.
static (Shared in Visual Basic) | PANTONE491 | Gets the PANTONE 491 color.
static (Shared in Visual Basic) | PANTONE492 | Gets the PANTONE 492 color.
static (Shared in Visual Basic) | PANTONE493 | Gets the PANTONE 493 color.
static (Shared in Visual Basic) | PANTONE494 | Gets the PANTONE 494 color.
static (Shared in Visual Basic) | PANTONE495 | Gets the PANTONE 495 color.
static (Shared in Visual Basic) | PANTONE496 | Gets the PANTONE 496 color.
static (Shared in Visual Basic) | PANTONE497 | Gets the PANTONE 497 color.
static (Shared in Visual Basic) | PANTONE4975 | Gets the PANTONE 4975 color.
static (Shared in Visual Basic) | PANTONE498 | Gets the PANTONE 498 color.
static (Shared in Visual Basic) | PANTONE4985 | Gets the PANTONE 4985 color.
static (Shared in Visual Basic) | PANTONE499 | Gets the PANTONE 499 color.
static (Shared in Visual Basic) | PANTONE4995 | Gets the PANTONE 4995 color.
static (Shared in Visual Basic) | PANTONE500 | Gets the PANTONE 500 color.
static (Shared in Visual Basic) | PANTONE5005 | Gets the PANTONE 5005 color.
static (Shared in Visual Basic) | PANTONE501 | Gets the PANTONE 501 color.
static (Shared in Visual Basic) | PANTONE5015 | Gets the PANTONE 5015 color.
static (Shared in Visual Basic) | PANTONE502 | Gets the PANTONE 502 color.
static (Shared in Visual Basic) | PANTONE5025 | Gets the PANTONE 5025 color.
static (Shared in Visual Basic) | PANTONE503 | Gets the PANTONE 503 color.
static (Shared in Visual Basic) | PANTONE5035 | Gets the PANTONE 5035 color.
static (Shared in Visual Basic) | PANTONE504 | Gets the PANTONE 504 color.
static (Shared in Visual Basic) | PANTONE505 | Gets the PANTONE 505 color.
static (Shared in Visual Basic) | PANTONE506 | Gets the PANTONE 506 color.
static (Shared in Visual Basic) | PANTONE507 | Gets the PANTONE 507 color.
static (Shared in Visual Basic) | PANTONE508 | Gets the PANTONE 508 color.
static (Shared in Visual Basic) | PANTONE509 | Gets the PANTONE 509 color.
static (Shared in Visual Basic) | PANTONE510 | Gets the PANTONE 510 color.
static (Shared in Visual Basic) | PANTONE511 | Gets the PANTONE 511 color.
static (Shared in Visual Basic) | PANTONE5115 | Gets the PANTONE 5115 color.
static (Shared in Visual Basic) | PANTONE512 | Gets the PANTONE 512 color.
static (Shared in Visual Basic) | PANTONE5125 | Gets the PANTONE 5125 color.
static (Shared in Visual Basic) | PANTONE513 | Gets the PANTONE 513 color.
static (Shared in Visual Basic) | PANTONE5135 | Gets the PANTONE 5135 color.
static (Shared in Visual Basic) | PANTONE514 | Gets the PANTONE 514 color.
static (Shared in Visual Basic) | PANTONE5145 | Gets the PANTONE 5145 color.
static (Shared in Visual Basic) | PANTONE515 | Gets the PANTONE 515 color.
static (Shared in Visual Basic) | PANTONE5155 | Gets the PANTONE 5155 color.
static (Shared in Visual Basic) | PANTONE516 | Gets the PANTONE 516 color.
static (Shared in Visual Basic) | PANTONE5165 | Gets the PANTONE 5165 color.
static (Shared in Visual Basic) | PANTONE517 | Gets the PANTONE 517 color.
static (Shared in Visual Basic) | PANTONE5175 | Gets the PANTONE 5175 color.
static (Shared in Visual Basic) | PANTONE518 | Gets the PANTONE 518 color.
static (Shared in Visual Basic) | PANTONE5185 | Gets the PANTONE 5185 color.
static (Shared in Visual Basic) | PANTONE519 | Gets the PANTONE 519 color.
static (Shared in Visual Basic) | PANTONE5195 | Gets the PANTONE 5195 color.
static (Shared in Visual Basic) | PANTONE520 | Gets the PANTONE 520 color.
static (Shared in Visual Basic) | PANTONE5205 | Gets the PANTONE 5205 color.
static (Shared in Visual Basic) | PANTONE521 | Gets the PANTONE 521 color.
static (Shared in Visual Basic) | PANTONE5215 | Gets the PANTONE 5215 color.
static (Shared in Visual Basic) | PANTONE522 | Gets the PANTONE 522 color.
static (Shared in Visual Basic) | PANTONE5225 | Gets the PANTONE 5225 color.
static (Shared in Visual Basic) | PANTONE523 | Gets the PANTONE 523 color.
static (Shared in Visual Basic) | PANTONE5235 | Gets the PANTONE 5235 color.
static (Shared in Visual Basic) | PANTONE524 | Gets the PANTONE 524 color.
static (Shared in Visual Basic) | PANTONE5245 | Gets the PANTONE 5245 color.
static (Shared in Visual Basic) | PANTONE525 | Gets the PANTONE 525 color.
static (Shared in Visual Basic) | PANTONE5255 | Gets the PANTONE 5255 color.
static (Shared in Visual Basic) | PANTONE526 | Gets the PANTONE 526 color.
static (Shared in Visual Basic) | PANTONE5265 | Gets the PANTONE 5265 color.
static (Shared in Visual Basic) | PANTONE527 | Gets the PANTONE 527 color.
static (Shared in Visual Basic) | PANTONE5275 | Gets the PANTONE 5275 color.
static (Shared in Visual Basic) | PANTONE528 | Gets the PANTONE 528 color.
static (Shared in Visual Basic) | PANTONE5285 | Gets the PANTONE 5285 color.
static (Shared in Visual Basic) | PANTONE529 | Gets the PANTONE 529 color.
static (Shared in Visual Basic) | PANTONE5295 | Gets the PANTONE 5295 color.
static (Shared in Visual Basic) | PANTONE530 | Gets the PANTONE 530 color.
static (Shared in Visual Basic) | PANTONE5305 | Gets the PANTONE 5305 color.
static (Shared in Visual Basic) | PANTONE531 | Gets the PANTONE 531 color.
static (Shared in Visual Basic) | PANTONE5315 | Gets the PANTONE 5315 color.
static (Shared in Visual Basic) | PANTONE532 | Gets the PANTONE 532 color.
static (Shared in Visual Basic) | PANTONE533 | Gets the PANTONE 533 color.
static (Shared in Visual Basic) | PANTONE534 | Gets the PANTONE 534 color.
static (Shared in Visual Basic) | PANTONE535 | Gets the PANTONE 535 color.
static (Shared in Visual Basic) | PANTONE536 | Gets the PANTONE 536 color.
static (Shared in Visual Basic) | PANTONE537 | Gets the PANTONE 537 color.
static (Shared in Visual Basic) | PANTONE538 | Gets the PANTONE 538 color.
static (Shared in Visual Basic) | PANTONE539 | Gets the PANTONE 539 color.
static (Shared in Visual Basic) | PANTONE5395 | Gets the PANTONE 5395 color.
static (Shared in Visual Basic) | PANTONE540 | Gets the PANTONE 540 color.
static (Shared in Visual Basic) | PANTONE5405 | Gets the PANTONE 5405 color.
static (Shared in Visual Basic) | PANTONE541 | Gets the PANTONE 541 color.
static (Shared in Visual Basic) | PANTONE5415 | Gets the PANTONE 5415 color.
static (Shared in Visual Basic) | PANTONE542 | Gets the PANTONE 542 color.
static (Shared in Visual Basic) | PANTONE5425 | Gets the PANTONE 5425 color.
static (Shared in Visual Basic) | PANTONE543 | Gets the PANTONE 543 color.
static (Shared in Visual Basic) | PANTONE5435 | Gets the PANTONE 5435 color.
static (Shared in Visual Basic) | PANTONE544 | Gets the PANTONE 544 color.
static (Shared in Visual Basic) | PANTONE5445 | Gets the PANTONE 5445 color.
static (Shared in Visual Basic) | PANTONE545 | Gets the PANTONE 545 color.
static (Shared in Visual Basic) | PANTONE5455 | Gets the PANTONE 5455 color.
static (Shared in Visual Basic) | PANTONE546 | Gets the PANTONE 546 color.
static (Shared in Visual Basic) | PANTONE5463 | Gets the PANTONE 5463 color.
static (Shared in Visual Basic) | PANTONE5467 | Gets the PANTONE 5467 color.
static (Shared in Visual Basic) | PANTONE547 | Gets the PANTONE 547 color.
static (Shared in Visual Basic) | PANTONE5473 | Gets the PANTONE 5473 color.
static (Shared in Visual Basic) | PANTONE5477 | Gets the PANTONE 5477 color.
static (Shared in Visual Basic) | PANTONE548 | Gets the PANTONE 548 color.
static (Shared in Visual Basic) | PANTONE5483 | Gets the PANTONE 5483 color.
static (Shared in Visual Basic) | PANTONE5487 | Gets the PANTONE 5487 color.
static (Shared in Visual Basic) | PANTONE549 | Gets the PANTONE 549 color.
static (Shared in Visual Basic) | PANTONE5493 | Gets the PANTONE 5493 color.
static (Shared in Visual Basic) | PANTONE5497 | Gets the PANTONE 5497 color.
static (Shared in Visual Basic) | PANTONE550 | Gets the PANTONE 550 color.
static (Shared in Visual Basic) | PANTONE5503 | Gets the PANTONE 5503 color.
static (Shared in Visual Basic) | PANTONE5507 | Gets the PANTONE 5507 color.
static (Shared in Visual Basic) | PANTONE551 | Gets the PANTONE 551 color.
static (Shared in Visual Basic) | PANTONE5513 | Gets the PANTONE 5513 color.
static (Shared in Visual Basic) | PANTONE5517 | Gets the PANTONE 5517 color.
static (Shared in Visual Basic) | PANTONE552 | Gets the PANTONE 552 color.
static (Shared in Visual Basic) | PANTONE5523 | Gets the PANTONE 5523 color.
static (Shared in Visual Basic) | PANTONE5527 | Gets the PANTONE 5527 color.
static (Shared in Visual Basic) | PANTONE553 | Gets the PANTONE 553 color.
static (Shared in Visual Basic) | PANTONE5535 | Gets the PANTONE 5535 color.
static (Shared in Visual Basic) | PANTONE554 | Gets the PANTONE 554 color.
static (Shared in Visual Basic) | PANTONE5545 | Gets the PANTONE 5545 color.
static (Shared in Visual Basic) | PANTONE555 | Gets the PANTONE 555 color.
static (Shared in Visual Basic) | PANTONE5555 | Gets the PANTONE 5555 color.
static (Shared in Visual Basic) | PANTONE556 | Gets the PANTONE 556 color.
static (Shared in Visual Basic) | PANTONE5565 | Gets the PANTONE 5565 color.
static (Shared in Visual Basic) | PANTONE557 | Gets the PANTONE 557 color.
static (Shared in Visual Basic) | PANTONE5575 | Gets the PANTONE 5575 color.
static (Shared in Visual Basic) | PANTONE558 | Gets the PANTONE 558 color.
static (Shared in Visual Basic) | PANTONE5585 | Gets the PANTONE 5585 color.
static (Shared in Visual Basic) | PANTONE559 | Gets the PANTONE 559 color.
static (Shared in Visual Basic) | PANTONE5595 | Gets the PANTONE 5595 color.
static (Shared in Visual Basic) | PANTONE560 | Gets the PANTONE 560 color.
static (Shared in Visual Basic) | PANTONE5605 | Gets the PANTONE 5605 color.
static (Shared in Visual Basic) | PANTONE561 | Gets the PANTONE 561 color.
static (Shared in Visual Basic) | PANTONE5615 | Gets the PANTONE 5615 color.
static (Shared in Visual Basic) | PANTONE562 | Gets the PANTONE 562 color.
static (Shared in Visual Basic) | PANTONE5625 | Gets the PANTONE 5625 color.
static (Shared in Visual Basic) | PANTONE563 | Gets the PANTONE 563 color.
static (Shared in Visual Basic) | PANTONE5635 | Gets the PANTONE 5635 color.
static (Shared in Visual Basic) | PANTONE564 | Gets the PANTONE 564 color.
static (Shared in Visual Basic) | PANTONE5645 | Gets the PANTONE 5645 color.
static (Shared in Visual Basic) | PANTONE565 | Gets the PANTONE 565 color.
static (Shared in Visual Basic) | PANTONE5655 | Gets the PANTONE 5655 color.
static (Shared in Visual Basic) | PANTONE566 | Gets the PANTONE 566 color.
static (Shared in Visual Basic) | PANTONE5665 | Gets the PANTONE 5665 color.
static (Shared in Visual Basic) | PANTONE567 | Gets the PANTONE 567 color.
static (Shared in Visual Basic) | PANTONE568 | Gets the PANTONE 568 color.
static (Shared in Visual Basic) | PANTONE569 | Gets the PANTONE 569 color.
static (Shared in Visual Basic) | PANTONE570 | Gets the PANTONE 570 color.
static (Shared in Visual Basic) | PANTONE571 | Gets the PANTONE 571 color.
static (Shared in Visual Basic) | PANTONE572 | Gets the PANTONE 572 color.
static (Shared in Visual Basic) | PANTONE573 | Gets the PANTONE 573 color.
static (Shared in Visual Basic) | PANTONE574 | Gets the PANTONE 574 color.
static (Shared in Visual Basic) | PANTONE5743 | Gets the PANTONE 5743 color.
static (Shared in Visual Basic) | PANTONE5747 | Gets the PANTONE 5747 color.
static (Shared in Visual Basic) | PANTONE575 | Gets the PANTONE 575 color.
static (Shared in Visual Basic) | PANTONE5753 | Gets the PANTONE 5753 color.
static (Shared in Visual Basic) | PANTONE5757 | Gets the PANTONE 5757 color.
static (Shared in Visual Basic) | PANTONE576 | Gets the PANTONE 576 color.
static (Shared in Visual Basic) | PANTONE5763 | Gets the PANTONE 5763 color.
static (Shared in Visual Basic) | PANTONE5767 | Gets the PANTONE 5767 color.
static (Shared in Visual Basic) | PANTONE577 | Gets the PANTONE 577 color.
static (Shared in Visual Basic) | PANTONE5773 | Gets the PANTONE 5773 color.
static (Shared in Visual Basic) | PANTONE5777 | Gets the PANTONE 5777 color.
static (Shared in Visual Basic) | PANTONE578 | Gets the PANTONE 578 color.
static (Shared in Visual Basic) | PANTONE5783 | Gets the PANTONE 5783 color.
static (Shared in Visual Basic) | PANTONE5787 | Gets the PANTONE 5787 color.
static (Shared in Visual Basic) | PANTONE579 | Gets the PANTONE 579 color.
static (Shared in Visual Basic) | PANTONE5793 | Gets the PANTONE 5793 color.
static (Shared in Visual Basic) | PANTONE5797 | Gets the PANTONE 5797 color.
static (Shared in Visual Basic) | PANTONE580 | Gets the PANTONE 580 color.
static (Shared in Visual Basic) | PANTONE5803 | Gets the PANTONE 5803 color.
static (Shared in Visual Basic) | PANTONE5807 | Gets the PANTONE 5807 color.
static (Shared in Visual Basic) | PANTONE581 | Gets the PANTONE 581 color.
static (Shared in Visual Basic) | PANTONE5815 | Gets the PANTONE 5815 color.
static (Shared in Visual Basic) | PANTONE582 | Gets the PANTONE 582 color.
static (Shared in Visual Basic) | PANTONE5825 | Gets the PANTONE 5825 color.
static (Shared in Visual Basic) | PANTONE583 | Gets the PANTONE 583 color.
static (Shared in Visual Basic) | PANTONE5835 | Gets the PANTONE 5835 color.
static (Shared in Visual Basic) | PANTONE584 | Gets the PANTONE 584 color.
static (Shared in Visual Basic) | PANTONE5845 | Gets the PANTONE 5845 color.
static (Shared in Visual Basic) | PANTONE585 | Gets the PANTONE 585 color.
static (Shared in Visual Basic) | PANTONE5855 | Gets the PANTONE 5855 color.
static (Shared in Visual Basic) | PANTONE586 | Gets the PANTONE 586 color.
static (Shared in Visual Basic) | PANTONE5865 | Gets the PANTONE 5865 color.
static (Shared in Visual Basic) | PANTONE587 | Gets the PANTONE 587 color.
static (Shared in Visual Basic) | PANTONE5875 | Gets the PANTONE 5875 color.
static (Shared in Visual Basic) | PANTONE600 | Gets the PANTONE 600 color.
static (Shared in Visual Basic) | PANTONE601 | Gets the PANTONE 601 color.
static (Shared in Visual Basic) | PANTONE602 | Gets the PANTONE 602 color.
static (Shared in Visual Basic) | PANTONE603 | Gets the PANTONE 603 color.
static (Shared in Visual Basic) | PANTONE604 | Gets the PANTONE 604 color.
static (Shared in Visual Basic) | PANTONE605 | Gets the PANTONE 605 color.
static (Shared in Visual Basic) | PANTONE606 | Gets the PANTONE 606 color.
static (Shared in Visual Basic) | PANTONE607 | Gets the PANTONE 607 color.
static (Shared in Visual Basic) | PANTONE608 | Gets the PANTONE 608 color.
static (Shared in Visual Basic) | PANTONE609 | Gets the PANTONE 609 color.
static (Shared in Visual Basic) | PANTONE610 | Gets the PANTONE 610 color.
static (Shared in Visual Basic) | PANTONE611 | Gets the PANTONE 611 color.
static (Shared in Visual Basic) | PANTONE612 | Gets the PANTONE 612 color.
static (Shared in Visual Basic) | PANTONE613 | Gets the PANTONE 613 color.
static (Shared in Visual Basic) | PANTONE614 | Gets the PANTONE 614 color.
static (Shared in Visual Basic) | PANTONE615 | Gets the PANTONE 615 color.
static (Shared in Visual Basic) | PANTONE616 | Gets the PANTONE 616 color.
static (Shared in Visual Basic) | PANTONE617 | Gets the PANTONE 617 color.
static (Shared in Visual Basic) | PANTONE618 | Gets the PANTONE 618 color.
static (Shared in Visual Basic) | PANTONE619 | Gets the PANTONE 619 color.
static (Shared in Visual Basic) | PANTONE620 | Gets the PANTONE 620 color.
static (Shared in Visual Basic) | PANTONE621 | Gets the PANTONE 621 color.
static (Shared in Visual Basic) | PANTONE622 | Gets the PANTONE 622 color.
static (Shared in Visual Basic) | PANTONE623 | Gets the PANTONE 623 color.
static (Shared in Visual Basic) | PANTONE624 | Gets the PANTONE 624 color.
static (Shared in Visual Basic) | PANTONE625 | Gets the PANTONE 625 color.
static (Shared in Visual Basic) | PANTONE626 | Gets the PANTONE 626 color.
static (Shared in Visual Basic) | PANTONE627 | Gets the PANTONE 627 color.
static (Shared in Visual Basic) | PANTONE628 | Gets the PANTONE 628 color.
static (Shared in Visual Basic) | PANTONE629 | Gets the PANTONE 629 color.
static (Shared in Visual Basic) | PANTONE630 | Gets the PANTONE 630 color.
static (Shared in Visual Basic) | PANTONE631 | Gets the PANTONE 631 color.
static (Shared in Visual Basic) | PANTONE632 | Gets the PANTONE 632 color.
static (Shared in Visual Basic) | PANTONE633 | Gets the PANTONE 633 color.
static (Shared in Visual Basic) | PANTONE634 | Gets the PANTONE 634 color.
static (Shared in Visual Basic) | PANTONE635 | Gets the PANTONE 635 color.
static (Shared in Visual Basic) | PANTONE636 | Gets the PANTONE 636 color.
static (Shared in Visual Basic) | PANTONE637 | Gets the PANTONE 637 color.
static (Shared in Visual Basic) | PANTONE638 | Gets the PANTONE 638 color.
static (Shared in Visual Basic) | PANTONE639 | Gets the PANTONE 639 color.
static (Shared in Visual Basic) | PANTONE640 | Gets the PANTONE 640 color.
static (Shared in Visual Basic) | PANTONE641 | Gets the PANTONE 641 color.
static (Shared in Visual Basic) | PANTONE642 | Gets the PANTONE 642 color.
static (Shared in Visual Basic) | PANTONE643 | Gets the PANTONE 643 color.
static (Shared in Visual Basic) | PANTONE644 | Gets the PANTONE 644 color.
static (Shared in Visual Basic) | PANTONE645 | Gets the PANTONE 645 color.
static (Shared in Visual Basic) | PANTONE646 | Gets the PANTONE 646 color.
static (Shared in Visual Basic) | PANTONE647 | Gets the PANTONE 647 color.
static (Shared in Visual Basic) | PANTONE648 | Gets the PANTONE 648 color.
static (Shared in Visual Basic) | PANTONE649 | Gets the PANTONE 649 color.
static (Shared in Visual Basic) | PANTONE650 | Gets the PANTONE 650 color.
static (Shared in Visual Basic) | PANTONE651 | Gets the PANTONE 651 color.
static (Shared in Visual Basic) | PANTONE652 | Gets the PANTONE 652 color.
static (Shared in Visual Basic) | PANTONE653 | Gets the PANTONE 653 color.
static (Shared in Visual Basic) | PANTONE654 | Gets the PANTONE 654 color.
static (Shared in Visual Basic) | PANTONE655 | Gets the PANTONE 655 color.
static (Shared in Visual Basic) | PANTONE656 | Gets the PANTONE 656 color.
static (Shared in Visual Basic) | PANTONE657 | Gets the PANTONE 657 color.
static (Shared in Visual Basic) | PANTONE658 | Gets the PANTONE 658 color.
static (Shared in Visual Basic) | PANTONE659 | Gets the PANTONE 659 color.
static (Shared in Visual Basic) | PANTONE660 | Gets the PANTONE 660 color.
static (Shared in Visual Basic) | PANTONE661 | Gets the PANTONE 661 color.
static (Shared in Visual Basic) | PANTONE662 | Gets the PANTONE 662 color.
static (Shared in Visual Basic) | PANTONE663 | Gets the PANTONE 663 color.
static (Shared in Visual Basic) | PANTONE664 | Gets the PANTONE 664 color.
static (Shared in Visual Basic) | PANTONE665 | Gets the PANTONE 665 color.
static (Shared in Visual Basic) | PANTONE666 | Gets the PANTONE 666 color.
static (Shared in Visual Basic) | PANTONE667 | Gets the PANTONE 667 color.
static (Shared in Visual Basic) | PANTONE668 | Gets the PANTONE 668 color.
static (Shared in Visual Basic) | PANTONE669 | Gets the PANTONE 669 color.
static (Shared in Visual Basic) | PANTONE670 | Gets the PANTONE 670 color.
static (Shared in Visual Basic) | PANTONE671 | Gets the PANTONE 671 color.
static (Shared in Visual Basic) | PANTONE672 | Gets the PANTONE 672 color.
static (Shared in Visual Basic) | PANTONE673 | Gets the PANTONE 673 color.
static (Shared in Visual Basic) | PANTONE674 | Gets the PANTONE 674 color.
static (Shared in Visual Basic) | PANTONE675 | Gets the PANTONE 675 color.
static (Shared in Visual Basic) | PANTONE676 | Gets the PANTONE 676 color.
static (Shared in Visual Basic) | PANTONE677 | Gets the PANTONE 677 color.
static (Shared in Visual Basic) | PANTONE678 | Gets the PANTONE 678 color.
static (Shared in Visual Basic) | PANTONE679 | Gets the PANTONE 679 color.
static (Shared in Visual Basic) | PANTONE680 | Gets the PANTONE 680 color.
static (Shared in Visual Basic) | PANTONE681 | Gets the PANTONE 681 color.
static (Shared in Visual Basic) | PANTONE682 | Gets the PANTONE 682 color.
static (Shared in Visual Basic) | PANTONE683 | Gets the PANTONE 683 color.
static (Shared in Visual Basic) | PANTONE684 | Gets the PANTONE 684 color.
static (Shared in Visual Basic) | PANTONE685 | Gets the PANTONE 685 color.
static (Shared in Visual Basic) | PANTONE686 | Gets the PANTONE 686 color.
static (Shared in Visual Basic) | PANTONE687 | Gets the PANTONE 687 color.
static (Shared in Visual Basic) | PANTONE688 | Gets the PANTONE 688 color.
static (Shared in Visual Basic) | PANTONE689 | Gets the PANTONE 689 color.
static (Shared in Visual Basic) | PANTONE690 | Gets the PANTONE 690 color.
static (Shared in Visual Basic) | PANTONE691 | Gets the PANTONE 691 color.
static (Shared in Visual Basic) | PANTONE692 | Gets the PANTONE 692 color.
static (Shared in Visual Basic) | PANTONE693 | Gets the PANTONE 693 color.
static (Shared in Visual Basic) | PANTONE694 | Gets the PANTONE 694 color.
static (Shared in Visual Basic) | PANTONE695 | Gets the PANTONE 695 color.
static (Shared in Visual Basic) | PANTONE696 | Gets the PANTONE 696 color.
static (Shared in Visual Basic) | PANTONE697 | Gets the PANTONE 697 color.
static (Shared in Visual Basic) | PANTONE698 | Gets the PANTONE 698 color.
static (Shared in Visual Basic) | PANTONE699 | Gets the PANTONE 699 color.
static (Shared in Visual Basic) | PANTONE700 | Gets the PANTONE 700 color.
static (Shared in Visual Basic) | PANTONE701 | Gets the PANTONE 701 color.
static (Shared in Visual Basic) | PANTONE702 | Gets the PANTONE 702 color.
static (Shared in Visual Basic) | PANTONE703 | Gets the PANTONE 703 color.
static (Shared in Visual Basic) | PANTONE704 | Gets the PANTONE 704 color.
static (Shared in Visual Basic) | PANTONE705 | Gets the PANTONE 705 color.
static (Shared in Visual Basic) | PANTONE706 | Gets the PANTONE 706 color.
static (Shared in Visual Basic) | PANTONE707 | Gets the PANTONE 707 color.
static (Shared in Visual Basic) | PANTONE708 | Gets the PANTONE 708 color.
static (Shared in Visual Basic) | PANTONE709 | Gets the PANTONE 709 color.
static (Shared in Visual Basic) | PANTONE710 | Gets the PANTONE 710 color.
static (Shared in Visual Basic) | PANTONE711 | Gets the PANTONE 711 color.
static (Shared in Visual Basic) | PANTONE712 | Gets the PANTONE 712 color.
static (Shared in Visual Basic) | PANTONE713 | Gets the PANTONE 713 color.
static (Shared in Visual Basic) | PANTONE714 | Gets the PANTONE 714 color.
static (Shared in Visual Basic) | PANTONE715 | Gets the PANTONE 715 color.
static (Shared in Visual Basic) | PANTONE716 | Gets the PANTONE 716 color.
static (Shared in Visual Basic) | PANTONE717 | Gets the PANTONE 717 color.
static (Shared in Visual Basic) | PANTONE718 | Gets the PANTONE 718 color.
static (Shared in Visual Basic) | PANTONE719 | Gets the PANTONE 719 color.
static (Shared in Visual Basic) | PANTONE720 | Gets the PANTONE 720 color.
static (Shared in Visual Basic) | PANTONE721 | Gets the PANTONE 721 color.
static (Shared in Visual Basic) | PANTONE722 | Gets the PANTONE 722 color.
static (Shared in Visual Basic) | PANTONE723 | Gets the PANTONE 723 color.
static (Shared in Visual Basic) | PANTONE724 | Gets the PANTONE 724 color.
static (Shared in Visual Basic) | PANTONE725 | Gets the PANTONE 725 color.
static (Shared in Visual Basic) | PANTONE726 | Gets the PANTONE 726 color.
static (Shared in Visual Basic) | PANTONE727 | Gets the PANTONE 727 color.
static (Shared in Visual Basic) | PANTONE728 | Gets the PANTONE 728 color.
static (Shared in Visual Basic) | PANTONE729 | Gets the PANTONE 729 color.
static (Shared in Visual Basic) | PANTONE730 | Gets the PANTONE 730 color.
static (Shared in Visual Basic) | PANTONE731 | Gets the PANTONE 731 color.
static (Shared in Visual Basic) | PANTONE732 | Gets the PANTONE 732 color.
static (Shared in Visual Basic) | PANTONE7401 | Gets the PANTONE 7401 color.
static (Shared in Visual Basic) | PANTONE7402 | Gets the PANTONE 7402 color.
static (Shared in Visual Basic) | PANTONE7403 | Gets the PANTONE 7403 color.
static (Shared in Visual Basic) | PANTONE7404 | Gets the PANTONE 7404 color.
static (Shared in Visual Basic) | PANTONE7405 | Gets the PANTONE 7405 color.
static (Shared in Visual Basic) | PANTONE7406 | Gets the PANTONE 7406 color.
static (Shared in Visual Basic) | PANTONE7407 | Gets the PANTONE 7407 color.
static (Shared in Visual Basic) | PANTONE7408 | Gets the PANTONE 7408 color.
static (Shared in Visual Basic) | PANTONE7409 | Gets the PANTONE 7409 color.
static (Shared in Visual Basic) | PANTONE7410 | Gets the PANTONE 7410 color.
static (Shared in Visual Basic) | PANTONE7411 | Gets the PANTONE 7411 color.
static (Shared in Visual Basic) | PANTONE7412 | Gets the PANTONE 7412 color.
static (Shared in Visual Basic) | PANTONE7413 | Gets the PANTONE 7413 color.
static (Shared in Visual Basic) | PANTONE7414 | Gets the PANTONE 7414 color.
static (Shared in Visual Basic) | PANTONE7415 | Gets the PANTONE 7415 color.
static (Shared in Visual Basic) | PANTONE7416 | Gets the PANTONE 7416 color.
static (Shared in Visual Basic) | PANTONE7417 | Gets the PANTONE 7417 color.
static (Shared in Visual Basic) | PANTONE7418 | Gets the PANTONE 7418 color.
static (Shared in Visual Basic) | PANTONE7419 | Gets the PANTONE 7419 color.
static (Shared in Visual Basic) | PANTONE7420 | Gets the PANTONE 7420 color.
static (Shared in Visual Basic) | PANTONE7421 | Gets the PANTONE 7421 color.
static (Shared in Visual Basic) | PANTONE7422 | Gets the PANTONE 7422 color.
static (Shared in Visual Basic) | PANTONE7423 | Gets the PANTONE 7423 color.
static (Shared in Visual Basic) | PANTONE7424 | Gets the PANTONE 7424 color.
static (Shared in Visual Basic) | PANTONE7425 | Gets the PANTONE 7425 color.
static (Shared in Visual Basic) | PANTONE7426 | Gets the PANTONE 7426 color.
static (Shared in Visual Basic) | PANTONE7427 | Gets the PANTONE 7427 color.
static (Shared in Visual Basic) | PANTONE7428 | Gets the PANTONE 7428 color.
static (Shared in Visual Basic) | PANTONE7429 | Gets the PANTONE 7429 color.
static (Shared in Visual Basic) | PANTONE7430 | Gets the PANTONE 7430 color.
static (Shared in Visual Basic) | PANTONE7431 | Gets the PANTONE 7431 color.
static (Shared in Visual Basic) | PANTONE7432 | Gets the PANTONE 7432 color.
static (Shared in Visual Basic) | PANTONE7433 | Gets the PANTONE 7433 color.
static (Shared in Visual Basic) | PANTONE7434 | Gets the PANTONE 7434 color.
static (Shared in Visual Basic) | PANTONE7435 | Gets the PANTONE 7435 color.
static (Shared in Visual Basic) | PANTONE7436 | Gets the PANTONE 7436 color.
static (Shared in Visual Basic) | PANTONE7437 | Gets the PANTONE 7437 color.
static (Shared in Visual Basic) | PANTONE7438 | Gets the PANTONE 7438 color.
static (Shared in Visual Basic) | PANTONE7439 | Gets the PANTONE 7439 color.
static (Shared in Visual Basic) | PANTONE7440 | Gets the PANTONE 7440 color.
static (Shared in Visual Basic) | PANTONE7441 | Gets the PANTONE 7441 color.
static (Shared in Visual Basic) | PANTONE7442 | Gets the PANTONE 7442 color.
static (Shared in Visual Basic) | PANTONE7443 | Gets the PANTONE 7443 color.
static (Shared in Visual Basic) | PANTONE7444 | Gets the PANTONE 7444 color.
static (Shared in Visual Basic) | PANTONE7445 | Gets the PANTONE 7445 color.
static (Shared in Visual Basic) | PANTONE7446 | Gets the PANTONE 7446 color.
static (Shared in Visual Basic) | PANTONE7447 | Gets the PANTONE 7447 color.
static (Shared in Visual Basic) | PANTONE7448 | Gets the PANTONE 7448 color.
static (Shared in Visual Basic) | PANTONE7449 | Gets the PANTONE 7449 color.
static (Shared in Visual Basic) | PANTONE7450 | Gets the PANTONE 7450 color.
static (Shared in Visual Basic) | PANTONE7451 | Gets the PANTONE 7451 color.
static (Shared in Visual Basic) | PANTONE7452 | Gets the PANTONE 7452 color.
static (Shared in Visual Basic) | PANTONE7453 | Gets the PANTONE 7453 color.
static (Shared in Visual Basic) | PANTONE7454 | Gets the PANTONE 7454 color.
static (Shared in Visual Basic) | PANTONE7455 | Gets the PANTONE 7455 color.
static (Shared in Visual Basic) | PANTONE7456 | Gets the PANTONE 7456 color.
static (Shared in Visual Basic) | PANTONE7457 | Gets the PANTONE 7457 color.
static (Shared in Visual Basic) | PANTONE7458 | Gets the PANTONE 7458 color.
static (Shared in Visual Basic) | PANTONE7459 | Gets the PANTONE 7459 color.
static (Shared in Visual Basic) | PANTONE7460 | Gets the PANTONE 7460 color.
static (Shared in Visual Basic) | PANTONE7461 | Gets the PANTONE 7461 color.
static (Shared in Visual Basic) | PANTONE7462 | Gets the PANTONE 7462 color.
static (Shared in Visual Basic) | PANTONE7463 | Gets the PANTONE 7463 color.
static (Shared in Visual Basic) | PANTONE7464 | Gets the PANTONE 7464 color.
static (Shared in Visual Basic) | PANTONE7465 | Gets the PANTONE 7465 color.
static (Shared in Visual Basic) | PANTONE7466 | Gets the PANTONE 7466 color.
static (Shared in Visual Basic) | PANTONE7467 | Gets the PANTONE 7467 color.
static (Shared in Visual Basic) | PANTONE7468 | Gets the PANTONE 7468 color.
static (Shared in Visual Basic) | PANTONE7469 | Gets the PANTONE 7469 color.
static (Shared in Visual Basic) | PANTONE7470 | Gets the PANTONE 7470 color.
static (Shared in Visual Basic) | PANTONE7471 | Gets the PANTONE 7471 color.
static (Shared in Visual Basic) | PANTONE7472 | Gets the PANTONE 7472 color.
static (Shared in Visual Basic) | PANTONE7473 | Gets the PANTONE 7473 color.
static (Shared in Visual Basic) | PANTONE7474 | Gets the PANTONE 7474 color.
static (Shared in Visual Basic) | PANTONE7475 | Gets the PANTONE 7475 color.
static (Shared in Visual Basic) | PANTONE7476 | Gets the PANTONE 7476 color.
static (Shared in Visual Basic) | PANTONE7477 | Gets the PANTONE 7477 color.
static (Shared in Visual Basic) | PANTONE7478 | Gets the PANTONE 7478 color.
static (Shared in Visual Basic) | PANTONE7479 | Gets the PANTONE 7479 color.
static (Shared in Visual Basic) | PANTONE7480 | Gets the PANTONE 7480 color.
static (Shared in Visual Basic) | PANTONE7481 | Gets the PANTONE 7481 color.
static (Shared in Visual Basic) | PANTONE7482 | Gets the PANTONE 7482 color.
static (Shared in Visual Basic) | PANTONE7483 | Gets the PANTONE 7483 color.
static (Shared in Visual Basic) | PANTONE7484 | Gets the PANTONE 7484 color.
static (Shared in Visual Basic) | PANTONE7485 | Gets the PANTONE 7485 color.
static (Shared in Visual Basic) | PANTONE7486 | Gets the PANTONE 7486 color.
static (Shared in Visual Basic) | PANTONE7487 | Gets the PANTONE 7487 color.
static (Shared in Visual Basic) | PANTONE7488 | Gets the PANTONE 7488 color.
static (Shared in Visual Basic) | PANTONE7489 | Gets the PANTONE 7489 color.
static (Shared in Visual Basic) | PANTONE7490 | Gets the PANTONE 7490 color.
static (Shared in Visual Basic) | PANTONE7491 | Gets the PANTONE 7491 color.
static (Shared in Visual Basic) | PANTONE7492 | Gets the PANTONE 7492 color.
static (Shared in Visual Basic) | PANTONE7493 | Gets the PANTONE 7493 color.
static (Shared in Visual Basic) | PANTONE7494 | Gets the PANTONE 7494 color.
static (Shared in Visual Basic) | PANTONE7495 | Gets the PANTONE 7495 color.
static (Shared in Visual Basic) | PANTONE7496 | Gets the PANTONE 7496 color.
static (Shared in Visual Basic) | PANTONE7497 | Gets the PANTONE 7497 color.
static (Shared in Visual Basic) | PANTONE7498 | Gets the PANTONE 7498 color.
static (Shared in Visual Basic) | PANTONE7499 | Gets the PANTONE 7499 color.
static (Shared in Visual Basic) | PANTONE7500 | Gets the PANTONE 7500 color.
static (Shared in Visual Basic) | PANTONE7501 | Gets the PANTONE 7501 color.
static (Shared in Visual Basic) | PANTONE7502 | Gets the PANTONE 7502 color.
static (Shared in Visual Basic) | PANTONE7503 | Gets the PANTONE 7503 color.
static (Shared in Visual Basic) | PANTONE7504 | Gets the PANTONE 7504 color.
static (Shared in Visual Basic) | PANTONE7505 | Gets the PANTONE 7505 color.
static (Shared in Visual Basic) | PANTONE7506 | Gets the PANTONE 7506 color.
static (Shared in Visual Basic) | PANTONE7507 | Gets the PANTONE 7507 color.
static (Shared in Visual Basic) | PANTONE7508 | Gets the PANTONE 7508 color.
static (Shared in Visual Basic) | PANTONE7509 | Gets the PANTONE 7509 color.
static (Shared in Visual Basic) | PANTONE7510 | Gets the PANTONE 7510 color.
static (Shared in Visual Basic) | PANTONE7511 | Gets the PANTONE 7511 color.
static (Shared in Visual Basic) | PANTONE7512 | Gets the PANTONE 7512 color.
static (Shared in Visual Basic) | PANTONE7513 | Gets the PANTONE 7513 color.
static (Shared in Visual Basic) | PANTONE7514 | Gets the PANTONE 7514 color.
static (Shared in Visual Basic) | PANTONE7515 | Gets the PANTONE 7515 color.
static (Shared in Visual Basic) | PANTONE7516 | Gets the PANTONE 7516 color.
static (Shared in Visual Basic) | PANTONE7517 | Gets the PANTONE 7517 color.
static (Shared in Visual Basic) | PANTONE7518 | Gets the PANTONE 7518 color.
static (Shared in Visual Basic) | PANTONE7519 | Gets the PANTONE 7519 color.
static (Shared in Visual Basic) | PANTONE7520 | Gets the PANTONE 7520 color.
static (Shared in Visual Basic) | PANTONE7521 | Gets the PANTONE 7521 color.
static (Shared in Visual Basic) | PANTONE7522 | Gets the PANTONE 7522 color.
static (Shared in Visual Basic) | PANTONE7523 | Gets the PANTONE 7523 color.
static (Shared in Visual Basic) | PANTONE7524 | Gets the PANTONE 7524 color.
static (Shared in Visual Basic) | PANTONE7525 | Gets the PANTONE 7525 color.
static (Shared in Visual Basic) | PANTONE7526 | Gets the PANTONE 7526 color.
static (Shared in Visual Basic) | PANTONE7527 | Gets the PANTONE 7527 color.
static (Shared in Visual Basic) | PANTONE7528 | Gets the PANTONE 7528 color.
static (Shared in Visual Basic) | PANTONE7529 | Gets the PANTONE 7529 color.
static (Shared in Visual Basic) | PANTONE7530 | Gets the PANTONE 7530 color.
static (Shared in Visual Basic) | PANTONE7531 | Gets the PANTONE 7531 color.
static (Shared in Visual Basic) | PANTONE7532 | Gets the PANTONE 7532 color.
static (Shared in Visual Basic) | PANTONE7533 | Gets the PANTONE 7533 color.
static (Shared in Visual Basic) | PANTONE7534 | Gets the PANTONE 7534 color.
static (Shared in Visual Basic) | PANTONE7535 | Gets the PANTONE 7535 color.
static (Shared in Visual Basic) | PANTONE7536 | Gets the PANTONE 7536 color.
static (Shared in Visual Basic) | PANTONE7537 | Gets the PANTONE 7537 color.
static (Shared in Visual Basic) | PANTONE7538 | Gets the PANTONE 7538 color.
static (Shared in Visual Basic) | PANTONE7539 | Gets the PANTONE 7539 color.
static (Shared in Visual Basic) | PANTONE7540 | Gets the PANTONE 7540 color.
static (Shared in Visual Basic) | PANTONE7541 | Gets the PANTONE 7541 color.
static (Shared in Visual Basic) | PANTONE7542 | Gets the PANTONE 7542 color.
static (Shared in Visual Basic) | PANTONE7543 | Gets the PANTONE 7543 color.
static (Shared in Visual Basic) | PANTONE7544 | Gets the PANTONE 7544 color.
static (Shared in Visual Basic) | PANTONE7545 | Gets the PANTONE 7545 color.
static (Shared in Visual Basic) | PANTONE7546 | Gets the PANTONE 7546 color.
static (Shared in Visual Basic) | PANTONE7547 | Gets the PANTONE 7547 color.
static (Shared in Visual Basic) | PANTONE8003 | Gets the PANTONE 8003 color.
static (Shared in Visual Basic) | PANTONE801 | Gets the PANTONE 801 color.
static (Shared in Visual Basic) | PANTONE802 | Gets the PANTONE 802 color.
static (Shared in Visual Basic) | PANTONE8021 | Gets the PANTONE 8021 color.
static (Shared in Visual Basic) | PANTONE803 | Gets the PANTONE 803 color.
static (Shared in Visual Basic) | PANTONE804 | Gets the PANTONE 804 color.
static (Shared in Visual Basic) | PANTONE805 | Gets the PANTONE 805 color.
static (Shared in Visual Basic) | PANTONE806 | Gets the PANTONE 806 color.
static (Shared in Visual Basic) | PANTONE8062 | Gets the PANTONE 8062 color.
static (Shared in Visual Basic) | PANTONE807 | Gets the PANTONE 807 color.
static (Shared in Visual Basic) | PANTONE808 | Gets the PANTONE 808 color.
static (Shared in Visual Basic) | PANTONE809 | Gets the PANTONE 809 color.
static (Shared in Visual Basic) | PANTONE810 | Gets the PANTONE 810 color.
static (Shared in Visual Basic) | PANTONE8100 | Gets the PANTONE 8100 color.
static (Shared in Visual Basic) | PANTONE811 | Gets the PANTONE 811 color.
static (Shared in Visual Basic) | PANTONE812 | Gets the PANTONE 812 color.
static (Shared in Visual Basic) | PANTONE813 | Gets the PANTONE 813 color.
static (Shared in Visual Basic) | PANTONE814 | Gets the PANTONE 814 color.
static (Shared in Visual Basic) | PANTONE8201 | Gets the PANTONE 8201 color.
static (Shared in Visual Basic) | PANTONE8281 | Gets the PANTONE 8281 color.
static (Shared in Visual Basic) | PANTONE8321 | Gets the PANTONE 8321 color.
static (Shared in Visual Basic) | PANTONE871 | Gets the PANTONE 871 color.
static (Shared in Visual Basic) | PANTONE872 | Gets the PANTONE 872 color.
static (Shared in Visual Basic) | PANTONE873 | Gets the PANTONE 873 color.
static (Shared in Visual Basic) | PANTONE874 | Gets the PANTONE 874 color.
static (Shared in Visual Basic) | PANTONE875 | Gets the PANTONE 875 color.
static (Shared in Visual Basic) | PANTONE876 | Gets the PANTONE 876 color.
static (Shared in Visual Basic) | PANTONE877 | Gets the PANTONE 877 color.
static (Shared in Visual Basic) | ProcessBlack | Gets the PANTONE Process Black color.
static (Shared in Visual Basic) | ProcessBlue | Gets the PANTONE Process Blue color.
static (Shared in Visual Basic) | ProcessCyan | Gets the PANTONE Process Cyan color.
static (Shared in Visual Basic) | ProcessMagenta | Gets the PANTONE Process Magenta color.
static (Shared in Visual Basic) | ProcessYellow | Gets the PANTONE Process Yellow color.
static (Shared in Visual Basic) | Purple | Gets the PANTONE Purple color.
static (Shared in Visual Basic) | Red032 | Gets the PANTONE Red 032 color.
static (Shared in Visual Basic) | ReflexBlue | Gets the PANTONE Reflex Blue color.
static (Shared in Visual Basic) | RhodamineRed | Gets the PANTONE Rhodamine Red color.
static (Shared in Visual Basic) | RubineRed | Gets the PANTONE Rubine Red color.
Public Property | Tint | Gets or sets the tint for this color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
static (Shared in Visual Basic) | Violet | Gets the PANTONE Violet color.
static (Shared in Visual Basic) | WarmGray1 | Gets the PANTONE Warm Gray 1 color.
static (Shared in Visual Basic) | WarmGray10 | Gets the PANTONE Warm Gray 10 color.
static (Shared in Visual Basic) | WarmGray11 | Gets the PANTONE Warm Gray 11 color.
static (Shared in Visual Basic) | WarmGray2 | Gets the PANTONE Warm Gray 2 color.
static (Shared in Visual Basic) | WarmGray3 | Gets the PANTONE Warm Gray 3 color.
static (Shared in Visual Basic) | WarmGray4 | Gets the PANTONE Warm Gray 4 color.
static (Shared in Visual Basic) | WarmGray5 | Gets the PANTONE Warm Gray 5 color.
static (Shared in Visual Basic) | WarmGray6 | Gets the PANTONE Warm Gray 6 color.
static (Shared in Visual Basic) | WarmGray7 | Gets the PANTONE Warm Gray 7 color.
static (Shared in Visual Basic) | WarmGray8 | Gets the PANTONE Warm Gray 8 color.
static (Shared in Visual Basic) | WarmGray9 | Gets the PANTONE Warm Gray 9 color.
static (Shared in Visual Basic) | WarmRed | Gets the PANTONE Warm Red color.
static (Shared in Visual Basic) | Yellow | Gets the PANTONE Yellow color.
static (Shared in Visual Basic) | Yellow012 | Gets the PANTONE Yellow 012 color.
Top
See Also

Reference

PDFPantoneColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


Black Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black Property
Gets the PANTONE Black color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Black
public static PDFPantoneColor Black {get;}
public: __property static PDFPantoneColor* get_Black();
public:
static property PDFPantoneColor^ Black {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Black color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black2 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black2 Property
Gets the PANTONE Black 2 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black2 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Black2
public static PDFPantoneColor Black2 {get;}
public: __property static PDFPantoneColor* get_Black2();
public:
static property PDFPantoneColor^ Black2 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Black 2 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black3 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black3 Property
Gets the PANTONE Black 3 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black3 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Black3
public static PDFPantoneColor Black3 {get;}
public: __property static PDFPantoneColor* get_Black3();
public:
static property PDFPantoneColor^ Black3 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Black 3 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black4 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black4 Property
Gets the PANTONE Black 4 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black4 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Black4
public static PDFPantoneColor Black4 {get;}
public: __property static PDFPantoneColor* get_Black4();
public:
static property PDFPantoneColor^ Black4 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Black 4 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black5 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black5 Property
Gets the PANTONE Black 5 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black5 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Black5
public static PDFPantoneColor Black5 {get;}
public: __property static PDFPantoneColor* get_Black5();
public:
static property PDFPantoneColor^ Black5 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Black 5 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black6 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black6 Property
Gets the PANTONE Black 6 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black6 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Black6
public static PDFPantoneColor Black6 {get;}
public: __property static PDFPantoneColor* get_Black6();
public:
static property PDFPantoneColor^ Black6 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Black 6 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black7 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black7 Property
Gets the PANTONE Black 7 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black7 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Black7
public static PDFPantoneColor Black7 {get;}
public: __property static PDFPantoneColor* get_Black7();
public:
static property PDFPantoneColor^ Black7 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Black 7 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Blue072 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Blue072 Property
Gets the PANTONE Blue 072 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Blue072 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Blue072
public static PDFPantoneColor Blue072 {get;}
public: __property static PDFPantoneColor* get_Blue072();
public:
static property PDFPantoneColor^ Blue072 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Blue 072 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray1 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray1 Property
Gets the PANTONE Cool Gray 1 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray1 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray1
public static PDFPantoneColor CoolGray1 {get;}
public: __property static PDFPantoneColor* get_CoolGray1();
public:
static property PDFPantoneColor^ CoolGray1 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 1 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray10 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray10 Property
Gets the PANTONE Cool Gray 10 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray10 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray10
public static PDFPantoneColor CoolGray10 {get;}
public: __property static PDFPantoneColor* get_CoolGray10();
public:
static property PDFPantoneColor^ CoolGray10 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 10 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray11 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray11 Property
Gets the PANTONE Cool Gray 11 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray11 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray11
public static PDFPantoneColor CoolGray11 {get;}
public: __property static PDFPantoneColor* get_CoolGray11();
public:
static property PDFPantoneColor^ CoolGray11 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 11 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray2 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray2 Property
Gets the PANTONE Cool Gray 2 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray2 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray2
public static PDFPantoneColor CoolGray2 {get;}
public: __property static PDFPantoneColor* get_CoolGray2();
public:
static property PDFPantoneColor^ CoolGray2 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 2 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray3 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray3 Property
Gets the PANTONE Cool Gray 3 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray3 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray3
public static PDFPantoneColor CoolGray3 {get;}
public: __property static PDFPantoneColor* get_CoolGray3();
public:
static property PDFPantoneColor^ CoolGray3 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 3 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray4 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray4 Property
Gets the PANTONE Cool Gray 4 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray4 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray4
public static PDFPantoneColor CoolGray4 {get;}
public: __property static PDFPantoneColor* get_CoolGray4();
public:
static property PDFPantoneColor^ CoolGray4 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 4 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray5 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray5 Property
Gets the PANTONE Cool Gray 5 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray5 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray5
public static PDFPantoneColor CoolGray5 {get;}
public: __property static PDFPantoneColor* get_CoolGray5();
public:
static property PDFPantoneColor^ CoolGray5 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 5 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray6 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray6 Property
Gets the PANTONE Cool Gray 6 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray6 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray6
public static PDFPantoneColor CoolGray6 {get;}
public: __property static PDFPantoneColor* get_CoolGray6();
public:
static property PDFPantoneColor^ CoolGray6 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 6 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray7 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray7 Property
Gets the PANTONE Cool Gray 7 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray7 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray7
public static PDFPantoneColor CoolGray7 {get;}
public: __property static PDFPantoneColor* get_CoolGray7();
public:
static property PDFPantoneColor^ CoolGray7 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 7 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray8 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray8 Property
Gets the PANTONE Cool Gray 8 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray8 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray8
public static PDFPantoneColor CoolGray8 {get;}
public: __property static PDFPantoneColor* get_CoolGray8();
public:
static property PDFPantoneColor^ CoolGray8 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 8 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray9 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray9 Property
Gets the PANTONE Cool Gray 9 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray9 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray9
public static PDFPantoneColor CoolGray9 {get;}
public: __property static PDFPantoneColor* get_CoolGray9();
public:
static property PDFPantoneColor^ CoolGray9 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 9 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Green Property (PDFPantoneColor)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Green Property
Gets the PANTONE Green color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Green As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Green
public static PDFPantoneColor Green {get;}
public: __property static PDFPantoneColor* get_Green();
public:
static property PDFPantoneColor^ Green {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Green color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeBlack Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeBlack Property
Gets the PANTONE Hexachrome Black color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeBlack As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeBlack
public static PDFPantoneColor HexachromeBlack {get;}
public: __property static PDFPantoneColor* get_HexachromeBlack();
public:
static property PDFPantoneColor^ HexachromeBlack {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Black color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeCyan Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeCyan Property
Gets the PANTONE Hexachrome Cyan color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeCyan As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeCyan
public static PDFPantoneColor HexachromeCyan {get;}
public: __property static PDFPantoneColor* get_HexachromeCyan();
public:
static property PDFPantoneColor^ HexachromeCyan {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Cyan color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeGreen Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeGreen Property
Gets the PANTONE Hexachrome Green color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeGreen As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeGreen
public static PDFPantoneColor HexachromeGreen {get;}
public: __property static PDFPantoneColor* get_HexachromeGreen();
public:
static property PDFPantoneColor^ HexachromeGreen {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Green color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeMagenta Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeMagenta Property
Gets the PANTONE Hexachrome Magenta color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeMagenta As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeMagenta
public static PDFPantoneColor HexachromeMagenta {get;}
public: __property static PDFPantoneColor* get_HexachromeMagenta();
public:
static property PDFPantoneColor^ HexachromeMagenta {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Magenta color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeOrange Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeOrange Property
Gets the PANTONE Hexachrome Orange color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeOrange As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeOrange
public static PDFPantoneColor HexachromeOrange {get;}
public: __property static PDFPantoneColor* get_HexachromeOrange();
public:
static property PDFPantoneColor^ HexachromeOrange {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Orange color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeYellow Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeYellow Property
Gets the PANTONE Hexachrome Yellow color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeYellow As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeYellow
public static PDFPantoneColor HexachromeYellow {get;}
public: __property static PDFPantoneColor* get_HexachromeYellow();
public:
static property PDFPantoneColor^ HexachromeYellow {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Yellow color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Orange021 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Orange021 Property
Gets the PANTONE Orange 021 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Orange021 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Orange021
public static PDFPantoneColor Orange021 {get;}
public: __property static PDFPantoneColor* get_Orange021();
public:
static property PDFPantoneColor^ Orange021 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Orange 021 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE100 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE100 Property
Gets the PANTONE 100 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE100 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE100
public static PDFPantoneColor PANTONE100 {get;}
public: __property static PDFPantoneColor* get_PANTONE100();
public:
static property PDFPantoneColor^ PANTONE100 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 100 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE101 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE101 Property
Gets the PANTONE 101 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE101 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE101
public static PDFPantoneColor PANTONE101 {get;}
public: __property static PDFPantoneColor* get_PANTONE101();
public:
static property PDFPantoneColor^ PANTONE101 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 101 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE102 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE102 Property
Gets the PANTONE 102 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE102 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE102
public static PDFPantoneColor PANTONE102 {get;}
public: __property static PDFPantoneColor* get_PANTONE102();
public:
static property PDFPantoneColor^ PANTONE102 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 102 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE103 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE103 Property
Gets the PANTONE 103 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE103 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE103
public static PDFPantoneColor PANTONE103 {get;}
public: __property static PDFPantoneColor* get_PANTONE103();
public:
static property PDFPantoneColor^ PANTONE103 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 103 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE104 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE104 Property
Gets the PANTONE 104 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE104 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE104
public static PDFPantoneColor PANTONE104 {get;}
public: __property static PDFPantoneColor* get_PANTONE104();
public:
static property PDFPantoneColor^ PANTONE104 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 104 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE105 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE105 Property
Gets the PANTONE 105 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE105 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE105
public static PDFPantoneColor PANTONE105 {get;}
public: __property static PDFPantoneColor* get_PANTONE105();
public:
static property PDFPantoneColor^ PANTONE105 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 105 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE106 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE106 Property
Gets the PANTONE 106 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE106 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE106
public static PDFPantoneColor PANTONE106 {get;}
public: __property static PDFPantoneColor* get_PANTONE106();
public:
static property PDFPantoneColor^ PANTONE106 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 106 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE107 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE107 Property
Gets the PANTONE 107 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE107 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE107
public static PDFPantoneColor PANTONE107 {get;}
public: __property static PDFPantoneColor* get_PANTONE107();
public:
static property PDFPantoneColor^ PANTONE107 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 107 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE108 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE108 Property
Gets the PANTONE 108 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE108 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE108
public static PDFPantoneColor PANTONE108 {get;}
public: __property static PDFPantoneColor* get_PANTONE108();
public:
static property PDFPantoneColor^ PANTONE108 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 108 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE109 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE109 Property
Gets the PANTONE 109 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE109 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE109
public static PDFPantoneColor PANTONE109 {get;}
public: __property static PDFPantoneColor* get_PANTONE109();
public:
static property PDFPantoneColor^ PANTONE109 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 109 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE110 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE110 Property
Gets the PANTONE 110 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE110 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE110
public static PDFPantoneColor PANTONE110 {get;}
public: __property static PDFPantoneColor* get_PANTONE110();
public:
static property PDFPantoneColor^ PANTONE110 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 110 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE111 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE111 Property
Gets the PANTONE 111 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE111 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE111
public static PDFPantoneColor PANTONE111 {get;}
public: __property static PDFPantoneColor* get_PANTONE111();
public:
static property PDFPantoneColor^ PANTONE111 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 111 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE112 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE112 Property
Gets the PANTONE 112 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE112 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE112
public static PDFPantoneColor PANTONE112 {get;}
public: __property static PDFPantoneColor* get_PANTONE112();
public:
static property PDFPantoneColor^ PANTONE112 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 112 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE113 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE113 Property
Gets the PANTONE 113 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE113 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE113
public static PDFPantoneColor PANTONE113 {get;}
public: __property static PDFPantoneColor* get_PANTONE113();
public:
static property PDFPantoneColor^ PANTONE113 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 113 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE114 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE114 Property
Gets the PANTONE 114 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE114 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE114
public static PDFPantoneColor PANTONE114 {get;}
public: __property static PDFPantoneColor* get_PANTONE114();
public:
static property PDFPantoneColor^ PANTONE114 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 114 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE115 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE115 Property
Gets the PANTONE 115 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE115 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE115
public static PDFPantoneColor PANTONE115 {get;}
public: __property static PDFPantoneColor* get_PANTONE115();
public:
static property PDFPantoneColor^ PANTONE115 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 115 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE116 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE116 Property
Gets the PANTONE 116 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE116 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE116
public static PDFPantoneColor PANTONE116 {get;}
public: __property static PDFPantoneColor* get_PANTONE116();
public:
static property PDFPantoneColor^ PANTONE116 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 116 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE117 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE117 Property
Gets the PANTONE 117 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE117 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE117
public static PDFPantoneColor PANTONE117 {get;}
public: __property static PDFPantoneColor* get_PANTONE117();
public:
static property PDFPantoneColor^ PANTONE117 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 117 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE118 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE118 Property
Gets the PANTONE 118 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE118 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE118
public static PDFPantoneColor PANTONE118 {get;}
public: __property static PDFPantoneColor* get_PANTONE118();
public:
static property PDFPantoneColor^ PANTONE118 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 118 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE119 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE119 Property
Gets the PANTONE 119 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE119 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE119
public static PDFPantoneColor PANTONE119 {get;}
public: __property static PDFPantoneColor* get_PANTONE119();
public:
static property PDFPantoneColor^ PANTONE119 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 119 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE120 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE120 Property
Gets the PANTONE 120 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE120 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE120
public static PDFPantoneColor PANTONE120 {get;}
public: __property static PDFPantoneColor* get_PANTONE120();
public:
static property PDFPantoneColor^ PANTONE120 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 120 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1205 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1205 Property
Gets the PANTONE 1205 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1205 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1205
public static PDFPantoneColor PANTONE1205 {get;}
public: __property static PDFPantoneColor* get_PANTONE1205();
public:
static property PDFPantoneColor^ PANTONE1205 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1205 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE121 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE121 Property
Gets the PANTONE 121 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE121 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE121
public static PDFPantoneColor PANTONE121 {get;}
public: __property static PDFPantoneColor* get_PANTONE121();
public:
static property PDFPantoneColor^ PANTONE121 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 121 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1215 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1215 Property
Gets the PANTONE 1215 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1215 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1215
public static PDFPantoneColor PANTONE1215 {get;}
public: __property static PDFPantoneColor* get_PANTONE1215();
public:
static property PDFPantoneColor^ PANTONE1215 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1215 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE122 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE122 Property
Gets the PANTONE 122 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE122 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE122
public static PDFPantoneColor PANTONE122 {get;}
public: __property static PDFPantoneColor* get_PANTONE122();
public:
static property PDFPantoneColor^ PANTONE122 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 122 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1225 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1225 Property
Gets the PANTONE 1225 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1225 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1225
public static PDFPantoneColor PANTONE1225 {get;}
public: __property static PDFPantoneColor* get_PANTONE1225();
public:
static property PDFPantoneColor^ PANTONE1225 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1225 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE123 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE123 Property
Gets the PANTONE 123 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE123 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE123
public static PDFPantoneColor PANTONE123 {get;}
public: __property static PDFPantoneColor* get_PANTONE123();
public:
static property PDFPantoneColor^ PANTONE123 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 123 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1235 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1235 Property
Gets the PANTONE 1235 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1235 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1235
public static PDFPantoneColor PANTONE1235 {get;}
public: __property static PDFPantoneColor* get_PANTONE1235();
public:
static property PDFPantoneColor^ PANTONE1235 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1235 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE124 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE124 Property
Gets the PANTONE 124 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE124 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE124
public static PDFPantoneColor PANTONE124 {get;}
public: __property static PDFPantoneColor* get_PANTONE124();
public:
static property PDFPantoneColor^ PANTONE124 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 124 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1245 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1245 Property
Gets the PANTONE 1245 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1245 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1245
public static PDFPantoneColor PANTONE1245 {get;}
public: __property static PDFPantoneColor* get_PANTONE1245();
public:
static property PDFPantoneColor^ PANTONE1245 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1245 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE125 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE125 Property
Gets the PANTONE 125 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE125 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE125
public static PDFPantoneColor PANTONE125 {get;}
public: __property static PDFPantoneColor* get_PANTONE125();
public:
static property PDFPantoneColor^ PANTONE125 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 125 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1255 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1255 Property
Gets the PANTONE 1255 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1255 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1255
public static PDFPantoneColor PANTONE1255 {get;}
public: __property static PDFPantoneColor* get_PANTONE1255();
public:
static property PDFPantoneColor^ PANTONE1255 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1255 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE126 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE126 Property
Gets the PANTONE 126 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE126 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE126
public static PDFPantoneColor PANTONE126 {get;}
public: __property static PDFPantoneColor* get_PANTONE126();
public:
static property PDFPantoneColor^ PANTONE126 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 126 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1265 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1265 Property
Gets the PANTONE 1265 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1265 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1265
public static PDFPantoneColor PANTONE1265 {get;}
public: __property static PDFPantoneColor* get_PANTONE1265();
public:
static property PDFPantoneColor^ PANTONE1265 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1265 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE127 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE127 Property
Gets the PANTONE 127 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE127 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE127
public static PDFPantoneColor PANTONE127 {get;}
public: __property static PDFPantoneColor* get_PANTONE127();
public:
static property PDFPantoneColor^ PANTONE127 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 127 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE128 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE128 Property
Gets the PANTONE 128 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE128 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE128
public static PDFPantoneColor PANTONE128 {get;}
public: __property static PDFPantoneColor* get_PANTONE128();
public:
static property PDFPantoneColor^ PANTONE128 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 128 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE129 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE129 Property
Gets the PANTONE 129 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE129 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE129
public static PDFPantoneColor PANTONE129 {get;}
public: __property static PDFPantoneColor* get_PANTONE129();
public:
static property PDFPantoneColor^ PANTONE129 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 129 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE130 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE130 Property
Gets the PANTONE 130 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE130 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE130
public static PDFPantoneColor PANTONE130 {get;}
public: __property static PDFPantoneColor* get_PANTONE130();
public:
static property PDFPantoneColor^ PANTONE130 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 130 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE131 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE131 Property
Gets the PANTONE 131 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE131 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE131
public static PDFPantoneColor PANTONE131 {get;}
public: __property static PDFPantoneColor* get_PANTONE131();
public:
static property PDFPantoneColor^ PANTONE131 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 131 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE132 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE132 Property
Gets the PANTONE 132 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE132 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE132
public static PDFPantoneColor PANTONE132 {get;}
public: __property static PDFPantoneColor* get_PANTONE132();
public:
static property PDFPantoneColor^ PANTONE132 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 132 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE133 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE133 Property
Gets the PANTONE 133 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE133 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE133
public static PDFPantoneColor PANTONE133 {get;}
public: __property static PDFPantoneColor* get_PANTONE133();
public:
static property PDFPantoneColor^ PANTONE133 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 133 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE134 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE134 Property
Gets the PANTONE 134 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE134 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE134
public static PDFPantoneColor PANTONE134 {get;}
public: __property static PDFPantoneColor* get_PANTONE134();
public:
static property PDFPantoneColor^ PANTONE134 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 134 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1345 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1345 Property
Gets the PANTONE 1345 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1345 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1345
public static PDFPantoneColor PANTONE1345 {get;}
public: __property static PDFPantoneColor* get_PANTONE1345();
public:
static property PDFPantoneColor^ PANTONE1345 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1345 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE135 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE135 Property
Gets the PANTONE 135 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE135 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE135
public static PDFPantoneColor PANTONE135 {get;}
public: __property static PDFPantoneColor* get_PANTONE135();
public:
static property PDFPantoneColor^ PANTONE135 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 135 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1355 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1355 Property
Gets the PANTONE 1355 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1355 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1355
public static PDFPantoneColor PANTONE1355 {get;}
public: __property static PDFPantoneColor* get_PANTONE1355();
public:
static property PDFPantoneColor^ PANTONE1355 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1355 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE136 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE136 Property
Gets the PANTONE 136 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE136 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE136
public static PDFPantoneColor PANTONE136 {get;}
public: __property static PDFPantoneColor* get_PANTONE136();
public:
static property PDFPantoneColor^ PANTONE136 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 136 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1365 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1365 Property
Gets the PANTONE 1365 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1365 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1365
public static PDFPantoneColor PANTONE1365 {get;}
public: __property static PDFPantoneColor* get_PANTONE1365();
public:
static property PDFPantoneColor^ PANTONE1365 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1365 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE137 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE137 Property
Gets the PANTONE 137 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE137 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE137
public static PDFPantoneColor PANTONE137 {get;}
public: __property static PDFPantoneColor* get_PANTONE137();
public:
static property PDFPantoneColor^ PANTONE137 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 137 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1375 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1375 Property
Gets the PANTONE 1375 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1375 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1375
public static PDFPantoneColor PANTONE1375 {get;}
public: __property static PDFPantoneColor* get_PANTONE1375();
public:
static property PDFPantoneColor^ PANTONE1375 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1375 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE138 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE138 Property
Gets the PANTONE 138 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE138 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE138
public static PDFPantoneColor PANTONE138 {get;}
public: __property static PDFPantoneColor* get_PANTONE138();
public:
static property PDFPantoneColor^ PANTONE138 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 138 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1385 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1385 Property
Gets the PANTONE 1385 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1385 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1385
public static PDFPantoneColor PANTONE1385 {get;}
public: __property static PDFPantoneColor* get_PANTONE1385();
public:
static property PDFPantoneColor^ PANTONE1385 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1385 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE139 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE139 Property
Gets the PANTONE 139 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE139 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE139
public static PDFPantoneColor PANTONE139 {get;}
public: __property static PDFPantoneColor* get_PANTONE139();
public:
static property PDFPantoneColor^ PANTONE139 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 139 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1395 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1395 Property
Gets the PANTONE 1395 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1395 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1395
public static PDFPantoneColor PANTONE1395 {get;}
public: __property static PDFPantoneColor* get_PANTONE1395();
public:
static property PDFPantoneColor^ PANTONE1395 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1395 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE140 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE140 Property
Gets the PANTONE 140 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE140 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE140
public static PDFPantoneColor PANTONE140 {get;}
public: __property static PDFPantoneColor* get_PANTONE140();
public:
static property PDFPantoneColor^ PANTONE140 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 140 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1405 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1405 Property
Gets the PANTONE 1405 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1405 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1405
public static PDFPantoneColor PANTONE1405 {get;}
public: __property static PDFPantoneColor* get_PANTONE1405();
public:
static property PDFPantoneColor^ PANTONE1405 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1405 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE141 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE141 Property
Gets the PANTONE 141 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE141 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE141
public static PDFPantoneColor PANTONE141 {get;}
public: __property static PDFPantoneColor* get_PANTONE141();
public:
static property PDFPantoneColor^ PANTONE141 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 141 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE142 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE142 Property
Gets the PANTONE 142 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE142 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE142
public static PDFPantoneColor PANTONE142 {get;}
public: __property static PDFPantoneColor* get_PANTONE142();
public:
static property PDFPantoneColor^ PANTONE142 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 142 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE143 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE143 Property
Gets the PANTONE 143 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE143 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE143
public static PDFPantoneColor PANTONE143 {get;}
public: __property static PDFPantoneColor* get_PANTONE143();
public:
static property PDFPantoneColor^ PANTONE143 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 143 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE144 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE144 Property
Gets the PANTONE 144 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE144 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE144
public static PDFPantoneColor PANTONE144 {get;}
public: __property static PDFPantoneColor* get_PANTONE144();
public:
static property PDFPantoneColor^ PANTONE144 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 144 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE145 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE145 Property
Gets the PANTONE 145 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE145 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE145
public static PDFPantoneColor PANTONE145 {get;}
public: __property static PDFPantoneColor* get_PANTONE145();
public:
static property PDFPantoneColor^ PANTONE145 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 145 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE146 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE146 Property
Gets the PANTONE 146 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE146 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE146
public static PDFPantoneColor PANTONE146 {get;}
public: __property static PDFPantoneColor* get_PANTONE146();
public:
static property PDFPantoneColor^ PANTONE146 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 146 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE147 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE147 Property
Gets the PANTONE 147 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE147 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE147
public static PDFPantoneColor PANTONE147 {get;}
public: __property static PDFPantoneColor* get_PANTONE147();
public:
static property PDFPantoneColor^ PANTONE147 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 147 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE148 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE148 Property
Gets the PANTONE 148 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE148 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE148
public static PDFPantoneColor PANTONE148 {get;}
public: __property static PDFPantoneColor* get_PANTONE148();
public:
static property PDFPantoneColor^ PANTONE148 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 148 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1485 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1485 Property
Gets the PANTONE 1485 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1485 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1485
public static PDFPantoneColor PANTONE1485 {get;}
public: __property static PDFPantoneColor* get_PANTONE1485();
public:
static property PDFPantoneColor^ PANTONE1485 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1485 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE149 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE149 Property
Gets the PANTONE 149 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE149 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE149
public static PDFPantoneColor PANTONE149 {get;}
public: __property static PDFPantoneColor* get_PANTONE149();
public:
static property PDFPantoneColor^ PANTONE149 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 149 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1495 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1495 Property
Gets the PANTONE 1495 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1495 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1495
public static PDFPantoneColor PANTONE1495 {get;}
public: __property static PDFPantoneColor* get_PANTONE1495();
public:
static property PDFPantoneColor^ PANTONE1495 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1495 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE150 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE150 Property
Gets the PANTONE 150 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE150 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE150
public static PDFPantoneColor PANTONE150 {get;}
public: __property static PDFPantoneColor* get_PANTONE150();
public:
static property PDFPantoneColor^ PANTONE150 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 150 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1505 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1505 Property
Gets the PANTONE 1505 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1505 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1505
public static PDFPantoneColor PANTONE1505 {get;}
public: __property static PDFPantoneColor* get_PANTONE1505();
public:
static property PDFPantoneColor^ PANTONE1505 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1505 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE151 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE151 Property
Gets the PANTONE 151 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE151 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE151
public static PDFPantoneColor PANTONE151 {get;}
public: __property static PDFPantoneColor* get_PANTONE151();
public:
static property PDFPantoneColor^ PANTONE151 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 151 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE152 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE152 Property
Gets the PANTONE 152 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE152 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE152
public static PDFPantoneColor PANTONE152 {get;}
public: __property static PDFPantoneColor* get_PANTONE152();
public:
static property PDFPantoneColor^ PANTONE152 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 152 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1525 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1525 Property
Gets the PANTONE 1525 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1525 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1525
public static PDFPantoneColor PANTONE1525 {get;}
public: __property static PDFPantoneColor* get_PANTONE1525();
public:
static property PDFPantoneColor^ PANTONE1525 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1525 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE153 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE153 Property
Gets the PANTONE 153 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE153 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE153
public static PDFPantoneColor PANTONE153 {get;}
public: __property static PDFPantoneColor* get_PANTONE153();
public:
static property PDFPantoneColor^ PANTONE153 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 153 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1535 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1535 Property
Gets the PANTONE 1535 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1535 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1535
public static PDFPantoneColor PANTONE1535 {get;}
public: __property static PDFPantoneColor* get_PANTONE1535();
public:
static property PDFPantoneColor^ PANTONE1535 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1535 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE154 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE154 Property
Gets the PANTONE 154 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE154 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE154
public static PDFPantoneColor PANTONE154 {get;}
public: __property static PDFPantoneColor* get_PANTONE154();
public:
static property PDFPantoneColor^ PANTONE154 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 154 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1545 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1545 Property
Gets the PANTONE 1545 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1545 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1545
public static PDFPantoneColor PANTONE1545 {get;}
public: __property static PDFPantoneColor* get_PANTONE1545();
public:
static property PDFPantoneColor^ PANTONE1545 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1545 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE155 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE155 Property
Gets the PANTONE 155 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE155 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE155
public static PDFPantoneColor PANTONE155 {get;}
public: __property static PDFPantoneColor* get_PANTONE155();
public:
static property PDFPantoneColor^ PANTONE155 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 155 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1555 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1555 Property
Gets the PANTONE 1555 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1555 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1555
public static PDFPantoneColor PANTONE1555 {get;}
public: __property static PDFPantoneColor* get_PANTONE1555();
public:
static property PDFPantoneColor^ PANTONE1555 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1555 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE156 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE156 Property
Gets the PANTONE 156 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE156 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE156
public static PDFPantoneColor PANTONE156 {get;}
public: __property static PDFPantoneColor* get_PANTONE156();
public:
static property PDFPantoneColor^ PANTONE156 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 156 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1565 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1565 Property
Gets the PANTONE 1565 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1565 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1565
public static PDFPantoneColor PANTONE1565 {get;}
public: __property static PDFPantoneColor* get_PANTONE1565();
public:
static property PDFPantoneColor^ PANTONE1565 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1565 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE157 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE157 Property
Gets the PANTONE 157 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE157 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE157
public static PDFPantoneColor PANTONE157 {get;}
public: __property static PDFPantoneColor* get_PANTONE157();
public:
static property PDFPantoneColor^ PANTONE157 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 157 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1575 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1575 Property
Gets the PANTONE 1575 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1575 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1575
public static PDFPantoneColor PANTONE1575 {get;}
public: __property static PDFPantoneColor* get_PANTONE1575();
public:
static property PDFPantoneColor^ PANTONE1575 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1575 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE158 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE158 Property
Gets the PANTONE 158 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE158 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE158
public static PDFPantoneColor PANTONE158 {get;}
public: __property static PDFPantoneColor* get_PANTONE158();
public:
static property PDFPantoneColor^ PANTONE158 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 158 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1585 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1585 Property
Gets the PANTONE 1585 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1585 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1585
public static PDFPantoneColor PANTONE1585 {get;}
public: __property static PDFPantoneColor* get_PANTONE1585();
public:
static property PDFPantoneColor^ PANTONE1585 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1585 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE159 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE159 Property
Gets the PANTONE 159 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE159 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE159
public static PDFPantoneColor PANTONE159 {get;}
public: __property static PDFPantoneColor* get_PANTONE159();
public:
static property PDFPantoneColor^ PANTONE159 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 159 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1595 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1595 Property
Gets the PANTONE 1595 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1595 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1595
public static PDFPantoneColor PANTONE1595 {get;}
public: __property static PDFPantoneColor* get_PANTONE1595();
public:
static property PDFPantoneColor^ PANTONE1595 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1595 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE160 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE160 Property
Gets the PANTONE 160 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE160 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE160
public static PDFPantoneColor PANTONE160 {get;}
public: __property static PDFPantoneColor* get_PANTONE160();
public:
static property PDFPantoneColor^ PANTONE160 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 160 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1605 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1605 Property
Gets the PANTONE 1605 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1605 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1605
public static PDFPantoneColor PANTONE1605 {get;}
public: __property static PDFPantoneColor* get_PANTONE1605();
public:
static property PDFPantoneColor^ PANTONE1605 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1605 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE161 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE161 Property
Gets the PANTONE 161 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE161 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE161
public static PDFPantoneColor PANTONE161 {get;}
public: __property static PDFPantoneColor* get_PANTONE161();
public:
static property PDFPantoneColor^ PANTONE161 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 161 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1615 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1615 Property
Gets the PANTONE 1615 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1615 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1615
public static PDFPantoneColor PANTONE1615 {get;}
public: __property static PDFPantoneColor* get_PANTONE1615();
public:
static property PDFPantoneColor^ PANTONE1615 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1615 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE162 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE162 Property
Gets the PANTONE 162 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE162 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE162
public static PDFPantoneColor PANTONE162 {get;}
public: __property static PDFPantoneColor* get_PANTONE162();
public:
static property PDFPantoneColor^ PANTONE162 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 162 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1625 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1625 Property
Gets the PANTONE 1625 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1625 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1625
public static PDFPantoneColor PANTONE1625 {get;}
public: __property static PDFPantoneColor* get_PANTONE1625();
public:
static property PDFPantoneColor^ PANTONE1625 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1625 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE163 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE163 Property
Gets the PANTONE 163 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE163 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE163
public static PDFPantoneColor PANTONE163 {get;}
public: __property static PDFPantoneColor* get_PANTONE163();
public:
static property PDFPantoneColor^ PANTONE163 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 163 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1635 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1635 Property
Gets the PANTONE 1635 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1635 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1635
public static PDFPantoneColor PANTONE1635 {get;}
public: __property static PDFPantoneColor* get_PANTONE1635();
public:
static property PDFPantoneColor^ PANTONE1635 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1635 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE164 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE164 Property
Gets the PANTONE 164 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE164 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE164
public static PDFPantoneColor PANTONE164 {get;}
public: __property static PDFPantoneColor* get_PANTONE164();
public:
static property PDFPantoneColor^ PANTONE164 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 164 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1645 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1645 Property
Gets the PANTONE 1645 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1645 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1645
public static PDFPantoneColor PANTONE1645 {get;}
public: __property static PDFPantoneColor* get_PANTONE1645();
public:
static property PDFPantoneColor^ PANTONE1645 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1645 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE165 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE165 Property
Gets the PANTONE 165 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE165 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE165
public static PDFPantoneColor PANTONE165 {get;}
public: __property static PDFPantoneColor* get_PANTONE165();
public:
static property PDFPantoneColor^ PANTONE165 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 165 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1655 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1655 Property
Gets the PANTONE 1655 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1655 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1655
public static PDFPantoneColor PANTONE1655 {get;}
public: __property static PDFPantoneColor* get_PANTONE1655();
public:
static property PDFPantoneColor^ PANTONE1655 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1655 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE166 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE166 Property
Gets the PANTONE 166 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE166 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE166
public static PDFPantoneColor PANTONE166 {get;}
public: __property static PDFPantoneColor* get_PANTONE166();
public:
static property PDFPantoneColor^ PANTONE166 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 166 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1665 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1665 Property
Gets the PANTONE 1665 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1665 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1665
public static PDFPantoneColor PANTONE1665 {get;}
public: __property static PDFPantoneColor* get_PANTONE1665();
public:
static property PDFPantoneColor^ PANTONE1665 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1665 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE167 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE167 Property
Gets the PANTONE 167 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE167 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE167
public static PDFPantoneColor PANTONE167 {get;}
public: __property static PDFPantoneColor* get_PANTONE167();
public:
static property PDFPantoneColor^ PANTONE167 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 167 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1675 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1675 Property
Gets the PANTONE 1675 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1675 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1675
public static PDFPantoneColor PANTONE1675 {get;}
public: __property static PDFPantoneColor* get_PANTONE1675();
public:
static property PDFPantoneColor^ PANTONE1675 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1675 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE168 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE168 Property
Gets the PANTONE 168 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE168 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE168
public static PDFPantoneColor PANTONE168 {get;}
public: __property static PDFPantoneColor* get_PANTONE168();
public:
static property PDFPantoneColor^ PANTONE168 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 168 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1685 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1685 Property
Gets the PANTONE 1685 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1685 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1685
public static PDFPantoneColor PANTONE1685 {get;}
public: __property static PDFPantoneColor* get_PANTONE1685();
public:
static property PDFPantoneColor^ PANTONE1685 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1685 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE169 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE169 Property
Gets the PANTONE 169 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE169 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE169
public static PDFPantoneColor PANTONE169 {get;}
public: __property static PDFPantoneColor* get_PANTONE169();
public:
static property PDFPantoneColor^ PANTONE169 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 169 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE170 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE170 Property
Gets the PANTONE 170 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE170 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE170
public static PDFPantoneColor PANTONE170 {get;}
public: __property static PDFPantoneColor* get_PANTONE170();
public:
static property PDFPantoneColor^ PANTONE170 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 170 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE171 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE171 Property
Gets the PANTONE 171 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE171 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE171
public static PDFPantoneColor PANTONE171 {get;}
public: __property static PDFPantoneColor* get_PANTONE171();
public:
static property PDFPantoneColor^ PANTONE171 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 171 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE172 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE172 Property
Gets the PANTONE 172 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE172 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE172
public static PDFPantoneColor PANTONE172 {get;}
public: __property static PDFPantoneColor* get_PANTONE172();
public:
static property PDFPantoneColor^ PANTONE172 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 172 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE173 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE173 Property
Gets the PANTONE 173 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE173 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE173
public static PDFPantoneColor PANTONE173 {get;}
public: __property static PDFPantoneColor* get_PANTONE173();
public:
static property PDFPantoneColor^ PANTONE173 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 173 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE174 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE174 Property
Gets the PANTONE 174 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE174 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE174
public static PDFPantoneColor PANTONE174 {get;}
public: __property static PDFPantoneColor* get_PANTONE174();
public:
static property PDFPantoneColor^ PANTONE174 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 174 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE175 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE175 Property
Gets the PANTONE 175 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE175 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE175
public static PDFPantoneColor PANTONE175 {get;}
public: __property static PDFPantoneColor* get_PANTONE175();
public:
static property PDFPantoneColor^ PANTONE175 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 175 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE176 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE176 Property
Gets the PANTONE 176 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE176 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE176
public static PDFPantoneColor PANTONE176 {get;}
public: __property static PDFPantoneColor* get_PANTONE176();
public:
static property PDFPantoneColor^ PANTONE176 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 176 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1765 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1765 Property
Gets the PANTONE 1765 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1765 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1765
public static PDFPantoneColor PANTONE1765 {get;}
public: __property static PDFPantoneColor* get_PANTONE1765();
public:
static property PDFPantoneColor^ PANTONE1765 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1765 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1767 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1767 Property
Gets the PANTONE 1767 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1767 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1767
public static PDFPantoneColor PANTONE1767 {get;}
public: __property static PDFPantoneColor* get_PANTONE1767();
public:
static property PDFPantoneColor^ PANTONE1767 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1767 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE177 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE177 Property
Gets the PANTONE 177 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE177 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE177
public static PDFPantoneColor PANTONE177 {get;}
public: __property static PDFPantoneColor* get_PANTONE177();
public:
static property PDFPantoneColor^ PANTONE177 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 177 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1775 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1775 Property
Gets the PANTONE 1775 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1775 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1775
public static PDFPantoneColor PANTONE1775 {get;}
public: __property static PDFPantoneColor* get_PANTONE1775();
public:
static property PDFPantoneColor^ PANTONE1775 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1775 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1777 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1777 Property
Gets the PANTONE 1777 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1777 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1777
public static PDFPantoneColor PANTONE1777 {get;}
public: __property static PDFPantoneColor* get_PANTONE1777();
public:
static property PDFPantoneColor^ PANTONE1777 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1777 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE178 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE178 Property
Gets the PANTONE 178 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE178 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE178
public static PDFPantoneColor PANTONE178 {get;}
public: __property static PDFPantoneColor* get_PANTONE178();
public:
static property PDFPantoneColor^ PANTONE178 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 178 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1785 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1785 Property
Gets the PANTONE 1785 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1785 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1785
public static PDFPantoneColor PANTONE1785 {get;}
public: __property static PDFPantoneColor* get_PANTONE1785();
public:
static property PDFPantoneColor^ PANTONE1785 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1785 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1787 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1787 Property
Gets the PANTONE 1787 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1787 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1787
public static PDFPantoneColor PANTONE1787 {get;}
public: __property static PDFPantoneColor* get_PANTONE1787();
public:
static property PDFPantoneColor^ PANTONE1787 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1787 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1788 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1788 Property
Gets the PANTONE 1788 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1788 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1788
public static PDFPantoneColor PANTONE1788 {get;}
public: __property static PDFPantoneColor* get_PANTONE1788();
public:
static property PDFPantoneColor^ PANTONE1788 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1788 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE179 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE179 Property
Gets the PANTONE 179 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE179 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE179
public static PDFPantoneColor PANTONE179 {get;}
public: __property static PDFPantoneColor* get_PANTONE179();
public:
static property PDFPantoneColor^ PANTONE179 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 179 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1795 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1795 Property
Gets the PANTONE 1795 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1795 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1795
public static PDFPantoneColor PANTONE1795 {get;}
public: __property static PDFPantoneColor* get_PANTONE1795();
public:
static property PDFPantoneColor^ PANTONE1795 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1795 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1797 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1797 Property
Gets the PANTONE 1797 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1797 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1797
public static PDFPantoneColor PANTONE1797 {get;}
public: __property static PDFPantoneColor* get_PANTONE1797();
public:
static property PDFPantoneColor^ PANTONE1797 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1797 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE180 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE180 Property
Gets the PANTONE 180 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE180 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE180
public static PDFPantoneColor PANTONE180 {get;}
public: __property static PDFPantoneColor* get_PANTONE180();
public:
static property PDFPantoneColor^ PANTONE180 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 180 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1805 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1805 Property
Gets the PANTONE 1805 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1805 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1805
public static PDFPantoneColor PANTONE1805 {get;}
public: __property static PDFPantoneColor* get_PANTONE1805();
public:
static property PDFPantoneColor^ PANTONE1805 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1805 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1807 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1807 Property
Gets the PANTONE 1807 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1807 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1807
public static PDFPantoneColor PANTONE1807 {get;}
public: __property static PDFPantoneColor* get_PANTONE1807();
public:
static property PDFPantoneColor^ PANTONE1807 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1807 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE181 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE181 Property
Gets the PANTONE 181 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE181 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE181
public static PDFPantoneColor PANTONE181 {get;}
public: __property static PDFPantoneColor* get_PANTONE181();
public:
static property PDFPantoneColor^ PANTONE181 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 181 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1815 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1815 Property
Gets the PANTONE 1815 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1815 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1815
public static PDFPantoneColor PANTONE1815 {get;}
public: __property static PDFPantoneColor* get_PANTONE1815();
public:
static property PDFPantoneColor^ PANTONE1815 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1815 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1817 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1817 Property
Gets the PANTONE 1817 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1817 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1817
public static PDFPantoneColor PANTONE1817 {get;}
public: __property static PDFPantoneColor* get_PANTONE1817();
public:
static property PDFPantoneColor^ PANTONE1817 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1817 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE182 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE182 Property
Gets the PANTONE 182 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE182 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE182
public static PDFPantoneColor PANTONE182 {get;}
public: __property static PDFPantoneColor* get_PANTONE182();
public:
static property PDFPantoneColor^ PANTONE182 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 182 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE183 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE183 Property
Gets the PANTONE 183 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE183 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE183
public static PDFPantoneColor PANTONE183 {get;}
public: __property static PDFPantoneColor* get_PANTONE183();
public:
static property PDFPantoneColor^ PANTONE183 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 183 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE184 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE184 Property
Gets the PANTONE 184 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE184 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE184
public static PDFPantoneColor PANTONE184 {get;}
public: __property static PDFPantoneColor* get_PANTONE184();
public:
static property PDFPantoneColor^ PANTONE184 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 184 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE185 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE185 Property
Gets the PANTONE 185 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE185 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE185
public static PDFPantoneColor PANTONE185 {get;}
public: __property static PDFPantoneColor* get_PANTONE185();
public:
static property PDFPantoneColor^ PANTONE185 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 185 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE186 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE186 Property
Gets the PANTONE 186 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE186 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE186
public static PDFPantoneColor PANTONE186 {get;}
public: __property static PDFPantoneColor* get_PANTONE186();
public:
static property PDFPantoneColor^ PANTONE186 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 186 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE187 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE187 Property
Gets the PANTONE 187 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE187 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE187
public static PDFPantoneColor PANTONE187 {get;}
public: __property static PDFPantoneColor* get_PANTONE187();
public:
static property PDFPantoneColor^ PANTONE187 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 187 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE188 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE188 Property
Gets the PANTONE 188 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE188 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE188
public static PDFPantoneColor PANTONE188 {get;}
public: __property static PDFPantoneColor* get_PANTONE188();
public:
static property PDFPantoneColor^ PANTONE188 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 188 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE189 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE189 Property
Gets the PANTONE 189 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE189 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE189
public static PDFPantoneColor PANTONE189 {get;}
public: __property static PDFPantoneColor* get_PANTONE189();
public:
static property PDFPantoneColor^ PANTONE189 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 189 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1895 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1895 Property
Gets the PANTONE 1895 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1895 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1895
public static PDFPantoneColor PANTONE1895 {get;}
public: __property static PDFPantoneColor* get_PANTONE1895();
public:
static property PDFPantoneColor^ PANTONE1895 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1895 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE190 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE190 Property
Gets the PANTONE 190 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE190 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE190
public static PDFPantoneColor PANTONE190 {get;}
public: __property static PDFPantoneColor* get_PANTONE190();
public:
static property PDFPantoneColor^ PANTONE190 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 190 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1905 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1905 Property
Gets the PANTONE 1905 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1905 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1905
public static PDFPantoneColor PANTONE1905 {get;}
public: __property static PDFPantoneColor* get_PANTONE1905();
public:
static property PDFPantoneColor^ PANTONE1905 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1905 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE191 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE191 Property
Gets the PANTONE 191 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE191 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE191
public static PDFPantoneColor PANTONE191 {get;}
public: __property static PDFPantoneColor* get_PANTONE191();
public:
static property PDFPantoneColor^ PANTONE191 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 191 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1915 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1915 Property
Gets the PANTONE 1915 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1915 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1915
public static PDFPantoneColor PANTONE1915 {get;}
public: __property static PDFPantoneColor* get_PANTONE1915();
public:
static property PDFPantoneColor^ PANTONE1915 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1915 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE192 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE192 Property
Gets the PANTONE 192 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE192 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE192
public static PDFPantoneColor PANTONE192 {get;}
public: __property static PDFPantoneColor* get_PANTONE192();
public:
static property PDFPantoneColor^ PANTONE192 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 192 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1925 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1925 Property
Gets the PANTONE 1925 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1925 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1925
public static PDFPantoneColor PANTONE1925 {get;}
public: __property static PDFPantoneColor* get_PANTONE1925();
public:
static property PDFPantoneColor^ PANTONE1925 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1925 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE193 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE193 Property
Gets the PANTONE 193 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE193 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE193
public static PDFPantoneColor PANTONE193 {get;}
public: __property static PDFPantoneColor* get_PANTONE193();
public:
static property PDFPantoneColor^ PANTONE193 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 193 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1935 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1935 Property
Gets the PANTONE 1935 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1935 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1935
public static PDFPantoneColor PANTONE1935 {get;}
public: __property static PDFPantoneColor* get_PANTONE1935();
public:
static property PDFPantoneColor^ PANTONE1935 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1935 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE194 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE194 Property
Gets the PANTONE 194 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE194 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE194
public static PDFPantoneColor PANTONE194 {get;}
public: __property static PDFPantoneColor* get_PANTONE194();
public:
static property PDFPantoneColor^ PANTONE194 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 194 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1945 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1945 Property
Gets the PANTONE 1945 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1945 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1945
public static PDFPantoneColor PANTONE1945 {get;}
public: __property static PDFPantoneColor* get_PANTONE1945();
public:
static property PDFPantoneColor^ PANTONE1945 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1945 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE195 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE195 Property
Gets the PANTONE 195 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE195 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE195
public static PDFPantoneColor PANTONE195 {get;}
public: __property static PDFPantoneColor* get_PANTONE195();
public:
static property PDFPantoneColor^ PANTONE195 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 195 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1955 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1955 Property
Gets the PANTONE 1955 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1955 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1955
public static PDFPantoneColor PANTONE1955 {get;}
public: __property static PDFPantoneColor* get_PANTONE1955();
public:
static property PDFPantoneColor^ PANTONE1955 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 1955 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE196 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE196 Property
Gets the PANTONE 196 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE196 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE196
public static PDFPantoneColor PANTONE196 {get;}
public: __property static PDFPantoneColor* get_PANTONE196();
public:
static property PDFPantoneColor^ PANTONE196 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 196 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE197 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE197 Property
Gets the PANTONE 197 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE197 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE197
public static PDFPantoneColor PANTONE197 {get;}
public: __property static PDFPantoneColor* get_PANTONE197();
public:
static property PDFPantoneColor^ PANTONE197 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 197 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE198 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE198 Property
Gets the PANTONE 198 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE198 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE198
public static PDFPantoneColor PANTONE198 {get;}
public: __property static PDFPantoneColor* get_PANTONE198();
public:
static property PDFPantoneColor^ PANTONE198 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 198 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE199 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE199 Property
Gets the PANTONE 199 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE199 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE199
public static PDFPantoneColor PANTONE199 {get;}
public: __property static PDFPantoneColor* get_PANTONE199();
public:
static property PDFPantoneColor^ PANTONE199 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 199 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE200 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE200 Property
Gets the PANTONE 200 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE200 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE200
public static PDFPantoneColor PANTONE200 {get;}
public: __property static PDFPantoneColor* get_PANTONE200();
public:
static property PDFPantoneColor^ PANTONE200 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 200 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE201 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE201 Property
Gets the PANTONE 201 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE201 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE201
public static PDFPantoneColor PANTONE201 {get;}
public: __property static PDFPantoneColor* get_PANTONE201();
public:
static property PDFPantoneColor^ PANTONE201 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 201 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE202 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE202 Property
Gets the PANTONE 202 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE202 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE202
public static PDFPantoneColor PANTONE202 {get;}
public: __property static PDFPantoneColor* get_PANTONE202();
public:
static property PDFPantoneColor^ PANTONE202 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 202 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE203 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE203 Property
Gets the PANTONE 203 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE203 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE203
public static PDFPantoneColor PANTONE203 {get;}
public: __property static PDFPantoneColor* get_PANTONE203();
public:
static property PDFPantoneColor^ PANTONE203 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 203 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE204 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE204 Property
Gets the PANTONE 204 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE204 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE204
public static PDFPantoneColor PANTONE204 {get;}
public: __property static PDFPantoneColor* get_PANTONE204();
public:
static property PDFPantoneColor^ PANTONE204 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 204 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE205 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE205 Property
Gets the PANTONE 205 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE205 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE205
public static PDFPantoneColor PANTONE205 {get;}
public: __property static PDFPantoneColor* get_PANTONE205();
public:
static property PDFPantoneColor^ PANTONE205 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 205 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE206 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE206 Property
Gets the PANTONE 206 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE206 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE206
public static PDFPantoneColor PANTONE206 {get;}
public: __property static PDFPantoneColor* get_PANTONE206();
public:
static property PDFPantoneColor^ PANTONE206 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 206 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE207 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE207 Property
Gets the PANTONE 207 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE207 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE207
public static PDFPantoneColor PANTONE207 {get;}
public: __property static PDFPantoneColor* get_PANTONE207();
public:
static property PDFPantoneColor^ PANTONE207 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 207 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE208 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE208 Property
Gets the PANTONE 208 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE208 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE208
public static PDFPantoneColor PANTONE208 {get;}
public: __property static PDFPantoneColor* get_PANTONE208();
public:
static property PDFPantoneColor^ PANTONE208 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 208 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE209 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE209 Property
Gets the PANTONE 209 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE209 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE209
public static PDFPantoneColor PANTONE209 {get;}
public: __property static PDFPantoneColor* get_PANTONE209();
public:
static property PDFPantoneColor^ PANTONE209 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 209 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE210 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE210 Property
Gets the PANTONE 210 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE210 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE210
public static PDFPantoneColor PANTONE210 {get;}
public: __property static PDFPantoneColor* get_PANTONE210();
public:
static property PDFPantoneColor^ PANTONE210 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 210 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE211 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE211 Property
Gets the PANTONE 211 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE211 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE211
public static PDFPantoneColor PANTONE211 {get;}
public: __property static PDFPantoneColor* get_PANTONE211();
public:
static property PDFPantoneColor^ PANTONE211 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 211 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE212 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE212 Property
Gets the PANTONE 212 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE212 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE212
public static PDFPantoneColor PANTONE212 {get;}
public: __property static PDFPantoneColor* get_PANTONE212();
public:
static property PDFPantoneColor^ PANTONE212 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 212 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE213 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE213 Property
Gets the PANTONE 213 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE213 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE213
public static PDFPantoneColor PANTONE213 {get;}
public: __property static PDFPantoneColor* get_PANTONE213();
public:
static property PDFPantoneColor^ PANTONE213 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 213 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE214 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE214 Property
Gets the PANTONE 214 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE214 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE214
public static PDFPantoneColor PANTONE214 {get;}
public: __property static PDFPantoneColor* get_PANTONE214();
public:
static property PDFPantoneColor^ PANTONE214 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 214 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE215 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE215 Property
Gets the PANTONE 215 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE215 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE215
public static PDFPantoneColor PANTONE215 {get;}
public: __property static PDFPantoneColor* get_PANTONE215();
public:
static property PDFPantoneColor^ PANTONE215 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 215 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE216 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE216 Property
Gets the PANTONE 216 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE216 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE216
public static PDFPantoneColor PANTONE216 {get;}
public: __property static PDFPantoneColor* get_PANTONE216();
public:
static property PDFPantoneColor^ PANTONE216 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 216 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE217 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE217 Property
Gets the PANTONE 217 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE217 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE217
public static PDFPantoneColor PANTONE217 {get;}
public: __property static PDFPantoneColor* get_PANTONE217();
public:
static property PDFPantoneColor^ PANTONE217 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 217 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE218 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE218 Property
Gets the PANTONE 218 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE218 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE218
public static PDFPantoneColor PANTONE218 {get;}
public: __property static PDFPantoneColor* get_PANTONE218();
public:
static property PDFPantoneColor^ PANTONE218 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 218 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE219 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE219 Property
Gets the PANTONE 219 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE219 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE219
public static PDFPantoneColor PANTONE219 {get;}
public: __property static PDFPantoneColor* get_PANTONE219();
public:
static property PDFPantoneColor^ PANTONE219 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 219 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE220 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE220 Property
Gets the PANTONE 220 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE220 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE220
public static PDFPantoneColor PANTONE220 {get;}
public: __property static PDFPantoneColor* get_PANTONE220();
public:
static property PDFPantoneColor^ PANTONE220 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 220 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE221 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE221 Property
Gets the PANTONE 221 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE221 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE221
public static PDFPantoneColor PANTONE221 {get;}
public: __property static PDFPantoneColor* get_PANTONE221();
public:
static property PDFPantoneColor^ PANTONE221 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 221 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE222 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE222 Property
Gets the PANTONE 222 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE222 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE222
public static PDFPantoneColor PANTONE222 {get;}
public: __property static PDFPantoneColor* get_PANTONE222();
public:
static property PDFPantoneColor^ PANTONE222 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 222 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE223 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE223 Property
Gets the PANTONE 223 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE223 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE223
public static PDFPantoneColor PANTONE223 {get;}
public: __property static PDFPantoneColor* get_PANTONE223();
public:
static property PDFPantoneColor^ PANTONE223 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 223 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE224 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE224 Property
Gets the PANTONE 224 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE224 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE224
public static PDFPantoneColor PANTONE224 {get;}
public: __property static PDFPantoneColor* get_PANTONE224();
public:
static property PDFPantoneColor^ PANTONE224 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 224 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE225 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE225 Property
Gets the PANTONE 225 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE225 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE225
public static PDFPantoneColor PANTONE225 {get;}
public: __property static PDFPantoneColor* get_PANTONE225();
public:
static property PDFPantoneColor^ PANTONE225 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 225 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE226 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE226 Property
Gets the PANTONE 226 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE226 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE226
public static PDFPantoneColor PANTONE226 {get;}
public: __property static PDFPantoneColor* get_PANTONE226();
public:
static property PDFPantoneColor^ PANTONE226 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 226 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE227 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE227 Property
Gets the PANTONE 227 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE227 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE227
public static PDFPantoneColor PANTONE227 {get;}
public: __property static PDFPantoneColor* get_PANTONE227();
public:
static property PDFPantoneColor^ PANTONE227 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 227 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE228 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE228 Property
Gets the PANTONE 228 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE228 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE228
public static PDFPantoneColor PANTONE228 {get;}
public: __property static PDFPantoneColor* get_PANTONE228();
public:
static property PDFPantoneColor^ PANTONE228 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 228 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE229 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE229 Property
Gets the PANTONE 229 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE229 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE229
public static PDFPantoneColor PANTONE229 {get;}
public: __property static PDFPantoneColor* get_PANTONE229();
public:
static property PDFPantoneColor^ PANTONE229 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 229 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE230 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE230 Property
Gets the PANTONE 230 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE230 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE230
public static PDFPantoneColor PANTONE230 {get;}
public: __property static PDFPantoneColor* get_PANTONE230();
public:
static property PDFPantoneColor^ PANTONE230 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 230 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE231 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE231 Property
Gets the PANTONE 231 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE231 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE231
public static PDFPantoneColor PANTONE231 {get;}
public: __property static PDFPantoneColor* get_PANTONE231();
public:
static property PDFPantoneColor^ PANTONE231 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 231 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE232 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE232 Property
Gets the PANTONE 232 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE232 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE232
public static PDFPantoneColor PANTONE232 {get;}
public: __property static PDFPantoneColor* get_PANTONE232();
public:
static property PDFPantoneColor^ PANTONE232 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 232 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE233 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE233 Property
Gets the PANTONE 233 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE233 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE233
public static PDFPantoneColor PANTONE233 {get;}
public: __property static PDFPantoneColor* get_PANTONE233();
public:
static property PDFPantoneColor^ PANTONE233 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 233 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE234 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE234 Property
Gets the PANTONE 234 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE234 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE234
public static PDFPantoneColor PANTONE234 {get;}
public: __property static PDFPantoneColor* get_PANTONE234();
public:
static property PDFPantoneColor^ PANTONE234 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 234 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE235 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE235 Property
Gets the PANTONE 235 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE235 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE235
public static PDFPantoneColor PANTONE235 {get;}
public: __property static PDFPantoneColor* get_PANTONE235();
public:
static property PDFPantoneColor^ PANTONE235 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 235 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE236 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE236 Property
Gets the PANTONE 236 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE236 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE236
public static PDFPantoneColor PANTONE236 {get;}
public: __property static PDFPantoneColor* get_PANTONE236();
public:
static property PDFPantoneColor^ PANTONE236 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 236 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2365 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2365 Property
Gets the PANTONE 2365 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2365 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2365
public static PDFPantoneColor PANTONE2365 {get;}
public: __property static PDFPantoneColor* get_PANTONE2365();
public:
static property PDFPantoneColor^ PANTONE2365 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2365 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE237 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE237 Property
Gets the PANTONE 237 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE237 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE237
public static PDFPantoneColor PANTONE237 {get;}
public: __property static PDFPantoneColor* get_PANTONE237();
public:
static property PDFPantoneColor^ PANTONE237 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 237 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2375 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2375 Property
Gets the PANTONE 2375 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2375 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2375
public static PDFPantoneColor PANTONE2375 {get;}
public: __property static PDFPantoneColor* get_PANTONE2375();
public:
static property PDFPantoneColor^ PANTONE2375 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2375 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE238 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE238 Property
Gets the PANTONE 238 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE238 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE238
public static PDFPantoneColor PANTONE238 {get;}
public: __property static PDFPantoneColor* get_PANTONE238();
public:
static property PDFPantoneColor^ PANTONE238 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 238 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2385 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2385 Property
Gets the PANTONE 2385 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2385 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2385
public static PDFPantoneColor PANTONE2385 {get;}
public: __property static PDFPantoneColor* get_PANTONE2385();
public:
static property PDFPantoneColor^ PANTONE2385 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2385 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE239 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE239 Property
Gets the PANTONE 239 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE239 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE239
public static PDFPantoneColor PANTONE239 {get;}
public: __property static PDFPantoneColor* get_PANTONE239();
public:
static property PDFPantoneColor^ PANTONE239 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 239 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2395 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2395 Property
Gets the PANTONE 2395 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2395 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2395
public static PDFPantoneColor PANTONE2395 {get;}
public: __property static PDFPantoneColor* get_PANTONE2395();
public:
static property PDFPantoneColor^ PANTONE2395 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2395 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE240 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE240 Property
Gets the PANTONE 240 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE240 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE240
public static PDFPantoneColor PANTONE240 {get;}
public: __property static PDFPantoneColor* get_PANTONE240();
public:
static property PDFPantoneColor^ PANTONE240 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 240 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2405 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2405 Property
Gets the PANTONE 2405 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2405 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2405
public static PDFPantoneColor PANTONE2405 {get;}
public: __property static PDFPantoneColor* get_PANTONE2405();
public:
static property PDFPantoneColor^ PANTONE2405 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2405 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE241 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE241 Property
Gets the PANTONE 241 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE241 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE241
public static PDFPantoneColor PANTONE241 {get;}
public: __property static PDFPantoneColor* get_PANTONE241();
public:
static property PDFPantoneColor^ PANTONE241 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 241 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2415 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2415 Property
Gets the PANTONE 2415 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2415 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2415
public static PDFPantoneColor PANTONE2415 {get;}
public: __property static PDFPantoneColor* get_PANTONE2415();
public:
static property PDFPantoneColor^ PANTONE2415 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2415 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE242 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE242 Property
Gets the PANTONE 242 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE242 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE242
public static PDFPantoneColor PANTONE242 {get;}
public: __property static PDFPantoneColor* get_PANTONE242();
public:
static property PDFPantoneColor^ PANTONE242 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 242 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2425 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2425 Property
Gets the PANTONE 2425 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2425 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2425
public static PDFPantoneColor PANTONE2425 {get;}
public: __property static PDFPantoneColor* get_PANTONE2425();
public:
static property PDFPantoneColor^ PANTONE2425 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2425 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE243 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE243 Property
Gets the PANTONE 243 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE243 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE243
public static PDFPantoneColor PANTONE243 {get;}
public: __property static PDFPantoneColor* get_PANTONE243();
public:
static property PDFPantoneColor^ PANTONE243 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 243 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE244 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE244 Property
Gets the PANTONE 244 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE244 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE244
public static PDFPantoneColor PANTONE244 {get;}
public: __property static PDFPantoneColor* get_PANTONE244();
public:
static property PDFPantoneColor^ PANTONE244 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 244 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE245 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE245 Property
Gets the PANTONE 245 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE245 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE245
public static PDFPantoneColor PANTONE245 {get;}
public: __property static PDFPantoneColor* get_PANTONE245();
public:
static property PDFPantoneColor^ PANTONE245 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 245 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE246 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE246 Property
Gets the PANTONE 246 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE246 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE246
public static PDFPantoneColor PANTONE246 {get;}
public: __property static PDFPantoneColor* get_PANTONE246();
public:
static property PDFPantoneColor^ PANTONE246 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 246 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE247 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE247 Property
Gets the PANTONE 247 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE247 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE247
public static PDFPantoneColor PANTONE247 {get;}
public: __property static PDFPantoneColor* get_PANTONE247();
public:
static property PDFPantoneColor^ PANTONE247 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 247 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE248 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE248 Property
Gets the PANTONE 248 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE248 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE248
public static PDFPantoneColor PANTONE248 {get;}
public: __property static PDFPantoneColor* get_PANTONE248();
public:
static property PDFPantoneColor^ PANTONE248 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 248 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE249 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE249 Property
Gets the PANTONE 249 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE249 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE249
public static PDFPantoneColor PANTONE249 {get;}
public: __property static PDFPantoneColor* get_PANTONE249();
public:
static property PDFPantoneColor^ PANTONE249 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 249 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE250 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE250 Property
Gets the PANTONE 250 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE250 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE250
public static PDFPantoneColor PANTONE250 {get;}
public: __property static PDFPantoneColor* get_PANTONE250();
public:
static property PDFPantoneColor^ PANTONE250 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 250 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE251 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE251 Property
Gets the PANTONE 251 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE251 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE251
public static PDFPantoneColor PANTONE251 {get;}
public: __property static PDFPantoneColor* get_PANTONE251();
public:
static property PDFPantoneColor^ PANTONE251 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 251 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE252 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE252 Property
Gets the PANTONE 252 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE252 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE252
public static PDFPantoneColor PANTONE252 {get;}
public: __property static PDFPantoneColor* get_PANTONE252();
public:
static property PDFPantoneColor^ PANTONE252 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 252 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE253 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE253 Property
Gets the PANTONE 253 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE253 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE253
public static PDFPantoneColor PANTONE253 {get;}
public: __property static PDFPantoneColor* get_PANTONE253();
public:
static property PDFPantoneColor^ PANTONE253 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 253 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE254 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE254 Property
Gets the PANTONE 254 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE254 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE254
public static PDFPantoneColor PANTONE254 {get;}
public: __property static PDFPantoneColor* get_PANTONE254();
public:
static property PDFPantoneColor^ PANTONE254 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 254 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE255 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE255 Property
Gets the PANTONE 255 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE255 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE255
public static PDFPantoneColor PANTONE255 {get;}
public: __property static PDFPantoneColor* get_PANTONE255();
public:
static property PDFPantoneColor^ PANTONE255 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 255 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE256 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE256 Property
Gets the PANTONE 256 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE256 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE256
public static PDFPantoneColor PANTONE256 {get;}
public: __property static PDFPantoneColor* get_PANTONE256();
public:
static property PDFPantoneColor^ PANTONE256 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 256 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2562 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2562 Property
Gets the PANTONE 2562 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2562 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2562
public static PDFPantoneColor PANTONE2562 {get;}
public: __property static PDFPantoneColor* get_PANTONE2562();
public:
static property PDFPantoneColor^ PANTONE2562 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2562 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2563 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2563 Property
Gets the PANTONE 2563 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2563 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2563
public static PDFPantoneColor PANTONE2563 {get;}
public: __property static PDFPantoneColor* get_PANTONE2563();
public:
static property PDFPantoneColor^ PANTONE2563 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2563 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2567 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2567 Property
Gets the PANTONE 2567 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2567 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2567
public static PDFPantoneColor PANTONE2567 {get;}
public: __property static PDFPantoneColor* get_PANTONE2567();
public:
static property PDFPantoneColor^ PANTONE2567 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2567 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE257 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE257 Property
Gets the PANTONE 257 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE257 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE257
public static PDFPantoneColor PANTONE257 {get;}
public: __property static PDFPantoneColor* get_PANTONE257();
public:
static property PDFPantoneColor^ PANTONE257 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 257 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2572 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2572 Property
Gets the PANTONE 2572 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2572 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2572
public static PDFPantoneColor PANTONE2572 {get;}
public: __property static PDFPantoneColor* get_PANTONE2572();
public:
static property PDFPantoneColor^ PANTONE2572 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2572 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2573 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2573 Property
Gets the PANTONE 2573 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2573 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2573
public static PDFPantoneColor PANTONE2573 {get;}
public: __property static PDFPantoneColor* get_PANTONE2573();
public:
static property PDFPantoneColor^ PANTONE2573 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2573 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2577 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2577 Property
Gets the PANTONE 2577 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2577 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2577
public static PDFPantoneColor PANTONE2577 {get;}
public: __property static PDFPantoneColor* get_PANTONE2577();
public:
static property PDFPantoneColor^ PANTONE2577 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2577 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE258 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE258 Property
Gets the PANTONE 258 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE258 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE258
public static PDFPantoneColor PANTONE258 {get;}
public: __property static PDFPantoneColor* get_PANTONE258();
public:
static property PDFPantoneColor^ PANTONE258 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 258 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2582 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2582 Property
Gets the PANTONE 2582 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2582 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2582
public static PDFPantoneColor PANTONE2582 {get;}
public: __property static PDFPantoneColor* get_PANTONE2582();
public:
static property PDFPantoneColor^ PANTONE2582 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2582 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2583 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2583 Property
Gets the PANTONE 2583 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2583 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2583
public static PDFPantoneColor PANTONE2583 {get;}
public: __property static PDFPantoneColor* get_PANTONE2583();
public:
static property PDFPantoneColor^ PANTONE2583 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2583 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2587 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2587 Property
Gets the PANTONE 2587 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2587 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2587
public static PDFPantoneColor PANTONE2587 {get;}
public: __property static PDFPantoneColor* get_PANTONE2587();
public:
static property PDFPantoneColor^ PANTONE2587 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2587 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE259 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE259 Property
Gets the PANTONE 259 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE259 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE259
public static PDFPantoneColor PANTONE259 {get;}
public: __property static PDFPantoneColor* get_PANTONE259();
public:
static property PDFPantoneColor^ PANTONE259 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 259 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2592 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2592 Property
Gets the PANTONE 2592 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2592 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2592
public static PDFPantoneColor PANTONE2592 {get;}
public: __property static PDFPantoneColor* get_PANTONE2592();
public:
static property PDFPantoneColor^ PANTONE2592 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2592 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2593 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2593 Property
Gets the PANTONE 2593 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2593 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2593
public static PDFPantoneColor PANTONE2593 {get;}
public: __property static PDFPantoneColor* get_PANTONE2593();
public:
static property PDFPantoneColor^ PANTONE2593 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2593 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2597 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2597 Property
Gets the PANTONE 2597 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2597 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2597
public static PDFPantoneColor PANTONE2597 {get;}
public: __property static PDFPantoneColor* get_PANTONE2597();
public:
static property PDFPantoneColor^ PANTONE2597 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2597 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE260 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE260 Property
Gets the PANTONE 260 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE260 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE260
public static PDFPantoneColor PANTONE260 {get;}
public: __property static PDFPantoneColor* get_PANTONE260();
public:
static property PDFPantoneColor^ PANTONE260 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 260 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2602 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2602 Property
Gets the PANTONE 2602 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2602 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2602
public static PDFPantoneColor PANTONE2602 {get;}
public: __property static PDFPantoneColor* get_PANTONE2602();
public:
static property PDFPantoneColor^ PANTONE2602 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2602 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2603 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2603 Property
Gets the PANTONE 2603 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2603 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2603
public static PDFPantoneColor PANTONE2603 {get;}
public: __property static PDFPantoneColor* get_PANTONE2603();
public:
static property PDFPantoneColor^ PANTONE2603 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2603 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2607 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2607 Property
Gets the PANTONE 2607 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2607 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2607
public static PDFPantoneColor PANTONE2607 {get;}
public: __property static PDFPantoneColor* get_PANTONE2607();
public:
static property PDFPantoneColor^ PANTONE2607 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2607 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE261 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE261 Property
Gets the PANTONE 261 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE261 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE261
public static PDFPantoneColor PANTONE261 {get;}
public: __property static PDFPantoneColor* get_PANTONE261();
public:
static property PDFPantoneColor^ PANTONE261 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 261 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2612 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2612 Property
Gets the PANTONE 2612 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2612 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2612
public static PDFPantoneColor PANTONE2612 {get;}
public: __property static PDFPantoneColor* get_PANTONE2612();
public:
static property PDFPantoneColor^ PANTONE2612 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2612 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2613 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2613 Property
Gets the PANTONE 2613 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2613 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2613
public static PDFPantoneColor PANTONE2613 {get;}
public: __property static PDFPantoneColor* get_PANTONE2613();
public:
static property PDFPantoneColor^ PANTONE2613 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2613 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2617 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2617 Property
Gets the PANTONE 2617 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2617 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2617
public static PDFPantoneColor PANTONE2617 {get;}
public: __property static PDFPantoneColor* get_PANTONE2617();
public:
static property PDFPantoneColor^ PANTONE2617 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2617 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE262 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE262 Property
Gets the PANTONE 262 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE262 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE262
public static PDFPantoneColor PANTONE262 {get;}
public: __property static PDFPantoneColor* get_PANTONE262();
public:
static property PDFPantoneColor^ PANTONE262 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 262 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2622 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2622 Property
Gets the PANTONE 2622 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2622 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2622
public static PDFPantoneColor PANTONE2622 {get;}
public: __property static PDFPantoneColor* get_PANTONE2622();
public:
static property PDFPantoneColor^ PANTONE2622 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2622 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2623 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2623 Property
Gets the PANTONE 2623 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2623 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2623
public static PDFPantoneColor PANTONE2623 {get;}
public: __property static PDFPantoneColor* get_PANTONE2623();
public:
static property PDFPantoneColor^ PANTONE2623 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2623 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2627 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2627 Property
Gets the PANTONE 2627 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2627 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2627
public static PDFPantoneColor PANTONE2627 {get;}
public: __property static PDFPantoneColor* get_PANTONE2627();
public:
static property PDFPantoneColor^ PANTONE2627 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2627 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE263 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE263 Property
Gets the PANTONE 263 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE263 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE263
public static PDFPantoneColor PANTONE263 {get;}
public: __property static PDFPantoneColor* get_PANTONE263();
public:
static property PDFPantoneColor^ PANTONE263 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 263 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2635 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2635 Property
Gets the PANTONE 2635 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2635 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2635
public static PDFPantoneColor PANTONE2635 {get;}
public: __property static PDFPantoneColor* get_PANTONE2635();
public:
static property PDFPantoneColor^ PANTONE2635 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2635 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE264 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE264 Property
Gets the PANTONE 264 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE264 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE264
public static PDFPantoneColor PANTONE264 {get;}
public: __property static PDFPantoneColor* get_PANTONE264();
public:
static property PDFPantoneColor^ PANTONE264 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 264 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2645 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2645 Property
Gets the PANTONE 2645 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2645 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2645
public static PDFPantoneColor PANTONE2645 {get;}
public: __property static PDFPantoneColor* get_PANTONE2645();
public:
static property PDFPantoneColor^ PANTONE2645 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2645 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE265 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE265 Property
Gets the PANTONE 265 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE265 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE265
public static PDFPantoneColor PANTONE265 {get;}
public: __property static PDFPantoneColor* get_PANTONE265();
public:
static property PDFPantoneColor^ PANTONE265 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 265 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2655 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2655 Property
Gets the PANTONE 2655 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2655 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2655
public static PDFPantoneColor PANTONE2655 {get;}
public: __property static PDFPantoneColor* get_PANTONE2655();
public:
static property PDFPantoneColor^ PANTONE2655 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2655 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE266 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE266 Property
Gets the PANTONE 266 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE266 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE266
public static PDFPantoneColor PANTONE266 {get;}
public: __property static PDFPantoneColor* get_PANTONE266();
public:
static property PDFPantoneColor^ PANTONE266 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 266 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2665 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2665 Property
Gets the PANTONE 2665 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2665 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2665
public static PDFPantoneColor PANTONE2665 {get;}
public: __property static PDFPantoneColor* get_PANTONE2665();
public:
static property PDFPantoneColor^ PANTONE2665 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2665 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE267 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE267 Property
Gets the PANTONE 267 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE267 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE267
public static PDFPantoneColor PANTONE267 {get;}
public: __property static PDFPantoneColor* get_PANTONE267();
public:
static property PDFPantoneColor^ PANTONE267 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 267 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE268 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE268 Property
Gets the PANTONE 268 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE268 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE268
public static PDFPantoneColor PANTONE268 {get;}
public: __property static PDFPantoneColor* get_PANTONE268();
public:
static property PDFPantoneColor^ PANTONE268 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 268 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2685 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2685 Property
Gets the PANTONE 2685 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2685 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2685
public static PDFPantoneColor PANTONE2685 {get;}
public: __property static PDFPantoneColor* get_PANTONE2685();
public:
static property PDFPantoneColor^ PANTONE2685 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2685 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE269 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE269 Property
Gets the PANTONE 269 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE269 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE269
public static PDFPantoneColor PANTONE269 {get;}
public: __property static PDFPantoneColor* get_PANTONE269();
public:
static property PDFPantoneColor^ PANTONE269 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 269 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2695 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2695 Property
Gets the PANTONE 2695 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2695 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2695
public static PDFPantoneColor PANTONE2695 {get;}
public: __property static PDFPantoneColor* get_PANTONE2695();
public:
static property PDFPantoneColor^ PANTONE2695 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2695 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE270 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE270 Property
Gets the PANTONE 270 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE270 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE270
public static PDFPantoneColor PANTONE270 {get;}
public: __property static PDFPantoneColor* get_PANTONE270();
public:
static property PDFPantoneColor^ PANTONE270 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 270 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2705 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2705 Property
Gets the PANTONE 2705 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2705 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2705
public static PDFPantoneColor PANTONE2705 {get;}
public: __property static PDFPantoneColor* get_PANTONE2705();
public:
static property PDFPantoneColor^ PANTONE2705 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2705 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2706 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2706 Property
Gets the PANTONE 2706 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2706 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2706
public static PDFPantoneColor PANTONE2706 {get;}
public: __property static PDFPantoneColor* get_PANTONE2706();
public:
static property PDFPantoneColor^ PANTONE2706 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2706 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2707 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2707 Property
Gets the PANTONE 2707 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2707 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2707
public static PDFPantoneColor PANTONE2707 {get;}
public: __property static PDFPantoneColor* get_PANTONE2707();
public:
static property PDFPantoneColor^ PANTONE2707 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2707 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2708 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2708 Property
Gets the PANTONE 2708 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2708 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2708
public static PDFPantoneColor PANTONE2708 {get;}
public: __property static PDFPantoneColor* get_PANTONE2708();
public:
static property PDFPantoneColor^ PANTONE2708 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2708 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE271 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE271 Property
Gets the PANTONE 271 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE271 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE271
public static PDFPantoneColor PANTONE271 {get;}
public: __property static PDFPantoneColor* get_PANTONE271();
public:
static property PDFPantoneColor^ PANTONE271 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 271 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2715 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2715 Property
Gets the PANTONE 2715 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2715 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2715
public static PDFPantoneColor PANTONE2715 {get;}
public: __property static PDFPantoneColor* get_PANTONE2715();
public:
static property PDFPantoneColor^ PANTONE2715 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2715 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2716 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2716 Property
Gets the PANTONE 2716 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2716 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2716
public static PDFPantoneColor PANTONE2716 {get;}
public: __property static PDFPantoneColor* get_PANTONE2716();
public:
static property PDFPantoneColor^ PANTONE2716 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2716 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2717 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2717 Property
Gets the PANTONE 2717 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2717 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2717
public static PDFPantoneColor PANTONE2717 {get;}
public: __property static PDFPantoneColor* get_PANTONE2717();
public:
static property PDFPantoneColor^ PANTONE2717 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2717 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2718 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2718 Property
Gets the PANTONE 2718 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2718 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2718
public static PDFPantoneColor PANTONE2718 {get;}
public: __property static PDFPantoneColor* get_PANTONE2718();
public:
static property PDFPantoneColor^ PANTONE2718 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2718 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE272 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE272 Property
Gets the PANTONE 272 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE272 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE272
public static PDFPantoneColor PANTONE272 {get;}
public: __property static PDFPantoneColor* get_PANTONE272();
public:
static property PDFPantoneColor^ PANTONE272 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 272 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2725 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2725 Property
Gets the PANTONE 2725 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2725 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2725
public static PDFPantoneColor PANTONE2725 {get;}
public: __property static PDFPantoneColor* get_PANTONE2725();
public:
static property PDFPantoneColor^ PANTONE2725 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2725 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2726 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2726 Property
Gets the PANTONE 2726 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2726 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2726
public static PDFPantoneColor PANTONE2726 {get;}
public: __property static PDFPantoneColor* get_PANTONE2726();
public:
static property PDFPantoneColor^ PANTONE2726 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2726 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2727 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2727 Property
Gets the PANTONE 2727 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2727 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2727
public static PDFPantoneColor PANTONE2727 {get;}
public: __property static PDFPantoneColor* get_PANTONE2727();
public:
static property PDFPantoneColor^ PANTONE2727 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2727 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2728 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2728 Property
Gets the PANTONE 2728 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2728 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2728
public static PDFPantoneColor PANTONE2728 {get;}
public: __property static PDFPantoneColor* get_PANTONE2728();
public:
static property PDFPantoneColor^ PANTONE2728 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2728 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE273 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE273 Property
Gets the PANTONE 273 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE273 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE273
public static PDFPantoneColor PANTONE273 {get;}
public: __property static PDFPantoneColor* get_PANTONE273();
public:
static property PDFPantoneColor^ PANTONE273 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 273 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2735 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2735 Property
Gets the PANTONE 2735 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2735 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2735
public static PDFPantoneColor PANTONE2735 {get;}
public: __property static PDFPantoneColor* get_PANTONE2735();
public:
static property PDFPantoneColor^ PANTONE2735 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2735 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2736 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2736 Property
Gets the PANTONE 2736 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2736 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2736
public static PDFPantoneColor PANTONE2736 {get;}
public: __property static PDFPantoneColor* get_PANTONE2736();
public:
static property PDFPantoneColor^ PANTONE2736 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2736 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2738 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2738 Property
Gets the PANTONE 2738 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2738 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2738
public static PDFPantoneColor PANTONE2738 {get;}
public: __property static PDFPantoneColor* get_PANTONE2738();
public:
static property PDFPantoneColor^ PANTONE2738 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2738 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE274 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE274 Property
Gets the PANTONE 274 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE274 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE274
public static PDFPantoneColor PANTONE274 {get;}
public: __property static PDFPantoneColor* get_PANTONE274();
public:
static property PDFPantoneColor^ PANTONE274 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 274 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2745 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2745 Property
Gets the PANTONE 2745 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2745 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2745
public static PDFPantoneColor PANTONE2745 {get;}
public: __property static PDFPantoneColor* get_PANTONE2745();
public:
static property PDFPantoneColor^ PANTONE2745 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2745 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2746 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2746 Property
Gets the PANTONE 2746 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2746 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2746
public static PDFPantoneColor PANTONE2746 {get;}
public: __property static PDFPantoneColor* get_PANTONE2746();
public:
static property PDFPantoneColor^ PANTONE2746 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2746 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2747 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2747 Property
Gets the PANTONE 2747 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2747 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2747
public static PDFPantoneColor PANTONE2747 {get;}
public: __property static PDFPantoneColor* get_PANTONE2747();
public:
static property PDFPantoneColor^ PANTONE2747 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2747 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2748 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2748 Property
Gets the PANTONE 2748 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2748 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2748
public static PDFPantoneColor PANTONE2748 {get;}
public: __property static PDFPantoneColor* get_PANTONE2748();
public:
static property PDFPantoneColor^ PANTONE2748 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2748 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE275 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE275 Property
Gets the PANTONE 275 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE275 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE275
public static PDFPantoneColor PANTONE275 {get;}
public: __property static PDFPantoneColor* get_PANTONE275();
public:
static property PDFPantoneColor^ PANTONE275 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 275 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2755 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2755 Property
Gets the PANTONE 2755 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2755 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2755
public static PDFPantoneColor PANTONE2755 {get;}
public: __property static PDFPantoneColor* get_PANTONE2755();
public:
static property PDFPantoneColor^ PANTONE2755 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2755 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2756 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2756 Property
Gets the PANTONE 2756 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2756 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2756
public static PDFPantoneColor PANTONE2756 {get;}
public: __property static PDFPantoneColor* get_PANTONE2756();
public:
static property PDFPantoneColor^ PANTONE2756 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2756 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2757 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2757 Property
Gets the PANTONE 2757 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2757 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2757
public static PDFPantoneColor PANTONE2757 {get;}
public: __property static PDFPantoneColor* get_PANTONE2757();
public:
static property PDFPantoneColor^ PANTONE2757 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2757 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2758 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2758 Property
Gets the PANTONE 2758 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2758 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2758
public static PDFPantoneColor PANTONE2758 {get;}
public: __property static PDFPantoneColor* get_PANTONE2758();
public:
static property PDFPantoneColor^ PANTONE2758 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2758 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE276 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE276 Property
Gets the PANTONE 276 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE276 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE276
public static PDFPantoneColor PANTONE276 {get;}
public: __property static PDFPantoneColor* get_PANTONE276();
public:
static property PDFPantoneColor^ PANTONE276 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 276 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2765 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2765 Property
Gets the PANTONE 2765 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2765 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2765
public static PDFPantoneColor PANTONE2765 {get;}
public: __property static PDFPantoneColor* get_PANTONE2765();
public:
static property PDFPantoneColor^ PANTONE2765 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2765 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2766 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2766 Property
Gets the PANTONE 2766 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2766 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2766
public static PDFPantoneColor PANTONE2766 {get;}
public: __property static PDFPantoneColor* get_PANTONE2766();
public:
static property PDFPantoneColor^ PANTONE2766 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2766 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2767 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2767 Property
Gets the PANTONE 2767 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2767 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2767
public static PDFPantoneColor PANTONE2767 {get;}
public: __property static PDFPantoneColor* get_PANTONE2767();
public:
static property PDFPantoneColor^ PANTONE2767 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2767 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2768 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2768 Property
Gets the PANTONE 2768 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2768 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2768
public static PDFPantoneColor PANTONE2768 {get;}
public: __property static PDFPantoneColor* get_PANTONE2768();
public:
static property PDFPantoneColor^ PANTONE2768 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2768 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE277 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE277 Property
Gets the PANTONE 277 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE277 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE277
public static PDFPantoneColor PANTONE277 {get;}
public: __property static PDFPantoneColor* get_PANTONE277();
public:
static property PDFPantoneColor^ PANTONE277 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 277 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE278 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE278 Property
Gets the PANTONE 278 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE278 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE278
public static PDFPantoneColor PANTONE278 {get;}
public: __property static PDFPantoneColor* get_PANTONE278();
public:
static property PDFPantoneColor^ PANTONE278 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 278 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE279 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE279 Property
Gets the PANTONE 279 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE279 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE279
public static PDFPantoneColor PANTONE279 {get;}
public: __property static PDFPantoneColor* get_PANTONE279();
public:
static property PDFPantoneColor^ PANTONE279 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 279 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE280 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE280 Property
Gets the PANTONE 280 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE280 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE280
public static PDFPantoneColor PANTONE280 {get;}
public: __property static PDFPantoneColor* get_PANTONE280();
public:
static property PDFPantoneColor^ PANTONE280 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 280 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE281 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE281 Property
Gets the PANTONE 281 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE281 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE281
public static PDFPantoneColor PANTONE281 {get;}
public: __property static PDFPantoneColor* get_PANTONE281();
public:
static property PDFPantoneColor^ PANTONE281 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 281 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE282 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE282 Property
Gets the PANTONE 282 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE282 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE282
public static PDFPantoneColor PANTONE282 {get;}
public: __property static PDFPantoneColor* get_PANTONE282();
public:
static property PDFPantoneColor^ PANTONE282 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 282 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE283 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE283 Property
Gets the PANTONE 283 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE283 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE283
public static PDFPantoneColor PANTONE283 {get;}
public: __property static PDFPantoneColor* get_PANTONE283();
public:
static property PDFPantoneColor^ PANTONE283 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 283 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE284 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE284 Property
Gets the PANTONE 284 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE284 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE284
public static PDFPantoneColor PANTONE284 {get;}
public: __property static PDFPantoneColor* get_PANTONE284();
public:
static property PDFPantoneColor^ PANTONE284 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 284 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE285 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE285 Property
Gets the PANTONE 285 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE285 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE285
public static PDFPantoneColor PANTONE285 {get;}
public: __property static PDFPantoneColor* get_PANTONE285();
public:
static property PDFPantoneColor^ PANTONE285 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 285 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE286 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE286 Property
Gets the PANTONE 286 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE286 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE286
public static PDFPantoneColor PANTONE286 {get;}
public: __property static PDFPantoneColor* get_PANTONE286();
public:
static property PDFPantoneColor^ PANTONE286 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 286 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE287 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE287 Property
Gets the PANTONE 287 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE287 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE287
public static PDFPantoneColor PANTONE287 {get;}
public: __property static PDFPantoneColor* get_PANTONE287();
public:
static property PDFPantoneColor^ PANTONE287 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 287 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE288 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE288 Property
Gets the PANTONE 288 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE288 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE288
public static PDFPantoneColor PANTONE288 {get;}
public: __property static PDFPantoneColor* get_PANTONE288();
public:
static property PDFPantoneColor^ PANTONE288 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 288 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE289 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE289 Property
Gets the PANTONE 289 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE289 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE289
public static PDFPantoneColor PANTONE289 {get;}
public: __property static PDFPantoneColor* get_PANTONE289();
public:
static property PDFPantoneColor^ PANTONE289 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 289 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE290 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE290 Property
Gets the PANTONE 290 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE290 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE290
public static PDFPantoneColor PANTONE290 {get;}
public: __property static PDFPantoneColor* get_PANTONE290();
public:
static property PDFPantoneColor^ PANTONE290 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 290 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2905 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2905 Property
Gets the PANTONE 2905 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2905 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2905
public static PDFPantoneColor PANTONE2905 {get;}
public: __property static PDFPantoneColor* get_PANTONE2905();
public:
static property PDFPantoneColor^ PANTONE2905 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2905 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE291 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE291 Property
Gets the PANTONE 291 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE291 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE291
public static PDFPantoneColor PANTONE291 {get;}
public: __property static PDFPantoneColor* get_PANTONE291();
public:
static property PDFPantoneColor^ PANTONE291 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 291 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2915 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2915 Property
Gets the PANTONE 2915 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2915 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2915
public static PDFPantoneColor PANTONE2915 {get;}
public: __property static PDFPantoneColor* get_PANTONE2915();
public:
static property PDFPantoneColor^ PANTONE2915 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2915 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE292 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE292 Property
Gets the PANTONE 292 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE292 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE292
public static PDFPantoneColor PANTONE292 {get;}
public: __property static PDFPantoneColor* get_PANTONE292();
public:
static property PDFPantoneColor^ PANTONE292 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 292 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2925 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2925 Property
Gets the PANTONE 2925 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2925 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2925
public static PDFPantoneColor PANTONE2925 {get;}
public: __property static PDFPantoneColor* get_PANTONE2925();
public:
static property PDFPantoneColor^ PANTONE2925 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2925 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE293 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE293 Property
Gets the PANTONE 293 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE293 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE293
public static PDFPantoneColor PANTONE293 {get;}
public: __property static PDFPantoneColor* get_PANTONE293();
public:
static property PDFPantoneColor^ PANTONE293 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 293 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2935 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2935 Property
Gets the PANTONE 2935 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2935 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2935
public static PDFPantoneColor PANTONE2935 {get;}
public: __property static PDFPantoneColor* get_PANTONE2935();
public:
static property PDFPantoneColor^ PANTONE2935 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2935 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE294 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE294 Property
Gets the PANTONE 294 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE294 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE294
public static PDFPantoneColor PANTONE294 {get;}
public: __property static PDFPantoneColor* get_PANTONE294();
public:
static property PDFPantoneColor^ PANTONE294 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 294 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2945 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2945 Property
Gets the PANTONE 2945 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2945 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2945
public static PDFPantoneColor PANTONE2945 {get;}
public: __property static PDFPantoneColor* get_PANTONE2945();
public:
static property PDFPantoneColor^ PANTONE2945 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2945 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE295 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE295 Property
Gets the PANTONE 295 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE295 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE295
public static PDFPantoneColor PANTONE295 {get;}
public: __property static PDFPantoneColor* get_PANTONE295();
public:
static property PDFPantoneColor^ PANTONE295 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 295 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2955 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2955 Property
Gets the PANTONE 2955 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2955 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2955
public static PDFPantoneColor PANTONE2955 {get;}
public: __property static PDFPantoneColor* get_PANTONE2955();
public:
static property PDFPantoneColor^ PANTONE2955 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2955 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE296 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE296 Property
Gets the PANTONE 296 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE296 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE296
public static PDFPantoneColor PANTONE296 {get;}
public: __property static PDFPantoneColor* get_PANTONE296();
public:
static property PDFPantoneColor^ PANTONE296 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 296 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2965 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2965 Property
Gets the PANTONE 2965 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2965 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2965
public static PDFPantoneColor PANTONE2965 {get;}
public: __property static PDFPantoneColor* get_PANTONE2965();
public:
static property PDFPantoneColor^ PANTONE2965 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2965 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE297 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE297 Property
Gets the PANTONE 297 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE297 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE297
public static PDFPantoneColor PANTONE297 {get;}
public: __property static PDFPantoneColor* get_PANTONE297();
public:
static property PDFPantoneColor^ PANTONE297 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 297 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2975 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2975 Property
Gets the PANTONE 2975 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2975 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2975
public static PDFPantoneColor PANTONE2975 {get;}
public: __property static PDFPantoneColor* get_PANTONE2975();
public:
static property PDFPantoneColor^ PANTONE2975 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2975 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE298 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE298 Property
Gets the PANTONE 298 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE298 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE298
public static PDFPantoneColor PANTONE298 {get;}
public: __property static PDFPantoneColor* get_PANTONE298();
public:
static property PDFPantoneColor^ PANTONE298 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 298 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2985 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2985 Property
Gets the PANTONE 2985 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2985 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2985
public static PDFPantoneColor PANTONE2985 {get;}
public: __property static PDFPantoneColor* get_PANTONE2985();
public:
static property PDFPantoneColor^ PANTONE2985 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2985 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE299 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE299 Property
Gets the PANTONE 299 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE299 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE299
public static PDFPantoneColor PANTONE299 {get;}
public: __property static PDFPantoneColor* get_PANTONE299();
public:
static property PDFPantoneColor^ PANTONE299 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 299 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2995 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2995 Property
Gets the PANTONE 2995 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2995 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2995
public static PDFPantoneColor PANTONE2995 {get;}
public: __property static PDFPantoneColor* get_PANTONE2995();
public:
static property PDFPantoneColor^ PANTONE2995 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 2995 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE300 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE300 Property
Gets the PANTONE 300 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE300 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE300
public static PDFPantoneColor PANTONE300 {get;}
public: __property static PDFPantoneColor* get_PANTONE300();
public:
static property PDFPantoneColor^ PANTONE300 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 300 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3005 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3005 Property
Gets the PANTONE 3005 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3005 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3005
public static PDFPantoneColor PANTONE3005 {get;}
public: __property static PDFPantoneColor* get_PANTONE3005();
public:
static property PDFPantoneColor^ PANTONE3005 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3005 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE301 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE301 Property
Gets the PANTONE 301 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE301 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE301
public static PDFPantoneColor PANTONE301 {get;}
public: __property static PDFPantoneColor* get_PANTONE301();
public:
static property PDFPantoneColor^ PANTONE301 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 301 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3015 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3015 Property
Gets the PANTONE 3015 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3015 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3015
public static PDFPantoneColor PANTONE3015 {get;}
public: __property static PDFPantoneColor* get_PANTONE3015();
public:
static property PDFPantoneColor^ PANTONE3015 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3015 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE302 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE302 Property
Gets the PANTONE 302 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE302 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE302
public static PDFPantoneColor PANTONE302 {get;}
public: __property static PDFPantoneColor* get_PANTONE302();
public:
static property PDFPantoneColor^ PANTONE302 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 302 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3025 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3025 Property
Gets the PANTONE 3025 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3025 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3025
public static PDFPantoneColor PANTONE3025 {get;}
public: __property static PDFPantoneColor* get_PANTONE3025();
public:
static property PDFPantoneColor^ PANTONE3025 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3025 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE303 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE303 Property
Gets the PANTONE 303 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE303 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE303
public static PDFPantoneColor PANTONE303 {get;}
public: __property static PDFPantoneColor* get_PANTONE303();
public:
static property PDFPantoneColor^ PANTONE303 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 303 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3035 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3035 Property
Gets the PANTONE 3035 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3035 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3035
public static PDFPantoneColor PANTONE3035 {get;}
public: __property static PDFPantoneColor* get_PANTONE3035();
public:
static property PDFPantoneColor^ PANTONE3035 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3035 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE304 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE304 Property
Gets the PANTONE 304 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE304 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE304
public static PDFPantoneColor PANTONE304 {get;}
public: __property static PDFPantoneColor* get_PANTONE304();
public:
static property PDFPantoneColor^ PANTONE304 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 304 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE305 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE305 Property
Gets the PANTONE 305 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE305 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE305
public static PDFPantoneColor PANTONE305 {get;}
public: __property static PDFPantoneColor* get_PANTONE305();
public:
static property PDFPantoneColor^ PANTONE305 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 305 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE306 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE306 Property
Gets the PANTONE 306 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE306 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE306
public static PDFPantoneColor PANTONE306 {get;}
public: __property static PDFPantoneColor* get_PANTONE306();
public:
static property PDFPantoneColor^ PANTONE306 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 306 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE307 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE307 Property
Gets the PANTONE 307 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE307 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE307
public static PDFPantoneColor PANTONE307 {get;}
public: __property static PDFPantoneColor* get_PANTONE307();
public:
static property PDFPantoneColor^ PANTONE307 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 307 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE308 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE308 Property
Gets the PANTONE 308 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE308 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE308
public static PDFPantoneColor PANTONE308 {get;}
public: __property static PDFPantoneColor* get_PANTONE308();
public:
static property PDFPantoneColor^ PANTONE308 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 308 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE309 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE309 Property
Gets the PANTONE 309 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE309 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE309
public static PDFPantoneColor PANTONE309 {get;}
public: __property static PDFPantoneColor* get_PANTONE309();
public:
static property PDFPantoneColor^ PANTONE309 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 309 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE310 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE310 Property
Gets the PANTONE 310 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE310 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE310
public static PDFPantoneColor PANTONE310 {get;}
public: __property static PDFPantoneColor* get_PANTONE310();
public:
static property PDFPantoneColor^ PANTONE310 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 310 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3105 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3105 Property
Gets the PANTONE 3105 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3105 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3105
public static PDFPantoneColor PANTONE3105 {get;}
public: __property static PDFPantoneColor* get_PANTONE3105();
public:
static property PDFPantoneColor^ PANTONE3105 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3105 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE311 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE311 Property
Gets the PANTONE 311 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE311 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE311
public static PDFPantoneColor PANTONE311 {get;}
public: __property static PDFPantoneColor* get_PANTONE311();
public:
static property PDFPantoneColor^ PANTONE311 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 311 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3115 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3115 Property
Gets the PANTONE 3115 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3115 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3115
public static PDFPantoneColor PANTONE3115 {get;}
public: __property static PDFPantoneColor* get_PANTONE3115();
public:
static property PDFPantoneColor^ PANTONE3115 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3115 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE312 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE312 Property
Gets the PANTONE 312 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE312 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE312
public static PDFPantoneColor PANTONE312 {get;}
public: __property static PDFPantoneColor* get_PANTONE312();
public:
static property PDFPantoneColor^ PANTONE312 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 312 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3125 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3125 Property
Gets the PANTONE 3125 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3125 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3125
public static PDFPantoneColor PANTONE3125 {get;}
public: __property static PDFPantoneColor* get_PANTONE3125();
public:
static property PDFPantoneColor^ PANTONE3125 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3125 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE313 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE313 Property
Gets the PANTONE 313 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE313 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE313
public static PDFPantoneColor PANTONE313 {get;}
public: __property static PDFPantoneColor* get_PANTONE313();
public:
static property PDFPantoneColor^ PANTONE313 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 313 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3135 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3135 Property
Gets the PANTONE 3135 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3135 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3135
public static PDFPantoneColor PANTONE3135 {get;}
public: __property static PDFPantoneColor* get_PANTONE3135();
public:
static property PDFPantoneColor^ PANTONE3135 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3135 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE314 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE314 Property
Gets the PANTONE 314 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE314 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE314
public static PDFPantoneColor PANTONE314 {get;}
public: __property static PDFPantoneColor* get_PANTONE314();
public:
static property PDFPantoneColor^ PANTONE314 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 314 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3145 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3145 Property
Gets the PANTONE 3145 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3145 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3145
public static PDFPantoneColor PANTONE3145 {get;}
public: __property static PDFPantoneColor* get_PANTONE3145();
public:
static property PDFPantoneColor^ PANTONE3145 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3145 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE315 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE315 Property
Gets the PANTONE 315 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE315 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE315
public static PDFPantoneColor PANTONE315 {get;}
public: __property static PDFPantoneColor* get_PANTONE315();
public:
static property PDFPantoneColor^ PANTONE315 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 315 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3155 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3155 Property
Gets the PANTONE 3155 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3155 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3155
public static PDFPantoneColor PANTONE3155 {get;}
public: __property static PDFPantoneColor* get_PANTONE3155();
public:
static property PDFPantoneColor^ PANTONE3155 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3155 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE316 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE316 Property
Gets the PANTONE 316 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE316 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE316
public static PDFPantoneColor PANTONE316 {get;}
public: __property static PDFPantoneColor* get_PANTONE316();
public:
static property PDFPantoneColor^ PANTONE316 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 316 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3165 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3165 Property
Gets the PANTONE 3165 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3165 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3165
public static PDFPantoneColor PANTONE3165 {get;}
public: __property static PDFPantoneColor* get_PANTONE3165();
public:
static property PDFPantoneColor^ PANTONE3165 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3165 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE317 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE317 Property
Gets the PANTONE 317 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE317 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE317
public static PDFPantoneColor PANTONE317 {get;}
public: __property static PDFPantoneColor* get_PANTONE317();
public:
static property PDFPantoneColor^ PANTONE317 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 317 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE318 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE318 Property
Gets the PANTONE 318 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE318 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE318
public static PDFPantoneColor PANTONE318 {get;}
public: __property static PDFPantoneColor* get_PANTONE318();
public:
static property PDFPantoneColor^ PANTONE318 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 318 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE319 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE319 Property
Gets the PANTONE 319 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE319 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE319
public static PDFPantoneColor PANTONE319 {get;}
public: __property static PDFPantoneColor* get_PANTONE319();
public:
static property PDFPantoneColor^ PANTONE319 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 319 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE320 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE320 Property
Gets the PANTONE 320 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE320 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE320
public static PDFPantoneColor PANTONE320 {get;}
public: __property static PDFPantoneColor* get_PANTONE320();
public:
static property PDFPantoneColor^ PANTONE320 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 320 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE321 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE321 Property
Gets the PANTONE 321 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE321 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE321
public static PDFPantoneColor PANTONE321 {get;}
public: __property static PDFPantoneColor* get_PANTONE321();
public:
static property PDFPantoneColor^ PANTONE321 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 321 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE322 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE322 Property
Gets the PANTONE 322 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE322 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE322
public static PDFPantoneColor PANTONE322 {get;}
public: __property static PDFPantoneColor* get_PANTONE322();
public:
static property PDFPantoneColor^ PANTONE322 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 322 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE323 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE323 Property
Gets the PANTONE 323 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE323 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE323
public static PDFPantoneColor PANTONE323 {get;}
public: __property static PDFPantoneColor* get_PANTONE323();
public:
static property PDFPantoneColor^ PANTONE323 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 323 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE324 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE324 Property
Gets the PANTONE 324 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE324 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE324
public static PDFPantoneColor PANTONE324 {get;}
public: __property static PDFPantoneColor* get_PANTONE324();
public:
static property PDFPantoneColor^ PANTONE324 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 324 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3242 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3242 Property
Gets the PANTONE 3242 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3242 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3242
public static PDFPantoneColor PANTONE3242 {get;}
public: __property static PDFPantoneColor* get_PANTONE3242();
public:
static property PDFPantoneColor^ PANTONE3242 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3242 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3245 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3245 Property
Gets the PANTONE 3245 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3245 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3245
public static PDFPantoneColor PANTONE3245 {get;}
public: __property static PDFPantoneColor* get_PANTONE3245();
public:
static property PDFPantoneColor^ PANTONE3245 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3245 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3248 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3248 Property
Gets the PANTONE 3248 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3248 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3248
public static PDFPantoneColor PANTONE3248 {get;}
public: __property static PDFPantoneColor* get_PANTONE3248();
public:
static property PDFPantoneColor^ PANTONE3248 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3248 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE325 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE325 Property
Gets the PANTONE 325 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE325 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE325
public static PDFPantoneColor PANTONE325 {get;}
public: __property static PDFPantoneColor* get_PANTONE325();
public:
static property PDFPantoneColor^ PANTONE325 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 325 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3252 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3252 Property
Gets the PANTONE 3252 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3252 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3252
public static PDFPantoneColor PANTONE3252 {get;}
public: __property static PDFPantoneColor* get_PANTONE3252();
public:
static property PDFPantoneColor^ PANTONE3252 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3252 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3255 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3255 Property
Gets the PANTONE 3255 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3255 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3255
public static PDFPantoneColor PANTONE3255 {get;}
public: __property static PDFPantoneColor* get_PANTONE3255();
public:
static property PDFPantoneColor^ PANTONE3255 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3255 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3258 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3258 Property
Gets the PANTONE 3258 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3258 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3258
public static PDFPantoneColor PANTONE3258 {get;}
public: __property static PDFPantoneColor* get_PANTONE3258();
public:
static property PDFPantoneColor^ PANTONE3258 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3258 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE326 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE326 Property
Gets the PANTONE 326 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE326 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE326
public static PDFPantoneColor PANTONE326 {get;}
public: __property static PDFPantoneColor* get_PANTONE326();
public:
static property PDFPantoneColor^ PANTONE326 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 326 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3262 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3262 Property
Gets the PANTONE 3262 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3262 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3262
public static PDFPantoneColor PANTONE3262 {get;}
public: __property static PDFPantoneColor* get_PANTONE3262();
public:
static property PDFPantoneColor^ PANTONE3262 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3262 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3265 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3265 Property
Gets the PANTONE 3265 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3265 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3265
public static PDFPantoneColor PANTONE3265 {get;}
public: __property static PDFPantoneColor* get_PANTONE3265();
public:
static property PDFPantoneColor^ PANTONE3265 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3265 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3268 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3268 Property
Gets the PANTONE 3268 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3268 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3268
public static PDFPantoneColor PANTONE3268 {get;}
public: __property static PDFPantoneColor* get_PANTONE3268();
public:
static property PDFPantoneColor^ PANTONE3268 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3268 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE327 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE327 Property
Gets the PANTONE 327 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE327 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE327
public static PDFPantoneColor PANTONE327 {get;}
public: __property static PDFPantoneColor* get_PANTONE327();
public:
static property PDFPantoneColor^ PANTONE327 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 327 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3272 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3272 Property
Gets the PANTONE 3272 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3272 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3272
public static PDFPantoneColor PANTONE3272 {get;}
public: __property static PDFPantoneColor* get_PANTONE3272();
public:
static property PDFPantoneColor^ PANTONE3272 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3272 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3275 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3275 Property
Gets the PANTONE 3275 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3275 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3275
public static PDFPantoneColor PANTONE3275 {get;}
public: __property static PDFPantoneColor* get_PANTONE3275();
public:
static property PDFPantoneColor^ PANTONE3275 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3275 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3278 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3278 Property
Gets the PANTONE 3278 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3278 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3278
public static PDFPantoneColor PANTONE3278 {get;}
public: __property static PDFPantoneColor* get_PANTONE3278();
public:
static property PDFPantoneColor^ PANTONE3278 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3278 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE328 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE328 Property
Gets the PANTONE 328 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE328 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE328
public static PDFPantoneColor PANTONE328 {get;}
public: __property static PDFPantoneColor* get_PANTONE328();
public:
static property PDFPantoneColor^ PANTONE328 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 328 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3282 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3282 Property
Gets the PANTONE 3282 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3282 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3282
public static PDFPantoneColor PANTONE3282 {get;}
public: __property static PDFPantoneColor* get_PANTONE3282();
public:
static property PDFPantoneColor^ PANTONE3282 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3282 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3285 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3285 Property
Gets the PANTONE 3285 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3285 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3285
public static PDFPantoneColor PANTONE3285 {get;}
public: __property static PDFPantoneColor* get_PANTONE3285();
public:
static property PDFPantoneColor^ PANTONE3285 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3285 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3288 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3288 Property
Gets the PANTONE 3288 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3288 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3288
public static PDFPantoneColor PANTONE3288 {get;}
public: __property static PDFPantoneColor* get_PANTONE3288();
public:
static property PDFPantoneColor^ PANTONE3288 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3288 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE329 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE329 Property
Gets the PANTONE 329 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE329 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE329
public static PDFPantoneColor PANTONE329 {get;}
public: __property static PDFPantoneColor* get_PANTONE329();
public:
static property PDFPantoneColor^ PANTONE329 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 329 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3292 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3292 Property
Gets the PANTONE 3292 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3292 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3292
public static PDFPantoneColor PANTONE3292 {get;}
public: __property static PDFPantoneColor* get_PANTONE3292();
public:
static property PDFPantoneColor^ PANTONE3292 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3292 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3295 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3295 Property
Gets the PANTONE 3295 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3295 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3295
public static PDFPantoneColor PANTONE3295 {get;}
public: __property static PDFPantoneColor* get_PANTONE3295();
public:
static property PDFPantoneColor^ PANTONE3295 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3295 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3298 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3298 Property
Gets the PANTONE 3298 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3298 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3298
public static PDFPantoneColor PANTONE3298 {get;}
public: __property static PDFPantoneColor* get_PANTONE3298();
public:
static property PDFPantoneColor^ PANTONE3298 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3298 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE330 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE330 Property
Gets the PANTONE 330 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE330 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE330
public static PDFPantoneColor PANTONE330 {get;}
public: __property static PDFPantoneColor* get_PANTONE330();
public:
static property PDFPantoneColor^ PANTONE330 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 330 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3302 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3302 Property
Gets the PANTONE 3302 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3302 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3302
public static PDFPantoneColor PANTONE3302 {get;}
public: __property static PDFPantoneColor* get_PANTONE3302();
public:
static property PDFPantoneColor^ PANTONE3302 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3302 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3305 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3305 Property
Gets the PANTONE 3305 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3305 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3305
public static PDFPantoneColor PANTONE3305 {get;}
public: __property static PDFPantoneColor* get_PANTONE3305();
public:
static property PDFPantoneColor^ PANTONE3305 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3305 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3308 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3308 Property
Gets the PANTONE 3308 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3308 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3308
public static PDFPantoneColor PANTONE3308 {get;}
public: __property static PDFPantoneColor* get_PANTONE3308();
public:
static property PDFPantoneColor^ PANTONE3308 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3308 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE331 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE331 Property
Gets the PANTONE 331 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE331 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE331
public static PDFPantoneColor PANTONE331 {get;}
public: __property static PDFPantoneColor* get_PANTONE331();
public:
static property PDFPantoneColor^ PANTONE331 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 331 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE332 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE332 Property
Gets the PANTONE 332 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE332 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE332
public static PDFPantoneColor PANTONE332 {get;}
public: __property static PDFPantoneColor* get_PANTONE332();
public:
static property PDFPantoneColor^ PANTONE332 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 332 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE333 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE333 Property
Gets the PANTONE 333 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE333 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE333
public static PDFPantoneColor PANTONE333 {get;}
public: __property static PDFPantoneColor* get_PANTONE333();
public:
static property PDFPantoneColor^ PANTONE333 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 333 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE334 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE334 Property
Gets the PANTONE 334 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE334 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE334
public static PDFPantoneColor PANTONE334 {get;}
public: __property static PDFPantoneColor* get_PANTONE334();
public:
static property PDFPantoneColor^ PANTONE334 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 334 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE335 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE335 Property
Gets the PANTONE 335 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE335 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE335
public static PDFPantoneColor PANTONE335 {get;}
public: __property static PDFPantoneColor* get_PANTONE335();
public:
static property PDFPantoneColor^ PANTONE335 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 335 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE336 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE336 Property
Gets the PANTONE 336 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE336 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE336
public static PDFPantoneColor PANTONE336 {get;}
public: __property static PDFPantoneColor* get_PANTONE336();
public:
static property PDFPantoneColor^ PANTONE336 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 336 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE337 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE337 Property
Gets the PANTONE 337 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE337 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE337
public static PDFPantoneColor PANTONE337 {get;}
public: __property static PDFPantoneColor* get_PANTONE337();
public:
static property PDFPantoneColor^ PANTONE337 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 337 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3375 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3375 Property
Gets the PANTONE 3375 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3375 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3375
public static PDFPantoneColor PANTONE3375 {get;}
public: __property static PDFPantoneColor* get_PANTONE3375();
public:
static property PDFPantoneColor^ PANTONE3375 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3375 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE338 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE338 Property
Gets the PANTONE 338 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE338 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE338
public static PDFPantoneColor PANTONE338 {get;}
public: __property static PDFPantoneColor* get_PANTONE338();
public:
static property PDFPantoneColor^ PANTONE338 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 338 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3385 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3385 Property
Gets the PANTONE 3385 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3385 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3385
public static PDFPantoneColor PANTONE3385 {get;}
public: __property static PDFPantoneColor* get_PANTONE3385();
public:
static property PDFPantoneColor^ PANTONE3385 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3385 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE339 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE339 Property
Gets the PANTONE 339 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE339 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE339
public static PDFPantoneColor PANTONE339 {get;}
public: __property static PDFPantoneColor* get_PANTONE339();
public:
static property PDFPantoneColor^ PANTONE339 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 339 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3395 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3395 Property
Gets the PANTONE 3395 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3395 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3395
public static PDFPantoneColor PANTONE3395 {get;}
public: __property static PDFPantoneColor* get_PANTONE3395();
public:
static property PDFPantoneColor^ PANTONE3395 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3395 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE340 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE340 Property
Gets the PANTONE 340 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE340 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE340
public static PDFPantoneColor PANTONE340 {get;}
public: __property static PDFPantoneColor* get_PANTONE340();
public:
static property PDFPantoneColor^ PANTONE340 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 340 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3405 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3405 Property
Gets the PANTONE 3405 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3405 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3405
public static PDFPantoneColor PANTONE3405 {get;}
public: __property static PDFPantoneColor* get_PANTONE3405();
public:
static property PDFPantoneColor^ PANTONE3405 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3405 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE341 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE341 Property
Gets the PANTONE 341 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE341 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE341
public static PDFPantoneColor PANTONE341 {get;}
public: __property static PDFPantoneColor* get_PANTONE341();
public:
static property PDFPantoneColor^ PANTONE341 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 341 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3415 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3415 Property
Gets the PANTONE 3415 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3415 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3415
public static PDFPantoneColor PANTONE3415 {get;}
public: __property static PDFPantoneColor* get_PANTONE3415();
public:
static property PDFPantoneColor^ PANTONE3415 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3415 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE342 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE342 Property
Gets the PANTONE 342 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE342 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE342
public static PDFPantoneColor PANTONE342 {get;}
public: __property static PDFPantoneColor* get_PANTONE342();
public:
static property PDFPantoneColor^ PANTONE342 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 342 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3425 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3425 Property
Gets the PANTONE 3425 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3425 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3425
public static PDFPantoneColor PANTONE3425 {get;}
public: __property static PDFPantoneColor* get_PANTONE3425();
public:
static property PDFPantoneColor^ PANTONE3425 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3425 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE343 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE343 Property
Gets the PANTONE 343 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE343 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE343
public static PDFPantoneColor PANTONE343 {get;}
public: __property static PDFPantoneColor* get_PANTONE343();
public:
static property PDFPantoneColor^ PANTONE343 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 343 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3435 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3435 Property
Gets the PANTONE 3435 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3435 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3435
public static PDFPantoneColor PANTONE3435 {get;}
public: __property static PDFPantoneColor* get_PANTONE3435();
public:
static property PDFPantoneColor^ PANTONE3435 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3435 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE344 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE344 Property
Gets the PANTONE 344 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE344 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE344
public static PDFPantoneColor PANTONE344 {get;}
public: __property static PDFPantoneColor* get_PANTONE344();
public:
static property PDFPantoneColor^ PANTONE344 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 344 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE345 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE345 Property
Gets the PANTONE 345 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE345 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE345
public static PDFPantoneColor PANTONE345 {get;}
public: __property static PDFPantoneColor* get_PANTONE345();
public:
static property PDFPantoneColor^ PANTONE345 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 345 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE346 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE346 Property
Gets the PANTONE 346 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE346 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE346
public static PDFPantoneColor PANTONE346 {get;}
public: __property static PDFPantoneColor* get_PANTONE346();
public:
static property PDFPantoneColor^ PANTONE346 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 346 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE347 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE347 Property
Gets the PANTONE 347 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE347 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE347
public static PDFPantoneColor PANTONE347 {get;}
public: __property static PDFPantoneColor* get_PANTONE347();
public:
static property PDFPantoneColor^ PANTONE347 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 347 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE348 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE348 Property
Gets the PANTONE 348 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE348 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE348
public static PDFPantoneColor PANTONE348 {get;}
public: __property static PDFPantoneColor* get_PANTONE348();
public:
static property PDFPantoneColor^ PANTONE348 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 348 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE349 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE349 Property
Gets the PANTONE 349 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE349 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE349
public static PDFPantoneColor PANTONE349 {get;}
public: __property static PDFPantoneColor* get_PANTONE349();
public:
static property PDFPantoneColor^ PANTONE349 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 349 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE350 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE350 Property
Gets the PANTONE 350 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE350 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE350
public static PDFPantoneColor PANTONE350 {get;}
public: __property static PDFPantoneColor* get_PANTONE350();
public:
static property PDFPantoneColor^ PANTONE350 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 350 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE351 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE351 Property
Gets the PANTONE 351 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE351 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE351
public static PDFPantoneColor PANTONE351 {get;}
public: __property static PDFPantoneColor* get_PANTONE351();
public:
static property PDFPantoneColor^ PANTONE351 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 351 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE352 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE352 Property
Gets the PANTONE 352 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE352 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE352
public static PDFPantoneColor PANTONE352 {get;}
public: __property static PDFPantoneColor* get_PANTONE352();
public:
static property PDFPantoneColor^ PANTONE352 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 352 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE353 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE353 Property
Gets the PANTONE 353 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE353 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE353
public static PDFPantoneColor PANTONE353 {get;}
public: __property static PDFPantoneColor* get_PANTONE353();
public:
static property PDFPantoneColor^ PANTONE353 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 353 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE354 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE354 Property
Gets the PANTONE 354 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE354 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE354
public static PDFPantoneColor PANTONE354 {get;}
public: __property static PDFPantoneColor* get_PANTONE354();
public:
static property PDFPantoneColor^ PANTONE354 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 354 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE355 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE355 Property
Gets the PANTONE 355 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE355 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE355
public static PDFPantoneColor PANTONE355 {get;}
public: __property static PDFPantoneColor* get_PANTONE355();
public:
static property PDFPantoneColor^ PANTONE355 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 355 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE356 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE356 Property
Gets the PANTONE 356 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE356 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE356
public static PDFPantoneColor PANTONE356 {get;}
public: __property static PDFPantoneColor* get_PANTONE356();
public:
static property PDFPantoneColor^ PANTONE356 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 356 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE357 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE357 Property
Gets the PANTONE 357 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE357 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE357
public static PDFPantoneColor PANTONE357 {get;}
public: __property static PDFPantoneColor* get_PANTONE357();
public:
static property PDFPantoneColor^ PANTONE357 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 357 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE358 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE358 Property
Gets the PANTONE 358 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE358 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE358
public static PDFPantoneColor PANTONE358 {get;}
public: __property static PDFPantoneColor* get_PANTONE358();
public:
static property PDFPantoneColor^ PANTONE358 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 358 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE359 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE359 Property
Gets the PANTONE 359 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE359 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE359
public static PDFPantoneColor PANTONE359 {get;}
public: __property static PDFPantoneColor* get_PANTONE359();
public:
static property PDFPantoneColor^ PANTONE359 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 359 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE360 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE360 Property
Gets the PANTONE 360 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE360 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE360
public static PDFPantoneColor PANTONE360 {get;}
public: __property static PDFPantoneColor* get_PANTONE360();
public:
static property PDFPantoneColor^ PANTONE360 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 360 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE361 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE361 Property
Gets the PANTONE 361 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE361 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE361
public static PDFPantoneColor PANTONE361 {get;}
public: __property static PDFPantoneColor* get_PANTONE361();
public:
static property PDFPantoneColor^ PANTONE361 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 361 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE362 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE362 Property
Gets the PANTONE 362 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE362 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE362
public static PDFPantoneColor PANTONE362 {get;}
public: __property static PDFPantoneColor* get_PANTONE362();
public:
static property PDFPantoneColor^ PANTONE362 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 362 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE363 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE363 Property
Gets the PANTONE 363 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE363 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE363
public static PDFPantoneColor PANTONE363 {get;}
public: __property static PDFPantoneColor* get_PANTONE363();
public:
static property PDFPantoneColor^ PANTONE363 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 363 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE364 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE364 Property
Gets the PANTONE 364 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE364 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE364
public static PDFPantoneColor PANTONE364 {get;}
public: __property static PDFPantoneColor* get_PANTONE364();
public:
static property PDFPantoneColor^ PANTONE364 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 364 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE365 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE365 Property
Gets the PANTONE 365 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE365 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE365
public static PDFPantoneColor PANTONE365 {get;}
public: __property static PDFPantoneColor* get_PANTONE365();
public:
static property PDFPantoneColor^ PANTONE365 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 365 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE366 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE366 Property
Gets the PANTONE 366 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE366 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE366
public static PDFPantoneColor PANTONE366 {get;}
public: __property static PDFPantoneColor* get_PANTONE366();
public:
static property PDFPantoneColor^ PANTONE366 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 366 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE367 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE367 Property
Gets the PANTONE 367 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE367 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE367
public static PDFPantoneColor PANTONE367 {get;}
public: __property static PDFPantoneColor* get_PANTONE367();
public:
static property PDFPantoneColor^ PANTONE367 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 367 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE368 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE368 Property
Gets the PANTONE 368 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE368 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE368
public static PDFPantoneColor PANTONE368 {get;}
public: __property static PDFPantoneColor* get_PANTONE368();
public:
static property PDFPantoneColor^ PANTONE368 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 368 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE369 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE369 Property
Gets the PANTONE 369 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE369 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE369
public static PDFPantoneColor PANTONE369 {get;}
public: __property static PDFPantoneColor* get_PANTONE369();
public:
static property PDFPantoneColor^ PANTONE369 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 369 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE370 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE370 Property
Gets the PANTONE 370 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE370 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE370
public static PDFPantoneColor PANTONE370 {get;}
public: __property static PDFPantoneColor* get_PANTONE370();
public:
static property PDFPantoneColor^ PANTONE370 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 370 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE371 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE371 Property
Gets the PANTONE 371 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE371 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE371
public static PDFPantoneColor PANTONE371 {get;}
public: __property static PDFPantoneColor* get_PANTONE371();
public:
static property PDFPantoneColor^ PANTONE371 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 371 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE372 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE372 Property
Gets the PANTONE 372 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE372 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE372
public static PDFPantoneColor PANTONE372 {get;}
public: __property static PDFPantoneColor* get_PANTONE372();
public:
static property PDFPantoneColor^ PANTONE372 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 372 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE373 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE373 Property
Gets the PANTONE 373 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE373 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE373
public static PDFPantoneColor PANTONE373 {get;}
public: __property static PDFPantoneColor* get_PANTONE373();
public:
static property PDFPantoneColor^ PANTONE373 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 373 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE374 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE374 Property
Gets the PANTONE 374 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE374 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE374
public static PDFPantoneColor PANTONE374 {get;}
public: __property static PDFPantoneColor* get_PANTONE374();
public:
static property PDFPantoneColor^ PANTONE374 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 374 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE375 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE375 Property
Gets the PANTONE 375 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE375 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE375
public static PDFPantoneColor PANTONE375 {get;}
public: __property static PDFPantoneColor* get_PANTONE375();
public:
static property PDFPantoneColor^ PANTONE375 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 375 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE376 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE376 Property
Gets the PANTONE 376 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE376 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE376
public static PDFPantoneColor PANTONE376 {get;}
public: __property static PDFPantoneColor* get_PANTONE376();
public:
static property PDFPantoneColor^ PANTONE376 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 376 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE377 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE377 Property
Gets the PANTONE 377 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE377 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE377
public static PDFPantoneColor PANTONE377 {get;}
public: __property static PDFPantoneColor* get_PANTONE377();
public:
static property PDFPantoneColor^ PANTONE377 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 377 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE378 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE378 Property
Gets the PANTONE 378 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE378 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE378
public static PDFPantoneColor PANTONE378 {get;}
public: __property static PDFPantoneColor* get_PANTONE378();
public:
static property PDFPantoneColor^ PANTONE378 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 378 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE379 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE379 Property
Gets the PANTONE 379 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE379 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE379
public static PDFPantoneColor PANTONE379 {get;}
public: __property static PDFPantoneColor* get_PANTONE379();
public:
static property PDFPantoneColor^ PANTONE379 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 379 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE380 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE380 Property
Gets the PANTONE 380 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE380 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE380
public static PDFPantoneColor PANTONE380 {get;}
public: __property static PDFPantoneColor* get_PANTONE380();
public:
static property PDFPantoneColor^ PANTONE380 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 380 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE381 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE381 Property
Gets the PANTONE 381 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE381 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE381
public static PDFPantoneColor PANTONE381 {get;}
public: __property static PDFPantoneColor* get_PANTONE381();
public:
static property PDFPantoneColor^ PANTONE381 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 381 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE382 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE382 Property
Gets the PANTONE 382 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE382 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE382
public static PDFPantoneColor PANTONE382 {get;}
public: __property static PDFPantoneColor* get_PANTONE382();
public:
static property PDFPantoneColor^ PANTONE382 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 382 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE383 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE383 Property
Gets the PANTONE 383 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE383 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE383
public static PDFPantoneColor PANTONE383 {get;}
public: __property static PDFPantoneColor* get_PANTONE383();
public:
static property PDFPantoneColor^ PANTONE383 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 383 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE384 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE384 Property
Gets the PANTONE 384 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE384 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE384
public static PDFPantoneColor PANTONE384 {get;}
public: __property static PDFPantoneColor* get_PANTONE384();
public:
static property PDFPantoneColor^ PANTONE384 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 384 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE385 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE385 Property
Gets the PANTONE 385 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE385 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE385
public static PDFPantoneColor PANTONE385 {get;}
public: __property static PDFPantoneColor* get_PANTONE385();
public:
static property PDFPantoneColor^ PANTONE385 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 385 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE386 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE386 Property
Gets the PANTONE 386 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE386 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE386
public static PDFPantoneColor PANTONE386 {get;}
public: __property static PDFPantoneColor* get_PANTONE386();
public:
static property PDFPantoneColor^ PANTONE386 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 386 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE387 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE387 Property
Gets the PANTONE 387 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE387 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE387
public static PDFPantoneColor PANTONE387 {get;}
public: __property static PDFPantoneColor* get_PANTONE387();
public:
static property PDFPantoneColor^ PANTONE387 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 387 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE388 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE388 Property
Gets the PANTONE 388 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE388 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE388
public static PDFPantoneColor PANTONE388 {get;}
public: __property static PDFPantoneColor* get_PANTONE388();
public:
static property PDFPantoneColor^ PANTONE388 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 388 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE389 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE389 Property
Gets the PANTONE 389 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE389 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE389
public static PDFPantoneColor PANTONE389 {get;}
public: __property static PDFPantoneColor* get_PANTONE389();
public:
static property PDFPantoneColor^ PANTONE389 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 389 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE390 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE390 Property
Gets the PANTONE 390 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE390 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE390
public static PDFPantoneColor PANTONE390 {get;}
public: __property static PDFPantoneColor* get_PANTONE390();
public:
static property PDFPantoneColor^ PANTONE390 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 390 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE391 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE391 Property
Gets the PANTONE 391 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE391 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE391
public static PDFPantoneColor PANTONE391 {get;}
public: __property static PDFPantoneColor* get_PANTONE391();
public:
static property PDFPantoneColor^ PANTONE391 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 391 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE392 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE392 Property
Gets the PANTONE 392 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE392 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE392
public static PDFPantoneColor PANTONE392 {get;}
public: __property static PDFPantoneColor* get_PANTONE392();
public:
static property PDFPantoneColor^ PANTONE392 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 392 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE393 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE393 Property
Gets the PANTONE 393 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE393 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE393
public static PDFPantoneColor PANTONE393 {get;}
public: __property static PDFPantoneColor* get_PANTONE393();
public:
static property PDFPantoneColor^ PANTONE393 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 393 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3935 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3935 Property
Gets the PANTONE 3935 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3935 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3935
public static PDFPantoneColor PANTONE3935 {get;}
public: __property static PDFPantoneColor* get_PANTONE3935();
public:
static property PDFPantoneColor^ PANTONE3935 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3935 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE394 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE394 Property
Gets the PANTONE 394 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE394 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE394
public static PDFPantoneColor PANTONE394 {get;}
public: __property static PDFPantoneColor* get_PANTONE394();
public:
static property PDFPantoneColor^ PANTONE394 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 394 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3945 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3945 Property
Gets the PANTONE 3945 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3945 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3945
public static PDFPantoneColor PANTONE3945 {get;}
public: __property static PDFPantoneColor* get_PANTONE3945();
public:
static property PDFPantoneColor^ PANTONE3945 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3945 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE395 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE395 Property
Gets the PANTONE 395 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE395 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE395
public static PDFPantoneColor PANTONE395 {get;}
public: __property static PDFPantoneColor* get_PANTONE395();
public:
static property PDFPantoneColor^ PANTONE395 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 395 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3955 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3955 Property
Gets the PANTONE 3955 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3955 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3955
public static PDFPantoneColor PANTONE3955 {get;}
public: __property static PDFPantoneColor* get_PANTONE3955();
public:
static property PDFPantoneColor^ PANTONE3955 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3955 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE396 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE396 Property
Gets the PANTONE 396 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE396 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE396
public static PDFPantoneColor PANTONE396 {get;}
public: __property static PDFPantoneColor* get_PANTONE396();
public:
static property PDFPantoneColor^ PANTONE396 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 396 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3965 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3965 Property
Gets the PANTONE 3965 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3965 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3965
public static PDFPantoneColor PANTONE3965 {get;}
public: __property static PDFPantoneColor* get_PANTONE3965();
public:
static property PDFPantoneColor^ PANTONE3965 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3965 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE397 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE397 Property
Gets the PANTONE 397 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE397 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE397
public static PDFPantoneColor PANTONE397 {get;}
public: __property static PDFPantoneColor* get_PANTONE397();
public:
static property PDFPantoneColor^ PANTONE397 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 397 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3975 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3975 Property
Gets the PANTONE 3975 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3975 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3975
public static PDFPantoneColor PANTONE3975 {get;}
public: __property static PDFPantoneColor* get_PANTONE3975();
public:
static property PDFPantoneColor^ PANTONE3975 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3975 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE398 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE398 Property
Gets the PANTONE 398 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE398 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE398
public static PDFPantoneColor PANTONE398 {get;}
public: __property static PDFPantoneColor* get_PANTONE398();
public:
static property PDFPantoneColor^ PANTONE398 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 398 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3985 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3985 Property
Gets the PANTONE 3985 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3985 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3985
public static PDFPantoneColor PANTONE3985 {get;}
public: __property static PDFPantoneColor* get_PANTONE3985();
public:
static property PDFPantoneColor^ PANTONE3985 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3985 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE399 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE399 Property
Gets the PANTONE 399 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE399 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE399
public static PDFPantoneColor PANTONE399 {get;}
public: __property static PDFPantoneColor* get_PANTONE399();
public:
static property PDFPantoneColor^ PANTONE399 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 399 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3995 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3995 Property
Gets the PANTONE 3995 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3995 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3995
public static PDFPantoneColor PANTONE3995 {get;}
public: __property static PDFPantoneColor* get_PANTONE3995();
public:
static property PDFPantoneColor^ PANTONE3995 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 3995 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE400 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE400 Property
Gets the PANTONE 400 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE400 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE400
public static PDFPantoneColor PANTONE400 {get;}
public: __property static PDFPantoneColor* get_PANTONE400();
public:
static property PDFPantoneColor^ PANTONE400 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 400 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE401 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE401 Property
Gets the PANTONE 401 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE401 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE401
public static PDFPantoneColor PANTONE401 {get;}
public: __property static PDFPantoneColor* get_PANTONE401();
public:
static property PDFPantoneColor^ PANTONE401 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 401 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE402 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE402 Property
Gets the PANTONE 402 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE402 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE402
public static PDFPantoneColor PANTONE402 {get;}
public: __property static PDFPantoneColor* get_PANTONE402();
public:
static property PDFPantoneColor^ PANTONE402 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 402 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE403 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE403 Property
Gets the PANTONE 403 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE403 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE403
public static PDFPantoneColor PANTONE403 {get;}
public: __property static PDFPantoneColor* get_PANTONE403();
public:
static property PDFPantoneColor^ PANTONE403 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 403 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE404 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE404 Property
Gets the PANTONE 404 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE404 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE404
public static PDFPantoneColor PANTONE404 {get;}
public: __property static PDFPantoneColor* get_PANTONE404();
public:
static property PDFPantoneColor^ PANTONE404 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 404 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE405 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE405 Property
Gets the PANTONE 405 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE405 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE405
public static PDFPantoneColor PANTONE405 {get;}
public: __property static PDFPantoneColor* get_PANTONE405();
public:
static property PDFPantoneColor^ PANTONE405 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 405 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE406 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE406 Property
Gets the PANTONE 406 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE406 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE406
public static PDFPantoneColor PANTONE406 {get;}
public: __property static PDFPantoneColor* get_PANTONE406();
public:
static property PDFPantoneColor^ PANTONE406 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 406 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE407 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE407 Property
Gets the PANTONE 407 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE407 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE407
public static PDFPantoneColor PANTONE407 {get;}
public: __property static PDFPantoneColor* get_PANTONE407();
public:
static property PDFPantoneColor^ PANTONE407 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 407 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE408 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE408 Property
Gets the PANTONE 408 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE408 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE408
public static PDFPantoneColor PANTONE408 {get;}
public: __property static PDFPantoneColor* get_PANTONE408();
public:
static property PDFPantoneColor^ PANTONE408 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 408 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE409 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE409 Property
Gets the PANTONE 409 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE409 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE409
public static PDFPantoneColor PANTONE409 {get;}
public: __property static PDFPantoneColor* get_PANTONE409();
public:
static property PDFPantoneColor^ PANTONE409 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 409 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE410 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE410 Property
Gets the PANTONE 410 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE410 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE410
public static PDFPantoneColor PANTONE410 {get;}
public: __property static PDFPantoneColor* get_PANTONE410();
public:
static property PDFPantoneColor^ PANTONE410 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 410 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE411 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE411 Property
Gets the PANTONE 411 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE411 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE411
public static PDFPantoneColor PANTONE411 {get;}
public: __property static PDFPantoneColor* get_PANTONE411();
public:
static property PDFPantoneColor^ PANTONE411 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 411 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE412 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE412 Property
Gets the PANTONE 412 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE412 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE412
public static PDFPantoneColor PANTONE412 {get;}
public: __property static PDFPantoneColor* get_PANTONE412();
public:
static property PDFPantoneColor^ PANTONE412 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 412 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE413 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE413 Property
Gets the PANTONE 413 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE413 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE413
public static PDFPantoneColor PANTONE413 {get;}
public: __property static PDFPantoneColor* get_PANTONE413();
public:
static property PDFPantoneColor^ PANTONE413 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 413 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE414 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE414 Property
Gets the PANTONE 414 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE414 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE414
public static PDFPantoneColor PANTONE414 {get;}
public: __property static PDFPantoneColor* get_PANTONE414();
public:
static property PDFPantoneColor^ PANTONE414 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 414 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE415 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE415 Property
Gets the PANTONE 415 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE415 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE415
public static PDFPantoneColor PANTONE415 {get;}
public: __property static PDFPantoneColor* get_PANTONE415();
public:
static property PDFPantoneColor^ PANTONE415 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 415 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE416 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE416 Property
Gets the PANTONE 416 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE416 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE416
public static PDFPantoneColor PANTONE416 {get;}
public: __property static PDFPantoneColor* get_PANTONE416();
public:
static property PDFPantoneColor^ PANTONE416 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 416 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE417 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE417 Property
Gets the PANTONE 417 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE417 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE417
public static PDFPantoneColor PANTONE417 {get;}
public: __property static PDFPantoneColor* get_PANTONE417();
public:
static property PDFPantoneColor^ PANTONE417 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 417 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE418 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE418 Property
Gets the PANTONE 418 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE418 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE418
public static PDFPantoneColor PANTONE418 {get;}
public: __property static PDFPantoneColor* get_PANTONE418();
public:
static property PDFPantoneColor^ PANTONE418 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 418 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE419 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE419 Property
Gets the PANTONE 419 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE419 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE419
public static PDFPantoneColor PANTONE419 {get;}
public: __property static PDFPantoneColor* get_PANTONE419();
public:
static property PDFPantoneColor^ PANTONE419 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 419 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE420 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE420 Property
Gets the PANTONE 420 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE420 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE420
public static PDFPantoneColor PANTONE420 {get;}
public: __property static PDFPantoneColor* get_PANTONE420();
public:
static property PDFPantoneColor^ PANTONE420 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 420 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE421 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE421 Property
Gets the PANTONE 421 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE421 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE421
public static PDFPantoneColor PANTONE421 {get;}
public: __property static PDFPantoneColor* get_PANTONE421();
public:
static property PDFPantoneColor^ PANTONE421 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 421 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE422 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE422 Property
Gets the PANTONE 422 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE422 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE422
public static PDFPantoneColor PANTONE422 {get;}
public: __property static PDFPantoneColor* get_PANTONE422();
public:
static property PDFPantoneColor^ PANTONE422 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 422 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE423 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE423 Property
Gets the PANTONE 423 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE423 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE423
public static PDFPantoneColor PANTONE423 {get;}
public: __property static PDFPantoneColor* get_PANTONE423();
public:
static property PDFPantoneColor^ PANTONE423 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 423 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE424 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE424 Property
Gets the PANTONE 424 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE424 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE424
public static PDFPantoneColor PANTONE424 {get;}
public: __property static PDFPantoneColor* get_PANTONE424();
public:
static property PDFPantoneColor^ PANTONE424 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 424 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE425 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE425 Property
Gets the PANTONE 425 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE425 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE425
public static PDFPantoneColor PANTONE425 {get;}
public: __property static PDFPantoneColor* get_PANTONE425();
public:
static property PDFPantoneColor^ PANTONE425 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 425 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE426 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE426 Property
Gets the PANTONE 426 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE426 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE426
public static PDFPantoneColor PANTONE426 {get;}
public: __property static PDFPantoneColor* get_PANTONE426();
public:
static property PDFPantoneColor^ PANTONE426 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 426 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE427 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE427 Property
Gets the PANTONE 427 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE427 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE427
public static PDFPantoneColor PANTONE427 {get;}
public: __property static PDFPantoneColor* get_PANTONE427();
public:
static property PDFPantoneColor^ PANTONE427 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 427 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE428 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE428 Property
Gets the PANTONE 428 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE428 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE428
public static PDFPantoneColor PANTONE428 {get;}
public: __property static PDFPantoneColor* get_PANTONE428();
public:
static property PDFPantoneColor^ PANTONE428 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 428 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE429 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE429 Property
Gets the PANTONE 429 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE429 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE429
public static PDFPantoneColor PANTONE429 {get;}
public: __property static PDFPantoneColor* get_PANTONE429();
public:
static property PDFPantoneColor^ PANTONE429 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 429 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE430 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE430 Property
Gets the PANTONE 430 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE430 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE430
public static PDFPantoneColor PANTONE430 {get;}
public: __property static PDFPantoneColor* get_PANTONE430();
public:
static property PDFPantoneColor^ PANTONE430 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 430 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE431 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE431 Property
Gets the PANTONE 431 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE431 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE431
public static PDFPantoneColor PANTONE431 {get;}
public: __property static PDFPantoneColor* get_PANTONE431();
public:
static property PDFPantoneColor^ PANTONE431 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 431 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE432 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE432 Property
Gets the PANTONE 432 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE432 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE432
public static PDFPantoneColor PANTONE432 {get;}
public: __property static PDFPantoneColor* get_PANTONE432();
public:
static property PDFPantoneColor^ PANTONE432 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 432 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE433 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE433 Property
Gets the PANTONE 433 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE433 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE433
public static PDFPantoneColor PANTONE433 {get;}
public: __property static PDFPantoneColor* get_PANTONE433();
public:
static property PDFPantoneColor^ PANTONE433 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 433 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE434 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE434 Property
Gets the PANTONE 434 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE434 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE434
public static PDFPantoneColor PANTONE434 {get;}
public: __property static PDFPantoneColor* get_PANTONE434();
public:
static property PDFPantoneColor^ PANTONE434 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 434 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE435 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE435 Property
Gets the PANTONE 435 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE435 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE435
public static PDFPantoneColor PANTONE435 {get;}
public: __property static PDFPantoneColor* get_PANTONE435();
public:
static property PDFPantoneColor^ PANTONE435 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 435 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE436 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE436 Property
Gets the PANTONE 436 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE436 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE436
public static PDFPantoneColor PANTONE436 {get;}
public: __property static PDFPantoneColor* get_PANTONE436();
public:
static property PDFPantoneColor^ PANTONE436 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 436 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE437 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE437 Property
Gets the PANTONE 437 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE437 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE437
public static PDFPantoneColor PANTONE437 {get;}
public: __property static PDFPantoneColor* get_PANTONE437();
public:
static property PDFPantoneColor^ PANTONE437 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 437 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE438 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE438 Property
Gets the PANTONE 438 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE438 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE438
public static PDFPantoneColor PANTONE438 {get;}
public: __property static PDFPantoneColor* get_PANTONE438();
public:
static property PDFPantoneColor^ PANTONE438 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 438 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE439 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE439 Property
Gets the PANTONE 439 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE439 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE439
public static PDFPantoneColor PANTONE439 {get;}
public: __property static PDFPantoneColor* get_PANTONE439();
public:
static property PDFPantoneColor^ PANTONE439 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 439 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE440 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE440 Property
Gets the PANTONE 440 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE440 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE440
public static PDFPantoneColor PANTONE440 {get;}
public: __property static PDFPantoneColor* get_PANTONE440();
public:
static property PDFPantoneColor^ PANTONE440 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 440 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE441 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE441 Property
Gets the PANTONE 441 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE441 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE441
public static PDFPantoneColor PANTONE441 {get;}
public: __property static PDFPantoneColor* get_PANTONE441();
public:
static property PDFPantoneColor^ PANTONE441 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 441 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE442 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE442 Property
Gets the PANTONE 442 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE442 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE442
public static PDFPantoneColor PANTONE442 {get;}
public: __property static PDFPantoneColor* get_PANTONE442();
public:
static property PDFPantoneColor^ PANTONE442 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 442 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE443 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE443 Property
Gets the PANTONE 443 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE443 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE443
public static PDFPantoneColor PANTONE443 {get;}
public: __property static PDFPantoneColor* get_PANTONE443();
public:
static property PDFPantoneColor^ PANTONE443 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 443 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE444 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE444 Property
Gets the PANTONE 444 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE444 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE444
public static PDFPantoneColor PANTONE444 {get;}
public: __property static PDFPantoneColor* get_PANTONE444();
public:
static property PDFPantoneColor^ PANTONE444 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 444 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE445 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE445 Property
Gets the PANTONE 445 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE445 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE445
public static PDFPantoneColor PANTONE445 {get;}
public: __property static PDFPantoneColor* get_PANTONE445();
public:
static property PDFPantoneColor^ PANTONE445 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 445 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE446 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE446 Property
Gets the PANTONE 446 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE446 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE446
public static PDFPantoneColor PANTONE446 {get;}
public: __property static PDFPantoneColor* get_PANTONE446();
public:
static property PDFPantoneColor^ PANTONE446 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 446 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE447 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE447 Property
Gets the PANTONE 447 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE447 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE447
public static PDFPantoneColor PANTONE447 {get;}
public: __property static PDFPantoneColor* get_PANTONE447();
public:
static property PDFPantoneColor^ PANTONE447 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 447 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE448 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE448 Property
Gets the PANTONE 448 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE448 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE448
public static PDFPantoneColor PANTONE448 {get;}
public: __property static PDFPantoneColor* get_PANTONE448();
public:
static property PDFPantoneColor^ PANTONE448 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 448 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4485 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4485 Property
Gets the PANTONE 4485 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4485 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4485
public static PDFPantoneColor PANTONE4485 {get;}
public: __property static PDFPantoneColor* get_PANTONE4485();
public:
static property PDFPantoneColor^ PANTONE4485 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4485 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE449 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE449 Property
Gets the PANTONE 449 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE449 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE449
public static PDFPantoneColor PANTONE449 {get;}
public: __property static PDFPantoneColor* get_PANTONE449();
public:
static property PDFPantoneColor^ PANTONE449 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 449 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4495 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4495 Property
Gets the PANTONE 4495 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4495 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4495
public static PDFPantoneColor PANTONE4495 {get;}
public: __property static PDFPantoneColor* get_PANTONE4495();
public:
static property PDFPantoneColor^ PANTONE4495 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4495 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE450 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE450 Property
Gets the PANTONE 450 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE450 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE450
public static PDFPantoneColor PANTONE450 {get;}
public: __property static PDFPantoneColor* get_PANTONE450();
public:
static property PDFPantoneColor^ PANTONE450 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 450 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4505 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4505 Property
Gets the PANTONE 4505 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4505 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4505
public static PDFPantoneColor PANTONE4505 {get;}
public: __property static PDFPantoneColor* get_PANTONE4505();
public:
static property PDFPantoneColor^ PANTONE4505 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4505 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE451 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE451 Property
Gets the PANTONE 451 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE451 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE451
public static PDFPantoneColor PANTONE451 {get;}
public: __property static PDFPantoneColor* get_PANTONE451();
public:
static property PDFPantoneColor^ PANTONE451 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 451 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4515 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4515 Property
Gets the PANTONE 4515 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4515 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4515
public static PDFPantoneColor PANTONE4515 {get;}
public: __property static PDFPantoneColor* get_PANTONE4515();
public:
static property PDFPantoneColor^ PANTONE4515 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4515 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE452 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE452 Property
Gets the PANTONE 452 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE452 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE452
public static PDFPantoneColor PANTONE452 {get;}
public: __property static PDFPantoneColor* get_PANTONE452();
public:
static property PDFPantoneColor^ PANTONE452 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 452 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4525 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4525 Property
Gets the PANTONE 4525 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4525 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4525
public static PDFPantoneColor PANTONE4525 {get;}
public: __property static PDFPantoneColor* get_PANTONE4525();
public:
static property PDFPantoneColor^ PANTONE4525 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4525 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE453 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE453 Property
Gets the PANTONE 453 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE453 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE453
public static PDFPantoneColor PANTONE453 {get;}
public: __property static PDFPantoneColor* get_PANTONE453();
public:
static property PDFPantoneColor^ PANTONE453 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 453 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4535 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4535 Property
Gets the PANTONE 4535 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4535 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4535
public static PDFPantoneColor PANTONE4535 {get;}
public: __property static PDFPantoneColor* get_PANTONE4535();
public:
static property PDFPantoneColor^ PANTONE4535 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4535 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE454 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE454 Property
Gets the PANTONE 454 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE454 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE454
public static PDFPantoneColor PANTONE454 {get;}
public: __property static PDFPantoneColor* get_PANTONE454();
public:
static property PDFPantoneColor^ PANTONE454 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 454 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4545 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4545 Property
Gets the PANTONE 4545 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4545 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4545
public static PDFPantoneColor PANTONE4545 {get;}
public: __property static PDFPantoneColor* get_PANTONE4545();
public:
static property PDFPantoneColor^ PANTONE4545 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4545 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE455 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE455 Property
Gets the PANTONE 455 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE455 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE455
public static PDFPantoneColor PANTONE455 {get;}
public: __property static PDFPantoneColor* get_PANTONE455();
public:
static property PDFPantoneColor^ PANTONE455 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 455 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE456 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE456 Property
Gets the PANTONE 456 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE456 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE456
public static PDFPantoneColor PANTONE456 {get;}
public: __property static PDFPantoneColor* get_PANTONE456();
public:
static property PDFPantoneColor^ PANTONE456 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 456 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE457 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE457 Property
Gets the PANTONE 457 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE457 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE457
public static PDFPantoneColor PANTONE457 {get;}
public: __property static PDFPantoneColor* get_PANTONE457();
public:
static property PDFPantoneColor^ PANTONE457 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 457 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE458 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE458 Property
Gets the PANTONE 458 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE458 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE458
public static PDFPantoneColor PANTONE458 {get;}
public: __property static PDFPantoneColor* get_PANTONE458();
public:
static property PDFPantoneColor^ PANTONE458 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 458 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE459 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE459 Property
Gets the PANTONE 459 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE459 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE459
public static PDFPantoneColor PANTONE459 {get;}
public: __property static PDFPantoneColor* get_PANTONE459();
public:
static property PDFPantoneColor^ PANTONE459 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 459 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE460 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE460 Property
Gets the PANTONE 460 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE460 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE460
public static PDFPantoneColor PANTONE460 {get;}
public: __property static PDFPantoneColor* get_PANTONE460();
public:
static property PDFPantoneColor^ PANTONE460 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 460 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE461 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE461 Property
Gets the PANTONE 461 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE461 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE461
public static PDFPantoneColor PANTONE461 {get;}
public: __property static PDFPantoneColor* get_PANTONE461();
public:
static property PDFPantoneColor^ PANTONE461 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 461 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE462 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE462 Property
Gets the PANTONE 462 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE462 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE462
public static PDFPantoneColor PANTONE462 {get;}
public: __property static PDFPantoneColor* get_PANTONE462();
public:
static property PDFPantoneColor^ PANTONE462 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 462 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4625 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4625 Property
Gets the PANTONE 4625 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4625 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4625
public static PDFPantoneColor PANTONE4625 {get;}
public: __property static PDFPantoneColor* get_PANTONE4625();
public:
static property PDFPantoneColor^ PANTONE4625 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4625 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE463 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE463 Property
Gets the PANTONE 463 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE463 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE463
public static PDFPantoneColor PANTONE463 {get;}
public: __property static PDFPantoneColor* get_PANTONE463();
public:
static property PDFPantoneColor^ PANTONE463 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 463 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4635 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4635 Property
Gets the PANTONE 4635 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4635 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4635
public static PDFPantoneColor PANTONE4635 {get;}
public: __property static PDFPantoneColor* get_PANTONE4635();
public:
static property PDFPantoneColor^ PANTONE4635 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4635 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE464 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE464 Property
Gets the PANTONE 464 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE464 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE464
public static PDFPantoneColor PANTONE464 {get;}
public: __property static PDFPantoneColor* get_PANTONE464();
public:
static property PDFPantoneColor^ PANTONE464 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 464 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4645 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4645 Property
Gets the PANTONE 4645 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4645 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4645
public static PDFPantoneColor PANTONE4645 {get;}
public: __property static PDFPantoneColor* get_PANTONE4645();
public:
static property PDFPantoneColor^ PANTONE4645 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4645 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE465 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE465 Property
Gets the PANTONE 465 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE465 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE465
public static PDFPantoneColor PANTONE465 {get;}
public: __property static PDFPantoneColor* get_PANTONE465();
public:
static property PDFPantoneColor^ PANTONE465 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 465 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4655 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4655 Property
Gets the PANTONE 4655 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4655 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4655
public static PDFPantoneColor PANTONE4655 {get;}
public: __property static PDFPantoneColor* get_PANTONE4655();
public:
static property PDFPantoneColor^ PANTONE4655 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4655 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE466 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE466 Property
Gets the PANTONE 466 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE466 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE466
public static PDFPantoneColor PANTONE466 {get;}
public: __property static PDFPantoneColor* get_PANTONE466();
public:
static property PDFPantoneColor^ PANTONE466 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 466 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4665 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4665 Property
Gets the PANTONE 4665 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4665 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4665
public static PDFPantoneColor PANTONE4665 {get;}
public: __property static PDFPantoneColor* get_PANTONE4665();
public:
static property PDFPantoneColor^ PANTONE4665 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4665 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE467 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE467 Property
Gets the PANTONE 467 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE467 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE467
public static PDFPantoneColor PANTONE467 {get;}
public: __property static PDFPantoneColor* get_PANTONE467();
public:
static property PDFPantoneColor^ PANTONE467 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 467 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4675 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4675 Property
Gets the PANTONE 4675 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4675 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4675
public static PDFPantoneColor PANTONE4675 {get;}
public: __property static PDFPantoneColor* get_PANTONE4675();
public:
static property PDFPantoneColor^ PANTONE4675 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4675 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE468 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE468 Property
Gets the PANTONE 468 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE468 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE468
public static PDFPantoneColor PANTONE468 {get;}
public: __property static PDFPantoneColor* get_PANTONE468();
public:
static property PDFPantoneColor^ PANTONE468 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 468 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4685 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4685 Property
Gets the PANTONE 4685 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4685 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4685
public static PDFPantoneColor PANTONE4685 {get;}
public: __property static PDFPantoneColor* get_PANTONE4685();
public:
static property PDFPantoneColor^ PANTONE4685 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4685 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE469 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE469 Property
Gets the PANTONE 469 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE469 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE469
public static PDFPantoneColor PANTONE469 {get;}
public: __property static PDFPantoneColor* get_PANTONE469();
public:
static property PDFPantoneColor^ PANTONE469 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 469 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4695 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4695 Property
Gets the PANTONE 4695 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4695 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4695
public static PDFPantoneColor PANTONE4695 {get;}
public: __property static PDFPantoneColor* get_PANTONE4695();
public:
static property PDFPantoneColor^ PANTONE4695 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4695 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE470 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE470 Property
Gets the PANTONE 470 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE470 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE470
public static PDFPantoneColor PANTONE470 {get;}
public: __property static PDFPantoneColor* get_PANTONE470();
public:
static property PDFPantoneColor^ PANTONE470 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 470 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4705 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4705 Property
Gets the PANTONE 4705 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4705 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4705
public static PDFPantoneColor PANTONE4705 {get;}
public: __property static PDFPantoneColor* get_PANTONE4705();
public:
static property PDFPantoneColor^ PANTONE4705 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4705 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE471 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE471 Property
Gets the PANTONE 471 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE471 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE471
public static PDFPantoneColor PANTONE471 {get;}
public: __property static PDFPantoneColor* get_PANTONE471();
public:
static property PDFPantoneColor^ PANTONE471 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 471 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4715 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4715 Property
Gets the PANTONE 4715 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4715 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4715
public static PDFPantoneColor PANTONE4715 {get;}
public: __property static PDFPantoneColor* get_PANTONE4715();
public:
static property PDFPantoneColor^ PANTONE4715 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4715 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE472 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE472 Property
Gets the PANTONE 472 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE472 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE472
public static PDFPantoneColor PANTONE472 {get;}
public: __property static PDFPantoneColor* get_PANTONE472();
public:
static property PDFPantoneColor^ PANTONE472 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 472 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4725 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4725 Property
Gets the PANTONE 4725 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4725 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4725
public static PDFPantoneColor PANTONE4725 {get;}
public: __property static PDFPantoneColor* get_PANTONE4725();
public:
static property PDFPantoneColor^ PANTONE4725 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4725 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE473 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE473 Property
Gets the PANTONE 473 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE473 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE473
public static PDFPantoneColor PANTONE473 {get;}
public: __property static PDFPantoneColor* get_PANTONE473();
public:
static property PDFPantoneColor^ PANTONE473 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 473 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4735 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4735 Property
Gets the PANTONE 4735 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4735 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4735
public static PDFPantoneColor PANTONE4735 {get;}
public: __property static PDFPantoneColor* get_PANTONE4735();
public:
static property PDFPantoneColor^ PANTONE4735 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4735 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE474 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE474 Property
Gets the PANTONE 474 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE474 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE474
public static PDFPantoneColor PANTONE474 {get;}
public: __property static PDFPantoneColor* get_PANTONE474();
public:
static property PDFPantoneColor^ PANTONE474 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 474 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4745 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4745 Property
Gets the PANTONE 4745 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4745 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4745
public static PDFPantoneColor PANTONE4745 {get;}
public: __property static PDFPantoneColor* get_PANTONE4745();
public:
static property PDFPantoneColor^ PANTONE4745 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4745 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE475 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE475 Property
Gets the PANTONE 475 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE475 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE475
public static PDFPantoneColor PANTONE475 {get;}
public: __property static PDFPantoneColor* get_PANTONE475();
public:
static property PDFPantoneColor^ PANTONE475 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 475 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4755 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4755 Property
Gets the PANTONE 4755 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4755 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4755
public static PDFPantoneColor PANTONE4755 {get;}
public: __property static PDFPantoneColor* get_PANTONE4755();
public:
static property PDFPantoneColor^ PANTONE4755 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4755 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE476 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE476 Property
Gets the PANTONE 476 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE476 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE476
public static PDFPantoneColor PANTONE476 {get;}
public: __property static PDFPantoneColor* get_PANTONE476();
public:
static property PDFPantoneColor^ PANTONE476 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 476 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE477 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE477 Property
Gets the PANTONE 477 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE477 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE477
public static PDFPantoneColor PANTONE477 {get;}
public: __property static PDFPantoneColor* get_PANTONE477();
public:
static property PDFPantoneColor^ PANTONE477 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 477 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE478 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE478 Property
Gets the PANTONE 478 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE478 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE478
public static PDFPantoneColor PANTONE478 {get;}
public: __property static PDFPantoneColor* get_PANTONE478();
public:
static property PDFPantoneColor^ PANTONE478 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 478 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE479 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE479 Property
Gets the PANTONE 479 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE479 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE479
public static PDFPantoneColor PANTONE479 {get;}
public: __property static PDFPantoneColor* get_PANTONE479();
public:
static property PDFPantoneColor^ PANTONE479 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 479 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE480 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE480 Property
Gets the PANTONE 480 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE480 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE480
public static PDFPantoneColor PANTONE480 {get;}
public: __property static PDFPantoneColor* get_PANTONE480();
public:
static property PDFPantoneColor^ PANTONE480 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 480 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE481 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE481 Property
Gets the PANTONE 481 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE481 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE481
public static PDFPantoneColor PANTONE481 {get;}
public: __property static PDFPantoneColor* get_PANTONE481();
public:
static property PDFPantoneColor^ PANTONE481 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 481 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE482 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE482 Property
Gets the PANTONE 482 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE482 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE482
public static PDFPantoneColor PANTONE482 {get;}
public: __property static PDFPantoneColor* get_PANTONE482();
public:
static property PDFPantoneColor^ PANTONE482 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 482 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE483 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE483 Property
Gets the PANTONE 483 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE483 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE483
public static PDFPantoneColor PANTONE483 {get;}
public: __property static PDFPantoneColor* get_PANTONE483();
public:
static property PDFPantoneColor^ PANTONE483 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 483 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE484 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE484 Property
Gets the PANTONE 484 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE484 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE484
public static PDFPantoneColor PANTONE484 {get;}
public: __property static PDFPantoneColor* get_PANTONE484();
public:
static property PDFPantoneColor^ PANTONE484 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 484 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE485 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE485 Property
Gets the PANTONE 485 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE485 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE485
public static PDFPantoneColor PANTONE485 {get;}
public: __property static PDFPantoneColor* get_PANTONE485();
public:
static property PDFPantoneColor^ PANTONE485 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 485 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE486 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE486 Property
Gets the PANTONE 486 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE486 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE486
public static PDFPantoneColor PANTONE486 {get;}
public: __property static PDFPantoneColor* get_PANTONE486();
public:
static property PDFPantoneColor^ PANTONE486 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 486 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE487 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE487 Property
Gets the PANTONE 487 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE487 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE487
public static PDFPantoneColor PANTONE487 {get;}
public: __property static PDFPantoneColor* get_PANTONE487();
public:
static property PDFPantoneColor^ PANTONE487 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 487 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE488 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE488 Property
Gets the PANTONE 488 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE488 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE488
public static PDFPantoneColor PANTONE488 {get;}
public: __property static PDFPantoneColor* get_PANTONE488();
public:
static property PDFPantoneColor^ PANTONE488 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 488 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE489 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE489 Property
Gets the PANTONE 489 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE489 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE489
public static PDFPantoneColor PANTONE489 {get;}
public: __property static PDFPantoneColor* get_PANTONE489();
public:
static property PDFPantoneColor^ PANTONE489 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 489 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE490 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE490 Property
Gets the PANTONE 490 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE490 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE490
public static PDFPantoneColor PANTONE490 {get;}
public: __property static PDFPantoneColor* get_PANTONE490();
public:
static property PDFPantoneColor^ PANTONE490 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 490 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE491 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE491 Property
Gets the PANTONE 491 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE491 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE491
public static PDFPantoneColor PANTONE491 {get;}
public: __property static PDFPantoneColor* get_PANTONE491();
public:
static property PDFPantoneColor^ PANTONE491 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 491 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE492 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE492 Property
Gets the PANTONE 492 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE492 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE492
public static PDFPantoneColor PANTONE492 {get;}
public: __property static PDFPantoneColor* get_PANTONE492();
public:
static property PDFPantoneColor^ PANTONE492 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 492 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE493 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE493 Property
Gets the PANTONE 493 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE493 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE493
public static PDFPantoneColor PANTONE493 {get;}
public: __property static PDFPantoneColor* get_PANTONE493();
public:
static property PDFPantoneColor^ PANTONE493 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 493 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE494 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE494 Property
Gets the PANTONE 494 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE494 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE494
public static PDFPantoneColor PANTONE494 {get;}
public: __property static PDFPantoneColor* get_PANTONE494();
public:
static property PDFPantoneColor^ PANTONE494 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 494 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE495 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE495 Property
Gets the PANTONE 495 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE495 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE495
public static PDFPantoneColor PANTONE495 {get;}
public: __property static PDFPantoneColor* get_PANTONE495();
public:
static property PDFPantoneColor^ PANTONE495 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 495 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE496 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE496 Property
Gets the PANTONE 496 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE496 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE496
public static PDFPantoneColor PANTONE496 {get;}
public: __property static PDFPantoneColor* get_PANTONE496();
public:
static property PDFPantoneColor^ PANTONE496 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 496 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE497 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE497 Property
Gets the PANTONE 497 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE497 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE497
public static PDFPantoneColor PANTONE497 {get;}
public: __property static PDFPantoneColor* get_PANTONE497();
public:
static property PDFPantoneColor^ PANTONE497 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 497 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4975 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4975 Property
Gets the PANTONE 4975 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4975 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4975
public static PDFPantoneColor PANTONE4975 {get;}
public: __property static PDFPantoneColor* get_PANTONE4975();
public:
static property PDFPantoneColor^ PANTONE4975 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4975 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE498 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE498 Property
Gets the PANTONE 498 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE498 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE498
public static PDFPantoneColor PANTONE498 {get;}
public: __property static PDFPantoneColor* get_PANTONE498();
public:
static property PDFPantoneColor^ PANTONE498 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 498 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4985 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4985 Property
Gets the PANTONE 4985 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4985 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4985
public static PDFPantoneColor PANTONE4985 {get;}
public: __property static PDFPantoneColor* get_PANTONE4985();
public:
static property PDFPantoneColor^ PANTONE4985 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4985 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE499 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE499 Property
Gets the PANTONE 499 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE499 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE499
public static PDFPantoneColor PANTONE499 {get;}
public: __property static PDFPantoneColor* get_PANTONE499();
public:
static property PDFPantoneColor^ PANTONE499 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 499 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4995 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4995 Property
Gets the PANTONE 4995 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4995 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4995
public static PDFPantoneColor PANTONE4995 {get;}
public: __property static PDFPantoneColor* get_PANTONE4995();
public:
static property PDFPantoneColor^ PANTONE4995 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 4995 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE500 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE500 Property
Gets the PANTONE 500 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE500 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE500
public static PDFPantoneColor PANTONE500 {get;}
public: __property static PDFPantoneColor* get_PANTONE500();
public:
static property PDFPantoneColor^ PANTONE500 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 500 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5005 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5005 Property
Gets the PANTONE 5005 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5005 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5005
public static PDFPantoneColor PANTONE5005 {get;}
public: __property static PDFPantoneColor* get_PANTONE5005();
public:
static property PDFPantoneColor^ PANTONE5005 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5005 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE501 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE501 Property
Gets the PANTONE 501 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE501 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE501
public static PDFPantoneColor PANTONE501 {get;}
public: __property static PDFPantoneColor* get_PANTONE501();
public:
static property PDFPantoneColor^ PANTONE501 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 501 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5015 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5015 Property
Gets the PANTONE 5015 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5015 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5015
public static PDFPantoneColor PANTONE5015 {get;}
public: __property static PDFPantoneColor* get_PANTONE5015();
public:
static property PDFPantoneColor^ PANTONE5015 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5015 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE502 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE502 Property
Gets the PANTONE 502 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE502 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE502
public static PDFPantoneColor PANTONE502 {get;}
public: __property static PDFPantoneColor* get_PANTONE502();
public:
static property PDFPantoneColor^ PANTONE502 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 502 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5025 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5025 Property
Gets the PANTONE 5025 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5025 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5025
public static PDFPantoneColor PANTONE5025 {get;}
public: __property static PDFPantoneColor* get_PANTONE5025();
public:
static property PDFPantoneColor^ PANTONE5025 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5025 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE503 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE503 Property
Gets the PANTONE 503 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE503 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE503
public static PDFPantoneColor PANTONE503 {get;}
public: __property static PDFPantoneColor* get_PANTONE503();
public:
static property PDFPantoneColor^ PANTONE503 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 503 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5035 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5035 Property
Gets the PANTONE 5035 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5035 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5035
public static PDFPantoneColor PANTONE5035 {get;}
public: __property static PDFPantoneColor* get_PANTONE5035();
public:
static property PDFPantoneColor^ PANTONE5035 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5035 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE504 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE504 Property
Gets the PANTONE 504 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE504 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE504
public static PDFPantoneColor PANTONE504 {get;}
public: __property static PDFPantoneColor* get_PANTONE504();
public:
static property PDFPantoneColor^ PANTONE504 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 504 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE505 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE505 Property
Gets the PANTONE 505 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE505 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE505
public static PDFPantoneColor PANTONE505 {get;}
public: __property static PDFPantoneColor* get_PANTONE505();
public:
static property PDFPantoneColor^ PANTONE505 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 505 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE506 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE506 Property
Gets the PANTONE 506 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE506 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE506
public static PDFPantoneColor PANTONE506 {get;}
public: __property static PDFPantoneColor* get_PANTONE506();
public:
static property PDFPantoneColor^ PANTONE506 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 506 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE507 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE507 Property
Gets the PANTONE 507 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE507 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE507
public static PDFPantoneColor PANTONE507 {get;}
public: __property static PDFPantoneColor* get_PANTONE507();
public:
static property PDFPantoneColor^ PANTONE507 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 507 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE508 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE508 Property
Gets the PANTONE 508 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE508 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE508
public static PDFPantoneColor PANTONE508 {get;}
public: __property static PDFPantoneColor* get_PANTONE508();
public:
static property PDFPantoneColor^ PANTONE508 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 508 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE509 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE509 Property
Gets the PANTONE 509 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE509 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE509
public static PDFPantoneColor PANTONE509 {get;}
public: __property static PDFPantoneColor* get_PANTONE509();
public:
static property PDFPantoneColor^ PANTONE509 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 509 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE510 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE510 Property
Gets the PANTONE 510 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE510 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE510
public static PDFPantoneColor PANTONE510 {get;}
public: __property static PDFPantoneColor* get_PANTONE510();
public:
static property PDFPantoneColor^ PANTONE510 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 510 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE511 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE511 Property
Gets the PANTONE 511 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE511 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE511
public static PDFPantoneColor PANTONE511 {get;}
public: __property static PDFPantoneColor* get_PANTONE511();
public:
static property PDFPantoneColor^ PANTONE511 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 511 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5115 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5115 Property
Gets the PANTONE 5115 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5115 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5115
public static PDFPantoneColor PANTONE5115 {get;}
public: __property static PDFPantoneColor* get_PANTONE5115();
public:
static property PDFPantoneColor^ PANTONE5115 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5115 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE512 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE512 Property
Gets the PANTONE 512 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE512 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE512
public static PDFPantoneColor PANTONE512 {get;}
public: __property static PDFPantoneColor* get_PANTONE512();
public:
static property PDFPantoneColor^ PANTONE512 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 512 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5125 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5125 Property
Gets the PANTONE 5125 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5125 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5125
public static PDFPantoneColor PANTONE5125 {get;}
public: __property static PDFPantoneColor* get_PANTONE5125();
public:
static property PDFPantoneColor^ PANTONE5125 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5125 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE513 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE513 Property
Gets the PANTONE 513 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE513 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE513
public static PDFPantoneColor PANTONE513 {get;}
public: __property static PDFPantoneColor* get_PANTONE513();
public:
static property PDFPantoneColor^ PANTONE513 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 513 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5135 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5135 Property
Gets the PANTONE 5135 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5135 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5135
public static PDFPantoneColor PANTONE5135 {get;}
public: __property static PDFPantoneColor* get_PANTONE5135();
public:
static property PDFPantoneColor^ PANTONE5135 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5135 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE514 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE514 Property
Gets the PANTONE 514 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE514 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE514
public static PDFPantoneColor PANTONE514 {get;}
public: __property static PDFPantoneColor* get_PANTONE514();
public:
static property PDFPantoneColor^ PANTONE514 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 514 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5145 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5145 Property
Gets the PANTONE 5145 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5145 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5145
public static PDFPantoneColor PANTONE5145 {get;}
public: __property static PDFPantoneColor* get_PANTONE5145();
public:
static property PDFPantoneColor^ PANTONE5145 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5145 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE515 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE515 Property
Gets the PANTONE 515 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE515 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE515
public static PDFPantoneColor PANTONE515 {get;}
public: __property static PDFPantoneColor* get_PANTONE515();
public:
static property PDFPantoneColor^ PANTONE515 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 515 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5155 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5155 Property
Gets the PANTONE 5155 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5155 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5155
public static PDFPantoneColor PANTONE5155 {get;}
public: __property static PDFPantoneColor* get_PANTONE5155();
public:
static property PDFPantoneColor^ PANTONE5155 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5155 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE516 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE516 Property
Gets the PANTONE 516 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE516 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE516
public static PDFPantoneColor PANTONE516 {get;}
public: __property static PDFPantoneColor* get_PANTONE516();
public:
static property PDFPantoneColor^ PANTONE516 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 516 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5165 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5165 Property
Gets the PANTONE 5165 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5165 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5165
public static PDFPantoneColor PANTONE5165 {get;}
public: __property static PDFPantoneColor* get_PANTONE5165();
public:
static property PDFPantoneColor^ PANTONE5165 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5165 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE517 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE517 Property
Gets the PANTONE 517 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE517 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE517
public static PDFPantoneColor PANTONE517 {get;}
public: __property static PDFPantoneColor* get_PANTONE517();
public:
static property PDFPantoneColor^ PANTONE517 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 517 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5175 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5175 Property
Gets the PANTONE 5175 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5175 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5175
public static PDFPantoneColor PANTONE5175 {get;}
public: __property static PDFPantoneColor* get_PANTONE5175();
public:
static property PDFPantoneColor^ PANTONE5175 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5175 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE518 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE518 Property
Gets the PANTONE 518 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE518 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE518
public static PDFPantoneColor PANTONE518 {get;}
public: __property static PDFPantoneColor* get_PANTONE518();
public:
static property PDFPantoneColor^ PANTONE518 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 518 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5185 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5185 Property
Gets the PANTONE 5185 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5185 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5185
public static PDFPantoneColor PANTONE5185 {get;}
public: __property static PDFPantoneColor* get_PANTONE5185();
public:
static property PDFPantoneColor^ PANTONE5185 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5185 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE519 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE519 Property
Gets the PANTONE 519 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE519 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE519
public static PDFPantoneColor PANTONE519 {get;}
public: __property static PDFPantoneColor* get_PANTONE519();
public:
static property PDFPantoneColor^ PANTONE519 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 519 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5195 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5195 Property
Gets the PANTONE 5195 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5195 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5195
public static PDFPantoneColor PANTONE5195 {get;}
public: __property static PDFPantoneColor* get_PANTONE5195();
public:
static property PDFPantoneColor^ PANTONE5195 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5195 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE520 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE520 Property
Gets the PANTONE 520 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE520 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE520
public static PDFPantoneColor PANTONE520 {get;}
public: __property static PDFPantoneColor* get_PANTONE520();
public:
static property PDFPantoneColor^ PANTONE520 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 520 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5205 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5205 Property
Gets the PANTONE 5205 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5205 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5205
public static PDFPantoneColor PANTONE5205 {get;}
public: __property static PDFPantoneColor* get_PANTONE5205();
public:
static property PDFPantoneColor^ PANTONE5205 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5205 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE521 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE521 Property
Gets the PANTONE 521 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE521 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE521
public static PDFPantoneColor PANTONE521 {get;}
public: __property static PDFPantoneColor* get_PANTONE521();
public:
static property PDFPantoneColor^ PANTONE521 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 521 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5215 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5215 Property
Gets the PANTONE 5215 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5215 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5215
public static PDFPantoneColor PANTONE5215 {get;}
public: __property static PDFPantoneColor* get_PANTONE5215();
public:
static property PDFPantoneColor^ PANTONE5215 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5215 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE522 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE522 Property
Gets the PANTONE 522 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE522 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE522
public static PDFPantoneColor PANTONE522 {get;}
public: __property static PDFPantoneColor* get_PANTONE522();
public:
static property PDFPantoneColor^ PANTONE522 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 522 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5225 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5225 Property
Gets the PANTONE 5225 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5225 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5225
public static PDFPantoneColor PANTONE5225 {get;}
public: __property static PDFPantoneColor* get_PANTONE5225();
public:
static property PDFPantoneColor^ PANTONE5225 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5225 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE523 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE523 Property
Gets the PANTONE 523 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE523 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE523
public static PDFPantoneColor PANTONE523 {get;}
public: __property static PDFPantoneColor* get_PANTONE523();
public:
static property PDFPantoneColor^ PANTONE523 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 523 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5235 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5235 Property
Gets the PANTONE 5235 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5235 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5235
public static PDFPantoneColor PANTONE5235 {get;}
public: __property static PDFPantoneColor* get_PANTONE5235();
public:
static property PDFPantoneColor^ PANTONE5235 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5235 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE524 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE524 Property
Gets the PANTONE 524 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE524 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE524
public static PDFPantoneColor PANTONE524 {get;}
public: __property static PDFPantoneColor* get_PANTONE524();
public:
static property PDFPantoneColor^ PANTONE524 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 524 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5245 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5245 Property
Gets the PANTONE 5245 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5245 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5245
public static PDFPantoneColor PANTONE5245 {get;}
public: __property static PDFPantoneColor* get_PANTONE5245();
public:
static property PDFPantoneColor^ PANTONE5245 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5245 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE525 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE525 Property
Gets the PANTONE 525 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE525 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE525
public static PDFPantoneColor PANTONE525 {get;}
public: __property static PDFPantoneColor* get_PANTONE525();
public:
static property PDFPantoneColor^ PANTONE525 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 525 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5255 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5255 Property
Gets the PANTONE 5255 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5255 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5255
public static PDFPantoneColor PANTONE5255 {get;}
public: __property static PDFPantoneColor* get_PANTONE5255();
public:
static property PDFPantoneColor^ PANTONE5255 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5255 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE526 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE526 Property
Gets the PANTONE 526 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE526 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE526
public static PDFPantoneColor PANTONE526 {get;}
public: __property static PDFPantoneColor* get_PANTONE526();
public:
static property PDFPantoneColor^ PANTONE526 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 526 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5265 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5265 Property
Gets the PANTONE 5265 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5265 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5265
public static PDFPantoneColor PANTONE5265 {get;}
public: __property static PDFPantoneColor* get_PANTONE5265();
public:
static property PDFPantoneColor^ PANTONE5265 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5265 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE527 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE527 Property
Gets the PANTONE 527 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE527 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE527
public static PDFPantoneColor PANTONE527 {get;}
public: __property static PDFPantoneColor* get_PANTONE527();
public:
static property PDFPantoneColor^ PANTONE527 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 527 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5275 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5275 Property
Gets the PANTONE 5275 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5275 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5275
public static PDFPantoneColor PANTONE5275 {get;}
public: __property static PDFPantoneColor* get_PANTONE5275();
public:
static property PDFPantoneColor^ PANTONE5275 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5275 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE528 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE528 Property
Gets the PANTONE 528 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE528 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE528
public static PDFPantoneColor PANTONE528 {get;}
public: __property static PDFPantoneColor* get_PANTONE528();
public:
static property PDFPantoneColor^ PANTONE528 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 528 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5285 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5285 Property
Gets the PANTONE 5285 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5285 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5285
public static PDFPantoneColor PANTONE5285 {get;}
public: __property static PDFPantoneColor* get_PANTONE5285();
public:
static property PDFPantoneColor^ PANTONE5285 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5285 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE529 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE529 Property
Gets the PANTONE 529 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE529 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE529
public static PDFPantoneColor PANTONE529 {get;}
public: __property static PDFPantoneColor* get_PANTONE529();
public:
static property PDFPantoneColor^ PANTONE529 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 529 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5295 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5295 Property
Gets the PANTONE 5295 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5295 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5295
public static PDFPantoneColor PANTONE5295 {get;}
public: __property static PDFPantoneColor* get_PANTONE5295();
public:
static property PDFPantoneColor^ PANTONE5295 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5295 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE530 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE530 Property
Gets the PANTONE 530 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE530 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE530
public static PDFPantoneColor PANTONE530 {get;}
public: __property static PDFPantoneColor* get_PANTONE530();
public:
static property PDFPantoneColor^ PANTONE530 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 530 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5305 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5305 Property
Gets the PANTONE 5305 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5305 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5305
public static PDFPantoneColor PANTONE5305 {get;}
public: __property static PDFPantoneColor* get_PANTONE5305();
public:
static property PDFPantoneColor^ PANTONE5305 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5305 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE531 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE531 Property
Gets the PANTONE 531 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE531 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE531
public static PDFPantoneColor PANTONE531 {get;}
public: __property static PDFPantoneColor* get_PANTONE531();
public:
static property PDFPantoneColor^ PANTONE531 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 531 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5315 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5315 Property
Gets the PANTONE 5315 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5315 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5315
public static PDFPantoneColor PANTONE5315 {get;}
public: __property static PDFPantoneColor* get_PANTONE5315();
public:
static property PDFPantoneColor^ PANTONE5315 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5315 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE532 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE532 Property
Gets the PANTONE 532 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE532 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE532
public static PDFPantoneColor PANTONE532 {get;}
public: __property static PDFPantoneColor* get_PANTONE532();
public:
static property PDFPantoneColor^ PANTONE532 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 532 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE533 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE533 Property
Gets the PANTONE 533 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE533 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE533
public static PDFPantoneColor PANTONE533 {get;}
public: __property static PDFPantoneColor* get_PANTONE533();
public:
static property PDFPantoneColor^ PANTONE533 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 533 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE534 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE534 Property
Gets the PANTONE 534 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE534 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE534
public static PDFPantoneColor PANTONE534 {get;}
public: __property static PDFPantoneColor* get_PANTONE534();
public:
static property PDFPantoneColor^ PANTONE534 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 534 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE535 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE535 Property
Gets the PANTONE 535 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE535 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE535
public static PDFPantoneColor PANTONE535 {get;}
public: __property static PDFPantoneColor* get_PANTONE535();
public:
static property PDFPantoneColor^ PANTONE535 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 535 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE536 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE536 Property
Gets the PANTONE 536 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE536 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE536
public static PDFPantoneColor PANTONE536 {get;}
public: __property static PDFPantoneColor* get_PANTONE536();
public:
static property PDFPantoneColor^ PANTONE536 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 536 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE537 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE537 Property
Gets the PANTONE 537 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE537 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE537
public static PDFPantoneColor PANTONE537 {get;}
public: __property static PDFPantoneColor* get_PANTONE537();
public:
static property PDFPantoneColor^ PANTONE537 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 537 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE538 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE538 Property
Gets the PANTONE 538 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE538 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE538
public static PDFPantoneColor PANTONE538 {get;}
public: __property static PDFPantoneColor* get_PANTONE538();
public:
static property PDFPantoneColor^ PANTONE538 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 538 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE539 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE539 Property
Gets the PANTONE 539 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE539 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE539
public static PDFPantoneColor PANTONE539 {get;}
public: __property static PDFPantoneColor* get_PANTONE539();
public:
static property PDFPantoneColor^ PANTONE539 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 539 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5395 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5395 Property
Gets the PANTONE 5395 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5395 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5395
public static PDFPantoneColor PANTONE5395 {get;}
public: __property static PDFPantoneColor* get_PANTONE5395();
public:
static property PDFPantoneColor^ PANTONE5395 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5395 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE540 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE540 Property
Gets the PANTONE 540 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE540 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE540
public static PDFPantoneColor PANTONE540 {get;}
public: __property static PDFPantoneColor* get_PANTONE540();
public:
static property PDFPantoneColor^ PANTONE540 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 540 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5405 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5405 Property
Gets the PANTONE 5405 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5405 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5405
public static PDFPantoneColor PANTONE5405 {get;}
public: __property static PDFPantoneColor* get_PANTONE5405();
public:
static property PDFPantoneColor^ PANTONE5405 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5405 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE541 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE541 Property
Gets the PANTONE 541 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE541 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE541
public static PDFPantoneColor PANTONE541 {get;}
public: __property static PDFPantoneColor* get_PANTONE541();
public:
static property PDFPantoneColor^ PANTONE541 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 541 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5415 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5415 Property
Gets the PANTONE 5415 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5415 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5415
public static PDFPantoneColor PANTONE5415 {get;}
public: __property static PDFPantoneColor* get_PANTONE5415();
public:
static property PDFPantoneColor^ PANTONE5415 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5415 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE542 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE542 Property
Gets the PANTONE 542 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE542 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE542
public static PDFPantoneColor PANTONE542 {get;}
public: __property static PDFPantoneColor* get_PANTONE542();
public:
static property PDFPantoneColor^ PANTONE542 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 542 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5425 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5425 Property
Gets the PANTONE 5425 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5425 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5425
public static PDFPantoneColor PANTONE5425 {get;}
public: __property static PDFPantoneColor* get_PANTONE5425();
public:
static property PDFPantoneColor^ PANTONE5425 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5425 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE543 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE543 Property
Gets the PANTONE 543 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE543 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE543
public static PDFPantoneColor PANTONE543 {get;}
public: __property static PDFPantoneColor* get_PANTONE543();
public:
static property PDFPantoneColor^ PANTONE543 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 543 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5435 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5435 Property
Gets the PANTONE 5435 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5435 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5435
public static PDFPantoneColor PANTONE5435 {get;}
public: __property static PDFPantoneColor* get_PANTONE5435();
public:
static property PDFPantoneColor^ PANTONE5435 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5435 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE544 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE544 Property
Gets the PANTONE 544 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE544 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE544
public static PDFPantoneColor PANTONE544 {get;}
public: __property static PDFPantoneColor* get_PANTONE544();
public:
static property PDFPantoneColor^ PANTONE544 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 544 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5445 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5445 Property
Gets the PANTONE 5445 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5445 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5445
public static PDFPantoneColor PANTONE5445 {get;}
public: __property static PDFPantoneColor* get_PANTONE5445();
public:
static property PDFPantoneColor^ PANTONE5445 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5445 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE545 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE545 Property
Gets the PANTONE 545 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE545 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE545
public static PDFPantoneColor PANTONE545 {get;}
public: __property static PDFPantoneColor* get_PANTONE545();
public:
static property PDFPantoneColor^ PANTONE545 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 545 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5455 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5455 Property
Gets the PANTONE 5455 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5455 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5455
public static PDFPantoneColor PANTONE5455 {get;}
public: __property static PDFPantoneColor* get_PANTONE5455();
public:
static property PDFPantoneColor^ PANTONE5455 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5455 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE546 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE546 Property
Gets the PANTONE 546 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE546 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE546
public static PDFPantoneColor PANTONE546 {get;}
public: __property static PDFPantoneColor* get_PANTONE546();
public:
static property PDFPantoneColor^ PANTONE546 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 546 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5463 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5463 Property
Gets the PANTONE 5463 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5463 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5463
public static PDFPantoneColor PANTONE5463 {get;}
public: __property static PDFPantoneColor* get_PANTONE5463();
public:
static property PDFPantoneColor^ PANTONE5463 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5463 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5467 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5467 Property
Gets the PANTONE 5467 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5467 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5467
public static PDFPantoneColor PANTONE5467 {get;}
public: __property static PDFPantoneColor* get_PANTONE5467();
public:
static property PDFPantoneColor^ PANTONE5467 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5467 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE547 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE547 Property
Gets the PANTONE 547 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE547 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE547
public static PDFPantoneColor PANTONE547 {get;}
public: __property static PDFPantoneColor* get_PANTONE547();
public:
static property PDFPantoneColor^ PANTONE547 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 547 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5473 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5473 Property
Gets the PANTONE 5473 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5473 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5473
public static PDFPantoneColor PANTONE5473 {get;}
public: __property static PDFPantoneColor* get_PANTONE5473();
public:
static property PDFPantoneColor^ PANTONE5473 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5473 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5477 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5477 Property
Gets the PANTONE 5477 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5477 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5477
public static PDFPantoneColor PANTONE5477 {get;}
public: __property static PDFPantoneColor* get_PANTONE5477();
public:
static property PDFPantoneColor^ PANTONE5477 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5477 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE548 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE548 Property
Gets the PANTONE 548 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE548 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE548
public static PDFPantoneColor PANTONE548 {get;}
public: __property static PDFPantoneColor* get_PANTONE548();
public:
static property PDFPantoneColor^ PANTONE548 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 548 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5483 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5483 Property
Gets the PANTONE 5483 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5483 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5483
public static PDFPantoneColor PANTONE5483 {get;}
public: __property static PDFPantoneColor* get_PANTONE5483();
public:
static property PDFPantoneColor^ PANTONE5483 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5483 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5487 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5487 Property
Gets the PANTONE 5487 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5487 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5487
public static PDFPantoneColor PANTONE5487 {get;}
public: __property static PDFPantoneColor* get_PANTONE5487();
public:
static property PDFPantoneColor^ PANTONE5487 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5487 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE549 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE549 Property
Gets the PANTONE 549 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE549 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE549
public static PDFPantoneColor PANTONE549 {get;}
public: __property static PDFPantoneColor* get_PANTONE549();
public:
static property PDFPantoneColor^ PANTONE549 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 549 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5493 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5493 Property
Gets the PANTONE 5493 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5493 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5493
public static PDFPantoneColor PANTONE5493 {get;}
public: __property static PDFPantoneColor* get_PANTONE5493();
public:
static property PDFPantoneColor^ PANTONE5493 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5493 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5497 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5497 Property
Gets the PANTONE 5497 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5497 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5497
public static PDFPantoneColor PANTONE5497 {get;}
public: __property static PDFPantoneColor* get_PANTONE5497();
public:
static property PDFPantoneColor^ PANTONE5497 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5497 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE550 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE550 Property
Gets the PANTONE 550 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE550 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE550
public static PDFPantoneColor PANTONE550 {get;}
public: __property static PDFPantoneColor* get_PANTONE550();
public:
static property PDFPantoneColor^ PANTONE550 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 550 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5503 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5503 Property
Gets the PANTONE 5503 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5503 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5503
public static PDFPantoneColor PANTONE5503 {get;}
public: __property static PDFPantoneColor* get_PANTONE5503();
public:
static property PDFPantoneColor^ PANTONE5503 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5503 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5507 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5507 Property
Gets the PANTONE 5507 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5507 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5507
public static PDFPantoneColor PANTONE5507 {get;}
public: __property static PDFPantoneColor* get_PANTONE5507();
public:
static property PDFPantoneColor^ PANTONE5507 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5507 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE551 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE551 Property
Gets the PANTONE 551 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE551 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE551
public static PDFPantoneColor PANTONE551 {get;}
public: __property static PDFPantoneColor* get_PANTONE551();
public:
static property PDFPantoneColor^ PANTONE551 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 551 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5513 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5513 Property
Gets the PANTONE 5513 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5513 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5513
public static PDFPantoneColor PANTONE5513 {get;}
public: __property static PDFPantoneColor* get_PANTONE5513();
public:
static property PDFPantoneColor^ PANTONE5513 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5513 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5517 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5517 Property
Gets the PANTONE 5517 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5517 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5517
public static PDFPantoneColor PANTONE5517 {get;}
public: __property static PDFPantoneColor* get_PANTONE5517();
public:
static property PDFPantoneColor^ PANTONE5517 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5517 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE552 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE552 Property
Gets the PANTONE 552 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE552 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE552
public static PDFPantoneColor PANTONE552 {get;}
public: __property static PDFPantoneColor* get_PANTONE552();
public:
static property PDFPantoneColor^ PANTONE552 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 552 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5523 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5523 Property
Gets the PANTONE 5523 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5523 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5523
public static PDFPantoneColor PANTONE5523 {get;}
public: __property static PDFPantoneColor* get_PANTONE5523();
public:
static property PDFPantoneColor^ PANTONE5523 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5523 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5527 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5527 Property
Gets the PANTONE 5527 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5527 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5527
public static PDFPantoneColor PANTONE5527 {get;}
public: __property static PDFPantoneColor* get_PANTONE5527();
public:
static property PDFPantoneColor^ PANTONE5527 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5527 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE553 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE553 Property
Gets the PANTONE 553 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE553 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE553
public static PDFPantoneColor PANTONE553 {get;}
public: __property static PDFPantoneColor* get_PANTONE553();
public:
static property PDFPantoneColor^ PANTONE553 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 553 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5535 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5535 Property
Gets the PANTONE 5535 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5535 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5535
public static PDFPantoneColor PANTONE5535 {get;}
public: __property static PDFPantoneColor* get_PANTONE5535();
public:
static property PDFPantoneColor^ PANTONE5535 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5535 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE554 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE554 Property
Gets the PANTONE 554 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE554 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE554
public static PDFPantoneColor PANTONE554 {get;}
public: __property static PDFPantoneColor* get_PANTONE554();
public:
static property PDFPantoneColor^ PANTONE554 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 554 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5545 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5545 Property
Gets the PANTONE 5545 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5545 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5545
public static PDFPantoneColor PANTONE5545 {get;}
public: __property static PDFPantoneColor* get_PANTONE5545();
public:
static property PDFPantoneColor^ PANTONE5545 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5545 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE555 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE555 Property
Gets the PANTONE 555 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE555 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE555
public static PDFPantoneColor PANTONE555 {get;}
public: __property static PDFPantoneColor* get_PANTONE555();
public:
static property PDFPantoneColor^ PANTONE555 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 555 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5555 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5555 Property
Gets the PANTONE 5555 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5555 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5555
public static PDFPantoneColor PANTONE5555 {get;}
public: __property static PDFPantoneColor* get_PANTONE5555();
public:
static property PDFPantoneColor^ PANTONE5555 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5555 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE556 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE556 Property
Gets the PANTONE 556 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE556 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE556
public static PDFPantoneColor PANTONE556 {get;}
public: __property static PDFPantoneColor* get_PANTONE556();
public:
static property PDFPantoneColor^ PANTONE556 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 556 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5565 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5565 Property
Gets the PANTONE 5565 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5565 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5565
public static PDFPantoneColor PANTONE5565 {get;}
public: __property static PDFPantoneColor* get_PANTONE5565();
public:
static property PDFPantoneColor^ PANTONE5565 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5565 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE557 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE557 Property
Gets the PANTONE 557 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE557 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE557
public static PDFPantoneColor PANTONE557 {get;}
public: __property static PDFPantoneColor* get_PANTONE557();
public:
static property PDFPantoneColor^ PANTONE557 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 557 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5575 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5575 Property
Gets the PANTONE 5575 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5575 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5575
public static PDFPantoneColor PANTONE5575 {get;}
public: __property static PDFPantoneColor* get_PANTONE5575();
public:
static property PDFPantoneColor^ PANTONE5575 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5575 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE558 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE558 Property
Gets the PANTONE 558 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE558 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE558
public static PDFPantoneColor PANTONE558 {get;}
public: __property static PDFPantoneColor* get_PANTONE558();
public:
static property PDFPantoneColor^ PANTONE558 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 558 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5585 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5585 Property
Gets the PANTONE 5585 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5585 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5585
public static PDFPantoneColor PANTONE5585 {get;}
public: __property static PDFPantoneColor* get_PANTONE5585();
public:
static property PDFPantoneColor^ PANTONE5585 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5585 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE559 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE559 Property
Gets the PANTONE 559 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE559 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE559
public static PDFPantoneColor PANTONE559 {get;}
public: __property static PDFPantoneColor* get_PANTONE559();
public:
static property PDFPantoneColor^ PANTONE559 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 559 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5595 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5595 Property
Gets the PANTONE 5595 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5595 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5595
public static PDFPantoneColor PANTONE5595 {get;}
public: __property static PDFPantoneColor* get_PANTONE5595();
public:
static property PDFPantoneColor^ PANTONE5595 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5595 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE560 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE560 Property
Gets the PANTONE 560 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE560 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE560
public static PDFPantoneColor PANTONE560 {get;}
public: __property static PDFPantoneColor* get_PANTONE560();
public:
static property PDFPantoneColor^ PANTONE560 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 560 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5605 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5605 Property
Gets the PANTONE 5605 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5605 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5605
public static PDFPantoneColor PANTONE5605 {get;}
public: __property static PDFPantoneColor* get_PANTONE5605();
public:
static property PDFPantoneColor^ PANTONE5605 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5605 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE561 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE561 Property
Gets the PANTONE 561 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE561 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE561
public static PDFPantoneColor PANTONE561 {get;}
public: __property static PDFPantoneColor* get_PANTONE561();
public:
static property PDFPantoneColor^ PANTONE561 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 561 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5615 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5615 Property
Gets the PANTONE 5615 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5615 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5615
public static PDFPantoneColor PANTONE5615 {get;}
public: __property static PDFPantoneColor* get_PANTONE5615();
public:
static property PDFPantoneColor^ PANTONE5615 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5615 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE562 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE562 Property
Gets the PANTONE 562 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE562 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE562
public static PDFPantoneColor PANTONE562 {get;}
public: __property static PDFPantoneColor* get_PANTONE562();
public:
static property PDFPantoneColor^ PANTONE562 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 562 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5625 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5625 Property
Gets the PANTONE 5625 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5625 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5625
public static PDFPantoneColor PANTONE5625 {get;}
public: __property static PDFPantoneColor* get_PANTONE5625();
public:
static property PDFPantoneColor^ PANTONE5625 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5625 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE563 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE563 Property
Gets the PANTONE 563 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE563 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE563
public static PDFPantoneColor PANTONE563 {get;}
public: __property static PDFPantoneColor* get_PANTONE563();
public:
static property PDFPantoneColor^ PANTONE563 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 563 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5635 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5635 Property
Gets the PANTONE 5635 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5635 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5635
public static PDFPantoneColor PANTONE5635 {get;}
public: __property static PDFPantoneColor* get_PANTONE5635();
public:
static property PDFPantoneColor^ PANTONE5635 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5635 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE564 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE564 Property
Gets the PANTONE 564 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE564 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE564
public static PDFPantoneColor PANTONE564 {get;}
public: __property static PDFPantoneColor* get_PANTONE564();
public:
static property PDFPantoneColor^ PANTONE564 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 564 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5645 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5645 Property
Gets the PANTONE 5645 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5645 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5645
public static PDFPantoneColor PANTONE5645 {get;}
public: __property static PDFPantoneColor* get_PANTONE5645();
public:
static property PDFPantoneColor^ PANTONE5645 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5645 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE565 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE565 Property
Gets the PANTONE 565 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE565 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE565
public static PDFPantoneColor PANTONE565 {get;}
public: __property static PDFPantoneColor* get_PANTONE565();
public:
static property PDFPantoneColor^ PANTONE565 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 565 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5655 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5655 Property
Gets the PANTONE 5655 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5655 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5655
public static PDFPantoneColor PANTONE5655 {get;}
public: __property static PDFPantoneColor* get_PANTONE5655();
public:
static property PDFPantoneColor^ PANTONE5655 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5655 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE566 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE566 Property
Gets the PANTONE 566 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE566 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE566
public static PDFPantoneColor PANTONE566 {get;}
public: __property static PDFPantoneColor* get_PANTONE566();
public:
static property PDFPantoneColor^ PANTONE566 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 566 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5665 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5665 Property
Gets the PANTONE 5665 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5665 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5665
public static PDFPantoneColor PANTONE5665 {get;}
public: __property static PDFPantoneColor* get_PANTONE5665();
public:
static property PDFPantoneColor^ PANTONE5665 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5665 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE567 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE567 Property
Gets the PANTONE 567 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE567 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE567
public static PDFPantoneColor PANTONE567 {get;}
public: __property static PDFPantoneColor* get_PANTONE567();
public:
static property PDFPantoneColor^ PANTONE567 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 567 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE568 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE568 Property
Gets the PANTONE 568 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE568 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE568
public static PDFPantoneColor PANTONE568 {get;}
public: __property static PDFPantoneColor* get_PANTONE568();
public:
static property PDFPantoneColor^ PANTONE568 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 568 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE569 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE569 Property
Gets the PANTONE 569 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE569 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE569
public static PDFPantoneColor PANTONE569 {get;}
public: __property static PDFPantoneColor* get_PANTONE569();
public:
static property PDFPantoneColor^ PANTONE569 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 569 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE570 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE570 Property
Gets the PANTONE 570 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE570 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE570
public static PDFPantoneColor PANTONE570 {get;}
public: __property static PDFPantoneColor* get_PANTONE570();
public:
static property PDFPantoneColor^ PANTONE570 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 570 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE571 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE571 Property
Gets the PANTONE 571 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE571 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE571
public static PDFPantoneColor PANTONE571 {get;}
public: __property static PDFPantoneColor* get_PANTONE571();
public:
static property PDFPantoneColor^ PANTONE571 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 571 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE572 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE572 Property
Gets the PANTONE 572 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE572 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE572
public static PDFPantoneColor PANTONE572 {get;}
public: __property static PDFPantoneColor* get_PANTONE572();
public:
static property PDFPantoneColor^ PANTONE572 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 572 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE573 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE573 Property
Gets the PANTONE 573 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE573 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE573
public static PDFPantoneColor PANTONE573 {get;}
public: __property static PDFPantoneColor* get_PANTONE573();
public:
static property PDFPantoneColor^ PANTONE573 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 573 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE574 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE574 Property
Gets the PANTONE 574 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE574 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE574
public static PDFPantoneColor PANTONE574 {get;}
public: __property static PDFPantoneColor* get_PANTONE574();
public:
static property PDFPantoneColor^ PANTONE574 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 574 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5743 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5743 Property
Gets the PANTONE 5743 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5743 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5743
public static PDFPantoneColor PANTONE5743 {get;}
public: __property static PDFPantoneColor* get_PANTONE5743();
public:
static property PDFPantoneColor^ PANTONE5743 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5743 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5747 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5747 Property
Gets the PANTONE 5747 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5747 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5747
public static PDFPantoneColor PANTONE5747 {get;}
public: __property static PDFPantoneColor* get_PANTONE5747();
public:
static property PDFPantoneColor^ PANTONE5747 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5747 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE575 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE575 Property
Gets the PANTONE 575 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE575 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE575
public static PDFPantoneColor PANTONE575 {get;}
public: __property static PDFPantoneColor* get_PANTONE575();
public:
static property PDFPantoneColor^ PANTONE575 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 575 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5753 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5753 Property
Gets the PANTONE 5753 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5753 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5753
public static PDFPantoneColor PANTONE5753 {get;}
public: __property static PDFPantoneColor* get_PANTONE5753();
public:
static property PDFPantoneColor^ PANTONE5753 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5753 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5757 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5757 Property
Gets the PANTONE 5757 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5757 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5757
public static PDFPantoneColor PANTONE5757 {get;}
public: __property static PDFPantoneColor* get_PANTONE5757();
public:
static property PDFPantoneColor^ PANTONE5757 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5757 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE576 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE576 Property
Gets the PANTONE 576 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE576 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE576
public static PDFPantoneColor PANTONE576 {get;}
public: __property static PDFPantoneColor* get_PANTONE576();
public:
static property PDFPantoneColor^ PANTONE576 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 576 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5763 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5763 Property
Gets the PANTONE 5763 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5763 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5763
public static PDFPantoneColor PANTONE5763 {get;}
public: __property static PDFPantoneColor* get_PANTONE5763();
public:
static property PDFPantoneColor^ PANTONE5763 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5763 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5767 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5767 Property
Gets the PANTONE 5767 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5767 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5767
public static PDFPantoneColor PANTONE5767 {get;}
public: __property static PDFPantoneColor* get_PANTONE5767();
public:
static property PDFPantoneColor^ PANTONE5767 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5767 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE577 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE577 Property
Gets the PANTONE 577 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE577 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE577
public static PDFPantoneColor PANTONE577 {get;}
public: __property static PDFPantoneColor* get_PANTONE577();
public:
static property PDFPantoneColor^ PANTONE577 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 577 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5773 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5773 Property
Gets the PANTONE 5773 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5773 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5773
public static PDFPantoneColor PANTONE5773 {get;}
public: __property static PDFPantoneColor* get_PANTONE5773();
public:
static property PDFPantoneColor^ PANTONE5773 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5773 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5777 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5777 Property
Gets the PANTONE 5777 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5777 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5777
public static PDFPantoneColor PANTONE5777 {get;}
public: __property static PDFPantoneColor* get_PANTONE5777();
public:
static property PDFPantoneColor^ PANTONE5777 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5777 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE578 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE578 Property
Gets the PANTONE 578 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE578 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE578
public static PDFPantoneColor PANTONE578 {get;}
public: __property static PDFPantoneColor* get_PANTONE578();
public:
static property PDFPantoneColor^ PANTONE578 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 578 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5783 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5783 Property
Gets the PANTONE 5783 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5783 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5783
public static PDFPantoneColor PANTONE5783 {get;}
public: __property static PDFPantoneColor* get_PANTONE5783();
public:
static property PDFPantoneColor^ PANTONE5783 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5783 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5787 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5787 Property
Gets the PANTONE 5787 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5787 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5787
public static PDFPantoneColor PANTONE5787 {get;}
public: __property static PDFPantoneColor* get_PANTONE5787();
public:
static property PDFPantoneColor^ PANTONE5787 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5787 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE579 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE579 Property
Gets the PANTONE 579 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE579 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE579
public static PDFPantoneColor PANTONE579 {get;}
public: __property static PDFPantoneColor* get_PANTONE579();
public:
static property PDFPantoneColor^ PANTONE579 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 579 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5793 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5793 Property
Gets the PANTONE 5793 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5793 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5793
public static PDFPantoneColor PANTONE5793 {get;}
public: __property static PDFPantoneColor* get_PANTONE5793();
public:
static property PDFPantoneColor^ PANTONE5793 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5793 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5797 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5797 Property
Gets the PANTONE 5797 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5797 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5797
public static PDFPantoneColor PANTONE5797 {get;}
public: __property static PDFPantoneColor* get_PANTONE5797();
public:
static property PDFPantoneColor^ PANTONE5797 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5797 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE580 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE580 Property
Gets the PANTONE 580 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE580 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE580
public static PDFPantoneColor PANTONE580 {get;}
public: __property static PDFPantoneColor* get_PANTONE580();
public:
static property PDFPantoneColor^ PANTONE580 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 580 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5803 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5803 Property
Gets the PANTONE 5803 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5803 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5803
public static PDFPantoneColor PANTONE5803 {get;}
public: __property static PDFPantoneColor* get_PANTONE5803();
public:
static property PDFPantoneColor^ PANTONE5803 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5803 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5807 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5807 Property
Gets the PANTONE 5807 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5807 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5807
public static PDFPantoneColor PANTONE5807 {get;}
public: __property static PDFPantoneColor* get_PANTONE5807();
public:
static property PDFPantoneColor^ PANTONE5807 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5807 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE581 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE581 Property
Gets the PANTONE 581 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE581 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE581
public static PDFPantoneColor PANTONE581 {get;}
public: __property static PDFPantoneColor* get_PANTONE581();
public:
static property PDFPantoneColor^ PANTONE581 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 581 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5815 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5815 Property
Gets the PANTONE 5815 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5815 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5815
public static PDFPantoneColor PANTONE5815 {get;}
public: __property static PDFPantoneColor* get_PANTONE5815();
public:
static property PDFPantoneColor^ PANTONE5815 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5815 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE582 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE582 Property
Gets the PANTONE 582 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE582 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE582
public static PDFPantoneColor PANTONE582 {get;}
public: __property static PDFPantoneColor* get_PANTONE582();
public:
static property PDFPantoneColor^ PANTONE582 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 582 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5825 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5825 Property
Gets the PANTONE 5825 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5825 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5825
public static PDFPantoneColor PANTONE5825 {get;}
public: __property static PDFPantoneColor* get_PANTONE5825();
public:
static property PDFPantoneColor^ PANTONE5825 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5825 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE583 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE583 Property
Gets the PANTONE 583 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE583 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE583
public static PDFPantoneColor PANTONE583 {get;}
public: __property static PDFPantoneColor* get_PANTONE583();
public:
static property PDFPantoneColor^ PANTONE583 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 583 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5835 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5835 Property
Gets the PANTONE 5835 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5835 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5835
public static PDFPantoneColor PANTONE5835 {get;}
public: __property static PDFPantoneColor* get_PANTONE5835();
public:
static property PDFPantoneColor^ PANTONE5835 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5835 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE584 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE584 Property
Gets the PANTONE 584 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE584 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE584
public static PDFPantoneColor PANTONE584 {get;}
public: __property static PDFPantoneColor* get_PANTONE584();
public:
static property PDFPantoneColor^ PANTONE584 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 584 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5845 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5845 Property
Gets the PANTONE 5845 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5845 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5845
public static PDFPantoneColor PANTONE5845 {get;}
public: __property static PDFPantoneColor* get_PANTONE5845();
public:
static property PDFPantoneColor^ PANTONE5845 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5845 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE585 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE585 Property
Gets the PANTONE 585 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE585 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE585
public static PDFPantoneColor PANTONE585 {get;}
public: __property static PDFPantoneColor* get_PANTONE585();
public:
static property PDFPantoneColor^ PANTONE585 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 585 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5855 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5855 Property
Gets the PANTONE 5855 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5855 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5855
public static PDFPantoneColor PANTONE5855 {get;}
public: __property static PDFPantoneColor* get_PANTONE5855();
public:
static property PDFPantoneColor^ PANTONE5855 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5855 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE586 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE586 Property
Gets the PANTONE 586 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE586 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE586
public static PDFPantoneColor PANTONE586 {get;}
public: __property static PDFPantoneColor* get_PANTONE586();
public:
static property PDFPantoneColor^ PANTONE586 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 586 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5865 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5865 Property
Gets the PANTONE 5865 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5865 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5865
public static PDFPantoneColor PANTONE5865 {get;}
public: __property static PDFPantoneColor* get_PANTONE5865();
public:
static property PDFPantoneColor^ PANTONE5865 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5865 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE587 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE587 Property
Gets the PANTONE 587 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE587 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE587
public static PDFPantoneColor PANTONE587 {get;}
public: __property static PDFPantoneColor* get_PANTONE587();
public:
static property PDFPantoneColor^ PANTONE587 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 587 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5875 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5875 Property
Gets the PANTONE 5875 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5875 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5875
public static PDFPantoneColor PANTONE5875 {get;}
public: __property static PDFPantoneColor* get_PANTONE5875();
public:
static property PDFPantoneColor^ PANTONE5875 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 5875 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE600 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE600 Property
Gets the PANTONE 600 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE600 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE600
public static PDFPantoneColor PANTONE600 {get;}
public: __property static PDFPantoneColor* get_PANTONE600();
public:
static property PDFPantoneColor^ PANTONE600 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 600 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE601 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE601 Property
Gets the PANTONE 601 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE601 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE601
public static PDFPantoneColor PANTONE601 {get;}
public: __property static PDFPantoneColor* get_PANTONE601();
public:
static property PDFPantoneColor^ PANTONE601 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 601 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE602 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE602 Property
Gets the PANTONE 602 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE602 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE602
public static PDFPantoneColor PANTONE602 {get;}
public: __property static PDFPantoneColor* get_PANTONE602();
public:
static property PDFPantoneColor^ PANTONE602 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 602 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE603 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE603 Property
Gets the PANTONE 603 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE603 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE603
public static PDFPantoneColor PANTONE603 {get;}
public: __property static PDFPantoneColor* get_PANTONE603();
public:
static property PDFPantoneColor^ PANTONE603 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 603 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE604 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE604 Property
Gets the PANTONE 604 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE604 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE604
public static PDFPantoneColor PANTONE604 {get;}
public: __property static PDFPantoneColor* get_PANTONE604();
public:
static property PDFPantoneColor^ PANTONE604 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 604 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE605 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE605 Property
Gets the PANTONE 605 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE605 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE605
public static PDFPantoneColor PANTONE605 {get;}
public: __property static PDFPantoneColor* get_PANTONE605();
public:
static property PDFPantoneColor^ PANTONE605 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 605 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE606 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE606 Property
Gets the PANTONE 606 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE606 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE606
public static PDFPantoneColor PANTONE606 {get;}
public: __property static PDFPantoneColor* get_PANTONE606();
public:
static property PDFPantoneColor^ PANTONE606 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 606 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE607 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE607 Property
Gets the PANTONE 607 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE607 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE607
public static PDFPantoneColor PANTONE607 {get;}
public: __property static PDFPantoneColor* get_PANTONE607();
public:
static property PDFPantoneColor^ PANTONE607 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 607 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE608 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE608 Property
Gets the PANTONE 608 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE608 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE608
public static PDFPantoneColor PANTONE608 {get;}
public: __property static PDFPantoneColor* get_PANTONE608();
public:
static property PDFPantoneColor^ PANTONE608 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 608 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE609 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE609 Property
Gets the PANTONE 609 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE609 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE609
public static PDFPantoneColor PANTONE609 {get;}
public: __property static PDFPantoneColor* get_PANTONE609();
public:
static property PDFPantoneColor^ PANTONE609 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 609 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE610 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE610 Property
Gets the PANTONE 610 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE610 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE610
public static PDFPantoneColor PANTONE610 {get;}
public: __property static PDFPantoneColor* get_PANTONE610();
public:
static property PDFPantoneColor^ PANTONE610 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 610 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE611 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE611 Property
Gets the PANTONE 611 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE611 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE611
public static PDFPantoneColor PANTONE611 {get;}
public: __property static PDFPantoneColor* get_PANTONE611();
public:
static property PDFPantoneColor^ PANTONE611 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 611 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE612 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE612 Property
Gets the PANTONE 612 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE612 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE612
public static PDFPantoneColor PANTONE612 {get;}
public: __property static PDFPantoneColor* get_PANTONE612();
public:
static property PDFPantoneColor^ PANTONE612 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 612 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE613 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE613 Property
Gets the PANTONE 613 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE613 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE613
public static PDFPantoneColor PANTONE613 {get;}
public: __property static PDFPantoneColor* get_PANTONE613();
public:
static property PDFPantoneColor^ PANTONE613 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 613 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE614 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE614 Property
Gets the PANTONE 614 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE614 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE614
public static PDFPantoneColor PANTONE614 {get;}
public: __property static PDFPantoneColor* get_PANTONE614();
public:
static property PDFPantoneColor^ PANTONE614 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 614 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE615 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE615 Property
Gets the PANTONE 615 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE615 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE615
public static PDFPantoneColor PANTONE615 {get;}
public: __property static PDFPantoneColor* get_PANTONE615();
public:
static property PDFPantoneColor^ PANTONE615 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 615 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE616 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE616 Property
Gets the PANTONE 616 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE616 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE616
public static PDFPantoneColor PANTONE616 {get;}
public: __property static PDFPantoneColor* get_PANTONE616();
public:
static property PDFPantoneColor^ PANTONE616 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 616 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE617 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE617 Property
Gets the PANTONE 617 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE617 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE617
public static PDFPantoneColor PANTONE617 {get;}
public: __property static PDFPantoneColor* get_PANTONE617();
public:
static property PDFPantoneColor^ PANTONE617 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 617 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE618 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE618 Property
Gets the PANTONE 618 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE618 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE618
public static PDFPantoneColor PANTONE618 {get;}
public: __property static PDFPantoneColor* get_PANTONE618();
public:
static property PDFPantoneColor^ PANTONE618 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 618 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE619 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE619 Property
Gets the PANTONE 619 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE619 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE619
public static PDFPantoneColor PANTONE619 {get;}
public: __property static PDFPantoneColor* get_PANTONE619();
public:
static property PDFPantoneColor^ PANTONE619 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 619 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE620 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE620 Property
Gets the PANTONE 620 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE620 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE620
public static PDFPantoneColor PANTONE620 {get;}
public: __property static PDFPantoneColor* get_PANTONE620();
public:
static property PDFPantoneColor^ PANTONE620 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 620 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE621 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE621 Property
Gets the PANTONE 621 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE621 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE621
public static PDFPantoneColor PANTONE621 {get;}
public: __property static PDFPantoneColor* get_PANTONE621();
public:
static property PDFPantoneColor^ PANTONE621 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 621 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE622 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE622 Property
Gets the PANTONE 622 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE622 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE622
public static PDFPantoneColor PANTONE622 {get;}
public: __property static PDFPantoneColor* get_PANTONE622();
public:
static property PDFPantoneColor^ PANTONE622 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 622 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE623 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE623 Property
Gets the PANTONE 623 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE623 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE623
public static PDFPantoneColor PANTONE623 {get;}
public: __property static PDFPantoneColor* get_PANTONE623();
public:
static property PDFPantoneColor^ PANTONE623 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 623 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE624 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE624 Property
Gets the PANTONE 624 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE624 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE624
public static PDFPantoneColor PANTONE624 {get;}
public: __property static PDFPantoneColor* get_PANTONE624();
public:
static property PDFPantoneColor^ PANTONE624 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 624 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE625 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE625 Property
Gets the PANTONE 625 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE625 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE625
public static PDFPantoneColor PANTONE625 {get;}
public: __property static PDFPantoneColor* get_PANTONE625();
public:
static property PDFPantoneColor^ PANTONE625 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 625 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE626 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE626 Property
Gets the PANTONE 626 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE626 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE626
public static PDFPantoneColor PANTONE626 {get;}
public: __property static PDFPantoneColor* get_PANTONE626();
public:
static property PDFPantoneColor^ PANTONE626 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 626 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE627 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE627 Property
Gets the PANTONE 627 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE627 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE627
public static PDFPantoneColor PANTONE627 {get;}
public: __property static PDFPantoneColor* get_PANTONE627();
public:
static property PDFPantoneColor^ PANTONE627 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 627 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE628 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE628 Property
Gets the PANTONE 628 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE628 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE628
public static PDFPantoneColor PANTONE628 {get;}
public: __property static PDFPantoneColor* get_PANTONE628();
public:
static property PDFPantoneColor^ PANTONE628 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 628 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE629 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE629 Property
Gets the PANTONE 629 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE629 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE629
public static PDFPantoneColor PANTONE629 {get;}
public: __property static PDFPantoneColor* get_PANTONE629();
public:
static property PDFPantoneColor^ PANTONE629 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 629 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE630 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE630 Property
Gets the PANTONE 630 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE630 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE630
public static PDFPantoneColor PANTONE630 {get;}
public: __property static PDFPantoneColor* get_PANTONE630();
public:
static property PDFPantoneColor^ PANTONE630 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 630 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE631 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE631 Property
Gets the PANTONE 631 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE631 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE631
public static PDFPantoneColor PANTONE631 {get;}
public: __property static PDFPantoneColor* get_PANTONE631();
public:
static property PDFPantoneColor^ PANTONE631 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 631 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE632 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE632 Property
Gets the PANTONE 632 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE632 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE632
public static PDFPantoneColor PANTONE632 {get;}
public: __property static PDFPantoneColor* get_PANTONE632();
public:
static property PDFPantoneColor^ PANTONE632 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 632 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE633 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE633 Property
Gets the PANTONE 633 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE633 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE633
public static PDFPantoneColor PANTONE633 {get;}
public: __property static PDFPantoneColor* get_PANTONE633();
public:
static property PDFPantoneColor^ PANTONE633 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 633 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE634 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE634 Property
Gets the PANTONE 634 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE634 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE634
public static PDFPantoneColor PANTONE634 {get;}
public: __property static PDFPantoneColor* get_PANTONE634();
public:
static property PDFPantoneColor^ PANTONE634 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 634 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE635 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE635 Property
Gets the PANTONE 635 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE635 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE635
public static PDFPantoneColor PANTONE635 {get;}
public: __property static PDFPantoneColor* get_PANTONE635();
public:
static property PDFPantoneColor^ PANTONE635 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 635 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE636 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE636 Property
Gets the PANTONE 636 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE636 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE636
public static PDFPantoneColor PANTONE636 {get;}
public: __property static PDFPantoneColor* get_PANTONE636();
public:
static property PDFPantoneColor^ PANTONE636 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 636 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE637 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE637 Property
Gets the PANTONE 637 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE637 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE637
public static PDFPantoneColor PANTONE637 {get;}
public: __property static PDFPantoneColor* get_PANTONE637();
public:
static property PDFPantoneColor^ PANTONE637 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 637 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE638 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE638 Property
Gets the PANTONE 638 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE638 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE638
public static PDFPantoneColor PANTONE638 {get;}
public: __property static PDFPantoneColor* get_PANTONE638();
public:
static property PDFPantoneColor^ PANTONE638 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 638 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE639 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE639 Property
Gets the PANTONE 639 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE639 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE639
public static PDFPantoneColor PANTONE639 {get;}
public: __property static PDFPantoneColor* get_PANTONE639();
public:
static property PDFPantoneColor^ PANTONE639 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 639 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE640 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE640 Property
Gets the PANTONE 640 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE640 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE640
public static PDFPantoneColor PANTONE640 {get;}
public: __property static PDFPantoneColor* get_PANTONE640();
public:
static property PDFPantoneColor^ PANTONE640 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 640 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE641 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE641 Property
Gets the PANTONE 641 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE641 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE641
public static PDFPantoneColor PANTONE641 {get;}
public: __property static PDFPantoneColor* get_PANTONE641();
public:
static property PDFPantoneColor^ PANTONE641 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 641 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE642 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE642 Property
Gets the PANTONE 642 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE642 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE642
public static PDFPantoneColor PANTONE642 {get;}
public: __property static PDFPantoneColor* get_PANTONE642();
public:
static property PDFPantoneColor^ PANTONE642 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 642 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE643 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE643 Property
Gets the PANTONE 643 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE643 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE643
public static PDFPantoneColor PANTONE643 {get;}
public: __property static PDFPantoneColor* get_PANTONE643();
public:
static property PDFPantoneColor^ PANTONE643 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 643 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE644 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE644 Property
Gets the PANTONE 644 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE644 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE644
public static PDFPantoneColor PANTONE644 {get;}
public: __property static PDFPantoneColor* get_PANTONE644();
public:
static property PDFPantoneColor^ PANTONE644 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 644 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE645 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE645 Property
Gets the PANTONE 645 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE645 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE645
public static PDFPantoneColor PANTONE645 {get;}
public: __property static PDFPantoneColor* get_PANTONE645();
public:
static property PDFPantoneColor^ PANTONE645 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 645 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE646 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE646 Property
Gets the PANTONE 646 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE646 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE646
public static PDFPantoneColor PANTONE646 {get;}
public: __property static PDFPantoneColor* get_PANTONE646();
public:
static property PDFPantoneColor^ PANTONE646 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 646 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE647 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE647 Property
Gets the PANTONE 647 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE647 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE647
public static PDFPantoneColor PANTONE647 {get;}
public: __property static PDFPantoneColor* get_PANTONE647();
public:
static property PDFPantoneColor^ PANTONE647 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 647 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE648 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE648 Property
Gets the PANTONE 648 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE648 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE648
public static PDFPantoneColor PANTONE648 {get;}
public: __property static PDFPantoneColor* get_PANTONE648();
public:
static property PDFPantoneColor^ PANTONE648 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 648 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE649 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE649 Property
Gets the PANTONE 649 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE649 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE649
public static PDFPantoneColor PANTONE649 {get;}
public: __property static PDFPantoneColor* get_PANTONE649();
public:
static property PDFPantoneColor^ PANTONE649 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 649 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE650 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE650 Property
Gets the PANTONE 650 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE650 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE650
public static PDFPantoneColor PANTONE650 {get;}
public: __property static PDFPantoneColor* get_PANTONE650();
public:
static property PDFPantoneColor^ PANTONE650 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 650 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE651 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE651 Property
Gets the PANTONE 651 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE651 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE651
public static PDFPantoneColor PANTONE651 {get;}
public: __property static PDFPantoneColor* get_PANTONE651();
public:
static property PDFPantoneColor^ PANTONE651 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 651 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE652 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE652 Property
Gets the PANTONE 652 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE652 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE652
public static PDFPantoneColor PANTONE652 {get;}
public: __property static PDFPantoneColor* get_PANTONE652();
public:
static property PDFPantoneColor^ PANTONE652 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 652 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE653 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE653 Property
Gets the PANTONE 653 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE653 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE653
public static PDFPantoneColor PANTONE653 {get;}
public: __property static PDFPantoneColor* get_PANTONE653();
public:
static property PDFPantoneColor^ PANTONE653 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 653 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE654 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE654 Property
Gets the PANTONE 654 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE654 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE654
public static PDFPantoneColor PANTONE654 {get;}
public: __property static PDFPantoneColor* get_PANTONE654();
public:
static property PDFPantoneColor^ PANTONE654 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 654 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE655 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE655 Property
Gets the PANTONE 655 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE655 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE655
public static PDFPantoneColor PANTONE655 {get;}
public: __property static PDFPantoneColor* get_PANTONE655();
public:
static property PDFPantoneColor^ PANTONE655 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 655 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE656 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE656 Property
Gets the PANTONE 656 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE656 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE656
public static PDFPantoneColor PANTONE656 {get;}
public: __property static PDFPantoneColor* get_PANTONE656();
public:
static property PDFPantoneColor^ PANTONE656 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 656 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE657 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE657 Property
Gets the PANTONE 657 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE657 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE657
public static PDFPantoneColor PANTONE657 {get;}
public: __property static PDFPantoneColor* get_PANTONE657();
public:
static property PDFPantoneColor^ PANTONE657 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 657 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE658 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE658 Property
Gets the PANTONE 658 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE658 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE658
public static PDFPantoneColor PANTONE658 {get;}
public: __property static PDFPantoneColor* get_PANTONE658();
public:
static property PDFPantoneColor^ PANTONE658 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 658 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE659 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE659 Property
Gets the PANTONE 659 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE659 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE659
public static PDFPantoneColor PANTONE659 {get;}
public: __property static PDFPantoneColor* get_PANTONE659();
public:
static property PDFPantoneColor^ PANTONE659 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 659 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE660 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE660 Property
Gets the PANTONE 660 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE660 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE660
public static PDFPantoneColor PANTONE660 {get;}
public: __property static PDFPantoneColor* get_PANTONE660();
public:
static property PDFPantoneColor^ PANTONE660 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 660 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE661 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE661 Property
Gets the PANTONE 661 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE661 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE661
public static PDFPantoneColor PANTONE661 {get;}
public: __property static PDFPantoneColor* get_PANTONE661();
public:
static property PDFPantoneColor^ PANTONE661 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 661 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE662 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE662 Property
Gets the PANTONE 662 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE662 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE662
public static PDFPantoneColor PANTONE662 {get;}
public: __property static PDFPantoneColor* get_PANTONE662();
public:
static property PDFPantoneColor^ PANTONE662 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 662 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE663 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE663 Property
Gets the PANTONE 663 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE663 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE663
public static PDFPantoneColor PANTONE663 {get;}
public: __property static PDFPantoneColor* get_PANTONE663();
public:
static property PDFPantoneColor^ PANTONE663 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 663 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE664 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE664 Property
Gets the PANTONE 664 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE664 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE664
public static PDFPantoneColor PANTONE664 {get;}
public: __property static PDFPantoneColor* get_PANTONE664();
public:
static property PDFPantoneColor^ PANTONE664 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 664 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE665 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE665 Property
Gets the PANTONE 665 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE665 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE665
public static PDFPantoneColor PANTONE665 {get;}
public: __property static PDFPantoneColor* get_PANTONE665();
public:
static property PDFPantoneColor^ PANTONE665 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 665 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE666 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE666 Property
Gets the PANTONE 666 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE666 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE666
public static PDFPantoneColor PANTONE666 {get;}
public: __property static PDFPantoneColor* get_PANTONE666();
public:
static property PDFPantoneColor^ PANTONE666 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 666 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE667 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE667 Property
Gets the PANTONE 667 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE667 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE667
public static PDFPantoneColor PANTONE667 {get;}
public: __property static PDFPantoneColor* get_PANTONE667();
public:
static property PDFPantoneColor^ PANTONE667 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 667 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE668 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE668 Property
Gets the PANTONE 668 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE668 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE668
public static PDFPantoneColor PANTONE668 {get;}
public: __property static PDFPantoneColor* get_PANTONE668();
public:
static property PDFPantoneColor^ PANTONE668 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 668 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE669 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE669 Property
Gets the PANTONE 669 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE669 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE669
public static PDFPantoneColor PANTONE669 {get;}
public: __property static PDFPantoneColor* get_PANTONE669();
public:
static property PDFPantoneColor^ PANTONE669 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 669 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE670 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE670 Property
Gets the PANTONE 670 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE670 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE670
public static PDFPantoneColor PANTONE670 {get;}
public: __property static PDFPantoneColor* get_PANTONE670();
public:
static property PDFPantoneColor^ PANTONE670 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 670 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE671 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE671 Property
Gets the PANTONE 671 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE671 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE671
public static PDFPantoneColor PANTONE671 {get;}
public: __property static PDFPantoneColor* get_PANTONE671();
public:
static property PDFPantoneColor^ PANTONE671 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 671 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE672 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE672 Property
Gets the PANTONE 672 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE672 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE672
public static PDFPantoneColor PANTONE672 {get;}
public: __property static PDFPantoneColor* get_PANTONE672();
public:
static property PDFPantoneColor^ PANTONE672 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 672 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE673 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE673 Property
Gets the PANTONE 673 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE673 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE673
public static PDFPantoneColor PANTONE673 {get;}
public: __property static PDFPantoneColor* get_PANTONE673();
public:
static property PDFPantoneColor^ PANTONE673 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 673 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE674 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE674 Property
Gets the PANTONE 674 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE674 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE674
public static PDFPantoneColor PANTONE674 {get;}
public: __property static PDFPantoneColor* get_PANTONE674();
public:
static property PDFPantoneColor^ PANTONE674 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 674 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE675 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE675 Property
Gets the PANTONE 675 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE675 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE675
public static PDFPantoneColor PANTONE675 {get;}
public: __property static PDFPantoneColor* get_PANTONE675();
public:
static property PDFPantoneColor^ PANTONE675 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 675 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE676 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE676 Property
Gets the PANTONE 676 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE676 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE676
public static PDFPantoneColor PANTONE676 {get;}
public: __property static PDFPantoneColor* get_PANTONE676();
public:
static property PDFPantoneColor^ PANTONE676 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 676 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE677 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE677 Property
Gets the PANTONE 677 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE677 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE677
public static PDFPantoneColor PANTONE677 {get;}
public: __property static PDFPantoneColor* get_PANTONE677();
public:
static property PDFPantoneColor^ PANTONE677 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 677 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE678 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE678 Property
Gets the PANTONE 678 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE678 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE678
public static PDFPantoneColor PANTONE678 {get;}
public: __property static PDFPantoneColor* get_PANTONE678();
public:
static property PDFPantoneColor^ PANTONE678 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 678 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE679 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE679 Property
Gets the PANTONE 679 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE679 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE679
public static PDFPantoneColor PANTONE679 {get;}
public: __property static PDFPantoneColor* get_PANTONE679();
public:
static property PDFPantoneColor^ PANTONE679 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 679 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE680 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE680 Property
Gets the PANTONE 680 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE680 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE680
public static PDFPantoneColor PANTONE680 {get;}
public: __property static PDFPantoneColor* get_PANTONE680();
public:
static property PDFPantoneColor^ PANTONE680 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 680 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE681 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE681 Property
Gets the PANTONE 681 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE681 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE681
public static PDFPantoneColor PANTONE681 {get;}
public: __property static PDFPantoneColor* get_PANTONE681();
public:
static property PDFPantoneColor^ PANTONE681 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 681 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE682 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE682 Property
Gets the PANTONE 682 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE682 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE682
public static PDFPantoneColor PANTONE682 {get;}
public: __property static PDFPantoneColor* get_PANTONE682();
public:
static property PDFPantoneColor^ PANTONE682 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 682 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE683 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE683 Property
Gets the PANTONE 683 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE683 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE683
public static PDFPantoneColor PANTONE683 {get;}
public: __property static PDFPantoneColor* get_PANTONE683();
public:
static property PDFPantoneColor^ PANTONE683 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 683 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE684 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE684 Property
Gets the PANTONE 684 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE684 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE684
public static PDFPantoneColor PANTONE684 {get;}
public: __property static PDFPantoneColor* get_PANTONE684();
public:
static property PDFPantoneColor^ PANTONE684 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 684 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE685 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE685 Property
Gets the PANTONE 685 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE685 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE685
public static PDFPantoneColor PANTONE685 {get;}
public: __property static PDFPantoneColor* get_PANTONE685();
public:
static property PDFPantoneColor^ PANTONE685 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 685 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE686 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE686 Property
Gets the PANTONE 686 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE686 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE686
public static PDFPantoneColor PANTONE686 {get;}
public: __property static PDFPantoneColor* get_PANTONE686();
public:
static property PDFPantoneColor^ PANTONE686 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 686 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE687 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE687 Property
Gets the PANTONE 687 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE687 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE687
public static PDFPantoneColor PANTONE687 {get;}
public: __property static PDFPantoneColor* get_PANTONE687();
public:
static property PDFPantoneColor^ PANTONE687 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 687 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE688 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE688 Property
Gets the PANTONE 688 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE688 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE688
public static PDFPantoneColor PANTONE688 {get;}
public: __property static PDFPantoneColor* get_PANTONE688();
public:
static property PDFPantoneColor^ PANTONE688 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 688 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE689 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE689 Property
Gets the PANTONE 689 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE689 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE689
public static PDFPantoneColor PANTONE689 {get;}
public: __property static PDFPantoneColor* get_PANTONE689();
public:
static property PDFPantoneColor^ PANTONE689 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 689 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE690 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE690 Property
Gets the PANTONE 690 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE690 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE690
public static PDFPantoneColor PANTONE690 {get;}
public: __property static PDFPantoneColor* get_PANTONE690();
public:
static property PDFPantoneColor^ PANTONE690 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 690 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE691 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE691 Property
Gets the PANTONE 691 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE691 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE691
public static PDFPantoneColor PANTONE691 {get;}
public: __property static PDFPantoneColor* get_PANTONE691();
public:
static property PDFPantoneColor^ PANTONE691 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 691 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE692 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE692 Property
Gets the PANTONE 692 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE692 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE692
public static PDFPantoneColor PANTONE692 {get;}
public: __property static PDFPantoneColor* get_PANTONE692();
public:
static property PDFPantoneColor^ PANTONE692 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 692 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE693 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE693 Property
Gets the PANTONE 693 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE693 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE693
public static PDFPantoneColor PANTONE693 {get;}
public: __property static PDFPantoneColor* get_PANTONE693();
public:
static property PDFPantoneColor^ PANTONE693 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 693 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE694 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE694 Property
Gets the PANTONE 694 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE694 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE694
public static PDFPantoneColor PANTONE694 {get;}
public: __property static PDFPantoneColor* get_PANTONE694();
public:
static property PDFPantoneColor^ PANTONE694 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 694 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE695 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE695 Property
Gets the PANTONE 695 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE695 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE695
public static PDFPantoneColor PANTONE695 {get;}
public: __property static PDFPantoneColor* get_PANTONE695();
public:
static property PDFPantoneColor^ PANTONE695 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 695 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE696 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE696 Property
Gets the PANTONE 696 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE696 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE696
public static PDFPantoneColor PANTONE696 {get;}
public: __property static PDFPantoneColor* get_PANTONE696();
public:
static property PDFPantoneColor^ PANTONE696 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 696 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE697 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE697 Property
Gets the PANTONE 697 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE697 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE697
public static PDFPantoneColor PANTONE697 {get;}
public: __property static PDFPantoneColor* get_PANTONE697();
public:
static property PDFPantoneColor^ PANTONE697 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 697 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE698 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE698 Property
Gets the PANTONE 698 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE698 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE698
public static PDFPantoneColor PANTONE698 {get;}
public: __property static PDFPantoneColor* get_PANTONE698();
public:
static property PDFPantoneColor^ PANTONE698 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 698 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE699 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE699 Property
Gets the PANTONE 699 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE699 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE699
public static PDFPantoneColor PANTONE699 {get;}
public: __property static PDFPantoneColor* get_PANTONE699();
public:
static property PDFPantoneColor^ PANTONE699 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 699 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE700 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE700 Property
Gets the PANTONE 700 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE700 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE700
public static PDFPantoneColor PANTONE700 {get;}
public: __property static PDFPantoneColor* get_PANTONE700();
public:
static property PDFPantoneColor^ PANTONE700 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 700 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE701 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE701 Property
Gets the PANTONE 701 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE701 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE701
public static PDFPantoneColor PANTONE701 {get;}
public: __property static PDFPantoneColor* get_PANTONE701();
public:
static property PDFPantoneColor^ PANTONE701 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 701 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE702 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE702 Property
Gets the PANTONE 702 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE702 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE702
public static PDFPantoneColor PANTONE702 {get;}
public: __property static PDFPantoneColor* get_PANTONE702();
public:
static property PDFPantoneColor^ PANTONE702 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 702 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE703 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE703 Property
Gets the PANTONE 703 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE703 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE703
public static PDFPantoneColor PANTONE703 {get;}
public: __property static PDFPantoneColor* get_PANTONE703();
public:
static property PDFPantoneColor^ PANTONE703 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 703 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE704 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE704 Property
Gets the PANTONE 704 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE704 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE704
public static PDFPantoneColor PANTONE704 {get;}
public: __property static PDFPantoneColor* get_PANTONE704();
public:
static property PDFPantoneColor^ PANTONE704 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 704 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE705 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE705 Property
Gets the PANTONE 705 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE705 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE705
public static PDFPantoneColor PANTONE705 {get;}
public: __property static PDFPantoneColor* get_PANTONE705();
public:
static property PDFPantoneColor^ PANTONE705 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 705 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE706 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE706 Property
Gets the PANTONE 706 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE706 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE706
public static PDFPantoneColor PANTONE706 {get;}
public: __property static PDFPantoneColor* get_PANTONE706();
public:
static property PDFPantoneColor^ PANTONE706 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 706 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE707 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE707 Property
Gets the PANTONE 707 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE707 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE707
public static PDFPantoneColor PANTONE707 {get;}
public: __property static PDFPantoneColor* get_PANTONE707();
public:
static property PDFPantoneColor^ PANTONE707 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 707 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE708 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE708 Property
Gets the PANTONE 708 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE708 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE708
public static PDFPantoneColor PANTONE708 {get;}
public: __property static PDFPantoneColor* get_PANTONE708();
public:
static property PDFPantoneColor^ PANTONE708 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 708 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE709 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE709 Property
Gets the PANTONE 709 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE709 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE709
public static PDFPantoneColor PANTONE709 {get;}
public: __property static PDFPantoneColor* get_PANTONE709();
public:
static property PDFPantoneColor^ PANTONE709 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 709 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE710 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE710 Property
Gets the PANTONE 710 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE710 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE710
public static PDFPantoneColor PANTONE710 {get;}
public: __property static PDFPantoneColor* get_PANTONE710();
public:
static property PDFPantoneColor^ PANTONE710 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 710 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE711 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE711 Property
Gets the PANTONE 711 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE711 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE711
public static PDFPantoneColor PANTONE711 {get;}
public: __property static PDFPantoneColor* get_PANTONE711();
public:
static property PDFPantoneColor^ PANTONE711 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 711 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE712 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE712 Property
Gets the PANTONE 712 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE712 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE712
public static PDFPantoneColor PANTONE712 {get;}
public: __property static PDFPantoneColor* get_PANTONE712();
public:
static property PDFPantoneColor^ PANTONE712 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 712 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE713 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE713 Property
Gets the PANTONE 713 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE713 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE713
public static PDFPantoneColor PANTONE713 {get;}
public: __property static PDFPantoneColor* get_PANTONE713();
public:
static property PDFPantoneColor^ PANTONE713 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 713 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE714 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE714 Property
Gets the PANTONE 714 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE714 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE714
public static PDFPantoneColor PANTONE714 {get;}
public: __property static PDFPantoneColor* get_PANTONE714();
public:
static property PDFPantoneColor^ PANTONE714 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 714 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE715 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE715 Property
Gets the PANTONE 715 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE715 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE715
public static PDFPantoneColor PANTONE715 {get;}
public: __property static PDFPantoneColor* get_PANTONE715();
public:
static property PDFPantoneColor^ PANTONE715 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 715 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE716 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE716 Property
Gets the PANTONE 716 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE716 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE716
public static PDFPantoneColor PANTONE716 {get;}
public: __property static PDFPantoneColor* get_PANTONE716();
public:
static property PDFPantoneColor^ PANTONE716 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 716 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE717 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE717 Property
Gets the PANTONE 717 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE717 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE717
public static PDFPantoneColor PANTONE717 {get;}
public: __property static PDFPantoneColor* get_PANTONE717();
public:
static property PDFPantoneColor^ PANTONE717 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 717 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE718 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE718 Property
Gets the PANTONE 718 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE718 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE718
public static PDFPantoneColor PANTONE718 {get;}
public: __property static PDFPantoneColor* get_PANTONE718();
public:
static property PDFPantoneColor^ PANTONE718 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 718 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE719 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE719 Property
Gets the PANTONE 719 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE719 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE719
public static PDFPantoneColor PANTONE719 {get;}
public: __property static PDFPantoneColor* get_PANTONE719();
public:
static property PDFPantoneColor^ PANTONE719 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 719 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE720 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE720 Property
Gets the PANTONE 720 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE720 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE720
public static PDFPantoneColor PANTONE720 {get;}
public: __property static PDFPantoneColor* get_PANTONE720();
public:
static property PDFPantoneColor^ PANTONE720 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 720 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE721 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE721 Property
Gets the PANTONE 721 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE721 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE721
public static PDFPantoneColor PANTONE721 {get;}
public: __property static PDFPantoneColor* get_PANTONE721();
public:
static property PDFPantoneColor^ PANTONE721 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 721 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE722 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE722 Property
Gets the PANTONE 722 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE722 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE722
public static PDFPantoneColor PANTONE722 {get;}
public: __property static PDFPantoneColor* get_PANTONE722();
public:
static property PDFPantoneColor^ PANTONE722 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 722 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE723 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE723 Property
Gets the PANTONE 723 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE723 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE723
public static PDFPantoneColor PANTONE723 {get;}
public: __property static PDFPantoneColor* get_PANTONE723();
public:
static property PDFPantoneColor^ PANTONE723 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 723 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE724 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE724 Property
Gets the PANTONE 724 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE724 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE724
public static PDFPantoneColor PANTONE724 {get;}
public: __property static PDFPantoneColor* get_PANTONE724();
public:
static property PDFPantoneColor^ PANTONE724 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 724 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE725 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE725 Property
Gets the PANTONE 725 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE725 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE725
public static PDFPantoneColor PANTONE725 {get;}
public: __property static PDFPantoneColor* get_PANTONE725();
public:
static property PDFPantoneColor^ PANTONE725 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 725 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE726 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE726 Property
Gets the PANTONE 726 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE726 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE726
public static PDFPantoneColor PANTONE726 {get;}
public: __property static PDFPantoneColor* get_PANTONE726();
public:
static property PDFPantoneColor^ PANTONE726 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 726 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE727 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE727 Property
Gets the PANTONE 727 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE727 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE727
public static PDFPantoneColor PANTONE727 {get;}
public: __property static PDFPantoneColor* get_PANTONE727();
public:
static property PDFPantoneColor^ PANTONE727 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 727 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE728 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE728 Property
Gets the PANTONE 728 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE728 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE728
public static PDFPantoneColor PANTONE728 {get;}
public: __property static PDFPantoneColor* get_PANTONE728();
public:
static property PDFPantoneColor^ PANTONE728 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 728 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE729 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE729 Property
Gets the PANTONE 729 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE729 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE729
public static PDFPantoneColor PANTONE729 {get;}
public: __property static PDFPantoneColor* get_PANTONE729();
public:
static property PDFPantoneColor^ PANTONE729 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 729 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE730 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE730 Property
Gets the PANTONE 730 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE730 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE730
public static PDFPantoneColor PANTONE730 {get;}
public: __property static PDFPantoneColor* get_PANTONE730();
public:
static property PDFPantoneColor^ PANTONE730 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 730 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE731 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE731 Property
Gets the PANTONE 731 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE731 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE731
public static PDFPantoneColor PANTONE731 {get;}
public: __property static PDFPantoneColor* get_PANTONE731();
public:
static property PDFPantoneColor^ PANTONE731 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 731 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE732 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE732 Property
Gets the PANTONE 732 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE732 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE732
public static PDFPantoneColor PANTONE732 {get;}
public: __property static PDFPantoneColor* get_PANTONE732();
public:
static property PDFPantoneColor^ PANTONE732 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 732 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7401 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7401 Property
Gets the PANTONE 7401 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7401 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7401
public static PDFPantoneColor PANTONE7401 {get;}
public: __property static PDFPantoneColor* get_PANTONE7401();
public:
static property PDFPantoneColor^ PANTONE7401 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7401 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7402 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7402 Property
Gets the PANTONE 7402 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7402 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7402
public static PDFPantoneColor PANTONE7402 {get;}
public: __property static PDFPantoneColor* get_PANTONE7402();
public:
static property PDFPantoneColor^ PANTONE7402 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7402 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7403 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7403 Property
Gets the PANTONE 7403 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7403 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7403
public static PDFPantoneColor PANTONE7403 {get;}
public: __property static PDFPantoneColor* get_PANTONE7403();
public:
static property PDFPantoneColor^ PANTONE7403 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7403 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7404 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7404 Property
Gets the PANTONE 7404 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7404 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7404
public static PDFPantoneColor PANTONE7404 {get;}
public: __property static PDFPantoneColor* get_PANTONE7404();
public:
static property PDFPantoneColor^ PANTONE7404 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7404 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7405 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7405 Property
Gets the PANTONE 7405 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7405 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7405
public static PDFPantoneColor PANTONE7405 {get;}
public: __property static PDFPantoneColor* get_PANTONE7405();
public:
static property PDFPantoneColor^ PANTONE7405 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7405 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7406 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7406 Property
Gets the PANTONE 7406 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7406 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7406
public static PDFPantoneColor PANTONE7406 {get;}
public: __property static PDFPantoneColor* get_PANTONE7406();
public:
static property PDFPantoneColor^ PANTONE7406 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7406 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7407 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7407 Property
Gets the PANTONE 7407 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7407 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7407
public static PDFPantoneColor PANTONE7407 {get;}
public: __property static PDFPantoneColor* get_PANTONE7407();
public:
static property PDFPantoneColor^ PANTONE7407 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7407 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7408 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7408 Property
Gets the PANTONE 7408 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7408 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7408
public static PDFPantoneColor PANTONE7408 {get;}
public: __property static PDFPantoneColor* get_PANTONE7408();
public:
static property PDFPantoneColor^ PANTONE7408 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7408 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7409 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7409 Property
Gets the PANTONE 7409 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7409 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7409
public static PDFPantoneColor PANTONE7409 {get;}
public: __property static PDFPantoneColor* get_PANTONE7409();
public:
static property PDFPantoneColor^ PANTONE7409 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7409 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7410 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7410 Property
Gets the PANTONE 7410 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7410 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7410
public static PDFPantoneColor PANTONE7410 {get;}
public: __property static PDFPantoneColor* get_PANTONE7410();
public:
static property PDFPantoneColor^ PANTONE7410 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7410 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7411 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7411 Property
Gets the PANTONE 7411 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7411 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7411
public static PDFPantoneColor PANTONE7411 {get;}
public: __property static PDFPantoneColor* get_PANTONE7411();
public:
static property PDFPantoneColor^ PANTONE7411 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7411 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7412 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7412 Property
Gets the PANTONE 7412 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7412 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7412
public static PDFPantoneColor PANTONE7412 {get;}
public: __property static PDFPantoneColor* get_PANTONE7412();
public:
static property PDFPantoneColor^ PANTONE7412 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7412 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7413 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7413 Property
Gets the PANTONE 7413 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7413 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7413
public static PDFPantoneColor PANTONE7413 {get;}
public: __property static PDFPantoneColor* get_PANTONE7413();
public:
static property PDFPantoneColor^ PANTONE7413 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7413 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7414 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7414 Property
Gets the PANTONE 7414 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7414 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7414
public static PDFPantoneColor PANTONE7414 {get;}
public: __property static PDFPantoneColor* get_PANTONE7414();
public:
static property PDFPantoneColor^ PANTONE7414 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7414 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7415 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7415 Property
Gets the PANTONE 7415 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7415 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7415
public static PDFPantoneColor PANTONE7415 {get;}
public: __property static PDFPantoneColor* get_PANTONE7415();
public:
static property PDFPantoneColor^ PANTONE7415 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7415 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7416 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7416 Property
Gets the PANTONE 7416 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7416 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7416
public static PDFPantoneColor PANTONE7416 {get;}
public: __property static PDFPantoneColor* get_PANTONE7416();
public:
static property PDFPantoneColor^ PANTONE7416 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7416 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7417 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7417 Property
Gets the PANTONE 7417 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7417 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7417
public static PDFPantoneColor PANTONE7417 {get;}
public: __property static PDFPantoneColor* get_PANTONE7417();
public:
static property PDFPantoneColor^ PANTONE7417 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7417 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7418 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7418 Property
Gets the PANTONE 7418 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7418 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7418
public static PDFPantoneColor PANTONE7418 {get;}
public: __property static PDFPantoneColor* get_PANTONE7418();
public:
static property PDFPantoneColor^ PANTONE7418 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7418 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7419 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7419 Property
Gets the PANTONE 7419 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7419 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7419
public static PDFPantoneColor PANTONE7419 {get;}
public: __property static PDFPantoneColor* get_PANTONE7419();
public:
static property PDFPantoneColor^ PANTONE7419 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7419 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7420 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7420 Property
Gets the PANTONE 7420 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7420 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7420
public static PDFPantoneColor PANTONE7420 {get;}
public: __property static PDFPantoneColor* get_PANTONE7420();
public:
static property PDFPantoneColor^ PANTONE7420 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7420 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7421 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7421 Property
Gets the PANTONE 7421 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7421 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7421
public static PDFPantoneColor PANTONE7421 {get;}
public: __property static PDFPantoneColor* get_PANTONE7421();
public:
static property PDFPantoneColor^ PANTONE7421 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7421 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7422 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7422 Property
Gets the PANTONE 7422 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7422 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7422
public static PDFPantoneColor PANTONE7422 {get;}
public: __property static PDFPantoneColor* get_PANTONE7422();
public:
static property PDFPantoneColor^ PANTONE7422 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7422 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7423 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7423 Property
Gets the PANTONE 7423 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7423 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7423
public static PDFPantoneColor PANTONE7423 {get;}
public: __property static PDFPantoneColor* get_PANTONE7423();
public:
static property PDFPantoneColor^ PANTONE7423 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7423 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7424 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7424 Property
Gets the PANTONE 7424 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7424 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7424
public static PDFPantoneColor PANTONE7424 {get;}
public: __property static PDFPantoneColor* get_PANTONE7424();
public:
static property PDFPantoneColor^ PANTONE7424 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7424 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7425 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7425 Property
Gets the PANTONE 7425 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7425 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7425
public static PDFPantoneColor PANTONE7425 {get;}
public: __property static PDFPantoneColor* get_PANTONE7425();
public:
static property PDFPantoneColor^ PANTONE7425 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7425 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7426 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7426 Property
Gets the PANTONE 7426 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7426 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7426
public static PDFPantoneColor PANTONE7426 {get;}
public: __property static PDFPantoneColor* get_PANTONE7426();
public:
static property PDFPantoneColor^ PANTONE7426 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7426 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7427 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7427 Property
Gets the PANTONE 7427 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7427 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7427
public static PDFPantoneColor PANTONE7427 {get;}
public: __property static PDFPantoneColor* get_PANTONE7427();
public:
static property PDFPantoneColor^ PANTONE7427 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7427 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7428 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7428 Property
Gets the PANTONE 7428 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7428 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7428
public static PDFPantoneColor PANTONE7428 {get;}
public: __property static PDFPantoneColor* get_PANTONE7428();
public:
static property PDFPantoneColor^ PANTONE7428 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7428 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7429 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7429 Property
Gets the PANTONE 7429 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7429 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7429
public static PDFPantoneColor PANTONE7429 {get;}
public: __property static PDFPantoneColor* get_PANTONE7429();
public:
static property PDFPantoneColor^ PANTONE7429 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7429 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7430 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7430 Property
Gets the PANTONE 7430 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7430 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7430
public static PDFPantoneColor PANTONE7430 {get;}
public: __property static PDFPantoneColor* get_PANTONE7430();
public:
static property PDFPantoneColor^ PANTONE7430 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7430 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7431 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7431 Property
Gets the PANTONE 7431 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7431 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7431
public static PDFPantoneColor PANTONE7431 {get;}
public: __property static PDFPantoneColor* get_PANTONE7431();
public:
static property PDFPantoneColor^ PANTONE7431 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7431 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7432 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7432 Property
Gets the PANTONE 7432 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7432 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7432
public static PDFPantoneColor PANTONE7432 {get;}
public: __property static PDFPantoneColor* get_PANTONE7432();
public:
static property PDFPantoneColor^ PANTONE7432 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7432 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7433 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7433 Property
Gets the PANTONE 7433 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7433 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7433
public static PDFPantoneColor PANTONE7433 {get;}
public: __property static PDFPantoneColor* get_PANTONE7433();
public:
static property PDFPantoneColor^ PANTONE7433 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7433 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7434 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7434 Property
Gets the PANTONE 7434 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7434 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7434
public static PDFPantoneColor PANTONE7434 {get;}
public: __property static PDFPantoneColor* get_PANTONE7434();
public:
static property PDFPantoneColor^ PANTONE7434 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7434 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7435 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7435 Property
Gets the PANTONE 7435 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7435 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7435
public static PDFPantoneColor PANTONE7435 {get;}
public: __property static PDFPantoneColor* get_PANTONE7435();
public:
static property PDFPantoneColor^ PANTONE7435 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7435 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7436 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7436 Property
Gets the PANTONE 7436 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7436 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7436
public static PDFPantoneColor PANTONE7436 {get;}
public: __property static PDFPantoneColor* get_PANTONE7436();
public:
static property PDFPantoneColor^ PANTONE7436 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7436 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7437 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7437 Property
Gets the PANTONE 7437 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7437 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7437
public static PDFPantoneColor PANTONE7437 {get;}
public: __property static PDFPantoneColor* get_PANTONE7437();
public:
static property PDFPantoneColor^ PANTONE7437 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7437 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7438 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7438 Property
Gets the PANTONE 7438 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7438 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7438
public static PDFPantoneColor PANTONE7438 {get;}
public: __property static PDFPantoneColor* get_PANTONE7438();
public:
static property PDFPantoneColor^ PANTONE7438 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7438 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7439 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7439 Property
Gets the PANTONE 7439 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7439 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7439
public static PDFPantoneColor PANTONE7439 {get;}
public: __property static PDFPantoneColor* get_PANTONE7439();
public:
static property PDFPantoneColor^ PANTONE7439 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7439 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7440 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7440 Property
Gets the PANTONE 7440 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7440 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7440
public static PDFPantoneColor PANTONE7440 {get;}
public: __property static PDFPantoneColor* get_PANTONE7440();
public:
static property PDFPantoneColor^ PANTONE7440 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7440 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7441 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7441 Property
Gets the PANTONE 7441 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7441 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7441
public static PDFPantoneColor PANTONE7441 {get;}
public: __property static PDFPantoneColor* get_PANTONE7441();
public:
static property PDFPantoneColor^ PANTONE7441 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7441 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7442 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7442 Property
Gets the PANTONE 7442 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7442 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7442
public static PDFPantoneColor PANTONE7442 {get;}
public: __property static PDFPantoneColor* get_PANTONE7442();
public:
static property PDFPantoneColor^ PANTONE7442 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7442 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7443 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7443 Property
Gets the PANTONE 7443 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7443 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7443
public static PDFPantoneColor PANTONE7443 {get;}
public: __property static PDFPantoneColor* get_PANTONE7443();
public:
static property PDFPantoneColor^ PANTONE7443 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7443 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7444 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7444 Property
Gets the PANTONE 7444 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7444 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7444
public static PDFPantoneColor PANTONE7444 {get;}
public: __property static PDFPantoneColor* get_PANTONE7444();
public:
static property PDFPantoneColor^ PANTONE7444 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7444 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7445 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7445 Property
Gets the PANTONE 7445 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7445 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7445
public static PDFPantoneColor PANTONE7445 {get;}
public: __property static PDFPantoneColor* get_PANTONE7445();
public:
static property PDFPantoneColor^ PANTONE7445 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7445 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7446 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7446 Property
Gets the PANTONE 7446 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7446 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7446
public static PDFPantoneColor PANTONE7446 {get;}
public: __property static PDFPantoneColor* get_PANTONE7446();
public:
static property PDFPantoneColor^ PANTONE7446 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7446 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7447 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7447 Property
Gets the PANTONE 7447 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7447 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7447
public static PDFPantoneColor PANTONE7447 {get;}
public: __property static PDFPantoneColor* get_PANTONE7447();
public:
static property PDFPantoneColor^ PANTONE7447 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7447 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7448 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7448 Property
Gets the PANTONE 7448 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7448 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7448
public static PDFPantoneColor PANTONE7448 {get;}
public: __property static PDFPantoneColor* get_PANTONE7448();
public:
static property PDFPantoneColor^ PANTONE7448 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7448 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7449 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7449 Property
Gets the PANTONE 7449 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7449 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7449
public static PDFPantoneColor PANTONE7449 {get;}
public: __property static PDFPantoneColor* get_PANTONE7449();
public:
static property PDFPantoneColor^ PANTONE7449 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7449 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7450 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7450 Property
Gets the PANTONE 7450 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7450 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7450
public static PDFPantoneColor PANTONE7450 {get;}
public: __property static PDFPantoneColor* get_PANTONE7450();
public:
static property PDFPantoneColor^ PANTONE7450 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7450 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7451 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7451 Property
Gets the PANTONE 7451 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7451 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7451
public static PDFPantoneColor PANTONE7451 {get;}
public: __property static PDFPantoneColor* get_PANTONE7451();
public:
static property PDFPantoneColor^ PANTONE7451 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7451 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7452 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7452 Property
Gets the PANTONE 7452 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7452 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7452
public static PDFPantoneColor PANTONE7452 {get;}
public: __property static PDFPantoneColor* get_PANTONE7452();
public:
static property PDFPantoneColor^ PANTONE7452 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7452 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7453 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7453 Property
Gets the PANTONE 7453 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7453 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7453
public static PDFPantoneColor PANTONE7453 {get;}
public: __property static PDFPantoneColor* get_PANTONE7453();
public:
static property PDFPantoneColor^ PANTONE7453 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7453 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7454 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7454 Property
Gets the PANTONE 7454 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7454 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7454
public static PDFPantoneColor PANTONE7454 {get;}
public: __property static PDFPantoneColor* get_PANTONE7454();
public:
static property PDFPantoneColor^ PANTONE7454 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7454 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7455 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7455 Property
Gets the PANTONE 7455 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7455 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7455
public static PDFPantoneColor PANTONE7455 {get;}
public: __property static PDFPantoneColor* get_PANTONE7455();
public:
static property PDFPantoneColor^ PANTONE7455 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7455 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7456 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7456 Property
Gets the PANTONE 7456 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7456 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7456
public static PDFPantoneColor PANTONE7456 {get;}
public: __property static PDFPantoneColor* get_PANTONE7456();
public:
static property PDFPantoneColor^ PANTONE7456 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7456 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7457 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7457 Property
Gets the PANTONE 7457 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7457 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7457
public static PDFPantoneColor PANTONE7457 {get;}
public: __property static PDFPantoneColor* get_PANTONE7457();
public:
static property PDFPantoneColor^ PANTONE7457 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7457 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7458 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7458 Property
Gets the PANTONE 7458 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7458 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7458
public static PDFPantoneColor PANTONE7458 {get;}
public: __property static PDFPantoneColor* get_PANTONE7458();
public:
static property PDFPantoneColor^ PANTONE7458 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7458 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7459 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7459 Property
Gets the PANTONE 7459 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7459 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7459
public static PDFPantoneColor PANTONE7459 {get;}
public: __property static PDFPantoneColor* get_PANTONE7459();
public:
static property PDFPantoneColor^ PANTONE7459 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7459 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7460 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7460 Property
Gets the PANTONE 7460 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7460 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7460
public static PDFPantoneColor PANTONE7460 {get;}
public: __property static PDFPantoneColor* get_PANTONE7460();
public:
static property PDFPantoneColor^ PANTONE7460 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7460 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7461 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7461 Property
Gets the PANTONE 7461 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7461 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7461
public static PDFPantoneColor PANTONE7461 {get;}
public: __property static PDFPantoneColor* get_PANTONE7461();
public:
static property PDFPantoneColor^ PANTONE7461 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7461 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7462 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7462 Property
Gets the PANTONE 7462 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7462 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7462
public static PDFPantoneColor PANTONE7462 {get;}
public: __property static PDFPantoneColor* get_PANTONE7462();
public:
static property PDFPantoneColor^ PANTONE7462 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7462 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7463 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7463 Property
Gets the PANTONE 7463 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7463 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7463
public static PDFPantoneColor PANTONE7463 {get;}
public: __property static PDFPantoneColor* get_PANTONE7463();
public:
static property PDFPantoneColor^ PANTONE7463 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7463 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7464 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7464 Property
Gets the PANTONE 7464 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7464 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7464
public static PDFPantoneColor PANTONE7464 {get;}
public: __property static PDFPantoneColor* get_PANTONE7464();
public:
static property PDFPantoneColor^ PANTONE7464 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7464 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7465 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7465 Property
Gets the PANTONE 7465 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7465 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7465
public static PDFPantoneColor PANTONE7465 {get;}
public: __property static PDFPantoneColor* get_PANTONE7465();
public:
static property PDFPantoneColor^ PANTONE7465 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7465 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7466 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7466 Property
Gets the PANTONE 7466 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7466 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7466
public static PDFPantoneColor PANTONE7466 {get;}
public: __property static PDFPantoneColor* get_PANTONE7466();
public:
static property PDFPantoneColor^ PANTONE7466 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7466 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7467 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7467 Property
Gets the PANTONE 7467 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7467 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7467
public static PDFPantoneColor PANTONE7467 {get;}
public: __property static PDFPantoneColor* get_PANTONE7467();
public:
static property PDFPantoneColor^ PANTONE7467 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7467 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7468 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7468 Property
Gets the PANTONE 7468 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7468 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7468
public static PDFPantoneColor PANTONE7468 {get;}
public: __property static PDFPantoneColor* get_PANTONE7468();
public:
static property PDFPantoneColor^ PANTONE7468 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7468 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7469 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7469 Property
Gets the PANTONE 7469 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7469 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7469
public static PDFPantoneColor PANTONE7469 {get;}
public: __property static PDFPantoneColor* get_PANTONE7469();
public:
static property PDFPantoneColor^ PANTONE7469 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7469 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7470 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7470 Property
Gets the PANTONE 7470 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7470 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7470
public static PDFPantoneColor PANTONE7470 {get;}
public: __property static PDFPantoneColor* get_PANTONE7470();
public:
static property PDFPantoneColor^ PANTONE7470 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7470 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7471 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7471 Property
Gets the PANTONE 7471 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7471 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7471
public static PDFPantoneColor PANTONE7471 {get;}
public: __property static PDFPantoneColor* get_PANTONE7471();
public:
static property PDFPantoneColor^ PANTONE7471 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7471 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7472 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7472 Property
Gets the PANTONE 7472 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7472 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7472
public static PDFPantoneColor PANTONE7472 {get;}
public: __property static PDFPantoneColor* get_PANTONE7472();
public:
static property PDFPantoneColor^ PANTONE7472 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7472 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7473 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7473 Property
Gets the PANTONE 7473 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7473 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7473
public static PDFPantoneColor PANTONE7473 {get;}
public: __property static PDFPantoneColor* get_PANTONE7473();
public:
static property PDFPantoneColor^ PANTONE7473 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7473 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7474 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7474 Property
Gets the PANTONE 7474 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7474 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7474
public static PDFPantoneColor PANTONE7474 {get;}
public: __property static PDFPantoneColor* get_PANTONE7474();
public:
static property PDFPantoneColor^ PANTONE7474 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7474 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7475 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7475 Property
Gets the PANTONE 7475 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7475 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7475
public static PDFPantoneColor PANTONE7475 {get;}
public: __property static PDFPantoneColor* get_PANTONE7475();
public:
static property PDFPantoneColor^ PANTONE7475 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7475 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7476 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7476 Property
Gets the PANTONE 7476 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7476 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7476
public static PDFPantoneColor PANTONE7476 {get;}
public: __property static PDFPantoneColor* get_PANTONE7476();
public:
static property PDFPantoneColor^ PANTONE7476 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7476 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7477 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7477 Property
Gets the PANTONE 7477 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7477 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7477
public static PDFPantoneColor PANTONE7477 {get;}
public: __property static PDFPantoneColor* get_PANTONE7477();
public:
static property PDFPantoneColor^ PANTONE7477 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7477 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7478 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7478 Property
Gets the PANTONE 7478 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7478 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7478
public static PDFPantoneColor PANTONE7478 {get;}
public: __property static PDFPantoneColor* get_PANTONE7478();
public:
static property PDFPantoneColor^ PANTONE7478 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7478 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7479 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7479 Property
Gets the PANTONE 7479 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7479 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7479
public static PDFPantoneColor PANTONE7479 {get;}
public: __property static PDFPantoneColor* get_PANTONE7479();
public:
static property PDFPantoneColor^ PANTONE7479 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7479 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7480 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7480 Property
Gets the PANTONE 7480 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7480 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7480
public static PDFPantoneColor PANTONE7480 {get;}
public: __property static PDFPantoneColor* get_PANTONE7480();
public:
static property PDFPantoneColor^ PANTONE7480 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7480 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7481 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7481 Property
Gets the PANTONE 7481 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7481 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7481
public static PDFPantoneColor PANTONE7481 {get;}
public: __property static PDFPantoneColor* get_PANTONE7481();
public:
static property PDFPantoneColor^ PANTONE7481 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7481 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7482 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7482 Property
Gets the PANTONE 7482 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7482 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7482
public static PDFPantoneColor PANTONE7482 {get;}
public: __property static PDFPantoneColor* get_PANTONE7482();
public:
static property PDFPantoneColor^ PANTONE7482 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7482 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7483 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7483 Property
Gets the PANTONE 7483 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7483 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7483
public static PDFPantoneColor PANTONE7483 {get;}
public: __property static PDFPantoneColor* get_PANTONE7483();
public:
static property PDFPantoneColor^ PANTONE7483 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7483 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7484 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7484 Property
Gets the PANTONE 7484 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7484 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7484
public static PDFPantoneColor PANTONE7484 {get;}
public: __property static PDFPantoneColor* get_PANTONE7484();
public:
static property PDFPantoneColor^ PANTONE7484 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7484 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7485 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7485 Property
Gets the PANTONE 7485 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7485 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7485
public static PDFPantoneColor PANTONE7485 {get;}
public: __property static PDFPantoneColor* get_PANTONE7485();
public:
static property PDFPantoneColor^ PANTONE7485 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7485 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7486 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7486 Property
Gets the PANTONE 7486 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7486 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7486
public static PDFPantoneColor PANTONE7486 {get;}
public: __property static PDFPantoneColor* get_PANTONE7486();
public:
static property PDFPantoneColor^ PANTONE7486 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7486 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7487 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7487 Property
Gets the PANTONE 7487 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7487 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7487
public static PDFPantoneColor PANTONE7487 {get;}
public: __property static PDFPantoneColor* get_PANTONE7487();
public:
static property PDFPantoneColor^ PANTONE7487 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7487 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7488 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7488 Property
Gets the PANTONE 7488 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7488 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7488
public static PDFPantoneColor PANTONE7488 {get;}
public: __property static PDFPantoneColor* get_PANTONE7488();
public:
static property PDFPantoneColor^ PANTONE7488 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7488 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7489 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7489 Property
Gets the PANTONE 7489 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7489 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7489
public static PDFPantoneColor PANTONE7489 {get;}
public: __property static PDFPantoneColor* get_PANTONE7489();
public:
static property PDFPantoneColor^ PANTONE7489 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7489 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7490 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7490 Property
Gets the PANTONE 7490 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7490 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7490
public static PDFPantoneColor PANTONE7490 {get;}
public: __property static PDFPantoneColor* get_PANTONE7490();
public:
static property PDFPantoneColor^ PANTONE7490 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7490 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7491 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7491 Property
Gets the PANTONE 7491 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7491 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7491
public static PDFPantoneColor PANTONE7491 {get;}
public: __property static PDFPantoneColor* get_PANTONE7491();
public:
static property PDFPantoneColor^ PANTONE7491 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7491 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7492 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7492 Property
Gets the PANTONE 7492 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7492 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7492
public static PDFPantoneColor PANTONE7492 {get;}
public: __property static PDFPantoneColor* get_PANTONE7492();
public:
static property PDFPantoneColor^ PANTONE7492 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7492 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7493 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7493 Property
Gets the PANTONE 7493 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7493 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7493
public static PDFPantoneColor PANTONE7493 {get;}
public: __property static PDFPantoneColor* get_PANTONE7493();
public:
static property PDFPantoneColor^ PANTONE7493 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7493 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7494 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7494 Property
Gets the PANTONE 7494 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7494 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7494
public static PDFPantoneColor PANTONE7494 {get;}
public: __property static PDFPantoneColor* get_PANTONE7494();
public:
static property PDFPantoneColor^ PANTONE7494 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7494 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7495 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7495 Property
Gets the PANTONE 7495 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7495 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7495
public static PDFPantoneColor PANTONE7495 {get;}
public: __property static PDFPantoneColor* get_PANTONE7495();
public:
static property PDFPantoneColor^ PANTONE7495 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7495 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7496 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7496 Property
Gets the PANTONE 7496 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7496 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7496
public static PDFPantoneColor PANTONE7496 {get;}
public: __property static PDFPantoneColor* get_PANTONE7496();
public:
static property PDFPantoneColor^ PANTONE7496 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7496 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7497 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7497 Property
Gets the PANTONE 7497 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7497 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7497
public static PDFPantoneColor PANTONE7497 {get;}
public: __property static PDFPantoneColor* get_PANTONE7497();
public:
static property PDFPantoneColor^ PANTONE7497 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7497 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7498 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7498 Property
Gets the PANTONE 7498 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7498 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7498
public static PDFPantoneColor PANTONE7498 {get;}
public: __property static PDFPantoneColor* get_PANTONE7498();
public:
static property PDFPantoneColor^ PANTONE7498 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7498 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7499 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7499 Property
Gets the PANTONE 7499 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7499 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7499
public static PDFPantoneColor PANTONE7499 {get;}
public: __property static PDFPantoneColor* get_PANTONE7499();
public:
static property PDFPantoneColor^ PANTONE7499 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7499 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7500 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7500 Property
Gets the PANTONE 7500 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7500 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7500
public static PDFPantoneColor PANTONE7500 {get;}
public: __property static PDFPantoneColor* get_PANTONE7500();
public:
static property PDFPantoneColor^ PANTONE7500 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7500 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7501 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7501 Property
Gets the PANTONE 7501 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7501 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7501
public static PDFPantoneColor PANTONE7501 {get;}
public: __property static PDFPantoneColor* get_PANTONE7501();
public:
static property PDFPantoneColor^ PANTONE7501 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7501 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7502 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7502 Property
Gets the PANTONE 7502 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7502 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7502
public static PDFPantoneColor PANTONE7502 {get;}
public: __property static PDFPantoneColor* get_PANTONE7502();
public:
static property PDFPantoneColor^ PANTONE7502 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7502 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7503 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7503 Property
Gets the PANTONE 7503 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7503 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7503
public static PDFPantoneColor PANTONE7503 {get;}
public: __property static PDFPantoneColor* get_PANTONE7503();
public:
static property PDFPantoneColor^ PANTONE7503 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7503 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7504 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7504 Property
Gets the PANTONE 7504 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7504 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7504
public static PDFPantoneColor PANTONE7504 {get;}
public: __property static PDFPantoneColor* get_PANTONE7504();
public:
static property PDFPantoneColor^ PANTONE7504 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7504 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7505 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7505 Property
Gets the PANTONE 7505 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7505 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7505
public static PDFPantoneColor PANTONE7505 {get;}
public: __property static PDFPantoneColor* get_PANTONE7505();
public:
static property PDFPantoneColor^ PANTONE7505 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7505 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7506 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7506 Property
Gets the PANTONE 7506 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7506 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7506
public static PDFPantoneColor PANTONE7506 {get;}
public: __property static PDFPantoneColor* get_PANTONE7506();
public:
static property PDFPantoneColor^ PANTONE7506 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7506 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7507 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7507 Property
Gets the PANTONE 7507 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7507 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7507
public static PDFPantoneColor PANTONE7507 {get;}
public: __property static PDFPantoneColor* get_PANTONE7507();
public:
static property PDFPantoneColor^ PANTONE7507 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7507 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7508 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7508 Property
Gets the PANTONE 7508 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7508 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7508
public static PDFPantoneColor PANTONE7508 {get;}
public: __property static PDFPantoneColor* get_PANTONE7508();
public:
static property PDFPantoneColor^ PANTONE7508 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7508 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7509 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7509 Property
Gets the PANTONE 7509 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7509 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7509
public static PDFPantoneColor PANTONE7509 {get;}
public: __property static PDFPantoneColor* get_PANTONE7509();
public:
static property PDFPantoneColor^ PANTONE7509 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7509 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7510 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7510 Property
Gets the PANTONE 7510 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7510 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7510
public static PDFPantoneColor PANTONE7510 {get;}
public: __property static PDFPantoneColor* get_PANTONE7510();
public:
static property PDFPantoneColor^ PANTONE7510 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7510 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7511 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7511 Property
Gets the PANTONE 7511 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7511 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7511
public static PDFPantoneColor PANTONE7511 {get;}
public: __property static PDFPantoneColor* get_PANTONE7511();
public:
static property PDFPantoneColor^ PANTONE7511 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7511 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7512 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7512 Property
Gets the PANTONE 7512 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7512 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7512
public static PDFPantoneColor PANTONE7512 {get;}
public: __property static PDFPantoneColor* get_PANTONE7512();
public:
static property PDFPantoneColor^ PANTONE7512 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7512 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7513 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7513 Property
Gets the PANTONE 7513 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7513 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7513
public static PDFPantoneColor PANTONE7513 {get;}
public: __property static PDFPantoneColor* get_PANTONE7513();
public:
static property PDFPantoneColor^ PANTONE7513 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7513 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7514 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7514 Property
Gets the PANTONE 7514 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7514 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7514
public static PDFPantoneColor PANTONE7514 {get;}
public: __property static PDFPantoneColor* get_PANTONE7514();
public:
static property PDFPantoneColor^ PANTONE7514 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7514 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7515 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7515 Property
Gets the PANTONE 7515 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7515 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7515
public static PDFPantoneColor PANTONE7515 {get;}
public: __property static PDFPantoneColor* get_PANTONE7515();
public:
static property PDFPantoneColor^ PANTONE7515 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7515 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7516 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7516 Property
Gets the PANTONE 7516 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7516 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7516
public static PDFPantoneColor PANTONE7516 {get;}
public: __property static PDFPantoneColor* get_PANTONE7516();
public:
static property PDFPantoneColor^ PANTONE7516 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7516 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7517 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7517 Property
Gets the PANTONE 7517 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7517 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7517
public static PDFPantoneColor PANTONE7517 {get;}
public: __property static PDFPantoneColor* get_PANTONE7517();
public:
static property PDFPantoneColor^ PANTONE7517 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7517 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7518 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7518 Property
Gets the PANTONE 7518 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7518 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7518
public static PDFPantoneColor PANTONE7518 {get;}
public: __property static PDFPantoneColor* get_PANTONE7518();
public:
static property PDFPantoneColor^ PANTONE7518 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7518 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7519 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7519 Property
Gets the PANTONE 7519 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7519 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7519
public static PDFPantoneColor PANTONE7519 {get;}
public: __property static PDFPantoneColor* get_PANTONE7519();
public:
static property PDFPantoneColor^ PANTONE7519 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7519 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7520 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7520 Property
Gets the PANTONE 7520 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7520 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7520
public static PDFPantoneColor PANTONE7520 {get;}
public: __property static PDFPantoneColor* get_PANTONE7520();
public:
static property PDFPantoneColor^ PANTONE7520 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7520 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7521 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7521 Property
Gets the PANTONE 7521 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7521 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7521
public static PDFPantoneColor PANTONE7521 {get;}
public: __property static PDFPantoneColor* get_PANTONE7521();
public:
static property PDFPantoneColor^ PANTONE7521 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7521 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7522 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7522 Property
Gets the PANTONE 7522 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7522 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7522
public static PDFPantoneColor PANTONE7522 {get;}
public: __property static PDFPantoneColor* get_PANTONE7522();
public:
static property PDFPantoneColor^ PANTONE7522 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7522 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7523 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7523 Property
Gets the PANTONE 7523 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7523 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7523
public static PDFPantoneColor PANTONE7523 {get;}
public: __property static PDFPantoneColor* get_PANTONE7523();
public:
static property PDFPantoneColor^ PANTONE7523 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7523 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7524 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7524 Property
Gets the PANTONE 7524 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7524 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7524
public static PDFPantoneColor PANTONE7524 {get;}
public: __property static PDFPantoneColor* get_PANTONE7524();
public:
static property PDFPantoneColor^ PANTONE7524 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7524 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7525 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7525 Property
Gets the PANTONE 7525 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7525 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7525
public static PDFPantoneColor PANTONE7525 {get;}
public: __property static PDFPantoneColor* get_PANTONE7525();
public:
static property PDFPantoneColor^ PANTONE7525 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7525 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7526 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7526 Property
Gets the PANTONE 7526 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7526 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7526
public static PDFPantoneColor PANTONE7526 {get;}
public: __property static PDFPantoneColor* get_PANTONE7526();
public:
static property PDFPantoneColor^ PANTONE7526 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7526 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7527 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7527 Property
Gets the PANTONE 7527 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7527 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7527
public static PDFPantoneColor PANTONE7527 {get;}
public: __property static PDFPantoneColor* get_PANTONE7527();
public:
static property PDFPantoneColor^ PANTONE7527 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7527 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7528 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7528 Property
Gets the PANTONE 7528 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7528 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7528
public static PDFPantoneColor PANTONE7528 {get;}
public: __property static PDFPantoneColor* get_PANTONE7528();
public:
static property PDFPantoneColor^ PANTONE7528 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7528 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7529 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7529 Property
Gets the PANTONE 7529 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7529 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7529
public static PDFPantoneColor PANTONE7529 {get;}
public: __property static PDFPantoneColor* get_PANTONE7529();
public:
static property PDFPantoneColor^ PANTONE7529 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7529 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7530 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7530 Property
Gets the PANTONE 7530 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7530 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7530
public static PDFPantoneColor PANTONE7530 {get;}
public: __property static PDFPantoneColor* get_PANTONE7530();
public:
static property PDFPantoneColor^ PANTONE7530 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7530 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7531 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7531 Property
Gets the PANTONE 7531 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7531 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7531
public static PDFPantoneColor PANTONE7531 {get;}
public: __property static PDFPantoneColor* get_PANTONE7531();
public:
static property PDFPantoneColor^ PANTONE7531 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7531 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7532 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7532 Property
Gets the PANTONE 7532 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7532 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7532
public static PDFPantoneColor PANTONE7532 {get;}
public: __property static PDFPantoneColor* get_PANTONE7532();
public:
static property PDFPantoneColor^ PANTONE7532 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7532 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7533 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7533 Property
Gets the PANTONE 7533 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7533 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7533
public static PDFPantoneColor PANTONE7533 {get;}
public: __property static PDFPantoneColor* get_PANTONE7533();
public:
static property PDFPantoneColor^ PANTONE7533 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7533 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7534 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7534 Property
Gets the PANTONE 7534 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7534 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7534
public static PDFPantoneColor PANTONE7534 {get;}
public: __property static PDFPantoneColor* get_PANTONE7534();
public:
static property PDFPantoneColor^ PANTONE7534 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7534 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7535 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7535 Property
Gets the PANTONE 7535 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7535 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7535
public static PDFPantoneColor PANTONE7535 {get;}
public: __property static PDFPantoneColor* get_PANTONE7535();
public:
static property PDFPantoneColor^ PANTONE7535 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7535 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7536 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7536 Property
Gets the PANTONE 7536 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7536 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7536
public static PDFPantoneColor PANTONE7536 {get;}
public: __property static PDFPantoneColor* get_PANTONE7536();
public:
static property PDFPantoneColor^ PANTONE7536 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7536 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7537 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7537 Property
Gets the PANTONE 7537 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7537 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7537
public static PDFPantoneColor PANTONE7537 {get;}
public: __property static PDFPantoneColor* get_PANTONE7537();
public:
static property PDFPantoneColor^ PANTONE7537 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7537 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7538 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7538 Property
Gets the PANTONE 7538 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7538 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7538
public static PDFPantoneColor PANTONE7538 {get;}
public: __property static PDFPantoneColor* get_PANTONE7538();
public:
static property PDFPantoneColor^ PANTONE7538 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7538 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7539 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7539 Property
Gets the PANTONE 7539 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7539 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7539
public static PDFPantoneColor PANTONE7539 {get;}
public: __property static PDFPantoneColor* get_PANTONE7539();
public:
static property PDFPantoneColor^ PANTONE7539 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7539 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7540 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7540 Property
Gets the PANTONE 7540 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7540 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7540
public static PDFPantoneColor PANTONE7540 {get;}
public: __property static PDFPantoneColor* get_PANTONE7540();
public:
static property PDFPantoneColor^ PANTONE7540 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7540 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7541 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7541 Property
Gets the PANTONE 7541 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7541 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7541
public static PDFPantoneColor PANTONE7541 {get;}
public: __property static PDFPantoneColor* get_PANTONE7541();
public:
static property PDFPantoneColor^ PANTONE7541 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7541 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7542 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7542 Property
Gets the PANTONE 7542 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7542 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7542
public static PDFPantoneColor PANTONE7542 {get;}
public: __property static PDFPantoneColor* get_PANTONE7542();
public:
static property PDFPantoneColor^ PANTONE7542 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7542 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7543 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7543 Property
Gets the PANTONE 7543 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7543 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7543
public static PDFPantoneColor PANTONE7543 {get;}
public: __property static PDFPantoneColor* get_PANTONE7543();
public:
static property PDFPantoneColor^ PANTONE7543 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7543 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7544 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7544 Property
Gets the PANTONE 7544 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7544 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7544
public static PDFPantoneColor PANTONE7544 {get;}
public: __property static PDFPantoneColor* get_PANTONE7544();
public:
static property PDFPantoneColor^ PANTONE7544 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7544 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7545 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7545 Property
Gets the PANTONE 7545 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7545 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7545
public static PDFPantoneColor PANTONE7545 {get;}
public: __property static PDFPantoneColor* get_PANTONE7545();
public:
static property PDFPantoneColor^ PANTONE7545 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7545 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7546 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7546 Property
Gets the PANTONE 7546 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7546 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7546
public static PDFPantoneColor PANTONE7546 {get;}
public: __property static PDFPantoneColor* get_PANTONE7546();
public:
static property PDFPantoneColor^ PANTONE7546 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7546 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7547 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7547 Property
Gets the PANTONE 7547 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7547 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7547
public static PDFPantoneColor PANTONE7547 {get;}
public: __property static PDFPantoneColor* get_PANTONE7547();
public:
static property PDFPantoneColor^ PANTONE7547 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 7547 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8003 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8003 Property
Gets the PANTONE 8003 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8003 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8003
public static PDFPantoneColor PANTONE8003 {get;}
public: __property static PDFPantoneColor* get_PANTONE8003();
public:
static property PDFPantoneColor^ PANTONE8003 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 8003 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE801 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE801 Property
Gets the PANTONE 801 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE801 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE801
public static PDFPantoneColor PANTONE801 {get;}
public: __property static PDFPantoneColor* get_PANTONE801();
public:
static property PDFPantoneColor^ PANTONE801 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 801 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE802 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE802 Property
Gets the PANTONE 802 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE802 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE802
public static PDFPantoneColor PANTONE802 {get;}
public: __property static PDFPantoneColor* get_PANTONE802();
public:
static property PDFPantoneColor^ PANTONE802 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 802 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8021 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8021 Property
Gets the PANTONE 8021 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8021 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8021
public static PDFPantoneColor PANTONE8021 {get;}
public: __property static PDFPantoneColor* get_PANTONE8021();
public:
static property PDFPantoneColor^ PANTONE8021 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 8021 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE803 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE803 Property
Gets the PANTONE 803 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE803 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE803
public static PDFPantoneColor PANTONE803 {get;}
public: __property static PDFPantoneColor* get_PANTONE803();
public:
static property PDFPantoneColor^ PANTONE803 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 803 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE804 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE804 Property
Gets the PANTONE 804 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE804 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE804
public static PDFPantoneColor PANTONE804 {get;}
public: __property static PDFPantoneColor* get_PANTONE804();
public:
static property PDFPantoneColor^ PANTONE804 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 804 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE805 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE805 Property
Gets the PANTONE 805 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE805 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE805
public static PDFPantoneColor PANTONE805 {get;}
public: __property static PDFPantoneColor* get_PANTONE805();
public:
static property PDFPantoneColor^ PANTONE805 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 805 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE806 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE806 Property
Gets the PANTONE 806 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE806 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE806
public static PDFPantoneColor PANTONE806 {get;}
public: __property static PDFPantoneColor* get_PANTONE806();
public:
static property PDFPantoneColor^ PANTONE806 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 806 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8062 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8062 Property
Gets the PANTONE 8062 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8062 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8062
public static PDFPantoneColor PANTONE8062 {get;}
public: __property static PDFPantoneColor* get_PANTONE8062();
public:
static property PDFPantoneColor^ PANTONE8062 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 8062 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE807 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE807 Property
Gets the PANTONE 807 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE807 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE807
public static PDFPantoneColor PANTONE807 {get;}
public: __property static PDFPantoneColor* get_PANTONE807();
public:
static property PDFPantoneColor^ PANTONE807 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 807 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE808 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE808 Property
Gets the PANTONE 808 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE808 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE808
public static PDFPantoneColor PANTONE808 {get;}
public: __property static PDFPantoneColor* get_PANTONE808();
public:
static property PDFPantoneColor^ PANTONE808 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 808 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE809 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE809 Property
Gets the PANTONE 809 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE809 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE809
public static PDFPantoneColor PANTONE809 {get;}
public: __property static PDFPantoneColor* get_PANTONE809();
public:
static property PDFPantoneColor^ PANTONE809 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 809 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE810 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE810 Property
Gets the PANTONE 810 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE810 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE810
public static PDFPantoneColor PANTONE810 {get;}
public: __property static PDFPantoneColor* get_PANTONE810();
public:
static property PDFPantoneColor^ PANTONE810 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 810 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8100 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8100 Property
Gets the PANTONE 8100 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8100 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8100
public static PDFPantoneColor PANTONE8100 {get;}
public: __property static PDFPantoneColor* get_PANTONE8100();
public:
static property PDFPantoneColor^ PANTONE8100 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 8100 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE811 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE811 Property
Gets the PANTONE 811 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE811 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE811
public static PDFPantoneColor PANTONE811 {get;}
public: __property static PDFPantoneColor* get_PANTONE811();
public:
static property PDFPantoneColor^ PANTONE811 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 811 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE812 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE812 Property
Gets the PANTONE 812 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE812 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE812
public static PDFPantoneColor PANTONE812 {get;}
public: __property static PDFPantoneColor* get_PANTONE812();
public:
static property PDFPantoneColor^ PANTONE812 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 812 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE813 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE813 Property
Gets the PANTONE 813 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE813 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE813
public static PDFPantoneColor PANTONE813 {get;}
public: __property static PDFPantoneColor* get_PANTONE813();
public:
static property PDFPantoneColor^ PANTONE813 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 813 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE814 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE814 Property
Gets the PANTONE 814 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE814 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE814
public static PDFPantoneColor PANTONE814 {get;}
public: __property static PDFPantoneColor* get_PANTONE814();
public:
static property PDFPantoneColor^ PANTONE814 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 814 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8201 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8201 Property
Gets the PANTONE 8201 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8201 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8201
public static PDFPantoneColor PANTONE8201 {get;}
public: __property static PDFPantoneColor* get_PANTONE8201();
public:
static property PDFPantoneColor^ PANTONE8201 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 8201 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8281 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8281 Property
Gets the PANTONE 8281 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8281 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8281
public static PDFPantoneColor PANTONE8281 {get;}
public: __property static PDFPantoneColor* get_PANTONE8281();
public:
static property PDFPantoneColor^ PANTONE8281 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 8281 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8321 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8321 Property
Gets the PANTONE 8321 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8321 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8321
public static PDFPantoneColor PANTONE8321 {get;}
public: __property static PDFPantoneColor* get_PANTONE8321();
public:
static property PDFPantoneColor^ PANTONE8321 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 8321 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE871 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE871 Property
Gets the PANTONE 871 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE871 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE871
public static PDFPantoneColor PANTONE871 {get;}
public: __property static PDFPantoneColor* get_PANTONE871();
public:
static property PDFPantoneColor^ PANTONE871 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 871 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE872 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE872 Property
Gets the PANTONE 872 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE872 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE872
public static PDFPantoneColor PANTONE872 {get;}
public: __property static PDFPantoneColor* get_PANTONE872();
public:
static property PDFPantoneColor^ PANTONE872 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 872 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE873 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE873 Property
Gets the PANTONE 873 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE873 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE873
public static PDFPantoneColor PANTONE873 {get;}
public: __property static PDFPantoneColor* get_PANTONE873();
public:
static property PDFPantoneColor^ PANTONE873 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 873 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE874 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE874 Property
Gets the PANTONE 874 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE874 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE874
public static PDFPantoneColor PANTONE874 {get;}
public: __property static PDFPantoneColor* get_PANTONE874();
public:
static property PDFPantoneColor^ PANTONE874 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 874 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE875 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE875 Property
Gets the PANTONE 875 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE875 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE875
public static PDFPantoneColor PANTONE875 {get;}
public: __property static PDFPantoneColor* get_PANTONE875();
public:
static property PDFPantoneColor^ PANTONE875 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 875 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE876 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE876 Property
Gets the PANTONE 876 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE876 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE876
public static PDFPantoneColor PANTONE876 {get;}
public: __property static PDFPantoneColor* get_PANTONE876();
public:
static property PDFPantoneColor^ PANTONE876 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 876 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE877 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE877 Property
Gets the PANTONE 877 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE877 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE877
public static PDFPantoneColor PANTONE877 {get;}
public: __property static PDFPantoneColor* get_PANTONE877();
public:
static property PDFPantoneColor^ PANTONE877 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE 877 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessBlack Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessBlack Property
Gets the PANTONE Process Black color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessBlack As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessBlack
public static PDFPantoneColor ProcessBlack {get;}
public: __property static PDFPantoneColor* get_ProcessBlack();
public:
static property PDFPantoneColor^ ProcessBlack {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Process Black color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessBlue Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessBlue Property
Gets the PANTONE Process Blue color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessBlue As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessBlue
public static PDFPantoneColor ProcessBlue {get;}
public: __property static PDFPantoneColor* get_ProcessBlue();
public:
static property PDFPantoneColor^ ProcessBlue {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Process Blue color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessCyan Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessCyan Property
Gets the PANTONE Process Cyan color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessCyan As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessCyan
public static PDFPantoneColor ProcessCyan {get;}
public: __property static PDFPantoneColor* get_ProcessCyan();
public:
static property PDFPantoneColor^ ProcessCyan {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Process Cyan color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessMagenta Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessMagenta Property
Gets the PANTONE Process Magenta color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessMagenta As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessMagenta
public static PDFPantoneColor ProcessMagenta {get;}
public: __property static PDFPantoneColor* get_ProcessMagenta();
public:
static property PDFPantoneColor^ ProcessMagenta {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Process Magenta color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessYellow Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessYellow Property
Gets the PANTONE Process Yellow color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessYellow As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessYellow
public static PDFPantoneColor ProcessYellow {get;}
public: __property static PDFPantoneColor* get_ProcessYellow();
public:
static property PDFPantoneColor^ ProcessYellow {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Process Yellow color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Purple Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Purple Property
Gets the PANTONE Purple color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Purple As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Purple
public static PDFPantoneColor Purple {get;}
public: __property static PDFPantoneColor* get_Purple();
public:
static property PDFPantoneColor^ Purple {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Purple color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Red032 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Red032 Property
Gets the PANTONE Red 032 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Red032 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Red032
public static PDFPantoneColor Red032 {get;}
public: __property static PDFPantoneColor* get_Red032();
public:
static property PDFPantoneColor^ Red032 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Red 032 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ReflexBlue Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ReflexBlue Property
Gets the PANTONE Reflex Blue color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ReflexBlue As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.ReflexBlue
public static PDFPantoneColor ReflexBlue {get;}
public: __property static PDFPantoneColor* get_ReflexBlue();
public:
static property PDFPantoneColor^ ReflexBlue {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Reflex Blue color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


RhodamineRed Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : RhodamineRed Property
Gets the PANTONE Rhodamine Red color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property RhodamineRed As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.RhodamineRed
public static PDFPantoneColor RhodamineRed {get;}
public: __property static PDFPantoneColor* get_RhodamineRed();
public:
static property PDFPantoneColor^ RhodamineRed {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Rhodamine Red color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


RubineRed Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : RubineRed Property
Gets the PANTONE Rubine Red color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property RubineRed As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.RubineRed
public static PDFPantoneColor RubineRed {get;}
public: __property static PDFPantoneColor* get_RubineRed();
public:
static property PDFPantoneColor^ RubineRed {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Rubine Red color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Violet Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Violet Property
Gets the PANTONE Violet color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Violet As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Violet
public static PDFPantoneColor Violet {get;}
public: __property static PDFPantoneColor* get_Violet();
public:
static property PDFPantoneColor^ Violet {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Violet color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray1 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray1 Property
Gets the PANTONE Warm Gray 1 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray1 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray1
public static PDFPantoneColor WarmGray1 {get;}
public: __property static PDFPantoneColor* get_WarmGray1();
public:
static property PDFPantoneColor^ WarmGray1 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 1 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray10 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray10 Property
Gets the PANTONE Warm Gray 10 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray10 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray10
public static PDFPantoneColor WarmGray10 {get;}
public: __property static PDFPantoneColor* get_WarmGray10();
public:
static property PDFPantoneColor^ WarmGray10 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 10 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray11 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray11 Property
Gets the PANTONE Warm Gray 11 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray11 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray11
public static PDFPantoneColor WarmGray11 {get;}
public: __property static PDFPantoneColor* get_WarmGray11();
public:
static property PDFPantoneColor^ WarmGray11 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 11 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray2 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray2 Property
Gets the PANTONE Warm Gray 2 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray2 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray2
public static PDFPantoneColor WarmGray2 {get;}
public: __property static PDFPantoneColor* get_WarmGray2();
public:
static property PDFPantoneColor^ WarmGray2 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 2 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray3 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray3 Property
Gets the PANTONE Warm Gray 3 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray3 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray3
public static PDFPantoneColor WarmGray3 {get;}
public: __property static PDFPantoneColor* get_WarmGray3();
public:
static property PDFPantoneColor^ WarmGray3 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 3 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray4 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray4 Property
Gets the PANTONE Warm Gray 4 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray4 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray4
public static PDFPantoneColor WarmGray4 {get;}
public: __property static PDFPantoneColor* get_WarmGray4();
public:
static property PDFPantoneColor^ WarmGray4 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 4 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray5 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray5 Property
Gets the PANTONE Warm Gray 5 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray5 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray5
public static PDFPantoneColor WarmGray5 {get;}
public: __property static PDFPantoneColor* get_WarmGray5();
public:
static property PDFPantoneColor^ WarmGray5 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 5 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray6 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray6 Property
Gets the PANTONE Warm Gray 6 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray6 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray6
public static PDFPantoneColor WarmGray6 {get;}
public: __property static PDFPantoneColor* get_WarmGray6();
public:
static property PDFPantoneColor^ WarmGray6 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 6 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray7 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray7 Property
Gets the PANTONE Warm Gray 7 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray7 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray7
public static PDFPantoneColor WarmGray7 {get;}
public: __property static PDFPantoneColor* get_WarmGray7();
public:
static property PDFPantoneColor^ WarmGray7 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 7 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray8 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray8 Property
Gets the PANTONE Warm Gray 8 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray8 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray8
public static PDFPantoneColor WarmGray8 {get;}
public: __property static PDFPantoneColor* get_WarmGray8();
public:
static property PDFPantoneColor^ WarmGray8 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 8 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray9 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray9 Property
Gets the PANTONE Warm Gray 9 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray9 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray9
public static PDFPantoneColor WarmGray9 {get;}
public: __property static PDFPantoneColor* get_WarmGray9();
public:
static property PDFPantoneColor^ WarmGray9 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 9 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmRed Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmRed Property
Gets the PANTONE Warm Red color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmRed As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmRed
public static PDFPantoneColor WarmRed {get;}
public: __property static PDFPantoneColor* get_WarmRed();
public:
static property PDFPantoneColor^ WarmRed {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Warm Red color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Yellow Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Yellow Property
Gets the PANTONE Yellow color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Yellow As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Yellow
public static PDFPantoneColor Yellow {get;}
public: __property static PDFPantoneColor* get_Yellow();
public:
static property PDFPantoneColor^ Yellow {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Yellow color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Yellow012 Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Yellow012 Property
Gets the PANTONE Yellow 012 color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Yellow012 As PDFPantoneColor
'Usage

Dim value As PDFPantoneColor

value = PDFPantoneColor.Yellow012
public static PDFPantoneColor Yellow012 {get;}
public: __property static PDFPantoneColor* get_Yellow012();
public:
static property PDFPantoneColor^ Yellow012 {
   PDFPantoneColor^ get();
}

Property Value

A PDFPantoneColor object specifying the PANTONE Yellow 012 color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


%%PageItemTitle%%

PDFPatternColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPatternColorSpace Class
Defines a pattern colorspace.
Object Model
PDFPatternColorSpace ClassPDFPattern Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPatternColorSpace
   Inherits PDFColorSpace
'Usage

Dim instance As PDFPatternColorSpace
public class PDFPatternColorSpace : PDFColorSpace
public __gc class PDFPatternColorSpace : public PDFColorSpace
public ref class PDFPatternColorSpace : public PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPatternColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPatternColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFPatternColorSpace Class Members
Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPatternColorSpace Class

The following tables list the members exposed by PDFPatternColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PDFPatternColorSpace Constructor | Initializes a new PDFDeviceColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | Pattern | Gets the pattern represented by this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFPatternColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFPatternColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPatternColorSpace Class : PDFPatternColorSpace Constructor
Initializes a new PDFDeviceColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pattern As PDFPattern _
)
'Usage

Dim pattern As PDFPattern

Dim instance As New PDFPatternColorSpace(pattern)
public PDFPatternColorSpace(
   PDFPattern pattern
)
public: PDFPatternColorSpace(
   PDFPattern* pattern
)
public:
PDFPatternColorSpace(
   PDFPattern^ pattern
)

Parameters

pattern
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPatternColorSpace Class
PDFPatternColorSpace Members


%%PageItemTitle%% $$Properties$$

PDFPatternColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPatternColorSpace Class

For a list of all members of this type, see PDFPatternColorSpace members.

Public Properties
 | Name | Description
Public Property | Pattern | Gets the pattern represented by this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFPatternColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


Pattern Property (PDFPatternColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPatternColorSpace Class : Pattern Property
Gets the pattern represented by this colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pattern As PDFPattern
'Usage

Dim instance As PDFPatternColorSpace
Dim value As PDFPattern

value = instance.Pattern
public PDFPattern Pattern {get;}
public: __property PDFPattern* get_Pattern();
public:
property PDFPattern^ Pattern {
   PDFPattern^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPatternColorSpace Class
PDFPatternColorSpace Members


%%PageItemTitle%%

PDFSeparationColorSpace Class
Members

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class
Defines a separation colorspace.
Object Model
PDFSeparationColorSpace ClassPDFColorSpace ClassPDFFunction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSeparationColorSpace
   Inherits PDFColorSpace
'Usage

Dim instance As PDFSeparationColorSpace
public class PDFSeparationColorSpace : PDFColorSpace
public __gc class PDFSeparationColorSpace : public PDFColorSpace
public ref class PDFSeparationColorSpace : public PDFColorSpace
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Members$$

PDFSeparationColorSpace Class Members
Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class

The following tables list the members exposed by PDFSeparationColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PDFSeparationColorSpace Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Colorant | Gets or sets the colorant represented by this separation colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFSeparationColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : PDFSeparationColorSpace Constructor
Overload List
Overload | Description
PDFSeparationColorSpace Constructor(PDFArray) | Initializes a new PDFSeparationColorSpace object.
PDFSeparationColorSpace Constructor() | Initializes a new PDFSeparationColorSpace object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


%%PageItemTitle%%

PDFSeparationColorSpace Constructor(PDFArray)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class > PDFSeparationColorSpace Constructor : PDFSeparationColorSpace Constructor(PDFArray)
Initializes a new PDFSeparationColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rawColorSpace As PDFArray _
)
'Usage

Dim rawColorSpace As PDFArray

Dim instance As New PDFSeparationColorSpace(rawColorSpace)
public PDFSeparationColorSpace(
   PDFArray rawColorSpace
)
public: PDFSeparationColorSpace(
   PDFArray* rawColorSpace
)
public:
PDFSeparationColorSpace(
   PDFArray^ rawColorSpace
)

Parameters

rawColorSpace
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members
Overload List


%%PageItemTitle%%

PDFSeparationColorSpace Constructor()

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class > PDFSeparationColorSpace Constructor : PDFSeparationColorSpace Constructor()
Initializes a new PDFSeparationColorSpace object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSeparationColorSpace()
public PDFSeparationColorSpace()
public: PDFSeparationColorSpace();
public:
PDFSeparationColorSpace();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFSeparationColorSpace Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class

For a list of all members of this type, see PDFSeparationColorSpace members.

Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Colorant | Gets or sets the colorant represented by this separation colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace)
Top
See Also

Reference

PDFSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


AlternateColorSpace Property (PDFSeparationColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : AlternateColorSpace Property
Gets or sets the alternate colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlternateColorSpace As PDFColorSpace
'Usage

Dim instance As PDFSeparationColorSpace
Dim value As PDFColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
public PDFColorSpace AlternateColorSpace {get; set;}
public: __property PDFColorSpace* get_AlternateColorSpace();
public: __property void set_AlternateColorSpace(
   PDFColorSpace* value
);
public:
property PDFColorSpace^ AlternateColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The alternate color space to be used when the destination device does not support separation colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


Colorant Property

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : Colorant Property
Gets or sets the colorant represented by this separation colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Colorant As String
'Usage

Dim instance As PDFSeparationColorSpace
Dim value As String

instance.Colorant = value

value = instance.Colorant
public string Colorant {get; set;}
public: __property string* get_Colorant();
public: __property void set_Colorant(
   string* value
);
public:
property String^ Colorant {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the colorant.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


TintTransform Property (PDFSeparationColorSpace)

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : TintTransform Property
Gets or sets the tint transform function for the this colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TintTransform As PDFFunction
'Usage

Dim instance As PDFSeparationColorSpace
Dim value As PDFFunction

instance.TintTransform = value

value = instance.TintTransform
public PDFFunction TintTransform {get; set;}
public: __property PDFFunction* get_TintTransform();
public: __property void set_TintTransform(
   PDFFunction* value
);
public:
property PDFFunction^ TintTransform {
   PDFFunction^ get();
   void set (    PDFFunction^ value);
}

Property Value

Tint transform function for the colorspace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


%%PageItemTitle%%

PDFColorSpaceType Enumeration

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceType Enumeration
Defines the available colorspace types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFColorSpaceType
   Inherits System.Enum
'Usage

Dim instance As PDFColorSpaceType
public enum PDFColorSpaceType : System.Enum
__value public enum PDFColorSpaceType : public System.Enum
public enum class PDFColorSpaceType : public System.Enum
Members
Member | Description
CalGray | Calibrated gray colorspace.
CalRGB | Calibrated RGB colorspace.
DeviceCMYK | CMYK device colorspace.
DeviceGray | Gray device colorspace.
DeviceN | DeviceN colorspace.
DeviceRGB | RGB device colorspace.
ICCBased | ICC based colorspace.
Indexed | Indexed colorspace.
Lab | Lab colorspace.
Pattern | Pattern colorspace.
Separation | Separation colorspace.
Unknown | Unknown colorspace.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpaceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceColorSpaceType Enumeration

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpaceType Enumeration
Defines the available device colorspace types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFDeviceColorSpaceType
   Inherits System.Enum
'Usage

Dim instance As PDFDeviceColorSpaceType
public enum PDFDeviceColorSpaceType : System.Enum
__value public enum PDFDeviceColorSpaceType : public System.Enum
public enum class PDFDeviceColorSpaceType : public System.Enum
Members
Member | Description
DeviceCMYK | CMYK device colorspace.
DeviceGray | Gray device colorspace.
DeviceRGB | RGB device colorspace.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpaceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


O2S.Components.PDF4NET.Graphics.Fonts Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | CJKFont | Defines a font for east asian languages (chinese, japanese and korean).
Class | PDFFont | Defines a particular format for text, including font face and size.
Class | PDFFontBase | Base class for all PDF fonts.
Class | PDFFontMetrics | Defines the metrics for a font object used in the pdf file.
Class | PostScriptFont | Defines a particular format for text, including font face and size.
Class | TrueTypeFont | Defines a TrueType font that can be used in a PDF file.
Class | Type0Font | Defines a generic Type0 font that can be used in a PDF file.
Class | Type3Font | Defines a Type3 font.
Class | Type3VisualChar | Defines the visual appearance of a Type3 character.
Class | Type3VisualCharCollection | Defines a collection of Type3 characters.
Enumerations
 | Enumeration | Description
Enumeration | CJKFontFace | Defines the available CJK fonts faces.
Enumeration | PDFFontFace | Specifies the available PDF fonts for drawing text on a page
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

CJKFont Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class
Defines a font for east asian languages (chinese, japanese and korean).
Object Model
CJKFont ClassPDFFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class CJKFont
   Inherits PDFFontBase
'Usage

Dim instance As CJKFont
public class CJKFont : PDFFontBase
public __gc class CJKFont : public PDFFontBase
public ref class CJKFont : public PDFFontBase
Remarks
The fonts defined by this class are based on Asian Language Pack for Adobe Acrobat and Adobe Acrobat Reader products.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.CJKFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CJKFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

CJKFont Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

The following tables list the members exposed by CJKFont.

Public Constructors
 | Name | Description
Public Constructor | CJKFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | CJKFontFace | Gets of sets the cjk font face.
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

CJKFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

CJKFont Constructor

O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : CJKFont Constructor
Overload List
Overload | Description
CJKFont Constructor(CJKFontFace,Double) | Initializes a new CJKFont object with the specified CJKFontFace and size.
CJKFont Constructor(CJKFont) | Initializes a new CJKFont object based on an existing font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CJKFont Class
CJKFont Members


%%PageItemTitle%%

CJKFont Constructor(CJKFontFace,Double)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class > CJKFont Constructor : CJKFont Constructor(CJKFontFace,Double)
a CJKFontFace enumeration member specifying the font face
a float value specifying the size of the font in points
Initializes a new CJKFont object with the specified CJKFontFace and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal cjkFontFace As CJKFontFace, _
   ByVal size As Double _
)
'Usage

Dim cjkFontFace As CJKFontFace
Dim size As Double

Dim instance As New CJKFont(cjkFontFace, size)
public CJKFont(
   CJKFontFace cjkFontFace,
   double size
)
public: CJKFont(
   CJKFontFace cjkFontFace,
   double size
)
public:
CJKFont(
   CJKFontFace cjkFontFace,
   double size
)

Parameters

cjkFontFace
a CJKFontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CJKFont Class
CJKFont Members
Overload List


%%PageItemTitle%%

CJKFont Constructor(CJKFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class > CJKFont Constructor : CJKFont Constructor(CJKFont)
a CJKFont object to be copied in the new font.
Initializes a new CJKFont object based on an existing font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As CJKFont _
)
'Usage

Dim font As CJKFont

Dim instance As New CJKFont(font)
public CJKFont(
   CJKFont font
)
public: CJKFont(
   CJKFont* font
)
public:
CJKFont(
   CJKFont^ font
)

Parameters

font
a CJKFont object to be copied in the new font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CJKFont Class
CJKFont Members
Overload List


%%PageItemTitle%% $$Methods$$

CJKFont Class Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

For a list of all members of this type, see CJKFont members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

CJKFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method (CJKFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As CJKFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CJKFont Class
CJKFont Members


%%PageItemTitle%% $$Properties$$

CJKFont Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

For a list of all members of this type, see CJKFont members.

Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | CJKFontFace | Gets of sets the cjk font face.
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

CJKFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Bold Property (CJKFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : Bold Property
Gets or sets whether the font object is bold or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Bold As Boolean
'Usage

Dim instance As CJKFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public override bool Bold {get; set;}
public: __property bool get_Bold() override;
public: __property void set_Bold(
   bool value
) override;
public:
property bool Bold {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this font object is bold; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CJKFont Class
CJKFont Members


CJKFontFace Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : CJKFontFace Property
Gets of sets the cjk font face.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CJKFontFace As CJKFontFace
'Usage

Dim instance As CJKFont
Dim value As CJKFontFace

instance.CJKFontFace = value

value = instance.CJKFontFace
public CJKFontFace CJKFontFace {get; set;}
public: __property CJKFontFace get_CJKFontFace();
public: __property void set_CJKFontFace(
   CJKFontFace value
);
public:
property CJKFontFace CJKFontFace {
   CJKFontFace get();
   void set (    CJKFontFace value);
}

Property Value

a CJKFontFace enumeration member specifying the cjk font face.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CJKFont Class
CJKFont Members


Italic Property (CJKFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : Italic Property
Gets or sets whether the font object is italic or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Italic As Boolean
'Usage

Dim instance As CJKFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public override bool Italic {get; set;}
public: __property bool get_Italic() override;
public: __property void set_Italic(
   bool value
) override;
public:
property bool Italic {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this font object is italic; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CJKFont Class
CJKFont Members


%%PageItemTitle%%

PDFFont Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFont Class
Defines a particular format for text, including font face and size.
Object Model
PDFFont ClassPDFFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFont
   Inherits PDFFontBase
'Usage

Dim instance As PDFFont
public class PDFFont : PDFFontBase
public __gc class PDFFont : public PDFFontBase
public ref class PDFFont : public PDFFontBase
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.PDFFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

PDFFont Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFont Class

The following tables list the members exposed by PDFFont.

Public Constructors
 | Name | Description
Public Constructor | PDFFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | FontFace | Gets or sets the font face
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PDFFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

PDFFont Constructor

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : PDFFont Constructor
Overload List
Overload | Description
PDFFont Constructor() | Initializes a new PDFFont object
PDFFont Constructor(PDFFontFace,Double) | Initializes a new PDFFont object of specified FontFace and size.
PDFFont Constructor(PDFFont) | Initializes a new PDFFont object based on an existing font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

PDFFont Constructor()

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor()
Initializes a new PDFFont object
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFont()
public PDFFont()
public: PDFFont();
public:
PDFFont();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


%%PageItemTitle%%

PDFFont Constructor(PDFFontFace,Double)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor(PDFFontFace,Double)
a FontFace enumeration member specifying the font face
a float value specifying the size of the font in points
Initializes a new PDFFont object of specified FontFace and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fontFace As PDFFontFace, _
   ByVal size As Double _
)
'Usage

Dim fontFace As PDFFontFace
Dim size As Double

Dim instance As New PDFFont(fontFace, size)
public PDFFont(
   PDFFontFace fontFace,
   double size
)
public: PDFFont(
   PDFFontFace fontFace,
   double size
)
public:
PDFFont(
   PDFFontFace fontFace,
   double size
)

Parameters

fontFace
a FontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


%%PageItemTitle%%

PDFFont Constructor(PDFFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor(PDFFont)
a PDFFont object to be copied in the new font.
Initializes a new PDFFont object based on an existing font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PDFFont _
)
'Usage

Dim font As PDFFont

Dim instance As New PDFFont(font)
public PDFFont(
   PDFFont font
)
public: PDFFont(
   PDFFont* font
)
public:
PDFFont(
   PDFFont^ font
)

Parameters

font
a PDFFont object to be copied in the new font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFFont Class Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFont Class

For a list of all members of this type, see PDFFont members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PDFFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method (PDFFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As PDFFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%% $$Properties$$

PDFFont Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFont Class

For a list of all members of this type, see PDFFont members.

Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | FontFace | Gets or sets the font face
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PDFFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Bold Property (PDFFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : Bold Property
Gets or sets whether the font object is bold or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Bold As Boolean
'Usage

Dim instance As PDFFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public override bool Bold {get; set;}
public: __property bool get_Bold() override;
public: __property void set_Bold(
   bool value
) override;
public:
property bool Bold {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this font object is bold; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


FontFace Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : FontFace Property
Gets or sets the font face
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontFace As PDFFontFace
'Usage

Dim instance As PDFFont
Dim value As PDFFontFace

instance.FontFace = value

value = instance.FontFace
public PDFFontFace FontFace {get; set;}
public: __property PDFFontFace get_FontFace();
public: __property void set_FontFace(
   PDFFontFace value
);
public:
property PDFFontFace FontFace {
   PDFFontFace get();
   void set (    PDFFontFace value);
}

Property Value

a FontFace enumeration member specifying the font face
Remarks
When creating a PDFFont object using the default constructor, the default value of this property is set to O2S.Components.PDF4NET.Graphics.Fonts.FontFace.Helvetica
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


Italic Property (PDFFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : Italic Property
Gets or sets whether the font object is italic or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Italic As Boolean
'Usage

Dim instance As PDFFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public override bool Italic {get; set;}
public: __property bool get_Italic() override;
public: __property void set_Italic(
   bool value
) override;
public:
property bool Italic {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this font object is italic; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

PDFFontBase Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontBase Class
Base class for all PDF fonts.
Object Model
PDFFontBase ClassPDFFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFFontBase
'Usage

Dim instance As PDFFontBase
public abstract class PDFFontBase
public __gc abstract class PDFFontBase
public ref class PDFFontBase abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.CJKFont
O2S.Components.PDF4NET.Graphics.Fonts.PDFFont
O2S.Components.PDF4NET.Graphics.Fonts.PostScriptFont
O2S.Components.PDF4NET.Graphics.Fonts.TrueTypeFont
O2S.Components.PDF4NET.Graphics.Fonts.Type0Font
O2S.Components.PDF4NET.Graphics.Fonts.Type3Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

PDFFontBase Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontBase Class

The following tables list the members exposed by PDFFontBase.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not.
Public Property | Italic | Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object.
Public Property | Overline | Gets or sets whether the font object is overline or not.
Public Property | Size | Gets or sets the font size.
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not.
Public Property | Underline | Gets or sets whether the font object is underline or not.
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object.
Top
See Also

Reference

PDFFontBase Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Methods$$

PDFFontBase Class Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontBase Class

For a list of all members of this type, see PDFFontBase members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object.
Top
See Also

Reference

PDFFontBase Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method (PDFFontBase)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As PDFFontBase
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public virtual double GetCharWidth(
   char charCode
)
public: virtual double GetCharWidth(
   char charCode
)
public:
virtual double GetCharWidth(
   char charCode
)

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


MeasureString Method

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : MeasureString Method
The string to measure
Measures the specified string when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function MeasureString( _
   ByVal text As String _
) As Double
'Usage

Dim instance As PDFFontBase
Dim text As String
Dim value As Double

value = instance.MeasureString(text)
public virtual double MeasureString(
   string text
)
public: virtual double MeasureString(
   string* text
)
public:
virtual double MeasureString(
   String^ text
)

Parameters

text
The string to measure

Return Value

This method returns a float value that represents the size, in points, of the string specified by the text parameter as drawn with this font object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%PageItemTitle%% $$Properties$$

PDFFontBase Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontBase Class

For a list of all members of this type, see PDFFontBase members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not.
Public Property | Italic | Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object.
Public Property | Overline | Gets or sets whether the font object is overline or not.
Public Property | Size | Gets or sets the font size.
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not.
Public Property | Underline | Gets or sets whether the font object is underline or not.
Top
See Also

Reference

PDFFontBase Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Bold Property (PDFFontBase)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Bold Property
Gets or sets whether the font object is bold or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Bold As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public virtual bool Bold {get; set;}
public: __property virtual bool get_Bold();
public: __property virtual void set_Bold(
   bool value
);
public:
virtual property bool Bold {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this font object is bold; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Italic Property (PDFFontBase)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Italic Property
Gets or sets whether the font object is italic or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Italic As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public virtual bool Italic {get; set;}
public: __property virtual bool get_Italic();
public: __property virtual void set_Italic(
   bool value
);
public:
virtual property bool Italic {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this font object is italic; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Metrics Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Metrics Property
Gets the metrics of this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Metrics As PDFFontMetrics
'Usage

Dim instance As PDFFontBase
Dim value As PDFFontMetrics

value = instance.Metrics
public PDFFontMetrics Metrics {get;}
public: __property PDFFontMetrics* get_Metrics();
public:
property PDFFontMetrics^ Metrics {
   PDFFontMetrics^ get();
}

Property Value

A PDFFontMetrics object specifying the metrics of this font object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Overline Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Overline Property
Gets or sets whether the font object is overline or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Overline As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Overline = value

value = instance.Overline
public bool Overline {get; set;}
public: __property bool get_Overline();
public: __property void set_Overline(
   bool value
);
public:
property bool Overline {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this PDFFont object is overline; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Size Property (PDFFontBase)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Size Property
Gets or sets the font size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Size As Double
'Usage

Dim instance As PDFFontBase
Dim value As Double

instance.Size = value

value = instance.Size
public double Size {get; set;}
public: __property double get_Size();
public: __property void set_Size(
   double value
);
public:
property double Size {
   double get();
   void set (    double value);
}

Property Value

a float value specifyig the size of the font in points (1/72 inches)
Remarks
The size of a font is always given in points, it does not matter the logical unit used for positioning the text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Strikethrough Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Strikethrough Property
Gets or sets whether the font object is strikethrough or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Strikethrough As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Strikethrough = value

value = instance.Strikethrough
public bool Strikethrough {get; set;}
public: __property bool get_Strikethrough();
public: __property void set_Strikethrough(
   bool value
);
public:
property bool Strikethrough {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this font object is strikethrough; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Underline Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Underline Property
Gets or sets whether the font object is underline or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Underline As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Underline = value

value = instance.Underline
public bool Underline {get; set;}
public: __property bool get_Underline();
public: __property void set_Underline(
   bool value
);
public:
property bool Underline {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this font object is underline; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%PageItemTitle%%

PDFFontMetrics Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontMetrics Class
Defines the metrics for a font object used in the pdf file.
Object Model
PDFFontMetrics ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFontMetrics
'Usage

Dim instance As PDFFontMetrics
public class PDFFontMetrics
public __gc class PDFFontMetrics
public ref class PDFFontMetrics
Remarks
The values of the properties of this class are given in unscaled glyph units. To convert the values to points, divide by 1000 then multiply by font size (points).
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontMetrics

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

PDFFontMetrics Class Members
Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontMetrics Class

The following tables list the members exposed by PDFFontMetrics.

Public Properties
 | Name | Description
Public Property | Ascent | Gets the ascent of the font.
Public Property | AverageWidth | Gets the average width of glyphs in the font.
Public Property | BoundingBox | Gets the font's bounding box.
Public Property | CapHeight | Gets the capHeight of the font.
Public Property | Descent | Gets the descent of the font.
Public Property | Leading | Gets the leading of the font.
Public Property | MaxWidth | Gets the maximum width of glyphs in the font.
Public Property | Name | Gets the Postscript name of the font.
Public Property | StemH | Gets the horizontal stem of the font.
Public Property | StemV | Gets the vertical stem of the font.
Public Property | XHeight | Gets the x height of the font.
Top
See Also

Reference

PDFFontMetrics Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Properties$$

PDFFontMetrics Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontMetrics Class

For a list of all members of this type, see PDFFontMetrics members.

Public Properties
 | Name | Description
Public Property | Ascent | Gets the ascent of the font.
Public Property | AverageWidth | Gets the average width of glyphs in the font.
Public Property | BoundingBox | Gets the font's bounding box.
Public Property | CapHeight | Gets the capHeight of the font.
Public Property | Descent | Gets the descent of the font.
Public Property | Leading | Gets the leading of the font.
Public Property | MaxWidth | Gets the maximum width of glyphs in the font.
Public Property | Name | Gets the Postscript name of the font.
Public Property | StemH | Gets the horizontal stem of the font.
Public Property | StemV | Gets the vertical stem of the font.
Public Property | XHeight | Gets the x height of the font.
Top
See Also

Reference

PDFFontMetrics Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Ascent Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Ascent Property
Gets the ascent of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Ascent As Double
'Usage

Dim instance As PDFFontMetrics
Dim value As Double

value = instance.Ascent
public double Ascent {get;}
public: __property double get_Ascent();
public:
property double Ascent {
   double get();
}

Property Value

A double value specifying the maximum height above the baseline reached by glyphs in this font, excluding the height of glyphs for accented characters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


AverageWidth Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : AverageWidth Property
Gets the average width of glyphs in the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AverageWidth As Double
'Usage

Dim instance As PDFFontMetrics
Dim value As Double

value = instance.AverageWidth
public double AverageWidth {get;}
public: __property double get_AverageWidth();
public:
property double AverageWidth {
   double get();
}

Property Value

A double value specifying the average width of glyphs in the font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


BoundingBox Property (PDFFontMetrics)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : BoundingBox Property
Gets the font's bounding box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BoundingBox As PDFRectangle
'Usage

Dim instance As PDFFontMetrics
Dim value As PDFRectangle

value = instance.BoundingBox
public PDFRectangle BoundingBox {get;}
public: __property PDFRectangle* get_BoundingBox();
public:
property PDFRectangle^ BoundingBox {
   PDFRectangle^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFRectangle object specifying the font's bounding box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


CapHeight Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : CapHeight Property
Gets the capHeight of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CapHeight As Double
'Usage

Dim instance As PDFFontMetrics
Dim value As Double

value = instance.CapHeight
public double CapHeight {get;}
public: __property double get_CapHeight();
public:
property double CapHeight {
   double get();
}

Property Value

A double value specifying the vertical coordinate of the top of flat capital letters, measured from the baseline.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


Descent Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Descent Property
Gets the descent of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Descent As Double
'Usage

Dim instance As PDFFontMetrics
Dim value As Double

value = instance.Descent
public double Descent {get;}
public: __property double get_Descent();
public:
property double Descent {
   double get();
}

Property Value

A double value specifying the maximum depth below the baseline reached by glyphs in this font. This value is a negative number.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


Leading Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Leading Property
Gets the leading of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Leading As Double
'Usage

Dim instance As PDFFontMetrics
Dim value As Double

value = instance.Leading
public double Leading {get;}
public: __property double get_Leading();
public:
property double Leading {
   double get();
}

Property Value

A double value specifying the desired spacing between baselines of consecutives lines of text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


MaxWidth Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : MaxWidth Property
Gets the maximum width of glyphs in the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MaxWidth As Double
'Usage

Dim instance As PDFFontMetrics
Dim value As Double

value = instance.MaxWidth
public double MaxWidth {get;}
public: __property double get_MaxWidth();
public:
property double MaxWidth {
   double get();
}

Property Value

A double value specifying the maximum width of glyphs in the font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


Name Property (PDFFontMetrics)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Name Property
Gets the Postscript name of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As PDFFontMetrics
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

The name of the font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


StemH Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : StemH Property
Gets the horizontal stem of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property StemH As Double
'Usage

Dim instance As PDFFontMetrics
Dim value As Double

value = instance.StemH
public double StemH {get;}
public: __property double get_StemH();
public:
property double StemH {
   double get();
}

Property Value

A double value specifying the thickness, measured invertically, of the dominant horizontal stems of glyphs in the font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


StemV Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : StemV Property
Gets the vertical stem of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property StemV As Double
'Usage

Dim instance As PDFFontMetrics
Dim value As Double

value = instance.StemV
public double StemV {get;}
public: __property double get_StemV();
public:
property double StemV {
   double get();
}

Property Value

A double value specifying the thickness, measure horizontally, of the dominant vertical stems of glyphs in the font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


XHeight Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : XHeight Property
Gets the x height of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property XHeight As Double
'Usage

Dim instance As PDFFontMetrics
Dim value As Double

value = instance.XHeight
public double XHeight {get;}
public: __property double get_XHeight();
public:
property double XHeight {
   double get();
}

Property Value

A double value specifying the vertical coordinate of the top of flat non-ascending lowercase letters (like letter x), measured from the baseline.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


%%PageItemTitle%%

PostScriptFont Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class
Defines a particular format for text, including font face and size.
Object Model
PostScriptFont ClassPDFFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class PostScriptFont
   Inherits PDFFontBase
'Usage

Dim instance As PostScriptFont
public sealed class PostScriptFont : PDFFontBase
public __gc __sealed class PostScriptFont : public PDFFontBase
public ref class PostScriptFont sealed : public PDFFontBase
Remarks
A PostScript font is always loaded from disk. The metrics of the font are specified in an .afm file (Adobe Font Metrics) and the binary representation of the font is specified in a .pfb file (Printer Font Binary).

The font can be embedded or not in the pdf file. When the font is embedded in the pdf file, the most accurate results are obtained when the file is viewed and printed. The viewer will synthesize the correct appearance of the font based on the embedded data, and the bold and italic modifiers do not have any effect.

If the font is not embedded in the pdf file, the pdf viewer will load the font from the local machine and will use it for display. If the font is not installed on the local machine, then the pdf viewer will use a local font that will match closely the metrics of the font used in the pdf file.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.PostScriptFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

PostScriptFont Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

The following tables list the members exposed by PostScriptFont.

Public Constructors
 | Name | Description
Public Constructor | PostScriptFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PostScriptFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

PostScriptFont Constructor

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : PostScriptFont Constructor
Overload List
Overload | Description
PostScriptFont Constructor(String,String,Single,Boolean) | Initializes a new PostScriptFont object based on the given metrics and font data files.
PostScriptFont Constructor(PostScriptFont,Double) | Initializes a new PostScriptFont object based on an existing font object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%PageItemTitle%%

PostScriptFont Constructor(String,String,Single,Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class > PostScriptFont Constructor : PostScriptFont Constructor(String,String,Single,Boolean)
the full path to file containing the metrics for this PostScript font.
the full path to file containing the binary representation of this PostScript font.
the size of the font, in points.
a flag specifying whether the font should be embedded in the pdf file or not.
Initializes a new PostScriptFont object based on the given metrics and font data files.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal metricsFile As String, _
   ByVal fontDataFile As String, _
   ByVal size As Single, _
   ByVal embed As Boolean _
)
'Usage

Dim metricsFile As String
Dim fontDataFile As String
Dim size As Single
Dim embed As Boolean

Dim instance As New PostScriptFont(metricsFile, fontDataFile, size, embed)
public PostScriptFont(
   string metricsFile,
   string fontDataFile,
   float size,
   bool embed
)
public: PostScriptFont(
   string* metricsFile,
   string* fontDataFile,
   float size,
   bool embed
)
public:
PostScriptFont(
   String^ metricsFile,
   String^ fontDataFile,
   float size,
   bool embed
)

Parameters

metricsFile
the full path to file containing the metrics for this PostScript font.
fontDataFile
the full path to file containing the binary representation of this PostScript font.
size
the size of the font, in points.
embed
a flag specifying whether the font should be embedded in the pdf file or not.
Remarks
A PostScript font is always loaded from disk. The metrics of the font are specified using an .afm file (Adobe Font Metrics) or a .pfm file (Printer Font Metrics). The binary representation of the font is specified using a .pfb file (Printer Font Binary).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members
Overload List


%%PageItemTitle%%

PostScriptFont Constructor(PostScriptFont,Double)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class > PostScriptFont Constructor : PostScriptFont Constructor(PostScriptFont,Double)
the original PostScriptFont object
the size of the new font
Initializes a new PostScriptFont object based on an existing font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PostScriptFont, _
   ByVal size As Double _
)
'Usage

Dim font As PostScriptFont
Dim size As Double

Dim instance As New PostScriptFont(font, size)
public PostScriptFont(
   PostScriptFont font,
   double size
)
public: PostScriptFont(
   PostScriptFont* font,
   double size
)
public:
PostScriptFont(
   PostScriptFont^ font,
   double size
)

Parameters

font
the original PostScriptFont object
size
the size of the new font
Remarks
Use this constructor when the same font (the same face)) is used multiple time but at different sizes. This will avoid reparsing the font file. Because the some of the internal structures are shared by the new and the original font object, changing the bold and italic modifiers for one font object, will also update the other font object. This is because the values of this modifiers are built in the font data. All the other properties of the font (underline, overline, strikethrough, size) can be changed without side effects. The embedding can not be changed for the new font, if the original font is embedded, this new font will use the same embedded data, in order to avoid redundancy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members
Overload List


%%PageItemTitle%% $$Methods$$

PostScriptFont Class Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

For a list of all members of this type, see PostScriptFont members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PostScriptFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method (PostScriptFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As PostScriptFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%PageItemTitle%% $$Properties$$

PostScriptFont Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

For a list of all members of this type, see PostScriptFont members.

Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PostScriptFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Bold Property (PostScriptFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : Bold Property
Gets of sets whether the font object is bold or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Property Bold As Boolean
'Usage

Dim instance As PostScriptFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public override bool Bold {get; set;}
public: __property bool get_Bold() override;
public: __property void set_Bold(
   bool value
) override;
public:
property bool Bold {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this Font object is bold; otherwise, false.
Remarks
When the Type1 font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate weight (bold or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct weight (assuming the font is installed on the local computer). It the bold face of the font is not installed on the local machine, and only the regular face is installed, the pdf viewer will synthesize the bold appearance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members


Italic Property (PostScriptFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : Italic Property
Gets of sets whether the font object is italic or not
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Property Italic As Boolean
'Usage

Dim instance As PostScriptFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public override bool Italic {get; set;}
public: __property bool get_Italic() override;
public: __property void set_Italic(
   bool value
) override;
public:
property bool Italic {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this Font object is italic; otherwise, false.
Remarks
When the Type1 font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate face (italic or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct face (assuming the font is installed on the local computer).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%PageItemTitle%%

TrueTypeFont Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class
Defines a TrueType font that can be used in a PDF file.
Object Model
TrueTypeFont ClassPDFFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class TrueTypeFont
   Inherits PDFFontBase
'Usage

Dim instance As TrueTypeFont
public class TrueTypeFont : PDFFontBase
public __gc class TrueTypeFont : public PDFFontBase
public ref class TrueTypeFont : public PDFFontBase
Remarks

The font can be embedded or not in the pdf file. When the font is embedded in the pdf file, the most accurate results are obtained when the file is viewed and printed. The viewer will synthesize the correct appearance of the font based on the embedded data, and the bold and italic modifiers do not have any effect.

If the font is not embedded in the pdf file, the pdf viewer will load the font from the local machine and will use it for display. If the font is not installed on the local machine, then the pdf viewer will use a local font that will match closely the metrics of the font used in the pdf file.

When the font is not emdedded in the pdf file, the bold and italic modifiers have the following effect: assuming that the font used for displaying text has only a regular face, these modifiers force the pdf viewer to synthesize the bold or italic appearance of the font. But the regular version of the font must be installed on the machine where the pdf file is viewed.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.TrueTypeFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

TrueTypeFont Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

The following tables list the members exposed by TrueTypeFont.

Public Constructors
 | Name | Description
Public Constructor | TrueTypeFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Name | Gets the name of this font.
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | SubsetFont | Gets or sets a value indicating whether font data should be subset.
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | GetGlyphEmWidth | Gets the Em width of the given glyph when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

TrueTypeFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

TrueTypeFont Constructor

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : TrueTypeFont Constructor
Overload List
Overload | Description
TrueTypeFont Constructor(String,Double,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(String,Double,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(String,Int32,Double,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(Stream,Double,Boolean) | Initializes a new TrueTypeFont object based on the given font stream and size.
TrueTypeFont Constructor(Stream,Double,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font stream and size.
TrueTypeFont Constructor(Stream,Int32,Double,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font stream and size.
TrueTypeFont Constructor(Font,Boolean) | Initializes a new TrueTypeFont object based on a System.Drawing.Font object.
TrueTypeFont Constructor(Font,Boolean,Boolean) | Initializes a new TrueTypeFont object based on a System.Drawing.Font object.
TrueTypeFont Constructor(TrueTypeFont,Double) | Initializes a new TrueTypeFont object based on an existing font object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


%%PageItemTitle%%

TrueTypeFont Constructor(String,Double,Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Double,Boolean)
the full path to the font file.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on the given font file and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeFontFile As String, _
   ByVal size As Double, _
   ByVal embed As Boolean _
)
'Usage

Dim trueTypeFontFile As String
Dim size As Double
Dim embed As Boolean

Dim instance As New TrueTypeFont(trueTypeFontFile, size, embed)
public TrueTypeFont(
   string trueTypeFontFile,
   double size,
   bool embed
)
public: TrueTypeFont(
   string* trueTypeFontFile,
   double size,
   bool embed
)
public:
TrueTypeFont(
   String^ trueTypeFontFile,
   double size,
   bool embed
)

Parameters

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(String,Double,Boolean,Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Double,Boolean,Boolean)
the full path to the font file.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font file and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeFontFile As String, _
   ByVal size As Double, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim trueTypeFontFile As String
Dim size As Double
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(trueTypeFontFile, size, embed, unicode)
public TrueTypeFont(
   string trueTypeFontFile,
   double size,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   string* trueTypeFontFile,
   double size,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   String^ trueTypeFontFile,
   double size,
   bool embed,
   bool unicode
)

Parameters

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(String,Int32,Double,Boolean,Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Int32,Double,Boolean,Boolean)
the full path to the TrueType collection file.
The index of the font in the collection.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font file and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeCollectionFile As String, _
   ByVal fontIndex As Integer, _
   ByVal size As Double, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim trueTypeCollectionFile As String
Dim fontIndex As Integer
Dim size As Double
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(trueTypeCollectionFile, fontIndex, size, embed, unicode)
public TrueTypeFont(
   string trueTypeCollectionFile,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   string* trueTypeCollectionFile,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   String^ trueTypeCollectionFile,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)

Parameters

trueTypeCollectionFile
the full path to the TrueType collection file.
fontIndex
The index of the font in the collection.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Stream,Double,Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Stream,Double,Boolean)
a stream object with font data.
the size of the font, in points.
true if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on the given font stream and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeFontStream As Stream, _
   ByVal size As Double, _
   ByVal embed As Boolean _
)
'Usage

Dim trueTypeFontStream As Stream
Dim size As Double
Dim embed As Boolean

Dim instance As New TrueTypeFont(trueTypeFontStream, size, embed)
public TrueTypeFont(
   Stream trueTypeFontStream,
   double size,
   bool embed
)
public: TrueTypeFont(
   Stream* trueTypeFontStream,
   double size,
   bool embed
)
public:
TrueTypeFont(
   Stream^ trueTypeFontStream,
   double size,
   bool embed
)

Parameters

trueTypeFontStream
a stream object with font data.
size
the size of the font, in points.
embed
true if the font file should be embedded in the pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Stream,Double,Boolean,Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Stream,Double,Boolean,Boolean)
a stream object with font data.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font stream and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeFontStream As Stream, _
   ByVal size As Double, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim trueTypeFontStream As Stream
Dim size As Double
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(trueTypeFontStream, size, embed, unicode)
public TrueTypeFont(
   Stream trueTypeFontStream,
   double size,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   Stream* trueTypeFontStream,
   double size,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   Stream^ trueTypeFontStream,
   double size,
   bool embed,
   bool unicode
)

Parameters

trueTypeFontStream
a stream object with font data.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Remarks
The font is always loaded from disk.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Stream,Int32,Double,Boolean,Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Stream,Int32,Double,Boolean,Boolean)
a stream object with TrueType collection data.
The index of the font in the collection.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font stream and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeCollectionStream As Stream, _
   ByVal fontIndex As Integer, _
   ByVal size As Double, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim trueTypeCollectionStream As Stream
Dim fontIndex As Integer
Dim size As Double
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(trueTypeCollectionStream, fontIndex, size, embed, unicode)
public TrueTypeFont(
   Stream trueTypeCollectionStream,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   Stream* trueTypeCollectionStream,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   Stream^ trueTypeCollectionStream,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)

Parameters

trueTypeCollectionStream
a stream object with TrueType collection data.
fontIndex
The index of the font in the collection.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Remarks
The font is always loaded from disk.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Font,Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Font,Boolean)
the System.Drawing.Font object.
true, if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on a System.Drawing.Font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As Font, _
   ByVal embed As Boolean _
)
'Usage

Dim font As Font
Dim embed As Boolean

Dim instance As New TrueTypeFont(font, embed)
public TrueTypeFont(
   Font font,
   bool embed
)
public: TrueTypeFont(
   Font* font,
   bool embed
)
public:
TrueTypeFont(
   Font^ font,
   bool embed
)

Parameters

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Font,Boolean,Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Font,Boolean,Boolean)
the System.Drawing.Font object.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on a System.Drawing.Font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As Font, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim font As Font
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(font, embed, unicode)
public TrueTypeFont(
   Font font,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   Font* font,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   Font^ font,
   bool embed,
   bool unicode
)

Parameters

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(TrueTypeFont,Double)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(TrueTypeFont,Double)
the original TrueTypeFont object
the size of the new font
Initializes a new TrueTypeFont object based on an existing font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As TrueTypeFont, _
   ByVal size As Double _
)
'Usage

Dim font As TrueTypeFont
Dim size As Double

Dim instance As New TrueTypeFont(font, size)
public TrueTypeFont(
   TrueTypeFont font,
   double size
)
public: TrueTypeFont(
   TrueTypeFont* font,
   double size
)
public:
TrueTypeFont(
   TrueTypeFont^ font,
   double size
)

Parameters

font
the original TrueTypeFont object
size
the size of the new font
Remarks
Use this constructor when the same font (the same face)) is used multiple time but at different sizes. This will avoid reparsing the font file. Because the some of the internal structures are shared by the new and the original font object, changing the bold and italic modifiers for one font object, will also update the other font object. This is because the values of this modifiers are built in the font data. All the other properties of the font (underline, overline, strikethrough, size) can be changed without side effects. The embedding can not be changed for the new font, if the original font is embedded, this new font will use the same embedded data, in order to avoid redundancy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%% $$Methods$$

TrueTypeFont Class Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

For a list of all members of this type, see TrueTypeFont members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | GetGlyphEmWidth | Gets the Em width of the given glyph when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

TrueTypeFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method (TrueTypeFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As TrueTypeFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a double value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


GetGlyphEmWidth Method

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : GetGlyphEmWidth Method
the index of the glyph to get its width
Gets the Em width of the given glyph when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetGlyphEmWidth( _
   ByVal glyph As Integer _
) As Integer
'Usage

Dim instance As TrueTypeFont
Dim glyph As Integer
Dim value As Integer

value = instance.GetGlyphEmWidth(glyph)
public int GetGlyphEmWidth(
   int glyph
)
public: int GetGlyphEmWidth(
   int glyph
)
public:
int GetGlyphEmWidth(
   int glyph
)

Parameters

glyph
the index of the glyph to get its width

Return Value

The width of the glyph in Em units.
Remarks
To scale this value to font's current size, divide it by 2048 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetGlyphEmWidth(glyph) / 2048.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


%%PageItemTitle%% $$Properties$$

TrueTypeFont Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

For a list of all members of this type, see TrueTypeFont members.

Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Name | Gets the name of this font.
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | SubsetFont | Gets or sets a value indicating whether font data should be subset.
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

TrueTypeFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Bold Property (TrueTypeFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : Bold Property
Gets or sets whether the font object is bold or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Bold As Boolean
'Usage

Dim instance As TrueTypeFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public override bool Bold {get; set;}
public: __property bool get_Bold() override;
public: __property void set_Bold(
   bool value
) override;
public:
property bool Bold {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this font object is bold; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


Italic Property (TrueTypeFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : Italic Property
Gets or sets whether the font object is italic or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Italic As Boolean
'Usage

Dim instance As TrueTypeFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public override bool Italic {get; set;}
public: __property bool get_Italic() override;
public: __property void set_Italic(
   bool value
) override;
public:
property bool Italic {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this font object is italic; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


Name Property (TrueTypeFont)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : Name Property
Gets the name of this font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As TrueTypeFont
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

The name of the font as it appears in the font file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


SubsetFont Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : SubsetFont Property
Gets or sets a value indicating whether font data should be subset.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubsetFont As Boolean
'Usage

Dim instance As TrueTypeFont
Dim value As Boolean

instance.SubsetFont = value

value = instance.SubsetFont
public bool SubsetFont {get; set;}
public: __property bool get_SubsetFont();
public: __property void set_SubsetFont(
   bool value
);
public:
property bool SubsetFont {
   bool get();
   void set (    bool value);
}

Property Value

If true, the font data is reduced strictly to the characters used in the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


%%PageItemTitle%%

Type0Font Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type0Font Class
Defines a generic Type0 font that can be used in a PDF file.
Object Model
Type0Font ClassPDFFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Type0Font
   Inherits PDFFontBase
'Usage

Dim instance As Type0Font
public class Type0Font : PDFFontBase
public __gc class Type0Font : public PDFFontBase
public ref class Type0Font : public PDFFontBase
Remarks
This class is for internal library use.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.Type0Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type0Font Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

Type0Font Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type0Font Class

The following tables list the members exposed by Type0Font.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

Type0Font Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Methods$$

Type0Font Class Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type0Font Class

For a list of all members of this type, see Type0Font members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

Type0Font Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method (Type0Font)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type0Font Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As Type0Font
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type0Font Class
Type0Font Members


%%PageItemTitle%%

Type3Font Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3Font Class
Defines a Type3 font.
Object Model
Type3Font ClassType3VisualCharCollection ClassPDFMatrix ClassPDFFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Type3Font
   Inherits PDFFontBase
'Usage

Dim instance As Type3Font
public class Type3Font : PDFFontBase
public __gc class Type3Font : public PDFFontBase
public ref class Type3Font : public PDFFontBase
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.Type3Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3Font Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

Type3Font Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3Font Class

The following tables list the members exposed by Type3Font.

Public Constructors
 | Name | Description
Public Constructor | Type3Font Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Characters | Gets the list of visual appearances for the characters in this font.
Public Property | FontBBox | Gets or sets the font bounding box.
Public Property | FontMatrix | Gets or sets the font matrix.
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Widths | Gets or sets the widths of the characters in this font.
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

Type3Font Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

Type3Font Constructor

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3Font Class : Type3Font Constructor
Overload List
Overload | Description
Type3Font Constructor() | Initializes a new Type3Font object.
Type3Font Constructor(String) | Initializes a new Type3Font object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3Font Class
Type3Font Members


%%PageItemTitle%%

Type3Font Constructor()

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3Font Class > Type3Font Constructor : Type3Font Constructor()
Initializes a new Type3Font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Type3Font()
public Type3Font()
public: Type3Font();
public:
Type3Font();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3Font Class
Type3Font Members
Overload List


%%PageItemTitle%%

Type3Font Constructor(String)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3Font Class > Type3Font Constructor : Type3Font Constructor(String)
The name of the font.
Initializes a new Type3Font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fontName As String _
)
'Usage

Dim fontName As String

Dim instance As New Type3Font(fontName)
public Type3Font(
   string fontName
)
public: Type3Font(
   string* fontName
)
public:
Type3Font(
   String^ fontName
)

Parameters

fontName
The name of the font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3Font Class
Type3Font Members
Overload List


%%PageItemTitle%% $$Methods$$

Type3Font Class Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3Font Class

For a list of all members of this type, see Type3Font members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

Type3Font Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method (Type3Font)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3Font Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As Type3Font
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3Font Class
Type3Font Members


%%PageItemTitle%% $$Properties$$

Type3Font Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3Font Class

For a list of all members of this type, see Type3Font members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Characters | Gets the list of visual appearances for the characters in this font.
Public Property | FontBBox | Gets or sets the font bounding box.
Public Property | FontMatrix | Gets or sets the font matrix.
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Widths | Gets or sets the widths of the characters in this font.
Top
See Also

Reference

Type3Font Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Characters Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3Font Class : Characters Property
Gets the list of visual appearances for the characters in this font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Characters As Type3VisualCharCollection
'Usage

Dim instance As Type3Font
Dim value As Type3VisualCharCollection

value = instance.Characters
public Type3VisualCharCollection Characters {get;}
public: __property Type3VisualCharCollection* get_Characters();
public:
property Type3VisualCharCollection^ Characters {
   Type3VisualCharCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3Font Class
Type3Font Members


FontBBox Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3Font Class : FontBBox Property
Gets or sets the font bounding box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontBBox As Double()
'Usage

Dim instance As Type3Font
Dim value() As Double

instance.FontBBox = value

value = instance.FontBBox
public double[] FontBBox {get; set;}
public: __property double[]* get_FontBBox();
public: __property void set_FontBBox(
   double[]* value
);
public:
property array<double>^ FontBBox {
   array<double>^ get();
   void set (    array<double>^ value);
}
Remarks
This array must have 4 elements. First 2 elements represent the (x,y) of the lower left corner, last 2 elements represent the (x,y) of the upper right corner
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3Font Class
Type3Font Members


FontMatrix Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3Font Class : FontMatrix Property
Gets or sets the font matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontMatrix As PDFMatrix
'Usage

Dim instance As Type3Font
Dim value As PDFMatrix

instance.FontMatrix = value

value = instance.FontMatrix
public PDFMatrix FontMatrix {get; set;}
public: __property PDFMatrix* get_FontMatrix();
public: __property void set_FontMatrix(
   PDFMatrix* value
);
public:
property PDFMatrix^ FontMatrix {
   PDFMatrix^ get();
   void set (    PDFMatrix^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3Font Class
Type3Font Members


Widths Property

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3Font Class : Widths Property
Gets or sets the widths of the characters in this font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Widths As Double()
'Usage

Dim instance As Type3Font
Dim value() As Double

instance.Widths = value

value = instance.Widths
public double[] Widths {get; set;}
public: __property double[]* get_Widths();
public: __property void set_Widths(
   double[]* value
);
public:
property array<double>^ Widths {
   array<double>^ get();
   void set (    array<double>^ value);
}
Remarks
This array must have 256 elements
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3Font Class
Type3Font Members


%%PageItemTitle%%

Type3VisualChar Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3VisualChar Class
Defines the visual appearance of a Type3 character.
Object Model
Type3VisualChar ClassPDFBasicCanvas Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Type3VisualChar
   Inherits O2S.Components.PDF4NET.PDFGraphicsContainer
'Usage

Dim instance As Type3VisualChar
public class Type3VisualChar : O2S.Components.PDF4NET.PDFGraphicsContainer
public __gc class Type3VisualChar : public O2S.Components.PDF4NET.PDFGraphicsContainer
public ref class Type3VisualChar : public O2S.Components.PDF4NET.PDFGraphicsContainer
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Fonts.Type3VisualChar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3VisualChar Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

Type3VisualChar Class Members
Properties Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3VisualChar Class

The following tables list the members exposed by Type3VisualChar.

Public Constructors
 | Name | Description
Public Constructor | Type3VisualChar Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas.
Top
Public Methods
 | Name | Description
Public Method | SetCharWidth | Sets the character width.
Top
See Also

Reference

Type3VisualChar Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

Type3VisualChar Constructor

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3VisualChar Class : Type3VisualChar Constructor
Overload List
Overload | Description
Type3VisualChar Constructor() | Initializes a new Type3VisualChar object.
Type3VisualChar Constructor(Boolean) | Initializes a new Type3VisualChar object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3VisualChar Class
Type3VisualChar Members


%%PageItemTitle%%

Type3VisualChar Constructor()

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3VisualChar Class > Type3VisualChar Constructor : Type3VisualChar Constructor()
Initializes a new Type3VisualChar object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Type3VisualChar()
public Type3VisualChar()
public: Type3VisualChar();
public:
Type3VisualChar();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3VisualChar Class
Type3VisualChar Members
Overload List


%%PageItemTitle%%

Type3VisualChar Constructor(Boolean)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3VisualChar Class > Type3VisualChar Constructor : Type3VisualChar Constructor(Boolean)
Initializes a new Type3VisualChar object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal includeColorInfo As Boolean _
)
'Usage

Dim includeColorInfo As Boolean

Dim instance As New Type3VisualChar(includeColorInfo)
public Type3VisualChar(
   bool includeColorInfo
)
public: Type3VisualChar(
   bool includeColorInfo
)
public:
Type3VisualChar(
   bool includeColorInfo
)

Parameters

includeColorInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3VisualChar Class
Type3VisualChar Members
Overload List


%%PageItemTitle%% $$Methods$$

Type3VisualChar Class Methods

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3VisualChar Class

For a list of all members of this type, see Type3VisualChar members.

Public Methods
 | Name | Description
Public Method | SetCharWidth | Sets the character width.
Top
See Also

Reference

Type3VisualChar Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


SetCharWidth Method

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3VisualChar Class : SetCharWidth Method
The width of the character.
Sets the character width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetCharWidth( _
   ByVal width As Double _
)
'Usage

Dim instance As Type3VisualChar
Dim width As Double

instance.SetCharWidth(width)
public void SetCharWidth(
   double width
)
public: void SetCharWidth(
   double width
)
public:
void SetCharWidth(
   double width
)

Parameters

width
The width of the character.
Remarks
The value provided as parameter must match the corresponding value set in the Type3Font.Widths array.
NOTE: This method must be called first before drawing anything on character's canvas.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3VisualChar Class
Type3VisualChar Members


%%PageItemTitle%% $$Properties$$

Type3VisualChar Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3VisualChar Class

For a list of all members of this type, see Type3VisualChar members.

Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas.
Top
See Also

Reference

Type3VisualChar Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Canvas Property (Type3VisualChar)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3VisualChar Class : Canvas Property
Gets the form XObject canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Canvas As PDFBasicCanvas
'Usage

Dim instance As Type3VisualChar
Dim value As PDFBasicCanvas

value = instance.Canvas
public PDFBasicCanvas Canvas {get;}
public: __property PDFBasicCanvas* get_Canvas();
public:
property PDFBasicCanvas^ Canvas {
   PDFBasicCanvas^ get();
}

Property Value

The drawing surface of the form XObject.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3VisualChar Class
Type3VisualChar Members


%%PageItemTitle%%

Type3VisualCharCollection Class
Members

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3VisualCharCollection Class
Defines a collection of Type3 characters.
Object Model
Type3VisualCharCollection ClassType3VisualChar Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class Type3VisualCharCollection
'Usage

Dim instance As Type3VisualCharCollection
[DefaultMember("Item")]
public class Type3VisualCharCollection
[DefaultMember("Item")]
public __gc class Type3VisualCharCollection
[DefaultMember("Item")]
public ref class Type3VisualCharCollection
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.Type3VisualCharCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3VisualCharCollection Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

Type3VisualCharCollection Class Members
Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3VisualCharCollection Class

The following tables list the members exposed by Type3VisualCharCollection.

Public Properties
 | Name | Description
Public Property | Item | Gets or sets the visual appearance corresponding to a character code.
Top
See Also

Reference

Type3VisualCharCollection Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Properties$$

Type3VisualCharCollection Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type3VisualCharCollection Class

For a list of all members of this type, see Type3VisualCharCollection members.

Public Properties
 | Name | Description
Public Property | Item | Gets or sets the visual appearance corresponding to a character code.
Top
See Also

Reference

Type3VisualCharCollection Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Item Property (Type3VisualCharCollection)

O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type3VisualCharCollection Class : Item Property
The character code.
Gets or sets the visual appearance corresponding to a character code.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal code As Byte _
) As Type3VisualChar
'Usage

Dim instance As Type3VisualCharCollection
Dim code As Byte
Dim value As Type3VisualChar

instance.Item(code) = value

value = instance.Item(code)
public Type3VisualChar this[
   byte code
]; {get; set;}
public: __property Type3VisualChar* get_Item   byte code
;
public: __property void set_Item   byte code,
   Type3VisualChar* value
;
public:
property Type3VisualChar^ default [byte] {
   Type3VisualChar^ get(byte code);
   void set (byte code, Type3VisualChar^ value);
}

Parameters

code
The character code.

Property Value

The visual appearance of the character.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type3VisualCharCollection Class
Type3VisualCharCollection Members


%%PageItemTitle%%

CJKFontFace Enumeration

O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFontFace Enumeration
Defines the available CJK fonts faces.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum CJKFontFace
   Inherits System.Enum
'Usage

Dim instance As CJKFontFace
public enum CJKFontFace : System.Enum
__value public enum CJKFontFace : public System.Enum
public enum class CJKFontFace : public System.Enum
Members
Member | Description
HanyangSystemsGothicMedium | The Hanyang Systems Gothic Medium korean font face.
HanyangSystemsShinMyeongJoMedium | The Hanyang Systems Shin MyeongJo Medium korean font face.
HeiseiKakuGothicW5 | The Heisei Kaku Gothic W5 japanese font face.
HeiseiMinchoW3 | The Heisei Mincho W3 japanese font face.
KozMinProVIRegular | KozMinProVI-Regular japanese font face.
MonotypeHeiMedium | The Monotype Hei Medium chinese traditional font face.
MonotypeSungLight | The Monotype Sung Light chinese traditional font face.
SinoTypeSongLight | The SinoType Song Light chinese simplified font face.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Fonts.CJKFontFace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

PDFFontFace Enumeration

O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontFace Enumeration
Specifies the available PDF fonts for drawing text on a page
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFontFace
   Inherits System.Enum
'Usage

Dim instance As PDFFontFace
public enum PDFFontFace : System.Enum
__value public enum PDFFontFace : public System.Enum
public enum class PDFFontFace : public System.Enum
Members
Member | Description
Courier | The Courier font
Helvetica | The Helvetica font
Symbol | The Symbol font
TimesRoman | The Times Roman font
ZapfDingbats | The ZapfDingbats font
Remarks
These fonts and their variations (bold, italic) are recongized and implemented by any PDF viewer.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontFace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Fonts Namespace


O2S.Components.PDF4NET.Graphics.Shadings Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFAxialShading | Defines an axial shading.
Class | PDFFunctionShading | Defines a function based shading.
Class | PDFRadialShading | Defines a radial shading, a blend between 2 circles.
Class | PDFShading | Defines the base class for all PDF shadings.
Enumerations
 | Enumeration | Description
Enumeration | PDFShadingType | Specifies the available shading types.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFAxialShading Class
Members

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFAxialShading Class
Defines an axial shading.
Object Model
PDFAxialShading ClassPDFColorSpace ClassPDFColor ClassPDFPoint ClassPDFFunction ClassPDFColor ClassPDFPoint Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAxialShading
   Inherits PDFShading
'Usage

Dim instance As PDFAxialShading
public class PDFAxialShading : PDFShading
public __gc class PDFAxialShading : public PDFShading
public ref class PDFAxialShading : public PDFShading
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shadings.PDFShading
O2S.Components.PDF4NET.Graphics.Shadings.PDFAxialShading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Members
O2S.Components.PDF4NET.Graphics.Shadings Namespace


%%PageItemTitle%% $$Members$$

PDFAxialShading Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFAxialShading Class

The following tables list the members exposed by PDFAxialShading.

Public Constructors
 | Name | Description
Public Constructor | PDFAxialShading Constructor | Initializes a new PDFAxialShading object.
Top
Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | Domain | Gets or sets the shading's domain.
Public Property | EndColor | Gets or sets the shading's end color.
Public Property | EndPoint | Gets or sets the shading's end point.
Public Property | ExtendEnd | Gets or sets a value indicating whether the shading should be extended beyond the end point.
Public Property | ExtendStart | Gets or sets a value indicating whether the shading should be extended beyond the start point.
Public Property | Function | Gets or sets the function that defines the shading.
Public Property | StartColor | Gets or sets the shading's start color.
Public Property | StartPoint | Gets or sets the shading's start point.
Public Property | Type | Gets the type of the shading. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Top
See Also

Reference

PDFAxialShading Class
O2S.Components.PDF4NET.Graphics.Shadings Namespace


%%PageItemTitle%%

PDFAxialShading Constructor

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFAxialShading Class : PDFAxialShading Constructor
Initializes a new PDFAxialShading object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFAxialShading()
public PDFAxialShading()
public: PDFAxialShading();
public:
PDFAxialShading();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Class
PDFAxialShading Members


%%PageItemTitle%% $$Properties$$

PDFAxialShading Class Properties

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFAxialShading Class

For a list of all members of this type, see PDFAxialShading members.

Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | Domain | Gets or sets the shading's domain.
Public Property | EndColor | Gets or sets the shading's end color.
Public Property | EndPoint | Gets or sets the shading's end point.
Public Property | ExtendEnd | Gets or sets a value indicating whether the shading should be extended beyond the end point.
Public Property | ExtendStart | Gets or sets a value indicating whether the shading should be extended beyond the start point.
Public Property | Function | Gets or sets the function that defines the shading.
Public Property | StartColor | Gets or sets the shading's start color.
Public Property | StartPoint | Gets or sets the shading's start point.
Public Property | Type | Gets the type of the shading. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Top
See Also

Reference

PDFAxialShading Class
O2S.Components.PDF4NET.Graphics.Shadings Namespace


Domain Property (PDFAxialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFAxialShading Class : Domain Property
Gets or sets the shading's domain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Domain As Double()
'Usage

Dim instance As PDFAxialShading
Dim value() As Double

instance.Domain = value

value = instance.Domain
public double[] Domain {get; set;}
public: __property double[]* get_Domain();
public: __property void set_Domain(
   double[]* value
);
public:
property array<double>^ Domain {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of two numbers [t0 t1] specifying the limiting values of a parametric variable t.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the domain array length is not equal to 2.
Remarks
The variable is considered to vary linearly between these two values as the color gradient varies between the starting and ending points of the axis. The variable t becomes the input argument to the color function(s).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Class
PDFAxialShading Members


EndColor Property (PDFAxialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFAxialShading Class : EndColor Property
Gets or sets the shading's end color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndColor As PDFColor
'Usage

Dim instance As PDFAxialShading
Dim value As PDFColor

instance.EndColor = value

value = instance.EndColor
public PDFColor EndColor {get; set;}
public: __property PDFColor* get_EndColor();
public: __property void set_EndColor(
   PDFColor* value
);
public:
property PDFColor^ EndColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

The end color of the shading.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the end color is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Class
PDFAxialShading Members


EndPoint Property

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFAxialShading Class : EndPoint Property
Gets or sets the shading's end point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndPoint As PDFPoint
'Usage

Dim instance As PDFAxialShading
Dim value As PDFPoint

instance.EndPoint = value

value = instance.EndPoint
public PDFPoint EndPoint {get; set;}
public: __property PDFPoint* get_EndPoint();
public: __property void set_EndPoint(
   PDFPoint* value
);
public:
property PDFPoint^ EndPoint {
   PDFPoint^ get();
   void set (    PDFPoint^ value);
}

Property Value

The point in the coordinate system of the target canvas where the shading ends.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Class
PDFAxialShading Members


ExtendEnd Property (PDFAxialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFAxialShading Class : ExtendEnd Property
Gets or sets a value indicating whether the shading should be extended beyond the end point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtendEnd As Boolean
'Usage

Dim instance As PDFAxialShading
Dim value As Boolean

instance.ExtendEnd = value

value = instance.ExtendEnd
public bool ExtendEnd {get; set;}
public: __property bool get_ExtendEnd();
public: __property void set_ExtendEnd(
   bool value
);
public:
property bool ExtendEnd {
   bool get();
   void set (    bool value);
}

Property Value

True if the shading should be extended beyond the end point, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Class
PDFAxialShading Members


ExtendStart Property (PDFAxialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFAxialShading Class : ExtendStart Property
Gets or sets a value indicating whether the shading should be extended beyond the start point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtendStart As Boolean
'Usage

Dim instance As PDFAxialShading
Dim value As Boolean

instance.ExtendStart = value

value = instance.ExtendStart
public bool ExtendStart {get; set;}
public: __property bool get_ExtendStart();
public: __property void set_ExtendStart(
   bool value
);
public:
property bool ExtendStart {
   bool get();
   void set (    bool value);
}

Property Value

True if the shading should be extended beyond the start point, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Class
PDFAxialShading Members


Function Property (PDFAxialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFAxialShading Class : Function Property
Gets or sets the function that defines the shading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Function As PDFFunction
'Usage

Dim instance As PDFAxialShading
Dim value As PDFFunction

instance.Function = value

value = instance.Function
public PDFFunction Function {get; set;}
public: __property PDFFunction* get_Function();
public: __property void set_Function(
   PDFFunction* value
);
public:
property PDFFunction^ Function {
   PDFFunction^ get();
   void set (    PDFFunction^ value);
}

Property Value

A 1-in, n-out function, where n is the number of color components in the shading dictionary's color space
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the function is null.
Remarks
The function is called with values of the parametric variable t in the domain defined by the Domain entry.
If the function is changed to a type other than Type2 then the shading colors must be set by setting the proper values on the function and not using the StartColor and EndColor properties on the shading.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Class
PDFAxialShading Members


StartColor Property (PDFAxialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFAxialShading Class : StartColor Property
Gets or sets the shading's start color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartColor As PDFColor
'Usage

Dim instance As PDFAxialShading
Dim value As PDFColor

instance.StartColor = value

value = instance.StartColor
public PDFColor StartColor {get; set;}
public: __property PDFColor* get_StartColor();
public: __property void set_StartColor(
   PDFColor* value
);
public:
property PDFColor^ StartColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

The start color of the shading.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the start color is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Class
PDFAxialShading Members


StartPoint Property

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFAxialShading Class : StartPoint Property
Gets or sets the shading's start point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartPoint As PDFPoint
'Usage

Dim instance As PDFAxialShading
Dim value As PDFPoint

instance.StartPoint = value

value = instance.StartPoint
public PDFPoint StartPoint {get; set;}
public: __property PDFPoint* get_StartPoint();
public: __property void set_StartPoint(
   PDFPoint* value
);
public:
property PDFPoint^ StartPoint {
   PDFPoint^ get();
   void set (    PDFPoint^ value);
}

Property Value

The point in the coordinate system of the target canvas where the shading begins.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShading Class
PDFAxialShading Members


%%PageItemTitle%%

PDFFunctionShading Class
Members

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFFunctionShading Class
Defines a function based shading.
Object Model
PDFFunctionShading ClassPDFColorSpace ClassPDFFunction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFunctionShading
   Inherits PDFShading
'Usage

Dim instance As PDFFunctionShading
public class PDFFunctionShading : PDFShading
public __gc class PDFFunctionShading : public PDFShading
public ref class PDFFunctionShading : public PDFShading
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shadings.PDFShading
O2S.Components.PDF4NET.Graphics.Shadings.PDFFunctionShading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunctionShading Members
O2S.Components.PDF4NET.Graphics.Shadings Namespace


%%PageItemTitle%% $$Members$$

PDFFunctionShading Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFFunctionShading Class

The following tables list the members exposed by PDFFunctionShading.

Public Constructors
 | Name | Description
Public Constructor | PDFFunctionShading Constructor | Initializes a new PDFFunctionShading object.
Top
Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | Domain | Gets or sets the shading's domain.
Public Property | Function | Gets or sets the function that defines the shading.
Public Property | Matrix | Gets or sets the shading's matrix.
Public Property | Type | Gets the type of the shading. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Top
See Also

Reference

PDFFunctionShading Class
O2S.Components.PDF4NET.Graphics.Shadings Namespace


%%PageItemTitle%%

PDFFunctionShading Constructor

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFFunctionShading Class : PDFFunctionShading Constructor
Initializes a new PDFFunctionShading object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFunctionShading()
public PDFFunctionShading()
public: PDFFunctionShading();
public:
PDFFunctionShading();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunctionShading Class
PDFFunctionShading Members


%%PageItemTitle%% $$Properties$$

PDFFunctionShading Class Properties

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFFunctionShading Class

For a list of all members of this type, see PDFFunctionShading members.

Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | Domain | Gets or sets the shading's domain.
Public Property | Function | Gets or sets the function that defines the shading.
Public Property | Matrix | Gets or sets the shading's matrix.
Public Property | Type | Gets the type of the shading. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Top
See Also

Reference

PDFFunctionShading Class
O2S.Components.PDF4NET.Graphics.Shadings Namespace


Domain Property (PDFFunctionShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFFunctionShading Class : Domain Property
Gets or sets the shading's domain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Domain As Double()
'Usage

Dim instance As PDFFunctionShading
Dim value() As Double

instance.Domain = value

value = instance.Domain
public double[] Domain {get; set;}
public: __property double[]* get_Domain();
public: __property void set_Domain(
   double[]* value
);
public:
property array<double>^ Domain {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of four numbers [xmin xmax ymin ymax] specifying the rectangular domain of coordinates over which the color function(s) are defined
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the domain array length is not equal to 4.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunctionShading Class
PDFFunctionShading Members


Function Property (PDFFunctionShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFFunctionShading Class : Function Property
Gets or sets the function that defines the shading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Function As PDFFunction
'Usage

Dim instance As PDFFunctionShading
Dim value As PDFFunction

instance.Function = value

value = instance.Function
public PDFFunction Function {get; set;}
public: __property PDFFunction* get_Function();
public: __property void set_Function(
   PDFFunction* value
);
public:
property PDFFunction^ Function {
   PDFFunction^ get();
   void set (    PDFFunction^ value);
}

Property Value

A 2-in, n-out function, where n is the number of color components in the shading dictionary's color space
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the function is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunctionShading Class
PDFFunctionShading Members


Matrix Property (PDFFunctionShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFFunctionShading Class : Matrix Property
Gets or sets the shading's matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Matrix As Double()
'Usage

Dim instance As PDFFunctionShading
Dim value() As Double

instance.Matrix = value

value = instance.Matrix
public double[] Matrix {get; set;}
public: __property double[]* get_Matrix();
public: __property void set_Matrix(
   double[]* value
);
public:
property array<double>^ Matrix {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of six numbers specifying a transformation matrix mapping the coordinate space specified by the Domain entry into the shading's target coordinate space.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the matrix array length is not equal to 6.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFunctionShading Class
PDFFunctionShading Members


%%PageItemTitle%%

PDFRadialShading Class
Members

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFRadialShading Class
Defines a radial shading, a blend between 2 circles.
Object Model
PDFRadialShading ClassPDFColorSpace ClassPDFPoint ClassPDFColor ClassPDFFunction ClassPDFPoint ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRadialShading
   Inherits PDFShading
'Usage

Dim instance As PDFRadialShading
public class PDFRadialShading : PDFShading
public __gc class PDFRadialShading : public PDFShading
public ref class PDFRadialShading : public PDFShading
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shadings.PDFShading
O2S.Components.PDF4NET.Graphics.Shadings.PDFRadialShading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Members
O2S.Components.PDF4NET.Graphics.Shadings Namespace


%%PageItemTitle%% $$Members$$

PDFRadialShading Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFRadialShading Class

The following tables list the members exposed by PDFRadialShading.

Public Constructors
 | Name | Description
Public Constructor | PDFRadialShading Constructor | Initializes a new PDFRadialShading object.
Top
Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | Domain | Gets or sets the shading's domain.
Public Property | EndCircleCenter | Gets or sets the center of the shading's end circle.
Public Property | EndCircleRadius | Gets or sets the radius of the end circle.
Public Property | EndColor | Gets or sets the shading's end color.
Public Property | ExtendEnd | Gets or sets a value indicating whether the shading should be extended beyond the end circle.
Public Property | ExtendStart | Gets or sets a value indicating whether the shading should be extended beyond the start circle.
Public Property | Function | Gets or sets the function that defines the shading.
Public Property | StartCircleCenter | Gets or sets the center of the shading's start circle.
Public Property | StartCircleRadius | Gets or sets the radius of the start circle.
Public Property | StartColor | Gets or sets the shading's start color.
Public Property | Type | Gets the type of the shading. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Top
See Also

Reference

PDFRadialShading Class
O2S.Components.PDF4NET.Graphics.Shadings Namespace


%%PageItemTitle%%

PDFRadialShading Constructor

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : PDFRadialShading Constructor
Initializes a new PDFRadialShading object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRadialShading()
public PDFRadialShading()
public: PDFRadialShading();
public:
PDFRadialShading();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


%%PageItemTitle%% $$Properties$$

PDFRadialShading Class Properties

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFRadialShading Class

For a list of all members of this type, see PDFRadialShading members.

Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Public Property | Domain | Gets or sets the shading's domain.
Public Property | EndCircleCenter | Gets or sets the center of the shading's end circle.
Public Property | EndCircleRadius | Gets or sets the radius of the end circle.
Public Property | EndColor | Gets or sets the shading's end color.
Public Property | ExtendEnd | Gets or sets a value indicating whether the shading should be extended beyond the end circle.
Public Property | ExtendStart | Gets or sets a value indicating whether the shading should be extended beyond the start circle.
Public Property | Function | Gets or sets the function that defines the shading.
Public Property | StartCircleCenter | Gets or sets the center of the shading's start circle.
Public Property | StartCircleRadius | Gets or sets the radius of the start circle.
Public Property | StartColor | Gets or sets the shading's start color.
Public Property | Type | Gets the type of the shading. (Inherited from O2S.Components.PDF4NET.Graphics.Shadings.PDFShading)
Top
See Also

Reference

PDFRadialShading Class
O2S.Components.PDF4NET.Graphics.Shadings Namespace


Domain Property (PDFRadialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : Domain Property
Gets or sets the shading's domain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Domain As Double()
'Usage

Dim instance As PDFRadialShading
Dim value() As Double

instance.Domain = value

value = instance.Domain
public double[] Domain {get; set;}
public: __property double[]* get_Domain();
public: __property void set_Domain(
   double[]* value
);
public:
property array<double>^ Domain {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of two numbers [t0 t1] specifying the limiting values of a parametric variable t.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the domain array length is not equal to 2.
Remarks
The variable is considered to vary linearly between these two values as the color gradient varies between the starting and ending circles. The variable t becomes the input argument to the color function(s).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


EndCircleCenter Property

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : EndCircleCenter Property
Gets or sets the center of the shading's end circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndCircleCenter As PDFPoint
'Usage

Dim instance As PDFRadialShading
Dim value As PDFPoint

instance.EndCircleCenter = value

value = instance.EndCircleCenter
public PDFPoint EndCircleCenter {get; set;}
public: __property PDFPoint* get_EndCircleCenter();
public: __property void set_EndCircleCenter(
   PDFPoint* value
);
public:
property PDFPoint^ EndCircleCenter {
   PDFPoint^ get();
   void set (    PDFPoint^ value);
}

Property Value

The point in the coordinate system of the target canvas where the end circle of the shading is located.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


EndCircleRadius Property

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : EndCircleRadius Property
Gets or sets the radius of the end circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndCircleRadius As Double
'Usage

Dim instance As PDFRadialShading
Dim value As Double

instance.EndCircleRadius = value

value = instance.EndCircleRadius
public double EndCircleRadius {get; set;}
public: __property double get_EndCircleRadius();
public: __property void set_EndCircleRadius(
   double value
);
public:
property double EndCircleRadius {
   double get();
   void set (    double value);
}

Property Value

The radius of the end circle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


EndColor Property (PDFRadialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : EndColor Property
Gets or sets the shading's end color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndColor As PDFColor
'Usage

Dim instance As PDFRadialShading
Dim value As PDFColor

instance.EndColor = value

value = instance.EndColor
public PDFColor EndColor {get; set;}
public: __property PDFColor* get_EndColor();
public: __property void set_EndColor(
   PDFColor* value
);
public:
property PDFColor^ EndColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

The end color of the shading.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the end color is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


ExtendEnd Property (PDFRadialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : ExtendEnd Property
Gets or sets a value indicating whether the shading should be extended beyond the end circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtendEnd As Boolean
'Usage

Dim instance As PDFRadialShading
Dim value As Boolean

instance.ExtendEnd = value

value = instance.ExtendEnd
public bool ExtendEnd {get; set;}
public: __property bool get_ExtendEnd();
public: __property void set_ExtendEnd(
   bool value
);
public:
property bool ExtendEnd {
   bool get();
   void set (    bool value);
}

Property Value

True if the shading should be extended beyond the end circle, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


ExtendStart Property (PDFRadialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : ExtendStart Property
Gets or sets a value indicating whether the shading should be extended beyond the start circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtendStart As Boolean
'Usage

Dim instance As PDFRadialShading
Dim value As Boolean

instance.ExtendStart = value

value = instance.ExtendStart
public bool ExtendStart {get; set;}
public: __property bool get_ExtendStart();
public: __property void set_ExtendStart(
   bool value
);
public:
property bool ExtendStart {
   bool get();
   void set (    bool value);
}

Property Value

True if the shading should be extended beyond the start circle, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


Function Property (PDFRadialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : Function Property
Gets or sets the function that defines the shading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Function As PDFFunction
'Usage

Dim instance As PDFRadialShading
Dim value As PDFFunction

instance.Function = value

value = instance.Function
public PDFFunction Function {get; set;}
public: __property PDFFunction* get_Function();
public: __property void set_Function(
   PDFFunction* value
);
public:
property PDFFunction^ Function {
   PDFFunction^ get();
   void set (    PDFFunction^ value);
}

Property Value

A 1-in, n-out function, where n is the number of color components in the shading dictionary's color space
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the function is null.
Remarks
The function is called with values of the parametric variable t in the domain defined by the Domain entry.
If the function is changed to a type other than Type2 then the shading colors must be set by setting the proper values on the function and not using the StartColor and EndColor properties on the shading.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


StartCircleCenter Property

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : StartCircleCenter Property
Gets or sets the center of the shading's start circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartCircleCenter As PDFPoint
'Usage

Dim instance As PDFRadialShading
Dim value As PDFPoint

instance.StartCircleCenter = value

value = instance.StartCircleCenter
public PDFPoint StartCircleCenter {get; set;}
public: __property PDFPoint* get_StartCircleCenter();
public: __property void set_StartCircleCenter(
   PDFPoint* value
);
public:
property PDFPoint^ StartCircleCenter {
   PDFPoint^ get();
   void set (    PDFPoint^ value);
}

Property Value

The point in the coordinate system of the target canvas where the start circle of the shading is located.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


StartCircleRadius Property

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : StartCircleRadius Property
Gets or sets the radius of the start circle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartCircleRadius As Double
'Usage

Dim instance As PDFRadialShading
Dim value As Double

instance.StartCircleRadius = value

value = instance.StartCircleRadius
public double StartCircleRadius {get; set;}
public: __property double get_StartCircleRadius();
public: __property void set_StartCircleRadius(
   double value
);
public:
property double StartCircleRadius {
   double get();
   void set (    double value);
}

Property Value

The radius of the start circle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


StartColor Property (PDFRadialShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFRadialShading Class : StartColor Property
Gets or sets the shading's start color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartColor As PDFColor
'Usage

Dim instance As PDFRadialShading
Dim value As PDFColor

instance.StartColor = value

value = instance.StartColor
public PDFColor StartColor {get; set;}
public: __property PDFColor* get_StartColor();
public: __property void set_StartColor(
   PDFColor* value
);
public:
property PDFColor^ StartColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

The start color of the shading.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the start color is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadialShading Class
PDFRadialShading Members


%%PageItemTitle%%

PDFShading Class
Members

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFShading Class
Defines the base class for all PDF shadings.
Object Model
PDFShading ClassPDFColorSpace Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFShading
'Usage

Dim instance As PDFShading
public class PDFShading
public __gc class PDFShading
public ref class PDFShading
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shadings.PDFShading
O2S.Components.PDF4NET.Graphics.Shadings.PDFAxialShading
O2S.Components.PDF4NET.Graphics.Shadings.PDFFunctionShading
O2S.Components.PDF4NET.Graphics.Shadings.PDFRadialShading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShading Members
O2S.Components.PDF4NET.Graphics.Shadings Namespace


%%PageItemTitle%% $$Members$$

PDFShading Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFShading Class

The following tables list the members exposed by PDFShading.

Public Constructors
 | Name | Description
Public Constructor | PDFShading Constructor | Initializes a new PDFShading object.
Top
Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts.
Public Property | ColorSpace | Gets or sets the shading's colorspace.
Public Property | Type | Gets the type of the shading.
Top
See Also

Reference

PDFShading Class
O2S.Components.PDF4NET.Graphics.Shadings Namespace


%%PageItemTitle%%

PDFShading Constructor

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFShading Class : PDFShading Constructor
Initializes a new PDFShading object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFShading()
public PDFShading()
public: PDFShading();
public:
PDFShading();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShading Class
PDFShading Members


%%PageItemTitle%% $$Properties$$

PDFShading Class Properties

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFShading Class

For a list of all members of this type, see PDFShading members.

Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts.
Public Property | ColorSpace | Gets or sets the shading's colorspace.
Public Property | Type | Gets the type of the shading.
Top
See Also

Reference

PDFShading Class
O2S.Components.PDF4NET.Graphics.Shadings Namespace


AntiAlias Property

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFShading Class : AntiAlias Property
Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AntiAlias As Boolean
'Usage

Dim instance As PDFShading
Dim value As Boolean

instance.AntiAlias = value

value = instance.AntiAlias
public bool AntiAlias {get; set;}
public: __property bool get_AntiAlias();
public: __property void set_AntiAlias(
   bool value
);
public:
property bool AntiAlias {
   bool get();
   void set (    bool value);
}

Property Value

True if the antialiasing artifacts should be filtered, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShading Class
PDFShading Members


ColorSpace Property (PDFShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFShading Class : ColorSpace Property
Gets or sets the shading's colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorSpace As PDFColorSpace
'Usage

Dim instance As PDFShading
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public PDFColorSpace ColorSpace {get; set;}
public: __property PDFColorSpace* get_ColorSpace();
public: __property void set_ColorSpace(
   PDFColorSpace* value
);
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The color space in which color values are expressed.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the colorspace is set to null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShading Class
PDFShading Members


Type Property (PDFShading)

O2S.Components.PDF4NET.Graphics.Shadings Namespace > PDFShading Class : Type Property
Gets the type of the shading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PDFShadingType
'Usage

Dim instance As PDFShading
Dim value As PDFShadingType

value = instance.Type
public PDFShadingType Type {get;}
public: __property PDFShadingType get_Type();
public:
property PDFShadingType Type {
   PDFShadingType get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShading Class
PDFShading Members


%%PageItemTitle%%

PDFShadingType Enumeration

O2S.Components.PDF4NET.Graphics.Shadings Namespace : PDFShadingType Enumeration
Specifies the available shading types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFShadingType
   Inherits System.Enum
'Usage

Dim instance As PDFShadingType
public enum PDFShadingType : System.Enum
__value public enum PDFShadingType : public System.Enum
public enum class PDFShadingType : public System.Enum
Members
Member | Description
Axial | Axial shading.
Radial | Radial shading.
Unknown | Unknown shading.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shadings.PDFShadingType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shadings Namespace


O2S.Components.PDF4NET.Graphics.Shapes Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFCcittImage | Defines a PDF image in CCITT Fax format.
Class | PDFFormXObject | Defines a PDF form XObject.
Class | PDFImage | Defines an image specified by a pair of coordinates, a width, and a height.
Class | PDFJpeg2000Image | Defines a PDF image in JPEG2000 format.
Class | PDFJpegImage | Defines a PDF image in JPEG format.
Class | PDFMetafile | Defines a Windows metafile object.
Class | PDFPath | Represents a series of connected lines and curves.
Class | PDFRawImage | Defines a PDF image in RAW format.
Class | PDFTextFormatOptions | Defines the available formatting options for a text box
Enumerations
 | Enumeration | Description
Enumeration | PDFCcittFaxCompression | Specifies the available CCITT fax compression modes.
Enumeration | PDFClipText | Specifies the available cliping modes when displaying a text box
Enumeration | PDFImageCompression | Specifies the available compression methods for storing an image in the PDF file.
Enumeration | PDFKeepAspectRatio | Specifies the available modes to resize an image when it is drawn on the page.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFCcittImage Class
Members

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFCcittImage Class
Defines a PDF image in CCITT Fax format.
Object Model
PDFCcittImage ClassPDFColorSpace ClassPDFDictionary ClassPDFBaseImageMask Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCcittImage
   Inherits PDFImage
'Usage

Dim instance As PDFCcittImage
public class PDFCcittImage : PDFImage
public __gc class PDFCcittImage : public PDFImage
public ref class PDFCcittImage : public PDFImage
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFCcittImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCcittImage Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFCcittImage Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFCcittImage Class

The following tables list the members exposed by PDFCcittImage.

Public Constructors
 | Name | Description
Public Constructor | PDFCcittImage Constructor | Initializes a new PDFCcittImage object.
Top
Public Properties
 | Name | Description
Public Property | BlackIs1 | Gets or sets a value indicating how the image data should be interpreted.
Public Property | ColorSpace | Gets or sets the image colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Compression | Gets or sets the compression method used by the image data.
Public Property | Dictionary | Gets the image dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top
See Also

Reference

PDFCcittImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFCcittImage Constructor

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : PDFCcittImage Constructor
Image data using CCITT Fax compression.
Initializes a new PDFCcittImage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imageData() As Byte _
)
'Usage

Dim imageData() As Byte

Dim instance As New PDFCcittImage(imageData)
public PDFCcittImage(
   byte[] imageData
)
public: PDFCcittImage(
   byte[]* imageData
)
public:
PDFCcittImage(
   array<byte>^ imageData
)

Parameters

imageData
Image data using CCITT Fax compression.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


%%PageItemTitle%% $$Properties$$

PDFCcittImage Class Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFCcittImage Class

For a list of all members of this type, see PDFCcittImage members.

Public Properties
 | Name | Description
Public Property | BlackIs1 | Gets or sets a value indicating how the image data should be interpreted.
Public Property | ColorSpace | Gets or sets the image colorspace. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Compression | Gets or sets the compression method used by the image data.
Public Property | Dictionary | Gets the image dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top
See Also

Reference

PDFCcittImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


BlackIs1 Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : BlackIs1 Property
Gets or sets a value indicating how the image data should be interpreted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlackIs1 As Boolean
'Usage

Dim instance As PDFCcittImage
Dim value As Boolean

instance.BlackIs1 = value

value = instance.BlackIs1
public bool BlackIs1 {get; set;}
public: __property bool get_BlackIs1();
public: __property void set_BlackIs1(
   bool value
);
public:
property bool BlackIs1 {
   bool get();
   void set (    bool value);
}

Property Value

True if the 1 bits are considered black, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


Compression Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : Compression Property
Gets or sets the compression method used by the image data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compression As PDFCcittFaxCompression
'Usage

Dim instance As PDFCcittImage
Dim value As PDFCcittFaxCompression

instance.Compression = value

value = instance.Compression
public PDFCcittFaxCompression Compression {get; set;}
public: __property PDFCcittFaxCompression get_Compression();
public: __property void set_Compression(
   PDFCcittFaxCompression value
);
public:
property PDFCcittFaxCompression Compression {
   PDFCcittFaxCompression get();
   void set (    PDFCcittFaxCompression value);
}

Property Value

The compression method of the image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


Height Property (PDFCcittImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : Height Property
Gets or sets the height of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PDFCcittImage
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public: __property int get_Height() override;
public: __property void set_Height(
   int value
) override;
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The height of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


Width Property (PDFCcittImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : Width Property
Gets or sets the width of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PDFCcittImage
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public: __property int get_Width() override;
public: __property void set_Width(
   int value
) override;
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The width of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


%%PageItemTitle%%

PDFFormXObject Class
Members

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFFormXObject Class
Defines a PDF form XObject.
Object Model
PDFFormXObject ClassPDFBasicCanvas ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFormXObject
   Inherits O2S.Components.PDF4NET.PDFGraphicsContainer
'Usage

Dim instance As PDFFormXObject
public class PDFFormXObject : O2S.Components.PDF4NET.PDFGraphicsContainer
public __gc class PDFFormXObject : public O2S.Components.PDF4NET.PDFGraphicsContainer
public ref class PDFFormXObject : public O2S.Components.PDF4NET.PDFGraphicsContainer
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile
O2S.Components.PDF4NET.PDFPageBackground

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFormXObject Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFFormXObject Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFFormXObject Class

The following tables list the members exposed by PDFFormXObject.

Public Constructors
 | Name | Description
Public Constructor | PDFFormXObject Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas.
Public Property | Dictionary | Gets the form XObject dictionary.
Public Property | Height | Gets or sets the height of this form XObject.
Public Property | Width | Gets or sets the width of this form XObject.
Top
See Also

Reference

PDFFormXObject Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFFormXObject Constructor

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : PDFFormXObject Constructor
Overload List
Overload | Description
PDFFormXObject Constructor() | Initializes a new PDFFormXObject object.
PDFFormXObject Constructor(PDFImportedContent) | Initializes a new PDFFormXObject object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


%%PageItemTitle%%

PDFFormXObject Constructor()

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor()
Initializes a new PDFFormXObject object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFormXObject()
public PDFFormXObject()
public: PDFFormXObject();
public:
PDFFormXObject();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%%

PDFFormXObject Constructor(PDFImportedContent)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor(PDFImportedContent)
Imported content that represents the content of the form XObject.
Initializes a new PDFFormXObject object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal importedContent As PDFImportedContent _
)
'Usage

Dim importedContent As PDFImportedContent

Dim instance As New PDFFormXObject(importedContent)
public PDFFormXObject(
   PDFImportedContent importedContent
)
public: PDFFormXObject(
   PDFImportedContent* importedContent
)
public:
PDFFormXObject(
   PDFImportedContent^ importedContent
)

Parameters

importedContent
Imported content that represents the content of the form XObject.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFormXObject Class Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFFormXObject Class

For a list of all members of this type, see PDFFormXObject members.

Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas.
Public Property | Dictionary | Gets the form XObject dictionary.
Public Property | Height | Gets or sets the height of this form XObject.
Public Property | Width | Gets or sets the width of this form XObject.
Top
See Also

Reference

PDFFormXObject Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


Canvas Property (PDFFormXObject)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : Canvas Property
Gets the form XObject canvas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Canvas As PDFBasicCanvas
'Usage

Dim instance As PDFFormXObject
Dim value As PDFBasicCanvas

value = instance.Canvas
public PDFBasicCanvas Canvas {get;}
public: __property PDFBasicCanvas* get_Canvas();
public:
property PDFBasicCanvas^ Canvas {
   PDFBasicCanvas^ get();
}

Property Value

The drawing surface of the form XObject.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


Dictionary Property (PDFFormXObject)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : Dictionary Property
Gets the form XObject dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFFormXObject
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw form XObject dictionary.
Remarks
This property gives you direct access to form XObject dictionary and its associated resources. Note: Modifying directly this dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


Height Property (PDFFormXObject)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : Height Property
Gets or sets the height of this form XObject.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PDFFormXObject
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public: __property double get_Height();
public: __property void set_Height(
   double value
);
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The height of the form XObject in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


Width Property (PDFFormXObject)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : Width Property
Gets or sets the width of this form XObject.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFFormXObject
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the form XObject in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


%%PageItemTitle%%

PDFImage Class
Members

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImage Class
Defines an image specified by a pair of coordinates, a width, and a height.
Object Model
PDFImage ClassPDFColorSpace ClassPDFDictionary ClassPDFBaseImageMask Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFImage
'Usage

Dim instance As PDFImage
public class PDFImage
public __gc class PDFImage
public ref class PDFImage
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFCcittImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFJpeg2000Image
O2S.Components.PDF4NET.Graphics.Shapes.PDFJpegImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFRawImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFImage Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImage Class

The following tables list the members exposed by PDFImage.

Public Constructors
 | Name | Description
Public Constructor | PDFImage Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary.
Public Property | Height | Gets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in.
Public Property | Mask | Gets or sets the mask for this image.
Public Property | Width | Gets the width of this image object.
Top
See Also

Reference

PDFImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFImage Constructor

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : PDFImage Constructor
Overload List
Overload | Description
PDFImage Constructor(String) | Initializes a new PDFImage object specifying a file name.
PDFImage Constructor(String,Int32) | Initializes a new PDFImage object specifying a file name and an active frame.
PDFImage Constructor(String,Int32,PDFImageCompression) | Initializes a new PDFImage object specifying a file name and an active frame.
PDFImage Constructor(Stream) | Initializes a new PDFImage object specifying a stream.
PDFImage Constructor(Stream,Int32) | Initializes a new PDFImage object specifying a stream and an active frame.
PDFImage Constructor(Stream,Int32,PDFImageCompression) | Initializes a new PDFImage object specifying a stream and an active frame.
PDFImage Constructor(Bitmap) | Initializes a new PDFImage object from a System.Drawing.Image.
PDFImage Constructor(Bitmap,Int32) | Initializes a new PDFImage object from a System.Drawing.Image and an active frame.
PDFImage Constructor(Bitmap,Int32,PDFImageCompression) | Initializes a new PDFImage object from a System.Drawing.Image and an active frame.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

PDFImage Constructor(String)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(String)
a string value representing a path to the image file.
Initializes a new PDFImage object specifying a file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String _
)
'Usage

Dim fileName As String

Dim instance As New PDFImage(fileName)
public PDFImage(
   string fileName
)
public: PDFImage(
   string* fileName
)
public:
PDFImage(
   String^ fileName
)

Parameters

fileName
a string value representing a path to the image file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(String,Int32)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(String,Int32)
a string value representing a path to the image file.
the frame in the image that should be used.
Initializes a new PDFImage object specifying a file name and an active frame.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String, _
   ByVal activeFrame As Integer _
)
'Usage

Dim fileName As String
Dim activeFrame As Integer

Dim instance As New PDFImage(fileName, activeFrame)
public PDFImage(
   string fileName,
   int activeFrame
)
public: PDFImage(
   string* fileName,
   int activeFrame
)
public:
PDFImage(
   String^ fileName,
   int activeFrame
)

Parameters

fileName
a string value representing a path to the image file.
activeFrame
the frame in the image that should be used.
Remarks
If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(String,Int32,PDFImageCompression)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(String,Int32,PDFImageCompression)
a string value representing a path to the image file.
the frame in the image that should be used.
Compression method for storing the image data in the PDF file.
Initializes a new PDFImage object specifying a file name and an active frame.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String, _
   ByVal activeFrame As Integer, _
   ByVal imageCompression As PDFImageCompression _
)
'Usage

Dim fileName As String
Dim activeFrame As Integer
Dim imageCompression As PDFImageCompression

Dim instance As New PDFImage(fileName, activeFrame, imageCompression)
public PDFImage(
   string fileName,
   int activeFrame,
   PDFImageCompression imageCompression
)
public: PDFImage(
   string* fileName,
   int activeFrame,
   PDFImageCompression imageCompression
)
public:
PDFImage(
   String^ fileName,
   int activeFrame,
   PDFImageCompression imageCompression
)

Parameters

fileName
a string value representing a path to the image file.
activeFrame
the frame in the image that should be used.
imageCompression
Compression method for storing the image data in the PDF file.
Remarks
If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Stream)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Stream)
a Stream object where to load the image from.
Initializes a new PDFImage object specifying a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PDFImage(stream)
public PDFImage(
   Stream stream
)
public: PDFImage(
   Stream* stream
)
public:
PDFImage(
   Stream^ stream
)

Parameters

stream
a Stream object where to load the image from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Stream,Int32)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Stream,Int32)
a Stream object where to load the image from.
the frame in the image that should be used.
Initializes a new PDFImage object specifying a stream and an active frame.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal activeFrame As Integer _
)
'Usage

Dim stream As Stream
Dim activeFrame As Integer

Dim instance As New PDFImage(stream, activeFrame)
public PDFImage(
   Stream stream,
   int activeFrame
)
public: PDFImage(
   Stream* stream,
   int activeFrame
)
public:
PDFImage(
   Stream^ stream,
   int activeFrame
)

Parameters

stream
a Stream object where to load the image from.
activeFrame
the frame in the image that should be used.
Remarks
If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Stream,Int32,PDFImageCompression)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Stream,Int32,PDFImageCompression)
a Stream object where to load the image from.
the frame in the image that should be used.
Compression method for storing the image data in the PDF file.
Initializes a new PDFImage object specifying a stream and an active frame.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal activeFrame As Integer, _
   ByVal imageCompression As PDFImageCompression _
)
'Usage

Dim stream As Stream
Dim activeFrame As Integer
Dim imageCompression As PDFImageCompression

Dim instance As New PDFImage(stream, activeFrame, imageCompression)
public PDFImage(
   Stream stream,
   int activeFrame,
   PDFImageCompression imageCompression
)
public: PDFImage(
   Stream* stream,
   int activeFrame,
   PDFImageCompression imageCompression
)
public:
PDFImage(
   Stream^ stream,
   int activeFrame,
   PDFImageCompression imageCompression
)

Parameters

stream
a Stream object where to load the image from.
activeFrame
the frame in the image that should be used.
imageCompression
Compression method for storing the image data in the PDF file.
Remarks
If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Bitmap)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Bitmap)
a System.Drawing.Bitmap object where to copy the image from.
Initializes a new PDFImage object from a System.Drawing.Image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As Bitmap _
)
'Usage

Dim image As Bitmap

Dim instance As New PDFImage(image)
public PDFImage(
   Bitmap image
)
public: PDFImage(
   Bitmap* image
)
public:
PDFImage(
   Bitmap^ image
)

Parameters

image
a System.Drawing.Bitmap object where to copy the image from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Bitmap,Int32)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Bitmap,Int32)
a System.Drawing.Bitmap object where to copy the image from.
the frame in the image that should be used.
Initializes a new PDFImage object from a System.Drawing.Image and an active frame.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As Bitmap, _
   ByVal activeFrame As Integer _
)
'Usage

Dim image As Bitmap
Dim activeFrame As Integer

Dim instance As New PDFImage(image, activeFrame)
public PDFImage(
   Bitmap image,
   int activeFrame
)
public: PDFImage(
   Bitmap* image,
   int activeFrame
)
public:
PDFImage(
   Bitmap^ image,
   int activeFrame
)

Parameters

image
a System.Drawing.Bitmap object where to copy the image from.
activeFrame
the frame in the image that should be used.
Remarks
If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%%

PDFImage Constructor(Bitmap,Int32,PDFImageCompression)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Bitmap,Int32,PDFImageCompression)
a System.Drawing.Bitmap object where to copy the image from.
the frame in the image that should be used.
Compression method for storing the image data in the PDF file.
Initializes a new PDFImage object from a System.Drawing.Image and an active frame.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As Bitmap, _
   ByVal activeFrame As Integer, _
   ByVal imageCompression As PDFImageCompression _
)
'Usage

Dim image As Bitmap
Dim activeFrame As Integer
Dim imageCompression As PDFImageCompression

Dim instance As New PDFImage(image, activeFrame, imageCompression)
public PDFImage(
   Bitmap image,
   int activeFrame,
   PDFImageCompression imageCompression
)
public: PDFImage(
   Bitmap* image,
   int activeFrame,
   PDFImageCompression imageCompression
)
public:
PDFImage(
   Bitmap^ image,
   int activeFrame,
   PDFImageCompression imageCompression
)

Parameters

image
a System.Drawing.Bitmap object where to copy the image from.
activeFrame
the frame in the image that should be used.
imageCompression
Compression method for storing the image data in the PDF file.
Remarks
If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFImage Class Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImage Class

For a list of all members of this type, see PDFImage members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary.
Public Property | Height | Gets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in.
Public Property | Mask | Gets or sets the mask for this image.
Public Property | Width | Gets the width of this image object.
Top
See Also

Reference

PDFImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


ColorSpace Property (PDFImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : ColorSpace Property
Gets or sets the image colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorSpace As PDFColorSpace
'Usage

Dim instance As PDFImage
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public PDFColorSpace ColorSpace {get; set;}
public: __property PDFColorSpace* get_ColorSpace();
public: __property void set_ColorSpace(
   PDFColorSpace* value
);
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The image colorspace used to interpret the image data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members


Dictionary Property (PDFImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Dictionary Property
Gets the image dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFImage
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw image dictionary.
Remarks
This property gives you direct access to image dictionary and its associated resources. Note: Modifying directly the page dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members


Height Property (PDFImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Height Property
Gets the height of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Height As Integer
'Usage

Dim instance As PDFImage
Dim value As Integer

instance.Height = value

value = instance.Height
public virtual int Height {get; set;}
public: __property virtual int get_Height();
public: __property virtual void set_Height(
   int value
);
public:
virtual property int Height {
   int get();
   void set (    int value);
}

Property Value

The height of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members


Interpolate Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Interpolate Property
Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Interpolate As Boolean
'Usage

Dim instance As PDFImage
Dim value As Boolean

instance.Interpolate = value

value = instance.Interpolate
public bool Interpolate {get; set;}
public: __property bool get_Interpolate();
public: __property void set_Interpolate(
   bool value
);
public:
property bool Interpolate {
   bool get();
   void set (    bool value);
}

Property Value

True if the image should be interpolated when the PDF viewer zooms in, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members


Mask Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Mask Property
Gets or sets the mask for this image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Mask As PDFBaseImageMask
'Usage

Dim instance As PDFImage
Dim value As PDFBaseImageMask

instance.Mask = value

value = instance.Mask
public PDFBaseImageMask Mask {get; set;}
public: __property PDFBaseImageMask* get_Mask();
public: __property void set_Mask(
   PDFBaseImageMask* value
);
public:
property PDFBaseImageMask^ Mask {
   PDFBaseImageMask^ get();
   void set (    PDFBaseImageMask^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask descendant specifying the mask for this image.
Remarks
The mask allows to define areas of an image to be treated as transparent when the image is painted on the page. Note: An image mask should not be used with jpeg images because they use a lossy image compression and unwanted effects might appear.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members


Width Property (PDFImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Width Property
Gets the width of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Width As Integer
'Usage

Dim instance As PDFImage
Dim value As Integer

instance.Width = value

value = instance.Width
public virtual int Width {get; set;}
public: __property virtual int get_Width();
public: __property virtual void set_Width(
   int value
);
public:
virtual property int Width {
   int get();
   void set (    int value);
}

Property Value

The width of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImage Class
PDFImage Members


%%PageItemTitle%%

PDFJpeg2000Image Class
Members

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFJpeg2000Image Class
Defines a PDF image in JPEG2000 format.
Object Model
PDFJpeg2000Image ClassPDFColorSpace ClassPDFDictionary ClassPDFBaseImageMask Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFJpeg2000Image
   Inherits PDFImage
'Usage

Dim instance As PDFJpeg2000Image
public class PDFJpeg2000Image : PDFImage
public __gc class PDFJpeg2000Image : public PDFImage
public ref class PDFJpeg2000Image : public PDFImage
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFJpeg2000Image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpeg2000Image Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFJpeg2000Image Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFJpeg2000Image Class

The following tables list the members exposed by PDFJpeg2000Image.

Public Constructors
 | Name | Description
Public Constructor | PDFJpeg2000Image Constructor | Initializes a new PDFJpeg2000Image object.
Top
Public Properties
 | Name | Description
Public Property | BitsPerComponent | Gets or sets the bits per components.
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top
See Also

Reference

PDFJpeg2000Image Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFJpeg2000Image Constructor

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : PDFJpeg2000Image Constructor
JPEG2000 image data.
Initializes a new PDFJpeg2000Image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imageData() As Byte _
)
'Usage

Dim imageData() As Byte

Dim instance As New PDFJpeg2000Image(imageData)
public PDFJpeg2000Image(
   byte[] imageData
)
public: PDFJpeg2000Image(
   byte[]* imageData
)
public:
PDFJpeg2000Image(
   array<byte>^ imageData
)

Parameters

imageData
JPEG2000 image data.
Remarks
The imageData parameter must contain the image in JPEG2000 format, the data is stored as it is in the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


%%PageItemTitle%% $$Properties$$

PDFJpeg2000Image Class Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFJpeg2000Image Class

For a list of all members of this type, see PDFJpeg2000Image members.

Public Properties
 | Name | Description
Public Property | BitsPerComponent | Gets or sets the bits per components.
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top
See Also

Reference

PDFJpeg2000Image Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


BitsPerComponent Property (PDFJpeg2000Image)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : BitsPerComponent Property
Gets or sets the bits per components.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitsPerComponent As Integer
'Usage

Dim instance As PDFJpeg2000Image
Dim value As Integer

instance.BitsPerComponent = value

value = instance.BitsPerComponent
public int BitsPerComponent {get; set;}
public: __property int get_BitsPerComponent();
public: __property void set_BitsPerComponent(
   int value
);
public:
property int BitsPerComponent {
   int get();
   void set (    int value);
}

Property Value

The number of bits used to represent a color component in this image.
Remarks
Valid values are 1, 2, 4, 8, and (in PDF 1.5) 16
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


ColorSpace Property (PDFJpeg2000Image)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : ColorSpace Property
Gets or sets the image colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property ColorSpace As PDFColorSpace
'Usage

Dim instance As PDFJpeg2000Image
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public new PDFColorSpace ColorSpace {get; set;}
public: __property new PDFColorSpace* get_ColorSpace();
public: __property new void set_ColorSpace(
   PDFColorSpace* value
);
public:
new property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The image colorspace used to interpret the image data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


Height Property (PDFJpeg2000Image)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : Height Property
Gets or sets the height of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PDFJpeg2000Image
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public: __property int get_Height() override;
public: __property void set_Height(
   int value
) override;
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The height of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


Width Property (PDFJpeg2000Image)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : Width Property
Gets or sets the width of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PDFJpeg2000Image
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public: __property int get_Width() override;
public: __property void set_Width(
   int value
) override;
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The width of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


%%PageItemTitle%%

PDFJpegImage Class
Members

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFJpegImage Class
Defines a PDF image in JPEG format.
Object Model
PDFJpegImage ClassPDFColorSpace ClassPDFDictionary ClassPDFBaseImageMask Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFJpegImage
   Inherits PDFImage
'Usage

Dim instance As PDFJpegImage
public class PDFJpegImage : PDFImage
public __gc class PDFJpegImage : public PDFImage
public ref class PDFJpegImage : public PDFImage
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFJpegImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFJpegImage Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFJpegImage Class

The following tables list the members exposed by PDFJpegImage.

Public Constructors
 | Name | Description
Public Constructor | PDFJpegImage Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | ImageQuality | Gets or sets the image quality.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top
See Also

Reference

PDFJpegImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFJpegImage Constructor

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpegImage Class : PDFJpegImage Constructor
Overload List
Overload | Description
PDFJpegImage Constructor(String) | Initializes a new PDFJpegImage object.
PDFJpegImage Constructor(Byte[]) | Initializes a new PDFJpegImage object.
PDFJpegImage Constructor(Bitmap) | Initializes a new PDFJpegImage object.
PDFJpegImage Constructor(Bitmap,Int32) | Initializes a new PDFJpegImage object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Class
PDFJpegImage Members


%%PageItemTitle%%

PDFJpegImage Constructor(String)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpegImage Class > PDFJpegImage Constructor : PDFJpegImage Constructor(String)
JPEG file.
Initializes a new PDFJpegImage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String _
)
'Usage

Dim fileName As String

Dim instance As New PDFJpegImage(fileName)
public PDFJpegImage(
   string fileName
)
public: PDFJpegImage(
   string* fileName
)
public:
PDFJpegImage(
   String^ fileName
)

Parameters

fileName
JPEG file.
Remarks
Path to a valid JPEG file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Class
PDFJpegImage Members
Overload List


%%PageItemTitle%%

PDFJpegImage Constructor(Byte[])

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpegImage Class > PDFJpegImage Constructor : PDFJpegImage Constructor(Byte[])
JPEG image data.
Initializes a new PDFJpegImage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imageData() As Byte _
)
'Usage

Dim imageData() As Byte

Dim instance As New PDFJpegImage(imageData)
public PDFJpegImage(
   byte[] imageData
)
public: PDFJpegImage(
   byte[]* imageData
)
public:
PDFJpegImage(
   array<byte>^ imageData
)

Parameters

imageData
JPEG image data.
Remarks
The imageData parameter must contain the image in JPEG format, the data is stored as it is in the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Class
PDFJpegImage Members
Overload List


%%PageItemTitle%%

PDFJpegImage Constructor(Bitmap)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpegImage Class > PDFJpegImage Constructor : PDFJpegImage Constructor(Bitmap)
Source bitmap.
Initializes a new PDFJpegImage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As Bitmap _
)
'Usage

Dim image As Bitmap

Dim instance As New PDFJpegImage(image)
public PDFJpegImage(
   Bitmap image
)
public: PDFJpegImage(
   Bitmap* image
)
public:
PDFJpegImage(
   Bitmap^ image
)

Parameters

image
Source bitmap.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Class
PDFJpegImage Members
Overload List


%%PageItemTitle%%

PDFJpegImage Constructor(Bitmap,Int32)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpegImage Class > PDFJpegImage Constructor : PDFJpegImage Constructor(Bitmap,Int32)
Source bitmap.
An integer value specifying the quality for the image.
Initializes a new PDFJpegImage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As Bitmap, _
   ByVal imageQuality As Integer _
)
'Usage

Dim image As Bitmap
Dim imageQuality As Integer

Dim instance As New PDFJpegImage(image, imageQuality)
public PDFJpegImage(
   Bitmap image,
   int imageQuality
)
public: PDFJpegImage(
   Bitmap* image,
   int imageQuality
)
public:
PDFJpegImage(
   Bitmap^ image,
   int imageQuality
)

Parameters

image
Source bitmap.
imageQuality
An integer value specifying the quality for the image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Class
PDFJpegImage Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFJpegImage Class Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFJpegImage Class

For a list of all members of this type, see PDFJpegImage members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | ImageQuality | Gets or sets the image quality.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top
See Also

Reference

PDFJpegImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


ColorSpace Property (PDFJpegImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpegImage Class : ColorSpace Property
Gets or sets the image colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property ColorSpace As PDFColorSpace
'Usage

Dim instance As PDFJpegImage
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public new PDFColorSpace ColorSpace {get; set;}
public: __property new PDFColorSpace* get_ColorSpace();
public: __property new void set_ColorSpace(
   PDFColorSpace* value
);
public:
new property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The image colorspace used to interpret the image data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Class
PDFJpegImage Members


Height Property (PDFJpegImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpegImage Class : Height Property
Gets or sets the height of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PDFJpegImage
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public: __property int get_Height() override;
public: __property void set_Height(
   int value
) override;
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The height of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Class
PDFJpegImage Members


ImageQuality Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpegImage Class : ImageQuality Property
Gets or sets the image quality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageQuality As Integer
'Usage

Dim instance As PDFJpegImage
Dim value As Integer

instance.ImageQuality = value

value = instance.ImageQuality
public int ImageQuality {get; set;}
public: __property int get_ImageQuality();
public: __property void set_ImageQuality(
   int value
);
public:
property int ImageQuality {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the quality for the image.
Remarks
This property specifies the level of jpeg compression to be applied on the image when it is saved to pdf file. A higher value means higher quality but lower compression, a lower value means low quality by higher compression. The possible values for this property vary from 1 to 100.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Class
PDFJpegImage Members


Width Property (PDFJpegImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpegImage Class : Width Property
Gets or sets the width of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PDFJpegImage
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public: __property int get_Width() override;
public: __property void set_Width(
   int value
) override;
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The width of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJpegImage Class
PDFJpegImage Members


%%PageItemTitle%%

PDFMetafile Class
Members

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFMetafile Class
Defines a Windows metafile object.
Object Model
PDFMetafile ClassPDFBasicCanvas ClassPDFDictionary Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMetafile
   Inherits PDFFormXObject
'Usage

Dim instance As PDFMetafile
public class PDFMetafile : PDFFormXObject
public __gc class PDFMetafile : public PDFFormXObject
public ref class PDFMetafile : public PDFFormXObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFMetafile Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFMetafile Class

The following tables list the members exposed by PDFMetafile.

Public Constructors
 | Name | Description
Public Constructor | PDFMetafile Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Dictionary | Gets the form XObject dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top
See Also

Reference

PDFMetafile Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFMetafile Constructor

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class : PDFMetafile Constructor
Overload List
Overload | Description
PDFMetafile Constructor(String) | Initializes a new PDFMetafile object with the specified metafile file.
PDFMetafile Constructor(String,Boolean) | Initializes a new PDFMetafile object with the specified metafile file.
PDFMetafile Constructor(String,Boolean,Dictionary<String,PDFFontBase>) | Initializes a new PDFMetafile object with the specified metafile file.
PDFMetafile Constructor(Stream) | Initializes a new PDFMetafile object with the specified metafile stream.
PDFMetafile Constructor(Stream,Boolean) | Initializes a new PDFMetafile object with the specified metafile stream.
PDFMetafile Constructor(Stream,Boolean,Dictionary<String,PDFFontBase>) | Initializes a new PDFMetafile object with the specified metafile stream.
PDFMetafile Constructor(Metafile) | Initializes a new PDFMetafile object with the specified metafile object.
PDFMetafile Constructor(Metafile,Boolean) | Initializes a new PDFMetafile object with the specified metafile object.
PDFMetafile Constructor(Metafile,Boolean,Dictionary<String,PDFFontBase>) | Initializes a new PDFMetafile object with the specified metafile object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members


%%PageItemTitle%%

PDFMetafile Constructor(String)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(String)
the full path to the metafile on disk.
Initializes a new PDFMetafile object with the specified metafile file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String _
)
'Usage

Dim fileName As String

Dim instance As New PDFMetafile(fileName)
public PDFMetafile(
   string fileName
)
public: PDFMetafile(
   string* fileName
)
public:
PDFMetafile(
   String^ fileName
)

Parameters

fileName
the full path to the metafile on disk.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(String,Boolean)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(String,Boolean)
the full path to the metafile on disk.
True if the fonts in the metafile should be created with Unicode support.
Initializes a new PDFMetafile object with the specified metafile file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String, _
   ByVal useUnicodeFonts As Boolean _
)
'Usage

Dim fileName As String
Dim useUnicodeFonts As Boolean

Dim instance As New PDFMetafile(fileName, useUnicodeFonts)
public PDFMetafile(
   string fileName,
   bool useUnicodeFonts
)
public: PDFMetafile(
   string* fileName,
   bool useUnicodeFonts
)
public:
PDFMetafile(
   String^ fileName,
   bool useUnicodeFonts
)

Parameters

fileName
the full path to the metafile on disk.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
Remarks
When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(String,Boolean,Dictionary<String,PDFFontBase>)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(String,Boolean,Dictionary<String,PDFFontBase>)
the full path to the metafile on disk.
True if the fonts in the metafile should be created with Unicode support.
Cache for reusing fonts across multiple metafiles.
Initializes a new PDFMetafile object with the specified metafile file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String, _
   ByVal useUnicodeFonts As Boolean, _
   ByVal fontCache As Dictionary(Of String,PDFFontBase) _
)
'Usage

Dim fileName As String
Dim useUnicodeFonts As Boolean
Dim fontCache As Dictionary(Of String,PDFFontBase)

Dim instance As New PDFMetafile(fileName, useUnicodeFonts, fontCache)
public PDFMetafile(
   string fileName,
   bool useUnicodeFonts,
   Dictionary<string,PDFFontBase> fontCache
)
public: PDFMetafile(
   string* fileName,
   bool useUnicodeFonts,
   Dictionary<string*,PDFFontBase*>* fontCache
)
public:
PDFMetafile(
   String^ fileName,
   bool useUnicodeFonts,
   Dictionary<String^,PDFFontBase^>^ fontCache
)

Parameters

fileName
the full path to the metafile on disk.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
fontCache
Cache for reusing fonts across multiple metafiles.
Remarks
When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(Stream)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Stream)
the stream with metafile content.
Initializes a new PDFMetafile object with the specified metafile stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PDFMetafile(stream)
public PDFMetafile(
   Stream stream
)
public: PDFMetafile(
   Stream* stream
)
public:
PDFMetafile(
   Stream^ stream
)

Parameters

stream
the stream with metafile content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(Stream,Boolean)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Stream,Boolean)
the stream with metafile content.
True if the fonts in the metafile should be created with Unicode support.
Initializes a new PDFMetafile object with the specified metafile stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal useUnicodeFonts As Boolean _
)
'Usage

Dim stream As Stream
Dim useUnicodeFonts As Boolean

Dim instance As New PDFMetafile(stream, useUnicodeFonts)
public PDFMetafile(
   Stream stream,
   bool useUnicodeFonts
)
public: PDFMetafile(
   Stream* stream,
   bool useUnicodeFonts
)
public:
PDFMetafile(
   Stream^ stream,
   bool useUnicodeFonts
)

Parameters

stream
the stream with metafile content.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
Remarks
When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(Stream,Boolean,Dictionary<String,PDFFontBase>)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Stream,Boolean,Dictionary<String,PDFFontBase>)
the stream with metafile content.
True if the fonts in the metafile should be created with Unicode support.
Cache for reusing fonts across multiple metafiles.
Initializes a new PDFMetafile object with the specified metafile stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal useUnicodeFonts As Boolean, _
   ByVal fontCache As Dictionary(Of String,PDFFontBase) _
)
'Usage

Dim stream As Stream
Dim useUnicodeFonts As Boolean
Dim fontCache As Dictionary(Of String,PDFFontBase)

Dim instance As New PDFMetafile(stream, useUnicodeFonts, fontCache)
public PDFMetafile(
   Stream stream,
   bool useUnicodeFonts,
   Dictionary<string,PDFFontBase> fontCache
)
public: PDFMetafile(
   Stream* stream,
   bool useUnicodeFonts,
   Dictionary<string*,PDFFontBase*>* fontCache
)
public:
PDFMetafile(
   Stream^ stream,
   bool useUnicodeFonts,
   Dictionary<String^,PDFFontBase^>^ fontCache
)

Parameters

stream
the stream with metafile content.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
fontCache
Cache for reusing fonts across multiple metafiles.
Remarks
When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(Metafile)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Metafile)
the metafile object.
Initializes a new PDFMetafile object with the specified metafile object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal metafile As Metafile _
)
'Usage

Dim metafile As Metafile

Dim instance As New PDFMetafile(metafile)
public PDFMetafile(
   Metafile metafile
)
public: PDFMetafile(
   Metafile* metafile
)
public:
PDFMetafile(
   Metafile^ metafile
)

Parameters

metafile
the metafile object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(Metafile,Boolean)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Metafile,Boolean)
the metafile object.
True if the fonts in the metafile should be created with Unicode support.
Initializes a new PDFMetafile object with the specified metafile object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal metafile As Metafile, _
   ByVal useUnicodeFonts As Boolean _
)
'Usage

Dim metafile As Metafile
Dim useUnicodeFonts As Boolean

Dim instance As New PDFMetafile(metafile, useUnicodeFonts)
public PDFMetafile(
   Metafile metafile,
   bool useUnicodeFonts
)
public: PDFMetafile(
   Metafile* metafile,
   bool useUnicodeFonts
)
public:
PDFMetafile(
   Metafile^ metafile,
   bool useUnicodeFonts
)

Parameters

metafile
the metafile object.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
Remarks
When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFMetafile Constructor(Metafile,Boolean,Dictionary<String,PDFFontBase>)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Metafile,Boolean,Dictionary<String,PDFFontBase>)
the metafile object.
True if the fonts in the metafile should be created with Unicode support.
Cache for reusing fonts across multiple metafiles.
Initializes a new PDFMetafile object with the specified metafile object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal metafile As Metafile, _
   ByVal useUnicodeFonts As Boolean, _
   ByVal fontCache As Dictionary(Of String,PDFFontBase) _
)
'Usage

Dim metafile As Metafile
Dim useUnicodeFonts As Boolean
Dim fontCache As Dictionary(Of String,PDFFontBase)

Dim instance As New PDFMetafile(metafile, useUnicodeFonts, fontCache)
public PDFMetafile(
   Metafile metafile,
   bool useUnicodeFonts,
   Dictionary<string,PDFFontBase> fontCache
)
public: PDFMetafile(
   Metafile* metafile,
   bool useUnicodeFonts,
   Dictionary<string*,PDFFontBase*>* fontCache
)
public:
PDFMetafile(
   Metafile^ metafile,
   bool useUnicodeFonts,
   Dictionary<String^,PDFFontBase^>^ fontCache
)

Parameters

metafile
the metafile object.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
fontCache
Cache for reusing fonts across multiple metafiles.
Remarks
When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


%%PageItemTitle%%

PDFPath Class
Members

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class
Represents a series of connected lines and curves.
Object Model
PDFPath Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPath
'Usage

Dim instance As PDFPath
public class PDFPath
public __gc class PDFPath
public ref class PDFPath
Remarks
A path can be used to create complex geometric shapes that are not available in PDF4NET library as basic drawing primitives.
A path consists of one or more subpaths that can be connected or not. All the points of a subpath are connected through lines and/or curves. A subpath can be open or it can be explicitly closed.
When the path is filled, its subpaths, that are not explicitly closed, are automatically closed.
Each drawing primitive in a subpath updates the current drawing point. If the current drawing point is explicitly moved using MoveTo, the current subpath is ended and a new subpath is started.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFPath Class Members
Methods

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class

The following tables list the members exposed by PDFPath.

Public Constructors
 | Name | Description
Public Constructor | PDFPath Constructor | Initializes a new PDFPath object.
Top
Public Methods
 | Name | Description
Public Method | BezierTo | Appends a Berzier curve to the end of the current subpath.
Public Method | CloseSubpath | Closes the current subpath.
Public Method | Ellipse | Add an ellipse to this path object.
Public Method | LineTo | Appends a line segment to the end of the current subpath.
Public Method | MoveTo | Moves the current point in the path to a new position.
Public Method | PolyBezierTo | Appends a series of connected Bezier curves to the end of the current subpath.
Public Method | Polygon | Add a polygon to this path object.
Public Method | PolyLineTo | Appends a series of connected line segments to the end of the current subpath.
Public Method | Rectangle | Add a rectangle to this path object.
Public Method | RoundRectangle | Add a rounded rectangle to this path object.
Top
See Also

Reference

PDFPath Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFPath Constructor

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : PDFPath Constructor
Initializes a new PDFPath object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPath()
public PDFPath()
public: PDFPath();
public:
PDFPath();
Remarks
The starting point of the path is (0,0).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%% $$Methods$$

PDFPath Class Methods

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class

For a list of all members of this type, see PDFPath members.

Public Methods
 | Name | Description
Public Method | BezierTo | Appends a Berzier curve to the end of the current subpath.
Public Method | CloseSubpath | Closes the current subpath.
Public Method | Ellipse | Add an ellipse to this path object.
Public Method | LineTo | Appends a line segment to the end of the current subpath.
Public Method | MoveTo | Moves the current point in the path to a new position.
Public Method | PolyBezierTo | Appends a series of connected Bezier curves to the end of the current subpath.
Public Method | Polygon | Add a polygon to this path object.
Public Method | PolyLineTo | Appends a series of connected line segments to the end of the current subpath.
Public Method | Rectangle | Add a rectangle to this path object.
Public Method | RoundRectangle | Add a rounded rectangle to this path object.
Top
See Also

Reference

PDFPath Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


BezierTo Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : BezierTo Method
The x coordinate of the first control point.
The y coordinate of the first control point.
The x coordinate of the second control point.
The y coordinate of the second control point.
The x coordinate of the third control point.
The y coordinate of the third control point.
Appends a Berzier curve to the end of the current subpath.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub BezierTo( _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double _
)
'Usage

Dim instance As PDFPath
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double

instance.BezierTo(x1, y1, x2, y2, x3, y3)
public void BezierTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)
public: void BezierTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)
public:
void BezierTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)

Parameters

x1
The x coordinate of the first control point.
y1
The y coordinate of the first control point.
x2
The x coordinate of the second control point.
y2
The y coordinate of the second control point.
x3
The x coordinate of the third control point.
y3
The y coordinate of the third control point.
Remarks
The new point (x3,y3) becomes the path current point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


CloseSubpath Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : CloseSubpath Method
Closes the current subpath.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CloseSubpath()
'Usage

Dim instance As PDFPath

instance.CloseSubpath()
public void CloseSubpath()
public: void CloseSubpath();
public:
void CloseSubpath();
Remarks
Current subpath is closed. A new subpath is automatically started and the new current point is (0,0).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


Ellipse Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : Ellipse Method
The x coordinate of the top left corner of the bounding rectangle.
The y coordinate of the top left corner of the bounding rectangle.
The width of the bounding rectangle.
The height of the bounding rectangle.
Add an ellipse to this path object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Ellipse( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFPath
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.Ellipse(left, top, width, height)
public void Ellipse(
   double left,
   double top,
   double width,
   double height
)
public: void Ellipse(
   double left,
   double top,
   double width,
   double height
)
public:
void Ellipse(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x coordinate of the top left corner of the bounding rectangle.
top
The y coordinate of the top left corner of the bounding rectangle.
width
The width of the bounding rectangle.
height
The height of the bounding rectangle.
Remarks
The ellipse defines a closed subpath within the path. A new subpath is automatically started and the new current point is (left,top).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


LineTo Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : LineTo Method
The x coordinate of the line ending point.
The y coordinate of the line ending point.
Appends a line segment to the end of the current subpath.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub LineTo( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PDFPath
Dim x As Double
Dim y As Double

instance.LineTo(x, y)
public void LineTo(
   double x,
   double y
)
public: void LineTo(
   double x,
   double y
)
public:
void LineTo(
   double x,
   double y
)

Parameters

x
The x coordinate of the line ending point.
y
The y coordinate of the line ending point.
Remarks
The new point (x,y) becomes the path current point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


MoveTo Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : MoveTo Method
The x coordinate of the new current point.
The y coordinate of the new current point.
Moves the current point in the path to a new position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MoveTo( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PDFPath
Dim x As Double
Dim y As Double

instance.MoveTo(x, y)
public void MoveTo(
   double x,
   double y
)
public: void MoveTo(
   double x,
   double y
)
public:
void MoveTo(
   double x,
   double y
)

Parameters

x
The x coordinate of the new current point.
y
The y coordinate of the new current point.
Remarks
The previous path, if exists, is ended and a new subpath is automatically started.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


PolyBezierTo Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : PolyBezierTo Method
An array of O2S.Components.PDF4NET.PDFPoint objects that represents the control points that define the Bezier curves to add.
Appends a series of connected Bezier curves to the end of the current subpath.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PolyBezierTo( _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFPath
Dim points() As PDFPoint

instance.PolyBezierTo(points)
public void PolyBezierTo(
   PDFPoint[] points
)
public: void PolyBezierTo(
   PDFPoint*[]* points
)
public:
void PolyBezierTo(
   array<PDFPoint^>^ points
)

Parameters

points
An array of O2S.Components.PDF4NET.PDFPoint objects that represents the control points that define the Bezier curves to add.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when points parameter is null.
System.ArgumentException | Thrown when the last Bezier curve in the array is incomplete.
Remarks
Each Bezier curve is defined by 4 points. The first curve uses the current point as its first control point and each following curve uses the last point of the previous curve as its first control point.
The last point in the array becomes the new current point in the path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


Polygon Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : Polygon Method
An array of O2S.Components.PDF4NET.PDFPoint objects that represents the points that define the polygon to add.
Add a polygon to this path object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Polygon( _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFPath
Dim points() As PDFPoint

instance.Polygon(points)
public void Polygon(
   PDFPoint[] points
)
public: void Polygon(
   PDFPoint*[]* points
)
public:
void Polygon(
   array<PDFPoint^>^ points
)

Parameters

points
An array of O2S.Components.PDF4NET.PDFPoint objects that represents the points that define the polygon to add.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when points parameter is null.
Remarks
The polygon defines a closed subpath within the path. The first point in the array is considered as the starting point for the polygon. A new subpath is automatically started and the new current point is the first point of the polygon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


PolyLineTo Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : PolyLineTo Method
An array of O2S.Components.PDF4NET.PDFPoint objects that represents the points that define the line segments to add.
Appends a series of connected line segments to the end of the current subpath.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PolyLineTo( _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFPath
Dim points() As PDFPoint

instance.PolyLineTo(points)
public void PolyLineTo(
   PDFPoint[] points
)
public: void PolyLineTo(
   PDFPoint*[]* points
)
public:
void PolyLineTo(
   array<PDFPoint^>^ points
)

Parameters

points
An array of O2S.Components.PDF4NET.PDFPoint objects that represents the points that define the line segments to add.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when points parameter is null.
Remarks
The last point in the array becomes the new current point in the path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


Rectangle Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : Rectangle Method
The x coordinate of the top left corner of the rectangle.
The y coordinate of the top left corner of the rectangle.
The width of the rectangle.
The height of the rectangle.
Add a rectangle to this path object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Rectangle( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PDFPath
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.Rectangle(left, top, width, height)
public void Rectangle(
   double left,
   double top,
   double width,
   double height
)
public: void Rectangle(
   double left,
   double top,
   double width,
   double height
)
public:
void Rectangle(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
Remarks
The rectangle defines a closed subpath within the path. A new subpath is automatically started and the new current point is (left,top).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


RoundRectangle Method

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : RoundRectangle Method
The x coordinate of the top left corner of the rectangle.
The y coordinate of the top left corner of the rectangle.
The width of the rectangle.
The height of the rectangle.
The width of the ellipse used to draw the rounded corners.
The height of the ellipse used to draw the rounded corners.
Add a rounded rectangle to this path object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RoundRectangle( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
'Usage

Dim instance As PDFPath
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.RoundRectangle(left, top, width, height, ellipseWidth, ellipseHeight)
public void RoundRectangle(
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public: void RoundRectangle(
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public:
void RoundRectangle(
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
ellipseWidth
The width of the ellipse used to draw the rounded corners.
ellipseHeight
The height of the ellipse used to draw the rounded corners.
Remarks
The rounded rectangle defines a closed subpath within the path. A new subpath is automatically started and the new current point is (left,top).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPath Class
PDFPath Members


%%PageItemTitle%%

PDFRawImage Class
Members

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRawImage Class
Defines a PDF image in RAW format.
Object Model
PDFRawImage ClassPDFColorSpace ClassPDFDictionary ClassPDFBaseImageMask Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRawImage
   Inherits PDFImage
'Usage

Dim instance As PDFRawImage
public class PDFRawImage : PDFImage
public __gc class PDFRawImage : public PDFImage
public ref class PDFRawImage : public PDFImage
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFRawImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRawImage Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFRawImage Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRawImage Class

The following tables list the members exposed by PDFRawImage.

Public Constructors
 | Name | Description
Public Constructor | PDFRawImage Constructor | Initializes a new PDFRawImage object.
Top
Public Properties
 | Name | Description
Public Property | BitsPerComponent | Gets or sets the bits per components.
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top
See Also

Reference

PDFRawImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFRawImage Constructor

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : PDFRawImage Constructor
Raw image data, its size depends on the BitsPerComponent and ColorSpace.
Initializes a new PDFRawImage object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imageData() As Byte _
)
'Usage

Dim imageData() As Byte

Dim instance As New PDFRawImage(imageData)
public PDFRawImage(
   byte[] imageData
)
public: PDFRawImage(
   byte[]* imageData
)
public:
PDFRawImage(
   array<byte>^ imageData
)

Parameters

imageData
Raw image data, its size depends on the BitsPerComponent and ColorSpace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRawImage Class
PDFRawImage Members


%%PageItemTitle%% $$Properties$$

PDFRawImage Class Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRawImage Class

For a list of all members of this type, see PDFRawImage members.

Public Properties
 | Name | Description
Public Property | BitsPerComponent | Gets or sets the bits per components.
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top
See Also

Reference

PDFRawImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


BitsPerComponent Property (PDFRawImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : BitsPerComponent Property
Gets or sets the bits per components.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitsPerComponent As Integer
'Usage

Dim instance As PDFRawImage
Dim value As Integer

instance.BitsPerComponent = value

value = instance.BitsPerComponent
public int BitsPerComponent {get; set;}
public: __property int get_BitsPerComponent();
public: __property void set_BitsPerComponent(
   int value
);
public:
property int BitsPerComponent {
   int get();
   void set (    int value);
}

Property Value

The number of bits used to represent a color component in this image.
Remarks
Valid values are 1, 2, 4, 8, and (in PDF 1.5) 16
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRawImage Class
PDFRawImage Members


ColorSpace Property (PDFRawImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : ColorSpace Property
Gets or sets the image colorspace.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property ColorSpace As PDFColorSpace
'Usage

Dim instance As PDFRawImage
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public new PDFColorSpace ColorSpace {get; set;}
public: __property new PDFColorSpace* get_ColorSpace();
public: __property new void set_ColorSpace(
   PDFColorSpace* value
);
public:
new property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (    PDFColorSpace^ value);
}

Property Value

The image colorspace used to interpret the image data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRawImage Class
PDFRawImage Members


Height Property (PDFRawImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : Height Property
Gets or sets the height of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PDFRawImage
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public: __property int get_Height() override;
public: __property void set_Height(
   int value
) override;
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The height of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRawImage Class
PDFRawImage Members


Width Property (PDFRawImage)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : Width Property
Gets or sets the width of this image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PDFRawImage
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public: __property int get_Width() override;
public: __property void set_Width(
   int value
) override;
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The width of the image in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRawImage Class
PDFRawImage Members


%%PageItemTitle%%

PDFTextFormatOptions Class
Members

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFormatOptions Class
Defines the available formatting options for a text box
Object Model
PDFTextFormatOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextFormatOptions
'Usage

Dim instance As PDFTextFormatOptions
public class PDFTextFormatOptions
public __gc class PDFTextFormatOptions
public ref class PDFTextFormatOptions
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextFormatOptions Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%% $$Members$$

PDFTextFormatOptions Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFormatOptions Class

The following tables list the members exposed by PDFTextFormatOptions.

Public Constructors
 | Name | Description
Public Constructor | PDFTextFormatOptions Constructor | Initializes a new PDFTextFormatOptions object.
Top
Public Properties
 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box.
Public Property | BreakLongWords | Gets or sets whether to break no spaced text at character level.
Public Property | ClipText | Gets or sets the text clipping mode for the text box
Public Property | FirstLineIndent | Gets or sets the first line indentation.
Public Property | KeepWhiteSpaces | Gets or sets whether the white spaces are kept within the text.
Public Property | LineSpacing | Gets or sets the line spacing.
Public Property | Orientation | Gets or sets the text box orientation.
Top
See Also

Reference

PDFTextFormatOptions Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFTextFormatOptions Constructor

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : PDFTextFormatOptions Constructor
Initializes a new PDFTextFormatOptions object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFTextFormatOptions()
public PDFTextFormatOptions()
public: PDFTextFormatOptions();
public:
PDFTextFormatOptions();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%% $$Properties$$

PDFTextFormatOptions Class Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFormatOptions Class

For a list of all members of this type, see PDFTextFormatOptions members.

Public Properties
 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box.
Public Property | BreakLongWords | Gets or sets whether to break no spaced text at character level.
Public Property | ClipText | Gets or sets the text clipping mode for the text box
Public Property | FirstLineIndent | Gets or sets the first line indentation.
Public Property | KeepWhiteSpaces | Gets or sets whether the white spaces are kept within the text.
Public Property | LineSpacing | Gets or sets the line spacing.
Public Property | Orientation | Gets or sets the text box orientation.
Top
See Also

Reference

PDFTextFormatOptions Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


Align Property (PDFTextFormatOptions)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : Align Property
Gets or sets the text alignment within the text box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Align As PDFTextAlign
'Usage

Dim instance As PDFTextFormatOptions
Dim value As PDFTextAlign

instance.Align = value

value = instance.Align
public PDFTextAlign Align {get; set;}
public: __property PDFTextAlign get_Align();
public: __property void set_Align(
   PDFTextAlign value
);
public:
property PDFTextAlign Align {
   PDFTextAlign get();
   void set (    PDFTextAlign value);
}

Property Value

a TextAlign enumeration member specifying the alignment of the text within the text box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


BreakLongWords Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : BreakLongWords Property
Gets or sets whether to break no spaced text at character level.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BreakLongWords As Boolean
'Usage

Dim instance As PDFTextFormatOptions
Dim value As Boolean

instance.BreakLongWords = value

value = instance.BreakLongWords
public bool BreakLongWords {get; set;}
public: __property bool get_BreakLongWords();
public: __property void set_BreakLongWords(
   bool value
);
public:
property bool BreakLongWords {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value specifying whether to break no spaced text at character level.
Remarks
This property allows to perform text wrapping at character level, not only at word level. It applies only if the first word in a line is longer than the available width.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


ClipText Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : ClipText Property
Gets or sets the text clipping mode for the text box
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClipText As PDFClipText
'Usage

Dim instance As PDFTextFormatOptions
Dim value As PDFClipText

instance.ClipText = value

value = instance.ClipText
public PDFClipText ClipText {get; set;}
public: __property PDFClipText get_ClipText();
public: __property void set_ClipText(
   PDFClipText value
);
public:
property PDFClipText ClipText {
   PDFClipText get();
   void set (    PDFClipText value);
}

Property Value

a ClipText enumeration member specifying how the text within the text box should be clipped at box boundary.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


FirstLineIndent Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : FirstLineIndent Property
Gets or sets the first line indentation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FirstLineIndent As Double
'Usage

Dim instance As PDFTextFormatOptions
Dim value As Double

instance.FirstLineIndent = value

value = instance.FirstLineIndent
public double FirstLineIndent {get; set;}
public: __property double get_FirstLineIndent();
public: __property void set_FirstLineIndent(
   double value
);
public:
property double FirstLineIndent {
   double get();
   void set (    double value);
}

Property Value

a float value specifying the indentation of the first line.
Remarks
This value allows the indent the first line of a text box. Also, this value is used to indent the next line when a new line has been requested by the \n character, or <br/> tag in a HTML text box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


KeepWhiteSpaces Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : KeepWhiteSpaces Property
Gets or sets whether the white spaces are kept within the text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property KeepWhiteSpaces As Boolean
'Usage

Dim instance As PDFTextFormatOptions
Dim value As Boolean

instance.KeepWhiteSpaces = value

value = instance.KeepWhiteSpaces
public bool KeepWhiteSpaces {get; set;}
public: __property bool get_KeepWhiteSpaces();
public: __property void set_KeepWhiteSpaces(
   bool value
);
public:
property bool KeepWhiteSpaces {
   bool get();
   void set (    bool value);
}

Property Value

a bool value specifying whether the white spaces are kept within the text.
Remarks
This property allows to align text using whitespaces (blanks or tabs). It is useful when using a monospaced font like Courier.

This property has effect only on regular text boxes when using left, center or right alignments. Justified text ignores the value of this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


LineSpacing Property

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : LineSpacing Property
Gets or sets the line spacing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineSpacing As Double
'Usage

Dim instance As PDFTextFormatOptions
Dim value As Double

instance.LineSpacing = value

value = instance.LineSpacing
public double LineSpacing {get; set;}
public: __property double get_LineSpacing();
public: __property void set_LineSpacing(
   double value
);
public:
property double LineSpacing {
   double get();
   void set (    double value);
}

Property Value

a float value specifying the additional space to be added between lines of text.
Remarks
If this value is negative, then the lines of text will be drawn closer. The value of this property is given in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


Orientation Property (PDFTextFormatOptions)

O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : Orientation Property
Gets or sets the text box orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Orientation As Double
'Usage

Dim instance As PDFTextFormatOptions
Dim value As Double

instance.Orientation = value

value = instance.Orientation
public double Orientation {get; set;}
public: __property double get_Orientation();
public: __property void set_Orientation(
   double value
);
public:
property double Orientation {
   double get();
   void set (    double value);
}

Property Value

a float value specifying the rotation angle of the text box.
Remarks
The text boxes are always rotated around the top left corner.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


%%PageItemTitle%%

PDFCcittFaxCompression Enumeration

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFCcittFaxCompression Enumeration
Specifies the available CCITT fax compression modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFCcittFaxCompression
   Inherits System.Enum
'Usage

Dim instance As PDFCcittFaxCompression
public enum PDFCcittFaxCompression : System.Enum
__value public enum PDFCcittFaxCompression : public System.Enum
public enum class PDFCcittFaxCompression : public System.Enum
Members
Member | Description
CcittFaxG31D | 1D CCITT Fax Group 3
CcittFaxG32D | 2D CCITT Fax Group 3
CcittFaxG4 | CCITT Fax Group 4
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.PDFCcittFaxCompression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFClipText Enumeration

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFClipText Enumeration
Specifies the available cliping modes when displaying a text box
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFClipText
   Inherits System.Enum
'Usage

Dim instance As PDFClipText
public enum PDFClipText : System.Enum
__value public enum PDFClipText : public System.Enum
public enum class PDFClipText : public System.Enum
Members
Member | Description
ClipGlyphs | The text is clipped at text box boundary allowing partial text lines to be displayed within the text box.
ClipNone | The text is not clipped, it can flow outside the text box when text lines height is greater than text box height.
ClipWords | The text is logically clipped at word level, only the fully visible lines of text are displayed within the text box.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.PDFClipText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFImageCompression Enumeration

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImageCompression Enumeration
Specifies the available compression methods for storing an image in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFImageCompression
   Inherits System.Enum
'Usage

Dim instance As PDFImageCompression
public enum PDFImageCompression : System.Enum
__value public enum PDFImageCompression : public System.Enum
public enum class PDFImageCompression : public System.Enum
Members
Member | Description
CCITTG4 | Image data is compressed using CCITT G4 method. Valid only for 1bpp images.
Default | The library decides what compression method will be used.
Deflate | The image data is compressed using DEFLATE method.
JPEG | The image data is compressed using JPEG (DCT) method.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.PDFImageCompression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%PageItemTitle%%

PDFKeepAspectRatio Enumeration

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFKeepAspectRatio Enumeration
Specifies the available modes to resize an image when it is drawn on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFKeepAspectRatio
   Inherits System.Enum
'Usage

Dim instance As PDFKeepAspectRatio
public enum PDFKeepAspectRatio : System.Enum
__value public enum PDFKeepAspectRatio : public System.Enum
public enum class PDFKeepAspectRatio : public System.Enum
Members
Member | Description
KeepBoth | The image is drawn inside the given rectangle while keeping the original aspect ratio.
KeepHeight | The image is drawn on the page using the specified Height. The Width is automatically computed in order to keep the original aspect ratio of the image.
KeepNone | The image is drawn on the page using the specified Width and Height values.
KeepWidth | The image is drawn on the page using the specified Width. The Height is automatically computed in order to keep the original aspect ratio of the image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.PDFKeepAspectRatio

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFAlphaChannelMask | Defines an image based mask for an image.
Class | PDFBaseImageMask | Defines a base class for all image masks.
Class | PDFColorImageMask | Defines a color-key mask for an image.
Class | PDFImageMask | Defines an image based mask for an image.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFAlphaChannelMask Class
Members

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFAlphaChannelMask Class
Defines an image based mask for an image.
Object Model
PDFAlphaChannelMask Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAlphaChannelMask
   Inherits PDFImageMask
'Usage

Dim instance As PDFAlphaChannelMask
public class PDFAlphaChannelMask : PDFImageMask
public __gc class PDFAlphaChannelMask : public PDFImageMask
public ref class PDFAlphaChannelMask : public PDFImageMask
Remarks
An alpha channel mask allows to specify a grayscale bitmap that defines the alpha channel values for the image. Only grayscale images are supported as alpha channel masks.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFAlphaChannelMask

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAlphaChannelMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%% $$Members$$

PDFAlphaChannelMask Class Members

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFAlphaChannelMask Class

The following tables list the members exposed by PDFAlphaChannelMask.

Public Constructors
 | Name | Description
Public Constructor | PDFAlphaChannelMask Constructor | Overloaded.
Top
See Also

Reference

PDFAlphaChannelMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

PDFAlphaChannelMask Constructor

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class : PDFAlphaChannelMask Constructor
Overload List
Overload | Description
PDFAlphaChannelMask Constructor(String) | Initializes a new PDFAlphaChannelMask object based on a file.
PDFAlphaChannelMask Constructor(Stream) | Initializes a new PDFAlphaChannelMask object based on a stream.
PDFAlphaChannelMask Constructor(Bitmap) | Initializes a new PDFAlphaChannelMask object based on a System.Drawing.Bitmap object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members


%%PageItemTitle%%

PDFAlphaChannelMask Constructor(String)

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class > PDFAlphaChannelMask Constructor : PDFAlphaChannelMask Constructor(String)
the file representing the mask
Initializes a new PDFAlphaChannelMask object based on a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String _
)
'Usage

Dim fileName As String

Dim instance As New PDFAlphaChannelMask(fileName)
public PDFAlphaChannelMask(
   string fileName
)
public: PDFAlphaChannelMask(
   string* fileName
)
public:
PDFAlphaChannelMask(
   String^ fileName
)

Parameters

fileName
the file representing the mask
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members
Overload List


%%PageItemTitle%%

PDFAlphaChannelMask Constructor(Stream)

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class > PDFAlphaChannelMask Constructor : PDFAlphaChannelMask Constructor(Stream)
the stream representing the mask
Initializes a new PDFAlphaChannelMask object based on a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PDFAlphaChannelMask(stream)
public PDFAlphaChannelMask(
   Stream stream
)
public: PDFAlphaChannelMask(
   Stream* stream
)
public:
PDFAlphaChannelMask(
   Stream^ stream
)

Parameters

stream
the stream representing the mask
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members
Overload List


%%PageItemTitle%%

PDFAlphaChannelMask Constructor(Bitmap)

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class > PDFAlphaChannelMask Constructor : PDFAlphaChannelMask Constructor(Bitmap)
the image representing the mask
Initializes a new PDFAlphaChannelMask object based on a System.Drawing.Bitmap object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As Bitmap _
)
'Usage

Dim image As Bitmap

Dim instance As New PDFAlphaChannelMask(image)
public PDFAlphaChannelMask(
   Bitmap image
)
public: PDFAlphaChannelMask(
   Bitmap* image
)
public:
PDFAlphaChannelMask(
   Bitmap^ image
)

Parameters

image
the image representing the mask
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members
Overload List


%%PageItemTitle%%

PDFBaseImageMask Class
Members

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFBaseImageMask Class
Defines a base class for all image masks.
Object Model
PDFBaseImageMask Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFBaseImageMask
'Usage

Dim instance As PDFBaseImageMask
public abstract class PDFBaseImageMask
public __gc abstract class PDFBaseImageMask
public ref class PDFBaseImageMask abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFColorImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBaseImageMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%% $$Members$$

PDFBaseImageMask Class Members

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFBaseImageMask Class

The following tables list the members exposed by PDFBaseImageMask.

See Also

Reference

PDFBaseImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

PDFColorImageMask Class
Members

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFColorImageMask Class
Defines a color-key mask for an image.
Object Model
PDFColorImageMask ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class PDFColorImageMask
   Inherits PDFBaseImageMask
'Usage

Dim instance As PDFColorImageMask
public sealed class PDFColorImageMask : PDFBaseImageMask
public __gc __sealed class PDFColorImageMask : public PDFBaseImageMask
public ref class PDFColorImageMask sealed : public PDFBaseImageMask
Remarks
A color-key mask allows to specify a range of colors within an image to be treated as transparent when the image is painted on the page. All the colors between startColor and endColor will be treated as transparent.
A color is considered higher than startColor and lower than endColor when all its components meet this considition individually. For example, in RGB colorspace, being given the color C with its components (Cr, Cg, Cb), then startColor (SC) <= C <= endColor (EC) when:
SCr <= Cr <= ECr AND SCg <= Cg <= ECg AND SCb <= Cb <= ECb.
Note: A color image mask should not be used with jpeg images because they use a lossy image compression and unwanted effects might appear.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFColorImageMask

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColorImageMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%% $$Members$$

PDFColorImageMask Class Members
Properties

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFColorImageMask Class

The following tables list the members exposed by PDFColorImageMask.

Public Constructors
 | Name | Description
Public Constructor | PDFColorImageMask Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | EndColor | Gets or sets the end color for image mask.
Public Property | StartColor | Gets or sets the start color for image mask.
Top
See Also

Reference

PDFColorImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

PDFColorImageMask Constructor

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class : PDFColorImageMask Constructor
Overload List
Overload | Description
PDFColorImageMask Constructor() | Initializes a new PDFColorImageMask object considering white as transparent color.
PDFColorImageMask Constructor(PDFColor,PDFColor) | Initializes a new PDFColorImageMask object specifying a start and an end color for the image mask.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members


%%PageItemTitle%%

PDFColorImageMask Constructor()

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class > PDFColorImageMask Constructor : PDFColorImageMask Constructor()
Initializes a new PDFColorImageMask object considering white as transparent color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFColorImageMask()
public PDFColorImageMask()
public: PDFColorImageMask();
public:
PDFColorImageMask();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members
Overload List


%%PageItemTitle%%

PDFColorImageMask Constructor(PDFColor,PDFColor)

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class > PDFColorImageMask Constructor : PDFColorImageMask Constructor(PDFColor,PDFColor)
the start color for the image mask.
the end color for the image mask.
Initializes a new PDFColorImageMask object specifying a start and an end color for the image mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startColor As PDFColor, _
   ByVal endColor As PDFColor _
)
'Usage

Dim startColor As PDFColor
Dim endColor As PDFColor

Dim instance As New PDFColorImageMask(startColor, endColor)
public PDFColorImageMask(
   PDFColor startColor,
   PDFColor endColor
)
public: PDFColorImageMask(
   PDFColor* startColor,
   PDFColor* endColor
)
public:
PDFColorImageMask(
   PDFColor^ startColor,
   PDFColor^ endColor
)

Parameters

startColor
the start color for the image mask.
endColor
the end color for the image mask.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFColorImageMask Class Properties

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFColorImageMask Class

For a list of all members of this type, see PDFColorImageMask members.

Public Properties
 | Name | Description
Public Property | EndColor | Gets or sets the end color for image mask.
Public Property | StartColor | Gets or sets the start color for image mask.
Top
See Also

Reference

PDFColorImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


EndColor Property (PDFColorImageMask)

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class : EndColor Property
Gets or sets the end color for image mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndColor As PDFColor
'Usage

Dim instance As PDFColorImageMask
Dim value As PDFColor

instance.EndColor = value

value = instance.EndColor
public PDFColor EndColor {get; set;}
public: __property PDFColor* get_EndColor();
public: __property void set_EndColor(
   PDFColor* value
);
public:
property PDFColor^ EndColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the end color for the image mask.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members


StartColor Property (PDFColorImageMask)

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class : StartColor Property
Gets or sets the start color for image mask.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartColor As PDFColor
'Usage

Dim instance As PDFColorImageMask
Dim value As PDFColor

instance.StartColor = value

value = instance.StartColor
public PDFColor StartColor {get; set;}
public: __property PDFColor* get_StartColor();
public: __property void set_StartColor(
   PDFColor* value
);
public:
property PDFColor^ StartColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the start color for the image mask.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members


%%PageItemTitle%%

PDFImageMask Class
Members

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFImageMask Class
Defines an image based mask for an image.
Object Model
PDFImageMask Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFImageMask
   Inherits PDFBaseImageMask
'Usage

Dim instance As PDFImageMask
public class PDFImageMask : PDFBaseImageMask
public __gc class PDFImageMask : public PDFBaseImageMask
public ref class PDFImageMask : public PDFBaseImageMask
Remarks
An image based mask allows to specify a monochrome bitmap that defines what regions of the base image will be painted or not on the page.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFAlphaChannelMask

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%% $$Members$$

PDFImageMask Class Members

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFImageMask Class

The following tables list the members exposed by PDFImageMask.

Public Constructors
 | Name | Description
Public Constructor | PDFImageMask Constructor | Overloaded.
Top
See Also

Reference

PDFImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


%%PageItemTitle%%

PDFImageMask Constructor

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class : PDFImageMask Constructor
Overload List
Overload | Description
PDFImageMask Constructor(String) | Initializes a new PDFImageMask object based on a file.
PDFImageMask Constructor(Stream) | Initializes a new PDFImageMask object based on a stream.
PDFImageMask Constructor(Bitmap) | Initializes a new PDFImageMask object based on a System.Drawing.Image object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageMask Class
PDFImageMask Members


%%PageItemTitle%%

PDFImageMask Constructor(String)

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class > PDFImageMask Constructor : PDFImageMask Constructor(String)
the file representing the mask
Initializes a new PDFImageMask object based on a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileName As String _
)
'Usage

Dim fileName As String

Dim instance As New PDFImageMask(fileName)
public PDFImageMask(
   string fileName
)
public: PDFImageMask(
   string* fileName
)
public:
PDFImageMask(
   String^ fileName
)

Parameters

fileName
the file representing the mask
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageMask Class
PDFImageMask Members
Overload List


%%PageItemTitle%%

PDFImageMask Constructor(Stream)

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class > PDFImageMask Constructor : PDFImageMask Constructor(Stream)
the stream representing the mask
Initializes a new PDFImageMask object based on a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PDFImageMask(stream)
public PDFImageMask(
   Stream stream
)
public: PDFImageMask(
   Stream* stream
)
public:
PDFImageMask(
   Stream^ stream
)

Parameters

stream
the stream representing the mask
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageMask Class
PDFImageMask Members
Overload List


%%PageItemTitle%%

PDFImageMask Constructor(Bitmap)

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class > PDFImageMask Constructor : PDFImageMask Constructor(Bitmap)
the image representing the mask
Initializes a new PDFImageMask object based on a System.Drawing.Image object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As Bitmap _
)
'Usage

Dim image As Bitmap

Dim instance As New PDFImageMask(image)
public PDFImageMask(
   Bitmap image
)
public: PDFImageMask(
   Bitmap* image
)
public:
PDFImageMask(
   Bitmap^ image
)

Parameters

image
the image representing the mask
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageMask Class
PDFImageMask Members
Overload List


O2S.Components.PDF4NET.Measures Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFMeasure | Defines the base class for PDF measures.
Class | PDFNumberFormat | Defines how a measure units should be formatted for display.
Class | PDFNumberFormatCollection | Defines a collection of number formats.
Class | PDFRectilinearMeasure | Defines a rectilinear measure.
Class | PDFViewport | Defines a rectangular region of a page.
Class | PDFViewportCollection | Defines a collection of viewports.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFMeasure Class
Members

O2S.Components.PDF4NET.Measures Namespace : PDFMeasure Class
Defines the base class for PDF measures.
Object Model
PDFMeasure Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFMeasure
'Usage

Dim instance As PDFMeasure
public abstract class PDFMeasure
public __gc abstract class PDFMeasure
public ref class PDFMeasure abstract
Remarks
A measure dictionary shall specify an alternative coordinate system for a region of a page. Along with the viewport object, it shall provide the information needed to convert coordinates in the page's coordinate system to coordinates in the measuring coordinate system. The measure object shall provide information for formatting the resulting values into textual form for presentation in a graphical user interface.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Measures.PDFMeasure
O2S.Components.PDF4NET.Geo.PDFGeospatialMeasure
O2S.Components.PDF4NET.Measures.PDFRectilinearMeasure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasure Members
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%% $$Members$$

PDFMeasure Class Members

O2S.Components.PDF4NET.Measures Namespace : PDFMeasure Class

The following tables list the members exposed by PDFMeasure.

See Also

Reference

PDFMeasure Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%%

PDFNumberFormat Class
Members

O2S.Components.PDF4NET.Measures Namespace : PDFNumberFormat Class
Defines how a measure units should be formatted for display.
Object Model
PDFNumberFormat Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFNumberFormat
'Usage

Dim instance As PDFNumberFormat
public class PDFNumberFormat
public __gc class PDFNumberFormat
public ref class PDFNumberFormat
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Measures.PDFNumberFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Members
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%% $$Members$$

PDFNumberFormat Class Members
Properties

O2S.Components.PDF4NET.Measures Namespace : PDFNumberFormat Class

The following tables list the members exposed by PDFNumberFormat.

Public Constructors
 | Name | Description
Public Constructor | PDFNumberFormat Constructor | Initializes a new PDFNumberFormat object.
Top
Public Properties
 | Name | Description
Public Property | ConversionFactor | Gets or sets the conversion factor.
Public Property | DecimalSeparator | Gets or sets the decimal separator.
Public Property | Denominator | Gets or sets the denominator.
Public Property | DisplayUnitAsSuffix | Gets or sets a value indicating whether the Unit is displayed before or after the calculated unit value.
Public Property | DoNotReduceFraction | Gets or sets a value indicating whether the fractional part can be reduced or the low-order zeros truncated.
Public Property | FractionDisplay | Gets or sets the fraction display.
Public Property | Precision |
Public Property | ThousandsSeparator | Gets or sets the thousands separator.
Public Property | Unit | Gets or sets the unit.
Public Property | UnitPrefix | Gets or sets the unit prefix.
Public Property | UnitSuffix | Gets or sets the unit suffix.
Top
See Also

Reference

PDFNumberFormat Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%%

PDFNumberFormat Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : PDFNumberFormat Constructor
Initializes a new PDFNumberFormat object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFNumberFormat()
public PDFNumberFormat()
public: PDFNumberFormat();
public:
PDFNumberFormat();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


%%PageItemTitle%% $$Properties$$

PDFNumberFormat Class Properties

O2S.Components.PDF4NET.Measures Namespace : PDFNumberFormat Class

For a list of all members of this type, see PDFNumberFormat members.

Public Properties
 | Name | Description
Public Property | ConversionFactor | Gets or sets the conversion factor.
Public Property | DecimalSeparator | Gets or sets the decimal separator.
Public Property | Denominator | Gets or sets the denominator.
Public Property | DisplayUnitAsSuffix | Gets or sets a value indicating whether the Unit is displayed before or after the calculated unit value.
Public Property | DoNotReduceFraction | Gets or sets a value indicating whether the fractional part can be reduced or the low-order zeros truncated.
Public Property | FractionDisplay | Gets or sets the fraction display.
Public Property | Precision |
Public Property | ThousandsSeparator | Gets or sets the thousands separator.
Public Property | Unit | Gets or sets the unit.
Public Property | UnitPrefix | Gets or sets the unit prefix.
Public Property | UnitSuffix | Gets or sets the unit suffix.
Top
See Also

Reference

PDFNumberFormat Class
O2S.Components.PDF4NET.Measures Namespace


ConversionFactor Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : ConversionFactor Property
Gets or sets the conversion factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ConversionFactor As Double
'Usage

Dim instance As PDFNumberFormat
Dim value As Double

instance.ConversionFactor = value

value = instance.ConversionFactor
public double ConversionFactor {get; set;}
public: __property double get_ConversionFactor();
public: __property void set_ConversionFactor(
   double value
);
public:
property double ConversionFactor {
   double get();
   void set (    double value);
}

Property Value

The conversion factor used to multiply a value in partial units of the previous number format collection element to obtain a value in the units of this object.
Remarks
When this object is in the first number format in the array, its meaning (that is, what it shall be multiplied by) depends on which property in the PDFRectilinearMeasure references the number format collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


DecimalSeparator Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : DecimalSeparator Property
Gets or sets the decimal separator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DecimalSeparator As String
'Usage

Dim instance As PDFNumberFormat
Dim value As String

instance.DecimalSeparator = value

value = instance.DecimalSeparator
public string DecimalSeparator {get; set;}
public: __property string* get_DecimalSeparator();
public: __property void set_DecimalSeparator(
   string* value
);
public:
property String^ DecimalSeparator {
   String^ get();
   void set (    String^ value);
}

Property Value

Text that shall be used as the decimal position in displaying numerical values.
Remarks
An empty string indicates that the default shall be used.
Default value is PERIOD (0x2E).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


Denominator Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : Denominator Property
Gets or sets the denominator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Denominator As Integer
'Usage

Dim instance As PDFNumberFormat
Dim value As Integer

instance.Denominator = value

value = instance.Denominator
public int Denominator {get; set;}
public: __property int get_Denominator();
public: __property void set_Denominator(
   int value
);
public:
property int Denominator {
   int get();
   void set (    int value);
}

Property Value

The denominator of a fractional display when FractionDisplay property is set to F.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


DisplayUnitAsSuffix Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : DisplayUnitAsSuffix Property
Gets or sets a value indicating whether the Unit is displayed before or after the calculated unit value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayUnitAsSuffix As Boolean
'Usage

Dim instance As PDFNumberFormat
Dim value As Boolean

instance.DisplayUnitAsSuffix = value

value = instance.DisplayUnitAsSuffix
public bool DisplayUnitAsSuffix {get; set;}
public: __property bool get_DisplayUnitAsSuffix();
public: __property void set_DisplayUnitAsSuffix(
   bool value
);
public:
property bool DisplayUnitAsSuffix {
   bool get();
   void set (    bool value);
}

Property Value

When true, the Unit is a suffix to the value, otherwise it is a prefix to the value.
Remarks
The strings specified by the UnitPrefix and UnitSuffix properties shall be concatenated before considering this property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


DoNotReduceFraction Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : DoNotReduceFraction Property
Gets or sets a value indicating whether the fractional part can be reduced or the low-order zeros truncated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DoNotReduceFraction As Boolean
'Usage

Dim instance As PDFNumberFormat
Dim value As Boolean

instance.DoNotReduceFraction = value

value = instance.DoNotReduceFraction
public bool DoNotReduceFraction {get; set;}
public: __property bool get_DoNotReduceFraction();
public: __property void set_DoNotReduceFraction(
   bool value
);
public:
property bool DoNotReduceFraction {
   bool get();
   void set (    bool value);
}

Property Value

When true, a fractional value formatted according to the Precision / Denominator properties may not have its denominator reduced or low-order zeros truncated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


FractionDisplay Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : FractionDisplay Property
Gets or sets the fraction display.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FractionDisplay As String
'Usage

Dim instance As PDFNumberFormat
Dim value As String

instance.FractionDisplay = value

value = instance.FractionDisplay
public string FractionDisplay {get; set;}
public: __property string* get_FractionDisplay();
public: __property void set_FractionDisplay(
   string* value
);
public:
property String^ FractionDisplay {
   String^ get();
   void set (    String^ value);
}

Property Value

A value indicating whether and in what manner to display a fractional value from the result of converting to the units of this object by means of the ConversionFactor property.
Remarks
Supported values are: D - decimal; F - fraction; R - round; T - truncate.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


Precision Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : Precision Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Precision As Integer
'Usage

Dim instance As PDFNumberFormat
Dim value As Integer

instance.Precision = value

value = instance.Precision
public int Precision {get; set;}
public: __property int get_Precision();
public: __property void set_Precision(
   int value
);
public:
property int Precision {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


ThousandsSeparator Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : ThousandsSeparator Property
Gets or sets the thousands separator.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ThousandsSeparator As String
'Usage

Dim instance As PDFNumberFormat
Dim value As String

instance.ThousandsSeparator = value

value = instance.ThousandsSeparator
public string ThousandsSeparator {get; set;}
public: __property string* get_ThousandsSeparator();
public: __property void set_ThousandsSeparator(
   string* value
);
public:
property String^ ThousandsSeparator {
   String^ get();
   void set (    String^ value);
}

Property Value

Text that shall be used between orders of thousands in display of numerical values.
Remarks
An empty string indicates that no text shall be added.
Default value is COMMA (0x2C).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


Unit Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : Unit Property
Gets or sets the unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Unit As String
'Usage

Dim instance As PDFNumberFormat
Dim value As String

instance.Unit = value

value = instance.Unit
public string Unit {get; set;}
public: __property string* get_Unit();
public: __property void set_Unit(
   string* value
);
public:
property String^ Unit {
   String^ get();
   void set (    String^ value);
}

Property Value

A text string specifying a label for displaying the units represented by this object in a user interface; the label should use a universally recognized abbreviation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


UnitPrefix Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : UnitPrefix Property
Gets or sets the unit prefix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnitPrefix As String
'Usage

Dim instance As PDFNumberFormat
Dim value As String

instance.UnitPrefix = value

value = instance.UnitPrefix
public string UnitPrefix {get; set;}
public: __property string* get_UnitPrefix();
public: __property void set_UnitPrefix(
   string* value
);
public:
property String^ UnitPrefix {
   String^ get();
   void set (    String^ value);
}

Property Value

Text that shall be concatenated to the left of the label specified by Unit property.
Remarks
An empty string indicates that no text shall be added.
Default value is a single ASCII SPACE character (0x20).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


UnitSuffix Property

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : UnitSuffix Property
Gets or sets the unit suffix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnitSuffix As String
'Usage

Dim instance As PDFNumberFormat
Dim value As String

instance.UnitSuffix = value

value = instance.UnitSuffix
public string UnitSuffix {get; set;}
public: __property string* get_UnitSuffix();
public: __property void set_UnitSuffix(
   string* value
);
public:
property String^ UnitSuffix {
   String^ get();
   void set (    String^ value);
}

Property Value

Text that shall be concatenated after the label specified by Unit property.
Remarks
An empty string indicates that no text shall be added.
Default value is a single ASCII SPACE character (0x20).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


%%PageItemTitle%%

PDFNumberFormatCollection Class
Members

O2S.Components.PDF4NET.Measures Namespace : PDFNumberFormatCollection Class
Defines a collection of number formats.
Object Model
PDFNumberFormatCollection ClassPDFNumberFormat Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFNumberFormatCollection
   Inherits System.Collections.ObjectModel.Collection(Of PDFNumberFormat)
'Usage

Dim instance As PDFNumberFormatCollection
public class PDFNumberFormatCollection : System.Collections.ObjectModel.Collection<PDFNumberFormat>
public __gc class PDFNumberFormatCollection : public System.Collections.ObjectModel.Collection<PDFNumberFormat>
public ref class PDFNumberFormatCollection : public System.Collections.ObjectModel.Collection<PDFNumberFormat>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Measures.PDFNumberFormatCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormatCollection Members
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%% $$Members$$

PDFNumberFormatCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Measures Namespace : PDFNumberFormatCollection Class

The following tables list the members exposed by PDFNumberFormatCollection.

Public Constructors
 | Name | Description
Public Constructor | PDFNumberFormatCollection Constructor | Initializes a new PDFNumberFormatCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Top
See Also

Reference

PDFNumberFormatCollection Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%%

PDFNumberFormatCollection Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormatCollection Class : PDFNumberFormatCollection Constructor
Initializes a new PDFNumberFormatCollection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFNumberFormatCollection()
public PDFNumberFormatCollection()
public: PDFNumberFormatCollection();
public:
PDFNumberFormatCollection();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormatCollection Class
PDFNumberFormatCollection Members


%%PageItemTitle%%

PDFRectilinearMeasure Class
Members

O2S.Components.PDF4NET.Measures Namespace : PDFRectilinearMeasure Class
Defines a rectilinear measure.
Object Model
PDFRectilinearMeasure ClassPDFNumberFormatCollection ClassPDFNumberFormat ClassPDFNumberFormatCollection ClassPDFNumberFormat ClassPDFNumberFormatCollection ClassPDFNumberFormat ClassPDFPoint ClassPDFNumberFormatCollection ClassPDFNumberFormat ClassPDFNumberFormatCollection ClassPDFNumberFormat ClassPDFNumberFormatCollection ClassPDFNumberFormat Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRectilinearMeasure
   Inherits PDFMeasure
'Usage

Dim instance As PDFRectilinearMeasure
public class PDFRectilinearMeasure : PDFMeasure
public __gc class PDFRectilinearMeasure : public PDFMeasure
public ref class PDFRectilinearMeasure : public PDFMeasure
Remarks
The rectilinear measure defines a rectilinear coordinate system entry which is defined as one in which the x and y axes are perpendicular and have units that increment linearly (to the right and up, respectively).
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Measures.PDFMeasure
O2S.Components.PDF4NET.Measures.PDFRectilinearMeasure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Members
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%% $$Members$$

PDFRectilinearMeasure Class Members
Properties

O2S.Components.PDF4NET.Measures Namespace : PDFRectilinearMeasure Class

The following tables list the members exposed by PDFRectilinearMeasure.

Public Constructors
 | Name | Description
Public Constructor | PDFRectilinearMeasure Constructor | Initializes a new PDFRectilinearMeasure object.
Top
Public Properties
 | Name | Description
Public Property | Angle | Gets or sets the number formats for angles.
Public Property | Area | Gets or sets the number formats for area.
Public Property | CXY | Gets or sets the conversion factor.
Public Property | Distance | Gets or sets the number formats for distance.
Public Property | Origin | Gets or sets the origin of the coordinate system.
Public Property | ScaleRatio | Gets or sets the scale ratio.
Public Property | Slope | Gets or sets the number formats for slopes.
Public Property | X | Gets or sets the number formats for X axis.
Public Property | Y | Gets or sets the number formats for Y axis.
Top
See Also

Reference

PDFRectilinearMeasure Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%%

PDFRectilinearMeasure Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : PDFRectilinearMeasure Constructor
Initializes a new PDFRectilinearMeasure object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRectilinearMeasure()
public PDFRectilinearMeasure()
public: PDFRectilinearMeasure();
public:
PDFRectilinearMeasure();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


%%PageItemTitle%% $$Properties$$

PDFRectilinearMeasure Class Properties

O2S.Components.PDF4NET.Measures Namespace : PDFRectilinearMeasure Class

For a list of all members of this type, see PDFRectilinearMeasure members.

Public Properties
 | Name | Description
Public Property | Angle | Gets or sets the number formats for angles.
Public Property | Area | Gets or sets the number formats for area.
Public Property | CXY | Gets or sets the conversion factor.
Public Property | Distance | Gets or sets the number formats for distance.
Public Property | Origin | Gets or sets the origin of the coordinate system.
Public Property | ScaleRatio | Gets or sets the scale ratio.
Public Property | Slope | Gets or sets the number formats for slopes.
Public Property | X | Gets or sets the number formats for X axis.
Public Property | Y | Gets or sets the number formats for Y axis.
Top
See Also

Reference

PDFRectilinearMeasure Class
O2S.Components.PDF4NET.Measures Namespace


Angle Property

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : Angle Property
Gets or sets the number formats for angles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Angle As PDFNumberFormatCollection
'Usage

Dim instance As PDFRectilinearMeasure
Dim value As PDFNumberFormatCollection

instance.Angle = value

value = instance.Angle
public PDFNumberFormatCollection Angle {get; set;}
public: __property PDFNumberFormatCollection* get_Angle();
public: __property void set_Angle(
   PDFNumberFormatCollection* value
);
public:
property PDFNumberFormatCollection^ Angle {
   PDFNumberFormatCollection^ get();
   void set (    PDFNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of angles.
Remarks
The first element in the collection shall specify the conversion to the largest angle unit from degrees. The scale factor from CXY (if present) shall be used to convert from default default user space units to the appropriate units before applying the angle function.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


Area Property

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : Area Property
Gets or sets the number formats for area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Area As PDFNumberFormatCollection
'Usage

Dim instance As PDFRectilinearMeasure
Dim value As PDFNumberFormatCollection

instance.Area = value

value = instance.Area
public PDFNumberFormatCollection Area {get; set;}
public: __property PDFNumberFormatCollection* get_Area();
public: __property void set_Area(
   PDFNumberFormatCollection* value
);
public:
property PDFNumberFormatCollection^ Area {
   PDFNumberFormatCollection^ get();
   void set (    PDFNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of area.
Remarks
The first element in the collection shall specify the conversion to the largest area unit from units represented by the first element in X, squared. The scale factors from X, Y (if present) and CXY (if Y is present) shall be used to convert from default user space units to the appropriate units before applying the area function.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


CXY Property

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : CXY Property
Gets or sets the conversion factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CXY As Double
'Usage

Dim instance As PDFRectilinearMeasure
Dim value As Double

instance.CXY = value

value = instance.CXY
public double CXY {get; set;}
public: __property double get_CXY();
public: __property void set_CXY(
   double value
);
public:
property double CXY {
   double get();
   void set (    double value);
}

Property Value

A factor that shall be used to convert the largest units along the y axis to the largest units along the x axis.
Remarks
It shall be used for calculations (distance, area, and angle) where the units are be equivalent; if not specified, these calculations may not be performed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


Distance Property

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : Distance Property
Gets or sets the number formats for distance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Distance As PDFNumberFormatCollection
'Usage

Dim instance As PDFRectilinearMeasure
Dim value As PDFNumberFormatCollection

instance.Distance = value

value = instance.Distance
public PDFNumberFormatCollection Distance {get; set;}
public: __property PDFNumberFormatCollection* get_Distance();
public: __property void set_Distance(
   PDFNumberFormatCollection* value
);
public:
property PDFNumberFormatCollection^ Distance {
   PDFNumberFormatCollection^ get();
   void set (    PDFNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of distance in any direction.
Remarks
The first element in the collection shall specify the conversion to the largest distance unit from units represented by the first element in X. The scale factors from X, Y (if present) and CXY (if Y is present) shall be used to convert from default user space units to the appropriate units before applying the distance function.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


Origin Property

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : Origin Property
Gets or sets the origin of the coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Origin As PDFPoint
'Usage

Dim instance As PDFRectilinearMeasure
Dim value As PDFPoint

value = instance.Origin
public PDFPoint Origin {get;}
public: __property PDFPoint* get_Origin();
public:
property PDFPoint^ Origin {
   PDFPoint^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFPoint object that shall specify the origin of the measurement coordinate system in default user space coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


ScaleRatio Property

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : ScaleRatio Property
Gets or sets the scale ratio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScaleRatio As String
'Usage

Dim instance As PDFRectilinearMeasure
Dim value As String

instance.ScaleRatio = value

value = instance.ScaleRatio
public string ScaleRatio {get; set;}
public: __property string* get_ScaleRatio();
public: __property void set_ScaleRatio(
   string* value
);
public:
property String^ ScaleRatio {
   String^ get();
   void set (    String^ value);
}

Property Value

A text string expressing the scale ratio of the drawing in the region corresponding to this measure.
Remarks
Universally recognized unit abbreviations should be used, either matching those of the number format objects in this measure or those of commonly used scale ratios.
For example: 1/4 in = 1 ft
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


Slope Property

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : Slope Property
Gets or sets the number formats for slopes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Slope As PDFNumberFormatCollection
'Usage

Dim instance As PDFRectilinearMeasure
Dim value As PDFNumberFormatCollection

instance.Slope = value

value = instance.Slope
public PDFNumberFormatCollection Slope {get; set;}
public: __property PDFNumberFormatCollection* get_Slope();
public: __property void set_Slope(
   PDFNumberFormatCollection* value
);
public:
property PDFNumberFormatCollection^ Slope {
   PDFNumberFormatCollection^ get();
   void set (    PDFNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of the slope of a line.
Remarks
The first element in the collection shall specify the conversion to the largest slope unit from units represented by the first element in Y divided by the first element in X. The scale factors from X, Y (if present) and CXY (if Y is present) shall be used to convert from default user space units to the appropriate units before applying the slope function.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


X Property (PDFRectilinearMeasure)

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : X Property
Gets or sets the number formats for X axis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property X As PDFNumberFormatCollection
'Usage

Dim instance As PDFRectilinearMeasure
Dim value As PDFNumberFormatCollection

instance.X = value

value = instance.X
public PDFNumberFormatCollection X {get; set;}
public: __property PDFNumberFormatCollection* get_X();
public: __property void set_X(
   PDFNumberFormatCollection* value
);
public:
property PDFNumberFormatCollection^ X {
   PDFNumberFormatCollection^ get();
   void set (    PDFNumberFormatCollection^ value);
}

Property Value

A number format array for measurement of change along the x axis and, if Y is not present, along the y axis as well.
Remarks
The first element in the array shall contain the scale factor for converting from default user space units to the largest units in the measuring coordinate system along that axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


Y Property (PDFRectilinearMeasure)

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : Y Property
Gets or sets the number formats for Y axis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As PDFNumberFormatCollection
'Usage

Dim instance As PDFRectilinearMeasure
Dim value As PDFNumberFormatCollection

instance.Y = value

value = instance.Y
public PDFNumberFormatCollection Y {get; set;}
public: __property PDFNumberFormatCollection* get_Y();
public: __property void set_Y(
   PDFNumberFormatCollection* value
);
public:
property PDFNumberFormatCollection^ Y {
   PDFNumberFormatCollection^ get();
   void set (    PDFNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of change along the y axis.
Remarks
The first element in the array shall contain the scale factor for converting from default user space units to the largest units in the measuring coordinate system along the y axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


%%PageItemTitle%%

PDFViewport Class
Members

O2S.Components.PDF4NET.Measures Namespace : PDFViewport Class
Defines a rectangular region of a page.
Object Model
PDFViewport ClassPDFRectangle ClassPDFMeasure ClassPDFPointData Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFViewport
'Usage

Dim instance As PDFViewport
public class PDFViewport
public __gc class PDFViewport
public ref class PDFViewport
Remarks
Viewports allow different measurement scales (specified by the Measure property) to be used in different areas of a page, if necessary.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Measures.PDFViewport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewport Members
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%% $$Members$$

PDFViewport Class Members
Properties

O2S.Components.PDF4NET.Measures Namespace : PDFViewport Class

The following tables list the members exposed by PDFViewport.

Public Constructors
 | Name | Description
Public Constructor | PDFViewport Constructor | Initializes a new PDFViewport object.
Top
Public Properties
 | Name | Description
Public Property | BoundingBox | Gets or sets the bounding box.
Public Property | Measure | Gets or sets the viewport measure.
Public Property | Name | Gets or sets the name.
Public Property | PointData | Gets or sets the point data.
Top
See Also

Reference

PDFViewport Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%%

PDFViewport Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFViewport Class : PDFViewport Constructor
Initializes a new PDFViewport object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFViewport()
public PDFViewport()
public: PDFViewport();
public:
PDFViewport();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewport Class
PDFViewport Members


%%PageItemTitle%% $$Properties$$

PDFViewport Class Properties

O2S.Components.PDF4NET.Measures Namespace : PDFViewport Class

For a list of all members of this type, see PDFViewport members.

Public Properties
 | Name | Description
Public Property | BoundingBox | Gets or sets the bounding box.
Public Property | Measure | Gets or sets the viewport measure.
Public Property | Name | Gets or sets the name.
Public Property | PointData | Gets or sets the point data.
Top
See Also

Reference

PDFViewport Class
O2S.Components.PDF4NET.Measures Namespace


BoundingBox Property (PDFViewport)

O2S.Components.PDF4NET.Measures Namespace > PDFViewport Class : BoundingBox Property
Gets or sets the bounding box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BoundingBox As PDFRectangle
'Usage

Dim instance As PDFViewport
Dim value As PDFRectangle

instance.BoundingBox = value

value = instance.BoundingBox
public PDFRectangle BoundingBox {get; set;}
public: __property PDFRectangle* get_BoundingBox();
public: __property void set_BoundingBox(
   PDFRectangle* value
);
public:
property PDFRectangle^ BoundingBox {
   PDFRectangle^ get();
   void set (    PDFRectangle^ value);
}

Property Value

A O2S.Components.PDF4NET.PDFRectangle that specifies the viewport bounding box.
Remarks
The two coordinate pairs of the rectangle shall be specified in normalized form; that is, lower-left followed by upper-right, relative to the measuring coordinate system. This ordering shall determine the orientation of the measuring coordinate system (that is, the direction of the positive x and yaxes) in this viewport, which may have a different rotation from the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewport Class
PDFViewport Members


Measure Property

O2S.Components.PDF4NET.Measures Namespace > PDFViewport Class : Measure Property
Gets or sets the viewport measure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Measure As PDFMeasure
'Usage

Dim instance As PDFViewport
Dim value As PDFMeasure

instance.Measure = value

value = instance.Measure
public PDFMeasure Measure {get; set;}
public: __property PDFMeasure* get_Measure();
public: __property void set_Measure(
   PDFMeasure* value
);
public:
property PDFMeasure^ Measure {
   PDFMeasure^ get();
   void set (    PDFMeasure^ value);
}

Property Value

The viewport measure.
Remarks
A PDFMeasure object that specifies the scale and units that shall apply to measurements taken on the contents within the viewport.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewport Class
PDFViewport Members


Name Property (PDFViewport)

O2S.Components.PDF4NET.Measures Namespace > PDFViewport Class : Name Property
Gets or sets the name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFViewport
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

A descriptive text string or title of the viewport, intended for use in a user interface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewport Class
PDFViewport Members


PointData Property

O2S.Components.PDF4NET.Measures Namespace > PDFViewport Class : PointData Property
Gets or sets the point data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PointData As PDFPointData
'Usage

Dim instance As PDFViewport
Dim value As PDFPointData

instance.PointData = value

value = instance.PointData
public PDFPointData PointData {get; set;}
public: __property PDFPointData* get_PointData();
public: __property void set_PointData(
   PDFPointData* value
);
public:
property PDFPointData^ PointData {
   PDFPointData^ get();
   void set (    PDFPointData^ value);
}

Property Value

A O2S.Components.PDF4NET.Geo.PDFPointData object that shall specify the extended geospatial data that applies to the viewport.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewport Class
PDFViewport Members


%%PageItemTitle%%

PDFViewportCollection Class
Members

O2S.Components.PDF4NET.Measures Namespace : PDFViewportCollection Class
Defines a collection of viewports.
Object Model
PDFViewportCollection ClassPDFViewport Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFViewportCollection
   Inherits System.Collections.ObjectModel.Collection(Of PDFViewport)
'Usage

Dim instance As PDFViewportCollection
public class PDFViewportCollection : System.Collections.ObjectModel.Collection<PDFViewport>
public __gc class PDFViewportCollection : public System.Collections.ObjectModel.Collection<PDFViewport>
public ref class PDFViewportCollection : public System.Collections.ObjectModel.Collection<PDFViewport>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Measures.PDFViewportCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewportCollection Members
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%% $$Members$$

PDFViewportCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Measures Namespace : PDFViewportCollection Class

The following tables list the members exposed by PDFViewportCollection.

Public Constructors
 | Name | Description
Public Constructor | PDFViewportCollection Constructor | Initializes a new PDFViewportCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Top
See Also

Reference

PDFViewportCollection Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%%

PDFViewportCollection Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFViewportCollection Class : PDFViewportCollection Constructor
Initializes a new PDFViewportCollection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFViewportCollection()
public PDFViewportCollection()
public: PDFViewportCollection();
public:
PDFViewportCollection();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewportCollection Class
PDFViewportCollection Members


O2S.Components.PDF4NET.PageObjects Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFImagePageObject | Defines an image object displayed on a PDF page.
Class | PDFPageObject | Defines a graphic object drawn on a PDF page, text, image or vector graphics.
Class | PDFPageObjectCollection | Defines a read only collection of PDFPageObject objects.
Class | PDFPathPageObject | Defines a path drawn on a PDF page.
Class | PDFTextPageObject | Defines a text object displayed on a PDF page.
Enumerations
 | Enumeration | Description
Enumeration | PDFPageObjectType |
Enumeration | PDFPathPageObjectOperatorType | Supported operator types in a PDF path.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFImagePageObject Class
Members

O2S.Components.PDF4NET.PageObjects Namespace : PDFImagePageObject Class
Defines an image object displayed on a PDF page.
Object Model
PDFImagePageObject ClassDisplayRectangle ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFImagePageObject
   Inherits PDFPageObject
'Usage

Dim instance As PDFImagePageObject
public class PDFImagePageObject : PDFPageObject
public __gc class PDFImagePageObject : public PDFPageObject
public ref class PDFImagePageObject : public PDFPageObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PageObjects.PDFPageObject
O2S.Components.PDF4NET.PageObjects.PDFImagePageObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImagePageObject Members
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Members$$

PDFImagePageObject Class Members
Properties

O2S.Components.PDF4NET.PageObjects Namespace : PDFImagePageObject Class

The following tables list the members exposed by PDFImagePageObject.

Public Properties
 | Name | Description
Public Property | DisplayBounds | Gets the image bounds in display coordinates.
Public Property | Image | Gets the image.
Public Property | LayerName | Gets the layer name. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | ObjectType | Gets the page object type. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | Orientation | Gets the image orientation.
Public Property | PDFBounds | Gets the image bounds in PDF coordinates.
Top
See Also

Reference

PDFImagePageObject Class
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Properties$$

PDFImagePageObject Class Properties

O2S.Components.PDF4NET.PageObjects Namespace : PDFImagePageObject Class

For a list of all members of this type, see PDFImagePageObject members.

Public Properties
 | Name | Description
Public Property | DisplayBounds | Gets the image bounds in display coordinates.
Public Property | Image | Gets the image.
Public Property | LayerName | Gets the layer name. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | ObjectType | Gets the page object type. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | Orientation | Gets the image orientation.
Public Property | PDFBounds | Gets the image bounds in PDF coordinates.
Top
See Also

Reference

PDFImagePageObject Class
O2S.Components.PDF4NET.PageObjects Namespace


DisplayBounds Property (PDFImagePageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFImagePageObject Class : DisplayBounds Property
Gets the image bounds in display coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayBounds As DisplayRectangle
'Usage

Dim instance As PDFImagePageObject
Dim value As DisplayRectangle

value = instance.DisplayBounds
public DisplayRectangle DisplayBounds {get;}
public: __property DisplayRectangle* get_DisplayBounds();
public:
property DisplayRectangle^ DisplayBounds {
   DisplayRectangle^ get();
}

Property Value

The image position and size in display coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImagePageObject Class
PDFImagePageObject Members


Image Property (PDFImagePageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFImagePageObject Class : Image Property
Gets the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Image As Bitmap
'Usage

Dim instance As PDFImagePageObject
Dim value As Bitmap

value = instance.Image
public Bitmap Image {get;}
public: __property Bitmap* get_Image();
public:
property Bitmap^ Image {
   Bitmap^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImagePageObject Class
PDFImagePageObject Members


Orientation Property (PDFImagePageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFImagePageObject Class : Orientation Property
Gets the image orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Orientation As Double
'Usage

Dim instance As PDFImagePageObject
Dim value As Double

value = instance.Orientation
public double Orientation {get;}
public: __property double get_Orientation();
public:
property double Orientation {
   double get();
}

Property Value

The rotation angle of the image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImagePageObject Class
PDFImagePageObject Members


PDFBounds Property (PDFImagePageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFImagePageObject Class : PDFBounds Property
Gets the image bounds in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PDFBounds As PDFRectangle
'Usage

Dim instance As PDFImagePageObject
Dim value As PDFRectangle

value = instance.PDFBounds
public PDFRectangle PDFBounds {get;}
public: __property PDFRectangle* get_PDFBounds();
public:
property PDFRectangle^ PDFBounds {
   PDFRectangle^ get();
}

Property Value

The image position and size in PDF coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImagePageObject Class
PDFImagePageObject Members


%%PageItemTitle%%

PDFPageObject Class
Members

O2S.Components.PDF4NET.PageObjects Namespace : PDFPageObject Class
Defines a graphic object drawn on a PDF page, text, image or vector graphics.
Object Model
PDFPageObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageObject
'Usage

Dim instance As PDFPageObject
public class PDFPageObject
public __gc class PDFPageObject
public ref class PDFPageObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PageObjects.PDFPageObject
O2S.Components.PDF4NET.PageObjects.PDFImagePageObject
O2S.Components.PDF4NET.PageObjects.PDFPathPageObject
O2S.Components.PDF4NET.PageObjects.PDFTextPageObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageObject Members
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Members$$

PDFPageObject Class Members
Properties

O2S.Components.PDF4NET.PageObjects Namespace : PDFPageObject Class

The following tables list the members exposed by PDFPageObject.

Public Properties
 | Name | Description
Public Property | LayerName | Gets the layer name.
Public Property | ObjectType | Gets the page object type.
Top
See Also

Reference

PDFPageObject Class
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Properties$$

PDFPageObject Class Properties

O2S.Components.PDF4NET.PageObjects Namespace : PDFPageObject Class

For a list of all members of this type, see PDFPageObject members.

Public Properties
 | Name | Description
Public Property | LayerName | Gets the layer name.
Public Property | ObjectType | Gets the page object type.
Top
See Also

Reference

PDFPageObject Class
O2S.Components.PDF4NET.PageObjects Namespace


LayerName Property

O2S.Components.PDF4NET.PageObjects Namespace > PDFPageObject Class : LayerName Property
Gets the layer name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LayerName As String
'Usage

Dim instance As PDFPageObject
Dim value As String

value = instance.LayerName
public string LayerName {get;}
public: __property string* get_LayerName();
public:
property String^ LayerName {
   String^ get();
}

Property Value

The name of the layer this object is included into.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageObject Class
PDFPageObject Members


ObjectType Property

O2S.Components.PDF4NET.PageObjects Namespace > PDFPageObject Class : ObjectType Property
Gets the page object type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ObjectType As PDFPageObjectType
'Usage

Dim instance As PDFPageObject
Dim value As PDFPageObjectType

value = instance.ObjectType
public PDFPageObjectType ObjectType {get;}
public: __property PDFPageObjectType get_ObjectType();
public:
property PDFPageObjectType ObjectType {
   PDFPageObjectType get();
}

Property Value

The type of type of the page object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageObject Class
PDFPageObject Members


%%PageItemTitle%%

PDFPageObjectCollection Class
Members

O2S.Components.PDF4NET.PageObjects Namespace : PDFPageObjectCollection Class
Defines a read only collection of PDFPageObject objects.
Object Model
PDFPageObjectCollection ClassPDFPageObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageObjectCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFPageObject)
'Usage

Dim instance As PDFPageObjectCollection
public class PDFPageObjectCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>
public __gc class PDFPageObjectCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>
public ref class PDFPageObjectCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.PageObjects.PDFPageObjectCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageObjectCollection Members
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Members$$

PDFPageObjectCollection Class Members
Properties Methods

O2S.Components.PDF4NET.PageObjects Namespace : PDFPageObjectCollection Class

The following tables list the members exposed by PDFPageObjectCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Top
See Also

Reference

PDFPageObjectCollection Class
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%%

PDFPathPageObject Class
Members

O2S.Components.PDF4NET.PageObjects Namespace : PDFPathPageObject Class
Defines a path drawn on a PDF page.
Object Model
PDFPathPageObject ClassDisplayRectangle ClassPDFColor ClassPDFPathPageObjectOperatorType EnumerationPDFPoint ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPathPageObject
   Inherits PDFPageObject
'Usage

Dim instance As PDFPathPageObject
public class PDFPathPageObject : PDFPageObject
public __gc class PDFPathPageObject : public PDFPageObject
public ref class PDFPathPageObject : public PDFPageObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PageObjects.PDFPageObject
O2S.Components.PDF4NET.PageObjects.PDFPathPageObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Members
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Members$$

PDFPathPageObject Class Members
Properties

O2S.Components.PDF4NET.PageObjects Namespace : PDFPathPageObject Class

The following tables list the members exposed by PDFPathPageObject.

Public Properties
 | Name | Description
Public Property | DashArray | Gets the dash array.
Public Property | DashPhase | Gets the dash phase.
Public Property | DisplayBounds | Gets the path bounds.
Public Property | FillColor | Gets the color used to fill the path interior.
Public Property | FillMode | Get the fill mode.
Public Property | LayerName | Gets the layer name. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | LineWidth | Gets the line width.
Public Property | ObjectType | Gets the page object type. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | PathOperators | Gets the path operators.
Public Property | PathPoints | Gets the list of points that create the path.
Public Property | StrokeColor | Gets the color used to stroke the path outline.
Top
See Also

Reference

PDFPathPageObject Class
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Properties$$

PDFPathPageObject Class Properties

O2S.Components.PDF4NET.PageObjects Namespace : PDFPathPageObject Class

For a list of all members of this type, see PDFPathPageObject members.

Public Properties
 | Name | Description
Public Property | DashArray | Gets the dash array.
Public Property | DashPhase | Gets the dash phase.
Public Property | DisplayBounds | Gets the path bounds.
Public Property | FillColor | Gets the color used to fill the path interior.
Public Property | FillMode | Get the fill mode.
Public Property | LayerName | Gets the layer name. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | LineWidth | Gets the line width.
Public Property | ObjectType | Gets the page object type. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | PathOperators | Gets the path operators.
Public Property | PathPoints | Gets the list of points that create the path.
Public Property | StrokeColor | Gets the color used to stroke the path outline.
Top
See Also

Reference

PDFPathPageObject Class
O2S.Components.PDF4NET.PageObjects Namespace


DashArray Property

O2S.Components.PDF4NET.PageObjects Namespace > PDFPathPageObject Class : DashArray Property
Gets the dash array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DashArray As Double()
'Usage

Dim instance As PDFPathPageObject
Dim value() As Double

value = instance.DashArray
public double[] DashArray {get;}
public: __property double[]* get_DashArray();
public:
property array<double>^ DashArray {
   array<double>^ get();
}

Property Value

An array that describes the sequence of dashes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Class
PDFPathPageObject Members


DashPhase Property

O2S.Components.PDF4NET.PageObjects Namespace > PDFPathPageObject Class : DashPhase Property
Gets the dash phase.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DashPhase As Double
'Usage

Dim instance As PDFPathPageObject
Dim value As Double

value = instance.DashPhase
public double DashPhase {get;}
public: __property double get_DashPhase();
public:
property double DashPhase {
   double get();
}

Property Value

The dash phase.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Class
PDFPathPageObject Members


DisplayBounds Property (PDFPathPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFPathPageObject Class : DisplayBounds Property
Gets the path bounds.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayBounds As DisplayRectangle
'Usage

Dim instance As PDFPathPageObject
Dim value As DisplayRectangle

value = instance.DisplayBounds
public DisplayRectangle DisplayBounds {get;}
public: __property DisplayRectangle* get_DisplayBounds();
public:
property DisplayRectangle^ DisplayBounds {
   DisplayRectangle^ get();
}

Property Value

The rectangle that bounds the path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Class
PDFPathPageObject Members


FillColor Property (PDFPathPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFPathPageObject Class : FillColor Property
Gets the color used to fill the path interior.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FillColor As PDFColor
'Usage

Dim instance As PDFPathPageObject
Dim value As PDFColor

value = instance.FillColor
public PDFColor FillColor {get;}
public: __property PDFColor* get_FillColor();
public:
property PDFColor^ FillColor {
   PDFColor^ get();
}

Property Value

The color of the path interior.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Class
PDFPathPageObject Members


FillMode Property

O2S.Components.PDF4NET.PageObjects Namespace > PDFPathPageObject Class : FillMode Property
Get the fill mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FillMode As PDFFillMode
'Usage

Dim instance As PDFPathPageObject
Dim value As PDFFillMode

value = instance.FillMode
public PDFFillMode FillMode {get;}
public: __property PDFFillMode get_FillMode();
public:
property PDFFillMode FillMode {
   PDFFillMode get();
}

Property Value

The path fill mode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Class
PDFPathPageObject Members


LineWidth Property

O2S.Components.PDF4NET.PageObjects Namespace > PDFPathPageObject Class : LineWidth Property
Gets the line width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LineWidth As Double
'Usage

Dim instance As PDFPathPageObject
Dim value As Double

value = instance.LineWidth
public double LineWidth {get;}
public: __property double get_LineWidth();
public:
property double LineWidth {
   double get();
}

Property Value

The width of the stroke of the path outline.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Class
PDFPathPageObject Members


PathOperators Property

O2S.Components.PDF4NET.PageObjects Namespace > PDFPathPageObject Class : PathOperators Property
Gets the path operators.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PathOperators As PDFPathPageObjectOperatorType()
'Usage

Dim instance As PDFPathPageObject
Dim value() As PDFPathPageObjectOperatorType

value = instance.PathOperators
public PDFPathPageObjectOperatorType[] PathOperators {get;}
public: __property PDFPathPageObjectOperatorType[]* get_PathOperators();
public:
property array<PDFPathPageObjectOperatorType>^ PathOperators {
   array<PDFPathPageObjectOperatorType>^ get();
}

Property Value

The list of path operators, one for each array of points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Class
PDFPathPageObject Members


PathPoints Property

O2S.Components.PDF4NET.PageObjects Namespace > PDFPathPageObject Class : PathPoints Property
Gets the list of points that create the path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PathPoints As PDFPoint()
'Usage

Dim instance As PDFPathPageObject
Dim value() As PDFPoint

value = instance.PathPoints
public PDFPoint[] PathPoints {get;}
public: __property PDFPoint*[]* get_PathPoints();
public:
property array<PDFPoint^>^ PathPoints {
   array<PDFPoint^>^ get();
}

Property Value

An array of point arrays, one for each path operator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Class
PDFPathPageObject Members


StrokeColor Property (PDFPathPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFPathPageObject Class : StrokeColor Property
Gets the color used to stroke the path outline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property StrokeColor As PDFColor
'Usage

Dim instance As PDFPathPageObject
Dim value As PDFColor

value = instance.StrokeColor
public PDFColor StrokeColor {get;}
public: __property PDFColor* get_StrokeColor();
public:
property PDFColor^ StrokeColor {
   PDFColor^ get();
}

Property Value

The color of the path outline.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPathPageObject Class
PDFPathPageObject Members


%%PageItemTitle%%

PDFTextPageObject Class
Members

O2S.Components.PDF4NET.PageObjects Namespace : PDFTextPageObject Class
Defines a text object displayed on a PDF page.
Object Model
PDFTextPageObject ClassDisplayRectangle ClassPDFColor ClassPDFGlyphCollection ClassPDFGlyph ClassPDFColor ClassPDFMatrix Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextPageObject
   Inherits PDFPageObject
'Usage

Dim instance As PDFTextPageObject
public class PDFTextPageObject : PDFPageObject
public __gc class PDFTextPageObject : public PDFPageObject
public ref class PDFTextPageObject : public PDFPageObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PageObjects.PDFPageObject
O2S.Components.PDF4NET.PageObjects.PDFTextPageObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Members
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Members$$

PDFTextPageObject Class Members
Properties Methods

O2S.Components.PDF4NET.PageObjects Namespace : PDFTextPageObject Class

The following tables list the members exposed by PDFTextPageObject.

Public Properties
 | Name | Description
Public Property | DisplayBounds | Gets the bounds of this text object in display coordinate system.
Public Property | FillColor | Gets the color used to fill the path interior.
Public Property | FontEncoding | Gets the font encoding as it appears in the PDF file.
Public Property | FontName | Gets the name of the font used to display the text object.
Public Property | FontSize | Gets the size of the font used to display the text object.
Public Property | Glyphs | Gets or sets the list of glyphs included in this text object.
Public Property | LayerName | Gets the layer name. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | ObjectType | Gets the page object type. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | Orientation | Gets the rotation angle of the display bounds.
Public Property | ScaledFontSize | Gets the scaled size of the font used to display the text object.
Public Property | StrokeColor | Gets the color used to stroke the path outline.
Public Property | Text | Gets the text in this object.
Public Property | TextMatrix | Gets the active text matrix.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts this object to string representation.
Top
See Also

Reference

PDFTextPageObject Class
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Methods$$

PDFTextPageObject Class Methods

O2S.Components.PDF4NET.PageObjects Namespace : PDFTextPageObject Class

For a list of all members of this type, see PDFTextPageObject members.

Public Methods
 | Name | Description
Public Method | ToString | Converts this object to string representation.
Top
See Also

Reference

PDFTextPageObject Class
O2S.Components.PDF4NET.PageObjects Namespace


ToString Method (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : ToString Method
Converts this object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFTextPageObject
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The object as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


%%PageItemTitle%% $$Properties$$

PDFTextPageObject Class Properties

O2S.Components.PDF4NET.PageObjects Namespace : PDFTextPageObject Class

For a list of all members of this type, see PDFTextPageObject members.

Public Properties
 | Name | Description
Public Property | DisplayBounds | Gets the bounds of this text object in display coordinate system.
Public Property | FillColor | Gets the color used to fill the path interior.
Public Property | FontEncoding | Gets the font encoding as it appears in the PDF file.
Public Property | FontName | Gets the name of the font used to display the text object.
Public Property | FontSize | Gets the size of the font used to display the text object.
Public Property | Glyphs | Gets or sets the list of glyphs included in this text object.
Public Property | LayerName | Gets the layer name. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | ObjectType | Gets the page object type. (Inherited from O2S.Components.PDF4NET.PageObjects.PDFPageObject)
Public Property | Orientation | Gets the rotation angle of the display bounds.
Public Property | ScaledFontSize | Gets the scaled size of the font used to display the text object.
Public Property | StrokeColor | Gets the color used to stroke the path outline.
Public Property | Text | Gets the text in this object.
Public Property | TextMatrix | Gets the active text matrix.
Top
See Also

Reference

PDFTextPageObject Class
O2S.Components.PDF4NET.PageObjects Namespace


DisplayBounds Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : DisplayBounds Property
Gets the bounds of this text object in display coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayBounds As DisplayRectangle
'Usage

Dim instance As PDFTextPageObject
Dim value As DisplayRectangle

value = instance.DisplayBounds
public DisplayRectangle DisplayBounds {get;}
public: __property DisplayRectangle* get_DisplayBounds();
public:
property DisplayRectangle^ DisplayBounds {
   DisplayRectangle^ get();
}

Property Value

The bounding rectangle of the text object in display coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


FillColor Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : FillColor Property
Gets the color used to fill the path interior.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FillColor As PDFColor
'Usage

Dim instance As PDFTextPageObject
Dim value As PDFColor

value = instance.FillColor
public PDFColor FillColor {get;}
public: __property PDFColor* get_FillColor();
public:
property PDFColor^ FillColor {
   PDFColor^ get();
}

Property Value

The color of the path interior.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


FontEncoding Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : FontEncoding Property
Gets the font encoding as it appears in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontEncoding As String
'Usage

Dim instance As PDFTextPageObject
Dim value As String

value = instance.FontEncoding
public string FontEncoding {get;}
public: __property string* get_FontEncoding();
public:
property String^ FontEncoding {
   String^ get();
}

Property Value

The encoding of the font used to draw this text object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


FontName Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : FontName Property
Gets the name of the font used to display the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontName As String
'Usage

Dim instance As PDFTextPageObject
Dim value As String

value = instance.FontName
public string FontName {get;}
public: __property string* get_FontName();
public:
property String^ FontName {
   String^ get();
}

Property Value

The name of the font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


FontSize Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : FontSize Property
Gets the size of the font used to display the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontSize As Double
'Usage

Dim instance As PDFTextPageObject
Dim value As Double

value = instance.FontSize
public double FontSize {get;}
public: __property double get_FontSize();
public:
property double FontSize {
   double get();
}

Property Value

The size of the font in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


Glyphs Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : Glyphs Property
Gets or sets the list of glyphs included in this text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Glyphs As PDFGlyphCollection
'Usage

Dim instance As PDFTextPageObject
Dim value As PDFGlyphCollection

value = instance.Glyphs
public PDFGlyphCollection Glyphs {get;}
public: __property PDFGlyphCollection* get_Glyphs();
public:
property PDFGlyphCollection^ Glyphs {
   PDFGlyphCollection^ get();
}

Property Value

The collection of glyphs that compose the text object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


Orientation Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : Orientation Property
Gets the rotation angle of the display bounds.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Orientation As Double
'Usage

Dim instance As PDFTextPageObject
Dim value As Double

value = instance.Orientation
public double Orientation {get;}
public: __property double get_Orientation();
public:
property double Orientation {
   double get();
}

Property Value

The rotation angle of the display bounds, relative to top left corner of the bounding rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


ScaledFontSize Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : ScaledFontSize Property
Gets the scaled size of the font used to display the text object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScaledFontSize As Double
'Usage

Dim instance As PDFTextPageObject
Dim value As Double

value = instance.ScaledFontSize
public double ScaledFontSize {get;}
public: __property double get_ScaledFontSize();
public:
property double ScaledFontSize {
   double get();
}

Property Value

The scaled size of the font in points, based on current text matrix.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


StrokeColor Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : StrokeColor Property
Gets the color used to stroke the path outline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property StrokeColor As PDFColor
'Usage

Dim instance As PDFTextPageObject
Dim value As PDFColor

value = instance.StrokeColor
public PDFColor StrokeColor {get;}
public: __property PDFColor* get_StrokeColor();
public:
property PDFColor^ StrokeColor {
   PDFColor^ get();
}

Property Value

The color of the path outline.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


Text Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : Text Property
Gets the text in this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PDFTextPageObject
Dim value As String

value = instance.Text
public string Text {get;}
public: __property string* get_Text();
public:
property String^ Text {
   String^ get();
}

Property Value

The text content represented by this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


TextMatrix Property (PDFTextPageObject)

O2S.Components.PDF4NET.PageObjects Namespace > PDFTextPageObject Class : TextMatrix Property
Gets the active text matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextMatrix As PDFMatrix
'Usage

Dim instance As PDFTextPageObject
Dim value As PDFMatrix

value = instance.TextMatrix
public PDFMatrix TextMatrix {get;}
public: __property PDFMatrix* get_TextMatrix();
public:
property PDFMatrix^ TextMatrix {
   PDFMatrix^ get();
}

Property Value

The transformation matrix being in place when the text is displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextPageObject Class
PDFTextPageObject Members


%%PageItemTitle%%

PDFPageObjectType Enumeration

O2S.Components.PDF4NET.PageObjects Namespace : PDFPageObjectType Enumeration
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageObjectType
   Inherits System.Enum
'Usage

Dim instance As PDFPageObjectType
public enum PDFPageObjectType : System.Enum
__value public enum PDFPageObjectType : public System.Enum
public enum class PDFPageObjectType : public System.Enum
Members
Member | Description
Image | Image page object.
Path | Path page object.
Text | Text page object.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PageObjects.PDFPageObjectType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%%

PDFPathPageObjectOperatorType Enumeration

O2S.Components.PDF4NET.PageObjects Namespace : PDFPathPageObjectOperatorType Enumeration
Supported operator types in a PDF path.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPathPageObjectOperatorType
   Inherits System.Enum
'Usage

Dim instance As PDFPathPageObjectOperatorType
public enum PDFPathPageObjectOperatorType : System.Enum
__value public enum PDFPathPageObjectOperatorType : public System.Enum
public enum class PDFPathPageObjectOperatorType : public System.Enum
Members
Member | Description
CCurveTo | c - Curve to operator.
ClosePath | h - Close path operator.
LineTo | l - Line to operator.
MoveTo | m - Move to operator.
Rectangle | re - rectangle.
VCurveTo | v - Curve to operator.
YCurveTo | y - Curve to operator.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PageObjects.PDFPathPageObjectOperatorType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.PageObjects Namespace


O2S.Components.PDF4NET.PDFA Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFAValidationErrorCollection | Defines a collection of colorspaces.
Enumerations
 | Enumeration | Description
Enumeration | PDFAValidationError | Specifies the possible errors that can appear while validating a PDF document against the PDF-A/1b standard
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFAValidationErrorCollection Class
Members

O2S.Components.PDF4NET.PDFA Namespace : PDFAValidationErrorCollection Class
Defines a collection of colorspaces.
Object Model
PDFAValidationErrorCollection ClassPDFAValidationError Enumeration
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAValidationErrorCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFAValidationError)
'Usage

Dim instance As PDFAValidationErrorCollection
public class PDFAValidationErrorCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>
public __gc class PDFAValidationErrorCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>
public ref class PDFAValidationErrorCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.PDFA.PDFAValidationErrorCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAValidationErrorCollection Members
O2S.Components.PDF4NET.PDFA Namespace


%%PageItemTitle%% $$Members$$

PDFAValidationErrorCollection Class Members
Properties Methods

O2S.Components.PDF4NET.PDFA Namespace : PDFAValidationErrorCollection Class

The following tables list the members exposed by PDFAValidationErrorCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Top
See Also

Reference

PDFAValidationErrorCollection Class
O2S.Components.PDF4NET.PDFA Namespace


%%PageItemTitle%%

PDFAValidationError Enumeration

O2S.Components.PDF4NET.PDFA Namespace : PDFAValidationError Enumeration
Specifies the possible errors that can appear while validating a PDF document against the PDF-A/1b standard
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFAValidationError
   Inherits System.Enum
'Usage

Dim instance As PDFAValidationError
public enum PDFAValidationError : System.Enum
__value public enum PDFAValidationError : public System.Enum
public enum class PDFAValidationError : public System.Enum
Members
Member | Description
AnnotationActionTypeIsProhibited | An annotation has an associated action with a prohibited type.
AnnotationAdditionalActionsArePresent | An annotaiton has additional actions attached to it.
AnnotationAppearanceIsNotAFormXObject | An annotation has an appearance entry but this is not a form XObject.
AnnotationColorIsPresent | A color is defined on an annotation but the document's OutputIntent is not set to RGB.
AnnotationFlagsAreNotPresent | The annotation flags (/F key) are not defined on an annotation.
AnnotationHasMultipleAppearances | An annotation has multiple appearances but only the normal appearance is allowed.
AnnotationInteriorColorIsPresent | An interior color is defined on an annotation but the document's OutputIntent is not set to RGB.
AnnotationIsHidden | An annotation is marked as hidden.
AnnotationIsInvisible | An annotation is marked as invisible.
AnnotationIsNotPrintable | An annotation is not printable.
AnnotationNormalAppearanceIsNotDefined | The normal appearance is not defined for an annotation.
AnnotationOpacityIsPresent | An annotation has an opacity level less than 100%.
AnnotationTypeIsProhibited | An annotation with prohibited type is present on a PDF page.
CmykOutputProfileIsMissing | The graphic content streams use the DeviceCMYK or DeviceGray colorspaces but the document does not include a PDF/A RGB output profile in document's OutputIntents collection.
DocumentAdditionalActionsArePresent | The PDF document includes additional actions.
DocumentAttachmentsArePresent | The PDF document includes document attachments (embedded files).
DocumentIsEncrypted | The PDF document is encrypted.
DocumentMetadataIsNotPresent | Metadata is not present in the PDF document.
DocumentOpenActionTypeIsProhibited | The PDF document has an open action but its type is prohibited.
ExtGStateBlendModeIsProhibited | An extended graphic state specifies a prohibited blend mode.
ExtGStateHasTR2Key | The /TR2 key is present in an extended graphic state and its value is different than /Default.
ExtGStateHasTRKey | The /TR key is present in an extended graphic state.
ExtGStateRenderingIntentIsProhibited | An extended graphic state has a rendering intent that is prohibited.
ExtGStateSoftMaskIsPresent | An extended graphic state has a soft mask.
ExtGStateTransparencyLevelIsProhibited | An extended graphic state specifies a prohibited transparency level.
FieldAdditionalActionsArePresent | A field has additional actions attached to it.
FieldWidgetActionIsPresent | A field widget has an action attached to it.
FieldWidgetAdditionalActionsArePresent | A field widget has additional actions attached to it.
FieldWidgetAppearanceIsNotPresent | A field widget does not have an appearance defined for it.
FontDescriptorIsMissing | A built in PDF font has been used.
FormXObjectHasOPIKey | The /OPI key is present in a form XObject.
FormXObjectHasPSKey | The /PS key is present in a form XObject.
FormXObjectHasSubtype2Key | The /Subtype2 key is present in a form XObject.
ImageHasAlternatesKey | The /Alternates key is present in an image object.
ImageHasInterpolateKey | The /Interpolate key is present in an image object and its value is true.
ImageHasOPIKey | The /OPI key is present in an image object.
ImageRenderingIntentIsProhibited | An image has a rendering intent that is prohibited.
LayersArePresent | The PDF document includes layers (optional content).
NeedAppearancesIsPresentInDocumentAcroForm | The document's AcroForm includes the /NeedAppearances key and it is set to true.
PostScriptFormXObjectIsPresent | A PostScript form XObject is present in the file.
ReferenceFormXObjectIsPresent | A reference form XObject is present in the file.
RgbAndCmykAreMixed | The graphic content streams use both the DeviceRGB and DeviceCMYK colorspaces.
RgbOutputProfileIsMissing | The graphic content streams use the DeviceRGB or DeviceGray colorspaces but the document does not include a PDF/A RGB output profile in document's OutputIntents collection.
TextAnnotationCanRotate | The NoRotate flag is not set on an annotation.
TextAnnotationCanZoom | The NoZoom flag is not set on an annotation.
TrueTypeFontIsNotEmbedded | A TrueType font is used but font data is not embedded.
Type0FontIsNotEmbedded | A Type0 font is used but font data is not embedded.
Type1FontIsNotEmbedded | A Type1 font is used but font data is not embedded.
XObjectSoftMaskIsPresent | A form XObject has a soft mask.
XObjectTransparencyGroupIsPresent | A form XObject has a transparency group.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFA.PDFAValidationError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.PDFA Namespace


O2S.Components.PDF4NET.PDFFile Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFFile | Represents a pdf file on disk.
Class | PDFImportedContent | Represents the binary content of a page in a pdf file.
Class | PDFImportedPage | Represents a page in a pdf file.
Class | PDFImportedPageInfo | Defines the properties of an imported page but without actual page content.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFFile Class
Members

O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class
Represents a pdf file on disk.
Object Model
PDFFile ClassPDFDictionary ClassPDFDocumentInformation ClassPDFSecurityManager Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFile
'Usage

Dim instance As PDFFile
public class PDFFile
public __gc class PDFFile
public ref class PDFFile
Remarks
This class defines an existing pdf file. Its methods allows to perform various operations on pdf files. It allows to merge multiple pdf files, split pdf files to individual pages, apply security to existing pdf files, extract full pages or their content from pdf files.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.PDFFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFFile Class Members
Properties Methods

O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

The following tables list the members exposed by PDFFile.

Public Properties
 | Name | Description
Public Property | DocumentCatalog | Gets the document catalog dictionary.
Public Property | DocumentInformation | Gets the document information for this PDF file.
Public Property | IsRepaired | Gets a value indicating whether the PDF file was repaired or not before it has been loaded.
Public Property | PagesCount | Gets the number of pages in the PDF file.
Public Property | PDFVersion | Gets or sets the PDF version of this PDFFile object.
Public Property | SecurityManager | Gets the security manager for this PDF file.
static (Shared in Visual Basic) | SerialNumber | Sets the serial number and unlocks the component.
Top
Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
Public Method | Dispose | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | EncryptFile | Overloaded. Encrypts the given pdf file with the security settings specified by securityManager parameter.
Public Method | ExtractPage | Overloaded. Extracts the specified page from the current file.
Public Method | ExtractPageContent | Overloaded. Gets the binary content of the specified page.
Public Method | ExtractPageInfo | Extracts the specified page information from the current file.
Public Method | ExtractPages | Overloaded. Gets an array of imported page objects representing the pages given as parameter.
Public Method | ExtractPagesContent | Overloaded. Gets an array of imported content objects representing the binary content of the pages given as parameter.
Public Method | ExtractPagesInfo | Gets an array of imported page info objects representing the pages given as parameter.
static (Shared in Visual Basic) | FromFile | Overloaded. Creates a PDFFile object from the given pdf file.
static (Shared in Visual Basic) | FromStream | Overloaded. Creates a PDFFile object from the given stream object.
Public Method | GetJavaScripts | Gets the JavaScript code fragments embedded in the PDF file.
Public Method | GetPageNumberingRanges | Gets the page numbering ranges included in the PDF file.
static (Shared in Visual Basic) | MergeFiles | Overloaded. Merges multiple pdf files into a single pdf file.
static (Shared in Visual Basic) | SplitFile | Splits the given pdf file to individual pages.
Top
See Also

Reference

PDFFile Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Methods$$

PDFFile Class Methods

O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

For a list of all members of this type, see PDFFile members.

Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
Public Method | Dispose | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | EncryptFile | Overloaded. Encrypts the given pdf file with the security settings specified by securityManager parameter.
Public Method | ExtractPage | Overloaded. Extracts the specified page from the current file.
Public Method | ExtractPageContent | Overloaded. Gets the binary content of the specified page.
Public Method | ExtractPageInfo | Extracts the specified page information from the current file.
Public Method | ExtractPages | Overloaded. Gets an array of imported page objects representing the pages given as parameter.
Public Method | ExtractPagesContent | Overloaded. Gets an array of imported content objects representing the binary content of the pages given as parameter.
Public Method | ExtractPagesInfo | Gets an array of imported page info objects representing the pages given as parameter.
static (Shared in Visual Basic) | FromFile | Overloaded. Creates a PDFFile object from the given pdf file.
static (Shared in Visual Basic) | FromStream | Overloaded. Creates a PDFFile object from the given stream object.
Public Method | GetJavaScripts | Gets the JavaScript code fragments embedded in the PDF file.
Public Method | GetPageNumberingRanges | Gets the page numbering ranges included in the PDF file.
static (Shared in Visual Basic) | MergeFiles | Overloaded. Merges multiple pdf files into a single pdf file.
static (Shared in Visual Basic) | SplitFile | Splits the given pdf file to individual pages.
Top
See Also

Reference

PDFFile Class
O2S.Components.PDF4NET.PDFFile Namespace


Close Method (PDFFile)

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : Close Method
Closes the underlying pdf file and frees all resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As PDFFile

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


Dispose() Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : Dispose() Method
Closes the underlying pdf file and frees all resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PDFFile

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


EncryptFile Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : EncryptFile Method
Encrypts the given pdf file with the security settings specified by securityManager parameter.
Overload List
Overload | Description
EncryptFile(PDFSecurityManager,String,String) | Encrypts the given pdf file with the security settings specified by securityManager parameter.
EncryptFile(PDFSecurityManager,String) | Encrypts the given pdf file with the security settings specified by securityManager parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


EncryptFile(PDFSecurityManager,String,String) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > EncryptFile Method : EncryptFile(PDFSecurityManager,String,String) Method
a O2S.Components.PDF4NET.Security.PDFSecurityManager object specifying the security settings for the destination pdf file.
the source pdf file that will be encrypted.
the destination pdf file where the encrypted docment will be saved.
Encrypts the given pdf file with the security settings specified by securityManager parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub EncryptFile( _
   ByVal securityManager As PDFSecurityManager, _
   ByVal srcFileName As String, _
   ByVal destFileName As String _
)
'Usage

Dim securityManager As PDFSecurityManager
Dim srcFileName As String
Dim destFileName As String

PDFFile.EncryptFile(securityManager, srcFileName, destFileName)
public static void EncryptFile(
   PDFSecurityManager securityManager,
   string srcFileName,
   string destFileName
)
public: static void EncryptFile(
   PDFSecurityManager* securityManager,
   string* srcFileName,
   string* destFileName
)
public:
static void EncryptFile(
   PDFSecurityManager^ securityManager,
   String^ srcFileName,
   String^ destFileName
)

Parameters

securityManager
a O2S.Components.PDF4NET.Security.PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.
destFileName
the destination pdf file where the encrypted docment will be saved.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | thrown when input pdf files can not be parsed.
Remarks
This method encrypts an existing pdf file specified by srcFileName and saves the encrypted file to the location specified by destFileName parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


EncryptFile(PDFSecurityManager,String) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > EncryptFile Method : EncryptFile(PDFSecurityManager,String) Method
a O2S.Components.PDF4NET.Security.PDFSecurityManager object specifying the security settings for the destination pdf file.
the source pdf file that will be encrypted.
Encrypts the given pdf file with the security settings specified by securityManager parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function EncryptFile( _
   ByVal securityManager As PDFSecurityManager, _
   ByVal srcFileName As String _
) As PDFDocument
'Usage

Dim securityManager As PDFSecurityManager
Dim srcFileName As String
Dim value As PDFDocument

value = PDFFile.EncryptFile(securityManager, srcFileName)
public static PDFDocument EncryptFile(
   PDFSecurityManager securityManager,
   string srcFileName
)
public: static PDFDocument* EncryptFile(
   PDFSecurityManager* securityManager,
   string* srcFileName
)
public:
static PDFDocument^ EncryptFile(
   PDFSecurityManager^ securityManager,
   String^ srcFileName
)

Parameters

securityManager
a O2S.Components.PDF4NET.Security.PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.

Return Value

a O2S.Components.PDF4NET.PDFDocument object representing the encrypted source pdf file
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | thrown when input pdf files can not be parsed.
Remarks
This method encrypts an existing pdf file specified by srcFileName and saves the encrypted file to the location specified by destFileName parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPage Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPage Method
Extracts the specified page from the current file.
Overload List
Overload | Description
ExtractPage(Int32) | Extracts the specified page from the current file.
ExtractPage(Int32,Boolean) | Extracts the specified page from the current file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPage(Int32) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPage Method : ExtractPage(Int32) Method
the number of the page tha will be extracted.
Extracts the specified page from the current file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPage( _
   ByVal pageNumber As Integer _
) As PDFImportedPage
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFImportedPage

value = instance.ExtractPage(pageNumber)
public PDFImportedPage ExtractPage(
   int pageNumber
)
public: PDFImportedPage* ExtractPage(
   int pageNumber
)
public:
PDFImportedPage^ ExtractPage(
   int pageNumber
)

Parameters

pageNumber
the number of the page tha will be extracted.

Return Value

a PDFImportedPage object representing the extracted page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts a full page from the current pdf file. This page can be later inserted in any new document keeping all the attributes it had in the old document. Use AddPage method to insert the extracted page into a new document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPage(Int32,Boolean) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPage Method : ExtractPage(Int32,Boolean) Method
the number of the page tha will be extracted.
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.
Extracts the specified page from the current file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPage( _
   ByVal pageNumber As Integer, _
   ByVal removeUnusedResources As Boolean _
) As PDFImportedPage
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim removeUnusedResources As Boolean
Dim value As PDFImportedPage

value = instance.ExtractPage(pageNumber, removeUnusedResources)
public PDFImportedPage ExtractPage(
   int pageNumber,
   bool removeUnusedResources
)
public: PDFImportedPage* ExtractPage(
   int pageNumber,
   bool removeUnusedResources
)
public:
PDFImportedPage^ ExtractPage(
   int pageNumber,
   bool removeUnusedResources
)

Parameters

pageNumber
the number of the page tha will be extracted.
removeUnusedResources
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.

Return Value

a PDFImportedPage object representing the extracted page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts a full page from the current pdf file. This page can be later inserted in any new document keeping all the attributes it had in the old document. Use AddPage method to insert the extracted page into a new document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPageContent Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPageContent Method
Gets the binary content of the specified page.
Overload List
Overload | Description
ExtractPageContent(Int32) | Gets the binary content of the specified page.
ExtractPageContent(Int32,Boolean) | Gets the binary content of the specified page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPageContent(Int32) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPageContent Method : ExtractPageContent(Int32) Method
the number of the page whose binary content should be retrieved.
Gets the binary content of the specified page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPageContent( _
   ByVal pageNumber As Integer _
) As PDFImportedContent
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFImportedContent

value = instance.ExtractPageContent(pageNumber)
public PDFImportedContent ExtractPageContent(
   int pageNumber
)
public: PDFImportedContent* ExtractPageContent(
   int pageNumber
)
public:
PDFImportedContent^ ExtractPageContent(
   int pageNumber
)

Parameters

pageNumber
the number of the page whose binary content should be retrieved.

Return Value

a PDFImportedContent object representing the binary representation of the page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts the binary content of the given page. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use O2S.Components.PDF4NET.Graphics.PDFBasicCanvas.DrawImportedContent method to draw the imported content on a new page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPageContent(Int32,Boolean) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPageContent Method : ExtractPageContent(Int32,Boolean) Method
the number of the page whose binary content should be retrieved.
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.
Gets the binary content of the specified page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPageContent( _
   ByVal pageNumber As Integer, _
   ByVal removeUnusedResources As Boolean _
) As PDFImportedContent
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim removeUnusedResources As Boolean
Dim value As PDFImportedContent

value = instance.ExtractPageContent(pageNumber, removeUnusedResources)
public PDFImportedContent ExtractPageContent(
   int pageNumber,
   bool removeUnusedResources
)
public: PDFImportedContent* ExtractPageContent(
   int pageNumber,
   bool removeUnusedResources
)
public:
PDFImportedContent^ ExtractPageContent(
   int pageNumber,
   bool removeUnusedResources
)

Parameters

pageNumber
the number of the page whose binary content should be retrieved.
removeUnusedResources
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.

Return Value

a PDFImportedContent object representing the binary representation of the page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts the binary content of the given page. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use O2S.Components.PDF4NET.Graphics.PDFBasicCanvas.DrawImportedContent method to draw the imported content on a new page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPageInfo Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPageInfo Method
the number of the page for which information will be extracted.
Extracts the specified page information from the current file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractPageInfo( _
   ByVal pageNumber As Integer _
) As PDFImportedPageInfo
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFImportedPageInfo

value = instance.ExtractPageInfo(pageNumber)
public PDFImportedPageInfo ExtractPageInfo(
   int pageNumber
)
public: PDFImportedPageInfo* ExtractPageInfo(
   int pageNumber
)
public:
PDFImportedPageInfo^ ExtractPageInfo(
   int pageNumber
)

Parameters

pageNumber
the number of the page for which information will be extracted.

Return Value

A PDFImportedPageInfo object representing the page information.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts a only the page information from the current pdf file, no page content is extracted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPages Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPages Method
Gets an array of imported page objects representing the pages given as parameter.
Overload List
Overload | Description
ExtractPages(String) | Gets an array of imported page objects representing the pages given as parameter.
ExtractPages(String,Boolean) | Gets an array of imported page objects representing the pages given as parameter.
ExtractPages() | Gets an array of imported page objects representing all the pages in the file.
ExtractPages(Boolean) | Gets an array of imported page objects representing all the pages in the file.
ExtractPages(String,Int32,Int32) | Gets an array of imported page objects representing the pages in the range specified by startPage and endPage parameters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPages(String) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages(String) Method
a set of page numbers, separated by comma or dash, specifying the pages that should be extracted.
Gets an array of imported page objects representing the pages given as parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPages( _
   ByVal pageNumbers As String _
) As PDFImportedPage()
'Usage

Dim instance As PDFFile
Dim pageNumbers As String
Dim value() As PDFImportedPage

value = instance.ExtractPages(pageNumbers)
public PDFImportedPage[] ExtractPages(
   string pageNumbers
)
public: PDFImportedPage*[]* ExtractPages(
   string* pageNumbers
)
public:
array<PDFImportedPage^>^ ExtractPages(
   String^ pageNumbers
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages that should be extracted.

Return Value

an array of PDFImportedPage objects representing the pages given as paramter.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts the given set of pages. These pages can be inserted in any new document. Use PDFDocument.Pages.Add method to add imported page to current document.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPages(String,Boolean) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages(String,Boolean) Method
a set of page numbers, separated by comma or dash, specifying the pages that should be extracted.
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.
Gets an array of imported page objects representing the pages given as parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPages( _
   ByVal pageNumbers As String, _
   ByVal removeUnusedResources As Boolean _
) As PDFImportedPage()
'Usage

Dim instance As PDFFile
Dim pageNumbers As String
Dim removeUnusedResources As Boolean
Dim value() As PDFImportedPage

value = instance.ExtractPages(pageNumbers, removeUnusedResources)
public PDFImportedPage[] ExtractPages(
   string pageNumbers,
   bool removeUnusedResources
)
public: PDFImportedPage*[]* ExtractPages(
   string* pageNumbers,
   bool removeUnusedResources
)
public:
array<PDFImportedPage^>^ ExtractPages(
   String^ pageNumbers,
   bool removeUnusedResources
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages that should be extracted.
removeUnusedResources
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.

Return Value

an array of PDFImportedPage objects representing the pages given as paramter.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts the given set of pages. These pages can be inserted in any new document. Use PDFDocument.Pages.Add method to add imported page to current document.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPages() Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages() Method
Gets an array of imported page objects representing all the pages in the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPages() As PDFImportedPage()
'Usage

Dim instance As PDFFile
Dim value() As PDFImportedPage

value = instance.ExtractPages()
public PDFImportedPage[] ExtractPages()
public: PDFImportedPage*[]* ExtractPages();
public:
array<PDFImportedPage^>^ ExtractPages();

Return Value

an array of PDFImportedPage objects representing all the pages in the file.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | Thrown when page content can not be extracted due to a PDF parsing error.
Remarks
This method extracts all the pages in the file. These pages can be inserted in any new document. Use AddPage method to add imported page to current document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPages(Boolean) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages(Boolean) Method
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.
Gets an array of imported page objects representing all the pages in the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPages( _
   ByVal removeUnusedResources As Boolean _
) As PDFImportedPage()
'Usage

Dim instance As PDFFile
Dim removeUnusedResources As Boolean
Dim value() As PDFImportedPage

value = instance.ExtractPages(removeUnusedResources)
public PDFImportedPage[] ExtractPages(
   bool removeUnusedResources
)
public: PDFImportedPage*[]* ExtractPages(
   bool removeUnusedResources
)
public:
array<PDFImportedPage^>^ ExtractPages(
   bool removeUnusedResources
)

Parameters

removeUnusedResources
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.

Return Value

an array of PDFImportedPage objects representing all the pages in the file.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | Thrown when page content can not be extracted due to a PDF parsing error.
Remarks
This method extracts all the pages in the file. These pages can be inserted in any new document. Use AddPage method to add imported page to current document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPages(String,Int32,Int32) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages(String,Int32,Int32) Method
the PDF file from which the pages are extracted.
the zero based index of the first page in the range.
the zero based index of the last page in the range.
Gets an array of imported page objects representing the pages in the range specified by startPage and endPage parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ExtractPages( _
   ByVal fileName As String, _
   ByVal startPage As Integer, _
   ByVal endPage As Integer _
) As PDFImportedPage()
'Usage

Dim fileName As String
Dim startPage As Integer
Dim endPage As Integer
Dim value() As PDFImportedPage

value = PDFFile.ExtractPages(fileName, startPage, endPage)
public static PDFImportedPage[] ExtractPages(
   string fileName,
   int startPage,
   int endPage
)
public: static PDFImportedPage*[]* ExtractPages(
   string* fileName,
   int startPage,
   int endPage
)
public:
static array<PDFImportedPage^>^ ExtractPages(
   String^ fileName,
   int startPage,
   int endPage
)

Parameters

fileName
the PDF file from which the pages are extracted.
startPage
the zero based index of the first page in the range.
endPage
the zero based index of the last page in the range.

Return Value

an array of PDFImportedPage objects representing the requested range of consecutive pages.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the given pdf file.
Remarks
This method extracts a consecutive range of pages from the given PDF file. These pages can be inserted in any new document. Use AddPage method to add imported page to current document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPagesContent Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPagesContent Method
Gets an array of imported content objects representing the binary content of the pages given as parameter.
Overload List
Overload | Description
ExtractPagesContent(String) | Gets an array of imported content objects representing the binary content of the pages given as parameter.
ExtractPagesContent(String,Boolean) | Gets an array of imported content objects representing the binary content of the pages given as parameter.
ExtractPagesContent() | Gets an array of imported content objects representing the binary content of all the pages in the file.
ExtractPagesContent(Boolean) | Gets an array of imported content objects representing the binary content of all the pages in the file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPagesContent(String) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPagesContent Method : ExtractPagesContent(String) Method
a set of page numbers, separated by comma or dash, specifying the page numbers whose content should be extracted.
Gets an array of imported content objects representing the binary content of the pages given as parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPagesContent( _
   ByVal pageNumbers As String _
) As PDFImportedContent()
'Usage

Dim instance As PDFFile
Dim pageNumbers As String
Dim value() As PDFImportedContent

value = instance.ExtractPagesContent(pageNumbers)
public PDFImportedContent[] ExtractPagesContent(
   string pageNumbers
)
public: PDFImportedContent*[]* ExtractPagesContent(
   string* pageNumbers
)
public:
array<PDFImportedContent^>^ ExtractPagesContent(
   String^ pageNumbers
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the page numbers whose content should be extracted.

Return Value

an array of PDFImportedContent objects representing the binary content of the pages given as parameter.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts the binary content of the given set of pages. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use O2S.Components.PDF4NET.Graphics.PDFBasicCanvas.DrawImportedContent method to draw the imported content on a new page.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPagesContent(String,Boolean) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPagesContent Method : ExtractPagesContent(String,Boolean) Method
a set of page numbers, separated by comma or dash, specifying the page numbers whose content should be extracted.
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.
Gets an array of imported content objects representing the binary content of the pages given as parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPagesContent( _
   ByVal pageNumbers As String, _
   ByVal removeUnusedResources As Boolean _
) As PDFImportedContent()
'Usage

Dim instance As PDFFile
Dim pageNumbers As String
Dim removeUnusedResources As Boolean
Dim value() As PDFImportedContent

value = instance.ExtractPagesContent(pageNumbers, removeUnusedResources)
public PDFImportedContent[] ExtractPagesContent(
   string pageNumbers,
   bool removeUnusedResources
)
public: PDFImportedContent*[]* ExtractPagesContent(
   string* pageNumbers,
   bool removeUnusedResources
)
public:
array<PDFImportedContent^>^ ExtractPagesContent(
   String^ pageNumbers,
   bool removeUnusedResources
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the page numbers whose content should be extracted.
removeUnusedResources
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.

Return Value

an array of PDFImportedContent objects representing the binary content of the pages given as parameter.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts the binary content of the given set of pages. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use O2S.Components.PDF4NET.Graphics.PDFBasicCanvas.DrawImportedContent method to draw the imported content on a new page.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPagesContent() Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPagesContent Method : ExtractPagesContent() Method
Gets an array of imported content objects representing the binary content of all the pages in the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPagesContent() As PDFImportedContent()
'Usage

Dim instance As PDFFile
Dim value() As PDFImportedContent

value = instance.ExtractPagesContent()
public PDFImportedContent[] ExtractPagesContent()
public: PDFImportedContent*[]* ExtractPagesContent();
public:
array<PDFImportedContent^>^ ExtractPagesContent();

Return Value

an array of PDFImportedContent objects representing the binary content of all the pages in the file.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | Thrown when page content can not be extracted due to a PDF parsing error.
Remarks
This method extracts the binary content of all the pages in the file. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use PDFCanvas.DrawImportedContent method to draw the imported content on a new page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPagesContent(Boolean) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPagesContent Method : ExtractPagesContent(Boolean) Method
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.
Gets an array of imported content objects representing the binary content of all the pages in the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ExtractPagesContent( _
   ByVal removeUnusedResources As Boolean _
) As PDFImportedContent()
'Usage

Dim instance As PDFFile
Dim removeUnusedResources As Boolean
Dim value() As PDFImportedContent

value = instance.ExtractPagesContent(removeUnusedResources)
public PDFImportedContent[] ExtractPagesContent(
   bool removeUnusedResources
)
public: PDFImportedContent*[]* ExtractPagesContent(
   bool removeUnusedResources
)
public:
array<PDFImportedContent^>^ ExtractPagesContent(
   bool removeUnusedResources
)

Parameters

removeUnusedResources
indicates whether the page content should be parsed in order to detect the resources actually used on the page and remove the unused ones from page's resources dictionary.

Return Value

an array of PDFImportedContent objects representing the binary content of all the pages in the file.
Exceptions
Exception | Description
O2S.Components.PDF4NET.PDFParserException | Thrown when page content can not be extracted due to a PDF parsing error.
Remarks
This method extracts the binary content of all the pages in the file. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use PDFCanvas.DrawImportedContent method to draw the imported content on a new page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPagesInfo Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPagesInfo Method
a set of page numbers, separated by comma or dash, specifying the pages whose information should be extracted.
Gets an array of imported page info objects representing the pages given as parameter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractPagesInfo( _
   ByVal pageNumbers As String _
) As PDFImportedPageInfo()
'Usage

Dim instance As PDFFile
Dim pageNumbers As String
Dim value() As PDFImportedPageInfo

value = instance.ExtractPagesInfo(pageNumbers)
public PDFImportedPageInfo[] ExtractPagesInfo(
   string pageNumbers
)
public: PDFImportedPageInfo*[]* ExtractPagesInfo(
   string* pageNumbers
)
public:
array<PDFImportedPageInfo^>^ ExtractPagesInfo(
   String^ pageNumbers
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages whose information should be extracted.

Return Value

an array of PDFImportedPageInfo objects representing the pages given as paramter.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.
Remarks
This method extracts the information for the given set of pages without extracting the whole page content.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


FromFile Method (PDFFile)

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : FromFile Method
Creates a PDFFile object from the given pdf file.
Overload List
Overload | Description
FromFile(String) | Creates a PDFFile object from the given pdf file.
FromFile(String,Byte[]) | Creates a PDFFile object from the given pdf file.
FromFile(String,String) | Creates a PDFFile object from the given pdf file.
FromFile(String,PDFDocumentLoadOptions) | Creates a PDFFile object from the given pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


FromFile(String) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromFile Method : FromFile(String) Method
the full path to a pdf file used as source for this PDFFile object.
Creates a PDFFile object from the given pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromFile( _
   ByVal fileName As String _
) As PDFFile
'Usage

Dim fileName As String
Dim value As PDFFile

value = PDFFile.FromFile(fileName)
public static PDFFile FromFile(
   string fileName
)
public: static PDFFile* FromFile(
   string* fileName
)
public:
static PDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.

Return Value

A PDFFile object created based on the given pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromFile(String,Byte[]) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromFile Method : FromFile(String,Byte[]) Method
the full path to a pdf file used as source for this PDFFile object.
the user password used to decrypt the PDF file.
Creates a PDFFile object from the given pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromFile( _
   ByVal fileName As String, _
   ByVal userPassword() As Byte _
) As PDFFile
'Usage

Dim fileName As String
Dim userPassword() As Byte
Dim value As PDFFile

value = PDFFile.FromFile(fileName, userPassword)
public static PDFFile FromFile(
   string fileName,
   byte[] userPassword
)
public: static PDFFile* FromFile(
   string* fileName,
   byte[]* userPassword
)
public:
static PDFFile^ FromFile(
   String^ fileName,
   array<byte>^ userPassword
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromFile(String,String) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromFile Method : FromFile(String,String) Method
the full path to a pdf file used as source for this PDFFile object.
the password used to decrypt the PDF file.
Creates a PDFFile object from the given pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromFile( _
   ByVal fileName As String, _
   ByVal password As String _
) As PDFFile
'Usage

Dim fileName As String
Dim password As String
Dim value As PDFFile

value = PDFFile.FromFile(fileName, password)
public static PDFFile FromFile(
   string fileName,
   string password
)
public: static PDFFile* FromFile(
   string* fileName,
   string* password
)
public:
static PDFFile^ FromFile(
   String^ fileName,
   String^ password
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.
password
the password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromFile(String,PDFDocumentLoadOptions) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromFile Method : FromFile(String,PDFDocumentLoadOptions) Method
the full path to a pdf file used as source for this PDFFile object.
options specifying what parts of the PDF file should be loaded.
Creates a PDFFile object from the given pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromFile( _
   ByVal fileName As String, _
   ByVal loadOptions As PDFDocumentLoadOptions _
) As PDFFile
'Usage

Dim fileName As String
Dim loadOptions As PDFDocumentLoadOptions
Dim value As PDFFile

value = PDFFile.FromFile(fileName, loadOptions)
public static PDFFile FromFile(
   string fileName,
   PDFDocumentLoadOptions loadOptions
)
public: static PDFFile* FromFile(
   string* fileName,
   PDFDocumentLoadOptions* loadOptions
)
public:
static PDFFile^ FromFile(
   String^ fileName,
   PDFDocumentLoadOptions^ loadOptions
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.
loadOptions
options specifying what parts of the PDF file should be loaded.

Return Value

A PDFFile object created based on the given pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromStream Method (PDFFile)

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : FromStream Method
Creates a PDFFile object from the given stream object.
Overload List
Overload | Description
FromStream(Stream) | Creates a PDFFile object from the given stream object.
FromStream(Stream,Byte[]) | Creates a PDFFile object from the given stream object.
FromStream(Stream,String) | Creates a PDFFile object from the given stream object.
FromStream(Stream,PDFDocumentLoadOptions) | Creates a PDFFile object from the given stream object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


FromStream(Stream) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromStream Method : FromStream(Stream) Method
the stream object used as source for this PDFFile object.
Creates a PDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal stream As Stream _
) As PDFFile
'Usage

Dim stream As Stream
Dim value As PDFFile

value = PDFFile.FromStream(stream)
public static PDFFile FromStream(
   Stream stream
)
public: static PDFFile* FromStream(
   Stream* stream
)
public:
static PDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this PDFFile object.

Return Value

A PDFFile object created based on the given stream object.
Remarks
The stream must contain a valid pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromStream(Stream,Byte[]) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromStream Method : FromStream(Stream,Byte[]) Method
the stream object used as source for this PDFFile object.
the user password used to decrypt the PDF file.
Creates a PDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal stream As Stream, _
   ByVal userPassword() As Byte _
) As PDFFile
'Usage

Dim stream As Stream
Dim userPassword() As Byte
Dim value As PDFFile

value = PDFFile.FromStream(stream, userPassword)
public static PDFFile FromStream(
   Stream stream,
   byte[] userPassword
)
public: static PDFFile* FromStream(
   Stream* stream,
   byte[]* userPassword
)
public:
static PDFFile^ FromStream(
   Stream^ stream,
   array<byte>^ userPassword
)

Parameters

stream
the stream object used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given stream object.
Remarks
The stream must contain a valid pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromStream(Stream,String) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromStream Method : FromStream(Stream,String) Method
the stream object used as source for this PDFFile object.
the password used to decrypt the PDF file.
Creates a PDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal stream As Stream, _
   ByVal password As String _
) As PDFFile
'Usage

Dim stream As Stream
Dim password As String
Dim value As PDFFile

value = PDFFile.FromStream(stream, password)
public static PDFFile FromStream(
   Stream stream,
   string password
)
public: static PDFFile* FromStream(
   Stream* stream,
   string* password
)
public:
static PDFFile^ FromStream(
   Stream^ stream,
   String^ password
)

Parameters

stream
the stream object used as source for this PDFFile object.
password
the password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given stream object.
Remarks
The stream must contain a valid pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromStream(Stream,PDFDocumentLoadOptions) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromStream Method : FromStream(Stream,PDFDocumentLoadOptions) Method
the stream object used as source for this PDFFile object.
options specifying what parts of the PDF file should be loaded.
Creates a PDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal stream As Stream, _
   ByVal loadOptions As PDFDocumentLoadOptions _
) As PDFFile
'Usage

Dim stream As Stream
Dim loadOptions As PDFDocumentLoadOptions
Dim value As PDFFile

value = PDFFile.FromStream(stream, loadOptions)
public static PDFFile FromStream(
   Stream stream,
   PDFDocumentLoadOptions loadOptions
)
public: static PDFFile* FromStream(
   Stream* stream,
   PDFDocumentLoadOptions* loadOptions
)
public:
static PDFFile^ FromStream(
   Stream^ stream,
   PDFDocumentLoadOptions^ loadOptions
)

Parameters

stream
the stream object used as source for this PDFFile object.
loadOptions
options specifying what parts of the PDF file should be loaded.

Return Value

A PDFFile object created based on the given stream object.
Remarks
The stream must contain a valid pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


GetJavaScripts Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : GetJavaScripts Method
Gets the JavaScript code fragments embedded in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetJavaScripts() As PDFJavaScriptCollection
'Usage

Dim instance As PDFFile
Dim value As PDFJavaScriptCollection

value = instance.GetJavaScripts()
public PDFJavaScriptCollection GetJavaScripts()
public: PDFJavaScriptCollection* GetJavaScripts();
public:
PDFJavaScriptCollection^ GetJavaScripts();

Return Value

A collection of O2S.Components.PDF4NET.PDFJavaScript objects representing the JavaScript code fragments included in the PDF file.
Remarks
The PDF file must be open with the load options specifying that LoadJavaScripts property is true in order for the method below to return the existing JavaScripts.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


GetPageNumberingRanges Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : GetPageNumberingRanges Method
Gets the page numbering ranges included in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPageNumberingRanges() As PDFPageNumberingRangeCollection
'Usage

Dim instance As PDFFile
Dim value As PDFPageNumberingRangeCollection

value = instance.GetPageNumberingRanges()
public PDFPageNumberingRangeCollection GetPageNumberingRanges()
public: PDFPageNumberingRangeCollection* GetPageNumberingRanges();
public:
PDFPageNumberingRangeCollection^ GetPageNumberingRanges();

Return Value

A collection of O2S.Components.PDF4NET.PDFPageNumberingRange objects representing the page numbering ranges included in the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


MergeFiles Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : MergeFiles Method
Merges multiple pdf files into a single pdf file.
Overload List
Overload | Description
MergeFiles(String,String[]) | Merges multiple pdf files into a single pdf file.
MergeFiles(String,String[],Boolean) | Merges multiple pdf files into a single pdf file.
MergeFiles(String[]) | Merges multiple pdf files into a single O2S.Components.PDF4NET.PDFDocument object.
MergeFiles(Stream,Stream[]) | Merges multiple pdf files into a single pdf file.
MergeFiles(Stream,Stream[],Boolean) | Merges multiple pdf files into a single pdf file.
MergeFiles(Stream[]) | Merges multiple pdf files into a single O2S.Components.PDF4NET.PDFDocument object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


MergeFiles(String,String[]) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(String,String[]) Method
the fully qualified name of the destination file
an array of pdf files that will be merged
Merges multiple pdf files into a single pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub MergeFiles( _
   ByVal destFileName As String, _
   ByVal srcFileNames() As String _
)
'Usage

Dim destFileName As String
Dim srcFileNames() As String

PDFFile.MergeFiles(destFileName, srcFileNames)
public static void MergeFiles(
   string destFileName,
   string[] srcFileNames
)
public: static void MergeFiles(
   string* destFileName,
   string*[]* srcFileNames
)
public:
static void MergeFiles(
   String^ destFileName,
   array<String^>^ srcFileNames
)

Parameters

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged
Exceptions
Exception | Description
System.ArgumentException | thrown when less than 2 source pdf files as given as parameter.
O2S.Components.PDF4NET.PDFParserException | thrown when input pdf files can not be parsed.
Remarks
This method merges several pdf files into a single one and saves the final pdf file to the location specified by destFileName parameter. The method accepts a string array of pdf files, so multiple pdf files can be appended at once. The files will be merged in the order they appear in the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(String,String[],Boolean) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(String,String[],Boolean) Method
the fully qualified name of the destination file
an array of pdf files that will be merged
True if the merged PDF file must be saved in fast web view format.
Merges multiple pdf files into a single pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub MergeFiles( _
   ByVal destFileName As String, _
   ByVal srcFileNames() As String, _
   ByVal enableFastWebView As Boolean _
)
'Usage

Dim destFileName As String
Dim srcFileNames() As String
Dim enableFastWebView As Boolean

PDFFile.MergeFiles(destFileName, srcFileNames, enableFastWebView)
public static void MergeFiles(
   string destFileName,
   string[] srcFileNames,
   bool enableFastWebView
)
public: static void MergeFiles(
   string* destFileName,
   string*[]* srcFileNames,
   bool enableFastWebView
)
public:
static void MergeFiles(
   String^ destFileName,
   array<String^>^ srcFileNames,
   bool enableFastWebView
)

Parameters

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.
Exceptions
Exception | Description
System.ArgumentException | thrown when less than 2 source pdf files as given as parameter.
O2S.Components.PDF4NET.PDFParserException | thrown when input pdf files can not be parsed.
Remarks
This method merges several pdf files into a single one and saves the final pdf file to the location specified by destFileName parameter. The method accepts a string array of pdf files, so multiple pdf files can be appended at once. The files will be merged in the order they appear in the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(String[]) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(String[]) Method
an array of pdf files that will be merged
Merges multiple pdf files into a single O2S.Components.PDF4NET.PDFDocument object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function MergeFiles( _
   ByVal srcFileNames() As String _
) As PDFDocument
'Usage

Dim srcFileNames() As String
Dim value As PDFDocument

value = PDFFile.MergeFiles(srcFileNames)
public static PDFDocument MergeFiles(
   string[] srcFileNames
)
public: static PDFDocument* MergeFiles(
   string*[]* srcFileNames
)
public:
static PDFDocument^ MergeFiles(
   array<String^>^ srcFileNames
)

Parameters

srcFileNames
an array of pdf files that will be merged
Exceptions
Exception | Description
System.ArgumentException | thrown when less than 2 source pdf files as given as parameter.
O2S.Components.PDF4NET.PDFParserException | thrown when input pdf files can not be parsed.
Remarks
This method merges several pdf files into a single one and returns the new O2S.Components.PDF4NET.PDFDocument object, so new content and new pages can be added. The method accepts a string array of pdf files, so multiple pdf files can be appended at once. The files will be merged in the order they appear in the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(Stream,Stream[]) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(Stream,Stream[]) Method
a stream to hold the merged pdf file
an array of pdf streams that will be merged
Merges multiple pdf files into a single pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub MergeFiles( _
   ByVal destFile As Stream, _
   ByVal srcFiles() As Stream _
)
'Usage

Dim destFile As Stream
Dim srcFiles() As Stream

PDFFile.MergeFiles(destFile, srcFiles)
public static void MergeFiles(
   Stream destFile,
   Stream[] srcFiles
)
public: static void MergeFiles(
   Stream* destFile,
   Stream*[]* srcFiles
)
public:
static void MergeFiles(
   Stream^ destFile,
   array<Stream^>^ srcFiles
)

Parameters

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged
Exceptions
Exception | Description
System.ArgumentException | thrown when less than 2 source pdf files are given as parameter.
O2S.Components.PDF4NET.PDFParserException | thrown when input pdf files can not be parsed.
Remarks
This method merges several pdf streams into a single one and saves the final pdf file to a stream specified by destFile parameter. The method accepts an array of pdf streams, so multiple pdf files can be appended at once in memory. The files will be merged in the order they appear in the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(Stream,Stream[],Boolean) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(Stream,Stream[],Boolean) Method
a stream to hold the merged pdf file
an array of pdf streams that will be merged
True if the merged PDF file must be saved in fast web view format.
Merges multiple pdf files into a single pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub MergeFiles( _
   ByVal destFile As Stream, _
   ByVal srcFiles() As Stream, _
   ByVal enableFastWebView As Boolean _
)
'Usage

Dim destFile As Stream
Dim srcFiles() As Stream
Dim enableFastWebView As Boolean

PDFFile.MergeFiles(destFile, srcFiles, enableFastWebView)
public static void MergeFiles(
   Stream destFile,
   Stream[] srcFiles,
   bool enableFastWebView
)
public: static void MergeFiles(
   Stream* destFile,
   Stream*[]* srcFiles,
   bool enableFastWebView
)
public:
static void MergeFiles(
   Stream^ destFile,
   array<Stream^>^ srcFiles,
   bool enableFastWebView
)

Parameters

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.
Exceptions
Exception | Description
System.ArgumentException | thrown when less than 2 source pdf files are given as parameter.
O2S.Components.PDF4NET.PDFParserException | thrown when input pdf files can not be parsed.
Remarks
This method merges several pdf streams into a single one and saves the final pdf file to a stream specified by destFile parameter. The method accepts an array of pdf streams, so multiple pdf files can be appended at once in memory. The files will be merged in the order they appear in the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(Stream[]) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(Stream[]) Method
an array of pdf file streams that will be merged
Merges multiple pdf files into a single O2S.Components.PDF4NET.PDFDocument object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function MergeFiles( _
   ByVal srcFiles() As Stream _
) As PDFDocument
'Usage

Dim srcFiles() As Stream
Dim value As PDFDocument

value = PDFFile.MergeFiles(srcFiles)
public static PDFDocument MergeFiles(
   Stream[] srcFiles
)
public: static PDFDocument* MergeFiles(
   Stream*[]* srcFiles
)
public:
static PDFDocument^ MergeFiles(
   array<Stream^>^ srcFiles
)

Parameters

srcFiles
an array of pdf file streams that will be merged
Exceptions
Exception | Description
System.ArgumentException | thrown when less than 2 source pdf streams as given as parameter.
O2S.Components.PDF4NET.PDFParserException | thrown when input pdf streams can not be parsed.
Remarks
This method merges several pdf streams into a single one and returns the new O2S.Components.PDF4NET.PDFDocument object, to allow new content and new pages to be added. The method accepts an array of pdf streams, so multiple pdf streams can be appended at once. The streams will be merged in the order they appear in the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


SplitFile Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : SplitFile Method
the full path of the pdf file to split.
the name of destiantion individual pages file.
Splits the given pdf file to individual pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SplitFile( _
   ByVal srcFileName As String, _
   ByVal destFileName As String _
)
'Usage

Dim srcFileName As String
Dim destFileName As String

PDFFile.SplitFile(srcFileName, destFileName)
public static void SplitFile(
   string srcFileName,
   string destFileName
)
public: static void SplitFile(
   string* srcFileName,
   string* destFileName
)
public:
static void SplitFile(
   String^ srcFileName,
   String^ destFileName
)

Parameters

srcFileName
the full path of the pdf file to split.
destFileName
the name of destiantion individual pages file.
Remarks
This method splits a pdf file to individual pages. Each page is named using destFileName parameter after which a numeric index is appended, eg: destfileName001.pdf, destfileName002.pdf, destfileName003.pdf, etc.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%% $$Properties$$

PDFFile Class Properties

O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

For a list of all members of this type, see PDFFile members.

Public Properties
 | Name | Description
Public Property | DocumentCatalog | Gets the document catalog dictionary.
Public Property | DocumentInformation | Gets the document information for this PDF file.
Public Property | IsRepaired | Gets a value indicating whether the PDF file was repaired or not before it has been loaded.
Public Property | PagesCount | Gets the number of pages in the PDF file.
Public Property | PDFVersion | Gets or sets the PDF version of this PDFFile object.
Public Property | SecurityManager | Gets the security manager for this PDF file.
static (Shared in Visual Basic) | SerialNumber | Sets the serial number and unlocks the component.
Top
See Also

Reference

PDFFile Class
O2S.Components.PDF4NET.PDFFile Namespace


DocumentCatalog Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : DocumentCatalog Property
Gets the document catalog dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DocumentCatalog As PDFDictionary
'Usage

Dim instance As PDFFile
Dim value As PDFDictionary

value = instance.DocumentCatalog
public PDFDictionary DocumentCatalog {get;}
public: __property PDFDictionary* get_DocumentCatalog();
public:
property PDFDictionary^ DocumentCatalog {
   PDFDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


DocumentInformation Property (PDFFile)

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : DocumentInformation Property
Gets the document information for this PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DocumentInformation As PDFDocumentInformation
'Usage

Dim instance As PDFFile
Dim value As PDFDocumentInformation

value = instance.DocumentInformation
public PDFDocumentInformation DocumentInformation {get;}
public: __property PDFDocumentInformation* get_DocumentInformation();
public:
property PDFDocumentInformation^ DocumentInformation {
   PDFDocumentInformation^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFDocumentInformation object storing the document information for this PDF file.
Remarks
The document information is created automatically when a PDF file is imported. If the PDF file does not contain any document information, this property returns null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


IsRepaired Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : IsRepaired Property
Gets a value indicating whether the PDF file was repaired or not before it has been loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsRepaired As Boolean
'Usage

Dim instance As PDFFile
Dim value As Boolean

value = instance.IsRepaired
public bool IsRepaired {get;}
public: __property bool get_IsRepaired();
public:
property bool IsRepaired {
   bool get();
}

Property Value

True if the file has been repaired before it has been loaded, false otherwise.
Remarks
The file is repaired in memory, the original file on disk is not affected.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


PagesCount Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : PagesCount Property
Gets the number of pages in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PagesCount As Integer
'Usage

Dim instance As PDFFile
Dim value As Integer

value = instance.PagesCount
public int PagesCount {get;}
public: __property int get_PagesCount();
public:
property int PagesCount {
   int get();
}

Property Value

An integer value specifying the number of pages of the PDF document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


PDFVersion Property (PDFFile)

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : PDFVersion Property
Gets or sets the PDF version of this PDFFile object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PDFVersion As PDFVersion
'Usage

Dim instance As PDFFile
Dim value As PDFVersion

value = instance.PDFVersion
public PDFVersion PDFVersion {get;}
public: __property PDFVersion get_PDFVersion();
public:
property PDFVersion PDFVersion {
   PDFVersion get();
}

Property Value

A PDFVersion enumeration member specifying the PDF version of this O2S.Components.PDF4NET.PDFDocument object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


SecurityManager Property (PDFFile)

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : SecurityManager Property
Gets the security manager for this PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SecurityManager As PDFSecurityManager
'Usage

Dim instance As PDFFile
Dim value As PDFSecurityManager

value = instance.SecurityManager
public PDFSecurityManager SecurityManager {get;}
public: __property PDFSecurityManager* get_SecurityManager();
public:
property PDFSecurityManager^ SecurityManager {
   PDFSecurityManager^ get();
}

Property Value

A O2S.Components.PDF4NET.Security.PDFSecurityManager object storing the security settings for this PDF file.
Remarks
The security manager is created automatically when an encrypted PDF file is processed. If the PDF file is not encrypted, then this property returns null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


SerialNumber Property (PDFFile)

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : SerialNumber Property
Sets the serial number and unlocks the component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared WriteOnly Property SerialNumber As String
'Usage

PDFFile.SerialNumber = value
public static string SerialNumber {set;}
public: __property static void set_SerialNumber(
   string* value
);
public:
static property String^ SerialNumber {
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

PDFImportedContent Class
Members

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class
Represents the binary content of a page in a pdf file.
Object Model
PDFImportedContent ClassDisplayRectangle ClassPDFSeparationInfo Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFImportedContent
   Inherits O2S.Components.PDF4NET.PDFGraphicsContainer
'Usage

Dim instance As PDFImportedContent
public class PDFImportedContent : O2S.Components.PDF4NET.PDFGraphicsContainer
public __gc class PDFImportedContent : public O2S.Components.PDF4NET.PDFGraphicsContainer
public ref class PDFImportedContent : public O2S.Components.PDF4NET.PDFGraphicsContainer
Remarks
This class represents the binary content of a page in a pdf file. This binary content creates the visual appearance of the page. It contains instructions for drawing text, images, etc. This binary content can be extracted and drawn on a new page. When it is drawn, it can be rotated. The content is automatically scaled to fit the given destination rectangle. To draw only a section of the imported content to the destination rectangle, set the ClipLeft, ClipTop, ClipWidth and ClipHeight properties to desired values. These values define the clipping rectangle, only the content inside the clipping rectangle will be displayed in the destination rectangle.
Links, form fields and annotations are not part of page content, so when the content is extracted, these items are not included.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.PDFFile.PDFImportedContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFImportedContent Class Members
Properties Methods

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

The following tables list the members exposed by PDFImportedContent.

Public Properties
 | Name | Description
Public Property | ClipHeight | Gets or sets the visible height of the imported page content.
Public Property | ClipLeft | Gets or sets the left coordinate of the visible part of the imported page content.
Public Property | ClipRectangle | Gets or sets the rectangle that defines the visible area of imported content.
Public Property | ClipTop | Gets or sets the top coordinate of the visible part of the imported page content.
Public Property | ClipWidth | Gets or sets the visible width of the imported page content.
Public Property | Height | Gets the original height of the imported contet.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Width | Gets the original width of the imported content.
Top
Public Methods
 | Name | Description
Public Method | ExtractColorSpaces | Extracts the colorspaces that exist in the page resources.
Top
See Also

Reference

PDFImportedContent Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Methods$$

PDFImportedContent Class Methods

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

For a list of all members of this type, see PDFImportedContent members.

Public Methods
 | Name | Description
Public Method | ExtractColorSpaces | Extracts the colorspaces that exist in the page resources.
Top
See Also

Reference

PDFImportedContent Class
O2S.Components.PDF4NET.PDFFile Namespace


ExtractColorSpaces Method (PDFImportedContent)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ExtractColorSpaces Method
Extracts the colorspaces that exist in the page resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractColorSpaces() As PDFColorSpaceCollection
'Usage

Dim instance As PDFImportedContent
Dim value As PDFColorSpaceCollection

value = instance.ExtractColorSpaces()
public PDFColorSpaceCollection ExtractColorSpaces()
public: PDFColorSpaceCollection* ExtractColorSpaces();
public:
PDFColorSpaceCollection^ ExtractColorSpaces();

Return Value

List of colorspaces defined in page resources.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%% $$Properties$$

PDFImportedContent Class Properties

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

For a list of all members of this type, see PDFImportedContent members.

Public Properties
 | Name | Description
Public Property | ClipHeight | Gets or sets the visible height of the imported page content.
Public Property | ClipLeft | Gets or sets the left coordinate of the visible part of the imported page content.
Public Property | ClipRectangle | Gets or sets the rectangle that defines the visible area of imported content.
Public Property | ClipTop | Gets or sets the top coordinate of the visible part of the imported page content.
Public Property | ClipWidth | Gets or sets the visible width of the imported page content.
Public Property | Height | Gets the original height of the imported contet.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Width | Gets the original width of the imported content.
Top
See Also

Reference

PDFImportedContent Class
O2S.Components.PDF4NET.PDFFile Namespace


ClipHeight Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipHeight Property
Gets or sets the visible height of the imported page content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClipHeight As Double
'Usage

Dim instance As PDFImportedContent
Dim value As Double

instance.ClipHeight = value

value = instance.ClipHeight
public double ClipHeight {get; set;}
public: __property double get_ClipHeight();
public: __property void set_ClipHeight(
   double value
);
public:
property double ClipHeight {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


ClipLeft Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipLeft Property
Gets or sets the left coordinate of the visible part of the imported page content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClipLeft As Double
'Usage

Dim instance As PDFImportedContent
Dim value As Double

instance.ClipLeft = value

value = instance.ClipLeft
public double ClipLeft {get; set;}
public: __property double get_ClipLeft();
public: __property void set_ClipLeft(
   double value
);
public:
property double ClipLeft {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


ClipRectangle Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipRectangle Property
Gets or sets the rectangle that defines the visible area of imported content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClipRectangle As DisplayRectangle
'Usage

Dim instance As PDFImportedContent
Dim value As DisplayRectangle

instance.ClipRectangle = value

value = instance.ClipRectangle
public DisplayRectangle ClipRectangle {get; set;}
public: __property DisplayRectangle* get_ClipRectangle();
public: __property void set_ClipRectangle(
   DisplayRectangle* value
);
public:
property DisplayRectangle^ ClipRectangle {
   DisplayRectangle^ get();
   void set (    DisplayRectangle^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


ClipTop Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipTop Property
Gets or sets the top coordinate of the visible part of the imported page content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClipTop As Double
'Usage

Dim instance As PDFImportedContent
Dim value As Double

instance.ClipTop = value

value = instance.ClipTop
public double ClipTop {get; set;}
public: __property double get_ClipTop();
public: __property void set_ClipTop(
   double value
);
public:
property double ClipTop {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


ClipWidth Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipWidth Property
Gets or sets the visible width of the imported page content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClipWidth As Double
'Usage

Dim instance As PDFImportedContent
Dim value As Double

instance.ClipWidth = value

value = instance.ClipWidth
public double ClipWidth {get; set;}
public: __property double get_ClipWidth();
public: __property void set_ClipWidth(
   double value
);
public:
property double ClipWidth {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


Height Property (PDFImportedContent)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : Height Property
Gets the original height of the imported contet.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PDFImportedContent
Dim value As Double

value = instance.Height
public double Height {get;}
public: __property double get_Height();
public:
property double Height {
   double get();
}

Property Value

The original height of the imported content in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


SeparationInfo Property (PDFImportedContent)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : SeparationInfo Property
Gets the separation information associated with the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SeparationInfo As PDFSeparationInfo
'Usage

Dim instance As PDFImportedContent
Dim value As PDFSeparationInfo

value = instance.SeparationInfo
public PDFSeparationInfo SeparationInfo {get;}
public: __property PDFSeparationInfo* get_SeparationInfo();
public:
property PDFSeparationInfo^ SeparationInfo {
   PDFSeparationInfo^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFSeparationInfo object specifying the separation information for the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


Width Property (PDFImportedContent)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : Width Property
Gets the original width of the imported content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PDFImportedContent
Dim value As Double

value = instance.Width
public double Width {get;}
public: __property double get_Width();
public:
property double Width {
   double get();
}

Property Value

The original width of the imported content in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


%%PageItemTitle%%

PDFImportedPage Class
Members

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class
Represents a page in a pdf file.
Object Model
PDFImportedPage ClassPDFAnnotationCollection ClassPDFAnnotation ClassPDFRectangle ClassPDFPageBackground ClassPDFRectangle ClassPDFCanvas ClassPDFAction ClassPDFRectangle ClassPDFDictionary ClassPDFDocument ClassPDFFieldCollection ClassPDFField ClassPDFRectangle ClassPDFPageNumber ClassPDFAction ClassPDFSeparationInfo ClassPDFRectangle ClassPDFCanvas ClassPDFViewportCollection ClassPDFViewport Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFImportedPage
   Inherits O2S.Components.PDF4NET.PDFPage
'Usage

Dim instance As PDFImportedPage
public class PDFImportedPage : O2S.Components.PDF4NET.PDFPage
public __gc class PDFImportedPage : public O2S.Components.PDF4NET.PDFPage
public ref class PDFImportedPage : public O2S.Components.PDF4NET.PDFPage
Remarks
This class represents a single page in a pdf file. A page can be extracted from a pdf document and included anywhere in a new one.
Links, form fields and annotations are part of the page, so when the page is extracted, these items are extracted too.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFImportedPage Class Members
Properties Methods

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

The following tables list the members exposed by PDFImportedPage.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the list of page annotations. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ArtBox | Gets or sets the page art box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Background | Gets or sets the background of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | BleedBox | Gets or sets the page bleed box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ByteCount | Gets the approximate size in bytes of the imported page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Canvas | Gets the page canvas. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | CloseAction | Gets or sets the action to be performed when the page is closed. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ContentStream | Gets the page's content stream.
Public Property | CropBox | Gets or sets the page crop box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Dictionary | Gets the page dictionary. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Document | Gets the document this page belongs to. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Fields | Gets the list of fields defined on this page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Height | Gets or sets the page height. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | MediaBox | Gets or sets the page media box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Number | Gets or sets the page number visual aspect for this O2S.Components.PDF4NET.PDFPage object. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | OpenAction | Gets or sets the action to be performed when the page is opened. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Orientation | Gets or sets the page orientation. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Rotation | Gets or sets the page rotation angle. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | SeparationInfo | Gets the separation information associated with the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Size | Gets or sets the page size. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | TrimBox | Gets or sets the page trim box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | UnderCanvas | Gets the canvas of the page.
Public Property | Viewports | Gets or sets the page viewports. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | VisibleHeight | Gets the height of the top left corner of the visible page area.
Public Property | VisibleLeft | Gets the X coordinate of the top left corner of the visible page area.
Public Property | VisibleTop | Gets the Y coordinate of the top left corner of the visible page area.
Public Property | VisibleWidth | Gets the width of the top left corner of the visible page area.
Public Property | Width | Gets or sets the page width. (Inherited from O2S.Components.PDF4NET.PDFPage)
Top
Public Methods
 | Name | Description
Public Method | ExtractColorSpaces | Extracts the colorspaces that exist in the page resources.
Public Method | ExtractImages | Gets the lists on images on the page as bitmap objects.
Public Method | ExtractPageObjects | Extracts the graphic objects from the PDF page.
Public Method | ExtractPDFGraphicOperators | Extracts the page content as a sequence of PDF graphic operators.
Public Method | ExtractText | Extracts the text from the PDF page.
Public Method | ExtractTextRuns | Extracts the text runs from the PDF page.
Public Method | ReplaceImage | Overloaded. Replaces an existing image with a new image.
Public Method | SearchText | Searches the page for the given text.
Top
See Also

Reference

PDFImportedPage Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Methods$$

PDFImportedPage Class Methods

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

For a list of all members of this type, see PDFImportedPage members.

Public Methods
 | Name | Description
Public Method | ExtractColorSpaces | Extracts the colorspaces that exist in the page resources.
Public Method | ExtractImages | Gets the lists on images on the page as bitmap objects.
Public Method | ExtractPageObjects | Extracts the graphic objects from the PDF page.
Public Method | ExtractPDFGraphicOperators | Extracts the page content as a sequence of PDF graphic operators.
Public Method | ExtractText | Extracts the text from the PDF page.
Public Method | ExtractTextRuns | Extracts the text runs from the PDF page.
Public Method | ReplaceImage | Overloaded. Replaces an existing image with a new image.
Public Method | SearchText | Searches the page for the given text.
Top
See Also

Reference

PDFImportedPage Class
O2S.Components.PDF4NET.PDFFile Namespace


ExtractColorSpaces Method (PDFImportedPage)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractColorSpaces Method
Extracts the colorspaces that exist in the page resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractColorSpaces() As PDFColorSpaceCollection
'Usage

Dim instance As PDFImportedPage
Dim value As PDFColorSpaceCollection

value = instance.ExtractColorSpaces()
public PDFColorSpaceCollection ExtractColorSpaces()
public: PDFColorSpaceCollection* ExtractColorSpaces();
public:
PDFColorSpaceCollection^ ExtractColorSpaces();

Return Value

List of colorspaces defined in page resources.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ExtractImages Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractImages Method
Gets the lists on images on the page as bitmap objects.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractImages() As Bitmap()
'Usage

Dim instance As PDFImportedPage
Dim value() As Bitmap

value = instance.ExtractImages()
public Bitmap[] ExtractImages()
public: Bitmap*[]* ExtractImages();
public:
array<Bitmap^>^ ExtractImages();

Return Value

An array of System.Drawing.Bitmap objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ExtractPageObjects Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractPageObjects Method
Extracts the graphic objects from the PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractPageObjects() As PDFPageObjectCollection
'Usage

Dim instance As PDFImportedPage
Dim value As PDFPageObjectCollection

value = instance.ExtractPageObjects()
public PDFPageObjectCollection ExtractPageObjects()
public: PDFPageObjectCollection* ExtractPageObjects();
public:
PDFPageObjectCollection^ ExtractPageObjects();

Return Value

The collection of page objects included in the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ExtractPDFGraphicOperators Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractPDFGraphicOperators Method
Extracts the page content as a sequence of PDF graphic operators.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractPDFGraphicOperators() As PDFGraphicOperatorCollection
'Usage

Dim instance As PDFImportedPage
Dim value As PDFGraphicOperatorCollection

value = instance.ExtractPDFGraphicOperators()
public PDFGraphicOperatorCollection ExtractPDFGraphicOperators()
public: PDFGraphicOperatorCollection* ExtractPDFGraphicOperators();
public:
PDFGraphicOperatorCollection^ ExtractPDFGraphicOperators();

Return Value

The collection of text runs included in the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ExtractText Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractText Method
Extracts the text from the PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractText() As String
'Usage

Dim instance As PDFImportedPage
Dim value As String

value = instance.ExtractText()
public string ExtractText()
public: string* ExtractText();
public:
String^ ExtractText();

Return Value

The text content of the page.
Remarks
The text returned by this method appears in the order it is defined in the page content stream, not in the visual order as it appears in the viewer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ExtractTextRuns Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractTextRuns Method
Extracts the text runs from the PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractTextRuns() As PDFTextRunCollection
'Usage

Dim instance As PDFImportedPage
Dim value As PDFTextRunCollection

value = instance.ExtractTextRuns()
public PDFTextRunCollection ExtractTextRuns()
public: PDFTextRunCollection* ExtractTextRuns();
public:
PDFTextRunCollection^ ExtractTextRuns();

Return Value

The collection of text runs included in the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ReplaceImage Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ReplaceImage Method
Replaces an existing image with a new image.
Overload List
Overload | Description
ReplaceImage(String,PDFImage) | Replaces an existing image with a new image.
ReplaceImage(Int32,PDFImage) | Replaces an existing image with a new image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ReplaceImage(String,PDFImage) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class > ReplaceImage Method : ReplaceImage(String,PDFImage) Method
The image ID that identifies the image in the resources dictionary.
The new image to be embedded in the PDF file.
Replaces an existing image with a new image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ReplaceImage( _
   ByVal imageID As String, _
   ByVal newImage As PDFImage _
)
'Usage

Dim instance As PDFImportedPage
Dim imageID As String
Dim newImage As PDFImage

instance.ReplaceImage(imageID, newImage)
public void ReplaceImage(
   string imageID,
   PDFImage newImage
)
public: void ReplaceImage(
   string* imageID,
   PDFImage* newImage
)
public:
void ReplaceImage(
   String^ imageID,
   PDFImage^ newImage
)

Parameters

imageID
The image ID that identifies the image in the resources dictionary.
newImage
The new image to be embedded in the PDF file.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the image ID is invalid and the specified image does not exist in the resources dictionary.
Remarks
This method just replaces the image data, it does not change the position or size of the image on the page. If the image is shared between several pages, the new image will appear on all pages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members
Overload List


ReplaceImage(Int32,PDFImage) Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class > ReplaceImage Method : ReplaceImage(Int32,PDFImage) Method
The image index in the resources dictionary.
The new image to be embedded in the PDF file.
Replaces an existing image with a new image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ReplaceImage( _
   ByVal imageIndex As Integer, _
   ByVal newImage As PDFImage _
)
'Usage

Dim instance As PDFImportedPage
Dim imageIndex As Integer
Dim newImage As PDFImage

instance.ReplaceImage(imageIndex, newImage)
public void ReplaceImage(
   int imageIndex,
   PDFImage newImage
)
public: void ReplaceImage(
   int imageIndex,
   PDFImage* newImage
)
public:
void ReplaceImage(
   int imageIndex,
   PDFImage^ newImage
)

Parameters

imageIndex
The image index in the resources dictionary.
newImage
The new image to be embedded in the PDF file.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the image index is lower than 0 or greater than number of images on the page.
Remarks
This method just replaces the image data, it does not change the position or size of the image on the page. If the image is shared between several pages, the new image will appear on all pages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members
Overload List


SearchText Method

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : SearchText Method
Text to search.
Searches the page for the given text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function SearchText( _
   ByVal text As String _
) As PDFSearchTextResultCollection
'Usage

Dim instance As PDFImportedPage
Dim text As String
Dim value As PDFSearchTextResultCollection

value = instance.SearchText(text)
public PDFSearchTextResultCollection SearchText(
   string text
)
public: PDFSearchTextResultCollection* SearchText(
   string* text
)
public:
PDFSearchTextResultCollection^ SearchText(
   String^ text
)

Parameters

text
Text to search.

Return Value

List of search results.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%% $$Properties$$

PDFImportedPage Class Properties

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

For a list of all members of this type, see PDFImportedPage members.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the list of page annotations. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ArtBox | Gets or sets the page art box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Background | Gets or sets the background of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | BleedBox | Gets or sets the page bleed box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ByteCount | Gets the approximate size in bytes of the imported page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Canvas | Gets the page canvas. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | CloseAction | Gets or sets the action to be performed when the page is closed. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ContentStream | Gets the page's content stream.
Public Property | CropBox | Gets or sets the page crop box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Dictionary | Gets the page dictionary. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Document | Gets the document this page belongs to. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Fields | Gets the list of fields defined on this page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Height | Gets or sets the page height. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | MediaBox | Gets or sets the page media box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Number | Gets or sets the page number visual aspect for this O2S.Components.PDF4NET.PDFPage object. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | OpenAction | Gets or sets the action to be performed when the page is opened. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Orientation | Gets or sets the page orientation. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Rotation | Gets or sets the page rotation angle. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | SeparationInfo | Gets the separation information associated with the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Size | Gets or sets the page size. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | TrimBox | Gets or sets the page trim box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | UnderCanvas | Gets the canvas of the page.
Public Property | Viewports | Gets or sets the page viewports. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | VisibleHeight | Gets the height of the top left corner of the visible page area.
Public Property | VisibleLeft | Gets the X coordinate of the top left corner of the visible page area.
Public Property | VisibleTop | Gets the Y coordinate of the top left corner of the visible page area.
Public Property | VisibleWidth | Gets the width of the top left corner of the visible page area.
Public Property | Width | Gets or sets the page width. (Inherited from O2S.Components.PDF4NET.PDFPage)
Top
See Also

Reference

PDFImportedPage Class
O2S.Components.PDF4NET.PDFFile Namespace


ContentStream Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ContentStream Property
Gets the page's content stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ContentStream As Byte()
'Usage

Dim instance As PDFImportedPage
Dim value() As Byte

value = instance.ContentStream
public byte[] ContentStream {get;}
public: __property byte[]* get_ContentStream();
public:
property array<byte>^ ContentStream {
   array<byte>^ get();
}

Property Value

A byte array representing the page's content stream.
Remarks
This property returns the page's content stream after it has decrpyted and decompressed. It contains the stream of raw PDF instructions used to create the page visual appearance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


UnderCanvas Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : UnderCanvas Property
Gets the canvas of the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UnderCanvas As PDFCanvas
'Usage

Dim instance As PDFImportedPage
Dim value As PDFCanvas

value = instance.UnderCanvas
public PDFCanvas UnderCanvas {get;}
public: __property PDFCanvas* get_UnderCanvas();
public:
property PDFCanvas^ UnderCanvas {
   PDFCanvas^ get();
}

Property Value

A O2S.Components.PDF4NET.Graphics.PDFBasicCanvas object specifying the drawing surface located under actual page content.
Remarks
The under canvas allows to draw directly under existing page content. The regular Canvas draws on top of existing content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


VisibleHeight Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleHeight Property
Gets the height of the top left corner of the visible page area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VisibleHeight As Double
'Usage

Dim instance As PDFImportedPage
Dim value As Double

value = instance.VisibleHeight
public double VisibleHeight {get;}
public: __property double get_VisibleHeight();
public:
property double VisibleHeight {
   double get();
}

Property Value

The height of the visible page area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


VisibleLeft Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleLeft Property
Gets the X coordinate of the top left corner of the visible page area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VisibleLeft As Double
'Usage

Dim instance As PDFImportedPage
Dim value As Double

value = instance.VisibleLeft
public double VisibleLeft {get;}
public: __property double get_VisibleLeft();
public:
property double VisibleLeft {
   double get();
}

Property Value

The X coordinate of the visible page area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


VisibleTop Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleTop Property
Gets the Y coordinate of the top left corner of the visible page area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VisibleTop As Double
'Usage

Dim instance As PDFImportedPage
Dim value As Double

value = instance.VisibleTop
public double VisibleTop {get;}
public: __property double get_VisibleTop();
public:
property double VisibleTop {
   double get();
}

Property Value

The Y coordinate of the visible page area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


VisibleWidth Property

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleWidth Property
Gets the width of the top left corner of the visible page area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VisibleWidth As Double
'Usage

Dim instance As PDFImportedPage
Dim value As Double

value = instance.VisibleWidth
public double VisibleWidth {get;}
public: __property double get_VisibleWidth();
public:
property double VisibleWidth {
   double get();
}

Property Value

The width of the visible page area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


%%PageItemTitle%%

PDFImportedPageInfo Class
Members

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPageInfo Class
Defines the properties of an imported page but without actual page content.
Object Model
PDFImportedPageInfo ClassPDFRectangle ClassPDFRectangle ClassPDFRectangle ClassPDFRectangle ClassPDFSeparationInfo ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFImportedPageInfo
'Usage

Dim instance As PDFImportedPageInfo
public class PDFImportedPageInfo
public __gc class PDFImportedPageInfo
public ref class PDFImportedPageInfo
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.PDFImportedPageInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPageInfo Members
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Members$$

PDFImportedPageInfo Class Members
Properties

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPageInfo Class

The following tables list the members exposed by PDFImportedPageInfo.

Public Properties
 | Name | Description
Public Property | ArtBox | Gets the dimensions of the page's art box.
Public Property | BleedBox | Gets the dimensions of the page's bleed box.
Public Property | CropBox | Gets the dimensions of the page's crop box.
Public Property | MediaBox | Gets the dimensions of the page's media box.
Public Property | Rotation | Gets the rotation angle of the page.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | TrimBox | Gets the dimensions of the page's trim box.
Top
See Also

Reference

PDFImportedPageInfo Class
O2S.Components.PDF4NET.PDFFile Namespace


%%PageItemTitle%% $$Properties$$

PDFImportedPageInfo Class Properties

O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPageInfo Class

For a list of all members of this type, see PDFImportedPageInfo members.

Public Properties
 | Name | Description
Public Property | ArtBox | Gets the dimensions of the page's art box.
Public Property | BleedBox | Gets the dimensions of the page's bleed box.
Public Property | CropBox | Gets the dimensions of the page's crop box.
Public Property | MediaBox | Gets the dimensions of the page's media box.
Public Property | Rotation | Gets the rotation angle of the page.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | TrimBox | Gets the dimensions of the page's trim box.
Top
See Also

Reference

PDFImportedPageInfo Class
O2S.Components.PDF4NET.PDFFile Namespace


ArtBox Property (PDFImportedPageInfo)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : ArtBox Property
Gets the dimensions of the page's art box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ArtBox As PDFRectangle
'Usage

Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.ArtBox
public PDFRectangle ArtBox {get;}
public: __property PDFRectangle* get_ArtBox();
public:
property PDFRectangle^ ArtBox {
   PDFRectangle^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFRectangle object representing the page's art box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


BleedBox Property (PDFImportedPageInfo)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : BleedBox Property
Gets the dimensions of the page's bleed box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BleedBox As PDFRectangle
'Usage

Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.BleedBox
public PDFRectangle BleedBox {get;}
public: __property PDFRectangle* get_BleedBox();
public:
property PDFRectangle^ BleedBox {
   PDFRectangle^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFRectangle object representing the page's bleed box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


CropBox Property (PDFImportedPageInfo)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : CropBox Property
Gets the dimensions of the page's crop box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CropBox As PDFRectangle
'Usage

Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.CropBox
public PDFRectangle CropBox {get;}
public: __property PDFRectangle* get_CropBox();
public:
property PDFRectangle^ CropBox {
   PDFRectangle^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFRectangle object representing the page's crop box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


MediaBox Property (PDFImportedPageInfo)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : MediaBox Property
Gets the dimensions of the page's media box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MediaBox As PDFRectangle
'Usage

Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.MediaBox
public PDFRectangle MediaBox {get;}
public: __property PDFRectangle* get_MediaBox();
public:
property PDFRectangle^ MediaBox {
   PDFRectangle^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFRectangle object representing the page's media box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


Rotation Property (PDFImportedPageInfo)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : Rotation Property
Gets the rotation angle of the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFImportedPageInfo
Dim value As PDFRotationMode

value = instance.Rotation
public PDFRotationMode Rotation {get;}
public: __property PDFRotationMode get_Rotation();
public:
property PDFRotationMode Rotation {
   PDFRotationMode get();
}

Property Value

The rotation angle of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


SeparationInfo Property (PDFImportedPageInfo)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : SeparationInfo Property
Gets the separation information associated with the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SeparationInfo As PDFSeparationInfo
'Usage

Dim instance As PDFImportedPageInfo
Dim value As PDFSeparationInfo

value = instance.SeparationInfo
public PDFSeparationInfo SeparationInfo {get;}
public: __property PDFSeparationInfo* get_SeparationInfo();
public:
property PDFSeparationInfo^ SeparationInfo {
   PDFSeparationInfo^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFSeparationInfo object specifying the separation information for the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


TrimBox Property (PDFImportedPageInfo)

O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : TrimBox Property
Gets the dimensions of the page's trim box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TrimBox As PDFRectangle
'Usage

Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.TrimBox
public PDFRectangle TrimBox {get;}
public: __property PDFRectangle* get_TrimBox();
public:
property PDFRectangle^ TrimBox {
   PDFRectangle^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFRectangle object representing the page's trim box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


O2S.Components.PDF4NET.Portfolios Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFPortfolioAttributes | Defines the portfolio attributes for a document attachment.
Class | PDFPortfolioFolder | Defines a folder in a PDF portfolio.
Class | PDFPortfolioFolderCollection | Defines a collection of portfolio folders.
Class | PDFPortfolioInformation | Defines a PDF portfolio, a collection of documents with a specific presentation.
Class | PDFPortfolioSchema | Defines the schema of a PDF portfolio.
Class | PDFPortfolioSchemaField | Defines a field in a portfolio schema.
Class | PDFPortfolioSortInformation | Defines the sort order of the portfolio items in the user interface.
Enumerations
 | Enumeration | Description
Enumeration | PDFPortfolioSchemaFieldType | Specifies the available data types for fields in a portfolio schema.
Enumeration | PDFPortfolioViewMode | Specifies the available view modes for a portfolio.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFPortfolioAttributes Class
Members

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioAttributes Class
Defines the portfolio attributes for a document attachment.
Object Model
PDFPortfolioAttributes ClassPDFObject Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PDFPortfolioAttributes
'Usage

Dim instance As PDFPortfolioAttributes
[DefaultMember("Item")]
public class PDFPortfolioAttributes
[DefaultMember("Item")]
public __gc class PDFPortfolioAttributes
[DefaultMember("Item")]
public ref class PDFPortfolioAttributes
Remarks
The attributes are defined as a dictionary of key/value pairs. Each attribute key must match a field key in the portfolio schema.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Portfolios.PDFPortfolioAttributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioAttributes Members
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PDFPortfolioAttributes Class Members
Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioAttributes Class

The following tables list the members exposed by PDFPortfolioAttributes.

Public Constructors
 | Name | Description
Public Constructor | PDFPortfolioAttributes Constructor | Initializes a new PDFPortfolioAttributes object.
Top
Public Properties
 | Name | Description
Public Property | AttributeKeys | Gets the list of keys of the attributes.
Public Property | Item | Gets or sets an attribute.
Top
See Also

Reference

PDFPortfolioAttributes Class
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%%

PDFPortfolioAttributes Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioAttributes Class : PDFPortfolioAttributes Constructor
Initializes a new PDFPortfolioAttributes object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPortfolioAttributes()
public PDFPortfolioAttributes()
public: PDFPortfolioAttributes();
public:
PDFPortfolioAttributes();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioAttributes Class
PDFPortfolioAttributes Members


%%PageItemTitle%% $$Properties$$

PDFPortfolioAttributes Class Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioAttributes Class

For a list of all members of this type, see PDFPortfolioAttributes members.

Public Properties
 | Name | Description
Public Property | AttributeKeys | Gets the list of keys of the attributes.
Public Property | Item | Gets or sets an attribute.
Top
See Also

Reference

PDFPortfolioAttributes Class
O2S.Components.PDF4NET.Portfolios Namespace


AttributeKeys Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioAttributes Class : AttributeKeys Property
Gets the list of keys of the attributes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AttributeKeys As String()
'Usage

Dim instance As PDFPortfolioAttributes
Dim value() As String

value = instance.AttributeKeys
public string[] AttributeKeys {get;}
public: __property string*[]* get_AttributeKeys();
public:
property array<String^>^ AttributeKeys {
   array<String^>^ get();
}

Property Value

An array with the keys of the attributes associated with a document attachment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioAttributes Class
PDFPortfolioAttributes Members


Item Property (PDFPortfolioAttributes)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioAttributes Class : Item Property
The key used to identify the attribute, must match one of the field keys in the portfolio schema.
Gets or sets an attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal attributeKey As String _
) As PDFObject
'Usage

Dim instance As PDFPortfolioAttributes
Dim attributeKey As String
Dim value As PDFObject

instance.Item(attributeKey) = value

value = instance.Item(attributeKey)
public PDFObject this[
   string attributeKey
]; {get; set;}
public: __property PDFObject* get_Item   string* attributeKey
;
public: __property void set_Item   string* attributeKey,
   PDFObject* value
;
public:
property PDFObject^ default [String^] {
   PDFObject^ get(String^ attributeKey);
   void set (String^ attributeKey, PDFObject^ value);
}

Parameters

attributeKey
The key used to identify the attribute, must match one of the field keys in the portfolio schema.

Property Value

The attribute value if it exists, null otherwise.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the attribute key is null or empty.
System.ArgumentException | Thrown when a setting an attribute with the key being "Type".
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioAttributes Class
PDFPortfolioAttributes Members


%%PageItemTitle%%

PDFPortfolioFolder Class
Members

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioFolder Class
Defines a folder in a PDF portfolio.
Object Model
PDFPortfolioFolder ClassPDFDictionary ClassPDFPortfolioFolderCollection ClassPDFPortfolioFolder ClassPDFImage ClassPDFPortfolioFolder ClassPDFPortfolioAttributes Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPortfolioFolder
'Usage

Dim instance As PDFPortfolioFolder
public class PDFPortfolioFolder
public __gc class PDFPortfolioFolder
public ref class PDFPortfolioFolder
Remarks
A PDF portfolio can have a folder structure that allows an easier navigation into the portfolio's documents.
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Portfolios.PDFPortfolioFolder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Members
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PDFPortfolioFolder Class Members
Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioFolder Class

The following tables list the members exposed by PDFPortfolioFolder.

Public Constructors
 | Name | Description
Public Constructor | PDFPortfolioFolder Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CreationDate | Gets or sets the creation date and time of the folder.
Public Property | Description | Gets or sets the folder description.
Public Property | Dictionary | Gets the folder dictionary.
Public Property | Folders | Gets the collection of child folders.
Public Property | Image | Gets or sets the folder image.
Public Property | ModifyDate | Gets or sets the modify date and time of the folder.
Public Property | Name | Gets or sets the name of this folder.
Public Property | Parent | Gets the parent of this PDFPortfolioFolder object.
Public Property | PortfolioAttributes | Gets or sets the portfolio attributes for this folder.
Top
See Also

Reference

PDFPortfolioFolder Class
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%%

PDFPortfolioFolder Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : PDFPortfolioFolder Constructor
Overload List
Overload | Description
PDFPortfolioFolder Constructor() | Initializes a new PDFPortfolioFolder object.
PDFPortfolioFolder Constructor(String) | Initializes a new PDFPortfolioFolder object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


%%PageItemTitle%%

PDFPortfolioFolder Constructor()

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class > PDFPortfolioFolder Constructor : PDFPortfolioFolder Constructor()
Initializes a new PDFPortfolioFolder object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPortfolioFolder()
public PDFPortfolioFolder()
public: PDFPortfolioFolder();
public:
PDFPortfolioFolder();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members
Overload List


%%PageItemTitle%%

PDFPortfolioFolder Constructor(String)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class > PDFPortfolioFolder Constructor : PDFPortfolioFolder Constructor(String)
The name of the folder.
Initializes a new PDFPortfolioFolder object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFPortfolioFolder(name)
public PDFPortfolioFolder(
   string name
)
public: PDFPortfolioFolder(
   string* name
)
public:
PDFPortfolioFolder(
   String^ name
)

Parameters

name
The name of the folder.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPortfolioFolder Class Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioFolder Class

For a list of all members of this type, see PDFPortfolioFolder members.

Public Properties
 | Name | Description
Public Property | CreationDate | Gets or sets the creation date and time of the folder.
Public Property | Description | Gets or sets the folder description.
Public Property | Dictionary | Gets the folder dictionary.
Public Property | Folders | Gets the collection of child folders.
Public Property | Image | Gets or sets the folder image.
Public Property | ModifyDate | Gets or sets the modify date and time of the folder.
Public Property | Name | Gets or sets the name of this folder.
Public Property | Parent | Gets the parent of this PDFPortfolioFolder object.
Public Property | PortfolioAttributes | Gets or sets the portfolio attributes for this folder.
Top
See Also

Reference

PDFPortfolioFolder Class
O2S.Components.PDF4NET.Portfolios Namespace


CreationDate Property (PDFPortfolioFolder)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : CreationDate Property
Gets or sets the creation date and time of the folder.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PDFPortfolioFolder
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

A DateTime value specifying the date and time when the folder was created.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


Description Property (PDFPortfolioFolder)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : Description Property
Gets or sets the folder description.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As PDFPortfolioFolder
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

A description associated with this folder.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


Dictionary Property (PDFPortfolioFolder)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : Dictionary Property
Gets the folder dictionary.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFPortfolioFolder
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

The raw folder dictionary.
Remarks
This property gives you direct access to folder dictionary and its associated resources. Note: Modifying directly the folder dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


Folders Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : Folders Property
Gets the collection of child folders.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Folders As PDFPortfolioFolderCollection
'Usage

Dim instance As PDFPortfolioFolder
Dim value As PDFPortfolioFolderCollection

value = instance.Folders
public PDFPortfolioFolderCollection Folders {get;}
public: __property PDFPortfolioFolderCollection* get_Folders();
public:
property PDFPortfolioFolderCollection^ Folders {
   PDFPortfolioFolderCollection^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFBookmarkCollection object with the list of child bookmarks.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


Image Property (PDFPortfolioFolder)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : Image Property
Gets or sets the folder image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Image As PDFImage
'Usage

Dim instance As PDFPortfolioFolder
Dim value As PDFImage

instance.Image = value

value = instance.Image
public PDFImage Image {get; set;}
public: __property PDFImage* get_Image();
public: __property void set_Image(
   PDFImage* value
);
public:
property PDFImage^ Image {
   PDFImage^ get();
   void set (    PDFImage^ value);
}

Property Value

An image object defining the thumbnail image for the folder.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


ModifyDate Property (PDFPortfolioFolder)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : ModifyDate Property
Gets or sets the modify date and time of the folder.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModifyDate As Date
'Usage

Dim instance As PDFPortfolioFolder
Dim value As Date

instance.ModifyDate = value

value = instance.ModifyDate
public DateTime ModifyDate {get; set;}
public: __property DateTime get_ModifyDate();
public: __property void set_ModifyDate(
   DateTime value
);
public:
property DateTime ModifyDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

A DateTime value specifying the date and time when the folder was modified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


Name Property (PDFPortfolioFolder)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : Name Property
Gets or sets the name of this folder.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFPortfolioFolder
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The folder name.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property is set to a null or empty string.
Remarks
Two sibling folders shall not share the same name following case normalization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


Parent Property (PDFPortfolioFolder)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : Parent Property
Gets the parent of this PDFPortfolioFolder object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As PDFPortfolioFolder
'Usage

Dim instance As PDFPortfolioFolder
Dim value As PDFPortfolioFolder

value = instance.Parent
public PDFPortfolioFolder Parent {get;}
public: __property PDFPortfolioFolder* get_Parent();
public:
property PDFPortfolioFolder^ Parent {
   PDFPortfolioFolder^ get();
}

Property Value

The parent folder.
Remarks
If the parent folder is null, the folder is the top level folder.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


PortfolioAttributes Property (PDFPortfolioFolder)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioFolder Class : PortfolioAttributes Property
Gets or sets the portfolio attributes for this folder.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PortfolioAttributes As PDFPortfolioAttributes
'Usage

Dim instance As PDFPortfolioFolder
Dim value As PDFPortfolioAttributes

instance.PortfolioAttributes = value

value = instance.PortfolioAttributes
public PDFPortfolioAttributes PortfolioAttributes {get; set;}
public: __property PDFPortfolioAttributes* get_PortfolioAttributes();
public: __property void set_PortfolioAttributes(
   PDFPortfolioAttributes* value
);
public:
property PDFPortfolioAttributes^ PortfolioAttributes {
   PDFPortfolioAttributes^ get();
   void set (    PDFPortfolioAttributes^ value);
}

Property Value

A collection of attributes associated with this folder.
Remarks
These attributes are displayed in the user interface of the PDF viewer application.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolder Class
PDFPortfolioFolder Members


%%PageItemTitle%%

PDFPortfolioFolderCollection Class
Members

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioFolderCollection Class
Defines a collection of portfolio folders.
Object Model
PDFPortfolioFolderCollection ClassPDFPortfolioFolder Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPortfolioFolderCollection
   Inherits O2S.Components.PDF4NET.PDFCollection(Of PDFPortfolioFolder,PDFPortfolioFolder)
'Usage

Dim instance As PDFPortfolioFolderCollection
public class PDFPortfolioFolderCollection : O2S.Components.PDF4NET.PDFCollection<PDFPortfolioFolder,PDFPortfolioFolder>
public __gc class PDFPortfolioFolderCollection : public O2S.Components.PDF4NET.PDFCollection<PDFPortfolioFolder,PDFPortfolioFolder>
public ref class PDFPortfolioFolderCollection : public O2S.Components.PDF4NET.PDFCollection<PDFPortfolioFolder,PDFPortfolioFolder>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Portfolios.PDFPortfolioFolderCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioFolderCollection Members
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PDFPortfolioFolderCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioFolderCollection Class

The following tables list the members exposed by PDFPortfolioFolderCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Top
See Also

Reference

PDFPortfolioFolderCollection Class
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%%

PDFPortfolioInformation Class
Members

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioInformation Class
Defines a PDF portfolio, a collection of documents with a specific presentation.
Object Model
PDFPortfolioInformation ClassPDFDictionary ClassPDFPortfolioFolder ClassPDFPortfolioSchema ClassPDFPortfolioSortInformation ClassPDFDocumentAttachment Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPortfolioInformation
'Usage

Dim instance As PDFPortfolioInformation
public class PDFPortfolioInformation
public __gc class PDFPortfolioInformation
public ref class PDFPortfolioInformation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Portfolios.PDFPortfolioInformation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioInformation Members
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PDFPortfolioInformation Class Members
Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioInformation Class

The following tables list the members exposed by PDFPortfolioInformation.

Public Constructors
 | Name | Description
Public Constructor | PDFPortfolioInformation Constructor | Initializes a new PDFPortfolioInformation object.
Top
Public Properties
 | Name | Description
Public Property | Dictionary | Gets the dictionary that represents this portfolio.
Public Property | Folder | Gets or sets the root folder for this portfolio.
Public Property | Schema | Gets or sets the schema information for this portfolio.
Public Property | SortInformation | Gets or sets the sort information for this portfolio.
Public Property | StartupDocument | Gets or sets the document that is first displayed when the portfolio is opened by the PDF viewer application.
Public Property | ViewMode | Gets or sets the view mode for this portfolio.
Top
See Also

Reference

PDFPortfolioInformation Class
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%%

PDFPortfolioInformation Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioInformation Class : PDFPortfolioInformation Constructor
Initializes a new PDFPortfolioInformation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPortfolioInformation()
public PDFPortfolioInformation()
public: PDFPortfolioInformation();
public:
PDFPortfolioInformation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioInformation Class
PDFPortfolioInformation Members


%%PageItemTitle%% $$Properties$$

PDFPortfolioInformation Class Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioInformation Class

For a list of all members of this type, see PDFPortfolioInformation members.

Public Properties
 | Name | Description
Public Property | Dictionary | Gets the dictionary that represents this portfolio.
Public Property | Folder | Gets or sets the root folder for this portfolio.
Public Property | Schema | Gets or sets the schema information for this portfolio.
Public Property | SortInformation | Gets or sets the sort information for this portfolio.
Public Property | StartupDocument | Gets or sets the document that is first displayed when the portfolio is opened by the PDF viewer application.
Public Property | ViewMode | Gets or sets the view mode for this portfolio.
Top
See Also

Reference

PDFPortfolioInformation Class
O2S.Components.PDF4NET.Portfolios Namespace


Dictionary Property (PDFPortfolioInformation)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioInformation Class : Dictionary Property
Gets the dictionary that represents this portfolio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dictionary As PDFDictionary
'Usage

Dim instance As PDFPortfolioInformation
Dim value As PDFDictionary

value = instance.Dictionary
public PDFDictionary Dictionary {get;}
public: __property PDFDictionary* get_Dictionary();
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Property Value

A PDF dictionary object representing the portfolio.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioInformation Class
PDFPortfolioInformation Members


Folder Property (PDFPortfolioInformation)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioInformation Class : Folder Property
Gets or sets the root folder for this portfolio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Folder As PDFPortfolioFolder
'Usage

Dim instance As PDFPortfolioInformation
Dim value As PDFPortfolioFolder

instance.Folder = value

value = instance.Folder
public PDFPortfolioFolder Folder {get; set;}
public: __property PDFPortfolioFolder* get_Folder();
public: __property void set_Folder(
   PDFPortfolioFolder* value
);
public:
property PDFPortfolioFolder^ Folder {
   PDFPortfolioFolder^ get();
   void set (    PDFPortfolioFolder^ value);
}

Property Value

Root folder for this portfolio.
Remarks
Folders are used to group document attachments into logical groups.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioInformation Class
PDFPortfolioInformation Members


Schema Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioInformation Class : Schema Property
Gets or sets the schema information for this portfolio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Schema As PDFPortfolioSchema
'Usage

Dim instance As PDFPortfolioInformation
Dim value As PDFPortfolioSchema

instance.Schema = value

value = instance.Schema
public PDFPortfolioSchema Schema {get; set;}
public: __property PDFPortfolioSchema* get_Schema();
public: __property void set_Schema(
   PDFPortfolioSchema* value
);
public:
property PDFPortfolioSchema^ Schema {
   PDFPortfolioSchema^ get();
   void set (    PDFPortfolioSchema^ value);
}

Property Value

Schema for this portfolio, used to define metadata information for items in the portfolio.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioInformation Class
PDFPortfolioInformation Members


SortInformation Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioInformation Class : SortInformation Property
Gets or sets the sort information for this portfolio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SortInformation As PDFPortfolioSortInformation
'Usage

Dim instance As PDFPortfolioInformation
Dim value As PDFPortfolioSortInformation

instance.SortInformation = value

value = instance.SortInformation
public PDFPortfolioSortInformation SortInformation {get; set;}
public: __property PDFPortfolioSortInformation* get_SortInformation();
public: __property void set_SortInformation(
   PDFPortfolioSortInformation* value
);
public:
property PDFPortfolioSortInformation^ SortInformation {
   PDFPortfolioSortInformation^ get();
   void set (    PDFPortfolioSortInformation^ value);
}

Property Value

Sort information for the items in the portfolio, used for displaying the portfolio items in the user interface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioInformation Class
PDFPortfolioInformation Members


StartupDocument Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioInformation Class : StartupDocument Property
Gets or sets the document that is first displayed when the portfolio is opened by the PDF viewer application.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StartupDocument As PDFDocumentAttachment
'Usage

Dim instance As PDFPortfolioInformation
Dim value As PDFDocumentAttachment

instance.StartupDocument = value

value = instance.StartupDocument
public PDFDocumentAttachment StartupDocument {get; set;}
public: __property PDFDocumentAttachment* get_StartupDocument();
public: __property void set_StartupDocument(
   PDFDocumentAttachment* value
);
public:
property PDFDocumentAttachment^ StartupDocument {
   PDFDocumentAttachment^ get();
   void set (    PDFDocumentAttachment^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioInformation Class
PDFPortfolioInformation Members


ViewMode Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioInformation Class : ViewMode Property
Gets or sets the view mode for this portfolio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ViewMode As PDFPortfolioViewMode
'Usage

Dim instance As PDFPortfolioInformation
Dim value As PDFPortfolioViewMode

instance.ViewMode = value

value = instance.ViewMode
public PDFPortfolioViewMode ViewMode {get; set;}
public: __property PDFPortfolioViewMode get_ViewMode();
public: __property void set_ViewMode(
   PDFPortfolioViewMode value
);
public:
property PDFPortfolioViewMode ViewMode {
   PDFPortfolioViewMode get();
   void set (    PDFPortfolioViewMode value);
}

Property Value

The display mode of this portfolio.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioInformation Class
PDFPortfolioInformation Members


%%PageItemTitle%%

PDFPortfolioSchema Class
Members

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSchema Class
Defines the schema of a PDF portfolio.
Object Model
PDFPortfolioSchema ClassPDFPortfolioSchemaField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PDFPortfolioSchema
'Usage

Dim instance As PDFPortfolioSchema
[DefaultMember("Item")]
public class PDFPortfolioSchema
[DefaultMember("Item")]
public __gc class PDFPortfolioSchema
[DefaultMember("Item")]
public ref class PDFPortfolioSchema
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Portfolios.PDFPortfolioSchema

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchema Members
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PDFPortfolioSchema Class Members
Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSchema Class

The following tables list the members exposed by PDFPortfolioSchema.

Public Constructors
 | Name | Description
Public Constructor | PDFPortfolioSchema Constructor | Initializes a new PDFPortfolioSchema object.
Top
Public Properties
 | Name | Description
Public Property | FieldKeys | Gets the list of keys of the fields in this schema.
Public Property | Item | Gets or sets a field in the schema.
Top
See Also

Reference

PDFPortfolioSchema Class
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%%

PDFPortfolioSchema Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchema Class : PDFPortfolioSchema Constructor
Initializes a new PDFPortfolioSchema object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPortfolioSchema()
public PDFPortfolioSchema()
public: PDFPortfolioSchema();
public:
PDFPortfolioSchema();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchema Class
PDFPortfolioSchema Members


%%PageItemTitle%% $$Properties$$

PDFPortfolioSchema Class Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSchema Class

For a list of all members of this type, see PDFPortfolioSchema members.

Public Properties
 | Name | Description
Public Property | FieldKeys | Gets the list of keys of the fields in this schema.
Public Property | Item | Gets or sets a field in the schema.
Top
See Also

Reference

PDFPortfolioSchema Class
O2S.Components.PDF4NET.Portfolios Namespace


FieldKeys Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchema Class : FieldKeys Property
Gets the list of keys of the fields in this schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FieldKeys As String()
'Usage

Dim instance As PDFPortfolioSchema
Dim value() As String

value = instance.FieldKeys
public string[] FieldKeys {get;}
public: __property string*[]* get_FieldKeys();
public:
property array<String^>^ FieldKeys {
   array<String^>^ get();
}

Property Value

An array with the keys of the fields in the schema.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchema Class
PDFPortfolioSchema Members


Item Property (PDFPortfolioSchema)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchema Class : Item Property
The key used to identify the field in the schema.
Gets or sets a field in the schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal fieldKey As String _
) As PDFPortfolioSchemaField
'Usage

Dim instance As PDFPortfolioSchema
Dim fieldKey As String
Dim value As PDFPortfolioSchemaField

instance.Item(fieldKey) = value

value = instance.Item(fieldKey)
public PDFPortfolioSchemaField this[
   string fieldKey
]; {get; set;}
public: __property PDFPortfolioSchemaField* get_Item   string* fieldKey
;
public: __property void set_Item   string* fieldKey,
   PDFPortfolioSchemaField* value
;
public:
property PDFPortfolioSchemaField^ default [String^] {
   PDFPortfolioSchemaField^ get(String^ fieldKey);
   void set (String^ fieldKey, PDFPortfolioSchemaField^ value);
}

Parameters

fieldKey
The key used to identify the field in the schema.

Property Value

The field if it exists in the schema, null otherwise.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the field key is null or empty.
System.ArgumentException | Thrown when a setting a field with the key being "Type".
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchema Class
PDFPortfolioSchema Members


%%PageItemTitle%%

PDFPortfolioSchemaField Class
Members

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSchemaField Class
Defines a field in a portfolio schema.
Object Model
PDFPortfolioSchemaField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPortfolioSchemaField
'Usage

Dim instance As PDFPortfolioSchemaField
public class PDFPortfolioSchemaField
public __gc class PDFPortfolioSchemaField
public ref class PDFPortfolioSchemaField
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Portfolios.PDFPortfolioSchemaField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchemaField Members
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PDFPortfolioSchemaField Class Members
Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSchemaField Class

The following tables list the members exposed by PDFPortfolioSchemaField.

Public Constructors
 | Name | Description
Public Constructor | PDFPortfolioSchemaField Constructor | Initializes a new PDFPortfolioSchemaField object.
Top
Public Properties
 | Name | Description
Public Property | Editable | Gets or sets a value indicating whether the PDF viewer application should provide support for editing the field value..
Public Property | Name | Gets or sets the field name.
Public Property | Order | Gets or sets the field order.
Public Property | Type | Gets or sets the field type.
Public Property | Visible | Gets or sets the field visibility.
Top
See Also

Reference

PDFPortfolioSchemaField Class
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%%

PDFPortfolioSchemaField Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchemaField Class : PDFPortfolioSchemaField Constructor
Initializes a new PDFPortfolioSchemaField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPortfolioSchemaField()
public PDFPortfolioSchemaField()
public: PDFPortfolioSchemaField();
public:
PDFPortfolioSchemaField();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchemaField Class
PDFPortfolioSchemaField Members


%%PageItemTitle%% $$Properties$$

PDFPortfolioSchemaField Class Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSchemaField Class

For a list of all members of this type, see PDFPortfolioSchemaField members.

Public Properties
 | Name | Description
Public Property | Editable | Gets or sets a value indicating whether the PDF viewer application should provide support for editing the field value..
Public Property | Name | Gets or sets the field name.
Public Property | Order | Gets or sets the field order.
Public Property | Type | Gets or sets the field type.
Public Property | Visible | Gets or sets the field visibility.
Top
See Also

Reference

PDFPortfolioSchemaField Class
O2S.Components.PDF4NET.Portfolios Namespace


Editable Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchemaField Class : Editable Property
Gets or sets a value indicating whether the PDF viewer application should provide support for editing the field value..
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Editable As Boolean
'Usage

Dim instance As PDFPortfolioSchemaField
Dim value As Boolean

instance.Editable = value

value = instance.Editable
public bool Editable {get; set;}
public: __property bool get_Editable();
public: __property void set_Editable(
   bool value
);
public:
property bool Editable {
   bool get();
   void set (    bool value);
}

Property Value

True if the viewer application should provide support for editing the field value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchemaField Class
PDFPortfolioSchemaField Members


Name Property (PDFPortfolioSchemaField)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchemaField Class : Name Property
Gets or sets the field name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFPortfolioSchemaField
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The display name of the field
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property is set to null or an empty string.
Remarks
This name is used by the PDF viewer application to display the field in the user interface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchemaField Class
PDFPortfolioSchemaField Members


Order Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchemaField Class : Order Property
Gets or sets the field order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Order As Integer
'Usage

Dim instance As PDFPortfolioSchemaField
Dim value As Integer

instance.Order = value

value = instance.Order
public int Order {get; set;}
public: __property int get_Order();
public: __property void set_Order(
   int value
);
public:
property int Order {
   int get();
   void set (    int value);
}

Property Value

The relative order of the field name in the user interface.
Remarks
Fields are sorted by the PDF viewer application in ascending order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchemaField Class
PDFPortfolioSchemaField Members


Type Property (PDFPortfolioSchemaField)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchemaField Class : Type Property
Gets or sets the field type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As PDFPortfolioSchemaFieldType
'Usage

Dim instance As PDFPortfolioSchemaField
Dim value As PDFPortfolioSchemaFieldType

instance.Type = value

value = instance.Type
public PDFPortfolioSchemaFieldType Type {get; set;}
public: __property PDFPortfolioSchemaFieldType get_Type();
public: __property void set_Type(
   PDFPortfolioSchemaFieldType value
);
public:
property PDFPortfolioSchemaFieldType Type {
   PDFPortfolioSchemaFieldType get();
   void set (    PDFPortfolioSchemaFieldType value);
}

Property Value

The type of this field.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is set to PDFPortfolioSchemaFieldType.NoType or PDFPortfolioSchemaFieldType.Unknown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchemaField Class
PDFPortfolioSchemaField Members


Visible Property (PDFPortfolioSchemaField)

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchemaField Class : Visible Property
Gets or sets the field visibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As PDFPortfolioSchemaField
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

The initial visibility of the field in the user interface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchemaField Class
PDFPortfolioSchemaField Members


%%PageItemTitle%%

PDFPortfolioSortInformation Class
Members

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSortInformation Class
Defines the sort order of the portfolio items in the user interface.
Object Model
PDFPortfolioSortInformation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPortfolioSortInformation
'Usage

Dim instance As PDFPortfolioSortInformation
public class PDFPortfolioSortInformation
public __gc class PDFPortfolioSortInformation
public ref class PDFPortfolioSortInformation
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Portfolios.PDFPortfolioSortInformation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSortInformation Members
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PDFPortfolioSortInformation Class Members
Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSortInformation Class

The following tables list the members exposed by PDFPortfolioSortInformation.

Public Constructors
 | Name | Description
Public Constructor | PDFPortfolioSortInformation Constructor | Initializes a new PDFPortfolioSortInformation object.
Top
Public Properties
 | Name | Description
Public Property | Ascending | Gets or sets a value indicating the sort order.
Public Property | SortFields | Gets or sets the list of fields used for sort order.
Top
See Also

Reference

PDFPortfolioSortInformation Class
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%%

PDFPortfolioSortInformation Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSortInformation Class : PDFPortfolioSortInformation Constructor
Initializes a new PDFPortfolioSortInformation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPortfolioSortInformation()
public PDFPortfolioSortInformation()
public: PDFPortfolioSortInformation();
public:
PDFPortfolioSortInformation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSortInformation Class
PDFPortfolioSortInformation Members


%%PageItemTitle%% $$Properties$$

PDFPortfolioSortInformation Class Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSortInformation Class

For a list of all members of this type, see PDFPortfolioSortInformation members.

Public Properties
 | Name | Description
Public Property | Ascending | Gets or sets a value indicating the sort order.
Public Property | SortFields | Gets or sets the list of fields used for sort order.
Top
See Also

Reference

PDFPortfolioSortInformation Class
O2S.Components.PDF4NET.Portfolios Namespace


Ascending Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSortInformation Class : Ascending Property
Gets or sets a value indicating the sort order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ascending As Boolean()
'Usage

Dim instance As PDFPortfolioSortInformation
Dim value() As Boolean

instance.Ascending = value

value = instance.Ascending
public bool[] Ascending {get; set;}
public: __property bool[]* get_Ascending();
public: __property void set_Ascending(
   bool[]* value
);
public:
property array<bool>^ Ascending {
   array<bool>^ get();
   void set (    array<bool>^ value);
}

Property Value

True if the items are sorted ascending, false otherwise.
Remarks
This property specifies the sort order for each field defined in the SortFields property. The number of elements in this array must match the number of elements in the SortFields array otherwise the results are unknown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSortInformation Class
PDFPortfolioSortInformation Members


SortFields Property

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSortInformation Class : SortFields Property
Gets or sets the list of fields used for sort order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SortFields As String()
'Usage

Dim instance As PDFPortfolioSortInformation
Dim value() As String

instance.SortFields = value

value = instance.SortFields
public string[] SortFields {get; set;}
public: __property string*[]* get_SortFields();
public: __property void set_SortFields(
   string*[]* value
);
public:
property array<String^>^ SortFields {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

An array of names specifying the fields used for sorting the portfolio items in the user interface.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the value is a null or empty array.
Remarks
Each name in the array must be defined in the portfolio schema.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSortInformation Class
PDFPortfolioSortInformation Members


%%PageItemTitle%%

PDFPortfolioSchemaFieldType Enumeration

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioSchemaFieldType Enumeration
Specifies the available data types for fields in a portfolio schema.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPortfolioSchemaFieldType
   Inherits System.Enum
'Usage

Dim instance As PDFPortfolioSchemaFieldType
public enum PDFPortfolioSchemaFieldType : System.Enum
__value public enum PDFPortfolioSchemaFieldType : public System.Enum
public enum class PDFPortfolioSchemaFieldType : public System.Enum
Members
Member | Description
CreationDate | The field data is the creation date of the file in the document attachment.
Date | Date field.
Description | The field data is the description of the document attachment.
FileName | The field data is the file name of the document attachment.
ModDate | The field data is the modification date of the file in the document attachment.
NoType | The field has no data type associated with it.
Number | Number field
Size | The field data is the size of the file in the document attachment.
String | Text field.
Unknown | Unknown data type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Portfolios.PDFPortfolioSchemaFieldType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%%

PDFPortfolioViewMode Enumeration

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioViewMode Enumeration
Specifies the available view modes for a portfolio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPortfolioViewMode
   Inherits System.Enum
'Usage

Dim instance As PDFPortfolioViewMode
public enum PDFPortfolioViewMode : System.Enum
__value public enum PDFPortfolioViewMode : public System.Enum
public enum class PDFPortfolioViewMode : public System.Enum
Members
Member | Description
Details | The portfolio is displayed in details mode, all the information is displayed in a column format.
Hidden | The portfolio information is initially hidden, without preventing the user from obtaining a file list via explicit action.
Tile | The portfolio is displayed in tile mode, with each file in the collection denoted by a small icon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Portfolios.PDFPortfolioViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Portfolios Namespace


O2S.Components.PDF4NET.Security Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFDigitalSignature | Defines a digital signature used for signing a PDF file.
Class | PDFSecurityManager | Manages the security settings for a pdf document.
Enumerations
 | Enumeration | Description
Enumeration | EncryptionAlgorithm | Specifies the available encryption algorithms.
Enumeration | EncryptionKeySize | Specifies the available key sizes when encrypting a pdf document. Supported by Compact .NET Edition.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFDigitalSignature Class
Members

O2S.Components.PDF4NET.Security Namespace : PDFDigitalSignature Class
Defines a digital signature used for signing a PDF file.
Object Model
PDFDigitalSignature Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDigitalSignature
   Inherits O2S.Components.PDF4NET.Cos.PDFObject
'Usage

Dim instance As PDFDigitalSignature
public class PDFDigitalSignature : O2S.Components.PDF4NET.Cos.PDFObject
public __gc class PDFDigitalSignature : public O2S.Components.PDF4NET.Cos.PDFObject
public ref class PDFDigitalSignature : public O2S.Components.PDF4NET.Cos.PDFObject
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Security.PDFDigitalSignature

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Members
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%% $$Members$$

PDFDigitalSignature Class Members
Properties

O2S.Components.PDF4NET.Security Namespace : PDFDigitalSignature Class

The following tables list the members exposed by PDFDigitalSignature.

Public Constructors
 | Name | Description
Public Constructor | PDFDigitalSignature Constructor | Initializes a new PDFDigitalSignature object.
Top
Public Properties
 | Name | Description
Public Property | Certificate | Gets or sets the certificate for signing the PDF document.
Public Property | ContactInfo | Gets or sets the signer's contact information.
Public Property | Location | Gets or sets the location of the signer.
Public Property | Name | Gets or sets the name of the signer.
Public Property | Reason | Gets or sets the reason for signing the document.
Top
See Also

Reference

PDFDigitalSignature Class
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%%

PDFDigitalSignature Constructor

O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : PDFDigitalSignature Constructor
Initializes a new PDFDigitalSignature object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDigitalSignature()
public PDFDigitalSignature()
public: PDFDigitalSignature();
public:
PDFDigitalSignature();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%% $$Properties$$

PDFDigitalSignature Class Properties

O2S.Components.PDF4NET.Security Namespace : PDFDigitalSignature Class

For a list of all members of this type, see PDFDigitalSignature members.

Public Properties
 | Name | Description
Public Property | Certificate | Gets or sets the certificate for signing the PDF document.
Public Property | ContactInfo | Gets or sets the signer's contact information.
Public Property | Location | Gets or sets the location of the signer.
Public Property | Name | Gets or sets the name of the signer.
Public Property | Reason | Gets or sets the reason for signing the document.
Top
See Also

Reference

PDFDigitalSignature Class
O2S.Components.PDF4NET.Security Namespace


Certificate Property

O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Certificate Property
Gets or sets the certificate for signing the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Certificate As X509Certificate2
'Usage

Dim instance As PDFDigitalSignature
Dim value As X509Certificate2

instance.Certificate = value

value = instance.Certificate
public X509Certificate2 Certificate {get; set;}
public: __property X509Certificate2* get_Certificate();
public: __property void set_Certificate(
   X509Certificate2* value
);
public:
property X509Certificate2^ Certificate {
   X509Certificate2^ get();
   void set (    X509Certificate2^ value);
}

Property Value

A System.Security.Cryptography.X509Certificates.X509Certificate2 object specifying the certificate for signing.
Remarks
This property also sets the Name property to the name in the certificate.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


ContactInfo Property

O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : ContactInfo Property
Gets or sets the signer's contact information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContactInfo As String
'Usage

Dim instance As PDFDigitalSignature
Dim value As String

instance.ContactInfo = value

value = instance.ContactInfo
public string ContactInfo {get; set;}
public: __property string* get_ContactInfo();
public: __property void set_ContactInfo(
   string* value
);
public:
property String^ ContactInfo {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the signer's contact information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


Location Property (PDFDigitalSignature)

O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Location Property
Gets or sets the location of the signer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Location As String
'Usage

Dim instance As PDFDigitalSignature
Dim value As String

instance.Location = value

value = instance.Location
public string Location {get; set;}
public: __property string* get_Location();
public: __property void set_Location(
   string* value
);
public:
property String^ Location {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the location of the signer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


Name Property (PDFDigitalSignature)

O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Name Property
Gets or sets the name of the signer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFDigitalSignature
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the name of the signer.
Remarks
The Certificate property overwrites the value of this property with the name stored in the certificate. If you want to set the Name to another value, set this property after the Certificate property has been set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


Reason Property

O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Reason Property
Gets or sets the reason for signing the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Reason As String
'Usage

Dim instance As PDFDigitalSignature
Dim value As String

instance.Reason = value

value = instance.Reason
public string Reason {get; set;}
public: __property string* get_Reason();
public: __property void set_Reason(
   string* value
);
public:
property String^ Reason {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the reason for signing the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%%

PDFSecurityManager Class
Members

O2S.Components.PDF4NET.Security Namespace : PDFSecurityManager Class
Manages the security settings for a pdf document.
Object Model
PDFSecurityManager Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSecurityManager
'Usage

Dim instance As PDFSecurityManager
public class PDFSecurityManager
public __gc class PDFSecurityManager
public ref class PDFSecurityManager
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Security.PDFSecurityManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Members
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%% $$Members$$

PDFSecurityManager Class Members
Properties

O2S.Components.PDF4NET.Security Namespace : PDFSecurityManager Class

The following tables list the members exposed by PDFSecurityManager.

Public Constructors
 | Name | Description
Public Constructor | PDFSecurityManager Constructor | Initializes a new PDFSecurityManager object.
Top
Public Properties
 | Name | Description
Public Property | AllowAccessibilityExtractContent | Gets or sets whether the user is allowed to extract the content of the document in support of accessibility. Supported by Compact .NET Edition.
Public Property | AllowAssembleDocument | Gets or sets whether the user is allowed to assemble the pdf document. Supported by Compact .NET Edition.
Public Property | AllowExtractContent | Gets or sets whether the user is allowed to extract the content of the document. Supported by Compact .NET Edition.
Public Property | AllowFormsFill | Gets or sets whether the user is allowed to fill the form fields in the pdf document. Supported by Compact .NET Edition.
Public Property | AllowInteractiveEdit | Gets or sets whether the user is allowed to perform interactive edit operations on the document. Supported by Compact .NET Edition.
Public Property | AllowModifyDocument | Gets or sets whether the user is allowed to modify the document. Supported by Compact .NET Edition.
Public Property | AllowPrint | Gets or sets whether the user is allowed to print the document. Supported by Compact .NET Edition.
Public Property | EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the PDF file.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether document level metadata should be encrypted.
Public Property | FullQualityPrint | Gets or sets the quality of the document printing. Supported by Compact .NET Edition.
Public Property | KeySize | Gets or sets the length of the encryption key.
Public Property | OwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to.
Public Property | UnicodeOwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to.
Public Property | UnicodeUserPassword | Gets or sets the user password for the pdf document this security manager object is attached to.
Public Property | UserPassword | Gets or sets the user password for the pdf document this security manager object is attached to.
Top
See Also

Reference

PDFSecurityManager Class
O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%%

PDFSecurityManager Constructor

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : PDFSecurityManager Constructor
Initializes a new PDFSecurityManager object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSecurityManager()
public PDFSecurityManager()
public: PDFSecurityManager();
public:
PDFSecurityManager();
Remarks
When a PDFSecurityManager object is created, all the public properties are set to true, the user and owner passwords are null, and the encryption strength is set to 128 bit.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%% $$Properties$$

PDFSecurityManager Class Properties

O2S.Components.PDF4NET.Security Namespace : PDFSecurityManager Class

For a list of all members of this type, see PDFSecurityManager members.

Public Properties
 | Name | Description
Public Property | AllowAccessibilityExtractContent | Gets or sets whether the user is allowed to extract the content of the document in support of accessibility. Supported by Compact .NET Edition.
Public Property | AllowAssembleDocument | Gets or sets whether the user is allowed to assemble the pdf document. Supported by Compact .NET Edition.
Public Property | AllowExtractContent | Gets or sets whether the user is allowed to extract the content of the document. Supported by Compact .NET Edition.
Public Property | AllowFormsFill | Gets or sets whether the user is allowed to fill the form fields in the pdf document. Supported by Compact .NET Edition.
Public Property | AllowInteractiveEdit | Gets or sets whether the user is allowed to perform interactive edit operations on the document. Supported by Compact .NET Edition.
Public Property | AllowModifyDocument | Gets or sets whether the user is allowed to modify the document. Supported by Compact .NET Edition.
Public Property | AllowPrint | Gets or sets whether the user is allowed to print the document. Supported by Compact .NET Edition.
Public Property | EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the PDF file.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether document level metadata should be encrypted.
Public Property | FullQualityPrint | Gets or sets the quality of the document printing. Supported by Compact .NET Edition.
Public Property | KeySize | Gets or sets the length of the encryption key.
Public Property | OwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to.
Public Property | UnicodeOwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to.
Public Property | UnicodeUserPassword | Gets or sets the user password for the pdf document this security manager object is attached to.
Public Property | UserPassword | Gets or sets the user password for the pdf document this security manager object is attached to.
Top
See Also

Reference

PDFSecurityManager Class
O2S.Components.PDF4NET.Security Namespace


AllowAccessibilityExtractContent Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowAccessibilityExtractContent Property
Gets or sets whether the user is allowed to extract the content of the document in support of accessibility.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowAccessibilityExtractContent As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowAccessibilityExtractContent = value

value = instance.AllowAccessibilityExtractContent
public bool AllowAccessibilityExtractContent {get; set;}
public: __property bool get_AllowAccessibilityExtractContent();
public: __property void set_AllowAccessibilityExtractContent(
   bool value
);
public:
property bool AllowAccessibilityExtractContent {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to extract the content of the document in support of accessibility.
Remarks
This property has effect only when using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to copy or otherwise extract text and graphics from the document in support of accessibility to disabled users or for other purposes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowAssembleDocument Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowAssembleDocument Property
Gets or sets whether the user is allowed to assemble the pdf document.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowAssembleDocument As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowAssembleDocument = value

value = instance.AllowAssembleDocument
public bool AllowAssembleDocument {get; set;}
public: __property bool get_AllowAssembleDocument();
public: __property void set_AllowAssembleDocument(
   bool value
);
public:
property bool AllowAssembleDocument {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to assemble the pdf document or not.
Remarks
This property has effect only when using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to assemble the document (insert, rotate, or delete pages and create bookmarks or thumbnail images), event property AllowModifyDocument is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowExtractContent Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowExtractContent Property
Gets or sets whether the user is allowed to extract the content of the document.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowExtractContent As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowExtractContent = value

value = instance.AllowExtractContent
public bool AllowExtractContent {get; set;}
public: __property bool get_AllowExtractContent();
public: __property void set_AllowExtractContent(
   bool value
);
public:
property bool AllowExtractContent {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to extract the content of the document.
Remarks
When using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey), this property, if true, allows a user to copy or otherwise extract text and graphics from the document by operations other than those controlled by property AllowAccessibilityExtractContent. When using 40 bit encryption (KeySize property is set to EncryptionKeySize.Use40BitKey), then this property also controls extraction of text and graphics in support of accessibility to disabled users or other purposes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowFormsFill Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowFormsFill Property
Gets or sets whether the user is allowed to fill the form fields in the pdf document.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowFormsFill As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowFormsFill = value

value = instance.AllowFormsFill
public bool AllowFormsFill {get; set;}
public: __property bool get_AllowFormsFill();
public: __property void set_AllowFormsFill(
   bool value
);
public:
property bool AllowFormsFill {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to fill the form fields in the pdf document.
Remarks
This property has effect only when using 128 bit encryption. (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to fill in existing interactive form fields (including signature fields), event property AllowInteractiveEdit is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowInteractiveEdit Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowInteractiveEdit Property
Gets or sets whether the user is allowed to perform interactive edit operations on the document.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowInteractiveEdit As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowInteractiveEdit = value

value = instance.AllowInteractiveEdit
public bool AllowInteractiveEdit {get; set;}
public: __property bool get_AllowInteractiveEdit();
public: __property void set_AllowInteractiveEdit(
   bool value
);
public:
property bool AllowInteractiveEdit {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to perform interactive edit operations on the document.
Remarks
This property, if true, allows a user to add or modify text annotations, fill in interactive forms fields, and, if property AllowModifyDocument is true, create or modify interactive form fields (including signature fields).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowModifyDocument Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowModifyDocument Property
Gets or sets whether the user is allowed to modify the document.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowModifyDocument As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowModifyDocument = value

value = instance.AllowModifyDocument
public bool AllowModifyDocument {get; set;}
public: __property bool get_AllowModifyDocument();
public: __property void set_AllowModifyDocument(
   bool value
);
public:
property bool AllowModifyDocument {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to modify the document or not.
Remarks
This property, if true, allows a user to modify the content of pdf document by operations other than those controlled by the following properties: AllowInteractiveEdit, AllowFormsFill, AllowAssembleDocument.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowPrint Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowPrint Property
Gets or sets whether the user is allowed to print the document.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowPrint As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowPrint = value

value = instance.AllowPrint
public bool AllowPrint {get; set;}
public: __property bool get_AllowPrint();
public: __property void set_AllowPrint(
   bool value
);
public:
property bool AllowPrint {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed or not to print the document.
Remarks
This property, together with FullQualityPrint and KeySize properties, controls the printing of the document. If this property is false, then the user is not allowed to print the document. If this property is true, then the user is allowed to print the document, depending on the value of FullQualityPrint and KeySize properties. If KeySize is EncryptionKeySize.Use40BitKey then FullQualityPrint property is ignored. If KeySize is EncryptionKeySize.Use128BitKey then if FullQualityPrint is true, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


EncryptionAlgorithm Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : EncryptionAlgorithm Property
Gets or sets the encryption algorithm used to encrypt the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EncryptionAlgorithm As EncryptionAlgorithm
'Usage

Dim instance As PDFSecurityManager
Dim value As EncryptionAlgorithm

instance.EncryptionAlgorithm = value

value = instance.EncryptionAlgorithm
public EncryptionAlgorithm EncryptionAlgorithm {get; set;}
public: __property EncryptionAlgorithm get_EncryptionAlgorithm();
public: __property void set_EncryptionAlgorithm(
   EncryptionAlgorithm value
);
public:
property EncryptionAlgorithm EncryptionAlgorithm {
   EncryptionAlgorithm get();
   void set (    EncryptionAlgorithm value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


EncryptMetadata Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : EncryptMetadata Property
Gets or sets a value indicatig whether document level metadata should be encrypted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EncryptMetadata As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.EncryptMetadata = value

value = instance.EncryptMetadata
public bool EncryptMetadata {get; set;}
public: __property bool get_EncryptMetadata();
public: __property void set_EncryptMetadata(
   bool value
);
public:
property bool EncryptMetadata {
   bool get();
   void set (    bool value);
}

Property Value

True if the document metadata is encrypted (default), false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


FullQualityPrint Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : FullQualityPrint Property
Gets or sets the quality of the document printing.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FullQualityPrint As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.FullQualityPrint = value

value = instance.FullQualityPrint
public bool FullQualityPrint {get; set;}
public: __property bool get_FullQualityPrint();
public: __property void set_FullQualityPrint(
   bool value
);
public:
property bool FullQualityPrint {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the document is printed in full quality or not.
Remarks
This property has effect only when AllowPrint property is true and KeySize property is set to EncryptionKeySize.Use128BitKey. If this property is true, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


KeySize Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : KeySize Property
Gets or sets the length of the encryption key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property KeySize As EncryptionKeySize
'Usage

Dim instance As PDFSecurityManager
Dim value As EncryptionKeySize

instance.KeySize = value

value = instance.KeySize
public EncryptionKeySize KeySize {get; set;}
public: __property EncryptionKeySize get_KeySize();
public: __property void set_KeySize(
   EncryptionKeySize value
);
public:
property EncryptionKeySize KeySize {
   EncryptionKeySize get();
   void set (    EncryptionKeySize value);
}

Property Value

A EncryptionKeySize enumeration member specifying the length of the encryption key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


OwnerPassword Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : OwnerPassword Property
Gets or sets the owner password for the pdf document this security manager object is attached to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OwnerPassword As Byte()
'Usage

Dim instance As PDFSecurityManager
Dim value() As Byte

instance.OwnerPassword = value

value = instance.OwnerPassword
public byte[] OwnerPassword {get; set;}
public: __property byte[]* get_OwnerPassword();
public: __property void set_OwnerPassword(
   byte[]* value
);
public:
property array<byte>^ OwnerPassword {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array specifying the owner password for the pdf file.
Remarks

Note: This property must be used when using RC4 or AES-128 encryption. If AES-256 encryption is used, then the UnicodeOwnerPassword property must be set.

An owner password allows the user to get full control over the pdf document. If a pdf file is password protected, entering an owner password when opening the file, allows the user to get full access to the document without any restrictions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


UnicodeOwnerPassword Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : UnicodeOwnerPassword Property
Gets or sets the owner password for the pdf document this security manager object is attached to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnicodeOwnerPassword As String
'Usage

Dim instance As PDFSecurityManager
Dim value As String

instance.UnicodeOwnerPassword = value

value = instance.UnicodeOwnerPassword
public string UnicodeOwnerPassword {get; set;}
public: __property string* get_UnicodeOwnerPassword();
public: __property void set_UnicodeOwnerPassword(
   string* value
);
public:
property String^ UnicodeOwnerPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

An unicode string specifying the owner password for the pdf file.
Remarks

Note: This property must be used when using AES-256 encryption. If RC4 or AES-128 encryption is used, then the OwnerPassword property must be set.

An owner password allows the user to get full control over the pdf document. If a pdf file is password protected, entering an owner password when opening the file, allows the user to get full access to the document without any restrictions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


UnicodeUserPassword Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : UnicodeUserPassword Property
Gets or sets the user password for the pdf document this security manager object is attached to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnicodeUserPassword As String
'Usage

Dim instance As PDFSecurityManager
Dim value As String

instance.UnicodeUserPassword = value

value = instance.UnicodeUserPassword
public string UnicodeUserPassword {get; set;}
public: __property string* get_UnicodeUserPassword();
public: __property void set_UnicodeUserPassword(
   string* value
);
public:
property String^ UnicodeUserPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

An unicode string specifying the user password for the pdf file.
Remarks

Note: This property must be used when using AES-256 encryption. If RC4 or AES-128 encryption is used, then the UserPassword property must be set.

A user password restricts access to a pdf document. When the pdf document is opened, the viewer requests the user to enter a password, if a user password has been set on the document. If the user password has not been set (this property is set to null), then the viewer opens the document without requesting a password. When the pdf document is open with a user password (or without one), the access to the document is restricted by the access rights associated with the document (allow print, etc).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


UserPassword Property

O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : UserPassword Property
Gets or sets the user password for the pdf document this security manager object is attached to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UserPassword As Byte()
'Usage

Dim instance As PDFSecurityManager
Dim value() As Byte

instance.UserPassword = value

value = instance.UserPassword
public byte[] UserPassword {get; set;}
public: __property byte[]* get_UserPassword();
public: __property void set_UserPassword(
   byte[]* value
);
public:
property array<byte>^ UserPassword {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array specifying the user password for the pdf file.
Remarks

Note: This property must be used when using RC4 or AES-128 encryption. If AES-256 encryption is used, then the UnicodeUserPassword property must be set.

A user password restricts access to a pdf document. When the pdf document is opened, the viewer requests the user to enter a password, if a user password has been set on the document. If the user password has not been set (this property is set to null), then the viewer opens the document without requesting a password. When the pdf document is open with a user password (or without one), the access to the document is restricted by the access rights associated with the document (allow print, etc).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

EncryptionAlgorithm Enumeration

O2S.Components.PDF4NET.Security Namespace : EncryptionAlgorithm Enumeration
Specifies the available encryption algorithms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum EncryptionAlgorithm
   Inherits System.Enum
'Usage

Dim instance As EncryptionAlgorithm
public enum EncryptionAlgorithm : System.Enum
__value public enum EncryptionAlgorithm : public System.Enum
public enum class EncryptionAlgorithm : public System.Enum
Members
Member | Description
Aes | 128/256 bit AES encryption. Supported in PDF 1.6 or higher.
AesEnhanced | 256 bit AES encryption with enhanced password validation.
RC4 | 40 bit or 128 bit RC4 encryption.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Security.EncryptionAlgorithm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Security Namespace


%%PageItemTitle%%

EncryptionKeySize Enumeration

O2S.Components.PDF4NET.Security Namespace : EncryptionKeySize Enumeration
Specifies the available key sizes when encrypting a pdf document.

Supported by Compact .NET Edition.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum EncryptionKeySize
   Inherits System.Enum
'Usage

Dim instance As EncryptionKeySize
public enum EncryptionKeySize : System.Enum
__value public enum EncryptionKeySize : public System.Enum
public enum class EncryptionKeySize : public System.Enum
Members
Member | Description
Use128BitKey | A 128 bit encryption key will be used to encrypt the pdf document.
Use256BitKey | A 256 bit encryption key will be used to encrypt the pdf document.
Use40BitKey | A 40 bit encryption key will be used to encrypt the pdf document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Security.EncryptionKeySize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDF4NET.Security Namespace


O2S.Components.PDF4NET.Text Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFGlyph | Defines a glyph in a PDF text run.
Class | PDFGlyphCollection | Defines a read only collection of PDFGlyph objects.
Class | PDFSearchTextResult | Defines the results of a text search operation.
Class | PDFSearchTextResultCollection | Defines a read only collection of PDFSearchTextResult objects.
Class | PDFTextRun | Defines a sequence of characters that share the same visual attributes.
Class | PDFTextRunCollection | Defines a read only collection of PDFTextRun objects.
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFGlyph Class
Members

O2S.Components.PDF4NET.Text Namespace : PDFGlyph Class
Defines a glyph in a PDF text run.
Object Model
PDFGlyph ClassDisplayRectangle ClassPDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGlyph
'Usage

Dim instance As PDFGlyph
public class PDFGlyph
public __gc class PDFGlyph
public ref class PDFGlyph
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Text.PDFGlyph

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGlyph Members
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFGlyph Class Members
Properties Methods

O2S.Components.PDF4NET.Text Namespace : PDFGlyph Class

The following tables list the members exposed by PDFGlyph.

Public Properties
 | Name | Description
Public Property | DisplayBounds | Gets the bounds of the glyph in display coordinate system.
Public Property | PDFBounds | Gets the bounds of the glyph.
Public Property | Text | Gets the text represents by this glyph.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the object to its string representation.
Top
See Also

Reference

PDFGlyph Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Methods$$

PDFGlyph Class Methods

O2S.Components.PDF4NET.Text Namespace : PDFGlyph Class

For a list of all members of this type, see PDFGlyph members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the object to its string representation.
Top
See Also

Reference

PDFGlyph Class
O2S.Components.PDF4NET.Text Namespace


ToString Method (PDFGlyph)

O2S.Components.PDF4NET.Text Namespace > PDFGlyph Class : ToString Method
Converts the object to its string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFGlyph
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The object represented as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGlyph Class
PDFGlyph Members


%%PageItemTitle%% $$Properties$$

PDFGlyph Class Properties

O2S.Components.PDF4NET.Text Namespace : PDFGlyph Class

For a list of all members of this type, see PDFGlyph members.

Public Properties
 | Name | Description
Public Property | DisplayBounds | Gets the bounds of the glyph in display coordinate system.
Public Property | PDFBounds | Gets the bounds of the glyph.
Public Property | Text | Gets the text represents by this glyph.
Top
See Also

Reference

PDFGlyph Class
O2S.Components.PDF4NET.Text Namespace


DisplayBounds Property (PDFGlyph)

O2S.Components.PDF4NET.Text Namespace > PDFGlyph Class : DisplayBounds Property
Gets the bounds of the glyph in display coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayBounds As DisplayRectangle
'Usage

Dim instance As PDFGlyph
Dim value As DisplayRectangle

value = instance.DisplayBounds
public DisplayRectangle DisplayBounds {get;}
public: __property DisplayRectangle* get_DisplayBounds();
public:
property DisplayRectangle^ DisplayBounds {
   DisplayRectangle^ get();
}

Property Value

A O2S.Components.PDF4NET.DisplayRectangle specifying the bounding rectangle for the glyph in display coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGlyph Class
PDFGlyph Members


PDFBounds Property (PDFGlyph)

O2S.Components.PDF4NET.Text Namespace > PDFGlyph Class : PDFBounds Property
Gets the bounds of the glyph.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PDFBounds As PDFRectangle
'Usage

Dim instance As PDFGlyph
Dim value As PDFRectangle

value = instance.PDFBounds
public PDFRectangle PDFBounds {get;}
public: __property PDFRectangle* get_PDFBounds();
public:
property PDFRectangle^ PDFBounds {
   PDFRectangle^ get();
}

Property Value

A O2S.Components.PDF4NET.PDFRectangle specifying the bounding rectangle for the glyph, in PDF coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGlyph Class
PDFGlyph Members


Text Property (PDFGlyph)

O2S.Components.PDF4NET.Text Namespace > PDFGlyph Class : Text Property
Gets the text represents by this glyph.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PDFGlyph
Dim value As String

value = instance.Text
public string Text {get;}
public: __property string* get_Text();
public:
property String^ Text {
   String^ get();
}

Property Value

The character this glyph corresponds to.
Remarks
Usually a glyph corresponds to a single character, but when ligatures are used a single glyph can correspond to 2 or 3 characters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGlyph Class
PDFGlyph Members


%%PageItemTitle%%

PDFGlyphCollection Class
Members

O2S.Components.PDF4NET.Text Namespace : PDFGlyphCollection Class
Defines a read only collection of PDFGlyph objects.
Object Model
PDFGlyphCollection ClassPDFGlyph Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGlyphCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFGlyph)
'Usage

Dim instance As PDFGlyphCollection
public class PDFGlyphCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>
public __gc class PDFGlyphCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>
public ref class PDFGlyphCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.Text.PDFGlyphCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGlyphCollection Members
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFGlyphCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Text Namespace : PDFGlyphCollection Class

The following tables list the members exposed by PDFGlyphCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Top
See Also

Reference

PDFGlyphCollection Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%%

PDFSearchTextResult Class
Members

O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResult Class
Defines the results of a text search operation.
Object Model
PDFSearchTextResult ClassPDFTextRunCollection ClassPDFTextRun Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSearchTextResult
'Usage

Dim instance As PDFSearchTextResult
public class PDFSearchTextResult
public __gc class PDFSearchTextResult
public ref class PDFSearchTextResult
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Text.PDFSearchTextResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSearchTextResult Members
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFSearchTextResult Class Members
Properties

O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResult Class

The following tables list the members exposed by PDFSearchTextResult.

Public Properties
 | Name | Description
Public Property | TextRuns | Gets the list of actual text runs that compose the search result.
Top
See Also

Reference

PDFSearchTextResult Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFSearchTextResult Class Properties

O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResult Class

For a list of all members of this type, see PDFSearchTextResult members.

Public Properties
 | Name | Description
Public Property | TextRuns | Gets the list of actual text runs that compose the search result.
Top
See Also

Reference

PDFSearchTextResult Class
O2S.Components.PDF4NET.Text Namespace


TextRuns Property

O2S.Components.PDF4NET.Text Namespace > PDFSearchTextResult Class : TextRuns Property
Gets the list of actual text runs that compose the search result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextRuns As PDFTextRunCollection
'Usage

Dim instance As PDFSearchTextResult
Dim value As PDFTextRunCollection

value = instance.TextRuns
public PDFTextRunCollection TextRuns {get;}
public: __property PDFTextRunCollection* get_TextRuns();
public:
property PDFTextRunCollection^ TextRuns {
   PDFTextRunCollection^ get();
}

Property Value

List of text runs that compose the search result.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSearchTextResult Class
PDFSearchTextResult Members


%%PageItemTitle%%

PDFSearchTextResultCollection Class
Members

O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResultCollection Class
Defines a read only collection of PDFSearchTextResult objects.
Object Model
PDFSearchTextResultCollection ClassPDFSearchTextResult Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSearchTextResultCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFSearchTextResult)
'Usage

Dim instance As PDFSearchTextResultCollection
public class PDFSearchTextResultCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>
public __gc class PDFSearchTextResultCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>
public ref class PDFSearchTextResultCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.Text.PDFSearchTextResultCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSearchTextResultCollection Members
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFSearchTextResultCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResultCollection Class

The following tables list the members exposed by PDFSearchTextResultCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top
See Also

Reference

PDFSearchTextResultCollection Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%%

PDFTextRun Class
Members

O2S.Components.PDF4NET.Text Namespace : PDFTextRun Class
Defines a sequence of characters that share the same visual attributes.
Object Model
PDFTextRun ClassDisplayRectangle ClassPDFColor ClassPDFGlyphCollection ClassPDFGlyph ClassPDFRectangle ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextRun
'Usage

Dim instance As PDFTextRun
public class PDFTextRun
public __gc class PDFTextRun
public ref class PDFTextRun
Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Text.PDFTextRun

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Members
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFTextRun Class Members
Properties Methods

O2S.Components.PDF4NET.Text Namespace : PDFTextRun Class

The following tables list the members exposed by PDFTextRun.

Public Properties
 | Name | Description
Public Property | DisplayBounds | Gets the bounds of this text run in display coordinate system.
Public Property | FillColor | Gets the color used to fill the path interior.
Public Property | FontEncoding | Gets the font encoding as it appears in the PDF file.
Public Property | FontName | Gets the name of the font used to display the text run.
Public Property | FontSize | Gets the size of the font used to display the text run.
Public Property | Glyphs | Gets or sets the list of glyphs included in this text run.
Public Property | Orientation | Gets the rotation angle of the display bounds.
Public Property | PDFBounds | Gets the bounds of this text run.
Public Property | ScaledFontSize | Gets the scaled size of the font used to display the text run.
Public Property | StrokeColor | Gets the color used to stroke the path outline.
Public Property | Text | Gets the text in this object.
Public Property | TextMatrix | Gets the active text matrix.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts this object to string representation.
Top
See Also

Reference

PDFTextRun Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Methods$$

PDFTextRun Class Methods

O2S.Components.PDF4NET.Text Namespace : PDFTextRun Class

For a list of all members of this type, see PDFTextRun members.

Public Methods
 | Name | Description
Public Method | ToString | Converts this object to string representation.
Top
See Also

Reference

PDFTextRun Class
O2S.Components.PDF4NET.Text Namespace


ToString Method (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : ToString Method
Converts this object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFTextRun
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The object as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%PageItemTitle%% $$Properties$$

PDFTextRun Class Properties

O2S.Components.PDF4NET.Text Namespace : PDFTextRun Class

For a list of all members of this type, see PDFTextRun members.

Public Properties
 | Name | Description
Public Property | DisplayBounds | Gets the bounds of this text run in display coordinate system.
Public Property | FillColor | Gets the color used to fill the path interior.
Public Property | FontEncoding | Gets the font encoding as it appears in the PDF file.
Public Property | FontName | Gets the name of the font used to display the text run.
Public Property | FontSize | Gets the size of the font used to display the text run.
Public Property | Glyphs | Gets or sets the list of glyphs included in this text run.
Public Property | Orientation | Gets the rotation angle of the display bounds.
Public Property | PDFBounds | Gets the bounds of this text run.
Public Property | ScaledFontSize | Gets the scaled size of the font used to display the text run.
Public Property | StrokeColor | Gets the color used to stroke the path outline.
Public Property | Text | Gets the text in this object.
Public Property | TextMatrix | Gets the active text matrix.
Top
See Also

Reference

PDFTextRun Class
O2S.Components.PDF4NET.Text Namespace


DisplayBounds Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : DisplayBounds Property
Gets the bounds of this text run in display coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayBounds As DisplayRectangle
'Usage

Dim instance As PDFTextRun
Dim value As DisplayRectangle

value = instance.DisplayBounds
public DisplayRectangle DisplayBounds {get;}
public: __property DisplayRectangle* get_DisplayBounds();
public:
property DisplayRectangle^ DisplayBounds {
   DisplayRectangle^ get();
}

Property Value

The bounding rectangle of the text run in display coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


FillColor Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : FillColor Property
Gets the color used to fill the path interior.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FillColor As PDFColor
'Usage

Dim instance As PDFTextRun
Dim value As PDFColor

value = instance.FillColor
public PDFColor FillColor {get;}
public: __property PDFColor* get_FillColor();
public:
property PDFColor^ FillColor {
   PDFColor^ get();
}

Property Value

The color of the path interior.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


FontEncoding Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : FontEncoding Property
Gets the font encoding as it appears in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontEncoding As String
'Usage

Dim instance As PDFTextRun
Dim value As String

value = instance.FontEncoding
public string FontEncoding {get;}
public: __property string* get_FontEncoding();
public:
property String^ FontEncoding {
   String^ get();
}

Property Value

The encoding of the font used to draw this text run.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


FontName Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : FontName Property
Gets the name of the font used to display the text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontName As String
'Usage

Dim instance As PDFTextRun
Dim value As String

value = instance.FontName
public string FontName {get;}
public: __property string* get_FontName();
public:
property String^ FontName {
   String^ get();
}

Property Value

The name of the font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


FontSize Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : FontSize Property
Gets the size of the font used to display the text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontSize As Double
'Usage

Dim instance As PDFTextRun
Dim value As Double

value = instance.FontSize
public double FontSize {get;}
public: __property double get_FontSize();
public:
property double FontSize {
   double get();
}

Property Value

The size of the font in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


Glyphs Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : Glyphs Property
Gets or sets the list of glyphs included in this text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Glyphs As PDFGlyphCollection
'Usage

Dim instance As PDFTextRun
Dim value As PDFGlyphCollection

value = instance.Glyphs
public PDFGlyphCollection Glyphs {get;}
public: __property PDFGlyphCollection* get_Glyphs();
public:
property PDFGlyphCollection^ Glyphs {
   PDFGlyphCollection^ get();
}

Property Value

The collection of glyphs that compose the text run.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


Orientation Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : Orientation Property
Gets the rotation angle of the display bounds.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Orientation As Double
'Usage

Dim instance As PDFTextRun
Dim value As Double

value = instance.Orientation
public double Orientation {get;}
public: __property double get_Orientation();
public:
property double Orientation {
   double get();
}

Property Value

The rotation angle of the display bounds, relative to top left corner of the bounding rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


PDFBounds Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : PDFBounds Property
Gets the bounds of this text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PDFBounds As PDFRectangle
'Usage

Dim instance As PDFTextRun
Dim value As PDFRectangle

value = instance.PDFBounds
public PDFRectangle PDFBounds {get;}
public: __property PDFRectangle* get_PDFBounds();
public:
property PDFRectangle^ PDFBounds {
   PDFRectangle^ get();
}

Property Value

The bounding rectangle of the text run in PDF coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


ScaledFontSize Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : ScaledFontSize Property
Gets the scaled size of the font used to display the text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScaledFontSize As Double
'Usage

Dim instance As PDFTextRun
Dim value As Double

value = instance.ScaledFontSize
public double ScaledFontSize {get;}
public: __property double get_ScaledFontSize();
public:
property double ScaledFontSize {
   double get();
}

Property Value

The scaled size of the font in points, based on current text matrix.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


StrokeColor Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : StrokeColor Property
Gets the color used to stroke the path outline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property StrokeColor As PDFColor
'Usage

Dim instance As PDFTextRun
Dim value As PDFColor

value = instance.StrokeColor
public PDFColor StrokeColor {get;}
public: __property PDFColor* get_StrokeColor();
public:
property PDFColor^ StrokeColor {
   PDFColor^ get();
}

Property Value

The color of the path outline.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


Text Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : Text Property
Gets the text in this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PDFTextRun
Dim value As String

value = instance.Text
public string Text {get;}
public: __property string* get_Text();
public:
property String^ Text {
   String^ get();
}

Property Value

The text content represented by this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


TextMatrix Property (PDFTextRun)

O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : TextMatrix Property
Gets the active text matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextMatrix As Matrix
'Usage

Dim instance As PDFTextRun
Dim value As Matrix

value = instance.TextMatrix
public Matrix TextMatrix {get;}
public: __property Matrix* get_TextMatrix();
public:
property Matrix^ TextMatrix {
   Matrix^ get();
}

Property Value

The transformation matrix being in place when the text is displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%PageItemTitle%%

PDFTextRunCollection Class
Members

O2S.Components.PDF4NET.Text Namespace : PDFTextRunCollection Class
Defines a read only collection of PDFTextRun objects.
Object Model
PDFTextRunCollection ClassPDFTextRun Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextRunCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFTextRun)
'Usage

Dim instance As PDFTextRunCollection
public class PDFTextRunCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>
public __gc class PDFTextRunCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>
public ref class PDFTextRunCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.Text.PDFTextRunCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunCollection Members
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFTextRunCollection Class Members
Properties Methods

O2S.Components.PDF4NET.Text Namespace : PDFTextRunCollection Class

The following tables list the members exposed by PDFTextRunCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top
See Also

Reference

PDFTextRunCollection Class
O2S.Components.PDF4NET.Text Namespace


Empty Index Entry

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Topic Not Found

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


RandomAccess.cs
///<fileName>///File name: RandomAccess.cs///</fileName> usingSystem;usingSystem.Drawing;usingSystem.Threading;usingO2S.Components.PDF4NET;usingO2S.Components.PDF4NET.Graphics;usingO2S.Components.PDF4NET.Graphics.Shapes;namespaceO2S.Samples.PDF4NET.RandomAccess{ ///<summary>///This sample will show the possibility to ///access in a random way any page of the document. ///On each page the access time will be written. ///</summary>classRandomAccess { ///<summary>///The main entry point for the application. ///</summary>[STAThread] staticvoidMain(string[] args) { //Create the array that will hold the page access indexesint[] pageIndexes ={4, 7, 9, 2, 6, 1, 0, 3, 8, 5}; inti; //Create the pdf documentPDFDocument pdfDoc =newPDFDocument( ); //Create all the pages of the documentfor( i =0; i <pageIndexes.Length; i++) { pdfDoc.AddPage( ); } //Create the graphic objects PDFFont fontText =newPDFFont( FontFace.Helvetica, 12); PDFBrush brush =newPDFBrush( newPDFColor( ) ); //Access each page of the document. The access order //is given by the content of pageIndexes arrayfor( i =0; i <pageIndexes.Length; i++) { pdfDoc.Pages[pageIndexes[i&cd;.Canvas.DrawText( "Write time: "+DateTime.Now.ToString( "yyyy/MM/dd HH:mm:ss"), fontText, null, brush, 20, 50); //Sleep for 2 secondsThread.Sleep( 2000); } //Save the document to diskpdfDoc.SaveToFile( "randomaccess.pdf"); } }}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


SlideShow.cs
///<fileName>///File name: SlideShow.cs///</fileName> usingSystem;usingSystem.Data;usingSystem.Drawing;usingO2S.Components.PDF4NET;usingO2S.Components.PDF4NET.Graphics;usingO2S.Components.PDF4NET.Graphics.Shapes;namespaceO2S.Samples.PDF4NET.SlideShow{ ///<summary>///This sample will show the presentation capabilities ///of the pdf document. The report in SimpleGrid sample ///uses now transitions to automatically advance from ///one page to the next. ///</summary>classSlideShow { privatestaticfloatleftMargin =15; privatestaticfloatrightMargin =15; privatestaticfloattopMargin =20; privatestaticfloatminBottomMargin =20; privatestaticfloatrowHeight =30; privatestaticfloatheaderHeight =30; privatestaticfloatfirstPageTopOffset =50; privatestaticfloat[] columnsWidth ={ 80, 100, 100, 90, 212, 90, 40, 50}; privatestaticstring[] columnsHeader ={ "Author ID", "First name", "Last name", "Phone", "Address", "City", "State", "ZIP"}; ///<summary>///The main entry point for the application. ///</summary>[STAThread] staticvoidMain(string[] args) { //Create the graphic objectsPDFFont fontTitle =newPDFFont( FontFace.Helvetica, 20); PDFBrush blackBrush =newPDFBrush( newPDFColor( ) ); //Create the pdf documentPDFDocument pdfDoc =newPDFDocument( ); //Set the document to be Landscape orientedpdfDoc.PageOrientation =PageOrientation.Landscape; //Create the transition objectPDFPageTransition trans =newPDFPageTransition( ); trans.Effect =PageTransitionEffect.Box; trans.PageDuration =2; trans.TransitionDuration =2; trans.TransitionMotionDirection =TransitionMotionDirection.Outward; //Create first page of the reportPDFPage page =pdfDoc.AddPage( ); //Add the transition to the pagepage.Transition =trans; //Draw the title of the reportpage.Canvas.DrawText( "Authors - with transition effects", fontTitle, null, blackBrush, page.Width/2, 15, 0, TextAlign.TopCenter ); //Draw report headerDrawReportHeader( page, firstPageTopOffset ); //Create the datasetDataSet ds =newDataSet( ); //Load the datasetds.ReadXml( "authors.xml", XmlReadMode.ReadSchema ); //Get the table from the datasetDataTable authors =ds.Tables[0]; //rowOffset - specifies the vertical position where a row //should begin to be printedfloatrowOffset =firstPageTopOffset +headerHeight; for( inti =0; i <authors.Rows.Count; i++) { if( rowOffset +rowHeight >page.Height -minBottomMargin ) { //not enough space to draw a new row, then create a new page, //draw the header, then draw the rows.page =pdfDoc.AddPage( ); //set the transition effect for the pagepage.Transition =trans; DrawReportHeader( page, topMargin ); rowOffset =topMargin +headerHeight; } DrawReportRow( page, rowOffset, authors.Rows[i] ); rowOffset =rowOffset +rowHeight; } //Save the document to diskpdfDoc.SaveToFile( "slideshow.pdf"); } privatestaticvoidDrawReportHeader( PDFPage pdfPage, floattopOffset ) { //Create the graphic objectsPDFFont fontHeader =newPDFFont( FontFace.Helvetica, 12); fontHeader.Bold =true; PDFPen borderColor =newPDFPen( newPDFColor( ), 1); PDFBrush textColor =newPDFBrush( newPDFColor( ) ); PDFBrush headerFill =newPDFBrush( newPDFColor( 192, 192, 192) ); //Draw the headerpdfPage.Canvas.DrawRectangle( borderColor, headerFill, topOffset, leftMargin, pdfPage.Width -leftMargin -rightMargin, headerHeight ); inti; floatxOffset =leftMargin; //Draw the columns separatorsfor( i =0; i <columnsWidth.Length -1; i++) { xOffset =xOffset +columnsWidth[i]; pdfPage.Canvas.DrawLine( borderColor, xOffset, topOffset, xOffset, topOffset +headerHeight ); } xOffset =leftMargin; //Draw the columns headerfor( i =0; i <columnsWidth.Length; i++) { pdfPage.Canvas.DrawText( columnsHeader[i], fontHeader, null, textColor, xOffset +columnsWidth[i]/2, topOffset +headerHeight/2, 0, TextAlign.MiddleCenter ); xOffset =xOffset +columnsWidth[i]; } } privatestaticvoidDrawReportRow( PDFPage pdfPage, floattopOffset, DataRow row ) { //Create the graphic objectsPDFFont fontText =newPDFFont( FontFace.Helvetica, 12); PDFPen borderColor =newPDFPen( newPDFColor( ), 1); PDFBrush textColor =newPDFBrush( newPDFColor( ) ); PDFBrush headerFill =newPDFBrush( newPDFColor( 192, 192, 192) ); //Draw rows bordersPointF[] points ={ newPointF( leftMargin, topOffset ), newPointF( leftMargin, topOffset +rowHeight), newPointF( pdfPage.Width -rightMargin, topOffset +rowHeight ), newPointF( pdfPage.Width -rightMargin, topOffset )}; pdfPage.Canvas.DrawLines( borderColor, points ); inti; floatxOffset =leftMargin; //Draw the columns separatorsfor( i =0; i <columnsWidth.Length -1; i++) { xOffset =xOffset +columnsWidth[i]; pdfPage.Canvas.DrawLine( borderColor, xOffset, topOffset, xOffset, topOffset +rowHeight ); } xOffset =leftMargin; //Draw the columns headerfor( i =0; i <columnsWidth.Length; i++) { pdfPage.Canvas.DrawText( ( string)row[i], fontText, null, textColor, xOffset +2, topOffset +rowHeight/2, 0, TextAlign.MiddleLeft ); xOffset =xOffset +columnsWidth[i]; } } }}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Templates.cs
///<fileName>///File name: Templates.cs///</fileName> usingSystem;usingSystem.Drawing;usingO2S.Components.PDF4NET;usingO2S.Components.PDF4NET.Graphics;usingO2S.Components.PDF4NET.Graphics.Shapes;namespaceO2S.Samples.PDF4NET.Templates{ ///<summary>///This sample will show how to use common content ///on multiple pages using templates. ///</summary>classTemplates { ///<summary>///The main entry point for the application. ///</summary>[STAThread] staticvoidMain(string[] args) { //The default page size is letterconstintwidth =612; constintheight =792; //Create the graphic objects PDFFont fontText =newPDFFont( FontFace.Helvetica, 12); PDFFont fontTitle =newPDFFont( FontFace.Helvetica, 72); PDFBrush blackBrush =newPDFBrush( newPDFColor( ) ); PDFPen blackPen =newPDFPen( newPDFColor( ), 1); //Import a sample pdf documentPDFDocument pdfDoc =newPDFDocument( "sample.pdf"); //Create the template from a PDF file and attach it to the documentPDFPageTemplate tmpl =newPDFPageTemplate( "one-page-template.pdf", 0, 0, 0, width, height ); pdfDoc.PageTemplate =tmpl; //Create 10 additional pagesfor( inti =0; i <10; i++) { PDFPage pdfPage =pdfDoc.AddPage( ); if( i >0) { pdfPage.Canvas.DrawText( "Page "+i.ToString( ), fontTitle, null, blackBrush, pdfPage.Width/2, pdfPage.Height/2, 0, TextAlign.MiddleCenter ); } } //Do not apply the template on 6th pagepdfDoc.Pages[5].ApplyTemplate =false; //Draw the title on the 6th page (the first of the newly 10 added pages)pdfDoc.Pages[5].Canvas.DrawText( "Templates", fontTitle, null, blackBrush, pdfDoc.Pages[0].Width/2, pdfDoc.Pages[0].Height/2, 0, TextAlign.MiddleCenter ); //Save the document to diskpdfDoc.SaveToFile( "templates.pdf"); } }}

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Linearized PDF
PDF4NET library can create linearized PDF files (fast web view PDF files) with no additional effort from the developer. The new Save method added to PDFDocument class has a second boolean parameter that allows to specify whether the resulting PDF file should be created in linearized or regular format.
PDFDocument doc = new PDFDocument();
// Create the PDF file content.
// ...
// Save the linearized PDF file (set second parameter to true).
doc.Save("file.pdf", true);

Linearized PDF files require 2 passes over the PDF file and the save operation will require more time than saving the file in regular format.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

(Global) Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFActionCollection Class Methods

O2S.Components.PDF4NET.Actions Namespace : PDFActionCollection Class

For a list of all members of this type, see PDFActionCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top
See Also

Reference

PDFActionCollection Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%% $$Properties$$

PDFActionCollection Class Properties

O2S.Components.PDF4NET.Actions Namespace : PDFActionCollection Class

For a list of all members of this type, see PDFActionCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top
See Also

Reference

PDFActionCollection Class
O2S.Components.PDF4NET.Actions Namespace


%%PageItemTitle%%

PDFGoToAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : PDFGoToAction Constructor
Overload List
Overload | Description
PDFGoToAction Constructor | Initializes a new PDFGoToAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

PDFHideAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : PDFHideAction Constructor
Overload List
Overload | Description
PDFHideAction Constructor | Initializes a new PDFHideAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%PageItemTitle%%

PDFJavaScriptAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFJavaScriptAction Class : PDFJavaScriptAction Constructor
Overload List
Overload | Description
PDFJavaScriptAction Constructor | Initializes a new PDFJavaScriptAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


%%PageItemTitle%%

PDFLaunchAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : PDFLaunchAction Constructor
Overload List
Overload | Description
PDFLaunchAction Constructor | Initializes a new PDFLaunchAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%%

PDFNamedAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFNamedAction Class : PDFNamedAction Constructor
Overload List
Overload | Description
PDFNamedAction Constructor | Initializes a new PDFNamedAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


%%PageItemTitle%%

PDFRemoteGoToAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : PDFRemoteGoToAction Constructor
Overload List
Overload | Description
PDFRemoteGoToAction Constructor | Initializes a new PDFRemoteGoToAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

PDFResetFormAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : PDFResetFormAction Constructor
Overload List
Overload | Description
PDFResetFormAction Constructor | Initializes a new PDFResetFormAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%PageItemTitle%%

PDFSubmitFormAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : PDFSubmitFormAction Constructor
Overload List
Overload | Description
PDFSubmitFormAction Constructor | Initializes a new PDFSubmitFormAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

PDFURIAction Constructor

O2S.Components.PDF4NET.Actions Namespace > PDFURIAction Class : PDFURIAction Constructor
Overload List
Overload | Description
PDFURIAction Constructor | Initializes a new PDFURIAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFURIAction Class
PDFURIAction Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Actions Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFGoToAction
O2S.Components.PDF4NET.Actions.PDFHideAction
O2S.Components.PDF4NET.Actions.PDFJavaScriptAction
O2S.Components.PDF4NET.Actions.PDFLaunchAction
O2S.Components.PDF4NET.Actions.PDFNamedAction
O2S.Components.PDF4NET.Actions.PDFRemoteGoToAction
O2S.Components.PDF4NET.Actions.PDFResetFormAction
O2S.Components.PDF4NET.Actions.PDFSubmitFormAction
O2S.Components.PDF4NET.Actions.PDFURIAction
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Actions.PDFActionCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDF3DActivation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : PDF3DActivation Constructor
Overload List
Overload | Description
PDF3DActivation Constructor | Initializes a new PDF3DActivation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


%%PageItemTitle%% $$Methods$$

PDF3DAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

For a list of all members of this type, see PDF3DAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDF3DAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : PDF3DAnnotation Constructor
Overload List
Overload | Description
PDF3DAnnotation Constructor | Initializes a new PDF3DAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


%%PageItemTitle%% $$Methods$$

PDF3DCrossSectionCollection Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

For a list of all members of this type, see PDF3DCrossSectionCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Top
See Also

Reference

PDF3DCrossSectionCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDF3DCrossSectionCollection Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

For a list of all members of this type, see PDF3DCrossSectionCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Top
See Also

Reference

PDF3DCrossSectionCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DCrossSection Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : PDF3DCrossSection Constructor
Overload List
Overload | Description
PDF3DCrossSection Constructor | Initializes a new PDF3DCrossSection object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


%%PageItemTitle%% $$Methods$$

PDF3DNodeCollection Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

For a list of all members of this type, see PDF3DNodeCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Top
See Also

Reference

PDF3DNodeCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDF3DNodeCollection Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

For a list of all members of this type, see PDF3DNodeCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Top
See Also

Reference

PDF3DNodeCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DNode Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : PDF3DNode Constructor
Overload List
Overload | Description
PDF3DNode Constructor | Initializes a new PDF3DNode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DNode Class
PDF3DNode Members


%%PageItemTitle%%

PDF3DStream Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : PDF3DStream Constructor
Overload List
Overload | Description
PDF3DStream Constructor | Initializes a new PDF3DStream object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DStream Class
PDF3DStream Members


%%PageItemTitle%% $$Methods$$

PDF3DViewCollection Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

For a list of all members of this type, see PDF3DViewCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Top
See Also

Reference

PDF3DViewCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDF3DViewCollection Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

For a list of all members of this type, see PDF3DViewCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Top
See Also

Reference

PDF3DViewCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDF3DView Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : PDF3DView Constructor
Overload List
Overload | Description
PDF3DView Constructor | Initializes a new PDF3DView object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF3DView Class
PDF3DView Members


%%PageItemTitle%% $$Properties$$

PDFAnnotationAppearance Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationAppearance Class

For a list of all members of this type, see PDFAnnotationAppearance members.

Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Dictionary | Gets the form XObject dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top
See Also

Reference

PDFAnnotationAppearance Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFAnnotationAppearance Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationAppearance Class : PDFAnnotationAppearance Constructor
Overload List
Overload | Description
PDFAnnotationAppearance Constructor | Initializes a new PDFAnnotationAppearance object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationAppearance Class
PDFAnnotationAppearance Members


%%PageItemTitle%% $$Properties$$

PDFAnnotationCollection Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationCollection Class

For a list of all members of this type, see PDFAnnotationCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top
See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFBaseMarkupAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

For a list of all members of this type, see PDFBaseMarkupAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFBaseMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFEllipseAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFEllipseAnnotation Class

For a list of all members of this type, see PDFEllipseAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFEllipseAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFEllipseAnnotation Class

For a list of all members of this type, see PDFEllipseAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from O2S.Components.PDF4NET.Annotations.PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFFlashAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFFlashAnnotation Class

For a list of all members of this type, see PDFFlashAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFlashAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFFreeTextAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

For a list of all members of this type, see PDFFreeTextAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFFreeTextAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : PDFFreeTextAnnotation Constructor
Overload List
Overload | Description
PDFFreeTextAnnotation Constructor | Initializes a new PDFFreeTextAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFHighlightAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFHighlightAnnotation Class

For a list of all members of this type, see PDFHighlightAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFHighlightAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFHighlightAnnotation Class

For a list of all members of this type, see PDFHighlightAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFImageAppearance Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFImageAppearance Class

For a list of all members of this type, see PDFImageAppearance members.

Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Dictionary | Gets the form XObject dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top
See Also

Reference

PDFImageAppearance Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFInkAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFInkAnnotation Class

For a list of all members of this type, see PDFInkAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFInkAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFInkAnnotation Class : PDFInkAnnotation Constructor
Overload List
Overload | Description
PDFInkAnnotation Constructor | Initializes a new PDFInkAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFLineAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

For a list of all members of this type, see PDFLineAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFLinkAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

For a list of all members of this type, see PDFLinkAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%%

PDFLinkAnnotation Constructor

O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : PDFLinkAnnotation Constructor
Overload List
Overload | Description
PDFLinkAnnotation Constructor | Initializes a new PDFLinkAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFMovieAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

For a list of all members of this type, see PDFMovieAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFMovieAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFPointsCollection Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class

For a list of all members of this type, see PDFPointsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Top
See Also

Reference

PDFPointsCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFPointsCollection Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class

For a list of all members of this type, see PDFPointsCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Top
See Also

Reference

PDFPointsCollection Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFRectangleAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFRectangleAnnotation Class

For a list of all members of this type, see PDFRectangleAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFRectangleAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFRectangleAnnotation Class

For a list of all members of this type, see PDFRectangleAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from O2S.Components.PDF4NET.Annotations.PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFRubberStampAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

For a list of all members of this type, see PDFRubberStampAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRubberStampAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFSCAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFSCAnnotation Class

For a list of all members of this type, see PDFSCAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFSquigglyAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFSquigglyAnnotation Class

For a list of all members of this type, see PDFSquigglyAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFSquigglyAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFSquigglyAnnotation Class

For a list of all members of this type, see PDFSquigglyAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFStrikeOutAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

For a list of all members of this type, see PDFStrikeOutAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFStrikeOutAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

For a list of all members of this type, see PDFStrikeOutAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFTextAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

For a list of all members of this type, see PDFTextAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFTextMarkupAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

For a list of all members of this type, see PDFTextMarkupAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFUnderlineAnnotation Class Methods

O2S.Components.PDF4NET.Annotations Namespace : PDFUnderlineAnnotation Class

For a list of all members of this type, see PDFUnderlineAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFUnderlineAnnotation Class Properties

O2S.Components.PDF4NET.Annotations Namespace : PDFUnderlineAnnotation Class

For a list of all members of this type, see PDFUnderlineAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Annotations.RichMedia Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Annotations Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DActivation
O2S.Components.PDF4NET.Annotations.PDF3DAnimation
O2S.Components.PDF4NET.Annotations.PDF3DBackground
O2S.Components.PDF4NET.Annotations.PDF3DCrossSection
O2S.Components.PDF4NET.Annotations.PDF3DNode
O2S.Components.PDF4NET.Annotations.PDF3DProjection
O2S.Components.PDF4NET.Annotations.PDF3DRenderMode
O2S.Components.PDF4NET.Annotations.PDF3DStream
O2S.Components.PDF4NET.Annotations.PDF3DView
O2S.Components.PDF4NET.Annotations.PDF3DLightingScheme
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotation
O2S.Components.PDF4NET.Annotations.PDFInkAnnotation
O2S.Components.PDF4NET.Annotations.PDFLineAnnotation
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFEllipseAnnotation
O2S.Components.PDF4NET.Annotations.PDFRectangleAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFHighlightAnnotation
O2S.Components.PDF4NET.Annotations.PDFSquigglyAnnotation
O2S.Components.PDF4NET.Annotations.PDFStrikeOutAnnotation
O2S.Components.PDF4NET.Annotations.PDFUnderlineAnnotation
O2S.Components.PDF4NET.Annotations.PDFFlashAnnotation
O2S.Components.PDF4NET.Annotations.PDFFreeTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFLinkAnnotation
O2S.Components.PDF4NET.Annotations.PDFMovieAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFCheckBoxWidget
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem
O2S.Components.PDF4NET.Forms.PDFDropDownListWidget
O2S.Components.PDF4NET.Forms.PDFListBoxWidget
O2S.Components.PDF4NET.Forms.PDFPushButtonWidget
O2S.Components.PDF4NET.Forms.PDFSignatureWidget
O2S.Components.PDF4NET.Forms.PDFTextBoxWidget
O2S.Components.PDF4NET.Annotations.PDFAnnotationBorder
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDF4NET.Annotations.PDFImageAppearance
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Annotations.PDF3DCrossSectionCollection
O2S.Components.PDF4NET.Annotations.PDF3DNodeCollection
O2S.Components.PDF4NET.Annotations.PDF3DViewCollection
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Annotations.PDFAnnotationCollection
O2S.Components.PDF4NET.Annotations.PDFPointsCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Converters Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Converters.PDFConverter
O2S.Components.PDF4NET.Converters.PDFConvertOptions
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

IncompatiblePDFObjectException Class Methods

O2S.Components.PDF4NET.Cos Namespace : IncompatiblePDFObjectException Class

For a list of all members of this type, see IncompatiblePDFObjectException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

IncompatiblePDFObjectException Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Properties$$

IncompatiblePDFObjectException Class Properties

O2S.Components.PDF4NET.Cos Namespace : IncompatiblePDFObjectException Class

For a list of all members of this type, see IncompatiblePDFObjectException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

IncompatiblePDFObjectException Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Methods$$

InvalidPDFValueException Class Methods

O2S.Components.PDF4NET.Cos Namespace : InvalidPDFValueException Class

For a list of all members of this type, see InvalidPDFValueException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPDFValueException Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%% $$Properties$$

InvalidPDFValueException Class Properties

O2S.Components.PDF4NET.Cos Namespace : InvalidPDFValueException Class

For a list of all members of this type, see InvalidPDFValueException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPDFValueException Class
O2S.Components.PDF4NET.Cos Namespace


%%PageItemTitle%%

PDFArray Constructor

O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : PDFArray Constructor
Overload List
Overload | Description
PDFArray Constructor | Initializes a new PDFArray object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFArray Class
PDFArray Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Cos Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFArray
O2S.Components.PDF4NET.Cos.PDFBoolean
O2S.Components.PDF4NET.Cos.PDFCosObject
O2S.Components.PDF4NET.Cos.PDFDateTime
O2S.Components.PDF4NET.Cos.PDFDictionary
O2S.Components.PDF4NET.Cos.PDFName
O2S.Components.PDF4NET.Cos.PDFNull
O2S.Components.PDF4NET.Cos.PDFNumber
O2S.Components.PDF4NET.Cos.PDFString
O2S.Components.PDF4NET.Security.PDFDigitalSignature
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.Cos.IncompatiblePDFObjectException
O2S.Components.PDF4NET.Cos.InvalidPDFValueException
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

FDFFieldCollection Class Methods

O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

For a list of all members of this type, see FDFFieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top
See Also

Reference

FDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

FDFFieldCollection Class Properties

O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

For a list of all members of this type, see FDFFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top
See Also

Reference

FDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


FromStream Method (FDFFile)

O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : FromStream Method
Creates a FDFFile object from the given stream object.
Overload List
Overload | Description
FromStream | Creates a FDFFile object from the given stream object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%% $$Methods$$

PDFCalculatedFieldCollection Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFCalculatedFieldCollection Class

For a list of all members of this type, see PDFCalculatedFieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top
See Also

Reference

PDFCalculatedFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFCalculatedFieldCollection Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFCalculatedFieldCollection Class

For a list of all members of this type, see PDFCalculatedFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top
See Also

Reference

PDFCalculatedFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFCheckBoxField Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

For a list of all members of this type, see PDFCheckBoxField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : PDFCheckBoxField Constructor
Overload List
Overload | Description
PDFCheckBoxField Constructor | Initializes a new PDFCheckBoxField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%% $$Methods$$

PDFCheckBoxWidget Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxWidget Class

For a list of all members of this type, see PDFCheckBoxWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFCheckBoxWidget Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxWidget Class

For a list of all members of this type, see PDFCheckBoxWidget members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxWidget Class : PDFCheckBoxWidget Constructor
Overload List
Overload | Description
PDFCheckBoxWidget Constructor | Initializes a new PDFCheckBoxWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxWidget Class
PDFCheckBoxWidget Members


%%PageItemTitle%% $$Methods$$

PDFCheckWidget Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFCheckWidget Class

For a list of all members of this type, see PDFCheckWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFCheckWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : PDFCheckWidget Constructor
Overload List
Overload | Description
PDFCheckWidget Constructor | Initializes a new PDFCheckWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%PageItemTitle%% $$Methods$$

PDFDropDownListField Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

For a list of all members of this type, see PDFDropDownListField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFDropDownListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFDropDownListField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : PDFDropDownListField Constructor
Overload List
Overload | Description
PDFDropDownListField Constructor | Initializes a new PDFDropDownListField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%% $$Methods$$

PDFDropDownListWidget Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListWidget Class

For a list of all members of this type, see PDFDropDownListWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFDropDownListWidget Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListWidget Class

For a list of all members of this type, see PDFDropDownListWidget members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFDropDownListWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListWidget Class : PDFDropDownListWidget Constructor
Overload List
Overload | Description
PDFDropDownListWidget Constructor | Initializes a new PDFDropDownListWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListWidget Class
PDFDropDownListWidget Members


%%PageItemTitle%% $$Methods$$

PDFFieldWidgetCollection Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetCollection Class

For a list of all members of this type, see PDFFieldWidgetCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top
See Also

Reference

PDFFieldWidgetCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFFieldWidgetCollection Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetCollection Class

For a list of all members of this type, see PDFFieldWidgetCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top
See Also

Reference

PDFFieldWidgetCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : PDFFieldWidget Constructor
Overload List
Overload | Description
PDFFieldWidget Constructor | Initializes a new PDFFieldWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%PageItemTitle%% $$Methods$$

PDFListBoxField Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

For a list of all members of this type, see PDFListBoxField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFListBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFListBoxField Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

For a list of all members of this type, see PDFListBoxField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFListBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFListBoxField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFListBoxField Class : PDFListBoxField Constructor
Overload List
Overload | Description
PDFListBoxField Constructor | Initializes a new PDFListBoxField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxField Class
PDFListBoxField Members


%%PageItemTitle%% $$Methods$$

PDFListBoxWidget Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListBoxWidget Class

For a list of all members of this type, see PDFListBoxWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFListBoxWidget Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFListBoxWidget Class

For a list of all members of this type, see PDFListBoxWidget members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFListBoxWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFListBoxWidget Class : PDFListBoxWidget Constructor
Overload List
Overload | Description
PDFListBoxWidget Constructor | Initializes a new PDFListBoxWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxWidget Class
PDFListBoxWidget Members


%%PageItemTitle%% $$Methods$$

PDFListField Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

For a list of all members of this type, see PDFListField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFListItemCollection Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

For a list of all members of this type, see PDFListItemCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top
See Also

Reference

PDFListItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFListItemCollection Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

For a list of all members of this type, see PDFListItemCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top
See Also

Reference

PDFListItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFPushButtonField Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonField Class

For a list of all members of this type, see PDFPushButtonField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFPushButtonField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonField Class : PDFPushButtonField Constructor
Overload List
Overload | Description
PDFPushButtonField Constructor | Initializes a new PDFPushButtonField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


%%PageItemTitle%% $$Methods$$

PDFPushButtonWidget Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonWidget Class

For a list of all members of this type, see PDFPushButtonWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : PDFPushButtonWidget Constructor
Overload List
Overload | Description
PDFPushButtonWidget Constructor | Initializes a new PDFPushButtonWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%PageItemTitle%% $$Methods$$

PDFRadioButtonItem Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

For a list of all members of this type, see PDFRadioButtonItem members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFRadioButtonItem Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

For a list of all members of this type, see PDFRadioButtonItem members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonItem Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : PDFRadioButtonItem Constructor
Overload List
Overload | Description
PDFRadioButtonItem Constructor | Initializes a new PDFRadioButtonItem object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%% $$Methods$$

PDFRadioButtonListField Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

For a list of all members of this type, see PDFRadioButtonListField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonListField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : PDFRadioButtonListField Constructor
Overload List
Overload | Description
PDFRadioButtonListField Constructor | Initializes a new PDFRadioButtonListField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%% $$Methods$$

PDFSignatureField Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

For a list of all members of this type, see PDFSignatureField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFSignatureField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : PDFSignatureField Constructor
Overload List
Overload | Description
PDFSignatureField Constructor | Initializes a new PDFSignatureField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%PageItemTitle%%

PDFSignatureLockFieldAction Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureLockFieldAction Class : PDFSignatureLockFieldAction Constructor
Overload List
Overload | Description
PDFSignatureLockFieldAction Constructor | Initializes a new PDFSignatureLockFieldAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


%%PageItemTitle%% $$Methods$$

PDFSignatureWidget Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureWidget Class

For a list of all members of this type, see PDFSignatureWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFSignatureWidget Class Properties

O2S.Components.PDF4NET.Forms Namespace : PDFSignatureWidget Class

For a list of all members of this type, see PDFSignatureWidget members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets or sets the annotation ID. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFSignatureWidget Class : PDFSignatureWidget Constructor
Overload List
Overload | Description
PDFSignatureWidget Constructor | Initializes a new PDFSignatureWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureWidget Class
PDFSignatureWidget Members


%%PageItemTitle%% $$Methods$$

PDFTextBoxField Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

For a list of all members of this type, see PDFTextBoxField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDF4NET.Forms.PDFField)
Top
See Also

Reference

PDFTextBoxField Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFTextBoxField Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : PDFTextBoxField Constructor
Overload List
Overload | Description
PDFTextBoxField Constructor | Initializes a new PDFTextBoxField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%% $$Methods$$

PDFTextBoxWidget Class Methods

O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxWidget Class

For a list of all members of this type, see PDFTextBoxWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from O2S.Components.PDF4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%%

PDFTextBoxWidget Constructor

O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxWidget Class : PDFTextBoxWidget Constructor
Overload List
Overload | Description
PDFTextBoxWidget Constructor | Initializes a new PDFTextBoxWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxWidget Class
PDFTextBoxWidget Members


%%PageItemTitle%% $$Properties$$

XFAArea Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAArea Class

For a list of all members of this type, see XFAArea members.

Public Properties
 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Top
See Also

Reference

XFAArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFABarcodeField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class

For a list of all members of this type, see XFABarcodeField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFABarcodeField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAButtonField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class

For a list of all members of this type, see XFAButtonField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAButtonField Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class

For a list of all members of this type, see XFAButtonField members.

Public Properties
 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFACheckButtonField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class

For a list of all members of this type, see XFACheckButtonField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFACheckButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAChoiceListField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class

For a list of all members of this type, see XFAChoiceListField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAChoiceListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFADateTimeEditField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class

For a list of all members of this type, see XFADateTimeEditField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFADateTimeEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAHttpSubmitButtonField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class

For a list of all members of this type, see XFAHttpSubmitButtonField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAHttpSubmitButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAImageEditField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class

For a list of all members of this type, see XFAImageEditField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAImageEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAListItemCollection Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

For a list of all members of this type, see XFAListItemCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Top
See Also

Reference

XFAListItemCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAListItemCollection Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

For a list of all members of this type, see XFAListItemCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Top
See Also

Reference

XFAListItemCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFANumericEditField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class

For a list of all members of this type, see XFANumericEditField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFANumericEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Properties$$

XFAPageArea Class Properties

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageArea Class

For a list of all members of this type, see XFAPageArea members.

Public Properties
 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer)
Top
See Also

Reference

XFAPageArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFAPasswordEditField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class

For a list of all members of this type, see XFAPasswordEditField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFAPasswordEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFARadioButtonField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class

For a list of all members of this type, see XFARadioButtonField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFARadioButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFARadioButtonListField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class

For a list of all members of this type, see XFARadioButtonListField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFARadioButtonListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%PageItemTitle%% $$Methods$$

XFATextEditField Class Methods

O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class

For a list of all members of this type, see XFATextEditField members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the field to string representation. (Inherited from O2S.Components.PDF4NET.Forms.XFA.XFAField)
Top
See Also

Reference

XFATextEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Forms.XFA Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAAreaCollection
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAArea
O2S.Components.PDF4NET.Forms.XFA.XFAPageArea
O2S.Components.PDF4NET.Forms.XFA.XFASubform
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAHttpSubmitButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListField
O2S.Components.PDF4NET.Forms.XFA.XFADateTimeEditField
O2S.Components.PDF4NET.Forms.XFA.XFAImageEditField
O2S.Components.PDF4NET.Forms.XFA.XFANumericEditField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonListField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPasswordEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPageSet
O2S.Components.PDF4NET.Forms.XFA.XFAForm
O2S.Components.PDF4NET.Forms.XFA.XFAFieldCollection
O2S.Components.PDF4NET.Forms.XFA.XFAFieldImportError
O2S.Components.PDF4NET.Forms.XFA.XFAListItem
O2S.Components.PDF4NET.Forms.XFA.XFAPageAreaCollection
O2S.Components.PDF4NET.Forms.XFA.XFAPageSetCollection
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonFieldCollection
O2S.Components.PDF4NET.Forms.XFA.XFASubformCollection
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

XFDFFieldCollection Class Methods

O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

For a list of all members of this type, see XFDFFieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top
See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

XFDFFieldCollection Class Properties

O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

For a list of all members of this type, see XFDFFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top
See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


FromStream Method (XFDFFile)

O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : FromStream Method
Creates a XFDFFile object from the given stream object.
Overload List
Overload | Description
FromStream | Creates a XFDFFile object from the given stream object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Forms Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFCheckBoxWidget
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem
O2S.Components.PDF4NET.Forms.PDFDropDownListWidget
O2S.Components.PDF4NET.Forms.PDFListBoxWidget
O2S.Components.PDF4NET.Forms.PDFPushButtonWidget
O2S.Components.PDF4NET.Forms.PDFSignatureWidget
O2S.Components.PDF4NET.Forms.PDFTextBoxWidget
O2S.Components.PDF4NET.Forms.FDFField
O2S.Components.PDF4NET.Forms.FDFFile
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFCheckBoxField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFDropDownListField
O2S.Components.PDF4NET.Forms.PDFListBoxField
O2S.Components.PDF4NET.Forms.PDFPushButtonField
O2S.Components.PDF4NET.Forms.PDFRadioButtonListField
O2S.Components.PDF4NET.Forms.PDFSignatureField
O2S.Components.PDF4NET.Forms.PDFTextBoxField
O2S.Components.PDF4NET.Forms.PDFFieldImportError
O2S.Components.PDF4NET.Forms.PDFForm
O2S.Components.PDF4NET.Forms.PDFListItem
O2S.Components.PDF4NET.Forms.PDFSignatureLockFieldAction
O2S.Components.PDF4NET.Forms.XFDFField
O2S.Components.PDF4NET.Forms.XFDFFile
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Forms.FDFFieldCollection
O2S.Components.PDF4NET.Forms.PDFCalculatedFieldCollection
O2S.Components.PDF4NET.Forms.PDFFieldCollection
O2S.Components.PDF4NET.Forms.PDFFieldWidgetCollection
O2S.Components.PDF4NET.Forms.PDFListItemCollection
O2S.Components.PDF4NET.Forms.XFDFFieldCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFFunctionCollection Class Methods

O2S.Components.PDF4NET.Functions Namespace : PDFFunctionCollection Class

For a list of all members of this type, see PDFFunctionCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Top
See Also

Reference

PDFFunctionCollection Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%% $$Properties$$

PDFFunctionCollection Class Properties

O2S.Components.PDF4NET.Functions Namespace : PDFFunctionCollection Class

For a list of all members of this type, see PDFFunctionCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Top
See Also

Reference

PDFFunctionCollection Class
O2S.Components.PDF4NET.Functions Namespace


%%PageItemTitle%%

PDFType3Function Constructor

O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : PDFType3Function Constructor
Overload List
Overload | Description
PDFType3Function Constructor | Initilizes a new PDFType3Function object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFType3Function Class
PDFType3Function Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Functions Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType0Function
O2S.Components.PDF4NET.Functions.PDFType2Function
O2S.Components.PDF4NET.Functions.PDFType3Function
O2S.Components.PDF4NET.Functions.PDFType4Function
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Functions.PDFFunctionCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Properties$$

PDFGeographicCoordinateSystem Class Properties

O2S.Components.PDF4NET.Geo Namespace : PDFGeographicCoordinateSystem Class

For a list of all members of this type, see PDFGeographicCoordinateSystem members.

Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code. (Inherited from O2S.Components.PDF4NET.Geo.PDFCoordinateSystem)
Public Property | WKT | Gets or sets the well known text. (Inherited from O2S.Components.PDF4NET.Geo.PDFCoordinateSystem)
Top
See Also

Reference

PDFGeographicCoordinateSystem Class
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%%

PDFGeographicCoordinateSystem Constructor

O2S.Components.PDF4NET.Geo Namespace > PDFGeographicCoordinateSystem Class : PDFGeographicCoordinateSystem Constructor
Overload List
Overload | Description
PDFGeographicCoordinateSystem Constructor | Initializes a new PDFGeographicCoordinateSystem object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeographicCoordinateSystem Class
PDFGeographicCoordinateSystem Members


%%PageItemTitle%%

PDFGeospatialMeasure Constructor

O2S.Components.PDF4NET.Geo Namespace > PDFGeospatialMeasure Class : PDFGeospatialMeasure Constructor
Overload List
Overload | Description
PDFGeospatialMeasure Constructor | Initializes a new PDFGeospatialMeasure object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGeospatialMeasure Class
PDFGeospatialMeasure Members


%%PageItemTitle%%

PDFPointData Constructor

O2S.Components.PDF4NET.Geo Namespace > PDFPointData Class : PDFPointData Constructor
Overload List
Overload | Description
PDFPointData Constructor | Initializes a new PDFPointData object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointData Class
PDFPointData Members


%%PageItemTitle%% $$Properties$$

PDFProjectedCoordinateSystem Class Properties

O2S.Components.PDF4NET.Geo Namespace : PDFProjectedCoordinateSystem Class

For a list of all members of this type, see PDFProjectedCoordinateSystem members.

Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code. (Inherited from O2S.Components.PDF4NET.Geo.PDFCoordinateSystem)
Public Property | WKT | Gets or sets the well known text. (Inherited from O2S.Components.PDF4NET.Geo.PDFCoordinateSystem)
Top
See Also

Reference

PDFProjectedCoordinateSystem Class
O2S.Components.PDF4NET.Geo Namespace


%%PageItemTitle%%

PDFProjectedCoordinateSystem Constructor

O2S.Components.PDF4NET.Geo Namespace > PDFProjectedCoordinateSystem Class : PDFProjectedCoordinateSystem Constructor
Overload List
Overload | Description
PDFProjectedCoordinateSystem Constructor | Initializes a new PDFProjectedCoordinateSystem object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFProjectedCoordinateSystem Class
PDFProjectedCoordinateSystem Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Geo Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Geo.PDFCoordinateSystem
O2S.Components.PDF4NET.Geo.PDFGeographicCoordinateSystem
O2S.Components.PDF4NET.Geo.PDFProjectedCoordinateSystem
O2S.Components.PDF4NET.Geo.PDFPointData
O2S.Components.PDF4NET.Measures.PDFMeasure
O2S.Components.PDF4NET.Geo.PDFGeospatialMeasure
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

BarcodeEncodingException Class Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

BarcodeEncodingException Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Methods$$

PDF417Barcode Class Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Top
See Also

Reference

PDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCodabarBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

For a list of all members of this type, see PDFCodabarBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCodabarBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode11Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

For a list of all members of this type, see PDFCode11Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode11Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode25InterleavedBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

For a list of all members of this type, see PDFCode25InterleavedBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode25InterleavedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode32Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

For a list of all members of this type, see PDFCode32Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode32Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode39ExtendedBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

For a list of all members of this type, see PDFCode39ExtendedBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode39ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode93Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

For a list of all members of this type, see PDFCode93Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode93Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode93ExtendedBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

For a list of all members of this type, see PDFCode93ExtendedBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode93ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128ABarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

For a list of all members of this type, see PDFCode128ABarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128ABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

For a list of all members of this type, see PDFCode128Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128BBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

For a list of all members of this type, see PDFCode128BBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128BBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128CBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

For a list of all members of this type, see PDFCode128CBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128CBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCOOP25Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

For a list of all members of this type, see PDFCOOP25Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCOOP25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFEAN8Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

For a list of all members of this type, see PDFEAN8Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN8Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFEAN13Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

For a list of all members of this type, see PDFEAN13Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFFedExGround96Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

For a list of all members of this type, see PDFFedExGround96Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFFedExGround96Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFHeightModulatedBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

For a list of all members of this type, see PDFHeightModulatedBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFHeightModulatedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFIATA25Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

For a list of all members of this type, see PDFIATA25Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFIATA25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFIdentcodeBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

For a list of all members of this type, see PDFIdentcodeBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFIdentcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFISBNBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

For a list of all members of this type, see PDFISBNBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISBNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFISMNBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

For a list of all members of this type, see PDFISMNBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISMNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFISSNBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

For a list of all members of this type, see PDFISSNBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISSNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFJAN13Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

For a list of all members of this type, see PDFJAN13Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFJAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFKixBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

For a list of all members of this type, see PDFKixBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFKixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFLeitcodeBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

For a list of all members of this type, see PDFLeitcodeBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFLeitcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFMatrix25Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

For a list of all members of this type, see PDFMatrix25Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMatrix25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Methods$$

PDFMicroPDF417Barcode Class Methods

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

For a list of all members of this type, see PDFMicroPDF417Barcode members.

Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Top
See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFMSIPlesseyBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

For a list of all members of this type, see PDFMSIPlesseyBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMSIPlesseyBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFPlanetBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

For a list of all members of this type, see PDFPlanetBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPlanetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFPostNetBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

For a list of all members of this type, see PDFPostNetBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPostNetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFPZNBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

For a list of all members of this type, see PDFPZNBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPZNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFRM4SCCBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

For a list of all members of this type, see PDFRM4SCCBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFRM4SCCBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFSCC14Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

For a list of all members of this type, see PDFSCC14Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSCC14Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFSingaporePostBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

For a list of all members of this type, see PDFSingaporePostBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSingaporePostBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFSSCC18Barcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

For a list of all members of this type, see PDFSSCC18Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSSCC18Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUPCABarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

For a list of all members of this type, see PDFUPCABarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUPCABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUPCEBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

For a list of all members of this type, see PDFUPCEBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUPCEBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUSPSFIMBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

For a list of all members of this type, see PDFUSPSFIMBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSFIMBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUSPSHorizontalBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

For a list of all members of this type, see PDFUSPSHorizontalBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSHorizontalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUSPSPICBarcode Class Properties

O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

For a list of all members of this type, see PDFUSPSPICBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSPICBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.Barcodes Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMicroPDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodablockFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode16KBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFDataMatrixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFQRBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodabarBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode11Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128ABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128BBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFFedExGround96Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSCC14Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSSCC18Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSPICBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIdentcodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFLeitcodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCOOP25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIATA25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMatrix25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode32Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPZNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN8Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISBNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISMNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISSNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFJAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCEBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPlanetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPostNetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFKixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSingaporePostBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPharmacodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSFIMBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.Graphics.Barcodes.BarcodeEncodingException
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFCalGrayColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : PDFCalGrayColorSpace Constructor
Overload List
Overload | Description
PDFCalGrayColorSpace Constructor | Initializes a new PDFCalGrayColorSpace object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


%%PageItemTitle%%

PDFCalRgbColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : PDFCalRgbColorSpace Constructor
Overload List
Overload | Description
PDFCalRgbColorSpace Constructor | Initializes a new PDFCalRgbColorSpace object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


%%PageItemTitle%% $$Methods$$

PDFColorSpaceCollection Class Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceCollection Class

For a list of all members of this type, see PDFColorSpaceCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Top
See Also

Reference

PDFColorSpaceCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Properties$$

PDFColorSpaceCollection Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceCollection Class

For a list of all members of this type, see PDFColorSpaceCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Top
See Also

Reference

PDFColorSpaceCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFDeviceColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : PDFDeviceColorSpace Constructor
Overload List
Overload | Description
PDFDeviceColorSpace Constructor | Initializes a new PDFDeviceColorSpace object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


%%PageItemTitle%%

PDFDeviceNAttributes Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNAttributes Class : PDFDeviceNAttributes Constructor
Overload List
Overload | Description
PDFDeviceNAttributes Constructor | Initilizes a new PDFDeviceNAttributes object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNAttributes Class
PDFDeviceNAttributes Members


%%PageItemTitle%%

PDFDeviceNColorants Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : PDFDeviceNColorants Constructor
Overload List
Overload | Description
PDFDeviceNColorants Constructor | Initilizes a new PDFDeviceNColorants object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


%%PageItemTitle%% $$Methods$$

PDFDeviceNColorNameCollection Class Methods

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorNameCollection Class

For a list of all members of this type, see PDFDeviceNColorNameCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Top
See Also

Reference

PDFDeviceNColorNameCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%% $$Properties$$

PDFDeviceNColorNameCollection Class Properties

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorNameCollection Class

For a list of all members of this type, see PDFDeviceNColorNameCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<string>)
Top
See Also

Reference

PDFDeviceNColorNameCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


%%PageItemTitle%%

PDFICCColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : PDFICCColorSpace Constructor
Overload List
Overload | Description
PDFICCColorSpace Constructor | Initializes a new PDFICCColorSpace object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


%%PageItemTitle%%

PDFLabColorSpace Constructor

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : PDFLabColorSpace Constructor
Overload List
Overload | Description
PDFLabColorSpace Constructor | Initializes a new PDFLabColorSpace object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPatternColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNAttributes
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorants
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorNameCollection
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpaceCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Properties$$

Type0Font Class Properties

O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type0Font Class

For a list of all members of this type, see Type0Font members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Metrics | Gets the metrics of this font object. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

Type0Font Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.Fonts Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.CJKFont
O2S.Components.PDF4NET.Graphics.Fonts.PDFFont
O2S.Components.PDF4NET.Graphics.Fonts.PostScriptFont
O2S.Components.PDF4NET.Graphics.Fonts.TrueTypeFont
O2S.Components.PDF4NET.Graphics.Fonts.Type0Font
O2S.Components.PDF4NET.Graphics.Fonts.Type3Font
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontMetrics
O2S.Components.PDF4NET.Graphics.Fonts.Type3VisualCharCollection
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Fonts.Type3VisualChar
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFAxialShadingPattern Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFAxialShadingPattern Class : PDFAxialShadingPattern Constructor
Overload List
Overload | Description
PDFAxialShadingPattern Constructor | Initializes a new PDFAxialShadingPattern object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAxialShadingPattern Class
PDFAxialShadingPattern Members


%%PageItemTitle%% $$Methods$$

PDFDeviceColor Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceColor Class

For a list of all members of this type, see PDFDeviceColor members.

Public Methods
 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Method | Equals | Verifies if the given object is equal to this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Method | GetHashCode | Gets the hash code of this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Public Method | ToString | Converts the color object to string representation. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
See Also

Reference

PDFDeviceColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PDFDeviceColor Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceColor Class

For a list of all members of this type, see PDFDeviceColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
Top
See Also

Reference

PDFDeviceColor Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFExtendedGraphicState Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : PDFExtendedGraphicState Constructor
Overload List
Overload | Description
PDFExtendedGraphicState Constructor | Initializes a new PDFExtendedGraphicState object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


%%PageItemTitle%% $$Methods$$

PDFGraphicOperatorCollection Class Methods

O2S.Components.PDF4NET.Graphics Namespace : PDFGraphicOperatorCollection Class

For a list of all members of this type, see PDFGraphicOperatorCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Top
See Also

Reference

PDFGraphicOperatorCollection Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PDFGraphicOperatorCollection Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFGraphicOperatorCollection Class

For a list of all members of this type, see PDFGraphicOperatorCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGraphicOperator>)
Top
See Also

Reference

PDFGraphicOperatorCollection Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PDFHorizontalGradientBrush Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFHorizontalGradientBrush Class

For a list of all members of this type, see PDFHorizontalGradientBrush members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Public Property | EndColor | (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Top
See Also

Reference

PDFHorizontalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PDFLayerCollection Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFLayerCollection Class

For a list of all members of this type, see PDFLayerCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Top
See Also

Reference

PDFLayerCollection Class
O2S.Components.PDF4NET.Graphics Namespace


%%PageItemTitle%%

PDFShadingPattern Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPattern Class : PDFShadingPattern Constructor
Overload List
Overload | Description
PDFShadingPattern Constructor | Initializes a new PDFShadingPattern object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFShadingPattern Class
PDFShadingPattern Members


%%PageItemTitle%%

PDFTilingPattern Constructor

O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : PDFTilingPattern Constructor
Overload List
Overload | Description
PDFTilingPattern Constructor | Initializes a new PDFTilingPattern object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


%%PageItemTitle%% $$Properties$$

PDFVerticalGradientBrush Class Properties

O2S.Components.PDF4NET.Graphics Namespace : PDFVerticalGradientBrush Class

For a list of all members of this type, see PDFVerticalGradientBrush members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Public Property | EndColor | (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush)
Top
See Also

Reference

PDFVerticalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.Shadings Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Graphics.Shadings.PDFShading
O2S.Components.PDF4NET.Graphics.Shadings.PDFAxialShading
O2S.Components.PDF4NET.Graphics.Shadings.PDFFunctionShading
O2S.Components.PDF4NET.Graphics.Shadings.PDFRadialShading
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Properties$$

PDFMetafile Class Properties

O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFMetafile Class

For a list of all members of this type, see PDFMetafile members.

Public Properties
 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Dictionary | Gets the form XObject dictionary. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top
See Also

Reference

PDFMetafile Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFColorImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFAlphaChannelMask
See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics.Shapes Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFCcittImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFJpeg2000Image
O2S.Components.PDF4NET.Graphics.Shapes.PDFJpegImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFRawImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFPath
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDF4NET.Annotations.PDFImageAppearance
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile
O2S.Components.PDF4NET.PDFPageBackground
See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Graphics Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Graphics.PDFBasicCanvas
O2S.Components.PDF4NET.Graphics.PDFCanvas
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFHatchBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHorizontalGradientBrush
O2S.Components.PDF4NET.Graphics.PDFVerticalGradientBrush
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFCalGrayColor
O2S.Components.PDF4NET.Graphics.PDFCalRgbColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFCmykColor
O2S.Components.PDF4NET.Graphics.PDFGrayColor
O2S.Components.PDF4NET.Graphics.PDFRgbColor
O2S.Components.PDF4NET.Graphics.PDFDeviceNColor
O2S.Components.PDF4NET.Graphics.PDFICCColor
O2S.Components.PDF4NET.Graphics.PDFIndexedColor
O2S.Components.PDF4NET.Graphics.PDFLabColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor
O2S.Components.PDF4NET.Graphics.PDFShadingPatternColor
O2S.Components.PDF4NET.Graphics.PDFTilingPatternColor
O2S.Components.PDF4NET.Graphics.PDFExtendedGraphicState
O2S.Components.PDF4NET.Graphics.PDFGraphicOperator
O2S.Components.PDF4NET.Graphics.PDFCosObjectParamOperator
O2S.Components.PDF4NET.Graphics.PDFNumericParamOperator
O2S.Components.PDF4NET.Graphics.PDFLayer
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFCMLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFInchLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFMMLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFPointLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFMatrix
O2S.Components.PDF4NET.Graphics.PDFPen
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern
O2S.Components.PDF4NET.Graphics.PDFLinearGradientPattern
O2S.Components.PDF4NET.Graphics.PDFTilingPattern
O2S.Components.PDF4NET.Graphics.PDFHatchPattern
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Graphics.PDFLayerCollection
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.Graphics.PDFGraphicOperatorCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFNumberFormatCollection Class Methods

O2S.Components.PDF4NET.Measures Namespace : PDFNumberFormatCollection Class

For a list of all members of this type, see PDFNumberFormatCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Top
See Also

Reference

PDFNumberFormatCollection Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%% $$Properties$$

PDFNumberFormatCollection Class Properties

O2S.Components.PDF4NET.Measures Namespace : PDFNumberFormatCollection Class

For a list of all members of this type, see PDFNumberFormatCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFNumberFormat>)
Top
See Also

Reference

PDFNumberFormatCollection Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%%

PDFNumberFormatCollection Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormatCollection Class : PDFNumberFormatCollection Constructor
Overload List
Overload | Description
PDFNumberFormatCollection Constructor | Initializes a new PDFNumberFormatCollection object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormatCollection Class
PDFNumberFormatCollection Members


%%PageItemTitle%%

PDFNumberFormat Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFNumberFormat Class : PDFNumberFormat Constructor
Overload List
Overload | Description
PDFNumberFormat Constructor | Initializes a new PDFNumberFormat object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNumberFormat Class
PDFNumberFormat Members


%%PageItemTitle%%

PDFRectilinearMeasure Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFRectilinearMeasure Class : PDFRectilinearMeasure Constructor
Overload List
Overload | Description
PDFRectilinearMeasure Constructor | Initializes a new PDFRectilinearMeasure object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectilinearMeasure Class
PDFRectilinearMeasure Members


%%PageItemTitle%% $$Methods$$

PDFViewportCollection Class Methods

O2S.Components.PDF4NET.Measures Namespace : PDFViewportCollection Class

For a list of all members of this type, see PDFViewportCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Top
See Also

Reference

PDFViewportCollection Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%% $$Properties$$

PDFViewportCollection Class Properties

O2S.Components.PDF4NET.Measures Namespace : PDFViewportCollection Class

For a list of all members of this type, see PDFViewportCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFViewport>)
Top
See Also

Reference

PDFViewportCollection Class
O2S.Components.PDF4NET.Measures Namespace


%%PageItemTitle%%

PDFViewportCollection Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFViewportCollection Class : PDFViewportCollection Constructor
Overload List
Overload | Description
PDFViewportCollection Constructor | Initializes a new PDFViewportCollection object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewportCollection Class
PDFViewportCollection Members


%%PageItemTitle%%

PDFViewport Constructor

O2S.Components.PDF4NET.Measures Namespace > PDFViewport Class : PDFViewport Constructor
Overload List
Overload | Description
PDFViewport Constructor | Initializes a new PDFViewport object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewport Class
PDFViewport Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Measures Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Measures.PDFMeasure
O2S.Components.PDF4NET.Geo.PDFGeospatialMeasure
O2S.Components.PDF4NET.Measures.PDFRectilinearMeasure
O2S.Components.PDF4NET.Measures.PDFNumberFormat
O2S.Components.PDF4NET.Measures.PDFViewport
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.Measures.PDFNumberFormatCollection
O2S.Components.PDF4NET.Measures.PDFViewportCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFPageObjectCollection Class Methods

O2S.Components.PDF4NET.PageObjects Namespace : PDFPageObjectCollection Class

For a list of all members of this type, see PDFPageObjectCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Top
See Also

Reference

PDFPageObjectCollection Class
O2S.Components.PDF4NET.PageObjects Namespace


%%PageItemTitle%% $$Properties$$

PDFPageObjectCollection Class Properties

O2S.Components.PDF4NET.PageObjects Namespace : PDFPageObjectCollection Class

For a list of all members of this type, see PDFPageObjectCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageObject>)
Top
See Also

Reference

PDFPageObjectCollection Class
O2S.Components.PDF4NET.PageObjects Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.PageObjects Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.PageObjects.PDFPageObject
O2S.Components.PDF4NET.PageObjects.PDFImagePageObject
O2S.Components.PDF4NET.PageObjects.PDFPathPageObject
O2S.Components.PDF4NET.PageObjects.PDFTextPageObject
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.PageObjects.PDFPageObjectCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFAValidationErrorCollection Class Methods

O2S.Components.PDF4NET.PDFA Namespace : PDFAValidationErrorCollection Class

For a list of all members of this type, see PDFAValidationErrorCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Top
See Also

Reference

PDFAValidationErrorCollection Class
O2S.Components.PDF4NET.PDFA Namespace


%%PageItemTitle%% $$Properties$$

PDFAValidationErrorCollection Class Properties

O2S.Components.PDF4NET.PDFA Namespace : PDFAValidationErrorCollection Class

For a list of all members of this type, see PDFAValidationErrorCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFAValidationError>)
Top
See Also

Reference

PDFAValidationErrorCollection Class
O2S.Components.PDF4NET.PDFA Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.PDFA Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.PDFA.PDFAValidationErrorCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Properties$$

PDFBookmarkCollection Class Properties

O2S.Components.PDF4NET Namespace : PDFBookmarkCollection Class

For a list of all members of this type, see PDFBookmarkCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top
See Also

Reference

PDFBookmarkCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFBookmark Constructor

O2S.Components.PDF4NET Namespace > PDFBookmark Class : PDFBookmark Constructor
Overload List
Overload | Description
PDFBookmark Constructor | Initializes a new PDFBookmark object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%PageItemTitle%% $$Methods$$

PDFCollection<T,K> Class Methods

O2S.Components.PDF4NET Namespace : PDFCollection<T,K> Class

For a list of all members of this type, see PDFCollection<T,K> members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

PDFCollection<T,K> Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFCollection<T,K> Class Properties

O2S.Components.PDF4NET Namespace : PDFCollection<T,K> Class

For a list of all members of this type, see PDFCollection<T,K> members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

PDFCollection<T,K> Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFDocumentAttachmentCollection Class Methods

O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

For a list of all members of this type, see PDFDocumentAttachmentCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Top
See Also

Reference

PDFDocumentAttachmentCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFDocumentAttachmentCollection Class Properties

O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

For a list of all members of this type, see PDFDocumentAttachmentCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Top
See Also

Reference

PDFDocumentAttachmentCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFDocumentInformation Constructor

O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : PDFDocumentInformation Constructor
Overload List
Overload | Description
PDFDocumentInformation Constructor | Initializes a new PDFDocumentInformation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

PDFDocumentSaveOptions Constructor

O2S.Components.PDF4NET Namespace > PDFDocumentSaveOptions Class : PDFDocumentSaveOptions Constructor
Overload List
Overload | Description
PDFDocumentSaveOptions Constructor | Initializes a new PDFDocumentSaveOptions
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentSaveOptions Class
PDFDocumentSaveOptions Members


GetNamedDestination Method

O2S.Components.PDF4NET Namespace > PDFDocument Class : GetNamedDestination Method
Gets the destination with the specified name from the document.
Overload List
Overload | Description
GetNamedDestination | Gets the destination with the specified name from the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%% $$Methods$$

PDFException Class Methods

O2S.Components.PDF4NET Namespace : PDFException Class

For a list of all members of this type, see PDFException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFException Class Properties

O2S.Components.PDF4NET Namespace : PDFException Class

For a list of all members of this type, see PDFException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFException Class
O2S.Components.PDF4NET Namespace


Dispose Method (PDFFile)

O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : Dispose Method
Closes the underlying pdf file and frees all resources.
Overload List
Overload | Description
Dispose | Closes the underlying pdf file and frees all resources.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.PDFFile Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.PDFFile.PDFFile
O2S.Components.PDF4NET.PDFFile.PDFImportedPageInfo
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.PDFFile.PDFImportedContent
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedPage
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFInvalidPasswordException Class Methods

O2S.Components.PDF4NET Namespace : PDFInvalidPasswordException Class

For a list of all members of this type, see PDFInvalidPasswordException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFInvalidPasswordException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFInvalidPasswordException Class Properties

O2S.Components.PDF4NET Namespace : PDFInvalidPasswordException Class

For a list of all members of this type, see PDFInvalidPasswordException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFInvalidPasswordException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFInvalidPDFAFormatException Class Methods

O2S.Components.PDF4NET Namespace : PDFInvalidPDFAFormatException Class

For a list of all members of this type, see PDFInvalidPDFAFormatException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFInvalidPDFAFormatException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFJavaScriptCollection Class Properties

O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

For a list of all members of this type, see PDFJavaScriptCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Top
See Also

Reference

PDFJavaScriptCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFMetadataSchemaCollection Class Methods

O2S.Components.PDF4NET Namespace : PDFMetadataSchemaCollection Class

For a list of all members of this type, see PDFMetadataSchemaCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Top
See Also

Reference

PDFMetadataSchemaCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFMetadataSchemaCollection Class Properties

O2S.Components.PDF4NET Namespace : PDFMetadataSchemaCollection Class

For a list of all members of this type, see PDFMetadataSchemaCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Top
See Also

Reference

PDFMetadataSchemaCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFOutputIntentCollection Class Methods

O2S.Components.PDF4NET Namespace : PDFOutputIntentCollection Class

For a list of all members of this type, see PDFOutputIntentCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Top
See Also

Reference

PDFOutputIntentCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFOutputIntentCollection Class Properties

O2S.Components.PDF4NET Namespace : PDFOutputIntentCollection Class

For a list of all members of this type, see PDFOutputIntentCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFOutputIntent>)
Top
See Also

Reference

PDFOutputIntentCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFOutputIntentCollection Constructor

O2S.Components.PDF4NET Namespace > PDFOutputIntentCollection Class : PDFOutputIntentCollection Constructor
Overload List
Overload | Description
PDFOutputIntentCollection Constructor | Initializes a new PDFOutputIntentCollection object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntentCollection Class
PDFOutputIntentCollection Members


%%PageItemTitle%%

PDFOutputIntent Constructor

O2S.Components.PDF4NET Namespace > PDFOutputIntent Class : PDFOutputIntent Constructor
Overload List
Overload | Description
PDFOutputIntent Constructor | Initializes a new PDFOutputIntent object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFOutputIntent Class
PDFOutputIntent Members


%%PageItemTitle%% $$Methods$$

PDFPageCollection Class Methods

O2S.Components.PDF4NET Namespace : PDFPageCollection Class

For a list of all members of this type, see PDFPageCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top
See Also

Reference

PDFPageCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFPageCollection Class Properties

O2S.Components.PDF4NET Namespace : PDFPageCollection Class

For a list of all members of this type, see PDFPageCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top
See Also

Reference

PDFPageCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageDestination Constructor

O2S.Components.PDF4NET Namespace > PDFPageDestination Class : PDFPageDestination Constructor
Overload List
Overload | Description
PDFPageDestination Constructor | Initializes a new PDFPageDestination object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


%%PageItemTitle%% $$Methods$$

PDFPageNumberingRangeCollection Class Methods

O2S.Components.PDF4NET Namespace : PDFPageNumberingRangeCollection Class

For a list of all members of this type, see PDFPageNumberingRangeCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Top
See Also

Reference

PDFPageNumberingRangeCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFPageNumberingRangeCollection Class Properties

O2S.Components.PDF4NET Namespace : PDFPageNumberingRangeCollection Class

For a list of all members of this type, see PDFPageNumberingRangeCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Top
See Also

Reference

PDFPageNumberingRangeCollection Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFPageNumberingRange Constructor

O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : PDFPageNumberingRange Constructor
Overload List
Overload | Description
PDFPageNumberingRange Constructor | Initializes a new PDFPageNumberingRange object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


%%PageItemTitle%%

PDFPage Constructor

O2S.Components.PDF4NET Namespace > PDFPage Class : PDFPage Constructor
Overload List
Overload | Description
PDFPage Constructor | Initializes a new PDFPage object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%% $$Methods$$

PDFParserException Class Methods

O2S.Components.PDF4NET Namespace : PDFParserException Class

For a list of all members of this type, see PDFParserException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFParserException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFParserException Class Properties

O2S.Components.PDF4NET Namespace : PDFParserException Class

For a list of all members of this type, see PDFParserException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFParserException Class
O2S.Components.PDF4NET Namespace


%%PageItemTitle%%

PDFRemotePageDestination Constructor

O2S.Components.PDF4NET Namespace > PDFRemotePageDestination Class : PDFRemotePageDestination Constructor
Overload List
Overload | Description
PDFRemotePageDestination Constructor | Initializes a new PDFRemotePageDestination object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemotePageDestination Class
PDFRemotePageDestination Members


%%PageItemTitle%%

PDFSeparationInfo Constructor

O2S.Components.PDF4NET Namespace > PDFSeparationInfo Class : PDFSeparationInfo Constructor
Overload List
Overload | Description
PDFSeparationInfo Constructor | Initializes a new PDFSeparationInfo object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


%%PageItemTitle%%

PDFVersionExtension Constructor

O2S.Components.PDF4NET Namespace > PDFVersionExtension Class : PDFVersionExtension Constructor
Overload List
Overload | Description
PDFVersionExtension Constructor | Initializes a new PDFVersionExtension object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFVersionExtension Class
PDFVersionExtension Members


%%PageItemTitle%%

PDFViewerPreferences Constructor

O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : PDFViewerPreferences Constructor
Overload List
Overload | Description
PDFViewerPreferences Constructor | Initializes a new PDFViewerPreferences object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

PDFXMPMetadata Constructor

O2S.Components.PDF4NET Namespace > PDFXMPMetadata Class : PDFXMPMetadata Constructor
Overload List
Overload | Description
PDFXMPMetadata Constructor | Initializes a new PDFXMPMetadata object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


%%PageItemTitle%%

PDFPortfolioAttributes Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioAttributes Class : PDFPortfolioAttributes Constructor
Overload List
Overload | Description
PDFPortfolioAttributes Constructor | Initializes a new PDFPortfolioAttributes object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioAttributes Class
PDFPortfolioAttributes Members


%%PageItemTitle%% $$Methods$$

PDFPortfolioFolderCollection Class Methods

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioFolderCollection Class

For a list of all members of this type, see PDFPortfolioFolderCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Top
See Also

Reference

PDFPortfolioFolderCollection Class
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%% $$Properties$$

PDFPortfolioFolderCollection Class Properties

O2S.Components.PDF4NET.Portfolios Namespace : PDFPortfolioFolderCollection Class

For a list of all members of this type, see PDFPortfolioFolderCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPortfolioFolder>)
Top
See Also

Reference

PDFPortfolioFolderCollection Class
O2S.Components.PDF4NET.Portfolios Namespace


%%PageItemTitle%%

PDFPortfolioInformation Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioInformation Class : PDFPortfolioInformation Constructor
Overload List
Overload | Description
PDFPortfolioInformation Constructor | Initializes a new PDFPortfolioInformation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioInformation Class
PDFPortfolioInformation Members


%%PageItemTitle%%

PDFPortfolioSchemaField Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchemaField Class : PDFPortfolioSchemaField Constructor
Overload List
Overload | Description
PDFPortfolioSchemaField Constructor | Initializes a new PDFPortfolioSchemaField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchemaField Class
PDFPortfolioSchemaField Members


%%PageItemTitle%%

PDFPortfolioSchema Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSchema Class : PDFPortfolioSchema Constructor
Overload List
Overload | Description
PDFPortfolioSchema Constructor | Initializes a new PDFPortfolioSchema object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSchema Class
PDFPortfolioSchema Members


%%PageItemTitle%%

PDFPortfolioSortInformation Constructor

O2S.Components.PDF4NET.Portfolios Namespace > PDFPortfolioSortInformation Class : PDFPortfolioSortInformation Constructor
Overload List
Overload | Description
PDFPortfolioSortInformation Constructor | Initializes a new PDFPortfolioSortInformation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPortfolioSortInformation Class
PDFPortfolioSortInformation Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Portfolios Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Portfolios.PDFPortfolioAttributes
O2S.Components.PDF4NET.Portfolios.PDFPortfolioFolder
O2S.Components.PDF4NET.Portfolios.PDFPortfolioInformation
O2S.Components.PDF4NET.Portfolios.PDFPortfolioSchema
O2S.Components.PDF4NET.Portfolios.PDFPortfolioSchemaField
O2S.Components.PDF4NET.Portfolios.PDFPortfolioSortInformation
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Portfolios.PDFPortfolioFolderCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%%

PDFDigitalSignature Constructor

O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : PDFDigitalSignature Constructor
Overload List
Overload | Description
PDFDigitalSignature Constructor | Initializes a new PDFDigitalSignature object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Security Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Security.PDFDigitalSignature
O2S.Components.PDF4NET.Security.PDFSecurityManager
See Also

Reference

O2S.Components.PDF4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFGlyphCollection Class Methods

O2S.Components.PDF4NET.Text Namespace : PDFGlyphCollection Class

For a list of all members of this type, see PDFGlyphCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Top
See Also

Reference

PDFGlyphCollection Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFGlyphCollection Class Properties

O2S.Components.PDF4NET.Text Namespace : PDFGlyphCollection Class

For a list of all members of this type, see PDFGlyphCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Top
See Also

Reference

PDFGlyphCollection Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Methods$$

PDFSearchTextResultCollection Class Methods

O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResultCollection Class

For a list of all members of this type, see PDFSearchTextResultCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top
See Also

Reference

PDFSearchTextResultCollection Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFSearchTextResultCollection Class Properties

O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResultCollection Class

For a list of all members of this type, see PDFSearchTextResultCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top
See Also

Reference

PDFSearchTextResultCollection Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Methods$$

PDFTextRunCollection Class Methods

O2S.Components.PDF4NET.Text Namespace : PDFTextRunCollection Class

For a list of all members of this type, see PDFTextRunCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top
See Also

Reference

PDFTextRunCollection Class
O2S.Components.PDF4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFTextRunCollection Class Properties

O2S.Components.PDF4NET.Text Namespace : PDFTextRunCollection Class

For a list of all members of this type, see PDFTextRunCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top
See Also

Reference

PDFTextRunCollection Class
O2S.Components.PDF4NET.Text Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET.Text Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.Text.PDFGlyph
O2S.Components.PDF4NET.Text.PDFSearchTextResult
O2S.Components.PDF4NET.Text.PDFTextRun
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDF4NET.Text.PDFGlyphCollection
O2S.Components.PDF4NET.Text.PDFSearchTextResultCollection
O2S.Components.PDF4NET.Text.PDFTextRunCollection
See Also

Reference

O2S.Components.PDF4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDF4NET Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDF4NET.DisplayRectangle
O2S.Components.PDF4NET.PDFBookmark
O2S.Components.PDF4NET.PDFCustomProperties
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination
O2S.Components.PDF4NET.PDFPageDestination
O2S.Components.PDF4NET.PDFRemotePageDestination
O2S.Components.PDF4NET.PDFDocument
O2S.Components.PDF4NET.PDFDocumentAttachment
O2S.Components.PDF4NET.PDFDocumentInformation
O2S.Components.PDF4NET.PDFDocumentLoadOptions
O2S.Components.PDF4NET.PDFDocumentSaveOptions
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Fonts.Type3VisualChar
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern
O2S.Components.PDF4NET.Graphics.PDFLinearGradientPattern
O2S.Components.PDF4NET.Graphics.PDFTilingPattern
O2S.Components.PDF4NET.Graphics.PDFHatchPattern
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDF4NET.Annotations.PDFImageAppearance
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile
O2S.Components.PDF4NET.PDFPageBackground
O2S.Components.PDF4NET.PDFFile.PDFImportedContent
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedPage
O2S.Components.PDF4NET.PDFJavaScript
O2S.Components.PDF4NET.PDFMetadataSchema
O2S.Components.PDF4NET.PDFOutputIntent
O2S.Components.PDF4NET.PDFPageNumber
O2S.Components.PDF4NET.PDFPageNumberingRange
O2S.Components.PDF4NET.PDFPoint
O2S.Components.PDF4NET.PDFRectangle
O2S.Components.PDF4NET.PDFSeparationInfo
O2S.Components.PDF4NET.PDFVersionExtension
O2S.Components.PDF4NET.PDFViewerPreferences
O2S.Components.PDF4NET.PDFXMPMetadata
O2S.Components.PDF4NET.XDPPackage
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T,K>
O2S.Components.PDF4NET.Annotations.PDFAnnotationCollection
O2S.Components.PDF4NET.Annotations.PDFPointsCollection
O2S.Components.PDF4NET.Forms.FDFFieldCollection
O2S.Components.PDF4NET.Forms.PDFCalculatedFieldCollection
O2S.Components.PDF4NET.Forms.PDFFieldCollection
O2S.Components.PDF4NET.Forms.PDFFieldWidgetCollection
O2S.Components.PDF4NET.Forms.PDFListItemCollection
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection
O2S.Components.PDF4NET.Forms.XFDFFieldCollection
O2S.Components.PDF4NET.Graphics.PDFLayerCollection
O2S.Components.PDF4NET.PDFBookmarkCollection
O2S.Components.PDF4NET.PDFDocumentAttachmentCollection
O2S.Components.PDF4NET.PDFJavaScriptCollection
O2S.Components.PDF4NET.PDFMetadataSchemaCollection
O2S.Components.PDF4NET.PDFOutputIntentCollection
O2S.Components.PDF4NET.PDFPageCollection
O2S.Components.PDF4NET.PDFPageNumberingRangeCollection
O2S.Components.PDF4NET.Portfolios.PDFPortfolioFolderCollection
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.Cos.IncompatiblePDFObjectException
O2S.Components.PDF4NET.Cos.InvalidPDFValueException
O2S.Components.PDF4NET.PDFInvalidPasswordException
O2S.Components.PDF4NET.PDFInvalidPDFAFormatException
O2S.Components.PDF4NET.PDFParserException
See Also

Reference

O2S.Components.PDF4NET Assembly


PDF file

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


PDF support for presentations
PDF files may include basic presentation features, such as automatic advance to the next page and transition effects when advancing from one page to the next one. In this way, the document can be displayed in the form of a slide show.

The presentation features are controlled by the PDFPageTransition class. This class specifies the type of transition effect between page, the display duration of a page and the transition duration to the next page.

In order to enable the presentation features, each page of the document must have attached a PDFPageTransition object, using the Transition property of the page. The display duration of a page is controlled by the PageDuration property, and the transition duration is controlled by the TransitionDuration property. Both properties are specified in seconds. The TransitionDuration for a page controls the transition between the previous page and that page. This rule also applies to the transition effect.

The PageDuration controls the display duration of a page. If it is zero or the page does not have a transition object, then the viewer does not automatically advance to the next page. Also, the next page must have attached a transition object to specify the transition effect and the transition duration between the first page and the next page, in order to have automatic advance.

Note: The presentation features are optional and may not be implemented by all viewers.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: RandomAccess
Samples

RandomAccess

This sample shows the possibilities of random accessing each page of the document. It creates a document with 10 pages, then the pages are access in a random order. On each page it is written the time of access. To better observe the random access, between page writes, there is a few seconds delay.

C# Source code | PDF file

© 2003 - 2007 O2 Solutions. All rights reserved.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: SlideShow
Samples

SlideShow

This samples shows the transition effects available in pdf files. This sample is identical with SimpleGrid sample, but it uses transition effects when passing from one page to another.
This sample uses authors.xml file found in \bin folder.

C# Source code | VB.NET Source code | PDF file

� 2003 - 2007 O2 Solutions. All rights reserved.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Samples: Templates
Samples

Templates

This samples shows template capabilites of the PDF4NET library. A template is created from an existing PDF page. Then it imports a PDF document, adds 10 additional pages and attached the template to the document. The template is drawn under existing page content.

C# Source code | VB.NET Source code | PDF file

© 2003 - 2007 O2 Solutions. All rights reserved.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you


SlideShow.vb
''File name: SlideShow.vb' ImportsSystemImportsSystem.DataImportsSystem.DrawingImportsO2S.Components.PDF4NETImportsO2S.Components.PDF4NET.GraphicsImportsO2S.Components.PDF4NET.Graphics.ShapesNamespaceO2S.Samples.PDF4NET.SlideShow '/ <summary>'/ This sample will show the presentation capabilities'/ of the pdf document. The report in SimpleGrid sample'/ uses now transitions to automatically advance from'/ one page to the next.'/ </summary>ClassSlideShow PrivateSharedleftMargin AsSingle=15PrivateSharedrightMargin AsSingle=15PrivateSharedtopMargin AsSingle=20PrivateSharedminBottomMargin AsSingle=20PrivateSharedrowHeight AsSingle=30PrivateSharedheaderHeight AsSingle=30PrivateSharedfirstPageTopOffset AsSingle=50PrivateSharedcolumnsWidth AsSingle() ={80, 100, 100, 90, 212, 90, 40, 50} PrivateSharedcolumnsHeader AsString() ={"Author ID", "First name", "Last name", "Phone", "Address", "City", "State", "ZIP"} SharedSubMain() 'Create the graphic objectsDimfontTitle AsNewPDFFont(FontFace.Helvetica, 20) DimblackBrush AsNewPDFBrush(NewPDFColor()) 'Create the pdf documentDimpdfDoc AsNewPDFDocument() 'Set the document to be Landscape orientedpdfDoc.PageOrientation =PageOrientation.Landscape 'Create the transition objectDimtrans AsNewPDFPageTransition() trans.Effect =PageTransitionEffect.Box trans.PageDuration =2trans.TransitionDuration =2trans.TransitionMotionDirection =TransitionMotionDirection.Outward 'Create first page of the reportDimpage AsPDFPage =pdfDoc.AddPage() 'Add the transition to the pagepage.Transition =trans 'Draw the title of the reportpage.Canvas.DrawText("Authors - with transition effects", fontTitle, Nothing, blackBrush, page.Width /2, 15, 0, TextAlign.TopCenter) 'Draw report headerDrawReportHeader(page, firstPageTopOffset) 'Create the datasetDimds AsNewDataSet() 'Load the datasetds.ReadXml("authors.xml", XmlReadMode.ReadSchema) 'Get the table from the datasetDimauthors AsDataTable =ds.Tables(0) 'rowOffset - specifies the vertical position where a row'should begin to be printedDimrowOffset AsSingle=firstPageTopOffset +headerHeight Dimi AsIntegerFori =0Toauthors.Rows.Count -1IfrowOffset +rowHeight >page.Height -minBottomMargin Then'not enough space to draw a new row, then create a new page, 'draw the header, then draw the rows.page =pdfDoc.AddPage() 'set the transition effect for the pagepage.Transition =trans DrawReportHeader(page, topMargin) rowOffset =topMargin +headerHeight EndIfDrawReportRow(page, rowOffset, authors.Rows(i)) rowOffset =rowOffset +rowHeight Nexti 'Save the document to diskpdfDoc.SaveToFile("slideshow.pdf") End Sub'MainPrivateSharedSubDrawReportHeader(ByValpdfPage AsPDFPage, ByValtopOffset AsSingle) 'Create the graphic objectsDimfontHeader AsNewPDFFont(FontFace.Helvetica, 12) fontHeader.Bold =TrueDimborderColor AsNewPDFPen(NewPDFColor(), 1) DimtextColor AsNewPDFBrush(NewPDFColor()) DimheaderFill AsNewPDFBrush(NewPDFColor(192, 192, 192)) 'Draw the headerpdfPage.Canvas.DrawRectangle(borderColor, headerFill, topOffset, leftMargin, pdfPage.Width -leftMargin -rightMargin, headerHeight) Dimi AsIntegerDimxOffset AsSingle=leftMargin 'Draw the columns separatorsFori =0To(columnsWidth.Length -1) -1xOffset =xOffset +columnsWidth(i) pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset +headerHeight) Nexti xOffset =leftMargin 'Draw the columns headerFori =0TocolumnsWidth.Length -1pdfPage.Canvas.DrawText(columnsHeader(i), fontHeader, Nothing, textColor, xOffset +columnsWidth(i) /2, topOffset +headerHeight /2, 0, TextAlign.MiddleCenter) xOffset =xOffset +columnsWidth(i) Nexti End Sub'DrawReportHeaderPrivateSharedSubDrawReportRow(ByValpdfPage AsPDFPage, ByValtopOffset AsSingle, ByValrow AsDataRow) 'Create the graphic objectsDimfontText AsNewPDFFont(FontFace.Helvetica, 12) DimborderColor AsNewPDFPen(NewPDFColor(), 1) DimtextColor AsNewPDFBrush(NewPDFColor()) DimheaderFill AsNewPDFBrush(NewPDFColor(192, 192, 192)) 'Draw rows bordersDimpoints AsPointF() ={NewPointF(leftMargin, topOffset), NewPointF(leftMargin, topOffset +rowHeight), NewPointF(pdfPage.Width -rightMargin, topOffset +rowHeight), NewPointF(pdfPage.Width -rightMargin, topOffset)} pdfPage.Canvas.DrawLines(borderColor, points) Dimi AsIntegerDimxOffset AsSingle=leftMargin 'Draw the columns separatorsFori =0To(columnsWidth.Length -1) -1xOffset =xOffset +columnsWidth(i) pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset +rowHeight) Nexti xOffset =leftMargin 'Draw the columns headerFori =0TocolumnsWidth.Length -1pdfPage.Canvas.DrawText(CStr(row(i)), fontText, Nothing, textColor, xOffset +2, topOffset +rowHeight /2, 0, TextAlign.MiddleLeft) xOffset =xOffset +columnsWidth(i) Nexti End Sub'DrawReportRow End Class'SlideShowEnd Namespace'O2S.Samples.PDF4NET.SlideShow

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


Templates.vb
''File name: Templates.vb' ImportsSystemImportsSystem.DrawingImportsO2S.Components.PDF4NETImportsO2S.Components.PDF4NET.GraphicsImportsO2S.Components.PDF4NET.Graphics.Shapes'/ <summary>'/ This sample will show how to use common content'/ on multiple pages using templates. '/ </summary>ClassTemplates <STAThread()>_ SharedSubMain(ByValargs() AsString) 'The default page size is letterConstwidth AsInteger=612Constheight AsInteger=792'Create the graphic objects DimfontText AsNewPDFFont(FontFace.Helvetica, 12) DimfontTitle AsNewPDFFont(FontFace.Helvetica, 72) DimblackBrush AsNewPDFBrush(NewPDFColor) DimblackPen AsNewPDFPen(NewPDFColor, 1) 'Import a sample pdf documentDimpdfDoc AsNewPDFDocument("sample.pdf") 'Create the template from a PDF file and attach it to the documentDimtmpl AsNewPDFPageTemplate("one-page-template.pdf", 0, 0, 0, width, height) pdfDoc.PageTemplate =tmpl 'Create 10 additional pagesDimi AsIntegerFori =0To9DimpdfPage AsPDFPage =pdfDoc.AddPage() Ifi >0ThenpdfPage.Canvas.DrawText("Page "+i.ToString(), fontTitle, Nothing, blackBrush, pdfPage.Width /2, pdfPage.Height /2, 0, TextAlign.MiddleCenter) EndIfNexti 'Do not apply the template on 6th pagepdfDoc.Pages(5).ApplyTemplate =False'Draw the title on the 6th page (the first of the newly 10 added pages)pdfDoc.Pages(5).Canvas.DrawText("Templates", fontTitle, Nothing, blackBrush, pdfDoc.Pages(0).Width /2, pdfDoc.Pages(0).Height /2, 0, TextAlign.MiddleCenter) 'Save the document to diskpdfDoc.SaveToFile("templates.pdf") End Sub'MainEnd Class'Templates

© O2 Solutions. All Rights Reserved.

Send comments on this topic.