%%ItemTitle%%

PDFView4NET WinForms Edition
Getting started

This section will help you get started with PDFView4NET toolkit. It includes information on installing and configuring PDFView4NET toolkit, features included in the toolkit. It also presents information on licensing and deployment of PDFView4NET assemblies.

  • Installation
    Shows information on installing and configuring PDFView4NET toolkit to work with Visual Studio .Net 2005.
  • What's included in the installation kit
    Shows the content of the installation kit at file level.
  • Features
    See the complete list of features supported by PDFView4NET.
  • What's New
    Shows the version history and release notes for PDFView4NET toolkit.
  • Licensing
    Shows the license agreement for PDFView4NET toolkit.
  • License activation
    Shows how to activate the license for PDFView4NET toolkit and remove the evaluation message.
  • Deployment
    Provides information on how to deploy PDFView4NET assemblies with your applications.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Installation

This section describes the installation steps that need to be performed in order to have a fully working PDFView4NET installation on your computer. Some of the steps are automatic, but other need to be performed manually. The steps need to be performed in the order they are presented, but optional steps that do not apply to the edition you purchased may be skipped.

  1. Install PDFView4NET on your computer
    Shows the steps to perform for running the setup kit and installing the PDFView4NET toolkit on computer's disk.
  2. Add PDFView4NET to Visual Studio toolbox
    Shows how to install PDFVeiw4NET components into Visual Studio toolbox.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Installing PDFView4NET on your computer

After downloading PDFView4NET toolkit from our website, run the setup package to install PDFView4NET files on your computer's disk. The setup process is very easy, just click Next in the setup dialogs and the toolkit will be installed on your computer's disk. By default the PDFView4NET toolkit is installed in <Program Files> folder, but this can be changed during the setup.

When the setup process has finished, perform the next step in order to have a fully working PDFView4NET installation on your computer.

  1. Add PDFView4NET to Visual Studio toolbox
    Shows how to install PDFView4NET components into Visual Studio toolbox.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Adding PDFView4NET Windows Forms controls to Visual Studio toolbox

After Barcode4NET toolkit has been installed on your computer's disk, the Barcode4NET assemblies are located in the \bin folder of the installation location.

  1. Start Visual Studio .Net 2005 and create a new Windows Forms application. Make sure that the application form is in design mode and the components toolbox is displayed. Right click on the toolbox and select Add tab from the menu.

    ImageTitle
  2. Type "PDFView4NET" as tab name and press Enter.

    ImageTitle
  3. Right click on PDFView4NET tab, select Choose items from the menu and Choose toolbox items dialog will be displayed. Make sure .NET Framework Components tab is selected.
    Select PDFAnnotationsView, PDFBookmarksView, PDFDocument, PDFFileAttachmentsView and PDFPageView controls in the list. If they are not displayed in the list, click Browse button and locate O2S.Components.PDFView4NET.dll assembly on your computer's disk.

    ImageTitle
    Click OK.
  4. BarcodeView and BarcodeTextBox controls are now available in the toolbox.

    ImageTitle

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

What's included in the installation kit

After installing PDFView4NET toolkit, the following files and folders will be present on your computer's disk:

Bin\o2s.components.pdfrender4net.dll - PDFRender4NET class library for PDF rendering and printing.
Bin\o2s.components.pdfrender4net.xml - Intellisense file.
Bin\o2s.components.pdfview4net.dll - PDFView4NET controls for Windows forms.
Bin\o2s.components.pdfview4net.xml - Intellisense file.

Help\ - PDFView4NET help files

Samples\ - C# and VB.NET samples

SupportFiles\ - PDF files used with the samples.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Features

PDFView4NET is a .NET toolkit for adding PDF render and print support in .NET applications. It includes a PDF viewer control for Windows Forms and a .NET library for rendering and printing PDF files from any .NET application. The PDF viewer control for Windows Forms includes support for annotating PDF files, bookmarks navigation, adding and removing file attachments and other features. The toolkit includes its own PDF rendering engine and it does not rely on any other software for rendering and printing PDF files. PDFView4NET toolkit has been developed entirely in C#, being 100% managed code.

The main features of PDFView4NET toolkit are outlined below.

PDF Rendering
General
Support for .NET 2.0 to .NET 4.5 | Yes
Load documents from file and stream | Yes
Support for encrypted files, both RC4 40/128bit and AES 128bit are supported | Yes
Render PDF files to Bmp, Gif, Jpeg, Png or Tiff | Yes
Render PDF files to System.Drawing.Graphics | Yes
Render content based on layer visibility | Yes
Filters and compression
FlateDecode | Yes
LZWDecode | Yes
ASCII85Decode | Yes
ASCIIHexDecode | Yes
DCTDecode | Yes
CCITTFaxDecode | Yes
JPXDecode | Yes
JBIG2Decode | Yes
Images
RAW, JPEG, CCITT, JPEG2000, JBIG2 | Yes
Inline images | Yes
Soft masks, image masks and chroma key masks | Yes
Fonts
Standard PDF fonts | Yes
Embedded fonts | Yes
CID-keyed fonts | Yes
TrueType | Yes
Type 1 (CFF and Postscript) | Yes
Type 3 | Yes
Colorspaces
Device colorspaces: RGB, CMYK and Gray | Yes
Calibrated colorspaces: CalRGB, CalGray, Lab and ICC | Yes
Separation | Yes
DeviceN | Yes
Indexed | Yes
Printing
Print PDF files to any Windows printer | Yes
Print page content and/or annotations and/or form fields | Yes
Auto-rotate and center | Yes
Print custom page range | Yes
Multiple print scaling options | Yes
Print multiples pages per sheet (2-up, 4-up, n-up) | Yes
Print custom content under and on top of printed PDF page | Yes
PDF View Windows Forms controls
General
All PDF rendering features | Yes
Support for .NET 2.0 to .NET 4.5 Windows Forms | Yes
Load documents from file and stream | Yes
Support for encrypted files (load and save), both RC4 40/128bit and AES 128bit are supported | Yes
Navigation
Zoom (absolute, fit width, fit height, zoom in, zoom out, dynamic zoom, marquee zoom) | Yes
Pan | Yes
Rotate pages | Yes
PDFBookmarksView control for displaying bookmarks and navigating within the document | Yes
Single page, one column and two columns page display layouts |
PDFPageThumbnailView control for displaying page thumbnails and navigating within the document | Yes
Annotations
Display all annotations | Yes
Standard and owner draw annotation tooltips | Yes
Add/Edit text, free text, ellipse, file attachment, ink, line, rectangle, stamp, link, highlight, underline, strikeout and barcode annotations | Yes
Create text and stamp annotations with custom appearance | Yes
Annotation tooltips and popup windows. | Yes
Delete any annotation | Yes
PDFAnnotationsView control for displaying all the annotations in a document (similar to Adobe Acrobat) | Yes
PDF forms
User interactive form design | Yes
Add, edit and remove form fields | Yes
User interactive form filling | Yes
Create and fill forms from code | Yes
Pushbutton, checkbox, radiobutton, dropdown list and listbox fields | Yes
Field tooltips | Yes
Save filled forms | Yes
Text
Extract page text | Yes
Search text and highlight search results | Yes
Text selection and copy | Yes
Document attachments
Add/Edit/Delete file attachments | Yes
PDFFileAttachmentsView control for displaying all the attachments in a document (similar to Adobe Acrobat) | Yes
Design-time support
Visual Studio .NET 2005/2008/2010/2012 WinForms designer | Yes
Package content
PDFView4NET controls for Windows Forms | Yes
PDFRender4NET class library for .NET | Yes
PDF rendering library licensed for WinForms and console applications, windows services, ASP.NET applications and web services | Yes
Integrated help system | Yes
Licensing
Per developer licensing | Yes
Royalty free distribution | Yes

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

What's New

March 1, 2017 - PDFView4NET 5.0.0 WinForms Edition release
PDFView4NET 5.0.0 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Display page content based on layer visibility
— Some documents are not rendered correctly - fixed
— Some text is not rendered correctly - fixed
— Some inline images are not decoded - fixed
— Sampled function is not computed correctly - fixed
PDF Viewer:
— Zero width clip paths are not handled correctly in thumbnails - fixed

December 21, 2016 - PDFView4NET 4.7.6 WinForms Edition release
PDFView4NET 4.7.6 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some PDF files cannot be loaded - fixed
— Some TrueType glyphs are not rendered correctly - fixed
— Dashed lines with round line caps are not drawn correctly - fixed
— Some files with direct referenced fonts in resources cannot be converte to image - fixed
— Zero width clip paths are not handled correctly - fixed

August 31, 2016 - PDFView4NET 4.7.5 WinForms Edition release
PDFView4NET 4.7.5 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— WinAnsi encoded text is not displayed when the font does not exist in the /Resources dictionary - fixed
— Some /Identity-H encoded text is not displayed correctly - fixed
— Separation color (with Lab alternate colorspace) is not rendered correctly - fixed
— Pages rotated with 360 degrees are not converted correctly to image - fixed
— Some CFF fonts are not rendered correctly - fixed
— Some Type1 fonts are not decoded correctly - fixed
— JPEG2000 images with reversed Decode array are not displayed correctly - fixed
— Some PDF files with invalid circular references cannot be loaded - fixed
PDF Viewer:
— Page rendering error event is not fired in PDFPageView control - fixed
— Annotations cannot be added to pages rotated with 360 degrees - fixed

May 4, 2016 - PDFView4NET 4.7.4 WinForms Edition release
PDFView4NET 4.7.4 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Documents with invalid page objects in Pages tree cannot be loaded - fixed
— Some inline images are not decoded correctly - fixed
— Some characters are not displayed due to encoding issues - fixed
— Files over 2GB cannot be loaded - fixed
— Text position is not computed correctly for some Type3 fonts - fixed
— Some umlaut characters are not displayed - fixed
— Separation indexed images cannot be rendered - fixed
— Button fields are not rendered correctly in some situations - fixed
— Some fonts with cmap based encoding cannot be rendered - fixed
— Pages that contain 0 width/height images cannot be displayed - fixed
PDF Viewer:
— Opening and closing quickly a viewer form cause an exception in some situations - fixed
— Text selection in form fields cause exception in some scenarios - fixed

February 3, 2016 - PDFView4NET 4.7.3 WinForms Edition release
PDFView4NET 4.7.3 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some CFF fonts are not rendered correctly - fixed
— Files that contain comments in trailer cannot be loaded - fixed
— Some RLE images cannot be decoded - fixed
— Some images are not decoded correctly - fixed
— Arial Black font is rendered as Arial when it is not embedded in the PDF file - fixed
— Closing bracket ')' is not rendered correctly for some fonts - fixed
— Annotation appearance is not rendered when the appearance entry is an indirect reference - fixed
— Some embedded images are not decoded correctly - fixed
PDF Viewer:
— When UseWinFormsControlsForFormFields property is true the form field's MaxLength is ignored - fixed
— Field values in FDF files that contain escaped character cannot be imported - fixed
— Size of line annotation grows when the annotation is rotated - fixed
— The PDFAnnotationsView.Document property cannot be set to another value after it has been set to an initial value - fixed
— The PDFFileAttachmentsView.Document property cannot be set to another value after it has been set to an initial value - fixed

September 4, 2015 - PDFView4NET 4.7.2 WinForms Edition release
PDFView4NET 4.7.2 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some text is not rendered correctly - fixed
— CalGray images are not rendered - fixed
— Text with CFF font is rendered flipped on horizontal - fixed
PDF Viewer:
— Setting the ZoomMode to FitWidth resets the displayed page to 0 - fixed
— Mouse wheel does not update the page number the same way like the scrollbar - fixed

July 24, 2015 - PDFView4NET 4.7.1 WinForms Edition release
PDFView4NET 4.7.1 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— If file attachments are not indirect objects they are not loaded - fixed
— Custom XMP metadata is lost when the document is saved - fixed
— Type3 fonts with external resources are not rendered correctly - fixed
— 4bpp Gray images are not decoded correctly - fixed
— Some JBIG2 images are not decoded correctly - fixed
— Pages with invalid annotation appearances (no bbox) cannot be rendered - fixed
PDF Viewer:
— Checkboxes that include spaces in their export values cannot be unchecked - fixed

February 06, 2015 - PDFView4NET 4.7.0 WinForms Edition release
PDFView4NET 4.7.0 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Type 3 fonts
— In some situations clipping regions with zero width/height were not applied - fixed
— Some embedded images are not decoded correctly - fixed
— In some situations the checkbox marks are not printed - fixed
— A stencil mask is not drawn correctly if it is painted multiple times on the page - fixed
— Fields with empty BG entry are painted in black - fixed
— 8pp images with reversed /Decode array are not displayed correctly - fixed
— Stencil mask is not applied on CCITT 1bpp images - fixed
— Some JBIG2 images are not rendered correctly - fixed
— Some forms are rendered very slowly because fonts are not cached - fixed
PDF Viewer:
— Newly added free text annotations in a PDFDocument are not printed using the specified font and size - fixed
— Vertical scrollbars are missing in multine textbox fields when standard Windows textbox is used for editing - fixed

June 30, 2014 - PDFView4NET 4.6.2 WinForms Edition release
PDFView4NET 4.6.2 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— For some barcode fonts spaces are displayed instead of the glyph associated with the space character - fixed
— In some situations the checkmarks in checkbox fields are not displayed correctly - fixed
— Images with indexed colorspace based on DeviceN colorspace are not displayed - fixed
— Some forms cannot be converted correctly to image - fixed
— Some soft masks are not decoded correctly - fixed
— Some bullet characters are not displayed correctly - fixed
— Dashed border is not displayed for free text annotations - fixed
PDF Viewer:
— EnsurePageVisible method display the bottom of the page if the page is rotated with 180 degrees - fixed
— Annotations are not drawn correctly if the page media box does not start at (0,0) - fixed
— Search text does not return results if the search term contains spaces and the document contains only graphic spaces between tokens - fixed
— Cursor does not change to Hand for locked link annotations - fixed
— Checkmark in newly created checkbox fields appears very small if the "Highlight form fields" option is selected in Adobe Reader - fixed
— Annotations are not displayed on pages rotated with -180 degrees - fixed
— Pages with a rotation angle greater than 360 are not displayed correctly - fixed
— Cloned pages cannot be converted to image - fixed
— In some situations the signature appearance is not visible when converting a PDF page to image - fixed
— In some situation the position of extracted text is not correct - fixed
— When textbox alignment is changed from code, the field appearance in the viewer is not updated - fixed
— Barcode annotations created with PDFView4NET are not recognized as such when the document is loaded in the viewer - fixed
— Image masks are not displayed correctly when the document is rotated or zoomed in - fixed

February 4, 2014 - PDFView4NET 4.6.1 WinForms Edition release
PDFView4NET 4.6.1 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Encrypted PDF files with /R 2 /V 1 cannot be loaded - fixed
— Images with indexed colorspace that declares a sample count larger that actual number of samples cannot be loaded - fixed
— In some situations the /Threads entry in document catalog causes a stack overflow when loading the PDF file - fixed
— Mask entry is not applied for 1bpp indexed images - fixed
— Documents that include images with incomplete data cannot be displayed - fixed
— Documents with damaged TrueType fonts cannot be loaded - fixed
— Characters with code 0 in Identity-H encoding are not displayed - fixed
— Some fonts with a /Cmap encoding are not displayed - fixed
— Search operation throws an exception in some PDF files with specific terms - fixed
— Some visible characters are displayed for some unprintable character codes - fixed
— Text that uses fonts with incorrect metrics is displayed in the wrong position - fixed
— In some documents false search results are returned because the space between letters is ignored - fixed
PDF Viewer:
— Some images are displayed inverted - fixed
— Doubleclicking form fields throws an exception is some situations - fixed
— An exception is thrown if the mouse is clicked in the empty control - fixed
— Thumbnails are not scrolled into view in PDFPageThumbnail control when SelectedPages property is set - fixed
— The action of a bookmark in the PDFBookmarksView control is not executed if the bookmark is already selected when the bookmark is clicked - fixed
— Mouse events are not fired for locked annotations - fixed
— Cursor changes shape when it is over an annotation even if the annotation is not visible - fixed
— If a document contains pages with different sizes, in SingePage display mode the pages are not displayed in the right position - fixed
— PageRenderingError event is not fired when invalid fonts are encountered in a PDF file - fixed
— PDF files with single point clip paths are not displayed correctly - fixed
— In some PDF files bookmarks jump to wrong location - fixed
— Zoom marquee does not work correctly with some PDF files - fixed
— In some scenarios the form data is not exported correctly in XFDF/XML format - fixed

August 20, 2013 - PDFView4NET 4.6.0 WinForms Edition release
PDFView4NET 4.6.0 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ AES 256 encryption
— Reversed image masks are not displayed correctly - fixed
— Free text annotations with no font attached are not displayed - fixed
— Invisible characters are shown as black rectangles - fixed
PDF Viewer:
— DefaultRectangleAnnotation* and DefaultEllipseAnnotation* properties are not considered when drawing annotations on the page - fixed
— Bookmark title is not decoded correctly in some situations - fixed
— In some scenarios the DestinationName property is not set on go to actions - fixed
— A stack overflow exception is thrown when exporting link annotations with go to actions
— Saving documents that include a document information dictionary cause the output file to have incorrect ids assigned to objects - fixed
— Spaces are added to extracted text in some scenarios - fixed
— The textbox field content cannot be fully erased on .NET 4.5, at least one character is always displayed - fixed
— When moving an annotation outside the page area, it can no longer be selected and moved - fixed

June 4, 2013 - PDFView4NET 4.5.1 WinForms Edition release
PDFView4NET 4.5.1 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some ZapgDingbats characters are not displayed correctly - fixed
— Annotations are not printed on rotated pages - fixed
— In some situations bullets are not displayed - fixed
— Content is not clipped correctly when using odd-even rule - fixed
— Some JPEG2000 images are not decoded correctly - fixed
— Some rotated text is displayed unrotated - fixed
— Stencil mask is not applied to JBIG2 images - fixed
— Some LZW encoded images cannot be decompressed - fixed
— Pages with multiple instances of the same font are rendered very slow - fixed
PDF Viewer:
— An unfinished polygon annotation appears on the new page if the page changes during drawing
— PageNumberChanged event is not fired when dragging the scrollbar very fast - fixed

March 27, 2013 - PDFView4NET 4.5.0 WinForms Edition release
PDFView4NET 4.5.0 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Jpeg images with Flate encoded stencil mask are not displayed correctly
— Some Windings characters are not displayed correctly - fixed
— Type0 OTF fonts embededded as TrueType are not displayed - fixed
— Accented characters in some Type1 fonts are not displayed - fixed
— Some LZW streams are not decoded correctly - fixed
— Pages with crop box larger than media box are not rendered correctly - fixed
PDF Viewer:
+ Barcode annotations
+ Enhanced text extraction
+ Hatched fills for rectangle, ellipse and polygon annotations
— When adding multiple quadpoints to strikeout and underline annotations only the first set is drawn correctly - fixed
— In some situations when the PDF file has been updated using incremental mode then the pages from an intermediary update are loaded - fixed
— Text is not extracted correctly from some PDF files - fixed
— PDFAnnotationCollection.MoveItem method does not update the visual z-order in the viewer - fixed
— WorkMode cannot be changed in AfterAnnotationAdd event if current work mode is AddPolygonAnnotation or AddPolylineAnnotation - fixed
— An exception is thrown when the viewer is in TextSelect mode, the current document is reloaded and the page is clicked - fixed
— Radiobuttons and checkboxes that include spaces in their export values do not work correctly - fixed
— Position of polygon and polyline points is not updated when polygon/polyline annotations are moved - fixed

October 15, 2012 - PDFView4NET 4.3.0 WinForms Edition release
PDFView4NET 4.3.0 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Added PrintContent parameter to PDFFile.GetBWPageImage method.
— Windings characters with Identity-H encoding are not displayed correctly - fixed
— Text is not displayed when the font resources are not stored at page level - fixed
— Type 0 fonts with null /Widths entry should use the /DW entry for glyph widths - fixed
— Dashed lines with zero width cannot be printed on PS printers, a PS exception appears - fixed
PDF Viewer:
+ Added support for named actions.
— Radiobutton fields are not exported correctly in XFDF and XML - fixed
— Updated drawing of line annotations, Shift key now forces vertical / horizontal lines
— Textbox fields with empty color array (/C) cannot be edited - fixed
— Field widgets are not placed in the correct position when the screen resolution is greater then 96dpi - fixed
— AddHighlightAnnotation work mode draws a rectangle when drawing the annotation instead of a highlight - fixed
— Size of line annotations changes when the viewer is in EditAnnotations mode and line annotations are clicked - fixed
— Documents that contain annotations with zero width or height cannot be loaded - fixed
— Chained actions are not loaded, only the first action is loaded - fixed
— Improved selection and resize of line annotations
— When an annotation is selected in EditAnnotations mode, the cursor changes if it hovers over the annotation location even if the page is different - fixed
— When a dropdownlist is activated, changing the page causes the dropdown list to remain visible - fixed
— Annotations with popups attached are not deleted correctly - fixed
— Signature fields with autosized fonts cannot be signed, an exception is thrown - fixed
— Removing the last page from the document causes an exception - fixed
— When a PDF form is loaded, the action properties on the field widgets and annotations are not initialized - fixed

May 15, 2012 - PDFView4NET 4.2.1 WinForms Edition release
PDFView4NET 4.2.1 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some JBIG2 images cannot be decoded (damaged image) - fixed
— 1bpp indexed images cannot be used for stamp appearances - fixed
— Stencil masks are not decoded correctly in some situations - fixed
PDF Viewer:
— Image based appearance for annotations is not created correctly when current culture is not en-US - fixed
— In some situations the checkbox appearance is not updated when visual related properties are changed
— Text is not displayed in textbox fields when an explicit color is not defined on the field - fixed
— In some situations, when an invalid page range was specified for printing, a single white page was printed - fixed
— In some situations, Zoom property does not work in release mode - fixed
— Fit zoom modes do not work correctly when the desktop dpi is larger than 96dpi (large fonts option is used) - fixed
— FitHeight and FitVisible zoom modes have no effect when the rendered page is smaller than the visible control area - fixed
— Dropdown list fields do not display the dropdown button when they are inactive - fixed

April 3, 2012 - PDFView4NET 4.2.0 WinForms Edition release
PDFView4NET 4.2.0 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Images with separation colorspace that uses a grayscale ICC colorspace are not decoded correctly - fixed
— JPX images with separation colorspace that uses a grayscale colorspace are not decoded correctly - fixed
— JBIG2 images with indexed colorspace that uses a separation colorspace are not decoded correctly - fixed
— 8bpp images are not decoded correctly in some situations - fixed
— Some custom encoded text is not displayed correctly - fixed
— An exception is thrown when displaying PDF files that include damaged fonts - fixed
— Custom metadata (PDFDocument.Metadata.XMPMetadata) is not saved in UTF8 format - fixed
— Transparent PNGs are shown with black background in stamps - fixed
— Some JPEG2000 images are not decoded correctly - fixed
— Accents on top of characters are not always displayed in the correct position - fixed
PDF Viewer:
— Very small patterns (less than 1 pt) cause an exception - fixed
— Shortcut keys (&) on the form block the corresponding keys in textbox fields - fixed
— When a field is being edited and the form is closed, an exception is thrown - fixed
— In some situations when a measure annotation is resized, it becomes invisible - fixed

January 18, 2012 - PDFView4NET 4.1.0 WinForms Edition release
PDFView4NET 4.1.0 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Viewer:
+ Added support for measure annotations
— Rendered page images now use 24bpp color depth
— Viewer control throws an exception when its size is zero - fixed
— If a textfield is being edited and the form is resized, the field is not displayed in the right position - fixed
— PDFPageView.MouseMove event is not fired if the mouse does not move over a page - fixed
— When the PDFPageView.ScrollPosition property is set directly the control content is not updated - fixed
— Scaled form Xobjects are not rendered correctly - fixed
— Images ignore the graphic state transparency - fixed
— Local Japanese fonts are not loaded correctly when the culture is set to Japanese - fixed
— PDFPageView.HighlightFormField method does not highlight the form field - fixed

November 28, 2011 - PDFView4NET 4.0.2 WinForms Edition release
PDFView4NET 4.0.2 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some PDF files that contain references to missing objects cannot be loaded - fixed
— Zero width characters are rendered using default character width - fixed
— JPEG images with separation colorspace and reversed decode array are not displayed correctly - fixed
— Some images using PNG prediction are not decoded correctly - fixed
— Some fonts with invalid Widths array are not displayed correctly - fixed
PDF Viewer:
+ Added action properties to PDFAnnotation class.
— PDFPageView.EnsurePageVisible method does not work correctly on 270 degrees rotated pages - fixed
— Annotation display is not updated when the page is rotated - fixed
— Large pages (3*Letter size) rotated with 270 degrees are not displayed corectly - fixed
— When pages are reordered using the thumbnails view, the viewer control gets out of sync - fixed
— Ctrl and Shift modifiers do not work correctly with up/down arrows - fixed
— When copying and pasting free text annotation the Font property is lost - fixed
— Form XObject content is not clipped at XObject border - fixed
— Annotations are not placed correctly when screen dpi is greater than 96 - fixed
— Marquee zoom does not work when zoom mode is FitWidth/FitHeight/FitVisible - fixed
— Out of memory exception is thrown when zooming to 3000% and the file contains annotations - fixed
— Annotations with appearance bbox different than annotation rectangle are not displayed correctly - fixed

September 27, 2011 - PDFView4NET 4.0.1 WinForms Edition release
PDFView4NET 4.0.1 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Text is not displayed when the font uses the encoding PDFDocEncoding - fixed
— Graphic state changes in a form XObject affect the page graphics after the form XObject - fixed
— PNG prediction is not decoded correctly - fixed
— 1bpp images with Indexed colorspace based on ICC are not decoded correctly - fixed
— 1bpp Gray images with softmasks are not displayed correctly - fixed
— 2bpp indexed images with color masking are not displayed correctly - fixed
— Large 1bpp mask images are not scaled correctly - fixed
PDF Viewer:
+ Added PDFPageView.RenderingProgressDisplay property to control the display of rendering progress bar
— PDFDocument.Print does not print anything - fixed
— Keyboard scroll was disabled - fixed
— PDFPageView.BackgroundImage property is ignored - fixed
— PDFPageView.Cursor property does not work like in the previous version - fixed
— PDFPageView.ZoomMode property cannot be set in design mode - fixed
— Some signature widgets cannot be converted to image - fixed
— PDFPageView.ShowAnnotations property does not show/hide the annotations - fixed
— PDFPageView.PageBorderColor and PDFPageView.ActivePageBorderColor properties are not used - fixed
— In some situations, when setting the FitWidth / FitHeight zoom modes the pages are not refreshed correctly - fixed
— Pages rotated with -180 degrees are not displayed correctly - fixed
— Tab key does not scroll page to bring field in view - fixed
— Form fields with widgets with no appearance (empty checkboxes) are not highlighted when HighlightFormFields property is set to true - fixed
— Text selection uses always red opaque color - fixed
— EnsurePageVisible method does not consider page rotation - fixed
— ZoomToPDFRectangle method does not consider page rotation - fixed

August 22, 2011 - PDFView4NET 4.0.0 WinForms Edition release
PDFView4NET 4.0.0 WinForms Edition has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some masked images are not decoded correctly - fixed
— Uacute character is not displayed for Type1 Courier font with WinAnsiEncoding - fixed
— Some CCITT G3 images are not decoded correctly - fixed
— Zero width/height clipping regions are not applied - fixed
— PDF files with null objects in form's Fields array cannot be loaded - fixed
— PDF files with signature fields that use a zero sized font cannot be loaded - fixed
— Some DeviceN colorspaces are not decoded correctly - fixed
— Some MacRoman encoded fonts are not displayed correctly - fixed
— Some Type1 fonts are not correctly decoded - fixed
— Some vertical text is not displayed correctly - fixed
— Some inline images are not decoded correctly - fixed
PDF Viewer:
+ Faster loading and display of PDF files
+ New multithreaded PDF rendering engine
+ Async page rendering with progress display
— Some character bounds are not extracted correctly - fixed
— Text selection and search results highlight does not work correctly on skewed text - fixed

July 8, 2011 - PDFView4NET 3.0.5 release
PDFView4NET 3.0.5 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some 1bbp images with reversed /Decode array are reversed twice during decoding - fixed
— PDF files with dictionary objects in trailer cannot be loaded - fixed
— PDF files with encrpytion version 2 and revision 2 cannot be loaded - fixed
— Helvetica Oblique and Courier Oblique fonts are rendered bold - fixed
— 1bpp images with Indexed / CalRGB colorspace are not decoded correctly - fixed
— Some bullet characters are not displayed correctly - fixed
— In /StandardEncoding the hyphen character is replaced by minus - fixed
— Very small paths (width/height less than 0.01 points) cause a memory exception when rendering on a Bitmap graphics - fixed
— Some JPEG2000 images are not decoded correctly - fixed
— Some embedded images are not decoded correctly - fixed
— Pages with an indirect reference for the /Rotate entry are not converted correctly to image - fixed
— Transparency is ignored for 32bpp images - fixed
— Font Monotype Corsiva, if it is not embedded, cannot be displayed - fixed
— Color mask is not applied correctly to indexed images - fixed
— Inline images with abbreviated name objects are not displayed - fixed
— PDFFile.GetPageImage generates an incorrect image when the computer's display scaling is set to a value larger than 100% - fixed
— DCT images with DeviceN colorspace based on CMYK are not decoded correctly - fixed
PDF Viewer:
+ Added support for submit form and reset form actions
+ Added DisplayQuadPoints property in highlight annotations
— When using TrueType fonts with free text annotations the font is not subset correctly - fixed
— An exception is thrown when using opaque 32bpp images as annotation appearance - fixed

February 23, 2011 - PDFView4NET 3.0.4 release
PDFView4NET 3.0.4 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Images are not drawn transparent when the alpha channel is the in the graphic state - fixed
— Gray images with reversed /Decode array and Flate compression are displayed as negative - fixed
— Checkmarks are not displayed correctly in some situations - fixed
— Some JBIG2 images are not decoded correctly - fixed
— JBIG2 images having a width not multiple of 4 are decoded at aligned width not at real width - fixed
— Images with CCITT encoded softmasks cannot be decoded - fixed
PDF Viewer:
— In multiline fields, after typing many lines, the caret is no longer placed on the corresponding text line - fixed
— In multiline text fields, when navigating with left/right keys, an exception is thrown if the cursor is at the end of the line, the next line is not visible and right key is pressed or if the cursor is at the beginning of the line, the previous line is not visible and left key is pressed - fixed
— Tamil text is not extracted correctly in some situations - fixed
— PolygonInteriorColor property is ignored when creating the polygon appearance - fixed
— When a multiline textbox field contains more lines than available space, clicking the mouse on a line can generate an exception - fixed

January 31, 2011 - PDFView4NET 3.0.3 release
PDFView4NET 3.0.3 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Text using TrueType fonts with MacRoman encoding is not displayed correctly - fixed
— PDF files with CID widths stored as double cannot be displayed - fixed
— Images that use abbreviations for filter names are not displayed correctly - fixed
— Fonts with cmap encoding are not displayed correctly - fixed
— CMYK JPEG2000 images are not decoded correctly - fixed
PDF Viewer:
+ Added TabOrder property to PDFFieldWidget class
+ Updated search so hyphen-minus is matched to en-dash
— When Ctrl+AnyKey is pressed in a textbox field and the text is selected, the selected content is removed after field looses focus - fixed
— In some situations, when loading a PDF form the font for field widgets is empty - fixed
— TrueTypeFont.Name property is empty for fonts created from objects inside a PDF file - fixed
— ZoomMarquee does not work correctly if current zoom mode is FitWidth or FitHeight - fixed
— Push button appearance is not created correctly - fixed
— An error appears when moving annotations with invalid popups - fixed
— FDF import does not work - fixed
— Text selection does not work correctly on pages with cropbox != mediabox - fixed
— Form fields are not filled correctly with some characters when they use fonts with custom encoding - fixed
— Text cannot be extracted when the /W entry contains double values - fixed
— Text selection is not displayed when the font has no ascent or capHeight - fixed
— When a page is rotated its thumbnail is not rotated correctly - fixed

December 15, 2010 - PDFView4NET 3.0.2 release
PDFView4NET 3.0.2 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Added support for displaying PDF patterns
— Text that uses 90msp-KJHS encoding is not displayed correctly - fixed
— PDF file cannot be loaded if comment delimited is placed next to a number object, no space between them - fixed
— Pages with PDF paths that contain lines with matching start/end coordinates cannot be displayed - fixed
— In some situations text using Wingdings fonts is not properly displayed - fixed
— Some PDF files cannot be loaded because of damaged objects - fixed
PDF Viewer:
+ Added support for horizontal scrolling with the keyboard
— Documents with even number of pages and TwoPageRight or TwoColumnRight display mode cannot be displayed - fixed
— In some situations the digital signatures are not created correctly - fixed
— Form fields with fonts that do not specify an encoding are not filled correctly with extended ASCII characters - fixed
— Free text annotations are not edited correctly on rotated pages - fixed
— Links do not work in text select mode - fixed
— Image appearance is displayed rotated when applied to field widgets on rotated pages - fixed
— When field font is subset for creating the appearance, after the form is saved, new characters are not displayed in the fields because the subset font does not include them - fixed
— Polygon annotations are not moved correctly when the page is rotated - fixed
— Polygon annotations are not displayed in PDFAnnotationsView control - fixed
— If a polygon annotations has no border defined, an exception is thrown when moving the annotation - fixed

October 6, 2010 - PDFView4NET 3.0.1 release
PDFView4NET 3.0.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Added support for decoding CMYK JPEG images.
— Page rendering is stopped when invalid color definitions are found, such as negative values for colors - fixed
— Characters are not placed correctly when they do not have a width in /W array and their width cannot be read from the font data - fixed
— Some Type1 fonts are not rendered correctly - fixed
— Rotated text using Fill&Stroke rendering mode is displayed very bold if the font size is encoded in the text transformation matrix - fixed
— PDFFile.Open leaks a file handle when the file is opened with an incorrect password - fixed
— Some AES encrypted files cannot be opened - fixed
PDF Viewer:
— PDFDocument.Dispose leaks a file handle - fixed
— Appearance is not updated for signature fields when the Appearance property is set - fixed
— Stream object with zero length are saved incorrectly, the stream tags are not saved - fixed
— Text selection does not work correctly in some situations - fixed
— Textbox displays a border when border width is zero and border color is not null - fixed
— Pressing TAB in an expanded dropdown list causes an exception - fixed
— Form fields with Type0 fonts do not display the field content - fixed
— Center and right alignment is not correct in textbox fields that use base PDF fonts (Helvetica, Times Roman or Courier) - fixed
— When a field is removed from document's fields collection, it is not removed from the corresponding pages' fields collections - fixed
— MoveItem method does not work correctly on the Annotations collection - fixed
— All link annotation actions are converted to Goto actions - fixed
— Removing a page from the document does not remove the page fields from the document - fixed
— Encrypted documents can no longer be decrypted - fixed
— A free text annotation that uses a custom font, loses its appearance when the file is loaded again in the viewer - fixed
— Arrows are not displayed for horizontal and vertical line annotations - fixed
— If all the fields in a form are read only, and a field is clicked with the mouse then TAB is pressed, an exception is thrown - fixed
— When a free text annotation is moved, its appearance is changed, the font switches to default - fixed
— Search results obtained by PDFPage.SearchText are not highlighted on the page using PDFPageView.HighlightSearchResult method - fixed
— PDFPageView.EnsureSearchResultVisible method does not highlight search results returned by PDFPage.SearchText - fixed
— PDF files with output intents are not saved correctly - fixed
— Some PDF forms cannot display the field values because the default appearance string is not well formed - fixed
— Comboboxes with Unicode content cannot be opened - fixed
— Custom appearance is lost for checkboxes, radiobuttons and pushbuttons when the widgets are moved/resized - fixed

August 9, 2010 - PDFView4NET 3.0 release
PDFView4NET 3.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Added support for decoding CMYK JPEG images.
+ Added support for calibrated CMYK to RGB conversion.
— Some Type1 fonts are not rendered correctly - fixed
— Indexed images with 1bpp and ICC base colorspace are not decoded correctly - fixed
— PDF files that contain TrueType fonts with invalid 'post' table cannot be loaded - fixed
— Low resolution barcode images cannot be scanned when they are printed - fixed
— Text is not displayed correctly when 'cm' operators appear inside BT/ET - fixed
— JPEG images with chroma key mask are not displayed correctly if they have a resolution larger than 96dpi - fixed
— When pages are printed as bitmap, the page image is not disposed - fixed
— PDF files that start with blank lines cannot be open - fixed
— Pages with fields that do not have an appearance, a default appearance string and resources cannot be converted to image - fixed
— Adieresis character is not displayed correctly in some situations - fixed
— CFF fonts created from TrueType fonts are not scaled correctly on display - fixed
PDF Viewer:
+ User interactive form design.
+ Add, edit and remove form fields.
+ Added FieldValidate event in PDFPageView control.
+ Added support for polygon annotations.
+ Added support for FitR option when executing destinations.
— Text cannot be selected from middle of word - fixed
— Text annotations with custom icon are displayed rotated on rotated pages - fixed
— Underline, strikeout and squiggly annotations are not displayed correctly on rotated pages - fixed
— Search results are not highlighted correctly on rotated pages - fixed
— PDF pages that contain widget annotations without parent fields cannot be loaded - fixed
— The Bounds property of selected text runs is not correct when the page is rotated - fixed
— When text is placed on page using offset values in TJ operator, the text selection does not follow the mouse - fixed
— Text selection is not displayed correctly when page mediabox.LLY is different from mediabox.LLX - fixed
— If a form contains only read only fields, clicking on a form field and pressing TAB causes an exception - fixed
— In some situations, when scrolling using the mouse wheel an exception is thrown - fixed
— When a page is rotated, its appearance is not updated in the thumbnails view - fixed
— If a document is loaded and then attached to a viewer control, the search functionality does not work in the viewer - fixed
— Tabbing through fields does not work when the page's annotations collection contains other annotation types than field widgets - fixed

April 26, 2010 - PDFView4NET 2.4.4 release
PDFView4NET 2.4.4 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Added support to display Japanese text with 90msRKSJ encoding.
— In some situations inline jpeg images are not loaded correctly from the file - fixed
— Some flate encoded images with paeth predictor cannot be decoded - fixed
— Some JBIG2 images cannot be decoded - fixed
— Encrypted PDF files with no document id cannot be decrypted - fixed
— Some Type1 fonts cannot be displayed, the outline data is not decoded correctly - fixed
— Rendering of link annotations with a border specification that include a dash pattern throw an exception - fixed
— Content of PDF files that set clip regions with 0 width and height is not displayed - fixed
— Some soft masks are not decoded correctly - fixed
— Times-Bold and Times-Italic fonts are not matched correctly to Times New Roman on local machine when they are not embedded - fixed
PDF Viewer:
+ Added support for vertical spacing before the first page and after the last page in OneColumn mode.
+ Added support for prerendering all document pages on load.
+ Added ZoomChanged, SmoothingModeChanged and TextSelectionCleared events in PDFPageView class.
— End key does not scroll pages till the bottom, 1 pixel is missing - fixed
— When a bookmark is clicked, the corresponding target is not executed - fixed
— Documents with many bookmarks on the same level cannot be loaded, stack overflow exception is thrown - fixed
— Line annotations are not rotated correctly - fixed
— Changing the attributes of an ink annotation after the annotation has been moved causes the annotation to disappear - fixed
— The image in stamp annotations with custom appearance is not rotated when the annotation is rotated - fixed
— The image in link and text annotations with custom appearance is not rotated when the annotation is rotated - fixed
— Annotations with custom appearance loaded from an PDF file lose the appearance when the annotation is rotated - fixed
— Comb fields cannot display unicode data - fixed
— When a field is active and the zoom changes, the field content is not scaled - fixed
— When a page is scrolled using the mouse wheel, if a form field is active, the form field is scrolled into wrong position - fixed
— HighlightSearchResult method has no effect on search results returned by PDFPage.SearchText method - fixed
— Text selection does not work on rotated pages - fixed

February 15, 2010 - PDFView4NET 2.4.3 release
PDFView4NET 2.4.3 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— 1bpp indexed images with a separation base colorspace are not rendered correctly - fixed
— Some 1bpp images include more data than necessary and they are not decoded correctly - fixed
— 1bpp indexed images with a color mask are not decoded correctly - fixed
PDF Viewer:
+ Added support to handle remote go to actions like local go to actions when the file name is missing.
+ Added support to draw vertical/horizontal line annotations.
+ Added support to display bookmarks with the color defined in the PDF file.
+ Added support for image appearance for link annotations.
— Dropdown list fields do not display all the items in some situations - fixed
— Text is not extracted in some situations - fixed
— Text selection does not work when text contains ligatures - fixed
— When an annotation is drawn on top of a link, the link cannot be clicked - fixed
— Cursor is not placed correctly in multiline textbox fields that are rotated with 270 degrees - fixed
— When loading a document with bookmarks in BookmarkClick event, a random bookmark is selected in the bookmarks view when the new document is loaded - fixed
— An exception is thrown when clicking the thumbnails view background, outside any page area - fixed
— An exception is thrown when a link without action is clicked - fixed

December 15, 2009 - PDFView4NET 2.4.2 release
PDFView4NET 2.4.2 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some CCITT images are not decoded correctly - fixed
— Some ASCII Hex encoded images are not decoded correctly - fixed
— Pages with zero width/height annotations cannot be converted to image - fixed
— Some image masks with predictor = 2 are not decoded correctly - fixed
— Some JBIG2 images are not decoded correctly - fixed
— Some Symbol characters are not displayed correctly - fixed
— Unescaped but paired paranthesis in strings are not handled correctly - fixed
PDF Viewer:
+ Added SearchText and ConvertToImage methods to PDFPage.
+ Updated text selection to allow starting a selection from a white space outside the text.
— In some situations encrypted files cannot be displayed when PDFPageThumbnailsView control is used together with the PDFPageView control - fixed
— Textbox fields with no appearance throw an exception when they are clicked - fixed
— When extracting text, in some situations, additional spaces are inserted in the text - fixed
— Text selection does not work when text contains ligatures - fixed
— Selection is dropdown lists with autosized font is not displayed correctly - fixed
— Max field length is not enforced when text is pasted into the field - fixed
— When the viewer displays pages in OneColumn mode, if the text is selected on one page and the pages are scrolled, the selection markings are drawn on other pages - fixed
— Widget annotations are not displayed if they are not linked to a form field - fixed
— When /NeedAppearances is true and fields have an appearance, the appearance is not rebuilt - fixed

October 19, 2009 - PDFView4NET 2.4.1 release
PDFView4NET 2.4.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Some CCITT images are not decoded correctly - fixed
— Some images are not displayed in the right position - fixed
— Appearance is not built correctly for line and free text annotations when using other culture than US - fixed
— Cross reference streams that use a PNG predictor greater than 10 are not decoded correctly - fixed
— PDF pages with annotations that include only the /D appearance cannot be printed - fixed
— Pages with no MediaBox/CropBox cannot be loaded - fixed
PDF Viewer:
+ Added support for Launch actions
+ PDFPageView.HighlightNextSearchResult and PDFPageView.HighlightPrevSearchResult methods now return the highlighted search result.
+ Added PDFPageView.EnsureSearchResultVisible method to force a highlighted search result to move into visible control area.
+ Added support for Comb fields
— In some situations content of dropdown and listbox fields is not painted correctly - fixed
— FitWidth option does not work correctly when the PDFPageView control is hosted in a WPF application - fixed
— End key throws an exception when pressed in a single line field that is pre-filled with multiline text - fixed
— PDFPageView loses focus when scrollbars are removed because of zooming out - fixed
— Clicking the mouse on a page thumbnail when the thumbnail view control is not linked to a page view control causes an exception - fixed
— Ligatures are not converted correctly to separated characters when text is extracted from a PDF page - fixed
— Thumbnails are not always rendered correctly - fixed
— Search method does not display the highlight in the correct position in some situations - fixed
— In a multiline text field, when selecting a line (not the last one) with Shift-End and pressing Del, an exception is thrown - fixed

September 1, 2009 - PDFView4NET 2.4 release
PDFView4NET 2.4 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ JPEG 2000 support
+ JBIG2 support
— Non-embedded Arial-BoldMT font is not matched correctly against a local machine font - fixed
— PDF files with Document catalog included in an object stream cannot be loaded - fixed
— PDF page cannot be rendered if it includes a form field using a font that cannot be found - fixed
— Some ASCII85 streams are not decoded correctly - fixed
— Encrypted files with non-encrypted metadata cannot be loaded - fixed
— Short strings (less than 16 bytes) are not decrypted when the input file uses AES encryption - fixed
PDF Viewer:
+ PDFThumbnailsView control for displaying page thumbnails
+ Text selection and copy
+ Added GetDestinationNames method to PDFDocument to retrieve the names of the destinations in the PDF file as a list of strings
+ Added MouseWheelScrollDelta property to PDFPageView to control the scroll distance using the mouse wheel.
+ BackgroundImage property is now used in PDFPageView to display a background image under the page

July 29, 2009 - PDFView4NET 2.3.2 release
PDFView4NET 2.3.2 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— PDF files that contain nested arrays on multiple levels cannot be loaded - fixed
— Copy operation works like Cut - fixed
— Flate compressed images with 1bpp and decode array [1 0] are not displayed correctly - fixed
— Fonts with incomplete Widths entry are not rendered correctly - fixed
— 1bpp flate compressed images, with PNG Prediction = None are not decoded correctly - fixed
— TJ operator does not display correctly vertical text when there are intercharacter spacing values - fixed
— Text is not positioned correctly in some situations - fixed
— Images with both a soft mask and a stencil mask are not displayed - fixed
— String elements of array objects stored as separated objects are not decrypted correctly - fixed
— Images with stencil masks that have a different size are not displayed correctly - fixed
— Grayscale images (1 color 8bpp) with LZW compression and predictor = 2 are not displayed correctly - fixed
— Flate compressed images with BPC=1 and predictor = 2,3,4 are not decompressed correctly - fixed
— Colors are not correctly rendered when the PDF content has comments - fixed
— Zero height paths are not displayed - fixed
— The PDFPageView control throws an exception when loading a page that has the CropBox/MediaBox defined as indirect objects - fixed
— Encrypted PDF files with encrypt dictionary embedded in the trailer are not displayed correctly - fixed
— Flate compressed images with 2 bits per pixel are not displayed - fixed
PDF Viewer:
+ Added ActivePageBorderColor property to PDFPageView
+ Added PDFPageView.HighlightPrevSearchResult() method
+ Added JumpToDestination method in PDFPageView for jumping programmatically to named destinations
— Removing thelast page in a document when multiple pages are visible, including the removed one, causes an exception - fixed
— Free text annotations can be edited even if they are locked or read only - fixed
— PDFPageView throws an exception when a file is displayed and the form is minimized or the form size is too small - fixed
— Position of text runs is not computed correctly when the page is rotated and multiple Tj operators are chained together - fixed
— Highlight annotation color is not updated correctly if the annotation is resized (increased) after it has been added to the page - fixed
— PDF files with infinite loops in bookmarks tree cannot be loaded - fixed
— In some situations the page number is not displayed correctly in PDFAnnotationsView control for newly added annotations - fixed
— Links and bookmarks no longer work when page display mode is SinglePage - fixed
— Zoom out operation throws an exception when the page becomes smaller that the control area - fixed
— Text cannot be displayed when the font includes an invalid Unicode Cmap - fixed
— In some situations the viewer is not updated correctly when the current page is displayed - fixed
— The bounding rectangle of an ink annotation is not updated when the ink width changes and parts of the ink become invisible when the width grows - fixed
— An exception is thrown when the TAB key is pressed and the current page is not the one that contains the active field and it does not contain any fields - fixed
— EnsurePageVisible method does not scroll to a position within the page, it always scroll to top of the page - fixed

April 28, 2009 - PDFView4NET 2.3.1 release
PDFView4NET 2.3.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Images with BPC=4 and predictor 15 are not displayed correctly - fixed
— In some situations TrueType fonts are not decoded correctly - fixed
— Some non embedded fonts not matched correctly to local fonts - fixed
— Fields without /DR key (at field or at form level, so the font cannot be located) are not displayed correctly - fixed
— Soft masked Jpeg images with resolutions other than 96 are not displayed correctly - fixed
— CCITT G4 images with missing /Columns entry are not decoded correctly - fixed
— Pages that use /Multiply blend mode for content are not displayed because the content is considered transparent - fixed
— Encrypted PDF files with version = 1 and revision = 3 cannot be decrypted - fixed
— When displaying text with CidFontType2 fonts, the /DW entry is not considered for characters that do no have a width in /W array - fixed
— Indexed images with chroma masks are not displayed correctly - fixed
— Invalid text matrix cause the page rendering to stop - fixed
PDF Viewer:
+ Added support for page and annotation cloning
+ Added support for drawing unicode text in drop down lists and list boxes
+ Added support for annotation serialization
+ Added ZoomClick work mode
+ Added IncrementalLoad property to PDFDocument to allow full document load in memory
+ Added FieldClick, FieldBeginEdit and FieldEndEdit events
— In some situations, when the viewer is in one column mode, an exception is thrown when loading a document with 1 page after a document with n pages has been loaded before - fixed
— Text selection does not work correctly in multiline textbox fields, Shift-End does not select the last character and selection is not displayed if the field displays only one line of text and it is not the first one - fixed
— When viewer control is used in a WPF application, in single page mode, in some situations the wrong page is displayed - fixed
— FontName property in text run returns the font label instead of actual font name - fixed
— Insert method in Pages collection always adds the new page at the end of collection - fixed
— In some situations an exception is thrown when a textbox field is clicked - fixed
— SearchText does not work when the text contains empty ("") text runs - fixed
— PDF forms with missing fields (fields listed in /AcroForm but not in the PDF file) cannot be loaded - fixed
— Text run position is not computed correctly and text search highlight is not displayed in the right position when the text is included in a form XObject - fixed
— Marquee zoom does not work correctly for rotated pages - fixed - fixed
— Text extraction does not work correctly for some CJK files - fixed

February 19, 2009 - PDFView4NET 2.3 release
PDFView4NET 2.3 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Printing multiple page ranges with PDFPrintSettings class
+ Form XObjects are now displayed based on their optional content status, view only and/or print only.
— Some tiff images are not decoded correctly - fixed
— 4bit indexed images with Gray colorspace are not decoded correctly - fixed
— CCITT G4 images that have Columns != Width are not decoded correctly - fixed
— Streams encoded with A85 filter (instead of ASCII85) are not decoded - fixed
— Images with DeviceN colorspace that uses an ICCBased colorspace are not decoded correctly - fixed
— Paths defined by a single line are not filled with correct color - fixed
— 1bpp Indexed images with /DeviceGray colorspace are not displayed correctly - fixed
— Vertically drawn text is not displayed in the right position - fixed
— Separation color with /DeviceGray base colorspace is not displayed correctly - fixed
PDF Viewer:
+ ZoomIn, ZoomOut, ZoomDynamic and ZoomMarquee work modes for viewer control
+ Annotation popup windows
+ Annotation multilevel replies
+ Annotation opacity
+ Highlight form fields on a page
+ Standard and owner draw field tooltips
+ Tooltip property added to PDFField class
+ Added support for SHIFT-TAB keys to navigate backwards in the form fields
+ WYSIWYG drawing for highlight, rectangle, ellipse and ink annotations
+ Added support for moving and resizing annotations with CTRL+arrows and SHIFT+arrows
+ SearchText methods now returns the results of search text operation
+ Added SearchResultHighlightColor property to PDFPageView for setting the highlight color of search results
+ Added VerticalPageSpacing and HorizontalPageSpacing properties to PDFPageView for setting the space between pages in continuous page display modes
+ Added VisibleWidth and VisibleHeight properties to PDFPage class
— Text cannot be extracted from PDF files with resources defined at /Pages level - fixed
— When the Color property of a newly added FreeTextAnnotation is changed in BeforeAnnotationAdd event, an exception is thrown - fixed
— Destinations that use a page number (not in PDF spec) instead of a page reference in GoTo actions are not executed properly - fixed
— Line annotation appearance is not updated when line width changes - fixed
— When text is selected using Shift-End in a text box field and Backspace or Delete keys are pressed, and exception is thrown - fixed
— Text in textbox fields is not aligned according to field align property - fixed
— If a secured document is loaded into a PDFDocument, and then a clear document is loaded, the PDFDocument object still keeps the SecurityManager from the previous document - fixed

January 9, 2009 - PDFView4NET 2.2.1 release
PDFView4NET 2.2.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— PDF files created with Aspose.Words cannot be loaded - fixed
— Some thin lines are not displayed - fixed
— PDF files with zero length lines (start and end points are the same) cannot be displayed - fixed
PDF Viewer:
— Document dispose throws an exception in some situations - fixed
— Highlighting of search results does not work when scaling transformations are in place - fixed
— When the attributes of an undisplayed annotation (annotation that is on a page that is not currently displayed) are changed, the annotation becomes invisible - fixed
— PDF files with infinite loops in bookmarks tree cannot be loaded - fixed
— When the document is first loaded and then attached to a viewer, the viewer throws an exception because the search results are not initialized - fixed
— If the searched text is not found and HighlightNextSearchResult method is called, the viewer throws an exception - fixed

December 1, 2008 - PDFView4NET 2.2.0 release
PDFView4NET 2.2.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Images with Indexed colorspace that uses a DeviceN colorspace as base colorspace, cannot be displayed - fixed
— Inline images cannot be displayed - fixed
— When a DCT encoded image has a softmask with a different size, the image is not displayed - fixed
— Float values with more than 10 decimals are not converted correctly - fixed
— GetPageImagesAsMultipageTiff methods create an invalid TIFF image when the PDF file has only 1 page - fixed
— Images with Indexed colorspace that uses a ICC colorspace as base colorspace, cannot be displayed - fixed
— Some Type1 fonts with custom embedded encodings are not displayed correctly - fixed
— Some Type4 functions (postscript) are not evaluated properly - fixed
— PDF pages that have attributes defined on parent /Pages node are not displayed correctly - fixed
— Non-embedded fonts without post table cannot be rendered - fixed
— Some image masks are not painted correctly - fixed
— Some images with CalRGB colospace are not displayed - fixed
— Copies property in PrinterSettings is ignored if the printed does not support multiple copies - fixed
— PDF files that include annotations smaller than 1pt cannot be displayed - fixed
— Text cannot be extracted from some pages that include inline images - fixed
— Type2 functions without a /Range entry are not computed correctly - fixed
PDF Viewer:
+ Search text and highlight search results in PDFPageView control
+ Annotation tooltips
+ Custom appearances for text and stamp annotations
+ Added support for TAB key in PDF forms
+ Added PageClick and PageDoubleClick events to PDFPageView to notify the user when the page was clicked
— Author for free text annotation is not initialized by default with logged in user - fixed
— Setting the Contents property on a free text annotation does not update its visual appearance in the viewer - fixed
— Annotations reply model does not work unless the reply annotation (a text annotation) does not have these flags: print | hidden| nozoom | norotate - fixed
— When a field value is set from code and the form is not displayed in the viewer, the field appearance is not built - fixed
— Checkbox and radiobutton field values are not stored correctly in the PDF file, changing the Checked status does not sets correctly the field value when the file is saved - fixed
— Zoom and ZoomMode properties cannot be set at design time - fixed
— Clicking on a link annotation with a GoTo action, the PageNumberChanged event is fired twice and the 2nd time the page number is wrong - fixed
— In some situations the border of a link annotation is not displayed - fixed
— Load method does not throw an exception if the document has no pages - fixed
— In some situations, the first page of the loaded PDF file is not displayed - fixed
— Newly created annotations on rotated pages are not displayed correctly - fixed
— PDFPageView control is not refreshed when a loaded PDFDocument is attached to it - fixed
— If a multipage document is displayed in OneColumn view, and the pages do not have the same width, the hittest for form fields and annotations does not work properly - fixed
— If the current page number is larger than the number of pages in a document that is loading, an exception is thrown by the viewer - fixed
— Filling forms from code take a long time when the form has many fields - fixed
— "Visible but not print" and "Hidden but printable" options for form fields are not handled correctly - fixed
— Bookmarks with /XYZ destination and null values for coordinates generate an exception - fixed
— Annotations with empty appearance dictionaries throw an exception - fixed
— Top level bookmarks throw an exception when they are removed - fixed
— Space key was not displayed in textbox editor until another character was typed - fixed

September 8, 2008 - PDFView4NET 2.1.0 release
PDFView4NET 2.1.0 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Added IconName property to stamp annotations
+ Added support for specifying the DocumentName being displayed in printer queue window when printing a PDF file
— PDF forms with signature fields cannot be loaded - fixed
— Highlight annotations are printed opaque - fixed
— Some 1bit images using flate compression cannot be decoded correctly - fixed
— Bitmap printing ignores the PDFPrintContent flags - fixed
— Resolution is not set (default remains 96) on B/W images - fixed
— When the /Annots array contains direct dictionary objects, the PDF file cannot be printed - fixed
— In some situations the TimesNewRoman font is not rendered correctly - fixed
— In some situations the softmask is not applied correctly to an image - fixed
— Dashed lines with very small dash width are not displayed - fixed
— Some inline images are not decoded correctly - fixed
— Some encrpyted PDF files cannot be open - fixed
— PDF files with custom objects in /Pages hierarchy cannot be loaded - fixed
— Some CCITT encoded images are not decoded correctly when the width of a line in bytes is not multiple of 4 bytes - fixed
PDF Viewer:
+ Added new page display layouts in PDFPageView control: single page, one column, two columns with support for keyboard navigation (up/down/page up/page down/home/end)
+ Added new bookmarks view control
+ Added support for free text annotations (type writer tool)
+ Added support for annotation states in text annotations and in reply to annotation model
+ The PDFDocument now throws an UnsupportedEncryptionException when an unknown encryption is used
+ All exceptions are now serializable
+ Updated hit testing method for annotations to match behavior in Adobe Acrobat
+ Added Close method to PDFDocument to close the underlying PDF file
+ Added AllowFormFill property to PDFPageView to enable/disable the form filling at viewer level
— Characters are not multiplicated when a key is pressed for a longer period of time in a textbox field - fixed
— Default field appearance defined on widget instead of field is ignored - fixed
— PDFLinkAnnotation class does not have a public constructor - fixed
— The PDFAnnotationsView control displays a Page entry for each page that includes annotations, even if those annotations are not listed in the control - fixed
— CreationDate property on newly created annotations returns DateTime.MinDate instead of actual creation time - fixed
— When updating the description of file attachments, the new value is not saved - fixed
— MoveItem method on pages collection does not move the pages properly and the viewer is not refreshed if the displayed page is affected - fixed
— When the interior color of ellipse and rectangle annotations changes, the viewer is not updated - fixed
— Scroll events are not fired in PDFPageView control when scrolling pages using the keyboard - fixed
— After a page has been rendered once, changing its rotation does not trigger page rendering again unless it is the displayed page - fixed
— Readonly fields can be filled interactively by end user - fixed

July 7, 2008 - PDFView4NET 2.0.1 release
PDFView4NET 2.0.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— In some situations the annotations are not printed in the right position - fixed
— In some situations custom encoded text is not printed - fixed
— In some situations border is not displayed for link annotations - fixed
— Some PDF files throw an exception when they are closed - fixed
— Fonts with invalid Differences array are not displayed - fixed
— Dashed lines are not displayed correctly - fixed
— Some CCITT 1D images are not displayed correctly - fixed
— Reversed softmasks are not decoded correctly
— Some ICC based images are not displayed correctly
PDF Viewer:
— AfterAnnotationMove and AfterAnnotationResize events are fired even if the annotation is just clicked - fixed
— In some situations textbox fields display the text in wrong position - fixed
— When a bookmark title has changed, the new title is not saved when the file is saved - fixed
— When a top level bookmark is moved (added) to another bookmark, the hierarchy is broken - fixed
— Some PDF forms with empty fields are not loaded - fixed
— An exception is thrown when the last page is displayed in the viewer control and another page is removed from the document - fixed

June 16, 2008 - PDFView4NET 2.0.0 release
PDFView4NET 2.0.0 has been released. For the complete list of features click Features. The following features are supported in this version (+ new features/enhancements, — bug fixes):
Breaking changes:
+ FromPage and ToPage properties in PrinterSettings start now at 1 instead of 0.
+ Image property in text and stamp annotations changed to Appearance (type: PDFAnnotationAppearance)
PDF Rendering:
+ Support for converting PDF pages to B/W TIFF images
— When an encoding dictionary includes hex codes in differences array, the corresponding characters are not displayed - fixed
— Some Type 1 fonts with custom encoding are not displayed correctly - fixed
— Images with ImageMask set to true and missing BitPerComponent entry cannot be decoded - fixed
— Annotations with non-standard rectangle (llx, lly, urx, ury) are not rendered correctly in GetPageImage method - fixed
— Images with /CCF filter (short from /CCITTFaxDecode) are not displayed correctly - fixed
— In some situations black squares (.notdef char) are displayed for unprintable characters - fixed
— In some situations images with DeviceN colorspace are not rendered correctly - fixed
— Images with a device colorspace stored as array are not displayed - fixed
PDF Viewer:
+ User interactive form filling
+ Fill forms from code
+ Pushbutton, checkbox, radiobutton, dropdown list and listbox fields
+ Save filled forms
+ Zoom modes: custom, fit width, fit height, fit visible
+ Support for transparent PNG and GIF images in image stamps and text annotations
+ New events PDFPageView.AfterAnnotationMove and PDFPageView.AfterAnnotationResize
— Link action is executed when page viewer is in EditAnnotations mode - fixed
— Annotation visual appearance is not updated when annotation color or icon has changed - fixed
— Annotations are added to the page (but they are hidden) even if the BeforeAnnotationAdd event is canceled - fixed
— Highlight annotations do not update the visual appearance when the color is changed - fixed
— Annotation events on PDFAnnotationsView control are not fired unless the PageView property is set - fixed
— Highlight annotations are not created correctly when regional settings are not eu-US - fixed
— The horizontal line in underline annotations is not displayed - fixed
— Annotations are not moved and resized correctly when the page is rotated - fixed
— An exception is thrown when a top level bookmark is removed - fixed
— Nested arrays that contain indirect references are not saved correctly - fixed

May 06, 2008 - PDFView4NET 1.0.5 release
PDFView4NET 1.0.5 has been released. For the complete list of features click Features. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— CCITT encoded stencil masks are not applied correctly - fixed
— Char spacing is not applied correctly in some situations - fixed
— Indexed 4bit images are not displayed - fixed
— In some situations, PDF files that use object stream compression cannot be loaded - fixed
— Some PDF files with CJK fonts are not displayed correctly - fixed
— File attachments with Unicode file names cannot be saved in Acrobat/Reader 8 - fixed
— Annotation's image is not updated on screen if the image is changed from code - fixed
— Encrypted PDF files that use object streams cannot be displayed - fixed
— Strings stored in encrypted object streams are damaged when they are decrypted - fixed
— In some situations paths that include rectangles are not filled correctly - fixed
— Images with Separation colorspace are not displayed - fixed
— PDF files with incomplete catalog dictionary are not loaded - fixed
— Paths that are drawn with pens that use a dash pattern with 0 length elements generate an exception - fixed
— CalRGB colors are not displayed correctly in some situations - fixed
PDF Viewer:
— Documents with delayed load file attachments are not saved correctly - fixed
— Text annotations with custom images display standard note icon when they are clicked in Acrobat/Reader 7 - fixed
— Page removal from a document does not work - fixed
— Stream objects are not saved correctly when their size is 0 - fixed

March 28, 2008 - PDFView4NET 1.0.4 release
PDFView4NET 1.0.4 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— DCT compressed softmasks are not applied correctly - fixed
— Stencil masks are not applied correctly - fixed
— Font encoding is not properly determined for font objects with Encoding dictionaries - fixed
— Inline images with custom colorspace are not displayed - fixed
— PDF files with Type0 fonts that include entire font dictionary in /DescendantFonts key are not displayed properly - fixed
— Borderless link annotations are rendered with border in PDFRender4NET - fixed
— Zero width/height rectangles are not displayed when they are stroked with non-zero pen - fixed
— In some situations TIF images are not displayed because the underlying stream has been closed - fixed
— Text is not displayed in some PDF files that use object compression - fixed
— 1x1 images are not scaled as block and dithering appears - fixed
— TrueType CourierNew font is not rendered correctly when the font is not embedded - fixed
— Files that include complete annotation dictionaries in /Annots array cannot be loaded - fixed
— PDF forms that include fields without default appearance cannot be loaded - fixed
— Forms with empty fields that use a font that is not used elsewhere in the file cannot be displayed - fixed
— Images encoded with predictor #2 are not decoded correctly - fixed
PDF Viewer:
+ Added Execute method on bookmarks for explicit execution of bookmark's action or destination
+ Added SetCustomKey method to PDFDocumentInformation class - fixed
+ Added support for displaying images in text and stamp annotations
+ Added delayed load option for file attachments
— Disposal of some PDF documents throw an exception - fixed
— Mouse cursor is not restored in PDFPageView control when changing from EditAnnotation to Pan&Scan mode - fixed
— New bookmarks added to a document are not saved when the document is saved - fixed

February 25, 2008 - PDFView4NET 1.0.3 release
PDFView4NET 1.0.3 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Added support for CCITT T4 1D decoding
+ Added support for RunLengthDecode filter
— Pages with resources specified in parent objects are not rendered correctly - fixed
— Some ASCII85 encoded streams are not decoded correctly - fixed
— Incorrectly escaped paranthesis in strings cause the page rendering to hang - fixed
— Stroked text is not rendered correctly in some situations - fixed
— Embedded JPEG images with a soft mask are not displayed correctly - fixed
— Initial colorspace in page content was considered to be DeviceRGB instead of DeviceGray - fixed
— Files with invalid CFF data cannot be displayed - fixed
— Indexed 1bpp images are not decoded correctly - fixed
PDF Viewer:
+ Added PageNumberChanged event to PDFPageView control
— Documents with links that use named destinations cannot be loaded - fixed
— Link annotations with /Dest key do not work - fixed
— Bookmarks with named destinations do not work - fixed
— Clearing the attachments collection from PDFDocument does not remove the attachments from the actual PDF file - fixed
— Invalid annotations appearance is created when regional settings on local computer are not en-US - fixed
— PDF files with invisible signatures cannot be loaded - fixed
— Ink annotation points are not set correctly from code - fixed
— In some situations the page size is not updated properly in PDFPageView control - fixed

January 22nd, 2008 - PDFView4NET 1.0.2 release
PDFView4NET 1.0.2 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
+ Attribute "AllowPartiallyTrustedCallers" applied to PDFRender4NET assembly
— Color masks are not processed correctly - fixed
— Some Type1 fonts are not decoded correctly - fixed
— Pages with inline images that include /IM key are not rendered - fixed
— Printed page content is shifted to the right and down when None scaling option was used - fixed
— Tiff images with custom indexed colorspace are not displayed correctly - fixed
PDF Viewer:
+ Support for Remote GoTo actions
+ IRawPDFData interface to support raw PDF data extraction from annotations, actions, pages, bookmarks and document
+ Support for PDFRectangle for annotations
+ Support for converting screen points <-> PDF points in PDFPageView control
+ Support for text markup (highlight, underline, stirkeout, squiggly) annotations
— Link actions are not loaded - fixed
— PDFPageView displays garbage lines when scrolling the page up/down - fixed

November 26th, 2007 - PDFView4NET 1.0.1 release
PDFView4NET 1.0.1 has been released. For the complete list of features click here. The following features are supported in this version (+ new features/enhancements, — bug fixes):
PDF Rendering:
— Unprintable chars in range 0 - 31 are displayed as empty squares - fixed
— Some Type1 fonts are not decoded correctly - fixed
— Hidden and NoView flags are not handled in PDF rendering library - fixed
— Arial Black font is not substituted correctly when the font is not embedded - fixed
— Flex operations are not handled correctly in Type1 font - fixed
— Flate encoded grayscale images are not decoded correctly - fixed
— Separation colorspaces with ICC alternate colorspace are not rendered correctly - fixed
— CITT images with byte aligned data are not displayed - fixed
— Text that uses a font with negative size is not displayed - fixed
PDF Viewer:
— PDF file is not released when the PDFDocument is disposed - fixed
— When PDFPageView.MouseDown event is handled in user code and the handling code displays a modal dialog box, the page remains blocked in pan mode after the dialog is closed - fixed

November 2nd, 2007 - PDFView4NET 1.0 release
PDFView4NET 1.0 has been released. For the complete list of features click here.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Licensing

The PDFView4NET toolkit is licensed per developer. One license can be used on multiple computers as long as it is used by the same developer, and it cannot be used concurrently or shared by other developers.
Any PDFView4NET license lets you distribute the runtime components with your application inside your organization on unlimited number of desktop computers and servers.
This license does NOT ALLOW you to distribute the PDFView4NET library for use in development. This requires an OEM distribution license. If you want to do so, please contact us.

LICENSE AGREEMENT

VERY IMPORTANT - READ CAREFULLY:

This O2 Solutions Software License Agreement (hereinafter, this "LICENSE") is a legal agreement between you (either an individual or a single entity) and O2 Solutions, SRL. ("O2 Solutions"), for the software containing this LICENSE which has been obtained through O2 Solutions or its authorized distributor.

  1. OWNERSHIP; LICENSE GRANT
    This is a license agreement and NOT an agreement for sale. O2 Solutions continues to own the copy of the SOFTWARE contained on the disk and all other copies that you are authorized by this LICENSE to make. Your rights to the SOFTWARE are specified in this LICENSE, and O2 Solutions retains all rights not expressly granted to you in this LICENSE. O2 Solutions hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.
  2. PERMITTED USES. This LICENSE grants you the following rights:
    A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer.
    B. The o2s.components.pdfrender4net.dll assembly is supported to be used in any .NET application (Windows Forms, ASP.NET, Windows Services or console applications). The o2s.components.pdfview4net.dll assembly is supported to be used only in .NET Windows Forms applications.
    C. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy for each developer for which the Software has been licensed as described in Section 2.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.
    D. You may use the evaluation versions of the SOFTWARE for the limited purposes of demonstrations, trials and design time evaluations.
  3. PROHIBITED USES. You may not, without the prior written permission of O2 Solutions:
    A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.
    B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.
    C. Transfer, rent, lease, or sublicense the SOFTWARE.
  4. REDISTRIBUTABLE COMPONENTS
    A.     The files o2s.components.pdfrender4net.dll, o2s.components.pdfview4net.dll are considered as REDISTRIBUTABLE DLLs.
    B. In addition to the license and rights granted in Sections I and II, O2 Solutions grants you a nonexclusive, royalty-free right to reproduce and distribute the object code version of the SOFTWARE designated in the SOFTWARE as (i) those portions of the SOFTWARE which are identified in the documentation as REDISTRIBUTABLE DLLs ("DLLs"); provided: you distribute the REDISTRIBUTABLES in object code form only in conjunction with and as part of your software application product which adds significant and primary functionality; you do not use O2 Solutions' name, logo or trademarks to market your software application product; you include a valid copyright notice on your SOFTWARE; and
    C. In addition to the other requirements set forth in this Section 4, you hereby agree to indemnify, hold harmless, and defend O2 Solutions from and against any and all liabilities, damages, losses, costs and expenses (including attorneys' fees) arising from or related to any claim, action, proceeding or allegation that arise or result from the use and distribution of any of your software application product(s) or components.
  5. COPYRIGHT
    All title and copyrights in and to the SOFTWARE are owned by O2 Solutions. The SOFTWARE is protected by United States copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of O2 Solutions.
  6. TERMINATION
    This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from O2 Solutions if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to O2 Solutions.
  7. LIMITED WARRANTY
    A.     O2 Solutions does not warranty that the SOFTWARE will be error-free. Except with respect to REDISTRIBUTABLES, which are provided "AS IS," without warranty of any kind, O2 Solutions warrants that the SOFTWARE will perform substantially in accordance with the accompanying electronic documentation for a period of thirty (30) days from the date of receipt.
    B. O2 Solutions' entire liability, in contract tort or otherwise, and your exclusive remedy under the performance warranty set forth in Section 7.A, shall be, at O2 Solutions' option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.
    C. EXCEPT AS EXPRESSLY SET FORTH IN THIS SECTION 7, O2 SOLUTIONS DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, WHETHER ARISING BY STATUTE OR OTHERWISE IN LAW OR FROM A COURSE OF DEALING OR USAGE OR TRADE, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF ACCURACY, COMPLETENESS, PERFORMANCE, CURRENCY, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE WITH REGARD TO THE SOFTWARE.
  8. LIMITATION OF LIABILITIES
    O2 Solutions' liability, whether in contract, or otherwise, arising out of Licensee's use of, or in connection with, the SOFTWARE, or otherwise under this Agreement, shall not exceed the amount of the license fee paid by you to O2 Solutions. IN NO EVENT SHALL O2 SOLUTIONS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS
    OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE, EVEN IF O2 SOLUTIONS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

License activation

After you purchase the PDFView4NET toolkit, you will receive a serial number for unlocking the evaluation version.

NOTE: The serial numbers are case sensitive

Unlocking the PDFRender4NET class library

The PDFFile class has a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from the PDF renderings and prints.

Unlocking the PDFView4NET Windows Forms controls

The PDFDocument Windows Forms component has a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from the associated PDFPageView control.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Deployment

All the assemblies included in PDFView4NET toolkit can be used the XCOPY deployment, no additional configurations are needed.

All the assemblies are strong named so they can be deployed to Global Assembly Cache (GAC) if needed.

Deploying PDFView4NET with .NET Windows Forms applications

If you are using the PDFView4NET Windows Forms controls then the following assemblies are required to be deployed with your application: o2s.components.pdfview4net.dll.

If you are using the PDF rendering, printing and conversion library then the following assemblies are required to be deployed with your application: o2s.components.pdfrender4net.dll.

The assemblies can be deployed in the same folder with your application's executable or they can be deployed to GAC.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

O2S.Components.PDFRender4NET Assembly
Namespaces
Namespace | Description
O2S.Components.PDFRender4NET |
O2S.Components.PDFRender4NET.Exceptions |
Send Feedback


%%ItemTitle%%

O2S.Components.PDFRender4NET Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PageRenderingErrorEventArgs | Defines the arguments for page rendering error event.
Class | PDFFile | Represents an existing PDF file.
Class | PDFSize | Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.
See Also

Reference

O2S.Components.PDFRender4NET Assembly


%%PageItemTitle%%

PageRenderingErrorEventArgs Class
Members

O2S.Components.PDFRender4NET Namespace : PageRenderingErrorEventArgs Class
Defines the arguments for page rendering error event.
Object Model
PageRenderingErrorEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PageRenderingErrorEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PageRenderingErrorEventArgs
public class PageRenderingErrorEventArgs : System.EventArgs
public __gc class PageRenderingErrorEventArgs : public System.EventArgs
public ref class PageRenderingErrorEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFRender4NET.PageRenderingErrorEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Members
O2S.Components.PDFRender4NET Namespace


%%PageItemTitle%% $$Members$$

PageRenderingErrorEventArgs Class Members
Properties

O2S.Components.PDFRender4NET Namespace : PageRenderingErrorEventArgs Class

The following tables list the members exposed by PageRenderingErrorEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PageRenderingErrorEventArgs Constructor | Initializes a new PageRenderingErrorEventArgs object.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the page rendering should be cancelled or not.
Public Property | ErrorMessage | Gets the associated error message.
Public Property | PageNumber | Gets the page number where the error appeared.
Public Property | PageRenderingError | Gets the type of the error that appeared.
Top
See Also

Reference

PageRenderingErrorEventArgs Class
O2S.Components.PDFRender4NET Namespace


%%PageItemTitle%%

PageRenderingErrorEventArgs Constructor

O2S.Components.PDFRender4NET Namespace > PageRenderingErrorEventArgs Class : PageRenderingErrorEventArgs Constructor
The page number on which the error appeared.
The type of the error that appeared.
Optional error message.
Initializes a new PageRenderingErrorEventArgs object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageNumber As Integer, _
   ByVal pageRenderingError As PDFPageRenderingError, _
   ByVal errorMessage As String _
)
'Usage

Dim pageNumber As Integer
Dim pageRenderingError As PDFPageRenderingError
Dim errorMessage As String

Dim instance As New PageRenderingErrorEventArgs(pageNumber, pageRenderingError, errorMessage)
public PageRenderingErrorEventArgs(
   int pageNumber,
   PDFPageRenderingError pageRenderingError,
   string errorMessage
)
public: PageRenderingErrorEventArgs(
   int pageNumber,
   PDFPageRenderingError pageRenderingError,
   string* errorMessage
)
public:
PageRenderingErrorEventArgs(
   int pageNumber,
   PDFPageRenderingError pageRenderingError,
   String^ errorMessage
)

Parameters

pageNumber
The page number on which the error appeared.
pageRenderingError
The type of the error that appeared.
errorMessage
Optional error message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%PageItemTitle%% $$Properties$$

PageRenderingErrorEventArgs Class Properties

O2S.Components.PDFRender4NET Namespace : PageRenderingErrorEventArgs Class

For a list of all members of this type, see PageRenderingErrorEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the page rendering should be cancelled or not.
Public Property | ErrorMessage | Gets the associated error message.
Public Property | PageNumber | Gets the page number where the error appeared.
Public Property | PageRenderingError | Gets the type of the error that appeared.
Top
See Also

Reference

PageRenderingErrorEventArgs Class
O2S.Components.PDFRender4NET Namespace


%%ItemTitle%%

Cancel Property (PageRenderingErrorEventArgs)

O2S.Components.PDFRender4NET Namespace > PageRenderingErrorEventArgs Class : Cancel Property
Gets or sets a value indicating whether the page rendering should be cancelled or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As PageRenderingErrorEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

True if the rest of the page should not be rendered, otherwise false. Default false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%ItemTitle%%

ErrorMessage Property (PageRenderingErrorEventArgs)

O2S.Components.PDFRender4NET Namespace > PageRenderingErrorEventArgs Class : ErrorMessage Property
Gets the associated error message.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ErrorMessage As String
'Usage

Dim instance As PageRenderingErrorEventArgs
Dim value As String

value = instance.ErrorMessage
public string ErrorMessage {get;}
public: __property string* get_ErrorMessage();
public:
property String^ ErrorMessage {
   String^ get();
}

Property Value

Message with details about the error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%ItemTitle%%

PageNumber Property (PageRenderingErrorEventArgs)

O2S.Components.PDFRender4NET Namespace > PageRenderingErrorEventArgs Class : PageNumber Property
Gets the page number where the error appeared.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As PageRenderingErrorEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

The number of page where the error appeared.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%ItemTitle%%

PageRenderingError Property (PageRenderingErrorEventArgs)

O2S.Components.PDFRender4NET Namespace > PageRenderingErrorEventArgs Class : PageRenderingError Property
Gets the type of the error that appeared.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageRenderingError As PDFPageRenderingError
'Usage

Dim instance As PageRenderingErrorEventArgs
Dim value As PDFPageRenderingError

value = instance.PageRenderingError
public PDFPageRenderingError PageRenderingError {get;}
public: __property PDFPageRenderingError get_PageRenderingError();
public:
property PDFPageRenderingError PageRenderingError {
   PDFPageRenderingError get();
}

Property Value

The type of error that appeared during page rendering.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%PageItemTitle%%

PDFFile Class
Members

O2S.Components.PDFRender4NET Namespace : PDFFile Class
Represents an existing PDF file.
Object Model
PDFFile Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFile
'Usage

Dim instance As PDFFile
public class PDFFile
public __gc class PDFFile
public ref class PDFFile
Inheritance Hierarchy

System.Object
O2S.Components.PDFRender4NET.PDFFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Members
O2S.Components.PDFRender4NET Namespace


%%PageItemTitle%% $$Members$$

PDFFile Class Members
Properties Methods Events

O2S.Components.PDFRender4NET Namespace : PDFFile Class

The following tables list the members exposed by PDFFile.

Public Properties
 | Name | Description
Public Property | BWConversionThreshold | Gets or sets the threshold for B/W conversion.
Public Property | PageCount | Gets the number of pages in the PDF file.
Public Property | SerialNumber | Sets the serial number and unlocks the component.
Public Property | SubstituteFonts | Specifies a collection of fonts to be used when the corresponding font is not embedded in the PDF file.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Closes the PDF file and frees all resources.
Public Method | GetBWPageImage | Overloaded.
Public Method | GetBWPageImagesAsMultipageTiff | Overloaded.
Public Method | GetPageImage | Overloaded. Renders a PDF page to a System.Drawing.Bitmap object.
Public Method | GetPageImagesAsMultipageTiff | Overloaded. Renders all the pages of the PDF file to a multi page TIFF image.
Public Method | GetPageSize | Gets the size of a page in points.
static (Shared in Visual Basic) | Open | Overloaded. Creates a PDFFile object from the given pdf file.
Public Method | Print | Overloaded. Prints the PDF file with the specified settings.
Public Method | RenderPage | Overloaded. Renders the specified page on a graphics surface.
Top
Public Events
 | Name | Description
Public Event | AfterPrintPage | Fired after a PDF page is printed.
Public Event | BeforePrintPage | Fired before a PDF page is printed.
Public Event | PageRenderingError | Gets or sets the event being fired when a page rendering error has occured.
Public Event | PrintProgress | Fired after a PDF page is printed, to notify about the progress of the print operation.
Public Event | QueryPageSettings | Fired before a PDF page is printed for setting page properties.
Top
See Also

Reference

PDFFile Class
O2S.Components.PDFRender4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFFile Class Methods

O2S.Components.PDFRender4NET Namespace : PDFFile Class

For a list of all members of this type, see PDFFile members.

Public Methods
 | Name | Description
Public Method | Dispose | Closes the PDF file and frees all resources.
Public Method | GetBWPageImage | Overloaded.
Public Method | GetBWPageImagesAsMultipageTiff | Overloaded.
Public Method | GetPageImage | Overloaded. Renders a PDF page to a System.Drawing.Bitmap object.
Public Method | GetPageImagesAsMultipageTiff | Overloaded. Renders all the pages of the PDF file to a multi page TIFF image.
Public Method | GetPageSize | Gets the size of a page in points.
static (Shared in Visual Basic) | Open | Overloaded. Creates a PDFFile object from the given pdf file.
Public Method | Print | Overloaded. Prints the PDF file with the specified settings.
Public Method | RenderPage | Overloaded. Renders the specified page on a graphics surface.
Top
See Also

Reference

PDFFile Class
O2S.Components.PDFRender4NET Namespace


%%ItemTitle%%

Dispose Method (PDFFile)

O2S.Components.PDFRender4NET Namespace > PDFFile Class : Dispose Method
Closes the PDF file and frees all resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PDFFile

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

GetBWPageImage Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class : GetBWPageImage Method
Overload List
Overload | Description
GetBWPageImage(Int32,Double) |
GetBWPageImage(Int32,Double,PDFPrintContent) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

GetBWPageImage(Int32,Double) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetBWPageImage Method : GetBWPageImage(Int32,Double) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetBWPageImage( _
   ByVal pageNumber As Integer, _
   ByVal resolution As Double _
) As Bitmap
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim resolution As Double
Dim value As Bitmap

value = instance.GetBWPageImage(pageNumber, resolution)
public Bitmap GetBWPageImage(
   int pageNumber,
   double resolution
)
public: Bitmap* GetBWPageImage(
   int pageNumber,
   double resolution
)
public:
Bitmap^ GetBWPageImage(
   int pageNumber,
   double resolution
)

Parameters

pageNumber
resolution
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetBWPageImage(Int32,Double,PDFPrintContent) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetBWPageImage Method : GetBWPageImage(Int32,Double,PDFPrintContent) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetBWPageImage( _
   ByVal pageNumber As Integer, _
   ByVal resolution As Double, _
   ByVal printContent As PDFPrintContent _
) As Bitmap
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim resolution As Double
Dim printContent As PDFPrintContent
Dim value As Bitmap

value = instance.GetBWPageImage(pageNumber, resolution, printContent)
public Bitmap GetBWPageImage(
   int pageNumber,
   double resolution,
   PDFPrintContent printContent
)
public: Bitmap* GetBWPageImage(
   int pageNumber,
   double resolution,
   PDFPrintContent printContent
)
public:
Bitmap^ GetBWPageImage(
   int pageNumber,
   double resolution,
   PDFPrintContent printContent
)

Parameters

pageNumber
resolution
printContent
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetBWPageImagesAsMultipageTiff Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class : GetBWPageImagesAsMultipageTiff Method
Overload List
Overload | Description
GetBWPageImagesAsMultipageTiff(String,Double) |
GetBWPageImagesAsMultipageTiff(Stream,Double) |
GetBWPageImagesAsMultipageTiff(Double) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

GetBWPageImagesAsMultipageTiff(String,Double) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetBWPageImagesAsMultipageTiff Method : GetBWPageImagesAsMultipageTiff(String,Double) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub GetBWPageImagesAsMultipageTiff( _
   ByVal file As String, _
   ByVal resolution As Double _
)
'Usage

Dim instance As PDFFile
Dim file As String
Dim resolution As Double

instance.GetBWPageImagesAsMultipageTiff(file, resolution)
public void GetBWPageImagesAsMultipageTiff(
   string file,
   double resolution
)
public: void GetBWPageImagesAsMultipageTiff(
   string* file,
   double resolution
)
public:
void GetBWPageImagesAsMultipageTiff(
   String^ file,
   double resolution
)

Parameters

file
resolution
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetBWPageImagesAsMultipageTiff(Stream,Double) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetBWPageImagesAsMultipageTiff Method : GetBWPageImagesAsMultipageTiff(Stream,Double) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub GetBWPageImagesAsMultipageTiff( _
   ByVal stream As Stream, _
   ByVal resolution As Double _
)
'Usage

Dim instance As PDFFile
Dim stream As Stream
Dim resolution As Double

instance.GetBWPageImagesAsMultipageTiff(stream, resolution)
public void GetBWPageImagesAsMultipageTiff(
   Stream stream,
   double resolution
)
public: void GetBWPageImagesAsMultipageTiff(
   Stream* stream,
   double resolution
)
public:
void GetBWPageImagesAsMultipageTiff(
   Stream^ stream,
   double resolution
)

Parameters

stream
resolution
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetBWPageImagesAsMultipageTiff(Double) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetBWPageImagesAsMultipageTiff Method : GetBWPageImagesAsMultipageTiff(Double) Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetBWPageImagesAsMultipageTiff( _
   ByVal resolution As Double _
) As MemoryStream
'Usage

Dim instance As PDFFile
Dim resolution As Double
Dim value As MemoryStream

value = instance.GetBWPageImagesAsMultipageTiff(resolution)
public MemoryStream GetBWPageImagesAsMultipageTiff(
   double resolution
)
public: MemoryStream* GetBWPageImagesAsMultipageTiff(
   double resolution
)
public:
MemoryStream^ GetBWPageImagesAsMultipageTiff(
   double resolution
)

Parameters

resolution
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetPageImage Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class : GetPageImage Method
Renders a PDF page to a System.Drawing.Bitmap object.
Overload List
Overload | Description
GetPageImage(Int32,Double) | Renders a PDF page to a System.Drawing.Bitmap object.
GetPageImage(Int32,Double,PDFPrintContent) | Renders a PDF page to a System.Drawing.Bitmap object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

GetPageImage(Int32,Double) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetPageImage Method : GetPageImage(Int32,Double) Method
The number of the page to render.
The resolution the page will be rendered at.
Renders a PDF page to a System.Drawing.Bitmap object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetPageImage( _
   ByVal pageNumber As Integer, _
   ByVal resolution As Double _
) As Bitmap
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim resolution As Double
Dim value As Bitmap

value = instance.GetPageImage(pageNumber, resolution)
public Bitmap GetPageImage(
   int pageNumber,
   double resolution
)
public: Bitmap* GetPageImage(
   int pageNumber,
   double resolution
)
public:
Bitmap^ GetPageImage(
   int pageNumber,
   double resolution
)

Parameters

pageNumber
The number of the page to render.
resolution
The resolution the page will be rendered at.

Return Value

A System.Drawing.Bitmap object representing the PDF page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetPageImage(Int32,Double,PDFPrintContent) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetPageImage Method : GetPageImage(Int32,Double,PDFPrintContent) Method
The number of the page to render.
The resolution the page will be rendered at.
The page content to be rendered.
Renders a PDF page to a System.Drawing.Bitmap object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetPageImage( _
   ByVal pageNumber As Integer, _
   ByVal resolution As Double, _
   ByVal printContent As PDFPrintContent _
) As Bitmap
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim resolution As Double
Dim printContent As PDFPrintContent
Dim value As Bitmap

value = instance.GetPageImage(pageNumber, resolution, printContent)
public Bitmap GetPageImage(
   int pageNumber,
   double resolution,
   PDFPrintContent printContent
)
public: Bitmap* GetPageImage(
   int pageNumber,
   double resolution,
   PDFPrintContent printContent
)
public:
Bitmap^ GetPageImage(
   int pageNumber,
   double resolution,
   PDFPrintContent printContent
)

Parameters

pageNumber
The number of the page to render.
resolution
The resolution the page will be rendered at.
printContent
The page content to be rendered.

Return Value

A System.Drawing.Bitmap object representing the PDF page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetPageImagesAsMultipageTiff Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class : GetPageImagesAsMultipageTiff Method
Renders all the pages of the PDF file to a multi page TIFF image.
Overload List
Overload | Description
GetPageImagesAsMultipageTiff(String,Double) | Renders all the pages of the PDF file to a multi page TIFF image.
GetPageImagesAsMultipageTiff(Stream,Double) | Renders all the pages of the PDF file to a multi page TIFF image.
GetPageImagesAsMultipageTiff(Double) | Renders all the pages of the PDF file to a multi page TIFF image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

GetPageImagesAsMultipageTiff(String,Double) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetPageImagesAsMultipageTiff Method : GetPageImagesAsMultipageTiff(String,Double) Method
The physical path where the TIFF image will be stored.
The resolution the pages will be rendered at.
Renders all the pages of the PDF file to a multi page TIFF image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub GetPageImagesAsMultipageTiff( _
   ByVal file As String, _
   ByVal resolution As Double _
)
'Usage

Dim instance As PDFFile
Dim file As String
Dim resolution As Double

instance.GetPageImagesAsMultipageTiff(file, resolution)
public void GetPageImagesAsMultipageTiff(
   string file,
   double resolution
)
public: void GetPageImagesAsMultipageTiff(
   string* file,
   double resolution
)
public:
void GetPageImagesAsMultipageTiff(
   String^ file,
   double resolution
)

Parameters

file
The physical path where the TIFF image will be stored.
resolution
The resolution the pages will be rendered at.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetPageImagesAsMultipageTiff(Stream,Double) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetPageImagesAsMultipageTiff Method : GetPageImagesAsMultipageTiff(Stream,Double) Method
The stream where the TIFF image will be stored.
The resolution the pages will be rendered at.
Renders all the pages of the PDF file to a multi page TIFF image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub GetPageImagesAsMultipageTiff( _
   ByVal stream As Stream, _
   ByVal resolution As Double _
)
'Usage

Dim instance As PDFFile
Dim stream As Stream
Dim resolution As Double

instance.GetPageImagesAsMultipageTiff(stream, resolution)
public void GetPageImagesAsMultipageTiff(
   Stream stream,
   double resolution
)
public: void GetPageImagesAsMultipageTiff(
   Stream* stream,
   double resolution
)
public:
void GetPageImagesAsMultipageTiff(
   Stream^ stream,
   double resolution
)

Parameters

stream
The stream where the TIFF image will be stored.
resolution
The resolution the pages will be rendered at.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetPageImagesAsMultipageTiff(Double) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > GetPageImagesAsMultipageTiff Method : GetPageImagesAsMultipageTiff(Double) Method
The resolution the pages will be rendered at.
Renders all the pages of the PDF file to a multi page TIFF image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetPageImagesAsMultipageTiff( _
   ByVal resolution As Double _
) As MemoryStream
'Usage

Dim instance As PDFFile
Dim resolution As Double
Dim value As MemoryStream

value = instance.GetPageImagesAsMultipageTiff(resolution)
public MemoryStream GetPageImagesAsMultipageTiff(
   double resolution
)
public: MemoryStream* GetPageImagesAsMultipageTiff(
   double resolution
)
public:
MemoryStream^ GetPageImagesAsMultipageTiff(
   double resolution
)

Parameters

resolution
The resolution the pages will be rendered at.

Return Value

A memory stream storing the TIFF image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

GetPageSize(Int32) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class : GetPageSize(Int32) Method
The number of the page.
Gets the size of a page in points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPageSize( _
   ByVal pageNumber As Integer _
) As PDFSize
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFSize

value = instance.GetPageSize(pageNumber)
public PDFSize GetPageSize(
   int pageNumber
)
public: PDFSize* GetPageSize(
   int pageNumber
)
public:
PDFSize^ GetPageSize(
   int pageNumber
)

Parameters

pageNumber
The number of the page.

Return Value

The size of the page in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

Open Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class : Open Method
Creates a PDFFile object from the given pdf file.
Overload List
Overload | Description
Open(String) | Creates a PDFFile object from the given pdf file.
Open(String,Byte[]) | Creates a PDFFile object from the given pdf file.
Open(Stream) | Creates a PDFFile object from the given stream object.
Open(Stream,Byte[]) | Creates a PDFFile object from the given stream object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

Open(String) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > Open Method : Open(String) Method
the full path to a pdf file used as source for this PDFFile object.
Creates a PDFFile object from the given pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Open( _
   ByVal fileName As String _
) As PDFFile
'Usage

Dim fileName As String
Dim value As PDFFile

value = PDFFile.Open(fileName)
public static PDFFile Open(
   string fileName
)
public: static PDFFile* Open(
   string* fileName
)
public:
static PDFFile^ Open(
   String^ fileName
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.

Return Value

A PDFFile object created based on the given pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

Open(String,Byte[]) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > Open Method : Open(String,Byte[]) Method
the full path to a pdf file used as source for this PDFFile object.
the user password used to decrypt the PDF file.
Creates a PDFFile object from the given pdf file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Open( _
   ByVal fileName As String, _
   ByVal userPassword() As Byte _
) As PDFFile
'Usage

Dim fileName As String
Dim userPassword() As Byte
Dim value As PDFFile

value = PDFFile.Open(fileName, userPassword)
public static PDFFile Open(
   string fileName,
   byte[] userPassword
)
public: static PDFFile* Open(
   string* fileName,
   byte[]* userPassword
)
public:
static PDFFile^ Open(
   String^ fileName,
   array<byte>^ userPassword
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

Open(Stream) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > Open Method : Open(Stream) Method
the stream object used as source for this PDFFile object.
Creates a PDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Open( _
   ByVal stream As Stream _
) As PDFFile
'Usage

Dim stream As Stream
Dim value As PDFFile

value = PDFFile.Open(stream)
public static PDFFile Open(
   Stream stream
)
public: static PDFFile* Open(
   Stream* stream
)
public:
static PDFFile^ Open(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this PDFFile object.

Return Value

A PDFFile object created based on the given stream object.
Remarks
The stream must contain a valid pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

Open(Stream,Byte[]) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > Open Method : Open(Stream,Byte[]) Method
the stream object used as source for this PDFFile object.
the user password used to decrypt the PDF file.
Creates a PDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Open( _
   ByVal stream As Stream, _
   ByVal userPassword() As Byte _
) As PDFFile
'Usage

Dim stream As Stream
Dim userPassword() As Byte
Dim value As PDFFile

value = PDFFile.Open(stream, userPassword)
public static PDFFile Open(
   Stream stream,
   byte[] userPassword
)
public: static PDFFile* Open(
   Stream* stream,
   byte[]* userPassword
)
public:
static PDFFile^ Open(
   Stream^ stream,
   array<byte>^ userPassword
)

Parameters

stream
the stream object used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given stream object.
Remarks
The stream must contain a valid pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

Print Method (PDFFile)

O2S.Components.PDFRender4NET Namespace > PDFFile Class : Print Method
Prints the PDF file with the specified settings.
Overload List
Overload | Description
Print(PDFPrintSettings) | Prints the PDF file with the specified settings.
Print(PDFPrintSettings,PDFPrintContent) | Prints the PDF file with the specified settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

Print(PDFPrintSettings) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > Print Method : Print(PDFPrintSettings) Method
Settings for printing the PDF file.
Prints the PDF file with the specified settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Print( _
   ByVal settings As PDFPrintSettings _
)
'Usage

Dim instance As PDFFile
Dim settings As PDFPrintSettings

instance.Print(settings)
public void Print(
   PDFPrintSettings settings
)
public: void Print(
   PDFPrintSettings* settings
)
public:
void Print(
   PDFPrintSettings^ settings
)

Parameters

settings
Settings for printing the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

Print(PDFPrintSettings,PDFPrintContent) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > Print Method : Print(PDFPrintSettings,PDFPrintContent) Method
Settings for printing the PDF file.
The content to be printed.
Prints the PDF file with the specified settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Print( _
   ByVal settings As PDFPrintSettings, _
   ByVal printContent As PDFPrintContent _
)
'Usage

Dim instance As PDFFile
Dim settings As PDFPrintSettings
Dim printContent As PDFPrintContent

instance.Print(settings, printContent)
public void Print(
   PDFPrintSettings settings,
   PDFPrintContent printContent
)
public: void Print(
   PDFPrintSettings* settings,
   PDFPrintContent printContent
)
public:
void Print(
   PDFPrintSettings^ settings,
   PDFPrintContent printContent
)

Parameters

settings
Settings for printing the PDF file.
printContent
The content to be printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

RenderPage Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class : RenderPage Method
Renders the specified page on a graphics surface.
Overload List
Overload | Description
RenderPage(Int32,Graphics) | Renders the specified page on a graphics surface.
RenderPage(Int32,Graphics,PDFPrintContent) | Renders the specified page on a graphics surface.
RenderPage(Int32,Graphics,Double,Double) | Renders the specified page on a graphics surface.
RenderPage(Int32,Graphics,Double,Double,PDFPrintContent) | Renders the specified page on a graphics surface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

RenderPage(Int32,Graphics) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > RenderPage Method : RenderPage(Int32,Graphics) Method
The number of the page to render.
The drawing surface.
Renders the specified page on a graphics surface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub RenderPage( _
   ByVal pageNumber As Integer, _
   ByVal g As Graphics _
)
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim g As Graphics

instance.RenderPage(pageNumber, g)
public void RenderPage(
   int pageNumber,
   Graphics g
)
public: void RenderPage(
   int pageNumber,
   Graphics* g
)
public:
void RenderPage(
   int pageNumber,
   Graphics^ g
)

Parameters

pageNumber
The number of the page to render.
g
The drawing surface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

RenderPage(Int32,Graphics,PDFPrintContent) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > RenderPage Method : RenderPage(Int32,Graphics,PDFPrintContent) Method
The number of the page to render.
The drawing surface.
The page content to be rendered.
Renders the specified page on a graphics surface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub RenderPage( _
   ByVal pageNumber As Integer, _
   ByVal g As Graphics, _
   ByVal printContent As PDFPrintContent _
)
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim g As Graphics
Dim printContent As PDFPrintContent

instance.RenderPage(pageNumber, g, printContent)
public void RenderPage(
   int pageNumber,
   Graphics g,
   PDFPrintContent printContent
)
public: void RenderPage(
   int pageNumber,
   Graphics* g,
   PDFPrintContent printContent
)
public:
void RenderPage(
   int pageNumber,
   Graphics^ g,
   PDFPrintContent printContent
)

Parameters

pageNumber
The number of the page to render.
g
The drawing surface.
printContent
The page content to be rendered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

RenderPage(Int32,Graphics,Double,Double) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > RenderPage Method : RenderPage(Int32,Graphics,Double,Double) Method
The number of the page to render.
The drawing surface.
The X coordinate of the top left corner of the page.
The Y coordinate of the top left corner of the page.
Renders the specified page on a graphics surface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub RenderPage( _
   ByVal pageNumber As Integer, _
   ByVal g As Graphics, _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim g As Graphics
Dim x As Double
Dim y As Double

instance.RenderPage(pageNumber, g, x, y)
public void RenderPage(
   int pageNumber,
   Graphics g,
   double x,
   double y
)
public: void RenderPage(
   int pageNumber,
   Graphics* g,
   double x,
   double y
)
public:
void RenderPage(
   int pageNumber,
   Graphics^ g,
   double x,
   double y
)

Parameters

pageNumber
The number of the page to render.
g
The drawing surface.
x
The X coordinate of the top left corner of the page.
y
The Y coordinate of the top left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%ItemTitle%%

RenderPage(Int32,Graphics,Double,Double,PDFPrintContent) Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class > RenderPage Method : RenderPage(Int32,Graphics,Double,Double,PDFPrintContent) Method
The number of the page to render.
The drawing surface.
The X coordinate of the top left corner of the page.
The Y coordinate of the top left corner of the page.
The page content to be rendered.
Renders the specified page on a graphics surface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub RenderPage( _
   ByVal pageNumber As Integer, _
   ByVal g As Graphics, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal printContent As PDFPrintContent _
)
'Usage

Dim instance As PDFFile
Dim pageNumber As Integer
Dim g As Graphics
Dim x As Double
Dim y As Double
Dim printContent As PDFPrintContent

instance.RenderPage(pageNumber, g, x, y, printContent)
public void RenderPage(
   int pageNumber,
   Graphics g,
   double x,
   double y,
   PDFPrintContent printContent
)
public: void RenderPage(
   int pageNumber,
   Graphics* g,
   double x,
   double y,
   PDFPrintContent printContent
)
public:
void RenderPage(
   int pageNumber,
   Graphics^ g,
   double x,
   double y,
   PDFPrintContent printContent
)

Parameters

pageNumber
The number of the page to render.
g
The drawing surface.
x
The X coordinate of the top left corner of the page.
y
The Y coordinate of the top left corner of the page.
printContent
The page content to be rendered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFile Class Properties

O2S.Components.PDFRender4NET Namespace : PDFFile Class

For a list of all members of this type, see PDFFile members.

Public Properties
 | Name | Description
Public Property | BWConversionThreshold | Gets or sets the threshold for B/W conversion.
Public Property | PageCount | Gets the number of pages in the PDF file.
Public Property | SerialNumber | Sets the serial number and unlocks the component.
Public Property | SubstituteFonts | Specifies a collection of fonts to be used when the corresponding font is not embedded in the PDF file.
Top
See Also

Reference

PDFFile Class
O2S.Components.PDFRender4NET Namespace


%%ItemTitle%%

BWConversionThreshold Property

O2S.Components.PDFRender4NET Namespace > PDFFile Class : BWConversionThreshold Property
Gets or sets the threshold for B/W conversion.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BWConversionThreshold As Integer
'Usage

Dim instance As PDFFile
Dim value As Integer

instance.BWConversionThreshold = value

value = instance.BWConversionThreshold
public int BWConversionThreshold {get; set;}
public: __property int get_BWConversionThreshold();
public: __property void set_BWConversionThreshold(
   int value
);
public:
property int BWConversionThreshold {
   int get();
   void set (    int value);
}

Property Value

A value between 0 and 765.
Remarks
The sum of RGB pixel values is compared to the threshold. If the value is greater the pixel becomes white, if the value is lower the pixel becomes black.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

PageCount Property (PDFFile)

O2S.Components.PDFRender4NET Namespace > PDFFile Class : PageCount Property
Gets the number of pages in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageCount As Integer
'Usage

Dim instance As PDFFile
Dim value As Integer

value = instance.PageCount
public int PageCount {get;}
public: __property int get_PageCount();
public:
property int PageCount {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

SerialNumber Property (PDFFile)

O2S.Components.PDFRender4NET Namespace > PDFFile Class : SerialNumber Property
Sets the serial number and unlocks the component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public WriteOnly Property SerialNumber As String
'Usage

Dim instance As PDFFile

instance.SerialNumber = value
public string SerialNumber {set;}
public: __property void set_SerialNumber(
   string* value
);
public:
property String^ SerialNumber {
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

SubstituteFonts Property (PDFFile)

O2S.Components.PDFRender4NET Namespace > PDFFile Class : SubstituteFonts Property
Specifies a collection of fonts to be used when the corresponding font is not embedded in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubstituteFonts As Dictionary(Of String,String)
'Usage

Dim instance As PDFFile
Dim value As Dictionary(Of String,String)

instance.SubstituteFonts = value

value = instance.SubstituteFonts
public Dictionary<string,string> SubstituteFonts {get; set;}
public: __property Dictionary<string*,string*>* get_SubstituteFonts();
public: __property void set_SubstituteFonts(
   Dictionary<string*,string*>* value
);
public:
property Dictionary<String^,String^>^ SubstituteFonts {
   Dictionary<String^,String^>^ get();
   void set (    Dictionary<String^,String^>^ value);
}
Remarks
This collection is searched before searching the local machine for the font. The key is the PDF font name, the value is the path to the corresponding TTF file to be used for rendering.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%% $$Events$$

PDFFile Class Events

O2S.Components.PDFRender4NET Namespace : PDFFile Class

For a list of all members of this type, see PDFFile members.

Public Events
 | Name | Description
Public Event | AfterPrintPage | Fired after a PDF page is printed.
Public Event | BeforePrintPage | Fired before a PDF page is printed.
Public Event | PageRenderingError | Gets or sets the event being fired when a page rendering error has occured.
Public Event | PrintProgress | Fired after a PDF page is printed, to notify about the progress of the print operation.
Public Event | QueryPageSettings | Fired before a PDF page is printed for setting page properties.
Top
See Also

Reference

PDFFile Class
O2S.Components.PDFRender4NET Namespace


%%ItemTitle%%

AfterPrintPage Event (PDFFile)

O2S.Components.PDFRender4NET Namespace > PDFFile Class : AfterPrintPage Event
Fired after a PDF page is printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterPrintPage As EventHandler(Of PrintPageEventArgs)
'Usage

Dim instance As PDFFile
Dim handler As EventHandler(Of PrintPageEventArgs)

AddHandler instance.AfterPrintPage, handler
public event EventHandler<PrintPageEventArgs> AfterPrintPage
public: __event EventHandler<PrintPageEventArgs*>* AfterPrintPage
public:
event EventHandler<PrintPageEventArgs^>^ AfterPrintPage
Event Data

The event handler receives an argument of type PrintPageEventArgs containing data related to this event. The following PrintPageEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the print job should be canceled.
Graphics | Gets the System.Drawing.Graphics used to paint the page.
HasMorePages | Gets or sets a value indicating whether an additional page should be printed.
MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins.
PageBounds | Gets the rectangular area that represents the total area of the page.
PageSettings | Gets the page settings for the current page.
Remarks
You can use this event to print content, such as stamps, on the page on the PDF content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

BeforePrintPage Event (PDFFile)

O2S.Components.PDFRender4NET Namespace > PDFFile Class : BeforePrintPage Event
Fired before a PDF page is printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event BeforePrintPage As EventHandler(Of PrintPageEventArgs)
'Usage

Dim instance As PDFFile
Dim handler As EventHandler(Of PrintPageEventArgs)

AddHandler instance.BeforePrintPage, handler
public event EventHandler<PrintPageEventArgs> BeforePrintPage
public: __event EventHandler<PrintPageEventArgs*>* BeforePrintPage
public:
event EventHandler<PrintPageEventArgs^>^ BeforePrintPage
Event Data

The event handler receives an argument of type PrintPageEventArgs containing data related to this event. The following PrintPageEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the print job should be canceled.
Graphics | Gets the System.Drawing.Graphics used to paint the page.
HasMorePages | Gets or sets a value indicating whether an additional page should be printed.
MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins.
PageBounds | Gets the rectangular area that represents the total area of the page.
PageSettings | Gets the page settings for the current page.
Remarks
You can use this event to print content, such as watermarks, on the page under the PDF content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

PageRenderingError Event (PDFFile)

O2S.Components.PDFRender4NET Namespace > PDFFile Class : PageRenderingError Event
Gets or sets the event being fired when a page rendering error has occured.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageRenderingError As EventHandler(Of PageRenderingErrorEventArgs)
'Usage

Dim instance As PDFFile
Dim handler As EventHandler(Of PageRenderingErrorEventArgs)

AddHandler instance.PageRenderingError, handler
public event EventHandler<PageRenderingErrorEventArgs> PageRenderingError
public: __event EventHandler<PageRenderingErrorEventArgs*>* PageRenderingError
public:
event EventHandler<PageRenderingErrorEventArgs^>^ PageRenderingError
Event Data

The event handler receives an argument of type PageRenderingErrorEventArgs containing data related to this event. The following PageRenderingErrorEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the page rendering should be cancelled or not.
ErrorMessage | Gets the associated error message.
PageNumber | Gets the page number where the error appeared.
PageRenderingError | Gets the type of the error that appeared.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

PrintProgress Event (PDFFile)

O2S.Components.PDFRender4NET Namespace > PDFFile Class : PrintProgress Event
Fired after a PDF page is printed, to notify about the progress of the print operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PrintProgress As EventHandler(Of PrintProgressEventArgs)
'Usage

Dim instance As PDFFile
Dim handler As EventHandler(Of PrintProgressEventArgs)

AddHandler instance.PrintProgress, handler
public event EventHandler<PrintProgressEventArgs> PrintProgress
public: __event EventHandler<PrintProgressEventArgs*>* PrintProgress
public:
event EventHandler<PrintProgressEventArgs^>^ PrintProgress
Remarks
You can use this event to dispaly a progress bar that indicates the progress of the print operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%%

QueryPageSettings Event

O2S.Components.PDFRender4NET Namespace > PDFFile Class : QueryPageSettings Event
Fired before a PDF page is printed for setting page properties.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event QueryPageSettings As EventHandler(Of QueryPageSettingsEventArgs)
'Usage

Dim instance As PDFFile
Dim handler As EventHandler(Of QueryPageSettingsEventArgs)

AddHandler instance.QueryPageSettings, handler
public event EventHandler<QueryPageSettingsEventArgs> QueryPageSettings
public: __event EventHandler<QueryPageSettingsEventArgs*>* QueryPageSettings
public:
event EventHandler<QueryPageSettingsEventArgs^>^ QueryPageSettings
Event Data

The event handler receives an argument of type QueryPageSettingsEventArgs containing data related to this event. The following QueryPageSettingsEventArgs properties provide information specific to this event.

Property | Description
Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
PageSettings | Gets or sets the page settings for the page to be printed.
PrintAction | Returns System.Drawing.Printing.PrintAction.PrintToFile in all cases. (Inherited from System.Drawing.Printing.PrintEventArgs)
Remarks
You can use this event to change the page printing properties, such as paper size and paper source.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%PageItemTitle%%

PDFSize Class
Members

O2S.Components.PDFRender4NET Namespace : PDFSize Class
Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.
Object Model
PDFSize Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSize
'Usage

Dim instance As PDFSize
public class PDFSize
public __gc class PDFSize
public ref class PDFSize
Inheritance Hierarchy

System.Object
O2S.Components.PDFRender4NET.PDFSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Members
O2S.Components.PDFRender4NET Namespace


%%PageItemTitle%% $$Members$$

PDFSize Class Members
Properties

O2S.Components.PDFRender4NET Namespace : PDFSize Class

The following tables list the members exposed by PDFSize.

Public Constructors
 | Name | Description
Public Constructor | PDFSize Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height.
Public Property | Width | Gets or sets the width.
Top
See Also

Reference

PDFSize Class
O2S.Components.PDFRender4NET Namespace


%%PageItemTitle%%

PDFSize Constructor

O2S.Components.PDFRender4NET Namespace > PDFSize Class : PDFSize Constructor
Overload List
Overload | Description
PDFSize Constructor() | Initializes a new PDFSize object.
PDFSize Constructor(Double,Double) | Initializes a new PDFSize object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members


%%PageItemTitle%%

PDFSize Constructor()

O2S.Components.PDFRender4NET Namespace > PDFSize Class > PDFSize Constructor : PDFSize Constructor()
Initializes a new PDFSize object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSize()
public PDFSize()
public: PDFSize();
public:
PDFSize();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members
Overload List


%%PageItemTitle%%

PDFSize Constructor(Double,Double)

O2S.Components.PDFRender4NET Namespace > PDFSize Class > PDFSize Constructor : PDFSize Constructor(Double,Double)
The width.
The height.
Initializes a new PDFSize object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim width As Double
Dim height As Double

Dim instance As New PDFSize(width, height)
public PDFSize(
   double width,
   double height
)
public: PDFSize(
   double width,
   double height
)
public:
PDFSize(
   double width,
   double height
)

Parameters

width
The width.
height
The height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFSize Class Properties

O2S.Components.PDFRender4NET Namespace : PDFSize Class

For a list of all members of this type, see PDFSize members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height.
Public Property | Width | Gets or sets the width.
Top
See Also

Reference

PDFSize Class
O2S.Components.PDFRender4NET Namespace


%%ItemTitle%%

Height Property (PDFSize)

O2S.Components.PDFRender4NET Namespace > PDFSize Class : Height Property
Gets or sets the height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PDFSize
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public: __property double get_Height();
public: __property void set_Height(
   double value
);
public:
property double Height {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members


%%ItemTitle%%

Width Property (PDFSize)

O2S.Components.PDFRender4NET Namespace > PDFSize Class : Width Property
Gets or sets the width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFSize
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members


%%ItemTitle%%

O2S.Components.PDFRender4NET.Exceptions Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | FontParserException | Defines the exception thrown when errors are encountered when parsing the font files.
Class | InvalidPageException | Defines the exception thrown when the page object is not valid.
Class | InvalidPasswordException | Defines the exception thrown when the password for opening the PDF file is not valid.
Class | PageRenderingException | Defines the exception thrown when errors are encountered in the page content.
Enumerations
 | Enumeration | Description
Enumeration | PDFPageRenderingError | Specifies the possible errors that can appear during the rendering of a PDF page.
See Also

Reference

O2S.Components.PDFRender4NET Assembly


%%PageItemTitle%%

FontParserException Class
Members

O2S.Components.PDFRender4NET.Exceptions Namespace : FontParserException Class
Defines the exception thrown when errors are encountered when parsing the font files.
Object Model
FontParserException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class FontParserException
   Inherits System.ApplicationException
'Usage

Dim instance As FontParserException
[Serializable()]
public class FontParserException : System.ApplicationException
[Serializable()]
public __gc class FontParserException : public System.ApplicationException
[Serializable()]
public ref class FontParserException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFRender4NET.Exceptions.FontParserException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontParserException Members
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%% $$Members$$

FontParserException Class Members
Properties Methods

O2S.Components.PDFRender4NET.Exceptions Namespace : FontParserException Class

The following tables list the members exposed by FontParserException.

Public Constructors
 | Name | Description
Public Constructor | FontParserException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

FontParserException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%%

FontParserException Constructor

O2S.Components.PDFRender4NET.Exceptions Namespace > FontParserException Class : FontParserException Constructor
Overload List
Overload | Description
FontParserException Constructor(String) | Initializes a new FontParsingException object.
FontParserException Constructor(String,Exception) | Initializes a new FontParserException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontParserException Class
FontParserException Members


%%PageItemTitle%%

FontParserException Constructor(String)

O2S.Components.PDFRender4NET.Exceptions Namespace > FontParserException Class > FontParserException Constructor : FontParserException Constructor(String)
The message with details about the error in the font data.
Initializes a new FontParsingException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New FontParserException(message)
public FontParserException(
   string message
)
public: FontParserException(
   string* message
)
public:
FontParserException(
   String^ message
)

Parameters

message
The message with details about the error in the font data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontParserException Class
FontParserException Members
Overload List


%%PageItemTitle%%

FontParserException Constructor(String,Exception)

O2S.Components.PDFRender4NET.Exceptions Namespace > FontParserException Class > FontParserException Constructor : FontParserException Constructor(String,Exception)
The message with details about the error in the font data.
Inner exception.
Initializes a new FontParserException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New FontParserException(message, innerException)
public FontParserException(
   string message,
   Exception innerException
)
public: FontParserException(
   string* message,
   Exception* innerException
)
public:
FontParserException(
   String^ message,
   Exception^ innerException
)

Parameters

message
The message with details about the error in the font data.
innerException
Inner exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FontParserException Class
FontParserException Members
Overload List


%%PageItemTitle%%

InvalidPageException Class
Members

O2S.Components.PDFRender4NET.Exceptions Namespace : InvalidPageException Class
Defines the exception thrown when the page object is not valid.
Object Model
InvalidPageException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class InvalidPageException
   Inherits System.ApplicationException
'Usage

Dim instance As InvalidPageException
[Serializable()]
public class InvalidPageException : System.ApplicationException
[Serializable()]
public __gc class InvalidPageException : public System.ApplicationException
[Serializable()]
public ref class InvalidPageException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFRender4NET.Exceptions.InvalidPageException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPageException Members
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%% $$Members$$

InvalidPageException Class Members
Properties Methods

O2S.Components.PDFRender4NET.Exceptions Namespace : InvalidPageException Class

The following tables list the members exposed by InvalidPageException.

Public Constructors
 | Name | Description
Public Constructor | InvalidPageException Constructor | Initializes a new InvalidPageException object.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPageException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%%

InvalidPageException Constructor

O2S.Components.PDFRender4NET.Exceptions Namespace > InvalidPageException Class : InvalidPageException Constructor
The message with details about the error in page content.
Initializes a new InvalidPageException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPageException(message)
public InvalidPageException(
   string message
)
public: InvalidPageException(
   string* message
)
public:
InvalidPageException(
   String^ message
)

Parameters

message
The message with details about the error in page content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPageException Class
InvalidPageException Members


%%PageItemTitle%%

InvalidPasswordException Class
Members

O2S.Components.PDFRender4NET.Exceptions Namespace : InvalidPasswordException Class
Defines the exception thrown when the password for opening the PDF file is not valid.
Object Model
InvalidPasswordException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class InvalidPasswordException
   Inherits System.ApplicationException
'Usage

Dim instance As InvalidPasswordException
[Serializable()]
public class InvalidPasswordException : System.ApplicationException
[Serializable()]
public __gc class InvalidPasswordException : public System.ApplicationException
[Serializable()]
public ref class InvalidPasswordException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFRender4NET.Exceptions.InvalidPasswordException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Members
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%% $$Members$$

InvalidPasswordException Class Members
Properties Methods

O2S.Components.PDFRender4NET.Exceptions Namespace : InvalidPasswordException Class

The following tables list the members exposed by InvalidPasswordException.

Public Constructors
 | Name | Description
Public Constructor | InvalidPasswordException Constructor | Initializes a new InvalidPasswordException object.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPasswordException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%%

InvalidPasswordException Constructor

O2S.Components.PDFRender4NET.Exceptions Namespace > InvalidPasswordException Class : InvalidPasswordException Constructor
The message with details about the error in page content.
Initializes a new InvalidPasswordException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPasswordException(message)
public InvalidPasswordException(
   string message
)
public: InvalidPasswordException(
   string* message
)
public:
InvalidPasswordException(
   String^ message
)

Parameters

message
The message with details about the error in page content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


%%PageItemTitle%%

PageRenderingException Class
Members

O2S.Components.PDFRender4NET.Exceptions Namespace : PageRenderingException Class
Defines the exception thrown when errors are encountered in the page content.
Object Model
PageRenderingException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PageRenderingException
   Inherits System.ApplicationException
'Usage

Dim instance As PageRenderingException
[Serializable()]
public class PageRenderingException : System.ApplicationException
[Serializable()]
public __gc class PageRenderingException : public System.ApplicationException
[Serializable()]
public ref class PageRenderingException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFRender4NET.Exceptions.PageRenderingException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingException Members
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%% $$Members$$

PageRenderingException Class Members
Properties Methods

O2S.Components.PDFRender4NET.Exceptions Namespace : PageRenderingException Class

The following tables list the members exposed by PageRenderingException.

Public Constructors
 | Name | Description
Public Constructor | PageRenderingException Constructor | Initializes a new PageRenderingException object.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PageRenderingException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%%

PageRenderingException Constructor

O2S.Components.PDFRender4NET.Exceptions Namespace > PageRenderingException Class : PageRenderingException Constructor
The message with details about the error in page content.
Initializes a new PageRenderingException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PageRenderingException(message)
public PageRenderingException(
   string message
)
public: PageRenderingException(
   string* message
)
public:
PageRenderingException(
   String^ message
)

Parameters

message
The message with details about the error in page content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingException Class
PageRenderingException Members


%%PageItemTitle%%

PDFPageRenderingError Enumeration

O2S.Components.PDFRender4NET.Exceptions Namespace : PDFPageRenderingError Enumeration
Specifies the possible errors that can appear during the rendering of a PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageRenderingError
   Inherits System.Enum
'Usage

Dim instance As PDFPageRenderingError
public enum PDFPageRenderingError : System.Enum
__value public enum PDFPageRenderingError : public System.Enum
public enum class PDFPageRenderingError : public System.Enum
Members
Member | Description
CmykJpeg | CMYK JPEG image is rendered as negative.
ContentStreamError | Content stream cannot be processed.
InvalidFontData | Font cannot be rendered.
JBig2 | JBIG2 image is not rendered.
Jpeg2000 | JPEG2000 image is not rendered.
TextClipPath | Text used as clipping path.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFRender4NET.Exceptions.PDFPageRenderingError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFRender4NET.Exceptions Namespace


%%ItemTitle%%

O2S.Components.PDFView4NET Assembly
Namespaces
Namespace | Description
O2S.Components.PDFView4NET |
O2S.Components.PDFView4NET.Actions |
O2S.Components.PDFView4NET.Annotations |
O2S.Components.PDFView4NET.Forms |
O2S.Components.PDFView4NET.Graphics |
O2S.Components.PDFView4NET.Graphics.Barcodes |
O2S.Components.PDFView4NET.Graphics.Fonts |
O2S.Components.PDFView4NET.Graphics.OptionalContent |
O2S.Components.PDFView4NET.Printing |
O2S.Components.PDFView4NET.Text |


%%ItemTitle%%

O2S.Components.PDFView4NET Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | AfterAnnotationAddEventArgs | Defines the parameters for the PDFPageView.AfterAnnotationAdd event.
Class | AfterAnnotationMoveEventArgs | Defines the parameters for the PDFPageView.AfterAnnotationMove event.
Class | AfterAnnotationResizeEventArgs | Defines the parameters for the PDFPageView.AfterAnnotationResize event.
Class | AfterFieldAddEventArgs | Defines the parameters for the PDFPageView.AfterFieldAdd event.
Class | AfterLinkExecuteEventArgs | Defines the parameters for the PDFPageView.AfterLinkExecute event.
Class | AfterPageReorderEventArgs | Defines the event args for PDFPageThumbnailView.AfterPageReorder event.
Class | AfterTextSelectEventArgs | Defines the parameters for the PDFPageView.AfterTextSelect event.
Class | AnnotationClickEventArgs | Defines the parameters for the PDFPageView.AnnotationClick and PDFPageView.AnnotationDoubleClick events.
Class | AnnotationContextMenuEventArgs | Defines the parameters for the PDFPageView.AnnotationContextMenu event.
Class | AnnotationToolTipDrawEventArgs | Defines the parameters for the PDFPageView.AnnotationToolTipDraw event.
Class | AnnotationToolTipPopupEventArgs | Defines the parameters for the PDFPageView.AnnotationToolTipPopup event.
Class | BeforeAnnotationAddEventArgs | Defines the parameters for the PDFPageView.BeforeAnnotationAdd event.
Class | BeforeFieldAddEventArgs | Defines the parameters for the PDFPageView.BeforeFieldAdd event.
Class | BeforeLinkExecuteEventArgs | Defines the parameters for the PDFPageView.BeforeLinkExecute event.
Class | BeforePageReorderEventArgs | Defines the event args for PDFPageThumbnailView.BeforePageReorder event.
Class | BookmarkClickEventArgs | Defines the parameters for the PDFBookmarksView.BookmarkClick and PDFBookmarksView.BookmarkDoubleClick events.
Class | BookmarkEventArgs | Defines the parameters for the PDFDocument.BookmarkAdded and PDFDocument.BookmarkRemoved events.
Class | DisplayRectangle | Defines a rectangle in display coordinates, relative to top left corner of the page.
Class | FieldClickEventArgs | Defines the parameters for the PDFPageView.FieldClick event.
Class | FieldContextMenuEventArgs | Defines the parameters for the PDFPageView.FieldContextMenu event.
Class | FieldEditEventArgs | Defines the parameters for the PDFPageView.FieldBeginEdit and PDFPageView.FieldEndEdit event.
Class | FieldValidateEventArgs | Defines the parameters for the PDFPageView.FieldValidate event.
Class | InvalidDocumentException | Defines the exception thrown when the PDF file is not valid.
Class | InvalidPasswordException | Defines the exception thrown when the password for opening the PDF file is not valid.
Class | PageClickEventArgs | Defines the parameters for the PDFPageView.PageClick and PDFPageView.PageDoubleClick events.
Class | PageContextMenuEventArgs | Defines the parameters for the page context menu event.
Class | PageRenderingErrorEventArgs | Defines the arguments for page rendering error event.
Class | PasswordRequiredEventArgs | Event arguments for PasswordRequired event.
Class | PDFAnnotationsView | Defines a viewer for the annotations in a PDF file.
Class | PDFAnnotationsViewCollection | Defines a collection of PDFAnnotationsView objects representing the viewers for a document's annotations.
Class | PDFAnnotationToolTip | Defines the way how tooltips are displayed for annotations.
Class | PDFBookmark | Defines a bookmark in a PDF file.
Class | PDFBookmarkCollection | Defines a collection of bookmarks.
Class | PDFBookmarksView | Defines a viewer for the bookmarks in a PDF file.
Class | PDFBookmarksViewCollection | Defines a collection of PDFBookmarksView objects representing the viewers for a document's bookmarks.
Class | PDFCollection<T,K> | Defines a collection that fires notifications when it changes or when an item in the collection changes its properties.
Class | PDFCollectionChangedEventArgs<T> | Defines the event arguments for the collection changed event.
Class | PDFDestination | Defines the base class for PDF destinations.
Class | PDFDigitalSignature | Defines a digital signature used for signing a PDF file.
Class | PDFDirectDestination | Defines the base class direct PDF destinations.
Class | PDFDocument | Defines a PDF document.
Class | PDFDocumentInformation | Provides access to document metadata.
Class | PDFException | Defines a generic PDF exception.
Class | PDFFileAttachment | Defines a file attachment embedded in the PDF file.
Class | PDFFileAttachmentCollection | Defines a collection of file attachments.
Class | PDFFileAttachmentsView | Defines a viewer for the bookmarks in a PDF file.
Class | PDFFileAttachmentsViewCollection | Defines a collection of PDFFileAttachmentsView objects representing the viewers for a document's file attachments.
Class | PDFGraphicsContainer | Defines an abstract object that can store graphic content.
Class | PDFMatrix | Defines a tranformation matrix in the PDF content stream.
Class | PDFNamedDestination | Defines a named PDF destination.
Class | PDFNamedDestinationCollection | Defines a collection of named destinations.
Class | PDFPage | Defines a PDF page.
Class | PDFPageCollection | Defines a collection of PDF pages.
Class | PDFPageDestination | Defines a destination to a page within the current document.
Class | PDFPageThumbnailView | Defines a viewer for page thumbnails.
Class | PDFPageThumbnailViewCollection | Defines a collection of PDFPageThumbnailViewCollection objects representing the viewers for a document's pages.
Class | PDFPageView | Defines a viewer for a PDF page.
Class | PDFPageViewCollection | Defines a collection of PDFPageView2Collection objects representing the viewers for a document's pages.
Class | PDFRectangle | Defines a rectangle in PDF default coordinates, where the origin of the coordinate system is located in the bottom left corner of the page.
Class | PDFRemotePageDestination | Defines a destination to a page in another PDF document.
Class | PDFSecurityManager | Manages the security settings for a pdf document.
Class | PDFSize | Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.
Class | PDFViewerPreferences | Defines the way the PDF document is displayed on the screen.
Class | PDFXMPMetadata | Defines the XMP metadata for a PDF document.
Class | UnsupportedEncryptionException | Defines the exceptions thrown when the PDF file is encrypted with an unknown encryption method.
Interfaces
 | Interface | Description
Interface | IRawPDFData | Defines an interface for accessing raw PDF data from a high level PDF object.
Enumerations
 | Enumeration | Description
Enumeration | ChangeType | Specify the available changes in a collection.
Enumeration | EncryptionAlgorithm | Specifies the available encryption algorithms.
Enumeration | EncryptionKeySize | Specifies the available key sizes when encrypting a pdf document.
Enumeration | PDFBookmarkDisplayStyle | Specifies the available modes for displaying a bookmark in a viewer application.
Enumeration | PDFDestinationZoomMode | Specifies the available zoom modes that can be applied when the PDF page specified in the destination is displayed.
Enumeration | PDFPageDisplayLayout | Specifies the possible display layouts to be used with the PDFPageView control.
Enumeration | PDFPageLayout | Specifies the possible page layouts to be used when the document is opened.
Enumeration | PDFPageMode | Specifies the possible modes to be display the document when it is opened.
Enumeration | PDFPageRenderingError | Specifies the possible errors that can appear during the rendering of a PDF page.
Enumeration | PDFPageRotation | Specifies the available rotation modes for a PDF page.
Enumeration | PDFRenderingProgressDisplayMode | Specifies the available modes for displaying the page rendering progress.
Enumeration | PDFRotationMode | Specifies the available rotation modes for a PDF object.
Enumeration | PDFZoomMode | Specifies the available zoom modes for displaying a PDF page in the PDFPageView control.
Enumeration | UserInteractiveWorkMode | Specifies the available user interactive working modes for the PDFPageView control.
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

AfterAnnotationAddEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AfterAnnotationAddEventArgs Class
Defines the parameters for the PDFPageView.AfterAnnotationAdd event.
Object Model
AfterAnnotationAddEventArgs ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AfterAnnotationAddEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AfterAnnotationAddEventArgs
public class AfterAnnotationAddEventArgs : System.EventArgs
public __gc class AfterAnnotationAddEventArgs : public System.EventArgs
public ref class AfterAnnotationAddEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AfterAnnotationAddEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterAnnotationAddEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AfterAnnotationAddEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AfterAnnotationAddEventArgs Class

The following tables list the members exposed by AfterAnnotationAddEventArgs.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been added to the document.
Top
See Also

Reference

AfterAnnotationAddEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AfterAnnotationAddEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AfterAnnotationAddEventArgs Class

For a list of all members of this type, see AfterAnnotationAddEventArgs members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been added to the document.
Top
See Also

Reference

AfterAnnotationAddEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Annotation Property (AfterAnnotationAddEventArgs)

O2S.Components.PDFView4NET Namespace > AfterAnnotationAddEventArgs Class : Annotation Property
Gets the annotation that has been added to the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotation As PDFAnnotation
'Usage

Dim instance As AfterAnnotationAddEventArgs
Dim value As PDFAnnotation

value = instance.Annotation
public PDFAnnotation Annotation {get;}
public: __property PDFAnnotation* get_Annotation();
public:
property PDFAnnotation^ Annotation {
   PDFAnnotation^ get();
}

Property Value

The annotation that has been added to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterAnnotationAddEventArgs Class
AfterAnnotationAddEventArgs Members


%%PageItemTitle%%

AfterAnnotationMoveEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AfterAnnotationMoveEventArgs Class
Defines the parameters for the PDFPageView.AfterAnnotationMove event.
Object Model
AfterAnnotationMoveEventArgs ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AfterAnnotationMoveEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AfterAnnotationMoveEventArgs
public class AfterAnnotationMoveEventArgs : System.EventArgs
public __gc class AfterAnnotationMoveEventArgs : public System.EventArgs
public ref class AfterAnnotationMoveEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AfterAnnotationMoveEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterAnnotationMoveEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AfterAnnotationMoveEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AfterAnnotationMoveEventArgs Class

The following tables list the members exposed by AfterAnnotationMoveEventArgs.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been moved on the page.
Top
See Also

Reference

AfterAnnotationMoveEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AfterAnnotationMoveEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AfterAnnotationMoveEventArgs Class

For a list of all members of this type, see AfterAnnotationMoveEventArgs members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been moved on the page.
Top
See Also

Reference

AfterAnnotationMoveEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Annotation Property (AfterAnnotationMoveEventArgs)

O2S.Components.PDFView4NET Namespace > AfterAnnotationMoveEventArgs Class : Annotation Property
Gets the annotation that has been moved on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotation As PDFAnnotation
'Usage

Dim instance As AfterAnnotationMoveEventArgs
Dim value As PDFAnnotation

value = instance.Annotation
public PDFAnnotation Annotation {get;}
public: __property PDFAnnotation* get_Annotation();
public:
property PDFAnnotation^ Annotation {
   PDFAnnotation^ get();
}

Property Value

The annotation that has been moved on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterAnnotationMoveEventArgs Class
AfterAnnotationMoveEventArgs Members


%%PageItemTitle%%

AfterAnnotationResizeEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AfterAnnotationResizeEventArgs Class
Defines the parameters for the PDFPageView.AfterAnnotationResize event.
Object Model
AfterAnnotationResizeEventArgs ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AfterAnnotationResizeEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AfterAnnotationResizeEventArgs
public class AfterAnnotationResizeEventArgs : System.EventArgs
public __gc class AfterAnnotationResizeEventArgs : public System.EventArgs
public ref class AfterAnnotationResizeEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AfterAnnotationResizeEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterAnnotationResizeEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AfterAnnotationResizeEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AfterAnnotationResizeEventArgs Class

The following tables list the members exposed by AfterAnnotationResizeEventArgs.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been resized.
Top
See Also

Reference

AfterAnnotationResizeEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AfterAnnotationResizeEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AfterAnnotationResizeEventArgs Class

For a list of all members of this type, see AfterAnnotationResizeEventArgs members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been resized.
Top
See Also

Reference

AfterAnnotationResizeEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Annotation Property (AfterAnnotationResizeEventArgs)

O2S.Components.PDFView4NET Namespace > AfterAnnotationResizeEventArgs Class : Annotation Property
Gets the annotation that has been resized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotation As PDFAnnotation
'Usage

Dim instance As AfterAnnotationResizeEventArgs
Dim value As PDFAnnotation

value = instance.Annotation
public PDFAnnotation Annotation {get;}
public: __property PDFAnnotation* get_Annotation();
public:
property PDFAnnotation^ Annotation {
   PDFAnnotation^ get();
}

Property Value

The annotation that has been resized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterAnnotationResizeEventArgs Class
AfterAnnotationResizeEventArgs Members


%%PageItemTitle%%

AfterFieldAddEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AfterFieldAddEventArgs Class
Defines the parameters for the PDFPageView.AfterFieldAdd event.
Object Model
AfterFieldAddEventArgs ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AfterFieldAddEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AfterFieldAddEventArgs
public class AfterFieldAddEventArgs : System.EventArgs
public __gc class AfterFieldAddEventArgs : public System.EventArgs
public ref class AfterFieldAddEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AfterFieldAddEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterFieldAddEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AfterFieldAddEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AfterFieldAddEventArgs Class

The following tables list the members exposed by AfterFieldAddEventArgs.

Public Properties
 | Name | Description
Public Property | Field | Gets the field that has been added to the document.
Top
See Also

Reference

AfterFieldAddEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AfterFieldAddEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AfterFieldAddEventArgs Class

For a list of all members of this type, see AfterFieldAddEventArgs members.

Public Properties
 | Name | Description
Public Property | Field | Gets the field that has been added to the document.
Top
See Also

Reference

AfterFieldAddEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Field Property (AfterFieldAddEventArgs)

O2S.Components.PDFView4NET Namespace > AfterFieldAddEventArgs Class : Field Property
Gets the field that has been added to the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As AfterFieldAddEventArgs
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

The field that has been added to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterFieldAddEventArgs Class
AfterFieldAddEventArgs Members


%%PageItemTitle%%

AfterLinkExecuteEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AfterLinkExecuteEventArgs Class
Defines the parameters for the PDFPageView.AfterLinkExecute event.
Object Model
AfterLinkExecuteEventArgs ClassPDFLinkAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AfterLinkExecuteEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AfterLinkExecuteEventArgs
public class AfterLinkExecuteEventArgs : System.EventArgs
public __gc class AfterLinkExecuteEventArgs : public System.EventArgs
public ref class AfterLinkExecuteEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AfterLinkExecuteEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterLinkExecuteEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AfterLinkExecuteEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AfterLinkExecuteEventArgs Class

The following tables list the members exposed by AfterLinkExecuteEventArgs.

Public Properties
 | Name | Description
Public Property | Link | Gets the link that has been executed.
Top
See Also

Reference

AfterLinkExecuteEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AfterLinkExecuteEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AfterLinkExecuteEventArgs Class

For a list of all members of this type, see AfterLinkExecuteEventArgs members.

Public Properties
 | Name | Description
Public Property | Link | Gets the link that has been executed.
Top
See Also

Reference

AfterLinkExecuteEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Link Property (AfterLinkExecuteEventArgs)

O2S.Components.PDFView4NET Namespace > AfterLinkExecuteEventArgs Class : Link Property
Gets the link that has been executed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As PDFLinkAnnotation
'Usage

Dim instance As AfterLinkExecuteEventArgs
Dim value As PDFLinkAnnotation

value = instance.Link
public PDFLinkAnnotation Link {get;}
public: __property PDFLinkAnnotation* get_Link();
public:
property PDFLinkAnnotation^ Link {
   PDFLinkAnnotation^ get();
}

Property Value

The annotation that has been executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterLinkExecuteEventArgs Class
AfterLinkExecuteEventArgs Members


%%PageItemTitle%%

AfterPageReorderEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AfterPageReorderEventArgs Class
Defines the event args for PDFPageThumbnailView.AfterPageReorder event.
Object Model
AfterPageReorderEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AfterPageReorderEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AfterPageReorderEventArgs
public class AfterPageReorderEventArgs : System.EventArgs
public __gc class AfterPageReorderEventArgs : public System.EventArgs
public ref class AfterPageReorderEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AfterPageReorderEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterPageReorderEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AfterPageReorderEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AfterPageReorderEventArgs Class

The following tables list the members exposed by AfterPageReorderEventArgs.

Public Properties
 | Name | Description
Public Property | Pages | Gets the list of reordered pages.
Top
See Also

Reference

AfterPageReorderEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AfterPageReorderEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AfterPageReorderEventArgs Class

For a list of all members of this type, see AfterPageReorderEventArgs members.

Public Properties
 | Name | Description
Public Property | Pages | Gets the list of reordered pages.
Top
See Also

Reference

AfterPageReorderEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Pages Property (AfterPageReorderEventArgs)

O2S.Components.PDFView4NET Namespace > AfterPageReorderEventArgs Class : Pages Property
Gets the list of reordered pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pages As Integer()
'Usage

Dim instance As AfterPageReorderEventArgs
Dim value() As Integer

value = instance.Pages
public int[] Pages {get;}
public: __property int[]* get_Pages();
public:
property array<int>^ Pages {
   array<int>^ get();
}

Property Value

The list of the new positions of the reordered pages in the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterPageReorderEventArgs Class
AfterPageReorderEventArgs Members


%%PageItemTitle%%

AfterTextSelectEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AfterTextSelectEventArgs Class
Defines the parameters for the PDFPageView.AfterTextSelect event.
Object Model
AfterTextSelectEventArgs ClassPDFTextSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AfterTextSelectEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AfterTextSelectEventArgs
public class AfterTextSelectEventArgs : System.EventArgs
public __gc class AfterTextSelectEventArgs : public System.EventArgs
public ref class AfterTextSelectEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AfterTextSelectEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterTextSelectEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AfterTextSelectEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AfterTextSelectEventArgs Class

The following tables list the members exposed by AfterTextSelectEventArgs.

Public Properties
 | Name | Description
Public Property | TextSelection | Gets the selected text.
Top
See Also

Reference

AfterTextSelectEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AfterTextSelectEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AfterTextSelectEventArgs Class

For a list of all members of this type, see AfterTextSelectEventArgs members.

Public Properties
 | Name | Description
Public Property | TextSelection | Gets the selected text.
Top
See Also

Reference

AfterTextSelectEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

TextSelection Property

O2S.Components.PDFView4NET Namespace > AfterTextSelectEventArgs Class : TextSelection Property
Gets the selected text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextSelection As PDFTextSelection
'Usage

Dim instance As AfterTextSelectEventArgs
Dim value As PDFTextSelection

value = instance.TextSelection
public PDFTextSelection TextSelection {get;}
public: __property PDFTextSelection* get_TextSelection();
public:
property PDFTextSelection^ TextSelection {
   PDFTextSelection^ get();
}

Property Value

The text selection on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AfterTextSelectEventArgs Class
AfterTextSelectEventArgs Members


%%PageItemTitle%%

AnnotationClickEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AnnotationClickEventArgs Class
Defines the parameters for the PDFPageView.AnnotationClick and PDFPageView.AnnotationDoubleClick events.
Object Model
AnnotationClickEventArgs ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AnnotationClickEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AnnotationClickEventArgs
public class AnnotationClickEventArgs : System.EventArgs
public __gc class AnnotationClickEventArgs : public System.EventArgs
public ref class AnnotationClickEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AnnotationClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationClickEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AnnotationClickEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AnnotationClickEventArgs Class

The following tables list the members exposed by AnnotationClickEventArgs.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been double clicked.
Public Property | MouseButton | Gets the mouse button that was clicked on the annotation.
Top
See Also

Reference

AnnotationClickEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AnnotationClickEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AnnotationClickEventArgs Class

For a list of all members of this type, see AnnotationClickEventArgs members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been double clicked.
Public Property | MouseButton | Gets the mouse button that was clicked on the annotation.
Top
See Also

Reference

AnnotationClickEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Annotation Property (AnnotationClickEventArgs)

O2S.Components.PDFView4NET Namespace > AnnotationClickEventArgs Class : Annotation Property
Gets the annotation that has been double clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotation As PDFAnnotation
'Usage

Dim instance As AnnotationClickEventArgs
Dim value As PDFAnnotation

value = instance.Annotation
public PDFAnnotation Annotation {get;}
public: __property PDFAnnotation* get_Annotation();
public:
property PDFAnnotation^ Annotation {
   PDFAnnotation^ get();
}

Property Value

The annotation that has been double clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationClickEventArgs Class
AnnotationClickEventArgs Members


%%ItemTitle%%

MouseButton Property (AnnotationClickEventArgs)

O2S.Components.PDFView4NET Namespace > AnnotationClickEventArgs Class : MouseButton Property
Gets the mouse button that was clicked on the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MouseButton As MouseButtons
'Usage

Dim instance As AnnotationClickEventArgs
Dim value As MouseButtons

value = instance.MouseButton
public MouseButtons MouseButton {get;}
public: __property MouseButtons get_MouseButton();
public:
property MouseButtons MouseButton {
   MouseButtons get();
}

Property Value

A System.Windows.Forms.MouseButtons enumeration member specifying the mouse button that was clicked on the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationClickEventArgs Class
AnnotationClickEventArgs Members


%%PageItemTitle%%

AnnotationContextMenuEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AnnotationContextMenuEventArgs Class
Defines the parameters for the PDFPageView.AnnotationContextMenu event.
Object Model
AnnotationContextMenuEventArgs ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AnnotationContextMenuEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AnnotationContextMenuEventArgs
public class AnnotationContextMenuEventArgs : System.EventArgs
public __gc class AnnotationContextMenuEventArgs : public System.EventArgs
public ref class AnnotationContextMenuEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AnnotationContextMenuEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationContextMenuEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AnnotationContextMenuEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AnnotationContextMenuEventArgs Class

The following tables list the members exposed by AnnotationContextMenuEventArgs.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been double clicked.
Public Property | MousePosition | Gets the position where the mouse was clicked.
Top
See Also

Reference

AnnotationContextMenuEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AnnotationContextMenuEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AnnotationContextMenuEventArgs Class

For a list of all members of this type, see AnnotationContextMenuEventArgs members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that has been double clicked.
Public Property | MousePosition | Gets the position where the mouse was clicked.
Top
See Also

Reference

AnnotationContextMenuEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Annotation Property (AnnotationContextMenuEventArgs)

O2S.Components.PDFView4NET Namespace > AnnotationContextMenuEventArgs Class : Annotation Property
Gets the annotation that has been double clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotation As PDFAnnotation
'Usage

Dim instance As AnnotationContextMenuEventArgs
Dim value As PDFAnnotation

value = instance.Annotation
public PDFAnnotation Annotation {get;}
public: __property PDFAnnotation* get_Annotation();
public:
property PDFAnnotation^ Annotation {
   PDFAnnotation^ get();
}

Property Value

The annotation that has been double clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationContextMenuEventArgs Class
AnnotationContextMenuEventArgs Members


%%ItemTitle%%

MousePosition Property (AnnotationContextMenuEventArgs)

O2S.Components.PDFView4NET Namespace > AnnotationContextMenuEventArgs Class : MousePosition Property
Gets the position where the mouse was clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MousePosition As Point
'Usage

Dim instance As AnnotationContextMenuEventArgs
Dim value As Point

value = instance.MousePosition
public Point MousePosition {get;}
public: __property Point get_MousePosition();
public:
property Point MousePosition {
   Point get();
}

Property Value

The position in control coordinates where the context menu should be displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationContextMenuEventArgs Class
AnnotationContextMenuEventArgs Members


%%PageItemTitle%%

AnnotationToolTipDrawEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AnnotationToolTipDrawEventArgs Class
Defines the parameters for the PDFPageView.AnnotationToolTipDraw event.
Object Model
AnnotationToolTipDrawEventArgs ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AnnotationToolTipDrawEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AnnotationToolTipDrawEventArgs
public class AnnotationToolTipDrawEventArgs : System.EventArgs
public __gc class AnnotationToolTipDrawEventArgs : public System.EventArgs
public ref class AnnotationToolTipDrawEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AnnotationToolTipDrawEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipDrawEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AnnotationToolTipDrawEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AnnotationToolTipDrawEventArgs Class

The following tables list the members exposed by AnnotationToolTipDrawEventArgs.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation for which the tooltip needs to be drawn.
Public Property | Bounds | Gets the size and location of the annotation tooltip to draw.
Public Property | Font | Gets the font used to draw the annotation tooltip.
Public Property | Graphics | Gets the graphics surface used to draw the annotation tooltip.
Public Property | ToolTipText | Gets the text for the annotation tooltip that is being drawn.
Top
See Also

Reference

AnnotationToolTipDrawEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AnnotationToolTipDrawEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AnnotationToolTipDrawEventArgs Class

For a list of all members of this type, see AnnotationToolTipDrawEventArgs members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation for which the tooltip needs to be drawn.
Public Property | Bounds | Gets the size and location of the annotation tooltip to draw.
Public Property | Font | Gets the font used to draw the annotation tooltip.
Public Property | Graphics | Gets the graphics surface used to draw the annotation tooltip.
Public Property | ToolTipText | Gets the text for the annotation tooltip that is being drawn.
Top
See Also

Reference

AnnotationToolTipDrawEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Annotation Property (AnnotationToolTipDrawEventArgs)

O2S.Components.PDFView4NET Namespace > AnnotationToolTipDrawEventArgs Class : Annotation Property
Gets the annotation for which the tooltip needs to be drawn.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotation As PDFAnnotation
'Usage

Dim instance As AnnotationToolTipDrawEventArgs
Dim value As PDFAnnotation

value = instance.Annotation
public PDFAnnotation Annotation {get;}
public: __property PDFAnnotation* get_Annotation();
public:
property PDFAnnotation^ Annotation {
   PDFAnnotation^ get();
}

Property Value

The annotation for which the tooltip needs to be drawn.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipDrawEventArgs Class
AnnotationToolTipDrawEventArgs Members


%%ItemTitle%%

Bounds Property (AnnotationToolTipDrawEventArgs)

O2S.Components.PDFView4NET Namespace > AnnotationToolTipDrawEventArgs Class : Bounds Property
Gets the size and location of the annotation tooltip to draw.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bounds As Rectangle
'Usage

Dim instance As AnnotationToolTipDrawEventArgs
Dim value As Rectangle

value = instance.Bounds
public Rectangle Bounds {get;}
public: __property Rectangle get_Bounds();
public:
property Rectangle Bounds {
   Rectangle get();
}

Property Value

A System.Drawing.Rectangle that represents the bounds of the annotation tooltip to draw.
Remarks
By default, the bounds are set by the operating system based on system settings and the annotation tooltip text. You can increase the bounds of the annotation tooltip before it is shown by handling the PDFPageView.AnnotationToolTipPopup event of the PDFPageView class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipDrawEventArgs Class
AnnotationToolTipDrawEventArgs Members


%%ItemTitle%%

Font Property (AnnotationToolTipDrawEventArgs)

O2S.Components.PDFView4NET Namespace > AnnotationToolTipDrawEventArgs Class : Font Property
Gets the font used to draw the annotation tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Font As Font
'Usage

Dim instance As AnnotationToolTipDrawEventArgs
Dim value As Font

value = instance.Font
public Font Font {get;}
public: __property Font* get_Font();
public:
property Font^ Font {
   Font^ get();
}

Property Value

A Font object.
Remarks
Use the Font property when you are custom drawing an annotation tooltip that should use the Windows default font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipDrawEventArgs Class
AnnotationToolTipDrawEventArgs Members


%%ItemTitle%%

Graphics Property

O2S.Components.PDFView4NET Namespace > AnnotationToolTipDrawEventArgs Class : Graphics Property
Gets the graphics surface used to draw the annotation tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Graphics As Graphics
'Usage

Dim instance As AnnotationToolTipDrawEventArgs
Dim value As Graphics

value = instance.Graphics
public Graphics Graphics {get;}
public: __property Graphics* get_Graphics();
public:
property Graphics^ Graphics {
   Graphics^ get();
}

Property Value

The System.Drawing.Graphics on which to draw the annotation tooltip.
Remarks
You use the System.Drawing.Graphics object to customize the drawing of certain visual aspects of an annotation tooltip. For example, you can draw your own background by using the System.Drawing.Graphics.FillRectangle(System.Drawing.Brush,System.Drawing.RectangleF) method.
Any custom drawing that is done outside of the rectangle specified by the Bounds property will not show up. You can increase the bounds of the annotation tooltip before it is shown by handling the PDFPageView.AnnotationToolTipPopup event.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipDrawEventArgs Class
AnnotationToolTipDrawEventArgs Members


%%ItemTitle%%

ToolTipText Property

O2S.Components.PDFView4NET Namespace > AnnotationToolTipDrawEventArgs Class : ToolTipText Property
Gets the text for the annotation tooltip that is being drawn.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ToolTipText As String
'Usage

Dim instance As AnnotationToolTipDrawEventArgs
Dim value As String

value = instance.ToolTipText
public string ToolTipText {get;}
public: __property string* get_ToolTipText();
public:
property String^ ToolTipText {
   String^ get();
}

Property Value

The text that is associated with the annotation tooltip when the draw event occurs.
Remarks
The value of this property is the value of PDFAnnotationToolTip.Contents property after the { } tags have been replaced with actual values for the corresponding annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipDrawEventArgs Class
AnnotationToolTipDrawEventArgs Members


%%PageItemTitle%%

AnnotationToolTipPopupEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : AnnotationToolTipPopupEventArgs Class
Defines the parameters for the PDFPageView.AnnotationToolTipPopup event.
Object Model
AnnotationToolTipPopupEventArgs ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AnnotationToolTipPopupEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AnnotationToolTipPopupEventArgs
public class AnnotationToolTipPopupEventArgs : System.EventArgs
public __gc class AnnotationToolTipPopupEventArgs : public System.EventArgs
public ref class AnnotationToolTipPopupEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.AnnotationToolTipPopupEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipPopupEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

AnnotationToolTipPopupEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : AnnotationToolTipPopupEventArgs Class

The following tables list the members exposed by AnnotationToolTipPopupEventArgs.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation for which the tooltip needs to be shown.
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled.
Public Property | ToolTipSize | Gets or sets the size of the annotation tooltip.
Top
See Also

Reference

AnnotationToolTipPopupEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

AnnotationToolTipPopupEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : AnnotationToolTipPopupEventArgs Class

For a list of all members of this type, see AnnotationToolTipPopupEventArgs members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation for which the tooltip needs to be shown.
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled.
Public Property | ToolTipSize | Gets or sets the size of the annotation tooltip.
Top
See Also

Reference

AnnotationToolTipPopupEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Annotation Property (AnnotationToolTipPopupEventArgs)

O2S.Components.PDFView4NET Namespace > AnnotationToolTipPopupEventArgs Class : Annotation Property
Gets the annotation for which the tooltip needs to be shown.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotation As PDFAnnotation
'Usage

Dim instance As AnnotationToolTipPopupEventArgs
Dim value As PDFAnnotation

value = instance.Annotation
public PDFAnnotation Annotation {get;}
public: __property PDFAnnotation* get_Annotation();
public:
property PDFAnnotation^ Annotation {
   PDFAnnotation^ get();
}

Property Value

The annotation for which the tooltip needs to be shown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipPopupEventArgs Class
AnnotationToolTipPopupEventArgs Members


%%ItemTitle%%

Cancel Property (AnnotationToolTipPopupEventArgs)

O2S.Components.PDFView4NET Namespace > AnnotationToolTipPopupEventArgs Class : Cancel Property
Gets or sets a value indicating whether the event should be canceled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As AnnotationToolTipPopupEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

true if the event should be canceled; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipPopupEventArgs Class
AnnotationToolTipPopupEventArgs Members


%%ItemTitle%%

ToolTipSize Property

O2S.Components.PDFView4NET Namespace > AnnotationToolTipPopupEventArgs Class : ToolTipSize Property
Gets or sets the size of the annotation tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ToolTipSize As Size
'Usage

Dim instance As AnnotationToolTipPopupEventArgs
Dim value As Size

instance.ToolTipSize = value

value = instance.ToolTipSize
public Size ToolTipSize {get; set;}
public: __property Size get_ToolTipSize();
public: __property void set_ToolTipSize(
   Size value
);
public:
property Size ToolTipSize {
   Size get();
   void set (    Size value);
}

Property Value

The System.Drawing.Size of the annotation tooltip window.
Remarks
The ToolTipSize property enables the PDFPageView.AnnotationToolTipPopup event handler to change the size of the annotation tooltip window. ToolTipSize is often used in conjunction with the members of the AnnotationToolTipDrawEventArgs class to customize the appearance of annotation tooltips.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationToolTipPopupEventArgs Class
AnnotationToolTipPopupEventArgs Members


%%PageItemTitle%%

BeforeAnnotationAddEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : BeforeAnnotationAddEventArgs Class
Defines the parameters for the PDFPageView.BeforeAnnotationAdd event.
Object Model
BeforeAnnotationAddEventArgs ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BeforeAnnotationAddEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As BeforeAnnotationAddEventArgs
public class BeforeAnnotationAddEventArgs : System.EventArgs
public __gc class BeforeAnnotationAddEventArgs : public System.EventArgs
public ref class BeforeAnnotationAddEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.BeforeAnnotationAddEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeAnnotationAddEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

BeforeAnnotationAddEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : BeforeAnnotationAddEventArgs Class

The following tables list the members exposed by BeforeAnnotationAddEventArgs.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that will be added to the document.
Public Property | Cancel | Gets or sets a value indicating whether the annotation should be added or not.
Top
See Also

Reference

BeforeAnnotationAddEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

BeforeAnnotationAddEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : BeforeAnnotationAddEventArgs Class

For a list of all members of this type, see BeforeAnnotationAddEventArgs members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets the annotation that will be added to the document.
Public Property | Cancel | Gets or sets a value indicating whether the annotation should be added or not.
Top
See Also

Reference

BeforeAnnotationAddEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Annotation Property (BeforeAnnotationAddEventArgs)

O2S.Components.PDFView4NET Namespace > BeforeAnnotationAddEventArgs Class : Annotation Property
Gets the annotation that will be added to the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotation As PDFAnnotation
'Usage

Dim instance As BeforeAnnotationAddEventArgs
Dim value As PDFAnnotation

value = instance.Annotation
public PDFAnnotation Annotation {get;}
public: __property PDFAnnotation* get_Annotation();
public:
property PDFAnnotation^ Annotation {
   PDFAnnotation^ get();
}

Property Value

The annotation that is about to be added to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeAnnotationAddEventArgs Class
BeforeAnnotationAddEventArgs Members


%%ItemTitle%%

Cancel Property (BeforeAnnotationAddEventArgs)

O2S.Components.PDFView4NET Namespace > BeforeAnnotationAddEventArgs Class : Cancel Property
Gets or sets a value indicating whether the annotation should be added or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As BeforeAnnotationAddEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

True if the annotation should not be added. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeAnnotationAddEventArgs Class
BeforeAnnotationAddEventArgs Members


%%PageItemTitle%%

BeforeFieldAddEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : BeforeFieldAddEventArgs Class
Defines the parameters for the PDFPageView.BeforeFieldAdd event.
Object Model
BeforeFieldAddEventArgs ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BeforeFieldAddEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As BeforeFieldAddEventArgs
public class BeforeFieldAddEventArgs : System.EventArgs
public __gc class BeforeFieldAddEventArgs : public System.EventArgs
public ref class BeforeFieldAddEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.BeforeFieldAddEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeFieldAddEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

BeforeFieldAddEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : BeforeFieldAddEventArgs Class

The following tables list the members exposed by BeforeFieldAddEventArgs.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the field should be added or not.
Public Property | Field | Gets the field that will be added to the document.
Top
See Also

Reference

BeforeFieldAddEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

BeforeFieldAddEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : BeforeFieldAddEventArgs Class

For a list of all members of this type, see BeforeFieldAddEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the field should be added or not.
Public Property | Field | Gets the field that will be added to the document.
Top
See Also

Reference

BeforeFieldAddEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Cancel Property (BeforeFieldAddEventArgs)

O2S.Components.PDFView4NET Namespace > BeforeFieldAddEventArgs Class : Cancel Property
Gets or sets a value indicating whether the field should be added or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As BeforeFieldAddEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

True if the field should not be added. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeFieldAddEventArgs Class
BeforeFieldAddEventArgs Members


%%ItemTitle%%

Field Property (BeforeFieldAddEventArgs)

O2S.Components.PDFView4NET Namespace > BeforeFieldAddEventArgs Class : Field Property
Gets the field that will be added to the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As BeforeFieldAddEventArgs
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

The field that is about to be added to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeFieldAddEventArgs Class
BeforeFieldAddEventArgs Members


%%PageItemTitle%%

BeforeLinkExecuteEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : BeforeLinkExecuteEventArgs Class
Defines the parameters for the PDFPageView.BeforeLinkExecute event.
Object Model
BeforeLinkExecuteEventArgs ClassPDFLinkAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BeforeLinkExecuteEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As BeforeLinkExecuteEventArgs
public class BeforeLinkExecuteEventArgs : System.EventArgs
public __gc class BeforeLinkExecuteEventArgs : public System.EventArgs
public ref class BeforeLinkExecuteEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.BeforeLinkExecuteEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeLinkExecuteEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

BeforeLinkExecuteEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : BeforeLinkExecuteEventArgs Class

The following tables list the members exposed by BeforeLinkExecuteEventArgs.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the link should be executed or not.
Public Property | Link | Gets the link annotation that will be executed.
Top
See Also

Reference

BeforeLinkExecuteEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

BeforeLinkExecuteEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : BeforeLinkExecuteEventArgs Class

For a list of all members of this type, see BeforeLinkExecuteEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the link should be executed or not.
Public Property | Link | Gets the link annotation that will be executed.
Top
See Also

Reference

BeforeLinkExecuteEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Cancel Property (BeforeLinkExecuteEventArgs)

O2S.Components.PDFView4NET Namespace > BeforeLinkExecuteEventArgs Class : Cancel Property
Gets or sets a value indicating whether the link should be executed or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As BeforeLinkExecuteEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

True if the link should not be executed. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeLinkExecuteEventArgs Class
BeforeLinkExecuteEventArgs Members


%%ItemTitle%%

Link Property (BeforeLinkExecuteEventArgs)

O2S.Components.PDFView4NET Namespace > BeforeLinkExecuteEventArgs Class : Link Property
Gets the link annotation that will be executed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Link As PDFLinkAnnotation
'Usage

Dim instance As BeforeLinkExecuteEventArgs
Dim value As PDFLinkAnnotation

value = instance.Link
public PDFLinkAnnotation Link {get;}
public: __property PDFLinkAnnotation* get_Link();
public:
property PDFLinkAnnotation^ Link {
   PDFLinkAnnotation^ get();
}

Property Value

The link annotation that is about to be executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforeLinkExecuteEventArgs Class
BeforeLinkExecuteEventArgs Members


%%PageItemTitle%%

BeforePageReorderEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : BeforePageReorderEventArgs Class
Defines the event args for PDFPageThumbnailView.BeforePageReorder event.
Object Model
BeforePageReorderEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BeforePageReorderEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As BeforePageReorderEventArgs
public class BeforePageReorderEventArgs : System.EventArgs
public __gc class BeforePageReorderEventArgs : public System.EventArgs
public ref class BeforePageReorderEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.BeforePageReorderEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforePageReorderEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

BeforePageReorderEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : BeforePageReorderEventArgs Class

The following tables list the members exposed by BeforePageReorderEventArgs.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the reorder operation should be canceled or not.
Public Property | InsertPosition | Gets the position in the document where the pages are inserted.
Public Property | Pages | Gets the list of pages being reordered.
Top
See Also

Reference

BeforePageReorderEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

BeforePageReorderEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : BeforePageReorderEventArgs Class

For a list of all members of this type, see BeforePageReorderEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the reorder operation should be canceled or not.
Public Property | InsertPosition | Gets the position in the document where the pages are inserted.
Public Property | Pages | Gets the list of pages being reordered.
Top
See Also

Reference

BeforePageReorderEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Cancel Property (BeforePageReorderEventArgs)

O2S.Components.PDFView4NET Namespace > BeforePageReorderEventArgs Class : Cancel Property
Gets or sets a value indicating whether the reorder operation should be canceled or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As BeforePageReorderEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

True if the reorder operation should be canceled. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforePageReorderEventArgs Class
BeforePageReorderEventArgs Members


%%ItemTitle%%

InsertPosition Property

O2S.Components.PDFView4NET Namespace > BeforePageReorderEventArgs Class : InsertPosition Property
Gets the position in the document where the pages are inserted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property InsertPosition As Integer
'Usage

Dim instance As BeforePageReorderEventArgs
Dim value As Integer

value = instance.InsertPosition
public int InsertPosition {get;}
public: __property int get_InsertPosition();
public:
property int InsertPosition {
   int get();
}

Property Value

Index in the document where the pages are inserted.
Remarks
The first page in the list is inserted in this position, the next page is inserted at insertPosition + 1 and so on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforePageReorderEventArgs Class
BeforePageReorderEventArgs Members


%%ItemTitle%%

Pages Property (BeforePageReorderEventArgs)

O2S.Components.PDFView4NET Namespace > BeforePageReorderEventArgs Class : Pages Property
Gets the list of pages being reordered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pages As Integer()
'Usage

Dim instance As BeforePageReorderEventArgs
Dim value() As Integer

value = instance.Pages
public int[] Pages {get;}
public: __property int[]* get_Pages();
public:
property array<int>^ Pages {
   array<int>^ get();
}

Property Value

The list of pages being reordered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BeforePageReorderEventArgs Class
BeforePageReorderEventArgs Members


%%PageItemTitle%%

BookmarkClickEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : BookmarkClickEventArgs Class
Defines the parameters for the PDFBookmarksView.BookmarkClick and PDFBookmarksView.BookmarkDoubleClick events.
Object Model
BookmarkClickEventArgs ClassPDFBookmark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BookmarkClickEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As BookmarkClickEventArgs
public class BookmarkClickEventArgs : System.EventArgs
public __gc class BookmarkClickEventArgs : public System.EventArgs
public ref class BookmarkClickEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.BookmarkClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkClickEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

BookmarkClickEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : BookmarkClickEventArgs Class

The following tables list the members exposed by BookmarkClickEventArgs.

Public Properties
 | Name | Description
Public Property | Bookmark | Gets the bookmark that has been clicked.
Public Property | Location | Gets the location of the mouse during the generating mouse event.
Public Property | MouseButton | Gets the mouse button that was clicked on the bookmark.
Top
See Also

Reference

BookmarkClickEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

BookmarkClickEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : BookmarkClickEventArgs Class

For a list of all members of this type, see BookmarkClickEventArgs members.

Public Properties
 | Name | Description
Public Property | Bookmark | Gets the bookmark that has been clicked.
Public Property | Location | Gets the location of the mouse during the generating mouse event.
Public Property | MouseButton | Gets the mouse button that was clicked on the bookmark.
Top
See Also

Reference

BookmarkClickEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Bookmark Property (BookmarkClickEventArgs)

O2S.Components.PDFView4NET Namespace > BookmarkClickEventArgs Class : Bookmark Property
Gets the bookmark that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bookmark As PDFBookmark
'Usage

Dim instance As BookmarkClickEventArgs
Dim value As PDFBookmark

value = instance.Bookmark
public PDFBookmark Bookmark {get;}
public: __property PDFBookmark* get_Bookmark();
public:
property PDFBookmark^ Bookmark {
   PDFBookmark^ get();
}

Property Value

The bookmark that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkClickEventArgs Class
BookmarkClickEventArgs Members


%%ItemTitle%%

Location Property (BookmarkClickEventArgs)

O2S.Components.PDFView4NET Namespace > BookmarkClickEventArgs Class : Location Property
Gets the location of the mouse during the generating mouse event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Location As Point
'Usage

Dim instance As BookmarkClickEventArgs
Dim value As Point

value = instance.Location
public Point Location {get;}
public: __property Point get_Location();
public:
property Point Location {
   Point get();
}

Property Value

A Point containing the x- and y- coordinate of the mouse, in pixels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkClickEventArgs Class
BookmarkClickEventArgs Members


%%ItemTitle%%

MouseButton Property (BookmarkClickEventArgs)

O2S.Components.PDFView4NET Namespace > BookmarkClickEventArgs Class : MouseButton Property
Gets the mouse button that was clicked on the bookmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MouseButton As MouseButtons
'Usage

Dim instance As BookmarkClickEventArgs
Dim value As MouseButtons

value = instance.MouseButton
public MouseButtons MouseButton {get;}
public: __property MouseButtons get_MouseButton();
public:
property MouseButtons MouseButton {
   MouseButtons get();
}

Property Value

A System.Windows.Forms.MouseButtons enumeration member specifying the mouse button that was clicked on the bookmark.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkClickEventArgs Class
BookmarkClickEventArgs Members


%%PageItemTitle%%

BookmarkEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : BookmarkEventArgs Class
Defines the parameters for the PDFDocument.BookmarkAdded and PDFDocument.BookmarkRemoved events.
Object Model
BookmarkEventArgs ClassPDFBookmark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BookmarkEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As BookmarkEventArgs
public class BookmarkEventArgs : System.EventArgs
public __gc class BookmarkEventArgs : public System.EventArgs
public ref class BookmarkEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.BookmarkEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

BookmarkEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : BookmarkEventArgs Class

The following tables list the members exposed by BookmarkEventArgs.

Public Properties
 | Name | Description
Public Property | Bookmark | Gets the bookmark that has been acted upon.
Top
See Also

Reference

BookmarkEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

BookmarkEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : BookmarkEventArgs Class

For a list of all members of this type, see BookmarkEventArgs members.

Public Properties
 | Name | Description
Public Property | Bookmark | Gets the bookmark that has been acted upon.
Top
See Also

Reference

BookmarkEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Bookmark Property (BookmarkEventArgs)

O2S.Components.PDFView4NET Namespace > BookmarkEventArgs Class : Bookmark Property
Gets the bookmark that has been acted upon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bookmark As PDFBookmark
'Usage

Dim instance As BookmarkEventArgs
Dim value As PDFBookmark

value = instance.Bookmark
public PDFBookmark Bookmark {get;}
public: __property PDFBookmark* get_Bookmark();
public:
property PDFBookmark^ Bookmark {
   PDFBookmark^ get();
}

Property Value

The bookmark that has been acted upon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarkEventArgs Class
BookmarkEventArgs Members


%%PageItemTitle%%

DisplayRectangle Class
Members

O2S.Components.PDFView4NET Namespace : DisplayRectangle Class
Defines a rectangle in display coordinates, relative to top left corner of the page.
Object Model
DisplayRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DisplayRectangle
'Usage

Dim instance As DisplayRectangle
public class DisplayRectangle
public __gc class DisplayRectangle
public ref class DisplayRectangle
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.DisplayRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

DisplayRectangle Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : DisplayRectangle Class

The following tables list the members exposed by DisplayRectangle.

Public Constructors
 | Name | Description
Public Constructor | DisplayRectangle Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | Left | Gets or sets X coordinate of the top left corner.
Public Property | Top | Gets or sets Y coordinate of the top left corner.
Public Property | Width | Gets or sets the rectangle's width.
Top
Public Methods
 | Name | Description
Public Method | Contains | Tests if this rectangle contains the given point.
Public Method | Intersects | Verifies if the given rectangle intersects this rectangle.
Public Method | ToString | Converts the rectangle to string representation.
Top
See Also

Reference

DisplayRectangle Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

DisplayRectangle Constructor

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class : DisplayRectangle Constructor
Overload List
Overload | Description
DisplayRectangle Constructor() | Initializes a new DisplayRectangle object.
DisplayRectangle Constructor(Double,Double,Double,Double) | Initializes a new PDFRectangle object.
DisplayRectangle Constructor(RectangleF) | Initializes a new PDFRectangle object.
DisplayRectangle Constructor(Rectangle) | Initializes a new PDFRectangle object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%PageItemTitle%%

DisplayRectangle Constructor()

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor()
Initializes a new DisplayRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DisplayRectangle()
public DisplayRectangle()
public: DisplayRectangle();
public:
DisplayRectangle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


%%PageItemTitle%%

DisplayRectangle Constructor(Double,Double,Double,Double)

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor(Double,Double,Double,Double)
The x coordinate of the top left corner of the rectangle.
The y coordinate of the top left corner of the rectangle.
The width of the rectangle.
The height of the rectangle.
Initializes a new PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

Dim instance As New DisplayRectangle(left, top, width, height)
public DisplayRectangle(
   double left,
   double top,
   double width,
   double height
)
public: DisplayRectangle(
   double left,
   double top,
   double width,
   double height
)
public:
DisplayRectangle(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


%%PageItemTitle%%

DisplayRectangle Constructor(RectangleF)

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor(RectangleF)
Source rectangle.
Initializes a new PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rectangle As RectangleF _
)
'Usage

Dim rectangle As RectangleF

Dim instance As New DisplayRectangle(rectangle)
public DisplayRectangle(
   RectangleF rectangle
)
public: DisplayRectangle(
   RectangleF rectangle
)
public:
DisplayRectangle(
   RectangleF rectangle
)

Parameters

rectangle
Source rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


%%PageItemTitle%%

DisplayRectangle Constructor(Rectangle)

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor(Rectangle)
Source rectangle.
Initializes a new PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rectangle As Rectangle _
)
'Usage

Dim rectangle As Rectangle

Dim instance As New DisplayRectangle(rectangle)
public DisplayRectangle(
   Rectangle rectangle
)
public: DisplayRectangle(
   Rectangle rectangle
)
public:
DisplayRectangle(
   Rectangle rectangle
)

Parameters

rectangle
Source rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

DisplayRectangle Class Methods

O2S.Components.PDFView4NET Namespace : DisplayRectangle Class

For a list of all members of this type, see DisplayRectangle members.

Public Methods
 | Name | Description
Public Method | Contains | Tests if this rectangle contains the given point.
Public Method | Intersects | Verifies if the given rectangle intersects this rectangle.
Public Method | ToString | Converts the rectangle to string representation.
Top
See Also

Reference

DisplayRectangle Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Contains Method

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class : Contains Method
Tests if this rectangle contains the given point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal x As Double, _
   ByVal y As Double _
) As Boolean
'Usage

Dim instance As DisplayRectangle
Dim x As Double
Dim y As Double
Dim value As Boolean

value = instance.Contains(x, y)
public bool Contains(
   double x,
   double y
)
public: bool Contains(
   double x,
   double y
)
public:
bool Contains(
   double x,
   double y
)

Parameters

x
y

Return Value

True if the rectangle contains the point, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%ItemTitle%%

Intersects Method

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class : Intersects Method
The rectangle to intersect.
Verifies if the given rectangle intersects this rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Intersects( _
   ByVal displayRect As DisplayRectangle _
) As Boolean
'Usage

Dim instance As DisplayRectangle
Dim displayRect As DisplayRectangle
Dim value As Boolean

value = instance.Intersects(displayRect)
public bool Intersects(
   DisplayRectangle displayRect
)
public: bool Intersects(
   DisplayRectangle* displayRect
)
public:
bool Intersects(
   DisplayRectangle^ displayRect
)

Parameters

displayRect
The rectangle to intersect.

Return Value

True if the rectangles intersect, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%ItemTitle%%

ToString Method (DisplayRectangle)

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class : ToString Method
Converts the rectangle to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As DisplayRectangle
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%PageItemTitle%% $$Properties$$

DisplayRectangle Class Properties

O2S.Components.PDFView4NET Namespace : DisplayRectangle Class

For a list of all members of this type, see DisplayRectangle members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | Left | Gets or sets X coordinate of the top left corner.
Public Property | Top | Gets or sets Y coordinate of the top left corner.
Public Property | Width | Gets or sets the rectangle's width.
Top
See Also

Reference

DisplayRectangle Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Height Property (DisplayRectangle)

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class : Height Property
Gets or sets the rectangle's height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As DisplayRectangle
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public: __property double get_Height();
public: __property void set_Height(
   double value
);
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The height of the rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%ItemTitle%%

Left Property (DisplayRectangle)

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class : Left Property
Gets or sets X coordinate of the top left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As DisplayRectangle
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public: __property double get_Left();
public: __property void set_Left(
   double value
);
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the top left corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%ItemTitle%%

Top Property (DisplayRectangle)

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class : Top Property
Gets or sets Y coordinate of the top left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Top As Double
'Usage

Dim instance As DisplayRectangle
Dim value As Double

instance.Top = value

value = instance.Top
public double Top {get; set;}
public: __property double get_Top();
public: __property void set_Top(
   double value
);
public:
property double Top {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the top left corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%ItemTitle%%

Width Property (DisplayRectangle)

O2S.Components.PDFView4NET Namespace > DisplayRectangle Class : Width Property
Gets or sets the rectangle's width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As DisplayRectangle
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


%%PageItemTitle%%

FieldClickEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : FieldClickEventArgs Class
Defines the parameters for the PDFPageView.FieldClick event.
Object Model
FieldClickEventArgs ClassPDFField ClassPDFFieldWidget ClassPDFPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FieldClickEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As FieldClickEventArgs
public class FieldClickEventArgs : System.EventArgs
public __gc class FieldClickEventArgs : public System.EventArgs
public ref class FieldClickEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.FieldClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldClickEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

FieldClickEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : FieldClickEventArgs Class

The following tables list the members exposed by FieldClickEventArgs.

Public Properties
 | Name | Description
Public Property | Field | Gets the field that has been clicked.
Public Property | FieldWidget | Gets the field widget that has been clicked.
Public Property | MouseButton | Gets the mouse button that was clicked on the field widget.
Public Property | MousePosition | Gets the position where the mouse was clicked.
Public Property | Page | Gets the page where the clicked field widget appears.
Top
See Also

Reference

FieldClickEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

FieldClickEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : FieldClickEventArgs Class

For a list of all members of this type, see FieldClickEventArgs members.

Public Properties
 | Name | Description
Public Property | Field | Gets the field that has been clicked.
Public Property | FieldWidget | Gets the field widget that has been clicked.
Public Property | MouseButton | Gets the mouse button that was clicked on the field widget.
Public Property | MousePosition | Gets the position where the mouse was clicked.
Public Property | Page | Gets the page where the clicked field widget appears.
Top
See Also

Reference

FieldClickEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Field Property (FieldClickEventArgs)

O2S.Components.PDFView4NET Namespace > FieldClickEventArgs Class : Field Property
Gets the field that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As FieldClickEventArgs
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

The field that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldClickEventArgs Class
FieldClickEventArgs Members


%%ItemTitle%%

FieldWidget Property (FieldClickEventArgs)

O2S.Components.PDFView4NET Namespace > FieldClickEventArgs Class : FieldWidget Property
Gets the field widget that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FieldWidget As PDFFieldWidget
'Usage

Dim instance As FieldClickEventArgs
Dim value As PDFFieldWidget

value = instance.FieldWidget
public PDFFieldWidget FieldWidget {get;}
public: __property PDFFieldWidget* get_FieldWidget();
public:
property PDFFieldWidget^ FieldWidget {
   PDFFieldWidget^ get();
}

Property Value

The field widget that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldClickEventArgs Class
FieldClickEventArgs Members


%%ItemTitle%%

MouseButton Property (FieldClickEventArgs)

O2S.Components.PDFView4NET Namespace > FieldClickEventArgs Class : MouseButton Property
Gets the mouse button that was clicked on the field widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MouseButton As MouseButtons
'Usage

Dim instance As FieldClickEventArgs
Dim value As MouseButtons

value = instance.MouseButton
public MouseButtons MouseButton {get;}
public: __property MouseButtons get_MouseButton();
public:
property MouseButtons MouseButton {
   MouseButtons get();
}

Property Value

A System.Windows.Forms.MouseButtons enumeration member specifying the mouse button that was clicked on the field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldClickEventArgs Class
FieldClickEventArgs Members


%%ItemTitle%%

MousePosition Property (FieldClickEventArgs)

O2S.Components.PDFView4NET Namespace > FieldClickEventArgs Class : MousePosition Property
Gets the position where the mouse was clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MousePosition As Point
'Usage

Dim instance As FieldClickEventArgs
Dim value As Point

value = instance.MousePosition
public Point MousePosition {get;}
public: __property Point get_MousePosition();
public:
property Point MousePosition {
   Point get();
}

Property Value

The position in control coordinates where the mouse was clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldClickEventArgs Class
FieldClickEventArgs Members


%%ItemTitle%%

Page Property (FieldClickEventArgs)

O2S.Components.PDFView4NET Namespace > FieldClickEventArgs Class : Page Property
Gets the page where the clicked field widget appears.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PDFPage
'Usage

Dim instance As FieldClickEventArgs
Dim value As PDFPage

value = instance.Page
public PDFPage Page {get;}
public: __property PDFPage* get_Page();
public:
property PDFPage^ Page {
   PDFPage^ get();
}

Property Value

The page that displays the clicked field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldClickEventArgs Class
FieldClickEventArgs Members


%%PageItemTitle%%

FieldContextMenuEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : FieldContextMenuEventArgs Class
Defines the parameters for the PDFPageView.FieldContextMenu event.
Object Model
FieldContextMenuEventArgs ClassPDFField ClassPDFFieldWidget ClassPDFPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FieldContextMenuEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As FieldContextMenuEventArgs
public class FieldContextMenuEventArgs : System.EventArgs
public __gc class FieldContextMenuEventArgs : public System.EventArgs
public ref class FieldContextMenuEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.FieldContextMenuEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldContextMenuEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

FieldContextMenuEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : FieldContextMenuEventArgs Class

The following tables list the members exposed by FieldContextMenuEventArgs.

Public Properties
 | Name | Description
Public Property | Field | Gets the field that has been clicked.
Public Property | FieldWidget | Gets the field widget that has been clicked.
Public Property | MousePosition | Gets the position where the mouse was clicked.
Public Property | Page | Gets the page where the clicked field widget appears.
Top
See Also

Reference

FieldContextMenuEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

FieldContextMenuEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : FieldContextMenuEventArgs Class

For a list of all members of this type, see FieldContextMenuEventArgs members.

Public Properties
 | Name | Description
Public Property | Field | Gets the field that has been clicked.
Public Property | FieldWidget | Gets the field widget that has been clicked.
Public Property | MousePosition | Gets the position where the mouse was clicked.
Public Property | Page | Gets the page where the clicked field widget appears.
Top
See Also

Reference

FieldContextMenuEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Field Property (FieldContextMenuEventArgs)

O2S.Components.PDFView4NET Namespace > FieldContextMenuEventArgs Class : Field Property
Gets the field that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As FieldContextMenuEventArgs
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

The field that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldContextMenuEventArgs Class
FieldContextMenuEventArgs Members


%%ItemTitle%%

FieldWidget Property (FieldContextMenuEventArgs)

O2S.Components.PDFView4NET Namespace > FieldContextMenuEventArgs Class : FieldWidget Property
Gets the field widget that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FieldWidget As PDFFieldWidget
'Usage

Dim instance As FieldContextMenuEventArgs
Dim value As PDFFieldWidget

value = instance.FieldWidget
public PDFFieldWidget FieldWidget {get;}
public: __property PDFFieldWidget* get_FieldWidget();
public:
property PDFFieldWidget^ FieldWidget {
   PDFFieldWidget^ get();
}

Property Value

The field widget that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldContextMenuEventArgs Class
FieldContextMenuEventArgs Members


%%ItemTitle%%

MousePosition Property (FieldContextMenuEventArgs)

O2S.Components.PDFView4NET Namespace > FieldContextMenuEventArgs Class : MousePosition Property
Gets the position where the mouse was clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MousePosition As Point
'Usage

Dim instance As FieldContextMenuEventArgs
Dim value As Point

value = instance.MousePosition
public Point MousePosition {get;}
public: __property Point get_MousePosition();
public:
property Point MousePosition {
   Point get();
}

Property Value

The position in control coordinates where the mouse was clicked and the context menu should be displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldContextMenuEventArgs Class
FieldContextMenuEventArgs Members


%%ItemTitle%%

Page Property (FieldContextMenuEventArgs)

O2S.Components.PDFView4NET Namespace > FieldContextMenuEventArgs Class : Page Property
Gets the page where the clicked field widget appears.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PDFPage
'Usage

Dim instance As FieldContextMenuEventArgs
Dim value As PDFPage

value = instance.Page
public PDFPage Page {get;}
public: __property PDFPage* get_Page();
public:
property PDFPage^ Page {
   PDFPage^ get();
}

Property Value

The page that displays the clicked field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldContextMenuEventArgs Class
FieldContextMenuEventArgs Members


%%PageItemTitle%%

FieldEditEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : FieldEditEventArgs Class
Defines the parameters for the PDFPageView.FieldBeginEdit and PDFPageView.FieldEndEdit event.
Object Model
FieldEditEventArgs ClassPDFField ClassPDFFieldWidget ClassPDFPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FieldEditEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As FieldEditEventArgs
public class FieldEditEventArgs : System.EventArgs
public __gc class FieldEditEventArgs : public System.EventArgs
public ref class FieldEditEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.FieldEditEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldEditEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

FieldEditEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : FieldEditEventArgs Class

The following tables list the members exposed by FieldEditEventArgs.

Public Properties
 | Name | Description
Public Property | AllowEdit | Gets or sets a value indicating whether field edit is allowed or not.
Public Property | Field | Gets the field that has been clicked.
Public Property | FieldWidget | Gets the field widget that has been clicked.
Public Property | Page | Gets the page where the clicked field widget appears.
Top
See Also

Reference

FieldEditEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

FieldEditEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : FieldEditEventArgs Class

For a list of all members of this type, see FieldEditEventArgs members.

Public Properties
 | Name | Description
Public Property | AllowEdit | Gets or sets a value indicating whether field edit is allowed or not.
Public Property | Field | Gets the field that has been clicked.
Public Property | FieldWidget | Gets the field widget that has been clicked.
Public Property | Page | Gets the page where the clicked field widget appears.
Top
See Also

Reference

FieldEditEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

AllowEdit Property

O2S.Components.PDFView4NET Namespace > FieldEditEventArgs Class : AllowEdit Property
Gets or sets a value indicating whether field edit is allowed or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowEdit As Boolean
'Usage

Dim instance As FieldEditEventArgs
Dim value As Boolean

instance.AllowEdit = value

value = instance.AllowEdit
public bool AllowEdit {get; set;}
public: __property bool get_AllowEdit();
public: __property void set_AllowEdit(
   bool value
);
public:
property bool AllowEdit {
   bool get();
   void set (    bool value);
}

Property Value

True if field edititing is allowed, false otherwise. Default is true.
Remarks
Set this property in PDFPageView.FieldBeginEdit event to enable or disable the editing of a specific field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldEditEventArgs Class
FieldEditEventArgs Members


%%ItemTitle%%

Field Property (FieldEditEventArgs)

O2S.Components.PDFView4NET Namespace > FieldEditEventArgs Class : Field Property
Gets the field that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As FieldEditEventArgs
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

The field that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldEditEventArgs Class
FieldEditEventArgs Members


%%ItemTitle%%

FieldWidget Property (FieldEditEventArgs)

O2S.Components.PDFView4NET Namespace > FieldEditEventArgs Class : FieldWidget Property
Gets the field widget that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FieldWidget As PDFFieldWidget
'Usage

Dim instance As FieldEditEventArgs
Dim value As PDFFieldWidget

value = instance.FieldWidget
public PDFFieldWidget FieldWidget {get;}
public: __property PDFFieldWidget* get_FieldWidget();
public:
property PDFFieldWidget^ FieldWidget {
   PDFFieldWidget^ get();
}

Property Value

The field widget that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldEditEventArgs Class
FieldEditEventArgs Members


%%ItemTitle%%

Page Property (FieldEditEventArgs)

O2S.Components.PDFView4NET Namespace > FieldEditEventArgs Class : Page Property
Gets the page where the clicked field widget appears.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PDFPage
'Usage

Dim instance As FieldEditEventArgs
Dim value As PDFPage

value = instance.Page
public PDFPage Page {get;}
public: __property PDFPage* get_Page();
public:
property PDFPage^ Page {
   PDFPage^ get();
}

Property Value

The page that displays the clicked field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldEditEventArgs Class
FieldEditEventArgs Members


%%PageItemTitle%%

FieldValidateEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : FieldValidateEventArgs Class
Defines the parameters for the PDFPageView.FieldValidate event.
Object Model
FieldValidateEventArgs ClassPDFField ClassPDFFieldWidget ClassPDFPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FieldValidateEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As FieldValidateEventArgs
public class FieldValidateEventArgs : System.EventArgs
public __gc class FieldValidateEventArgs : public System.EventArgs
public ref class FieldValidateEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.FieldValidateEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldValidateEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

FieldValidateEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : FieldValidateEventArgs Class

The following tables list the members exposed by FieldValidateEventArgs.

Public Properties
 | Name | Description
Public Property | Field | Gets the field that has been validated.
Public Property | FieldWidget | Gets the field widget that has been clicked.
Public Property | IsValid | Gets or sets a value indicating whether field value is valid or not.
Public Property | Page | Gets the page where the clicked field widget appears.
Top
See Also

Reference

FieldValidateEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

FieldValidateEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : FieldValidateEventArgs Class

For a list of all members of this type, see FieldValidateEventArgs members.

Public Properties
 | Name | Description
Public Property | Field | Gets the field that has been validated.
Public Property | FieldWidget | Gets the field widget that has been clicked.
Public Property | IsValid | Gets or sets a value indicating whether field value is valid or not.
Public Property | Page | Gets the page where the clicked field widget appears.
Top
See Also

Reference

FieldValidateEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Field Property (FieldValidateEventArgs)

O2S.Components.PDFView4NET Namespace > FieldValidateEventArgs Class : Field Property
Gets the field that has been validated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As FieldValidateEventArgs
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

The field that has been validated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldValidateEventArgs Class
FieldValidateEventArgs Members


%%ItemTitle%%

FieldWidget Property (FieldValidateEventArgs)

O2S.Components.PDFView4NET Namespace > FieldValidateEventArgs Class : FieldWidget Property
Gets the field widget that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FieldWidget As PDFFieldWidget
'Usage

Dim instance As FieldValidateEventArgs
Dim value As PDFFieldWidget

value = instance.FieldWidget
public PDFFieldWidget FieldWidget {get;}
public: __property PDFFieldWidget* get_FieldWidget();
public:
property PDFFieldWidget^ FieldWidget {
   PDFFieldWidget^ get();
}

Property Value

The field widget that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldValidateEventArgs Class
FieldValidateEventArgs Members


%%ItemTitle%%

IsValid Property (FieldValidateEventArgs)

O2S.Components.PDFView4NET Namespace > FieldValidateEventArgs Class : IsValid Property
Gets or sets a value indicating whether field value is valid or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsValid As Boolean
'Usage

Dim instance As FieldValidateEventArgs
Dim value As Boolean

instance.IsValid = value

value = instance.IsValid
public bool IsValid {get; set;}
public: __property bool get_IsValid();
public: __property void set_IsValid(
   bool value
);
public:
property bool IsValid {
   bool get();
   void set (    bool value);
}

Property Value

True if field value is value, false otherwise. Default is true.
Remarks
Set this property to false to mark a field as invalid and keep focus on the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldValidateEventArgs Class
FieldValidateEventArgs Members


%%ItemTitle%%

Page Property (FieldValidateEventArgs)

O2S.Components.PDFView4NET Namespace > FieldValidateEventArgs Class : Page Property
Gets the page where the clicked field widget appears.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PDFPage
'Usage

Dim instance As FieldValidateEventArgs
Dim value As PDFPage

value = instance.Page
public PDFPage Page {get;}
public: __property PDFPage* get_Page();
public:
property PDFPage^ Page {
   PDFPage^ get();
}

Property Value

The page that displays the clicked field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldValidateEventArgs Class
FieldValidateEventArgs Members


%%PageItemTitle%%

InvalidDocumentException Class
Members

O2S.Components.PDFView4NET Namespace : InvalidDocumentException Class
Defines the exception thrown when the PDF file is not valid.
Object Model
InvalidDocumentException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class InvalidDocumentException
   Inherits System.ApplicationException
'Usage

Dim instance As InvalidDocumentException
[Serializable()]
public class InvalidDocumentException : System.ApplicationException
[Serializable()]
public __gc class InvalidDocumentException : public System.ApplicationException
[Serializable()]
public ref class InvalidDocumentException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFView4NET.InvalidDocumentException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDocumentException Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

InvalidDocumentException Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : InvalidDocumentException Class

The following tables list the members exposed by InvalidDocumentException.

Public Constructors
 | Name | Description
Public Constructor | InvalidDocumentException Constructor | Initializes a new InvalidDocumentException object.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidDocumentException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

InvalidDocumentException Constructor

O2S.Components.PDFView4NET Namespace > InvalidDocumentException Class : InvalidDocumentException Constructor
The message with details about the error in page content.
Initializes a new InvalidDocumentException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidDocumentException(message)
public InvalidDocumentException(
   string message
)
public: InvalidDocumentException(
   string* message
)
public:
InvalidDocumentException(
   String^ message
)

Parameters

message
The message with details about the error in page content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDocumentException Class
InvalidDocumentException Members


%%PageItemTitle%%

InvalidPasswordException Class
Members

O2S.Components.PDFView4NET Namespace : InvalidPasswordException Class
Defines the exception thrown when the password for opening the PDF file is not valid.
Object Model
InvalidPasswordException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class InvalidPasswordException
   Inherits System.ApplicationException
'Usage

Dim instance As InvalidPasswordException
[Serializable()]
public class InvalidPasswordException : System.ApplicationException
[Serializable()]
public __gc class InvalidPasswordException : public System.ApplicationException
[Serializable()]
public ref class InvalidPasswordException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFView4NET.InvalidPasswordException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

InvalidPasswordException Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : InvalidPasswordException Class

The following tables list the members exposed by InvalidPasswordException.

Public Constructors
 | Name | Description
Public Constructor | InvalidPasswordException Constructor | Initializes a new InvalidPasswordException object.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPasswordException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

InvalidPasswordException Constructor

O2S.Components.PDFView4NET Namespace > InvalidPasswordException Class : InvalidPasswordException Constructor
The message with details about the error in page content.
Initializes a new InvalidPasswordException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPasswordException(message)
public InvalidPasswordException(
   string message
)
public: InvalidPasswordException(
   string* message
)
public:
InvalidPasswordException(
   String^ message
)

Parameters

message
The message with details about the error in page content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


%%PageItemTitle%%

PageClickEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : PageClickEventArgs Class
Defines the parameters for the PDFPageView.PageClick and PDFPageView.PageDoubleClick events.
Object Model
PageClickEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PageClickEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PageClickEventArgs
public class PageClickEventArgs : System.EventArgs
public __gc class PageClickEventArgs : public System.EventArgs
public ref class PageClickEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.PageClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageClickEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PageClickEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : PageClickEventArgs Class

The following tables list the members exposed by PageClickEventArgs.

Public Properties
 | Name | Description
Public Property | ControlPoint | Gets the control point where the page was clicked.
Public Property | MouseButton | Gets the mouse button that was clicked on the page.
Public Property | PageNumber | Gets the number of the page that has been clicked.
Public Property | PDFPoint | Gets the PDF point where the page was clicked.
Top
See Also

Reference

PageClickEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PageClickEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : PageClickEventArgs Class

For a list of all members of this type, see PageClickEventArgs members.

Public Properties
 | Name | Description
Public Property | ControlPoint | Gets the control point where the page was clicked.
Public Property | MouseButton | Gets the mouse button that was clicked on the page.
Public Property | PageNumber | Gets the number of the page that has been clicked.
Public Property | PDFPoint | Gets the PDF point where the page was clicked.
Top
See Also

Reference

PageClickEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

ControlPoint Property

O2S.Components.PDFView4NET Namespace > PageClickEventArgs Class : ControlPoint Property
Gets the control point where the page was clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ControlPoint As Point
'Usage

Dim instance As PageClickEventArgs
Dim value As Point

value = instance.ControlPoint
public Point ControlPoint {get;}
public: __property Point get_ControlPoint();
public:
property Point ControlPoint {
   Point get();
}

Property Value

The click point in control coordinates.
Remarks
The position of the click point is given in pixels relative to the top left corner of the corner.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageClickEventArgs Class
PageClickEventArgs Members


%%ItemTitle%%

MouseButton Property (PageClickEventArgs)

O2S.Components.PDFView4NET Namespace > PageClickEventArgs Class : MouseButton Property
Gets the mouse button that was clicked on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MouseButton As MouseButtons
'Usage

Dim instance As PageClickEventArgs
Dim value As MouseButtons

value = instance.MouseButton
public MouseButtons MouseButton {get;}
public: __property MouseButtons get_MouseButton();
public:
property MouseButtons MouseButton {
   MouseButtons get();
}

Property Value

A System.Windows.Forms.MouseButtons enumeration member specifying the mouse button that was clicked on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageClickEventArgs Class
PageClickEventArgs Members


%%ItemTitle%%

PageNumber Property (PageClickEventArgs)

O2S.Components.PDFView4NET Namespace > PageClickEventArgs Class : PageNumber Property
Gets the number of the page that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As PageClickEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

The page that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageClickEventArgs Class
PageClickEventArgs Members


%%ItemTitle%%

PDFPoint Property

O2S.Components.PDFView4NET Namespace > PageClickEventArgs Class : PDFPoint Property
Gets the PDF point where the page was clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PDFPoint As PDFPoint
'Usage

Dim instance As PageClickEventArgs
Dim value As PDFPoint

value = instance.PDFPoint
public PDFPoint PDFPoint {get;}
public: __property PDFPoint* get_PDFPoint();
public:
property PDFPoint^ PDFPoint {
   PDFPoint^ get();
}

Property Value

The click point in PDF coordinates.
Remarks
The position of the click point is given in points relative to the origin of the PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageClickEventArgs Class
PageClickEventArgs Members


%%PageItemTitle%%

PageContextMenuEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : PageContextMenuEventArgs Class
Defines the parameters for the page context menu event.
Object Model
PageContextMenuEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PageContextMenuEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PageContextMenuEventArgs
public class PageContextMenuEventArgs : System.EventArgs
public __gc class PageContextMenuEventArgs : public System.EventArgs
public ref class PageContextMenuEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.PageContextMenuEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageContextMenuEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PageContextMenuEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : PageContextMenuEventArgs Class

The following tables list the members exposed by PageContextMenuEventArgs.

Public Properties
 | Name | Description
Public Property | MousePosition | Gets the position where the mouse was clicked.
Public Property | PageNumber | Gets the number of the page that has been clicked.
Top
See Also

Reference

PageContextMenuEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PageContextMenuEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : PageContextMenuEventArgs Class

For a list of all members of this type, see PageContextMenuEventArgs members.

Public Properties
 | Name | Description
Public Property | MousePosition | Gets the position where the mouse was clicked.
Public Property | PageNumber | Gets the number of the page that has been clicked.
Top
See Also

Reference

PageContextMenuEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

MousePosition Property (PageContextMenuEventArgs)

O2S.Components.PDFView4NET Namespace > PageContextMenuEventArgs Class : MousePosition Property
Gets the position where the mouse was clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MousePosition As Point
'Usage

Dim instance As PageContextMenuEventArgs
Dim value As Point

value = instance.MousePosition
public Point MousePosition {get;}
public: __property Point get_MousePosition();
public:
property Point MousePosition {
   Point get();
}

Property Value

The position in control coordinates where the context menu should be displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageContextMenuEventArgs Class
PageContextMenuEventArgs Members


%%ItemTitle%%

PageNumber Property (PageContextMenuEventArgs)

O2S.Components.PDFView4NET Namespace > PageContextMenuEventArgs Class : PageNumber Property
Gets the number of the page that has been clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As PageContextMenuEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

The page that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageContextMenuEventArgs Class
PageContextMenuEventArgs Members


%%PageItemTitle%%

PageRenderingErrorEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : PageRenderingErrorEventArgs Class
Defines the arguments for page rendering error event.
Object Model
PageRenderingErrorEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PageRenderingErrorEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PageRenderingErrorEventArgs
public class PageRenderingErrorEventArgs : System.EventArgs
public __gc class PageRenderingErrorEventArgs : public System.EventArgs
public ref class PageRenderingErrorEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.PageRenderingErrorEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PageRenderingErrorEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : PageRenderingErrorEventArgs Class

The following tables list the members exposed by PageRenderingErrorEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PageRenderingErrorEventArgs Constructor | Initializes a new PageRenderingErrorEventArgs object.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the page rendering should be cancelled or not.
Public Property | ErrorMessage | Gets the associated error message.
Public Property | PageNumber | Gets the page number where the error appeared.
Public Property | PageRenderingError | Gets the type of the error that appeared.
Top
See Also

Reference

PageRenderingErrorEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PageRenderingErrorEventArgs Constructor

O2S.Components.PDFView4NET Namespace > PageRenderingErrorEventArgs Class : PageRenderingErrorEventArgs Constructor
The page number on which the error appeared.
The type of the error that appeared.
Optional error message with details about the error.
Initializes a new PageRenderingErrorEventArgs object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageNumber As Integer, _
   ByVal pageRenderingError As PDFPageRenderingError, _
   ByVal errorMessage As String _
)
'Usage

Dim pageNumber As Integer
Dim pageRenderingError As PDFPageRenderingError
Dim errorMessage As String

Dim instance As New PageRenderingErrorEventArgs(pageNumber, pageRenderingError, errorMessage)
public PageRenderingErrorEventArgs(
   int pageNumber,
   PDFPageRenderingError pageRenderingError,
   string errorMessage
)
public: PageRenderingErrorEventArgs(
   int pageNumber,
   PDFPageRenderingError pageRenderingError,
   string* errorMessage
)
public:
PageRenderingErrorEventArgs(
   int pageNumber,
   PDFPageRenderingError pageRenderingError,
   String^ errorMessage
)

Parameters

pageNumber
The page number on which the error appeared.
pageRenderingError
The type of the error that appeared.
errorMessage
Optional error message with details about the error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%PageItemTitle%% $$Properties$$

PageRenderingErrorEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : PageRenderingErrorEventArgs Class

For a list of all members of this type, see PageRenderingErrorEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the page rendering should be cancelled or not.
Public Property | ErrorMessage | Gets the associated error message.
Public Property | PageNumber | Gets the page number where the error appeared.
Public Property | PageRenderingError | Gets the type of the error that appeared.
Top
See Also

Reference

PageRenderingErrorEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Cancel Property (PageRenderingErrorEventArgs)

O2S.Components.PDFView4NET Namespace > PageRenderingErrorEventArgs Class : Cancel Property
Gets or sets a value indicating whether the page rendering should be cancelled or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As PageRenderingErrorEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

True if the rest of the page should not be rendered, otherwise false. Default false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%ItemTitle%%

ErrorMessage Property (PageRenderingErrorEventArgs)

O2S.Components.PDFView4NET Namespace > PageRenderingErrorEventArgs Class : ErrorMessage Property
Gets the associated error message.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ErrorMessage As String
'Usage

Dim instance As PageRenderingErrorEventArgs
Dim value As String

value = instance.ErrorMessage
public string ErrorMessage {get;}
public: __property string* get_ErrorMessage();
public:
property String^ ErrorMessage {
   String^ get();
}

Property Value

Message with details about the error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%ItemTitle%%

PageNumber Property (PageRenderingErrorEventArgs)

O2S.Components.PDFView4NET Namespace > PageRenderingErrorEventArgs Class : PageNumber Property
Gets the page number where the error appeared.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As PageRenderingErrorEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

The number of page where the error appeared.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%ItemTitle%%

PageRenderingError Property (PageRenderingErrorEventArgs)

O2S.Components.PDFView4NET Namespace > PageRenderingErrorEventArgs Class : PageRenderingError Property
Gets the type of the error that appeared.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageRenderingError As PDFPageRenderingError
'Usage

Dim instance As PageRenderingErrorEventArgs
Dim value As PDFPageRenderingError

value = instance.PageRenderingError
public PDFPageRenderingError PageRenderingError {get;}
public: __property PDFPageRenderingError get_PageRenderingError();
public:
property PDFPageRenderingError PageRenderingError {
   PDFPageRenderingError get();
}

Property Value

The type of error that appeared during page rendering.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingErrorEventArgs Class
PageRenderingErrorEventArgs Members


%%PageItemTitle%%

PasswordRequiredEventArgs Class
Members

O2S.Components.PDFView4NET Namespace : PasswordRequiredEventArgs Class
Event arguments for PasswordRequired event.
Object Model
PasswordRequiredEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PasswordRequiredEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PasswordRequiredEventArgs
public class PasswordRequiredEventArgs : System.EventArgs
public __gc class PasswordRequiredEventArgs : public System.EventArgs
public ref class PasswordRequiredEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.PasswordRequiredEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PasswordRequiredEventArgs Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PasswordRequiredEventArgs Class Members
Properties

O2S.Components.PDFView4NET Namespace : PasswordRequiredEventArgs Class

The following tables list the members exposed by PasswordRequiredEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PasswordRequiredEventArgs Constructor | Initializes a new PasswordRequiredEventArgs object.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the PasswordRequired event should be fired again or not if the password is not valid.
Public Property | Password | Gets or sets the password to be used for opening the PDF file.
Top
See Also

Reference

PasswordRequiredEventArgs Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PasswordRequiredEventArgs Constructor

O2S.Components.PDFView4NET Namespace > PasswordRequiredEventArgs Class : PasswordRequiredEventArgs Constructor
Initializes a new PasswordRequiredEventArgs object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PasswordRequiredEventArgs()
public PasswordRequiredEventArgs()
public: PasswordRequiredEventArgs();
public:
PasswordRequiredEventArgs();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PasswordRequiredEventArgs Class
PasswordRequiredEventArgs Members


%%PageItemTitle%% $$Properties$$

PasswordRequiredEventArgs Class Properties

O2S.Components.PDFView4NET Namespace : PasswordRequiredEventArgs Class

For a list of all members of this type, see PasswordRequiredEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the PasswordRequired event should be fired again or not if the password is not valid.
Public Property | Password | Gets or sets the password to be used for opening the PDF file.
Top
See Also

Reference

PasswordRequiredEventArgs Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Cancel Property (PasswordRequiredEventArgs)

O2S.Components.PDFView4NET Namespace > PasswordRequiredEventArgs Class : Cancel Property
Gets or sets a value indicating whether the PasswordRequired event should be fired again or not if the password is not valid.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As PasswordRequiredEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

True if the PasswordRequired event should not be fired again if the password is invalid, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PasswordRequiredEventArgs Class
PasswordRequiredEventArgs Members


%%ItemTitle%%

Password Property (PasswordRequiredEventArgs)

O2S.Components.PDFView4NET Namespace > PasswordRequiredEventArgs Class : Password Property
Gets or sets the password to be used for opening the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Password As Byte()
'Usage

Dim instance As PasswordRequiredEventArgs
Dim value() As Byte

instance.Password = value

value = instance.Password
public byte[] Password {get; set;}
public: __property byte[]* get_Password();
public: __property void set_Password(
   byte[]* value
);
public:
property array<byte>^ Password {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The password for opening the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PasswordRequiredEventArgs Class
PasswordRequiredEventArgs Members


%%PageItemTitle%%

PDFAnnotationsView Class
Members

O2S.Components.PDFView4NET Namespace : PDFAnnotationsView Class
Defines a viewer for the annotations in a PDF file.
Object Model
PDFAnnotationsView ClassPDFDocument ClassPDFPageView ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class PDFAnnotationsView
   Inherits O2S.Components.WinForms.TreeList
'Usage

Dim instance As PDFAnnotationsView
[ToolboxBitmap()]
public class PDFAnnotationsView : O2S.Components.WinForms.TreeList
[ToolboxBitmap()]
public __gc class PDFAnnotationsView : public O2S.Components.WinForms.TreeList
[ToolboxBitmap()]
public ref class PDFAnnotationsView : public O2S.Components.WinForms.TreeList
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
O2S.Components.PDFView4NET.PDFAnnotationsView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsView Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationsView Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFAnnotationsView Class

The following tables list the members exposed by PDFAnnotationsView.

Public Constructors
 | Name | Description
Public Constructor | PDFAnnotationsView Constructor | Initializes a new PDFAnnotationsView object.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the PDF document for which the annotations are displayed.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageView | Gets or sets the pages viewer control that represents the target for the annotations in the document.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedAnnotation | Gets or sets the selected annotation in the control.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top
Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
Public Events
 | Name | Description
Public Event | AnnotationClick | Gets or sets the event that is fired when an annotation is clicked with the mouse.
Public Event | AnnotationContextMenu | Gets or sets the event that is fired when a context menu should be displayed for the annotation.
Public Event | AnnotationDoubleClick | Gets or sets the event that is fired when an annotation is double clicked with the mouse.
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFAnnotationsView Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFAnnotationsView Constructor

O2S.Components.PDFView4NET Namespace > PDFAnnotationsView Class : PDFAnnotationsView Constructor
Initializes a new PDFAnnotationsView object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFAnnotationsView()
public PDFAnnotationsView()
public: PDFAnnotationsView();
public:
PDFAnnotationsView();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsView Class
PDFAnnotationsView Members


%%PageItemTitle%% $$Properties$$

PDFAnnotationsView Class Properties

O2S.Components.PDFView4NET Namespace : PDFAnnotationsView Class

For a list of all members of this type, see PDFAnnotationsView members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the PDF document for which the annotations are displayed.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageView | Gets or sets the pages viewer control that represents the target for the annotations in the document.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedAnnotation | Gets or sets the selected annotation in the control.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFAnnotationsView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Document Property (PDFAnnotationsView)

O2S.Components.PDFView4NET Namespace > PDFAnnotationsView Class : Document Property
Gets or sets the PDF document for which the annotations are displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DescriptionAttribute("The document for which the annotations are displayed")>
<DefaultValueAttribute()>
Public Property Document As PDFDocument
'Usage

Dim instance As PDFAnnotationsView
Dim value As PDFDocument

instance.Document = value

value = instance.Document
[Category("PDF")]
[Description("The document for which the annotations are displayed")]
[DefaultValue()]
public PDFDocument Document {get; set;}
[Category("PDF")]
[Description("The document for which the annotations are displayed")]
[DefaultValue()]
public: __property PDFDocument* get_Document();
public: __property void set_Document(
   PDFDocument* value
);
[Category("PDF")]
[Description("The document for which the annotations are displayed")]
[DefaultValue()]
public:
property PDFDocument^ Document {
   PDFDocument^ get();
   void set (    PDFDocument^ value);
}

Property Value

A PDFDocument object specifying the document for which the annotations are displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsView Class
PDFAnnotationsView Members


%%ItemTitle%%

PageView Property (PDFAnnotationsView)

O2S.Components.PDFView4NET Namespace > PDFAnnotationsView Class : PageView Property
Gets or sets the pages viewer control that represents the target for the annotations in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The page viewer control that displays the annotations")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
Public Property PageView As PDFPageView
'Usage

Dim instance As PDFAnnotationsView
Dim value As PDFPageView

instance.PageView = value

value = instance.PageView
[Description("The page viewer control that displays the annotations")]
[DefaultValue()]
[Category("PDF")]
public PDFPageView PageView {get; set;}
[Description("The page viewer control that displays the annotations")]
[DefaultValue()]
[Category("PDF")]
public: __property PDFPageView* get_PageView();
public: __property void set_PageView(
   PDFPageView* value
);
[Description("The page viewer control that displays the annotations")]
[DefaultValue()]
[Category("PDF")]
public:
property PDFPageView^ PageView {
   PDFPageView^ get();
   void set (    PDFPageView^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsView Class
PDFAnnotationsView Members


%%ItemTitle%%

SelectedAnnotation Property

O2S.Components.PDFView4NET Namespace > PDFAnnotationsView Class : SelectedAnnotation Property
Gets or sets the selected annotation in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property SelectedAnnotation As PDFAnnotation
'Usage

Dim instance As PDFAnnotationsView
Dim value As PDFAnnotation

instance.SelectedAnnotation = value

value = instance.SelectedAnnotation
[Browsable(false)]
public PDFAnnotation SelectedAnnotation {get; set;}
[Browsable(false)]
public: __property PDFAnnotation* get_SelectedAnnotation();
public: __property void set_SelectedAnnotation(
   PDFAnnotation* value
);
[Browsable(false)]
public:
property PDFAnnotation^ SelectedAnnotation {
   PDFAnnotation^ get();
   void set (    PDFAnnotation^ value);
}

Property Value

The selected annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsView Class
PDFAnnotationsView Members


%%PageItemTitle%% $$Events$$

PDFAnnotationsView Class Events

O2S.Components.PDFView4NET Namespace : PDFAnnotationsView Class

For a list of all members of this type, see PDFAnnotationsView members.

Public Events
 | Name | Description
Public Event | AnnotationClick | Gets or sets the event that is fired when an annotation is clicked with the mouse.
Public Event | AnnotationContextMenu | Gets or sets the event that is fired when a context menu should be displayed for the annotation.
Public Event | AnnotationDoubleClick | Gets or sets the event that is fired when an annotation is double clicked with the mouse.
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFAnnotationsView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

AnnotationClick Event (PDFAnnotationsView)

O2S.Components.PDFView4NET Namespace > PDFAnnotationsView Class : AnnotationClick Event
Gets or sets the event that is fired when an annotation is clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AnnotationClick As EventHandler(Of AnnotationClickEventArgs)
'Usage

Dim instance As PDFAnnotationsView
Dim handler As EventHandler(Of AnnotationClickEventArgs)

AddHandler instance.AnnotationClick, handler
public event EventHandler<AnnotationClickEventArgs> AnnotationClick
public: __event EventHandler<AnnotationClickEventArgs*>* AnnotationClick
public:
event EventHandler<AnnotationClickEventArgs^>^ AnnotationClick
Event Data

The event handler receives an argument of type AnnotationClickEventArgs containing data related to this event. The following AnnotationClickEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that has been double clicked.
MouseButton | Gets the mouse button that was clicked on the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsView Class
PDFAnnotationsView Members


%%ItemTitle%%

AnnotationContextMenu Event (PDFAnnotationsView)

O2S.Components.PDFView4NET Namespace > PDFAnnotationsView Class : AnnotationContextMenu Event
Gets or sets the event that is fired when a context menu should be displayed for the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AnnotationContextMenu As EventHandler(Of AnnotationContextMenuEventArgs)
'Usage

Dim instance As PDFAnnotationsView
Dim handler As EventHandler(Of AnnotationContextMenuEventArgs)

AddHandler instance.AnnotationContextMenu, handler
public event EventHandler<AnnotationContextMenuEventArgs> AnnotationContextMenu
public: __event EventHandler<AnnotationContextMenuEventArgs*>* AnnotationContextMenu
public:
event EventHandler<AnnotationContextMenuEventArgs^>^ AnnotationContextMenu
Event Data

The event handler receives an argument of type AnnotationContextMenuEventArgs containing data related to this event. The following AnnotationContextMenuEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that has been double clicked.
MousePosition | Gets the position where the mouse was clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsView Class
PDFAnnotationsView Members


%%ItemTitle%%

AnnotationDoubleClick Event (PDFAnnotationsView)

O2S.Components.PDFView4NET Namespace > PDFAnnotationsView Class : AnnotationDoubleClick Event
Gets or sets the event that is fired when an annotation is double clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AnnotationDoubleClick As EventHandler(Of AnnotationClickEventArgs)
'Usage

Dim instance As PDFAnnotationsView
Dim handler As EventHandler(Of AnnotationClickEventArgs)

AddHandler instance.AnnotationDoubleClick, handler
public event EventHandler<AnnotationClickEventArgs> AnnotationDoubleClick
public: __event EventHandler<AnnotationClickEventArgs*>* AnnotationDoubleClick
public:
event EventHandler<AnnotationClickEventArgs^>^ AnnotationDoubleClick
Event Data

The event handler receives an argument of type AnnotationClickEventArgs containing data related to this event. The following AnnotationClickEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that has been double clicked.
MouseButton | Gets the mouse button that was clicked on the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsView Class
PDFAnnotationsView Members


%%PageItemTitle%%

PDFAnnotationsViewCollection Class
Members

O2S.Components.PDFView4NET Namespace : PDFAnnotationsViewCollection Class
Defines a collection of PDFAnnotationsView objects representing the viewers for a document's annotations.
Object Model
PDFAnnotationsViewCollection ClassPDFAnnotationsView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAnnotationsViewCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFAnnotationsView,PDFDocument)
'Usage

Dim instance As PDFAnnotationsViewCollection
public class PDFAnnotationsViewCollection : O2S.Components.PDFView4NET.PDFCollection<PDFAnnotationsView,PDFDocument>
public __gc class PDFAnnotationsViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFAnnotationsView,PDFDocument>
public ref class PDFAnnotationsViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFAnnotationsView,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.PDFAnnotationsViewCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsViewCollection Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationsViewCollection Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFAnnotationsViewCollection Class

The following tables list the members exposed by PDFAnnotationsViewCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFAnnotationsView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Top
See Also

Reference

PDFAnnotationsViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFAnnotationToolTip Class
Members

O2S.Components.PDFView4NET Namespace : PDFAnnotationToolTip Class
Defines the way how tooltips are displayed for annotations.
Object Model
PDFAnnotationToolTip Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAnnotationToolTip
'Usage

Dim instance As PDFAnnotationToolTip
public class PDFAnnotationToolTip
public __gc class PDFAnnotationToolTip
public ref class PDFAnnotationToolTip
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFAnnotationToolTip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationToolTip Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationToolTip Class Members
Properties Events

O2S.Components.PDFView4NET Namespace : PDFAnnotationToolTip Class

The following tables list the members exposed by PDFAnnotationToolTip.

Public Constructors
 | Name | Description
Public Constructor | PDFAnnotationToolTip Constructor | Initializes a new PDFAnnotationToolTip object.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color for the annotation tooltip.
Public Property | Contents | Gets or sets the contents of annotation tooltip.
Public Property | ForeColor | Gets or sets the foreground color for the annotation tooltip.
Public Property | OwnerDraw | Gets or sets a value indicating whether the annotation tooltip is drawn by the operating system or by application code that you provide.
Public Property | Title | Gets or sets the title of annotation tooltip. Gets or sets of way the tooltips are displayed for annotations.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFAnnotationToolTip Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFAnnotationToolTip Constructor

O2S.Components.PDFView4NET Namespace > PDFAnnotationToolTip Class : PDFAnnotationToolTip Constructor
Initializes a new PDFAnnotationToolTip object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFAnnotationToolTip()
public PDFAnnotationToolTip()
public: PDFAnnotationToolTip();
public:
PDFAnnotationToolTip();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationToolTip Class
PDFAnnotationToolTip Members


%%PageItemTitle%% $$Properties$$

PDFAnnotationToolTip Class Properties

O2S.Components.PDFView4NET Namespace : PDFAnnotationToolTip Class

For a list of all members of this type, see PDFAnnotationToolTip members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color for the annotation tooltip.
Public Property | Contents | Gets or sets the contents of annotation tooltip.
Public Property | ForeColor | Gets or sets the foreground color for the annotation tooltip.
Public Property | OwnerDraw | Gets or sets a value indicating whether the annotation tooltip is drawn by the operating system or by application code that you provide.
Public Property | Title | Gets or sets the title of annotation tooltip. Gets or sets of way the tooltips are displayed for annotations.
Top
See Also

Reference

PDFAnnotationToolTip Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

BackColor Property (PDFAnnotationToolTip)

O2S.Components.PDFView4NET Namespace > PDFAnnotationToolTip Class : BackColor Property
Gets or sets the background color for the annotation tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BackColor As Color
'Usage

Dim instance As PDFAnnotationToolTip
Dim value As Color

instance.BackColor = value

value = instance.BackColor
public Color BackColor {get; set;}
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
public:
property Color BackColor {
   Color get();
   void set (    Color value);
}

Property Value

The background System.Drawing.Color of the annotation tooltip.
Remarks
Use the BackColor and ForeColor properties to modify the color scheme used by annotation tooltips. The system default font is automatically used and can only be overridden by owner-drawing the annotation tooltip. For more information, see the OwnerDraw property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationToolTip Class
PDFAnnotationToolTip Members


%%ItemTitle%%

Contents Property (PDFAnnotationToolTip)

O2S.Components.PDFView4NET Namespace > PDFAnnotationToolTip Class : Contents Property
Gets or sets the contents of annotation tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ToolTips")>
<DefaultValueAttribute()>
<DescriptionAttribute("The contents of the tooltip")>
Public Property Contents As String
'Usage

Dim instance As PDFAnnotationToolTip
Dim value As String

instance.Contents = value

value = instance.Contents
[Category("ToolTips")]
[DefaultValue()]
[Description("The contents of the tooltip")]
public string Contents {get; set;}
[Category("ToolTips")]
[DefaultValue()]
[Description("The contents of the tooltip")]
public: __property string* get_Contents();
public: __property void set_Contents(
   string* value
);
[Category("ToolTips")]
[DefaultValue()]
[Description("The contents of the tooltip")]
public:
property String^ Contents {
   String^ get();
   void set (    String^ value);
}

Property Value

The contents of the annotation tooltip.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationToolTip Class
PDFAnnotationToolTip Members


%%ItemTitle%%

ForeColor Property

O2S.Components.PDFView4NET Namespace > PDFAnnotationToolTip Class : ForeColor Property
Gets or sets the foreground color for the annotation tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ForeColor As Color
'Usage

Dim instance As PDFAnnotationToolTip
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
public Color ForeColor {get; set;}
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
public:
property Color ForeColor {
   Color get();
   void set (    Color value);
}

Property Value

The foreground System.Drawing.Color of the annotation tooltip.
Remarks
Use the BackColor and ForeColor properties to modify the color scheme used by annotation tooltips. The system default font is automatically used and can only be overridden by owner-drawing the annotation tooltip. For more information, see the OwnerDraw property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationToolTip Class
PDFAnnotationToolTip Members


%%ItemTitle%%

OwnerDraw Property

O2S.Components.PDFView4NET Namespace > PDFAnnotationToolTip Class : OwnerDraw Property
Gets or sets a value indicating whether the annotation tooltip is drawn by the operating system or by application code that you provide.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OwnerDraw As Boolean
'Usage

Dim instance As PDFAnnotationToolTip
Dim value As Boolean

instance.OwnerDraw = value

value = instance.OwnerDraw
public bool OwnerDraw {get; set;}
public: __property bool get_OwnerDraw();
public: __property void set_OwnerDraw(
   bool value
);
public:
property bool OwnerDraw {
   bool get();
   void set (    bool value);
}

Property Value

true if the annotation tooltip is drawn by code that you provide; false if the annotation tooltip is drawn by the operating system. The default is false.
Remarks
Usually, an annotation tooltip is drawn by the operating system, but to customize the appearance of the annotation tooltip you can set the OwnerDraw property to true and handle the PDFPageView.AnnotationToolTipDraw event.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationToolTip Class
PDFAnnotationToolTip Members


%%ItemTitle%%

Title Property (PDFAnnotationToolTip)

O2S.Components.PDFView4NET Namespace > PDFAnnotationToolTip Class : Title Property
Gets or sets the title of annotation tooltip. Gets or sets of way the tooltips are displayed for annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("ToolTips")>
<DefaultValueAttribute()>
<DescriptionAttribute("The title of the tooltip")>
Public Property Title As String
'Usage

Dim instance As PDFAnnotationToolTip
Dim value As String

instance.Title = value

value = instance.Title
[Category("ToolTips")]
[DefaultValue()]
[Description("The title of the tooltip")]
public string Title {get; set;}
[Category("ToolTips")]
[DefaultValue()]
[Description("The title of the tooltip")]
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
[Category("ToolTips")]
[DefaultValue()]
[Description("The title of the tooltip")]
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

The title of the annotation tooltip.A %% object that describes how tooltips should be displayed for annotations.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationToolTip Class
PDFAnnotationToolTip Members


%%PageItemTitle%% $$Events$$

PDFAnnotationToolTip Class Events

O2S.Components.PDFView4NET Namespace : PDFAnnotationToolTip Class

For a list of all members of this type, see PDFAnnotationToolTip members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFAnnotationToolTip Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

PropertyChanged Event (PDFAnnotationToolTip)

O2S.Components.PDFView4NET Namespace > PDFAnnotationToolTip Class : PropertyChanged Event
Gets or sets the event that is fired when a property has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As PDFAnnotationToolTip
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationToolTip Class
PDFAnnotationToolTip Members


%%PageItemTitle%%

PDFBookmark Class
Members

O2S.Components.PDFView4NET Namespace : PDFBookmark Class
Defines a bookmark in a PDF file.
Object Model
PDFBookmark ClassPDFAction ClassPDFBookmarkCollection ClassPDFBookmark ClassPDFRgbColor ClassPDFDocument ClassPDFBookmark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFBookmark
   Implements IRawPDFData
'Usage

Dim instance As PDFBookmark
public class PDFBookmark : IRawPDFData
public __gc class PDFBookmark : public IRawPDFData
public ref class PDFBookmark : public IRawPDFData
Remarks
The bookmarks have a tree structure that allows an easier navigation into the document. The bookmarks tree serves as a table of contents for the document.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFBookmark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFBookmark Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFBookmark Class

The following tables list the members exposed by PDFBookmark.

Public Constructors
 | Name | Description
Public Constructor | PDFBookmark Constructor | Initializes a new PDFBookmark object.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the bookmark is clicked.
Public Property | Bookmarks | Gets the collection of child bookmarks.
Public Property | Color | Gets or sets the bookmark color.
Public Property | DisplayStyle | Gets or sets the display style of this object.
Public Property | Document | Gets or sets the document this bookmark belongs to.
Public Property | Expanded | Gets or sets a value indicating whether the bookmark should be displayed in collapsed or expanded state.
Public Property | Parent | Gets the parent of this PDFBookmark object.
Public Property | Title | Gets or sets the title of this bookmark.
Top
Public Methods
 | Name | Description
Public Method | Execute | Executes the bookmark's action or destination on the target pages view control.
Public Method | GetRawValue | Gets the value of the specified key.
Top
See Also

Reference

PDFBookmark Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFBookmark Constructor

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : PDFBookmark Constructor
Initializes a new PDFBookmark object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFBookmark()
public PDFBookmark()
public: PDFBookmark();
public:
PDFBookmark();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%PageItemTitle%% $$Methods$$

PDFBookmark Class Methods

O2S.Components.PDFView4NET Namespace : PDFBookmark Class

For a list of all members of this type, see PDFBookmark members.

Public Methods
 | Name | Description
Public Method | Execute | Executes the bookmark's action or destination on the target pages view control.
Public Method | GetRawValue | Gets the value of the specified key.
Top
See Also

Reference

PDFBookmark Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Execute Method

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : Execute Method
The pages view on which the bookmark action or destination is executed.
Executes the bookmark's action or destination on the target pages view control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Execute( _
   ByVal pageView As PDFPageView _
)
'Usage

Dim instance As PDFBookmark
Dim pageView As PDFPageView

instance.Execute(pageView)
public void Execute(
   PDFPageView pageView
)
public: void Execute(
   PDFPageView* pageView
)
public:
void Execute(
   PDFPageView^ pageView
)

Parameters

pageView
The pages view on which the bookmark action or destination is executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%ItemTitle%%

GetRawValue Method (PDFBookmark)

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : GetRawValue Method
The key in the bookmark for which the value has been requested.
Gets the value of the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRawValue( _
   ByVal key As String _
) As String
'Usage

Dim instance As PDFBookmark
Dim key As String
Dim value As String

value = instance.GetRawValue(key)
public string GetRawValue(
   string key
)
public: string* GetRawValue(
   string* key
)
public:
String^ GetRawValue(
   String^ key
)

Parameters

key
The key in the bookmark for which the value has been requested.

Return Value

The value of the given key, or null if the bookmark does not contain the key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%PageItemTitle%% $$Properties$$

PDFBookmark Class Properties

O2S.Components.PDFView4NET Namespace : PDFBookmark Class

For a list of all members of this type, see PDFBookmark members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the bookmark is clicked.
Public Property | Bookmarks | Gets the collection of child bookmarks.
Public Property | Color | Gets or sets the bookmark color.
Public Property | DisplayStyle | Gets or sets the display style of this object.
Public Property | Document | Gets or sets the document this bookmark belongs to.
Public Property | Expanded | Gets or sets a value indicating whether the bookmark should be displayed in collapsed or expanded state.
Public Property | Parent | Gets the parent of this PDFBookmark object.
Public Property | Title | Gets or sets the title of this bookmark.
Top
See Also

Reference

PDFBookmark Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Action Property (PDFBookmark)

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : Action Property
Gets or sets the action to be executed when the bookmark is clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Action As PDFAction
'Usage

Dim instance As PDFBookmark
Dim value As PDFAction

instance.Action = value

value = instance.Action
public PDFAction Action {get; set;}
public: __property PDFAction* get_Action();
public: __property void set_Action(
   PDFAction* value
);
public:
property PDFAction^ Action {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to execute when the bookmark is selected by the user.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%ItemTitle%%

Bookmarks Property (PDFBookmark)

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : Bookmarks Property
Gets the collection of child bookmarks.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bookmarks As PDFBookmarkCollection
'Usage

Dim instance As PDFBookmark
Dim value As PDFBookmarkCollection

value = instance.Bookmarks
public PDFBookmarkCollection Bookmarks {get;}
public: __property PDFBookmarkCollection* get_Bookmarks();
public:
property PDFBookmarkCollection^ Bookmarks {
   PDFBookmarkCollection^ get();
}

Property Value

A PDFBookmarkCollection object with the list of child bookmarks.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%ItemTitle%%

Color Property (PDFBookmark)

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : Color Property
Gets or sets the bookmark color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As PDFRgbColor
'Usage

Dim instance As PDFBookmark
Dim value As PDFRgbColor

instance.Color = value

value = instance.Color
public PDFRgbColor Color {get; set;}
public: __property PDFRgbColor* get_Color();
public: __property void set_Color(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ Color {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The color of the bookmark.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%ItemTitle%%

DisplayStyle Property

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : DisplayStyle Property
Gets or sets the display style of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayStyle As PDFBookmarkDisplayStyle
'Usage

Dim instance As PDFBookmark
Dim value As PDFBookmarkDisplayStyle

instance.DisplayStyle = value

value = instance.DisplayStyle
public PDFBookmarkDisplayStyle DisplayStyle {get; set;}
public: __property PDFBookmarkDisplayStyle get_DisplayStyle();
public: __property void set_DisplayStyle(
   PDFBookmarkDisplayStyle value
);
public:
property PDFBookmarkDisplayStyle DisplayStyle {
   PDFBookmarkDisplayStyle get();
   void set (    PDFBookmarkDisplayStyle value);
}

Property Value

The bookmark's display style.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%ItemTitle%%

Document Property (PDFBookmark)

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : Document Property
Gets or sets the document this bookmark belongs to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Document As PDFDocument
'Usage

Dim instance As PDFBookmark
Dim value As PDFDocument

value = instance.Document
public PDFDocument Document {get;}
public: __property PDFDocument* get_Document();
public:
property PDFDocument^ Document {
   PDFDocument^ get();
}

Property Value

The document that contains this bookmark.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%ItemTitle%%

Expanded Property

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : Expanded Property
Gets or sets a value indicating whether the bookmark should be displayed in collapsed or expanded state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Expanded As Boolean
'Usage

Dim instance As PDFBookmark
Dim value As Boolean

instance.Expanded = value

value = instance.Expanded
public bool Expanded {get; set;}
public: __property bool get_Expanded();
public: __property void set_Expanded(
   bool value
);
public:
property bool Expanded {
   bool get();
   void set (    bool value);
}

Property Value

True if the bookmark should be displayed in expanded state, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%ItemTitle%%

Parent Property (PDFBookmark)

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : Parent Property
Gets the parent of this PDFBookmark object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As PDFBookmark
'Usage

Dim instance As PDFBookmark
Dim value As PDFBookmark

value = instance.Parent
public PDFBookmark Parent {get;}
public: __property PDFBookmark* get_Parent();
public:
property PDFBookmark^ Parent {
   PDFBookmark^ get();
}

Property Value

The parent bookmark.
Remarks
If the parent bookmark is null, the bookmark is a top level bookmark.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%ItemTitle%%

Title Property (PDFBookmark)

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : Title Property
Gets or sets the title of this bookmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As PDFBookmark
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

The bookmark title.
Remarks
The title is displayed by the viewer application in the bookmarks tree.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%PageItemTitle%%

PDFBookmarkCollection Class
Members

O2S.Components.PDFView4NET Namespace : PDFBookmarkCollection Class
Defines a collection of bookmarks.
Object Model
PDFBookmarkCollection ClassPDFBookmark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFBookmarkCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFBookmark,PDFBookmark)
'Usage

Dim instance As PDFBookmarkCollection
public class PDFBookmarkCollection : O2S.Components.PDFView4NET.PDFCollection<PDFBookmark,PDFBookmark>
public __gc class PDFBookmarkCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFBookmark,PDFBookmark>
public ref class PDFBookmarkCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFBookmark,PDFBookmark>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.PDFBookmarkCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarkCollection Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFBookmarkCollection Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFBookmarkCollection Class

The following tables list the members exposed by PDFBookmarkCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFBookmark,PDFBookmark>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top
See Also

Reference

PDFBookmarkCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFBookmarksView Class
Members

O2S.Components.PDFView4NET Namespace : PDFBookmarksView Class
Defines a viewer for the bookmarks in a PDF file.
Object Model
PDFBookmarksView ClassPDFDocument ClassPDFPageView ClassPDFBookmark Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class PDFBookmarksView
   Inherits System.Windows.Forms.TreeView
'Usage

Dim instance As PDFBookmarksView
[ToolboxBitmap()]
public class PDFBookmarksView : System.Windows.Forms.TreeView
[ToolboxBitmap()]
public __gc class PDFBookmarksView : public System.Windows.Forms.TreeView
[ToolboxBitmap()]
public ref class PDFBookmarksView : public System.Windows.Forms.TreeView
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TreeView
O2S.Components.PDFView4NET.PDFBookmarksView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksView Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFBookmarksView Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFBookmarksView Class

The following tables list the members exposed by PDFBookmarksView.

Public Constructors
 | Name | Description
Public Constructor | PDFBookmarksView Constructor |
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | (Inherited from System.Windows.Forms.TreeView)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the PDF document for which the bookmarks are displayed.
Public Property | DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from System.Windows.Forms.TreeView)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from System.Windows.Forms.TreeView)
Public Property | FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from System.Windows.Forms.TreeView)
Public Property | HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageKey | Gets or sets the key of the default image for each node in the System.Windows.Forms.TreeView control when it is in an unselected state. (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageList | Gets or sets the System.Windows.Forms.ImageList that contains the System.Drawing.Image objects that are used by the tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Indent | Gets or sets the distance to indent each child tree node level. (Inherited from System.Windows.Forms.TreeView)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from System.Windows.Forms.TreeView)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LineColor | Gets or sets the color of the lines connecting the nodes of the System.Windows.Forms.TreeView control. (Inherited from System.Windows.Forms.TreeView)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | PageView | Gets or sets the pages viewer control that represents the target for the bookmarks in the document.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from System.Windows.Forms.TreeView)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | Gets or sets a value that indicates whether the System.Windows.Forms.TreeView should be laid out from right-to-left. (Inherited from System.Windows.Forms.TreeView)
Public Property | Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedBookmark | Gets the selected bookmark.
Public Property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedImageKey | Gets or sets the key of the default image shown when a System.Windows.Forms.TreeNode is in a selected state. (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a System.Windows.Forms.TreeNode. (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from System.Windows.Forms.TreeView)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | StateImageList | Gets or sets the image list that is used to indicate the state of the System.Windows.Forms.TreeView and its nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | TreeViewNodeSorter | Gets or sets the implementation of System.Collections.IComparer to perform a custom sort of the System.Windows.Forms.TreeView nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top
Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | Disables any redrawing of the tree view. (Inherited from System.Windows.Forms.TreeView)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | CollapseAll | Collapses all the tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | Enables the redrawing of the tree view. (Inherited from System.Windows.Forms.TreeView)
Public Method | ExpandAll | Expands all the tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetNodeAt | Overloaded. Retrieves the tree node that is at the specified point. (Inherited from System.Windows.Forms.TreeView)
Public Method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | HitTest | Overloaded. Provides node information, given a point. (Inherited from System.Windows.Forms.TreeView)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | Sort | Sorts the items in System.Windows.Forms.TreeView control. (Inherited from System.Windows.Forms.TreeView)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Overrides System.ComponentModel.Component.ToString. (Inherited from System.Windows.Forms.TreeView)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top
Public Events
 | Name | Description
Public Event | AfterCheck | Occurs after the tree node check box is checked. (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterCollapse | Occurs after the tree node is collapsed. (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterExpand | Occurs after the tree node is expanded. (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterSelect | Occurs after the tree node is selected. (Inherited from System.Windows.Forms.TreeView)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BeforeCheck | Occurs before the tree node check box is checked. (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeExpand | Occurs before the tree node is expanded. (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeSelect | Occurs before the tree node is selected. (Inherited from System.Windows.Forms.TreeView)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BookmarkClick | Gets or sets the event that is fired when a bookmark is clicked with the mouse.
Public Event | BookmarkDoubleClick | Gets or sets the event that is fired when a bookmark is double clicked with the mouse.
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DrawNode | Occurs when a System.Windows.Forms.TreeView is drawn and the System.Windows.Forms.TreeView.DrawMode property is set to a System.Windows.Forms.TreeViewDrawMode value other than System.Windows.Forms.TreeViewDrawMode.Normal. (Inherited from System.Windows.Forms.TreeView)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | ItemDrag | Occurs when the user begins dragging a node. (Inherited from System.Windows.Forms.TreeView)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | NodeMouseClick | Occurs when the user clicks a System.Windows.Forms.TreeNode with the mouse. (Inherited from System.Windows.Forms.TreeView)
Public Event | NodeMouseDoubleClick | Occurs when the user double-clicks a System.Windows.Forms.TreeNode with the mouse. (Inherited from System.Windows.Forms.TreeView)
Public Event | NodeMouseHover | Occurs when the mouse hovers over a System.Windows.Forms.TreeNode. (Inherited from System.Windows.Forms.TreeView)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | Occurs when the value of the System.Windows.Forms.TreeView.RightToLeftLayout property changes. (Inherited from System.Windows.Forms.TreeView)
Public Event | SelectedBookmarkChanged | Gets or sets the event that is fired when the selected bookmark is changed.
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFBookmarksView Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFBookmarksView Constructor

O2S.Components.PDFView4NET Namespace > PDFBookmarksView Class : PDFBookmarksView Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFBookmarksView()
public PDFBookmarksView()
public: PDFBookmarksView();
public:
PDFBookmarksView();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksView Class
PDFBookmarksView Members


%%PageItemTitle%% $$Properties$$

PDFBookmarksView Class Properties

O2S.Components.PDFView4NET Namespace : PDFBookmarksView Class

For a list of all members of this type, see PDFBookmarksView members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | (Inherited from System.Windows.Forms.TreeView)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the PDF document for which the bookmarks are displayed.
Public Property | DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from System.Windows.Forms.TreeView)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from System.Windows.Forms.TreeView)
Public Property | FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from System.Windows.Forms.TreeView)
Public Property | HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageKey | Gets or sets the key of the default image for each node in the System.Windows.Forms.TreeView control when it is in an unselected state. (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageList | Gets or sets the System.Windows.Forms.ImageList that contains the System.Drawing.Image objects that are used by the tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Indent | Gets or sets the distance to indent each child tree node level. (Inherited from System.Windows.Forms.TreeView)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from System.Windows.Forms.TreeView)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LineColor | Gets or sets the color of the lines connecting the nodes of the System.Windows.Forms.TreeView control. (Inherited from System.Windows.Forms.TreeView)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | PageView | Gets or sets the pages viewer control that represents the target for the bookmarks in the document.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from System.Windows.Forms.TreeView)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | Gets or sets a value that indicates whether the System.Windows.Forms.TreeView should be laid out from right-to-left. (Inherited from System.Windows.Forms.TreeView)
Public Property | Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedBookmark | Gets the selected bookmark.
Public Property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedImageKey | Gets or sets the key of the default image shown when a System.Windows.Forms.TreeNode is in a selected state. (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a System.Windows.Forms.TreeNode. (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from System.Windows.Forms.TreeView)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | StateImageList | Gets or sets the image list that is used to indicate the state of the System.Windows.Forms.TreeView and its nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | TreeViewNodeSorter | Gets or sets the implementation of System.Collections.IComparer to perform a custom sort of the System.Windows.Forms.TreeView nodes. (Inherited from System.Windows.Forms.TreeView)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFBookmarksView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Document Property (PDFBookmarksView)

O2S.Components.PDFView4NET Namespace > PDFBookmarksView Class : Document Property
Gets or sets the PDF document for which the bookmarks are displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The document for which the bookmarks are displayed")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
Public Property Document As PDFDocument
'Usage

Dim instance As PDFBookmarksView
Dim value As PDFDocument

instance.Document = value

value = instance.Document
[Description("The document for which the bookmarks are displayed")]
[DefaultValue()]
[Category("PDF")]
public PDFDocument Document {get; set;}
[Description("The document for which the bookmarks are displayed")]
[DefaultValue()]
[Category("PDF")]
public: __property PDFDocument* get_Document();
public: __property void set_Document(
   PDFDocument* value
);
[Description("The document for which the bookmarks are displayed")]
[DefaultValue()]
[Category("PDF")]
public:
property PDFDocument^ Document {
   PDFDocument^ get();
   void set (    PDFDocument^ value);
}

Property Value

A PDFDocument object specifying the document for which the bookmarks are displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksView Class
PDFBookmarksView Members


%%ItemTitle%%

PageView Property (PDFBookmarksView)

O2S.Components.PDFView4NET Namespace > PDFBookmarksView Class : PageView Property
Gets or sets the pages viewer control that represents the target for the bookmarks in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The page viewer control where the bookmark destinations are displayed")>
<CategoryAttribute("PDF")>
<DefaultValueAttribute()>
Public Property PageView As PDFPageView
'Usage

Dim instance As PDFBookmarksView
Dim value As PDFPageView

instance.PageView = value

value = instance.PageView
[Description("The page viewer control where the bookmark destinations are displayed")]
[Category("PDF")]
[DefaultValue()]
public PDFPageView PageView {get; set;}
[Description("The page viewer control where the bookmark destinations are displayed")]
[Category("PDF")]
[DefaultValue()]
public: __property PDFPageView* get_PageView();
public: __property void set_PageView(
   PDFPageView* value
);
[Description("The page viewer control where the bookmark destinations are displayed")]
[Category("PDF")]
[DefaultValue()]
public:
property PDFPageView^ PageView {
   PDFPageView^ get();
   void set (    PDFPageView^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksView Class
PDFBookmarksView Members


%%ItemTitle%%

SelectedBookmark Property

O2S.Components.PDFView4NET Namespace > PDFBookmarksView Class : SelectedBookmark Property
Gets the selected bookmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property SelectedBookmark As PDFBookmark
'Usage

Dim instance As PDFBookmarksView
Dim value As PDFBookmark

value = instance.SelectedBookmark
[Browsable(false)]
public PDFBookmark SelectedBookmark {get;}
[Browsable(false)]
public: __property PDFBookmark* get_SelectedBookmark();
[Browsable(false)]
public:
property PDFBookmark^ SelectedBookmark {
   PDFBookmark^ get();
}

Property Value

The bookmark currently selected in the tree.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksView Class
PDFBookmarksView Members


%%PageItemTitle%% $$Events$$

PDFBookmarksView Class Events

O2S.Components.PDFView4NET Namespace : PDFBookmarksView Class

For a list of all members of this type, see PDFBookmarksView members.

Public Events
 | Name | Description
Public Event | AfterCheck | Occurs after the tree node check box is checked. (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterCollapse | Occurs after the tree node is collapsed. (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterExpand | Occurs after the tree node is expanded. (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterSelect | Occurs after the tree node is selected. (Inherited from System.Windows.Forms.TreeView)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BeforeCheck | Occurs before the tree node check box is checked. (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeExpand | Occurs before the tree node is expanded. (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeSelect | Occurs before the tree node is selected. (Inherited from System.Windows.Forms.TreeView)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BookmarkClick | Gets or sets the event that is fired when a bookmark is clicked with the mouse.
Public Event | BookmarkDoubleClick | Gets or sets the event that is fired when a bookmark is double clicked with the mouse.
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DrawNode | Occurs when a System.Windows.Forms.TreeView is drawn and the System.Windows.Forms.TreeView.DrawMode property is set to a System.Windows.Forms.TreeViewDrawMode value other than System.Windows.Forms.TreeViewDrawMode.Normal. (Inherited from System.Windows.Forms.TreeView)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | ItemDrag | Occurs when the user begins dragging a node. (Inherited from System.Windows.Forms.TreeView)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | NodeMouseClick | Occurs when the user clicks a System.Windows.Forms.TreeNode with the mouse. (Inherited from System.Windows.Forms.TreeView)
Public Event | NodeMouseDoubleClick | Occurs when the user double-clicks a System.Windows.Forms.TreeNode with the mouse. (Inherited from System.Windows.Forms.TreeView)
Public Event | NodeMouseHover | Occurs when the mouse hovers over a System.Windows.Forms.TreeNode. (Inherited from System.Windows.Forms.TreeView)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | Occurs when the value of the System.Windows.Forms.TreeView.RightToLeftLayout property changes. (Inherited from System.Windows.Forms.TreeView)
Public Event | SelectedBookmarkChanged | Gets or sets the event that is fired when the selected bookmark is changed.
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFBookmarksView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

BookmarkClick Event

O2S.Components.PDFView4NET Namespace > PDFBookmarksView Class : BookmarkClick Event
Gets or sets the event that is fired when a bookmark is clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DefaultValueAttribute()>
<DescriptionAttribute("The event that is fired when the bookmark is clicked")>
Public Event BookmarkClick As EventHandler(Of BookmarkClickEventArgs)
'Usage

Dim instance As PDFBookmarksView
Dim handler As EventHandler(Of BookmarkClickEventArgs)

AddHandler instance.BookmarkClick, handler
[Category("PDF")]
[DefaultValue()]
[Description("The event that is fired when the bookmark is clicked")]
public event EventHandler<BookmarkClickEventArgs> BookmarkClick
[Category("PDF")]
[DefaultValue()]
[Description("The event that is fired when the bookmark is clicked")]
public: __event EventHandler<BookmarkClickEventArgs*>* BookmarkClick
[Category("PDF")]
[DefaultValue()]
[Description("The event that is fired when the bookmark is clicked")]
public:
event EventHandler<BookmarkClickEventArgs^>^ BookmarkClick
Event Data

The event handler receives an argument of type BookmarkClickEventArgs containing data related to this event. The following BookmarkClickEventArgs properties provide information specific to this event.

Property | Description
Bookmark | Gets the bookmark that has been clicked.
Location | Gets the location of the mouse during the generating mouse event.
MouseButton | Gets the mouse button that was clicked on the bookmark.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksView Class
PDFBookmarksView Members


%%ItemTitle%%

BookmarkDoubleClick Event

O2S.Components.PDFView4NET Namespace > PDFBookmarksView Class : BookmarkDoubleClick Event
Gets or sets the event that is fired when a bookmark is double clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
<DescriptionAttribute("The event that is fired when the bookmark is double clicked")>
Public Event BookmarkDoubleClick As EventHandler(Of BookmarkClickEventArgs)
'Usage

Dim instance As PDFBookmarksView
Dim handler As EventHandler(Of BookmarkClickEventArgs)

AddHandler instance.BookmarkDoubleClick, handler
[DefaultValue()]
[Category("PDF")]
[Description("The event that is fired when the bookmark is double clicked")]
public event EventHandler<BookmarkClickEventArgs> BookmarkDoubleClick
[DefaultValue()]
[Category("PDF")]
[Description("The event that is fired when the bookmark is double clicked")]
public: __event EventHandler<BookmarkClickEventArgs*>* BookmarkDoubleClick
[DefaultValue()]
[Category("PDF")]
[Description("The event that is fired when the bookmark is double clicked")]
public:
event EventHandler<BookmarkClickEventArgs^>^ BookmarkDoubleClick
Event Data

The event handler receives an argument of type BookmarkClickEventArgs containing data related to this event. The following BookmarkClickEventArgs properties provide information specific to this event.

Property | Description
Bookmark | Gets the bookmark that has been clicked.
Location | Gets the location of the mouse during the generating mouse event.
MouseButton | Gets the mouse button that was clicked on the bookmark.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksView Class
PDFBookmarksView Members


%%ItemTitle%%

SelectedBookmarkChanged Event

O2S.Components.PDFView4NET Namespace > PDFBookmarksView Class : SelectedBookmarkChanged Event
Gets or sets the event that is fired when the selected bookmark is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DefaultValueAttribute()>
<DescriptionAttribute("The event that is fired when the selected bookmark changes")>
Public Event SelectedBookmarkChanged As EventHandler
'Usage

Dim instance As PDFBookmarksView
Dim handler As EventHandler

AddHandler instance.SelectedBookmarkChanged, handler
[Category("PDF")]
[DefaultValue()]
[Description("The event that is fired when the selected bookmark changes")]
public event EventHandler SelectedBookmarkChanged
[Category("PDF")]
[DefaultValue()]
[Description("The event that is fired when the selected bookmark changes")]
public: __event EventHandler* SelectedBookmarkChanged
[Category("PDF")]
[DefaultValue()]
[Description("The event that is fired when the selected bookmark changes")]
public:
event EventHandler^ SelectedBookmarkChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksView Class
PDFBookmarksView Members


%%PageItemTitle%%

PDFBookmarksViewCollection Class
Members

O2S.Components.PDFView4NET Namespace : PDFBookmarksViewCollection Class
Defines a collection of PDFBookmarksView objects representing the viewers for a document's bookmarks.
Object Model
PDFBookmarksViewCollection ClassPDFBookmarksView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFBookmarksViewCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFBookmarksView,PDFDocument)
'Usage

Dim instance As PDFBookmarksViewCollection
public class PDFBookmarksViewCollection : O2S.Components.PDFView4NET.PDFCollection<PDFBookmarksView,PDFDocument>
public __gc class PDFBookmarksViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFBookmarksView,PDFDocument>
public ref class PDFBookmarksViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFBookmarksView,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.PDFBookmarksViewCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksViewCollection Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFBookmarksViewCollection Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFBookmarksViewCollection Class

The following tables list the members exposed by PDFBookmarksViewCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFBookmarksView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Top
See Also

Reference

PDFBookmarksViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFCollection<T,K> Class
Members

O2S.Components.PDFView4NET Namespace : PDFCollection<T,K> Class
The type of the collection items.
The type of the collection parent.
Defines a collection that fires notifications when it changes or when an item in the collection changes its properties.
Object Model
PDFCollection<T,K> Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCollection
    (Of T,K)
   Inherits System.Collections.ObjectModel.Collection(Of T)
'Usage

Dim instance As PDFCollection(Of T,K)
public class PDFCollection<T,K> : System.Collections.ObjectModel.Collection<T>
public __gc class PDFCollection<T,K> : public System.Collections.ObjectModel.Collection<T>
generic<typename T>
generic<typename K>
public ref class PDFCollection : public System.Collections.ObjectModel.Collection<T>
Type Parameters
T
The type of the collection items.
K
The type of the collection parent.
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Actions.PDFActionCollection
O2S.Components.PDFView4NET.Annotations.PDFAnnotationCollection
O2S.Components.PDFView4NET.Annotations.PDFAnnotationReplyCollection
O2S.Components.PDFView4NET.Annotations.PDFPointsCollection
O2S.Components.PDFView4NET.Forms.FDFFieldCollection
O2S.Components.PDFView4NET.Forms.PDFFieldCollection
O2S.Components.PDFView4NET.Forms.PDFFieldWidgetCollection
O2S.Components.PDFView4NET.Forms.PDFListItemCollection
O2S.Components.PDFView4NET.Forms.XFDFFieldCollection
O2S.Components.PDFView4NET.PDFAnnotationsViewCollection
O2S.Components.PDFView4NET.PDFBookmarkCollection
O2S.Components.PDFView4NET.PDFBookmarksViewCollection
O2S.Components.PDFView4NET.PDFFileAttachmentCollection
O2S.Components.PDFView4NET.PDFFileAttachmentsViewCollection
O2S.Components.PDFView4NET.PDFNamedDestinationCollection
O2S.Components.PDFView4NET.PDFPageCollection
O2S.Components.PDFView4NET.PDFPageThumbnailViewCollection
O2S.Components.PDFView4NET.PDFPageViewCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollection<T,K> Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFCollection<T,K> Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFCollection<T,K> Class

The following tables list the members exposed by PDFCollection<T,K>.

Public Constructors
 | Name | Description
Public Constructor | PDFCollection<T,K> Constructor | Initializes a new PDFCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

PDFCollection<T,K> Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFCollection<T,K> Constructor

O2S.Components.PDFView4NET Namespace > PDFCollection<T,K> Class : PDFCollection<T,K> Constructor
The object that owns the collection.
Initializes a new PDFCollection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal parent As K _
)
'Usage

Dim parent As K

Dim instance As New PDFCollection(Of T,K)(parent)
public PDFCollection<T,K>(
   K parent
)
public: PDFCollection<T,K>(
   K* parent
)
public:
PDFCollection<T,K>(
   K^ parent
)

Parameters

parent
The object that owns the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollection<T,K> Class
PDFCollection<T,K> Members


%%PageItemTitle%% $$Methods$$

PDFCollection<T,K> Class Methods

O2S.Components.PDFView4NET Namespace : PDFCollection<T,K> Class

For a list of all members of this type, see PDFCollection<T,K> members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

PDFCollection<T,K> Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

MoveItem Method (PDFCollection<T,K>)

O2S.Components.PDFView4NET Namespace > PDFCollection<T,K> Class : MoveItem Method
Item to move.
Number of positions to move.
Moves the item up or down to the beginning or end of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function MoveItem( _
   ByVal item As T, _
   ByVal step As Integer _
) As Boolean
'Usage

Dim instance As PDFCollection(Of T,K)
Dim item As T
Dim step As Integer
Dim value As Boolean

value = instance.MoveItem(item, step)
public virtual bool MoveItem(
   T item,
   int step
)
public: virtual bool MoveItem(
   T* item,
   int step
)
public:
virtual bool MoveItem(
   T^ item,
   int step
)

Parameters

item
Item to move.
step
Number of positions to move.

Return Value

True if the item has been moved.
Remarks
It the new position is outside the collection, the item is not moved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollection<T,K> Class
PDFCollection<T,K> Members


%%PageItemTitle%%

PDFCollectionChangedEventArgs<T> Class
Members

O2S.Components.PDFView4NET Namespace : PDFCollectionChangedEventArgs<T> Class
Type of the items in the collection.
Defines the event arguments for the collection changed event.
Object Model
PDFCollectionChangedEventArgs<T> Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCollectionChangedEventArgs(Of T)
   Inherits System.EventArgs
'Usage

Dim instance As PDFCollectionChangedEventArgs(Of T)
public class PDFCollectionChangedEventArgs<T> : System.EventArgs
public __gc class PDFCollectionChangedEventArgs<T> : public System.EventArgs
generic<typename T>
public ref class PDFCollectionChangedEventArgs : public System.EventArgs
Type Parameters
T
Type of the items in the collection.
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.PDFCollectionChangedEventArgs<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFCollectionChangedEventArgs<T> Class Members
Properties

O2S.Components.PDFView4NET Namespace : PDFCollectionChangedEventArgs<T> Class

The following tables list the members exposed by PDFCollectionChangedEventArgs<T>.

Public Constructors
 | Name | Description
Public Constructor | PDFCollectionChangedEventArgs<T> Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ChangedProperty | Gets the name of changed property when the change type is item update.
Public Property | ChangeType | Gets the type of change event.
Public Property | NewItem | Gets the new item involved in the operation.
Public Property | OldItem | Gets the old item involved in the operation.
Public Property | Position | Gets the position of the affected item in the collection.
Top
See Also

Reference

PDFCollectionChangedEventArgs<T> Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFCollectionChangedEventArgs<T> Constructor

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class : PDFCollectionChangedEventArgs<T> Constructor
Overload List
Overload | Description
PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T) | Initializes a new PDFCollectionChangedEventArgs object.
PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T,Int32) | Initializes a new PDFCollectionChangedEventArgs object.
PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T,String) | Initializes a new PDFCollectionChangedEventArgs object.
PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T,String,Int32) | Initializes a new PDFCollectionChangedEventArgs object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members


%%PageItemTitle%%

PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T)

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class > PDFCollectionChangedEventArgs<T> Constructor : PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T)
The type of change.
Old item involved in the operation
New item involved in the operation.
Initializes a new PDFCollectionChangedEventArgs object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal changeType As ChangeType, _
   ByVal oldItem As T, _
   ByVal newItem As T _
)
'Usage

Dim changeType As ChangeType
Dim oldItem As T
Dim newItem As T

Dim instance As New PDFCollectionChangedEventArgs(Of T)(changeType, oldItem, newItem)
public PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T oldItem,
   T newItem
)
public: PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T* oldItem,
   T* newItem
)
public:
PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T^ oldItem,
   T^ newItem
)

Parameters

changeType
The type of change.
oldItem
Old item involved in the operation
newItem
New item involved in the operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members
Overload List


%%PageItemTitle%%

PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T,Int32)

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class > PDFCollectionChangedEventArgs<T> Constructor : PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T,Int32)
The type of change.
Old item involved in the operation
New item involved in the operation.
Position of the item in the collection.
Initializes a new PDFCollectionChangedEventArgs object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal changeType As ChangeType, _
   ByVal oldItem As T, _
   ByVal newItem As T, _
   ByVal position As Integer _
)
'Usage

Dim changeType As ChangeType
Dim oldItem As T
Dim newItem As T
Dim position As Integer

Dim instance As New PDFCollectionChangedEventArgs(Of T)(changeType, oldItem, newItem, position)
public PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T oldItem,
   T newItem,
   int position
)
public: PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T* oldItem,
   T* newItem,
   int position
)
public:
PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T^ oldItem,
   T^ newItem,
   int position
)

Parameters

changeType
The type of change.
oldItem
Old item involved in the operation
newItem
New item involved in the operation.
position
Position of the item in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members
Overload List


%%PageItemTitle%%

PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T,String)

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class > PDFCollectionChangedEventArgs<T> Constructor : PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T,String)
The type of change.
Old item involved in the operation
New item involved in the operation.
The name of the property that has changed.
Initializes a new PDFCollectionChangedEventArgs object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal changeType As ChangeType, _
   ByVal oldItem As T, _
   ByVal newItem As T, _
   ByVal changedProperty As String _
)
'Usage

Dim changeType As ChangeType
Dim oldItem As T
Dim newItem As T
Dim changedProperty As String

Dim instance As New PDFCollectionChangedEventArgs(Of T)(changeType, oldItem, newItem, changedProperty)
public PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T oldItem,
   T newItem,
   string changedProperty
)
public: PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T* oldItem,
   T* newItem,
   string* changedProperty
)
public:
PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T^ oldItem,
   T^ newItem,
   String^ changedProperty
)

Parameters

changeType
The type of change.
oldItem
Old item involved in the operation
newItem
New item involved in the operation.
changedProperty
The name of the property that has changed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members
Overload List


%%PageItemTitle%%

PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T,String,Int32)

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class > PDFCollectionChangedEventArgs<T> Constructor : PDFCollectionChangedEventArgs<T> Constructor(ChangeType,T,T,String,Int32)
The type of change.
Old item involved in the operation
New item involved in the operation.
The name of the property that has changed.
Position of the item in the collection.
Initializes a new PDFCollectionChangedEventArgs object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal changeType As ChangeType, _
   ByVal oldItem As T, _
   ByVal newItem As T, _
   ByVal changedProperty As String, _
   ByVal position As Integer _
)
'Usage

Dim changeType As ChangeType
Dim oldItem As T
Dim newItem As T
Dim changedProperty As String
Dim position As Integer

Dim instance As New PDFCollectionChangedEventArgs(Of T)(changeType, oldItem, newItem, changedProperty, position)
public PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T oldItem,
   T newItem,
   string changedProperty,
   int position
)
public: PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T* oldItem,
   T* newItem,
   string* changedProperty,
   int position
)
public:
PDFCollectionChangedEventArgs<T>(
   ChangeType changeType,
   T^ oldItem,
   T^ newItem,
   String^ changedProperty,
   int position
)

Parameters

changeType
The type of change.
oldItem
Old item involved in the operation
newItem
New item involved in the operation.
changedProperty
The name of the property that has changed.
position
Position of the item in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFCollectionChangedEventArgs<T> Class Properties

O2S.Components.PDFView4NET Namespace : PDFCollectionChangedEventArgs<T> Class

For a list of all members of this type, see PDFCollectionChangedEventArgs<T> members.

Public Properties
 | Name | Description
Public Property | ChangedProperty | Gets the name of changed property when the change type is item update.
Public Property | ChangeType | Gets the type of change event.
Public Property | NewItem | Gets the new item involved in the operation.
Public Property | OldItem | Gets the old item involved in the operation.
Public Property | Position | Gets the position of the affected item in the collection.
Top
See Also

Reference

PDFCollectionChangedEventArgs<T> Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

ChangedProperty Property

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class : ChangedProperty Property
Gets the name of changed property when the change type is item update.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ChangedProperty As String
'Usage

Dim instance As PDFCollectionChangedEventArgs(Of T)
Dim value As String

value = instance.ChangedProperty
public string ChangedProperty {get;}
public: __property string* get_ChangedProperty();
public:
property String^ ChangedProperty {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members


%%ItemTitle%%

ChangeType Property

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class : ChangeType Property
Gets the type of change event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ChangeType As ChangeType
'Usage

Dim instance As PDFCollectionChangedEventArgs(Of T)
Dim value As ChangeType

value = instance.ChangeType
public ChangeType ChangeType {get;}
public: __property ChangeType get_ChangeType();
public:
property ChangeType ChangeType {
   ChangeType get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members


%%ItemTitle%%

NewItem Property

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class : NewItem Property
Gets the new item involved in the operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NewItem As T
'Usage

Dim instance As PDFCollectionChangedEventArgs(Of T)
Dim value As T

value = instance.NewItem
public T NewItem {get;}
public: __property T* get_NewItem();
public:
property T^ NewItem {
   T^ get();
}
Remarks
This property is null for Remove, ItemUpdate or Clear operations, and it is the item being Added, Inserted or the Replacement
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members


%%ItemTitle%%

OldItem Property

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class : OldItem Property
Gets the old item involved in the operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OldItem As T
'Usage

Dim instance As PDFCollectionChangedEventArgs(Of T)
Dim value As T

value = instance.OldItem
public T OldItem {get;}
public: __property T* get_OldItem();
public:
property T^ OldItem {
   T^ get();
}
Remarks
This property is null for Add, Insert or Clear operations, and it is the item being Removed, Replaced or Updated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members


%%ItemTitle%%

Position Property

O2S.Components.PDFView4NET Namespace > PDFCollectionChangedEventArgs<T> Class : Position Property
Gets the position of the affected item in the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Position As Integer
'Usage

Dim instance As PDFCollectionChangedEventArgs(Of T)
Dim value As Integer

value = instance.Position
public int Position {get;}
public: __property int get_Position();
public:
property int Position {
   int get();
}
Remarks
For removed or replaced items, this property returns the position of the item in the collection before being removed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCollectionChangedEventArgs<T> Class
PDFCollectionChangedEventArgs<T> Members


%%PageItemTitle%%

PDFDestination Class
Members

O2S.Components.PDFView4NET Namespace : PDFDestination Class
Defines the base class for PDF destinations.
Object Model
PDFDestination Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFDestination
'Usage

Dim instance As PDFDestination
public abstract class PDFDestination
public __gc abstract class PDFDestination
public ref class PDFDestination abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFDestination
O2S.Components.PDFView4NET.PDFDirectDestination
O2S.Components.PDFView4NET.PDFNamedDestination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDestination Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDestination Class Members

O2S.Components.PDFView4NET Namespace : PDFDestination Class

The following tables list the members exposed by PDFDestination.

See Also

Reference

PDFDestination Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFDigitalSignature Class
Members

O2S.Components.PDFView4NET Namespace : PDFDigitalSignature Class
Defines a digital signature used for signing a PDF file.
Object Model
PDFDigitalSignature Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDigitalSignature
'Usage

Dim instance As PDFDigitalSignature
public class PDFDigitalSignature
public __gc class PDFDigitalSignature
public ref class PDFDigitalSignature
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFDigitalSignature

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDigitalSignature Class Members
Properties

O2S.Components.PDFView4NET Namespace : PDFDigitalSignature Class

The following tables list the members exposed by PDFDigitalSignature.

Public Constructors
 | Name | Description
Public Constructor | PDFDigitalSignature Constructor | Initializes a new PDFDigitalSignature object.
Top
Public Properties
 | Name | Description
Public Property | Certificate | Gets or sets the certificate for signing the PDF document.
Public Property | ContactInfo | Gets or sets the signer's contact information.
Public Property | Location | Gets or sets the location of the signer.
Public Property | Name | Gets or sets the name of the signer.
Public Property | Reason | Gets or sets the reason for signing the document.
Top
See Also

Reference

PDFDigitalSignature Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFDigitalSignature Constructor

O2S.Components.PDFView4NET Namespace > PDFDigitalSignature Class : PDFDigitalSignature Constructor
Initializes a new PDFDigitalSignature object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDigitalSignature()
public PDFDigitalSignature()
public: PDFDigitalSignature();
public:
PDFDigitalSignature();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%% $$Properties$$

PDFDigitalSignature Class Properties

O2S.Components.PDFView4NET Namespace : PDFDigitalSignature Class

For a list of all members of this type, see PDFDigitalSignature members.

Public Properties
 | Name | Description
Public Property | Certificate | Gets or sets the certificate for signing the PDF document.
Public Property | ContactInfo | Gets or sets the signer's contact information.
Public Property | Location | Gets or sets the location of the signer.
Public Property | Name | Gets or sets the name of the signer.
Public Property | Reason | Gets or sets the reason for signing the document.
Top
See Also

Reference

PDFDigitalSignature Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Certificate Property

O2S.Components.PDFView4NET Namespace > PDFDigitalSignature Class : Certificate Property
Gets or sets the certificate for signing the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Certificate As X509Certificate2
'Usage

Dim instance As PDFDigitalSignature
Dim value As X509Certificate2

instance.Certificate = value

value = instance.Certificate
public X509Certificate2 Certificate {get; set;}
public: __property X509Certificate2* get_Certificate();
public: __property void set_Certificate(
   X509Certificate2* value
);
public:
property X509Certificate2^ Certificate {
   X509Certificate2^ get();
   void set (    X509Certificate2^ value);
}

Property Value

A System.Security.Cryptography.X509Certificates.X509Certificate2 object specifying the certificate for signing.
Remarks
This property also sets the Name property to the name in the certificate.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%ItemTitle%%

ContactInfo Property

O2S.Components.PDFView4NET Namespace > PDFDigitalSignature Class : ContactInfo Property
Gets or sets the signer's contact information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContactInfo As String
'Usage

Dim instance As PDFDigitalSignature
Dim value As String

instance.ContactInfo = value

value = instance.ContactInfo
public string ContactInfo {get; set;}
public: __property string* get_ContactInfo();
public: __property void set_ContactInfo(
   string* value
);
public:
property String^ ContactInfo {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the signer's contact information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%ItemTitle%%

Location Property (PDFDigitalSignature)

O2S.Components.PDFView4NET Namespace > PDFDigitalSignature Class : Location Property
Gets or sets the location of the signer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Location As String
'Usage

Dim instance As PDFDigitalSignature
Dim value As String

instance.Location = value

value = instance.Location
public string Location {get; set;}
public: __property string* get_Location();
public: __property void set_Location(
   string* value
);
public:
property String^ Location {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the location of the signer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%ItemTitle%%

Name Property (PDFDigitalSignature)

O2S.Components.PDFView4NET Namespace > PDFDigitalSignature Class : Name Property
Gets or sets the name of the signer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFDigitalSignature
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the name of the signer.
Remarks
The Certificate property overwrites the value of this property with the name stored in the certificate. If you want to set the Name to another value, set this property after the Certificate property has been set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%ItemTitle%%

Reason Property

O2S.Components.PDFView4NET Namespace > PDFDigitalSignature Class : Reason Property
Gets or sets the reason for signing the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Reason As String
'Usage

Dim instance As PDFDigitalSignature
Dim value As String

instance.Reason = value

value = instance.Reason
public string Reason {get; set;}
public: __property string* get_Reason();
public: __property void set_Reason(
   string* value
);
public:
property String^ Reason {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the reason for signing the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%%

PDFDirectDestination Class
Members

O2S.Components.PDFView4NET Namespace : PDFDirectDestination Class
Defines the base class direct PDF destinations.
Object Model
PDFDirectDestination Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDirectDestination
   Inherits PDFDestination
'Usage

Dim instance As PDFDirectDestination
public class PDFDirectDestination : PDFDestination
public __gc class PDFDirectDestination : public PDFDestination
public ref class PDFDirectDestination : public PDFDestination
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFDestination
O2S.Components.PDFView4NET.PDFDirectDestination
O2S.Components.PDFView4NET.PDFPageDestination
O2S.Components.PDFView4NET.PDFRemotePageDestination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDirectDestination Class Members
Properties

O2S.Components.PDFView4NET Namespace : PDFDirectDestination Class

The following tables list the members exposed by PDFDirectDestination.

Public Constructors
 | Name | Description
Public Constructor | PDFDirectDestination Constructor | Initializes a new PDFDirectDestination object.
Top
Public Properties
 | Name | Description
Public Property | ZoomMode | Gets or sets the zoom mode.
Top
See Also

Reference

PDFDirectDestination Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFDirectDestination Constructor

O2S.Components.PDFView4NET Namespace > PDFDirectDestination Class : PDFDirectDestination Constructor
Initializes a new PDFDirectDestination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDirectDestination()
public PDFDirectDestination()
public: PDFDirectDestination();
public:
PDFDirectDestination();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


%%PageItemTitle%% $$Properties$$

PDFDirectDestination Class Properties

O2S.Components.PDFView4NET Namespace : PDFDirectDestination Class

For a list of all members of this type, see PDFDirectDestination members.

Public Properties
 | Name | Description
Public Property | ZoomMode | Gets or sets the zoom mode.
Top
See Also

Reference

PDFDirectDestination Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

ZoomMode Property (PDFDirectDestination)

O2S.Components.PDFView4NET Namespace > PDFDirectDestination Class : ZoomMode Property
Gets or sets the zoom mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ZoomMode As PDFDestinationZoomMode
'Usage

Dim instance As PDFDirectDestination
Dim value As PDFDestinationZoomMode

instance.ZoomMode = value

value = instance.ZoomMode
public PDFDestinationZoomMode ZoomMode {get; set;}
public: __property PDFDestinationZoomMode get_ZoomMode();
public: __property void set_ZoomMode(
   PDFDestinationZoomMode value
);
public:
property PDFDestinationZoomMode ZoomMode {
   PDFDestinationZoomMode get();
   void set (    PDFDestinationZoomMode value);
}

Property Value

The zoom mode to be applied when the destination is displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


%%PageItemTitle%%

PDFDocument Class
Members

O2S.Components.PDFView4NET Namespace : PDFDocument Class
Defines a PDF document.
Object Model
PDFDocument ClassPDFAnnotationsViewCollection ClassPDFAnnotationsView ClassPDFBookmarkCollection ClassPDFBookmark ClassPDFBookmarksViewCollection ClassPDFBookmarksView ClassPDFDocumentInformation ClassPDFFileAttachmentCollection ClassPDFFileAttachment ClassPDFFileAttachmentsViewCollection ClassPDFFileAttachmentsView ClassPDFForm ClassPDFXMPMetadata ClassPDFPageCollection ClassPDFPage ClassPDFPageThumbnailViewCollection ClassPDFPageThumbnailView ClassPDFPageViewCollection ClassPDFPageView ClassPDFSecurityManager ClassPDFViewerPreferences Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class PDFDocument
   Inherits System.ComponentModel.Component
   Implements IRawPDFData
'Usage

Dim instance As PDFDocument
[ToolboxBitmap()]
public class PDFDocument : System.ComponentModel.Component, IRawPDFData
[ToolboxBitmap()]
public __gc class PDFDocument : public System.ComponentModel.Component, IRawPDFData
[ToolboxBitmap()]
public ref class PDFDocument : public System.ComponentModel.Component, IRawPDFData
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
O2S.Components.PDFView4NET.PDFDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocument Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFDocument Class

The following tables list the members exposed by PDFDocument.

Public Constructors
 | Name | Description
Public Constructor | PDFDocument Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AnnotationViews | Gets the list of annotation views attached to the PDF document.
Public Property | Bookmarks | Gets the list of bookmarks in the PDF document.
Public Property | BookmarkViews | Gets the list of bookmark views attached to the PDF document.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DelayedLoadForFileAttachments | Gets or sets a value indicating whether delayed load should be used for file attachments.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | FileAttachments | Gets the list of file attachments in the PDF document.
Public Property | FileAttachmentViews | Gets the list of file attachment views attached to the PDF document.
Public Property | FilePath | Gets or sets the path to the PDF file.
Public Property | Form | Gets the PDF form included in the document.
Public Property | ID | Gets the document ID.
Public Property | IncrementalLoad | Gets or sets a value indicating whether the document parts should be loaded as needed or the entire document should be loaded in memory.
Public Property | Metadata | Gets the XMP metadata for this PDFDocument object.
Public Property | PageCount | Gets the number of pages in the document.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | PageMode | Gets or sets the document's page mode specifying how the document should be displayed when opened.
Public Property | Pages | Gets the list of pages in the document.
Public Property | PDFPageThumbnailViews | Gets the list of page thumbnail views attached to the PDF document.
Public Property | PDFPageViews | Gets the list of page views attached to the PDF document.
Public Property | PrerenderDocumentPages | Gets or sets a value indicating whether the document pages should be prerendered or not.
Public Property | SecurityManager | Gets o sets the document's security manager.
Public Property | SerialNumber | Gets or sets the serial number used to unlock the component.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Top
Public Methods
 | Name | Description
Public Method | Close | Closes the PDF file and frees the resources.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetDestinationNames | Gets the names of the destinations stored in the PDF file.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNamedDestinations | Gets the named destinations stored in the PDF file.
Public Method | GetRawValue | Gets the value of the specified key.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Load | Overloaded. Loads the PDF file from disk.
Public Method | Print | Overloaded. Prints the PDF document with the specified settings.
Public Method | Save | Overloaded. Saves the PDF document as a file.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | AfterPrintPage | Fired after a PDF page is printed.
Public Event | BeforePrintPage | Fired before a PDF page is printed.
Public Event | BookmarkAdded | Gets or sets the event being fired when a new bookmark has been added to the document.
Public Event | BookmarkRemoved | Gets or sets the event being fired when an existing bookmark has been removed from the document.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | PasswordRequired | Gets or sets the event being fired when a password is required for opening the PDF file.
Public Event | PrintProgress | Fired after a PDF page is printed, to notify about the progress of the print operation.
Top
See Also

Reference

PDFDocument Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFDocument Constructor

O2S.Components.PDFView4NET Namespace > PDFDocument Class : PDFDocument Constructor
Overload List
Overload | Description
PDFDocument Constructor() | Initializes a new PDFDocument object.
PDFDocument Constructor(IContainer) | Initializes a new PDFDocument object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PDFDocument Constructor()

O2S.Components.PDFView4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor()
Initializes a new PDFDocument object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDocument()
public PDFDocument()
public: PDFDocument();
public:
PDFDocument();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%%

PDFDocument Constructor(IContainer)

O2S.Components.PDFView4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(IContainer)
The container of this object.
Initializes a new PDFDocument object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer _
)
'Usage

Dim container As IContainer

Dim instance As New PDFDocument(container)
public PDFDocument(
   IContainer container
)
public: PDFDocument(
   IContainer* container
)
public:
PDFDocument(
   IContainer^ container
)

Parameters

container
The container of this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFDocument Class Methods

O2S.Components.PDFView4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Methods
 | Name | Description
Public Method | Close | Closes the PDF file and frees the resources.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetDestinationNames | Gets the names of the destinations stored in the PDF file.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNamedDestinations | Gets the named destinations stored in the PDF file.
Public Method | GetRawValue | Gets the value of the specified key.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Load | Overloaded. Loads the PDF file from disk.
Public Method | Print | Overloaded. Prints the PDF document with the specified settings.
Public Method | Save | Overloaded. Saves the PDF document as a file.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PDFDocument Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Close Method (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : Close Method
Closes the PDF file and frees the resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As PDFDocument

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

GetDestinationNames Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class : GetDestinationNames Method
Gets the names of the destinations stored in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetDestinationNames() As String()
'Usage

Dim instance As PDFDocument
Dim value() As String

value = instance.GetDestinationNames()
public string[] GetDestinationNames()
public: string*[]* GetDestinationNames();
public:
array<String^>^ GetDestinationNames();

Return Value

An array of strings representing the names of the destinations in the PDF file.
Remarks
These names can be used with PDFPageView.JumpToDestination method to jump programmatically to a destination in the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

GetNamedDestinations Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class : GetNamedDestinations Method
Gets the named destinations stored in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetNamedDestinations() As PDFNamedDestinationCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFNamedDestinationCollection

value = instance.GetNamedDestinations()
public PDFNamedDestinationCollection GetNamedDestinations()
public: PDFNamedDestinationCollection* GetNamedDestinations();
public:
PDFNamedDestinationCollection^ GetNamedDestinations();

Return Value

An collection of named destinations.
Remarks
The destination names can be used with PDFPageView.JumpToDestination method to jump programmatically to a destination in the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

GetRawValue Method (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : GetRawValue Method
The key in the action for which the value has been requested.
Gets the value of the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRawValue( _
   ByVal key As String _
) As String
'Usage

Dim instance As PDFDocument
Dim key As String
Dim value As String

value = instance.GetRawValue(key)
public string GetRawValue(
   string key
)
public: string* GetRawValue(
   string* key
)
public:
String^ GetRawValue(
   String^ key
)

Parameters

key
The key in the action for which the value has been requested.

Return Value

The value of the given key, or null if the action does not contain the key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

Load Method (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : Load Method
Loads the PDF file from disk.
Overload List
Overload | Description
Load(String) | Loads the PDF file from disk.
Load(String,Byte[]) | Loads the PDF file from disk.
Load(Stream) | Loads the PDF file from stream.
Load(Stream,Byte[]) | Loads the PDF file from stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

Load(String) Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class > Load Method : Load(String) Method
Path to PDF file.
Loads the PDF file from disk.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Load( _
   ByVal file As String _
)
'Usage

Dim instance As PDFDocument
Dim file As String

instance.Load(file)
public void Load(
   string file
)
public: void Load(
   string* file
)
public:
void Load(
   String^ file
)

Parameters

file
Path to PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%ItemTitle%%

Load(String,Byte[]) Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class > Load Method : Load(String,Byte[]) Method
Path to PDF file.
Password to open the PDF file.
Loads the PDF file from disk.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Load( _
   ByVal file As String, _
   ByVal password() As Byte _
)
'Usage

Dim instance As PDFDocument
Dim file As String
Dim password() As Byte

instance.Load(file, password)
public void Load(
   string file,
   byte[] password
)
public: void Load(
   string* file,
   byte[]* password
)
public:
void Load(
   String^ file,
   array<byte>^ password
)

Parameters

file
Path to PDF file.
password
Password to open the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%ItemTitle%%

Load(Stream) Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class > Load Method : Load(Stream) Method
Stream storing the PDF file.
Loads the PDF file from stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Load( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PDFDocument
Dim stream As Stream

instance.Load(stream)
public void Load(
   Stream stream
)
public: void Load(
   Stream* stream
)
public:
void Load(
   Stream^ stream
)

Parameters

stream
Stream storing the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%ItemTitle%%

Load(Stream,Byte[]) Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class > Load Method : Load(Stream,Byte[]) Method
Stream storing the PDF file.
Password to open the PDF file.
Loads the PDF file from stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Load( _
   ByVal stream As Stream, _
   ByVal password() As Byte _
)
'Usage

Dim instance As PDFDocument
Dim stream As Stream
Dim password() As Byte

instance.Load(stream, password)
public void Load(
   Stream stream,
   byte[] password
)
public: void Load(
   Stream* stream,
   byte[]* password
)
public:
void Load(
   Stream^ stream,
   array<byte>^ password
)

Parameters

stream
Stream storing the PDF file.
password
Password to open the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%ItemTitle%%

Print Method (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : Print Method
Prints the PDF document with the specified settings.
Overload List
Overload | Description
Print(PDFPrintSettings) | Prints the PDF document with the specified settings.
Print(PDFPrintSettings,PDFPrintContent) | Prints the PDF document with the specified settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

Print(PDFPrintSettings) Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class > Print Method : Print(PDFPrintSettings) Method
Settings for printing the PDF file.
Prints the PDF document with the specified settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Print( _
   ByVal settings As PDFPrintSettings _
)
'Usage

Dim instance As PDFDocument
Dim settings As PDFPrintSettings

instance.Print(settings)
public void Print(
   PDFPrintSettings settings
)
public: void Print(
   PDFPrintSettings* settings
)
public:
void Print(
   PDFPrintSettings^ settings
)

Parameters

settings
Settings for printing the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%ItemTitle%%

Print(PDFPrintSettings,PDFPrintContent) Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class > Print Method : Print(PDFPrintSettings,PDFPrintContent) Method
Settings for printing the PDF file.
The content to be printed.
Prints the PDF document with the specified settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Print( _
   ByVal settings As PDFPrintSettings, _
   ByVal printContent As PDFPrintContent _
)
'Usage

Dim instance As PDFDocument
Dim settings As PDFPrintSettings
Dim printContent As PDFPrintContent

instance.Print(settings, printContent)
public void Print(
   PDFPrintSettings settings,
   PDFPrintContent printContent
)
public: void Print(
   PDFPrintSettings* settings,
   PDFPrintContent printContent
)
public:
void Print(
   PDFPrintSettings^ settings,
   PDFPrintContent printContent
)

Parameters

settings
Settings for printing the PDF file.
printContent
The content to be printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%ItemTitle%%

Save Method (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : Save Method
Saves the PDF document as a file.
Overload List
Overload | Description
Save(String) | Saves the PDF document as a file.
Save(Stream) | Saves the PDF document to a stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

Save(String) Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class > Save Method : Save(String) Method
The name of the PDF file.
Saves the PDF document as a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As String _
)
'Usage

Dim instance As PDFDocument
Dim fileName As String

instance.Save(fileName)
public void Save(
   string fileName
)
public: void Save(
   string* fileName
)
public:
void Save(
   String^ fileName
)

Parameters

fileName
The name of the PDF file.
Remarks
The exceptions thrown by this method are the exceptions that are thrown by System.IO.FileStream constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%ItemTitle%%

Save(Stream) Method

O2S.Components.PDFView4NET Namespace > PDFDocument Class > Save Method : Save(Stream) Method
The stream where to save the PDF file.
Saves the PDF document to a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PDFDocument
Dim stream As Stream

instance.Save(stream)
public void Save(
   Stream stream
)
public: void Save(
   Stream* stream
)
public:
void Save(
   Stream^ stream
)

Parameters

stream
The stream where to save the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFDocument Class Properties

O2S.Components.PDFView4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Properties
 | Name | Description
Public Property | AnnotationViews | Gets the list of annotation views attached to the PDF document.
Public Property | Bookmarks | Gets the list of bookmarks in the PDF document.
Public Property | BookmarkViews | Gets the list of bookmark views attached to the PDF document.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DelayedLoadForFileAttachments | Gets or sets a value indicating whether delayed load should be used for file attachments.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | FileAttachments | Gets the list of file attachments in the PDF document.
Public Property | FileAttachmentViews | Gets the list of file attachment views attached to the PDF document.
Public Property | FilePath | Gets or sets the path to the PDF file.
Public Property | Form | Gets the PDF form included in the document.
Public Property | ID | Gets the document ID.
Public Property | IncrementalLoad | Gets or sets a value indicating whether the document parts should be loaded as needed or the entire document should be loaded in memory.
Public Property | Metadata | Gets the XMP metadata for this PDFDocument object.
Public Property | PageCount | Gets the number of pages in the document.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | PageMode | Gets or sets the document's page mode specifying how the document should be displayed when opened.
Public Property | Pages | Gets the list of pages in the document.
Public Property | PDFPageThumbnailViews | Gets the list of page thumbnail views attached to the PDF document.
Public Property | PDFPageViews | Gets the list of page views attached to the PDF document.
Public Property | PrerenderDocumentPages | Gets or sets a value indicating whether the document pages should be prerendered or not.
Public Property | SecurityManager | Gets o sets the document's security manager.
Public Property | SerialNumber | Gets or sets the serial number used to unlock the component.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Top
See Also

Reference

PDFDocument Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

AnnotationViews Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : AnnotationViews Property
Gets the list of annotation views attached to the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property AnnotationViews As PDFAnnotationsViewCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFAnnotationsViewCollection

value = instance.AnnotationViews
[Browsable(false)]
public PDFAnnotationsViewCollection AnnotationViews {get;}
[Browsable(false)]
public: __property PDFAnnotationsViewCollection* get_AnnotationViews();
[Browsable(false)]
public:
property PDFAnnotationsViewCollection^ AnnotationViews {
   PDFAnnotationsViewCollection^ get();
}

Property Value

A PDFAnnotationsViewCollection object specifying a list of annotation views for the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

Bookmarks Property (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : Bookmarks Property
Gets the list of bookmarks in the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Bookmarks As PDFBookmarkCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFBookmarkCollection

value = instance.Bookmarks
[Browsable(false)]
public PDFBookmarkCollection Bookmarks {get;}
[Browsable(false)]
public: __property PDFBookmarkCollection* get_Bookmarks();
[Browsable(false)]
public:
property PDFBookmarkCollection^ Bookmarks {
   PDFBookmarkCollection^ get();
}

Property Value

The list of top level bookmarks in the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

BookmarkViews Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : BookmarkViews Property
Gets the list of bookmark views attached to the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property BookmarkViews As PDFBookmarksViewCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFBookmarksViewCollection

value = instance.BookmarkViews
[Browsable(false)]
public PDFBookmarksViewCollection BookmarkViews {get;}
[Browsable(false)]
public: __property PDFBookmarksViewCollection* get_BookmarkViews();
[Browsable(false)]
public:
property PDFBookmarksViewCollection^ BookmarkViews {
   PDFBookmarksViewCollection^ get();
}

Property Value

A PDFBookmarksViewCollection object specifying a list of bookmark views for the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

DelayedLoadForFileAttachments Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : DelayedLoadForFileAttachments Property
Gets or sets a value indicating whether delayed load should be used for file attachments.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Delayed load option for file attachments.")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
Public Property DelayedLoadForFileAttachments As Boolean
'Usage

Dim instance As PDFDocument
Dim value As Boolean

instance.DelayedLoadForFileAttachments = value

value = instance.DelayedLoadForFileAttachments
[Description("Delayed load option for file attachments.")]
[DefaultValue()]
[Category("PDF")]
public bool DelayedLoadForFileAttachments {get; set;}
[Description("Delayed load option for file attachments.")]
[DefaultValue()]
[Category("PDF")]
public: __property bool get_DelayedLoadForFileAttachments();
public: __property void set_DelayedLoadForFileAttachments(
   bool value
);
[Description("Delayed load option for file attachments.")]
[DefaultValue()]
[Category("PDF")]
public:
property bool DelayedLoadForFileAttachments {
   bool get();
   void set (    bool value);
}

Property Value

True if the file attachments should be loaded of explicit request, otherwise they are loaded automatically.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

DocumentInformation Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : DocumentInformation Property
Gets or sets the document information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property DocumentInformation As PDFDocumentInformation
'Usage

Dim instance As PDFDocument
Dim value As PDFDocumentInformation

instance.DocumentInformation = value

value = instance.DocumentInformation
[DefaultValue()]
[Browsable(false)]
public PDFDocumentInformation DocumentInformation {get; set;}
[DefaultValue()]
[Browsable(false)]
public: __property PDFDocumentInformation* get_DocumentInformation();
public: __property void set_DocumentInformation(
   PDFDocumentInformation* value
);
[DefaultValue()]
[Browsable(false)]
public:
property PDFDocumentInformation^ DocumentInformation {
   PDFDocumentInformation^ get();
   void set (    PDFDocumentInformation^ value);
}

Property Value

The document's metadata.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

FileAttachments Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : FileAttachments Property
Gets the list of file attachments in the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property FileAttachments As PDFFileAttachmentCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFFileAttachmentCollection

value = instance.FileAttachments
[Browsable(false)]
public PDFFileAttachmentCollection FileAttachments {get;}
[Browsable(false)]
public: __property PDFFileAttachmentCollection* get_FileAttachments();
[Browsable(false)]
public:
property PDFFileAttachmentCollection^ FileAttachments {
   PDFFileAttachmentCollection^ get();
}

Property Value

The list of files embedded in the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

FileAttachmentViews Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : FileAttachmentViews Property
Gets the list of file attachment views attached to the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property FileAttachmentViews As PDFFileAttachmentsViewCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFFileAttachmentsViewCollection

value = instance.FileAttachmentViews
[Browsable(false)]
public PDFFileAttachmentsViewCollection FileAttachmentViews {get;}
[Browsable(false)]
public: __property PDFFileAttachmentsViewCollection* get_FileAttachmentViews();
[Browsable(false)]
public:
property PDFFileAttachmentsViewCollection^ FileAttachmentViews {
   PDFFileAttachmentsViewCollection^ get();
}

Property Value

A PDFFileAttachmentsViewCollection object specifying a list of file attachments views for the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

FilePath Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : FilePath Property
Gets or sets the path to the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The path to the PDF file")>
<CategoryAttribute("PDF")>
<DefaultValueAttribute()>
Public Property FilePath As String
'Usage

Dim instance As PDFDocument
Dim value As String

instance.FilePath = value

value = instance.FilePath
[Description("The path to the PDF file")]
[Category("PDF")]
[DefaultValue()]
public string FilePath {get; set;}
[Description("The path to the PDF file")]
[Category("PDF")]
[DefaultValue()]
public: __property string* get_FilePath();
public: __property void set_FilePath(
   string* value
);
[Description("The path to the PDF file")]
[Category("PDF")]
[DefaultValue()]
public:
property String^ FilePath {
   String^ get();
   void set (    String^ value);
}

Property Value

Path to the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

Form Property (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : Form Property
Gets the PDF form included in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Form As PDFForm
'Usage

Dim instance As PDFDocument
Dim value As PDFForm

value = instance.Form
[Browsable(false)]
public PDFForm Form {get;}
[Browsable(false)]
public: __property PDFForm* get_Form();
[Browsable(false)]
public:
property PDFForm^ Form {
   PDFForm^ get();
}

Property Value

A O2S.Components.PDFView4NET.Forms.PDFForm object representing the PDF form included in the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

ID Property (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : ID Property
Gets the document ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property ID As String
'Usage

Dim instance As PDFDocument
Dim value As String

value = instance.ID
[Browsable(false)]
public string ID {get;}
[Browsable(false)]
public: __property string* get_ID();
[Browsable(false)]
public:
property String^ ID {
   String^ get();
}

Property Value

The PDF identifier of this document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

IncrementalLoad Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : IncrementalLoad Property
Gets or sets a value indicating whether the document parts should be loaded as needed or the entire document should be loaded in memory.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Incremental load option for document content.")>
<CategoryAttribute("PDF")>
Public Property IncrementalLoad As Boolean
'Usage

Dim instance As PDFDocument
Dim value As Boolean

instance.IncrementalLoad = value

value = instance.IncrementalLoad
[DefaultValue()]
[Description("Incremental load option for document content.")]
[Category("PDF")]
public bool IncrementalLoad {get; set;}
[DefaultValue()]
[Description("Incremental load option for document content.")]
[Category("PDF")]
public: __property bool get_IncrementalLoad();
public: __property void set_IncrementalLoad(
   bool value
);
[DefaultValue()]
[Description("Incremental load option for document content.")]
[Category("PDF")]
public:
property bool IncrementalLoad {
   bool get();
   void set (    bool value);
}

Property Value

True if incremental loading should be used for PDF document, false otherwise. Default is true.
Remarks
By default the PDFDocument loads only the pages that need to be displayed. This requires the source stream to be kept open in order to load remaining pages when they are needed. Loading the entire PDF file in memory allows closing the source stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

Metadata Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : Metadata Property
Gets the XMP metadata for this PDFDocument object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property Metadata As PDFXMPMetadata
'Usage

Dim instance As PDFDocument
Dim value As PDFXMPMetadata

instance.Metadata = value

value = instance.Metadata
[Browsable(false)]
public PDFXMPMetadata Metadata {get; set;}
[Browsable(false)]
public: __property PDFXMPMetadata* get_Metadata();
public: __property void set_Metadata(
   PDFXMPMetadata* value
);
[Browsable(false)]
public:
property PDFXMPMetadata^ Metadata {
   PDFXMPMetadata^ get();
   void set (    PDFXMPMetadata^ value);
}

Property Value

A PDFXMPMetadata object specifying the XMP metadata.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

PageCount Property (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : PageCount Property
Gets the number of pages in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property PageCount As Integer
'Usage

Dim instance As PDFDocument
Dim value As Integer

value = instance.PageCount
[Browsable(false)]
public int PageCount {get;}
[Browsable(false)]
public: __property int get_PageCount();
[Browsable(false)]
public:
property int PageCount {
   int get();
}

Property Value

The number of pages in the document, -1 if there is no file loaded.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

PageLayout Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : PageLayout Property
Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property PageLayout As PDFPageLayout
'Usage

Dim instance As PDFDocument
Dim value As PDFPageLayout

instance.PageLayout = value

value = instance.PageLayout
[Browsable(false)]
public PDFPageLayout PageLayout {get; set;}
[Browsable(false)]
public: __property PDFPageLayout get_PageLayout();
public: __property void set_PageLayout(
   PDFPageLayout value
);
[Browsable(false)]
public:
property PDFPageLayout PageLayout {
   PDFPageLayout get();
   void set (    PDFPageLayout value);
}

Property Value

The document's page layout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

PageMode Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : PageMode Property
Gets or sets the document's page mode specifying how the document should be displayed when opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property PageMode As PDFPageMode
'Usage

Dim instance As PDFDocument
Dim value As PDFPageMode

instance.PageMode = value

value = instance.PageMode
[Browsable(false)]
public PDFPageMode PageMode {get; set;}
[Browsable(false)]
public: __property PDFPageMode get_PageMode();
public: __property void set_PageMode(
   PDFPageMode value
);
[Browsable(false)]
public:
property PDFPageMode PageMode {
   PDFPageMode get();
   void set (    PDFPageMode value);
}

Property Value

The document's page mode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

Pages Property (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : Pages Property
Gets the list of pages in the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Pages As PDFPageCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFPageCollection

value = instance.Pages
[Browsable(false)]
public PDFPageCollection Pages {get;}
[Browsable(false)]
public: __property PDFPageCollection* get_Pages();
[Browsable(false)]
public:
property PDFPageCollection^ Pages {
   PDFPageCollection^ get();
}

Property Value

The list of document's pages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

PDFPageThumbnailViews Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : PDFPageThumbnailViews Property
Gets the list of page thumbnail views attached to the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property PDFPageThumbnailViews As PDFPageThumbnailViewCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFPageThumbnailViewCollection

value = instance.PDFPageThumbnailViews
[Browsable(false)]
public PDFPageThumbnailViewCollection PDFPageThumbnailViews {get;}
[Browsable(false)]
public: __property PDFPageThumbnailViewCollection* get_PDFPageThumbnailViews();
[Browsable(false)]
public:
property PDFPageThumbnailViewCollection^ PDFPageThumbnailViews {
   PDFPageThumbnailViewCollection^ get();
}

Property Value

A PDFPageThumbnailViewCollection object specifying a list of page thumbnail views for the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

PDFPageViews Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : PDFPageViews Property
Gets the list of page views attached to the PDF document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property PDFPageViews As PDFPageViewCollection
'Usage

Dim instance As PDFDocument
Dim value As PDFPageViewCollection

value = instance.PDFPageViews
[Browsable(false)]
public PDFPageViewCollection PDFPageViews {get;}
[Browsable(false)]
public: __property PDFPageViewCollection* get_PDFPageViews();
[Browsable(false)]
public:
property PDFPageViewCollection^ PDFPageViews {
   PDFPageViewCollection^ get();
}

Property Value

A PDFPageViewCollection object specifying a list of page views for the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

PrerenderDocumentPages Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : PrerenderDocumentPages Property
Gets or sets a value indicating whether the document pages should be prerendered or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property PrerenderDocumentPages As Boolean
'Usage

Dim instance As PDFDocument
Dim value As Boolean

instance.PrerenderDocumentPages = value

value = instance.PrerenderDocumentPages
[DefaultValue()]
[Browsable(true)]
public bool PrerenderDocumentPages {get; set;}
[DefaultValue()]
[Browsable(true)]
public: __property bool get_PrerenderDocumentPages();
public: __property void set_PrerenderDocumentPages(
   bool value
);
[DefaultValue()]
[Browsable(true)]
public:
property bool PrerenderDocumentPages {
   bool get();
   void set (    bool value);
}

Property Value

True if the document pages should be prerendered, false otherwise.
Remarks
Setting this property to true causes the document to render all pages when the PDF file is loaded. This leads to faster page navigation but the document load time and memory consumption increases.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

SecurityManager Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : SecurityManager Property
Gets o sets the document's security manager.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property SecurityManager As PDFSecurityManager
'Usage

Dim instance As PDFDocument
Dim value As PDFSecurityManager

instance.SecurityManager = value

value = instance.SecurityManager
[DefaultValue()]
[Browsable(false)]
public PDFSecurityManager SecurityManager {get; set;}
[DefaultValue()]
[Browsable(false)]
public: __property PDFSecurityManager* get_SecurityManager();
public: __property void set_SecurityManager(
   PDFSecurityManager* value
);
[DefaultValue()]
[Browsable(false)]
public:
property PDFSecurityManager^ SecurityManager {
   PDFSecurityManager^ get();
   void set (    PDFSecurityManager^ value);
}

Property Value

The security manager used for encrypting the document content and for applying restrictions on the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

SerialNumber Property (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : SerialNumber Property
Gets or sets the serial number used to unlock the component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DescriptionAttribute("The serial number for unlocking the evaluation version")>
<DefaultValueAttribute()>
Public Property SerialNumber As String
'Usage

Dim instance As PDFDocument
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
[Category("PDF")]
[Description("The serial number for unlocking the evaluation version")]
[DefaultValue()]
public string SerialNumber {get; set;}
[Category("PDF")]
[Description("The serial number for unlocking the evaluation version")]
[DefaultValue()]
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
[Category("PDF")]
[Description("The serial number for unlocking the evaluation version")]
[DefaultValue()]
public:
property String^ SerialNumber {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

ViewerPreferences Property

O2S.Components.PDFView4NET Namespace > PDFDocument Class : ViewerPreferences Property
Gets or sets the document's viewer preferences.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property ViewerPreferences As PDFViewerPreferences
'Usage

Dim instance As PDFDocument
Dim value As PDFViewerPreferences

instance.ViewerPreferences = value

value = instance.ViewerPreferences
[DefaultValue()]
[Browsable(false)]
public PDFViewerPreferences ViewerPreferences {get; set;}
[DefaultValue()]
[Browsable(false)]
public: __property PDFViewerPreferences* get_ViewerPreferences();
public: __property void set_ViewerPreferences(
   PDFViewerPreferences* value
);
[DefaultValue()]
[Browsable(false)]
public:
property PDFViewerPreferences^ ViewerPreferences {
   PDFViewerPreferences^ get();
   void set (    PDFViewerPreferences^ value);
}

Property Value

The viewer preferences for displaying the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%% $$Events$$

PDFDocument Class Events

O2S.Components.PDFView4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Events
 | Name | Description
Public Event | AfterPrintPage | Fired after a PDF page is printed.
Public Event | BeforePrintPage | Fired before a PDF page is printed.
Public Event | BookmarkAdded | Gets or sets the event being fired when a new bookmark has been added to the document.
Public Event | BookmarkRemoved | Gets or sets the event being fired when an existing bookmark has been removed from the document.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | PasswordRequired | Gets or sets the event being fired when a password is required for opening the PDF file.
Public Event | PrintProgress | Fired after a PDF page is printed, to notify about the progress of the print operation.
Top
See Also

Reference

PDFDocument Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

AfterPrintPage Event (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : AfterPrintPage Event
Fired after a PDF page is printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterPrintPage As EventHandler(Of PrintPageEventArgs)
'Usage

Dim instance As PDFDocument
Dim handler As EventHandler(Of PrintPageEventArgs)

AddHandler instance.AfterPrintPage, handler
public event EventHandler<PrintPageEventArgs> AfterPrintPage
public: __event EventHandler<PrintPageEventArgs*>* AfterPrintPage
public:
event EventHandler<PrintPageEventArgs^>^ AfterPrintPage
Event Data

The event handler receives an argument of type PrintPageEventArgs containing data related to this event. The following PrintPageEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the print job should be canceled.
Graphics | Gets the System.Drawing.Graphics used to paint the page.
HasMorePages | Gets or sets a value indicating whether an additional page should be printed.
MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins.
PageBounds | Gets the rectangular area that represents the total area of the page.
PageSettings | Gets the page settings for the current page.
Remarks
You can use this event to print content, such as stamps, on the page on the PDF content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

BeforePrintPage Event (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : BeforePrintPage Event
Fired before a PDF page is printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event BeforePrintPage As EventHandler(Of PrintPageEventArgs)
'Usage

Dim instance As PDFDocument
Dim handler As EventHandler(Of PrintPageEventArgs)

AddHandler instance.BeforePrintPage, handler
public event EventHandler<PrintPageEventArgs> BeforePrintPage
public: __event EventHandler<PrintPageEventArgs*>* BeforePrintPage
public:
event EventHandler<PrintPageEventArgs^>^ BeforePrintPage
Event Data

The event handler receives an argument of type PrintPageEventArgs containing data related to this event. The following PrintPageEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the print job should be canceled.
Graphics | Gets the System.Drawing.Graphics used to paint the page.
HasMorePages | Gets or sets a value indicating whether an additional page should be printed.
MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins.
PageBounds | Gets the rectangular area that represents the total area of the page.
PageSettings | Gets the page settings for the current page.
Remarks
You can use this event to print content, such as watermarks, on the page under the PDF content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

BookmarkAdded Event

O2S.Components.PDFView4NET Namespace > PDFDocument Class : BookmarkAdded Event
Gets or sets the event being fired when a new bookmark has been added to the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
<DescriptionAttribute("Fired when a new bookmark has been added to the document")>
Public Event BookmarkAdded As EventHandler(Of BookmarkEventArgs)
'Usage

Dim instance As PDFDocument
Dim handler As EventHandler(Of BookmarkEventArgs)

AddHandler instance.BookmarkAdded, handler
[DefaultValue()]
[Category("PDF")]
[Description("Fired when a new bookmark has been added to the document")]
public event EventHandler<BookmarkEventArgs> BookmarkAdded
[DefaultValue()]
[Category("PDF")]
[Description("Fired when a new bookmark has been added to the document")]
public: __event EventHandler<BookmarkEventArgs*>* BookmarkAdded
[DefaultValue()]
[Category("PDF")]
[Description("Fired when a new bookmark has been added to the document")]
public:
event EventHandler<BookmarkEventArgs^>^ BookmarkAdded
Event Data

The event handler receives an argument of type BookmarkEventArgs containing data related to this event. The following BookmarkEventArgs properties provide information specific to this event.

Property | Description
Bookmark | Gets the bookmark that has been acted upon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

BookmarkRemoved Event

O2S.Components.PDFView4NET Namespace > PDFDocument Class : BookmarkRemoved Event
Gets or sets the event being fired when an existing bookmark has been removed from the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DescriptionAttribute("Fired when an existing bookmark has been removed from the document")>
<DefaultValueAttribute()>
Public Event BookmarkRemoved As EventHandler(Of BookmarkEventArgs)
'Usage

Dim instance As PDFDocument
Dim handler As EventHandler(Of BookmarkEventArgs)

AddHandler instance.BookmarkRemoved, handler
[Category("PDF")]
[Description("Fired when an existing bookmark has been removed from the document")]
[DefaultValue()]
public event EventHandler<BookmarkEventArgs> BookmarkRemoved
[Category("PDF")]
[Description("Fired when an existing bookmark has been removed from the document")]
[DefaultValue()]
public: __event EventHandler<BookmarkEventArgs*>* BookmarkRemoved
[Category("PDF")]
[Description("Fired when an existing bookmark has been removed from the document")]
[DefaultValue()]
public:
event EventHandler<BookmarkEventArgs^>^ BookmarkRemoved
Event Data

The event handler receives an argument of type BookmarkEventArgs containing data related to this event. The following BookmarkEventArgs properties provide information specific to this event.

Property | Description
Bookmark | Gets the bookmark that has been acted upon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

PasswordRequired Event

O2S.Components.PDFView4NET Namespace > PDFDocument Class : PasswordRequired Event
Gets or sets the event being fired when a password is required for opening the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Fired when a password is required for opening the PDF file")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
Public Event PasswordRequired As EventHandler(Of PasswordRequiredEventArgs)
'Usage

Dim instance As PDFDocument
Dim handler As EventHandler(Of PasswordRequiredEventArgs)

AddHandler instance.PasswordRequired, handler
[Description("Fired when a password is required for opening the PDF file")]
[DefaultValue()]
[Category("PDF")]
public event EventHandler<PasswordRequiredEventArgs> PasswordRequired
[Description("Fired when a password is required for opening the PDF file")]
[DefaultValue()]
[Category("PDF")]
public: __event EventHandler<PasswordRequiredEventArgs*>* PasswordRequired
[Description("Fired when a password is required for opening the PDF file")]
[DefaultValue()]
[Category("PDF")]
public:
event EventHandler<PasswordRequiredEventArgs^>^ PasswordRequired
Event Data

The event handler receives an argument of type PasswordRequiredEventArgs containing data related to this event. The following PasswordRequiredEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the PasswordRequired event should be fired again or not if the password is not valid.
Password | Gets or sets the password to be used for opening the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%ItemTitle%%

PrintProgress Event (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : PrintProgress Event
Fired after a PDF page is printed, to notify about the progress of the print operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PrintProgress As EventHandler(Of PrintProgressEventArgs)
'Usage

Dim instance As PDFDocument
Dim handler As EventHandler(Of PrintProgressEventArgs)

AddHandler instance.PrintProgress, handler
public event EventHandler<PrintProgressEventArgs> PrintProgress
public: __event EventHandler<PrintProgressEventArgs*>* PrintProgress
public:
event EventHandler<PrintProgressEventArgs^>^ PrintProgress
Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the page printing should be cancelled or not.
CurrentPage | Gets the page number within the print range being printed.
PageNumber | Gets the page number within the document being printed.
PrintPageCount | Gets the total number of pages being printed.
Remarks
You can use this event to dispaly a progress bar that indicates the progress of the print operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%%

PDFDocumentInformation Class
Members

O2S.Components.PDFView4NET Namespace : PDFDocumentInformation Class
Provides access to document metadata.
Object Model
PDFDocumentInformation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDocumentInformation
   Implements IRawPDFData
'Usage

Dim instance As PDFDocumentInformation
public class PDFDocumentInformation : IRawPDFData
public __gc class PDFDocumentInformation : public IRawPDFData
public ref class PDFDocumentInformation : public IRawPDFData
Remarks
This class stores document general information, such as document's title, author and other information.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFDocumentInformation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFDocumentInformation Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFDocumentInformation Class

The following tables list the members exposed by PDFDocumentInformation.

Public Constructors
 | Name | Description
Public Constructor | PDFDocumentInformation Constructor | Initializes a new PDFDocumentInformation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the author of the document.
Public Property | CreationDate | Gets or sets the date when the document was created.
Public Property | Creator | Gets or sets the application that created the document.
Public Property | Keywords | Gets or sets the keywords of the document.
Public Property | ModDate | Gets or sets the date when the document was modified.
Public Property | Producer | Gets or sets the PDF engine that produced the document.
Public Property | Subject | Gets or sets the subject of the document.
Public Property | Title | Gets or sets the title of the document.
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key.
Public Method | SetCustomKey | Sets a custom key/value pair in the document information.
Top
See Also

Reference

PDFDocumentInformation Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFDocumentInformation Constructor

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : PDFDocumentInformation Constructor
Initializes a new PDFDocumentInformation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDocumentInformation()
public PDFDocumentInformation()
public: PDFDocumentInformation();
public:
PDFDocumentInformation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%% $$Methods$$

PDFDocumentInformation Class Methods

O2S.Components.PDFView4NET Namespace : PDFDocumentInformation Class

For a list of all members of this type, see PDFDocumentInformation members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key.
Public Method | SetCustomKey | Sets a custom key/value pair in the document information.
Top
See Also

Reference

PDFDocumentInformation Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

GetRawValue Method (PDFDocumentInformation)

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : GetRawValue Method
The key in the document information for which the value has been requested.
Gets the value of the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRawValue( _
   ByVal key As String _
) As String
'Usage

Dim instance As PDFDocumentInformation
Dim key As String
Dim value As String

value = instance.GetRawValue(key)
public string GetRawValue(
   string key
)
public: string* GetRawValue(
   string* key
)
public:
String^ GetRawValue(
   String^ key
)

Parameters

key
The key in the document information for which the value has been requested.

Return Value

The value of the given key, or null if the document information does not contain the key.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when key is null or an empty string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%ItemTitle%%

SetCustomKey Method

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : SetCustomKey Method
The custom key to set.
The value for custom key.
Sets a custom key/value pair in the document information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetCustomKey( _
   ByVal key As String, _
   ByVal value As String _
)
'Usage

Dim instance As PDFDocumentInformation
Dim key As String
Dim value As String

instance.SetCustomKey(key, value)
public void SetCustomKey(
   string key,
   string value
)
public: void SetCustomKey(
   string* key,
   string* value
)
public:
void SetCustomKey(
   String^ key,
   String^ value
)

Parameters

key
The custom key to set.
value
The value for custom key.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when key is null or an empty string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%% $$Properties$$

PDFDocumentInformation Class Properties

O2S.Components.PDFView4NET Namespace : PDFDocumentInformation Class

For a list of all members of this type, see PDFDocumentInformation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the author of the document.
Public Property | CreationDate | Gets or sets the date when the document was created.
Public Property | Creator | Gets or sets the application that created the document.
Public Property | Keywords | Gets or sets the keywords of the document.
Public Property | ModDate | Gets or sets the date when the document was modified.
Public Property | Producer | Gets or sets the PDF engine that produced the document.
Public Property | Subject | Gets or sets the subject of the document.
Public Property | Title | Gets or sets the title of the document.
Top
See Also

Reference

PDFDocumentInformation Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Author Property (PDFDocumentInformation)

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : Author Property
Gets or sets the author of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The document author.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%ItemTitle%%

CreationDate Property (PDFDocumentInformation)

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : CreationDate Property
Gets or sets the date when the document was created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PDFDocumentInformation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The document creation date.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%ItemTitle%%

Creator Property

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : Creator Property
Gets or sets the application that created the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Creator As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Creator = value

value = instance.Creator
public string Creator {get; set;}
public: __property string* get_Creator();
public: __property void set_Creator(
   string* value
);
public:
property String^ Creator {
   String^ get();
   void set (    String^ value);
}

Property Value

The document creator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%ItemTitle%%

Keywords Property

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : Keywords Property
Gets or sets the keywords of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Keywords As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Keywords = value

value = instance.Keywords
public string Keywords {get; set;}
public: __property string* get_Keywords();
public: __property void set_Keywords(
   string* value
);
public:
property String^ Keywords {
   String^ get();
   void set (    String^ value);
}

Property Value

The document keywords.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%ItemTitle%%

ModDate Property (PDFDocumentInformation)

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : ModDate Property
Gets or sets the date when the document was modified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModDate As Date
'Usage

Dim instance As PDFDocumentInformation
Dim value As Date

instance.ModDate = value

value = instance.ModDate
public DateTime ModDate {get; set;}
public: __property DateTime get_ModDate();
public: __property void set_ModDate(
   DateTime value
);
public:
property DateTime ModDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The document modifiy date.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%ItemTitle%%

Producer Property

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : Producer Property
Gets or sets the PDF engine that produced the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Producer As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Producer = value

value = instance.Producer
public string Producer {get; set;}
public: __property string* get_Producer();
public: __property void set_Producer(
   string* value
);
public:
property String^ Producer {
   String^ get();
   void set (    String^ value);
}

Property Value

The document producer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%ItemTitle%%

Subject Property (PDFDocumentInformation)

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : Subject Property
Gets or sets the subject of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Subject As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Subject = value

value = instance.Subject
public string Subject {get; set;}
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
public:
property String^ Subject {
   String^ get();
   void set (    String^ value);
}

Property Value

The document subject.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%ItemTitle%%

Title Property (PDFDocumentInformation)

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : Title Property
Gets or sets the title of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As PDFDocumentInformation
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

The document title.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%PageItemTitle%%

PDFException Class
Members

O2S.Components.PDFView4NET Namespace : PDFException Class
Defines a generic PDF exception.
Object Model
PDFException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFException
   Inherits System.ApplicationException
'Usage

Dim instance As PDFException
public class PDFException : System.ApplicationException
public __gc class PDFException : public System.ApplicationException
public ref class PDFException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFView4NET.PDFException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFException Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFException Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFException Class

The following tables list the members exposed by PDFException.

Public Constructors
 | Name | Description
Public Constructor | PDFException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFException Constructor

O2S.Components.PDFView4NET Namespace > PDFException Class : PDFException Constructor
Overload List
Overload | Description
PDFException Constructor(String) | Initializes a new PDFException object.
PDFException Constructor(String,Exception) | Initializes a new PDFException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFException Class
PDFException Members


%%PageItemTitle%%

PDFException Constructor(String)

O2S.Components.PDFView4NET Namespace > PDFException Class > PDFException Constructor : PDFException Constructor(String)
The message that describes the exception.
Initializes a new PDFException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PDFException(message)
public PDFException(
   string message
)
public: PDFException(
   string* message
)
public:
PDFException(
   String^ message
)

Parameters

message
The message that describes the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFException Class
PDFException Members
Overload List


%%PageItemTitle%%

PDFException Constructor(String,Exception)

O2S.Components.PDFView4NET Namespace > PDFException Class > PDFException Constructor : PDFException Constructor(String,Exception)
the message that describes the exception.
The exception that is the cause of the current exception.
Initializes a new PDFException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PDFException(message, innerException)
public PDFException(
   string message,
   Exception innerException
)
public: PDFException(
   string* message,
   Exception* innerException
)
public:
PDFException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFException Class
PDFException Members
Overload List


%%PageItemTitle%%

PDFFileAttachment Class
Members

O2S.Components.PDFView4NET Namespace : PDFFileAttachment Class
Defines a file attachment embedded in the PDF file.
Object Model
PDFFileAttachment Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFileAttachment
'Usage

Dim instance As PDFFileAttachment
public class PDFFileAttachment
public __gc class PDFFileAttachment
public ref class PDFFileAttachment
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFFileAttachment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFFileAttachment Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFFileAttachment Class

The following tables list the members exposed by PDFFileAttachment.

Public Constructors
 | Name | Description
Public Constructor | PDFFileAttachment Constructor | Initializes a new PDFFileAttachment object.
Top
Public Properties
 | Name | Description
Public Property | CreationDate | Gets or sets the creation date.
Public Property | Data | Gets or sets the data stored in the file attachment.
Public Property | Description | Gets or sets the file description.
Public Property | FileName | Gets or sets the file name.
Public Property | ModDate | Gets or sets the modification date.
Public Property | Size | Gets the file size.
Top
Public Methods
 | Name | Description
Public Method | Load | Loads the file attachment content from the PDF file.
Public Method | Save | Overloaded. Saves the content of the embedded file to the specified file.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFFileAttachment Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFFileAttachment Constructor

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : PDFFileAttachment Constructor
Initializes a new PDFFileAttachment object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFileAttachment()
public PDFFileAttachment()
public: PDFFileAttachment();
public:
PDFFileAttachment();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%PageItemTitle%% $$Methods$$

PDFFileAttachment Class Methods

O2S.Components.PDFView4NET Namespace : PDFFileAttachment Class

For a list of all members of this type, see PDFFileAttachment members.

Public Methods
 | Name | Description
Public Method | Load | Loads the file attachment content from the PDF file.
Public Method | Save | Overloaded. Saves the content of the embedded file to the specified file.
Top
See Also

Reference

PDFFileAttachment Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Load Method (PDFFileAttachment)

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : Load Method
Loads the file attachment content from the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Load()
'Usage

Dim instance As PDFFileAttachment

instance.Load()
public void Load()
public: void Load();
public:
void Load();
Remarks
Use this method to load the file attachment content if the delayed load option has been set to true on the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%ItemTitle%%

Save Method (PDFFileAttachment)

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : Save Method
Saves the content of the embedded file to the specified file.
Overload List
Overload | Description
Save(String) | Saves the content of the embedded file to the specified file.
Save(Stream) | Saves the content of the embedded file to the specified stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%ItemTitle%%

Save(String) Method

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class > Save Method : Save(String) Method
Physical path where the embedded file should be saved.
Saves the content of the embedded file to the specified file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As String _
)
'Usage

Dim instance As PDFFileAttachment
Dim fileName As String

instance.Save(fileName)
public void Save(
   string fileName
)
public: void Save(
   string* fileName
)
public:
void Save(
   String^ fileName
)

Parameters

fileName
Physical path where the embedded file should be saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members
Overload List


%%ItemTitle%%

Save(Stream) Method

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class > Save Method : Save(Stream) Method
Stream where the embedded file should be saved.
Saves the content of the embedded file to the specified stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PDFFileAttachment
Dim stream As Stream

instance.Save(stream)
public void Save(
   Stream stream
)
public: void Save(
   Stream* stream
)
public:
void Save(
   Stream^ stream
)

Parameters

stream
Stream where the embedded file should be saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFileAttachment Class Properties

O2S.Components.PDFView4NET Namespace : PDFFileAttachment Class

For a list of all members of this type, see PDFFileAttachment members.

Public Properties
 | Name | Description
Public Property | CreationDate | Gets or sets the creation date.
Public Property | Data | Gets or sets the data stored in the file attachment.
Public Property | Description | Gets or sets the file description.
Public Property | FileName | Gets or sets the file name.
Public Property | ModDate | Gets or sets the modification date.
Public Property | Size | Gets the file size.
Top
See Also

Reference

PDFFileAttachment Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

CreationDate Property (PDFFileAttachment)

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : CreationDate Property
Gets or sets the creation date.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PDFFileAttachment
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The creation date of the file attachment.
Remarks
If the creation date is not set on the file attachment, this property returns DateTime.MinValue.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%ItemTitle%%

Data Property (PDFFileAttachment)

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : Data Property
Gets or sets the data stored in the file attachment.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Data As Byte()
'Usage

Dim instance As PDFFileAttachment
Dim value() As Byte

instance.Data = value

value = instance.Data
public byte[] Data {get; set;}
public: __property byte[]* get_Data();
public: __property void set_Data(
   byte[]* value
);
public:
property array<byte>^ Data {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The content of the file attachment.
Remarks
If this property returns 0, this means that the file attachment has not been loaded and you need to call the Load method first.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%ItemTitle%%

Description Property (PDFFileAttachment)

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : Description Property
Gets or sets the file description.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As PDFFileAttachment
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

The description of the file stored in the attachment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%ItemTitle%%

FileName Property (PDFFileAttachment)

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : FileName Property
Gets or sets the file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PDFFileAttachment
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the file whose content is stored in Data property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%ItemTitle%%

ModDate Property (PDFFileAttachment)

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : ModDate Property
Gets or sets the modification date.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModDate As Date
'Usage

Dim instance As PDFFileAttachment
Dim value As Date

instance.ModDate = value

value = instance.ModDate
public DateTime ModDate {get; set;}
public: __property DateTime get_ModDate();
public: __property void set_ModDate(
   DateTime value
);
public:
property DateTime ModDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date when the file attachment was modified.
Remarks
If the modification date is not set on the file attachment, this property returns DateTime.MinValue.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%ItemTitle%%

Size Property (PDFFileAttachment)

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : Size Property
Gets the file size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Size As Integer
'Usage

Dim instance As PDFFileAttachment
Dim value As Integer

value = instance.Size
public int Size {get;}
public: __property int get_Size();
public:
property int Size {
   int get();
}

Property Value

The size of the file stored in Data property.
Remarks
If this property returns 0, this means that the file attachment has not been loaded and you need to call the Load method first.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%PageItemTitle%% $$Events$$

PDFFileAttachment Class Events

O2S.Components.PDFView4NET Namespace : PDFFileAttachment Class

For a list of all members of this type, see PDFFileAttachment members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFFileAttachment Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

PropertyChanged Event (PDFFileAttachment)

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : PropertyChanged Event
Gets or sets the event that is fired when a property has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As PDFFileAttachment
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%PageItemTitle%%

PDFFileAttachmentCollection Class
Members

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentCollection Class
Defines a collection of file attachments.
Object Model
PDFFileAttachmentCollection ClassPDFFileAttachment Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFileAttachmentCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFFileAttachment,PDFDocument)
'Usage

Dim instance As PDFFileAttachmentCollection
public class PDFFileAttachmentCollection : O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachment,PDFDocument>
public __gc class PDFFileAttachmentCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachment,PDFDocument>
public ref class PDFFileAttachmentCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachment,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.PDFFileAttachmentCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentCollection Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFFileAttachmentCollection Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentCollection Class

The following tables list the members exposed by PDFFileAttachmentCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachment,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Top
Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFFileAttachmentCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Events$$

PDFFileAttachmentCollection Class Events

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentCollection Class

For a list of all members of this type, see PDFFileAttachmentCollection members.

Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFFileAttachmentCollection Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

CollectionChanged Event (PDFFileAttachmentCollection)

O2S.Components.PDFView4NET Namespace > PDFFileAttachmentCollection Class : CollectionChanged Event
Gets or sets the event being fired when the collection has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event CollectionChanged As EventHandler(Of PDFCollectionChangedEventArgs(Of PDFFileAttachment))
'Usage

Dim instance As PDFFileAttachmentCollection
Dim handler As EventHandler(Of PDFCollectionChangedEventArgs(Of PDFFileAttachment))

AddHandler instance.CollectionChanged, handler
public event EventHandler<PDFCollectionChangedEventArgs<PDFFileAttachment>> CollectionChanged
public: __event EventHandler<PDFCollectionChangedEventArgs<PDFFileAttachment*>*>* CollectionChanged
public:
event EventHandler<PDFCollectionChangedEventArgs<PDFFileAttachment^>^>^ CollectionChanged
Event Data

The event handler receives an argument of type PDFCollectionChangedEventArgs<T> containing data related to this event. The following PDFCollectionChangedEventArgs<T> properties provide information specific to this event.

Property | Description
ChangedProperty | Gets the name of changed property when the change type is item update.
ChangeType | Gets the type of change event.
NewItem | Gets the new item involved in the operation.
OldItem | Gets the old item involved in the operation.
Position | Gets the position of the affected item in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentCollection Class
PDFFileAttachmentCollection Members


%%PageItemTitle%%

PDFFileAttachmentsView Class
Members

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentsView Class
Defines a viewer for the bookmarks in a PDF file.
Object Model
PDFFileAttachmentsView ClassPDFDocument ClassPDFFileAttachment Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class PDFFileAttachmentsView
   Inherits System.Windows.Forms.ListView
'Usage

Dim instance As PDFFileAttachmentsView
[ToolboxBitmap()]
public class PDFFileAttachmentsView : System.Windows.Forms.ListView
[ToolboxBitmap()]
public __gc class PDFFileAttachmentsView : public System.Windows.Forms.ListView
[ToolboxBitmap()]
public ref class PDFFileAttachmentsView : public System.Windows.Forms.ListView
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListView
O2S.Components.PDFView4NET.PDFFileAttachmentsView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentsView Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFFileAttachmentsView Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentsView Class

The following tables list the members exposed by PDFFileAttachmentsView.

Public Constructors
 | Name | Description
Public Constructor | PDFFileAttachmentsView Constructor | Initializes a new PDFFileAttachmentsView object.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | Activation | Gets or sets the type of action the user must take to activate an item. (Inherited from System.Windows.Forms.ListView)
Public Property | Alignment | Gets or sets the alignment of items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | AllowColumnReorder | Gets or sets a value indicating whether the user can drag column headers to reorder columns in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoArrange | Gets or sets whether icons are automatically kept arranged. (Inherited from System.Windows.Forms.ListView)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from System.Windows.Forms.ListView)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageTiled | Gets or sets a value indicating whether the background image of the System.Windows.Forms.ListView should be tiled. (Inherited from System.Windows.Forms.ListView)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style of the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | CheckedIndices | Gets the indexes of the currently checked items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | CheckedItems | Gets the currently checked items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Columns | Gets the collection of all column headers that appear in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the PDF document for which the file attachments are displayed.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | FocusedItem | Gets or sets the item in the control that currently has focus. (Inherited from System.Windows.Forms.ListView)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color. (Inherited from System.Windows.Forms.ListView)
Public Property | FullRowSelect | Gets or sets a value indicating whether clicking an item selects all its subitems. (Inherited from System.Windows.Forms.ListView)
Public Property | GridLines | Gets or sets a value indicating whether grid lines appear between the rows and columns containing the items and subitems in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Groups | Gets the collection of System.Windows.Forms.ListViewGroup objects assigned to the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | HeaderStyle | Gets or sets the column header style. (Inherited from System.Windows.Forms.ListView)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HideSelection | Gets or sets a value indicating whether the selected item in the control remains highlighted when the control loses focus. (Inherited from System.Windows.Forms.ListView)
Public Property | HotTracking | Gets or sets a value indicating whether the text of an item or subitem has the appearance of a hyperlink when the mouse pointer passes over it. (Inherited from System.Windows.Forms.ListView)
Public Property | HoverSelection | Gets or sets a value indicating whether an item is automatically selected when the mouse pointer remains over the item for a few seconds. (Inherited from System.Windows.Forms.ListView)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InsertionMark | Gets an object used to indicate the expected drop location when an item is dragged within a System.Windows.Forms.ListView control. (Inherited from System.Windows.Forms.ListView)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | Items | Gets a collection containing all items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | LabelEdit | Gets or sets a value indicating whether the user can edit the labels of items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | LabelWrap | Gets or sets a value indicating whether item labels wrap when items are displayed in the control as icons. (Inherited from System.Windows.Forms.ListView)
Public Property | LargeImageList | Gets or sets the System.Windows.Forms.ImageList to use when displaying items as large icons in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | ListViewItemSorter | Gets or sets the sorting comparer for the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MultiSelect | Gets or sets a value indicating whether multiple items can be selected. (Inherited from System.Windows.Forms.ListView)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | OwnerDraw | Gets or sets a value indicating whether the System.Windows.Forms.ListView control is drawn by the operating system or by code that you provide. (Inherited from System.Windows.Forms.ListView)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | Gets or sets a value indicating whether the control is laid out from right to left. (Inherited from System.Windows.Forms.ListView)
Public Property | Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items. (Inherited from System.Windows.Forms.ListView)
Public Property | SelectedFileAttachment | Gets or sets the selected file attachment in the list.
Public Property | SelectedIndices | Gets the indexes of the selected items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | SelectedItems | Gets the items that are selected in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | ShowGroups | Gets or sets a value indicating whether items are displayed in groups. (Inherited from System.Windows.Forms.ListView)
Public Property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are shown for the System.Windows.Forms.ListViewItem objects contained in the System.Windows.Forms.ListView. (Inherited from System.Windows.Forms.ListView)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | SmallImageList | Gets or sets the System.Windows.Forms.ImageList to use when displaying items as small icons in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Sorting | Gets or sets the sort order for items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | StateImageList | Gets or sets the System.Windows.Forms.ImageList associated with application-defined states in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | TileSize | Gets or sets the size of the tiles shown in tile view. (Inherited from System.Windows.Forms.ListView)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopItem | Gets or sets the first visible item in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseCompatibleStateImageBehavior | Gets or sets a value indicating whether the System.Windows.Forms.ListView uses state image behavior that is compatible with the .NET Framework 1.1 or the .NET Framework 2.0. (Inherited from System.Windows.Forms.ListView)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | View | Gets or sets how items are displayed in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | VirtualListSize | Gets or sets the number of System.Windows.Forms.ListViewItem objects contained in the list when in virtual mode. (Inherited from System.Windows.Forms.ListView)
Public Property | VirtualMode | Gets or sets a value indicating whether you have provided your own data-management operations for the System.Windows.Forms.ListView control. (Inherited from System.Windows.Forms.ListView)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top
Public Methods
 | Name | Description
Public Method | ArrangeIcons | Overloaded. Arranges items in the control when they are displayed as icons with a specified alignment setting. (Inherited from System.Windows.Forms.ListView)
Public Method | AutoResizeColumn | Resizes the width of the given column as indicated by the resize style. (Inherited from System.Windows.Forms.ListView)
Public Method | AutoResizeColumns | Resizes the width of the columns as indicated by the resize style. (Inherited from System.Windows.Forms.ListView)
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | Prevents the control from drawing until the System.Windows.Forms.ListView.EndUpdate method is called. (Inherited from System.Windows.Forms.ListView)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Removes all items and columns from the control. (Inherited from System.Windows.Forms.ListView)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | Resumes drawing of the list view control after drawing is suspended by the System.Windows.Forms.ListView.BeginUpdate method. (Inherited from System.Windows.Forms.ListView)
Public Method | EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary. (Inherited from System.Windows.Forms.ListView)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | FindItemWithText | Overloaded. Finds the first System.Windows.Forms.ListViewItem that begins with the specified text value. (Inherited from System.Windows.Forms.ListView)
Public Method | FindNearestItem | Overloaded. Finds the next item from the given point, searching in the specified direction (Inherited from System.Windows.Forms.ListView)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetItemAt | Retrieves the item at the specified location. (Inherited from System.Windows.Forms.ListView)
Public Method | GetItemRect | Overloaded. Retrieves the bounding rectangle for a specific item within the list view control. (Inherited from System.Windows.Forms.ListView)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | HitTest | Overloaded. Provides item information, given a point. (Inherited from System.Windows.Forms.ListView)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RedrawItems | Forces a range of System.Windows.Forms.ListViewItem objects to be redrawn. (Inherited from System.Windows.Forms.ListView)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | Sort | Sorts the items of the list view. (Inherited from System.Windows.Forms.ListView)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a string representation of the System.Windows.Forms.ListView control. (Inherited from System.Windows.Forms.ListView)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top
Public Events
 | Name | Description
Public Event | AfterLabelEdit | Occurs when the label for an item is edited by the user. (Inherited from System.Windows.Forms.ListView)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BeforeLabelEdit | Occurs when the user starts editing the label of an item. (Inherited from System.Windows.Forms.ListView)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CacheVirtualItems | Occurs when the contents of the display area for a System.Windows.Forms.ListView in virtual mode has changed, and the System.Windows.Forms.ListView determines that a new range of items is needed. (Inherited from System.Windows.Forms.ListView)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ColumnClick | Occurs when the user clicks a column header within the list view control. (Inherited from System.Windows.Forms.ListView)
Public Event | ColumnReordered | Occurs when the column header order is changed. (Inherited from System.Windows.Forms.ListView)
Public Event | ColumnWidthChanged | Occurs after the width of a column is successfully changed. (Inherited from System.Windows.Forms.ListView)
Public Event | ColumnWidthChanging | Occurs when the width of a column is changing. (Inherited from System.Windows.Forms.ListView)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DrawColumnHeader | Occurs when the details view of a System.Windows.Forms.ListView is drawn and the System.Windows.Forms.ListView.OwnerDraw property is set to true. (Inherited from System.Windows.Forms.ListView)
Public Event | DrawItem | Occurs when a System.Windows.Forms.ListView is drawn and the System.Windows.Forms.ListView.OwnerDraw property is set to true. (Inherited from System.Windows.Forms.ListView)
Public Event | DrawSubItem | Occurs when the details view of a System.Windows.Forms.ListView is drawn and the System.Windows.Forms.ListView.OwnerDraw property is set to true. (Inherited from System.Windows.Forms.ListView)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | ItemActivate | Occurs when an item is activated. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemCheck | Occurs when the check state of an item changes. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemChecked | Occurs when the checked state of an item changes. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemDrag | Occurs when the user begins dragging an item. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemMouseHover | Occurs when the mouse hovers over an item. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemSelectionChanged | Occurs when the selection state of an item changes. (Inherited from System.Windows.Forms.ListView)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RetrieveVirtualItem | Occurs when the System.Windows.Forms.ListView is in virtual mode and requires a System.Windows.Forms.ListViewItem. (Inherited from System.Windows.Forms.ListView)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | Occurs when the value of the System.Windows.Forms.ListView.RightToLeftLayout property changes. (Inherited from System.Windows.Forms.ListView)
Public Event | SearchForVirtualItem | Occurs when the System.Windows.Forms.ListView is in virtual mode and a search is taking place. (Inherited from System.Windows.Forms.ListView)
Public Event | SelectedFileAttachmentChanged | Gets or sets the event that is fired when the selected file attachment is changed.
Public Event | SelectedIndexChanged | Occurs when the System.Windows.Forms.ListView.SelectedIndices collection changes. (Inherited from System.Windows.Forms.ListView)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VirtualItemsSelectionRangeChanged | Occurs when a System.Windows.Forms.ListView is in virtual mode and the selection state of a range of items has changed. (Inherited from System.Windows.Forms.ListView)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFFileAttachmentsView Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFFileAttachmentsView Constructor

O2S.Components.PDFView4NET Namespace > PDFFileAttachmentsView Class : PDFFileAttachmentsView Constructor
Initializes a new PDFFileAttachmentsView object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFileAttachmentsView()
public PDFFileAttachmentsView()
public: PDFFileAttachmentsView();
public:
PDFFileAttachmentsView();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentsView Class
PDFFileAttachmentsView Members


%%PageItemTitle%% $$Properties$$

PDFFileAttachmentsView Class Properties

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentsView Class

For a list of all members of this type, see PDFFileAttachmentsView members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | Activation | Gets or sets the type of action the user must take to activate an item. (Inherited from System.Windows.Forms.ListView)
Public Property | Alignment | Gets or sets the alignment of items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | AllowColumnReorder | Gets or sets a value indicating whether the user can drag column headers to reorder columns in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoArrange | Gets or sets whether icons are automatically kept arranged. (Inherited from System.Windows.Forms.ListView)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from System.Windows.Forms.ListView)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageTiled | Gets or sets a value indicating whether the background image of the System.Windows.Forms.ListView should be tiled. (Inherited from System.Windows.Forms.ListView)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style of the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | CheckedIndices | Gets the indexes of the currently checked items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | CheckedItems | Gets the currently checked items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Columns | Gets the collection of all column headers that appear in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the PDF document for which the file attachments are displayed.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | FocusedItem | Gets or sets the item in the control that currently has focus. (Inherited from System.Windows.Forms.ListView)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color. (Inherited from System.Windows.Forms.ListView)
Public Property | FullRowSelect | Gets or sets a value indicating whether clicking an item selects all its subitems. (Inherited from System.Windows.Forms.ListView)
Public Property | GridLines | Gets or sets a value indicating whether grid lines appear between the rows and columns containing the items and subitems in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Groups | Gets the collection of System.Windows.Forms.ListViewGroup objects assigned to the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | HeaderStyle | Gets or sets the column header style. (Inherited from System.Windows.Forms.ListView)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HideSelection | Gets or sets a value indicating whether the selected item in the control remains highlighted when the control loses focus. (Inherited from System.Windows.Forms.ListView)
Public Property | HotTracking | Gets or sets a value indicating whether the text of an item or subitem has the appearance of a hyperlink when the mouse pointer passes over it. (Inherited from System.Windows.Forms.ListView)
Public Property | HoverSelection | Gets or sets a value indicating whether an item is automatically selected when the mouse pointer remains over the item for a few seconds. (Inherited from System.Windows.Forms.ListView)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InsertionMark | Gets an object used to indicate the expected drop location when an item is dragged within a System.Windows.Forms.ListView control. (Inherited from System.Windows.Forms.ListView)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | Items | Gets a collection containing all items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | LabelEdit | Gets or sets a value indicating whether the user can edit the labels of items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | LabelWrap | Gets or sets a value indicating whether item labels wrap when items are displayed in the control as icons. (Inherited from System.Windows.Forms.ListView)
Public Property | LargeImageList | Gets or sets the System.Windows.Forms.ImageList to use when displaying items as large icons in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | ListViewItemSorter | Gets or sets the sorting comparer for the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MultiSelect | Gets or sets a value indicating whether multiple items can be selected. (Inherited from System.Windows.Forms.ListView)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | OwnerDraw | Gets or sets a value indicating whether the System.Windows.Forms.ListView control is drawn by the operating system or by code that you provide. (Inherited from System.Windows.Forms.ListView)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | Gets or sets a value indicating whether the control is laid out from right to left. (Inherited from System.Windows.Forms.ListView)
Public Property | Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items. (Inherited from System.Windows.Forms.ListView)
Public Property | SelectedFileAttachment | Gets or sets the selected file attachment in the list.
Public Property | SelectedIndices | Gets the indexes of the selected items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | SelectedItems | Gets the items that are selected in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | ShowGroups | Gets or sets a value indicating whether items are displayed in groups. (Inherited from System.Windows.Forms.ListView)
Public Property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are shown for the System.Windows.Forms.ListViewItem objects contained in the System.Windows.Forms.ListView. (Inherited from System.Windows.Forms.ListView)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | SmallImageList | Gets or sets the System.Windows.Forms.ImageList to use when displaying items as small icons in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | Sorting | Gets or sets the sort order for items in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | StateImageList | Gets or sets the System.Windows.Forms.ImageList associated with application-defined states in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | TileSize | Gets or sets the size of the tiles shown in tile view. (Inherited from System.Windows.Forms.ListView)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopItem | Gets or sets the first visible item in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseCompatibleStateImageBehavior | Gets or sets a value indicating whether the System.Windows.Forms.ListView uses state image behavior that is compatible with the .NET Framework 1.1 or the .NET Framework 2.0. (Inherited from System.Windows.Forms.ListView)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | View | Gets or sets how items are displayed in the control. (Inherited from System.Windows.Forms.ListView)
Public Property | VirtualListSize | Gets or sets the number of System.Windows.Forms.ListViewItem objects contained in the list when in virtual mode. (Inherited from System.Windows.Forms.ListView)
Public Property | VirtualMode | Gets or sets a value indicating whether you have provided your own data-management operations for the System.Windows.Forms.ListView control. (Inherited from System.Windows.Forms.ListView)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFFileAttachmentsView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Document Property (PDFFileAttachmentsView)

O2S.Components.PDFView4NET Namespace > PDFFileAttachmentsView Class : Document Property
Gets or sets the PDF document for which the file attachments are displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The document for which the annotations are displayed")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
Public Property Document As PDFDocument
'Usage

Dim instance As PDFFileAttachmentsView
Dim value As PDFDocument

instance.Document = value

value = instance.Document
[Description("The document for which the annotations are displayed")]
[DefaultValue()]
[Category("PDF")]
public PDFDocument Document {get; set;}
[Description("The document for which the annotations are displayed")]
[DefaultValue()]
[Category("PDF")]
public: __property PDFDocument* get_Document();
public: __property void set_Document(
   PDFDocument* value
);
[Description("The document for which the annotations are displayed")]
[DefaultValue()]
[Category("PDF")]
public:
property PDFDocument^ Document {
   PDFDocument^ get();
   void set (    PDFDocument^ value);
}

Property Value

A PDFDocument object specifying the document for which the file attachments are displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentsView Class
PDFFileAttachmentsView Members


%%ItemTitle%%

SelectedFileAttachment Property

O2S.Components.PDFView4NET Namespace > PDFFileAttachmentsView Class : SelectedFileAttachment Property
Gets or sets the selected file attachment in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property SelectedFileAttachment As PDFFileAttachment
'Usage

Dim instance As PDFFileAttachmentsView
Dim value As PDFFileAttachment

instance.SelectedFileAttachment = value

value = instance.SelectedFileAttachment
[Browsable(false)]
public PDFFileAttachment SelectedFileAttachment {get; set;}
[Browsable(false)]
public: __property PDFFileAttachment* get_SelectedFileAttachment();
public: __property void set_SelectedFileAttachment(
   PDFFileAttachment* value
);
[Browsable(false)]
public:
property PDFFileAttachment^ SelectedFileAttachment {
   PDFFileAttachment^ get();
   void set (    PDFFileAttachment^ value);
}

Property Value

A PDFFileAttachment object specifying the selected attachment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentsView Class
PDFFileAttachmentsView Members


%%PageItemTitle%% $$Events$$

PDFFileAttachmentsView Class Events

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentsView Class

For a list of all members of this type, see PDFFileAttachmentsView members.

Public Events
 | Name | Description
Public Event | AfterLabelEdit | Occurs when the label for an item is edited by the user. (Inherited from System.Windows.Forms.ListView)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BeforeLabelEdit | Occurs when the user starts editing the label of an item. (Inherited from System.Windows.Forms.ListView)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CacheVirtualItems | Occurs when the contents of the display area for a System.Windows.Forms.ListView in virtual mode has changed, and the System.Windows.Forms.ListView determines that a new range of items is needed. (Inherited from System.Windows.Forms.ListView)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ColumnClick | Occurs when the user clicks a column header within the list view control. (Inherited from System.Windows.Forms.ListView)
Public Event | ColumnReordered | Occurs when the column header order is changed. (Inherited from System.Windows.Forms.ListView)
Public Event | ColumnWidthChanged | Occurs after the width of a column is successfully changed. (Inherited from System.Windows.Forms.ListView)
Public Event | ColumnWidthChanging | Occurs when the width of a column is changing. (Inherited from System.Windows.Forms.ListView)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DrawColumnHeader | Occurs when the details view of a System.Windows.Forms.ListView is drawn and the System.Windows.Forms.ListView.OwnerDraw property is set to true. (Inherited from System.Windows.Forms.ListView)
Public Event | DrawItem | Occurs when a System.Windows.Forms.ListView is drawn and the System.Windows.Forms.ListView.OwnerDraw property is set to true. (Inherited from System.Windows.Forms.ListView)
Public Event | DrawSubItem | Occurs when the details view of a System.Windows.Forms.ListView is drawn and the System.Windows.Forms.ListView.OwnerDraw property is set to true. (Inherited from System.Windows.Forms.ListView)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | ItemActivate | Occurs when an item is activated. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemCheck | Occurs when the check state of an item changes. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemChecked | Occurs when the checked state of an item changes. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemDrag | Occurs when the user begins dragging an item. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemMouseHover | Occurs when the mouse hovers over an item. (Inherited from System.Windows.Forms.ListView)
Public Event | ItemSelectionChanged | Occurs when the selection state of an item changes. (Inherited from System.Windows.Forms.ListView)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RetrieveVirtualItem | Occurs when the System.Windows.Forms.ListView is in virtual mode and requires a System.Windows.Forms.ListViewItem. (Inherited from System.Windows.Forms.ListView)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | Occurs when the value of the System.Windows.Forms.ListView.RightToLeftLayout property changes. (Inherited from System.Windows.Forms.ListView)
Public Event | SearchForVirtualItem | Occurs when the System.Windows.Forms.ListView is in virtual mode and a search is taking place. (Inherited from System.Windows.Forms.ListView)
Public Event | SelectedFileAttachmentChanged | Gets or sets the event that is fired when the selected file attachment is changed.
Public Event | SelectedIndexChanged | Occurs when the System.Windows.Forms.ListView.SelectedIndices collection changes. (Inherited from System.Windows.Forms.ListView)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VirtualItemsSelectionRangeChanged | Occurs when a System.Windows.Forms.ListView is in virtual mode and the selection state of a range of items has changed. (Inherited from System.Windows.Forms.ListView)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFFileAttachmentsView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

SelectedFileAttachmentChanged Event

O2S.Components.PDFView4NET Namespace > PDFFileAttachmentsView Class : SelectedFileAttachmentChanged Event
Gets or sets the event that is fired when the selected file attachment is changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DefaultValueAttribute()>
<DescriptionAttribute("The event that is fired when the select file attachment changes")>
Public Event SelectedFileAttachmentChanged As EventHandler
'Usage

Dim instance As PDFFileAttachmentsView
Dim handler As EventHandler

AddHandler instance.SelectedFileAttachmentChanged, handler
[Category("PDF")]
[DefaultValue()]
[Description("The event that is fired when the select file attachment changes")]
public event EventHandler SelectedFileAttachmentChanged
[Category("PDF")]
[DefaultValue()]
[Description("The event that is fired when the select file attachment changes")]
public: __event EventHandler* SelectedFileAttachmentChanged
[Category("PDF")]
[DefaultValue()]
[Description("The event that is fired when the select file attachment changes")]
public:
event EventHandler^ SelectedFileAttachmentChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentsView Class
PDFFileAttachmentsView Members


%%PageItemTitle%%

PDFFileAttachmentsViewCollection Class
Members

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentsViewCollection Class
Defines a collection of PDFFileAttachmentsView objects representing the viewers for a document's file attachments.
Object Model
PDFFileAttachmentsViewCollection ClassPDFFileAttachmentsView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFileAttachmentsViewCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFFileAttachmentsView,PDFDocument)
'Usage

Dim instance As PDFFileAttachmentsViewCollection
public class PDFFileAttachmentsViewCollection : O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachmentsView,PDFDocument>
public __gc class PDFFileAttachmentsViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachmentsView,PDFDocument>
public ref class PDFFileAttachmentsViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachmentsView,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.PDFFileAttachmentsViewCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentsViewCollection Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFFileAttachmentsViewCollection Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentsViewCollection Class

The following tables list the members exposed by PDFFileAttachmentsViewCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachmentsView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Top
See Also

Reference

PDFFileAttachmentsViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFGraphicsContainer Class
Members

O2S.Components.PDFView4NET Namespace : PDFGraphicsContainer Class
Defines an abstract object that can store graphic content.
Object Model
PDFGraphicsContainer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFGraphicsContainer
'Usage

Dim instance As PDFGraphicsContainer
public abstract class PDFGraphicsContainer
public __gc abstract class PDFGraphicsContainer
public ref class PDFGraphicsContainer abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFGraphicsContainer
O2S.Components.PDFView4NET.PDFPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGraphicsContainer Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFGraphicsContainer Class Members

O2S.Components.PDFView4NET Namespace : PDFGraphicsContainer Class

The following tables list the members exposed by PDFGraphicsContainer.

See Also

Reference

PDFGraphicsContainer Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFMatrix Class
Members

O2S.Components.PDFView4NET Namespace : PDFMatrix Class
Defines a tranformation matrix in the PDF content stream.
Object Model
PDFMatrix Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMatrix
'Usage

Dim instance As PDFMatrix
public class PDFMatrix
public __gc class PDFMatrix
public ref class PDFMatrix
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFMatrix

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFMatrix Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFMatrix Class

The following tables list the members exposed by PDFMatrix.

Public Constructors
 | Name | Description
Public Constructor | PDFMatrix Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | M11 | Gets or sets the m11 element of the matrix.
Public Property | M12 | Gets or sets the m12 element of the matrix.
Public Property | M21 | Gets or sets the m21 element of the matrix.
Public Property | M22 | Gets or sets the m22 element of the matrix.
Public Property | TX | Gets or sets the tx element of the matrix.
Public Property | TY | Gets or sets the ty element of the matrix.
Top
Public Methods
 | Name | Description
Public Method | Multiply | Multiplies this matrix with another one.
Public Method | Rotate | Rotates the matrix with the specified angle.
Public Method | Scale | Scales the matrix.
Public Method | ToString | Converts the matrix to string representation.
Public Method | TransformPoint | Overloaded. Transforms the point with the affine transformation specifies by this matrix.
Public Method | TransformPoints | Transforms the point with the affine transformation specifies by this matrix.
Public Method | TransformVector | Overloaded. Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Public Method | TransformVectors | Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Public Method | Translate | Translates the matrix.
Top
See Also

Reference

PDFMatrix Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFMatrix Constructor

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : PDFMatrix Constructor
Overload List
Overload | Description
PDFMatrix Constructor() | Initializes a new PDFMatrix object.
PDFMatrix Constructor(Double,Double,Double,Double,Double,Double) | Initializes a new PDFMatrix object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%PageItemTitle%%

PDFMatrix Constructor()

O2S.Components.PDFView4NET Namespace > PDFMatrix Class > PDFMatrix Constructor : PDFMatrix Constructor()
Initializes a new PDFMatrix object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMatrix()
public PDFMatrix()
public: PDFMatrix();
public:
PDFMatrix();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


%%PageItemTitle%%

PDFMatrix Constructor(Double,Double,Double,Double,Double,Double)

O2S.Components.PDFView4NET Namespace > PDFMatrix Class > PDFMatrix Constructor : PDFMatrix Constructor(Double,Double,Double,Double,Double,Double)
The element located at row 1, column 1 in the matrix.
The element located at row 1, column 2 in the matrix.
The element located at row 2, column 1 in the matrix.
The element located at row 2, column 2 in the matrix.
The X translation offset.
The Y translation offset.
Initializes a new PDFMatrix object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal m11 As Double, _
   ByVal m12 As Double, _
   ByVal m21 As Double, _
   ByVal m22 As Double, _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim m11 As Double
Dim m12 As Double
Dim m21 As Double
Dim m22 As Double
Dim tx As Double
Dim ty As Double

Dim instance As New PDFMatrix(m11, m12, m21, m22, tx, ty)
public PDFMatrix(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)
public: PDFMatrix(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)
public:
PDFMatrix(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)

Parameters

m11
The element located at row 1, column 1 in the matrix.
m12
The element located at row 1, column 2 in the matrix.
m21
The element located at row 2, column 1 in the matrix.
m22
The element located at row 2, column 2 in the matrix.
tx
The X translation offset.
ty
The Y translation offset.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFMatrix Class Methods

O2S.Components.PDFView4NET Namespace : PDFMatrix Class

For a list of all members of this type, see PDFMatrix members.

Public Methods
 | Name | Description
Public Method | Multiply | Multiplies this matrix with another one.
Public Method | Rotate | Rotates the matrix with the specified angle.
Public Method | Scale | Scales the matrix.
Public Method | ToString | Converts the matrix to string representation.
Public Method | TransformPoint | Overloaded. Transforms the point with the affine transformation specifies by this matrix.
Public Method | TransformPoints | Transforms the point with the affine transformation specifies by this matrix.
Public Method | TransformVector | Overloaded. Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Public Method | TransformVectors | Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Public Method | Translate | Translates the matrix.
Top
See Also

Reference

PDFMatrix Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Multiply Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : Multiply Method
Matrix to multiply this one to.
Multiplies this matrix with another one.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Multiply( _
   ByVal matrix As PDFMatrix _
)
'Usage

Dim instance As PDFMatrix
Dim matrix As PDFMatrix

instance.Multiply(matrix)
public void Multiply(
   PDFMatrix matrix
)
public: void Multiply(
   PDFMatrix* matrix
)
public:
void Multiply(
   PDFMatrix^ matrix
)

Parameters

matrix
Matrix to multiply this one to.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

Rotate Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : Rotate Method
Angle (degrees) to rotate the matrix.
Rotates the matrix with the specified angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal angle As Double _
)
'Usage

Dim instance As PDFMatrix
Dim angle As Double

instance.Rotate(angle)
public void Rotate(
   double angle
)
public: void Rotate(
   double angle
)
public:
void Rotate(
   double angle
)

Parameters

angle
Angle (degrees) to rotate the matrix.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

Scale Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : Scale Method
X scale factor.
Y scale factor.
Scales the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Scale( _
   ByVal sx As Double, _
   ByVal sy As Double _
)
'Usage

Dim instance As PDFMatrix
Dim sx As Double
Dim sy As Double

instance.Scale(sx, sy)
public void Scale(
   double sx,
   double sy
)
public: void Scale(
   double sx,
   double sy
)
public:
void Scale(
   double sx,
   double sy
)

Parameters

sx
X scale factor.
sy
Y scale factor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

ToString Method (PDFMatrix)

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : ToString Method
Converts the matrix to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFMatrix
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

TransformPoint Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : TransformPoint Method
Transforms the point with the affine transformation specifies by this matrix.
Overload List
Overload | Description
TransformPoint(PDFPoint) | Transforms the point with the affine transformation specifies by this matrix.
TransformPoint(Double,Double) | Transforms the point with the affine transformation specifies by this matrix.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

TransformPoint(PDFPoint) Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class > TransformPoint Method : TransformPoint(PDFPoint) Method
Transforms the point with the affine transformation specifies by this matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TransformPoint( _
   ByVal srcPoint As PDFPoint _
) As PDFPoint
'Usage

Dim instance As PDFMatrix
Dim srcPoint As PDFPoint
Dim value As PDFPoint

value = instance.TransformPoint(srcPoint)
public PDFPoint TransformPoint(
   PDFPoint srcPoint
)
public: PDFPoint* TransformPoint(
   PDFPoint* srcPoint
)
public:
PDFPoint^ TransformPoint(
   PDFPoint^ srcPoint
)

Parameters

srcPoint

Return Value

Transformed point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


%%ItemTitle%%

TransformPoint(Double,Double) Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class > TransformPoint Method : TransformPoint(Double,Double) Method
X coordinate.
Y coordinate.
Transforms the point with the affine transformation specifies by this matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TransformPoint( _
   ByVal x As Double, _
   ByVal y As Double _
) As PDFPoint
'Usage

Dim instance As PDFMatrix
Dim x As Double
Dim y As Double
Dim value As PDFPoint

value = instance.TransformPoint(x, y)
public PDFPoint TransformPoint(
   double x,
   double y
)
public: PDFPoint* TransformPoint(
   double x,
   double y
)
public:
PDFPoint^ TransformPoint(
   double x,
   double y
)

Parameters

x
X coordinate.
y
Y coordinate.

Return Value

Transformed point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


%%ItemTitle%%

TransformPoints Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : TransformPoints Method
Transforms the point with the affine transformation specifies by this matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub TransformPoints( _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFMatrix
Dim points() As PDFPoint

instance.TransformPoints(points)
public void TransformPoints(
   PDFPoint[] points
)
public: void TransformPoints(
   PDFPoint*[]* points
)
public:
void TransformPoints(
   array<PDFPoint^>^ points
)

Parameters

points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

TransformVector Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : TransformVector Method
Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Overload List
Overload | Description
TransformVector(PDFPoint) | Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
TransformVector(Double,Double) | Transforms the point with the affine transformation specifies by this matrix and ignores the translation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

TransformVector(PDFPoint) Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class > TransformVector Method : TransformVector(PDFPoint) Method
Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TransformVector( _
   ByVal srcPoint As PDFPoint _
) As PDFPoint
'Usage

Dim instance As PDFMatrix
Dim srcPoint As PDFPoint
Dim value As PDFPoint

value = instance.TransformVector(srcPoint)
public PDFPoint TransformVector(
   PDFPoint srcPoint
)
public: PDFPoint* TransformVector(
   PDFPoint* srcPoint
)
public:
PDFPoint^ TransformVector(
   PDFPoint^ srcPoint
)

Parameters

srcPoint

Return Value

Transformed point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


%%ItemTitle%%

TransformVector(Double,Double) Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class > TransformVector Method : TransformVector(Double,Double) Method
X coordinate.
Y coordinate.
Transforms the point with the affine transformation specifies by this matrix and ignores the translation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TransformVector( _
   ByVal x As Double, _
   ByVal y As Double _
) As PDFPoint
'Usage

Dim instance As PDFMatrix
Dim x As Double
Dim y As Double
Dim value As PDFPoint

value = instance.TransformVector(x, y)
public PDFPoint TransformVector(
   double x,
   double y
)
public: PDFPoint* TransformVector(
   double x,
   double y
)
public:
PDFPoint^ TransformVector(
   double x,
   double y
)

Parameters

x
X coordinate.
y
Y coordinate.

Return Value

Transformed point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members
Overload List


%%ItemTitle%%

TransformVectors Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : TransformVectors Method
Transforms the point with the affine transformation specifies by this matrix and ignores the translation values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub TransformVectors( _
   ByVal points() As PDFPoint _
)
'Usage

Dim instance As PDFMatrix
Dim points() As PDFPoint

instance.TransformVectors(points)
public void TransformVectors(
   PDFPoint[] points
)
public: void TransformVectors(
   PDFPoint*[]* points
)
public:
void TransformVectors(
   array<PDFPoint^>^ points
)

Parameters

points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

Translate Method

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : Translate Method
x translation offset.
y translation offset.
Translates the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Translate( _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim instance As PDFMatrix
Dim tx As Double
Dim ty As Double

instance.Translate(tx, ty)
public void Translate(
   double tx,
   double ty
)
public: void Translate(
   double tx,
   double ty
)
public:
void Translate(
   double tx,
   double ty
)

Parameters

tx
x translation offset.
ty
y translation offset.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%PageItemTitle%% $$Properties$$

PDFMatrix Class Properties

O2S.Components.PDFView4NET Namespace : PDFMatrix Class

For a list of all members of this type, see PDFMatrix members.

Public Properties
 | Name | Description
Public Property | M11 | Gets or sets the m11 element of the matrix.
Public Property | M12 | Gets or sets the m12 element of the matrix.
Public Property | M21 | Gets or sets the m21 element of the matrix.
Public Property | M22 | Gets or sets the m22 element of the matrix.
Public Property | TX | Gets or sets the tx element of the matrix.
Public Property | TY | Gets or sets the ty element of the matrix.
Top
See Also

Reference

PDFMatrix Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

M11 Property

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : M11 Property
Gets or sets the m11 element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M11 As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.M11 = value

value = instance.M11
public double M11 {get; set;}
public: __property double get_M11();
public: __property void set_M11(
   double value
);
public:
property double M11 {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

M12 Property

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : M12 Property
Gets or sets the m12 element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M12 As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.M12 = value

value = instance.M12
public double M12 {get; set;}
public: __property double get_M12();
public: __property void set_M12(
   double value
);
public:
property double M12 {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

M21 Property

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : M21 Property
Gets or sets the m21 element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M21 As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.M21 = value

value = instance.M21
public double M21 {get; set;}
public: __property double get_M21();
public: __property void set_M21(
   double value
);
public:
property double M21 {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

M22 Property

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : M22 Property
Gets or sets the m22 element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M22 As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.M22 = value

value = instance.M22
public double M22 {get; set;}
public: __property double get_M22();
public: __property void set_M22(
   double value
);
public:
property double M22 {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

TX Property

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : TX Property
Gets or sets the tx element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TX As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.TX = value

value = instance.TX
public double TX {get; set;}
public: __property double get_TX();
public: __property void set_TX(
   double value
);
public:
property double TX {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%ItemTitle%%

TY Property

O2S.Components.PDFView4NET Namespace > PDFMatrix Class : TY Property
Gets or sets the ty element of the matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TY As Double
'Usage

Dim instance As PDFMatrix
Dim value As Double

instance.TY = value

value = instance.TY
public double TY {get; set;}
public: __property double get_TY();
public: __property void set_TY(
   double value
);
public:
property double TY {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix Class
PDFMatrix Members


%%PageItemTitle%%

PDFNamedDestination Class
Members

O2S.Components.PDFView4NET Namespace : PDFNamedDestination Class
Defines a named PDF destination.
Object Model
PDFNamedDestination ClassPDFDirectDestination Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFNamedDestination
   Inherits PDFDestination
'Usage

Dim instance As PDFNamedDestination
public class PDFNamedDestination : PDFDestination
public __gc class PDFNamedDestination : public PDFDestination
public ref class PDFNamedDestination : public PDFDestination
Remarks
A named destination associates a name with a direct PDF destination and allows to refer to that destination by its name.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFDestination
O2S.Components.PDFView4NET.PDFNamedDestination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedDestination Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFNamedDestination Class Members
Properties Events

O2S.Components.PDFView4NET Namespace : PDFNamedDestination Class

The following tables list the members exposed by PDFNamedDestination.

Public Constructors
 | Name | Description
Public Constructor | PDFNamedDestination Constructor | Initializes a new PDFNamedDestination object.
Top
Public Properties
 | Name | Description
Public Property | Destination | Gets or sets the destination.
Public Property | Name | Gets or sets the destination name.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFNamedDestination Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFNamedDestination Constructor

O2S.Components.PDFView4NET Namespace > PDFNamedDestination Class : PDFNamedDestination Constructor
Initializes a new PDFNamedDestination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFNamedDestination()
public PDFNamedDestination()
public: PDFNamedDestination();
public:
PDFNamedDestination();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedDestination Class
PDFNamedDestination Members


%%PageItemTitle%% $$Properties$$

PDFNamedDestination Class Properties

O2S.Components.PDFView4NET Namespace : PDFNamedDestination Class

For a list of all members of this type, see PDFNamedDestination members.

Public Properties
 | Name | Description
Public Property | Destination | Gets or sets the destination.
Public Property | Name | Gets or sets the destination name.
Top
See Also

Reference

PDFNamedDestination Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Destination Property (PDFNamedDestination)

O2S.Components.PDFView4NET Namespace > PDFNamedDestination Class : Destination Property
Gets or sets the destination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Destination As PDFDirectDestination
'Usage

Dim instance As PDFNamedDestination
Dim value As PDFDirectDestination

instance.Destination = value

value = instance.Destination
public PDFDirectDestination Destination {get; set;}
public: __property PDFDirectDestination* get_Destination();
public: __property void set_Destination(
   PDFDirectDestination* value
);
public:
property PDFDirectDestination^ Destination {
   PDFDirectDestination^ get();
   void set (    PDFDirectDestination^ value);
}

Property Value

The direct destination that can be refered by its associated name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedDestination Class
PDFNamedDestination Members


%%ItemTitle%%

Name Property (PDFNamedDestination)

O2S.Components.PDFView4NET Namespace > PDFNamedDestination Class : Name Property
Gets or sets the destination name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFNamedDestination
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The name to be user for refering the associated destination.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedDestination Class
PDFNamedDestination Members


%%PageItemTitle%% $$Events$$

PDFNamedDestination Class Events

O2S.Components.PDFView4NET Namespace : PDFNamedDestination Class

For a list of all members of this type, see PDFNamedDestination members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFNamedDestination Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

PropertyChanged Event (PDFNamedDestination)

O2S.Components.PDFView4NET Namespace > PDFNamedDestination Class : PropertyChanged Event
Gets or sets the event that is fired when a property has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As PDFNamedDestination
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedDestination Class
PDFNamedDestination Members


%%PageItemTitle%%

PDFNamedDestinationCollection Class
Members

O2S.Components.PDFView4NET Namespace : PDFNamedDestinationCollection Class
Defines a collection of named destinations.
Object Model
PDFNamedDestinationCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PDFNamedDestinationCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFNamedDestination,PDFDocument)
'Usage

Dim instance As PDFNamedDestinationCollection
[DefaultMember("Item")]
public class PDFNamedDestinationCollection : O2S.Components.PDFView4NET.PDFCollection<PDFNamedDestination,PDFDocument>
[DefaultMember("Item")]
public __gc class PDFNamedDestinationCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFNamedDestination,PDFDocument>
[DefaultMember("Item")]
public ref class PDFNamedDestinationCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFNamedDestination,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.PDFNamedDestinationCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedDestinationCollection Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFNamedDestinationCollection Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFNamedDestinationCollection Class

The following tables list the members exposed by PDFNamedDestinationCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFNamedDestination,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Top
Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFNamedDestinationCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Events$$

PDFNamedDestinationCollection Class Events

O2S.Components.PDFView4NET Namespace : PDFNamedDestinationCollection Class

For a list of all members of this type, see PDFNamedDestinationCollection members.

Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFNamedDestinationCollection Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

CollectionChanged Event (PDFNamedDestinationCollection)

O2S.Components.PDFView4NET Namespace > PDFNamedDestinationCollection Class : CollectionChanged Event
Gets or sets the event being fired when the collection has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event CollectionChanged As EventHandler(Of PDFCollectionChangedEventArgs(Of PDFNamedDestination))
'Usage

Dim instance As PDFNamedDestinationCollection
Dim handler As EventHandler(Of PDFCollectionChangedEventArgs(Of PDFNamedDestination))

AddHandler instance.CollectionChanged, handler
public event EventHandler<PDFCollectionChangedEventArgs<PDFNamedDestination>> CollectionChanged
public: __event EventHandler<PDFCollectionChangedEventArgs<PDFNamedDestination*>*>* CollectionChanged
public:
event EventHandler<PDFCollectionChangedEventArgs<PDFNamedDestination^>^>^ CollectionChanged
Event Data

The event handler receives an argument of type PDFCollectionChangedEventArgs<T> containing data related to this event. The following PDFCollectionChangedEventArgs<T> properties provide information specific to this event.

Property | Description
ChangedProperty | Gets the name of changed property when the change type is item update.
ChangeType | Gets the type of change event.
NewItem | Gets the new item involved in the operation.
OldItem | Gets the old item involved in the operation.
Position | Gets the position of the affected item in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedDestinationCollection Class
PDFNamedDestinationCollection Members


%%PageItemTitle%%

PDFPage Class
Members

O2S.Components.PDFView4NET Namespace : PDFPage Class
Defines a PDF page.
Object Model
PDFPage ClassPDFAnnotationCollection ClassPDFAnnotation ClassPDFDocument ClassPDFFieldCollection ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFPage
   Inherits PDFGraphicsContainer
   Implements IRawPDFData
'Usage

Dim instance As PDFPage
[Serializable()]
public class PDFPage : PDFGraphicsContainer, IRawPDFData
[Serializable()]
public __gc class PDFPage : public PDFGraphicsContainer, IRawPDFData
[Serializable()]
public ref class PDFPage : public PDFGraphicsContainer, IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFGraphicsContainer
O2S.Components.PDFView4NET.PDFPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPage Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFPage Class

The following tables list the members exposed by PDFPage.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the list of page annotations.
Public Property | CropBox | Gets the page crop box.
Public Property | Document | Gets or sets the document that includes this page.
Public Property | Fields | Gets the list of fields defined on this page.
Public Property | Height | Gets the height of the physical page.
Public Property | MediaBox | Gets the page media box.
Public Property | Rotation | Gets or sets the page rotation angle.
Public Property | VisibleHeight | Gets the height of the visible page.
Public Property | VisibleWidth | Gets the width of the visible page.
Public Property | Width | Gets the width of the physical page.
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones this page.
Public Method | ConvertToImage | Overloaded. Converts the page to bitmap.
Public Method | ExtractText | Extracts the text from the PDF page.
Public Method | ExtractTextRuns | Extracts the text runs from the PDF page.
Public Method | GetObjectData | Serializes the page.
Public Method | GetRawValue | Gets the value of the specified key.
Public Method | Render | Overloaded. Renders the page on a graphics surface.
Public Method | SearchText | Overloaded. Searches the page for the given text.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Public Event | RotationChanged | Fired after the page rotation has changed.
Top
See Also

Reference

PDFPage Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFPage Class Methods

O2S.Components.PDFView4NET Namespace : PDFPage Class

For a list of all members of this type, see PDFPage members.

Public Methods
 | Name | Description
Public Method | Clone | Clones this page.
Public Method | ConvertToImage | Overloaded. Converts the page to bitmap.
Public Method | ExtractText | Extracts the text from the PDF page.
Public Method | ExtractTextRuns | Extracts the text runs from the PDF page.
Public Method | GetObjectData | Serializes the page.
Public Method | GetRawValue | Gets the value of the specified key.
Public Method | Render | Overloaded. Renders the page on a graphics surface.
Public Method | SearchText | Overloaded. Searches the page for the given text.
Top
See Also

Reference

PDFPage Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Clone Method (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : Clone Method
Clones this page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As Object
'Usage

Dim instance As PDFPage
Dim value As Object

value = instance.Clone()
public object Clone()
public: Object* Clone();
public:
Object^ Clone();

Return Value

The new page object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

ConvertToImage Method

O2S.Components.PDFView4NET Namespace > PDFPage Class : ConvertToImage Method
Converts the page to bitmap.
Overload List
Overload | Description
ConvertToImage(Double) | Converts the page to bitmap.
ConvertToImage(Double,PDFRectangle) | Converts the page to bitmap.
ConvertToImage(Double,PDFSearchTextResultCollection,Color) | Converts the page to bitmap and highlights the specified search results.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

ConvertToImage(Double) Method

O2S.Components.PDFView4NET Namespace > PDFPage Class > ConvertToImage Method : ConvertToImage(Double) Method
Resolution used for page conversion.
Converts the page to bitmap.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertToImage( _
   ByVal resolution As Double _
) As Bitmap
'Usage

Dim instance As PDFPage
Dim resolution As Double
Dim value As Bitmap

value = instance.ConvertToImage(resolution)
public Bitmap ConvertToImage(
   double resolution
)
public: Bitmap* ConvertToImage(
   double resolution
)
public:
Bitmap^ ConvertToImage(
   double resolution
)

Parameters

resolution
Resolution used for page conversion.

Return Value

The page converted as image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members
Overload List


%%ItemTitle%%

ConvertToImage(Double,PDFRectangle) Method

O2S.Components.PDFView4NET Namespace > PDFPage Class > ConvertToImage Method : ConvertToImage(Double,PDFRectangle) Method
Resolution used for page conversion.
Area on the page to convert to image.
Converts the page to bitmap.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertToImage( _
   ByVal resolution As Double, _
   ByVal convertArea As PDFRectangle _
) As Bitmap
'Usage

Dim instance As PDFPage
Dim resolution As Double
Dim convertArea As PDFRectangle
Dim value As Bitmap

value = instance.ConvertToImage(resolution, convertArea)
public Bitmap ConvertToImage(
   double resolution,
   PDFRectangle convertArea
)
public: Bitmap* ConvertToImage(
   double resolution,
   PDFRectangle* convertArea
)
public:
Bitmap^ ConvertToImage(
   double resolution,
   PDFRectangle^ convertArea
)

Parameters

resolution
Resolution used for page conversion.
convertArea
Area on the page to convert to image.

Return Value

The area on the page converted as image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members
Overload List


%%ItemTitle%%

ConvertToImage(Double,PDFSearchTextResultCollection,Color) Method

O2S.Components.PDFView4NET Namespace > PDFPage Class > ConvertToImage Method : ConvertToImage(Double,PDFSearchTextResultCollection,Color) Method
Resolution used for page conversion.
Search results to highlight on the page.
Color for highlighting the search results.
Converts the page to bitmap and highlights the specified search results.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertToImage( _
   ByVal resolution As Double, _
   ByVal searchResults As PDFSearchTextResultCollection, _
   ByVal highlightColor As Color _
) As Bitmap
'Usage

Dim instance As PDFPage
Dim resolution As Double
Dim searchResults As PDFSearchTextResultCollection
Dim highlightColor As Color
Dim value As Bitmap

value = instance.ConvertToImage(resolution, searchResults, highlightColor)
public Bitmap ConvertToImage(
   double resolution,
   PDFSearchTextResultCollection searchResults,
   Color highlightColor
)
public: Bitmap* ConvertToImage(
   double resolution,
   PDFSearchTextResultCollection* searchResults,
   Color highlightColor
)
public:
Bitmap^ ConvertToImage(
   double resolution,
   PDFSearchTextResultCollection^ searchResults,
   Color highlightColor
)

Parameters

resolution
Resolution used for page conversion.
searchResults
Search results to highlight on the page.
highlightColor
Color for highlighting the search results.

Return Value

The page converted as image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members
Overload List


%%ItemTitle%%

ExtractText Method

O2S.Components.PDFView4NET Namespace > PDFPage Class : ExtractText Method
Extracts the text from the PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractText() As String
'Usage

Dim instance As PDFPage
Dim value As String

value = instance.ExtractText()
public string ExtractText()
public: string* ExtractText();
public:
String^ ExtractText();

Return Value

The text content of the page.
Remarks
The text returned by this method appears in the order it is defined in the page content stream, not in the visual order as it appears in the viewer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

ExtractTextRuns Method

O2S.Components.PDFView4NET Namespace > PDFPage Class : ExtractTextRuns Method
Extracts the text runs from the PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ExtractTextRuns() As PDFTextRunCollection
'Usage

Dim instance As PDFPage
Dim value As PDFTextRunCollection

value = instance.ExtractTextRuns()
public PDFTextRunCollection ExtractTextRuns()
public: PDFTextRunCollection* ExtractTextRuns();
public:
PDFTextRunCollection^ ExtractTextRuns();

Return Value

The collection of text runs included in the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

GetObjectData Method (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : GetObjectData Method
Serialization information.
Streaming context.
Serializes the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFPage
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
Serialization information.
context
Streaming context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

GetRawValue Method (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : GetRawValue Method
The key in the action for which the value has been requested.
Gets the value of the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRawValue( _
   ByVal key As String _
) As String
'Usage

Dim instance As PDFPage
Dim key As String
Dim value As String

value = instance.GetRawValue(key)
public string GetRawValue(
   string key
)
public: string* GetRawValue(
   string* key
)
public:
String^ GetRawValue(
   String^ key
)

Parameters

key
The key in the action for which the value has been requested.

Return Value

The value of the given key, or null if the action does not contain the key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

Render Method

O2S.Components.PDFView4NET Namespace > PDFPage Class : Render Method
Renders the page on a graphics surface.
Overload List
Overload | Description
Render(Graphics,Double,Double) | Renders the page on a graphics surface.
Render(Graphics,Double,Double,PDFPrintContent) | Renders the page on a graphics surface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

Render(Graphics,Double,Double) Method

O2S.Components.PDFView4NET Namespace > PDFPage Class > Render Method : Render(Graphics,Double,Double) Method
The drawing surface.
The X coordinate of the top left corner of the page.
The Y coordinate of the top left corner of the page.
Renders the page on a graphics surface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Render( _
   ByVal g As Graphics, _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PDFPage
Dim g As Graphics
Dim x As Double
Dim y As Double

instance.Render(g, x, y)
public void Render(
   Graphics g,
   double x,
   double y
)
public: void Render(
   Graphics* g,
   double x,
   double y
)
public:
void Render(
   Graphics^ g,
   double x,
   double y
)

Parameters

g
The drawing surface.
x
The X coordinate of the top left corner of the page.
y
The Y coordinate of the top left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members
Overload List


%%ItemTitle%%

Render(Graphics,Double,Double,PDFPrintContent) Method

O2S.Components.PDFView4NET Namespace > PDFPage Class > Render Method : Render(Graphics,Double,Double,PDFPrintContent) Method
The drawing surface.
The X coordinate of the top left corner of the page.
The Y coordinate of the top left corner of the page.
Renders the page on a graphics surface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Render( _
   ByVal g As Graphics, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal printContent As PDFPrintContent _
)
'Usage

Dim instance As PDFPage
Dim g As Graphics
Dim x As Double
Dim y As Double
Dim printContent As PDFPrintContent

instance.Render(g, x, y, printContent)
public void Render(
   Graphics g,
   double x,
   double y,
   PDFPrintContent printContent
)
public: void Render(
   Graphics* g,
   double x,
   double y,
   PDFPrintContent printContent
)
public:
void Render(
   Graphics^ g,
   double x,
   double y,
   PDFPrintContent printContent
)

Parameters

g
The drawing surface.
x
The X coordinate of the top left corner of the page.
y
The Y coordinate of the top left corner of the page.
printContent
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members
Overload List


%%ItemTitle%%

SearchText Method (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : SearchText Method
Searches the page for the given text.
Overload List
Overload | Description
SearchText(String) | Searches the page for the given text.
SearchText(PDFTextRunCollection,String) | Searches a collection of text runs for the given text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

SearchText(String) Method

O2S.Components.PDFView4NET Namespace > PDFPage Class > SearchText Method : SearchText(String) Method
Text to search.
Searches the page for the given text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SearchText( _
   ByVal text As String _
) As PDFSearchTextResultCollection
'Usage

Dim instance As PDFPage
Dim text As String
Dim value As PDFSearchTextResultCollection

value = instance.SearchText(text)
public PDFSearchTextResultCollection SearchText(
   string text
)
public: PDFSearchTextResultCollection* SearchText(
   string* text
)
public:
PDFSearchTextResultCollection^ SearchText(
   String^ text
)

Parameters

text
Text to search.

Return Value

List of search results.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members
Overload List


%%ItemTitle%%

SearchText(PDFTextRunCollection,String) Method

O2S.Components.PDFView4NET Namespace > PDFPage Class > SearchText Method : SearchText(PDFTextRunCollection,String) Method
Collection of text runs.
Text to search.
Searches a collection of text runs for the given text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SearchText( _
   ByVal textRuns As PDFTextRunCollection, _
   ByVal text As String _
) As PDFSearchTextResultCollection
'Usage

Dim instance As PDFPage
Dim textRuns As PDFTextRunCollection
Dim text As String
Dim value As PDFSearchTextResultCollection

value = instance.SearchText(textRuns, text)
public PDFSearchTextResultCollection SearchText(
   PDFTextRunCollection textRuns,
   string text
)
public: PDFSearchTextResultCollection* SearchText(
   PDFTextRunCollection* textRuns,
   string* text
)
public:
PDFSearchTextResultCollection^ SearchText(
   PDFTextRunCollection^ textRuns,
   String^ text
)

Parameters

textRuns
Collection of text runs.
text
Text to search.

Return Value

List of search results.
Remarks
The collection of text runs is expected to be retrieved from the current page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPage Class Properties

O2S.Components.PDFView4NET Namespace : PDFPage Class

For a list of all members of this type, see PDFPage members.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the list of page annotations.
Public Property | CropBox | Gets the page crop box.
Public Property | Document | Gets or sets the document that includes this page.
Public Property | Fields | Gets the list of fields defined on this page.
Public Property | Height | Gets the height of the physical page.
Public Property | MediaBox | Gets the page media box.
Public Property | Rotation | Gets or sets the page rotation angle.
Public Property | VisibleHeight | Gets the height of the visible page.
Public Property | VisibleWidth | Gets the width of the visible page.
Public Property | Width | Gets the width of the physical page.
Top
See Also

Reference

PDFPage Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Annotations Property

O2S.Components.PDFView4NET Namespace > PDFPage Class : Annotations Property
Gets the list of page annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotations As PDFAnnotationCollection
'Usage

Dim instance As PDFPage
Dim value As PDFAnnotationCollection

value = instance.Annotations
public PDFAnnotationCollection Annotations {get;}
public: __property PDFAnnotationCollection* get_Annotations();
public:
property PDFAnnotationCollection^ Annotations {
   PDFAnnotationCollection^ get();
}

Property Value

The list of all annotations included on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

CropBox Property

O2S.Components.PDFView4NET Namespace > PDFPage Class : CropBox Property
Gets the page crop box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CropBox As PDFRectangle
'Usage

Dim instance As PDFPage
Dim value As PDFRectangle

value = instance.CropBox
public PDFRectangle CropBox {get;}
public: __property PDFRectangle* get_CropBox();
public:
property PDFRectangle^ CropBox {
   PDFRectangle^ get();
}

Property Value

A rectangle that defines the page crop box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

Document Property (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : Document Property
Gets or sets the document that includes this page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Document As PDFDocument
'Usage

Dim instance As PDFPage
Dim value As PDFDocument

value = instance.Document
public PDFDocument Document {get;}
public: __property PDFDocument* get_Document();
public:
property PDFDocument^ Document {
   PDFDocument^ get();
}

Property Value

The document this page belongs to.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

Fields Property (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : Fields Property
Gets the list of fields defined on this page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As PDFFieldCollection
'Usage

Dim instance As PDFPage
Dim value As PDFFieldCollection

value = instance.Fields
public PDFFieldCollection Fields {get;}
public: __property PDFFieldCollection* get_Fields();
public:
property PDFFieldCollection^ Fields {
   PDFFieldCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

Height Property (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : Height Property
Gets the height of the physical page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PDFPage
Dim value As Double

value = instance.Height
public double Height {get;}
public: __property double get_Height();
public:
property double Height {
   double get();
}

Property Value

The height of the physical page.
Remarks
This property returns the height of the page as it is defined by the page media box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

MediaBox Property

O2S.Components.PDFView4NET Namespace > PDFPage Class : MediaBox Property
Gets the page media box.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MediaBox As PDFRectangle
'Usage

Dim instance As PDFPage
Dim value As PDFRectangle

value = instance.MediaBox
public PDFRectangle MediaBox {get;}
public: __property PDFRectangle* get_MediaBox();
public:
property PDFRectangle^ MediaBox {
   PDFRectangle^ get();
}

Property Value

A rectangle that defines the page media box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

Rotation Property (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : Rotation Property
Gets or sets the page rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rotation As PDFPageRotation
'Usage

Dim instance As PDFPage
Dim value As PDFPageRotation

instance.Rotation = value

value = instance.Rotation
public PDFPageRotation Rotation {get; set;}
public: __property PDFPageRotation get_Rotation();
public: __property void set_Rotation(
   PDFPageRotation value
);
public:
property PDFPageRotation Rotation {
   PDFPageRotation get();
   void set (    PDFPageRotation value);
}

Property Value

The rotation angle of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

VisibleHeight Property

O2S.Components.PDFView4NET Namespace > PDFPage Class : VisibleHeight Property
Gets the height of the visible page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VisibleHeight As Double
'Usage

Dim instance As PDFPage
Dim value As Double

value = instance.VisibleHeight
public double VisibleHeight {get;}
public: __property double get_VisibleHeight();
public:
property double VisibleHeight {
   double get();
}

Property Value

The height of the visible page.
Remarks
This property returns the height of the page as it is defined by the page crop box and page orientation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

VisibleWidth Property

O2S.Components.PDFView4NET Namespace > PDFPage Class : VisibleWidth Property
Gets the width of the visible page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VisibleWidth As Double
'Usage

Dim instance As PDFPage
Dim value As Double

value = instance.VisibleWidth
public double VisibleWidth {get;}
public: __property double get_VisibleWidth();
public:
property double VisibleWidth {
   double get();
}

Property Value

The width of the visible page.
Remarks
This property returns the width of the page as it is defined by the page crop box and page orientation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

Width Property (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : Width Property
Gets the width of the physical page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PDFPage
Dim value As Double

value = instance.Width
public double Width {get;}
public: __property double get_Width();
public:
property double Width {
   double get();
}

Property Value

The width of the physical page.
Remarks
This property returns the width of the page as it is defined by the page media box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%% $$Events$$

PDFPage Class Events

O2S.Components.PDFView4NET Namespace : PDFPage Class

For a list of all members of this type, see PDFPage members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Public Event | RotationChanged | Fired after the page rotation has changed.
Top
See Also

Reference

PDFPage Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

PropertyChanged Event (PDFPage)

O2S.Components.PDFView4NET Namespace > PDFPage Class : PropertyChanged Event
Gets or sets the event that is fired when a property has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As PDFPage
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%ItemTitle%%

RotationChanged Event

O2S.Components.PDFView4NET Namespace > PDFPage Class : RotationChanged Event
Fired after the page rotation has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event RotationChanged As EventHandler(Of EventArgs)
'Usage

Dim instance As PDFPage
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.RotationChanged, handler
public event EventHandler<EventArgs> RotationChanged
public: __event EventHandler<EventArgs*>* RotationChanged
public:
event EventHandler<EventArgs^>^ RotationChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPage Class
PDFPage Members


%%PageItemTitle%%

PDFPageCollection Class
Members

O2S.Components.PDFView4NET Namespace : PDFPageCollection Class
Defines a collection of PDF pages.
Object Model
PDFPageCollection ClassPDFPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFPage,PDFDocument)
'Usage

Dim instance As PDFPageCollection
public class PDFPageCollection : O2S.Components.PDFView4NET.PDFCollection<PDFPage,PDFDocument>
public __gc class PDFPageCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFPage,PDFDocument>
public ref class PDFPageCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFPage,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.PDFPageCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageCollection Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageCollection Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFPageCollection Class

The following tables list the members exposed by PDFPageCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | MoveItem | Overridden. Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top
Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFPageCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFPageCollection Class Methods

O2S.Components.PDFView4NET Namespace : PDFPageCollection Class

For a list of all members of this type, see PDFPageCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | MoveItem | Overridden. Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top
See Also

Reference

PDFPageCollection Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

MoveItem Method (PDFPageCollection)

O2S.Components.PDFView4NET Namespace > PDFPageCollection Class : MoveItem Method
Item to move.
Number of positions to move.
Moves the item up or down to the beginning or end of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function MoveItem( _
   ByVal item As PDFPage, _
   ByVal step As Integer _
) As Boolean
'Usage

Dim instance As PDFPageCollection
Dim item As PDFPage
Dim step As Integer
Dim value As Boolean

value = instance.MoveItem(item, step)
public override bool MoveItem(
   PDFPage item,
   int step
)
public: bool MoveItem(
   PDFPage* item,
   int step
) override
public:
bool MoveItem(
   PDFPage^ item,
   int step
) override

Parameters

item
Item to move.
step
Number of positions to move.

Return Value

True if the item has been moved.
Remarks
It the new position is outside the collection, the item is not moved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageCollection Class
PDFPageCollection Members


%%PageItemTitle%% $$Events$$

PDFPageCollection Class Events

O2S.Components.PDFView4NET Namespace : PDFPageCollection Class

For a list of all members of this type, see PDFPageCollection members.

Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFPageCollection Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

CollectionChanged Event (PDFPageCollection)

O2S.Components.PDFView4NET Namespace > PDFPageCollection Class : CollectionChanged Event
Gets or sets the event being fired when the collection has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event CollectionChanged As EventHandler(Of PDFCollectionChangedEventArgs(Of PDFPage))
'Usage

Dim instance As PDFPageCollection
Dim handler As EventHandler(Of PDFCollectionChangedEventArgs(Of PDFPage))

AddHandler instance.CollectionChanged, handler
public event EventHandler<PDFCollectionChangedEventArgs<PDFPage>> CollectionChanged
public: __event EventHandler<PDFCollectionChangedEventArgs<PDFPage*>*>* CollectionChanged
public:
event EventHandler<PDFCollectionChangedEventArgs<PDFPage^>^>^ CollectionChanged
Event Data

The event handler receives an argument of type PDFCollectionChangedEventArgs<T> containing data related to this event. The following PDFCollectionChangedEventArgs<T> properties provide information specific to this event.

Property | Description
ChangedProperty | Gets the name of changed property when the change type is item update.
ChangeType | Gets the type of change event.
NewItem | Gets the new item involved in the operation.
OldItem | Gets the old item involved in the operation.
Position | Gets the position of the affected item in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageCollection Class
PDFPageCollection Members


%%PageItemTitle%%

PDFPageDestination Class
Members

O2S.Components.PDFView4NET Namespace : PDFPageDestination Class
Defines a destination to a page within the current document.
Object Model
PDFPageDestination ClassPDFPage Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageDestination
   Inherits PDFDirectDestination
'Usage

Dim instance As PDFPageDestination
public class PDFPageDestination : PDFDirectDestination
public __gc class PDFPageDestination : public PDFDirectDestination
public ref class PDFPageDestination : public PDFDirectDestination
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFDestination
O2S.Components.PDFView4NET.PDFDirectDestination
O2S.Components.PDFView4NET.PDFPageDestination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageDestination Class Members
Properties

O2S.Components.PDFView4NET Namespace : PDFPageDestination Class

The following tables list the members exposed by PDFPageDestination.

Public Constructors
 | Name | Description
Public Constructor | PDFPageDestination Constructor | Initializes a new PDFPageDestination object.
Top
Public Properties
 | Name | Description
Public Property | Page | Gets or sets the destination page.
Public Property | PageNumber | Gets or sets the page number.
Public Property | ZoomMode | Gets or sets the zoom mode. (Inherited from O2S.Components.PDFView4NET.PDFDirectDestination)
Top
See Also

Reference

PDFPageDestination Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageDestination Constructor

O2S.Components.PDFView4NET Namespace > PDFPageDestination Class : PDFPageDestination Constructor
Initializes a new PDFPageDestination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPageDestination()
public PDFPageDestination()
public: PDFPageDestination();
public:
PDFPageDestination();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


%%PageItemTitle%% $$Properties$$

PDFPageDestination Class Properties

O2S.Components.PDFView4NET Namespace : PDFPageDestination Class

For a list of all members of this type, see PDFPageDestination members.

Public Properties
 | Name | Description
Public Property | Page | Gets or sets the destination page.
Public Property | PageNumber | Gets or sets the page number.
Public Property | ZoomMode | Gets or sets the zoom mode. (Inherited from O2S.Components.PDFView4NET.PDFDirectDestination)
Top
See Also

Reference

PDFPageDestination Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Page Property (PDFPageDestination)

O2S.Components.PDFView4NET Namespace > PDFPageDestination Class : Page Property
Gets or sets the destination page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As PDFPage
'Usage

Dim instance As PDFPageDestination
Dim value As PDFPage

instance.Page = value

value = instance.Page
public PDFPage Page {get; set;}
public: __property PDFPage* get_Page();
public: __property void set_Page(
   PDFPage* value
);
public:
property PDFPage^ Page {
   PDFPage^ get();
   void set (    PDFPage^ value);
}

Property Value

The target page of the destination.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


%%ItemTitle%%

PageNumber Property (PDFPageDestination)

O2S.Components.PDFView4NET Namespace > PDFPageDestination Class : PageNumber Property
Gets or sets the page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As PDFPageDestination
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

The number of the page this destination points to.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


%%PageItemTitle%%

PDFPageThumbnailView Class
Members

O2S.Components.PDFView4NET Namespace : PDFPageThumbnailView Class
Defines a viewer for page thumbnails.
Object Model
PDFPageThumbnailView ClassPDFDocument ClassPDFPageView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class PDFPageThumbnailView
   Inherits System.Windows.Forms.UserControl
'Usage

Dim instance As PDFPageThumbnailView
[ToolboxBitmap()]
public class PDFPageThumbnailView : System.Windows.Forms.UserControl
[ToolboxBitmap()]
public __gc class PDFPageThumbnailView : public System.Windows.Forms.UserControl
[ToolboxBitmap()]
public ref class PDFPageThumbnailView : public System.Windows.Forms.UserControl
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
O2S.Components.PDFView4NET.PDFPageThumbnailView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageThumbnailView Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFPageThumbnailView Class

The following tables list the members exposed by PDFPageThumbnailView.

Public Constructors
 | Name | Description
Public Constructor | PDFPageThumbnailView Constructor | Initializes a new PDFPageThumbnailView object.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets of sets the document that is displayed in the control.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageView | Gets or sets the pages viewer control that displays the same pages in full size.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedPages | Gets or sets the list of selected pages.
Public Property | ShowPageNumbers | Gets or sets a value indicating whether page numbers should be displayed.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | ThumbnailHighlightColor | Gets or sets the color for highlighting the selected thumbnails.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top
Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
Public Events
 | Name | Description
Public Event | AfterPageReorder | Gets or sets the event that is fired after the selected pages are reordered.
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BeforePageReorder | Gets or sets the event that is fired before the selected pages are reordered.
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | PageClick | Gets or sets the event that is fired when a page is clicked with the mouse.
Public Event | PageContextMenu | Gets or sets the event that is fired when a context menu should be displayed for a page.
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFPageThumbnailView Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageThumbnailView Constructor

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : PDFPageThumbnailView Constructor
Initializes a new PDFPageThumbnailView object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPageThumbnailView()
public PDFPageThumbnailView()
public: PDFPageThumbnailView();
public:
PDFPageThumbnailView();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%PageItemTitle%% $$Properties$$

PDFPageThumbnailView Class Properties

O2S.Components.PDFView4NET Namespace : PDFPageThumbnailView Class

For a list of all members of this type, see PDFPageThumbnailView members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets of sets the document that is displayed in the control.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageView | Gets or sets the pages viewer control that displays the same pages in full size.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedPages | Gets or sets the list of selected pages.
Public Property | ShowPageNumbers | Gets or sets a value indicating whether page numbers should be displayed.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | ThumbnailHighlightColor | Gets or sets the color for highlighting the selected thumbnails.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFPageThumbnailView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Document Property (PDFPageThumbnailView)

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : Document Property
Gets of sets the document that is displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("The document displayed in the control")>
<CategoryAttribute("PDF")>
Public Property Document As PDFDocument
'Usage

Dim instance As PDFPageThumbnailView
Dim value As PDFDocument

instance.Document = value

value = instance.Document
[DefaultValue()]
[Description("The document displayed in the control")]
[Category("PDF")]
public PDFDocument Document {get; set;}
[DefaultValue()]
[Description("The document displayed in the control")]
[Category("PDF")]
public: __property PDFDocument* get_Document();
public: __property void set_Document(
   PDFDocument* value
);
[DefaultValue()]
[Description("The document displayed in the control")]
[Category("PDF")]
public:
property PDFDocument^ Document {
   PDFDocument^ get();
   void set (    PDFDocument^ value);
}

Property Value

The document for which the page thumbnails are displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%ItemTitle%%

PageView Property (PDFPageThumbnailView)

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : PageView Property
Gets or sets the pages viewer control that displays the same pages in full size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DescriptionAttribute("The viewer control where the full sized pages are displayed")>
<DefaultValueAttribute()>
Public Property PageView As PDFPageView
'Usage

Dim instance As PDFPageThumbnailView
Dim value As PDFPageView

instance.PageView = value

value = instance.PageView
[Category("PDF")]
[Description("The viewer control where the full sized pages are displayed")]
[DefaultValue()]
public PDFPageView PageView {get; set;}
[Category("PDF")]
[Description("The viewer control where the full sized pages are displayed")]
[DefaultValue()]
public: __property PDFPageView* get_PageView();
public: __property void set_PageView(
   PDFPageView* value
);
[Category("PDF")]
[Description("The viewer control where the full sized pages are displayed")]
[DefaultValue()]
public:
property PDFPageView^ PageView {
   PDFPageView^ get();
   void set (    PDFPageView^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%ItemTitle%%

SelectedPages Property

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : SelectedPages Property
Gets or sets the list of selected pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedPages As Integer()
'Usage

Dim instance As PDFPageThumbnailView
Dim value() As Integer

instance.SelectedPages = value

value = instance.SelectedPages
public int[] SelectedPages {get; set;}
public: __property int[]* get_SelectedPages();
public: __property void set_SelectedPages(
   int[]* value
);
public:
property array<int>^ SelectedPages {
   array<int>^ get();
   void set (    array<int>^ value);
}

Property Value

An array of integers specifying the page numbers for selected pages.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when a page number in the array is less and zero or greater than number of pages in the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%ItemTitle%%

ShowPageNumbers Property

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : ShowPageNumbers Property
Gets or sets a value indicating whether page numbers should be displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShowPageNumbers As Boolean
'Usage

Dim instance As PDFPageThumbnailView
Dim value As Boolean

instance.ShowPageNumbers = value

value = instance.ShowPageNumbers
public bool ShowPageNumbers {get; set;}
public: __property bool get_ShowPageNumbers();
public: __property void set_ShowPageNumbers(
   bool value
);
public:
property bool ShowPageNumbers {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%ItemTitle%%

ThumbnailHighlightColor Property

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : ThumbnailHighlightColor Property
Gets or sets the color for highlighting the selected thumbnails.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Highlight color for thumbnails")>
<CategoryAttribute("PDF")>
Public Property ThumbnailHighlightColor As Color
'Usage

Dim instance As PDFPageThumbnailView
Dim value As Color

instance.ThumbnailHighlightColor = value

value = instance.ThumbnailHighlightColor
[DefaultValue()]
[Description("Highlight color for thumbnails")]
[Category("PDF")]
public Color ThumbnailHighlightColor {get; set;}
[DefaultValue()]
[Description("Highlight color for thumbnails")]
[Category("PDF")]
public: __property Color get_ThumbnailHighlightColor();
public: __property void set_ThumbnailHighlightColor(
   Color value
);
[DefaultValue()]
[Description("Highlight color for thumbnails")]
[Category("PDF")]
public:
property Color ThumbnailHighlightColor {
   Color get();
   void set (    Color value);
}

Property Value

The highlight color for thumbails.
Remarks
It is recommended to use a transparent color (alpha less than 255) for this property, otherwise the thumbnail under selection will not be visible.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%PageItemTitle%% $$Events$$

PDFPageThumbnailView Class Events

O2S.Components.PDFView4NET Namespace : PDFPageThumbnailView Class

For a list of all members of this type, see PDFPageThumbnailView members.

Public Events
 | Name | Description
Public Event | AfterPageReorder | Gets or sets the event that is fired after the selected pages are reordered.
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BeforePageReorder | Gets or sets the event that is fired before the selected pages are reordered.
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | PageClick | Gets or sets the event that is fired when a page is clicked with the mouse.
Public Event | PageContextMenu | Gets or sets the event that is fired when a context menu should be displayed for a page.
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFPageThumbnailView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

AfterPageReorder Event

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : AfterPageReorder Event
Gets or sets the event that is fired after the selected pages are reordered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterPageReorder As EventHandler(Of AfterPageReorderEventArgs)
'Usage

Dim instance As PDFPageThumbnailView
Dim handler As EventHandler(Of AfterPageReorderEventArgs)

AddHandler instance.AfterPageReorder, handler
public event EventHandler<AfterPageReorderEventArgs> AfterPageReorder
public: __event EventHandler<AfterPageReorderEventArgs*>* AfterPageReorder
public:
event EventHandler<AfterPageReorderEventArgs^>^ AfterPageReorder
Event Data

The event handler receives an argument of type AfterPageReorderEventArgs containing data related to this event. The following AfterPageReorderEventArgs properties provide information specific to this event.

Property | Description
Pages | Gets the list of reordered pages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%ItemTitle%%

BeforePageReorder Event

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : BeforePageReorder Event
Gets or sets the event that is fired before the selected pages are reordered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event BeforePageReorder As EventHandler(Of BeforePageReorderEventArgs)
'Usage

Dim instance As PDFPageThumbnailView
Dim handler As EventHandler(Of BeforePageReorderEventArgs)

AddHandler instance.BeforePageReorder, handler
public event EventHandler<BeforePageReorderEventArgs> BeforePageReorder
public: __event EventHandler<BeforePageReorderEventArgs*>* BeforePageReorder
public:
event EventHandler<BeforePageReorderEventArgs^>^ BeforePageReorder
Event Data

The event handler receives an argument of type BeforePageReorderEventArgs containing data related to this event. The following BeforePageReorderEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the reorder operation should be canceled or not.
InsertPosition | Gets the position in the document where the pages are inserted.
Pages | Gets the list of pages being reordered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%ItemTitle%%

PageClick Event (PDFPageThumbnailView)

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : PageClick Event
Gets or sets the event that is fired when a page is clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageClick As EventHandler(Of PageClickEventArgs)
'Usage

Dim instance As PDFPageThumbnailView
Dim handler As EventHandler(Of PageClickEventArgs)

AddHandler instance.PageClick, handler
public event EventHandler<PageClickEventArgs> PageClick
public: __event EventHandler<PageClickEventArgs*>* PageClick
public:
event EventHandler<PageClickEventArgs^>^ PageClick
Event Data

The event handler receives an argument of type PageClickEventArgs containing data related to this event. The following PageClickEventArgs properties provide information specific to this event.

Property | Description
ControlPoint | Gets the control point where the page was clicked.
MouseButton | Gets the mouse button that was clicked on the page.
PageNumber | Gets the number of the page that has been clicked.
PDFPoint | Gets the PDF point where the page was clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%ItemTitle%%

PageContextMenu Event

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : PageContextMenu Event
Gets or sets the event that is fired when a context menu should be displayed for a page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageContextMenu As EventHandler(Of PageContextMenuEventArgs)
'Usage

Dim instance As PDFPageThumbnailView
Dim handler As EventHandler(Of PageContextMenuEventArgs)

AddHandler instance.PageContextMenu, handler
public event EventHandler<PageContextMenuEventArgs> PageContextMenu
public: __event EventHandler<PageContextMenuEventArgs*>* PageContextMenu
public:
event EventHandler<PageContextMenuEventArgs^>^ PageContextMenu
Event Data

The event handler receives an argument of type PageContextMenuEventArgs containing data related to this event. The following PageContextMenuEventArgs properties provide information specific to this event.

Property | Description
MousePosition | Gets the position where the mouse was clicked.
PageNumber | Gets the number of the page that has been clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%PageItemTitle%%

PDFPageThumbnailViewCollection Class
Members

O2S.Components.PDFView4NET Namespace : PDFPageThumbnailViewCollection Class
Defines a collection of PDFPageThumbnailViewCollection objects representing the viewers for a document's pages.
Object Model
PDFPageThumbnailViewCollection ClassPDFPageThumbnailView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageThumbnailViewCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFPageThumbnailView,PDFDocument)
'Usage

Dim instance As PDFPageThumbnailViewCollection
public class PDFPageThumbnailViewCollection : O2S.Components.PDFView4NET.PDFCollection<PDFPageThumbnailView,PDFDocument>
public __gc class PDFPageThumbnailViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFPageThumbnailView,PDFDocument>
public ref class PDFPageThumbnailViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFPageThumbnailView,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.PDFPageThumbnailViewCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailViewCollection Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageThumbnailViewCollection Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFPageThumbnailViewCollection Class

The following tables list the members exposed by PDFPageThumbnailViewCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFPageThumbnailView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Top
See Also

Reference

PDFPageThumbnailViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageView Class
Members

O2S.Components.PDFView4NET Namespace : PDFPageView Class
Defines a viewer for a PDF page.
Object Model
PDFPageView ClassPDFAnnotationToolTip ClassPDFDocument Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class PDFPageView
   Inherits System.Windows.Forms.UserControl
'Usage

Dim instance As PDFPageView
[ToolboxBitmap()]
public class PDFPageView : System.Windows.Forms.UserControl
[ToolboxBitmap()]
public __gc class PDFPageView : public System.Windows.Forms.UserControl
[ToolboxBitmap()]
public ref class PDFPageView : public System.Windows.Forms.UserControl
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
O2S.Components.PDFView4NET.PDFPageView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageView Class Members
Properties Methods Events

O2S.Components.PDFView4NET Namespace : PDFPageView Class

The following tables list the members exposed by PDFPageView.

Public Constructors
 | Name | Description
Public Constructor | PDFPageView Constructor | Initializes a new PDFPageView object.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | ActivePageBorderColor | Gets or sets the border color of the active page in the viewer.
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | AllowFormFill | Gets or sets a value indicating whether form filling is allowed or not.
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AnnotationToolTips | Gets or sets the annotation tooltips.
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CacheRenderedPages | Gets or sets a value indicating whether the rendered pages should be cached.
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Overridden. Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DefaultEllipseAnnotationBorderColor | Gets or sets the default border color for ellipse annotations.
Public Property | DefaultEllipseAnnotationBorderWidth | Gets or sets the default border width for ellipse annotations.
Public Property | DefaultEllipseAnnotationInteriorColor | Gets or sets the default interior color for ellipse annotations.
Public Property | DefaultHighlightAnnotationColor | Gets or sets the default highlight color.
Public Property | DefaultInkAnnotationColor | Gets or sets the default ink color.
Public Property | DefaultInkAnnotationWidth | Gets or sets the default ink width.
Public Property | DefaultMeasureAnnotationScaleAndUnit | Gets or sets the scale and unit a unit in the PDF file corresponds to.
Public Property | DefaultRectangleAnnotationBorderColor | Gets or sets the default border color for rectangle annotations.
Public Property | DefaultRectangleAnnotationBorderWidth | Gets or sets the default border width for rectangle annotations.
Public Property | DefaultRectangleAnnotationInteriorColor | Gets or sets the default interior color for rectangle annotations.
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the document displayed by this control.
Public Property | DownscaleLargeImages | Gets or sets a value indicating whether large images should be down scaled.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | EnableKeyboardScroll | Gets or sets a value indicating whether scrolling through pages using the keyboard is enabled.
Public Property | EnableRepeatedKeys | Gets or sets a value indicating whether keeping a key pressed generates multiple characters or not.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | FormFieldHighlightColor | Gets or sets the color for highlighting the form fields.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HighlightFormFields | Gets or sets a value indicating whether form fields are highlighted on the page or not.
Public Property | HighlightSelectedAnnotation | Gets or sets a value indicating whether the selected annotation should be highlighted or not.
Public Property | HorizontalPageSpacing | Gets or sets the horizontal spacing between pages.
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MouseWheelScrollDelta | Gets or sets the distance the page is scrolled with the mouse wheel.
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageBorderColor | Gets or sets the border color of the pages in the viewer.
Public Property | PageDisplayLayout | Gets or sets the display layout of PDF pages.
Public Property | PageNumber | Gets or sets the page displayed in the control.
Public Property | PageShadowHeight | Gets or sets the page shadow height.
Public Property | PageShadowWidth | Gets or sets the page shadow width.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | RenderingProgressColor | Gets or sets the color of the rendering progress bar.
Public Property | RenderingProgressDisplay | Gets or sets the mode used for displaying the page rendering progress.
Public Property | RenderPageOnZoomOut | Gets or sets a value indicating whether the page should be rendered again when zooming out.
Public Property | RequiredFormFieldHighlightColor | Gets or sets the color for highlighting the required form fields.
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | ScrollPosition | Gets or sets the current scroll position.
Public Property | SearchResultHighlightColor | Gets or sets the color for highlighting the search results.
Public Property | ShowAnnotations | Gets or sets a value indicating whether the annotations should be displayed or not.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | SubstituteFonts | Specifies a collection of fonts to be used when the corresponding font is not embedded in the PDF file.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | TextSelectionColor | Gets or sets the color for highlighting the text selection.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | UseWinFormsControlsForFormFields | Gets or sets a value indicating whether standard windows forms controls should be used for form fields editing.
Public Property | VerticalPageSpacing | Gets or sets the vertical spacing between pages.
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | WorkMode | Gets or sets the control's work mode.
Public Property | Zoom | Gets or sets the zoom factor.
Public Property | ZoomMode | Gets or sets the current zoom mode.
Top
Public Methods
 | Name | Description
Public Method | ActivateFieldWidget | Activates the specified field widget, as if it was clicked with the mouse.
Public Method | BeginContentUpdate | Notifies the viewer that the content is updated and no repaint is necessary till EndContentUpdate is called.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ClearSearch | Clears the search results from the control and removes the highlighting from text.
Public Method | ClearTextSelection | Clears the text selection from the control.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | ConvertDisplayRectangleToScreenRectangle | Converts a display rectangle on the PDF page to a rectangle on the screen.
Public Method | ConvertPDFPointToScreenPoint | Overloaded. Converts a point in the document to a point on the screen.
Public Method | ConvertPDFRectangleToScreenRectangle | Overloaded. Converts a rectangle on the PDF page to a rectangle on the screen.
Public Method | ConvertScreenPointToDisplayPoint | Converts a point on the screen to a document point.
Public Method | ConvertScreenPointToPDFPoint | Overloaded. Converts a point on the screen to a document point.
Public Method | ConvertScreenRectangleToPDFRectangle | Overloaded. Converts a rectangle on the screen to a page relative rectangle.
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndContentUpdate | Notifies the viewer that the content has been updated and the display needs to be refreshed in order to show the changed.
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EnsurePageVisible | Overloaded. Displays the specified page.
Public Method | EnsureSearchResultVisible | Ensure the specified search result is visible on the screen.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
static (Shared in Visual Basic) | GetKeyState |
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPageAtPoint | Gets the page located at the specified point.
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GoToFirstPage | Displays the first page of the document.
Public Method | GoToLastPage | Displays the last page of the document.
Public Method | GoToNextPage | Displays the next page of the document.
Public Method | GoToPrevPage | Displays the previous page of the document.
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | HighlightFormField | Highlights the form field with the specified color.
Public Method | HighlightNextSearchResult | Highlights the next search result.
Public Method | HighlightPrevSearchResult | Highlights the previous search result.
Public Method | HighlightSearchResult | Overloaded. Highlights the specified search result.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | JumpToDestination | Jumps in the document to the destination specified by the name.
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SearchText | Overloaded. Searches the current page for the given text.
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectAnnotation | Selects the annotation in the viewer.
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Public Method | ZoomToPDFRectangle | Zooms the page to best fit the specified rectangle.
Top
Public Events
 | Name | Description
Public Event | AfterAnnotationAdd | Gets or sets the event that is fired after an annotation has been added to the page displayed in the control.
Public Event | AfterAnnotationMove | Gets or sets the event that is fired after an annotation has been moved on the page.
Public Event | AfterAnnotationResize | Gets or sets the event that is fired after an annotation has been resized.
Public Event | AfterFieldAdd | Gets or sets the event that is fired after a form field has been added to the page displayed in the control.
Public Event | AfterLinkExecute | Gets or sets the event that is fired after a link is executed.
Public Event | AfterTextSelect | Gets or sets the event that is fired after text has been selected on the page.
Public Event | AnnotationClick | Gets or sets the event that is fired when an annotation is clicked with the mouse.
Public Event | AnnotationContextMenu | Gets or sets the event that is fired when a context menu should be displayed for the annotation.
Public Event | AnnotationDoubleClick | Gets or sets the event that is fired when an annotation is double clicked with the mouse.
Public Event | AnnotationToolTipDraw | Gets or sets the event that is fired when an annotation tooltip needs to be drawn.
Public Event | AnnotationToolTipPopup | Gets or sets the event that is fired when an annotation tooltip needs to be shown.
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BeforeAnnotationAdd | Gets or sets the event that is fired before an annotation is added to the page displayed in the control.
Public Event | BeforeFieldAdd | Gets or sets the event that is fired before a form field is added to the page displayed in the control.
Public Event | BeforeLinkExecute | Gets or sets the event that is fired before a link is executed.
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FieldBeginEdit | Gets or sets the event that is fired before a form field enters in edit mode.
Public Event | FieldClick | Gets or sets the event that is fired when a form field is clicked with the mouse.
Public Event | FieldContextMenu | Gets or sets the event that is fired when a context menu should be displayed for the form field.
Public Event | FieldEndEdit | Gets or sets the event that is fired after a form field leaves the edit mode.
Public Event | FieldValidate | Gets or sets the event that is fired when a field value needs to be validated.
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | PageClick | Gets or sets the event that is fired when a page is clicked with the mouse.
Public Event | PageDisplayLayoutChanged | Gets or sets the event that is fired when the page display layout has changed.
Public Event | PageDoubleClick | Gets or sets the event that is fired when a page is double clicked with the mouse.
Public Event | PageNumberChanged | Gets or sets the event that is fired when the page number has changed.
Public Event | PageRenderingError | Gets or sets the event being fired when a page rendering error has occured.
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextSelectionCleared | Gets or sets the event that is fired when the existing text selection is cleared.
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | WorkModeChanged | Gets or sets the event that is fired when the control's work mode has changed.
Public Event | ZoomChanged | Gets or sets the event that is fired when the control's zoom level has changed.
Public Event | ZoomModeChanged | Gets or sets the event that is fired when the control's zoom mode has changed.
Top
See Also

Reference

PDFPageView Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageView Constructor

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PDFPageView Constructor
Initializes a new PDFPageView object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPageView()
public PDFPageView()
public: PDFPageView();
public:
PDFPageView();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%PageItemTitle%% $$Methods$$

PDFPageView Class Methods

O2S.Components.PDFView4NET Namespace : PDFPageView Class

For a list of all members of this type, see PDFPageView members.

Public Methods
 | Name | Description
Public Method | ActivateFieldWidget | Activates the specified field widget, as if it was clicked with the mouse.
Public Method | BeginContentUpdate | Notifies the viewer that the content is updated and no repaint is necessary till EndContentUpdate is called.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ClearSearch | Clears the search results from the control and removes the highlighting from text.
Public Method | ClearTextSelection | Clears the text selection from the control.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | ConvertDisplayRectangleToScreenRectangle | Converts a display rectangle on the PDF page to a rectangle on the screen.
Public Method | ConvertPDFPointToScreenPoint | Overloaded. Converts a point in the document to a point on the screen.
Public Method | ConvertPDFRectangleToScreenRectangle | Overloaded. Converts a rectangle on the PDF page to a rectangle on the screen.
Public Method | ConvertScreenPointToDisplayPoint | Converts a point on the screen to a document point.
Public Method | ConvertScreenPointToPDFPoint | Overloaded. Converts a point on the screen to a document point.
Public Method | ConvertScreenRectangleToPDFRectangle | Overloaded. Converts a rectangle on the screen to a page relative rectangle.
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndContentUpdate | Notifies the viewer that the content has been updated and the display needs to be refreshed in order to show the changed.
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EnsurePageVisible | Overloaded. Displays the specified page.
Public Method | EnsureSearchResultVisible | Ensure the specified search result is visible on the screen.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
static (Shared in Visual Basic) | GetKeyState |
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPageAtPoint | Gets the page located at the specified point.
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GoToFirstPage | Displays the first page of the document.
Public Method | GoToLastPage | Displays the last page of the document.
Public Method | GoToNextPage | Displays the next page of the document.
Public Method | GoToPrevPage | Displays the previous page of the document.
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | HighlightFormField | Highlights the form field with the specified color.
Public Method | HighlightNextSearchResult | Highlights the next search result.
Public Method | HighlightPrevSearchResult | Highlights the previous search result.
Public Method | HighlightSearchResult | Overloaded. Highlights the specified search result.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | JumpToDestination | Jumps in the document to the destination specified by the name.
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SearchText | Overloaded. Searches the current page for the given text.
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectAnnotation | Selects the annotation in the viewer.
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Public Method | ZoomToPDFRectangle | Zooms the page to best fit the specified rectangle.
Top
See Also

Reference

PDFPageView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

ActivateFieldWidget Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ActivateFieldWidget Method
The field widget to activate.
Activates the specified field widget, as if it was clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ActivateFieldWidget( _
   ByVal fieldWidget As PDFFieldWidget _
)
'Usage

Dim instance As PDFPageView
Dim fieldWidget As PDFFieldWidget

instance.ActivateFieldWidget(fieldWidget)
public void ActivateFieldWidget(
   PDFFieldWidget fieldWidget
)
public: void ActivateFieldWidget(
   PDFFieldWidget* fieldWidget
)
public:
void ActivateFieldWidget(
   PDFFieldWidget^ fieldWidget
)

Parameters

fieldWidget
The field widget to activate.
Remarks
A field widget can be activated only on current page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

BeginContentUpdate Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : BeginContentUpdate Method
Notifies the viewer that the content is updated and no repaint is necessary till EndContentUpdate is called.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub BeginContentUpdate()
'Usage

Dim instance As PDFPageView

instance.BeginContentUpdate()
public void BeginContentUpdate()
public: void BeginContentUpdate();
public:
void BeginContentUpdate();
Remarks
When changing the displayed file from code (such as setting field values programatically), these changes can cause multiple refreshes and the update process can become slow. In this situation, it is recommended that no change is displayed till all the changes have been made and then the viewer is refreshed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ClearSearch Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ClearSearch Method
Clears the search results from the control and removes the highlighting from text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ClearSearch()
'Usage

Dim instance As PDFPageView

instance.ClearSearch()
public void ClearSearch()
public: void ClearSearch();
public:
void ClearSearch();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ClearTextSelection Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ClearTextSelection Method
Clears the text selection from the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ClearTextSelection()
'Usage

Dim instance As PDFPageView

instance.ClearTextSelection()
public void ClearTextSelection()
public: void ClearTextSelection();
public:
void ClearTextSelection();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ConvertDisplayRectangleToScreenRectangle Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ConvertDisplayRectangleToScreenRectangle Method
The rectangle on the PDF page to convert.
Converts a display rectangle on the PDF page to a rectangle on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertDisplayRectangleToScreenRectangle( _
   ByVal displayRectangle As DisplayRectangle _
) As Rectangle
'Usage

Dim instance As PDFPageView
Dim displayRectangle As DisplayRectangle
Dim value As Rectangle

value = instance.ConvertDisplayRectangleToScreenRectangle(displayRectangle)
public Rectangle ConvertDisplayRectangleToScreenRectangle(
   DisplayRectangle displayRectangle
)
public: Rectangle ConvertDisplayRectangleToScreenRectangle(
   DisplayRectangle* displayRectangle
)
public:
Rectangle ConvertDisplayRectangleToScreenRectangle(
   DisplayRectangle^ displayRectangle
)

Parameters

displayRectangle
The rectangle on the PDF page to convert.

Return Value

The converted rectangle in screen coordinates.
Remarks
This method converts a PDF rectangle from points to screen pixels. The source rectangle is relative to top left corner of the visible page. The screen rectangle is relative to control's display area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ConvertPDFPointToScreenPoint Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ConvertPDFPointToScreenPoint Method
Converts a point in the document to a point on the screen.
Overload List
Overload | Description
ConvertPDFPointToScreenPoint(PDFPoint) | Converts a point in the document to a point on the screen.
ConvertPDFPointToScreenPoint(Int32,PDFPoint) | Converts a point in the document to a point on the screen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ConvertPDFPointToScreenPoint(PDFPoint) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > ConvertPDFPointToScreenPoint Method : ConvertPDFPointToScreenPoint(PDFPoint) Method
The point on the page to convert.
Converts a point in the document to a point on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertPDFPointToScreenPoint( _
   ByVal pdfPoint As PDFPoint _
) As Point
'Usage

Dim instance As PDFPageView
Dim pdfPoint As PDFPoint
Dim value As Point

value = instance.ConvertPDFPointToScreenPoint(pdfPoint)
public Point ConvertPDFPointToScreenPoint(
   PDFPoint pdfPoint
)
public: Point ConvertPDFPointToScreenPoint(
   PDFPoint* pdfPoint
)
public:
Point ConvertPDFPointToScreenPoint(
   PDFPoint^ pdfPoint
)

Parameters

pdfPoint
The point on the page to convert.

Return Value

The converted point in screen coordinates.
Remarks
This method converts a document point from points to screen pixels. The source point is relative to PDF's default coordinate system, which has the origin in the lower left corner of the page. The screen point is relative to control's display area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

ConvertPDFPointToScreenPoint(Int32,PDFPoint) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > ConvertPDFPointToScreenPoint Method : ConvertPDFPointToScreenPoint(Int32,PDFPoint) Method
The number of the page to which the PDF point is relative.
Converts a point in the document to a point on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertPDFPointToScreenPoint( _
   ByVal pageNumber As Integer, _
   ByVal pdfPoint As PDFPoint _
) As Point
'Usage

Dim instance As PDFPageView
Dim pageNumber As Integer
Dim pdfPoint As PDFPoint
Dim value As Point

value = instance.ConvertPDFPointToScreenPoint(pageNumber, pdfPoint)
public Point ConvertPDFPointToScreenPoint(
   int pageNumber,
   PDFPoint pdfPoint
)
public: Point ConvertPDFPointToScreenPoint(
   int pageNumber,
   PDFPoint* pdfPoint
)
public:
Point ConvertPDFPointToScreenPoint(
   int pageNumber,
   PDFPoint^ pdfPoint
)

Parameters

pageNumber
The number of the page to which the PDF point is relative.
pdfPoint

Return Value

The converted point in screen coordinates.
Remarks
This method converts a document point from points to screen pixels. The source point is relative to PDF's default coordinate system, which has the origin in the lower left corner of the page. The screen point is relative to control's display area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

ConvertPDFRectangleToScreenRectangle Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ConvertPDFRectangleToScreenRectangle Method
Converts a rectangle on the PDF page to a rectangle on the screen.
Overload List
Overload | Description
ConvertPDFRectangleToScreenRectangle(PDFRectangle) | Converts a rectangle on the PDF page to a rectangle on the screen.
ConvertPDFRectangleToScreenRectangle(Int32,PDFRectangle) | Converts a rectangle in the document to a rectangle on the screen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ConvertPDFRectangleToScreenRectangle(PDFRectangle) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > ConvertPDFRectangleToScreenRectangle Method : ConvertPDFRectangleToScreenRectangle(PDFRectangle) Method
The rectangle on the PDF page to convert.
Converts a rectangle on the PDF page to a rectangle on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertPDFRectangleToScreenRectangle( _
   ByVal pdfRectangle As PDFRectangle _
) As Rectangle
'Usage

Dim instance As PDFPageView
Dim pdfRectangle As PDFRectangle
Dim value As Rectangle

value = instance.ConvertPDFRectangleToScreenRectangle(pdfRectangle)
public Rectangle ConvertPDFRectangleToScreenRectangle(
   PDFRectangle pdfRectangle
)
public: Rectangle ConvertPDFRectangleToScreenRectangle(
   PDFRectangle* pdfRectangle
)
public:
Rectangle ConvertPDFRectangleToScreenRectangle(
   PDFRectangle^ pdfRectangle
)

Parameters

pdfRectangle
The rectangle on the PDF page to convert.

Return Value

The converted rectangle in screen coordinates.
Remarks
This method converts a PDF point from points to screen pixels. The source rectangle is relative to PDF's default coordinate system, which has the origin in the lower left corner of the page. The screen rectangle is relative to control's display area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

ConvertPDFRectangleToScreenRectangle(Int32,PDFRectangle) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > ConvertPDFRectangleToScreenRectangle Method : ConvertPDFRectangleToScreenRectangle(Int32,PDFRectangle) Method
The number of the page to which the PDF rectangle is relative.
The rectangle in the document to convert.
Converts a rectangle in the document to a rectangle on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertPDFRectangleToScreenRectangle( _
   ByVal pageNumber As Integer, _
   ByVal pdfRectangle As PDFRectangle _
) As Rectangle
'Usage

Dim instance As PDFPageView
Dim pageNumber As Integer
Dim pdfRectangle As PDFRectangle
Dim value As Rectangle

value = instance.ConvertPDFRectangleToScreenRectangle(pageNumber, pdfRectangle)
public Rectangle ConvertPDFRectangleToScreenRectangle(
   int pageNumber,
   PDFRectangle pdfRectangle
)
public: Rectangle ConvertPDFRectangleToScreenRectangle(
   int pageNumber,
   PDFRectangle* pdfRectangle
)
public:
Rectangle ConvertPDFRectangleToScreenRectangle(
   int pageNumber,
   PDFRectangle^ pdfRectangle
)

Parameters

pageNumber
The number of the page to which the PDF rectangle is relative.
pdfRectangle
The rectangle in the document to convert.

Return Value

The converted rectangle in screen coordinates.
Remarks
This method converts a document rectangle from points to screen pixels. The source rectangle is relative to PDF's default coordinate system, which has the origin in the lower left corner of the page. The screen rectangle is relative to control's display area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

ConvertScreenPointToDisplayPoint Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ConvertScreenPointToDisplayPoint Method
The point on the screen to convert.
Converts a point on the screen to a document point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConvertScreenPointToDisplayPoint( _
   ByVal screenPoint As Point _
) As PDFPoint
'Usage

Dim instance As PDFPageView
Dim screenPoint As Point
Dim value As PDFPoint

value = instance.ConvertScreenPointToDisplayPoint(screenPoint)
public PDFPoint ConvertScreenPointToDisplayPoint(
   Point screenPoint
)
public: PDFPoint* ConvertScreenPointToDisplayPoint(
   Point screenPoint
)
public:
PDFPoint^ ConvertScreenPointToDisplayPoint(
   Point screenPoint
)

Parameters

screenPoint
The point on the screen to convert.

Return Value

The converted point in display coordinate system.
Remarks
This method converts a screen point from pixels to PDF points. The screen point is relative to control's display area. The converted point is relative to top left corner of the visible page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ConvertScreenPointToPDFPoint Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ConvertScreenPointToPDFPoint Method
Converts a point on the screen to a document point.
Overload List
Overload | Description
ConvertScreenPointToPDFPoint(Point) | Converts a point on the screen to a document point.
ConvertScreenPointToPDFPoint(Int32,Point) | Converts a point on the screen to a document point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ConvertScreenPointToPDFPoint(Point) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > ConvertScreenPointToPDFPoint Method : ConvertScreenPointToPDFPoint(Point) Method
The point on the screen to convert.
Converts a point on the screen to a document point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertScreenPointToPDFPoint( _
   ByVal screenPoint As Point _
) As PDFPoint
'Usage

Dim instance As PDFPageView
Dim screenPoint As Point
Dim value As PDFPoint

value = instance.ConvertScreenPointToPDFPoint(screenPoint)
public PDFPoint ConvertScreenPointToPDFPoint(
   Point screenPoint
)
public: PDFPoint* ConvertScreenPointToPDFPoint(
   Point screenPoint
)
public:
PDFPoint^ ConvertScreenPointToPDFPoint(
   Point screenPoint
)

Parameters

screenPoint
The point on the screen to convert.

Return Value

The converted point in default PDF coordinates.
Remarks
This method converts a screen point from pixels to PDF points. The screen point is relative to control's display area. The converted point is relative to PDF's default coordinate system, which has the origin in the lower left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

ConvertScreenPointToPDFPoint(Int32,Point) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > ConvertScreenPointToPDFPoint Method : ConvertScreenPointToPDFPoint(Int32,Point) Method
The number of the page to which the PDF point is relative.
The point on the screen to convert.
Converts a point on the screen to a document point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertScreenPointToPDFPoint( _
   ByVal pageNumber As Integer, _
   ByVal screenPoint As Point _
) As PDFPoint
'Usage

Dim instance As PDFPageView
Dim pageNumber As Integer
Dim screenPoint As Point
Dim value As PDFPoint

value = instance.ConvertScreenPointToPDFPoint(pageNumber, screenPoint)
public PDFPoint ConvertScreenPointToPDFPoint(
   int pageNumber,
   Point screenPoint
)
public: PDFPoint* ConvertScreenPointToPDFPoint(
   int pageNumber,
   Point screenPoint
)
public:
PDFPoint^ ConvertScreenPointToPDFPoint(
   int pageNumber,
   Point screenPoint
)

Parameters

pageNumber
The number of the page to which the PDF point is relative.
screenPoint
The point on the screen to convert.

Return Value

The converted point in default PDF coordinates.
Remarks
This method converts a screen point from pixels to PDF points. The screen point is relative to control's display area. The converted point is relative to PDF's default coordinate system, which has the origin in the lower left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

ConvertScreenRectangleToPDFRectangle Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ConvertScreenRectangleToPDFRectangle Method
Converts a rectangle on the screen to a page relative rectangle.
Overload List
Overload | Description
ConvertScreenRectangleToPDFRectangle(Rectangle) | Converts a rectangle on the screen to a page relative rectangle.
ConvertScreenRectangleToPDFRectangle(Int32,Rectangle) | Converts a rectangle on the screen to a document rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ConvertScreenRectangleToPDFRectangle(Rectangle) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > ConvertScreenRectangleToPDFRectangle Method : ConvertScreenRectangleToPDFRectangle(Rectangle) Method
The rectangle on the screen to convert.
Converts a rectangle on the screen to a page relative rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertScreenRectangleToPDFRectangle( _
   ByVal screenRectangle As Rectangle _
) As PDFRectangle
'Usage

Dim instance As PDFPageView
Dim screenRectangle As Rectangle
Dim value As PDFRectangle

value = instance.ConvertScreenRectangleToPDFRectangle(screenRectangle)
public PDFRectangle ConvertScreenRectangleToPDFRectangle(
   Rectangle screenRectangle
)
public: PDFRectangle* ConvertScreenRectangleToPDFRectangle(
   Rectangle screenRectangle
)
public:
PDFRectangle^ ConvertScreenRectangleToPDFRectangle(
   Rectangle screenRectangle
)

Parameters

screenRectangle
The rectangle on the screen to convert.

Return Value

The converted rectangle in default PDF coordinates.
Remarks
This method converts a screen rectangle from pixels to PDF points. The screen rectangle is relative to control's display area. The converted rectangle is relative to PDF's default coordinate system, which has the origin in the lower left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

ConvertScreenRectangleToPDFRectangle(Int32,Rectangle) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > ConvertScreenRectangleToPDFRectangle Method : ConvertScreenRectangleToPDFRectangle(Int32,Rectangle) Method
The number of the page to which the PDF point is relative.
The rectangle on the screen to convert.
Converts a rectangle on the screen to a document rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ConvertScreenRectangleToPDFRectangle( _
   ByVal pageNumber As Integer, _
   ByVal screenRect As Rectangle _
) As PDFRectangle
'Usage

Dim instance As PDFPageView
Dim pageNumber As Integer
Dim screenRect As Rectangle
Dim value As PDFRectangle

value = instance.ConvertScreenRectangleToPDFRectangle(pageNumber, screenRect)
public PDFRectangle ConvertScreenRectangleToPDFRectangle(
   int pageNumber,
   Rectangle screenRect
)
public: PDFRectangle* ConvertScreenRectangleToPDFRectangle(
   int pageNumber,
   Rectangle screenRect
)
public:
PDFRectangle^ ConvertScreenRectangleToPDFRectangle(
   int pageNumber,
   Rectangle screenRect
)

Parameters

pageNumber
The number of the page to which the PDF point is relative.
screenRect
The rectangle on the screen to convert.

Return Value

The converted rectangle in default PDF coordinates.
Remarks
This method converts a screen rectangle from pixels to PDF points. The screen rectangle is relative to control's display area. The converted rectangle is relative to PDF's default coordinate system, which has the origin in the lower left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

EndContentUpdate Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : EndContentUpdate Method
Notifies the viewer that the content has been updated and the display needs to be refreshed in order to show the changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndContentUpdate()
'Usage

Dim instance As PDFPageView

instance.EndContentUpdate()
public void EndContentUpdate()
public: void EndContentUpdate();
public:
void EndContentUpdate();
Remarks
This method is used in pair with BeginContentUpdate
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

EnsurePageVisible Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : EnsurePageVisible Method
Displays the specified page.
Overload List
Overload | Description
EnsurePageVisible(Int32) | Displays the specified page.
EnsurePageVisible(Int32,PDFPoint) | Displays the specified page at the specified location.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

EnsurePageVisible(Int32) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > EnsurePageVisible Method : EnsurePageVisible(Int32) Method
The page to display.
Displays the specified page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub EnsurePageVisible( _
   ByVal pageNumber As Integer _
)
'Usage

Dim instance As PDFPageView
Dim pageNumber As Integer

instance.EnsurePageVisible(pageNumber)
public void EnsurePageVisible(
   int pageNumber
)
public: void EnsurePageVisible(
   int pageNumber
)
public:
void EnsurePageVisible(
   int pageNumber
)

Parameters

pageNumber
The page to display.
Exceptions
Exception | Description
 | Thrown if pageNumber is less than 0 or greater than or equal to the number of pages in the document.
Remarks
The top margin of the page is displayed at the top of the viewer control, if applicable.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

EnsurePageVisible(Int32,PDFPoint) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > EnsurePageVisible Method : EnsurePageVisible(Int32,PDFPoint) Method
The page to display.
The PDF point on the page that must be made visible.
Displays the specified page at the specified location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub EnsurePageVisible( _
   ByVal pageNumber As Integer, _
   ByVal visiblePDFPoint As PDFPoint _
)
'Usage

Dim instance As PDFPageView
Dim pageNumber As Integer
Dim visiblePDFPoint As PDFPoint

instance.EnsurePageVisible(pageNumber, visiblePDFPoint)
public void EnsurePageVisible(
   int pageNumber,
   PDFPoint visiblePDFPoint
)
public: void EnsurePageVisible(
   int pageNumber,
   PDFPoint* visiblePDFPoint
)
public:
void EnsurePageVisible(
   int pageNumber,
   PDFPoint^ visiblePDFPoint
)

Parameters

pageNumber
The page to display.
visiblePDFPoint
The PDF point on the page that must be made visible.
Exceptions
Exception | Description
 | Thrown if pageNumber is less than 0 or greater than or equal to the number of pages in the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

EnsureSearchResultVisible Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : EnsureSearchResultVisible Method
Ensure the specified search result is visible on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EnsureSearchResultVisible( _
   ByVal searchTextResult As PDFSearchTextResult _
)
'Usage

Dim instance As PDFPageView
Dim searchTextResult As PDFSearchTextResult

instance.EnsureSearchResultVisible(searchTextResult)
public void EnsureSearchResultVisible(
   PDFSearchTextResult searchTextResult
)
public: void EnsureSearchResultVisible(
   PDFSearchTextResult* searchTextResult
)
public:
void EnsureSearchResultVisible(
   PDFSearchTextResult^ searchTextResult
)

Parameters

searchTextResult

Return Value

The search result to be made visible by scrolling the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

GetKeyState Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : GetKeyState Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DllImportAttribute("user32.dll")>
<PreserveSigAttribute()>
Public Shared Function GetKeyState( _
   ByVal nVirtKey As Short _
) As Short
'Usage

Dim nVirtKey As Short
Dim value As Short

value = PDFPageView.GetKeyState(nVirtKey)
[DllImport("user32.dll")]
[PreserveSig()]
public static short GetKeyState(
   short nVirtKey
)
[DllImport("user32.dll")]
[PreserveSig()]
public: static short GetKeyState(
   short nVirtKey
)
[DllImport("user32.dll")]
[PreserveSig()]
public:
static short GetKeyState(
   short nVirtKey
)

Parameters

nVirtKey
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

GetPageAtPoint(Point) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : GetPageAtPoint(Point) Method
The point in control coordinates.
Gets the page located at the specified point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPageAtPoint( _
   ByVal pt As Point _
) As Integer
'Usage

Dim instance As PDFPageView
Dim pt As Point
Dim value As Integer

value = instance.GetPageAtPoint(pt)
public int GetPageAtPoint(
   Point pt
)
public: int GetPageAtPoint(
   Point pt
)
public:
int GetPageAtPoint(
   Point pt
)

Parameters

pt
The point in control coordinates.

Return Value

The number of the page that is located at the specified point, otherwise -1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

GoToFirstPage Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : GoToFirstPage Method
Displays the first page of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GoToFirstPage()
'Usage

Dim instance As PDFPageView

instance.GoToFirstPage()
public void GoToFirstPage()
public: void GoToFirstPage();
public:
void GoToFirstPage();
Remarks
If there is no document attached to this control, or the document is empty, nothing happens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

GoToLastPage Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : GoToLastPage Method
Displays the last page of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GoToLastPage()
'Usage

Dim instance As PDFPageView

instance.GoToLastPage()
public void GoToLastPage()
public: void GoToLastPage();
public:
void GoToLastPage();
Remarks
If there is no document attached to this control, or the document is empty, nothing happens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

GoToNextPage Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : GoToNextPage Method
Displays the next page of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GoToNextPage()
'Usage

Dim instance As PDFPageView

instance.GoToNextPage()
public void GoToNextPage()
public: void GoToNextPage();
public:
void GoToNextPage();
Remarks
If current page is the last page, then the page does not change. If there is no document attached to this control, or the document is empty, nothing happens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

GoToPrevPage Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : GoToPrevPage Method
Displays the previous page of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GoToPrevPage()
'Usage

Dim instance As PDFPageView

instance.GoToPrevPage()
public void GoToPrevPage()
public: void GoToPrevPage();
public:
void GoToPrevPage();
Remarks
If current page is the first page, then the page does not change. If there is no document attached to this control, or the document is empty, nothing happens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

HighlightFormField Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : HighlightFormField Method
The field to highlight.
The color of highlight.
Highlights the form field with the specified color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub HighlightFormField( _
   ByVal fieldName As String, _
   ByVal highlightColor As Color _
)
'Usage

Dim instance As PDFPageView
Dim fieldName As String
Dim highlightColor As Color

instance.HighlightFormField(fieldName, highlightColor)
public void HighlightFormField(
   string fieldName,
   Color highlightColor
)
public: void HighlightFormField(
   string* fieldName,
   Color highlightColor
)
public:
void HighlightFormField(
   String^ fieldName,
   Color highlightColor
)

Parameters

fieldName
The field to highlight.
highlightColor
The color of highlight.
Remarks
The form field is highlighted by drawing a rectangle with the highlight color over the field rectangle. The highlight color should be a transparent color in order to avoid complete blocking of field content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

HighlightNextSearchResult Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : HighlightNextSearchResult Method
Highlights the next search result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function HighlightNextSearchResult() As PDFSearchTextResult
'Usage

Dim instance As PDFPageView
Dim value As PDFSearchTextResult

value = instance.HighlightNextSearchResult()
public PDFSearchTextResult HighlightNextSearchResult()
public: PDFSearchTextResult* HighlightNextSearchResult();
public:
PDFSearchTextResult^ HighlightNextSearchResult();

Return Value

The highlighted search result.
Remarks
This method has effect when SearchText(String) method has been called with O2S.Components.PDFView4NET.Text.PDFHighlightSearchResultsMode.SingleResult as parameter. If there are no search results, nothing happens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

HighlightPrevSearchResult Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : HighlightPrevSearchResult Method
Highlights the previous search result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function HighlightPrevSearchResult() As PDFSearchTextResult
'Usage

Dim instance As PDFPageView
Dim value As PDFSearchTextResult

value = instance.HighlightPrevSearchResult()
public PDFSearchTextResult HighlightPrevSearchResult()
public: PDFSearchTextResult* HighlightPrevSearchResult();
public:
PDFSearchTextResult^ HighlightPrevSearchResult();

Return Value

The highlighted search result.
Remarks
This method has effect when SearchText(String) method has been called with O2S.Components.PDFView4NET.Text.PDFHighlightSearchResultsMode.SingleResult as parameter. If there are no search results, nothing happens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

HighlightSearchResult Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : HighlightSearchResult Method
Highlights the specified search result.
Overload List
Overload | Description
HighlightSearchResult(PDFSearchTextResult) | Highlights the specified search result.
HighlightSearchResult(PDFSearchTextResult,Color) | Highlights the specified search result.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

HighlightSearchResult(PDFSearchTextResult) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > HighlightSearchResult Method : HighlightSearchResult(PDFSearchTextResult) Method
The highlighted search result.
Highlights the specified search result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub HighlightSearchResult( _
   ByVal searchTextResult As PDFSearchTextResult _
)
'Usage

Dim instance As PDFPageView
Dim searchTextResult As PDFSearchTextResult

instance.HighlightSearchResult(searchTextResult)
public void HighlightSearchResult(
   PDFSearchTextResult searchTextResult
)
public: void HighlightSearchResult(
   PDFSearchTextResult* searchTextResult
)
public:
void HighlightSearchResult(
   PDFSearchTextResult^ searchTextResult
)

Parameters

searchTextResult
The highlighted search result.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

HighlightSearchResult(PDFSearchTextResult,Color) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > HighlightSearchResult Method : HighlightSearchResult(PDFSearchTextResult,Color) Method
The highlighted search result.
Color for highlighting the search result.
Highlights the specified search result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub HighlightSearchResult( _
   ByVal searchTextResult As PDFSearchTextResult, _
   ByVal searchResultHighlightColor As Color _
)
'Usage

Dim instance As PDFPageView
Dim searchTextResult As PDFSearchTextResult
Dim searchResultHighlightColor As Color

instance.HighlightSearchResult(searchTextResult, searchResultHighlightColor)
public void HighlightSearchResult(
   PDFSearchTextResult searchTextResult,
   Color searchResultHighlightColor
)
public: void HighlightSearchResult(
   PDFSearchTextResult* searchTextResult,
   Color searchResultHighlightColor
)
public:
void HighlightSearchResult(
   PDFSearchTextResult^ searchTextResult,
   Color searchResultHighlightColor
)

Parameters

searchTextResult
The highlighted search result.
searchResultHighlightColor
Color for highlighting the search result.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

JumpToDestination Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : JumpToDestination Method
The name of the destination.
Jumps in the document to the destination specified by the name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub JumpToDestination( _
   ByVal destinationName As String _
)
'Usage

Dim instance As PDFPageView
Dim destinationName As String

instance.JumpToDestination(destinationName)
public void JumpToDestination(
   string destinationName
)
public: void JumpToDestination(
   string* destinationName
)
public:
void JumpToDestination(
   String^ destinationName
)

Parameters

destinationName
The name of the destination.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

SearchText Method (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : SearchText Method
Searches the current page for the given text.
Overload List
Overload | Description
SearchText(String) | Searches the current page for the given text.
SearchText(String,PDFHighlightSearchResultsMode) | Searches the current page for the given text.
SearchText(String,PDFSearchTextRange) | Searches the document for the given text.
SearchText(String,PDFSearchTextRange,PDFHighlightSearchResultsMode) | Searches the document for the given text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

SearchText(String) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > SearchText Method : SearchText(String) Method
Text to search.
Searches the current page for the given text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SearchText( _
   ByVal text As String _
) As PDFPageSearchTextResultCollection
'Usage

Dim instance As PDFPageView
Dim text As String
Dim value As PDFPageSearchTextResultCollection

value = instance.SearchText(text)
public PDFPageSearchTextResultCollection SearchText(
   string text
)
public: PDFPageSearchTextResultCollection* SearchText(
   string* text
)
public:
PDFPageSearchTextResultCollection^ SearchText(
   String^ text
)

Parameters

text
Text to search.

Return Value

List of search results.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

SearchText(String,PDFHighlightSearchResultsMode) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > SearchText Method : SearchText(String,PDFHighlightSearchResultsMode) Method
Text to search.
The mode to highlight the search results.
Searches the current page for the given text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SearchText( _
   ByVal text As String, _
   ByVal highlightMode As PDFHighlightSearchResultsMode _
) As PDFPageSearchTextResultCollection
'Usage

Dim instance As PDFPageView
Dim text As String
Dim highlightMode As PDFHighlightSearchResultsMode
Dim value As PDFPageSearchTextResultCollection

value = instance.SearchText(text, highlightMode)
public PDFPageSearchTextResultCollection SearchText(
   string text,
   PDFHighlightSearchResultsMode highlightMode
)
public: PDFPageSearchTextResultCollection* SearchText(
   string* text,
   PDFHighlightSearchResultsMode highlightMode
)
public:
PDFPageSearchTextResultCollection^ SearchText(
   String^ text,
   PDFHighlightSearchResultsMode highlightMode
)

Parameters

text
Text to search.
highlightMode
The mode to highlight the search results.

Return Value

List of search results.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

SearchText(String,PDFSearchTextRange) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > SearchText Method : SearchText(String,PDFSearchTextRange) Method
Text to search.
Range of pages to search.
Searches the document for the given text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SearchText( _
   ByVal text As String, _
   ByVal searchRange As PDFSearchTextRange _
) As PDFPageSearchTextResultCollection
'Usage

Dim instance As PDFPageView
Dim text As String
Dim searchRange As PDFSearchTextRange
Dim value As PDFPageSearchTextResultCollection

value = instance.SearchText(text, searchRange)
public PDFPageSearchTextResultCollection SearchText(
   string text,
   PDFSearchTextRange searchRange
)
public: PDFPageSearchTextResultCollection* SearchText(
   string* text,
   PDFSearchTextRange searchRange
)
public:
PDFPageSearchTextResultCollection^ SearchText(
   String^ text,
   PDFSearchTextRange searchRange
)

Parameters

text
Text to search.
searchRange
Range of pages to search.

Return Value

List of search results.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

SearchText(String,PDFSearchTextRange,PDFHighlightSearchResultsMode) Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class > SearchText Method : SearchText(String,PDFSearchTextRange,PDFHighlightSearchResultsMode) Method
Text to search.
Range of pages to search.
The mode to highlight the search results.
Searches the document for the given text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SearchText( _
   ByVal text As String, _
   ByVal searchRange As PDFSearchTextRange, _
   ByVal highlightMode As PDFHighlightSearchResultsMode _
) As PDFPageSearchTextResultCollection
'Usage

Dim instance As PDFPageView
Dim text As String
Dim searchRange As PDFSearchTextRange
Dim highlightMode As PDFHighlightSearchResultsMode
Dim value As PDFPageSearchTextResultCollection

value = instance.SearchText(text, searchRange, highlightMode)
public PDFPageSearchTextResultCollection SearchText(
   string text,
   PDFSearchTextRange searchRange,
   PDFHighlightSearchResultsMode highlightMode
)
public: PDFPageSearchTextResultCollection* SearchText(
   string* text,
   PDFSearchTextRange searchRange,
   PDFHighlightSearchResultsMode highlightMode
)
public:
PDFPageSearchTextResultCollection^ SearchText(
   String^ text,
   PDFSearchTextRange searchRange,
   PDFHighlightSearchResultsMode highlightMode
)

Parameters

text
Text to search.
searchRange
Range of pages to search.
highlightMode
The mode to highlight the search results.

Return Value

List of search results.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members
Overload List


%%ItemTitle%%

SelectAnnotation Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : SelectAnnotation Method
The annotation to select.
Selects the annotation in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function SelectAnnotation( _
   ByVal annotation As PDFAnnotation _
) As Boolean
'Usage

Dim instance As PDFPageView
Dim annotation As PDFAnnotation
Dim value As Boolean

value = instance.SelectAnnotation(annotation)
public bool SelectAnnotation(
   PDFAnnotation annotation
)
public: bool SelectAnnotation(
   PDFAnnotation* annotation
)
public:
bool SelectAnnotation(
   PDFAnnotation^ annotation
)

Parameters

annotation
The annotation to select.

Return Value

True if the annotation could be selected, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ZoomToPDFRectangle Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ZoomToPDFRectangle Method
Page number to zoom.
Rectangle on the page, in PDF coordinates, to zoom to.
Zooms the page to best fit the specified rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ZoomToPDFRectangle( _
   ByVal pageNumber As Integer, _
   ByVal rectangle As PDFRectangle _
)
'Usage

Dim instance As PDFPageView
Dim pageNumber As Integer
Dim rectangle As PDFRectangle

instance.ZoomToPDFRectangle(pageNumber, rectangle)
public void ZoomToPDFRectangle(
   int pageNumber,
   PDFRectangle rectangle
)
public: void ZoomToPDFRectangle(
   int pageNumber,
   PDFRectangle* rectangle
)
public:
void ZoomToPDFRectangle(
   int pageNumber,
   PDFRectangle^ rectangle
)

Parameters

pageNumber
Page number to zoom.
rectangle
Rectangle on the page, in PDF coordinates, to zoom to.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%PageItemTitle%% $$Properties$$

PDFPageView Class Properties

O2S.Components.PDFView4NET Namespace : PDFPageView Class

For a list of all members of this type, see PDFPageView members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | ActivePageBorderColor | Gets or sets the border color of the active page in the viewer.
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | AllowFormFill | Gets or sets a value indicating whether form filling is allowed or not.
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AnnotationToolTips | Gets or sets the annotation tooltips.
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CacheRenderedPages | Gets or sets a value indicating whether the rendered pages should be cached.
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Overridden. Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DefaultEllipseAnnotationBorderColor | Gets or sets the default border color for ellipse annotations.
Public Property | DefaultEllipseAnnotationBorderWidth | Gets or sets the default border width for ellipse annotations.
Public Property | DefaultEllipseAnnotationInteriorColor | Gets or sets the default interior color for ellipse annotations.
Public Property | DefaultHighlightAnnotationColor | Gets or sets the default highlight color.
Public Property | DefaultInkAnnotationColor | Gets or sets the default ink color.
Public Property | DefaultInkAnnotationWidth | Gets or sets the default ink width.
Public Property | DefaultMeasureAnnotationScaleAndUnit | Gets or sets the scale and unit a unit in the PDF file corresponds to.
Public Property | DefaultRectangleAnnotationBorderColor | Gets or sets the default border color for rectangle annotations.
Public Property | DefaultRectangleAnnotationBorderWidth | Gets or sets the default border width for rectangle annotations.
Public Property | DefaultRectangleAnnotationInteriorColor | Gets or sets the default interior color for rectangle annotations.
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the document displayed by this control.
Public Property | DownscaleLargeImages | Gets or sets a value indicating whether large images should be down scaled.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | EnableKeyboardScroll | Gets or sets a value indicating whether scrolling through pages using the keyboard is enabled.
Public Property | EnableRepeatedKeys | Gets or sets a value indicating whether keeping a key pressed generates multiple characters or not.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | FormFieldHighlightColor | Gets or sets the color for highlighting the form fields.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HighlightFormFields | Gets or sets a value indicating whether form fields are highlighted on the page or not.
Public Property | HighlightSelectedAnnotation | Gets or sets a value indicating whether the selected annotation should be highlighted or not.
Public Property | HorizontalPageSpacing | Gets or sets the horizontal spacing between pages.
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MouseWheelScrollDelta | Gets or sets the distance the page is scrolled with the mouse wheel.
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageBorderColor | Gets or sets the border color of the pages in the viewer.
Public Property | PageDisplayLayout | Gets or sets the display layout of PDF pages.
Public Property | PageNumber | Gets or sets the page displayed in the control.
Public Property | PageShadowHeight | Gets or sets the page shadow height.
Public Property | PageShadowWidth | Gets or sets the page shadow width.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | RenderingProgressColor | Gets or sets the color of the rendering progress bar.
Public Property | RenderingProgressDisplay | Gets or sets the mode used for displaying the page rendering progress.
Public Property | RenderPageOnZoomOut | Gets or sets a value indicating whether the page should be rendered again when zooming out.
Public Property | RequiredFormFieldHighlightColor | Gets or sets the color for highlighting the required form fields.
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | ScrollPosition | Gets or sets the current scroll position.
Public Property | SearchResultHighlightColor | Gets or sets the color for highlighting the search results.
Public Property | ShowAnnotations | Gets or sets a value indicating whether the annotations should be displayed or not.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | SubstituteFonts | Specifies a collection of fonts to be used when the corresponding font is not embedded in the PDF file.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | TextSelectionColor | Gets or sets the color for highlighting the text selection.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | UseWinFormsControlsForFormFields | Gets or sets a value indicating whether standard windows forms controls should be used for form fields editing.
Public Property | VerticalPageSpacing | Gets or sets the vertical spacing between pages.
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | WorkMode | Gets or sets the control's work mode.
Public Property | Zoom | Gets or sets the zoom factor.
Public Property | ZoomMode | Gets or sets the current zoom mode.
Top
See Also

Reference

PDFPageView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

ActivePageBorderColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ActivePageBorderColor Property
Gets or sets the border color of the active page in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<CategoryAttribute("PDF")>
<DescriptionAttribute("Border color of current page")>
Public Property ActivePageBorderColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.ActivePageBorderColor = value

value = instance.ActivePageBorderColor
[DefaultValue()]
[Browsable(true)]
[Category("PDF")]
[Description("Border color of current page")]
public Color ActivePageBorderColor {get; set;}
[DefaultValue()]
[Browsable(true)]
[Category("PDF")]
[Description("Border color of current page")]
public: __property Color get_ActivePageBorderColor();
public: __property void set_ActivePageBorderColor(
   Color value
);
[DefaultValue()]
[Browsable(true)]
[Category("PDF")]
[Description("Border color of current page")]
public:
property Color ActivePageBorderColor {
   Color get();
   void set (    Color value);
}

Property Value

The border color of the active page in the viewer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AllowFormFill Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AllowFormFill Property
Gets or sets a value indicating whether form filling is allowed or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF Forms")>
<DescriptionAttribute("Enables interactive form fill in the control")>
<DefaultValueAttribute()>
Public Property AllowFormFill As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.AllowFormFill = value

value = instance.AllowFormFill
[Category("PDF Forms")]
[Description("Enables interactive form fill in the control")]
[DefaultValue()]
public bool AllowFormFill {get; set;}
[Category("PDF Forms")]
[Description("Enables interactive form fill in the control")]
[DefaultValue()]
public: __property bool get_AllowFormFill();
public: __property void set_AllowFormFill(
   bool value
);
[Category("PDF Forms")]
[Description("Enables interactive form fill in the control")]
[DefaultValue()]
public:
property bool AllowFormFill {
   bool get();
   void set (    bool value);
}

Property Value

True if the end-user can fill the form, false otherwise. Default is true.
Remarks
This property lets you disable the interactive form filling without modifying the PDF form (make the form fields read only).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AnnotationToolTips Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AnnotationToolTips Property
Gets or sets the annotation tooltips.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Controls the way the tooltips are displayed for annotations")>
<BrowsableAttribute(False)>
<CategoryAttribute("PDF Annotations")>
<DefaultValueAttribute()>
Public Property AnnotationToolTips As PDFAnnotationToolTip
'Usage

Dim instance As PDFPageView
Dim value As PDFAnnotationToolTip

instance.AnnotationToolTips = value

value = instance.AnnotationToolTips
[Description("Controls the way the tooltips are displayed for annotations")]
[Browsable(false)]
[Category("PDF Annotations")]
[DefaultValue()]
public PDFAnnotationToolTip AnnotationToolTips {get; set;}
[Description("Controls the way the tooltips are displayed for annotations")]
[Browsable(false)]
[Category("PDF Annotations")]
[DefaultValue()]
public: __property PDFAnnotationToolTip* get_AnnotationToolTips();
public: __property void set_AnnotationToolTips(
   PDFAnnotationToolTip* value
);
[Description("Controls the way the tooltips are displayed for annotations")]
[Browsable(false)]
[Category("PDF Annotations")]
[DefaultValue()]
public:
property PDFAnnotationToolTip^ AnnotationToolTips {
   PDFAnnotationToolTip^ get();
   void set (    PDFAnnotationToolTip^ value);
}

Property Value

A PDFAnnotationToolTip object that describes how tooltips should be displayed for annotations.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

CacheRenderedPages Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : CacheRenderedPages Property
Gets or sets a value indicating whether the rendered pages should be cached.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
<DescriptionAttribute("Enables the cache of rendered pages.")>
Public Property CacheRenderedPages As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.CacheRenderedPages = value

value = instance.CacheRenderedPages
[DefaultValue()]
[Category("PDF")]
[Description("Enables the cache of rendered pages.")]
public bool CacheRenderedPages {get; set;}
[DefaultValue()]
[Category("PDF")]
[Description("Enables the cache of rendered pages.")]
public: __property bool get_CacheRenderedPages();
public: __property void set_CacheRenderedPages(
   bool value
);
[DefaultValue()]
[Category("PDF")]
[Description("Enables the cache of rendered pages.")]
public:
property bool CacheRenderedPages {
   bool get();
   void set (    bool value);
}

Property Value

True if the rendered pages should be cached, false otherwise. Default is true.
Remarks
Caching of rendered pages improves the display speed when the page is displayed again but this also increases memory consumption, depending on how complex the page content is.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

Cursor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : Cursor Property
Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides Property Cursor As Cursor
'Usage

Dim instance As PDFPageView
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public override Cursor Cursor {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property Cursor* get_Cursor() override;
public: __property void set_Cursor(
   Cursor* value
) override;
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property Cursor^ Cursor {
   Cursor^ get() override;
   void set (    Cursor^ value) override;
}

Property Value

A Cursor that represents the cursor to display when the mouse pointer is over the control.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultEllipseAnnotationBorderColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultEllipseAnnotationBorderColor Property
Gets or sets the default border color for ellipse annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Default color for drawing the border of ellipse annotations")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF Annotations")>
<BrowsableAttribute(True)>
Public Property DefaultEllipseAnnotationBorderColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.DefaultEllipseAnnotationBorderColor = value

value = instance.DefaultEllipseAnnotationBorderColor
[Description("Default color for drawing the border of ellipse annotations")]
[DefaultValue()]
[Category("PDF Annotations")]
[Browsable(true)]
public Color DefaultEllipseAnnotationBorderColor {get; set;}
[Description("Default color for drawing the border of ellipse annotations")]
[DefaultValue()]
[Category("PDF Annotations")]
[Browsable(true)]
public: __property Color get_DefaultEllipseAnnotationBorderColor();
public: __property void set_DefaultEllipseAnnotationBorderColor(
   Color value
);
[Description("Default color for drawing the border of ellipse annotations")]
[DefaultValue()]
[Category("PDF Annotations")]
[Browsable(true)]
public:
property Color DefaultEllipseAnnotationBorderColor {
   Color get();
   void set (    Color value);
}

Property Value

The default color used to draw the border of ellipse annotation on the screen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultEllipseAnnotationBorderWidth Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultEllipseAnnotationBorderWidth Property
Gets or sets the default border width for ellipse annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Default pen width for drawing the border of ellipse annotations")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF Annotations")>
Public Property DefaultEllipseAnnotationBorderWidth As Double
'Usage

Dim instance As PDFPageView
Dim value As Double

instance.DefaultEllipseAnnotationBorderWidth = value

value = instance.DefaultEllipseAnnotationBorderWidth
[Browsable(true)]
[Description("Default pen width for drawing the border of ellipse annotations")]
[DefaultValue()]
[Category("PDF Annotations")]
public double DefaultEllipseAnnotationBorderWidth {get; set;}
[Browsable(true)]
[Description("Default pen width for drawing the border of ellipse annotations")]
[DefaultValue()]
[Category("PDF Annotations")]
public: __property double get_DefaultEllipseAnnotationBorderWidth();
public: __property void set_DefaultEllipseAnnotationBorderWidth(
   double value
);
[Browsable(true)]
[Description("Default pen width for drawing the border of ellipse annotations")]
[DefaultValue()]
[Category("PDF Annotations")]
public:
property double DefaultEllipseAnnotationBorderWidth {
   double get();
   void set (    double value);
}

Property Value

The default width of the pen used to draw the border of ellipse annotation on the screen.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thown when the value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultEllipseAnnotationInteriorColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultEllipseAnnotationInteriorColor Property
Gets or sets the default interior color for ellipse annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF Annotations")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute("Default color for drawing the interior of ellipse annotations")>
Public Property DefaultEllipseAnnotationInteriorColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.DefaultEllipseAnnotationInteriorColor = value

value = instance.DefaultEllipseAnnotationInteriorColor
[Category("PDF Annotations")]
[DefaultValue()]
[Browsable(true)]
[Description("Default color for drawing the interior of ellipse annotations")]
public Color DefaultEllipseAnnotationInteriorColor {get; set;}
[Category("PDF Annotations")]
[DefaultValue()]
[Browsable(true)]
[Description("Default color for drawing the interior of ellipse annotations")]
public: __property Color get_DefaultEllipseAnnotationInteriorColor();
public: __property void set_DefaultEllipseAnnotationInteriorColor(
   Color value
);
[Category("PDF Annotations")]
[DefaultValue()]
[Browsable(true)]
[Description("Default color for drawing the interior of ellipse annotations")]
public:
property Color DefaultEllipseAnnotationInteriorColor {
   Color get();
   void set (    Color value);
}

Property Value

The default color used to draw the interior of ellipse annotation on the screen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultHighlightAnnotationColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultHighlightAnnotationColor Property
Gets or sets the default highlight color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Default color for drawing highlight annotations")>
<CategoryAttribute("PDF Annotations")>
Public Property DefaultHighlightAnnotationColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.DefaultHighlightAnnotationColor = value

value = instance.DefaultHighlightAnnotationColor
[Browsable(true)]
[DefaultValue()]
[Description("Default color for drawing highlight annotations")]
[Category("PDF Annotations")]
public Color DefaultHighlightAnnotationColor {get; set;}
[Browsable(true)]
[DefaultValue()]
[Description("Default color for drawing highlight annotations")]
[Category("PDF Annotations")]
public: __property Color get_DefaultHighlightAnnotationColor();
public: __property void set_DefaultHighlightAnnotationColor(
   Color value
);
[Browsable(true)]
[DefaultValue()]
[Description("Default color for drawing highlight annotations")]
[Category("PDF Annotations")]
public:
property Color DefaultHighlightAnnotationColor {
   Color get();
   void set (    Color value);
}

Property Value

The default color used to draw the highlight annotation on the screen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultInkAnnotationColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultInkAnnotationColor Property
Gets or sets the default ink color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("PDF Annotations")>
<DescriptionAttribute("Default color for drawing ink annotations")>
Public Property DefaultInkAnnotationColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.DefaultInkAnnotationColor = value

value = instance.DefaultInkAnnotationColor
[Browsable(true)]
[DefaultValue()]
[Category("PDF Annotations")]
[Description("Default color for drawing ink annotations")]
public Color DefaultInkAnnotationColor {get; set;}
[Browsable(true)]
[DefaultValue()]
[Category("PDF Annotations")]
[Description("Default color for drawing ink annotations")]
public: __property Color get_DefaultInkAnnotationColor();
public: __property void set_DefaultInkAnnotationColor(
   Color value
);
[Browsable(true)]
[DefaultValue()]
[Category("PDF Annotations")]
[Description("Default color for drawing ink annotations")]
public:
property Color DefaultInkAnnotationColor {
   Color get();
   void set (    Color value);
}

Property Value

The default color used to draw the ink annotation on the screen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultInkAnnotationWidth Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultInkAnnotationWidth Property
Gets or sets the default ink width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Default pen width for drawing ink annotations")>
<CategoryAttribute("PDF Annotations")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property DefaultInkAnnotationWidth As Double
'Usage

Dim instance As PDFPageView
Dim value As Double

instance.DefaultInkAnnotationWidth = value

value = instance.DefaultInkAnnotationWidth
[Description("Default pen width for drawing ink annotations")]
[Category("PDF Annotations")]
[Browsable(true)]
[DefaultValue()]
public double DefaultInkAnnotationWidth {get; set;}
[Description("Default pen width for drawing ink annotations")]
[Category("PDF Annotations")]
[Browsable(true)]
[DefaultValue()]
public: __property double get_DefaultInkAnnotationWidth();
public: __property void set_DefaultInkAnnotationWidth(
   double value
);
[Description("Default pen width for drawing ink annotations")]
[Category("PDF Annotations")]
[Browsable(true)]
[DefaultValue()]
public:
property double DefaultInkAnnotationWidth {
   double get();
   void set (    double value);
}

Property Value

The default width of the pen used to draw the ink annotation on the screen.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thown when the value is less than or equal to zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultMeasureAnnotationScaleAndUnit Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultMeasureAnnotationScaleAndUnit Property
Gets or sets the scale and unit a unit in the PDF file corresponds to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<CategoryAttribute("PDF Annotations")>
<DescriptionAttribute("Unit and scale for converting a PDF point")>
<DefaultValueAttribute()>
Public Property DefaultMeasureAnnotationScaleAndUnit As String
'Usage

Dim instance As PDFPageView
Dim value As String

instance.DefaultMeasureAnnotationScaleAndUnit = value

value = instance.DefaultMeasureAnnotationScaleAndUnit
[Browsable(true)]
[Category("PDF Annotations")]
[Description("Unit and scale for converting a PDF point")]
[DefaultValue()]
public string DefaultMeasureAnnotationScaleAndUnit {get; set;}
[Browsable(true)]
[Category("PDF Annotations")]
[Description("Unit and scale for converting a PDF point")]
[DefaultValue()]
public: __property string* get_DefaultMeasureAnnotationScaleAndUnit();
public: __property void set_DefaultMeasureAnnotationScaleAndUnit(
   string* value
);
[Browsable(true)]
[Category("PDF Annotations")]
[Description("Unit and scale for converting a PDF point")]
[DefaultValue()]
public:
property String^ DefaultMeasureAnnotationScaleAndUnit {
   String^ get();
   void set (    String^ value);
}

Property Value

The real word unit and scale a unit in the PDF file corresponds to.
Remarks
The format of this property is "scale unit = scale unit", such as "1 pt = 10 ft" meaning that 1 point corresponds to 10 feet. Supported units are "mm" (millimeter), "cm" (centimeter), "m" (meter), "km" (kilometer), "pt" (point), "in" (inch), "ft" (foot) and "mi" (mile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultRectangleAnnotationBorderColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultRectangleAnnotationBorderColor Property
Gets or sets the default border color for rectangle annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Annotations")>
<DescriptionAttribute("Default color for drawing the border of rectangle annotations")>
Public Property DefaultRectangleAnnotationBorderColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.DefaultRectangleAnnotationBorderColor = value

value = instance.DefaultRectangleAnnotationBorderColor
[DefaultValue()]
[Browsable(true)]
[Category("PDF Annotations")]
[Description("Default color for drawing the border of rectangle annotations")]
public Color DefaultRectangleAnnotationBorderColor {get; set;}
[DefaultValue()]
[Browsable(true)]
[Category("PDF Annotations")]
[Description("Default color for drawing the border of rectangle annotations")]
public: __property Color get_DefaultRectangleAnnotationBorderColor();
public: __property void set_DefaultRectangleAnnotationBorderColor(
   Color value
);
[DefaultValue()]
[Browsable(true)]
[Category("PDF Annotations")]
[Description("Default color for drawing the border of rectangle annotations")]
public:
property Color DefaultRectangleAnnotationBorderColor {
   Color get();
   void set (    Color value);
}

Property Value

The default color used to draw the border of rectangle annotation on the screen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultRectangleAnnotationBorderWidth Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultRectangleAnnotationBorderWidth Property
Gets or sets the default border width for rectangle annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF Annotations")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Default pen width for drawing the border of rectangle annotations")>
Public Property DefaultRectangleAnnotationBorderWidth As Double
'Usage

Dim instance As PDFPageView
Dim value As Double

instance.DefaultRectangleAnnotationBorderWidth = value

value = instance.DefaultRectangleAnnotationBorderWidth
[Category("PDF Annotations")]
[Browsable(true)]
[DefaultValue()]
[Description("Default pen width for drawing the border of rectangle annotations")]
public double DefaultRectangleAnnotationBorderWidth {get; set;}
[Category("PDF Annotations")]
[Browsable(true)]
[DefaultValue()]
[Description("Default pen width for drawing the border of rectangle annotations")]
public: __property double get_DefaultRectangleAnnotationBorderWidth();
public: __property void set_DefaultRectangleAnnotationBorderWidth(
   double value
);
[Category("PDF Annotations")]
[Browsable(true)]
[DefaultValue()]
[Description("Default pen width for drawing the border of rectangle annotations")]
public:
property double DefaultRectangleAnnotationBorderWidth {
   double get();
   void set (    double value);
}

Property Value

The default width of the pen used to draw the border of rectangle annotation on the screen.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thown when the value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DefaultRectangleAnnotationInteriorColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DefaultRectangleAnnotationInteriorColor Property
Gets or sets the default interior color for rectangle annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF Annotations")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute("Default color for drawing the interior of rectangle annotations")>
Public Property DefaultRectangleAnnotationInteriorColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.DefaultRectangleAnnotationInteriorColor = value

value = instance.DefaultRectangleAnnotationInteriorColor
[Category("PDF Annotations")]
[DefaultValue()]
[Browsable(true)]
[Description("Default color for drawing the interior of rectangle annotations")]
public Color DefaultRectangleAnnotationInteriorColor {get; set;}
[Category("PDF Annotations")]
[DefaultValue()]
[Browsable(true)]
[Description("Default color for drawing the interior of rectangle annotations")]
public: __property Color get_DefaultRectangleAnnotationInteriorColor();
public: __property void set_DefaultRectangleAnnotationInteriorColor(
   Color value
);
[Category("PDF Annotations")]
[DefaultValue()]
[Browsable(true)]
[Description("Default color for drawing the interior of rectangle annotations")]
public:
property Color DefaultRectangleAnnotationInteriorColor {
   Color get();
   void set (    Color value);
}

Property Value

The default color used to draw the interior of rectangle annotation on the screen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

Document Property (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : Document Property
Gets or sets the document displayed by this control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The document displayed in the control")>
<CategoryAttribute("PDF")>
<DefaultValueAttribute()>
Public Property Document As PDFDocument
'Usage

Dim instance As PDFPageView
Dim value As PDFDocument

instance.Document = value

value = instance.Document
[Description("The document displayed in the control")]
[Category("PDF")]
[DefaultValue()]
public PDFDocument Document {get; set;}
[Description("The document displayed in the control")]
[Category("PDF")]
[DefaultValue()]
public: __property PDFDocument* get_Document();
public: __property void set_Document(
   PDFDocument* value
);
[Description("The document displayed in the control")]
[Category("PDF")]
[DefaultValue()]
public:
property PDFDocument^ Document {
   PDFDocument^ get();
   void set (    PDFDocument^ value);
}

Property Value

A PDFDocument object representing the document displayed in the viewer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

DownscaleLargeImages Property (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : DownscaleLargeImages Property
Gets or sets a value indicating whether large images should be down scaled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Enables the downscaling of large images in a PDF page.")>
<CategoryAttribute("PDF")>
Public Property DownscaleLargeImages As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.DownscaleLargeImages = value

value = instance.DownscaleLargeImages
[DefaultValue()]
[Description("Enables the downscaling of large images in a PDF page.")]
[Category("PDF")]
public bool DownscaleLargeImages {get; set;}
[DefaultValue()]
[Description("Enables the downscaling of large images in a PDF page.")]
[Category("PDF")]
public: __property bool get_DownscaleLargeImages();
public: __property void set_DownscaleLargeImages(
   bool value
);
[DefaultValue()]
[Description("Enables the downscaling of large images in a PDF page.")]
[Category("PDF")]
public:
property bool DownscaleLargeImages {
   bool get();
   void set (    bool value);
}

Property Value

If true, large images are scaled down before they are displayed.
Remarks
Very large images can show memory problems when they are displayed. If this property is true, a large image is reduced in size before it is painted on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

EnableKeyboardScroll Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : EnableKeyboardScroll Property
Gets or sets a value indicating whether scrolling through pages using the keyboard is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DefaultValueAttribute()>
<DescriptionAttribute("Enables scrolling of pages using the keyboard.")>
Public Property EnableKeyboardScroll As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.EnableKeyboardScroll = value

value = instance.EnableKeyboardScroll
[Category("PDF")]
[DefaultValue()]
[Description("Enables scrolling of pages using the keyboard.")]
public bool EnableKeyboardScroll {get; set;}
[Category("PDF")]
[DefaultValue()]
[Description("Enables scrolling of pages using the keyboard.")]
public: __property bool get_EnableKeyboardScroll();
public: __property void set_EnableKeyboardScroll(
   bool value
);
[Category("PDF")]
[DefaultValue()]
[Description("Enables scrolling of pages using the keyboard.")]
public:
property bool EnableKeyboardScroll {
   bool get();
   void set (    bool value);
}

Property Value

True if the pages can be scrolled using the keyboard, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

EnableRepeatedKeys Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : EnableRepeatedKeys Property
Gets or sets a value indicating whether keeping a key pressed generates multiple characters or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Enables repeated characters in textboxes by keeping pressed a key.")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
Public Property EnableRepeatedKeys As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.EnableRepeatedKeys = value

value = instance.EnableRepeatedKeys
[Description("Enables repeated characters in textboxes by keeping pressed a key.")]
[DefaultValue()]
[Category("PDF")]
public bool EnableRepeatedKeys {get; set;}
[Description("Enables repeated characters in textboxes by keeping pressed a key.")]
[DefaultValue()]
[Category("PDF")]
public: __property bool get_EnableRepeatedKeys();
public: __property void set_EnableRepeatedKeys(
   bool value
);
[Description("Enables repeated characters in textboxes by keeping pressed a key.")]
[DefaultValue()]
[Category("PDF")]
public:
property bool EnableRepeatedKeys {
   bool get();
   void set (    bool value);
}

Property Value

True if keeping a key pressed generates repeated characters, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

FormFieldHighlightColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : FormFieldHighlightColor Property
Gets or sets the color for highlighting the form fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF Forms")>
<DescriptionAttribute("Highlight color for form fields")>
<DefaultValueAttribute()>
Public Property FormFieldHighlightColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.FormFieldHighlightColor = value

value = instance.FormFieldHighlightColor
[Category("PDF Forms")]
[Description("Highlight color for form fields")]
[DefaultValue()]
public Color FormFieldHighlightColor {get; set;}
[Category("PDF Forms")]
[Description("Highlight color for form fields")]
[DefaultValue()]
public: __property Color get_FormFieldHighlightColor();
public: __property void set_FormFieldHighlightColor(
   Color value
);
[Category("PDF Forms")]
[Description("Highlight color for form fields")]
[DefaultValue()]
public:
property Color FormFieldHighlightColor {
   Color get();
   void set (    Color value);
}

Property Value

The highlight color for form fields.
Remarks
It is recommended to use a transparent color (alpha less than 255) for this property, otherwise the field content under highlight will not be visible.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

HighlightFormFields Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : HighlightFormFields Property
Gets or sets a value indicating whether form fields are highlighted on the page or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF Forms")>
<DescriptionAttribute("Highlights the form fields on the page")>
<DefaultValueAttribute()>
Public Property HighlightFormFields As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.HighlightFormFields = value

value = instance.HighlightFormFields
[Category("PDF Forms")]
[Description("Highlights the form fields on the page")]
[DefaultValue()]
public bool HighlightFormFields {get; set;}
[Category("PDF Forms")]
[Description("Highlights the form fields on the page")]
[DefaultValue()]
public: __property bool get_HighlightFormFields();
public: __property void set_HighlightFormFields(
   bool value
);
[Category("PDF Forms")]
[Description("Highlights the form fields on the page")]
[DefaultValue()]
public:
property bool HighlightFormFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the form fields are highlighted on the page, otherwise false. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

HighlightSelectedAnnotation Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : HighlightSelectedAnnotation Property
Gets or sets a value indicating whether the selected annotation should be highlighted or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF Annotations")>
<DefaultValueAttribute()>
<DescriptionAttribute("Highlights the selected annotation")>
Public Property HighlightSelectedAnnotation As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.HighlightSelectedAnnotation = value

value = instance.HighlightSelectedAnnotation
[Category("PDF Annotations")]
[DefaultValue()]
[Description("Highlights the selected annotation")]
public bool HighlightSelectedAnnotation {get; set;}
[Category("PDF Annotations")]
[DefaultValue()]
[Description("Highlights the selected annotation")]
public: __property bool get_HighlightSelectedAnnotation();
public: __property void set_HighlightSelectedAnnotation(
   bool value
);
[Category("PDF Annotations")]
[DefaultValue()]
[Description("Highlights the selected annotation")]
public:
property bool HighlightSelectedAnnotation {
   bool get();
   void set (    bool value);
}

Property Value

True if the selected annotation should be highlighted, false otherwise. Default is true.
Remarks
The selected annotation is highlighted by drawing a dotted rectangle around the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

HorizontalPageSpacing Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : HorizontalPageSpacing Property
Gets or sets the horizontal spacing between pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
<DescriptionAttribute("Horizontal space between pages")>
Public Property HorizontalPageSpacing As Integer
'Usage

Dim instance As PDFPageView
Dim value As Integer

instance.HorizontalPageSpacing = value

value = instance.HorizontalPageSpacing
[DefaultValue()]
[Category("PDF")]
[Description("Horizontal space between pages")]
public int HorizontalPageSpacing {get; set;}
[DefaultValue()]
[Category("PDF")]
[Description("Horizontal space between pages")]
public: __property int get_HorizontalPageSpacing();
public: __property void set_HorizontalPageSpacing(
   int value
);
[DefaultValue()]
[Category("PDF")]
[Description("Horizontal space between pages")]
public:
property int HorizontalPageSpacing {
   int get();
   void set (    int value);
}

Property Value

The horizontal space between pages when a two column page display mode is selected.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

MouseWheelScrollDelta Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : MouseWheelScrollDelta Property
Gets or sets the distance the page is scrolled with the mouse wheel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Scroll distance for the mouse wheel.")>
<CategoryAttribute("PDF")>
Public Property MouseWheelScrollDelta As Integer
'Usage

Dim instance As PDFPageView
Dim value As Integer

instance.MouseWheelScrollDelta = value

value = instance.MouseWheelScrollDelta
[DefaultValue()]
[Description("Scroll distance for the mouse wheel.")]
[Category("PDF")]
public int MouseWheelScrollDelta {get; set;}
[DefaultValue()]
[Description("Scroll distance for the mouse wheel.")]
[Category("PDF")]
public: __property int get_MouseWheelScrollDelta();
public: __property void set_MouseWheelScrollDelta(
   int value
);
[DefaultValue()]
[Description("Scroll distance for the mouse wheel.")]
[Category("PDF")]
public:
property int MouseWheelScrollDelta {
   int get();
   void set (    int value);
}

Property Value

The amount of pixels the page is scrolled with the mouse wheel.
Remarks
The page is scrolled up and down with the number of pixels specified by this property when using the mouse wheel.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageBorderColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageBorderColor Property
Gets or sets the border color of the pages in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
<DescriptionAttribute("Border color of displayed pages")>
Public Property PageBorderColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.PageBorderColor = value

value = instance.PageBorderColor
[Browsable(true)]
[DefaultValue()]
[Category("PDF")]
[Description("Border color of displayed pages")]
public Color PageBorderColor {get; set;}
[Browsable(true)]
[DefaultValue()]
[Category("PDF")]
[Description("Border color of displayed pages")]
public: __property Color get_PageBorderColor();
public: __property void set_PageBorderColor(
   Color value
);
[Browsable(true)]
[DefaultValue()]
[Category("PDF")]
[Description("Border color of displayed pages")]
public:
property Color PageBorderColor {
   Color get();
   void set (    Color value);
}

Property Value

The border color of the pages in the viewer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageDisplayLayout Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageDisplayLayout Property
Gets or sets the display layout of PDF pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
<DescriptionAttribute("The display layout for PDF pages.")>
Public Property PageDisplayLayout As PDFPageDisplayLayout
'Usage

Dim instance As PDFPageView
Dim value As PDFPageDisplayLayout

instance.PageDisplayLayout = value

value = instance.PageDisplayLayout
[DefaultValue()]
[Category("PDF")]
[Description("The display layout for PDF pages.")]
public PDFPageDisplayLayout PageDisplayLayout {get; set;}
[DefaultValue()]
[Category("PDF")]
[Description("The display layout for PDF pages.")]
public: __property PDFPageDisplayLayout get_PageDisplayLayout();
public: __property void set_PageDisplayLayout(
   PDFPageDisplayLayout value
);
[DefaultValue()]
[Category("PDF")]
[Description("The display layout for PDF pages.")]
public:
property PDFPageDisplayLayout PageDisplayLayout {
   PDFPageDisplayLayout get();
   void set (    PDFPageDisplayLayout value);
}

Property Value

The layout of PDF pages displayed in the control.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageNumber Property (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageNumber Property
Gets or sets the page displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Current page being displayed in the control")>
<CategoryAttribute("PDF")>
Public Property PageNumber As Integer
'Usage

Dim instance As PDFPageView
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
[DefaultValue()]
[Description("Current page being displayed in the control")]
[Category("PDF")]
public int PageNumber {get; set;}
[DefaultValue()]
[Description("Current page being displayed in the control")]
[Category("PDF")]
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
[DefaultValue()]
[Description("Current page being displayed in the control")]
[Category("PDF")]
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

The number of the page displayed in the control.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown if value is less than 0 or greater than or equal to the number of pages in the document.
Remarks
The page number starts at 0 for first page. If there is no PDF file loaded in the control, the value is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageShadowHeight Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageShadowHeight Property
Gets or sets the page shadow height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Shadow height for displayed pages.")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
Public Property PageShadowHeight As Integer
'Usage

Dim instance As PDFPageView
Dim value As Integer

instance.PageShadowHeight = value

value = instance.PageShadowHeight
[Description("Shadow height for displayed pages.")]
[DefaultValue()]
[Category("PDF")]
public int PageShadowHeight {get; set;}
[Description("Shadow height for displayed pages.")]
[DefaultValue()]
[Category("PDF")]
public: __property int get_PageShadowHeight();
public: __property void set_PageShadowHeight(
   int value
);
[Description("Shadow height for displayed pages.")]
[DefaultValue()]
[Category("PDF")]
public:
property int PageShadowHeight {
   int get();
   void set (    int value);
}

Property Value

The height of the page shadow.
Remarks
If this value is zero, no vertical shadow is displayed. A positive value will display a shadow on the bottom side of the page, a negative value will display a shadow on the top side of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageShadowWidth Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageShadowWidth Property
Gets or sets the page shadow width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DefaultValueAttribute()>
<DescriptionAttribute("Shadow width for displayed pages.")>
Public Property PageShadowWidth As Integer
'Usage

Dim instance As PDFPageView
Dim value As Integer

instance.PageShadowWidth = value

value = instance.PageShadowWidth
[Category("PDF")]
[DefaultValue()]
[Description("Shadow width for displayed pages.")]
public int PageShadowWidth {get; set;}
[Category("PDF")]
[DefaultValue()]
[Description("Shadow width for displayed pages.")]
public: __property int get_PageShadowWidth();
public: __property void set_PageShadowWidth(
   int value
);
[Category("PDF")]
[DefaultValue()]
[Description("Shadow width for displayed pages.")]
public:
property int PageShadowWidth {
   int get();
   void set (    int value);
}

Property Value

The width of the page shadow.
Remarks
If this value is zero, no horizontal shadow is displayed. A positive value will display a shadow on the right side of the page, a negative value will display a shadow on the left side of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

RenderingProgressColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : RenderingProgressColor Property
Gets or sets the color of the rendering progress bar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The page rendering progress bar color.")>
<DefaultValueAttribute()>
<CategoryAttribute("Display")>
Public Property RenderingProgressColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.RenderingProgressColor = value

value = instance.RenderingProgressColor
[Description("The page rendering progress bar color.")]
[DefaultValue()]
[Category("Display")]
public Color RenderingProgressColor {get; set;}
[Description("The page rendering progress bar color.")]
[DefaultValue()]
[Category("Display")]
public: __property Color get_RenderingProgressColor();
public: __property void set_RenderingProgressColor(
   Color value
);
[Description("The page rendering progress bar color.")]
[DefaultValue()]
[Category("Display")]
public:
property Color RenderingProgressColor {
   Color get();
   void set (    Color value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

RenderingProgressDisplay Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : RenderingProgressDisplay Property
Gets or sets the mode used for displaying the page rendering progress.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The page rendering progress mode.")>
<DefaultValueAttribute()>
<CategoryAttribute("Display")>
Public Property RenderingProgressDisplay As PDFRenderingProgressDisplayMode
'Usage

Dim instance As PDFPageView
Dim value As PDFRenderingProgressDisplayMode

instance.RenderingProgressDisplay = value

value = instance.RenderingProgressDisplay
[Description("The page rendering progress mode.")]
[DefaultValue()]
[Category("Display")]
public PDFRenderingProgressDisplayMode RenderingProgressDisplay {get; set;}
[Description("The page rendering progress mode.")]
[DefaultValue()]
[Category("Display")]
public: __property PDFRenderingProgressDisplayMode get_RenderingProgressDisplay();
public: __property void set_RenderingProgressDisplay(
   PDFRenderingProgressDisplayMode value
);
[Description("The page rendering progress mode.")]
[DefaultValue()]
[Category("Display")]
public:
property PDFRenderingProgressDisplayMode RenderingProgressDisplay {
   PDFRenderingProgressDisplayMode get();
   void set (    PDFRenderingProgressDisplayMode value);
}

Property Value

A PDFRenderingProgressDisplayMode value specifying how the page rendering progress should be displayed to the viewer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

RenderPageOnZoomOut Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : RenderPageOnZoomOut Property
Gets or sets a value indicating whether the page should be rendered again when zooming out.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Enables the cache of rendered pages.")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
Public Property RenderPageOnZoomOut As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.RenderPageOnZoomOut = value

value = instance.RenderPageOnZoomOut
[Description("Enables the cache of rendered pages.")]
[DefaultValue()]
[Category("PDF")]
public bool RenderPageOnZoomOut {get; set;}
[Description("Enables the cache of rendered pages.")]
[DefaultValue()]
[Category("PDF")]
public: __property bool get_RenderPageOnZoomOut();
public: __property void set_RenderPageOnZoomOut(
   bool value
);
[Description("Enables the cache of rendered pages.")]
[DefaultValue()]
[Category("PDF")]
public:
property bool RenderPageOnZoomOut {
   bool get();
   void set (    bool value);
}

Property Value

True if the page should be rendered again, false otherwise. Default is false.
Remarks
If the page is rendered in full image at a zoom level, when zooming out the page is not rendered again but the existing rendered page image is scaled down to match the new zoom.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

RequiredFormFieldHighlightColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : RequiredFormFieldHighlightColor Property
Gets or sets the color for highlighting the required form fields.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("PDF Forms")>
<DescriptionAttribute("Highlight color for required form fields")>
Public Property RequiredFormFieldHighlightColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.RequiredFormFieldHighlightColor = value

value = instance.RequiredFormFieldHighlightColor
[DefaultValue()]
[Category("PDF Forms")]
[Description("Highlight color for required form fields")]
public Color RequiredFormFieldHighlightColor {get; set;}
[DefaultValue()]
[Category("PDF Forms")]
[Description("Highlight color for required form fields")]
public: __property Color get_RequiredFormFieldHighlightColor();
public: __property void set_RequiredFormFieldHighlightColor(
   Color value
);
[DefaultValue()]
[Category("PDF Forms")]
[Description("Highlight color for required form fields")]
public:
property Color RequiredFormFieldHighlightColor {
   Color get();
   void set (    Color value);
}

Property Value

The highlight color for required form fields.
Remarks
The required form fields are highlighted by drawing a colored border around them. If the value of this property is Color.Empty then the required fields are not highlighted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ScrollPosition Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ScrollPosition Property
Gets or sets the current scroll position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property ScrollPosition As Point
'Usage

Dim instance As PDFPageView
Dim value As Point

instance.ScrollPosition = value

value = instance.ScrollPosition
[Browsable(false)]
public Point ScrollPosition {get; set;}
[Browsable(false)]
public: __property Point get_ScrollPosition();
public: __property void set_ScrollPosition(
   Point value
);
[Browsable(false)]
public:
property Point ScrollPosition {
   Point get();
   void set (    Point value);
}

Property Value

The position of the scrollbars.
Remarks
This property works the same way like the AutoScrollPosition property.
ScrollPosition represents the location of the scrollable control's display rectangle. The X and Y coordinate values retrieved are negative if the control has scrolled away from its starting position (0,0). When you set this property, you must always assign positive X and Y values to set the scroll position relative to the starting position. For example, if you have a horizontal scroll bar and you set x and y to 200, you move the scroll 200 pixels to the right; if you then set x and y to 100, the scroll appears to jump the left by 100 pixels, because you are setting it 100 pixels away from the starting position. In the first case, ScrollPosition returns {-200, 0}; in the second case, it returns {-100,0}.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

SearchResultHighlightColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : SearchResultHighlightColor Property
Gets or sets the color for highlighting the search results.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Highlight color for search results")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF Search")>
Public Property SearchResultHighlightColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.SearchResultHighlightColor = value

value = instance.SearchResultHighlightColor
[Description("Highlight color for search results")]
[DefaultValue()]
[Category("PDF Search")]
public Color SearchResultHighlightColor {get; set;}
[Description("Highlight color for search results")]
[DefaultValue()]
[Category("PDF Search")]
public: __property Color get_SearchResultHighlightColor();
public: __property void set_SearchResultHighlightColor(
   Color value
);
[Description("Highlight color for search results")]
[DefaultValue()]
[Category("PDF Search")]
public:
property Color SearchResultHighlightColor {
   Color get();
   void set (    Color value);
}

Property Value

The highlight color for search results.
Remarks
It is recommended to use a transparent color (alpha less than 255) for this property, otherwise the text under highlight will not be visible.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ShowAnnotations Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ShowAnnotations Property
Gets or sets a value indicating whether the annotations should be displayed or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<CategoryAttribute("PDF Annotations")>
<DescriptionAttribute("Displays the annotations")>
Public Property ShowAnnotations As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.ShowAnnotations = value

value = instance.ShowAnnotations
[DefaultValue()]
[Category("PDF Annotations")]
[Description("Displays the annotations")]
public bool ShowAnnotations {get; set;}
[DefaultValue()]
[Category("PDF Annotations")]
[Description("Displays the annotations")]
public: __property bool get_ShowAnnotations();
public: __property void set_ShowAnnotations(
   bool value
);
[DefaultValue()]
[Category("PDF Annotations")]
[Description("Displays the annotations")]
public:
property bool ShowAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

True if the annotations should be displayed, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

SubstituteFonts Property (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : SubstituteFonts Property
Specifies a collection of fonts to be used when the corresponding font is not embedded in the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property SubstituteFonts As Dictionary(Of String,String)
'Usage

Dim instance As PDFPageView
Dim value As Dictionary(Of String,String)

instance.SubstituteFonts = value

value = instance.SubstituteFonts
[Browsable(false)]
public Dictionary<string,string> SubstituteFonts {get; set;}
[Browsable(false)]
public: __property Dictionary<string*,string*>* get_SubstituteFonts();
public: __property void set_SubstituteFonts(
   Dictionary<string*,string*>* value
);
[Browsable(false)]
public:
property Dictionary<String^,String^>^ SubstituteFonts {
   Dictionary<String^,String^>^ get();
   void set (    Dictionary<String^,String^>^ value);
}
Remarks
This collection is searched before searching the local machine for the font. The key is the PDF font name, the value is the path to the corresponding TTF file to be used for rendering.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

TextSelectionColor Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : TextSelectionColor Property
Gets or sets the color for highlighting the text selection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Color for text selection")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF Text Selection")>
Public Property TextSelectionColor As Color
'Usage

Dim instance As PDFPageView
Dim value As Color

instance.TextSelectionColor = value

value = instance.TextSelectionColor
[Description("Color for text selection")]
[DefaultValue()]
[Category("PDF Text Selection")]
public Color TextSelectionColor {get; set;}
[Description("Color for text selection")]
[DefaultValue()]
[Category("PDF Text Selection")]
public: __property Color get_TextSelectionColor();
public: __property void set_TextSelectionColor(
   Color value
);
[Description("Color for text selection")]
[DefaultValue()]
[Category("PDF Text Selection")]
public:
property Color TextSelectionColor {
   Color get();
   void set (    Color value);
}

Property Value

The highlight color for text selection.
Remarks
It is recommended to use a transparent color (alpha less than 255) for this property, otherwise the text under selection will not be visible.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

UseWinFormsControlsForFormFields Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : UseWinFormsControlsForFormFields Property
Gets or sets a value indicating whether standard windows forms controls should be used for form fields editing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF Forms")>
<DescriptionAttribute("Enables windows controls editors")>
<DefaultValueAttribute()>
Public Property UseWinFormsControlsForFormFields As Boolean
'Usage

Dim instance As PDFPageView
Dim value As Boolean

instance.UseWinFormsControlsForFormFields = value

value = instance.UseWinFormsControlsForFormFields
[Category("PDF Forms")]
[Description("Enables windows controls editors")]
[DefaultValue()]
public bool UseWinFormsControlsForFormFields {get; set;}
[Category("PDF Forms")]
[Description("Enables windows controls editors")]
[DefaultValue()]
public: __property bool get_UseWinFormsControlsForFormFields();
public: __property void set_UseWinFormsControlsForFormFields(
   bool value
);
[Category("PDF Forms")]
[Description("Enables windows controls editors")]
[DefaultValue()]
public:
property bool UseWinFormsControlsForFormFields {
   bool get();
   void set (    bool value);
}

Property Value

True if standard windows controls should be used for form fields editing, false otherwise. Default is false.
Remarks
Standard windows controls cannot fully mimic the appearance of a form field during editing but they support all standard key navigation features.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

VerticalPageSpacing Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : VerticalPageSpacing Property
Gets or sets the vertical spacing between pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<CategoryAttribute("PDF")>
<DefaultValueAttribute()>
<DescriptionAttribute("Vertical space between pages")>
Public Property VerticalPageSpacing As Integer
'Usage

Dim instance As PDFPageView
Dim value As Integer

instance.VerticalPageSpacing = value

value = instance.VerticalPageSpacing
[Category("PDF")]
[DefaultValue()]
[Description("Vertical space between pages")]
public int VerticalPageSpacing {get; set;}
[Category("PDF")]
[DefaultValue()]
[Description("Vertical space between pages")]
public: __property int get_VerticalPageSpacing();
public: __property void set_VerticalPageSpacing(
   int value
);
[Category("PDF")]
[DefaultValue()]
[Description("Vertical space between pages")]
public:
property int VerticalPageSpacing {
   int get();
   void set (    int value);
}

Property Value

The vertical space between pages when a continuous page display mode is selected.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

WorkMode Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : WorkMode Property
Gets or sets the control's work mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property WorkMode As UserInteractiveWorkMode
'Usage

Dim instance As PDFPageView
Dim value As UserInteractiveWorkMode

instance.WorkMode = value

value = instance.WorkMode
[Browsable(false)]
public UserInteractiveWorkMode WorkMode {get; set;}
[Browsable(false)]
public: __property UserInteractiveWorkMode get_WorkMode();
public: __property void set_WorkMode(
   UserInteractiveWorkMode value
);
[Browsable(false)]
public:
property UserInteractiveWorkMode WorkMode {
   UserInteractiveWorkMode get();
   void set (    UserInteractiveWorkMode value);
}

Property Value

The user interactive work mode of the control.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

Zoom Property

O2S.Components.PDFView4NET Namespace > PDFPageView Class : Zoom Property
Gets or sets the zoom factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The zoom factor for the displayed pages")>
<DefaultValueAttribute()>
<CategoryAttribute("PDF")>
Public Property Zoom As Double
'Usage

Dim instance As PDFPageView
Dim value As Double

instance.Zoom = value

value = instance.Zoom
[Description("The zoom factor for the displayed pages")]
[DefaultValue()]
[Category("PDF")]
public double Zoom {get; set;}
[Description("The zoom factor for the displayed pages")]
[DefaultValue()]
[Category("PDF")]
public: __property double get_Zoom();
public: __property void set_Zoom(
   double value
);
[Description("The zoom factor for the displayed pages")]
[DefaultValue()]
[Category("PDF")]
public:
property double Zoom {
   double get();
   void set (    double value);
}

Property Value

The zoom factor for displaying the document's pages.
Remarks
The zoom factor is given in percents. Minimum zoom factor is 10%.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ZoomMode Property (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ZoomMode Property
Gets or sets the current zoom mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("The zoom mode for the displayed pages")>
<CategoryAttribute("PDF")>
Public Property ZoomMode As PDFZoomMode
'Usage

Dim instance As PDFPageView
Dim value As PDFZoomMode

instance.ZoomMode = value

value = instance.ZoomMode
[DefaultValue()]
[Description("The zoom mode for the displayed pages")]
[Category("PDF")]
public PDFZoomMode ZoomMode {get; set;}
[DefaultValue()]
[Description("The zoom mode for the displayed pages")]
[Category("PDF")]
public: __property PDFZoomMode get_ZoomMode();
public: __property void set_ZoomMode(
   PDFZoomMode value
);
[DefaultValue()]
[Description("The zoom mode for the displayed pages")]
[Category("PDF")]
public:
property PDFZoomMode ZoomMode {
   PDFZoomMode get();
   void set (    PDFZoomMode value);
}

Property Value

The zoom mode for displaying the current page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%PageItemTitle%% $$Events$$

PDFPageView Class Events

O2S.Components.PDFView4NET Namespace : PDFPageView Class

For a list of all members of this type, see PDFPageView members.

Public Events
 | Name | Description
Public Event | AfterAnnotationAdd | Gets or sets the event that is fired after an annotation has been added to the page displayed in the control.
Public Event | AfterAnnotationMove | Gets or sets the event that is fired after an annotation has been moved on the page.
Public Event | AfterAnnotationResize | Gets or sets the event that is fired after an annotation has been resized.
Public Event | AfterFieldAdd | Gets or sets the event that is fired after a form field has been added to the page displayed in the control.
Public Event | AfterLinkExecute | Gets or sets the event that is fired after a link is executed.
Public Event | AfterTextSelect | Gets or sets the event that is fired after text has been selected on the page.
Public Event | AnnotationClick | Gets or sets the event that is fired when an annotation is clicked with the mouse.
Public Event | AnnotationContextMenu | Gets or sets the event that is fired when a context menu should be displayed for the annotation.
Public Event | AnnotationDoubleClick | Gets or sets the event that is fired when an annotation is double clicked with the mouse.
Public Event | AnnotationToolTipDraw | Gets or sets the event that is fired when an annotation tooltip needs to be drawn.
Public Event | AnnotationToolTipPopup | Gets or sets the event that is fired when an annotation tooltip needs to be shown.
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BeforeAnnotationAdd | Gets or sets the event that is fired before an annotation is added to the page displayed in the control.
Public Event | BeforeFieldAdd | Gets or sets the event that is fired before a form field is added to the page displayed in the control.
Public Event | BeforeLinkExecute | Gets or sets the event that is fired before a link is executed.
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FieldBeginEdit | Gets or sets the event that is fired before a form field enters in edit mode.
Public Event | FieldClick | Gets or sets the event that is fired when a form field is clicked with the mouse.
Public Event | FieldContextMenu | Gets or sets the event that is fired when a context menu should be displayed for the form field.
Public Event | FieldEndEdit | Gets or sets the event that is fired after a form field leaves the edit mode.
Public Event | FieldValidate | Gets or sets the event that is fired when a field value needs to be validated.
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | PageClick | Gets or sets the event that is fired when a page is clicked with the mouse.
Public Event | PageDisplayLayoutChanged | Gets or sets the event that is fired when the page display layout has changed.
Public Event | PageDoubleClick | Gets or sets the event that is fired when a page is double clicked with the mouse.
Public Event | PageNumberChanged | Gets or sets the event that is fired when the page number has changed.
Public Event | PageRenderingError | Gets or sets the event being fired when a page rendering error has occured.
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextSelectionCleared | Gets or sets the event that is fired when the existing text selection is cleared.
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | WorkModeChanged | Gets or sets the event that is fired when the control's work mode has changed.
Public Event | ZoomChanged | Gets or sets the event that is fired when the control's zoom level has changed.
Public Event | ZoomModeChanged | Gets or sets the event that is fired when the control's zoom mode has changed.
Top
See Also

Reference

PDFPageView Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

AfterAnnotationAdd Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AfterAnnotationAdd Event
Gets or sets the event that is fired after an annotation has been added to the page displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterAnnotationAdd As EventHandler(Of AfterAnnotationAddEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AfterAnnotationAddEventArgs)

AddHandler instance.AfterAnnotationAdd, handler
public event EventHandler<AfterAnnotationAddEventArgs> AfterAnnotationAdd
public: __event EventHandler<AfterAnnotationAddEventArgs*>* AfterAnnotationAdd
public:
event EventHandler<AfterAnnotationAddEventArgs^>^ AfterAnnotationAdd
Event Data

The event handler receives an argument of type AfterAnnotationAddEventArgs containing data related to this event. The following AfterAnnotationAddEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that has been added to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AfterAnnotationMove Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AfterAnnotationMove Event
Gets or sets the event that is fired after an annotation has been moved on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterAnnotationMove As EventHandler(Of AfterAnnotationMoveEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AfterAnnotationMoveEventArgs)

AddHandler instance.AfterAnnotationMove, handler
public event EventHandler<AfterAnnotationMoveEventArgs> AfterAnnotationMove
public: __event EventHandler<AfterAnnotationMoveEventArgs*>* AfterAnnotationMove
public:
event EventHandler<AfterAnnotationMoveEventArgs^>^ AfterAnnotationMove
Event Data

The event handler receives an argument of type AfterAnnotationMoveEventArgs containing data related to this event. The following AfterAnnotationMoveEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that has been moved on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AfterAnnotationResize Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AfterAnnotationResize Event
Gets or sets the event that is fired after an annotation has been resized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterAnnotationResize As EventHandler(Of AfterAnnotationResizeEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AfterAnnotationResizeEventArgs)

AddHandler instance.AfterAnnotationResize, handler
public event EventHandler<AfterAnnotationResizeEventArgs> AfterAnnotationResize
public: __event EventHandler<AfterAnnotationResizeEventArgs*>* AfterAnnotationResize
public:
event EventHandler<AfterAnnotationResizeEventArgs^>^ AfterAnnotationResize
Event Data

The event handler receives an argument of type AfterAnnotationResizeEventArgs containing data related to this event. The following AfterAnnotationResizeEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that has been resized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AfterFieldAdd Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AfterFieldAdd Event
Gets or sets the event that is fired after a form field has been added to the page displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterFieldAdd As EventHandler(Of AfterFieldAddEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AfterFieldAddEventArgs)

AddHandler instance.AfterFieldAdd, handler
public event EventHandler<AfterFieldAddEventArgs> AfterFieldAdd
public: __event EventHandler<AfterFieldAddEventArgs*>* AfterFieldAdd
public:
event EventHandler<AfterFieldAddEventArgs^>^ AfterFieldAdd
Event Data

The event handler receives an argument of type AfterFieldAddEventArgs containing data related to this event. The following AfterFieldAddEventArgs properties provide information specific to this event.

Property | Description
Field | Gets the field that has been added to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AfterLinkExecute Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AfterLinkExecute Event
Gets or sets the event that is fired after a link is executed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterLinkExecute As EventHandler(Of AfterLinkExecuteEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AfterLinkExecuteEventArgs)

AddHandler instance.AfterLinkExecute, handler
public event EventHandler<AfterLinkExecuteEventArgs> AfterLinkExecute
public: __event EventHandler<AfterLinkExecuteEventArgs*>* AfterLinkExecute
public:
event EventHandler<AfterLinkExecuteEventArgs^>^ AfterLinkExecute
Event Data

The event handler receives an argument of type AfterLinkExecuteEventArgs containing data related to this event. The following AfterLinkExecuteEventArgs properties provide information specific to this event.

Property | Description
Link | Gets the link that has been executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AfterTextSelect Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AfterTextSelect Event
Gets or sets the event that is fired after text has been selected on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AfterTextSelect As EventHandler(Of AfterTextSelectEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AfterTextSelectEventArgs)

AddHandler instance.AfterTextSelect, handler
public event EventHandler<AfterTextSelectEventArgs> AfterTextSelect
public: __event EventHandler<AfterTextSelectEventArgs*>* AfterTextSelect
public:
event EventHandler<AfterTextSelectEventArgs^>^ AfterTextSelect
Event Data

The event handler receives an argument of type AfterTextSelectEventArgs containing data related to this event. The following AfterTextSelectEventArgs properties provide information specific to this event.

Property | Description
TextSelection | Gets the selected text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AnnotationClick Event (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AnnotationClick Event
Gets or sets the event that is fired when an annotation is clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AnnotationClick As EventHandler(Of AnnotationClickEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AnnotationClickEventArgs)

AddHandler instance.AnnotationClick, handler
public event EventHandler<AnnotationClickEventArgs> AnnotationClick
public: __event EventHandler<AnnotationClickEventArgs*>* AnnotationClick
public:
event EventHandler<AnnotationClickEventArgs^>^ AnnotationClick
Event Data

The event handler receives an argument of type AnnotationClickEventArgs containing data related to this event. The following AnnotationClickEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that has been double clicked.
MouseButton | Gets the mouse button that was clicked on the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AnnotationContextMenu Event (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AnnotationContextMenu Event
Gets or sets the event that is fired when a context menu should be displayed for the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AnnotationContextMenu As EventHandler(Of AnnotationContextMenuEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AnnotationContextMenuEventArgs)

AddHandler instance.AnnotationContextMenu, handler
public event EventHandler<AnnotationContextMenuEventArgs> AnnotationContextMenu
public: __event EventHandler<AnnotationContextMenuEventArgs*>* AnnotationContextMenu
public:
event EventHandler<AnnotationContextMenuEventArgs^>^ AnnotationContextMenu
Event Data

The event handler receives an argument of type AnnotationContextMenuEventArgs containing data related to this event. The following AnnotationContextMenuEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that has been double clicked.
MousePosition | Gets the position where the mouse was clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AnnotationDoubleClick Event (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AnnotationDoubleClick Event
Gets or sets the event that is fired when an annotation is double clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AnnotationDoubleClick As EventHandler(Of AnnotationClickEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AnnotationClickEventArgs)

AddHandler instance.AnnotationDoubleClick, handler
public event EventHandler<AnnotationClickEventArgs> AnnotationDoubleClick
public: __event EventHandler<AnnotationClickEventArgs*>* AnnotationDoubleClick
public:
event EventHandler<AnnotationClickEventArgs^>^ AnnotationDoubleClick
Event Data

The event handler receives an argument of type AnnotationClickEventArgs containing data related to this event. The following AnnotationClickEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that has been double clicked.
MouseButton | Gets the mouse button that was clicked on the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AnnotationToolTipDraw Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AnnotationToolTipDraw Event
Gets or sets the event that is fired when an annotation tooltip needs to be drawn.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AnnotationToolTipDraw As EventHandler(Of AnnotationToolTipDrawEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AnnotationToolTipDrawEventArgs)

AddHandler instance.AnnotationToolTipDraw, handler
public event EventHandler<AnnotationToolTipDrawEventArgs> AnnotationToolTipDraw
public: __event EventHandler<AnnotationToolTipDrawEventArgs*>* AnnotationToolTipDraw
public:
event EventHandler<AnnotationToolTipDrawEventArgs^>^ AnnotationToolTipDraw
Event Data

The event handler receives an argument of type AnnotationToolTipDrawEventArgs containing data related to this event. The following AnnotationToolTipDrawEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation for which the tooltip needs to be drawn.
Bounds | Gets the size and location of the annotation tooltip to draw.
Font | Gets the font used to draw the annotation tooltip.
Graphics | Gets the graphics surface used to draw the annotation tooltip.
ToolTipText | Gets the text for the annotation tooltip that is being drawn.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

AnnotationToolTipPopup Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : AnnotationToolTipPopup Event
Gets or sets the event that is fired when an annotation tooltip needs to be shown.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AnnotationToolTipPopup As EventHandler(Of AnnotationToolTipPopupEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of AnnotationToolTipPopupEventArgs)

AddHandler instance.AnnotationToolTipPopup, handler
public event EventHandler<AnnotationToolTipPopupEventArgs> AnnotationToolTipPopup
public: __event EventHandler<AnnotationToolTipPopupEventArgs*>* AnnotationToolTipPopup
public:
event EventHandler<AnnotationToolTipPopupEventArgs^>^ AnnotationToolTipPopup
Event Data

The event handler receives an argument of type AnnotationToolTipPopupEventArgs containing data related to this event. The following AnnotationToolTipPopupEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation for which the tooltip needs to be shown.
Cancel | Gets or sets a value indicating whether the event should be canceled.
ToolTipSize | Gets or sets the size of the annotation tooltip.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

BeforeAnnotationAdd Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : BeforeAnnotationAdd Event
Gets or sets the event that is fired before an annotation is added to the page displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event BeforeAnnotationAdd As EventHandler(Of BeforeAnnotationAddEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of BeforeAnnotationAddEventArgs)

AddHandler instance.BeforeAnnotationAdd, handler
public event EventHandler<BeforeAnnotationAddEventArgs> BeforeAnnotationAdd
public: __event EventHandler<BeforeAnnotationAddEventArgs*>* BeforeAnnotationAdd
public:
event EventHandler<BeforeAnnotationAddEventArgs^>^ BeforeAnnotationAdd
Event Data

The event handler receives an argument of type BeforeAnnotationAddEventArgs containing data related to this event. The following BeforeAnnotationAddEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that will be added to the document.
Cancel | Gets or sets a value indicating whether the annotation should be added or not.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

BeforeFieldAdd Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : BeforeFieldAdd Event
Gets or sets the event that is fired before a form field is added to the page displayed in the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event BeforeFieldAdd As EventHandler(Of BeforeFieldAddEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of BeforeFieldAddEventArgs)

AddHandler instance.BeforeFieldAdd, handler
public event EventHandler<BeforeFieldAddEventArgs> BeforeFieldAdd
public: __event EventHandler<BeforeFieldAddEventArgs*>* BeforeFieldAdd
public:
event EventHandler<BeforeFieldAddEventArgs^>^ BeforeFieldAdd
Event Data

The event handler receives an argument of type BeforeFieldAddEventArgs containing data related to this event. The following BeforeFieldAddEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the field should be added or not.
Field | Gets the field that will be added to the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

BeforeLinkExecute Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : BeforeLinkExecute Event
Gets or sets the event that is fired before a link is executed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event BeforeLinkExecute As EventHandler(Of BeforeLinkExecuteEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of BeforeLinkExecuteEventArgs)

AddHandler instance.BeforeLinkExecute, handler
public event EventHandler<BeforeLinkExecuteEventArgs> BeforeLinkExecute
public: __event EventHandler<BeforeLinkExecuteEventArgs*>* BeforeLinkExecute
public:
event EventHandler<BeforeLinkExecuteEventArgs^>^ BeforeLinkExecute
Event Data

The event handler receives an argument of type BeforeLinkExecuteEventArgs containing data related to this event. The following BeforeLinkExecuteEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the link should be executed or not.
Link | Gets the link annotation that will be executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

FieldBeginEdit Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : FieldBeginEdit Event
Gets or sets the event that is fired before a form field enters in edit mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event FieldBeginEdit As EventHandler(Of FieldEditEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of FieldEditEventArgs)

AddHandler instance.FieldBeginEdit, handler
public event EventHandler<FieldEditEventArgs> FieldBeginEdit
public: __event EventHandler<FieldEditEventArgs*>* FieldBeginEdit
public:
event EventHandler<FieldEditEventArgs^>^ FieldBeginEdit
Event Data

The event handler receives an argument of type FieldEditEventArgs containing data related to this event. The following FieldEditEventArgs properties provide information specific to this event.

Property | Description
AllowEdit | Gets or sets a value indicating whether field edit is allowed or not.
Field | Gets the field that has been clicked.
FieldWidget | Gets the field widget that has been clicked.
Page | Gets the page where the clicked field widget appears.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

FieldClick Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : FieldClick Event
Gets or sets the event that is fired when a form field is clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event FieldClick As EventHandler(Of FieldClickEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of FieldClickEventArgs)

AddHandler instance.FieldClick, handler
public event EventHandler<FieldClickEventArgs> FieldClick
public: __event EventHandler<FieldClickEventArgs*>* FieldClick
public:
event EventHandler<FieldClickEventArgs^>^ FieldClick
Event Data

The event handler receives an argument of type FieldClickEventArgs containing data related to this event. The following FieldClickEventArgs properties provide information specific to this event.

Property | Description
Field | Gets the field that has been clicked.
FieldWidget | Gets the field widget that has been clicked.
MouseButton | Gets the mouse button that was clicked on the field widget.
MousePosition | Gets the position where the mouse was clicked.
Page | Gets the page where the clicked field widget appears.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

FieldContextMenu Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : FieldContextMenu Event
Gets or sets the event that is fired when a context menu should be displayed for the form field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event FieldContextMenu As EventHandler(Of FieldContextMenuEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of FieldContextMenuEventArgs)

AddHandler instance.FieldContextMenu, handler
public event EventHandler<FieldContextMenuEventArgs> FieldContextMenu
public: __event EventHandler<FieldContextMenuEventArgs*>* FieldContextMenu
public:
event EventHandler<FieldContextMenuEventArgs^>^ FieldContextMenu
Event Data

The event handler receives an argument of type FieldContextMenuEventArgs containing data related to this event. The following FieldContextMenuEventArgs properties provide information specific to this event.

Property | Description
Field | Gets the field that has been clicked.
FieldWidget | Gets the field widget that has been clicked.
MousePosition | Gets the position where the mouse was clicked.
Page | Gets the page where the clicked field widget appears.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

FieldEndEdit Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : FieldEndEdit Event
Gets or sets the event that is fired after a form field leaves the edit mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event FieldEndEdit As EventHandler(Of FieldEditEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of FieldEditEventArgs)

AddHandler instance.FieldEndEdit, handler
public event EventHandler<FieldEditEventArgs> FieldEndEdit
public: __event EventHandler<FieldEditEventArgs*>* FieldEndEdit
public:
event EventHandler<FieldEditEventArgs^>^ FieldEndEdit
Event Data

The event handler receives an argument of type FieldEditEventArgs containing data related to this event. The following FieldEditEventArgs properties provide information specific to this event.

Property | Description
AllowEdit | Gets or sets a value indicating whether field edit is allowed or not.
Field | Gets the field that has been clicked.
FieldWidget | Gets the field widget that has been clicked.
Page | Gets the page where the clicked field widget appears.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

FieldValidate Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : FieldValidate Event
Gets or sets the event that is fired when a field value needs to be validated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event FieldValidate As EventHandler(Of FieldValidateEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of FieldValidateEventArgs)

AddHandler instance.FieldValidate, handler
public event EventHandler<FieldValidateEventArgs> FieldValidate
public: __event EventHandler<FieldValidateEventArgs*>* FieldValidate
public:
event EventHandler<FieldValidateEventArgs^>^ FieldValidate
Event Data

The event handler receives an argument of type FieldValidateEventArgs containing data related to this event. The following FieldValidateEventArgs properties provide information specific to this event.

Property | Description
Field | Gets the field that has been validated.
FieldWidget | Gets the field widget that has been clicked.
IsValid | Gets or sets a value indicating whether field value is valid or not.
Page | Gets the page where the clicked field widget appears.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageClick Event (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageClick Event
Gets or sets the event that is fired when a page is clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageClick As EventHandler(Of PageClickEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of PageClickEventArgs)

AddHandler instance.PageClick, handler
public event EventHandler<PageClickEventArgs> PageClick
public: __event EventHandler<PageClickEventArgs*>* PageClick
public:
event EventHandler<PageClickEventArgs^>^ PageClick
Event Data

The event handler receives an argument of type PageClickEventArgs containing data related to this event. The following PageClickEventArgs properties provide information specific to this event.

Property | Description
ControlPoint | Gets the control point where the page was clicked.
MouseButton | Gets the mouse button that was clicked on the page.
PageNumber | Gets the number of the page that has been clicked.
PDFPoint | Gets the PDF point where the page was clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageDisplayLayoutChanged Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageDisplayLayoutChanged Event
Gets or sets the event that is fired when the page display layout has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageDisplayLayoutChanged As EventHandler(Of EventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.PageDisplayLayoutChanged, handler
public event EventHandler<EventArgs> PageDisplayLayoutChanged
public: __event EventHandler<EventArgs*>* PageDisplayLayoutChanged
public:
event EventHandler<EventArgs^>^ PageDisplayLayoutChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageDoubleClick Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageDoubleClick Event
Gets or sets the event that is fired when a page is double clicked with the mouse.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageDoubleClick As EventHandler(Of PageClickEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of PageClickEventArgs)

AddHandler instance.PageDoubleClick, handler
public event EventHandler<PageClickEventArgs> PageDoubleClick
public: __event EventHandler<PageClickEventArgs*>* PageDoubleClick
public:
event EventHandler<PageClickEventArgs^>^ PageDoubleClick
Event Data

The event handler receives an argument of type PageClickEventArgs containing data related to this event. The following PageClickEventArgs properties provide information specific to this event.

Property | Description
ControlPoint | Gets the control point where the page was clicked.
MouseButton | Gets the mouse button that was clicked on the page.
PageNumber | Gets the number of the page that has been clicked.
PDFPoint | Gets the PDF point where the page was clicked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageNumberChanged Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageNumberChanged Event
Gets or sets the event that is fired when the page number has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageNumberChanged As EventHandler(Of EventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.PageNumberChanged, handler
public event EventHandler<EventArgs> PageNumberChanged
public: __event EventHandler<EventArgs*>* PageNumberChanged
public:
event EventHandler<EventArgs^>^ PageNumberChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

PageRenderingError Event (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : PageRenderingError Event
Gets or sets the event being fired when a page rendering error has occured.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PageRenderingError As EventHandler(Of PageRenderingErrorEventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of PageRenderingErrorEventArgs)

AddHandler instance.PageRenderingError, handler
public event EventHandler<PageRenderingErrorEventArgs> PageRenderingError
public: __event EventHandler<PageRenderingErrorEventArgs*>* PageRenderingError
public:
event EventHandler<PageRenderingErrorEventArgs^>^ PageRenderingError
Event Data

The event handler receives an argument of type PageRenderingErrorEventArgs containing data related to this event. The following PageRenderingErrorEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the page rendering should be cancelled or not.
ErrorMessage | Gets the associated error message.
PageNumber | Gets the page number where the error appeared.
PageRenderingError | Gets the type of the error that appeared.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

TextSelectionCleared Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : TextSelectionCleared Event
Gets or sets the event that is fired when the existing text selection is cleared.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event TextSelectionCleared As EventHandler(Of EventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.TextSelectionCleared, handler
public event EventHandler<EventArgs> TextSelectionCleared
public: __event EventHandler<EventArgs*>* TextSelectionCleared
public:
event EventHandler<EventArgs^>^ TextSelectionCleared
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

WorkModeChanged Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : WorkModeChanged Event
Gets or sets the event that is fired when the control's work mode has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event WorkModeChanged As EventHandler(Of EventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.WorkModeChanged, handler
public event EventHandler<EventArgs> WorkModeChanged
public: __event EventHandler<EventArgs*>* WorkModeChanged
public:
event EventHandler<EventArgs^>^ WorkModeChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ZoomChanged Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ZoomChanged Event
Gets or sets the event that is fired when the control's zoom level has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ZoomChanged As EventHandler(Of EventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.ZoomChanged, handler
public event EventHandler<EventArgs> ZoomChanged
public: __event EventHandler<EventArgs*>* ZoomChanged
public:
event EventHandler<EventArgs^>^ ZoomChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

ZoomModeChanged Event

O2S.Components.PDFView4NET Namespace > PDFPageView Class : ZoomModeChanged Event
Gets or sets the event that is fired when the control's zoom mode has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ZoomModeChanged As EventHandler(Of EventArgs)
'Usage

Dim instance As PDFPageView
Dim handler As EventHandler(Of EventArgs)

AddHandler instance.ZoomModeChanged, handler
public event EventHandler<EventArgs> ZoomModeChanged
public: __event EventHandler<EventArgs*>* ZoomModeChanged
public:
event EventHandler<EventArgs^>^ ZoomModeChanged
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%PageItemTitle%%

PDFPageViewCollection Class
Members

O2S.Components.PDFView4NET Namespace : PDFPageViewCollection Class
Defines a collection of PDFPageView2Collection objects representing the viewers for a document's pages.
Object Model
PDFPageViewCollection ClassPDFPageView Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageViewCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFPageView,PDFDocument)
'Usage

Dim instance As PDFPageViewCollection
public class PDFPageViewCollection : O2S.Components.PDFView4NET.PDFCollection<PDFPageView,PDFDocument>
public __gc class PDFPageViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFPageView,PDFDocument>
public ref class PDFPageViewCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFPageView,PDFDocument>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.PDFPageViewCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageViewCollection Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFPageViewCollection Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFPageViewCollection Class

The following tables list the members exposed by PDFPageViewCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFPageView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Top
See Also

Reference

PDFPageViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFRectangle Class
Members

O2S.Components.PDFView4NET Namespace : PDFRectangle Class
Defines a rectangle in PDF default coordinates, where the origin of the coordinate system is located in the bottom left corner of the page.
Object Model
PDFRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRectangle
'Usage

Dim instance As PDFRectangle
public class PDFRectangle
public __gc class PDFRectangle
public ref class PDFRectangle
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFRectangle Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : PDFRectangle Class

The following tables list the members exposed by PDFRectangle.

Public Constructors
 | Name | Description
Public Constructor | PDFRectangle Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | LLX | Gets or sets X coordinate of the lower left corner.
Public Property | LLY | Gets or sets Y coordinate of the lower left corner.
Public Property | URX | Gets or sets X coordinate of the upper right corner.
Public Property | URY | Gets or sets Y coordinate of the upper right corner.
Public Property | Width | Gets or sets the rectangle's width.
Top
Public Methods
 | Name | Description
Public Method | Equals | Tests the equality between 2 rectangles.
Public Method | ToString | Converts the color to string representation.
Top
See Also

Reference

PDFRectangle Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFRectangle Constructor

O2S.Components.PDFView4NET Namespace > PDFRectangle Class : PDFRectangle Constructor
Overload List
Overload | Description
PDFRectangle Constructor() | Initializes a new PDFRectangle object.
PDFRectangle Constructor(Double,Double,Double,Double) | Initializes a new PDFRectangle object.
PDFRectangle Constructor(PDFRectangle) | Initializes a new PDFRectangle object from another PDFRectangle object.
PDFRectangle Constructor(PDFPoint,PDFPoint) | Initializes a new PDFRectangle object from 2 PDFPoint objects, representing 2 opposite corners of the rectangle.
PDFRectangle Constructor(RectangleF) | Initializes a new PDFRectangle object from a RectangleF structure.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%PageItemTitle%%

PDFRectangle Constructor()

O2S.Components.PDFView4NET Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor()
Initializes a new PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRectangle()
public PDFRectangle()
public: PDFRectangle();
public:
PDFRectangle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%%

PDFRectangle Constructor(Double,Double,Double,Double)

O2S.Components.PDFView4NET Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor(Double,Double,Double,Double)
Initializes a new PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal llx As Double, _
   ByVal lly As Double, _
   ByVal urx As Double, _
   ByVal ury As Double _
)
'Usage

Dim llx As Double
Dim lly As Double
Dim urx As Double
Dim ury As Double

Dim instance As New PDFRectangle(llx, lly, urx, ury)
public PDFRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)
public: PDFRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)
public:
PDFRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)

Parameters

llx
lly
urx
ury
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%%

PDFRectangle Constructor(PDFRectangle)

O2S.Components.PDFView4NET Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor(PDFRectangle)
Source rectangle.
Initializes a new PDFRectangle object from another PDFRectangle object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rectangle As PDFRectangle _
)
'Usage

Dim rectangle As PDFRectangle

Dim instance As New PDFRectangle(rectangle)
public PDFRectangle(
   PDFRectangle rectangle
)
public: PDFRectangle(
   PDFRectangle* rectangle
)
public:
PDFRectangle(
   PDFRectangle^ rectangle
)

Parameters

rectangle
Source rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%%

PDFRectangle Constructor(PDFPoint,PDFPoint)

O2S.Components.PDFView4NET Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor(PDFPoint,PDFPoint)
First corner of the rectangle.
Second corner of the rectangle.
Initializes a new PDFRectangle object from 2 PDFPoint objects, representing 2 opposite corners of the rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pt1 As PDFPoint, _
   ByVal pt2 As PDFPoint _
)
'Usage

Dim pt1 As PDFPoint
Dim pt2 As PDFPoint

Dim instance As New PDFRectangle(pt1, pt2)
public PDFRectangle(
   PDFPoint pt1,
   PDFPoint pt2
)
public: PDFRectangle(
   PDFPoint* pt1,
   PDFPoint* pt2
)
public:
PDFRectangle(
   PDFPoint^ pt1,
   PDFPoint^ pt2
)

Parameters

pt1
First corner of the rectangle.
pt2
Second corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%%

PDFRectangle Constructor(RectangleF)

O2S.Components.PDFView4NET Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor(RectangleF)
Source rectangle.
Initializes a new PDFRectangle object from a RectangleF structure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rectangle As RectangleF _
)
'Usage

Dim rectangle As RectangleF

Dim instance As New PDFRectangle(rectangle)
public PDFRectangle(
   RectangleF rectangle
)
public: PDFRectangle(
   RectangleF rectangle
)
public:
PDFRectangle(
   RectangleF rectangle
)

Parameters

rectangle
Source rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFRectangle Class Methods

O2S.Components.PDFView4NET Namespace : PDFRectangle Class

For a list of all members of this type, see PDFRectangle members.

Public Methods
 | Name | Description
Public Method | Equals | Tests the equality between 2 rectangles.
Public Method | ToString | Converts the color to string representation.
Top
See Also

Reference

PDFRectangle Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Equals Method (PDFRectangle)

O2S.Components.PDFView4NET Namespace > PDFRectangle Class : Equals Method
Tests the equality between 2 rectangles.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFRectangle
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%ItemTitle%%

ToString Method (PDFRectangle)

O2S.Components.PDFView4NET Namespace > PDFRectangle Class : ToString Method
Converts the color to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFRectangle
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%PageItemTitle%% $$Properties$$

PDFRectangle Class Properties

O2S.Components.PDFView4NET Namespace : PDFRectangle Class

For a list of all members of this type, see PDFRectangle members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | LLX | Gets or sets X coordinate of the lower left corner.
Public Property | LLY | Gets or sets Y coordinate of the lower left corner.
Public Property | URX | Gets or sets X coordinate of the upper right corner.
Public Property | URY | Gets or sets Y coordinate of the upper right corner.
Public Property | Width | Gets or sets the rectangle's width.
Top
See Also

Reference

PDFRectangle Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Height Property (PDFRectangle)

O2S.Components.PDFView4NET Namespace > PDFRectangle Class : Height Property
Gets or sets the rectangle's height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public: __property double get_Height();
public: __property void set_Height(
   double value
);
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The height of the rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%ItemTitle%%

LLX Property

O2S.Components.PDFView4NET Namespace > PDFRectangle Class : LLX Property
Gets or sets X coordinate of the lower left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LLX As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.LLX = value

value = instance.LLX
public double LLX {get; set;}
public: __property double get_LLX();
public: __property void set_LLX(
   double value
);
public:
property double LLX {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the lower left corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%ItemTitle%%

LLY Property

O2S.Components.PDFView4NET Namespace > PDFRectangle Class : LLY Property
Gets or sets Y coordinate of the lower left corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LLY As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.LLY = value

value = instance.LLY
public double LLY {get; set;}
public: __property double get_LLY();
public: __property void set_LLY(
   double value
);
public:
property double LLY {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the lower left corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%ItemTitle%%

URX Property

O2S.Components.PDFView4NET Namespace > PDFRectangle Class : URX Property
Gets or sets X coordinate of the upper right corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property URX As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.URX = value

value = instance.URX
public double URX {get; set;}
public: __property double get_URX();
public: __property void set_URX(
   double value
);
public:
property double URX {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the upper right corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%ItemTitle%%

URY Property

O2S.Components.PDFView4NET Namespace > PDFRectangle Class : URY Property
Gets or sets Y coordinate of the upper right corner.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property URY As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.URY = value

value = instance.URY
public double URY {get; set;}
public: __property double get_URY();
public: __property void set_URY(
   double value
);
public:
property double URY {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the upper right corner of the rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%ItemTitle%%

Width Property (PDFRectangle)

O2S.Components.PDFView4NET Namespace > PDFRectangle Class : Width Property
Gets or sets the rectangle's width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFRectangle
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangle Class
PDFRectangle Members


%%PageItemTitle%%

PDFRemotePageDestination Class
Members

O2S.Components.PDFView4NET Namespace : PDFRemotePageDestination Class
Defines a destination to a page in another PDF document.
Object Model
PDFRemotePageDestination Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRemotePageDestination
   Inherits PDFDirectDestination
'Usage

Dim instance As PDFRemotePageDestination
public class PDFRemotePageDestination : PDFDirectDestination
public __gc class PDFRemotePageDestination : public PDFDirectDestination
public ref class PDFRemotePageDestination : public PDFDirectDestination
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFDestination
O2S.Components.PDFView4NET.PDFDirectDestination
O2S.Components.PDFView4NET.PDFRemotePageDestination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemotePageDestination Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFRemotePageDestination Class Members
Properties

O2S.Components.PDFView4NET Namespace : PDFRemotePageDestination Class

The following tables list the members exposed by PDFRemotePageDestination.

Public Constructors
 | Name | Description
Public Constructor | PDFRemotePageDestination Constructor | Initializes a new PDFRemotePageDestination object.
Top
Public Properties
 | Name | Description
Public Property | PageNumber | Gets or sets the destination page number.
Public Property | ZoomMode | Gets or sets the zoom mode. (Inherited from O2S.Components.PDFView4NET.PDFDirectDestination)
Top
See Also

Reference

PDFRemotePageDestination Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFRemotePageDestination Constructor

O2S.Components.PDFView4NET Namespace > PDFRemotePageDestination Class : PDFRemotePageDestination Constructor
Initializes a new PDFRemotePageDestination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRemotePageDestination()
public PDFRemotePageDestination()
public: PDFRemotePageDestination();
public:
PDFRemotePageDestination();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemotePageDestination Class
PDFRemotePageDestination Members


%%PageItemTitle%% $$Properties$$

PDFRemotePageDestination Class Properties

O2S.Components.PDFView4NET Namespace : PDFRemotePageDestination Class

For a list of all members of this type, see PDFRemotePageDestination members.

Public Properties
 | Name | Description
Public Property | PageNumber | Gets or sets the destination page number.
Public Property | ZoomMode | Gets or sets the zoom mode. (Inherited from O2S.Components.PDFView4NET.PDFDirectDestination)
Top
See Also

Reference

PDFRemotePageDestination Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

PageNumber Property (PDFRemotePageDestination)

O2S.Components.PDFView4NET Namespace > PDFRemotePageDestination Class : PageNumber Property
Gets or sets the destination page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As PDFRemotePageDestination
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

The number of the page in the remote PDF document.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 0.
Remarks
The page number if 0 based.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemotePageDestination Class
PDFRemotePageDestination Members


%%PageItemTitle%%

PDFSecurityManager Class
Members

O2S.Components.PDFView4NET Namespace : PDFSecurityManager Class
Manages the security settings for a pdf document.
Object Model
PDFSecurityManager Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSecurityManager
'Usage

Dim instance As PDFSecurityManager
public class PDFSecurityManager
public __gc class PDFSecurityManager
public ref class PDFSecurityManager
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFSecurityManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFSecurityManager Class Members
Properties

O2S.Components.PDFView4NET Namespace : PDFSecurityManager Class

The following tables list the members exposed by PDFSecurityManager.

Public Constructors
 | Name | Description
Public Constructor | PDFSecurityManager Constructor | Initializes a new PDFSecurityManager object.
Top
Public Properties
 | Name | Description
Public Property | AllowAccessibilityExtractContent | Gets or sets whether the user is allowed to extract the content of the document in support of accessibility.
Public Property | AllowAssembleDocument | Gets or sets whether the user is allowed to assemble the pdf document.
Public Property | AllowExtractContent | Gets or sets whether the user is allowed to extract the content of the document.
Public Property | AllowFormsFill | Gets or sets whether the user is allowed to fill the form fields in the pdf document.
Public Property | AllowInteractiveEdit | Gets or sets whether the user is allowed to perform interactive edit operations on the document.
Public Property | AllowModifyDocument | Gets or sets whether the user is allowed to modify the document.
Public Property | AllowPrint | Gets or sets whether the user is allowed to print the document.
Public Property | EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the PDF file.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether document level metadata should be encrypted.
Public Property | FullQualityPrint | Gets or sets the quality of the document printing.
Public Property | KeySize | Gets or sets the length of the encryption key.
Public Property | OwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to.
Public Property | UnicodeOwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to.
Public Property | UnicodeUserPassword | Gets or sets the user password for the pdf document this security manager object is attached to.
Public Property | UserPassword | Gets or sets the user password for the pdf document this security manager object is attached to.
Top
See Also

Reference

PDFSecurityManager Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFSecurityManager Constructor

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : PDFSecurityManager Constructor
Initializes a new PDFSecurityManager object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSecurityManager()
public PDFSecurityManager()
public: PDFSecurityManager();
public:
PDFSecurityManager();
Remarks
When a PDFSecurityManager object is created, all the public properties are set to true, the user and owner passwords are null, and the encryption strength is set to 128 bit.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%% $$Properties$$

PDFSecurityManager Class Properties

O2S.Components.PDFView4NET Namespace : PDFSecurityManager Class

For a list of all members of this type, see PDFSecurityManager members.

Public Properties
 | Name | Description
Public Property | AllowAccessibilityExtractContent | Gets or sets whether the user is allowed to extract the content of the document in support of accessibility.
Public Property | AllowAssembleDocument | Gets or sets whether the user is allowed to assemble the pdf document.
Public Property | AllowExtractContent | Gets or sets whether the user is allowed to extract the content of the document.
Public Property | AllowFormsFill | Gets or sets whether the user is allowed to fill the form fields in the pdf document.
Public Property | AllowInteractiveEdit | Gets or sets whether the user is allowed to perform interactive edit operations on the document.
Public Property | AllowModifyDocument | Gets or sets whether the user is allowed to modify the document.
Public Property | AllowPrint | Gets or sets whether the user is allowed to print the document.
Public Property | EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the PDF file.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether document level metadata should be encrypted.
Public Property | FullQualityPrint | Gets or sets the quality of the document printing.
Public Property | KeySize | Gets or sets the length of the encryption key.
Public Property | OwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to.
Public Property | UnicodeOwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to.
Public Property | UnicodeUserPassword | Gets or sets the user password for the pdf document this security manager object is attached to.
Public Property | UserPassword | Gets or sets the user password for the pdf document this security manager object is attached to.
Top
See Also

Reference

PDFSecurityManager Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

AllowAccessibilityExtractContent Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : AllowAccessibilityExtractContent Property
Gets or sets whether the user is allowed to extract the content of the document in support of accessibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowAccessibilityExtractContent As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowAccessibilityExtractContent = value

value = instance.AllowAccessibilityExtractContent
public bool AllowAccessibilityExtractContent {get; set;}
public: __property bool get_AllowAccessibilityExtractContent();
public: __property void set_AllowAccessibilityExtractContent(
   bool value
);
public:
property bool AllowAccessibilityExtractContent {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to extract the content of the document in support of accessibility.
Remarks
This property has effect only when using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to copy or otherwise extract text and graphics from the document in support of accessibility to disabled users or for other purposes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

AllowAssembleDocument Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : AllowAssembleDocument Property
Gets or sets whether the user is allowed to assemble the pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowAssembleDocument As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowAssembleDocument = value

value = instance.AllowAssembleDocument
public bool AllowAssembleDocument {get; set;}
public: __property bool get_AllowAssembleDocument();
public: __property void set_AllowAssembleDocument(
   bool value
);
public:
property bool AllowAssembleDocument {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to assemble the pdf document or not.
Remarks
This property has effect only when using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to assemble the document (insert, rotate, or delete pages and create bookmarks or thumbnail images), event property AllowModifyDocument is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

AllowExtractContent Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : AllowExtractContent Property
Gets or sets whether the user is allowed to extract the content of the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowExtractContent As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowExtractContent = value

value = instance.AllowExtractContent
public bool AllowExtractContent {get; set;}
public: __property bool get_AllowExtractContent();
public: __property void set_AllowExtractContent(
   bool value
);
public:
property bool AllowExtractContent {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to extract the content of the document.
Remarks
When using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey), this property, if true, allows a user to copy or otherwise extract text and graphics from the document by operations other than those controlled by property AllowAccessibilityExtractContent. When using 40 bit encryption (KeySize property is set to EncryptionKeySize.Use40BitKey), then this property also controls extraction of text and graphics in support of accessibility to disabled users or other purposes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

AllowFormsFill Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : AllowFormsFill Property
Gets or sets whether the user is allowed to fill the form fields in the pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowFormsFill As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowFormsFill = value

value = instance.AllowFormsFill
public bool AllowFormsFill {get; set;}
public: __property bool get_AllowFormsFill();
public: __property void set_AllowFormsFill(
   bool value
);
public:
property bool AllowFormsFill {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to fill the form fields in the pdf document.
Remarks
This property has effect only when using 128 bit encryption. (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to fill in existing interactive form fields (including signature fields), event property AllowInteractiveEdit is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

AllowInteractiveEdit Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : AllowInteractiveEdit Property
Gets or sets whether the user is allowed to perform interactive edit operations on the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowInteractiveEdit As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowInteractiveEdit = value

value = instance.AllowInteractiveEdit
public bool AllowInteractiveEdit {get; set;}
public: __property bool get_AllowInteractiveEdit();
public: __property void set_AllowInteractiveEdit(
   bool value
);
public:
property bool AllowInteractiveEdit {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to perform interactive edit operations on the document.
Remarks
This property, if true, allows a user to add or modify text annotations, fill in interactive forms fields, and, if property AllowModifyDocument is true, create or modify interactive form fields (including signature fields).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

AllowModifyDocument Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : AllowModifyDocument Property
Gets or sets whether the user is allowed to modify the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowModifyDocument As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowModifyDocument = value

value = instance.AllowModifyDocument
public bool AllowModifyDocument {get; set;}
public: __property bool get_AllowModifyDocument();
public: __property void set_AllowModifyDocument(
   bool value
);
public:
property bool AllowModifyDocument {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed to modify the document or not.
Remarks
This property, if true, allows a user to modify the content of pdf document by operations other than those controlled by the following properties: AllowInteractiveEdit, AllowFormsFill, AllowAssembleDocument.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

AllowPrint Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : AllowPrint Property
Gets or sets whether the user is allowed to print the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowPrint As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowPrint = value

value = instance.AllowPrint
public bool AllowPrint {get; set;}
public: __property bool get_AllowPrint();
public: __property void set_AllowPrint(
   bool value
);
public:
property bool AllowPrint {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the user is allowed or not to print the document.
Remarks
This property, together with FullQualityPrint and KeySize properties, controls the printing of the document. If this property is false, then the user is not allowed to print the document. If this property is true, then the user is allowed to print the document, depending on the value of FullQualityPrint and KeySize properties. If KeySize is EncryptionKeySize.Use40BitKey then FullQualityPrint property is ignored. If KeySize is EncryptionKeySize.Use128BitKey then if FullQualityPrint is true, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

EncryptionAlgorithm Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : EncryptionAlgorithm Property
Gets or sets the encryption algorithm used to encrypt the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EncryptionAlgorithm As EncryptionAlgorithm
'Usage

Dim instance As PDFSecurityManager
Dim value As EncryptionAlgorithm

instance.EncryptionAlgorithm = value

value = instance.EncryptionAlgorithm
public EncryptionAlgorithm EncryptionAlgorithm {get; set;}
public: __property EncryptionAlgorithm get_EncryptionAlgorithm();
public: __property void set_EncryptionAlgorithm(
   EncryptionAlgorithm value
);
public:
property EncryptionAlgorithm EncryptionAlgorithm {
   EncryptionAlgorithm get();
   void set (    EncryptionAlgorithm value);
}
Remarks
When using AES encrpytion the key size is always 128 bit and the KeySize property is set automatically to 128 bit and it can not be changed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

EncryptMetadata Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : EncryptMetadata Property
Gets or sets a value indicatig whether document level metadata should be encrypted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EncryptMetadata As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.EncryptMetadata = value

value = instance.EncryptMetadata
public bool EncryptMetadata {get; set;}
public: __property bool get_EncryptMetadata();
public: __property void set_EncryptMetadata(
   bool value
);
public:
property bool EncryptMetadata {
   bool get();
   void set (    bool value);
}

Property Value

True if the document metadata is encrypted (default), false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

FullQualityPrint Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : FullQualityPrint Property
Gets or sets the quality of the document printing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FullQualityPrint As Boolean
'Usage

Dim instance As PDFSecurityManager
Dim value As Boolean

instance.FullQualityPrint = value

value = instance.FullQualityPrint
public bool FullQualityPrint {get; set;}
public: __property bool get_FullQualityPrint();
public: __property void set_FullQualityPrint(
   bool value
);
public:
property bool FullQualityPrint {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the document is printed in full quality or not.
Remarks
This property has effect only when AllowPrint property is true and KeySize property is set to EncryptionKeySize.Use128BitKey. If this property is true, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

KeySize Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : KeySize Property
Gets or sets the length of the encryption key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property KeySize As EncryptionKeySize
'Usage

Dim instance As PDFSecurityManager
Dim value As EncryptionKeySize

instance.KeySize = value

value = instance.KeySize
public EncryptionKeySize KeySize {get; set;}
public: __property EncryptionKeySize get_KeySize();
public: __property void set_KeySize(
   EncryptionKeySize value
);
public:
property EncryptionKeySize KeySize {
   EncryptionKeySize get();
   void set (    EncryptionKeySize value);
}

Property Value

A EncryptionKeySize enumeration member specifying the length of the encryption key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

OwnerPassword Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : OwnerPassword Property
Gets or sets the owner password for the pdf document this security manager object is attached to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OwnerPassword As Byte()
'Usage

Dim instance As PDFSecurityManager
Dim value() As Byte

instance.OwnerPassword = value

value = instance.OwnerPassword
public byte[] OwnerPassword {get; set;}
public: __property byte[]* get_OwnerPassword();
public: __property void set_OwnerPassword(
   byte[]* value
);
public:
property array<byte>^ OwnerPassword {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array specifying the owner password for the pdf file.
Remarks
An owner password allows the user to get full control over the pdf document. If a pdf file is password protected, entering an owner password when opening the file, allows the user to get full access to the document without any restrictions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

UnicodeOwnerPassword Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : UnicodeOwnerPassword Property
Gets or sets the owner password for the pdf document this security manager object is attached to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnicodeOwnerPassword As String
'Usage

Dim instance As PDFSecurityManager
Dim value As String

instance.UnicodeOwnerPassword = value

value = instance.UnicodeOwnerPassword
public string UnicodeOwnerPassword {get; set;}
public: __property string* get_UnicodeOwnerPassword();
public: __property void set_UnicodeOwnerPassword(
   string* value
);
public:
property String^ UnicodeOwnerPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

An unicode string specifying the owner password for the pdf file.
Remarks

Note: This property must be used when using AES-256 encryption. If RC4 or AES-128 encryption is used, then the OwnerPassword property must be set.

An owner password allows the user to get full control over the pdf document. If a pdf file is password protected, entering an owner password when opening the file, allows the user to get full access to the document without any restrictions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

UnicodeUserPassword Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : UnicodeUserPassword Property
Gets or sets the user password for the pdf document this security manager object is attached to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnicodeUserPassword As String
'Usage

Dim instance As PDFSecurityManager
Dim value As String

instance.UnicodeUserPassword = value

value = instance.UnicodeUserPassword
public string UnicodeUserPassword {get; set;}
public: __property string* get_UnicodeUserPassword();
public: __property void set_UnicodeUserPassword(
   string* value
);
public:
property String^ UnicodeUserPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

An unicode string specifying the user password for the pdf file.
Remarks

Note: This property must be used when using AES-256 encryption. If RC4 or AES-128 encryption is used, then the UserPassword property must be set.

A user password restricts access to a pdf document. When the pdf document is opened, the viewer requests the user to enter a password, if a user password has been set on the document. If the user password has not been set (this property is set to null), then the viewer opens the document without requesting a password. When the pdf document is open with a user password (or without one), the access to the document is restricted by the access rights associated with the document (allow print, etc).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%ItemTitle%%

UserPassword Property

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : UserPassword Property
Gets or sets the user password for the pdf document this security manager object is attached to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UserPassword As Byte()
'Usage

Dim instance As PDFSecurityManager
Dim value() As Byte

instance.UserPassword = value

value = instance.UserPassword
public byte[] UserPassword {get; set;}
public: __property byte[]* get_UserPassword();
public: __property void set_UserPassword(
   byte[]* value
);
public:
property array<byte>^ UserPassword {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array specifying the user password for the pdf file.
Remarks
A user password restricts access to a pdf document. When the pdf document is opened, the viewer requests the user to enter a password, if a user password has been set on the document. If the user password has not been set (this property is set to null), then the viewer opens the document without requesting a password. When the pdf document is open with a user password (or without one), the access to the document is restricted by the access rights associated with the document (allow print, etc).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

PDFSize Class
Members

O2S.Components.PDFView4NET Namespace : PDFSize Class
Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.
Object Model
PDFSize Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSize
'Usage

Dim instance As PDFSize
public class PDFSize
public __gc class PDFSize
public ref class PDFSize
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFSize Class Members
Properties

O2S.Components.PDFView4NET Namespace : PDFSize Class

The following tables list the members exposed by PDFSize.

Public Constructors
 | Name | Description
Public Constructor | PDFSize Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height.
Public Property | Width | Gets or sets the width.
Top
See Also

Reference

PDFSize Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFSize Constructor

O2S.Components.PDFView4NET Namespace > PDFSize Class : PDFSize Constructor
Overload List
Overload | Description
PDFSize Constructor() | Initializes a new PDFSize object.
PDFSize Constructor(Double,Double) | Initializes a new PDFSize object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members


%%PageItemTitle%%

PDFSize Constructor()

O2S.Components.PDFView4NET Namespace > PDFSize Class > PDFSize Constructor : PDFSize Constructor()
Initializes a new PDFSize object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSize()
public PDFSize()
public: PDFSize();
public:
PDFSize();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members
Overload List


%%PageItemTitle%%

PDFSize Constructor(Double,Double)

O2S.Components.PDFView4NET Namespace > PDFSize Class > PDFSize Constructor : PDFSize Constructor(Double,Double)
The width.
The height.
Initializes a new PDFSize object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim width As Double
Dim height As Double

Dim instance As New PDFSize(width, height)
public PDFSize(
   double width,
   double height
)
public: PDFSize(
   double width,
   double height
)
public:
PDFSize(
   double width,
   double height
)

Parameters

width
The width.
height
The height.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFSize Class Properties

O2S.Components.PDFView4NET Namespace : PDFSize Class

For a list of all members of this type, see PDFSize members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height.
Public Property | Width | Gets or sets the width.
Top
See Also

Reference

PDFSize Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Height Property (PDFSize)

O2S.Components.PDFView4NET Namespace > PDFSize Class : Height Property
Gets or sets the height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PDFSize
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public: __property double get_Height();
public: __property void set_Height(
   double value
);
public:
property double Height {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members


%%ItemTitle%%

Width Property (PDFSize)

O2S.Components.PDFView4NET Namespace > PDFSize Class : Width Property
Gets or sets the width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFSize
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSize Class
PDFSize Members


%%PageItemTitle%%

PDFViewerPreferences Class
Members

O2S.Components.PDFView4NET Namespace : PDFViewerPreferences Class
Defines the way the PDF document is displayed on the screen.
Object Model
PDFViewerPreferences Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFViewerPreferences
'Usage

Dim instance As PDFViewerPreferences
public class PDFViewerPreferences
public __gc class PDFViewerPreferences
public ref class PDFViewerPreferences
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFViewerPreferences

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFViewerPreferences Class Members
Properties

O2S.Components.PDFView4NET Namespace : PDFViewerPreferences Class

The following tables list the members exposed by PDFViewerPreferences.

Public Constructors
 | Name | Description
Public Constructor | PDFViewerPreferences Constructor | Initializes a new PDFDocumentInformation object.
Top
Public Properties
 | Name | Description
Public Property | CenterWindow | Gets or sets a value indicating whether the document's window should be centered on the screen.
Public Property | DisplayDocTitle | Gets or sets a value indicating whether the window's title bar should display the document's title loaded from document information metadata.
Public Property | FitWindow | Gets or sets a value indicating whether the document's window should be resized to match the size of the first displayed page.
Public Property | HideMenubar | Gets or sets a value indicating whether the viewer's menubar should be hidden when the document is active.
Public Property | HideToolbar | Gets or sets a value indicating whether the viewer's toolbar should be hidden when the document is active.
Public Property | HideWindowUI | Gets or sets a value indicating whether the viewer's UI should be hidden when the document is active.
Public Property | NonFullScreenPageMode | Gets or sets the document's page mode specifying how to display the document on exiting the full-screen mode.
Top
See Also

Reference

PDFViewerPreferences Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFViewerPreferences Constructor

O2S.Components.PDFView4NET Namespace > PDFViewerPreferences Class : PDFViewerPreferences Constructor
Initializes a new PDFDocumentInformation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFViewerPreferences()
public PDFViewerPreferences()
public: PDFViewerPreferences();
public:
PDFViewerPreferences();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%% $$Properties$$

PDFViewerPreferences Class Properties

O2S.Components.PDFView4NET Namespace : PDFViewerPreferences Class

For a list of all members of this type, see PDFViewerPreferences members.

Public Properties
 | Name | Description
Public Property | CenterWindow | Gets or sets a value indicating whether the document's window should be centered on the screen.
Public Property | DisplayDocTitle | Gets or sets a value indicating whether the window's title bar should display the document's title loaded from document information metadata.
Public Property | FitWindow | Gets or sets a value indicating whether the document's window should be resized to match the size of the first displayed page.
Public Property | HideMenubar | Gets or sets a value indicating whether the viewer's menubar should be hidden when the document is active.
Public Property | HideToolbar | Gets or sets a value indicating whether the viewer's toolbar should be hidden when the document is active.
Public Property | HideWindowUI | Gets or sets a value indicating whether the viewer's UI should be hidden when the document is active.
Public Property | NonFullScreenPageMode | Gets or sets the document's page mode specifying how to display the document on exiting the full-screen mode.
Top
See Also

Reference

PDFViewerPreferences Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

CenterWindow Property

O2S.Components.PDFView4NET Namespace > PDFViewerPreferences Class : CenterWindow Property
Gets or sets a value indicating whether the document's window should be centered on the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CenterWindow As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.CenterWindow = value

value = instance.CenterWindow
public bool CenterWindow {get; set;}
public: __property bool get_CenterWindow();
public: __property void set_CenterWindow(
   bool value
);
public:
property bool CenterWindow {
   bool get();
   void set (    bool value);
}

Property Value

True if the document's window should be centered on the screen. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%ItemTitle%%

DisplayDocTitle Property

O2S.Components.PDFView4NET Namespace > PDFViewerPreferences Class : DisplayDocTitle Property
Gets or sets a value indicating whether the window's title bar should display the document's title loaded from document information metadata.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayDocTitle As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.DisplayDocTitle = value

value = instance.DisplayDocTitle
public bool DisplayDocTitle {get; set;}
public: __property bool get_DisplayDocTitle();
public: __property void set_DisplayDocTitle(
   bool value
);
public:
property bool DisplayDocTitle {
   bool get();
   void set (    bool value);
}

Property Value

True if the window's title bar should display the document's title. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%ItemTitle%%

FitWindow Property

O2S.Components.PDFView4NET Namespace > PDFViewerPreferences Class : FitWindow Property
Gets or sets a value indicating whether the document's window should be resized to match the size of the first displayed page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FitWindow As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.FitWindow = value

value = instance.FitWindow
public bool FitWindow {get; set;}
public: __property bool get_FitWindow();
public: __property void set_FitWindow(
   bool value
);
public:
property bool FitWindow {
   bool get();
   void set (    bool value);
}

Property Value

True if the document's window should be resized. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%ItemTitle%%

HideMenubar Property

O2S.Components.PDFView4NET Namespace > PDFViewerPreferences Class : HideMenubar Property
Gets or sets a value indicating whether the viewer's menubar should be hidden when the document is active.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HideMenubar As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideMenubar = value

value = instance.HideMenubar
public bool HideMenubar {get; set;}
public: __property bool get_HideMenubar();
public: __property void set_HideMenubar(
   bool value
);
public:
property bool HideMenubar {
   bool get();
   void set (    bool value);
}

Property Value

True if the menubar should be hidden. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%ItemTitle%%

HideToolbar Property

O2S.Components.PDFView4NET Namespace > PDFViewerPreferences Class : HideToolbar Property
Gets or sets a value indicating whether the viewer's toolbar should be hidden when the document is active.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HideToolbar As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideToolbar = value

value = instance.HideToolbar
public bool HideToolbar {get; set;}
public: __property bool get_HideToolbar();
public: __property void set_HideToolbar(
   bool value
);
public:
property bool HideToolbar {
   bool get();
   void set (    bool value);
}

Property Value

True if the toolbar should be hidden. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%ItemTitle%%

HideWindowUI Property

O2S.Components.PDFView4NET Namespace > PDFViewerPreferences Class : HideWindowUI Property
Gets or sets a value indicating whether the viewer's UI should be hidden when the document is active.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HideWindowUI As Boolean
'Usage

Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideWindowUI = value

value = instance.HideWindowUI
public bool HideWindowUI {get; set;}
public: __property bool get_HideWindowUI();
public: __property void set_HideWindowUI(
   bool value
);
public:
property bool HideWindowUI {
   bool get();
   void set (    bool value);
}

Property Value

True if the UI should be hidden. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%ItemTitle%%

NonFullScreenPageMode Property

O2S.Components.PDFView4NET Namespace > PDFViewerPreferences Class : NonFullScreenPageMode Property
Gets or sets the document's page mode specifying how to display the document on exiting the full-screen mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NonFullScreenPageMode As PDFPageMode
'Usage

Dim instance As PDFViewerPreferences
Dim value As PDFPageMode

instance.NonFullScreenPageMode = value

value = instance.NonFullScreenPageMode
public PDFPageMode NonFullScreenPageMode {get; set;}
public: __property PDFPageMode get_NonFullScreenPageMode();
public: __property void set_NonFullScreenPageMode(
   PDFPageMode value
);
public:
property PDFPageMode NonFullScreenPageMode {
   PDFPageMode get();
   void set (    PDFPageMode value);
}

Property Value

The document's page mode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown if the value to be set is not one of the supported values.
Remarks
Only the following page modes are supported: PDFPageMode.UseNone, PDFPageMode.UseOutlines, PDFPageMode.UseThumbs and PDFPageMode.UseOC.
This property is meaningful only if the PDFDocument.PageMode property is PDFPageMode.FullScreen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

PDFXMPMetadata Class
Members

O2S.Components.PDFView4NET Namespace : PDFXMPMetadata Class
Defines the XMP metadata for a PDF document.
Object Model
PDFXMPMetadata Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFXMPMetadata
'Usage

Dim instance As PDFXMPMetadata
public class PDFXMPMetadata
public __gc class PDFXMPMetadata
public ref class PDFXMPMetadata
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.PDFXMPMetadata

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFXMPMetadata Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

PDFXMPMetadata Class Members
Properties

O2S.Components.PDFView4NET Namespace : PDFXMPMetadata Class

The following tables list the members exposed by PDFXMPMetadata.

Public Constructors
 | Name | Description
Public Constructor | PDFXMPMetadata Constructor | Initializes a new PDFXMPMetadata object.
Top
Public Properties
 | Name | Description
Public Property | XMPMetadata | Gets the raw XMP metadata as an XML string.
Top
See Also

Reference

PDFXMPMetadata Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFXMPMetadata Constructor

O2S.Components.PDFView4NET Namespace > PDFXMPMetadata Class : PDFXMPMetadata Constructor
Initializes a new PDFXMPMetadata object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFXMPMetadata()
public PDFXMPMetadata()
public: PDFXMPMetadata();
public:
PDFXMPMetadata();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


%%PageItemTitle%% $$Properties$$

PDFXMPMetadata Class Properties

O2S.Components.PDFView4NET Namespace : PDFXMPMetadata Class

For a list of all members of this type, see PDFXMPMetadata members.

Public Properties
 | Name | Description
Public Property | XMPMetadata | Gets the raw XMP metadata as an XML string.
Top
See Also

Reference

PDFXMPMetadata Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

XMPMetadata Property

O2S.Components.PDFView4NET Namespace > PDFXMPMetadata Class : XMPMetadata Property
Gets the raw XMP metadata as an XML string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XMPMetadata As String
'Usage

Dim instance As PDFXMPMetadata
Dim value As String

instance.XMPMetadata = value

value = instance.XMPMetadata
public string XMPMetadata {get; set;}
public: __property string* get_XMPMetadata();
public: __property void set_XMPMetadata(
   string* value
);
public:
property String^ XMPMetadata {
   String^ get();
   void set (    String^ value);
}

Property Value

The raw XMP metadata stored in the PDF file.
Remarks
If the PDFDocument object has been created from a source PDF file, this property returns the XMP metadata included in the file, otherwise it returns an empty string.
If this property is set from user code, the new value is appended as it is to the XMP metadata generated by PDF4NET.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


%%PageItemTitle%%

UnsupportedEncryptionException Class
Members

O2S.Components.PDFView4NET Namespace : UnsupportedEncryptionException Class
Defines the exceptions thrown when the PDF file is encrypted with an unknown encryption method.
Object Model
UnsupportedEncryptionException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class UnsupportedEncryptionException
   Inherits System.ApplicationException
'Usage

Dim instance As UnsupportedEncryptionException
[Serializable()]
public class UnsupportedEncryptionException : System.ApplicationException
[Serializable()]
public __gc class UnsupportedEncryptionException : public System.ApplicationException
[Serializable()]
public ref class UnsupportedEncryptionException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFView4NET.UnsupportedEncryptionException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnsupportedEncryptionException Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

UnsupportedEncryptionException Class Members
Properties Methods

O2S.Components.PDFView4NET Namespace : UnsupportedEncryptionException Class

The following tables list the members exposed by UnsupportedEncryptionException.

Public Constructors
 | Name | Description
Public Constructor | UnsupportedEncryptionException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

UnsupportedEncryptionException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

UnsupportedEncryptionException Constructor

O2S.Components.PDFView4NET Namespace > UnsupportedEncryptionException Class : UnsupportedEncryptionException Constructor
Overload List
Overload | Description
UnsupportedEncryptionException Constructor(String) | Initializes a new UnsupportedEncryptionException object.
UnsupportedEncryptionException Constructor(String,Exception) | Initializes a new PDFUnsupportedEncryptionException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnsupportedEncryptionException Class
UnsupportedEncryptionException Members


%%PageItemTitle%%

UnsupportedEncryptionException Constructor(String)

O2S.Components.PDFView4NET Namespace > UnsupportedEncryptionException Class > UnsupportedEncryptionException Constructor : UnsupportedEncryptionException Constructor(String)
The message that describes the exception.
Initializes a new UnsupportedEncryptionException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New UnsupportedEncryptionException(message)
public UnsupportedEncryptionException(
   string message
)
public: UnsupportedEncryptionException(
   string* message
)
public:
UnsupportedEncryptionException(
   String^ message
)

Parameters

message
The message that describes the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnsupportedEncryptionException Class
UnsupportedEncryptionException Members
Overload List


%%PageItemTitle%%

UnsupportedEncryptionException Constructor(String,Exception)

O2S.Components.PDFView4NET Namespace > UnsupportedEncryptionException Class > UnsupportedEncryptionException Constructor : UnsupportedEncryptionException Constructor(String,Exception)
the message that describes the exception.
The exception that is the cause of the current exception.
Initializes a new PDFUnsupportedEncryptionException object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New UnsupportedEncryptionException(message, innerException)
public UnsupportedEncryptionException(
   string message,
   Exception innerException
)
public: UnsupportedEncryptionException(
   string* message,
   Exception* innerException
)
public:
UnsupportedEncryptionException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UnsupportedEncryptionException Class
UnsupportedEncryptionException Members
Overload List


%%PageItemTitle%%

ChangeType Enumeration

O2S.Components.PDFView4NET Namespace : ChangeType Enumeration
Specify the available changes in a collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ChangeType
   Inherits System.Enum
'Usage

Dim instance As ChangeType
public enum ChangeType : System.Enum
__value public enum ChangeType : public System.Enum
public enum class ChangeType : public System.Enum
Members
Member | Description
Add | New item has been added at the end of collection.
Clear | Collection has been cleared.
Insert | New item has been inserted in the collection.
ItemUpdate | Existing item has been updated.
Move | Existing item has been moved in the collection.
Remove | Item has been removed.
Replace | Item has been replaced.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.ChangeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

EncryptionAlgorithm Enumeration

O2S.Components.PDFView4NET Namespace : EncryptionAlgorithm Enumeration
Specifies the available encryption algorithms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum EncryptionAlgorithm
   Inherits System.Enum
'Usage

Dim instance As EncryptionAlgorithm
public enum EncryptionAlgorithm : System.Enum
__value public enum EncryptionAlgorithm : public System.Enum
public enum class EncryptionAlgorithm : public System.Enum
Members
Member | Description
Aes | 128/256 bit AES encryption. Supported in PDF 1.6 or higher.
RC4 | 40/128 bit RC4 encryption.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.EncryptionAlgorithm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

EncryptionKeySize Enumeration

O2S.Components.PDFView4NET Namespace : EncryptionKeySize Enumeration
Specifies the available key sizes when encrypting a pdf document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum EncryptionKeySize
   Inherits System.Enum
'Usage

Dim instance As EncryptionKeySize
public enum EncryptionKeySize : System.Enum
__value public enum EncryptionKeySize : public System.Enum
public enum class EncryptionKeySize : public System.Enum
Members
Member | Description
Use128BitKey | A 128 bit encryption key will be used to encrypt the pdf document.
Use256BitKey | A 256 bit encryption key will be used to encrypt the pdf document.
Use40BitKey | A 40 bit encryption key will be used to encrypt the pdf document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.EncryptionKeySize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFBookmarkDisplayStyle Enumeration

O2S.Components.PDFView4NET Namespace : PDFBookmarkDisplayStyle Enumeration
Specifies the available modes for displaying a bookmark in a viewer application.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PDFBookmarkDisplayStyle
   Inherits System.Enum
'Usage

Dim instance As PDFBookmarkDisplayStyle
[Flags()]
public enum PDFBookmarkDisplayStyle : System.Enum
[Flags()]
__value public enum PDFBookmarkDisplayStyle : public System.Enum
[Flags()]
public enum class PDFBookmarkDisplayStyle : public System.Enum
Members
Member | Description
Bold | The bookmark is displayed using bold font.
Italic | The bookmark is displayed using italic font.
Regular | The bookmark is displayed using regular font.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFBookmarkDisplayStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFDestinationZoomMode Enumeration

O2S.Components.PDFView4NET Namespace : PDFDestinationZoomMode Enumeration
Specifies the available zoom modes that can be applied when the PDF page specified in the destination is displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFDestinationZoomMode
   Inherits System.Enum
'Usage

Dim instance As PDFDestinationZoomMode
public enum PDFDestinationZoomMode : System.Enum
__value public enum PDFDestinationZoomMode : public System.Enum
public enum class PDFDestinationZoomMode : public System.Enum
Members
Member | Description
Fit | Display the destination page, with its contents magnified just enough to fit the entire page within the window both horizontally and vertically.
FitB | Display the destination page, with its contents magnified just enough to fit its bounding box entirely within the window both horizontally and vertically.
FitBH | Display the destination page at the specified top position and the contents of the page magnified just enough to fit the entire width of its bounding box within the window.
FitBV | Display the destination page at the specified left position and the contents of the page magnified just enough to fit the entire height of its bounding box within the window.
FitH | Display the destination page at the specified top position and the contents of the page magnified just enough to fit the entire width of the page within the window.
FitR | Display the destination page, with its contents magnified just enough to fit the rectangle specified by the coordinates left, bottom, right, and top entirely within the window both horizontally and vertically.
FitV | Display the destination page at the specified left position and the contents of the page magnified just enough to fit the entire height of the page within the window.
XYZ | Display the destination page at the specified position and zoom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFDestinationZoomMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageDisplayLayout Enumeration

O2S.Components.PDFView4NET Namespace : PDFPageDisplayLayout Enumeration
Specifies the possible display layouts to be used with the PDFPageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageDisplayLayout
   Inherits System.Enum
'Usage

Dim instance As PDFPageDisplayLayout
public enum PDFPageDisplayLayout : System.Enum
__value public enum PDFPageDisplayLayout : public System.Enum
public enum class PDFPageDisplayLayout : public System.Enum
Members
Member | Description
DocumentDefault | Displays the pages as defined in the PDF document.
OneColumn | Display the pages in one column.
SinglePage | Display one page at a time.
TwoColumnLeft | Display the pages in two columns, with odd-numbered pages on the left.
TwoColumnRight | Display the pages in two columns, with odd-numbered pages on the right.
TwoPageLeft | Display the pages two at a time, with odd-numbered pages on the left.
TwoPageRight | Display the pages two at a time, with odd-numbered pages on the right.
Remarks
These values are used to override the page layout defined on the document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFPageDisplayLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageLayout Enumeration

O2S.Components.PDFView4NET Namespace : PDFPageLayout Enumeration
Specifies the possible page layouts to be used when the document is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageLayout
   Inherits System.Enum
'Usage

Dim instance As PDFPageLayout
public enum PDFPageLayout : System.Enum
__value public enum PDFPageLayout : public System.Enum
public enum class PDFPageLayout : public System.Enum
Members
Member | Description
OneColumn | Display the pages in one column.
SinglePage | Display one page at a time.
TwoColumnLeft | Display the pages in two columns, with odd-numbered pages on the left.
TwoColumnRight | Display the pages in two columns, with odd-numbered pages on the right.
TwoPageLeft | Display the pages two at a time, with odd-numbered pages on the left.
TwoPageRight | Display the pages two at a time, with odd-numbered pages on the right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFPageLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageMode Enumeration

O2S.Components.PDFView4NET Namespace : PDFPageMode Enumeration
Specifies the possible modes to be display the document when it is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageMode
   Inherits System.Enum
'Usage

Dim instance As PDFPageMode
public enum PDFPageMode : System.Enum
__value public enum PDFPageMode : public System.Enum
public enum class PDFPageMode : public System.Enum
Members
Member | Description
FullScreen | Full screen mode, with no menu bar, window controls, or any other window visible.
UseAttachments | Attachments panel visible.
UseNone | Neither document outline nor thumbnail images visible.
UseOC | Optional content panel visible.
UseOutlines | Document outline visible.
UseThumbs | Thumbnail images visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFPageMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageRenderingError Enumeration

O2S.Components.PDFView4NET Namespace : PDFPageRenderingError Enumeration
Specifies the possible errors that can appear during the rendering of a PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageRenderingError
   Inherits System.Enum
'Usage

Dim instance As PDFPageRenderingError
public enum PDFPageRenderingError : System.Enum
__value public enum PDFPageRenderingError : public System.Enum
public enum class PDFPageRenderingError : public System.Enum
Members
Member | Description
CmykJpeg | CMYK JPEG image is rendered as negative.
ContentStreamError | Content stream cannot be processed.
JBig2 | JBIG2 image is not rendered.
Jpeg2000 | JPEG2000 image is not rendered.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFPageRenderingError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageRotation Enumeration

O2S.Components.PDFView4NET Namespace : PDFPageRotation Enumeration
Specifies the available rotation modes for a PDF page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPageRotation
   Inherits System.Enum
'Usage

Dim instance As PDFPageRotation
public enum PDFPageRotation : System.Enum
__value public enum PDFPageRotation : public System.Enum
public enum class PDFPageRotation : public System.Enum
Members
Member | Description
Rotate0Degrees | 0 degrees rotation.
Rotate180Degrees | 180 degrees clockwise rotation.
Rotate270Degrees | 270 degrees clockwise rotation.
Rotate90Degrees | 90 degrees clockwise rotation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFPageRotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFRenderingProgressDisplayMode Enumeration

O2S.Components.PDFView4NET Namespace : PDFRenderingProgressDisplayMode Enumeration
Specifies the available modes for displaying the page rendering progress.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFRenderingProgressDisplayMode
   Inherits System.Enum
'Usage

Dim instance As PDFRenderingProgressDisplayMode
public enum PDFRenderingProgressDisplayMode : System.Enum
__value public enum PDFRenderingProgressDisplayMode : public System.Enum
public enum class PDFRenderingProgressDisplayMode : public System.Enum
Members
Member | Description
None | No visual rendering progress is displayed.
RectangularProgressBar | A rectangular progress bar is displayed during the page rendering.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFRenderingProgressDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFRotationMode Enumeration

O2S.Components.PDFView4NET Namespace : PDFRotationMode Enumeration
Specifies the available rotation modes for a PDF object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFRotationMode
   Inherits System.Enum
'Usage

Dim instance As PDFRotationMode
public enum PDFRotationMode : System.Enum
__value public enum PDFRotationMode : public System.Enum
public enum class PDFRotationMode : public System.Enum
Members
Member | Description
Rotate0Degrees | 0 degrees rotation.
Rotate180Degrees | 180 degrees rotation.
Rotate270Degrees | 270 degrees rotation.
Rotate90Degrees | 90 degrees rotation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFRotationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFZoomMode Enumeration

O2S.Components.PDFView4NET Namespace : PDFZoomMode Enumeration
Specifies the available zoom modes for displaying a PDF page in the PDFPageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFZoomMode
   Inherits System.Enum
'Usage

Dim instance As PDFZoomMode
public enum PDFZoomMode : System.Enum
__value public enum PDFZoomMode : public System.Enum
public enum class PDFZoomMode : public System.Enum
Members
Member | Description
Custom | Custom zoom factor, it is set by PDFPageView.Zoom property.
FitHeight | The page is magnified just enough to fit the entire height of the page within the page view control.
FitVisible | The page is magnified just enough to fit the entire page within the page view control both horizontally and vertically.
FitWidth | The page is magnified just enough to fit the entire width of the page within the page view control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.PDFZoomMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

UserInteractiveWorkMode Enumeration

O2S.Components.PDFView4NET Namespace : UserInteractiveWorkMode Enumeration
Specifies the available user interactive working modes for the PDFPageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum UserInteractiveWorkMode
   Inherits System.Enum
'Usage

Dim instance As UserInteractiveWorkMode
public enum UserInteractiveWorkMode : System.Enum
__value public enum UserInteractiveWorkMode : public System.Enum
public enum class UserInteractiveWorkMode : public System.Enum
Members
Member | Description
AddBarcodeAnnotation | The user can add a free text annotation when the mouse is clicked and dragged on the page.
AddCheckBoxField | The user can add a checkbox field when the mouse is clicked and dragged on the page.
AddDropDownListField | The user can add a drop down list field when the mouse is clicked and dragged on the page.
AddEllipseAnnotation | The user can add an ellipse annotation when the mouse is clicked on the page.
AddFileAttachmentAnnotation | The user can add a file attachment annotation when the mouse is clicked on the page.
AddFreeTextAnnotation | The user can add a free text annotation when the mouse is clicked and dragged on the page.
AddHighlightAnnotation | The user can add a highlight annotation when the mouse is clicked and dragged on the page.
AddInkAnnotation | The user can add an ink annotation when the mouse is clicked on the page.
AddLineAnnotation | The user can add a line annotation when the mouse is clicked on the page.
AddLinkAnnotation | The user can add a link annotation when the mouse is clicked and dragged on the page.
AddListBoxField | The user can add a listbox field when the mouse is clicked and dragged on the page.
AddMeasureAnnotation | The user draws an annotation that measures the distance between 2 points.
AddPolygonAnnotation | The user can draw a polygon annotation on the page.
AddPolylineAnnotation | The user can click on the page and draw a polyline. Left mouse button double click ends the draw.
AddPolyMeasureAnnotation | The user draws an annotation that measures the distance between n points.
AddPushButtonField | The user can add a pushbutton field when the mouse is clicked and dragged on the page.
AddRadioButtonField | The user can add a radio button field when the mouse is clicked and dragged on the page.
AddRectangleAnnotation | The user can add a rectangle annotation when the mouse is clicked on the page.
AddSignatureField | The user can add a digital signature field when the mouse is clicked and dragged on the page.
AddSquigglyAnnotation | The user can add a squiggle (jagged line) annotation when the mouse is clicked and dragged on the page.
AddStampAnnotation | The user can add a stamp annotation when the mouse is clicked on the page.
AddStrikeOutAnnotation | The user can add a strike out annotation when the mouse is clicked and dragged on the page.
AddTextAnnotation | The user can add a text annotation when the mouse is clicked on the page.
AddTextBoxField | The user can add a textbox field when the mouse is clicked and dragged on the page.
AddUnderlineAnnotation | The user can add an underline annotation when the mouse is clicked and dragged on the page.
EditAnnotations | Annotations on page can be moved or resized.
None | No action.
PanAndScan | This is the default mode. The user can click anywhere on the page and move it.
TextSelect | The user can select text on the page with the mouse.
ZoomClick | The user can click on the page and the page is zoomed as long as the mouse is clicked. Left mouse button zooms in, right mouse button zooms out.
ZoomDynamic | The user can dynamically zoom the document by moving the mouse up and down.
ZoomIn | The user can zoom in the document.
ZoomMarquee | The user can select an area on the page that can be zoomed.
ZoomOut | The user can zoom out the document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.UserInteractiveWorkMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

IRawPDFData Interface
Members

O2S.Components.PDFView4NET Namespace : IRawPDFData Interface
Defines an interface for accessing raw PDF data from a high level PDF object.
Object Model
IRawPDFData Interface
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IRawPDFData
'Usage

Dim instance As IRawPDFData
public interface IRawPDFData
public __gc __interface IRawPDFData
public interface class IRawPDFData
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRawPDFData Members
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Members$$

IRawPDFData Interface Members
Methods

O2S.Components.PDFView4NET Namespace : IRawPDFData Interface

The following tables list the members exposed by IRawPDFData.

Public Methods
 | Name | Description
Method | GetRawValue | Gets the value of the specified key.
Top
See Also

Reference

IRawPDFData Interface
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

IRawPDFData Interface Methods

O2S.Components.PDFView4NET Namespace : IRawPDFData Interface

For a list of all members of this type, see IRawPDFData members.

Public Methods
 | Name | Description
Method | GetRawValue | Gets the value of the specified key.
Top
See Also

Reference

IRawPDFData Interface
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

GetRawValue Method (IRawPDFData)

O2S.Components.PDFView4NET Namespace > IRawPDFData Interface : GetRawValue Method
The key in the PDF object for which the value has been requested.
Gets the value of the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetRawValue( _
   ByVal key As String _
) As String
'Usage

Dim instance As IRawPDFData
Dim key As String
Dim value As String

value = instance.GetRawValue(key)
string GetRawValue(
   string key
)
string* GetRawValue(
   string* key
)
String^ GetRawValue(
   String^ key
)

Parameters

key
The key in the PDF object for which the value has been requested.

Return Value

The value of the given key, or null if the object does not contain the key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRawPDFData Interface
IRawPDFData Members


%%ItemTitle%%

O2S.Components.PDFView4NET.Actions Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFAction | Defines the base class for all actions available in a PDF file.
Class | PDFActionCollection | Defines a collection of actions.
Class | PDFGoToAction | Defines a "Go to" action in the PDF document.
Class | PDFHideAction | This class represents a PDF Hide field action.
Class | PDFJavaScriptAction | This class represents a PDF Javascript action.
Class | PDFLaunchAction | This class represents a PDF Launch action.
Class | PDFNamedAction | This class represents a PDF Named action.
Class | PDFRemoteGoToAction | Defines a "Remote Go to" action in the PDF document.
Class | PDFResetFormAction | Defines a SubmitForm action.
Class | PDFSubmitFormAction | Defines a SubmitForm action.
Class | PDFUriAction | Defines an URI action.
Enumerations
 | Enumeration | Description
Enumeration | NamedAction | Specifies the available named actions supported by the viewer.
Enumeration | PDFActionType | Specifies the available types of actions.
Enumeration | PDFSubmitDataFormat | Specifies the available data formats for submitting the form data.
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

PDFAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFAction Class
Defines the base class for all actions available in a PDF file.
Object Model
PDFAction ClassPDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFAction
public class PDFAction : O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFAction : public O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFAction : public O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFGoToAction
O2S.Components.PDFView4NET.Actions.PDFHideAction
O2S.Components.PDFView4NET.Actions.PDFJavaScriptAction
O2S.Components.PDFView4NET.Actions.PDFLaunchAction
O2S.Components.PDFView4NET.Actions.PDFNamedAction
O2S.Components.PDFView4NET.Actions.PDFRemoteGoToAction
O2S.Components.PDFView4NET.Actions.PDFResetFormAction
O2S.Components.PDFView4NET.Actions.PDFSubmitFormAction
O2S.Components.PDFView4NET.Actions.PDFUriAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFAction Class

The following tables list the members exposed by PDFAction.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object.
Public Property | Type | Gets the action type.
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key.
Top
See Also

Reference

PDFAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Methods$$

PDFAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFAction Class

For a list of all members of this type, see PDFAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key.
Top
See Also

Reference

PDFAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

GetRawValue Method (PDFAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFAction Class : GetRawValue Method
The key in the action for which the value has been requested.
Gets the value of the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRawValue( _
   ByVal key As String _
) As String
'Usage

Dim instance As PDFAction
Dim key As String
Dim value As String

value = instance.GetRawValue(key)
public string GetRawValue(
   string key
)
public: string* GetRawValue(
   string* key
)
public:
String^ GetRawValue(
   String^ key
)

Parameters

key
The key in the action for which the value has been requested.

Return Value

The value of the given key, or null if the action does not contain the key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAction Class
PDFAction Members


%%PageItemTitle%% $$Properties$$

PDFAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFAction Class

For a list of all members of this type, see PDFAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object.
Public Property | Type | Gets the action type.
Top
See Also

Reference

PDFAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

Actions Property

O2S.Components.PDFView4NET.Actions Namespace > PDFAction Class : Actions Property
Gets the child actions for this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Actions As PDFActionCollection
'Usage

Dim instance As PDFAction
Dim value As PDFActionCollection

value = instance.Actions
public PDFActionCollection Actions {get;}
public: __property PDFActionCollection* get_Actions();
public:
property PDFActionCollection^ Actions {
   PDFActionCollection^ get();
}

Property Value

List of child actions to be executed after current action is executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAction Class
PDFAction Members


%%ItemTitle%%

Type Property (PDFAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFAction Class : Type Property
Gets the action type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PDFActionType
'Usage

Dim instance As PDFAction
Dim value As PDFActionType

value = instance.Type
public PDFActionType Type {get;}
public: __property PDFActionType get_Type();
public:
property PDFActionType Type {
   PDFActionType get();
}

Property Value

The type of this action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAction Class
PDFAction Members


%%PageItemTitle%%

PDFActionCollection Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFActionCollection Class
Defines a collection of actions.
Object Model
PDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFActionCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFAction,PDFAction)
'Usage

Dim instance As PDFActionCollection
public class PDFActionCollection : O2S.Components.PDFView4NET.PDFCollection<PDFAction,PDFAction>
public __gc class PDFActionCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFAction,PDFAction>
public ref class PDFActionCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFAction,PDFAction>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Actions.PDFActionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFActionCollection Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFActionCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFActionCollection Class

The following tables list the members exposed by PDFActionCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFAction,PDFAction>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top
See Also

Reference

PDFActionCollection Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFGoToAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFGoToAction Class
Defines a "Go to" action in the PDF document.
Object Model
PDFGoToAction ClassPDFActionCollection ClassPDFAction ClassPDFPageDestination Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGoToAction
   Inherits PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFGoToAction
public class PDFGoToAction : PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFGoToAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFGoToAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFGoToAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGoToAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFGoToAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFGoToAction Class

The following tables list the members exposed by PDFGoToAction.

Public Constructors
 | Name | Description
Public Constructor | PDFGoToAction Constructor | Initializes a new PDFGoToAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Destination | Gets or sets the destination of the GoTo action.
Public Property | DestinationName | Gets the destination name, if the internal destination is a named destination.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFGoToAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFGoToAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFGoToAction Class : PDFGoToAction Constructor
Initializes a new PDFGoToAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFGoToAction()
public PDFGoToAction()
public: PDFGoToAction();
public:
PDFGoToAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%% $$Properties$$

PDFGoToAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFGoToAction Class

For a list of all members of this type, see PDFGoToAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Destination | Gets or sets the destination of the GoTo action.
Public Property | DestinationName | Gets the destination name, if the internal destination is a named destination.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFGoToAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

Destination Property (PDFGoToAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFGoToAction Class : Destination Property
Gets or sets the destination of the GoTo action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Destination As PDFPageDestination
'Usage

Dim instance As PDFGoToAction
Dim value As PDFPageDestination

instance.Destination = value

value = instance.Destination
public PDFPageDestination Destination {get; set;}
public: __property PDFPageDestination* get_Destination();
public: __property void set_Destination(
   PDFPageDestination* value
);
public:
property PDFPageDestination^ Destination {
   PDFPageDestination^ get();
   void set (    PDFPageDestination^ value);
}

Property Value

The location in the document that will be displayed as a result of executing this action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%ItemTitle%%

DestinationName Property (PDFGoToAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFGoToAction Class : DestinationName Property
Gets the destination name, if the internal destination is a named destination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DestinationName As String
'Usage

Dim instance As PDFGoToAction
Dim value As String

value = instance.DestinationName
public string DestinationName {get;}
public: __property string* get_DestinationName();
public:
property String^ DestinationName {
   String^ get();
}

Property Value

The name associated with the Destination.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%%

PDFHideAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFHideAction Class
This class represents a PDF Hide field action.
Object Model
PDFHideAction ClassPDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFHideAction
   Inherits PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFHideAction
public class PDFHideAction : PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFHideAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFHideAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This type of action lets you hide or show a field.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFHideAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFHideAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFHideAction Class

The following tables list the members exposed by PDFHideAction.

Public Constructors
 | Name | Description
Public Constructor | PDFHideAction Constructor | Initializes a new PDFHideAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether the specified form field should be hidden or shown.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFHideAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFHideAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFHideAction Class : PDFHideAction Constructor
Initializes a new PDFHideAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFHideAction()
public PDFHideAction()
public: PDFHideAction();
public:
PDFHideAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%PageItemTitle%% $$Properties$$

PDFHideAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFHideAction Class

For a list of all members of this type, see PDFHideAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether the specified form field should be hidden or shown.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFHideAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

FieldName Property

O2S.Components.PDFView4NET.Actions Namespace > PDFHideAction Class : FieldName Property
Gets or sets the name of the field that is affected by this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FieldName As String
'Usage

Dim instance As PDFHideAction
Dim value As String

instance.FieldName = value

value = instance.FieldName
public string FieldName {get; set;}
public: __property string* get_FieldName();
public: __property void set_FieldName(
   string* value
);
public:
property String^ FieldName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the name of the field that is affected by this action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%ItemTitle%%

Hide Property

O2S.Components.PDFView4NET.Actions Namespace > PDFHideAction Class : Hide Property
Gets or sets a value indicating whether the specified form field should be hidden or shown.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Hide As Boolean
'Usage

Dim instance As PDFHideAction
Dim value As Boolean

instance.Hide = value

value = instance.Hide
public bool Hide {get; set;}
public: __property bool get_Hide();
public: __property void set_Hide(
   bool value
);
public:
property bool Hide {
   bool get();
   void set (    bool value);
}

Property Value

True if the form field should be hidden, false if the form field should be shown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%PageItemTitle%%

PDFJavaScriptAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFJavaScriptAction Class
This class represents a PDF Javascript action.
Object Model
PDFJavaScriptAction ClassPDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFJavaScriptAction
   Inherits PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFJavaScriptAction
public class PDFJavaScriptAction : PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFJavaScriptAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFJavaScriptAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This type of action allows a user to execute Javascript code within the viewer.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFJavaScriptAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFJavaScriptAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFJavaScriptAction Class

The following tables list the members exposed by PDFJavaScriptAction.

Public Constructors
 | Name | Description
Public Constructor | PDFJavaScriptAction Constructor | Initializes a new PDFJavaScriptAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Script | Gets or sets the javascript code to be executed when this action is executed.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFJavaScriptAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFJavaScriptAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFJavaScriptAction Class : PDFJavaScriptAction Constructor
Initializes a new PDFJavaScriptAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFJavaScriptAction()
public PDFJavaScriptAction()
public: PDFJavaScriptAction();
public:
PDFJavaScriptAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


%%PageItemTitle%% $$Properties$$

PDFJavaScriptAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFJavaScriptAction Class

For a list of all members of this type, see PDFJavaScriptAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Script | Gets or sets the javascript code to be executed when this action is executed.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFJavaScriptAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

Script Property

O2S.Components.PDFView4NET.Actions Namespace > PDFJavaScriptAction Class : Script Property
Gets or sets the javascript code to be executed when this action is executed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Script As String
'Usage

Dim instance As PDFJavaScriptAction
Dim value As String

instance.Script = value

value = instance.Script
public string Script {get; set;}
public: __property string* get_Script();
public: __property void set_Script(
   string* value
);
public:
property String^ Script {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing valid javascript code to be executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


%%PageItemTitle%%

PDFLaunchAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFLaunchAction Class
This class represents a PDF Launch action.
Object Model
PDFLaunchAction ClassPDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLaunchAction
   Inherits PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFLaunchAction
public class PDFLaunchAction : PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFLaunchAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFLaunchAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This type of action allows a user to launch an application or to open a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFLaunchAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFLaunchAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFLaunchAction Class

The following tables list the members exposed by PDFLaunchAction.

Public Constructors
 | Name | Description
Public Constructor | PDFLaunchAction Constructor | Initializes a new PDFLaunchAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | FileName | Gets or sets the name of the file to be launched by this action.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the launched application.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFLaunchAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFLaunchAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFLaunchAction Class : PDFLaunchAction Constructor
Initializes a new PDFLaunchAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLaunchAction()
public PDFLaunchAction()
public: PDFLaunchAction();
public:
PDFLaunchAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%% $$Properties$$

PDFLaunchAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFLaunchAction Class

For a list of all members of this type, see PDFLaunchAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | FileName | Gets or sets the name of the file to be launched by this action.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the launched application.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFLaunchAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

FileName Property (PDFLaunchAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFLaunchAction Class : FileName Property
Gets or sets the name of the file to be launched by this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PDFLaunchAction
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

An string value specifying the full path to the file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%ItemTitle%%

NewWindow Property

O2S.Components.PDFView4NET.Actions Namespace > PDFLaunchAction Class : NewWindow Property
Gets or sets whether the remote document opens in current window or in a new window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NewWindow As Boolean
'Usage

Dim instance As PDFLaunchAction
Dim value As Boolean

instance.NewWindow = value

value = instance.NewWindow
public bool NewWindow {get; set;}
public: __property bool get_NewWindow();
public: __property void set_NewWindow(
   bool value
);
public:
property bool NewWindow {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether the remote document opens in current window or in a new window. If the remote document opens in the current window, the current pdf file is replaced with the remote document.
Remarks
If the file is not a pdf document, this property is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%ItemTitle%%

Parameters Property

O2S.Components.PDFView4NET.Actions Namespace > PDFLaunchAction Class : Parameters Property
Gets or sets a parameter string to be passed to the launched application.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Parameters As String
'Usage

Dim instance As PDFLaunchAction
Dim value As String

instance.Parameters = value

value = instance.Parameters
public string Parameters {get; set;}
public: __property string* get_Parameters();
public: __property void set_Parameters(
   string* value
);
public:
property String^ Parameters {
   String^ get();
   void set (    String^ value);
}

Property Value

An string value specifying the the list of parameters to be passed to the launched application
Remarks
This property matches the string of parameters as if they were passed to the application in the command line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%%

PDFNamedAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFNamedAction Class
This class represents a PDF Named action.
Object Model
PDFNamedAction ClassPDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFNamedAction
   Inherits PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFNamedAction
public class PDFNamedAction : PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFNamedAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFNamedAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This type of action allows a user to navigate to specific pages in the document or to print the document.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFNamedAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFNamedAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFNamedAction Class

The following tables list the members exposed by PDFNamedAction.

Public Constructors
 | Name | Description
Public Constructor | PDFNamedAction Constructor | Initializes a new PDFNamedAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | NamedAction | Gets or sets the named action to be executed when this action is executed.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFNamedAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFNamedAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFNamedAction Class : PDFNamedAction Constructor
Initializes a new PDFNamedAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFNamedAction()
public PDFNamedAction()
public: PDFNamedAction();
public:
PDFNamedAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


%%PageItemTitle%% $$Properties$$

PDFNamedAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFNamedAction Class

For a list of all members of this type, see PDFNamedAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | NamedAction | Gets or sets the named action to be executed when this action is executed.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFNamedAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

NamedAction Property

O2S.Components.PDFView4NET.Actions Namespace > PDFNamedAction Class : NamedAction Property
Gets or sets the named action to be executed when this action is executed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NamedAction As NamedAction
'Usage

Dim instance As PDFNamedAction
Dim value As NamedAction

instance.NamedAction = value

value = instance.NamedAction
public NamedAction NamedAction {get; set;}
public: __property NamedAction get_NamedAction();
public: __property void set_NamedAction(
   NamedAction value
);
public:
property NamedAction NamedAction {
   NamedAction get();
   void set (    NamedAction value);
}

Property Value

An NamedAction enumeration member specifying the action to be executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


%%PageItemTitle%%

PDFRemoteGoToAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFRemoteGoToAction Class
Defines a "Remote Go to" action in the PDF document.
Object Model
PDFRemoteGoToAction ClassPDFActionCollection ClassPDFAction ClassPDFRemotePageDestination Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRemoteGoToAction
   Inherits PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFRemoteGoToAction
public class PDFRemoteGoToAction : PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFRemoteGoToAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFRemoteGoToAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFRemoteGoToAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFRemoteGoToAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFRemoteGoToAction Class

The following tables list the members exposed by PDFRemoteGoToAction.

Public Constructors
 | Name | Description
Public Constructor | PDFRemoteGoToAction Constructor | Initializes a new PDFRemoteGoToAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Destination | Gets or sets the destination of this action.
Public Property | DestinationName | Gets the destination name, if the internal destination is a named destination.
Public Property | FileName | Gets or sets the target file name.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFRemoteGoToAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFRemoteGoToAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFRemoteGoToAction Class : PDFRemoteGoToAction Constructor
Initializes a new PDFRemoteGoToAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRemoteGoToAction()
public PDFRemoteGoToAction()
public: PDFRemoteGoToAction();
public:
PDFRemoteGoToAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%% $$Properties$$

PDFRemoteGoToAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFRemoteGoToAction Class

For a list of all members of this type, see PDFRemoteGoToAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Destination | Gets or sets the destination of this action.
Public Property | DestinationName | Gets the destination name, if the internal destination is a named destination.
Public Property | FileName | Gets or sets the target file name.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFRemoteGoToAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

Destination Property (PDFRemoteGoToAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFRemoteGoToAction Class : Destination Property
Gets or sets the destination of this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Destination As PDFRemotePageDestination
'Usage

Dim instance As PDFRemoteGoToAction
Dim value As PDFRemotePageDestination

instance.Destination = value

value = instance.Destination
public PDFRemotePageDestination Destination {get; set;}
public: __property PDFRemotePageDestination* get_Destination();
public: __property void set_Destination(
   PDFRemotePageDestination* value
);
public:
property PDFRemotePageDestination^ Destination {
   PDFRemotePageDestination^ get();
   void set (    PDFRemotePageDestination^ value);
}

Property Value

The location in the remote document that will be displayed as a result of executing this action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%ItemTitle%%

DestinationName Property (PDFRemoteGoToAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFRemoteGoToAction Class : DestinationName Property
Gets the destination name, if the internal destination is a named destination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DestinationName As String
'Usage

Dim instance As PDFRemoteGoToAction
Dim value As String

value = instance.DestinationName
public string DestinationName {get;}
public: __property string* get_DestinationName();
public:
property String^ DestinationName {
   String^ get();
}

Property Value

The name associated with the Destination.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%ItemTitle%%

FileName Property (PDFRemoteGoToAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFRemoteGoToAction Class : FileName Property
Gets or sets the target file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PDFRemoteGoToAction
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the file that represents the target of this action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%%

PDFResetFormAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFResetFormAction Class
Defines a SubmitForm action.
Object Model
PDFResetFormAction ClassPDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFResetFormAction
   Inherits PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFResetFormAction
public class PDFResetFormAction : PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFResetFormAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFResetFormAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This action allows a user to reset the form fields to their default values.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFResetFormAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFResetFormAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFResetFormAction Class

The following tables list the members exposed by PDFResetFormAction.

Public Constructors
 | Name | Description
Public Constructor | PDFResetFormAction Constructor | Initializes a new PDFResetFormAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | ResetFields | Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFResetFormAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFResetFormAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFResetFormAction Class : PDFResetFormAction Constructor
Initializes a new PDFResetFormAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFResetFormAction()
public PDFResetFormAction()
public: PDFResetFormAction();
public:
PDFResetFormAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%PageItemTitle%% $$Properties$$

PDFResetFormAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFResetFormAction Class

For a list of all members of this type, see PDFResetFormAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | ResetFields | Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFResetFormAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

Fields Property (PDFResetFormAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFResetFormAction Class : Fields Property
Gets or sets the list of fields affected by this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fields As List(Of String)
'Usage

Dim instance As PDFResetFormAction
Dim value As List(Of String)

instance.Fields = value

value = instance.Fields
public List<string> Fields {get; set;}
public: __property List<string*>* get_Fields();
public: __property void set_Fields(
   List<string*>* value
);
public:
property List<String^>^ Fields {
   List<String^>^ get();
   void set (    List<String^>^ value);
}

Property Value

A System.Collections.Specialized.StringCollection object specifying the list of fields affected by this action.
Remarks
The ResetFields property controls how the fields in this collection are reset.
If ResetFields property is true, only the fields in this collection will be reset.
If ResetFields property is false, the fields in this collection are not reset and only the remaining form fields are reset.
If the collection is null or empty, then all the form fields are reset and the ResetFields property is ignored.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%ItemTitle%%

ResetFields Property

O2S.Components.PDFView4NET.Actions Namespace > PDFResetFormAction Class : ResetFields Property
Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResetFields As Boolean
'Usage

Dim instance As PDFResetFormAction
Dim value As Boolean

instance.ResetFields = value

value = instance.ResetFields
public bool ResetFields {get; set;}
public: __property bool get_ResetFields();
public: __property void set_ResetFields(
   bool value
);
public:
property bool ResetFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the fields in Fields collection should be reset, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%PageItemTitle%%

PDFSubmitFormAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFSubmitFormAction Class
Defines a SubmitForm action.
Object Model
PDFSubmitFormAction ClassPDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSubmitFormAction
   Inherits PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFSubmitFormAction
public class PDFSubmitFormAction : PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFSubmitFormAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFSubmitFormAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This action allows a user to submit the form data to a specified URL.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFSubmitFormAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFSubmitFormAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFSubmitFormAction Class

The following tables list the members exposed by PDFSubmitFormAction.

Public Constructors
 | Name | Description
Public Constructor | PDFSubmitFormAction Constructor | Initializes a new PDFSubmitFormAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | DataFormat | Gets or sets the format of the data being submitted.
Public Property | EmbedForm | Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value should be submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Url | Gets or sets the URL for submitting the form data.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFSubmitFormAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFSubmitFormAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : PDFSubmitFormAction Constructor
Initializes a new PDFSubmitFormAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSubmitFormAction()
public PDFSubmitFormAction()
public: PDFSubmitFormAction();
public:
PDFSubmitFormAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%% $$Properties$$

PDFSubmitFormAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFSubmitFormAction Class

For a list of all members of this type, see PDFSubmitFormAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | DataFormat | Gets or sets the format of the data being submitted.
Public Property | EmbedForm | Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value should be submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Url | Gets or sets the URL for submitting the form data.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Top
See Also

Reference

PDFSubmitFormAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

DataFormat Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : DataFormat Property
Gets or sets the format of the data being submitted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DataFormat As PDFSubmitDataFormat
'Usage

Dim instance As PDFSubmitFormAction
Dim value As PDFSubmitDataFormat

instance.DataFormat = value

value = instance.DataFormat
public PDFSubmitDataFormat DataFormat {get; set;}
public: __property PDFSubmitDataFormat get_DataFormat();
public: __property void set_DataFormat(
   PDFSubmitDataFormat value
);
public:
property PDFSubmitDataFormat DataFormat {
   PDFSubmitDataFormat get();
   void set (    PDFSubmitDataFormat value);
}

Property Value

A SubmitDataFormat enumeration member specifying the format of the data being submitted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

EmbedForm Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : EmbedForm Property
Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EmbedForm As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.EmbedForm = value

value = instance.EmbedForm
public bool EmbedForm {get; set;}
public: __property bool get_EmbedForm();
public: __property void set_EmbedForm(
   bool value
);
public:
property bool EmbedForm {
   bool get();
   void set (    bool value);
}

Property Value

True if the PDF document is embedded in the submitted FDF file, false otherwise. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.FDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

ExcludeNonUserAnnotations Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : ExcludeNonUserAnnotations Property
Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExcludeNonUserAnnotations As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.ExcludeNonUserAnnotations = value

value = instance.ExcludeNonUserAnnotations
public bool ExcludeNonUserAnnotations {get; set;}
public: __property bool get_ExcludeNonUserAnnotations();
public: __property void set_ExcludeNonUserAnnotations(
   bool value
);
public:
property bool ExcludeNonUserAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

True if only the annotations whose author is the current user should be submitted, false otherwise. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.FDF and IncludeAnnotations property is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

Fields Property (PDFSubmitFormAction)

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : Fields Property
Gets or sets the list of fields affected by this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fields As List(Of String)
'Usage

Dim instance As PDFSubmitFormAction
Dim value As List(Of String)

instance.Fields = value

value = instance.Fields
public List<string> Fields {get; set;}
public: __property List<string*>* get_Fields();
public: __property void set_Fields(
   List<string*>* value
);
public:
property List<String^>^ Fields {
   List<String^>^ get();
   void set (    List<String^>^ value);
}

Property Value

A System.Collections.Specialized.StringCollection object specifying the list of fields affected by this action.
Remarks
The SubmitFields property controls how the fields in this collection are submitted to the specified URL.
If SubmitFields property is true, only the fields in this collection will be submitted.
If SubmitFields property is false, the fields in this collection will not be submitted and only the remaining form fields will be submitted.
If the collection is null or empty, then all the form fields are submitted and the SubmitFields property is ignored.
In any of the situations above, the fields with PDFField.NoExport property set to true will not be submitted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

IncludeAnnotations Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeAnnotations Property
Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncludeAnnotations As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeAnnotations = value

value = instance.IncludeAnnotations
public bool IncludeAnnotations {get; set;}
public: __property bool get_IncludeAnnotations();
public: __property void set_IncludeAnnotations(
   bool value
);
public:
property bool IncludeAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

True if the incremental updates to the underlying PDF document should be included in the submitted FDF file, false otherwise. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.FDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

IncludeAppendSaves Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeAppendSaves Property
Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncludeAppendSaves As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeAppendSaves = value

value = instance.IncludeAppendSaves
public bool IncludeAppendSaves {get; set;}
public: __property bool get_IncludeAppendSaves();
public: __property void set_IncludeAppendSaves(
   bool value
);
public:
property bool IncludeAppendSaves {
   bool get();
   void set (    bool value);
}

Property Value

True if the incremental updates to the underlying PDF document should be included in the submitted FDF file, false otherwise. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.FDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

IncludeNoValueFields Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeNoValueFields Property
Gets or sets a value indicating whether the fields with no value should be submitted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncludeNoValueFields As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeNoValueFields = value

value = instance.IncludeNoValueFields
public bool IncludeNoValueFields {get; set;}
public: __property bool get_IncludeNoValueFields();
public: __property void set_IncludeNoValueFields(
   bool value
);
public:
property bool IncludeNoValueFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the fields with no value should be submitted, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

SubmitCoordinates Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : SubmitCoordinates Property
Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubmitCoordinates As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.SubmitCoordinates = value

value = instance.SubmitCoordinates
public bool SubmitCoordinates {get; set;}
public: __property bool get_SubmitCoordinates();
public: __property void set_SubmitCoordinates(
   bool value
);
public:
property bool SubmitCoordinates {
   bool get();
   void set (    bool value);
}

Property Value

True if the coordinates of the mouse click that caused the submit form action should be transmitted as part of form data, otherwise false. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.HTML.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

SubmitFields Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : SubmitFields Property
Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubmitFields As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.SubmitFields = value

value = instance.SubmitFields
public bool SubmitFields {get; set;}
public: __property bool get_SubmitFields();
public: __property void set_SubmitFields(
   bool value
);
public:
property bool SubmitFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the fields in Fields collection should be submitted, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

Url Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : Url Property
Gets or sets the URL for submitting the form data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Url As String
'Usage

Dim instance As PDFSubmitFormAction
Dim value As String

instance.Url = value

value = instance.Url
public string Url {get; set;}
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
public:
property String^ Url {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the URL where the form data should be submitted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

UseCanonicalDateTimeFormat Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : UseCanonicalDateTimeFormat Property
Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseCanonicalDateTimeFormat As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.UseCanonicalDateTimeFormat = value

value = instance.UseCanonicalDateTimeFormat
public bool UseCanonicalDateTimeFormat {get; set;}
public: __property bool get_UseCanonicalDateTimeFormat();
public: __property void set_UseCanonicalDateTimeFormat(
   bool value
);
public:
property bool UseCanonicalDateTimeFormat {
   bool get();
   void set (    bool value);
}

Property Value

True if the the field values representing dates should be submitted using PDF date/time format. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%ItemTitle%%

UseHttpGet Property

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : UseHttpGet Property
Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseHttpGet As Boolean
'Usage

Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.UseHttpGet = value

value = instance.UseHttpGet
public bool UseHttpGet {get; set;}
public: __property bool get_UseHttpGet();
public: __property void set_UseHttpGet(
   bool value
);
public:
property bool UseHttpGet {
   bool get();
   void set (    bool value);
}

Property Value

True if the field names and values should be submitted using HTTP GET method. If false, the field names and values are submitted using HTTP POST method. Default is false.
Remarks
This property has meaning only if DataFormat property is DataFormat.HTML or DataFormat.PDF.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%%

PDFUriAction Class
Members

O2S.Components.PDFView4NET.Actions Namespace : PDFUriAction Class
Defines an URI action.
Object Model
PDFUriAction ClassPDFActionCollection ClassPDFAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUriAction
   Inherits PDFAction
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFUriAction
public class PDFUriAction : PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFUriAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFUriAction : public PDFAction, O2S.Components.PDFView4NET.IRawPDFData
Remarks
URI actions allow to defines actions that launch a specified url in the default browser.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFUriAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUriAction Members
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Members$$

PDFUriAction Class Members
Properties Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFUriAction Class

The following tables list the members exposed by PDFUriAction.

Public Constructors
 | Name | Description
Public Constructor | PDFUriAction Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | URI | Gets or sets the URI associated with this action.
Top
Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFUriAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFUriAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFUriAction Class : PDFUriAction Constructor
Overload List
Overload | Description
PDFUriAction Constructor() | Initializes a new PDFUriAction object.
PDFUriAction Constructor(String) | Initializes a new PDFUriAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUriAction Class
PDFUriAction Members


%%PageItemTitle%%

PDFUriAction Constructor()

O2S.Components.PDFView4NET.Actions Namespace > PDFUriAction Class > PDFUriAction Constructor : PDFUriAction Constructor()
Initializes a new PDFUriAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUriAction()
public PDFUriAction()
public: PDFUriAction();
public:
PDFUriAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUriAction Class
PDFUriAction Members
Overload List


%%PageItemTitle%%

PDFUriAction Constructor(String)

O2S.Components.PDFView4NET.Actions Namespace > PDFUriAction Class > PDFUriAction Constructor : PDFUriAction Constructor(String)
The URI associated with the action.
Initializes a new PDFUriAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As String _
)
'Usage

Dim uri As String

Dim instance As New PDFUriAction(uri)
public PDFUriAction(
   string uri
)
public: PDFUriAction(
   string* uri
)
public:
PDFUriAction(
   String^ uri
)

Parameters

uri
The URI associated with the action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUriAction Class
PDFUriAction Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFUriAction Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFUriAction Class

For a list of all members of this type, see PDFUriAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets the child actions for this object. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | Type | Gets the action type. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Public Property | URI | Gets or sets the URI associated with this action.
Top
See Also

Reference

PDFUriAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

URI Property

O2S.Components.PDFView4NET.Actions Namespace > PDFUriAction Class : URI Property
Gets or sets the URI associated with this action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property URI As String
'Usage

Dim instance As PDFUriAction
Dim value As String

instance.URI = value

value = instance.URI
public string URI {get; set;}
public: __property string* get_URI();
public: __property void set_URI(
   string* value
);
public:
property String^ URI {
   String^ get();
   void set (    String^ value);
}

Property Value

A url that will be launched in the default browser when the action is executed.
Exceptions
Exception | Description
 | Thrown when the URI is null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUriAction Class
PDFUriAction Members


%%PageItemTitle%%

NamedAction Enumeration

O2S.Components.PDFView4NET.Actions Namespace : NamedAction Enumeration
Specifies the available named actions supported by the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum NamedAction
   Inherits System.Enum
'Usage

Dim instance As NamedAction
public enum NamedAction : System.Enum
__value public enum NamedAction : public System.Enum
public enum class NamedAction : public System.Enum
Members
Member | Description
FirstPage | Go to first page in the document.
LastPage | Go to last page in the document.
NextPage | Go to next page in the document.
PrevPage | Go to previous page in the document.
Print | Print the document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Actions.NamedAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFActionType Enumeration

O2S.Components.PDFView4NET.Actions Namespace : PDFActionType Enumeration
Specifies the available types of actions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFActionType
   Inherits System.Enum
'Usage

Dim instance As PDFActionType
public enum PDFActionType : System.Enum
__value public enum PDFActionType : public System.Enum
public enum class PDFActionType : public System.Enum
Members
Member | Description
GoTo | Go to action, goes to the specified page in current document.
Hide | Hide action.
Launch | Launch action.
Named | Named action.
RemoteGoTo | Remote Go to action, goes to the specified page in another document.
Unknown | Unknown action.
Uri | Uri action, launches a web url in the default browser.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Actions.PDFActionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFSubmitDataFormat Enumeration

O2S.Components.PDFView4NET.Actions Namespace : PDFSubmitDataFormat Enumeration
Specifies the available data formats for submitting the form data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFSubmitDataFormat
   Inherits System.Enum
'Usage

Dim instance As PDFSubmitDataFormat
public enum PDFSubmitDataFormat : System.Enum
__value public enum PDFSubmitDataFormat : public System.Enum
public enum class PDFSubmitDataFormat : public System.Enum
Members
Member | Description
FDF | The field names and values are submitted in FDF format.
HTML | The field names and values are submitted in HTML Form format.
PDF | The entire PDF file is submitted.
XFDF | The field names and values are submitted in XFDF format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Actions.PDFSubmitDataFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%%

O2S.Components.PDFView4NET.Annotations Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFAnnotation | Defines the base class for all annotations available in a PDF file.
Class | PDFAnnotationAppearance | Defines the base class for all annotation appearances.
Class | PDFAnnotationBorder | Defines the border of an annotation.
Class | PDFAnnotationCollection | Defines a collection of annotations.
Class | PDFAnnotationReplyCollection | Defines a collection of annotations.
Class | PDFBarcodeAnnotation | Defines a barcode annotation.
Class | PDFEllipseAnnotation | Defines an ellipse (Circle) annotation.
Class | PDFFileAttachmentAnnotation | Defines a file attachment annotation.
Class | PDFFreeTextAnnotation | Defines a free text annotations.
Class | PDFHighlightAnnotation | Defines a highlight annotation.
Class | PDFImageAppearance | Defines an annotation appearance that consists of an image.
Class | PDFInkAnnotation | Defines an ink annotation.
Class | PDFLineAnnotation | Defines a line annotation.
Class | PDFLinkAnnotation | Defines a link annotations.
Class | PDFMarkupAnnotation | Defines the base class for all markup type annotations.
Class | PDFMeasureAnnotation | Defines a measure annotation.
Class | PDFPointsCollection | Defines a collection of array the store points on the page.
Class | PDFPolygonAnnotation | Defines a polygon annotation.
Class | PDFPolyLineAnnotation | Defines a polyline annotation.
Class | PDFPolyMeasureAnnotation | Defines a poly ruler annotation.
Class | PDFPopupAnnotation | Defines a popup annotation.
Class | PDFRectangleAnnotation | Defines a rectangle (Square) annotation.
Class | PDFSCAnnotation | Defines the base class for rectangle (Square) and ellipse (Circle) annotations.
Class | PDFSquigglyAnnotation | Defines a squiggly annotation.
Class | PDFStampAnnotation | Defines a rubber stamp annotation.
Class | PDFStrikeOutAnnotation | Defines a strike out annotation.
Class | PDFTextAnnotation | Defines a text annotation.
Class | PDFTextMarkupAnnotation | Defines a text markup annotation.
Class | PDFUnderlineAnnotation | Defines an underline annotation.
Enumerations
 | Enumeration | Description
Enumeration | PDFAnnotationFlags | Specifies the available flags for an annotation.
Enumeration | PDFAnnotationType | Specifies the available types of annotations.
Enumeration | PDFBorderStyle | Specifies the available styles for an annotation's border.
Enumeration | PDFFileAttachmentAnnotationIcon | Specifies the available icons for a file attachment annotation.
Enumeration | PDFLineDirection | Specifies the available directions for a line annotation.
Enumeration | PDFLineEndingStyle | Specifies the available line ending styles to be used when drawing a line annotation.
Enumeration | PDFStampAnnotationIcon | Specifies the available icons for a stmap annotation.
Enumeration | PDFTextAnnotationIcon | Specifies the available icons for a text annotation.
Enumeration | PDFTextAnnotationState | Specifies the available states for a text annotation.
Enumeration | PDFTextMarkupType | Specifies the available markup types for a text markup annotation.
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

PDFAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotation Class
Defines the base class for all annotations available in a PDF file.
Object Model
PDFAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFAnnotation
[Serializable()]
public class PDFAnnotation : O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFAnnotation : public O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFAnnotation : public O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFFreeTextAnnotation
O2S.Components.PDFView4NET.Annotations.PDFLinkAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPopupAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotation Class

The following tables list the members exposed by PDFAnnotation.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color.
Public Property | Contents | Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Flags | Gets or sets the annotation flags.
Public Property | ID | Gets the annotation unique id.
Public Property | ModifiedDate | Gets or sets the annotation modified date.
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle.
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle.
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle.
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle.
Public Property | Page | Gets the page that includes this annotation.
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed.
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee.
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened.
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation.
Public Property | Rotation | Gets or sets the annotation rotation angle.
Public Property | Tag | Gets the annotation tag.
Public Property | Type | Gets the annotation type.
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation.
Public Method | Dispose | Disposes the internal resources.
Public Method | Export | Exports the annotation as XML to the specified stream.
Public Method | GetObjectData | Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key.
static (Shared in Visual Basic) | Import | Imports the annotation from the specified stream.
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotation Class

For a list of all members of this type, see PDFAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation.
Public Method | Dispose | Disposes the internal resources.
Public Method | Export | Exports the annotation as XML to the specified stream.
Public Method | GetObjectData | Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key.
static (Shared in Visual Basic) | Import | Imports the annotation from the specified stream.
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer.
Top
See Also

Reference

PDFAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Clone Method (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Clone Method
Clones the annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Clone() As Object
'Usage

Dim instance As PDFAnnotation
Dim value As Object

value = instance.Clone()
public object Clone()
public: Object* Clone();
public:
Object^ Clone();

Return Value

The new annotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Dispose Method (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Dispose Method
Disposes the internal resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PDFAnnotation

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Export Method

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Export Method
Destination stream for annotation export.
Exports the annotation as XML to the specified stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Export( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PDFAnnotation
Dim stream As Stream

instance.Export(stream)
public void Export(
   Stream stream
)
public: void Export(
   Stream* stream
)
public:
void Export(
   Stream^ stream
)

Parameters

stream
Destination stream for annotation export.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when stream is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

GetObjectData Method (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
public:
virtual void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

GetRawValue Method (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : GetRawValue Method
The key in the annotation for which the value has been requested.
Gets the value of the specified key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRawValue( _
   ByVal key As String _
) As String
'Usage

Dim instance As PDFAnnotation
Dim key As String
Dim value As String

value = instance.GetRawValue(key)
public string GetRawValue(
   string key
)
public: string* GetRawValue(
   string* key
)
public:
String^ GetRawValue(
   String^ key
)

Parameters

key
The key in the annotation for which the value has been requested.

Return Value

The value of the given key, or null if the annotation does not contain the key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Import Method

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Import Method
Source stream for annotation import.
Imports the annotation from the specified stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Import( _
   ByVal stream As Stream _
) As PDFAnnotation
'Usage

Dim stream As Stream
Dim value As PDFAnnotation

value = PDFAnnotation.Import(stream)
public static PDFAnnotation Import(
   Stream stream
)
public: static PDFAnnotation* Import(
   Stream* stream
)
public:
static PDFAnnotation^ Import(
   Stream^ stream
)

Parameters

stream
Source stream for annotation import.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when stream is null.
System.IO.InvalidDataException | Thrown when the stream does not contain an annotation in a valid format.
Remarks
The stream must contain an annotation previously exported using the Export method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

PrepareForCopyPaste Method (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : PrepareForCopyPaste Method
Prepares the annotation for a copy/paste operation in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub PrepareForCopyPaste()
'Usage

Dim instance As PDFAnnotation

instance.PrepareForCopyPaste()
public virtual void PrepareForCopyPaste()
public: virtual void PrepareForCopyPaste();
public:
virtual void PrepareForCopyPaste();
Remarks
The method builds internal structures so when the annotation is pasted it appears exactly in the same visual position on the new page, no matter the page rotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotation Class

For a list of all members of this type, see PDFAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color.
Public Property | Contents | Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Flags | Gets or sets the annotation flags.
Public Property | ID | Gets the annotation unique id.
Public Property | ModifiedDate | Gets or sets the annotation modified date.
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle.
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle.
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle.
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle.
Public Property | Page | Gets the page that includes this annotation.
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed.
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee.
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened.
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation.
Public Property | Rotation | Gets or sets the annotation rotation angle.
Public Property | Tag | Gets the annotation tag.
Public Property | Type | Gets the annotation type.
Top
See Also

Reference

PDFAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Appearance Property (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public virtual PDFAnnotationAppearance Appearance {get; set;}
public: __property virtual PDFAnnotationAppearance* get_Appearance();
public: __property virtual void set_Appearance(
   PDFAnnotationAppearance* value
);
public:
virtual property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The appearance of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Color Property (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Color Property
Gets or sets the annotation color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Color As PDFRgbColor
'Usage

Dim instance As PDFAnnotation
Dim value As PDFRgbColor

instance.Color = value

value = instance.Color
public PDFRgbColor Color {get; set;}
public: __property PDFRgbColor* get_Color();
public: __property void set_Color(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ Color {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The annotation color.
Remarks
The actual usage of this color depends on the annotation type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Contents Property (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Contents Property
Gets or sets the annotation contents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Contents As String
'Usage

Dim instance As PDFAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
public virtual string Contents {get; set;}
public: __property virtual string* get_Contents();
public: __property virtual void set_Contents(
   string* value
);
public:
virtual property String^ Contents {
   String^ get();
   void set (    String^ value);
}

Property Value

The text to be displayed for the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

CreationDate Property (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : CreationDate Property
Gets or sets the annotation creation date.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PDFAnnotation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date when the annotation was created.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

DisplayRectangle Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : DisplayRectangle Property
Gets or sets the display rectangle of this annotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayRectangle As DisplayRectangle
'Usage

Dim instance As PDFAnnotation
Dim value As DisplayRectangle

instance.DisplayRectangle = value

value = instance.DisplayRectangle
public DisplayRectangle DisplayRectangle {get; set;}
public: __property DisplayRectangle* get_DisplayRectangle();
public: __property void set_DisplayRectangle(
   DisplayRectangle* value
);
public:
property DisplayRectangle^ DisplayRectangle {
   DisplayRectangle^ get();
   void set (    DisplayRectangle^ value);
}

Property Value

A System.Drawing.RectangleF object specifying the position and size of the annotation.
Remarks
The display rectangle is relative to the top left corner of the page, as opposed to PDFRectangle which is relative to bottom left corner of the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Flags Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Flags Property
Gets or sets the annotation flags.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Flags As PDFAnnotationFlags
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAnnotationFlags

instance.Flags = value

value = instance.Flags
public PDFAnnotationFlags Flags {get; set;}
public: __property PDFAnnotationFlags get_Flags();
public: __property void set_Flags(
   PDFAnnotationFlags value
);
public:
property PDFAnnotationFlags Flags {
   PDFAnnotationFlags get();
   void set (    PDFAnnotationFlags value);
}

Property Value

Flags the control the annotation behavior.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

ID Property (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : ID Property
Gets the annotation unique id.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ID As String
'Usage

Dim instance As PDFAnnotation
Dim value As String

value = instance.ID
public string ID {get;}
public: __property string* get_ID();
public:
property String^ ID {
   String^ get();
}

Property Value

A unique id that identifies the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

ModifiedDate Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : ModifiedDate Property
Gets or sets the annotation modified date.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModifiedDate As Date
'Usage

Dim instance As PDFAnnotation
Dim value As Date

instance.ModifiedDate = value

value = instance.ModifiedDate
public DateTime ModifiedDate {get; set;}
public: __property DateTime get_ModifiedDate();
public: __property void set_ModifiedDate(
   DateTime value
);
public:
property DateTime ModifiedDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The most recent date when the annotation was modified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

MouseDown Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : MouseDown Property
Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseDown As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseDown = value

value = instance.MouseDown
public PDFAction MouseDown {get; set;}
public: __property PDFAction* get_MouseDown();
public: __property void set_MouseDown(
   PDFAction* value
);
public:
property PDFAction^ MouseDown {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the mouse is pressed in the annotation rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

MouseEnter Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : MouseEnter Property
Gets or sets the action that is executed when the mouse enters the annotation rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseEnter As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseEnter = value

value = instance.MouseEnter
public PDFAction MouseEnter {get; set;}
public: __property PDFAction* get_MouseEnter();
public: __property void set_MouseEnter(
   PDFAction* value
);
public:
property PDFAction^ MouseEnter {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the mouse enters the annotation rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

MouseLeave Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : MouseLeave Property
Gets or sets the action that is executed when the mouse leaves the annotation rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseLeave As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseLeave = value

value = instance.MouseLeave
public PDFAction MouseLeave {get; set;}
public: __property PDFAction* get_MouseLeave();
public: __property void set_MouseLeave(
   PDFAction* value
);
public:
property PDFAction^ MouseLeave {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the mouse leaves the annotation rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

MouseUp Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : MouseUp Property
Gets or sets the action that is executed when the mouse is released in the annotation rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MouseUp As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseUp = value

value = instance.MouseUp
public PDFAction MouseUp {get; set;}
public: __property PDFAction* get_MouseUp();
public: __property void set_MouseUp(
   PDFAction* value
);
public:
property PDFAction^ MouseUp {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the mouse is released in the annotation rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Page Property (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Page Property
Gets the page that includes this annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PDFPage
'Usage

Dim instance As PDFAnnotation
Dim value As PDFPage

value = instance.Page
public PDFPage Page {get;}
public: __property PDFPage* get_Page();
public:
property PDFPage^ Page {
   PDFPage^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

PageClose Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : PageClose Property
Gets or sets the action to be performed when the page containing the annotation is closed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageClose As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageClose = value

value = instance.PageClose
public PDFAction PageClose {get; set;}
public: __property PDFAction* get_PageClose();
public: __property void set_PageClose(
   PDFAction* value
);
public:
property PDFAction^ PageClose {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page containing the annotation is closed.
Remarks
This action is executed before the page's Close action has been executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

PageHide Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : PageHide Property
Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageHide As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageHide = value

value = instance.PageHide
public PDFAction PageHide {get; set;}
public: __property PDFAction* get_PageHide();
public: __property void set_PageHide(
   PDFAction* value
);
public:
property PDFAction^ PageHide {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

PageOpen Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : PageOpen Property
Gets or sets the action to be performed when the page containing the annotation is opened.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageOpen As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageOpen = value

value = instance.PageOpen
public PDFAction PageOpen {get; set;}
public: __property PDFAction* get_PageOpen();
public: __property void set_PageOpen(
   PDFAction* value
);
public:
property PDFAction^ PageOpen {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page containing the annotation is opened.
Remarks
This action is executed after the page's Open action has been executed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

PageShow Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : PageShow Property
Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageShow As PDFAction
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageShow = value

value = instance.PageShow
public PDFAction PageShow {get; set;}
public: __property PDFAction* get_PageShow();
public: __property void set_PageShow(
   PDFAction* value
);
public:
property PDFAction^ PageShow {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

PDFRectangle Property (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public virtual PDFRectangle PDFRectangle {get; set;}
public: __property virtual PDFRectangle* get_PDFRectangle();
public: __property virtual void set_PDFRectangle(
   PDFRectangle* value
);
public:
virtual property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get();
   void set (    PDFRectangle^ value);
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Replies Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Replies Property
Gets the collection of replies to this annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Replies As PDFAnnotationReplyCollection
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAnnotationReplyCollection

value = instance.Replies
public PDFAnnotationReplyCollection Replies {get;}
public: __property PDFAnnotationReplyCollection* get_Replies();
public:
property PDFAnnotationReplyCollection^ Replies {
   PDFAnnotationReplyCollection^ get();
}

Property Value

The collection of replies to this annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Rotation Property (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public virtual PDFRotationMode Rotation {get; set;}
public: __property virtual PDFRotationMode get_Rotation();
public: __property virtual void set_Rotation(
   PDFRotationMode value
);
public:
virtual property PDFRotationMode Rotation {
   PDFRotationMode get();
   void set (    PDFRotationMode value);
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Tag Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Tag Property
Gets the annotation tag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tag As String
'Usage

Dim instance As PDFAnnotation
Dim value As String

instance.Tag = value

value = instance.Tag
public string Tag {get; set;}
public: __property string* get_Tag();
public: __property void set_Tag(
   string* value
);
public:
property String^ Tag {
   String^ get();
   void set (    String^ value);
}

Property Value

A string to store user defined data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%ItemTitle%%

Type Property (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : Type Property
Gets the annotation type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PDFAnnotationType
'Usage

Dim instance As PDFAnnotation
Dim value As PDFAnnotationType

value = instance.Type
public PDFAnnotationType Type {get;}
public: __property PDFAnnotationType get_Type();
public:
property PDFAnnotationType Type {
   PDFAnnotationType get();
}

Property Value

The annotation type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%% $$Events$$

PDFAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotation Class

For a list of all members of this type, see PDFAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

PropertyChanged Event (PDFAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotation Class : PropertyChanged Event
Gets or sets the event that is fired when a property has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As PDFAnnotation
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


%%PageItemTitle%%

PDFAnnotationAppearance Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationAppearance Class
Defines the base class for all annotation appearances.
Object Model
PDFAnnotationAppearance Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAnnotationAppearance
'Usage

Dim instance As PDFAnnotationAppearance
public class PDFAnnotationAppearance
public __gc class PDFAnnotationAppearance
public ref class PDFAnnotationAppearance
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDFView4NET.Annotations.PDFImageAppearance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationAppearance Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationAppearance Class Members
Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationAppearance Class

The following tables list the members exposed by PDFAnnotationAppearance.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFAnnotationAppearance Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Events$$

PDFAnnotationAppearance Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationAppearance Class

For a list of all members of this type, see PDFAnnotationAppearance members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFAnnotationAppearance Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

PropertyChanged Event (PDFAnnotationAppearance)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotationAppearance Class : PropertyChanged Event
Gets or sets the event that is fired when a property has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As PDFAnnotationAppearance
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationAppearance Class
PDFAnnotationAppearance Members


%%PageItemTitle%%

PDFAnnotationBorder Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationBorder Class
Defines the border of an annotation.
Object Model
PDFAnnotationBorder Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFAnnotationBorder
'Usage

Dim instance As PDFAnnotationBorder
[Serializable()]
public class PDFAnnotationBorder
[Serializable()]
public __gc class PDFAnnotationBorder
[Serializable()]
public ref class PDFAnnotationBorder
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotationBorder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationBorder Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationBorder Class

The following tables list the members exposed by PDFAnnotationBorder.

Public Constructors
 | Name | Description
Public Constructor | PDFAnnotationBorder Constructor | Initializes a new PDFAnnotationBorder object.
Top
Public Properties
 | Name | Description
Public Property | Width | Gets or sets the border width.
Top
Public Methods
 | Name | Description
Public Method | GetObjectData | Serializes the object content.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFAnnotationBorder Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotationBorder Class : PDFAnnotationBorder Constructor
Initializes a new PDFAnnotationBorder object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFAnnotationBorder()
public PDFAnnotationBorder()
public: PDFAnnotationBorder();
public:
PDFAnnotationBorder();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%% $$Methods$$

PDFAnnotationBorder Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationBorder Class

For a list of all members of this type, see PDFAnnotationBorder members.

Public Methods
 | Name | Description
Public Method | GetObjectData | Serializes the object content.
Top
See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFAnnotationBorder)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotationBorder Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFAnnotationBorder
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%% $$Properties$$

PDFAnnotationBorder Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationBorder Class

For a list of all members of this type, see PDFAnnotationBorder members.

Public Properties
 | Name | Description
Public Property | Width | Gets or sets the border width.
Top
See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Width Property (PDFAnnotationBorder)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotationBorder Class : Width Property
Gets or sets the border width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PDFAnnotationBorder
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public: __property double get_Width();
public: __property void set_Width(
   double value
);
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the border.
Remarks
0 means no border is displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%% $$Events$$

PDFAnnotationBorder Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationBorder Class

For a list of all members of this type, see PDFAnnotationBorder members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed.
Top
See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

PropertyChanged Event (PDFAnnotationBorder)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotationBorder Class : PropertyChanged Event
Gets or sets the event that is fired when a property has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As PDFAnnotationBorder
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public: __event PropertyChangedEventHandler* PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%%

PDFAnnotationCollection Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationCollection Class
Defines a collection of annotations.
Object Model
PDFAnnotationCollection ClassPDFAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAnnotationCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFAnnotation,PDFPage)
'Usage

Dim instance As PDFAnnotationCollection
public class PDFAnnotationCollection : O2S.Components.PDFView4NET.PDFCollection<PDFAnnotation,PDFPage>
public __gc class PDFAnnotationCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFAnnotation,PDFPage>
public ref class PDFAnnotationCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFAnnotation,PDFPage>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Annotations.PDFAnnotationCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationCollection Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationCollection Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationCollection Class

The following tables list the members exposed by PDFAnnotationCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | FindByID | Searches the collection for the annotation with a specific ID.
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | MoveItem | Overridden. Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top
Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFAnnotationCollection Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationCollection Class

For a list of all members of this type, see PDFAnnotationCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | FindByID | Searches the collection for the annotation with a specific ID.
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | MoveItem | Overridden. Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top
See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

FindByID Method

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotationCollection Class : FindByID Method
ID of the annotation to look for.
Searches the collection for the annotation with a specific ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function FindByID( _
   ByVal id As String _
) As PDFAnnotation
'Usage

Dim instance As PDFAnnotationCollection
Dim id As String
Dim value As PDFAnnotation

value = instance.FindByID(id)
public PDFAnnotation FindByID(
   string id
)
public: PDFAnnotation* FindByID(
   string* id
)
public:
PDFAnnotation^ FindByID(
   String^ id
)

Parameters

id
ID of the annotation to look for.

Return Value

Annotation with given id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationCollection Class
PDFAnnotationCollection Members


%%ItemTitle%%

MoveItem Method (PDFAnnotationCollection)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotationCollection Class : MoveItem Method
Item to move.
Number of positions to move.
Moves the item up or down to the beginning or end of the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function MoveItem( _
   ByVal item As PDFAnnotation, _
   ByVal step As Integer _
) As Boolean
'Usage

Dim instance As PDFAnnotationCollection
Dim item As PDFAnnotation
Dim step As Integer
Dim value As Boolean

value = instance.MoveItem(item, step)
public override bool MoveItem(
   PDFAnnotation item,
   int step
)
public: bool MoveItem(
   PDFAnnotation* item,
   int step
) override
public:
bool MoveItem(
   PDFAnnotation^ item,
   int step
) override

Parameters

item
Item to move.
step
Number of positions to move.

Return Value

True if the item has been moved.
Remarks
It the new position is outside the collection, the item is not moved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationCollection Class
PDFAnnotationCollection Members


%%PageItemTitle%% $$Events$$

PDFAnnotationCollection Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationCollection Class

For a list of all members of this type, see PDFAnnotationCollection members.

Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

CollectionChanged Event (PDFAnnotationCollection)

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotationCollection Class : CollectionChanged Event
Gets or sets the event being fired when the collection has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event CollectionChanged As EventHandler(Of PDFCollectionChangedEventArgs(Of PDFAnnotation))
'Usage

Dim instance As PDFAnnotationCollection
Dim handler As EventHandler(Of PDFCollectionChangedEventArgs(Of PDFAnnotation))

AddHandler instance.CollectionChanged, handler
public event EventHandler<PDFCollectionChangedEventArgs<PDFAnnotation>> CollectionChanged
public: __event EventHandler<PDFCollectionChangedEventArgs<PDFAnnotation*>*>* CollectionChanged
public:
event EventHandler<PDFCollectionChangedEventArgs<PDFAnnotation^>^>^ CollectionChanged
Event Data

The event handler receives an argument of type PDFCollectionChangedEventArgs<T> containing data related to this event. The following PDFCollectionChangedEventArgs<T> properties provide information specific to this event.

Property | Description
ChangedProperty | Gets the name of changed property when the change type is item update.
ChangeType | Gets the type of change event.
NewItem | Gets the new item involved in the operation.
OldItem | Gets the old item involved in the operation.
Position | Gets the position of the affected item in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationCollection Class
PDFAnnotationCollection Members


%%PageItemTitle%%

PDFAnnotationReplyCollection Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationReplyCollection Class
Defines a collection of annotations.
Object Model
PDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFAnnotationReplyCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFMarkupAnnotation,PDFAnnotation)
'Usage

Dim instance As PDFAnnotationReplyCollection
public class PDFAnnotationReplyCollection : O2S.Components.PDFView4NET.PDFCollection<PDFMarkupAnnotation,PDFAnnotation>
public __gc class PDFAnnotationReplyCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFMarkupAnnotation,PDFAnnotation>
public ref class PDFAnnotationReplyCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFMarkupAnnotation,PDFAnnotation>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Annotations.PDFAnnotationReplyCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationReplyCollection Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFAnnotationReplyCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationReplyCollection Class

The following tables list the members exposed by PDFAnnotationReplyCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFMarkupAnnotation,PDFAnnotation>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Top
See Also

Reference

PDFAnnotationReplyCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFBarcodeAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFBarcodeAnnotation Class
Defines a barcode annotation.
Object Model
PDFBarcodeAnnotation ClassPDFAnnotationAppearance ClassPDFBarcode ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFBarcodeAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFBarcodeAnnotation
[Serializable()]
public class PDFBarcodeAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFBarcodeAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFBarcodeAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFBarcodeAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcodeAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFBarcodeAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFBarcodeAnnotation Class

The following tables list the members exposed by PDFBarcodeAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFBarcodeAnnotation Constructor | Initializes a new PDFBarcodeAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Barcode | Gets or sets the barcode.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFBarcodeAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFBarcodeAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFBarcodeAnnotation Class : PDFBarcodeAnnotation Constructor
Initializes a new PDFBarcodeAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFBarcodeAnnotation()
public PDFBarcodeAnnotation()
public: PDFBarcodeAnnotation();
public:
PDFBarcodeAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcodeAnnotation Class
PDFBarcodeAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFBarcodeAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFBarcodeAnnotation Class

For a list of all members of this type, see PDFBarcodeAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFBarcodeAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFBarcodeAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFBarcodeAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFBarcodeAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcodeAnnotation Class
PDFBarcodeAnnotation Members


%%ItemTitle%%

PrepareForCopyPaste Method (PDFBarcodeAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFBarcodeAnnotation Class : PrepareForCopyPaste Method
Prepares the annotation for a copy/paste operation in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub PrepareForCopyPaste()
'Usage

Dim instance As PDFBarcodeAnnotation

instance.PrepareForCopyPaste()
public override void PrepareForCopyPaste()
public: void PrepareForCopyPaste(); override
public:
void PrepareForCopyPaste(); override
Remarks
The method builds internal structures so when the annotation is pasted it appears exactly in the same visual position on the new page, no matter the page rotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcodeAnnotation Class
PDFBarcodeAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFBarcodeAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFBarcodeAnnotation Class

For a list of all members of this type, see PDFBarcodeAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Barcode | Gets or sets the barcode.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFBarcodeAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Appearance Property (PDFBarcodeAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFBarcodeAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFBarcodeAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcodeAnnotation Class
PDFBarcodeAnnotation Members


%%ItemTitle%%

Barcode Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFBarcodeAnnotation Class : Barcode Property
Gets or sets the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Barcode As PDFBarcode
'Usage

Dim instance As PDFBarcodeAnnotation
Dim value As PDFBarcode

instance.Barcode = value

value = instance.Barcode
public PDFBarcode Barcode {get; set;}
public: __property PDFBarcode* get_Barcode();
public: __property void set_Barcode(
   PDFBarcode* value
);
public:
property PDFBarcode^ Barcode {
   PDFBarcode^ get();
   void set (    PDFBarcode^ value);
}

Property Value

The barcode that will be displayed on the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcodeAnnotation Class
PDFBarcodeAnnotation Members


%%ItemTitle%%

PDFRectangle Property (PDFBarcodeAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFBarcodeAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFBarcodeAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcodeAnnotation Class
PDFBarcodeAnnotation Members


%%ItemTitle%%

Rotation Property (PDFBarcodeAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFBarcodeAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFBarcodeAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcodeAnnotation Class
PDFBarcodeAnnotation Members


%%PageItemTitle%%

PDFEllipseAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFEllipseAnnotation Class
Defines an ellipse (Circle) annotation.
Object Model
PDFEllipseAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFRgbColor ClassPDFAnnotation ClassPDFRgbColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFEllipseAnnotation
   Inherits PDFSCAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFEllipseAnnotation
[Serializable()]
public class PDFEllipseAnnotation : PDFSCAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFEllipseAnnotation : public PDFSCAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFEllipseAnnotation : public PDFSCAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation
O2S.Components.PDFView4NET.Annotations.PDFEllipseAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEllipseAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFEllipseAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFEllipseAnnotation Class

The following tables list the members exposed by PDFEllipseAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFEllipseAnnotation Constructor | Initializes a new PDFEllipseAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | BorderWidth | Gets or sets the border width. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | HatchColor | Gets or sets the annotation's hatch color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | HatchType | Gets or sets the type of the hatched filling. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | HatchWidth | Gets or sets the annotation's hatch color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFEllipseAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFEllipseAnnotation Class : PDFEllipseAnnotation Constructor
Initializes a new PDFEllipseAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFEllipseAnnotation()
public PDFEllipseAnnotation()
public: PDFEllipseAnnotation();
public:
PDFEllipseAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEllipseAnnotation Class
PDFEllipseAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFEllipseAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFEllipseAnnotation Class

For a list of all members of this type, see PDFEllipseAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFEllipseAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFEllipseAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFEllipseAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEllipseAnnotation Class
PDFEllipseAnnotation Members


%%PageItemTitle%%

PDFFileAttachmentAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class
Defines a file attachment annotation.
Object Model
PDFFileAttachmentAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFFileAttachmentAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFFileAttachmentAnnotation
[Serializable()]
public class PDFFileAttachmentAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFFileAttachmentAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFFileAttachmentAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFFileAttachmentAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFFileAttachmentAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

The following tables list the members exposed by PDFFileAttachmentAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFFileAttachmentAnnotation Constructor | Initializes a new PDFFileAttachmentAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Data | Gets or sets the data stored in the file attachment annotation.
Public Property | Description | Gets or sets the file description.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | FileName | Gets or sets the file name.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Overridden. Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Size | Gets the file size.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Save | Overloaded. Saves the content of the embedded file to the specified file.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFFileAttachmentAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : PDFFileAttachmentAnnotation Constructor
Initializes a new PDFFileAttachmentAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFileAttachmentAnnotation()
public PDFFileAttachmentAnnotation()
public: PDFFileAttachmentAnnotation();
public:
PDFFileAttachmentAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFFileAttachmentAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

For a list of all members of this type, see PDFFileAttachmentAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Save | Overloaded. Saves the content of the embedded file to the specified file.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

Save Method (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Save Method
Saves the content of the embedded file to the specified file.
Overload List
Overload | Description
Save(String) | Saves the content of the embedded file to the specified file.
Save(Stream) | Saves the content of the embedded file to the specified stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

Save(String) Method

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > Save Method : Save(String) Method
Physical path where the embedded file should be saved.
Saves the content of the embedded file to the specified file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As String _
)
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim fileName As String

instance.Save(fileName)
public void Save(
   string fileName
)
public: void Save(
   string* fileName
)
public:
void Save(
   String^ fileName
)

Parameters

fileName
Physical path where the embedded file should be saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


%%ItemTitle%%

Save(Stream) Method

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > Save Method : Save(Stream) Method
Stream where the embedded file should be saved.
Saves the content of the embedded file to the specified stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim stream As Stream

instance.Save(stream)
public void Save(
   Stream stream
)
public: void Save(
   Stream* stream
)
public:
void Save(
   Stream^ stream
)

Parameters

stream
Stream where the embedded file should be saved.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFileAttachmentAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

For a list of all members of this type, see PDFFileAttachmentAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Data | Gets or sets the data stored in the file attachment annotation.
Public Property | Description | Gets or sets the file description.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | FileName | Gets or sets the file name.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Overridden. Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Size | Gets the file size.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Appearance Property (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the text annotation icon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

Data Property (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Data Property
Gets or sets the data stored in the file attachment annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Data As Byte()
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value() As Byte

instance.Data = value

value = instance.Data
public byte[] Data {get; set;}
public: __property byte[]* get_Data();
public: __property void set_Data(
   byte[]* value
);
public:
property array<byte>^ Data {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The content of the file attachment annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

Description Property (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Description Property
Gets or sets the file description.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

The description of the file stored in the attachment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

FileName Property (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : FileName Property
Gets or sets the file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the file whose content is stored in Data property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

Icon Property (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Icon Property
Gets or sets the annotation icon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Icon As PDFFileAttachmentAnnotationIcon
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As PDFFileAttachmentAnnotationIcon

instance.Icon = value

value = instance.Icon
public PDFFileAttachmentAnnotationIcon Icon {get; set;}
public: __property PDFFileAttachmentAnnotationIcon get_Icon();
public: __property void set_Icon(
   PDFFileAttachmentAnnotationIcon value
);
public:
property PDFFileAttachmentAnnotationIcon Icon {
   PDFFileAttachmentAnnotationIcon get();
   void set (    PDFFileAttachmentAnnotationIcon value);
}

Property Value

The icon to be displayed for the annotation.
Remarks
If the Icon property to any of the PDFFileAttachmentAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFFileAttachmentAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFFileAttachmentAnnotationIcon.Custom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

IconName Property (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : IconName Property
Gets or sets the icon name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IconName As String
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
public string IconName {get; set;}
public: __property string* get_IconName();
public: __property void set_IconName(
   string* value
);
public:
property String^ IconName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the stamp's icon.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
This property lets you set a custom name for your user defined icon appearances.
If the Icon property to any of the PDFFileAttachmentAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFFileAttachmentAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFFileAttachmentAnnotationIcon.Custom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

Opacity Property (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Opacity Property
Gets or sets the annotation opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Opacity As Double
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public override double Opacity {get; set;}
public: __property double get_Opacity() override;
public: __property void set_Opacity(
   double value
) override;
public:
property double Opacity {
   double get() override;
   void set (    double value) override;
}

Property Value

The opacity of the annotation in percents.
Remarks
100 means total opacity, 0 means fully transparent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

Rotation Property (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%ItemTitle%%

Size Property (PDFFileAttachmentAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Size Property
Gets the file size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Size As Integer
'Usage

Dim instance As PDFFileAttachmentAnnotation
Dim value As Integer

value = instance.Size
public int Size {get;}
public: __property int get_Size();
public:
property int Size {
   int get();
}

Property Value

The size of the file stored in Data property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%%

PDFFreeTextAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFFreeTextAnnotation Class
Defines a free text annotations.
Object Model
PDFFreeTextAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFRgbColor ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFRgbColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFFreeTextAnnotation
   Inherits PDFAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFFreeTextAnnotation
[Serializable()]
public class PDFFreeTextAnnotation : PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFFreeTextAnnotation : public PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFFreeTextAnnotation : public PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFFreeTextAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFFreeTextAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFFreeTextAnnotation Class

The following tables list the members exposed by PDFFreeTextAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFFreeTextAnnotation Constructor | Initializes a new PDFFreeTextAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFFreeTextAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : PDFFreeTextAnnotation Constructor
Initializes a new PDFFreeTextAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFreeTextAnnotation()
public PDFFreeTextAnnotation()
public: PDFFreeTextAnnotation();
public:
PDFFreeTextAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFFreeTextAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFFreeTextAnnotation Class

For a list of all members of this type, see PDFFreeTextAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFFreeTextAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFFreeTextAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFFreeTextAnnotation Class

For a list of all members of this type, see PDFFreeTextAnnotation members.

Public Properties
 | Name | Description
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Align Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Align Property
Gets or sets the text alignment in a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Align As PDFFieldTextAlign
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFFieldTextAlign

instance.Align = value

value = instance.Align
public PDFFieldTextAlign Align {get; set;}
public: __property PDFFieldTextAlign get_Align();
public: __property void set_Align(
   PDFFieldTextAlign value
);
public:
property PDFFieldTextAlign Align {
   PDFFieldTextAlign get();
   void set (    PDFFieldTextAlign value);
}

Property Value

A O2S.Components.PDFView4NET.Forms.PDFFieldTextAlign enumeration member specifying the text alignment in a field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%ItemTitle%%

Author Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Author Property
Gets or sets the annotation author.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the person who created the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%ItemTitle%%

BorderColor Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : BorderColor Property
Gets or sets the widget's border color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderColor As PDFDeviceColor
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFDeviceColor

instance.BorderColor = value

value = instance.BorderColor
public PDFDeviceColor BorderColor {get; set;}
public: __property PDFDeviceColor* get_BorderColor();
public: __property void set_BorderColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ BorderColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The color of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%ItemTitle%%

BorderStyle Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : BorderStyle Property
Gets or sets the widget's border style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderStyle As PDFBorderStyle
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFBorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public PDFBorderStyle BorderStyle {get; set;}
public: __property PDFBorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   PDFBorderStyle value
);
public:
property PDFBorderStyle BorderStyle {
   PDFBorderStyle get();
   void set (    PDFBorderStyle value);
}

Property Value

The style of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%ItemTitle%%

BorderWidth Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : BorderWidth Property
Gets or sets the widget's border width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public: __property double get_BorderWidth();
public: __property void set_BorderWidth(
   double value
);
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%ItemTitle%%

Contents Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Contents Property
Gets or sets the annotation contents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Contents As String
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
public override string Contents {get; set;}
public: __property string* get_Contents() override;
public: __property void set_Contents(
   string* value
) override;
public:
property String^ Contents {
   String^ get() override;
   void set (    String^ value) override;
}

Property Value

The text to be displayed for the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%ItemTitle%%

Font Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Font Property
Gets or sets the font used to display the widget text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Font As PDFFontBase
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
public PDFFontBase Font {get; set;}
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (    PDFFontBase^ value);
}

Property Value

The font used for displaying the widget content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%ItemTitle%%

PDFRectangle Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%ItemTitle%%

Subject Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Subject Property
Gets or sets the annotation subject.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Subject As String
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
public string Subject {get; set;}
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
public:
property String^ Subject {
   String^ get();
   void set (    String^ value);
}

Property Value

The subject of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%ItemTitle%%

TextColor Property (PDFFreeTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : TextColor Property
Gets or sets the text color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As PDFRgbColor
'Usage

Dim instance As PDFFreeTextAnnotation
Dim value As PDFRgbColor

instance.TextColor = value

value = instance.TextColor
public PDFRgbColor TextColor {get; set;}
public: __property PDFRgbColor* get_TextColor();
public: __property void set_TextColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ TextColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The color of the annotation's text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%%

PDFHighlightAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFHighlightAnnotation Class
Defines a highlight annotation.
Object Model
PDFHighlightAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFHighlightAnnotation
   Inherits PDFTextMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFHighlightAnnotation
[Serializable()]
public class PDFHighlightAnnotation : PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFHighlightAnnotation : public PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFHighlightAnnotation : public PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This annotation is used to highlight text in a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFHighlightAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHighlightAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFHighlightAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFHighlightAnnotation Class

The following tables list the members exposed by PDFHighlightAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFHighlightAnnotation Constructor | Initializes a new PDFHighlightAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFHighlightAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFHighlightAnnotation Class : PDFHighlightAnnotation Constructor
Initializes a new PDFHighlightAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFHighlightAnnotation()
public PDFHighlightAnnotation()
public: PDFHighlightAnnotation();
public:
PDFHighlightAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHighlightAnnotation Class
PDFHighlightAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFHighlightAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFHighlightAnnotation Class

For a list of all members of this type, see PDFHighlightAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFHighlightAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFHighlightAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFHighlightAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHighlightAnnotation Class
PDFHighlightAnnotation Members


%%PageItemTitle%%

PDFImageAppearance Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFImageAppearance Class
Defines an annotation appearance that consists of an image.
Object Model
PDFImageAppearance Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFImageAppearance
   Inherits PDFAnnotationAppearance
'Usage

Dim instance As PDFImageAppearance
public class PDFImageAppearance : PDFAnnotationAppearance
public __gc class PDFImageAppearance : public PDFAnnotationAppearance
public ref class PDFImageAppearance : public PDFAnnotationAppearance
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDFView4NET.Annotations.PDFImageAppearance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageAppearance Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFImageAppearance Class Members
Properties Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFImageAppearance Class

The following tables list the members exposed by PDFImageAppearance.

Public Constructors
 | Name | Description
Public Constructor | PDFImageAppearance Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Image | Gets or sets the image that represents the appearance.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotationAppearance)
Top
See Also

Reference

PDFImageAppearance Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFImageAppearance Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFImageAppearance Class : PDFImageAppearance Constructor
Overload List
Overload | Description
PDFImageAppearance Constructor() | Initializes a new PDFImageAppearance object.
PDFImageAppearance Constructor(Bitmap) | Initializes a new PDFImageAppearance object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageAppearance Class
PDFImageAppearance Members


%%PageItemTitle%%

PDFImageAppearance Constructor()

O2S.Components.PDFView4NET.Annotations Namespace > PDFImageAppearance Class > PDFImageAppearance Constructor : PDFImageAppearance Constructor()
Initializes a new PDFImageAppearance object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFImageAppearance()
public PDFImageAppearance()
public: PDFImageAppearance();
public:
PDFImageAppearance();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageAppearance Class
PDFImageAppearance Members
Overload List


%%PageItemTitle%%

PDFImageAppearance Constructor(Bitmap)

O2S.Components.PDFView4NET.Annotations Namespace > PDFImageAppearance Class > PDFImageAppearance Constructor : PDFImageAppearance Constructor(Bitmap)
The image used for creating the appearance.
Initializes a new PDFImageAppearance object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As Bitmap _
)
'Usage

Dim image As Bitmap

Dim instance As New PDFImageAppearance(image)
public PDFImageAppearance(
   Bitmap image
)
public: PDFImageAppearance(
   Bitmap* image
)
public:
PDFImageAppearance(
   Bitmap^ image
)

Parameters

image
The image used for creating the appearance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageAppearance Class
PDFImageAppearance Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFImageAppearance Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFImageAppearance Class

For a list of all members of this type, see PDFImageAppearance members.

Public Properties
 | Name | Description
Public Property | Image | Gets or sets the image that represents the appearance.
Top
See Also

Reference

PDFImageAppearance Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Image Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFImageAppearance Class : Image Property
Gets or sets the image that represents the appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Image As Bitmap
'Usage

Dim instance As PDFImageAppearance
Dim value As Bitmap

instance.Image = value

value = instance.Image
public Bitmap Image {get; set;}
public: __property Bitmap* get_Image();
public: __property void set_Image(
   Bitmap* value
);
public:
property Bitmap^ Image {
   Bitmap^ get();
   void set (    Bitmap^ value);
}

Property Value

A System.Drawing.Bitmap object specifying the image used for creating the appearance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFImageAppearance Class
PDFImageAppearance Members


%%PageItemTitle%%

PDFInkAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFInkAnnotation Class
Defines an ink annotation.
Object Model
PDFInkAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPointsCollection ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFInkAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFInkAnnotation
[Serializable()]
public class PDFInkAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFInkAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFInkAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFInkAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFInkAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFInkAnnotation Class

The following tables list the members exposed by PDFInkAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFInkAnnotation Constructor | Initializes a new PDFInkAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayPoints | Gets the annotation points in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InkWidth | Gets or sets the widget's border width.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Points | Gets the annotation points.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFInkAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFInkAnnotation Class : PDFInkAnnotation Constructor
Initializes a new PDFInkAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFInkAnnotation()
public PDFInkAnnotation()
public: PDFInkAnnotation();
public:
PDFInkAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFInkAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFInkAnnotation Class

For a list of all members of this type, see PDFInkAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFInkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFInkAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFInkAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%ItemTitle%%

PrepareForCopyPaste Method (PDFInkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFInkAnnotation Class : PrepareForCopyPaste Method
Prepares the annotation for a copy/paste operation in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub PrepareForCopyPaste()
'Usage

Dim instance As PDFInkAnnotation

instance.PrepareForCopyPaste()
public override void PrepareForCopyPaste()
public: void PrepareForCopyPaste(); override
public:
void PrepareForCopyPaste(); override
Remarks
The method builds internal structures so when the annotation is pasted it appears exactly in the same visual position on the new page, no matter the page rotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFInkAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFInkAnnotation Class

For a list of all members of this type, see PDFInkAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayPoints | Gets the annotation points in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InkWidth | Gets or sets the widget's border width.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Points | Gets the annotation points.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

DisplayPoints Property (PDFInkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFInkAnnotation Class : DisplayPoints Property
Gets the annotation points in display coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayPoints As PDFPoint()
'Usage

Dim instance As PDFInkAnnotation
Dim value() As PDFPoint

instance.DisplayPoints = value

value = instance.DisplayPoints
public PDFPoint[] DisplayPoints {get; set;}
public: __property PDFPoint*[]* get_DisplayPoints();
public: __property void set_DisplayPoints(
   PDFPoint*[]* value
);
public:
property array<PDFPoint^>^ DisplayPoints {
   array<PDFPoint^>^ get();
   void set (    array<PDFPoint^>^ value);
}

Property Value

The list of points that create this annotation.
Remarks
The collection consists of at least one points array. Each points array includes 2*n values representing the coordinates of n points in the page coordinate space
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%ItemTitle%%

InkWidth Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFInkAnnotation Class : InkWidth Property
Gets or sets the widget's border width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InkWidth As Double
'Usage

Dim instance As PDFInkAnnotation
Dim value As Double

instance.InkWidth = value

value = instance.InkWidth
public double InkWidth {get; set;}
public: __property double get_InkWidth();
public: __property void set_InkWidth(
   double value
);
public:
property double InkWidth {
   double get();
   void set (    double value);
}

Property Value

The width of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%ItemTitle%%

Points Property (PDFInkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFInkAnnotation Class : Points Property
Gets the annotation points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Points As PDFPointsCollection
'Usage

Dim instance As PDFInkAnnotation
Dim value As PDFPointsCollection

value = instance.Points
public PDFPointsCollection Points {get;}
public: __property PDFPointsCollection* get_Points();
public:
property PDFPointsCollection^ Points {
   PDFPointsCollection^ get();
}

Property Value

The list of points that create this annotation.
Remarks
The collection consists of at least one points array. Each points array includes 2*n values representing the coordinates of n points in the page coordinate space
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%PageItemTitle%%

PDFLineAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFLineAnnotation Class
Defines a line annotation.
Object Model
PDFLineAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFRgbColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFLineAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFLineAnnotation
[Serializable()]
public class PDFLineAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFLineAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFLineAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFLineAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFLineAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFLineAnnotation Class

The following tables list the members exposed by PDFLineAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFLineAnnotation Constructor | Initializes a new PDFLineAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | BeginLineStyle | Gets or sets the style used for the beginning of the line.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayEndPoint | Gets the end point of the line in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayStartPoint | Gets the start point of the line in display coordinates.
Public Property | EndLineStyle | Gets or sets the style used for the end of the line.
Public Property | EndPoint | Gets the end point of the line.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | LineDirection | Gets or sets the direction of the line annotation.
Public Property | LineWidth | Gets or sets the line width.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | StartPoint | Gets the start point of the line in PDF coordinates.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | SetDisplayLinePoints | Sets the start and end position of the line.
Public Method | SetLinePoints | Sets the start and end position of the line.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFLineAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : PDFLineAnnotation Constructor
Initializes a new PDFLineAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLineAnnotation()
public PDFLineAnnotation()
public: PDFLineAnnotation();
public:
PDFLineAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFLineAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFLineAnnotation Class

For a list of all members of this type, see PDFLineAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | SetDisplayLinePoints | Sets the start and end position of the line.
Public Method | SetLinePoints | Sets the start and end position of the line.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFLineAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

PrepareForCopyPaste Method (PDFLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : PrepareForCopyPaste Method
Prepares the annotation for a copy/paste operation in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub PrepareForCopyPaste()
'Usage

Dim instance As PDFLineAnnotation

instance.PrepareForCopyPaste()
public override void PrepareForCopyPaste()
public: void PrepareForCopyPaste(); override
public:
void PrepareForCopyPaste(); override
Remarks
The method builds internal structures so when the annotation is pasted it appears exactly in the same visual position on the new page, no matter the page rotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

SetDisplayLinePoints Method

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : SetDisplayLinePoints Method
Start point of the line
End point of the line
Sets the start and end position of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetDisplayLinePoints( _
   ByVal startPoint As PDFPoint, _
   ByVal endPoint As PDFPoint _
)
'Usage

Dim instance As PDFLineAnnotation
Dim startPoint As PDFPoint
Dim endPoint As PDFPoint

instance.SetDisplayLinePoints(startPoint, endPoint)
public void SetDisplayLinePoints(
   PDFPoint startPoint,
   PDFPoint endPoint
)
public: void SetDisplayLinePoints(
   PDFPoint* startPoint,
   PDFPoint* endPoint
)
public:
void SetDisplayLinePoints(
   PDFPoint^ startPoint,
   PDFPoint^ endPoint
)

Parameters

startPoint
Start point of the line
endPoint
End point of the line
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

SetLinePoints Method (PDFLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : SetLinePoints Method
Start point of the measure
End point of the measure
Sets the start and end position of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetLinePoints( _
   ByVal startPoint As PDFPoint, _
   ByVal endPoint As PDFPoint _
)
'Usage

Dim instance As PDFLineAnnotation
Dim startPoint As PDFPoint
Dim endPoint As PDFPoint

instance.SetLinePoints(startPoint, endPoint)
public void SetLinePoints(
   PDFPoint startPoint,
   PDFPoint endPoint
)
public: void SetLinePoints(
   PDFPoint* startPoint,
   PDFPoint* endPoint
)
public:
void SetLinePoints(
   PDFPoint^ startPoint,
   PDFPoint^ endPoint
)

Parameters

startPoint
Start point of the measure
endPoint
End point of the measure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFLineAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFLineAnnotation Class

For a list of all members of this type, see PDFLineAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | BeginLineStyle | Gets or sets the style used for the beginning of the line.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayEndPoint | Gets the end point of the line in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayStartPoint | Gets the start point of the line in display coordinates.
Public Property | EndLineStyle | Gets or sets the style used for the end of the line.
Public Property | EndPoint | Gets the end point of the line.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | LineDirection | Gets or sets the direction of the line annotation.
Public Property | LineWidth | Gets or sets the line width.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | StartPoint | Gets the start point of the line in PDF coordinates.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

BeginLineStyle Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : BeginLineStyle Property
Gets or sets the style used for the beginning of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BeginLineStyle As PDFLineEndingStyle
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFLineEndingStyle

instance.BeginLineStyle = value

value = instance.BeginLineStyle
public PDFLineEndingStyle BeginLineStyle {get; set;}
public: __property PDFLineEndingStyle get_BeginLineStyle();
public: __property void set_BeginLineStyle(
   PDFLineEndingStyle value
);
public:
property PDFLineEndingStyle BeginLineStyle {
   PDFLineEndingStyle get();
   void set (    PDFLineEndingStyle value);
}

Property Value

A PDFLineEndingStyle enumeration member specifying the style for the beginning of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

DisplayEndPoint Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : DisplayEndPoint Property
Gets the end point of the line in display coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayEndPoint As PDFPoint
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFPoint

value = instance.DisplayEndPoint
public PDFPoint DisplayEndPoint {get;}
public: __property PDFPoint* get_DisplayEndPoint();
public:
property PDFPoint^ DisplayEndPoint {
   PDFPoint^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

DisplayStartPoint Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : DisplayStartPoint Property
Gets the start point of the line in display coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayStartPoint As PDFPoint
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFPoint

value = instance.DisplayStartPoint
public PDFPoint DisplayStartPoint {get;}
public: __property PDFPoint* get_DisplayStartPoint();
public:
property PDFPoint^ DisplayStartPoint {
   PDFPoint^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

EndLineStyle Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : EndLineStyle Property
Gets or sets the style used for the end of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EndLineStyle As PDFLineEndingStyle
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFLineEndingStyle

instance.EndLineStyle = value

value = instance.EndLineStyle
public PDFLineEndingStyle EndLineStyle {get; set;}
public: __property PDFLineEndingStyle get_EndLineStyle();
public: __property void set_EndLineStyle(
   PDFLineEndingStyle value
);
public:
property PDFLineEndingStyle EndLineStyle {
   PDFLineEndingStyle get();
   void set (    PDFLineEndingStyle value);
}

Property Value

A PDFLineEndingStyle enumeration member specifying the style for the end of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

EndPoint Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : EndPoint Property
Gets the end point of the line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property EndPoint As PDFPoint
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFPoint

value = instance.EndPoint
public PDFPoint EndPoint {get;}
public: __property PDFPoint* get_EndPoint();
public:
property PDFPoint^ EndPoint {
   PDFPoint^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

InteriorColor Property (PDFLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : InteriorColor Property
Gets or sets the annotation's interior color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteriorColor As PDFRgbColor
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFRgbColor

instance.InteriorColor = value

value = instance.InteriorColor
public PDFRgbColor InteriorColor {get; set;}
public: __property PDFRgbColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ InteriorColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The annotation interior color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

LineDirection Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : LineDirection Property
Gets or sets the direction of the line annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineDirection As PDFLineDirection
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFLineDirection

instance.LineDirection = value

value = instance.LineDirection
public PDFLineDirection LineDirection {get; set;}
public: __property PDFLineDirection get_LineDirection();
public: __property void set_LineDirection(
   PDFLineDirection value
);
public:
property PDFLineDirection LineDirection {
   PDFLineDirection get();
   void set (    PDFLineDirection value);
}

Property Value

A PDFLineDirection enumeration member specifying the direction of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

LineWidth Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : LineWidth Property
Gets or sets the line width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LineWidth As Double
'Usage

Dim instance As PDFLineAnnotation
Dim value As Double

instance.LineWidth = value

value = instance.LineWidth
public double LineWidth {get; set;}
public: __property double get_LineWidth();
public: __property void set_LineWidth(
   double value
);
public:
property double LineWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the line annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

PDFRectangle Property (PDFLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

Rotation Property (PDFLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%ItemTitle%%

StartPoint Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : StartPoint Property
Gets the start point of the line in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property StartPoint As PDFPoint
'Usage

Dim instance As PDFLineAnnotation
Dim value As PDFPoint

value = instance.StartPoint
public PDFPoint StartPoint {get;}
public: __property PDFPoint* get_StartPoint();
public:
property PDFPoint^ StartPoint {
   PDFPoint^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%%

PDFLinkAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFLinkAnnotation Class
Defines a link annotations.
Object Model
PDFLinkAnnotation ClassPDFAction ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFLinkAnnotation
   Inherits PDFAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFLinkAnnotation
[Serializable()]
public class PDFLinkAnnotation : PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFLinkAnnotation : public PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFLinkAnnotation : public PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFLinkAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFLinkAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFLinkAnnotation Class

The following tables list the members exposed by PDFLinkAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFLinkAnnotation Constructor | Initializes a new PDFLinkAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the link is clicked.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFLinkAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFLinkAnnotation Class : PDFLinkAnnotation Constructor
Initializes a new PDFLinkAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLinkAnnotation()
public PDFLinkAnnotation()
public: PDFLinkAnnotation();
public:
PDFLinkAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFLinkAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFLinkAnnotation Class

For a list of all members of this type, see PDFLinkAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFLinkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLinkAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFLinkAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFLinkAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFLinkAnnotation Class

For a list of all members of this type, see PDFLinkAnnotation members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the link is clicked.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Action Property (PDFLinkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLinkAnnotation Class : Action Property
Gets or sets the action to be executed when the link is clicked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Action As PDFAction
'Usage

Dim instance As PDFLinkAnnotation
Dim value As PDFAction

instance.Action = value

value = instance.Action
public PDFAction Action {get; set;}
public: __property PDFAction* get_Action();
public: __property void set_Action(
   PDFAction* value
);
public:
property PDFAction^ Action {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

Action to execute.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%ItemTitle%%

Appearance Property (PDFLinkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLinkAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFLinkAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the text annotation icon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%ItemTitle%%

Author Property (PDFLinkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLinkAnnotation Class : Author Property
Gets or sets the annotation author.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PDFLinkAnnotation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the person who created the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%ItemTitle%%

BorderWidth Property (PDFLinkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLinkAnnotation Class : BorderWidth Property
Gets or sets the border width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PDFLinkAnnotation
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public: __property double get_BorderWidth();
public: __property void set_BorderWidth(
   double value
);
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the annotation's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%ItemTitle%%

Rotation Property (PDFLinkAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFLinkAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFLinkAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%%

PDFMarkupAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFMarkupAnnotation Class
Defines the base class for all markup type annotations.
Object Model
PDFMarkupAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFMarkupAnnotation
   Inherits PDFAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFMarkupAnnotation
[Serializable()]
public class PDFMarkupAnnotation : PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFMarkupAnnotation : public PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFMarkupAnnotation : public PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFBarcodeAnnotation
O2S.Components.PDFView4NET.Annotations.PDFFileAttachmentAnnotation
O2S.Components.PDFView4NET.Annotations.PDFInkAnnotation
O2S.Components.PDFView4NET.Annotations.PDFLineAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMeasureAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolygonAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation
O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation
O2S.Components.PDFView4NET.Annotations.PDFStampAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMarkupAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFMarkupAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFMarkupAnnotation Class

The following tables list the members exposed by PDFMarkupAnnotation.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFMarkupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFMarkupAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFMarkupAnnotation Class

For a list of all members of this type, see PDFMarkupAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window.
Top
See Also

Reference

PDFMarkupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFMarkupAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMarkupAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFMarkupAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


%%ItemTitle%%

ShowPopup Method

O2S.Components.PDFView4NET.Annotations Namespace > PDFMarkupAnnotation Class : ShowPopup Method
True if the popup window should be displayed, false if it should be hidden.
Shows or hides the annotation popup window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ShowPopup( _
   ByVal showPopup As Boolean _
)
'Usage

Dim instance As PDFMarkupAnnotation
Dim showPopup As Boolean

instance.ShowPopup(showPopup)
public void ShowPopup(
   bool showPopup
)
public: void ShowPopup(
   bool showPopup
)
public:
void ShowPopup(
   bool showPopup
)

Parameters

showPopup
True if the popup window should be displayed, false if it should be hidden.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFMarkupAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFMarkupAnnotation Class

For a list of all members of this type, see PDFMarkupAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFMarkupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Author Property (PDFMarkupAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMarkupAnnotation Class : Author Property
Gets or sets the annotation author.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PDFMarkupAnnotation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the person who created the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


%%ItemTitle%%

InReplyTo Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFMarkupAnnotation Class : InReplyTo Property
Gets or sets the annotation that this annotation is "in reply to".
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InReplyTo As PDFAnnotation
'Usage

Dim instance As PDFMarkupAnnotation
Dim value As PDFAnnotation

instance.InReplyTo = value

value = instance.InReplyTo
public PDFAnnotation InReplyTo {get; set;}
public: __property PDFAnnotation* get_InReplyTo();
public: __property void set_InReplyTo(
   PDFAnnotation* value
);
public:
property PDFAnnotation^ InReplyTo {
   PDFAnnotation^ get();
   void set (    PDFAnnotation^ value);
}

Property Value

The parent annotation that this annotation is "in reply to".
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


%%ItemTitle%%

Opacity Property (PDFMarkupAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMarkupAnnotation Class : Opacity Property
Gets or sets the annotation opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Opacity As Double
'Usage

Dim instance As PDFMarkupAnnotation
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public virtual double Opacity {get; set;}
public: __property virtual double get_Opacity();
public: __property virtual void set_Opacity(
   double value
);
public:
virtual property double Opacity {
   double get();
   void set (    double value);
}

Property Value

The opacity of the annotation in percents.
Remarks
100 means total opacity, 0 means fully transparent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


%%ItemTitle%%

Subject Property (PDFMarkupAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMarkupAnnotation Class : Subject Property
Gets or sets the annotation subject.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Subject As String
'Usage

Dim instance As PDFMarkupAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
public string Subject {get; set;}
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
public:
property String^ Subject {
   String^ get();
   void set (    String^ value);
}

Property Value

The subject of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


%%PageItemTitle%%

PDFMeasureAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFMeasureAnnotation Class
Defines a measure annotation.
Object Model
PDFMeasureAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFRgbColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFMeasureAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFMeasureAnnotation
[Serializable()]
public class PDFMeasureAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFMeasureAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFMeasureAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMeasureAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFMeasureAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFMeasureAnnotation Class

The following tables list the members exposed by PDFMeasureAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFMeasureAnnotation Constructor | Initializes a new PDFMeasureAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | ScaleAndUnit | Gets or sets the scale and unit a point in the PDF file corresponds to.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | SetLinePoints | Sets the start and end position of the measure line.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFMeasureAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFMeasureAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFMeasureAnnotation Class : PDFMeasureAnnotation Constructor
Initializes a new PDFMeasureAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMeasureAnnotation()
public PDFMeasureAnnotation()
public: PDFMeasureAnnotation();
public:
PDFMeasureAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Class
PDFMeasureAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFMeasureAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFMeasureAnnotation Class

For a list of all members of this type, see PDFMeasureAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | SetLinePoints | Sets the start and end position of the measure line.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFMeasureAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFMeasureAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMeasureAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFMeasureAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Class
PDFMeasureAnnotation Members


%%ItemTitle%%

SetLinePoints Method (PDFMeasureAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMeasureAnnotation Class : SetLinePoints Method
Start point of the measure
End point of the measure
Sets the start and end position of the measure line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetLinePoints( _
   ByVal startPoint As PDFPoint, _
   ByVal endPoint As PDFPoint _
)
'Usage

Dim instance As PDFMeasureAnnotation
Dim startPoint As PDFPoint
Dim endPoint As PDFPoint

instance.SetLinePoints(startPoint, endPoint)
public void SetLinePoints(
   PDFPoint startPoint,
   PDFPoint endPoint
)
public: void SetLinePoints(
   PDFPoint* startPoint,
   PDFPoint* endPoint
)
public:
void SetLinePoints(
   PDFPoint^ startPoint,
   PDFPoint^ endPoint
)

Parameters

startPoint
Start point of the measure
endPoint
End point of the measure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Class
PDFMeasureAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFMeasureAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFMeasureAnnotation Class

For a list of all members of this type, see PDFMeasureAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | ScaleAndUnit | Gets or sets the scale and unit a point in the PDF file corresponds to.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFMeasureAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Contents Property (PDFMeasureAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMeasureAnnotation Class : Contents Property
Gets or sets the annotation contents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Contents As String
'Usage

Dim instance As PDFMeasureAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
public override string Contents {get; set;}
public: __property string* get_Contents() override;
public: __property void set_Contents(
   string* value
) override;
public:
property String^ Contents {
   String^ get() override;
   void set (    String^ value) override;
}

Property Value

The text to be displayed for the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Class
PDFMeasureAnnotation Members


%%ItemTitle%%

InteriorColor Property (PDFMeasureAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMeasureAnnotation Class : InteriorColor Property
Gets or sets the annotation's interior color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteriorColor As PDFRgbColor
'Usage

Dim instance As PDFMeasureAnnotation
Dim value As PDFRgbColor

instance.InteriorColor = value

value = instance.InteriorColor
public PDFRgbColor InteriorColor {get; set;}
public: __property PDFRgbColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ InteriorColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The annotation interior color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Class
PDFMeasureAnnotation Members


%%ItemTitle%%

PDFRectangle Property (PDFMeasureAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMeasureAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFMeasureAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Class
PDFMeasureAnnotation Members


%%ItemTitle%%

Rotation Property (PDFMeasureAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMeasureAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFMeasureAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Class
PDFMeasureAnnotation Members


%%ItemTitle%%

ScaleAndUnit Property (PDFMeasureAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFMeasureAnnotation Class : ScaleAndUnit Property
Gets or sets the scale and unit a point in the PDF file corresponds to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScaleAndUnit As String
'Usage

Dim instance As PDFMeasureAnnotation
Dim value As String

instance.ScaleAndUnit = value

value = instance.ScaleAndUnit
public string ScaleAndUnit {get; set;}
public: __property string* get_ScaleAndUnit();
public: __property void set_ScaleAndUnit(
   string* value
);
public:
property String^ ScaleAndUnit {
   String^ get();
   void set (    String^ value);
}

Property Value

The real word unit and scale a point in the PDF file corresponds to.
Remarks
The format of this property is "scale unit = scale unit", such as "1 pt = 10 ft" meaning that 1 point corresponds to 10 feet. Supported units are "mm" (millimeter), "cm" (centimeter), "m" (meter), "km" (kilometer), "pt" (point), "in" (inch), "ft" (foot) and "mi" (mile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Class
PDFMeasureAnnotation Members


%%PageItemTitle%%

PDFPointsCollection Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFPointsCollection Class
Defines a collection of array the store points on the page.
Object Model
PDFPointsCollection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPointsCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of Double(),PDFAnnotation)
'Usage

Dim instance As PDFPointsCollection
public class PDFPointsCollection : O2S.Components.PDFView4NET.PDFCollection<double[],PDFAnnotation>
public __gc class PDFPointsCollection : public O2S.Components.PDFView4NET.PDFCollection<double[],PDFAnnotation>
public ref class PDFPointsCollection : public O2S.Components.PDFView4NET.PDFCollection<array<double>,PDFAnnotation>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Annotations.PDFPointsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointsCollection Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFPointsCollection Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPointsCollection Class

The following tables list the members exposed by PDFPointsCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<double[],PDFAnnotation>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Top
Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFPointsCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Events$$

PDFPointsCollection Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPointsCollection Class

For a list of all members of this type, see PDFPointsCollection members.

Public Events
 | Name | Description
Public Event | CollectionChanged | Gets or sets the event being fired when the collection has changed.
Top
See Also

Reference

PDFPointsCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

CollectionChanged Event (PDFPointsCollection)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPointsCollection Class : CollectionChanged Event
Gets or sets the event being fired when the collection has changed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event CollectionChanged As EventHandler(Of PDFCollectionChangedEventArgs(Of Double()))
'Usage

Dim instance As PDFPointsCollection
Dim handler As EventHandler(Of PDFCollectionChangedEventArgs(Of Double()))

AddHandler instance.CollectionChanged, handler
public event EventHandler<PDFCollectionChangedEventArgs<double[]>> CollectionChanged
public: __event EventHandler<PDFCollectionChangedEventArgs<double[]>*>* CollectionChanged
public:
event EventHandler<PDFCollectionChangedEventArgs<array<double>>^>^ CollectionChanged
Event Data

The event handler receives an argument of type PDFCollectionChangedEventArgs<T> containing data related to this event. The following PDFCollectionChangedEventArgs<T> properties provide information specific to this event.

Property | Description
ChangedProperty | Gets the name of changed property when the change type is item update.
ChangeType | Gets the type of change event.
NewItem | Gets the new item involved in the operation.
OldItem | Gets the old item involved in the operation.
Position | Gets the position of the affected item in the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPointsCollection Class
PDFPointsCollection Members


%%PageItemTitle%%

PDFPolygonAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolygonAnnotation Class
Defines a polygon annotation.
Object Model
PDFPolygonAnnotation ClassPDFAnnotationAppearance ClassPDFAnnotationBorder ClassPDFRgbColor ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFRgbColor ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFPolygonAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFPolygonAnnotation
[Serializable()]
public class PDFPolygonAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFPolygonAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFPolygonAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolygonAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFPolygonAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolygonAnnotation Class

The following tables list the members exposed by PDFPolygonAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFPolygonAnnotation Constructor | Initializes a new PDFPolygonAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayPoints | Gets or sets the polygon points in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | HatchColor | Gets or sets the annotation's hatch color.
Public Property | HatchType | Gets or sets the type of the hatched filling.
Public Property | HatchWidth | Gets or sets the annotation's hatch color.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Points | Gets the annotation points.
Public Property | PolygonInteriorColor | Gets or sets the polygons's interior color.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPolygonAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFPolygonAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : PDFPolygonAnnotation Constructor
Initializes a new PDFPolygonAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPolygonAnnotation()
public PDFPolygonAnnotation()
public: PDFPolygonAnnotation();
public:
PDFPolygonAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFPolygonAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolygonAnnotation Class

For a list of all members of this type, see PDFPolygonAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFPolygonAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFPolygonAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFPolygonAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%ItemTitle%%

PrepareForCopyPaste Method (PDFPolygonAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : PrepareForCopyPaste Method
Prepares the annotation for a copy/paste operation in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub PrepareForCopyPaste()
'Usage

Dim instance As PDFPolygonAnnotation

instance.PrepareForCopyPaste()
public override void PrepareForCopyPaste()
public: void PrepareForCopyPaste(); override
public:
void PrepareForCopyPaste(); override
Remarks
The method builds internal structures so when the annotation is pasted it appears exactly in the same visual position on the new page, no matter the page rotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFPolygonAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolygonAnnotation Class

For a list of all members of this type, see PDFPolygonAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayPoints | Gets or sets the polygon points in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | HatchColor | Gets or sets the annotation's hatch color.
Public Property | HatchType | Gets or sets the type of the hatched filling.
Public Property | HatchWidth | Gets or sets the annotation's hatch color.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Points | Gets the annotation points.
Public Property | PolygonInteriorColor | Gets or sets the polygons's interior color.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPolygonAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Border Property (PDFPolygonAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : Border Property
Gets or sets the annotation border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As PDFAnnotationBorder
'Usage

Dim instance As PDFPolygonAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
public PDFAnnotationBorder Border {get; set;}
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (    PDFAnnotationBorder^ value);
}

Property Value

The annotation border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%ItemTitle%%

DisplayPoints Property (PDFPolygonAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : DisplayPoints Property
Gets or sets the polygon points in display coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayPoints As PDFPoint()
'Usage

Dim instance As PDFPolygonAnnotation
Dim value() As PDFPoint

instance.DisplayPoints = value

value = instance.DisplayPoints
public PDFPoint[] DisplayPoints {get; set;}
public: __property PDFPoint*[]* get_DisplayPoints();
public: __property void set_DisplayPoints(
   PDFPoint*[]* value
);
public:
property array<PDFPoint^>^ DisplayPoints {
   array<PDFPoint^>^ get();
   void set (    array<PDFPoint^>^ value);
}

Property Value

An array of O2S.Components.PDFView4NET.PDFPoint objects.
Remarks
Set this property after the annotation has been added to the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%ItemTitle%%

HatchColor Property (PDFPolygonAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : HatchColor Property
Gets or sets the annotation's hatch color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchColor As PDFRgbColor
'Usage

Dim instance As PDFPolygonAnnotation
Dim value As PDFRgbColor

instance.HatchColor = value

value = instance.HatchColor
public PDFRgbColor HatchColor {get; set;}
public: __property PDFRgbColor* get_HatchColor();
public: __property void set_HatchColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ HatchColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The annotation hatch color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%ItemTitle%%

HatchType Property (PDFPolygonAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : HatchType Property
Gets or sets the type of the hatched filling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchType As PDFHatchType
'Usage

Dim instance As PDFPolygonAnnotation
Dim value As PDFHatchType

instance.HatchType = value

value = instance.HatchType
public PDFHatchType HatchType {get; set;}
public: __property PDFHatchType get_HatchType();
public: __property void set_HatchType(
   PDFHatchType value
);
public:
property PDFHatchType HatchType {
   PDFHatchType get();
   void set (    PDFHatchType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%ItemTitle%%

HatchWidth Property (PDFPolygonAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : HatchWidth Property
Gets or sets the annotation's hatch color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchWidth As Double
'Usage

Dim instance As PDFPolygonAnnotation
Dim value As Double

instance.HatchWidth = value

value = instance.HatchWidth
public double HatchWidth {get; set;}
public: __property double get_HatchWidth();
public: __property void set_HatchWidth(
   double value
);
public:
property double HatchWidth {
   double get();
   void set (    double value);
}

Property Value

The annotation hatch color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%ItemTitle%%

PDFRectangle Property (PDFPolygonAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFPolygonAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%ItemTitle%%

Points Property (PDFPolygonAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : Points Property
Gets the annotation points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Points As Double()
'Usage

Dim instance As PDFPolygonAnnotation
Dim value() As Double

instance.Points = value

value = instance.Points
public double[] Points {get; set;}
public: __property double[]* get_Points();
public: __property void set_Points(
   double[]* value
);
public:
property array<double>^ Points {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

The list of points that create this annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%ItemTitle%%

PolygonInteriorColor Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : PolygonInteriorColor Property
Gets or sets the polygons's interior color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PolygonInteriorColor As PDFRgbColor
'Usage

Dim instance As PDFPolygonAnnotation
Dim value As PDFRgbColor

instance.PolygonInteriorColor = value

value = instance.PolygonInteriorColor
public PDFRgbColor PolygonInteriorColor {get; set;}
public: __property PDFRgbColor* get_PolygonInteriorColor();
public: __property void set_PolygonInteriorColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ PolygonInteriorColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The polygon interior color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%PageItemTitle%%

PDFPolyLineAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyLineAnnotation Class
Defines a polyline annotation.
Object Model
PDFPolyLineAnnotation ClassPDFAnnotationAppearance ClassPDFAnnotationBorder ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFPolyLineAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFPolyLineAnnotation
[Serializable()]
public class PDFPolyLineAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFPolyLineAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFPolyLineAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolyMeasureAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyLineAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFPolyLineAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyLineAnnotation Class

The following tables list the members exposed by PDFPolyLineAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFPolyLineAnnotation Constructor | Initializes a new PDFPolyLineAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayPoints | Gets or sets the polygon points in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Points | Gets the annotation points.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPolyLineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFPolyLineAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyLineAnnotation Class : PDFPolyLineAnnotation Constructor
Initializes a new PDFPolyLineAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPolyLineAnnotation()
public PDFPolyLineAnnotation()
public: PDFPolyLineAnnotation();
public:
PDFPolyLineAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyLineAnnotation Class
PDFPolyLineAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFPolyLineAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyLineAnnotation Class

For a list of all members of this type, see PDFPolyLineAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFPolyLineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFPolyLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyLineAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFPolyLineAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyLineAnnotation Class
PDFPolyLineAnnotation Members


%%ItemTitle%%

PrepareForCopyPaste Method (PDFPolyLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyLineAnnotation Class : PrepareForCopyPaste Method
Prepares the annotation for a copy/paste operation in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub PrepareForCopyPaste()
'Usage

Dim instance As PDFPolyLineAnnotation

instance.PrepareForCopyPaste()
public override void PrepareForCopyPaste()
public: void PrepareForCopyPaste(); override
public:
void PrepareForCopyPaste(); override
Remarks
The method builds internal structures so when the annotation is pasted it appears exactly in the same visual position on the new page, no matter the page rotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyLineAnnotation Class
PDFPolyLineAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFPolyLineAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyLineAnnotation Class

For a list of all members of this type, see PDFPolyLineAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayPoints | Gets or sets the polygon points in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Points | Gets the annotation points.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPolyLineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Border Property (PDFPolyLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyLineAnnotation Class : Border Property
Gets or sets the annotation border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Border As PDFAnnotationBorder
'Usage

Dim instance As PDFPolyLineAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
public PDFAnnotationBorder Border {get; set;}
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (    PDFAnnotationBorder^ value);
}

Property Value

The annotation border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyLineAnnotation Class
PDFPolyLineAnnotation Members


%%ItemTitle%%

DisplayPoints Property (PDFPolyLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyLineAnnotation Class : DisplayPoints Property
Gets or sets the polygon points in display coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayPoints As PDFPoint()
'Usage

Dim instance As PDFPolyLineAnnotation
Dim value() As PDFPoint

instance.DisplayPoints = value

value = instance.DisplayPoints
public PDFPoint[] DisplayPoints {get; set;}
public: __property PDFPoint*[]* get_DisplayPoints();
public: __property void set_DisplayPoints(
   PDFPoint*[]* value
);
public:
property array<PDFPoint^>^ DisplayPoints {
   array<PDFPoint^>^ get();
   void set (    array<PDFPoint^>^ value);
}

Property Value

An array of O2S.Components.PDFView4NET.PDFPoint objects.
Remarks
Set this property after the annotation has been added to the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyLineAnnotation Class
PDFPolyLineAnnotation Members


%%ItemTitle%%

Points Property (PDFPolyLineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyLineAnnotation Class : Points Property
Gets the annotation points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Points As Double()
'Usage

Dim instance As PDFPolyLineAnnotation
Dim value() As Double

instance.Points = value

value = instance.Points
public virtual double[] Points {get; set;}
public: __property virtual double[]* get_Points();
public: __property virtual void set_Points(
   double[]* value
);
public:
virtual property array<double>^ Points {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

The list of points that create this annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyLineAnnotation Class
PDFPolyLineAnnotation Members


%%PageItemTitle%%

PDFPolyMeasureAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyMeasureAnnotation Class
Defines a poly ruler annotation.
Object Model
PDFPolyMeasureAnnotation ClassPDFAnnotationAppearance ClassPDFAnnotationBorder ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPolyMeasureAnnotation
   Inherits PDFPolyLineAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFPolyMeasureAnnotation
public class PDFPolyMeasureAnnotation : PDFPolyLineAnnotation, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFPolyMeasureAnnotation : public PDFPolyLineAnnotation, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFPolyMeasureAnnotation : public PDFPolyLineAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolyMeasureAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyMeasureAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFPolyMeasureAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyMeasureAnnotation Class

The following tables list the members exposed by PDFPolyMeasureAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFPolyMeasureAnnotation Constructor | Initializes a new PDFPolyMeasureAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayPoints | Gets or sets the polygon points in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Points | Overridden. Gets the annotation points.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ScaleAndUnit | Gets or sets the scale and unit a point in the PDF file corresponds to.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPolyMeasureAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFPolyMeasureAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyMeasureAnnotation Class : PDFPolyMeasureAnnotation Constructor
Initializes a new PDFPolyMeasureAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPolyMeasureAnnotation()
public PDFPolyMeasureAnnotation()
public: PDFPolyMeasureAnnotation();
public:
PDFPolyMeasureAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyMeasureAnnotation Class
PDFPolyMeasureAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFPolyMeasureAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyMeasureAnnotation Class

For a list of all members of this type, see PDFPolyMeasureAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayPoints | Gets or sets the polygon points in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Points | Overridden. Gets the annotation points.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ScaleAndUnit | Gets or sets the scale and unit a point in the PDF file corresponds to.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPolyMeasureAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Points Property (PDFPolyMeasureAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyMeasureAnnotation Class : Points Property
Gets the annotation points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Points As Double()
'Usage

Dim instance As PDFPolyMeasureAnnotation
Dim value() As Double

instance.Points = value

value = instance.Points
public override double[] Points {get; set;}
public: __property double[]* get_Points() override;
public: __property void set_Points(
   double[]* value
) override;
public:
property array<double>^ Points {
   array<double>^ get() override;
   void set (    array<double>^ value) override;
}

Property Value

The list of points that create this annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyMeasureAnnotation Class
PDFPolyMeasureAnnotation Members


%%ItemTitle%%

ScaleAndUnit Property (PDFPolyMeasureAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyMeasureAnnotation Class : ScaleAndUnit Property
Gets or sets the scale and unit a point in the PDF file corresponds to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScaleAndUnit As String
'Usage

Dim instance As PDFPolyMeasureAnnotation
Dim value As String

instance.ScaleAndUnit = value

value = instance.ScaleAndUnit
public string ScaleAndUnit {get; set;}
public: __property string* get_ScaleAndUnit();
public: __property void set_ScaleAndUnit(
   string* value
);
public:
property String^ ScaleAndUnit {
   String^ get();
   void set (    String^ value);
}

Property Value

The real word unit and scale a point in the PDF file corresponds to.
Remarks
The format of this property is "scale unit = scale unit", such as "1 pt = 10 ft" meaning that 1 point corresponds to 10 feet. Supported units are "mm" (millimeter), "cm" (centimeter), "m" (meter), "km" (kilometer), "pt" (point), "in" (inch), "ft" (foot) and "mi" (mile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyMeasureAnnotation Class
PDFPolyMeasureAnnotation Members


%%PageItemTitle%%

PDFPopupAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFPopupAnnotation Class
Defines a popup annotation.
Object Model
PDFPopupAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFMarkupAnnotation ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFPopupAnnotation
   Inherits PDFAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFPopupAnnotation
[Serializable()]
public class PDFPopupAnnotation : PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFPopupAnnotation : public PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFPopupAnnotation : public PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Remarks
Popup annotations are used to display a popup window for another annotation in order to edit its contents.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPopupAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPopupAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFPopupAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPopupAnnotation Class

The following tables list the members exposed by PDFPopupAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFPopupAnnotation Constructor | Initializes a new PDFPopupAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Open | Gets or sets the open status of the popup window.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Parent | Gets the parent annotation.
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPopupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFPopupAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFPopupAnnotation Class : PDFPopupAnnotation Constructor
Initializes a new PDFPopupAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPopupAnnotation()
public PDFPopupAnnotation()
public: PDFPopupAnnotation();
public:
PDFPopupAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPopupAnnotation Class
PDFPopupAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFPopupAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFPopupAnnotation Class

For a list of all members of this type, see PDFPopupAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPopupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFPopupAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPopupAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFPopupAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPopupAnnotation Class
PDFPopupAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFPopupAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFPopupAnnotation Class

For a list of all members of this type, see PDFPopupAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Open | Gets or sets the open status of the popup window.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Parent | Gets the parent annotation.
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPopupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Open Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFPopupAnnotation Class : Open Property
Gets or sets the open status of the popup window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Open As Boolean
'Usage

Dim instance As PDFPopupAnnotation
Dim value As Boolean

instance.Open = value

value = instance.Open
public bool Open {get; set;}
public: __property bool get_Open();
public: __property void set_Open(
   bool value
);
public:
property bool Open {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPopupAnnotation Class
PDFPopupAnnotation Members


%%ItemTitle%%

Parent Property (PDFPopupAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFPopupAnnotation Class : Parent Property
Gets the parent annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As PDFMarkupAnnotation
'Usage

Dim instance As PDFPopupAnnotation
Dim value As PDFMarkupAnnotation

value = instance.Parent
public PDFMarkupAnnotation Parent {get;}
public: __property PDFMarkupAnnotation* get_Parent();
public:
property PDFMarkupAnnotation^ Parent {
   PDFMarkupAnnotation^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPopupAnnotation Class
PDFPopupAnnotation Members


%%PageItemTitle%%

PDFRectangleAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFRectangleAnnotation Class
Defines a rectangle (Square) annotation.
Object Model
PDFRectangleAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFRgbColor ClassPDFAnnotation ClassPDFRgbColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFRectangleAnnotation
   Inherits PDFSCAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFRectangleAnnotation
[Serializable()]
public class PDFRectangleAnnotation : PDFSCAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFRectangleAnnotation : public PDFSCAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFRectangleAnnotation : public PDFSCAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation
O2S.Components.PDFView4NET.Annotations.PDFRectangleAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangleAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFRectangleAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFRectangleAnnotation Class

The following tables list the members exposed by PDFRectangleAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFRectangleAnnotation Constructor | Initializes a new PDFRectangleAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | BorderWidth | Gets or sets the border width. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | HatchColor | Gets or sets the annotation's hatch color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | HatchType | Gets or sets the type of the hatched filling. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | HatchWidth | Gets or sets the annotation's hatch color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFRectangleAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFRectangleAnnotation Class : PDFRectangleAnnotation Constructor
Initializes a new PDFRectangleAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRectangleAnnotation()
public PDFRectangleAnnotation()
public: PDFRectangleAnnotation();
public:
PDFRectangleAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangleAnnotation Class
PDFRectangleAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFRectangleAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFRectangleAnnotation Class

For a list of all members of this type, see PDFRectangleAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFRectangleAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFRectangleAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFRectangleAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangleAnnotation Class
PDFRectangleAnnotation Members


%%PageItemTitle%%

PDFSCAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFSCAnnotation Class
Defines the base class for rectangle (Square) and ellipse (Circle) annotations.
Object Model
PDFSCAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFRgbColor ClassPDFAnnotation ClassPDFRgbColor ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFSCAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFSCAnnotation
[Serializable()]
public class PDFSCAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFSCAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFSCAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation
O2S.Components.PDFView4NET.Annotations.PDFEllipseAnnotation
O2S.Components.PDFView4NET.Annotations.PDFRectangleAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFSCAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFSCAnnotation Class

The following tables list the members exposed by PDFSCAnnotation.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | HatchColor | Gets or sets the annotation's hatch color.
Public Property | HatchType | Gets or sets the type of the hatched filling.
Public Property | HatchWidth | Gets or sets the annotation's hatch color.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFSCAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFSCAnnotation Class

For a list of all members of this type, see PDFSCAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFSCAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFSCAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFSCAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFSCAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFSCAnnotation Class

For a list of all members of this type, see PDFSCAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | HatchColor | Gets or sets the annotation's hatch color.
Public Property | HatchType | Gets or sets the type of the hatched filling.
Public Property | HatchWidth | Gets or sets the annotation's hatch color.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

BorderWidth Property (PDFSCAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFSCAnnotation Class : BorderWidth Property
Gets or sets the border width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PDFSCAnnotation
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public: __property double get_BorderWidth();
public: __property void set_BorderWidth(
   double value
);
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the annotation's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


%%ItemTitle%%

HatchColor Property (PDFSCAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFSCAnnotation Class : HatchColor Property
Gets or sets the annotation's hatch color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchColor As PDFRgbColor
'Usage

Dim instance As PDFSCAnnotation
Dim value As PDFRgbColor

instance.HatchColor = value

value = instance.HatchColor
public PDFRgbColor HatchColor {get; set;}
public: __property PDFRgbColor* get_HatchColor();
public: __property void set_HatchColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ HatchColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The annotation hatch color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


%%ItemTitle%%

HatchType Property (PDFSCAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFSCAnnotation Class : HatchType Property
Gets or sets the type of the hatched filling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchType As PDFHatchType
'Usage

Dim instance As PDFSCAnnotation
Dim value As PDFHatchType

instance.HatchType = value

value = instance.HatchType
public PDFHatchType HatchType {get; set;}
public: __property PDFHatchType get_HatchType();
public: __property void set_HatchType(
   PDFHatchType value
);
public:
property PDFHatchType HatchType {
   PDFHatchType get();
   void set (    PDFHatchType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


%%ItemTitle%%

HatchWidth Property (PDFSCAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFSCAnnotation Class : HatchWidth Property
Gets or sets the annotation's hatch color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HatchWidth As Double
'Usage

Dim instance As PDFSCAnnotation
Dim value As Double

instance.HatchWidth = value

value = instance.HatchWidth
public double HatchWidth {get; set;}
public: __property double get_HatchWidth();
public: __property void set_HatchWidth(
   double value
);
public:
property double HatchWidth {
   double get();
   void set (    double value);
}

Property Value

The annotation hatch color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


%%ItemTitle%%

InteriorColor Property (PDFSCAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFSCAnnotation Class : InteriorColor Property
Gets or sets the annotation's interior color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InteriorColor As PDFRgbColor
'Usage

Dim instance As PDFSCAnnotation
Dim value As PDFRgbColor

instance.InteriorColor = value

value = instance.InteriorColor
public PDFRgbColor InteriorColor {get; set;}
public: __property PDFRgbColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFRgbColor* value
);
public:
property PDFRgbColor^ InteriorColor {
   PDFRgbColor^ get();
   void set (    PDFRgbColor^ value);
}

Property Value

The annotation interior color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


%%ItemTitle%%

PDFRectangle Property (PDFSCAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFSCAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFSCAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


%%PageItemTitle%%

PDFSquigglyAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFSquigglyAnnotation Class
Defines a squiggly annotation.
Object Model
PDFSquigglyAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFSquigglyAnnotation
   Inherits PDFTextMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFSquigglyAnnotation
[Serializable()]
public class PDFSquigglyAnnotation : PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFSquigglyAnnotation : public PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFSquigglyAnnotation : public PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This annotation is used to underline text in a document with a jagged line.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFSquigglyAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSquigglyAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFSquigglyAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFSquigglyAnnotation Class

The following tables list the members exposed by PDFSquigglyAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFSquigglyAnnotation Constructor | Initializes a new PDFSquigglyAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFSquigglyAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFSquigglyAnnotation Class : PDFSquigglyAnnotation Constructor
Initializes a new PDFSquigglyAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSquigglyAnnotation()
public PDFSquigglyAnnotation()
public: PDFSquigglyAnnotation();
public:
PDFSquigglyAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSquigglyAnnotation Class
PDFSquigglyAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFSquigglyAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFSquigglyAnnotation Class

For a list of all members of this type, see PDFSquigglyAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFSquigglyAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFSquigglyAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFSquigglyAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSquigglyAnnotation Class
PDFSquigglyAnnotation Members


%%PageItemTitle%%

PDFStampAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFStampAnnotation Class
Defines a rubber stamp annotation.
Object Model
PDFStampAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFStampAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFStampAnnotation
[Serializable()]
public class PDFStampAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFStampAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFStampAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFStampAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFStampAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFStampAnnotation Class

The following tables list the members exposed by PDFStampAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFStampAnnotation Constructor | Initializes a new PDFStampAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Icon |
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Overridden. Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFStampAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFStampAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : PDFStampAnnotation Constructor
Initializes a new PDFStampAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFStampAnnotation()
public PDFStampAnnotation()
public: PDFStampAnnotation();
public:
PDFStampAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFStampAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFStampAnnotation Class

For a list of all members of this type, see PDFStampAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Overridden. Prepares the annotation for a copy/paste operation in the viewer.
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFStampAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFStampAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFStampAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%ItemTitle%%

PrepareForCopyPaste Method (PDFStampAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : PrepareForCopyPaste Method
Prepares the annotation for a copy/paste operation in the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub PrepareForCopyPaste()
'Usage

Dim instance As PDFStampAnnotation

instance.PrepareForCopyPaste()
public override void PrepareForCopyPaste()
public: void PrepareForCopyPaste(); override
public:
void PrepareForCopyPaste(); override
Remarks
The method builds internal structures so when the annotation is pasted it appears exactly in the same visual position on the new page, no matter the page rotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFStampAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFStampAnnotation Class

For a list of all members of this type, see PDFStampAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Icon |
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Overridden. Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFStampAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Appearance Property (PDFStampAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFStampAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the stamp.
Remarks
When this property is set to a valid appearance, the Icon is set to PDFStampAnnotationIcon.Custom and the IconName is set to "Custom". If you want to use your custom icon name, make sure you set the IconName property after this property is set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%ItemTitle%%

Icon Property (PDFStampAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : Icon Property
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Icon As PDFStampAnnotationIcon
'Usage

Dim instance As PDFStampAnnotation
Dim value As PDFStampAnnotationIcon

instance.Icon = value

value = instance.Icon
public PDFStampAnnotationIcon Icon {get; set;}
public: __property PDFStampAnnotationIcon get_Icon();
public: __property void set_Icon(
   PDFStampAnnotationIcon value
);
public:
property PDFStampAnnotationIcon Icon {
   PDFStampAnnotationIcon get();
   void set (    PDFStampAnnotationIcon value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%ItemTitle%%

IconName Property (PDFStampAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : IconName Property
Gets or sets the icon name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IconName As String
'Usage

Dim instance As PDFStampAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
public string IconName {get; set;}
public: __property string* get_IconName();
public: __property void set_IconName(
   string* value
);
public:
property String^ IconName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the stamp's icon.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
This property lets you set a custom name for your user defined stamp appearances.
If the Icon property to any of the PDFStampAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFStampAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFStampAnnotationIcon.Custom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%ItemTitle%%

Opacity Property (PDFStampAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : Opacity Property
Gets or sets the annotation opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Opacity As Double
'Usage

Dim instance As PDFStampAnnotation
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public override double Opacity {get; set;}
public: __property double get_Opacity() override;
public: __property void set_Opacity(
   double value
) override;
public:
property double Opacity {
   double get() override;
   void set (    double value) override;
}

Property Value

The opacity of the annotation in percents.
Remarks
100 means total opacity, 0 means fully transparent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%ItemTitle%%

PDFRectangle Property (PDFStampAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFStampAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%ItemTitle%%

Rotation Property (PDFStampAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFStampAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%PageItemTitle%%

PDFStrikeOutAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFStrikeOutAnnotation Class
Defines a strike out annotation.
Object Model
PDFStrikeOutAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFStrikeOutAnnotation
   Inherits PDFTextMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFStrikeOutAnnotation
[Serializable()]
public class PDFStrikeOutAnnotation : PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFStrikeOutAnnotation : public PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFStrikeOutAnnotation : public PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This annotation is used to strike out text in a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFStrikeOutAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStrikeOutAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFStrikeOutAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

The following tables list the members exposed by PDFStrikeOutAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFStrikeOutAnnotation Constructor | Initializes a new PDFStrikeOutAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFStrikeOutAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFStrikeOutAnnotation Class : PDFStrikeOutAnnotation Constructor
Initializes a new PDFStrikeOutAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFStrikeOutAnnotation()
public PDFStrikeOutAnnotation()
public: PDFStrikeOutAnnotation();
public:
PDFStrikeOutAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStrikeOutAnnotation Class
PDFStrikeOutAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFStrikeOutAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

For a list of all members of this type, see PDFStrikeOutAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFStrikeOutAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFStrikeOutAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFStrikeOutAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStrikeOutAnnotation Class
PDFStrikeOutAnnotation Members


%%PageItemTitle%%

PDFTextAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextAnnotation Class
Defines a text annotation.
Object Model
PDFTextAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFTextAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFTextAnnotation
[Serializable()]
public class PDFTextAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFTextAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFTextAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFTextAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextAnnotation Class

The following tables list the members exposed by PDFTextAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFTextAnnotation Constructor | Initializes a new PDFTextAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Overridden. Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | State | Gets or sets the annotation state.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextAnnotation Class : PDFTextAnnotation Constructor
Initializes a new PDFTextAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFTextAnnotation()
public PDFTextAnnotation()
public: PDFTextAnnotation();
public:
PDFTextAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFTextAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextAnnotation Class

For a list of all members of this type, see PDFTextAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFTextAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFTextAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextAnnotation Class

For a list of all members of this type, see PDFTextAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Overridden. Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | State | Gets or sets the annotation state.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

Appearance Property (PDFTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextAnnotation Class : Appearance Property
Gets or sets the annotation appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFTextAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The appearance of the text annotation icon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%ItemTitle%%

Icon Property (PDFTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextAnnotation Class : Icon Property
Gets or sets the annotation icon.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Icon As PDFTextAnnotationIcon
'Usage

Dim instance As PDFTextAnnotation
Dim value As PDFTextAnnotationIcon

instance.Icon = value

value = instance.Icon
public PDFTextAnnotationIcon Icon {get; set;}
public: __property PDFTextAnnotationIcon get_Icon();
public: __property void set_Icon(
   PDFTextAnnotationIcon value
);
public:
property PDFTextAnnotationIcon Icon {
   PDFTextAnnotationIcon get();
   void set (    PDFTextAnnotationIcon value);
}

Property Value

The icon to be displayed for the annotation.
Remarks
If the Icon property to any of the PDFTextAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFTextAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFTextAnnotationIcon.Custom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%ItemTitle%%

IconName Property (PDFTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextAnnotation Class : IconName Property
Gets or sets the icon name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IconName As String
'Usage

Dim instance As PDFTextAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
public string IconName {get; set;}
public: __property string* get_IconName();
public: __property void set_IconName(
   string* value
);
public:
property String^ IconName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the stamp's icon.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
This property lets you set a custom name for your user defined stamp appearances.
If the Icon property to any of the PDFTextAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFTextAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFTextAnnotationIcon.Custom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%ItemTitle%%

Opacity Property (PDFTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextAnnotation Class : Opacity Property
Gets or sets the annotation opacity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Opacity As Double
'Usage

Dim instance As PDFTextAnnotation
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public override double Opacity {get; set;}
public: __property double get_Opacity() override;
public: __property void set_Opacity(
   double value
) override;
public:
property double Opacity {
   double get() override;
   void set (    double value) override;
}

Property Value

The opacity of the annotation in percents.
Remarks
100 means total opacity, 0 means fully transparent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%ItemTitle%%

Rotation Property (PDFTextAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFTextAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%ItemTitle%%

State Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextAnnotation Class : State Property
Gets or sets the annotation state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property State As PDFTextAnnotationState
'Usage

Dim instance As PDFTextAnnotation
Dim value As PDFTextAnnotationState

instance.State = value

value = instance.State
public PDFTextAnnotationState State {get; set;}
public: __property PDFTextAnnotationState get_State();
public: __property void set_State(
   PDFTextAnnotationState value
);
public:
property PDFTextAnnotationState State {
   PDFTextAnnotationState get();
   void set (    PDFTextAnnotationState value);
}

Property Value

The state of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%PageItemTitle%%

PDFTextMarkupAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextMarkupAnnotation Class
Defines a text markup annotation.
Object Model
PDFTextMarkupAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PDFTextMarkupAnnotation
   Inherits PDFMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFTextMarkupAnnotation
[Serializable()]
public class PDFTextMarkupAnnotation : PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public __gc class PDFTextMarkupAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
[Serializable()]
public ref class PDFTextMarkupAnnotation : public PDFMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Remarks
Text markup annotations appear as highlights, underlines, strikeouts or jagged (squiggly) underlines in the text of a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFHighlightAnnotation
O2S.Components.PDFView4NET.Annotations.PDFSquigglyAnnotation
O2S.Components.PDFView4NET.Annotations.PDFStrikeOutAnnotation
O2S.Components.PDFView4NET.Annotations.PDFUnderlineAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFTextMarkupAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

The following tables list the members exposed by PDFTextMarkupAnnotation.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | QuadPoints | Gets or sets the points that define the markup area.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFTextMarkupAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

For a list of all members of this type, see PDFTextMarkupAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFTextMarkupAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFTextMarkupAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


%%PageItemTitle%% $$Properties$$

PDFTextMarkupAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

For a list of all members of this type, see PDFTextMarkupAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | QuadPoints | Gets or sets the points that define the markup area.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

DisplayQuadPoints Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : DisplayQuadPoints Property
Gets or sets the points that define the markup area in display coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayQuadPoints As PDFPoint()
'Usage

Dim instance As PDFTextMarkupAnnotation
Dim value() As PDFPoint

instance.DisplayQuadPoints = value

value = instance.DisplayQuadPoints
public PDFPoint[] DisplayQuadPoints {get; set;}
public: __property PDFPoint*[]* get_DisplayQuadPoints();
public: __property void set_DisplayQuadPoints(
   PDFPoint*[]* value
);
public:
property array<PDFPoint^>^ DisplayQuadPoints {
   array<PDFPoint^>^ get();
   void set (    array<PDFPoint^>^ value);
}

Property Value

An array of O2S.Components.PDFView4NET.PDFPoint objects.
Remarks
Set this property after the annotation has been added to the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


%%ItemTitle%%

MarkupType Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : MarkupType Property
Gets or sets the type of the annotation markup.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property MarkupType As PDFTextMarkupType
'Usage

Dim instance As PDFTextMarkupAnnotation
Dim value As PDFTextMarkupType

value = instance.MarkupType
public virtual PDFTextMarkupType MarkupType {get;}
public: __property virtual PDFTextMarkupType get_MarkupType();
public:
virtual property PDFTextMarkupType MarkupType {
   PDFTextMarkupType get();
}

Property Value

The type of the text markup.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


%%ItemTitle%%

PDFRectangle Property (PDFTextMarkupAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFTextMarkupAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


%%ItemTitle%%

QuadPoints Property

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : QuadPoints Property
Gets or sets the points that define the markup area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property QuadPoints As Double()
'Usage

Dim instance As PDFTextMarkupAnnotation
Dim value() As Double

instance.QuadPoints = value

value = instance.QuadPoints
public double[] QuadPoints {get; set;}
public: __property double[]* get_QuadPoints();
public: __property void set_QuadPoints(
   double[]* value
);
public:
property array<double>^ QuadPoints {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of points the define the location of the markup within the annotation.
Remarks
The array must include 8*n values representing the coordinates (x, y)of n quadrilaters. The coordinates for each quadrilateral are given in the order x1 y1 x2 y2 x3 y3 x4 y4 specifying the quadrilater's 4 vertices in counterclockwise order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


%%ItemTitle%%

Rotation Property (PDFTextMarkupAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFTextMarkupAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


%%PageItemTitle%%

PDFUnderlineAnnotation Class
Members

O2S.Components.PDFView4NET.Annotations Namespace : PDFUnderlineAnnotation Class
Defines an underline annotation.
Object Model
PDFUnderlineAnnotation ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFAnnotation ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUnderlineAnnotation
   Inherits PDFTextMarkupAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFUnderlineAnnotation
public class PDFUnderlineAnnotation : PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFUnderlineAnnotation : public PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFUnderlineAnnotation : public PDFTextMarkupAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Remarks
This annotation is used to underline text in a document.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFUnderlineAnnotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnderlineAnnotation Members
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Members$$

PDFUnderlineAnnotation Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFUnderlineAnnotation Class

The following tables list the members exposed by PDFUnderlineAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PDFUnderlineAnnotation Constructor | Initializes a new PDFUnderlineAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFUnderlineAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFUnderlineAnnotation Class : PDFUnderlineAnnotation Constructor
Initializes a new PDFUnderlineAnnotation object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUnderlineAnnotation()
public PDFUnderlineAnnotation()
public: PDFUnderlineAnnotation();
public:
PDFUnderlineAnnotation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnderlineAnnotation Class
PDFUnderlineAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFUnderlineAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFUnderlineAnnotation Class

For a list of all members of this type, see PDFUnderlineAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Overridden. Serializes the object content.
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

GetObjectData Method (PDFUnderlineAnnotation)

O2S.Components.PDFView4NET.Annotations Namespace > PDFUnderlineAnnotation Class : GetObjectData Method
Serializes the object content.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim instance As PDFUnderlineAnnotation
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
) override
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
) override

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnderlineAnnotation Class
PDFUnderlineAnnotation Members


%%PageItemTitle%%

PDFAnnotationFlags Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationFlags Enumeration
Specifies the available flags for an annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PDFAnnotationFlags
   Inherits System.Enum
'Usage

Dim instance As PDFAnnotationFlags
[Flags()]
public enum PDFAnnotationFlags : System.Enum
[Flags()]
__value public enum PDFAnnotationFlags : public System.Enum
[Flags()]
public enum class PDFAnnotationFlags : public System.Enum
Members
Member | Description
Hidden | If set, do not display or print the annotation or allow it to interact with the user.
Invisible | If set, do not display the annotation if it does not belong to one of the standard annotation types.
Locked | If set, do not allow the annotation to be deleted or its properties (including position and size) to be modified by the user. However, this flag does not restrict changes to the annotation’s contents, such as the value of a form field.
LockedContents | If set, do not allow the contents of the annotation to be modified by the user. This flag does not restrict deletion of the annotation or changes to other annotation properties, such as position and size.
NoRotate | If set, do not rotate the annotation's appearance to match the rotation of the page.
NoView | If set, do not display the annotation on the screen or allow it to interact with the user. The annotation may be printed (depending on the Print flag), but should be considered hidden for the purposes of onscreen display and user interaction.
NoZoom | If set, do not scale the annotation's appearance to match the magnification of the page.
Print | If set, print the annotation when the page is printed. If clear, never print the annotation, regardless of whether it is displayed on the screen.
ReadOnly | If set, do not allow the annotation to interact with the user.
ToggleNoView | If set, invert the interpretation of the NoView flag for certain events.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFAnnotationFlags

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFAnnotationType Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationType Enumeration
Specifies the available types of annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFAnnotationType
   Inherits System.Enum
'Usage

Dim instance As PDFAnnotationType
public enum PDFAnnotationType : System.Enum
__value public enum PDFAnnotationType : public System.Enum
public enum class PDFAnnotationType : public System.Enum
Members
Member | Description
Barcode | Barcode annotation.
Ellipse | Ellipse (Circle) annotation.
FileAttachment | File attachment annotation.
FreeText | Free text annotation.
Highlight | Highlight annotation.
Ink | Ink annotation.
Line | Line annotation.
Link | Link annotation.
Measure | Measure annotation.
Polygon | Polygon annotation.
PolyLine | PolyLine annotation.
PolyMeasure | Poly measure annotation.
Popup | Popup annotation.
Rectangle | Rectangle (Square) annotation.
Squiggly | Squiggly annotation.
Stamp | Stamp annotation.
StrikeOut | StrikeOut annotation.
Text | Text annotation.
Underline | Underline annotation.
Unknown | Unknown annotation.
Widget | Widget annotation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFAnnotationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFBorderStyle Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFBorderStyle Enumeration
Specifies the available styles for an annotation's border.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFBorderStyle
   Inherits System.Enum
'Usage

Dim instance As PDFBorderStyle
public enum PDFBorderStyle : System.Enum
__value public enum PDFBorderStyle : public System.Enum
public enum class PDFBorderStyle : public System.Enum
Members
Member | Description
Beveled | A simulated embossed rectangle that appears to be raised above the surface of the page.
Dashed | A dashed rectangle surrounding the annotation.
Inset | A simulated engraved rectangle that appears to be recessed below the surface of the page.
Solid | A solid rectangle surrounding the annotation.
Underline | A single line along the bottom of the annotation rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFBorderStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFFileAttachmentAnnotationIcon Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFFileAttachmentAnnotationIcon Enumeration
Specifies the available icons for a file attachment annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFileAttachmentAnnotationIcon
   Inherits System.Enum
'Usage

Dim instance As PDFFileAttachmentAnnotationIcon
public enum PDFFileAttachmentAnnotationIcon : System.Enum
__value public enum PDFFileAttachmentAnnotationIcon : public System.Enum
public enum class PDFFileAttachmentAnnotationIcon : public System.Enum
Members
Member | Description
Custom | Custom icon.
Graph | Graph icon.
Paperclip | Paperclip icon.
PushPin | Push pin icon.
Tag | Tag icon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFFileAttachmentAnnotationIcon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFLineDirection Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFLineDirection Enumeration
Specifies the available directions for a line annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFLineDirection
   Inherits System.Enum
'Usage

Dim instance As PDFLineDirection
public enum PDFLineDirection : System.Enum
__value public enum PDFLineDirection : public System.Enum
public enum class PDFLineDirection : public System.Enum
Members
Member | Description
BottomLeftToTopRight | Line starts at bottom left corner and ends at top right corner.
BottomRightToTopLeft | Line starts at bottom right corner and ends at top left corner.
BottomToTop | Vertical line from bottom to top.
LeftToRight | Horizontal line from left to right.
RightToLeft | Horizontal line from right to left.
TopLeftToBottomRight | Line starts at top left corner and ends at bottom right corner.
TopRightToBottomLeft | Line starts at top right corner and ends at bottom left corner.
TopToBottom | Vertical line from top to bottom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFLineDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFLineEndingStyle Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFLineEndingStyle Enumeration
Specifies the available line ending styles to be used when drawing a line annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFLineEndingStyle
   Inherits System.Enum
'Usage

Dim instance As PDFLineEndingStyle
public enum PDFLineEndingStyle : System.Enum
__value public enum PDFLineEndingStyle : public System.Enum
public enum class PDFLineEndingStyle : public System.Enum
Members
Member | Description
Circle | A circle filled with annotation's interior color, if any.
ClosedArrow | Two short lines meeting in an acute angle as in the OpenArrow style, connected by a third line to form a triangular closed arrowhead filled with annotation's interior color, if any.
Diamond | A diamond filled with annotation's interior color, if any.
None | No line ending.
OpenArrow | Two short lines meeting in an acute angle, forming a open arrow head.
Square | A square filled with annotation's interior color, if any.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFLineEndingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFStampAnnotationIcon Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFStampAnnotationIcon Enumeration
Specifies the available icons for a stmap annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFStampAnnotationIcon
   Inherits System.Enum
'Usage

Dim instance As PDFStampAnnotationIcon
public enum PDFStampAnnotationIcon : System.Enum
__value public enum PDFStampAnnotationIcon : public System.Enum
public enum class PDFStampAnnotationIcon : public System.Enum
Members
Member | Description
Approved | Approved icon.
AsIs | As Is icon.
Confidential | Confidential icon.
Custom | User defined custom icon.
Departmental | Departmental icon.
Draft | Draft icon.
Experimental | Experimental icon.
Expired | Expired icon.
Final | Final icon.
ForComment | for comment icon.
ForPublicRelease | For public release icon.
NotApproved | Not approved icon.
NotForPublicRelease | Not for public release icon.
Sold | Sold icon.
TopSecret | Top secret icon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFStampAnnotationIcon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextAnnotationIcon Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextAnnotationIcon Enumeration
Specifies the available icons for a text annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFTextAnnotationIcon
   Inherits System.Enum
'Usage

Dim instance As PDFTextAnnotationIcon
public enum PDFTextAnnotationIcon : System.Enum
__value public enum PDFTextAnnotationIcon : public System.Enum
public enum class PDFTextAnnotationIcon : public System.Enum
Members
Member | Description
Check | Check mark icon.
Circle | Circle icon.
Comment | Comment icon.
Cross | Cross icon.
Custom | User defined custom icon.
Help | Help icon.
Insert | Insert icon.
Key | Key icon.
NewParagraph | New paragraph icon.
Note | Note icon.
Paragraph | Paragraph icon.
RightArrow | Right arrow icon.
RightPointer | Right pointer icon.
Star | Star arrow icon.
UpArrow | Up arrow icon.
UpLeftArrow | Up left arrow icon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFTextAnnotationIcon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextAnnotationState Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextAnnotationState Enumeration
Specifies the available states for a text annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFTextAnnotationState
   Inherits System.Enum
'Usage

Dim instance As PDFTextAnnotationState
public enum PDFTextAnnotationState : System.Enum
__value public enum PDFTextAnnotationState : public System.Enum
public enum class PDFTextAnnotationState : public System.Enum
Members
Member | Description
Accepted | The user agrees with the change.
Cancelled | The change has been cancelled.
Completed | The change has been completed.
Marked | The annotation has been marked by the user.
None | The user has indicated nothing about the change.
NoState | No state has been associated with the annotation.
Rejected | The user disagrees with the change.
Unmarked | The annotation has not been marked by the user.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFTextAnnotationState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextMarkupType Enumeration

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextMarkupType Enumeration
Specifies the available markup types for a text markup annotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFTextMarkupType
   Inherits System.Enum
'Usage

Dim instance As PDFTextMarkupType
public enum PDFTextMarkupType : System.Enum
__value public enum PDFTextMarkupType : public System.Enum
public enum class PDFTextMarkupType : public System.Enum
Members
Member | Description
Highlight | Highlight.
Squiggly | Jagged underline.
StrikeOut | Strike out.
Underline | Underline.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Annotations.PDFTextMarkupType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Annotations Namespace


%%ItemTitle%%

O2S.Components.PDFView4NET.Forms Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | FDFField | Defines a field in a FDF document.
Class | FDFFieldCollection | Defines a collection of fields in a FDF document.
Class | FDFFile | Represents a FDF file on disk.
Class | PDFCheckBoxField | Defines a checkbox in a PDF form.
Class | PDFCheckBoxWidget | Defines the widget for a check box field.
Class | PDFCheckWidget | Defines a widget that can be checked.
Class | PDFDropDownListField | Defines a drop down list field for user input in the PDF file.
Class | PDFDropDownListWidget | Defines the widget for a textbox field.
Class | PDFField | Defines the base class for form fields in a PDF form.
Class | PDFFieldCollection | Defines a collection of form fields.
Class | PDFFieldImportError | Represents an error that happened during the import of a FDF/XFDF/XML file.
Class | PDFFieldWidget | Defines the widget for a form field.
Class | PDFFieldWidgetCollection | Defines a collection of form fields.
Class | PDFForm | Defines a form in a PDF document.
Class | PDFListBoxField | Defines a scrollable list box field for user input in the PDF file.
Class | PDFListBoxWidget | Defines the widget for a listbox field.
Class | PDFListField | Base class for all list type fields.
Class | PDFListItem | Defines an item in a list.
Class | PDFListItemCollection | Defines a collection of list items.
Class | PDFPushButtonField | Defines a pushbutton in a PDF form.
Class | PDFPushButtonWidget | Defines the widget for a pushbutton field.
Class | PDFRadioButtonItem | Defines the widget for a radio button.
Class | PDFRadioButtonListField | Defines a list of radio buttons in a PDF form.
Class | PDFSignatureField | Defines a signature field in a PDF form.
Class | PDFSignatureLockFieldAction | Defines the field lock action to be executed when a signature field is signed.
Class | PDFSignatureWidget | Defines the widget for a signature field.
Class | PDFTextBoxField | Defines a text box in a PDF form.
Class | PDFTextBoxWidget | Defines the widget for a textbox field.
Class | XFDFField | Defines a field in a XFDF document.
Class | XFDFFieldCollection | Defines a collection of fields in a XFDF document.
Class | XFDFFile | Represents a XFDF file on disk.
Enumerations
 | Enumeration | Description
Enumeration | PDFCheckSymbolStyle | Specifies the available style for a check box and radio button items.
Enumeration | PDFExportDataOptions | Specifies the available export options for PDF forms.
Enumeration | PDFFieldTextAlign | Specifies the available alignments for text in a field.
Enumeration | PDFFieldType | Specifies the available field types.
Enumeration | PDFFieldWidgetVisibilityStatus | Specifies the available visibility states for a field widget.
Enumeration | PDFFormDataFormat | Specifies the available formats for data import/export for AcroForms.
Enumeration | PDFPushButtonHighlightMode | Specifies the available highlighting modes for a button.
Enumeration | PDFSignatureLockFieldMode | Specifies the available lock modes for form fields when a signature lock is applied.
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

FDFField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : FDFField Class
Defines a field in a FDF document.
Object Model
FDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class FDFField
'Usage

Dim instance As FDFField
public sealed class FDFField
public __gc __sealed class FDFField
public ref class FDFField sealed
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.FDFField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

FDFField Class Members
Properties

O2S.Components.PDFView4NET.Forms Namespace : FDFField Class

The following tables list the members exposed by FDFField.

Public Properties
 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top
See Also

Reference

FDFField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

FDFField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : FDFField Class

For a list of all members of this type, see FDFField members.

Public Properties
 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top
See Also

Reference

FDFField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Name Property (FDFField)

O2S.Components.PDFView4NET.Forms Namespace > FDFField Class : Name Property
Gets the field name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As FDFField
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

A string value specifying the name of the FDF field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFField Class
FDFField Members


%%ItemTitle%%

Value Property (FDFField)

O2S.Components.PDFView4NET.Forms Namespace > FDFField Class : Value Property
Gets the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As String
'Usage

Dim instance As FDFField
Dim value As String

value = instance.Value
public string Value {get;}
public: __property string* get_Value();
public:
property String^ Value {
   String^ get();
}

Property Value

A string value specifying the value of the FDF field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFField Class
FDFField Members


%%PageItemTitle%%

FDFFieldCollection Class
Members

O2S.Components.PDFView4NET.Forms Namespace : FDFFieldCollection Class
Defines a collection of fields in a FDF document.
Object Model
FDFFieldCollection ClassFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FDFFieldCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of FDFField,FDFFile)
'Usage

Dim instance As FDFFieldCollection
public class FDFFieldCollection : O2S.Components.PDFView4NET.PDFCollection<FDFField,FDFFile>
public __gc class FDFFieldCollection : public O2S.Components.PDFView4NET.PDFCollection<FDFField,FDFFile>
public ref class FDFFieldCollection : public O2S.Components.PDFView4NET.PDFCollection<FDFField,FDFFile>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Forms.FDFFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFieldCollection Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

FDFFieldCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : FDFFieldCollection Class

The following tables list the members exposed by FDFFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<FDFField,FDFFile>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top
See Also

Reference

FDFFieldCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

FDFFile Class
Members

O2S.Components.PDFView4NET.Forms Namespace : FDFFile Class
Represents a FDF file on disk.
Object Model
FDFFile ClassFDFFieldCollection ClassFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FDFFile
'Usage

Dim instance As FDFFile
public class FDFFile
public __gc class FDFFile
public ref class FDFFile
Remarks
This class defines an existing FDF file. Its methods allows to import/export data from/to FDF files.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.FDFFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

FDFFile Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : FDFFile Class

The following tables list the members exposed by FDFFile.

Public Properties
 | Name | Description
Public Property | Fields | Gets the list of fields in the FDF file.
Public Property | PDFFileName | Gets the name of the PDF file the FDF file was exported from.
Top
Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a FDFFile object from the given FDF file.
static (Shared in Visual Basic) | FromStream | Creates a FDFFile object from the given stream object.
Top
See Also

Reference

FDFFile Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

FDFFile Class Methods

O2S.Components.PDFView4NET.Forms Namespace : FDFFile Class

For a list of all members of this type, see FDFFile members.

Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a FDFFile object from the given FDF file.
static (Shared in Visual Basic) | FromStream | Creates a FDFFile object from the given stream object.
Top
See Also

Reference

FDFFile Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Close Method (FDFFile)

O2S.Components.PDFView4NET.Forms Namespace > FDFFile Class : Close Method
Closes the underlying pdf file and frees all resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As FDFFile

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


%%ItemTitle%%

FromFile Method (FDFFile)

O2S.Components.PDFView4NET.Forms Namespace > FDFFile Class : FromFile Method
the full path to a FDF file used as source for this FDFFile object.
Creates a FDFFile object from the given FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromFile( _
   ByVal fileName As String _
) As FDFFile
'Usage

Dim fileName As String
Dim value As FDFFile

value = FDFFile.FromFile(fileName)
public static FDFFile FromFile(
   string fileName
)
public: static FDFFile* FromFile(
   string* fileName
)
public:
static FDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a FDF file used as source for this FDFFile object.

Return Value

A FDFFile object created based on the given FDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


%%ItemTitle%%

FromStream(Stream) Method

O2S.Components.PDFView4NET.Forms Namespace > FDFFile Class : FromStream(Stream) Method
the stream object used as source for this FDFFile object.
Creates a FDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromStream( _
   ByVal stream As Stream _
) As FDFFile
'Usage

Dim stream As Stream
Dim value As FDFFile

value = FDFFile.FromStream(stream)
public static FDFFile FromStream(
   Stream stream
)
public: static FDFFile* FromStream(
   Stream* stream
)
public:
static FDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this FDFFile object.

Return Value

A FDFFile object created based on the given stream object.
Remarks
The stream must contain a valid FDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%% $$Properties$$

FDFFile Class Properties

O2S.Components.PDFView4NET.Forms Namespace : FDFFile Class

For a list of all members of this type, see FDFFile members.

Public Properties
 | Name | Description
Public Property | Fields | Gets the list of fields in the FDF file.
Public Property | PDFFileName | Gets the name of the PDF file the FDF file was exported from.
Top
See Also

Reference

FDFFile Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Fields Property (FDFFile)

O2S.Components.PDFView4NET.Forms Namespace > FDFFile Class : Fields Property
Gets the list of fields in the FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As FDFFieldCollection
'Usage

Dim instance As FDFFile
Dim value As FDFFieldCollection

value = instance.Fields
public FDFFieldCollection Fields {get;}
public: __property FDFFieldCollection* get_Fields();
public:
property FDFFieldCollection^ Fields {
   FDFFieldCollection^ get();
}

Property Value

A FDFFieldCollection object specifying the list of fields in the FDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


%%ItemTitle%%

PDFFileName Property (FDFFile)

O2S.Components.PDFView4NET.Forms Namespace > FDFFile Class : PDFFileName Property
Gets the name of the PDF file the FDF file was exported from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PDFFileName As String
'Usage

Dim instance As FDFFile
Dim value As String

value = instance.PDFFileName
public string PDFFileName {get;}
public: __property string* get_PDFFileName();
public:
property String^ PDFFileName {
   String^ get();
}

Property Value

A string value specifying the the name of the PDF file the FDF file was exported from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%%

PDFCheckBoxField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckBoxField Class
Defines a checkbox in a PDF form.
Object Model
PDFCheckBoxField ClassPDFJavaScriptAction ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCheckBoxField
   Inherits PDFField
'Usage

Dim instance As PDFCheckBoxField
public class PDFCheckBoxField : PDFField
public __gc class PDFCheckBoxField : public PDFField
public ref class PDFCheckBoxField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFCheckBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFCheckBoxField Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckBoxField Class

The following tables list the members exposed by PDFCheckBoxField.

Public Constructors
 | Name | Description
Public Constructor | PDFCheckBoxField Constructor | Initializes a new PDFCheckBoxField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Checked | Gets or sets a value indicating whether the checkbox is checked or not.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckBoxField Class : PDFCheckBoxField Constructor
The name of the field.
Initializes a new PDFCheckBoxField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFCheckBoxField(name)
public PDFCheckBoxField(
   string name
)
public: PDFCheckBoxField(
   string* name
)
public:
PDFCheckBoxField(
   String^ name
)

Parameters

name
The name of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%% $$Properties$$

PDFCheckBoxField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckBoxField Class

For a list of all members of this type, see PDFCheckBoxField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Checked | Gets or sets a value indicating whether the checkbox is checked or not.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Checked Property (PDFCheckBoxField)

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckBoxField Class : Checked Property
Gets or sets a value indicating whether the checkbox is checked or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Checked As Boolean
'Usage

Dim instance As PDFCheckBoxField
Dim value As Boolean

instance.Checked = value

value = instance.Checked
public bool Checked {get; set;}
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
public:
property bool Checked {
   bool get();
   void set (    bool value);
}

Property Value

True if at least one checkbox widget is checked, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%%

PDFCheckBoxWidget Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckBoxWidget Class
Defines the widget for a check box field.
Object Model
PDFCheckBoxWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCheckBoxWidget
   Inherits PDFCheckWidget
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFCheckBoxWidget
public class PDFCheckBoxWidget : PDFCheckWidget, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFCheckBoxWidget : public PDFCheckWidget, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFCheckBoxWidget : public PDFCheckWidget, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFCheckWidget
O2S.Components.PDFView4NET.Forms.PDFCheckBoxWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxWidget Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFCheckBoxWidget Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckBoxWidget Class

The following tables list the members exposed by PDFCheckBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFCheckBoxWidget Constructor | Initializes a new PDFCheckBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckBoxWidget Class : PDFCheckBoxWidget Constructor
Initializes a new PDFCheckBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCheckBoxWidget()
public PDFCheckBoxWidget()
public: PDFCheckBoxWidget();
public:
PDFCheckBoxWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxWidget Class
PDFCheckBoxWidget Members


%%PageItemTitle%%

PDFCheckWidget Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckWidget Class
Defines a widget that can be checked.
Object Model
PDFCheckWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCheckWidget
   Inherits PDFFieldWidget
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFCheckWidget
public class PDFCheckWidget : PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFCheckWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFCheckWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFCheckWidget
O2S.Components.PDFView4NET.Forms.PDFCheckBoxWidget
O2S.Components.PDFView4NET.Forms.PDFRadioButtonItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFCheckWidget Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckWidget Class

The following tables list the members exposed by PDFCheckWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFCheckWidget Constructor | Initializes a new PDFCheckWidget object.
Top
Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not.
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance.
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget.
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance.
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance.
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance.
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFCheckWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : PDFCheckWidget Constructor
Initializes a new PDFCheckWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCheckWidget()
public PDFCheckWidget()
public: PDFCheckWidget();
public:
PDFCheckWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%PageItemTitle%% $$Properties$$

PDFCheckWidget Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckWidget Class

For a list of all members of this type, see PDFCheckWidget members.

Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not.
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance.
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget.
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance.
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance.
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance.
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFCheckWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Appearance Property (PDFCheckWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : Appearance Property
Gets or sets the widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public new PDFAnnotationAppearance Appearance {get; set;}
public: __property new PDFAnnotationAppearance* get_Appearance();
public: __property new void set_Appearance(
   PDFAnnotationAppearance* value
);
public:
new property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The normal appearance of the field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

Checked Property (PDFCheckWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : Checked Property
Gets or sets a value indicating whether this widget is checked or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Checked As Boolean
'Usage

Dim instance As PDFCheckWidget
Dim value As Boolean

instance.Checked = value

value = instance.Checked
public bool Checked {get; set;}
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
public:
property bool Checked {
   bool get();
   void set (    bool value);
}

Property Value

True if the widget is checked, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

CheckedDownAppearance Property

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : CheckedDownAppearance Property
Gets or sets the checked down widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckedDownAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.CheckedDownAppearance = value

value = instance.CheckedDownAppearance
public PDFAnnotationAppearance CheckedDownAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_CheckedDownAppearance();
public: __property void set_CheckedDownAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ CheckedDownAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The down appearance of the field widget in checked state.
Remarks
This appearance is displayed when the mouse is clicked on the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

CheckedNormalAppearance Property

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : CheckedNormalAppearance Property
Gets or sets the checked rollover widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckedNormalAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.CheckedNormalAppearance = value

value = instance.CheckedNormalAppearance
public PDFAnnotationAppearance CheckedNormalAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_CheckedNormalAppearance();
public: __property void set_CheckedNormalAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ CheckedNormalAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The rollover appearance of the field widget in checked state.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

CheckedRolloverAppearance Property

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : CheckedRolloverAppearance Property
Gets or sets the checked rollover widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckedRolloverAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.CheckedRolloverAppearance = value

value = instance.CheckedRolloverAppearance
public PDFAnnotationAppearance CheckedRolloverAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_CheckedRolloverAppearance();
public: __property void set_CheckedRolloverAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ CheckedRolloverAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The rollover appearance of the field widget in checked state.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

CheckSymbolStyle Property

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : CheckSymbolStyle Property
Gets or sets the symbol used as checkmark.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckSymbolStyle As PDFCheckSymbolStyle
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFCheckSymbolStyle

instance.CheckSymbolStyle = value

value = instance.CheckSymbolStyle
public PDFCheckSymbolStyle CheckSymbolStyle {get; set;}
public: __property PDFCheckSymbolStyle get_CheckSymbolStyle();
public: __property void set_CheckSymbolStyle(
   PDFCheckSymbolStyle value
);
public:
property PDFCheckSymbolStyle CheckSymbolStyle {
   PDFCheckSymbolStyle get();
   void set (    PDFCheckSymbolStyle value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

ExportValue Property

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : ExportValue Property
Gets or sets the export value for this check box widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExportValue As String
'Usage

Dim instance As PDFCheckWidget
Dim value As String

instance.ExportValue = value

value = instance.ExportValue
public string ExportValue {get; set;}
public: __property string* get_ExportValue();
public: __property void set_ExportValue(
   string* value
);
public:
property String^ ExportValue {
   String^ get();
   void set (    String^ value);
}

Property Value

The value that is exported from the form if the widget is checked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

PDFRectangle Property (PDFCheckWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

UncheckedDownAppearance Property

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : UncheckedDownAppearance Property
Gets or sets the unchecked down widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UncheckedDownAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.UncheckedDownAppearance = value

value = instance.UncheckedDownAppearance
public PDFAnnotationAppearance UncheckedDownAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_UncheckedDownAppearance();
public: __property void set_UncheckedDownAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ UncheckedDownAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The down appearance of the field widget in unchecked state.
Remarks
This appearance is displayed when the mouse is clicked on the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

UncheckedNormalAppearance Property

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : UncheckedNormalAppearance Property
Gets or sets the unchecked normal widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UncheckedNormalAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.UncheckedNormalAppearance = value

value = instance.UncheckedNormalAppearance
public PDFAnnotationAppearance UncheckedNormalAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_UncheckedNormalAppearance();
public: __property void set_UncheckedNormalAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ UncheckedNormalAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The normal appearance of the field widget in unchecked state.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%ItemTitle%%

UncheckedRolloverAppearance Property

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : UncheckedRolloverAppearance Property
Gets or sets the unchecked rollover widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UncheckedRolloverAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.UncheckedRolloverAppearance = value

value = instance.UncheckedRolloverAppearance
public PDFAnnotationAppearance UncheckedRolloverAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_UncheckedRolloverAppearance();
public: __property void set_UncheckedRolloverAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ UncheckedRolloverAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The rollover appearance of the field widget in unchecked state.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%PageItemTitle%%

PDFDropDownListField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFDropDownListField Class
Defines a drop down list field for user input in the PDF file.
Object Model
PDFDropDownListField ClassPDFJavaScriptAction ClassPDFForm ClassPDFJavaScriptAction ClassPDFListItemCollection ClassPDFListItem ClassPDFJavaScriptAction ClassPDFListItem ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDropDownListField
   Inherits PDFListField
'Usage

Dim instance As PDFDropDownListField
public class PDFDropDownListField : PDFListField
public __gc class PDFDropDownListField : public PDFListField
public ref class PDFDropDownListField : public PDFListField
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFListField
O2S.Components.PDFView4NET.Forms.PDFDropDownListField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFDropDownListField Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFDropDownListField Class

The following tables list the members exposed by PDFDropDownListField.

Public Constructors
 | Name | Description
Public Constructor | PDFDropDownListField Constructor | Initializes a new PDFDropDownListField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | CheckSpelling | Gets or sets whether the field content should be checked for spelling erorrs.
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Edit | Gets or sets whether the user can enter text in the drop down list or not.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFDropDownListField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFDropDownListField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFDropDownListField Class : PDFDropDownListField Constructor
The name of this drop down list field object.
Initializes a new PDFDropDownListField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFDropDownListField(name)
public PDFDropDownListField(
   string name
)
public: PDFDropDownListField(
   string* name
)
public:
PDFDropDownListField(
   String^ name
)

Parameters

name
The name of this drop down list field object.
Remarks
The field name must be unique across the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%% $$Properties$$

PDFDropDownListField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFDropDownListField Class

For a list of all members of this type, see PDFDropDownListField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | CheckSpelling | Gets or sets whether the field content should be checked for spelling erorrs.
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Edit | Gets or sets whether the user can enter text in the drop down list or not.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFDropDownListField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

CheckSpelling Property (PDFDropDownListField)

O2S.Components.PDFView4NET.Forms Namespace > PDFDropDownListField Class : CheckSpelling Property
Gets or sets whether the field content should be checked for spelling erorrs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckSpelling As Boolean
'Usage

Dim instance As PDFDropDownListField
Dim value As Boolean

instance.CheckSpelling = value

value = instance.CheckSpelling
public bool CheckSpelling {get; set;}
public: __property bool get_CheckSpelling();
public: __property void set_CheckSpelling(
   bool value
);
public:
property bool CheckSpelling {
   bool get();
   void set (    bool value);
}

Property Value

True if the field content should be checked for spelling erorrs, false otherwise. Default is true.
Remarks
The field content is checked for spelling errors only when the PDF file is opened in the viewer (if the PDF viewer support this feature) and it is not spell checked when its value is set from code. This flag has meaning only if Edit is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%ItemTitle%%

Edit Property

O2S.Components.PDFView4NET.Forms Namespace > PDFDropDownListField Class : Edit Property
Gets or sets whether the user can enter text in the drop down list or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Edit As Boolean
'Usage

Dim instance As PDFDropDownListField
Dim value As Boolean

instance.Edit = value

value = instance.Edit
public bool Edit {get; set;}
public: __property bool get_Edit();
public: __property void set_Edit(
   bool value
);
public:
property bool Edit {
   bool get();
   void set (    bool value);
}

Property Value

True if the drop down list is editable, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%%

PDFDropDownListWidget Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFDropDownListWidget Class
Defines the widget for a textbox field.
Object Model
PDFDropDownListWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFRgbColor ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDropDownListWidget
   Inherits PDFFieldWidget
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFDropDownListWidget
public class PDFDropDownListWidget : PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFDropDownListWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFDropDownListWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
Remarks
The field widget is the field's visual representation on a PDF page. A textbox field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFDropDownListWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListWidget Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFDropDownListWidget Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Forms Namespace : PDFDropDownListWidget Class

The following tables list the members exposed by PDFDropDownListWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFDropDownListWidget Constructor | Initializes a new PDFDropDownListWidget object.
Top
Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFDropDownListWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFDropDownListWidget Class : PDFDropDownListWidget Constructor
Initializes a new PDFDropDownListWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDropDownListWidget()
public PDFDropDownListWidget()
public: PDFDropDownListWidget();
public:
PDFDropDownListWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListWidget Class
PDFDropDownListWidget Members


%%PageItemTitle%%

PDFField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFField Class
Defines the base class for form fields in a PDF form.
Object Model
PDFField ClassPDFJavaScriptAction ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFField
'Usage

Dim instance As PDFField
public class PDFField
public __gc class PDFField
public ref class PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFCheckBoxField
O2S.Components.PDFView4NET.Forms.PDFListField
O2S.Components.PDFView4NET.Forms.PDFPushButtonField
O2S.Components.PDFView4NET.Forms.PDFRadioButtonListField
O2S.Components.PDFView4NET.Forms.PDFSignatureField
O2S.Components.PDFView4NET.Forms.PDFTextBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFField Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFField Class

The following tables list the members exposed by PDFField.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value.
Public Property | Form | Gets the form that contains this field.
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke.
Public Property | MappingName | Gets or sets the mapping name of the field.
Public Property | Name | Gets or sets the field name.
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Tooltip | Gets or sets the field tooltip.
Public Property | Type | Gets the field type.
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value.
Public Property | Value | Gets or sets the field value.
Public Property | Widgets | Gets the list of widgets associated with this field.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources.
Top
See Also

Reference

PDFField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFField Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFField Class

For a list of all members of this type, see PDFField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources.
Top
See Also

Reference

PDFField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Dispose Method (PDFField)

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : Dispose Method
Disposes the internal resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PDFField

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%% $$Properties$$

PDFField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFField Class

For a list of all members of this type, see PDFField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value.
Public Property | Form | Gets the form that contains this field.
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke.
Public Property | MappingName | Gets or sets the mapping name of the field.
Public Property | Name | Gets or sets the field name.
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Tooltip | Gets or sets the field tooltip.
Public Property | Type | Gets the field type.
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value.
Public Property | Value | Gets or sets the field value.
Public Property | Widgets | Gets the list of widgets associated with this field.
Top
See Also

Reference

PDFField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

CalculateAction Property

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : CalculateAction Property
Gets or sets the JavaScript action to be executed for calculating the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CalculateAction As PDFJavaScriptAction
'Usage

Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.CalculateAction = value

value = instance.CalculateAction
public PDFJavaScriptAction CalculateAction {get; set;}
public: __property PDFJavaScriptAction* get_CalculateAction();
public: __property void set_CalculateAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ CalculateAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDFView4NET.Actions.PDFJavaScriptAction object specifying the action to be executed for calculating the field value.
Remarks
This property specifies a JavaScript action to be performed to recalculate the value of this field when that of another field changes.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

Form Property (PDFField)

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : Form Property
Gets the form that contains this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Form As PDFForm
'Usage

Dim instance As PDFField
Dim value As PDFForm

value = instance.Form
public PDFForm Form {get;}
public: __property PDFForm* get_Form();
public:
property PDFForm^ Form {
   PDFForm^ get();
}

Property Value

The form that owns the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

FormatAction Property

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : FormatAction Property
Gets or sets the JavaScript action to be executed for formating the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FormatAction As PDFJavaScriptAction
'Usage

Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.FormatAction = value

value = instance.FormatAction
public PDFJavaScriptAction FormatAction {get; set;}
public: __property PDFJavaScriptAction* get_FormatAction();
public: __property void set_FormatAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ FormatAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDFView4NET.Actions.PDFJavaScriptAction object specifying the action to be executed for formating the field value.
Remarks
This property specifies a JavaScript action to be performed before the field is formatted to display its current value. This action can modify the field’s value before formatting.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

KeyPressAction Property

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : KeyPressAction Property
Gets or sets the JavaScript action to be executed when the user types a keystroke.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property KeyPressAction As PDFJavaScriptAction
'Usage

Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.KeyPressAction = value

value = instance.KeyPressAction
public PDFJavaScriptAction KeyPressAction {get; set;}
public: __property PDFJavaScriptAction* get_KeyPressAction();
public: __property void set_KeyPressAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ KeyPressAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDFView4NET.Actions.PDFJavaScriptAction object specifying the action to be executed when the user types a keystroke.
Remarks
This property specifies a JavaScript action to be performed when the user types a keystroke into a text field or combo box or modifies the selection in a scrollable list box. This action can check the keystroke for validity and reject or modify it.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField and PDFRadioButtonListField fields.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

MappingName Property

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : MappingName Property
Gets or sets the mapping name of the field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MappingName As String
'Usage

Dim instance As PDFField
Dim value As String

instance.MappingName = value

value = instance.MappingName
public string MappingName {get; set;}
public: __property string* get_MappingName();
public: __property void set_MappingName(
   string* value
);
public:
property String^ MappingName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the mapping name of the field.
Remarks
The field's mapping name is used when exporting interactive form field data from the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

Name Property (PDFField)

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : Name Property
Gets or sets the field name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFField
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The fully qualified field name.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the name is null or empty or not a valid PDF field name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

NoExport Property

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : NoExport Property
Gets or sets a value indicating whether the field can be exported or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NoExport As Boolean
'Usage

Dim instance As PDFField
Dim value As Boolean

instance.NoExport = value

value = instance.NoExport
public bool NoExport {get; set;}
public: __property bool get_NoExport();
public: __property void set_NoExport(
   bool value
);
public:
property bool NoExport {
   bool get();
   void set (    bool value);
}

Property Value

True if the field can not be exported, false otherwise. Default is false.
Remarks
If true, the field must not be exported by a submit-form action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

ReadOnly Property

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : ReadOnly Property
Gets or sets a value indicating whether the field is read-only.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReadOnly As Boolean
'Usage

Dim instance As PDFField
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
public bool ReadOnly {get; set;}
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
public:
property bool ReadOnly {
   bool get();
   void set (    bool value);
}

Property Value

True if the field is read-only, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

Required Property

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : Required Property
Gets or sets a value indicating whether the field is required.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Required As Boolean
'Usage

Dim instance As PDFField
Dim value As Boolean

instance.Required = value

value = instance.Required
public bool Required {get; set;}
public: __property bool get_Required();
public: __property void set_Required(
   bool value
);
public:
property bool Required {
   bool get();
   void set (    bool value);
}

Property Value

True if the field is required, false otherwise. Default is false.
Remarks
If true, the field must have a value when it is exported by a submit-form action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

Tooltip Property (PDFField)

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : Tooltip Property
Gets or sets the field tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Tooltip As String
'Usage

Dim instance As PDFField
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
public virtual string Tooltip {get; set;}
public: __property virtual string* get_Tooltip();
public: __property virtual void set_Tooltip(
   string* value
);
public:
virtual property String^ Tooltip {
   String^ get();
   void set (    String^ value);
}

Property Value

The field's tooltip.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

Type Property (PDFField)

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : Type Property
Gets the field type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PDFFieldType
'Usage

Dim instance As PDFField
Dim value As PDFFieldType

value = instance.Type
public PDFFieldType Type {get;}
public: __property PDFFieldType get_Type();
public:
property PDFFieldType Type {
   PDFFieldType get();
}

Property Value

The type of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

ValidateAction Property

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : ValidateAction Property
Gets or sets the JavaScript action to be executed for validating the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ValidateAction As PDFJavaScriptAction
'Usage

Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.ValidateAction = value

value = instance.ValidateAction
public PDFJavaScriptAction ValidateAction {get; set;}
public: __property PDFJavaScriptAction* get_ValidateAction();
public: __property void set_ValidateAction(
   PDFJavaScriptAction* value
);
public:
property PDFJavaScriptAction^ ValidateAction {
   PDFJavaScriptAction^ get();
   void set (    PDFJavaScriptAction^ value);
}

Property Value

A O2S.Components.PDFView4NET.Actions.PDFJavaScriptAction object specifying the action to be executed for validating the field value.
Remarks
This property specifies a JavaScript action to be performed when the field’s value is changed. This action can check the new value for validity.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

Value Property (PDFField)

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : Value Property
Gets or sets the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As Object
'Usage

Dim instance As PDFField
Dim value As Object

instance.Value = value

value = instance.Value
public object Value {get; set;}
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
public:
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The field value.
Remarks
The value type depends on the actual field. Check box fields accept string and boolean values while other fields work only with strings. If other type is provided, it will be converted to string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%ItemTitle%%

Widgets Property

O2S.Components.PDFView4NET.Forms Namespace > PDFField Class : Widgets Property
Gets the list of widgets associated with this field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Widgets As PDFFieldWidgetCollection
'Usage

Dim instance As PDFField
Dim value As PDFFieldWidgetCollection

value = instance.Widgets
public PDFFieldWidgetCollection Widgets {get;}
public: __property PDFFieldWidgetCollection* get_Widgets();
public:
property PDFFieldWidgetCollection^ Widgets {
   PDFFieldWidgetCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFField Class
PDFField Members


%%PageItemTitle%%

PDFFieldCollection Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldCollection Class
Defines a collection of form fields.
Object Model
PDFFieldCollection ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PDFFieldCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFField,PDFForm)
'Usage

Dim instance As PDFFieldCollection
[DefaultMember("Item")]
public class PDFFieldCollection : O2S.Components.PDFView4NET.PDFCollection<PDFField,PDFForm>
[DefaultMember("Item")]
public __gc class PDFFieldCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFField,PDFForm>
[DefaultMember("Item")]
public ref class PDFFieldCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFField,PDFForm>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Forms.PDFFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldCollection Class

The following tables list the members exposed by PDFFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Property | Item | Gets the field with the specified name.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Dispose | Disposes the internal objects and resources.
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFField,PDFForm>)
Public Method | Remove | Overloaded. Removes the field with the specified name from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top
See Also

Reference

PDFFieldCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFFieldCollection Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldCollection Class

For a list of all members of this type, see PDFFieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Dispose | Disposes the internal objects and resources.
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFField,PDFForm>)
Public Method | Remove | Overloaded. Removes the field with the specified name from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top
See Also

Reference

PDFFieldCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Dispose Method (PDFFieldCollection)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldCollection Class : Dispose Method
Disposes the internal objects and resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PDFFieldCollection

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
Remarks
This method also calls Dispose on the objects in the collection. If you want to remove the items from the collection then call the Clear method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members


%%ItemTitle%%

Remove Method

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldCollection Class : Remove Method
Removes the field with the specified name from the collection.
Overload List
Overload | Description
Remove(String) | Removes the field with the specified name from the collection.
Remove(PDFField) | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members


%%ItemTitle%%

Remove(String) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldCollection Class > Remove Method : Remove(String) Method
The name of the field to remove.
Removes the field with the specified name from the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal name As String _
)
'Usage

Dim instance As PDFFieldCollection
Dim name As String

instance.Remove(name)
public void Remove(
   string name
)
public: void Remove(
   string* name
)
public:
void Remove(
   String^ name
)

Parameters

name
The name of the field to remove.
Remarks
If the field with the specified name does not exist in the collection nothing happens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFFieldCollection Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldCollection Class

For a list of all members of this type, see PDFFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Property | Item | Gets the field with the specified name.
Top
See Also

Reference

PDFFieldCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Item Property

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldCollection Class : Item Property
The name of the field to lookup in the collection.
Gets the field with the specified name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal name As String _
) As PDFField
'Usage

Dim instance As PDFFieldCollection
Dim name As String
Dim value As PDFField

value = instance.Item(name)
public new PDFField this[
   string name
]; {get;}
public: __property new PDFField* get_Item   string* name
;
public:
new property PDFField^ default [String^] {
   PDFField^ get(String^ name);
}

Parameters

name
The name of the field to lookup in the collection.

Property Value

The field if exists, otherwise null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members


%%PageItemTitle%%

PDFFieldImportError Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldImportError Class
Represents an error that happened during the import of a FDF/XFDF/XML file.
Object Model
PDFFieldImportError ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFieldImportError
'Usage

Dim instance As PDFFieldImportError
public class PDFFieldImportError
public __gc class PDFFieldImportError
public ref class PDFFieldImportError
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFFieldImportError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldImportError Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldImportError Class Members
Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldImportError Class

The following tables list the members exposed by PDFFieldImportError.

Public Properties
 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top
See Also

Reference

PDFFieldImportError Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFFieldImportError Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldImportError Class

For a list of all members of this type, see PDFFieldImportError members.

Public Properties
 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top
See Also

Reference

PDFFieldImportError Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Exception Property

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldImportError Class : Exception Property
Gets the exception thrown by the field during the import.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Exception As Exception
'Usage

Dim instance As PDFFieldImportError
Dim value As Exception

value = instance.Exception
public Exception Exception {get;}
public: __property Exception* get_Exception();
public:
property Exception^ Exception {
   Exception^ get();
}

Property Value

A Exception object with the details about the import error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldImportError Class
PDFFieldImportError Members


%%ItemTitle%%

Field Property (PDFFieldImportError)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldImportError Class : Field Property
Gets the field that generated the import error.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As PDFFieldImportError
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

A PDFField object representing the field that generated the error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldImportError Class
PDFFieldImportError Members


%%PageItemTitle%%

PDFFieldWidget Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidget Class
Defines the widget for a form field.
Object Model
PDFFieldWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFRgbColor ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFieldWidget
   Inherits O2S.Components.PDFView4NET.Annotations.PDFAnnotation
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFFieldWidget
public class PDFFieldWidget : O2S.Components.PDFView4NET.Annotations.PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFFieldWidget : public O2S.Components.PDFView4NET.Annotations.PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFFieldWidget : public O2S.Components.PDFView4NET.Annotations.PDFAnnotation, O2S.Components.PDFView4NET.IRawPDFData
Remarks
The field widget is the field's visual representation on a PDF page. A form field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFCheckWidget
O2S.Components.PDFView4NET.Forms.PDFDropDownListWidget
O2S.Components.PDFView4NET.Forms.PDFListBoxWidget
O2S.Components.PDFView4NET.Forms.PDFPushButtonWidget
O2S.Components.PDFView4NET.Forms.PDFSignatureWidget
O2S.Components.PDFView4NET.Forms.PDFTextBoxWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldWidget Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidget Class

The following tables list the members exposed by PDFFieldWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFFieldWidget Constructor | Initializes a new PDFFieldWidget object.
Top
Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not.
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color.
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus.
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the widget rotation angle.
Public Property | TabOrder | Gets or sets the widget's tab order.
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget.
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFieldWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : PDFFieldWidget Constructor
Initializes a new PDFFieldWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFieldWidget()
public PDFFieldWidget()
public: PDFFieldWidget();
public:
PDFFieldWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%PageItemTitle%% $$Properties$$

PDFFieldWidget Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidget Class

For a list of all members of this type, see PDFFieldWidget members.

Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not.
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color.
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus.
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the widget rotation angle.
Public Property | TabOrder | Gets or sets the widget's tab order.
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget.
Top
See Also

Reference

PDFFieldWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

AllowResize Property

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : AllowResize Property
Gets or sets a value indicating whether the field widget can be resized in the viewer control or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowResize As Boolean
'Usage

Dim instance As PDFFieldWidget
Dim value As Boolean

instance.AllowResize = value

value = instance.AllowResize
public bool AllowResize {get; set;}
public: __property bool get_AllowResize();
public: __property void set_AllowResize(
   bool value
);
public:
property bool AllowResize {
   bool get();
   void set (    bool value);
}

Property Value

True if the field widget can be resized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

Appearance Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : Appearance Property
Gets or sets the widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Appearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
public override PDFAnnotationAppearance Appearance {get; set;}
public: __property PDFAnnotationAppearance* get_Appearance() override;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
) override;
public:
property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get() override;
   void set (    PDFAnnotationAppearance^ value) override;
}

Property Value

The normal appearance of the field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

BackColor Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : BackColor Property
Gets or sets the widget's background color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BackColor As PDFDeviceColor
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFDeviceColor

instance.BackColor = value

value = instance.BackColor
public PDFDeviceColor BackColor {get; set;}
public: __property PDFDeviceColor* get_BackColor();
public: __property void set_BackColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ BackColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The color of widget's background.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

Blur Property

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : Blur Property
Gets or sets the action that is executed when the field widget loses focus.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Blur As PDFAction
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFAction

instance.Blur = value

value = instance.Blur
public PDFAction Blur {get; set;}
public: __property PDFAction* get_Blur();
public: __property void set_Blur(
   PDFAction* value
);
public:
property PDFAction^ Blur {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the field widget loses focus.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

BorderColor Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : BorderColor Property
Gets or sets the widget's border color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderColor As PDFDeviceColor
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFDeviceColor

instance.BorderColor = value

value = instance.BorderColor
public PDFDeviceColor BorderColor {get; set;}
public: __property PDFDeviceColor* get_BorderColor();
public: __property void set_BorderColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ BorderColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The color of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

BorderStyle Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : BorderStyle Property
Gets or sets the widget's border style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderStyle As PDFBorderStyle
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFBorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
public PDFBorderStyle BorderStyle {get; set;}
public: __property PDFBorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   PDFBorderStyle value
);
public:
property PDFBorderStyle BorderStyle {
   PDFBorderStyle get();
   void set (    PDFBorderStyle value);
}

Property Value

The style of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

BorderWidth Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : BorderWidth Property
Gets or sets the widget's border width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PDFFieldWidget
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public: __property double get_BorderWidth();
public: __property void set_BorderWidth(
   double value
);
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of widget's border.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

Field Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : Field Property
Gets the form field that owns this widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PDFField
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFField

value = instance.Field
public PDFField Field {get;}
public: __property PDFField* get_Field();
public:
property PDFField^ Field {
   PDFField^ get();
}

Property Value

The form field that owns this widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

Focus Property

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : Focus Property
Gets or sets the action that is executed when the field widget receives focus.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Focus As PDFAction
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFAction

instance.Focus = value

value = instance.Focus
public PDFAction Focus {get; set;}
public: __property PDFAction* get_Focus();
public: __property void set_Focus(
   PDFAction* value
);
public:
property PDFAction^ Focus {
   PDFAction^ get();
   void set (    PDFAction^ value);
}

Property Value

The action to be executed when the field widget receives focus.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

Font Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : Font Property
Gets or sets the font used to display the widget text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Font As PDFFontBase
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
public PDFFontBase Font {get; set;}
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (    PDFFontBase^ value);
}

Property Value

The font used for displaying the widget content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

PDFRectangle Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

Rotation Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : Rotation Property
Gets or sets the widget rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Rotation As PDFRotationMode
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
public override PDFRotationMode Rotation {get; set;}
public: __property PDFRotationMode get_Rotation() override;
public: __property void set_Rotation(
   PDFRotationMode value
) override;
public:
property PDFRotationMode Rotation {
   PDFRotationMode get() override;
   void set (    PDFRotationMode value) override;
}

Property Value

The rotation angle of the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

TabOrder Property

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : TabOrder Property
Gets or sets the widget's tab order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TabOrder As Integer
'Usage

Dim instance As PDFFieldWidget
Dim value As Integer

instance.TabOrder = value

value = instance.TabOrder
public int TabOrder {get; set;}
public: __property int get_TabOrder();
public: __property void set_TabOrder(
   int value
);
public:
property int TabOrder {
   int get();
   void set (    int value);
}

Property Value

The position of the widget that defines the navigation between the fields using TAB key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

TextColor Property (PDFFieldWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : TextColor Property
Gets or sets the widget's text color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As PDFDeviceColor
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFDeviceColor

instance.TextColor = value

value = instance.TextColor
public PDFDeviceColor TextColor {get; set;}
public: __property PDFDeviceColor* get_TextColor();
public: __property void set_TextColor(
   PDFDeviceColor* value
);
public:
property PDFDeviceColor^ TextColor {
   PDFDeviceColor^ get();
   void set (    PDFDeviceColor^ value);
}

Property Value

The color of widget's text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%ItemTitle%%

VisibilityStatus Property

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : VisibilityStatus Property
Gets or sets the visibility status of the field widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property VisibilityStatus As PDFFieldWidgetVisibilityStatus
'Usage

Dim instance As PDFFieldWidget
Dim value As PDFFieldWidgetVisibilityStatus

instance.VisibilityStatus = value

value = instance.VisibilityStatus
public PDFFieldWidgetVisibilityStatus VisibilityStatus {get; set;}
public: __property PDFFieldWidgetVisibilityStatus get_VisibilityStatus();
public: __property void set_VisibilityStatus(
   PDFFieldWidgetVisibilityStatus value
);
public:
property PDFFieldWidgetVisibilityStatus VisibilityStatus {
   PDFFieldWidgetVisibilityStatus get();
   void set (    PDFFieldWidgetVisibilityStatus value);
}

Property Value

A PDFFieldWidgetVisibilityStatus enumeration member specifying the visibility status of the field widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%PageItemTitle%%

PDFFieldWidgetCollection Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidgetCollection Class
Defines a collection of form fields.
Object Model
PDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFieldWidgetCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFFieldWidget,PDFField)
'Usage

Dim instance As PDFFieldWidgetCollection
public class PDFFieldWidgetCollection : O2S.Components.PDFView4NET.PDFCollection<PDFFieldWidget,PDFField>
public __gc class PDFFieldWidgetCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFFieldWidget,PDFField>
public ref class PDFFieldWidgetCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFFieldWidget,PDFField>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Forms.PDFFieldWidgetCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidgetCollection Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFFieldWidgetCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidgetCollection Class

The following tables list the members exposed by PDFFieldWidgetCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFFieldWidget,PDFField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top
See Also

Reference

PDFFieldWidgetCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFForm Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFForm Class
Defines a form in a PDF document.
Object Model
PDFForm ClassPDFDocument ClassPDFFieldCollection ClassPDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFForm
'Usage

Dim instance As PDFForm
public class PDFForm
public __gc class PDFForm
public ref class PDFForm
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFForm Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFForm Class

The following tables list the members exposed by PDFForm.

Public Properties
 | Name | Description
Public Property | Document | Gets the document that includes this form.
Public Property | Fields | Gets the list of fields included in the form.
Public Property | NeedAppearances | Gets or sets a value indicating whether the viewer application needs to rebuild the field appearance upon form loading.
Top
Public Methods
 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top
See Also

Reference

PDFForm Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFForm Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFForm Class

For a list of all members of this type, see PDFForm members.

Public Methods
 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top
See Also

Reference

PDFForm Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

ExportData Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class : ExportData Method
Exports the form data to a file.
Overload List
Overload | Description
ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) | Exports the form data to a file.
ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) | Exports the form data to a stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


%%ItemTitle%%

ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ExportData Method : ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) Method
The full path to the file where form data will be exported.
The format of exported data.
Options for specifying the type of data to be exported.
The name of the PDF file the data is exported from.
Exports the form data to a file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ExportData( _
   ByVal fileName As String, _
   ByVal format As PDFFormDataFormat, _
   ByVal options As PDFExportDataOptions, _
   ByVal pdfFileName As String _
)
'Usage

Dim instance As PDFForm
Dim fileName As String
Dim format As PDFFormDataFormat
Dim options As PDFExportDataOptions
Dim pdfFileName As String

instance.ExportData(fileName, format, options, pdfFileName)
public void ExportData(
   string fileName,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string pdfFileName
)
public: void ExportData(
   string* fileName,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string* pdfFileName
)
public:
void ExportData(
   String^ fileName,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   String^ pdfFileName
)

Parameters

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFileName
The name of the PDF file the data is exported from.
Remarks
The name of the source PDF file is required because the data files (both FDF and XFDF) need a reference to the PDF file from which they were exported. This file name does not need to match the actual file name used for saving the PDF document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%ItemTitle%%

ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ExportData Method : ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) Method
The stream where form data will be exported.
The format of exported data.
Options for specifying the type of data to be exported.
Exports the form data to a stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ExportData( _
   ByVal stream As Stream, _
   ByVal format As PDFFormDataFormat, _
   ByVal options As PDFExportDataOptions, _
   ByVal pdfFilename As String _
)
'Usage

Dim instance As PDFForm
Dim stream As Stream
Dim format As PDFFormDataFormat
Dim options As PDFExportDataOptions
Dim pdfFilename As String

instance.ExportData(stream, format, options, pdfFilename)
public void ExportData(
   Stream stream,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string pdfFilename
)
public: void ExportData(
   Stream* stream,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string* pdfFilename
)
public:
void ExportData(
   Stream^ stream,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   String^ pdfFilename
)

Parameters

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFilename
Remarks
The name of the source PDF file is required because the data files (both FDF and XFDF) need a reference to the PDF file from which they were exported. This file name does not need to match the actual file name used for saving the PDF document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%ItemTitle%%

ImportData Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class : ImportData Method
Imports form data from an external file.
Overload List
Overload | Description
ImportData(String,PDFFormDataFormat) | Imports form data from an external file.
ImportData(String,PDFFormDataFormat,Boolean) | Imports form data from an external file.
ImportData(Stream,PDFFormDataFormat) | Imports form data from an external file.
ImportData(Stream,PDFFormDataFormat,Boolean) | Imports form data from an external file.
ImportData(FDFFile) | Imports form data from a FDF file.
ImportData(FDFFile,Boolean) | Imports form data from a FDF file.
ImportData(XFDFFile) | Imports form data from a XFDF file.
ImportData(XFDFFile,Boolean) | Imports form data from a XFDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


%%ItemTitle%%

ImportData(String,PDFFormDataFormat) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(String,PDFFormDataFormat) Method
The file from which to import form data.
The format of input file.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As PDFFormDataFormat _
)
'Usage

Dim instance As PDFForm
Dim fileName As String
Dim dataFormat As PDFFormDataFormat

instance.ImportData(fileName, dataFormat)
public void ImportData(
   string fileName,
   PDFFormDataFormat dataFormat
)
public: void ImportData(
   string* fileName,
   PDFFormDataFormat dataFormat
)
public:
void ImportData(
   String^ fileName,
   PDFFormDataFormat dataFormat
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.
Exceptions
Exception | Description
O2S.Components.PDFView4NET.PDFException | thrown when the input file can not be open or read.
O2S.Components.PDFEngine.PDFObjects.PDFParserException | thrown when the input file can not be parsed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%ItemTitle%%

ImportData(String,PDFFormDataFormat,Boolean) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(String,PDFFormDataFormat,Boolean) Method
The file from which to import form data.
The format of input file.
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As PDFFormDataFormat, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
'Usage

Dim instance As PDFForm
Dim fileName As String
Dim dataFormat As PDFFormDataFormat
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(fileName, dataFormat, continueImportOnError)
public PDFFieldImportError[] ImportData(
   string fileName,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
public: PDFFieldImportError*[]* ImportData(
   string* fileName,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
public:
array<PDFFieldImportError^>^ ImportData(
   String^ fileName,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.
Exceptions
Exception | Description
O2S.Components.PDFView4NET.PDFException | thrown when the input file can not be open or read.
O2S.Components.PDFEngine.PDFObjects.PDFParserException | thrown when the input file can not be parsed.
Remarks
If no errors occured during the import, the returned array is null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%ItemTitle%%

ImportData(Stream,PDFFormDataFormat) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(Stream,PDFFormDataFormat) Method
The stream from which to import form data.
The format of input stream.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As PDFFormDataFormat _
)
'Usage

Dim instance As PDFForm
Dim stream As Stream
Dim dataFormat As PDFFormDataFormat

instance.ImportData(stream, dataFormat)
public void ImportData(
   Stream stream,
   PDFFormDataFormat dataFormat
)
public: void ImportData(
   Stream* stream,
   PDFFormDataFormat dataFormat
)
public:
void ImportData(
   Stream^ stream,
   PDFFormDataFormat dataFormat
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.
Exceptions
Exception | Description
O2S.Components.PDFView4NET.PDFException | Thrown when the input stream can not be read.
O2S.Components.PDFEngine.PDFObjects.PDFParserException | Thrown when the input stream can not be parsed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%ItemTitle%%

ImportData(Stream,PDFFormDataFormat,Boolean) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(Stream,PDFFormDataFormat,Boolean) Method
The stream from which to import form data.
The format of input stream.
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from an external file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As PDFFormDataFormat, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
'Usage

Dim instance As PDFForm
Dim stream As Stream
Dim dataFormat As PDFFormDataFormat
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(stream, dataFormat, continueImportOnError)
public PDFFieldImportError[] ImportData(
   Stream stream,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
public: PDFFieldImportError*[]* ImportData(
   Stream* stream,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
public:
array<PDFFieldImportError^>^ ImportData(
   Stream^ stream,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.
Exceptions
Exception | Description
O2S.Components.PDFView4NET.PDFException | Thrown when the input stream can not be read.
O2S.Components.PDFEngine.PDFObjects.PDFParserException | Thrown when the input stream can not be parsed.
Remarks
If no errors occured during the import, the returned array is null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%ItemTitle%%

ImportData(FDFFile) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(FDFFile) Method
A FDFFile object that stores the form data.
Imports form data from a FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal fdfFile As FDFFile _
)
'Usage

Dim instance As PDFForm
Dim fdfFile As FDFFile

instance.ImportData(fdfFile)
public void ImportData(
   FDFFile fdfFile
)
public: void ImportData(
   FDFFile* fdfFile
)
public:
void ImportData(
   FDFFile^ fdfFile
)

Parameters

fdfFile
A FDFFile object that stores the form data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%ItemTitle%%

ImportData(FDFFile,Boolean) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(FDFFile,Boolean) Method
A FDFFile object that stores the form data.
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from a FDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ImportData( _
   ByVal fdfFile As FDFFile, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
'Usage

Dim instance As PDFForm
Dim fdfFile As FDFFile
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(fdfFile, continueImportOnError)
public PDFFieldImportError[] ImportData(
   FDFFile fdfFile,
   bool continueImportOnError
)
public: PDFFieldImportError*[]* ImportData(
   FDFFile* fdfFile,
   bool continueImportOnError
)
public:
array<PDFFieldImportError^>^ ImportData(
   FDFFile^ fdfFile,
   bool continueImportOnError
)

Parameters

fdfFile
A FDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.
Remarks
If no errors occured during the import, the returned array is null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%ItemTitle%%

ImportData(XFDFFile) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(XFDFFile) Method
A XFDFFile object that stores the form data.
Imports form data from a XFDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ImportData( _
   ByVal xfdfFile As XFDFFile _
)
'Usage

Dim instance As PDFForm
Dim xfdfFile As XFDFFile

instance.ImportData(xfdfFile)
public void ImportData(
   XFDFFile xfdfFile
)
public: void ImportData(
   XFDFFile* xfdfFile
)
public:
void ImportData(
   XFDFFile^ xfdfFile
)

Parameters

xfdfFile
A XFDFFile object that stores the form data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%ItemTitle%%

ImportData(XFDFFile,Boolean) Method

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(XFDFFile,Boolean) Method
A XFDFFile object that stores the form data.
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from a XFDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ImportData( _
   ByVal xfdfFile As XFDFFile, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
'Usage

Dim instance As PDFForm
Dim xfdfFile As XFDFFile
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(xfdfFile, continueImportOnError)
public PDFFieldImportError[] ImportData(
   XFDFFile xfdfFile,
   bool continueImportOnError
)
public: PDFFieldImportError*[]* ImportData(
   XFDFFile* xfdfFile,
   bool continueImportOnError
)
public:
array<PDFFieldImportError^>^ ImportData(
   XFDFFile^ xfdfFile,
   bool continueImportOnError
)

Parameters

xfdfFile
A XFDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.
Remarks
If no errors occured during the import, the returned array is null (Nothing in VB.NET).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFForm Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFForm Class

For a list of all members of this type, see PDFForm members.

Public Properties
 | Name | Description
Public Property | Document | Gets the document that includes this form.
Public Property | Fields | Gets the list of fields included in the form.
Public Property | NeedAppearances | Gets or sets a value indicating whether the viewer application needs to rebuild the field appearance upon form loading.
Top
See Also

Reference

PDFForm Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Document Property (PDFForm)

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class : Document Property
Gets the document that includes this form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Document As PDFDocument
'Usage

Dim instance As PDFForm
Dim value As PDFDocument

value = instance.Document
public PDFDocument Document {get;}
public: __property PDFDocument* get_Document();
public:
property PDFDocument^ Document {
   PDFDocument^ get();
}

Property Value

The document that owns the form.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


%%ItemTitle%%

Fields Property (PDFForm)

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class : Fields Property
Gets the list of fields included in the form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As PDFFieldCollection
'Usage

Dim instance As PDFForm
Dim value As PDFFieldCollection

value = instance.Fields
public PDFFieldCollection Fields {get;}
public: __property PDFFieldCollection* get_Fields();
public:
property PDFFieldCollection^ Fields {
   PDFFieldCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


%%ItemTitle%%

NeedAppearances Property

O2S.Components.PDFView4NET.Forms Namespace > PDFForm Class : NeedAppearances Property
Gets or sets a value indicating whether the viewer application needs to rebuild the field appearance upon form loading.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NeedAppearances As Boolean
'Usage

Dim instance As PDFForm
Dim value As Boolean

instance.NeedAppearances = value

value = instance.NeedAppearances
public bool NeedAppearances {get; set;}
public: __property bool get_NeedAppearances();
public: __property void set_NeedAppearances(
   bool value
);
public:
property bool NeedAppearances {
   bool get();
   void set (    bool value);
}

Property Value

True if the field appearance must be rebuilt by the viewer application, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFForm Class
PDFForm Members


%%PageItemTitle%%

PDFListBoxField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFListBoxField Class
Defines a scrollable list box field for user input in the PDF file.
Object Model
PDFListBoxField ClassPDFJavaScriptAction ClassPDFForm ClassPDFJavaScriptAction ClassPDFListItemCollection ClassPDFListItem ClassPDFJavaScriptAction ClassPDFListItem ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFListBoxField
   Inherits PDFListField
'Usage

Dim instance As PDFListBoxField
public class PDFListBoxField : PDFListField
public __gc class PDFListBoxField : public PDFListField
public ref class PDFListBoxField : public PDFListField
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFListField
O2S.Components.PDFView4NET.Forms.PDFListBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListBoxField Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFListBoxField Class

The following tables list the members exposed by PDFListBoxField.

Public Constructors
 | Name | Description
Public Constructor | PDFListBoxField Constructor | Initializes a new PDFListBoxField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFListBoxField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFListBoxField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFListBoxField Class : PDFListBoxField Constructor
The name of this field object.
Initializes a new PDFListBoxField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFListBoxField(name)
public PDFListBoxField(
   string name
)
public: PDFListBoxField(
   string* name
)
public:
PDFListBoxField(
   String^ name
)

Parameters

name
The name of this field object.
Remarks
The field name must be unique across the document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxField Class
PDFListBoxField Members


%%PageItemTitle%%

PDFListBoxWidget Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFListBoxWidget Class
Defines the widget for a listbox field.
Object Model
PDFListBoxWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFRgbColor ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFListBoxWidget
   Inherits PDFFieldWidget
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFListBoxWidget
public class PDFListBoxWidget : PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFListBoxWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFListBoxWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
Remarks
The field widget is the field's visual representation on a PDF page. A textbox field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFListBoxWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxWidget Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListBoxWidget Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Forms Namespace : PDFListBoxWidget Class

The following tables list the members exposed by PDFListBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFListBoxWidget Constructor | Initializes a new PDFListBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFListBoxWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFListBoxWidget Class : PDFListBoxWidget Constructor
Initializes a new PDFListBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFListBoxWidget()
public PDFListBoxWidget()
public: PDFListBoxWidget();
public:
PDFListBoxWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxWidget Class
PDFListBoxWidget Members


%%PageItemTitle%%

PDFListField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFListField Class
Base class for all list type fields.
Object Model
PDFListField ClassPDFJavaScriptAction ClassPDFForm ClassPDFJavaScriptAction ClassPDFListItemCollection ClassPDFListItem ClassPDFJavaScriptAction ClassPDFListItem ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFListField
   Inherits PDFField
'Usage

Dim instance As PDFListField
public abstract class PDFListField : PDFField
public __gc abstract class PDFListField : public PDFField
public ref class PDFListField abstract : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFListField
O2S.Components.PDFView4NET.Forms.PDFDropDownListField
O2S.Components.PDFView4NET.Forms.PDFListBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListField Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFListField Class

The following tables list the members exposed by PDFListField.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFListField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFListField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFListField Class

For a list of all members of this type, see PDFListField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFListField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

CommitOnSelChange Property

O2S.Components.PDFView4NET.Forms Namespace > PDFListField Class : CommitOnSelChange Property
Gets or sets whether the selected item is commited as soon as the selection is made.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CommitOnSelChange As Boolean
'Usage

Dim instance As PDFListField
Dim value As Boolean

instance.CommitOnSelChange = value

value = instance.CommitOnSelChange
public bool CommitOnSelChange {get; set;}
public: __property bool get_CommitOnSelChange();
public: __property void set_CommitOnSelChange(
   bool value
);
public:
property bool CommitOnSelChange {
   bool get();
   void set (    bool value);
}

Property Value

True if the selected item is commited as soon as the selection is made, false otherwise. Default is false.
Remarks
If set, the new value is committed as soon as a selection is made with the pointing device. This option enables applications to perform an action once a selection is made, without requiring the user to exit the field. If clear, the new value is not committed until the user exits the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


%%ItemTitle%%

Items Property

O2S.Components.PDFView4NET.Forms Namespace > PDFListField Class : Items Property
Gets the collection of items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Items As PDFListItemCollection
'Usage

Dim instance As PDFListField
Dim value As PDFListItemCollection

value = instance.Items
public PDFListItemCollection Items {get;}
public: __property PDFListItemCollection* get_Items();
public:
property PDFListItemCollection^ Items {
   PDFListItemCollection^ get();
}

Property Value

A PDFListItemCollection that represents the items within the list.
Remarks
Use this property to get the properties of items in the list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


%%ItemTitle%%

SelectedIndex Property (PDFListField)

O2S.Components.PDFView4NET.Forms Namespace > PDFListField Class : SelectedIndex Property
Gets or sets the lowest ordinal index of the selected items in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedIndex As Integer
'Usage

Dim instance As PDFListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
public int SelectedIndex {get; set;}
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
public:
property int SelectedIndex {
   int get();
   void set (    int value);
}

Property Value

The lowest ordinal index of the selected items in the list. The default is -1, which indicates that nothing is selected.
Remarks
Use this property to determine the index of the currently selected item in the list if the list control allows only one selection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


%%ItemTitle%%

SelectedItem Property

O2S.Components.PDFView4NET.Forms Namespace > PDFListField Class : SelectedItem Property
Gets or sets the first selected item in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedItem As PDFListItem
'Usage

Dim instance As PDFListField
Dim value As PDFListItem

instance.SelectedItem = value

value = instance.SelectedItem
public PDFListItem SelectedItem {get; set;}
public: __property PDFListItem* get_SelectedItem();
public: __property void set_SelectedItem(
   PDFListItem* value
);
public:
property PDFListItem^ SelectedItem {
   PDFListItem^ get();
   void set (    PDFListItem^ value);
}

Property Value

A PDFListItem object specifying the first selected item.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The item does not exist in the list.
Remarks
null (Nothing in VB.NET) means that no item is selected.
If the item does not exist in the list, an exception is thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


%%ItemTitle%%

SelectedValue Property (PDFListField)

O2S.Components.PDFView4NET.Forms Namespace > PDFListField Class : SelectedValue Property
Gets or sets the value of the first selected item in the list.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedValue As String
'Usage

Dim instance As PDFListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
public string SelectedValue {get; set;}
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
public:
property String^ SelectedValue {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the value of the first selected item, null (Nothing in VB.NET) if there is no selected item.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The value does not exist in field's set of values.
Remarks
When setting the selected value, if the value does not exist in the list, an exception is thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


%%ItemTitle%%

Sort Property

O2S.Components.PDFView4NET.Forms Namespace > PDFListField Class : Sort Property
Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Sort As Boolean
'Usage

Dim instance As PDFListField
Dim value As Boolean

instance.Sort = value

value = instance.Sort
public bool Sort {get; set;}
public: __property bool get_Sort();
public: __property void set_Sort(
   bool value
);
public:
property bool Sort {
   bool get();
   void set (    bool value);
}

Property Value

True if the items are sorted, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListField Class
PDFListField Members


%%PageItemTitle%%

PDFListItem Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFListItem Class
Defines an item in a list.
Object Model
PDFListItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFListItem
'Usage

Dim instance As PDFListItem
public class PDFListItem
public __gc class PDFListItem
public ref class PDFListItem
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFListItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListItem Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFListItem Class

The following tables list the members exposed by PDFListItem.

Public Constructors
 | Name | Description
Public Constructor | PDFListItem Constructor | Initialzies a new PDFListItem object.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the item.
Public Property | Value | Gets or sets the value of the item.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new PDFListItem object.
Public Method | ToString | Gets the string representation of this object.
Top
See Also

Reference

PDFListItem Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFListItem Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFListItem Class : PDFListItem Constructor
The item name, it is displayed in the list.
The item value, it is exported when form content is exported.
Initialzies a new PDFListItem object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal value As String _
)
'Usage

Dim name As String
Dim value As String

Dim instance As New PDFListItem(name, value)
public PDFListItem(
   string name,
   string value
)
public: PDFListItem(
   string* name,
   string* value
)
public:
PDFListItem(
   String^ name,
   String^ value
)

Parameters

name
The item name, it is displayed in the list.
value
The item value, it is exported when form content is exported.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the item value is null or empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%% $$Methods$$

PDFListItem Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFListItem Class

For a list of all members of this type, see PDFListItem members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new PDFListItem object.
Public Method | ToString | Gets the string representation of this object.
Top
See Also

Reference

PDFListItem Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Create Method

O2S.Components.PDFView4NET.Forms Namespace > PDFListItem Class : Create Method
The item name, it is displayed in the list.
The item value, it is exported when form content is exported.
Creates a new PDFListItem object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Create( _
   ByVal name As String, _
   ByVal value As String _
) As PDFListItem
'Usage

Dim name As String
Dim value As String
Dim value As PDFListItem

value = PDFListItem.Create(name, value)
public static PDFListItem Create(
   string name,
   string value
)
public: static PDFListItem* Create(
   string* name,
   string* value
)
public:
static PDFListItem^ Create(
   String^ name,
   String^ value
)

Parameters

name
The item name, it is displayed in the list.
value
The item value, it is exported when form content is exported.

Return Value

A PDFListItem object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Class
PDFListItem Members


%%ItemTitle%%

ToString Method (PDFListItem)

O2S.Components.PDFView4NET.Forms Namespace > PDFListItem Class : ToString Method
Gets the string representation of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFListItem
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%% $$Properties$$

PDFListItem Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFListItem Class

For a list of all members of this type, see PDFListItem members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the item.
Public Property | Value | Gets or sets the value of the item.
Top
See Also

Reference

PDFListItem Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Name Property (PDFListItem)

O2S.Components.PDFView4NET.Forms Namespace > PDFListItem Class : Name Property
Gets or sets the name of the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PDFListItem
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the name of the item.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Class
PDFListItem Members


%%ItemTitle%%

Value Property (PDFListItem)

O2S.Components.PDFView4NET.Forms Namespace > PDFListItem Class : Value Property
Gets or sets the value of the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As String
'Usage

Dim instance As PDFListItem
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the value of the item.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItem Class
PDFListItem Members


%%PageItemTitle%%

PDFListItemCollection Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFListItemCollection Class
Defines a collection of list items.
Object Model
PDFListItemCollection ClassPDFListItem Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFListItemCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of PDFListItem,PDFListField)
'Usage

Dim instance As PDFListItemCollection
public class PDFListItemCollection : O2S.Components.PDFView4NET.PDFCollection<PDFListItem,PDFListField>
public __gc class PDFListItemCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFListItem,PDFListField>
public ref class PDFListItemCollection : public O2S.Components.PDFView4NET.PDFCollection<PDFListItem,PDFListField>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Forms.PDFListItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListItemCollection Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFListItemCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFListItemCollection Class

The following tables list the members exposed by PDFListItemCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFListItem,PDFListField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top
See Also

Reference

PDFListItemCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonField Class
Defines a pushbutton in a PDF form.
Object Model
PDFPushButtonField ClassPDFJavaScriptAction ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPushButtonField
   Inherits PDFField
'Usage

Dim instance As PDFPushButtonField
public class PDFPushButtonField : PDFField
public __gc class PDFPushButtonField : public PDFField
public ref class PDFPushButtonField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFPushButtonField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFPushButtonField Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonField Class

The following tables list the members exposed by PDFPushButtonField.

Public Constructors
 | Name | Description
Public Constructor | PDFPushButtonField Constructor | Initializes a new PDFPushButtonField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Caption | Gets the button caption.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Tooltip | Overridden. Gets or sets the field tooltip.
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFPushButtonField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonField Class : PDFPushButtonField Constructor
The name of the pushbutton field
Initializes a new PDFPushButtonField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFPushButtonField(name)
public PDFPushButtonField(
   string name
)
public: PDFPushButtonField(
   string* name
)
public:
PDFPushButtonField(
   String^ name
)

Parameters

name
The name of the pushbutton field
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


%%PageItemTitle%% $$Properties$$

PDFPushButtonField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonField Class

For a list of all members of this type, see PDFPushButtonField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Caption | Gets the button caption.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Tooltip | Overridden. Gets or sets the field tooltip.
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFPushButtonField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Caption Property (PDFPushButtonField)

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonField Class : Caption Property
Gets the button caption.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Caption As String
'Usage

Dim instance As PDFPushButtonField
Dim value As String

value = instance.Caption
public string Caption {get;}
public: __property string* get_Caption();
public:
property String^ Caption {
   String^ get();
}

Property Value

The text displayed on the button.
Remarks
If the button has multiple widgets, this property returns the caption defined on the first widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


%%ItemTitle%%

Tooltip Property (PDFPushButtonField)

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonField Class : Tooltip Property
Gets or sets the field tooltip.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Tooltip As String
'Usage

Dim instance As PDFPushButtonField
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
public override string Tooltip {get; set;}
public: __property string* get_Tooltip() override;
public: __property void set_Tooltip(
   string* value
) override;
public:
property String^ Tooltip {
   String^ get() override;
   void set (    String^ value) override;
}

Property Value

The field's tooltip.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


%%PageItemTitle%%

PDFPushButtonWidget Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonWidget Class
Defines the widget for a pushbutton field.
Object Model
PDFPushButtonWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFRgbColor ClassPDFAnnotationAppearance ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFAnnotationAppearance ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPushButtonWidget
   Inherits PDFFieldWidget
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFPushButtonWidget
public class PDFPushButtonWidget : PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFPushButtonWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFPushButtonWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
Remarks
The field widget is the field's visual representation on a PDF page. A pushbutton field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFPushButtonWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFPushButtonWidget Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonWidget Class

The following tables list the members exposed by PDFPushButtonWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFPushButtonWidget Constructor | Initializes a new PDFPushButtonWidget object.
Top
Public Properties
 | Name | Description
Public Property | Align | Gets or sets the caption alignment on the button.
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Caption | Gets or sets the widget's caption.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DownAppearance | Gets or sets the down widget appearance.
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | HighlightMode | Gets or sets the highlighting mode of the button widget.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | RolloverAppearance | Gets or sets the rollover widget appearance.
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonWidget Class : PDFPushButtonWidget Constructor
Initializes a new PDFPushButtonWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPushButtonWidget()
public PDFPushButtonWidget()
public: PDFPushButtonWidget();
public:
PDFPushButtonWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%PageItemTitle%% $$Properties$$

PDFPushButtonWidget Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonWidget Class

For a list of all members of this type, see PDFPushButtonWidget members.

Public Properties
 | Name | Description
Public Property | Align | Gets or sets the caption alignment on the button.
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Caption | Gets or sets the widget's caption.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DownAppearance | Gets or sets the down widget appearance.
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | HighlightMode | Gets or sets the highlighting mode of the button widget.
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | RolloverAppearance | Gets or sets the rollover widget appearance.
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Align Property (PDFPushButtonWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonWidget Class : Align Property
Gets or sets the caption alignment on the button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Align As PDFFieldTextAlign
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFFieldTextAlign

instance.Align = value

value = instance.Align
public PDFFieldTextAlign Align {get; set;}
public: __property PDFFieldTextAlign get_Align();
public: __property void set_Align(
   PDFFieldTextAlign value
);
public:
property PDFFieldTextAlign Align {
   PDFFieldTextAlign get();
   void set (    PDFFieldTextAlign value);
}

Property Value

A PDFFieldTextAlign enumeration member specifying the caption alignment on the button.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%ItemTitle%%

Caption Property (PDFPushButtonWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonWidget Class : Caption Property
Gets or sets the widget's caption.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Caption As String
'Usage

Dim instance As PDFPushButtonWidget
Dim value As String

instance.Caption = value

value = instance.Caption
public string Caption {get; set;}
public: __property string* get_Caption();
public: __property void set_Caption(
   string* value
);
public:
property String^ Caption {
   String^ get();
   void set (    String^ value);
}

Property Value

The caption of pushbutton's widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%ItemTitle%%

DownAppearance Property

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonWidget Class : DownAppearance Property
Gets or sets the down widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DownAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFAnnotationAppearance

instance.DownAppearance = value

value = instance.DownAppearance
public PDFAnnotationAppearance DownAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_DownAppearance();
public: __property void set_DownAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ DownAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The down appearance of the field widget.
Remarks
This appearance is displayed when the mouse is clicked on the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%ItemTitle%%

HighlightMode Property

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonWidget Class : HighlightMode Property
Gets or sets the highlighting mode of the button widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighlightMode As PDFPushButtonHighlightMode
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFPushButtonHighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
public PDFPushButtonHighlightMode HighlightMode {get; set;}
public: __property PDFPushButtonHighlightMode get_HighlightMode();
public: __property void set_HighlightMode(
   PDFPushButtonHighlightMode value
);
public:
property PDFPushButtonHighlightMode HighlightMode {
   PDFPushButtonHighlightMode get();
   void set (    PDFPushButtonHighlightMode value);
}

Property Value

A PDFPushButtonHighlightMode enumeration member specifying the highlighting mode for the button widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%ItemTitle%%

PDFRectangle Property (PDFPushButtonWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonWidget Class : PDFRectangle Property
Gets or sets the annotation rectangle in PDF coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PDFRectangle As PDFRectangle
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
public override PDFRectangle PDFRectangle {get; set;}
public: __property PDFRectangle* get_PDFRectangle() override;
public: __property void set_PDFRectangle(
   PDFRectangle* value
) override;
public:
property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get() override;
   void set (    PDFRectangle^ value) override;
}

Property Value

The annotation rectangle specified in the default PDF coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%ItemTitle%%

RolloverAppearance Property

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonWidget Class : RolloverAppearance Property
Gets or sets the rollover widget appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RolloverAppearance As PDFAnnotationAppearance
'Usage

Dim instance As PDFPushButtonWidget
Dim value As PDFAnnotationAppearance

instance.RolloverAppearance = value

value = instance.RolloverAppearance
public PDFAnnotationAppearance RolloverAppearance {get; set;}
public: __property PDFAnnotationAppearance* get_RolloverAppearance();
public: __property void set_RolloverAppearance(
   PDFAnnotationAppearance* value
);
public:
property PDFAnnotationAppearance^ RolloverAppearance {
   PDFAnnotationAppearance^ get();
   void set (    PDFAnnotationAppearance^ value);
}

Property Value

The rollover appearance of the field widget.
Remarks
This appearance is displayed when the mouse is over the widget.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%PageItemTitle%%

PDFRadioButtonItem Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFRadioButtonItem Class
Defines the widget for a radio button.
Object Model
PDFRadioButtonItem ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFRgbColor ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFDeviceColor ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance ClassPDFAnnotationAppearance Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRadioButtonItem
   Inherits PDFCheckWidget
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFRadioButtonItem
public class PDFRadioButtonItem : PDFCheckWidget, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFRadioButtonItem : public PDFCheckWidget, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFRadioButtonItem : public PDFCheckWidget, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFCheckWidget
O2S.Components.PDFView4NET.Forms.PDFRadioButtonItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonItem Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFRadioButtonItem Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Forms Namespace : PDFRadioButtonItem Class

The following tables list the members exposed by PDFRadioButtonItem.

Public Constructors
 | Name | Description
Public Constructor | PDFRadioButtonItem Constructor | Initializes a new PDFRadioButtonItem object.
Top
Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonItem Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFRadioButtonItem Class : PDFRadioButtonItem Constructor
Initializes a new PDFRadioButtonItem object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRadioButtonItem()
public PDFRadioButtonItem()
public: PDFRadioButtonItem();
public:
PDFRadioButtonItem();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%%

PDFRadioButtonListField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFRadioButtonListField Class
Defines a list of radio buttons in a PDF form.
Object Model
PDFRadioButtonListField ClassPDFJavaScriptAction ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRadioButtonListField
   Inherits PDFField
'Usage

Dim instance As PDFRadioButtonListField
public class PDFRadioButtonListField : PDFField
public __gc class PDFRadioButtonListField : public PDFField
public ref class PDFRadioButtonListField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFRadioButtonListField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFRadioButtonListField Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFRadioButtonListField Class

The following tables list the members exposed by PDFRadioButtonListField.

Public Constructors
 | Name | Description
Public Constructor | PDFRadioButtonListField Constructor | Initializes a new PDFRadioButtonListField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Checked | Gets or sets a value indicating whether the radio button list is checked or not.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radiobutton should be selected all the time.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the selected radio button item.
Public Property | SelectedValue | Gets or sets the value of the selected radio button item .
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonListField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFRadioButtonListField Class : PDFRadioButtonListField Constructor
The name of the field.
Initializes a new PDFRadioButtonListField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFRadioButtonListField(name)
public PDFRadioButtonListField(
   string name
)
public: PDFRadioButtonListField(
   string* name
)
public:
PDFRadioButtonListField(
   String^ name
)

Parameters

name
The name of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%% $$Properties$$

PDFRadioButtonListField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFRadioButtonListField Class

For a list of all members of this type, see PDFRadioButtonListField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Checked | Gets or sets a value indicating whether the radio button list is checked or not.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radiobutton should be selected all the time.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the selected radio button item.
Public Property | SelectedValue | Gets or sets the value of the selected radio button item .
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Checked Property (PDFRadioButtonListField)

O2S.Components.PDFView4NET.Forms Namespace > PDFRadioButtonListField Class : Checked Property
Gets or sets a value indicating whether the radio button list is checked or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Checked As Boolean
'Usage

Dim instance As PDFRadioButtonListField
Dim value As Boolean

instance.Checked = value

value = instance.Checked
public bool Checked {get; set;}
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
public:
property bool Checked {
   bool get();
   void set (    bool value);
}

Property Value

True if at least one radio button widget is checked, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%ItemTitle%%

NoToggleToOff Property

O2S.Components.PDFView4NET.Forms Namespace > PDFRadioButtonListField Class : NoToggleToOff Property
Gets or sets a value indicating whether a radiobutton should be selected all the time.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NoToggleToOff As Boolean
'Usage

Dim instance As PDFRadioButtonListField
Dim value As Boolean

instance.NoToggleToOff = value

value = instance.NoToggleToOff
public bool NoToggleToOff {get; set;}
public: __property bool get_NoToggleToOff();
public: __property void set_NoToggleToOff(
   bool value
);
public:
property bool NoToggleToOff {
   bool get();
   void set (    bool value);
}

Property Value

True if a radiobutton should be selected all the time, otherwise false. Default is true.
Remarks
If this property is true, clicking on currently selected radiobutton has no effect. If this property is false, clicking on currently selected radiobutton deselects it, leaving no radiobutton selected.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%ItemTitle%%

SelectedIndex Property (PDFRadioButtonListField)

O2S.Components.PDFView4NET.Forms Namespace > PDFRadioButtonListField Class : SelectedIndex Property
Gets or sets the selected radio button item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedIndex As Integer
'Usage

Dim instance As PDFRadioButtonListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
public int SelectedIndex {get; set;}
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
public:
property int SelectedIndex {
   int get();
   void set (    int value);
}

Property Value

The index of the selected radio button item.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%ItemTitle%%

SelectedValue Property (PDFRadioButtonListField)

O2S.Components.PDFView4NET.Forms Namespace > PDFRadioButtonListField Class : SelectedValue Property
Gets or sets the value of the selected radio button item .
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SelectedValue As String
'Usage

Dim instance As PDFRadioButtonListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
public string SelectedValue {get; set;}
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
public:
property String^ SelectedValue {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the value of the selected item.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The value does not exist in field's set of values.
Remarks
null (Nothing in VB.NET) or "Off" means that no radio button item is selected.
When setting the selected value, if the value does not exist in the list, an exception is thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%%

PDFSignatureField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureField Class
Defines a signature field in a PDF form.
Object Model
PDFSignatureField ClassPDFJavaScriptAction ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFSignatureLockFieldAction ClassPDFDigitalSignature ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSignatureField
   Inherits PDFField
'Usage

Dim instance As PDFSignatureField
public class PDFSignatureField : PDFField
public __gc class PDFSignatureField : public PDFField
public ref class PDFSignatureField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFSignatureField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFSignatureField Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureField Class

The following tables list the members exposed by PDFSignatureField.

Public Constructors
 | Name | Description
Public Constructor | PDFSignatureField Constructor | Initializes a new PDFSignatureField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | LockFieldAction | Gets or sets the lock field action.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Signature | Gets or sets the digital signature for signing the the field.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFSignatureField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureField Class : PDFSignatureField Constructor
The name of the field.
Initializes a new PDFSignatureField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFSignatureField(name)
public PDFSignatureField(
   string name
)
public: PDFSignatureField(
   string* name
)
public:
PDFSignatureField(
   String^ name
)

Parameters

name
The name of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%PageItemTitle%% $$Properties$$

PDFSignatureField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureField Class

For a list of all members of this type, see PDFSignatureField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | LockFieldAction | Gets or sets the lock field action.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Signature | Gets or sets the digital signature for signing the the field.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFSignatureField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

LockFieldAction Property

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureField Class : LockFieldAction Property
Gets or sets the lock field action.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LockFieldAction As PDFSignatureLockFieldAction
'Usage

Dim instance As PDFSignatureField
Dim value As PDFSignatureLockFieldAction

instance.LockFieldAction = value

value = instance.LockFieldAction
public PDFSignatureLockFieldAction LockFieldAction {get; set;}
public: __property PDFSignatureLockFieldAction* get_LockFieldAction();
public: __property void set_LockFieldAction(
   PDFSignatureLockFieldAction* value
);
public:
property PDFSignatureLockFieldAction^ LockFieldAction {
   PDFSignatureLockFieldAction^ get();
   void set (    PDFSignatureLockFieldAction^ value);
}

Property Value

The lock field action to be executed when the signature field is signed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%ItemTitle%%

Signature Property

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureField Class : Signature Property
Gets or sets the digital signature for signing the the field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Signature As PDFDigitalSignature
'Usage

Dim instance As PDFSignatureField
Dim value As PDFDigitalSignature

instance.Signature = value

value = instance.Signature
public PDFDigitalSignature Signature {get; set;}
public: __property PDFDigitalSignature* get_Signature();
public: __property void set_Signature(
   PDFDigitalSignature* value
);
public:
property PDFDigitalSignature^ Signature {
   PDFDigitalSignature^ get();
   void set (    PDFDigitalSignature^ value);
}

Property Value

A O2S.Components.PDFView4NET.PDFDigitalSignature object specifying the digital signature for signing the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%PageItemTitle%%

PDFSignatureLockFieldAction Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureLockFieldAction Class
Defines the field lock action to be executed when a signature field is signed.
Object Model
PDFSignatureLockFieldAction Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSignatureLockFieldAction
'Usage

Dim instance As PDFSignatureLockFieldAction
public class PDFSignatureLockFieldAction
public __gc class PDFSignatureLockFieldAction
public ref class PDFSignatureLockFieldAction
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFSignatureLockFieldAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFSignatureLockFieldAction Class Members
Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureLockFieldAction Class

The following tables list the members exposed by PDFSignatureLockFieldAction.

Public Constructors
 | Name | Description
Public Constructor | PDFSignatureLockFieldAction Constructor | Initializes a new PDFSignatureLockFieldAction object.
Top
Public Properties
 | Name | Description
Public Property | Fields | Gets or sets the fields to be locked.
Public Property | SignatureLockFieldMode | Gets or sets the mode for applying the field lock.
Top
See Also

Reference

PDFSignatureLockFieldAction Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureLockFieldAction Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureLockFieldAction Class : PDFSignatureLockFieldAction Constructor
Initializes a new PDFSignatureLockFieldAction object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSignatureLockFieldAction()
public PDFSignatureLockFieldAction()
public: PDFSignatureLockFieldAction();
public:
PDFSignatureLockFieldAction();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


%%PageItemTitle%% $$Properties$$

PDFSignatureLockFieldAction Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureLockFieldAction Class

For a list of all members of this type, see PDFSignatureLockFieldAction members.

Public Properties
 | Name | Description
Public Property | Fields | Gets or sets the fields to be locked.
Public Property | SignatureLockFieldMode | Gets or sets the mode for applying the field lock.
Top
See Also

Reference

PDFSignatureLockFieldAction Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Fields Property (PDFSignatureLockFieldAction)

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureLockFieldAction Class : Fields Property
Gets or sets the fields to be locked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Fields As String()
'Usage

Dim instance As PDFSignatureLockFieldAction
Dim value() As String

instance.Fields = value

value = instance.Fields
public string[] Fields {get; set;}
public: __property string*[]* get_Fields();
public: __property void set_Fields(
   string*[]* value
);
public:
property array<String^>^ Fields {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

The list of fields to be locked when the signature lock is applied.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


%%ItemTitle%%

SignatureLockFieldMode Property

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureLockFieldAction Class : SignatureLockFieldMode Property
Gets or sets the mode for applying the field lock.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SignatureLockFieldMode As PDFSignatureLockFieldMode
'Usage

Dim instance As PDFSignatureLockFieldAction
Dim value As PDFSignatureLockFieldMode

instance.SignatureLockFieldMode = value

value = instance.SignatureLockFieldMode
public PDFSignatureLockFieldMode SignatureLockFieldMode {get; set;}
public: __property PDFSignatureLockFieldMode get_SignatureLockFieldMode();
public: __property void set_SignatureLockFieldMode(
   PDFSignatureLockFieldMode value
);
public:
property PDFSignatureLockFieldMode SignatureLockFieldMode {
   PDFSignatureLockFieldMode get();
   void set (    PDFSignatureLockFieldMode value);
}

Property Value

A value which, in conjunction with Fields, indicates the set of fields that should be locked.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


%%PageItemTitle%%

PDFSignatureWidget Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureWidget Class
Defines the widget for a signature field.
Object Model
PDFSignatureWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFRgbColor ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSignatureWidget
   Inherits PDFFieldWidget
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFSignatureWidget
public class PDFSignatureWidget : PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFSignatureWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFSignatureWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFSignatureWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureWidget Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFSignatureWidget Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureWidget Class

The following tables list the members exposed by PDFSignatureWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFSignatureWidget Constructor | Initializes a new PDFSignatureWidget object.
Top
Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureWidget Class : PDFSignatureWidget Constructor
Initializes a new PDFSignatureWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSignatureWidget()
public PDFSignatureWidget()
public: PDFSignatureWidget();
public:
PDFSignatureWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureWidget Class
PDFSignatureWidget Members


%%PageItemTitle%%

PDFTextBoxField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFTextBoxField Class
Defines a text box in a PDF form.
Object Model
PDFTextBoxField ClassPDFJavaScriptAction ClassPDFForm ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFJavaScriptAction ClassPDFFieldWidgetCollection ClassPDFFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextBoxField
   Inherits PDFField
'Usage

Dim instance As PDFTextBoxField
public class PDFTextBoxField : PDFField
public __gc class PDFTextBoxField : public PDFField
public ref class PDFTextBoxField : public PDFField
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFTextBoxField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFTextBoxField Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFTextBoxField Class

The following tables list the members exposed by PDFTextBoxField.

Public Constructors
 | Name | Description
Public Constructor | PDFTextBoxField Constructor | Initializes a new PDFTextBoxField object.
Top
Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | CheckSpelling | Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Public Property | Comb | Gets or sets a value indicating whether the field acts like a comb or not.
Public Property | DefaultValue | Gets or sets the field's default value.
Public Property | FileSelect | Gets or sets a value indicating whether the field can be used for selecting a file from disk.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MaxLength | Gets or sets the max length of the text that can be inserted in the field.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Password | Gets or sets a value indicating whether the field is used for entering passwords.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ScrollLongText | Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Public Property | Text | Gets or sets the field text.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFTextBoxField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFTextBoxField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : PDFTextBoxField Constructor
The name of the field.
Initializes a new PDFTextBoxField object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PDFTextBoxField(name)
public PDFTextBoxField(
   string name
)
public: PDFTextBoxField(
   string* name
)
public:
PDFTextBoxField(
   String^ name
)

Parameters

name
The name of the field.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the name is null or empty or not a valid PDF field name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%% $$Properties$$

PDFTextBoxField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFTextBoxField Class

For a list of all members of this type, see PDFTextBoxField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | CheckSpelling | Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Public Property | Comb | Gets or sets a value indicating whether the field acts like a comb or not.
Public Property | DefaultValue | Gets or sets the field's default value.
Public Property | FileSelect | Gets or sets a value indicating whether the field can be used for selecting a file from disk.
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MaxLength | Gets or sets the max length of the text that can be inserted in the field.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Password | Gets or sets a value indicating whether the field is used for entering passwords.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ScrollLongText | Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Public Property | Text | Gets or sets the field text.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFTextBoxField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

CheckSpelling Property (PDFTextBoxField)

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : CheckSpelling Property
Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckSpelling As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.CheckSpelling = value

value = instance.CheckSpelling
public bool CheckSpelling {get; set;}
public: __property bool get_CheckSpelling();
public: __property void set_CheckSpelling(
   bool value
);
public:
property bool CheckSpelling {
   bool get();
   void set (    bool value);
}

Property Value

True if the field content should be checked for spelling erorrs, false otherwise. Default is true.
Remarks
The field content is checked for spelling errors only when the PDF file is opened in the viewer (if the PDF viewer support this feature) and it is not spell checked when its value is set from code.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%ItemTitle%%

Comb Property

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : Comb Property
Gets or sets a value indicating whether the field acts like a comb or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Comb As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Comb = value

value = instance.Comb
public bool Comb {get; set;}
public: __property bool get_Comb();
public: __property void set_Comb(
   bool value
);
public:
property bool Comb {
   bool get();
   void set (    bool value);
}

Property Value

True if the field acts like a comb, otherwise false. Default is false.
Remarks
If this property is true, the field is automatically divided into as many equally spaced positions, or combs, as the value of MaxLen property and the text is laid out into those combs.
When this property is set to true, the Multiline and Password properties are automatically set to false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%ItemTitle%%

DefaultValue Property

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : DefaultValue Property
Gets or sets the field's default value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultValue As String
'Usage

Dim instance As PDFTextBoxField
Dim value As String

instance.DefaultValue = value

value = instance.DefaultValue
public string DefaultValue {get; set;}
public: __property string* get_DefaultValue();
public: __property void set_DefaultValue(
   string* value
);
public:
property String^ DefaultValue {
   String^ get();
   void set (    String^ value);
}

Property Value

The default value of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%ItemTitle%%

FileSelect Property

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : FileSelect Property
Gets or sets a value indicating whether the field can be used for selecting a file from disk.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileSelect As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.FileSelect = value

value = instance.FileSelect
public bool FileSelect {get; set;}
public: __property bool get_FileSelect();
public: __property void set_FileSelect(
   bool value
);
public:
property bool FileSelect {
   bool get();
   void set (    bool value);
}

Property Value

True if the text entered in the field represents the pathname of a file whose contents are to be submitted as the value of the field. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%ItemTitle%%

MaxLength Property

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : MaxLength Property
Gets or sets the max length of the text that can be inserted in the field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxLength As Integer
'Usage

Dim instance As PDFTextBoxField
Dim value As Integer

instance.MaxLength = value

value = instance.MaxLength
public int MaxLength {get; set;}
public: __property int get_MaxLength();
public: __property void set_MaxLength(
   int value
);
public:
property int MaxLength {
   int get();
   void set (    int value);
}

Property Value

Maximum amount of text that can be inserted in the text.
Remarks
If this property is 0, then the text length is unlimited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%ItemTitle%%

Multiline Property

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : Multiline Property
Gets or sets a value indicating whether the field is multiline.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Multiline As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Multiline = value

value = instance.Multiline
public bool Multiline {get; set;}
public: __property bool get_Multiline();
public: __property void set_Multiline(
   bool value
);
public:
property bool Multiline {
   bool get();
   void set (    bool value);
}

Property Value

True if the field is multiline, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%ItemTitle%%

Password Property (PDFTextBoxField)

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : Password Property
Gets or sets a value indicating whether the field is used for entering passwords.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Password As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Password = value

value = instance.Password
public bool Password {get; set;}
public: __property bool get_Password();
public: __property void set_Password(
   bool value
);
public:
property bool Password {
   bool get();
   void set (    bool value);
}

Property Value

True if the field is a password field, false otherwise. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%ItemTitle%%

ScrollLongText Property

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : ScrollLongText Property
Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScrollLongText As Boolean
'Usage

Dim instance As PDFTextBoxField
Dim value As Boolean

instance.ScrollLongText = value

value = instance.ScrollLongText
public bool ScrollLongText {get; set;}
public: __property bool get_ScrollLongText();
public: __property void set_ScrollLongText(
   bool value
);
public:
property bool ScrollLongText {
   bool get();
   void set (    bool value);
}

Property Value

True if the field content can be scrolled, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%ItemTitle%%

Text Property (PDFTextBoxField)

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : Text Property
Gets or sets the field text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As PDFTextBoxField
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

The text content of the field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%%

PDFTextBoxWidget Class
Members

O2S.Components.PDFView4NET.Forms Namespace : PDFTextBoxWidget Class
Defines the widget for a textbox field.
Object Model
PDFTextBoxWidget ClassPDFAnnotationAppearance ClassPDFDeviceColor ClassPDFAction ClassPDFDeviceColor ClassPDFRgbColor ClassPDFField ClassPDFAction ClassPDFFontBase ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFPage ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAction ClassPDFAnnotationReplyCollection ClassPDFMarkupAnnotation ClassPDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextBoxWidget
   Inherits PDFFieldWidget
   Implements O2S.Components.PDFView4NET.IRawPDFData
'Usage

Dim instance As PDFTextBoxWidget
public class PDFTextBoxWidget : PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public __gc class PDFTextBoxWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
public ref class PDFTextBoxWidget : public PDFFieldWidget, O2S.Components.PDFView4NET.IRawPDFData
Remarks
The field widget is the field's visual representation on a PDF page. A textbox field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFTextBoxWidget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxWidget Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

PDFTextBoxWidget Class Members
Properties Methods Events

O2S.Components.PDFView4NET.Forms Namespace : PDFTextBoxWidget Class

The following tables list the members exposed by PDFTextBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PDFTextBoxWidget Constructor | Initializes a new PDFTextBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFTextBoxWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxWidget Class : PDFTextBoxWidget Constructor
Initializes a new PDFTextBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFTextBoxWidget()
public PDFTextBoxWidget()
public: PDFTextBoxWidget();
public:
PDFTextBoxWidget();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxWidget Class
PDFTextBoxWidget Members


%%PageItemTitle%% $$Properties$$

PDFTextBoxWidget Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFTextBoxWidget Class

For a list of all members of this type, see PDFTextBoxWidget members.

Public Properties
 | Name | Description
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Align Property (PDFTextBoxWidget)

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxWidget Class : Align Property
Gets or sets the text alignment in a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Align As PDFFieldTextAlign
'Usage

Dim instance As PDFTextBoxWidget
Dim value As PDFFieldTextAlign

instance.Align = value

value = instance.Align
public PDFFieldTextAlign Align {get; set;}
public: __property PDFFieldTextAlign get_Align();
public: __property void set_Align(
   PDFFieldTextAlign value
);
public:
property PDFFieldTextAlign Align {
   PDFFieldTextAlign get();
   void set (    PDFFieldTextAlign value);
}

Property Value

A PDFFieldTextAlign enumeration member specifying the text alignment in a field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxWidget Class
PDFTextBoxWidget Members


%%PageItemTitle%%

XFDFField Class
Members

O2S.Components.PDFView4NET.Forms Namespace : XFDFField Class
Defines a field in a XFDF document.
Object Model
XFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class XFDFField
'Usage

Dim instance As XFDFField
public sealed class XFDFField
public __gc __sealed class XFDFField
public ref class XFDFField sealed
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.XFDFField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFField Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

XFDFField Class Members
Properties

O2S.Components.PDFView4NET.Forms Namespace : XFDFField Class

The following tables list the members exposed by XFDFField.

Public Properties
 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top
See Also

Reference

XFDFField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

XFDFField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : XFDFField Class

For a list of all members of this type, see XFDFField members.

Public Properties
 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top
See Also

Reference

XFDFField Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Name Property (XFDFField)

O2S.Components.PDFView4NET.Forms Namespace > XFDFField Class : Name Property
Gets the field name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As XFDFField
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

A string value specifying the name of the XFDF field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFField Class
XFDFField Members


%%ItemTitle%%

Value Property (XFDFField)

O2S.Components.PDFView4NET.Forms Namespace > XFDFField Class : Value Property
Gets the field value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As String
'Usage

Dim instance As XFDFField
Dim value As String

value = instance.Value
public string Value {get;}
public: __property string* get_Value();
public:
property String^ Value {
   String^ get();
}

Property Value

A string value specifying the value of the XFDF field.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFField Class
XFDFField Members


%%PageItemTitle%%

XFDFFieldCollection Class
Members

O2S.Components.PDFView4NET.Forms Namespace : XFDFFieldCollection Class
Defines a collection of fields in a XFDF document.
Object Model
XFDFFieldCollection ClassXFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class XFDFFieldCollection
   Inherits O2S.Components.PDFView4NET.PDFCollection(Of XFDFField,XFDFFile)
'Usage

Dim instance As XFDFFieldCollection
public sealed class XFDFFieldCollection : O2S.Components.PDFView4NET.PDFCollection<XFDFField,XFDFFile>
public __gc __sealed class XFDFFieldCollection : public O2S.Components.PDFView4NET.PDFCollection<XFDFField,XFDFFile>
public ref class XFDFFieldCollection sealed : public O2S.Components.PDFView4NET.PDFCollection<XFDFField,XFDFFile>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Forms.XFDFFieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFieldCollection Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

XFDFFieldCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : XFDFFieldCollection Class

The following tables list the members exposed by XFDFFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<XFDFField,XFDFFile>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top
See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

XFDFFile Class
Members

O2S.Components.PDFView4NET.Forms Namespace : XFDFFile Class
Represents a XFDF file on disk.
Object Model
XFDFFile ClassXFDFFieldCollection ClassXFDFField Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XFDFFile
'Usage

Dim instance As XFDFFile
public class XFDFFile
public __gc class XFDFFile
public ref class XFDFFile
Remarks
This class defines an existing XFDF file.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Forms.XFDFFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Members
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Members$$

XFDFFile Class Members
Properties Methods

O2S.Components.PDFView4NET.Forms Namespace : XFDFFile Class

The following tables list the members exposed by XFDFFile.

Public Properties
 | Name | Description
Public Property | Fields | Gets the list of fields in the XFDF file.
Public Property | PDFFileName | Gets the name of the PDF file the XFDF file was exported from.
Top
Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a XFDFFile object from the given XFDF file.
static (Shared in Visual Basic) | FromStream | Creates a XFDFFile object from the given stream object.
Top
See Also

Reference

XFDFFile Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

XFDFFile Class Methods

O2S.Components.PDFView4NET.Forms Namespace : XFDFFile Class

For a list of all members of this type, see XFDFFile members.

Public Methods
 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a XFDFFile object from the given XFDF file.
static (Shared in Visual Basic) | FromStream | Creates a XFDFFile object from the given stream object.
Top
See Also

Reference

XFDFFile Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Close Method (XFDFFile)

O2S.Components.PDFView4NET.Forms Namespace > XFDFFile Class : Close Method
Closes the underlying pdf file and frees all resources.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As XFDFFile

instance.Close()
public void Close()
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


%%ItemTitle%%

FromFile Method (XFDFFile)

O2S.Components.PDFView4NET.Forms Namespace > XFDFFile Class : FromFile Method
the full path to a XFDF file used as source for this XFDFFile object.
Creates a XFDFFile object from the given XFDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromFile( _
   ByVal fileName As String _
) As XFDFFile
'Usage

Dim fileName As String
Dim value As XFDFFile

value = XFDFFile.FromFile(fileName)
public static XFDFFile FromFile(
   string fileName
)
public: static XFDFFile* FromFile(
   string* fileName
)
public:
static XFDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a XFDF file used as source for this XFDFFile object.

Return Value

A XFDFFile object created based on the given XFDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


%%ItemTitle%%

FromStream(Stream) Method

O2S.Components.PDFView4NET.Forms Namespace > XFDFFile Class : FromStream(Stream) Method
the stream object used as source for this XFDFFile object.
Creates a XFDFFile object from the given stream object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromStream( _
   ByVal stream As Stream _
) As XFDFFile
'Usage

Dim stream As Stream
Dim value As XFDFFile

value = XFDFFile.FromStream(stream)
public static XFDFFile FromStream(
   Stream stream
)
public: static XFDFFile* FromStream(
   Stream* stream
)
public:
static XFDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this XFDFFile object.

Return Value

A XFDFFile object created based on the given stream object.
Remarks
The stream must contain a valid XFDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


%%PageItemTitle%% $$Properties$$

XFDFFile Class Properties

O2S.Components.PDFView4NET.Forms Namespace : XFDFFile Class

For a list of all members of this type, see XFDFFile members.

Public Properties
 | Name | Description
Public Property | Fields | Gets the list of fields in the XFDF file.
Public Property | PDFFileName | Gets the name of the PDF file the XFDF file was exported from.
Top
See Also

Reference

XFDFFile Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

Fields Property (XFDFFile)

O2S.Components.PDFView4NET.Forms Namespace > XFDFFile Class : Fields Property
Gets the list of fields in the XFDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As XFDFFieldCollection
'Usage

Dim instance As XFDFFile
Dim value As XFDFFieldCollection

value = instance.Fields
public XFDFFieldCollection Fields {get;}
public: __property XFDFFieldCollection* get_Fields();
public:
property XFDFFieldCollection^ Fields {
   XFDFFieldCollection^ get();
}

Property Value

A XFDFFieldCollection object specifying the list of fields in the XFDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


%%ItemTitle%%

PDFFileName Property (XFDFFile)

O2S.Components.PDFView4NET.Forms Namespace > XFDFFile Class : PDFFileName Property
Gets the name of the PDF file the XFDF file was exported from.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PDFFileName As String
'Usage

Dim instance As XFDFFile
Dim value As String

value = instance.PDFFileName
public string PDFFileName {get;}
public: __property string* get_PDFFileName();
public:
property String^ PDFFileName {
   String^ get();
}

Property Value

A string value specifying the the name of the PDF file the XFDF file was exported from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


%%PageItemTitle%%

PDFCheckSymbolStyle Enumeration

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckSymbolStyle Enumeration
Specifies the available style for a check box and radio button items.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFCheckSymbolStyle
   Inherits System.Enum
'Usage

Dim instance As PDFCheckSymbolStyle
public enum PDFCheckSymbolStyle : System.Enum
__value public enum PDFCheckSymbolStyle : public System.Enum
public enum class PDFCheckSymbolStyle : public System.Enum
Members
Member | Description
Check | A check mark is used for the checked state.
Circle | A circle is used for the checked state.
Cross | A cross is used for the checked state.
Cross2 | A cross is used for the checked state.
Cross3 | A cross is used for the checked state.
Custom | The appearance of the check box is created from code.
Dash | A dash is used for the checked state.
Diamond | A diamond symbol is used for the checked state.
Square | A square is used for the checked state.
Star | A star is used for the checked state.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Forms.PDFCheckSymbolStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFExportDataOptions Enumeration

O2S.Components.PDFView4NET.Forms Namespace : PDFExportDataOptions Enumeration
Specifies the available export options for PDF forms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PDFExportDataOptions
   Inherits System.Enum
'Usage

Dim instance As PDFExportDataOptions
[Flags()]
public enum PDFExportDataOptions : System.Enum
[Flags()]
__value public enum PDFExportDataOptions : public System.Enum
[Flags()]
public enum class PDFExportDataOptions : public System.Enum
Members
Member | Description
FormData | Form data is exported from the PDF document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Forms.PDFExportDataOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldTextAlign Enumeration

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldTextAlign Enumeration
Specifies the available alignments for text in a field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFieldTextAlign
   Inherits System.Enum
'Usage

Dim instance As PDFFieldTextAlign
public enum PDFFieldTextAlign : System.Enum
__value public enum PDFFieldTextAlign : public System.Enum
public enum class PDFFieldTextAlign : public System.Enum
Members
Member | Description
Center | The text is center aligned
Left | The text is left aligned
Right | The text is right aligned
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Forms.PDFFieldTextAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldType Enumeration

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldType Enumeration
Specifies the available field types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFieldType
   Inherits System.Enum
'Usage

Dim instance As PDFFieldType
public enum PDFFieldType : System.Enum
__value public enum PDFFieldType : public System.Enum
public enum class PDFFieldType : public System.Enum
Members
Member | Description
CheckBox | Check box.
DropDownList | Combobox.
ListBox | List box.
PushButton | Push button.
RadioButton | Radio button list.
Signature | Signature field.
TextBox | Text box.
Unknown | Unknown.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Forms.PDFFieldType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldWidgetVisibilityStatus Enumeration

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidgetVisibilityStatus Enumeration
Specifies the available visibility states for a field widget.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFieldWidgetVisibilityStatus
   Inherits System.Enum
'Usage

Dim instance As PDFFieldWidgetVisibilityStatus
public enum PDFFieldWidgetVisibilityStatus : System.Enum
__value public enum PDFFieldWidgetVisibilityStatus : public System.Enum
public enum class PDFFieldWidgetVisibilityStatus : public System.Enum
Members
Member | Description
Hidden | The field widget is not visible on the page.
HiddenPrintable | The field widget is not visible on the page but it prints.
Visible | The field widget is visible on the page.
VisibleNonPrintable | The field widget is visible on the page but it does not print.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Forms.PDFFieldWidgetVisibilityStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFFormDataFormat Enumeration

O2S.Components.PDFView4NET.Forms Namespace : PDFFormDataFormat Enumeration
Specifies the available formats for data import/export for AcroForms.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFormDataFormat
   Inherits System.Enum
'Usage

Dim instance As PDFFormDataFormat
public enum PDFFormDataFormat : System.Enum
__value public enum PDFFormDataFormat : public System.Enum
public enum class PDFFormDataFormat : public System.Enum
Members
Member | Description
FDF | Form data is imported or exported in FDF format.
XFDF | Form data is imported or exported in XFDF format.
XML | Form data is imported or exported in XML format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Forms.PDFFormDataFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonHighlightMode Enumeration

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonHighlightMode Enumeration
Specifies the available highlighting modes for a button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFPushButtonHighlightMode
   Inherits System.Enum
'Usage

Dim instance As PDFPushButtonHighlightMode
public enum PDFPushButtonHighlightMode : System.Enum
__value public enum PDFPushButtonHighlightMode : public System.Enum
public enum class PDFPushButtonHighlightMode : public System.Enum
Members
Member | Description
Invert | Inverts the content of button's normal appearance. Rollover and down button appearances are ignored.
None | No highlighting, the button's appearance does not change when the button is pressed. Rollover and down button appearances are ignored.
Outline | Inverts the button's border. Rollover and down button appearances are ignored.
Push | Displays the button's down appearance. Rollover appearance has also effect on this mode. When this mode is used, both rollover and down appearances must be constructed from code.
Remarks
The highlight mode defines how the button's down appearance is created when the button is pressed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Forms.PDFPushButtonHighlightMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureLockFieldMode Enumeration

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureLockFieldMode Enumeration
Specifies the available lock modes for form fields when a signature lock is applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFSignatureLockFieldMode
   Inherits System.Enum
'Usage

Dim instance As PDFSignatureLockFieldMode
public enum PDFSignatureLockFieldMode : System.Enum
__value public enum PDFSignatureLockFieldMode : public System.Enum
public enum class PDFSignatureLockFieldMode : public System.Enum
Members
Member | Description
All | All fields in the form are locked.
Exclude | All the form fields are locked excepting the specified fields.
Include | Only the specified fields are locked.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Forms.PDFSignatureLockFieldMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

O2S.Components.PDFView4NET.Graphics Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFCmykColor | Defines a CMYK color, a color based on a CMYK device colorspace.
Class | PDFColor | Defines a PDF color.
Class | PDFDeviceColor | Defines a device based color.
Class | PDFGrayColor | Defines a Gray color, a color based on a Gray device colorspace.
Class | PDFRgbColor | Defines a RGB color, a color based on a RGB device colorspace.
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

PDFCmykColor Class
Members

O2S.Components.PDFView4NET.Graphics Namespace : PDFCmykColor Class
Defines a CMYK color, a color based on a CMYK device colorspace.
Object Model
PDFCmykColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCmykColor
   Inherits PDFDeviceColor
'Usage

Dim instance As PDFCmykColor
public class PDFCmykColor : PDFDeviceColor
public __gc class PDFCmykColor : public PDFDeviceColor
public ref class PDFCmykColor : public PDFDeviceColor
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.PDFColor
O2S.Components.PDFView4NET.Graphics.PDFDeviceColor
O2S.Components.PDFView4NET.Graphics.PDFCmykColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Members
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFCmykColor Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFCmykColor Class

The following tables list the members exposed by PDFCmykColor.

Public Constructors
 | Name | Description
Public Constructor | PDFCmykColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan component of the color.
Public Property | K | Gets or sets the black component of the color.
Public Property | M | Gets or sets the magenta component of the color.
Public Property | Y | Gets or sets the yellow component of the color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToGdiColor | Overloaded. Converts this color object to a GDI color object. (Inherited from O2S.Components.PDFView4NET.Graphics.PDFColor)
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFCmykColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%%

PDFCmykColor Constructor

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class : PDFCmykColor Constructor
Overload List
Overload | Description
PDFCmykColor Constructor() | Initializes a new PDFRgbColor object.
PDFCmykColor Constructor(Double,Double,Double,Double) | Initializes a new PDFCmykColor object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

PDFCmykColor Constructor()

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class > PDFCmykColor Constructor : PDFCmykColor Constructor()
Initializes a new PDFRgbColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCmykColor()
public PDFCmykColor()
public: PDFCmykColor();
public:
PDFCmykColor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members
Overload List


%%PageItemTitle%%

PDFCmykColor Constructor(Double,Double,Double,Double)

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class > PDFCmykColor Constructor : PDFCmykColor Constructor(Double,Double,Double,Double)
Cyan component of the color.
Magenta component of the color.
Yellow component of the color.
Black component of the color.
Initializes a new PDFCmykColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal c As Double, _
   ByVal m As Double, _
   ByVal y As Double, _
   ByVal k As Double _
)
'Usage

Dim c As Double
Dim m As Double
Dim y As Double
Dim k As Double

Dim instance As New PDFCmykColor(c, m, y, k)
public PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)
public: PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)
public:
PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)

Parameters

c
Cyan component of the color.
m
Magenta component of the color.
y
Yellow component of the color.
k
Black component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFCmykColor Class Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFCmykColor Class

For a list of all members of this type, see PDFCmykColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToGdiColor | Overloaded. Converts this color object to a GDI color object. (Inherited from O2S.Components.PDFView4NET.Graphics.PDFColor)
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFCmykColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%ItemTitle%%

Clone Method (PDFCmykColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFCmykColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%ItemTitle%%

Equals Method (PDFCmykColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFCmykColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%ItemTitle%%

GetHashCode Method (PDFCmykColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFCmykColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%ItemTitle%%

ToString Method (PDFCmykColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFCmykColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%% $$Properties$$

PDFCmykColor Class Properties

O2S.Components.PDFView4NET.Graphics Namespace : PDFCmykColor Class

For a list of all members of this type, see PDFCmykColor members.

Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan component of the color.
Public Property | K | Gets or sets the black component of the color.
Public Property | M | Gets or sets the magenta component of the color.
Public Property | Y | Gets or sets the yellow component of the color.
Top
See Also

Reference

PDFCmykColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%ItemTitle%%

C Property

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class : C Property
Gets or sets the cyan component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property C As Double
'Usage

Dim instance As PDFCmykColor
Dim value As Double

instance.C = value

value = instance.C
public double C {get; set;}
public: __property double get_C();
public: __property void set_C(
   double value
);
public:
property double C {
   double get();
   void set (    double value);
}

Property Value

Cyan component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%ItemTitle%%

K Property

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class : K Property
Gets or sets the black component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property K As Double
'Usage

Dim instance As PDFCmykColor
Dim value As Double

instance.K = value

value = instance.K
public double K {get; set;}
public: __property double get_K();
public: __property void set_K(
   double value
);
public:
property double K {
   double get();
   void set (    double value);
}

Property Value

Black component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%ItemTitle%%

M Property

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class : M Property
Gets or sets the magenta component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property M As Double
'Usage

Dim instance As PDFCmykColor
Dim value As Double

instance.M = value

value = instance.M
public double M {get; set;}
public: __property double get_M();
public: __property void set_M(
   double value
);
public:
property double M {
   double get();
   void set (    double value);
}

Property Value

Magenta component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%ItemTitle%%

Y Property

O2S.Components.PDFView4NET.Graphics Namespace > PDFCmykColor Class : Y Property
Gets or sets the yellow component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PDFCmykColor
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public: __property double get_Y();
public: __property void set_Y(
   double value
);
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

Yellow component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


%%PageItemTitle%%

PDFColor Class
Members

O2S.Components.PDFView4NET.Graphics Namespace : PDFColor Class
Defines a PDF color.
Object Model
PDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFColor
'Usage

Dim instance As PDFColor
public abstract class PDFColor
public __gc abstract class PDFColor
public ref class PDFColor abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.PDFColor
O2S.Components.PDFView4NET.Graphics.PDFDeviceColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Members
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFColor Class Members
Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFColor Class

The following tables list the members exposed by PDFColor.

Public Methods
 | Name | Description
Public Method | Clone | Clones this color object.
Public Method | ToGdiColor | Overloaded. Converts this color object to a GDI color object.
Top
See Also

Reference

PDFColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PDFColor Class Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFColor Class

For a list of all members of this type, see PDFColor members.

Public Methods
 | Name | Description
Public Method | Clone | Clones this color object.
Public Method | ToGdiColor | Overloaded. Converts this color object to a GDI color object.
Top
See Also

Reference

PDFColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%ItemTitle%%

Clone Method (PDFColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Clone() As Object
'Usage

Dim instance As PDFColor
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public: virtual Object* Clone();
public:
virtual Object^ Clone();

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Class
PDFColor Members


%%ItemTitle%%

ToGdiColor Method (PDFColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFColor Class : ToGdiColor Method
Converts this color object to a GDI color object.
Overload List
Overload | Description
ToGdiColor() | Converts this color object to a GDI color object.
ToGdiColor(Double) | Converts this color object to a GDI color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Class
PDFColor Members


%%ItemTitle%%

ToGdiColor() Method

O2S.Components.PDFView4NET.Graphics Namespace > PDFColor Class > ToGdiColor Method : ToGdiColor() Method
Converts this color object to a GDI color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Function ToGdiColor() As Color
'Usage

Dim instance As PDFColor
Dim value As Color

value = instance.ToGdiColor()
public virtual Color ToGdiColor()
public: virtual Color ToGdiColor();
public:
virtual Color ToGdiColor();

Return Value

GDI color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Class
PDFColor Members
Overload List


%%ItemTitle%%

ToGdiColor(Double) Method

O2S.Components.PDFView4NET.Graphics Namespace > PDFColor Class > ToGdiColor Method : ToGdiColor(Double) Method
Current alpha value.
Converts this color object to a GDI color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Function ToGdiColor( _
   ByVal alpha As Double _
) As Color
'Usage

Dim instance As PDFColor
Dim alpha As Double
Dim value As Color

value = instance.ToGdiColor(alpha)
public virtual Color ToGdiColor(
   double alpha
)
public: virtual Color ToGdiColor(
   double alpha
)
public:
virtual Color ToGdiColor(
   double alpha
)

Parameters

alpha
Current alpha value.

Return Value

GDI color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFColor Class
PDFColor Members
Overload List


%%PageItemTitle%%

PDFDeviceColor Class
Members

O2S.Components.PDFView4NET.Graphics Namespace : PDFDeviceColor Class
Defines a device based color.
Object Model
PDFDeviceColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDeviceColor
   Inherits PDFColor
'Usage

Dim instance As PDFDeviceColor
public class PDFDeviceColor : PDFColor
public __gc class PDFDeviceColor : public PDFColor
public ref class PDFDeviceColor : public PDFColor
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.PDFColor
O2S.Components.PDFView4NET.Graphics.PDFDeviceColor
O2S.Components.PDFView4NET.Graphics.PDFCmykColor
O2S.Components.PDFView4NET.Graphics.PDFGrayColor
O2S.Components.PDFView4NET.Graphics.PDFRgbColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDeviceColor Members
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFDeviceColor Class Members
Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFDeviceColor Class

The following tables list the members exposed by PDFDeviceColor.

Public Methods
 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from O2S.Components.PDFView4NET.Graphics.PDFColor)
Public Method | ToGdiColor | Overloaded. Converts this color object to a GDI color object. (Inherited from O2S.Components.PDFView4NET.Graphics.PDFColor)
Top
See Also

Reference

PDFDeviceColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%%

PDFGrayColor Class
Members

O2S.Components.PDFView4NET.Graphics Namespace : PDFGrayColor Class
Defines a Gray color, a color based on a Gray device colorspace.
Object Model
PDFGrayColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFGrayColor
   Inherits PDFDeviceColor
'Usage

Dim instance As PDFGrayColor
public class PDFGrayColor : PDFDeviceColor
public __gc class PDFGrayColor : public PDFDeviceColor
public ref class PDFGrayColor : public PDFDeviceColor
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.PDFColor
O2S.Components.PDFView4NET.Graphics.PDFDeviceColor
O2S.Components.PDFView4NET.Graphics.PDFGrayColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Members
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFGrayColor Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFGrayColor Class

The following tables list the members exposed by PDFGrayColor.

Public Constructors
 | Name | Description
Public Constructor | PDFGrayColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | G | Gets or sets the gray level of the color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToGdiColor | Overloaded. Converts this color object to a GDI color object. (Inherited from O2S.Components.PDFView4NET.Graphics.PDFColor)
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFGrayColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%%

PDFGrayColor Constructor

O2S.Components.PDFView4NET.Graphics Namespace > PDFGrayColor Class : PDFGrayColor Constructor
Overload List
Overload | Description
PDFGrayColor Constructor() | Initializes a new PDFGrayColor object.
PDFGrayColor Constructor(Double) | Initializes a new PDFGrayColor object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%%

PDFGrayColor Constructor()

O2S.Components.PDFView4NET.Graphics Namespace > PDFGrayColor Class > PDFGrayColor Constructor : PDFGrayColor Constructor()
Initializes a new PDFGrayColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFGrayColor()
public PDFGrayColor()
public: PDFGrayColor();
public:
PDFGrayColor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members
Overload List


%%PageItemTitle%%

PDFGrayColor Constructor(Double)

O2S.Components.PDFView4NET.Graphics Namespace > PDFGrayColor Class > PDFGrayColor Constructor : PDFGrayColor Constructor(Double)
Gray level of the color.
Initializes a new PDFGrayColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal g As Double _
)
'Usage

Dim g As Double

Dim instance As New PDFGrayColor(g)
public PDFGrayColor(
   double g
)
public: PDFGrayColor(
   double g
)
public:
PDFGrayColor(
   double g
)

Parameters

g
Gray level of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFGrayColor Class Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFGrayColor Class

For a list of all members of this type, see PDFGrayColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToGdiColor | Overloaded. Converts this color object to a GDI color object. (Inherited from O2S.Components.PDFView4NET.Graphics.PDFColor)
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFGrayColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%ItemTitle%%

Clone Method (PDFGrayColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFGrayColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFGrayColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%ItemTitle%%

Equals Method (PDFGrayColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFGrayColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFGrayColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%ItemTitle%%

GetHashCode Method (PDFGrayColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFGrayColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFGrayColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%ItemTitle%%

ToString Method (PDFGrayColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFGrayColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFGrayColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%% $$Properties$$

PDFGrayColor Class Properties

O2S.Components.PDFView4NET.Graphics Namespace : PDFGrayColor Class

For a list of all members of this type, see PDFGrayColor members.

Public Properties
 | Name | Description
Public Property | G | Gets or sets the gray level of the color.
Top
See Also

Reference

PDFGrayColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%ItemTitle%%

G Property (PDFGrayColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFGrayColor Class : G Property
Gets or sets the gray level of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property G As Double
'Usage

Dim instance As PDFGrayColor
Dim value As Double

instance.G = value

value = instance.G
public double G {get; set;}
public: __property double get_G();
public: __property void set_G(
   double value
);
public:
property double G {
   double get();
   void set (    double value);
}

Property Value

Gray level of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


%%PageItemTitle%%

PDFRgbColor Class
Members

O2S.Components.PDFView4NET.Graphics Namespace : PDFRgbColor Class
Defines a RGB color, a color based on a RGB device colorspace.
Object Model
PDFRgbColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRgbColor
   Inherits PDFDeviceColor
'Usage

Dim instance As PDFRgbColor
public class PDFRgbColor : PDFDeviceColor
public __gc class PDFRgbColor : public PDFDeviceColor
public ref class PDFRgbColor : public PDFDeviceColor
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.PDFColor
O2S.Components.PDFView4NET.Graphics.PDFDeviceColor
O2S.Components.PDFView4NET.Graphics.PDFRgbColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Members
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%% $$Members$$

PDFRgbColor Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFRgbColor Class

The following tables list the members exposed by PDFRgbColor.

Public Constructors
 | Name | Description
Public Constructor | PDFRgbColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | B | Gets or sets the blue component of the color.
Public Property | G | Gets or sets the green component of the color.
Public Property | R | Gets or sets the red component of the color.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToGdiColor | Overloaded. Overridden. Converts this color object to a GDI color object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFRgbColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%PageItemTitle%%

PDFRgbColor Constructor

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class : PDFRgbColor Constructor
Overload List
Overload | Description
PDFRgbColor Constructor() | Initializes a new PDFRgbColor object.
PDFRgbColor Constructor(Byte,Byte,Byte) | Initializes a new PDFRgbColor object.
PDFRgbColor Constructor(Color) | Initializes a new PDFRgbColor object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%%

PDFRgbColor Constructor()

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor()
Initializes a new PDFRgbColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRgbColor()
public PDFRgbColor()
public: PDFRgbColor();
public:
PDFRgbColor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


%%PageItemTitle%%

PDFRgbColor Constructor(Byte,Byte,Byte)

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor(Byte,Byte,Byte)
Red component of the color.
Green component of the color.
Blue component of the color.
Initializes a new PDFRgbColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal r As Byte, _
   ByVal g As Byte, _
   ByVal b As Byte _
)
'Usage

Dim r As Byte
Dim g As Byte
Dim b As Byte

Dim instance As New PDFRgbColor(r, g, b)
public PDFRgbColor(
   byte r,
   byte g,
   byte b
)
public: PDFRgbColor(
   byte r,
   byte g,
   byte b
)
public:
PDFRgbColor(
   byte r,
   byte g,
   byte b
)

Parameters

r
Red component of the color.
g
Green component of the color.
b
Blue component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


%%PageItemTitle%%

PDFRgbColor Constructor(Color)

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor(Color)
Source color.
Initializes a new PDFRgbColor object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As Color _
)
'Usage

Dim color As Color

Dim instance As New PDFRgbColor(color)
public PDFRgbColor(
   Color color
)
public: PDFRgbColor(
   Color color
)
public:
PDFRgbColor(
   Color color
)

Parameters

color
Source color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFRgbColor Class Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFRgbColor Class

For a list of all members of this type, see PDFRgbColor members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Verifies if the given object is equal to this object.
Public Method | GetHashCode | Gets the hash code of this object.
Public Method | ToGdiColor | Overloaded. Overridden. Converts this color object to a GDI color object.
Public Method | ToString | Converts the color object to string representation.
Top
See Also

Reference

PDFRgbColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%ItemTitle%%

Clone Method (PDFRgbColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class : Clone Method
Clones this color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As PDFRgbColor
Dim value As Object

value = instance.Clone()
public override object Clone()
public: Object* Clone(); override
public:
Object^ Clone(); override

Return Value

A copy of this color object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%ItemTitle%%

Equals Method (PDFRgbColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class : Equals Method
Object to verify.
Verifies if the given object is equal to this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PDFRgbColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%ItemTitle%%

GetHashCode Method (PDFRgbColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class : GetHashCode Method
Gets the hash code of this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PDFRgbColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

The hashcode of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%ItemTitle%%

ToGdiColor Method (PDFRgbColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class : ToGdiColor Method
Converts this color object to a GDI color object.
Overload List
Overload | Description
ToGdiColor(Double) | Converts this color object to a GDI color object.
ToGdiColor() | Converts this color object to a GDI color object. (Inherited from O2S.Components.PDFView4NET.Graphics.PDFColor)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%ItemTitle%%

ToGdiColor(Double) Method

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class > ToGdiColor Method : ToGdiColor(Double) Method
Current alpha value.
Converts this color object to a GDI color object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function ToGdiColor( _
   ByVal alpha As Double _
) As Color
'Usage

Dim instance As PDFRgbColor
Dim alpha As Double
Dim value As Color

value = instance.ToGdiColor(alpha)
public override Color ToGdiColor(
   double alpha
)
public: Color ToGdiColor(
   double alpha
) override
public:
Color ToGdiColor(
   double alpha
) override

Parameters

alpha
Current alpha value.

Return Value

GDI color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


%%ItemTitle%%

ToString Method (PDFRgbColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class : ToString Method
Converts the color object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFRgbColor
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The color representation in PDF format
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%PageItemTitle%% $$Properties$$

PDFRgbColor Class Properties

O2S.Components.PDFView4NET.Graphics Namespace : PDFRgbColor Class

For a list of all members of this type, see PDFRgbColor members.

Public Properties
 | Name | Description
Public Property | B | Gets or sets the blue component of the color.
Public Property | G | Gets or sets the green component of the color.
Public Property | R | Gets or sets the red component of the color.
Top
See Also

Reference

PDFRgbColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%ItemTitle%%

B Property

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class : B Property
Gets or sets the blue component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property B As Byte
'Usage

Dim instance As PDFRgbColor
Dim value As Byte

instance.B = value

value = instance.B
public byte B {get; set;}
public: __property byte get_B();
public: __property void set_B(
   byte value
);
public:
property byte B {
   byte get();
   void set (    byte value);
}

Property Value

Blue component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%ItemTitle%%

G Property (PDFRgbColor)

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class : G Property
Gets or sets the green component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property G As Byte
'Usage

Dim instance As PDFRgbColor
Dim value As Byte

instance.G = value

value = instance.G
public byte G {get; set;}
public: __property byte get_G();
public: __property void set_G(
   byte value
);
public:
property byte G {
   byte get();
   void set (    byte value);
}

Property Value

Green component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%ItemTitle%%

R Property

O2S.Components.PDFView4NET.Graphics Namespace > PDFRgbColor Class : R Property
Gets or sets the red component of the color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property R As Byte
'Usage

Dim instance As PDFRgbColor
Dim value As Byte

instance.R = value

value = instance.R
public byte R {get; set;}
public: __property byte get_R();
public: __property void set_R(
   byte value
);
public:
property byte R {
   byte get();
   void set (    byte value);
}

Property Value

Red component of the color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


%%ItemTitle%%

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | BarcodeEncodingException | Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.
Class | PDF417Barcode | Defines a PDF 417 barcode.
Class | PDFBarcode | Defines the base class for all barcode types.
Class | PDFBasePDF417Barcode | Defines the base class for all PDF 417 barcodes.
Class | PDFBidimensionalBarcode | Defines the base class for all bidimensional barcodes.
Class | PDFCodabarBarcode | Defines a Code 39 barcode.
Class | PDFCodablockFBarcode | Defines a CODABLOCK F barcode.
Class | PDFCode11Barcode | Defines a Code 11 barcode.
Class | PDFCode128ABarcode | Defines a Code 128 barcode.
Class | PDFCode128Barcode | Defines the base class for all Code 128 barcodes.
Class | PDFCode128BBarcode | Defines a Code 128 barcode.
Class | PDFCode128CBarcode | Defines a Code 128 barcode.
Class | PDFCode16KBarcode | Defines a Code 16K barcode.
Class | PDFCode25Barcode | Defines a Code 2 of 5 barcode.
Class | PDFCode25InterleavedBarcode | Defines a Code 2 of 5 barcode.
Class | PDFCode32Barcode | Defines a Code 32 barcode.
Class | PDFCode39Barcode | Defines a Code 39 barcode.
Class | PDFCode39ExtendedBarcode | Defines an extended Code 39 barcode.
Class | PDFCode93Barcode | Defines a Code 93 barcode.
Class | PDFCode93ExtendedBarcode | Defines an extended Code 93 barcode.
Class | PDFCOOP25Barcode | Defines a COOP 2 of 5 barcode.
Class | PDFDataMatrixBarcode | Defines a DataMatrix barcode.
Class | PDFEAN128Barcode | Defines a EAN 128 barcode.
Class | PDFEAN13Barcode | Defines the class for EAN-13 barcodes.
Class | PDFEAN8Barcode | Defines the class for EAN-8 barcodes.
Class | PDFEANBarcode | Defines the base class for EAN based barcodes.
Class | PDFFedExGround96Barcode | Defines a FedEx Ground 96 barcode.
Class | PDFHeightModulatedBarcode | Defines the base class for all height modulated barcodes.
Class | PDFIATA25Barcode | Defines a IATA 2 of 5 barcode.
Class | PDFIdentcodeBarcode | Defines an Identcode barcode.
Class | PDFISBNBarcode | Defines the class for ISBN barcodes.
Class | PDFISMNBarcode | Defines the class for ISMN barcodes.
Class | PDFISSNBarcode | Defines the class for ISSN barcodes.
Class | PDFJAN13Barcode | Defines the class for JAN13 barcodes.
Class | PDFKixBarcode | Defines a Kix barcode.
Class | PDFLeitcodeBarcode | Defines a Leitcode barcode.
Class | PDFMatrix25Barcode | Defines a Matrix 2 of 5 barcode.
Class | PDFMicroPDF417Barcode | Defines a Micro PDF 417 barcode.
Class | PDFMSIPlesseyBarcode | Defines a MSI/Plessey barcode.
Class | PDFPharmacodeBarcode | Defines a Pharmacode barcode.
Class | PDFPlanetBarcode | Defines a Planet barcode.
Class | PDFPostNetBarcode | Defines a PostNet barcode.
Class | PDFPZNBarcode | Defines a PZN barcode.
Class | PDFQRBarcode | Defines a QR barcode.
Class | PDFRM4SCCBarcode | Defines a RM4SCC barcode.
Class | PDFSCC14Barcode | Defines a SCC-14 barcode.
Class | PDFSingaporePostBarcode | Defines a Singapore Post barcode.
Class | PDFSSCC18Barcode | Defines a SSCC-18 barcode.
Class | PDFUnidimensionalBarcode | Defines the base class for 1D barcodes.
Class | PDFUPCABarcode | Defines the class for UPC-A barcodes.
Class | PDFUPCEBarcode | Defines the class for UPC-E barcodes.
Class | PDFUSPSFIMBarcode | Defines a USPS FIM barcode.
Class | PDFUSPSHorizontalBarcode | Defines a horizontal bars barcode.
Class | PDFUSPSPICBarcode | Defines a USPS Package Identification Code barcode.
Enumerations
 | Enumeration | Description
Enumeration | MicroPDF417SymbolSize | Specifies the available sizes for a Micro PDF417 symbol.
Enumeration | PDF417DataCompactionMode | Specifies the available data compaction modes for a PDF417 barcode.
Enumeration | PDF417ErrorCorrectionLevel | Specifies the available error correction levels for a PDF417 barcode.
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

BarcodeEncodingException Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class
Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.
Object Model
BarcodeEncodingException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BarcodeEncodingException
   Inherits System.ApplicationException
'Usage

Dim instance As BarcodeEncodingException
public class BarcodeEncodingException : System.ApplicationException
public __gc class BarcodeEncodingException : public System.ApplicationException
public ref class BarcodeEncodingException : public System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFView4NET.Graphics.Barcodes.BarcodeEncodingException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarcodeEncodingException Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

BarcodeEncodingException Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

The following tables list the members exposed by BarcodeEncodingException.

Public Constructors
 | Name | Description
Public Constructor | BarcodeEncodingException Constructor | Initializes a new BarcodeEncodingException object with the specified message.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

BarcodeEncodingException Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > BarcodeEncodingException Class : BarcodeEncodingException Constructor
The exception message.
Initializes a new BarcodeEncodingException object with the specified message.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New BarcodeEncodingException(message)
public BarcodeEncodingException(
   string message
)
public: BarcodeEncodingException(
   string* message
)
public:
BarcodeEncodingException(
   String^ message
)

Parameters

message
The exception message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BarcodeEncodingException Class
BarcodeEncodingException Members


%%PageItemTitle%%

PDF417Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDF417Barcode Class
Defines a PDF 417 barcode.
Object Model
PDF417Barcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDF417Barcode
   Inherits PDFBasePDF417Barcode
'Usage

Dim instance As PDF417Barcode
public class PDF417Barcode : PDFBasePDF417Barcode
public __gc class PDF417Barcode : public PDFBasePDF417Barcode
public ref class PDF417Barcode : public PDFBasePDF417Barcode
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDF417Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDF417Barcode Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

The following tables list the members exposed by PDF417Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDF417Barcode Constructor | Initializes a new PDF417Barcode object.
Top
Public Properties
 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Top
See Also

Reference

PDF417Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDF417Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : PDF417Barcode Constructor
Initializes a new PDF417Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDF417Barcode()
public PDF417Barcode()
public: PDF417Barcode();
public:
PDF417Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%% $$Properties$$

PDF417Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Properties
 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDF417Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

ActualColumns Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ActualColumns Property
Returns the actual number of columns used by this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ActualColumns As Integer
'Usage

Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualColumns
public int ActualColumns {get;}
public: __property int get_ActualColumns();
public:
property int ActualColumns {
   int get();
}

Property Value

An integer value specifying the actual number of columns used by this barcode.
Remarks
This value is computed automatically by the library when Columns property is 0. When Columns property is not 0, this property matches the Columns property.
This property returns -1 if a valid number of columns can not be computed for the following combination: barcode data, rows and error correction level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%ItemTitle%%

ActualRows Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ActualRows Property
Returns the actual number of rows used by this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ActualRows As Integer
'Usage

Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualRows
public int ActualRows {get;}
public: __property int get_ActualRows();
public:
property int ActualRows {
   int get();
}

Property Value

An integer value specifying the actual number of rows used by this barcode.
Remarks
This value is computed automatically by the library when Rows property is 0. When Rows property is not 0, this property matches the Rows property.
This property returns -1 if a valid number of rows can not be computed for the following combination: barcode data, columns and error correction level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%ItemTitle%%

Columns Property (PDF417Barcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : Columns Property
Gets or sets the number of columns in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Columns As Integer
'Usage

Dim instance As PDF417Barcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
public int Columns {get; set;}
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
public:
property int Columns {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of columns used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 0 or greater than 30 - OR - Throws when value is 0 and Rows is also 0.
Remarks
The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Rows property must not be 0.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%ItemTitle%%

ErrorCorrectionLevel Property (PDF417Barcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ErrorCorrectionLevel Property
Gets or sets the level of error correction used by this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
'Usage

Dim instance As PDF417Barcode
Dim value As PDF417ErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
public PDF417ErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
public: __property PDF417ErrorCorrectionLevel get_ErrorCorrectionLevel();
public: __property void set_ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
public:
property PDF417ErrorCorrectionLevel ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (    PDF417ErrorCorrectionLevel value);
}

Property Value

An PDF417ErrorCorrectionLevel enumeration member specifying the level of error correction used by this barcode.
Remarks
The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%ItemTitle%%

Rows Property (PDF417Barcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : Rows Property
Gets or sets the number of rows in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As PDF417Barcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of rows used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Columns is also 0.
Remarks
The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Columns property must not be 0.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

PDFBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBarcode Class
Defines the base class for all barcode types.
Object Model
PDFBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFBarcode
'Usage

Dim instance As PDFBarcode
public abstract class PDFBarcode
public __gc abstract class PDFBarcode
public ref class PDFBarcode abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBarcode Class

The following tables list the members exposed by PDFBarcode.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the bars color.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | Height | Gets the height in points of the barcode rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode.
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode.
Public Property | Width | Gets the width in points of the barcode rectangle.
Public Property | XDimension | Gets or sets the width in points of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top
See Also

Reference

PDFBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBarcode Class

For a list of all members of this type, see PDFBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the bars color.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | Height | Gets the height in points of the barcode rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode.
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode.
Public Property | Width | Gets the width in points of the barcode rectangle.
Public Property | XDimension | Gets or sets the width in points of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top
See Also

Reference

PDFBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

BackColor Property (PDFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BackColor Property
Gets or sets the background color of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BackColor As PDFColor
'Usage

Dim instance As PDFBarcode
Dim value As PDFColor

instance.BackColor = value

value = instance.BackColor
public PDFColor BackColor {get; set;}
public: __property PDFColor* get_BackColor();
public: __property void set_BackColor(
   PDFColor* value
);
public:
property PDFColor^ BackColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A O2S.Components.PDFView4NET.Graphics.PDFColor object specifying the background color of barcode.
Remarks
If this property is null (Nothing in VB.NET), then the barcode's background will be transparent. Default barcode background color is white.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

BarColor Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BarColor Property
Gets or sets the bars color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BarColor As PDFColor
'Usage

Dim instance As PDFBarcode
Dim value As PDFColor

instance.BarColor = value

value = instance.BarColor
public PDFColor BarColor {get; set;}
public: __property PDFColor* get_BarColor();
public: __property void set_BarColor(
   PDFColor* value
);
public:
property PDFColor^ BarColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A O2S.Components.PDFView4NET.Graphics.PDFColor object specifying the bars color.
Remarks
If this property is null (Nothing in VB.NET), then no bars are shown. Default bars color is black.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

BottomQuietZone Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BottomQuietZone Property
Gets or sets the height of the bottom quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BottomQuietZone As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.BottomQuietZone = value

value = instance.BottomQuietZone
public double BottomQuietZone {get; set;}
public: __property double get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   double value
);
public:
property double BottomQuietZone {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of the bottom quiet zone.
Remarks
The bottom quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

Data Property (PDFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Data Property
Gets or sets the string to be encoded as barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Data As String
'Usage

Dim instance As PDFBarcode
Dim value As String

instance.Data = value

value = instance.Data
public string Data {get; set;}
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
public:
property String^ Data {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the value to be encoded as barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).
Remarks
The characters allowed to be encoded are defined by each barcode type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

Height Property (PDFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Height Property
Gets the height in points of the barcode rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

value = instance.Height
public double Height {get;}
public: __property double get_Height();
public:
property double Height {
   double get();
}

Property Value

A double value specifying the height of the barcode rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

Left Property (PDFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Left Property
Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public: __property double get_Left();
public: __property void set_Left(
   double value
);
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

a double value representing the X coordinate of the top left corner of the barcode's rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

LeftQuietZone Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : LeftQuietZone Property
Gets or sets the width of the left quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LeftQuietZone As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.LeftQuietZone = value

value = instance.LeftQuietZone
public double LeftQuietZone {get; set;}
public: __property double get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   double value
);
public:
property double LeftQuietZone {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the width of the left quiet zone.
Remarks
The left quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

RightQuietZone Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : RightQuietZone Property
Gets or sets the width of the right quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RightQuietZone As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.RightQuietZone = value

value = instance.RightQuietZone
public double RightQuietZone {get; set;}
public: __property double get_RightQuietZone();
public: __property void set_RightQuietZone(
   double value
);
public:
property double RightQuietZone {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the width of the right quiet zone.
Remarks
The right quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

TextColor Property (PDFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : TextColor Property
Gets or sets the color of the barcode text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextColor As PDFColor
'Usage

Dim instance As PDFBarcode
Dim value As PDFColor

instance.TextColor = value

value = instance.TextColor
public PDFColor TextColor {get; set;}
public: __property PDFColor* get_TextColor();
public: __property void set_TextColor(
   PDFColor* value
);
public:
property PDFColor^ TextColor {
   PDFColor^ get();
   void set (    PDFColor^ value);
}

Property Value

A O2S.Components.PDFView4NET.Graphics.PDFColor object specifying the text color.
Remarks
If this property is null (Nothing in VB.NET), then no text is shown. Default text color is black.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

Top Property (PDFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Top Property
Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Top As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.Top = value

value = instance.Top
public double Top {get; set;}
public: __property double get_Top();
public: __property void set_Top(
   double value
);
public:
property double Top {
   double get();
   void set (    double value);
}

Property Value

a double value representing the Y coordinate of the top left corner of the barcode's rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

TopQuietZone Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : TopQuietZone Property
Gets or sets the height of the top quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TopQuietZone As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.TopQuietZone = value

value = instance.TopQuietZone
public double TopQuietZone {get; set;}
public: __property double get_TopQuietZone();
public: __property void set_TopQuietZone(
   double value
);
public:
property double TopQuietZone {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of the top quiet zone.
Remarks
The top quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

Width Property (PDFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Width Property
Gets the width in points of the barcode rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

value = instance.Width
public double Width {get;}
public: __property double get_Width();
public:
property double Width {
   double get();
}

Property Value

A double value specifying the width of the barcode rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

XDimension Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : XDimension Property
Gets or sets the width in points of a narrow bar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property XDimension As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.XDimension = value

value = instance.XDimension
public double XDimension {get; set;}
public: __property double get_XDimension();
public: __property void set_XDimension(
   double value
);
public:
property double XDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the width of a narrow bar.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.
Remarks
The recommended width of a narrow bar is 0.864 points, which is 12 mils (1 mil = 0.001inches). Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%ItemTitle%%

YDimension Property (PDFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBarcode Class : YDimension Property
Gets or sets the height of a bar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property YDimension As Double
'Usage

Dim instance As PDFBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
public virtual double YDimension {get; set;}
public: __property virtual double get_YDimension();
public: __property virtual void set_YDimension(
   double value
);
public:
virtual property double YDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of a bar.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcode Class
PDFBarcode Members


%%PageItemTitle%%

PDFBasePDF417Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class
Defines the base class for all PDF 417 barcodes.
Object Model
PDFBasePDF417Barcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFBasePDF417Barcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFBasePDF417Barcode
public abstract class PDFBasePDF417Barcode : PDFBidimensionalBarcode
public __gc abstract class PDFBasePDF417Barcode : public PDFBidimensionalBarcode
public ref class PDFBasePDF417Barcode abstract : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDF417Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFMicroPDF417Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasePDF417Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFBasePDF417Barcode Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

The following tables list the members exposed by PDFBasePDF417Barcode.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top
See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Methods$$

PDFBasePDF417Barcode Class Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

For a list of all members of this type, see PDFBasePDF417Barcode members.

Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top
See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

GetMaxDataLength Method

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : GetMaxDataLength Method
Calculates the length of the maximum data section that can be encoded in the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetMaxDataLength() As Integer
'Usage

Dim instance As PDFBasePDF417Barcode
Dim value As Integer

value = instance.GetMaxDataLength()
public int GetMaxDataLength()
public: int GetMaxDataLength();
public:
int GetMaxDataLength();

Return Value

The maximum length of encoded data.
Remarks
This method calculates how much of the barcode data can be actually encoded in the barcode. The encoded data is considered to start at the beginning of barcode data. The maximum length is calculated based on barcode data, error correction level and barcode rows and columns.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


%%PageItemTitle%% $$Properties$$

PDFBasePDF417Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

For a list of all members of this type, see PDFBasePDF417Barcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

CompactionMode Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : CompactionMode Property
Gets or sets the data compaction mode for this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompactionMode As PDF417DataCompactionMode
'Usage

Dim instance As PDFBasePDF417Barcode
Dim value As PDF417DataCompactionMode

instance.CompactionMode = value

value = instance.CompactionMode
public PDF417DataCompactionMode CompactionMode {get; set;}
public: __property PDF417DataCompactionMode get_CompactionMode();
public: __property void set_CompactionMode(
   PDF417DataCompactionMode value
);
public:
property PDF417DataCompactionMode CompactionMode {
   PDF417DataCompactionMode get();
   void set (    PDF417DataCompactionMode value);
}

Property Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this barcode.
Remarks
The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


%%ItemTitle%%

IsValid Property (PDFBasePDF417Barcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : IsValid Property
Gets a value indicating whether a valid barcode can be built.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsValid As Boolean
'Usage

Dim instance As PDFBasePDF417Barcode
Dim value As Boolean

value = instance.IsValid
public bool IsValid {get;}
public: __property bool get_IsValid();
public:
property bool IsValid {
   bool get();
}

Property Value

True if the barcode can be built, false otherwise.
Remarks
The following items are considered when building the barcode: barcode data, rows, columns and error correction level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


%%PageItemTitle%%

PDFBidimensionalBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class
Defines the base class for all bidimensional barcodes.
Object Model
PDFBidimensionalBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFBidimensionalBarcode
   Inherits PDFBarcode
'Usage

Dim instance As PDFBidimensionalBarcode
public abstract class PDFBidimensionalBarcode : PDFBarcode
public __gc abstract class PDFBidimensionalBarcode : public PDFBarcode
public ref class PDFBidimensionalBarcode abstract : public PDFBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCodablockFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode16KBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFDataMatrixBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFQRBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBidimensionalBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFBidimensionalBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

The following tables list the members exposed by PDFBidimensionalBarcode.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFBidimensionalBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFBidimensionalBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

For a list of all members of this type, see PDFBidimensionalBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFBidimensionalBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

AlternateData Property
Example

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFBidimensionalBarcode Class : AlternateData Property
Gets or sets the alternate data to encode as a barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AlternateData As Byte()
'Usage

Dim instance As PDFBidimensionalBarcode
Dim value() As Byte

instance.AlternateData = value

value = instance.AlternateData
public byte[] AlternateData {get; set;}
public: __property byte[]* get_AlternateData();
public: __property void set_AlternateData(
   byte[]* value
);
public:
property array<byte>^ AlternateData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array specifying the data to be encoded as a barcode.
Remarks
Barcodes were designed to work with 8bit characters. Because .NET strings are Unicode, when they are converted to 8bit characters (using Windows 1252 encoding) the Unicode characters are removed. This property allows you to specify directly the byte array to encode.
If both PDFBarcode.Data and AlternateData properties are specified, the AlternateData property is used.
Example
The following line of code shows how to encode a Unicode string:
  • C#
...
barcode.AlternateData = Encoding.Unicode.GetBytes("my unicode string");
...
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBidimensionalBarcode Class
PDFBidimensionalBarcode Members


%%PageItemTitle%%

PDFCodabarBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class
Defines a Code 39 barcode.
Object Model
PDFCodabarBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCodabarBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCodabarBarcode
public class PDFCodabarBarcode : PDFUnidimensionalBarcode
public __gc class PDFCodabarBarcode : public PDFUnidimensionalBarcode
public ref class PDFCodabarBarcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Codabar barcode: 0 1 2 3 4 5 6 7 8 9 - $ : / . +
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCodabarBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCodabarBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

The following tables list the members exposed by PDFCodabarBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCodabarBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCodabarBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCodabarBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class : PDFCodabarBarcode Constructor
Overload List
Overload | Description
PDFCodabarBarcode Constructor() | Initializes a new PDFCodabarBarcode object.
PDFCodabarBarcode Constructor(String,Double,Double) | Initializes a new PDFCodabarBarcode object.
PDFCodabarBarcode Constructor(String) | Initializes a new PDFCodabarBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members


%%PageItemTitle%%

PDFCodabarBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor()
Initializes a new PDFCodabarBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCodabarBarcode()
public PDFCodabarBarcode()
public: PDFCodabarBarcode();
public:
PDFCodabarBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


%%PageItemTitle%%

PDFCodabarBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCodabarBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCodabarBarcode(data, left, top)
public PDFCodabarBarcode(
   string data,
   double left,
   double top
)
public: PDFCodabarBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCodabarBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


%%PageItemTitle%%

PDFCodabarBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCodabarBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCodabarBarcode(data)
public PDFCodabarBarcode(
   string data
)
public: PDFCodabarBarcode(
   string* data
)
public:
PDFCodabarBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


%%PageItemTitle%%

PDFCodablockFBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class
Defines a CODABLOCK F barcode.
Object Model
PDFCodablockFBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCodablockFBarcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFCodablockFBarcode
public class PDFCodablockFBarcode : PDFBidimensionalBarcode
public __gc class PDFCodablockFBarcode : public PDFBidimensionalBarcode
public ref class PDFCodablockFBarcode : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCodablockFBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCodablockFBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

The following tables list the members exposed by PDFCodablockFBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCodablockFBarcode Constructor | Initializes a new PDFCodablockFBarcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top
See Also

Reference

PDFCodablockFBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCodablockFBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : PDFCodablockFBarcode Constructor
Initializes a new PDFCodablockFBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCodablockFBarcode()
public PDFCodablockFBarcode()
public: PDFCodablockFBarcode();
public:
PDFCodablockFBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%PageItemTitle%% $$Properties$$

PDFCodablockFBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

For a list of all members of this type, see PDFCodablockFBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top
See Also

Reference

PDFCodablockFBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

Columns Property (PDFCodablockFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : Columns Property
Gets or sets the number of columns in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Columns As Integer
'Usage

Dim instance As PDFCodablockFBarcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
public int Columns {get; set;}
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
public:
property int Columns {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of columns used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.
Remarks
The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%ItemTitle%%

Rows Property (PDFCodablockFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : Rows Property
Gets or sets the number of rows in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As PDFCodablockFBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of rows used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 2, or greater than 44.
Remarks
The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%ItemTitle%%

YDimension Property (PDFCodablockFBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : YDimension Property
Gets or sets the height of a barcode row.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property YDimension As Double
'Usage

Dim instance As PDFCodablockFBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
public new double YDimension {get; set;}
public: __property new double get_YDimension();
public: __property new void set_YDimension(
   double value
);
public:
new property double YDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of a barcode row.
Remarks
The minimum YDimension should be either 8*XDimension or 0.55*Columns+3, whichever is greater. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


%%PageItemTitle%%

PDFCode11Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class
Defines a Code 11 barcode.
Object Model
PDFCode11Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode11Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode11Barcode
public class PDFCode11Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode11Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode11Barcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Code 11 barcode: 0 1 2 3 4 5 6 7 8 9 -
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode11Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode11Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

The following tables list the members exposed by PDFCode11Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode11Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode11Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode11Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class : PDFCode11Barcode Constructor
Overload List
Overload | Description
PDFCode11Barcode Constructor() | Initializes a new PDFCode11Barcode object.
PDFCode11Barcode Constructor(String,Double,Double) | Initializes a new PDFCode11Barcode object.
PDFCode11Barcode Constructor(String) | Initializes a new PDFCode11Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members


%%PageItemTitle%%

PDFCode11Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor()
Initializes a new PDFCode11Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode11Barcode()
public PDFCode11Barcode()
public: PDFCode11Barcode();
public:
PDFCode11Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


%%PageItemTitle%%

PDFCode11Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode11Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode11Barcode(data, left, top)
public PDFCode11Barcode(
   string data,
   double left,
   double top
)
public: PDFCode11Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode11Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


%%PageItemTitle%%

PDFCode11Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode11Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode11Barcode(data)
public PDFCode11Barcode(
   string data
)
public: PDFCode11Barcode(
   string* data
)
public:
PDFCode11Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128ABarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class
Defines a Code 128 barcode.
Object Model
PDFCode128ABarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode128ABarcode
   Inherits PDFCode128Barcode
'Usage

Dim instance As PDFCode128ABarcode
public class PDFCode128ABarcode : PDFCode128Barcode
public __gc class PDFCode128ABarcode : public PDFCode128Barcode
public ref class PDFCode128ABarcode : public PDFCode128Barcode
Remarks
This class defines a Code 128 barcode using the A character set. Only the following symbols are allowed in a Code 128 A barcode: NUL (\x00) SOH (\x01) STX (\x02) ETX (\x03) EOT (\x04) ENQ (\x05) ACK (\x06) BEL (\x07) BS (\x08) HT (\x09) LF (\x0A) VT (\x0B) FF (\x0C) CR (\x0D) SO (\x0E) SI (\x0F) DLE (\x10) DC1 (\x11) DC2 (\x12) DC3 (\x13) DC4 (\x14) NAK (\x15) SYN (\x16) ETB (\x17) CAN (\x18) EM (\x19) SUB (\x1A) ESC (\x1B) FS (\x1C) GS (\x1D) RS (\x1E) US (\x1F) SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128ABarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128ABarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

The following tables list the members exposed by PDFCode128ABarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode128ABarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128ABarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128ABarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class : PDFCode128ABarcode Constructor
Overload List
Overload | Description
PDFCode128ABarcode Constructor() | Initializes a new PDFCode128ABarcode object.
PDFCode128ABarcode Constructor(String,Double,Double) | Initializes a new PDFCode128ABarcode object.
PDFCode128ABarcode Constructor(String) | Initializes a new PDFCode128ABarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members


%%PageItemTitle%%

PDFCode128ABarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor()
Initializes a new PDFCode128ABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode128ABarcode()
public PDFCode128ABarcode()
public: PDFCode128ABarcode();
public:
PDFCode128ABarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


%%PageItemTitle%%

PDFCode128ABarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128ABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode128ABarcode(data, left, top)
public PDFCode128ABarcode(
   string data,
   double left,
   double top
)
public: PDFCode128ABarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode128ABarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


%%PageItemTitle%%

PDFCode128ABarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode128ABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode128ABarcode(data)
public PDFCode128ABarcode(
   string data
)
public: PDFCode128ABarcode(
   string* data
)
public:
PDFCode128ABarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


%%PageItemTitle%%

PDFCode128Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class
Defines the base class for all Code 128 barcodes.
Object Model
PDFCode128Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode128Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode128Barcode
public class PDFCode128Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode128Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode128Barcode : public PDFUnidimensionalBarcode
Remarks
Code 128 allows to encode 102 symbols, grouped in 3 sets of symbols, A, B and C. Each symbol set is represented by its own barcode class: PDFCode128ABarcode, PDFCode128BBarcode and PDFCode128CBarcode.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128ABarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128BBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEAN128Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

The following tables list the members exposed by PDFCode128Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode128Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class : PDFCode128Barcode Constructor
Overload List
Overload | Description
PDFCode128Barcode Constructor() | Initializes a new PDFCode128Barcode object.
PDFCode128Barcode Constructor(String,Double,Double) | Initializes a new PDFCode128Barcode object.
PDFCode128Barcode Constructor(String) | Initializes a new PDFCode128Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members


%%PageItemTitle%%

PDFCode128Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor()
Initializes a new PDFCode128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode128Barcode()
public PDFCode128Barcode()
public: PDFCode128Barcode();
public:
PDFCode128Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode128Barcode(data, left, top)
public PDFCode128Barcode(
   string data,
   double left,
   double top
)
public: PDFCode128Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode128Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode128Barcode(data)
public PDFCode128Barcode(
   string data
)
public: PDFCode128Barcode(
   string* data
)
public:
PDFCode128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


%%PageItemTitle%%

PDFCode128BBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class
Defines a Code 128 barcode.
Object Model
PDFCode128BBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode128BBarcode
   Inherits PDFCode128Barcode
'Usage

Dim instance As PDFCode128BBarcode
public class PDFCode128BBarcode : PDFCode128Barcode
public __gc class PDFCode128BBarcode : public PDFCode128Barcode
public ref class PDFCode128BBarcode : public PDFCode128Barcode
Remarks
This class defines a Code 128 barcode using the B character set. Only the following symbols are allowed in a Code 128 B barcode: SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ DEL (\x7F) FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128BBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128BBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

The following tables list the members exposed by PDFCode128BBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode128BBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128BBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128BBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class : PDFCode128BBarcode Constructor
Overload List
Overload | Description
PDFCode128BBarcode Constructor() | Initializes a new PDFCode128BBarcode object.
PDFCode128BBarcode Constructor(String,Double,Double) | Initializes a new PDFCode128BBarcode object.
PDFCode128BBarcode Constructor(String) | Initializes a new PDFCode128BBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members


%%PageItemTitle%%

PDFCode128BBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor()
Initializes a new PDFCode128BBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode128BBarcode()
public PDFCode128BBarcode()
public: PDFCode128BBarcode();
public:
PDFCode128BBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128BBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128BBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode128BBarcode(data, left, top)
public PDFCode128BBarcode(
   string data,
   double left,
   double top
)
public: PDFCode128BBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode128BBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128BBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode128BBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode128BBarcode(data)
public PDFCode128BBarcode(
   string data
)
public: PDFCode128BBarcode(
   string* data
)
public:
PDFCode128BBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128CBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class
Defines a Code 128 barcode.
Object Model
PDFCode128CBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode128CBarcode
   Inherits PDFCode128Barcode
'Usage

Dim instance As PDFCode128CBarcode
public class PDFCode128CBarcode : PDFCode128Barcode
public __gc class PDFCode128CBarcode : public PDFCode128Barcode
public ref class PDFCode128CBarcode : public PDFCode128Barcode
Remarks
This class defines a Code 128 barcode using the C character set. Only the following symbols are allowed in a Code 128 C barcode: 0 1 2 3 4 5 6 7 8 9 FNC1 (\xF0).
Code 128 C encodes only numeric symbols at double density, each pair of digits is encoded using a single symbol.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFFedExGround96Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFSCC14Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFSSCC18Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUSPSPICBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode128CBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

The following tables list the members exposed by PDFCode128CBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode128CBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128CBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode128CBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class : PDFCode128CBarcode Constructor
Overload List
Overload | Description
PDFCode128CBarcode Constructor() | Initializes a new PDFCode128CBarcode object.
PDFCode128CBarcode Constructor(String,Double,Double) | Initializes a new PDFCode128CBarcode object.
PDFCode128CBarcode Constructor(String) | Initializes a new PDFCode128CBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members


%%PageItemTitle%%

PDFCode128CBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor()
Initializes a new PDFCode128CBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode128CBarcode()
public PDFCode128CBarcode()
public: PDFCode128CBarcode();
public:
PDFCode128CBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128CBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128CBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode128CBarcode(data, left, top)
public PDFCode128CBarcode(
   string data,
   double left,
   double top
)
public: PDFCode128CBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode128CBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


%%PageItemTitle%%

PDFCode128CBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode128CBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode128CBarcode(data)
public PDFCode128CBarcode(
   string data
)
public: PDFCode128CBarcode(
   string* data
)
public:
PDFCode128CBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


%%PageItemTitle%%

PDFCode16KBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class
Defines a Code 16K barcode.
Object Model
PDFCode16KBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode16KBarcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFCode16KBarcode
public class PDFCode16KBarcode : PDFBidimensionalBarcode
public __gc class PDFCode16KBarcode : public PDFBidimensionalBarcode
public ref class PDFCode16KBarcode : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode16KBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode16KBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

The following tables list the members exposed by PDFCode16KBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode16KBarcode Constructor | Initializes a new PDFCode16KBarcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top
See Also

Reference

PDFCode16KBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode16KBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : PDFCode16KBarcode Constructor
Initializes a new PDFCode16KBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode16KBarcode()
public PDFCode16KBarcode()
public: PDFCode16KBarcode();
public:
PDFCode16KBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%PageItemTitle%% $$Properties$$

PDFCode16KBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

For a list of all members of this type, see PDFCode16KBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top
See Also

Reference

PDFCode16KBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

Columns Property (PDFCode16KBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : Columns Property
Gets the number of columns in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Columns As Integer
'Usage

Dim instance As PDFCode16KBarcode
Dim value As Integer

value = instance.Columns
public int Columns {get;}
public: __property int get_Columns();
public:
property int Columns {
   int get();
}

Property Value

An integer value specifying the number of columns used by this barcode.
Remarks
A Code 16K barcode has always 5 columns.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%ItemTitle%%

Rows Property (PDFCode16KBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : Rows Property
Gets or sets the number of rows in this barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As PDFCode16KBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

An integer value specifying the number of rows used by this barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.
Remarks
The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%ItemTitle%%

YDimension Property (PDFCode16KBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : YDimension Property
Gets or sets the height of a barcode row.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property YDimension As Double
'Usage

Dim instance As PDFCode16KBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
public new double YDimension {get; set;}
public: __property new double get_YDimension();
public: __property new void set_YDimension(
   double value
);
public:
new property double YDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of a barcode row.
Remarks
A minimum YDimension of 8*XDimension is recommended for ease of scanning. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


%%PageItemTitle%%

PDFCode25Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class
Defines a Code 2 of 5 barcode.
Object Model
PDFCode25Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode25Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode25Barcode
public class PDFCode25Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode25Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode25Barcode : public PDFUnidimensionalBarcode
Remarks
Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCOOP25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFIATA25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFMatrix25Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode25Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

The following tables list the members exposed by PDFCode25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode25Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode25Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class : PDFCode25Barcode Constructor
Overload List
Overload | Description
PDFCode25Barcode Constructor() | Initializes a new PDFCode25Barcode object.
PDFCode25Barcode Constructor(String,Double,Double) | Initializes a new PDFCode25Barcode object.
PDFCode25Barcode Constructor(String) | Initializes a new PDFCode25Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members


%%PageItemTitle%%

PDFCode25Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor()
Initializes a new PDFCode25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode25Barcode()
public PDFCode25Barcode()
public: PDFCode25Barcode();
public:
PDFCode25Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


%%PageItemTitle%%

PDFCode25Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode25Barcode(data, left, top)
public PDFCode25Barcode(
   string data,
   double left,
   double top
)
public: PDFCode25Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


%%PageItemTitle%%

PDFCode25Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode25Barcode(data)
public PDFCode25Barcode(
   string data
)
public: PDFCode25Barcode(
   string* data
)
public:
PDFCode25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFCode25Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

For a list of all members of this type, see PDFCode25Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode25Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

WideToNarrowRatio Property (PDFCode25Barcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class : WideToNarrowRatio Property
Gets or sets the ratio between wide bars and narrow bars.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WideToNarrowRatio As Double
'Usage

Dim instance As PDFCode25Barcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
public double WideToNarrowRatio {get; set;}
public: __property double get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   double value
);
public:
property double WideToNarrowRatio {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the ratio between wide bars and narrow bars.
Remarks
The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members


%%PageItemTitle%%

PDFCode25InterleavedBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class
Defines a Code 2 of 5 barcode.
Object Model
PDFCode25InterleavedBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode25InterleavedBarcode
   Inherits PDFCode25Barcode
'Usage

Dim instance As PDFCode25InterleavedBarcode
public class PDFCode25InterleavedBarcode : PDFCode25Barcode
public __gc class PDFCode25InterleavedBarcode : public PDFCode25Barcode
public ref class PDFCode25InterleavedBarcode : public PDFCode25Barcode
Remarks
Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFIdentcodeBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFLeitcodeBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode25InterleavedBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

The following tables list the members exposed by PDFCode25InterleavedBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode25InterleavedBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode25InterleavedBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class : PDFCode25InterleavedBarcode Constructor
Overload List
Overload | Description
PDFCode25InterleavedBarcode Constructor() | Initializes a new PDFCode25InterleavedBarcode object.
PDFCode25InterleavedBarcode Constructor(String,Double,Double) | Initializes a new PDFCode25InterleavedBarcode object.
PDFCode25InterleavedBarcode Constructor(String) | Initializes a new PDFCode25InterleavedBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor()
Initializes a new PDFCode25InterleavedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode25InterleavedBarcode()
public PDFCode25InterleavedBarcode()
public: PDFCode25InterleavedBarcode();
public:
PDFCode25InterleavedBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode25InterleavedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode25InterleavedBarcode(data, left, top)
public PDFCode25InterleavedBarcode(
   string data,
   double left,
   double top
)
public: PDFCode25InterleavedBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode25InterleavedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode25InterleavedBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode25InterleavedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode25InterleavedBarcode(data)
public PDFCode25InterleavedBarcode(
   string data
)
public: PDFCode25InterleavedBarcode(
   string* data
)
public:
PDFCode25InterleavedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode32Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class
Defines a Code 32 barcode.
Object Model
PDFCode32Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode32Barcode
   Inherits PDFCode39Barcode
'Usage

Dim instance As PDFCode32Barcode
public class PDFCode32Barcode : PDFCode39Barcode
public __gc class PDFCode32Barcode : public PDFCode39Barcode
public ref class PDFCode32Barcode : public PDFCode39Barcode
Remarks
Only the following symbols are allowed in a Code 32 barcode: 1 2 3 4 5 6 7 8 9 0. The barcode length is 9 digits (8 user defined digits + 1 check digit).
Code 32 barcodes are also known as Italian Pharmacode barcodes.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode32Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode32Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

The following tables list the members exposed by PDFCode32Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode32Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode32Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode32Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class : PDFCode32Barcode Constructor
Overload List
Overload | Description
PDFCode32Barcode Constructor() | Initializes a new PDFCode32Barcode object.
PDFCode32Barcode Constructor(String,Double,Double) | Initializes a new PDFCode32Barcode object.
PDFCode32Barcode Constructor(String) | Initializes a new PDFCode32Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members


%%PageItemTitle%%

PDFCode32Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor()
Initializes a new PDFCode32Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode32Barcode()
public PDFCode32Barcode()
public: PDFCode32Barcode();
public:
PDFCode32Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


%%PageItemTitle%%

PDFCode32Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode32Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode32Barcode(data, left, top)
public PDFCode32Barcode(
   string data,
   double left,
   double top
)
public: PDFCode32Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode32Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


%%PageItemTitle%%

PDFCode32Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode32Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode32Barcode(data)
public PDFCode32Barcode(
   string data
)
public: PDFCode32Barcode(
   string* data
)
public:
PDFCode32Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


%%PageItemTitle%%

PDFCode39Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class
Defines a Code 39 barcode.
Object Model
PDFCode39Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode39Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode39Barcode
public class PDFCode39Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode39Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode39Barcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Code 39 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 39 Extended barcode must be used.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode32Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPZNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode39Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

The following tables list the members exposed by PDFCode39Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode39Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode39Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode39Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class : PDFCode39Barcode Constructor
Overload List
Overload | Description
PDFCode39Barcode Constructor() | Initializes a new PDFCode39Barcode object.
PDFCode39Barcode Constructor(String,Double,Double) | Initializes a new PDFCode39Barcode object.
PDFCode39Barcode Constructor(String) | Initializes a new PDFCode39Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members


%%PageItemTitle%%

PDFCode39Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor()
Initializes a new PDFCode39Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode39Barcode()
public PDFCode39Barcode()
public: PDFCode39Barcode();
public:
PDFCode39Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


%%PageItemTitle%%

PDFCode39Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode39Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode39Barcode(data, left, top)
public PDFCode39Barcode(
   string data,
   double left,
   double top
)
public: PDFCode39Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode39Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


%%PageItemTitle%%

PDFCode39Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode39Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode39Barcode(data)
public PDFCode39Barcode(
   string data
)
public: PDFCode39Barcode(
   string* data
)
public:
PDFCode39Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFCode39Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

For a list of all members of this type, see PDFCode39Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode39Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

WideToNarrowRatio Property (PDFCode39Barcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class : WideToNarrowRatio Property
Gets or sets the ratio between wide bars and narrow bars.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WideToNarrowRatio As Double
'Usage

Dim instance As PDFCode39Barcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
public double WideToNarrowRatio {get; set;}
public: __property double get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   double value
);
public:
property double WideToNarrowRatio {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the ratio between wide bars and narrow bars.
Remarks
The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members


%%PageItemTitle%%

PDFCode39ExtendedBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class
Defines an extended Code 39 barcode.
Object Model
PDFCode39ExtendedBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode39ExtendedBarcode
   Inherits PDFCode39Barcode
'Usage

Dim instance As PDFCode39ExtendedBarcode
public class PDFCode39ExtendedBarcode : PDFCode39Barcode
public __gc class PDFCode39ExtendedBarcode : public PDFCode39Barcode
public ref class PDFCode39ExtendedBarcode : public PDFCode39Barcode
Remarks
All 128 ASCII characters can be encoded in an extended Code 39 barcode.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode39ExtendedBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

The following tables list the members exposed by PDFCode39ExtendedBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode39ExtendedBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode39ExtendedBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class : PDFCode39ExtendedBarcode Constructor
Overload List
Overload | Description
PDFCode39ExtendedBarcode Constructor() | Initializes a new PDFCode39ExtendedBarcode object.
PDFCode39ExtendedBarcode Constructor(String,Double,Double) | Initializes a new PDFCode39ExtendedBarcode object.
PDFCode39ExtendedBarcode Constructor(String) | Initializes a new PDFCode39ExtendedBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor()
Initializes a new PDFCode39ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode39ExtendedBarcode()
public PDFCode39ExtendedBarcode()
public: PDFCode39ExtendedBarcode();
public:
PDFCode39ExtendedBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode39ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode39ExtendedBarcode(data, left, top)
public PDFCode39ExtendedBarcode(
   string data,
   double left,
   double top
)
public: PDFCode39ExtendedBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode39ExtendedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode39ExtendedBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode39ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode39ExtendedBarcode(data)
public PDFCode39ExtendedBarcode(
   string data
)
public: PDFCode39ExtendedBarcode(
   string* data
)
public:
PDFCode39ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode93Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class
Defines a Code 93 barcode.
Object Model
PDFCode93Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode93Barcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFCode93Barcode
public class PDFCode93Barcode : PDFUnidimensionalBarcode
public __gc class PDFCode93Barcode : public PDFUnidimensionalBarcode
public ref class PDFCode93Barcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Code 93 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 93 Extended barcode must be used.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode93Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

The following tables list the members exposed by PDFCode93Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode93Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode93Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode93Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class : PDFCode93Barcode Constructor
Overload List
Overload | Description
PDFCode93Barcode Constructor() | Initializes a new PDFCode93Barcode object.
PDFCode93Barcode Constructor(String,Double,Double) | Initializes a new PDFCode93Barcode object.
PDFCode93Barcode Constructor(String) | Initializes a new PDFCode93Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members


%%PageItemTitle%%

PDFCode93Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor()
Initializes a new PDFCode93Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode93Barcode()
public PDFCode93Barcode()
public: PDFCode93Barcode();
public:
PDFCode93Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


%%PageItemTitle%%

PDFCode93Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode93Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode93Barcode(data, left, top)
public PDFCode93Barcode(
   string data,
   double left,
   double top
)
public: PDFCode93Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCode93Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


%%PageItemTitle%%

PDFCode93Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode93Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode93Barcode(data)
public PDFCode93Barcode(
   string data
)
public: PDFCode93Barcode(
   string* data
)
public:
PDFCode93Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


%%PageItemTitle%%

PDFCode93ExtendedBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class
Defines an extended Code 93 barcode.
Object Model
PDFCode93ExtendedBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCode93ExtendedBarcode
   Inherits PDFCode93Barcode
'Usage

Dim instance As PDFCode93ExtendedBarcode
public class PDFCode93ExtendedBarcode : PDFCode93Barcode
public __gc class PDFCode93ExtendedBarcode : public PDFCode93Barcode
public ref class PDFCode93ExtendedBarcode : public PDFCode93Barcode
Remarks
All 128 ASCII characters can be encoded in an extended Code 93 barcode.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCode93ExtendedBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

The following tables list the members exposed by PDFCode93ExtendedBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCode93ExtendedBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode93ExtendedBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class : PDFCode93ExtendedBarcode Constructor
Overload List
Overload | Description
PDFCode93ExtendedBarcode Constructor() | Initializes a new PDFCode93ExtendedBarcode object.
PDFCode93ExtendedBarcode Constructor(String,Double,Double) | Initializes a new PDFCode93ExtendedBarcode object.
PDFCode93ExtendedBarcode Constructor(String) | Initializes a new PDFCode93ExtendedBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor()
Initializes a new PDFCode93ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCode93ExtendedBarcode()
public PDFCode93ExtendedBarcode()
public: PDFCode93ExtendedBarcode();
public:
PDFCode93ExtendedBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode93ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCode93ExtendedBarcode(data, left, top)
public PDFCode93ExtendedBarcode(
   string data,
   double left,
   double top
)
public: PDFCode93ExtendedBarcode(
   string* data,
   double left,
   double top
)
public:
PDFCode93ExtendedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCode93ExtendedBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFCode93ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCode93ExtendedBarcode(data)
public PDFCode93ExtendedBarcode(
   string data
)
public: PDFCode93ExtendedBarcode(
   string* data
)
public:
PDFCode93ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PDFCOOP25Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class
Defines a COOP 2 of 5 barcode.
Object Model
PDFCOOP25Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFCOOP25Barcode
   Inherits PDFCode25Barcode
'Usage

Dim instance As PDFCOOP25Barcode
public class PDFCOOP25Barcode : PDFCode25Barcode
public __gc class PDFCOOP25Barcode : public PDFCode25Barcode
public ref class PDFCOOP25Barcode : public PDFCode25Barcode
Remarks
COOP 2 of 5 is a numeric symbology. Only the following symbols are allowed in a COOP 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCOOP25Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFCOOP25Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

The following tables list the members exposed by PDFCOOP25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFCOOP25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCOOP25Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFCOOP25Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class : PDFCOOP25Barcode Constructor
Overload List
Overload | Description
PDFCOOP25Barcode Constructor() | Initializes a new PDFCOOP25Barcode object.
PDFCOOP25Barcode Constructor(String,Double,Double) | Initializes a new PDFCOOP25Barcode object.
PDFCOOP25Barcode Constructor(String) | Initializes a new PDFCOOP25Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members


%%PageItemTitle%%

PDFCOOP25Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor()
Initializes a new PDFCOOP25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFCOOP25Barcode()
public PDFCOOP25Barcode()
public: PDFCOOP25Barcode();
public:
PDFCOOP25Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


%%PageItemTitle%%

PDFCOOP25Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCOOP25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFCOOP25Barcode(data, left, top)
public PDFCOOP25Barcode(
   string data,
   double left,
   double top
)
public: PDFCOOP25Barcode(
   string* data,
   double left,
   double top
)
public:
PDFCOOP25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


%%PageItemTitle%%

PDFCOOP25Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFCOOP25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFCOOP25Barcode(data)
public PDFCOOP25Barcode(
   string data
)
public: PDFCOOP25Barcode(
   string* data
)
public:
PDFCOOP25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


%%PageItemTitle%%

PDFDataMatrixBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class
Defines a DataMatrix barcode.
Object Model
PDFDataMatrixBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFDataMatrixBarcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFDataMatrixBarcode
public class PDFDataMatrixBarcode : PDFBidimensionalBarcode
public __gc class PDFDataMatrixBarcode : public PDFBidimensionalBarcode
public ref class PDFDataMatrixBarcode : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFDataMatrixBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFDataMatrixBarcode Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

The following tables list the members exposed by PDFDataMatrixBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFDataMatrixBarcode Constructor | Initializes a new PDFDataMatrixBarcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
Public Methods
 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top
See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFDataMatrixBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : PDFDataMatrixBarcode Constructor
Initializes a new PDFDataMatrixBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFDataMatrixBarcode()
public PDFDataMatrixBarcode()
public: PDFDataMatrixBarcode();
public:
PDFDataMatrixBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%% $$Methods$$

PDFDataMatrixBarcode Class Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

For a list of all members of this type, see PDFDataMatrixBarcode members.

Public Methods
 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top
See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

Randomize253State Method

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : Randomize253State Method
The padding codeword, usually 129.
The position of the padding codeword (0 based index).
Applies the 253-state randomizing algorithm on padding values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Randomize253State( _
   ByVal padCodeword As Integer, _
   ByVal position As Integer _
) As Byte
'Usage

Dim instance As PDFDataMatrixBarcode
Dim padCodeword As Integer
Dim position As Integer
Dim value As Byte

value = instance.Randomize253State(padCodeword, position)
public byte Randomize253State(
   int padCodeword,
   int position
)
public: byte Randomize253State(
   int padCodeword,
   int position
)
public:
byte Randomize253State(
   int padCodeword,
   int position
)

Parameters

padCodeword
The padding codeword, usually 129.
position
The position of the padding codeword (0 based index).

Return Value

The randomized value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%% $$Properties$$

PDFDataMatrixBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

For a list of all members of this type, see PDFDataMatrixBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

Encoding Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : Encoding Property
Gets or sets the encoding of this DataMatrix barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Encoding As DataMatrixEncoding
'Usage

Dim instance As PDFDataMatrixBarcode
Dim value As DataMatrixEncoding

instance.Encoding = value

value = instance.Encoding
public DataMatrixEncoding Encoding {get; set;}
public: __property DataMatrixEncoding get_Encoding();
public: __property void set_Encoding(
   DataMatrixEncoding value
);
public:
property DataMatrixEncoding Encoding {
   DataMatrixEncoding get();
   void set (    DataMatrixEncoding value);
}

Property Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.
Remarks
If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then DataMatrixEncoding.Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both DataMatrixEncoding.ASCII and DataMatrixEncoding.Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the DataMatrixEncoding.Base256 encoding is the best option.
If the selected encoding is DataMatrixEncoding.Auto, then the library will select the encoding that will generate the smallest encoded data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%ItemTitle%%

SymbolSize Property (PDFDataMatrixBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : SymbolSize Property
Gets or sets the symbol size of this DataMatrix barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SymbolSize As DataMatrixSymbolSize
'Usage

Dim instance As PDFDataMatrixBarcode
Dim value As DataMatrixSymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
public DataMatrixSymbolSize SymbolSize {get; set;}
public: __property DataMatrixSymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   DataMatrixSymbolSize value
);
public:
property DataMatrixSymbolSize SymbolSize {
   DataMatrixSymbolSize get();
   void set (    DataMatrixSymbolSize value);
}

Property Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.
Remarks
If the SymbolSize is DataMatrixSymbolSize.Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


%%PageItemTitle%%

PDFEAN128Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class
Defines a EAN 128 barcode.
Object Model
PDFEAN128Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFEAN128Barcode
   Inherits PDFCode128Barcode
'Usage

Dim instance As PDFEAN128Barcode
public class PDFEAN128Barcode : PDFCode128Barcode
public __gc class PDFEAN128Barcode : public PDFCode128Barcode
public ref class PDFEAN128Barcode : public PDFCode128Barcode
Remarks
An EAN-128 barcode is a Code 128 barcode that has specific rules for interpreting the encoded data, based on an application identifier.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEAN128Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEAN128Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

The following tables list the members exposed by PDFEAN128Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFEAN128Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN128Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEAN128Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class : PDFEAN128Barcode Constructor
Overload List
Overload | Description
PDFEAN128Barcode Constructor() | Initializes a new PDFEAN128Barcode object.
PDFEAN128Barcode Constructor(String,Double,Double) | Initializes a new PDFEAN128Barcode object.
PDFEAN128Barcode Constructor(String) | Initializes a new PDFEAN128Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members


%%PageItemTitle%%

PDFEAN128Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor()
Initializes a new PDFEAN128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFEAN128Barcode()
public PDFEAN128Barcode()
public: PDFEAN128Barcode();
public:
PDFEAN128Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN128Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFEAN128Barcode(data, left, top)
public PDFEAN128Barcode(
   string data,
   double left,
   double top
)
public: PDFEAN128Barcode(
   string* data,
   double left,
   double top
)
public:
PDFEAN128Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN128Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFEAN128Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFEAN128Barcode(data)
public PDFEAN128Barcode(
   string data
)
public: PDFEAN128Barcode(
   string* data
)
public:
PDFEAN128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFEAN128Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

For a list of all members of this type, see PDFEAN128Barcode members.

Public Properties
 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN128Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

ApplicationIdentifier Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class : ApplicationIdentifier Property
Gets or sets the application identifier.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ApplicationIdentifier As String
'Usage

Dim instance As PDFEAN128Barcode
Dim value As String

instance.ApplicationIdentifier = value

value = instance.ApplicationIdentifier
public string ApplicationIdentifier {get; set;}
public: __property string* get_ApplicationIdentifier();
public: __property void set_ApplicationIdentifier(
   string* value
);
public:
property String^ ApplicationIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the application identifier.
Remarks
The application identifier defines how the barcode data should be interpreted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members


%%PageItemTitle%%

PDFEAN13Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class
Defines the class for EAN-13 barcodes.
Object Model
PDFEAN13Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFEAN13Barcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFEAN13Barcode
public class PDFEAN13Barcode : PDFEANBarcode
public __gc class PDFEAN13Barcode : public PDFEANBarcode
public ref class PDFEAN13Barcode : public PDFEANBarcode
Remarks
EAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always have 12 characters length. The 13th character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEAN13Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEAN13Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

The following tables list the members exposed by PDFEAN13Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFEAN13Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN13Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEAN13Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class : PDFEAN13Barcode Constructor
Overload List
Overload | Description
PDFEAN13Barcode Constructor() | Initializes a new PDFEAN13Barcode object.
PDFEAN13Barcode Constructor(String,Double,Double) | Initializes a new PDFEAN13Barcode object.
PDFEAN13Barcode Constructor(String) | Initializes a new PDFEAN13Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members


%%PageItemTitle%%

PDFEAN13Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor()
Initializes a new PDFEAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFEAN13Barcode()
public PDFEAN13Barcode()
public: PDFEAN13Barcode();
public:
PDFEAN13Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN13Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFEAN13Barcode(data, left, top)
public PDFEAN13Barcode(
   string data,
   double left,
   double top
)
public: PDFEAN13Barcode(
   string* data,
   double left,
   double top
)
public:
PDFEAN13Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN13Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFEAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFEAN13Barcode(data)
public PDFEAN13Barcode(
   string data
)
public: PDFEAN13Barcode(
   string* data
)
public:
PDFEAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN8Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class
Defines the class for EAN-8 barcodes.
Object Model
PDFEAN8Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFEAN8Barcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFEAN8Barcode
public class PDFEAN8Barcode : PDFEANBarcode
public __gc class PDFEAN8Barcode : public PDFEANBarcode
public ref class PDFEAN8Barcode : public PDFEANBarcode
Remarks
EAN-8 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-8 barcode must always have 7 characters length. The 8th character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEAN8Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEAN8Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

The following tables list the members exposed by PDFEAN8Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFEAN8Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN8Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFEAN8Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class : PDFEAN8Barcode Constructor
Overload List
Overload | Description
PDFEAN8Barcode Constructor() | Initializes a new PDFEAN8Barcode object.
PDFEAN8Barcode Constructor(String,Double,Double) | Initializes a new PDFEAN8Barcode object.
PDFEAN8Barcode Constructor(String) | Initializes a new PDFEAN8Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members


%%PageItemTitle%%

PDFEAN8Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor()
Initializes a new PDFEAN8Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFEAN8Barcode()
public PDFEAN8Barcode()
public: PDFEAN8Barcode();
public:
PDFEAN8Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN8Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN8Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFEAN8Barcode(data, left, top)
public PDFEAN8Barcode(
   string data,
   double left,
   double top
)
public: PDFEAN8Barcode(
   string* data,
   double left,
   double top
)
public:
PDFEAN8Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


%%PageItemTitle%%

PDFEAN8Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFEAN8Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFEAN8Barcode(data)
public PDFEAN8Barcode(
   string data
)
public: PDFEAN8Barcode(
   string* data
)
public:
PDFEAN8Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


%%PageItemTitle%%

PDFEANBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class
Defines the base class for EAN based barcodes.
Object Model
PDFEANBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFEANBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFEANBarcode
public abstract class PDFEANBarcode : PDFUnidimensionalBarcode
public __gc abstract class PDFEANBarcode : public PDFUnidimensionalBarcode
public ref class PDFEANBarcode abstract : public PDFUnidimensionalBarcode
Remarks
An EAN based symbology is a numeric symbology. Only the following symbols are allowed in an EAN based barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always has 12 characters length. The 13th character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEAN13Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEAN8Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFISBNBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFISMNBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFISSNBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFJAN13Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUPCABarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUPCEBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFEANBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

The following tables list the members exposed by PDFEANBarcode.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters.
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEANBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFEANBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

For a list of all members of this type, see PDFEANBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters.
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEANBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

BarReductionFactor Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : BarReductionFactor Property
Gets or sets the factor used for reducing/enlarging bar widths for special characters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BarReductionFactor As Double
'Usage

Dim instance As PDFEANBarcode
Dim value As Double

instance.BarReductionFactor = value

value = instance.BarReductionFactor
public double BarReductionFactor {get; set;}
public: __property double get_BarReductionFactor();
public: __property void set_BarReductionFactor(
   double value
);
public:
property double BarReductionFactor {
   double get();
   void set (    double value);
}

Property Value

A factor applied to bar width for reducing/enlarging the bars for special characters 1, 2, 7, and 8.
Remarks
The standard recommends this value to be 1/13 of bar width.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


%%ItemTitle%%

Supplement Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : Supplement Property
Gets or sets the supplement for barcode data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Supplement As String
'Usage

Dim instance As PDFEANBarcode
Dim value As String

instance.Supplement = value

value = instance.Supplement
public string Supplement {get; set;}
public: __property string* get_Supplement();
public: __property void set_Supplement(
   string* value
);
public:
property String^ Supplement {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying a 2 or 5 digit supplemental barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).
Remarks
This supplement is optional. If it exists, it can be only 2 or 5 digits.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


%%ItemTitle%%

SupplementDisplayLocation Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : SupplementDisplayLocation Property
Gets or sets the location of the supplement text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SupplementDisplayLocation As BarcodeTextLocation
'Usage

Dim instance As PDFEANBarcode
Dim value As BarcodeTextLocation

instance.SupplementDisplayLocation = value

value = instance.SupplementDisplayLocation
public BarcodeTextLocation SupplementDisplayLocation {get; set;}
public: __property BarcodeTextLocation get_SupplementDisplayLocation();
public: __property void set_SupplementDisplayLocation(
   BarcodeTextLocation value
);
public:
property BarcodeTextLocation SupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (    BarcodeTextLocation value);
}

Property Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.
Remarks
The embedding options are ignored for supplement text. BarcodeTextLocation.AboveEmbedded has the same effect like BarcodeTextLocation.Above, and BarcodeTextLocation.BelowEmbedded has the same effect like BarcodeTextLocation.Below.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


%%ItemTitle%%

SupplementYDimension Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : SupplementYDimension Property
Gets or sets the height of a bar in the supplement barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SupplementYDimension As Double
'Usage

Dim instance As PDFEANBarcode
Dim value As Double

instance.SupplementYDimension = value

value = instance.SupplementYDimension
public double SupplementYDimension {get; set;}
public: __property double get_SupplementYDimension();
public: __property void set_SupplementYDimension(
   double value
);
public:
property double SupplementYDimension {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the height of a bar in the supplement barcode.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


%%PageItemTitle%%

PDFFedExGround96Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class
Defines a FedEx Ground 96 barcode.
Object Model
PDFFedExGround96Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFedExGround96Barcode
   Inherits PDFCode128CBarcode
'Usage

Dim instance As PDFFedExGround96Barcode
public class PDFFedExGround96Barcode : PDFCode128CBarcode
public __gc class PDFFedExGround96Barcode : public PDFCode128CBarcode
public ref class PDFFedExGround96Barcode : public PDFCode128CBarcode
Remarks
This class defines a FedEx Ground 96 barcode. Only the following symbols are allowed in the barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 21 digits and the first 2 digits are always 96.
The structure of a FedEx Ground 96 barcode is as follows:
1-2 - Application Identifier (96)
3-4 - Two digit “Serial Container Numeric Code” - “11,12,13” identifies the carrier as “FedEx Ground”.
5-7 - Class of Service - Three-digit number used to identify the FedEx Ground class of service.
8-14 - FedEx Ground Shipper ID - Seven-digit unique shipper identification number.
15-21 - Package Number - Seven-digit package serial number.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFFedExGround96Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFFedExGround96Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

The following tables list the members exposed by PDFFedExGround96Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFFedExGround96Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFFedExGround96Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class : PDFFedExGround96Barcode Constructor
Overload List
Overload | Description
PDFFedExGround96Barcode Constructor() | Initializes a new PDFFedExGround96Barcode object.
PDFFedExGround96Barcode Constructor(String,Double,Double) | Initializes a new PDFFedExGround96Barcode object.
PDFFedExGround96Barcode Constructor(String) | Initializes a new PDFFedExGround96Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor()
Initializes a new PDFFedExGround96Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFedExGround96Barcode()
public PDFFedExGround96Barcode()
public: PDFFedExGround96Barcode();
public:
PDFFedExGround96Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFFedExGround96Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFFedExGround96Barcode(data, left, top)
public PDFFedExGround96Barcode(
   string data,
   double left,
   double top
)
public: PDFFedExGround96Barcode(
   string* data,
   double left,
   double top
)
public:
PDFFedExGround96Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PDFFedExGround96Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFFedExGround96Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFFedExGround96Barcode(data)
public PDFFedExGround96Barcode(
   string data
)
public: PDFFedExGround96Barcode(
   string* data
)
public:
PDFFedExGround96Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PDFHeightModulatedBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class
Defines the base class for all height modulated barcodes.
Object Model
PDFHeightModulatedBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFHeightModulatedBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFHeightModulatedBarcode
public abstract class PDFHeightModulatedBarcode : PDFUnidimensionalBarcode
public __gc abstract class PDFHeightModulatedBarcode : public PDFUnidimensionalBarcode
public ref class PDFHeightModulatedBarcode abstract : public PDFUnidimensionalBarcode
Remarks
Height modulated barcodes encode the information in the height of the bars, not and in the width of the bars and spaces.
Usually height modulated barcodes are used for encoding postal information, such as ZIP/Postal codes or delivery points.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPlanetBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPostNetBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFRM4SCCBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHeightModulatedBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFHeightModulatedBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

The following tables list the members exposed by PDFHeightModulatedBarcode.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFHeightModulatedBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFIATA25Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class
Defines a IATA 2 of 5 barcode.
Object Model
PDFIATA25Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFIATA25Barcode
   Inherits PDFCode25Barcode
'Usage

Dim instance As PDFIATA25Barcode
public class PDFIATA25Barcode : PDFCode25Barcode
public __gc class PDFIATA25Barcode : public PDFCode25Barcode
public ref class PDFIATA25Barcode : public PDFCode25Barcode
Remarks
IATA 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
IATA (International Air Transport Assosiation) uses this for the management of air cargo.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFIATA25Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFIATA25Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

The following tables list the members exposed by PDFIATA25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFIATA25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFIATA25Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFIATA25Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class : PDFIATA25Barcode Constructor
Overload List
Overload | Description
PDFIATA25Barcode Constructor() | Initializes a new PDFIATA25Barcode object.
PDFIATA25Barcode Constructor(String,Double,Double) | Initializes a new PDFIATA25Barcode object.
PDFIATA25Barcode Constructor(String) | Initializes a new PDFIATA25Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members


%%PageItemTitle%%

PDFIATA25Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor()
Initializes a new PDFIATA25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFIATA25Barcode()
public PDFIATA25Barcode()
public: PDFIATA25Barcode();
public:
PDFIATA25Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


%%PageItemTitle%%

PDFIATA25Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFIATA25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFIATA25Barcode(data, left, top)
public PDFIATA25Barcode(
   string data,
   double left,
   double top
)
public: PDFIATA25Barcode(
   string* data,
   double left,
   double top
)
public:
PDFIATA25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


%%PageItemTitle%%

PDFIATA25Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFIATA25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFIATA25Barcode(data)
public PDFIATA25Barcode(
   string data
)
public: PDFIATA25Barcode(
   string* data
)
public:
PDFIATA25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


%%PageItemTitle%%

PDFIdentcodeBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class
Defines an Identcode barcode.
Object Model
PDFIdentcodeBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFIdentcodeBarcode
   Inherits PDFCode25InterleavedBarcode
'Usage

Dim instance As PDFIdentcodeBarcode
public class PDFIdentcodeBarcode : PDFCode25InterleavedBarcode
public __gc class PDFIdentcodeBarcode : public PDFCode25InterleavedBarcode
public ref class PDFIdentcodeBarcode : public PDFCode25InterleavedBarcode
Remarks
The Identcode is a numeric barcode using the digits from 0 to 9 and is used by the Deutsche Post AG (DHL). It has a fixed length of 12 digits (11 user defined digits + 1 check digit).
The structure of Identcode barcode is:
1..2 - Mail center (outgoing)
3..5 - Customer code
6..11 - Delivery number
12 - Check digit (computed automatically)
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFIdentcodeBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFIdentcodeBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

The following tables list the members exposed by PDFIdentcodeBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFIdentcodeBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFIdentcodeBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class : PDFIdentcodeBarcode Constructor
Overload List
Overload | Description
PDFIdentcodeBarcode Constructor() | Initializes a new PDFIdentcodeBarcode object.
PDFIdentcodeBarcode Constructor(String,Double,Double) | Initializes a new PDFIdentcodeBarcode object.
PDFIdentcodeBarcode Constructor(String) | Initializes a new PDFIdentcodeBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor()
Initializes a new PDFIdentcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFIdentcodeBarcode()
public PDFIdentcodeBarcode()
public: PDFIdentcodeBarcode();
public:
PDFIdentcodeBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFIdentcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFIdentcodeBarcode(data, left, top)
public PDFIdentcodeBarcode(
   string data,
   double left,
   double top
)
public: PDFIdentcodeBarcode(
   string* data,
   double left,
   double top
)
public:
PDFIdentcodeBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFIdentcodeBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFIdentcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFIdentcodeBarcode(data)
public PDFIdentcodeBarcode(
   string data
)
public: PDFIdentcodeBarcode(
   string* data
)
public:
PDFIdentcodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFISBNBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class
Defines the class for ISBN barcodes.
Object Model
PDFISBNBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFISBNBarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFISBNBarcode
public class PDFISBNBarcode : PDFEANBarcode
public __gc class PDFISBNBarcode : public PDFEANBarcode
public ref class PDFISBNBarcode : public PDFEANBarcode
Remarks
ISBN symbology is a numeric symbology. Only the following symbols are allowed in an ISBN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISBN barcode (International Standard Book Numbering) is in fact an EAN-13 barcode having the 978 number system. The data for an ISBN barcode must always have 9 characters length. The number system is always 978 and the last character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFISBNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFISBNBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

The following tables list the members exposed by PDFISBNBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFISBNBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISBNBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFISBNBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class : PDFISBNBarcode Constructor
Overload List
Overload | Description
PDFISBNBarcode Constructor() | Initializes a new PDFISBNBarcode object.
PDFISBNBarcode Constructor(String,Double,Double) | Initializes a new PDFISBNBarcode object.
PDFISBNBarcode Constructor(String) | Initializes a new PDFISBNBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members


%%PageItemTitle%%

PDFISBNBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor()
Initializes a new PDFISBNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFISBNBarcode()
public PDFISBNBarcode()
public: PDFISBNBarcode();
public:
PDFISBNBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


%%PageItemTitle%%

PDFISBNBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISBNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFISBNBarcode(data, left, top)
public PDFISBNBarcode(
   string data,
   double left,
   double top
)
public: PDFISBNBarcode(
   string* data,
   double left,
   double top
)
public:
PDFISBNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


%%PageItemTitle%%

PDFISBNBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFISBNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFISBNBarcode(data)
public PDFISBNBarcode(
   string data
)
public: PDFISBNBarcode(
   string* data
)
public:
PDFISBNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


%%PageItemTitle%%

PDFISMNBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class
Defines the class for ISMN barcodes.
Object Model
PDFISMNBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFISMNBarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFISMNBarcode
public class PDFISMNBarcode : PDFEANBarcode
public __gc class PDFISMNBarcode : public PDFEANBarcode
public ref class PDFISMNBarcode : public PDFEANBarcode
Remarks
ISMN symbology is a numeric symbology. Only the following symbols are allowed in an ISMN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISMN barcode (International Standard Music Number) is in fact an EAN-13 barcode having the 979 number system. The data for an ISMN barcode must always have 9 characters length. The number system is always 979 and the last character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFISMNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFISMNBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

The following tables list the members exposed by PDFISMNBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFISMNBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISMNBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFISMNBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class : PDFISMNBarcode Constructor
Overload List
Overload | Description
PDFISMNBarcode Constructor() | Initializes a new PDFISMNBarcode object.
PDFISMNBarcode Constructor(String,Double,Double) | Initializes a new PDFISMNBarcode object.
PDFISMNBarcode Constructor(String) | Initializes a new PDFISMNBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members


%%PageItemTitle%%

PDFISMNBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor()
Initializes a new PDFISMNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFISMNBarcode()
public PDFISMNBarcode()
public: PDFISMNBarcode();
public:
PDFISMNBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


%%PageItemTitle%%

PDFISMNBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISMNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFISMNBarcode(data, left, top)
public PDFISMNBarcode(
   string data,
   double left,
   double top
)
public: PDFISMNBarcode(
   string* data,
   double left,
   double top
)
public:
PDFISMNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


%%PageItemTitle%%

PDFISMNBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFISMNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFISMNBarcode(data)
public PDFISMNBarcode(
   string data
)
public: PDFISMNBarcode(
   string* data
)
public:
PDFISMNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


%%PageItemTitle%%

PDFISSNBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class
Defines the class for ISSN barcodes.
Object Model
PDFISSNBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFISSNBarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFISSNBarcode
public class PDFISSNBarcode : PDFEANBarcode
public __gc class PDFISSNBarcode : public PDFEANBarcode
public ref class PDFISSNBarcode : public PDFEANBarcode
Remarks
ISSN symbology is a numeric symbology. Only the following symbols are allowed in an ISSN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISSN barcode (International Standard Serial Number for Periodicals) is in fact an EAN-13 barcode having the 977 number system. The data for an ISSN barcode must always have 9 characters length. The number system is always 977 and the last character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFISSNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFISSNBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

The following tables list the members exposed by PDFISSNBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFISSNBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISSNBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFISSNBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class : PDFISSNBarcode Constructor
Overload List
Overload | Description
PDFISSNBarcode Constructor() | Initializes a new PDFISSNBarcode object.
PDFISSNBarcode Constructor(String,Double,Double) | Initializes a new PDFISSNBarcode object.
PDFISSNBarcode Constructor(String) | Initializes a new PDFISSNBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members


%%PageItemTitle%%

PDFISSNBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor()
Initializes a new PDFISSNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFISSNBarcode()
public PDFISSNBarcode()
public: PDFISSNBarcode();
public:
PDFISSNBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


%%PageItemTitle%%

PDFISSNBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISSNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFISSNBarcode(data, left, top)
public PDFISSNBarcode(
   string data,
   double left,
   double top
)
public: PDFISSNBarcode(
   string* data,
   double left,
   double top
)
public:
PDFISSNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


%%PageItemTitle%%

PDFISSNBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFISSNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFISSNBarcode(data)
public PDFISSNBarcode(
   string data
)
public: PDFISSNBarcode(
   string* data
)
public:
PDFISSNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


%%PageItemTitle%%

PDFJAN13Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class
Defines the class for JAN13 barcodes.
Object Model
PDFJAN13Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFJAN13Barcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFJAN13Barcode
public class PDFJAN13Barcode : PDFEANBarcode
public __gc class PDFJAN13Barcode : public PDFEANBarcode
public ref class PDFJAN13Barcode : public PDFEANBarcode
Remarks
JAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an JAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. An JAN-13 barcode (Japanese Article Numbering) is in fact an EAN-13 barcode having the 49 number system. The data for an JAN-13 barcode must always have 10 characters length. The number system is always 49 and the last character is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFJAN13Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFJAN13Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

The following tables list the members exposed by PDFJAN13Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFJAN13Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFJAN13Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFJAN13Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class : PDFJAN13Barcode Constructor
Overload List
Overload | Description
PDFJAN13Barcode Constructor() | Initializes a new PDFJAN13Barcode object.
PDFJAN13Barcode Constructor(String,Double,Double) | Initializes a new PDFJAN13Barcode object.
PDFJAN13Barcode Constructor(String) | Initializes a new PDFJAN13Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members


%%PageItemTitle%%

PDFJAN13Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor()
Initializes a new PDFJAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFJAN13Barcode()
public PDFJAN13Barcode()
public: PDFJAN13Barcode();
public:
PDFJAN13Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFJAN13Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFJAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFJAN13Barcode(data, left, top)
public PDFJAN13Barcode(
   string data,
   double left,
   double top
)
public: PDFJAN13Barcode(
   string* data,
   double left,
   double top
)
public:
PDFJAN13Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFJAN13Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFJAN13Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFJAN13Barcode(data)
public PDFJAN13Barcode(
   string data
)
public: PDFJAN13Barcode(
   string* data
)
public:
PDFJAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


%%PageItemTitle%%

PDFKixBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class
Defines a Kix barcode.
Object Model
PDFKixBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFKixBarcode
   Inherits PDFRM4SCCBarcode
'Usage

Dim instance As PDFKixBarcode
public class PDFKixBarcode : PDFRM4SCCBarcode
public __gc class PDFKixBarcode : public PDFRM4SCCBarcode
public ref class PDFKixBarcode : public PDFRM4SCCBarcode
Remarks
The Kix barcode, a height-modulated barcode symbology, is used by Royal Dutch Post in automated mail sortation process.
Only the following symbols are allowed in a Kix barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFKixBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFKixBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

The following tables list the members exposed by PDFKixBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFKixBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFKixBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFKixBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class : PDFKixBarcode Constructor
Overload List
Overload | Description
PDFKixBarcode Constructor() | Initializes a new PDFKixBarcode object.
PDFKixBarcode Constructor(String,Double,Double) | Initializes a new PDFKixBarcode object.
PDFKixBarcode Constructor(String) | Initializes a new PDFKixBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members


%%PageItemTitle%%

PDFKixBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor()
Initializes a new PDFKixBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFKixBarcode()
public PDFKixBarcode()
public: PDFKixBarcode();
public:
PDFKixBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


%%PageItemTitle%%

PDFKixBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFKixBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFKixBarcode(data, left, top)
public PDFKixBarcode(
   string data,
   double left,
   double top
)
public: PDFKixBarcode(
   string* data,
   double left,
   double top
)
public:
PDFKixBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


%%PageItemTitle%%

PDFKixBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFKixBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFKixBarcode(data)
public PDFKixBarcode(
   string data
)
public: PDFKixBarcode(
   string* data
)
public:
PDFKixBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


%%PageItemTitle%%

PDFLeitcodeBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class
Defines a Leitcode barcode.
Object Model
PDFLeitcodeBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFLeitcodeBarcode
   Inherits PDFCode25InterleavedBarcode
'Usage

Dim instance As PDFLeitcodeBarcode
public class PDFLeitcodeBarcode : PDFCode25InterleavedBarcode
public __gc class PDFLeitcodeBarcode : public PDFCode25InterleavedBarcode
public ref class PDFLeitcodeBarcode : public PDFCode25InterleavedBarcode
Remarks
The Leitcode is a numeric barcode using the digits from 0 to 9 and is used by the Deutsche Post AG (DHL). It has a fixed length of 14 digits (13 user defined digits + 1 check digit).
The structure of Leitcode barcode is:
1..5 - ZIP code
6..8 - Street's code number
9..11 - House number
12..13 - Product code
14 - Check Digit
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFLeitcodeBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFLeitcodeBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

The following tables list the members exposed by PDFLeitcodeBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFLeitcodeBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFLeitcodeBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class : PDFLeitcodeBarcode Constructor
Overload List
Overload | Description
PDFLeitcodeBarcode Constructor() | Initializes a new PDFLeitcodeBarcode object.
PDFLeitcodeBarcode Constructor(String,Double,Double) | Initializes a new PDFLeitcodeBarcode object.
PDFLeitcodeBarcode Constructor(String) | Initializes a new PDFLeitcodeBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor()
Initializes a new PDFLeitcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFLeitcodeBarcode()
public PDFLeitcodeBarcode()
public: PDFLeitcodeBarcode();
public:
PDFLeitcodeBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFLeitcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFLeitcodeBarcode(data, left, top)
public PDFLeitcodeBarcode(
   string data,
   double left,
   double top
)
public: PDFLeitcodeBarcode(
   string* data,
   double left,
   double top
)
public:
PDFLeitcodeBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFLeitcodeBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFLeitcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFLeitcodeBarcode(data)
public PDFLeitcodeBarcode(
   string data
)
public: PDFLeitcodeBarcode(
   string* data
)
public:
PDFLeitcodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PDFMatrix25Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class
Defines a Matrix 2 of 5 barcode.
Object Model
PDFMatrix25Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMatrix25Barcode
   Inherits PDFCode25Barcode
'Usage

Dim instance As PDFMatrix25Barcode
public class PDFMatrix25Barcode : PDFCode25Barcode
public __gc class PDFMatrix25Barcode : public PDFCode25Barcode
public ref class PDFMatrix25Barcode : public PDFCode25Barcode
Remarks
Matrix 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFMatrix25Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFMatrix25Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

The following tables list the members exposed by PDFMatrix25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFMatrix25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMatrix25Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFMatrix25Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class : PDFMatrix25Barcode Constructor
Overload List
Overload | Description
PDFMatrix25Barcode Constructor() | Initializes a new PDFMatrix25Barcode object.
PDFMatrix25Barcode Constructor(String,Double,Double) | Initializes a new PDFMatrix25Barcode object.
PDFMatrix25Barcode Constructor(String) | Initializes a new PDFMatrix25Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members


%%PageItemTitle%%

PDFMatrix25Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor()
Initializes a new PDFMatrix25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMatrix25Barcode()
public PDFMatrix25Barcode()
public: PDFMatrix25Barcode();
public:
PDFMatrix25Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PDFMatrix25Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFMatrix25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFMatrix25Barcode(data, left, top)
public PDFMatrix25Barcode(
   string data,
   double left,
   double top
)
public: PDFMatrix25Barcode(
   string* data,
   double left,
   double top
)
public:
PDFMatrix25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PDFMatrix25Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFMatrix25Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFMatrix25Barcode(data)
public PDFMatrix25Barcode(
   string data
)
public: PDFMatrix25Barcode(
   string* data
)
public:
PDFMatrix25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PDFMicroPDF417Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class
Defines a Micro PDF 417 barcode.
Object Model
PDFMicroPDF417Barcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMicroPDF417Barcode
   Inherits PDFBasePDF417Barcode
'Usage

Dim instance As PDFMicroPDF417Barcode
public class PDFMicroPDF417Barcode : PDFBasePDF417Barcode
public __gc class PDFMicroPDF417Barcode : public PDFBasePDF417Barcode
public ref class PDFMicroPDF417Barcode : public PDFBasePDF417Barcode
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFMicroPDF417Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMicroPDF417Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFMicroPDF417Barcode Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

The following tables list the members exposed by PDFMicroPDF417Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFMicroPDF417Barcode Constructor | Initializes a new PDFMicroPDF417Barcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Top
See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFMicroPDF417Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMicroPDF417Barcode Class : PDFMicroPDF417Barcode Constructor
Initializes a new PDFMicroPDF417Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMicroPDF417Barcode()
public PDFMicroPDF417Barcode()
public: PDFMicroPDF417Barcode();
public:
PDFMicroPDF417Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMicroPDF417Barcode Class
PDFMicroPDF417Barcode Members


%%PageItemTitle%% $$Properties$$

PDFMicroPDF417Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

For a list of all members of this type, see PDFMicroPDF417Barcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

SymbolSize Property (PDFMicroPDF417Barcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMicroPDF417Barcode Class : SymbolSize Property
Gets or sets the symbol size of this Micro PDF 417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SymbolSize As MicroPDF417SymbolSize
'Usage

Dim instance As PDFMicroPDF417Barcode
Dim value As MicroPDF417SymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
public MicroPDF417SymbolSize SymbolSize {get; set;}
public: __property MicroPDF417SymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   MicroPDF417SymbolSize value
);
public:
property MicroPDF417SymbolSize SymbolSize {
   MicroPDF417SymbolSize get();
   void set (    MicroPDF417SymbolSize value);
}

Property Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.
Remarks
If the SymbolSize is MicroPDF417SymbolSize.Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMicroPDF417Barcode Class
PDFMicroPDF417Barcode Members


%%PageItemTitle%%

PDFMSIPlesseyBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class
Defines a MSI/Plessey barcode.
Object Model
PDFMSIPlesseyBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFMSIPlesseyBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFMSIPlesseyBarcode
public class PDFMSIPlesseyBarcode : PDFUnidimensionalBarcode
public __gc class PDFMSIPlesseyBarcode : public PDFUnidimensionalBarcode
public ref class PDFMSIPlesseyBarcode : public PDFUnidimensionalBarcode
Remarks
MSI/Plessey is a numeric symbology. Only the following symbols are allowed in a MSI/Plessey barcode: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFMSIPlesseyBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

The following tables list the members exposed by PDFMSIPlesseyBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFMSIPlesseyBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMSIPlesseyBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class : PDFMSIPlesseyBarcode Constructor
Overload List
Overload | Description
PDFMSIPlesseyBarcode Constructor() | Initializes a new PDFMSIPlesseyBarcode object.
PDFMSIPlesseyBarcode Constructor(String,Double,Double) | Initializes a new PDFMSIPlesseyBarcode object.
PDFMSIPlesseyBarcode Constructor(String) | Initializes a new PDFMSIPlesseyBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor()
Initializes a new PDFMSIPlesseyBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFMSIPlesseyBarcode()
public PDFMSIPlesseyBarcode()
public: PDFMSIPlesseyBarcode();
public:
PDFMSIPlesseyBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFMSIPlesseyBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFMSIPlesseyBarcode(data, left, top)
public PDFMSIPlesseyBarcode(
   string data,
   double left,
   double top
)
public: PDFMSIPlesseyBarcode(
   string* data,
   double left,
   double top
)
public:
PDFMSIPlesseyBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PDFMSIPlesseyBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFMSIPlesseyBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFMSIPlesseyBarcode(data)
public PDFMSIPlesseyBarcode(
   string data
)
public: PDFMSIPlesseyBarcode(
   string* data
)
public:
PDFMSIPlesseyBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PDFPharmacodeBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class
Defines a Pharmacode barcode.
Object Model
PDFPharmacodeBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPharmacodeBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFPharmacodeBarcode
public class PDFPharmacodeBarcode : PDFUnidimensionalBarcode
public __gc class PDFPharmacodeBarcode : public PDFUnidimensionalBarcode
public ref class PDFPharmacodeBarcode : public PDFUnidimensionalBarcode
Remarks
Only the following symbols are allowed in a Pharmacode barcode: 1 2 3 4 5 6 7 8 9 0 and the Data property must represent a number between 3 and 131070.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPharmacodeBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPharmacodeBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

The following tables list the members exposed by PDFPharmacodeBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFPharmacodeBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarSpacing | Gets or sets the space between bars.
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPharmacodeBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : PDFPharmacodeBarcode Constructor
Overload List
Overload | Description
PDFPharmacodeBarcode Constructor() | Initializes a new PDFPharmacodeBarcode object.
PDFPharmacodeBarcode Constructor(String,Double,Double) | Initializes a new PDFPharmacodeBarcode object.
PDFPharmacodeBarcode Constructor(String) | Initializes a new PDFPharmacodeBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor()
Initializes a new PDFPharmacodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPharmacodeBarcode()
public PDFPharmacodeBarcode()
public: PDFPharmacodeBarcode();
public:
PDFPharmacodeBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPharmacodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFPharmacodeBarcode(data, left, top)
public PDFPharmacodeBarcode(
   string data,
   double left,
   double top
)
public: PDFPharmacodeBarcode(
   string* data,
   double left,
   double top
)
public:
PDFPharmacodeBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


%%PageItemTitle%%

PDFPharmacodeBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFPharmacodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFPharmacodeBarcode(data)
public PDFPharmacodeBarcode(
   string data
)
public: PDFPharmacodeBarcode(
   string* data
)
public:
PDFPharmacodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPharmacodeBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

For a list of all members of this type, see PDFPharmacodeBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarSpacing | Gets or sets the space between bars.
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPharmacodeBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

BarSpacing Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : BarSpacing Property
Gets or sets the space between bars.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BarSpacing As Double
'Usage

Dim instance As PDFPharmacodeBarcode
Dim value As Double

instance.BarSpacing = value

value = instance.BarSpacing
public double BarSpacing {get; set;}
public: __property double get_BarSpacing();
public: __property void set_BarSpacing(
   double value
);
public:
property double BarSpacing {
   double get();
   void set (    double value);
}

Property Value

The distance between the bars.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


%%ItemTitle%%

WideToNarrowRatio Property (PDFPharmacodeBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : WideToNarrowRatio Property
Gets or sets the ratio between wide bars and narrow bars.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WideToNarrowRatio As Double
'Usage

Dim instance As PDFPharmacodeBarcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
public double WideToNarrowRatio {get; set;}
public: __property double get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   double value
);
public:
property double WideToNarrowRatio {
   double get();
   void set (    double value);
}

Property Value

A double value specifying the ratio between wide bars and narrow bars.
Remarks
The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


%%PageItemTitle%%

PDFPlanetBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class
Defines a Planet barcode.
Object Model
PDFPlanetBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPlanetBarcode
   Inherits PDFHeightModulatedBarcode
'Usage

Dim instance As PDFPlanetBarcode
public class PDFPlanetBarcode : PDFHeightModulatedBarcode
public __gc class PDFPlanetBarcode : public PDFHeightModulatedBarcode
public ref class PDFPlanetBarcode : public PDFHeightModulatedBarcode
Remarks
The Planet barcode was developed by the United States Postal Service (USPS).
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPlanetBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPlanetBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

The following tables list the members exposed by PDFPlanetBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFPlanetBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPlanetBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPlanetBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class : PDFPlanetBarcode Constructor
Overload List
Overload | Description
PDFPlanetBarcode Constructor() | Initializes a new PDFPlanetBarcode object.
PDFPlanetBarcode Constructor(String,Double,Double) | Initializes a new PDFPlanetBarcode object.
PDFPlanetBarcode Constructor(String) | Initializes a new PDFPlanetBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members


%%PageItemTitle%%

PDFPlanetBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor()
Initializes a new PDFPlanetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPlanetBarcode()
public PDFPlanetBarcode()
public: PDFPlanetBarcode();
public:
PDFPlanetBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


%%PageItemTitle%%

PDFPlanetBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPlanetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFPlanetBarcode(data, left, top)
public PDFPlanetBarcode(
   string data,
   double left,
   double top
)
public: PDFPlanetBarcode(
   string* data,
   double left,
   double top
)
public:
PDFPlanetBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


%%PageItemTitle%%

PDFPlanetBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFPlanetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFPlanetBarcode(data)
public PDFPlanetBarcode(
   string data
)
public: PDFPlanetBarcode(
   string* data
)
public:
PDFPlanetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


%%PageItemTitle%%

PDFPostNetBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class
Defines a PostNet barcode.
Object Model
PDFPostNetBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPostNetBarcode
   Inherits PDFHeightModulatedBarcode
'Usage

Dim instance As PDFPostNetBarcode
public class PDFPostNetBarcode : PDFHeightModulatedBarcode
public __gc class PDFPostNetBarcode : public PDFHeightModulatedBarcode
public ref class PDFPostNetBarcode : public PDFHeightModulatedBarcode
Remarks
PostNet was developed by the United States Postal Service (USPS) to allow faster sorting and routing of mail.
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPostNetBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPostNetBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

The following tables list the members exposed by PDFPostNetBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFPostNetBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPostNetBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPostNetBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class : PDFPostNetBarcode Constructor
Overload List
Overload | Description
PDFPostNetBarcode Constructor() | Initializes a new PDFPostNetBarcode object.
PDFPostNetBarcode Constructor(String,Double,Double) | Initializes a new PDFPostNetBarcode object.
PDFPostNetBarcode Constructor(String) | Initializes a new PDFPostNetBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members


%%PageItemTitle%%

PDFPostNetBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor()
Initializes a new PDFPostNetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPostNetBarcode()
public PDFPostNetBarcode()
public: PDFPostNetBarcode();
public:
PDFPostNetBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


%%PageItemTitle%%

PDFPostNetBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPostNetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFPostNetBarcode(data, left, top)
public PDFPostNetBarcode(
   string data,
   double left,
   double top
)
public: PDFPostNetBarcode(
   string* data,
   double left,
   double top
)
public:
PDFPostNetBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


%%PageItemTitle%%

PDFPostNetBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFPostNetBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFPostNetBarcode(data)
public PDFPostNetBarcode(
   string data
)
public: PDFPostNetBarcode(
   string* data
)
public:
PDFPostNetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


%%PageItemTitle%%

PDFPZNBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class
Defines a PZN barcode.
Object Model
PDFPZNBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPZNBarcode
   Inherits PDFCode39Barcode
'Usage

Dim instance As PDFPZNBarcode
public class PDFPZNBarcode : PDFCode39Barcode
public __gc class PDFPZNBarcode : public PDFCode39Barcode
public ref class PDFPZNBarcode : public PDFCode39Barcode
Remarks
The PZN barcode has a fixed length, 6 digits and only the following symbols are allowed: 1 2 3 4 5 6 7 8 9 0.
PZN (Pharma-Zentral-Nummer) barcodes are used in pharmaceutical industry in Germany.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPZNBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFPZNBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

The following tables list the members exposed by PDFPZNBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFPZNBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPZNBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFPZNBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class : PDFPZNBarcode Constructor
Overload List
Overload | Description
PDFPZNBarcode Constructor() | Initializes a new PDFPZNBarcode object.
PDFPZNBarcode Constructor(String,Double,Double) | Initializes a new PDFPZNBarcode object.
PDFPZNBarcode Constructor(String) | Initializes a new PDFPZNBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members


%%PageItemTitle%%

PDFPZNBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor()
Initializes a new PDFPZNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPZNBarcode()
public PDFPZNBarcode()
public: PDFPZNBarcode();
public:
PDFPZNBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


%%PageItemTitle%%

PDFPZNBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor(String,Double,Double)
The data to be encoded.
The X coordinate of the top left corner of the barcode rectangle.
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPZNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFPZNBarcode(data, left, top)
public PDFPZNBarcode(
   string data,
   double left,
   double top
)
public: PDFPZNBarcode(
   string* data,
   double left,
   double top
)
public:
PDFPZNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


%%PageItemTitle%%

PDFPZNBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFPZNBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFPZNBarcode(data)
public PDFPZNBarcode(
   string data
)
public: PDFPZNBarcode(
   string* data
)
public:
PDFPZNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


%%PageItemTitle%%

PDFQRBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFQRBarcode Class
Defines a QR barcode.
Object Model
PDFQRBarcode ClassPDFColor ClassPDFColor ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFQRBarcode
   Inherits PDFBidimensionalBarcode
'Usage

Dim instance As PDFQRBarcode
public class PDFQRBarcode : PDFBidimensionalBarcode
public __gc class PDFQRBarcode : public PDFBidimensionalBarcode
public ref class PDFQRBarcode : public PDFBidimensionalBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFQRBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFQRBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFQRBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFQRBarcode Class

The following tables list the members exposed by PDFQRBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFQRBarcode Constructor | Iniitalizes a new PDFQRBarcode object.
Top
Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CharacterSet | Gets or sets the character set.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFQRBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFQRBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFQRBarcode Class : PDFQRBarcode Constructor
Iniitalizes a new PDFQRBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFQRBarcode()
public PDFQRBarcode()
public: PDFQRBarcode();
public:
PDFQRBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFQRBarcode Class
PDFQRBarcode Members


%%PageItemTitle%% $$Properties$$

PDFQRBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFQRBarcode Class

For a list of all members of this type, see PDFQRBarcode members.

Public Properties
 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | CharacterSet | Gets or sets the character set.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFQRBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

CharacterSet Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFQRBarcode Class : CharacterSet Property
Gets or sets the character set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CharacterSet As QRCharacterSet
'Usage

Dim instance As PDFQRBarcode
Dim value As QRCharacterSet

instance.CharacterSet = value

value = instance.CharacterSet
public QRCharacterSet CharacterSet {get; set;}
public: __property QRCharacterSet get_CharacterSet();
public: __property void set_CharacterSet(
   QRCharacterSet value
);
public:
property QRCharacterSet CharacterSet {
   QRCharacterSet get();
   void set (    QRCharacterSet value);
}

Property Value

The character set used to encode the barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFQRBarcode Class
PDFQRBarcode Members


%%ItemTitle%%

ErrorCorrectionLevel Property (PDFQRBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFQRBarcode Class : ErrorCorrectionLevel Property
Gets or sets the error correction level.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ErrorCorrectionLevel As QRErrorCorrectionLevel
'Usage

Dim instance As PDFQRBarcode
Dim value As QRErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
public QRErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
public: __property QRErrorCorrectionLevel get_ErrorCorrectionLevel();
public: __property void set_ErrorCorrectionLevel(
   QRErrorCorrectionLevel value
);
public:
property QRErrorCorrectionLevel ErrorCorrectionLevel {
   QRErrorCorrectionLevel get();
   void set (    QRErrorCorrectionLevel value);
}

Property Value

The error correction level for the barcode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFQRBarcode Class
PDFQRBarcode Members


%%PageItemTitle%%

PDFRM4SCCBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class
Defines a RM4SCC barcode.
Object Model
PDFRM4SCCBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFRM4SCCBarcode
   Inherits PDFHeightModulatedBarcode
'Usage

Dim instance As PDFRM4SCCBarcode
public class PDFRM4SCCBarcode : PDFHeightModulatedBarcode
public __gc class PDFRM4SCCBarcode : public PDFHeightModulatedBarcode
public ref class PDFRM4SCCBarcode : public PDFHeightModulatedBarcode
Remarks
The Royal Mail 4-state Customer Code (RM4SCC) is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a RM4SCC barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFKixBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFSingaporePostBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFRM4SCCBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

The following tables list the members exposed by PDFRM4SCCBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFRM4SCCBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFRM4SCCBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class : PDFRM4SCCBarcode Constructor
Overload List
Overload | Description
PDFRM4SCCBarcode Constructor() | Initializes a new PDFRM4SCCBarcode object.
PDFRM4SCCBarcode Constructor(String,Double,Double) | Initializes a new PDFRM4SCCBarcode object.
PDFRM4SCCBarcode Constructor(String) | Initializes a new PDFRM4SCCBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor()
Initializes a new PDFRM4SCCBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFRM4SCCBarcode()
public PDFRM4SCCBarcode()
public: PDFRM4SCCBarcode();
public:
PDFRM4SCCBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFRM4SCCBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFRM4SCCBarcode(data, left, top)
public PDFRM4SCCBarcode(
   string data,
   double left,
   double top
)
public: PDFRM4SCCBarcode(
   string* data,
   double left,
   double top
)
public:
PDFRM4SCCBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


%%PageItemTitle%%

PDFRM4SCCBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFRM4SCCBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFRM4SCCBarcode(data)
public PDFRM4SCCBarcode(
   string data
)
public: PDFRM4SCCBarcode(
   string* data
)
public:
PDFRM4SCCBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


%%PageItemTitle%%

PDFSCC14Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class
Defines a SCC-14 barcode.
Object Model
PDFSCC14Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSCC14Barcode
   Inherits PDFCode128CBarcode
'Usage

Dim instance As PDFSCC14Barcode
public class PDFSCC14Barcode : PDFCode128CBarcode
public __gc class PDFSCC14Barcode : public PDFCode128CBarcode
public ref class PDFSCC14Barcode : public PDFCode128CBarcode
Remarks
This class defines a SCC-14 (Shipping Container Code) barcode. Only the following symbols are allowed in a SCC-14 barcode: 0 1 2 3 4 5 6 7 8 9.
A SCC-14 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 14 digits. 13 digits are provided by the user, the 14th digit is the check digit and it is calculated automatically by the library.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFSCC14Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFSCC14Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

The following tables list the members exposed by PDFSCC14Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFSCC14Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSCC14Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFSCC14Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class : PDFSCC14Barcode Constructor
Overload List
Overload | Description
PDFSCC14Barcode Constructor() | Initializes a new PDFSCC14Barcode object.
PDFSCC14Barcode Constructor(String,Double,Double) | Initializes a new PDFSCC14Barcode object.
PDFSCC14Barcode Constructor(String) | Initializes a new PDFSCC14Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members


%%PageItemTitle%%

PDFSCC14Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor()
Initializes a new PDFSCC14Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSCC14Barcode()
public PDFSCC14Barcode()
public: PDFSCC14Barcode();
public:
PDFSCC14Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


%%PageItemTitle%%

PDFSCC14Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSCC14Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFSCC14Barcode(data, left, top)
public PDFSCC14Barcode(
   string data,
   double left,
   double top
)
public: PDFSCC14Barcode(
   string* data,
   double left,
   double top
)
public:
PDFSCC14Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


%%PageItemTitle%%

PDFSCC14Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFSCC14Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFSCC14Barcode(data)
public PDFSCC14Barcode(
   string data
)
public: PDFSCC14Barcode(
   string* data
)
public:
PDFSCC14Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


%%PageItemTitle%%

PDFSingaporePostBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class
Defines a Singapore Post barcode.
Object Model
PDFSingaporePostBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSingaporePostBarcode
   Inherits PDFRM4SCCBarcode
'Usage

Dim instance As PDFSingaporePostBarcode
public class PDFSingaporePostBarcode : PDFRM4SCCBarcode
public __gc class PDFSingaporePostBarcode : public PDFRM4SCCBarcode
public ref class PDFSingaporePostBarcode : public PDFRM4SCCBarcode
Remarks
The Singapore Post barcode is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a Singapore Post barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFSingaporePostBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFSingaporePostBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

The following tables list the members exposed by PDFSingaporePostBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFSingaporePostBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSingaporePostBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class : PDFSingaporePostBarcode Constructor
Overload List
Overload | Description
PDFSingaporePostBarcode Constructor() | Initializes a new PDFSingaporePostBarcode object.
PDFSingaporePostBarcode Constructor(String,Double,Double) | Initializes a new PDFSingaporePostBarcode object.
PDFSingaporePostBarcode Constructor(String) | Initializes a new PDFSingaporePostBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor()
Initializes a new PDFSingaporePostBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSingaporePostBarcode()
public PDFSingaporePostBarcode()
public: PDFSingaporePostBarcode();
public:
PDFSingaporePostBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSingaporePostBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFSingaporePostBarcode(data, left, top)
public PDFSingaporePostBarcode(
   string data,
   double left,
   double top
)
public: PDFSingaporePostBarcode(
   string* data,
   double left,
   double top
)
public:
PDFSingaporePostBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PDFSingaporePostBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFSingaporePostBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFSingaporePostBarcode(data)
public PDFSingaporePostBarcode(
   string data
)
public: PDFSingaporePostBarcode(
   string* data
)
public:
PDFSingaporePostBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PDFSSCC18Barcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class
Defines a SSCC-18 barcode.
Object Model
PDFSSCC18Barcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSSCC18Barcode
   Inherits PDFCode128CBarcode
'Usage

Dim instance As PDFSSCC18Barcode
public class PDFSSCC18Barcode : PDFCode128CBarcode
public __gc class PDFSSCC18Barcode : public PDFCode128CBarcode
public ref class PDFSSCC18Barcode : public PDFCode128CBarcode
Remarks
This class defines a SSCC-18 (Serial Shipping Container Code) barcode. Only the following symbols are allowed in a SSCC-18 barcode: 0 1 2 3 4 5 6 7 8 9.
A SSCC-18 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 18 digits. 17 digits are provided by the user, the 18th digit is the check digit and it is calculated automatically by the library.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFSSCC18Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFSSCC18Barcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

The following tables list the members exposed by PDFSSCC18Barcode.

Public Constructors
 | Name | Description
Public Constructor | PDFSSCC18Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSSCC18Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFSSCC18Barcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class : PDFSSCC18Barcode Constructor
Overload List
Overload | Description
PDFSSCC18Barcode Constructor() | Initializes a new PDFSSCC18Barcode object.
PDFSSCC18Barcode Constructor(String,Double,Double) | Initializes a new PDFSSCC18Barcode object.
PDFSSCC18Barcode Constructor(String) | Initializes a new PDFSSCC18Barcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members


%%PageItemTitle%%

PDFSSCC18Barcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor()
Initializes a new PDFSSCC18Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFSSCC18Barcode()
public PDFSSCC18Barcode()
public: PDFSSCC18Barcode();
public:
PDFSSCC18Barcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


%%PageItemTitle%%

PDFSSCC18Barcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSSCC18Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFSSCC18Barcode(data, left, top)
public PDFSSCC18Barcode(
   string data,
   double left,
   double top
)
public: PDFSSCC18Barcode(
   string* data,
   double left,
   double top
)
public:
PDFSSCC18Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


%%PageItemTitle%%

PDFSSCC18Barcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor(String)
The data to be encoded.
Initializes a new PDFSSCC18Barcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFSSCC18Barcode(data)
public PDFSSCC18Barcode(
   string data
)
public: PDFSSCC18Barcode(
   string* data
)
public:
PDFSSCC18Barcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


%%PageItemTitle%%

PDFUnidimensionalBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class
Defines the base class for 1D barcodes.
Object Model
PDFUnidimensionalBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFUnidimensionalBarcode
   Inherits PDFBarcode
'Usage

Dim instance As PDFUnidimensionalBarcode
public abstract class PDFUnidimensionalBarcode : PDFBarcode
public __gc abstract class PDFUnidimensionalBarcode : public PDFBarcode
public ref class PDFUnidimensionalBarcode abstract : public PDFBarcode
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCodabarBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode11Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPharmacodeBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUSPSFIMBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUnidimensionalBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

The following tables list the members exposed by PDFUnidimensionalBarcode.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form.
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUnidimensionalBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUnidimensionalBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

For a list of all members of this type, see PDFUnidimensionalBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form.
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUnidimensionalBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

BarWidthReduction Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : BarWidthReduction Property
Gets or sets the bar width reduction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BarWidthReduction As Double
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As Double

instance.BarWidthReduction = value

value = instance.BarWidthReduction
public double BarWidthReduction {get; set;}
public: __property double get_BarWidthReduction();
public: __property void set_BarWidthReduction(
   double value
);
public:
property double BarWidthReduction {
   double get();
   void set (    double value);
}

Property Value

A value used for reducing the bar width (not the space width) in order to compensate for ink bleeding when printing the barcode on various surfaces.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%ItemTitle%%

DataDisplayLocation Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DataDisplayLocation Property
Gets or sets the location of the barcode data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DataDisplayLocation As BarcodeTextLocation
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
public BarcodeTextLocation DataDisplayLocation {get; set;}
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (    BarcodeTextLocation value);
}

Property Value

A BarcodeTextLocation enumeration member specifying the location where the barcode data is displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%ItemTitle%%

DisplayCheckSum Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DisplayCheckSum Property
Gets or sets whether the check characters should be displayed in human readable form.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayCheckSum As Boolean
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
public bool DisplayCheckSum {get; set;}
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
public:
property bool DisplayCheckSum {
   bool get();
   void set (    bool value);
}

Property Value

True if the check characters should be displayed. Default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%ItemTitle%%

DisplayStartStopSymbols Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DisplayStartStopSymbols Property
Gets or sets a value indicating whether the start/stop symbols should be displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DisplayStartStopSymbols As Boolean
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.DisplayStartStopSymbols = value

value = instance.DisplayStartStopSymbols
public bool DisplayStartStopSymbols {get; set;}
public: __property bool get_DisplayStartStopSymbols();
public: __property void set_DisplayStartStopSymbols(
   bool value
);
public:
property bool DisplayStartStopSymbols {
   bool get();
   void set (    bool value);
}

Property Value

True if the start/stop symbol should be displayed. Default is true.
Remarks
Hiding the start/stop symbols can generate unreadable barcodes in some situations, unless you have specialized barcode readers that are aware of missing start/stop symbols.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%ItemTitle%%

EnableCheckSum Property

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : EnableCheckSum Property
Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EnableCheckSum As Boolean
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
public bool EnableCheckSum {get; set;}
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
public:
property bool EnableCheckSum {
   bool get();
   void set (    bool value);
}

Property Value

True if a checksum symbol should be appended automatically to the barcode, false otherwise.
Remarks
Not all barcodes support checksum symbols. This property is ignored for those that do not support them.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%ItemTitle%%

Font Property (PDFUnidimensionalBarcode)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : Font Property
Gets or sets the font used to display the barcode text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Font As PDFFontBase
'Usage

Dim instance As PDFUnidimensionalBarcode
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
public PDFFontBase Font {get; set;}
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (    PDFFontBase^ value);
}

Property Value

A O2S.Components.PDFView4NET.Graphics.Fonts.PDFFont object used to display the barcode text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


%%PageItemTitle%%

PDFUPCABarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class
Defines the class for UPC-A barcodes.
Object Model
PDFUPCABarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUPCABarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFUPCABarcode
public class PDFUPCABarcode : PDFEANBarcode
public __gc class PDFUPCABarcode : public PDFEANBarcode
public ref class PDFUPCABarcode : public PDFEANBarcode
Remarks
UPC-A symbology is a numeric symbology. Only the following symbols are allowed in an UPC-A barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-A barcode must always have 11 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUPCABarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUPCABarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

The following tables list the members exposed by PDFUPCABarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUPCABarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUPCABarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUPCABarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class : PDFUPCABarcode Constructor
Overload List
Overload | Description
PDFUPCABarcode Constructor() | Initializes a new PDFUPCABarcode object.
PDFUPCABarcode Constructor(String,Double,Double) | Initializes a new PDFUPCABarcode object.
PDFUPCABarcode Constructor(String) | Initializes a new PDFUPCABarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members


%%PageItemTitle%%

PDFUPCABarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor()
Initializes a new PDFUPCABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUPCABarcode()
public PDFUPCABarcode()
public: PDFUPCABarcode();
public:
PDFUPCABarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


%%PageItemTitle%%

PDFUPCABarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUPCABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUPCABarcode(data, left, top)
public PDFUPCABarcode(
   string data,
   double left,
   double top
)
public: PDFUPCABarcode(
   string* data,
   double left,
   double top
)
public:
PDFUPCABarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


%%PageItemTitle%%

PDFUPCABarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUPCABarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUPCABarcode(data)
public PDFUPCABarcode(
   string data
)
public: PDFUPCABarcode(
   string* data
)
public:
PDFUPCABarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


%%PageItemTitle%%

PDFUPCEBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class
Defines the class for UPC-E barcodes.
Object Model
PDFUPCEBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUPCEBarcode
   Inherits PDFEANBarcode
'Usage

Dim instance As PDFUPCEBarcode
public class PDFUPCEBarcode : PDFEANBarcode
public __gc class PDFUPCEBarcode : public PDFEANBarcode
public ref class PDFUPCEBarcode : public PDFEANBarcode
Remarks
UPC-E symbology is a numeric symbology. Only the following symbols are allowed in an UPC-E barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-E barcode must always have 7 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUPCEBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUPCEBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

The following tables list the members exposed by PDFUPCEBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUPCEBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUPCEBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUPCEBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class : PDFUPCEBarcode Constructor
Overload List
Overload | Description
PDFUPCEBarcode Constructor() | Initializes a new PDFUPCEBarcode object.
PDFUPCEBarcode Constructor(String,Double,Double) | Initializes a new PDFUPCEBarcode object.
PDFUPCEBarcode Constructor(String) | Initializes a new PDFUPCEBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members


%%PageItemTitle%%

PDFUPCEBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor()
Initializes a new PDFUPCEBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUPCEBarcode()
public PDFUPCEBarcode()
public: PDFUPCEBarcode();
public:
PDFUPCEBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


%%PageItemTitle%%

PDFUPCEBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUPCEBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUPCEBarcode(data, left, top)
public PDFUPCEBarcode(
   string data,
   double left,
   double top
)
public: PDFUPCEBarcode(
   string* data,
   double left,
   double top
)
public:
PDFUPCEBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


%%PageItemTitle%%

PDFUPCEBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUPCEBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUPCEBarcode(data)
public PDFUPCEBarcode(
   string data
)
public: PDFUPCEBarcode(
   string* data
)
public:
PDFUPCEBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSFIMBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class
Defines a USPS FIM barcode.
Object Model
PDFUSPSFIMBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUSPSFIMBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFUSPSFIMBarcode
public class PDFUSPSFIMBarcode : PDFUnidimensionalBarcode
public __gc class PDFUSPSFIMBarcode : public PDFUnidimensionalBarcode
public ref class PDFUSPSFIMBarcode : public PDFUnidimensionalBarcode
Remarks
The Facing Identification Mark, or FIM, is a bar code designed by the United States Postal Service to assist in the automated processing of mail. The FIM is a set of vertical bars printed on the envelope or postcard near the upper edge, just to the left of the postage area (the area where the postage stamp or its equivalent is placed). The FIM is intended for use primarily on preprinted envelopes and postcards and is applied by the company printing the envelopes or postcards, not by the USPS.
FIM barcodes support only 4 data strings: "A", "B", "C", and "D", one string for each FIM barcode.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUSPSFIMBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUSPSFIMBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

The following tables list the members exposed by PDFUSPSFIMBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUSPSFIMBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSFIMBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class : PDFUSPSFIMBarcode Constructor
Overload List
Overload | Description
PDFUSPSFIMBarcode Constructor() | Initializes a new PDFUSPSFIMBarcode object.
PDFUSPSFIMBarcode Constructor(String,Double,Double) | Initializes a new PDFUSPSFIMBarcode object.
PDFUSPSFIMBarcode Constructor(String) | Initializes a new PDFUSPSFIMBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor()
Initializes a new PDFUSPSFIMBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUSPSFIMBarcode()
public PDFUSPSFIMBarcode()
public: PDFUSPSFIMBarcode();
public:
PDFUSPSFIMBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSFIMBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUSPSFIMBarcode(data, left, top)
public PDFUSPSFIMBarcode(
   string data,
   double left,
   double top
)
public: PDFUSPSFIMBarcode(
   string* data,
   double left,
   double top
)
public:
PDFUSPSFIMBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSFIMBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUSPSFIMBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUSPSFIMBarcode(data)
public PDFUSPSFIMBarcode(
   string data
)
public: PDFUSPSFIMBarcode(
   string* data
)
public:
PDFUSPSFIMBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class
Defines a horizontal bars barcode.
Object Model
PDFUSPSHorizontalBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUSPSHorizontalBarcode
   Inherits PDFUnidimensionalBarcode
'Usage

Dim instance As PDFUSPSHorizontalBarcode
public class PDFUSPSHorizontalBarcode : PDFUnidimensionalBarcode
public __gc class PDFUSPSHorizontalBarcode : public PDFUnidimensionalBarcode
public ref class PDFUSPSHorizontalBarcode : public PDFUnidimensionalBarcode
Remarks
This type of barcode is used by USPS to identify mailings as business reply mail. The Data property is a string of "1", each digit corresponding to a bar.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUSPSHorizontalBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

The following tables list the members exposed by PDFUSPSHorizontalBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUSPSHorizontalBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSHorizontalBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class : PDFUSPSHorizontalBarcode Constructor
Overload List
Overload | Description
PDFUSPSHorizontalBarcode Constructor() | Initializes a new PDFUSPSHorizontalBarcode object.
PDFUSPSHorizontalBarcode Constructor(String) | Initializes a new PDFUSPSHorizontalBarcode object.
PDFUSPSHorizontalBarcode Constructor(String,Double,Double) | Initializes a new PDFUSPSHorizontalBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor()
Initializes a new PDFUSPSHorizontalBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUSPSHorizontalBarcode()
public PDFUSPSHorizontalBarcode()
public: PDFUSPSHorizontalBarcode();
public:
PDFUSPSHorizontalBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUSPSHorizontalBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUSPSHorizontalBarcode(data)
public PDFUSPSHorizontalBarcode(
   string data
)
public: PDFUSPSHorizontalBarcode(
   string* data
)
public:
PDFUSPSHorizontalBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSHorizontalBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSHorizontalBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUSPSHorizontalBarcode(data, left, top)
public PDFUSPSHorizontalBarcode(
   string data,
   double left,
   double top
)
public: PDFUSPSHorizontalBarcode(
   string* data,
   double left,
   double top
)
public:
PDFUSPSHorizontalBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSPICBarcode Class
Members

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class
Defines a USPS Package Identification Code barcode.
Object Model
PDFUSPSPICBarcode ClassPDFColor ClassPDFColor ClassPDFFontBase ClassPDFColor Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFUSPSPICBarcode
   Inherits PDFCode128CBarcode
'Usage

Dim instance As PDFUSPSPICBarcode
public class PDFUSPSPICBarcode : PDFCode128CBarcode
public __gc class PDFUSPSPICBarcode : public PDFCode128CBarcode
public ref class PDFUSPSPICBarcode : public PDFCode128CBarcode
Remarks
Only the following symbols are allowed in the barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 21 digits for standard barcode (the first 2 digits are always 91) or 29 digits for concatenated barcode (the first 3 digits are always 420).
The structure of a USPS PIC standard barcode is as follows:
1 - 2 - Application Identifier (91)
3 - 4 - Service Type Code (STC)
5 - 13 - Customer ID: DUNS number that uniquely identifies the customer
14 - 21 - Package Sequence Number (PSN)
The structure of a USPS PIC concatenated barcode is as follows:
1 - 3 - Routing Application Identifier (420)
4 - 8 - 5-digit ZIP code
9 - 10 - Application Identifier (91)
11 - 12 - Service Type Code (STC)
13 - 21 - Customer ID: DUNS number that uniquely identifies the customer
22 - 29 - Package Sequence Number (PSN)
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUSPSPICBarcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Members
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Members$$

PDFUSPSPICBarcode Class Members
Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

The following tables list the members exposed by PDFUSPSPICBarcode.

Public Constructors
 | Name | Description
Public Constructor | PDFUSPSPICBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSPICBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class : PDFUSPSPICBarcode Constructor
Overload List
Overload | Description
PDFUSPSPICBarcode Constructor() | Initializes a new PDFUSPSPICBarcode object.
PDFUSPSPICBarcode Constructor(String,Double,Double) | Initializes a new PDFUSPSPICBarcode object.
PDFUSPSPICBarcode Constructor(String) | Initializes a new PDFUSPSPICBarcode object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor()

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor()
Initializes a new PDFUSPSPICBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFUSPSPICBarcode()
public PDFUSPSPICBarcode()
public: PDFUSPSPICBarcode();
public:
PDFUSPSPICBarcode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor(String,Double,Double)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor(String,Double,Double)
The data to be encoded.
the X coordinate of the top left corner of the barcode rectangle.
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSPICBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
'Usage

Dim data As String
Dim left As Double
Dim top As Double

Dim instance As New PDFUSPSPICBarcode(data, left, top)
public PDFUSPSPICBarcode(
   string data,
   double left,
   double top
)
public: PDFUSPSPICBarcode(
   string* data,
   double left,
   double top
)
public:
PDFUSPSPICBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


%%PageItemTitle%%

PDFUSPSPICBarcode Constructor(String)

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor(String)
The data to be encoded.
Initializes a new PDFUSPSPICBarcode object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PDFUSPSPICBarcode(data)
public PDFUSPSPICBarcode(
   string data
)
public: PDFUSPSPICBarcode(
   string* data
)
public:
PDFUSPSPICBarcode(
   String^ data
)

Parameters

data
The data to be encoded.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


%%PageItemTitle%%

MicroPDF417SymbolSize Enumeration

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : MicroPDF417SymbolSize Enumeration
Specifies the available sizes for a Micro PDF417 symbol.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MicroPDF417SymbolSize
   Inherits System.Enum
'Usage

Dim instance As MicroPDF417SymbolSize
public enum MicroPDF417SymbolSize : System.Enum
__value public enum MicroPDF417SymbolSize : public System.Enum
public enum class MicroPDF417SymbolSize : public System.Enum
Members
Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size10x3 | Micro PDF417 symbol with 10 rows and 3 columns.
Size10x4 | Micro PDF417 symbol with 10 rows and 4 columns.
Size11x1 | Micro PDF417 symbol with 11 rows and 1 column.
Size11x2 | Micro PDF417 symbol with 11 rows and 2 columns.
Size12x3 | Micro PDF417 symbol with 12 rows and 3 columns.
Size12x4 | Micro PDF417 symbol with 12 rows and 4 columns.
Size14x1 | Micro PDF417 symbol with 14 rows and 1 column.
Size14x2 | Micro PDF417 symbol with 14 rows and 2 columns.
Size15x3 | Micro PDF417 symbol with 15 rows and 3 columns.
Size15x4 | Micro PDF417 symbol with 15 rows and 4 columns.
Size17x1 | Micro PDF417 symbol with 17 rows and 1 column.
Size17x2 | Micro PDF417 symbol with 17 rows and 2 columns.
Size20x1 | Micro PDF417 symbol with 20 rows and 1 column.
Size20x2 | Micro PDF417 symbol with 20 rows and 2 columns.
Size20x3 | Micro PDF417 symbol with 20 rows and 3 columns.
Size20x4 | Micro PDF417 symbol with 20 rows and 4 columns.
Size23x2 | Micro PDF417 symbol with 23 rows and 2 columns.
Size24x1 | Micro PDF417 symbol with 24 rows and 1 column.
Size26x2 | Micro PDF417 symbol with 26 rows and 2 columns.
Size26x3 | Micro PDF417 symbol with 26 rows and 3 columns.
Size26x4 | Micro PDF417 symbol with 26 rows and 4 columns.
Size28x1 | Micro PDF417 symbol with 28 rows and 1 column.
Size32x3 | Micro PDF417 symbol with 32 rows and 3 columns.
Size32x4 | Micro PDF417 symbol with 32 rows and 4 columns.
Size38x3 | Micro PDF417 symbol with 38 rows and 3 columns.
Size38x4 | Micro PDF417 symbol with 38 rows and 4 columns.
Size44x3 | Micro PDF417 symbol with 44 rows and 3 columns.
Size44x4 | Micro PDF417 symbol with 44 rows and 4 columns.
Size4x4 | Micro PDF417 symbol with 4 rows and 4 columns.
Size6x3 | Micro PDF417 symbol with 6 rows and 3 columns.
Size6x4 | Micro PDF417 symbol with 6 rows and 4 columns.
Size8x2 | Micro PDF417 symbol with 8 rows and 2 columns.
Size8x3 | Micro PDF417 symbol with 8 rows and 3 columns.
Size8x4 | Micro PDF417 symbol with 8 rows and 4 columns.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Graphics.Barcodes.MicroPDF417SymbolSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDF417DataCompactionMode Enumeration

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDF417DataCompactionMode Enumeration
Specifies the available data compaction modes for a PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF417DataCompactionMode
   Inherits System.Enum
'Usage

Dim instance As PDF417DataCompactionMode
public enum PDF417DataCompactionMode : System.Enum
__value public enum PDF417DataCompactionMode : public System.Enum
public enum class PDF417DataCompactionMode : public System.Enum
Members
Member | Description
Byte | Binary compaction mode.
Numeric | Numeric compaction mode.
Text | Text compaction mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Graphics.Barcodes.PDF417DataCompactionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%%

PDF417ErrorCorrectionLevel Enumeration

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDF417ErrorCorrectionLevel Enumeration
Specifies the available error correction levels for a PDF417 barcode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDF417ErrorCorrectionLevel
   Inherits System.Enum
'Usage

Dim instance As PDF417ErrorCorrectionLevel
public enum PDF417ErrorCorrectionLevel : System.Enum
__value public enum PDF417ErrorCorrectionLevel : public System.Enum
public enum class PDF417ErrorCorrectionLevel : public System.Enum
Members
Member | Description
Level0 | Level 0 - 2 error correction codewords.
Level1 | Level 1 - 4 error correction codewords.
Level2 | Level 2 - 8 error correction codewords.
Level3 | Level 3 - 16 error correction codewords.
Level4 | Level 4 - 32 error correction codewords.
Level5 | Level 5 - 64 error correction codewords.
Level6 | Level 6 - 128 error correction codewords.
Level7 | Level 7 - 256 error correction codewords.
Level8 | Level 8 - 512 error correction codewords.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Graphics.Barcodes.PDF417ErrorCorrectionLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%%

O2S.Components.PDFView4NET.Graphics.Fonts Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFFont | Defines a particular format for text, including font face and size.
Class | PDFFontBase | Base class for all PDF fonts.
Class | PostScriptFont | Defines a particular format for text, including font face and size.
Class | TrueTypeFont | Defines a TrueType font that can be used in a PDF file.
Class | Type0Font | Defines a generic Type0 font that can be used in a PDF file.
Enumerations
 | Enumeration | Description
Enumeration | PDFFontFace | Specifies the available PDF fonts for drawing text on a page
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

PDFFont Class
Members

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PDFFont Class
Defines a particular format for text, including font face and size.
Object Model
PDFFont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFFont
   Inherits PDFFontBase
'Usage

Dim instance As PDFFont
public class PDFFont : PDFFontBase
public __gc class PDFFont : public PDFFontBase
public ref class PDFFont : public PDFFontBase
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Members
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

PDFFont Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PDFFont Class

The following tables list the members exposed by PDFFont.

Public Constructors
 | Name | Description
Public Constructor | PDFFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | FontFace | Gets or sets the font face
Public Property | FontName | Gets the name of the font. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PDFFont Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

PDFFont Constructor

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFont Class : PDFFont Constructor
Overload List
Overload | Description
PDFFont Constructor() | Initializes a new PDFFont object
PDFFont Constructor(PDFFontFace,Double) | Initializes a new PDFFont object of specified FontFace and size.
PDFFont Constructor(PDFFont) | Initializes a new PDFFont object based on an existing font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

PDFFont Constructor()

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor()
Initializes a new PDFFont object
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFFont()
public PDFFont()
public: PDFFont();
public:
PDFFont();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


%%PageItemTitle%%

PDFFont Constructor(PDFFontFace,Double)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor(PDFFontFace,Double)
a FontFace enumeration member specifying the font face
a double value specifying the size of the font in points
Initializes a new PDFFont object of specified FontFace and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fontFace As PDFFontFace, _
   ByVal size As Double _
)
'Usage

Dim fontFace As PDFFontFace
Dim size As Double

Dim instance As New PDFFont(fontFace, size)
public PDFFont(
   PDFFontFace fontFace,
   double size
)
public: PDFFont(
   PDFFontFace fontFace,
   double size
)
public:
PDFFont(
   PDFFontFace fontFace,
   double size
)

Parameters

fontFace
a FontFace enumeration member specifying the font face
size
a double value specifying the size of the font in points
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


%%PageItemTitle%%

PDFFont Constructor(PDFFont)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor(PDFFont)
a PDFFont object to be copied in the new font.
Initializes a new PDFFont object based on an existing font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PDFFont _
)
'Usage

Dim font As PDFFont

Dim instance As New PDFFont(font)
public PDFFont(
   PDFFont font
)
public: PDFFont(
   PDFFont* font
)
public:
PDFFont(
   PDFFont^ font
)

Parameters

font
a PDFFont object to be copied in the new font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


%%PageItemTitle%% $$Methods$$

PDFFont Class Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PDFFont Class

For a list of all members of this type, see PDFFont members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PDFFont Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

GetCharWidth Method (PDFFont)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFont Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As PDFFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a double value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%% $$Properties$$

PDFFont Class Properties

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PDFFont Class

For a list of all members of this type, see PDFFont members.

Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | FontFace | Gets or sets the font face
Public Property | FontName | Gets the name of the font. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PDFFont Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

Bold Property (PDFFont)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFont Class : Bold Property
Gets or sets whether the font object is bold or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Bold As Boolean
'Usage

Dim instance As PDFFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public override bool Bold {get; set;}
public: __property bool get_Bold() override;
public: __property void set_Bold(
   bool value
) override;
public:
property bool Bold {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this font object is bold; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


%%ItemTitle%%

FontFace Property

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFont Class : FontFace Property
Gets or sets the font face
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FontFace As PDFFontFace
'Usage

Dim instance As PDFFont
Dim value As PDFFontFace

instance.FontFace = value

value = instance.FontFace
public PDFFontFace FontFace {get; set;}
public: __property PDFFontFace get_FontFace();
public: __property void set_FontFace(
   PDFFontFace value
);
public:
property PDFFontFace FontFace {
   PDFFontFace get();
   void set (    PDFFontFace value);
}

Property Value

a FontFace enumeration member specifying the font face
Remarks
When creating a PDFFont object using the default constructor, the default value of this property is set to O2S.Components.PDFView4NET.Graphics.Fonts.FontFace.Helvetica
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


%%ItemTitle%%

Italic Property (PDFFont)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFont Class : Italic Property
Gets or sets whether the font object is italic or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Italic As Boolean
'Usage

Dim instance As PDFFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public override bool Italic {get; set;}
public: __property bool get_Italic() override;
public: __property void set_Italic(
   bool value
) override;
public:
property bool Italic {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this font object is italic; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFont Class
PDFFont Members


%%PageItemTitle%%

PDFFontBase Class
Members

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PDFFontBase Class
Base class for all PDF fonts.
Object Model
PDFFontBase Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class PDFFontBase
'Usage

Dim instance As PDFFontBase
public abstract class PDFFontBase
public __gc abstract class PDFFontBase
public ref class PDFFontBase abstract
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFont
O2S.Components.PDFView4NET.Graphics.Fonts.PostScriptFont
O2S.Components.PDFView4NET.Graphics.Fonts.TrueTypeFont
O2S.Components.PDFView4NET.Graphics.Fonts.Type0Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Members
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

PDFFontBase Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PDFFontBase Class

The following tables list the members exposed by PDFFontBase.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not.
Public Property | FontName | Gets the name of the font.
Public Property | Italic | Gets or sets whether the font object is italic or not.
Public Property | Overline | Gets or sets whether the font object is overline or not.
Public Property | Size | Gets or sets the font size.
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not.
Public Property | Underline | Gets or sets whether the font object is underline or not.
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object.
Top
See Also

Reference

PDFFontBase Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Methods$$

PDFFontBase Class Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PDFFontBase Class

For a list of all members of this type, see PDFFontBase members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object.
Top
See Also

Reference

PDFFontBase Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

GetCharWidth Method (PDFFontBase)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFontBase Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As PDFFontBase
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public virtual double GetCharWidth(
   char charCode
)
public: virtual double GetCharWidth(
   char charCode
)
public:
virtual double GetCharWidth(
   char charCode
)

Parameters

charCode
the char to get its width

Return Value

This method returns a double value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%ItemTitle%%

MeasureString Method

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFontBase Class : MeasureString Method
The string to measure
Measures the specified string when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function MeasureString( _
   ByVal text As String _
) As Double
'Usage

Dim instance As PDFFontBase
Dim text As String
Dim value As Double

value = instance.MeasureString(text)
public virtual double MeasureString(
   string text
)
public: virtual double MeasureString(
   string* text
)
public:
virtual double MeasureString(
   String^ text
)

Parameters

text
The string to measure

Return Value

This method returns a double value that represents the size, in points, of the string specified by the text parameter as drawn with this font object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%PageItemTitle%% $$Properties$$

PDFFontBase Class Properties

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PDFFontBase Class

For a list of all members of this type, see PDFFontBase members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not.
Public Property | FontName | Gets the name of the font.
Public Property | Italic | Gets or sets whether the font object is italic or not.
Public Property | Overline | Gets or sets whether the font object is overline or not.
Public Property | Size | Gets or sets the font size.
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not.
Public Property | Underline | Gets or sets whether the font object is underline or not.
Top
See Also

Reference

PDFFontBase Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

Bold Property (PDFFontBase)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFontBase Class : Bold Property
Gets or sets whether the font object is bold or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Bold As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public virtual bool Bold {get; set;}
public: __property virtual bool get_Bold();
public: __property virtual void set_Bold(
   bool value
);
public:
virtual property bool Bold {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this font object is bold; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%ItemTitle%%

FontName Property (PDFFontBase)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFontBase Class : FontName Property
Gets the name of the font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontName As String
'Usage

Dim instance As PDFFontBase
Dim value As String

value = instance.FontName
public string FontName {get;}
public: __property string* get_FontName();
public:
property String^ FontName {
   String^ get();
}

Property Value

The name of the font as it appears in the font dictionary.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%ItemTitle%%

Italic Property (PDFFontBase)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFontBase Class : Italic Property
Gets or sets whether the font object is italic or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Italic As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public virtual bool Italic {get; set;}
public: __property virtual bool get_Italic();
public: __property virtual void set_Italic(
   bool value
);
public:
virtual property bool Italic {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this font object is italic; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%ItemTitle%%

Overline Property

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFontBase Class : Overline Property
Gets or sets whether the font object is overline or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Overline As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Overline = value

value = instance.Overline
public bool Overline {get; set;}
public: __property bool get_Overline();
public: __property void set_Overline(
   bool value
);
public:
property bool Overline {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this PDFFont object is overline; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%ItemTitle%%

Size Property (PDFFontBase)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFontBase Class : Size Property
Gets or sets the font size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Size As Double
'Usage

Dim instance As PDFFontBase
Dim value As Double

instance.Size = value

value = instance.Size
public double Size {get; set;}
public: __property double get_Size();
public: __property void set_Size(
   double value
);
public:
property double Size {
   double get();
   void set (    double value);
}

Property Value

a double value specifyig the size of the font in points (1/72 inches)
Remarks
The size of a font is always given in points, it does not matter the logical unit used for positioning the text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%ItemTitle%%

Strikethrough Property

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFontBase Class : Strikethrough Property
Gets or sets whether the font object is strikethrough or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Strikethrough As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Strikethrough = value

value = instance.Strikethrough
public bool Strikethrough {get; set;}
public: __property bool get_Strikethrough();
public: __property void set_Strikethrough(
   bool value
);
public:
property bool Strikethrough {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this font object is strikethrough; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%ItemTitle%%

Underline Property

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PDFFontBase Class : Underline Property
Gets or sets whether the font object is underline or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Underline As Boolean
'Usage

Dim instance As PDFFontBase
Dim value As Boolean

instance.Underline = value

value = instance.Underline
public bool Underline {get; set;}
public: __property bool get_Underline();
public: __property void set_Underline(
   bool value
);
public:
property bool Underline {
   bool get();
   void set (    bool value);
}

Property Value

This property returns true if this font object is underline; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFontBase Class
PDFFontBase Members


%%PageItemTitle%%

PostScriptFont Class
Members

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PostScriptFont Class
Defines a particular format for text, including font face and size.
Object Model
PostScriptFont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class PostScriptFont
   Inherits PDFFontBase
'Usage

Dim instance As PostScriptFont
public sealed class PostScriptFont : PDFFontBase
public __gc __sealed class PostScriptFont : public PDFFontBase
public ref class PostScriptFont sealed : public PDFFontBase
Remarks
A PostScript font is always loaded from disk. The metrics of the font are specified in an .afm file (Adobe Font Metrics) and the binary representation of the font is specified in a .pfb file (Printer Font Binary).

The font can be embedded or not in the pdf file. When the font is embedded in the pdf file, the most accurate results are obtained when the file is viewed and printed. The viewer will synthesize the correct appearance of the font based on the embedded data, and the bold and italic modifiers do not have any effect.

If the font is not embedded in the pdf file, the pdf viewer will load the font from the local machine and will use it for display. If the font is not installed on the local machine, then the pdf viewer will use a local font that will match closely the metrics of the font used in the pdf file.

Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDFView4NET.Graphics.Fonts.PostScriptFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Members
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

PostScriptFont Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PostScriptFont Class

The following tables list the members exposed by PostScriptFont.

Public Constructors
 | Name | Description
Public Constructor | PostScriptFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | FontName | Gets the name of the font. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PostScriptFont Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

PostScriptFont Constructor

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PostScriptFont Class : PostScriptFont Constructor
Overload List
Overload | Description
PostScriptFont Constructor(String,String,Double,Boolean) | Initializes a new PostScriptFont object based on the given metrics and font data files.
PostScriptFont Constructor(PostScriptFont,Double) | Initializes a new PostScriptFont object based on an existing font object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%PageItemTitle%%

PostScriptFont Constructor(String,String,Double,Boolean)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PostScriptFont Class > PostScriptFont Constructor : PostScriptFont Constructor(String,String,Double,Boolean)
the full path to file containing the metrics for this PostScript font.
the full path to file containing the binary representation of this PostScript font.
the size of the font, in points.
a flag specifying whether the font should be embedded in the pdf file or not.
Initializes a new PostScriptFont object based on the given metrics and font data files.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal metricsFile As String, _
   ByVal fontDataFile As String, _
   ByVal size As Double, _
   ByVal embed As Boolean _
)
'Usage

Dim metricsFile As String
Dim fontDataFile As String
Dim size As Double
Dim embed As Boolean

Dim instance As New PostScriptFont(metricsFile, fontDataFile, size, embed)
public PostScriptFont(
   string metricsFile,
   string fontDataFile,
   double size,
   bool embed
)
public: PostScriptFont(
   string* metricsFile,
   string* fontDataFile,
   double size,
   bool embed
)
public:
PostScriptFont(
   String^ metricsFile,
   String^ fontDataFile,
   double size,
   bool embed
)

Parameters

metricsFile
the full path to file containing the metrics for this PostScript font.
fontDataFile
the full path to file containing the binary representation of this PostScript font.
size
the size of the font, in points.
embed
a flag specifying whether the font should be embedded in the pdf file or not.
Remarks
A PostScript font is always loaded from disk. The metrics of the font are specified using an .afm file (Adobe Font Metrics) or a .pfm file (Printer Font Metrics). The binary representation of the font is specified using a .pfb file (Printer Font Binary).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members
Overload List


%%PageItemTitle%%

PostScriptFont Constructor(PostScriptFont,Double)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PostScriptFont Class > PostScriptFont Constructor : PostScriptFont Constructor(PostScriptFont,Double)
the original PostScriptFont object
the size of the new font
Initializes a new PostScriptFont object based on an existing font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PostScriptFont, _
   ByVal size As Double _
)
'Usage

Dim font As PostScriptFont
Dim size As Double

Dim instance As New PostScriptFont(font, size)
public PostScriptFont(
   PostScriptFont font,
   double size
)
public: PostScriptFont(
   PostScriptFont* font,
   double size
)
public:
PostScriptFont(
   PostScriptFont^ font,
   double size
)

Parameters

font
the original PostScriptFont object
size
the size of the new font
Remarks
Use this constructor when the same font (the same face)) is used multiple time but at different sizes. This will avoid reparsing the font file. Because the some of the internal structures are shared by the new and the original font object, changing the bold and italic modifiers for one font object, will also update the other font object. This is because the values of this modifiers are built in the font data. All the other properties of the font (underline, overline, strikethrough, size) can be changed without side effects. The embedding can not be changed for the new font, if the original font is embedded, this new font will use the same embedded data, in order to avoid redundancy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members
Overload List


%%PageItemTitle%% $$Methods$$

PostScriptFont Class Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PostScriptFont Class

For a list of all members of this type, see PostScriptFont members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PostScriptFont Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

GetCharWidth Method (PostScriptFont)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PostScriptFont Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As PostScriptFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a double value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%PageItemTitle%% $$Properties$$

PostScriptFont Class Properties

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PostScriptFont Class

For a list of all members of this type, see PostScriptFont members.

Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | FontName | Gets the name of the font. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

PostScriptFont Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

Bold Property (PostScriptFont)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PostScriptFont Class : Bold Property
Gets of sets whether the font object is bold or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Property Bold As Boolean
'Usage

Dim instance As PostScriptFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public override bool Bold {get; set;}
public: __property bool get_Bold() override;
public: __property void set_Bold(
   bool value
) override;
public:
property bool Bold {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this Font object is bold; otherwise, false.
Remarks
When the Type1 font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate weight (bold or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct weight (assuming the font is installed on the local computer). It the bold face of the font is not installed on the local machine, and only the regular face is installed, the pdf viewer will synthesize the bold appearance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%ItemTitle%%

Italic Property (PostScriptFont)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > PostScriptFont Class : Italic Property
Gets of sets whether the font object is italic or not
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Property Italic As Boolean
'Usage

Dim instance As PostScriptFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public override bool Italic {get; set;}
public: __property bool get_Italic() override;
public: __property void set_Italic(
   bool value
) override;
public:
property bool Italic {
   bool get() override;
   void set (    bool value) override;
}

Property Value

This property returns true if this Font object is italic; otherwise, false.
Remarks
When the Type1 font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate face (italic or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct face (assuming the font is installed on the local computer).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostScriptFont Class
PostScriptFont Members


%%PageItemTitle%%

TrueTypeFont Class
Members

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : TrueTypeFont Class
Defines a TrueType font that can be used in a PDF file.
Object Model
TrueTypeFont Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class TrueTypeFont
   Inherits PDFFontBase
'Usage

Dim instance As TrueTypeFont
public class TrueTypeFont : PDFFontBase
public __gc class TrueTypeFont : public PDFFontBase
public ref class TrueTypeFont : public PDFFontBase
Remarks

The font can be embedded or not in the pdf file. When the font is embedded in the pdf file, the most accurate results are obtained when the file is viewed and printed. The viewer will synthesize the correct appearance of the font based on the embedded data, and the bold and italic modifiers do not have any effect.

If the font is not embedded in the pdf file, the pdf viewer will load the font from the local machine and will use it for display. If the font is not installed on the local machine, then the pdf viewer will use a local font that will match closely the metrics of the font used in the pdf file.

When the font is not emdedded in the pdf file, the bold and italic modifiers have the following effect: assuming that the font used for displaying text has only a regular face, these modifiers force the pdf viewer to synthesize the bold or italic appearance of the font. But the regular version of the font must be installed on the machine where the pdf file is viewed.

Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDFView4NET.Graphics.Fonts.TrueTypeFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Members
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

TrueTypeFont Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : TrueTypeFont Class

The following tables list the members exposed by TrueTypeFont.

Public Constructors
 | Name | Description
Public Constructor | TrueTypeFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | FontName | Gets the name of the font. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Name | Gets the name of this font.
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

TrueTypeFont Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%%

TrueTypeFont Constructor

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class : TrueTypeFont Constructor
Overload List
Overload | Description
TrueTypeFont Constructor(String,Double,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(String,Double,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(String,Int32,Double,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(Stream,Double,Boolean) | Initializes a new TrueTypeFont object based on the given font stream and size.
TrueTypeFont Constructor(Stream,Double,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font stream and size.
TrueTypeFont Constructor(Stream,Int32,Double,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font stream and size.
TrueTypeFont Constructor(Font,Boolean) | Initializes a new TrueTypeFont object based on a System.Drawing.Font object.
TrueTypeFont Constructor(Font,Boolean,Boolean) | Initializes a new TrueTypeFont object based on a System.Drawing.Font object.
TrueTypeFont Constructor(TrueTypeFont,Double) | Initializes a new TrueTypeFont object based on an existing font object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


%%PageItemTitle%%

TrueTypeFont Constructor(String,Double,Boolean)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Double,Boolean)
the full path to the font file.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on the given font file and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeFontFile As String, _
   ByVal size As Double, _
   ByVal embed As Boolean _
)
'Usage

Dim trueTypeFontFile As String
Dim size As Double
Dim embed As Boolean

Dim instance As New TrueTypeFont(trueTypeFontFile, size, embed)
public TrueTypeFont(
   string trueTypeFontFile,
   double size,
   bool embed
)
public: TrueTypeFont(
   string* trueTypeFontFile,
   double size,
   bool embed
)
public:
TrueTypeFont(
   String^ trueTypeFontFile,
   double size,
   bool embed
)

Parameters

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(String,Double,Boolean,Boolean)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Double,Boolean,Boolean)
the full path to the font file.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font file and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeFontFile As String, _
   ByVal size As Double, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim trueTypeFontFile As String
Dim size As Double
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(trueTypeFontFile, size, embed, unicode)
public TrueTypeFont(
   string trueTypeFontFile,
   double size,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   string* trueTypeFontFile,
   double size,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   String^ trueTypeFontFile,
   double size,
   bool embed,
   bool unicode
)

Parameters

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(String,Int32,Double,Boolean,Boolean)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Int32,Double,Boolean,Boolean)
the full path to the TrueType collection file.
The index of the font in the collection.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font file and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeCollectionFile As String, _
   ByVal fontIndex As Integer, _
   ByVal size As Double, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim trueTypeCollectionFile As String
Dim fontIndex As Integer
Dim size As Double
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(trueTypeCollectionFile, fontIndex, size, embed, unicode)
public TrueTypeFont(
   string trueTypeCollectionFile,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   string* trueTypeCollectionFile,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   String^ trueTypeCollectionFile,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)

Parameters

trueTypeCollectionFile
the full path to the TrueType collection file.
fontIndex
The index of the font in the collection.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Stream,Double,Boolean)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Stream,Double,Boolean)
a stream object with font data.
the size of the font, in points.
true if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on the given font stream and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeFontStream As Stream, _
   ByVal size As Double, _
   ByVal embed As Boolean _
)
'Usage

Dim trueTypeFontStream As Stream
Dim size As Double
Dim embed As Boolean

Dim instance As New TrueTypeFont(trueTypeFontStream, size, embed)
public TrueTypeFont(
   Stream trueTypeFontStream,
   double size,
   bool embed
)
public: TrueTypeFont(
   Stream* trueTypeFontStream,
   double size,
   bool embed
)
public:
TrueTypeFont(
   Stream^ trueTypeFontStream,
   double size,
   bool embed
)

Parameters

trueTypeFontStream
a stream object with font data.
size
the size of the font, in points.
embed
true if the font file should be embedded in the pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Stream,Double,Boolean,Boolean)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Stream,Double,Boolean,Boolean)
a stream object with font data.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font stream and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeFontStream As Stream, _
   ByVal size As Double, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim trueTypeFontStream As Stream
Dim size As Double
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(trueTypeFontStream, size, embed, unicode)
public TrueTypeFont(
   Stream trueTypeFontStream,
   double size,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   Stream* trueTypeFontStream,
   double size,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   Stream^ trueTypeFontStream,
   double size,
   bool embed,
   bool unicode
)

Parameters

trueTypeFontStream
a stream object with font data.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Remarks
The font is always loaded from disk.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Stream,Int32,Double,Boolean,Boolean)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Stream,Int32,Double,Boolean,Boolean)
a stream object with TrueType collection data.
The index of the font in the collection.
the size of the font, in points.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font stream and size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal trueTypeCollectionStream As Stream, _
   ByVal fontIndex As Integer, _
   ByVal size As Double, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim trueTypeCollectionStream As Stream
Dim fontIndex As Integer
Dim size As Double
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(trueTypeCollectionStream, fontIndex, size, embed, unicode)
public TrueTypeFont(
   Stream trueTypeCollectionStream,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   Stream* trueTypeCollectionStream,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   Stream^ trueTypeCollectionStream,
   int fontIndex,
   double size,
   bool embed,
   bool unicode
)

Parameters

trueTypeCollectionStream
a stream object with TrueType collection data.
fontIndex
The index of the font in the collection.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Remarks
The font is always loaded from disk.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Font,Boolean)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Font,Boolean)
the System.Drawing.Font object.
true, if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on a System.Drawing.Font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As Font, _
   ByVal embed As Boolean _
)
'Usage

Dim font As Font
Dim embed As Boolean

Dim instance As New TrueTypeFont(font, embed)
public TrueTypeFont(
   Font font,
   bool embed
)
public: TrueTypeFont(
   Font* font,
   bool embed
)
public:
TrueTypeFont(
   Font^ font,
   bool embed
)

Parameters

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(Font,Boolean,Boolean)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Font,Boolean,Boolean)
the System.Drawing.Font object.
true, if the font file should be embedded in the pdf file.
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on a System.Drawing.Font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As Font, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
'Usage

Dim font As Font
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As New TrueTypeFont(font, embed, unicode)
public TrueTypeFont(
   Font font,
   bool embed,
   bool unicode
)
public: TrueTypeFont(
   Font* font,
   bool embed,
   bool unicode
)
public:
TrueTypeFont(
   Font^ font,
   bool embed,
   bool unicode
)

Parameters

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%%

TrueTypeFont Constructor(TrueTypeFont,Double)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(TrueTypeFont,Double)
the original TrueTypeFont object
the size of the new font
Initializes a new TrueTypeFont object based on an existing font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As TrueTypeFont, _
   ByVal size As Double _
)
'Usage

Dim font As TrueTypeFont
Dim size As Double

Dim instance As New TrueTypeFont(font, size)
public TrueTypeFont(
   TrueTypeFont font,
   double size
)
public: TrueTypeFont(
   TrueTypeFont* font,
   double size
)
public:
TrueTypeFont(
   TrueTypeFont^ font,
   double size
)

Parameters

font
the original TrueTypeFont object
size
the size of the new font
Remarks
Use this constructor when the same font (the same face)) is used multiple time but at different sizes. This will avoid reparsing the font file. Because the some of the internal structures are shared by the new and the original font object, changing the bold and italic modifiers for one font object, will also update the other font object. This is because the values of this modifiers are built in the font data. All the other properties of the font (underline, overline, strikethrough, size) can be changed without side effects. The embedding can not be changed for the new font, if the original font is embedded, this new font will use the same embedded data, in order to avoid redundancy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


%%PageItemTitle%% $$Methods$$

TrueTypeFont Class Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : TrueTypeFont Class

For a list of all members of this type, see TrueTypeFont members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

TrueTypeFont Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

GetCharWidth Method (TrueTypeFont)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As TrueTypeFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a double value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


%%PageItemTitle%% $$Properties$$

TrueTypeFont Class Properties

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : TrueTypeFont Class

For a list of all members of this type, see TrueTypeFont members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | FontName | Gets the name of the font. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Name | Gets the name of this font.
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

TrueTypeFont Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

Name Property (TrueTypeFont)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > TrueTypeFont Class : Name Property
Gets the name of this font.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As TrueTypeFont
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

The name of the font as it appears in the font file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


%%PageItemTitle%%

Type0Font Class
Members

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : Type0Font Class
Defines a generic Type0 font that can be used in a PDF file.
Object Model
Type0Font Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Type0Font
   Inherits PDFFontBase
'Usage

Dim instance As Type0Font
public class Type0Font : PDFFontBase
public __gc class Type0Font : public PDFFontBase
public ref class Type0Font : public PDFFontBase
Remarks
This class is for internal library use.
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDFView4NET.Graphics.Fonts.Type0Font

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type0Font Members
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Members$$

Type0Font Class Members
Properties Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : Type0Font Class

The following tables list the members exposed by Type0Font.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | FontName | Gets the name of the font. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

Type0Font Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%PageItemTitle%% $$Methods$$

Type0Font Class Methods

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : Type0Font Class

For a list of all members of this type, see Type0Font members.

Public Methods
 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

Type0Font Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

GetCharWidth Method (Type0Font)

O2S.Components.PDFView4NET.Graphics.Fonts Namespace > Type0Font Class : GetCharWidth Method
the char to get its width
Gets the width of the given character when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
'Usage

Dim instance As Type0Font
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
public override double GetCharWidth(
   char charCode
)
public: double GetCharWidth(
   char charCode
) override
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a double value that represents the width, in unscaled glyph units, of the given character.
Remarks
To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Type0Font Class
Type0Font Members


%%PageItemTitle%%

PDFFontFace Enumeration

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : PDFFontFace Enumeration
Specifies the available PDF fonts for drawing text on a page
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFFontFace
   Inherits System.Enum
'Usage

Dim instance As PDFFontFace
public enum PDFFontFace : System.Enum
__value public enum PDFFontFace : public System.Enum
public enum class PDFFontFace : public System.Enum
Members
Member | Description
Courier | The Courier font
Helvetica | The Helvetica font
Symbol | The Symbol font
TimesRoman | The Times Roman font
ZapfDingbats | The ZapfDingbats font
Remarks
These fonts and their variations (bold, italic) are recongized and implemented by any PDF viewer.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontFace

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%%

O2S.Components.PDFView4NET.Graphics.OptionalContent Namespace
Inheritance Hierarchy
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%ItemTitle%%

O2S.Components.PDFView4NET.Printing Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFPrintSettings |
Class | PrintProgressEventArgs | Defines the arguments for print progress event.
Enumerations
 | Enumeration | Description
Enumeration | PageScaling | Specifies the available scaling options when printing a PDF file.
Enumeration | PDFPrintContent | Specifies what parts of the page (content, annotations and/or form fields) should be printed.
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

PDFPrintSettings Class
Members

O2S.Components.PDFView4NET.Printing Namespace : PDFPrintSettings Class
Object Model
PDFPrintSettings Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPrintSettings
'Usage

Dim instance As PDFPrintSettings
public class PDFPrintSettings
public __gc class PDFPrintSettings
public ref class PDFPrintSettings
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Printing.PDFPrintSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Members
O2S.Components.PDFView4NET.Printing Namespace


%%PageItemTitle%% $$Members$$

PDFPrintSettings Class Members
Properties

O2S.Components.PDFView4NET.Printing Namespace : PDFPrintSettings Class

The following tables list the members exposed by PDFPrintSettings.

Public Constructors
 | Name | Description
Public Constructor | PDFPrintSettings Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AutoRotate | Gets or sets a value indicating whether the page should be rotated to match the paper orientation.
Public Property | BitmapPrintResolution | Gets or sets the bitmap resolution for printing.
Public Property | BitmapTransparentColor | Gets or sets the bitmap transparent color.
Public Property | Columns | Gets or sets the columns count.
Public Property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document.
Public Property | DownscaleLargeImages | Gets or sets a value indicating whether large images should be down scaled.
Public Property | PageScaling | Gets or sets the page scaling.
Public Property | PaperSize | Gets or sets the paper size for the page.
Public Property | PaperSource | Gets or sets the page's paper source.
Public Property | PenAdjust | Gets or sets the value of pen adjustment factor.
Public Property | PrinterSettings | Gets the printer settings for printing the PDF file
Public Property | PrintRanges | Gets or sets the ranges of pages to print.
Public Property | Rows | Gets or sets the rows count.
Top
See Also

Reference

PDFPrintSettings Class
O2S.Components.PDFView4NET.Printing Namespace


%%PageItemTitle%%

PDFPrintSettings Constructor

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : PDFPrintSettings Constructor
Overload List
Overload | Description
PDFPrintSettings Constructor() | Initializes a new PDFPrintSettings object.
PDFPrintSettings Constructor(PrinterSettings) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%PageItemTitle%%

PDFPrintSettings Constructor()

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class > PDFPrintSettings Constructor : PDFPrintSettings Constructor()
Initializes a new PDFPrintSettings object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PDFPrintSettings()
public PDFPrintSettings()
public: PDFPrintSettings();
public:
PDFPrintSettings();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members
Overload List


%%PageItemTitle%%

PDFPrintSettings Constructor(PrinterSettings)

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class > PDFPrintSettings Constructor : PDFPrintSettings Constructor(PrinterSettings)
Printer settings object for printing the PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal printerSettings As PrinterSettings _
)
'Usage

Dim printerSettings As PrinterSettings

Dim instance As New PDFPrintSettings(printerSettings)
public PDFPrintSettings(
   PrinterSettings printerSettings
)
public: PDFPrintSettings(
   PrinterSettings* printerSettings
)
public:
PDFPrintSettings(
   PrinterSettings^ printerSettings
)

Parameters

printerSettings
Printer settings object for printing the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members
Overload List


%%PageItemTitle%% $$Properties$$

PDFPrintSettings Class Properties

O2S.Components.PDFView4NET.Printing Namespace : PDFPrintSettings Class

For a list of all members of this type, see PDFPrintSettings members.

Public Properties
 | Name | Description
Public Property | AutoRotate | Gets or sets a value indicating whether the page should be rotated to match the paper orientation.
Public Property | BitmapPrintResolution | Gets or sets the bitmap resolution for printing.
Public Property | BitmapTransparentColor | Gets or sets the bitmap transparent color.
Public Property | Columns | Gets or sets the columns count.
Public Property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document.
Public Property | DownscaleLargeImages | Gets or sets a value indicating whether large images should be down scaled.
Public Property | PageScaling | Gets or sets the page scaling.
Public Property | PaperSize | Gets or sets the paper size for the page.
Public Property | PaperSource | Gets or sets the page's paper source.
Public Property | PenAdjust | Gets or sets the value of pen adjustment factor.
Public Property | PrinterSettings | Gets the printer settings for printing the PDF file
Public Property | PrintRanges | Gets or sets the ranges of pages to print.
Public Property | Rows | Gets or sets the rows count.
Top
See Also

Reference

PDFPrintSettings Class
O2S.Components.PDFView4NET.Printing Namespace


%%ItemTitle%%

AutoRotate Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : AutoRotate Property
Gets or sets a value indicating whether the page should be rotated to match the paper orientation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoRotate As Boolean
'Usage

Dim instance As PDFPrintSettings
Dim value As Boolean

instance.AutoRotate = value

value = instance.AutoRotate
public bool AutoRotate {get; set;}
public: __property bool get_AutoRotate();
public: __property void set_AutoRotate(
   bool value
);
public:
property bool AutoRotate {
   bool get();
   void set (    bool value);
}

Property Value

True if the page should be rotated in order to match the paper orientation, false otherwise. Default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

BitmapPrintResolution Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : BitmapPrintResolution Property
Gets or sets the bitmap resolution for printing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitmapPrintResolution As Double
'Usage

Dim instance As PDFPrintSettings
Dim value As Double

instance.BitmapPrintResolution = value

value = instance.BitmapPrintResolution
public double BitmapPrintResolution {get; set;}
public: __property double get_BitmapPrintResolution();
public: __property void set_BitmapPrintResolution(
   double value
);
public:
property double BitmapPrintResolution {
   double get();
   void set (    double value);
}

Property Value

The resolution of the printed bitmap.
Remarks
By default the PDF file is printed by rendering the page content directly on printer's Graphics surface. In some situations this process is slow, so an alternate bitmap print can be used. The page is converted to a bitmap image and then the bitmap is drawn on printer's Graphics surface. Set this property to a value greater than zero if you want to use the bitmap print method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

BitmapTransparentColor Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : BitmapTransparentColor Property
Gets or sets the bitmap transparent color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitmapTransparentColor As Color
'Usage

Dim instance As PDFPrintSettings
Dim value As Color

instance.BitmapTransparentColor = value

value = instance.BitmapTransparentColor
public Color BitmapTransparentColor {get; set;}
public: __property Color get_BitmapTransparentColor();
public: __property void set_BitmapTransparentColor(
   Color value
);
public:
property Color BitmapTransparentColor {
   Color get();
   void set (    Color value);
}

Property Value

The color of the bitmap to be considered transparent.
Remarks
When the page is printed in bitmap mode, the printed bitmap is opaque. The printed bitmap can be made transparent by setting this property to a color (usually white) and this color in the bitmap will be replaced with a transparent color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

Columns Property (PDFPrintSettings)

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : Columns Property
Gets or sets the columns count.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Columns As Integer
'Usage

Dim instance As PDFPrintSettings
Dim value As Integer

instance.Columns = value

value = instance.Columns
public int Columns {get; set;}
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
public:
property int Columns {
   int get();
   void set (    int value);
}

Property Value

The number of columns a paper sheet is divided into when printing multiple pages per sheet.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when values is less than 1.
Remarks
This property is used only when PageScaling is PageScaling.MultiplePagesPerSheet.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

DocumentName Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : DocumentName Property
Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DocumentName As String
'Usage

Dim instance As PDFPrintSettings
Dim value As String

instance.DocumentName = value

value = instance.DocumentName
public string DocumentName {get; set;}
public: __property string* get_DocumentName();
public: __property void set_DocumentName(
   string* value
);
public:
property String^ DocumentName {
   String^ get();
   void set (    String^ value);
}

Property Value

The document name to display while printing the document. The default is the name of the file being printed.
Remarks
The DocumentName property does not specify the file to print.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

DownscaleLargeImages Property (PDFPrintSettings)

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : DownscaleLargeImages Property
Gets or sets a value indicating whether large images should be down scaled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DownscaleLargeImages As Boolean
'Usage

Dim instance As PDFPrintSettings
Dim value As Boolean

instance.DownscaleLargeImages = value

value = instance.DownscaleLargeImages
public bool DownscaleLargeImages {get; set;}
public: __property bool get_DownscaleLargeImages();
public: __property void set_DownscaleLargeImages(
   bool value
);
public:
property bool DownscaleLargeImages {
   bool get();
   void set (    bool value);
}

Property Value

If true, large images are scaled down before they are printed.
Remarks
Very large images can show memory problems when they are printed. If this property is true, a large image is reduced in size before it is painted on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

PageScaling Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : PageScaling Property
Gets or sets the page scaling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PageScaling As PageScaling
'Usage

Dim instance As PDFPrintSettings
Dim value As PageScaling

instance.PageScaling = value

value = instance.PageScaling
public PageScaling PageScaling {get; set;}
public: __property PageScaling get_PageScaling();
public: __property void set_PageScaling(
   PageScaling value
);
public:
property PageScaling PageScaling {
   PageScaling get();
   void set (    PageScaling value);
}

Property Value

The scaling mode applied to PDF pages when they are printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

PaperSize Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : PaperSize Property
Gets or sets the paper size for the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperSize As PaperSize
'Usage

Dim instance As PDFPrintSettings
Dim value As PaperSize

instance.PaperSize = value

value = instance.PaperSize
public PaperSize PaperSize {get; set;}
public: __property PaperSize* get_PaperSize();
public: __property void set_PaperSize(
   PaperSize* value
);
public:
property PaperSize^ PaperSize {
   PaperSize^ get();
   void set (    PaperSize^ value);
}

Property Value

A PaperSize object that represents the size of the paper.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

PaperSource Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : PaperSource Property
Gets or sets the page's paper source.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperSource As PaperSource
'Usage

Dim instance As PDFPrintSettings
Dim value As PaperSource

instance.PaperSource = value

value = instance.PaperSource
public PaperSource PaperSource {get; set;}
public: __property PaperSource* get_PaperSource();
public: __property void set_PaperSource(
   PaperSource* value
);
public:
property PaperSource^ PaperSource {
   PaperSource^ get();
   void set (    PaperSource^ value);
}

Property Value

A PaperSource object that specifies the source of the paper.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

PenAdjust Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : PenAdjust Property
Gets or sets the value of pen adjustment factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PenAdjust As Double
'Usage

Dim instance As PDFPrintSettings
Dim value As Double

instance.PenAdjust = value

value = instance.PenAdjust
public double PenAdjust {get; set;}
public: __property double get_PenAdjust();
public: __property void set_PenAdjust(
   double value
);
public:
property double PenAdjust {
   double get();
   void set (    double value);
}

Property Value

Global value that is added to any pen used to draw graphics.
Remarks
This property increases or decreases the width of any pen used in the PDF file with the specified amount.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

PrinterSettings Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : PrinterSettings Property
Gets the printer settings for printing the PDF file
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PrinterSettings As PrinterSettings
'Usage

Dim instance As PDFPrintSettings
Dim value As PrinterSettings

value = instance.PrinterSettings
public PrinterSettings PrinterSettings {get;}
public: __property PrinterSettings* get_PrinterSettings();
public:
property PrinterSettings^ PrinterSettings {
   PrinterSettings^ get();
}

Property Value

Settings for printing the PDF file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

PrintRanges Property

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : PrintRanges Property
Gets or sets the ranges of pages to print.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PrintRanges As String
'Usage

Dim instance As PDFPrintSettings
Dim value As String

instance.PrintRanges = value

value = instance.PrintRanges
public string PrintRanges {get; set;}
public: __property string* get_PrintRanges();
public: __property void set_PrintRanges(
   string* value
);
public:
property String^ PrintRanges {
   String^ get();
   void set (    String^ value);
}

Property Value

Multiple page ranges, separated by comma.
Remarks
Use this property to print multiple page ranges, because the PrinterSettings object allows to print only a single continuous page range. When this property is set, the PrinterSettings.PrintRange property is ignored. Values accepted by this property look like this: "1-3,5,7,9-12". If a range is not valid, those pages are not printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%ItemTitle%%

Rows Property (PDFPrintSettings)

O2S.Components.PDFView4NET.Printing Namespace > PDFPrintSettings Class : Rows Property
Gets or sets the rows count.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As PDFPrintSettings
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

The number of rows a paper sheet is divided into when printing multiple pages per sheet.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when values is less than 1.
Remarks
This property is used only when PageScaling is PageScaling.MultiplePagesPerSheet.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPrintSettings Class
PDFPrintSettings Members


%%PageItemTitle%%

PrintProgressEventArgs Class
Members

O2S.Components.PDFView4NET.Printing Namespace : PrintProgressEventArgs Class
Defines the arguments for print progress event.
Object Model
PrintProgressEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PrintProgressEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PrintProgressEventArgs
public class PrintProgressEventArgs : System.EventArgs
public __gc class PrintProgressEventArgs : public System.EventArgs
public ref class PrintProgressEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
O2S.Components.PDFView4NET.Printing.PrintProgressEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Members
O2S.Components.PDFView4NET.Printing Namespace


%%PageItemTitle%% $$Members$$

PrintProgressEventArgs Class Members
Properties

O2S.Components.PDFView4NET.Printing Namespace : PrintProgressEventArgs Class

The following tables list the members exposed by PrintProgressEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PrintProgressEventArgs Constructor | Initializes a new PrintProgressEventArgs object.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the page printing should be cancelled or not.
Public Property | CurrentPage | Gets the page number within the print range being printed.
Public Property | PageNumber | Gets the page number within the document being printed.
Public Property | PrintPageCount | Gets the total number of pages being printed.
Top
See Also

Reference

PrintProgressEventArgs Class
O2S.Components.PDFView4NET.Printing Namespace


%%PageItemTitle%%

PrintProgressEventArgs Constructor

O2S.Components.PDFView4NET.Printing Namespace > PrintProgressEventArgs Class : PrintProgressEventArgs Constructor
The number of the page within the document being printed.
The number of the page within the printed range being printed.
Total number of pages being printed.
Initializes a new PrintProgressEventArgs object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageNumber As Integer, _
   ByVal currentPage As Integer, _
   ByVal printPageCount As Integer _
)
'Usage

Dim pageNumber As Integer
Dim currentPage As Integer
Dim printPageCount As Integer

Dim instance As New PrintProgressEventArgs(pageNumber, currentPage, printPageCount)
public PrintProgressEventArgs(
   int pageNumber,
   int currentPage,
   int printPageCount
)
public: PrintProgressEventArgs(
   int pageNumber,
   int currentPage,
   int printPageCount
)
public:
PrintProgressEventArgs(
   int pageNumber,
   int currentPage,
   int printPageCount
)

Parameters

pageNumber
The number of the page within the document being printed.
currentPage
The number of the page within the printed range being printed.
printPageCount
Total number of pages being printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


%%PageItemTitle%% $$Properties$$

PrintProgressEventArgs Class Properties

O2S.Components.PDFView4NET.Printing Namespace : PrintProgressEventArgs Class

For a list of all members of this type, see PrintProgressEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the page printing should be cancelled or not.
Public Property | CurrentPage | Gets the page number within the print range being printed.
Public Property | PageNumber | Gets the page number within the document being printed.
Public Property | PrintPageCount | Gets the total number of pages being printed.
Top
See Also

Reference

PrintProgressEventArgs Class
O2S.Components.PDFView4NET.Printing Namespace


%%ItemTitle%%

Cancel Property (PrintProgressEventArgs)

O2S.Components.PDFView4NET.Printing Namespace > PrintProgressEventArgs Class : Cancel Property
Gets or sets a value indicating whether the page printing should be cancelled or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As PrintProgressEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

True if the printing, otherwise false. Default false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


%%ItemTitle%%

CurrentPage Property

O2S.Components.PDFView4NET.Printing Namespace > PrintProgressEventArgs Class : CurrentPage Property
Gets the page number within the print range being printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CurrentPage As Integer
'Usage

Dim instance As PrintProgressEventArgs
Dim value As Integer

value = instance.CurrentPage
public int CurrentPage {get;}
public: __property int get_CurrentPage();
public:
property int CurrentPage {
   int get();
}

Property Value

The number of the page within the print range being printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


%%ItemTitle%%

PageNumber Property (PrintProgressEventArgs)

O2S.Components.PDFView4NET.Printing Namespace > PrintProgressEventArgs Class : PageNumber Property
Gets the page number within the document being printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As PrintProgressEventArgs
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

The number of the page within the document being printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


%%ItemTitle%%

PrintPageCount Property

O2S.Components.PDFView4NET.Printing Namespace > PrintProgressEventArgs Class : PrintPageCount Property
Gets the total number of pages being printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PrintPageCount As Integer
'Usage

Dim instance As PrintProgressEventArgs
Dim value As Integer

value = instance.PrintPageCount
public int PrintPageCount {get;}
public: __property int get_PrintPageCount();
public:
property int PrintPageCount {
   int get();
}

Property Value

Number of pages being printed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


%%PageItemTitle%%

PageScaling Enumeration

O2S.Components.PDFView4NET.Printing Namespace : PageScaling Enumeration
Specifies the available scaling options when printing a PDF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PageScaling
   Inherits System.Enum
'Usage

Dim instance As PageScaling
public enum PageScaling : System.Enum
__value public enum PageScaling : public System.Enum
public enum class PageScaling : public System.Enum
Members
Member | Description
FitToPrinterMargins | Page content is scaled, enlarged or reduced, to fit the printable area. The original aspect ratio is not preserved.
FitToPrinterMarginsProportional | Page content is scaled, enlarged or reduced, to fit the printable area. The original aspect ratio is preserved.
MultiplePagesPerSheet | Multiple pages are printed on a single sheet of paper.
MultiplePagesPerSheetProportional | Multiple pages are printed on a single sheet of paper. The original aspect ratio is preserved for each page.
None | No page scaling is performed. The page content is displayed starting from the top left corner of the page. Content that falls outside the printable are is not printed.
ReduceToPrinterMargins | Page content is scaled (reduced) to fit the printable area if it is larger than the printable area. If it is smaller, no scaling is performed. The original aspect ratio is not preserved if one of the dimensions, width and/or height, needs to be scaled.
ReduceToPrinterMarginsProportional | Page content is scaled (reduced) to fit the printable area if it is larger than the printable area. If it is smaller, no scaling is performed. The original aspect ratio is preserved if one of the dimensions, width and/or height, needs to be scaled.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Printing.PageScaling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Printing Namespace


%%PageItemTitle%%

PDFPrintContent Enumeration

O2S.Components.PDFView4NET.Printing Namespace : PDFPrintContent Enumeration
Specifies what parts of the page (content, annotations and/or form fields) should be printed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PDFPrintContent
   Inherits System.Enum
'Usage

Dim instance As PDFPrintContent
[Flags()]
public enum PDFPrintContent : System.Enum
[Flags()]
__value public enum PDFPrintContent : public System.Enum
[Flags()]
public enum class PDFPrintContent : public System.Enum
Members
Member | Description
Annotations | Annotations should be printed.
FormFields | Form fields should be printed.
Page | Page content should be printed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Printing.PDFPrintContent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Printing Namespace


%%ItemTitle%%

O2S.Components.PDFView4NET.Text Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PDFPageSearchTextResult | Defines the results of a text search operation for a specific PDF page.
Class | PDFPageSearchTextResultCollection | Defines a read only collection of PDFPageSearchTextResult objects.
Class | PDFSearchTextResult | Defines the results of a text search operation.
Class | PDFSearchTextResultCollection | Defines a read only collection of PDFSearchTextResult objects.
Class | PDFTextRun | Defines a sequence of characters that share the same visual attributes.
Class | PDFTextRunCollection | Defines a read only collection of PDFTextRun objects.
Class | PDFTextRunSelection | Specifies which part of a text run represents selected text.
Class | PDFTextRunSelectionCollection | Defines a read only collection of PDFTextRunSelection objects.
Class | PDFTextSelection | Defines a selection of text of a PDF page.
Enumerations
 | Enumeration | Description
Enumeration | PDFHighlightSearchResultsMode | Specifies how the search results are highlighted in the O2S.Components.PDFView4NET.PDFPageView control.
Enumeration | PDFSearchTextRange | Specifies the available ranges for searching text in the viewer control.
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

PDFPageSearchTextResult Class
Members

O2S.Components.PDFView4NET.Text Namespace : PDFPageSearchTextResult Class
Defines the results of a text search operation for a specific PDF page.
Object Model
PDFPageSearchTextResult ClassPDFSearchTextResultCollection ClassPDFSearchTextResult Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageSearchTextResult
'Usage

Dim instance As PDFPageSearchTextResult
public class PDFPageSearchTextResult
public __gc class PDFPageSearchTextResult
public ref class PDFPageSearchTextResult
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Text.PDFPageSearchTextResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageSearchTextResult Members
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFPageSearchTextResult Class Members
Properties

O2S.Components.PDFView4NET.Text Namespace : PDFPageSearchTextResult Class

The following tables list the members exposed by PDFPageSearchTextResult.

Public Properties
 | Name | Description
Public Property | PageNumber | Gets the page number the search results belong to.
Public Property | SearchTextResults | Gets the search results.
Top
See Also

Reference

PDFPageSearchTextResult Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFPageSearchTextResult Class Properties

O2S.Components.PDFView4NET.Text Namespace : PDFPageSearchTextResult Class

For a list of all members of this type, see PDFPageSearchTextResult members.

Public Properties
 | Name | Description
Public Property | PageNumber | Gets the page number the search results belong to.
Public Property | SearchTextResults | Gets the search results.
Top
See Also

Reference

PDFPageSearchTextResult Class
O2S.Components.PDFView4NET.Text Namespace


%%ItemTitle%%

PageNumber Property (PDFPageSearchTextResult)

O2S.Components.PDFView4NET.Text Namespace > PDFPageSearchTextResult Class : PageNumber Property
Gets the page number the search results belong to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageNumber As Integer
'Usage

Dim instance As PDFPageSearchTextResult
Dim value As Integer

value = instance.PageNumber
public int PageNumber {get;}
public: __property int get_PageNumber();
public:
property int PageNumber {
   int get();
}

Property Value

The page on which the search results were found.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageSearchTextResult Class
PDFPageSearchTextResult Members


%%ItemTitle%%

SearchTextResults Property

O2S.Components.PDFView4NET.Text Namespace > PDFPageSearchTextResult Class : SearchTextResults Property
Gets the search results.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SearchTextResults As PDFSearchTextResultCollection
'Usage

Dim instance As PDFPageSearchTextResult
Dim value As PDFSearchTextResultCollection

value = instance.SearchTextResults
public PDFSearchTextResultCollection SearchTextResults {get;}
public: __property PDFSearchTextResultCollection* get_SearchTextResults();
public:
property PDFSearchTextResultCollection^ SearchTextResults {
   PDFSearchTextResultCollection^ get();
}

Property Value

The collection of search results on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageSearchTextResult Class
PDFPageSearchTextResult Members


%%PageItemTitle%%

PDFPageSearchTextResultCollection Class
Members

O2S.Components.PDFView4NET.Text Namespace : PDFPageSearchTextResultCollection Class
Defines a read only collection of PDFPageSearchTextResult objects.
Object Model
PDFPageSearchTextResultCollection ClassPDFPageSearchTextResult Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFPageSearchTextResultCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFPageSearchTextResult)
'Usage

Dim instance As PDFPageSearchTextResultCollection
public class PDFPageSearchTextResultCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>
public __gc class PDFPageSearchTextResultCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>
public ref class PDFPageSearchTextResultCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDFView4NET.Text.PDFPageSearchTextResultCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageSearchTextResultCollection Members
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFPageSearchTextResultCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Text Namespace : PDFPageSearchTextResultCollection Class

The following tables list the members exposed by PDFPageSearchTextResultCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Top
See Also

Reference

PDFPageSearchTextResultCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%%

PDFSearchTextResult Class
Members

O2S.Components.PDFView4NET.Text Namespace : PDFSearchTextResult Class
Defines the results of a text search operation.
Object Model
PDFSearchTextResult ClassPDFPage ClassPDFTextRunCollection ClassPDFTextRun Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSearchTextResult
'Usage

Dim instance As PDFSearchTextResult
public class PDFSearchTextResult
public __gc class PDFSearchTextResult
public ref class PDFSearchTextResult
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Text.PDFSearchTextResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSearchTextResult Members
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFSearchTextResult Class Members
Properties

O2S.Components.PDFView4NET.Text Namespace : PDFSearchTextResult Class

The following tables list the members exposed by PDFSearchTextResult.

Public Properties
 | Name | Description
Public Property | Page | Gets the page this search result belongs to.
Public Property | TextRuns | Gets the list of actual text runs that compose the search result.
Top
See Also

Reference

PDFSearchTextResult Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFSearchTextResult Class Properties

O2S.Components.PDFView4NET.Text Namespace : PDFSearchTextResult Class

For a list of all members of this type, see PDFSearchTextResult members.

Public Properties
 | Name | Description
Public Property | Page | Gets the page this search result belongs to.
Public Property | TextRuns | Gets the list of actual text runs that compose the search result.
Top
See Also

Reference

PDFSearchTextResult Class
O2S.Components.PDFView4NET.Text Namespace


%%ItemTitle%%

Page Property (PDFSearchTextResult)

O2S.Components.PDFView4NET.Text Namespace > PDFSearchTextResult Class : Page Property
Gets the page this search result belongs to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PDFPage
'Usage

Dim instance As PDFSearchTextResult
Dim value As PDFPage

value = instance.Page
public PDFPage Page {get;}
public: __property PDFPage* get_Page();
public:
property PDFPage^ Page {
   PDFPage^ get();
}

Property Value

The page that includes this search result.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSearchTextResult Class
PDFSearchTextResult Members


%%ItemTitle%%

TextRuns Property

O2S.Components.PDFView4NET.Text Namespace > PDFSearchTextResult Class : TextRuns Property
Gets the list of actual text runs that compose the search result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextRuns As PDFTextRunCollection
'Usage

Dim instance As PDFSearchTextResult
Dim value As PDFTextRunCollection

value = instance.TextRuns
public PDFTextRunCollection TextRuns {get;}
public: __property PDFTextRunCollection* get_TextRuns();
public:
property PDFTextRunCollection^ TextRuns {
   PDFTextRunCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSearchTextResult Class
PDFSearchTextResult Members


%%PageItemTitle%%

PDFSearchTextResultCollection Class
Members

O2S.Components.PDFView4NET.Text Namespace : PDFSearchTextResultCollection Class
Defines a read only collection of PDFSearchTextResult objects.
Object Model
PDFSearchTextResultCollection ClassPDFSearchTextResult Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFSearchTextResultCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFSearchTextResult)
'Usage

Dim instance As PDFSearchTextResultCollection
public class PDFSearchTextResultCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>
public __gc class PDFSearchTextResultCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>
public ref class PDFSearchTextResultCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDFView4NET.Text.PDFSearchTextResultCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSearchTextResultCollection Members
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFSearchTextResultCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Text Namespace : PDFSearchTextResultCollection Class

The following tables list the members exposed by PDFSearchTextResultCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top
See Also

Reference

PDFSearchTextResultCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%%

PDFTextRun Class
Members

O2S.Components.PDFView4NET.Text Namespace : PDFTextRun Class
Defines a sequence of characters that share the same visual attributes.
Object Model
PDFTextRun Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextRun
'Usage

Dim instance As PDFTextRun
public class PDFTextRun
public __gc class PDFTextRun
public ref class PDFTextRun
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Text.PDFTextRun

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Members
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFTextRun Class Members
Properties Methods

O2S.Components.PDFView4NET.Text Namespace : PDFTextRun Class

The following tables list the members exposed by PDFTextRun.

Public Properties
 | Name | Description
Public Property | Bounds | Gets the bounding rectangle of the text run.
Public Property | DisplayBounds | Gets the bounds of this text run in display coordinate system.
Public Property | DisplayGlyphBounds | Gets the bounds of the glyphs in the text run in display coordinate system.
Public Property | FontName | Gets the name of the font used to display the text run.
Public Property | FontSize | Gets the size of the font used to display the text run.
Public Property | GlyphBounds | Gets the bounds of the glyphs in the text run.
Public Property | Orientation | Gets the rotation angle of the display bounds.
Public Property | ScaledFontSize | Gets the scaled size of the font used to display the text run.
Public Property | SourceTextRunIndex | Index of the source text run in the text run collection.
Public Property | Text | Gets the text in this object.
Public Property | TextMatrix | Gets the active text matrix.
Public Property | VisibleText | Gets the visible text in this object.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts this object to string representation.
Top
See Also

Reference

PDFTextRun Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Methods$$

PDFTextRun Class Methods

O2S.Components.PDFView4NET.Text Namespace : PDFTextRun Class

For a list of all members of this type, see PDFTextRun members.

Public Methods
 | Name | Description
Public Method | ToString | Converts this object to string representation.
Top
See Also

Reference

PDFTextRun Class
O2S.Components.PDFView4NET.Text Namespace


%%ItemTitle%%

ToString Method (PDFTextRun)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : ToString Method
Converts this object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFTextRun
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The object as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%PageItemTitle%% $$Properties$$

PDFTextRun Class Properties

O2S.Components.PDFView4NET.Text Namespace : PDFTextRun Class

For a list of all members of this type, see PDFTextRun members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets the bounding rectangle of the text run.
Public Property | DisplayBounds | Gets the bounds of this text run in display coordinate system.
Public Property | DisplayGlyphBounds | Gets the bounds of the glyphs in the text run in display coordinate system.
Public Property | FontName | Gets the name of the font used to display the text run.
Public Property | FontSize | Gets the size of the font used to display the text run.
Public Property | GlyphBounds | Gets the bounds of the glyphs in the text run.
Public Property | Orientation | Gets the rotation angle of the display bounds.
Public Property | ScaledFontSize | Gets the scaled size of the font used to display the text run.
Public Property | SourceTextRunIndex | Index of the source text run in the text run collection.
Public Property | Text | Gets the text in this object.
Public Property | TextMatrix | Gets the active text matrix.
Public Property | VisibleText | Gets the visible text in this object.
Top
See Also

Reference

PDFTextRun Class
O2S.Components.PDFView4NET.Text Namespace


%%ItemTitle%%

Bounds Property (PDFTextRun)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : Bounds Property
Gets the bounding rectangle of the text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bounds As PDFRectangle
'Usage

Dim instance As PDFTextRun
Dim value As PDFRectangle

value = instance.Bounds
public PDFRectangle Bounds {get;}
public: __property PDFRectangle* get_Bounds();
public:
property PDFRectangle^ Bounds {
   PDFRectangle^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

DisplayBounds Property (PDFTextRun)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : DisplayBounds Property
Gets the bounds of this text run in display coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayBounds As DisplayRectangle
'Usage

Dim instance As PDFTextRun
Dim value As DisplayRectangle

value = instance.DisplayBounds
public DisplayRectangle DisplayBounds {get;}
public: __property DisplayRectangle* get_DisplayBounds();
public:
property DisplayRectangle^ DisplayBounds {
   DisplayRectangle^ get();
}

Property Value

The bounding rectangle of the text run in display coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

DisplayGlyphBounds Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : DisplayGlyphBounds Property
Gets the bounds of the glyphs in the text run in display coordinate system.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayGlyphBounds As DisplayRectangle()
'Usage

Dim instance As PDFTextRun
Dim value() As DisplayRectangle

value = instance.DisplayGlyphBounds
public DisplayRectangle[] DisplayGlyphBounds {get;}
public: __property DisplayRectangle*[]* get_DisplayGlyphBounds();
public:
property array<DisplayRectangle^>^ DisplayGlyphBounds {
   array<DisplayRectangle^>^ get();
}

Property Value

The bounding rectangles of the glyphs in display coordinate system.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

FontName Property (PDFTextRun)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : FontName Property
Gets the name of the font used to display the text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontName As String
'Usage

Dim instance As PDFTextRun
Dim value As String

value = instance.FontName
public string FontName {get;}
public: __property string* get_FontName();
public:
property String^ FontName {
   String^ get();
}

Property Value

The name of the font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

FontSize Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : FontSize Property
Gets the size of the font used to display the text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FontSize As Double
'Usage

Dim instance As PDFTextRun
Dim value As Double

value = instance.FontSize
public double FontSize {get;}
public: __property double get_FontSize();
public:
property double FontSize {
   double get();
}

Property Value

The size of the font in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

GlyphBounds Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : GlyphBounds Property
Gets the bounds of the glyphs in the text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property GlyphBounds As PDFRectangle()
'Usage

Dim instance As PDFTextRun
Dim value() As PDFRectangle

value = instance.GlyphBounds
public PDFRectangle[] GlyphBounds {get;}
public: __property PDFRectangle*[]* get_GlyphBounds();
public:
property array<PDFRectangle^>^ GlyphBounds {
   array<PDFRectangle^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

Orientation Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : Orientation Property
Gets the rotation angle of the display bounds.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Orientation As Double
'Usage

Dim instance As PDFTextRun
Dim value As Double

value = instance.Orientation
public double Orientation {get;}
public: __property double get_Orientation();
public:
property double Orientation {
   double get();
}

Property Value

The rotation angle of the display bounds, relative to top left corner of the bounding rectangle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

ScaledFontSize Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : ScaledFontSize Property
Gets the scaled size of the font used to display the text run.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScaledFontSize As Double
'Usage

Dim instance As PDFTextRun
Dim value As Double

value = instance.ScaledFontSize
public double ScaledFontSize {get;}
public: __property double get_ScaledFontSize();
public:
property double ScaledFontSize {
   double get();
}

Property Value

The scaled size of the font in points, based on current text matrix.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

SourceTextRunIndex Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : SourceTextRunIndex Property
Index of the source text run in the text run collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SourceTextRunIndex As Integer
'Usage

Dim instance As PDFTextRun
Dim value As Integer

value = instance.SourceTextRunIndex
public int SourceTextRunIndex {get;}
public: __property int get_SourceTextRunIndex();
public:
property int SourceTextRunIndex {
   int get();
}

Property Value

Index of source text run in the text run collection.
Remarks
This property is set only for text runs that a part of a search result and it indicates the text run from which this object has been created.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

Text Property (PDFTextRun)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : Text Property
Gets the text in this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PDFTextRun
Dim value As String

value = instance.Text
public string Text {get;}
public: __property string* get_Text();
public:
property String^ Text {
   String^ get();
}

Property Value

The text content represented by this object.
Remarks
This property includes all characters as they appear in the PDF file, even if they are not visible characters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

TextMatrix Property (PDFTextRun)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : TextMatrix Property
Gets the active text matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextMatrix As PDFMatrix
'Usage

Dim instance As PDFTextRun
Dim value As PDFMatrix

value = instance.TextMatrix
public PDFMatrix TextMatrix {get;}
public: __property PDFMatrix* get_TextMatrix();
public:
property PDFMatrix^ TextMatrix {
   PDFMatrix^ get();
}

Property Value

The transformation matrix being in place when the text is displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%ItemTitle%%

VisibleText Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRun Class : VisibleText Property
Gets the visible text in this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VisibleText As String
'Usage

Dim instance As PDFTextRun
Dim value As String

value = instance.VisibleText
public string VisibleText {get;}
public: __property string* get_VisibleText();
public:
property String^ VisibleText {
   String^ get();
}

Property Value

The visible text content represented by this object.
Remarks
This property includes only the visible characters that are included in the text run. Invisible characters are not included and ligatures are converted to corresponding characters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRun Class
PDFTextRun Members


%%PageItemTitle%%

PDFTextRunCollection Class
Members

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunCollection Class
Defines a read only collection of PDFTextRun objects.
Object Model
PDFTextRunCollection ClassPDFTextRun Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextRunCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFTextRun)
'Usage

Dim instance As PDFTextRunCollection
public class PDFTextRunCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>
public __gc class PDFTextRunCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>
public ref class PDFTextRunCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDFView4NET.Text.PDFTextRunCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunCollection Members
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFTextRunCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunCollection Class

The following tables list the members exposed by PDFTextRunCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top
See Also

Reference

PDFTextRunCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%%

PDFTextRunSelection Class
Members

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunSelection Class
Specifies which part of a text run represents selected text.
Object Model
PDFTextRunSelection ClassPDFTextRun Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextRunSelection
'Usage

Dim instance As PDFTextRunSelection
public class PDFTextRunSelection
public __gc class PDFTextRunSelection
public ref class PDFTextRunSelection
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Text.PDFTextRunSelection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunSelection Members
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFTextRunSelection Class Members
Properties Methods

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunSelection Class

The following tables list the members exposed by PDFTextRunSelection.

Public Properties
 | Name | Description
Public Property | Bounds | Gets the bounding rectangle of the selected text.
Public Property | DisplayBounds | Gets the bounding rectangle of the selected text.
Public Property | SelectionLength | Gets the selection length.
Public Property | SelectionStart | Gets the selection start position.
Public Property | TextMatrix | Gets the text matrix.
Public Property | TextRun | Gets the text run that includes selected text.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts this object to string representation.
Top
See Also

Reference

PDFTextRunSelection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Methods$$

PDFTextRunSelection Class Methods

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunSelection Class

For a list of all members of this type, see PDFTextRunSelection members.

Public Methods
 | Name | Description
Public Method | ToString | Converts this object to string representation.
Top
See Also

Reference

PDFTextRunSelection Class
O2S.Components.PDFView4NET.Text Namespace


%%ItemTitle%%

ToString Method (PDFTextRunSelection)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRunSelection Class : ToString Method
Converts this object to string representation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PDFTextRunSelection
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

The object as string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunSelection Class
PDFTextRunSelection Members


%%PageItemTitle%% $$Properties$$

PDFTextRunSelection Class Properties

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunSelection Class

For a list of all members of this type, see PDFTextRunSelection members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets the bounding rectangle of the selected text.
Public Property | DisplayBounds | Gets the bounding rectangle of the selected text.
Public Property | SelectionLength | Gets the selection length.
Public Property | SelectionStart | Gets the selection start position.
Public Property | TextMatrix | Gets the text matrix.
Public Property | TextRun | Gets the text run that includes selected text.
Top
See Also

Reference

PDFTextRunSelection Class
O2S.Components.PDFView4NET.Text Namespace


%%ItemTitle%%

Bounds Property (PDFTextRunSelection)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRunSelection Class : Bounds Property
Gets the bounding rectangle of the selected text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bounds As PDFRectangle
'Usage

Dim instance As PDFTextRunSelection
Dim value As PDFRectangle

value = instance.Bounds
public PDFRectangle Bounds {get;}
public: __property PDFRectangle* get_Bounds();
public:
property PDFRectangle^ Bounds {
   PDFRectangle^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunSelection Class
PDFTextRunSelection Members


%%ItemTitle%%

DisplayBounds Property (PDFTextRunSelection)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRunSelection Class : DisplayBounds Property
Gets the bounding rectangle of the selected text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayBounds As DisplayRectangle
'Usage

Dim instance As PDFTextRunSelection
Dim value As DisplayRectangle

value = instance.DisplayBounds
public DisplayRectangle DisplayBounds {get;}
public: __property DisplayRectangle* get_DisplayBounds();
public:
property DisplayRectangle^ DisplayBounds {
   DisplayRectangle^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunSelection Class
PDFTextRunSelection Members


%%ItemTitle%%

SelectionLength Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRunSelection Class : SelectionLength Property
Gets the selection length.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectionLength As Integer
'Usage

Dim instance As PDFTextRunSelection
Dim value As Integer

value = instance.SelectionLength
public int SelectionLength {get;}
public: __property int get_SelectionLength();
public:
property int SelectionLength {
   int get();
}

Property Value

The length of the selected text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunSelection Class
PDFTextRunSelection Members


%%ItemTitle%%

SelectionStart Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRunSelection Class : SelectionStart Property
Gets the selection start position.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectionStart As Integer
'Usage

Dim instance As PDFTextRunSelection
Dim value As Integer

value = instance.SelectionStart
public int SelectionStart {get;}
public: __property int get_SelectionStart();
public:
property int SelectionStart {
   int get();
}

Property Value

Position within the textrun's text where the selection starts.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunSelection Class
PDFTextRunSelection Members


%%ItemTitle%%

TextMatrix Property (PDFTextRunSelection)

O2S.Components.PDFView4NET.Text Namespace > PDFTextRunSelection Class : TextMatrix Property
Gets the text matrix.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextMatrix As PDFMatrix
'Usage

Dim instance As PDFTextRunSelection
Dim value As PDFMatrix

value = instance.TextMatrix
public PDFMatrix TextMatrix {get;}
public: __property PDFMatrix* get_TextMatrix();
public:
property PDFMatrix^ TextMatrix {
   PDFMatrix^ get();
}

Property Value

The transformation matrix that corresponds to the selected text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunSelection Class
PDFTextRunSelection Members


%%ItemTitle%%

TextRun Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextRunSelection Class : TextRun Property
Gets the text run that includes selected text.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TextRun As PDFTextRun
'Usage

Dim instance As PDFTextRunSelection
Dim value As PDFTextRun

value = instance.TextRun
public PDFTextRun TextRun {get;}
public: __property PDFTextRun* get_TextRun();
public:
property PDFTextRun^ TextRun {
   PDFTextRun^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunSelection Class
PDFTextRunSelection Members


%%PageItemTitle%%

PDFTextRunSelectionCollection Class
Members

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunSelectionCollection Class
Defines a read only collection of PDFTextRunSelection objects.
Object Model
PDFTextRunSelectionCollection ClassPDFTextRunSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextRunSelectionCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PDFTextRunSelection)
'Usage

Dim instance As PDFTextRunSelectionCollection
public class PDFTextRunSelectionCollection : System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>
public __gc class PDFTextRunSelectionCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>
public ref class PDFTextRunSelectionCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDFView4NET.Text.PDFTextRunSelectionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextRunSelectionCollection Members
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFTextRunSelectionCollection Class Members
Properties Methods

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunSelectionCollection Class

The following tables list the members exposed by PDFTextRunSelectionCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Top
Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Top
See Also

Reference

PDFTextRunSelectionCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%%

PDFTextSelection Class
Members

O2S.Components.PDFView4NET.Text Namespace : PDFTextSelection Class
Defines a selection of text of a PDF page.
Object Model
PDFTextSelection ClassPDFTextRunSelectionCollection ClassPDFTextRunSelection Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PDFTextSelection
'Usage

Dim instance As PDFTextSelection
public class PDFTextSelection
public __gc class PDFTextSelection
public ref class PDFTextSelection
Inheritance Hierarchy

System.Object
O2S.Components.PDFView4NET.Text.PDFTextSelection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextSelection Members
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Members$$

PDFTextSelection Class Members
Properties

O2S.Components.PDFView4NET.Text Namespace : PDFTextSelection Class

The following tables list the members exposed by PDFTextSelection.

Public Properties
 | Name | Description
Public Property | SelectedTextRuns | Gets the list of selected text runs included in the text selection.
Public Property | Text | Gets the text included in the selection.
Top
See Also

Reference

PDFTextSelection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFTextSelection Class Properties

O2S.Components.PDFView4NET.Text Namespace : PDFTextSelection Class

For a list of all members of this type, see PDFTextSelection members.

Public Properties
 | Name | Description
Public Property | SelectedTextRuns | Gets the list of selected text runs included in the text selection.
Public Property | Text | Gets the text included in the selection.
Top
See Also

Reference

PDFTextSelection Class
O2S.Components.PDFView4NET.Text Namespace


%%ItemTitle%%

SelectedTextRuns Property

O2S.Components.PDFView4NET.Text Namespace > PDFTextSelection Class : SelectedTextRuns Property
Gets the list of selected text runs included in the text selection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SelectedTextRuns As PDFTextRunSelectionCollection
'Usage

Dim instance As PDFTextSelection
Dim value As PDFTextRunSelectionCollection

value = instance.SelectedTextRuns
public PDFTextRunSelectionCollection SelectedTextRuns {get;}
public: __property PDFTextRunSelectionCollection* get_SelectedTextRuns();
public:
property PDFTextRunSelectionCollection^ SelectedTextRuns {
   PDFTextRunSelectionCollection^ get();
}

Property Value

A list of PDFTextRunSelection objects representing the selected text on the page.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextSelection Class
PDFTextSelection Members


%%ItemTitle%%

Text Property (PDFTextSelection)

O2S.Components.PDFView4NET.Text Namespace > PDFTextSelection Class : Text Property
Gets the text included in the selection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PDFTextSelection
Dim value As String

value = instance.Text
public string Text {get;}
public: __property string* get_Text();
public:
property String^ Text {
   String^ get();
}

Property Value

The seelcted text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextSelection Class
PDFTextSelection Members


%%PageItemTitle%%

PDFHighlightSearchResultsMode Enumeration

O2S.Components.PDFView4NET.Text Namespace : PDFHighlightSearchResultsMode Enumeration
Specifies how the search results are highlighted in the O2S.Components.PDFView4NET.PDFPageView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFHighlightSearchResultsMode
   Inherits System.Enum
'Usage

Dim instance As PDFHighlightSearchResultsMode
public enum PDFHighlightSearchResultsMode : System.Enum
__value public enum PDFHighlightSearchResultsMode : public System.Enum
public enum class PDFHighlightSearchResultsMode : public System.Enum
Members
Member | Description
AllResults | All search results are highlighted.
SingleResult | A single search result is highlighted.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Text.PDFHighlightSearchResultsMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%%

PDFSearchTextRange Enumeration

O2S.Components.PDFView4NET.Text Namespace : PDFSearchTextRange Enumeration
Specifies the available ranges for searching text in the viewer control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PDFSearchTextRange
   Inherits System.Enum
'Usage

Dim instance As PDFSearchTextRange
public enum PDFSearchTextRange : System.Enum
__value public enum PDFSearchTextRange : public System.Enum
public enum class PDFSearchTextRange : public System.Enum
Members
Member | Description
CurrentPage | The current page is searched.
VisiblePages | All visible pages are searched.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDFView4NET.Text.PDFSearchTextRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

O2S.Components.PDFView4NET.Text Namespace


%%ItemTitle%%

Samples

These samples show how to use PDFView4NET toolkit in Windows Forms applications.

Annotations
This sample shows annotations support in PDFView4NET. New annotations can be created and existing annotations can be moved or edited.

Annotations

BookmarksThis sample shows the bookmarks support in PDFView4NET toolkit. The sample demonstrates the PDFPageView and PDFBookmarksView controls, allowing the user to navigate within the PDF document using the bookmarks tree.

PDF Bookmarks

File attachments
This sample shows the file attachments support in PDFView4NET toolkit. The sample demonstrates the PDFPageView and PDFFileAttachmentsView controls, allowing the user to add, edit and remove file attachments from a PDF file.

PDF Attachments

Form Designer
This sample shows how to create PDF forms using the interactive form design features included in PDFView4NET. You can add new fields, edit existing field properties and remove fields.

Form desginer

PDF2Image
This sample shows how to convert a PDF file to images.

Convert PDF files to images

Convert PDF files to images

PrintPDF
This sample shows how to print a PDF file from your application without displaying any user interface.

Print PDF files

Print PDF files

Print Preview
This sample shows how to display a PDF file in the standard print preview control.

PDF Print preview

PDF Print preview

Rotate page
This sample shows how to rotate pages in a PDF file.

Rotate page

Search text
This sample shows how to search and highlight text in PDFPageView control. All search results can be highlighted at once or they can be highlighted one at a time.

Search text

Zoom and page layout
This sample shows the various zoom options in PDFView4NET, plus the possible page layouts in the viewer control. Single page, one column and two column layouts are supported.

Zoom and page layout demo

Zoom and page layout demo

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Empty Index Entry

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Topic Not Found

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Class Reference

This section presents the complete class reference for all controls, classes and enumerations included in Barcode4NET toolkit.

Barcode4NET assembly
Class reference for Barcode4NET class library for standard Microsoft .NET Framework.

Barcode4NET.Windows assembly
Class reference for BarcodeView and BarcodeTextBox Windows Forms controls for standard Microsoft .NET Framework.

Barcode4NET.Web assembly
Class reference for BarcodeView ASP.NET server control for standard Microsoft .NET Framework.

Barcode4NET.CF assembly
Class reference for Barcode4NET class library for Microsoft .NET Compact Framework.

Barcode4NET.Windows.CF assembly
Class reference for BarcodeView Windows Forms control for Microsoft .NET Compact Framework.

Barcode4NET.RS.Design assembly
Class reference for BarcodeView design time control for Sql Server Reporting Services 2005.

© O2 Solutions. All Rights Reserved.

Send comments on this topic.


%%PageItemTitle%% $$Methods$$

FontParserException Class Methods

O2S.Components.PDFRender4NET.Exceptions Namespace : FontParserException Class

For a list of all members of this type, see FontParserException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

FontParserException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%% $$Properties$$

FontParserException Class Properties

O2S.Components.PDFRender4NET.Exceptions Namespace : FontParserException Class

For a list of all members of this type, see FontParserException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

FontParserException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%% $$Methods$$

InvalidPageException Class Methods

O2S.Components.PDFRender4NET.Exceptions Namespace : InvalidPageException Class

For a list of all members of this type, see InvalidPageException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPageException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%% $$Properties$$

InvalidPageException Class Properties

O2S.Components.PDFRender4NET.Exceptions Namespace : InvalidPageException Class

For a list of all members of this type, see InvalidPageException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPageException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%%

InvalidPageException Constructor

O2S.Components.PDFRender4NET.Exceptions Namespace > InvalidPageException Class : InvalidPageException Constructor
Overload List
Overload | Description
InvalidPageException Constructor | Initializes a new InvalidPageException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPageException Class
InvalidPageException Members


%%PageItemTitle%% $$Methods$$

InvalidPasswordException Class Methods

O2S.Components.PDFRender4NET.Exceptions Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPasswordException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%% $$Properties$$

InvalidPasswordException Class Properties

O2S.Components.PDFRender4NET.Exceptions Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPasswordException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%%

InvalidPasswordException Constructor

O2S.Components.PDFRender4NET.Exceptions Namespace > InvalidPasswordException Class : InvalidPasswordException Constructor
Overload List
Overload | Description
InvalidPasswordException Constructor | Initializes a new InvalidPasswordException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


%%PageItemTitle%% $$Methods$$

PageRenderingException Class Methods

O2S.Components.PDFRender4NET.Exceptions Namespace : PageRenderingException Class

For a list of all members of this type, see PageRenderingException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PageRenderingException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%% $$Properties$$

PageRenderingException Class Properties

O2S.Components.PDFRender4NET.Exceptions Namespace : PageRenderingException Class

For a list of all members of this type, see PageRenderingException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PageRenderingException Class
O2S.Components.PDFRender4NET.Exceptions Namespace


%%PageItemTitle%%

PageRenderingException Constructor

O2S.Components.PDFRender4NET.Exceptions Namespace > PageRenderingException Class : PageRenderingException Constructor
Overload List
Overload | Description
PageRenderingException Constructor | Initializes a new PageRenderingException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageRenderingException Class
PageRenderingException Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFRender4NET.Exceptions Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
O2S.Components.PDFRender4NET.Exceptions.FontParserException
O2S.Components.PDFRender4NET.Exceptions.InvalidPageException
O2S.Components.PDFRender4NET.Exceptions.InvalidPasswordException
O2S.Components.PDFRender4NET.Exceptions.PageRenderingException
See Also

Reference

O2S.Components.PDFRender4NET Assembly


%%ItemTitle%%

GetPageSize Method

O2S.Components.PDFRender4NET Namespace > PDFFile Class : GetPageSize Method
Gets the size of a page.
Overload List
Overload | Description
GetPageSize | Gets the size of a page in points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFile Class
PDFFile Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFRender4NET Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFRender4NET.PDFFile
O2S.Components.PDFRender4NET.PDFSize
System.EventArgs
O2S.Components.PDFRender4NET.PageRenderingErrorEventArgs
See Also

Reference

O2S.Components.PDFRender4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFActionCollection Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFActionCollection Class

For a list of all members of this type, see PDFActionCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFAction,PDFAction>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top
See Also

Reference

PDFActionCollection Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Properties$$

PDFActionCollection Class Properties

O2S.Components.PDFView4NET.Actions Namespace : PDFActionCollection Class

For a list of all members of this type, see PDFActionCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top
See Also

Reference

PDFActionCollection Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%% $$Methods$$

PDFGoToAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFGoToAction Class

For a list of all members of this type, see PDFGoToAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFGoToAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFGoToAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFGoToAction Class : PDFGoToAction Constructor
Overload List
Overload | Description
PDFGoToAction Constructor | Initializes a new PDFGoToAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


%%PageItemTitle%% $$Methods$$

PDFHideAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFHideAction Class

For a list of all members of this type, see PDFHideAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFHideAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFHideAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFHideAction Class : PDFHideAction Constructor
Overload List
Overload | Description
PDFHideAction Constructor | Initializes a new PDFHideAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHideAction Class
PDFHideAction Members


%%PageItemTitle%% $$Methods$$

PDFJavaScriptAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFJavaScriptAction Class

For a list of all members of this type, see PDFJavaScriptAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFJavaScriptAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFJavaScriptAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFJavaScriptAction Class : PDFJavaScriptAction Constructor
Overload List
Overload | Description
PDFJavaScriptAction Constructor | Initializes a new PDFJavaScriptAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


%%PageItemTitle%% $$Methods$$

PDFLaunchAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFLaunchAction Class

For a list of all members of this type, see PDFLaunchAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFLaunchAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFLaunchAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFLaunchAction Class : PDFLaunchAction Constructor
Overload List
Overload | Description
PDFLaunchAction Constructor | Initializes a new PDFLaunchAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


%%PageItemTitle%% $$Methods$$

PDFNamedAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFNamedAction Class

For a list of all members of this type, see PDFNamedAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFNamedAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFNamedAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFNamedAction Class : PDFNamedAction Constructor
Overload List
Overload | Description
PDFNamedAction Constructor | Initializes a new PDFNamedAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


%%PageItemTitle%% $$Methods$$

PDFRemoteGoToAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFRemoteGoToAction Class

For a list of all members of this type, see PDFRemoteGoToAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFRemoteGoToAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFRemoteGoToAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFRemoteGoToAction Class : PDFRemoteGoToAction Constructor
Overload List
Overload | Description
PDFRemoteGoToAction Constructor | Initializes a new PDFRemoteGoToAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


%%PageItemTitle%% $$Methods$$

PDFResetFormAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFResetFormAction Class

For a list of all members of this type, see PDFResetFormAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFResetFormAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFResetFormAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFResetFormAction Class : PDFResetFormAction Constructor
Overload List
Overload | Description
PDFResetFormAction Constructor | Initializes a new PDFResetFormAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


%%PageItemTitle%% $$Methods$$

PDFSubmitFormAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFSubmitFormAction Class

For a list of all members of this type, see PDFSubmitFormAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFSubmitFormAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%PageItemTitle%%

PDFSubmitFormAction Constructor

O2S.Components.PDFView4NET.Actions Namespace > PDFSubmitFormAction Class : PDFSubmitFormAction Constructor
Overload List
Overload | Description
PDFSubmitFormAction Constructor | Initializes a new PDFSubmitFormAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


%%PageItemTitle%% $$Methods$$

PDFUriAction Class Methods

O2S.Components.PDFView4NET.Actions Namespace : PDFUriAction Class

For a list of all members of this type, see PDFUriAction members.

Public Methods
 | Name | Description
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Actions.PDFAction)
Top
See Also

Reference

PDFUriAction Class
O2S.Components.PDFView4NET.Actions Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET.Actions Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFView4NET.Actions.PDFAction
O2S.Components.PDFView4NET.Actions.PDFGoToAction
O2S.Components.PDFView4NET.Actions.PDFHideAction
O2S.Components.PDFView4NET.Actions.PDFJavaScriptAction
O2S.Components.PDFView4NET.Actions.PDFLaunchAction
O2S.Components.PDFView4NET.Actions.PDFNamedAction
O2S.Components.PDFView4NET.Actions.PDFRemoteGoToAction
O2S.Components.PDFView4NET.Actions.PDFResetFormAction
O2S.Components.PDFView4NET.Actions.PDFSubmitFormAction
O2S.Components.PDFView4NET.Actions.PDFUriAction
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Actions.PDFActionCollection
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%%

PDFAnnotationBorder Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFAnnotationBorder Class : PDFAnnotationBorder Constructor
Overload List
Overload | Description
PDFAnnotationBorder Constructor | Initializes a new PDFAnnotationBorder object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


%%PageItemTitle%% $$Properties$$

PDFAnnotationCollection Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationCollection Class

For a list of all members of this type, see PDFAnnotationCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top
See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFAnnotationReplyCollection Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationReplyCollection Class

For a list of all members of this type, see PDFAnnotationReplyCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFMarkupAnnotation,PDFAnnotation>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Top
See Also

Reference

PDFAnnotationReplyCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFAnnotationReplyCollection Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFAnnotationReplyCollection Class

For a list of all members of this type, see PDFAnnotationReplyCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFMarkupAnnotation>)
Top
See Also

Reference

PDFAnnotationReplyCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Events$$

PDFBarcodeAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFBarcodeAnnotation Class

For a list of all members of this type, see PDFBarcodeAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFBarcodeAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFBarcodeAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFBarcodeAnnotation Class : PDFBarcodeAnnotation Constructor
Overload List
Overload | Description
PDFBarcodeAnnotation Constructor | Initializes a new PDFBarcodeAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBarcodeAnnotation Class
PDFBarcodeAnnotation Members


%%PageItemTitle%% $$Events$$

PDFEllipseAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFEllipseAnnotation Class

For a list of all members of this type, see PDFEllipseAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFEllipseAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFEllipseAnnotation Class

For a list of all members of this type, see PDFEllipseAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | BorderWidth | Gets or sets the border width. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | HatchColor | Gets or sets the annotation's hatch color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | HatchType | Gets or sets the type of the hatched filling. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | HatchWidth | Gets or sets the annotation's hatch color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFEllipseAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFEllipseAnnotation Class : PDFEllipseAnnotation Constructor
Overload List
Overload | Description
PDFEllipseAnnotation Constructor | Initializes a new PDFEllipseAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFEllipseAnnotation Class
PDFEllipseAnnotation Members


%%PageItemTitle%% $$Events$$

PDFFileAttachmentAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

For a list of all members of this type, see PDFFileAttachmentAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFFileAttachmentAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : PDFFileAttachmentAnnotation Constructor
Overload List
Overload | Description
PDFFileAttachmentAnnotation Constructor | Initializes a new PDFFileAttachmentAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


%%PageItemTitle%% $$Events$$

PDFFreeTextAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFFreeTextAnnotation Class

For a list of all members of this type, see PDFFreeTextAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFFreeTextAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFFreeTextAnnotation Class : PDFFreeTextAnnotation Constructor
Overload List
Overload | Description
PDFFreeTextAnnotation Constructor | Initializes a new PDFFreeTextAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


%%PageItemTitle%% $$Events$$

PDFHighlightAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFHighlightAnnotation Class

For a list of all members of this type, see PDFHighlightAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFHighlightAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFHighlightAnnotation Class

For a list of all members of this type, see PDFHighlightAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFHighlightAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFHighlightAnnotation Class : PDFHighlightAnnotation Constructor
Overload List
Overload | Description
PDFHighlightAnnotation Constructor | Initializes a new PDFHighlightAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFHighlightAnnotation Class
PDFHighlightAnnotation Members


%%PageItemTitle%% $$Events$$

PDFImageAppearance Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFImageAppearance Class

For a list of all members of this type, see PDFImageAppearance members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotationAppearance)
Top
See Also

Reference

PDFImageAppearance Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Events$$

PDFInkAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFInkAnnotation Class

For a list of all members of this type, see PDFInkAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFInkAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFInkAnnotation Class : PDFInkAnnotation Constructor
Overload List
Overload | Description
PDFInkAnnotation Constructor | Initializes a new PDFInkAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


%%PageItemTitle%% $$Events$$

PDFLineAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFLineAnnotation Class

For a list of all members of this type, see PDFLineAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFLineAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFLineAnnotation Class : PDFLineAnnotation Constructor
Overload List
Overload | Description
PDFLineAnnotation Constructor | Initializes a new PDFLineAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


%%PageItemTitle%% $$Events$$

PDFLinkAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFLinkAnnotation Class

For a list of all members of this type, see PDFLinkAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFLinkAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFLinkAnnotation Class : PDFLinkAnnotation Constructor
Overload List
Overload | Description
PDFLinkAnnotation Constructor | Initializes a new PDFLinkAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


%%PageItemTitle%% $$Events$$

PDFMarkupAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFMarkupAnnotation Class

For a list of all members of this type, see PDFMarkupAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFMarkupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Events$$

PDFMeasureAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFMeasureAnnotation Class

For a list of all members of this type, see PDFMeasureAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFMeasureAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFMeasureAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFMeasureAnnotation Class : PDFMeasureAnnotation Constructor
Overload List
Overload | Description
PDFMeasureAnnotation Constructor | Initializes a new PDFMeasureAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFMeasureAnnotation Class
PDFMeasureAnnotation Members


%%PageItemTitle%% $$Methods$$

PDFPointsCollection Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFPointsCollection Class

For a list of all members of this type, see PDFPointsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<double[],PDFAnnotation>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Top
See Also

Reference

PDFPointsCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFPointsCollection Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFPointsCollection Class

For a list of all members of this type, see PDFPointsCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<double[]>)
Top
See Also

Reference

PDFPointsCollection Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Events$$

PDFPolygonAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolygonAnnotation Class

For a list of all members of this type, see PDFPolygonAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPolygonAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFPolygonAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolygonAnnotation Class : PDFPolygonAnnotation Constructor
Overload List
Overload | Description
PDFPolygonAnnotation Constructor | Initializes a new PDFPolygonAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolygonAnnotation Class
PDFPolygonAnnotation Members


%%PageItemTitle%% $$Events$$

PDFPolyLineAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyLineAnnotation Class

For a list of all members of this type, see PDFPolyLineAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPolyLineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFPolyLineAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyLineAnnotation Class : PDFPolyLineAnnotation Constructor
Overload List
Overload | Description
PDFPolyLineAnnotation Constructor | Initializes a new PDFPolyLineAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyLineAnnotation Class
PDFPolyLineAnnotation Members


%%PageItemTitle%% $$Events$$

PDFPolyMeasureAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyMeasureAnnotation Class

For a list of all members of this type, see PDFPolyMeasureAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPolyMeasureAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PDFPolyMeasureAnnotation Class Methods

O2S.Components.PDFView4NET.Annotations Namespace : PDFPolyMeasureAnnotation Class

For a list of all members of this type, see PDFPolyMeasureAnnotation members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation)
Public Method | ShowPopup | Shows or hides the annotation popup window. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Top
See Also

Reference

PDFPolyMeasureAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFPolyMeasureAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFPolyMeasureAnnotation Class : PDFPolyMeasureAnnotation Constructor
Overload List
Overload | Description
PDFPolyMeasureAnnotation Constructor | Initializes a new PDFPolyMeasureAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPolyMeasureAnnotation Class
PDFPolyMeasureAnnotation Members


%%PageItemTitle%% $$Events$$

PDFPopupAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFPopupAnnotation Class

For a list of all members of this type, see PDFPopupAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPopupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFPopupAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFPopupAnnotation Class : PDFPopupAnnotation Constructor
Overload List
Overload | Description
PDFPopupAnnotation Constructor | Initializes a new PDFPopupAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPopupAnnotation Class
PDFPopupAnnotation Members


%%PageItemTitle%% $$Events$$

PDFRectangleAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFRectangleAnnotation Class

For a list of all members of this type, see PDFRectangleAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFRectangleAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFRectangleAnnotation Class

For a list of all members of this type, see PDFRectangleAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | BorderWidth | Gets or sets the border width. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | HatchColor | Gets or sets the annotation's hatch color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | HatchType | Gets or sets the type of the hatched filling. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | HatchWidth | Gets or sets the annotation's hatch color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFRectangleAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFRectangleAnnotation Class : PDFRectangleAnnotation Constructor
Overload List
Overload | Description
PDFRectangleAnnotation Constructor | Initializes a new PDFRectangleAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRectangleAnnotation Class
PDFRectangleAnnotation Members


%%PageItemTitle%% $$Events$$

PDFSCAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFSCAnnotation Class

For a list of all members of this type, see PDFSCAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Events$$

PDFSquigglyAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFSquigglyAnnotation Class

For a list of all members of this type, see PDFSquigglyAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFSquigglyAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFSquigglyAnnotation Class

For a list of all members of this type, see PDFSquigglyAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFSquigglyAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFSquigglyAnnotation Class : PDFSquigglyAnnotation Constructor
Overload List
Overload | Description
PDFSquigglyAnnotation Constructor | Initializes a new PDFSquigglyAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSquigglyAnnotation Class
PDFSquigglyAnnotation Members


%%PageItemTitle%% $$Events$$

PDFStampAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFStampAnnotation Class

For a list of all members of this type, see PDFStampAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFStampAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFStampAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFStampAnnotation Class : PDFStampAnnotation Constructor
Overload List
Overload | Description
PDFStampAnnotation Constructor | Initializes a new PDFStampAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStampAnnotation Class
PDFStampAnnotation Members


%%PageItemTitle%% $$Events$$

PDFStrikeOutAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

For a list of all members of this type, see PDFStrikeOutAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFStrikeOutAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

For a list of all members of this type, see PDFStrikeOutAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFStrikeOutAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFStrikeOutAnnotation Class : PDFStrikeOutAnnotation Constructor
Overload List
Overload | Description
PDFStrikeOutAnnotation Constructor | Initializes a new PDFStrikeOutAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFStrikeOutAnnotation Class
PDFStrikeOutAnnotation Members


%%PageItemTitle%% $$Events$$

PDFTextAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextAnnotation Class

For a list of all members of this type, see PDFTextAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFTextAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFTextAnnotation Class : PDFTextAnnotation Constructor
Overload List
Overload | Description
PDFTextAnnotation Constructor | Initializes a new PDFTextAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


%%PageItemTitle%% $$Events$$

PDFTextMarkupAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

For a list of all members of this type, see PDFTextMarkupAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Events$$

PDFUnderlineAnnotation Class Events

O2S.Components.PDFView4NET.Annotations Namespace : PDFUnderlineAnnotation Class

For a list of all members of this type, see PDFUnderlineAnnotation members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PDFUnderlineAnnotation Class Properties

O2S.Components.PDFView4NET.Annotations Namespace : PDFUnderlineAnnotation Class

For a list of all members of this type, see PDFUnderlineAnnotation members.

Public Properties
 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayQuadPoints | Gets or sets the points that define the markup area in display coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDFView4NET.Annotations Namespace


%%PageItemTitle%%

PDFUnderlineAnnotation Constructor

O2S.Components.PDFView4NET.Annotations Namespace > PDFUnderlineAnnotation Class : PDFUnderlineAnnotation Constructor
Overload List
Overload | Description
PDFUnderlineAnnotation Constructor | Initializes a new PDFUnderlineAnnotation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFUnderlineAnnotation Class
PDFUnderlineAnnotation Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET.Annotations Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Annotations.PDFFreeTextAnnotation
O2S.Components.PDFView4NET.Annotations.PDFLinkAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFBarcodeAnnotation
O2S.Components.PDFView4NET.Annotations.PDFFileAttachmentAnnotation
O2S.Components.PDFView4NET.Annotations.PDFInkAnnotation
O2S.Components.PDFView4NET.Annotations.PDFLineAnnotation
O2S.Components.PDFView4NET.Annotations.PDFMeasureAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolygonAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolyLineAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPolyMeasureAnnotation
O2S.Components.PDFView4NET.Annotations.PDFSCAnnotation
O2S.Components.PDFView4NET.Annotations.PDFEllipseAnnotation
O2S.Components.PDFView4NET.Annotations.PDFRectangleAnnotation
O2S.Components.PDFView4NET.Annotations.PDFStampAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextAnnotation
O2S.Components.PDFView4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDFView4NET.Annotations.PDFHighlightAnnotation
O2S.Components.PDFView4NET.Annotations.PDFSquigglyAnnotation
O2S.Components.PDFView4NET.Annotations.PDFStrikeOutAnnotation
O2S.Components.PDFView4NET.Annotations.PDFUnderlineAnnotation
O2S.Components.PDFView4NET.Annotations.PDFPopupAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFCheckWidget
O2S.Components.PDFView4NET.Forms.PDFCheckBoxWidget
O2S.Components.PDFView4NET.Forms.PDFRadioButtonItem
O2S.Components.PDFView4NET.Forms.PDFDropDownListWidget
O2S.Components.PDFView4NET.Forms.PDFListBoxWidget
O2S.Components.PDFView4NET.Forms.PDFPushButtonWidget
O2S.Components.PDFView4NET.Forms.PDFSignatureWidget
O2S.Components.PDFView4NET.Forms.PDFTextBoxWidget
O2S.Components.PDFView4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDFView4NET.Annotations.PDFImageAppearance
O2S.Components.PDFView4NET.Annotations.PDFAnnotationBorder
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Annotations.PDFAnnotationCollection
O2S.Components.PDFView4NET.Annotations.PDFAnnotationReplyCollection
O2S.Components.PDFView4NET.Annotations.PDFPointsCollection
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%% $$Methods$$

FDFFieldCollection Class Methods

O2S.Components.PDFView4NET.Forms Namespace : FDFFieldCollection Class

For a list of all members of this type, see FDFFieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<FDFField,FDFFile>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top
See Also

Reference

FDFFieldCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

FDFFieldCollection Class Properties

O2S.Components.PDFView4NET.Forms Namespace : FDFFieldCollection Class

For a list of all members of this type, see FDFFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top
See Also

Reference

FDFFieldCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

FromStream Method (FDFFile)

O2S.Components.PDFView4NET.Forms Namespace > FDFFile Class : FromStream Method
Creates a FDFFile object from the given stream object.
Overload List
Overload | Description
FromStream | Creates a FDFFile object from the given stream object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FDFFile Class
FDFFile Members


%%PageItemTitle%% $$Methods$$

PDFCheckBoxField Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckBoxField Class

For a list of all members of this type, see PDFCheckBoxField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckBoxField Class : PDFCheckBoxField Constructor
Overload List
Overload | Description
PDFCheckBoxField Constructor | Initializes a new PDFCheckBoxField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


%%PageItemTitle%% $$Events$$

PDFCheckBoxWidget Class Events

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckBoxWidget Class

For a list of all members of this type, see PDFCheckBoxWidget members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFCheckBoxWidget Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckBoxWidget Class

For a list of all members of this type, see PDFCheckBoxWidget members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFCheckBoxWidget Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckBoxWidget Class

For a list of all members of this type, see PDFCheckBoxWidget members.

Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckBoxWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckBoxWidget Class : PDFCheckBoxWidget Constructor
Overload List
Overload | Description
PDFCheckBoxWidget Constructor | Initializes a new PDFCheckBoxWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckBoxWidget Class
PDFCheckBoxWidget Members


%%PageItemTitle%% $$Events$$

PDFCheckWidget Class Events

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckWidget Class

For a list of all members of this type, see PDFCheckWidget members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFCheckWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFCheckWidget Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFCheckWidget Class

For a list of all members of this type, see PDFCheckWidget members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFCheckWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFCheckWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFCheckWidget Class : PDFCheckWidget Constructor
Overload List
Overload | Description
PDFCheckWidget Constructor | Initializes a new PDFCheckWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


%%PageItemTitle%% $$Methods$$

PDFDropDownListField Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFDropDownListField Class

For a list of all members of this type, see PDFDropDownListField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFDropDownListField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFDropDownListField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFDropDownListField Class : PDFDropDownListField Constructor
Overload List
Overload | Description
PDFDropDownListField Constructor | Initializes a new PDFDropDownListField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


%%PageItemTitle%% $$Events$$

PDFDropDownListWidget Class Events

O2S.Components.PDFView4NET.Forms Namespace : PDFDropDownListWidget Class

For a list of all members of this type, see PDFDropDownListWidget members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFDropDownListWidget Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFDropDownListWidget Class

For a list of all members of this type, see PDFDropDownListWidget members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFDropDownListWidget Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFDropDownListWidget Class

For a list of all members of this type, see PDFDropDownListWidget members.

Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFDropDownListWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFDropDownListWidget Class : PDFDropDownListWidget Constructor
Overload List
Overload | Description
PDFDropDownListWidget Constructor | Initializes a new PDFDropDownListWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDropDownListWidget Class
PDFDropDownListWidget Members


%%PageItemTitle%% $$Events$$

PDFFieldWidget Class Events

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidget Class

For a list of all members of this type, see PDFFieldWidget members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFieldWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFFieldWidget Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidget Class

For a list of all members of this type, see PDFFieldWidget members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFFieldWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFFieldWidgetCollection Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidgetCollection Class

For a list of all members of this type, see PDFFieldWidgetCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFFieldWidget,PDFField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top
See Also

Reference

PDFFieldWidgetCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFFieldWidgetCollection Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFFieldWidgetCollection Class

For a list of all members of this type, see PDFFieldWidgetCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top
See Also

Reference

PDFFieldWidgetCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFFieldWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFFieldWidget Class : PDFFieldWidget Constructor
Overload List
Overload | Description
PDFFieldWidget Constructor | Initializes a new PDFFieldWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


%%PageItemTitle%% $$Methods$$

PDFListBoxField Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFListBoxField Class

For a list of all members of this type, see PDFListBoxField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFListBoxField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFListBoxField Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFListBoxField Class

For a list of all members of this type, see PDFListBoxField members.

Public Properties
 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Form | Gets the form that contains this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Type | Gets the field type. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFListBoxField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFListBoxField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFListBoxField Class : PDFListBoxField Constructor
Overload List
Overload | Description
PDFListBoxField Constructor | Initializes a new PDFListBoxField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxField Class
PDFListBoxField Members


%%PageItemTitle%% $$Events$$

PDFListBoxWidget Class Events

O2S.Components.PDFView4NET.Forms Namespace : PDFListBoxWidget Class

For a list of all members of this type, see PDFListBoxWidget members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFListBoxWidget Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFListBoxWidget Class

For a list of all members of this type, see PDFListBoxWidget members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFListBoxWidget Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFListBoxWidget Class

For a list of all members of this type, see PDFListBoxWidget members.

Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFListBoxWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFListBoxWidget Class : PDFListBoxWidget Constructor
Overload List
Overload | Description
PDFListBoxWidget Constructor | Initializes a new PDFListBoxWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFListBoxWidget Class
PDFListBoxWidget Members


%%PageItemTitle%% $$Methods$$

PDFListField Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFListField Class

For a list of all members of this type, see PDFListField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFListField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFListItemCollection Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFListItemCollection Class

For a list of all members of this type, see PDFListItemCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFListItem,PDFListField>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top
See Also

Reference

PDFListItemCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFListItemCollection Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFListItemCollection Class

For a list of all members of this type, see PDFListItemCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top
See Also

Reference

PDFListItemCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFPushButtonField Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonField Class

For a list of all members of this type, see PDFPushButtonField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFPushButtonField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonField Class : PDFPushButtonField Constructor
Overload List
Overload | Description
PDFPushButtonField Constructor | Initializes a new PDFPushButtonField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


%%PageItemTitle%% $$Events$$

PDFPushButtonWidget Class Events

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonWidget Class

For a list of all members of this type, see PDFPushButtonWidget members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFPushButtonWidget Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFPushButtonWidget Class

For a list of all members of this type, see PDFPushButtonWidget members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFPushButtonWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFPushButtonWidget Class : PDFPushButtonWidget Constructor
Overload List
Overload | Description
PDFPushButtonWidget Constructor | Initializes a new PDFPushButtonWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


%%PageItemTitle%% $$Events$$

PDFRadioButtonItem Class Events

O2S.Components.PDFView4NET.Forms Namespace : PDFRadioButtonItem Class

For a list of all members of this type, see PDFRadioButtonItem members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFRadioButtonItem Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFRadioButtonItem Class

For a list of all members of this type, see PDFRadioButtonItem members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFRadioButtonItem Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFRadioButtonItem Class

For a list of all members of this type, see PDFRadioButtonItem members.

Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonItem Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFRadioButtonItem Class : PDFRadioButtonItem Constructor
Overload List
Overload | Description
PDFRadioButtonItem Constructor | Initializes a new PDFRadioButtonItem object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


%%PageItemTitle%% $$Methods$$

PDFRadioButtonListField Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFRadioButtonListField Class

For a list of all members of this type, see PDFRadioButtonListField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFRadioButtonListField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFRadioButtonListField Class : PDFRadioButtonListField Constructor
Overload List
Overload | Description
PDFRadioButtonListField Constructor | Initializes a new PDFRadioButtonListField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


%%PageItemTitle%% $$Methods$$

PDFSignatureField Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureField Class

For a list of all members of this type, see PDFSignatureField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFSignatureField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureField Class : PDFSignatureField Constructor
Overload List
Overload | Description
PDFSignatureField Constructor | Initializes a new PDFSignatureField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


%%PageItemTitle%%

PDFSignatureLockFieldAction Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureLockFieldAction Class : PDFSignatureLockFieldAction Constructor
Overload List
Overload | Description
PDFSignatureLockFieldAction Constructor | Initializes a new PDFSignatureLockFieldAction object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


%%PageItemTitle%% $$Events$$

PDFSignatureWidget Class Events

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureWidget Class

For a list of all members of this type, see PDFSignatureWidget members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFSignatureWidget Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureWidget Class

For a list of all members of this type, see PDFSignatureWidget members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

PDFSignatureWidget Class Properties

O2S.Components.PDFView4NET.Forms Namespace : PDFSignatureWidget Class

For a list of all members of this type, see PDFSignatureWidget members.

Public Properties
 | Name | Description
Public Property | AllowResize | Gets or sets a value indicating whether the field widget can be resized in the viewer control or not. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | ID | Gets the annotation unique id. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Replies | Gets the collection of replies to this annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | TabOrder | Gets or sets the widget's tab order. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Tag | Gets the annotation tag. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from O2S.Components.PDFView4NET.Forms.PDFFieldWidget)
Top
See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFSignatureWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFSignatureWidget Class : PDFSignatureWidget Constructor
Overload List
Overload | Description
PDFSignatureWidget Constructor | Initializes a new PDFSignatureWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSignatureWidget Class
PDFSignatureWidget Members


%%PageItemTitle%% $$Methods$$

PDFTextBoxField Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFTextBoxField Class

For a list of all members of this type, see PDFTextBoxField members.

Public Methods
 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Forms.PDFField)
Top
See Also

Reference

PDFTextBoxField Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFTextBoxField Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxField Class : PDFTextBoxField Constructor
Overload List
Overload | Description
PDFTextBoxField Constructor | Initializes a new PDFTextBoxField object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


%%PageItemTitle%% $$Events$$

PDFTextBoxWidget Class Events

O2S.Components.PDFView4NET.Forms Namespace : PDFTextBoxWidget Class

For a list of all members of this type, see PDFTextBoxWidget members.

Public Events
 | Name | Description
Public Event | PropertyChanged | Gets or sets the event that is fired when a property has changed. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Methods$$

PDFTextBoxWidget Class Methods

O2S.Components.PDFView4NET.Forms Namespace : PDFTextBoxWidget Class

For a list of all members of this type, see PDFTextBoxWidget members.

Public Methods
 | Name | Description
Public Method | Clone | Clones the annotation. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Dispose | Disposes the internal resources. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | Export | Exports the annotation as XML to the specified stream. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetObjectData | Serializes the object content. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | GetRawValue | Gets the value of the specified key. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Public Method | PrepareForCopyPaste | Prepares the annotation for a copy/paste operation in the viewer. (Inherited from O2S.Components.PDFView4NET.Annotations.PDFAnnotation)
Top
See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%%

PDFTextBoxWidget Constructor

O2S.Components.PDFView4NET.Forms Namespace > PDFTextBoxWidget Class : PDFTextBoxWidget Constructor
Overload List
Overload | Description
PDFTextBoxWidget Constructor | Initializes a new PDFTextBoxWidget object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFTextBoxWidget Class
PDFTextBoxWidget Members


%%PageItemTitle%% $$Methods$$

XFDFFieldCollection Class Methods

O2S.Components.PDFView4NET.Forms Namespace : XFDFFieldCollection Class

For a list of all members of this type, see XFDFFieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<XFDFField,XFDFFile>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top
See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%PageItemTitle%% $$Properties$$

XFDFFieldCollection Class Properties

O2S.Components.PDFView4NET.Forms Namespace : XFDFFieldCollection Class

For a list of all members of this type, see XFDFFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top
See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDFView4NET.Forms Namespace


%%ItemTitle%%

FromStream Method (XFDFFile)

O2S.Components.PDFView4NET.Forms Namespace > XFDFFile Class : FromStream Method
Creates a XFDFFile object from the given stream object.
Overload List
Overload | Description
FromStream | Creates a XFDFFile object from the given stream object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XFDFFile Class
XFDFFile Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET.Forms Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFView4NET.Annotations.PDFAnnotation
O2S.Components.PDFView4NET.Forms.PDFFieldWidget
O2S.Components.PDFView4NET.Forms.PDFCheckWidget
O2S.Components.PDFView4NET.Forms.PDFCheckBoxWidget
O2S.Components.PDFView4NET.Forms.PDFRadioButtonItem
O2S.Components.PDFView4NET.Forms.PDFDropDownListWidget
O2S.Components.PDFView4NET.Forms.PDFListBoxWidget
O2S.Components.PDFView4NET.Forms.PDFPushButtonWidget
O2S.Components.PDFView4NET.Forms.PDFSignatureWidget
O2S.Components.PDFView4NET.Forms.PDFTextBoxWidget
O2S.Components.PDFView4NET.Forms.FDFField
O2S.Components.PDFView4NET.Forms.FDFFile
O2S.Components.PDFView4NET.Forms.PDFField
O2S.Components.PDFView4NET.Forms.PDFCheckBoxField
O2S.Components.PDFView4NET.Forms.PDFListField
O2S.Components.PDFView4NET.Forms.PDFDropDownListField
O2S.Components.PDFView4NET.Forms.PDFListBoxField
O2S.Components.PDFView4NET.Forms.PDFPushButtonField
O2S.Components.PDFView4NET.Forms.PDFRadioButtonListField
O2S.Components.PDFView4NET.Forms.PDFSignatureField
O2S.Components.PDFView4NET.Forms.PDFTextBoxField
O2S.Components.PDFView4NET.Forms.PDFFieldImportError
O2S.Components.PDFView4NET.Forms.PDFForm
O2S.Components.PDFView4NET.Forms.PDFListItem
O2S.Components.PDFView4NET.Forms.PDFSignatureLockFieldAction
O2S.Components.PDFView4NET.Forms.XFDFField
O2S.Components.PDFView4NET.Forms.XFDFFile
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Forms.FDFFieldCollection
O2S.Components.PDFView4NET.Forms.PDFFieldCollection
O2S.Components.PDFView4NET.Forms.PDFFieldWidgetCollection
O2S.Components.PDFView4NET.Forms.PDFListItemCollection
O2S.Components.PDFView4NET.Forms.XFDFFieldCollection
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%% $$Methods$$

BarcodeEncodingException Class Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

BarcodeEncodingException Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Methods$$

PDF417Barcode Class Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Top
See Also

Reference

PDF417Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCodabarBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

For a list of all members of this type, see PDFCodabarBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCodabarBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode11Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

For a list of all members of this type, see PDFCode11Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode11Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode25InterleavedBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

For a list of all members of this type, see PDFCode25InterleavedBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode25InterleavedBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode32Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

For a list of all members of this type, see PDFCode32Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode32Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode39ExtendedBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

For a list of all members of this type, see PDFCode39ExtendedBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode39ExtendedBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode93Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

For a list of all members of this type, see PDFCode93Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode93Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode93ExtendedBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

For a list of all members of this type, see PDFCode93ExtendedBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode93ExtendedBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128ABarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

For a list of all members of this type, see PDFCode128ABarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128ABarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

For a list of all members of this type, see PDFCode128Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128BBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

For a list of all members of this type, see PDFCode128BBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128BBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCode128CBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

For a list of all members of this type, see PDFCode128CBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCode128CBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFCOOP25Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

For a list of all members of this type, see PDFCOOP25Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFCOOP25Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFEAN8Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

For a list of all members of this type, see PDFEAN8Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN8Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFEAN13Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

For a list of all members of this type, see PDFEAN13Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFEAN13Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFFedExGround96Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

For a list of all members of this type, see PDFFedExGround96Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFFedExGround96Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFHeightModulatedBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

For a list of all members of this type, see PDFHeightModulatedBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFHeightModulatedBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFIATA25Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

For a list of all members of this type, see PDFIATA25Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFIATA25Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFIdentcodeBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

For a list of all members of this type, see PDFIdentcodeBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFIdentcodeBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFISBNBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

For a list of all members of this type, see PDFISBNBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISBNBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFISMNBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

For a list of all members of this type, see PDFISMNBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISMNBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFISSNBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

For a list of all members of this type, see PDFISSNBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFISSNBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFJAN13Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

For a list of all members of this type, see PDFJAN13Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFJAN13Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFKixBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

For a list of all members of this type, see PDFKixBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFKixBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFLeitcodeBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

For a list of all members of this type, see PDFLeitcodeBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFLeitcodeBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFMatrix25Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

For a list of all members of this type, see PDFMatrix25Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMatrix25Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Methods$$

PDFMicroPDF417Barcode Class Methods

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

For a list of all members of this type, see PDFMicroPDF417Barcode members.

Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode)
Top
See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFMSIPlesseyBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

For a list of all members of this type, see PDFMSIPlesseyBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFMSIPlesseyBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFPlanetBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

For a list of all members of this type, see PDFPlanetBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPlanetBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFPostNetBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

For a list of all members of this type, see PDFPostNetBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPostNetBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFPZNBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

For a list of all members of this type, see PDFPZNBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFPZNBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFRM4SCCBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

For a list of all members of this type, see PDFRM4SCCBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFRM4SCCBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFSCC14Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

For a list of all members of this type, see PDFSCC14Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSCC14Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFSingaporePostBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

For a list of all members of this type, see PDFSingaporePostBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSingaporePostBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFSSCC18Barcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

For a list of all members of this type, see PDFSSCC18Barcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFSSCC18Barcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUPCABarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

For a list of all members of this type, see PDFUPCABarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUPCABarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUPCEBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

For a list of all members of this type, see PDFUPCEBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarReductionFactor | Gets or sets the factor used for reducing/enlarging bar widths for special characters. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUPCEBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUSPSFIMBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

For a list of all members of this type, see PDFUSPSFIMBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSFIMBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUSPSHorizontalBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

For a list of all members of this type, see PDFUSPSHorizontalBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSHorizontalBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%PageItemTitle%% $$Properties$$

PDFUSPSPICBarcode Class Properties

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

For a list of all members of this type, see PDFUSPSPICBarcode members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | BarWidthReduction | Gets or sets the bar width reduction. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode)
Top
See Also

Reference

PDFUSPSPICBarcode Class
O2S.Components.PDFView4NET.Graphics.Barcodes Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET.Graphics.Barcodes Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDF417Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFMicroPDF417Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCodablockFBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode16KBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFDataMatrixBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFQRBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCodabarBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode11Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128ABarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128BBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFFedExGround96Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFSCC14Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFSSCC18Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUSPSPICBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEAN128Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFIdentcodeBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFLeitcodeBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCOOP25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFIATA25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFMatrix25Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode32Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPZNBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEAN13Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFEAN8Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFISBNBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFISMNBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFISSNBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFJAN13Barcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUPCABarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUPCEBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPlanetBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPostNetBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFKixBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFSingaporePostBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFPharmacodeBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUSPSFIMBarcode
O2S.Components.PDFView4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode
System.Exception
System.ApplicationException
O2S.Components.PDFView4NET.Graphics.Barcodes.BarcodeEncodingException
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%% $$Properties$$

Type0Font Class Properties

O2S.Components.PDFView4NET.Graphics.Fonts Namespace : Type0Font Class

For a list of all members of this type, see Type0Font members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | FontName | Gets the name of the font. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase)
Top
See Also

Reference

Type0Font Class
O2S.Components.PDFView4NET.Graphics.Fonts Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET.Graphics.Fonts Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDFView4NET.Graphics.Fonts.PDFFont
O2S.Components.PDFView4NET.Graphics.Fonts.PostScriptFont
O2S.Components.PDFView4NET.Graphics.Fonts.TrueTypeFont
O2S.Components.PDFView4NET.Graphics.Fonts.Type0Font
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET.Graphics.OptionalContent Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFDeviceColor Class Methods

O2S.Components.PDFView4NET.Graphics Namespace : PDFDeviceColor Class

For a list of all members of this type, see PDFDeviceColor members.

Public Methods
 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from O2S.Components.PDFView4NET.Graphics.PDFColor)
Public Method | ToGdiColor | Overloaded. Converts this color object to a GDI color object. (Inherited from O2S.Components.PDFView4NET.Graphics.PDFColor)
Top
See Also

Reference

PDFDeviceColor Class
O2S.Components.PDFView4NET.Graphics Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET.Graphics Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFView4NET.Graphics.PDFColor
O2S.Components.PDFView4NET.Graphics.PDFDeviceColor
O2S.Components.PDFView4NET.Graphics.PDFCmykColor
O2S.Components.PDFView4NET.Graphics.PDFGrayColor
O2S.Components.PDFView4NET.Graphics.PDFRgbColor
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%% $$Methods$$

InvalidDocumentException Class Methods

O2S.Components.PDFView4NET Namespace : InvalidDocumentException Class

For a list of all members of this type, see InvalidDocumentException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidDocumentException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

InvalidDocumentException Class Properties

O2S.Components.PDFView4NET Namespace : InvalidDocumentException Class

For a list of all members of this type, see InvalidDocumentException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidDocumentException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

InvalidDocumentException Constructor

O2S.Components.PDFView4NET Namespace > InvalidDocumentException Class : InvalidDocumentException Constructor
Overload List
Overload | Description
InvalidDocumentException Constructor | Initializes a new InvalidDocumentException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDocumentException Class
InvalidDocumentException Members


%%PageItemTitle%% $$Methods$$

InvalidPasswordException Class Methods

O2S.Components.PDFView4NET Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPasswordException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

InvalidPasswordException Class Properties

O2S.Components.PDFView4NET Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidPasswordException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

InvalidPasswordException Constructor

O2S.Components.PDFView4NET Namespace > InvalidPasswordException Class : InvalidPasswordException Constructor
Overload List
Overload | Description
InvalidPasswordException Constructor | Initializes a new InvalidPasswordException object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


%%PageItemTitle%% $$Methods$$

PDFAnnotationsView Class Methods

O2S.Components.PDFView4NET Namespace : PDFAnnotationsView Class

For a list of all members of this type, see PDFAnnotationsView members.

Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
See Also

Reference

PDFAnnotationsView Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFAnnotationsViewCollection Class Methods

O2S.Components.PDFView4NET Namespace : PDFAnnotationsViewCollection Class

For a list of all members of this type, see PDFAnnotationsViewCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFAnnotationsView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Top
See Also

Reference

PDFAnnotationsViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFAnnotationsViewCollection Class Properties

O2S.Components.PDFView4NET Namespace : PDFAnnotationsViewCollection Class

For a list of all members of this type, see PDFAnnotationsViewCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotationsView>)
Top
See Also

Reference

PDFAnnotationsViewCollection Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Dispose Method (PDFAnnotationsView)

O2S.Components.PDFView4NET Namespace > PDFAnnotationsView Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFAnnotationsView Class
PDFAnnotationsView Members


%%PageItemTitle%% $$Methods$$

PDFBookmarkCollection Class Methods

O2S.Components.PDFView4NET Namespace : PDFBookmarkCollection Class

For a list of all members of this type, see PDFBookmarkCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFBookmark,PDFBookmark>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top
See Also

Reference

PDFBookmarkCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFBookmarkCollection Class Properties

O2S.Components.PDFView4NET Namespace : PDFBookmarkCollection Class

For a list of all members of this type, see PDFBookmarkCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top
See Also

Reference

PDFBookmarkCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFBookmarksView Class Methods

O2S.Components.PDFView4NET Namespace : PDFBookmarksView Class

For a list of all members of this type, see PDFBookmarksView members.

Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | Disables any redrawing of the tree view. (Inherited from System.Windows.Forms.TreeView)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | CollapseAll | Collapses all the tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | Enables the redrawing of the tree view. (Inherited from System.Windows.Forms.TreeView)
Public Method | ExpandAll | Expands all the tree nodes. (Inherited from System.Windows.Forms.TreeView)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetNodeAt | Overloaded. Retrieves the tree node that is at the specified point. (Inherited from System.Windows.Forms.TreeView)
Public Method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from System.Windows.Forms.TreeView)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | HitTest | Overloaded. Provides node information, given a point. (Inherited from System.Windows.Forms.TreeView)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | Sort | Sorts the items in System.Windows.Forms.TreeView control. (Inherited from System.Windows.Forms.TreeView)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Overrides System.ComponentModel.Component.ToString. (Inherited from System.Windows.Forms.TreeView)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFBookmarksView Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFBookmarksViewCollection Class Methods

O2S.Components.PDFView4NET Namespace : PDFBookmarksViewCollection Class

For a list of all members of this type, see PDFBookmarksViewCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFBookmarksView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Top
See Also

Reference

PDFBookmarksViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFBookmarksViewCollection Class Properties

O2S.Components.PDFView4NET Namespace : PDFBookmarksViewCollection Class

For a list of all members of this type, see PDFBookmarksViewCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFBookmarksView>)
Top
See Also

Reference

PDFBookmarksViewCollection Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Dispose Method (PDFBookmarksView)

O2S.Components.PDFView4NET Namespace > PDFBookmarksView Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmarksView Class
PDFBookmarksView Members


%%PageItemTitle%%

PDFBookmark Constructor

O2S.Components.PDFView4NET Namespace > PDFBookmark Class : PDFBookmark Constructor
Overload List
Overload | Description
PDFBookmark Constructor | Initializes a new PDFBookmark object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFBookmark Class
PDFBookmark Members


%%PageItemTitle%% $$Properties$$

PDFCollection<T,K> Class Properties

O2S.Components.PDFView4NET Namespace : PDFCollection<T,K> Class

For a list of all members of this type, see PDFCollection<T,K> members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

PDFCollection<T,K> Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFDigitalSignature Constructor

O2S.Components.PDFView4NET Namespace > PDFDigitalSignature Class : PDFDigitalSignature Constructor
Overload List
Overload | Description
PDFDigitalSignature Constructor | Initializes a new PDFDigitalSignature object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


%%PageItemTitle%%

PDFDocumentInformation Constructor

O2S.Components.PDFView4NET Namespace > PDFDocumentInformation Class : PDFDocumentInformation Constructor
Overload List
Overload | Description
PDFDocumentInformation Constructor | Initializes a new PDFDocumentInformation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


%%ItemTitle%%

Dispose Method (PDFDocument)

O2S.Components.PDFView4NET Namespace > PDFDocument Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFDocument Class
PDFDocument Members


%%PageItemTitle%% $$Methods$$

PDFException Class Methods

O2S.Components.PDFView4NET Namespace : PDFException Class

For a list of all members of this type, see PDFException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFException Class Properties

O2S.Components.PDFView4NET Namespace : PDFException Class

For a list of all members of this type, see PDFException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

PDFException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFFileAttachmentCollection Class Methods

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentCollection Class

For a list of all members of this type, see PDFFileAttachmentCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachment,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Top
See Also

Reference

PDFFileAttachmentCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFFileAttachmentCollection Class Properties

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentCollection Class

For a list of all members of this type, see PDFFileAttachmentCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachment>)
Top
See Also

Reference

PDFFileAttachmentCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFFileAttachmentsView Class Methods

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentsView Class

For a list of all members of this type, see PDFFileAttachmentsView members.

Public Methods
 | Name | Description
Public Method | ArrangeIcons | Overloaded. Arranges items in the control when they are displayed as icons with a specified alignment setting. (Inherited from System.Windows.Forms.ListView)
Public Method | AutoResizeColumn | Resizes the width of the given column as indicated by the resize style. (Inherited from System.Windows.Forms.ListView)
Public Method | AutoResizeColumns | Resizes the width of the columns as indicated by the resize style. (Inherited from System.Windows.Forms.ListView)
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | Prevents the control from drawing until the System.Windows.Forms.ListView.EndUpdate method is called. (Inherited from System.Windows.Forms.ListView)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Removes all items and columns from the control. (Inherited from System.Windows.Forms.ListView)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | Resumes drawing of the list view control after drawing is suspended by the System.Windows.Forms.ListView.BeginUpdate method. (Inherited from System.Windows.Forms.ListView)
Public Method | EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary. (Inherited from System.Windows.Forms.ListView)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | FindItemWithText | Overloaded. Finds the first System.Windows.Forms.ListViewItem that begins with the specified text value. (Inherited from System.Windows.Forms.ListView)
Public Method | FindNearestItem | Overloaded. Finds the next item from the given point, searching in the specified direction (Inherited from System.Windows.Forms.ListView)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetItemAt | Retrieves the item at the specified location. (Inherited from System.Windows.Forms.ListView)
Public Method | GetItemRect | Overloaded. Retrieves the bounding rectangle for a specific item within the list view control. (Inherited from System.Windows.Forms.ListView)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | HitTest | Overloaded. Provides item information, given a point. (Inherited from System.Windows.Forms.ListView)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RedrawItems | Forces a range of System.Windows.Forms.ListViewItem objects to be redrawn. (Inherited from System.Windows.Forms.ListView)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | Sort | Sorts the items of the list view. (Inherited from System.Windows.Forms.ListView)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a string representation of the System.Windows.Forms.ListView control. (Inherited from System.Windows.Forms.ListView)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

PDFFileAttachmentsView Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFFileAttachmentsViewCollection Class Methods

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentsViewCollection Class

For a list of all members of this type, see PDFFileAttachmentsViewCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFFileAttachmentsView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Top
See Also

Reference

PDFFileAttachmentsViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFFileAttachmentsViewCollection Class Properties

O2S.Components.PDFView4NET Namespace : PDFFileAttachmentsViewCollection Class

For a list of all members of this type, see PDFFileAttachmentsViewCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFFileAttachmentsView>)
Top
See Also

Reference

PDFFileAttachmentsViewCollection Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Dispose Method (PDFFileAttachmentsView)

O2S.Components.PDFView4NET Namespace > PDFFileAttachmentsView Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachmentsView Class
PDFFileAttachmentsView Members


%%PageItemTitle%%

PDFFileAttachment Constructor

O2S.Components.PDFView4NET Namespace > PDFFileAttachment Class : PDFFileAttachment Constructor
Overload List
Overload | Description
PDFFileAttachment Constructor | Initializes a new PDFFileAttachment object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFFileAttachment Class
PDFFileAttachment Members


%%PageItemTitle%% $$Methods$$

PDFNamedDestinationCollection Class Methods

O2S.Components.PDFView4NET Namespace : PDFNamedDestinationCollection Class

For a list of all members of this type, see PDFNamedDestinationCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFNamedDestination,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Top
See Also

Reference

PDFNamedDestinationCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFNamedDestinationCollection Class Properties

O2S.Components.PDFView4NET Namespace : PDFNamedDestinationCollection Class

For a list of all members of this type, see PDFNamedDestinationCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFNamedDestination>)
Top
See Also

Reference

PDFNamedDestinationCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFPageCollection Class Properties

O2S.Components.PDFView4NET Namespace : PDFPageCollection Class

For a list of all members of this type, see PDFPageCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top
See Also

Reference

PDFPageCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%%

PDFPageDestination Constructor

O2S.Components.PDFView4NET Namespace > PDFPageDestination Class : PDFPageDestination Constructor
Overload List
Overload | Description
PDFPageDestination Constructor | Initializes a new PDFPageDestination object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


%%PageItemTitle%% $$Methods$$

PDFPageThumbnailView Class Methods

O2S.Components.PDFView4NET Namespace : PDFPageThumbnailView Class

For a list of all members of this type, see PDFPageThumbnailView members.

Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
See Also

Reference

PDFPageThumbnailView Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Methods$$

PDFPageThumbnailViewCollection Class Methods

O2S.Components.PDFView4NET Namespace : PDFPageThumbnailViewCollection Class

For a list of all members of this type, see PDFPageThumbnailViewCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFPageThumbnailView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Top
See Also

Reference

PDFPageThumbnailViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFPageThumbnailViewCollection Class Properties

O2S.Components.PDFView4NET Namespace : PDFPageThumbnailViewCollection Class

For a list of all members of this type, see PDFPageThumbnailViewCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageThumbnailView>)
Top
See Also

Reference

PDFPageThumbnailViewCollection Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Dispose Method (PDFPageThumbnailView)

O2S.Components.PDFView4NET Namespace > PDFPageThumbnailView Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageThumbnailView Class
PDFPageThumbnailView Members


%%PageItemTitle%% $$Methods$$

PDFPageViewCollection Class Methods

O2S.Components.PDFView4NET Namespace : PDFPageViewCollection Class

For a list of all members of this type, see PDFPageViewCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | MoveItem | Moves the item up or down to the beginning or end of the collection. (Inherited from O2S.Components.PDFView4NET.PDFCollection<PDFPageView,PDFDocument>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Top
See Also

Reference

PDFPageViewCollection Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

PDFPageViewCollection Class Properties

O2S.Components.PDFView4NET Namespace : PDFPageViewCollection Class

For a list of all members of this type, see PDFPageViewCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<PDFPageView>)
Top
See Also

Reference

PDFPageViewCollection Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%%

Dispose Method (PDFPageView)

O2S.Components.PDFView4NET Namespace > PDFPageView Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%ItemTitle%%

GetPageAtPoint Method

O2S.Components.PDFView4NET Namespace > PDFPageView Class : GetPageAtPoint Method
Gets the page located at the specified point.
Overload List
Overload | Description
GetPageAtPoint | Gets the page located at the specified point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFPageView Class
PDFPageView Members


%%PageItemTitle%%

PDFRemotePageDestination Constructor

O2S.Components.PDFView4NET Namespace > PDFRemotePageDestination Class : PDFRemotePageDestination Constructor
Overload List
Overload | Description
PDFRemotePageDestination Constructor | Initializes a new PDFRemotePageDestination object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFRemotePageDestination Class
PDFRemotePageDestination Members


%%PageItemTitle%%

PDFSecurityManager Constructor

O2S.Components.PDFView4NET Namespace > PDFSecurityManager Class : PDFSecurityManager Constructor
Overload List
Overload | Description
PDFSecurityManager Constructor | Initializes a new PDFSecurityManager object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


%%PageItemTitle%%

PDFViewerPreferences Constructor

O2S.Components.PDFView4NET Namespace > PDFViewerPreferences Class : PDFViewerPreferences Constructor
Overload List
Overload | Description
PDFViewerPreferences Constructor | Initializes a new PDFDocumentInformation object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


%%PageItemTitle%%

PDFXMPMetadata Constructor

O2S.Components.PDFView4NET Namespace > PDFXMPMetadata Class : PDFXMPMetadata Constructor
Overload List
Overload | Description
PDFXMPMetadata Constructor | Initializes a new PDFXMPMetadata object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET.Printing Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFView4NET.Printing.PDFPrintSettings
System.EventArgs
O2S.Components.PDFView4NET.Printing.PrintProgressEventArgs
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%% $$Methods$$

PDFPageSearchTextResultCollection Class Methods

O2S.Components.PDFView4NET.Text Namespace : PDFPageSearchTextResultCollection Class

For a list of all members of this type, see PDFPageSearchTextResultCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Top
See Also

Reference

PDFPageSearchTextResultCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFPageSearchTextResultCollection Class Properties

O2S.Components.PDFView4NET.Text Namespace : PDFPageSearchTextResultCollection Class

For a list of all members of this type, see PDFPageSearchTextResultCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFPageSearchTextResult>)
Top
See Also

Reference

PDFPageSearchTextResultCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Methods$$

PDFSearchTextResultCollection Class Methods

O2S.Components.PDFView4NET.Text Namespace : PDFSearchTextResultCollection Class

For a list of all members of this type, see PDFSearchTextResultCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top
See Also

Reference

PDFSearchTextResultCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFSearchTextResultCollection Class Properties

O2S.Components.PDFView4NET.Text Namespace : PDFSearchTextResultCollection Class

For a list of all members of this type, see PDFSearchTextResultCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top
See Also

Reference

PDFSearchTextResultCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Methods$$

PDFTextRunCollection Class Methods

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunCollection Class

For a list of all members of this type, see PDFTextRunCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top
See Also

Reference

PDFTextRunCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFTextRunCollection Class Properties

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunCollection Class

For a list of all members of this type, see PDFTextRunCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top
See Also

Reference

PDFTextRunCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Methods$$

PDFTextRunSelectionCollection Class Methods

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunSelectionCollection Class

For a list of all members of this type, see PDFTextRunSelectionCollection members.

Public Methods
 | Name | Description
Public Method | Contains | Determines whether an element is in the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Public Method | CopyTo | Copies the entire ReadOnlyCollection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Top
See Also

Reference

PDFTextRunSelectionCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%PageItemTitle%% $$Properties$$

PDFTextRunSelectionCollection Class Properties

O2S.Components.PDFView4NET.Text Namespace : PDFTextRunSelectionCollection Class

For a list of all members of this type, see PDFTextRunSelectionCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollection instance. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Public Property | Item | Gets the element at the specified index. (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRunSelection>)
Top
See Also

Reference

PDFTextRunSelectionCollection Class
O2S.Components.PDFView4NET.Text Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET.Text Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFView4NET.Text.PDFPageSearchTextResult
O2S.Components.PDFView4NET.Text.PDFSearchTextResult
O2S.Components.PDFView4NET.Text.PDFTextRun
O2S.Components.PDFView4NET.Text.PDFTextRunSelection
O2S.Components.PDFView4NET.Text.PDFTextSelection
System.Collections.ObjectModel.ReadOnlyCollection<T>
O2S.Components.PDFView4NET.Text.PDFPageSearchTextResultCollection
O2S.Components.PDFView4NET.Text.PDFSearchTextResultCollection
O2S.Components.PDFView4NET.Text.PDFTextRunCollection
O2S.Components.PDFView4NET.Text.PDFTextRunSelectionCollection
See Also

Reference

O2S.Components.PDFView4NET Assembly


%%PageItemTitle%% $$Methods$$

UnsupportedEncryptionException Class Methods

O2S.Components.PDFView4NET Namespace : UnsupportedEncryptionException Class

For a list of all members of this type, see UnsupportedEncryptionException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

UnsupportedEncryptionException Class
O2S.Components.PDFView4NET Namespace


%%PageItemTitle%% $$Properties$$

UnsupportedEncryptionException Class Properties

O2S.Components.PDFView4NET Namespace : UnsupportedEncryptionException Class

For a list of all members of this type, see UnsupportedEncryptionException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

UnsupportedEncryptionException Class
O2S.Components.PDFView4NET Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

O2S.Components.PDFView4NET Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
O2S.Components.PDFView4NET.DisplayRectangle
O2S.Components.PDFView4NET.PDFAnnotationToolTip
O2S.Components.PDFView4NET.PDFBookmark
O2S.Components.PDFView4NET.PDFDestination
O2S.Components.PDFView4NET.PDFDirectDestination
O2S.Components.PDFView4NET.PDFPageDestination
O2S.Components.PDFView4NET.PDFRemotePageDestination
O2S.Components.PDFView4NET.PDFNamedDestination
O2S.Components.PDFView4NET.PDFDigitalSignature
O2S.Components.PDFView4NET.PDFDocumentInformation
O2S.Components.PDFView4NET.PDFFileAttachment
O2S.Components.PDFView4NET.PDFGraphicsContainer
O2S.Components.PDFView4NET.PDFPage
O2S.Components.PDFView4NET.PDFMatrix
O2S.Components.PDFView4NET.PDFRectangle
O2S.Components.PDFView4NET.PDFSecurityManager
O2S.Components.PDFView4NET.PDFSize
O2S.Components.PDFView4NET.PDFViewerPreferences
O2S.Components.PDFView4NET.PDFXMPMetadata
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDFView4NET.PDFCollection<T,K>
O2S.Components.PDFView4NET.Actions.PDFActionCollection
O2S.Components.PDFView4NET.Annotations.PDFAnnotationCollection
O2S.Components.PDFView4NET.Annotations.PDFAnnotationReplyCollection
O2S.Components.PDFView4NET.Annotations.PDFPointsCollection
O2S.Components.PDFView4NET.Forms.FDFFieldCollection
O2S.Components.PDFView4NET.Forms.PDFFieldCollection
O2S.Components.PDFView4NET.Forms.PDFFieldWidgetCollection
O2S.Components.PDFView4NET.Forms.PDFListItemCollection
O2S.Components.PDFView4NET.Forms.XFDFFieldCollection
O2S.Components.PDFView4NET.PDFAnnotationsViewCollection
O2S.Components.PDFView4NET.PDFBookmarkCollection
O2S.Components.PDFView4NET.PDFBookmarksViewCollection
O2S.Components.PDFView4NET.PDFFileAttachmentCollection
O2S.Components.PDFView4NET.PDFFileAttachmentsViewCollection
O2S.Components.PDFView4NET.PDFNamedDestinationCollection
O2S.Components.PDFView4NET.PDFPageCollection
O2S.Components.PDFView4NET.PDFPageThumbnailViewCollection
O2S.Components.PDFView4NET.PDFPageViewCollection
System.EventArgs
O2S.Components.PDFView4NET.AfterAnnotationAddEventArgs
O2S.Components.PDFView4NET.AfterAnnotationMoveEventArgs
O2S.Components.PDFView4NET.AfterAnnotationResizeEventArgs
O2S.Components.PDFView4NET.AfterFieldAddEventArgs
O2S.Components.PDFView4NET.AfterLinkExecuteEventArgs
O2S.Components.PDFView4NET.AfterPageReorderEventArgs
O2S.Components.PDFView4NET.AfterTextSelectEventArgs
O2S.Components.PDFView4NET.AnnotationClickEventArgs
O2S.Components.PDFView4NET.AnnotationContextMenuEventArgs
O2S.Components.PDFView4NET.AnnotationToolTipDrawEventArgs
O2S.Components.PDFView4NET.AnnotationToolTipPopupEventArgs
O2S.Components.PDFView4NET.BeforeAnnotationAddEventArgs
O2S.Components.PDFView4NET.BeforeFieldAddEventArgs
O2S.Components.PDFView4NET.BeforeLinkExecuteEventArgs
O2S.Components.PDFView4NET.BeforePageReorderEventArgs
O2S.Components.PDFView4NET.BookmarkClickEventArgs
O2S.Components.PDFView4NET.BookmarkEventArgs
O2S.Components.PDFView4NET.FieldClickEventArgs
O2S.Components.PDFView4NET.FieldContextMenuEventArgs
O2S.Components.PDFView4NET.FieldEditEventArgs
O2S.Components.PDFView4NET.FieldValidateEventArgs
O2S.Components.PDFView4NET.PageClickEventArgs
O2S.Components.PDFView4NET.PageContextMenuEventArgs
O2S.Components.PDFView4NET.PageRenderingErrorEventArgs
O2S.Components.PDFView4NET.PasswordRequiredEventArgs
O2S.Components.PDFView4NET.PDFCollectionChangedEventArgs<T>
System.Exception
System.ApplicationException
O2S.Components.PDFView4NET.InvalidDocumentException
O2S.Components.PDFView4NET.InvalidPasswordException
O2S.Components.PDFView4NET.PDFException
O2S.Components.PDFView4NET.UnsupportedEncryptionException
System.MarshalByRefObject
System.ComponentModel.Component
O2S.Components.PDFView4NET.PDFDocument
System.Windows.Forms.Control
System.Windows.Forms.ListView
O2S.Components.PDFView4NET.PDFFileAttachmentsView
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
O2S.Components.PDFView4NET.PDFPageThumbnailView
O2S.Components.PDFView4NET.PDFPageView
O2S.Components.WinForms.TreeList
O2S.Components.PDFView4NET.PDFAnnotationsView
System.Windows.Forms.TreeView
O2S.Components.PDFView4NET.PDFBookmarksView
See Also

Reference

O2S.Components.PDFView4NET Assembly


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you