活字認識ライブラリー .NET APIリファレンス: メインページ

活字認識ライブラリー .NET APIリファレンス 15.00
  • メインページ
  • クラス
活字認識ライブラリー .NET APIリファレンス ドキュメント

はじめに

カラーOCRライブラリー 活字認識ライブラリーをVisual C# / Visual Basic.NETなどの.NET Framework上で動作するインターフェースについて解説します。


活字認識ライブラリー .NET APIリファレンス: 関数

  • 関数
  • 全て
  • 列挙型
  • 列挙型の値
  • c
  • e
  • h
  • i
  • l
  • p
  • r
  • s
  • t
これはネームスペースの一覧です。それぞれが属しているネームスペースへリンクしています。

- c -

  • CHAR_CLASS_ALL : IdrEngine
  • CHAR_CLASS_ALPHABET : IdrEngine
  • CHAR_CLASS_HIRAGANA : IdrEngine
  • CHAR_CLASS_KANJI : IdrEngine
  • CHAR_CLASS_KANJI_1ST : IdrEngine
  • CHAR_CLASS_KANJI_2ND : IdrEngine
  • CHAR_CLASS_KATAKANA : IdrEngine
  • CHAR_CLASS_NUMBER : IdrEngine
  • CHAR_CLASS_SYMBOL : IdrEngine
  • CHAR_CLASS_USER : IdrEngine
  • CharClass : IdrEngine
  • CharDirection : IdrEngine

- e -

  • ErrorCode : IdrEngine

- h -

  • HandCharClass : IdrEngine

- i -

  • IDR_A3 : IdrEngine
  • IDR_A4 : IdrEngine
  • IDR_B4 : IdrEngine
  • IDR_ERROR_CHAR_DICTDATA : IdrEngine
  • IDR_ERROR_CHAR_DICTLOAD : IdrEngine
  • IDR_ERROR_CHAR_DIRECTION : IdrEngine
  • IDR_ERROR_CHAR_EXCEPTREGION : IdrEngine
  • IDR_ERROR_CHAR_ILLEGIBLETEXT : IdrEngine
  • IDR_ERROR_CHAR_OVER : IdrEngine
  • IDR_ERROR_CHAR_STOP : IdrEngine
  • IDR_ERROR_CHAR_TOOMANY : IdrEngine
  • IDR_ERROR_CHAR_VOIDTEXT : IdrEngine
  • IDR_ERROR_ENTRY_YET : IdrEngine
  • IDR_ERROR_EXCEPTION : IdrEngine
  • IDR_ERROR_F_BMPTYPE : IdrEngine
  • IDR_ERROR_F_COLOR : IdrEngine
  • IDR_ERROR_F_COMPRESS : IdrEngine
  • IDR_ERROR_F_DATA : IdrEngine
  • IDR_ERROR_F_OPEN : IdrEngine
  • IDR_ERROR_F_OVERFLOW : IdrEngine
  • IDR_ERROR_F_READ : IdrEngine
  • IDR_ERROR_F_SEEK : IdrEngine
  • IDR_ERROR_F_SIZE : IdrEngine
  • IDR_ERROR_F_TAGMAX : IdrEngine
  • IDR_ERROR_F_TIFFTYPE : IdrEngine
  • IDR_ERROR_F_WRITE : IdrEngine
  • IDR_ERROR_GETPROC : IdrEngine
  • IDR_ERROR_IMAGE : IdrEngine
  • IDR_ERROR_IMAGE_AREA : IdrEngine
  • IDR_ERROR_JCHAR_UD_ALREADY : IdrEngine
  • IDR_ERROR_JCHAR_UD_CODE : IdrEngine
  • IDR_ERROR_JCHAR_UD_HINSHI : IdrEngine
  • IDR_ERROR_JCHAR_UD_LARGE : IdrEngine
  • IDR_ERROR_JCHAR_UD_LIMIT : IdrEngine
  • IDR_ERROR_JCHAR_UD_RECOVER : IdrEngine
  • IDR_ERROR_JCHAR_UD_SAVE : IdrEngine
  • IDR_ERROR_JCHAR_UD_SPACE : IdrEngine
  • IDR_ERROR_JCHARLOAD : IdrEngine
  • IDR_ERROR_LAYOUT_COMPLEX : IdrEngine
  • IDR_ERROR_LAYOUT_NOREGION : IdrEngine
  • IDR_ERROR_LICENSE : IdrEngine
  • IDR_ERROR_MEMORY : IdrEngine
  • IDR_ERROR_MULTI_INSTANCE : IdrEngine
  • IDR_ERROR_NORMAL : IdrEngine
  • IDR_ERROR_NOT_ENTRY : IdrEngine
  • IDR_ERROR_NOT_EXIST : IdrEngine
  • IDR_ERROR_NOT_REMOVE : IdrEngine
  • IDR_ERROR_OVER : IdrEngine
  • IDR_ERROR_PARAMETER : IdrEngine
  • IDR_ERROR_PERMIT : IdrEngine
  • IDR_ERROR_POST_UD_ALREADY : IdrEngine
  • IDR_ERROR_POST_UD_CODE : IdrEngine
  • IDR_ERROR_POST_UD_HINSHI : IdrEngine
  • IDR_ERROR_POST_UD_LIMIT : IdrEngine
  • IDR_ERROR_POST_UD_RECOVER : IdrEngine
  • IDR_ERROR_POST_UD_SAVE : IdrEngine
  • IDR_ERROR_POST_UD_SPACE : IdrEngine
  • IDR_ERROR_PROC : IdrEngine
  • IDR_ERROR_RECOG_AREA : IdrEngine
  • IDR_ERROR_ROTAUTO : IdrEngine
  • IDR_ERROR_SAVEIMAGE : IdrEngine
  • IDR_ERROR_TABLE_COMPLEX : IdrEngine
  • IDR_ERROR_TABLE_LINEDENSITY : IdrEngine
  • IDR_ERROR_TIMEOUT : IdrEngine
  • IDR_ERROR_TRIAL_LIMIT : IdrEngine
  • IDR_HORIZONTAL : IdrEngine
  • IDR_IMG_BMP : IdrEngine
  • IDR_IMG_JPG : IdrEngine
  • IDR_IMG_TIFF : IdrEngine
  • IDR_LANG_ENGLISH : IdrEngine
  • IDR_LANG_JAPANESE : IdrEngine
  • IDR_NON_SUPPORT_OS : IdrEngine
  • IDR_POST_1 : IdrEngine
  • IDR_POST_2 : IdrEngine
  • IDR_POST_NON : IdrEngine
  • IDR_ROT_0 : IdrEngine
  • IDR_ROT_180 : IdrEngine
  • IDR_ROT_270 : IdrEngine
  • IDR_ROT_90 : IdrEngine
  • IDR_VERTICAL : IdrEngine
  • IDR_VIRTIAL : IdrEngine
  • ImageFileType : IdrEngine

- l -

  • LanguageMode : IdrEngine
  • LayoutMode : IdrEngine
  • LayoutMode_ALL : IdrEngine
  • LayoutMode_Horizontal : IdrEngine
  • LayoutMode_Vertical : IdrEngine

- p -

  • PostMode : IdrEngine

- r -

  • RegionType : IdrEngine
  • RotateDirection : IdrEngine

- s -

  • SizeImage : IdrEngine

- t -

  • TY_CHAR_HAND : IdrEngine
  • TY_CHAR_TEXT : IdrEngine
  • TY_DIAG : IdrEngine
  • TY_FIELD : IdrEngine
  • TY_IMAGE : IdrEngine
  • TY_NONE : IdrEngine
  • TY_TABLE : IdrEngine


活字認識ライブラリー .NET APIリファレンス: 関数

  • 関数
  • 全て
  • 列挙型
  • 列挙型の値
  • CharClass : IdrEngine
  • CharDirection : IdrEngine
  • ErrorCode : IdrEngine
  • HandCharClass : IdrEngine
  • ImageFileType : IdrEngine
  • LanguageMode : IdrEngine
  • LayoutMode : IdrEngine
  • PostMode : IdrEngine
  • RegionType : IdrEngine
  • RotateDirection : IdrEngine
  • SizeImage : IdrEngine


活字認識ライブラリー .NET APIリファレンス: 関数

  • 関数
  • 全て
  • 列挙型
  • 列挙型の値
  • c
  • i
  • l
  • t

- c -

  • CHAR_CLASS_ALL : IdrEngine
  • CHAR_CLASS_ALPHABET : IdrEngine
  • CHAR_CLASS_HIRAGANA : IdrEngine
  • CHAR_CLASS_KANJI : IdrEngine
  • CHAR_CLASS_KANJI_1ST : IdrEngine
  • CHAR_CLASS_KANJI_2ND : IdrEngine
  • CHAR_CLASS_KATAKANA : IdrEngine
  • CHAR_CLASS_NUMBER : IdrEngine
  • CHAR_CLASS_SYMBOL : IdrEngine
  • CHAR_CLASS_USER : IdrEngine

- i -

  • IDR_A3 : IdrEngine
  • IDR_A4 : IdrEngine
  • IDR_B4 : IdrEngine
  • IDR_ERROR_CHAR_DICTDATA : IdrEngine
  • IDR_ERROR_CHAR_DICTLOAD : IdrEngine
  • IDR_ERROR_CHAR_DIRECTION : IdrEngine
  • IDR_ERROR_CHAR_EXCEPTREGION : IdrEngine
  • IDR_ERROR_CHAR_ILLEGIBLETEXT : IdrEngine
  • IDR_ERROR_CHAR_OVER : IdrEngine
  • IDR_ERROR_CHAR_STOP : IdrEngine
  • IDR_ERROR_CHAR_TOOMANY : IdrEngine
  • IDR_ERROR_CHAR_VOIDTEXT : IdrEngine
  • IDR_ERROR_ENTRY_YET : IdrEngine
  • IDR_ERROR_EXCEPTION : IdrEngine
  • IDR_ERROR_F_BMPTYPE : IdrEngine
  • IDR_ERROR_F_COLOR : IdrEngine
  • IDR_ERROR_F_COMPRESS : IdrEngine
  • IDR_ERROR_F_DATA : IdrEngine
  • IDR_ERROR_F_OPEN : IdrEngine
  • IDR_ERROR_F_OVERFLOW : IdrEngine
  • IDR_ERROR_F_READ : IdrEngine
  • IDR_ERROR_F_SEEK : IdrEngine
  • IDR_ERROR_F_SIZE : IdrEngine
  • IDR_ERROR_F_TAGMAX : IdrEngine
  • IDR_ERROR_F_TIFFTYPE : IdrEngine
  • IDR_ERROR_F_WRITE : IdrEngine
  • IDR_ERROR_GETPROC : IdrEngine
  • IDR_ERROR_IMAGE : IdrEngine
  • IDR_ERROR_IMAGE_AREA : IdrEngine
  • IDR_ERROR_JCHAR_UD_ALREADY : IdrEngine
  • IDR_ERROR_JCHAR_UD_CODE : IdrEngine
  • IDR_ERROR_JCHAR_UD_HINSHI : IdrEngine
  • IDR_ERROR_JCHAR_UD_LARGE : IdrEngine
  • IDR_ERROR_JCHAR_UD_LIMIT : IdrEngine
  • IDR_ERROR_JCHAR_UD_RECOVER : IdrEngine
  • IDR_ERROR_JCHAR_UD_SAVE : IdrEngine
  • IDR_ERROR_JCHAR_UD_SPACE : IdrEngine
  • IDR_ERROR_JCHARLOAD : IdrEngine
  • IDR_ERROR_LAYOUT_COMPLEX : IdrEngine
  • IDR_ERROR_LAYOUT_NOREGION : IdrEngine
  • IDR_ERROR_LICENSE : IdrEngine
  • IDR_ERROR_MEMORY : IdrEngine
  • IDR_ERROR_MULTI_INSTANCE : IdrEngine
  • IDR_ERROR_NORMAL : IdrEngine
  • IDR_ERROR_NOT_ENTRY : IdrEngine
  • IDR_ERROR_NOT_EXIST : IdrEngine
  • IDR_ERROR_NOT_REMOVE : IdrEngine
  • IDR_ERROR_OVER : IdrEngine
  • IDR_ERROR_PARAMETER : IdrEngine
  • IDR_ERROR_PERMIT : IdrEngine
  • IDR_ERROR_POST_UD_ALREADY : IdrEngine
  • IDR_ERROR_POST_UD_CODE : IdrEngine
  • IDR_ERROR_POST_UD_HINSHI : IdrEngine
  • IDR_ERROR_POST_UD_LIMIT : IdrEngine
  • IDR_ERROR_POST_UD_RECOVER : IdrEngine
  • IDR_ERROR_POST_UD_SAVE : IdrEngine
  • IDR_ERROR_POST_UD_SPACE : IdrEngine
  • IDR_ERROR_PROC : IdrEngine
  • IDR_ERROR_RECOG_AREA : IdrEngine
  • IDR_ERROR_ROTAUTO : IdrEngine
  • IDR_ERROR_SAVEIMAGE : IdrEngine
  • IDR_ERROR_TABLE_COMPLEX : IdrEngine
  • IDR_ERROR_TABLE_LINEDENSITY : IdrEngine
  • IDR_ERROR_TIMEOUT : IdrEngine
  • IDR_ERROR_TRIAL_LIMIT : IdrEngine
  • IDR_HORIZONTAL : IdrEngine
  • IDR_IMG_BMP : IdrEngine
  • IDR_IMG_JPG : IdrEngine
  • IDR_IMG_TIFF : IdrEngine
  • IDR_LANG_ENGLISH : IdrEngine
  • IDR_LANG_JAPANESE : IdrEngine
  • IDR_NON_SUPPORT_OS : IdrEngine
  • IDR_POST_1 : IdrEngine
  • IDR_POST_2 : IdrEngine
  • IDR_POST_NON : IdrEngine
  • IDR_ROT_0 : IdrEngine
  • IDR_ROT_180 : IdrEngine
  • IDR_ROT_270 : IdrEngine
  • IDR_ROT_90 : IdrEngine
  • IDR_VERTICAL : IdrEngine
  • IDR_VIRTIAL : IdrEngine

- l -

  • LayoutMode_ALL : IdrEngine
  • LayoutMode_Horizontal : IdrEngine
  • LayoutMode_Vertical : IdrEngine

- t -

  • TY_CHAR_HAND : IdrEngine
  • TY_CHAR_TEXT : IdrEngine
  • TY_DIAG : IdrEngine
  • TY_FIELD : IdrEngine
  • TY_IMAGE : IdrEngine
  • TY_NONE : IdrEngine
  • TY_TABLE : IdrEngine


活字認識ライブラリー .NET APIリファレンス: 構成

  • 構成
  • クラス階層
  • 構成メンバ
構成
クラス、構造体、共用体、インタフェースの説明です。
[detail level 12]
\ N IdrEngine | OCRライブラリー(C版)の、C::ラッパークラス
o C EngineFactory | OCRエンジンの管理クラス
o C IDRException | OCRエンジン内でのエラーを通知する。
o C IDRRect | 矩形情報管理クラス
o C IIDRRect | 領域を指定する際に用いる矩形情報を管理する。
o C ICandInf | 文字認識によって得られる個々の文字についての情報を管理する。
o C IRegion | 認識領域についての情報を管理する。
o C ICellRegion | 表認識領域についての情報を管理する。
o C ILayout | 各レイアウトの情報を管理する。
o C ILayoutList | レイアウトのリストの管理を行う。
o C IEngine | 認識対象画像の管理・認識処理を行う。
o C CSRect | 矩形情報構造体
o C CharCand | 候補文字情報構造体
o C ProcMode | 動作モード 構造体
o C Point | 4点検出(台形補正)の座標 構造体
o C TrapeCoordinate | 原稿領域4点(台形補正)の座標構造体
o C TableLine | 罫線情報を管理します。
\ C CellInfo | 表セル領域についての情報を管理する。


活字認識ライブラリー .NET APIリファレンス: パッケージ IdrEngine

  • 関数
構成 | 列挙型
パッケージ IdrEngine

OCRライブラリー(C版)の、C::ラッパークラス [詳細]

構成

class | Engine
class | EngineFactory
OCRエンジンの管理クラス [詳細]
class | IDRException
OCRエンジン内でのエラーを通知する。 [詳細]
class | IDRRect
矩形情報管理クラス [詳細]
interface | IIDRRect
領域を指定する際に用いる矩形情報を管理する。 [詳細]
interface | ICandInf
文字認識によって得られる個々の文字についての情報を管理する。 [詳細]
interface | IRegion
認識領域についての情報を管理する。 [詳細]
interface | ICellRegion
表認識領域についての情報を管理する。 [詳細]
interface | ILayout
各レイアウトの情報を管理する。 [詳細]
interface | ILayoutList
レイアウトのリストの管理を行う。 [詳細]
interface | IEngine
認識対象画像の管理・認識処理を行う。 [詳細]
struct | CSRect
矩形情報構造体 [詳細]
struct | CharCand
候補文字情報構造体 [詳細]
struct | ProcMode
動作モード 構造体 [詳細]
struct | Point
4点検出(台形補正)の座標 構造体 [詳細]
struct | TrapeCoordinate
原稿領域4点(台形補正)の座標構造体 [詳細]
struct | TableLine
罫線情報を管理します。 [詳細]
struct | CellInfo
表セル領域についての情報を管理する。 [詳細]

列挙型

enum ErrorCode {
ErrorCode.IDR_ERROR_EXCEPTION = 0x7fffffff, ErrorCode.IDR_ERROR_NORMAL = 0x00000000, ErrorCode.IDR_ERROR_MEMORY = 0x00000001, ErrorCode.IDR_ERROR_PARAMETER = 0x00000002,
ErrorCode.IDR_ERROR_RECOG_AREA = 0x00000003, ErrorCode.IDR_ERROR_IMAGE_AREA = 0x00000004, ErrorCode.IDR_ERROR_PERMIT = 0x00000005, ErrorCode.IDR_ERROR_MULTI_INSTANCE = 0x00000006,
ErrorCode.IDR_ERROR_TRIAL_LIMIT = 0x00000007, ErrorCode.IDR_ERROR_OVER = 0x00000008, ErrorCode.IDR_ERROR_GETPROC = 0x00000010, ErrorCode.IDR_ERROR_PROC = 0x00000011,
ErrorCode.IDR_ERROR_IMAGE = 0x00000012, ErrorCode.IDR_ERROR_LAYOUT_NOREGION = 0x00000100, ErrorCode.IDR_ERROR_LAYOUT_COMPLEX = 0x00000101, ErrorCode.IDR_ERROR_CHAR_DICTLOAD = 0x00000200,
ErrorCode.IDR_ERROR_CHAR_DICTDATA = 0x00000201, ErrorCode.IDR_ERROR_CHAR_VOIDTEXT = 0x00000202, ErrorCode.IDR_ERROR_CHAR_EXCEPTREGION = 0x00000203, ErrorCode.IDR_ERROR_CHAR_ILLEGIBLETEXT = 0x00000204,
ErrorCode.IDR_ERROR_CHAR_DIRECTION = 0x00000205, ErrorCode.IDR_ERROR_CHAR_TOOMANY = 0x00000206, ErrorCode.IDR_ERROR_CHAR_STOP = 0x00000207, ErrorCode.IDR_ERROR_CHAR_OVER = 0x00000208,
ErrorCode.IDR_ERROR_NOT_EXIST = 0x00000209, ErrorCode.IDR_ERROR_NOT_ENTRY = 0x0000020a, ErrorCode.IDR_ERROR_NOT_REMOVE = 0x0000020b, ErrorCode.IDR_ERROR_ENTRY_YET = 0x0000020c,
ErrorCode.IDR_ERROR_TIMEOUT = 0x0000020d, ErrorCode.IDR_ERROR_JCHAR_UD_LIMIT = 0x00000210, ErrorCode.IDR_ERROR_JCHAR_UD_HINSHI = 0x00000211, ErrorCode.IDR_ERROR_JCHAR_UD_ALREADY = 0x00000212,
ErrorCode.IDR_ERROR_JCHAR_UD_SPACE = 0x00000213, ErrorCode.IDR_ERROR_JCHAR_UD_LARGE = 0x00000214, ErrorCode.IDR_ERROR_JCHAR_UD_CODE = 0x00000215, ErrorCode.IDR_ERROR_JCHAR_UD_RECOVER = 0x00000216,
ErrorCode.IDR_ERROR_JCHAR_UD_SAVE = 0x00000217, ErrorCode.IDR_ERROR_TABLE_COMPLEX = 0x00000300, ErrorCode.IDR_ERROR_TABLE_LINEDENSITY = 0x00000301, ErrorCode.IDR_ERROR_POST_UD_LIMIT = 0x00000500,
ErrorCode.IDR_ERROR_POST_UD_HINSHI = 0x00000501, ErrorCode.IDR_ERROR_POST_UD_ALREADY = 0x00000502, ErrorCode.IDR_ERROR_POST_UD_SPACE = 0x00000503, ErrorCode.IDR_ERROR_POST_UD_CODE = 0x00000504,
ErrorCode.IDR_ERROR_POST_UD_RECOVER = 0x00000505, ErrorCode.IDR_ERROR_POST_UD_SAVE = 0x00000506, ErrorCode.IDR_ERROR_F_OPEN = 0x00000601, ErrorCode.IDR_ERROR_F_READ = 0x00000602,
ErrorCode.IDR_ERROR_F_SEEK = 0x00000603, ErrorCode.IDR_ERROR_F_TAGMAX = 0x00000604, ErrorCode.IDR_ERROR_F_TIFFTYPE = 0x00000605, ErrorCode.IDR_ERROR_F_BMPTYPE = 0x00000606,
ErrorCode.IDR_ERROR_F_DATA = 0x00000607, ErrorCode.IDR_ERROR_F_WRITE = 0x00000608, ErrorCode.IDR_ERROR_F_OVERFLOW = 0x00000609, ErrorCode.IDR_ERROR_F_SIZE = 0x0000060a,
ErrorCode.IDR_ERROR_F_COMPRESS = 0x0000060b, ErrorCode.IDR_ERROR_F_COLOR = 0x0000060c, ErrorCode.IDR_ERROR_ROTAUTO = 0x0000060d, ErrorCode.IDR_ERROR_JCHARLOAD = 0x00010003,
ErrorCode.IDR_NON_SUPPORT_OS = 0x00010004, ErrorCode.IDR_ERROR_LICENSE = 0x00020000, ErrorCode.IDR_ERROR_SAVEIMAGE = 0x00100000
}
エラーコード [詳細]
enum | RotateDirection { RotateDirection.IDR_ROT_0 = 0, RotateDirection.IDR_ROT_90 = 1, RotateDirection.IDR_ROT_180 = 2, RotateDirection.IDR_ROT_270 = 3 }
画像の回転方向を表す定数 [詳細]
enum | ImageFileType { ImageFileType.IDR_IMG_TIFF = 1, ImageFileType.IDR_IMG_BMP = 2, ImageFileType.IDR_IMG_JPG = 5 }
画像フォーマット定数 [詳細]
enum RegionType {
RegionType.TY_NONE = -1, RegionType.TY_CHAR_TEXT = 0x0006, RegionType.TY_IMAGE = 0x0002, RegionType.TY_TABLE = 0x0003,
RegionType.TY_DIAG = 0x0004, RegionType.TY_FIELD = 0x0005, RegionType.TY_CHAR_HAND = 0x0001
}
レイアウトの属性定数 [詳細]
enum | CharDirection { CharDirection.IDR_HORIZONTAL = 0x0000, CharDirection.IDR_VIRTIAL = 0x0001, CharDirection.IDR_VERTICAL = 0x0001 }
文字方向定数 [詳細]
enum CharClass {
CharClass.CHAR_CLASS_ALL = 0x0fff0, CharClass.CHAR_CLASS_KANJI_1ST = 0x00010, CharClass.CHAR_CLASS_KANJI_2ND = 0x00020, CharClass.CHAR_CLASS_KANJI = 0x00030,
CharClass.CHAR_CLASS_HIRAGANA = 0x00200, CharClass.CHAR_CLASS_KATAKANA = 0x00400, CharClass.CHAR_CLASS_ALPHABET = 0x00800, CharClass.CHAR_CLASS_NUMBER = 0x01000,
CharClass.CHAR_CLASS_SYMBOL = 0x0a000, CharClass.CHAR_CLASS_USER = 0x04000
}
文字クラス定数 [詳細]
enum HandCharClass {
HandCharClass.CHAR_CLASS_ALL = 0xff00, HandCharClass.CHAR_CLASS_KANJI = 0x0100, HandCharClass.CHAR_CLASS_HIRAGANA = 0x0200, HandCharClass.CHAR_CLASS_KATAKANA = 0x0400,
HandCharClass.CHAR_CLASS_ALPHABET = 0x0800, HandCharClass.CHAR_CLASS_NUMBER = 0x1000, HandCharClass.CHAR_CLASS_SYMBOL = 0x2000, HandCharClass.CHAR_CLASS_USER = 0x4000
}
手書き用文字クラス定数 [詳細]
enum | SizeImage { SizeImage.IDR_A4 = 1, SizeImage.IDR_A3 = 3, SizeImage.IDR_B4 = 5 }
動作モード定数 [詳細]
enum | PostMode { PostMode.IDR_POST_NON = 0, PostMode.IDR_POST_1 = 1, PostMode.IDR_POST_2 = 2 }
動作モード定数 [詳細]
enum | LanguageMode { LanguageMode.IDR_LANG_JAPANESE = 0, LanguageMode.IDR_LANG_ENGLISH = 1 }
言語モード定数 [詳細]
enum | LayoutMode { LayoutMode.LayoutMode_ALL = 0, LayoutMode.LayoutMode_Horizontal = 1, LayoutMode.LayoutMode_Vertical = 2 }
レイアウトモード定数 [詳細]

説明

OCRライブラリー(C版)の、C::ラッパークラス

列挙型

enum IdrEngine.CharClass

文字クラス定数

認識対象文字のクラス（種別）を表す。 使用時は、これらの論理和を取った値を使用する。

ILayout.Class IRegion.Class

列挙型の値
CHAR_CLASS_ALL | 全指定
CHAR_CLASS_KANJI_1ST | 第一水準漢字指定
CHAR_CLASS_KANJI_2ND | 第二水準漢字指定
CHAR_CLASS_KANJI | 漢字指定
CHAR_CLASS_HIRAGANA | ひらがな指定
CHAR_CLASS_KATAKANA | カタカナ指定
CHAR_CLASS_ALPHABET | アルファベット指定
CHAR_CLASS_NUMBER | 数字指定
CHAR_CLASS_SYMBOL | 記号指定
CHAR_CLASS_USER | ユーザー定義指定
enum IdrEngine.CharDirection

文字方向定数

レイアウト属性が「文字」である場合の文字方向を表す。

ILayout.Direction

列挙型の値
IDR_HORIZONTAL | 横書き文字
IDR_VIRTIAL | 縦書き文字（※将来のバージョンでは利用できなくなる可能性があります。）
IDR_VERTICAL | 縦書き文字
enum IdrEngine.ErrorCode

エラーコード

各メソッドの戻り値、またはスローする例外のエラーコード

IdrEngine.IDRException.No

列挙型の値
IDR_ERROR_EXCEPTION | ハードウェア例外が発生
IDR_ERROR_NORMAL | 正常終了
IDR_ERROR_MEMORY | メモリー不足
IDR_ERROR_PARAMETER | 引数が違う
IDR_ERROR_RECOG_AREA | 認識領域がA4版より大きい
IDR_ERROR_IMAGE_AREA | 認識領域がイメージデータを超過
IDR_ERROR_PERMIT | 許可されたIDと異なる
IDR_ERROR_MULTI_INSTANCE | 多重起動された
IDR_ERROR_TRIAL_LIMIT | 体験版の使用期限を超過
IDR_ERROR_OVER | 制限数を超えた設定がされた
IDR_ERROR_GETPROC | 関数のポインター取得に失敗
IDR_ERROR_PROC | 関数ポインターがNULL
IDR_ERROR_IMAGE | 原画像がセットされていない
IDR_ERROR_LAYOUT_NOREGION | 領域がない
IDR_ERROR_LAYOUT_COMPLEX | 領域が複雑過ぎる
IDR_ERROR_CHAR_DICTLOAD | 辞書読込みエラー
IDR_ERROR_CHAR_DICTDATA | 辞書データエラー
IDR_ERROR_CHAR_VOIDTEXT | 領域中に文字がない
IDR_ERROR_CHAR_EXCEPTREGION | 無視された部分がある
IDR_ERROR_CHAR_ILLEGIBLETEXT | 認識不能
IDR_ERROR_CHAR_DIRECTION | 未対応の文字組方向がある
IDR_ERROR_CHAR_TOOMANY | 1領域中の文字数が多過ぎる
IDR_ERROR_CHAR_STOP | ユーザーからの中止
IDR_ERROR_CHAR_OVER | 登録文字数が上限を超過
IDR_ERROR_NOT_EXIST | 登録文字が辞書に存在しない
IDR_ERROR_NOT_ENTRY | 文字が登録されていない
IDR_ERROR_NOT_REMOVE | 文字を削除できない
IDR_ERROR_ENTRY_YET | 文字がすでに登録されている
IDR_ERROR_TIMEOUT | 処理時間がかかり過ぎたために処理を中断した
IDR_ERROR_JCHAR_UD_LIMIT | ユーザー辞書の登録語数上限を超過
IDR_ERROR_JCHAR_UD_HINSHI | ユーザー辞書には不適な品詞番号
IDR_ERROR_JCHAR_UD_ALREADY | 辞書に登録済み
IDR_ERROR_JCHAR_UD_SPACE | ユーザー辞書に空白文字を登録
IDR_ERROR_JCHAR_UD_LARGE | ユーザー辞書への登録文字が60P以上
IDR_ERROR_JCHAR_UD_CODE | ユーザー辞書に不適な文字を登録
IDR_ERROR_JCHAR_UD_RECOVER | ユーザー辞書処理において何らかの障害が発生したが、関数内部で対策を行った
IDR_ERROR_JCHAR_UD_SAVE | ユーザー辞書ファイル保存に失敗
IDR_ERROR_TABLE_COMPLEX | 表が複雑過ぎる
IDR_ERROR_TABLE_LINEDENSITY | 線が密集し過ぎる
IDR_ERROR_POST_UD_LIMIT | ユーザー辞書の登録語数上限を超過
IDR_ERROR_POST_UD_HINSHI | ユーザー辞書には不適な品詞番号
IDR_ERROR_POST_UD_ALREADY | 辞書に登録済み
IDR_ERROR_POST_UD_SPACE | ユーザー辞書に空白文字を登録
IDR_ERROR_POST_UD_CODE | ユーザー辞書に不適な文字を登録
IDR_ERROR_POST_UD_RECOVER | ユーザー辞書処理において何らかの障害が発生したが、関数内部で対策を行った
IDR_ERROR_POST_UD_SAVE | ユーザー辞書ファイルの保存に失敗
IDR_ERROR_F_OPEN | オープンエラー
IDR_ERROR_F_READ | 読込みエラー
IDR_ERROR_F_SEEK | 読込みシークエラー
IDR_ERROR_F_TAGMAX | タグエラー
IDR_ERROR_F_TIFFTYPE | tiff形式エラー
IDR_ERROR_F_BMPTYPE | bmp形式エラー
IDR_ERROR_F_DATA | データエラー
IDR_ERROR_F_WRITE | 書込みエラー
IDR_ERROR_F_OVERFLOW | オーバーフローエラー
IDR_ERROR_F_SIZE | サイズエラー
IDR_ERROR_F_COMPRESS | 圧縮エラー
IDR_ERROR_F_COLOR | カラーエラー
IDR_ERROR_ROTAUTO | 傾き補正ができない
IDR_ERROR_JCHARLOAD | jchar.dllがロードできない
IDR_NON_SUPPORT_OS | 未対応OS
IDR_ERROR_LICENSE | ライセンスエラー
IDR_ERROR_SAVEIMAGE | 画像保存に失敗
enum IdrEngine.HandCharClass

手書き用文字クラス定数

認識対象文字のクラス（種別）を表す。 使用時は、これらの論理和を取った値を使用する。

ILayout.Class IRegion.Class

列挙型の値
CHAR_CLASS_ALL | 全指定
CHAR_CLASS_KANJI | 漢字指定
CHAR_CLASS_HIRAGANA | ひらがな指定
CHAR_CLASS_KATAKANA | カタカナ指定
CHAR_CLASS_ALPHABET | アルファベット指定
CHAR_CLASS_NUMBER | 数字指定
CHAR_CLASS_SYMBOL | 記号指定
CHAR_CLASS_USER | ユーザー定義指定
enum IdrEngine.ImageFileType

画像フォーマット定数

IdrEngine.IEngine.SaveImage

列挙型の値
IDR_IMG_TIFF | Tiff(G4)
IDR_IMG_BMP | Bmp
IDR_IMG_JPG | JPEG
enum IdrEngine.LanguageMode

言語モード定数

認識言語

列挙型の値
IDR_LANG_JAPANESE | 日本語
IDR_LANG_ENGLISH | 英語
enum IdrEngine.LayoutMode

レイアウトモード定数

列挙型の値
LayoutMode_ALL | 縦横混在
LayoutMode_Horizontal | 横書きのみ
LayoutMode_Vertical | 縦書きのみ
enum IdrEngine.PostMode

動作モード定数

言語処理の処理回数

列挙型の値
IDR_POST_NON | 言語処理を行わない
IDR_POST_1 | 1回
IDR_POST_2 | 2回
enum IdrEngine.RegionType

レイアウトの属性定数

ILayout.Attribute

列挙型の値
TY_NONE | 属性なし
TY_CHAR_TEXT | 文字
TY_IMAGE | 画像
TY_TABLE | 表
TY_DIAG | 図形
TY_FIELD | 罫線
TY_CHAR_HAND | 手書き
enum IdrEngine.RotateDirection

画像の回転方向を表す定数

IdrEngine.IEngine.AutoRotate IdrEngine.IEngine.ManualRotate

列挙型の値
IDR_ROT_0 | 回転の必要なし
IDR_ROT_90 | 時計回りに90度回転する必要がある
IDR_ROT_180 | 時計回りに180度回転する必要がある
IDR_ROT_270 | 時計回りに270度回転する必要がある
enum IdrEngine.SizeImage

動作モード定数

入力画像の最大サイズ

列挙型の値
IDR_A4 | A4サイズ
IDR_A3 | A3サイズ
IDR_B4 | B4サイズ


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.EngineFactory

  • IdrEngine
  • EngineFactory
Static Public メソッド | プロパティ | すべてのメンバ一覧
クラス IdrEngine.EngineFactory

OCRエンジンの管理クラス [詳細]

Static Public メソッド

static IEngine GetEngine ()
OCRエンジンのインスタンスの生成・取得を行う。 [詳細]

プロパティ

static ProcMode | DefaultProcMode [get]
動作モードについて、規定の設定を取得する。 [詳細]
static ProcMode | ProcMode [get, set]
動作モードを取得、または設定する。 [詳細]
static LanguageMode | Language [get, set]
言語モードを取得、または設定する。 [詳細]
static bool | Hand [get, set]
手書き認識の有無を取得、または設定する。 [詳細]

説明

OCRエンジンの管理クラス

エンジンの生成・取得を行う

メソッド

static IEngine IdrEngine.EngineFactory.GetEngine ( )
static

OCRエンジンのインスタンスの生成・取得を行う。

このメソッドによりOCRエンジンを取得後、IdrEngine.IEngine.Release() を呼び出すまで、本メソッドの呼び出しは拒絶される。

戻り値
OCRエンジンの唯一のインスタンスを返す。

プロパティ

ProcMode IdrEngine.EngineFactory.DefaultProcMode
staticget

動作モードについて、規定の設定を取得する。

戻り値
動作モード
bool IdrEngine.EngineFactory.Hand
staticgetset

手書き認識の有無を取得、または設定する。

戻り値
手書き認識有無
LanguageMode IdrEngine.EngineFactory.Language
staticgetset

言語モードを取得、または設定する。

戻り値
言語モード
ProcMode IdrEngine.EngineFactory.ProcMode
staticgetset

動作モードを取得、または設定する。

戻り値
動作モード


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.IDRException

  • IDRException
Public メソッド | プロパティ | すべてのメンバ一覧
クラス IdrEngine.IDRException

OCRエンジン内でのエラーを通知する。 [詳細]

IdrEngine.IDRExceptionに対する継承グラフ

Public メソッド

IDRException (int i, string msg)
コンストラクタ [詳細]
IDRException (ErrorCode i, string msg)
コンストラクタ [詳細]
bool | InvalidLicense ()
ライセンスエラーをチェックする。 [詳細]
override System.String | ToString ()

プロパティ

ErrorCode No [get]
エラーコードを取得する。 [詳細]

説明

OCRエンジン内でのエラーを通知する。

コンストラクタとデストラクタ

IdrEngine.IDRException.IDRException | ( | int | i,
 |  | string | msg
 | ) |  |

コンストラクタ

引数
i | エラーコード
msg | エラーメッセージ
IdrEngine.IDRException.IDRException | ( | ErrorCode | i,
 |  | string | msg
 | ) |  |

コンストラクタ

引数
i | エラーコード
msg | エラーメッセージ

メソッド

bool IdrEngine.IDRException.InvalidLicense ( )

ライセンスエラーをチェックする。

戻り値
ライセンスエラーの場合はtrue。それ以外の場合はfalse。

プロパティ

ErrorCode IdrEngine.IDRException.No
get

エラーコードを取得する。

戻り値
エラーコード


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.IDRRect

  • IDRRect
Public メソッド | プロパティ | すべてのメンバ一覧
クラス IdrEngine.IDRRect

矩形情報管理クラス [詳細]

IdrEngine.IDRRectに対する継承グラフ
IdrEngine.IIDRRect IdrEngine.Engine.Layout IdrEngine.Engine.Layout IdrEngine.Engine.Layout.Region IdrEngine.Engine.LayoutHand IdrEngine.Engine.LayoutOther IdrEngine.Engine.LayoutTable IdrEngine.Engine.LayoutHand IdrEngine.Engine.LayoutOther IdrEngine.Engine.LayoutTable IdrEngine.Engine.Layout.RegionTbl

Public メソッド

IDRRect (ref IdrEngine.CSRect rect)
IDRRect (ref IIDRRect rect)
IDRRect (int x0, int y0, int x2, int y2)
void Set (ref IdrEngine.CSRect rect)
IdrEngine.CSRectにより表される矩形を設定する。 [詳細]

プロパティ

int | Width [get]
int | Height [get]
int | Left [get]
int | Top [get]
int | Right [get]
int | Bottom [get]
- プロパティ inherited from IdrEngine.IIDRRect
int | Width [get]
矩形の幅を取得する。 [詳細]
int | Height [get]
矩形の高さを取得する。 [詳細]
int | Left [get]
矩形の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
矩形の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
矩形の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
矩形の右下のY座標（矩形に含まれる）を取得する。 [詳細]

説明

矩形情報管理クラス

メソッド

void IdrEngine.IDRRect.Set ( ref IdrEngine.CSRect rect)

IdrEngine.CSRectにより表される矩形を設定する。

引数
rect 矩形情報

IdrEngine.IIDRRectを実装しています。


活字認識ライブラリー .NET APIリファレンス: インタフェース IdrEngine.IIDRRect

  • IIDRRect
Public メソッド | プロパティ | すべてのメンバ一覧
インタフェース IdrEngine.IIDRRect

領域を指定する際に用いる矩形情報を管理する。 [詳細]

IdrEngine.IIDRRectに対する継承グラフ
IdrEngine.IDRRect IdrEngine.Engine.Layout IdrEngine.Engine.Layout IdrEngine.Engine.Layout.Region IdrEngine.Engine.LayoutHand IdrEngine.Engine.LayoutOther IdrEngine.Engine.LayoutTable IdrEngine.Engine.LayoutHand IdrEngine.Engine.LayoutOther IdrEngine.Engine.LayoutTable IdrEngine.Engine.Layout.RegionTbl

Public メソッド

void Set (ref IdrEngine.CSRect rect)
IdrEngine.CSRectにより表される矩形を設定する。 [詳細]

プロパティ

int | Width [get]
矩形の幅を取得する。 [詳細]
int | Height [get]
矩形の高さを取得する。 [詳細]
int | Left [get]
矩形の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
矩形の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
矩形の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
矩形の右下のY座標（矩形に含まれる）を取得する。 [詳細]

説明

領域を指定する際に用いる矩形情報を管理する。

メソッド

void IdrEngine.IIDRRect.Set ( ref IdrEngine.CSRect rect)

IdrEngine.CSRectにより表される矩形を設定する。

引数
rect 矩形情報

IdrEngine.IDRRectで実装されています。

プロパティ

int IdrEngine.IIDRRect.Bottom
get

矩形の右下のY座標（矩形に含まれる）を取得する。

戻り値
矩形の右下のY座標
int IdrEngine.IIDRRect.Height
get

矩形の高さを取得する。

戻り値
矩形の高さ
int IdrEngine.IIDRRect.Left
get

矩形の左上のX座標（矩形に含まれる）を取得する。

戻り値
矩形の左上のX座標
int IdrEngine.IIDRRect.Right
get

矩形の右下のX座標（矩形に含まれる）を取得する。

戻り値
矩形の右下のX座標
int IdrEngine.IIDRRect.Top
get

矩形の左上のY座標（矩形に含まれる）を取得する。

戻り値
矩形の左上のY座標
int IdrEngine.IIDRRect.Width
get

矩形の幅を取得する。

戻り値
矩形の幅


活字認識ライブラリー .NET APIリファレンス: インタフェース IdrEngine.ICandInf

  • ICandInf
プロパティ | すべてのメンバ一覧
インタフェース IdrEngine.ICandInf

文字認識によって得られる個々の文字についての情報を管理する。 [詳細]

IdrEngine.Engine.Layout.Region.CandInfに継承されています。

プロパティ

IIDRRect | Rect [get]
文字画像の外接矩形を取得する。 [詳細]
bool | IsWideChar [get]
全角文字かどうかを示す。 [詳細]
bool | IsKakutei [get]
確定文字かどうかを示す。 [詳細]
int | Size [get]
フォントサイズを示す。 [詳細]
bool | IsItalic [get]
イタリック文字かどうかを示す。 [詳細]
CharCand | this[int idx] [get]
指定番目の候補文字を取得する。 [詳細]
ICandInf | Next [get]
次の文字を取得する。 [詳細]
int | Color [get]
フォントカラーを示す。 [詳細]

説明

文字認識によって得られる個々の文字についての情報を管理する。

IdrEngine.IRegion.CandTop および IdrEngine.ICandInf.Next により取得する。

プロパティ

int IdrEngine.ICandInf.Color
get

フォントカラーを示す。

戻り値
フォントカラー
bool IdrEngine.ICandInf.IsItalic
get

イタリック文字かどうかを示す。

戻り値
イタリック文字の場合は true。それ以外の場合は false。
bool IdrEngine.ICandInf.IsKakutei
get

確定文字かどうかを示す。

戻り値
確定文字の場合は true。それ以外の場合は false。
bool IdrEngine.ICandInf.IsWideChar
get

全角文字かどうかを示す。

戻り値
全角文字の場合は true。それ以外の場合は false。
ICandInf IdrEngine.ICandInf.Next
get

次の文字を取得する。

戻り値

次の文字

終端に達した場合は null となる。

IIDRRect IdrEngine.ICandInf.Rect
get

文字画像の外接矩形を取得する。

戻り値
文字画像の外接矩形
int IdrEngine.ICandInf.Size
get

フォントサイズを示す。

※本機能は未対応です。使用しないでください。

戻り値
フォントサイズ
CharCand IdrEngine.ICandInf.this[int idx]
get

指定番目の候補文字を取得する。

戻り値
候補文字


活字認識ライブラリー .NET APIリファレンス: インタフェース IdrEngine.IRegion

  • IRegion
Public メソッド | プロパティ | すべてのメンバ一覧
インタフェース IdrEngine.IRegion

認識領域についての情報を管理する。 [詳細]

IdrEngine.IRegionに対する継承グラフ
IdrEngine.Engine.Layout.Region IdrEngine.ICellRegion IdrEngine.Engine.Layout.RegionTbl IdrEngine.Engine.Layout.RegionTbl

Public メソッド

void Delete ()
対応するメモリーを解放する。 [詳細]

プロパティ

int | Row [get]
表内の自分の行番号を取得する。 [詳細]
int | Col [get]
表内の自分の列番号を取得する。 [詳細]
int | Class [get]
認識に使用された文字クラスを取得する。 [詳細]
String | UserChar [get]
認識に使用されたユーザー指定文字を取得する。 [詳細]
int | Width [get]
認識領域の幅を取得する。 [詳細]
int | Height [get]
認識領域の高さを取得する。 [詳細]
int | Left [get]
認識領域の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
認識領域の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
認識領域の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
認識領域の右下のY座標（矩形に含まれる）を取得する。 [詳細]
ICandInf | CandTop [get]
認識領域の認識結果から、最初の文字についての情報を取得する。 [詳細]
String | StrCand [get]
認識領域の認識結果文字列を取得する。 [詳細]

説明

認識領域についての情報を管理する。

レイアウトが表以外の場合は、1認識領域 = 1レイアウトとなる。 表の場合は、1認識領域 = 表内の1セルとなる。 IdrEngine.ILayout[row, col] により取得する。

メソッド

void IdrEngine.IRegion.Delete ( )

対応するメモリーを解放する。

不要になった後、OCRエンジンの解放を行う前に、必ずこのメソッドを使用しておく必要がある。

IdrEngine.Engine.Layout.RegionTbl, と IdrEngine.Engine.Layout.Regionで実装されています。

プロパティ

int IdrEngine.IRegion.Bottom
get

認識領域の右下のY座標（矩形に含まれる）を取得する。

戻り値
認識領域の右下のY座標
ICandInf IdrEngine.IRegion.CandTop
get

認識領域の認識結果から、最初の文字についての情報を取得する。

戻り値
最初の文字についての情報
int IdrEngine.IRegion.Class
get

認識に使用された文字クラスを取得する。

戻り値
認識に使用された文字クラス
int IdrEngine.IRegion.Col
get

表内の自分の列番号を取得する。

戻り値
表中の自分の列番号（表以外の時は 0）
int IdrEngine.IRegion.Height
get

認識領域の高さを取得する。

戻り値
認識領域の高さ
int IdrEngine.IRegion.Left
get

認識領域の左上のX座標（矩形に含まれる）を取得する。

戻り値
認識領域の左上のX座標
int IdrEngine.IRegion.Right
get

認識領域の右下のX座標（矩形に含まれる）を取得する。

戻り値
認識領域の右下のX座標
int IdrEngine.IRegion.Row
get

表内の自分の行番号を取得する。

戻り値
表中の自分の行番号（表以外の時は 0）
String IdrEngine.IRegion.StrCand
get

認識領域の認識結果文字列を取得する。

戻り値
認識結果文字列
int IdrEngine.IRegion.Top
get

認識領域の左上のY座標（矩形に含まれる）を取得する。

戻り値
認識領域の左上のY座標
String IdrEngine.IRegion.UserChar
get

認識に使用されたユーザー指定文字を取得する。

戻り値
認識に使用されたユーザー指定文字
int IdrEngine.IRegion.Width
get

認識領域の幅を取得する。

戻り値
認識領域の幅


活字認識ライブラリー .NET APIリファレンス: インタフェース IdrEngine.ICellRegion

  • ICellRegion
プロパティ | すべてのメンバ一覧
インタフェース IdrEngine.ICellRegion

表認識領域についての情報を管理する。 [詳細]

IdrEngine.ICellRegionに対する継承グラフ
IdrEngine.IRegion IdrEngine.Engine.Layout.RegionTbl

プロパティ

CellInfo | Cell [get]
表のセル情報を取得する。 [詳細]
- プロパティ inherited from IdrEngine.IRegion
int | Row [get]
表内の自分の行番号を取得する。 [詳細]
int | Col [get]
表内の自分の列番号を取得する。 [詳細]
int | Class [get]
認識に使用された文字クラスを取得する。 [詳細]
String | UserChar [get]
認識に使用されたユーザー指定文字を取得する。 [詳細]
int | Width [get]
認識領域の幅を取得する。 [詳細]
int | Height [get]
認識領域の高さを取得する。 [詳細]
int | Left [get]
認識領域の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
認識領域の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
認識領域の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
認識領域の右下のY座標（矩形に含まれる）を取得する。 [詳細]
ICandInf | CandTop [get]
認識領域の認識結果から、最初の文字についての情報を取得する。 [詳細]
String | StrCand [get]
認識領域の認識結果文字列を取得する。 [詳細]

Additional Inherited Members

- Public メソッド inherited from IdrEngine.IRegion
void Delete ()
対応するメモリーを解放する。 [詳細]

説明

表認識領域についての情報を管理する。

IdrEngine.ILayout[row, col] により取得する。

プロパティ

CellInfo IdrEngine.ICellRegion.Cell
get

表のセル情報を取得する。

戻り値
セル情報


活字認識ライブラリー .NET APIリファレンス: インタフェース IdrEngine.ILayout

  • ILayout
Public メソッド | プロパティ | すべてのメンバ一覧
インタフェース IdrEngine.ILayout

各レイアウトの情報を管理する。 [詳細]

IdrEngine.ILayoutに対する継承グラフ
IdrEngine.Engine.Layout IdrEngine.Engine.Layout IdrEngine.Engine.LayoutHand IdrEngine.Engine.LayoutOther IdrEngine.Engine.LayoutTable IdrEngine.Engine.LayoutHand IdrEngine.Engine.LayoutOther IdrEngine.Engine.LayoutTable

Public メソッド

void | Delete ()
対応するメモリーを解放する。 [詳細]
int | NumOfCol (int row)
レイアウトの指定行の列数を取得する。 [詳細]

プロパティ

int | NumOfRow [get]
レイアウトに含まれる行数を取得する。 [詳細]
int | Class [get, set]
認識に使用された文字クラスを取得、または設定する。 [詳細]
String | UserChar [get, set]
認識に使用されたユーザー指定文字を取得、または設定する。 [詳細]
IRegion | this[int row, int col] [get]
行番号・列番号を指定して認識領域を取得する。 [詳細]
int | Width [get]
レイアウトの幅を取得する。 [詳細]
int | Height [get]
レイアウトの高さを取得する。 [詳細]
int | Left [get]
レイアウトの左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
レイアウトの左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
レイアウトの右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
レイアウトの右下のY座標（矩形に含まれる）を取得する。 [詳細]
RegionType | Attribute [get]
領域属性を取得する。 [詳細]
CharDirection | Direction [get]
レイアウトの文字方向を取得する。 [詳細]
String | strAttr [get]
領域属性を文字列で取得する。 [詳細]

説明

各レイアウトの情報を管理する。

IdrEngine.ILayoutList[n] により取得する。

メソッド

void IdrEngine.ILayout.Delete ( )

対応するメモリーを解放する。

不要になった後、OCRエンジンの解放を行う前に、必ずこのメソッドを使用しておく必要がある。

IdrEngine.Engine.LayoutTable, と IdrEngine.Engine.Layoutで実装されています。

int IdrEngine.ILayout.NumOfCol ( int row)

レイアウトの指定行の列数を取得する。

引数
row 行番号
戻り値
レイアウトの指定行の列数（表以外の場合 1）

IdrEngine.Engine.LayoutTable, と IdrEngine.Engine.Layoutで実装されています。

プロパティ

RegionType IdrEngine.ILayout.Attribute
get

領域属性を取得する。

戻り値
領域属性
int IdrEngine.ILayout.Bottom
get

レイアウトの右下のY座標（矩形に含まれる）を取得する。

戻り値
レイアウトの右下のY座標
int IdrEngine.ILayout.Class
getset

認識に使用された文字クラスを取得、または設定する。

this[row, col]により認識領域を取得する前に設定しておく必要がある。

戻り値
認識に使用された文字クラス
CharDirection IdrEngine.ILayout.Direction
get

レイアウトの文字方向を取得する。

戻り値
レイアウトの文字方向
int IdrEngine.ILayout.Height
get

レイアウトの高さを取得する。

戻り値
レイアウトの高さ
int IdrEngine.ILayout.Left
get

レイアウトの左上のX座標（矩形に含まれる）を取得する。

戻り値
レイアウトの左上のX座標
int IdrEngine.ILayout.NumOfRow
get

レイアウトに含まれる行数を取得する。

戻り値
レイアウトに含まれる行数（表以外の場合 1）
int IdrEngine.ILayout.Right
get

レイアウトの右下のX座標（矩形に含まれる）を取得する。

戻り値
レイアウトの右下のX座標
String IdrEngine.ILayout.strAttr
get

領域属性を文字列で取得する。

戻り値
領域属性の文字列表現
IRegion IdrEngine.ILayout.this[int row, int col]
get

行番号・列番号を指定して認識領域を取得する。

NumOfRow, NumOfCol() の範囲で指定。

戻り値

認識領域

範囲外の認識領域を指定した場合、または認識領域が取得できなかった場合はnull。

int IdrEngine.ILayout.Top
get

レイアウトの左上のY座標（矩形に含まれる）を取得する。

戻り値
レイアウトの左上のY座標
String IdrEngine.ILayout.UserChar
getset

認識に使用されたユーザー指定文字を取得、または設定する。

this[row, col]により認識領域を取得する前に設定しておく必要がある。 ClassにCHAR_CLASS_USER が設定されている場合に有効。

戻り値
認識に使用されたユーザー指定文字
int IdrEngine.ILayout.Width
get

レイアウトの幅を取得する。

戻り値
レイアウトの幅


活字認識ライブラリー .NET APIリファレンス: インタフェース IdrEngine.ILayoutList

  • ILayoutList
プロパティ | すべてのメンバ一覧
インタフェース IdrEngine.ILayoutList

レイアウトのリストの管理を行う。 [詳細]

IdrEngine.ILayoutListに対する継承グラフ
IdrEngine.Engine.LayoutList

プロパティ

ILayout | this[int idx] [get]
指定番目のレイアウトを取得する。 [詳細]
int | Count [get]
レイアウト数を取得します。 [詳細]

説明

レイアウトのリストの管理を行う。

IdrEngine.IEngine.RecogLayout() により取得する。

プロパティ

int IdrEngine.ILayoutList.Count
get

レイアウト数を取得します。

戻り値
レイアウト数
ILayout IdrEngine.ILayoutList.this[int idx]
get

指定番目のレイアウトを取得する。

戻り値

指定番目のレイアウト

範囲外を指定した場合はnullが返る。


活字認識ライブラリー .NET APIリファレンス: インタフェース IdrEngine.IEngine

  • IEngine
Public メソッド | プロパティ | すべてのメンバ一覧
インタフェース IdrEngine.IEngine

認識対象画像の管理・認識処理を行う。 [詳細]

IdrEngine.Engine, IdrEngine.Engine, と IdrEngine.Engineに継承されています。

Public メソッド

void | Release ()
OCRエンジンの解放を行う。 [詳細]
void | SetBmp (IntPtr pBmp)
認識対象画像の指定を行う。 [詳細]
void | SetBmp (Bitmap bmp)
認識対象画像の指定を行う。 [詳細]
void | SetBmp (string strFile, int nPage)
認識対象画像の指定を行う。 [詳細]
void | SaveImage (string strFile, ImageFileType nType)
認識対象画像の保存を行う。 [詳細]
double | AutoSkew ()
自動傾き補正を行う。 [詳細]
void | ManualSkew (double dRad)
手動傾き補正を行う。 [詳細]
RotateDirection AutoRotate ()
自動回転処理を行う。 [詳細]
void | ManualRoate (RotateDirection nDir)
手動回転処理を行う。（※将来のバージョンでは利用できなくなる可能性があります。） [詳細]
void | ManualRotate (RotateDirection nDir)
手動回転処理を行う。 [詳細]
void | Despeckle (IIDRRect rect, int dotSize)
ノイズ除去を行う。 [詳細]
ILayoutList | RecogLayout (IIDRRect rect)
レイアウトを取得する。 [詳細]
ILayoutList | RecogLayout (IIDRRect rect, LayoutMode layoutmode)
レイアウトを取得する。 [詳細]
ILayout | CreateLayout (ref IIDRRect rect, CharDirection direction)
レイアウトを作成する。 [詳細]
ILayout | CreateLayout (ref IIDRRect rect, CharDirection direction, RegionType category)
レイアウトを作成する。 [詳細]
TrapeCoordinate TrapezoidCoodinate ()
台形補正に必要な原稿の4点を取得します。 [詳細]
void | TrapezoidImage (ref TrapeCoordinate trapeCoord, int width, int height)
画像の台形補正を行います。 [詳細]

プロパティ

string | PatternDic [get, set]
ユーザーパターン辞書のパスを取得、または設定する。 [詳細]
string | PostDic [get, set]
ユーザー単語辞書のパスを取得、または設定する。 [詳細]
IIDRRect | Rect [get]
設定されている画像のサイズを取得する。 [詳細]
bool | SpeedMode [get, set]
スピードモードを取得、または設定する。 [詳細]
bool | Italic [get, set]
イタリック認識の有無を取得、または設定する。 [詳細]
bool | Ruby [get, set]
ルビ認識の有無を取得、または設定する。 [詳細]
bool | LowResolution [get, set]
低解像度画像の認識精度向上処理の有無を取得、または設定する。 [詳細]
bool | CancelLine [get, set]
取り消し線認識の有無を取得、または設定する。 [詳細]

説明

認識対象画像の管理・認識処理を行う。

IdrEngine.EngineFactory.GetEngine() により取得する。

メソッド

RotateDirection IdrEngine.IEngine.AutoRotate ( )

自動回転処理を行う。

認識対象画像の回転方向を自動で検出し、その補正を行う。

戻り値
回転方向
double IdrEngine.IEngine.AutoSkew ( )

自動傾き補正を行う。

認識対象画像の傾きを自動検出し、傾き補正を行う。

戻り値
傾き確度（単位：度）
ILayout IdrEngine.IEngine.CreateLayout | ( | ref IIDRRect | rect,
 |  | CharDirection | direction
 | ) |  |

レイアウトを作成する。

レイアウト認識を行わずに、指定領域の文字属性レイアウトを作成する。

引数
rect | レイアウトを作成する対象領域
direction | レイアウト内の文字方向
戻り値
レイアウト
ILayout IdrEngine.IEngine.CreateLayout | ( | ref IIDRRect | rect,
 |  | CharDirection | direction,
 |  | RegionType | category
 | ) |  |

レイアウトを作成する。

レイアウト認識を行わずに、指定領域の文字属性レイアウトを作成する。

引数
rect | レイアウトを作成する対象領域
direction | レイアウト内の文字方向
category | レイアウトの領域属性
戻り値
レイアウト
void IdrEngine.IEngine.Despeckle | ( | IIDRRect | rect,
 |  | int | dotSize
 | ) |  |

ノイズ除去を行う。

引数
rect | 範囲
dotSize | サイズ
void IdrEngine.IEngine.ManualRoate ( RotateDirection nDir)

手動回転処理を行う。（※将来のバージョンでは利用できなくなる可能性があります。）

指定の回転方向だけ、回転させ補正を行う。

引数
nDir 回転方向
void IdrEngine.IEngine.ManualRotate ( RotateDirection nDir)

手動回転処理を行う。

指定の回転方向だけ、回転させ補正を行う。

引数
nDir 回転方向
void IdrEngine.IEngine.ManualSkew ( double dRad)

手動傾き補正を行う。

指定の角度だけ傾き補正を行う。

引数
dRad 補正角度（単位：度）
ILayoutList IdrEngine.IEngine.RecogLayout ( IIDRRect rect)

レイアウトを取得する。

認識対象画像の指定領域に対してレイアウト認識を行い、そのレイアウトのリストを取得する。

引数
rect 認識対象領域
戻り値
レイアウトリスト
ILayoutList IdrEngine.IEngine.RecogLayout | ( | IIDRRect | rect,
 |  | LayoutMode | layoutmode
 | ) |  |

レイアウトを取得する。

認識対象画像の指定領域に対してレイアウト認識を行い、そのレイアウトのリストを取得する。

引数
rect | 認識対象領域
layoutmode | レイアウトモード
戻り値
レイアウトリスト
void IdrEngine.IEngine.Release ( )

OCRエンジンの解放を行う。

IdrEngine.EngineFactory.GetEngine()で取得後、このメソッドによりOCRエンジンを解放するまでは他からはエンジンの取得が行えない。

void IdrEngine.IEngine.SaveImage | ( | string | strFile,
 |  | ImageFileType | nType
 | ) |  |

認識対象画像の保存を行う。

認識対象画像を指定のファイルに指定のフォーマットで保存する。

引数
strFile | ファイル名
nType | 画像フォーマット
void IdrEngine.IEngine.SetBmp ( IntPtr pBmp)

認識対象画像の指定を行う。

引数
pBmp BITMAPINFOHEADERの先頭アドレス
void IdrEngine.IEngine.SetBmp ( Bitmap bmp)

認識対象画像の指定を行う。

引数
bmp ビットマップオブジェクト
void IdrEngine.IEngine.SetBmp | ( | string | strFile,
 |  | int | nPage
 | ) |  |

認識対象画像の指定を行う。

ファイルを指定して認識対象画像を設定する。

引数
strFile | 画像ファイルのパス
nPage | 画像ファイル中のページ番号（マルチページTIF用）
TrapeCoordinate IdrEngine.IEngine.TrapezoidCoodinate ( )

台形補正に必要な原稿の4点を取得します。

戻り値
原稿4点座標情報
void IdrEngine.IEngine.TrapezoidImage | ( | ref TrapeCoordinate | trapeCoord,
 |  | int | width,
 |  | int | height
 | ) |  |

画像の台形補正を行います。

引数
trapeCoord | 原稿4点座標情報
width | 補正後画像の幅
height | 補正後画像の高さ

プロパティ

bool IdrEngine.IEngine.CancelLine
getset

取り消し線認識の有無を取得、または設定する。

bool IdrEngine.IEngine.Italic
getset

イタリック認識の有無を取得、または設定する。

bool IdrEngine.IEngine.LowResolution
getset

低解像度画像の認識精度向上処理の有無を取得、または設定する。

string IdrEngine.IEngine.PatternDic
getset

ユーザーパターン辞書のパスを取得、または設定する。

戻り値
ユーザーパターン辞書のパス
string IdrEngine.IEngine.PostDic
getset

ユーザー単語辞書のパスを取得、または設定する。

戻り値
ユーザー単語辞書のパス
IIDRRect IdrEngine.IEngine.Rect
get

設定されている画像のサイズを取得する。

戻り値
設定されている画像のサイズが返る。取得できない場合は nullが返る。
bool IdrEngine.IEngine.Ruby
getset

ルビ認識の有無を取得、または設定する。

bool IdrEngine.IEngine.SpeedMode
getset

スピードモードを取得、または設定する。


活字認識ライブラリー .NET APIリファレンス: 構造体 IdrEngine.CSRect

  • CSRect
Public 変数 | すべてのメンバ一覧
構造体 IdrEngine.CSRect

矩形情報構造体 [詳細]

Public 変数

short | left
左上の座標 X [詳細]
short | top
左上の座標 Y [詳細]
short | width
横幅 [詳細]
short | height
縦幅 [詳細]

説明

矩形情報構造体

変数

short IdrEngine.CSRect.height

縦幅

short IdrEngine.CSRect.left

左上の座標 X

short IdrEngine.CSRect.top

左上の座標 Y

short IdrEngine.CSRect.width

横幅


活字認識ライブラリー .NET APIリファレンス: 構造体 IdrEngine.CharCand

  • CharCand
Public 変数 | すべてのメンバ一覧
構造体 IdrEngine.CharCand

候補文字情報構造体 [詳細]

Public 変数

short | code
文字コード(unicode) [詳細]
uint | value
識別距離 [詳細]

説明

候補文字情報構造体

認識結果文字の各候補文字を格納する。IdrEngine.ICandInf[n] により取得する。

変数

short IdrEngine.CharCand.code

文字コード(unicode)

uint IdrEngine.CharCand.value

識別距離


活字認識ライブラリー .NET APIリファレンス: 構造体 IdrEngine.ProcMode

  • ProcMode
Public 変数 | すべてのメンバ一覧
構造体 IdrEngine.ProcMode

動作モード 構造体 [詳細]

Public 変数

SizeImage sizeImage
入力画像の最大サイズ [詳細]
bool secondRecog
再認識を行う [詳細]
PostMode langProcMode
言語処理の処理回数を指定 (0, 1 or 2) [詳細]

説明

動作モード 構造体

OCRの動作モードについて取得・設定する。

変数

PostMode IdrEngine.ProcMode.langProcMode

言語処理の処理回数を指定 (0, 1 or 2)

bool IdrEngine.ProcMode.secondRecog

再認識を行う

SizeImage IdrEngine.ProcMode.sizeImage

入力画像の最大サイズ


活字認識ライブラリー .NET APIリファレンス: 構造体 IdrEngine.Point

  • Point
Public 変数 | すべてのメンバ一覧
構造体 IdrEngine.Point

4点検出(台形補正)の座標 構造体 [詳細]

Public 変数

int | x
int | y

説明

4点検出(台形補正)の座標 構造体


活字認識ライブラリー .NET APIリファレンス: 構造体 IdrEngine.TrapeCoordinate

  • TrapeCoordinate
Public 変数 | すべてのメンバ一覧
構造体 IdrEngine.TrapeCoordinate

原稿領域4点(台形補正)の座標構造体 [詳細]

Public 変数

Point topLeft
原稿左上座標 [詳細]
Point topRight
原稿右上座標 [詳細]
Point bottomLeft
原稿左下座標 [詳細]
Point bottomRight
原稿右下座標 [詳細]

説明

原稿領域4点(台形補正)の座標構造体

台形補正を行う原稿領域の4点(4隅)を扱います。

変数

Point IdrEngine.TrapeCoordinate.bottomLeft

原稿左下座標

Point IdrEngine.TrapeCoordinate.bottomRight

原稿右下座標

Point IdrEngine.TrapeCoordinate.topLeft

原稿左上座標

Point IdrEngine.TrapeCoordinate.topRight

原稿右上座標


活字認識ライブラリー .NET APIリファレンス: 構造体 IdrEngine.TableLine

  • TableLine
Public 変数 | すべてのメンバ一覧
構造体 IdrEngine.TableLine

罫線情報を管理します。 [詳細]

Public 変数

int | color
線色 [詳細]
short | width
線幅 [詳細]
short | style
罫線属性 [詳細]

説明

罫線情報を管理します。

変数

int IdrEngine.TableLine.color

線色

short IdrEngine.TableLine.style

罫線属性

short IdrEngine.TableLine.width

線幅


活字認識ライブラリー .NET APIリファレンス: 構造体 IdrEngine.CellInfo

  • CellInfo
Public 変数 | すべてのメンバ一覧
構造体 IdrEngine.CellInfo

表セル領域についての情報を管理する。 [詳細]

Public 変数

int | color
セル背景色 [詳細]
short | hAlignment
セル内横方向の文字位置 [詳細]
short | vAlignment
セル内縦方向の文字位置 [詳細]
TableLine lineLeft
セル左の罫線情報 [詳細]
TableLine lineTop
セル上の罫線情報 [詳細]
TableLine lineRight
セル右の罫線情報 [詳細]
TableLine lineBottom
セル下の罫線情報 [詳細]

説明

表セル領域についての情報を管理する。

変数

int IdrEngine.CellInfo.color

セル背景色

short IdrEngine.CellInfo.hAlignment

セル内横方向の文字位置

TableLine IdrEngine.CellInfo.lineBottom

セル下の罫線情報

TableLine IdrEngine.CellInfo.lineLeft

セル左の罫線情報

TableLine IdrEngine.CellInfo.lineRight

セル右の罫線情報

TableLine IdrEngine.CellInfo.lineTop

セル上の罫線情報

short IdrEngine.CellInfo.vAlignment

セル内縦方向の文字位置


活字認識ライブラリー .NET APIリファレンス: クラス階層

クラス階層
この継承一覧はおおまかにはソートされていますが、完全にアルファベット順でソートされてはいません。
[detail level 1234]
o C IdrEngine.CellInfo | 表セル領域についての情報を管理する。
o C IdrEngine.CharCand | 候補文字情報構造体
o C IdrEngine.CSRect | 矩形情報構造体
o C IdrEngine.EngineFactory | OCRエンジンの管理クラス
o C Exception |
| \ C IdrEngine.IDRException | OCRエンジン内でのエラーを通知する。
o C IdrEngine.ICandInf | 文字認識によって得られる個々の文字についての情報を管理する。
o C IdrEngine.IEngine | 認識対象画像の管理・認識処理を行う。
o C IdrEngine.IIDRRect | 領域を指定する際に用いる矩形情報を管理する。
| \ C IdrEngine.IDRRect | 矩形情報管理クラス
| o C IdrEngine.Engine.Layout |
| | o C IdrEngine.Engine.LayoutHand |
| | o C IdrEngine.Engine.LayoutOther |
| | \ C IdrEngine.Engine.LayoutTable |
| o C IdrEngine.Engine.Layout |
| \ C IdrEngine.Engine.Layout.Region |
| \ C IdrEngine.Engine.Layout.RegionTbl |
o C IdrEngine.ILayout | 各レイアウトの情報を管理する。
| o C IdrEngine.Engine.Layout |
| \ C IdrEngine.Engine.Layout |
o C IdrEngine.ILayoutList | レイアウトのリストの管理を行う。
| \ C IdrEngine.Engine.LayoutList |
o C IdrEngine.IRegion | 認識領域についての情報を管理する。
| o C IdrEngine.Engine.Layout.Region |
| \ C IdrEngine.ICellRegion | 表認識領域についての情報を管理する。
| \ C IdrEngine.Engine.Layout.RegionTbl |
o C IdrEngine.Point | 4点検出(台形補正)の座標 構造体
o C IdrEngine.ProcMode | 動作モード 構造体
o C IdrEngine.TableLine | 罫線情報を管理します。
\ C IdrEngine.TrapeCoordinate | 原稿領域4点(台形補正)の座標構造体


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.Engine.Layout

  • Engine
  • Layout
構成 | Public メソッド | Protected 変数 | プロパティ | すべてのメンバ一覧
クラス IdrEngine.Engine.Layout
IdrEngine.Engine.Layoutに対する継承グラフ
IdrEngine.IDRRect IdrEngine.ILayout IdrEngine.IDRRect IdrEngine.ILayout IdrEngine.IIDRRect IdrEngine.IIDRRect IdrEngine.Engine.LayoutHand IdrEngine.Engine.LayoutOther IdrEngine.Engine.LayoutTable

構成

class | Region
class | RegionTbl

Public メソッド

Layout (ref IIDRRect rect, RegionType category, CharDirection direction)
Layout (ref IdrEngine.CSRect rect, RegionType category, CharDirection direction)
virtual void | Delete ()
対応するメモリーを解放する。 [詳細]
virtual int | NumOfCol (int row)
レイアウトの指定行の列数を取得する。 [詳細]
- Public メソッド inherited from IdrEngine.IDRRect
IDRRect (ref IdrEngine.CSRect rect)
IDRRect (ref IIDRRect rect)
IDRRect (int x0, int y0, int x2, int y2)
void | Set (ref IdrEngine.CSRect rect)
IdrEngine.CSRectにより表される矩形を設定する。 [詳細]

Protected 変数

int | m_nNumOfRow
int | m_nNumOfCol
RegionType | m_Category
CharDirection | m_Direction
int | m_Class
string | m_UserChar

プロパティ

int | NumOfRow [get]
virtual int | Class [get, set]
String | UserChar [get, set]
virtual IRegion | this[int row, int col] [get]
RegionType | Attribute [get]
CharDirection | Direction [get]
virtual String | strAttr [get]
- プロパティ inherited from IdrEngine.IDRRect
int | Width [get]
int | Height [get]
int | Left [get]
int | Top [get]
int | Right [get]
int | Bottom [get]
- プロパティ inherited from IdrEngine.IIDRRect
int | Width [get]
矩形の幅を取得する。 [詳細]
int | Height [get]
矩形の高さを取得する。 [詳細]
int | Left [get]
矩形の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
矩形の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
矩形の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
矩形の右下のY座標（矩形に含まれる）を取得する。 [詳細]
- プロパティ inherited from IdrEngine.ILayout
int | NumOfRow [get]
レイアウトに含まれる行数を取得する。 [詳細]
int | Class [get, set]
認識に使用された文字クラスを取得、または設定する。 [詳細]
String | UserChar [get, set]
認識に使用されたユーザー指定文字を取得、または設定する。 [詳細]
IRegion | this[int row, int col] [get]
行番号・列番号を指定して認識領域を取得する。 [詳細]
int | Width [get]
レイアウトの幅を取得する。 [詳細]
int | Height [get]
レイアウトの高さを取得する。 [詳細]
int | Left [get]
レイアウトの左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
レイアウトの左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
レイアウトの右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
レイアウトの右下のY座標（矩形に含まれる）を取得する。 [詳細]
RegionType | Attribute [get]
領域属性を取得する。 [詳細]
CharDirection | Direction [get]
レイアウトの文字方向を取得する。 [詳細]
String | strAttr [get]
領域属性を文字列で取得する。 [詳細]

メソッド

virtual void IdrEngine.Engine.Layout.Delete ( )
virtual

対応するメモリーを解放する。

不要になった後、OCRエンジンの解放を行う前に、必ずこのメソッドを使用しておく必要がある。

IdrEngine.ILayoutを実装しています。

IdrEngine.Engine.LayoutTableで再定義されています。

virtual int IdrEngine.Engine.Layout.NumOfCol ( int row)
virtual

レイアウトの指定行の列数を取得する。

引数
row 行番号
戻り値
レイアウトの指定行の列数（表以外の場合 1）

IdrEngine.ILayoutを実装しています。

IdrEngine.Engine.LayoutTableで再定義されています。

プロパティ

virtual int IdrEngine.Engine.Layout.Class
getset

認識対象の文字クラス

this[row,col]により認識領域を取得する前に設定しておく必要がある

参照
IdrEngine.CharClass


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.Engine.LayoutHand

  • Engine
  • LayoutHand
Public メソッド | プロパティ | すべてのメンバ一覧
クラス IdrEngine.Engine.LayoutHand
IdrEngine.Engine.LayoutHandに対する継承グラフ
IdrEngine.Engine.Layout IdrEngine.IDRRect IdrEngine.ILayout IdrEngine.IDRRect IdrEngine.ILayout IdrEngine.IIDRRect IdrEngine.IIDRRect

Public メソッド

LayoutHand (ref IIDRRect rect, RegionType category, CharDirection direction)
LayoutHand (ref IdrEngine.CSRect rect, RegionType category, CharDirection direction)
- Public メソッド inherited from IdrEngine.Engine.Layout
Layout (ref IIDRRect rect, RegionType category, CharDirection direction)
Layout (ref IdrEngine.CSRect rect, RegionType category, CharDirection direction)
virtual void | Delete ()
対応するメモリーを解放する。 [詳細]
virtual int | NumOfCol (int row)
レイアウトの指定行の列数を取得する。 [詳細]
- Public メソッド inherited from IdrEngine.IDRRect
IDRRect (ref IdrEngine.CSRect rect)
IDRRect (ref IIDRRect rect)
IDRRect (int x0, int y0, int x2, int y2)
void | Set (ref IdrEngine.CSRect rect)
IdrEngine.CSRectにより表される矩形を設定する。 [詳細]

プロパティ

override int | Class [get, set]
override IRegion | this[int row, int col] [get]
override String | strAttr [get]
- プロパティ inherited from IdrEngine.Engine.Layout
int | NumOfRow [get]
virtual int | Class [get, set]
String | UserChar [get, set]
virtual IRegion | this[int row, int col] [get]
RegionType | Attribute [get]
CharDirection | Direction [get]
virtual String | strAttr [get]
- プロパティ inherited from IdrEngine.IDRRect
int | Width [get]
int | Height [get]
int | Left [get]
int | Top [get]
int | Right [get]
int | Bottom [get]
- プロパティ inherited from IdrEngine.IIDRRect
int | Width [get]
矩形の幅を取得する。 [詳細]
int | Height [get]
矩形の高さを取得する。 [詳細]
int | Left [get]
矩形の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
矩形の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
矩形の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
矩形の右下のY座標（矩形に含まれる）を取得する。 [詳細]
- プロパティ inherited from IdrEngine.ILayout
int | NumOfRow [get]
レイアウトに含まれる行数を取得する。 [詳細]
int | Class [get, set]
認識に使用された文字クラスを取得、または設定する。 [詳細]
String | UserChar [get, set]
認識に使用されたユーザー指定文字を取得、または設定する。 [詳細]
IRegion | this[int row, int col] [get]
行番号・列番号を指定して認識領域を取得する。 [詳細]
int | Width [get]
レイアウトの幅を取得する。 [詳細]
int | Height [get]
レイアウトの高さを取得する。 [詳細]
int | Left [get]
レイアウトの左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
レイアウトの左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
レイアウトの右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
レイアウトの右下のY座標（矩形に含まれる）を取得する。 [詳細]
RegionType | Attribute [get]
領域属性を取得する。 [詳細]
CharDirection | Direction [get]
レイアウトの文字方向を取得する。 [詳細]
String | strAttr [get]
領域属性を文字列で取得する。 [詳細]

Additional Inherited Members

- Protected 変数 inherited from IdrEngine.Engine.Layout
int | m_nNumOfRow
int | m_nNumOfCol
RegionType | m_Category
CharDirection | m_Direction
int | m_Class
string | m_UserChar


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.Engine.LayoutOther

  • Engine
  • LayoutOther
Public メソッド | プロパティ | すべてのメンバ一覧
クラス IdrEngine.Engine.LayoutOther
IdrEngine.Engine.LayoutOtherに対する継承グラフ
IdrEngine.Engine.Layout IdrEngine.IDRRect IdrEngine.ILayout IdrEngine.IDRRect IdrEngine.ILayout IdrEngine.IIDRRect IdrEngine.IIDRRect

Public メソッド

LayoutOther (ref IIDRRect rect, RegionType category, CharDirection direction)
LayoutOther (ref IdrEngine.CSRect rect, RegionType category, CharDirection direction)
- Public メソッド inherited from IdrEngine.Engine.Layout
Layout (ref IIDRRect rect, RegionType category, CharDirection direction)
Layout (ref IdrEngine.CSRect rect, RegionType category, CharDirection direction)
virtual void | Delete ()
対応するメモリーを解放する。 [詳細]
virtual int | NumOfCol (int row)
レイアウトの指定行の列数を取得する。 [詳細]
- Public メソッド inherited from IdrEngine.IDRRect
IDRRect (ref IdrEngine.CSRect rect)
IDRRect (ref IIDRRect rect)
IDRRect (int x0, int y0, int x2, int y2)
void | Set (ref IdrEngine.CSRect rect)
IdrEngine.CSRectにより表される矩形を設定する。 [詳細]

プロパティ

override String | strAttr [get]
- プロパティ inherited from IdrEngine.Engine.Layout
int | NumOfRow [get]
virtual int | Class [get, set]
String | UserChar [get, set]
virtual IRegion | this[int row, int col] [get]
RegionType | Attribute [get]
CharDirection | Direction [get]
virtual String | strAttr [get]
- プロパティ inherited from IdrEngine.IDRRect
int | Width [get]
int | Height [get]
int | Left [get]
int | Top [get]
int | Right [get]
int | Bottom [get]
- プロパティ inherited from IdrEngine.IIDRRect
int | Width [get]
矩形の幅を取得する。 [詳細]
int | Height [get]
矩形の高さを取得する。 [詳細]
int | Left [get]
矩形の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
矩形の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
矩形の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
矩形の右下のY座標（矩形に含まれる）を取得する。 [詳細]
- プロパティ inherited from IdrEngine.ILayout
int | NumOfRow [get]
レイアウトに含まれる行数を取得する。 [詳細]
int | Class [get, set]
認識に使用された文字クラスを取得、または設定する。 [詳細]
String | UserChar [get, set]
認識に使用されたユーザー指定文字を取得、または設定する。 [詳細]
IRegion | this[int row, int col] [get]
行番号・列番号を指定して認識領域を取得する。 [詳細]
int | Width [get]
レイアウトの幅を取得する。 [詳細]
int | Height [get]
レイアウトの高さを取得する。 [詳細]
int | Left [get]
レイアウトの左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
レイアウトの左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
レイアウトの右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
レイアウトの右下のY座標（矩形に含まれる）を取得する。 [詳細]
RegionType | Attribute [get]
領域属性を取得する。 [詳細]
CharDirection | Direction [get]
レイアウトの文字方向を取得する。 [詳細]
String | strAttr [get]
領域属性を文字列で取得する。 [詳細]

Additional Inherited Members

- Protected 変数 inherited from IdrEngine.Engine.Layout
int | m_nNumOfRow
int | m_nNumOfCol
RegionType | m_Category
CharDirection | m_Direction
int | m_Class
string | m_UserChar


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.Engine.LayoutTable

  • Engine
  • LayoutTable
Public メソッド | プロパティ | すべてのメンバ一覧
クラス IdrEngine.Engine.LayoutTable
IdrEngine.Engine.LayoutTableに対する継承グラフ
IdrEngine.Engine.Layout IdrEngine.IDRRect IdrEngine.ILayout IdrEngine.IDRRect IdrEngine.ILayout IdrEngine.IIDRRect IdrEngine.IIDRRect

Public メソッド

LayoutTable (ref IIDRRect rect, RegionType category, CharDirection direction)
LayoutTable (ref IdrEngine.CSRect rect, RegionType category, CharDirection direction)
override void | Delete ()
対応するメモリーを解放する。 [詳細]
override int | NumOfCol (int row)
レイアウトの指定行の列数を取得する。 [詳細]
- Public メソッド inherited from IdrEngine.Engine.Layout
Layout (ref IIDRRect rect, RegionType category, CharDirection direction)
Layout (ref IdrEngine.CSRect rect, RegionType category, CharDirection direction)
- Public メソッド inherited from IdrEngine.IDRRect
IDRRect (ref IdrEngine.CSRect rect)
IDRRect (ref IIDRRect rect)
IDRRect (int x0, int y0, int x2, int y2)
void | Set (ref IdrEngine.CSRect rect)
IdrEngine.CSRectにより表される矩形を設定する。 [詳細]

プロパティ

override IRegion | this[int row, int col] [get]
override String | strAttr [get]
- プロパティ inherited from IdrEngine.Engine.Layout
int | NumOfRow [get]
virtual int | Class [get, set]
String | UserChar [get, set]
virtual IRegion | this[int row, int col] [get]
RegionType | Attribute [get]
CharDirection | Direction [get]
virtual String | strAttr [get]
- プロパティ inherited from IdrEngine.IDRRect
int | Width [get]
int | Height [get]
int | Left [get]
int | Top [get]
int | Right [get]
int | Bottom [get]
- プロパティ inherited from IdrEngine.IIDRRect
int | Width [get]
矩形の幅を取得する。 [詳細]
int | Height [get]
矩形の高さを取得する。 [詳細]
int | Left [get]
矩形の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
矩形の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
矩形の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
矩形の右下のY座標（矩形に含まれる）を取得する。 [詳細]
- プロパティ inherited from IdrEngine.ILayout
int | NumOfRow [get]
レイアウトに含まれる行数を取得する。 [詳細]
int | Class [get, set]
認識に使用された文字クラスを取得、または設定する。 [詳細]
String | UserChar [get, set]
認識に使用されたユーザー指定文字を取得、または設定する。 [詳細]
IRegion | this[int row, int col] [get]
行番号・列番号を指定して認識領域を取得する。 [詳細]
int | Width [get]
レイアウトの幅を取得する。 [詳細]
int | Height [get]
レイアウトの高さを取得する。 [詳細]
int | Left [get]
レイアウトの左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
レイアウトの左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
レイアウトの右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
レイアウトの右下のY座標（矩形に含まれる）を取得する。 [詳細]
RegionType | Attribute [get]
領域属性を取得する。 [詳細]
CharDirection | Direction [get]
レイアウトの文字方向を取得する。 [詳細]
String | strAttr [get]
領域属性を文字列で取得する。 [詳細]

Additional Inherited Members

- Protected 変数 inherited from IdrEngine.Engine.Layout
int | m_nNumOfRow
int | m_nNumOfCol
RegionType | m_Category
CharDirection | m_Direction
int | m_Class
string | m_UserChar

メソッド

override void IdrEngine.Engine.LayoutTable.Delete ( )
virtual

対応するメモリーを解放する。

不要になった後、OCRエンジンの解放を行う前に、必ずこのメソッドを使用しておく必要がある。

IdrEngine.Engine.Layoutを再定義しています。

override int IdrEngine.Engine.LayoutTable.NumOfCol ( int row)
virtual

レイアウトの指定行の列数を取得する。

引数
row 行番号
戻り値
レイアウトの指定行の列数（表以外の場合 1）

IdrEngine.Engine.Layoutを再定義しています。


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.Engine.Layout.Region

  • Engine
  • Layout
  • Region
構成 | Public メソッド | Protected メソッド | Protected 変数 | プロパティ | すべてのメンバ一覧
クラス IdrEngine.Engine.Layout.Region
IdrEngine.Engine.Layout.Regionに対する継承グラフ
IdrEngine.IDRRect IdrEngine.IRegion IdrEngine.IIDRRect IdrEngine.Engine.Layout.RegionTbl

Public メソッド

Region (ulong recog, IIDRRect rect, CharDirection direction, int cls, ref string uc)
Region (ulong recog, IIDRRect rect, CharDirection direction, int cls, ref string uc, int i, int j)
virtual void | Delete ()
対応するメモリーを解放する。 [詳細]
- Public メソッド inherited from IdrEngine.IDRRect
IDRRect (ref IdrEngine.CSRect rect)
IDRRect (ref IIDRRect rect)
IDRRect (int x0, int y0, int x2, int y2)
void | Set (ref IdrEngine.CSRect rect)
IdrEngine.CSRectにより表される矩形を設定する。 [詳細]

Protected メソッド

void RecogCand ()

Protected 変数

ulong hRecog

プロパティ

int | Row [get]
int | Col [get]
int | Class [get]
String | UserChar [get]
ICandInf | CandTop [get]
String | StrCand [get]
new 領域内の認識結果文字列を取得します。 [詳細]
- プロパティ inherited from IdrEngine.IDRRect
int | Width [get]
int | Height [get]
int | Left [get]
int | Top [get]
int | Right [get]
int | Bottom [get]
- プロパティ inherited from IdrEngine.IIDRRect
int | Width [get]
矩形の幅を取得する。 [詳細]
int | Height [get]
矩形の高さを取得する。 [詳細]
int | Left [get]
矩形の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
矩形の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
矩形の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
矩形の右下のY座標（矩形に含まれる）を取得する。 [詳細]
- プロパティ inherited from IdrEngine.IRegion
int | Row [get]
表内の自分の行番号を取得する。 [詳細]
int | Col [get]
表内の自分の列番号を取得する。 [詳細]
int | Class [get]
認識に使用された文字クラスを取得する。 [詳細]
String | UserChar [get]
認識に使用されたユーザー指定文字を取得する。 [詳細]
int | Width [get]
認識領域の幅を取得する。 [詳細]
int | Height [get]
認識領域の高さを取得する。 [詳細]
int | Left [get]
認識領域の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
認識領域の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
認識領域の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
認識領域の右下のY座標（矩形に含まれる）を取得する。 [詳細]
ICandInf | CandTop [get]
認識領域の認識結果から、最初の文字についての情報を取得する。 [詳細]
String | StrCand [get]
認識領域の認識結果文字列を取得する。 [詳細]

メソッド

virtual void IdrEngine.Engine.Layout.Region.Delete ( )
virtual

対応するメモリーを解放する。

不要になった後、OCRエンジンの解放を行う前に、必ずこのメソッドを使用しておく必要がある。

IdrEngine.IRegionを実装しています。

IdrEngine.Engine.Layout.RegionTblで再定義されています。

プロパティ

int IdrEngine.Engine.Layout.Region.Class
get

認識対象の文字クラス

参照
IdrEngine.CharClass
String IdrEngine.Engine.Layout.Region.StrCand
get

new 領域内の認識結果文字列を取得します。

<return>認識結果文字列</return>


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.Engine.Layout.RegionTbl

  • Engine
  • Layout
  • RegionTbl
Public メソッド | プロパティ | すべてのメンバ一覧
クラス IdrEngine.Engine.Layout.RegionTbl
IdrEngine.Engine.Layout.RegionTblに対する継承グラフ
IdrEngine.Engine.Layout.Region IdrEngine.ICellRegion IdrEngine.IDRRect IdrEngine.IRegion IdrEngine.IRegion IdrEngine.IIDRRect

Public メソッド

RegionTbl (ulong recog, IDRRect rect, CharDirection direction, int cls, ref string uc)
RegionTbl (ulong recog, IDRRect rect, CharDirection direction, int cls, ref string uc, int i, int j, CellInfo cell)
override void | Delete ()
対応するメモリーを解放する。 [詳細]
- Public メソッド inherited from IdrEngine.Engine.Layout.Region
Region (ulong recog, IIDRRect rect, CharDirection direction, int cls, ref string uc)
Region (ulong recog, IIDRRect rect, CharDirection direction, int cls, ref string uc, int i, int j)
- Public メソッド inherited from IdrEngine.IDRRect
IDRRect (ref IdrEngine.CSRect rect)
IDRRect (ref IIDRRect rect)
IDRRect (int x0, int y0, int x2, int y2)
void | Set (ref IdrEngine.CSRect rect)
IdrEngine.CSRectにより表される矩形を設定する。 [詳細]

プロパティ

CellInfo | Cell [get]
セル情報を取得します。 [詳細]
- プロパティ inherited from IdrEngine.Engine.Layout.Region
int | Row [get]
int | Col [get]
int | Class [get]
String | UserChar [get]
ICandInf | CandTop [get]
String | StrCand [get]
new 領域内の認識結果文字列を取得します。 [詳細]
- プロパティ inherited from IdrEngine.IDRRect
int | Width [get]
int | Height [get]
int | Left [get]
int | Top [get]
int | Right [get]
int | Bottom [get]
- プロパティ inherited from IdrEngine.IIDRRect
int | Width [get]
矩形の幅を取得する。 [詳細]
int | Height [get]
矩形の高さを取得する。 [詳細]
int | Left [get]
矩形の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
矩形の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
矩形の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
矩形の右下のY座標（矩形に含まれる）を取得する。 [詳細]
- プロパティ inherited from IdrEngine.IRegion
int | Row [get]
表内の自分の行番号を取得する。 [詳細]
int | Col [get]
表内の自分の列番号を取得する。 [詳細]
int | Class [get]
認識に使用された文字クラスを取得する。 [詳細]
String | UserChar [get]
認識に使用されたユーザー指定文字を取得する。 [詳細]
int | Width [get]
認識領域の幅を取得する。 [詳細]
int | Height [get]
認識領域の高さを取得する。 [詳細]
int | Left [get]
認識領域の左上のX座標（矩形に含まれる）を取得する。 [詳細]
int | Top [get]
認識領域の左上のY座標（矩形に含まれる）を取得する。 [詳細]
int | Right [get]
認識領域の右下のX座標（矩形に含まれる）を取得する。 [詳細]
int | Bottom [get]
認識領域の右下のY座標（矩形に含まれる）を取得する。 [詳細]
ICandInf | CandTop [get]
認識領域の認識結果から、最初の文字についての情報を取得する。 [詳細]
String | StrCand [get]
認識領域の認識結果文字列を取得する。 [詳細]
- プロパティ inherited from IdrEngine.ICellRegion
CellInfo | Cell [get]
表のセル情報を取得する。 [詳細]

Additional Inherited Members

- Protected メソッド inherited from IdrEngine.Engine.Layout.Region
void | RecogCand ()
- Protected 変数 inherited from IdrEngine.Engine.Layout.Region
ulong | hRecog

メソッド

override void IdrEngine.Engine.Layout.RegionTbl.Delete ( )
virtual

対応するメモリーを解放する。

不要になった後、OCRエンジンの解放を行う前に、必ずこのメソッドを使用しておく必要がある。

IdrEngine.Engine.Layout.Regionを再定義しています。

プロパティ

CellInfo IdrEngine.Engine.Layout.RegionTbl.Cell
get

セル情報を取得します。

<return>セル情報</return>


活字認識ライブラリー .NET APIリファレンス: クラス IdrEngine.Engine.LayoutList

  • Engine
  • LayoutList
Public メソッド | プロパティ | すべてのメンバ一覧
クラス IdrEngine.Engine.LayoutList
IdrEngine.Engine.LayoutListに対する継承グラフ
IdrEngine.ILayoutList

Public メソッド

void | Clear ()
void | Add (ILayout lay)

プロパティ

ILayout | this[int idx] [get]
int | Count [get]
- プロパティ inherited from IdrEngine.ILayoutList
ILayout | this[int idx] [get]
指定番目のレイアウトを取得する。 [詳細]
int | Count [get]
レイアウト数を取得します。 [詳細]


活字認識ライブラリー .NET APIリファレンス: 構成メンバ

  • 全て
  • 関数
  • 変数
  • プロパティ
  • a
  • b
  • c
  • d
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
これはクラスメンバの一覧で、それぞれの説明へリンクしています。

- a -

  • Attribute : IdrEngine.ILayout
  • AutoRotate() : IdrEngine.IEngine
  • AutoSkew() : IdrEngine.IEngine

- b -

  • Bottom : IdrEngine.IIDRRect , IdrEngine.IRegion , IdrEngine.ILayout
  • bottomLeft : IdrEngine.TrapeCoordinate
  • bottomRight : IdrEngine.TrapeCoordinate

- c -

  • CancelLine : IdrEngine.IEngine
  • CandTop : IdrEngine.IRegion
  • Cell : IdrEngine.Engine.Layout.RegionTbl , IdrEngine.ICellRegion
  • Class : IdrEngine.Engine.Layout.Region , IdrEngine.IRegion , IdrEngine.ILayout , IdrEngine.Engine.Layout
  • code : IdrEngine.CharCand
  • Col : IdrEngine.IRegion
  • Color : IdrEngine.ICandInf
  • color : IdrEngine.TableLine , IdrEngine.CellInfo
  • Count : IdrEngine.ILayoutList
  • CreateLayout() : IdrEngine.IEngine

- d -

  • DefaultProcMode : IdrEngine.EngineFactory
  • Delete() : IdrEngine.IRegion , IdrEngine.Engine.Layout , IdrEngine.Engine.Layout.RegionTbl , IdrEngine.Engine.Layout.Region , IdrEngine.Engine.LayoutTable , IdrEngine.ILayout
  • Despeckle() : IdrEngine.IEngine
  • Direction : IdrEngine.ILayout

- g -

  • GetEngine() : IdrEngine.EngineFactory

- h -

  • hAlignment : IdrEngine.CellInfo
  • Hand : IdrEngine.EngineFactory
  • Height : IdrEngine.ILayout , IdrEngine.IRegion , IdrEngine.IIDRRect
  • height : IdrEngine.CSRect

- i -

  • IDRException() : IdrEngine.IDRException
  • InvalidLicense() : IdrEngine.IDRException
  • IsItalic : IdrEngine.ICandInf
  • IsKakutei : IdrEngine.ICandInf
  • IsWideChar : IdrEngine.ICandInf
  • Italic : IdrEngine.IEngine

- l -

  • langProcMode : IdrEngine.ProcMode
  • Language : IdrEngine.EngineFactory
  • Left : IdrEngine.IRegion , IdrEngine.ILayout , IdrEngine.IIDRRect
  • left : IdrEngine.CSRect
  • lineBottom : IdrEngine.CellInfo
  • lineLeft : IdrEngine.CellInfo
  • lineRight : IdrEngine.CellInfo
  • lineTop : IdrEngine.CellInfo
  • LowResolution : IdrEngine.IEngine

- m -

  • ManualRoate() : IdrEngine.IEngine
  • ManualRotate() : IdrEngine.IEngine
  • ManualSkew() : IdrEngine.IEngine

- n -

  • Next : IdrEngine.ICandInf
  • No : IdrEngine.IDRException
  • NumOfCol() : IdrEngine.Engine.LayoutTable , IdrEngine.Engine.Layout , IdrEngine.ILayout
  • NumOfRow : IdrEngine.ILayout

- p -

  • PatternDic : IdrEngine.IEngine
  • PostDic : IdrEngine.IEngine
  • ProcMode : IdrEngine.EngineFactory

- r -

  • RecogLayout() : IdrEngine.IEngine
  • Rect : IdrEngine.IEngine , IdrEngine.ICandInf
  • Release() : IdrEngine.IEngine
  • Right : IdrEngine.IRegion , IdrEngine.ILayout , IdrEngine.IIDRRect
  • Row : IdrEngine.IRegion
  • Ruby : IdrEngine.IEngine

- s -

  • SaveImage() : IdrEngine.IEngine
  • secondRecog : IdrEngine.ProcMode
  • Set() : IdrEngine.IIDRRect , IdrEngine.IDRRect
  • SetBmp() : IdrEngine.IEngine
  • Size : IdrEngine.ICandInf
  • sizeImage : IdrEngine.ProcMode
  • SpeedMode : IdrEngine.IEngine
  • strAttr : IdrEngine.ILayout
  • StrCand : IdrEngine.IRegion , IdrEngine.Engine.Layout.Region
  • style : IdrEngine.TableLine

- t -

  • this[int idx] : IdrEngine.ICandInf , IdrEngine.ILayoutList
  • this[int row, int col] : IdrEngine.ILayout
  • top : IdrEngine.CSRect
  • Top : IdrEngine.IIDRRect , IdrEngine.ILayout , IdrEngine.IRegion
  • topLeft : IdrEngine.TrapeCoordinate
  • topRight : IdrEngine.TrapeCoordinate
  • TrapezoidCoodinate() : IdrEngine.IEngine
  • TrapezoidImage() : IdrEngine.IEngine

- u -

  • UserChar : IdrEngine.IRegion , IdrEngine.ILayout

- v -

  • vAlignment : IdrEngine.CellInfo
  • value : IdrEngine.CharCand

- w -

  • Width : IdrEngine.IIDRRect
  • width : IdrEngine.TableLine , IdrEngine.CSRect
  • Width : IdrEngine.ILayout , IdrEngine.IRegion


活字認識ライブラリー .NET APIリファレンス: 構成メンバ - 関数

  • 全て
  • 関数
  • 変数
  • プロパティ
  • a
  • c
  • d
  • g
  • i
  • m
  • n
  • r
  • s
  • t

- a -

  • AutoRotate() : IdrEngine.IEngine
  • AutoSkew() : IdrEngine.IEngine

- c -

  • CreateLayout() : IdrEngine.IEngine

- d -

  • Delete() : IdrEngine.IRegion , IdrEngine.ILayout , IdrEngine.Engine.Layout.RegionTbl , IdrEngine.Engine.Layout.Region , IdrEngine.Engine.LayoutTable , IdrEngine.Engine.Layout
  • Despeckle() : IdrEngine.IEngine

- g -

  • GetEngine() : IdrEngine.EngineFactory

- i -

  • IDRException() : IdrEngine.IDRException
  • InvalidLicense() : IdrEngine.IDRException

- m -

  • ManualRoate() : IdrEngine.IEngine
  • ManualRotate() : IdrEngine.IEngine
  • ManualSkew() : IdrEngine.IEngine

- n -

  • NumOfCol() : IdrEngine.ILayout , IdrEngine.Engine.LayoutTable , IdrEngine.Engine.Layout

- r -

  • RecogLayout() : IdrEngine.IEngine
  • Release() : IdrEngine.IEngine

- s -

  • SaveImage() : IdrEngine.IEngine
  • Set() : IdrEngine.IDRRect , IdrEngine.IIDRRect
  • SetBmp() : IdrEngine.IEngine

- t -

  • TrapezoidCoodinate() : IdrEngine.IEngine
  • TrapezoidImage() : IdrEngine.IEngine


活字認識ライブラリー .NET APIリファレンス: 構成メンバ - 変数

  • 全て
  • 関数
  • 変数
  • プロパティ
  • bottomLeft : IdrEngine.TrapeCoordinate
  • bottomRight : IdrEngine.TrapeCoordinate
  • code : IdrEngine.CharCand
  • color : IdrEngine.CellInfo , IdrEngine.TableLine
  • hAlignment : IdrEngine.CellInfo
  • height : IdrEngine.CSRect
  • langProcMode : IdrEngine.ProcMode
  • left : IdrEngine.CSRect
  • lineBottom : IdrEngine.CellInfo
  • lineLeft : IdrEngine.CellInfo
  • lineRight : IdrEngine.CellInfo
  • lineTop : IdrEngine.CellInfo
  • secondRecog : IdrEngine.ProcMode
  • sizeImage : IdrEngine.ProcMode
  • style : IdrEngine.TableLine
  • top : IdrEngine.CSRect
  • topLeft : IdrEngine.TrapeCoordinate
  • topRight : IdrEngine.TrapeCoordinate
  • vAlignment : IdrEngine.CellInfo
  • value : IdrEngine.CharCand
  • width : IdrEngine.CSRect , IdrEngine.TableLine


活字認識ライブラリー .NET APIリファレンス: 構成メンバ - プロパティ

  • 全て
  • 関数
  • 変数
  • プロパティ
  • a
  • b
  • c
  • d
  • h
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- a -

  • Attribute : IdrEngine.ILayout

- b -

  • Bottom : IdrEngine.IIDRRect , IdrEngine.ILayout , IdrEngine.IRegion

- c -

  • CancelLine : IdrEngine.IEngine
  • CandTop : IdrEngine.IRegion
  • Cell : IdrEngine.Engine.Layout.RegionTbl , IdrEngine.ICellRegion
  • Class : IdrEngine.Engine.Layout.Region , IdrEngine.Engine.Layout , IdrEngine.IRegion , IdrEngine.ILayout
  • Col : IdrEngine.IRegion
  • Color : IdrEngine.ICandInf
  • Count : IdrEngine.ILayoutList

- d -

  • DefaultProcMode : IdrEngine.EngineFactory
  • Direction : IdrEngine.ILayout

- h -

  • Hand : IdrEngine.EngineFactory
  • Height : IdrEngine.ILayout , IdrEngine.IRegion , IdrEngine.IIDRRect

- i -

  • IsItalic : IdrEngine.ICandInf
  • IsKakutei : IdrEngine.ICandInf
  • IsWideChar : IdrEngine.ICandInf
  • Italic : IdrEngine.IEngine

- l -

  • Language : IdrEngine.EngineFactory
  • Left : IdrEngine.IIDRRect , IdrEngine.ILayout , IdrEngine.IRegion
  • LowResolution : IdrEngine.IEngine

- n -

  • Next : IdrEngine.ICandInf
  • No : IdrEngine.IDRException
  • NumOfRow : IdrEngine.ILayout

- p -

  • PatternDic : IdrEngine.IEngine
  • PostDic : IdrEngine.IEngine
  • ProcMode : IdrEngine.EngineFactory

- r -

  • Rect : IdrEngine.ICandInf , IdrEngine.IEngine
  • Right : IdrEngine.IRegion , IdrEngine.ILayout , IdrEngine.IIDRRect
  • Row : IdrEngine.IRegion
  • Ruby : IdrEngine.IEngine

- s -

  • Size : IdrEngine.ICandInf
  • SpeedMode : IdrEngine.IEngine
  • strAttr : IdrEngine.ILayout
  • StrCand : IdrEngine.IRegion , IdrEngine.Engine.Layout.Region

- t -

  • this[int idx] : IdrEngine.ICandInf , IdrEngine.ILayoutList
  • this[int row, int col] : IdrEngine.ILayout
  • Top : IdrEngine.IIDRRect , IdrEngine.IRegion , IdrEngine.ILayout

- u -

  • UserChar : IdrEngine.IRegion , IdrEngine.ILayout

- w -

  • Width : IdrEngine.IIDRRect , IdrEngine.ILayout , IdrEngine.IRegion


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • Engine
  • Layout
IdrEngine.Engine.Layout メンバ一覧

これは全メンバの一覧です。IdrEngine.Engine.Layout継承メンバも含んでいます。

Attribute (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Bottom (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Bottom IdrEngine.ILayout
Class IdrEngine.Engine.Layout
Delete() | IdrEngine.Engine.Layout | virtual
Direction (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Height (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Height IdrEngine.ILayout
IDRRect() (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IdrEngine.CSRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IIDRRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(int x0, int y0, int x2, int y2) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Layout(ref IIDRRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Layout(ref IdrEngine.CSRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Left (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Left IdrEngine.ILayout
m_Category (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_Class (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_Direction (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_nNumOfCol (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_nNumOfRow (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_UserChar (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
NumOfCol(int row) | IdrEngine.Engine.Layout | virtual
NumOfRow (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Right (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Right IdrEngine.ILayout
Set(ref IdrEngine.CSRect rect) | IdrEngine.IDRRect
strAttr (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
this[int row, int col] (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Top (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Top IdrEngine.ILayout
UserChar (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Width (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • Engine
  • Layout
  • Region
IdrEngine.Engine.Layout.Region メンバ一覧

これは全メンバの一覧です。IdrEngine.Engine.Layout.Region継承メンバも含んでいます。

Bottom (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Bottom IdrEngine.IRegion
CandTop (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Class IdrEngine.Engine.Layout.Region
Col (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Delete() | IdrEngine.Engine.Layout.Region | virtual
Height (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Height IdrEngine.IRegion
hRecog (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region | protected
IDRRect() (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IdrEngine.CSRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IIDRRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(int x0, int y0, int x2, int y2) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Left (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Left IdrEngine.IRegion
RecogCand() (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region | protected
Region(ulong recog, IIDRRect rect, CharDirection direction, int cls, ref string uc) (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Region(ulong recog, IIDRRect rect, CharDirection direction, int cls, ref string uc, int i, int j) (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Right (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Right IdrEngine.IRegion
Row (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Set(ref IdrEngine.CSRect rect) | IdrEngine.IDRRect
StrCand IdrEngine.Engine.Layout.Region
Top (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Top IdrEngine.IRegion
UserChar (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Width (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • Engine
  • Layout
  • RegionTbl
IdrEngine.Engine.Layout.RegionTbl メンバ一覧

これは全メンバの一覧です。IdrEngine.Engine.Layout.RegionTbl継承メンバも含んでいます。

Bottom (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Bottom IdrEngine.IRegion
CandTop (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Cell IdrEngine.Engine.Layout.RegionTbl
Class IdrEngine.Engine.Layout.Region
Col (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Delete() | IdrEngine.Engine.Layout.RegionTbl | virtual
Height (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Height IdrEngine.IRegion
hRecog (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region | protected
IDRRect() (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IdrEngine.CSRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IIDRRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(int x0, int y0, int x2, int y2) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Left (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Left IdrEngine.IRegion
RecogCand() (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region | protected
Region(ulong recog, IIDRRect rect, CharDirection direction, int cls, ref string uc) (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Region(ulong recog, IIDRRect rect, CharDirection direction, int cls, ref string uc, int i, int j) (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
RegionTbl(ulong recog, IDRRect rect, CharDirection direction, int cls, ref string uc) (次で定義されています。 IdrEngine.Engine.Layout.RegionTbl) | IdrEngine.Engine.Layout.RegionTbl
RegionTbl(ulong recog, IDRRect rect, CharDirection direction, int cls, ref string uc, int i, int j, CellInfo cell) (次で定義されています。 IdrEngine.Engine.Layout.RegionTbl) | IdrEngine.Engine.Layout.RegionTbl
Right (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Right IdrEngine.IRegion
Row (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Set(ref IdrEngine.CSRect rect) | IdrEngine.IDRRect
StrCand IdrEngine.Engine.Layout.Region
Top (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::IRegion.Top IdrEngine.IRegion
UserChar (次で定義されています。 IdrEngine.Engine.Layout.Region) | IdrEngine.Engine.Layout.Region
Width (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • Engine
  • LayoutHand
IdrEngine.Engine.LayoutHand メンバ一覧

これは全メンバの一覧です。IdrEngine.Engine.LayoutHand継承メンバも含んでいます。

Attribute (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Bottom (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Bottom IdrEngine.ILayout
Class (次で定義されています。 IdrEngine.Engine.LayoutHand) | IdrEngine.Engine.LayoutHand
Delete() | IdrEngine.Engine.Layout | virtual
Direction (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Height (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Height IdrEngine.ILayout
IDRRect() (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IdrEngine.CSRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IIDRRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(int x0, int y0, int x2, int y2) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Layout(ref IIDRRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Layout(ref IdrEngine.CSRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
LayoutHand(ref IIDRRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.LayoutHand) | IdrEngine.Engine.LayoutHand
LayoutHand(ref IdrEngine.CSRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.LayoutHand) | IdrEngine.Engine.LayoutHand
Left (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Left IdrEngine.ILayout
m_Category (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_Class (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_Direction (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_nNumOfCol (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_nNumOfRow (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_UserChar (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
NumOfCol(int row) | IdrEngine.Engine.Layout | virtual
NumOfRow (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Right (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Right IdrEngine.ILayout
Set(ref IdrEngine.CSRect rect) | IdrEngine.IDRRect
strAttr (次で定義されています。 IdrEngine.Engine.LayoutHand) | IdrEngine.Engine.LayoutHand
this[int row, int col] (次で定義されています。 IdrEngine.Engine.LayoutHand) | IdrEngine.Engine.LayoutHand
Top (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Top IdrEngine.ILayout
UserChar (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Width (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • Engine
  • LayoutList
IdrEngine.Engine.LayoutList メンバ一覧

これは全メンバの一覧です。IdrEngine.Engine.LayoutList継承メンバも含んでいます。

Add(ILayout lay) (次で定義されています。 IdrEngine.Engine.LayoutList) | IdrEngine.Engine.LayoutList
Clear() (次で定義されています。 IdrEngine.Engine.LayoutList) | IdrEngine.Engine.LayoutList
Count (次で定義されています。 IdrEngine.Engine.LayoutList) | IdrEngine.Engine.LayoutList
LayoutList() (次で定義されています。 IdrEngine.Engine.LayoutList) | IdrEngine.Engine.LayoutList
this[int idx] (次で定義されています。 IdrEngine.Engine.LayoutList) | IdrEngine.Engine.LayoutList


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • Engine
  • LayoutOther
IdrEngine.Engine.LayoutOther メンバ一覧

これは全メンバの一覧です。IdrEngine.Engine.LayoutOther継承メンバも含んでいます。

Attribute (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Bottom (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Bottom IdrEngine.ILayout
Class IdrEngine.Engine.Layout
Delete() | IdrEngine.Engine.Layout | virtual
Direction (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Height (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Height IdrEngine.ILayout
IDRRect() (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IdrEngine.CSRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IIDRRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(int x0, int y0, int x2, int y2) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Layout(ref IIDRRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Layout(ref IdrEngine.CSRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
LayoutOther(ref IIDRRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.LayoutOther) | IdrEngine.Engine.LayoutOther
LayoutOther(ref IdrEngine.CSRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.LayoutOther) | IdrEngine.Engine.LayoutOther
Left (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Left IdrEngine.ILayout
m_Category (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_Class (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_Direction (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_nNumOfCol (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_nNumOfRow (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_UserChar (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
NumOfCol(int row) | IdrEngine.Engine.Layout | virtual
NumOfRow (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Right (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Right IdrEngine.ILayout
Set(ref IdrEngine.CSRect rect) | IdrEngine.IDRRect
strAttr (次で定義されています。 IdrEngine.Engine.LayoutOther) | IdrEngine.Engine.LayoutOther
this[int row, int col] (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Top (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Top IdrEngine.ILayout
UserChar (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Width (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • Engine
  • LayoutTable
IdrEngine.Engine.LayoutTable メンバ一覧

これは全メンバの一覧です。IdrEngine.Engine.LayoutTable継承メンバも含んでいます。

Attribute (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Bottom (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Bottom IdrEngine.ILayout
Class IdrEngine.Engine.Layout
Delete() | IdrEngine.Engine.LayoutTable | virtual
Direction (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Height (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Height IdrEngine.ILayout
IDRRect() (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IdrEngine.CSRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IIDRRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(int x0, int y0, int x2, int y2) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Layout(ref IIDRRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Layout(ref IdrEngine.CSRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
LayoutTable(ref IIDRRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.LayoutTable) | IdrEngine.Engine.LayoutTable
LayoutTable(ref IdrEngine.CSRect rect, RegionType category, CharDirection direction) (次で定義されています。 IdrEngine.Engine.LayoutTable) | IdrEngine.Engine.LayoutTable
Left (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Left IdrEngine.ILayout
m_Category (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_Class (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_Direction (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_nNumOfCol (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_nNumOfRow (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
m_UserChar (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout | protected
NumOfCol(int row) | IdrEngine.Engine.LayoutTable | virtual
NumOfRow (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Right (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Right IdrEngine.ILayout
Set(ref IdrEngine.CSRect rect) | IdrEngine.IDRRect
strAttr (次で定義されています。 IdrEngine.Engine.LayoutTable) | IdrEngine.Engine.LayoutTable
this[int row, int col] (次で定義されています。 IdrEngine.Engine.LayoutTable) | IdrEngine.Engine.LayoutTable
Top (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IdrEngine::ILayout.Top IdrEngine.ILayout
UserChar (次で定義されています。 IdrEngine.Engine.Layout) | IdrEngine.Engine.Layout
Width (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • EngineFactory
IdrEngine.EngineFactory メンバ一覧

これは全メンバの一覧です。IdrEngine.EngineFactory継承メンバも含んでいます。

DefaultProcMode | IdrEngine.EngineFactory | static
GetEngine() | IdrEngine.EngineFactory | static
Hand | IdrEngine.EngineFactory | static
Language | IdrEngine.EngineFactory | static
ProcMode | IdrEngine.EngineFactory | static


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • IDRException
IdrEngine.IDRException メンバ一覧

これは全メンバの一覧です。IdrEngine.IDRException継承メンバも含んでいます。

IDRException(int i, string msg) | IdrEngine.IDRException
IDRException(ErrorCode i, string msg) | IdrEngine.IDRException
InvalidLicense() | IdrEngine.IDRException
No | IdrEngine.IDRException
ToString() (次で定義されています。 IdrEngine.IDRException) | IdrEngine.IDRException


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • IDRRect
IdrEngine.IDRRect メンバ一覧

これは全メンバの一覧です。IdrEngine.IDRRect継承メンバも含んでいます。

Bottom (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Height (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect() (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IdrEngine.CSRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(ref IIDRRect rect) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
IDRRect(int x0, int y0, int x2, int y2) (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Left (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Right (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Set(ref IdrEngine.CSRect rect) | IdrEngine.IDRRect
Top (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect
Width (次で定義されています。 IdrEngine.IDRRect) | IdrEngine.IDRRect


活字認識ライブラリー .NET APIリファレンス: 構成索引

構成索引
C | E | I | L | P | R | T
C
I
ILayout (IdrEngine) Engine.LayoutOther (IdrEngine) Engine.Layout.RegionTbl (IdrEngine)
ILayoutList (IdrEngine) Engine.LayoutTable (IdrEngine)
T
CellInfo (IdrEngine) ICandInf (IdrEngine) IRegion (IdrEngine)
P
CharCand (IdrEngine) ICellRegion (IdrEngine)
L
TableLine (IdrEngine)
CSRect (IdrEngine) IDRException (IdrEngine) Point (IdrEngine) TrapeCoordinate (IdrEngine)
E
IDRRect (IdrEngine) Engine.Layout (IdrEngine) ProcMode (IdrEngine)
IEngine (IdrEngine) Engine.LayoutHand (IdrEngine)
R


活字認識ライブラリー .NET APIリファレンス: IdrEngine ディレクトリリファレンス

IdrEngine ディレクトリリファレンス

ファイル

ファイル | AssemblyInfo.cs
ファイル | Engine.cs
ファイル | EngineFactory.cs
ファイル | IDRRect.cs
ファイル | IEngie.cs
ファイル | Layout.cs
ファイル | Ocrmng.cs
ファイル | Region.cs


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • ICandInf
IdrEngine.ICandInf メンバ一覧

これは全メンバの一覧です。IdrEngine.ICandInf継承メンバも含んでいます。

Color | IdrEngine.ICandInf
IsItalic | IdrEngine.ICandInf
IsKakutei | IdrEngine.ICandInf
IsWideChar | IdrEngine.ICandInf
Next | IdrEngine.ICandInf
Rect | IdrEngine.ICandInf
Size | IdrEngine.ICandInf
this[int idx] | IdrEngine.ICandInf


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • ICellRegion
IdrEngine.ICellRegion メンバ一覧

これは全メンバの一覧です。IdrEngine.ICellRegion継承メンバも含んでいます。

Bottom | IdrEngine.IRegion
CandTop | IdrEngine.IRegion
Cell | IdrEngine.ICellRegion
Class | IdrEngine.IRegion
Col | IdrEngine.IRegion
Delete() | IdrEngine.IRegion
Height | IdrEngine.IRegion
Left | IdrEngine.IRegion
Right | IdrEngine.IRegion
Row | IdrEngine.IRegion
StrCand | IdrEngine.IRegion
Top | IdrEngine.IRegion
UserChar | IdrEngine.IRegion
Width | IdrEngine.IRegion


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • IEngine
IdrEngine.IEngine メンバ一覧

これは全メンバの一覧です。IdrEngine.IEngine継承メンバも含んでいます。

AutoRotate() | IdrEngine.IEngine
AutoSkew() | IdrEngine.IEngine
CancelLine | IdrEngine.IEngine
CreateLayout(ref IIDRRect rect, CharDirection direction) | IdrEngine.IEngine
CreateLayout(ref IIDRRect rect, CharDirection direction, RegionType category) | IdrEngine.IEngine
Despeckle(IIDRRect rect, int dotSize) | IdrEngine.IEngine
Italic | IdrEngine.IEngine
LowResolution | IdrEngine.IEngine
ManualRoate(RotateDirection nDir) | IdrEngine.IEngine
ManualRotate(RotateDirection nDir) | IdrEngine.IEngine
ManualSkew(double dRad) | IdrEngine.IEngine
PatternDic | IdrEngine.IEngine
PostDic | IdrEngine.IEngine
RecogLayout(IIDRRect rect) | IdrEngine.IEngine
RecogLayout(IIDRRect rect, LayoutMode layoutmode) | IdrEngine.IEngine
Rect | IdrEngine.IEngine
Release() | IdrEngine.IEngine
Ruby | IdrEngine.IEngine
SaveImage(string strFile, ImageFileType nType) | IdrEngine.IEngine
SetBmp(IntPtr pBmp) | IdrEngine.IEngine
SetBmp(Bitmap bmp) | IdrEngine.IEngine
SetBmp(string strFile, int nPage) | IdrEngine.IEngine
SpeedMode | IdrEngine.IEngine
TrapezoidCoodinate() | IdrEngine.IEngine
TrapezoidImage(ref TrapeCoordinate trapeCoord, int width, int height) | IdrEngine.IEngine


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • IIDRRect
IdrEngine.IIDRRect メンバ一覧

これは全メンバの一覧です。IdrEngine.IIDRRect継承メンバも含んでいます。

Bottom IdrEngine.IIDRRect
Height IdrEngine.IIDRRect
Left IdrEngine.IIDRRect
Right IdrEngine.IIDRRect
Set(ref IdrEngine.CSRect rect) IdrEngine.IIDRRect


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • ILayout
IdrEngine.ILayout メンバ一覧

これは全メンバの一覧です。IdrEngine.ILayout継承メンバも含んでいます。

Attribute | IdrEngine.ILayout
Bottom | IdrEngine.ILayout
Class | IdrEngine.ILayout
Delete() | IdrEngine.ILayout
Direction | IdrEngine.ILayout
Height | IdrEngine.ILayout
Left | IdrEngine.ILayout
NumOfCol(int row) | IdrEngine.ILayout
NumOfRow | IdrEngine.ILayout
Right | IdrEngine.ILayout
strAttr | IdrEngine.ILayout
this[int row, int col] | IdrEngine.ILayout
Top | IdrEngine.ILayout
UserChar | IdrEngine.ILayout
Width | IdrEngine.ILayout


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • ILayoutList
IdrEngine.ILayoutList メンバ一覧

これは全メンバの一覧です。IdrEngine.ILayoutList継承メンバも含んでいます。


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • IRegion
IdrEngine.IRegion メンバ一覧

これは全メンバの一覧です。IdrEngine.IRegion継承メンバも含んでいます。

Bottom | IdrEngine.IRegion
CandTop | IdrEngine.IRegion
Class | IdrEngine.IRegion
Col | IdrEngine.IRegion
Delete() | IdrEngine.IRegion
Height | IdrEngine.IRegion
Left | IdrEngine.IRegion
Right | IdrEngine.IRegion
Row | IdrEngine.IRegion
StrCand | IdrEngine.IRegion
Top | IdrEngine.IRegion
UserChar | IdrEngine.IRegion
Width | IdrEngine.IRegion


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • CSRect
IdrEngine.CSRect メンバ一覧

これは全メンバの一覧です。IdrEngine.CSRect継承メンバも含んでいます。

height | IdrEngine.CSRect
left | IdrEngine.CSRect
top | IdrEngine.CSRect
width | IdrEngine.CSRect


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • CellInfo
IdrEngine.CellInfo メンバ一覧

これは全メンバの一覧です。IdrEngine.CellInfo継承メンバも含んでいます。

color | IdrEngine.CellInfo
hAlignment | IdrEngine.CellInfo
lineBottom | IdrEngine.CellInfo
lineLeft | IdrEngine.CellInfo
lineRight | IdrEngine.CellInfo
lineTop | IdrEngine.CellInfo
vAlignment | IdrEngine.CellInfo


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • CharCand
IdrEngine.CharCand メンバ一覧

これは全メンバの一覧です。IdrEngine.CharCand継承メンバも含んでいます。


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • Point
IdrEngine.Point メンバ一覧

これは全メンバの一覧です。IdrEngine.Point継承メンバも含んでいます。

x (次で定義されています。 IdrEngine.Point) | IdrEngine.Point
y (次で定義されています。 IdrEngine.Point) | IdrEngine.Point


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • ProcMode
IdrEngine.ProcMode メンバ一覧

これは全メンバの一覧です。IdrEngine.ProcMode継承メンバも含んでいます。


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • TableLine
IdrEngine.TableLine メンバ一覧

これは全メンバの一覧です。IdrEngine.TableLine継承メンバも含んでいます。


活字認識ライブラリー .NET APIリファレンス: メンバ一覧

  • TrapeCoordinate
IdrEngine.TrapeCoordinate メンバ一覧

これは全メンバの一覧です。IdrEngine.TrapeCoordinate継承メンバも含んでいます。

bottomLeft | IdrEngine.TrapeCoordinate
bottomRight | IdrEngine.TrapeCoordinate
topLeft | IdrEngine.TrapeCoordinate
topRight | IdrEngine.TrapeCoordinate