Pao.BarCode

NDoc で作成されたクラス ライブラリ

Pao.BarCode 名前空間

クラス

クラス | 説明
CheckDigit | 各種チェックデジットの算出を行うライブラリーです。
Code128 | Code128バーコードを生成するのに用いられるクラスです。
Code39 | Code39バーコードを生成するのに用いられるクラスです。
EAN128 | UCC/EAN128バーコードを生成するのに用いられるクラスです。
ITF | ITFバーコードを生成するのに用いられるクラスです。
JAN13 | JANコード(13桁)を生成するのに用いられるclassです。
JAN8 | JANコード(8桁)を生成するのに用いられるクラスです。
Matrix2of5 | Matrix 2 of 5 バーコードを生成するのに用いられるクラスです。
NEC2of5 | NEC 2 of 5 バーコードを生成するのに用いられるクラスです。
NW7 | Codabar/NW7バーコードを生成するのに用いられるクラスです。
QRCode | QRコードを生成するのに用いられるクラスです。
YubinCustomer | 郵便カスタマーバーコードを生成するのに用いられるクラスです。

インターフェイス

インターフェイス | 説明
IBarCode |


CheckDigit クラス

各種チェックデジットの算出を行うライブラリーです。

この型のすべてのメンバの一覧については、 CheckDigit メンバを参照してください。

System.Object
CheckDigit

public class CheckDigit

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

CheckDigit クラス | CheckDigit メンバ | Pao.BarCode 名前空間


CheckDigit Members

NDoc で作成されたクラス ライブラリ

CheckDigit メンバ

CheckDigit 概要

パブリック コンストラクタ

CheckDigit コンストラクタ コンストラクタ

参照

CheckDigit クラス | CheckDigit メンバ | Pao.BarCode 名前空間


CheckDigit コンストラクタ

コンストラクタ

public CheckDigit();

参照

CheckDigit クラス | Pao.BarCode 名前空間


CheckDigit メソッド

CheckDigit クラスのメソッドは以下のとおりです。CheckDigit クラスの完全なメンバ一覧については、 CheckDigit メンバ のトピックを参照してください。

パブリック メソッド

Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
Modulus103W1 | モジュラス103 ウエイト1 のチェックデジットの計算
Modulus103W1_EAN128 | モジュラス103 ウエイト1(UCC/EAN128用) のチェックデジットの計算
Modulus10W3 | モジュラス10 ウエイト3 のチェックデジットの計算
ToString (Object から継承されます) |

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

CheckDigit クラス | CheckDigit メンバ | Pao.BarCode 名前空間


CheckDigit.Modulus103W1 メソッド

モジュラス103 ウエイト1 のチェックデジットの計算

public int Modulus103W1(
string data
);

パラメータ

data
チェックデジットを除いた文字列

戻り値

チェックデジット

参照

CheckDigit クラス | Pao.BarCode 名前空間


CheckDigit.Modulus103W1_EAN128 メソッド

モジュラス103 ウエイト1(UCC/EAN128用) のチェックデジットの計算

public int Modulus103W1_EAN128(
string data
);

パラメータ

data
チェックデジットを除いた文字列

戻り値

チェックデジット

参照

CheckDigit クラス | Pao.BarCode 名前空間


CheckDigit.Modulus10W3 メソッド

モジュラス10 ウエイト3 のチェックデジットの計算

public string Modulus10W3(
string data
);

パラメータ

data
チェックデジットを除いた文字列

戻り値

チェックデジット

参照

CheckDigit クラス | Pao.BarCode 名前空間


Code128 クラス

Code128バーコードを生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 Code128 メンバを参照してください。

System.Object
Code128

public class Code128 : IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

Code128 クラス | Code128 メンバ | Pao.BarCode 名前空間


Code128 Members

NDoc で作成されたクラス ライブラリ

Code128 メンバ

Code128 概要

パブリック コンストラクタ

Code128 オーバーロード。 Code128 クラスの新しいインスタンスを初期化します。

参照

Code128 クラス | Code128 メンバ | Pao.BarCode 名前空間


Code128 コンストラクタ

コンストラクタ　Code128

オーバーロードの一覧

コンストラクタ　Code128

public Code128(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public Code128(string,ImageFormat);

参照

Code128 クラス | Pao.BarCode 名前空間


Code128 コンストラクタ (Graphics)

コンストラクタ　Code128

public Code128(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

Code128 クラス | Pao.BarCode 名前空間


Code128 コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public Code128(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

Code128 クラス | Pao.BarCode 名前空間


Code128 プロパティ

Code128 クラスのプロパティは以下のとおりです。Code128 クラスの完全なメンバ一覧については、 Code128 メンバ のトピックを参照してください。

パブリック プロパティ

ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
ShiroBarChousei | 描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
TextFont | 添字のフォントプロパティ
TextKintou | 描画位置設定(バーコード全体の幅に均等割付)プロパティ
TextWrite | TextWrite 添字の描画プロパティ

参照

Code128 クラス | Code128 メンバ | Pao.BarCode 名前空間


Code128.ImgDpi Property

NDoc で作成されたクラス ライブラリ

Code128.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

実装

IBarCode.ImgDpi

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

Code128.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

実装

IBarCode.ImgDrawUnit

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

Code128.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int KuroBarChousei {get; set;}

実装

IBarCode.KuroBarChousei

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.RotateAngle Property

NDoc で作成されたクラス ライブラリ

Code128.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

実装

IBarCode.RotateAngle

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

Code128.ShiroBarChousei プロパティ

描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 　　白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int ShiroBarChousei {get; set;}

実装

IBarCode.ShiroBarChousei

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.TextFont Property

NDoc で作成されたクラス ライブラリ

Code128.TextFont プロパティ

添字のフォントプロパティ

public System.Drawing.Font TextFont {get; set;}

実装

IBarCode.TextFont

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.TextKintou Property

NDoc で作成されたクラス ライブラリ

Code128.TextKintou プロパティ

描画位置設定(バーコード全体の幅に均等割付)プロパティ

public bool TextKintou {get; set;}

実装

IBarCode.TextKintou

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.TextWrite Property

NDoc で作成されたクラス ライブラリ

Code128.TextWrite プロパティ

TextWrite 添字の描画プロパティ

public bool TextWrite {get; set;}

実装

IBarCode.TextWrite

参照

Code128 クラス | Pao.BarCode 名前空間


Code128 メソッド

Code128 クラスのメソッドは以下のとおりです。Code128 クラスの完全なメンバ一覧については、 Code128 メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDelicate | オーバーロード。 バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

Code128 クラス | Code128 メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

Code128.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.Draw

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.Draw

参照

Code128 クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

Code128.DrawDelicate メソッド

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

オーバーロードの一覧

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(string,float,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,float,string);

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.DrawDelicate メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDelicate

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDelicate

参照

Code128 クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

Code128.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(string,float,float,float,float,string);

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDirect

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDirect

参照

Code128 クラス | Pao.BarCode 名前空間


Code128.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float width,
float height,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

Code128 クラス | Pao.BarCode 名前空間


Code39 クラス

Code39バーコードを生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 Code39 メンバを参照してください。

System.Object
Code39

public class Code39 : IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

Code39 クラス | Code39 メンバ | Pao.BarCode 名前空間


Code39 Members

NDoc で作成されたクラス ライブラリ

Code39 メンバ

Code39 概要

パブリック コンストラクタ

Code39 オーバーロード。 Code39 クラスの新しいインスタンスを初期化します。

参照

Code39 クラス | Code39 メンバ | Pao.BarCode 名前空間


Code39 コンストラクタ

コンストラクタ　Code39

オーバーロードの一覧

コンストラクタ　Code39

public Code39(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public Code39(string,ImageFormat);

参照

Code39 クラス | Pao.BarCode 名前空間


Code39 コンストラクタ (Graphics)

コンストラクタ　Code39

public Code39(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

Code39 クラス | Pao.BarCode 名前空間


Code39 コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public Code39(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

Code39 クラス | Pao.BarCode 名前空間


Code39 プロパティ

Code39 クラスのプロパティは以下のとおりです。Code39 クラスの完全なメンバ一覧については、 Code39 メンバ のトピックを参照してください。

パブリック プロパティ

DispStartStopCode | スタート／ストップコードの描画プロパティ
ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
ShiroBarChousei | 描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
TextFont | 添字のフォントプロパティ
TextKintou | 描画位置設定(バーコード全体の幅に均等割付)プロパティ
TextWrite | TextWrite 添字の描画プロパティ

参照

Code39 クラス | Code39 メンバ | Pao.BarCode 名前空間


Code39.DispStartStopCode Property

NDoc で作成されたクラス ライブラリ

Code39.DispStartStopCode プロパティ

スタート／ストップコードの描画プロパティ

public bool DispStartStopCode {get; set;}

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.ImgDpi Property

NDoc で作成されたクラス ライブラリ

Code39.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

実装

IBarCode.ImgDpi

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

Code39.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

実装

IBarCode.ImgDrawUnit

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

Code39.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int KuroBarChousei {get; set;}

実装

IBarCode.KuroBarChousei

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.RotateAngle Property

NDoc で作成されたクラス ライブラリ

Code39.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

実装

IBarCode.RotateAngle

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

Code39.ShiroBarChousei プロパティ

描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 　　白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int ShiroBarChousei {get; set;}

実装

IBarCode.ShiroBarChousei

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.TextFont Property

NDoc で作成されたクラス ライブラリ

Code39.TextFont プロパティ

添字のフォントプロパティ

public System.Drawing.Font TextFont {get; set;}

実装

IBarCode.TextFont

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.TextKintou Property

NDoc で作成されたクラス ライブラリ

Code39.TextKintou プロパティ

描画位置設定(バーコード全体の幅に均等割付)プロパティ

public bool TextKintou {get; set;}

実装

IBarCode.TextKintou

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.TextWrite Property

NDoc で作成されたクラス ライブラリ

Code39.TextWrite プロパティ

TextWrite 添字の描画プロパティ

public bool TextWrite {get; set;}

実装

IBarCode.TextWrite

参照

Code39 クラス | Pao.BarCode 名前空間


Code39 メソッド

Code39 クラスのメソッドは以下のとおりです。Code39 クラスの完全なメンバ一覧については、 Code39 メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDelicate | オーバーロード。 バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

Code39 クラス | Code39 メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

Code39.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.Draw

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.Draw

参照

Code39 クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

Code39.DrawDelicate メソッド

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

オーバーロードの一覧

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(string,float,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,float,string);

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.DrawDelicate メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDelicate

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDelicate

参照

Code39 クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

Code39.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(string,float,float,float,float,string);

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDirect

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDirect

参照

Code39 クラス | Pao.BarCode 名前空間


Code39.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float width,
float height,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

Code39 クラス | Pao.BarCode 名前空間


EAN128 クラス

UCC/EAN128バーコードを生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 EAN128 メンバを参照してください。

System.Object
EAN128

public class EAN128 : IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

EAN128 クラス | EAN128 メンバ | Pao.BarCode 名前空間


EAN128 Members

NDoc で作成されたクラス ライブラリ

EAN128 メンバ

EAN128 概要

パブリック コンストラクタ

EAN128 オーバーロード。 EAN128 クラスの新しいインスタンスを初期化します。

参照

EAN128 クラス | EAN128 メンバ | Pao.BarCode 名前空間


EAN128 コンストラクタ

コンストラクタ　EAN128

オーバーロードの一覧

コンストラクタ　EAN128

public EAN128(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public EAN128(string,ImageFormat);

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128 コンストラクタ (Graphics)

コンストラクタ　EAN128

public EAN128(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128 コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public EAN128(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128 プロパティ

EAN128 クラスのプロパティは以下のとおりです。EAN128 クラスの完全なメンバ一覧については、 EAN128 メンバ のトピックを参照してください。

パブリック プロパティ

ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
ShiroBarChousei | 描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
TextFont | 添字のフォントプロパティ
TextKintou | 描画位置設定(バーコード全体の幅に均等割付)プロパティ
TextWrite | TextWrite 添字の描画プロパティ

参照

EAN128 クラス | EAN128 メンバ | Pao.BarCode 名前空間


EAN128.ImgDpi Property

NDoc で作成されたクラス ライブラリ

EAN128.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

実装

IBarCode.ImgDpi

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

EAN128.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

実装

IBarCode.ImgDrawUnit

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

EAN128.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int KuroBarChousei {get; set;}

実装

IBarCode.KuroBarChousei

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.RotateAngle Property

NDoc で作成されたクラス ライブラリ

EAN128.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

実装

IBarCode.RotateAngle

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

EAN128.ShiroBarChousei プロパティ

描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 　　白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int ShiroBarChousei {get; set;}

実装

IBarCode.ShiroBarChousei

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.TextFont Property

NDoc で作成されたクラス ライブラリ

EAN128.TextFont プロパティ

添字のフォントプロパティ

public System.Drawing.Font TextFont {get; set;}

実装

IBarCode.TextFont

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.TextKintou Property

NDoc で作成されたクラス ライブラリ

EAN128.TextKintou プロパティ

描画位置設定(バーコード全体の幅に均等割付)プロパティ

public bool TextKintou {get; set;}

実装

IBarCode.TextKintou

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.TextWrite Property

NDoc で作成されたクラス ライブラリ

EAN128.TextWrite プロパティ

TextWrite 添字の描画プロパティ

public bool TextWrite {get; set;}

実装

IBarCode.TextWrite

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128 メソッド

EAN128 クラスのメソッドは以下のとおりです。EAN128 クラスの完全なメンバ一覧については、 EAN128 メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawConvenience | オーバーロード。 バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のEAN128を描画します。 幅はプリンタのDPIから自動的に算出します。 幅指定より速度精度とも良い。
DrawDelicate | オーバーロード。 バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

EAN128 クラス | EAN128 メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

EAN128.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.Draw

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.Draw

参照

EAN128 クラス | Pao.BarCode 名前空間


DrawConvenience メソッド

NDoc で作成されたクラス ライブラリ

EAN128.DrawConvenience メソッド

バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のEAN128を描画します。 幅はプリンタのDPIから自動的に算出します。 幅指定より速度精度とも良い。

オーバーロードの一覧

バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のEAN128を描画します。 幅はプリンタのDPIから自動的に算出します。 幅指定より速度精度とも良い。

public void DrawConvenience(string,float,float,float);

バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のGS1-128を描画します。 バーコード幅をパラメータ指定できるので、バーコードの微調整ができますが、 パラメータで幅指定しない方が、速度・精度は上です。

public void DrawConvenience(string,float,float,float,float);

バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のEAN128を描画します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。 バーコード幅をパラメータ指定できるので、バーコードの微調整ができますが、 パラメータで幅指定しない方が、速度・精度は上です。

public void DrawConvenience(string,float,float,float,float,string);

バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のEAN128を描画します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。 幅はプリンタのDPIから自動的に算出します。 幅指定より速度精度とも良い。

public void DrawConvenience(string,float,float,float,string);

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.DrawConvenience メソッド (String, Single, Single, Single)

バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のEAN128を描画します。 幅はプリンタのDPIから自動的に算出します。 幅指定より速度精度とも良い。

public void DrawConvenience(
string code,
float mmX,
float mmY,
float mmHeight
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
mmX
描画位置の始点(左上)のX座標をmmで指定
mmY
描画位置の始点(左上)のY座標をmmで指定
mmHeight
バーコードのバーの高さをmmで指定

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.DrawConvenience メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のGS1-128を描画します。 バーコード幅をパラメータ指定できるので、バーコードの微調整ができますが、 パラメータで幅指定しない方が、速度・精度は上です。

public void DrawConvenience(
string code,
float mmX,
float mmY,
float mmWidth,
float mmHeight
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
mmX
描画位置の始点(左上)のX座標をmmで指定
mmY
描画位置の始点(左上)のY座標をmmで指定
mmWidth
バーコードのバーの幅を指定
mmHeight
バーコードのバーの高さを指定

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.DrawConvenience メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のEAN128を描画します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。 バーコード幅をパラメータ指定できるので、バーコードの微調整ができますが、 パラメータで幅指定しない方が、速度・精度は上です。

public void DrawConvenience(
string code,
float mmX,
float mmY,
float mmWidth,
float mmHeight,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
mmX
描画位置の始点(左上)のX座標をmmで指定
mmY
描画位置の始点(左上)のY座標をmmで指定
mmWidth
バーコードのバーの幅を指定
mmHeight
バーコードのバーの高さをmmで指定
imgFilePath
画像ファイルパス

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.DrawConvenience メソッド (String, Single, Single, Single, String)

バーコードの描画を行います。コンビニエンスストアで行う標準料金代理収納用のEAN128を描画します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。 幅はプリンタのDPIから自動的に算出します。 幅指定より速度精度とも良い。

public void DrawConvenience(
string code,
float mmX,
float mmY,
float mmHeight,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
mmX
描画位置の始点(左上)のX座標をmmで指定
mmY
描画位置の始点(左上)のY座標をmmで指定
mmHeight
バーコードのバーの高さをmmで指定
imgFilePath
画像ファイルパス

参照

EAN128 クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

EAN128.DrawDelicate メソッド

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

オーバーロードの一覧

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(string,float,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,float,string);

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.DrawDelicate メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDelicate

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDelicate

参照

EAN128 クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

EAN128.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(string,float,float,float,float,string);

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDirect

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDirect

参照

EAN128 クラス | Pao.BarCode 名前空間


EAN128.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float width,
float height,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

EAN128 クラス | Pao.BarCode 名前空間


IBarCode インターフェイス

この型のすべてのメンバの一覧については、 IBarCode メンバを参照してください。

public interface IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

IBarCode インターフェイス | IBarCode メンバ | Pao.BarCode 名前空間


IBarCode Members

NDoc で作成されたクラス ライブラリ

IBarCode メンバ

IBarCode 概要

参照

IBarCode インターフェイス | IBarCode メンバ | Pao.BarCode 名前空間


IBarCode プロパティ

IBarCode クラスのプロパティは以下のとおりです。IBarCode クラスの完全なメンバ一覧については、 IBarCode メンバ のトピックを参照してください。

パブリック プロパティ

ImgDpi | Image DPI (use draw to image file)
ImgDrawUnit | Image Draw Unit (use draw to image file)
KuroBarChousei | number of dot for fine adjustment of black bars.(The defined value of dot is 0.)
RotateAngle | barcode angle
ShiroBarChousei | number of dot for fine adjustment of white bars.(The defined value of dot is 0.)
TextFont | the font used in writing text
TextKintou | drawing position drawing position (to fit a barcode to set width). true: Draw barcode within an overall width by equal spacing, false: Draw barcode at a bar meaning a code (default)
TextWrite | true if text will be generated along with the barcode

参照

IBarCode インターフェイス | IBarCode メンバ | Pao.BarCode 名前空間


IBarCode.ImgDpi Property

NDoc で作成されたクラス ライブラリ

IBarCode.ImgDpi プロパティ

Image DPI (use draw to image file)

float ImgDpi {get; set;}

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

IBarCode.ImgDrawUnit プロパティ

Image Draw Unit (use draw to image file)

System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

IBarCode.KuroBarChousei プロパティ

number of dot for fine adjustment of black bars.(The defined value of dot is 0.)

int KuroBarChousei {get; set;}

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.RotateAngle Property

NDoc で作成されたクラス ライブラリ

IBarCode.RotateAngle プロパティ

barcode angle

float RotateAngle {get; set;}

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

IBarCode.ShiroBarChousei プロパティ

number of dot for fine adjustment of white bars.(The defined value of dot is 0.)

int ShiroBarChousei {get; set;}

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.TextFont Property

NDoc で作成されたクラス ライブラリ

IBarCode.TextFont プロパティ

the font used in writing text

System.Drawing.Font TextFont {get; set;}

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.TextKintou Property

NDoc で作成されたクラス ライブラリ

IBarCode.TextKintou プロパティ

drawing position drawing position (to fit a barcode to set width). true: Draw barcode within an overall width by equal spacing, false: Draw barcode at a bar meaning a code (default)

bool TextKintou {get; set;}

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.TextWrite Property

NDoc で作成されたクラス ライブラリ

IBarCode.TextWrite プロパティ

true if text will be generated along with the barcode

bool TextWrite {get; set;}

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode メソッド

IBarCode クラスのメソッドは以下のとおりです。IBarCode クラスの完全なメンバ一覧については、 IBarCode メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 Draw a barcode draw barcode to image file, when specifying ImageFormat in constructor.
DrawDelicate | オーバーロード。 This is to draw a barcode. The difference from Draw methods is that this method is not used to set overall width but the thinnest bar width of barcode. draw barcode to image file, when specifying ImageFormat in constructor.
DrawDirect | オーバーロード。 Barcode is directly drawn within the width set in pixel. Accuracy and speed are better than Draw method, although the width cannot be fixed. draw barcode to image file, when specifying ImageFormat in constructor.

参照

IBarCode インターフェイス | IBarCode メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

IBarCode.Draw メソッド

Draw a barcode

オーバーロードの一覧

Draw a barcode

void Draw(string,float,float,float,float);

Draw a barcode draw barcode to image file, when specifying ImageFormat in constructor.

void Draw(string,float,float,float,float,string);

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.Draw メソッド (String, Single, Single, Single, Single)

Draw a barcode

void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
Set barcode codes by character strings.
x
Set x-coordinate of the drawing start point at upper left.
y
Set y-coordinate of the drawing start point at upper left.
width
Set overall width of the barcode.
height
Set height of the barcode.

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.Draw メソッド (String, Single, Single, Single, Single, String)

Draw a barcode draw barcode to image file, when specifying ImageFormat in constructor.

void Draw(
string code,
float x,
float y,
float width,
float height,
string imageFilePath
);

パラメータ

code
Set barcode codes by character strings.
x
Set x-coordinate of the drawing start point at upper left.
y
Set y-coordinate of the drawing start point at upper left.
width
Set overall width of the barcode.
height
Set height of the barcode.
imageFilePath
image file path

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

IBarCode.DrawDelicate メソッド

This is to draw a barcode. The difference from Draw methods is that this method is not used to set overall width but the thinnest bar width of barcode.

オーバーロードの一覧

This is to draw a barcode. The difference from Draw methods is that this method is not used to set overall width but the thinnest bar width of barcode.

void DrawDelicate(string,float,float,float,float);

This is to draw a barcode. The difference from Draw methods is that this method is not used to set overall width but the thinnest bar width of barcode. draw barcode to image file, when specifying ImageFormat in constructor.

void DrawDelicate(string,float,float,float,float,string);

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.DrawDelicate メソッド (String, Single, Single, Single, Single)

This is to draw a barcode. The difference from Draw methods is that this method is not used to set overall width but the thinnest bar width of barcode.

void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
Set barcode codes by character strings.
x
Set x-coordinate of the drawing start point at upper left.
y
Set y-coordinate of the drawing start point at upper left.
minLineWidth
Set the thinnest bar width of barcode to be drawn.
height
Set height of the barcode.

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

This is to draw a barcode. The difference from Draw methods is that this method is not used to set overall width but the thinnest bar width of barcode. draw barcode to image file, when specifying ImageFormat in constructor.

void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imageFilePath
);

パラメータ

code
Set barcode codes by character strings.
x
Set x-coordinate of the drawing start point at upper left.
y
Set y-coordinate of the drawing start point at upper left.
minLineWidth
Set the thinnest bar width of barcode to be drawn.
height
Set height of the barcode.
imageFilePath
image file path

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

IBarCode.DrawDirect メソッド

Barcode is directly drawn within the width set in pixel. Accuracy and speed are better than Draw method, although the width cannot be fixed.

オーバーロードの一覧

Barcode is directly drawn within the width set in pixel. Accuracy and speed are better than Draw method, although the width cannot be fixed.

void DrawDirect(string,float,float,float,float);

Barcode is directly drawn within the width set in pixel. Accuracy and speed are better than Draw method, although the width cannot be fixed. draw barcode to image file, when specifying ImageFormat in constructor.

void DrawDirect(string,float,float,float,float,string);

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.DrawDirect メソッド (String, Single, Single, Single, Single)

Barcode is directly drawn within the width set in pixel. Accuracy and speed are better than Draw method, although the width cannot be fixed.

void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
Set barcode codes by character strings.
x
Set x-coordinate of the drawing start point at upper left.
y
Set y-coordinate of the drawing start point at upper left.
width
Set overall width of the barcode.
height
Set height of the barcode.

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


IBarCode.DrawDirect メソッド (String, Single, Single, Single, Single, String)

Barcode is directly drawn within the width set in pixel. Accuracy and speed are better than Draw method, although the width cannot be fixed. draw barcode to image file, when specifying ImageFormat in constructor.

void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imageFilePath
);

パラメータ

code
Set barcode codes by character strings.
x
Set x-coordinate of the drawing start point at upper left.
y
Set y-coordinate of the drawing start point at upper left.
width
Set overall width of the barcode.
height
Set height of the barcode.
imageFilePath
image file path

参照

IBarCode インターフェイス | Pao.BarCode 名前空間


ITF クラス

ITFバーコードを生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 ITF メンバを参照してください。

System.Object
ITF

public class ITF : IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

ITF クラス | ITF メンバ | Pao.BarCode 名前空間


ITF Members

NDoc で作成されたクラス ライブラリ

ITF メンバ

ITF 概要

パブリック コンストラクタ

ITF オーバーロード。 ITF クラスの新しいインスタンスを初期化します。

参照

ITF クラス | ITF メンバ | Pao.BarCode 名前空間


ITF コンストラクタ

コンストラクタ　ITF

オーバーロードの一覧

コンストラクタ　ITF

public ITF(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public ITF(string,ImageFormat);

参照

ITF クラス | Pao.BarCode 名前空間


ITF コンストラクタ (Graphics)

コンストラクタ　ITF

public ITF(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

ITF クラス | Pao.BarCode 名前空間


ITF コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public ITF(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

ITF クラス | Pao.BarCode 名前空間


ITF プロパティ

ITF クラスのプロパティは以下のとおりです。ITF クラスの完全なメンバ一覧については、 ITF メンバ のトピックを参照してください。

パブリック プロパティ

ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
ShiroBarChousei | 描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
TextFont | 添字のフォントプロパティ
TextKintou | 描画位置設定(バーコード全体の幅に均等割付)プロパティ
TextWrite | TextWrite 添字の描画プロパティ

参照

ITF クラス | ITF メンバ | Pao.BarCode 名前空間


ITF.ImgDpi Property

NDoc で作成されたクラス ライブラリ

ITF.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

実装

IBarCode.ImgDpi

参照

ITF クラス | Pao.BarCode 名前空間


ITF.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

ITF.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

実装

IBarCode.ImgDrawUnit

参照

ITF クラス | Pao.BarCode 名前空間


ITF.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

ITF.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int KuroBarChousei {get; set;}

実装

IBarCode.KuroBarChousei

参照

ITF クラス | Pao.BarCode 名前空間


ITF.RotateAngle Property

NDoc で作成されたクラス ライブラリ

ITF.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

実装

IBarCode.RotateAngle

参照

ITF クラス | Pao.BarCode 名前空間


ITF.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

ITF.ShiroBarChousei プロパティ

描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 　　白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int ShiroBarChousei {get; set;}

実装

IBarCode.ShiroBarChousei

参照

ITF クラス | Pao.BarCode 名前空間


ITF.TextFont Property

NDoc で作成されたクラス ライブラリ

ITF.TextFont プロパティ

添字のフォントプロパティ

public System.Drawing.Font TextFont {get; set;}

実装

IBarCode.TextFont

参照

ITF クラス | Pao.BarCode 名前空間


ITF.TextKintou Property

NDoc で作成されたクラス ライブラリ

ITF.TextKintou プロパティ

描画位置設定(バーコード全体の幅に均等割付)プロパティ

public bool TextKintou {get; set;}

実装

IBarCode.TextKintou

参照

ITF クラス | Pao.BarCode 名前空間


ITF.TextWrite Property

NDoc で作成されたクラス ライブラリ

ITF.TextWrite プロパティ

TextWrite 添字の描画プロパティ

public bool TextWrite {get; set;}

実装

IBarCode.TextWrite

参照

ITF クラス | Pao.BarCode 名前空間


ITF メソッド

ITF クラスのメソッドは以下のとおりです。ITF クラスの完全なメンバ一覧については、 ITF メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDelicate | オーバーロード。 バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

ITF クラス | ITF メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

ITF.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

ITF クラス | Pao.BarCode 名前空間


ITF.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.Draw

参照

ITF クラス | Pao.BarCode 名前空間


ITF.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.Draw

参照

ITF クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

ITF.DrawDelicate メソッド

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

オーバーロードの一覧

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(string,float,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,float,string);

参照

ITF クラス | Pao.BarCode 名前空間


ITF.DrawDelicate メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDelicate

参照

ITF クラス | Pao.BarCode 名前空間


ITF.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDelicate

参照

ITF クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

ITF.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(string,float,float,float,float,string);

参照

ITF クラス | Pao.BarCode 名前空間


ITF.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDirect

参照

ITF クラス | Pao.BarCode 名前空間


ITF.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDirect

参照

ITF クラス | Pao.BarCode 名前空間


ITF.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float width,
float height,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

ITF クラス | Pao.BarCode 名前空間


JAN13 クラス

JANコード(13桁)を生成するのに用いられるclassです。

この型のすべてのメンバの一覧については、 JAN13 メンバを参照してください。

System.Object
JAN13

public class JAN13 : IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

JAN13 クラス | JAN13 メンバ | Pao.BarCode 名前空間


JAN13 Members

NDoc で作成されたクラス ライブラリ

JAN13 メンバ

JAN13 概要

パブリック コンストラクタ

JAN13 オーバーロード。 JAN13 クラスの新しいインスタンスを初期化します。

参照

JAN13 クラス | JAN13 メンバ | Pao.BarCode 名前空間


JAN13 コンストラクタ

コンストラクタ　JAN13

オーバーロードの一覧

コンストラクタ　JAN13

public JAN13(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public JAN13(string,ImageFormat);

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13 コンストラクタ (Graphics)

コンストラクタ　JAN13

public JAN13(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13 コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public JAN13(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13 プロパティ

JAN13 クラスのプロパティは以下のとおりです。JAN13 クラスの完全なメンバ一覧については、 JAN13 メンバ のトピックを参照してください。

パブリック プロパティ

ImageWidthIncludeLeftChar | JAN13の添字は、一番左の文字がバーコードの幅からはみ出ます。 このプロパティは、画像ファイルにバーコードを出力する際に指定する (1) バーコードの幅に、左にはみ出る添字の１文字の幅を含めるか、 (2) バーコードの幅は、あくまで実際のバーコードの幅で左にはみ出る祖英1文字は含めないか を指定します。 既定値は、(1) バーコードの幅に、左にはみ出る添字の１文字の幅を含める = true です。
ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
ShiroBarChousei | 描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
TextFont | 添字のフォントプロパティ
TextKintou | 描画位置設定(バーコード全体の幅に均等割付)プロパティ
TextWrite | TextWrite 添字の描画プロパティ

参照

JAN13 クラス | JAN13 メンバ | Pao.BarCode 名前空間


JAN13.ImageWidthIncludeLeftChar Property

NDoc で作成されたクラス ライブラリ

JAN13.ImageWidthIncludeLeftChar プロパティ

JAN13の添字は、一番左の文字がバーコードの幅からはみ出ます。 このプロパティは、画像ファイルにバーコードを出力する際に指定する (1) バーコードの幅に、左にはみ出る添字の１文字の幅を含めるか、 (2) バーコードの幅は、あくまで実際のバーコードの幅で左にはみ出る祖英1文字は含めないか を指定します。 既定値は、(1) バーコードの幅に、左にはみ出る添字の１文字の幅を含める = true です。

public bool ImageWidthIncludeLeftChar {get; set;}

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.ImgDpi Property

NDoc で作成されたクラス ライブラリ

JAN13.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

実装

IBarCode.ImgDpi

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

JAN13.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

実装

IBarCode.ImgDrawUnit

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

JAN13.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int KuroBarChousei {get; set;}

実装

IBarCode.KuroBarChousei

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.RotateAngle Property

NDoc で作成されたクラス ライブラリ

JAN13.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

実装

IBarCode.RotateAngle

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

JAN13.ShiroBarChousei プロパティ

描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 　　白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int ShiroBarChousei {get; set;}

実装

IBarCode.ShiroBarChousei

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.TextFont Property

NDoc で作成されたクラス ライブラリ

JAN13.TextFont プロパティ

添字のフォントプロパティ

public System.Drawing.Font TextFont {get; set;}

実装

IBarCode.TextFont

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.TextKintou Property

NDoc で作成されたクラス ライブラリ

JAN13.TextKintou プロパティ

描画位置設定(バーコード全体の幅に均等割付)プロパティ

public bool TextKintou {get; set;}

実装

IBarCode.TextKintou

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.TextWrite Property

NDoc で作成されたクラス ライブラリ

JAN13.TextWrite プロパティ

TextWrite 添字の描画プロパティ

public bool TextWrite {get; set;}

実装

IBarCode.TextWrite

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13 メソッド

JAN13 クラスのメソッドは以下のとおりです。JAN13 クラスの完全なメンバ一覧については、 JAN13 メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDelicate | オーバーロード。 バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

JAN13 クラス | JAN13 メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

JAN13.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.Draw

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.Draw

参照

JAN13 クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

JAN13.DrawDelicate メソッド

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

オーバーロードの一覧

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(string,float,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,float,string);

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.DrawDelicate メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDelicate

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDelicate

参照

JAN13 クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

JAN13.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(string,float,float,float,float,string);

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDirect

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDirect

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN13.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float width,
float height,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

JAN13 クラス | Pao.BarCode 名前空間


JAN8 クラス

JANコード(8桁)を生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 JAN8 メンバを参照してください。

System.Object
JAN8

public class JAN8 : IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

JAN8 クラス | JAN8 メンバ | Pao.BarCode 名前空間


JAN8 Members

NDoc で作成されたクラス ライブラリ

JAN8 メンバ

JAN8 概要

パブリック コンストラクタ

JAN8 オーバーロード。 JAN8 クラスの新しいインスタンスを初期化します。

参照

JAN8 クラス | JAN8 メンバ | Pao.BarCode 名前空間


JAN8 コンストラクタ

コンストラクタ　JAN8

オーバーロードの一覧

コンストラクタ　JAN8

public JAN8(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public JAN8(string,ImageFormat);

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8 コンストラクタ (Graphics)

コンストラクタ　JAN8

public JAN8(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8 コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public JAN8(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8 プロパティ

JAN8 クラスのプロパティは以下のとおりです。JAN8 クラスの完全なメンバ一覧については、 JAN8 メンバ のトピックを参照してください。

パブリック プロパティ

ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
ShiroBarChousei | 描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
TextFont | 添字のフォントプロパティ
TextKintou | 描画位置設定(バーコード全体の幅に均等割付)プロパティ
TextWrite | TextWrite 添字の描画プロパティ

参照

JAN8 クラス | JAN8 メンバ | Pao.BarCode 名前空間


JAN8.ImgDpi Property

NDoc で作成されたクラス ライブラリ

JAN8.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

実装

IBarCode.ImgDpi

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

JAN8.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

実装

IBarCode.ImgDrawUnit

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

JAN8.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int KuroBarChousei {get; set;}

実装

IBarCode.KuroBarChousei

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.RotateAngle Property

NDoc で作成されたクラス ライブラリ

JAN8.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

実装

IBarCode.RotateAngle

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

JAN8.ShiroBarChousei プロパティ

描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 　　白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int ShiroBarChousei {get; set;}

実装

IBarCode.ShiroBarChousei

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.TextFont Property

NDoc で作成されたクラス ライブラリ

JAN8.TextFont プロパティ

添字のフォントプロパティ

public System.Drawing.Font TextFont {get; set;}

実装

IBarCode.TextFont

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.TextKintou Property

NDoc で作成されたクラス ライブラリ

JAN8.TextKintou プロパティ

描画位置設定(バーコード全体の幅に均等割付)プロパティ

public bool TextKintou {get; set;}

実装

IBarCode.TextKintou

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.TextWrite Property

NDoc で作成されたクラス ライブラリ

JAN8.TextWrite プロパティ

TextWrite 添字の描画プロパティ

public bool TextWrite {get; set;}

実装

IBarCode.TextWrite

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8 メソッド

JAN8 クラスのメソッドは以下のとおりです。JAN8 クラスの完全なメンバ一覧については、 JAN8 メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDelicate | オーバーロード。 バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

JAN8 クラス | JAN8 メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

JAN8.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.Draw

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.Draw

参照

JAN8 クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

JAN8.DrawDelicate メソッド

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

オーバーロードの一覧

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(string,float,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,float,string);

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.DrawDelicate メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDelicate

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDelicate

参照

JAN8 クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

JAN8.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(string,float,float,float,float,string);

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDirect

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDirect

参照

JAN8 クラス | Pao.BarCode 名前空間


JAN8.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float width,
float height,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

JAN8 クラス | Pao.BarCode 名前空間


Matrix2of5 クラス

Matrix 2 of 5 バーコードを生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 Matrix2of5 メンバを参照してください。

System.Object
Matrix2of5

public class Matrix2of5 : IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

Matrix2of5 クラス | Matrix2of5 メンバ | Pao.BarCode 名前空間


Matrix2of5 Members

NDoc で作成されたクラス ライブラリ

Matrix2of5 メンバ

Matrix2of5 概要

パブリック コンストラクタ

Matrix2of5 オーバーロード。 Matrix2of5 クラスの新しいインスタンスを初期化します。

参照

Matrix2of5 クラス | Matrix2of5 メンバ | Pao.BarCode 名前空間


Matrix2of5 コンストラクタ

コンストラクタ　Matrix2of5

オーバーロードの一覧

コンストラクタ　Matrix2of5

public Matrix2of5(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public Matrix2of5(string,ImageFormat);

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5 コンストラクタ (Graphics)

コンストラクタ　Matrix2of5

public Matrix2of5(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5 コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public Matrix2of5(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5 プロパティ

Matrix2of5 クラスのプロパティは以下のとおりです。Matrix2of5 クラスの完全なメンバ一覧については、 Matrix2of5 メンバ のトピックを参照してください。

パブリック プロパティ

ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
ShiroBarChousei | 描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
TextFont | 添字のフォントプロパティ
TextKintou | 描画位置設定(バーコード全体の幅に均等割付)プロパティ
TextWrite | TextWrite 添字の描画プロパティ

参照

Matrix2of5 クラス | Matrix2of5 メンバ | Pao.BarCode 名前空間


Matrix2of5.ImgDpi Property

NDoc で作成されたクラス ライブラリ

Matrix2of5.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

実装

IBarCode.ImgDpi

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

Matrix2of5.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

実装

IBarCode.ImgDrawUnit

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

Matrix2of5.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int KuroBarChousei {get; set;}

実装

IBarCode.KuroBarChousei

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.RotateAngle Property

NDoc で作成されたクラス ライブラリ

Matrix2of5.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

実装

IBarCode.RotateAngle

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

Matrix2of5.ShiroBarChousei プロパティ

描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 　　白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int ShiroBarChousei {get; set;}

実装

IBarCode.ShiroBarChousei

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.TextFont Property

NDoc で作成されたクラス ライブラリ

Matrix2of5.TextFont プロパティ

添字のフォントプロパティ

public System.Drawing.Font TextFont {get; set;}

実装

IBarCode.TextFont

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.TextKintou Property

NDoc で作成されたクラス ライブラリ

Matrix2of5.TextKintou プロパティ

描画位置設定(バーコード全体の幅に均等割付)プロパティ

public bool TextKintou {get; set;}

実装

IBarCode.TextKintou

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.TextWrite Property

NDoc で作成されたクラス ライブラリ

Matrix2of5.TextWrite プロパティ

TextWrite 添字の描画プロパティ

public bool TextWrite {get; set;}

実装

IBarCode.TextWrite

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5 メソッド

Matrix2of5 クラスのメソッドは以下のとおりです。Matrix2of5 クラスの完全なメンバ一覧については、 Matrix2of5 メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDelicate | オーバーロード。 バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

Matrix2of5 クラス | Matrix2of5 メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

Matrix2of5.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.Draw

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.Draw

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

Matrix2of5.DrawDelicate メソッド

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

オーバーロードの一覧

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(string,float,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,float,string);

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.DrawDelicate メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDelicate

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDelicate

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

Matrix2of5.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(string,float,float,float,float,string);

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDirect

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDirect

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


Matrix2of5.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float width,
float height,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

Matrix2of5 クラス | Pao.BarCode 名前空間


NEC2of5 クラス

NEC 2 of 5 バーコードを生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 NEC2of5 メンバを参照してください。

System.Object
NEC2of5

public class NEC2of5 : IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

NEC2of5 クラス | NEC2of5 メンバ | Pao.BarCode 名前空間


NEC2of5 Members

NDoc で作成されたクラス ライブラリ

NEC2of5 メンバ

NEC2of5 概要

パブリック コンストラクタ

NEC2of5 オーバーロード。 NEC2of5 クラスの新しいインスタンスを初期化します。

参照

NEC2of5 クラス | NEC2of5 メンバ | Pao.BarCode 名前空間


NEC2of5 コンストラクタ

コンストラクタ　NEC2of5

オーバーロードの一覧

コンストラクタ　NEC2of5

public NEC2of5(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public NEC2of5(string,ImageFormat);

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5 コンストラクタ (Graphics)

コンストラクタ　NEC2of5

public NEC2of5(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5 コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public NEC2of5(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5 プロパティ

NEC2of5 クラスのプロパティは以下のとおりです。NEC2of5 クラスの完全なメンバ一覧については、 NEC2of5 メンバ のトピックを参照してください。

パブリック プロパティ

ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
ShiroBarChousei | 描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
TextFont | 添字のフォントプロパティ
TextKintou | 描画位置設定(バーコード全体の幅に均等割付)プロパティ
TextWrite | TextWrite 添字の描画プロパティ

参照

NEC2of5 クラス | NEC2of5 メンバ | Pao.BarCode 名前空間


NEC2of5.ImgDpi Property

NDoc で作成されたクラス ライブラリ

NEC2of5.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

実装

IBarCode.ImgDpi

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

NEC2of5.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

実装

IBarCode.ImgDrawUnit

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

NEC2of5.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int KuroBarChousei {get; set;}

実装

IBarCode.KuroBarChousei

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.RotateAngle Property

NDoc で作成されたクラス ライブラリ

NEC2of5.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

実装

IBarCode.RotateAngle

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

NEC2of5.ShiroBarChousei プロパティ

描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 　　白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int ShiroBarChousei {get; set;}

実装

IBarCode.ShiroBarChousei

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.TextFont Property

NDoc で作成されたクラス ライブラリ

NEC2of5.TextFont プロパティ

添字のフォントプロパティ

public System.Drawing.Font TextFont {get; set;}

実装

IBarCode.TextFont

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.TextKintou Property

NDoc で作成されたクラス ライブラリ

NEC2of5.TextKintou プロパティ

描画位置設定(バーコード全体の幅に均等割付)プロパティ

public bool TextKintou {get; set;}

実装

IBarCode.TextKintou

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.TextWrite Property

NDoc で作成されたクラス ライブラリ

NEC2of5.TextWrite プロパティ

TextWrite 添字の描画プロパティ

public bool TextWrite {get; set;}

実装

IBarCode.TextWrite

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5 メソッド

NEC2of5 クラスのメソッドは以下のとおりです。NEC2of5 クラスの完全なメンバ一覧については、 NEC2of5 メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDelicate | オーバーロード。 バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

NEC2of5 クラス | NEC2of5 メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

NEC2of5.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.Draw

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.Draw

参照

NEC2of5 クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

NEC2of5.DrawDelicate メソッド

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

オーバーロードの一覧

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(string,float,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,float,string);

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.DrawDelicate メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDelicate

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDelicate

参照

NEC2of5 クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

NEC2of5.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(string,float,float,float,float,string);

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDirect

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDirect

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NEC2of5.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float width,
float height,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

NEC2of5 クラス | Pao.BarCode 名前空間


NW7 クラス

Codabar/NW7バーコードを生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 NW7 メンバを参照してください。

System.Object
NW7

public class NW7 : IBarCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

NW7 クラス | NW7 メンバ | Pao.BarCode 名前空間


NW7 Members

NDoc で作成されたクラス ライブラリ

NW7 メンバ

NW7 概要

パブリック コンストラクタ

NW7 オーバーロード。 NW7 クラスの新しいインスタンスを初期化します。

参照

NW7 クラス | NW7 メンバ | Pao.BarCode 名前空間


NW7 コンストラクタ

コンストラクタ　NW7

オーバーロードの一覧

コンストラクタ　NW7

public NW7(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public NW7(string,ImageFormat);

参照

NW7 クラス | Pao.BarCode 名前空間


NW7 コンストラクタ (Graphics)

コンストラクタ　NW7

public NW7(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

NW7 クラス | Pao.BarCode 名前空間


NW7 コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public NW7(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

NW7 クラス | Pao.BarCode 名前空間


NW7 プロパティ

NW7 クラスのプロパティは以下のとおりです。NW7 クラスの完全なメンバ一覧については、 NW7 メンバ のトピックを参照してください。

パブリック プロパティ

DispStartStopCode | スタート／ストップコードの描画プロパティ
ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
ShiroBarChousei | 描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。
TextFont | 添字のフォントプロパティ
TextKintou | 描画位置設定(バーコード全体の幅に均等割付)プロパティ
TextWrite | TextWrite 添字の描画プロパティ

参照

NW7 クラス | NW7 メンバ | Pao.BarCode 名前空間


NW7.DispStartStopCode Property

NDoc で作成されたクラス ライブラリ

NW7.DispStartStopCode プロパティ

スタート／ストップコードの描画プロパティ

public bool DispStartStopCode {get; set;}

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.ImgDpi Property

NDoc で作成されたクラス ライブラリ

NW7.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

実装

IBarCode.ImgDpi

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

NW7.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

実装

IBarCode.ImgDrawUnit

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

NW7.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int KuroBarChousei {get; set;}

実装

IBarCode.KuroBarChousei

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.RotateAngle Property

NDoc で作成されたクラス ライブラリ

NW7.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

実装

IBarCode.RotateAngle

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.ShiroBarChousei Property

NDoc で作成されたクラス ライブラリ

NW7.ShiroBarChousei プロパティ

描画する白バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての白バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。 →インクジェットプリンタで黒バーがにじんで太くなる時などに有効 例：コンビニバーコード、EPSON PX-502A(360DPI)のプリンタには、 　　白バーを＋１してあげると丁度良い。 ※この機能は。DrawDirect / DrawDelicate メソッドには有効ですが、 Draw メソッドには無効ですのでご注意ください。

public int ShiroBarChousei {get; set;}

実装

IBarCode.ShiroBarChousei

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.TextFont Property

NDoc で作成されたクラス ライブラリ

NW7.TextFont プロパティ

添字のフォントプロパティ

public System.Drawing.Font TextFont {get; set;}

実装

IBarCode.TextFont

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.TextKintou Property

NDoc で作成されたクラス ライブラリ

NW7.TextKintou プロパティ

描画位置設定(バーコード全体の幅に均等割付)プロパティ

public bool TextKintou {get; set;}

実装

IBarCode.TextKintou

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.TextWrite Property

NDoc で作成されたクラス ライブラリ

NW7.TextWrite プロパティ

TextWrite 添字の描画プロパティ

public bool TextWrite {get; set;}

実装

IBarCode.TextWrite

参照

NW7 クラス | Pao.BarCode 名前空間


NW7 メソッド

NW7 クラスのメソッドは以下のとおりです。NW7 クラスの完全なメンバ一覧については、 NW7 メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDelicate | オーバーロード。 バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

NW7 クラス | NW7 メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

NW7.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.Draw

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.Draw

参照

NW7 クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

NW7.DrawDelicate メソッド

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

オーバーロードの一覧

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(string,float,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,float,string);

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.DrawDelicate メソッド (String, Single, Single, Single, Single)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDelicate

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.DrawDelicate メソッド (String, Single, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLineWidth,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLineWidth
バーコードを描画するバーの最小幅の値を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDelicate

参照

NW7 クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

NW7.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(string,float,float,float,float,string);

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

実装

IBarCode.DrawDirect

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。 ※コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

実装

IBarCode.DrawDirect

参照

NW7 クラス | Pao.BarCode 名前空間


NW7.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float width,
float height,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

NW7 クラス | Pao.BarCode 名前空間


QRCode クラス

QRコードを生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 QRCode メンバを参照してください。

System.Object
QRCode

public class QRCode

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

QRCode クラス | QRCode メンバ | Pao.BarCode 名前空間


QRCode Members

NDoc で作成されたクラス ライブラリ

QRCode メンバ

QRCode 概要

パブリック コンストラクタ

QRCode オーバーロード。 QRCode クラスの新しいインスタンスを初期化します。

参照

QRCode クラス | QRCode メンバ | Pao.BarCode 名前空間


QRCode コンストラクタ

コンストラクタ　QRCode

オーバーロードの一覧

コンストラクタ　QRCode

public QRCode(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public QRCode(string,ImageFormat);

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode コンストラクタ (Graphics)

コンストラクタ　QRCode

public QRCode(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public QRCode(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode プロパティ

QRCode クラスのプロパティは以下のとおりです。QRCode クラスの完全なメンバ一覧については、 QRCode メンバ のトピックを参照してください。

パブリック プロパティ

EncodeMode | エンコードモード "N":数字のみ "A":英数字のみ その他("Z"):8ビットバイトコード(漢字含む)
ErrorCorrect | エラー訂正レベル "L" "M" "Q" "H"
ImgDpi | 画像DPI (画像ファイル出力用)
ImgDrawUnit | 画像描画単位 (画像ファイル出力用)
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)
Version | バージョン 1～40

参照

QRCode クラス | QRCode メンバ | Pao.BarCode 名前空間


QRCode.EncodeMode Property

NDoc で作成されたクラス ライブラリ

QRCode.EncodeMode プロパティ

エンコードモード 　"N":数字のみ　"A":英数字のみ　その他("Z"):8ビットバイトコード(漢字含む)

public string EncodeMode {get; set;}

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.ErrorCorrect Property

NDoc で作成されたクラス ライブラリ

QRCode.ErrorCorrect プロパティ

エラー訂正レベル "L" "M" "Q" "H"

public string ErrorCorrect {get; set;}

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.ImgDpi Property

NDoc で作成されたクラス ライブラリ

QRCode.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.ImgDrawUnit Property

NDoc で作成されたクラス ライブラリ

QRCode.ImgDrawUnit プロパティ

画像描画単位 (画像ファイル出力用)

public System.Drawing.GraphicsUnit ImgDrawUnit {get; set;}

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.RotateAngle Property

NDoc で作成されたクラス ライブラリ

QRCode.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.Version Property

NDoc で作成されたクラス ライブラリ

QRCode.Version プロパティ

バージョン 1～40

public int Version {get; set;}

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode メソッド

QRCode クラスのメソッドは以下のとおりです。QRCode クラスの完全なメンバ一覧については、 QRCode メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードの描画を行う
DrawDelicate | オーバーロード。 バーコードの描画を行う
DrawDirect | オーバーロード。 バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | SVGファイルへのバーコードの出力を行います。

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

QRCode クラス | QRCode メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

QRCode.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float,float);

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(string,float,float,float,float,string);

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.Draw メソッド (String, Single, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.Draw メソッド (String, Single, Single, Single, Single, String)

バーコードを描画する コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void Draw(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

参照

QRCode クラス | Pao.BarCode 名前空間


DrawDelicate メソッド

NDoc で作成されたクラス ライブラリ

QRCode.DrawDelicate メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void DrawDelicate(string,float,float,float);

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(string,float,float,float,string);

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.DrawDelicate メソッド (String, Single, Single, Single)

バーコードの描画を行う

public void DrawDelicate(
string code,
float x,
float y,
float minLinePitch
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLinePitch
バーコードを描画する間隔の最小幅の値を指定

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.DrawDelicate メソッド (String, Single, Single, Single, String)

バーコードの描画を行います。Draw メソッドとの違いは、バーコード全体の幅を指定するのではなく、バーを描画する一番細い線の幅を指定します。 コンストラクタでImageFormat指定時、画像ファイルに描画する。

public void DrawDelicate(
string code,
float x,
float y,
float minLinePitch,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLinePitch
バーコードを描画するバーの最小ピッチの値を指定
imgFilePath
画像ファイルパス

参照

QRCode クラス | Pao.BarCode 名前空間


DrawDirect メソッド

NDoc で作成されたクラス ライブラリ

QRCode.DrawDirect メソッド

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

オーバーロードの一覧

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float);

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(string,float,float,float,float,string);

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.DrawDirect メソッド (String, Single, Single, Single, Single)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.DrawDirect メソッド (String, Single, Single, Single, Single, String)

バーコードを指定した幅以内にピクセル単位でダイレクトに描画します。 幅が固定でありませんが、通常のDrawメソッドより精度・描画速度がよいです。

public void DrawDirect(
string code,
float x,
float y,
float width,
float height,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
width
バーコードの全体の幅を指定
height
バーコードのバーの高さを指定
imgFilePath
画像ファイルパス

参照

QRCode クラス | Pao.BarCode 名前空間


QRCode.WriteSVG メソッド

SVGファイルへのバーコードの出力を行います。

public void WriteSVG(
string code,
float x,
float y,
float minLinePitch,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
minLinePitch
バーコードを描画する間隔の最小幅の値を指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

QRCode クラス | Pao.BarCode 名前空間


YubinCustomer クラス

郵便カスタマーバーコードを生成するのに用いられるクラスです。

この型のすべてのメンバの一覧については、 YubinCustomer メンバを参照してください。

System.Object
YubinCustomer

public class YubinCustomer

必要条件

名前空間: Pao.BarCode

アセンブリ: Pao.BarCode (Pao.BarCode.dll 内)

参照

YubinCustomer クラス | YubinCustomer メンバ | Pao.BarCode 名前空間


YubinCustomer Members

NDoc で作成されたクラス ライブラリ

YubinCustomer メンバ

YubinCustomer 概要

パブリック コンストラクタ

YubinCustomer オーバーロード。 YubinCustomer クラスの新しいインスタンスを初期化します。

参照

YubinCustomer クラス | YubinCustomer メンバ | Pao.BarCode 名前空間


YubinCustomer コンストラクタ

コンストラクタ　YubinCustomer

オーバーロードの一覧

コンストラクタ　YubinCustomer

public YubinCustomer(Graphics);

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public YubinCustomer(string,ImageFormat);

参照

YubinCustomer クラス | Pao.BarCode 名前空間


YubinCustomer コンストラクタ (Graphics)

コンストラクタ　YubinCustomer

public YubinCustomer(
Graphics g
);

パラメータ

g
バーコードの描画を行うGraphicsを指定します。

参照

YubinCustomer クラス | Pao.BarCode 名前空間


YubinCustomer コンストラクタ (String, ImageFormat)

コンストラクタ ミリやインチ等の単位で幅・高さを指定し、かつ、dpiを指定して バーコードをファイルに書き込むときに使用する

public YubinCustomer(
string imgFilePath,
ImageFormat imgFormat
);

パラメータ

imgFilePath
画像ファイルパス
imgFormat
画像フォーマット

参照

YubinCustomer クラス | Pao.BarCode 名前空間


YubinCustomer プロパティ

YubinCustomer クラスのプロパティは以下のとおりです。YubinCustomer クラスの完全なメンバ一覧については、 YubinCustomer メンバ のトピックを参照してください。

パブリック プロパティ

ImgDpi | 画像DPI (画像ファイル出力用)
KuroBarChousei | 描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。
RotateAngle | 回転角度を数値で指定(左下を軸に右回転して描画を行う)

参照

YubinCustomer クラス | YubinCustomer メンバ | Pao.BarCode 名前空間


YubinCustomer.ImgDpi Property

NDoc で作成されたクラス ライブラリ

YubinCustomer.ImgDpi プロパティ

画像DPI (画像ファイル出力用)

public float ImgDpi {get; set;}

参照

YubinCustomer クラス | Pao.BarCode 名前空間


YubinCustomer.KuroBarChousei Property

NDoc で作成されたクラス ライブラリ

YubinCustomer.KuroBarChousei プロパティ

描画する黒バー幅をドット単位で微細調整できます。 既定値は、0 ドットです。 例えば、このプロパティに-1 を指定すると、バーコード内全ての黒バーの幅が1ドットずつ細くなります。 プリンタにより、調整が必要な場合にこの機能を使用してください。

public int KuroBarChousei {get; set;}

参照

YubinCustomer クラス | Pao.BarCode 名前空間


YubinCustomer.RotateAngle Property

NDoc で作成されたクラス ライブラリ

YubinCustomer.RotateAngle プロパティ

回転角度を数値で指定(左下を軸に右回転して描画を行う)

public float RotateAngle {get; set;}

参照

YubinCustomer クラス | Pao.BarCode 名前空間


YubinCustomer メソッド

YubinCustomer クラスのメソッドは以下のとおりです。YubinCustomer クラスの完全なメンバ一覧については、 YubinCustomer メンバ のトピックを参照してください。

パブリック メソッド

Draw | オーバーロード。 バーコードの描画を行う
Equals (Object から継承されます) |
GetHashCode (Object から継承されます) |
GetType (Object から継承されます) |
ToString (Object から継承されます) |
WriteSVG | バーコードの描画を行う

プロテクト メソッド

Finalize (Object から継承されます)
MemberwiseClone (Object から継承されます)

参照

YubinCustomer クラス | YubinCustomer メンバ | Pao.BarCode 名前空間


Draw メソッド

NDoc で作成されたクラス ライブラリ

YubinCustomer.Draw メソッド

バーコードの描画を行う

オーバーロードの一覧

バーコードの描画を行う

public void Draw(string,float,float,float);

バーコードの描画を行う

public void Draw(string,float,float,float,string);

参照

YubinCustomer クラス | Pao.BarCode 名前空間


YubinCustomer.Draw メソッド (String, Single, Single, Single)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float point
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
point
バーコード大きさを表すポイントを指定

参照

YubinCustomer クラス | Pao.BarCode 名前空間


YubinCustomer.Draw メソッド (String, Single, Single, Single, String)

バーコードの描画を行う

public void Draw(
string code,
float x,
float y,
float point,
string imgFilePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
point
バーコード大きさを表すポイントを指定
imgFilePath
画像ファイルパス

参照

YubinCustomer クラス | Pao.BarCode 名前空間


YubinCustomer.WriteSVG メソッド

バーコードの描画を行う

public void WriteSVG(
string code,
float x,
float y,
float point,
string filePath
);

パラメータ

code
描画を行うバーコードのコードを文字列で指定
x
描画位置の始点(左上)のX座標を指定
y
描画位置の始点(左上)のY座標を指定
point
バーコード大きさを表すポイントを指定
filePath
SVGファイルのファイル名をフルパスで指定

参照

YubinCustomer クラス | Pao.BarCode 名前空間