Reports.NETプログラマーズ

本ヘルプについて

本ヘルプは、有限会社パオ・アット・オフィスが開発したソフトウエア「Reports.NET」についての説明を行うものです。
利用者は本ヘルプのいかなる部分も、発行者の許可なく、複製を行ってはいけません。
有限会社パオ・アット・オフィスは、本ヘルプの内容に起因する一切の結果に関して、いかなる責任も負いません。
有限会社パオ・アット・オフィスは、本ヘルプの内容、またはReports.NETの仕様を予告なく改訂、あるいは、内容変更する権利を有します。また、それらの行為を行った場合においても、利用者への通知の義務を負いません。
有限会社パオ・アット・オフィスは、Reports.NETの仕様に起因する結果にたいして、いかなる責任も負いません。
マニュアル中での画像は、説明のため見やすく編集している箇所があります。利用者の皆様の画面とは一致しない場合がございますので、あらかじめご了承ください。

本マニュアルの中で記載されている製品名は、各社の登録商標もしくは商標です。

有限会社パオ・アット・オフィス
郵便番号275-0026
千葉県習志野市谷津3-29-2-401

http://www.pao.ac/


はじめに

.NET開発環境下で開発を行っているプログラマの皆様、こんにちは、お疲れ様です。
Reports.NET の クラスとしてのインターフェースは、非常に単純で簡単なので本書を読むにあたって心してかからなくて良いです。
※その分、デザイン部であるレポート定義XMLファイルに頼るところが多いということです。
クラスやメソッドの数も少ししかありません。
もう、ここであげてしまいましょうか。

IReports インタフェース　･･･印刷又はプレビューを行うための共通インターフェース
│
├─LoadDefFile メソッド ･･･レポート定義ファイルを読み込む
│
├─PageStart メソッド ･･･ページの開始だよ、と宣言する
│
├─Write メソッド ･･･印刷データを書き込む
│
├─PageEnd メソッド　 ･･･ページの終了だよ、と宣言する
│
├─Output メソッド　 ･･･印刷／プレビューを指示する
│
├─LoadXMLFile メソッド　･･･印刷データファイルを読み込む
│
├─SaveXMLFile メソッド　･･･印刷データファイルを書き出す
│
├─SaveData メソッド ･･･圧縮した印刷バイナリデータを返す
│　　　　　　　　　　　　　　 (WEBサービスとの転送フォーマット)
│
├─LoadData メソッド ･･･圧縮した印刷バイナリデータを読み込む
│　　　　　　　　　　　　　　 (WEBサービスとの転送フォーマット)
│
├─SaveSVGFile メソッド ･･･SVG形式の印刷データを書き出す
│
├─SaveSVGZFile メソッド　･･･SVGZ形式の印刷データを書き出す
│
└─SavePDF メソッド ･･･PDF形式の印刷データを書き出す

ReportCreator　クラス　･･･印刷又は、プレビューのインスタンス(オブジェクト)を返す
│
├─GetPreview メソッド ･･･プレビューオブジェクトを返す(上記の IReports型)
│
├─GetReport メソッド ･･･印刷オブジェクトを返す(上記の IReports型)
│
├─GetPdf メソッド　　　　 ･･･PDFオブジェクトを返す(上記の IReports型)
│
└─GetImagePdf メソッド　･･･イメージPDFオブジェクトを返す(上記の IReports型)

たったこれだけです。たったこれだけなんです。
※ReportStartImplクラスも見えてると思いますが、これはプレビュー単体起動用なので気にしないでください。
どうです？たいしたことないでしょう。
それでは本書内ではコーディング例等を用いながら、各クラスやメソッドについてもう少し細かく書いていくことにします。
皆様が楽しんで楽にプログラミングできることを心から願います。

作者


機能概要

  Reports.NETの核となるのは、エンジンと呼ばれる部分です。エンジンは、.NETアプリケーションに対し、「レポート定義ファイル」により定義された帳票を作成するための機能を提供します。利用者様は任意のアプリケーションからエンジンを制御し、帳票の印刷・プレビューや「印刷データ」の書き出しを行う事が可能です。
  また、PDFやSVG / SVGZ形式のファイルに出力することが可能で、ブラウザでプレビュー・印刷を行うことができます。


新規ﾍﾟｰｼﾞ

機能概要【Webサービスとの連携】

  Windowsをプラットフォームとしたリッチクライアントから、IISやUNIX(Linux等)サーバ上のWEBサービス(.NET WebService / axis等)に対して1つの命令を下す(メソッドを呼び出す)だけで、WEBサーバから印刷データを圧縮したバイナリデータを取得し、印刷を行うことが可能です。クライアントから命令がきたら(メソッドが呼び出されたら)サーバ側のみでデータベース等にアクセスして印刷データを作成し、バイナリデータ(byte[]型変数)として、クライアント側に返し、クライアント側でそれを印刷するという仕組みです。
  WEBサーバ側のプラットフォームに多様性を持たせるため、開発言語は、.NET だけでなくJava言語にも対応しています。(Reports.jar)


動作条件

本製品を使用するためには、以下の条件を満たす環境のパソコンが必要です。

OS | Microsoft.NET Frameworkが正常に動作するものである事
動作に必要なメモリ | Microsoft .NET Frameworkが正常に動作するために必要な容量
画面解像度 | エンジン:特に制限なし デザイナー:1024×768以上の解像度で、フォントサイズが標準の「小さいフォント」である事
開発環境 | Microsoft Visual Studio .NET がインストールされている事


使用方法

  1. 「Pao.Reports.dll」を任意のディレクトリにコピーして下さい。なお、最新版は常に弊社WebSiteにご用意させて頂いております。
    http://www.pao.ac/products/reports.net/
    (正式にユーザ登録して頂いたお客様には、「ユーザ情報ファイル」を個別に送付させて頂きます。「ユーザ情報ファイル」を「Pao.Reports.dll」と同じ場所にコピーしてご利用頂く事で、正式版としての利用が可能です。)
  2. Reports.NETをご利用になりたいプログラムのプロジェクトに、「Pao.Reports.dll」への参照を追加して下さい。

  3. 必要に応じてC#の場合は「using」を、VB.NETの場合は「Imports」を定義して下さい。
    C#の場合
    using Pao.Reports;

    VB.NETの場合
    Imports Pao.Reports


アプリケーションプログラムからのReports.NET使用方法

  1. 例題サンプルプログラムの紹介
  2. 印刷・プレビューオブジェクトのインスタンス生成方法
  3. レポート定義ファイル読み込み方法
  4. ページの開始・終了宣言の方法
  5. オブジェクトへのデータセット方法(C#.NET表記)
  6. オブジェクトへのデータセット方法(VB.NET表記)
  7. 印刷・プレビューの指示方法
  8. 印刷データの保存・読み込み方法
  9. 圧縮した印刷バイナリデータ取得
  10. SVG、SVGZ、PDF印刷データの保存


例題サンプルプログラムの紹介

「アプリケーションプログラムからのReports.NET使用方法」全般では、ここに示す例題サンプルプログラムにそって都度説明をしていきます。まず、大体のプログラムの流れを頭に入れておいて下さい。

＜プログラムの説明＞

  • 画面のラジオボタン(オプションボタン)にて、印刷又は、プレビューを選択されて、実行ボタンをクリックされた後、動作します。
  • 帳票の各ページのヘッダに日時と頁数を書き込みます。
  • 明細部は、６０回ループしてその行番号と、回数を１０倍した値を表に書き込みます。
  • 明細部の各行は、横罫線で区切られます。
  • 改ページの条件は１５行なので、全部で４ページになります。
  • 以上の描画が済むと、画面の指示に従い、印刷、又はプレビューを行います。
  • 最後に、一旦、印刷又はプレビューした印刷データを、印刷データファイルに保存し、もう一度その印刷データファイルを読み込んで、その印刷データをプレビュー表示します。

以上の処理を実現しているサンプルプログラムをC#.NET/VB.NET 共に作成しましたので、参考までに少し追ってみてください。コメントが入っておりますので、そこを読むだけでも構いません。

ここでは、サンプルプログラムの処理の流れを頭に入れておいてください。

なお、このサンプルプログラムは、本製品の圧縮ファイルの中の、「サンプル\programers」フォルダ内に納められています。

＜サンプルプログラム実行時＞


C#.NETの例

//IReport インターフェースで宣言(印刷・プレビューどちらでも使える入れ物の用意)

IReport paoRep = null;

if(radioButtonPreview.Checked)//ラジオボタンでプレビューが選択されている場合

{

//プレビューオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetPreview();

}

else

{

//印刷オブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetReport();

}

//レポート定義ファイルの読み込み

paoRep.LoadDefFile("レポート定義ファイル.xml");

int page = 0; //頁数を定義

int line = 0; //行数を定義

for (int i = 0; i < 60; i++)

{

if (i % 15 == 0) //1頁15行で開始

{

//頁開始を宣言

paoRep.PageStart();

page++; //頁数をインクリメント

line = 0; //行数を初期化

//＊＊＊ヘッダのセット＊＊＊

//文字列のセット

paoRep.Write("日付", System.DateTime.Now.ToString());

paoRep.Write("頁数", "Page - " + page.ToString());

}

line++; //行数をインクリメント

//＊＊＊明細のセット＊＊＊

//繰返し文字列のセット

paoRep.Write("行番号", (i+1).ToString() , line);

paoRep.Write("10倍数", ((i+1)*10).ToString() , line);

//繰返し図形(横線)のセット

paoRep.Write("横線", line);

if (((i+1) % 15) == 0) paoRep.PageEnd(); //1頁15行で終了宣言

}

// 印刷/プレビューを実行

paoRep.Output();

paoRep.SaveXMLFile("印刷データ.XML"); //印刷データの保存

//プレビューオブジェクトのインスタンスを獲得しなおし(一旦初期化)

paoRep = ReportCreator.GetPreview();

paoRep.LoadXMLFile("印刷データ.XML"); //印刷データの読み込み

paoRep.Output(); // プレビューを実行


VB.NETの例

'IReport インターフェースで宣言(印刷・レポートどちらでも使える入れ物の用意)

Dim paoRep As IReport = Nothing

If radioButtonPreview.Checked = True Then 'ラジオボタンでプレビューが選択されている場合

'プレビューオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetPreview()

Else

'印刷オブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetReport()

End If

'レポート定義ファイルの読み込み

paoRep.LoadDefFile("レポート定義ファイル.xml")

Dim page As Integer = 0 '頁数を定義

Dim line As Integer = 0 '行数を定義

Dim i As Integer

For i = 1 To 60

If ((i - 1) Mod 15 = 0) Then '1頁15行で開始

'頁開始を宣言

paoRep.PageStart()

page = page + 1 '頁数をインクリメント

line = 0 '行数を初期化

'＊＊＊ヘッダのセット＊＊＊

'文字列のセット

paoRep.Write("日付", System.DateTime.Now.ToString())

paoRep.Write("頁数", "Page - " + page.ToString())

End If

line = line + 1 '行数をインクリメント

'＊＊＊明細のセット＊＊＊

'繰返し文字列のセット

paoRep.Write("行番号", i.ToString(), line)

paoRep.Write("10倍数", (i * 10).ToString(), line)

'繰返し図形(横線)のセット

paoRep.Write("横線", line)

If ((i Mod 15) = 0) Then paoRep.PageEnd() '1頁15行で終了

Next i

'印刷/プレビューを実行

paoRep.Output()

paoRep.SaveXMLFile("印刷データファイル.xml") '印刷データの保存

'プレビューオブジェクトのインスタンスを獲得しなおし(一旦初期化)

paoRep = ReportCreator.GetPreview()

paoRep.LoadXMLFile("印刷データファイル.xml") '印刷データの読み込み

paoRep.Output() ' プレビューを実行


印刷・プレビューオブジェクトのインスタンス生成方法

印刷のクラスもプレビューのクラスも同じメソッドを共有しているため、
IReportインターフェースを使ってオブジェクトを宣言した後、
ReportCreatorクラスのスタティックメソッドとなっている、

  • IReport GetPreview()　･･･プレビューオブジェクトのインスタンス生成
  • IReport GetReport()　･･･インスタンスオブジェクトのインスタンス生成

のどちらかを呼び出すことで、印刷・プレビューオブジェクトのインスタンスを生成することができます。

＜C#.NET の例＞

//IReport インターフェースで宣言(印刷・プレビューどちらでも使える入れ物の用意)

IReport paoRep = null;

if(radioButtonPreview.Checked)//ラジオボタンでプレビューが選択されている場合

{

//プレビューオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetPreview();

}

else

{

//印刷オブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetReport();

}

＜VB.NET の例＞

'IReport インターフェースで宣言(印刷・レポートどちらでも使える入れ物の用意)

Dim paoRep As IReport = Nothing

If radioButtonPreview.Checked = True Then'ラジオボタンでプレビューが選択されている場合

'プレビューオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetPreview()

Else

'印刷オブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetReport()

End If

勿論、プレビューだけ行いたい場合等は・・・

IReport paoRep = ReportCreator.GetPreview();

Dim paoRep As IReport = ReportCreator.GetPreview()

のようにすることも可能です。


レポート定義ファイル読み込み方法

プログラムから帳票にデータをセットする場合などは、デザイナー等で作成されたレポート定義ファイルをまず読み込みます。

※レポート定義ファイルには、どの座標にどのオブジェクトがある等、帳票の定義がXMLファイル形式で書き込まれております。詳しくは、「レポート定義XMLファイル仕様書」を参照してください。

プログラムからレポート定義ファイルを読み込むには、IReport インタフェースに実装されている LoadDefFile メソッドを使用します。LoadDefFile メソッドの第一引数に読み込むレポート定義ファイルのパスを指定してください。

例題では、相対パスになっておりますが、プログラムがどこで動作するかわからないため、絶対パスを指定することをお勧めします。

＜C#.NET の例＞

//レポート定義ファイルの読み込み

paoRep.LoadDefFile("レポート定義ファイル.xml");

＜VB.NET の例＞

'レポート定義ファイルの読み込み

paoRep.LoadDefFile("レポート定義ファイル.xml")


ページの開始・終了宣言の方法

プログラムから帳票にデータをセットする場合は、レポート定義ファイルを読み込んだ後、ページ毎に、ページの開始宣言及びページの終了宣言をしなければなりません。
ページの開始宣言とページの終了宣言の間で帳票データをセットしますが、デザイナー等で作成されたレポート定義ファイルの内容通り帳票を出力するのであれば、データのセットは不要です。
つまりプログラムからレポート定義体を読み込んで帳票を出力する最小構成は、

  1. 印刷・プレビューインスタンスの生成
  2. レポート定義ファイルの読込
  3. ページの開始宣言
  4. ページの終了宣言
  5. 印刷・プレビューの指示

ということになります。
通常の利用では、「3.ページ開始宣言」と「4.ページ終了宣言」の間に帳票データをセットするロジックが入る事が殆どでしょう。

ページ開始宣言・ページ終了宣言を行うには、
IReport インタフェースに実装されている PageStart / PageEnd メソッドを使用します。
引数はありません。

＜C#.NET の例＞

//頁開始を宣言

paoRep.PageStart();

：

：　　←　Write()・・・印刷データセット処理

：

//頁終了を宣言

paoRep.PageEnd();

＜VB.NET の例＞

'頁開始を宣言

paoRep.PageStart()

：

：　　←　Write()・・・印刷データセット処理

：

'頁終了を宣言

paoRep.PageEnd()


オブジェクトへのデータセット方法(C#.NET)

オブジェクトへのデータセット方法(C#.NET表記)

ここでは、どのようにしてレポート定義ファイルで指定された各オブジェクトに対して値を入れたり、表の横罫線を繰返し描画するのかについてC#.NET表記で述べていきます。
なお、オブジェクトのデータセットは、必ずページの開始宣言(PageStart)とページの終了宣言(PageEnd)の間で行ってください。

プログラムから帳票にデータをセットする場合は、IReport インタフェースに実装されている Write メソッドを使用します。Writeメソッドは、３つのパターンにオーバーロードされています。

  1. void Write(string name, string value)
    オブジェクトに対して文字列をセットします。
    ヘッダやフッタなど繰り返さない固定オブジェクトの値のセットに使用してください。
    string name
        レポート定義ファイル内のオブジェクト名を指定します。
        この場合、文字列をセットするため対象となるオブジェクトのタイプは、
        基本的に　Text(文字列) と、ArtText(装飾文字列)と、Barcode(バーコード) のみとなります。
        オブジェクトを削除したいときに、
        Text(文字列)・ArtText(装飾文字列)以外のオブジェクトを指定します。
    string value
        セットする文字列を指定します。
        Text(文字列) と、ArtText(装飾文字列)以外のオブジェクトに空文字(“”)を指定した場合、
        そのオブジェクトを削除します。

  2. void Write(string name, string value, int index)
    オブジェクトに対して描画位置を指定して文字列をセットします。
    表の行など繰り返し値をセットするオブジェクトに使用してください。
    このパターンのメソッドを使用する場合、レポート定義ファイル内のIntervalX 又は IntervalY に１以上の値が入っている必要があります。
    IntervalX とは、横方向に繰り返す間隔(mm)です。
    IntervalY とは、縦方向に繰り返す間隔(mm)です。主に表の行などに使用されます。
    string name
        レポート定義ファイル内のオブジェクト名を指定します。
        この場合、文字列をセットするため対象となるオブジェクトのタイプは、
        基本的に　Text(文字列) と、ArtText(装飾文字列)と、Barcode(バーコード) のみとなります。
        オブジェクトを削除したいときに、
        Text(文字列)・ArtText(装飾文字列)以外のオブジェクトを指定します。
    string value
        セットする文字列を指定します。
        Text(文字列) と、ArtText(装飾文字列)以外のオブジェクトに空文字(“”)を指定した場合、
        そのオブジェクトを削除します。
    int index
        IntervalX／IntervalYで指定された縦方向・横方向の間隔で描画を行うページ内の描画位置です。左上から右下方向に値が大きくなります。
    例えば、表でIntervalYに値がある場合、描画位置は・・・
    オブジェクトの最初の位置＋InterbalY×(index -1) のようになります。
        表の場合、１行目が１、２行目が２、３行目が３となります。

  3. void Write(string name, int index)
    オブジェクトに対して描画位置を指定します。
    表の行の横罫線など繰り返し描画を行うオブジェクトに使用してください。
    このパターンのメソッドを使用する場合、レポート定義ファイル内のIntervalX 又は IntervalY に１以上の値が入っている必要があります。
    IntervalX とは、横方向に繰り返す間隔(mm)です。
    IntervalY とは、縦方向に繰り返す間隔(mm)です。主に表の行などに使用されます。
    string name
    レポート定義ファイル内のオブジェクト名を指定します。
        この場合、どのオブジェクトでも繰返し描画ができるため対象となるオブジェクトのタイプは、全てのオブジェクトです。
    int index
        IntervalX／IntervalYで指定された縦方向・横方向の間隔で描画を行うページ内の印字位置です。左上から右下方向に値が大きくなります。
    例えば、表でIntervalYに値がある場合、印字位置は・・・
    オブジェクトの最初の位置＋InterbalY×(index -1) のようになります。
        表の場合、１行目が１、２行目が２、３行目が３となります。

＜C#.NETの例＞

int page = 0; //頁数を定義

int line = 0; //行数を定義

for (int i = 0; i < 60; i++)

{

if (i % 15 == 0) //1頁15行で開始

{

//頁開始を宣言

paoRep.PageStart();

page++; //頁数をインクリメント

line = 0; //行数を初期化

//＊＊＊ヘッダのセット＊＊＊

//文字列のセット

paoRep.Write("日付", System.DateTime.Now.ToString());

paoRep.Write("頁数", "Page - " + page.ToString());

}

line++; //行数をインクリメント

//＊＊＊明細のセット＊＊＊

//繰返し文字列のセット

paoRep.Write("行番号", (i+1).ToString() , line);

paoRep.Write("10倍数", ((i+1)*10).ToString() , line);

//繰返し図形(横線)のセット

paoRep.Write("横線", line);

if (((i+1) % 15) == 0) paoRep.PageEnd(); //1頁15行で終了宣言

}


オブジェクトへのデータセット方法(VB.NET)

オブジェクトへのデータセット方法(VB.NET表記)

ここでは、どのようにしてレポート定義ファイルで指定された各オブジェクトに対して値を入れたり、表の横罫線を繰返し描画するのかについてVB.NET表記で述べていきます。
なお、オブジェクトのデータセットは、必ずページの開始宣言(PageStart)とページの終了宣言(PageEnd)の間で行ってください。

プログラムから帳票にデータをセットする場合は、IReport インタフェースに実装されている Write() メソッドを使用します。Write()メソッドは、３つのパターンにオーバーロードされています。

  1. Sub Write(name As String, value As String)
    オブジェクトに対して文字列をセットします。
    ヘッダやフッタなど繰り返さない固定オブジェクトの値のセットに使用してください。
    name As String
        この場合、文字列をセットするため対象となるオブジェクトのタイプは、
        基本的に　Text(文字列) と、ArtText(装飾文字列)と、Barcode(バーコード) のみとなります。
        オブジェクトを削除したいときに、
        Text(文字列)・ArtText(装飾文字列)以外のオブジェクトを指定します。
    value As String
        セットする文字列を指定します。
        Text(文字列) と、ArtText(装飾文字列)以外のオブジェクトに空文字(“”)を指定した場合、
        そのオブジェクトを削除します。

  2. Sub Write(name As String, value As String, index As Long)
    オブジェクトに対して描画位置を指定して文字列をセットします。
    表の行など繰り返し値をセットするオブジェクトに使用してください。
    このパターンのメソッドを使用する場合、レポート定義ファイル内のIntervalX 又は IntervalY に１以上の値が入っている必要があります。
    IntervalX とは、横方向に繰り返す間隔(mm)です。
    IntervalY とは、縦方向に繰り返す間隔(mm)です。主に表の行などに使用されます。
    name As String
        この場合、文字列をセットするため対象となるオブジェクトのタイプは、
        基本的に　Text(文字列) と、ArtText(装飾文字列)と、Barcode(バーコード) のみとなります。
        オブジェクトを削除したいときに、
        Text(文字列)・ArtText(装飾文字列)以外のオブジェクトを指定します。
    value As String
        セットする文字列を指定します。
        Text(文字列) と、ArtText(装飾文字列)以外のオブジェクトに空文字(“”)を指定した場合、
        そのオブジェクトを削除します。
    index As Long
        IntervalX／IntervalYで指定された縦方向・横方向の間隔で描画を行うページ内の描画位置です。左上から右下方向に値が大きくなります。
    例えば、表でIntervalYに値がある場合、描画位置は・・・
    オブジェクトの最初の位置＋InterbalY×(index -1) のようになります。
        表の場合、１行目が１、２行目が２、３行目が３となります。

  3. Sub Write(name As String, index As Long)
    オブジェクトに対して描画位置を指定します。
    表の行の横罫線など繰り返し描画を行うオブジェクトに使用してください。
    このパターンのメソッドを使用する場合、レポート定義ファイル内のIntervalX 又は IntervalY に１以上の値が入っている必要があります。
    IntervalX とは、横方向に繰り返す間隔(mm)です。
    IntervalY とは、縦方向に繰り返す間隔(mm)です。主に表の行などに使用されます。
    name As String
    レポート定義ファイル内のオブジェクト名を指定します。
        この場合、どのオブジェクトでも繰返し描画ができるため対象となるオブジェクトのタイプは、全てのオブジェクトです。
    index As Long
        IntervalX／IntervalYで指定された縦方向・横方向の間隔で描画を行うページ内の印字位置です。左上から右下方向に値が大きくなります。
    例えば、表でIntervalYに値がある場合、印字位置は・・・
    オブジェクトの最初の位置＋InterbalY×(index -1) のようになります。
        表の場合、１行目が１、２行目が２、３行目が３となります。

＜VB.NETの例＞

Dim page As Integer = 0 '頁数を定義

Dim line As Integer = 0 '行数を定義

For i = 1 To 60

If ((i - 1) Mod 15 = 0) Then '1頁15行で開始

'頁開始を宣言

paoRep.PageStart()

page = page + 1 '頁数をインクリメント

line = 0 '行数を初期化

'＊＊＊ヘッダのセット＊＊＊

'文字列のセット

paoRep.Write("日付", System.DateTime.Now.ToString())

paoRep.Write("頁数", "Page - " + page.ToString())

End If

line = line + 1 '行数をインクリメント

'＊＊＊明細のセット＊＊＊

'繰返し文字列のセット

paoRep.Write("行番号", i.ToString(), line)

paoRep.Write("10倍数", (i * 10).ToString(), line)

'繰返し図形(横線)のセット

paoRep.Write("横線", line)

If ((i Mod 15) = 0) Then paoRep.PageEnd() '1頁15行で終了

Next i


印刷・プレビューの指示方法

各帳票のオブジェクトへデータのセットが終わり、最後のページ終了宣言(PageEnd)が終わると、印刷・プレビューを行う事ができます。
プログラムから印刷/プレビューを行うには、IReport インタフェースに実装されている Output メソッドを使用します。引数はありません。

＜C#.NET の例＞

paoRep.Output(); // 印刷/プレビューを実行

＜VB.NET の例＞

paoRep.Output() '印刷/プレビューを実行


印刷データの保存・読み込み方法

Reports.NET では、印刷データをそのままXMLファイルに保存し、それを読み込むことができます。例えば、WEBアプリケーションとクライアントとの通信などで、サーバ側でデータベース検索して帳票を作成し、そのデータをクライアントが受け取るようなことが可能なのです。
印刷データの保存を行えるタイミングは、帳票データをセット後の印刷・プレビュー指示をするときと同じです。印刷・プレビューの前後どちらで行っても構いません。
印刷データの読込は、印刷・プレビューのインスタンスが作成されていれば、いつでも可能です。例えば以下のような手順で読み込んだ印刷データを印刷・プレビューすることができます。

  1. 印刷・プレビューインスタンスの生成
  2. 印刷データファイルの読込
  3. 印刷・プレビューの指示

プログラムから印刷データの保存を行うには、IReport インタフェースに実装されている SaveXMLFile メソッドを使用します。引数はありません。
プログラムから印刷データの読込を行うには、IReport インタフェースに実装されている LoadXMLFile メソッドを使用します。引数はありません。

＜C#.NET の例＞

paoRep.SaveXMLFile("印刷データ.XML"); //印刷データの保存

//プレビューオブジェクトのインスタンスを獲得しなおし(一旦初期化)

paoRep = ReportCreator.GetPreview();

paoRep.LoadXMLFile("印刷データ.XML"); //印刷データの読み込み

paoRep.Output(); // プレビューを実行

＜VB.NET の例＞

paoRep.SaveXMLFile("印刷データファイル.xml") '印刷データの保存

'プレビューオブジェクトのインスタンスを獲得しなおし(一旦初期化)

paoRep = ReportCreator.GetPreview()

paoRep.LoadXMLFile("印刷データファイル.xml") '印刷データの読み込み

paoRep.Output() ' プレビューを実行


圧縮した印刷バイナリデータ取得

Web用

プログラムから圧縮した印刷バイナリデータの取得を行うには、IReport インタフェース に実装されているSaveData メソッドを使用します。引数はありません。
プログラムから圧縮した印刷バイナリデータの読込みを行うには、IReport インタフェース に実装されているLoadData メソッドを使用します。引数は印刷データ（ZIP形式）のファイル名です。


SVG、SVGZ、PDF印刷データの保存

プログラムからSVG形式の印刷データの書き出しを行うには、IReport インタフェース に実装されているSaveSVGFile メソッドを使用します。引数はSVG形式のデータを保存するファイル名(拡張子はhtml)です。
プログラムからSVGZ形式の印刷データの書き出しを行うには、IReport インタフェース に実装されているSaveSVGZFile メソッドを使用します。引数はSVGZ形式のデータを保存するファイル名(拡張子はhtml)です。
プログラムからPDF形式の印刷データの書き出しを行うには、IReport インタフェース に実装されているSavePDF メソッドを使用します。引数は印刷データを保存するファイル名です。


プログラマーズリファレンス

  1. IReport インターフェース
  2. ReportCreator クラス
  3. LoadDefFile メソッド
  4. PageStart メソッド
  5. PageEnd メソッド
  6. Write メソッド
  7. void Write(string name, string value) メソッド
  8. void Write(string name, string value, int index) メソッド
  9. void Write(string name, int index) メソッド
  10. Sub Write(name As String, value As String) メソッド
  11. Sub Write(name As String, value As String, index As Long) メソッド
  12. Sub Write(name As String, index As Long) メソッド
  13. Output メソッド
  14. Output() メソッド
  15. Output(System.Drawing.Printing.PrinterSettings setting) メソッド
  16. SaveXMLFile メソッド
  17. LoadXMLFile メソッド
  18. SaveData メソッド
  19. LoadData メソッド
  20. SaveSVGFile メソッド
  21. SaveSVGZFile メソッド
  22. SavePDF メソッド
  23. DispLayDialog プロパティ
  24. DisplayPrinting プロパティ
  25. AccessFile プロパティ
  26. GetPreview メソッド
  27. GetReport メソッド
  28. GetPdf メソッド
  29. GetImagePdf メソッド


IReportインターフェース

Reports.NET を制御する全てのメソッドを保持しているインターフェースです。
ReportCreator クラスの持つ GetPreview メソッド 及び、GetReport メソッドによりインスタンスを生成することが可能です。プレビュー時には、GetPreview にてインスタンスを生成し、印刷時には、GetReport にてインスタンスを生成してください。

コンストラクタ
引数なし

パブリックメソッド
LoadDefFile | レポート定義ファイルを読み込む
PageStart | ページの開始を宣言する
PageEnd | ページの終了を宣言する
Write | 印刷データを書き込む
Output | 印刷プレビューを指示する
SaveXMLFile | 印刷データファイルを書き出す
LoadXMLFile | 印刷データファイルを読み込む
SaveData | 圧縮した印刷バイナリデータを返す
LoadData | 圧縮した印刷バイナリデータを書き出す
SaveSVGFile | SVG形式の印刷データを書き出す
SaveSVGZFile | SVGZ形式の印刷データを書き出す
SavePDF | PDF形式の印刷データを書き出す

パブリックプロパティ
DisplayDialog | 印刷(Output)時[印刷]ダイアログを表示するかを指定
DisplayPrinting | 印刷中(ページ数)を表示する
AccessFile | プレビュー画面からファイルアクセスを許可する


ReportCreatorクラス

印刷、又は、プレビューを行うオブジェクトを返すメソッドを実装したクラスです。
IReport 型のGetPreview メソッド 及び、GetReport メソッドを内蔵しています。
プレビューを行うときは、GetPreview メソッドを呼び出してください。
印刷を行うときは、GetReport メソッドを呼び出してください。

パブリックメソッド
GetPreview | プレビューを行うオブジェクトを返す
GetReport | 印刷を行うオブジェクトを返す
GetPdf | PDFオブジェクトを返す
GetImagePdf | イメージPDFオブジェクトを返す


LoadDefFileメソッド

レポート定義ファイルを読み込みます。
プログラムがどこで動作するかわからないため、絶対パスを指定することをお勧めします。

＜C#.NET＞
void LoadDefFile(string name)
string name
    レポート定義ファイル名

＜VB.NET＞
Sub LoadDefFile(name As String)
name As String
    レポート定義ファイル名

＜C#.NET の例＞

//レポート定義ファイルの読み込み

paoRep.LoadDefFile("C:\\レポート定義ファイル.xml");

＜VB.NET の例＞

'レポート定義ファイルの読み込み

paoRep.LoadDefFile("C:\レポート定義ファイル.xml")

参照
Ireport インターフェース


PageStartメソッド

ページの開始宣言をします。
ページの開始を宣言後、ページの終了宣言(PageEnd)までの間に、印刷データをセットするコードを入れてください。

＜C#.NET＞
void PageStart()

＜VB.NET＞
Sub PageStart()

＜C#.NET の例＞

//頁開始を宣言

paoRep.PageStart();

：

：　　←　Write()・・・印刷データセット処理

：

//頁終了を宣言

paoRep.PageEnd();

＜VB.NET の例＞

'頁開始を宣言

paoRep.PageStart()

：

：　　←　Write()・・・印刷データセット処理

：

'頁終了を宣言

paoRep.PageEnd()

参照
Ireport インターフェース


PageEndメソッド

ページの終了宣言をします。
ページの開始宣言(PageStart)から、このメソッドの宣言までの間に、印刷データをセットするコードを入れてください。

＜C#.NET＞
void PageEnd()

＜VB.NET＞
Sub PageEnd()

＜C#.NET の例＞

//頁開始を宣言

paoRep.PageStart();

：

：　　←　Write()・・・印刷データセット処理

：

//頁終了を宣言

paoRep.PageEnd();

＜VB.NET の例＞

'頁開始を宣言

paoRep.PageStart()

：

：　　←　Write()・・・印刷データセット処理

：

'頁終了を宣言

paoRep.PageEnd()

参照
Ireport インターフェース


Writeメソッド

レポート定義ファイルで指定されたオブジェクトの操作を行います。
レポート定義ファイルで指定されているオブジェクトに対して文字を書き込んだり、表の横罫線を繰返し描画したりします。

オーバーロードの一覧

＜C#.NET＞

  • void Write(string name, string value)
    オブジェクトに対して文字列をセットします。
    ヘッダやフッタなど繰り返さない固定オブジェクトの値のセットに使用してください。
  • void Write(string name, string value, int index)
    オブジェクトに対して描画位置を指定して文字列をセットします。
    表の行など繰り返し値をセットするオブジェクトに使用してください。
  • void Write(string name, int index)
    オブジェクトに対して描画位置を指定します。
    表の行の横罫線など繰り返し描画を行うオブジェクトに使用してください。

＜VB.NET＞

  • Sub Write(name As String, value As String)
    オブジェクトに対して文字列をセットします。
    ヘッダやフッタなど繰り返さない固定オブジェクトの値のセットに使用してください。
  • Sub Write(name As String, value As String, index As Long)
    オブジェクトに対して描画位置を指定して文字列をセットします。
    表の行など繰り返し値をセットするオブジェクトに使用してください。
  • Sub Write(name As String, index As Long)
    オブジェクトに対して描画位置を指定します。
    表の行の横罫線など繰り返し描画を行うオブジェクトに使用してください。

参照
Ireport インターフェース


void Write(string name, string value)メソッド

オブジェクトに対して文字列をセットします。
ヘッダやフッタなど繰り返さない固定オブジェクトの値のセットに使用してください。
string name
    レポート定義ファイル内のオブジェクト名を指定します。
    この場合、文字列をセットするため対象となるオブジェクトのタイプは、
    基本的に　Text(文字列) と、ArtText(装飾文字列)と、Barcode(バーコード) のみとなります。
    オブジェクトを削除したいときに、Text(文字列)・ArtText(装飾文字列)以外のオブジェクトを指定します。
string value
    セットする文字列を指定します。
    Text(文字列) と、ArtText(装飾文字列)以外のオブジェクトに空文字(“”)を指定した場合、
    そのオブジェクトを削除します。

＜例＞

//文字列のセット

paoRep.Write("日付", System.DateTime.Now.ToString());

参照
Ireport インターフェース


void Write(string name, string value, int index)メソッド

オブジェクトに対して描画位置を指定して文字列をセットします。
表の行など繰り返し値をセットするオブジェクトに使用してください。
このパターンのメソッドを使用する場合、レポート定義ファイル内のIntervalX 又は IntervalY に１以上の値が入っている必要があります。
IntervalX とは、横方向に繰り返す間隔(mm)です。
IntervalY とは、縦方向に繰り返す間隔(mm)です。主に表の行などに使用されます。
string name
    レポート定義ファイル内のオブジェクト名を指定します。
    この場合、文字列をセットするため対象となるオブジェクトのタイプは、
    基本的に　Text(文字列) と、ArtText(装飾文字列)と、Barcode(バーコード) のみとなります。
    オブジェクトを削除したいときに、Text(文字列)・ArtText(装飾文字列)以外のオブジェクトを指定します。
string value
    セットする文字列を指定します。
    Text(文字列) と、ArtText(装飾文字列)以外のオブジェクトに空文字(“”)を指定した場合、
    そのオブジェクトを削除します。
int index
    IntervalX／IntervalYで指定された縦方向・横方向の間隔で描画を行うページ内の描画位置です。左上から右下方向に値が大きくなります。
例えば、表でIntervalYに値がある場合、描画位置は・・・
オブジェクトの最初の位置＋InterbalY×(index -1) のようになります。
    表の場合、１行目が１、２行目が２、３行目が３となります。

＜例＞

//繰返し文字列のセット

paoRep.Write("No.", “1” , 1);

参照
Ireport インターフェース


void Write(string name, int index)メソッド

オブジェクトに対して描画位置を指定します。
表の行の横罫線など繰り返し描画を行うオブジェクトに使用してください。
このパターンのメソッドを使用する場合、レポート定義ファイル内のIntervalX 又は IntervalY に１以上の値が入っている必要があります。
IntervalX とは、横方向に繰り返す間隔(mm)です。
IntervalY とは、縦方向に繰り返す間隔(mm)です。主に表の行などに使用されます。
string name
レポート定義ファイル内のオブジェクト名を指定します。
    この場合、どのオブジェクトでも繰返し描画ができるため対象となるオブジェクトのタイプは、全てのオブジェクトです。
int index
    IntervalX／IntervalYで指定された縦方向・横方向の間隔で描画を行うページ内の印字位置です。左上から右下方向に値が大きくなります。
例えば、表でIntervalYに値がある場合、印字位置は・・・
オブジェクトの最初の位置＋InterbalY×(index -1) のようになります。
    表の場合、１行目が１、２行目が２、３行目が３となります。

＜例＞

//繰返し文字列のセット

paoRep.Write("横線", 1);

参照
Ireport インターフェース


Sub Write(name As String, value As String)メソッド

オブジェクトに対して文字列をセットします。
ヘッダやフッタなど繰り返さない固定オブジェクトの値のセットに使用してください。
name As String
レポート定義ファイル内のオブジェクト名を指定します。
    この場合、文字列をセットするため対象となるオブジェクトのタイプは、
    基本的に　Text(文字列) と、ArtText(装飾文字列)と、Barcode(バーコード) のみとなります。
    オブジェクトを削除したいときに、Text(文字列)・ArtText(装飾文字列)以外のオブジェクトを指定します。
value As String
    セットする文字列を指定します。
    Text(文字列) と、ArtText(装飾文字列)以外のオブジェクトに空文字(“”)を指定した場合、
    そのオブジェクトを削除します。
＜例＞

'文字列のセット

paoRep.Write("日付", System.DateTime.Now.ToString())

参照
Ireport インターフェース


Sub Write(name As String, value As String, index As Long)メソッド

オブジェクトに対して描画位置を指定して文字列をセットします。
表の行など繰り返し値をセットするオブジェクトに使用してください。
このパターンのメソッドを使用する場合、レポート定義ファイル内のIntervalX 又は IntervalY に１以上の値が入っている必要があります。
IntervalX とは、横方向に繰り返す間隔(mm)です。
IntervalY とは、縦方向に繰り返す間隔(mm)です。主に表の行などに使用されます。
name As String
    レポート定義ファイル内のオブジェクト名を指定します。
    この場合、文字列をセットするため対象となるオブジェクトのタイプは、
    基本的に　Text(文字列) と、ArtText(装飾文字列)と、Barcode(バーコード) のみとなります。
    オブジェクトを削除したいときに、Text(文字列)・ArtText(装飾文字列)以外のオブジェクトを指定します。
value As String
    セットする文字列を指定します。
    Text(文字列) と、ArtText(装飾文字列)以外のオブジェクトに空文字(“”)を指定した場合、
    そのオブジェクトを削除します。
index As Long
    IntervalX／IntervalYで指定された縦方向・横方向の間隔で描画を行うページ内の描画位置です。左上から右下方向に値が大きくなります。
例えば、表でIntervalYに値がある場合、描画位置は・・・
オブジェクトの最初の位置＋InterbalY×(index -1) のようになります。
    表の場合、１行目が１、２行目が２、３行目が３となります。

＜例＞

paoRep.Write("No.", “1”, 1)

参照
Ireport インターフェース


Sub Write(name As String, index As Long)メソッド

オブジェクトに対して描画位置を指定します。
表の行の横罫線など繰り返し描画を行うオブジェクトに使用してください。
このパターンのメソッドを使用する場合、レポート定義ファイル内のIntervalX 又は IntervalY に１以上の値が入っている必要があります。
IntervalX とは、横方向に繰り返す間隔(mm)です。
IntervalY とは、縦方向に繰り返す間隔(mm)です。主に表の行などに使用されます。
name As String
レポート定義ファイル内のオブジェクト名を指定します。
    この場合、どのオブジェクトでも繰返し描画ができるため対象となるオブジェクトのタイプは、全てのオブジェクトです。
index As Long
    IntervalX／IntervalYで指定された縦方向・横方向の間隔で描画を行うページ内の印字位置です。左上から右下方向に値が大きくなります。
例えば、表でIntervalYに値がある場合、印字位置は・・・
オブジェクトの最初の位置＋InterbalY×(index -1) のようになります。
    表の場合、１行目が１、２行目が２、３行目が３となります。

＜例＞

paoRep.Write("横線", 1)

参照
Ireport インターフェース


Outputメソッド

レポート(帳票)のプリンターへの印刷、又は、プレビュー画面の表示を行います。

オーバーロードの一覧

＜C#.NET＞

  • bool Output()
    デフォルトのプリンタへデフォルトの設定で印刷／プレビュー指示を行います。
  • bool Output(PrinterSettings setting)
    引数で指定したプリンタの設定で印刷／プレビュー指示を行います。

＜VB.NET＞

  • Function Output() As Boolean
    デフォルトのプリンタへデフォルトの設定で印刷／プレビュー指示を行います。
  • Function Output(setting As PrinterSettings) As Boolean
    引数で指定したプリンタの設定で印刷／プレビュー指示を行います。

参照
Ireport インターフェース


新規ﾍﾟｰｼﾞ

Output()メソッド

デフォルトのプリンタへデフォルトの設定で印刷／プレビュー指示を行います。

＜C#.NET＞
bool Output()

＜VB.NET＞
Function Output() As Boolean

＜C#.NET の例＞

paoRep.Output(); // 印刷/プレビューを実行

＜VB.NET の例＞

paoRep.Output() '印刷/プレビューを実行

参照
Ireport インターフェース Output メソッド


Output(PrinterSettings setting)メソッド

Output(System.Drawing.Printing.PrinterSettings setting) メソッド

引数で指定したプリンタの設定で印刷／プレビュー指示を行います。

＜C#.NET＞
bool Output(System.Drawing.Printing.PrinterSettings setting)

＜VB.NET＞
Function Output(setting As System.Drawing.Printing.PrinterSettings) As Boolean

＜C#.NET の例＞

System.Drawing.Printing.PrinterSettings setting

= new System.Drawing.Printing.PrinterSettings();

setting.PrinterName = “プリンター名”;

paoRep.Output(setting); // 印刷/プレビューを実行

＜VB.NET の例＞

Dim setting As System.Drawing.Printing.PageSettings

= New System.Drawing.Printing.PageSettings()

setting.PrinterName = “プリンター名”

paoRep.Output(setting) '印刷/プレビューを実行

参照
Ireport インターフェース Output メソッド


SaveXMLFileメソッド

印刷データをXMLファイルに保存します。
保存した印刷データは、プログラム(LoadXMLFile)、又は、プレビュー画面から読み込むことが可能です。

＜C#.NET＞
bool SaveXMLFIle(string name)
string name
    保存する印刷データXMLファイルパス名

＜VB.NET＞
SaveXMLFIle(name As String) As Boolean
name As String
    保存する印刷データXMLファイルパス名

＜C#.NET の例＞

paoRep.SaveXMLFile("印刷データ.XML"); //印刷データの保存

＜VB.NET の例＞

paoRep.SaveXMLFile("印刷データファイル.xml") '印刷データの保存

参照
Ireport インターフェース


LoadXMLFileメソッド

SaveXMLFile で保存された、印刷データXMLファイルを読み込みます。
読み込んだ印刷データは、印刷又はプレビュー(Output)することが可能です。

＜C#.NET＞
bool LoadXMLFIle(string name)
string name
    読み込む印刷データXMLファイルパス名

＜VB.NET＞
LoadXMLFIle(name As String) As Boolean
name As String
    読み込む印刷データXMLファイルパス名

＜C#.NET の例＞

paoRep.LoadXMLFile("印刷データ.XML"); //印刷データの読込

＜VB.NET の例＞

paoRep.LoadXMLFile("印刷データファイル.xml") '印刷データの読込

参照
Ireport インターフェース


SaveData メソッド

圧縮した印刷バイナリデータを返します。

WEBサービス側で、リッチクライアントに返す印刷データを作成する時に使用します。

＜C#.NET＞

byte[] SaveData()

＜VB.NET＞

SaveData() As Byte()

＜C#.NET の例＞

byte[]
b = paoRep.
SaveData();
//
圧縮した印刷バイナリデータを返す

＜VB.NET の例＞

Dim b As Byte() = paoRep. SaveData ' 圧縮した印刷バイナリデータを返す

参照
Ireport インターフェース


LoadData メソッド

SaveData で作成された圧縮した印刷バイナリデータを読み込みます。

リッチクライアントで、WEBサービス側で作成された印刷データを読み込む時に使用します。

＜C#.NET＞

bool LoadData(string name)

string name

    読み込む印刷データXMLファイルパス名

＜VB.NET＞

LoadData(name As String) As Boolean

name As String

    読み込む印刷データXMLファイルパス名

＜C#.NET の例＞

byte[] data = webService.getPrintData();

IReport
paoRep = ReportCreator.GetPreview()
//
プレビューオブジェクトを作成paoRep.LoadData(data);
//
圧縮した印刷バイナリデータの読込

paoRep.Output(); //プレビュー

＜VB.NET の例＞

Dim data As Byte() = webTest.get帳票データ() '印刷データを取得

Dim paoRep As IReport = ReportCreator.GetPreview() ' プレビューオブジェクトを作成

paoRep.LoadData(data) '印刷データを読み込む

paoRep.Output() 'プレビューを実行

参照
Ireport インターフェース


SaveSVGFile メソッド

SVG形式の印刷データを書き出します。

＜C#.NET＞

bool SaveSVGFile(string name)

string name

    書き出す印刷データhtmlファイルパス名

    SVGファイルは、ページ数分作成されるため、

それを読み込むhtmlファイルの名前を指定します。

＜VB.NET＞

SaveSVGFile(name As String) As Boolean

name As String

    書き出す印刷データSVGファイルパス名

    SVGファイルは、ページ数分作成されるため、

それを読み込むhtmlファイルの名前を指定します。

＜C#.NET の例＞

paoRep.SaveSVGFile("印刷データ.html"); //SVGデータの書出

＜VB.NET の例＞

paoRep. SaveSVGFile("印刷データファイル.html") 'SVGデータの書出

参照
Ireport インターフェース


SaveSVGZFile メソッド

SVGZ形式の印刷データを書き出します。

＜C#.NET＞

bool SaveSVGZFile(string name)

string name

    書き出す印刷データhtmlファイルパス名

    SVGZファイルは、ページ数分作成されるため、

それを読み込むhtmlファイルの名前を指定します。

＜VB.NET＞

SaveSVGZFile(name As String) As Boolean

name As String

    書き出す印刷データSVGZファイルパス名

    SVGZファイルは、ページ数分作成されるため、

それを読み込むhtmlファイルの名前を指定します。

＜C#.NET の例＞

paoRep.SaveSVGZFile("印刷データ.html"); //SVGZデータの書出

＜VB.NET の例＞

paoRep.SaveSVGZFile("印刷データファイル.html") 'SVGZデータの書出

参照
Ireport インターフェース


SavePDF メソッド

PDF形式の印刷データを書き出します。

＜C#.NET＞

bool SavePDF (string name)

string name

    書き出す印刷データPDFファイルパス名

＜VB.NET＞

SavePDF (name As String) As Boolean

name As String

    書き出す印刷データPDFファイルパス名

＜C#.NET の例＞

paoRep.SavePDF("印刷データ.PDF"); //PDFデータの書出

＜VB.NET の例＞

paoRep.SavePDF("印刷データファイル.pdf") 'PDFデータの書出

参照
Ireport インターフェース


DispLayDaialogプロパティ

Output メソッド で印刷を行うときに、[印刷]ダイアログボックスを表示するかどうかを指定します。デフォルトは、true: 表示します。このプロパティは、印刷時のみ有効で、プレビュー表示時に指定されても意味を持ちません。
ちません。

＜C#.NET＞
bool DispLayDialog
  true : 印刷時に[印刷]ダイアログボックスを表示(既定値)
  false : 印刷時に[印刷]ダイアログボックスを表示しない

＜VB.NET＞
DispLayDialog As Boolean
  True : 印刷時に[印刷]ダイアログボックスを表示(既定値)
  False : 印刷時に[印刷]ダイアログボックスを表示しない

＜C#.NET の例＞

paoRep.DispLayDialog = false; //[印刷]ダイアログを表示しない

paoRep.Output(); //印刷

＜VB.NET の例＞

paoRep.DispLayDialog = False ‘[印刷]ダイアログを表示しない

paoRep.Output() ‘印刷

参照
Ireport インターフェース


DisplayPrinting プロパティ

Output メソッド で印刷を行うときに、印刷中(ページ数)を表示するかどうかを指定します。デフォルトは、true: 表示します。このプロパティは、印刷時のみ有効で、プレビュー表示時に指定されても意味を持ちません。

＜C#.NET＞

bool DisplayPrinting

  true : 印刷時に印刷中(ページ数)を表示(既定値)

  false : 印刷時に印刷中(ページ数)を表示しない

＜VB.NET＞

DisplayPrinting As Boolean

  True : 印刷時に印刷中(ページ数)を表示(既定値)

  False : 印刷時に印刷中(ページ数)を表示しない

＜C#.NET の例＞

paoRep.DisplayPrinting = false; //印刷中(ページ数)を表示しない

paoRep.Output(); //印刷

＜VB.NET の例＞

paoRep.DisplayPrinting = False ‘印刷中(ページ数)を表示しない

paoRep.Output() ‘印刷

参照
Ireport インターフェース


AccessFile プロパティ

Output メソッド で印刷を行うときに、プレビュー画面からファイルアクセス（ファイル保存等）を許可するかどうかを指定します。デフォルトは、true: 表示します。

＜C#.NET＞

bool AccessFile

  true : 印刷時にプレビュー画面からファイルアクセスを許可する(既定値)

  false : 印刷時にプレビュー画面からファイルアクセスを許可しない

＜VB.NET＞

AccessFile As Boolean

  True : 印刷時にプレビュー画面からファイルアクセスを許可する(既定値)

  False : 印刷時にプレビュー画面からファイルアクセスを許可しない

＜C#.NET の例＞

paoRep.AccessFile = false; //プレビュー画面からファイルアクセスを許可しない

＜VB.NET の例＞

paoRep. AccessFile = False ‘プレビュー画面からファイルアクセスを許可しない

参照
Ireport インターフェース


GetPreviewメソッド

プレビューを制御するオブジェクトを返すメソッドです。
直接印刷するときは、GetReport メソッドを使用してください。

＜C#.NET＞
IReport GetPreview()

＜VB.NET＞
Function GetPreview() As IReport

＜C#.NET の例＞

//プレビューオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetPreview();

＜VB.NET の例＞

'プレビューオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetPreview()

参照
 ReportsCreator クラス


GetReportメソッド

印刷を制御するオブジェクトを返すメソッドです。
プレビューを行うときは、GetPreview メソッドを使用してください。

＜C#.NET＞
IReport GetReport()

＜VB.NET＞
Function GetReport() As IReport

＜C#.NET の例＞

//印刷オブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetReport();

＜VB.NET の例＞

'印刷オブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetReport()

参照
 ReportsCreator クラス


GetPdf メソッド

PDFオブジェクトを返すメソッドです。

＜C#.NET＞

IReport GetPdf()

＜VB.NET＞

Function GetPdf() As IReport

＜C#.NET の例＞

// PDFオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetPdf();

＜VB.NET の例＞

' PDFオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetPdf()

参照
 ReportsCreator クラス


GetImagePdf メソッド

イメージPDFオブジェクトを返すメソッドです。

＜C#.NET＞

IReport GetImagePdf()

＜VB.NET＞

Function GetImagePdf () As IReport

＜C#.NET の例＞

//イメージPDFオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetImagePdf ();

＜VB.NET の例＞

'イメージPDFオブジェクトのインスタンスを獲得

paoRep = ReportCreator.GetImagePdf ()

参照
 ReportsCreator クラス


変更履歴
版 | 作成日 | 変更点
1 | 2003.05.25 | 新規作成
2 | 2003.06.10 | QRコード、Webサービス、PDF対応
3 | 2006.08.05 | ZIP・SVG・SVGZ対応 プロパティ追加（プリントダイアログetc）
4 | 2007.03.02 | Writeメソッドのvalue に空文字を指定した場合、 オブジェクトを削除できる機能の説明を追加