セットアップ

動作環境

  • Windows XP, Windows 2000
  • .NET Framework1.1 がインストールされていること。

セットアップ手順

  1. CD-ROMのSetup.exeを起動し、セットアップを開始します。
  2. セットアップでの画面指示に従い、インストールしてください。
  3. 「ダウンロードリストエディタ」を起動すると、下記のライセンス登録画面が表示されます。別途入手した製品ライセンスキーを登録してください。

「評価モード」として３０日間使用可能です。「評価モード」で作成したダウンロードリストは、使用期限をすぎると運用できない仕様になっています。本運用に使用する場合は、必ずライセンス登録後に作成したものを使用してください。

セットアップ後のファイル構造

  • LcmEditor.exe　 ：　ダウンロードリストエディタの実行モジュール
  • Manual.chm ：　ヘルプドキュメントファイル
  • ライセンス.rtf ：　ライセンス許諾書ファイル
  • PAT\LcmEditor.def ：　ダウンロードリストエディタのパラメータファイル
  • Sample\Sample.exe ：　サンプルシステムの自己解凍ファイル
  • ClientManager\ ：　「LLL/.net クライアントマネージャ」のインストールモジュール

アンインストール

  1. 「コントロールパネル」の「プログラムの追加と削除」から、LLL/.net デプロイメントツールを削除して下さい。
    （注意）アンインストール途中で、「不正なコマンドライン　パラメータです。」とダイアログ表示されることがありますが、[OK]ボタンで継続して下さい。
  2. その後、LLL/.netデプロイメントツールのインストールディレクトリを全て削除して下さい。


デプロイメントツールの概要

  デプロイメントツールは、Webサーバーに配置したプログラムファイル等を、インターネットを経由してクライアントＰＣに配布します。スタンドアロン、クライアントサーバー、スマートクライアント型の各システムの配布が可能です。基本的に「LLL/.net開発キット」に含まれるプログラム配布機能と同じです。

    プログラム配布を実施するには、Webサーバーに配布対象ファイルとダウンロードリストを配置する必要があります。ダウンロードリストの作成には、「ダウンロードリストエディタ」を使用し、配布システムの全体情報と配布ファイルのリストを登録します。そしてダウンロードリストのリンクをホームページに公開しておきます。

    Webサーバーに配置した配布システムをクライアントＰＣにダウンロードする方法は３つあります。（１）ホームページのリンクからシステム登録する方法、（２）「クライアントマネージャ」のメニュー操作による方法、（３）「クライアントマネージャ」のコマンドライン引数による方法です。いずれの場合も、クライアントＰＣには「LLL/.net クライアントマネージャー」をインストールしておく必要があります。Ｗｅｂサーバから取得したダウンロードリストの内容に従って、「クライアントマネージャー」がシステム登録を実施します。

   クライアントＰＣでのシステム登録が完了すると、デスクトップにシステム起動用のアイコンが作成されます。このアイコンをクリックすると、まずWebサーバーに配布対象ファイルに変更がないかチェックします。変更があればWebサーバーからクライアントＰＣにダウンロードします。その後、システムの開始プログラムを実行します。つまり、システム起動時に自動的にシステムを最新状態にアップデートした後に開始プログラムが実行します。

    配布システムがオフライン実行可能な設定で、インターネット接続状態でない場合は、オフライン状態で開始プログラムを実行することも可能です。

デプロイメントツールの詳細については下記の説明を参照して下さい。

（１）ダウンロードリストの作成

（２）Webサーバーの設定

（３）クライアントＰＣの設定

（４）サンプルシステムの配布手順

【変更履歴】

バージョン1.60

◎「LLL/.netデプロイメントツール」の最初のバージョンです。（バージョン番号はLLL/.net開発キットと同期）


ダウンロードリストエディタ

   ダウンロードリストエディタは、デプロイメントツールで使用するダウンロードリストを編集します。ダウンロードリストは拡張子に”.lcm”をもつファイルで、配布システムの全体情報と配布ファイルのリストが登録されます。ダウンロードリストはひとつの配布システムに、必要に応じて複数作成することが可能です。

ダウンロードリストエディタの操作方法は下記の画面説明を参照して下さい。

  • エディタのメイン画面
  • メニュー・ツールバー
  • 配布対象ファイルのプロパティ
  • 代用拡張子の設定


エディタのメイン画面

  ダウンロードリストの全体情報と配布ファイルの明細を設定する編集画面です。ダウンロードリストは、拡張子=.lcm　のファイルとして作成されます。

  ダウンロードリストを新規に作成する場合、配布ディレクトリにあるファイルが配布対象ファイルとして初期表示されます。これは、"PAT\LcmEditor.DEF"ファイルの[Files]セクションに登録されたファイルが対象です。また、配布ディレクトリが「LLL/.net 開発キット」の開発ディレクトリの場合、フォルダー名、ユーザ名、システム名、実行ファイルのプログラム名などが初期表示されます。

項目 | 説明
システム登録情報 |
配布ディレクトリ | 配布対象のディレクトリを表示します。
ダウンロードリスト名 | 編集中のダウンロードリスト名を表示します。
URLアドレス | ホームページのリンクからシステム登録する場合、ダウンロードリストへのディレクトリパスをURLアドレス形式で設定しておく必要があります。
フォルダー名 | システム登録するフォルダー名。「LLL/.netクライアントマネージャ」のシステム保存ディレクトリのサブディレクトリとして使用されます。省略時は、システム名が代用されます。
ユーザ名 | システムのユーザ名。
システム名 | システムのシステム名。デスクトップアイコン名に使用されます。必須設定項目です。
デスクトップアイコン | クライアントPCのデスクトップに作成するアイコンファイルを設定します。アイコンファイルは、配布対象ファイルとして登録されている必要があります。
開始プログラム | システム起動時に開始するプログラムファイルを設定します。プログラムファイルは、配布対象ファイルとして登録されている必要があります。
オフライン実行可能 | チェック状態にすると、システム起動時にインターネットに接続できなくても、開始プログラムを起動します。
配布対象ファイルの明細 |
配布対象ファイル名 | 配布対象ファイルのファイル名です。配布ディレクトリ下のサブディレクトリのファイルも含むことができます。
説明 | プロパティで設定したコメントを表示します。
オプション | プロパティで設定したオプションを表示します。上書き禁止モードなど


メニューとツールバー

  ダウンロードリストエディタのメニューとツールバーコマンドの操作説明です。

メニュー・ツールバー | 説明
ディレクトリ選択 | ディレクトリ選択ダイアログから配布対象のディレクトリを選択します。選択したディレクトリにダウンロードリストが存在する場合、自動的にオープンされます。
ダウンロードリストを新規作成 | 新規作成するダウンロードリスト名をダイアログから入力します。デフォルトとして "download(n).lcm" が設定されます。nは１～９
ダウンロードリストを開く | 作成済みのダウンロードリストをダイアログから選択しオープンします。
ダウンロードリストを保存 | 編集中のダウンロードリストを保存します。
終了 | エディタを終了します。
配布ファイル追加 | 配布対象ファイルをファイルオープンダイアログから選択します。選択したファイルは配布対象ファイルの明細に追加されます。
配布ファイル取消 | 選択中の配布対象ファイルを明細から削除します。
配布ファイルプロパティ | 「配布対象ファイルのプロパティ」を表示します。
アイテムを上移動 | 選択中の配布対象ファイルの明細順番を上移動
アイテムを下移動 | 選択中の配布対象ファイルの明細順番を下移動
代用拡張子の設定 | 「代用拡張子の設定」を表示します。
ヘルプ・ドキュメント | ヘルプドキュメントを表示。
ヘルプ・バージョン | バージョン情報の表示。


配布対象ファイルのプロパティ

配布対象ファイルのコメントやオプションを設定する画面です。

項目 | 説明
配布対象ファイル | クライアントに配布するファイル。
説明 | 配布対象ファイルのコメント。(省略可能)
ファイルの上書き禁止 | クライアントにファイルが存在する場合、ファイルの上書きを禁止します。
[登録] | 登録。
[取消]] | 取消。


代用拡張子の設定

    配布対象ファイルがＷｅｂサーバーでスクリプトファイル等と判断される場合、正常にファイルを配布することができません。 このようなファイルを配布する場合、拡張子を変更した代用ファイルを複写作成することで配布することができます。 配布された代用ファイルはクライアント側で元の拡張子ファイル名に戻されます。 この機能を使用する場合、この画面で代用ファイルの拡張子とスクリプトファイル等の拡張子をそれぞれ設定する必要があります。

  ダウンロードリスト保存時に該当する拡張子の配布ファイルが存在する場合、自動的に代用ファイルが作成されます。 代用ファイル名は、(ファイル名)_(拡張子).(代用拡張子)　となります。　（例：abcdef.asp ---> abcdef_asp.lsub）

  注意事項として、代用ファイルのオリジナルの配布ファイルを変更したときは、必ずダウンロードリストの保存を実施し、代用ファイルも更新する必要があります。

項目 | 説明
代用拡張子 | ファイル配布に使用する代用拡張子を設定します。空白にすると代用ファイルによるプログラム配布をしません。
代用拡張子を使用する拡張子 | スクリプトファイルなどの拡張子をカンマ(,)で区切って設定します。
[登録] | 登録。
[取消]] | 取消。


Webサーバーの設定

配布システムの設定。

  1. 配布システム用の公開ディレクトリを作成します。
  2. 公開ディレクトリにダウンロードリストと配布対象ファイルを配置します。
  3. ホームページにて、ダウンロードリストへのリンクを公開します。

ＩＩＳの設定

  • 公開ディレクトリの「実行アクセス権」を「スクリプトのみ」に設定してください。
  • 「スクリプトおよび実行可能ファイル」と設定した場合、プログラム配布でエラーが発生します。どうしても「スクリプトおよび実行可能ファイル」に設定する必要がある場合は、プログラム配布用の公開ディレクトリを別途作成して運用する必要があります。
  • 詳細についてはIISのマニュアルを参照してください。

【制限事項】

  • 配布対象ファイルの拡張子により正常に配布できないファイルが存在します。この場合は、ダウンロードリストエディタの代用拡張子の設定を使用して下さい。（初期設定の拡張子は、asp, aspx, asax, asmx, config, resx, vbproj, csproj, vb, cs）
  • 配布対象ファイルがBINサブディレクトリにある場合、正常に配布できません。この場合、配布元のディレクトリ名 "BIN" を "BIN_代用拡張子"（例:BIN_lsub） に変更して設定して下さい。配布先では自動的にBINディレクトリとして格納します。

IIS6.0以降の設定

  ＩＩＳ6.0以降は、MIMEタイプが設定されていないファイルのダウンロードができなくなり、そのままではプログラム配布時にエラーメッセージが表示されます。これを回避するには、以下の手順でMIMEタイプを設定してください。

  1. 「インターネットインフォメーションサービス(IIS) マネージャ」を起動します。
  2. 「インターネットインフォメーションサービス」配下の「ローカルコンピュータ」の「Web サイト」の「既定のWeb サイト」から公開ディレクトリを選択しプロパティ画面を起動します。
  3. プロパティ画面の[HTTP ヘッダー]タブの[MIME の種類]ボタンをクリックします。
  4. MIME の種類画面で、以下のMIME タイプを追加します。
    • 拡張子：lcm MIMEタイプ：application/lllnet
    • 拡張子：lsub MIMEタイプ：application/lllnet
    • 拡張子：def MIMEタイプ：application/lllnet
    • 拡張子：crf MIMEタイプ：application/lllnet
    • プログラム配布するファイルにMIMEタイプの設定のない拡張子のファイルが含まれる場合は追加して下さい。(拡張子：xxx MIMEタイプ：application/xxxx)


クライアントＰＣの設定

クライアントＰＣには、「LLL/.netクライアントマネージャ」（以下「クライアントマネージャ」）がインストールされている必要があります。クライアントＰＣに 「クライアントマネージャー」をインストールすると、ダウンロードリストの拡張子（.lcm)と関連付けされ、クライアントＰＣでのシステム登録が可能になります。

（１）「クライアントマネージャー」のセットアップ

クライアントＰＣに必要な動作環境

  • Windows XP, Windows 2000
  • .NET Framework1.1 がインストールされ、正常に動作するクライアント。

  セットアップ手順には以下の２つの方法があります。

  • 「クライアントマネージャー」のインストーラ "ClientManager\Setup.exe" を実行する方法。
  • ホームページのリンクからセットアップする方法。
        Webサーバーのホームページにて、「クライアントマネージャー」のセットアップモジュール（ClientManager\LClientManager.msi）へのリンクを公開しておきます。クライアントＰＣでこのリンクをクリックすると、下記ダイアログが表示されます。このダイアログの[開く]をクリックすると、セットアップが開始されます。

（２）クライアントＰＣでのシステム登録手順

WebサーバーからクライアントＰＣにシステム登録するには以下の方法があります。

  1. ホームページのリンクからシステム登録する方法。
  2. 「クライアントマネージャ」のメニュー操作によるシステム登録。
  3. 「クライアントマネージャ」のコマンドライン起動によるシステム登録。

   クライアントＰＣでのシステム登録が完了すると、デスクトップにシステム起動用のアイコンが作成されます。デスクトップアイコンを作成しない場合は、「クライアントマネージャ」のコマンドライン起動によるシステム起動も可能です。

商品の仕様は予告なく変更になることがあります。


ホームページによるシステム登録

１．ホームページによるシステム登録

    ホームページに作成したダウンロードリストへのリンクからシステム登録する方法を説明します。

（１）ダウンロードリストのリンクをクリックすると、下記ダイアログが表示されます。このダイアログの[開く]をクリックします。

（２）Webサーバーのアクセスに認証情報が必要な場合、認証情報ダイアログが表示されます。適切な認証情報を入力して下さい。[パスワードを記憶する]をチェックすると次回からは自動的に認証します。

（３）ダウンロードリストに関連付けされた「クライアントマネージャ」が起動します。「クライアントマネージャ」はダウンロードリストのフォルダーを確認します。フォルダーを新規作成する場合は、下記メッセージが表示されます。このダイアログの[OK]をクリックします。

（４）ダウンロードリストの設定に従い、下記手順でシステム登録されます。

  1. 配布ファイルのダウンロード。
  2. デスクトップアイコンの作成。
  3. 開始プログラムの起動。

（注意）クライアントＰＣの環境によっては、うまく動作しないことも考えれます。この場合は、「クライアントマネージャー」の操作でシステム登録してください。

商品の仕様は予告なく変更になることがあります。


メニュー操作によるシステム登録

２．メニュー操作によるシステム登録

「クライアントマネージャー」のメニュー操作でシステム登録する方法を説明します。

（１）メイン画面のメニューから[ファイル][システム登録]を選択すると、登録システムのURL入力画面が表示されます。Webサーバーのダウンロードリスト へのURLアドレスを入力して、[OK]ボタンをクリックします。

（２）Webサーバーのアクセスに認証情報が必要な場合、認証情報ダイアログが表示されます。適切な認証情報を入力して下さい。[パスワードを記憶する]をチェックすると次回からは自動的に認証します。

（３）ダウンロードリストが正常に取得できた場合、ダウンロードリストのフォルダーを確認します。フォルダーを新規作成する場合は、下記メッセージが表示されます。このダイアログの[OK]をクリックします。

[OK]をクリックすると、ダウンロードリストの設定に従い、下記手順でシステム登録します。

  • 配布ファイルのダウンロード。
  • デスクトップアイコンの作成。

（４）システム登録が完了すると、下記画面が表示されます。

商品の仕様は予告なく変更になることがあります。


コマンドライン起動によるシステム登録

３．コマンドライン起動によるシステム登録

    「クライアントマネージャ」のコマンドライン起動によるシステム登録を説明します。

（１）ダウンロードリストのURLアドレスを引数にして起動すると、システム未登録の場合にシステム登録されます。

例： （プログラムディレクトリ）\LClientManager.exe http://www.xxxxxx.co.jp/sample/download1.lcm

（２）Webサーバーのアクセスに認証情報が必要な場合、認証情報ダイアログが表示されます。適切な認証情報を入力して下さい。[パスワードを記憶する]をチェックすると次回からは自動的に認証します。

（３）ダウンロードリストが正常に取得できると、保存先のフォルダーを作成の為、下記メッセージが表示されます。このダイアログの[OK]をクリックします。

（４）ダウンロードリストの設定に従い、下記手順でシステム登録されます。

  1. 配布ファイルのダウンロード。
  2. デスクトップアイコンの作成。
  3. 開始プログラムの起動。

（５）登録済みシステムをコマンドライン起動するには、以下の２つの方法があります。この方法によりデスクトップアイコンを使用しないシステム起動が可能になります。

  1. ダウンロードリストのURLアドレスを引数にする。システム未登録の場合にはシステム登録されます。
    例：　（プログラムディレクトリ）\LClientManager.exe http://www.xxxxxx.co.jp/sample/download1.lcm
  2. ダウンロードリストのフォルダー名を引数にする。システム未登録の場合エラーになります。
    例： （プログラムディレクトリ）\LClientManager.exe サンプル

商品の仕様は予告なく変更になることがあります。


サンプルシステムの配布手順

添付のサンプルシステムの配布手順を説明します。

サンプルシステムは、「LLL/.net 開発キット」 で作成した簡単な販売管理システムです。スタンドアロンで実行可能です。

Ｗebサーバーの準備

  1. SampleディレクトリのSample.exeを実行し、サンプルシステムを解凍してください。
  2. 「クライアントマネージャ」のインストールモジュール（ClientManager\LClientSetup.msi）をSampleディレクトリに複写して下さい。
  3. 「ダウンロードリストエディタ」を起動してSampleディレクトリを選択し、ダウンロードリストの「URLアドレス」にWebサーバーのSampleディレクトリへのURLを設定して保存してください。
  4. 「Webサーバーの設定」を参考にして、SampleディレクトリをWeb公開してください。

クライアントPCの操作手順

（１）WebブラウザでサンプルシステムのSample.htmをオープン。

（２）クライアントＰＣに 「LLL/.netクライアントマネージャー」 をインストール。

  • （１）「LLL/.netクライアントマネージャー」をクリックして下さい。
  • 下図ダイアログが表示されます。[開く]をクリックして下さい。

  • 「クライアントマネージャー」のセットアップが開始されます。ウィザード手順に従ってインストールしてください。

（３）クライアントPCに 「サンプルシステム」 をインストール。

  • （２）サンプルシステムの配布をクリックしてください。
  • 下図ダイアログが表示されます。[開く]をクリックして下さい。

  • 下図ダイアログが表示されます。 [OK]をクリックしてください。

  • 正常にダウンロードされると、配布システムの開始プログラムが実行されます。（サンプルの場合メニューが表示されます。）

  • ＰＣのデスクトップに起動用アイコンが作成されます。次回以降、配布システムを実行する場合は、このアイコンをクリックしてください。
  • 起動用アイコンをクリックすると、Webサーバーに配布システムのプログラム変更がないかチェックし、変更があればダウンロードした後で、開始プログラムが実行されます。

もし、ダウンロードが正常にできない場合は以下のことを確認してください

  • 「LLL/.net クライアントマネージャー」が正常にインストールされているか確認。
  • 「インターネットオプション」から「インターネット一時ファイル」を削除。

（４）セットアップした配布システムを削除する手順

  1. [コントロールパネル][プログラムの追加と削除]から　「LLL/.net クライアントマネージャー」を削除。
  2. ディレクトリ（「Program Files」-「LLLnet ClientManager」）を削除。